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House Design
Tutorial

This House Design Tutorial shows you how to get started on a design project. The tutorials that 
follow continue with the same plan. When you are finished, you will have created a sample 
plan named “Stucco Beach House.” You can then apply the tools and techniques learned to 
your own plans.

 In this tutorial you will learn about:
•      Before You Begin
•      Getting Started
•      Setting Defaults
•      Drawing Walls
•      Creating Dimension Lines
•      Adjusting Wall Positions

•      Creating Rooms
•      Creating a 3D View
•      Adding Floors
•      Adding Stairs
•      Placing Doors and Windows
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Before You Begin
Chief Architect may look differently on your screen than it does in the following tutorials. 

• Screen captures are taken from a smaller window to optimize image quality, so the size and 
proportion of your interface may be different.

• Some features, such as the Reference Grid, have been turned off to optimize image quality. 
For more information, see “General Plan Defaults Dialog” on page 90 of the Reference 
Manual.

• Since toolbars can be customized, their default layout and location may differ. For more 
information, see “Toolbar Customization Dialog” on page 137 of the Reference Manual.

• As the program is updated, features may be added or removed. If you are using the latest 
version of Chief Architect, you may see buttons and/or menu items that have been added or 
removed since this tutorial was written. For more information, see “Program Updates” on 
page 17.

• Depending on your operating system and system settings, dialogs and toolbars may appear 
differently than they do in the tutorials.

Getting Started
Begin by opening a new, blank plan.

To begin a new plan
1. When Chief Architect launches, the Getting Started dialog displays. For more 

information, see “Startup Options” on page 30 of the Reference Manual.

• Select New Plan  to open a new, blank plan.

• You can also select File> New Plan  to open a new, blank plan.
• For more information, see “File Management” on page 53 of the Reference Manual.

2. You should begin work on any new file by giving it a name. To do this: 

• Select File> Save  from the menu to open the Save Plan File dialog.
• Specify the location on your computer where you would like to save the plan.
• Type a name for your plan.
• Click Save.

3. It is a good idea to save your work on a regular basis as you proceed. To do this, you can:

• Select File> Save  from the menu to open the Save Plan File dialog

• Click the Save  button on the toolbar.
• Type Ctrl + S on your keyboard.
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For more information about saving files, see “Saving, Exporting, and Backing Up Files” on 
page 57 of the Reference Manual.

Setting Defaults
Default settings determine the initial characteristics of objects when they are first drawn. When 
set up in advance, they can help you both save time and avoid mistakes. Before you draw walls 
and create rooms, therefore, you should always make sure the defaults will meet your needs for 
the current project. For more information about defaults, see “Preferences and Default 
Settings” on page 75 of the Reference Manual.

While all defaults are important, there are several that can be considered critical because they 
help determine the size and structural characteristics of the building. These critical defaults are:

• Normal Room Defaults
• Floor Defaults
• Framing Defaults

• Wall Defaults
• Dimension Defaults
• Annotation Sets

It is recommended that whenever possible, you set these defaults before drawing anything in 
your plan. Changes made to these settings later on are possible, but may require extra work to 
review and adjust heights and wall positions.

To access a file’s default settings

1. Select Edit> Default Settings  to open the Default Settings dialog.
2. Click on the arrow next to a category to expand it and show its contents.

• Click on the arrow again to collapse the category.
3. Select a defaults dialog that you would like to open and click the Edit button.

• You can also open the defaults dialog by double-clicking on a line item.

Normal Room Defaults
The Normal Room Defaults dialog serves as the master defaults dialog for floor and ceiling 
structure and finish definitions on all floors. These are particularly important because they 
influence the overall height of the structure. For more information, see “Floor and Room 
Defaults” on page 332 of the Reference Manual.

To set the Normal Room Defaults
1. In the Default Settings dialog, click the white arrow beside "Rooms", then select "Normal 

Rooms" from the list and click the Edit button.
2. The settings in this are similar to those on the Structure panel of the Room Specification 

dialog, but only four options are active here:
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• Specify the default Ceiling Structure.
• Specify the default Ceiling Finish.
• Specify the default Floor Finish.
• Specify the default Floor Structure.

3. If you wish, you can also specify unique default Floor Finish definitions for Kitchen/Bath/
Utility Rooms, Deck Rooms, and Garage/Porch/Slab Rooms.

Floor Defaults
The Floor Defaults dialogs let you set the default floor and ceiling structure and finish 
definitions for the each floor as well as the default ceiling heights and room moldings. The 
Floor Defaults dialogs draw their default floor and ceiling structure and finish definitions from 
the Normal Room Defaults dialog. For more information, see “Floor Defaults Dialog” on page 
438 of the Reference Manual.

To set the Floor Defaults
1. In the Default Settings dialog, select "Floor" from the list and click the Edit button to 

open the Floor Defaults dialog for the current floor.
• In a plan in progress with multiple floors, begin by navigating to the floor where you 

would like to modify the floor defaults, then open the Default Settings dialog. 
2. On the Structure panel, note the Ceiling Height. The initial value is 109 1/8” (inches). 

Leave this value unchanged for this tutorial.
3. Click OK to close the Floor Defaults dialog.

To reset the Floor Defaults
1. Select Edit> Reset to Defaults.
2. Under Reset Scope, choose either a particular floor, or All Floors.
3. Click OK and floor and ceiling heights for any room that was changed in the Room 

Specification dialog will be restored to the Floor default values.

Framing Defaults
The Framing Defaults dialog influence how all of the major structural components of the 
model are created: including floors and ceilings, walls, and the roof. For more details, see 
“Framing Defaults” on page 580 of the Reference Manual.

To set the Framing Defaults
1. In the Default Settings dialog, select "Framing", then click the Edit button to open the 

Framing Defaults dialog.
2. It is a good idea to review the settings on each of the panels; however, there are several 

settings that should be set before you start drawing:
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• On the Foundation panel, set the Floor Joist Width and On-Center Spacing.
• On the 1st Floor panel, Set the Floor Joist Width and On-Center Spacing.
• On the Roof panel, set the On Center Rafter Spacing, Rafter Type, and the Height and 

Width of the roof framing members.
3. When your Framing Defaults suit your needs, click OK. 

Wall Defaults
The Wall Defaults dialogs let you specify the thickness, materials, and other characteristics of 
the walls that are drawn by each of the Wall Tools. For more information, see “Wall Type 
Definitions” on page 303 of the Reference Manual.

To set the Wall Defaults
1. In the Default Settings dialog, click on the arrow next to "Walls", select "Exterior Wall" 

and click the Edit button.
2. For this tutorial, go to the Wall Types panel, select "Stucco-6" from the Wall Type drop 

down list and click OK.

Dimension Defaults
Dimension lines are important for both positioning walls and other objects and for annotating 
your drawing. It is a good idea, therefore, to specify how you want dimensions to locate objects 
as well as their appearance before you begin drawing.

To set the Dimension Defaults
1. In the Default Settings dialog, click on the arrow next to "Dimension" to expand this 

category, then select the type of dimension you want to modify. For this tutorial, select 
Auto Exterior Dimensions, and click the Edit button.

2. On the Locate Objects panel, specify how you want Auto Exterior Dimension lines to 
locate walls: either at their outside surfaces or at their dimension layer.

• Under the Walls heading, select Wall Dimension Layer and Primary Wall Side.
• Specify how Openings are located. For this tutorial, Sides is used.

To learn more about defining Wall Types, see “Wall Type Definitions”
on page 303 of the Reference Manual.
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3. Review each of the panels and settings available for setting up your Dimension Defaults.
4. For more information, see “Dimension Preferences and Defaults” on page 988 of the 

Reference Manual.

Annotation Sets
While not directly involved in the structural properties of a drawing, if you intend to produce a 
full plan set for your project you should consider using Annotation Sets to increase your 
efficiency and productivity. An Annotation Set is a collection of saved defaults for text, 
dimensions, and other similar objects. When you select an Annotation Set, you are simply 
enabling a pre-defined group of defaults set up for a particular purpose. For more information, 
see “Annotation Sets” on page 82 of the Reference Manual.

Other Defaults
You may want to review some of the other available defaults when setting up your template. 
For example, you can modify your Cabinet defaults, where you can set up your materials for 
Base, Wall and Full Height Cabinets so that any future cabinets placed in the plan will initially 
use these default settings.

You can save this plan as a Template for use when creating new
plans. See “Creating Templates” on page 87 of the Reference Manual.
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Drawing Walls
Once your defaults are set, a new drawing can be started by drawing some exterior walls. When 
drawing walls, do not try to size or position them precisely - they can be more easily positioned 
after they are created. For more information, see “Walls, Railings, and Fencing” on page 261 of 
the Reference Manual.

To draw exterior walls
1. When drawing a structure’s perimeter walls, it is recommended that you make sure Grid 

Snaps are turned on. You may choose to disable them, though, once the shell walls are in 
position. See “Snap Behaviors” on page 164 of the Reference Manual for more 
information. 

2. Select Build> Wall> Straight Exterior Wall  from the menu or click the 
corresponding toolbar button, then click and drag from left to right to draw a wall. Walls 
can be drawn in two ways:

• If you first click using the left mouse button, each wall section will end when the 
mouse button is released. Place the pointer over an existing wall end and click and 
drag to create a new connected wall section. 

• If you initially click using the right mouse button, you will draw continuously 
connected walls until you click both mouse buttons simultaneously (or press the Esc 
key). See “Continuous Wall Drawing” on page 280 of the Reference Manual.

3. There are a few things to make note of as you draw a wall.
• The wall’s length displays in two places: above the wall and in the Status Bar at the 

bottom of the screen. Its angle is also shown in the Status Bar:
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• Wall angles are restricted to increments of 15° when Angle Snaps  are on. In most 
instances, this makes drawing straight walls easy and is desirable; however, you can 

toggle Angle Snaps on and off by selecting Edit> Snap Settings> Angle Snaps  
or pressing the F10 key. See “Snap Behaviors” on page 164 of the Reference Manual 
for more information.

4. Continue drawing walls, creating a rough outline of the building’s exterior, as shown in the 
following image. 

• Exact dimensions are not important yet, but keep the final size of the structure in mind 
as you draw. The overall lengths of this building’s sides are 41’ x 39’6".

• It is helpful to draw exterior walls in a clockwise direction to ensure the proper 
orientation of wall surfaces.

• When the walls enclose an area completely, a Living Area label is created. See “Living 
Area” on page 341 of the Reference Manual.
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Interior walls are drawn the same way that exterior walls are.

To draw interior walls

1. Select Build> Wall> Straight Interior Wall  from the menu or click the corresponding 
toolbar button.

2. Draw an interior wall as shown in the following image.

To delete a wall

1. While the Select Objects  tool is active, click on a wall with the pointer to select it.
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2. Press the Delete key or click the Delete  edit button.

Creating Dimension Lines
Dimension lines locate walls, openings in walls, and other objects. In Chief Architect, you can 
generate several types of automatic dimension lines and draw a variety of manual dimensions 
such as Interior Dimensions, Point to Point dimensions, Baseline dimensions, and angular 
dimensions. For more information, see “Dimensions” on page 987 of the Reference Manual.

To create automatic exterior dimension lines

1. Select CAD> Automatic Dimensions > Auto Exterior Dimensions .

2. For a closer view of a certain area, click the Zoom  tool, click and drag a box around 
the area you want to see in detail, and release the mouse button. That area fills the screen. 
For more information, see “Window and View Tools” on page 881 of the Reference 
Manual.

3. To return to the previous zoom factor, select Window> Undo Zoom .
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4. If you can’t see all the exterior dimension lines at once, select Window> Fill Window 
Building Only  to center your plan on screen.

To draw an interior dimension line

1. Select CAD> Dimensions> Interior Dimension .
2. Click and drag a line that intersects the interior wall and other walls you want to locate.

3. Notice that Interior Dimension lines locate the interior side of exterior walls, while other 
types of dimension lines locate the exterior side.

Note: Interior Dimensions locate the Main Layer of walls by default rather than wall sur-
faces. See “Wall Type Definitions Dialog” on page 306 of the Reference Manual. This
and other options can be changed in the Dimension Defaults dialog. See “Dimension
Defaults Dialog” on page 989 of the Reference Manual. 
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Adjusting Wall Positions
With the perimeter walls in place, you can adjust their position with precision. There are 
several ways to do this, but the fastest and most accurate uses dimension lines. For more 
information, see “Moving Objects Using Dimensions” on page 1020 of the Reference Manual.

To move walls using dimensions

1. Begin by selecting Window> Fill Window Building Only  so the entire building can 
be seen.

2. Click the Select Objects  button, then click on a wall that you want to move.
3. Click on a dimension line that indicates how far the selected wall is from another wall. 

There are a couple of ways to determine which dimensions can be used for this purpose:
• Move the selected wall and see which dimensions update.
• Move your pointer over a dimension. If it is an associated dimension, the icon will 

change to a Pointing Hand .

4. With the Pointing Hand icon visible, click on the associated dimension and enter a new 
value. 

• Remember: Type an apostrophe to denote feet and quotes to denote inches. 
• If neither apostrophes nor quotes are included, inches will be used. 

5. Press the Enter key on your keyboard to move the wall to the newly specified distance.
6. Repeat this process for the adjacent exterior wall, continuing in a clockwise direction. 

When you are finished, your dimensions should match those in the following image:

When using dimensions to reposition walls, you should always work in the same
direction, adjusting one wall section after another.

Selected Wall

Associated Dimension

Pointing Hand icon
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Dimensions can also be used to change the length of a selected wall. Bear in mind, though, that 
the when a wall is resized in this manner its Start point will always be locked and its End point 
will always be moved. Because of this, it is often easier to move walls than to resize them. See 
“Editing Walls” on page 287 of the Reference Manual.

When your exterior walls are in position, you may find it helpful to delete the dimensions. 

To delete all dimensions at once

1. Select Edit> Delete Objects  to open the Delete Objects dialog. See “Delete Objects 
Dialog” on page 257 of the Reference Manual.

2. Select the All Rooms On This Floor radio button, then under the CAD heading:
• Check Manual Dimensions to delete manually-drawn dimension lines such as those 

drawn by the Interior Dimension  tool;
• Check Automatic Dimensions to delete automatically generated dimension lines such 

as those created by the Auto Exterior Dimensions  tool;
• Click the Delete button, then Done.
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Although using dimensions is generally the fastest and most accurate way to move walls, you 
can also move them using their edit handles and edit tools.

To move walls using their edit handles

1. Click the Select Objects  tool then click on an exterior wall to select it.
2. Click and drag the Move edit handle that displays at the position along the wall where you 

clicked. Walls can be moved perpendicular to the direction that they are drawn.
3. As you move the wall, the dimension lines that indicate how far it is from other walls will 

update.

If you have difficulty positioning a wall at a particular location, try zooming in on it using 

either the Zoom  or Zoom In  tool or by scrolling with your mouse wheel. You can also 
use the arrow keys on your keyboard to nudge a selected wall up, down, left, or right on-screen.

Creating Rooms
When the exterior walls enclose an area, a single, large room is created. Once the exterior walls 
are in position, you can add interior walls and to create multiple rooms. Rooms can be assigned 
a Room Type that applies attributes such as flooring that are typical of that type of room. For 
more information about rooms, see “Room Types” on page 337 of the Reference Manual.

To define rooms using interior walls

1. Select Build> Wall> Straight Interior Wall , then click and drag to draw interior 
walls. As with exterior walls, you don’t need to worry about exact placement as you draw.
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2. Select Build> Wall> Break Wall  and click to place two breaks at the locations shown 
in the following image.

3. Click the Select Objects  button, then select the top wall section created by the breaks 
and delete it. Repeat this process for the bottom wall section, so that only the middle 
section remains, which is hatched in the image below for illustrative purposes.



16

Chief Architect X8 User’s Guide

4. Draw a horizontal Interior Dimension  inside this new room, then use it to move the 
vertical interior wall 9’ 7 3/4” from the opposing exterior wall.

To change a wall’s type

1. Select a wall with the incorrect wall type and click the Open Object  edit button to 
open the Wall Specification dialog. See “Wall Specification Dialog” on page 310 of the 
Reference Manual.

2. On the Wall Types panel, click the Wall Type drop-down list and select the desired wall 
type. 

3. Click OK to close the dialog and change the selected wall to the chosen wall type. Repeat 
this process for each of the walls that you want to change, as in the image below.
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Using Room Dividers
In reality, rooms are not always divided by a physical wall. The separation of two rooms may 
be marked by a change in the flooring (carpet to tile, for example), or by a change in the 
interior wall covering. In Chief Architect, a Room Divider or invisible wall can be used to 
define rooms without creating an actual wall. For more information, see “Room Dividers and 
Invisible Walls” on page 275 of the Reference Manual.

To create a room divider 

1. Select Build> Wall> Room Divider  and draw Room Dividers as shown in the 
following image.

If you need to adjust how a wall intersection displays, see “Wall Layer
Intersections Edit Handles” on page 292 of the Reference Manual.
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2. Using the Select Objects  tool, select one of the Room Dividers, and click the Open 
Object  edit tool. On the General panel of the Wall Specification dialog, note that 
Invisible and No Locate are checked.

3. Uncheck No Locate and click OK. When No Locate is selected, it will prevent dimensions 
from locating the wall. 

4. Adjust the wall spacing of the interior, exterior, and Room Divider walls using Interior 
Dimensions , just as you did with exterior walls, to match the following image:
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Room Types
Rooms in Chief Architect are given special attributes when they are assigned a Room Type. For 
example, porches use a concrete floor material and have a ceiling and roof, while decks use 
floor planking and have no ceiling or roof. For more information, see “Rooms” on page 331 of 
the Reference Manual.

To designate a Room Type for a room

1. Click the Select Objects  button, then click in the small room at the bottom of the plan.

2. Click the Open Object  edit button to open the Room Specification dialog.
3. On the General panel, click the Room Type drop-down list and select Entry.
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4. Click OK close the dialog and apply your change.

Double-clicking inside of a room when the Select Objects  tool is active will also open the 
Room Specification dialog. For more information, see “Room Specification Dialog” on page 
352 of the Reference Manual.

5. Open each of the rooms and assign room types as shown in the following image.
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Creating a 3D View
You can create a 3D view of the model to see how it looks so far. For more information, see 
“3D Views” on page 889 of the Reference Manual. 

To create a camera view

1. In floor plan view, click the Fill Window  button to zoom out as needed to fill the view 
window with the entire drawing. 

2. Select 3D> Create Perspective View> Full Camera  (or press Shift + J).
3. Click at the bottom of the floor plan view window and drag a line that stops at the Entry. 

The point where you click (A) defines the point of perspective and the line (B) defines the 
direction of perspective.
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4. Release the mouse button to create the 3D camera view. Where the mouse is released (C) is 
the camera’s focal point.

5. You can use the Mouse-Orbit Camera  tool to change the camera’s perspective. The 
camera will revolve around its focal point (C). See “Repositioning Cameras” on page 912 
of the Reference Manual for more information.

6. To smooth out the edges and create a more realistic rendering of the model, you can select 

3D> Camera View Options> Final View  or Final View with Shadows .

A

B

C
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7. To return to floor plan view, select File> Close from the menu.

To create a floor overview 
1. In floor plan view, select 3D> Create Perspective View> Perspective Floor Overview 

. A floor overview displays the floor without a ceiling or roof.

2. Select 3D> Move Camera With Mouse> Mouse-Orbit Camera  (which should be 
selected by default) then click and drag the mouse on screen to change the camera 
perspective. You can press the I (in) and the O (out) keys on the keyboard to zoom in and 
out of the plan. For more information on modifying camera views, see “Editing 3D Views” 
on page 918 of the Reference Manual.

Adding Floors
Creating new floors in a plan is easy, but it is best to do so only after the first floor plan has 
been finalized. With this first floor of this plan completed, you can now add a second story and 
basement. For more information about working with multiple floors, see “Multiple Floors” on 
page 437 of the Reference Manual.

To add a second floor

1. Select Build> Floor> Build New Floor . The New Floor dialog displays.
2. Select Derive new 2nd floor plan from the 1st floor plan and click OK to close the New 

Floor dialog to display the Floor 2 Defaults. You could also create a blank second floor 

Note: Final Views often take significantly longer to generate than Previews, so a 3D view
will revert back to the Preview Settings as soon as anything is changed within the view.
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plan and then drawn the second story walls manually; however, it is usually faster to 
automatically generate the perimeter walls and then edit them as needed.

3. Click OK and a floor plan for the second floor is created based on the exterior walls of the 
first floor plan. The second floor perimeter walls will now require some editing. It will be 
difficult to know where the second story walls should be without knowing where the first 
floor walls are located.

4. Select Tools> Reference Floors> Floor Reference Display  or press the F9 key. The 
first floor walls are displayed for reference.

To merge two parallel walls into one
1. Select the topmost horizontal wall, then click and drag its Move edit handle to move it.
2. When the wall becomes aligned with another wall and can merge with it, it will stop at a 

"sticky point."
3. Release the mouse button. Note that if you keep dragging the mouse, the wall will break 

free of the sticky point and you can continue moving it.
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4. When you select the wall now, notice that the edit handles are located along its full length.

Use the techniques described above and in “Drawing Walls” on page 7 and “Adjusting Wall 
Positions” on page 12 to create exterior walls as shown in the following image:

Note: Before merging walls, make sure Object Snaps are turned on. For more informa-
tion, see “Object Snaps” on page 164 of the Reference Manual.
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5. Remember to Save  your plan as you work.

To create a foundation or basement

1. Select Build> Floor> Build Foundation . In the Build Foundation dialog:
• Change the Minimum Stem Wall Height to 100 inches.
• Click OK to close the dialog and create a foundation level for your plan.
• For more information, see “Foundation Defaults” on page 450 of the Reference 

Manual.
2. Select Derive New Foundation Plan From the First Floor Plan and click OK to close 

the New Floor dialog. For more information, see “Adding Floors” on page 439 of the 
Reference Manual.

3. You can select Window> Fill Window Building Only  from the menu to center the 
plan on screen.
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4. Select 3D> Create Perspective View> Perspective Full Overview  to create an 
exterior 3D overview of the entire plan so far.

To add a second story balcony

Now that a second floor has been created, the tools and techniques described earlier can be 
used to add a second story balcony that is aligned with the floor below.

1. Press Ctrl + Tab on your keyboard to switch back to floor plan view and return to Floor 2. 

Notice the "S" Markers, which indicate steps in the foundation stem
wall top heights. For more information, see “Foundation Defaults” on

page 450 of the Reference Manual.
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2. If they are not already displayed, select Tools> Reference Floors> Reference Floor 
Display  or press the F9 key to display the positions of the first floor walls on Floor 2.

3. Select Build> Railing and Deck> Straight Railing .

4. Draw a balcony as shown in the following image:

5. If Object Snaps  are on, the second story balcony railing will likely snap into 
alignment with the walls on Floor 1 as they are drawn. If not, you can manually align 
them:

• With a railing selected, click the Align with Wall Below  edit button. 

• If Align with Wall Below  is not available, the selected railing either needs to be 
moved closer to the wall below, or the railing is already aligned with the one below. 
See “Aligning Walls” on page 293 of the Reference Manual.

6. Use the Select Objects  tool to select one of the railings, then click the Open 
Object  edit button. On the General panel of the Railing Specification dialog, increase 
the Thickness to 8 1/8” and click OK.

7. Repeat these steps for each section of railing that has a wall directly below it on Floor 1.
8. Finally, add interior walls to the second floor. When you are finished, it should look similar 

to this:

For best results, do not use the Deck Railing tool or specify the balcony room as a
Deck.
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Adding Stairs
Now that the structure has three floors, it will require stairs. For more information about stairs, 
see “The Stair Tools” on page 537 of the Reference Manual.

To draw stairs with a landing

1. Click Down One Floor  to go to the first floor. You may want to press F9 to turn off the 
Reference Floor Display .

2. Select Build> Stairs> Straight Stairs  (or press Shift + Y).
3. Click and drag to draw a short stair section from right to left, as shown in the following 

image:
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4. Draw another stair section from left to right, directly above the first:

5. While the Straight Stairs  tool is still active, click in the space to the left of the two 
stair sections to create a landing.

6. Click on the landing with either the Straight Stairs  or Select Objects  tool active, 
and if needed, resize it using its edit handles to fit it against the wall.

A stairwell is simply an interior room that has been assigned the Room Type “Open Below”. 
See “Room Specification Dialog” on page 352 of the Reference Manual.
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To create a stairwell
1. Select either of the two stair sections.

2. On the edit toolbar, click the Auto Stairwell  button to create a stairwell.

3. Click the Up One Floor  button to go to Floor 2. Notice that there is now a stairwell 
room defined by railings directly above the stairs on Floor 1.

It makes sense to draw the basement stairs directly below the stairs to Floor 1. The Auto 
Stairwell  edit tool could be used to create another stairwell; however, in this situation, it 
will be better to use the existing interior walls to define the stairwell, rather than by the railings 
that the Auto Stairwell tool generates.

To manually create a stairwell

1. Click the Down One Floor  button to go down to Floor 1.
2. Next, click on a stair section inside of the stairwell room and click the Select Next 

Object  edit button as many times as needed until the room is selected instead of the 
stair. 

3. With the room selected, click the Open Object  edit button and in the Room 
Specification dialog, select "Open Below" from the Room Type drop-down list and click 
OK.
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4. Go Down One Floor  to the foundation (Floor 0) level, and press F9 to turn on the 

Reference Floor Display .

5. Select Build> Stairs> Straight Stairs  and draw two stair sections directly below the 
stairs you drew on Floor 1. Do not draw the landing just yet, though.

6. Select each stair section and adjust its width and position using its edit handles so that it 
fits within the walls forming the stairwell drawn on Floor 1.

7. When the stair sections are positioned properly, click with the Straight Stairs  tool to 
create a landing as you did on Floor 1.

8. Next, use the Select Objects  tool to select the landing, click the Break Line  edit 
button, and click along the landing’s edge to place a break. This divides the edge into two 
sections with a corner handle between them, allowing you to reshape it so that it fits 
against the foundation walls.
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9. Select 3D> Create Perspective View> Perspective Full Overview  to create an 
exterior 3D view of your plan. 

10. When the 3D view has generated, select 3D> Rendering Techniques> Glass House  
to view the entire model inside and out with partially transparent surfaces.

11. Select 3D> Move Camera With Mouse> Mouse-Orbit Camera  and click and drag 
the mouse on screen to change the camera perspective. You can press the I (in) and the O 
(out) keys on the keyboard to zoom in and out of the plan.

Placing Doors and Windows
Now is a good time to add some doors and windows to the model. For more information about 
doors and windows, see “Doors” on page 363 of the Reference Manual and “Windows” on 
page 393 of the Reference Manual.

To add a door
1. If your views are still tiled, close the 3D view and maximize the floor plan view.
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2. Select Build> Door> Hinged Door .
3. Move the pointer to the entry and click on the front wall, left of its center, to place a door.

To add a window

1. Select Build> Window> Window .
2. Move the pointer to the entry and click on the wall, right of center, to place a window.

To edit a door

1. To better see the results when the door is edited, create a Perspective Full Camera , 
view inside the structure, pointed at the entry.

2. Click the Select Objects  tool, then click on the door to select it in the 3D view.

3. Click the Open Object  edit button to open the Door Specification dialog. For more 
information, see “Door Specification Dialog” on page 376 of the Reference Manual.

4. On the General panel, set the Door Style to "Glass", the Width to 36", and the Panel 
Frame Bottom to 8". Press the Tab key to update the preview image on the right side of 
the dialog so that it reflects your change.
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5. On the Lites panel, set the Lites Across to 3 and Lites Vertical to 5.
6. On the Hardware panel, set the Handle In from Door Edge to 2".
7. Click OK to return to the 3D view.

To edit a window
1. Next, click on the window to select it.

2. Click the Open Object  edit button to open the Window Specification dialog. For 
more information, see “Window Specification Dialog” on page 408 of the Reference 
Manual.

3. On the General panel, select “Fixed Glass” from the Window Type drop-down list and set 
the Width to 54".
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4. On the Lites panel, change both the Lites Across and Lites Vertical to 4.
5. Click OK to close the Window Specification dialog.

To change the door swing
1. Return to floor plan view and select the door.

2. Click the Change Opening/Hinge Side  edit button.

To copy a window or door
1. Return to the 3D view and select the window, or door, you wish to copy.

2. Click the Copy/Paste  edit button. For more information about copying objects, see 
“Copying and Pasting Objects” on page 172 of the Reference Manual.

To save time, make these changes in the Door Defaults and Window
Defaults dialogs before doors and windows are placed. For more informa-

tion, see “Default Settings vs Preferences” on page 76 of the Reference Manual.
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Doors and windows can be placed, selected, deleted, copied, pasted, and edited in either 2D or 
3D views. If there is a window design that you will be using throughout a plan, you can create 
it once, then just copy and paste it. An even better approach is to set your door and window 
defaults to the desired settings before placing these objects. For more information, see “Default 
Settings vs Preferences” on page 76 of the Reference Manual.

To create a doorway

1. Return to floor plan view and Zoom  in on the entry room.

2. Select Build> Door> Doorway  and click on the front Entry room wall to place a 
doorway at that location.

3. Select 3D> Create Perspective View> Perspective Full Camera  and create an 
exterior camera view of the doorway.

To customize the doorway

1. Select the doorway by clicking on its frame and click the Open Object  edit button to 
open the Door Specification dialog.

2. On the General panel, change the Width to 54" and the Height to 96".
3. On the Casing panel, change the Exterior Casing Width to 10". Be sure to delete the (D) 

from the text field. It stands for "default" and if it is not removed, it will continue to apply 
the default casing width, regardless of the value you specify.

4. On the Casing panel, click the Library button beside Casing Profile and select a molding 
profile from the library.

5. On the Arch panel, click the Type drop-down and select "Broken Arch" from the list. Set 
the Height to 12".

6. Click OK to close the Door Specification dialog.



38

Chief Architect X8 User’s Guide

To center a wall opening
1. Return to floor plan view and select the doorway.

2. Click the Center Object  edit button, then click inside the entry room, near the interior 
wall containing the doorway. 

3. When a dashed centering axis displays in the room, click once to center the door. For more 
information, see “Using Center Object” on page 229 of the Reference Manual. 

4. Return to the camera view to see the results.

Use the tools and techniques you’ve learned to add window and doors to the rest of the plan, as 
shown in the following images. Hinged and Sliding Doors placed in interior walls become 
interior doors and have different specifications than exterior doors. See “Interior vs Exterior 
Doors” on page 364 of the Reference Manual.
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When you have finished, Save  your work. 

To take a final look

1. Using the Full Camera  tool, create an interior camera view on Floor 1. Remember 
that where you click determines the camera’s perspective and where you release 
determines the point about which the camera will rotate. A short drag distance is ideal, 
however, the distance must be greater than one foot.

1st Floor

 2nd Floor
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2. Release the mouse button to create the 3D camera view then use the Mouse-Orbit 
Camera  tool to take a look around and see your progress so far.

3. You can also create a Floor Overview  on any floor.
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4. When you are finished, be sure to Save  your work.

If you would like, you can continue working on this plan in the Interior Design Tutorial or 
Kitchen and Bath Design Tutorial. You can also learn about materials in the Materials Tutorial 
or find out more about roofs in the Roof Tutorial. To learn how to arrange views of your model 
on a page for printing, see the Layout Tutorial.
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