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Chapter 1:

Program Overview

Chief Architect is specifically designed for 
the residential and light commercial design 
professional. It allows you to easily and  
efficiently produce 3D models and 
construction documents for your projects. 
We thank you for choosing Chief Architect 
and wish you the best in your design work.

Chapter Contents
•      Chief Architect Premier vs Interiors
•      Startup Options
•      The Chief Architect Environment
•      Using the Mouse
•      View and Side Windows
•      Toolbars and Hotkeys
•      Menus
•      Dialogs
•      The Status Bar
•      Message Boxes
•      Preferences and Default Settings
•      Drawing a Plan
•      Viewing Your Plan
•      Sharing Your Files with Clients
•      Getting Help
•      About Chief Architect
•      Chief Architect Trial Software

Chief Architect Premier vs Interiors
Not all of the features described in this 
document are available in the Interiors 
version of Chief Architect.  

For a list of the features in each program, 
visit our website, www.chiefarchitect.com.

http://www.chiefarchitect.com/
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Startup Options
When Chief Architect opens, the 
Startup Options dialog displays, 

allowing you to choose how you want to 
begin working in the program or access 
useful resources. 

The Startup Options dialog can be opened at 
any time by selecting File> Startup 
Options .

Select a File command to open a .plan 
or .layout file.

• Click New Plan  to open a new, blank 
plan. See “Creating a New Plan or Lay-
out” on page 54.

• Click New from Template  to open a 
new, blank plan based on a template that 

you select. See “Template Files” on page 
84. 

• Choose Open Plan  or Open Layout 
 to work on an existing plan or layout 

file. See “Opening and Importing Files” 
on page 61.

1
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Recent Files lists the full pathnames of 
the most recently opened files. Click on 

a name to open the file. You set the number 
of files in this list  in the Preferences dialog. 
See “General Panel” on page 98.

A selection of useful online Resources 
is available here. Select one to launch 

your default internet browser to a page on 
our web site,  chiefarchitect.com.
• Select Overview Video to watch a 

browsable collection of videos outlining 
the software’s features and uses.

• Select Training Videos to access a 
searchable collection of videos focused 
on specific topics.

• Select Download Catalogs to visit our 
3D Library of downloadable bonus and 

manufacturer library catalogs. See 
“Library Content” on page 825.

Click Getting Started to launch your 
default internet browser to the Getting 

Started page on our web site. There, you will 
find links to a variety of online resources to 
help you begin using the program.

Click My Account to launch your 
default internet browser to the Log In 

page on our web site. 

Your software version’s Build number 
and the first five characters of your 

Product Key display here for reference. If 
your software license has an expiration date, 
it will also display here.

To prevent the Startup Options dialog from 
displaying when you launch Chief Architect, 
uncheck Show Options on Startup in the 
Preferences dialog. See “General Panel” on 
page 98. 

The Chief Architect Environment

Object-Based Design
Chief Architect’s parametric, object-based 
design technology means you place and edit 
objects, rather than work with the many 
individual lines or surfaces used to represent 
them. 

You can quickly select and edit the location, 
size, shape, style and other properties of 
objects as well as change the materials 
applied to their surfaces. 

Use Chief Architect’s editing capabilities to 
make the objects you place in a plan match 
the objects they represent in real life. For 

example, you can set up your windows and 
doors to match those available from your 
supplier. 

3D Drafting
In Chief Architect, the entire drawing area is 
laid out on a Cartesian grid, a three 
dimensional coordinate system described 
using the X, Y, and Z axes. The current 
position of your mouse pointer displays in 
the Status Bar at the bottom of the program 
window.

Architectural objects take up space in all 
three dimensions and their height, width and 

Move your mouse pointer over a name
to see the file’s full pathname. 

2

3

4

5

6

http://www.chiefarchitect.com/
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depth can be specified in Imperial or metric 
units. In addition, the location of objects can 
be precisely defined using coordinates, again 
specified in Imperial or metric units.

CAD objects such as lines and arcs take up 
space in two dimensions in the current view. 
Their dimensions can also be specified in 
Imperial or metric units and their locations 
precisely defined using coordinates.

Objects can be rotated relative to the 
Cartesian grid system, as well. When the 
program presents the option to rotate to an 
Absolute Angle, this angle will be measured 
relative to an imaginary horizontal line 
drawn in floor plan view from the origin in 
the positive X direction. See “Rotating 
Objects” on page 234. 

Easy Access to Tools
You can access Chief Architect’s features in 
various ways using the mouse and keyboard. 
• Menus provide access to most tools.
• Convenient toolbar buttons allow fast 

access to tools and let you customize the 
interface.

• Keyboard shortcuts are available for most 
tools and can be customized.

• Contextual menus display with a right-
click of the mouse.

• The Status Bar at the bottom of the screen 
provides tool descriptions and other 
information about the current task. 

Interface Toggles
A number of useful drawing and editing 
behaviors, as well as the display of important 

elements in the interface, can be easily 
enabled and disabled using the menus and 
toolbars. For example:

Status Bar

Parent 
Tools

Tool 
Palette

Menus

Library 
Browser

Edit  
Toolbar PointerCrosshair 

Lines
Reference 
Grid Lines

Selected 
Object

Temporary 
Dimension

Library 
Preview 
Panes

Title 
Bar

Project  
Browser
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• Object Snaps, Angle Snaps, and Grid 
Snaps can be toggled on or off as needed. 
Individual Object Snaps and Extension 
Snaps can be toggled as well. See “Snap 
Behaviors” on page 162.

• Display Elements like Print Preview, 
Show Line Weights, and the Reference 
Display can be turned on when needed 
and then toggled off.

• Special Edit Behaviors can be enabled for 
particular tasks, then replaced by the 
Default Behavior. See “Edit Behaviors” 
on page 178. 

When a setting is turned on, its icon will 
display a small checkmark at its lower right 
corner and have a border around it in both the 
toolbars and the menu. 

Many of these interface elements are global 
Preferences while others are file-specific 
default settings. See “Default Settings vs 
Preferences” on page 74.  

Using the Mouse
Many objects, such as doors and cabinets, are 
created by clicking the left mouse button. 
Others, such as walls, stairs and dimension 
lines, are created by dragging the pointer 
from one end of the object to the other.

The left button is the primary 
button used in Chief Architect. 
Unless specified otherwise, Chief 
Architect documentation refers to 

the left mouse button.

The Right button has several uses. 

Right-click to select any object.If, for 

example, the Straight Exterior Wall  
tool is active, the left mouse button allows 

you to select only walls. You can select other 
object types such as cabinets with the right 
mouse button.

Use the right mouse button to temporarily 
switch to the Alternate edit behavior. See 
“Edit Behaviors” on page 178.

You can also use the right mouse button to 
open a context sensitive menu with 
additional editing commands. See 
“Contextual Menus” on page 38.

The Middle button can be used to 
pan in most view types or to 
temporarily use the Move edit 
behavior. To close a tabbed view 

window, click on its tab using the middle 
mouse button. You can also program it to 
work as a double-click.

If your mouse does not have a middle mouse 
button, in the Mac version of Chief Architect 
you can use the left button and the Command 
key to achieve the same results.

Angle Snaps is enabled

Object Snaps is disabled

Note: If you are left-handed and have re-pro-
grammed your mouse, reverse the instruc-
tions for left and right buttons in this manual. 
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The Mouse Wheel can be used to 
zoom in and out in most view types. 
See “Zoom Tools” on page 881.

The Back, or X1, button on a 5-button mouse 
can be used to temporarily enable the 
Concentric edit behavior. See the 
documentation for your mouse.

The Forward, or X2, button on a 5-button 
mouse can be used to temporarily enable the 
Resize edit behavior. See the documentation 
for your mouse.

3D Mice
3Dconnexion®'s 3D mice can be used to nav-
igate in Chief Architect. For information 
about navigating in camera views and over-
views, see “3Dconnexion® 3D Mice” on 
page 912.

Using a Trackpad
In addition to the standard trackpad gestures 
on your system, in Chief Architect you can 
pinch to zoom. 

In OS X 10.10 (Yosemite), use the click-hold 
gesture to pan; in 10.9 (Mavericks) and prior, 
click-hold and two finger panning are 
supported. Panning is not supported in the 
Windows version of the software, however.

Edit Handles
When you select an object, its edit handles 
display. How each handle behaves when it is 
clicked and dragged may depend on which 

Edit Behavior  is currently active. See 
“Edit Behaviors” on page 178. 

When you pass the mouse over an edit 
handle, information about what the handle 
does displays in the Status Bar and the 
pointer changes to show how you can use 
that handle. 
• A two-headed arrow indicates that the 

object, corner or edge can be moved in 
the direction of the arrows. 

• A four-headed arrow indicates that the 
selected object or edge may be moved in 
multiple directions. 

• A circular arrow indicates that the 
selected object can be rotated.

Resize handles display along the edges of the 
object are used to change the size. See 
“Resizing Objects” on page 229.

The Move handle at the object’s center lets 
you move the object. Depending on the type 
of object(s) selected and how far you are 
zoomed in or out, the position of the Move 
handle may shift so that it remains on-screen. 
See “Moving Objects” on page 220.

The triangular Rotate handle lets you rotate 
the object. See “Rotating Objects” on page 
234.
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You can cancel any edit handle operation 
before it is completed by pressing the Esc 
key on your keyboard or by pressing any two 
mouse buttons at the same time. 

The edit handles that display depend on the 
type of object selected, the current view, and 
how far you are zoomed out. 

Edit handles do not resize as you zoom in or 
out. If you are zoomed out far enough, some 
edit handles may be hidden so that they do 
not stack over one another. As you zoom in, 
these handles become visible again.

Mouse Pointer Icons
The appearance of the mouse pointer in 
Chief Architect will vary, depending on 
which tool is active. For example, when the 

Select Objects  tool is active, it will look 
like a white arrow, and when a Cabinet 

Tool  is active, it will look like a base 
cabinet with a small cross.

In addition, one or more additional icons 
may follow the mouse pointer if a 
recommended setting is not in use or if a 
problematic condition exists in the file: 

View and Side Windows
Chief Architect’s main program window has 
a number of important features that let you 
interact with the program, such as toolbars 
and menus. It also features two different 
kinds of windows: view windows and side 
windows.

View Windows
View windows are sometimes referred to as 
“the drawing area” because most of them are 
windows in which you can draw or place 

architectural and/or CAD objects. There are 
a number of different types of view windows 
in Chief Architect:
• Floor plan view
• Camera views and overviews
• Cross section/e
• Ray Trace views
• CAD Details
• Materials Lists
• Layout

Object labels also have their own Move
and Rotate handles. See “Object
Labels” on page 1279. 

Icon Setting

   
Angle Snaps

   
Alternate Edit Behavior

   
Move Edit Behavior 

   
Resize Edit Behavior

   
Concentric Edit Behavior

   
Fillet Edit Behavior

   
Disconnect Edges

   
Auto Rebuild Terrain

   
Rebuilding Walls, Floors
and Ceilings

   
Fix Wall Connections
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View windows can be navigated by panning 
and zooming; and, they have scroll bars on 
the right side and on the bottom. You can 
turn off the display of the scroll bars by 

selecting View> Scrollbars . See “View 
Tools” on page 880.

Although only one view window can be 
active at any given time, there is no limit to 
the number of view windows that can be 
open. View windows can be tiled or tabbed, 
and you can navigate between them in a 
number of different ways. See “Window and 
View Tools” on page 879.

You can also tear a view window out of the 
main program window. This creates a 
second, separate program window complete 
with toolbars and menus.  Individual view 
windows can be torn out and transferred 
between program windows. 

Side Windows
Side windows provide access to a variety of 
tools, content, and information that helps you 
organize and add detail your drawings.

Side windows are so-named because they are 
typically docked to either the left or right 
side of the program window - although, they 
can also be docked to the top or bottom, or 
undocked entirely.  There are several 
different types of side window:
• Child Tool Palette
• The Library Browser
• Project Browser
• Active Layer Display Options
• Aerial View

Each of these side windows can be opened 
via the View menu or by clicking the toolbar 

button associated with it. Similarly, each can 
be closed by clicking the Close button in its 
title bar or tab, via the View menu, or by 
clicking its toolbar button. See “View Tools” 
on page 880. 

To undock a side window, either drag its title 
bar out into the drawing area or click the 
Undock button on its title bar. To dock a side 
window, drag its title bar to any side of the 
program window. You can also double-click 
on its title bar to return it to its last docked 
location.

Two or more side windows can be docked 
together to form a shared side window, and 
can be tiled and/or tabbed within that shared 
window. To create a shared side window, 
begin by docking a side window to a side of 
the main program window, then:
• To create tabbed side windows, drag a 

second side window over the first. When 
the docked window becomes highlighted, 
release the mouse button.

• To create tiled side windows, drag a sec-
ond side window over the first. When the 
docked window becomes highlighted, 
slowly drag the mouse towards one of its 
sides. When a highlighted space is cre-
ated along that side, release the mouse 
button. 

You can choose to disable Side Window 
Drag Docking in the Preferences dialog, 
and you can also enable Top/Bottom 
Docking. See “Appearance Panel” on page 
92.

Side windows can also be set to their initial 
states in the Preferences dialog. See “Reset 
Options Panel” on page 126.



Toolbars and Hotkeys

 37

Toolbars and Hotkeys
Using the toolbar buttons is the fastest, 
easiest way to access many program features. 
If a tool is active, a small checkmark will 
display at the lower left of its button icon. 
You can move the toolbars, customize them 
by adding or removing buttons, or create 
your own toolbars from scratch. See 
“Toolbar Customization Dialog” on page 
135.

You can also turn off the display of toolbars 
entirely or turn them on again by selecting 

View> Toolbars .

When you pass the pointer over a toolbar 
button, a “tool tip” displays the name of the 
tool and a more detailed description displays 
in the Status Bar at the bottom of the 
program window. When you see one of these 
tool tips, press the F1 key to get more 
information about that item. See “Getting 
Help” on page 49. 

Chief Architect’s tools are organized into 
families of related tools which can be 
accessed using either of two styles of toolbar 
interface: the Child Tool Palette or Drop 
Down tools. You can select the interface that 
you prefer in the Preferences dialog. See 
“Appearance Panel” on page 92. 

Toolbar Configurations
Chief Architect installs with five Toolbar 
Configurations, which are sets of toolbars 
organized for working on specific tasks. 
Each can be accessed in the Toolbar 
Customization dialog, by right-clicking on a 
toolbar, or by clicking a Toolbar 

Configuration button. See “Toolbar 
Configurations” on page 131. 

You can customize these configurations to 
suit your needs, or you can create your own 
custom configurations.

The Edit Toolbar
When you select an object, the edit toolbar 
appears. By default, it is located at the 
bottom of the program window, just above 
the Status Bar. The buttons on the edit 
toolbar can be used to edit the selected 
object(s). Which buttons display depends on 
the type of object selected, the current view, 
and how you selected the object.

The edit toolbar buttons are the same as the 
options in the contextual menu when you 
right-click on an object. See “Contextual 
Menus” on page 38.

Hotkeys
Many commands can be invoked from the 
keyboard.  Press Alt on your keyboard and 
press the underlined letter in a menu name to 
access that menu, as well as items in the 
menus and submenus. 

Other keys or key combinations will invoke a 
variety of program commands. If a Chief 
Architect menu item has a keyboard shortcut, 
or hotkey, associated with it, that hotkey will 
display to the right of its name in the menu. 
You can assign hotkeys to Chief Architect’s 
tools to best suit your style of work. See 
“Hotkeys” on page 138.
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Menus
Chief Architect uses a standard Windows 
menu format. The menus are located below 
the title bar in the program window and can 
be used to access nearly all tools in the 
program. Click on a menu name to expand it, 
then click on a menu item to either activate 
that tool or access the item’s submenu. Items 
with a submenu have an arrow to the right of 
the name.

Menu items with an icon to their left have a 
toolbar button associated with them. Some 
buttons are not included on the toolbars but 
can easily be added. See “Toolbar 
Customization Dialog” on page 135.

The menus can be accessed using the 
keyboard. Press the Alt key once to enable 
this functionality - one letter in each menu 
will become underlined. Press the key 
associated with one of these underlined 
letters to expand its menu - one letter in each 
menu item’s name will be underlined. Press 
the key associated with one of these letters to 
activate that tool or access the item’s 
submenu. Press the Esc key to undo your last 
selection, or click with the mouse to exit out 
of this functionality. 

Many tools in Chief Architect also have 
hotkeys associated with them. If a menu item 
has a hotkey, it will display to the right of the 
item’s name. See “Hotkeys” on page 138.

In the Chief Architect documentation, menu 
paths are written in this format: Build> Win-
dow> Box Window . An icon image after 
the menu path indicates that a toolbar button 
is also available. 

Contextual Menus
Contextual menus are context-sensitive 
menus that display tools relevant to a 
selected object or view. To open a contextual 
menu, right-click on an object, in an empty 
space in a view window, or in a text field in a 
dialog box.

The options in an object’s contextual menu 
are usually the same as those on an object’s 
Edit toolbar. See “The Edit Toolbar” on page 
37.

Contextual menus can be enabled or disabled 
in the Preferences dialog. When contextual 
menus are disabled, right-clicks perform 
generic object selection, much like when the 

Select Objects  tool is active  See 
“Appearance Panel” on page 92. 

Edit menu items with button icons 
to the left and hotkeys to the right

Contextual menu for floor plan view
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Dialogs
Default and preference settings, object 
specifications, display settings, and many 
other functions are accessed through dialog 
boxes. 

Many dialogs have multiple panels, which 
are listed in a tree list on the left side of the 
dialog. Click on a panel name in the list to 
make it active. In Windows, panels can also 
be navigated using the keyboard. Press:
• Ctrl + Tab or Ctrl + F6 to navigate for-

ward; 
• Ctrl + Shift + Tab or Ctrl + Shift + F6 to 

navigate backward.

When a panel name is active, you can also 
navigate the tree list using the Up and Down 
arrow keys. 

By default, dialogs always open to the first 
panel in the list; if you prefer, you can choose 
to Open Dialogs to the Last Panel Visited. 
See “General Panel” on page 98, 

Dialog panels and settings can be accessed 
using the mouse. You can also navigate the 
settings on a given dialog panel using the 
keyboard. For example:
• Line items in tree lists can be browsed 

using the arrow keys. Up and Down navi-
gate the list, while Left and Right expand 
and contract categories.

• Press the Tab key to shift focus from the 
tree list to the first setting on the selected 
panel. 

• Press the Tab key to shift focus from one 
setting to the next, or Shift + Tab to go in 
the reverse direction. 

• A checkbox can be checked or cleared by 
pressing the Spacebar or the + or - keys, 
respectively, while it is in focus. 

• Columns of radio buttons can be navi-
gated using the Up and Down arrow 
keys; rows can be navigated using the 
Left and Right arrows. Select a radio but-
ton by pressing the Spacebar while it is in 
focus.

• Settings in list boxes can be navigated 
using the Up and Down arrow keys. 
When a checkbox is in focus, it can be 
checked or cleared by pressing the Space-
bar. 

• Drop-down lists can be browsed using 
the Up and Down arrow keys. When the 
mouse pointer is directly over the drop-
down, the mouse scroll wheel can also be 
used; on a Mac, the list must also be 
expanded. In Windows only, you can 
press Tab to select the highlighted item in 
the list and proceed to the next setting. 

• Settings with spin control arrows  can 
be adjusted by typing in the text field or 
using the Up and Down arrow keys. 
When the mouse pointer is directly over 
the setting, the mouse scroll wheel can 
also be used.

• Slider bars  can be adjusted by typ-
ing in the text field or using the Left and 
Right arrow keys. When the mouse 
pointer is directly over the slider bar, the 
mouse scroll wheel can also be used.

• Line items in tables can be group selected 
using the Ctrl or Shift keys, or by press-
ing Ctrl+A.
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• Press Enter on your keyboard to close 
most dialogs and apply your changes.

In the Mac version of the software, Dictation 
is supported in dialogs. Select Edit> Start 
Dictation, then open a dialog. Say the word 
“Numeral” before a number to enter it as a 
numeric value or immediately follow a 
number with a unit such as “foot” to enter it 
as a measurement. 

The units of measurement used in dialogs are 
determined by your choice of template files. 
See “Creating a New Plan or Layout” on 
page 54.

The number format used in dialogs are set 
based on your operating system’s defaults. 
See “Region and Language Settings” on page 
75. You can change the number format as 
well as the angle format in the Dialog 
Number Style/Angle Style dialog. See 
“Dialog Number/Angle Style Dialog” on 
page 127.

Math Operations in Dialogs
Basic addition, subtraction, multiplication, 
and division can be performed in the text 
boxes where numeric values are entered.

Note that settings for angle, pitch, or bearing 
do not support math, nor do those with spin 
controls or slider bars.
• To add, type the + character followed by 

the amount that you wish to add. Spaces 
are ignored and including a unit of mea-
surement is optional. 

• To subtract, type the - character followed 
by the amount you wish to subtract. As 
with adding, spaces are ignored and a 
unit of measurement is optional.

• To multiply, type the * character followed 
by the amount you wish to multiply by. 
Spaces are ignored, and only one of the 
values being multiplied can have a unit of 
measurement. 

• To divide, type the / character followed 
by the amount you wish to divide by. To 
divide, there must be a space before the / 
- if there is not, the input may be treated 
as a fraction. The denominator, or value 
typed after the /, cannot have a unit of 
measurement.

Math expressions support a single operation 
only: more than one operation character (+, -, 
*, /) at a time is not allowed. 

Basic math operations can also be used to 
move objects using dimensions. See 
“Moving Objects Using Dimensions” on 
page 1019.

Dialog Size and Position
Dialog boxes can be both moved and resized 
to suit your needs. By default, the program 
will remember both the position and size that 
you specify for a dialog and use it the next 
time you open it. You can specify whether 
the program does this always, per session, or 
never in the Preferences dialog. You can 
also reset the default sizes and positions. See 
“Reset Options Panel” on page 126.
• To move a dialog, position your mouse 

pointer within its title bar and then simply 
click and drag.

• To resize a dialog, position your mouse 
pointer on any edge or corner and then 

Note: Keyboard navigation in dialogs may
vary somewhat depending on your computer
platform. 
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click and drag outward or inward. If you 
drag an edge, only that edge will move; if 
you drag a corner, the two adjacent edges 
will move. 

When a dialog is resized, some elements 
within it may resize in response: for 
example, some list boxes and text fields. 
Some elements within a dialog box can also 
be resized independently. See “Dialog Panel 
Splitters” on page 42. 

Note that all dialogs have a minimum size 
limitation but no maximum size. If a dialog 
opens on a monitor with resolution too low to 
display its full extents, it will have vertical 
and/or horizontal scroll bars. 

Specification Dialogs
Each object in Chief Architect has a 
unique specification dialog where you 

can enter size, style and other information 
specific to the selected object. To access it, 
select the object and click the Open Object 
edit button. You can also double-click on an 

object with the Select Objects  tool 
active to open its specification dialog. See 
“Selecting Objects” on page 183.

Most objects also have a defaults dialog that 
lets you specify the initial values in the 
specification dialog. 

You can open the specification dialog for 
group-selected objects if they are of the same 
type, such as base cabinets. 
• If a particular setting varies among the 

different objects, its checkbox will have a 

solid fill instead of a check mark. Click 
once to clear the box for all selected 
objects, or click a second time to place a 
checkmark for all selected objects. 

• In some dialogs, if a particular setting 
varies among the different objects, it will 
have a “No Change” radio button. Leave 
this button selected, or choose a different 
option to apply it to all objects in the 
selection set. 

•  If the setting has a text field or drop-
down list, it will say “No Change”. 
Changes made to such a setting can be 
undone by replacing the value in the text 
field with the letter N before you click 
OK. 

If you select multiple objects of different 

types, the Open Object  edit button is 
usually not available. This button may be 
available if the objects have data in common, 
but you can only edit the common data. 

Dialog Preview Panes
Many specification dialogs have a preview 
pane that shows how changes affect the 
selected object. This preview updates when 
you click in a different field or press the Tab 
key on your keyboard. 

If you switch to a panel with settings that 
affect the selected object’s appearance in a 
certain view, that view will be shown in the 
preview. For example, if you select the GEN-
ERAL panel, a 3D view will be shown; but if 
you select the FILL STYLE panel, floor plan 
view will be shown. When floor plan view is 
shown, the primary and all secondary layers 
associated with the object will display. See 
“Primary and Secondary Layers” on page 
144. 

Note: Some of the dialog box images in the
software documentation have been resized
smaller than their actual minimum size. 
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When you click in the preview pane, your 
mouse pointer changes to a four-headed 
arrow and you can rotate around the object as 
well as zoom in and out using the mouse 
scroll wheel. Some objects, notably walls, 
doors, and windows, have Interior and 
Exterior labels to indicate which side is 
visible in the preview. Click the Fill 
Window  button above the preview pane 
to zoom in or out so that the object fills the 
extents of the pane, maintaining the current 
rotation. 

A selection of Rendering Techniques can be 
applied to the preview in most dialogs: 
Standard, Vector View, and Glass House. See 
“Rendering Techniques” on page 951. You 
can specify whether Standard or Vector View 
is used by default in the Preferences dialog. 
See “Appearance Panel” on page 92. 

Click the Color  button to turn color in 
the preview off or on. Some objects have 

additional tools that affect object previews. 
For example, the Cabinet Specification 

dialogs have a Select Cabinet Face Item  
button. Object specific tools like this are 
discussed in the documentation for that 
object type. 

Dialog Panel Splitters
Many dialog panels are divided into up to 
three sections: a list of panels on the left, an 
object preview on the right, and a central 
area where settings are located. The vertical 
splitters separating these sections each have a 
pale, dotted handle. 

To resize the panel list or preview, as well as 
the area in the middle, move your mouse 
pointer over the vertical division line: when 

the splitter cursor  can be seen, click and 
drag to the left or right.  

The Status Bar
The Status Bar at the bottom of the main 
program window displays information about 
the current state of the program. 

This information depends on a variety of 
conditions such as settings in the 
Preferences dialog, the type of object 
selected, and the current position of the 
pointer. The information may include the 
following:
• The type of object currently selected or 

the total number of group-selected 
objects. 

• A description of the edit handle that the 
pointer is over.

• A brief description of the toolbar button 
or menu item highlighted by the mouse.

• The name of the active tool and its hot-
key, if it has one.

• The length and/or angle of an object as it 
is being drawn.

• The layer that the selected object is on.
• Basic information about a selected library 

object, folder, or catalog.
• The current floor.
• The size of the active window in pixels.
• The screen redraw time.
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• The current layout page.
• The Current CAD Layer.
• The current CAD coordinates of the 

mouse pointer.

The number format used in the Status Bar is 
set in the Dimension Defaults dialog, while 
the angle style can be specified in the 
Number Style/Angle Style dialog. See 
“Primary Format Panel” on page 989 and 
“Dialog Number/Angle Style Dialog” on 
page 127.

Message Boxes
As you work in Chief Architect, the program 
will occasionally prompt you to examine 
your settings, alert you if you command it to 
do something that could potentially cause a 
problem, or notify you if it encounters a 
problem that needs your attention.

Situations where such message boxes may 
display include: 
• Closing a file or view without saving;
• Modifying an object that is set to rebuild 

automatically;
• A file referenced outside the program, 

such as an image or texture, is missing;
• Creating an object in a space too small to 

contain it.

As with dialog boxes, you can access the 
options in a message box using the mouse or 
navigate them using the keyboard.

A few messages have a Send Report button. 
Click this button to send details regarding the 

issue that prompted the message to Chief 
Architect via the internet. 

Some message boxes include a “Remember 
my choice” or a “Do not show this again” 
checkbox. Check this box to prevent 
messages of this specific type from 
displaying in the future. When this box is 
checked, some options in the message box 
may become inactive.

To allow all message boxes to display again, 
click the Reset Message Boxes button in the 
Preferences dialog. See “Reset Options 
Panel” on page 126. 

Name Prompt
In dialogs throughout the program, there are 
opportunities to create new entities that 
require a name. Examples include:
• The Copy button in the Saved Defaults 

dialog.
• The Copy Set button in the Layer 

Display Options dialog.
• The Rename button in the Schedule 

Specification dialog.

When you click a New, Copy, or Rename 
button in a dialog, a Name Prompt box will 
open. 
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For best results, type a short, descriptive, and 
unique name and then click OK.

Preferences and Default Settings
Preferences and default settings control 
many aspects of the user interface and tool 
behavior in Chief Architect. You can use 
these settings to customize the program to 
suit your personal work style.

For more information about defaults and 
preferences, see “Preferences and Default 
Settings” on page 73.

Preferences
Preference settings let you change program 
behavior to suit your workflow. For example, 
you can: 
• Turn certain display elements on or off.
• Choose background and editing feedback 

colors.
• Set frequency of autosaves, maximum 

number of “undos,” and file locking.
• Set default folders for various files.
• Control the editing behaviors of objects.
• Setup the materials list categories, sub-

categories, and report style, as well as 
manufacturer and supplier information.

• Set rendering specifications to maximize 
efficiency and quality. 

Preference settings are global, affecting all 
plan and layout files.

Defaults
Most objects in Chief Architect derive their 
intial properties from their respective default 
dialogs. 

For example, a newly placed Window  
gets its initial values from the Window 
Defaults dialog and a newly placed Hinged 
Door  gets its initial values from the Door 
Defaults dialog. 

Once an object is placed in a plan, its initial 
properties can be overridden, but setting up 
your defaults before you begin drawing can 
save you considerable time as you build a 
model in the program.

Default settings, unlike Preferences, are file 
specific.

Dynamic Defaults
Most default settings are static: if you change 
one, any objects of that type in the current 
file will not be affected. A few defaults, 
however, are dynamic: they are tied to 
existing objects in the drawing and if you 
change the default, those objects may be 
affected. See “Dynamic Defaults” on page 
76. 
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Template Plans
You can set up an otherwise empty plan with 
the default settings of your choice and use it 

as your template for new, blank plans. See 
“Template Files” on page 84.

Drawing a Plan
When you draw a plan in Chief Architect, 
you are placing 3D objects that represent 
building components. Chief Architect comes 
with predefined default settings so you can 
start drawing plans immediately. You should 
review these default settings to be sure they 
match your drawing and building methods. 
See “Preferences and Default Settings” on 
page 73.

Set the Defaults
1. Open a new plan using the template of 

your choice. See “Template Files” on 
page 84. 

2. Set the structural defaults:
•  Floor Defaults. Set the default ceiling 

height for Floor 1. See “Floor Defaults 
Dialog” on page 436.

•  Foundation Defaults. Set the founda-
tion specifics such as type, footing size, 
and stem wall height. See “Foundation 
Defaults” on page 448.

•  Framing Defaults. Set the floor framing 
specifications, including type and 
dimensions. See “Framing Defaults” 
on page 578.

•  Default Wall Types. Specify the 
defaults for walls and railings. See 
“Wall, Railing, and Fencing Defaults” 
on page 260. 

3. Set material defaults for roof, walls, and 
rooms (optional). See “Material 
Defaults” on page 848.

4. Set style defaults for doors, windows, 
molding, cabinets and other objects. 

Draw the Floors
1. While the size of the drawing area in 

Chief Architect is limited only by the 
resources on your computer, it is best to 
begin your drawing near the origin, 
0,0,0. See “3D Drafting” on page 31.

2. Draw the exterior walls on Floor 1. See 
“Drawing Walls” on page 276.

3. Adjust the perimeter shape and size as 
required. See “Using the Edit Handles” 
on page 286.

4. Place any first floor bearing walls. 
5. Define types for special rooms such as 

garages and decks in the plan. See 
“Room Types” on page 335. 

6. Place perimeter doors and windows. See 
“Doors” on page 361 and “Windows” on 
page 391.

7. Build additional floors. See “Adding 
Floors” on page 437.

8. Specify the default ceiling height for 
each floor as soon as it is created. See 
“Floor Defaults Dialog” on page 436.
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9. Adjust the perimeter shape of additional 
floors as needed. See “Editing Walls” on 
page 285.

10. Align edited or moved walls with those 
above or below where appropriate. See 
“Aligning Walls” on page 292.

Entering Dimensions
When using Imperial units, enter distances as 
inches or feet and inches, in fractional or 
decimal form. Millimeters are the default 
unit for all metric distances. See “Dimen-
sions” on page 985.
• To enter feet, include the ( ' ) marker or 

the program assumes inches.
• In most cases, the program allows 

precision to 1/128th of an inch. Fractions 
with denominators 2, 4, 8 and 16 are 
allowed.

• The program usually converts decimals 
to fractions.

• You can enter angles as decimal degrees, 
degrees, minutes, and seconds, quadrant 
bearings, or azimuth bearings. See 
“Dialog Number/Angle Style Dialog” on 
page 127.

Build the Foundation
1. Derive the foundation plan from the first 

floor. See “Building a Foundation” on 
page 452.

2. Adjust the foundation perimeter shape 
as needed.

3. Place interior foundation walls as 
needed for the first floor bearing walls.

4. Place any other foundation walls 
required.

5. Align with Above as needed. See 
“Aligning Walls” on page 292.

Add Structure and Details
1. Build non-structural interior walls. 

Begin on floor one and work up in mul-
tiple story structures. 

2. Add walls where needed to create fea-
tures such as chimney chases, plumbing 
walls, or Open Below areas.

3. Finish the relevant interior structure 
including interior doors, doorways, cabi-
nets, fixtures, and fireplaces.

4. Build the roof planes. If you generate the 
roof automatically, remember to carry 
the roof directives in the walls from the 
first floor up to the top floor for multiple 
story structures. See “Roofs” on page 
473. 

5. Build the framing. See “Framing” on 
page 577. 

6. Build the terrain and landscaping. See 
“Terrain” on page 715.

7. Create the plot plan and plan footprint. 
See “Plot Plans and Plan Footprints” on 
page 731. 

8. Create any necessary views and print the 
plan and use CAD Detail from View to 
create 2D elevations and plan details. 
Use and modify details from the Library, 
as well. See “CAD Details” on page 
1117.

Create the Layout
1. If one does not exist, create a Layout file 

with a title block, placing the border, 
title block, and other text on page 0. See 
“Layout” on page 1235.
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2. Send views to the layout, starting with 
layout page 1. See “Sending Views to 
Layout” on page 1240.

3. Print the plan. See “Printing and Plot-
ting” on page 1211.

Viewing Your Plan
You can see your model in a wide variety of 
different 2D and 3D views. You can display 
more than one view at a time; and in any 
view, you can pan or zoom in or out. See 
“Window and View Tools” on page 879. 
Floor plan view is a 2D view of the model and 
is most commonly used for drawing and 
editing. In floor plan view, each floor displays 
separately and you can only  edit one floor at a 
time; however, you  have extensive control 
over which objects display at any given time, 
can easily switch between floors, and can also 
display items on a second floor for reference. 
See “Multiple Floors” on page 435.

You can create interior and exterior 3D views 
of your model from any perspective. As in 
floor plan view, you can select and edit many 
objects in 3D views and control which objects 
are visible. See “3D Views” on page 887. 

You can also create Floor Overviews that 
show only the current floor plus any floors 
beneath it. Ceilings on the current floor are 
omitted so you can see the interior, visualize 
the relationships between spaces, and plan 
traffic flow.

Framing Overviews display framing in 3D, 
provided that framing has been built. You can 
customize 3D views to serve special purposes 
such as this.

The Cross Section and Elevation camera tools 
create scaled 2D views of a model’s exterior 
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and interior that can be dimensioned and 
annotated. Just as in other views, you can 
select and edit objects in a Cross Section/
Elevation view as well as control which 
objects display. 

A variety of rendering techniques let you 
produce customized 3D views, from detail 
drawings to photorealistic Ray Trace views to 
artistic presentation views. 

Layout
All plan views can be sent to a layout 
where they can be arranged to produce 

full construction documentation. See 
“Sending Views to Layout” on page 1240.

All views can also be exported as a graphic 
image. See “To export a picture” on page 
1141.

Sharing Your Files with Clients
Chief Architect users have the option of 
letting their clients review plan and layout 
files on their own computers, at their 

convenience, using the Chief Architect 
Viewer. The Chief Architect Viewer allows 
clients to open plan and layout files, create 
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3D views, and add text annotations without 
making any changes to the actual model.

To share files using the Chief Architect 
Viewer, first invite a client to request a copy 
of the viewer at www.chiefarchitect.com.

To ensure that all custom backdrops, images 
and material textures are included,, use the 

Backup Entire Plan  tool when 
preparing to send files to your client. See 
“Backup Entire Plan” on page 70.

Getting Help
There are many forms of help 
available in Chief Architect including: 

Tool Tips, the Status Bar, and the online Help 
menu. 

All these forms of help assume you have a 
basic working knowledge of your operating 
system, including how to use a mouse, open, 
close and save files, copy, paste, and right-
click to access contextual menus. Help also 
assumes you are familiar with basic 
computer terminology.

More information is available in the product 
documentation in both printed and electronic 
format and on Chief Architect’s official web 
site,  chiefarchitect.com. 

See “Additional Resources” on page 1307.

Tool Tips
When you move the pointer over a toolbar 
button or menu item, a Tool Tip displays, 
offering a brief description of the tool. More 
information displays in the Status Bar at the 
bottom of the window.

Contextual Help
Online Help is a searchable menu that 
provides information about all of the 

tools in Chief Architect. Select Help> 
Launch Help to open the program’s Help 
and explore the table of contents, browse the 
Index, or Search for keywords.

The Help can also be used to provide instant 
information about toolbar buttons, menu 
items, and objects in your plan.
• When you move the cursor over a toolbar 

button or menu item, a brief summary of 
that tool displays in the Status Bar. Press 
the F1 key to open online Help to a page 
with more information about the tool.

• When an object is selected, edit handles 
display. Place the cursor over an edit han-
dle and press F1 to open online Help to a 
page with information about that handle. 

• Press the Help button in any dialog box 
to open online Help to a page describing 
the options in that dialog. 

Chief Architect strives to make our docu-
mentation as helpful as possible for all of our
customers. Please send any suggestions to 
documentation@chiefarchitect.com.

http://www.chiefarchitect.com/
http://www.chiefarchitect.com/resources/viewerrequest.php
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About Chief Architect
Select Help> About Chief Architect in 
Windows® or Chief Architect> About 
Chief Architect in Mac OS X® to view 
information about your software license, the 
program’s version number, and its release 

date. If your license has an expiration date, it 
will also display here.

Contact information for Chief Architect, Inc. 
is available on the MORE INFORMATION 
panel.

Chief Architect Trial Software
Chief Architect Premier X8 and Chief 
Architect Interiors X8 both have Trial 
versions available for free download at  
chiefarchitect.com. 

The Trial software offers the same 
functionality as a purchased license with a 
few limitations:
• File Saving
• Printing
• File Exporting
• Recording of Walkthroughs
• Printing or Exporting of Materials Lists
• Library Browser restrictions
• Use of the Time Tracker utility
• Use of the CAD Detail from View tool
• Creating or saving Plan Database files
• Exporting of Layer Sets

Full details can be found in the software’s 
Help and at  chiefarchitect.com.

Converting the Trial Version
An installation of the Chief Architect Trial 
software can be converted into a full working 

version of the program at any time by 
purchasing a software license. There are 
several ways to begin this process in the 
Trial: 
• Click the Purchase Full Version Now 

button in any Trial Restriction message 
box.

• Select Help> Purchase Chief 

Architect . 

• Select File> Startup Options  and 
then click the Purchase Full Version 
Now button.

Once you have purchased a license, you can 
activate it while the Trial software is running.

To activate the full version

1. Select Help> Activate Full Version.
2. In the Product Activation dialog, type 

or paste the Product Key associated 
with your software license.

3. Click the Activate Full Version button.

http://www.chiefarchitect.com/products/trial.html
http://www.chiefarchitect.com/support/article/KB-00967/
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Chapter 2:

File Management

Chief Architect reads and edits two main 
document types: .plan files and .layout files. 
The complete 3D model of a structure, 
surrounding terrain and any CAD data 
associated with it are stored in the plan file. 
Data used to create working drawings and 
the links to various views or details are 
stored in the layout file.

All commands related to opening, saving and 
closing plans are located in the File menu. 
You can also open plans from the Startup 
Options dialog. See “Startup Options” on 
page 30.

Just as with files created in other software 
applications, you should back up your plan 
and layout files externally on a regular basis 
to avoid accidental loss of work.

Chapter Contents
•      Compatibility with Previous Versions
•      Organizing Your Files
•      Chief Architect Data
•      Creating a New Plan or Layout
•      Saving, Exporting, and Backing Up Files
•      Thumbnail Images
•      Auto Archive
•      Undo Files
•      Opening and Importing Files
•      Plan Databases
•      Searching for Plans
•      Referenced Files
•      Backup Entire Plan
•      Closing Views and Files
•      Exiting Chief Architect
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Compatibility with Previous Versions
Plans and layout files produced in the 
following programs can all be read by Chief 
Architect X8. 

• Chief Architect® 5.0 through X7

• 3D Home Architect® 3.0 and 4.0

• Chief Architect® Home Edition 5.0
• All Better Homes and Gardens Home 

Designer® products, Interior Designer, 
and Landscaping and Deck Designer, Ver-
sions 6 through 8. 

• All Chief Architect Home Designer® 
products, Interior Designer, and Land-
scaping and Deck Designer, Versions 9 
through 2015.

• Trading Spaces® Design Companion™

Only the .PL1, .LA1, .plan, and .layout files 
from prior versions can be opened in Chief 
Architect X8. A number of steps are 
recommended when migrating plans created 
in an earlier program version into Chief 
Architect X8. Before doing so, see “Before 
You Begin” on page 1319.

Files that have been opened and saved in 
Chief Architect X8 cannot be read by any of 

the program versions listed above. To 
continue to read files in the program in which 
they were created, be sure to create copies of 
your files before opening them in Chief 
Architect X8. 

Plans and layout files produced in the 
Windows® version of Chief Architect X8 can 
be read in the Mac® version, and vice versa. 

Opening Chief Architect Plans 
in Home Designer Programs

Plans created in Chief Architect Versions 5 
through X8 can be opened in the latest Home 
Designer programs for viewing and 
annotating, but not for general editing or 
drawing of architectural objects. 

Plans created in build 11.4 or later of Chief 
Architect X1, or in later program versions, 
can be set to allow limited editability in 
Home Designer programs. When this 
permission is enabled, a Home Designer user 
can use all of their program’s drawing tools 
and can edit objects in the plan that those 
tools can create. If an object cannot be 
created in the Home Designer program, 
however, it will not be editable. 

To protect some objects from being edited 
when a file with editing permission is opened 
in a Home Designer program, consider 
locking their layers. See “Locking Layers” 
on page 145. 

Allow Editing in Select Home Designer 
Products can be enabled or disabled only 
when the file is opened in Chief Architect. 
See “General Plan Defaults Dialog” on page 
88. 

Note: 3D Home Architect 5.0 was not devel-
oped by Chief Architect, Inc. Plans written
using 3D Home Architect 5.0 or later cannot
be read by Chief Architect software.

Chief Architect automatically archives
plans created in prior versions. See
“Auto Archive” on page 59.
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Organizing Your Files
You should keep your plan and layout files 
separate from the support files needed to run 
Chief Architect. To keep files organized, you 
may find it helpful to create a new folder for 
each project.

Chief Architect files may use imported 
images, textures and other custom content 
saved in their own external data files. 
Consider storing copies of all external files in 
the same folder as the plan and layout files 
that use them so that they are easily found. 
See “Adding Library Content” on page 829.

Here is one way to organize your files:
• Create a folder in your Documents direc-

tory called “Chief Architect Plans” or 
another name you prefer. See your operat-
ing system’s Help to learn how to create 
folders.

• Inside this folder, make a new folder for 
each client or project. Save all the files for 
that client or project inside this folder, 
including plan and layout files and refer-
enced external files. See “Saving, Export-
ing, and Backing Up Files” on page 55.

Bear in mind, though, that path names 
exceeding 260 characters cannot be opened 
by Chief Architect. As a result, it is a good 
idea to limit the number of embedded folders 
you use in your file organization method.

Once you understand the file management of 
Chief Architect, you should decide on a 
naming convention that suits your needs. 

To specify a default Save As location

1. Select Edit> Preferences , then 
select New Plans from Category list. See 
“New Plans Panel” on page 103. 

2. Under Open and Save As, click Use this 
Folder. The Browse button becomes 
available.

3. Browse to the folder you plan to save 
your projects in. Click OK.

Chief Architect Data
When Chief Architect X8 is installed, the 
program automatically creates a folder in the 
user Documents directory called Chief 
Architect X8 Data. This folder contains 
important user-specific information saved in 
the following folders and files and should not 
be moved, renamed or deleted: 

• Archives - A folder of automatically 
archived plan and layout files. See “Auto 
Archive” on page 59. 

• Backdrops - A folder of custom back-
drop images. See “3D Backdrops” on 
page 909.

• Hotkeys - A folder of hotkey assign-
ments. See “Hotkeys” on page 138.

It is recommended that each layout file
be saved in the same folder as the plan

file(s) associated with it. See “Managing Lay-
out Links” on page 1255. 
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• Images - A folder of custom images. See 
“Adding Materials and Images” on page 
830.

• lex - A folder of customized dictionaries. 
See “Spell Check” on page 1050.

• Database Libraries - A folder of user 
library data. See “Library Content” on 
page 825.

• Scripts - A folder for custom Ruby 
scripts. See “Ruby Console” on page 
1303.

• Templates - A folder of plan and layout 
template files. See “Template Files” on 
page 84.

• Textures - A folder where you can save 
image files used to create custom material 
textures. See “Creating Materials” on 
page 857. 

• Toolbars - A folder of customized toolbar 
files. See “Toolbar Customization Dia-
log” on page 135. 

• mmaster.mat - The Master Materials List 
file. See “The Master List” on page 1298. 

• sheetSizes.sheet - A list of user-created 
Drawing Sheets. See “Customize Sheet 
Sizes Dialog” on page 1218. 

• units.dat - A list of user-created units of 
measurement. See “Unit Conversions 
Panel” on page 104. 

The name of the Chief Architect X8 Data 
folder cannot be changed, but you can 
specify its location on your computer in the 

Preferences  dialog. It’s best to use a 
location on your local hard drive. See 
“Folders Panel” on page 100.

Just as with your plan and layout files, it is a 
good idea to back up your Chief Architect 
X8 Data folder. 

Because the Chief Architect X8 Data 
contains custom user data, it is not deleted 
when the program is uninstalled. See 
“Uninstalling Chief Architect” on page 19 of 
the User’s Guide.

Creating a New Plan or Layout
To create a new, blank plan, select 
File> New Plan. 

You can also choose New Plan in the 
Startup Options dialog. See “Startup 
Options” on page 30.

By default, a new layout file will be 
assigned the same name of the first 

plan file sent to it, associating the layout files 
with the plan files used. 

New plan and layout files derive their default 
settings the from currently selected template 
files. See “Template Files” on page 84. 

If the Chief Architect X8 Data folder is
renamed, moved or deleted, the pro-

gram will automatically replace it using
default information from the Chief Architect
installation folder. When this occurs, cus-
tomized user settings and custom user
library content will not be available.

Note: Only one layout file can be open at any
given time.
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New, blank plans are called Untitled.plan 
and new, blank layout files, Untitled.layout. 
Unless these files are named and saved, they 
will be lost when closed. See “Saving, 
Exporting, and Backing Up Files” on page 
55.

Units of Measurement
All plan and layout files save measurements 
in either Imperial or metric units. New files 
are created using one or the other, depending 

on the current setting in the Preferences  
dialog. When the program is first installed, 
the Windows OS setting for units determines 
what system is used. See “New Plans Panel” 
on page 103.

A plan or layout file’s unit of measurement 
must be specified before it is created and 
cannot be changed later. If you normally 
work in one set of units but need to create a 
new file using the other, select File> 
Templates> New Plan From Template  
to open a new file using an appropriate 
template without changing your Preferences 

settings. See “Opening Template Files” on 
page 84. 

While it is recommended that you create new 
plans using the type of unit that you plan to 
use, you can display dimensions using any 
type of unit. See “Dimension Preferences 
and Defaults” on page 986.

Template Files
New plan and layout files are created as 
copies of the current template files specified 

in the Preferences  dialog. See 
“Template Files” on page 84. 

Commonly used settings, defaults and other 
information are included in template files. 
You can customize the settings in a template 
file to fit your work style and then save your 
changes as a new template file. See “To 
create your own template plan” on page 85.

If no template has been specified in the 

Preferences  dialog, new plans and 
layouts are created using the system defaults. 
System defaults cannot be modified.

Saving, Exporting, and Backing Up Files
Saving, exporting, and backing up your files 
are three separate tasks that accomplish 
different things: 
• Saving a plan or layout file retains your 

work so that it can be later opened in 
Chief Architect.

• Exporting a file allows you to save certain 
kinds of data in a format that can be used 
by a program other than Chief Architect.

• Backing up your files involves taking 
steps to make sure that your valuable data 
is protected and available when needed. 

Whether you are saving, exporting, or 
backing up your data, it is important that you 
select a location on your computer for the 
files you create, and also specify a short, 
meaningful name that you will be able to 
identify in the future. 
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To save an untitled plan or layout file

1. Select File> Save  to open the Save 
File dialog.

2. Specify a location on your computer 
where you would like to save the file. 
See “Organizing Your Files” on page 53.

3. In the File name text field, type a name 
for the file. 

4. Chief Architect automatically assigns 
the File of type and file extension .plan 
to plan files and .layout to layout files.

5. When both the Save in location and File 
name are correct, click Save. 

Saving Plan and Layout Files
When you first save a new, 
untitled file, you must select a 

location for it on your computer and give it a 
name. There are two options for saving plan 
and layout files: File> Save and File> Save 
As.

Both Save  and Save As  can be used 
to save your plan and layout files; however, 
they accomplish this in two different ways.

• File> Save  saves the current state of 
your plan or layout file without changing 
its name and should normally be used for 
saving your work.

• File> Save As  opens the Save File 
dialog, allowing you to save the plan or 
layout file using a different name or loca-
tion on your computer. 

Initially, all Open  and Save As  
operations go to the “My Documents” folder 
of your computer. After that, the location last 
visited is remembered and subsequent 

Open  or Save As  commands default 
to the directory last used for that operation. 
This path is saved when the program exits. 
The next time Chief Architect is launched, 
these defaults are used.

If you prefer, you can instead specify a 

directory to be used for all Open  or Save 
As  operations in the Preferences  
dialog. See “New Plans Panel” on page 103.

Saved Views
Any previously saved camera views and 
CAD Details associated with the plan are 
saved with the file.

When saving a layout, the program saves all 
pages of the layout, all the links to the 
various views saved in the layout, and all the 
CAD objects added to the .layout file.

By default, a new layout file is assigned the 
same name as the first plan file from which a 
view is sent to it. It is also saved in the same 
directory as the plan file. If no view has been 
sent to a layout, it remains untitled until you 
save it.

Although the program warns you if you
try to exit without saving, you should get

in the habit of saving plan files before exiting
the program.
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Save File Dialog
The Save File dialog uses the operating 
system’s file save dialog format, and is also 
used when exporting files. The dialog name 

may vary, depending on the type of file being 
saved or exported.

A similar Select Folder dialog allows you to 
select a folder to which files can be exported. 

Choose a location on your local 
computer for the file you are saving.

Any existing folders and/or files in the 
current location display here.

In the File Name field, type a name for 
the file. If you select an existing file 

from the space above, its name will display 
here automatically.

When saving a file, the program will 
choose the appropriate file type from 

the Save as type drop-down list. When 
exporting, you may need to choose a specific 
file type.

Saving Revision Files
Revisions are a common aspect of any design 
project. There are a number of possible 
strategies for organizing revision files:
• Prepending the file name;
• Appending the file name;
• Saving revisions in separate folders.

To avoid confusion and potential mistakes, it 
is recommended that you always give files 
unique names - including revision files. If 
you choose to organize your revisions by 
saving them in separate folders, you should 
also give each file a unique name that makes 
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it impossible to confuse it with another file 
saved in a different folder.

Exporting Files
Chief Architect has a number of options for 
exporting and importing information out of 
and your drawings. See “Importing and 
Exporting” on page 1167. 

Often, file export dialogs are simply versions 
of the Save File dialog. 

Similarly, file import dialogs are often 
similar to the Open File dialog. See 
“Importing Files” on page 62. 

Backup Entire Plan

File> Save As  is a simple way to transfer 
a plan or layout to a different location on 
your computer. Bear in mind, though, that 
plan and layout files often reference external 
data files such as imported textures, images, 
and backdrops. These external files are not 

affected when Save As  is used. 

If you transfer a plan file from one computer 
to another, the program will warn you of 
missing files if the external data files used by 
the plan cannot be found when you open it. 

Layouts are also dynamically linked to plan 
files. When transferring layout files to 
another computer, be aware that the plan files 
are also external file references and are not 
actually contained in the layout. 

When transferring plans or layouts to another 
computer that does not have these external 

files, use the Backup Entire Plan  tool. 
See “Backup Entire Plan” on page 70.

Backing Up Your Files
It is always a good idea to create 
backup copies of all your important 

files on your computer. 

It is strongly recommended, however, that 
you never save directly:
• Across a network, such as onto a server;
• Onto removable media such as a USB 

thumb drive, CD, or DVD;
• Across the Internet.

Instead, copy your files to such locations 
only after you have saved them on your 
computer’s hard drive and exited the 
program.

Similarly, you should never open files saved 
in these locations. Copy the files to the local 
hard drive, and then open them. See 
“Opening and Importing Files” on page 61.

Archive folders are used by Chief Architect 
to manage prior versions of your files. You 
should not view these files as a substitute for 
your own backup routine, and should never 
save a file in an archive folder. See “Auto 
Archive” on page 59.

When backing up your Chief Architect files, 
consider backing up not only your .plan and 
.layout files, but your custom user data, as 
well - including library content, toolbar 
configurations, and textures. This custom 
data is all located in the Chief Architect Data 
folder, so it can be easily backed up. See 
“Chief Architect Data” on page 53.

You can, if you wish, create a folder inside 
the Data folder for your .plan and .layout 
files, as well. See “Organizing Your Files” on 
page 53.
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Thumbnail Images
A thumbnail is a miniature image that helps 
identify a file in the Open Plan File dialog in 
Windows and in the Find Plan Assistant. 
Any view of a plan or any layout page can be 
saved as the thumbnail. See “Searching for 
Plans” on page 65.

If thumbnails are enabled in the Preferences 

 dialog, the program automatically creates 
one when you first save a new plan or layout. 
You can choose to generate small or large 
thumbnails. See “File Management Panel” 
on page 99. 

To create a custom thumbnail image

1. You must save the file and give it a name 
before you can save a thumbnail.

2. Create the 2D or 3D view that you want 
to use as a thumbnail for the current file.

3. With the desired view active, select 

File> Save Thumbnail Image .

Thumbnail images are saved in the plan or 
layout file that they are associated with. 

Auto Archive
The first time a plan or layout is saved, Chief 
Architect creates an Archive folder in the 
Chief Architect Data folder. The Archive 
folder contains Auto Save and Archive files. 

The program does not create Auto Save and 
Archive files for untitled plans and layouts. 
In order for these to be created, a file must 
have been previously saved and given a 
name and save location on your computer. 
Further, Archive files are only updated when 
you save your work.

Auto Save and Archive files should not be 
viewed as a substitute for regularly saving 

your work by selecting File> Save  or 
pressing Ctrl + S on the keyboard, nor should 
they be considered an alternative to your own 
file backup routine.

Archive Files
Every time a drawing is saved, Archive files 
that keep a historical archive of your plan are 
automatically created or updated. 

Files can be archived by hour, day or most 
recent save. They are renamed according to 
which archiving option is selected in the 

Preferences  dialog. See “General 
Panel” on page 98. 

Regardless of what archiving option you
select in the Preferences dialog, if you

do not save your work regularly, your archive
files will not be updated.

Previous 
Save
Daily
Hourly

Archive files illustrating all three archive options
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Plan, layout and related files from previous 
versions of the program are automatically 
moved to the archive folder when the plan is 
opened and saved in Chief Architect.

Archive files are meant to be for emergency 
use only. If you must access an archive file, 
open it as you would any other file. See 
“Creating a New Plan or Layout” on page 54. 

As soon as the file is open, use Save As  
to save this file to another location.

Legacy Archive Files
Plan and layout files saved in the current 
program version are not backwards-
compatible: that is, they cannot be opened in 
older versions of the software.

If you open a Chief Architect plan or layout 
file from a previous program version and 

immediately Save  it (not Save As ), 
the Auto Archive utility will create an 
additional archive file using the original 
program version format. This archive file is a 
copy of the original and can still be opened in 
the original program version.

If you open and Save  a Chief Architect 
Version 10 plan or layout file, the legacy 
archive file name will be appended “_v10” to 
help distinguish it from other archived .plan 
or .layout files of the same name, and a copy 
of its archive folder will be created in the 
Chief Architect X8 Archives folder.

Manage Archives
Chief Architect offers two convenient ways 
to access Archive folders. 

• Select File> Manage Auto Archives  
to open the current plan’s Archive folder.

• Click Yes in the Archived Files dialog 
when the program warns you that the 
number of archive files exceeds the Auto 
Archive Files value.

You can also move or delete archived files 
using your operating system. See your oper-
ating system’s Help for more information.

Auto Save Files
As you work, Chief Architect automatically 
creates Auto Save files at regular intervals 
when changes are made to a file but not 

saved by selecting File> Save . 

These Auto Save files are appended 
_auto_save.plan or _auto_save.layout and 
are saved in the Archive folder. 

When you close a file normally, its Auto 
Save file is retained until the next time the 
file is opened - at which time the Auto Save 
file is overwritten.

You can enable Auto Save and set its 

frequency in the Preferences  dialog. See 
“General Panel” on page 98. 

Auto save files created as a result of an 
improper program shutdown are appended 
_auto_save_bak.plan or 
_auto_save_bak.layout.

If your computer shuts down accidentally, 
you can recover some of your work by 
opening the _auto_save_bak file.

Auto Save file after normal shut-down

Auto Save file after abnormal shut-down
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When you reopen a file after a computer shut 
down or system crash, the program will 
notify you if an Auto Save file newer than 
the original file is found and give you the 
option to one that file. 

Even with Auto Save, you should save your 
work manually on a regular basis using any 
of the following methods: 

• Click the Save  button.

• Select File> Save .
• Press Ctrl + S on the keyboard.

Undo Files
Chief Architect stores a set number of copies 
of all open plan file changes, known as undo 
files. Undo files are referenced whenever 

you select Edit> Undo  or Edit> 
Redo . See “Undo and Redo” on page 
257.

Undo files are stored in the Undo Directory, 
which can be specified in the Preferences 

 dialog. See “Folders Panel” on page 100.

The maximum number of Undo files is 
specified in the Maximum Undos value in 
the Preference settings. If you have Undo 
enabled, be sure to define a directory on a 
hard drive with enough space for these files.

When Chief Architect is closed normally, 
any current Undo files are deleted.

Opening and Importing Files
Opening and importing files are often similar 
tasks, but accomplish two very different 
things:
• Opening a file refers to opening it in the 

program in which it was created. Only 
plan or layout files can be opened in Chief 
Architect. See “Compatibility with Previ-
ous Versions” on page 52. 

• Importing a file brings data that was cre-
ated in a different program into Chief 
Architect. A number of different file types 
can be imported into Chief Architect.

Select File> Open Plan to open 
an existing .plan file or File> 

Open Layout to open an existing .layout file 
located on your computer. Chief Architect 
automatically browses to either the directory 
last used or to a specific directory, depending 

on your current Preferences  settings. See 
“New Plans Panel” on page 103.

A file is auto saved only if you have
saved it previously. Auto Save does not

work for unnamed files. 

Before opening a file located on a
removable storage device, server, or

other computer on a network, copy it to your
local machine’s hard drive first.
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Open File Dialog
The Open File dialog uses the operating 
system’s file open dialog format, and is also 
used when importing files. The dialog name 
may vary, depending on your operating 

system and the type of file being opened or 
imported.

A similar Select Folder dialog allows you to 
select an entire folder of files to import. 

Choose the location on your local 
computer for the file you are opening.

Any existing folders and/or files in the 
current location display here.

In the File Name field, type the file’s 
name. If you select the file in the space 

above, its name will automatically display  
here.

When opening or importing a file, the 
program will usually choose the 

appropriate file type from the Save as type 
drop-down list. When importing, you may 
need to choose a specific file type.

Plan files open to the floor that was active 
when the file was last saved and closed; 
layout files open to the page that was active.  

Importing Files
Chief Architect has a number of options for 
exporting and importing information out of 
and into your drawings. Often, file import 
dialogs are simply versions of the Open File 
dialog. See “Importing and Exporting” on 
page 1167. 

Similarly, file export dialogs are often similar 
to the Save File dialog. See “Exporting 

1

2

3

4



Plan Databases

 63

Files” on page 58. 

Recently Opened Files
A list of recently opened and saved plan and 
layout files can be accessed by selecting 
File> Open Recent Files. Select one of these 
files to open it without using the Open File 
dialog. 

The maximum number of recent files listed 
in the File menu can be changed in the 

Preferences  dialog. You can also 
specify that the recent files list display at the 
bottom of the File menu rather than in a 
submenu. See “File Management Panel” on 
page 99.

The names of recent files also display in the 
Startup Options dialog. Click on the name 
of a file to open it. See “Startup Options” on 
page 30.

Plan Databases
A Plan Database is a collection of plan files 
along with search information about those 
files. You can create one or more Plan 
Databases and use them to find drawings that 

you have created that meet a set of search 
criteria that you specify. See “Searching for 
Plans” on page 65. 

Creating a Plan Database File
Select Tools> Plan Database> 
Create Plan Database to create a new 

plan database file that can be used to search 

for plans using the Plan Find Assistant. The 
Create Plan Database dialog opens.

 

Use the Database File field to name the 
plan database file to be created. Click 

the Browse button to save this file at the 
location of your choice, as well as name it. 

Specify the Plan Search Path, which is 
the pathname of the folder where plans 

to be included in the plan database are saved. 

Any plan files in this folder will be added to 
the plan database. Click the Browse button to 
navigate to a folder on your computer.

The Include Subfolders checkbox 
allows you to specify whether or not the 

search looks only in the Plan Search Path or 
if it also searches any subfolders found.

1
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• Check Use Relative Path if you antici-
pate moving the folder containing the 
database and plans to another location. As 
long as the database and the plans it refer-
ences remain in the same folder, that 
folder can be moved to another location.

When you click OK, the program searches 
for plan files and adds them to the plan 
database file. The program must read each 

plan and analyze it so this process may take 
some time. 

You can Cancel the search process at any 
time. If you do, your plan database will have 
incomplete information and will not contain 
entries for all plans in your search folder. 
When all plans have been found and added to 
the plan database, the program automatically 
opens the new plan database file for 
modification.

Editing a Plan Database File
Once a plan database file is created, it 
can be modified. Select Tools> Plan 

Database> Edit Plan Database, then select 
the plan database file you want to modify. 

Click OK to open the Edit Plan Database 
dialog. You can edit any of the information in 
the plan database and add and remove plans 
from the database.

Plans in the Database - All plans that 
currently have information stored in the 

plan database are listed here.

• Click Add Plan to select a plan file to add 
to the plan database.

1
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• Click Remove to remove the currently 
selected plan from the plan database.

Plan Information - Information about 
the selected plan displays and can be 

edited here. This information displays when 
a plan is found and selected using the Search 
for Plans  tool.
• The Thumbnail preview image of the 

selected plan displays to the right. See 
“Thumbnail Images” on page 59.

• Select a plan Style from the drop down 
list. 

• Click the Add Style button to add the 
name of a style to the list.

• Enter the Price range for this plan.
• The Area is automatically calculated by 

the program based on the living area of 
the plan when it is added to the database. 
You can enter a different value if you 
wish.

• The number of Bedrooms is automati-
cally calculated when a plan is added to 
the database. You can enter a different 
number if you wish.

• The number of Baths is automatically 
calculated when a plan is added to the 
database. You enter a different number if 
you wish.

• The number of Floors is automatically 
calculated when a plan is added to the 
database. You can enter a different num-
ber of floors if you wish.

• The selected plan file’s Path name dis-
plays here.

• Click Select File to relink the selected 
plan to a file on your computer. If a plan 
file is renamed, moved, or removed from 
your system, the plan database will be 
unable to locate it. You must then relink 
the plan database to the file or remove it 
to keep the plan database information 
accurate.

• Click Open Plan to open the selected 
plan. Opening a plan closes the Plan 
Database dialog. If you have not saved 
any changes you made before clicking the 
Open Plan button, you are asked to do so 
before you continue.

• Enter a Description for the plan, if 
desired. 

Searching for Plans
Select Tools> Plan Database> 
Search for Plans to open the Find 

Plan Assistant, which helps you search 
specific plan database files based on search 
parameters that you define. 

At the bottom of each page, the number of 
plans that match your current search 

parameters displays. As you modify the 
parameters, this number increases or 
decreases as matching plans are found. If this 
number is zero, the Next button will be 
disabled. 

On any page, click the Back button to 
modify any  previously selected parameters. 

2
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Find Plan Assistant
The Find Plan Assistant can be used to 
search for plans using stored information 
about each plan, such as the style of 
construction and the number of bedrooms 
and other room types. 

When you open the Find Plan Assistant, 
choose a plan database to search. Click the 
Browse button to select a plan database. 
Once a plan database is selected, click Next 
and proceed through the Find Plan 
Assistant. 

House Style

Select a style of house from the drop-
down list.

Specify the maximum number of floors 
that you would like. 

Specify the minimum and maximum 
number of bedrooms that you would 

like. 

The number of plans in the database 
that match your search parameters thus 

far displays here for reference. 

Click Next to continue. 
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House Size

Specify the minimum and maximum 
number of bathrooms you would like. 

Specify the minimum and maximum 
number of square feet that you would 

like. 

Define a price range by specifying 
Minimum and Maximum prices.  

The number of plans in the database 
that match your search parameters thus 

far displays here for reference. 

Click Next to continue. 
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Plan Details

Click on the name of a plan to select it 
and view information about it.

Basic information about the selected 
plan display here. 

A preview of the selected plan displays 
here. 

A written description of the selected 
plan provides additional details 

displays here. 

Click Next to continue, then click Finish to 
view the selected plan. 

Referenced Files
Chief Architect plan and layout files often 
reference a variety of external files for added 

detail, including: 
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• Material Textures
• Material Bump Maps
• Images
• Plant Images
• 3D Backdrops
• Picture Files
• PDF Files

Whenever any view in a plan or any page in a 
layout is opened, the program checks for 
referenced files used in that view and will 
notify you if any of those files cannot be 
found by opening the Missing Files dialog.

The Missing Files dialog will also open 
whenever you Export 3D Model, Export 
POV-Ray, or Export VRML. See “Importing 
and Exporting” on page 1167. 

If a layout file is missing referenced files on 
pages that you do not view during the current 
session, this dialog may also open when you 
print the layout. See “Layout” on page 1235. 

You can also open this dialog at any time by 
selecting Tools> Checks> Missing Files. 
When accessed this way, all missing files 
associated with the current file are listed: not 
just those used in the current view.

Missing Files Dialog

The table lists any Missing Files as well 
as useful information about each: 

• Object Type indicates how the missing 
file is used in the program

• Object Name states the name of the 
object in CA that references the file.

• Object Location indicates where in the 
file the object can be found.

• The next column indicates whether a 
missing texture is in use in the plan. 

• File Path states the last known location of 
the missing file on your computer system.

Click on a line item in the table to select it 
and resolve it using the options on the right. 
Multiple line items can be selected; however, 
the selections on the right may be limited. 
See “Shift and Ctrl Select” on page 186.

The buttons on the right offer options 
for resolving a selected missing file. 

The names of these buttons will vary some-
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what, depending on the type of file(s) 
selected in the list on the left 
• Click the top Replace Object button to 

replace any instances of an object or 
material referencing the selected missing 
file with a different object or material 
from the library. Not available for bump 
maps, PDF files, or picture files. 

• Click the Replace File button to open the 
Browse for Missing File dialog and 
select a file saved on your system to 
replace the missing one. See “Opening 
and Importing Files” on page 61.

• Click the Delete Object button to remove 
the object or material referencing the 

missing file from the plan. Not available 
for material textures that are In Use. 

• Click the Add Search Directory button to 
direct the program to a particular folder to 
search for missing files in. The list of 
Search folders can be reset in the 

Preferences  dialog. See “Reset 
Options Panel” on page 126.

You can prevent this dialog from opening 
automatically by checking Do not display 
missing files again during this session at 
the bottom of the dialog. This option is not 
available when the dialog is opened 
manually.

Backup Entire Plan
Because Chief Architect plans and 
layouts often contain many references 

to other external files, it is necessary to copy 
all the associated files to a new location 
when a plan or layout is moved. You can do 
this easily by selecting File> Backup Entire 
Plan.

Backing up an entire plan or layout is 
important when:
• Migrating legacy files created in older 

program versions. 
• Transferring files to another computer or 

sending them to another user. 
• Archiving or backing up your work.

To back up a plan or layout

1. To copy all associated plan or layout 
files to a new directory, select File> 
Backup Entire Plan . The Backup 
Entire Plan dialog opens.

•  Choose Backup All Files to copy the 
plan or layout file and all externally 
referenced files such as linked plan 
files, inserted picture files, metafiles, 
.pdf files, and texture, image, back-
drop, and bump map graphics files. 

•  Choose Backup Plan Files Only to 
copy all associated plan files and any 

Note: Always use File> Backup Entire Plan
when sending files to a user of the Chief
Architect Viewer to make sure that they have
all associated data. See “Sharing Your Files
with Clients” on page 48. 
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externally linked files and inserted pic-
ture files, but no graphics or texture 
files. This is best used only when trans-
ferring a file to a computer that already 
has the graphics files installed.

•  Check Send Backup Files to Zip 
Archive to save the files in a zipped 
folder instead of a regular folder.

•  Click OK.
2. The Select the Plan Backup Folder 

dialog opens next. This is a typical Save 
File dialog. See “Saving, Exporting, and 
Backing Up Files” on page 55.

3. Navigate to a folder on your system and 
select it. If you did not opt to save the 
files in a zipped folder, the destination 
folder must be empty. 

4. With the destination folder for the 
backup selected, click OK. 

Returning Viewer Files
When customers review and annotate files 
using the Chief Architect Viewer, they only 
need to return the .plan and/or .layout files. 
The associated files do not need to be 
returned.

Closing Views and Files
There are several ways to close a view 
window:
• Select File> Close to close the active win-

dow. 
• Press Ctrl + W or Ctrl + F4 on the 

keyboard to close the active window.
• Click the Close button in the active 

view’s title bar or in any view’s tab.
• A tabbed view can be closed by clicking 

on its tab using the middle mouse button.

• Select File> Close All Views to close all 
currently open view windows instead of 
just the active window. 

If a plan has only one view window open and 
you try to close it, the program will prompt 
you to save before closing if there are any 
unsaved changes. Edited cross section/
elevation views also prompt you to save 
before closing. 

Exiting Chief Architect
Select File> Exit to exit the program. If you 
have not saved any open plans, you are 

reminded to do so. It is better to save your 
work before exiting than to save on exit. 

When Send Backup to Zip Archive is
unchecked, you must select an empty

folder for the Backup Entire Plan feature to
work. If you select an existing folder that is
not empty, the backup is cancelled.

Although the program warns you if you
try to exit without saving, you should get

in the habit of saving plan files before exiting. 
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When you exit from the program using File> 
Exit, all Autosave files and Undo files are 
automatically deleted. 

On a Mac, if you click the program window’s 
red Close button, the window will close but 

the program itself will continue to run. To 
close it down completely, right-click on its 
icon on the Dock and select Quit from the 
contextual menu.
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Chapter 3:

Preferences and
Default Settings

Preferences are global settings that affect the 
functionality and appearance of the Chief 
Architect environment, while default settings 
control what objects look like when they are 
initially created. You can save time and 
increase your productivity by becoming 
familiar with these settings and customizing 
them before you begin a new project or as 
needed thereafter.

Chapter Contents
•      Default Settings vs Preferences
•      Dynamic Defaults
•      Set as Default
•      Multiple Saved Defaults
•      Annotation Sets
•      Exporting and Importing Annotation Sets
•      Template Files
•      Importing Default Settings
•      Reset to Defaults
•      General Plan Defaults Dialog
•      Preferences Dialog
•      Dialog Number/Angle Style Dialog

If you regularly use the same custom-
ized settings, it is a good idea to save

them in a template plan. See “To create your
own template plan” on page 85.
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Default Settings vs Preferences
Default and preference settings have 
important effects on how the tools in Chief 
Architect function. Default settings are file 
specific, while Preferences are global, taking 
effect regardless of what file is open. 

Defaults and Preferences can be customized 
to suit your needs and improve your 
efficiency, so it is recommended that you 
become familiar with them and learn how 
you can use them to your advantage.

Default Settings
Default settings determine the initial 
characteristics of objects when they 

are first drawn. For example, when you place 
a base cabinet in a plan, its size, materials, 
front items, hardware and fill style are 
determined by settings in the Base Cabinet 
Defaults dialog.

Some defaults affect the structure of your 
model: for example, Floor, Foundation, 
Framing, and Wall defaults. 

Defaults are file-specific, which means that 
any changes that you make to the default 
settings in one plan or layout file will have 
no effect on other plans or layout files. You 
can, however, import the defaults settings 
saved in one plan file into another. See 
“Importing Default Settings” on page 86. 

Default settings are an important aspect of 
template files, which determine the initial 
settings of new plan and layout files and can 
be used to save you considerable time. See 
“Template Files” on page 84. 

You can access a complete list of the various 
default settings in the current plan or layout 

file by selecting Edit> Default Settings  
from the menu.

• Click the + beside a category to expand it 
and access the defaults for items related to 
that category.

• To open the defaults dialog associated 
with an item in the list, double-click on 
the line item, or click on the item and then 
click the Edit button.

• General CAD defaults are view-specific 
and are only available in views where 
CAD objects can drawn. See “CAD 
Defaults Dialog” on page 1072. 

Many defaults dialogs can also be opened by 
double-clicking on a parent and/or child 
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toolbar button of a tool affected by the 
settings in that dialog. For example, you can:

• Double-click the Cabinet Tools  par-
ent button to open the Defaults Settings 
dialog for Cabinet tools only;

• Double-click the Base Cabinet  child 
button to open the Base Cabinet Defaults 
dialog.

A few defaults dialogs, such as CAD and 
Layer Set Defaults, do not have a parent or 
child tool associated with them. You can add 
optional buttons to your toolbars to quickly 
access these dialogs. See “To add a button to 
a toolbar” on page 132. 

Most items have one defaults dialog that 
affects all objects of that type. Manual 
Dimensions and the Text, Callouts, and 
Markers tools, on the other hand, support 
multiple Saved Defaults. If you double-click 
one of these line items, a Saved Defaults 
dialog will open, allowing you to access and 
manage all defaults associated with that item. 
See “Multiple Saved Defaults” on page 77.

Preferences
Preference settings influence the 
overall environment of the program, 

such as what the interface looks like, how the 
tools are accessed, and the basic rules 
governing how objects are drawn and edited. 
See “Preferences Dialog” on page 90. 

Unlike default settings, Preferences are 
global, which means that any changes that 

you make to them will take effect in all plan 
and layout files. 

To access the Preferences dialog, select 

Edit> Preferences  from the menu.

Region and Language Settings
There are a few formatting considerations in 
Chief Architect that are set based on your  
operating system’s Region settings: 
• Units of measurement - When you first 

install and launch the program, your tem-
plate plan and layout files will be set to 
use either Imperial or metric units, 
depending on your operating system set-
tings. See “New Plans Panel” on page 
103. 

• Currency - The currency associated with 
your Region settings will be used in the 
Materials List, Components dialogs, and 
Loan Calculator. See “Materials Lists” on 
page 1283 and “Loan Calculator” on page 
1132. 

• Decimal mark format - Depending on 
your operating system settings, either a 
dot or a comma will be used in dimension 
lines, dialogs, and anywhere the program 
can display a numeric value using deci-
mals.

• Thousands separator - Depending on 
your operating system settings, a comma, 
dot, or non breaking space may be speci-
fied as a thousands separator, or digit 
grouping symbol, for dimension lines. 

• Date format - The format of date text 
macros and Sun Angle date labels vary 
depending on your operating system set-
tings. See “Text Macros” on page 1064 
and “Sun Angles” on page 944.

You can create Hotkeys to open any of
the defaults dialogs listed in the Default

Settings dialog. See “Hotkeys” on page 138.
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Dynamic Defaults
Dynamic defaults are values that can be 
changed globally throughout a model. 
• If you change a dynamic default value in 

a defaults dialog, all objects of that type 
that are set to use the default will update 
automatically to use the new value.

• Any objects of that type that are not using 
the default value because of editing will 
not be affected if you change the default. 

Dynamic defaults are found in the default 
dialogs of a variety of objects, including 
dimension lines, walls, doors, cabinets and 
rooms.

Materials are another example of an attribute 
that uses Dynamic Defaults. See “Material 
Defaults” on page 848.

In object specification dialogs, dynamic 
defaults are followed by either a (D) in the 
value field or a Default checkbox.

To edit a dynamic default, delete the (D) or 
remove the check from Default box and type 
the desired value. 

To reset a value back to the dynamic default, 
type the letter D in the field or click the 
Default checkbox.

Set as Default
The Set as Default edit button allows 
you to apply the settings in a selected 

object’s specification dialog to the defaults 
for that type of object. 

Set as Default  affects the attributes of 
both subsequently created objects as well as 
any objects using Dynamic Defaults. See 
“Dynamic Defaults” on page 76. 

Attributes of already existing objects that are 
not Dynamic Defaults are not affected when 

Set as Default  is used, so it should not be 
viewed as an alternative to setting up defaults 
before you begin drawing. See “Default 
Settings” on page 74. 

The Set as Default  edit tool is not 
available for Terrain Paths, including 
Sidewalks, Streams, Terrain Walls and 
Terrain Curbs. See “Terrain Wall and Curb 
Tools” on page 727. 
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Multiple Saved Defaults
While most objects in Chief Architect 
have one defaults dialog that controls 

how all objects of that type are created in a 
given plan, Manual Dimensions, Rich Text, 
Text, Callouts, Markers, and Arrows can 
each have Multiple Saved Defaults rather 
than just one. This lets you set these tools up 
for more than one requirement or task in 
advance, and then simply specify which 
default you want to use as the Active Default 
at any given time. See “Annotation Sets” on 
page 80. 

Structural Member Reporting and Ray Trace 
Options also have Multiple Saved Defaults. 
Rather than affect drawing tools, though, 
these affect the information in Materials 
Lists and the properties of ray trace views. 

Using Multiple Saved Defaults
There are a couple of different approaches to 
using Multiple Saved Defaults:
• They can be created for specific tasks. For 

example, dimension defaults for a site 
plan can use a large font size and a format 
using feet, yards, or meters, while the 
defaults for cabinet elevations can use a 
smaller font and inches or millimeters.

• They can be set up for use at particular 
scales, such as 1/4” = 1’ and 1/2” = 1’, or 
1 mm = 50 mm and 1 mm = 100 mm.

• You can also use a combination of these 
two strategies.

A selection of Multiple Saved Defaults are 
included in the template plans installed with 
Chief Architect to serve as examples of these 

two approaches. You can use these sets as 
they are, customize them, or create new ones.

Saved Defaults are all view-specific. This 
means that if a Saved Default is active in a 

particular saved view, and you then Save  
your work and close the view, that Saved 
Default will be active the next time you open 
the view - regardless of what is in use in 
other views. 

The settings associated with Saved Defaults 
are static, which means that objects created 
while one Saved Default is active are not 
affected when you switch to another Active 
Default. See “Dynamic Defaults” on page 
76. 

Manually-drawn dimension lines are not 
affected when you switch Active Defaults; 
however, they do use dynamic defaults 
inherited from a Saved Dimension Defaults 
and will be affected if that Saved Dimension 
Defaults is edited. See “Dimension Defaults 
Dialog” on page 987. 

Text Styles
In addition to multiple saved defaults, 
objects that include text within them as well 
as object labels can be assigned a Text Style, 
which includes properties like font, color and 
size. See “Text Styles” on page 1061.

if an object is placed into a new file,
either from the library or by copy/past-

ing, its association with a Saved Dimension
Default and/or a Text Style is preserved. See
“Copying and Pasting Objects” on page 170
and “Add to Library” on page 1113. 
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Objects that have text within them are not 
affected if you assign a new Text Style to 
their Active Defaults. If a given Text Style is 

modified, however, any objects that it is 
assigned to will be affected. 

Saved Defaults Dialog
Tools that have Multiple Saved Defaults 
have a Saved Defaults dialog which lets 
you: 
• Make changes to existing Saved Defaults.
• Add and remove Saved Defaults from the 

list of those available in the current file.
• Specify which Saved Default is active.

To open the Saved Defaults dialog for any 
annotation object type, double-click on its 
name in the Default Settings dialog. See 
“Default Settings” on page 74.

If Edit Active Default on Double-Click is 
selected in the Preferences dialog, you can 
also access the Saved Defaults dialog by 
double-clicking on the toolbar button for one 
of these object types. See “General Panel” on 
page 98.

A list of the Available Saved Defaults 
for the selected object type displays and 

can be managed here. 
• Click on the name of a Saved Default for 

the selected object type in the list to select 
it.

• Click the Edit button to open the defaults 
dialog for the selected Saved Default.

• Click the Copy button to create a new 
Saved Default. The new Saved Default is 
a copy of the one selected in the Name 
field.

• In the New Default Name dialog, which 
opens when you click Copy, type a short, 
descriptive, unique name for the new 
saved default. The Defaults dialog for the 
new Saved Default opens next. Make any 
needed changes to its settings and click 
OK. 

• Click the Rename button to open the 
Rename Current Default dialog and type 
a new name for the current Saved Default. 
Names are case-sensitive and must be 
unique.

• Click the Delete button to remove the 
selected Saved Default from the list. 
Saved Defaults assigned to an Annotation 
Set in the current file cannot be deleted, 
nor can a Saved Dimension Default used 
by a dimension line. See “Dimension Line 
Specification Dialog” on page 1021.

The Currently Active Saved Defaults 
for the selected object type displays and 

can be changed here. 

1
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• Select a Saved Default from the drop-
down list to make it active when you click 
OK. 

• Click the Edit button to open the Defaults 
dialog for the Saved Default selected in 
the drop-down list. Click Cancel to close the dialog without 

retaining any of your changes. Any newly 
added Saved Defaults will not be retained. 

Active Defaults Dialog
You can view and modify the defaults 
that are currently active by clicking 

the Active Defaults toolbar button to open 

the Active Defaults dialog. This dialog can 
also be accessed via the Default Settings 
dialog. 

The Current Active Defaults for each 
of the annotation object types.display 

and can be changed here. The Current CAD 
Layer and active Layer Set can also be 
specified. 
• Select the Current CAD Layer from the 

drop-down list or click the Define button 
to open the Layer Display Options dia-
log. See “Layer Sets” on page 146. 

• Select a Saved Default from the drop-
down list associated with any of the anno-
tation object types.

• Click the Add button beside any Saved 
Default to create a new Saved Default for 
the object type based on the one that is 
currently selected. Type a short, descrip-
tive name for the new Saved Default, then 
modify its settings as needed.

Note: if you click Cancel or press Esc in the
Saved Defaults dialog after editing, renaming,
or copying a Saved Default, your changes will
not be retained.

1



80

Chief Architect X8 Reference Manual

• Click the Edit button to open the defaults 
dialog for the object type and make any 
changes you may need to the selected 
Saved Default. 

• Click the Delete button to remove the 
selected Saved Default from the list of 
those available in the plan or layout. Note 
that if a Saved Default is either in use or 
assigned to an Annotation Set, it cannot 
be deleted.

• Select a Layer Set from the drop-down 
list or click the Define button to open the 
Layer Display Options dialog. 

Annotation Sets -

• The Annotation Set that you are Cur-
rently Using is selected in the drop-down 
list. If “Active Defaults” is selected, the 

current collection of Active Defaults set-
tings above is not associated with a saved 
Annotation Set.

• Select a different Annotation Set from the 
drop-down list to activate it when you 
click OK.

• Click the Define button to open the 
Annotation Sets dialog. See “Annotation 
Sets Dialog” on page 81.

• When “Active Defaults” is selected, you 
can click the Save Current Active 
Defaults button to create a new Annota-
tion Set based on the current Active 
Defaults. 

Annotation Sets
Annotation Sets are simply a fast, easy way 
to switch from one collection of Saved 
Defaults created for one particular purpose to 
another collection set up for a different task. 

Annotation Sets include defaults for: 
manually-drawn Dimensions, Text, Callouts, 
Markers, Arrows, the Current CAD Layer, as 
well as the Active Layer Set. Multiple 
Annotation Sets can be saved in any plan, 
each for a specific purpose, and you can 
quickly switch from one set to another as you 
work.  

Many of the objects included in Annotation 
Sets can be assigned a Text Style.

Saved Defaults are all view-specific; so by 
extension, Annotation Sets are as well. This 

means that if an Annotation Set is active in a 

particular saved view, and you then Save  
your work and close the view, that Set will be 
active the next time you open the view - 
regardless of what is in use in other views.

Using Annotation Sets
As with Saved Defaults, there are a couple of 
approaches to using Annotation Sets:
• They can be created for specific tasks. 
• They can be set up for use at particular 

scales.
• You can also use a combination of these 

two strategies.

2

Saved Defaults can also be managed in
the Annotation Sets dialog, and can be

grouped into Annotation Sets for specific
drawing tasks.
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A selection of Annotation Sets are included 
in the template plans installed with Chief 
Architect to serve as examples of these two 
approaches. You can use these sets as they 
are, customize them, or create new Sets. 

Activating an Annotation Set
An Annotation Set can be selected in any 
view that supports Dimensions, CAD, and 
Text: floor plan view, cross section/elevation 
views, CAD Details, and Wall Details. 

Activating an Annotation Set really means 
activating all of the Saved Defaults and layer 
settings associated with it. An Annotation 
Set can be activated in either of three ways:
• Select a set from the Active Annotation 

Set Control drop-down. 
• Select an Annotation Set from the Cur-

rently Using drop-down list in the Active 
Defaults dialog. See “Active Defaults 
Dialog” on page 79. 

• Open a saved view in which the Annota-
tion Set was previously active. 

Using Active Defaults
If a particular Annotation Set is active and 
you switch one of its Saved Defaults to a 
different Saved Default, the Annotation Set 
will no longer be considered active and 
“Using Active Defaults” will display in the 
the Active Annotation Set Control drop-
down. This is not a problem: it simply means 
that you aren’t using all of the defaults that 
you may have set up for a specific purpose.

You can view and modify the currently active 
Saved Defaults in the Active Defaults 
dialog. You can also save the current defaults 
as an Annotation Set for future use, if you 
wish. See “Active Defaults Dialog” on page 
79. 

Creating Annotation Sets
There are two ways to create a new 
Annotation Set: 
• Click either the New or the Copy button 

in the Annotation Sets dialog. 
• Click the Save Current Active Defaults 

button in the Active Defaults dialog. 

Annotation Sets Dialog
The Annotation Sets dialog lists the 
Annotation Sets available in the 

current plan file and lets you add, remove, 
edit, and save them. 

To open the Annotation Sets dialog, select 

Edit> Default Settings  from the menu. 

Select “Annotation Sets” and click the Edit 
button. See “Default Settings” on page 74. 

You can also open this dialog by clicking the 

Annotation Sets  button, which you can 
add to your toolbars. See “To add a button to 
a toolbar” on page 132.
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A list of the Annotation Sets available 
in the current plan or layout display 

here.  
• Click on an item in the list to select it. 
• The selected set is highlighted and dis-

plays in the Name field to the right.
• When a set is selected, its name and other 

attributes can be edited. 
• Click the New button below the list to a 

new Annotation Set. Type a short, 
descriptive name for the new set in the 
Name field to the right.

• Click the Copy button below the list to 
create a copy of the Annotation Set. Type 
a short, descriptive name for the new set 
in the Name field to the right. 

• Click the Delete button to delete the 
selected Annotation Set from the list.

Information about the Selected 
Annotation Set displays and can be 

modified here. 

• The name of the Selected Annotation Set 
displays here. You can change the 
selected set’s name by typing in the text 
field. Names are case-insensitive and 
must be unique. 

• Select the Current CAD Layer from the 
drop-down list or click the Define button 
to open the Layer Display Options dia-
log. See “Current CAD Layer” on page 
1076.

• For each annotation object type, select a 
Saved Default from the drop-down list. 

• Click the Add button to create a new 
Saved Default for the object type based 
on the currently selected Saved Default. 
Type a short, descriptive name for the 
new Saved Default, then modify its set-
tings as needed.

• Click the Edit button to open the defaults 
dialog for the object type and make any 
changes you may need to the selected 
Saved Default. 

1
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• Click the Delete button to remove the 
selected saved default from the list of 
those available in the plan or layout. 

• Select a Layer Set from the drop-down 
list. See “Layer Sets” on page 146. 

• When “Use Active Layer Set” is selected, 
the layer set in use in the current view 
does not change when the Selected Anno-

tation Set is made active. This option is 
the default for installed Annotation Sets. 

• Click the Define button to open the Layer 
Display Options dialog. Not available 
when “Use Active Layer Set” is selected. 
See “Layer Display Options Dialog” on 
page 149. 

Exporting and Importing Annotation Sets
Annotation Sets can be exported 
out of a plan or layout file and 

then imported into other plans or layouts.

When you export Annotation Sets, all of the 
Multiple Saved Defaults in the file are 
exported, regardless of whether they are used 
by an Annotation Set. See “Multiple Saved 
Defaults” on page 77. 

Exporting Annotation Sets
To export a plan or layout’s 
Annotation Sets, open that file and 

then select File> Export> Export 
Annotation Sets. The Export Annotation 
Sets dialog is a typical Save As dialog that 
lets you specify the exported file’s name and 
its saved location on your computer. See 
“Exporting Files” on page 58.

Exported Annotation Sets files use the 
.cadefs file format. Information exported in 
.cadefs files includes:
• All Annotation Sets saved in the current 

file.
• All Saved Defaults for Manual Dimen-

sions, Text, Rich Text, Callouts, Markers, 
and Arrows. 

• All Layer Sets that are associated with an 
Annotation Set. Layer Sets not associated 
with an Annotation Set are not exported.

Import Annotation Sets Dialog
To import Annotation Sets into a plan 
or layout, open that file and then select 

File> Import> Import Annotation Sets. 
After you select a file to import, the Import 
Annotation Sets dialog opens.

The current File pathname displays 
here. Click the Browse button and 

browse to the location of a different .cadefs 
file you wish to import. If the pathname is 

1
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not that of a valid .cadefs file, this text will 
display in red. 

Specify how Imported Defaults - 
including Annotation Sets and Layer 

Sets - are handled. 
• Check Overwrite Existing Defaults to 

delete all Saved Defaults for Text, Rich 
Text, Callouts, Markers, Arrows, and 
Dimensions in the file and replace them 
with imported Saved Defaults. When this 
is unchecked, which it is by default, exist-
ing defaults are retained along with those 
that are imported. See “Multiple Saved 
Defaults” on page 77. 

Specify how Saved Defaults with 
Duplicate Names are handled. 

• Choose Replace Existing Defaults to 
replace any Saved Defaults already pres-
ent in the plan. 

• Choose Rename Duplicate Defaults to 
retain existing Saved Defaults and rename 
imported defaults by appending them 
with a “2”. If subsequent Saved Defaults 
with duplicate names are imported, the 
number will increase.

Specify how Imported Layer Sets are 
handled when duplicates are found. 

• Select Use Existing Layer Sets to retain 
the sets that are already present rather 
than overwrite them.

• Select Replace Existing Layer Sets to 
overwrite the sets that are already present, 
replacing them with imported sets.

• Select Rename Duplicate Layer Sets to 
retain existing layer sets and rename 
imported sets by appending them with a 
“2”.

Template Files
When Chief Architect opens a new, 
blank plan or layout file, the new file 

is actually a copy of a template using either 
metric or Imperial units of measurement and 
predefined default settings, layer settings, 
wall definitions, and page setup information. 

Once you are familiar with the default 
settings in Chief Architect, you can create 
template files to fit your needs, store them in 
the Templates directory, and even specify 
them as the defaults for new files.

If you make changes to a default template 
file, all subsequently created plans or layouts 
will use the new default settings.

Opening Template Files
If you have more than one plan or layout 
configuration that you regularly use, you can 

Note: Saved Dimension Defaults are not
overwritten when Annotation Sets are
imported - even when Overwrite Existing
Defaults is checked - if dimensions are pres-
ent in the active file. 

2

3

4

 If a template file is not specified or can-
not be found, the program starts new

plans using a set of system defined defaults.
System defaults are very basic and unlikely
to meet your drawing needs, so you should
always specify a template plan and layout.
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create multiple template files and open 
whichever is needed for a given project.

To create a new plan or layout file using a 
template other than the current preference, 
choose File> Templates> New Plan from 
Template  or New Layout from 
Template . The program browses to the 
Templates directory specified in the 

Preferences  dialog. See “Folders Panel” 
on page 100.

Creating Templates
The steps for creating template plans and 
layouts are similar; although, there are fewer 
default settings in layout files, and most 
layout templates include a border and title 
block whereas most plan templates are blank.

To create your own template plan

1. Select File> New Plan .

2. Select Edit> Defaults Settings  and 
open and modify the settings in the 
default dialogs as needed. See “Default 
Settings” on page 74.

3. Select Tools> Display Settings> Dis-
play Options  and create any custom 
layers, layer sets, and layer settings that 
you typically use. See “Layers” on page 
143.

4. Select Edit> Defaults Settings  and 
create any Annotation Sets that you may 
require. See “Annotation Sets” on page 
80.

5. Select Build> Wall> Define Wall 
Types  and create any custom wall 
types that you often use. See “Wall Type 
Definitions Dialog” on page 305. 

6. If you draw anything in the template 
plan, it displays in all new plans created 
with that template.

7. You can insert text macros into the tem-
plate. See “Text Macros” on page 1064.

8. After modifying all your default set-
tings, select File> Templates> Save 
Plan As Template . Name the tem-
plate plan and save it in the Templates 
directory.

9. In the Change Default Template dialog, 
click Yes to use the plan as your default 
template whenever you select File> 
New Plan . Click No if you prefer to 
access this template by selecting File> 
New Plan From Template .

10. The current plan remains untitled, but a 
copy of it is saved for use as a template.

To create your own template layout

1. Select File> New Layout .

2. Select Edit> Defaults Settings  and 
open and modify the settings in the 
default dialogs as needed. See “Default 
Settings” on page 74.

3. Select Tools> Display Settings> Dis-
play Options  and create any custom 

Note: Make sure you use the appropriate
units of measurement when you create a
template plan. The Imperial or metric units
used in the new plan are the same as when
the template was saved.
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layers, layer sets and layer settings that 
you typically use. See “Layers” on page 
143.

4. Select File> Print> Drawing Sheet 
Setup  and specify the desired print 
settings. See “Drawing Sheet Setup Dia-
log” on page 1216.

5. Select Tools> Layout> Page Down  
to go to layout page 0 and use the CAD 
tools to design a border and title block 
that suits your needs. See “Layout Page 
Zero” on page 1261.

To set a template as your default

1. Select Edit> Preferences  and go to 
the NEW PLANS panel of the 
Preferences dialog. See “New Plans 
Panel” on page 103.

2. Click Imperial or Metric Units.

3. Click the Browse button for either the 
plan or layout template.

4. Select a template file from the Templates 
directory or navigate to a different loca-
tion and select a template from there. 

Updating Template Files
To change the default settings in your 
template, you must open the template file as 
though it were a regular plan or layout by 

selecting File> Open Plan  or Open 
Layout .

After the necessary changes are made, select 
File> Templates> Save Plan as 
Template . Select your template from the 
list of files in the Templates directory. When 
the program asks if you want to replace the 
existing file, click Yes.

Importing Default Settings
Default settings are file-specific; 
however, you can transfer many 

important default settings from one plan file 
to another by selecting File> Import> 
Import Default Settings. 

Not all defaults settings saved in a plan can 
be imported from one file to another. For 
example, Electrical, CAD, Floor, Framing, 
Foundation, and General Plan Defaults are 
not imported. 
• Defaults associated with Annotation Sets 

are not imported but can be exported and 
imported separately. See “Exporting and 
Importing Annotation Sets” on page 83.

• Layer Sets can be exported and imported, 
as well. See “Exporting and Importing 
Layer Sets” on page 157. 

• Wall Type Definitions can also be 
exported and imported. See “Exporting 
and Importing Wall Types” on page 308.

If the source file that you import from is from 
an older program version, it may be missing 
settings available in version X8. If a default 
setting is missing, the system default will be 
imported instead. For this reason, it is best to 
review defaults before importing them and to 
avoid importing any defaults that are not 
actually present in the source file. See 
“Template Files” on page 84.
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Bear in mind that some default settings are 
dynamic and, if changed, can affect existing 
objects in the plan. See “Dynamic Defaults” 
on page 76.

To import default settings

1. Open the plan that you would like to 
import default settings into. 

2. Select File> Import> Import Default 
Settings  from the menu.

3. In the Open Plan File dialog, browse to 
and select the plan file that you would 
like to import defaults from and click 
OK. See “Importing Files” on page 62. 

4. In the Import Default Settings dialog:
•  Uncheck the box beside any defaults 

that you do not want to import.
•  Click the Select All button to place 

checks in the boxes beside all defaults 
in the list, or click Clear All to clear all 
of the checkboxes.

•  Multiple line items can be selected by 
Shift+clicking or Ctrl+clicking their 
names. Then check or uncheck the box 
beside any selected item to affect the 
entire selection set. 

•  Use the scroll bar on the right to scroll 
through the list.

•  Click OK to close the dialog and 
import the selected defaults.

Reset to Defaults
Select Edit> Reset to Defaults to open the 
Reset to Defaults dialog. 

This dialog allows you to reset critical 
structural settings in the current plan to the 
default values. 
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The settings can be cleared for the 
current floor or for All Floors.

Specify which settings you want to 
reset to Default.

• Floor and Ceiling Heights - Floor and 
ceiling heights for any room can be 
changed in the Room Specification dia-
log. Check to reset the default values as 

specified in the Floor Defaults dialog. 
See “Floor Defaults Dialog” on page 436.

• Roof Groups - You can specify a room’s 
Roof Group in the Room Specification 
dialog. This builds the roof over this room 
and others in the same Roof Group inde-
pendently from the roof built over other 
parts of the plan. Check to reset to the 
default Roof Group, zero. See “Roof 
Groups” on page 477. 

• Roof Directives - You can specify how 
the roof builds above an exterior wall in 
its Wall Specification dialog. When Roof 
Directives are reset, all items on the ROOF 
panel are unchecked and any value, such 
as the roof pitch, is reset to the default. 
See “Roof Directives in Walls” on page 
477. 

• Wall Top Heights and Wall Bottom 
Heights - Wall shape and height can be 
edited in 3D views. Check to reset wall 
shapes and heights. See “Editing Walls” 
on page 285.

General Plan Defaults Dialog
The settings in the General Plan Defaults 
dialog control basic features of the Chief 
Architect environment in plan files. Just as 
with other default settings, they are file 
specific, which means that they can be set 
differently in individual plan files. To open 
this dialog, select Edit> Default 
Settings , select Plan, and click the Edit 

button, or double-click the Select Objects 
 button.

The General Layout Defaults dialog is 
similar to the General Plan Defaults dialog, 
but has fewer settings and is available in 
layout files only. Its settings, too, are file 
specific.

1
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General Settings - Specify the default 
functionality for a variety of general 

behaviors in the program.
• Check Warn Before Delete Selected 

Item if you want the program to require 
confirmation before an item is deleted. 

• Check Ignore Casing for Opening 
Resize to allow wall openings such as 
doors to be positioned against an inter-

secting wall. Clear this box retain suffi-
cient space for the opening’s specified 
trim width. Not available in layout files.

• Check Allow Editing in Select Home 
Designer Products to allow limited edit-
ing of the current file in compatible Home 
Designer programs. See “Compatibility 
with Previous Versions” on page 52. 

1
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• Check Show Pitch as Degrees to display 
the roof pitch in degrees. Not available in 
layout files.

• The Arrow Key Scroll Distance setting 
determines how far to scroll in floor plan 
view when you press an arrow key. The 
initial default is 12 inches (300 mm). Not 
available in layout files. See “Using the 
Arrow Keys” on page 882.

Specify the Allowed Angles used when 
Angle Snaps are enabled. See “Angle 

Snaps” on page 164.
• Select 15 Degrees to enable Angle Snaps 

in 15° increments.
• Select 7 1/2 Degrees and Additional 

Angles to enable Angle Snaps in 7 ½° 
increments. 

• You can also enter up to eight Additional 
Angles in the fields provided. Click the 
Number Style button to specify the format 
used to enter angles in dialogs. See “Dia-
log Number/Angle Style Dialog” on page 
127.

The Snap Grid allows you to snap 
objects to specific points on-screen as 

they are moved or resized. See “Grid Snaps” 
on page 166.
• Check Use Snap Grid/Units to enable 

Grid Snaps.
• Specify the Snap Unit you wish to use. 

The initial default is 1 inch (10 mm).

• Uncheck Show Snap Grid to turn off the 
display of the Snap Grid, a visual indica-
tor of the location of the snap points. 

• Click the Color bar to specify the Snap 
Grid Color. See “Color Chooser/Select 
Color Dialog” on page 875. 

• Check Display as Dots to display the 
Snap Grid using dots rather than lines. 

You can also click Grid Snaps  
toggle button to turn on/off grid 

snapping or click the Display Reference 
Grid  toggle button to turn on/off the grid 
display. 

Specify how the Living Area label is 
calculated and whether it displays in 

floor plan view. Not available in layout files. 
See “Living Area” on page 339. 
• Select Main Layer to have the Living 

Area calculation measure from the walls’ 
Main Layer.

• Select Surface to have the Living Area 
calculation measure from the walls’ exte-
rior surface.

• Uncheck Show “Living Area” to disable 
the display of the Living Area label. 

Preferences Dialog
The settings in the Preferences 
dialog are global: they apply to all 

plan and layout files and are preserved 
between sessions. To access this dialog, 

select Edit> Preferences in Windows® or 
Chief Architect> Preferences in Mac OS 
X®. Unlike most dialogs in the program, it is 

2

3

It may be helpful to change the Snap
Unit temporarily when working with

large objects such as terrain or small objects
such as molding profiles.

4
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not necessary to have a plan or layout file 
open to access the Preferences dialog. 

The Preferences dialog’s list of panels is 
organized in a tree structure with categories 
and subcategories. A white arrow next to a 
category indicates that it has subcategories. 
Click the arrow to make the subcategories 
visible; to hide them, click the filled arrow.

Preferences dialog panels: 
•      Appearance Panel
•      Colors Panel
•      Font Panel
•      Library Browser Panel
•      Text Panel
•      General Panel
•      File Management Panel
•      Folders Panel

•      Ruby Panel
•      New Plans Panel
•      Layers Panel
•      Unit Conversions Panel
•      Time Tracker Panel
•      Architectural Panel
•      CAD Panel
•      Edit Panel
•      Behaviors Panel
•      Snap Properties Panel
•      Materials List Panel
•      Report Style Panel
•      Master List Panel
•      Categories Panel
•      Render Panel
•      Ray Trace Panel
•      Video Card Status Panel
•      Reset Options Panel
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Appearance Panel

Check Contextual Menus to activate 
contextual menus that display when 

you right-click. See “Contextual Menus” on 
page 38.
• Check Click Twice to Display to require 

two right-clicks on an object before the 
contextual menu displays. This allows the 
first right-click to be used for object 

selection. See “Selecting Objects” on 
page 183. 

In 3D views, the two clicks must be on 
the same object surface in order for the 
contextual menu to display: Clicking on 
two different surfaces of the same object 
is treated like two single-clicks. 

1



Preferences Dialog

 93

Check Status Bar to activate the Status 
Bar at the bottom of the main program 

window. See “The Status Bar” on page 42.
• Check Show Screen Redraw Time to 

display the number of seconds it takes to 
redraw the current view. 

• Check Show Coordinates to display the 
coordinates of your cursor at all times on 
the right side of the Status Bar.

The coordinates’ number style is controlled 
in the Number Style/Angle Style dialog.  
See “Dialog Number/Angle Style Dialog” on 
page 127.

Specify the on-screen display of Line 
Weights. See “Line Weights” on page 

1223. 
• Check Show Line Weights to represent 

line weights on-screen. Depending on 
your zoom factor and your monitor’s res-
olution, lines may appear to be wider on 
screen than when they are printed. Zoom-
ing closer may reflect a more accurate 
idea of the actual line width. 

• Specify the Minimum Display Weight, 
in Pixels. This is the lowest line weight 
possible on screen, regardless of how far 
you zoom out. A Minimum Display 
Weight of 0 is the same as 1. This setting 
is ignored when printing or when Print 
Preview  is enabled.

Display - 

• Images and Pictures - Check Display in 
Color when Possible to display pictures 

and images in color even when Color  
is toggled off. Does not affect the display 
of images in any 3D views aside from 

Vector Views. See “Color On/Off” on 
page 217.

• Menus - Check Show Icons to display 
tool icons next to items in the menus.

• Color Off is - Specify whether views 
appear in Black and White or Grayscale 
when color is toggled off. Does not apply 
to any 3D views aside from Vector Views. 
See “Vector View” on page 952.

Specify whether Dialog Previews use 
the Standard or Vector View 

Rendering Technique by default. See “Dialog 
Preview Panes” on page 41.

Specify how Toolbars present child 
tools when a parent button is clicked.

• Choose Parent-Child to display child 
tools as buttons at the end of the toolbar 
where the parent button resides.

• Choose Drop Down to display child tools 
when the drop-down arrow to the right of 
the parent button is clicked.

• Uncheck Scale Toolbar Icons for High 
DPI to prevent toolbar icons from becom-
ing larger on systems using high DPI res-
olution. When checked, toolbar buttons 
will increase in size when high DPI is 
used.

Uncheck Side Window Drag Docking 
to prevent undocked side windows 

from docking when moved using the mouse. 
A side window can still be docked to its last 
docked location by double-clicking its title 
bar. See “View and Side Windows” on page 
35.
• Top/Bottom Docking - Check the box 

beside a side window’s name to allow it to 
dock on the top and bottom edges of the 

2

3

4
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program window. Does not affect docking 
to the left and right sides.

Specify the Minimum Display Size of 
Dimensions and Labels, in pixels. This 

is the on-screen size and does not affect 
printed or exported output. To use the printed 
scale, set these values to 0 or turn on Print 
Preview . 

• Dimension sizes are set in the Dimension 
Defaults dialog. See “Dimension 
Defaults Dialog” on page 987. 

• Printed label sizes are set in the Schedule 
Defaults dialogs. See “Label Panel” on 
page 1277. 

Colors Panel

Click a color bar to open the Select Color 
dialog. See “Color Chooser/Select Color 
Dialog” on page 875. 
• Specify the Background Color for all 

views except some 3D views. See “Ren-
dering Techniques” on page 951.
The background color for 3D views that 
do not use the Vector View Rendering 
Technique or a backdrop image is set in 
the 3D View Defaults dialog. See “Back-
drop Panel” on page 895.

• Specify the Selection Line Color, which 
is the color of the lines that represent 
object(s) and their edit handles when they 
are selected.

• Specify the Handle Fill Color, which is 
the fill color of the edit handles for 
selected objects.

• Specify the Selection Fill Color, which is 
the fill color for selected objects. Note 
that depending on the fill assigned to a 
selected object, its Selection Fill color 
may vary.

• Specify the Editing Transparency, 
which is the degree to which the selection 
fill and edit handles are transparent. The 
default value is 20%. 

8

Note: If the Selection Line and Handle Fill
Colors are similar, it may be difficult to distin-
guish between active and inactive CAD
Points. 
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Font Panel
The FONT panel controls the conversion of 
text in legacy plans when they are opened in 

Chief Architect X8 as well as the text used in 
the Materials List.

Specify the Fonts for use in Legacy 
Text Conversion, Legacy Dimension 

Conversion, and Materials Lists.  
• Select Legacy Text Conversion from the 

list to specify the default font for text in 
legacy files. See “Character Size” on page 
1030.

• Select Legacy Dimension Conversion 
from the list to specify the font used by 
dimensions in legacy files. See “Dimen-
sions” on page 985.

• Select Materials Lists from the list to 
specify the default font used by Materials 
Lists and the Master List in legacy plans. 
See “Materials Lists” on page 1283. 

• Select a Font from the drop-down list for 
the use selected to the left. See “Fonts and 
Alphabets” on page 1030.

• Select one or more font styles to apply to 
the selected use: Bold, Italic, Underline, 
and/or Strikeout.

Sample text displays the selected font 
and font style.

For information about text in Chief Architect 
X8 files, see “Text, Callouts, and Markers” 
on page 1027.

1 Legacy Text and Dimension Conversion
settings only affect plans from previous

versions when they are opened in Chief
Architect X8. Set these values to the default
font that you used in previous versions before
opening legacy files.

2
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Library Browser Panel
The LIBRARY BROWSER panel controls the 
appearance of the Library Browser window. 
See “The Library Browser” on page 820. 

View options control the display of the 
main sections of the Library Browser.

• Check Hide Selection Pane to hide the 
pane that displays objects in a selected 
library or library folder.

• Check Hide Preview Pane to hide the 
pane that shows a preview of a selected 
object.

Selection Pane View options control 
how objects in the Selection Pane are 

presented. 
• Select Tiled to Fit Window to display all 

items in a library catalog or folder. If there 
are many items, their previews may be 
very small to fit in the pane.

• Select Scrollable List to display all items 
in the selected catalog or folder in a scrol-
lable list. If there are many objects, the 

list may be very long but each object pre-
view will be sized to fit the pane.

• Check Show Names in Selection Pane to 
display the names of the objects in the 
Selection Pane.

Preview Pane/Selection Pane Layout 
- Select a radio button to change the 

appearance of the Library Browser. 
• Vertical - Displayed sections of the 

Library Browser are divided vertically. 
• Horizontal - Displayed sections are 

divided horizontally. 
• Stacked - Displayed sections are divided 

both horizontally and vertically.

Specify whether selected library items 
in the Preview Pane are displayed 

using the Standard or Vector View 

1
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Rendering Technique. See “Rendering 
Techniques” on page 951.

To restore the original size and position of 
the Library Browser and other side windows, 
click the Restore Side Windows button on 
the Reset Options Panel.

Text Panel
The settings on the TEXT panel control some 
behaviors affecting text objects. See “Text, 
Callouts, and Markers” on page 1027. 

Text Specification Enter Key -

• Uncheck Create New Line to close the 
Text and Rich Text Specification dialogs 
when the Enter key is pressed. When this 
is checked, a new line of text is created 
when Enter is pressed and the dialog 
remains open. 

• Default Designer Information - Click 
the Define button to enter designer infor-
mation that applies to all plans drawn in 
Chief Architect. This default may be 
overridden for individual plans. See 
“Designer Information” on page 1127.

Specify how the Leader Lines  tool 
functions. See “The Text Tools” on 

page 1031.
• Specify the Number of Segments that 

text Leader Lines have. Changes to this 
setting affect subsequently drawn Leader 
Lines: existing lines are not affected.

• Uncheck Create Rich Text to create Text 
 objects when the Leader Line tool is 

used. When checked, Rich Text  is 
created. 

1 2



98

Chief Architect X8 Reference Manual

General Panel

Undo - Click in the Enable check box 
to enable Undos and Redos. See “Undo 

and Redo” on page 257.
• Maximum Undos - Specify how many 

levels of Undo and Redo you want avail-
able, from 1 to 100. Undo files are saved 
in the Undo Directory.

Check For Program Updates - Check 
Enable and specify a frequency in days 

to check for program updates. By default, 
Chief Architect will check for program 
updates once a day, whenever the program is 
launched. 

Check Show Options at Startup to 
open the Startup Options dialog when 

Chief Architect is launched. See “Startup 
Options” on page 30.

Troubleshooting - 

• Uncheck Optimize for Multi-Core 
CPUs to turn off program optimizations 
for multi core processors. This box is 
checked by default and should only be 
unchecked for technical troubleshooting 
purposes.

• Uncheck 2D Zoom and Panning Opti-
mizations to turn off program speed opti-
mizations for zooming and panning in 2D 
views. 

Uncheck Edit Active Default on 
Double-Click to open the Saved 

Defaults dialog when you double-click the 
toolbar button associated with a drawing tool 
that has multiple saved defaults. When this 
boxis checked, the defaults dialog for the 

1
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currently active saved default opens. See 
“Multiple Saved Defaults” on page 77.

Specify when the program should Save 
Dialog Size and Position: Always, Per 

Session, or Never. See “Dialog Size and 
Position” on page 40. 
• Check Open Dialogs to the Last Panel 

Visited to open panelled dialogs to the 
last panel that you accessed during the 
current program session. When 
unchecked, dialogs always open to the 
first panel. See “Dialogs” on page 39. 

Specify how window sizes in Room 
Planner Imports are measured. See 

“Import Room Planner File” on page 1169.
• Check Measure Windows from Inside 

of Frame to measure window heights and 
widths from the inside of the frame. When 
unchecked, window sizes are measured 
from the outside of the window frame, as 
they are in the Window Specification 
dialog in Chief Architect. See “General 
Panel” on page 407.

File Management Panel
The settings on the FILE MANAGEMENT 
panel let you modify functions related to the 
program’s plan and layout file management. 

6

7
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Check Auto Save, then enter a value 
greater than zero in the text field to 

specify the frequency in minutes that Auto 
Save files are created. Auto Save files are 
stored in the Archive folder. See “Auto Save 
Files” on page 60.

File Locking - Choose whether or not 
to lock .plan and .layout files when 

they are open. File Locking prevents another 
program or copy of Chief Architect software 
from opening and modifying the same file at 
the same time and is recommended in nearly 
all circumstances. 
• Select Use File Locking to lock files.
• Select Disable File Locking to disable 

this feature. 

Specify the maximum size and location 
of the Recent File List.

• Specify the maximum number of recently 
opened files to list in the Startup Options 
dialog and at File> Open Recent Files. 
You can open any of the files in this list 
by selecting it, making it a quick way to 
access your most recent work.

• Uncheck Show in Submenu to display 
the Recent File List at the bottom of the 
File menu rather than in a submenu.

Check Thumbnail Images to 
automatically create thumbnail images 

of files that display when opening or 
searching for saved files.If this option is 
disabled, you can still create thumbnails 
manually. See “Thumbnail Images” on page 
59. 
• Select either Small or Large thumbnails. 

Large thumbnails provide a higher quality 
image but result in larger file sizes. 

Select an Auto Archive Files option. 
Every time a file is saved, the current 

archive file is overwritten. See “Archive 
Files” on page 59.
• Select Hourly to save and append archive 

files based on an hourly format.
• Select Daily to save and append archive 

files based on a daily format.
• Select Previous Save to archive only the 

most recently saved file, unappended.

Uncheck Auto Archive Warning to 
prevent the program from prompting 

you to manage archive files. When checked, 
you will be reminded to manage the current 
file’s archives when they reach the number 
specified below. 
• Enter the Maximum Files, which is the 

number of files that must be in a file’s 
Archive directory before the Manage 
Archives warning will display. See “Man-
age Archives” on page 60.

Folders Panel
Chief Architect stores many support files in 
various folders on your computer. The 
default locations of these directories are 
listed and can be redefined on the FOLDERS 
panel if necessary. 

You do not need to change default locations 
under normal circumstances, but sometimes 
it may be preferable to locate certain files in 
another location. To specify a new default 

Even with Auto Save active, you should
frequently save your work to the hard

drive by selecting File> Save.
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folder for a particular purpose, click the 
Browse button to the right of that item. 

Important user-specific information is stored 
in the Chief Architect X8 Data folder, 
which is located in your Documents 
directory by default. See “Chief Architect 
Data” on page 53.

While you cannot change the name of this 
directory, you can change its location. To 
avoid unexpected results, it is best to use a 
location on your local hard drive.

If you move this folder on your computer 
without specifying its location here, the 
program will automatically replace it using 
default information from the Chief Architect 
installation folder. The same result will occur 
if you specify a location on a network or 
removable device and this location becomes 
inaccessible. When this occurs, customized 
user settings will not be used and custom 
library content will not be available. 

By default, Temporary files and Undo files 
are stored in the same folder. If you wish to 

use a different folder, you must specify a 
directory on a hard drive with sufficient 
space to hold these files. See “Undo and 
Redo” on page 257.

Chief Architect will not let you save your 
work to or open files saved in the Temporary 
or Undo folder. 

You can share patterns with other users by 
copying your pattern files into the Shared 
Patterns folder in an operating system 
window. Click the Browse button to select a 
location on your computer that other users 
can access. See “Patterns and Textures” on 
page 848.

All Program Paths - Click the Show button 
to open the Program Paths dialog, where 
you can find the location of files that may be 
needed for troubleshooting purposes. See 
“Program Paths Dialog” on page 1317.

Changing the settings on the Folders
panel can result in unexpected program

functionality. 
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Ruby Panel
The settings on the RUBY panel let you 
specify the Ruby safe level and the location 
of any Ruby files you may run in the Ruby 

Console. See “The Ruby Console” on page 
1304. 

Select the Ruby $SAFE level you wish to 
use from the drop-down list. A level of 0 is 
unprotected and could allow a malicious 
script to be run, while a level of 5 may 
prevent you from using the Ruby Console 
productively. Level 2 is chosen by default.

In the Include in $LOAD_PATH field, 
specify the pathname of the directory where 
your Ruby scripts are stored. Separate 
multiple locations with a semi-colon. 
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New Plans Panel

Specify what system of measurement 
New Plans and Layouts use, as well as 

what files are used as the templates for new 
plans and layouts. See “Template Files” on 
page 84.
• Select the Imperial Units or Metric 

Units radio button to determine the units 
used in your new files. Once a new plan 
or layout is created, its measurement sys-
tem cannot be changed. 

• Plan Template - Displays the template 
file the program uses when you open a 

new plan. Click the Browse button to 
select a new plan template.

• Layout Template - Displays the template 
file the program uses when you open a 
new layout file. Click the Browse button 
to select a new layout template.

Open/Save As Directory - Control 
how the program behaves when a new 

plan is opened or an existing plan is saved. 
• Use Last Directory refers the program to 

the directory last used to save or open a 
plan file. 

• Use This Directory refers the program to 
a particular location specified by you.

• Click the Browse button to define a par-
ticular directory when Use This Direc-
tory is selected.

Be sure that you use imperial files for
your imperial templates and metric files

for your metric templates. When a new file is
created, it uses units of the template file
regardless of your Preference setting.

1
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Layers Panel

Legacy Layers - Specify how layers 
are handled in legacy files when they 

are opened in Chief Architect X8.
• Check Purge Unused Layers to delete 

any layers that do not have a name and 
contain no objects.

• Check Keep All Layer Numbers to keep 
all layers that were on the System and 
User tabs in version 9 and prior and use 
their layer numbers as names.

• Check Reset Default Layer Names to 
change the names of layers that were on 
the Architectural and System tabs in ver-
sion 9 and prior to the default names used 
in Chief Architect X8.

To make no changes to layers when legacy 
files are opened in Chief Architect X8, 
uncheck Purge Unused Layers, check Keep 
All Layer Numbers, and uncheck Reset 
Default Layer Names.

Layer Editing - If you check Modify 
Name In All Layer Sets and then 

change the name of a layer in one layer set, it 
will be changed in all layer sets. Clear the 
checkmark if you want name changes to only 
affect a single layer set.

Unit Conversions Panel
In many places throughout Chief Architect, 
you can specify the size of an object with any 
Length unit listed on the UNIT CONVERSIONS 
panel. Using the data on this panel, the 
program will convert your entry into the unit 
set in the Dialog Number/Angle Style 
dialog. See “Dialog Number/Angle Style 
Dialog” on page 127.

These conversions are also useful when you 
import drawings. When an object is drawn in 
a Chief Architect plan file, it is always at its 
true, unscaled size and the drawing is only 
scaled when you print it. This means that if 
you import a scaled drawing, you must 
compensate for its scaling by creating a 
custom unit of measurement. See “Import 
Drawing Assistant” on page 1172. 

1

Note: When legacy plans are opened, there
may be a noticeable delay while layers are
converted.

2
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The default unit conversions are locked and 
cannot be changed, but custom conversions 
can be added to the list and later modified.

A list of available units of measurement 
displays here. Click on the name of a 

unit to select it.
• Add, Edit, Delete, or Copy the unit con-

versions. Certain unit conversions are 
locked and cannot be edited or deleted.

If you click Add, Edit or Copy, the Add Unit 
Conversion dialog displays. 

The Sample area shows how the unit 
selected above converts to a selection 

of similar units. You can use this to verify 
that any unit conversion you add is correct.

1

2
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Add Unit Conversion Dialog

Unit Name - Type a short, descriptive 
name of the new unit. Names must be 

unique: the names of units installed with the 
program cannot be used. 

Names can include any characters, as well as 
spaces. Bear in mind, though, that names of 
units for measuring length that have numbers 
in them may be unusable if entered in some 
dialogs in the program. 

Check Default Unit to display this new unit 
in places that present lists of available units. 
For example, if you have inches as units and 
make inches a default, inches appear on the 
list when you are given a choice of units, 
such as in the Import Drawing Assistant. In 
other places, such as the Materials List, all 
units are listed.

Measurement Type specifies what the 
new unit measures. Select the 

appropriate radio button: Length, Area, or 
Volume.

Conversion - 
 

• Specify how much to Multiply by your 
custom unit to convert to the unit you 
select from the drop-down list. A mea-
surement type must be selected before the 
list is populated. 

A Sample of the Unit Conversion 
defined above displays here. 

To create a new unit of measurement

When importing a drawing with a 1” = 20’ 
scale, for example, create a unit to convert 
this scaling to 1” = 1”.

1. Click the Add button to open the Add 
Unit Conversion dialog.

2. Type a short, descriptive name like 
“convert 1:20” in the Unit Name field.

•  Because this unit will be used only for 
scaling conversion, including numbers 
in its name will not cause any issues.

3. Select Length as the Measurement 
Type.

4. Type 20 in the Multiply by field.
5. Select “ft” from the drop-down list.

6. Click OK to close the dialog.

1

Note: You can achieve the same results if you
Multiply by 240 to convert to inches.
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Time Tracker Panel

• Uncheck Automatically Start Timer on 
File Open if you do not want to begin 
logging time whenever a file is opened. If 
this is not checked, you must select 
Tools> Time Tracker> Start Time Log-
ging  to begin logging.

• Check Stop timer if idle for __ minutes, 
and enter the number of minutes to stop 
logging time when a plan has been idle.

• Check Display Idle Timeout Dialog to 
warn when a plan is considered idle.

• Specify the Default User Name used in 
Time Log entries. This field is initially 
populated by the name that you entered 
when you registered your software 
license. See “Designer Information” on 
page 1127. 

For more information, see “Time Tracker” on 
page 1123.



108

Chief Architect X8 Reference Manual

Architectural Panel

Select the desired default behaviors for 
selected Walls.

• Check Show Same Wall Type Handles 
to display edit handles on selected walls 
that draw new walls of the same type 
when dragged. See “Same Wall Type Edit 
Handles” on page 290. 

• Check Select Room Before Wall in 3D 
to select the room defined by a wall when 
you click on the wall in 3D views. When 
this is unchecked, rooms cannot be 
selected in 3D views. See “Selecting 
Walls” on page 286. 

• Check Turn on Connect Island Rooms 
When Opening Legacy Plans to auto-
matically connect “island” rooms an 
Invisible wall in legacy plans opened in 
version X8. See “Room Definition” on 
page 331. 

Opening Appearance - Specify the 
appearance of opening indicators on 

cabinets, doors, and windows. See 
“Displaying Cabinets” on page 684, 
“Displaying Doors” on page 365, or 
“Displaying Windows” on page 401.
• Select Opening Indicators Point to 

Hinge Side for opening indicators that 
point to the hinge side of the opening.

• Select Opening Indicators Point to 
Handle Side for opening indicators that 
point to the handle side of the opening.

Check Stair Sections Move 
Independently to allow stair sections 

connected by landings to move separately, 
without moving the entire staircase. See 
“Editing Stairs and Ramps” on page 540.

1 2
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Uncheck Enable ‘Show Room Label’ 
Automatic Behavior When Changing 

Room Types to prevent a room’s label from 
displaying when an “Unspecified” room is 
assigned a different Room Type in its Room 
Specification dialog. When this box is 
checked, the room label’s display will be 
enabled when the Room Type is changed 
from “Unspecified”. See “General Panel” on 
page 351. 

Check Automatically Place Roof 
Intersection Points to automatically 

generate temporary CAD points that 

correspond to roof plane intersection points. 
When unchecked, these temporary points are 
not created. See “Locating Intersections” on 
page 494. 

Select the desired Skylight Ceiling 
Hole Default behavior.

• If you select Skylights Automatically 
Generate Ceiling Holes, the program 
automatically generates a ceiling hole for 
a new skylight.

• Select Manually Edit Ceiling Hole Poly-
lines to create your own ceiling holes.

CAD Panel
The CAD panel contains settings that define 
how CAD blocks, Sun Angles and other CAD 
and CAD-based objects behave.

4

5

6
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The CAD Blocks settings determine 
the default fill style behavior for CAD 

blocks. See “CAD Blocks” on page 1111.
• Check Always use ’By Object’ for CAD 

block fill style to retain the fill patterns of 
the component objects of CAD blocks. 
When checked, all settings that would 
otherwise affect the fill style of a CAD 
block in its specification dialog are 
ignored. See “CAD Block Specification 
Dialog” on page 1115.

• Check Use ’By Object’ when creating 
new CAD blocks to have By Object 
checked in the CAD Block Specification 
dialog when a new CAD block is created. 
See “General Panel” on page 1115.

The Options settings control the 
editability of polylines and splines.

• Uncheck Connect CAD Segments  to 
prevent CAD objects from snapping 
together to form polylines as they are 
drawn or edited. See “Connect CAD Seg-
ments” on page 182. 

1

Checked Unchecked
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• Check Advanced Splines to enable the 
advanced spline setting as the default 
editing behavior for all subsequently 
drawn splines. You can also enable this 
function for an individual spline by click-

ing the Advanced Splines  edit but-
ton. See “Advanced Splines” on page 
213.

The Line Properties settings affect 
open CAD shapes, including lines, arcs, 

and splines. 

• Endcap Printed Length - The beginning 
and end of CAD lines that use a dashed 
line style are sometimes difficult to distin-
guish. Endcaps can be placed to eliminate 
this problem. Specify the printed endcap 
length in inches (mm).

• Uncheck Show Same Line Type Han-
dles to turn off the display of these edit 
handles on selected CAD objects. See 
“Same Line Type Edit Handles” on page 
1083.

Sun Angle - Define the default Lati-
tude, Longitude and Time Zone used 

when creating Sun Angles. See “Sun Angles 
and Shadows” on page 943. 

Edit Panel
The settings on the EDIT panel of the 
Preferences dialog control the appearance 
of the cursor and selection behavior of edit 

handles. See “Using the Mouse Cross Hairs” 
on page 226.

Note: Unlike other Preferences, the program
always resets Connect CAD Segments to be
on whenever you close the program.

3
4



112

Chief Architect X8 Reference Manual

You can use a cursor with Cross Hairs 
in different view types and control its 

appearance. 
• Check Enable in Plan and Cross Sec-

tion/Elevation Views to use a cross hair 
cursor in floor plan and cross section/ele-
vation views. This option is checked by 
default.

• Check Enable in Perspective Views to 
use a cross hair cursor in perspective cam-
era views and overviews.

• When Synchronize with Cursor is 
checked, the mouse pointer and cross 
hairs always move together on screen. If 
you feel that they do not keep up with 
your mouse movements, try unchecking 
this option. 

• Click the Color bar to open the Select 
Color dialog and specify the color of the 
cross hairs. 

• Cross hair Size is specified as a percent-
age of the view Window Width. Specify 
the Size as 100% to extend the cross hairs 
across the entire screen. 

• Set the Aperture Size, measured in pix-
els. The aperture is the space where the 
cross hairs meet. A value of 0 makes the 
cross hairs meet at a point. Larger num-
bers leave a gap in the center.

Specify the desired Selection settings, 
which affect how objects are selected 

and their appearance. 

1
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• Enter an Edit Handle Size in pixels. The 
edit handles are twice this number of pix-
els plus one. For example, the default 
value is 4, which results in a handle that is 
9 x 9 pixels (4 x 2 = 8, and 8 + 1 = 9). The 
minimum value is 1, which results in a 
handle that is 3 x 3 pixels. 

• Enter a value, in pixels, for Edit Handle 
Tolerance to specify how close to an edit 
handle you must click in order to select it. 
The default value is 0. 

• Check Show Start and End Indicators 
to display an S and an E at the start and 
end points of a selected wall or the 
selected edge of a CAD-based object. 
This can make it easier to edit the selected 
edge in the object’s specification dialog. 
See “Selected Edge” on page 184. 

Specify program behavior when using 
Marquee Selection to select objects. 

See “Marquee Select” on page 185. 

• Choose Select Intersected Objects  to 
select any objects whose bounding boxes 
are intersected by or located within the 
marquee. See “Bounding Boxes” on page 
1208. 

• Choose Select Contained Objects  to 
select only objects located entirely within 
the marquee. This option provides the 
best results in most situations.

• Choose Select Objects by Center  to 
select only objects whose center points 
are located within the marquee.

Behaviors Panel
The settings on the BEHAVIORS panel of the 
Preferences dialog define basic editing 
behaviors of CAD and architectural objects.

You can add the Selection Modes tools
to your toolbars. See “To add a button
to a toolbar” on page 132. 

3
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Rotate/Resize About defines the point 
about which an object or a group of 

objects rotates or resizes. See “Rotate/Resize 
About” on page 161.
• Select Object Center to rotate or resize 

the selection about its center point. Object 
Center is the default setting. 

• Select Current Point to rotate the object 
about the current CAD point instead. 

To resize a CAD object about a current point, 
select the Resize Edit Type. 

This function can also be accessed by 
selecting Edit> Edit Behaviors> 
Resize . See “Edit Behaviors” on page 
178.

1

Rotate about 
Object Center

Rotate about 
Current Point
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• Rotate Jump defines the angles an object 
or group of objects jumps to as it is 
rotated. When this value is set to 0°, the 
Allowed Angles set in the Plan Defaults 
dialog are used; otherwise, Allowed 
Angles are ignored. 

The Primary Movement Methods 
control the directions that you can 

move objects using their edit handles. 

• Select Orthogonal to move an object per-
pendicular to any of its edges.

• Select Polar to move an object at 
Allowed Angles.

Specify whether the Continuous 
Drawing Behavior restarts after a 

closed shape is formed. See “Alternate” on 
page 179. 
• Uncheck Stop When Connected to 

remain in the continuous Alternate draw-
ing mode after a closed shape is formed. 
When checked, the continuous drawing 
mode is halted but can be started again.

Select one of the six Edit Type radio 
buttons. For detailed information about 

the different edit types and how they affect 
different objects, see “Edit Behaviors” on 
page 178.
• If Concentric is selected, specify the 

desired Jump increment. 
• Uncheck Behavior Indicators to turn off 

the display of the mouse pointer icons 
associated with these Edit Behaviors. This 
box is checked by default. 

Snap Properties Panel
The settings on the SNAP PROPERTIES panel 
of the Preferences dialog control the 
behavior of Object Snaps as well as the 

appearance of snap indicators. See “Object 
Snaps” on page 162.

Concentric 
Resize

Resize About 
Current Point

Box rotating about Current 
Point with Jump set to 45°

2 Note: Unlike other Preferences, the program
always restores the Default Edit Behavior
whenever you close the program.

3
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Options - 

• Specify the Objects in History, which is 
the number of Extension Line Anchors 
that can display at one time. 

• Specify the Snap Distance, which is how 
far your the cursor can be from a snap 
point for the snap to occur. This value is 
measured in screen pixels; the default 
value is 12. 
When working with very small objects, 
you may find it helpful to reduce this 
value; when working with very large 
objects, it may be helpful to increase it. 

This setting also controls the minimum 
length of camera and cross section/eleva-
tion lines of sight. See “Creating Camera 
Views” on page 899. 

• Specify the Maximum Bump Distance, 
which is the distance that a selected object 
must be dragged to override bumping and 
move past an obstructing object. 

• Check Snap Cabinets After Paste to 
make the cabinets snap together after you 
paste them.

• Check Always Snap Walls on Allowed 
Angles to limit walls to Allowed Angles. 
When unchecked, Object Snaps can over-

1



Preferences Dialog

 117

ride Angle Snaps, allowing walls to snap 
at off angles as they are drawn or edited. 
See “Angle Snaps” on page 164.

Control the appearance of Snap 
Indicators.

• Specify a snap Indicator Size in pixels. 
This setting also controls the size of tem-
porary CAD Points. See “Place Point” on 
page 1077. 

• Click the color bar to select a snap Indi-
cator Color from the Select Color dia-
log. See “Color Chooser/Select Color 
Dialog” on page 875. 

• Click the color bar to select an Extension 
Color from the Select Color dialog. 

• Click the color bar to select an Angle 
Snap Grid Color from the Select Color 
dialog. 

• Check Display Angle Snap Grid to turn 
on the display of the Angle Snap Grid. 
See “Angle Snap Grid” on page 165. 

Enable any combination of Object 
Snaps. You can also turn these options 

on an off with the toggle buttons on the 
toolbar or using keyboard hotkeys.
• Check Object Snaps to enable the object 

snap and extension snap options, below. 

• Endpoint  enables snapping to the 
ends of lines, arcs, splines and other 
objects.

• Midpoint  enables snapping to the 
midpoint of an object such as a line or arc. 
For objects such as boxes, you can snap to 
the midpoint of any side of the box. 

• Center  enables snapping to the center 
of cabinets, fixtures, furniture, as well as 
circles and arcs. 

• Quadrant  enables snapping to the 
left, right, top, or bottom of an object. 
Only used for arcs and circles.

• On Object  enables snapping to any 
point on the selected object, including 
CAD objects and cabinets.

• Points/Markers  allows you to snap 
to any temporary points you may have 
placed, as well as callouts and markers.

• Intersection  enables snapping to the 
intersection of two objects, such as the 
intersection of a line with another line. 
Intersection snapping also snaps exten-

2
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sion lines to objects, and allows you to 
snap two extension lines to each other.

When Intersection snapping is enabled, wall 
extension line snapping will also occur. See 
“Drawing Walls” on page 276.

Check any combination of Extension Snaps. 

• Tangent Extensions  enables snap-
ping to a point tangent to the point where 
the extension anchor sits.

• Perpendicular Extensions  enables 
snapping to a point perpendicular to the 
point where the extension anchor sits.

• Orthogonal Extensions  enables 
snapping to a point on a 90° axis from the 
extension anchor.

Control the behavior of Other Snaps.

• Check Bumping/Pushing  to allow 
objects to bump into and move other 
objects. See “Bumping/Pushing” on page 
221.

• Check Bumping/Pushing for Type-in 
Movement to cause objects moved using 
dimensions or the Enter Coordinates 
dialog to bump into objects in their path 
of movement and stop. When unchecked, 
objects moved using type-in methods 
move to their specified destination loca-
tions. See “Moving Objects” on page 220. 

• Check Angle Snaps  to enable snap-
ping to Allowed Angles. See “Angle 
Snaps” on page 164.

Intersection snaps

Tangent extension

Perpendicular extension

Orthogonal extension

4
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Materials List Panel
The settings on the MATERIALS LIST panel 
control which categories are included in 
Materials Lists. The names of all categories 
and their ID prefixes are listed here. They are 

defined by the program and cannot be 
changed. See “Materials Lists” on page 
1283.

When a material is entered in the Materials 
List, the program decides what category it 
goes in and assigns it an ID, which is the 
prefix followed by a number. EX1 would be 
the first exterior trim piece entered in the 
Materials List for a particular plan.
• Include These Categories - Check the 

categories you want to include in every 
new materials list generated. Before you 
hide a category, make sure you know 
what items are listed within it.

• Click Select All to check the boxes beside 
all categories, or click Clear All to clear 
the checkboxes beside all categories.

It is usually better to remove categories
from individual plan lists in the Layer

Display Options dialog, rather than globally.
See “Layer Display Options Dialog” on page
149.
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Report Style Panel
The REPORT STYLE panel controls the 
appearance of Materials Lists. 

Include These Columns - Check the 
box beside each column that should be 

included in newly created Materials Lists. 
Columns can also be specified per individual 
Materials List by choosing Tools> Display 
Options  while that Materials List is 
active. See “Materials List Display Options 
Dialog” on page 1291.

• Use the Move Up and Move Down but-
tons to change the order that columns 
appear. To change the order, select one or 
more items in the list and click the button. 
The selected columns move up or down 
by one in the list. 

When Querying Suppliers and 
Manufacturers - Select an option to 

1
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narrow or broaden your query when 
searching the Master List.

 Choose whether or not Grid lines 
display in the Materials and Master 

Lists, both on-screen and printed. 
• Check Horizontal Lines for lines 

between Materials List rows. 
• Check Vertical Lines for lines between 

Materials List columns. 

• Check Solid Lines for a solid line style. 
When unchecked, dotted lines are used.

Background Colors can be specified 
for Odd and Even numbered lines. 

Specify the Text Font Size, which is 
the height of the font used in the 

Materials List, Master List, and the 
Components dialog. See “Character Size” 
on page 1030. 

Master List Panel
The MASTER LIST panel specifies how the 
Master List(s) for materials appears. You can 
maintain Multiple Master Lists, but only one 

may be used at any given time. See 
“Materials Lists” on page 1283.

Include These Columns - Check each 
column to include it in the Master 

materials list.

Use the Move Up and Move Down buttons 
to change the order of columns. To change 
the order, select one or more items in the list 

and click the button. The selected columns 
move up or down by one in the list. 

Master List File - The name and 
pathname of the Master List currently 

referenced is shown. It is referenced for all 
subsequently opened plans when a materials 
list is generated. 

3 4
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• Click the Browse button to select a differ-
ent Master List. Navigate the directory 
structure until you find the new Master 
List to be used, select it, and click OK.

• Click the New button to create a new 
Master List. Name and save it in the loca-

tion of your choice. When you create a 
new Master List, it is blank until you 
build a materials list and enter prices, sup-
plier or manufacturer information. The 
Master List is saved automatically when 
you close.

Categories Panel
The CATEGORIES panel allows you to 
customize the organization of the Materials 
List by creating subcategories under the pre-
defined Materials List categories. See 
“Organizing Materials Lists” on page 1289. 

Subcategories can also be included in 
schedules. See “Adding Custom Columns” 
on page 1272. 

A list of available Categories displays 
here. Click on a name to select it. 

If the selected Category has any Sub-
Categories, their names will display 

here. 

1 2
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To Add, Edit, or Delete a Sub-
Category, select it and click the 

appropriate button. Clicking Add or Edit 
opens the Sub-Category dialog. 

In the Sub Category dialog: 

• Type a name of the Sub-Category to 
appear in the SubCat column of the 
Materials List. This name can be any 
sequence of characters, up to 12 charac-
ters in length. 

• Doors, Windows, Cabinets, Fixtures, Fur-
niture, and Electrical objects can be 
included in schedules. Subcategories for 
these objects can appear as column head-
ings. Type a Column Heading for 
Schedules. 

In the example above, two subcategories are 
added to the Windows category:  GLZ 
(Glazing) and EXT (Exterior Trim). 

Render Panel
The settings on the RENDER panel control 
how 3D views are generated, particularly 

Render Previews and Final Views. See 
“Previews vs Final Views” on page 936.

3
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The General Options settings affect 
the quality and rendering time of both 

Render Previews and Final Views. See “Pre-
views vs Final Views” on page 936.
• Check Legacy Shadows to generate 

shadows using the method used in version 
X5 and prior. Legacy shadows are signifi-
cantly slower than standard shadows, but 
are often of higher quality with smoother 
edges. If your video card does not support 
standard shadows, Legacy Shadows will 
be used automatically. See “Shadows” on 
page 934.

• Soft Shadows displays shadows with soft 
edges instead of hard edges. This feature 
is only used when a Software Edge 
Smoothing value greater than 0% are also 
used.

• Hardware Texture Filtering uses your 
video card to filter textures and improve 
their appearance: noticeably, on surfaces 
angled away from the camera. In some 
rare instances, this may slow rendering 
time somewhat. Not supported by some 
video cards. 

• Horizon Lines are lines that generate 
along the curved edges of symbol objects 
in Vector Views. Uncheck this box to 
increase the speed of Vector View genera-
tion but also suppress these lines. See 
“Vector View” on page 952. 

• Hardware Edge Smoothing uses the 
video card to remove the jagged edges 
that sometimes result along surface edges, 
producing cleaner lines. Select an MSAA 
(Multi Sample Anti-Aliasing) multiplier 
from the drop-down list: the higher the 
multiplier, the smoother the surface edges 
and longer the rendering time. The 
options available in this list may be lim-

ited, depending on what your video card 
is able to support. 

The Preview Options settings affect 
the quality and rendering time of 

Render Previews only. 
• Show Images controls the display of 

images, such as plants and vehicles, in 
rendered views. See “Displaying Images” 
on page 1136. 

• Use Textures controls whether or not sur-
faces are rendered with textures. When 
textures are turned off, surfaces are ren-
dered using the solid color assigned to the 
material. See “Mapping Patterns and Tex-
tures” on page 858.
Textures can also be turned on or off in 
most rendered views by selecting 3D> 
Camera View Options> Toggle Tex-
tures .

If turning textures off improves rendering 
times significantly, you may want to upgrade 
your video card. See “OpenGL and 
Hardware” on page 888. 
• Reflections in Mirrors allows flat sur-

faces using a Mirror material to display 
reflections of other objects in the scene. 
Reflections may slow program perfor-
mance in 3D views, particularly when 
multiple mirrors are present. By default, 
this is checked for Final Views but not for 
Previews. See “Reflections” on page 935. 

• Software Edge Smoothing removes the 
jagged edges that sometimes result along 
surface edges, producing cleaner lines. 
Use the slide bar or text field to specify 
how much jagged edge lines should be 
smoothed. 

Initial Software Edge Smoothing settings 

1
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for Previews and Final Views are 0% and 
80%, respectively.

The Final View Options settings are 
exactly the same as the Preview 

Options, but affect Final Views instead of 
Render Previews. See “Previews vs Final 
Views” on page 936

Select a Codec for Walkthrough 
Recordings from the drop-down list. 

By default, “Cinepak codec” is selected in 
the 32-bit Windows version of the software, 
“IYUV codec” in the 64-bit Windows 
version, and “H.264” in the Mac version; but 
any other codecs that you  may have installed 
on your system will also display in the list.  
See “Walkthroughs” on page 1158.

The 3Dconnexion® settings affect how 
3D mice function in Perspective 3D 

views. See “3Dconnexion® 3D Mice” on 
page 912.
• Select Navigate about Camera to center 

mouse movement about the location of 
the camera.

• Select Navigate about Camera Focal 
Point to center mouse movement about 
the location of the camera’s focal point. 
See “To create a camera view” on page 
899.

The Troubleshooting settings can be 
used to troubleshoot performance in 3D 

views.
• When Use Enhanced Lighting is 

checked, Standard rendered views gener-
ate lighting effects that require a video 
card that supports OpenGL 2.0. Uncheck-
ing this box may speed up Standard ren-
dering times somewhat; however, the 
quality of lighting effects will be reduced. 
Not available if your video card does not 
support OpenGL 2.0. See “OpenGL and 
Hardware” on page 888. 

• Software Rendered Overlays helps 
address specific errors that can occur with 
certain video cards and is checked by 
default. In some rare instances, this may 
slow rendering time somewhat. Note that 
it will become checked automatically if 
the program encounters certain error con-
ditions.

• Command Flushing - Select an option 
from the drop-down list to control how 
often the program flushes cached video 
memory. “Rarely” is selected by default 
and will produce fastest rendering times 
on most systems, but “Frequently” may 
be helpful for older video cards. 

Ray Trace Panel
The settings on RAY TRACE panel allow you 
to specify how much of your computer’s 
processor resources to allocate to the Chief 
Architect Ray Tracer. Changes to these 

settings do not affect ray traces that are in 
progress or queued: only ray traces that you 
start in the future. See “Ray Tracing” on page 
965. 

3
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• Specify the Number of Cores Used by 
typing in the text field or clicking the up 
or down arrows. The number of cores 
available will vary, depending on the 

number of cores your system has and 
whether it uses hyper threading. 

• Check Use Maximum to use the highest 
number of cores available on the system. 

Video Card Status Panel
The VIDEO CARD STATUS panel displays 
information about your video card, including 
the vendor and the OpenGL version it uses. 
See “OpenGL and Hardware” on page 888.

This information may be important if you are 
having problems generating 3D views.

Notice the Max Lights value. This indicates 
how many lights can be rendered in a 3D 
view. This value should be 8 or higher, 
depending on your video card. See 
“Lighting” on page 936.

Reset Options Panel
In order for some of the Reset Options to 
take effect, you will need to restart Chief 
Architect. 

• If message boxes have been suppressed, 
you can make them display again by 
clicking Reset Message Boxes. See 
“Message Boxes” on page 43.

• Click the Reset Toolbars button to reset 
all toolbars to their original states. If you 
are encountering warning messages 
regarding toolbars, this option may 
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resolve the issue. Note that any custom 
toolbar configurations that you may have 
created will be discarded if you click this 
button. See “Creating Custom Toolbar 
Configurations” on page 134.

• Chief Architect retains a list of locations 
where you have located missing files in 
the past. If you find that the program takes 
a long time searching before informing 
you that files are missing, you can click 
the Reset Search Folders button to clear 
this list. See “Referenced Files” on page 
68.

• Click the Reset Dialog Sizes button to 
restore all dialog boxes to their original 

sizes and positions. See “Dialogs” on 
page 39. 

• Click the Reset Side Windows button to 
restore all side windows to their original 
sizes and positions. Side window Settings 

 are also reset. See “Side Windows” on 
page 36. 

• Click the Reset Preferences button to 
restore all preferences to those originally 
installed with the program. 

Dialog Number/Angle Style Dialog
At the bottom of many dialogs, you can click 
the Number Style button to open the Dialog 
Number/Angle Style dialog. 

The settings in this dialog are global and 
control the format of distances, coordinates 
and angles of angles in dialog boxes as well 
as in the Status Bar. See “The Status Bar” on 
page 42.

These settings control the format of values 
used in dialogs but do not limit how you 
must enter these values. For example, if you 
set your Number Style to use Inches, values 
will display using fractional inches. You can, 
however, enter values using decimal inches, 
inches and feet, or even decimal feet. When 
the dialog you’re typing in updates, the value 
will be converted to fractional inches. 

Resetting all preferences to default can
be a drastic step and should be done

with caution.
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When Imperial units are used, the Fractional 
Inches and Feet, Fractional Inches options 
use fractional inches with denominators of 2, 
4, 8 and 16. A few objects, notably text, 
dimensions, and floor, ceiling and wall 
structure layers can be sized using smaller 
fractions with  larger denominators. 

Angles can be displayed using one of four 
basic methods: 
• Degrees/Minutes/Seconds - Measured 

counterclockwise from a line drawn hori-
zontally to the right of the angle’s vertex. 
Useful for most drawing tasks. Select the 
level of accuracy that you require.

• Quadrant Bearings - Measured from a 
vertical line representing North/ South, 
Quadrant Bearings use directional bear-

ings in their measurements. Useful for site 
drawings.

• Azimuth Bearings - Measured from a 
line drawn straight up from the angle’s 
vertex (ie, North on a site plan). Useful 
for site drawings, Azimuth Bearings use 
degrees, minutes, and seconds in their 
measurements.

• Pitch - Defined as a ratio of vertical rise 
to horizontal run. In Imperial units, the 
run is always 12”; in metric units it is 
1000 mm. Useful for roofs. 

Quadrant and Azimuth Bearings are affected 

by the orientation of the North Pointer , 
if one is present in the current plan. See 
“North Pointer” on page 943.
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Chapter 4:

Toolbars and
Hotkeys

Two of the most efficient ways to access 
Chief Architect’s tools are the toolbars and 
keyboard shortcuts, also referred to as 
hotkeys.

Both toolbars and hotkeys can be customized 
to suit your workflow. 

Chapter Contents
•      Toolbar Arrangement
•      Customizing Toolbars
•      Creating Custom Toolbar Configurations
•      Toolbar Customization Dialog
•      Hotkeys
•      Exporting and Importing Hotkeys

Toolbar Arrangement
Chief Architect’s toolbars provide fast access 
to the program’s most commonly used tools 
and settings, and are organized so that related 
tools are grouped together and easy to find. 

The toolbars that display in a given view 
depend on the view type. For example, the 
toolbars that are available in floor plan and 

3D views are not available in Materials Lists 
or Ray Trace views.

Some toolbars are available in more than one 
type of view. If a tool cannot be used in that 
view, its icon will appear pale grey in color.

Many of Chief Architect’s tools are 
organized into families of related tools which 
can be accessed using either of two styles of 
toolbar interface: the Child Tool Palette or 
Drop Down tools. You can select the 
interface that you prefer in the Preferences 
dialog. See “Appearance Panel” on page 92. 

If a tool or setting is active, a small
checkmark will display at the lower left
corner of its button icon.
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You can turn off the display of toolbars 
entirely or turn them on again by selecting 

View> Toolbars . 

Drop-Down Tools
Click on the arrow to the right of a button to 
display a drop-down list of related tools. For 
example, click the arrow to the right of the 

Window  button to display a drop-down 
list of the other Window Tools. 

The most recently selected tool displays in 
the toolbar.

Child Tool Palette
An alternative to Drop-Down toolbars is the 
Parent button and Child Tool Palette 
interface. Parent toolbar buttons have a blue 
triangle in the lower right corner. When you 
select a Parent button, its Child tools display 
in the Child Tool Palette. If the Child Tool 
Palette has been closed, it will open.

You can open the Tool Palette at any time, 
even when Drop Down tools are enabled, by 

selecting View> Tool Palette . See “View 
Tools” on page 880.

When you click the Window Tools  
Parent button, for example, its Child buttons 
display in the Child Tool Palette.

By default, the Child Tool Palette is docked 
on the left side of the program window; but it 
can be undocked and moved, as well as 
resized and closed, just like other side 
windows. See “Side Windows” on page 36. 

Click the Settings  button at the bottom 
of the palette to select how the tools within it 
are presented: 

• Select Fit Palette  to resize the palette 
so that it is one row wide. 

• Select Grid View  to display only the 
button icons of the child tools in a grid 
that may have multiple rows, depending 
on the width of the palette side window.

• Select List View  to display child 
tools in a vertical list with each tool’s but-
ton icon and name in a row.

As long as it is open, the Child Tool Palette 
will also display the members of a selected 
tool’s family when the Drop Down interface 
is active. If you select a tool that does not 
belong to a family, the previously selected 
tool’s family will continue to display in the 
Tool Palette.
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The Edit Toolbar
When you select an object, its edit toolbar 
opens. By default, it is located at the bottom 
of the program window, just above the Status 
Bar. The buttons on the edit toolbar can be 
used to edit the selected object(s). Which 
buttons display depends on the type of object 
selected, the current view, and how you 
selected the object.

Toolbar Configurations
Chief Architect installs a set of Toolbar 
Configurations, which control what tools are 
initially included in the toolbars, as well as 
where these toolbars are located. 

• The Default Configuration  displays 
architectural tools used for house design, 
including walls, windows, doors, stairs, 
cabinets, etc. 

• The Terrain Configuration  displays 
buttons associated with the terrain and 
road tools, including the plant and sprin-
kler tools. See “Terrain Toolbar Configu-
ration” on page 716.

• The Kitchen and Bath Design Configu-
ration  displays buttons associated 
with kitchen and bath design. See “Cabi-
nets” on page 675.

• The MEP Configuration  displays 
buttons associated with mechanical, elec-
trical, and plumbing. See “Line Styles” 
on page 1108.

• The Space Planning Configuration  
displays buttons associated with the 
Space Planning Assistant. See “Space 
Planning” on page 1127.

• The Extended Configuration  dis-
plays an extensive selection variety of 
tools for various uses. 

To switch toolbar configurations

There are several ways to switch from one 
Toolbar Configuration to another.
• Click a Toolbar Configuration button.
• Choose a configuration in the Toolbar 

Customization dialog. See “Configura-
tions Panel” on page 138.

• Right-click in an empty space on any 
toolbar and select a Toolbar Configura-
tion from the contextual menu. 

Customizing Toolbars
The Toolbar Configurations installed with 
the program are designed to help make tools 
quickly and easily accessible; however, for 
greatest efficiency, you may want to 
customize them to meet your own particular 
needs. A number of options are available:
• Toggling toolbars

• Moving toolbars
• Adding buttons to existing toolbars 
• Adding new toolbars 

Any changes made to an existing Toolbar 
Configuration will be saved whenever you: 
• Switch to a different configuration; 
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• Close the Toolbar Configuration dialog; 
• Exit out of Chief Architect.

Bear in mind that the size of the Chief 
Architect program window and the space 
available for toolbar button depends on your 
monitor’s size and screen resolution settings. 

Toggling Toolbars
There are several ways to toggle individual 
toolbars on or off:.
• Right-click in an empty space on any 

toolbar and mouse over Toolbars in the 
contextual menu. In the submenu, tool-
bars with a checkmark next to their name 
are on in the current view. Click on a 
toolbar name to turn it off if it is on, or 
vice versa.

• Toolbars can be turned on or off in the 
Toolbar Customization dialog. See 
“Toolbar Panel” on page 137 

• If a toolbar is undocked, click the Close 
button at its top right corner.

You can turn off the display of toolbars 
entirely or turn them on again by selecting 

View> Toolbars . 

Moving Toolbars
You can move any toolbar to a different 
location by clicking and dragging its dotted 
grab bar. Toolbars can be docked to any side 
of the program window, or they can be 
undocked and left floating. 

Undocked toolbars can be moved outside of 
the program window, and they can be closed 
completely. They can also be reshaped; 
however, they cannot be resized in such a 
manner that any buttons become hidden.

Toolbars are saved between program 
sessions. To restore the original toolbar 
positions and display, click the Reset 
Toolbars button in the Toolbar 
Customization dialog. See “Toolbar Panel” 
on page 137. 

Adding and Removing Buttons
Toolbar buttons can be added to or removed 
from toolbars using the Toolbar 
Customization dialog.

To add a button to a toolbar

1. Select Tools> Toolbar and Hotkeys> 
Customize Toolbars  and go to the 
TOOLS panel of the Toolbar 
Customization dialog. See “Tools 
Panel” on page 136.

2. Select the View Type that you want to 
add a toolbar button in.

•  You can add any buttons you like to 
any View Type; however, not all but-
tons will necessarily be available for 
use in all views. 

3. Search or browse to find the desired but-
ton or its parent in the Available Tool-
bar Buttons list.

4. Click and drag the button you wish to 
add to a toolbar out of the dialog box.

•  Drop it onto an existing toolbar to add 
the button to that toolbar.

•  Drop it away from an existing toolbar 
to create a new toolbar. The selected 
button is first in the new toolbar. The 
new toolbar is named with the current 
view followed by a number. 
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To remove a button from a toolbar, open the 
Toolbar Customization dialog, then click 
and drag the button out of the toolbar area. 

Buttons cannot be added to or removed from 
the Edit toolbar. See “The Edit Toolbar” on 
page 37.

Adding and Removing Toolbars
Toolbars can be added to or removed from 
each View Type using either the toolbar 
contextual menu or the Toolbar 
Customization dialog.

To add or remove an existing toolbar

1. Right-click on an empty space in a tool-
bar. 

2. In the contextual menu, click on the 
name of a toolbar. 

•  If the toolbar has a checkmark next to 
it, clicking on it will clear the check-
mark and remove the toolbar from the 
current View Type.

•  If the toolbar does not have a check-
mark next to it, clicking on it will add 
the toolbar to the current View Type.

You can also specify which toolbars are used 
in each View Type in the Toolbar 
Customization dialog. See “Toolbar Panel” 
on page 137.  

Creating New Toolbars
New toolbars can be created using the 
Toolbar Customization dialog.

To create a new toolbar

1. Select Tools> Toolbar and Hotkeys> 
Customize Toolbars  and go to the 
TOOLS panel.

2. Select the View type to which you want 
to add a new toolbar.

3. Select the first button that you want on 
the toolbar from the Available Toolbar 
Buttons list.

4. Click and drag the button out of the dia-
log box and drop it:

•  In an empty section of the program 
window border to create a new toolbar 
docked at that location.

•  In the drawing area to create a new, 
undocked toolbar.

5. Additional buttons can be added to this 
new toolbar.

6. By default, a new toolbar will inherit the 
name of the first tool that was added to 
it, preceded by the word Custom. You 
can assign a new name in the Toolbar 
Customization dialog. See “Toolbar 
Panel” on page 137.

7. Still on the TOOLBAR panel, specify the 
View Types that the new toolbar should 
be used in.

Locking Toolbars
When your toolbars are organized the 
way you want them, you can select 

Tools> Toolbars and Hotkeys> Lock 
Toolbars to prevent them from being moved. 
Select the same tool to unlock toolbars. Lock 
Toolbars is also available in the contextual 

You can use the Empty Space button in
your toolbars as a spacer.
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menu for toolbars: right-click in an empty 
space on any toolbar to access it. See 
“Contextual Menus” on page 38. 

Restoring Toolbars
To discard your changes and restore all 
installed Toolbar Configurations to their 
original condition, click the Reset Toolbars 
button in the Toolbar Customization dialog. 
See “Toolbar Panel” on page 137.

Because Reset Toolbars affects all Toolbar 
Configurations, you may find it worthwhile 
to create your own custom Toolbar 
Configurations.

You can also restore toolbars to their original 
state in the Preferences dialog. Note that if 
toolbars are restored using this option, any 
custom configurations that you have created 
will be discarded. See “Reset Options Panel” 
on page 126.

Creating Custom Toolbar Configurations
If you extensively edit your toolbars, you 
may want to consider creating one or more 
custom Toolbar Configurations so that your 
changes can be backed up as well as 
transferred to a different computer if you 
wish. 

To create a custom configuration

1. Go to the CONFIGURATIONS panel of the 
Toolbar Customization dialog.

2. Select a configuration similar to the one 
you want to create and click Copy.

3. Give the new configuration a short, 
unique name. It will be saved in the 
Chief Architect Toolbars folder. See 
“Chief Architect Data” on page 53.

4. When you click Save, the new configu-
ration will be active. It will appear in the 
list, and will be highlighted.

5. You can now move toolbars, add or 
remove buttons, and add or remove tool-
bars to meet your requirements.

6. Select each of the different View Types 
to see the toolbars active in each and 
confirm that they suit your needs.

•  Select each of the different View Types 
to see the toolbars active in each and 
confirm that they suit your needs.

7. When you are satisfied with your new 
Toolbar Configuration, click Close.

Custom Configuration Buttons
By default, new Toolbar Configurations 

display a default configuration  button; 
however, if you want you can make your 
own button icon for your custom Toolbar 
Configuration. 

Create a .bmp file with the same name as the 
configuration and save it in the Toolbars 
folder. To see an example, look at the 
Default.bmp file in the Chief Architect 
Toolbars folder, which corresponds to the 
Default Toolbar configuration. See “Chief 
Architect Data” on page 53. 
• Toolbar button bitmaps must be 20 x 20 

pixels in size. 

It is a good idea to back up your Toolbar
Configuration files. See “Chief Architect

Data” on page 53.
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• The color (R:192, G:192, B:192) maps to 
the system 3D face color.

• The color (R:128, G:128, B:128) maps to 
the system 3D Shadow color.

• The color (R:223, G:223, B:223) maps to 
the system 3D light color.

Importing Custom 
Configurations

Toolbar Configurations can be imported into 
the program, allowing you to transfer custom 
configurations between computers as well as 

add backed up configurations to new 
installations. 

To import a custom configuration

1. Go to the Configurations tab of the 

Toolbar Customization  dialog.
2. Click Add.
3. Browse to the location of the toolbar you 

want to import.
4. Click Open. If the .toolbar file is not in 

the Chief Architect Toolbars folder, a 
copy of the file will be created there.

Toolbar Customization Dialog
Select Tools> Toolbars and 
Hotkeys> Customize Toolbars to 

open the Toolbar Customization dialog. You 
can also right-click in an empty space in any 
toolbar and select Customize Toolbars from 
the contextual menu.

In the Toolbar Customization dialog, you 
can:
• Add and remove buttons from toolbars.
• Specify which of the available toolbars 

display in different view types. 
• Select the active Toolbar Configuration.
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Tools Panel
The settings on the TOOLS panel allow you to 
add or remove buttons from your toolbars, as 
well as to create new toolbars.

Select the View Type that you would 
like to add toolbar buttons to. When the 

dialog is first opened, the selected View Type 
is that of the current view. If you select a 
different View Type, the toolbars associated 
with it will display behind the dialog for 
reference until you click the Done button. 

The Available Toolbar Buttons 
display in a list that can be searched or 

browsed. 
• Type a keyword or the name of a tool in 

the Search field. As you type, only but-
tons that match your search will display. 
When nothing is typed in this field, all 
buttons will display in the list. 
If a child tool matches your search, its 

parent will display in the search results. 
Click the arrow next to the parent’s name 
to see the child tools.

• The Available Toolbar Buttons list can be 
browsed using the scroll bar to the right. 

• Click on a button in the list to display a 
description of that tool, below. 

• Parent tools have an arrow to the right of 
their button icon in the list. Click on this 
arrow to display the child tools below the 
parent. See “Toolbar Arrangement” on 
page 129. 

If you do not see a particular button in the 
list, it may be the child of a parent tool. 

1

2
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Tool Description - When a button is 
selected in the list above, a description 

of it displays here.

Toolbar Panel
The TOOLBAR panel allows you to manage 
the use of individual toolbars.

When this dialog is first opened, the 
selected View Type is that of the 

current view. If you select a different View 
Type, the toolbars associated with it will 
display behind the dialog for reference until 
you click the Done button. 

The Toolbars table displays the names 
of all available toolbars, along with the 

View Types in which they are in use. 
• Select a toolbar by clicking on its name. 

• Click to place a checkmark in a column 
to add the selected toolbar to that View 
Type; click on checkmark to remove it.

• Double-click on a toolbar in the Toolbar 
Name column to rename it. Toolbar 
names must be unique.

• Click Delete to remove the selected tool-
bar from the list. A deleted toolbar is no 
longer available in any View Type.

• Click Reset Toolbars to restore all the 
toolbars to their original configuration. 
See “Restoring Toolbars” on page 134. 

3

1

2
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Configurations Panel
The CONFIGURATIONS panel allows you to 
add, remove, and switch between Toolbar 

Configurations. See “Toolbar 
Configurations” on page 131.

A list of Toolbar Configurations displays 
here. Select a configuration before clicking 
the Remove, Copy, or Switch To buttons.
• Click Switch To to switch to the selected 

Toolbar Configuration. See “To switch 
toolbar configurations” on page 131.

• Click Copy to create a copy of the 
selected Toolbar Configuration. 

• Click Remove to remove the selected 
Toolbar Configuration. This removes the 
configuration from the list but does not 
delete the configuration file permanently. 
If only one configuration is listed, it can-
not be deleted. 

• The location of the Current Toolbars 
Folder displays below. See “Chief Archi-
tect Data” on page 53.

Hotkeys
Many Chief Architect tools have a keyboard 
shortcut, or hotkey, associated with them. If 

such a hotkey exists, it will display to the 
right of the tool’s name in the menu.

Clicking the Reset Toolbars button
removes all changes that you may have

made to all installed Toolbar Configurations.
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To use a hotkey, simply press the appropriate 
key or combination of keys on your keyboard 
instead of selecting the menu item or clicking 
the toolbar button. For example, press the 
Ctrl and Z keys at the same time to perform 

an Undo .

You can specify the hotkeys associated with 
Chief Architect tools in the Customize 
Hotkeys dialog. In this dialog, you can 
program hotkeys to activate tools and invoke 
a variety of commands such as opening 
dialogs, including Defaults dialogs.

Number keys can be, and are, used as 
hotkeys. Bear in mind that if a number key is 
assigned as a hotkey, the corresponding 
number pad key will invoke the same 
command as long as it is not assigned to 
something else. The converse, however, is 
not true: if a number pad key is assigned as a 
hotkey, the corresponding number key will 
not invoke that command. 

Create Hotkey List
A list of the hotkeys available to the current 
program user can be saved in .html or .xhtml 
format.

Select Tools> Toolbars and Hotkeys> 
Create Hotkey List to open the Save 

Hotkey List File dialog, a standard Save 
dialog, and create a hotkey list that can then 
be opened in a web browser window and 
printed, if you wish.

Next/Last Command
You can navigate a list of up to 100 recently 
used tools using the Cancel Selection/
Previous Command, Next Command and 
Previous Command hotkeys. The tools in 
this list are organized according to the order 
in which you selected them during the 
current program session. 

Cancel Selection/Previous Command, 
Next Command and Previous Command 
are hotkeys only: they do not have toolbar 
buttons associated with them and are not 
found in the menu. 

By default, Cancel Selection/Previous 
Command is assigned to the Esc key. This 
command can be used to:
• Cancel a current object selection.
• Cancel a current drawing or editing 

action that is in progress.
• Activate the previously used tool or com-

mand if no object is selected or action in 
progress.

By default, Next Command is assigned to 
the Shift+Esc keys. This command can be 
used to deactivate the current command and 
instead activate the one that is next in the list 
of recently used tools. 

Note: If a key or key combination is in use as
a system hotkey, it cannot be used as a pro-
gram hotkey.

Edit menu items with button icons 
to the left and hotkeys to the right

When cancelling a selection or a com-
mand, be careful to press the Esc key

only once to avoid changing the currently
active tool.
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If you prefer, you can assign two different 
hotkeys to the Cancel Selection and 

Previous Command instead of one single 
hotkey. 

Customize Hotkeys Dialog
Select Tools> Toolbars and 
Hotkeys> Customize Hotkeys to 

open the Customize Hotkeys dialog. 

Show Commands/Hotkeys 
Containing - 

• Click on an item in the list of Command 
Names and Hotkeys to select it.

• To filter the list, type part or all of a tool 
name or hotkey in the Search field, 
above. As you type, the list below will be 
filtered to only show items with either a 

Command Name or Hotkey that contains 
what you have typed. 

• Click the Clear  button on the right 
side of the Search field to remove any-
thing typed in this field. When the field is 
cleared, all Command Names and Hot-
keys are shown in the list.

1
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Tool Available In - A list of the View 
Types that the selected command can 

be used in displays here.

A brief Description of the selected 
command displays here.

Click on an item in the list of Commands 
and Hotkeys to select it.

Edit hotkey for this command - Click 
in this field, then press the key or key 

combination that you would like to use. 
• Create a simultaneous hotkey combina-

tion by holding down the Shift, Ctrl, and/
or Alt keys and typing an additional letter 
or number.

• Create a hotkey sequence by typing up to 
four hotkeys or hotkey combinations, one 
after the other. 

Bear in mind that while nearly all commands 
can be assigned custom hotkeys, a few 
cannot: Delete and Enter Coordinates are two 
notable examples. Hotkeys reserved by the 
operating system cannot be used, either.

Click the Reset Hotkeys button to 
restore the default hotkeys that were 

originallyl installed with the program.

Exporting and Importing Hotkeys
Customized hotkeys are user 
specific and are saved in the Chief 

Architect X8 Data folder. See “Chief 
Architect Data” on page 53. 

Hotkeys can be exported, making them 
available for import on another computer, or 
even by another user on the same computer.

Exporting Hotkeys
To export hotkeys, select File> 
Export> Hotkeys. The Export 

Hotkeys dialog is a typical Save As dialog 
that lets you specify the exported file’s name 
and its saved location on your computer. See 
“Exporting Files” on page 58. 

Exported hotkey files use the .xml file 
format. Information exported includes both 
customized hotkeys and hotkeys installed 
with the program. 

Importing Hotkeys
To import hotkeys, select File> 
Import> Hotkeys. The Import 

Hotkeys dialog is a typical Open File dialog. 
See “Importing Files” on page 62. 

When hotkeys are imported, the existing 
User Hotkeys.xml file is replaced by the 
imported data. Any previously programmed 
custom hotkeys will not be retained. 

2

3

4

Note: Default hotkeys use the number keys
and number keypad interchangeably. User
defined hotkeys, however, do not. As such,
when a custom hotkey is defined here, char-
acters typed using the numpad begin with
“Num +” in Windows, and “Num” on a Mac.

5
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Chapter 5:

Layers

Layers are used to organize and manage the 
display of all objects in all views and in the 
Materials List. A layer can be thought of as a 
transparency sheet with objects placed on it 
for viewing. Nearly all views use multiple 
layers, like a stack of transparencies put 
together to show different types of objects. 

You can find out which layer an object is on 
in its specification dialog or by selecting the 
object and looking at the Status Bar. You can 
customize how each layer displays in the 
Layer Display Options dialog. 

Multiple layers are organized into Layer 
Sets, which are designed to help you perform 
different tasks efficiently or produce specific 
views for your construction documents or for 
presentation purposes. You can customize 
the display settings for individual layer sets 
and can also copy, add and delete layer sets.

Different types of 2D and 3D views use their 
own layer sets. You can specify the initial 
layer set used by a particular type of view in 
the Layer Set Defaults dialog.

Chapter Contents
•      Displaying Objects
•      Layer Sets
•      Layer Set Management
•      Active Layer Set Control
•      Layer Display Options Dialog
•      Active Layer Display Options
•      Select Layer Dialog
•      Layer Panel
•      Object Layer Properties
•      Layer Painter, Eyedropper and Hider
•      Layout Layer Sets
•      Exporting and Importing Layer Sets
•      Layer Set Defaults Dialog
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Displaying Objects
The display of objects in different views is 
controlled by layer sets and layers in the 
Layer Display Options dialog. See “Layer 
Display Options Dialog” on page 149.

Primary and Secondary Layers
Every object is placed on a layer which 
controls whether it displays in a given view. 
This layer is referred to as the object’s 
primary layer, and you can see its name in 
the Status Bar when the object is selected. 
See “The Status Bar” on page 42. 

In addition, some objects have secondary 
layers which may alter the appearance of 
objects on the primary layer, but do not 
control whether the objects display or not. 

For example, the default primary layer for 
base cabinets is “Cabinets, Base”. In 
addition, base cabinets have a number of 
secondary layers that control the display of 
the countertop, face indicators, door opening 
indicators, module lines and labels.

You can view a list of an object’s primary 
and secondary layers  by selecting it and 

clicking the Object Layer Properties  
edit button. See “Object Layer Properties” on 
page 154. 

In All Views
All layers with a check in the “Disp.” column 
display when the current layer set is active. 

Objects that are not displayed cannot be seen 
or selected. If you try to place or draw an 
object on a layer that is hidden, the program 
asks if you want to turn the layer on.

Some objects cannot stand alone in a 
drawing: they can only be inserted into 
another object. If the display of an object that 
contains an inserted object is turned off, the 
display of the inserted object will be turned 
off, as well  For example, if the display of a 
wall is turned off, any doors and windows in 
that wall will not display either. See 
“Inserted Objects” on page 837.

Materials Lists
Layers showing an “M” in the Mat column 
are included in subsequently generated 
materials lists. This allows you to control the 
inclusion of objects in the Materials List on a 
layer-by-layer basis. 

Some default layers, such as Patterns, do not 
generate materials and are not included by 
default. See “Materials Lists and Layers” on 
page 1290.

Note: If an object’s primary layer is turned off,
information on its secondary layers will not
display - even if those layers are turned on.
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The overall content and organization of 
materials lists can be controlled in the 
Preferences dialog. See “Materials List 
Panel” on page 119.

To control the components that are included 
in a Materials List for a particular object, 
select the object and click the 

Components  edit button. See 
“Components Dialog” on page 1300.

Line and Text Styles
A layer’s Color, Weight, Line Style and 
Text Style attributes determine how an 
object on that layer appears in floor plan 
view and in 3D views using the Vector View 
rendering technique.

Many objects, including all CAD and text 
objects, allow you to override these settings 
for an individiual instance without changing 
its layer.

Edge and Pattern Lines
In 3D Vector Views, objects are represented 
using lines to define their surface edges. By 
default, Edge Lines use the attributes set for 
the object’s layer, as described above. 

Some CAD-based architectural objects, such 
as Slabs, have line style settings in their 
specification dialogs; however, these 
specifications are not used unless Use 
Object Settings is checked in the 3D View 

Defaults dialog. See “Options Panel” on 
page 893. 

In addition, a material applied to an object 
surface may have a pattern associated with it. 
Pattern line color, weight, and spacing is set 
in the Define Material dialog. See “Pattern 
Panel” on page 867. 

Locking Layers
Objects on layers with a lock symbol in the 
Lock column cannot be selected by the user. 

New objects cannot be drawn on a locked 
layer, either. If you lock a layer and then 
attempt to draw a new object on that layer, a 
message box will ask you to unlock the layer. 

Layers with objects that you need to see as a 
reference while working, but not select, are 
good candidates for locking. For example: 
• Locking the “Rooms” layer can make it 

easier to select objects located inside of 
rooms. 

• Locking the “Roof Planes” layer can 
make it easier to select objects located 
under the eaves. 

Another use for locking layers is to protect 
them from editing in plans opened by clients 
or others in select Home Designer programs. 
See “Opening Chief Architect Plans in Home 
Designer Programs” on page 52.
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Copying and Pasting
If you place an object on a renamed or 
custom layer and then paste it into a new plan 
or layout file, a new layer will be created in 
the destination file. See “Copying and 
Pasting Objects” on page 170.

Layer Sets
Layer Sets are used to control the layer 
settings for different views in a plan or layout 
file. All views associated with a plan file - 
including views sent to layout - make use of 
layer sets stored in that .plan file. 

A layer set consists of a complete list of the 
layers in the current plan or layout along with 
the display settings for each layer as set for a 
particular type of view or purpose. These 
display settings can be modified, and can be 
different for each layer set. See “Layer 
Display Options Dialog” on page 149.

Any changes made to a layer set in one view  
affects all other views using the same layer 
set.  If this is not desired, you can create a 
unique layer set for a particular view.  See 
“Layer Set Management” on page 147.

Layer sets are file specific, which means that 
changes made in one plan or layout file have 
no effect on the settings in other files. If you 
find that you use the same settings often, you 
should consider adding these layer sets to 
your template files. See “Template Files” on 
page 84.

While any view is active, select Tools> 
Layer Settings> Display Options  to 
make changes to the layer set used for that 
view type. 

Annotation Sets
Layer Sets are among the items associated 
with Annotation Sets, which are groups of 
Saved Defaults that can be customized and 
activated for specific drawing tasks. See 
“Annotation Sets” on page 80.

Layout Layer Sets
Views sent to layout use layer sets saved with 
the plan, rather than with the layout.  See 
“Displaying Layout Views” on page 1246.

Layer Sets and Templates
Layers and layer sets are plan-specific. A 
custom layer set that you created in one plan 
file may not be available in another. To 
include a custom layer set in all new plan 
files, add it to your template plan.  See 
“Exporting and Importing Layer Sets” on 
page 157 and “Template Files” on page 84.

Locking a layer does not prevent
objects on that layer from being modi-

fied. Most objects can be deleted using the
Delete Objects dialog. Objects are also
deleted if the floor they are placed on is
deleted. See “Deleting Objects” on page 255. 

Each plan file can have an unlimited
number of layer sets.
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Modify All Layer Sets
If you want changes made in one layer set to 
apply to all other layer sets in the current 
plan, check Modify All Layer Sets in the 
Layer Display Options dialog before 
making changes. The layer name and display 
attributes are applied to all other layer sets. 

For example, if you check Modify All Layer 
Sets and then change the color and line style 
for the Text layer of the Electrical Set, the 
same changes are applied to the Text layer of 
the Framing Set of the same plan.

Layer Set Defaults
Whenever a particular type of view is 
created, such as floor plan view or a framing 
overview, a specific layer set is activated for 
that view. Which layer set becomes active 
depends on the type of view created.

The default layer sets for nine different view 
types, including the Reference Floor, are 
specified in the Layer Set Defaults dialog. 

Each of these layer sets can be edited as 
needed in the Layer Display Options dialog. 
See “Layer Display Options Dialog” on page 
149.

Normally, it is best to change the settings in 
the existing default layer sets rather than 
select different default layer sets, but you can 
do so if needed. See “Layer Set Defaults 
Dialog” on page 158.

Layer Set Management
The Layer Set Management dialog 
lists the layer sets available in the 

current plan or layout file and lets you add 
and remove layer sets and modify and copy 
existing layer sets. Select Tools> Layer 
Settings> Layer Set Management to open 
this dialog.

In order for changes to a layer to be
applied to all layer sets, you must

check Modify All Layer Sets before making
the changes. 
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Use the Available Layer Sets options 
to manage the layer sets saved with the 

current plan or layout file.
• Click on a layer set name in the list to 

select it.
• Click the Define button or double-click 

on the layer set name to open the Layer 
Display Options dialog and make 
changes to the selected layer set. 

• Click the New button to open the New 
Layer Set Name dialog and create a new 
layer set based on system default settings. 

• Click the Copy button to open the New 
Layer Set Name dialog and create a new 
layer set based on a copy of the currently 
selected layer set.

• Click the Rename button to open the 
Rename Layer Set dialog and type a new 
name for the selected layer set. Not avail-
able for the Default Set.

• Click the Delete button to delete the 
selected layer set from the current file. 
The Delete button is enabled if the layer 
set can be deleted: you cannot delete the 
active layer set, the Default Set, or any 
layer set in use as a default. 

Do not delete any layer sets that are used 
by a layout. 

• Click the Import button to import layer 
settings from a .layers file. See “Export-
ing and Importing Layer Sets” on page 
157.

• Click the Export button to export the 
layer settings in the current plan in a .lay-
ers file. 

The Active Layer Set for Current 
View options affect only the layer set 

used in the view that was active when the 
Layer Set Management dialog was opened. 
• Select a new Active Layer Set from the 

drop-down list or click the Define button 
to make changes to the active layer set in 
the Layer Display Options dialog.

Reference Floor Layer Set -Click the 
drop-down list to specify which layer 

set is used by the Reference Floor when it is 
turned on. See “Reference Floor Display” on 
page 444. Not available when the dialog is 
opened in a layout file.
• Select a new Reference Floor Layer Set 

from the drop-down list or click the 
Define button to make changes to the 
selected layer set in the Layer Display 
Options dialog. 

Active Layer Set Control
The Active Layer 
Set Control drop-

down list displays on the toolbar for all views 
and provides convenient access to a list of all 

layer sets saved with the plan. Click the 
drop-down list to select a new layer set for 
the current view. 

1

2

3
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Layer Display Options Dialog
The Layer Display Options dialog 
controls the display of layers in a 

selected layer set. It consists of a table that 
lists all available layers and the attributes for 
each. Layers can be added and deleted. There 
is no limit to the number of layers that can 
exist in a plan.

From any view except the Materials List, 
select Tools> Layer Settings> Display 
Options  to open the Layer Display 
Options dialog. 

There are a number of dialogs similar to 
Layer Display Options in the program: 
• Select Tools> Reference Floors> Refer-

ence Floor Display Options  to open 
the Layer Display Options dialog with 

the Reference Display Set active. See 
“The Reference Floor” on page 444.

• Select Tools> Display Options  in a 
materials list to open the Materials List 
Display Options dialog. See “Materials 
List Display Options Dialog” on page 
1291.

• Select Tools> Layer Settings> Display 
Options  in a layout to open the 
Layout Page Display Options dialog. 
See “Layout Page Display Options” on 
page 1236. 

• The Layer Display Options dialog is 
also available for views sent to layout. 
See “Displaying Layout Views” on page 
1246. 
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The Layer Sets options let you specify 
which layer set - or sets - is affected by 

changes made in this dialog. 
• The currently selected layer set displays 

in the drop-down list. 
• Click the Copy Set button to create a 

copy of the current layer set.
• Check Modify All Layer Sets, then 

make changes to one or more layer’s 
attributes and click OK. The changes will 
be applied to the layer(s) in all layer sets. 
See “Modify All Layer Sets” on page 
147.

The Properties for Selected Layer Set  
are presented in a table of layers and 

their attributes. You can filter the names that 
display in the list by typing in the Name 
Filter text field. When nothing is typed in 
this field, all layers display. You can also 
click a column header to sort all layers in the 
table by that column. An arrow above a 
column indicates that it is being used to sort 
the table, and in which direction it is being 
sorted. 

1 Modify All Layer Sets is a one-time
action. It is always unchecked when

the Layer Display Options dialog is opened.

2
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The Name column is sorted alphabetically. 
Layers are named so that similar object types 
are listed near one another, and sorting is 
case sensitive to allow greater control over 
organization. Double-click a layer in the 
Name column to rename it. 
• A red + in the Used column indicates 

which layers have objects placed on them 
in the current plan. This column cannot 
be edited. 

• A check in the Disp column indicates 
which layers are set to be visible. If a 
layer is turned off, this column is blank.

• An M in the Mat column indicates which 
layers are included in the Materials List.

• A yellow  in the Lock column indicates 
which layers are locked, preventing 
objects on that layer from being selected. 
See “Locking Layers” on page 145.

• The Color column shows the line color 
for each layer and can be sorted so that 
like colors are listed together.

• The Line Style column shows the line 
style for each layer and can be sorted so 
that like line styles are listed together.

• The Line Weight column displays the 
line weight used by each layer and can be 
sorted so that like line weights are listed 
together. See “Line Weights” on page 
1223. 

• The Text Style column shows the text 
style assigned to each layer and can be 
sorted so that layers using the same style 
are listed together. See “Text Styles” on 
page 1061.

The buttons below the table offer additional 
control over the layers in the table.

• Click the Select All button to select all 
layers in the table at once. This allows 
changes to be quickly applied to all lay-
ers.

• Click the New button to open the New 
Layer Name dialog and create a new 
layer with a unique name of your choice. 
Duplicate layer names are not allowed.

• Click the Copy button to create a copy of 
the selected layer. The new layer is added 
directly below the original in the table.

• Click the Delete button to delete the 
selected layer. You cannot delete used 
layers or any of the system layers used by 
Chief Architect.

• Click the Reset Names button to revert 
layer names for system layers back to the 
original names that installed with Chief 
Architect. This does not affect layers you 
created.

• Click OK to close the dialog and apply 
your changes.

• Click Cancel to close the dialog, ignor-
ing any edits.

Layers are selected by clicking on them in 
the table. Hold down the Shift key or the Ctrl 
key to select multiple layers at once. Press 
Ctrl + A or click the Select All button to 
select all layers in the table. When selected, a 
layer’s attributes display and can be edited 
below. 

Note: New layers are added to all layer sets.
However, in all but the current layer set, their
display will be turned off. 
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The Properties for “Selected Layer” 
options let you modify the attributes of 

one or more selected layers. Line Color, 
Style, and Size affect lines in floor plan view 
and surface edge lines in Vector Views. 
When multiple layers are selected, “No 
Change” may display for attributes that are 
not shared by the selected layers.
• To turn off a selected layer, uncheck 

Display. See “Displaying Objects” on 
page 144. 

• Uncheck Materials List to exclude all 
objects on a selected layer from the Mate-
rials List. See “Materials Lists” on page 
1283.

• To protect the objects on a selected layer 
from accidental changes, check Lock. 
Items on locked layers can display but 
cannot be selected. See “Locking Layers” 
on page 145.

• To change the color of lines on a selected 
layer, click the Color bar to open the 
Select Color dialog. See  “Color 
Chooser/Select Color Dialog” on page 
875. 

• Specify the default Line Weight, or 
thickness, for objects on the selected 
layer. See “Line Weights” on page 1223.

• To change the Line Style of a selected 
layer, click the drop-down arrow or the 
Library button to select a line style from 
the library. See “Line Styles” on page 
1108.

• To change the Text Style of a selected 
layer, click the drop-down arrow or click 
the Define button to open the Text Style 
Defaults dialog. The Define button is not 
available when multiple layers with dif-
ferent Text Styles are selected. See “Text 
Style Defaults” on page 1062.

Active Layer Display Options
The Active Layer Display Options 
side window allows you to access the 

layer settings for the currently active Layer 
Set or the Object Layer Properties for the 
currently selected object. Select View> 
Active Layer Display Options to open or 
close this side window. 
• When no object is selected, the settings 

for the active Layer Set are shown. See 
“Layer Sets” on page 146.

• When one or more objects are selected, 
the objects’ Object Layer Properties are 
shown. See “Object Layer Properties” on 
page 154.

The list of layers and the options for editing 
their attributes are similar to those in the 
Layer Display Options dialog. See “Layer 
Display Options Dialog” on page 149. 

The program remembers what layer(s)
are selected when you click OK and

selects them again when you return to this
dialog.

3

Note: Not all objects display in all views. For
instance, invisible walls do not appear in
camera views or materials lists, regardless of
the layer they are placed on or whether that
layer is turned on or not.
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Click the Settings  button at the bottom 
of the side window to specify what settings 
and information are presented:
• Select Layer Set Control to display the 

Layer Set drop-down list at the top of the 
side window. The name of the active 
layer set is stated and can be changed 
here.

• Select Layer Name Filter to display the 
Name Filter text box above the layer 
table. Type in this field to filter the names 
shown in the table; when nothing is 
typed, all relevant layers are listed. 

• Select Layer Edit Buttons to display the 
Select All, New, Copy, Delete, and Reset 
Names buttons below the layer table. 

• Select Layer Properties to display the 
Properties for Selected Layer settings 
below the label table.

• Select Show All Layers to list all layers 
in the table, even when an object is 
selected.

• Select which Columns to include in the 
table. 

By default, when the Active Layer Display 
Options side window is opened, it will be 
docked on the right side of the program 
window. Like other side windows, though, it 
can be moved. See “Side Windows” on page 
36.

Select Layer Dialog
The Select Layer dialog allows you to select 
a layer for one of two purposes: 

Select CAD> Current CAD Layer to 
open this dialog and specify which 

layer is the Current CAD Layer. See 
“Current CAD Layer” on page 1076. 

This dialog also opens when the 
Layer Painter tool is used. See 

“Layer Painter, Eyedropper and Hider” on 
page 155.

The Select Layer dialog contains the table of 
layers and Name Filter found in the Layer 
Display Options dialog. Click on a layer in 
the table to select it, then click OK.
• If the dialog was opened using the 

Current CAD Layer  tool, the 
selected layer will become the Current 
CAD Layer. 

• If the dialog was opened using the Layer 
Painter  tool, you can click on objects 
in the current view to assign them to the 
selected layer. The Current CAD Layer and Layer Painter

buttons can be added to your toolbars. See
“To add a button to a toolbar” on page 132.
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Layer Panel
The LAYER panel is found in the 
specification dialogs for many different 
objects. Here you can specify the layer that 
the program uses to display the selected 
object.

• Check Default to place the selected 
object on the default layer for that object 
type. If the selected object is an automati-
cally generated dimension line, frieze 
molding, or shadow board that has been 
edited, this box will be unchecked. See 
“Dynamic Defaults” on page 76.

• Click the drop-down list to select a layer 
from those available in the file. 

• Click Define to open the Layer Display 
Options dialog and select, modify, or add 
a new layer. See “Layer Display Options 
Dialog” on page 149.

Object Layer Properties
The Object Layer Properties edit 
tool allows you to access and edit the 

layer or layers associated with one or more 
selected objects. See “Primary and 
Secondary Layers” on page 144.

Some objects, such as CAD lines, only have 
one layer associated with them. Other 
objects, including many architectural objects 
like cabinets, have multiple layers that affect 
their display in various views. A few objects, 
such as active camera symbols and layout 
boxes, do not have this edit tool. 

Object Layer Properties Dialog
When you click the Object Layer 
Properties  edit button, the Object Layer 
Properties dialog opens. 

The settings in this dialog are similar to those 
in the Layer Display Options dialog.

Note: In some specification dialogs, layer
information is located on the Line Style or
Appearance panel rather than the Layer
panel.
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Type in the Name Filter text field to 
filter the names that display in the list 

below. When nothing is typed in the field, no 
layers are suppressed. 

A table listing the layers associated 
with the selected object(s) displays 

here. This sortable table functions like that in 
the Layer Display Options dialog. 
• Check Show All Layers to list all layers 

in the current file rather than just those 
associated with the selected object. When 

unchecked, only the layers associated 
with the selected object(s) display.

The Properties of the selected layer(s) 
display and can be edited here. 

• As in the Layer Display Options dialog,, 
when multiple layers with different prop-
erties are selected, drop-down lists may 
display “No Change” and checkboxes 
may have a solid fill. See “Dialogs” on 
page 39. 

Layer Painter, Eyedropper and Hider
The Layer Painter and Layer 
Eyedropper tools allow you to 

move an object to any layer in any view 
without opening its specification dialog. 

The Layer Hider tool lets you turn off 
the display of any layer in the 

currently active layer set by clicking on an 
object on that layer. 

1

2

3



156

Chief Architect X8 Reference Manual

To use the Layer Painter

1. In any view, select Tools> Layer Set-
tings> Layer Painter .

2. In the Select Layer dialog, choose a 
layer and click OK. Your cursor will dis-

play the painter  icon. See “Select 
Layer Dialog” on page 153.

3. Note that the name of the layer being 
painted is noted on the left side of the 
Status Bar at the bottom of the program 
window. See “The Status Bar” on page 
42. 

4. Move your cursor over an object and 
notice that the Status Bar now states 
both the layer being painted and the cur-
rent layer of the target object. 

5. Click on objects in the view to move 
them to the selected layer. 

To use the Layer Eyedropper

1. In any view, select Tools> Layer Set-
tings> Layer Eyedropper .

2. Click on an object to load the layer it is 
on into the Layer Painter. 

3. Your cursor will display the painter  
icon, and you can click on other objects 
to place them on the selected layer.

To use the Layer Hider

1. In any view, select Tools> Layer Set-
tings> Layer Hider .

2. Your cursor will display the layer  
icon. 

3. Move your cursor over an object and 
notice that the Status Bar states the 
object’s primary layer. 

4. Click on the object to turn off the display 
of its primary layer in the currently 
active layer set. See “Layer Sets” on 
page 146.

Layout Layer Sets
Layer sets are an effective way to control not 
just what displays while you are working, but 
what displays in the views you send to layout 
and print. See “Layout” on page 1235.

When you send a view to layout, you have 
two choices as to which layer set the view 
uses:
• You can use the same layer set as the 

original view being sent to layout.

• You can make a copy of the layer set used 
by the original view. 

Both approaches have advantages and 
disadvantages, so you should use the option 
that best suits your needs. To learn more 
about the pros and cons of each approach, 
see “This new layout box references the 
“Layout Set 1” layer set saved in your plan”.

Whichever option you choose, remember 
that the layer set used by a layout view is 

http://www.chiefarchitect.com/support/article/KB-00939/
http://www.chiefarchitect.com/support/article/KB-00939/
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always saved with the plan that the view was 
originally sent to layout from. For this 
reason, you should avoid deleting layer sets 
from a plan unless you are absolutely sure 
that they are not being used by layout views. 

You can find out which layer set a layout 
view is using by selecting it and clicking the 

Layout Box Layers  edit button. See 
“Displaying Layout Views” on page 1246. 

If you select a layout view and click the 

Open View  edit button, you will return 
to the original view in the plan file. Bear in 
mind that the layout view’s layer set will be 
active. If you  make changes to its settings, 
the view on the layout page will be affected. 

Exporting and Importing Layer Sets
Layer sets created in one plan can 
be exported as a .layers file and 

imported into other plans. This is a 
convenient alternative to re-creating one or 
more layer sets that may already exist in 
another plan.

Exporting Layer Sets
To export layer sets from the current 
plan or layout file, select File> 

Export> Export Layer Sets or click the 
Export button in the Layer Set 
Management dialog.

The Save Layer Set File dialog is a typical 
Save As dialog. Exported layer set files use 
the .layers file extensions. See “Exporting 
Files” on page 58.

Importing Layer Sets
To import layer sets into the current 
plan or layout, select File> Import> 

Import Layer Sets or click the Import 
button in the Layer Set Management dialog.

The Import Layer Set File dialog is a typical 
Open File dialog. See “Importing Files” on 
page 62.

When the desired .layers file is selected, 
click Open. The Import Layer Sets dialog 
will open next.

• Select a layer set or hold down the Shift 
key to select multiple sets. 

• Check Replace Identically Named Lay-
ers to replace any layers present in the 
destination file if they have identical 
names to layers being imported. When 
unchecked, layers in the destination file 
may be replaced by imported layers with 
different names. Generally, this box 
should be checked unless you wish to 
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reset existing layer names in the destina-
tion file. 

• Click OK to close the dialog and import 
the selected layer sets. 

As layers sets are imported, the program 
checks the destination file for any layers with 
the same name as those being imported. If a 
layer in the destination file has an identical 
name to a layer being imported, it will be 
replaced by the imported layer. 

Layer Set Defaults Dialog
The Layer Set Defaults dialog is used 
to specify the initial layer sets for 

different view types.  Select Edit> Default 
Settings to open the Default Settings dialog, 
then select Layer Sets from the list and click 
the Edit button.

When  a new view is created for any of the 
specified view types, Chief Architect sets the 
default layer set listed here as the active layer 
set for that view. Click the drop-down list to 
change the initial layer set for each type of 
view.

Select Use Active Layer Set to use the 
currently active layer set for the new view 
when it is created.

Click the Define button to open the Layer 
Display Options dialog and change the layer 
settings for the layer set. See “Layer Display 
Options Dialog” on page 149.
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Chapter 6:

Creating Objects

There are a wide variety of objects in Chief 
Architect that you can use to create complete 
3D models and working drawings. Although 
these objects are sometimes very different 
from one another, the methods used to create 
them are similar. 

Once an object is created, it can be selected 
and edited to meet the requirements of your 
project. The editing characteristics common 
to most objects are described elsewhere. See 
“Editing Objects” on page 177. 

Chapter Contents
•      Architectural vs CAD Objects
•      Defaults and Preferences
•      Snap Behaviors
•      Object Snaps
•      Angle Snaps
•      Grid Snaps
•      Creating Objects
•      Copying and Pasting Objects
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Architectural vs CAD Objects
There are two broad categories of objects in 
Chief Architect: architectural objects and 
CAD objects. 

CAD objects such as  lines, arcs, text, and 
dimensions are 2D objects that can be 
created and edited in floor plan view, and 
cross section/elevation views, CAD detail 
windows, and on layout pages but do not 
display in 3D camera views and overviews. 
See “The CAD Drawing Tools” on page 
1075. 

In contrast, architectural objects such as 
walls, cabinets, doors, windows, and stairs 
display in 2D and 3D views. Architectural 
objects can be created and edited in 2D and 
3D views but not in CAD Detail windows or 
on layout pages.

Some architectural objects, such as custom 
countertops and slabs, have some behaviors 
in common with CAD objects and are 
referred to as CAD-based.

Defaults and Preferences
The ways that objects in the program behave 
as they are created and edited are affected by 
a number of default and preference settings. 
See “Preferences and Default Settings” on 
page 73.

Snap Settings
Select Edit> Snap Settings to access 
the three categories of Snap Settings 

that determine how objects snap to one 
another and whether they snap to allowed 
angles or to points on a grid, as well as object 
bumping and pushing behaviors.

Object Snaps enable snapping to 
objects. See “Object Snaps” on page 

162.

Angle Snaps enable snapping at 
Allowed Angles. See “Angle Snaps” 

on page 164.

Grid Snaps enable snapping to the 
Snap Grid.  See “Grid Snaps” on page 

166. 

Bumping/Pushing enables bumping 
and pushing behaviors. See 

“Bumping/Pushing” on page 221.

Edit Behaviors
Select Edit> Edit Behaviors to 
access the six global edit behavior 

modes that determine how dragging the edit 
handles with the left mouse button affects a 
selected object and may also affect how 
objects are drawn. 

The Default edit behavior provides 
the most commonly used editing 

options. See “Default” on page 178.

It is a good idea to be familiar with these
options and how they affect both draw-

ing and editing in the program.
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The Alternate edit behavior provides 
an alternative to the Default behaviors 

that may be more useful in some situations. 
See “Alternate” on page 179.

The Move edit behavior allows you to 
move a selected object using the 

corner handles and the Move handle. See 
“Move” on page 179.

The Resize edit behavior scales an 
object as you drag a corner handle. 

See “Resize” on page 180.

The Concentric edit behavior allows 
you to resize objects so that the 

distance moved by each edge is the same as 
all other edges. See “Concentric” on page 
180.

The Fillet edit behavior allows you to 
add a fillet at any corner of an object. 

See “Fillet” on page 182.

Connect CAD Segments
Select Edit> Edit Behaviors> 
Connect CAD Segments to toggle 

the ability to edit the individual segments of 
polyline-based objects and connected walls. 
It also affects the ability to snap line- and 
arc-based objects together as they are drawn 
to form a polyline. See “Disconnect Edges” 
on page 184. 

Rotate/Resize About
Objects can be rotated or resized 
about either their own centers or the 

Current CAD point. See “Point Tools” on 
page 1076. 

Specify which behavior is used by selecting 
Edit> Edit Behaviors> Rotate/Resize 

About Current Point  or in the 
Preferences dialog. See “Behaviors Panel” 
on page 113. 

Arc Creation Modes
Select Edit> Arc Creation Modes to 
access the five Arc Creation Modes 

that control how arcs and curved walls are 
drawn.

Free Form Arc mode allows you to 
define an arc by clicking and dragging 

along the desired path. See “Free Form Arc” 
on page 1089.

Center/Radius/End Arc mode allows 
you to define the center and radius of 

an arc, and then its length. See “Center/
Radius/End Arc” on page 1090.

Start/End/On Arc mode allows you 
to define the start and end points of an 

arc, then adjust the curvature. See “Start/
End/On Arc” on page 1090.

Start/Tangent/End Arc mode allows 
you to define the start and end points 

of an arc, its tangent and its curvature. See 
“Start/Tangent/End Arc” on page 1090.

Arc About Center mode allows you 
to draw an arc by defining the center 

and then the start and end points. See “Arc 
About Center” on page 1090.
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Snap Behaviors
There are three categories of 
snap behavior in Chief 

Architect that affect how objects are created 
and how they can be edited: 

• Object Snaps , which snap CAD and 
architectural objects to other objects. 

• Angle Snaps , which snap objects at 
specific angles. 

• Grid Snaps , which snap objects to 
points on a grid.

Snap behaviors can be controlled in the 
Preferences dialog and in the Plan or 
Layout Defaults dialogs. See “Snap 
Properties Panel” on page 115 and “General 
Plan Defaults Dialog” on page 88.

You can select Edit> Snap Settings  to 
quickly turn Object, Angle and Grid Snaps 
on or off. 

To temporarily disable Snap Behaviors and 
other move restrictions, press the Ctrl key 
while dragging an edit handle. See “Moving 
Objects” on page 220.

Hotkeys
You can also temporarily enable individual 
Snap Behaviors during a mouse editing 
operation using hotkeys. This can be helpful 

if you wish to use one particular type of snap 
behavior when you begin an operation, but a 
different behavior when you end it. 

The Snap Behavior hotkeys are listed on the 

right side of the Edit> Snap Settings  
submenu. See “Hotkeys” on page 138.

To use snap behavior hotkeys

1. Select Edit> Snap Settings  and 
toggle off the snap behavior category 
that you wish to control using hotkeys.

2. Select a tool that you wish to draw with 
or an object you wish to edit.

3. Begin drawing or editing and hold down 
the left mouse button without releasing.

4. Press and hold the appropriate key on 
your keyboard to enable the snap behav-
ior associated with it. 

5. When you are finished using the snap 
behavior, release the hotkey but continue 
holding down your left mouse button.

6. If you wish, you can press and hold a 
different hotkey on your keyboard and 
continue the drawing or editing opera-
tion.

7. When you are finished, release the left 
mouse button.

Object Snaps
Object Snaps allow you to position 
objects precisely relative to each 

other; for example, to position lines so that 

their endpoints meet or roof plane edges so 
that they are colinear.
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Object Snaps can be turned on or off by 
selecting Edit> Snap Settings> Object 
Snaps , by clicking the toggle button, or 
in the Preferences dialog. See “Snap 
Properties Panel” on page 115.

Object Snaps are indicated visually as you 
create or edit objects. To remove any object 
snap indicators that are visible on screen, 
press the 1 (one) key. As you continue 
drawing or editing, new indicators may 
appear.

With the exception of On Object  snaps, 
Object Snaps have priority over all other 
types of snapping in Chief Architect. 

Bumping/Pushing  overrides Object 
Snaps, however. See “Bumping/Pushing” on 
page 221.

Object Snap Locations
There are many locations on an object that 
other objects can snap to. In addition to snap 
points located on objects, Extension Snaps 
locate points away from objects. Each type 
of object snap can be toggled by selecting 

Edit> Snap Settings  or in the 
Preferences dialog. See “Snap Properties 
Panel” on page 115.

Regardless of which Object Snaps are active, 
when multiple objects are selected the 
selection set’s only snap point is its midpoint.

Extension Snaps
For some operations, it is helpful to snap to a 
point far away from an original object, while 
maintaining a relationship to a point on that 
object. For example, you may want to snap to 
a point exactly perpendicular to a line’s 

endpoint. Extension Snaps are helpful in 
these situations.

Extension Snaps are indicated by extension 
anchors, indicated by small blue circles. 

Anchors display for Endpoint, Midpoint, and 
Quadrant snaps when these snap behaviors 
are enabled.

When an anchor is established, you can 

create Tangent , Perpendicular  and 

Orthogonal  extension lines relative to it. 

To use extension snaps

1. Toggle on Object Snaps  and make 
sure the extension snaps are enabled.

2. Draw a Rectangular Polyline .

3. Select the Draw Line  tool and move 
your pointer along the edges of the poly-
line.

4. When your pointer passes over an end-
point or midpoint, an extension anchor is 
created.

5. Move your pointer perpendicular edge 
displaying the anchor to create a blue, 
dashed extension line.

Only a limited number of anchors can exist at 
one time; creating a new anchor removes the 

Extension anchors and  lines
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oldest existing anchor. You can specify the 
number of possible anchors in the 
Preferences dialog. See “Snap Properties 
Panel” on page 115.

Wall Intersection 
Extension Snaps

As walls are drawn, extension lines identify 
points that are either collinear or orthogonal 
to the end points of other walls. These exten-
sion lines identify potential intersection 
points and display only when Intersection 
Snaps  are enabled. See “Drawing Walls” 
on page 276. 

Object Snaps Hotkeys
• Press the “1” key to clear out all current 

extension anchors. 
• Hold down the “S” key to temporarily 

disable Object Snaps. You are still able to 
use Extension Snaps to existing anchors, 
so the “S” key can be used to avoid pick-
ing up unwanted extension anchors.

The “S”Key - Case Study
In the following example, there are several 
lines. Suppose we want to start a line at the 
intersection of two orthogonal extension 
lines drawn from two lines, A and B. To 
establish an extension anchor, we need to 
drag the mouse over line A’s endpoint, but 

there are several lines between the endpoints 
of lines A and B. We need to establish the 
two extension anchors without snapping to 
the intervening objects.

To establish two extension anchors

1. Drag the mouse over the endpoint for 
line A to establish the first endpoint 
anchor.

2. Temporarily disable object snapping by 
holding down the “S” key.

3. Move the mouse to the end of line B.
4. Release the “S” key to establish the sec-

ond endpoint anchor.
5. Move the mouse to the intersection of 

the two extension lines and draw the 
new object.

Angle Snaps
It is often important that objects be 
drawn at exact angles. This can be 

accomplished using Angle Snaps. Angle 
Snaps allow you to draw walls, lines, and 

other objects at specified Allowed Angles. 
Angle Snaps also affect the way objects 
rotate, the radius of arcs, and a variety of 
other operations.

The S key can help establish extension 
snaps when other objects may interfere

1.
3.

4.

5.

A B
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You can specify whether Angle Snaps use 
15° increments or 7.5° increments plus any 
additional Allowed Angles that you may 
specify. See “General Plan Defaults Dialog” 
on page 88. 

Angle Snaps can be turned on or off by 
selecting Edit> Snap Settings> Angle 
Snaps , by clicking the toggle button, or 
in the Preferences dialog. See “Snap 
Properties Panel” on page 115. When Angle 
Snaps are disabled, the Angle Snaps  icon 
will display near the mouse pointer. 

Angle Snap Settings
You can change Allowed Angle settings for 
Angle Snaps in the Plan Defaults or Layout 
Defaults dialog. See “General Plan Defaults 
Dialog” on page 88. 

Specify 15 Degree or 7 ½ Degree angle 
snaps. When 7 ½ Degree Angle Snaps are 
selected, you can also specify Additional 
Angles. 

Angle Snaps and 
Object Snaps

Angle Snaps have a higher priority than Grid 

Snaps and On Object Snaps , but a lower 
priority to all other Object Snaps. If a valid 
Object Snap exists, the program uses that 
instead of an Angle Snap. 

Sometimes both Angle Snaps and Object 
Snaps apply. For example, suppose a CAD 
line is drawn at 15°  using Angle Snaps and 
another line is approached. You can draw the 

new line at 15° using Intersection Snaps  
to snap to a point on the existing line. 

Now suppose that we don't want the new line 
to end on the existing line. Hold down the 
“S” key to temporarily disable Object Snaps, 
allowing only Angle Snaps. See “The 
“S”Key - Case Study” on page 164.

Angle Snap Grid
The Angle Snap Grid is a visual 
reference aide that displays the 

Allowed Angles in the current plan when 
line-based objects are being drawn. Select 
View> Angle Snap Grid to toggle this 
feature on or off. The Angle Snap Grid can 
be also turned on and off in the Preferences 
dialog and is disabled by default. See “Snap 
Properties Panel” on page 115.

Walls are an exception to this snapping
prioritization. When walls are drawn or

edited, Angle Snaps take higher priority than
Object Snaps. See “Drawing Walls” on page
276. 

Use both Object 
Snapping and 
Angle Snapping to 
create a 15-degree 
line that intersects 
an existing line
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When the Angle Snap Grid is turned on, it 
will display in all views where line-based 
objects can be drawn - including 3D views in 

which walls can be drawn and edited. See 
“Editing Line Based Objects” on page 187.

When Grid Snaps are enabled, small 
perpendicular hatch lines display along the 
lengths of the Angle Snap Grid lines, 
indicating the Snap Grid Unit.

Grid Snaps
Grid Snaps allow you to snap objects 
to points on an on-screen grid as they 

are created, moved, and resized. See 
“Moving Objects” on page 220 and 
“Resizing Objects” on page 229.

The display and size of this Snap Grid can be 
controlled in the Plan or Layout Defaults 
dialog. See “General Plan Defaults Dialog” 
on page 88.

It is recommended that you draw and 
position the exterior walls of your plan with 

Grid Snaps  enabled. Once these walls 
are in place, you may choose to turn Grid 
Snaps off to finish the rest of the drawing. 

Grid Snaps are turned on and off by selecting 

Edit> Snap Settings>Grid Snaps , by 
clicking the toggle button, or in the Plan or 
Layout Defaults dialog. 

In addition to the Snap Grid, the Reference 
Grid is provided to give you a visual sense 
of scale. The Reference Grid is useful for 
zooming in and out, or for general layout 
guidelines, but is not used for snapping. The 
Reference Grid can be toggled on and off by 
selecting View> Reference Grid. See “View 
Tools” on page 880.

Grid Snaps and Angle Snaps
Of the three snap behaviors, Grid Snaps have 
the lowest priority and are overridden by 
Angle Snaps and Object Snaps. 

When Grid snaps and Angle Snaps are both 
enabled, objects are drawn and edited using 
Polar Coordinates. For example, if the grid 
Snap Unit is set to 12" (1 foot), drawing a 
new wall at an Allowed Angle snaps the wall 
length to 0", 12", 24", and so on. The Angle 
Snap Grid illustrates this nicely: when Grid 

Drawing a line with the Angle Snap Grid on
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Snaps are enabled, small perpendicular hatch 
lines display along the lengths of the Angle 
Snap Grid lines. These hatches are at regular 
intervals equal to the Snap Grid Unit, but do 
not necessarily align with the Snap Grid 
itself. See “Angle Snap Grid” on page 165. 

Creating Objects
In Chief Architect, there are five ways to 
create objects: by clicking to place an object, 
by clicking and dragging to draw an object, 
by entering coordinates, by placing a 
distribution path or region, or by importing 
custom symbols, drawings, pictures or 
metafiles.

If you create an object using any of these 
methods and the layer it will go on is either 
locked or turned off, the program will ask 
you if you want to display or unlock the 
layer. Objects can be created on layers that 
are not set to display, but they cannot be 
created on locked layers. See “Object 
Creation and Layers” on page 170.

While the size of the drawing area in Chief 
Architect is limited only by the resources on 
your computer, it is best to begin your draw-
ing near the origin, 0,0,0. The current 
position of your mouse pointer displays in 
the Status Bar at the bottom of the program 
window. See “3D Drafting” on page 31. 

Click-to-Create
Many objects, including doors and windows, 
cabinets, library symbols, text, pictures, and 
images  are created by clicking. Select a 
library object or one of the drawing tools 
mentioned above, then click in the drawing 
area to place the object at that location. 

Continue clicking to place the selected object 
until another tool is selected.

If you click at a location where there is not 
enough room for the object to be placed, one 
of two things may happen:
• Some objects, notably cabinets, doors, 

and windows, will resize smaller to fit 
into the space. 

• Most objects cannot resize in this man-
ner, so the program will present a warn-
ing message indicating that there is not 
sufficient space at the current location.

When most drawing tools are active or 
library symbols selected for placement, a 
preview outline follows your mouse pointer, 
indicating the size and shape of the object to 
be created. If your pointer is positioned at a 
location where the object cannot be placed, 
this preview outline will not display.

As you move the mouse pointer, the center 
point of the object’s back edge will snap to 

active snap points when Grid Snaps  or 

Object Snaps  are enabled. See “Snap 
Behaviors” on page 162.

Many architectural objects can be created in 
floor plan view or any 3D view. In order to 
place a stand-alone, click-to-create object in 
3D, it is necessary to click near a wall or 

To draw a line or wall at an Allowed
Angle but with unrestricted length, dis-

able Grid Snaps and leave Angle Snaps on.
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within the Terrain Perimeter as these objects 
help orient the new object within the 3D 
space. 

Clicking and Dragging
Other objects, including walls and railings, 
straight stairs, and CAD and CAD-based 
objects are created by clicking and dragging 
to define either a path or an enclosed area. 
Select a tool, then click and drag in the 
drawing area to draw an object between your 
start and end points.

Continue drawing the selected object until 
another tool is selected.

You can temporarily slow the movement of 
the mouse as you drag by holding down the 
Shift key on your keyboard..

You can cancel any click-and-drag drawing 
operation before it is completed by pressing 
the Esc key on your keyboard, or by pressing 
any two mouse buttons at the same time. 

When the Alternate  edit behavior is 
active, a continuous drawing behavior is 
enabled, allowing you to click at the start and 
end points of line- and arc-based objects 
without dragging. See “Alternate” on page 
179. 

To continuously draw by right-clicking

1. Select a tool that creates line- or arc-
based objects.

2. Right-click, drag, and release the mouse 
button to draw the first object.

3. Move the pointer to a different location 
and notice the drawing indicator that 
begins at the object’s endpoint and fol-
lows your pointer as it moves.

4. Click to create a second object begin-
ning at the first object’s starting point 
and ending where you clicked.

5. Continue moving the pointer and click-
ing to create additional objects until: 

•  Another tool is selected, 
•  The Esc key is pressed,
•  Two mouse buttons are pressed at the 

same time, 
•  The left mouse button is double-

clicked,
•  A closed shape is formed.

Polyline- and Spline-based objects can be 
created by snapping multiple Line-, Arc-, 
and/or Spline-based objects together. These 
objects will only snap together to form a 
polyline or spline if they are on the same 
layer and share identical attributes such as 
color, line style, and arrow specifications. 
See “Editing Objects” on page 177. 

Entering Coordinates
Objects created by clicking and dragging can 
also be drawn by entering coordinates.  See 
“3D Drafting” on page 31. 

Coordinates can be either absolute or 
relative. Absolute coordinates refer to a fixed 
point of origin at 0,0,0, while relative 
coordinates treat the current location of the 
selected object as the point of origin. 

To keep the Alternate Drawing Mode
enabled when a closed shape is

formed, uncheck Stop When Connected in
the Preferences dialog. See “Behaviors
Panel” on page 113. 
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To use the Enter Coordinates dialog

1. Select any tool that requires you to click 
and drag to create an object.

2. Click and begin dragging to draw the 
object.

3. Before you finish dragging and with the 
mouse button pressed, press either the 
Tab or Enter key on your keyboard.

4. In the Enter Coordinates dialog:

•  The Start Location, where you clicked 
and began dragging, displays at the top.

5. Specify the method used to define the 
New Location, or end point.

•  Select Absolute to define the end point 
using absolute coordinates on the snap 
grid.

•  Select Relative to Start to define the 
end point relative to the start point, as 
though the start point was at (0,0).

•  Check Polar to define the end point of 
the new line by its Distance and Angle 
from the start point rather than as X 
and Y coordinates. 

•  The program remembers which option 
you last used in this dialog. 

6. Specify the position of the end point, 
either as X and Y Position coordinates, 
or as Distance and Angle.

7. Click OK to close the dialog and create 
the object.

CAD lines, arcs and points can also be 
created using the Input Line, Input Arc and 
Input Point dialogs. See “Input Point” on 
page 1077, “Input Line” on page 1081, or 
“Input Arc” on page 1091.

Auto Rebuild
A number of objects, notably foundations, 
roofs, and framing, can be automatically 
generated and rebuilt as changes are made to 
the model. Objects created in this manner 
can be edited just like other objects; 
however, the Auto Rebuild functionality will 
be disabled. 

Distributing Objects
You can place multiple copies of any object 
in an evenly-spaced array either within a 
region or along a path using the Distributed 
Objects  tools. See “Distributed Objects” 
on page 804.

Importing Objects
Custom symbols, drawings, pictures and 
metafiles can be imported into the program 
and placed in the drawing area with a click. 
See “Importing and Exporting” on page 1167 

You can also move objects using the
Enter Coordinates dialog. Click and

drag the Move edit handle of an existing
object, then press the Tab key and proceed
with steps 4 and 5. See “Moving Objects” on
page 220.
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and “Pictures, Images, and Walkthroughs” 
on page 1133. 

Converting Objects
A variety of objects can be created by 
converting existing CAD objects and many 
CAD-based objects into another type of 
object. See “Converting Objects” on page 
238. 

Object Creation and Layers
When it is created, every object is placed on 
a layer which controls whether and how it 
displays. See “Layers” on page 143. 

If you try to create an object on a layer that is 
not set to display in the current view, the 
program will ask if you want to turn that 
layer on. See “Message Boxes” on page 43. 

• Click Yes to create the object and turn on 
its layer in the current view.

• Click No to create the object but leave its 
layer turned off in the current view. 

• Click Cancel to not create the object and 
leave the layer turned off.

If you try to create an object on a layer that is 
locked, the program will prompt you to 
unlock the layer. If you choose to leave the 
layer locked, the object will not be created.  
See “Locking Layers” on page 145.

Similarly, if you try to insert an object into 
another object that is on a locked layer, 
nothing will be created. See “Inserted 
Objects” on page 837.

If you place an object on a renamed or 
custom layer and then paste it into a new plan 
or layout file, a new layer will be created in 
the destination file.

Copying and Pasting Objects
New objects can also be created by cutting, 
copying, and pasting existing objects, either 
individually or in groups. Objects can be 
copied from one floor to another, one view 
window to another, and one file to another. 
Because copying uses your system’s 
clipboard, some objects can be pasted into 
other applications, as well.

Objects cannot be pasted into any views that 
they cannot be created in normally. For 

example, CAD objects cannot be pasted into 
a 3D camera view or overview, while 
Architectural objects cannot be pasted into a 
CAD Detail window or onto a layout page.

If an object on a custom layer or one that 
inherits properties from a Saved Dimension 
Default or Saved Text Style is pasted into a 
different plan or layout file:
• That Saved Default, Text Style, or layer 

will be created in the destination file if it 
does not already exist. 

• If a Saved Default, Text Style, or layer 
with the same name does exist in the des-
tination file, the object will inherit its 
attributes from the existing settings.

Objects created in an Imperial plan or
layout should not be pasted into a metric

file, or vice versa. See “Units of Measure-
ment” on page 55. 
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See “Multiple Saved Defaults” on page 77 
and “Layers” on page 143.

A few objects, such as Terrain Perimeters 
and camera symbols, cannot be copied. 

Cut
Select Edit> Cut or press Ctrl + X  to 
remove the selected object(s) from the 

file and save them in the system clipboard. 
To paste the selection in Chief Architect or 
another application, select Edit> Paste or 
press Ctrl + V while in that application to 
enable the Paste function.

Copy
Select Edit> Copy or press Ctrl + C  
to copy the selected object(s) to the 

system clipboard. To paste the selection in 
Chief Architect or another application, select 
Edit> Paste or press Ctrl + V while in that 
application to enable the Paste function. 

Paste
Select Edit> Paste or press Ctrl + V  
to enable Paste mode, then left- or 

right-click in the current view to paste the 
selected object(s) previously copied to the 
system clipboard at that location. If pasting 
from another application, click in the 
destination view in Chief Architect first to 
make sure it is active. 

Once pasted, these object(s) are selected. 
Objects pasted in 3D views are selected on 
their top surfaces.

If the selection being pasted consists of text, 
it is placed in a Text object.

If the selection being pasted is an image, the 
Paste Image dialog opens.

The options in the Paste Image dialog and 
their results are similar to those in the Screen 
Capture Setup dialog. See “Creating Screen 
Captures” on page 1154. 

Copy/Paste
Click the Copy/Paste edit button to 
copy the selected object(s) to the 

system clipboard and immediately enable the 

Paste  function in Chief Architect. 

The Copy/Paste  edit button activates 
Paste mode in which each available edit tool 
and handle makes a copy in addition to its 
primary function and four new edit buttons 
display on the edit toolbar.

• Click the Sticky Mode  edit button 
remain in the current mode and place 
multiple copies of the selected object(s). 

• Click the Point to Point Move  edit 
button to make a copy of the selection at 
a specific location. See “Point to Point 
Move” on page 222. 

• Click the Reflect About Object  edit 
button to make a copy of the selection 
reflected about another object. See 
“Reflect About Object” on page 237. 
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• Click the Main Edit Mode  edit but-
ton or press the Esc key to return to the 
selected objects’s main edit toolbar.

If you paste a selection in a file other than its 
original source file, when you return to the 
original, Paste mode is still enabled. 

The Copy/Paste  edit button can be used 
with the edit handles in either of two ways: 
by clicking or by dragging an edit handle.

To Copy/Paste by clicking

1. Select an object or objects to copy.

2. Click the Copy/Paste  edit button, 

select Edit> Copy  from the menu or 
press Ctrl + C to copy and then Ctrl + 
V to activate the Paste functionality. The 
cursor displays the Copy/Paste icon.

3. If you wish to paste the copy in a differ-
ent view or program window, open that 
window. 

4. If your cursor does not display the Copy/
Paste icon, select Edit> Paste from the 
menu or press Ctrl + V.

5. Left- or right-click once to paste a copy 
of the object at that location.

To Copy/Paste by dragging

1. Select an object or objects to copy.

2. Click the Copy/Paste  edit button, 

select Edit> Copy  from the menu or 
press Ctrl + C. The cursor displays the 
Copy/Paste icon.

3. Drag an edit handle:
•  Drag the Move edit handle to position 

the copy at a new location. 

•  Drag a corner handle to create a copy in 
the same location but with a different 
size or shape. The result depends on 

which Edit Behavior  you use. See 
“Edit Behaviors” on page 178. 

4. You can resize or position the copy 
accurately with respect to the original by 
watching the moved distance in the Sta-
tus Bar at the bottom of the screen.

Sticky Mode
Normally, after an action is performed 
using the edit tools or handles while in 

an edit mode such as Paste mode, you  return 
to the Main Edit Mode. Click the Sticky 
Mode edit button to remain in Paste mode 
and continue pasting copies of the selected 
object(s). 

To exit Paste mode and return to the main 
edit toolbar for the selected object, click the 

Main Edit Mode  edit button or press the 
Esc key on your keyboard. If you have not 
pasted a copy of the selected object and 

immediately click Copy/Paste  after 
returning to the Main Edit Mode, Sticky 
Mode  is still enabled. 

Use the Concentric edit behavior to cre-
ate concentric copies of CAD-based

objects. See “To create setback lines” on
page 195 of the User’s Guide for an exam-
ple. 

Sticky Mode is available when the Trim
Object(s), Extend Object(s), Copy/Paste

or Multiple Copy edit button is clicked. See
“Trim and Extend” on page 244. 
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Copy and Paste in Place
Click the Copy and Paste in Place 
edit button to create a copy of the 

selected object(s) at the same location as the 
original. The copy remains selected so you 
can perform additional operations.

Because multiple walls, railing and fencing 
cannot share the same space, the Copy and 

Paste in Place  edit button is not avail-
able for these objects.

Paste Hold Position
When copying between different 
floors or view windows, you can paste 

a copy at the same absolute position as the 
original selection using Paste Hold Position.

To use Paste Hold Position

1. Select the object(s) to be copied.

2. Click the Copy/Paste  edit button.
3. Switch to the desired floor or plan file 

and select Edit> Paste> Paste Hold 
Position .

4. A copy is placed at the same X, Y coor-
dinates on the new floor or in the new 
plan as the original’s position.

Paste Special
The Paste Special tool allows you to 
choose a representation for the 

selection to be pasted. 

Selections can be pasted as:
• Enhanced Windows Metafiles (EMF). 

See “Metafiles” on page 1145. 

• Device Independent Bitmaps (BMP). See 
“Importing Pictures” on page 1143.

• Unformatted non-unicode text (TXT).
• File Name (a path to a file). Depending 

on the file type, it will be either opened or 
imported (if supported). 

• Unformatted text (HTML). Pastes as text.
• Model Objects - Chief Architect format, 

not compatible with other programs.

To use Paste Special

1. Select an object, image, text or file on 
your computer and copy it.

2. Switch to the desired Chief Architect 
view window and select Edit> Paste> 
Paste Special .

3. In the Paste Special dialog, select the 
desired representation for the selection 
and click OK.

4. Click in the drawing area to place the 
copy at that location. 

Multiple Copy
The Multiple Copy edit button makes 
it easy to create regularly spaced or 

concentric copies of any object or group of 
objects, including CAD Blocks and 
Architectural Blocks.

The copy intervals, or offsets, between 
copies can be specified in the Multiple Copy 
dialog. See “Multiple Copy Dialog” on page 
174.

To use Multiple Copy

1. Select the object(s) to copy.
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2. Click the Multiple Copy  edit 
button.

3. Click the Sticky Mode  edit button if 
you wish to make more than one set of 
multiple copies.

4. Three edit handles will display on the 
selected object. 

•  Click and drag the square Move edit 
handle. Copies of the selection are 
made at regular intervals between the 
original and the pointer’s location.

•  Click and drag the triangular Rotate 
edit handle. Rotated copies of the 
selection are made at regular intervals.

•  Click and drag the round Concentric 
Resize edit handle. Concentric copies 
of the selection are made at regular 
intervals either within or surrounding 
the selection. Line-based objects are 
copied in an array perpendicular to the 
selection but are not resized.

5. Release the mouse button to place the 
copies. The dragged distance determines 
the number of copies placed.

6. If you clicked the Sticky Mode  edit 
button, you can drag the last object cre-
ated to make additional copies.

7. Click the Main Edit Mode  edit but-
ton or press the Esc key to return to the 
selected objects’s main edit toolbar.

The Multiple Copy  tool can be used 

with the Alternate  edit behavior to 
create arrayed copies of objects. See 
“Alternate” on page 179.

To create an array of copies

1. Select the object(s) to copy.

2. Click the Multiple Copy  edit 
button.

3. Right-click to enable the Alternate  
edit behavior and drag the either Move 
or the Rotate edit handle in any direc-
tion. The Primary Offset or Primary 
Number of Copies is used.

4. Release the mouse button and move the 
pointer in another direction. The Sec-
ondary Offset or Secondary Copies 
value is used. 

5. Click the left or right mouse button to 
place the array of copies.

Multiple Copy Dialog
Separate multiple copy intervals can be 
specified for:
• General objects
• Roof and floor trusses
• Rafters
• Floor and ceiling joists, posts, and beams

• Wall studs

To set the copy intervals for these objects, 

click the Multiple Copy  button, then 

click the Multiple Copy Interval  button 
to open the Multiple Copy dialog. 

A rotated array can be rotated about the
selected object’s center or a CAD point.

See “Rotate/Resize About” on page 161.
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The specified intervals are retained between 
program sessions. 

Click the Offset Between Copies 
When Dragging radio button to 

specify the offsets, or copy intervals, at 
which objects are copied as you drag with the 
mouse.
• Primary Offset - Specify the offset, or 

copy interval, for each object type.
• You can also specify a Secondary Offset 

for each object type that is used when the 

Alternate  edit behavior is active. See 
“Alternate” on page 179.

• Rotation Of All Objects - Specify the 
copy interval, in degrees, to be used when 
objects are rotated as they are copied. 

Evenly Distribute Copies When 
Dragging - Click this radio button to 

specify a set number of copies to be made as 
you drag with the mouse. The further you 
drag, the wider the spaces between the 

copies. These settings apply to all object 
types.
• Primary Number of Copies - Specify 

the number of copies to be made. 
• Secondary Copies - Specify the number 

of copies to be made when the Alternate 

 edit behavior is active. 

Using the Transform/
Replicate Object Dialog
Objects and groups of objects can be 
copied and pasted using the 

Transform Replicate Object dialog. See 
“Transform/Replicate Object Dialog” on 
page 242.

1

2

The intervals for automatically generated raf-
ters, joists, and studs are set on their respec-
tive panels in the Build Framing dialog. See
“Build Framing Dialog” on page 586
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Copy Region as Picture
The Copy Region as Picture tool 
allows you to copy any portion of the 

screen and save it as a picture.  See “Copy 
Region as Picture” on page 1153. 

Using Point to Point Move
The Point to Point Move edit button 
can be used in combination with 

Copy/Paste  to make a copy of the 
selected object(s) at a specified location. See 
“Point to Point Move” on page 222.

To point to point copy

1. Select the object(s) to be copied, click 

the Copy/Paste  edit button, then the 

Point to Point Move  edit button.

2. Click at the start point and then at the 
end point. 

3. An exact copy of the selected object(s) 
is created at the end point while the orig-
inal remains unchanged. 

Using Reflect About Object
The Reflect About Object edit button 
can be used in combination with 

Copy/Paste  to make a reflected copy of 
the selected object(s), much the way Point to 
Point Move  can. See “Reflect About 
Object” on page 237.
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Chapter 7:

Editing Objects

Just as the methods used to create different 
objects in Chief Architect are similar, the 
options for moving, rotating, resizing, and 
otherwise editing them are also alike. 

Edit handles allow objects to be resized, 
relocated, or rotated using the mouse. Edit 
toolbar buttons and the contextual menus 
access edit tools relevant to the selected 
object(s). Most objects have a specification 
dialog that allows you to edit it in ways that 
are specific to that type of object. 

The editing characteristics common to most 
objects are described in this chapter. Unique, 
object-specific editing behaviors and the 
specification dialogs are covered in their 
respective chapters. 

Chapter Contents
•      Defaults and Preferences
•      Edit Behaviors
•      Selecting Objects
•      Editing Line Based Objects
•      Editing Arc Based Objects
•      Editing Open Polyline Based Objects
•      Editing Closed-Polyline Based Objects
•      Editing Box-Based Objects
•      Editing Spline Based Objects
•      Editing Circles, Ovals and Ellipses
•      Displaying Objects
•      Moving Objects
•      Aligning Objects
•      Resizing Objects
•      Reshaping Objects
•      Rotating Objects
•      Reflecting Objects
•      Converting Objects
•      Transform/Replicate Object Dialog
•      Trim and Extend
•      Union, Intersection, and Subtract
•      Matching Properties
•      Edit Area Tools
•      Deleting Objects
•      Undo and Redo
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Defaults and Preferences
The same defaults and preference settings 
that affect how objects are drawn also 
influence how they can be edited. See 
“Defaults and Preferences” on page 160.

Edit Behaviors
There are six Edit Behavior modes 
that determine how edit handles affect 

an object, and may also affect how objects 
are drawn. The currently active edit behavior 
is a global preference setting, affecting all 
plan and layout files.

Two of these modes, Default and Alternate, 
are useful for most drawing and editing 
needs and can be considered primary editing 
modes. Default mode, in particular, accesses 
the most commonly used behaviors and is the 
best choice in most circumstances. When an 
Edit Behavior other than Default is active, its 
icon displays near the mouse pointer. 

The other four modes, Move, Resize, 
Concentric and Fillet, offer special editing 
behaviors that may be useful only in certain 
situations and can be considered secondary. 

Each edit behavior can be temporarily 
enabled using the different buttons on your 
mouse or by pressing the keyboard keys 
associated with each. See “Using the Mouse” 
on page 33 and “Hotkeys” on page 138. 

You can also specify which edit behavior 
mode is active when the left mouse button is 
used in the Preferences dialog, by selecting 

Edit> Edit Behaviors , or by clicking the 
corresponding toggle button, which can be 
added to your toolbar. See “Behaviors Panel” 
on page 113.

Default
The Default mode is one of the 
primary edit behavior modes. It offers 

access to the most commonly used edit 
behaviors and should be selected as your 
preference in most situations.

• Drawing - Standard click and drag 
drawing behavior is enabled. See 
“Creating Objects” on page 167. 

• Resize/Reshape - Default allows you to 
adjust the angle of any corner of a poly-
line without affecting adjacent corners, 
changing the object’s shape. 

It is a good idea to be familiar with these
options and how they affect drawing

and editing in the program.

Note: Regardless of which Edit Behavior is
active, the Default behavior is restored when
you close the program. 

When the use of a tool is described in
this manual, it is assumed that the

Default edit behavior mode is active.
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• For box-based objects, the Default mode 
functions the same as the Alternate mode. 

• Movement - Default allows you to move 
objects orthogonal, or at a right angle, to 
any of their edges.

• Rotation - In Default mode, objects snap 
at Allowed Angles as they are rotated.

You can temporarily enable the Default  
edit mode when another mode is active by 
pressing Alt + Z or Alt + / while performing 
an edit or drawing operation.

Alternate
The Alternate mode is the second 
primary edit behavior mode. When 

this mode is active, the Alternate  icon 
displays near the mouse pointer.

• Drawing - Continuous drawing behavior 
is enabled. See “Clicking and Dragging” 
on page 168.

• Resize/Reshape - Alternate allows you 
to keep the angle between adjacent edges 

fixed when a corner edit handle is moved. 
Instead, adjacent corners move and adja-
cent edges lengthen or shorten. 

• Alternate allows you to drag an end han-
dle on an open polyline to change it from 
a line to an arc or vice versa. 

• Alternate overrides the Lock Center  
setting of arc-based objects.

• Movement - Alternate allows you to 
move objects at Allowed Angles when 

Angle Snaps  are enabled, or orthogo-
nal to any of its edges when they are not. 
See “Angle Snaps” on page 164. 

• Rotation - Alternate snaps objects at 
Allowed Angles as they are rotated.

You can temporarily enable the Alternate 

 edit mode when another mode is active 
by pressing Alt or using the right mouse 
button while performing an edit or drawing 
operation.

Move
The Move mode allows you to move 
an object using edit handles that 

would otherwise be used for resizing, as well 

Note: Not all commands have an Alternate
edit behavior. If a selected tool does not, it
will not work when this edit mode is active. 

Default edit behavior

Alternate edit behavior
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as with the Move handle. When this mode is 
active, the Move  icon displays near the 
mouse pointer.
• Drawing - Standard click and drag 

drawing behavior is enabled. 
• Resize/Reshape - Move allows you to 

move the selected object when any edit 
handle is used. 

• Movement - Move mode allows you to 
move objects at Allowed Angles.

• Rotation - In Move mode, objects snap 
at Allowed Angles as they are rotated.

You can temporarily enable the Move  
edit mode when another mode is active by 
pressing Z or / while performing an edit or 
drawing operation.

Resize
The Resize edit behavior allows you 
to rescale an object. As you drag a 

corner edit handle of an object, you get an 
exactly scaled version of the original. For 
example, you can resize an object to 50% of 
its original size while maintaining the same 
proportions. When this mode is active, the 
Resize  icon displays near the mouse 
pointer.
• Drawing - Standard click and drag 

drawing behavior is enabled.  
• Resize/Reshape - Resize allows you to 

keep the angle between adjacent edges 
fixed when a corner handle is moved. 

• Movement - Resize allows you to move 
an object orthogonal, or at a right angle, 
to any of its edges.

• Rotation - In Resize Mode, objects snap 
at Allowed Angles as they are rotated. 

You can temporarily enable the Resize  
edit mode when another mode is active by 
pressing X or the period key, or using the X2 
button on a five-button mouse while 
performing an edit or drawing operation. See 
“Using the Mouse” on page 33.

Concentric
The Concentric mode allows you to 
resize objects so that the distance 

moved by each edge is the same. For 
example, you can resize an irregularly 
shaped polyline so that each edge is exactly 
ten feet in from the original position, which 
is useful for creating site plans with setbacks. 
When this mode is active, the Concentric  
icon displays near the mouse pointer.

To proportionally resize an object,
always drag a corner edit handle and

not an edge handle.

Resize edit behavior
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• Drawing - Standard click and drag 
drawing behavior is enabled.  

• Resize/Reshape - Concentric allows you 
to resize an irregularly-shaped polyline 
so that each edge is moved the same dis-
tance from its original location. 

• Concentric mode also allows you to 
move opposite edges of an object so that 
each edge is moved the same distance 
from its original location. 

• Movement - Concentric mode allows 
you to move an object orthogonal, or at a 
right angle, to any of its edges.

• Rotation - In Concentric mode, objects 
snap at Allowed Angles as they are 
rotated.

In some cases, the Concentric and Resize 
edit behaviors have the same result, such as 
when a circle is resized. Usually, though, the 
two behaviors are different because 
concentric resizing does not maintain the 
original ratio between an irregular polyline’s 
edges. 

In Concentric mode, objects resize in 
Concentric Jump increments specified in 
the Preferences dialog. See “Behaviors 
Panel” on page 113. 

When the Concentric Jump distance is set 
at 0", objects resize according to the Snap 
Unit specified in the Plan Defaults dialog. 
See “Grid Snaps” on page 166. 

You can temporarily enable the 

Concentric  edit mode when another 
mode is active by pressing C or the comman 
key, or using the X1 button on a five-button 

Note: The Concentric edit behavior can be
used to create concentric copies of CAD-
based objects. See “To create setback lines”
on page 195 of the User’s Guide. 

Concentric edit behavior

To concentrically resize an object with
no restrictions, set the Concentric Jump

value on the Behaviors panel of the Prefer-
ences dialog to zero and turn off Grid Snaps.

Concentric 
edit behavior

Resize edit 
behavior
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mouse while performing an edit or drawing 
operation. See “Using the Mouse” on page 
33.

Fillet
The Fillet mode allows you to add a 
fillet, or curve, at any corner of an 

object. Dragging a corner edit handle adjusts 
the fillet radius at that corner. When this 
mode is active, the Fillet  icon displays 
near the mouse pointer.
• Drawing - Standard click and drag 

drawing behavior is enabled. 
• Resize/Reshape - Fillet allows you to 

create a fillet at by dragging a corner edit 
handle inward. 

• Movement - Move mode allows you to 
move objects at Allowed Angles.

• Rotation - In Move mode, objects snap 
at Allowed Angles as they are rotated.

The Fillet  edit behavior adjusts all the 
corners of a box at once. The radius of each 
corner is the same.

Fillet  does not have an effect on circles, 
ovals, ellipses or arc segments.

You can temporarily enable the Fillet  
edit mode when another mode is active by 
pressing F while performing an edit or 
drawing operation.

Connect CAD Segments
Typically, when two CAD objects 
share the same properties, they can be 

snapped end-to-end to form a polyline. 
Connect CAD Segments controls whether 
CAD objects can be snapped together to 
form polylines. See “Polylines” on page 
1097. 

When Connect CAD Segments  is 
diabled, the Connect CAD Segments  icon 
displays near the mouse pointer and CAD 
objects cannot form polylines. 

Select Edit> Edit Behaviors> Connect 
CAD Segments  to toggle this behavior 
on or off. You can also turn Connect CAD 
Segments  on or off in the Preferences 
dialog. See “CAD Panel” on page 109. 

Rotate/Resize About
Objects can be rotated or resized 
about either their own centers or the 

current CAD point. See “The Current Point” 
on page 1078. 

Fillet edit behavior

To produce fillets or chamfers of an
exact radius, use the Fillet Lines or

Chamfer Lines edit button. See “Fillet Lines”
on page 233 and “Chamfer Lines” on page
233.
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Selecting Objects
“Select” refers to selecting an object for 
editing. An object must be selected before it 
can be edited. 

In order for an object to be selected, it must 
be both unlocked and visible in the current 
view. See “Layers” on page 143. 

When an object is selected, it displays edit 
handles and a selection fill color. See “Colors 
Panel” on page 94.

In 3D views, a selected object will also 
display lines representing the selected edge 
or surface. The size of the edit handles does 
not change as you zoom in or out and is set in 
the Preferences dialog. See “Edit Panel” on 
page 111. To prevent them from stacking on 
one another, some edit handles may not 
display as you zoom away from the selected 
object. 

When an object is selected, its edit toolbar 
also displays, typically at the bottom of the 
Chief Architect program window just above 
the Status Bar.  See “The Edit Toolbar” on 
page 37.

Information about the selected object or 
objects may also display in the Status Bar. 
See “The Status Bar” on page 42.

A selected object remains selected until 
another object is selected, a different tool is 
activated, the Esc key on the keyboard is 
pressed, or any two mouse buttons are 
pressed at the same time. 

Select Objects
With the exception of temporary CAD 
points, any object created using Chief 

Architect can be selected using the Select 
Objects tool. Select Edit> Select Objects, 
click the toolbar button or press the Space 
bar on your keyboard to activate this tool, 
then click on an object or its label to select it. 
See      Object Labels.

You can also select objects or open context 
sensitive menus using the right mouse button 
when any tool is active.

By default, you can select an object by 
clicking within 12 pixels of it. You can adjust 
this distance by changing the Snap Distance 
in the Preferences dialog. A lower value, for 
example, can be helpful for working with 
small objects but can also make it very 
difficult to select larger objects. See “Snap 
Properties Panel” on page 115. 
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Selecting Similar Objects

If a tool other than Select Objects  is 
active, you can only select objects of that 
type using the left mouse button. For 

example, if the Straight Exterior Wall  
tool is active, you can only select walls using 
the left mouse button. 

This can be useful for selecting an object 
when many objects of a different type 
occupy the same space in floor plan view. 

Objects can be selected using the right mouse 
button, regardless of which tool is active. 

Right-Clicking
Regardless of which tool is active, you can 
select an eligible object by right-clicking on 
it once. When you right-click to select an 
object a contextual menu also appears, 
displaying the object’s edit tools. You can 
turn contextual menus on or off in the 
Preferences dialog. See “Contextual 
Menus” on page 38.

If a drawing tool is active and you right-click 
to select an object, you can unselect it by 
left-clicking in an empty space in the 
drawing area. Although a drawing tool is 
active, it is not used. If you then left-click a 
second time, the active tool will be used. 

Selected Edge
When you click on a polyline- or box-based 
object, the edge that you click nearest 
becomes the selected edge and displays an 
edit handle larger than those on other edges. 
The handle on this edge may also display at 
the point where you clicked to select it.  

This edge can be edited on the SELECTED 
LINE or SELECTED ARC panel of the object’s 
specification dialog, as well as using a 
variety of edit toolbar buttons. It can also be 
moved using dimensions. See “Moving 
Objects Using Dimensions” on page 1019, 
“Line Panel” on page 1084 and “Arc Panel” 
on page 1093.

The Start and End points of a CAD-based 
object’s selected edge or of a wall can be 
indicated by an S and an E when the object is 
selected. These Start and End indicators can 
be helpful when editing the selected edge in 
the object’s specification dialog, and their 
display can be turned on and off in the 
Preferences dialog. See “Edit Panel” on 
page 111. 

Disconnect Edges
Polyline-based objects are composed 
of lines and arcs that are connected 

end to end. The individual edges of open and 
closed polylines can be selected and edited 
independently of the object’s other edges 
when Disconnect Edges is in use. Select 

CAD> Lines> Disconnect Edges  to 
enable this ability. 

Selected edge with start and end indicators
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Disconnect Edges  also affects terrain 
paths and molding polylines, but does not 
affect Walkthrough Paths or closed polyline-
based objects such as slabs and roof planes. 

To use Disconnect Edges

1. Select CAD> Lines> Disconnect 
Edges . 

2. Click on an individual edge of an eligi-
ble polyline-based object to select it. 

3. Notice that it is no longer connected to 
the rest of the polyline.

4. The individual segment can now be 
edited entirely independent of its neigh-
bors.

5. Continue clicking on polyline edges to 
disconnect them from their polyline.

6. When you are finished, click the Select 
Objects  button or activate another 
tool.

7. To connect the segment to the polyline 
again, move the end handles so that they 
snap to the ends of adjacent segments.

When Disconnect Edges  is used, only 
edges that you click on are actually affected 

by it. Any polylines that you do not click on 
will remain intact. 

You can also separate the selected edge of an 
open or closed polyline from the rest of the 
polyline by clicking the Disconnect Selected 
Edge  edit button. See “Selected Edge” 
on page 184.

Select Next Object
If there is more than one object in a 
particular space, it may be difficult to 

select the desired object. When a nearby 
object is selected, click the Select Next 
Object edit button or press the Tab key until 
the desired object becomes selected. This 
function cannot be applied to groups of 
selected objects.

Marquee Select
Groups of objects can be selected by holding 
down either the Shift or Ctrl key when the 

Select Objects  tool is active and then 
dragging a marquee around the objects to be 
selected. 

You can specify whether objects must be 
totally contained in or intersected by the 
marquee, or whether an object’s center point 
must be contained in the marquee, in the 
Preferences dialog or using the Selection 
Mode  buttons, which can be added to 
your toolbars. See “Edit Panel” on page 111. 

If an object is currently selected and a 
selection marquee is drawn around it, that 
object becomes de-selected.  If an object is 
currently selected and a marquee is drawn 
around other objects, the original object  
remains selected and the other objects are 
added to the selection set.

Connect CAD Segments
               on

A selected terrain path

Connect CAD Segments
               off
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When using the marquee-select method, both 
CAD and architectural objects included in 
the marquee are selected. To remove an 
object from the selection set, hold down the 
Shift key and click it.

The Shift key can also be used to marquee-
select objects of a similar type. For example, 

click the Hinged Door  child button, hold 
down the Shift key, drag a marquee, release 
the mouse button, and only door objects 
within the marquee are selected. The Ctrl key 
will always marquee-select objects of all 
types, regardless of the active tool. 

Shift and Ctrl Select
You can select a group of objects by adding 
them to the selection set one by one. Select 
an object, hold down either the Shift or Ctrl 
key, and click additional objects to select 
them. 

More than one type of object can be selected 
using this method, but the ability to edit the 
group-selected items is limited to attributes 
that all selected objects have in common.

To remove an object from a selection set, 
click it once more - again, with either the 
Shift or Ctrl key pressed.

The Shift and Ctrl keys can be used to select 
multiple items in a variety of contexts, such 
as:  the Library and Project Browsers, lists in 
dialog boxes, and files to be imported.

Select All
Select Edit> Select All to select all objects 
drawn on the current floor, in the current 
cross section/elevation view or CAD Detail 
window, or on the current layout page.

Edit Area Tools
The Edit Area Tools allow you to 
define an area of your plan and select 

the objects within that area for editing. See 
“Edit Area Tools” on page 252.

Using a Fence
The Fence Select edit tool allows you 
to group-select multiple CAD and 

CAD-based objects in contact with the 
selected CAD line, arc, polyline or spline.

Using a Fence to make a group-selection can 
be helpful in a number of situations, for 
example: 
• When many CAD objects must be 

selected, particularly when they occupy 
the same area.

• When a selection marquee would be the 
wrong shape or include too many objects.

• When a selection group needs to be 
selected more than once.

The Fence Select  edit tool cannot be 
used to select architectural objects - only 
CAD and CAD-based objects. See 
“Architectural vs CAD Objects” on page 
160.

Fences are often used with the Trim Objects 
 and Extend Objects  edit tools. See 

“Trim and Extend” on page 244. 

To make marquee selection easier, you
can turn off the display of objects you

do not want to include in your selection set.
See “Displaying Objects” on page 144.
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To Fence Select a group of objects

1. Draw a CAD line, arc, open polyline, 
closed polyline or spline that crosses or 
touches all the objects you wish to 
group-select.

2. Click the Fence Select  edit button.
3. The originally selected object serves as a 

fence to select the objects it touches, 
while becoming deselected itself.

4. You can hold either the Shift or Ctrl key 
and click objects to add or remove them 
from the selection set. 

Match Properties
Rooms, cabinets, windows and doors 
on the current floor can be selected 

based on a set of attributes that you specify 
using the Match Properties edit tool. See 
“Match Properties” on page 250.

Editing Line Based Objects
Objects are considered line-based when they 
can be edited similar to CAD lines using 
their edit handles.

CAD lines, framing members, straight walls 
and railings, straight stairs and straight roads 
are examples of line-based objects. 

Most line-based objects can be connected to 
other like objects to form polylines or 
polyline-based objects provided that they are 
on the same layer and have identical 
attributes such as line color and arrow 
specifications. See “Editing Open Polyline 
Based Objects” on page 196 and “Editing 
Closed-Polyline Based Objects” on page 
201.

Some objects, notably walls, have line-based 
editing behavior only when selected on 
certain surfaces. See “Editing Walls” on page 
285.

Wall openings such as doors and windows 
have line-based editing behavior in floor plan 
view only but cannot be rotated, reversed or 

converted to an arc. See “Editing Doors” on 
page 367 and “Editing Windows” on page 
403.

Other objects, such as stairs, foundation 
walls with footings, and roads, have 
additional edit handles that allow you to 
concentrically adjust the object’s width. 

You can keep all fences on their own
custom layer and turn off their display

when not needed. See “Layers” on page 143.
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Using the Edit Handles
When selected, a typical line-based object 
displays six edit handles: a Move handle, two 
Extend/Change Angle handles, two Same 
Line Type handles, and a Rotate handle.

Any action performed using the edit handles 
can be cancelled by pressing the Esc key or 
any two mouse buttons at the same time.

Move
• Click and drag the Move handle to move 

the object according to the currently 

active Edit Behavior . See “Edit 
Behaviors” on page 178. 

• Movement may be limited or stopped by 
other objects or Snap Behaviors. Move 
restrictions can be overridden by holding 
down the Ctrl key while dragging. See 
“Unrestricted Movement” on page 221.

Rotate
• The Rotate handle is used to rotate the 

object, either about its center or about the 
current CAD point. See “Rotating 
Objects” on page 234.

Extend/Change Angle 
• Drag a square end handle parallel to the 

selected line to change its length. 

• Drag a square end handle at an angle to 
the selected line to change its angle. 

When Angle Snaps  are on, the line 
snaps to Allowed Angles. See “Angle 
Snaps” on page 164.

• Right-click and drag it to change the 
adjacent line into an arc, or vice versa. 
See “Alternate” on page 179. 

Same Line Type 
• Drag a diamond-shaped end handle in 

any direction to draw a new line that 
shares the original’s color, weight, line 
style, and layer. See “Same Line Type 
Edit Handles” on page 1083.

Adjust Width

Some line-based objects, such as stairs and 
roads, have additional handles that allow the 
width of the object to be adjusted.

• Click and drag a small, round Expand 
handle to increase or decrease the 
object’s width. By default, objects are 
resized in 1" increments. This Snap Unit 
is defined in the Plan Defaults dialog. 
See “General Plan Defaults Dialog” on 
page 88.

Using Dimensions
Dimensions can be used to position 
line-based objects relative to other 

objects. See “Moving Objects Using 
Dimensions” on page 1019.

The behavior of the edit handles may
depend on the currently active Edit

Behavior. See “Edit Behaviors” on page 178.

RotateExtend/Change Angle

MoveSame Line Type

Adjust Width
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Dimensions cannot, however, be used to 
adjust the length of line-based objects, or the 
width of line-based objects such as stairs.

Using Extension Line Snaps
Extension line snaps can be useful when 
editing line-based objects. See “Extension 
Snaps” on page 163. 

Using the 
Specification Dialog

Line-based objects can be edited using 
their specification dialogs. See “Line 

Specification Dialog” on page 1084.

Using the Edit Toolbar
A selected line-based object can be edited in 
a variety of ways using the buttons on the 
edit toolbar. 

The following toolbar buttons may display 
on the edit toolbar for a selected line-based 
object: 

• Click the Select Next Object  edit 
button to select nearby objects instead of 
the selected object. See “Selecting 
Objects” on page 183.

• Click the Open Object  edit button to 
open the specification dialog for the 
selected object(s). See “Specification 
Dialogs” on page 41.

• Click the Copy/Paste  edit button to 
copy the selected object(s) to the system 
clipboard so they can be pasted else-
where. See “Copying and Pasting 
Objects” on page 170.

• Click the Copy and Paste in Place  
edit button to create a copy of the 
selected object(s) at the same location as 
the original. See “Copy and Paste in 
Place” on page 173.

• Click the Delete  edit button to delete 
the selected object(s). See “Deleting 
Objects” on page 255.

• Click the Transform/Replicate 
Object  edit button to copy, move, 
rotate, resize, or reflect the selected 
object(s). See “Transform/Replicate 
Object Dialog” on page 242.

• Click the Multiple Copy  edit button 
to make a series of copies at set intervals. 
See “Multiple Copy” on page 173.

• Click the Make Parallel/Perpendicular 
 edit button to make the selected 

object(s) parallel or perpendicular to a 
straight edge. See “Using Make Parallel/
Perpendicular” on page 227. 

• Click the Point to Point Move  edit 
button to accurately move the selected 
object(s). See “Point to Point Move” on 
page 222. 

• Click the Center Object  edit button 
to center an object along along a wall 
within a room or relative to a cabinet 
fixture. See “Using Center Object” on 
page 227.

• Click the Reflect About Object  edit 
button to reflect the selected object(s) 
about another object. See “Reflecting 
Objects” on page 237. 
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• Click the Move to Front of Group  
edit button to display the selected object 
in front of other objects in the same 
drawing group. See “Move to Front of 
Group” on page 219.

• Click the Break Line  edit button to 
add a new corner or pivot point to the 
selected object. See “Break Line” on 
page 231.

• Click the Complete Break  edit 
button to break the selected object into 
two separate objects. See “Break Line” 
on page 231.

• Click the Reverse Direction  edit but-
ton to reverse the direction of the selected 
object(s). See “Reverse Direction” on 
page 238.

• Click the Convert Polyline  edit but-
ton to convert the object into a special 
polyline-based object. See “Convert 
Polyline” on page 239.

• Click the Revision Cloud(s) Around 
Objects  edit button to create a revi-
sion cloud around each of the selected 
object(s). See “Revision Clouds” on page 
1104.

• Click the Change Line/Arc  edit but-
ton to change a line-based object to an 
arc, or vice versa. See “Change Line/
Arc” on page 232.

• Click the Fence Select  edit button to 
use the selected object(s) as a selection 
fence. See “Using a Fence” on page 186.

• Click the Object Layer Properties  
edit button to access and edit layer infor-

mation about the selected object. See 
“Object Layer Properties” on page 154.

• Click the Intersect/Join Two Lines  
edit button, then click on a non-parallel 
line or arc to join the two objects. See 
“Intersect/Join Two Lines” on page 232.

• Click the Fillet Lines  edit button, 
then click on a non-parallel line or arc to 
create an additional arc connecting the 
two. See “Fillet Lines” on page 233.

• Click the Chamfer Lines  edit button, 
then click an edge adjacent to the selected 
edge to chamfer the corner between 
them. See “Chamfer Lines” on page 233.

• Click the Extend Object(s)  edit but-
ton to lengthen other object(s) until they 
intersect the selected object. See “Trim 
and Extend” on page 244. Not available 
for Sun Angles or North Pointers. 

• Click the Trim Object(s)  edit button 
to shorten the length of object(s) inter-
sected by the selected object. See “Trim 
and Extend” on page 244. Not available 
for Sun Angles or North Pointers.

• Click the Align/Distribute Objects  
edit button to specify how the selected 
objects are distributed. See “Align/Dis-
tribute Objects” on page 224. Only avail-
able when multiple objects are selected.

• Click the Align/Distribute Along 
Line  edit button, then click on a line-
based object align the selected object(s) 
relative to that line. See “Align/Distribute 
Along Line” on page 225. 



Editing Arc Based Objects

 191

Editing Arc Based Objects
Objects are considered arc-based when they 
can be edited similar to CAD arcs using their 
edit handles.  

CAD arcs, curved walls and railings, curved 
stairs, and curved roads are examples of arc-
based objects.  

Most arc-based objects can be connected to 
other like objects to form polylines or 
polyline-based objects provided that they are 
on the same layer and have identical 
attributes such as line color and arrow 
specifications. See “Editing Open Polyline 
Based Objects” on page 196 and “Editing 
Closed-Polyline Based Objects” on page 
201.

Some objects, notably curved walls, have 
arc-based editing behavior only when 
selected on certain surfaces. See “Editing 
Walls” on page 285.

Other objects, such as curved stairs and 
roads, have additional edit handles that allow 
you to concentrically adjust the object’s 
width. 

The currently active Arc Creation Mode  
determines how an arc-based object is 
drawn. Once an arc is drawn, the active Arc 
Creation Mode does not affect it. See 
“Drawing Arcs - Arc Creation Modes” on 
page 1089.

Using the Edit Handles
When selected, a typical arc-based object 
displays seven edit handles. 

Any action performed using the edit handles 
can be cancelled by pressing the Esc key or 
any two mouse buttons at the same time.

Move
• Two Move edit handles allow the arc to 

be relocated without changing its shape. 
One is located at the center of the chord 
and the other, at the arc center. 

The behavior of the edit handles may
depend on the currently active Edit

Behavior. See “Edit Behaviors” on page 178.

Extend 
(along arc or chord)

Move Arc 
Center

Reshape
(moves center)

Resize
(changes radius)

Rotate

Move 
Chord

Same Line Type
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• If you would like to snap one of these 
center points to another point, use that 
handle when moving the arc. See “Align-
ing Arc Centers” on page 229.

• Click and drag the Move handle to move 
the object according to the currently 

active Edit Behavior . See “Edit 
Behaviors” on page 178. 

• Movement may be limited or stopped by 
other objects or Snap Behaviors. Move 
restrictions can be overridden by holding 
down the Ctrl key while dragging. See 
“Unrestricted Movement” on page 221.

Rotate
• The Rotate handle is used to rotate the 

arc, either about its center or about the 
current CAD point. See “Rotating 
Objects” on page 234.

Extend
• The end edit handles expand or contract 

the arc when moved along the arc radius 
or chord. 

• If you follow the path of the arc, the end 
edit handles allow you to adjust the arc 
length.

• The angle formed by the center point of 
the arc and its two endpoints is referred to 
as the Included Angle. If Angle 
Snaps  are on, the Included Angle of 
the arc, as measured in degrees, can be 

rotated at Allowed Angles. See “Angle 
Snaps” on page 164.

• Right-click and drag it to change the 
adjacent arc into a line, or vice versa. See 
“Alternate” on page 179. 

Resize
• Drag the small, round Resize edit handle 

to change the radius and included angle 
of the arc while maintaining its center. 

Reshape
• Drag the small triangular Reshape 

handle to change the length and location 
of the center without moving the 
endpoints.

• If the object has a locked center, the 
Reshape edit handle does not display. 
See “Using Lock Center” on page 195.

Move edit handle

Extend edit handles

Resize edit handle

Reshape edit handle
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Same Line Type 
• Drag a diamond-shaped end handle in 

any direction to draw a new line that 
shares the arc’s color, weight, line style, 
and layer. See “Same Line Type Edit 
Handles” on page 1083.

Adjust Width

Some arc-based objects, such as stairs, have 
additional handles that allow the width of the 
object to be adjusted. 

• Click and drag a small, round edit handle 
to increase or decrease the object’s width. 
By default, objects are resized according 
to the Snap Unit defined in the Plan 
Defaults dialog. See “General Plan 
Defaults Dialog” on page 88.

Using Dimensions
Dimensions can be used to position 
arc-based objects. Dimension lines 

typically locate tangent extension lines and 
any extension lines that may be parallel to 
those lines rather than the arc itself. See 
“Moving Objects Using Dimensions” on 
page 1019.

Using Extension Line Snaps
Extension line snaps can be useful when 
editing arc-based objects. See “Extension 
Snaps” on page 163. 

Using the 
Specification Dialog

Arc-based objects can be edited using 
their specification dialogs. See “Arc 

Specification Dialog” on page 1093.

Using the Edit Toolbar
A selected arc-based object can be edited in a 
variety of ways using the buttons on the edit 
toolbar. 

The following toolbar buttons may display 
on the edit toolbar for a selected arc-based 
object:

• Click the Select Next Object  edit 
button to select nearby objects instead of 
the selected object. See “Selecting 
Objects” on page 183.

• Click the Open Object  edit button to 
open the specification dialog for the 
selected object(s). See “Specification 
Dialogs” on page 41.

• Click the Copy/Paste  edit button to 
copy the selected object(s) to the system 
clipboard so they can be pasted else-
where. See “Copying and Pasting 
Objects” on page 170.

• Click the Copy and Paste in Place  
edit button to create a copy of the 
selected object(s) at the same location as 
the original. See “Copy and Paste in 
Place” on page 173.

Adjust Width
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• Click the Delete  edit button to delete 
the selected object(s). See “Deleting 
Objects” on page 255.

• Click the Transform/Replicate 
Object  edit button to copy, move, 
rotate, resize, or reflect the selected 
object(s). See “Transform/Replicate 
Object Dialog” on page 242.

• Click the Multiple Copy  edit button 
to make a series of copies at set intervals. 
See “Multiple Copy” on page 173.

• Click the Point to Point Move  edit 
button to accurately move the selected 
object(s). See “Point to Point Move” on 
page 222. 

• Click the Center Object  edit button 
to center an object along along a wall 
within a room or relative to a cabinet 
fixture. See “Using Center Object” on 
page 227.

• Click the Reflect About Object  edit 
button to reflect the selected object(s) 
about another object. See “Reflecting 
Objects” on page 237. 

• Click the Move to Front of Group  
edit button to display the selected object 
in front of other objects in the same 
drawing group. See “Move to Front of 
Group” on page 219.

• Click the Break Line  edit button to 
add a new corner or pivot point to the 
selected object. See “Break Line” on 
page 231.

• Click the Complete Break  edit 
button to break the selected object into 

two separate objects. See “Break Line” 
on page 231.

• Click the Reverse Direction  edit but-
ton to reverse the direction of the selected 
object(s). See “Reverse Direction” on 
page 238.

• Click the Convert Polyline  edit but-
ton to convert the object into a special 
polyline-based object. See “Convert 
Polyline” on page 239.

• Click the Revision Cloud(s) Around 
Objects  edit button to create a revi-
sion cloud around each of the selected 
object(s). See “Revision Clouds” on page 
1104.

• Click the Change Line/Arc  edit but-
ton to change an arc-based object to a 
line, or vice versa. See “Change Line/
Arc” on page 232.

• Click the Convert Curve to Polyline  
edit button to convert the selected arc into 
a polyline. See “Convert Curve to 
Polyline” on page 234.

• Click the Lock Center  edit button to 
lock the selected arc-based object’s cen-
ter. See “Using Lock Center” on page 
195.

• Click the Make Arc Tangent  edit 
button to adjust the arc and attached 
line(s) so they transition smoothly. See 
“Using Make Arc Tangent” on page 228. 
Only available when a selected arc is 
attached on one or both ends to another 
line or arc.
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• Click the Fence Select  edit button to 
use the selected object(s) as a selection 
fence. See “Using a Fence” on page 186.

• Click the Object Layer Properties  
edit button to access and edit layer infor-
mation about the selected object. See 
“Object Layer Properties” on page 154.

• Click the Intersect/Join Two Lines  
edit button, then click on a non-parallel 
line or arc to join the two objects. See 
“Intersect/Join Two Lines” on page 232.

• Click the Fillet Lines  edit button, 
then click on a non-parallel line or arc to 
create an additional arc connecting the 
two. See “Fillet Lines” on page 233.

• Click the Chamfer Lines  edit button, 
then click an edge adjacent to the selected 
edge to chamfer the corner between 
them. See “Chamfer Lines” on page 233.

• Click the Extend Object(s)  edit but-
ton to lengthen other object(s) until they 
intersect the selected object. See “Trim 
and Extend” on page 244.

• Click the Trim Object(s)  edit button 
to shorten the length of object(s) inter-
sected by the selected object. See “Trim 
and Extend” on page 244.

• Click the Align/Distribute Objects  
edit button to specify how the selected 
objects are distributed. See “Align/Dis-
tribute Objects” on page 224. Only avail-
able when multiple objects are selected.

• Click the Align/Distribute Along 
Line  edit button, then click on a line-
based object align the selected object(s) 

relative to that line. See “Align/Distribute 
Along Line” on page 225. 

Arc Centers and Ends
When working with arc-based objects 
or circles, it can be helpful to see their 

center points. Similarly, when arcs are 
snapped together to form a polyline, seeing 
their endpoints can be helpful. Select View> 
Arc Centers and Ends to toggle the display 
of both on the current floor. You can also turn 
on their display in the CAD Defaults dialog. 
See “CAD Defaults Dialog” on page 1072.

Arc-based objects can be aligned using their 
center points. See “Aligning Arc Centers” on 
page 229. 

Using Lock Center
Click the Lock Center edit button to 
lock or unlock the selected arc-based 

object’s center. When an arc’s center is 
locked, it cannot be moved except by using 
one of its Move edit handles or when the 

Alternate  edit behavior is enabled.

An arc-based object with a locked center 
lengthens and shortens along its curve when 
it is resized. When this is not possible, its 
radius changes. In either case, its center 
remains locked in the same place. 

Locked-center arcs do not display a Reshape 
edit handle when selected. See “Using the 
Edit Handles” on page 191.

When it is part of a polyline, a locked-center 
arc resizes along its arc rather than its chord 
when an adjacent line or arc is moved. Thus, 
the radius remains constant for an unlocked 
center arc, while the center does not change 
for a locked-center arc. 
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Editing Open Polyline Based Objects
Open polyline-based objects are composed 
of individual line- and arc-based objects that 
are connected at their end points but do not 
form an enclosed area. See “Polylines” on 
page 1097. 

Objects are considered open polyline-based 
when they can be edited similar to open CAD 
polylines using their edit handles. 

Open CAD polylines, connected walls, 
stairs, and roads are examples of open 
polyline-based objects. 

For information about editing closed 
polyline-based objects, see “Editing Closed-
Polyline Based Objects” on page 201.

Other objects, such as connected stair and 
road segments, have additional edit handles 
that allow you to concentrically adjust the 
width of all segments of the object. 

Using the Edit Handles
A polyline can be composed of many 
segments. See “Polylines” on page 1097. 

Unlocked center Locked center

If Connect CAD Segments is disabled,
clicking on a CAD polyline edge selects

the individual edge rather than the entire poly-
line. See “Disconnect Edges” on page 184.
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When selected, an open polyline-based 
object displays a Move handle, a Rotate 
handle, a Reshape handle at the intersection 
of each segment, and an Extend handle at 
each end. 

Each straight, line-based segment also has a 
Move edit handle along its length. 

Each curved, arc-based segment has its own 
Move handle at the center of its chord, a 
Resize handle and, if it has an unlocked 
center, a Reshape handle. See “Editing Arc 
Based Objects” on page 191.

When a polyline is selected, the edge that 
you click nearest is called the selected edge, 
and certain operations affect only this edge. 
The Move handle of the selected edge is 
larger than that of other edges. It displays 
along the length of a line segment, or at the 
center of the chord on an arc segment. See 
“Selected Edge” on page 184.

Any action performed using the edit handles 
can be cancelled by pressing the Esc key or 
any two mouse buttons at the same time.

Move
• Click and drag the Move handle to move 

the object according to the currently 

active Edit Behavior . 
• Movement may be limited or stopped by 

other objects or Snap Behaviors. Move 
restrictions can be overridden by holding 
down the Ctrl key while dragging. See 
“Unrestricted Movement” on page 221.

Rotate
• The Rotate handle is used to rotate the 

object, either about its center or about the 
current CAD point. Its position varies 
depending on which edge is currently 
selected. See “Rotating Objects” on page 
234.

Extend
• Click and drag an Extend handle to 

lengthen or shorten the unconnected end 
of the selected line or arc segment, or to 
change the radius of the selected arc. See 
“Editing Arc Based Objects” on page 
191.

The behavior of the edit handles
depends on the currently active Edit

Behavior. See “Edit Behaviors” on page 178.

Move 
polyline

Move arc 
segment

Rotate polyline

Extend

Resize 
arc Reshape 

        arc

Move line 
segment

Reshape 
polyline

Same Line 
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• Right-click and drag it to change the 
adjacent line into an arc, or vice versa. 
See “Alternate” on page 179. 

Reshape 
• Click and drag a Reshape edit handle to 

change the angle and/or length of the seg-
ments on either side of it, or the size of 
the object, depending on the currently 

active Edit Behavior . 

Move Line Segment
• The Move Line Segment edit handle is 

found on straight segments of open poly-
lines and moves the straight section 
according to the currently active Edit 
Behavior . Adjacent segments may 
extend or contract in their original direc-
tions to maintain their connections. 

Move Arc
• Click and drag the Move Arc edit handle 

to change the radius and/or chord length 
or position, depending on the currently 

active Edit Behavior  and whether 
the arc has a locked center. Adjacent seg-
ments may extend, contract, or change 
angle to maintain their connections. 

Resize Arc
• Click and drag the Resize Arc edit handle 

to change the radius, chord length and 
chord position of the arc segment, 
depending on the currently active Edit 
Behavior  and whether the arc has a 
locked center. Adjacent segments may 
extend, contract, or change angle to 
maintain their connections. 

Reshape Arc
• Click and drag the Reshape Arc edit han-

dle to change the radius of the arc without 
moving its end points. Only available if 
the arc has an unlocked center.

Same Line Type 
• Drag a diamond-shaped end handle in 

any direction to draw a new line that 
shares the original polyline’s color, 
weight, line style, and layer. See “Same 
Line Type Edit Handles” on page 1083.

Adjust Width

Some open polyline-based objects, such as 
stairs and roads, have additional handles that 
allow the width of the object to be adjusted. 

• Click and drag a small, round edit handle 
to increase or decrease the object’s width. 
By default, objects are resized in 1" 
increments. This Snap Unit is defined in 
the Plan Defaults dialog. See “General 
Plan Defaults Dialog” on page 88.

Using Dimensions
Dimensions can be used to move or 
reshape polyline-based objects. See 

“Moving Objects Using Dimensions” on 
page 1019.

Adjust 
Width



Editing Open Polyline Based Objects

 199

Using Extension Line Snaps
Extension line snaps, especially tangent 
snaps, can be useful when editing polyline 
vertices. See “Extension Snaps” on page 163.

Using the Specification 
Dialog

Open polyline-based objects can be 
edited using their specification 

dialogs. See “Polyline Specification Dialog” 
on page 1098.

Using the Edit Toolbar
A selected open polyline-based object can be 
edited in a variety of ways using the buttons 
on the edit toolbar. 

The following toolbar buttons may display 
on the edit toolbar for a selected open 
polyline-based object:

• Click the Select Next Object  edit 
button to select nearby objects instead of 
the selected object. See “Selecting 
Objects” on page 183.

• Click the Open Object  edit button to 
open the specification dialog for the 
selected object(s). See “Specification 
Dialogs” on page 41.

• Click the Copy/Paste  edit button to 
copy the selected object(s) to the system 
clipboard so they can be pasted else-
where. See “Copying and Pasting 
Objects” on page 170.

• Click the Copy and Paste in Place  
edit button to create a copy of the 
selected object(s) at the same location as 

the original. See “Copy and Paste in 
Place” on page 173.

• Click the Delete  edit button to delete 
the selected object(s). See “Deleting 
Objects” on page 255.

• Click the Disconnect Selected Edge  
edit button to disconnected the selected 
edge of the polyline, turning it into a sep-
arate object. See “Disconnect Edges” on 
page 184. 

• Click the Transform/Replicate 
Object  edit button to copy, move, 
rotate, resize, or reflect the selected 
object(s). See “Transform/Replicate 
Object Dialog” on page 242.

• Click the Multiple Copy  edit button 
to make a series of copies at set intervals. 
See “Multiple Copy” on page 173.

• Click the Make Parallel/Perpendicular 
 edit button to make the selected 

straight edge parallel or perpendicular to 
another straight edge. See “Using Make 
Parallel/Perpendicular” on page 227. Not 
available when the selected edge is an 
arc.

• Click the Point to Point Move  edit 
button to accurately move the selected 
object(s). See “Point to Point Move” on 
page 222. 

• Click the Add to Library  edit button 
to add the selected object(s) to the library. 
See “Add to Library” on page 829.

• Click the Center Object  edit button 
to center an object along along a wall 
within a room or relative to a cabinet 
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fixture. See “Using Center Object” on 
page 227.

• Click the Reflect About Object  edit 
button to reflect the selected object(s) 
about another object. See “Reflecting 
Objects” on page 237. 

• Click the Move to Front of Group  
edit button to display the selected object 
in front of other objects in the same 
drawing group. See “Move to Front of 
Group” on page 219.

• Click the Break Line  edit button to 
add a new corner or pivot point to the 
selected object. See “Break Line” on 
page 231.

• Click the Complete Break  edit 
button to break the selected object into 
two separate objects. See “Break Line” 
on page 231. 

• Click the Reverse Direction  edit but-
ton to reverse the direction of the selected 
object(s). See “Reverse Direction” on 
page 238.

• Click the Close Polyline  edit button 
to convert the selected open polyline into 
a closed polyline. See “Using Close 
Polyline” on page 201. 

• Click the Convert to Spline  edit but-
ton to change the selected polyline into a 
spline. See “Splines” on page 1106.  

• Click the Convert Polyline  edit but-
ton to convert the object into a special 
polyline-based object. See “Convert 
Polyline” on page 239.

• Click the Revision Cloud(s) Around 
Objects  edit button to create a revi-
sion cloud around each of the selected 
object(s). See “Revision Clouds” on page 
1104.

• Click the Change Line/Arc  edit but-
ton to change a line-based polyline edge 
to an arc, or vice versa. See “Change 
Line/Arc” on page 232.

• Click the Record Walkthrough Along 
Path  edit button to record a walk-
through video of your model along the 
path defined by the selected polyline. See 
“Walkthroughs” on page 1158.

• Click the Convert Curve to Polyline  
edit button to convert the selected arc into 
a polyline. See “Convert Curve to 
Polyline” on page 234. Only available 
when the selected edge is an arc. 

• Click the Lock Center  edit button to 
lock the center of the selected curved 
edge. See “Using Lock Center” on page 
195. Only available when the selected 
edge is an arc. 

• Click the Make Arc Tangent  edit 
button to adjust the selected curved edge 
and attached edge(s) so they form a 
smooth shape. See “Using Make Arc 
Tangent” on page 228. Only available 
when the selected edge is an arc attached 
on one or both ends to another line or arc. 

• Click the Fence Select  edit button to 
use the selected object(s) as a selection 
fence. See “Using a Fence” on page 186.

• Click the Object Layer Properties  
edit button to access and edit layer infor-
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mation about the selected object. See 
“Object Layer Properties” on page 154.

• Click the Intersect/Join Two Lines  
edit button, then click on a non-parallel 
line or arc to join the two objects. See 
“Intersect/Join Two Lines” on page 232.

• Click the Fillet Lines  edit button, 
then click on an adjacent edge to create 
an arc connecting the two. See “Fillet 
Lines” on page 233. Cannot be used if the 
adjacent edge is an arc. 

• Click the Chamfer Lines  edit button, 
then click on an edge adjacent to the 
selected edge to chamfer the corner 
between them. See “Chamfer Lines” on 
page 233.

• Click the Extend Object(s)  edit but-
ton to lengthen other object(s) until they 
intersect the selected object. See “Trim 
and Extend” on page 244.

• Click the Trim Object(s)  edit button 
to shorten the length of object(s) inter-

sected by the selected object. See “Trim 
and Extend” on page 244.

• Click the Align/Distribute Objects  
edit button to specify how the selected 
objects are distributed. See “Align/Dis-
tribute Objects” on page 224. Only avail-
able when multiple objects are selected.

• Click the Align/Distribute Along 
Line  edit button, then click on a line-
based object align the selected object(s) 
relative to that line. See “Align/Distribute 
Along Line” on page 225. 

Using Close Polyline
An open polyline-based object can be 
converted into a closed polyline using 

the Close Polyline edit tool. This tool adds 
an edge to the open polyline, connecting its 
two ends and closing the gap between them. 
Close Polyline is not available when 

Connect CAD Segments  is enabled. See 
“Disconnect Edges” on page 184. 

Editing Closed-Polyline Based Objects
Closed polyline-based objects are composed 
of individual line- and arc-based objects 
joined end-to-end and forming an enclosed 
area. See “Polylines” on page 1097. 

Objects are considered closed polyline-based 
when they can be edited similar to closed 
CAD polylines using their edit handles. 

Closed CAD polylines, slabs and roof planes 
are examples of closed polyline-based 
objects. 

Some objects, notably walls, have closed 
polyline-based editing behavior only when 
they are selected on certain surfaces in 3D 
views. See “Editing Walls” on page 285.

For information about editing open polyline-
based objects, see “Editing Open Polyline 
Based Objects” on page 196.
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Other objects, such as connected road 
segments, have additional edit handles that 
allow you to concentrically adjust the width 
of all segments of the object. 

Using the Edit Handles
A polyline can be composed of many 
segments. See “Polylines” on page 1097. 

When selected, a closed polyline-based 
object displays a Move handle, a Rotate 
handle, and a Reshape handle at the 
intersection of each segment. 

Each straight, line-based segment has a 
Move edit handle along its length. 

Each curved, arc-based segment has its own 
Move handle at the center of its chord, a 
Resize handle and, if it has an unlocked 
center, a Reshape handle. See “Editing Arc 
Based Objects” on page 191.

When a polyline is selected, the edge that 
you click nearest is called the selected edge, 
and certain operations affect only this edge. 
The Move handle of the selected edge is 
larger than that of other edges. It displays 
along the length of a line segment, or at the 
center of the chord on an arc segment. See 
“Selected Edge” on page 184.

Any action performed using the edit handles 
can be cancelled by pressing the Esc key or 
any two mouse buttons at the same time.

Move
• Click and drag the Move handle to move 

the object according to the currently 

active Edit Behavior . 
• Movement may be limited or stopped by 

other objects or Snap Behaviors. Move 
restrictions can be overridden by holding 

If Connect CAD Segments is disabled,
clicking on a polyline edge selects the

individual edge rather than the entire poly-
line. See “Disconnect Edges” on page 184.

The behavior of the edit handles may
depend on the currently active Edit

Behavior. See “Edit Behaviors” on page 178.
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down the Ctrl key while dragging. See 
“Unrestricted Movement” on page 221.

Rotate
• The Rotate handle is used to rotate the 

object, either about its center or about the 
current CAD point. Its position varies 
depending on which edge is currently 
selected. See “Rotating Objects” on page 
234.

Reshape
• Click and drag a Reshape edit handle to 

change the angle and/or length of the seg-
ments on either side of it, or the size of 
the object, depending on the currently 

active Edit Behavior . 

Move Line Segment
• The Move Line Segment edit handle is 

found on straight segments of closed 
polylines and moves the straight section 
according to the currently active Edit 
Behavior . Adjacent segments may 
extend or contract in their original direc-
tions to maintain their connections. 

Move Arc
• Click and drag the Move Arc edit handle 

to change the radius and/or chord length 
or position, depending on the currently 

active Edit Behavior  and whether 
the arc has a locked center. Adjacent seg-
ments may extend, contract, or change 
angle to maintain their connections. 

Resize Arc
• Click and drag the Resize Arc edit handle 

to change the radius, chord length and 
chord position of the arc segment, 
depending on the currently active Edit 

Behavior  and whether the arc has a 
locked center. Adjacent segments may 
extend, contract, or change angle to 
maintain their connections. 

Reshape Arc
• Click and drag the Reshape Arc edit han-

dle to change the radius of the arc without 
moving its end points. Only available if 
the arc has an unlocked center.

Using Dimensions
Dimensions can be used to move or 
reshape closed polyline-based objects. 

See “Moving Objects Using Dimensions” on 
page 1019.

Using Extension Line Snaps
Extension line snaps, especially tangent 
snaps, can be useful when editing polyline 
vertices. See “Extension Snaps” on page 163.

Using the 
Specification Dialog

Closed polyline-based objects can be 
edited using their specification 

dialogs. See “Polyline Specification Dialog” 
on page 1098.

Using the Edit Toolbar
A selected closed polyline-based object can 
be edited in a variety of ways using the 
buttons on the edit toolbar. 

The following toolbar buttons may display 
on the edit toolbar for a selected closed 
polyline-based object:
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• Click the Select Next Object  edit 
button to select nearby objects instead of 
the selected object. See “Selecting 
Objects” on page 183.

• Click the Open Object  edit button to 
open the specification dialog for the 
selected object(s). See “Specification 
Dialogs” on page 41.

• Click the Copy/Paste  edit button to 
copy the selected object(s) to the system 
clipboard so they can be pasted else-
where. See “Copying and Pasting 
Objects” on page 170.

• Click the Copy and Paste in Place  
edit button to create a copy of the 
selected object(s) at the same location as 
the original. See “Copy and Paste in 
Place” on page 173.

• Click the Delete  edit button to delete 
the selected object(s). See “Deleting 
Objects” on page 255.

• Click the Disconnect Selected Edge  
edit button to disconnected the selected 
edge of the polyline, turning it into a sep-
arate object. See “Disconnect Edges” on 
page 184. 

• Click the Transform/Replicate 
Object  edit button to copy, move, 
rotate, resize, or reflect the selected 
object(s). See “Transform/Replicate 
Object Dialog” on page 242.

• Click the Multiple Copy  edit button 
to make a series of copies at set intervals. 
See “Multiple Copy” on page 173.

• Click the Make Parallel/Perpendicular 
 edit button to make the selected 

straight edge parallel or perpendicular to 
another straight edge by either rotating 
the selected edge or the entire polyline. 
See “Using Make Parallel/Perpendicular” 
on page 227. Not available when the 
selected edge is an arc.

• Click the Point to Point Move  edit 
button to accurately move the selected 
object(s). See “Point to Point Move” on 
page 222. 

• Click the Add to Library  edit button 
to add the selected object(s) to the library. 
See “Add to Library” on page 829.

• Click the Center Object  edit button 
to center an object along along a wall 
within a room or relative to a cabinet 
fixture. See “Using Center Object” on 
page 227.

• Click the Reflect About Object  edit 
button to reflect the selected object(s) 
about another object. See “Reflecting 
Objects” on page 237. 

• Click the Move to Front of Group  
edit button to display the selected object 
in front of other objects in the same 
drawing group. See “Move to Front of 
Group” on page 219.

• Click the Break Line  edit button to 
add a new corner or pivot point to the 
selected object. See “Break Line” on 
page 231.

• Click the Complete Break  edit 
button to break an edge of the selected 
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object into two separate objects. See 
“Break Line” on page 231.

• Click the Reverse Direction  edit but-
ton to reverse the direction of the selected 
object(s). See “Reverse Direction” on 
page 238.

• Click the Convert to Spline  edit but-
ton to change the selected polyline into a 
spline. See “Splines” on page 1106.

• Click the Union  edit button to join 
two or more objects. See “Union, Inter-
section, and Subtract” on page 246. Not 
available for objects specified as holes.

• Click the Intersection  edit button to 
create a new object defined by the areas 
shared by the original objects. See 
“Union, Intersection, and Subtract” on 
page 246. Not available for objects speci-
fied as holes.

• Click the Subtract  edit button, then 
click a second object to remove the area 
shared by both objects. See “Union, 
Intersection, and Subtract” on page 246. 
Not available for objects specified as 
holes.

• Click the Convert Polyline  edit but-
ton to convert the object into a special 
polyline-based object. See “Convert 
Polyline” on page 239.

• Click the Revision Cloud(s) Around 
Objects  edit button to create a revi-
sion cloud around each of the selected 
object(s). See “Revision Clouds” on page 
1104.

• Click the Change Line/Arc  edit but-
ton to change a line-based polyline edge 

to an arc, or vice versa. See “Change 
Line/Arc” on page 232.

• Click the Convert Curve to Polyline  
edit button to convert the selected arc into 
a polyline. See “Convert Curve to 
Polyline” on page 234. Only available 
when the selected edge is an arc. 

• Click the Lock Center  edit button to 
lock the center of the selected curved 
edge. See “Using Lock Center” on page 
195. Only available when the selected 
edge is an arc. 

• Click the Make Arc Tangent  edit 
button to adjust the selected curved edge 
and attached edge(s) so they form a 
smooth shape. See “Using Make Arc 
Tangent” on page 228. Only available 
when the selected edge is an arc attached 
on one or both ends to another line or arc. 

• Click the Fence Select  edit button to 
use the selected object(s) as a selection 
fence. See “Using a Fence” on page 186.

• Click the Object Layer Properties  
edit button to access and edit layer infor-
mation about the selected object. See 
“Object Layer Properties” on page 154.

• Click the Record Walkthrough Along 
Path  edit button to record a walk-
through video of your model along the 
path defined by the selected polyline. See 
“Walkthroughs” on page 1158.

• Click the Intersect/Join Two Lines  
edit button, then click on a non-parallel 
line or arc to join the two objects. See 
“Intersect/Join Two Lines” on page 232.
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• Click the Fillet Lines  edit button, 
then click on an adjacent edge to create 
an arc connecting the two. See “Fillet 
Lines” on page 233. Cannot be used if the 
adjacent edge is an arc. 

• Click the Chamfer Lines  edit button, 
then click an edge adjacent to the selected 
edge to chamfer the corner between 
them. See “Chamfer Lines” on page 233.

• Click the Extend Object(s)  edit but-
ton to lengthen other object(s) until they 
intersect the selected object. See “Trim 
and Extend” on page 244.

• Click the Trim Object(s)  edit button 
to shorten the length of object(s) inter-
sected by the selected object. See “Trim 
and Extend” on page 244.

• Click the Align/Distribute Objects  
edit button to specify how the selected 
objects are distributed. See “Align/Dis-
tribute Objects” on page 224. Only avail-
able when multiple objects are selected.

• Click the Align/Distribute Along 
Line  edit button, then click on a line-
based object align the selected object(s) 
relative to that line. See “Align/Distribute 
Along Line” on page 225. 

• Click the Create Hole  edit button, 
then click and drag to draw a rectangular 
hole in the selected object. 

Polyline Holes
Most closed polyline-based objects can 
contain one or more holes. There are several 
ways to create a hole; the methods available 
may vary depending on the object type. 
• Many closed polyline based object draw-

ing tools have an associated Hole draw-
ing tool.

• Many closed polyline based objects have 
a Hole in checkbox on the GENERAL 
panel of their specification dialog that 
will convert the object into a hole if it is 
located within a larger object of the same 
type.

• A CAD Polyline can be converted into a 
variety of different types of holes using 

the Convert Polyline  tool. See “Con-
vert Polyline” on page 239. 

• Click the Create Hole  edit button, 
then click and drag to draw a rectangular 
hole in the selected object. If the selected 
object has an associated Hole tool or 
Hole in checkbox, the Create Hole will 
create an object of that type; if the 
selected object does not, a standard 
closed polyline will be created. 

Bear in mind that by definition, a hole cannot 
exist where its containing object does not. It 
must be drawn entirely within the extents of 
its containing object without touching or 
crossing over an edge. 

Editing Box-Based Objects
Objects are considered box-based when they 
can be edited similar to CAD boxes using 
their edit handles. 

Box-based objects are similar to closed 
polyline-based objects, but must always have 
four sides with right-angled corners. 
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In addition to the CAD Box tools, Text 
objects, many library symbols, CAD blocks, 
pictures and images are examples of box-
based objects.

Using the Edit Handles
When selected, a box-based object displays 
ten edit handles. Unlike polylines, boxes 
must always have four sides with right-
angled corners.

Any action performed using the edit handles 
can be cancelled by pressing the Esc key or 
any two mouse buttons at the same time.

• Click and drag the Move handle to move 
the object according to the currently 

active Edit Behavior . See “Edit 
Behaviors” on page 178. 

• Movement may be limited or stopped by 
other objects or Snap Behaviors. Move 
restrictions can be overridden by holding 
down the Ctrl key while dragging. See 
“Unrestricted Movement” on page 221.

• The four Resize handles located at each 
corner are used to increase or decrease 
the size of the object. 

• The four Extend handles display along 
each edge. If you select an object on an 
edge, the Extend handle displays at the 
point where you clicked; otherwise, it 
displays at the center of the edge.

The behavior of the edit handles may
depend on the currently active Edit

Behavior. See “Edit Behaviors” on page 178.

Move

Rotate

Resize

Extend
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• The triangular Rotate handle located 
near the selected edge of the object is 
used to rotate it either about its center or 
the current CAD point. The pointer 
changes to a circular arrow  when 
moved over this handle. See “Rotating 
Objects” on page 234.

Using Dimensions
Dimensions can be used to move or 
reshape box-based objects. See 

“Moving Objects Using Dimensions” on 
page 1019.

Using the 
Specification Dialog

Box-based objects can be edited using 
their specification dialogs. See “Box 

Specification Dialog” on page 1103.

Using the Edit Toolbar
A selected box-based object can be edited in 
a variety of ways using the buttons on the 
edit toolbar.  

The following toolbar buttons may display 
on the edit toolbar for a selected box-based 
object:

• Click the Select Next Object  edit 
button to select nearby objects instead of 
the selected object. See “Selecting 
Objects” on page 183.

• Click the Open Object  edit button to 
open the specification dialog for the 
selected object(s). See “Specification 
Dialogs” on page 41. 

• Click the Copy/Paste  edit button to 
copy the selected object(s) to the system 
clipboard so they can be pasted else-
where. See “Copying and Pasting 
Objects” on page 170.

• Click the Copy and Paste in Place  
edit button to create a copy of the 
selected object(s) at the same location as 
the original. See “Copy and Paste in 
Place” on page 173.

• Click the Delete  edit button to delete 
the selected object(s). See “Deleting 
Objects” on page 255.

• Click the Transform/Replicate 
Object  edit button to copy, move, 
rotate, resize, or reflect the selected 
object(s). See “Transform/Replicate 
Object Dialog” on page 242.

• Click the Multiple Copy  edit button 
to make a series of copies at set intervals. 
See “Multiple Copy” on page 173.

• Click the Make Parallel/Perpendicular 
 edit button to make the selected 

straight edge parallel or perpendicular to 
another straight edge. See “Using Make 
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Parallel/Perpendicular” on page 227. Not 
available when the selected edge is an 
arc.

• Click the Point to Point Move  edit 
button to accurately move the selected 
object(s). See “Point to Point Move” on 
page 222. 

• Click the Center Object  edit button 
to center an object along along a wall 
within a room or relative to a cabinet 
fixture. See “Using Center Object” on 
page 227.

• Click the Reflect About Object  edit 
button to reflect the selected object(s) 
about another object. See “Reflecting 
Objects” on page 237. 

• Click the Move to Front of Group  
edit button to display the selected object 
in front of other objects in the same 
drawing group. See “Move to Front of 
Group” on page 219.

• Click the Convert Polyline  edit but-
ton to convert the object into a special 
polyline-based object. See “Convert 
Polyline” on page 239.

• Click the Revision Cloud(s) Around 
Objects  edit button to create a revi-
sion cloud around each of the selected 
object(s). See “Revision Clouds” on page 
1104.

• Click the Extend Object(s)  edit but-
ton to lengthen other object(s) until they 
intersect the selected object. See “Trim 
and Extend” on page 244.

• Click the Trim Object(s)  edit button 
to shorten the length of object(s) inter-
sected by the selected object. See “Trim 
and Extend” on page 244.

• Click the Align/Distribute Objects  
edit button to specify how the selected 
objects are distributed. See “Align/Dis-
tribute Objects” on page 224. Only avail-
able when multiple objects are selected.

• Click the Object Layer Properties  
edit button to access and edit layer infor-
mation about the selected object. See 
“Object Layer Properties” on page 154.

• Click the Align/Distribute Along 
Line  edit button, then click on a line-
based object align the selected object(s) 
relative to that line. See “Align/Distribute 
Along Line” on page 225. 

Editing Spline Based Objects
A Spline is a curve that passes smoothly 
through a set of points, or vertices. Splines 
are typically used in situations where an 
irregular, free-flowing curve is needed.

Objects are considered spline-based when 
they can be edited similar to CAD splines 

using their edit handles. See “Splines” on 
page 1106. 

Sprinkler lines, spline terrain curbs, spline 
terrain walls and both round and kidney-
shaped terrain features are spline-based 
objects. See “Terrain” on page 715.
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Using the Edit Handles
When a spline is selected, several different 
types of handles display. How many handles 
display depends on whether the Advanced 
Splines  edit button is on or not. See 
“Advanced Splines” on page 213. 

Any action performed using the edit handles 
can be cancelled by pressing the Esc key or 
any two mouse buttons at the same time.

Move
• Click and drag the Move handle to move 

the object according to the currently 

active Edit Behavior . See “Edit 
Behaviors” on page 178. 

• Movement may be limited or stopped by 
other objects or Snap Behaviors. Move 
restrictions can be overridden by holding 
down the Ctrl key while dragging. See 
“Unrestricted Movement” on page 221.

Rotate
• Click and drag the Rotate edit handle to 

rotate the entire spline. 

Vertex
• The Vertex edit handles display along the 

spline at each vertex. Click and drag a 
Vertex edit handle to change the length, 
angle and curve of adjacent segments 
without affecting other vertices. 

Same Line Type 
• Drag a diamond-shaped end handle in 

any direction to draw a new spline seg-
ment that shares the original spline’s 
color, weight, line style, and layer. See 
“Same Line Type Edit Handles” on page 
1083.

Advanced Splines 

Additional edit handles, called Control 
Handles, display beside each spline vertex 

when Advanced Splines  is enabled. See 
“Advanced Splines” on page 213.

The behavior of the edit handles may
depend on the currently active Edit

Behavior. See “Edit Behaviors” on page 178.

Move

Rotate

Vertex

Same Line Type
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• Click and drag a round Control edit han-
dle to change the angle of the associated 
tangent line. 

• If two tangent lines pass through a vertex, 
the angle between them remains constant 
as long as Lock Control Handle Angle 

 is enabled. See “Lock Control Handle 
Angle” on page 214.

Using the 
Specification Dialog

Spline-based objects can be edited 
using their specification dialogs. See 

“Polyline Specification Dialog” on page 
1098.

Using the Edit Toolbar
A selected spline-based object can be edited 
in a variety of ways using the buttons on the 
edit toolbar.  

The following toolbar buttons may display 
on the edit toolbar for a selected spline-based 
object: 

• Click the Select Next Object  edit 
button to select nearby objects instead of 
the selected object. See “Selecting 
Objects” on page 183.

• Click the Open Object edit button to 
open the specification dialog for the 
selected object(s). See “Polyline 
Specification Dialog” on page 1098. 

• Click the Copy/Paste  edit button to 
copy the selected object(s) to the system 
clipboard so they can be pasted else-
where. See “Copying and Pasting 
Objects” on page 170.

• Click the Copy and Paste in Place  
edit button to create a copy of the 
selected object(s) at the same location as 
the original. See “Copy and Paste in 
Place” on page 173.

• Click the Delete  edit button to delete 
the selected object(s). See “Deleting 
Objects” on page 255.

• Click the Transform/Replicate 
Object  edit button to copy, move, 
rotate, resize, or reflect the selected 
object(s). See “Transform/Replicate 
Object Dialog” on page 242.

• Click the Multiple Copy  edit button 
to make a series of copies at set intervals. 
See “Multiple Copy” on page 173.

Control 
Handles

Tangent lines 
through the vertex
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• Click the Make Parallel/Perpendicular 
 edit button to make the selected 

spline edge parallel or perpendicular to 
another straight edge. See “Using Make 
Parallel/Perpendicular” on page 227. 

• Click the Point to Point Move  edit 
button to accurately move the selected 
object(s). See “Point to Point Move” on 
page 222. 

• Click the Add to Library  edit button 
to add the selected object(s) to the library. 
See “Add to Library” on page 829.

• Click the Center Object  edit button 
to center an object along along a wall 
within a room or relative to a cabinet 
fixture. See “Using Center Object” on 
page 227.

• Click the Reflect About Object  edit 
button to reflect the selected object(s) 
about another object. See “Reflecting 
Objects” on page 237. 

• Click the Move to Front of Group  
edit button to display the selected object 
in front of other objects in the same 
drawing group. See “Move to Front of 
Group” on page 219.

• Click the Break Line  edit button to 
add a new corner or pivot point to the 
selected object. See “Break Line” on 
page 231.

• Click the Complete Break  edit 
button to break an edge of the selected 
object into two separate objects. See 
“Break Line” on page 231.

• Click the Trim Object(s)  edit button 
to shorten the length of object(s) inter-
sected by the selected object. See “Trim 
and Extend” on page 244.

• Click the Extend Object(s)  edit but-
ton to lengthen other object(s) until they 
intersect the selected object. See “Trim 
and Extend” on page 244.

• Click the Convert Polyline  edit but-
ton to convert the object into a special 
polyline-based object. See “Convert 
Polyline” on page 239.

• Click the Revision Cloud(s) Around 
Objects  edit button to create a revi-
sion cloud around each of the selected 
object(s). See “Revision Clouds” on page 
1104.

• Click the Fence Select  edit button to 
use the selected object(s) as a selection 
fence. See “Using a Fence” on page 186.

• Click the Convert Spline to Polyline  
edit button to convert the selected spline 
into a polyline. See “Convert Spline to 
Polyline” on page 241.

• Click the Record Walkthrough Along 
Path  edit button to record a walk-
through video of your model along the 
path defined by the selected polyline. See 
“Walkthroughs” on page 1158. 

• Click the Object Layer Properties  
edit button to access and edit layer infor-
mation about the selected object. See 
“Object Layer Properties” on page 154.

• Click the Advanced Splines  edit but-
ton to on advanced splines for the 
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selected spline. See “Advanced Splines” 
on page 213.

• Click the Straighten Spline Segment 
 edit button to straighten a segment of 

an advanced spline. See “Straighten 
Spline Segment” on page 213. Only 
available when Advanced Splines is 
turned on.

• Click the Lock Control Handle 
Angle  edit button to maintain the rel-
ative angle between the vertex and its 
control handles. See “Lock Control Han-
dle Angle” on page 214. Only available 
when Advanced Splines is turned on.

• Click the Align/Distribute Objects  
edit button to specify how the selected 
objects are distributed. See “Align/Dis-
tribute Objects” on page 224. Only avail-
able when multiple objects are selected.

• Click the Align/Distribute Along 
Line  edit button, then click on a line-
based object align the selected object(s) 
relative to that line. See “Align/Distribute 
Along Line” on page 225. 

Advanced Splines
Click the Advanced Splines edit 
button to display additional edit 

handles called Control Handles. These edit 
handles allow you to reshape the spline with 
more control at each vertex.

The line between the vertex and the control 
handles defines the tangent to the spline 
through the vertex. 
• Move the control handles at the end of 

the line to change the direction of the 
spline at that point. The spline curves 
away from its tangent direction at the ver-
tex on its way to the next vertex. 

• Change the shape of the spline by click-
ing and dragging the control handles. 

Notice that the control handles on either side 
of a vertex maintain their relationship to each 
other in a straight line. When one is moved, 
the other moves to keep the tangent line 
tangent with the vertex. 

You can specify all subsequently drawn 
splines to be Advanced Splines in the 
Preferences dialog. See “CAD Panel” on 
page 109.

Straighten Spline Segment
The Straighten Spline Segment edit 
button is used to straighten a segment 

of an advanced spline between two vertex 
points. 

To use, first select the spline. Click the 

Straighten Spline Segment  edit button, 
then click the spline between two vertices. 
That portion becomes straight.Vertex

Tangent line

Control 
Handles

Control handle Result
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If you reselect the spline, you see that the 
two control handles point toward the straight 
section from each vertex point on either end 
of the straight section.

Lock Control Handle Angle
The Lock Control Handle Angle edit 
button is available when Advanced 

Splines is enabled, and is turned on by 
default, as well. This tool maintains the 
relative angle between the vertex and its 
control handles. 

Click the Lock Control Handle Angle  
edit button to free the control of the relative 
edit angles between the vertex and its control 
handles. The control handles can now be 
adjusted individually. The opposite handle 
remains unaffected by the change. Notice 
that the spline adjusts so that it is tangent to 
the lines between the vertex and both of its 
control handles.

Editing Circles, Ovals and Ellipses
Objects created using the Circle Tools 
are unusual in that no architectural 

objects share their functionalities.

Using the Edit Handles
When selected, circles, ovals and ellipses 
display eleven edit handles. 

Unlike Ovals  and Ellipses , a 

Circle  cannot be edited into any other 
shapes; it can only be a circle unless it is 
converted into a polyline. See “Convert 
Curve to Polyline” on page 234.

Any action performed using the edit handles 
can be cancelled by pressing the Esc key or 
any two mouse buttons at the same time.

ResultClick a spline segment

Notice that the control handles are not collinear

Result
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Move
• Click and drag the Move handle to move 

the object according to the currently 

active Edit Behavior . See “Edit 
Behaviors” on page 178. 

• Movement may be limited or stopped by 
other objects or Snap Behaviors. Move 
restrictions can be overridden by holding 
down the Ctrl key while dragging. See 
“Unrestricted Movement” on page 221.

Rotate
• Click and drag the Rotate handle of an 

oval or ellipse to change its orientation.

Reshape
• The eight edit handles beyond the perim-

eter are Reshape edit handles. Move them 

in or out to resize and reshape an oval or 
ellipse.

• Unlike ovals and ellipses, circles cannot 
be reshaped. When a Reshape handle is 
dragged on a circle, it is only resized.

Concentric Resize
• The Concentric Resize edit handle dis-

plays on the perimeter of a circle between 
a corner Reshape handle and the center. 
Click and drag this handle to resize the 
circle without moving its center point. 

The behavior of the edit handles may
depend on the currently active Edit

Behavior. See “Edit Behaviors” on page 178.

Move

Concentric 
Resize

Rotate

Reshape
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Using Dimensions
Dimensions can be used to move or 
resize circle-based objects. See 

“Moving Objects Using Dimensions” on 
page 1019.

Using the 
Specification Dialog

Circles, ovals and ellipses can be 
edited using their specification 

dialogs. See “CAD Circle/Oval/Ellipse 
Specification Dialog” on page 1096. 

Using the Edit Toolbar
A selected circle, oval or ellipse can be 
edited in a variety of ways using the buttons 
on the edit toolbar.  

The following toolbar buttons may display 
on the edit toolbar for a selected circle, oval 
or ellipse:

• Click the Select Next Object  edit 
button to select nearby objects instead of 
the selected object. See “Selecting 
Objects” on page 183.

• Click the Open Object  edit button to 
open the specification dialog for the 
selected object(s). See “Specification 
Dialogs” on page 41.

• Click the Copy/Paste  edit button to 
copy the selected object(s) to the system 
clipboard so they can be pasted else-
where. See “Copying and Pasting 
Objects” on page 170.

• Click the Copy and Paste in Place  
edit button to create a copy of the 
selected object(s) at the same location as 

the original. See “Copy and Paste in 
Place” on page 173.

• Click the Delete  edit button to delete 
the selected object(s). See “Deleting 
Objects” on page 255.

• Click the Transform/Replicate 
Object  edit button to copy, move, 
rotate, resize, or reflect the selected 
object(s). See “Transform/Replicate 
Object Dialog” on page 242.

• Click the Multiple Copy  edit button 
to make a series of copies at set intervals. 
See “Multiple Copy” on page 173.

• Click the Make Parallel/Perpendicular 
 edit button to make the selected edge 

parallel or perpendicular to another 
straight edge. See “Using Make Parallel/
Perpendicular” on page 227. 

• Click the Point to Point Move  edit 
button to accurately move the selected 
object(s). See “Point to Point Move” on 
page 222. 

• Click the Center Object  edit button 
to center an object along along a wall 
within a room or relative to a cabinet 
fixture. See “Using Center Object” on 
page 227.

• Click the Reflect About Object  edit 
button to reflect the selected object(s) 
about another object. See “Reflecting 
Objects” on page 237. 

• Click the Move to Front of Group  
edit button to display the selected object 
in front of other objects in the same 
drawing group. See “Move to Front of 
Group” on page 219.
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• Click the Extend Object(s)  edit but-
ton to lengthen other object(s) until they 
intersect the selected object. See “Trim 
and Extend” on page 244. Not available 
for ellipses. 

• Click the Trim Object(s)  edit button 
to shorten the length of object(s) inter-
sected by the selected object. See “Trim 
and Extend” on page 244. Not available 
for ellipses. 

• Click the Convert Polyline  edit but-
ton to convert the object into a special 
polyline-based object. See “Convert 
Polyline” on page 239.

• Click the Revision Cloud(s) Around 
Objects  edit button to create a revi-
sion cloud around each of the selected 
object(s). See “Revision Clouds” on page 
1104.

• Click the Convert Curve to Polyline  
edit button to convert the selected circle, 
oval or ellipse into a polyline. See “Con-
vert Curve to Polyline” on page 234. 

• Click the Align/Distribute Objects  
edit button to specify how the selected 
objects are distributed. See “Align/Dis-
tribute Objects” on page 224. Only avail-
able when multiple objects are selected.

• Click the Object Layer Properties  
edit button to access and edit layer infor-
mation about the selected object. See 
“Object Layer Properties” on page 154.

• Click the Align/Distribute Along 
Line  edit button, then click on a line-
based object align the selected object(s) 
relative to that line. See “Align/Distribute 
Along Line” on page 225. 

Displaying Objects
The display of objects in 2D and 3D views 
can be controlled by layer. See “Displaying 
Objects” on page 144.

Text, Line and Fill Styles
In addition to text-based objects like Text 
and Schedules, a variety of objects can 
display text as part of their line style or label. 
The appearance of this text can be controlled 
by layer. See “Line and Text Styles” on page 
145. 

Line style, weight and color can be 
controlled by layer or overridden in the 
specification dialogs for many objects. See 
“Line Style Panel” on page 1085. 

You can also toggle the on screen display of 
line weights on and off. See “Line Weights” 
on page 1219.

In addition, many objects have a fill style 
that can be specified in the objects’ 
specification dialogs. See “Fill Style Panel” 
on page 1099.

Color On/Off
The display of color on-screen can be 
toggled on and off in any view by 

selecting View> Color or by clicking the 
toggle button. 
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• If Color  is toggled off in any 3D 
view other than a Vector View or a Line 
Drawing view, the view will be displayed 
in grayscale. 

• If Color  is toggled off in any line 
based view, including floor plan view, 
Vector Views, Line Drawing views, CAD 
Details, and layout, the view will be dis-
played either in black and white or gray-
scale, depending on the Color Off Is 
setting in the Preferences dialog. See 
“Appearance Panel” on page 92.

To display views in gray scale

1. Select View> Color  to toggle color 
off.

2. Select Edit> Preferences  to open 
the Preferences dialog. 

3. On the APPEARANCE panel, select Gray-
scale as the Color Off Is setting. See 
“Appearance Panel” on page 92.

To display views in black and white

1. Select View> Color  to toggle color 
off.

2. Select Edit> Preferences  to open 
the Preferences dialog. 

3. On the APPEARANCE panel, select Black 
and White as the Color Off Is setting. 

When Color  is toggled off and Black 
and White is specified, all lines appear as 
black, regardless of their color. Solid fill 
colors appear as either white or black, 
depending on which is closer to the actual fill 
color when Color is turned on. The 

background remains as defined in the 
Preferences dialog. See “Colors Panel” on 
page 94.

You can specify whether cross section/
elevations, camera views, and overviews 
using the Vector View Rendering Technique 
are generated with colors turned on in the 3D 
View Defaults dialog. See “Options Panel” 
on page 893.

You can also print in color, black and white, 
or gray scale. See “Print View Dialog” on 
page 1226.

Arc Centers and Ends
The display of arc center- and 
endpoints, and the display of circle 

center points can be toggled by selecting 
View> Arc Centers and Ends, by clicking 
the toggle button, or in the CAD Defaults 
dialog. See “CAD Defaults Dialog” on page 
1072. 

Drawing Groups
Each object in a plan or layout file belongs to 
one of three drawing groups, which 
influences whether it displays in front of or 
behind other objects. 
• The Default Group is where most 

objects are placed when first created. 
• Objects moved to the Back Group dis-

play behind those in the other two draw-
ing groups.

• Objects moved to the Front Group dis-
play in front of those in the other two 
drawing groups. 

Most objects are drawn in the Default Group. 
Notable exceptions are imported pictures, 
which are placed in the Back Group, and 
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Walkthrough Paths, which are placed in the 
Front Group. Objects in the Default Group 
display in front or behind one another 
according to program-defined rules that can 
be modified in only limited ways.

Once most CAD or CAD-based objects are 
created, though,  you can control how they 
display relative to other objects using their 
specification dialog. See “Line Style Panel” 
on page 1085.

For example, you can move an object to the 
Back Group or Front Group so that it 
displays behind or in front of objects in the 
other drawing groups.

You can also check Move to Front of Group 
or use the edit button of the same name to 
display the object in front of other objects in 
its drawing group, but not necessarily in 
front of objects in other groups.  

Move to Front of Group
Click the Move to Front of Group 
edit button to move the selected 

object(s) so that it displays in front of other 
objects in the same drawing group. Move to 
Front of Group functions like the checkbox 
of the same name in the object’s specification 
dialog.

An object moved to the front of the Default 
Group, for example, will display in front of 
objects in that group and those in the Back 
Group, but will still display behind objects in 
the Front Group. 

Move to Front of Group  only affects 
the display of objects in the Default Group 
when they are of the same type: for example, 
CAD objects, furnishings, base cabinets, or 
wall cabinets. It cannot make a base cabinet 

display in front of a wall cabinet; but it can 
make a selected wall cabinet display in front 
of other wall cabinets. 

Move to Front of Group  is useful for 
creating a sense of depth or to improve a 
drawing’s clarity. For example, in a cross 
section detail, you can move a CAD circle 
representing rebar to the front of a wall with 
a concrete fill pattern so that the rebar is not 
masked by the wall’s fill pattern. 

Move to Front of Group  is not available 
for Walkthrough Paths.  

Patterns and Textures
The appearance of architectural objects in 3D 
views is affected by the materials applied to 
the objects’ surfaces. See “Materials” on 
page 847. 

Material patterns display in Technical 
Illustration, Line Drawing and Vector Views, 
while textures display in other rendered 
views. See “Rendering Techniques” on page 
951. 

You can turn the display of patterns on or off 
in 3D views that use them by selecting 3D> 
Toggle Patterns .
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In 3D views that use textures, you can turn 
on or off the display of textures by selecting 

3D> Toggle Textures . 

Delete Surface
In any 3D view, select 3D> Delete 
Surface, then click a surface in the 

view to temporarily remove the surface from 

the current view. See “Delete 3D Surface” on 
page 910.

Refresh Display
Refresh Display redraws the current 
window to clean up extra lines, show 

missing items, and correct random on-screen 
effects caused by changes to a model. Select 
View> Refresh Display or press the F5 key 
to refresh the on-screen display. 

Moving Objects
Objects can be moved using the edit handles 
as well as a variety of edit tools. Multiple 
selected objects can also be moved as a 
group. See “Selecting Objects” on page 183.

Using the Edit Handles
Select an object, then click the Move edit 
handle and drag it to a new location. When 
your pointer is over the Move handle, it 
displays a four-headed arrow. 

As an object is moved, it jumps at set 

increments when Grid Snaps  are 
enabled. See “Grid Snaps” on page 166.

When Object Snaps  are enabled, a 
selected object snaps to its original location 
if it passes over that location while being 
moved.

The behavior of the Move edit handle varies 
depending on the currently active Edit 
Behavior . See “Edit Behaviors” on page 
178.  

• If the Default , Resize , Concen-
tric  or Fillet  edit behavior is 
active, the object moves orthogonal, or at 
a right angle to, any of its edges.

• If the Alternate  edit behavior is 
active, the selected object(s) can be 
moved at Allowed Angles if Angle 
Snaps  are enabled, or orthogonal to 
any of its edges if they are not. See 
“Alternate” on page 179.

• If the Move edit behavior is active, the 
selected object(s) can be moved by click-
ing and dragging any edit handle that 
would otherwise be used for resizing. See 
“Move” on page 179.

You can temporarily slow the movement of 
your mouse as you drag an edit handle by  
holding down the Shift key on your 
keyboard.
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Bumping/Pushing
When Edit> Snap Settings> 
Bumping/Pushing is enabled, 

architectural objects will bump into and can 
push one another as they are moved. This 
setting also affects CAD and CAD-based 
objects with CAD Stops Move and/or Wall 
Stops Move enabled. See “Line Style Panel” 
on page 1085. 

When an object bumps into another object 
while it is being moved, it stops. If you do 
not release the mouse button and continue to 
drag, however, the selected object resumes 
movement and continues past the obstructing 
object. 

Instead of dragging through and past an one 
or more obstructing objects, you can instead 
push them. To do this, bump an object into an 
obstructing object and release the mouse 
button. Then, click and drag the Move edit 
handle a second time in the same direction. 

Walls, wall openings, cabinets, furnishings 
and fixtures, and CAD and CAD-based 
objects are examples of objects that can 
bump into as well as push other objects. 

By default, Bumping/Pushing  does not 
affect objects moved using dimensions or the 
Enter Coordinates dialog. See “Moving 
Objects Using Dimensions” on page 1019 
and “Entering Coordinates” on page 168. 

The Maximum Bump Distance, which is 
the distance you must drag to override 
bumping, is set in the Preferences dialog. 
Bumping/Pushing for Type-in Movement 
can also be enabled there. See “Snap 
Properties Panel” on page 115. 

Certain types of objects, notably roof planes, 
and objects on locked layers can be bumped 

but cannot be pushed. See “Layer Display 
Options Dialog” on page 149. 

CAD Stops Move/
Wall Stops Move

CAD and CAD-based objects can be set to 
stop at other CAD objects and/or at walls as 
they are being moved. See “Line Style 
Panel” on page 1085.

Some objects, such as cross boxes, framing 
members and insulation, are automatically 
set to stop when moved against other CAD 
objects. 

CAD Stops Move and Wall Stops Move do 

not function if Bumping/Pushing  is 
turned off.

Unrestricted Movement
Many objects have restrictions placed on 
their movement by their own properties or 
specification settings. Architectural objects, 
for example, bump into other 3D objects as 
they are being moved when Bumping/
Pushing  is enabled.

CAD-based objects can be set to stop at other 
CAD objects or at walls. See “Line Style 
Panel” on page 1085. 

Other move restrictions are activated by the 

Snap Settings . See “Snap Behaviors” on 
page 162.

These restrictions can be overridden when 
necessary by holding down the Ctrl key 
while dragging to move an object.

To move an object freely 

1. Select the object. 
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2. Hold down the Ctrl key.
3. Click the Move edit handle and drag it to 

the new location.

You can also press the Ctrl key while 
dragging an object’s Move handle to override 
move restrictions. 

Nudging
You can use your keyboard to move a 
selected object or objects by single Snap 
Grid increments in 2D and 3D views. This is 
referred to as nudging. See “Grid Snaps” on 
page 166.

By default, the Nudge commands are not 
assigned hotkeys and the arrow keys are 
programmed to nudge a selected object. If 
you press an arrow key when no object is 
selected, you will instead pan the view 
window. See “Panning the Display” on page 
882.

If you wish, you can program assign hotkeys 
to the Nudge commands. When Nudge 
hotkeys are assigned, they cannot also be 
used to pan the display. See “Hotkeys” on 
page 138. 

In Floor Plan View

To nudge an object in floor plan view, select 
it and press any of the four arrow keys: Up, 
Down, Left, or Right. These directions are 
relative to the Snap Grid: if Rotate Plan 
View  is used to rotate floor plan view, the 
definitions of up, down, left, and right are 
affected. See “Rotate Plan View” on page 
237.

In 3D Views

To nudge an object in camera views, 
overviews, and cross section/elevation 

views, you can program the keys of your 
choice for use as nudging hotkeys. See 
“Hotkeys” on page 138.

In 3D views, nudging is relative to the 
selected surface. If, for example, you select 
the front of a cabinet in 3D and nudge it to 
the left, it will move to the left in floor plan 
view. If you instead select the back of a 
cabinet in 3D and nudge it to the left, it will 
move to the right in floor plan view. 

When multiple objects are selected, the 
surface that was clicked on last is considered 
the selected surface. When nudged, all 
selected objects will move relative to that 
surface. See “Shift and Ctrl Select” on page 
186. 

If an object is rotated, the directions that it 
can be nudged in 2D are not affected; 
however, in 3D, they are. If, for example, a 
cabinet is rotated 45º, it will nudge to the left 
as defined by the Snap Grid in floor plan 
view. When nudged in 3D, however, it will 
move at a 45º angle to the Snap Grid: or 
parallel to the selected surface.

Point to Point Move
The Point to Point Move edit button 
allows a selected object or group of 

objects to be accurately moved. 

To use Point to Point Move

1. Select one or more objects that you 
would like to move, then click the Point 
to Point Move  edit button.

2. Click a point that you want to accurately 
reposition.
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3. Click the point in the plan where you 
would like the selected point to be relo-
cated when it is moved.

4. The selected object(s) are moved so that 
they maintain their position relative to 
the point. 

Point to Point Move  can be used with 

the Copy/Paste  edit button. See “To 
point to point copy” on page 176.

Point to Point Move  can also be used 

with the Edit Area  tools. See “Edit Area 
Tools” on page 252.

Center Object
The Center Object edit button allows 
you to move walls, cabinets and other 

objects so that they are centered along a wall 
within a room or relative to a window or 
cabinet. 

Move to Framing Reference
Framing members can be positioned 
relative to a Framing Reference using 

the Move to Framing Reference edit tool. 
See “Framing Reference Marker” on page 
585.

Using Dimensions
Objects or the selected edges of some 
objects can be moved using 

dimensions. See “Moving Objects Using 
Dimensions” on page 1019.

When Bumping/Pushing for Type-in 
Movement is checked in the Preferences 
dialog, adjacent objects can be pushed when 
an object is moved using dimensions. 

Enter Coordinates
Objects or the selected edges of some objects 
can be moved using the Enter Coordinates 
dialog. See “Entering Coordinates” on page 
168. 

To push additional objects using the Enter 
Coordinates dialog, check Bumping/
Pushing for Type-in Movement in the 
Preferences dialog, then bump an object 
into another object. Click and drag a second 
time to begin pushing and press the Tab key 
to open the Enter Coordinates dialog. 

Using the Transform/
Replicate Object Dialog
Objects and groups of objects can be 
moved relative to themselves or an 

absolute location using the Transform 
Replicate Object dialog. See “Transform/
Replicate Object Dialog” on page 242.

Aligning Objects
It is often important to align objects such as 
text boxes, roof plane edges or walls, or to 

align objects on different floors. There are 
several methods to choose from. 

Note: By default, objects moved using either
the Enter Coordinates dialog or dimensions
are not subject to Bumping/Pushing. See
“Bumping/Pushing” on page 221.
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Align/Distribute Objects
Select two or more objects and click 
the Align/Distribute Objects edit 

button to open the Align/Distribute Objects 
dialog and specify how to align or distribute 
the selected objects vertically and/or 
horizontally.

Align/Distribute Objects  is available in 
all views for most CAD objects. For 
architectural objects, it is only available in 
floor plan view.  

Specify what edges or points on the 
selected objects to Move Objects 

Vertically to.
• Select Don’t Move Vertically to make 

no changes to the vertical alignment of 
the selected objects. 

• Select Top Edges to move the selected 
objects so their top edges are aligned. 
The object with the highest top edge in 
the selection set does not move.

• Select Centers to move the selected 
objects so their centers are aligned verti-
cally. The object with the center closest to 
the vertical center of the selection set 
does not move.

• Select Bottom Edges to move the 
selected objects so their bottom edges are 
aligned. The object with the lowest bot-
tom edge in the selection set does not 
move.

• Select Space Evenly to produce consis-
tent vertical spacing between the top and 
bottom edges of the objects in the selec-
tion set. The highest and lowest objects 
on screen do not move and the ones in 
between move up or down as needed. 
Only available if three or more objects 
are selected.

• Select Distribute Centers Evenly to pro-
duce consistent on-center vertical spacing 
between the objects in the selection set. 
The highest and lowest objects on screen 
do not move and the ones in between 
move up or down as needed. Only avail-
able if three or more objects are selected.

Specify what edges or points on the 
selected objects to Move Objects 

Horizontally to.
• Select Don’t Move Horizontally to 

make no changes to the horizontal align-
ment of the selected objects. 

• Select Left Edges to move the selected 
objects so their left edges are aligned. 

1

2
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The object in the selection set with the 
leftmost edge does not move.

• Select Centers to move the selected 
objects so their centers are aligned hori-
zontally. The object with the center clos-
est to the horizontal center of the 
selection set does not move.

• Select Right Edges to move the selected 
objects so their right edges are aligned. 
The object in the selection set with the 
rightmost edge does not move.

• Select Space Evenly to produce consis-
tent horizontal spacing between the left 
and right edges of the objects in the selec-
tion set. The left- and rightmost objects 
on screen do not move and the ones in 
between move left or right as needed.

• Select Distribute Centers Evenly to pro-
duce consistent on-center horizontal 
spacing between the objects in the selec-
tion set. The left- and rightmost objects 
on screen do not move and the ones in 
between move left or right as needed.

Align/Distribute Along Line
Select one or more objects, click the 
Align/Distribute Along Line edit 

button, then click on a line or line-based 
object to open the Align To Line dialog and 
specify how to align the selected objects 
relative to the line.

Align/Distribute Along Line  is 
available in all views for most CAD objects.  
For architectural objects, it is only available 
in floor plan view. 

Specify the Alignment to apply to the 
selected object(s) relative to the line.

• Select None to make no changes to the 
alignment of the selected objects. 

• Select Centers to move the selected 
objects so their centers are aligned with 
the line.

1
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• Select Closest Edges to move the 
selected objects so the edges closest to 
the line are aligned with the line. 

Specify the Distributation of the 
selected objects relative to the line. 

• Select None to make no changes to the 
spacing of the selected objects. 

• Select Space Evenly to produce consis-
tent spacing between the edges of the 
objects in the selection set in the same 
direction as the line. The outermost 
objects in the group do not move and the 
ones in between move as needed. 

• Select Distribute Centers Evenly to pro-
duce consistent on-center spacing in the 
same direction as the line between the 
objects in the selection set. The outer-
most objects in the group do not move 
and the ones in between move as needed.

Specify, too, how the first and last objects 
align with the line’s endpoints. These options 
are only available if three or more objects are 
selected. 
• Select Distribute To Endpoints to posi-

tion the first and last objects in the array 
so they align with the line’s endpoints. 

• Select Distribute Between Endpoints to 
position the first and last objects in the 
array so inside the line’s endpoints, 
spaced as though there were additional 
objects aligned with the endpoints. 

Using the Mouse 
Cross Hairs

Objects can be aligned by eye using the 
mouse cross hairs as a reference. This 
method can help you draw, place and edit 
objects quickly and with reasonable 

accuracy, but is not necessarily as accurate as 
some of the other approaches described here.

The mouse cross hairs can be turned on and 
off and their size and aperture set in the 
Preferences dialog. See “Edit Panel” on 
page 111.

Using Snap Settings

With Object Snaps  on, you can snap the 
edge of a selected object to that of another. 
Select an edge of an object. Drag it to the 
edge of another object to reveal an Object 
Snap point, then release the mouse.

With Grid Snaps  on and Angle 
Snaps  off, select the left side of the 
object, and drag from the center move 
handle. This snaps the selected side to the 
grid.

When both Grid Snaps  and Angle 
Snaps  on, objects snap at increments 
equal to the Snap unit specified in the Plan 
Defaults dialog rather than onto the grid 
itself. This does not align objects to the grid 
unless they were already snapped to the grid. 
See “Snap Behaviors” on page 162. 

Using Dimensions
Create a temporary or manual 
dimension relative to an object such as 

a wall or line, and relocate the objects to the 
same dimension. See “Moving Objects 
Using Dimensions” on page 1019. 

2

Text objects can be aligned using set-
tings in the Text Specification dialog.

See “Aligning Text” on page 1048.
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CAD Stops Move/
Wall Stops Move

CAD and CAD-based objects can be aligned 
using another CAD object or a wall as a 
guide. Check the CAD Stops Move and/or 
Wall Stops Move boxes in the objects’ 
specification dialogs, then move them until 
they bump into the CAD object or wall that 
you wish to use as a guide for alignment. See 
“Line Style Panel” on page 1085.

Using Make Parallel/
Perpendicular

The Make Parallel/Perpendicular 
edit button allows you to make a 

selected object parallel or perpendicular to 
any straight edge. 

If you select an edge of a polyline-based 
object, adjacent edges extend or contract to 
maintain contact, but other edges are remain 
unchanged. The selected edge rotates about 
its endpoint if selected near the end, or about 
its center if you click within its middle third. 

The Make Parallel  edit button displays 
for a selected CAD block instance when a 
line, including a straight polyline edge, or 
box edge within a block instance, straight 
polyline edge is selected. The entire block is 
rotated to make the selected line or edge 
perpendicular or parallel to the item 
subsequently clicked on. 

To use Make Parallel/Perpendicular

1. Select an object such as a roof plane on 
the edge that you would like to make 
parallel or perpendicular to another 
object.

•  Click near the center of the edge to 
rotate it about the center.

•  Click near an end to rotate the edge 
about that end.

2. Click the Make Parallel/
Perpendicular  edit button

3. Click on a straight edge such as a wall.
4. If the first object is within 45° of parallel 

to the second object, it is made parallel. 
Otherwise, it is made perpendicular to 
the second object. 

You can also make the selected edge parallel 
by rotating the entire object. See “Make 
Parallel/Perpendicular with Polyline Based 
Objects” on page 236.

Using Center Object
The Center Object edit button can be 
used to center a variety of objects 

relative to another object. Center Object can 
be used to center architectural objects in 
floor plan, cross section/elevation, and 3D 
views. It can also be used to center CAD 
objects in floor plan view, layout, and CAD 
Details.

Select edge

Click button

Click 

Result

wall
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To center an object 

1. Select an object.

2. Click the Center Object  edit button.
3. Move the mouse pointer over the object 

you would like to center the selected 
object relative to.

•  As the pointer passes over an eligible 
object, it becomes highlighted and a 
dashed centering axis line displays.

4. When the desired centering axis dis-
plays, click once to center the selected 
object along that axis line.

To center an object in a room

1. Select an object such a cabinet.

2. Click the Center Object  edit button.
3. Move the mouse pointer in the room that 

you would like to center the selected 
object relative to.

•  As you move the pointer, a centering 
axis will display along the wall it is 
closest to.

•  The selected object does not have to be 
inside a room in order to be centered 
relative to that room.

4. When a centering axis displays along the 
correct wall, click once. 

5. The object is moved perpendicular to the 
centering axis. 

If you click outside an exterior wall instead 
of clicking inside, the selected object is 
centered along the edge of the Exterior 
Room. See “The Exterior Room” on page 
332. 

Using Make Arc Tangent
If a selected arc is attached on one or 
both ends to another line or arc, the 

Make Arc Tangent edit button displays. 
Click this button to adjust the arc and 
attached lines so they transition smoothly.

To use Make Arc Tangent

1. Select an arc-based object attached to 
like objects on one or both ends. 

2. Click the Make Arc Tangent  edit 
button. 

•  If the arc is attached to an object on one 
end, it will adjust so that it is tangent to 
that object.

•  If the arc is attached to objects on both 
ends, the Radius of Tangent Arc dia-
log opens. 

3. The radius from the center of curvature 
to the middle of the arc-based object dis-
plays. Keep this radius or change it, and 
click OK.

4. The arc and attached segments adjust so 
that the arc radius matches the target as 

Before After
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closely as possible and the arc is made 
tangent to the attached segments. 

Aligning Arc Centers
The center points of circles and arc-based 
objects can be aligned, even if the objects are 
on different floors, when the Reference 
Display is turned on and Arc Centers and 
Ends  is toggled on. Note that Arc 
Centers and Ends is a floor-specific toggle. 
See “The Reference Floor” on page 444 and 
“Arc Centers and Ends” on page 195.

To align center points easily, it is helpful to 

turn on Object Snaps  and turn off Angle 
Snaps . See “Object Snaps” on page 162 
and “Angle Snaps” on page 164.

Aligning Objects on 
Different Floors

Objects on different floors can be aligned 

with one another using Object Snaps  

and the Reference Display . See “Object 
Snaps” on page 162 and “The Reference 
Floor” on page 444.

Resizing Objects
Objects can be resized using the edit handles, 
specification dialogs, and the Transform/
Replicate Object dialog. 

Using the Edit Handles
Depending on the currently active Edit 
Behavior , the end, corner and/or side 
edit handles can be used to resize a selected 
object. See “Edit Behaviors” on page 178.

When the Concentric  edit behavior is 
active, dragging an object’s corner or end 
handle  resizes it according to the 
Concentric Jump value set in the 
Preferences dialog. See “Concentric” on 
page 180.

Objects can be resized about either their 
center points or the current CAD point. See 
“Behaviors Panel” on page 113.

To override any movement restrictions 
caused by snap settings or the presence of 

other objects, press the Ctrl key while 
dragging an edit handle.

As an object is resized, any dimensions 
indicating its size will update to reflect your 
changes. You can use dimensions as 
references to help you achieve the correct 
size for most objects. 

You can temporarily slow the movement of 
your mouse as you drag an edit handle by  
holding down the Shift key on your 
keyboard.

Using the 
Specification Dialog

Most objects can be accurately resized 
in their specification dialogs. Some 

objects, such as images and some symbols, 
have a Retain Aspect Ratio option that lets 
you easily resize the object without distorting 
its shape. See “Specification Dialogs” on 
page 41. 
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Using Dimensions
Many objects can be resized by 
selecting an edge and then moving 

that edge using dimensions. See “Moving 
Objects Using Dimensions” on page 1019.

Walls can also be resized using dimensions; 
however, it is important to understand that 
the selected edges of other objects cannot be 
resized using dimensions - they can only be 

moved. To resize an edge, select an adjacent 
edge and move that edge instead.

Using the Transform/
Replicate Object Dialog
Most objects can be resized about 
either their centers or an absolute 

point using the Transform Replicate Object 
dialog. See “Transform/Replicate Object 
Dialog” on page 242.

Reshaping Objects
There is a variety of ways to reshape objects 
using the edit handles, specification dialogs 
and edit toolbar buttons.

Some objects, notably circles and box-based 
objects, cannot be reshaped - only resized. 
See “Resizing Objects” on page 229.

Using the Edit Handles

Depending on the Edit Behavior  in use, 
the end, corner and/or side edit handles can 
be used to reshape a selected object. See 
“Edit Behaviors” on page 178.

When a line-based, arc-based, or open-
polyline based object is selected, you can 
right-click and drag an end handle to change 
a line into an arc or vice versa. This behavior 
does not apply to closed polylines.

To override any movement restrictions 
caused by snap settings or the presence of 
other objects, press the Ctrl key while 
dragging an edit handle.

You can temporarily slow the movement of 
your mouse as you drag an edit handle by  

holding down the Shift key on your 
keyboard.

Using the 
Specification Dialog

A variety of CAD and CAD-based 
objects can be reshaped by editing 

values on either the SELECTED LINE or 
SELECTED ARC panel of their specification 
dialogs. See “Polyline Specification Dialog” 
on page 1098.

Using Dimensions
Both temporary and manually drawn 
dimensions can be used to increase or 

decrease the distance between the edge a 
line- or polyline-based object and another, 
parallel edge or line. 

Angular Dimensions  can be used to 
adjust the angle where two polyline segments 
meet. See “Using Angular Dimensions” on 
page 235.
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Break Line
The Break Line edit tool can be used 
to break an individual line-, arc-, or 

spline-based object into two segments. The 
edges of a polyline-based object can also be 
broken.

The Break Line  edit tool can also be 
used to create stepped cross section cutting 
planes. See “Stepped Cutting Planes” on 
page 904. 

There are two types of breaks: partial and 
complete. Partial breaks create a new corner, 
or pivot point, while complete breaks 
actually sever an edge into two segments. 

To create a partial break

1. Click the object, object edge, or object 
centerline that you want to break into 
two segments.

2. Click the Break Line  edit button 
once or press the 3 key. 

3. If you would like to create more than 

one break, click the Sticky Mode  
edit button. 

4. If you would like to move the edges of 
the object as you add breaks, click the 

Edge Edit Handles  edit button to 
toggle on their display. 

5. If you want, you can click the Corner 
Edit Handles  edit button to toggle 
off their display. 

6. Click the edge to create a new corner 
edit handle at that location and two sepa-
rate edges on either side of that handle. 

7. If you enabled Sticky Mode , con-
tinue clicking to place additional breaks.

8. Click the Main Edit Mode  edit but-
ton or press the Esc key to return to the 
selected object’s main edit toolbar.

If you click and drag one of the edit handles 
on either side of the partial break, the edge 
moves at a right angle to itself and another 
edge forms, connecting the moved edge with 
the one on the other side that does not move.

You can remove an edge from a polyline-
based object by clicking and dragging a 
corner handle until it snaps to an adjacent 
corner handle.

When a complete break is created, the object 
or edge is totally severed at that point. 

With the exception of framing members, 
complete breaks cannot be created on CAD-
based architectural objects. In the case of 
framing members, only complete breaks can 
be created.

To create a complete break

1. Click the object, object edge, or object 
centerline that you want to break into 
two segments.

2. Click the Break Line  edit button. 

3. Click the Complete Break  edit 
button. 

Note: The Break Line edit button is not avail-
able for box-based objects, objects created
with the Circle Tools, North Pointers, Sun
Angles, Joist Direction Lines, or some archi-
tectural objects such as stairs and trusses.
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4. If you would like to create more than 
one complete break, click the Sticky 
Mode  edit button. 

5. If you would like to move the edges of 
the object as you add breaks, click the 

Edge Edit Handles  edit button to 
toggle on their display. 

6. If you want, you can click the Corner 
Edit Handles  edit button to toggle 
off their display. 

7. Click on an edge to create a complete 
break at that location. 

8. If you enabled Sticky Mode , con-
tinue clicking to place additional breaks.

9. Click the Main Edit Mode  edit but-
ton or press the Esc key to return to the 
selected object’s main edit toolbar.

The edge that you clicked on will be divided 
into two separate sections, one of which will 
be selected. You can now move or edit the 
selected edge completely independent of the 
object or edge on the other side of the break. 
Click on the other edge to select it instead.

When Object Snaps  are enabled, breaks 
can be placed at snap locations such as 
midpoints. See “Object Snaps” on page 162.

To remove a break from an edge

1. Make sure that Object Snaps  are 
enabled.

2. Select the object that has a break that 
you want to remove.

3. Click on the corner edit handle 
associated with the break that you want 

to remove and drag it to an adjacent 
corner handle.

4. When you see an Endpoint  snap 
indicator, release the mouse button. The 
hande that you selected will be removed.

Change Line/Arc
Select an individual line-based or arc-
based object or a segment of a 

polyline-based object and click the Change 
Line/Arc edit button to convert the selected 
segment from a line to an arc or vice versa.

Make Parallel/Perpendicular
The Make Parallel edit button can be 
used to reshape a polyline by making 

a selected edge parallel or perpendicular to 
another straight edge. See “Using Make 
Parallel/Perpendicular” on page 227. 

Intersect/Join Two Lines
The Intersect/Join Two Lines edit 
tool allows you to connect two non-

parallel line- and/or arc-based objects or to 
join two edges of an open or closed polyline-
based object. The lines or edges will shorten 
or lengthen as need to intersect at a point and 
join. If one or more edges exists between the 
two polyline edges, they will be removed. 
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To use Intersect/Join Two Lines

1. Click on a line, arc, or polyline segment 
that you would like to connect to another 
line or segment.

2. Click the Intersect/Join Two Lines  
edit button.

3. Click on the other line or polyline edge.
4. If there are intervening polyline edges, a 

message will confirm that you would 
like them to be removed. Click Yes.

Fillet Lines
The Fillet Lines edit tool allows you 
to replace the angled corner where 

two polyline edges meet with an arc or to 
join two non-parallel line-based objects with 
an arc. 

If one or both of the two objects is an arc, 
both will extend or contract as needed to 
become connected. No additional arc is 
created.

To use Fillet Lines

1. Click on a line or polyline segment that 
you would like to connect to another line 
or segment with a fillet, or arc.

2. Click the Fillet Lines  edit button, 

then click the Fillet Radius  edit but-
ton. 

3. In the Set Fillet Radius dialog, specify 
the desired Fillet Radius and click OK. 
If this value is 0, no fillet will be created.

4. To apply the specified radius to all cor-
ners of a selected polyline, click the Fil-
let All Corners  edit button. If the 
selected polyline is a Custom Counter-
top or Molding Polyline, any corners 
that touch a wall will not be filleted by 
this tool. 

5. To apply a fillet to more than one corner 
of the selected polyline, click the Sticky 
Mode  edit button.

6. Click on the line or polyline segment 
that you want the selected line or edge to 
connect to with a fillet.

7. If you enabled Sticky Mode , con-
tinue clicking on edges to create addi-
tional fillets.

8. Click the Main Edit Mode  edit but-
ton or press the Esc key to return to the 
selected object’s main edit toolbar.

Once two lines are filleted, the arc between 
them can be edited. See “Editing Arc Based 
Objects” on page 191.

Chamfer Lines
The Chamfer Lines edit tool allows 
you to create a straight corner bevel of 

a specified size connecting any two non-
parallel lines or polyline edges. It can also be 
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used to extend an arc so that it joins to 
another arc or line.

If one or both of the two objects is an arc, 
both will extend or contract as needed to 
become connected. No additional chamfer is 
created.

The Chamfer Lines  edit tool is used 

much the way the Fillet Lines  edit tool 
is. See “To use Fillet Lines” on page 233. 

Close Polyline
An open polyline-based object can be 
converted into a closed polyline using 

the Close Polyline edit tool. See “Using 
Close Polyline” on page 201. 

Convert Curve to Polyline
The Convert Curve to Polyline edit 
button allows you to convert the 

selected arc- or circle-based object to a 
polyline composed of line segments.

To convert curve to polyline

1. Select an arc-based object or circle.

2. Click the Convert Curve to 
Polyline  edit button.

3. In the Convert Curve to Polyline dia-
log, specify the number of sides you 
would like the converted arc or circle-
based object to have.

•  The initial values in this dialog may 
vary depending on the type of object 
selected. 

4. Click OK to convert the selected arc or 
circle-based object into a polyline with 
the specified number of edges. 

Convert to Spline
Click the Convert to Spline edit 
button to convert the selected 

polyline-based object into a spline. See 
“Convert to Spline” on page 234. 

Union, Intersection, Subtract
Closed polyline-based 
objects can be reshaped 

using the Union, Intersection and Subtract 
edit buttons. See “Union, Intersection, and 
Subtract” on page 246.

Rotating Objects
Objects can be rotated using the edit handles 
as well as a variety of edit tools. Multiple 

selected objects can also be rotated as a 
group. See “Selecting Objects” on page 183. 

The Fillet Lines and Chamfer Lines edit
tools can also be used the same way as

the Intersect/Join Two Lines tool to join lines
and polyline edges and remove any interven-
ing polyline edges. 
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By default, an object or group of objects  
rotate about the center point of the selection 
set. You can instead specify that objects 
rotate about the current CAD point.  See 
“The Current Point” on page 1078.

Using the Edit Handles
Select an object, then click the triangular 
Rotate edit handle and drag it in any 
direction. When your pointer is over the 
Rotate handle, it displays a curved arrow.

The angles of line-based objects can also be 
changed by dragging an end handle in a 
direction other than parallel to the object. 
The object rotates about the opposite end 
point. See “Editing Line Based Objects” on 
page 187.

When Angle Snaps  are enabled, objects 
snap to Allowed Angles as specified in the 
Plan Defaults dialog as they are rotated. See 
“Angle Snaps” on page 164. 

To override any movement restrictions 
caused by snap settings or the presence of 
other objects, press the Ctrl key while 
dragging an edit handle.

You can temporarily slow the movement of 
your mouse as you drag an edit handle by  
holding down the Shift key on your 
keyboard.

Using the 
Specification Dialog

The exact angle of some objects such 
as lines, arcs, walls and the selected 

edges of polylines can be specified on either 
the GENERAL panel, SELECTED LINE panel, 
or SELECTED ARC panel of that object’s 

specification dialog. See “Polyline 
Specification Dialog” on page 1098.

Rotate/Resize About
Objects can be rotated or resized 
about either their own centers or the 

current CAD point. See “The Current Point” 
on page 1078. 

You can specify which behavior is used by 
selecting Edit> Edit Behaviors> Rotate/
Resize About Current Point . When this 
option is selected, objects rotate about the 
current CAD point; when it is not selected, 
object rotate about their centers. 

The Rotate/Resize About behavior can also 
be specified in the Preferences dialog. See 
“Behaviors Panel” on page 113. 

Entering Coordinates
Objects can be rotated by entering 
coordinates or a distance and angle in the 
Enter Coordinates dialog. See “Entering 
Coordinates” on page 168.

Using Angular Dimensions
Angular Dimensions are useful for 
adjusting the angles of a variety of 

objects with straight edges. See “Angular 
Dimensions” on page 1006. 
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To change an angular dimension

1. Draw an Angular Dimension  
between the objects you want to move.

•  Begin and end as close as possible to 
the two objects you wish to locate.

2. Select the edge that you want to move.
3. Click the dimension value to open the 

Set Angular Dimension dialog.
•  The Previous Value is indicated 

degrees, minutes and seconds. 

4. Enter a value in the New Value field.
5. Select Rotate Edge to move the selected 

edge when OK is clicked or select 
Rotate entire polyline to rotate the 
entire object the selected edge is a part 
of, maintaining the Previous Value of the 
angle.

6. Click OK to apply the change.

When an entire polyline is rotated using the 
Set Angular Dimension dialog, it rotates 
around the vertex of the angle. 

Make Parallel/Perpendicular 
with Polyline Based Objects

The Make Parallel/Perpendicular 
edit button usually adjusts the angle of 

a selected polyline edge. See “Using Make 
Parallel/Perpendicular” on page 227. 

To rotate the entire polyline instead, Shift + 
select the polyline before using the Make 
Parallel  edit tool.

You can also double-click the Make Parallel 
 edit button to open the Make Parallel 

dialog.

Choose to either Rotate Selected Edge 
Only, or Rotate Entire Polyline. This 
setting is global, affecting all files, and is 
retained during the current program session. 

Polylines rotate according to the current 
Rotate/Resize About setting. See 
“Behaviors Panel” on page 113.

Using the Transform/
Replicate Object Dialog
Objects and groups of objects can be 
rotated to a relative or absolute angle 

using the Transform Replicate Object 
dialog. See “Transform/Replicate Object 
Dialog” on page 242.
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Using Multiple Copy
A rotated array of copies of the 
selected object(s) can be created using 

the Multiple Copy edit tool. See “To create 
an array of copies” on page 174. 

Rotate Plan View
To rotate everything in floor plan 
view, including all objects on all 

floors, the Snap and Reference Grids, the 
plan’s Cartesian coordinates, and the 
drawing sheet, select Tools> Rotate Plan 
View to open the Rotate Plan View dialog. 

Enter the degrees to rotate the floor plan 
view to using decimal units with either 
positive or negative values. 

The degrees rotated displays in ±180º format. 
For example, if you enter 270º, it displays as 
-90º when the dialog is reopened.

Rotate Plan View  rotates a plan relative 
to its original orientation. For example, 
entering 90º twice results in a rotation of 90º, 
not 180º.

Text objects rotate with the plan unless you 
uncheck Rotate with plan in the Text 
Specification dialog for each object. See 
“Rich Text Specification Dialog” on page 
1034.

If you use Rotate Plan View  and then 

use either the CAD Detail from View  or 

Plan Footprint  tool, the CAD Detail 
window that is created will permanently 
inherit the same rotation as the floor plan 
view. If you later modify the floor plan 
view’s rotation, the CAD Detail will not be 
affected. See “CAD Details” on page 1117 
and “Plan Footprint” on page 1119. 

Reflecting Objects
There are several ways to reflect an object, 
group of objects, or an entire plan about an 
axis or another object. Either the original 
object(s) or copies of the original(s) can be 
reflected. 

Reflect About Object
A selected object or objects can be 
reflected about another object, 

regardless of its angle, using the Reflect 
About Object edit tool. 

Line-based objects are often used for 
reflecting a selection, but most objects have 
an axis that can be used.  

The Rotate Plan View tool does not
rotate objects; it literally rotates your

view of those objects. As a result, it does not
alter the orientation of the plan in layout views
or on the printed page. 
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• When an open or closed polyline-based 
object is used as the reflective object, the 
edge that is clicked on acts as the axis.

• When a circle or box-based object such 
as a CAD box or cabinet is used as the 
reflective object, the axis runs down the 
center of the object from back to front.

• In 3D views, architectural objects can 
only be reflected about a vertical axis - 
not a horizontal axis.

To use Reflect About Object

1. Draw a CAD line to act as the reflection 
line. 

2. Select the object(s) to be reflected. 

3. Click the Reflect About Object  edit 
button.

4.  Click the CAD line to reflect the selec-
tion about the line. 

5. The selection is reflected around the 
CAD line, and the original is no longer 
there. 

To retain a copy of the selected object(s) in 
the original location, click the Copy/
Paste  edit button before clicking the 

Reflect About Object  button.

Using the Transform/
Replicate Object Dialog
Objects and groups of objects can also 
be reflected horizontally or vertically 

using the Transform Replicate Object 
dialog. See “Transform/Replicate Object 
Dialog” on page 242.

Reverse Plan
The Reverse Plan tool is a quick way 
to mirror a plan so that everything on 

all floors of the entire plan is swapped left to 
right. 

Select Tools> Reverse Plan  to reflect an 
entire plan right to left, as though it were 
reflected about a vertical line. 

Reversing a plan rebuilds the entire model 
and affects views sent to layout. 

Reverse Direction
Select a line-based, arc-based or 
polyline-based object and click the 

Reverse Direction edit button to reverse its 
direction. Not available for Terrain Path 
objects.

Reversing a line or polyline is useful with 
certain line styles or with an arrow at one 
end.

Converting Objects
CAD objects and many CAD-based objects 
can be converted into a variety of other types 
of objects.

CAD to Walls
CAD to Walls allows you to convert a 
2D line drawing into a 3D model. 

Double CAD lines and arcs drawn to 
represent wall layers and other structural 
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items can be converted to actual Chief 
Architect walls, railings, windows, or doors. 
See “CAD to Walls” on page 300.

CAD Detail from View
Select CAD> CAD Detail from View 
to create a CAD drawing of the 

current view. See “CAD Detail from View” 
on page 1118.

CAD Detail from View  does not truly 
convert objects in the current view into CAD 
objects; instead, it creates a copy of the 
original view composed of CAD objects 

instead of architectural objects, leaving the 
original view intact.

Convert Polyline
The Convert Polyline edit button lets 
you to turn CAD objects into CAD-

based architectural objects such as counter 
tops and stair landings, special polylines 
such as materials list polylines, and a variety 
of slab, hole and terrain objects.

To convert a CAD object into one of these 
3D objects, select the object and click the 

Convert Polyline  edit button to open the 
Convert Polyline dialog.

Convert Polyline Dialog

Click the radio button beside one of the 
objects in this dialog, then click OK. 

Countertop - Convert the selected closed 
polyline to a countertop. See “Custom 
Countertops” on page 679.

Slab - Convert the selected closed polyline to 
a slab. See “The Slab Tools” on page 462.

Slab with Footing - Convert the selected 
closed polyline to a slab with footing.  
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Landing - Convert the selected closed 
polyline to a landing. Only available when 
the closed polyline is not a spline. See 
“Landings” on page 543.

Walkthrough Path - Convert the selected 
polyline to a Walkthrough Path. See 
“Walkthroughs” on page 1158. 

Material Region - Convert the selected 
closed polyline to a Floor or Wall Material 
Region. See “Floor and Wall Material 
Regions” on page 799.

Materials List Polyline - Convert the 
selected closed polyline to a materials list 
polyline. See “Calculate From Area” on page 
1284.

Molding Polyline - Convert to a molding 
polyline. See “Molding Polylines” on page 
664.

3D Molding Polyline - Convert to a 3D 
molding polyline. See “3D Molding Polyline 
Tool” on page 665.

Hole in Roof/Custom Ceiling - Convert the 
selected closed polyline to a roof/ceiling 
hole. Only available when the polyline is 
contained inside a single roof plane or ceiling 
plane. See “Roof Hole/Skylight 
Specification Dialog” on page 519.

Hole in Ceiling Platform - Convert the 
selected closed polyline to a ceiling platform 
hole. Only available when the polyline is 
contained inside a single ceiling plane. See 
“Floor and Ceiling Platforms” on page 344.

Hole in Floor Platform - Convert the 
selected closed polyline to a floor platform 
hole. Only available when the polyline is 
contained inside a single floor platform. See 
“Floor and Ceiling Platforms” on page 344.

Polyline Solid - Convert the selected closed 
polyline to a polyline solid. See “Polyline 
Solids” on page 791. 

Revision Cloud - Convert the selected 
closed polyline to a revision cloud. See 
“Revision Clouds” on page 1104. 

Sprinkler Line - Convert to a sprinkler line. 
See “Sprinkler Tools” on page 774.

Terrain Perimeter - Convert to the terrain 
permeter. See “Terrain Perimeter” on page 
716. This option is only available when: 
• The polyline is closed
• A terrain perimeter does not yet exist 
• Only one polyline is currently selected

Elevation Line - Convert to an elevation 
line. See “Elevation Lines” on page 720. 
Only available when a terrain perimeter 
exists.

Terrain Break - Convert to a terrain Break. 
See “Terrain Breaks” on page 722. Only 
available when a terrain perimeter exists.

Terrain Feature - Convert to a terrain 
feature. See “Terrain Feature Tools” on page 
724. Only available when a terrain perimeter 
exists.

Road (Perimeter) - Convert the selected 
closed polyline to a road polyline where the 
polyline represents the perimeter of the road. 
See “Polyline Road” on page 757. Only 
available when a terrain perimeter exists.

Road (Center Line) - Convert to a road 
where the polyline represents the center line 
for the road. See “Straight Road” on page 
757. Only available when a terrain perimeter 
exists.
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Road Median - Convert the selected 
polyline to a road median. This is helpful for 
creating medians on curved roads. See 
“Median” on page 757. 

Road Marking (Perimeter) - Convert to a 
road marking where the polyline represents 
the perimeter of the road marking. See “Road 
Marking” on page 758. Only available when 
a terrain perimeter exists and the polyline is 
closed.

Road Stripe (Center Line) - Convert to a 
road stripe where the polyline represents the 
centerline of the road stripe. See “Road 
Marking” on page 758. Only available when 
a terrain perimeter exists.

Sidewalk (Perimeter) - Convert to a 
sidewalk polyline where the polyline 
represents the perimeter of the sidewalk. See 
“Polyline Sidewalk” on page 759. Only 
available when a terrain perimeter exists and 
the polyline is closed.

Sidewalk (Center Line) - Convert to a 
sidewalk where the polyline represents the 
center line of the sidewalk. See “Straight 
Sidewalk” on page 759. Only available when 
a terrain perimeter exists.

Click OK to convert the object or objects.

The specification dialog appropriate to the 
newly converted object opens, allowing you 
to specify its height, material and other 
information.

Convert to Plain Polyline
Click the Convert to Plain Polyline 
edit button to convert special 

polylines to plain polylines. 

After a special polyline is converted into a 
plain polyline, it can be converted into a 
special of the same or different type.

Convert to Solid
Click the Convert To Solid edit 
button to convert the selected object 

into a Primitive object, or solid, so that it can 
be used with other solids to create complex 
structures. See “Primitive Tools” on page 
778. 

Convert to Symbol
Create a 3D view of a custom object, 
then select Tools> Symbol> Convert 

to Symbol to convert the object into a 
symbol. See “Convert to Symbol” on page 
1206.

Convert to Spline
Click the Convert to Spline edit 
button to convert some CAD-based 

objects such as Custom Countertops or 
splines that have been converted to polylines 
to spline-based objects. See “Editing Spline 
Based Objects” on page 209. 

Unlike polylines, splines form smooth curves 
rather than angled corners where their 
direction changes. See “Splines” on page 
1106.

Convert Spline to Polyline
Click the Convert Spline to Polyline 
edit button to convert the selected 

spline-based object into a polyline. 
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A curved portion in a spline is represented as 
a number of smaller straight lines. You can 

change a spline into a normal polyline that is 
made up of these straight lines using this edit 
tool.

Transform/Replicate Object Dialog
Select any object or group of objects 
and click the Transform/Replicate 

Object edit button to open the Transform/
Replicate Object dialog.

If multiple options are selected in the 
Transform/Replicate Object dialog, they are 
performed in the order they appear in the 
dialog, from top to bottom.

 The spline is replaced by the new polyline

Always double-check values entered in
the Transform/Replicate Object dialog.

Large offset values, resize factors, or num-
bers of copies can result in objects that are
time-consuming to create or may be off the
screen. 
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Transform/Replicate Object Dialog

Check Copy, then specify the Number 
of Copies to make.

Check Move, then specify how far or 
where to move the object(s).

• Select Relative to Itself to move the 
object relative to its current position, then 
specify the X Delta, Y Delta and Z Delta 
values, which are the object’s changes in 
position along each axis. 

• Select Absolute Location to move the 
object to an absolute location. You can 
either specify its X and Y Position, or 
Angle and Distance, if Polar is checked.

• Select Relative to Current Point to 
move the object relative to the current 
CAD point. See “Point Tools” on page 
1076. You can either specify its X Delta 
and Y Delta, or Angle and Distance, if 
Polar is checked.

Rotate - Select this option, then specify 
the Angle to rotate the object(s). 

1

2

When a CAD-based object is moved to
a new floor, only its display in floor plan

view is moved - its physical locations in the
model remains unchanged. See “Architec-
tural vs CAD Objects” on page 160.

3
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• Select Absolute Angle to rotate the 
object relative to an imaginary horizontal 
line drawn in the positive X direction 
from the origin. See “3D Drafting” on 
page 31. 

• Select Relative Angle to rotate the object 
the specified angle relative to its current 
orientation.

You can also specify the point the selected 
object(s) rotate about, below. 

Select Resize, then specify the Resize 
Factor in decimals. A resize factor of 2 

doubles the size of the object, while a resize 
factor of 0.5 halves the object’s size. Not 
available for all objects, including line- and 
arc-based objects and Primitives. 

You can also specify the point the selected 
object(s) is resized about, below. 

Reflect - Select this option, then 
specify which axis to reflect about.

• Horizontally - Select this option to 
reflect the object horizontally.

• Vertically - Select this option to reflect 
the object vertically.

You can also specify the point the selected 
object(s) is reflected about, below. 

Rotate/Resize/Reflect About - This 
section is enabled when the Rotate, 

Resize and/or Reflect functions are selected.
• X Position - Specify the X coordinate of 

the point to perform the selected edit 
function(s) about when About Absolute 
Point is selected.

• Y Position - Specify the Y coordinate of 
the point to perform the selected edit 
function(s) about when About Absolute 
Point is selected.

• About Object Center - Select this option 
to perform the selected edit function(s) 
about the object’s center.

• About Absolute Point - Select this 
option to perform the selected edit func-
tion(s) about the specified point.

• About Current Point - Select this option 
to perform the selected edit function(s) 
about the current CAD point. 

Trim and Extend
The Extend Object(s) and Trim 
Object(s) edit tools allow you to 

lengthen or shorten a variety of CAD objects 
and framing members. See “Editing 
Framing” on page 607.

When either the Extend Object(s) or Trim 
Object(s) edit buttons are clicked, its edit 
mode is enabled and three new edit buttons 
display on the edit toolbar.

• Click the Sticky Mode  edit button to 
remain in the current mode and edit mul-
tiple objects or select multiple fences. 

• Click the Select Fence  edit button, 
then click an object to use it as a fence. 
See “Using a Fence” on page 186.

• Click the Main Edit Mode  edit but-
ton or press the Esc key to return to the 
selected objects’s main edit toolbar. 

4

5

6
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If you did not do a fence selection and 
then immediately click either Extend 
Object(s) or Trim Object(s) after return-
ing to the Main Edit Mode, Sticky 
Mode  is still enabled. 

Trim Objects
Lines, arcs, open polylines, circles and 
framing items can be trimmed. The 

trimming, or cutting, object may be any CAD 
object, a group of CAD objects, or even a 
CAD block. Select the trimming object(s) 
and click the Trim Object(s) edit button.

The Trim Object(s)  edit tool can be used 
in three different ways: 
• Individually clicking on objects to be 

trimmed. 
• Selecting objects to be trimmed using a 

fence. See “Using a Fence” on page 186.
• Selecting objects to be trimmed using a 

temporary fence.

To trim by clicking

1. Draw the cutting line(s) or polyline(s) 
through the objects to be trimmed.

2. Select the cutting line(s) and click the 

Trim Object(s)  edit button.

3. Click the Sticky Mode  edit button if 
you wish to click multiple objects to 
trim them.

4. Click each segment intersected by a cut-
ting line one-by-one to trim it back to 
the cutting line.

To trim using a fence

1. Draw the cutting line(s) or polyline(s) 
through the objects to be trimmed.

2. Draw a fence through the object seg-
ments to be trimmed. Be sure that the 
fence intersects the objects on the side of 
the cutting line(s) that you want to edit. 
See “Using a Fence” on page 186.

3. Select the cutting line(s) and click the 

Trim Object(s)  edit button.

4. Click the Sticky Mode  edit button if 
you wish to trim objects using multiple 
fences.

5. Click the Select Fence  edit button.
6. Click the fence(s) to trim the object seg-

ments intersected by the fence.

To trim using a temporary fence

1. Draw the cutting line(s) or polyline(s) 
through the objects to be trimmed.

2. Select the cutting line(s) and click the 

Trim Object(s)  edit button.

3. Click the Sticky Mode  edit button if 
you wish to trim objects using multiple 
temporary fences.

4. Click and drag a temporary line to act as 
a fence, trimming the object segments 
intersected by it. Be sure to draw this 
fence on the side of the cutting object(s) 
that you wish to edit.

Note: Trim Objects and Extend Objects can-
not be used to modify closed polyline-based
objects. See “Editing Closed-Polyline Based
Objects” on page 201.
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Extend Objects
Lines, arcs, open polylines, and 
framing items can also be extended to 

any CAD object, group of CAD objects, or a 
CAD block. 

As with Trim Objects , there are three 

ways to use Extend Objects : 
• Individually clicking on objects to be 

extended. 
• Selecting objects to be extended using a 

fence.
• Selecting objects to be extended using a 

temporary fence.

To extend by clicking

1. Draw the boundary line(s) or polyline(s)  
you want the objects to extend to.

2. Select the boundary line(s) and click the 

Extend Objects  edit button.

3. Click the Sticky Mode  edit button if 
you wish to extend multiple objects.

4. Click an object that you would like to 
extend to the boundary line(s). 

To extend using a fence

1. Draw the boundary line(s) or polyline(s)  
you want the objects to extend to. 

2. Draw a fence through the objects to be 
extended. See “Using a Fence” on page 
186.

3. Select the boundary line(s) and click the 

Extend Objects  edit button.

4. Click the Sticky Mode  edit button if 
you wish to extend objects using multi-
ple fences.

5. Click the Select Fence  edit button.
6. Click the fence to extend the objects 

segments intersected by the fence until 
they meet the boundary line(s).

To extend using a temporary fence

1. Draw the boundary line(s) or polyline(s)  
you want the objects to extend to. 

2. Select the boundary line(s) and click the 

Extend Objects  edit button.

3. Click the Sticky Mode  edit button if 
you wish to extend objects using multi-
ple temporary fences.

4. Click and drag a temporary line to act as 
a fence, trimming the object segments 
intersected by it.

Union, Intersection, and Subtract
New closed polyline-based 
objects and solids can be 

created based on existing closed polyline-
based objects of the same type or solid 

objects. The Polyline Union, Polyline 
Intersection and Polyline Subtract edit 
tools are provided for this purpose. 
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Polyline Union
Use the Polyline Union edit button to 
combine two or more closed polylines 

or solids into a single object.

The following example shows three closed 
polylines and the single closed polyline that 
results when the three are merged using the 
Polyline Union  edit button. 
 

There are two methods of combining closed 
polylines or solids using the Polyline 
Union  edit button: the single selection 
and group selection methods. 

Begin by creating two or more overlapping 
objects of the same type. If one object is a 
countertop, for example, the others should be 
countertops, as well. 

If the original objects do not overlap, they 
will either not produce a new object or will 
be duplicated on top of themselves.

To use the single selection method

1. Select a single closed polyline or solid 
object. 

2. Click the Polyline Union  edit 
button.

3. Click another closed polyline or solid.
4. If the object is a polyline, a message box 

will let you choose to either retain or 
delete the original objects.

5. A new polyline of the same type as the 
originals is created and is selected. Its 
shape is defined by the boundaries of the 
original objects. If the original objects 
were retained, it is superimposed over 
them and can be moved.

To use the group selection method

1. Group-select two or more closed poly-
lines or solid objects.

2. Click the Polyline Union  edit 
button.

3. If the object is a polyline, choose to 
retain or delete the original objects in the 
dialog that opens.

4. A new object of the same type as the 
originals is created, is selected, and is 
superimposed over the originals if they 
were retained.

This second method allows you to combine 
more than two polylines simultaneously. 

Note: The Union Intersection and Subtract
edit tools are not available for objects speci-
fied as holes, such as Slab Holes or Custom
Countertop Holes. 

Note: If the original objects do not overlap,
the Union edit tool duplicates them and then
either deletes or retains the originals.
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Intersection
Use the Polyline Intersection edit 
button to create a single polyline 

based on the overlap area of two or more 
closed polyline-based objects or solids.

The following example shows two closed 
polylines and the single closed polyline that 

results when the Polyline Intersection  
edit button is used. 
 

There are two methods of combining closed 
polylines or solids using the Polyline Inter-
section  edit button: the single selection 
and group selection methods. The second 
method allows you to work with more than 
two objects simultaneously. 

Begin by creating two or more overlapping 
objects of the same type. If one object is a 
countertop, for example, the others should be 
countertops, as well.

If the original objects do not intersect, no 
new object is created.

To use the single selection method

1. Select a single closed polyline or solid 
object. 

2. Click the Polyline Intersection  edit 
button.

3. Click another closed polyline or solid.
4. If the object is a polyline, choose to 

retain or delete the original objects in the 
dialog that opens.

5. A new object of the same type as the 
originals is created and is selected. Its 
shape is defined by the area shared by 
the original objects and, if the originals 
were retained, it is superimposed over 
them and can be moved.

To use the group selection method

1. Group select two or more closed poly-
lines or solid objects. 

2. Click the Polyline Intersection  edit 
button.

3. If the object is a polyline, choose to 
retain or delete the original objects in the 
dialog that opens.

4. A new object of the same type as the 
originals is created, is selected, and is 
superimposed over the originals if they 
were retained. 

Subtract
Use the Polyline Subtract edit button 
to subtract the area of one object that 

overlaps another object of the same type to 
create a third, new object. 
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There is one method for using the Polyline 
Subtract  edit button.

To use the Subtract edit tool

1. Draw two or more closed polyline-based 
objects or solids that overlap. One object 
can be completely enclosed by another.

2. Select one or more of these objects that 
you want to remove a portion from as 
defined by the area shared in common 
with the remaining, unselected object. 

3. Click the Polyline Subtract  edit 
button and then click the unselected 
object.

4. If the object is a polyline, choose to 
retain or delete the original objects in the 
dialog that opens.

5. A new object of the same type as the 
originals is created, is selected, and is 
superimposed over the originals if they 
were retained.

Matching Properties
The Object Eyedropper tool and Match 
Properties and Apply Properties edit tools 
allow you to select attributes from one object 
and apply them to other, similar objects. 

These tools cannot be used to modify objects 
on locked layers or layers that are not set to 
display. They can be used to apply attributes 
to automatically generated objects such as 
roof planes and framing; however, the 
associated Auto Rebuild function will be 
turned off. See “Auto Rebuild” on page 169. 

Object Eyedropper
The Object Eyedropper tool allows 
you to apply selected attributes of one 

object to other, similar objects. 

To use the Object Eyedropper

1. Begin by selecting the Object Painter 
Mode that you want to use. Select 
Tools> Object Painter, then: 

•  Select Object Painter Object 
Mode  to apply attributes to indi-
vidual objects, one at a time.

•  Select Object Painter Room 
Mode  to apply attributes to an indi-

Originals

This polyline 
selected first

This polyline 
selected first

Note: If the original objects do not overlap, the
Subtract edit tool duplicates the first object
selected and then either deletes or retains it.
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vidual object as well as all objects in 
the same room that are identical to it 
with a single click.

•  Select Object Painter Floor Mode  
to apply attributes to an individual 
object as well as all objects on the same 
floor that are identical to it with a sin-
gle click.

•  Select Object Painter Plan Mode  
to apply attributes to an individual 
object as well as all objects in the entire 
plan that are identical to it with a single 
click.

2. Select Tools> Object Painter> Object 
Eyedropper , and notice that your 
mouse pointer displays an eyedropper 

 icon. 
3. Move your mouse pointer over an object 

in the current view. If it becomes high-
lighted and “Object to pick” information 
is stated on the left side of the Status 
Bar, click once to load the object’s attri-
butes so they can be applied to other, 
similar objects.

4. Click the Select Properties to Load  
edit button.

5. In the Select Properties to Load dialog, 
check the box beside attributes that you 
want to apply to other similar objects 
and click OK. The set of attributes 
available varies depending on the type 
of object selected. 

6. Notice that your mouse pointer now dis-

plays a spray can  icon. 
7. Move your mouse pointer over an object 

that is similar to the one selected in step 
1: if it becomes highlighted and “Load 

Properties to” information is stated in 
the Status Bar, the object is eligible to 
receive the loaded attributes.

8. Click on an eligible object to apply the 
specified attributes to it as well as any 
other identical objects, depending on 
which Object Painter Mode is active.

9. Continue clicking to apply attributes 
until the Esc key is pressed or another 
tool is activated.

Match Properties
The Match Properties edit tool 
allows you to quickly select all objects 

on the current floor of your plan that share 
the same set of specified attributes as the 
selected object. 

Apply Properties
The Apply Properties edit button can 
be used to apply the selected attributes 

to any other objects on the current floor that 
do not yet share them. 

Apply Properties  becomes available 

only after the Match Properties  edit tool 
has been used to select a group of objects 
sharing the same attributes. 

To use Match Properties/Apply Properties

1. Select an object with attributes that you 
would like to apply to other like objects 
on the current floor.

2. Click the Match Properties  edit 
button.

3. In the Match Properties dialog, check 
the box beside each attribute that you 
want to apply to other similar objects 
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and click OK. The available attributes 
vary, depending on the type of object 
selected. 

4. All objects sharing all of the specified 
attributes are now selected in the draw-
ing area. 

5. Click the Apply Properties  edit but-
ton, then click any like object that is not 
currently highlighted to apply the speci-
fied attributes to it and add it to the 
selection set. 

6. You can continue selecting/loading 
objects until the Esc key is pressed or 
another tool is activated.

Match Properties Dialog
To open the Match Properties dialog, select 
an object and click the Match 
Properties  edit button.

The Select Properties to Load dialog has 
the same settings as the Match Properties 
dialog but is accessed by selecting Tools> 
Object Eyedropper . 

Filter the attributes that display in the 
list below by typing in the Search field. 

• When all or part of a keyword is typed in 
the Search field, this list is divided into 

two categories: Found Properties which 
match your Search criteria followed by 
the remaining Other Properties. 

1
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• Click the Clear  button on the right 
side of the Search field to remove any-
thing typed in this field. 

A list of the selected object’s Properties 
and the associated Values displays here.

• Check the box beside a Property to apply 
its Value to similar objects. In the Match 
Properties dialog, checking boxes also 
allows you to select objects that share the 
same attributes when you click OK.

• Click the Select Found button to select 
all items shown in the search results. Not 
available when the Search field is empty.

• Click the Clear Found button to deselect 
all items shown in the search results. Not 
available when the Search field is empty.

• Click the Select All button to select all 
Properties, regardless of whether they are 
shown in the list or not. 

• Click the Clear All button to deselect all 
Properties, regardless of whether they are 
shown in the list or not.

• Line items can also be group-selected and 
then checked or unchecked together. See 
“Shift and Ctrl Select” on page 186.

A few Properties can only be used for 
selecting objects and cannot be loaded from 
one object to another. These Properties 
display in the Match Properties dialog 
followed by an asterisk but do not display in 
the Select Properties to Load dialog at all.

Edit Area Tools
The Edit Area Tools allow you to 
quickly define an area of your plan 

and select the objects in that area. Once 
selected, they can then be repositioned, 
copied or deleted. Select Edit> Edit Area to 
access the Edit Area Tools.

Unlike other selection methods, the Edit 
Area Tools  cut walls, railing and fencing 
where the selection marquee intersects them, 
allowing you to edit only the selected portion 
of these objects. 

Some objects, such as cabinets, are included 
in the selection only if more than half of the 
object is contained within the marquee.  

A few objects, notably CAD points, are not 

affected by the Edit Area Tools .

Edit Area
Select Edit> Edit Area> Edit Area 
and draw a rectangular marquee 

around the area of the plan to be edited. 

Edit Area  affects all objects included in 
the selection marquee that are located on the 
current floor, regardless of whether they are 
displaying in floor plan view or not.

Edit Area Visible
Select Edit> Edit Area> Edit Area 
Visible and draw a marquee around 

the area of the plan to be edited. 

2

The Edit Area tools can cause wide-
spread changes across an entire plan

and should always be used with caution.
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Edit Area Visible  only affects visible 
objects included in the selection marquee: 
objects not currently displayed in floor plan 
view are unaffected.

Edit Area (All Floors)
Select Edit> Edit Area> Edit Area 
(All Floors) and draw a marquee 

around the area of the plan to be edited. 

Edit Area (All Floors)  affects all objects 
on all floors of the plan that are included in 
the selection marquee, regardless of whether 
they display in floor plan view. 

Edit Area (All Floors) Visible
Select Edit> Edit Area> Edit Area 
(All Floors) Visible and draw a 

marquee around the area of the plan to be 
edited. 

Edit Area (All Floors) Visible  affects all 
visible objects on all floors of the plan that 
are included in the selection marquee. 
Objects not currently displaying in floor plan 
view are not affected.

Edit Area Polyline
If a rectangular marquee’s shape does not 
allow you to define an area precisely, use a 
closed polyline instead. 

Select a polyline that defines the desired area 
in floor plan view and then select one of the 

Edit Area Tools . The polyline becomes 
temporarily highlighted and acts as an Edit 
Area marquee. 

Using the Edit Handles
An Edit Area marquee displays edit handles 
that are similar to those of a closed polyline. 
See “Using the Edit Handles” on page 202.
• Click the Move edit handle to move the 

entire selection set. See “Moving 
Objects” on page 220.

• Click the Rotate edit handle to rotate the 
entire selection set. See “Rotating 
Objects” on page 234.

• Click and drag the Reshape and Resize 
edit handles at each corner and along 
each edge to adjust the size and shape of 
the marquee. See “Using the Edit Han-
dles” on page 202.

Adjusting the size or shape of an Edit Area 
marquee may change which objects are 
included in the selection set but does not 
otherwise affect those objects.

Using the Edit Toolbar
A selected Edit Area marquee and/or the 
objects within it can be edited in a variety of 
ways using the buttons on the edit toolbar.  
See “Using the Edit Toolbar” on page 203. 

The following toolbar buttons may display 
on the edit toolbar for an Edit Area marquee:

• Click the Copy/Paste  edit button to 
copy the selection set to the system clip-
board so it can be pasted elsewhere. See 
“Copying and Pasting Objects” on page 
170.

• Click the Delete  edit button to delete 
the selection set. See “Deleting Objects” 
on page 255.
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• Click the Transform/Replicate Object 
 edit button to copy, move, rotate, 

resize, or reflect the selection set. See 
“Transform/Replicate Object Dialog” on 
page 242.

• Click the Multiple Copy  edit button 
to make a series of copies of the selection 
set at regular intervals. Concentric copies 
are not possible using the Edit Area tools. 
See “Multiple Copy” on page 173.

• Click the Make Parallel/Perpendicular 
 edit button to rotate the Edit Area 

marquee and the selection set so that the 
selected marquee edge is parallel or per-
pendicular to another straight edge. See 
“Using Make Parallel/Perpendicular” on 
page 227. 

• Click the Point to Point Move  edit 
button to accurately move the selection 
set. See “Point to Point Move” on page 
222. 

• Click the Center Object  edit button 
to center the selection along along a wall 
within a room or relative to a cabinet 
fixture. See “Using Center Object” on 
page 227.

• Click the Reflect About Object  edit 
button to reflect the selection set about 
another object. See “Reflecting Objects” 
on page 237. 

• Click the Allowed Angles  edit button 
to open the Place at Allowed Angles 
dialog. 

Place at Allowed 
Angles Dialog

If more than one percent of the 
straight walls included in an Edit Area 

marquee are not at an Allowed Angle, the 
Allowed Angles edit button displays. 

Click the Allowed Angles  edit button to 
display the Place at Allowed Angles dialog.

Select the first option and click OK to rotate 
the plan so that the largest group of off-angle 
walls move to an Allowed Angle. This may 
place this largest group at Allowed Angles, 
but has two disadvantages. 
• First, other groups of off angle walls  

remain off angle. 
• Second, any walls that were at an allowed 

angle before this action will move to an 
off angle. The dialog shows how much 
(weighted by length) of the selected walls 
are in each category. 

Select the second option and click OK to add 
new entries to the Allowed Angles list and 
allow new walls to be placed at these angles. 
Walls already at Allowed Angles remain so. 
See “Angle Snaps” on page 164.
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Select the third option and click OK to do 
nothing, which is the same as clicking 
Cancel.
You may want to rotate the majority of the 
walls to one of the normal allowed angles. 

Then, use an Edit Area  tool to select 
everything again and select the second option 
to provide new angle entries to cover the 
remaining walls. 

Deleting Objects
Objects can be deleted in a variety of ways: 
• Select an object or group of objects, then 

click the Delete  edit button, select 

Edit> Delete  from the menu, or press 
the either the Delete or Backspace key on 
your keyboard. 

• Entire categories of objects can be 
deleted using the Delete Objects dialog.

• Objects are deleted if the floor they are 
placed on is deleted. See “Deleting 
Floors” on page 441.

If an object has a line with arrow or text 
leader attached to it, the arrow or leader is 
deleted if the object is deleted. To prevent the 
arrow from being deleted, drag the attached 
end away from the object before deleting it. 

A variety of objects in the program can be 
generated automatically, including roofs, the 
foundation, and framing. Automatically 
generated objects cannot be deleted unless 
the automatic creation option is disabled. 

Delete Objects Dialog
In floor plan view, use the Delete 
Objects dialog to delete all objects of 

one or more specified types in one room, on 
the current floor, or on all floors in the plan. 
Note that the Delete Objects dialog does not 
delete CAD objects or schedules drawn in 

cross section/elevation views  or CAD 
Details.

Although objects on locked layers can-
not be selected, most can nevertheless

be deleted using the Delete Objects dialog. 
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Select a Delete Scope: 
•Choose Single Room to delete objects 

only in rooms on the current floor that 
you specify. 

• Choose All Rooms on This Floor to 
delete objects in all rooms on the current 
floor.

• Choose All Floors to delete objects on all 
floors in the plan.

Specify categories of Objects to Delete 
by checking the box beside each 

category that you wish to delete.

• Check the box beside any heading to 
select all of the categories within it; clear 
the box beside a heading to deselect all of 
its categories.

• Click the Select All button to check the 
boxes beside all of the categories.

• Click the Clear All button to uncheck the 
boxes beside all of the categories.

To use the Delete Objects dialog

1. Select Edit> Delete Objects  to open 
the Delete Objects dialog.

1

2
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2. Specify the Delete Scope as Single 
Room, All Rooms On This Floor, or 
All Floors. 

3. Check the box for each category of 
objects you want to delete. Click Select 
All to check all the boxes or Clear All to 
uncheck all boxes.

•  If “Roof Planes” cannot be selected, 
they may be locked. See “Editing Roof 
and Ceiling Planes” on page 492.

4. When the scope is set to Single Room:
•  Move your cursor into the drawing area 

and click in a room of the plan to delete 
objects of the selected type within that 
room without closing the dialog. 

•  Only objects with their center point 
located in the room are deleted. 

•  Continue clicking on rooms or choose a 
different Delete Scope.

•  Click Done when all selections have 
been deleted. 

5. If you select All Rooms On This Floor 
or All Floors, you do not need to click in 
floor plan view. The Delete button 
becomes available, and clicking it closes 
the dialog and deletes the specified 
objects. 

Objects such as roofs, framing, or Auto 
Exterior Dimensions that are set to 
automatically rebuild or refresh cannot be 
deleted while that behavior is enabled. If 

objects of this sort are selected for deletion, 
the program will ask whether you want to 
turn off the automatic redraw behavior. 

Deleting Polyline Edges
There are number of different ways to delete 
individual edges of polyline-based objects:

• Select Connect CAD Segments . 
Select the edge and delete. See 
“Disconnect Edges” on page 184.

• Drag a corner handle until it overlaps an 
adjacent corner handle to remove the 
edge between them and merge them into 
a single handle.

• Create a complete break at both ends. 
Select the edge and delete. See “To create 
a complete break” on page 231.

• The Fillet Lines  and Chamfer 
Lines  tools can be used to delete 
polyline edges. See “Reshaping Objects” 
on page 230.

Delete Surface
In any 3D view, select 3D> Delete 
Surface, then click a surface in the 

view to temporarily remove the surface from 
the current view without permanently 
affecting the object. See “Delete 3D Surface” 
on page 910.

Undo and Redo
The Undo and Redo commands 
allow you to both undo the last 

action performed, as well as redo actions that 
were recently Undone. 

The ten most recent actions can be Undone 
or Redone, depending on your settings in the 
Preferences dialog. See “General Panel” on 
page 98. Actions that can be Undone and 
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Redone include creating, editing, and 
deleting objects. 

To Undo an action, select Edit> Undo , 

click the Undo  button, or press Ctrl + Z 
on your keyboard.

The Redo command is only available 
immediately after Undo has been used. To 
Redo an Undone action, select Edit> 
Redo , click the Redo  button or press 
Ctrl + Y on your keyboard. 

It is important to note that Undo  and 

Redo  do not affect all actions in the 
program, including:

• Save and Save As. See “Saving, Export-
ing, and Backing Up Files” on page 55. 

• Changes made in the Library Browser. 
See “The Library Browser” on page 820. 

• Changes made in a Materials List. See 
“Materials Lists” on page 1283. 

• Changes made in a dialog while the dia-
log box is open. See “Dialogs” on page 
39.

• Changes made to the display by panning 
the display or zooming in or out. See 
“Undo Zoom” on page 881.

• Changes made to the position of a cam-
era, or its Rendering Technique. See 
“Editing 3D Views” on page 916.
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Chapter 8:

Walls, Railings, and
Fencing

Walls are the single most important building 
component in Chief Architect. By creating 
walls and defining the rooms created by the 
walls, you are telling the program how you 
want the 3D model built.

There are several ways that walls can be 
created in Chief Architect. The most 
common is to simply draw them with the 
Wall Tools. 

In addition, exterior walls can be generated 
automatically when a new floor is built by 
using another floor as a model. For more, see 
“Adding Floors” on page 437.

2D CAD lines can also be converted into 
actual walls using the CAD to Walls tool.

Another feature that can be used to generate 
walls automatically is the Space Planning 
Assistant. See “Space Planning” on page 
1127.

Chapter Contents
•      Wall, Railing, and Fencing Defaults
•      Wall Tools
•      Railing and Deck Tools
•      Fencing Tools
•      Exterior and Interior Walls
•      Foundation Walls
•      Pony Walls
•      Railing and Deck Tools
•      Room Dividers and Invisible Walls
•      Polygon Shaped Rooms and Decks
•      Hatch Wall
•      Break Wall
•      Drawing Walls
•      Connecting Walls
•      Displaying Walls
•      Measuring Walls
•      Editing Walls
•      Edit Handles for Walls
•      Editing Straight/Curved Wall Combinations
•      Aligning Walls
•      Roof Directives in Walls
•      Attic Walls
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•      Stepped and Raked Walls
•      Double Walls
•      CAD to Walls
•      Wall Type Definitions
•      Wall Type Definitions Dialog

•      Exporting and Importing Wall Types
•      Wall Specification Dialog
•      Railing and Fencing Specification Dialogs
•      Wall Hatch Specification Dialog

Wall, Railing, and Fencing Defaults
There are several defaults dialogs for 
walls. Default Settings can be 

accessed by selecting Edit> Default 
Settings. Click the + next to “Walls” to 
display the walls sub-headings. Select a 
subheading and click the Edit button to open 
the Wall Defaults dialog associated with 
your selection: 

The defaults dialog for each wall tool can 
also be accessed by double-clicking the 
tool’s toolbar button. 

The settings in the various wall defaults 
dialogs determine what wall types are drawn 
when the different wall tools are used. It is a 
good idea to be familiar with these settings 
and how they relate to your style of building. 
See “Wall Type Definitions” on page 302.

Set as Default
You can set the attributes for a 
selected wall in your plan as a default 

wall type by clicking the Set as Default edit 
button..See “Set as Default” on page 76.

Which Wall Defaults gets updated depends 
on the attributes of the selected wall. If the 
selected wall is specified as: 

• A Foundation wall, its attributes will 
become the Foundation Wall Defaults.

• A Slab Footing, its attributes will become 
the Slab Footing Defaults.

• A Railing or Deck Railing that is not 
specified as Solid or set to Follow Ter-
rain, its attributes will become the Rail-
ing or Deck Railing Defaults.

• A Solid Railing or Deck Railing, its attri-
butes will become the Half Wall Defaults.

• A Railing or Deck Railing set to Follow 
Terrain, its attributes will become the 
Fencing Defaults.

• A wall specified as Invisible, its attributes 
will become the Room Divider Defaults.

If a wall does not have a setting listed above 
and defines:
• Only interior rooms, its attributes will 

become the Interior Wall Defaults.
• An exterior room or forms part of the 

structure’s exterior, its attributes will 
become the Exterior Wall Defaults. 

The Set as Default  edit tool is not 
available for Pony Walls. 

General Wall Defaults
The General Wall Defaults dialog 
controls the general behavior and 

display attributes of all walls, railings and 
fencing. 
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For quick access, the General Wall 
Defaults  button can be added to the 
toolbar or you can press Alt+Q on your 
keyboard. 

Resize About - These radio buttons 
determine what part of a wall retains its 

position when its wall type or wall type 
definition is changed. See “Resize About” on 
page 292.

The Resize About location is also where any 
snap points will be located along a wall as it 
is drawn or connected to other walls, and is 
where a wall’s length is measured. 
• Outer Surface - Snap to and resize about 

the exterior surface. When a wall is 
resized, its exterior surface does not 
move.

• Main Layer Outside - Snap to and resize 
about the outer line of the Main Layer. 
When a wall is resized, the outer line of 
its Main Layer does not move. When mul-
tiple Main Layers are specified, the outer 
line of the outermost Main Layer is used.

• Wall Center - Snap to and resize about 
the center line. When a wall is resized, its 
center line does not move, but wall layers 
on either side may.

• Main Layer Inside - Snap to and resize 
about the inner line of the Main Layer. 
When a wall is resized, the inner line of 
its Main Layer does not move. When mul-
tiple Main Layers are specified, the inner 
line of the innermost Main Layer is used.

• Inside Surface - Snap to and resize about 
the interior surface. When a wall is 
resized, its interior surface does not move.

Check Show Wall Length When 
Editing to display a temporary length 

dimension when a wall is drawn or edited. 
Wall length only displays when Temporary 
Dimensions  are on. See “Temporary 
Dimensions” on page 1008. 

The Automatic Walls  options control 
the automatic creation of Attic Walls 

and Room Dividers. 
• Uncheck Auto Rebuild Attic Walls to 

prevent Attic walls from automatically 
generating when the model changes. 
When checked, Attic Walls are automati-
cally generated. See “Attic Walls” on 
page 297.

• Uncheck Connect Island Rooms to pre-
vent Room Dividers from automatically 
connecting “island” rooms to the larger 
structure around them. When checked, 
Room Dividers are generated to prevent 

1

Note: In most circumstances, it is recom-
mended that you Resize About the Main
Layer Outside to avoid unexpected results. 

2

3
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room definition problems. See “Room 
Definition” on page 331. 

Exterior and Interior Wall Defaults Dialogs
Specify the initial attributes of walls drawn 

using the Exterior  and Interior Wall 
 tools in the Exterior and Interior Wall 

Defaults dialogs. See “Wall Tools” on page 
264.

The panels in this dialog are the same as their 
respective panels in the Wall Specification 
dialog. See “Wall Specification Dialog” on 
page 308. 

Foundation Wall Defaults
Specify which wall types is drawn when the 

Foundation Wall  tool is used either 
manually or when a stem wall or pier 
foundation is generated in the Foundation 
Wall Defaults dialog. See “Foundation 
Walls” on page 269.

The Foundation Wall Defaults dialog also 
controls the wall type drawn by the 

Retaining Wall  tool. Unlike other walls, 

Retaining Walls  are used to modify your 

terrain rather than build a structure. See 
“Terrain Wall and Curb Tools” on page 727.

Footing size and other information used 
when building stem wall or pier foundations 
is also specified here. For more information, 
see “Foundation Defaults” on page 448.

The panels in this dialog are the same as their 
respective panels in the Wall Specification 
dialog. See “Wall Specification Dialog” on 
page 308.

Slab Footing Defaults
Specify which wall type is drawn when the 

Slab Footing  tool is used either 
manually or when a foundation is generated 
in the Slab Footing Defaults dialog. See 
“Foundation Walls” on page 269.

Footing size and other information used 
when building a monolithic slab foundation 

is also specified here. See “Foundation 
Defaults” on page 448.

The panels in this dialog are the same as their 
respective panels in the Wall Specification 
dialog. See “Wall Specification Dialog” on 
page 308.

Pony Wall Defaults
Specify the wall types used for the upper and 

lower portions of Pony Walls  and other 
data associated with pony walls in the Pony 

Wall Defaults dialog. See “Pony Walls” on 
page 272.
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Upper Wall - From the drop-down list, 
select the default wall type for the 

upper portion of pony walls.
• Click the Define button to open the Wall 

Type Definitions dialog, where you can 
create and modify wall types. See “Wall 
Type Definitions Dialog” on page 305.

Lower Wall - From the drop-down list, 
select the default wall type for the 

lower portion of pony walls.
• Height of Lower Wall - Specify the 

default height of the lower portion of 
pony walls. 

• Click the Define button to open the Wall 
Type Definitions dialog.

Align Pony Wall - Specify the default 
option for aligning the layers of the 

upper and lower pony walls.  See “Wall 
Types Panel” on page 319.

Display In Plan View - Specify how 
pony walls appear in floor plan view.

• Select Show Upper Wall to display this 
wall type in floor plan view instead of the 
lower wall type. 

• Select Show Lower Wall to display this 
wall type in floor plan view instead of the 
upper wall type. 

• Check Hide Openings in Non-Displayed 
Parts of Walls to hide any doors and win-
dows located in the parts of pony walls 

1

2

3

4
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that are not visible. When unchecked, 
these openings will display along with 

those located in the visible parts of pony 
walls. 

Railing and Deck Railing Defaults
Specify the types of railings created when the 
Railing and Deck Railing tools are used. See 
“Railing and Deck Tools” on page 266.

The panels in these dialogs are the same as 
their respective panels in the Wall 
Specification dialog. See “Wall 
Specification Dialog” on page 308.

Half-Wall Defaults
Specify the attributes of a solid railing drawn 

using either Half Wall  tool. 

The panels in this dialog are the same as their 
respective panels in the Wall Specification 
dialog. See “Wall Specification Dialog” on 
page 308.

Fencing Defaults
Specify the attributes of fencing drawn using 

either of the Fencing Tools . 

The panels in this dialog are the same as their 
respective panels in the Wall Specification 
dialog. See “Wall Specification Dialog” on 
page 308.

Room Divider Defaults
Specify what type of wall is drawn when 

using the Room Divider  tool. See 
“Room Dividers and Invisible Walls” on 
page 273.

The panels in this dialog are the same as their 
respective panels in the Wall Specification 
dialog. See “Wall Specification Dialog” on 
page 308.

Wall Tools
Select Build> Wall  to access the Wall 
Tools. The type of wall drawn by each 

wall tool is specified in its corresponding 
defaults dialog. 

The Curved Wall tools are similar to 
their corresponding Straight Wall 

Tools. Select Build> Curved Wall  to access 
these tools. 

Note: By default, Railiings and Deck Railngs
are drawn using two separate wall types:
“Interior Railing” and “Deck Railing/Fence”.
See “Wall Type Definitions” on page 302.
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Exterior Walls
The Exterior Wall and Curved 
Exterior Wall tools draw walls 

using the default wall type specified for 
exterior walls in the Exterior/Interior Wall 
Defaults dialog. See “Exterior and Interior 
Walls” on page 269.

Interior Walls
The Interior Wall and Curved 
Interior Wall tools draw walls 

using the wall type specified for interior 
walls. The interior wall type is defined in the 
Exterior/Interior Wall Defaults Defaults 
dialog. 

Foundation Walls
The Foundation Wall and 
Curved Foundation Wall tools 

draw foundation walls according to the 
information specified in the Foundation 
Defaults dialog. Foundation walls normally 
have a footing and can be drawn on any floor 
of the model, not just the foundation floor. 
See “Foundation Walls” on page 269.

The Slab Footing tool draws a single-
layer concrete wall the same width as 

that specified for footings in the Foundation 
Defaults dialog. Rooms defined entirely by 
Slab Footings will have a Ceiling Height of 0 
and a Monolithic Slab Foundation specified. 
See “Foundation Defaults” on page 448.

Pony Walls
A Pony Wall, also called a split 
wall, is defined as a wall with 

two separate wall types, one for the upper 
portion and another for the lower portion.

The Pony Wall and Curved Pony Wall tools 
draw pony walls using the information 
specified in the Pony Wall Defaults dialog. 
You can also convert a normal wall into a 
pony wall and vice versa in the Wall 
Specification dialog. See “Pony Walls” on 
page 272.

Half-Walls
The Half-Wall and Curved 
Half-Wall tools create solid 

railings: walls that are 36” (900 mm) high 
topped with a handrail. The height and other 
attributes of solid railings drawn with this 
tool are defined in Half-Wall Defaults dialog. 
See “Half-Wall Defaults” on page 264. 

Room Dividers
Room Dividers are Invisible walls 
with a thickness of 0” (mm) that are 
used to define separate room areas in a 

plan. They can display in floor plan view but 
not in 3D views. See “Room Dividers and 
Invisible Walls” on page 273.

Polygon Shaped Room
The Polygon Shaped Room tool 
opens the New Polygon Shaped 

Room dialog, where you can specify the 
exact size and number of sides of a new 
polygonal room and then click in floor plan 
view to create that room. See “Polygon 
Shaped Rooms and Decks” on page 274.

Note: Whether a wall is recognized as an
exterior or interior wall by the program is
determined by its position in the model, not
by the tool used to draw it. See “Exterior and
Interior Walls” on page 269.
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Hatch Wall
The Hatch Wall tool applies a hatch 
pattern to a wall that displays in floor 

plan views. You must click the wall that you 
want to apply the hatch pattern to. You can 
then select the hatch and resize it if you want 
to only hatch a portion of a wall. See “Hatch 
Wall” on page 275.

Break Wall
The Break Wall tool applies a break 
in a wall. Once a wall is broken, the 

two wall segments are separate walls that can 
be modified independent of each other. See 
“Break Wall” on page 276.

Fix Wall Connections
The Fix Wall Connections tool 
connects walls whose ends are within 

a few inches of each other but are not 
connected. See “Fix Wall Connections” on 
page 280.

Define Wall Types
The Define Wall Types tool opens the 
Wall Type Definitions dialog, where 

wall types can be created, copied and edited. 
See “Wall Type Definitions Dialog” on page 
305.

Library Walls
You can also add a wall to the library, 
and then draw a new wall in any plan 

using its wall type and specifications by 
simply selecting it and then clicking and 
dragging in the drawing area. See “Adding 
Library Content” on page 829. 

When a new wall is drawn, it inherits the 
wall type of the library wall. If a wall type of 
that name already exists in the plan and the 
two are not identical, a new wall type will be 
created in that plan, and its name appended 
with “_2”. See “Wall Type Definitions” on 
page 302.

Layered Material Polylines
Select Build> Wall> Layered 
Material Polyline to draw a Layered 

Material Polyline. See “Floor and Wall 
Material Regions” on page 799.

Railing and Deck Tools
Select Build> Railing and Deck to 
access the Railing and Deck Tools. 

Railings are typically used to define interior 
spaces, while the various Deck tools are used 
to define exterior Deck rooms. 

With the exception of the Polygon Shaped 
Deck tool, each of the tools in this family 
have both Straight and Curved versions, and 

are created and edited just like walls. See 
“Drawing Walls” on page 276.

To create a break in a railing for a stairway or 

other access, use a Doorway  . This keeps 
the railing continuous and maintains room 
definition. See “Room Definition” on page 
331.  
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When first drawn, railings are specified as 
No Locate, which prevents Auto Exterior 
Dimensions  from locating them. This 
attribute may also be helpful if you do not 
want a railing to divide an area into two 
separate rooms. See “General Panel” on page 
309.

The attributes for railings when they are first 
drawn are defined in the Railing Defaults 
dialog. See “Railing and Deck Railing 
Defaults” on page 264.

Railings
The Railing and Curved Railing 
tools create railings that are 

primarily used to define interior spaces. The 
style and height of railings drawn with this 
tool are defined in Railing Defaults dialog. 
See “Railing and Deck Railing Defaults” on 
page 264.

Railings are ideal for a number of tasks:
• Creating changes in floor and/or ceiling 

height. See “Floor and Ceiling Heights” 
on page 342.

• Creating stairwells. See “Creating a Stair-
well” on page 556.

Deck Railing
The Straight Deck Railing and 
Curved Deck Railing tools draw 

decks, complete with framing and bounded 
by a railing. If a foundation level exists, 
supports for the deck are also created. See 
“Decks” on page 340.

When a room is defined using deck railing, 
its Room Type is automatically set to 
“Deck”. See “Decks” on page 340.

Deck Edges
The Straight Deck Edge and 
Curved Deck Edge draw decks 

complete with framing, but without a railing. 
No deck supports are created. 

Polygon Shaped Deck
The Polygon Shaped Deck tool opens 
the New Polygon Shaped Deck 

dialog, where you can specify the exact size 
and number of sides of a new polygonal deck 
room and then click in floor plan view to 
create that deck room. See “Polygon Shaped 
Rooms and Decks” on page 274.

Deck Railings

Deck Edges
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Railing Types
A variety of railing types can be specified in 
the Railing and Deck Railing Specification 
dialogs. See “Rail Style Panel” on page 323. 
Available types include:
• Baluster creates railings composed of 

newel posts, balusters, a railing, and an 
optional bottom rail. 

• Solid produces a framed railing wall, or 
Half Wall. See “Half-Walls” on page 265. 

• If Panels is selected, you can choose a 
panel style such as cable, glass, or iron-
work from the library. See “Newels/Bal-
usters Panel” on page 325.

By default, newels and balusters do not 
display in floor plan view, but their display 
can be turned on. See “Newels/Balusters 
Panel” on page 325.

Wall Types and Railings
Just like regular walls, railings are assigned a 
wall type: “Interior Railing”. This wall type 
has three layers: a framing layer in the 
middle and a layer of drywall on each side. 
See “Wall Type Definitions” on page 302. 

You can use a different wall type definition 
for railings if you wish, but bear in mind that 

this wall type definition determines several 
important things: 
• The railing’s appearance in floor plan 

view. See “Displaying Walls” on page 
281. 

• The actual thickness of Solid railings in 
3D views. 

• The extent of the floor platform, if a plat-
form edge is defined by the railing. is 
defined by the outer surface of the wall 
type. See “Floor and Ceiling Platforms” 
on page 344. 

• If the railing is used to create a change in 
floor height, this wall type controls the 
structure and position of the partial wall 
built beneath the railing, if one is 
required. See “Floor and Ceiling Heights” 
on page 342. 

If the railing is a type other than Solid, its 
sizing is specified on the NEWELS/BALUS-
TERS panel of the Railing Specification 
dialog, and the railing is centered along the 
width of the wall type. This will not be 
evident in floor plan view unless newels and 
balusters are set to display. 

Deck Railing is also assigned a wall type: 
“Deck Railing/Fencing”. This wall type has a 
single framing layer and is recommended for 
use only with deck railing and fencing. 

Fencing Tools
Select Build> Fencing or click the 
Fencing Tools to access the fencing 

tools. Fencing automatically follows the 
shape of the terrain. You can choose to have 
the fencing follow the terrain smoothly or to 
have each segment step as it follows the 
terrain. See “Rail Style Panel” on page 323.

The Fencing and Curved 
Fencing tools are used to draw 

fences, which are similar to railings but by 
default do not define room areas. Fencing is 
created and edited much like walls and 
railings, and normally used outside of a 
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building and follows the shape of the terrain.  
See “Terrain” on page 715.

Define the default fence style in the Fencing 
Defaults dialog. See “Fencing Defaults” on 
page 264.

Exterior and Interior Walls
Most walls are drawn using 
either the Straight Exterior 

Wall and Straight Interior Wall tools. 

Exterior and interior walls can 
also be drawn using the Curved 

Exterior Wall  and Curved Interior Wall  
tools. 

The only difference between the Exterior and 
Interior Wall Tools is the wall type used: 
Exterior Walls use a wall type set up to 
model a wall with siding, while Interior 
Walls model interior walls with sheetrock. 
You can specify the default wall type for 
each tool in the Exterior/Interior Wall 
Defaults dialog. See “Exterior and Interior 
Wall Defaults Dialogs” on page 262.

To draw a wall using a different wall type, 
you can change the default wall type for 
either tool in the Exterior and Interior Wall 
Defaults dialogs. You can also draw a wall 
using the default type and then change the 
wall type in the Wall Specification dialog.

Whether a wall is recognized by the program 
as an actual exterior or interior wall is based 
on its position in the model, not by which 
tool you use to draw the wall. 
• Any wall or wall segment that is entirely 

surrounded by interior room areas is con-
sidered to be an interior wall. 

• Any wall or wall segment that defines an 
exterior room or is exposed to the outside 
of the building is considered to be an 
exterior wall. See “Room Types” on page 
335. 

Foundation Walls
Foundation walls are similar to the 
interior and exterior walls but also 

have a footing. Foundation walls can either 
be created automatically when a foundation 

floor is created or manually by drawing them 
using the Straight or Curved Foundation 
Wall tool. See “Building a Foundation” on 
page 452. 
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The initial foundation wall type and footing 
size are specified in the Foundation Wall 
Defaults dialog. These values can be 
changed for individual walls in the Wall 
Specification dialog. See “Wall 
Specification Dialog” on page 308. 

You can draw a foundation wall on any floor 
of a plan, not just on the foundation level. 
Any wall can be specified as a foundation 
wall, regardless of the tool used to draw it. 
See “Foundation Panel” on page 317. 

Foundation walls are placed on the “Walls, 
Foundation” layer by default, but can be put 
on any layer you choose. In floor plan view, 
foundation wall footings are placed on the 
“Footings” layer and cannot be moved; in 3D 
views, they are on the “Walls, Foundation” 
layer. See “Displaying Walls” on page 281.

Slab Footing
The Slab Footing tool draws a single-
layer concrete wall using the wall type 

and other attributes specified in the Slab 
Footing Defaults dialog. Slab Footings are 
used to define Monolithic Slab foundations, 
garage curbs, and interior footings. 

Typically, the wall type should have the same 
width as that specified for footings. For 
Garage curbs, the footings should be wider 

than the wall type.  See “Foundation Panel” 
on page 317. 

Rooms defined by walls drawn using this 
tool will have a Ceiling Height of 0 and a 
Monolithic Slab Foundation. See “Structure 
Panel” on page 352. 

Foundation Wall Footings
Normally, a foundation wall’s footing is 
centered on the wall. If you prefer, you can:
• Center the footing on the main wall layer.
• Align the footing along the wall’s exte-

rior.
• Specify an offset, as measured from the 

wall’s centerline.

These offset options are set in the Wall 
Specification dialog. See “Foundation 
Panel” on page 317. 

You can select the footing in 3D views and 
edit its size and shape using the edit handles. 
See “Stepped and Raked Walls” on page 298.

Brick Ledges
Several types of brick ledges can be 
produced in Chief Architect. Perhaps the 
most common scenario is in monolithic slab 
foundations: 

Cross section of monolithic slab brick ledge
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• The width of the ledge is equal to that of 
the wall layers outside of the Main Layer 
of the wall above the ledge. 

• The Brick Ledge Depth is specified in 
the Wall Type Definition of the wall 
above the ledge. 

• The Foundation to Exterior of Layer 
setting must be the wall type’s exterior 
layer in order for the brick ledge to gener-
ate. 

Brick ledges in monolithic slab foundations 
do not extend under door openings. 

Brick ledges can also be produced in stem 
wall and pier foundations if you select the 
exterior wall layer for the Foundation to 
Exterior of Layer setting and specify a suf-
ficiently thick foundation wall. Brick ledges 
in these foundation types are flush with the 
top of the stem wall. See “Wall Type 
Definitions” on page 302. 

To produce a lowered brick ledge in a stem 
wall, the stem wall must be both sufficiently 
thick and specified as a Pony Wall. See 
“Pony Walls” on page 272. 

Cross section of a stem wall brick ledge

Cross section of a Pony Wall brick ledge
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• The brick wall type on the floor above 
must have its Foundation to Exterior of 
Layer set to its framing layer. See “Wall 
Type Definitions Dialog” on page 305. 

• For the upper Pony Wall, create a copy of 
the brick wall type, substituting the fram-
ing and interior layers for a single Main 
Layer of concrete. 

• The upper and lower Pony Walls should 
be aligned by their outer layers. 

• Specify the Pony Wall’s Elevation of 
Lower Wall Top as a negative value 
equal to the bottom height of the floor 
platform framing.

Pony Walls
A Pony Wall, sometimes called a 
split wall, is a wall with two 

separate wall types, one above the other. 

Walls drawn using the Pony Wall  tool 
are created using the wall types and other 
information specified in the Pony Wall 
Defaults dialog. See “Pony Wall Defaults” 
on page 262.

Most pony walls combine two exterior wall 
types; however, a pony wall can also produce 
an individual wall to be an exterior wall near 
its top and an interior wall near its bottom. 
See “Exterior/Interior Pony Walls” on page 
296.

You can also convert a normal wall into a 
pony wall and vice versa in the Wall 
Specification dialog. See “Wall Types 
Panel” on page 319.

The height where the upper portion meets the 
lower can be adjusted in 3D views using the 
wall’s edit handles as well as in the Wall 
Specification dialog. The upper and lower 
sections of a pony wall are linked, so if either 
portion is modified along the division 
between the two, such as raking or the 
stepping of a footing, the other portion of the 
pony wall adjusts to match. See “Stepped and 
Raked Walls” on page 298.

Displaying Pony Walls
You can specify whether the upper or lower 
portion of pony walls displays in floor plan 
view in the Pony Wall Defaults dialog. This 
Display in Plan View option can also be set 
for individual walls in the Wall Specification 
dialog. See “Wall Types Panel” on page 319.

Just as with other walls, the appearance of 
the portion of a pony wall that displays can 
be controlled. See “Displaying Walls” on 
page 281. 



Room Dividers and Invisible Walls

 273

Only the portion of a pony wall that displays 
can be snapped to; however, regardless of 
what part is displaying, the upper wall will 

be used to Align with Wall Above , and 
the lowe part will be used to Align with Wall 
Below . See “Editing Walls” on page 285 
and “Aligning Walls” on page 292. 

By default, windows and doors in pony walls 
are visible in floor plan view regardless of 
which part of the pony wall displays. You 
can, if you wish, select Hide Openings in 
Non-Displayed Parts of Walls in the Pony 
Wall Defaults dialog. 

If a window or door is completely contained 
by one part of a pony wall, it will display in 
floor plan view if the other part of the pony 
wall is shown; but the wall’s layer fill pattern 
or Hatch Wall fill pattern will display over it. 

In views sent to layout, the default Display 
in Plan View option for pony walls is static: 
if the default is changed in the plan, views 

previously sent to layout are unaffected. The 
display of pony walls that are not using the 
default, however, are dynamic: if you change 
an individual pony wall’s Display in Plan 
View setting, layout views will show the 
change. See “Keeping Layout Views 
Current” on page 1243. 

Changing Wall Types
The default upper and lower parts of a pony 
wall can be specified in the Pony Wall 
Defaults dialog. See “Pony Wall Defaults” 
on page 262.

The upper and lower parts of a pony wall can 
be redefined as different wall types in the 
Wall Specification dialog. See “Wall Types 
Panel” on page 319.

Room Dividers and Invisible Walls
The Room Divider tool is used to 
define separate room areas in a plan; 

typically, by dividing a large room area into 
two or more smaller areas. See “Room 
Definition” on page 331.

Common uses for Room Dividers  
include dividing areas of an open floor plan 
into areas with different purposes. 

Room Dividers can also be used to define 
areas with different floor or ceiling materials 
or heights. 

Note: The only way to control the materials
displaying on a pony wall is by changing the
wall types. 

Room Dividers separate this dining area 
from adjacent rooms 
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Room Dividers  are drawn using the 
attributes specified in the Room Divider 
Defaults dialog; which means they are 
simply walls that are specified as Invisible 
and have a single layer of an “Air Gap” 
material with a thickness of 0” (mm). 

If a zero-thickness Room Divider  
separates two rooms with different floor and/
or ceiling heights, its wall type will be 
changed to the current plan’s default Interior 
Wall so that the platform step created by the 
height difference can be enclosed. See “Floor 
and Ceiling Platforms” on page 344.

Any wall, regardless of its wall type or 
thickness, can also be specified as Invisible - 
or vie versa - in the Wall Specification 
dialog. See “General Panel” on page 309.

Room Dividers are placed on the “Walls, 
Invisible” layer by default, as are walls that 
are specified as Invisible. A wall placed on a 
non-default layer and then specified as 
Invisible, however, will not move to the 
“Walls, Invisible” layer. See “Room Divider 
Defaults” on page 264. 

Walls specified as Invisible can display in 
floor plan view but not in 3D views or the 

Materials List. See “Displaying Walls” on 
page 281.

It is not possible to place doors, windows, or 
fireplaces into an Invisible wall; however, if 
a wall with openings in it is specified as 
Invisible, any openings in it will remain. 

Important Notes on 
Invisible Walls

• Floor, wall and ceiling areas are calcu-
lated separately for rooms divided by 
Invisible walls.

• Invisible walls are ignored by the Auto 
Place Outlets  tool; it functions as 
though they were not present. 

• Cabinets, fixtures and furniture can be 
moved freely through Invisible walls. 

• Invisible walls can be drawn through a 
cabinet to attach to the wall behind.

• By default, Room Dividers are automati-
cally generated to connect “island” rooms 
to the larger structure around them. You 
can turn this behavior off in the General 
Wall Defaults dialog. See “General Wall 
Defaults” on page 260.

Polygon Shaped Rooms and Decks
The Polygon Shaped Room and Polygon 
Shaped Deck tools allow you to create 
rooms with regular sides and work similar to 

the Regular Polygon  CAD tool. See 
“Regular Polygon” on page 1101. 

Select Build> Wall> Polygon Shaped 
Room to open the New Polygon 

Shaped Room dialog and create a polygon 
shaped room with regular sides.

Select Build> Railing and Deck> 
Polygon Shaped Deck to open the 

New Polygon Shaped Deck dialog and 
create a polygon shaped deck with regular 
sides.
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The settings in these two dialogs are identical 
and are saved between program sessions. 
They are also independent of one another so 
different settings can be retained for each. 

To create a polygon shaped room or deck

1. Click the radio button beside an option 
to specify whether you want to Define 
Polygon by Side Length, Radius to 
Corner or Radius to Side.

2. Specify the desired Number of Sides.
3. Specify the desired Side Length or,
4. Specify the desired Radius.
5. Uncheck Include Railing to produce a 

deck platform defined by Deck Edges. 
This option is not available in the New 
Polygon Shaped Room dialog.

6. Click OK, then click once in floor plan 
view to create the specified polygon 
shaped room.

Hatch Wall
The Hatch Wall tool can be used to 
fill wall segments with a single hatch 

pattern in floor plan view.  

To apply wall hatching, select Build> Wall> 
Hatch Wall , then click on a wall. The 
hatch pattern covers the entire length and 
width of the wall segment.

Hatch Wall  places a hatch pattern across 
all layers of the selected wall layers 
displaying in the current view, covering any 
fill styles specified for that wall type. When 
wall hatching is applied to a railing, or when 

the “Walls, Main Layer Only” layer is turned 
on, wall hatching only displays in the Main 
Layer(s). See “The Main Layer” on page 
302.

In many cases, it is preferable to create a wall 
type definition rather than use the Hatch 
Wall  tool because multiple fill styles can 
be used. See “Wall Type Definitions Dialog” 
on page 305.

Once created, wall hatching can be selected, 
edited and deleted much like other line-based 
objects. See “Editing Line Based Objects” on 
page 187.

If you use the Hatch Wall  tool to apply a 
hatch pattern to a wall that has been divided 
into multiple segments using the Break 
Wall  tool, the pattern is only applied to 

Note: The Hatch Wall tool cannot be used to
apply a hatch pattern to Invisible Walls or to
walls on a locked layer. See “Room Dividers
and Invisible Walls” on page 273 and “Lock-
ing Layers” on page 145.
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the segment that you clicked on. See “Break 
Wall” on page 276.

Like doors and windows, wall hatching 
cannot extend across multiple wall segments. 
Unlike these objects, hatching cannot be 
located by dimension lines.

The wall hatch pattern and its line weight can 
be specified in the Wall Hatch Specification 

dialog. See “Wall Hatch Specification 
Dialog” on page 328. 

When editing or deleting wall hatching, 
make sure that it is selected rather than the 
wall by noting that “Wall Hatching” displays 
in the Status Bar. See “The Status Bar” on 
page 42. 

Break Wall
To divide a wall or railing, select  
Build> Wall> Break Wall and click 

on the wall. The wall is divided into two wall 
sections at the point where you click. 

The Break Wall  tool remains active, so 
you can continue to place breaks in walls. 
When you are finished, select a different 
tool.

If a wall break is placed near the intersection 
of two walls, the break is positioned at the 
center of the intersection. 

Once a break is placed, click the Select 
Objects  tool and select the original wall. 
If edit handles display near the break, the 
wall was correctly broken.

Walls separated by a break can be rejoined. 
Select one of the segments, then click on the 
end edit handle located at the break and drag 
it a few plan inches (mm) away from the 
break. See “Connecting Walls” on page 279.

The Break Wall  tool can be used to 
create aligned walls on either side of a gap. 
See “Creating a Nook” on page 292.

Drawing Walls
Walls, railings, and fencing are drawn similar 
to the way CAD lines are drawn: select a 
Wall Tool or a wall saved in the Library 
Browser, and then click and drag from end to 
end in the drawing area. Walls can be drawn 
in floor plan view, camera views, and 
overviews. See “Draw Line” on page 1080.

Drawing walls to create a floor plan is simple 
if you keep a few things in mind: 

• Draw exterior walls first to define the 
building’s footprint, then draw the interior 
walls after the perimeter is in place. 

• It is easiest to draw walls at the approxi-
mate location and length needed and then 
move or resize them precisely using 
dimensions later. See “Moving Objects 
Using Dimensions” on page 1019. 

• When drawing and positioning exterior 

walls, make sure Grid Snaps  are 
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enabled. Once these walls are in place, 
you may prefer to turn Grid Snaps off to 
draw and position interior walls and other 
objects. See “Grid Snaps” on page 166. 

• If you wish to input wall lengths as you 
draw, make sure your General Wall 
Defaults are set to Resize About Outer 
Surface. See “Entering Wall Lengths and 
Angles” on page 277. 

• As walls are drawn, Intersection Snap 
indicators, “sticky” points and extension 
lines identify points that are either collin-
ear or orthogonal to the end points of 
other walls, making alignment easier. See 
“Wall Intersection Extension Snaps” on 
page 164. 

• As walls are drawn, Angle Snaps take pri-
ority over Object Snaps. If you prefer that 
walls draw at any angle so that they can 
snap to other objects, uncheck Always 
Snap Walls On Allowed Angles in the 
Preferences dialog. See “Snap Properties 
Panel” on page 115. 

• When walls enclose an area to form a 
room, the program will orient all exterior 
walls so that the siding material faces out-
ward. See “Wall Type Definitions” on 
page 302. 

• To flip the layers of a wall after it is 
drawn, select it and click the Reverse 
Layers  edit button. See “Editing 
Walls” on page 285.

• Initial wall heights are determined by the 
default floor and ceiling heights of the 
current floor. See “Floor Defaults Dialog” 
on page 436.

Wall Positioning
The recommended method of drawing walls 
is to draw them at their approximate location 
and length, then move them into position 
with accuracy using dimensions. To make 
this task quick and efficient: 
• Notice the temporary wall that displays as 

you draw. Its length and angle display in 
the Status Bar at the bottom of the win-
dow and adjust as you move the mouse. 
Release the mouse button to draw the wall 
at the displayed length and angle. See 
“The Status Bar” on page 42. 

• Use Snaps to help ensure proper wall 
alignment and orientation. See “Snap 
Behaviors” on page 162. 

Once walls are drawn, they can be accurately 
dimensioned and moved as needed. See 
“Measuring Walls” on page 284. 

Entering Wall Lengths 
and Angles

The fastest way to draw walls is to draw 
them at their appoximate position and length, 
and then move or resize them accurately 
using dimensions. See “Using Dimensions” 
on page 286.

For those that wish to enter walls’ lengths 
and angles as they are drawn, first select 
Resize About Outer Surface in the General 
Wall Defaults dialog. See “Resize About” on 
page 292.

Then draw a wall, select it, and specify its 
Length and Angle in the Wall Specification 
dialog.  Draw a second wall and specify its 
length and angle, and so on. See “General 
Panel” on page 309.
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You can also press the Tab key while you are 
dragging to draw a wall to open the Enter 
Coordinates dialog, where you can enter the 
wall’s Distance, or length, and Angle. See 
“Entering Coordinates” on page 168. 

Wall Openings
To create a door or doorway, do not draw 
wall sections with a gap between them. Walls 
should be drawn to completely enclose 
rooms, and then door and window objects 
should be placed in the walls to create 
openings later. See “Doors” on page 361 and 
“Windows” on page 391. 

Masonry fireplaces placed in walls are also 
considered to be types of wall openings. See 
“Fireplaces” on page 467.

Temporary Dimensions
Temporary dimensions will display along the 
length of a wall as it is drawn when 

Temporary Dimensions  are toggled on 
and Show Wall Length When Editing is 
checked in the General Wall Defaults dialog. 
See “Temporary Dimensions” on page 1008 
and “General Wall Defaults” on page 260. 

Continuous Wall Drawing
You can draw walls continuously by right-
clicking, Alt+clicking or Alt+dragging. See 
“To draw continuous lines” on page 1081.

By default, this continuous drawing behavior 
will turn off when walls are drawn to form an 
enclosed area. You can specify that this 
behavior remain on in the Preferences 
dialog. See “Behaviors Panel” on page 113.

Drawing Curved Walls
Drawing a curved wall, curved railing, or 
curved fence is similar to drawing a CAD 
arc. See “Arc Tools” on page 1091.

As with CAD arcs, the method used to draw 
a curved wall depends on which Arc 
Creation Mode  is currently active.  See 
“Drawing Arcs - Arc Creation Modes” on 
page 1089.

A straight wall can also be converted into a 
curved wall and vice versa using the Change 
Line/Arc  edit button. See “Change Line/
Arc” on page 232.

A curved wall always has a center point. The 
center displays as a small cross when Show 
Arc Centers and Ends  is enabled. See 
“Arc Centers and Ends” on page 195. 

The radius of a curved wall is measured from 
the center to a surface or layer of the wall. 
The radius can be defined in the Wall 
Specification dialog. You may elect to 
define the radius to the exterior or interior 
wall layers. See  “General Panel” on page 
309.

To create a room in the shape of a cir-
cle, you must draw two curved walls.

Show Arc Center
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Space Planning Assistant
The Space Planning Assistant Tools 
allow you to place and arrange room  

boxes that can then be converted into a fully 
editable house plan, including walls. See 
“Space Planning” on page 1127.

Wall Framing
Once walls have been drawn, they can be 
framed. For best results, avoid generating 
framing until your model is in its final form. 
See “Wall Framing” on page 578. 

Framing for an individual wall can be built or 
rebuilt using the Build Framing for 
Selected Object  edit tool. This tool is 
only available if the selected wall has a 
framing material assigned to its Main Layer, 
and is not available if Retain Wall Framing is 
checked in the Wall Specification dialog. 
See “Build Framing for Selected Object” on 
page 609. 

Wall framing can be viewed and edited in 
floor plan and 3D views, as well as in Wall 
Detail  views. See “In Wall Detail Views” 
on page 605.

Connecting Walls
When walls are drawn sufficiently close to 
one another, they will snap together to form 
an intersection. This snapping occurs when 
the walls’ center lines are within a distance 
defined by the larger of the two walls’ widths 

and will occur even when Object Snaps  
are turned off. See “Object Snaps” on page 
162.

If the two walls in question have identical 
specifications and are collinear, they will 
merge to become a single wall. See 
“Aligning Collinear Walls” on page 292.  

When three or more walls connect to form a 
completely enclosed area, that area defines a 
room. See “Rooms” on page 329.

When walls snap together to form an 

intersection and Object Snaps  are 
enabled, the program joins them at their 
Resize About line, which is specified in the 

General Wall Defaults dialog. See “Aligning 
Walls” on page 292. 
• The wall that is being drawn or edited will 

move, lengthen, or shorten slightly to 
meet the other wall. 

• The other wall will not move; however, 
its length may be affected. 

Wall Intersections
Any time two walls intersect, one wall will 
build through the other. You can turn on the 
display of.the “Walls, Thru Wall Lines” layer 
in floor plan view to see which walls build 
through and which do not. See “Displaying 
Objects” on page 144. 

When a wall builds through another wall, it 
will extend into the intersected wall until it 
meets the interior surface of that wall’s Main 
Layer. See “The Main Layer” on page 302.



280

Chief Architect X8 Reference Manual

You can specify which walls build through 
wall intersections at corners in the Wall 
Specification dialog..See “Structure Panel” 
on page 311.

You can also control how the individual 
layers of one wall build into another using 

the Edit Wall Layer Intersections  edit 
tool..See “Wall Layer Intersections Edit 
Handles” on page 290. 

Fix Wall Connections
Occasionally, intersecting walls  may 
not properly connect. When this is the 

case and the connection in question is on the 
current floor, a circle will display at its 
location and the Connect Walls  icon will 
display near your mouse pointer. You can 
turn off this feedback in the Preferences 
dialog. See “Architectural Panel” on page 
108.

To correct wall connections throughout the 
current plan, select Build> Walls> Fix Wall 
Connections . 

Alternatively, you can fix an individual wall 

connection using the Connect Walls  edit 
tool.

To use the Connect Walls edit tool

1. Select a wall.

2. Click the Connect Walls  edit but-
ton.

3. Click on a wall that you want to connect 
to the selected wall. 

•  If the unconnected wall ends are suffi-
ciently close to one another, the tool 
connects them. 

•  If the separation is too great, extend 
one towards the other and try again. 

Removing Wall Breaks

The Break Wall  tool allows you to break 
a wall into two or more separate wall 
segments. See “Break Wall” on page 276.

To merge two collinear walls separated by a 
break,select one of the segments, then click 
on the end edit handle located at the break 
and drag it a few plan inches (mm) away 
from the break. 

If the two walls do not merge, either one or 
both walls have been moved and they are no 
longer collinear, or one or both has been 
edited in some way and they are no longer 
identical. Open the Wall Specification 
dialog for each wall and determine how they 
differ. See “Wall Hatch Specification 
Dialog” on page 328.

Through Wall Line
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Displaying Walls
While the structure and appearance of 
each wall type is controlled in the 

Wall Type Definitions dialog, the display of 
walls in all views is controlled in the Layer 
Display Options dialog. See “Displaying 
Objects” on page 144.

The program installs with a number of layers 
intended for specifically for various types of 
walls; however, you can specify any layers as 
the defaults for most of these walls. Once 
created, you can also place a selected wall on 
any layer. See “Layer Panel” on page 322.

If a “Walls” layer is turned off, any doors and 
windows placed in walls on that layer will 
not display, either. See “Displaying Doors” 
on page 365 and “Displaying Windows” on 
page 401.

In Floor Plan View
The appearance of each wall type, including 
line weights and colors and wall layer fill 
styles, is specified in the Wall Type 
Definitions dialog. See “Wall Type 
Definitions Dialog” on page 305.

There are also several options for controlling 
how walls are displayed in floor plan view. 
In the Layer Display Options dialog, you 
can specify whether or not various types of 
walls display. By default, walls are placed on 
layers with “Walls” at the beginning of the 
layer name, such as “Walls, Normal”. 

The display of the wall layers specified in the 
Wall Type Definitions dialog can be 
controlled. If you turn off the display of the 
layer called “Walls, Layers”, wall types 

display with two lines representing the inside 
and outside surfaces. 

In addition, you can turn off the display of 
non-structural layers and show only the 
walls’ Main Layers by turning on the display 
of the “Walls, Main Layer Only” layer. This 
allows you to create both fully configured 
walls and framing layouts. The “Walls, Main 
Layer Only” layer affects the display of walls 
in floor plan view only. See “The Main 
Layer” on page 302.

The “Walls, Thru Wall Lines” layer controls 
the display of lines indicating which walls 
build through at wall intersections. 

Either the upper or lower portion of a Pony 
Wall can display in floor plan view. Only the 
portion that displays can be snapped to or 
aligned with walls above or below. See 
“Pony Walls” on page 272.

Foundation Walls have footings that display 
in floor plan view as long as the “Footings” 
layer is turned on. See “Displaying 
Foundations” on page 454. 

Railing newels, balusters, and rails can be set 
to display in floor plan view in the Railing 
Specification dialog. See “Newels/Balusters 
Panel” on page 325.

It is sometimes helpful to display the walls 
from a floor other than the current floor. To 
do this, select and display a reference floor. 

Note: In floor plan view, railings not specified
as Solid display their Main Layer regardless
of whether “Walls, Layers” or “Walls, Main
Layer Only” is turned on. See “Wall Types
and Railings” on page 268. 
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See “The Reference Floor” on page 444. You 
can also specify which layers are included in 
the Reference Display Layer Set in the Layer 
Display Options dialog. 

In 3D Views
As in floor plan view, the display of walls 
can be controlled by layer in the Layer 
Display Options dialog. 

Each layer of a wall is generated when you 
create a 3D view. You can see the different 

layers in 3D using the Delete Surface  
tool. See “Delete 3D Surface” on page 910. 

A wall’s framing layer displays as a solid 
layer rather than studs and plates until wall 
framing is built. See “Framing” on page 577. 
Wall framing is placed on the “Framing, 
Wall” layer by default. 

You can specify whether the newels, 
balusters, and/or rails of railings display in 
floor plan view. See “Newels/Balusters 
Panel” on page 325.

While most architectural objects in the 
program can display in both floor plan and 
3D views, a few cannot. Invisible walls and 
Wall Hatching are examples of objects that 
do not display in 3D, regardless of what layer 
they are placed on.

In Cross Sections

When the Auto Detail  tool is used in a 
cross section view, the fill style of each wall 
layer as set in its Wall Type Definition is 
used. See “Auto Detail” on page 905. 

Wall Labels
Wall labels are located on the “Walls, 
Layers” layer and can be set to display in 
floor plan and cross section/elevation views. 
See “Object Labels” on page 1279. 

Walls do not have Automatic Labels by 
default. Once wall framing has been built, 
however, framed walls will be assigned 
Automatic Labels that correspond to each 

wall’s Wall Detail . See “In Wall Detail 
Views” on page 605. 

Concrete and masonry walls’ automatic 
labels are always blank; however, custom 
labels can be assigned ito any wall in the 
Wall Specification and Defaults dialogs. If 
you wish, you can use Named Values to 
create custom text macros for wall labels. 
See “Working with Named Values” on page 
1305. 

Any relevant wall label information will be 

exported when Export to REScheck  is 
used. See “Export to REScheck” on page 
1192.  

Wall Materials
There are several ways that materials can be 
assigned to walls, depending on how the 
walls and the rooms they define have been 
defined. See “Rooms” on page 329. 

When you draw a wall, it uses the materials 
specified in its wall type definition. See 
“Wall Type Definitions” on page 302. 

You can change the surface material of an 
individual wall in the Wall Specification 
dialog. If you select “Use Default” as the 
material and the wall is used to define a 
room, the program refers to the material 
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specified in the Room Specification dialog. 
See “Wall Specification Dialog” on page 
308.

You can also change a room’s wall material 
in the Room Specification dialog. See 
“Materials Panel” on page 852. To restore the 
default Wall Type material, select Use 
Default in the Select Material dialog. See 
“Select Material Dialog” on page 854. 

Wall materials can also be changed using the 

Material Painter  tool, but bear in mind 
that depending on which Material Painter 
Mode is in use, only a portion of the wall 
may be painted and that the entire room may 
be affected rather than the individual wall. 
See “Material Painter and Walls” on page 
851.

When neither the wall nor the room has a 
material assigned to it, the program refers to 
the general material for walls in the Material 
Defaults dialog. See “Material Defaults” on 
page 848.

In the Materials List
The materials that make up wall assemblies 
are listed under different Categories in the 
Materials List: 
• Siding - Lists all materials located outside 

of each wall’s Main Layer, such as siding, 
sheathing, and housewrap. 

• Framing - Lists the Main Layer mate-
rial(s) for all walls as well as railings 
specified as Solid. Non-framed walls’ 

Main Layer materials are also listed here 
when those walls are not specified as 
Foundation. 

Wall framing, including studs, plates, and 
headers, is only counted when a framing 
material has been assigned to a wall type 
and wall framing has been built. See 
“Framing” on page 577.

• Insulation - Insulation is calculated for 
all exterior walls that are not specified as 
Railing, regardless of the wall type defini-
tion. 

• Wallboard - Lists all materials located 
inside of each wall’s Main Layer, such as 
drywall. Includes all materials aside from 
framing, concrete, and rebar in walls that 
do not define rooms. 

Does not include Wall Coverings or mate-
rials specified in either the Room or Wall 
Specification dialog. See “Materials 
Panel” on page 322.

• Interior Trim - Lists base, crown and 
chair rail moldings, and Wall Covering 
materials specified in the Wall and Room 
Specification dialogs. See “Wall Cover-
ing Panel” on page 320.

• Foundation - Lists the concrete and rebar 
for all walls specified as Foundation as 
well as their footings. See “Foundation 
Walls” on page 269.

Slab Footings as well as the room areas that 
they define can be assigned Pour Numbers 
in their specification dialogs. Pour Numbers 
are listed separately under the Foundation 
category of the Materials List. See 
“Foundation Panel” on page 317.

Note: Wall materials that are specified on the
Materials panel of either the Wall or Room
Specification dialog are not calculated in the
Materials List.



284

Chief Architect X8 Reference Manual

With the exception of wallboard, windows 
and doors are taken into account in the 
calculation of these totals.

Additional wall-related information is listed 
in the General category, including the total 
linear feet of each wall type per floor and the 

thermal envelope wall area per floor. See 
“Conditioned Area” on page 1297.

A wall type’s Main Layer plays a central role 
in determining how wall materials are 
calculated. For this and other reasons, correct 
Main Layer assignment is very important. 
See “The Main Layer” on page 302. 

Measuring Walls
Accurate wall measurements are an essential 
aspect of any drawing, and can be achieved 
by following two basic rules:
• Be aware of what part of a wall assembly 

dimensions are locating;
• Position walls using dimensions rather 

than edit handles or edit tools.

These rules can easily be met when you keep 
the following recommendations in mind.

Use Dimension Defaults
Manually-drawn, automatic, and temporary 
dimensions can all be set to locate walls at 
their Dimension Layers or at their surfaces. 
Before drawing dimensions - and 
particularly, before using them to move your 
walls into position - make sure that all of 
your Dimension Defaults are set up to meet 
your needs. See “Dimension Preferences and 
Defaults” on page 986.

If a wall is specified as Invisible, dimensions 
will locate it at its centerline regardless of its 
Wall Type Definition or your Dimension 
Defaults settings. If the Invisible wall divides 
rooms with different floor heights, 
dimensions will locate the edge of the wall 
facing the room where the floor is lower. 

Be aware, too, that the wall length dimension 
that displays when a wall is selected as well 
as the Length specification in the Wall 
Specification dialog do not inherit their 
settings from the Dimension Defaults. 
Instead, they follow the Resize About line. 
See “Resize About” on page 292. 

Edit Dimension Lines
Once a dimension line has been drawn, its 
extension lines can be edited to locate a 
number of locations on a wall assembly:
• The exterior surface
• The Wall Dimension Layer’s exterior
• The center line of the wall assembly
• The Main Layer’s center line
• The Main Layer’s interior
• The interior surface

See “Editing Extension Lines” on page 1016. 

Moving Walls Using 
Dimensions

By far, the most precise method of 
positioning walls is using dimension lines. 
To produce accurate measurements, 
remember to: 
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• Be aware of what part of your walls is 
being located by each type of dimension.

• Avoid specifying dimension values with 
greater accuracy than your dimensions are 
set to display. See “Primary Format 
Panel” on page 989. 

See “Using Dimensions” on page 286.

Remember that the temporary wall length 
dimension that displays when a wall is 
selected may be set to locate a different part 
of the wall assembly than other dimension 
lines. See “Wall Length” on page 288. 

Use Object, Angle and 
Grid Snaps

Object Snaps, Angle Snaps, and Grid Snaps 
make it easier to align walls when they are 
being drawn as well as when they are edited. 
See “Snap Behaviors” on page 162. 

Object Snaps  help to ensure consistent 
wall connections and are particularly helpful 
when aligning collinear walls. 

When Grid Snaps  are enabled, walls are 
drawn on a regularly spaced grid, which 
helps avoid inaccurate wall placement. This 
can become particularly important if you 
forego positioning walls using dimensions in 
favor of using edit handles to move them. 

Angle Snaps  make it easy to accurately 
draw walls at regular angles, ensuring walls 
that are truly parallel or perpendicular to one 
another and separated by consistent 
distances.

No Locate
If a wall is specified as No Locate in the 
Wall Specification dialog, it will be ignored 
by Auto Exterior Dimensions  in floor plan 
view, as will any doors or windows placed in 
it. See “Dimensions” on page 985.

By default, Railings, Deck Railings, and 
Room Dividers are specified as No Locate. 
See “General Panel” on page 309.

If a wall is on its default layer and is speci-
fied as No Locate, it will be moved to the 
“Walls, No Locate” layer. If this box is later 
unchecked, the wall will return to its default 
layer. If a wall is on a non-default layer, it 
will remain there. See “Displaying Walls” on 
page 281. 

Once a dimension line has been created, it 
can be edited so that it locates a No Locate 
wall or railing that is perpendicular to it. See      
Editing Dimension Lines. 

Editing Walls
Walls can be selected individually and as a 
group in all views. When a wall is selected, it 
displays edit handles and an edit toolbar that 
can be used to edit it in various ways. When 

a wall is selected, temporary dimensions may 
also display. See “Temporary Dimensions” 
on page 1008. 

Using Grid Snaps is recommended
when you are laying out exterior shell

walls, but may be inconvenient when posi-
tioning interior walls or other objects. 
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The ways in which a wall can be edited 
depends on the current view and which edge 
is selected. See “Selecting Objects” on page 
183. 

Selecting Walls
• When you try to select a wall in a cross 

section/elevation or 3D view, the interior 
or exterior room that it defines may be 
selected first. Click the Select Next 
Object  edit button or press the Tab 
key on your keyboard to select the wall 
itself. See “Selecting Rooms” on page 
331.

You can specify that the wall be selected 
first instead of the room in the 
Preferences dialog. See “Appearance 
Panel” on page 92. 

• In floor plan view, if wall hatching has 
been applied to a wall using the Hatch 
Wall  tool, the hatching may be 
selected first. Click Select Next 
Object  to select the wall itself. See 
“Hatch Wall” on page 275.

• The Edit Area  tools allow you to 
select only part of a wall or walls. See 
“Edit Area Tools” on page 252.

Using the Edit Handles
A selected wall can be modified in a variety 
of ways using its edit handles in any view. 
The handles that are available will depend on 
the current view type. See “Edit Handles for 
Walls” on page 289.

In the Specification Dialog
The appearance and structure of walls 
can be customized in the Wall 

Specification dialog. See “Wall 
Specification Dialog” on page 308.

The characteristics of the roof directly above 
a selected wall can also be specified in the 
Wall Specification dialog. See “Roof Panel” 
on page 314.

Using the Edit Tools
A selected wall or walls can be edited in a 
variety of ways using the buttons on the edit 
toolbar. See “The Edit Toolbar” on page 37.

Using Dimensions
Automatic, manually-drawn, and 
temporary dimension lines can be 

used to both resize and move walls with 
accuracy. Select a wall, then click on a 
dimension line that locates it and type in the 
value that you need. See “Moving Objects 
Using Dimensions” on page 1019.

When a wall is resized using dimensions, the 
inline text field used to edit the dimension 
will have three unique buttons:
• Horizontal walls have Move Left End 

, Move Both Ends , and Move 
Right End . 

• Vertical walls have Move Top End , 

Move Both Ends , and Move Bottom 
End . 

Choose the option that you want to use 
before pressing the Enter key.
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If both ends of the selected wall intersect 
walls that are not parallel to one another, a 
fourth option will be available: Move Along 
Rails . When this option is used, the 
selected wall both resizes and changes 
position so that it remains connected to the 
other walls when you press the Enter key.

Depending on your Dimension Defaults 
settings, manual, automatic, and/or 
temporary dimension lines may locate wall 
surfaces or wall dimension lines. See 
“Locate Objects Panel” on page 992.

Dimension lines do not locate foundation 
wall footings when they are first drawn. 
Their extension lines can be edited to do so, 
however. See “Editing Extension Lines” on 
page 1016.

Unlike other types of walls, the thickness of 

a Slab Footing  can be resized using 
dimensions. A new wall type may result. See 
“Editing Foundations” on page 456.

Bear in mind that temporary dimensions can 
be set up to locate different wall layers than 
automatic and manual dimensions. As a 
result, they may appear to give different 
measurements between the same walls. See 
“Temporary Dimension Defaults Dialog” on 
page 1003.

Only the portions of pony walls that display 
are located by dimensions. The upper and 
lower parts of pony walls typically have 
different thicknesses, so which  part you 
choose to display may affect your plan’s 
dimensions. See “Pony Wall Defaults” on 
page 262.

Wall Thickness
The initial thickness of a wall is determined 
by its wall type definition. You can change a 
wall’s thickness by modifying the definition 
of it’s wall type. If you do this, all instances 
of the wall type used in the plan will be 
affected - not just an individual object. See 
“Wall Type Definitions” on page 302. 

You can also specify a selected wall’s 
thickness in its Wall Specification dialog. 
See “General Panel” on page 309. 

If a selected wall’s thickness is changed: 
• A copy of the wall’s wall type is created 

with the same name but appended with a 
number equal to the thickness of the Main 
Layers, and that new type is assigned to 
the wall. See “The Main Layer” on page 
302.

Move Both Ends

Move Left End     Move Right End

 Move Along Rails resizes 
and moves a selected wall.

Dimension Defaults and Temporary
Dimension Preferences settings can

have a significant effect on wall position. It is
recommended that you review these settings
and make sure that they meet your needs.
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• The change in thickness will be applied to 
new wall type’s innermost Main Layer. 

• The Main Layer must be at least 1/16” 
thick, and the wall’s thickness cannot be 
less than the original wall type’s total 
thickness minus the thickness of its Main 
Layer.  

If a wall type’s thickness is modified, the 
wall will resize about the Resize About line 
specified in the General Wall Defaults 
dialog. In some instances, the wall may 
appear to move as a result of changes made 
to the thicknesses of its layers. See “General 
Wall Defaults” on page 260. 

Wall Heights
The height of a wall is controlled by the 
ceiling height of the room(s) it defines. If the 
ceiling or floor height of a room is changed, 
the height of the walls that define it also 
change. 
• The initial ceiling height for all rooms on 

a floor is set in the Floor Defaults dialog 
for that floor. See “Floor Defaults” on 
page 330. Whenever possible, it is best to 
set all ceiling heights using the default.

• The ceiling height of a single room can be 
set in its Room Specification dialog. See 
“General Panel” on page 351.

• The default Floor and Ceiling Heights for 
a given floor can be adjusted by editing 
the top and/or bottom edges of the Exte-
rior Room in a 3D view. See “The Exte-
rior Room” on page 332. 

• If the wall height of the Exterior Room is 
adjusted in a 3D view, the default Floor or 
Ceiling Height of the entire floor is 
changed. See “The Exterior Room” on 
page 332.

• The top or bottom edge of any wall can be 
adjusted independent of floor or ceiling 
heights using the mouse in Cross Section/
Elevation and 3D views. Top and bottom 
edges can also be stepped and raked. See 
“Stepped and Raked Walls” on page 298.

• The edge dividing an upper and lower 
pony wall can be edited in Cross Section/
Elevation and 3D views. In addition, its 
height can be defined in the Wall 
Specification dialog. See “Wall Types 
Panel” on page 319. 

Wall Length
Wall length can be modified in several 
different ways: 
• Using dimensions. See “Measuring 

Walls” on page 284.
• In the Wall Specification dialog. See 

“General Panel” on page 309.
• By dragging the end edit handles. See 

“Editing Line Based Objects” on page 
187 and “Editing Arc Based Objects” on 
page 191. 

Bear in mind that if you try to resize a wall 
by a small amount using one of its edit 
handles and that wall is connected to another 
wall at that end, its length will not change 
because its end will snap back to the existing 
intersection. See “Connecting Walls” on 
page 279. 

The most accurate way to specify wall length 
is using dimensions. By default, wall length 
is measured at the outside edge of the Main 
Layer. You can instead specify that manual, 
automatic, and/or temporary dimension lines 
locate surfaces in the Dimension Defaults 
dialogs. See “Dimension Preferences and 
Defaults” on page 986.
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Be aware that the wall length dimension that 
displays when a wall is selected as well as 
the Length specification in the Wall 
Specification dialog do not inherit their 
settings from the Dimension Defaults. 
Instead, they follow the Resize About line. 
See “Resize About” on page 292. 

Locked vs. Unlocked Centers
The default for curved walls is an unlocked 
center because it is easier to draw and edit 
when the center is unlocked. 

Once walls are in place and curved walls are 
properly aligned with straight walls, it is a 
good idea to lock the curved walls’ centers.

To lock the center of a curved wall, select it 

and click the Lock Center  edit button. 
See “Using Lock Center” on page 195. The 
curved wall remains selected, but its edit 
handles change. 

The locked status can also be changed in the 
GENERAL panel of the Wall Specification 
dialog. See “General Panel” on page 309.

Edit Handles for Walls
Walls can be edited extensively using their 
edit handles. Depending on the type of view, 
a wall displays a different set of edit handles 
when selected. 
• In floor plan view, straight and curved 

walls and their footings can be edited like 
other line- and arc-based objects. See 
“Editing Line Based Objects” on page 
187 and “Editing Arc Based Objects” on 
page 191.

• In floor plan view, a wall’s edit handles 
display along its Resize About line. See 
“Resize About” on page 292.

• The Edit Wall Layer Intersections  
edit tool lets you control how a wall’s lay-
ers build to another wall that it intersects. 

• In a camera view or overview, click on the 
top surface of a wall to display the same 
edit handles as in floor plan view, allow-

ing you to rotate, move, and extend or 
shorten the length of the wall. 

• Moving a wall in any view will move any 
cabinets attached to that wall, as well.

• In a cross section/elevation view, the top 
and bottom edges of straight and curved 
walls can be edited like closed polylines. 
See “Editing Closed-Polyline Based 
Objects” on page 201. Only the top and 
bottom edges of walls can be broken, 
angled or curved: the side edges cannot.

• In a camera view or overview, click on an 
interior or exterior surface to display the 
same edit handles as in an elevation view: 
one at each corner and one on the top and 
bottom edges.

• A wall can only be moved perpendicular 
to itself or, in the case of curved walls, 
perpendicular to its chord using the Move 

Note: By default, dimensions and the Resize
About line all use the exterior edge of the
Main Layer. When Resize About is set to use
a different location, dimension lines may not
agree with a wall’s length specification. See
“Measuring Walls” on page 284. 
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edit handle. To move a wall at Allowed 

Angles, use the Alternate  Edit 
Behavior. See “Alternate” on page 179.

• The footings of Foundation Walls and 
Slab Footings can be selected in 3D views 
and edited using the edit handles. See 
“Footing Width and Height” on page 457. 

• The Same Wall Type edit handles can be 
enabled, allowing you to draw a new wall 
segment of the same type as the selected 
wall. 

Same Wall Type 
Edit Handles

The Same Wall Type edit handles 
allow you to draw a new wall 

extending out from either end of a selected 
wall and with identical properties as that 
wall. 

To temporarily enable the Same Wall Type 
edit handles, select a wall and click the Same 
Wall Type  edit button.  You can also 
enable these handles globally in the 
Preferences dialog. See “Architectural 
Panel” on page 108. 

When the Same Wall Type edit handles are 
enabled, two edit handles display just beyond 
a selected wall’s Extend edit handles in floor 
plan view or when the top edge of the wall is 
selected in a 3D view.

Click and drag a Same Wall Type edit handle 
at any angle to draw a new wall segment of 
the same type as the selected wall. 

Wall Layer Intersections 
Edit Handles

The Edit Wall Layer Intersections 
edit tool lets you control how a wall’s 

layers build into another intersecting wall. 
When you click this edit button, the selected 
wall’s standard set of edit handles are 
replaced by a set of Wall Layer Intersection 
handles which you can use to modify the 
length of each wall layer. See “Connecting 
Walls” on page 279. 

To edit wall layer intersections

1. Select a wall and click the Edit Wall 
Layer Intersections  edit button.

•  This edit button is not available if the 
wall is not connected to another wall at 
either end.

2. Zoom  in on either end of the wall so 
its edit handles can be clearly seen.

•  A Wall Layer Intersection edit handle 
is located at the midpoint of each wall 
layer.

3. Click and drag a Wall Layer Intersection 
handle either towards or away from the 
opposite edge of the intersecting wall.

•  As you drag, the wall layer will snap to 
the wall layer lines of the intersecting 
wall.

Same Wall Type edit handles
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4. When you are finished, click the Main 
Edit Mode  edit button or press the 
Esc key. 

Editing Straight/Curved Wall Combinations
If you move a straight wall connected to a 
curved wall with a locked center and the 
connection cannot be maintained without 
changing the center of the arc, the walls lose 
their connection. 

When an Extend edit handle of a curved wall 
with a locked center is dragged with the 

Alternate  Edit Behavior active, the 
locked center setting will be overridden. See 
“Edit Behaviors” on page 178. 

If you move a straight wall connected to a 
curved wall with a locked center, the curved 
wall extends along its curve and the straight 
wall will either lengthen or shorten as needed 
to stay connected to the curved wall. 

If the connection between the straight and 
curved wall cannot be maintained because of 
the curved wall’s radius, it will be broken.

Make Arc Tangent
If both ends of a selected curved wall 
are connected to other walls at angles 

of 45° or less, the Make Arc Tangent edit 
button is available. Click this button to open 
the Radius of Tangent Curved Wall dialog. 

• Specify where along the curved wall’s 
thickness the radius should be Measured 
to. The wall’s radius is usually changed 
by this action and a locked center auto-
matically becomes unlocked. See “Wall 
Type Definitions” on page 302.
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• Specify the Wall Radius, which is mea-
sured from the curved wall’s Arc Center 
to the Measured to location. 

When you click OK, the curved wall will 
adjust its length and position so that its ends 
become tangent to the walls it is attached to.

Aligning Walls
Wall alignment refers to the way wall 
segments line up with one another, either on 
the same floor or on the floor above or 
below.  Walls may need to be aligned in a 
variety of situations.

To make alignment easier when drawing or 
resizing walls, “sticky” points and extension 
lines identify points that are either collinear 
or orthogonal to the end points of other 
walls. See “Extension Snaps” on page 163. 

Resize About
The Resize About line specified in the 
General Wall Defaults dialog controls two 
important aspects of wall alignment:
• What part of a wall retains its position 

when its wall type or wall type definition 
is changed. See “Wall Type Definitions” 
on page 302.

• Where walls snap together to form an 
intersection. See “Connecting Walls” on 
page 279.

See “General Wall Defaults” on page 260.

The Resize About line is the line along 
which a selected wall’s length is measured in 
the Wall Specification dialog. See “Wall 
Length” on page 288. 

The Resize About line is also the line along 
which a selected wall’s edit handles display, 

and is the line along which any snap points 
will be located. See “Editing Walls” on page 
285. 

Aligning Collinear Walls
Collinear walls are parallel walls connected 
end to end and drawn on the same floor. 
When collinear walls join end-to-end, the 
walls snap together. If these walls have the 
same wall type and identical specifications, 

and if Object Snaps  are enabled, they 
will merge to become a single wall segment.

Creating a Nook
Walls can be aligned across an opening such 
as a nook, so that they are collinear, using the 

Break Wall  tool. 

To align walls across a gap

1. Select a wall to build a nook into and 

click the Break Wall  edit button. 
2. Click at a point on the wall close to one 

side of the nook area. Do not worry 
about exact placement right now. 

3. Click again near the other side of the 
nook. Two short lines at each location 
where you clicked indicate Wall Breaks. 
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4. Right-click the middle section of the 
wall to select the wall section. 

5. Click the middle Move handle and drag 
the wall outward. 

6. Draw side walls to connect the wall back 
to the rest of the house. 

7. Move these short walls using dimen-
sions to accurately size the nook. 

Aligning Walls 
Between Floors

Walls can be aligned between floors by 

clicking the Align With Wall Above  and 

Align With Wall Below  edit buttons.

By default, walls on different floors are 
aligned by the outer edges of their Main 
Layers. See “The Main Layer” on page 302.

To align walls between floors

1. Select a wall that you want to align with 
another wall either above or below it.

2. If the wall is above or below the other 
wall along only part of its length, you 
must click on it along that part. Select 
Tools> Reference Floors> Reference 
Display On  to help make sure you 
click on the correct part of the wall.

3. When you have selected the wall at the 
desired location, click either the Align 
With Wall Above  or Align With 
Wall Below  edit button.

Aligning Curved Walls 
Between Floors

Curved walls are aligned between floors 
using the same technique to align straight 
walls. If the centers and radii of the walls are 
within a few inches of each other, the Align 
With Wall Above  and Align With Wall 
Below  edit buttons are enabled for the 
selected wall. The selected curved wall will 
take on the radius and center of the 
referenced wall when the walls are aligned.

Aligning Pony Walls 
Between Floors

When aligning a pony wall with either the 
wall above or below:

• Align With Wall Below will always 
align the lower pony wall with the wall 
below, as specified in the lower pony 
wall’s Wall Type Definition. See “Wall 
Type Definitions” on page 302.

• Align With Wall Above  will always 
align the upper pony wall with the wall 
above, as specified in the upper pony 
wall’s Wall Type Definition. 

In order for these edit tools to be avail-
able, the areas of the walls in question

must be partially aligned, or overlapping.

Place Wall 
Breaks here

Position these 
walls as needed
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Aligning Foundation Walls
The Foundation To This Line setting in the 
Wall Type Definitions dialog controls how a 
wall of a given type aligns with foundation 
walls directly below on Floor 0. 

By default, Foundation To This Line is 
specified for the Main Layer of most wall 
types. An exception to this are brick wall 
types, which have Foundation To This Line 
specified for the exterior siding layer. See 
“Brick Ledges” on page 270.

Aligning Curved Walls 
With Straight Walls

Curved walls can be drawn tangent to 
an existing straight wall using the 

Start/Tangent/End Arc Mode. See 
“Drawing Arcs - Arc Creation Modes” on 
page 1089.

If both ends of a selected curved wall 
are connected to other walls, the Make 

Arc Tangent edit button is available. Click 
this button to move and resize the wall so 
that both ends are tangent to the connected 
walls. See “Make Arc Tangent” on page 291.

Aligning Railings on 
Different Platforms

Two collinear Railings or Deck Railings on 
the same floor can be aligned one above the 
other when they define rooms with different 
floor heights.

To align railing on different platforms

1. Click and drag to draw a Railing or 
Deck Railing that divides a room such as 
a deck in two.

2. Click the Select Objects  button, 
then click in one of the room areas.

3. Click the Open Object  edit button, 
and on the GENERAL panel of the Room 
Specification dialog:

•  Specify a Floor Height that differs 
from that of the other by at least the 
height of the railing, then click OK.

•  The default railing height is 36”, so for 
best results the Floor Height should be 
changed by at least this amount.

4. Click on the railing drawn in step 1, then 

click the Open Object  edit button. 
On the RAIL STYLE panel of the Railing 
or Deck Railing Specification dialog, 
check Generate on Low Platform. See 
“Rail Style Panel” on page 323. 

5. Click and drag a second railing parallel 
to the one drawn in step 1.

6. Select this second railing and click the 

Open Object  edit button. On the 
GENERAL panel of the Railing or Deck 
Railing Specification dialog, check the 
box beside No Room Def and click OK. 
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7. With the railing still selected, Ctrl + drag 
it into the same position as the first rail-

ing. See “To move an object freely” on 
page 221.

Roof Directives in Walls
To automatically generate a roof plane using 
values other than the defaults or to not 
generate a roof plane bearing on a particular 
wall (as for a gable or the sides of a shed 
roof), you can change the settings in the Wall 
Specification dialog. See “Roof Panel” on 
page 314. 

Hip, Gable, and Shed Roofs
By default, the program will produce a roof 
plane over each exterior wall to create a hip 
roof. You can instead specify a gable or shed 
roof above the selected wall. 
• Check Full Gable Wall to create a gable 

with a ridge centered above the selected 
wall(s).

• Check High Shed/Gable Wall for the 
side walls or the wall under the high side 
of a shed roof. 

• You can also select a wall and click the 

Change to Gable Wall(s)  edit button, 
or change it back by clicking the Change 
to Hip Wall(s)  edit button. 

Pitch
The default pitch for roof planes is set in the 
Build Roof dialog. However, any exterior 
wall can define the pitch of the roof plane 
built above it.

You can also specify a second, upper pitch 
above a given wall. Mansard, gambrel, gull 
wing and half-hip are examples of roof styles 
that use two pitches. See “Roof Tutorial” on 
page 63 of the User’s Guide.

Overhangs and Roof Returns
You can specify the overhang of the roof 
plane to be generated above the selected 
wall. This setting only takes effect when 
Same Height at Exterior Walls is unchecked 
in the the Build Roof dialog, which is also 
where the default Overhang value is set. 

Check Auto Roof Return to generate roof 
returns on the selected wall. In most cases, 
roof returns only generate on Full Gable 
Walls. See “Roof Returns” on page 527.

Extend Slope Downward
Check Extend Slope Downward to extend 
the roof plane downward over a bump out, 
instead of creating additional roof planes. 
The two connecting walls that create the 
bump out must be Full Gable walls.

In the following image, the bearing wall of 
the bump out has Extend Slope Downward 
checked. The two short side walls are Full 
Gable Walls. 
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Clerestory and Dormer Walls
Occasionally, walls are built between two 
roof planes rather than between a roof plane 
and a floor platform. Common examples 
include clerestory walls and the side, or the 
cheek, walls of floating dormers.

Check Roof Cuts Wall at Bottom to have 
the bottom of the selected wall clipped by the 
roof plane below, as where a floating dormer 
wall meets the main roof plane.

Exterior/Interior Pony Walls
It’s not uncommon for an individual wall to 
be an exterior wall near its top, and an inte-
rior wall near its bottom. 

Check Lower Wall Type If Split By Butt-
ing Roof to achieve this. When this option is 
checked, the selected wall is specified as a 
pony wall and a second, lower wall type can 
be specified. Unlike with other pony walls, 
the change in wall type occurs wherever a 
roof plane builds to the exterior of the wall. 
See “Pony Walls” on page 272. 

Before

After

Full Gable 
Wall

Extend Slope 
Downward

Clerestory wall built between two roof planes

Upper Wall 
Type

Lower 
Wall Type

Lower Wall Type If Split By Butting Roof
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Attic Walls
In Chief Architect, walls are built between 
the floor and ceiling platforms of the current 
floor.  See “Floor and Ceiling Heights” on 
page 342. When the program detects an open 
space between a wall and the roof plane 
above it, it automatically creates an Attic 
Wall on the floor above that wall to fill in the 
gap. 

Attic Walls are typically found above Full 
Gable Walls, forming a gable or closing the 
top portion of a side wall of a shed roof. 
They are also generated above all exterior 
walls when the Raise Off Plate value in the 
Build Roof dialog is 3” (175 mm) or greater. 
See “Build Roof Dialog” on page 480. 

Attic Walls are often found on the Attic floor, 
but can be generated on other floors, as well. 
See “The Attic Floor” on page 444. 

Attic Walls are specified as such in the Wall 
Specification dialog; if automatically 
generated, that will be noted as well. If 
needed, you can specify a regular wall as an 
Attic Wall. If you specify a wall as an Attic 
Wall and it is currently on its default layer, it 
will be moved to the “Walls, Attic” layer, See 
“General Panel” on page 309.

When you Rebuild Walls/Floors/
Ceilings , all automatically generated 
Attic Walls in the plan are deleted and rebuilt 
unless Auto Rebuild Attic Walls is also 
checked in the General Wall Defaults dialog. 
See “General Wall Defaults” on page 260.

Removing Attic Walls
Occasionally, the program will generate an 
Attic wall where one is not wanted. There are 
several ways to address this:
• Turn off the display of the  layer that the 

Attic Wall is on.
• Specify the Attic Wall as Invisible. See 

“Room Dividers and Invisible Walls” on 
page 273.

• Select the Attic Wall and Delete  it. 
When Auto Rebuild Attic Walls is on, 
the program will specify the wall as Invis-
ible automatically. If you delete this Invis-
ible wall, a new Attic Wall will be 
created.

• Turn off Auto Rebuild Attic Walls in the 
General Wall Defaults dialog and then 

Delete  the wall.
• Combine the Attic Wall with the wall 

below. To do this, select Combine with 
Above Wall in the Wall Specification 
dialog for the wall below. See “Roof 
Panel” on page 314.

Knee Walls
Knee Walls are a bit like Attic Walls in that 
they are not meant to generate to full ceiling 
height. Instead, they build upward until they 
encounter a roof plane. Unlike Attic Walls, 
however, Knee Walls are used in the interior 
of a structure, typically to separate unused 
areas from rooms on the upper floor of a 
story-and-a-half structure. See “Room 
Types” on page 335.
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Chief Architect does not specify walls as 
Knee Walls automatically. If an interior wall 
is drawn in a location where the roof is lower 
than the ceiling height, you should specify it 
as a Knee Wall in the Wall Specification 
dialog. See “Roof Panel” on page 314.

For best results, Knee Walls should be drawn 
perpendicular to the pitch of the roof and 
should intersect with Full Gable Walls on 
each end. 

Stepped and Raked Walls
Stepped and raked walls can be created using 

the Break Line  tool and the wall’s edit 
handles in any 3D or Cross Section/Elevation 
view. In many cases, working in a Back-
clipped Cross Section  is easiest and 
allows the greatest accuracy.

Stepped Walls and Footings
A typical example of stepped walls is a 
stepped foundation with pony walls. In the 
illustration below, the lower part of the pony 
wall is the concrete wall with footing, and 
the upper part of the pony wall is a framed 
wall with brick siding built to the first floor 
platform. See “Pony Walls” on page 272. 

To add a step to a wall

1. Select the wall in a Backclipped Cross 
Section  view. 

2. Click the Break Line  tool, then 
click the top or bottom edge of the wall 
to place the break. 

3. In addition to the corner handles, two 
handles display along the broken edge. 

4. Select one of these two handles, and 
drag up or down.

5. A square step is created.

The vertical edges of a wall cannot be 
broken, although they can be raked as well as 
moved side to side.

By default, a stepped foundation wall  
displays an “S” symbol at the location of 
each step in floor plan view. The display of 
this “S” is controlled in the Foundation 
Defaults dialog. See “Foundation Panel” on 
page 449.

Raked Walls
A raked wall has an angled top or bottom 
edge. 

When you try to select a wall in a 3D
view, the interior or exterior room that it

defines may be selected first. Click the Select
Next Object edit button to select the wall
itself. See “Selecting Walls” on page 286. 
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To create a simple raked wall

1. Select the wall in Cross Section/Eleva-
tion or 3D view. 

2. Click one of the corner edit handles and 
drag that handle either up or down. 

3. To rake a wall at a specific angle, you 
can: 

•  Use Angle Snaps  and Allowed 
Angles. See “Angle Snaps” on page 
164.

•  Draw a CAD Line  at the desired 
angle and use the Make Parallel/
Perpendicular  edit tool. See 

“Using Make Parallel/Perpendicular” 
on page 227. 

Compound Raked Walls
A compound raked wall is a wall that has a 
top or bottom edge with multiple angles. 

To create a compound raked wall

1. Select the wall in Cross Section/Eleva-
tion or 3D view. 

2. Use the Break Line  tool to add 
breaks to the wall edge, as for a stepped 
wall. 

3. Select a segment of the edge and adjust 
its angle, as for a raked wall. 

Double Walls
Most wall assemblies can be modeled using a 
single wall type. In some situations, such as 
where the walls of two modular home units 
meet, two walls are drawn side-by-side. 
When two walls are both parallel and 
touching, they are referred to as Double 
Walls. 

There are three types of Double Walls in 
Chief Architect: Frame Through, Split 
Framing and Furred Wall. 

Frame Through
Frame Through walls can be considered the 
basic Double Wall type. A Frame Through 
wall could be used as a double wall between 
hotel rooms for sound insulation. 

Note: The Double Wall options are not
enabled for curved walls.
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By default, all walls are specified as Frame 
Through in the Wall Specification dialog. 
See “Structure Panel” on page 311.

Split Framing
Split Framing walls divide floor and ceiling 
platforms, as well as any walls they intersect. 
The split occurs at the boundary where the 
two double walls touch and is useful for 
separating modular home units.

Chief Architect frames walls and platforms 
separately on either side of the Split Framing 
wall boundary, with no framing members 
crossing it. 

You can make floor platform rim joists touch 
each other at the boundary between Split 
Framing walls or provide spacing to carry 
sheathing over them using the Build 
Platform to Exterior of Layer setting in the 
Wall Type Definitions dialog. See “Wall 
Type Definitions Dialog” on page 305. 

To create a pair of Split Framing walls, 
specify both walls as such on the STRUCTURE 
panel of the Wall Specification dialog. 

Furred Walls
The recommended method for creating 
furring is to simply add the required air gap, 
framing, and finish layers to the wall type of 
your choice. Alternatively, though, Double 
Walls can be used, with the inner wall being 
specified as a Furred Wall.

Furred Walls are placed against the inside 
of a primary wall, typically an exterior wall. 
An example is a concrete wall furred out by a 
framed wall with an air gap or insulation 
between them. 

Rooms are defined in the normal manner by 
the primary wall, but the layers of the Furred 
Wall are treated by the program as though 
they were added to the primary. An air gap 
between the primary and furred walls should 
be defined as a layer of one of the walls, 
usually the furred wall. 

As with Frame Through walls, Furred Walls 
do not split platforms or connected walls.  
Unlike Frame Through walls, they do not 
connect or frame to non-parallel walls like 
normal walls. Instead, they will connect to 
other Furred Walls. 

To create a Furred Wall, specify the primary 
wall as a Frame Through wall and the 
furred wall as a Furred Wall on the STRUC-
TURE panel of the Wall Specification dialog.

Openings in Double Walls
Doors and windows placed in one Double 
Wall extend through both walls. You can 
specify how an opening builds through the 
Double Walls on the CASING panel of either 
the Door or Window Specification dialog. 
See “Door Specification Dialog” on page 
374 or “Window Specification Dialog” on 
page 406. 

CAD to Walls
The CAD to Walls tool can be used to 
convert CAD lines in floor plan view 

into architectural objects. Two or more 

parallel CAD lines can be converted to both 
straight or curved walls or rails. CAD lines 
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representing windows and doors can also be 
converted. 

All lines that you want to convert to walls 
must be located on one layer. The same is 
true for windows, doors, and rails. It may be 
helpful to place like items on a single layer 
with unique layer attributes. See “Layer 
Display Options Dialog” on page 149. 

To convert the lines of an imported drawing 

using CAD to Walls , map its layers in 
the Import Drawing Assistant. Do not 
convert lines with shared endpoints to either 
Boxes or Polylines. See “Select File” on 
page 1172. 

To convert to a specific wall type, the lines 
representing the wall’s surfaces must be 
within one inch or 25mm of that wall type’s 
width. If two wall types are specified, new 
walls are assigned the type having the closest 
width. 

When CAD objects are located properly, 

select CAD> CAD to Walls  to display 
the Convert CAD to Walls dialog.

Convert CAD to Walls Dialog

Set Layers - From the drop-down lists, 
select the source layers of lines to be 

converted to walls, windows, doors, and 
rails.
• Click Define to open the Layer Display 

Options dialog.
Set Wall Types - Specify the wall types 
for the new walls. 

If the distance between the surface lines is 
less than the total width of the specified wall 

For best results, delete any wall lines
or polylines located between interior

and exterior wall surface lines before using
Convert CAD to Walls. 

1 Note; If the same layer is specified as the
Wall Layer and Rail Layer, all eligible walls
will be converted into railings. 

2
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type,a copy of that wall type will be created. 
The width of its Main Layer will adjust so 

that the overall width is equal to the specified 
wall’s Main Layer.

Click OK to complete the conversion. 

Wall Type Definitions
Every wall drawn in a plan is assigned a wall 
type, and its Wall Type Definition determines 
its structure, its appearance in floor plan 
view, and its default materials. Wall types 
can be viewed, edited, and created in the 
Wall Type Definitions dialog. See “Wall 
Type Definitions Dialog” on page 305. 

Walls can have up to ten layers defined, each 
representing a different material. All of these 
layers can be calculated in the Materials List. 
The materials assigned to the surface layers 
of the wall type definition also determine the 
wall’s appearance in 3D views. See 
“Materials Lists” on page 1283.

A wall type is considered to be:
• “Framed” if it has a Main Layer with the 

Framing material type;
• “Concrete” if it has a Main Layer with the 

Concrete material type;
• “Masonry” if it has a Main Layer with the 

Brick material type. 

See “Material Types” on page 860.

You can specify the default wall type that is 
drawn by each Wall Tool and can specify the 

wall type of any wall after it is drawn in the 
Wall Specification dialog. See “Wall, 
Railing, and Fencing Defaults” on page 260 
and “Wall Types Panel” on page 319.

Wall types are plan specific, which means 
that wall types available in one plan file may 
not be available in other plans. You can, 
however:
• Export and import wall types. See 

“Exporting and Importing Wall Types” on 
page 308.

• Add a wall to the library for use in other 
plans. See “Add to Library” on page 829.

The Main Layer
In most circumstances, each wall type’s 
Main Layer should be specified as the 
structural layer. The Main Layer determines 
many things, including:
• Floor and ceiling platforms and automati-

cally built foundation walls normally 
build to the outer edge of the Main Layer.

• The Main Layers of exterior walls build 
through slab floors while interior wall 
layers stop at the slab surface.

• At intersections, walls join at the interior 
surfaces of their Main Layers. See “Con-
necting Walls” on page 279. 

• Windows are placed relative to the outer 
surface of the outermost Main Layer.

Wall framing will only generate in a wall
when a Framing material such as Fir

Stud 16” OC or Metal Stud 24” OC is speci-
fied for its framing layer. See “Material Types”
on page 860.
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• Exterior walls on different floors are 
aligned by the exterior edges of their 
outermost Main Layer. 

• Roof baselines are placed at the outer 
edge of the outermost Main Layer when 
roofs are automatically generated. See 
“The Baseline” on page 489.

• Roof baselines and gable/roof lines that 
are manually drawn snap to the outermost 
edge of the Main Layer. 

• By default, walls resize about the exterior 
surface of their Main Layers when their 
thickness, wall type, or Wall Type Defini-
tion is changed. See “Resize About” on 
page 292. 

• Object Snaps  locate the interior and 
exterior edges of a wall’s Main Layers. 
See “Object Snaps” on page 162. 

All of this information is reliant on the Main 
Layer, so creating your wall type definitions 
accurately beforehand and specifying the 
Main Layer correctly is very important.

Multiple Main Layers
In standard light frame construction, walls 
build to one another’s framing layers, and 
floor and ceiling platforms are built to bear 
over the wall framing; however, some 
building techniques configure these 
components in other ways. You can control 
how walls of a given type are intersected, 
and also where platforms build to, by 
specifying multiple Main Layers.

By default, when multiple Main Layers are 
specified:
• Intersecting walls build to the interior sur-

face of the innermost Main Layer. 

• Floor platforms build to the exterior sur-
face of the outermost Main Layer.

• A selected wall’s edit handles display 
along the exterior of the outermost Main 
Layer.

• The exterior surface of the outermost 
Main Layer is the Dimension Layer 

See “Wall Type Definitions Dialog” on page 
305.

The Dimension Layer
Dimension Defaults can be set to locate walls 
at their surfaces or at the exterior line of their 
Wall Dimension Layer. See “Locate Objects 
Panel” on page 992. 

For installed wall types, the default Wall 
Dimension layer is the Main Layer; however, 
this can be changed in the Wall Type 
Definitions dialog. In addition to the Wall 
Dimension Layer, dimensions can locate the 
inside surface of the Main Layer, as well. 

Whether Surface or Wall Dimension Layer is 
selected on the LOCATE OBJECTS panel of the 
Dimension Defaults dialog determines a 
number of aspects related to how dimensions 
locate walls:
• How Auto Exterior and Manual Dimen-

sions measure the lengths of walls.
• Where both Manual and Automatic Reach 

are measured from.
• Where Extension line lengths and their 

Gap From Marked Object are measured 
from.

• Where First Line Offset for Auto Exte-
rior Dimensions  is measured from.
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• How the minimum enclosed area required 

by Auto Exterior Dimensions  is 
measured.

The settings on the LOCATE OBJECTS panel 
control how dimensions initially locate 
walls. Once a dimension line has been 
created, you can move its extension lines or 
add new extensions to locate other points 
along a wall’s assembly. See “Measuring 
Walls” on page 284.

Interior and Exterior Surfaces
Every wall has an interior and exterior 
surface - including walls in a plan that are 
recognized by the program as being interior 
walls. See “Exterior and Interior Walls” on 
page 269.

Having separate designations for a wall’s two 
surfaces allows you to specify different 
materials for each in the Wall Specification 
dialog. See “Materials Panel” on page 322.

It also allows you to specify which direction 
Wall Detail views face. See “In Wall Detail 
Views” on page 605. 

In the Wall Type Definitions dialog, the 
exterior surface is shown at the top of the 
Wall Layers table. In floor plan view, you 
can identify a selected wall’s exterior surface 
by the location of its edit handles, which 
display on the exterior of the Main Layer by 
default. See “Resize About” on page 292.

Legacy Wall Types
In Chief Architect version X2 and prior, 
generic, single-layer wall types were used as 
the default for railings, deck railings and 
fencing. In the earliest program versions, 
they were the defaults for walls, as well. 

• In Chief Architect X1 and prior, there 
were two such wall types: “Default (wood 
frame 16”OC)” and “Default (concrete)”. 

• In Chief Architect X2, these two wall 
types were replaced by one named 
“Adjustable Thickness Wall”. 

When plans that include either of these wall 
types - in the drawing itself or set as a default 
- are opened in Chief Architect X8, the 
legacy wall type is replaced by a new wall 
type named “Wall-X”, where X is the 
thickness of the wall’s Main Layer, rounded 
up. There are a few exceptions:
• If legacy wall types with the same thick-

ness but different materials are found, 
they use the same naming convention 
appended with an additional _X. 

• If a wall using a legacy wall type is speci-
fied as a Foundation wall, the resulting 
wall type will be named “Foundation 
Wall-X”. 

• If a legacy wall type has the same attri-
butes as a wall type installed with Chief 
Architect X8, such as 8” Concrete Stem 
Wall, it will be replaced by that wall type. 

Unless a wall is specified as a Foundation 
wall, Deck Railing, or Fencing, it will be 
treated as a framed wall and its new wall type 
will acquire two additional 1/2” (13 mm) 
thick wall layers: an interior and an exterior 
layer. These new layers will use the interior 
and exterior materials of the original wall. 
The wall’s original layer will maintain its 
original thickness, acquire a framing 
material, and will become the new wall 
type’s Main Layer.

Foundation, Deck Railing, and Fencing wall 
types converted in this manner will continue 
to have only one layer.
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Wall Type Definitions Dialog
The Wall Type Definitions dialog is 
used to define new wall types and 

redefine existing wall types in the current 
plan file. Select Build> Wall> Define Wall 
Types to open this dialog. 

You can also click the Define button on the 
WALL TYPES panel of the Wall Specification 
dialog or in most Wall Defaults dialogs. See 
“Wall Types Panel” on page 319.

Changes made to an existing wall type 
definition affect all walls in the current plan 
using that wall type. Walls in other plan files 
are unaffected.

If changes to a wall type affect its thickness, 
the position of any walls in the plan using 
that wall type may be affected. See “General 
Wall Defaults” on page 260.

Manage the list of wall types available 
in the current plan.

• Click the drop-down list to display all 
wall types in the current plan. Select a 
wall type from the list to display its defi-

nition. You can rename a wall type by 
typing in a new name. Note that wall type 
names in a plan must be unique.

• To create a new wall type, click New to 
define a new wall type from scratch or 

1
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click Copy to copy the current wall type. 
A copied wall type can then be renamed 
and redefined. 

• Click Rename to rename an existing wall 
type, or simply click on its name and type 
a new name. 

• To remove a wall type from the current 
plan, select it and click Delete. Wall types 
that are in use or set as plan defaults can-
not be deleted.

The selected wall type’s Wall Layers 
are listed here. Wall layers are listed 

from exterior at the top to interior at the 
bottom. The last item listed is the interior 
surface line rather than a true layer. 
• The list is divided into three sections: 

Exterior, Main, and Interior Layers. To 
move a layer from one section to another, 
use the Move Up and Move Down but-
tons to the right.

• A wall type’s thickest structural layer is 
typically set as the Main Layer; however, 
multiple Main Layers can be specified. 
See “The Main Layer” on page 302.

• Click in either the Pattern or Texture col-
umn to open the Select Material dialog 
and choose a material for the selected 
wall layer. See “Select Library Object 
Dialog” on page 838.

• Click in the Fill column to open the Layer 
Fill Style dialog and specify a fill style for 
the selected wall layer. This dialog is sim-
ilar to the FILL STYLE panel for CAD 
objects. See “Fill Style Panel” on page 
1099. 

• Click in the Thickness column to type the 
selected layer’s thickness, or depth. Very 
thin layers can be created, but for best 
results, avoid using a thickness of 0. The 

number format can be changed by click-
ing the Number Style button. 

• A checkmark in the Ins column means 
that the selected layer will Auto 
Detail  as Insulation in cross section/
elevation views. Click in this column to 
place or remove the checkmark. See 
“Auto Detail” on page 905. 

The buttons on the right side of the table 
allow you to reorganize the wall type 
definition’s layers.
• Click the Insert Above button to create a 

new layer directly above, or outside, the 
selected layer in the wall type definition. 
The new layer is a copy of the original. 

• Click the Insert Below button to create a 
new layer directly below, or inside, the 
selected layer in the wall type definition. 
The new layer is a copy of the original.

• Click the Move Up button to swap the 
selected layer’s position with that of the 
layer immediately outside of it or to move 
it into the layer section directly outside of 
it. Not available for the outer-most layer 
or for a single Main Layer. 

• Click the Move Down button to swap the 
selected layer’s position with that of the 
layer immediately inside of it or to move 
it into the layer section directly inside of 
it. Not available for the inner-most layer 
or for a single Main Layer. 

• Click Delete to remove the selected layer 
from the wall type definition. 

• The Total Thickness of the wall assem-
bly displays here. If you change this 
value, the thickness of the Main Layer 
automatically updates to account for the 
difference.

2
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Specify the attributes of the Selected 
Wall Layer Line, which is the line 

defining the selected layer’s exterior.
• Define the Color, Style, and Weight for 

the selected Wall Line. 
• Check By Layer if you want the line to 

assume the attributes of the wall’s layer as 
defined in the Layer Display Options 
dialog. See “Displaying Objects” on page 
144. 

• Click the Library button to select a Line 
Style from the Library. See “Line Styles” 
on page 1108. 

Wall layer fill styles are overridden if you 

use the Hatch Wall  tool on a wall in 
floor plan view. See “Hatch Wall” on page 
275. 

Specify the attributes of the Selected 
Wall Layer.  

• Specify the Brick Ledge Depth, which is 
the vertical depth of the brick ledge under 
walls of this type when a Brick material 
Type is specified for the exterior layer and 
a monolithic slab foundation is built. See 
“Brick Ledges” on page 270. 
By default, the Brick Ledge Depth is 
equal to the Height value of the Brick 
material. See “Material Types” on page 
860.

• Build Platform to Exterior of Layer - 
Select a wall layer from the drop-down 
list to build floor and ceiling platforms to. 
By default, the exterior side of the outer-
most Main Layer is selected. 

• Dimension to Exterior of Layer  - Select 
the wall type’s Dimension Layer from the 
drop-down list. By default, the outermost 
Main Layer. is selected. This setting does 
not affect Interior Dimensions. See “The 
Dimension Layer” on page 303.

• Foundation to Exterior of Layer - 
Select a wall layer from the drop-down 
list to align the Main Layer of a founda-
tion wall or slab footing on the floor 
below to. By default, the outermost Main 
Layer is selected. See “Aligning Founda-
tion Walls” on page 458. 

• Foundation Offset - Specify how far to 
offset the Main Layer of a foundation 
wall on the floor below relative to the 
Foundation to Exterior of Layer selected 
above. A positive value offsets toward the 
exterior; a negative value offsets toward 
the interior. 

Specify the selected wall type’s Energy 
Values. This information is used when 

exporting to REScheck. See “Export to 
REScheck” on page 1192.
• Select a Wall Type from the drop-down 

list. When “Framed” is selected, the on 
center spacing is derived from the mate-
rial definition of the wall’s framing layer. 
See “Material Types” on page 860. 

• Specify a Cavity R-Value for the selected 
wall type definition. 

• Specify a Continuous R-Value.for the 
selected wall type definition.

A preview of the selected wall type 
definition displays here. See “Dialog 

Preview Panes” on page 41.
• When the selected preview type is a 3D 

view, a gap is shown between each of the 
wall layers in the preview. Click the 

Note: If Build Platform to Exterior of Layer is
set to the exterior wall layer, no siding mate-
rial will generate to cover the floor platform. 

3
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Explode Layers  button remove or 
restore these gaps.

• When Plan View is the selected preview 

type, click the Line Weights  button to 

toggle the display of the wall layer and 
pattern line weights, or thicknesses. See 
“Line Weights” on page 1223.

Exporting and Importing Wall Types
Wall type definitions created in 
one plan can be exported as a .dat 

file and imported into other plans. This is a 
convenient alternative to re-creating one or 
more wall type definitions that already exist 
in another plan. 

The wall type definitions available to export 
from the current plan are listed in the Wall 
Type Definitions dialog. See “Wall Type 
Definitions Dialog” on page 305.

Exporting Wall Types
To export wall type definitions from 
the current plan file, select File> 

Export> Export Wall Definitions. 

The Export Wall Definitions File dialog is a 
typical Save As dialog. Exported wall types 
are saved using the .dat file extension. See 
“Exporting Files” on page 58.

Importing Wall Types
To import wall type definitions into 
the current plan or layout, select File> 

Import> Import Wall Definitions.

The Import Wall Definitions File dialog is a 
typical Open File dialog. See “Importing 
Files” on page 62.

When wall type definitions are imported, the 
names of the wall type definitions in the .dat 
file are compared with those already present 
in the current plan. If the program finds 
identical names, it will ask you if you want to 
replace existing wall definitions with the 
same name. Click Yes to replace existing 
files in the plan file, or No to keep the 
definitions already in the plan. 

Wall Specification Dialog
To open the Wall Specification 
dialog, select a wall or group of walls 

and click the Open Object edit button. 

The panels of the Wall Specification dialog 
are also found in the Footing, Railing, Deck 

Railing, and Fencing Specification dialogs. 
See “Railing and Fencing Specification 
Dialogs” on page 322. 

The settings in this dialog are also similar to 
those in the various Wall Defaults dialogs. 

Wall type definitions that you use often
should be saved in your default tem-

plate plan. See “To create your own template
plan” on page 85.
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The settings in these defaults dialogs 
determine the initial characteristics of 
railings, deck railings, foundation walls and 

footing walls, and fencing when they are first 
drawn. See “Wall, Railing, and Fencing 
Defaults” on page 260.

General Panel
The settings on the GENERAL panel 
determine the basic use of the selected wall, 

as well as its length, angle, and other 
attributes.

Specify General  properties of the 
selected wall(s) or railing(s). 

• Check Foundation Wall to specify the 
selected wall as a foundation wall. More 
foundation wall settings are available on 

the FOUNDATION panel. See “Foundation 
Walls” on page 265. 

• Check Railing to specify the selected 
wall as a railing. More railing settings are 

1
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found on the RAILING, NEWELS/BALUS-
TERS, and RAILS panels. 

• Check Terrain Retaining Wall to treat 
the selected wall as a terrain retaining 
wall. See “Retaining Walls” on page 728. 

• Check Attic Wall to prevent the selected 
wall from extending through the roof 
above. See “Attic Walls” on page 297.

• The Thickness of the selected wall dis-
plays and can be changed here. If the wall 
is a Post to Overhead Beam railing, this 
setting can also affect the width of the 
beam. See “Wall Thickness” on page 287. 

• Wall Angle - The current absolute angle 
of the wall in a floor plan view is shown. 
If you type in a new angle, the wall rotates 
about its locked point and any walls 
attached to it will not move. If the 
selected wall is curved, this value 
describes the angle of the chord and can-
not be modified. See “3D Drafting” on 
page 31.

• Wall Length - The current length, as 
measured along the Resize About line, is 
shown. If you type a new length, the wall 
will extend or contract according to how 
it is locked. Any walls attached to the 
selected wall will not move. If the 
selected wall is curved, this value cannot 
be modified. See “Resize About” on page 
292. 

• Select a radio button to Lock the selected 
straight wall at its Start, End or Center. 
When the Wall Angle or Wall Length of 
the selected wall is changed, this point 
along the wall does not move. Not avail-
able for curved walls. 

Check any of the Options to modify the 
selected wall accordingly. In most 

cases, multiple options can be selected. 
• Check Invisible to specify the wall as 

invisible. Invisible walls can display in 
floor plan view but not in 3D views or the 

Materials List. Room Dividers  are 
invisible by default. See “Room Dividers 
and Invisible Walls” on page 273. 

• Check No Room Def. to display the wall 
in floor plan and/or 3D views but not cre-
ate room definition. See “Room Defini-
tion” on page 331. 

• Check No Locate to prevent Auto Exte-
rior Dimensions  from locating the 
wall in floor plan view. See “No Locate” 
on page 285.

• Automatically Generated Wall displays 
for reference and is checked whenever the 
selected wall was generated by the pro-
gram. Typically, automatic walls are also 
Attic walls.

• Select Lock Center to prevent the arc 
center of a selected curved wall from 
moving when the wall is edited using its 
edit handles. Not available for straight 
walls. 

The Curved Wall settings control the 
definition of a selected curved wall’s 

radius and are only available when the 
selected wall is curved. 
• Select Outer Surface to measure the 

selected wall’s radius from its center point 
to its outer surface.

• Select Main Layer Outside to measure 
the radius from the wall’s center point to 
the outside of its Main Layer. See “The 
Main Layer” on page 302.

2

3



Wall Specification Dialog

 311

• Select Main Layer Inside to measure the 
radius from the wall’s center point to the 
inside of its Main Layer.

• Select Inner Surface to measure the 
radius from the wall’s center point to its 
inner surface.

• Specify the selected wall’s Radius, as 
defined by the radio button selected 
above. 

• Select Lock Center to move the selected 
wall’s ends and prevent its center point 
from moving when its Radius is changed. 

• Select Lock Ends to move the selected 
wall’s center point and prevent its ends 
from moving when its Radius is changed. 

• Uncheck Automatic Facet Angle to 
specify the Facet Angle, which is the 
angle at which the surfaces of the curved 
wall are broken in 3D views. The default 
value is 7.5°; a smaller value produces a 
smoother curve but may take longer to 
generate in 3D views. 

If the selected wall has any Copyright 
information associated with it, it will 

display here.

A preview of the selected wall, 
including any doors, windows, and/or 

fireplaces inserted into it, displays on the 
right. If the selected wall is specified as 
Invisible, its plan view will display here by 
default. See “Dialog Preview Panes” on page 
41. 

Structure Panel
The settings on the STRUCTURE panel control 
the height and other structural attributes of 
the selected wall(s).

4
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The Default Wall Heights settings 
allow you to reset a wall’s default top 

and bottom heights if they have been 
manually edited. See “Wall Heights” on page 
288. 
• Default Wall Top Height and Default 

Wall Bottom Height are only enabled if 
the selected wall’s top and/or bottom 
height has been edited. Check these boxes 
to restore the default heights. 

The Platform Intersection settings 
control the relationship between the 

selected wall and the floor and ceiling 
platforms above and below it. 
• Select Stop at Ceiling Above to have the 

top of the wall stop at the bottom of the 
ceiling platform above.

• Select Balloon Through Ceiling Above 
to have the top of the wall go past the ceil-
ing platform. If there is a wall directly 
above, the framing will continue upward 
to its bottom plate. The two walls remain 
separate objects on different floors, how-

1

2



Wall Specification Dialog

 313

ever, unless the wall above is an Attic 
Wall. Does not affect interior walls. 

• Select Hang Floor Platform Above on 
Wall to produce a platform that hangs on 
the inside of the selected wall rather than 
bearing on top of it. When checked, the 
two options that follow are available.

• Select Subflooring to Interior Wall to 
hang the platform on the inside surface of 
the wall. When unchecked, the platform 
builds to the inside surface of the wall’s 
Main Layer. See “The Main Layer” on 
page 302. 

• Select Include Ledger to hang the plat-
form from a ledger board attached to the 
wall. When unchecked, no ledger is cre-
ated when platform framing is generated. 
See “Floor and Ceiling Framing” on page 
578. 

• Select Stop at Floor Below to have the 
bottom of the wall stop at the top surface 
of a floor platform. This is the default for 
framed wall types. 

• Select Go Through Floor Below to have 
the bottom of the wall go through the 
floor platform below. This is the default 
for concrete wall types. If the wall is 
framed and there is a framed wall directly 
below, the studs of the wall below will 
extend up produce balloon framing. Does 
not affect interior walls. 

• Select Generate Between Platforms to 
fill in the gap between floor and/or ceiling 
platforms when the selected railing or 

invisible wall separates rooms with differ-
ent floor and/or ceiling heights. When 
unchecked, this gap is not closed. Only 
available for railings, Invisible railings, 
and Invisible walls, this setting has no 
effect when the selected wall type has 
only one layer. See “Floor and Ceiling 
Platforms” on page 344. 

The Wall Intersection settings control 
whether the selected wall builds 

through wall corners at its Start and End 
points. The display of Start and End 
Indicators can be turned on or off in the 
Preferences dialog. See “Edit Panel” on 
page 111. 
• Select Through Wall at Start to build the 

wall through the wall corner located at its 
start point.

• Select Through Wall at End to build the 
wall through the wall corner located at its 
end point. 

• When neither box is checked, the program 
will determine whether the wall builds 
through the corners at each of its end-
points. 

Specify the number of Rim Joists for 
the floor platform below the selected 

wall(s). See “Framing” on page 577.
• Select Single or Double to generate one 

or two rim joists, respectively. 
• Select Automatic to generate two rim 

joists if there is no wall below the selected 
wall, and one rim joist when there is a 
wall below. Automatic produces a single 
rim joist for Deck Railing.

The Double Wall options specify how 
a selected straight wall frames when it 

is parallel to and touching a second wall. See 
“Double Walls” on page 299.

Note: Whether a wall is a framed or concrete
type is determined by the material assigned
to its Main Layer. See “Wall Type Definitions
Dialog” on page 305.

3
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These settings are only available for straight 
walls.
• Select Frame Through to create a basic 

double wall.
• Select Split Framing to create a double 

wall that splits platforms and connecting 
walls at its boundary.

• Select Furred Wall to treat the selected 
wall as additional layers added to another 
wall. 

Framing - 

• Check Retain Wall Framing to preserve 
the framing of the selected wall when the 
wall framing is globally rebuilt. See 
“Keeping Framing Current” on page 608. 

• Check Bearing Wall to produce joists 
that either butt or lap over the selected 
wall when floor or ceiling framing is gen-

erated. See “Floor and Ceiling Framing” 
on page 578.

• Check Create Wall/Footing Below to 
create a stem wall or slab footing below 
the selected wall on Floor 1 when an auto-
matic foundation is built. Has no effect if 
the selected wall is on any floor other than 
Floor 1. See “Building a Foundation” on 
page 452.

If Create Wall/Footing Below is checked, 
Foundation Wall and Slab Footing will 
become unchecked on the Foundation Panel.
• Check Stagger Multiple Framing Lay-

ers to produce wall studs that are offset 
from one another when wall framing is 
created. This setting only has an effect if a 
wall type with multiple Framing layers is 
specified. See “Wall Type Definitions 
Dialog” on page 305.

A preview of the selected wall, 
including any doors, windows, and/or 

fireplaces inserted into it, displays on the 
right. See “Dialog Preview Panes” on page 
41. 

Roof Panel
Any automatically generated roof style other 
than a hip requires roof information to be 
defined in the exterior walls. On the ROOF 
panel, you can specify how the selected wall 

interacts with the roof plan, defining the 
portion of the roof plan that bears on it. See 
“Automatic vs. Manual Roofs” on page 474.

Note: The Double Wall options are not avail-
able for curved walls. 

6
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Roof Options - Specify the shape of 
the wall relative to the roof. 

• Check Full Gable Wall to create a gable 
end over the selected wall. 

• Check High Shed/Gable Wall to specify 
the selected wall as the high end of a shed 
roof. 

• Check Knee Wall to define the selected 
interior wall as a knee wall. Only an inte-
rior wall can be defined as a knee wall. A 
knee wall’s height is defined by the roof 

above, not the ceiling height. See “Knee 
Walls” on page 297.

• Check Extend Slope Downward to con-
tinue a roof down over a bump out in an 
exterior wall. See “Extend Slope Down-
ward” on page 295. 

• Check Roof Cuts Wall at Bottom to pre-
vent the portion of a selected wall located 
below an intersecting roof plane from 
building. 

• Combine with Above Wall is only avail-
able when a selected wall has an Attic 

1
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wall above it. Check this box to balloon 
frame the two walls when automatic 
framing is built. The two walls remain 
separate objects. See “Attic Walls” on 
page 297. 

Pitch Options - Specify the pitch or 
pitches of the roof plane(s) above the 

selected wall.
• Enter a value to define the Pitch of the 

roof plane bearing on the selected wall. 
• Check Upper Pitch to create a roof with 

two pitches or, if the selected wall is a 
Full Gable Wall, a half hip condition.

• Enter the Pitch of the second, upper roof.
• Specify the Height that the Upper Pitch 

Starts at, or define the distance in from 
Baseline that the second pitch begins. The 
two values are dynamic. Press the Tab key 
to update the relative numbers.

Specify the Overhang Length, which 
is the horizontal distance from the 

baseline to the eave. See “The Baseline” on 
page 489.

Check Auto Roof Return to generate 
roof returns on the selected wall. In 

most cases, roof returns only work for Full 
Gable Walls. See “Roof Returns” on page 
527.

• Specify the horizontal Length of the roof 
return in inches (mm).

• Enter a value in inches (mm) to Extend 
the roof returns past the overhang. 

• Specify a Gable, Hip, or Full roof return. 
• Specify a Sloping or Flat roof return. See 

“Roof Tutorial” on page 63 of the User’s 
Guide.

• Check the boxes to  Include Shadow 
Boards, Ridge Caps, Frieze molding, 
and/or Gutters on the roof returns.

Check Lower Wall Type if Split by 
Butting Roof to specify the wall type 

for any portion of the selected wall located 
beneath an adjacent, abutting roof plane, 
should one be present. A wall affected by this 
setting is specified as a Pony Wall and the 
upper wall is defined on the WALL TYPES 
panel. See “Exterior/Interior Pony Walls” on 
page 296. 

A preview of the selected wall, 
including any doors, windows, and/or 

fireplaces inserted into it, displays on the 
right. See “Dialog Preview Panes” on page 
41. 

2
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Additional information about using the
settings on this panel can be found in
the “Roof Tutorial” on page 63 of the

Reference Manual. 
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Foundation Panel

Specify the Foundation properties of 
the selected wall(s).

• Check Foundation Wall to specify the 
selected wall as a foundation wall and 
enable additional settings on this panel. 
This box is checked by default for auto-
matically generated foundation walls as 
well as walls drawn with the Foundation 
Wall  and Slab Footing  tools.

• Check Slab Footing to specify the 
selected wall as a slab footing. See “Foun-
dation Walls” on page 269. When this is 
checked, Foundation Wall will also be 
checked.

• The Thickness of the selected wall dis-
plays and can be changed here. 

• If Slab Footing is checked, the Curb 
Width can be specified instead. 

Check Footing to assign a concrete 
footing to the selected wall(s) and 

enable the settings below. Only available 
when Foundatoin Wall is checked, above.

1 Note: Rooms defined by walls drawn using
the Slab Footing tool will have a Ceiling
Height of 0 and a Monolithic Slab Foundation.
Rooms defined by walls that are later speci-
fied as Slab Footings will not unless the room
is on Floor 0 and the plan has a Monolithic
Slab foundation specified.

2
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• Specify the Width and Height of the 
footing below the selected foundation 
wall(s). The Height value will be unavail-
able if the bottom height of the footing 
has been edited. See “Stepped Founda-
tions” on page 462.

• Check Automatic Footing Bottom 
Height to restore the default height of the 
selected wall’s footing. Only available 
when the footing bottom height has been 
edited.

• Check Vertical Footing to generate foot-
ings that run up and down along any steps 
in the foundation wall’s bottom height. 

Offset - Specify how the footing is centered 
under the selected wall.
• Check Center Footing on Main Layer to 

center the footing on the wall’s Main 
Layer. See “The Main Layer” on page 
302. 

• Check Align Footing on Outside to align 
the footing along the wall’s exterior sur-
face.  See “Wall Type Definitions” on 
page 302. 

• Specify the Footing Offset, which is the 
distance between the center of the footing 

and the center of the wall. A value of 0 
centers the footing under the wall. A posi-
tive value offsets the footing towards the 
wall’s interior surface. A negative value 
offsets it towards the wall’s exterior. Not 
available if either Center Footing on Main 
Layer or Align Footing on Outside are 
checked. 

Specify how Monolithic Slab footings 
generate. These settings apply only 

when the selected wall defines the side of a 
Monolithic Slab. See “Foundations” on page 
447.
• Specify the Chamfer Width and Height, 

which define the angled corners where the 
footing meets the underside of the slab. 

• Specify the Pour Number of the selected 
Slab Footing. Pour Numbers are listed 
separately in the Materials List. See “In 
the Materials List” on page 455.

A preview of the selected wall, 
including any doors, windows, and/or 

fireplaces inserted into it, displays on the 
right. See “Dialog Preview Panes” on page 
41. 

3
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Wall Types Panel

Choose the selected wall’s Wall Type 
from the drop-down list of all currently 

available types. A preview of the selected 
wall type displays below the drop-down list.
• Click the Define button to open the Wall 

Type Definitions dialog to create or mod-
ify existing wall types. See “Wall Type 
Definitions Dialog” on page 305.

Check Pony Wall to specify the 
selected wall as a pony wall having 

different wall types on its upper and lower 
portions. See “Pony Walls” on page 272. 

If the selected wall is a Foundation Wall, its 
initial wall type will become the Lower Wall 
Type. For all other walls, the initial wall type 
will be the upper Wall Type.

• Select the Lower Wall Type, the wall 
type of the lower portion of the pony wall, 
from the drop-down list. A preview of the 
selected wall type displays directly below.

• Click the Define button to open the Wall 
Type Definitions dialog. 

Specify the height of the division between 
the upper and lower walls. These two 
settings are dynamic: if one is changed, the 
other will update accordingly. 
• Specify the Elevation of Lower Wall 

Top, which is the division between the 
upper and lower walls. If the top of the 
lower pony wall is stepped or raked, this 
value will be “No Change”. This is an 
absolute value: regardless of the wall’s 

1
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location, it is always measured from 0” 
(mm) - the default floor height for Floor 
1. See “Floor Defaults Dialog” on page 
436. 

• Specify the Height Off Floor of the divi-
sion between the upper and lower walls. 
This value is measured from the floor 
height of the room(s) defined by the 
selected wall. If the wall defines rooms 
with different floor heights, “No change” 
will display. 

Align Pony Walls - Specify how the layers 
of the selected wall’s Upper and Lower 
portions align. 
• Select Outer Surface to align wall types 

at their outer surfaces.
• Select Main Layer Outside to align wall 

types at the exterior edge of their main 
layers.

• Select Wall Center to align the centers of 
the main layers of both wall types.

• Select Main Layer Inside to align the 
wall types at the interior side of their main 
layers.

• Select Inner Surface to align wall types 
at their interior surfaces.

• No Change is used by default when mul-
tiple pony walls with different alignment 
settings are selected. Choose this to leave 
the alignment as it was when the dialog 
was opened. 

Specify which part of the pony wall you 
would like to Display in Plan View. See 
“Displaying Pony Walls” on page 272.
• Select Default to display the portion of 

the pony wall specified in the Pony Wall 
Defaults dialog. 

• Select Upper Wall to display the upper 
portion of this pony wall in floor plan 
view regardless of the default setting.

• Select Lower Wall to display the lower 
portion of this pony wall in floor plan 
view regardless of the default setting.

• When walls are group-selected, choose 
No Change to allow each wall in the 
selection set to maintain its own setting.

A preview of the selected wall, 
including any doors, windows, and/or 

fireplaces inserted into it, displays on the 
right. See “Dialog Preview Panes” on page 
41. 

Wall Covering Panel
The WALL COVERING panel is also available 
in the Room Specification dialog. See      
Room Specification Dialog. 

3
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All wall covering materials applied to 
the selected wall are listed here. Select 

one from the drop-down list to edit its 
position or remove it from the wall. 
• Click Add New to apply a new wall cov-

ering to the selected wall. See “Select 
Library Object Dialog” on page 838.

• Click Replace to replace the current wall 
covering with a new one from the library.

• Click Delete to remove the current wall 
covering from the selected wall.

Preview panes showing the current wall 
covering display the row of buttons. 

Specify the Position of the selected 
wall covering. 

• Enter the heights of the current wall cov-
ering’s Top To Ceiling and Floor To Bot-
tom. The wall covering’s Height from it’s 
top edge to its bottom edge can also be 
specified.

• Check Interior and/or Exterior to apply 
the wall covering to the inside and/or out-
side of the selected wall. Interior is 
checked by default. Not available for 
rooms.  See “Wall Type Definitions” on 
page 302.

Most wall coverings are best previewed  
using the Standard Rendering 

1 2
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Technique. See “Dialog Preview Panes” on 
page 41. 

Rail Style Panel
The settings on the RAIL STYLE panel are 
only available for Railings, Half Walls. See 
“Rail Style Panel” on page 323.

Newels/Balusters Panel
The settings on the NEWELS/BALUSTERS 
panel are only available for Railings, Half 
Walls. See “Newels/Balusters Panel” on page 
325.

Rails Panel
The settings on the RAILS panel are only 
available for Railings, Deck Railings, and 
Fencing. See “Rails Panel” on page 326.

Layer Panel
For information about the settings on this 
panel, see “Layer Panel” on page 154.

Materials Panel
All walls - including interior walls, railings 
and fencing - have an “Exterior Wall 
Surface” and an “Interior Wall Surface”. See 
“Interior and Exterior Surfaces” on page 304. 

The materials specified on the MATERIALS 
panel affect the appearance of walls and 
Solid Railings in 3D views but are not 
calculated in the Materials List. See 
“Materials Lists” on page 1283. 

For most railing types, the “Exterior Wall 
Surface” component only affects the 
appearance of the floor platform under the 
railing. and “Interior Wall Surface” 
component is not used. For fencing, neither 
material component is used. 

Railing and Fencing Specification Dialogs
To open the Railing or Fencing 
Specification dialog, select a railing 

or fencing, or a group of railings or fencing, 
and click the Open Object edit button. 

The Railing and Fencing Specification 
dialogs are the same as the Wall 
Specification dialog, but have three panels 

that apply only to Railings, Half Walls, Deck 
Railings, and Fencing. See “Wall 
Specification Dialog” on page 308. 

The RAILS panel is similar to the HANDRAIL 
panel found in the Staircase and Ramp 
Specification dialogs. See “Stairs, Ramps, 
and Landings” on page 533. 
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Rail Style Panel

Check Specify Railing to specify the 
selected wall as a railing and enable the 

other options on this panel. Railings can be 

also drawn directly using the Railing  or 

Deck Railing  tools.

Railing Type - Select the radio button for the 
desired railing type. A preview of the 
selected type displays to the left.
• Check Balusters to create regularly 

spaced balusters between larger newel 
posts. 

• Check Solid to create a solid railing or 
Half Wall. 

• Check Open to create a railing with only 
newel posts and top and bottom rails.

• Check Middle Rail to create a railing 
with newel posts and top, bottom, and 
middle rails.

• Check No Rail to eliminate rails, leaving 
only newels or posts and an overhead 
beam, if selected. 

• Check Panels to create a railing com-
posed of panels. You can specify the 
panel style on the NEWELS/BALUSTERS 
panel..

Specify the properties of the selected 
railing’s Newels/Posts.

• Check Post to Rail to create newel posts 
from the floor to the top rail. This option 
is selected by default.

• Check Post to Overhead Beam to create 
newel posts from floor to an overhead 
beam placed just under the ceiling height. 

1
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The beam’s width is based on the Thick-
ness of the selected railing wall.

• Check Post to Ceiling to extend the 
newel posts to the ceiling.

• When none of the above Post options is 
selected, newel posts will build to the top 
of the railing.

• Check No Half Post at Wall to prevent a 
half-width post from being placed when a 
railing intersects a wall.

• Check Square Half Post to use a square 
halfpost where a railing intersect with a 
wall. Not available if No Half Post at Wall 
is checked.

The Bottom Rail options control the 
placement of the bottom rail, or shoe. If 

neither box is checked, the bottom rail is 
placed at floor platform level. Not available 
for railings specified as Solid or No Rail. 
• Uncheck Include Bottom Rail to elimi-

nate the bottom rail and extend the balus-
ters to the floor. Also not available for 
Panel railings.

• Check Raise Bottom Rail/Panel, then 
specify the Floor to Bottom distance, 

measured up from the floor platform to 
the bottom rail or panel.

Specify where the selected railing or 
fencing should Build From. With the 

exception of Follow Stairs, these settings are 
not available for Solid railings. 
• Check Step Terrain to have the railing or 

fencing follow the terrain in horizontal 
steps between each newel post. 

• Check Follow Terrain to have the railing 
or fencing follow the terrain smoothly.

• Check Generate on Low Platform to 
build the selected railing on the lower 
floor platform when the railing defines 
two room areas with different floor 
heights. See “Aligning Railings on Differ-
ent Platforms” on page 294.

• Check Follow Stairs to have the railing or 
fencing follow the rise of stairs drawn in 
the same location. See “Solid Railings” 
on page 554 and “Railing Panels” on page 
555.

A preview of the selected railing or 
fence, including any doorways or gates 

inserted into it, displays on the right. See 
“Dialog Preview Panes” on page 41. 
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Newels/Balusters Panel

Specify the height of the Railing, as 
well as its appearance in plan view. 

• Specify the Railing Height. For interior 
railings, this is measured from the height 
of the floor finish. See “Floor and Ceiling 
Platform Definitions” on page 344. 

• Check Default to use the Draw Newels/
Balusters setting in the Railing Defaults 
dialog. Check Draw Newels/Balusters to 
draw newels and balusters in floor plan 
view.

Specify the characteristics of the 
selected railing’s Newels/Posts. 

• Specify the Width of each newel at its 
widest point.

• Specify the Height, which is the height 
from the floor or ground to the top of the 
newel. Not available if Post to Rail, Post 
to Overhead Beam or Post to Ceiling is 
selected on the RAIL STYLE panel.

• Specify the Offset, which is the amount 
each newel is offset from the center of the 

1 2



326

Chief Architect X8 Reference Manual

railing. Use this to create a fence with the 
newels on one side of the fence boards.

• Specify the on-center Spacing of the 
newel posts.

• Type - Select Square, Round, or Library 
newels.

Specify the characteristics of the 
selected railing’s Balusters. These set-

tings are only available when the railing type 
is “Balusters”. 
• Specify the Width or diameter of each 

baluster at its widest point. 
• Specify the on-center Spacing of the bal-

usters.
• Type - Select Square, Round, or Library 

balusters .

Specify the characteristics of the 
selected railing’s Panels. These settings 

are only available when the railing type is 
“Panels”. 
• Specify the panel’s Thickness.

• Panel Type is only available when the 
railing type has been specified as Panels 
on the RAIL STYLE panel. Select “Solid 
(No Rails)”, “Solid (With Rails)”, or 
“Library” to select a symbol to be used as 
a railing panel. 

The Plan Display settings control how 
newels, balusters, and rails display in 

floor plan view. See “In Floor Plan View” on 
page 281. 
• Uncheck Use Defaults to enable the set-

tings that follow. When this is checked, 
the settings in the Defaults dialog for the 
tool used to draw the selected railing are 
used. 

• Check Draw Newels to display newel 
posts in floor plan view. 

• Check Draw Balusters to display balus-
ters in floor plan view.

• Check Draw Rails to display the rails in 
floor plan view.

• Click the Fill Style button to open the Fill 
Style dialog and specify the fill style for 
newels, balusters, and/or rails, when set 
to display.

A preview of the selected railing or 
fence, including any doorways or gates 

inserted into it, displays on the right. See 
“Dialog Preview Panes” on page 41. 

Rails Panel
The settings on the RAILS panel are used to 
specify the style and size of the horizonal 
components of a selected Railing, Deck 
Railing, or Fence. See “Railing and Deck 
Tools” on page 266.

A similar panel is also found in the Staircase 
and Ramp Specification dialogs and has 
additional settings for handrails at walls. See 
“Handrail Panel” on page 569.

Note: Selecting Library from the drop-down
list is the same as clicking the Library button
to the immediate right and allows you to
select a symbol from the library. See “Select
Library Object Dialog” on page 838.
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Rail Specification - 
 

• Choose the Selected Profile from the 
drop-down list, then modify it using the 
settings below. Staircases and ramps can 
only be assigned a handrail, so they do not 
have a drop-down list. For railing and 
fencing, four profiles can be specified: 

• Top Rail - Creates a handrail or solid rail-
ing cap. A top rail is not created when No 
Rail is selected on the RAIL STYLE panel.

• Middle Rail - Is only created when Open 
with Middle Rail is selected on the RAIL 
STYLE panel.

• Bottom Rail - Is only created when Bal-
usters, Open, or Open with Middle Rail is 
checked on the RAIL STYLE panel.

• Beam - Is only created when Post to 
Beam is checked on the RAIL STYLE 
panel. 

The name of the rail profile assigned to each 
component displays in the drop-down list. If 
no handrail profile is selected, “Default 
Handrail” is used and a 2” (5 mm) square 
profile is used. 
• Click the Replace button to select a pro-

file from the library for the selected rail. 
See “Select Library Object Dialog” on 
page 838.

• Click the Default button to remove a cus-
tom rail that has been specified and use 
the “Default Rail”.

• Check Rotate Profile to rotate the 
selected railing profile 90° counterclock-
wise, or to the left.

Selected Profile Size - 
 

• Specify the Height and Width of the rail 
molding. Width is not available if Auto-
matic is checked. 

1
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• Check Automatic Width to make the rail 
Width equal to the Thickness of the 
selected railing wall. Not available for 
stairs or ramps. 

• Check Retain Aspect Ratio to retain the 
original ratio between the profile’s Height 
and Width values. When one value is 
changed, the other updates in response. 
Not available when Automatic Width is 
checked. 

• Specify the Repeat Distance of a selected 
symbol molding. Not available when a 
molding profile is selected. See “Symbol 
Moldings” on page 663. 

A preview of the selected railing or 
fence, including any doorways or gates 

inserted into it, displays on the right. See 
“Dialog Preview Panes” on page 41. 

Wall Hatch Specification Dialog
To open the Wall Hatch Specification 
dialog, select a Wall Hatch and click 

the Open Object edit button. See “Hatch 
Wall” on page 275.

Layer Panel
Specify the layer that the selected Wall Hatch 
is placed on. See “Layer Panel” on page 154.

Fill Style Panel
The FILL STYLE panel is found in the 
specification dialogs for many different 
objects. See “Fill Style Panel” on page 1099.
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Chapter 9:

Rooms

When walls or railings create an enclosed 
area, a “room” is created. You can select 
rooms defined in this manner like other 
objects in Chief Architect.

Rooms are assigned a Room Type. Each 
Room Type has predefined characteristics. 
For example, a room defined as Porch is 
assigned certain attributes that are different 
than a Kitchen. 

Floor and ceiling heights, baseboard, chair-
rail, and crown moldings and materials can 
be defined room-by-room or for the entire 
floor.

Chapter Contents
•      Floor and Room Defaults
•      Room Definition
•      Selecting Rooms
•      Displaying Rooms
•      Editing Rooms
•      Room Types
•      Room Labels
•      Decks
•      Floor and Ceiling Heights
•      Floor and Ceiling Platforms
•      Special Ceilings
•      Room Polylines
•      Room Specification Dialog
•      Room Finish Schedules
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Floor and Room Defaults
Select Edit> Default Settings to open 
the Default Settings dialog where 

you can access several defaults dialogs 
which directly affect rooms. 

Floor Defaults
Default values for rooms are specified in the 
Floor Defaults dialog for the current floor. 
This dialog also controls important 
information that the program uses to create 
3D models - particularly floor and ceiling 
heights and materials. Moldings can also be 
specified in the Floor Defaults dialog. 

The default Floor and Ceiling Structure and 
Finish definitions in the Floor Defaults 
dialog are drawn from the Normal Room 
Defaults. See “Floor and Ceiling Platforms” 
on page 344. 

Only the defaults for the first floor of a 
building can be set ahead of time. The 
program uses the setting from the first floor 
to create subsequent floors. Once a new floor 
is built, its floor defaults can be changed. See 
“Floor Defaults Dialog” on page 436.

Floor 1 Default Height
Chief Architect always defines the default 
height of Floor 1 at 0’-0”. This height value 
is measured from the top of the subfloor and 
is the constant by which the heights of 
structural elements in the programlike walls, 
floors, and ceilings are measured. The 
heights of architectural objects can be 
measured relative to this absolute height, as 
well. As such, this default cannot be 
changed. 

Room Defaults
Additional structural and material defaults 
for several categories of Room Types can 
also be specified:
• Normal Rooms
• Kitchens/Baths/Utility Rooms
• Decks
• Garage/Porches/Slabs

These Room Defaults dialogs are accessed 
by expanding the “Rooms” category in the 
Default Settings dialog. Select a room type 
and click the Edit button to open the defaults 
dialog for that room type. See “Room Types” 
on page 335.

These dialogs allow you to specify the floor 
and ceiling structures and finishes for 
different Room Types. See “Structure Panel” 
on page 352 and “Materials Panel” on page 
359.

Room Label Defaults
The Room Label Defaults dialog allows you 
to specify the initial appearance of room 
labels. This dialog is also accessed by 
expanding the “Rooms” category in the 
Default Settings dialog. See “Room Labels” 
on page 337. 

The options on most panels of the Room 
Label Defaults dialog are similar to those in 
the Text Specification dialog. See “Text 
Specification Dialog” on page 1041.

The options on the DIMENSION FORMAT 
panel are similar to those in the Displayed 
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Line Length dialog. See “Displayed Line 
Length Dialog” on page 1074. 

Any text added to the Room Label Defaults 
dialog displays in all subsequently created 
room labels, after the Room Name. Changes 

made to default settings do not alter existing 
room labels. To update existing labels so that 
they reflect changes made to the defaults, 
delete and replace them. See “Editing Room 
Labels” on page 338.

Room Definition
A room is a totally enclosed area defined by 
any combination of joined walls or railings, 
visible or invisible. To be recognized as a 
room by Chief Architect, a room must have 
an unbroken perimeter.

Unless otherwise specified, rooms generate 
floor and ceiling platforms automatically. 
Most rooms are also automatically covered 
by the roof when one is built. There are 
exceptions to this, such as rooms defined as 
Decks. See “Room Types” on page 335.

If a room is drawn within a larger structure 
and none of its walls connect to the exterior 
walls, either directly or indirectly by 
connecting to walls that do, it is referred to as 
an “island” room. The program will connect 
such a room to the larger structure with an 
Invisible Wall. See “Room Dividers and 
Invisible Walls” on page 273.

Room definition disappears if part or all of a 
surrounding wall is deleted. It is a good idea 
to finalize the position of walls before 
defining rooms with names and attributes 
such as floor height and ceiling height.

Subdividing Rooms
When a room area is first defined, it inherits 
its characteristics from the Floor Defaults 
dialog for that floor. If the room is then 
specified as a particular type, it may inherit 
properties from the Room Defaults dialog 
associated with its type. 

If a new room is created by subdividing a 
larger room, it inherits its characteristics 
from that larger room - including any non-
default settings. 

If two rooms are separated by an Invisible 
wall, their interior areas will be measured 
from the wall’s centerline and characteristics 
like the floor finish materials and moldings 
will break along that line. 
• If the two rooms have different floor 

heights, the break will occur at the wall 
edge that faces the room where the floor 
is lower. 

• If the two rooms have different ceiling 
heights, the break will occur at the wall 
edge that faces the room where the ceiling 
is higher. 

Selecting Rooms
Room definition is established when a room 
is completely enclosed by walls. You can 

confirm that a room has room definition by 

using the Select Objects  tool to select it. 
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When a fully-enclosed room is selected, the 
room highlights. 

As with many other objects in the program, 
rooms can be group-selected, as well. Not all 
attributes of multiple selected rooms can be 
edited; however, many - such as moldings, 
materials, and fill style - can be.

The Exterior Room
You can also select the exterior of a model. 
This allows you to control the building’s 
exterior wall coverings and materials using 
the Room Specification dialog. 

Click just outside an exterior wall using the 

Select Objects  tool to select the Exterior 
Room. When it is selected, a highlighted 
band around the plan’s exterior displays. 
This band represents the selection area for 
the Exterior Room.

In camera views and overviews, the Exterior 
Room can be selected by clicking on the 
exterior surface of an exterior wall using the 

Select Objects  tool, provided that Select 
Room Before Wall in 3D is selected in the 
Preferences dialog. See “Architectural 
Panel” on page 108.

In 3D Views
Click on the floor of a room or on a wall 
surface inside the room in a 3D view using 

the Select Objects  tool. If you select 
another object instead of the room, click 

Select Next Object  edit button or press 
the Tab key until the room is selected. The 
Status Bar indicates which object is currently 
selected.

The Exterior Room can also be in 3D views 
selected by clicking once on the exterior 
surface of an exterior wall using the Select 
Objects  tool, provided that Select Room 
Before Wall in 3D is selected in the 
Preferences dialog. See “Architectural 
Panel” on page 108. 

Note: The selection color can be specified in
the Preferences dialog. See “Colors Panel”
on page 94.

The room at left is selected The Exterior Room is selected
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Match Properties
Click a room to select it, then click the 
Match Properties edit button and 

group-select rooms with shared attributes. 
See “Match Properties” on page 250.

Displaying Rooms
Unlike most things in Chief Architect, a 
room is not an individual object. Rather, a 
room is defined by the walls that enclose it.

You can see the primary and secondary 
layers associated with a room by selecting it 
and clicking the Object Layer 
Properties  edit button. See “Object 
Layer Properties” on page 154.

In Floor Plan View
Rooms typically display a transparent fill in 
floor plan view. You can, however, specify a 
solid color or fill pattern for all the rooms on 
an entire floor in the Floor Defaults dialog, 
or for individual rooms in the Room 
Specification dialog. See “Fill Style Panel” 
on page 359.

In order for room fill styles to display, the 
“Rooms” layer must be turned on. See 
“Displaying Objects” on page 144. 

Room labels that include the room’s name as 
well as its size and other information can be 
set to display in floor plan view. See “Room 
Labels” on page 337. 

In 3D Views
Rooms can be viewed in 3D views created by 
any of the 3D view tools. The Floor 
Overview tools can be used to see all rooms 
on the current floor without their ceilings. 
See “Creating Overviews” on page 900.

In the Materials List
The contents of a room, including 
furnishings and floor and ceiling materials 
can be calculated using the Calculate From 
Room tool. See “Calculate for Room” on 
page 1284.

Editing Rooms
Once a room is defined by walls or railings, 
its structure and appearance can be edited 
using the edit buttons or the Room 
Specification dialog. 

In 3D Views
The floor and ceiling heights for floors, 
rooms, and individual walls can be edited 
using edit handles in 3D views. Lowered 
ceilings cannot be edited in 3D. See “3D 
Views” on page 887. 

Note: If the wall height of the Exterior Room
is adjusted in a 3D view, the default Floor or
Ceiling Height of the entire floor is changed.
See “Floor and Room Defaults” on page 330.
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The default floor and ceiling heights for an 
entire model can be edited by selecting the 
Exterior Room. See “The Exterior Room” on 
page 332.

To change default ceiling heights in 3D

1. Create a 3D or Cross Section/Elevation 
view of the exterior of your plan. 

2. Click on the exterior surface of a wall to 
select the Exterior Room. The Status Bar 
indicates when the exterior room is 
selected. See “The Exterior Room” on 
page 332.

3. Click and drag the edit handle on the top 
wall edge to adjust the default ceiling 
height, or the edit handle on the bottom 
edge to adjust the default floor height. 
Temporary dimensions display.

To adjust room heights in 3D

1. Create a 3D or Cross Section/Elevation 
view of your plan.

2. Click on the surface of a wall that faces 
the room to select it. When the room is 
selected in 3D:

•  The room highlights. 
•  The Status Bar says “Room”. See “The 

Status Bar” on page 42.
•  Two edit handles display on the top and 

bottom edges of the highlighted wall.

3. Click and drag the edit handle on the top 
wall edge to adjust the room ceiling 
height, or the handle on the bottom edge 
to adjust its floor height. Temporary 
dimensions display.

4. As you drag a handle, notice that all 
walls defining that room are affected.

To adjust the height of a wall in 3D

1. Create a 3D or Cross Section/Elevation 
view of your plan. 

2. Click on a surface of the wall. By 
default, the room will be selected. You 
can change this behavior in the 
Preferences dialog. See “Architectural 
Panel” on page 108.

3. Click the Select Next Object  edit 
button to select the wall. The Status Bar 
says “Wall.” See “The Status Bar” on 
page 42.

4. Click and drag the edit handles. Tempo-
rary dimensions display in elevation 
views. See “Editing Closed-Polyline 
Based Objects” on page 201.

Room materials such as floor, ceiling, and 
wall materials can be changed in 3D views 

using the Material Painter . See “The 
Material Painter” on page 849.

Note: Any rooms that do not update when the
default floor or ceiling height is changed are
not using the default values. To use the
default values for a specific room, check
Default for any of the room height values in
its specification dialog. See “General Panel”
on page 351.

If you use the Material Painter to change
a room’s floor or ceiling finish material, it

will add that material to the room’s Floor or
Ceiling Finish Definition. Changes to a Deck
room’s planking or framing will affect its floor
structure definition.  
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In the Specification Dialog
Floor and ceiling heights, floor 
platform structure, moldings, wall 

coverings, and materials can all be specified 
in the Room Specification dialog. See 
“Room Specification Dialog” on page 350.

When multiple rooms are selected, the 
options available in the Room Specification 
dialog will be limited. You can, however, 
apply attributes to multiple rooms using the 

Match Properties  and Apply 
Properties  edit tools. See “Match 
Properties” on page 250.

Using the Edit Tools
A selected room can be edited in a variety of 
ways using the buttons on the edit toolbar. 
See “The Edit Toolbar” on page 37.

• Click the Make Room Polyline  edit 
button to create a polyline that follows the 

surfaces of the selected room. See “Room 
Polylines” on page 349.

• Click the Make Room Molding Polyline 
 edit button to create a room molding 

polyline. See “Room Molding Polylines” 
on page 349.

• Click the Expand Room Polyline  
edit button to create a temporarily 
enlarged room definition that ignores 
invisible walls and railings. See “Expand 
Room Polyline” on page 350. 

• Click the Calculate Materials for 
Room  edit button to create a materi-
als list of the contents of the selected 
room, not including walls. See “Calculate 
for Room” on page 1284.

• Click the Create Room Elevation 
Views  edit button to create an interior 
elevation view of each wall defining the 
selected room. See “Cross Section/Eleva-
tion Views” on page 902.

Room Types
When a room is first created by enclosing an 
area with walls, it is assigned a generic room 
type of “Unspecified.” 

Once your floor plan is laid out, each room 
should be assigned a Room Type in the 
Room Specification dialog. See “General 
Panel” on page 351. The Room Type applies 
appropriate structural and display properties 
to the room. 

When you assign a Room Type, a label 
showing the room’s Type displays in floor 
plan view.

You can edit the text of a room label in floor 
plan view, but the type of room originally 
assigned remains until it is changed in the 
Room Specification dialog. See “Editing 
Room Labels” on page 338.

Available Room Types
There are three categories of room types: 
Interior, Exterior and Hybrid.

Interior - Living, Dining, Family, Kitchen, 
Nook, Bath, Master Bath, Master Bedrm, 
Bedroom, Study, Office, Entry, Hall, Closet, 
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Dressing, Storage, Laundry, Utility and 
Unspecified.

Exterior - Court, Deck, Balcony.

Hybrid - Open Below, Garage, Slab, Porch, 
Attic.

Effects of Room Types
The program applies specific structural and 
display properties to rooms depending on the 
assigned Room Type.

Living and Conditioned Areas
• All interior type rooms are included in 

Living Area calculations by default; exte-
rior and hybrid type rooms are not. 

• With the exception of Unspecified rooms, 
all interior type rooms are included in 
Conditioned Area calculations by default. 
Open Below rooms are also included; 
however, exterior and other hybrid type 
rooms are not. See “Conditioned Area 
Totals” on page 1297.

Ceilings and Roofs
• Interior rooms have a ceiling and roof 

above them unless specified otherwise.
• Exterior rooms are assumed to be open to 

the outside and do not generate a roof 
above them, or room moldings.

• Attic rooms are ignored by the program’s 
automatic roof generator.

• Garage, Slabs, and Porches are treated 
like exterior rooms in all cases except that 
they generate a ceiling and a roof above 
them.

• A room’s default ceiling structure and fin-
ish definitions are determined by its 
Room Type. See “Room Defaults” on 
page 330.

Floors and Foundations
• Open Below is a unique type of interior 

room. It has no floor platform and can be 
used for defining stairwell openings. 

• Exterior walls of rooms default to create 
the foundation type specified in the 
Foundation Defaults dialog. 

• Walls that define the garage have a foun-
dation under them defined by the 
Foundation Defaults dialog with a con-
crete slab at the top of stem wall or grade 
beam.

• The floor in Garage and Slab rooms dis-
play in 3D on Floor 0, not the first floor. 
See “Garages” on page 459.

• A room’s default floor structure and finish 
definitions are determined by its Room 
Type. See “Room Defaults” on page 330.

• Defining a room as Slab causes the floor 
platform thickness to equal the slab thick-
ness value in the Foundation Defaults 
dialog.

• Courts, decks and balconies do not gener-
ate foundations.

Doors and Windows
• A window placed in a wall between an 

exterior room and an interior room always 
faces out toward the exterior. 

• Windows placed between interior type 
rooms generate a warning message. 

• Doors placed between interior and exte-
rior type rooms display threshold lines 
and are considered Exterior. See “Interior 
vs Exterior Doors” on page 362.

• Doors placed between interior type rooms 
do not display thresholds and are consid-
ered Interior. 
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• Open Below rooms are treated as interior 
rooms for window and door placement.

Electrical

• The Auto Place Outlets  tool adds 
outlets automatically to all interior rooms 
except bathrooms. Only one outlet over 
each sink is added for a bathroom.

• The Auto Place Outlets  tool places 
fewer outlets in hybrid rooms. 

• The Auto Place Outlets  tool does not 
place outlets in exterior type rooms, 
Porches or Open Below rooms.

• Any outlet manually placed in an exterior 
room automatically becomes a waterproof 
outlet designed for exterior use. 

Trim and Molding
• Moldings are not automatically drawn in 

exterior or hybrid rooms.
• Baseboards and chair rails are not initially 

drawn in Open Below rooms, but crown 
molding, if present, is. 

Dimensions

• Auto Interior  and Auto NKBA®  
Dimensions will only generate in rooms 
specified as Kitchens or Baths. See “The 
Automatic Dimension Tools” on page 
1009.

Plan Check

• Plan Check  uses the room type and 
its characteristics for basic plan checking. 
For example, a closet does not need a 
smoke detector but a bedroom does. See 
“Plan Check” on page 1130. 

Room Labels
A label can display in floor plan view for any 
area defined as a room. There are two parts 
to each room label: 
• The Room Name, which is similar to a 

Text  object and can be selected and 
edited. See “The Text Tools” on page 
1031. 

• The room area, which is not a standard 
text entry and cannot be directly edited. 

You can assign a custom Room Name, move 
a room label or even delete it without 
affecting the Room Type. See “Room Types” 
on page 335.

Room Label Defaults
The initial settings that control the 
size, font, color and other aspects of 

room label appearance are controlled in the 
Room Label Defaults dialog. See “Room 
Label Defaults” on page 330. 

Custom Room Labels
The Room Names that display in room labels 
are often based on the Room Types assigned 
in the Room Specification dialog. You can, 
however create a custom name for a selected 

Room labels can move or even disap-
pear when room entries are revalidated.
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room, also in the Room Specification 
dialog. See “General Panel” on page 351.

Before creating a custom Room Name, 
assign the Room Type most similar to the 
room’s actual use.  For example, if you wish 
to name a room “Guest Room”, begin by 
specifying it as a “Bedroom” since these 
rooms have similar uses. 

When a Room Name is based on its Room 
Type, the name in the label will be in all 
capital letters. When a custom Room Name 
is used, capitalization is user-defined. 

If you wish to further customize a room’s 
label by adding text or a text macro, uncheck 
Show Room Label in the Room 
Specification dialog and create your own 
label using a Text object. See “The Text 
Tools” on page 1031. 

Displaying Room Labels
The display of room labels is controlled in 
the Layer Display Options dialog. By 
default, room labels are placed on the 
“Rooms, Labels” layer and use the Text Style 
assigned to that layer. See “Layer Display 
Options Dialog” on page 149. 

You can specify how the area of rooms is 
reported by the program by turning on the 
display of one or more of these layers: 
• Rooms, Standard Area is measured from 

the center of interior walls that define the 
room and from either the outside surface 
or outside of the Main Layer of exterior 
walls, depending on the Living Area to 
setting in the General Plan Defaults dia-
log. It is rounded to the nearest square 
foot or mm and does not include the area 
within bay, box and bow windows. See 
“Exterior and Interior Walls” on page 269 

and “General Plan Defaults Dialog” on 
page 88.

• Rooms, Interior Area is measured from 
the inner surfaces of all the room's walls.

• Rooms, Interior Dimensions is also 
measured from the inner surfaces of the 
room walls. Its format is set on the 
DIMENSION FORMAT panel of the Room 
Label Defaults dialog. See “Room Label 
Defaults” on page 330.

The display of room labels can also be 
controlled on a room by room basis in the 
Room Specification dialog. See “General 
Panel” on page 351. 

Editing Room Labels

Room labels are similar to simple Text  
objects and can be changed, moved and 
resized much like any other text object. You 
can also modify a room label’s Text Style 
and other attributes in the Room Label 
Specification dialog. See “Text 
Specification Dialog” on page 1041.

The text of a room label cannot be modified 
in its specification dialog, however: it must 
be specified in the Room Specification 
dialog. See “General Panel” on page 351.

If you delete a room label, the Room Type 
and Room Name remain unchanged in the 
Room Specification dialog. To restore the 
label, check the Show Room Label 
checkbox on the GENERAL panel of that 
dialog.

You can customize room labels using a
variety of text macros. See “Text Mac-

ros” on page 1064. 
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Room Area
Unlike the rest of a room label, the room area 
and dimensions are not standard text entries 
and cannot be edited or changed. The room 
area moves, resizes and rotates with the rest 
of the room label, but you can turn the area 
and dimensions on or off separately in the 
Layer Display Options dialog. See 
“Displaying Rooms” on page 333.

The Interior Area room area calculation 
includes the areas within bay, box or bow 
windows, while the Standard Area and 
Interior Dimensions calculations do not.

You can use the Make Room Area 
Polyline  edit button to see the exact 
extents of the selected room’s Standard Area. 

You can also insert room areas as well as 
other information into text objects using Text 
Macros. See “Text Macros” on page 1064.

Living Area
The Living Area label is an automatically 
generated label that reports the area of the 
current floor specified as living space. By 
default, Interior Rooms are defined as part of 
the Living Area, while Exterior and Hybrid 
Rooms are not. See “Available Room Types” 
on page 335.

Regardless of its Room Type, you can 
specify whether any room is included in the 
Living Area Calculation in the Room 

Specification dialog. See “General Panel” 
on page 351.

A Living Area label is created as soon as a 
room area is defined by walls and/or railings 
and is recalculated every time you add, 
remove, resize, or redefine a room or when 

you Rebuild Walls/Floors/Ceilings . If 
multiple buildings are created, each will have 
its own Living Area label. If none of a 
structure’s rooms are included in the Living 
Area Calculation, however, no Living Area 
label will display for it.

To turn off the display of all Living Area 
labels in a plan, uncheck Show Living Area 
Label in the General Plan Defaults dialog 
or turn off the “Room Labels” layer in the 
Layer Display Options dialog. See “General 
Plan Defaults Dialog” on page 88.

The Living Area label can be moved or 
deleted. To restore a deleted Living Area 
label, select Tools> Checks> Plan 
Check . You can click the Done button 
immediately, without actually completing 
Plan Check. See “Plan Check” on page 1130.

Living Area vs. Footprint
The Living Area should not be mistaken for 
the footprint of a house. Only true livable 
areas are included in the Living Area 
calculation. By default, exterior and hybrid 
room types such as Garage, Deck, and Porch 
are not included. Neither is any room labeled 
Open Below or Attic. See “Available Room 
Types” on page 335. 

Regardless of its room type, you can specify 
whether a room is included in the Living 
Area calculation in the RoomSpecification 
dialog. See “General Panel” on page 351. 

Note: If you use the Convert to Rich Text edit
tool to convert a Room Label to a Text object,
it will no longer be display room size informa-
tion or update if the room type is changed.
See “Convert to Rich Text” on page 1047.
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Living Area is measured from either the 
outside surface or the outer surface of the 
Main Layer of exterior walls. See “Wall Type 
Definitions” on page 302. 

You can use the Make Living Area 
Polyline  edit button to see the exact 
extents of the current Living Area 
Calculation. 

To find the extents of the Living Area

1. Click just outside of an exterior wall to 
select the current floor’s Exterior Room. 
See “The Exterior Room” on page 332.

2. Click the Make Living Area Polyline 

 edit button. This creates a polyline 
surrounding the area included in the Liv-
ing Area on the current floor.

3. You can edit the polyline’s shape to 
include or exclude portions of the plan if 
you wish. See “Using the Edit Toolbar” 
on page 203. 

4. Select the polyline and click the Open 
Object  edit button. The polyline’s 
Area is stated in the Polyline 
Specification dialog. See “Polyline 
Panel” on page 1098. 

A polyline created using the Make Living 
Area Polyline  edit tool is a static 
representation of the current Living Area 
Calculation. If changes are made to the 
model that affect the Living Area, any 
previously created Living Area Polylines 
will not be affected. 

To find the footprint of a floor

1. Select the Exterior Room.

2. Click the Make Room Polyline  edit 
button. This creates a polyline around 
the exterior walls.

3. Edit the shape of the polyline if you 
wish.

4. Select the polyline and click the Open 
Object  edit button. The polyline’s 
Area is stated in the Polyline 
Specification dialog. 

Decks
A Deck room is an exterior-type room that 
uses deck planking and framing to create a 
floor platform rather than using a floor finish 
that spans the entire room area. See “Floor 

and Ceiling Platform Definitions” on page 
344. 

The default settings for deck planking and 
framing are set in the Deck Room Defaults 
dialog. See “Room Defaults” on page 330. 

You can quickly see which rooms are
included in the Living Area using the

Match Properties edit tool. See “Match Prop-
erties” on page 250. 

Note: Editing the shape of the Living Area
Polyline does not affect the Living Area Cal-
culation. 
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To draw a deck, select Build> Railing and 
Deck> Deck Railing , then click and drag 
to draw a railing. 
• To create a deck without a railing, use one 

of the Deck Edge tools. See “Fencing 
Tools” on page 268.

• You can also create a regular, polygon-
shaped deck using the Polygon Shaped 
Deck  tool. See “Polygon Shaped 
Deck” on page 267.

A room does not have to be defined by Deck 
Railing to be specified as a “Deck.” See 
“Room Types” on page 335. You can also 
define a room as a “Deck” in the Room 
Specification dialog. See “General Panel” 
on page 351. 

By default, decks do not have roofs. If you 
want a roof over a deck, check Roof Over 
This Room in the Room Specification 
dialog. See “Structure Panel” on page 352.

To give the roof a visible means of support, 
you can select the Post to Beam option in the 
Wall Specification dialog. See “Rail Style 
Panel” on page 323.

Openings in deck railings can be created 

using Doorways . See “Openings in 
Railings” on page 372. 

Deck Framing and Planking
When a Deck room is created, the floor 
platform is modeled using joists, beams, 
posts, and planking as specified in the Deck 
Room Defaults dialog. See “Structure 
Panel” on page 352, “Deck Panel” on page 
356, and “Deck Support Panel” on page 357. 
• If a floor level is present below the one 

that the Deck room is created on, the 

framing will be created there. If needed, 
beams may be generated with posts 
beneath them, if specified. When terrain 
is present, the posts will have footings, 
again, if specified. 

• If a floor level is not present below the 
Deck, framing will be generated on the 
same floor as the room. Beams may be 
created but posts will not. 

• Deck framing, planking, posts, and beams 
are placed on their own layers with names 
that begin with “Framing, Deck”: for 
example, “Framing, Deck Posts”. These 
layers are often turned off in floor plan 
view but are typically turned on in 3D 
views. See “Displaying Framing” on page 
604.

If standard floor framing is present when a 
room is specified as a Deck, that framing is 
deleted and replaced with deck framing. 

If changes are later made to the settings on 
the DECK panel of the Room Specification 
dialog, the deck framing and planking will be 
automatically rebuilt in response. To prevent 
this from happening, uncheck Automatic 
Deck Framing.

Once created, the individual planking and 
framing objects generated for a Deck room 
can be selected and edited like other framing 
objects, provided that Automatic Deck 
Framing is turned off. See “Editing 
Framing” on page 607. 

To rebuild a deck’s framing and remove any 
changes you may have made to individual 
deck framing or planks, select the Deck room 

and click the Build Deck Framing  edit 
button.
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If you delete a Deck room, its deck framing 
and planking will be automatically deleted, 
as well. To prevent this from happening, 
check Keep Deck Framing After Deck 
Room is Deleted. See “Deck Panel” on page 
356.

Deck Framing Schedules
The framing components that make up the 
decks in a plan can be listed in a Framing 
Schedule. See “Framing Schedules” on page 
614.

Floor and Ceiling Heights
Default floor and ceiling heights are defined 
in the Floor Defaults dialog for each floor, 
including the foundation. Use the Floor 
Defaults dialog to change these values on a 
floor-by-floor basis. See “Floor and Room 
Defaults” on page 330.

Use the Room Specification dialog to set 
floor heights on a room-by-room basis. See 
“Room Specification Dialog” on page 350. 

Different rooms on the same floor can have 
unique floor and ceiling heights, allowing 
you to create: 
• Split levels and bi-levels
• Sunken living rooms and garages
• Cathedral, vaulted, and coffered ceilings.

In 3D views, you can adjust the default floor 
and ceiling height for the entire floor, the 
floor and ceiling height for an individual 

room, or the top and bottom heights of an 
individual wall. See “In 3D Views” on page 
333.

In order to raise or lower an area’s floor or 
ceiling height, you must give it a room 
definition. To create room definition without 
enclosing an area with solid walls, use 

Railings . 

Invisible walls and railings will fill in the 
vertical space between floor platforms of 
different heights as long as Generate 
Between Platforms is checked in their 
specification dialog. See “General Panel” on 
page 309. 

Ceiling and floor heights are interrelated. 
Changing the floor height in one room can 
affect ceiling heights of the rooms below. 
• If a room’s floor is lowered, its ceiling 

height is increased while the ceiling 
below that room drops. 

• If the floor is raised, the ceiling height 
decreases while the ceiling below that 
room is raised. 

If the rooms above a particular room have 
more than one floor height, the room’s 
ceiling is stepped.



Floor and Ceiling Heights

 343

In a situation like this, a Lowered Ceiling can 
be used to cover “steps” made by different 
floor heights on the floor above. See 
“General Panel” on page 351.

Dropped Ceilings and 
Raised Floors

The structure of a dropped, or suspended, 
ceiling can be specified in the Ceiling Finish 
Definition dialog either for a room or the 
defaults for a floor. See “Floor and Ceiling 
Platform Definitions” on page 344.

To create a framed dropped ceiling

1. Select a room and click the Open 
Object  edit button. 

2. On the STRUCTURE panel of the Room 
Specification dialog, click the Ceiling 
Finish button. See “Structure Panel” on 
page 352.

3. In the Ceiling Finish Definition dialog:
•  Specify Layer 1 as the plenum space.
•  Specify Layer 2 as the horizontal fram-

ing. Framing member spacing and 
width are set in the material definition. 

See “Define Material Dialog” on page 
864.

•  Specify Layer 3 as the drywall.
•  Specify Layer 4 as the paint color.

A dropped ceiling composed of a metal grid 
requires only two layers: one for the plenum 
and one for the tiles.

You can create a raised floor, such as for a 
shower pan, in a similar manner by 
specifying it in the Floor Finish Definition 
dialog. 

Split Levels
A split level can be created by raising or 
lowering the floor and ceiling heights of 
various areas of the plan.

In the following example, the lowest floor 
height is 0, the next is 24, and the next is 48 
inches. The ceiling height in each room is set 
at 109 inches. See “Split Levels” on page 
442.
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Floor and Ceiling Platforms
In many ways, rooms in Chief Architect are 
defined by the floor platforms below them 
and the floor and/or ceiling platforms above. 

All floor and ceiling platform and finish 
materials are used for the calculation of the 
materials list. See “Materials Lists” on page 
1283.

Floor vs Ceiling Platforms
Floor and ceiling platforms are not the same 
thing in Chief Architect. Floor platforms 
have living space above them and are 
designed to be weight-bearing. Ceiling 
platforms, on the other hand, have living 
space below them but not above them. They 
are not designed to bear weight and are 
typically less strong - and less thick - than 
floor platforms. 

Floor and Ceiling Platform 
Definitions

Floor and ceiling platforms are made up of 
layers of different materials such as framing, 
subflooring, drywall, and finish materials. 
So, typically, are Floor Material Regions. See 
“Floor and Wall Material Regions” on page 
799. 

You can specify the composition of floor 
and/or ceiling platforms on a floor-by-floor 
and also a room-by-room basis in the Floor 
and Ceiling Structure Definition dialogs. 
See “Material Layers Definition Dialogs” on 
page 802.
• To specify the composition of the floor 

and ceiling platforms for an entire floor: 

open the associated FLOOR panel in the 
Framing Defaults dialog and click the 
Floor Structure or Ceiling Structure 
button. See “Floor Panels” on page 586. 

• To specify the floor and/or ceiling struc-
ture for an individual room, open the 
STRUCTURE panel of its Room 
Specification dialog and click the Floor 
Structure or Ceiling Structure button. 
See “Structure Panel” on page 352.

Floor and ceiling platform definitions play a 
role in determining floor and ceiling heights. 
Floor and ceiling finishes can be used to 
create raised floors as well as dropped 
ceilings. See “Floor and Ceiling Heights” on 
page 342. 

In addition to the structural layers of a 
platform, floors and ceilings typically have 
one or more finish layers. You can specify 
floor and ceiling finish materials for an entire 
floor or individual room much the way you 
can structural layers: by clicking the Floor 
Finish and/or Ceiling Finish button on the 
STRUCTURE panel of either the Floor 
Defaults or Room Specification dialog to 
open the Floor or Ceiling Finish Definition 
dialog.

If you use the Material Painter to change
a room’s floor or ceiling finish material, it

will add that material to the room’s Floor or
Ceiling Finish Definition. Changes to a Deck
room’s planking or framing will affect its floor
structure definition. See “The Material
Painter” on page 849. 
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Floor Material Regions
Floor Material Regions allow you to create 
areas within a floor that use different layers 
of materials than the parent object. See 
“Floor and Wall Material Regions” on page 
799.

Stepped Floor and 
Ceiling Platforms

Each floor has default floor and ceiling 
heights. You can, however, use the Room 
Specification dialog to specify floor and 
ceiling heights on a room by room basis to 
create stepped floors and ceilings. See 
“Structure Panel” on page 352. 

If you require a single floor platform with a 
uniform height and thickness but different 
ceiling heights for the rooms below, specify a 
lowered ceiling using the Ceiling Finish 
Specification dialog. See “Lowered 
Ceilings” on page 346.

By default, the gap between floor and ceiling 
platforms that step at a railing or invisible 
wall is closed off by a short section of solid 
wall. If you require a gap between the 
platforms, either select a single-layer wall 
type or uncheck Generate Between 
Platforms in the Wall or Railing 
Specification dialog. See “General Panel” 
on page 309. 

Cantilever Undersides
If a room cantilevers out past an exterior 
wall, the cantilever will use the same floor 
platform as the rest of the room. You can 
specify the surface material of the cantilever 
underside on the MATERIALS panel of the 
Room Specification dialog. For no material, 

select “No Material” from the Plan Materials 
dialog. See “Room Specification Dialog” on 
page 350.

Platform Edges
Typically, floor and ceiling platforms are 
built so that they bear on top of walls. The 
edges of the platform structures extend 
through exterior walls to the layer of the wall 
type definition with the Build Platform to 
This Line setting. See “Wall Type Defini-
tions” on page 302. 
• For framed walls, the Build Platform to 

This Line layer is set as the outside of the 
wall’s Main Layer, 

• For concrete walls, it’s the inside of the 
wall’s Main Layer. 

• The platforms of rooms with raised floors 
and/or lowered ceilings build in the same 
manner: to the Build Platform to This 
Line layer of the wall type assigned to the 
railing or invisible wall defining the 
room. See “Floor and Ceiling Heights” on 
page 342. 

For a given wall type, you can specify a 
different Build Platform to This Line wall 
layer surface provided that it  is on the 
exterior side of the Main Layer. 

In addition, you can specify that individual 
walls build through floor and ceiling 
platforms in the Wall Specification dialog.  
See “General Panel” on page 309.

Platform Holes
Select Build> Floor> Hole in 
Floor Platform or Hole in 

Ceiling Platform, then click and drag a 
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rectangular polyline that forms a hole in the 
designated platform.

You can also create a hole in a floor or 
ceiling platform by drawing a closed CAD 
polyline and then using the Convert 
Polyline  edit button to convert it into a 

platform hole. See “Convert Polyline” on 
page 239. 

Platform hole edges derive their material 
from the ceiling finish of the room directly 
below the hole. 

Special Ceilings
By default, the program builds a flat ceiling 
platform on top the wall plates of a room. 
More varied and complex ceilings are made 
using settings in the Room Specification 

dialog and the Ceiling Plane  tool. 
Ceiling planes are drawn and can be edited 
much like roof planes. See “Ceiling Planes” 
on page 511.

Lowered Ceilings
You can define a lowered or dropped ceiling 
in a room without affecting the top height of 
the walls by specifying the lowered ceiling 
framing as a layer in the ceiling finish.

In the following illustration, the default 
ceiling height for the entire first floor is 120", 
and the room on the right has a ceiling finish 
lowered to 96".  

To create a lowered ceiling

1. Select the room in which you would like 
to specify a lowered ceiling.

2. Click the Open Object  edit button 
to open the Room Specification dialog.

3. On the STRUCTURE panel, click the Ceil-
ing Finish button to open the Ceiling 
Finish Definition dialog. See “Material 
Layers Definition Dialogs” on page 802.

•  Select Layer 1 of the ceiling finish def-
inition, then click the Insert button to 
create a new layer above the current 
Layer 1.

•  Specify the desired Thickness of the 
new layer, which will form the lowered 
ceiling framing. 

•  Click the Select Material button and 
specify the new layer’s material as a 
Framing material. Normal ceiling Lowered ceiling
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•  Specify the Structural Type, the type 
of framing member you want to use to 
frame the lowered ceiling.

4. Repeat step 3 if you require additional 
layers, such as an air gap, above the low-
ered framing. 

5. When you are finished, click OK to 
close the Ceiling Finish Definition dia-
log.

6. On the STRUCTURE panel, notice that the 
preview diagram represents the Finished 
Ceiling height (F).

Vaulted and Cathedral Ceilings
A cathedral ceiling has the same pitch as the 
roof and is created using the underside of the 
roof above the room. A vaulted ceiling 
typically has a different pitch from that of the 
roof and is often framed using scissor 
trusses. See “Scissors Trusses” on page 630.

To create a cathedral ceiling

1. Build a roof for your plan. See “Roofs” 
on page 473. 

2. Select the room and open the Room 
Specification dialog. See “Room Speci-
fication Dialog” on page 350.

3. On the STRUCTURE panel, clear the 
checkbox for Ceiling Over This Room.

By default, cathedrals ceiling use the ceiling 
material set in the Room Specification 
dialog. If you require a different material on 
a given roof plane, uncheck Use Room Ceil-
ing Finish in the Roof Plane Specification 
dialog. See “Options Panel” on page 501.

To create a vaulted ceiling

1. To create a ceiling pitch different from 
the roof’s, select Build> Roof> Ceiling 
Plane  and draw ceiling planes. See 
“Ceiling Planes” on page 511.

2. Select each ceiling plane and specify its 
pitch. See “Ceiling Plane Specification 
Dialog” on page 512.

Trey Ceilings
A trey ceiling is an area within a ceiling that 
is raised and has either vertical or sloping 
sides.  A standard trey ceiling can be easily 
created by placing Soffits, Polyline Solids, or 
Primitive objects around the perimeter of the 
room. An angled trey ceiling can be created 
using the underside of roof planes above.

To create an automatic angled trey ceiling

1. In the Room Specification dialog, make 
sure that Ceiling Over this Room is 
checked, then specify the desired height 
of the walls as the Ceiling Height. See 
“Structure Panel” on page 352.
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2. Make sure that Auto Rebuild Roofs is 
unchecked, then build the roof. See 
“Build Roof Dialog” on page 480.

3. Change the Ceiling Height of the room 
to the desired height of the flat ceiling 
surface in its center. 

In floor plan view, dashed lines indicate 
where the ceiling changes from sloped to 
flat. These lines are located on the “Ceiling 
Break Lines” layer in the Layer Display 
Options dialog. See “Layer Display Options 
Dialog” on page 149. You can specify 
whether ceiling break lines indicate the break 

at the ceiling finish layer or the framing layer 
in the Build Roof dialog. See “Options 
Panel” on page 485.

If the roof is rebuilt after the ceiling height is 
adjusted upward, the new roof will be raised 
to match the new ceiling height and a trey 
ceiling will not be created.

In the following example, a hip roof is built 
on 8’ (2400 mm) ceilings. After the roof is 
built, the Ceiling Height is raised to 10’ 
(3000 mm). The resulting ceiling follows the 
roof pitch for 2’ (600 mm), then becomes a 
flat ceiling. 

Cantilever Undersides
Occasionally, a room will cantilever out past 
an exterior wall. You can specify the surface 
material of the underside of a cantilever on 
the MATERIALS panel of the Room 

Specification dialog. For no material, select 
“No Material” from the Plan Materials 
dialog. See “Room Specification Dialog” on 
page 350.

Other Special Ceilings

Soffits  can be used in various ways to 
enhance the 3D model. Soffits’ ability to 
follow the slope of the roof offers unlimited 

possibilities, such as exposed beams or 
trusses and coffered ceilings. See “Special 
Applications for Soffits” on page 794. 

       Hip roof with 
cathedral ceiling over.

Hip roof, ceiling over, 
ceiling height raised.

Ceiling Break lines in 
   floor plan view. 
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Polyline solids, framing members and locked 
roof trusses can also be used for similar 
purposes.

Room Polylines
Click the Make Room Polyline edit 
button to create a standard polyline on 

the Current CAD Layer that follows the 
surfaces of the selected room. See “Current 
CAD Layer” on page 1076.

Room polylines and room molding polylines 
are not affected when the room is altered.

Room Molding Polylines
To create a molding polyline that 
follows the interior surfaces of a 

room, select the room and click the Make 
Room Molding Polyline button on the edit 
toolbar.

Room molding polylines can be edited just 
like other molding polylines. Their shape and 
height can be altered and the molding profile 
can be changed. Additional molding profiles 
can also be assigned. See “Molding 
Polylines” on page 664.

Make Room Molding 
Polyline Dialog

Select the Molding type to assign to the 
room molding polyline from the drop-down 
list. The options available will be the 
moldings already assigned to the selected 
room.When you convert a molding type to a 
molding polyline, the room molding turns 
off. See “Moldings Panel” on page 359.
• Base Molding - Select to convert the 

room’s base molding into a molding poly-
line. 

• Chair Rail Molding - Select to convert 
the room’s chair rail molding into a mold-
ing polyline. 
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• Crown Molding - Select to convert the 
room’s crown molding into a molding 
polyline. 

• Blank Molding - Select to generate a 
blank molding polyline. The polyline fol-
lows the room perimeter and has blank 
sections where the polyline crosses win-
dows and doors if these objects are at the 
polyline height.

Specify the Height of the selected molding 
polyline, as measured from the selected 
room’s floor. 

Expand Room Polyline
The Expand Room Polyline edit 
button is available when you select a 

room separated from other rooms by 
invisible walls or railings. Select this edit 
tool to create and select a temporarily 
enlarged room definition that ignores those 
invisible walls and railings. 

To use the Expand Room Polyline tool

1. Click in a room defined by at least one 
invisible wall or railing.

2. Click the Expand Room Polyline  
edit button.

3. Click the Make Room Polyline  or 

Make Room Molding Polyline  edit 
button to create a polyline that follows 
the interior surfaces of walls, ignoring 
invisible walls and railings.

Expand Room Polyline  does not create 
a new room and cannot be used in 
combination with the Auto Interior 
Dimensions  or Auto NKBA® 
Dimensions  edit tools: it only allows you 
to generate a larger room polyline or room 
molding polyline.

Room Specification Dialog
The Room Specification dialog 
controls the structural characteristics 

and appearance of a selected room. To open 
the Room Specification dialog, select one or 
more rooms and click the Open Object edit 
button. See “Selecting Rooms” on page 331. 

Several of the panels in the Room 
Specification dialog are also found in the 
Floor and Room Defaults dialogs. See 
“Floor and Room Defaults” on page 330. 

Some values in this dialog are dynamic. A 
value with Default checked references the 
Floor Defaults dialog. To return a value to 

the default, replace the check mark. See 
“Dynamic Defaults” on page 76.

The settings in this dialog are similar to those 
in the Floor Defaults dialog, but affect only 
the selected room See “Floor Defaults 
Dialog” on page 436.

If multiple rooms are selected, not all of the 
settings in this dialog will be available. See 
“Selecting Objects” on page 183.

Many of the settings in this dialog can be 
included in a Room Finish Schedule. See 
“Schedules and Object Labels” on page 
1267.
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General Panel
The GENERAL panel is not available in the 
Room Defaults dialog, and only two of the 
settings here are active in the Floor Defaults 

dialog. See “Floor and Room Defaults” on 
page 330.

The settings here control the Room 
Type, the appearance of the Room 

Label, and how the room appears in the 
Room Finish Schedule.
• Select the Room Type. This affects some 

of the room’s characteristics. Not avail-
able when multiple rooms are selected. 
See “Room Types” on page 335.

• If you wish to use a custom name in the 
room label and schedule, uncheck Use 
Room Type, then specify the desired 
Room Name in the text field.

• Check Show Room Label to display the 
room label in floor plan view. See “Room 
Labels” on page 337.
This option is unchecked automatically if 

you select “Unspecified” as the Room 
Type, and checked automatically if you 
select any other Room Type; however, 
you can turn this behavior off if you wish 

in the Preferences  dialog. See 
“Architectural Panel” on page 108.

Specify whether the selected room is 
included in the Living Area 

calculation. See “Living Area” on page 339. 
• Select Include in Total Living Area Cal-

culation to include the room in the Living 
Area regardless of its Room Type. 

• Select Exclude from Total Living Area 
Calculation exclude the room from the 
Living Area regardless of its Room Type. 

1

2
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• Select Use Default for Room Type 
(Included/Excluded) to base the selected 
room’s inclusion in the Living Area on its 
Room Type. The default for the selected 
Room Type is stated in parentheses.

Specify whether the selected room is a 
Conditioned Room or not. See 

“Conditioned Area” on page 1297.
• Select Conditioned to include the room 

in the Conditioned Area of the structure, 
regardless of its Room Type. 

• Select Unconditioned exclude the room 
from the Conditioned Area, regardless of 
its Room Type. 

• Select Use Default for Room Type 
(Conditioned/Unconditioned) to base 
the selected room’s inclusion in the Liv-

ing Area on its Room Type. The default 
for the selected Room Type is stated in 
parentheses.

Options - 

• Specify the Roof Group of the selected 
room. Change this value to control how 
the program combines the selected room’s 
roof system with that of the rest of the 
building when automatic roofs are built. 
This value is nearly always left at zero. 
See “Roof Groups” on page 477.

• Uncheck Include in Schedule to prevent 
the selected room(s) from being included 
in the Room Finish Schedule. See 
“Schedules and Object Labels” on page 
1267.

Structure Panel
The STRUCTURE panel is also found in the 
Floor and Room Defaults dialogs and 
features a cross section diagram that shows 
the relationships between its various heights 
and platform thicknesses. It is meant to 
represent the relationships between heights 
and thicknesses rather than provide a scaled 
drawing of the model.

Two floors can be included in the diagram: 
the floor that the selected room is located on, 
and the floor below it, if one exists. 

What appears in both the diagram and in the 
settings to its left may be affected by the 
location where you clicked to select the 
room. For example:

• If the selected room is located above two 
rooms with different structural settings, 
the position of the pointer relative to these 
two lower rooms determines which of 
them displays as the floor below.

• If the selected room is located below two 
rooms with different floor heights, its 
absolute and relative ceiling height set-
tings will be disabled. 

When multiple rooms are selected, only the 
Floor and Ceiling Structure and Finish can be 
specified. In some Room Defaults dialogs, 
only the Floor Structure and/or Finish can 
be modified. See “Floor and Room Defaults” 
on page 330.

3

4
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Check the Default box beside any height 
value to restore the default setting. In the 
Floor Defaults dialog, the Floor and Ceiling 
Structure and Finish defaults are drawn from 
the Normal Room Defaults dialog. See 
“Dynamic Defaults” on page 76. 

Absolute Elevations - These height 
values are measured from zero, which 

is the default top height of the subflooring on 

Note: Many of the settings on this panel are
interdependent. For example, if the Ceiling
Structure thickness is modified, the Absolute
Ceiling and Rough Ceiling heights will
change in response. 

1
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Floor 1. See “Floor and Ceiling Heights” on 
page 342.
• Specify the Floor Above height, which is 

the subfloor height of the room on the 
floor above the selected room. If multiple 
rooms with differing floor heights are 
present directly above, this setting will be 
inactive and “No Change” will display. 

• Specify the Ceiling height of the selected 
room, as measured from zero to the bot-
tom of the ceiling framing. Not available 
in the Room or Floor Defaults dialog or 
if multiple floor heights are specified 
above the selected room. 

• Specify the Floor height, as measured 
from zero to the top of the subflooring.

If a room is defined directly beneath the 
selected room on the floor below, additional 
settings may be available. 
• Specify the Floor Below height, which is 

the subfloor height of the room directly 
below where you clicked to select the cur-
rently selected room. If there are multiple 
rooms with differing floor heights located 
below, this value may change depending 
on where you click.

• If the selected room is directly above a 
Garage and there is a foundation present, 
you can specify the SWT Below height, 
which is the top height of the concrete 
stem walls around the perimeter of the 
garage. 

Relative Heights - These height values 
are measured from surfaces within the 

selected room or the room below. 
• Specify the Rough Ceiling height, as 

measured from the subfloor surface to the 
bottom of the ceiling framing. Not avail-
able if multiple floor heights are specified 
directly above the selected room.

• Specify the Finished Ceiling height, as 
measured from the finished floor surface 
to the finished ceiling surface. Not avail-
able if multiple floor heights are specified 
directly above the selected room.

• Specify the distance from the Stem Wall 
Top to Ceiling. Only available when 
Floor for this Room is Supplied by the 
Foundation ‘Room’ from the Floor 
Below has been checked.

• Specify the Ceiling Below height, which 
is the height of the ceiling of the room 
below, as measured from that room’s sub-
floor to rough ceiling surfaces. Not avail-
able when Auto Rebuild Foundation is 
enabled or if there is no room below the 
selected room. See “Rebuilding Founda-
tions” on page 456. 

• Specify the Stem Wall height, which is 
measured from the top of the foundation 
wall footing to the top of the treated sill 
plate, if one is specified. Only available if 
the selected room or the room below it is 
defined by foundation walls.

A cross section diagram showing the 
relationship between the various height 

settings displays here for reference. 

Specify the characteristics of the 
room’s Ceiling. 

• If Roof Over This Room is checked, a 
roof automatically generates over the 

Note: The default floor height for Floor 1 is 0.
It can be modified in the Room Specification
dialog, but not in the Floor 1 Defaults dialog.
See “Floor and Room Defaults” on page 330.

2

3
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room. If unchecked, no roof generates.

If this option is unchecked and a roof 
plane is manually drawn over this room, 
its structure will be that of an eave rather 
than a regular roof. See “Roof Panel” on 
page 595.

• If Ceiling Over This Room is checked, 
the room has a flat ceiling. If unchecked, 
the ceiling follows the underside of the 
roof or manually drawn ceiling planes.

• Check Use Soffit Surface for Ceiling to 
frame the roof over the selected room 
using the framing defaults for fascia 
rather than for rafters. 

• The Ceiling Structure depth displays 
here for reference. Click the Edit button 
to open the Ceiling Structure Definition 
dialog and define the layers of materials 
that form the ceiling platform. Check 
Default to use the Ceiling Structure Defi-
nition set in the current floor’s Floor 
Defaults dialog. Not available for rooms 
on Floor 0. See “Material Layers Defini-
tion Dialogs” on page 802.

• The Ceiling Finish depth displays here 
for reference. Click the Edit button to 
open the Ceiling Finish Definition dialog 
and define the layers of materials that 
form the finished ceiling surface. Check 
Default to use the Ceiling Finish Defini-
tion set in the current floor’s Floor 
Defaults dialog. See “Material Layers 
Definition Dialogs” on page 802.

• Check the Default box to the right of 
either button to restore the default struc-
ture and/or finish.

Specify the characteristics of the 
room’s Floor. Only the Floor Finish 

and Structure settings are available in the 

Normal Room and Deck Room Defaults 
dialogs.
• When Floor Under This Room is 

checked, the room has a floor platform as 
specified below. 

• If Floor Supplied by the Foundation 
Room Below is checked, the floor for this 
room is a slab located on the floor below. 

• If Monolithic Slab Foundation is 
checked, the current Floor Structure will 
be replaced by a single 4” (100 mm) layer 
of concrete with footings that can be seen 
in camera views only. When a stem wall 
or grade beam foundation is generated, a 
slab will be created beneath the selected 
room.

• When Monolithic Slab Foundation is 
checked, specify the Pour Number of the 
selected room’s slab floor. Pour Numbers 
are listed separately in the Materials List. 
See “In the Materials List” on page 455.

• The Floor Finish depth displays here for 
reference. Click the Edit button to open 
the Floor Finish Definition dialog and 
define the layers of materials that form 
the finished floor surface. Check Default 
to use the Floor Finish Definition set in 
the current floor’s Floor Defaults dialog. 
See “Material Layers Definition Dialogs” 
on page 802.

• The Floor Structure depth displays here 
for reference. Click the Edit button to 
open the Floor Structure Definition dia-
log and define the layers of materials that 
form the floor platform. Check Default to 

5

If the selected room has a living space
located anywhere beneath it, avoid

checking Monolithic Slab Foundation.
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use the Floor Structure Definition set in 
the current floor’s Floor Defaults dialog. 
See “Material Layers Definition Dialogs” 
on page 802.

• If the selected room is a Deck, the Floor 
Structure button will be labeled Planks, 
Joists instead. See “Decks” on page 340.

• Check the Default box to the right of 
either button to restore the default struc-
ture and/or finish. 

Deck Panel
The options on the DECK panel are only 
available for rooms designated as Decks, and 
control how deck planking and joists are 
generated. See “Deck Framing and 
Planking” on page 341. 

The settings on this panel are also found in 
the Deck Room Defaults dialog, but affect 
the selected Deck room(s) only rather than 
Decks as they are initially created. See 
“Room Defaults” on page 330.

Note: The default floor and ceiling platform
and finish definitions for rooms are set in the
current floor’s Floor Defaults dialog. In the
Floor Defaults dialog, the defaults are drawn
from the Normal Room Defaults dialog. See
“Floor and Room Defaults” on page 330.
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Check Automatic Deck Framing to 
generate planking and support framing 

for the deck that updates as changes are made 
to the deck. See “Decks” on page 340.  
• Check Keep Deck Framing After Deck 

Room is Deleted to retain the automati-
cally generated framing and planking 
when the selected deck room is deleted. 
When this box is unchecked, the framing 
is automatically removed if the room is 
deleted. 

Specify the appearance of the Deck 
Planking. 

• Specify how far the deck planking Over-
hangs the rim joists.

• Specify the Plank Width of the deck 
planking.

• Specify the Plank Gap Width, which is 
the distance between individual planks.

• If you want to enter a Plank Direction, 
remove the checkmark from Automatic. 
Enter the direction as degrees.

• Specify the Number of Border Planks. 
These are planks that follow the outside 
edge of the deck and may not be parallel 
with the rest of the planking. Border 
planks generate as long as the length of an 
inside edge is greater than 0”. They do not 
generate on curved deck edges. 

• Check No Border Against Walls to pre-
vent border planking from being gener-
ated along any walls defining the deck. 

• Check Herringbone to produce a her-
ringbone pattern where the border planks 
meet.

• Check Treated to specify that the deck 
planking is counted as treated in framing 
schedules and the Materials List.

Specify the configuration of the Deck 
Joists. 

• Enter the Width of the joists that support 
the deck.

• Specify the Spacing between joists, as 
measured from joist center to joist center. 

• If you want to specify joist Direction, 
uncheck Automatic and enter the direc-
tion in degrees. When checked, joists are 
run in the direction that results in the 
shortest spans.

• Check Treated to specify that the deck 
joists are counted as treated in framing 
schedules and the Materials List.

Deck Support Panel
The options on the DECK SUPPORT panel are 
only available for Deck rooms and control 
how deck beams and posts are generated. See 
“Deck Framing and Planking” on page 341.

The settings on this panel are also found in 
the Deck Room Defaults dialog, but affect 
the selected Deck room(s) only rather than 
Decks as they are initially created. See 
“Room Defaults” on page 330.

1

2

Note: Planking thickness and joist depth are
specified in the Floor Structure Definition dia-
log. See “Floor and Ceiling Platform Defini-
tions” on page 344. 

3
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Specify the configuration of the Deck 
Beams. under the selected Deck room.

• Uncheck Deck Beams to prevent the 
automatic generation of support beams 
under the selected Deck room.

• Click the Edit Beam button to open the 
Framing Specification dialog and define 
the beam size and other characteristics. 
See “Framing Specification Dialog” on 
page 610.

• Specify the maximum Beam Spacing. 
Beams may be positioned closer than this 
value, but not further apart.

Specify the configuration of the Deck 
Posts under the selected Deck room.

• Uncheck Deck Posts to prevent the 
automatic generation of support posts 
under the selected Deck room.

• Click the Edit Post button to open the 
Post Defaults dialog and define the size 
and other characteristics of the posts asso-
ciated with the selected Deck. See “Fram-
ing Specification Dialog” on page 610.

• Specify the maximum Post Spacing. 
Posts may be positioned closer together 
than this value, but not further apart.

Specify whether Deck Post Footings 
are generated under the selected Deck 

room’s deck posts. Not available if Deck 
Posts is unchecked, above.
• Uncheck Deck Post Footings to prevent 

the automatic generation of footings 
under the selected Deck room’s posts.

• Specify the footings’ Height Above Ter-
rain. See “Foundations and the Terrain” 
on page 461. 

1

2

3
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• Specify the footings’ Thickness and 
Width. 

• Specify whether the footings are Square 
or Round in shape. 

• Specify the Rebar Size Number. 
• Specify the Rebar Count, or number of 

bars in each footing. 

Moldings Panel
Chair rail, crown and base moldings can be 
assigned to one or more rooms on the MOLD-
INGS panel. Moldings are placed around the 
wall surfaces of a room and continue around 
the surface of any soffit that is attached to the 
wall at the molding height.

The settings on the MOLDINGS panel are 
similar to those found in other specification 
dialogs throughout the program. See 
“Moldings Panel” on page 659.

The settings on this panel are also similar to 
those found in the Floor Defaults dialog, but 
affect only the selected room instead of all 
rooms on the current floor. 

Wall Covering Panel
The settings on the WALL COVERING panel 
of the Room Specification dialog are the 
same as those on the same panel of the Wall 

Specification dialog. When a wall covering 
is assigned in the Room Specification 
dialog, it is applied to all walls in the selected 
room only. See “Wall Covering Panel” on 
page 320.

Fill Style Panel
The settings on the FILL STYLE panel affect 
the appearance of the room in floor plan 
view. This panel is also found in the Floor 
Defaults dialog. For more information, see 
“Fill Style Panel” on page 1099.

Materials Panel
The settings on this panel affect the 
appearance of a selected room’s walls and 
moldings in 3D views. See “Materials Panel” 
on page 852. 

Default molding and ceiling and floor 
covering materials can be set on this panel in 
the Floor Defaults and Room Defaults 
dialogs.

Room Finish Schedules
The Room Finish Schedule tool 
allows you to produce customizable 

room finish schedules with information 

about room size, structure, materials and 
molding. See “The Schedule Tools” on page 
1268.

Wall coverings can be applied to exte-
rior rooms as well by selecting the exte-

rior room and opening it for specification. See
“Selecting Rooms” on page 331 for informa-
tion about selecting exterior rooms. 
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Chapter 10:

Doors

Chief Architect comes with tools for creating 
a wide variety of interior and exterior doors. 
In addition, the library offers a large 
selection of specialty doors and doorways 
including hinged, sliding, pocket, bifold, and 
garage doors. Additional name-brand door 
catalogs are also available for download 
from our web site,  chiefarchitect.com.

Chapter Contents
•      Door Defaults
•      The Door Tools
•      Displaying Doors
•      Editing Doors
•      Changing Door Swings
•      Special Doors
•      Door Specification Dialog
•      Door Schedules

Door Defaults
Default Settings are accessed by 
selecting Edit> Default Settings. 

Click the “+” next to Doors to show the door 
sub-headings. Select a subheading and click 
the Edit button to open the defaults dialog 
associated with your selection: 

Door Defaults can also be accessed by 

double-clicking the Door Tools  parent 

button or the Hinged Door  or Sliding 
Door  child button. Double-clicking the 
other Door Tools child buttons will open the 
defaults dialog for that particular door type. 

http://www.chiefarchitect.com/
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The Door Defaults dialogs look nearly the 
same as the Door Specification dialog. See 
“Door Specification Dialog” on page 374. 
There are only a couple of differences: 
• Since default settings are specified here, 

“Use Default” is not an option for some 
settings as it is in the Door Specification 
dialog. 

• The Door Type cannot be changed in the 
Defaults dialogs.

Because Hinged and Sliding Doors are often 
used in both interior and exterior 
applications, they have both Interior and 
Exterior Door Defaults. 

Interior vs Exterior Doors
Regardless of its Door Type or the tool used 
to create it, a door will be: 
• An Interior Door if it is placed into a wall 

that separates two interior rooms;
• An Exterior Door if it is placed into a wall 

that separates an interior room from either 
an exterior room or the building’s exte-
rior. See “Room Types” on page 335.

This rule applies to doors copied and pasted 
from one location to another just as it does to 
those created using the Door Tools. 

Dynamic Door Defaults
A variety of door default values are dynamic, 
including the Add for Rough Opening 
values, Casing and Lintel Specifications,  
and Hardware. When a dynamic default is 
changed, existing doors using the default 
value are affected. See “Dynamic Defaults” 
on page 76. 

All Materials listed under “Doorway” on the 
MATERIALS panel are also dynamic. 
Materials assigned to doors and hardware 
items from the library are listed separately 
and are dynamically linked to the “Interior 
Door”, “Exterior Door” and “Fixture Trim” 
and “Hardware” materials set in the Material 
Defaults dialog rather than the Door 
Defaults dialogs. See “Material Defaults 
Dialog” on page 849. 

Door Framing
The default Rough Opening for doors can be 
defined in the Door Defaults dialogs. You 
can also specify an additional amount to 
cutout for door openings in concrete garage 
curbs and foundation walls. See “General 
Panel” on page 375.

The defaults for trimmers and headers can be 
specified in the Build Framing dialog. See 
“Framing Defaults” on page 578. 

The Door Tools
To place a door, select the type you 
want from the Build> Door submenu. 

Move your mouse pointer over a wall 
section. When a preview outline can be seen, 
click to place a door at that location.

The minimum initial size for doors varies by 
Door Type. For example, If there is room 
enough along the wall to fit a 12” (300 mm) 
wide Hinged Door, a preview outline will 
display and a door can be placed. Garage 
doors, in contrast, must initially be at least 6’ 
(1800 mm) wide.
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Doors can be placed in both straight and 
curved walls, as well as span across straight, 
collinear wall segments. 

Doors can also be placed in curved walls. 
See “Options Panel” on page 377.

A newly created door inherits the settings in 
the Door Defaults dialog for its door type. 
Once created, doors can be edited in a variety 
of ways. See “Door Defaults” on page 361. 

Doors cannot be placed in a wall specified as 
Invisible or if the wall in question is on a 
locked layer. See “Locking Layers” on page 
145.

Once placed, any door may be changed into 
any other type of door in the Door 
Specification dialog. See “General Panel” 
on page 375.

Hinged Doors
Select Build> Door> Hinged Door 
and click a wall where you want to 

place a hinged door. Hinged doors can be 
placed on interior or exterior walls, and can 
be set up so that different door styles are 
placed in each. A hinged door becomes a 
double door when its width is four feet or 
greater. 

The initial swing direction of a hinged door 
depends on the location of the mouse pointer 
relative to the wall when you click. The door 
will swing towards the side of the wall that 
you click nearest. 

The initial hinge side of a hinged door can be 
set by clicking to place the door and then 
holding the mouse button down rather than 
releasing it. Move the mouse toward the end 
of the door that you would like the hinges to 
be on: as the mouse pointer nears either end, 

the door preview’s hinge side will move to 
that end. You can also adjust the door’s 
swing direction in this manner. When the 
swing direction and hinge side are correct, 
release the mouse button.

Doorways
Choose Build> Door>  Doorway and 
click a wall to place a doorway. 

Doorways are simply openings without a 
door and can be placed on interior or exterior 
walls, or in railings and fences to provide an 
opening. You can assign a door from the 
library to a doorway if you wish.

Sliding Doors
Select Build> Door> Sliding Door 
and click on a wall where you want to 

place a sliding door. Sliding doors can be 
placed on interior or exterior walls and can 
be set up so that different door styles are 
placed in each. If placed in an exterior wall, 
the door is glass; if placed in an interior wall, 
it is a solid slab.

The initial opening side of a sliding door can 
be specified by moving the mouse pointer 
along the wall while the mouse button is still 
pressed.  

The default sliding door dimensions are 
5’-0” x 6’-8” with a 12” bottom frame and a 
6” frame on the sides and top. 

Pocket Doors
Select Build> Door> Pocket Door  
and click a wall where you want to 

place a pocket door.

As with sliding doors, the initial opening side 
of a pocket door can be specified by moving 
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the mouse pointer along the wall while the 
mouse button is still pressed.  

The default pocket door dimensions are 2’-6” 
x 6’-8” high. A pocket door becomes a 
double pocket door if its width is four feet or 
greater. 

Bifold Doors
Choose Build> Door> Bifold Door 
and click a wall where you want to 

place a bifold door.

Like a hinged door, the initial opening side of 
a bifold door depends on the location of the 
mouse pointer relative to the wall when you 
click. The door will open towards the side of 
the wall that you click nearest. 

Similarly, the initial hinge side of a sliding 
door can be specified by moving the mouse 
pointer along the wall while the mouse 
button is still pressed.  

The default interior single bifold door is 2’-
6” x 6’-8”. A bifold door becomes a double 
bifold if its width is greater than three feet.

Bifold doors always display closed in all 3D 
views.

Garage Doors
Choose Build> Door> Garage Door 
and click a wall to place a garage door.

The default garage door is 8’-0” x 7’-0” high. 
A garage door must be at least two feet wide.

In floor plan view, dashed lines show the size 
and location of the garage door when open.

Garage doors will build into a garage stem 
wall provided the room is designated as a 

garage before the door is inserted. See 
“Room Types” on page 335.

The Doors & Doorways 
Library Catalog

The Doors & Doorways library 
catalog can be accessed by selecting 

View> Library Browser and browsing to 
Chief Architect Core Catalogs> 
Architectural. This catalog contains a variety 
of interior and exterior doors, as well as 
special entryways and wrapped openings. 

Entryways and wrapped openings are 
examples of Doorways, which are wall 
openings that do not have doors within them.

To add a door to the Doorway, select a Door 
Type other than “Doorway” from the drop-
down list in the Door Specification dialog. 
See “General Panel” on page 375. 

You can also select a custom door from the 
library and place it into a doorway in floor 
plan view or any 3D view.

To place a library door in a doorway

1. Go to floor plan view or any 3D view. 
2. Open the Library Browser. 
3. Browse or search to find a custom door 

style that suits your needs. 
4. Select the door in the Library Browser, 

then click on the doorway to place the 
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selected door within it. If a door already 
exists, it is replaced. 

5. Continue clicking other doorways as 
needed.

Creating Your Own Doors
You can create custom doors and doorways 
and save them in your own library for use in 
future plans. See “Custom Symbols” on page 
1195.

Displaying Doors
The display of doors, door labels, 
opening indicators, headers, and 

casing is controlled in the Layer Display 
Options dialog. See “Layer Display Options 
Dialog” on page 149. 

Doors can only be placed in walls, so if a 
wall’s layer is turned off, any doors placed in 
that wall will not display, either. See 
“Displaying Walls” on page 281. 

If the “Doors” layer is turned off, doors and 
their casing do not display but openings in 
the walls where they are located are visible.

In Floor Plan View
A door’s jamb, casing, and swing are all 
represented in floor plan view. If a door is 
recessed, the affected wall layers will adjust 
to accommodate the casing.

Doors in exterior walls and doors that open 
to exterior type rooms such as a Garage, 
Porch, or Deck have a threshold line across 
the opening in floor plan view. See “Room 
Types” on page 335.

You can specify whether an exterior door has 
a threshold in the Door Specification dialog. 
See “Casing Panel” on page 379.

If an exterior door to a Garage room on Floor 
1 extends into a Garage stem wall or curb on 
Floor 0, its location will be indicated on 
Floor 0. You can control the display of this 
concrete cutout in the Door Specification 
dialog. See “Garages” on page 459. 

When the “Doors, Headers” layer is turned 
on in floor plan view, door headers are 
represented by dashed lines within each 
door’s opening. These lines do not 
correspond to actual framing objects and 
cannot be selected. See “Wall Framing” on 
page 578. 

The vertical casing on the sides of doors will 
display in floor plan view when the 
“Casings, Exterior” and “Casings, Interior” 
layers are turned on. See “Casing Panel” on 
page 379. 

Threshold
Line
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In 3D Views
You can specify whether a selected door is 
shown open or closed in 3D views by 

clicking the Show Door Open in 3D  and 

Show Door Closed in 3D  edit buttons as 
well as in the Door Specification dialog. See 
“Options Panel” on page 377.

If a door is set to display open in 3D, the 
angle of the open door can be changed using 
the edit handles in floor plan view. See 
“Using the Mouse” on page 367.

To display opening indicator arrows in 
Vector Views, turn on the “Opening 
Indicators” layer in the Layer Display 
Options dialog. See “Vector View” on page 
952.

Reverse door opening indicators on the 
ARCHITECTURAL panel of the Preferences 
dialog. See “Architectural Panel” on page 
108.

You can also specify whether window and 
door glass is opaque or transparent in the 
Rendering Technique Options dialog. See 

“Rendering Technique Options” on page 
954.

When displayed as opaque, window and door 
glass uses the Material Color set in the 
Define Material dialog. See “General Panel” 
on page 865. 

Door Labels
Door labels display in floor plan and cross 
section/elevation views, centered on the 
doors they represent, when the “Doors, 
Labels” layer is turned on and use the Text 
Style assigned to their layer. See “Object 
Labels” on page 1279.

Automatic door labels indicate Width and 
Height. For example: 
• In Imperial plans, the automatic label for 

a 3’-0” wide, 6’-8” high double hung win-
dow will read 3068. 

• In metric plans, the automatic label for a 
900 mm wide, 2100 mm high double 
hung window will read 900x2100.

If you prefer, you can use one of two other 
formats: Height/Width and Width Only. 
Label formats are specified in the Door 
Specification dialog or in the Door Defaults 
dialog if no schedule is present. See “Label 
Panel” on page 1277. 

Customized labels using text and Object 
Specific Text Macros as well as label 
position and orientation can also be specified 
in the Door Specification dialog. See “Text 
Macros” on page 1064. 

Door with opening indicator
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Editing Doors
Before a door can be edited, it must be 
selected. To select a door, click it when the 

Select Objects  tool or any of the Door 
Tools  are active. Doors and/or windows 
can also be group selected and edited. See 
“Selecting Objects” on page 183. 

Blocked units are made up of individual 
doors and windows that have been grouped 
together to act as one object. You can create a 
blocked door unit  or by creating a Mulled 

Unit  composed of doors and/or windows.  
See “Make Mulled Unit” on page 397. 

Select a blocked unit by clicking on it in any 
view. To select a door that is a component of 
a blocked unit, click at the location of the 
component in question, then click the Select 
Next Object  edit button. See “Selecting 
Objects” on page 183.

In the Specification Dialog
The most precise method of editing a 
door or group of doors is to use the 

Door Specification dialog. Door type, size, 
casing, materials, shape, and more can all be 
specified in this dialog. See “Door 
Specification Dialog” on page 374. 

Using the Mouse
In floor plan view, click either of the two end 
handles and drag along the wall to change the 
width. The label showing the size updates as 
the handles are dragged. Click and drag the 
Move handle at the center to move the door 
along the wall it is placed in. Use the 
triangular Rotate handle to adjust the door’s 

swing.  If the door’s label displays, an 
additional handle is available to move it.

In 3D views, a selected door has five edit 
handles: the Move handle at the center and a 
Resize handle on each edge.  Click and drag 
an edge handle to resize the door.  

Using the edit handles, doors resize 
according to the currently active Edit 
Behavior . See “Edit Behaviors” on page 
178.

A door or window moved against an 
intersecting wall temporarily stops when the 
casing meets the intersecting wall. You can 
continue to drag and it resumes movement 
past the intersecting wall. 

Using Dimensions
Like various other objects, doors can 
be moved using dimensions. See 

“Moving Objects Using Dimensions” on 
page 1019. 

You can specify how doors and windows are 
located by dimensions in the Dimension 
Defaults dialog. See “Locate Objects Panel” 
on page 992. 

Dimensions can be set to locate the centers, 
sides, casing, or rough opening of wall 
openings, or you can choose to not locate 
openings at all. If you wish, you can move a 
dimension’s extension lines to locate non-
default locations on a door after the 
dimension is drawn. See “Editing Extension 
Lines” on page 1016. 
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Using the Edit Tools
A selected door or doors can be edited in a 
variety of ways using the buttons on the edit 
toolbar. See “The Edit Toolbar” on page 37.
• Click the Change Opening/Hinge Side 

 edit button to change the side of the 
door that its hinges are on. See “Changing 
Door Swings” on page 369.

• Click the Change Swing Side  edit 
button to change which direction the 
selected door swings. 

• Click the Show Door Open in 3D  or 

Show Door Closed in 3D  edit button 
to control the selected door’s appearance 
in 3D views. See “In 3D Views” on page 
366.

• Click the Gable Over Door/Window  
to create a gable over the selected door(s) 
the next time the roof is rebuilt. See 
“Gable/Roof Lines” on page 515. 

• Click the Components  edit button to 
modify or add information related to the 
selected door in the Materials List and 
schedules. See “Components Dialog” on 
page 1300.

Centering Doors
The Center Object edit button allows 
you to center a selected door along a 

wall within a room or relative to a cabinet or 
window. See “Using Center Object” on page 
227.

To center a door along a wall 

1. Select a door or combination of win-
dows and doors in floor plan view. 

2. Click the Center Object  edit button 
then choose from one of the following 
options: 

•  Click near a wall inside a room to cen-
ter the door along that wall in that 
room.

•  Click outside the house (on the exterior 
room) near an exterior wall to center 
the door along an exterior wall.

Door Sides
Like walls, all doors have two sides: an 
interior side and an exterior side. This is the 
case even for doors placed in interior walls. 
See “Exterior and Interior Walls” on page 
269. 

By default, the interior side of the door will 
face the direction that the door swings to 
open. If you prefer, you can specify that the 
interior side face the opposite direction in the 
Door Specification dialog. See “General 
Panel” on page 375.  

You can specify the materials for the two 
sides separately in the Door Specification 
dialog. See “Materials Panel” on page 389. 

You can also specify different casing for the 
interior and exterior sides of exterior doors - 
that is, doors placed in exterior walls or walls 
defining a Garage or other exterior room 
type. See “Room Types” on page 335.  

Door Casing
Doors typically feature casing, or trim, on 
both sides of the wall opening. 
• By default, interior doors use the same 

casing profile on both sides. You can 
specify that both sides be edited sepa-
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rately in the Door Specification dialog. 
See “General Panel” on page 375.

• Exterior doors can have different casing 
profiles on their interior and exterior 
sides.

The default casing for interior and exterior 
doors is a basic rectangular stock profile. 
You can specify a door’s casing profiles  in 
the Door Specification dialog, or you can 
choose to suppress casing altogether. See 
“Casing Panel” on page 379.

A separate molding profile can be specified 
for the lintel, or top horizontal molding. See 
“Lintel Panel” on page 381.

Interior and exterior door casing will display 
in all views when the “Casings, Exterior” 
and “Casings, Interior” layers are turned on. 
In floor plan view, only the vertical side 
casing will be shown. 

Door Hardware
Handles, locks, and hinges can be assigned to 
a door in the Door Specification dialog. See 
“Hardware Panel” on page 384.

In 3D views, handles and locks can also be 
applied directly from the Library Browser. 
Select a hardware item, then click on the 
door to apply it to that side of the door. See 
“Inserted Objects” on page 837.

Changing Door Swings
Door swing direction and hinge 
side can be changed using the 

Change Opening/Hinge Side and Change 
Swing Side edit buttons.

The Change Opening/Hinge Side  edit 
button is available for all doors except 
double doors and garage doors.

The Change Swing Side  edit button is 
available for all doors except pocket doors. 

Hinged Doors
In addition to using the edit buttons, hinged 
doors’ hinge side and swing direction can be 

changed using the triangular Rotate edit 
handle.

To adjust the angle of swing:

1. In floor plan view, select the door and 
grab the triangular handle.

2. Drag to change the amount of swing. 

3. Release the mouse. 

If you drag near the closed position, the door 
snaps to a closed position.

Note: If the door is set to draw closed, the
swing as it appears in floor plan view has no
affect on the 3D view. See “Options Panel” on
page 377.
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To change the swing using edit handles:

1. In floor plan view, select the door and 
grab the triangular edit handle.

2. Drag the pointer along the path of the 
new arc to change the hinge side and/or 
swing direction.

3. Release the mouse.

To change the swing using edit buttons:

1. In floor plan view, select the door.
2. To change the hinge side, click the 

Change Opening/Hinge Side  edit 
button.

3. To change the swing direction, click the 
Change Swing Side  edit button.

Sliding Doors
To change the side of a sliding door that is 
fixed, select the sliding door then click the 

Change Opening/Hinge Side  edit 
button.

You can specify a Double Hinged Door
to swing from its center in the Door
Specification dialog. See “Options

Panel” on page 377.

You can also specify a Hinged Door to
swing in both directions in the Door
Specification dialog. See “Options

Panel” on page 377.



Changing Door Swings

 371

To flip the fixed and moving sides of the 

door, click the Change Swing Side  edit 
button.

As with hinged doors, you can also change 
the Opening/Hinge and Swing sides of a 
sliding door by clicking and dragging the 
triangular edit handle.

Pocket Doors
To change the direction of a pocket door, 
select it and click the Change Opening/
Hinge Side  edit button.

As with hinged doors, you can also change 
the Opening/Hinge side of a pocket door by 
clicking and dragging the triangular edit 
handle.

Bifold Doors
To change the side of a bifold door that is 
fixed, select it then click the Change 
Opening/Hinge Side  edit button.

To change the hinged side of the door, click 

the Change Swing Side  edit button.

As with hinged doors, you can also change 
the Opening/Hinge and Swing sides of a 
bifold door by clicking and dragging the 
triangular edit handle.

Garage Doors
To change the side of a garage door that it 
faces, select it and click the Change Swing 
Side  edit button.

Note: There must be enough room for the
entire door to fit in the opposite wall or the
door does not change.
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As with other door types, you can also 
change the Swing side of a bifold door by 
clicking and dragging the triangular edit 
handle. 

In Door Schedules
Both Hinge Side and Swing can be included 
in Door Schedules. See “Columns and 
Objects to Include” on page 1271. 

Special Doors
A variety of special doors and doorways can 
be created in Chief Architect.

Transoms Above Doors
Transom windows above doors are created 
the same as other stacked windows. See 
“Grouped Windows” on page 396.

Wrapped Openings
Wrapped openings of various shapes are 
available in the Doors & Doorways 
Library. 

You can also create a wrapped opening by 
unchecking Use Interior Casing and/or  Use 
Exterior Casing in a Doorway’s Door 
Specification dialog. See “Casing Panel” on 
page 379. If base molding is present, it will 
wrap around the opening. 

Openings in Railings

Use the Doorway  tool to open a railing 
for a stairway or other access. 

To open a railing across an entire section, 
resize the doorway’s Width so that it is 
greater than the length of the railing in the 
Door Specification dialog. The opening 
resizes to the maximum width possible for 
that space. See “General Panel” on page 375.

To add a gate, specify the doorway’s Door 
Type as a Door, then choose an appropriate 
gate as the Door Style. A selection of gates is 
available in the Fences & Railings library 
folder. See “Placing Library Objects” on 
page 836. 

Doorway
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Recessed Doors
A door placed in a brick or stone wall is often 
recessed into the wall’s exterior. In the 
illustration below, the door to the right is 
recessed, so the brick wraps the opening. The 
door on the left is not recessed, so the casing 
is outside the brick. 

You can specify a door as recessed in the 
Door Specification dialog. See “Options 
Panel” on page 377.

Blocked Doors and Windows
Combinations of doors and windows can be 
blocked. Blocked units are mulled together 
and can be copied together as a unit. Blocked 
units containing doors can be treated as 
either windows or doors for materials list and 
schedule generation. See “Make Mulled 
Unit” on page 397.

Creating a Doorway 
with a Railing

When a railing is specified as No Room Def, 
it can be positioned within a Doorway .

To create a doorway with railing

1. Place a Doorway  at the desired loca-
tion in your plan.

2. Select Build> Wall> Straight 
Railing , then click and drag to draw 
a railing parallel to the wall with the 
doorway. 

3. Select the railing, then use the Resize 
edit handles to adjust the length of the 
railing as needed. See “Using the Edit 
Handles” on page 188.

4. With the railing selected, click the Open 
Object  edit button.

5. On the GENERAL panel of the Railing 
Specification dialog, check No Room 
Def and click OK. See “General Panel” 
on page 309.

6. With the railing still selected, Ctrl + drag 
it into position within the doorway. See 
“To move an object freely” on page 221.

Placing a Gable Over a Door
Click the Gable Over Door/Window 
edit button to produce a gable roof 

over the selected door(s) the next time 
automatic roofs are built. See “Gable/Roof 
Lines” on page 515.

You can manually edit or delete this gable 
line at any time. Your changes take effect 

Positioning a railing in a doorway
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when the automatic roofs are rebuilt. This 
can also be used with group selected doors.

Importing Doors
You can import custom door symbols and 
save them in your library for use in future 
plans. See “Custom Symbols” on page 1195.

Custom Muntins
Like windows, doors that are specified as 
“Glass” can have custom muntins. Custom 
muntins are created from CAD lines. See 
“Custom Muntins” on page 405.

Door Specification Dialog
To open the Interior or Exterior Door 
Specification dialog, select a door or 

group of doors and click the Open Object 
edit button or double-click on a door using 

the Select Objects  or any Door  tool.

Whether a selected door is Interior or 
Exterior depends on where it is placed. See 
“Interior vs Exterior Doors” on page 362.

The Lintel, Framing, and Energy Values
panels are also found in the Window
Specification dialog. In addition, the

Frame panel for windows is similar to the
Jamb panel for doors. See “Window Specifi-
cation Dialog” on page 406. 
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General Panel

General - 

• Door Style - Select Slab, Glass, Panel, or 
Louvered from the drop-down list; select 
a style from the Library; or choose Use 
Default to use the default door style set in 
the Door Defaults dialog. See “Door 
Defaults” on page 361.

• Select “Library” from the drop-down list 
or click the Library button to choose a 
door symbol from the library. Once a 

library door is selected, its name is added 
to the Door Style list. See “Select Library 
Object Dialog” on page 838.

• Specify the Door Type as Doorway, 
Hinged, Slider, Pocket, Bifold, or Garage. 
In the Door Defaults dialogs, the Door 
Type cannot be changed. 

• Specify the Swing Angle of the selected 
door in floor plan view, between 0° and 
180°. An angle of 0° displays the door as 
closed and an angle of 180° displays it as 

1
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wide open. The Swing Angle for Bifold 
doors and double doors that swing from 
the center can be no more than 90°. 

The Swing Angle also affects the door’s 
appearance in 3D views if Draw Closed 
is unchecked on the OPTIONS panel. 

Specify the Size and Position of the 
selected door. 

• Specify the Width, Height, and Thick-
ness of the door. These values do not 
include the jamb.

• Select the Elevation Reference from the 
drop-down list. This determines where the 
next two settings are measured from and 
also affects their labels.

• Specify the height to Top, measured from 
the selected Elevation Reference to the 
top of the door frame. 

• Specify the height to Bottom, measured 
from the selected Elevation Reference to 
the bottom of the door frame. 

Panel Frame Options - Specify the 
dimensions of the selected door’s rails 

and stiles. Only available for Glass, Panel, 
and Louvered doors. 
• Specify the Width of the stiles and top 

rail. 
• Specify the height of the Bottom rail.

Symbol Options - Check Reverse 
Interior/Exterior to reverse the two 

sides of the selected door so that they face 
the opposite direction. Only available when a 
door symbol from the Library is specified as 
the Door Style. See “Door Sides” on page 
368. 

Louvers - 

• Specify the Size, or vertical height, of the 
selected door’s louvers. Only available 
for Louvered and Glass Louvered doors.

• By default, louvers face the direction that 
the door swings. Check Reverse Direc-
tion to reverse the direction that they face.

The Interior Doors settings are only 
available when the selected door is 

placed in an interior wall. See “Exterior and 
Interior Walls” on page 269.
• Check Separate Trim and Materials for 

Each Side to specify the casing, lintels, 
and all materials for each side of the 
selected door independently. When 
unchecked, the two sides of the door use 
the same trim and materials. 

Check Include in Schedule to include 
the selected door(s) in Door Schedules. 

See “The Schedule Tools” on page 1268. 

A preview of the door displays on the 
right side of the dialog box. A label 

indicates which side of the door is its Interior 
and which is its Exterior. See “Dialog 
Preview Panes” on page 41.

2
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Options Panel

Specify the number of Door Units or 
panels that the selected door has. Not 

available for garage doors. 
• Select Calculate From Width to use the 

program defaults. Hinged, Pocket and 
Bifold doors default to Single Door when 
less than four feet (1200 mm) wide. If the 
width is greater than four feet, Double 
Door is the default. 

• Select Single Door to force the selected 
hinged, pocket or bifold door to be a sin-
gle door, regardless of its width.

• Select Double Door to force the selected 
hinged, pocket or bifold door to be a dou-
ble door, regardless of its width.

• If a Slider door is selected, instead choose 
Two, Three, or Four Panel.

3D Display - Specify whether the 
selected door is drawn open or closed in 

3D and cross section/elevation views. 

If Draw Open is selected, the Swing Angle 
set on the GENERAL panel is used in 3D 
views. See “General Panel” on page 375.

Door Swing - Specify how the selected 
door swings. Most options here are 

only available when the selected Hinged or 

1

Note: The defaults for Calculate From Width
are not editable.

2

3
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Pocket door is a Double Door. Not available 
for Bifold, Slider or Garage doors. See 
“Changing Door Swings” on page 369.
• Check Both Doors Swing to allow both 

sides of a Double Door to swing. 
• Check Left Swing Only or Right Swing 

Only to allow only the left or right side of 
a Double Door to swing. 

• Check Swings from Center to create a 
Double Door with hinges at the center 
rather than at the outside edges.  

• Check Swings Both Directions to allow a 
door or both sides of a Double Door to 
swing both directions. 

For a selected Garage Door, specify 
the number of Vertical Panels.

• If the selected door has been specified as 
the “Glass” Door Type on the GENERAL 
panel, the top Vertical Panel will be glass 
and the rest, solid panels. The number and 
style of the lites and the Muntin Width 
can be specified on the LITES panel.

The Safety settings afffect how the 
selected door is listed in the Door 

Schedule. See “Schedules and Object 
Labels” on page 1267.
• Check Tempered Glass to specify the 

selected door as having tempered glass. 
• Check Fire Door to specify the selected 

door as being a fire door. 

The Recessed into Wall options allow 
you to recess the selected door’s jamb 

into a wall, away from the exterior surface. 
This setting also affects the exterior casing 
and lintel, if used. Only available if the door 
is placed in a multi-layered wall. See “Wall 
Type Definitions” on page 302. 

• Check Recessed to activate the settings 
that follow.

• Select To Main Layer to recess the door 
to the wall’s Main Layer. 

• Select To Sheathing Layer to recess the 
door to the wall’s sheathing layer. 

In Curved Wall - Specify whether a 
door placed in a curved wall is Straight 

or Curved. Curved is selected for Pocket 
Doors and cannot be changed. See “Drawing 
Curved Walls” on page 278.

Plinth Blocks - Add an Interior Plinth 
Block and/or Exterior Plinth Block to 

4

5

6

Not Recessed

Recessed to Main Layer

Recessed to Sheathing Layer

7

Straight

Curved
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the selected door. Plinth blocks do not 
display in 3D views, but are counted in the 
Materials List. 

A preview of the door displays on the 
right side of the dialog box. See 

“Dialog Preview Panes” on page 41.

Casing Panel

Check Use Interior Casing to enable 
the settings that follow, then specify the 

interior casing for the selected door(s) using 
those settings. When this box is unchecked, 
no casing is used.
• Casing Profile - Click the Library but-

ton to select a molding profile for the cas-

ing. A preview of the casing profile 
displays to the right. See “Select Library 
Object Dialog” on page 838.

• Click the Clear button to remove a 
selected casing profile from the door. 

• Specify the Width of the selected casing.

9

1
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• Define the Depth of the selected casing, 
as measured from the back to the front of 
the casing profile.

• Define the Reveal, which is the distance 
between the inside edge of the door frame 
and the inside edge of the casing. 

Check Use Exterior Casing to enable 
the settings that follow, then specify the 

exterior casing for the selected door(s) These 
settings are the same as those for the Interior 
Casing, and are not available for doors in 
interior walls unless Use Exterior Trim and 
Materials is checked on the GENERAL panel. 
See “General Panel” on page 375. 

Uncheck Use Sill/Threshold to prevent 
a sill from being generated under the 

door. See “Displaying Doors” on page 365. 

The Double Wall Options affect doors 
placed in a Double Wall. See “Double 

Walls” on page 299. 
• Select Through to create a single jamb 

running through both Double Walls. This 
option is selected by default.

• If Enlarged is selected, casing is created 
only on the wall the door is inserted in. 
The opening on the other wall is enlarged 
to accommodate the casing.

• Select Double to place a second door in 
the Double Wall opposite the selected 
door. This second door cannot be 
selected. Casing is produced as with the 
Through type window.

• Select Not Through to place the door in 
one wall with no corresponding opening 
in the other wall.

The Curved Wall Casing settings are 
enabled if the selected door is located in 

a curved wall. See “Drawing Curved Walls” 
on page 278. 

Door and window casing and jamb can be 
constructed three ways in curved walls: 
• Straight - Both the door and casing are 

straight. This can be used where the wall’s 
curvature is not too sharp and the opening 
is not too wide. It cannot be selected for 
Pocket Doors, which must be curved if 
placed in a curved wall. 

• Radial - A vertical surface that would be 
perpendicular to a straight wall has its 
plane pass through the wall's center of 
curvature. 

• Parallel - A vertical surface that would be 
perpendicular to a straight wall remains 
parallel to the line from the wall center 
through the opening center. 

A preview of the door displays on the 
right side of the dialog box. If casing is 

not specified for a Doorway, the Show Wall 

2
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option will be toggled on automatically. See 
“Dialog Preview Panes” on page 41.

Lintel Panel
The settings on the LINTEL panel allow you 
to assign a lintel,or top molding that meets 
the side casing using a butt joint instead of a 
mitred joint. These settings are not available 

if the door has a reflected arch. See “Arch 
Panel” on page 383.

The profiles and materials of door and 
window lintels can be included in Room 
Finish Schedules.

Check Use Interior Lintel to enable 
the settings that follow, then specify the 

lintel applied to the interior side of the 
selected door(s) using these settings. When 
this box is unchecked, no lintel is used.
• Lintel Profile - Click the Library button 

to select a molding profile for the lintel. A 
preview of the selected profile displays to 
the right. See “Select Library Object Dia-
log” on page 838.

• Click the Clear button to remove a 
selected lintel profile from the door. 

• Specify the Width of the lintel. This 
value is independent of the casing’s 
width; however, the lintel does inherit its 
depth from the casing.

• Specify how far to Extend the lintel past 
the outside edges of the casing on each 
side. 

• Check Wrap to wrap the lintel profile 
back toward the wall. 

Check Use Exterior Lintel to enable 
the settings that follow, then specify the 

exterior lintel for the selected door(s) using 

1
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these settings. These settings are the same as 
those for the Interior Lintel, and are not 
available for doors in interior walls unless 
Use Exterior Trim and Materials is checked 

on the GENERAL panel. See “General Panel” 
on page 375. 

A preview of the door displays on the 
right side of the dialog box. See 

“Dialog Preview Panes” on page 41.

Lites Panel
The settings on the LITES panel of the Door 
Specification dialogs are only available 
when the selected door is specified as a Glass 
door on the General Panel. These settings are 

also found on the LITES panel of the Window 
Specification dialog. See “Lites Panel” on 
page 416.

Jamb Panel
The settings on the JAMB panel are similar to 
those on the FRAME panel of the Window 

Specification dialog. See “Frame Panel” on 
page 415.

Specify the attributes of the selected 
door’s Jamb. A door’s jamb is not 

included in its size, which is set on the 
General Panel.
• Specify the Sides Width, which is the 

thickness of the pieces of the door jamb 

that display in floor plan view. Changing 
this value does not affect the door’s size.

• Uncheck Fit Jamb to Wall to specify the 
Depth and Inset of the selected door’s 
jamb. When this box is checked, the jamb 
Depth automatically extends from the 
Recessed Into Wall layer to the wall’s 

3
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inside surface with an Inset of 0”. The 
Recessed Into Wall layer is specified on 
the Options Panel of this dialog.

• Specify the Depth of the door jamb from 
front to back.

• Specify the jamb’s Inset, which is mea-
sured from the Recessed Into Wall layer 

and moves the door jamb towards its inte-
rior side. If used, the casing and lintel are 
not affected by this setting.

A preview of the door displays on the 
right side of the dialog box. See 

“Dialog Preview Panes” on page 41.

Arch Panel
The settings on the ARCH panel are not 
available if the selected door is a Sliding, 
Bifold or Garage door. They are also 

unavailable if the selected door has been 
assigned a lintel. See “Lintel Panel” on page 
381.

Define the style and size of the Arch. • Select a Type of arch from the drop-down 
list.

2
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• Specify the Height of the arch, as mea-
sured from the base of the arch to the top 
of the door. Not available for Round Top 
and Octagonal Arches.

• The Radius can also be defined for Tudor 
and Double Arches.

Options - Define the orientation of the 
arch. 

• Check Reflect to reflect the arch, top to 
bottom. This is rarely used for doors, but 
can be specified for windows to create 
unique configurations. Not available if a 
lintel is specified for the selected door. 
See “Lintel Panel” on page 381.

• Select Full Arch to produce an arch with 
the apex at the door’s center.

• Select Left Arch to produce an arch with 
the apex on the door’s right side.

• Select Right Arch to produce an arch 
with the apex on the door’s left side. 

A preview of the door displays on the 
right side of the dialog box. See 

“Dialog Preview Panes” on page 41.

Hardware Panel
Many of the settings on the HARDWARE 
panel are Dynamic Defaults: if “Use 
Default” is selected, the setting in the Door 

Defaults dialog is used. See “Dynamic 
Defaults” on page 76.

Round
 Top

Gothic Elliptical Flat
Top

Tudor Double Trifoil Octo-
gonal

Dogear

Broken
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Specify the Handles to be used on the 
selected door. 

• Select an Interior Handle and/or Exte-
rior Handle from the drop-down lists. 
Select “Library” or click the Library but-
ton to select a handle from the library. See 
“Select Library Object Dialog” on page 
838.

• Specify the location of the door handles 
In From Door Edge.

• Specify the location of the door handles 
Up From Bottom.

Specify the door’s interior and exterior 
Locks. 

• Select an Interior Lock and/or Exterior 
Lock from the drop-down lists. Select 
“Library” or click the Library button to 
select a lock from the library. 

• Specify the location of the door locks Up 
From Bottom. The locks use the same In 
From Door Edge value as the handles.

Specify the Hinges to be used on the 
selected door.

• Select a style of Hinges from the drop-
down list. Select “Library” or click the 
Library button to select a hinges from the 
library. 

• Specify the distance In From Top/Bot-
tom of the door to the center of the top 
and bottom hinges. 

• Specify the Number of Hinges on the 
selected door. Interior hinged doors and 

1

2 Note: For hinges to look right, it is best to
have at least a 1/4" (6 mm) reveal for the inte-
rior, or hinge side, door casing. 

3
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bifold doors typically have two hinges 
while exterior hinged doors have three.

Check Hardware on Fixed Section to 
include handles, locks, and hinges on 

the fixed side of a double Hinged door. Only 
available for Double Doors with Left or 

Right Swing Only selected. See “Options 
Panel” on page 377. 

A preview of the door displays on the 
right side of the dialog box. See 

“Dialog Preview Panes” on page 41.

Shutters Panel
The settings on the SHUTTERS panel of the 
Door Specification dialogs are also found on 
the Shutters panel of the Window 

Specification dialog. See “Shutters Panel” 
on page 386.

Framing Panel
The settings on the FRAMING panel control 
how the selected door or doors is framed. A 
similar panel is also found in the Window 
Specification dialog. See “Window 
Specification Dialog” on page 406.

4 5

Chief Architect is dependent upon user
input and does not calculate loads or

perform structural analysis. Always consult
your local building authorities and contact a
licensed engineer for structural calculations.



Door Specification Dialog

 387

Specify the characteristics of the 
selected door’s Header.

• Uncheck Include Header to prevent a 
structural header from generating when 
wall framing is created. When this box is 
checked, a header as defined below is 
generated; when it is unchecked, a single, 
non-structural, horizontal framing mem-
ber of the same type as the wall studs is 
created above the door opening. 

• Select the header’s Type from the drop-
down list.

• Specify the Thickness of each header 
framing member.

• Specify the Count, which is the number 
of the framing members used to create 

the header. Up to 10 headers can be spec-
ified, but only those that fit within the 
wall’s framing layer will be generated 
when wall framing is created. 

• Specify the vertical Depth of the header.
• In the Door and Window Defaults dia-

logs, an additional Calculate from 
Width checkbox is available. When 
checked, the header Depth is automati-
cally calculated based on settings in the 
Framing Defaults dialog and the door’s 
current width. See “Openings Panel” on 
page 590. 

Trimmers - Specify the number of 
trimmers to be generated on each side 

of the selected door. 

1
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Rough Opening - Specify the amount 
to add to Each Side, the Top and the 

Bottom for the door’s framed rough opening. 
The rough opening should be large enough to 
accommodate the door frame and space for 
shims. Window frames do not need to be 
included in the rough opening: only shim 
space. If the Bottom Rough Opening value is 
greater than the Floor to Bottom value, the 
difference is added to the top of the rough 
opening when framing is built. 

Add for Concrete Cutout - Specify 
the amount to add to Each Side of the 

door opening when the upper part of the door 
is in a framed wall and the lower part is 
located in a concrete or masonry wall, stem 

wall, or garage curb. See “Wall Type 
Definitions” on page 302.
• Uncheck Show in Plan to suppress the 

display of the concrete cutout in floor 
plan view. A concrete cutout will only 
display in floor plan view if it is located 
in a garage curb. See “In Floor Plan 
View” on page 365.

Sill - When the bottom of a door is 
raised sufficiently off the floor, it will 

require a sill as part of its framing. 
• Specify the vertical Thickness of the sill.
• Check Double Sill to generate two sill 

members of the specified thickness 
instead of one.

Energy Values Panel
The settings on the ENERGY VALUES panel 
let you specify information used for export to 

REScheck. See “Export to REScheck” on 
page 1192.

Assembly - Select a Door Type from 
the drop-down list.

Energy Values - 

3
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• Specify the selected door’s U-Factor.
• Specify the selected door’s SHGC (Solar 

Heat Gain Coefficient). 

Layer Panel
The LAYER panel is available for a variety of 
different objects. For more information, see 
“Layer Panel” on page 154.

Materials Panel
The MATERIALS panel is available for a 
variety of objects throughout the program. 

For more information, see “Materials Panel” 
on page 852.

Label Panel
Door labels display in floor plan view and 
cross section/elevation views when the 
“Doors, Labels” is turned on and use the Text 
Style assigned to that layer. See “Door 
Labels” on page 366. 

For information about the settings on this 
panel, see “Label Panel” on page 1280.

Door Schedules
The Door Schedule tool allows you to 
produce customizable door schedules 

as well as door labels that display schedule 
numbers. See “The Schedule Tools” on page 
1268.

If a door is included in a Mulled Unit, it may 
instead be listed in a window schedule. See 
“Make Mulled Unit” on page 397. 

Door casing profiles and materials can also 
be included in Room Finish Schedules.

Hinge and Swing Side
Hinge Side and Swing Side columns can be 
added to door schedules. See “Columns and 
Objects to Include” on page 1271.

There are various methods for describing 
hinge side as well as door swing direction, or 
door hand. In Chief Architect, both are 

described from the perspective of someone 
standing on the exterior side of the door.
• The hinge side will be described as L if 

the hinges are on the left side of the door, 
as viewed from its exterior side. If the 
hinges are on the right side, they will be 
described as R.

• The swing direction will be Out if the 
door swings towards the viewer on the 
exterior side.

• The swing direction will be In if the door 
swings away from the viewer, towards the 
interior.

Regardless of where they are located in a 
plan, all doors have an interior and an 
exterior side, as do the walls they are placed 
in. See “Interior and Exterior Surfaces” on 
page 304.
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Chapter 11:

Windows

Chief Architect can model a wide variety of 
windows. Fixed glass, hung, casement, 
sliding, awning, hopper, and louver window 
styles can all be created with the standard 
Window tool. The shape of a window can be 
angled or made into a round top or other arch 
styles. Chief Architect can create bay, box, 
and bow windows with a single click. In 
addition, the library contains many mulled 
window combinations and additional name-
brand door catalogs are also available for 
download from our web site,  chiefarchi-
tect.com.

Once windows have been placed in the 
model, the program can automatically 
generate a window schedule. See “The 
Schedule Tools” on page 1268. 

Chapter Contents
•      Window Defaults
•      The Window Tools
•      Special Windows
•      Grouped Windows
•      Make Mulled Unit
•      Window Levels
•      Displaying Windows
•      Editing Windows
•      Custom Muntins
•      Window Specification Dialog
•      Bay, Box, and Bow Windows
•      Bay, Box, Bow Windows and Roofs
•      Bay/Box and Bow Window 

Specification Dialogs
•      Window Schedules

http://www.chiefarchitect.com/
http://www.chiefarchitect.com/
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Window Defaults
Default Settings can be accessed by 
selecting Edit> Default Settings. 

Select Window from the Default Settings 
dialog and click the Edit button.

You can also double-click the Window 
Tools  parent button to open the Window 
Defaults dialog. 

The settings in the Window Defaults dialog 
control the attributes of a window when it is 
initially placed in a plan, so you should 
define the type of window that will be placed 
most often in your model. See “Default 
Settings” on page 74.

The panels in the Window Defaults dialog 
are similar to those found in the Window 
Specification dialog, with one exception: 

On the GENERAL panel of the Window 
Defaults dialog, you can specify the 
Minimum Separation for component doors 
and windows in mulled units in the plan.

The Minimum Separation value in the 
Window Defaults dialog specifies how close 
windows in a mulled unit can be to each 

other. This setting also determines the width 
of the shared casing. If 0 is specified, no 
casing is created between mulled units. 

For more information, see “Window 
Specification Dialog” on page 406.

Dynamic Window Defaults
A variety of window default values are 
dynamic, including the Window Type, Add 
for Rough Opening values, Casing, Lintel 
and Sill Specifications, Sash and Frame 
sizes, and Treatments. All Materials are 
also dynamic. When a dynamic default is 
changed, existing windows using the default 
value are affected. See “Dynamic Defaults” 
on page 76. 

Window Framing
The defaults for window framing can be 
defined in the Window Defaults dialogs. You 
can also specify an additional amount to 
cutout for window openings in concrete 
walls when the upper part of the window is 
located in a framed wall. See “Framing 
Panel” on page 424.

The Window Tools
To place a window, select Build> 
Window and choose the desired 

Window Tool. Move your mouse pointer 
over a wall section, then click to place a 
window in the wall at that location.
• If there is room enough along the wall to 

fit a 6” (150 mm) wide Standard Window, 

a preview of the window will display and 
a window can be placed. 

• The Bay, Box, and Bow Window tools do 
not have preview outlines. If a minimum 
width of 30” (725 mm) cannot be accom-
modated at the location where you click, 
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a warning message will display and a 
window unit will not be created.

Standard Windows can be placed in both 
straight and curved walls, as well as span 
across straight, collinear wall segments. In 
contrast, a Bay, Box, or Bow Window can 
only be placed in a single, straight wall.

Windows cannot be placed in a wall 
specified as Invisible or if the wall in 
question is on a locked layer. See “Locking 
Layers” on page 145.

Standard Windows
Select Build> Window> Window, 
then click on a straight or curved wall 

to place a Standard Window at that location.

A Standard Window is a single window that 
is not a bay, box, bow window, a corner 
window or a blocked unit. These special 
types are made up of multiple Standard 
Windows. 

A Standard Window that is part of a special 
window is called a Component Window.

Standard Windows can be specified as any of 
a variety of window types, such as double 
hung, casement and awning. See “Window 
Specification Dialog” on page 406.

Bay Windows

A Bay Window is composed of three 
wall sections, each with a single 

component window. The two side walls are 
at an angle to the main wall. Select Build> 

Window> Bay Window and click on a 
straight wall to produce a bay window. 

When initially placed, bay windows measure  
2’-2” across at the front, 4’-2” across at the 
back, and are 1’-0” deep. The component 
windows are specified in the Window 
Defaults dialog and their sizes adjust to fit 
the available space. 

Box Windows
A Box Window is a bay window with 
side angles set at 90°. Select Build> 

Window> Box Window and click on a 
straight wall to produce a box window. 

Box windows initially measure 4’-2” wide 
with a depth of 1’-6”. The component 
windows are specified in the Window 
Defaults dialog and their sizes adjust to fit 
the available space. 

Bow Windows
A Bow Window is a group of 
identical wall segments that form a 

segmented curve. Select Build> Window> 
Bow Window and click on a straight wall to 
produce a 5-section bow window. 

Bow windows can be composed of between 
two and twenty sections. The number of bow 
window components can be changed in the 
Bow Window Specification dialog. See 

The roof is affected by Bay, Box and
Bow Windows. These windows should

therefore be placed before the roof is built.
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“Bay/Box and Bow Window 
Specification Dialogs” on page 429.

The component windows are specified in the 
Window Defaults dialog. Their sizes adjust 
to fit the available space.

The 5-section bow below has a 4’-10” radius 
centered 3’-9” inside the wall, giving an 
opening 5’-10” across and a depth of 11½”.

Note that for a bow with an odd number of 
sections, the radial dimension is from the 
center of the arc to an outside corner where 
two window sections join. The depth (11 ½”) 
is measured to the flat area of the center 
section, not to a corner. As a result, the radius 
is a bit greater  than the sum of the depth and 
the distance from the center of the bow’s 
curve to the exterior of the wall.

Pass-Through
Select Build> Window> Pass-
Through, then click on a straight or 

curved wall to place a Pass Through at that 
location. 

A Pass-Through is simply a wall opening 
without a window unit placed inside. Like a 
window, it can have casing and a sill. It does 
not, however, have a sash, frame, or glass. It 
is one of the window Types available in the 
Window Specification dialog. See “General 
Panel” on page 407.

Windows Library
Select View> Library Browser, then 
browse to Chief Architect Core 

Catalogs> Architectural> Windows to access 
a selection of special window units. Select 
the desired window, then click on a wall to 
place the window at that location. 

Special Windows
A variety of special windows can be created 
using multiple standard windows, the edit 
tools or custom symbols.

Creating Manual Bay, Box 
and Bow Windows

Sometimes it is easier to draw bay, box and 
bow windows manually than to use the 
automatic tools. Bays created using walls can 

have more than one window per section, 
which is not possible using a bay window 
unit.

Bear in mind that moving a manually created 
bay, box or bow window is generally more 
difficult than moving a unit created with one 

of the Window Tools  since it is 
composed of individual walls.

Note: Bay, box, and bow window areas are
not included in the living area or in room stan-
dard area calculations. They are included in
room interior area calculations.
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Corner Windows
To create a corner window, first create the 
desired window on each side of the corner. 
For best results, the heights, casing, and sills 
of both windows should be the same. For 
glass that meets at the corner: 
• Specify both windows as Fixed Glass.
• Use each window’s Move edit handle to 

position it all the way in the corner. To do 
this, drag the Move handle past the cor-
ner and parallel to the wall that the win-
dow is placed in. When the preview 
outline moves into the middle of the wall 
corner, release the mouse button.

• Uncheck Has Corner Post in the 
Window Specification dialog. See 
“Frame Panel” on page 415.

Angled top, or shaped windows can be 
components of corner windows as long as 
their heights are equal at the corners. 
Windows with single or two segment tops 
can be used, but windows with three cannot. 
If a two segment window is used, the 
segment nearest the corner must be flat.

When a corner post is required, there are a 
number of ways to control its size.

• Use dimensions to position the windows 
relative to the corner. By default, win-
dows will stop when their interior casing 
bumps into the adjacent wall. See “Edit-
ing Windows” on page 403. 

• To move a window all the way into a cor-
ner, check Ignore Casing for Opening 
Resize. See “General Plan Defaults Dia-
log” on page 88. 

• To produce a minimal corner post and no 
siding or casing between the windows, 
use their Move edit handles. Click and 
drag each window past the exterior cor-
ner until its preview outline moves into 
the middle of the wall corner. 

Special Window Shapes
A selection of special shaped windows is 
available in the Windows Library, including 
arched windows and mulled units. 

In addition, you can create a wide variety of 
window shapes in the Window Specification 
dialog, including:
• Arched windows. See “Arch Panel” on 

page 420.
• Trapezoidal windows. See “Shape Panel” 

on page 418.
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• Round windows can be created by 
reflecting an Round Arch window verti-
cally. See “Arch Panel” on page 420.

Recessed Windows
A window or mulled unit placed in a brick or 
stone wall is often recessed into the wall’s 
exterior, so the brick wraps the opening. 

You can specify a window as recessed in the 
Window Specification dialog. See “Options 
Panel” on page 408.

Window Symbols
You can import custom windows and save 
them in your own library for use in future 
plans. See “Custom Symbols” on page 1195.

By default, window symbols are assigned the 
“Custom” Type in Window Schedules and in 
the Window Symbol Specification dialog, 
and they use automatic labels appended with 
the letters CU. The Type is derived from the 
Symbol Specification dialog, where you can 
also select the CAD block used to represent 
the symbol in floor plan view. See “Symbol 
Specification Dialog” on page 1195. 

Placing a Gable 
Over a Window

Click the Gable Over Door/Window 
edit button to produce a gable roof 

over the selected window(s) the next time 
automatic roofs are built. See “Gable/Roof 
Lines” on page 515.

You can manually edit or delete this gable 
line at any time. Your changes take effect 
when the automatic roofs are rebuilt. This 
tool can also be used with group selected 
windows.

Stained Glass
A selection of solid stained glass materials is 
available in the Chief Architect Core 
Catalogs> Materials> Glass library. See 
“Materials” on page 847.

Vents
A selection of attic, foundation and gable 
vents are available in the Library Browser. 
See “The Library” on page 819.

Vents are placed in the same manner as 
regular windows and can be edited in much 
the same way, as well. 

Grouped Windows
Windows can be grouped together to create a 
wide variety of custom configurations. 
Stacked windows are easy to create in 3D 

views, particularly cross section/elevation 
views, using their edit handles. See “Editing 
Windows” on page 403.
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Notice how the windows and door in this 
example are separate, with spaces between 
them. Doors and/or windows can also be 
organized into a unit in which there are no 
spaces between the windows and door units, 
and the casing between them is shared. 

To help organize their display in floor plan 
view, you can place stacked windows of 
varying heights on different Window Levels. 
See “Window Levels” on page 400.

Automatically Mulled Openings
To form a mulled group of windows and/or 
doors, move them close enough together so 
that their casings touch. Once the casings 
touch, the windows are mulled together with 
one casing between the two of them. 

The sill of each window in the group must be 
at the same level for them to share the middle 

casing. The casing tops do not have to be at 
the same level. The casings are modeled as if 
they are one unit but the windows  remain 
separate objects for dimensioning and the 
Materials List.

Windows can be automatically mulled to 
doors if the bottom of the window is at the 
elevation of the floor, equal to the bottom of 
the door. 

The Minimum Separation value in the 
Window Defaults dialog specifies how close 
mulled window and door units can be to each 
other. Define a value that specifies the 
desired width for the shared casing. See 
“Window Defaults” on page 392.

Mulled Units in the Library
A selection of mulled window units is 
available in the Windows library. To place 
one in your plan, select it and click on a wall 
in any view. See “Placing Library Objects” 
on page 836.

Make Mulled Unit
Windows and doors can be selected as 
a group and blocked together into a 

single unit by clicking the Make Mulled 
Unit edit button.  

Make Mulled Unit
The Make Mulled Unit edit tool 
allows you to block a group of 

selected windows and/or doors into a single 
unit. 

Wall openings in a mulled unit are referred to 
as components. Components of a mulled unit 
must be within 24” (600 mm) of one another 
in order to become a blocked unit; however, 
their casings do not have to touch.



398

Chief Architect  X8 Reference Manual

Windows and doors in a mulled unit can be 
framed as a single opening or as multiple 
openings, and can be listed as a single unit or 
individual objects in the Materials List. See 
“Materials Lists” on page 1283. 

To create a mulled unit

1. In any view, group-select multiple win-
dows and doors on the same wall that 
are within 24” of each other. 

2. Click the Make Mulled Unit  edit 
button to create a block. 

The Make Mulled Unit  edit tool can be 
used to block component windows and/or 
doors only if they meet the following 
requirements:
• They must be placed in the same wall.
• Adjacent objects be within 24” (600 mm) 

of one another (side to side or top to bot-
tom).

• The edges of adjacent components that 
face one another must be parallel.

• The edges of adjacent components that 
face one another must be straight, not 
curved.

• The selected components can be adjacent 
vertically or horizontally, but not a com-
bination of the two. Complex units can be 
formed only by mulling several blocks 
together.

Unlike automatically mulled openings, 
adjacent component edges of mulled units do 
not need to be the same length.

Mulling Stacked Openings
Group selection can be done in floor plan 
view or any 3D view. Floor plan views work 
well for blocking windows that are side-by-
side, but a camera or elevation view is 
needed to block vertically stacked objects. 

To block stacked openings

1. In a cross section/elevation view, select 
the door and the windows on level 1 and 
2 above it, then click the Make Mulled 
Unit  edit button. 

2. Repeat step 1 with the sidelight on the 
right and the window above it. 

3. Repeat step 1 with the sidelight on the 
left and the window above it.

4. Group select the three vertically joined 
units and click the Make Mulled 
Unit  edit button to join them side to 
side. 

The configuration of the horizontal and 
vertical mullions in a mulled unit will vary 
depending on the order in which you block 
stacked openings. 
• If you form a mulled unit by first block-

ing objects vertically, the vertical mul-
lions of the larger unit will extend 
continuously from the bottom to the top 
of the entire unit, breaking any horizontal 
mullions. 

• If you form a mulled unit by first block-
ing objects horizontally, the horizontal 
mullions of the larger unit will extend 
from side to side, breaking any vertical 
mullions.
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In a complex unit composed of smaller units, 
there may be a variety of ways to organize 
the sub-units. 

Selecting Components 
of Mulled Units

To select a component of a mulled unit, click 
at the location of the component in question, 

then click the Select Next Object  edit 
button or press the Tab key until that individ-
ual component is selected. Only the compo-
nent clicked on is selectable using this 
method. If you need to select a different com-
ponent, click on it and repeat the process.

The selected component may be on any 
window level in the mulled unit. If there are 
multiple levels, it is easiest to select the 
components in a 3D view. When you have 
selected an individual component, you can 
change its parameters in the Window 
Specification dialog. See “Window 
Specification Dialog” on page 406.

If the selected component is not itself a 
mulled unit and has no components above it, 
its Height and Arch parameters can be 
changed. Changing the Height causes the 
component top to move. The bottom remains 
stationary.

Displaying Mulled Units
As with other windows, the display of 
mulled window units is controlled in 

the Layer Display Options dialog. See 
“Displaying Objects” on page 144.

Mulled units are placed on the “Windows” 
layer by default and have a single label, 
which is on the “Windows, Labels” layer. 
Mulled units are also included in the 

windows category of the Materials List and 
in window schedules. If the component 
objects of a mulled unit have unique 
moldings or materials, they will not be noted 
in the Materials List or in room finish 
schedules. See “Schedules and Object 
Labels” on page 1267.

If a mulled unit includes a door, Treat as 
Door will be checked in the Mulled Unit 
Specification dialog. When this box is 
checked, the unit’s label is placed on the 
“Doors, Labels” layer but the unit itself 
remains on the “Windows” layer unless you 
change it. Units set to Treat as Door are also 
included in the Doors category of the 
Materials List and in door schedules instead 
of window schedules. Similarly, their casing 
is recognized as door casing in room finish 
schedules. See “Options Panel” on page 408. 

You can, if you wish, display a mulled unit’s 
individual component labels instead of a 
single label for the unit. Labels are placed on 
the layers they would be on were the unit not 
mulled. A mulled unit’s label setting also 
affects how it is listed in schedules and in the 
Materials List. See “Label Panel” on page 
425.
• When Suppress All Labels is selected, 

individual components are counted in 
schedules and in the Materials List. 

• When Show Component Labels is 
selected, components are counted in 
schedules and in the Materials List.

• When Show Single Label for Entire 
Unit is selected, the unit is treated as a 
single object in schedules and the materi-
als list. 

Mulled units can be placed on different 
Window Levels to control their appearance 
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in floor plan view. See “Window Levels” on 
page 400.

Editing Mulled Units
A mulled unit moves as a single standard 
window in both floor plan and 3D views. 

The components of a mulled unit cannot be 
moved relative to one another. If this is 

required, you will first need to explode the 
mulled unit. 

To explode a mulled unit

1. Select the mulled unit.

2. Click the Explode Mulled Unit  edit 
button.

Window Levels
It is often necessary to position more than 
one window, mulled unit, and/or door at the 
same location along a wall in floor plan 
view: for example, to create an entry with 
side lites and transom. 

To help control and organize the appearance 
of stacked wall openings in floor plan view, 
you can assign windows at various heights to 
different Window Levels. 

Window Levels do not define the height of a 
window, just the appearance and behavior of 
windows and doors in floor plan view.
• In floor plan view, windows and doors on 

the Default Level display the line color 
and style of the layer they are on. See 
“Layers” on page 143. 

• Windows on any other level appear light 
gray, regardless of the layer they are on. 

The Default Level
The Default Level is the Window Level that 
Standard Windows are initally placed on 
when created and affects several things: 
• In floor plan view, windows and doors on 

the Default Level display the line color 
and style of the layer they are on.  

• When you click on stacked doors and 
windows in floor plan view, those on the 
Default Level are selected first. To select 
an opening on another level, use the 

Select Next Object  edit button. See 
“Select Next Object” on page 185. 

Typically, the Default Level is set as 0 (zero).

Window Level Zero
Window Level 0 (zero) is the level that all 
bay, box and bow windows and doors are 
always placed on. Typically, it is also the 
Default Level that standard windows are 
placed on, as well. 

Because doors are always on Level 0 and 
because Window Levels affect line colors in 
printouts, it is usually best to keep the 
Default Level at 0. If you do change the 
Default Level, remember to change it back 
before printing.

If you specify the Default Level as a value 
other than zero and then place a window in 
your plan, it will not use all Window 
Defaults settings. Instead: 
• The program will position it above any 

windows that are at the same location but 
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on a lower level rather than use the 
default Floor to Top height;

• Its Type will be Fixed Glass;
• Its Height will be 12” (300 mm); 
• It will have no Sill. 

Once the window is created, its parameters 
can be changed. See “Editing Windows” on 
page 403.  

Using Window Levels
The door and windows in the illustration 
below were created on different Window 
Levels. 

To stack windows using Window Levels

1. Place the door and side lites on Window 
Level Zero.

2. Open the Window Defaults dialog and 
change the Default Level to 1.

3. Place the second row of windows above 
the door and side lites on Level Zero. 
The program will automatically posi-
tion fixed glass windows above the door 
and side lites. 

4. Edit these fixed glass windows’ Widths 
and other attributes as needed.

5. Open the Window Defaults dialog and 
change the Default Level to 2.

6. Place the top window above the others. 
The program will place a fixed glass 
window above the windows on Level 1.

7. Edit this window’s Arch and other attri-
butes as needed.

8. When you are finished, open the 
Window Defaults dialog and change the 
Default Level back to 0.

In addition to using Window Levels to place 
and manage stacked windows, you can 
combine them into a single blocked unit. See 
“Make Mulled Unit” on page 397. 

Displaying Windows
The display of windows, window 
labels, openings, casing, and headers 

in floor plan and 3D views can be controlled 
in the Layer Display Options dialog. See 
“Layer Display Options Dialog” on page 
149.

Windows can only be placed in walls, so if a 
wall’s layer is turned off, any windows 
placed in that wall will not display, either. 
See “Displaying Walls” on page 281. 

If the “Windows” layer is not set to display, 
window casing and other components are not 

Level 0

Level 1

Level 2
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visible, but the openings in the walls where 
they are located can still be seen.

In Floor Plan View
A window’s frame, glass, casing, and sill are 
all represented in floor plan view. This 
makes some window types, notably Sliding 
and Double and Triple Casement windows, 
distinguishable. 

If a window is recessed, the affected wall 
layers will adjust to accommodate the casing.

Bay, box,and bow windows have dimensions 
lines associated with them. 
• You can suppress their display by turning 

off the “Manual Dimensions” layer or on 
a unit by unit basis in the unit’s specifica-
tion dialog. See “Bay/Box and Bow Win-
dow Specification Dialogs” on page 429. 

• The arrow style and fill are set in the 
Dimension Defaults dialog. See 
“Dimension Defaults Dialog” on page 
987.

Windows in pony walls display in floor plan 
view regardless of which part of the pony 
wall is visible. If you wish, you can instead 

display only openings located entirely in the 
portion of a pony wall that is set to display in 
floor plan view. See “Pony Wall Defaults” on 
page 262. 

If a window is placed in a Garage room at a 
height where it extends into the stem wall or 
curb, a cutout in the concrete will display on 
the floor below. You can specify the cutout’s 
size and whether it displays in floor plan 
view in the Window Specification dialog. 
See “General Panel” on page 407. 

Interior and exterior window casings will 
display in all views when the “Casings, 
Exterior” and “Casings, Interior” layers are 
turned on. In floor plan view, the sills and 
vertical side casings will be shown, but the 
horizontal top casing or lintel will not. 

In 3D Views
To show opening indicator arrows in Vector 
Views, turn on the “Opening Indicators” 
layer in the Layer Display Options dialog. 
See “Vector View” on page 952. 

You can change the direction of indicator 
arrows in the Preferences dialog. See 
“Architectural Panel” on page 108.

You can also specify whether window and 
door glass is opaque or transparent in the 

Double Hung

Left Sliding

Triple Casement
Window types in floor plan view

Windows showing opening indicators
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Rendering Technique Options dialog. See 
“Rendering Technique Options” on page 
954.

When displayed as opaque, window and door 
glass uses the Material Color set in the 
Define Material dialog. See “General Panel” 
on page 865. 

Window Labels
Window labels display in floor plan and 
cross section/elevation views, centered on 
the windows they represent, when the 
“Windows, Labels” layer is turned on and 
use the Text Style assigned to their layer. See 
“Object Labels” on page 1279.

Automatic window labels indicate Width and 
Height, followed by Type. For example: 
• In Imperial plans, the automatic label for 

a 3’-0” wide, 4’-0” high double hung 
window will read 3040 DH.

• In metric plans, the automatic label for a 
900 mm wide, 1200 mm high double 
hung window will read 900x1200 DH.

If you prefer, you can use one of two other 
formats: Height/Width followed by Type and 
Width Only followed by Type. Label formats 
are specified in the Window Schedule 
Specification dialog or in the Window 

Schedule Defaults dialog if no schedule is 
present. See “Label Panel” on page 1277. 

You can specify whether a Bay, Box or Bow 
Window displays a single label or displays 
the labels of its component windows. This 
choice will affect how the unit displays in 
schedules. 
• When Suppress All Labels is selected, 

individual components of Bay, Box and 
Bow Windows are counted in schedules 
and in the Materials List. 

• When Show Component Labels is 
selected, components of Bay, Box and 
Bow Windows are counted in schedules 
and in the Materials List.

• When Show Single Label for Entire 
Unit is selected, the Bay, Box or Bow 
Windows is treated as a single object in 
schedules but not in the materials list. 

These options are also available for mulled 
units but affect their display in schedules and 
the materials list somewhat differently. See 
“Displaying Mulled Units” on page 399. 

Customized labels using text and Object 
Specific Text Macros as well as label 
position and orientation can also be specified 
in the Window Specification dialog. See 
“Text Macros” on page 1064. 

Editing Windows
Before a window can be edited, it must be 
selected. Click on a window when the Select 
Objects  tool or any of the Window 
Tools  are active. Doors and/or windows 
can also be group-selected and edited. See 
“Selecting Objects” on page 183.

To select a window that is part of a blocked 
unit, click the component window, then click 

the Select Next Object  edit button. See 
“Selecting Components of Mulled Units” on 
page 399.
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Windows can be edited using their edit 
handles, the edit toolbar buttons, and the 
Window Specification dialog. See “Window 
Specification Dialog” on page 406.

When you select a window in floor plan 
view, the window size label displays the 
width followed by the height. For example, a 
3036 window is 3’-0” wide by 3’-6” high. 

In the Specification Dialog
The most precise method of editing an 
individual window or group of 

windows is to use the Window Specification 
dialog. The window type, size, casing, 
materials, shape, and more can all be 
specified in this dialog. See “Window 
Specification Dialog” on page 406.

Using the Mouse
In floor plan view, click either of the two end 
handles and drag along the wall to change the 
width. The label showing the size updates as 
the window is resized. 

In 3D views, a selected window has five edit 
handles: the Move handle at the center and a 
Resize handle on each edge. Click and drag 
an edge handle to resize the window.
• Using the edit handles, a window resizes 

according to the currently active Edit 
Behavior . See “Edit Behaviors” on 
page 178.

A single window or a group of windows can 
be moved with the center edit handle.

A door or window moved against an 
intersecting wall temporarily stops when it is 
the casing distance from the intersecting 
wall. Enable Ignore Casing for Opening 
Resize in the Plan Defaults dialog to turn off 

this behavior. See “General Plan Defaults 
Dialog” on page 88.

You can continue to drag the selected 
window and  it will resume movement past 
or onto the intersecting wall. 

To create a corner window, drag the Move 
handle straight out past the wall corner, 
parallel to the selected window’s wall. See 
“Corner Windows” on page 395.

Using Dimensions
Like various other objects, windows 
can be moved using dimensions. See 

“Moving Objects Using Dimensions” on 
page 1019. 

You can specify how windows and doors are 
located by dimensions in the Dimension 
Defaults dialog. See “Locate Objects Panel” 
on page 992. 

Dimensions can be set to locate the centers, 
sides, casing, or rough opening of wall 
openings, or you can choose to not locate 
openings at all. If you wish, you can move a 
dimension’s extension lines to locate non-
default locations on a window after the 
dimension is drawn. See “Editing Extension 
Lines” on page 1016. 

Using the Edit Tools
A selected window or windows can be edited 
in a variety of ways using the buttons on the 
edit toolbar. See “The Edit Toolbar” on page 
37.

• Click the Gable Over Door/Window  
to create a gable over the selected win-
dow(s) the next time the roof is rebuilt. 
See “Gable/Roof Lines” on page 515. 
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• Click the Components  edit button to 
modify or add information related to the 
selected window in the Materials List and 
schedules. See “Components Dialog” on 
page 1300.

Window Casing and Sills
Windows often feature casing, or trim, on 
both sides of the wall opening as well as a sill 
on one or both sides. 

The default casing for windows is a basic 
rectangular stock profile. You can specify a 
window’s casing profiles in the Window 
Specification dialog, or you can choose to 
suppress casing altogether. See “Casing 
Panel” on page 410.

A separate molding profile can be specified 
for the lintel, or top horizontal molding. A 
sill profile can be specified, as well. See 
“Lintel Panel” on page 413.

Custom Muntins
You can design your own muntins for the 
glazing of a window or door. Muntins are 
formed from a CAD block composed of lines 
and arcs drawn over window or door glass in 
a cross section/elevation view. The CAD 
block should cover at least half the glass 
horizontally and one quarter of the area 
vertically, but should not overlap it in either 
direction by more than five percent.

Creating Muntins
Custom muntins are created by 
drawing their pattern using the CAD 

tools, blocking the pattern to create a CAD 
block, and then selecting the window and 
clicking the Load Muntins edit button.

To create custom muntins

1. Create a Cross Section/Elevation  
view of the wall the window or door is 

in and Zoom  in on the window or 
door. 

2. Use the Draw Line  and Draw Arc 

 tools to design the desired muntins. 
Try to make them start and end as close 
to the edge of the glass as possible.

3. When the muntin design is complete, 
group-select all lines and arcs and click 

the Make CAD Block  edit button. 
See “Selecting Objects” on page 183. 

4. Select the door or window and click the 

Load Muntins  edit button to con-
vert the CAD block into custom 
muntins.

•  If the window in question is the compo-
nent of a mulled unit, bay, or box win-
dow, click on it and, then click the 

Select Next Object  edit button.
•  If the window in question is the compo-

nent of a bow window, the custom 
muntins will load onto all of its compo-
nents - not just one of them.

If your window has more than one sash (a 
double-hung window, for example, has two), 
you must create a separate CAD block for 
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each pane. When you click Load 
Muntins , all CAD blocks are loaded.

Custom muntins move with the opening and 
copy with their opening. They also stretch or 
compress when the glass area is resized. This 
stretching may not be perfect for non-
rectangular glass areas that are resized by a 
large amount.

Custom muntins can be created for the 

components of Bay Windows , Box 
Windows , and mulled units. To create 

custom muntins for a Bow Window , you 
must draw them on the one component that is 
selectable. When the muntins are loaded, 
they will applied to all of the components 
See “Component Windows” on page 426.

The Load Muntins  edit tool can also be 
used to add custom muntins to glass doors. 
See “Special Doors” on page 372.

Editing Muntins
Once blocked and loaded, custom muntins 
cannot be edited. If you wish to make 
changes to them, you must first remove 
them.

Removing Muntins
Remove custom muntins from a door 
or window by selecting the opening in 

cross section/elevation view and clicking the 
Unload Muntins edit button. The muntins 
disappear and the original CAD block takes 
their place. 

Window Specification Dialog
To open the Window Specification 
dialog, select a window or a group of 

windows and click the Open Object edit 
button; or double-click the window using the 

Select Objects  or a Window  tool. 

The settings in this dialog are similar to those 
in the Window Defaults dialog. See 
“Window Defaults” on page 392.

The settings in this dialog are also similar to 
those in the Mulled Unit and Window 
Symbol Specification dialogs. Although 
similar, a number of the options cannot be 
edited when either a window symbol or a 
mulled unit is selected, and some panels are 
not available. See “Grouped Windows” on 
page 396.

A selection of CAD blocks created for
use as custom muntins is available in

the library in Chief Architect Core Catalogs>
Architectural> Windows> Custom Muntins.
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General Panel

Window Type - Select the type of 
window from the list. The first entry in 

the list is the Default type set in the Window 
Defaults dialog. 

Specify the Size and Position of the 
selected window. 

• Specify the window’s Width and Height. 
These values include the window frame.

• Select the Elevation Reference from the 
drop-down list. This determines where 
the next two settings are measured from 
and also affects their setting labels.

• Specify the height to Top, measured from 
the selected Elevation Reference to the 
top of the window frame. 

• Specify the height to Bottom, measured 
from the selected Elevation Reference to 
the bottom of the window frame.

The Component Options affect 
windows with movable sections and are 

not available for Pass-Throughs, Fixed glass 
windows, mulled units, or window symbols.  
• Specify the Bottom Component Size for 

Single Hung, Double Hung, Double 
Awning, Double Hopper, and Triple Hop-
per windows; specify the Top/Bottom 

1

2 Note: When either the Floor to Top or Floor
to Bottom setting is modified, the other will
adjust in response to prevent the window’s
Height from changing.

3
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Component Size for Triple Awning win-
dows; or, 

• Specify the Side Component Size for 
Triple Casement and Triple Sliding win-
dows, the Right Component Size for 
Left Sliding windows, or the Left Com-
ponent Size for Right Sliding and Dou-
ble Casement windows.

A Component Size value of 0 creates  a 
window with identically sized components. 
• Specify how each Component Opens 

from the available options. Only avail-
able for Casement, Double and Triple 
Awning, and Double and Triple Hopper 
windows. 

The Interior Windows settings are 
only present when the selected window 

is a Pass-Through placed in an interior wall. 
See “Exterior and Interior Walls” on page 
269. 
• Check Separate Trim and Materials for 

Each Side to specify the casing, lintels, 

sills, and all materials for each side of the 
selected Pass-Through independently. 
When unchecked, the two sides use the 
same trim and materials. 

Options - 

• Louver Size - Specify the vertical height 
of the selected window’s louvers. Only 
available for Louvered and Glass Louver 
windows. 

• Check Include in Schedule to include 
the selected window(s) in Window 
Schedules. See “The Schedule Tools” on 
page 1268. 

A preview of the selected window 
displays here. A label indicates which 

side of the window is its Interior and which is 
its Exterior. See “Dialog Preview Panes” on 
page 41. 

Window opening directions can best be seen 
using the Vector View Rendering Technique.

Options Panel
The Mulled Units and Mullion Depth 
settings on the OPTIONS panel are only 
available in the Mulled Unit Specification 

dialog. See “Grouped Windows” on page 
396.

4
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Options -

• Check Interior Corner Block to count 
interior corner blocks in the materials list. 
These do not display in 3D views.

• Check Exterior Corner Block to count 
exterior corner blocks in the materials 
list. These do not display in 3D views. 

• Check Egress to specify the window as 
an egress window in the Window Sched-
ule and Materials List. Not available for 
Pass-Throughs.

• Check Tempered Glass to specify the 
selected window’s glass as tempered in 
the Window Schedule. See “Adding Cus-
tom Columns” on page 1272. 

• Check Reverse Symbol to reverse a win-
dow symbol as though it were reflected 
about a vertical line through its center. 
Only available in the Window Symbol 
Specification dialog. See “Window 
Symbols” on page 396. 

The Mulled Units options are only 
available when a mulled unit is 

selected.
• Check Treat as Door to include the unit 

in door schedules and the Door category 
of the Materials List rather than in the 
Window schedules and Materials List 

Consult your local building and fire code
authorities for your local egress window

requirements.

1
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category. Only available when the 
selected unit contains a door. 

• Uncheck Single Wall Hole to produce 
individually framed wall openings for 
each unit in a mulled unit. When this box 
is checked, a single wall opening with 
one header for the entire unit is produced. 

Specify the Mullion Depth for the 
casing between the components of a 

mulled unit, measured from wall surface. 
Positive values move the mullion surface 
towards the wall center; negative values, 
away from it. Only available when a mulled 
unit is selected.
• Specify the Inside depth of the mullion 

on the interior surface of the wall. 
• Specify the Outside depth of the mullion 

on the exterior surface of the wall. 

The Recessed into Wall options allow 
you to recess the selected window or 

mulled unit into a wall, away from the 
exterior surface. Only available if the 
window or mulled unit is in a multi-layered 
wall. Check Recessed to enable these 
options. 

• Select To Main Layer to recess the 
window to the wall’s Main Layer. 

• Select To Sheathing Layer to recess the 
window to the wall’s sheathing layer. 

Vertical Stacking - Specify the 
window Level that the selected window 

is placed on. Not available for mulled units 
or window symbols. See “Window Levels” 
on page 400.

A preview of the selected window 
displays here. See “Dialog Preview 

Panes” on page 41.

Casing Panel
The CASING panel is not available in the 
Window Symbol Specification dialog.

3

4

Not Recessed

Recessed (to Main Layer)

Recessed to Sheathing Layer
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Check Use Interior Casing to enable 
the settings that follow, then specify the 

interior casing for the selected windows(s) 
using those settings. When this box is 
unchecked, no casing is used.
• Casing Profile - Click the Library but-

ton to select a molding profile for the cas-
ing. A preview of the casing profile 
displays to the right. See “Select Library 
Object Dialog” on page 838.

• Click the Clear button to remove a 
selected casing profile from the window. 

• Specify the Width of the selected casing.

• Define the Depth of the selected casing, 
as measured from the back to the front of 
the casing profile.

• Define the Overlap Frame value, which 
is the the distance between the outside 
edge of the window frame and the inside 
edge of the casing. The default is 0”, 
which places the inside edge of the casing 
against the outside edge of the frame.

Type a positive value to overlap the cas-
ing over the frame by that amount. 

Type a negative value to produce a gap 
between the casing and the frame.

1
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To produce a reveal of a certain width, 
subtract the desired reveal from the total 
width of the frame and type the result 
here. 

Check Use Exterior Casing to enable 
the settings that follow, then specify the 

exterior casing for the selected window(s) 
using those settings. These settings are the 
same as those for the Interior Casing. If the 
selected window is a Pass-Through placed in 
an interior wall, these settings will be 
unavailable unless Separate Trim and 
Materials on Each Side is checked on the 
GENERAL panel. See “General Panel” on 
page 407. 

The Double Wall Options affect 
windows placed in a Double Wall. See 

“Double Walls” on page 299.
• Select Through to create a single frame 

running through both Double Walls. This 
option is selected by default.

• If Enlarged is selected, casing is created 
only on the wall the window is inserted 
in. The opening on the other wall is 
enlarged to accommodate the casing.

• Select Double to place a second window 
in the Double Wall opposite the selected 
window. This second window cannot be 
selected. Casing is produced as with the 
Through type window.

• Select Not Through to place the window 
in one wall with no corresponding open-
ing in the other wall.

Curved Wall Casing - This section is 
enabled if the window is placed in a 

curved wall. See “Drawing Curved Walls” on 
page 278.

Door and window casing and jamb can be 
constructed three ways in curved walls: 
• Straight - Both window sash and casing 

are straight. Straight casing may not fit 
properly into a wall if the window is too 
wide or the curvature of the wall, too 
tight.

• Radial - The sides of the casing or jambs 
are inserted in the wall at an angle that 
passes through the center of the curve. 

• Parallel - The sides of the casing are 
inserted in the wall at a right angle to the 
line tangent to the curved wall at the cen-
ter of the window. 

Normally, parallel casing has a straight sash. 
Radial casing is more like traditional curved 
windows, and typically has a curved sash.

A preview of the selected window 
displays here. You may need to rotate 

the preview to see the casing you are 
editing.If casing is not specified for a Pass-
Through, the Show Wall option will be 
toggled on automatically.  See “Dialog 
Preview Panes” on page 41. 

2
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Lintel Panel
The settings on the LINTEL panel of the 
Window and Mulled Unit Specification 
dialogs are also found on the panel of the 
same name in the Door Specification dialog. 
See “Lintel Panel” on page 381.

The LINTEL panel is not available in the 
Window Symbol Specification dialog.

These settings are not available if the 
window has a reflected arch. See “Arch 
Panel” on page 420.

The profiles and materials of window lintels 
and sills can be included in Room Finish 
Schedules.

Sill Panel
The settings on the SILL panel of the 
Window and Mulled Unit Specification 
dialogs are not available if the window has a 
reflected arch. See “Arch Panel” on page 
420.

The SILL panel is not available in the 
Window Symbol Specification dialog.

The profiles and materials of window lintels 
and sills can be included in Room Finish 
Schedules.

Check Use Interior Sill to enable the 
settings that follow, then specify the sill 

applied to the interior side of the selected 
window(s) using these settings. When this 
box is unchecked, no interior sill is used.

• Sill Profile - Click the Library button to 
select a molding profile for the sill. A pre-
view of the selected profile displays to the 
right.  See “Select Library Object Dialog” 
on page 838.

1
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• Click the Clear button to remove a 
selected sill profile from the window. 

• Specify how far to Extend the sill past the 
outside edges of the casing on each side. 
If an Apron is specified, it will also be 
affected by this setting.

• Check Wrap to wrap the sill profile back 
toward the wall. 

• Check Apron to include an apron under 
the sill. When Wrap is checked, the apron 
will be 1/2” (12 mm) shorter than the sill 

on each side; when it is unchecked, it will 
be the same length as the sill. 

Check Use Exterior Sill to enable the 
settings that follow, then specify the 

exterior sill for the selected window(s) using 
these settings. These settings are the same as 
those for the Interior Sill.

A preview of the selected window 
displays here. See “Dialog Preview 

Panes” on page 41.

Sash Panel
The settings on the SASH panel control the 
size and position of the selected window’s 
sash. Note that increasing the Side, Middle, 
Top or Bottom Width decreases the area of 
the glass and vice versa. 

The SASH panel is not available in the Mulled 
Unit and Window Symbol Specification 
dialogs, and the settings on this panel are not 
available for Pass-Throughs.

Specify the width and depth of the 
selected window’s Sash, which are the 

pieces of the window that hold the glass. 

• Specify the Side Width of all vertical 
sash members: those at the window sides 
as well as the central members of Case-

2
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ment and Sliding windows. This is also 
the width of the top portion of the win-
dow when an arch is specified.

• Specify the Middle width of horizontal 
components between the top and bottom 
sash in Double Hung, Double and Triple 
Awning, and Double and Triple Hopper 
windows. It does not affect Casement and 
Sliding windows.

• Specify the Top and Bottom Widths. 
The Top value is not used if the window 
has an arch.

• Specify the Depth, or thickness, of the 
sash stock measured from the exterior to 
the interior.

• Specify the Inset, the distance between 
the frame and the outermost sash. If there 
is no frame, the inset is measured from 
the outer surface of the wall’s Main 
Layer.

• Curved Options - When the selected 
window is placed in a curved wall, spec-
ify whether it has a curved or straight 
sash. A curved sash is typically used with 
Radial casing. See “Casing Panel” on 
page 410.

A preview of the selected window 
displays here. See “Dialog Preview 

Panes” on page 41. 

Frame Panel
The FRAME panel is not available for mulled 
units or window symbols.

The settings on the FRAME panel are similar 
to those on the JAMB panel of the Door 
Specification dialog. See “Jamb Panel” on 
page 382.

Straight Sash

Radial Casing

Curved Sash

2
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Specify the attributes of the selected 
window’s Frame. Note that a window’s 

frame is included in its size, while a door’s 
jamb is not.
• Check Has Frame to include a frame and 

enable the settings below. When this is 
unchecked, the selected window has no 
frame around it.

• Specify the Side, Top, and Bottom 
Widths of the window’s frame. Changing 
these values modifies the interior of a 
window but does not affect its size.

• Uncheck Fit Frame to Wall to specify 
the Depth and Inset of the selected win-
dow’s frame. When this box is checked, 
the frame Depth automatically extends 
from the Recessed Into Wall layer to the 
wall’s inside surface with an Inset of 0”. 

The Recessed Into Wall layer is specified 
on the Options Panel of this dialog.

• Specify the Depth of the window frame 
from front to back.

• Specify the frame’s Inset, which is mea-
sured from the Recessed Into Wall layer 
and moves the window frame towards its 
interior side. If used, the casing and lintel 
are not affected by this setting.

Has Corner Post is only available 
when the selected Fixed glass window 

is one of a pair forming a corner window. See 
“Corner Windows” on page 395. 

A preview of the selected window 
displays here. See “Dialog Preview 

Panes” on page 41.

Lites Panel
The LITES panel allows you to add muntins 
to various window styles, and is also 

available for Glass doors. See “Doors” on 
page 361. 

1
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There are four possible styles of muntin bars 
for regular windows, plus two additional 
options for arched windows.

A window that has been modified using the 
SHAPE panel cannot have divided lites or 

shutters added. You can, however, create 
Custom Muntins for such a window. See 
“Custom Muntins” on page 405.

The LITES panel is not available for mulled 
units or window symbols. 

Specify the number, position and style 
of Lites for the selected window.

• Select a Type, or style, of window lite 
from the drop-down list. 

• Normal style is the most common, with 
muntins going horizontally and vertically. 
Colonial windows are an example of the 
normal style.

• Diamond style uses angled muntin bars 
to divide up the lites. French windows are 
an example of the diamond style.

• Prairie style is based on the normal style, 
but with all the central muntin bars 
removed, leaving only the two outside 
muntin bars both horizontally and verti-
cally. Typically, both Lites Across and 
Lites Vertical should be set between 6 
and 8. Federal or Federation windows are 
an example of the Prairie style.

• Craftsman style is based on the normal 
style, but only the topmost horizontal 
muntin bar is kept with all the portions of 
the vertical muntin bars above it. Typi-
cally, both Lites Across and Lites Vertical 
should be set between 4 and 8.

1
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• Enter the number of horizontal Lites 
Across in each sash. 

• Enter the number of vertical Lites Verti-
cal in each sash.

• Specify the Muntin Width, which is the 
width of the bars dividing the panes of 
glass.

• Check or uncheck Lites in Top and/or 
Lites in Bottom - or Lites in Left and/or 
Lights in Right - to specify either one or 
both of the sashes to have divided lites. 

• Check Muntin in Corner to add a verti-
cal muntin bar where two corner win-
dows meet. Only available when Has 
Corner Post is unchecked on the FRAME 
panel. See “Corner Windows” on page 
395. 

• Check Auto Adjust Lites for Compo-
nent Size to have the program produce 
lites that are consistent in size across all 
components. When this is checked, the 
window’s lites and its specification set-
tings may not agree; when unchecked, 
lites in the components may not be con-
sistent in size. 

The Arch Options are only available if 
the window has an Arch specified.

• Specify a Ray Count of up to 10 radial 
muntin bars in the portion of the window 
within the arch. There is one more pane 
of glass than the number of rays speci-
fied. See “Arch Panel” on page 420.

• Check Concentric to produce muntins 
radiating from a curved inner muntin that 
is concentric with the window’s arch. 
You must have at least three Lites Across 
for this to be used.

A preview of the selected window 
displays here. See “Dialog Preview 

Panes” on page 41. 

Shape Panel
The settings on the SHAPE panel control the 
position of the selected window’s corners, 
allowing you to create angled edges and 
mitered top corners. 

If any of these settings are used to create a 
custom shape, the selected window will be 

automatically specified as “Fixed Glass” on 
the GENERAL panel. If the selected window 
has an arch specified on the ARCH panel, it 
will be removed.

The SHAPE panel is not available for mulled 
units or window symbols.

Note: Because the fixed window in a Triple
Sliding window is twice the size of the mov-
able windows, the fixed section has a vertical
muntin bar. To eliminate this, uncheck Auto
Adjust Lites for Component Size..

2
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Window Width displays for reference. 
It can be changed on the      General 

Panel.
• Click Match Roof to match the angle of 

the top of the window to the pitch of the 
roof above by changing its Sides heights, 
below. If either Top Inside Corner box is 
checked, it will become unchecked. 

Match Roof does not work for curved 
roofs, has no effect if the window is not 
in a gable end wall, and is not available in 
the Window Defaults dialog.

• Click Revert to restore the window to its 
original shape, type and arch settings. 

Specify the height of the window’s Left 
and Right Sides, as measured from the 

bottom of the window. By default, these 
settings match the window’s Height. 

The Top Inside Corners settings allow 
you to create a second set of top corners 

with angled edges between them and the 
outside top corners.
• Check Left to add an additional corner 

along the top edge.
• Specify the Height of the left inner cor-

ner, as seen from the exterior, measured 
from the bottom of the window.

• Specify the Offset of the left inner cor-
ner, as measured from the left side of the 
window.

• An additional Right Inside Corner can be 
specified in a similar manner.

Note: The Left and Right settings on this
panel refer to the window’s exterior.

1
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The Bottom Corners settings allow 
you to raise the heights of the bottom 

corners, as measured from the bottom of the 
window specified on the      General Panel.
• Check Left to raise the height of the bot-

tom left corner.
• Specify the Height of the bottom left cor-

ner. This value cannot exceed the Height 
of the Left Side. 

• The height of the Bottom Right corner 
can be raised in a similar manner.

A preview of the selected window 
displays here. You may want to rotate 

the view so the window’s exterior can be 
seen. See “Dialog Preview Panes” on page 
41. 

The following diagram represents added 
Inner corners using open circles and the left 
and right corners using solid black circles:

• A has different left and right Side Heights 
with no Top Inside Corner added. 

• B has matching left and right heights with 
an added Top Inside Corner. 

• C is the same as B, except that the left 
and right Side Heights have been short-
ened to 1/4”. 

• D is the same as B except it has two 
added Top Inside Corners.

• E is the same as A except that the Bottom 
Right Corner has been raised.

Arch Panel
The settings on ARCH panel of the Mulled 
Unit Specification dialog define the overall 
shape of the blocked unit’s top. If the mulled 
unit already includes a component window 
with an arch, these settings cannot be 
modified. If you intend to arch the top of a 
mulled unit, the top components should be 

constructed with horizontal, straight tops all 
at the same height.

The ARCH panel is not available for window 
symbols, and its settings are not available if 
the selected window has been modified using 
the      Shape Panel.

Note: The Left and Right settings on this
panel refer to the window’s exterior.

4
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Define the style and size of the Arch. 

• Select the Type of arch desired from the 
drop-down list.

• Specify the Height of the arch, as mea-
sured from the top of the window to the 
base of the arch. The Height can be 
defined for all arch types except Round 
Top and Octagonal Arches.

• The Radius can also be defined for Tudor 
and Double Arches.

Options - Define the orientation of the 
arch. 

• Check Reflect Vertically to reflect the 
specified arch, top to bottom. You can 
reflect a square window with a Round 
Top arch to create a circular window. Not 
available if a lintel or sill is specified for 
the selected window. See “Lintel Panel” 
on page 413 and “Sill Panel” on page 
413.

• Select Full Arch to produce an arch with 
the apex at the window’s center. 

• Select Arch on Left to produce an arch 
with the apex on the window’s right side, 
as seen from its exterior. 

• Select Arch on Right  to produce an arch 
with the apex on the window’s left side, 
as seen from the its exterior.

1

Round
Top

Gothic Elliptical Flat
Top

Broken

Tudor Double Octo-
gonal

Trifoil Dogear

2



422

Chief Architect  X8 Reference Manual

A preview of the selected window 
displays here. You may want to rotate 

the view so the window’s exterior can be 
seen. See “Dialog Preview Panes” on page 
41.

Treatments Panel
The settings on the TREATMENTS panel allow 
you to add embellishments to the interior and 
exterior of the selected window or mulled 
unit.

The TREATMENTS panel is not available for 
window symbols. 

Specify Curtains for the selected 
window or mulled unit’s interior side. 

• Specify a style of Curtains by selecting 
“Use Default”, “None” or “Library” from 
the drop-down list.  If a non-default 
library item has been selected, its name 
will display in the list, as well.

• Click the Library button or select 
“Library” from the drop-down list to 

choose a style of curtain from the library. 
See “Select Library Object Dialog” on 
page 838. 

• Specify the Height Off Floor of the bot-
tom edge of the curtains. 

• Specify the Height Above Casing of the 
top of curtains. 

3 Note: The Left and Right settings on this
panel refer to the window’s exterior.

1
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Specify a style of Blinds in the same 
manner that Curtains are chosen, above.

Specify an exterior Exterior Millwork 
Above Casing in the same manner that 

Curtains are chosen, above, and specify its 
Height and Width. 

Specify an Exterior Millwork Below 
Casing in the same manner that 

Curtains are chosen, above. Specify the 
Height of the millwork and the distance that 
it should Extend past the side casing. 

A preview of the selected window 
displays on the right. You may want to 

rotate the view so the window’s interior or 
exterior can be seen, as needed. See “Dialog 
Preview Panes” on page 41. 

Shutters Panel
The settings on the SHUTTERS panel allow 
you to specify exterior shutters for the 
selected window or mulled unit. 

The SHUTTERS panel is not available for 
window symbols.

2
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Select a Type of Shutters from the 
drop-down list or click the Library 

button to select a style of shutters from the 
Library Browser. See “Select Library Object 
Dialog” on page 838. 

Specify the Size of the selected 
shutters. 

• When Match Opening Width is 
checked, each shutter’s width is exactly 
half that of the window, excluding casing.

• Uncheck Match Opening Width to 
specify a Width in the text field. If the 
window is later resized, the shutters will 
not adjust in response.

• When Match Opening Height is 
checked, each shutter’s height equals that 
of the window, excluding casing.

• Uncheck Match Opening Height to 
specify a Height in the text field. If the 
window is later resized, the shutters will 
not adjust in response.

Specify the Position of the shutters 
relative to the window. 

• Select On Casing to position the shutters 
just outside the window frame, like func-
tional shutters. 

• Select Outside Casing to position shut-
ters outside the window casing, as deco-
rative shutters often are.

• Select Custom to create a custom posi-
tion for the shutters by specifying the 
Offset from Side and Offset from Bot-
tom in the fields below.

Additional shutter Options can be 
specified here.

• Check Reverse Direction to orient the 
shutters so their exterior sides face out-

ward and their interior sides face the 
wall. For functional shutters, this should 
remain unchecked. 

• Check No Arch for shutters with flat tops 
that reach the bottom of the curved por-
tion of an arched window. Only available 
when an Arch is selected. See “Arch 
Panel” on page 420.

Shutter Sides - Specify which sides of 
the selected window receive shutters. 

• Select Automatic to assign shutters to 
both sides of the window as long as there 
is sufficient room on the wall. If the win-
dow is next to a wall intersection or cor-
ner, the shutter closest to the intersection 
will not generate. 

• Select Left Side Only to assign a shutter 
to the left side of the window and none on 
the right. 

• Select Both Sides to assign shutters to 
both sides of the window under all cir-
cumstances, even if there isn’t enough 
room on the wall for one or both of them.

• Select Right Side Only to assign a shut-
ter to the right side of the window and 
none on the left.

A preview of the selected window 
displays on the right. In order to see the 

shutters, you may need to rotate the preview 
to show the Exterior. See “Dialog Preview 
Panes” on page 41. 

Framing Panel
The settings on the FRAMING panel are also 
found on the panel of the same name in the 
Door Specification dialog. See “Framing 
Panel” on page 386.

1
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Energy Values Panel
The settings on the ENERGY VALUES panel 
are also found on the panel of the same name 
in the Door Specification dialog. See 
“Energy Values Panel” on page 388.

Layer Panel
The settings on the LAYER panel are the same 
as those found on the same panel in dialogs 
throughout the program. See “Layer Panel” 
on page 154.

Materials Panel
The settings on the MATERIALS panel are the 
same as those found on the same panel in 

dialogs throughout the program. See 
“Materials Panel” on page 852.

The settings on the MATERIALS panel of the 
Mulled Unit Specification dialog apply to all 
components of the blocked unit. Any settings 
made for individual components of the 
blocked unit are overridden here.

Label Panel
Window labels display in floor plan view and 
cross section/elevation views when the 
“Windows, Labels” layer is turned on and 
use the Text Style assigned to that layer. See 
“Window Labels” on page 403. 

For more information about the settings on 
this panel. See “Label Panel” on page 1280.

Bay, Box, and Bow Windows
Bay, Box and Bow Windows 
are created much the way 

regular windows are: select a tool, then click 
a wall to place that window type. 

Chief Architect automatically builds a 
foundation under bay/box/bow windows 
placed on floor 1 unless they are raised from 
their original position. That section of the 
foundation wall is also a bay/box/bow, but 
without windows. If the foundation was 
generated before the window is placed, the 
foundation must be rebuilt or edited 
manually.

Editing Bay, Box and 
Bow Windows

Bay, box and bow windows are edited 
similar to regular windows, with one 

exception: in floor plan view, a diamond-
shaped Depth edit handle displays on the 
section. Drag this Depth handle outward to 
increase the depth, or inward to decrease the 
depth of the unit. See “Editing Windows” on 
page 403.

Bay, box and bow windows can also be 
edited in their respective specification 
dialogs. See “Bay/Box and Bow Window 
Specification Dialogs” on page 429.

Depth edit handle on a bay window
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Displaying Bay, Box 
and Bow Windows

The display of bay, box and bow windows is 
controlled in the Layer Display Options 
dialog. See “Layer Display Options Dialog” 
on page 149. 

Like other windows, bay, box and bow 
windows can display labels: either a single 
label for the unit, or one for each component. 
See “Window Labels” on page 403. 

Bay, box and bow window width and radius 
dimensions, which display in floor plan view 
when specified to do so in the window’s 
specification dialog, are placed on the 
“Dimensions, Manual” layer. See “Options 
Panel” on page 432.

Component Windows
A component window within a bay, box or 
bow window can be resized like any other 
standard window. To select a component 
window, click at the location of the 
component in question, then click the Select 
Next Object  edit button or press the Tab 
key. 
• Only the bay or box window component 

that was clicked on is selected using this 
method. If you need to select a different 
component, click on it and repeat the pro-
cess.

• In a bow window, all components are 
identical, so only one component can be 
selected. Changing this component 
changes them all.

Resizing Components
An individual component window can be 
resized using the edit handles, by changing 
settings in the component’s Window 
Specification dialog, or by using the 
Transform/Replicate Object dialog. See 
“Transform/Replicate Object Dialog” on 
page 242. 

When a bay/box/bow window is first created, 
there is room for one standard trimmer on 
each side of each component window. When 
the bay as a whole is moved and resized, its 
components automatically resize so that a 
standard trimmer is still accommodated. 

If you increase a component window’s width 
to the point where there is not enough room 
for standard trimmers, a thinner trimmer can 
be used. The size of this thinner trimmer is 
specified in the Build Framing dialog. See 
“Openings Panel” on page 590. 

If a component window is resized, it retains 
its size if at all possible when the containing 
bay/box/bow window is moved or resized. If 
the bay is resized in such a way that the 
component is too large to fit even with a 
thinner trimmer, the component resumes its 
default behavior, resizing as the containing 
bay window is resized.

Floors and Ceilings
When originally created, the floor and 
ceiling within a bay, box, or bow window are 
the same heights as the floor and ceiling of 
the room in which it is placed. 
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Both the top and bottom heights of these 
window units can be adjusted in its 
specification dialog or a 3D view using its 
edit handles to create a lowered ceiling and/
or a bench seat or garden window.

When the ceiling is lowered, the top heights 
of the walls that define the window unit are 
also lowered. When a roof is built over the 
unit, its height will be affected, as well.

When the bottom of the window is raised to 
create a bench seat, the unit’s walls will not 
reach the ground. As a result, window units 
with bench seats will have no foundation 
beneath them when the foundation is built.

Bay, Box, Bow Windows and Roofs
Several different roof styles can be specified 
for bay, box and bow window units in the 
Bay/Box and Bow Specification dialogs. 
See “General Panel” on page 430. 

If you change a bay, box, or bow window’s 
roof specification, you will need to rebuild 
the roofs to see the changes. See “Rebuilding 
Roofs” on page 479. 

Hip Roofs
By default, a hip roof is built above the unit 
when roofs are automatically generated. No 
roof directives need to be selected in the 
specification dialog to produce this roof.

Use the Existing Roof
To generate a standard roof that ignores a 
bay, box, or bow window, check Use 
Existing Roof. 
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With this option the bay, box, or bow 
windows is tucked under the roof eave. You 
may find it helpful to increase the width of 
the eaves. See “Roof Panel” on page 481.

Extend the Existing Roof
To have the main roof extend down over the 
window unit and follow the shape of the unit, 
select Extend Existing Roof Over. 

For this roof style, the ceiling heights of the 
window unit and the adjacent room must be 
the same. If you lower the ceiling of the 
window unit and then build the roof, a lower 
hip roof over the window is created. See 
“Floors and Ceilings” on page 426.

If a header is desired over the window unit, 
first build the roof, then lower the ceiling of 
the window unit. Once the ceiling is lowered, 

select Rebuild Walls/Floors/Ceilings . 
Do not rebuild roof planes.

Rectangular Hip Roofs
To create a rectangular-shaped hip roof 
above a bay, box, or bow window, select 
Rectangular Roof Over.

Extend Existing Roof - 
Rectangular

To extend the main roof down over a window 
unit to create a rectangular roof over it rather 
than one that follows its shape, select both 
Extend Existing Roof over and 
Rectangular Roof Over. 

Gable Roof
A gable roof is not one of the automatic 
options for the roof above a bay, box or bow 
window. A gable can be created by manually 
editing the rectangular hip roofs that are 
automatically created. See “Roof Planes” on 
page 488.
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To create a gable over a bay window

1. Select the front ridge corner handle of 
each side hip roof plane and drag the 
edge forward until the fascia snaps to the 
edge of the front hip section. 

2. Delete the front hip section. 
3. Adjust the roof’s overhang as needed. 

Bay/Box and Bow Window Specification Dialogs
To open the Bay/Box Window 
Specification or the Bow Window 

Specification dialog, select one or more 
Bay/Box or Bow Windows and click the 
Open Object edit button. 

The options in this dialog can only be set for 
objects placed in a plan: Bay, Box, and Bow 
Windows do not have defaults dialogs. 

The settings that are available in these 
dialogs depend on whether the selected 
object is a Bay, Box, or Bow Window. 

To create a gable roof over a normal
window, use the Gable Over Door/

Window edit button. See “Gable/Roof Lines”
on page 515.
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General Panel

Sections -The setting that displays here 
depends on whether the selected 

window is a Bay, Box, or Bow Window.
• Specify the Bay Angle, which is the 

angle of the side components of a Bay or 
Box Window. Bay Windows have an 
angle of 45° by default; Box Windows 
have an angle of 90°.

• Specify the Quantity, which is number of 
component windows in a Bow Window.

Size - Specify the Width and Depth of 
the selected Bay, Box, or Bow Window. 

Specify the Wall Type used by the 
walls embedded in the selected Bay, 

Box, or Bow Window. See “Wall Type 
Definitions” on page 302. 

• Select “Use Main Wall Type” from the 
drop-down list to use the same wall type 
as that of the wall that the window unit is 
placed in. If the main wall is a Pony Wall, 
both wall types are used. 

• Select a specific wall type from the drop-
down list to use it instead of the Main 
Wall Type. 

• When a specific wall type is selected, 
click the Define button to modify its defi-
nition. See “Wall Type Definitions 
Dialog” on page 305. 

Specify the height and structure of the 
Ceiling within the selected window. 

• Check Has Lowered Ceiling to enable 
the settings that follow. When this is 

1

2

3 4
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unchecked, the ceiling height and finish 
material within the window is the same as 
that for the adjacent room.

• Specify the Height Lowered, which is 
measured from the ceiling height of the 
adjacent room. 

• Specify the Finish Thickness, which is 
the thickness of the ceiling’s finish mate-
rial. 

• Specify the Structure Thickness, which 
is the thickness of the ceiling’s structural 
layer.

Specify the height and structure of the 
Floor within the selected window. 

• Check Has Raised Floor to enable the 
settings that follow. When this is 
unchecked, the floor height and material 
within the window is the same as that for 
the adjacent room. 

• Specify the Height Raised, which is the 
measured from the floor height of the 
adjacent room. 

• Check Use Floor Finish to measure the 
Height Raised distance from the surface 
of the floor finish. When unchecked, as it 
is by default, this height is measured 
from the subfloor. 

• Specify the Finish Thickness, which is 
the thickness of the floor’s finish mate-
rial.

• Specify the Structure Thickness, which 
is the thickness of the floor’s structural 
layer.

Check Include in Schedule to include 
the selected window(s) in Window 

Schedules. See “The Schedule Tools” on 
page 1268. 

Note: If the Height Lowered is 0”, Has Low-
ered Ceiling will become unchecked when
you click OK.

5

Note: If the Height Raised is 0”, Has Raised
Floor will become unchecked when you click
OK.

6
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Options Panel

Specify the structure of the automatic 
Roof over the selected window unit. 

See “Bay, Box, Bow Windows and Roofs” 
on page 427. 
• Check Use Existing Roof if the existing 

roof needs no changes to accommodate 
the bay window.

• Check Extend Existing Roof Over to 
extend the existing roof plane to cover 
the bay window below.

• Check Rectangular Roof Over to create 
a roof over the bay window that is square 
across the end instead of following the 
profile of the roof. 

Specify the appearance of the selected 
window unit’s Dimensions in floor 

plan view. 
• Check Display Standard Dimension to 

display the automatically-produced 

dimensions that show the window’s 
width and depth.

• Check Display Dimensions to Center to 
display a Bow Window’s radial dimen-
sion.

Specify the structure of the selected 
window unit’s Components and the 

wall sections containing them.
• Uncheck Has Component Windows to 

remove the component windows of the 
selected Bay, Box, or Bow Window and 
disable the settings that follow.

• Check No Framing Between Compo-
nents to eliminate the trimmer studs for 
Bay and Box Window components, 
allowing the width of each component 
window to increase. See “Wall Framing” 
on page 578.

1

2

3
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• Check No Framing Between Compo-
nents to remove both studs between the 
component windows.

• Check Connect Outer Casing to have 
exterior casing surround the component 
windows of a Bow Window as a group 
rather than individually. Mullions are 
provided between components. This is 
how interior casing is always created. 

• Check Components Recessed to recess 
the component windows into the wall and 
enable the settings that follow. Typically 
used if the window is placed in a brick 
wall and you want to produce a brick 
molding. 

• Select To Main Layer to recess the com-
ponents to the wall’s Main Layer instead 
of the exterior wall surface. See “The 
Main Layer” on page 302. 

• Select To Sheathing Layer to recess the 
components to the sheathing layer instead 
of the exterior wall surface.

Layer Panel
For information about using the LAYER 
panel, see “Layer Panel” on page 154.

Materials Panel
The settings on the MATERIALS panel are the 
same as those found on the same panel in 
dialogs throughout the program. See 
“Materials Panel” on page 852.

Label Panel
Bay, Box, and Bow Window labels display in 
floor plan view and cross section/elevation 
views when the “Windows, Labels” layer is 
turned on and use the Text Style assigned to 
that layer. See “Window Labels” on page 
403. 

For more information about the settings on 
this panel. See “Label Panel” on page 1280.

Window Schedules
The Window Schedule tool allows 
you to produce customizable window 

schedules as well as window labels that 
display schedule numbers. See “The 
Schedule Tools” on page 1268.

Window casing profiles and materials can 
also be included in Room Finish Schedules.

Note: If the selected unit is moved or resized,
its components automatically resize to use a
standard trimmer, regardless of whether
either of the two options above are selected.
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Chapter 12:

Multiple Floors

When a new plan file is opened in Chief 
Architect, two floor levels are present: Floor 
1 and the Attic Floor. You can add more 
floors whenever you like: up to 30 total. 
Once created, floors can also be copied, 
swapped, and deleted.  

Chief Architect also supports special floors 
for foundations and attics. Only one 
foundation level and one attic can exist in a 
plan. Foundations are discussed in their own 
chapter. See “Foundations” on page 447.

Chapter Contents
•      Floor Defaults Dialog
•      Floor Tools
•      Adding Floors
•      Displaying Floors
•      Exchanging Floors
•      Copying Floors
•      Deleting Floors
•      Rebuilding Walls, Floors and Ceilings
•      Split Levels
•      The Current Floor
•      The Attic Floor
•      The Reference Floor
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Floor Defaults Dialog
There is a Floor Defaults dialog for 
each floor in a plan file. The defaults 

for the current floor can be accessed by 
selecting Edit> Default Settings. Select 
“Floor” from the category tree and click the 
Edit button to open the Floor Defaults 
dialog for the currently active floor. See 
“Default Settings vs Preferences” on page 
74.
• The Floor Defaults dialog can also be 

opened by double-clicking the Floor 
Tools  parent button.

• In addition, the Floor Defaults  button 
can be added to a toolbar for quick access 
to the Floor Defaults dialog. See “Tool-
bar Customization Dialog” on page 135.

The Floor Defaults dialog also opens 
whenever you add a new floor to the plan. 
See “Adding Floors” on page 437. 

The Floor Defaults dialog does not open 
when you build a foundation; however, the 
Floor 0 Default settings are created based on 
the current Foundation Defaults. See 
“Foundation Defaults” on page 448. 

The Floor Defaults dialog is similar to the 
Room Specification dialog, but controls the 
default settings for all rooms on the current 
floor. The settings here also control the 
height of individual walls as they are drawn 

on the floor in question. See “Room 
Specification Dialog” on page 350. 

Structure Panel
The settings on the STRUCTURE panel are 
similar to those in the Room Specification 
dialog. See “Structure Panel” on page 352. 

Moldings Panel
The settings on the MOLDINGS panel are 
similar to those in the Room Specification 
dialog. See “Moldings Panel” on page 659. 

Fill Style Panel
The settings on the FILL STYLE panel are 
similar to those in the specification dialogs 
for many objects throughout the program. 
See “Fill Style Panel” on page 1099. 

Materials Panel
The settings on the MATERIALS panel are 
similar to those in the specification dialogs 
for many objects throughout the program. 
See “Materials Panel” on page 852. 

Floor Tools
Select Build> Floor to access the 
floor tools.

Select Build> Floor> Build New 
Floor to build a new floor. A new 

floor can be generated based upon the 

Note: The default floor height for Floor 1 is 0.
It can be modified in the Room Specification
dialog, but not in the Floor 1 Defaults dialog.
See “Floor and Room Defaults” on page 330.
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perimeter of the floor below or a blank floor 
can be created and drawn from scratch. See 
“Adding Floors” on page 437.

Select Build> Floor> Insert New 
Floor to insert a new floor below the 

current floor. See “Adding Floors” on page 
437.

Choose Build> Floor> Delete 
Current Floor to remove the current 

floor from the plan. For more information, 
see “Deleting Floors” on page 441.

Select Build> Floor> Exchange 
With Floor Above to move the 

current floor up one floor and the floor above 
it down. See “Exchanging Floors” on page 
440.

Choose Build> Floor> Exchange 
With Floor Below to move the 

current floor down one floor and the floor 
below it, up. See “Exchanging Floors” on 
page 440.

Choose Build> Floor> Build 
Foundation to open the Foundation 

Defaults dialog and build a foundation floor. 
See “Building a Foundation” on page 452.

Select Build> Floor> Delete 
Foundation to remove the foundation 

from the plan. See “Deleting Foundations” 
on page 459.

Select Build> Floor> Hole in Floor 
Platform to draw a hole in a floor 

platform on the current floor. See “Floor and 
Ceiling Platforms” on page 344.

Select Build> Floor> Hole in Ceiling 
Platform to draw a hole in a ceiling 

platform on the current floor. See “Floor and 
Ceiling Platforms” on page 344.

Select Build> Floor> Layered 
Material Polyline to draw a Layered 

Material Polyline. See “Floor and Wall 
Material Regions” on page 799.

Choose Build> Floor> Rebuild 
Walls/Floors/Ceilings to force Chief 

Architect to recalculate the relationship 
between the walls, floors, and ceilings in 
your model. See “Rebuilding Walls, Floors 
and Ceilings” on page 441.

Adding Floors
When a new plan file is opened in Chief 
Architect, two floor levels are present: Floor 
1 and the Attic Floor. You can add up to 30 
total living floors, as well as create a 
foundation below Floor 1.

Floors can be added whenever you like; and 
once created, they can also be copied, 
swapped, and deleted. 

Build New Floor
New floors can be created in floor 
plan view as well as in 3D views, and 

are always added above the top living floor. 

Note: Chief Architect allows only one floor,
the foundation/basement, below the first floor.
Keep this in mind when you begin an as-built
or plan for a multi-story building. See “Foun-
dations” on page 447. 
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To create a new floor, select Build> Floor> 
Build New Floor. 

• Derive new 2nd floor plan from the 1st 
floor plan creates a new top floor with 
exterior walls generated directly over the 
exterior walls of the floor below. Wall 
types and roof directives associated with 
the walls on the floor below are dupli-
cated; however, interior walls are not. See 
“Roof Panel” on page 314.

• Check Move Highest Floor’s Roof Up to 
move any roof planes displaying on the 
highest floor in the plan up one floor 
when the new floor is created. Roof 
planes displaying on floors other than the 
top floor are unaffected. This option is 
only available if there are roof planes 
built on the top floor and is not available 
when Auto Rebuild Roofs is enabled. 
See “Build Roof Dialog” on page 480.

• Check Step floor/ceiling elevations to 
match existing floor to maintain all ceil-
ing heights on the existing floor by step-
ping floor heights on the new floor to 
match. Ceiling heights on the new floor 

also become stepped accordingly. See 
“Stepped Floor and Ceiling Platforms” on 
page 345. 

• Make new (blank) plan for the 2nd 
floor creates a new top floor that is blank. 
This option is typically selected only if 
none of the exterior walls on the new 
floor will be directly above the exterior 
walls on the floor below. If you choose 
this method, it may be helpful to turn on 
the Reference Floor when drawing walls 
on the new floor. See “The Reference 
Floor” on page 444.

When you click OK, the Floor Defaults 
dialog for the newly created floor opens. 
Make any necessary changes to the floor 
structure, moldings, or materials and click 
OK. See “Floor Defaults Dialog” on page 
436.

The new floor becomes the current floor in 
floor plan view. If, however, the new floor is 
created in a 3D view, the camera remains on 
its original floor and does not move. 

Insert New Floor
A floor can also be inserted beneath 
the current floor in both floor plan 

view and 3D views. Begin by making the 
floor you would like to insert a floor under as 
the Current Floor, then select Build> Floor> 
Insert New Floor.  See “Change Floor / 
Reference” on page 445.

When Move highest floor roof up is
checked, roof planes on the top floor

will move even if the “Roof Planes” layer is
locked and manually edited roof planes are
set to be retained. See “Roof Panel” on page
481.
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• Select Derive new 2nd Floor plan from 
the 1st Floor plan to insert a new floor 
below the current floor, based on the exte-
rior walls of the current floor. 

• Check Move Highest Floor’s Roof Up to 
move any roof planes displaying on the 
highest floor in the plan up one floor 
when the new floor is created. Roof 
planes displaying on floors other than the 
top floor are unaffected. This option is 
only available if there are roof planes 
built on the top floor and is not available 
when Auto Rebuild Roofs is enabled. 
See “Build Roof Dialog” on page 480.

• Check Step floor/ceiling elevations to 
match existing floor to maintain the floor 
and ceiling heights on the existing floors 
by stepping floor and ceiling heights on 
the new floor to match. See “Stepped 
Floor and Ceiling Platforms” on page 
345. 

• Select Make new (blank) plan to insert a 
blank floor below the Current Floor. 

Adding a Foundation
To add a foundation, select Build> Floor> 
Build Foundation . See “Building a 
Foundation” on page 452.

Displaying Floors
Chief Architect allows you to view the floors 
in your plan in a variety of ways.

In Floor Plan View
In floor plan view, only one floor can be 
active for editing at a time. This is referred to 
as the Current Floor. See “The Current 
Floor” on page 443. 

In addition to the Current Floor, one other 
floor can be displayed for reference 
purposes: the Reference Floor. Objects on 
the Current Floor can snap to those on the 
Reference Floor, helping you align objects. 
See “The Reference Floor” on page 444.

Floor and ceiling platforms do not display in 
floor plan view.  When floor and/or ceiling 
framing is present, its display can be turned 
on; however, other components of floor and 
ceiling platforms like sheathing, drywall, and 
finish materials, cannot.

In 3D Views
In most 3D views, all floors in a plan are 
visible, from the foundation up to the attic. 
There are three exceptions: 

• Perspective Floor Camera  views, 
which show the Current Floor only.

When Move highest floor roof up is
checked, roof planes on the top floor

will move even if the “Roof Planes” layer is
locked and manually edited roof planes are
set to be retained. See “Roof Panel” on page
481.
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• Orthographic  and Perspective Floor 
Overviews , which show the Current 
Floor, not including its ceiling, plus any 
floors beneath it. 

• Wall Elevation  views, which show a 
wall on a single floor, in a single room.

See “3D View Tools” on page 897. 

In the Materials List
The materials that make up floor and ceiling 
platform assemblies are listed under different 
Categories in the Materials List: 
• Subfloor - Lists floor framing and struc-

tural subflooring materials specified in all 
Floor Structure Definitions in the current 
plan. See “Floor and Ceiling Platform 
Definitions” on page 344.

• Flooring - Lists flooring and subflooring 
materials specified in all Floor Finish 
Definitions in the current plan.

• Framing - Lists ceiling framing and any 
other materials specified in all Ceiling 
Structure Definitions in the current plan.

• Wall Board - Lists ceiling finish materi-
als specified in all Ceiling Finish Defini-
tions in the current plan.

• Insulation - Floor insulation is calculated 
for all rooms that have a floor, and ceiling 
insulation is calculated for all rooms that 
have a ceiling - regardless of the Floor or 
Ceiling Structure Definition. When a ceil-
ing is not present, insulation is calculated 
for the roof. See “Structure Panel” on 
page 352. 

• Foundation - Lists the concrete and mesh 
for all Floor Structure Definitions in the 
current plan with a layer of concrete 
material. See “Material Types” on page 
860.

See “Materials Lists” on page 1283. 

Exchanging Floors
Select Build> Floor> Exchange 
With Floor Above or  Exchange 

With Floor Below to swap the current floor 
with the floor above or below. 

The floor that was moved becomes the 
current floor at its new location. You can 
easily move a floor up or down several floors 
by using either one of these buttons 
repeatedly.

Copying Floors
The Edit Area  tools can be used to make 
copies of entire floors in a plan. See “Edit 
Area Tools” on page 252.  You can use these 
tools to:

• Make a copy of an existing floor to be 
pasted onto a new floor.

• Make a copy of all existing floors in a 
plan to be pasted into a different plan.
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You can also copy the information on a floor 
by pressing Ctrl + A (Select All), then using 

Copy  and Paste Hold Position . See 
“Paste Hold Position” on page 173.

Copying Between Plans
While you can copy and paste floors from 
one plan file to another, this is not always the 
best approach. 

• To make a copy of the plan for backup or 

your records, use Save As  to save the 
file using a new name. See “Saving, 
Exporting, and Backing Up Files” on 
page 55.

• To copy the model into another plan with 
multiple structures, consider exporting it 
as a symbol and importing it into the new 
plan. See “Custom Symbols” on page 
1195.

Deleting Floors
Select Build> Floor> Delete Current 
Floor to remove the current floor 

from the plan. If there is a floor above, it 
becomes the current floor; if there is no floor 
below, the floor beneath becomes the current 
floor. 

To delete Floor 0, select Build> 
Floor> Delete Foundation. You can 

delete the foundation without actually being 

on Floor 0. Floor 0 cannot be deleted while 
Auto Rebuild Foundation is turned on. See 
“Deleting Foundations” on page 459.

Rebuilding Walls, Floors and Ceilings
When you make a change to the walls 
or to the floor or ceiling platforms in 

your plan, they may not immediately resize 
or move in the 3D model. The program does 
detect such changes, though, and the next 
time you generate a 3D or section/elevation 
view, walls,  floors and ceilings are rebuilt.

By default, walls, floors and ceilings are also 
rebuilt when an automatic roof is generated. 
See “Build Roof Dialog” on page 480.

You can direct the program to rebuild walls, 
floors, and ceilings at any time by selecting 

Build> Floor> Rebuild Walls/Floors/
Ceilings .

If you do not want the program to rebuild 
walls, floors and ceilings when a 3D view is 
created, uncheck Auto Rebuild Floors and 
Ceilings in the 3D View Defaults dialog. 
This may speed up plan view editing for very 
large plans. When this is unchecked and the 
structure is not up to date, the Rebuild Walls, 
Floors, Ceilings  icon displays near your 
mouse pointer. See “Options Panel” on page 
893. 

When a floor is deleted, all objects on
that floor are deleted with it, including

locked roof planes and any other objects on
locked layers. See “Locking Layers” on page
145.
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Split Levels
Both split level floor plans and split level 
entries can be created by controlling the floor 
and ceiling heights of individual rooms in a 
multiple story structure. 

Split Level Floor Plans
A split level, or tri-level, structure is a 
building where the floor level in one part of 
the plan is located approximately half way 
between the floor and ceiling levels of 
another part of the plan. 

To create a simple split level plan

1. Draw a simple rectangular structure 
divided into two separate halves by an 
interior wall.

2. Select one of the rooms and click the 

Open Object  edit button. See 
“Room Specification Dialog” on page 
350.

3. Raise the Floor Height then press the 
Tab key.

4. Restore the Relative Rough Ceiling to 
the default value, then click OK.

5. Build a stem wall foundation. See 
“Foundations” on page 447.

•  The foundation under the room with 
the lower floor height will have the 
specified Min Stem Wall Height. 

•  The foundation under the room with 
the raised floor will have taller stem 
walls. 

•  Both can be edited in the Room 
Specification dialog.

6. If you add a Floor 2, note that the Ceil-
ing Height in the room on Floor 1 will 
be reset to the default value. 

•  To maintain a stepped condition on 
multiple floors, return to this room and 
set the Relative Rough Ceiling back to 
using the default.

For more detailed instructions, visit  chiefar-
chitect.com .

Split Level Entries
A split level entry, or divided entry, is 
characterized by an entry door that opens 
onto a landing positioned half way between 
the basement floor and first floor levels. 

Split Level Home

Split Level Entry

http://www.chiefarchitect.com/support/displayfaq.php?faqNumber=932
http://www.chiefarchitect.com/support/displayfaq.php?faqNumber=932
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To create a simple split level entry

1. Create a plan file with a full basement at 
the location of the entry door. See 
“Basement Rooms” on page 460.

2. Go to Floor 0 and draw a stair 

Landing  at the location of the entry. 
See “Landings” on page 543.

3. Specify the desired height of the land-
ing. See “Stair Landing Specification 
Dialog” on page 573.

4. Draw stairs upward from the basement 
floor to the landing.

5. Draw a second stair section from the 
landing upward. 

6. Select the stairs and click the Auto 
Stairwell  edit button. See “Creating 
a Stairwell” on page 556. 

Split level entries are often associated with 
daylight basements. See “Daylight 
Basements” on page 461. 

For more detailed instructions, visit  chiefar-
chitect.com .

The Current Floor
Only one floor can be active at any given 
time. The active floor is referred to as the 
Current Floor, and it is the only floor on 
which objects can be edited.

If you want to edit two different floors at the 
same time, you can open the plan again. This 
opens a second window on the current open 
plan that has the same editing abilities as the 
first. Only one of these windows can be 
active at any given time.

Floor Up / Floor Down
If you are working with 
more than one floor, you 

can select Tools> Reference Floors> Up 
One Floor or Down One Floor to switch 
from one floor to another. 

You can change the current floor in floor 
plan, cross section/elevation and 3D views. 
The current floor displays on the Change 

Floor/Reference  button, which can be 
found between the Down One Floor and the 
Up One Floor buttons. 

Floors become available once they have been 
built. The Attic and foundation levels are 
also accessible using these tools. 

Change Floor / Reference
If there are multiple floors, select 
Tools> Reference Floors> Change 

Floor/Reference to open the Change Floor/
Reference dialog, where you can select both 
the current floor and which floor is used in 
the Reference Floor, as well as control the 
appearance of the Reference Floor. 

http://www.chiefarchitect.com/support/displayfaq.php?search=1532&body_id=&search=
http://www.chiefarchitect.com/support/displayfaq.php?search=1532&body_id=&search=
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The Attic Floor
Chief Architect automatically creates 
a floor above the top numbered floor 

level of each plan. This floor is called the 
Attic floor and has only one purpose: to 
provide a space for automatically generated 
Attic walls. See “Attic Walls” on page 297.

Because the Attic floor is not meant to be a 
living area, a warning message will display if 
you try to draw walls or other objects on this 
floor.

In some situations, you may find it necessary 
to draw one or more walls on this floor; 
however, even if you enclose an area with 
walls, rooms cannot be created on the Attic 
floor.

If you wish to create an attic loft, bonus 
room, or storage area in your plan, you will 
need do so on a numbered floor level. 

The Reference Floor
When there is more than one floor in a 
model, it is often helpful to see how they 
relate to each other. Any floor can be shown 
as the Reference Floor along with the 
current floor. 

When the Reference Floor Display is turned 
on, the floor that you were last on prior to the 
current floor is used as the Reference Floor 
and is shown in red. Objects on the current 
floor can snap to objects on the Reference 
Floor; however, objects on the Reference 
Floor cannot be selected or edited.

Reference Floor Display
To turn on the Reference Floor, select 
Tools> Reference Floors> Reference 

Floor Display or press F9 on your keyboard. 
The Reference Floor can also be toggled on 
or off quickly in floor plan view by clicking 
the Reference Floor Display toggle button.

If the Reference Floor is on when a floor plan 
view is sent to layout, it is always on in that 
layout view and is not affected if it is turned 

off in the plan. It can be turned on or off in 
the view’s Layout Box Specification dialog, 
however. See “Plan View Panel” on page 
1253.

If the Reference Floor is turned on when a 
view is printed, it will be included in the 
printed output. See “Displaying Objects” on 
page 1214. 

Reference Floor Display 
Options

The display of objects in the 
Reference Floor is controlled by layer 

set. You can control the appearance of the 
layer set currently in use by selecting Tools> 
Reference Floors> Reference Floor 

Note: If objects on the current floor and the
Reference Floor have edges that line up, the
Reference Floor may be difficult to see on
screen. When lines of two different colors are
superimposed upon each other, discoloration
may result.
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Display Options. See “Layer Display 
Options Dialog” on page 149.

The current Reference Floor layer set can be 
specified in both the Change Floor/
Reference and Layer Set Management 

dialogs. While the default Reference Display 
Set is usually sufficient, you also can create 
as additional layer sets and use any of them 
for the Reference Floor.  See “Layer Set 
Management” on page 147. 

Change Floor / Reference
By default, the floor below the current 
floor is the Reference Floor, but any 

floor can be referenced using the Change 

Floor/Reference dialog. To open the dialog, 
select Tools> Reference Floors> Change 
Floor/Reference button. 

The Current Floor is highlighted here. 
You can select another floor to make it 

the current floor.

The Reference Floor currently used for 
reference is highlighted here. You can 

select another floor to display it instead. 

The Reference Floor Layer Set, which 
controls which layers are visible in the 

Reference Floor, is listed here. By default, 
the Reference Display Set is used. Select 
another layer set from the drop-down list to 
use it for the Reference Floor Display. 

Display Options allow you to control 
how the lines and fill patterns of objects 

in the Reference Floor appear.
• Select Draw Reference Floor First to 

draw the Reference Floor before drawing 
the objects on the current floor. The lines 
and fill patterns of objects in the Refer-

1

2

3

While any layer set can be used as
the Reference Display Layer Set, for

best results you should use the default
Reference Display Set or create a new
layer set specifically for reference display
purposes. See “Layer Sets” on page 146. 

 4
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ence Floor display behind the current 
floor.

• Select Draw Reference Floor Last to 
draw the Reference Floor after the objects 
on the current floor are drawn. The lines 
and fill patterns of objects in the Refer-
ence Floor display in front of the current 
floor, and may cover objects on the cur-
rent floor partially or completely. 

• Use Object Settings displays the line and 
fill styles of objects in the Reference 
Floor that aren’t using their default line 
and fill styles. When this is unchecked, 
objects display according to their layer 
settings in the Reference Floor Layer Set.

• Use XOR Drawing changes the color of 
lines in the Reference Floor that are 
drawn on top of one another. Lines with 
identical properties do not display. 

Swap Floor/Reference
If one floor is defined as the current 
floor and another floor is defined as 

the reference floor, select Tools> Reference 
Floors> Swap Floor/Reference to switch 
the status of the two floors.
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Chapter 13:

Foundations

There are three foundation types in Chief 
Architect: stem walls with footings, grade 
beams on piers, and monolithic slab. All 
three can be generated automatically or 
manually. The foundation type can be 
specified in the Foundation Defaults dialog 
when the foundation is built on Floor 0. 

There can be only one foundation level in a 
plan, Floor 0; however, foundation structures 
can be drawn on any floor using the 
Foundation and Slab Tools.

Chapter Contents
•      Foundation Defaults
•      Building a Foundation
•      Displaying Foundations
•      Editing Foundations
•      Aligning Foundation Walls
•      Deleting Foundations
•      Foundations and Rooms
•      Foundations and the Terrain
•      The Slab Tools
•      Editing Slabs
•      Slab Specification Dialog
•      Editing Piers and Pads
•      Pier/Pad Specification Dialog
•      Fireplaces
•      Fireplace Specification Dialog
•      Library Fireplaces
•      Chimneys

Always consult registered geotechnical
and civil engineers for information

regarding the proper foundation for your site. 
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Foundation Defaults
There are several defaults dialogs that 
affect the foundation. They can be 

accessed by selecting Edit> Default 
Settings. 

Select “Foundation” and click the Edit 
button to open the Foundation Defaults 
dialog. 

If a foundation has been built and you are on 
Floor 0, select “Floor” and click the Edit 
button to open the Floor 0 Defaults dialog. 

The settings here are initially drawn from 
those in the Foundation Defaults dialog.  
See “Floor Defaults Dialog” on page 436.

Click the + beside “Walls” to display the 
subheadings, then select “Foundation Wall” 
or “Slab Footing” and click the Edit button 
to open the defaults dialog for that wall tool. 
See “Wall, Railing, and Fencing Defaults” on 
page 260. 

Foundation Defaults Dialog
The Foundation Defaults dialog allows you 
to specify stem wall height, slab thickness, 
sill plates, and other characteristics of a 
foundation. These values determine how a 
new foundation is generated as well as the 
sizes for manually drawn foundation walls 
added to an existing foundation. 

The settings in the Foundation Defaults 
dialog are similar to those in the Build 
Foundation dialog, which opens when 

Build> Floor> Build Foundation  is 
selected. The primary difference is that when 
you click OK in the Foundation Defaults 
dialog, no changes are made to the model. 
See “Building a Foundation” on page 452.
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Foundation Panel

Check Auto Rebuild Foundation to 
automatically rebuild the foundation 

whenever changes are made to Floor 1 that 
affect the structure of the foundation.  See 
“Rebuilding Foundations” on page 456. 

Three different Foundation Types can 
be created in Chief Architect. Each type 

of foundation has different default settings, 

options, and behaviors. Select the radio 
button next to the desired type. 
• Select Walls with Footings to produce a 

foundation composed of stem walls with 
footings that run continuously under the 
base of the walls. 

• Select Grade Beams on Piers to 
generate a pier and grade beam 

1

2
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foundation. The floor framing rests 
directly on top of the grade beams. 

• Select Monolithic Slab to build a slab 
foundation defined by Slab Footings. The 
foundation forms the floor platform for 
Floor 1. It is visible on Floor 0 and can be 
selected and edited. See “Slab Footing” 
on page 270. 

• Check Hang 1st Floor Platform Inside 
Foundation Walls to produce stem walls 
that build up to the top of the floor plat-
form of Floor 1. When unchecked, the 
stem walls build to the bottom of the 
floor platform, which bears on top of 
them. Only available when Walls with 
Footings is selected, above.

• Check Show “S” Markers on Step 
Foundation to include an “S” symbol in 
floor plan view anywhere there is a step 
in foundation wall height. Not available 
when Grade Beams on Piers is selected, 
above. See “Displaying Foundations” on 
page 454. 

Slab 

• The name of the Default Slab Footing 
Wall Type displays here for reference. 
Click the Edit Default Slab Footing but-
ton to open the Wall Type Definitions 
dialog and change the definition of the 
default wall type. Only available when 
Monolithic Slab is the selected Founda-
tion Type. 

• Specify the Slab Thickness, which is the 
thickness of the slab produced above the 
footing or at the top of the stem wall.

• Check Slab at top of Stem Wall to raise 
the slab so its top is flush with the top of 
the stem walls. Only available when 

Walls with Footings is the selected Foun-
dation Type.
If Slab at top of Stem Wall is selected, 
all rooms on the first floor are automati-
cally set to Floor Supplied by the Foun-
dation Room Below in the Room 
Specification dialog. See “Structure 
Panel” on page 352.

Stem Walls  

• The name of the Default Foundation 
Wall Type displays here for reference. 

• Click the Edit Default Foundation Wall 
button to open the Foundation Wall 
Defaults dialog and change the default 
settings for foundation walls. See “Foun-
dation Walls” on page 269. 

• If Monolithic Slab is the selected Foun-
dation Type, the Edit Garage Curb but-
ton will be available. Click it to open the 
Foundation Wall Defaults dialog and 
define the walls that form curbs around 
Garage and Slab rooms. 

• Specify the Minimum Height, which is 
the minimum height for foundation stem 
walls and grade beams and includes the 
sill plates. 

• The Basement Ceiling Height displays 
here as a reference. This is the distance 
from the top of the slab floor to the base-
ment ceiling and is equal to the Minimum 
Wall Height minus the Slab Thickness. 

If the Minimum Wall Height is at least 
76” (1900 mm), a Ceiling Finish is added 
to the foundation room automatically. A 
slab floor is also generated above the 
footing. The ceiling height and finish can 
be changed later. See “Room Specifica-
tion Dialog” on page 350. To remove this 

3
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slab, specify the room areas in the base-
ment as “Open Below”. See “Room 
Types” on page 335. 

The Piers options are only available 
when Grade Beams on Piers is the 

selected Foundation Type. 
• Specify the Width, Depth, and Maxi-

mum Separation of the piers.
• Choose either Round or Square piers.

Garage Options 

• Specify the Garage Floor to Stem Wall 
Top, which is the distance between the 
slab and the tops of the stem walls in both 
Garage and Slab rooms. Available for 
Walls with Footings and Grade Beams on 
Piers foundation types. See “Foundation 
Defaults” on page 448. 

• Specify the Lower Garage Floor height, 
which is the distance that Garage and 

Slab room floors are lowered when a 
Monolithic Slab foundation is  built. This 
value is also the height of the curbs 
around these rooms.  See “Garages” on 
page 459. 

• Specify the Minimum Garage Stem 
Wall Height, which is  the minimum 
height that stem walls defining a Garage 
foundation will be, regardless of the Min-
imum Stem Wall Height for the rest of the 
foundation. 

Check Sill Plate to reserve space for 
one or more sill plates, or mud sills, 

between stem walls and grade beams and the 
floor platforms or framed walls that bear on 
them. Sill plates are generated when the floor 
framing for Floor 1 is generated. See “Sill 
Plates” on page 579.
• Specify the Width and Height of the 

treated sill plates. If the Height is set to 
zero, no sill plates are produced. Not 
available if Monolithic Slab is the 
selected Foundation Type.

• Specify the Count, which is the number 
of sill plates stacked vertically on each 
stem wall or grade beam.

Options Panel
The OPTIONS panel allows you to include 
rebar and other materials related to the 
foundation  in the Materials List. See 
“Materials Lists” on page 1283. 

Some options on this panel may be 
unavailable depending on the foundation 
type selected on the FOUNDATION panel. 

Note: The Garage Floor to Stem Wall Top set-
ting only affects Garage rooms that have a
Floor Height of 0. See “Structure Panel” on
page 352. 

5
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Specify the Rebar used in the major 
foundation components: Footing, Wall 

Horizontal courses, Wall Vertical courses, 
Pier, and Slab. Rebar is calculated in the 
Materials List but does not display in any 2D 
or 3D views of the model. See “The 
Materials List Tools” on page 1284. 
• Bars per Course - Specify the number of 

bars of rebar to be used per course for 
each foundation component. 

• Course Spacing - Define the spacing for 
Vertical and Horizontal Wall courses, and 
for Slabs. If slabs are to have rebar 
instead of mesh, this spacing value 
applies to both directions.

• Rebar size - Define the rebar size in 
1/8th inches. 4 represents 4/8, or ½ inch.

• Specify the Overlap where sticks of 
rebar meet, in terms of the rebar’s Diam-
eter. A value of 40.0, for example, equals 
40 times the Rebar Size. 

• Check Use Mesh to reinforce the slab 
floor with mesh instead of rebar, or 
uncheck it to use rebar. 

Foundation Options - Select either 
Foam Seal, Termite Flashing, or both. 

These options are added to the Materials 
List, but do not display in the model.

Building a Foundation
Foundations can be generated 
automatically or drawn manually. A 

combination of the two methods can also be 
used. 

Three foundation types are available: stem 
walls with footings, grade beams on piers, 

and monolithic slabs. The first two options 
are created using walls; the last creates 
concrete slabs with footings.

Automatically built foundations are placed 
on Floor 0 and are based on wall positions 

1

2



Building a Foundation

 453

and floor heights on Floor 1. Foundation 
walls or slab footings are generated under:
• All exterior walls on Floor 1 that define a 

room other than a Court, Deck or Bal-
cony room type. See “Room Definition” 
on page 331.

• Any interior walls on Floor 1 defining 
rooms with different floor heights. See 
“Floor and Ceiling Heights” on page 342. 

• Any interior walls on Floor 1 that have 
Create Wall/Footing Below checked in 
the Wall Specification dialog. See 
“Foundation Panel” on page 317. 

At least one room must be defined on Floor 1 
for a foundation to be automatically 
generated. If no rooms are defined on Floor 
1, a blank Floor 0 is created. 

There can be only one Floor 0 per plan. If 
your plan requires a foundation on more than 
one floor, you will need to draw the required 
foundation walls or slabs yourself.

To build an automatic foundation

1. Select Build> Floor> Build Founda-
tion . 

2. Specify the desired foundation type and 
other information in the Build 
Foundation dialog. The settings in this 
dialog are similar to those in the Foun-
dation Defaults dialog. See “Foundation 
Defaults” on page 448.

3. In the New Floor dialog, select Derive 
new Foundation plan from the 1st 
floor plan and click OK to build a foun-
dation based on Floor 1.

If you prefer, you can instead select Make 
new (blank) plan for the Foundation to 

create an empty foundation level where you 
can manually draw foundation walls or slabs.

In most cases, it is preferable to base Floor 0 
off the first floor plan and then manually edit 
the foundation as needed. See “Editing 
Foundations” on page 456.

Mixing Foundation Types
You can also create a foundation that 
combines stem walls, grade beams and piers, 
and/or monolithic slabs.

To create a foundation of multiple types

1. Begin by specifying any rooms on Floor 
1 that require a slab floor as either a 
Garage or Slab Room Type. See “Foun-
dations and Rooms” on page 459.

2. Alternatively, or in addition, you can 
specify any rooms on Floor 1 as having 
a Monolithic Slab Foundation. See 
“Structure Panel” on page 352.

3. Build Foundation , as described 
above.

•  If the foundation will include any grade 
beams and piers, specify Grade 
Beams on Piers as the Foundation 
Type and build the foundation.

•  If the foundation will include a combi-
nation of stem walls and slabs, specify 
Walls with Footings as the Founda-
tion Type.

4. Once the foundation walls have been 
generated, they can be moved or deleted, 

and new Foundation Walls , Slab 
Footings , and/or Slabs  can be 
drawn. See “Foundation Walls” on page 
269 and “The Slab Tools” on page 462. 
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Openings in Foundation Walls
Any doors placed in walls around a Garage 
will receive cutouts in the garage stem wall 

or curb. The width of that cutout can be 
specified in the Door Specification dialog. 
See “General Panel” on page 375.

Displaying Foundations
The display of foundation walls, slabs, 
curbs, piers and footings is controlled 

in the Layer Display Options dialog. See 
“Layer Display Options Dialog” on page 
149. 
• Foundation Walls, including grade 

beams, Slab Footings and Garage curbs, 
are placed on the “Walls, Foundation” 
layer by default.

• Footings under Slab Footings and Foun-
dation Walls are placed on the “Footings” 
layer by default, as are foundation piers. 

• Post footings and deck post footings are 
placed on the “Footings, Post” and “Foot-
ings, Deck Post” layers by default.

• Slabs created using the Slab Tools  
are placed on the “Slabs, Custom” layer 
by default.

• Wall labels and slab labels are placed on 
the “Walls, Labels” and “Polylines 3D, 
Labels” layers, respectively.

• The “Foundations” layer controls the dis-
play of all objects on Floor 0 in 3D views 
but does not affect floor plan view. 

Wall and Slab Labels
Foundation walls and Slabs can both display 
labels when the “Walls, Labels” and 
“Polylines 3D, Labels” layers are on. Unlike 

some objects, walls and slabs have blank 
Automatic Labels; however, you can specify 
a custom label in their specification dialogs. 
See “Wall Specification Dialog” on page 308 
and “Slab Specification Dialog” on page 
463.

Wall and Slab labels display in floor plan and 
cross section/elevation views when their 
respective layer is turned on and use the Text 
Style assigned to that layer. See “Object 
Labels” on page 1279.

In Floor Plan View
The appearance of foundation wall types, 
including line weights, colors and fill styles, 
is specified in the Wall Type Definitions 
dialog. See “Wall Type Definitions Dialog” 
on page 305.

Changes in stem wall and monolithic slab 
foundation heights are represented in floor 
plan view with S markers. These markers are 
located on the “Footings, Step Markers” 
layer and use the Text Style assigned to that 
layer. See “Stepped Foundations” on page 
462.

If a door on Floor 1 extends into a stem wall 
or curb defining a Garage room, its location 
will be indicated on Floor 0. See “Displaying 
Doors” on page 365.
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In 3D Views
In 3D views, all objects on Floor 0 will only 
display when the “Foundation” layer is 
turned on. 

While the display of foundation walls and 
their footings can be controlled independent 
of one another in floor plan view, in 3D 
views this is not the case. If a foundation 
wall is set to display, its footing will as well - 
even if the “Footings” layer is turned off. The 
reverse is also true - if a foundation wall’s 
display is turned off, so will its footing’s.

The display of monolithic slab foundations in 
3D views is controlled by the “Foundation” 

layer. Slab Footings  are located on the 
“Walls, Foundation” layer; but if this layer is 

turned off, any Slab Footings  that define 
a foundation room will continue to display as 
long as the “Foundation” layer is on. 

In Cross Sections

When the Auto Detail  tool is used in a 
cross section view, the fill style of each wall 
layer as set in its Wall Type Definition is 
used. See “Auto Detail” on page 905.

Foundation wall footings and Slabs  use a 
concrete fill that cannot be specified 
beforehand but can be edited once Auto 
Detail  has been generated. 

Monolithic slabs and their footings use the 
fill style specified for the slab room’s Floor 
Structure definition. See “Floor and Ceiling 
Platform Definitions” on page 344. 

In the Materials List
The materials that make up foundation walls, 
footings, and slab floors are listed under the 
Foundation category in the Materials List, 
including:
• Concrete for walls, slabs, and footings
• Rebar for walls and footings
• Rebar or mesh for slabs

Slab Footings and the room areas that they 
define can be assigned Pour Numbers in 
their specification dialogs. Typically, a Slab 
Footing will have the same Pour Number as 
the room it defines, although it is possible for 
it to define multiple rooms with differing 
Pour Numbers. Pour Numbers are listed 
separately under the Foundation category of 
the Materials List. See “Foundation Panel” 
on page 317 and “Structure Panel” on page 
352.

Other objects relevant to foundations can be 
found in these categories:
• Exterior Trim - Lists slabs drawn with 

the Slab  tools that are located outside 
of a structure.

• Interior Trim - Lists slabs drawn with 

the Slab  tools that are located inside 
of a structure.

• Masonry - Lists fireplaces created with 

the Fireplace  tool. 

See “Materials Lists” on page 1283. 
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Editing Foundations
Stem wall with footings, wall with piers and 
monolithic slab foundations are all created 
using walls which enclose room areas.
• Foundation walls can be selected and 

edited much like other walls. See “Edit-
ing Walls” on page 285.

• Footing size can be changed on a wall by 
wall basis. See “Footing Width and 
Height” on page 457. 

• Foundation rooms can also be selected 
and edited like other rooms. See      Foun-
dations and Rooms.

Rebuilding Foundations
By default, foundations do not update 
automatically when changes are made to the 
structure on Floor 1. For example, if exterior 
walls are moved or floor platforms are raised 
or lowered, the foundation must be rebuilt.

You can direct the program to rebuild an 
automatically generated foundation 
whenever changes are made on Floor 1 that 
affect the foundation by checking Auto 
Rebuild Foundation in the Foundation 
Defaults dialog. See “Foundation Panel” on 
page 449.

You can also rebuild an automatically 
generated foundation by selecting Build> 
Floor> Build Foundation  from the 
menu. 

When Auto Rebuild Foundation is enabled, 
walls cannot be edited, manually drawn or 
deleted on Floor 0. When the foundation is 
rebuilt, any manually drawn or edited walls 
are deleted. Similarly, rooms on Floor 0 

cannot be edited while this option is enabled. 
If you try to draw a wall or edit a room or a 
wall while Auto Rebuild Foundation is 
turned on, a warning message will display.

Changing Foundation Types
When a foundation is generated, the program 
creates Floor Defaults settings for Floor 0 
based on the information in the Build 
Foundation dialog. If you specify a 
Monolithic Slab foundation, the default 
Floor Structure on Floor 1 will also be 
changed to a slab rather than a framed 
platform. See “Floor Defaults Dialog” on 
page 436.

If you rebuild the foundation using a 
different Foundation Type, it is advisable to 
check the floor heights of all rooms on Floor 
1 - particularly Garage and Slab rooms, as 
well as any rooms that do not use the default 
floor height of 0”. 

Stem Wall Height
When a foundation is created, all of Floor 0 
uses the stem wall height specified in the 
Foundation Defaults dialog, 

This height is measured from the bottom of 
floor platform of Floor 1 to top of the stem 
walls’ footings. If Floor 1 has multiple floor 
platform heights, the foundation stem walls 
will be stepped.

To avoid unexpected results, it is rec-
ommended that you not change the

Foundation Type once the foundation is built.
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Once a foundation is created, stem wall 
heights can be adjusted either on a room-by-
room basis or for individual walls.

To change a room’s stem wall height

1. Select a room on Floor 0 and click the 

Open Object  edit button. 
2. Specify the desired Stem Wall Height 

in the Room Specification dialog. See 
“General Panel” on page 351.

3. If you wish to reduce the Stem Wall 
Height, you will first need to reduce the 
Ceiling Height value by the same 
amount. 

If adjacent rooms have stem wall heights that 
differ by at least 1/16 of an inch, the stem 
wall separating them uses the larger of these 
two values.

In 3D views, individual stem walls can be 
selected and edited. In most cases,this 
method should only be used for stepping the 
bottom of the foundation wall. See “Stepped 
Walls and Footings” on page 298. 

Footing Width and Height
Foundation Wall footings derive their Width, 
Height and Offset from in the Foundation 
Wall Defaults dialog, Similarly, Slab 
Footings use the width and height specified 
in the Slab Footing Defaults dialog. Once a 
Foundation Wall or Slab Footing is created, 
its footing can be adjusted in its specification 
dialog. See “Foundation Panel” on page 317.

Footing Width can be adjusted using the edit 
handles in both floor plan and 3D views. 
Each side of the footing can be edited 
independently, which means that the Offset 
can also be modified using the footing resize 
edit handles. 

If the selected wall is a Slab Footing, the 
footing width can also be resized using 
dimensions and will resize the Wall 
Thickness, creating a new wall type if 
necessary. See “Editing Walls” on page 285. 

Stem wall footing heights can also be edited 
in 3D views just as the rest of the stem wall 
can. Slab Footing heights, on the other hand, 
cannot be adjusted in 3D.

You can specify whether stepped stem walls 
have vertical footings on the FOUNDATION 
panel of the Foundation Wall Defaults and 
Specification dialogs. You can also specify 
the chamfer width and height of monolithic 
slab foundation footings. 

Stepped stem 
walls with 
vertical footing

Footing resize edit handles on a foundation wall
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Interior Footings
Slab foundations often have interior footings: 
to support posts, for example. You can 
specify that an interior footing be created 
under an interior wall on Floor 1 when the 
foundation is built by checking Create Wall/
Footing Below. See “Foundation Panel” on 
page 317. 

You can also draw them using the Slab 
Footing  tool. See “Foundation Walls” on 
page 269. 

If an interior footing is inside of a room with 
a slab foundation and a curb, as in a garage, 

specify the Slab Footing  as Invisible to 
prevent a curb from generating inside of the 
room. See “Room Dividers and Invisible 
Walls” on page 273.

Thickened Slabs
A thickened slab can be created by selecting 

a Slab Footing  and specifying its Cham-
fer Height to equal the Footing Height. The 
Chamfer Width can be increased, as well. 
• When the Slab Footing is drawn on the 

interior of a slab room, a thickened slab is 
created. 

• When the Slab Footing defines the edge 
of a slab, a thickened slab edge results. 

You can also specify the Chamfer Height 
and Width before the Slab Footings are 
created in the Slab Footing Defaults dialog. 
See “Foundation Panel” on page 317. 

Aligning Foundation Walls
By default, foundation walls and slab 
footings will align with walls on the floor 
above along the outside surface of the Main 
Layer of both wall types. If you prefer, you 
can specify that foundation walls align to a 
different part of the walls above. See “Wall 
Type Definitions” on page 302. 

If there is only one layer for both the stem 
wall and the first floor wall above it, the 
exterior surfaces of the walls align. The 
footing is centered on the stem wall unless 
this option is unchecked in the Wall 
Specification dialog. See “Foundation 
Panel” on page 317.
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Brick Ledges
Brick ledges can be produced in stem wall, 
pier and monolithic slab foundations. The 

method used to produce a brick ledge varies 
depending on the foundation type.  See 
“Brick Ledges” on page 270. 

Deleting Foundations
Select Build> Floor> Delete Foun-
dation to delete the entire foundation 

floor. 

You can also select and delete individual 
foundation walls and slabs by clicking the 

Delete  edit button or pressing the Delete 
key. See “Deleting Objects” on page 255.

Deleting and rebuilding the foundation is 
often the quickest way to update the model 
when substantial changes are made to Floor 1 
after the foundation is built.

Foundations and Rooms
When a foundation plan is created, rooms 
included in the Living Area calculation 
generate a stem wall, grade beam, or slab 
foundation below them. Garage rooms 
generate slab foundations, but exterior rooms 
such as Decks, Courts and Balconies do not 
generate any foundation. See “Room Types” 
on page 335. 

Interior foundation walls are not generated 
unless:
• They separate the area under a Slab or 

Garage room from the rest of the plan;
• They separate the area under a room 

specified as having a slab foundation 
from the rest of the plan; 

• They define areas under rooms with dif-
ferent floor heights.

• A wall on Floor 1 is specified as a Bear-
ing Wall. in the Wall Specification dia-
log. See “Foundation Panel” on page 317.

Garages
When a foundation is generated based on the 
floor plan of Floor 1, a room on the first floor 
specified as either a Garage or Slab type will 
receive a stem wall or pier foundation with a 
slab floor and stem walls. If a monolithic 
slab foundation is generated, the room will 
receive a slab floor with curbs.

An opening placed in a wall defining a 
Garage will receive a cutout in the stem wall 
or curb that displays in floor plan view on the 
floor below provided that the stem wall or 
curb’s Main Layer has a Concrete or Brick 
material type. 

The width of the concrete cutout can be 
defined and you can specify whether the 

Note: To remove all or part of the concrete
slab in the basement area, select a basement
room and define it as Open Below in the
Room Specification dialog.
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cutout displays in the Door or Window 
Specification dialog. See “General Panel” 
on page 375. 

By default, a room on Floor 1 specified as a 
Garage or a Slab will be assigned a lower 
floor height when the foundation is built. The 
amount that it is lowered depends on the 
foundation type:
• The floor height will drop the default 

thickness of the floor platform for Floor 1 
plus 12” (300 mm) in a Walls with Foot-
ings or Grade Beams on Piers foundation.

• The floor height will drop 3 1/2” (88 mm) 
in a Monolithic Slab foundation. 

These values are set in the Foundation 
Defaults dialog. See “Foundation Panel” on 
page 449. 

To build a Garage slab with stem walls

1. Before the foundation is generated, 
specify the room as a Garage or Slab. 

2. Build an automatic Wall with Footings 
or Grade Beamon Piers foundation.

In the Floor 1 Garage’s Room Specification 
dialog, Floor Supplied by the Foundation 
Room Below will now be checked. See 
“Structure Panel” on page 352.

By default, the program produces a  4" (100 
mm) slab and 24” (600 mm) high stem walls 
around the garage. These stem walls are 
drawn on Floor 0 and will indicate the 
locations of any doors that extend into them. 

To build a Garage slab with curbs

1. Before the foundation is generated, 
specify the room as a Garage or Slab. 

2. Build an automatic Monolithic Slab 
foundation, specifying the required 
Lower Garage Floor value.

By default, the program produces a  4" (100 
mm) slab and 3 1/2” (88 mm) high curb 
around the garage. The curbs are drawn 
using Slab Footings on Floor 0, use the 
Default Foundation Wall type, and will 
indicate the locations of any doors that 
extend into them. 

The floor height of the garage and the stem 
wall or curb height can then be adjusted, if 
necessary, in the Garage room’s Room 
Specification dialog. See “Structure Panel” 
on page 352. 

Basement Rooms
When a foundation’s type is Walls with 
Footings or Grade Beams on Piers, and it is 
assigned a Minimum Wall Height of 76” 
(1900 mm) or greater, the resulting basement 
is automatically created with a 4” (100 mm) 
concrete slab floor. and a default Floor Finish 
like that on Floor 1. 

Similarly, if a foundation is set up to have a 
Basement Ceiling Height of 72” (1800 mm) 
or greater when built, it is automatically 
given a painted drywall Ceiling Finish. See 
“Foundation Panel” on page 449.

Regardless of its ceiling height, however, 
you can specify a floor or ceiling finish for 
any room in the Room Specification dialog. 
See “Structure Panel” on page 352.

The resulting basement can be divided into 

separate rooms using Interior Walls  or 
any wall type you wish. If the rooms in a 
basement have different floor heights, it is 
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best to separate them using walls specified as 

Foundation Walls .

Foundations and the Terrain
Chief Architect automatically raises the 
structure in a plan a set distance above the 
terrain. See “Terrain Height vs Floor Height” 
on page 717. 

In a plan with a foundation present, the 
terrain will be: 
• 6” (187 mm) below the top of the stem 

walls or grade beams in a Walls with 
Footings or Grade Beams on Piers foun-
dation. 

• 8” (200 mm) below the top of the slab in 
a Monolithic Slab foundation. 

By default, the program will also create a 
flattened pad under the building footprint.

Not all foundations have these requirements, 
of course, so you can customize your 
foundation and terrain to suit your needs.

Daylight Basements
Daylight basements, also referred to as look-
out basements, have walls that are tall 
enough for basement windows to be 
positioned above the terrain. They are often 
found in split level or split entry structures.

To create a daylight basement condition,  
build a stem wall foundation and modify 
these settings in the Terrain Specification 
dialog: 
• Uncheck Auto Calculate Elevation.
• Increase the Building Pad Elevation, 

which is the distance between the default 
floor height of Floor 1 and the terrain. 

Walkout Basements
Walkout basements are a type of daylight 
basement typically located on sloped terrain. 
They feature walls that are above ground at 
the lower end of the slope so that a door can 
be positioned above the terrain at that end. 

To create a walkout basement, build a stem 
wall foundation and modify these settings in 
the Terrain Specification dialog: 
• Uncheck Flatten Pad.
• Uncheck Auto Calculate Elevation.

You will also need to create sloped terrain 
and adjust the Building Pad Elevation and/
or terrain data so that the terrain is at the 
appropriate height relative to the structure at 
both the high and low ends of the slope.

Floor platform

Stem Wall Top

Terrain
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Stepped Foundations
Stepped foundations are usually built on 
sloping terrain. A stepped foundation will be 
produced automatically if more than one 
floor height is present on Floor 1 when the 
foundation is built. 

In floor plan view, steps in stem wall and 
monolithic slab foundations are represented 
using S markers. See “Displaying 
Foundations” on page 454.

As with a walkout basement, you will need 
to build a stem wall foundation and modify 

these settings in the Terrain Specification 
dialog: 
• Uncheck Flatten Pad.
• Uncheck Auto Calculate Elevation.

You will also need to create sloped terrain 
and adjust the Building Pad Elevation and/
or terrain data so that the terrain is at the 
appropriate height relative to the structure at 
both the high and low ends of the slope.

You can also create a stepped foundation by 
editing foundation rooms and walls. See 
“Stem Wall Height” on page 456.

The Slab Tools
Select Build> Slab to access the Slab 
Tools. The Slab Tools are designed for 

more generic purposes than foundations and 
should not be substituted for a foundation 
plan. The settings in the Foundation 
Defaults dialog do not affect slabs created 
with the Slab Tools.

Slabs
Select Build> Slab> Slab or 
Slab With Footing, then either 

click or click and drag a rectangle to draw a 
slab. See “Rectangular Polyline” on page 
1101.

Once created, slabs can be edited like other 
closed polylines. See “Editing Closed-
Polyline Based Objects” on page 201.

A Slab is also created when the Post with 
Footing  tool is used. See “Post with 
Footing” on page 583. 

Slab Holes
A hole can be placed in a slab or 
in the floor of a foundation slab 

with footings. Select Build> Slab> Slab 
Hole or Build> Slab> Slab Hole With 
Footing, then either click or click and drag 
within an existing slab to create a hole.

You can also create a Slab Hole in a Slab, or 
a Slab Hole with Footing in a Slab with 

Footing, using the Create Hole  edit tool. 
See “Polyline Holes” on page 206. 

Piers and Pads
Piers and pads can be manually 
placed under walls, railings, or 

beams on any floor. Select Build> Slab> 
Round Pier or Build> Slab> Square Pad 
and click in floor plan view to place a pier or 
pad. 

For information about editing Piers and Pads, 
see “Editing Piers and Pads” on page 465.
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Slabs and the Materials List
If the slab material type is specified as 
Concrete or Volume, the materials list  

calculates the total volume of the slab and all 
footings. See “Define Material Dialog” on 
page 864.

Editing Slabs
Slabs and Slab Holes can be selected in 2D 
and 3D views both individually and as a 
group and can be edited using the edit 
handles, the edit toolbar and the Slab 
Specification dialog. See “Slab 
Specification Dialog” on page 463.

Using the Mouse
Slabs and Slab Holes can be edited like other 
closed-polyline base objects in both 2D and 

3D views. See “Editing Closed-Polyline 
Based Objects” on page 201. 

Using the Edit Tools
One or more selected Slabs or Slab Holes can 
be edited in a variety of ways using the 
buttons on the edit toolbar. As with most 
objects, Slabs can be copied, replicated, 
moved, deleted, etc. See “The Edit Toolbar” 
on page 37. 

Slab Specification Dialog
Select a Slab and click the Open 
Object edit button to open the Slab 

Specification dialog.
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General Panel

Specify the characteristics of the 
selected Slab. 

• Check Hole in Slab to convert the 
selected slab into a slab hole. A slab hole 
must be contained within a larger slab. 
See “Slab Holes” on page 462.

• Specify the Thickness, which is the mea-
surement from the slab’s top to bottom 
surfaces.

• Select the Elevation Reference, from the 
drop-down list. This determines where 
the next two settings are measured from 
and also affects their setting labels. 

• Specify the slab’s height to Top, which is 
of its top surface measured from the 
selected Elevation Reference. 

• Specify the slab’s height to Bottom, 
which is the height of its bottom surface, 
measured from the Elevation Reference. 

• When the selected slab is a Post Footing 
or Deck Post Footing, specify whether it 
is Square or Round. Not available for 
manually drawn slabs or if the slab’s 
shape has been modified using the 

Change Line/Arc  edit tool. See 
“Post with Footing” on page 583. 

Specify the characteristics of the 
selected slab’s Footing. 

• Check Has Footing if you would like the 
slab to have a footing around the inside of 
its perimeter.

• Specify the Height and Width for the 
footing.

• Specify the Footing Offset, which is the 
distance that the footing extends out past 
the edges of the slab. A value of 0 aligns 
the outside of the footing with the outside 
of the slab. 

1

2
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Polyline Panel
The POLYLINE panel states the length of the 
selected slab’s Perimeter, its enclosed Area, 
and its Volume See “Polyline Panel” on page 
1098.

If the selected Slab has any Holes in it, they 
will be subtracted from the Area and 
Volume values. See “Slab Holes” on page 
462.

Selected Line Panel
The SELECTED LINE panel is available when 
the selected edge is a line as opposed to an 
arc. For information about the settings on 
this panel, see “Polyline Specification 
Dialog” on page 1098.

Selected Arc Panel
The SELECTED LINE panel is available when 
the selected edge is an arc as opposed to a 
line. See “Change Line/Arc” on page 232.

Line Style Panel
For information about the settings on this 
panel, see “Line Specification Dialog” on 
page 1084.

Fill Style Panel
The settings on the FILL STYLE panel affect 
the selected slab’s appearance in floor plan 
view. For information about these settings, 
see “Fill Style Panel” on page 1099.

Materials Panel
For information about the settings on this 
panel, see “Materials Panel” on page 852.

Label Panel
Slab labels display in floor plan and cross 
section/elevation views when the “Polylines 
3D, Labels” layer is turned on and use the 
Text Style assigned to that layer. The 
Automatic Label for slabs is blank, but you 
can specify a custom label.

For information about the settings on this 
panel, see “Label Panel” on page 1280.  

Editing Piers and Pads
Round Piers and Square Pads can be selected 
individually and in groups in 2D and 3D 
views  and edited using their edit handles and 
edit toolbars. 

There are several ways to move piers and 
pads; however, they must always be 
positioned under a wall. A pier or pad can 
only be moved away from the wall it is 
placed beneath if it is moved to another wall.

Using the Mouse
In floor plan view, piers and pads can be 
edited like CAD lines. Three edit handles 
allow the pier or pad to be resized and moved 
along the wall it is placed beneath. See 
“Editing Line Based Objects” on page 187. 

In 3D views, piers and pads can be edited 
like CAD boxes. See “Editing Box-Based 
Objects” on page 206. 
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Using Dimensions
In floor plan view, piers and pads can also be 
moved using dimensions. See “Moving 
Objects Using Dimensions” on page 1019.

Using the Edit Tools
A selected pier or pad can be edited in a 
variety of ways using the buttons on the edit 
toolbar. As with most objects, piers and pads 
can be replicated, moved, deleted, etc. See 
“The Edit Toolbar” on page 37. 

Pier/Pad Specification Dialog
Select a Round Pier or Square Pad and 
click the Open Object edit button to 

open the Pier/Pad Specification dialog.

General Panel

Type - Specify whether the selected 
object is a Round Pier or Square Pad. 

Specify the Size and Position of the 
selected pier or pad.

• Specify the Top Height and Bottom 
Height, as measured from zero.

• Specify the selected pier or pad’s Width.

Layer Panel
For information about the settings on this 
panel, see “Layer Panel” on page 154.

Fill Style Panel
The settings on the FILL STYLE panel affect 
the selected pier or pad’s appearance in floor 
plan view. For information about these 
settings, see “Fill Style Panel” on page 1099.

If you move a foundation wall or beam,
any piers or pads it contains move with

it.

1

2
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Materials Panel
For information about the settings on this 
panel, see “Materials Panel” on page 852.

Fireplaces
A masonry fireplace can be placed in 
or away from a wall by selecting 

Build> Fireplace and then clicking in the 
drawing area. 
• If created in a wall, it is considered a wall 

opening and can be moved or resized like 
a window or door. 

• If created away from a wall, it moves and 
resizes similar to a cabinet.

A selection of prefabricated metal fireplaces 
is also available from the Architectural Core 
Catalog. These can be framed in with 
standard walls. See “The Library” on page 
819.

The display of fireplaces is controlled in the 
Layer Display Options dialog. See “Layer 
Display Options Dialog” on page 149.

Fireplaces are edited, moved, resized, and 
deleted similar other objects. See “Editing 
Objects” on page 177. 

Built into a Wall
To place a masonry fireplace in a wall, select 

Build> Fireplace  and click on a wall. A 
fireplace is created with the outside of the 
fireplace flush with the outside of the wall.

Fireplaces cannot be placed in a wall 
specified as Invisible or if the wall in 
question is on a locked layer. See “Locking 
Layers” on page 145.

Select the fireplace to display four edit 
handles located along the wall.

Click the diamond-shaped Depth handle and 
drag toward the outside of the wall. The 
fireplace will stop when the firebox front is 
flush with the inside edge of the wall.

In 3D views, fireplaces placed in walls 
display five edit handles: a Resize handle 
along each edge and a Move handle at the 
center. 

Fireplaces always face the interior when 
placed on an exterior wall. When placing a 
fireplace in an interior wall, click on the edge 
of the wall that you want the fireplace to 
face. The fireplace is created with the firebox 
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on the same side as the wall edge you clicked 
on to create it. 

Freestanding
To place a free-standing masonry fireplace, 

select Build> Fireplace  and click in an 
open area away from a wall.

Unlike fireplaces placed in walls, free-
standing fireplace have ten edit handles when 
selected and may be rotated, resized, or 
moved in any direction, similar to the way 
CAD boxes can. See “Editing Box-Based 
Objects” on page 206.

Free-standing fireplaces can be selected and 
replaced with a symbol from the library by 

clicking the Replace From Library  edit 
button. See “Replace From Library” on page 
839. 

Fireplace Foundations
When a Walls with Footings or Grade Beams 
on Piers foundation is built, a fireplace 
foundation will be generated under any Fire-
places  present on Floor 1. See “Building 
a Foundation” on page 452. 

Fireplace foundations are the same material 
type as the original fireplace, but do not have 
a firebox or a hearth. Fireplace foundations 
can be edited or deleted as needed. A firebox 
and hearth can be added in the Fireplace 
Specification dialog. 

Fireplace Specification Dialog
Select a masonry fireplace and click 
the Open Object edit button to 

display the Fireplace Specification dialog. 
Multiple fireplaces can be group-selected, 

but all objects in selection group must be 
either placed in a wall or free-standing. 

Dimensions in this dialog here must be 
entered in whole inches. Fractions and 
decimals are not accepted.



Fireplace Specification Dialog

 469

General Panel

Specify the Size and Position of the 
selected fireplace and its hearth. 

• Specify the Height, Width, and Depth of 
the fireplace.

• Specify the Hearth Depth. This is mea-
sured from the front of the fireplace out 
into the room. To eliminate the hearth 
altogether, enter a zero for this value.

• Specify the Hearth Height, relative to 
the floor in the room that the fireplace 
faces.

• Select the Elevation Reference from the 
drop-down list. This determines where 
the next two settings are measured from 
and also affects their setting labels.

• Specify the height to Top, measured from 
the selected Elevation Reference. 

• Specify the height to Bottom, measured 
from the selected Elevation Reference.

Add for Rough Opening - Specify the 
amount to add to Each Side, the Top 

and the Bottom for the fireplace’s framed 
rough opening. Only available for a fireplace 
placed in a wall, Each Side and Top are set 
to 2” (50 mm) by default. 

If the Bottom Rough Opening value exceeds 
the fireplace’s distance to the floor, the 
difference is added to the top when wall 
framing is built. See “Framing” on page 577. 

Plan Display - Check Suppress 
Dimensions to turn off the display of 

the selected fireplace’s width and firebox 
width dimensions in floor plan view. 

1

2

3



470

Chief Architect X8 Reference Manual

The preview of the fireplace updates as 
changes are made. See “Dialog Preview 

Panes” on page 41. 

Firebox Panel

Check No Firebox to eliminate the 
firebox from the fireplace. This is 

checked by default for a fireplace object 
generated on Floor 0 to serve as a solid 
matching base for a fireplace on Floor 1.

Define the Size of the selected 
fireplace’s firebox.

• Specify the firebox’s Height and Width.
• Specify the Depth of the firebox.

Define the firebox Offset, measured 
from the center of the fireplace. 

• Enter the offset Distance, which is how 
far the firebox is offset from the fireplace 
center. A value of 0 centers the firebox in 
the fireplace. 

• Offset to Left/Right - Choose to offset 
the firebox to the left or to the right. 

The preview of the fireplace updates as 
changes are made. See “Dialog Preview 

Panes” on page 41. 

Layer Panel
For information about the settings on this 
panel, see “Layer Panel” on page 154.

Materials Panel
For information about the settings on this 
panel, see “Materials Panel” on page 852.

4

1

2
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Library Fireplaces
A variety of different fireplace symbols are 
available in library. The fireplace symbols in 
the Library behave just like other Library 
objects.  See “The Library” on page 819. 

Placing a Library Fireplace
A variety of fireplace symbols are available 
in the library. See “Placing Library Objects” 
on page 836.

Flush fireplaces are designed to snap to wall 
surfaces. 

Some fireplace symbols can be enclosed by 
walls or positioned to project through a wall.

Chimneys
Chimneys can be created using a variety of 
methods. 

Masonry Fireplace Chimneys

To create a chimney on a masonry fireplace

1. Select the fireplace in a 3D view. 
2. Ctrl + drag the top edge of the chimney 

upward through all the floors and the 
roof until it is to the desired height. See 
“Unrestricted Movement” on page 221.

3. When the chimney is approximately the 
correct height, select the fireplace, click 

the Open Object  edit button, and 
type in the exact height.

Chimney Chases and Caps
There are two ways to draw a chimney chase: 
• Place a 3D Box, closed box Geometric 

Shape, or Soffit over the chimney chase, 
resize it to match, then increase its height 
either in its specification dialog or in a 
3D view using the same method as 
extending a masonry fireplace. 

• Use walls to define the chimney chase as 
a room area, making sure these walls are 
aligned between floors. The chimney 

Always check the manufacturer’s prod-
uct information for the framing and

clearance requirements of the fireplace unit
you plan to use, and design your plan
accordingly

Open Front fireplace projecting through a wall
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chase “room” on the uppermost floor 
should have a much higher ceiling than 
the other rooms on that floor and should 
also have no ceiling or roof. See “Room 
Specification Dialog” on page 350.

A selection of chimney tops is available in 
the library. In addition, custom chimney caps 
can be made using polyline solids or other 
primitive objects, Geometric Shapes, and/or 
Soffits. See “Other Objects” on page 777.
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Chapter 14:

Roofs

Chief Architect’s manual and automatic Roof 
Tools allow you to draw almost any roof 
style. 

Proficiency with the Roof Tools can only be 
attained through practice, but mastering 
these tools saves you time and effort in plan 
development. For information about creating 
specific roof styles, see “Roof Tutorial” on 
page 63 of the User’s Guide.

Chapter Contents
•      Automatic vs. Manual Roofs
•      Roof Defaults
•      The Roof Tools
•      Automatic Roofs
•      Build Roof Dialog
•      Roof Planes
•      Displaying Roofs
•      Editing Roof and Ceiling Planes
•      Roof Plane Specification Dialog
•      Roof Baseline Polylines
•      Roof Baseline Specification Dialog
•      Roof and Ceiling Framing
•      Curved Roof Planes
•      Ceiling Planes
•      Ceiling Plane Specification Dialog
•      Gable/Roof Lines
•      Skylights and Roof Holes
•      Roof Hole/Skylight Specification Dialog
•      Dormers and Crickets
•      Editing Auto Dormers
•      Dormer Specification Dialog
•      Roof Returns and Other Details
•      Roof Pitches in Degrees

Verify that all roof planes join as
intended. The program does not con-

firm correct geometry between manually
designed or edited roof planes. It is possible
to design and edit roof planes with hips and
valleys that do not meet properly. 
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Automatic vs. Manual Roofs
Chief Architect can create just about any roof 
style. Most common roof styles such as hips 
and gables can easily be generated 
automatically. See “Roof Tutorial” on page 
63 of the User’s Guide. 

More complex roof styles, including curved 
roof planes, can be created manually. The 
manual roof tools allow you to create any 
roof system that can be represented using 
roof planes.

Automatically 
Generated Roofs

The quickest and easiest way to create a roof 
over a structure is automatically. By default, 
a roof plane is generated over each exterior 
wall, creating a hip roof. The program 
automatically joins the roof planes at ridges, 
hips, and valleys and tries to create roof 
planes that join together to form a single, 
integrated system. See “Automatic Roofs” 
on page 477.

Any deviations from the default hip roof can 
be specified on the ROOF panel of the Wall 
Specification dialog for any exterior wall. 
Here, you can specify a Full Gable Wall, 
High/Shed Gable Wall, or other options 
instead of a default hip roof. You can also 
specify a different overhang, pitch, an upper 
pitch, and the elevation where the upper 
pitch begins for the roof plane that rests on 
the selected wall. See “Roof Directives in 
Walls” on page 295.

When you need the roof planes over an area 
of a plan to be entirely separate from those 
over the rest of the structure, you can assign 

those areas to a non-default Roof Group. See 
“Roof Groups” on page 477.

Roofs can also be automatically generated 
based on a Roof Baseline Polyline. When a 
Roof Baseline Polyline is used, information 
that determines where and how roof planes 
are generated is contained in the Roof 
Baseline Specification dialog. See “Roof 
Baseline Polylines” on page 504.

Bay, bow, and box windows also produce 
roof planes automatically. For information 
about these windows and the roof styles that 
can be used with them, see “Bay, Box, Bow 
Windows and Roofs” on page 427.

Manually Drawn Roofs
Any roof system that can be created 
automatically can also be created manually. 
Each roof plane is drawn and edited 
individually, offering full control over the 
process and limiting the possibilities only to 
your imagination. 

Using Both Techniques
Another useful option is to start with an 
automatically generated roof and use manual 
design techniques to finish it. Using both 
automatic roof generation and the manual 
roof drawing and editing techniques, you can 
quickly design highly customized roof 
systems. 

Note: You cannot manually draw or edit roof
planes when Auto Rebuild Roofs is enabled
in the Build Roof dialog. See “Roof Panel” on
page 481.
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Roof Defaults
Select Edit> Default Settings, to 
open the Default Settings dialog for a 

variety of drawing tools, several of which 
directly affect roof generation. 

Roof Defaults Dialog
The Build Roof and Roof Defaults dialogs 
are nearly identical in appearance and 
function. The only difference is that the 
Build Roof dialog has a number of 
checkboxes that allow you to automatically 
generate roof planes and related objects. See 
“Build Roof Dialog” on page 480.

If changes are made to the settings in this 
dialog after the roof has been built, you will 
need to rebuild the roof in order for your 
changes to take effect. 

Roof Framing Defaults
Default settings for framing can be specified 
in either the Build Roof, Framing Defaults, 
or the Framing Defaults dialog. Framing 
defaults control the depth of roof planes as 
well as the depth of floor and ceiling 
platforms, which influence roof plane 
heights. See “Framing Defaults” on page 
578.

To create roof planes of a particular depth, 
begin by setting up the desired roof framing 
defaults, then build the roof. If you later need 
to change the structure of the roof planes, 
make the needed change to the Framing 
Defaults, and then rebuild the roof. You can 
also edit the structure of individual roof 
planes.

Floor and Ceiling Heights
The initial heights of floors and ceilings, 
which influence roof heights, are specified in 
the Floor Defaults dialog for each floor. See 
“Floor Defaults Dialog” on page 436.

The floor and ceiling heights in individual 
rooms also influence roof heights and are 
specified in the Room Specification dialog. 
See “Structure Panel” on page 352.

Wall Specification Dialog
By default, when an automatic roof is built, a 
roof plane is generated over each exterior 
wall, creating a hip roof. 

Any deviations from this default hip roof, 
such as a gable or a different pitch, can be 
specified in the Wall Specification dialog for 
any exterior wall. See “Roof Panel” on page 
314. 

Dormer Defaults
The settings in the Dormer Defaults dialog 
determine the initial settings for automatic 
dormers and are much like those in the 
Dormer Specification dialog. See “Dormer 
Specification Dialog” on page 524.

The Dormer Defaults dialog can be opened 
from the Default Settings dialog or by 

If Auto Rebuild Roofs is checked in the
Build Roof dialog and you change floor

or ceiling heights, floor or ceiling platform
depths, wall positions or roof directives in
walls, the roof rebuilds to reflect your
changes. See “Rebuilding Roofs” on page
479.
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double-clicking either of the Auto 
Dormer  tools. 

The Roof Tools
Select Build> Roof to access the Roof 
Tools. 

Build Roof
Select Build> Roof> Build Roof to 
open the Build Roof dialog, specify 

the settings for automatically generated and 
manually drawn roof planes as well as 
manually drawn ceiling planes, and build or 
rebuild a roof. See “Build Roof Dialog” on 
page 480.

When roofs are automatically generated, a 
roof plane is created over each exterior wall 
by default, resulting in a hip roof, and the 
program tries to join them together to form a 
single, integrated system.

To automatically generate a roof plane using 
values other than the defaults or to not 
generate a roof plane bearing on a particular 
wall (as with a gable or the sides of a shed 
roof), you can change the settings in the Wall 
Specification dialog. See “Roof Panel” on 
page 314.

For more information about creating 
different roof styles, see “Roof Tutorial” on 
page 63 of the User’s Guide. 

Roof Plane
Select Build> Roof> Roof Plane to 
draw a roof plane manually. See 

“Roof Planes” on page 488. You can also 
double-click the Roof Plane button to open 
the Build Roof dialog.

Ceiling Plane
Select Build> Roof> Ceiling Plane to 
draw a ceiling plane manually. Ceiling 

planes are drawn and behave much like roof 
planes. See “Ceiling Planes” on page 511.

Gable/Roof Line
Select Build> Roof> Gable/Roof 
Line to draw a gable line that 

generates a gable along a baseline edge when 
roofs are automatically generated. See 
“Gable/Roof Lines” on page 515.

Skylight
Select Build> Roof> Skylight, then 
draw a rectangle over an existing roof 

plane to create a skylight. The skylight, sky-
light shaft, and ceiling hole (if a ceiling 
exists) are drawn at the same time. See 
“Skylights and Roof Holes” on page 518.

Auto Floating Dormer
Select Build> Roof> Auto Floating 
Dormer and click within an existing 

roof plane to place an auto floating dormer. 
See “Dormers and Crickets” on page 521.

Note: You cannot use the Roof Plane tool
when Auto Rebuild Roofs is enabled in the
Build Roof dialog. See “Manually Drawn
Roofs” on page 474.
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Auto Dormer
Select Build> Roof> Auto Dormer 
and click within a roof plane to place a 

dormer. See “Dormers and Crickets” on page 
521.

Edit All Roof Planes
Select Build> Roof> Edit All Roof 
Planes to open the Roof Plane 

Specification dialog and edit all roof planes 
in the entire plan at once. See “Roof Plane 
Specification Dialog” on page 498.

Delete Roof Planes
Select Build> Roof> Delete Roof 
Planes to delete all roof planes in the 

plan. See “Deleting Roof Planes” on page 
498.

Delete Ceiling Planes
Select Build> Roof> Delete Ceiling 
Planes to delete all manually drawn 

ceiling planes in the plan. See “Ceiling 
Planes” on page 511.

Fix Roofs
Select Build> Roof> Fix Roofs to 
remove breaks where a single edge of 

one roof plane meets the broken edge of 
another along a ridge, hip or valley. Fix 
Roofs does not affect eave edges. See 
“Aligning Roof Edges” on page 493.

Automatic Roofs
When roofs are automatically generated, a 
roof plane is created over each exterior wall 
by default, resulting in a hip roof, and the 
program tries to join them together to form a 
single, integrated system.

There are a number of options available to 
produce variations in this default roof style. 

Roof Directives in Walls
To automatically generate a roof plane using 
values other than the defaults or to not 
generate a roof plane bearing on a particular 
wall (as with a gable or the sides of a shed 
roof), you can change the settings in the Wall 
Specification dialog for that wall. See “Roof 
Panel” on page 314.

For more information about creating 
different roof styles, see “Roof Tutorial” on 
page 63 of the User’s Guide. 

Roof Groups
When an automatic roof is generated, the 
program tries to create roof planes that join 
together to form a single, integrated system. 
Different parts of the structure influence how 
the roof is generated over the whole. 

When you need the roof planes over an area 
of a plan to be entirely separate from those 
over the rest of the structure, you can assign 
those areas to a non-default Roof Group. The 
program treats different Roof Groups as 
separate buildings for the purpose of 
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automatic roof generation, preventing their 
roofs from influencing one another. 

Bear in mind that the use of Roof Groups 
typically involves using a combination of 
both automatic roof generation and manual 
roof editing, and that changes to Attic walls 

may also be necessary. See “Using Both 
Techniques” on page 474. 

Roof Groups are assigned using numbers. 
The Default Roof Group is always 0, and you 
can assign rooms to other roof groups in the 
Room Specification dialog. See “General 
Panel” on page 351.

Curved Walls and Roofs
Automatically generated roof planes are 
placed over curved walls at specified 
increments. In the Build Roof dialog, you 
can specify the degree increments for the 
roof over curved walls, from 6° to 90°. The 

lower the number, the more roof sections are 
created over the curved wall. 

The following  illustrations show a roof 
created at two different curved increments: 
30° and 15°.

Concave Curved Walls and Roofs
Regular roof plane sections can also generate 
over concave curved walls. For roof sections 
to generate over a concave curved wall, the 
sections’ baselines must be longer than the 
Minimum Alcove Size value on the BUILD 
panel of the Build Roof dialog.

If the baselines are shorter, the automatically 
generated roofs are simplified by either: 
• Ignoring the curved wall, as if the walls 

on either side extended to their meeting 
point.
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• Spanning the concave curved wall with a 
straight Baseline and produce a roof plane 
for it from that.

Rebuilding Roofs
By default, when changes are made to the 
model, the roof does not update to reflect 
these changes. This is the case even if the 
roof was automatically built. 

When Auto Rebuild Roofs is checked in the 
Build Roofs dialog, on the other hand, any 
changes made to the position of an exterior 
wall or to its roof directives will prompt the 

roof to regenerate to reflect these changes. 
See “Roof Panel” on page 481.

Changes made to floor heights,or ceiling 
heights, or floor or ceiling platform 
thicknesses will also cause the roof to be 
automatically rebuilt.

You can also rebuild the roof at any time to 
reflect the current state of the model by 
opening the Build Roof dialog, checking 
Build Roof Planes, and clicking OK.

Manually dawn roof planes are specified as 
such in the Roof Plane Specification dialog. 
If a roof plane was automatically generated, 
it will instead have a Mark as Edited 
checkbox. See “Roof Plane Specification 
Dialog” on page 498.

When the roof is rebuilt using Auto Rebuild 
Roof or Build Roof Planes in the Build 
Roof dialog, all roof planes in the plan, both 
automatically generated and manually 
drawn, are deleted and replaced.
• To preserve any manually drawn roof 

planes, check Retain Manually Drawn 
Roof Planes on the BUILD panel of the 
Build Roof dialog before the roof is 
rebuilt. 

• To preserve any automatically generated 
roof planes that you have edited, check 
Retain Edited Roof Planes on the BUILD 
panel of the Build Roof dialog before the 
roof is rebuilt.

Roof planes cannot be edited or manually 
drawn when Auto Rebuild Roofs is turned 

Note: Under some conditions, when the roof
is rebuilt new roof planes may be generated
in the same location as retained manually
drawn or automatic roof planes. 
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on. If you try to either edit or draw a roof 

plane using the Roof Plane  tool, a 
question message will display.

Build Roof Dialog
The Build Roof dialog is used to 
automatically build or rebuild roof 

planes and generate Roof Baseline Polylines. 
The settings in this dialog act as defaults for 
both manually drawn and automatic roofs. 
See “Roof Defaults” on page 475.

To open the Build Roof dialog, select Build> 
Roof> Build Roof . You can also double-

click the Roof Tools  button or the Roof 
Plane  button to open this dialog.

Roof planes and Roof Baseline Polylines are 
generated based on the positions and roof 
directive settings for each exterior wall in the 
plan. If you make changes to any of these 
walls or to any of the settings in this dialog, 
you will need to build the roof again for them 
to take effect. See “Roof Panel” on page 314. 

Aside from a number of checkboxes on the 
ROOF panel that allow you to automatically 
generate roof planes and related objects, the 
settings in this dialog are also found in the 
Roof Defaults dialog. See “Roof Defaults” 
on page 475. 

The settings in this dialog are similar to those 
found in the Roof Plane Specification 
dialog, but affect all subsequently created 
roof planes rather than one or more selected  
roof planes. See “Roof Plane Specification 
Dialog” on page 498. 

There are eleven panels in the Build Roof 
dialog: 
•      Roof Panel
•      Options Panel
•      Structure Panel
•      Rafter Tails Panel
•      Ridge Caps Panel
•      Gutter Panel
•      Frieze Panel
•      Shadow Boards Panel
•      Arrow Panel
•      Materials Panel
•      Roof Styles Panel
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Roof Panel

The Build options are commands 
related to building and rebuilding roof 

planes. 
• Check Build Roof Planes to build a new 

roof structure over the entire model. 
Unless you specify otherwise, the pro-
gram discards the existing roof planes  
and produces new ones. 

• If you check Auto Rebuild Roofs, the 
program automatically rebuilds the roof  
whenever you make a change that affects 
the generation of roofs, such as changes to 
exterior walls or ceiling heights.

• Check Make Roof Baseline Polylines to 
delete the existing roof and to create Roof 
Baseline Polyline(s) based on the exterior 
wall layout and roof information defined 
in those walls. If checked, Build Roof 

1
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Planes becomes unchecked. See “Roof 
Baseline Polylines” on page 504.

You can also rebuild aspects of the structure 
related to roofs: 
• Check Rebuild Walls/Floors/Ceilings to 

rebuild the walls and floor and ceiling 
platforms of your model before the roof is 
built. It is independent of Build Roof 
Planes and helps ensure that your roof is 
generated based on the most up-to-date 
model. See “Rebuilding Walls, Floors and 
Ceilings” on page 441. 

• Check Build Fascia and Roof Trim to 
regenerate fascia, frieze molding, shadow 
boards and gutters. See “Fascia and 
Shadow Boards” on page 528. You can 
check this box without also rebuilding the 
roof. 

Build Fascia and Roof Trim is invoked 
automatically after you manually edit roof 
planes or draw new roof planes if Auto 
Rebuild Walls/Floors/Ceilings is checked 
in the 3D View Defaults dialog. See “Options 
Panel” on page 893.

Specify how manually drawn or edited roof 
planes are handled when the roof is rebuilt 
automatically. These options are only avail-
able when Build Roof Planes is checked. 
See “Rebuilding Roofs” on page 479. 
• Check Retain Manually Drawn Roof 

Planes to prevent manually drawn roof 
planes from being deleted when roof 
planes are rebuilt. Automatic roof planes 
may be generated in the same location. 

Also available if Make Roof Baseline 
Polylines is checked. 

• Check Retain Edited Automatic Roof 
Planes to prevent automatic roof planes 
that have been manually edited - includ-
ing roof planes over exploded dormers - 
from being deleted when roof planes are 
rebuilt. Also available if Make Roof 
Baseline Polylines is checked.
If a newly generated roof plane is copla-
nar with a retained plane, and the area 
where they overlap is at least half the area 
of either of them, the new roof plane is 
deleted and only the retained plane is 
kept. 

• Check Use Existing Roof Baselines to 
produce a roof plan based on your Roof 
Baseline Polyline(s) instead of the exte-
rior wall layout. 

The Specifications  options are basic 
roof structure settings. 

• Enter a value to describe the Pitch as a 
ratio over 12. For a conversion to degrees, 
see “Roof Pitches in Degrees” on page 
532.

• Check Trusses (no Birdsmouth) if you 
wish to frame the roof using trusses rather 
than rafters. The roof height will be set so 
that the bottom edge of the truss top chord 
is flush with the top of the wall. See 
“Roof Trusses” on page 616.

• If you plan to use both trusses with raf-
ters, leave Trusses (no Birdsmouth) 
unchecked so that the rafters’ depth can 

You can create a custom hotkey for
Build Fascia and Roof Trim. See “Hot-
keys” on page 138. 

Note: Under some conditions, new roof
planes may be generated in the same loca-
tion as manually drawn or automatic roof
planes that have been retained. 

2
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be accomodated. See “Mixing Trusses 
with Stick Framing” on page 622. 

Roof Overhang is measured 
horizontally from the outside Main 

Layer of exterior walls to the end of the top 
of the rafter. It includes fascia and shadow 
boards but not frieze molding or gutters. See 
“The Main Layer” on page 302. 
• Eave is the overhang distance outside of 

bearing walls for roof planes using the 
default Pitch. If a particular roof plane has 
a different Pitch, its overhang will adjust 
to keep its fascia at the same height. Over-
hang may be greater for a shallower pitch, 
lesser for a greater pitch. 

• Gable is the overhang distance at gable 
ends or rake walls. 

The Roof Height options affect the 
heights of roof planes. 

Specify the amount to Raise/Lower From 
Ceiling Height, which controls the height of 
roof planes relative to the ceiling height 
specified for the rooms below. 
• The default value is 0, which creates roof 

planes that bear on the wall top plates at 
the Ceiling Height of the room below.

• Increase this value to raise roof planes so 
they do not bear directly on the wall top 
plates. If roofs are raised sufficiently, 
Attic walls will automatically generate to 
support them. The exact height depends 
on the roof pitch. 

• Decrease this value to drop roof planes 
downward and decrease the height of the 
bearing walls. If roofs are lowered suffi-
ciently, they may extend into rooms, pro-
ducing areas with angled ceilings. 

• Check Ignore Top Floor to ignore the top 
living floor when roof planes are gener-
ated. Roof planes are built on the top 
plates of the walls below the top floor. 

Specify how you would like the eaves of roof 
planes with different pitches to meet. See 
“Aligning Eaves” on page 494.
• Check Same Roof Height at Exterior 

Walls to keep bearing walls the same 
height and change horizontal roof over-
hang distances as needed so that eaves 
meet correctly. When checked, this option 
ignores any overhang values you may 
have entered in the Wall Specification 
dialog. See “Aligning Eaves” on page 
494.

Uncheck this option to raise or lower 
some roof planes relative to the wall’s top 
plate, allowing all horizontal overhangs to 
be the same unless a non-default value 
has been entered in the Wall 
Specification dialog. See “Roof Direc-
tives in Walls” on page 295.

• Check Same Height Eaves to keep the 
eave height for all roof planes the same. 
Roof planes are raised and lowered as 
needed so that eaves meet correctly. 

The eave height used when this box is 
checked is that of a roof plane using the 
default Pitch and Overhang values. When 
this box is checked, all roof planes are 
affected, including those that do not need 
adjustment in order to align with adjacent 

If the roof overhang values are not suffi-
cient to extend past the outer surface of

exterior walls, the walls may not generate
correctly in 3D views. 

3
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planes.

When Same Height Eaves is checked, 
any non-default overhang values speci-
fied in the Wall Specification dialog are 
used. Roof planes are raised or lowered so 
that the eave height is the same, regard-
less of the horizontal overhang.

• Uncheck Allow Low Roof Planes only 
when an upper floor overhangs roof 
planes below. 

Uncheck Automatic Birdsmouth Cut 
to enable the settings below. When 

checked, the birdsmouth is calculated based 
on the pitch and rafter depth and its values 
are listed here for reference. See 
“Birdsmouth Cut” on page 497. 

The Raise Off Plate and Birdsmouth settings 
do not affect the bearing wall heights.
• Enter a positive Raise Off Plate value in 

this field to produce the trusses with an 
energy heel to allow for more insulation. 

• Enter a negative Birdsmouth Cut value 
to control the Birdsmouth Depth. For 
example, for the Birdsmouth Depth of 3”, 
enter -3”. The location of the Baseline 
may change if you use the Raise Off 
Plate setting to specify the birdsmouth 
depth. See “Birdsmouth Cut” on page 
497. 

• Specify the Birdsmouth Seat, which is 
the horizontal depth of the birdsmouth 
cut. If you change this value, the Raise 
Off Plate/Birdsmouth Cut value will 
automatically adjust. 

To control the Birdsmouth Cut, you should 
also check Same Roof Height at Exterior 
Walls, above.
• The Vertical Rafter Depth displays here 

as a reference. It can be changed on the 
STRUCTURE panel. See “Structure Panel” 
on page 487. 

Options - 

• Enter the Segment Angle at Curved 
Wall, which is the angle for roof seg-
ments automatically generated to cover a 
curved wall. A smaller angle produces 
more roof planes. Note that in some 
instances, slightly smaller or larger values 
will be used instead of the specified angle. 

• Specify the Minimum Alcove Size, 
which is the minimum depth and width of 
an alcove in an otherwise straight exterior 
wall. Alcoves with both a depth and width 
less than this value are roofed over, while 
alcoves that are either wider or deeper 
than this value do not receive a roof. 

5
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Roof builds around
   3’ wide alcove

   Roof builds over
2’ 11” wide alcove

Effects of Minimum Alcove Size of 3’ (36”)
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Options Panel

Specify how the roof Eaves are 
configured. 

• Specify how the rafter and truss ends are 
Cut by selecting either Square Cut or 
Plumb Cut. 

• Check Boxed Eave to produce horizontal 
boxed eaves or uncheck it for sloping 
eaves. You can also change this for indi-
vidual roof planes in the Roof Plane 
Specification dialog.

• Higher Eaves Boxed - If the selected 
roof plane contains more than one eave, 
check this box to box the higher eaves as 
well as the lower ones. 

1

With Boxed Eave checked
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• By default, Boxed Eaves extend from the 
inside edge of the roof fascia to the exte-
rior Main Layer of the wall, covering the 
overhang area. If an exterior room with 
Use Soffit Surface for Ceiling checked is 
located between the roof’s baseline and 
an interior room, the Boxed Eave will 
extend across that room, as well. You can 
instead uncheck Default to Overhang 
and specify the Length of the boxed 
eaves. 

Specify where Ceiling Break Lines 
display. See “Special Ceilings” on page 

346. 
• Display At Finish Intersection positions 

ceiling break lines where the ceiling fin-
ish surfaces intersect. 

• Select Display At Framing Intersection 
to position ceiling break lines where the 
ceiling framing surfaces intersect. 

In Chief Architect Interiors, specify how the 
Ceiling surface on the underside of roof 
planes is built. See “Vaulted and Cathedral 
Ceilings” on page 347.
• When Use Room Ceiling Finish is 

checked, the ceiling finish thickness and 
material on the undersides of roof planes 
are defined by the room below. Uncheck 
this box to enable the two settings that 

follow and define the ceiling finish as part 
of the roof planes instead. When this is 
unchecked, you can specify the Ceiling 
Surface material on the Materials Panel. 

• Check Has Ceiling to enable the Ceiling 
Thickness option. When this box is 
unchecked, the selected roof plane will 
have no ceiling surface at all and the 
“Ceiling Surface” component will not be 
available on the MATERIALS panel.

• Specify the Ceiling Thickness, which is 
the thickness of the bottom surface of the 
ceiling plane. 

Specify the material components to 
Supply for subsequently-built roof 

planes. When checked, these items are 
calculated in the Materials List. See 
“Materials Lists” on page 1283. Only Gutter 
is available in the Roof Plane Specification 
dialog. 
• Uncheck Gutter to not include gutters on 

subsequently-built roof planes. This 
option affects both the Materials List and 
3D views.

• Check Edge Flashing to calculate edge 
flashing in the Materials List when one or 
more roof planes is against a wall.

• Check Ridge Vent to calculate ridge vent-
ing in the Materials List.

• Check Metal Drip Edge at Eave to cal-
culate metal drip edge along the eaves in 
the Materials List.

• Check Metal Drip Edge at Gable to cal-
culate metal drip edge along any gable 
eaves in the Materials List.

• Check Valley Flashing to calculate valley 
flashing in the Materials List when two or 
more roof planes form a valley.

With Higher Eaves Boxed checked

2
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3D Display - When Show All Ridges is 
checked, a line along each hip between 

roof planes forming the conical roof above a 
curved wall displays in Vector Views. 
Uncheck this box to suppress these lines. See 
“Rendered and Vector Views” on page 888.

Structure Panel
The settings on the STRUCTURE panel of the 
Build Roof dialog are the the same as those 
on the ROOF panel of the Build Framing 
dialog. Changes made in one dialog are also 
applied in the other. See “Roof Panel” on 
page 595.

Rafter Tails Panel
The settings on the RAFTER TAILS panel 
allow you to specify a rafter tail profile for 
exposed rafter ends under roof eaves. See 
“Rafter Tails” on page 530.

The settings on this panel are like those on 
the MOLDINGS panel found in a variety of 
dialogs in the program. See “Moldings 
Panel” on page 659. 

A few things about the RAFTER TAILS panel 
are unique:
• Only one rafter tail profile can be speci-

fied at a time, so the Add New button is 
only available when no profile is cur-
rently selected.

• Uncheck Stretch to Fit Rafter to use the 
rafter tail profile’s default size or to spec-
ify its Height and Width, below. When 

checked, the profile is sized by the pro-
gram to match the roof rafters.

• Specify the distance that the rafter tail 
profile should Extend past the inside sur-
face of the subfascia. This distance is 
measured along the top of the rafter tail, 
so it is greater than the length as measured 
in floor plan view. 

Ridge Caps Panel
The settings on the RIDGE CAPS panel allow 
you to specify a profile for ridge caps. See 
“Ridge Caps” on page 531. 

The settings on this panel are like those on 
the MOLDINGS panel found in many dialogs 
in the program. See “Moldings Panel” on 
page 659. 

Three settings are unique to the RIDGE CAPS 
panel: 
• Only available in the Roof Plane 

Specification dialog, check No Ridge 
Cap on Selected Edge to suppress the 
generation of a ridge cap on the roof 
plane’s selected edge. See “Selected 
Edge” on page 184. 

• Click the Add Default button to add the 
Default Ridge Cap profile, which has flat 
sides and follows the pitch of each roof 
plane. 

• Check Bend to Roof Pitch to adjust the 
shape of the selected ridge cap profile to 
match the pitch of the roof. 

Gutter Panel
The settings on the GUTTER panel allow you 
to specify a gutter profile for the eaves of 
roof planes. See “Gutters” on page 529. 

Note: Changes made on the Structure panel
will not affect the structure of existing roof
planes. To make changes take effect, rebuild
the roof.

4
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The profile specified here will only be 
generated when Gutters is checked on the 
OPTIONS panel. See “Options Panel” on page 
485.

The settings on this panel are like those on 
the MOLDINGS panel found in many dialogs 
in the program. See “Moldings Panel” on 
page 659. 

Frieze Panel
The settings on the FRIEZE panel allow you 
to specify one or more frieze molding 
profiles to generate under the eaves and/or 
gable overhangs of roof planes. See “Frieze 
Molding” on page 530.

The settings on this panel are like those on 
the MOLDINGS panel found in many dialogs 
in the program. See “Moldings Panel” on 
page 659. 

Shadow Boards Panel
The settings on the SHADOW BOARDS panel 
allow you to specify one or more shadow 
board profiles that follow the fascia on eaves 
and/or gable eaves. See “Shadow Boards” on 
page 528. 

The settings on this panel are like those on 
the MOLDINGS panel found in many dialogs 
in the program. See “Moldings Panel” on 
page 659. 

One setting is unique to the SHADOW 
BOARDS panel in the Roof Plane 
Specification dialog: 
• Check No Shadow Boards on Selected 

Edge to suppress the generation of 
shadow boards on the roof plane’s 
selected edge. See “Selected Edge” on 
page 184. 

Arrow Panel
The settings on this panel allow you to 
control the appearance of roof plane slope 
direction arrows. See “Displaying Roofs” on 
page 491.

For information about these settings, see 
“Arrow Panel” on page 1088.

Materials Panel
The settings on this panel allow you to 
specify materials for the roof’s various 
components that are not specified on the 
STRUCTURE panel. See “Materials Panel” on 
page 852.

Roof Styles Panel
The ROOF STYLES panel provides links to 
tutorial information about creating different 
roof styles automatically. Click on a roof 
style to launch the online Help to a page with 
information about the roof style you selected. 
See “Roof Tutorial” on page 63 of the User’s 
Guide. 

Roof Planes
When creating a roof, it is helpful to know 
how to draw a roof plane manually and be 
familiar with its parts. 
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Drawing Roof Planes
Roof planes are CAD-based objects 
that are created and edited like much 

closed polylines, and also have pitch, 
elevation and structural properties.  

Before drawing roof planes, you should set 
your roof defaults so that the 3D attributes of 
your roof planes are correct. See “Roof 
Defaults” on page 475.

To draw a roof plane

1. Select Build> Roof> Roof Plane . 
2. Click and drag a Baseline from point 1 

to point 2, as in the following example:

3. Release the mouse button at point 2 and 
move your cursor in the upslope direc-
tion. As you move the cursor, a preview 
outline of the roof plane displays.

4. Click at point 3 to build the roof plane. 
Point 3 is located on the ridge edge of 
the roof plane. 

The upslope mark displays at the center 
point of the Baseline and indicates the 
upslope direction of the roof plane. 

The overhang is the distance from the outer 
Main Layer of the wall to the end of the eave.

The Baseline
The pitch direction and initial height of any 
roof plane - manual or automatic - is 
determined by its Baseline.

The Baseline of the roof plane is normally 
located over the outer main layer of the wall 
and is used as the pivot point for the roof 
plane when the pitch is changed.  

The Baseline height is determined by the 
following formula: 

          Elevation of the wall top plate
       + Vertical Rafter Depth
        - Vertical Birdsmouth Depth 
       = Baseline Height
In a cross section, the Baseline is located 
directly above the outer surface of the main 
wall layer, at the top surface of the roof 
framing. 

Most roof planes are drawn over a
wall, and the Baseline should be

located directly above the outer edge of the
wall’s Main Layer. 

Line 1 - 2 is the Baseline

Note: You cannot manually draw roof planes
when Auto Rebuild Roofs is enabled in the
Build Roof dialog. See “Roof Panel” on page
481.
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A roof Baseline displays as a separate line 
within its roof plane when the “Roofs, 
Baselines” layer is turned on. In 3D views, it 
can only be seen if the roof plane is selected. 

A Baseline has a tick mark at its center point 
which indicates the direction that the roof 
plane slopes upward. If the upslope tick is 
pointing the wrong direction, either rotate the 
entire roof plane or delete it and draw a new 
one. 

When drawing the Baseline of a roof plane, 
here are some things to consider:
• A Baseline does not have to be drawn 

over a wall, although it often is.
• A Baseline drawn along a wall should be 

drawn over the outer edge of the wall’s 
main layer. It tries to snap to that layer. 

• The elevation of the top plate is defined 
by the ceiling height in the room. If the 
roof plane is not drawn over a wall, it’s 
height is based on the default ceiling 
height value for the current floor. 

• If a Baseline is drawn over the top of any 
other roof plane, the Baseline height 
equals the height of the existing roof 

plane at the point where you started draw-
ing.

Once drawn, a Baseline can be selected in 
floor plan view and edited independent of the 
roof plane. See “Editing Roof Baselines” on 
page 496. 

Eave and Gable Overhangs
Roof overhangs are measured horizontally 
from the outside Main Layer of exterior 
walls to the end of the top of the rafter. They 
include fascia and shadow boards but not 
frieze molding or gutters. See “The Main 
Layer” on page 302. 

The location of a roof plane’s fascia and 
shadow boards also determines its area and 
the size of its polyline in floor plan view. See 
“Polyline Panel” on page 502.

Roof Layers
Each roof plane is composed of Surface, 
Structure, and Ceiling Finish layers. These 
can be specified in the Build Roof dialog. 
See      Structure Panel. 

Location of Roof Baseline in cross-section

Straight up from outside 
of main wall layer at top 
surface of roof framing

  Roof Overhang measured horizontally from 
the wall’s Main Layer to outside of the fascia
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Displaying Roofs
Roof planes are drawn on the “Roof 
Planes” layer by default, although you 

can place a roof plane on any layer. See 
“Line Style Panel” on page 515. 

You can also choose to display gutters, gable 
lines, the overhang area, Roof Baseline 
Polylines, roof labels, frieze molding, ridge 
caps, shadow boards, valley truss bases and 
roof openings.  See “Layer Display Options 
Dialog” on page 149.

If the “Roof Planes” layer is turned off and 
Auto Rebuld Roofs feature is turned on, 
changes made to the plan that cause the roof 
to rebuild will not automatically turn on the 
display of the roof planes. See “Rebuilding 
Roofs” on page 479.

The appearance of curved roof planes in 3D 
views can be controlled by adjusting the 
Facet Angle in the Roof Plane 
Specification dialog. See “General Panel” 
on page 499.

Roof Plane Labels
Roof plane labels indicating the pitch and 
slope direction are located on the “Roofs, 
Labels” layer and can be set to display in 
floor plan and cross section/elevation views. 

You can specify whether roof plane labels 
display the pitch in terms of rise and run or in 
decimal degrees by checking or unchecking 
Pitch in Degrees in the Roof Plane 
Specification dialog. See “General Panel” 
on page 499.

A roof plane’s label can be customized in its 
specification dialog. See “Label Panel” on 
page 1280. Roof planes have named value 

pairs associated with them, so you can create 
custom labels using Text Macros. See “Text 
Macros” on page 1064.

Manually drawn Ceiling Planes  and 

Skylights  can also display labels when 
the “Roofs, Labels” layer is on. Unlike roof 
planes, these objects’ do not include a slope 
indicator and their Automatic Labels are 
blank; however, you can specify a custom 
label using text in their specification dialogs. 
See “Ceiling Planes” on page 511 and 
“Skylights and Roof Holes” on page 518.

When a roof plane, ceiling plane or roof 
hole/skylight is selected in a 3D view, its 
label will display on a temporary basis if the 
“Roofs, Labels” layer is turned on. 

Display on Floor Above/Below
In floor plan view, roof planes 
can display on any floor without 

affecting their height in 3D. 

To move the display of a roof plane to a new 
floor, select it in floor plan view and click 
either the Display on Floor Above or 
Display on Floor Below edit button. The 
display of group-selected roof planes can 
also be controlled in this manner.

Any skylights or roof holes placed in a roof 
plane moved in this manner will move, as 
well. Other associated objects like Auto 
Dormers or gutters will not move, however.

In Cross Section Views
When a roof or ceiling plane is viewed in a 
cross section, the layers that compose it can 
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be seen, including the roof surface, 
sheathing, and the ceiling surface. 
• If roof framing has been built, its display 

can be turned on, as well. See “Displaying 
Framing” on page 604.

• If a roof or ceiling plane is located over a 
room with Ceiling Over this Room 
checked, the ceiling surface will not gen-
erate. See “Vaulted and Cathedral Ceil-
ings” on page 347.

• The layers of roof and ceiling planes can 

be detailed using the Auto Detail  
tool. See “Auto Detail” on page 905. 

In the Materials List
The materials that make up roof and ceiling 
plane assemblies are listed under different 
Categories in the Materials List: 

• Roofing - Lists most materials associated 
with roofs, including roofing, sheathing, 
rafters and trusses, gutters, and skylights.

• Exterior Trim - Lists automatically gen-
erated frieze molding and shadow boards. 
See “Roof Returns and Other Details” on 
page 527. 

• Insulation - Insulation is calculated for 
roof and ceiling planes above rooms that 
do not have Ceiling Over This Room 
checked. See “Structure Panel” on page 
352. 

• Wallboard - Lists ceiling materials for all 
rooms, including those that use the under-
side of the roof as their ceiling.

• Framing - Lists ceiling framing for man-
ually drawn ceiling planes. 

See “Materials Lists” on page 1283. 

Editing Roof and Ceiling Planes
A selected roof or ceiling plane can be edited 
in 2D and 3D using edit handles, edit toolbar 
buttons, its specification dialog, and the 

Material Painter .

A roof or ceiling plane’s Baseline can also be 
selected and edited. To select it, first select 
the roof plane and then click the Select Next 
Object  edit button. See “The Baseline” 
on page 489. 

By default, all roof planes are deleted and 
replaced whenever the roof is rebuilt using 
the Build Roof dialog. If you have manually 
edited roof planes and do not want them to be 
replaced, be sure to check Retain Edited 
Roof Planes. See “Roof Panel” on page 481.

2D Shape and 3D Orientation
There are two basic aspects to editing roofs: 
2D shape and 3D orientation. 
• The 2D shape of a roof or ceiling plane 

can be edited just like a CAD polyline. As 
a plane is reshaped in 2D, the program 
maintains its height and pitch in 3D. See 
“Editing Closed-Polyline Based Objects” 
on page 201.

• The 3D orientation of a roof or ceiling 
plane is defined by its height and pitch 

Roof planes cannot be edited while
Auto Rebuild Roofs is turned on. If you

try to do so, the program will prompt you to
turn it off.
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and can be edited in its specification dia-
log. See “General Panel” on page 499.  

An understanding of these two concepts  
allows you to design almost any kind of roof.

A roof or ceiling plane’s display and 
appearance can be customized. See 
“Displaying Roofs” on page 491 and “Roof 
Plane Specification Dialog” on page 498.

Adding a Step to an Edge
You can make a step, or jog, in the edge of a 
roof or ceiling plane by selecting it, clicking 

the Break Line  edit button and then 
clicking on the roof edge. See “Break Line” 
on page 231.

Aligning Roof Edges
By default, the edges of a roof plane will 
automatically snap to the outer surface of a 
nearby parallel wall. You can disable this 
Special Snapping behavior for a selected 
roof plane in its specification dialog. See 
“General Panel” on page 499. 

After moving a corner edit handle, it may be 
difficult to make an edge parallel to an eave 
or a wall. Use the Make Parallel/
Perpendicular  edit button to align a roof 

or ceiling plane edge with a wall, another 
roof plane edge, or another object with a 
straight edge. See “Using Make Parallel/
Perpendicular” on page 227. 

Sometimes, what appears to be a single, 
straight roof plane edge may actually be 
broken into two or more edges, which can 
affect your ability to align the edge properly. 

A single edge will have three edit handles; if 
more than three display, more than one edge 
is present. An extra handle can be removed 
removed manually by dragging it into an 
adjacent handle. You can also use Build> 
Roof> Fix Roofs . See “Fix Roofs” on 
page 477.

When Bumping/Pushing  is enabled and 
CAD Stops Move is checked in the Roof 
Plane Specification dialog, a roof plane will 
bump against another roof plane, CAD or 
CAD based object as it is moved. Roof 
planes cannot push these objects, however. 
See “Bumping/Pushing” on page 221. 

Join Roof Planes
Two roof or ceiling planes can be 
joined at adjacent edges in both 2D 

and 3D using the Join Roof Planes edit 
button. To use this tool, first identify which 
edges of the roof planes can extend to meet at 
a ridge, hip, or valley. The program will join 
the two planes along the line where they 
intersect whenever possible. 

If opposite sides of a roof plane are par-
allel, Temporary Dimensions will display

between them when one side is selected.
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To use Join Roof Planes

1. Select a roof or ceiling plane on the edge 
to be joined to another plane.

2. Click the Join Roof Planes  edit but-
ton (or press 2 on the keyboard).

3. Move your pointer to the edge of the 
second roof or ceiling plane that the first 
one needs to join to. When your pointer 
is over the second plane, this plane will 
highlight.

4. Click on the edge of the second roof or 
ceiling plane to join it to the first plane.

If the planes are not close enough, or their 
shape is not correct, you may need to align 
their edges, remove extra edges, or move 
them closer. 

When roof or ceiling planes adjust, the 
program joins them at the proper location 
and the adjacent edges extend or contract to 
remain connected. If the joining of the two 
will completely eliminate or reverse an 
adjacent edge, the connection cannot be 
made. 

Locating Intersections
When roof planes of differing slopes meet, 
they create a ridge, hip, or valley. The Join 
Roof Planes  edit tool is the easiest way 
to move roof plane edges so that they meet 
correctly; but you can also locate roof plane 
intersection points where the ridge, hip or 
valley should be. Once you know where the 

planes will meet, you can drag edges or 
corners to those points.

To find roof plane intersection points

1. Make sure that Automatically Place 
Roof Intersection Points is turned on in 
the Preferences dialog. See “Architec-
tural Panel” on page 108. 

2. Select the roof plane you would like to 
place intersection points on.

3. Click the edge of another roof plane to 
place a temporary CAD Point where it 
would meet the selected roof plane.  

4. Repeat steps 1 and 2 for the ridge edge 
and both fascia edges. You should have 
three points located on the larger roof 
plane: these are the intersection points.

5. Once these intersection points are identi-
fied, you can snap the corners of the sec-
ond roof plane to them.

Aligning Eaves
It is not uncommon for roof plans to feature 
more than one pitch. In order for the eaves of 
roof planes with different pitches to meet 
correctly at ridges and hips, you must control 

Note: Join Roof Planes cannot be used to join
a roof plane and ceiling plane. Only planes of
the same type can be joined using this tool.

roof plane 
intersections 
marked with 
an “X”
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the roof planes’ heights and their horizontal 
overhang distances. Two options in the Build 
Roof dialog allow you to control how the 
eaves of automatically generated roof planes 
align. See “Roof Panel” on page 481.
• Same Roof Height at Exterior Walls 

maintains the default height of roof planes 
where they bear on exterior walls. The 
horizontal overhang distances of any non-
default roof planes are adjusted so that 
they continue to join correctly with 
default roof planes.

• Same Eave Heights maintains the default 
roof plane height at the eaves as well as 
any non-default horizontal overhang dis-
tances . All roof planes are raised or low-
ered so that they all have the same height 
at the eaves as default roof planes. 

Roof planes that do not join other roof planes 
with different pitches at ridges or hips are 
referred to as Independent. 
• When Same Roof Height at Exterior 

Walls is checked, Independent roof 
planes are not affected and will maintain 
any non-default overhang values. 

• When both Same Roof Height at Exte-
rior Walls and Same Eave Heights are 
checked, the overhangs of Independent 
roof planes will be adjusted to preserve 
their heights at both the exterior walls and 
the eaves. 

Move to be Coplanar
The Move to be Coplanar edit button 
allows you to move the selected roof 

plane to be coplanar (in the same plane) with 
the next selected roof plane. You can use this 
tool in both 2D and 3D views. The results 

can be easily seen in a cross section view. 
The two roof planes must have parallel 
Baselines for this to work.

Raising/Lowering Roof Planes
Roof planes can be raised or lowered 
in the Roof Plane Specification 

dialog.  Begin by locking the Pitch, then 
change the value of the Baseline Height. See 
“General Panel” on page 499.

You can also raise or lower roof 
planes in the Transform/Replicate 

Object dialog. See “Transform/Replicate 
Object Dialog” on page 242.

In addition, when a new floor is added to a 
plan, you can choose to move any roof 
planes displaying on the top floor up one 
floor. See “Adding Floors” on page 437. 

Change Roof Pitch or 
Height Dialog

The Change Roof Pitch or Height dialog 
displays when you attempt to snap the corner 
or an edge of a roof plane near the edge of 
another roof plane that does not match 
vertically. This dialog gives you the option to 
move the roof plane vertically, or pivot it 
about a point and change the pitch.

In this case, the current roof plane would 
have to raise its pitch or height in order to 
meet the second roof plane at the corner that 
you moved. 

You can open the specification dialog
for all roof planes in an entire plan by

selecting Build> Roof> Edit All Roof Planes. 
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The amount of vertical displacement 
between the selected roof plane and another 
nearby roof plane is stated at the top left. 
• Click on Pivot About Eave to maintain 

the current eave height and modify the 
baseline and ridge heights and pitch to 
meet the other roof plane. Not available 
when the selected corner is associated 
with the eave edge.

• Click on Pivot About Baseline to main-
tain the current baseline height and mod-
ify the eave and ridge heights and pitch to 
meet the other roof plane. Not available 
when the selected corner is associated 
with the baseline.

• Click on Pivot About Ridge to maintain 
the current ridge top height and modify 
the eave and baseline heights and pitch to 
meet the other roof plane. Not available 
when the selected corner is associated 
with the ridge edge.

• Click on Raise/Lower (no pivot) to 
maintain the current pitch and raise or 
lower the entire plane to connect the 
roofs. This may affect plate heights of the 
walls below.

• Click on None of the Above to close the 
dialog without making any changes to the 
selected roof plane.

To prevent this dialog from displaying, check 
Don’t show again during this session. The 
dialog does not display again until you have 
terminated and restarted the program.

Editing Roof Baselines
The pitch direction and initial height of any 
roof plane - manual or automatic - is 
determined by its Baseline. See “The 
Baseline” on page 489. 

In floor plan view, a Baseline can be selected 
and edited independent of the roof plane. To 
select it, click on the roof plane at the 
location of the Baseline and then click the 

Select Next Object  edit button. The 
Status Bar tells you when the roof plane 
Baseline is selected. See “Select Next 
Object” on page 185.  

If a roof plane Baseline is moved, its height 
will not change. Instead, the height of the 
roof plane will be affected. In most cases, 
therefore, moving a roof plane’s Baseline 
independent of the roof plane itself is not 
recommended. 

If the angle of a roof plane’s Baseline is 
changed, the direction of the roof plane’s 
pitch will be modified. The Baseline Angle 
can be modified in either of two ways: 
• In the Roof Plane Specification dialog. 

This will change its angle relative to the 
floor, and will tilt the roof plane along an 
axis perpendicular to its Baseline. This 
method is helpful when a specific eave 
angle is needed. See “General Panel” on 
page 499.

Unless you have a specific reason to
adjust the roof plane this way, it is usu-
ally best to select None of the Above.
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• Using its Rotate edit handle in floor plan 
view. This will change its angle relative to 
the roof plane’s eave or ridge and will 
modify the direction of the pitch. This 
method is best when the pitch direction 
matters more than the angle of the eave.

• Both of these methods can be used to 
modify the same roof plane, although the 
second approach makes it difficult to con-
trol both the pitch direction and eave 
angle, and is not recomended. 

The length of a roof plane Baseline can be 
lengthened or shortened using its edit 
handles without changing any of the roof 
plane’s attributes. 

Set Baseline Height Dialog
If you manually draw a roof plane so that it 
bears on a wall at its Baseline, and is placed 
in the same location as an existing roof 
plane, the Set Baseline Height dialog will 
display. See “The Baseline” on page 489.

• Select Over Wall Top to create a roof 
plane that bears on the wall it is drawn 
over and has an overhang as specified in 
the Build Roof dialog. This option would 
be appropriate to produce a full height 
dormer. See “Manually Drawn Dormers” 
on page 523.

• Select Over the Existing Roof Plane to 
produce a roof plane with a height based 

on that of the roof plane below it rather 
than the wall. The Baseline height equals 
the top height of the existing roof at the 
point where you began drawing the new 
roof plane Baseline, and has no overhang. 
This option would be appropriate to cre-
ate a dormer vent or cricket. See “Manu-
ally Drawn Crickets” on page 523.

Editing Roof Plane Structure
To create roof planes of a particular depth, 
begin by setting up the desired roof framing 
defaults, then build the roof. See “Framing 
Defaults” on page 578. 

If you later need to change the structure of 
the roof planes, make the needed change to 
the Framing Defaults, and then rebuild the 
roof. You can also edit roof structure on an 
individual roof plane basis. See “Roof Plane 
Specification Dialog” on page 498. 

Birdsmouth Cut
The birdsmouth is the notch cut into a rafter 
where it rests on the wall top plate. You can 
control its vertical depth and the width of the 
birdsmouth seat in the Build Roof dialog. 
See “Roof Panel” on page 481. 

There are two ways to create a roof plane 
with no birdsmouth: 
• Check Trusses (No Birdsmouth) in the 

Build Roof dialog before drawing the 
roof plane.

• Specify a Raise Off Plate value of at least 
1/16” in the Build Roof dialog. 

To change the birdsmouth depth after the 
roof is built, you can move the roof planes up 
or down, or change the pitch. For example, if 
you lock the pitch and raise the roof plane by 
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one inch, you decrease the birdsmouth depth 
by one inch. 

Locking Roof Planes
When the roof plan is correct, roof planes 
can be locked to prevent accidental changes. 
To do this, lock the “Roof Planes” layer in all 
layer sets. See “Layer Display Options 
Dialog” on page 149. 

Locking roof planes will not prevent roof 
planes from being deleted if the floor they 
are on is deleted. 

Deleting Roof Planes
There are several ways to delete roof planes.

Delete the entire roof quickly by 
selecting Build> Roof> Delete Roof 

Planes. 

You can also delete all roof planes at 
once in the Delete Objects dialog. 

See “Delete Objects Dialog” on page 255.

In addition, you can select any roof plane or 
group of roof planes, then press the Delete 

key or click the Delete  edit button to 
delete it from the plan. See “Deleting 
Objects” on page 255.

Generally speaking, roof planes cannot be 
deleted if they are locked. An exception to 
this rule occurs when an entire floor of a plan 
is deleted. Any roof planes present on a floor 
will be deleted when the floor is deleted, 
locked or not. See “Deleting Floors” on page 
441.

When a roof plane is deleted, any roof 
framing associated with it is automatically 
deleted, as well.

Roof Plane Specification Dialog
Select one or more roof planes and 
click the Open Object edit button to 

open the Roof Plane Specification dialog. 

You can also open this dialog for all roof 
planes in the entire plan by selecting Build> 
Roof> Edit All Roof Planes . 
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General Panel

There are four values that define the 3D 
orientation of a roof plane: Ridge/Top 
Height, Baseline Height, Fascia Top 
Height and Pitch.

Locking any of the Height values defines 
that value as the pivot point for the selected 
roof plane. Each of these dimensions is 
measured from the first floor default 
elevation of 0' - 0". 

If you lock the Pitch and change a Height 
value, the roof plane moves vertically, 
keeping the same slope. It will not pivot. For 
a conversion to degrees, see “Roof Pitches in 
Degrees” on page 532.

Changing these values does not affect the 2D 
representation of the roof plane.
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Specify the Height and Pitch of the 
selected roof plane(s). Heights are 

measured from the top surface of the roof 
plane(s) rafters or trusses. See “Roof Planes” 
on page 488.
• Define the Ridge/Top height, or lock this 

value to make it the roof plane’s pivot 
point.

• Define the Baseline height, or lock this 
value to make it the pivot point. 

• Define the Fascia Top height, or lock this 
value to make it the pivot point.

• Define the Shadow Board Top height, or 
lock this value to make it the pivot point. 
Only available when Shadow Boards are 
present on the selected roof plane. See 
“Fascia and Shadow Boards” on page 
528. 

• Specify the Pitch for the selected roof 
plane, or lock this value to move the roof 
plane vertically when a Height value is 
changed. 

• Check Pitch in Degrees to display the 
pitch value in this dialog in degrees in this 

dialog and in roof plane labels. Values 
between -89° and 89° can be entered. 
When Pitch in Degrees in unchecked, 
Pitch is described in terms of rise and run: 
x inches in 12 in Imperial plans and x mm 
in 1000 in metric plans.

Measurements - Information about the 
structure of the selected roof plane(s) 

displays here, mostly for reference.
• Specify the Rafter Depth for the selected 

roof plane. The default rafter depth is set 
in the Build Framing dialog. See “Build 
Framing Dialog” on page 586. 

• The Birdsmouth Depth is the plumb or 
vertical depth of the birdsmouth cut. To 
change it, move the roof plane some way. 
For example, if you lock the pitch and 
raise the roof plane by one inch, you will 
decrease the birdsmouth depth by one 
inch. See “Birdsmouth Cut” on page 497.

• The Birdsmouth Seat is the horizontal 
width of the birdsmouth cut. This value is 
dynamically linked to the birdsmouth 
depth - if one changes, so does the other.

• The Vertical Rafter Depth is defined by 
measuring a plumb line across the rafter. 
The degree of pitch affects the Vertical 
rafter width. The greater the pitch, the 
greater the vertical rafter depth.

Note: The Fascia Top height will decrease
slightly if the fascia edge is aligned with the
ridge top of another roof plane. 

1

2
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• Top of Plate is defined by the ceiling 
height of the room below. If no room is 
below the roof plane, this value is 0.

• Overhang from Baseline is the horizon-
tal overhang measured from the Baseline 
to the eave.

• Mark as Edited - When an automatically 
generated roof plane is modified, the pro-
gram marks it as "edited", giving you the 
option of retaining it when the roof is 
rebuilt. Uncheck this box to remove this 
status from the selected roof plane. See 
“Rebuilding Roofs” on page 479.

• Mark as Edited is only available for 
automatically generated roof planes. If a 
manually drawn roof plane is selected, the 
words Manual Roof Plane will display 
here instead.

• Check No Special Snapping to prevent 
the selected roof plane from snapping to 
the outer surface of any walls that it may 
butt against. When this box is unchecked, 
the roof plane’s edges will automatically 
snap to the outside of any nearby parallel 
walls. 

Check Curved Roof to specify the 
selected roof plane as curved. See 

“Curved Roof Planes” on page 508.
• Specify the roof plane’s Angle at Eave, 

Angle at Ridge and Radius to Roof Sur-
face.

• These three values are interrelated - when 
one is changed, the other two adjust 
accordingly. You may find it helpful to 
first specify the Radius value, then the 
Angle values. 

A flat roof plane with a pitch of 0 has angles 
of 0 at both the ridge and eave, as well as a 
radius of 0. 

• Uncheck Automatic Facet Angle to 
specify the Facet Angle, which is the 
angle at which curved roof surfaces are 
broken in 3D views. The default value is 
7.5°; a smaller value produces a smoother 
curve while a larger value may generate 
more quickly in 3D views. 
The Facet Angle value must divide into 
360° evenly; if it does not, the program 
will choose the nearest value that does. 

Specify the angle of the selected roof 
plane’s Baseline, relative to the XY 

axis. See “Editing Roof Baselines” on page 
496. 
• A positive Baseline Angle value causes 

the Baseline to tilt upward from its default 
height. A negative value causes it to tilt 
downward. The top heights of any walls 
under the selected roof plane will become 
angled, as well. 

• The Baseline Height defined above can 
be maintained at either the Start or End 
point. In floor plan view, the Baseline 
direction is clockwise around the house.

Options Panel
The settings on the OPTIONS panel are the 
same as those on the panel of the same name 
in the Build Roof dialog, but affect the 
selected roof plane only. See “Options Panel” 
on page 485.

Structure Panel
The settings on the STRUCTURE panel are 
similar to those on the ROOF panel of the 
Build Framing dialog, but apply to the 
selected roof plane only. See “Roof Panel” 
on page 595.

3

4
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One checkbox is unique to the STRUCTURE 
panel of the Roof Plane Specification 
dialog: check Retain Roof Framing to keep 
the selected roof plane’s framing from being 
deleted and replaced when roof framing is 
rebuilt. 

Rafter Tails Panel
The settings on the RAFTER TAILS panel are 
the same as those on the same panel of the 
Build Roof dialog, but affect the selected 
roof plane only. See “Rafter Tails Panel” on 
page 487.

Most of the settings on this panel are also 
like those on the MOLDINGS panel found in a 
variety of dialogs in the program. See 
“Moldings Panel” on page 659. 

Ridge Caps Panel
The settings on the RIDGE CAPS panel allow 
you to specify one more more ridge cap 
profiles on the ridge and hip edges of the 
selected roof plane and are the same as those 
on the same panel of the Build Roof dialog. 
See “Ridge Caps” on page 531. 

If you customize the settings on this panel, 
bear in mind that your changes may only take 
effect in the model if the same changes are 
also made to adjacent roof planes.

Most of the settings on this panel are like 
those on the MOLDINGS panel found in many 
dialogs in the program. See “Moldings 
Panel” on page 659.

One setting on this panel is unique: No 
Ridge Cap on Selected Edge. Check this 
box to remove the ridge cap profile(s) from 

the roof plane’s Selected Edge. See “Selected 
Edge” on page 184. 

Frieze Panel
The settings on the FRIEZE panel allow you 
to specify a frieze molding profile to 
generate under the eaves of the selected roof 
plane and are the same as those on the same 
panel of the Build Roof dialog. See “Frieze 
Molding” on page 530.

The settings on this panel are  like those on 
the MOLDINGS panel found in many dialogs 
in the program. See “Moldings Panel” on 
page 659.

Shadow Boards Panel
The settings on the SHADOW BOARDS panel 
allow you to specify one or more fascia 
shadow board profiles that follow the 
selected roof plane’s eaves. See “Shadow 
Boards” on page 528.

The settings on this panel are like those on 
the MOLDINGS panel found in many dialogs 
in the program. See “Moldings Panel” on 
page 659.

One setting on this panel is unique: No 
Shadow Boards on Selected Edge. Check 
this box to remove the shadow board 
profile(s) from the roof plane’s Selected 
Edge. See “Selected Edge” on page 184. 

Polyline Panel
The POLYLINE panel states the length of the 
roof plane’s Perimeter and its enclosed 
Area, calculated using several different 
methods. See “Polyline Panel” on page 502. 



Roof Plane Specification Dialog

 503

• Perimeter - This is the length of the roof 
plane’s perimeter, including fascia and 
shadow boards, with its pitch taken into 
account. It does not equal the perimeter as 
measured in floor plan view unless the 
pitch is 0. 

• Framing Area - This is the area of the 
roof plane’s framing, not including the 
fascia or shadow boards, with the pitch 
taken into account. It is slightly smaller 
than the Roof Surface Area as roofing 
typically overhangs the framing by a 
small amount.

• Projected Area - This is the area of the 
roof plane polyline, including fascia and 
shadow boards, as seen in floor plan view. 
It does not equal the Roof Surface Area 
unless the pitch is 0.

• Roof Surface Area - This is the area of 
the roof plane’s top surface, which covers 
the fascia and shadow boards, with the 
pitch taken into account.

• Overhang Area - This is the area of the 
roof plane’s overhang, including fascia 
and shadow boards, with its pitch taken 
into account. 

• Projected Overhang Area - This is the 
area of the roof plane’s overhang, includ-
ing fascia and shadow boards, as seen in 
floor plan view. 

Selected Line Panel
The SELECTED LINE panel is similar to the 
Line panel of the Line Specification dialog. 
See “Line Panel” on page 1084.

Line Style Panel
For information about the settings on this 
panel, see “Line Style Panel” on page 1085.

Fill Style Panel
The settings on the FILL STYLE panel control 
the appearance of the selected roof plane in 
floor plan view. For information about these 
settings, see “Fill Style Panel” on page 1099. 

Arrow Panel
The settings on the ARROW panel allow you 
to control the appearance of the selected roof 
plane’s slope direction arrow. See 
“Displaying Roofs” on page 491.

For information about these settings, see 
“Arrow Panel” on page 1088.

Materials Panel
The settings on the MATERIALS panel allow 
you to specify materials for the selected roof 
plane’s various components. For more 
information, see “Materials Panel” on page 
852.

The “Ceiling Surface” component is only 
available when Use Room Ceiling Finish is 
unchecked and Has Ceiling is checked on 
the OPTIONS panel.

Label Panel
Roof plane labels display when the “Roofs, 
Labels” layer is turned on and use the Text 
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Style assigned to that layer. See “Roof Plane 
Labels” on page 491.

For information about the settings on this 
panel, see “Label Panel” on page 1280.

Roof Baseline Polylines
Typically, the program builds an automatic 
roof based on the settings in the Build Roof 
dialog and on the ROOF panel of the Wall 
Specification dialog, along with the layout 
of the exterior walls and floor and ceiling 
heights. 

If you want to build a roof that diverges from 
the footprint of your building as well as the 
roof directives in the exterior walls, you can 
use Roof Baseline Polylines.

To create roof baseline polylines

1. Select Build> Roof> Build Roof .
2. On the BUILD panel of the Build Roof 

dialog, check Make Roof Baseline 
Polylines. 

3. Click OK. A set of roof Baselines is cre-
ated along the outside edge of the Main 
Layer of the exterior walls, forming one 
or more closed polylines.

As with roof planes, the heights of Roof 
Baseline Polylines are determined by ceiling 
heights in the plan. If roof planes will be 
built at more than one height, a separate 
baseline polyline is created for each height.

Once created, a Roof Baseline Polyline can 
be edited in a variety of ways, then used as 
the basis for the roof then next time it is built 
automatically. 

To create a new roof using the directives in 
your Roof Baseline Polyline(s), check Use 
Existing Roof Baselines in the Build Roof 

dialog and click OK. See “Roof Panel” on 
page 481.

Displaying Roof 
Baseline Polylines

Roof Baseline Polylines are placed on the 
“Roofs, Baseline Polylines” layer by default 
and use the Text Style assigned to that layer. 
See “Displaying Objects” on page 144.

Roof directive information displays along 
each edge of the polyline, including:
• V - vertical (against wall);
• G -gable/shed;
• K - knee wall;
• L - lower (extend slope downward).

If the directive information includes the 
pitch, the roof plane slopes toward that edge; 
if it includes the word (vert), it does not.

 Editing Roof 
Baseline Polylines

A Roof Baseline Polyline’s shape can be 
edited much like a CAD polyline using its 
edit handles and edit toolbar buttons. See 
“Editing Closed-Polyline Based Objects” on 
page 201.  

Roof Baseline Polylines always form a 
closed area with straight sides only. They 
cannot be severed or curved, but additional 
joints or corners can be added.
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When a new roof is built, it follows the shape 
of the Roof Baseline Polyline even if that 
shape does not follow the exterior walls. 

In addition to length and direction, each Roof 
Baseline Polyline edge has roof directives 
associated with it, much like the roof 
directives in individual walls. See “Roof 
Directives in Walls” on page 295.

An Example
For a simple example of Roof Baseline 
Polyline editing, consider an L-shaped 
house, with a rectangular roof. The inner part 
of the ’L’ is a patio that is covered under the 
same roof.

On the left is the baseline polyline as it was 
originally produced and the roof plan it 
creates.

To model the roof plan shown on the right

1. Select the Roof Baseline Polyline along 
its bottom-most edge.

2. Click the Intersect/Join Two Lines  
edit button. See “Reshaping Objects” on 
page 230.

3. Click the left-most edge to remove the 
two intervening edges. 

4. A message box informs you that “The 
system must delete intervening lines 
(those on the inside of the L) to join the 
two selected lines.” Click OK.

5. Open the Build Roof dialog and select 
the Build Roof Planes and Use Existing 
Roof Baseline check boxes to model the 
roof plan shown on the right side of the 
image above.

Roof Baseline Specification Dialog
Like walls, each line of a Roof 
Baseline Polyline contains roof 

directives that affect automatic roof 
generation. Select any edge of a Roof 

Baseline Polyline click the Open Object edit 
button open the Roof Baseline 
Specification dialog.

Roof Baseline Panel
The settings on the ROOF BASELINE panel 
control the roof directives associated with the 

selected edge of the Roof Baseline Polyline. 
See “Selected Edge” on page 184. 
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Specify the Baseline height, which is 
the height of the entire Roof Baseline 

Polyline, not just that of the selected edge. 
See “The Baseline” on page 489. 

Roof Options - 

• The first four checkboxes: Full Gable 
Wall, High Shed/Gable Wall, Knee 
Wall, and Extend Slope Downward are 
the same as those in the Wall 
Specification dialog. See “Roof Panel” 
on page 314.

• Check Against Wall if the roof plane ris-
ing from this baseline butts against an 
exterior wall. This is similar to checking 
High Shed/Gable Wall.

Pitch Options - 

• Specify the Pitch for the selected edge of 
the Roof Baseline Polyline. This over-
rides the default pitch set in the Build 
Roof dialog. See “Build Roof Dialog” on 
page 480.

• The Pitch, 2nd Pitch, and Starts at set-
tings are the same those in the Wall 
Specification dialog. 

• Baseline height - This is the height of the 
entire Roof Baseline Polyline, not just 
that of the selected edge. See “The Base-
line” on page 489. 

Polyline Panel
The POLYLINE panel states the length of the 
Roof Baseline Polyline’s Perimeter and its 
enclosed Area. See “Polyline Panel” on page 
502. 

1
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Selected Line Panel
This panel is similar to the LINE panel of the 
Line Specification dialog. See “Line Panel” 
on page 1084.

Line Style Panel
For information about the settings on this 
panel, see “Line Style Panel” on page 1085.

Fill Style Panel
The settings on the FILL STYLE panel control 
the appearance of the selected Roof Baseline 
Polyline in floor plan view. For information 
about these settings, see “Fill Style Panel” on 
page 1099.

Roof and Ceiling Framing
Roof framing can be both drawn manually 
and generated automatically. You can also 
combine the two techniques. As with other 
kinds of framing, it is often easiest to begin 
by generating roof framing automatically and 
then editing it as needed. See “Manual vs. 
Automatic Framing” on page 580.

Roof Trusses  cannot be generated 
automatically - they must be drawn manually 
and then replicated. If you intend to use Roof 
Trusses, make sure the settings in the Build 
Roof dialog are properly defined before you 
build the roof. See “Roof Trusses” on page 
616.

When using a combination of Roof Trusses 
and stick framing, begin by drawing the roof 
planes and ceiling planes. When they are in 
place, draw and replicate the Roof Trusses.  
Finally, automatically generate or manually 
draw the stick framing and edit it as needed. 
See “Mixing Rafters and Trusses” on page 
582.

Framing for manually drawn Ceiling 
Planes  cannot be drawn manually - it 
must be automatically generated. The 
framing for manually drawn Ceiling Planes 
is generated when roof framing is built and 
uses the settings in the Build Roof dialog as 
defaults. Once it has been created, it can be 
edited. See “Ceiling Plane” on page 476.

Rebuilding Roof Framing
If roof framing defaults are modified after 
the roof and roof framing are built, neither 
will update automatically. In order to update 
the model you need to rebuild the roof, then 
rebuild the roof framing. 

You can also modify the roof framing 
settings for individual roof planes, and then 
either build roof framing or click the Build 
Framing for Selected Object  edit 
button. See “Keeping Framing Current” on 
page 608.
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Curved Roof Planes
Any roof plane can be turned into a curved 
roof plane in the Roof Plane Specification 
dialog. See “Roof Plane Specification 
Dialog” on page 498.

One way to produce a barrel roof is using a 
single roof plane that starts out flat (zero 
pitch) and covers the entire building.

Curving a Single Roof Plane

To curve a roof plane

1. Draw a simple four wall structure with a 
4 in 12 pitch shed roof. 

2. Select the roof plane and click the Open 
Object  edit button to open the Roof 
Plane Specification dialog.

3. On the GENERAL panel, change the 
Pitch to 0 in 12.

4. Check Curved Roof and notice that the 
Angle values below are both at 0.0°.

5. Change the Angle at Eave from 0° to 
45° and press the Tab key. Notice that 
the other values update and that in order 
to maintain the 0 in 12 pitch, the Angle 
at Ridge becomes -45°. 

Curving Two Roof Planes
You can also create a barrel roof using  two 
roof planes. A 12 in 12 pitch is used because 
it allows the curved roof to be nearly vertical 
at the eave and nearly flat at its peak. 

To curve two roof planes

1. Draw a simple four wall structure with a 
12 in 12 pitch gable roof. 
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2. Select one of the roof planes and click 

the Open Object  edit button to open 
the Roof Plane Specification dialog.

3. Check Curved Roof and notice that the 
Angle values below are identical. 

4. Change the Angle at Ridge from 45° to 
1°. This makes the roof plane nearly flat 
at the ridge. The Angle At Eave updates 
to maintain the 12 in 12 pitch.

5. Repeat this process with the other roof 
plane.

Compound Curved 
Roof Planes

Compound curves can be created using two 
or more curved roof planes or a combination 
of straight and curved roof planes. 

To create a compound curved roof

1. Draw a simple four wall with a 4 in 12 
pitch gable roof.

2. In floor plan view, select one of the roof 
planes and pull its ridge edge back so 
that it is 4 feet from the wall. Do the 
same to the other roof plane.

Before curving roof planes or joining
the edges of any curved plane, make
sure all flat roof planes are correctly

joined. See “Join Roof Planes” on page 493.
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3. Select both roof planes and check 
Curved Roof in the Roof Plane 
Specification dialog. Set the Angle at 
Ridge to 33.6901°, which is the same as 
8 in 12. Notice that the Angle at Eave is 
almost flat.

4. Use the Roof Plane  tool to draw the 
two high roof planes. As you create each 
one, draw its Baseline along to the ridge 
edge of one of the low roof plane. See 
“To draw a roof plane” on page 489. 

5. Select the two new roof planes, click the 

Open Object  edit button, and 
change their Pitch to 33.6901° - or 8 in 
12. Viewed in 3D, the planes appear to 
join together into one.

Curved Roof Plane 
Intersections

Curved roof planes can be joined to other 

roof planes using the Join Roof Planes  
edit tool. Often, the result is a curved roof 
valley or hip. 

In many instances, a curved roof plane can 
only be joined to another roof plane if its 
Angle at Ridge or Radius to Roof Surface 
setting is changed. See “General Panel” on 
page 499. 

When that is the case, the Join Curved Roof 
Plane dialog will open when the Join Roof 
Planes  tool is used. 
• Choose Lock the Radius to Roof Sur-

face to maintain the roof plane’s curva-
ture but change its angle at the ridge edge.

• Choose Lock the Angle at Ridge to 
maintain the roof plane’s angle at its ridge 
edge but change its curvature.

In order to straighten a curved roof edge, 
select the edge in question and click the 

Straighten Curved Edge  edit button.
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Ceiling Planes
Ceiling planes are drawn the same 
way as roof planes and are edited 

using the same tools. They are useful for 
creating custom vaulted ceilings. See 
“Vaulted and Cathedral Ceilings” on page 
347.

Ceiling planes are drawn using the same 
pitch as roof planes, specified in the Build 
Roof dialog. See “Build Roof Dialog” on 
page 480.

If you wish, you can specify the desired pitch 
in the Build Roof dialog before drawing a 
ceiling plane, or you can change the pitch 
after it is drawn in the Ceiling Plane 
Specification dialog. See “Ceiling Plane 
Specification Dialog” on page 512.

There are a few things to remember when 
drawing ceiling planes.

• Ceiling planes should be created over 
rooms that have Ceiling Over this Room 
unchecked in the Room Specification 
dialog. See “Structure Panel” on page 
352.

• The Baseline of a ceiling plane should be 
drawn along the outer surface of the bear-
ing wall’s Main Layer. This allows the 
ceiling plane to extend over and be sup-
ported by the wall. See “The Main Layer” 
on page 302. 

• The sloping edge at the side of a ceiling 
plane should butt to the inside of the wall.

• Ceiling planes act independent of the roof 
planes above.

• Usually, the pitch of a ceiling plane is 
lower than the pitch of the corresponding 
roof plane. 

• Ceiling planes can be joined together 

using the Join Roof Planes  edit but-
ton. See “Join Roof Planes” on page 493.

• Select a ceiling plane and click the Open 
Object  edit button to open the Ceiling 
Plane Specification dialog. See “Ceiling 
Plane Specification Dialog” on page 512.

Displaying Ceiling Planes
Ceiling planes are drawn on the 
“Ceiling Planes” layer by default, 

although you can place a ceiling plane on any 
layer. See “Line Style Panel” on page 515. 

Manually drawn Ceiling Planes  can also 
display labels when the “Roofs, Labels” 
layer is on. See “Roof Plane Labels” on page 
491.

Cross Section showing ceiling planes.
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Editing Ceiling Planes
Ceiling planes can be edited much like roof 
planes using their edit handles and edit 
toolbar buttons. See “Editing Roof and 
Ceiling Planes” on page 492. 

Ceiling planes can also be edited in the 
Ceiling Plane Specification dialog. See 
“Editing Roof and Ceiling Planes” on page 
492. 

As with roof planes, the ceiling planes layer 
can be locked to prevent editing. 

Deleting Ceiling Planes
Select Build> Roof> Delete Ceiling 
Planes to delete all ceiling planes in 

the current plan. 

Ceiling planes can also be deleted at 
once in the Delete Objects dialog. 

See “Delete Objects Dialog” on page 255.

In addition, you can select any ceiling plane 
or group of ceiling planes, then press the 

Delete key or click the Delete  edit button 
to delete it from the plan. See “Deleting 
Objects” on page 255.

Ceiling Plane Specification Dialog
Select a ceiling plane and click the 
Open Object edit button to open the 

Ceiling Plane Specification dialog.

The Ceiling Plane Specification dialog is 
similar to the Roof Plane Specification 
dialog. See “Roof Plane Specification 
Dialog” on page 498.
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General Panel

There are four values that define the 3D 
orientation of a ceiling plane: Bottom at 
Ridge, Inside Bottom, Outside Bottom and 
Pitch.

Locking any of the Height values defines 
that value as the pivot point for the selected 
ceiling plane. Each of these dimensions is 
measured from the first floor default 
elevation of 0' - 0". 

If you lock the Pitch and change a Height 
value, the ceiling plane moves vertically, 
keeping the same slope. It will not pivot. 

Changing these values does not affect the 2D 
representation of the ceiling plane.

Specify the Height and Pitch of the 
selected ceiling plane. Heights are 

measured from the bottom surface of the 
ceiling plane’s rafters or trusses. 
• Define the Bottom at Ridge Height, or 

lock this value to make it the roof plane’s 
pivot point.

• Define the Inside Bottom Height, or lock 
this value to make it the roof plane’s pivot 
point. If the plane is drawn over a wall, 
this is located at the inside surface of the 
wall’s Main Layer.

1
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• Define the Outside Bottom Height, or 
lock this value to make it the roof plane’s 
pivot point. Only available when a ceiling 
plane is drawn over a wall, this is the 
height of the lower edge of the ceiling raf-
ters, were they not clipped by the wall 
below. 

• Specify the selected ceiling plane’s Pitch, 
or lock this value to move the plane verti-
cally when a Height value is changed. 

• Check Pitch in Degrees to display the 
Pitch value in degrees. See “Roof Pitches 
in Degrees” on page 532.

Measurements - Information about the 
structure of the selected ceiling plane(s) 

displays here, mostly for reference.
• Specify the Rafter Depth. The default 

rafter depth is the same as that for roof 
planes and is set in the Build Framing 
dialog. See “Build Framing Dialog” on 
page 586. 

• The Vertical Rafter Depth is defined by 
measuring a plumb line through a rafter. 
The greater the pitch, the greater the verti-
cal rafter depth.

• The Top of Plate is the top plate height of 
the bearing wall, and is also the ceiling 
height of the room.

• Overhang From Inside Bottom - Only 
appearing when a ceiling plane is drawn 
over a bearing wall, this is the horizontal 
distance from the Baseline to the inside 
Main Layer surface of the wall. The Base-
line is typically drawn over the outside 
Main Layer surface, so this value is equal 
to the wall’s Main Layer thickness. 

• Clip End - Only available when a ceiling 
plane is drawn over a bearing wall, this is 

the amount a ceiling rafter’s underside 
must be clipped at its lower end to rest on 
the wall top plate. This is equal to the 
ceiling plane’s rise in slope over the dis-
tance of the Overhang from Inside Bot-
tom.

The Outside Bottom value plus the Clip 
end value equals the Top of Plate value.

Ceiling Finish - 

• When Use Room Ceiling Finish is 
checked, the selected ceiling plane’s ceil-
ing finish thickness and material are 
defined by the room below and the “Ceil-
ing Surface” component will not be avail-
able on the MATERIALS panel. Uncheck 
this box to enable the Ceiling Thickness 
option.

• Specify the Ceiling Thickness, which is 
the thickness of the bottom surface of the 
ceiling plane. 

Check Curved Roof to specify the 
selected roof plane as curved. See 

“Curved Roof Planes” on page 508.
• Specify the roof plane’s Angle at Eave, 

Angle at Ridge and Radius to Roof Sur-
face.

• These three values are interrelated - when 
one is changed, the other two adjust 
accordingly. You may find it helpful to 
first specify the Radius value, then the 
Angle values. 

A flat ceiling plane with a pitch of 0 has 
angles of 0 at both the ridge and  eave, as 
well as a radius of 0. 

2
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Structure Panel
The settings on the STRUCTURE panel of the 
Ceiling Plane Specification dialog are a 
subset of those found on the ROOF panel of 
the Build Framing dialog. See “Roof Panel” 
on page 595.

Polyline Panel
The POLYLINE panel states the length of the 
ceiling plane’s Perimeter, its Framing 
Area, and its Projected Area. See “Polyline 
Panel” on page 502. 

Selected Line Panel
This panel is similar to the LINE panel of the 
Line Specification dialog. See “Line Panel” 
on page 1084.

Line Style Panel
For information about the settings on this 
panel, see “Line Style Panel” on page 1085.

Fill Style Panel
The settings on the FILL STYLE panel affect 
the appearance of the selected ceiling plane 
in floor plan view. For information about 
these settings, see “Fill Style Panel” on page 
1099.

Materials Panel
The “Ceiling Surface” component is only 
available when Use Room Ceiling Finish is 
unchecked on the General panel. 

For more information about the settings on 
this panel, see “Materials Panel” on page 
852.

Label Panel
Ceiling plane labels display when the 
“Roofs, Labels” layer is turned on and use 
the Text Style assigned to that layer. The 
Automatic Label for ceiling planes is blank, 
but you can specify a custom label. See 
“Roof Plane Labels” on page 491.

For information about the settings on this 
panel, see “Label Panel” on page 1280.

Gable/Roof Lines
The Gable/Roof Line tool can be 
used to automatically generate a gable 

above the bearing wall of a hip roof plane. It 
is best used in situations where roof 
directives in walls are not possible. For 
example: 
• If a Wall Break would be required in the 

same location as a door or window; 

• Where a wall is not present, such as 
across the front of an alcove; 

• Over a Bay, Box, or Bow Window.

See “Roof Directives in Walls” on page 295. 

In addition, the Gable Over Door/
Window edit button allows you to add 

a small Gable/Roof Line over one or more 
selected doors or windows the next time 
automatic roof planes are built.
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Gable/Roof Lines display in floor plan view 
when the “Roofs, Gable Lines” layer is set to 
display and can be selected and edited much 

like regular CAD lines. See “Editing Line 
Based Objects” on page 187. 

Creating a Gable

To create a gable using a Gable/Roof Line

1. Select Build> Roof> Gable/Roof 
Line , then click and drag to draw a 
line outside of the exterior wall that you 
want to create a gable over.

2. Position the Gable/Roof Line within 10 
feet (2260 mm) of the wall’s Main Layer 
but not touching it. See “The Main 
Layer” on page 302.

•  Make sure that the Gable/Roof Line is 
exactly parallel to the exterior wall. 

3. Resize the Gable/Roof Line so that it is 
the length of the desired gable.

•  The length of the Gable/Roof Line 
determines the gable width at the wall 
Main Layer, not at the overhang. 

•  At the larger roof eave, a gable roof is 
wider than the gable line by twice the 
overhang distance.

4. Select Build> Roof> Build Roof  
and regenerate the roof. See “Build Roof 
Dialog” on page 480. 

To use the Gable Over Door/Window tool

1. Select one or more doors or windows. 
2. Click the Gable Over Door/

Window edit button.

•  Gable Over Door/Window  is not 
available for openings placed in Full 

Gable Walls or for Bay, Box or Bow 
Windows. See “Bay, Box, Bow 
Windows and Roofs” on page 427.

3. The next time automatic roof planes are 
built, gables will be created over each of 
these doors and windows.

Gables produced using Gable Roof Lines
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•  Each gable will extend 12” (300 mm) 
on either side of its door or window.

•  If two of these openings are within 30” 
(750 mm) of each other on the same 
wall, a single gable will be created. 

•  If you move or resize the door or 
window(s), the associated Gable/Roof 
Line will not update until the roof is 
built again. 

4. To remove a Gable Over Door/Window, 
select the door(s) or window(s) and click 

the Delete Gable Over Opening  
edit button, or select the gable line and 

click the Delete  edit button. The 
next time the roof is built, the gable will 
be removed. 

Covering an Alcove

A Gable/Roof Line  can also be used to 
maintain a roof plane baseline where there is 
no wall below. For example, you can use it to 
extend a roof plane across an alcove, rather 
than wrap into it. 

In order for a Gable/Roof Line  to direct 
the roof to extend over an alcove or other 
area where no wall is present, it must be 
aligned with the exterior walls’ Main Layer. 

Gable/Roof Lines drawn to extend roof planes Result, after automatic roof generation
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Covering a Bay

A Gable/Roof Line  drawn across a bay 
causes a gable to be build above the bay 
when roofs are automatically generated. 

In order for the gable to be built, at least one 
end of the Gable/Roof Line must extend past 
the side walls of the bay. 

If the Gable/Roof Line is drawn along the 
outer edge of the bay’s outer wall’s Main 
Layer, the resulting gable will extend only to 
the eave of the larger roof. Draw the Gable/
Roof Line beyond the bay’s outer wall to 
extend out past the larger roof’s eave.  

Skylights and Roof Holes
A skylight can be created by selecting 
Build> Roof> Skylight and drawing a 

rectangular polyline within a single roof 
plane. You can also simply click once within 
a roof plane to place a 2’ x 2’ skylight.

The Skylight  tool places a flat panel 
skylight into a roof hole, produces a hole in 
the ceiling platform below, and automatically 

generates the skylight shaft between these 
two holes.

To place a skylight in a vaulted ceiling, 
uncheck Ceiling Over This Room in the 
Room Specification dialog, draw the ceiling 
planes to produce the vault and edit them as 
needed, and then draw the skylight. See 
“Structure Panel” on page 352.

Gable/roof line used to create a gable over a bay

Gable/roof line extends past end of side wall

Gable/roof line drawn beyond outer wall of 
bay results in gable extending to cover bay
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Editing Skylights
Skylights can be selected individually or in 
groups and can be edited using the edit 

handles, edit toolbar buttons, or the Roof 
Hole/Skylight Specification dialog. See 
“Roof Hole/Skylight Specification Dialog” 
on page 519.

Skylights must always be contained by a 
single roof plane. If the roof plane is deleted, 
any skylights or holes it contains are also 
deleted. Aside from this restriction, skylights 
can be edited much like standard closed 
polylines. See “Editing Closed-Polyline 
Based Objects” on page 201. 

If you clear the Skylight check box in the 
Roof Hole/Skylight Specification dialog, 
the curb and glass for the skylight is removed 
but the opening remains. 

By default, the flat ceiling hole does not 
display separately; but it can be edited 
separately, and even deleted entirely. See 
“Roof Hole/Skylight Specification Dialog” 
on page 519. 

A roof hole can also be created using the 

Create Hole  edit tool. See “Polyline 
Holes” on page 206.

Roof Hole/Skylight Specification Dialog
Select a skylight and click the Open 
Object edit button to open the Roof 

Hole/Skylight Specification dialog. See 
“Skylights and Roof Holes” on page 518.

Note: If a sloped ceiling plane is present
under the skylight, a hole in this ceiling plane
is automatically produced. This hole is visible,
and may be located directly under the roof
hole. It can be moved and edited separately. 
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General Panel

Check Skylight to specify this polyline 
as a skylight. If unchecked, the curb 

and glass for the skylight are removed but the 
opening remains. 
• Specify the Frame Width and Height of 

the selected skylight.

Angle for Inside Hole Rim - Defines 
the shape of the skylight well where it 

passes through the roof plane.
• Square Sides - The framing for the sky-

light is cut square to the pitch of the roof.
• Plumb Sides - The framing for the sky-

light is plumb-cut.
• Plumb/Square - The bottom edge is 

plumb-cut, the top edge square-cut.

Specify how the selected skylight/roof 
hole’s Ceiling Hole should be built. 

These options are only available if the room 
below has a default ceiling specified in the 
Room Specification dialog. See “Structure 
Panel” on page 352. 

• Select Skylight Automatically Gener-
ates Ceiling Hole to automatically gener-
ate and maintain the skylight hole in a flat 
ceiling. This option is the selected for 
skylights in vaulted ceilings. 

• Select Manually Edit Ceiling Hole 
Polyline to edit the flat ceiling hole poly-
line manually. Click OK to return to floor 
plan view and edit the ceiling hole poly-
line. When this option is selected, the 
ceiling hole polyline and the skylight can 
be selected separately in floor plan view.

• Select Do not generate ceiling hole to 
generate a hole through the roof plane but 
not the ceiling.

• Uncheck Generate shaft to ceiling hole 
to generate a roof hole and a ceiling hole, 
but no vertical surfaces connecting them. 

1

2

3

Note: Holes automatically produced in a slop-
ing custom ceiling plane by a new skylight
must be manually maintained.
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When checked, a shaft between the two is 
produced. Not available if Do not gener-
ate ceiling hole is selected. 

Polyline Panel
The POLYLINE panel states the roof hole/
skylight’s Perimeter, its Framing Area, and 
its Projected Area. See “Polyline Panel” on 
page 502.

Selected Line Panel
This panel is similar to the LINE panel of the 
Line Specification dialog. See “Line Panel” 
on page 1084.

Line Style Panel
For information about the settings on this 
panel, see “Line Style Panel” on page 1085.

Fill Style Panel
The settings on the FILL STYLE panel control 
the appearance of the selected roof hole or 
skylight in floor plan view. For information 
about these settings, see “Fill Style Panel” on 
page 1099.

Materials Panel
For information about the MATERIALS panel, 
see “Materials Panel” on page 852.

Label Panel
Roof hole and skylight labels display when 
the “Roofs, Labels” layer is turned on and 
use the Text Style assigned to that layer. The 
Automatic Label for these objects is blank, 
but you can specify a custom label. See 
“Roof Plane Labels” on page 491.

For information about the settings on this 
panel, see “Label Panel” on page 1280.

Dormers and Crickets
Dormers can be drawn manually 
or placed automatically using the 

Auto Dormer tools.

Automatic Dormers can  be placed only 
under certain conditions: 
• Automatic Dormers can only be placed 

entirely within a single roof plane. They 
cannot extend past the eaves or ridge of 
this roof plane.

• Automatic Dormer side walls cannot be 
positioned above other walls in the plan.

If you click within a roof plane to place an 
automatic dormer, but click too close to an 
eave or the ridge, a dormer will not be 

created; however, its outline will. Move this 
outline box to a location that meets the 
dormer’s requirements and it will be created.

Automatic dormers reside by default on their 
own layer, “Auto Dormers”. Their display 
cannot be turned off; however, you can lock 
this layer to prevent unintended editing. See 
“Layer Display Options Dialog” on page 
149.

Auto Floating Dormer
Select Build> Roof> Auto Floating 
Dormer and click the roof plane 
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where you would like to place the center of 
the dormer's front wall. 

The bottom edges of all floating dormer 
walls are cut off by the underlying roof 
plane. To produce such a dormer manually, 
check Roof Cuts Wall at Bottom for the 
dormer walls on the ROOF panel of the Wall 
Specification dialog.

Usually, no room is defined by the walls of 
this type of dormer. 

The images below show both the outside and 
inside of a typical floating dormer.

A floating dormer can be placed in floor plan 
view on the same floor that its underlying 
roof plane displays on, or it can be placed on 
the floor above. Normally, it does not matter 
what floor the dormer is on; but in some 
cases, it may need to be on the floor above so 
that the dormer walls do not interfere with 
walls or railings in the room below. 

Regardless of which floor it is placed on, a 
dormer must always fit within a single roof 

plane. When placing a dormer on the floor 
above, you may find it helpful to turn on the 

Reference Display . See “Reference 
Floor Display” on page 444. 

You may also find it helpful to display the 
underlying roof plane on the floor above 
using the Roof Plane Specification dialog. 
See “Roof Plane Specification Dialog” on 
page 498.

If the dormer is placed on the same floor as 
the underlying roof plane and the room 
below, and if the room has a flat ceiling, then 
a hole will be produced in the ceiling under 
the dormer.

Auto Dormer
Select Build> Roof> Auto Dormer 
and click on a roof plane where you 

want the center of the dormer's front wall to 
be. 

The walls of an auto dormer go to the floor 
and meet a knee wall on either side on the 
back of the dormer. This knee wall must run 
parallel to the underlying roof plane’s 
Baseline.
• If you are creating a (non-floating) auto 

dormer, a knee wall must already exist. 
The dormer side walls run back to the 
knee wall and the knee wall is broken 
where the dormer walls meet it. 

• The knee wall does not have to be desig-
nated as such in the Wall Specification 
dialog unless you are generating an auto-
matic roof. See “Knee Walls” on page 
297.

• A non-floating dormer must always be 
created on the same floor as the knee 
walls. 
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The initial width, height, roof style and other 
settings of Auto Dormers are set in the 
Dormer Defaults dialog. See “Dormer 
Defaults” on page 475.

Manually Drawn Dormers
Once you are familiar with Chief Architect’s 
roof tools, drawing dormers manually can be 
quite simple. There are several different 

ways to draw dormers; some methods work 
better in certain applications. 

A variety of resources with information 
about drawing dormers manually is available 
at chiefarchitect.com . 

See, too, “Manually Drawn Dormers” on 
page 80 of the User’s Guide.

There are a few things to keep in mind.
• Walls extend upward until they meet an 

overlying roof plane. 
• A wall can also be cut by underlying roof 

planes if Roof Cuts Wall at Bottom is 
checked in the Wall Specification dialog. 
For this to work properly, the edge of the 
roof plane must extend completely 
through the width of the wall. See “Clere-
story and Dormer Walls” on page 296.

• Polylines can be converted into a Hole in 
Roof/Ceiling that allows walls to extend 
above or below the roof line. See “Con-
vert Polyline” on page 239.

Manually Drawn Crickets
The automatic roof generator will not 
produce crickets in a roof plan; however, you 
can manually draw a cricket using the Roof 
Plane  tool. See “Crickets and Dormer 
Vents” on page 87 of the User’s Guide. 

Editing Auto Dormers
Auto Dormers are a collection of objects that 
behave as one. When a dormer is selected, it 
can be edited using its edit handles, edit 
tools, and specification dialog. See “Dormer 
Specification Dialog” on page 524.

If you click the Explode Dormer  edit 
button, the dormer’s individual components 
can be edited.

http://www.chiefarchitect.com/
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Using the Mouse
When selected, an auto dormer displays three 
edit handles. The Move handle displays over 
the front wall and allows you to relocate the 
dormer. Two resize handles display on the 
side walls and allow you to change the width 
of the dormer.

There are some things to keep in mind when 
editing auto dormers and auto floating 
dormers using the mouse.
• Dormers move at 90° angles unless the 

Ctrl key is pressed before moving them.
• The dormer must be contained within one 

underlying roof plane.
• Auto dormers cannot be moved beyond 

the required knee wall.

Editing the Window
Dormer windows can be selected, edited, 
deleted and replaced just like other windows. 
See “Editing Windows” on page 403. You 
can place several windows in the front wall.

Unless the dormer's window has been edited 
or changed in the Window Specification 
dialog, when the dormer width is changed, its 
width changes automatically to fill the front 
dormer wall. If the window has been edited, 
its width stays fixed. If a change to the 
dormer makes its front wall too short to hold 
the window, the window reverts to auto 
width.

Exploding Dormers
Click the Explode Auto Dormer edit 
button to explode the auto dormer into 

its component parts. The dormer walls, roof 
planes, window, and hole in the roof/ceiling 
can be edited individually. 

The program treats roof planes over an 
exploded anto dormer as though they were 
manually drawn, allowing you to protect 
them from being rebuilt in the Build Roof 
dialog. See “Roof Panel” on page 481.

Dormer Specification Dialog
Select a dormer or dormers and click 
the Open Object edit button to open 

the Dormer Specification dialog.

The settings in this dialog are also found in 
the Dormer Defaults dialog, where they 
apply to all dormers as they are created rather 
than to a selected dormer.

Move Resize
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Roof Panel

Specify the selected dormer’s Roof 
Style. 

• Choose a roof Type from the drop-down 
list.  You can choose from Hip, Gable, 
Shed, Gambrel, Mansard, Barrel, Curved 
Eave, Hip Curved Eave or Eyebrow. 

Describe the Pitch of the dormer’s roof 
planes.

1

Dormer Roof Types 

2
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• Specify the Pitch of the dormer roof 
planes. The default dormer pitch applies 
to all dormer roof types except Shed, 
which has a default 3 in 12 pitch. For 
Gambrel and Mansard types, this applies 
to the lowest, or eave, roof planes. 

• Check Pitch in Degrees to display the 
pitch in degrees; uncheck it to display the 
pitch in terms of rise and run. See “Roof 
Pitches in Degrees” on page 532.

• The Second Pitch specifies the upper 
roof of a Gambrel, Mansard, curved eave, 
and hip curved eave. 

• When a Second Pitch is used, specify the 
In from Eave distance, measured from 
the lower roof plane eave to where the 
upper roof plane starts.

Roof Overhang - Specify the depth of 
the selected dormer’s Eave and Gable 

Overhangs.

Specify the characteristics of the 
dormer’s Fascia/Rafters. 

• Specify the Fascia Depth for gable fascia 
and the Eave Fascia Depth. 

• Specify the Rafter Depth.
• The Vertical Rafter Depth displays for 

reference.
• Specify whether to Include Boxed Eaves, 

Gutters, Frieze, and/or Shadow Boards.
• Select either Plumb or Square Rafter 

Cut. 

Check Auto Roof Returns to generate 
roof returns on the selected dormer. 

Roof Returns can be only specified for Gable 
dormers. See “Roof Returns” on page 527.
• Specify the horizontal Length of the roof 

return in inches (mm).
• Enter a value in inches (mm) to Extend 

the roof returns past the dormer overhang. 
• Specify a Gable, Hip, or Full roof return. 
• Specify a Sloping or Flat roof return. See 

“Roof Tutorial” on page 63 of the User’s 
Guide.

• Check the boxes to Include Shadow 
Boards, Ridge Caps, and/or Frieze 
molding on the roof returns.

Walls Panel

3

4

5
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• Select a Wall Type for the dormer walls 
from the drop-down list. 

• Specify the Height of the dormer, as mea-
sured from where the top of the underly-
ing roof plane meets the dormer front wall 
exterior to the top plate of the dormer 
roof’s bearing walls.

This top height is called the dormer ceiling 
height, even if the ceiling in the dormer is not 
flat. The top dormer window casing is 
usually close to this height.
• Check Set to Existing Ceiling to assign 

the ceiling height of the room behind the 
dormer to the dormer. Not available in the 
Dormer Defaults dialog. 

• Height to Reach Existing shows the dif-
ference between the dormer height where 
the inside of the wall meets the underside 
of the roof and the ceiling of the room 
behind it.

• Specify the dormer’s Width, measured 
from the outside surfaces of the dormer 
side walls.

• Form Room Inside Dormer is used only 
for floating dormers and creates a flat 
ceiling in the dormer. If you check this 
option, you should define the dormer on 
the floor above the room it is positioned 
over. If this room has a flat ceiling, check-
ing this option makes a hole in the ceiling 
under the dormer. This option should nor-
mally be left unchecked.

Only available in the Dormer Defaults 
dialog, if Set Inside Window Trim Width is 
checked, the inside casing width for dormer 
windows defaults to the Inside Window 
Trim value entered below. Dormer windows 
can appear too narrow on the outside due to 
the space required for the inside casing to 
clear the inside surfaces of the side walls. 
This value sets the width for the inside casing 
of the dormer window.

Line Style Panel
For information about the settings on this 
panel, see “Line Style Panel” on page 1085.

Roof Returns and Other Details
Chief Architect offers a selection of tools to 
add architectural details to your roof design.

Roof Returns
A roof return is a small decorative roof plane 
that connects to the low side of a gable roof 
overhang and extends below the upper 
triangular portion of the gable wall. Three 
styles of roof returns that can be produced 
automatically.

The first two styles are called Gable and Hip 
returns since the return ends in a gable or hip. 

Hip Return Gable Return
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The third is called a Full return because it 
extends under the entire gable to connect 
both sides and is sometimes referred to as a 
water table. In order for a Full return to be 
created, the roof planes on each side must 
have the same Fascia Top Height.

It is not difficult to manually draw roof 
returns using small roof planes, but it is 
quicker to produce them automatically. 

Roof returns are generated automatically on 
a wall by wall basis using settings found in 
the Wall Specification dialog. See “Roof 
Panel” on page 314.

These roof return settings are also found in 
the Dormer Specification dialog for gable 
roof dormers and function similarly. See 
“Roof Panel” on page 525.

The pitch of an automatically generated roof 
return is the same as that of the roof plane 
above it. Its structure is the same as that of 
the subfascia and eaves of the roof plane 
above. See “Structure Panel” on page 501. 

Fascia and Shadow Boards
Fascia and shadow boards can be added to 
both automatic and manually drawn roof 
planes. They can be generated when the roof 
planes are drawn when specified in the Build 
Roof dialog, and can also be added to or 

removed from individual roof planes in the 
Roof Plane Specification dialog.
• Fascia and eave fascia can be specified in 

the Build Framing and Build Roof dia-
logs. See “Roof Panel” on page 595.

• One or more shadow boards profiles can 
be specified in the Build Roof dialog. See 
“Shadow Boards Panel” on page 488.

• Fascia and shadow boards are generated 
whenever Build Fascia and Roof Trim is 
checked. See “Roof Panel” on page 481.

• The materials used for fascia and shadow 
boards can be specified separately. See 
“Materials Panel” on page 488. 

Fascia and shadow boards display in 3D 
views and are included in the materials list.

Fascia

The material specified for fascia in the Build 
Roof dialog displays as part of the roof plane 
rather than as a separate object. It displays in 
3D views but not floor plan view.

In addition, sub fascia boards are created 
when roof framing is generated and are 
placed on the “Framing, Roof Rafters” layer. 
The fascia material is not applied to these 
framing members, however. 

The width and depth of fascia and eave fascia 
can be specified in the Build Framing dialog. 
See “Roof Panel” on page 595.

Shadow Boards

Shadow boards are added to both automatic 
and manually drawn roof planes when one 

Full Return

You can create a custom hotkey for
Build Fascia and Roof Trim. See “Hot-
keys” on page 138. 
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more shadow board profile is specified in the 
Build Roof dialog. They can also be added 
to, removed from, or customized for 
individual roof planes in the Roof Plane 
Specification dialog. See “Shadow Boards 
Panel” on page 488.

Automatically generated shadow boards are 

3D Molding Polylines  that follow the 
eaves of the roof. You can specify whether 
each profile is applied along eaves, along 
gable eaves, or along both. You can also use 
the same shadow board profile multiple 
times and adjust the offsets for each to suit 
different conditions. See “Molding 
Polylines” on page 664. 

Shadow boards are placed on the “Roofs, 
Trim” layer.  By default, this layer is locked, 
turned on in 3D views but not in plan view. 

If a shadow board polyline is edited, it will 
no longer be considered an Automatic 
shadow board, and will not be deleted and 
replaced if Fascia and Roof Trim is rebuilt. 

You can modify individual edges of an 
Automatic shadow board polyline indirectly 
by changing settings on the SHADOW 
BOARDS panel of the Roof Plane 
Specification dialog.

Soffits
Soffits are the layer of material that covers 
the rafter ends on the underside of roof eaves 
and can be constructed in several ways:
• By default, soffits follow the underside of 

the rafter ends and butt against the inside 
edge of the fascia. The rafter end depth 

and thus the soffit height is controlled by 
the Gable Sub Fascia Depth. See “Roof 
Panel” on page 595.

• Check Flat Under Eave Sub Fascia for 
soffits that follow the underside of the raf-
ter ends until they reach the eave subfas-
cia, at which point they flatten out until 
the butt against the inside of the fascia.

• Boxed eaves can be specified in the Build 
Roof and Roof Plane Specification dia-
logs. Boxed eave height is controlled by 
the Eave Sub Fascia Depth. See “Options 
Panel” on page 485.

Gutters
Gutters are added to non-sloping eaves on 
both automatic and manually drawn roof 
planes when Gutters is checked in the Build 
Roof dialog. They can also be added to, 
removed from, or customized for individual 
roof planes in the Roof Plane Specification 
dialog. See “Options Panel” on page 485. 

Automatically generated gutters are basically 

Molding Polylines  that follow the eaves 
of the roof but are not created on sloped 
gable eaves. 
• Gutters are regenerated or removed when-

ever the roof is built. See “Roof Panel” on 
page 481.

• A gutter profile can be specified. See 
“Gutter Panel” on page 487. 

• The gutter material can be specified. See 
“Materials Panel” on page 488. 

Gutters are placed on the “Roofs, Gutters” 
layer. By default, this layer is turned on in 3D 
views but not in plan view, is included in the 
materials list, and is locked. See “Layer 
Display Options Dialog” on page 149.

Note: In order to generate shadow boards,
you must also specify that fascia be used.
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Frieze Molding
Frieze moldings are added to both automatic 
and manually drawn roof planes when one or 
more frieze profile is specified in the Build 
Roof dialog. They can also be added to, 
removed from, or customized for individual 
roof planes in the Roof Plane Specification 
dialog.

Automatically generated frieze boards are 
placed along all exterior walls directly under 
the eaves. Frieze does not generate along 
railings; however, if an attic wall is built 
above a railing, it can generate along that 
wall. 
• Frieze moldings are generated whenever 

Build Fascia and Roof Trim is checked. 
See “Roof Panel” on page 481.

• You can specify whether each profile is 
applied under eaves, under gable eaves, or 
under both. You can also use the same 
profile multiple times and adjust the 
offsets for each to suit different 
conditions. See “Frieze Panel” on page 
488.

• The materials used for frieze moldings 
can be specified. See “Materials Panel” 
on page 488. 

Automatically generated frieze moldings are 

3D Molding Polylines  placed on the 
“Roofs, Trim” layer. By default, this layer is 
turned on in 3D views but not in plan view, 
and is locked. 

If a frieze molding polyline is edited, it will 
no longer be considered an Automatic freize, 
and will not be deleted and replaced if Fascia 

and Roof Trim is rebuilt. See “Frieze 
Moldings” on page 673.

Rafter Tails
Rafter tails are rafter ends that overhang the 
bearing walls and are located under the 
eaves. They can be the full rafter depth or 
trimmed to the depth of the soffits. Rafter 
tails can also be partially enclosed by soffits, 
and sometimes feature decorative profiles.

To produce a particular type of rafter tail, set 
the correct defaults on the STRUCTURE panel 
of the Build Roof dialog before you build 
both the roof planes and the roof framing. 
See “Roof Panel” on page 595.

To create full-depth exposed rafter ends
• Uncheck Soffits.
• Uncheck Eave Sub Fascia.
• Uncheck Eave Fascia.

To create hidden, trimmed rafter ends 
• Check Trim To Soffits. 
• Check Soffits.

To create full-depth, partially-exposed 
rafter ends
• Uncheck Trim To Soffits. 
• Check Soffits.
• Specify the desired Gable Sub Fascia 

Depth, which controls the soffit height.

Soffit height is determined by the depth
of the Gable Sub Fascia, which is set in

the Build Roof dialog. See “Structure Panel”
on page 487.
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To add a decorative profile to rafter tails
• Set soffits and fascia as needed to produce 

the desired rafter tail exposure, as 
described above. 

• Select a rafter tail profile on the RAFTER 
TAILS panel of the Build Roof dialog. See 
“Rafter Tails Panel” on page 487.

• Decorative rafter tail profiles are molding 
profiles, which means that you can create 
your own custom profiles if you want. See 
“Molding Profiles” on page 662. 

Ridge Caps
Ridge caps are roofing components that 
straddle the tops of roof ridges and hips. To 
generate ridge caps in Chief Architect, 
specify a ridge cap profile in the Build Roof 
dialog, and then build or rebuild the roof. 
Ridge caps will be produced on both 
automatically generated and manually drawn 
roof planes. See “Ridge Caps Panel” on page 
487.

The program’s default ridge cap profile has 
flat sides and is 1/2” (13 mm) thick and 6” 
(150 mm) on each side. It follows the pitch 
of each roof plane, and its thickness and size 
can be edited on the RIDGE CAPS panel. 

Ridge cap profiles are essentially a molding 
profile, though, which means that you can 

choose a different profile or molding symbol 
from the library or even create and use your 
own custom profile. See “Molding Profiles” 
on page 662. 

You can also use custom Symbol Moldings 
for ridge caps, but bear in mind that symbols 
cannot adjust their shape to match different 
pitches. As a result, different symbols will be 
required for different roof pitches. See 
“Symbol Moldings” on page 663. 

Like shadow boards and frieze molding, 
automatically generated ridge caps are 3D 
Molding Polylines  placed along the 
ridges and hips. Ridge Caps are created on 
the “Roofs, Ridge Caps” layer. By default, 
this layer is locked, displays in 3D views but 
does not display in floor plan view. 

If a ridge cap polyline is edited, it will no 
longer be considered an Automatic ridge cap, 
and will not be deleted and replaced if the 
roof is rebuilt. 

You can modify individual edges of an 
Automatic ridge cap polyline indirectly by 
changing settings on the RIDGE CAPS panel 
of the Roof Plane Specification dialog. Bear 
in mind, though, that your changes may only 
be reflected in the model if you make the 
same changes to adjacent roof planes, as 
well.
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Roof Pitches in Degrees
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Chapter 15:

Stairs, Ramps, and
Landings

Staircases can be composed of one or more 

straight or curved stair sections, ramps, and 
landings. Stairs and ramps can be drawn, 
selected and edited in 2D and 3D views.

Stair sections can be edited individually or as 
a group. Starter treads can be defined, stair 
sections can be flared, treads can be 
wrapped, and curved sections can be turned 
into winders. 

Landings can be created automatically or 
manually and their shape customized. You 
can edit an existing landing, or create a 
landing from a closed CAD polyline. 
Landing heights can be defined or you can let 
them automatically adjust as needed.

Stairwells can be created automatically or 
manually and can be seen in 3D views. 

Chapter Contents
•      Stair and Ramp Defaults
•      The Stair Tools
•      Anatomy of a Staircase
•      Drawing Stairs and Ramps
•      Displaying Stairs, Ramps, and Landings
•      Editing Stairs and Ramps
•      Merging Stair and Ramp Sections
•      Landings
•      Maintaining Tread Depth
•      Flared Stairs and Curved Treads
•      Starter Treads
•      Winders
•      Wrapped Stairs
•      Other Special Railings and Stairs
•      Creating a Stairwell
•      Rooms Below Staircases
•      Staircase Specification Dialog

Local building and fire authorities must
be consulted for specific stair construc-

tion codes and access requirements.
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•      Ramp Specification Dialog •      Stair Landing Specification Dialog

Stair and Ramp Defaults
Default settings for stairs and ramps 
determine the initial attributes of these 

objects when they are first created. Access 
the defaults by selecting Edit> Default 
Settings, then clicking the + beside Stairs 
and Ramps. Select an item and click the 
Edit button to open the defaults dialog 
associated with your selection. See “Default 
Settings vs Preferences” on page 74. 

The Stair and Ramp Defaults dialogs can 
also be accessed by double-clicking the Stair 
Tools  parent button or any child tool 
aside from the Landing tool. 

Both interior and exterior stairs have default 
definitions for size, style, materials and much 
more. In fact, the default dialogs for stairs 
and ramps are similar to the Staircase and 
Ramp Specification dialogs. See “Staircase 
Specification Dialog” on page 559 and 
“Ramp Specification Dialog” on page 570.

Interior and Exterior stairs are drawn using 
the same tools: stairs created inside of a room 
are considered Interior while those drawn 
outside of a structure are considered Exterior. 

Landings do not have a defaults dialog. 
Instead, they get their initial attributes from 
the stairs or ramps that they are connected to.  

Structural Defaults
The purpose of interior stairs is to provide 
passage from one floor platform to another, 
so the attributes that influence floor heights - 
including ceiling heights, floor platform 
thicknesses, and floor finish materials - also 
influence the structure of stairs. When 
considering a staircase’s structure, bear in 
mind that riser height is directly dependent 
on the distance from one floor platform to 
another. 

When Automatic Heights are used, stairs 
are built so that they rest on the top of the 
floor structure of the floor where they are 
drawn, and build up to the top of the floor 
structure on the floor above. Risers are 
measured to the floor finish surfaces on both 
floors. See “Floor and Ceiling Platform 
Definitions” on page 344. 

Ramps are built in a similar manner: interior 
ramps bear on the floor structure, and when 
Automatic Heights are used, the top surface 
of both interior and exterior ramps locates 
floor finish surfaces. 
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The Stair Tools
Select Build> Stairs to access the 
Stair Tools.

Straight Stairs
To draw a straight staircase select 
Build> Stairs> Straight Stairs, then 

click and drag in floor plan or a 3D view. 
You can also click once to place a staircase 
that extends from the current floor up to the 
next floor. See “Drawing Stairs and Ramps” 
on page 537.

Click Stairs
 Select Build> Stairs> Click Stairs to 
create stairs between levels on the 

same floor with a single click of the mouse. 
Click the low side, within a few feet of where 
the floor changes height. 
• If you click on the low side of a floor 

platform defined by a railing, a doorway 
will be created in the railing, adjacent to 
the stairs. 

• If you click on the low side of a floor 
platform defined by a wall, stairs will be 
created but a doorway will not.

• If you click at a location that is not near 
the edge of a floor platform, a full height 
staircase will be created.

Curved Stairs
Select Build> Stairs> Curve to 
Left or Curve to Right and click 

once in floor plan view to place a curved 
staircase. See “Curved Stairs and Ramps” on 
page 537.

Landing
Select Build> Stairs> Landing to 
draw a landing, which is a platform 

connecting two or more stair sections. See 
“Landings” on page 543.

There are two ways to create a landing using 
this tool:
• Click once to place a landing measuring 

39” (975 mm) on each side.
• Click and drag to draw a rectangular 

landing sized as needed. See “Polylines” 
on page 1097. 

You can also create a landing by converting a 
CAD polyline. See “Convert Polyline 
Dialog” on page 239.

Ramp
Select Build> Stairs> Ramp to draw 
a sloped ramp. By default, ramps are 

drawn at a 1:12 slope to a maximum height 
of 30” (760 mm). See “Drawing Stairs and 
Ramps” on page 537.

Anatomy of a Staircase
Stairs, as well as ramps, are often described 
in terms of rise and run. Rise is typically 
between 6" and 8", and the run between 10" 

and 12". In metric plans,  rise is 177 to 190 
mm, and the run is about 250 mm.
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Staircase Terminology
Balusters - The vertical members that run 
between the handrail and the treads or 
bottom rail. 

Bracket - Decorative L-shaped supports on 
the exposed side of stairs below each tread.

Landing - A platform connecting two or 
more stair sections.

Newels - The end post of a stair railing 
located at landings and the beginnings and 
endings of new stair sections.

Rise - The height of a riser, measured from 
tread surface to tread surface, Also referred 
to as Unit Rise. 

Rise Angle - The angle of the staircase or 
stair section, defined by a line drawn through 
the back surfaces of its treads.

Riser - The vertical stair member located 
between the treads. Risers may be solid or 
open. When open, the front surfaces of the 
stringers are considered the risers. 

Run - The depth of a tread, measured from 
riser surface to riser surface. Run does not 
include the Tread Overhang. Also referred to 
as Unit Run. 

Runner - The carpet that runs down the 
center of the staircase.

Shoe - The bottom railing, placed on the 
landing floor, that anchors the balusters at 
landings. 

Stringer - The inclined support member of a 
staircase that supports the treads and risers.

Tread - The horizontal member of a stair that 
the foot is placed on. 

Tread Overhang - The portion of a tread 
extending past the front surface of the riser 
and over the tread below. Also referred to as 
Nosing or Nosing Extension, it is not 
included in the Run or Tread Depth 
measurements.

Tread Thickness - The vertical depth of the 
tread material.

Winder - A wedge-shaped stair tread used 
where curved or angled stairways change 
direction.

Stair Structure and the Model
By default, stairs locate the height of the 
floor platform that they are drawn on and 
seek the next level, which may be the floor 
platform of the floor above or a landing. The 
stringers locate the subfloor of the floor 
platforms and maintain consistent riser 
height. If the stairs are long enough to reach 
the next level at a reasonable rise angle, their 
tread depth and number of treads are 
automatically calculated to create a staircase 
with consistent tread and riser dimensions 
along its entire length. 

You can modify this behavior or turn off it 
off altogether in the Staircase Specification 
dialog and specify your own rise and run 
values. Bear in mind, though, that if you turn 
it off, you will need to specify the correct 
Top and Bottom Heights to make sure that 
the stairs actually meet both floor platforms 
correctly. See “General Panel” on page 559. 

Stair Sections and 
Subsections

In Chief Architect, staircases can be 
composed of multiple sections and 
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subsections. See “Merging Stair and Ramp 
Sections” on page 541. 
• Stair sections are separated by landings.

• Subsections are considered part of the 
same section because they are connected 
to one another directly rather than sepa-
rated by a landing. 

Drawing Stairs and Ramps
Stairs and ramps can be drawn in floor plan 
and 3D views but not in cross section/
elevation views. In 3D views, these objects 
can only be drawn in the presence of a floor 
platform or terrain perimeter. See “Working 
in 3D” on page 920.

There are a few things to keep in mind when 
drawing stairs:
• Before stairs are created, make sure that 

the heights for both the lower and upper 
floors are correctly defined. 

• Stairs are drawn going UP, so they should 
be drawn from the lower of the two floors 
they connect. 

• By default, stairs adjust their riser and 
tread dimensions to connect two floor 
heights if possible. The rise and run are 
calculated so that the steps are consistent 
in size. 

• Stairs drawn within 1” (25 mm) of a wall 
will snap to the outer surface of the wall. 

• Stairs will snap to the Reference Display 

, if you have it turned on. See “Refer-
ence Floor Display” on page 444.

• If a stairwell room has been defined on 
the floor above, the top of the stairs can 
be dragged until it stops at the railing or 
wall defining the stairwell.

• When drawing stairs or a ramp up from 
the terrain, it is a good idea to make sure 

the terrain is up to date. See “Building the 
Terrain” on page 730.

Straight Stairs and Ramps

Straight Stairs  can be created in three 
different ways:
• Click and drag in a straight line to draw 

stairs that are the length that you drag.
• Click once to place stairs that go from the 

current floor up to the height of the next 
floor level.

• Click once using the Click Stairs  
tool to create stairs between rooms on the 
same floor with different floor heights or 
between exterior rooms and the terrain.

Similarly, Ramps  can be created by 
either clicking and dragging or by clicking. 
A ramp created with a single click will be 
30” (760 mm) high, have a slope of 1:12, and 
be 360” (9120 mm) long. 

An individual stair or ramp section must be 
between 6” (150 mm) and 100’ (30,000 mm) 
in length. If a greater length is needed, 
connect two sections using a landing.

Curved Stairs and Ramps
Curved Stairs can be created in 
floor plan view by selecting 

Build> Stairs> Curve to Left or Curve to 
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Right. Click to place a 90º curved stair 
section that can then be edited. You can 
continue clicking to place additional curved 
staircases until another tool is selected.

You can also curve straight stairs by drawing 
them against a curved wall.

In addition, you can change a straight stair 
section into curved stairs, or vice versa: 
• Select the stairs and click the Change 

Line/Arc  edit button. See “Change 
Line/Arc” on page 232.

• Select the stairs, hold down the Alt key 
(or right-click), and drag an end edit han-
dle. See “Alternate” on page 179.

Curved Ramps  can only be created by 
first creating a straight ramp and then 

clicking the Change Line/Arc  edit 
button.  

Drawing Stairs and Ramps 
Downward

Stairs and ramps can be drawn from the 
current floor level downward; however, 
drawing stairs or ramps between floors in 
this manner is not recommended. Drawing 
downward should only be used to create a 
staircase or ramp between a porch or deck 
and the terrain when you require the 
direction arrow to say “DN” instead of “UP”. 

To draw stairs going downward

1. Select Build> Stairs> Straight 
Stairs .

2. Hold down the Alt key or the right 
mouse button.

3. Click and drag to create straight stairs.

When drawing stairs or ramps from a floor 
platform to the terrain, or vice versa, they 
will locate the height of the terrain as long as 
it is lower than the floor height. You can also 
create a landing or “room” outside the 
structure and use it to establish the bottom 
height of the stairs or ramp. Then, draw in an 
upward direction from the lower platform to 
the upper platform. 

Straight stairs drawn along a curved wall

Alt+ 
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Displaying Stairs, Ramps, and Landings
The display of stairs, ramps, and 
landings in all views is controlled in 

the Layer Display Options dialog. Stairs, 
ramps, and landings are placed on the “Stairs 
& Ramps” layer by default but, once created, 
can be placed on any layer. See “Displaying 
Objects” on page 144.

In Floor Plan View
In floor plan view, stairs, ramps and landings 
display on the floor they were drawn on and 
are only visible from the floor above if there 
is a stairwell. See “Creating a Stairwell” on 
page 556.

Stairs and ramps have an arrow indicating 
the direction they run. Interior stairs and 
ramps have an UP arrow on the floor they 
were created on and a DN arrow when 
viewed from the floor above. See “Drawing 
Stairs and Ramps” on page 537. 

The style and size of the direction arrow can 
be specified in the Staircase or Ramp 
Specification dialog. The Text Style, color, 
and display are controlled by the “Stairs & 
Ramps, Up/Down Arrows” layer. See 
“Arrow Panel” on page 1088. 

Stair landings can also display labels in floor 
plan and cross section/elevation views when 
the “Polylines 3D, Labels” layer is turned on.  
Landings do not have an automatic label; 
however, you can specify a custom label in 
the Landing Specification dialog. See 
“Label Panel” on page 1280. 

You can specify whether newels, balusters, 
and/or rails display in floor plan view in the 

Staircase Specification dialog. See 
“Newels/Balusters Panel” on page 566. 

The display of stair and ramp overhangs and 
tread nosing in floor plan view can be 
controlled using the “Stairs & Ramps, 
Details” layer. The display of stair stringers 
in floor plan view is controlled using the 
“Stairs & Ramps, Stringers” layer. 

You can create custom labels for stairs, 
ramps, and landings using the Text Tools and 
custom text macros. See “Creating User 
Defined Text Macros” on page 1065. 

When a staircase is selected in floor plan 
view, the numbers associated with each of its 
sections and subsections display. Stair 
sections are assigned a single number, while 
subsection numbers have two parts: a section 
number and subsection number separated by 
a hyphen.

To see the center of a stair section curve in 
floor plan view, click Show Arc Centers 
and Ends . See “Arc Centers and Ends” 
on page 195. 

Stair Break Lines
In floor plan view, staircases can display a 
break line symbol. The portion of the 
staircase located above the break can display 

Stair section 
number

Stair subsection 
numbers
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as either a dashed outline with transparency 
or it can be suppressed altogether. See 
“Break Line Panel” on page 565.

A break line can be added to a selected 
staircase in either of two ways:

• Click the Add Break Line  edit but-
ton.

• Check Has Break Line in the Staircase 
Specification dialog.

A break line’s position along the staircase 
can be adjusted using the small, circular 
Move Break Line edit handle that displays 
along the break line, as well as in the 
Staircase Specification dialog.

To remove a break line from a staircase, click 

the Remove Break Line  edit button or 
uncheck Has Break Line. 

In 3D Views
Although stairs span between two floors, 
they can only belong to one floor. As a result, 
only multi-floor views show the upper floor 
with the platform opening and the lower 
floor with the staircase simultaneously. In 
Floor Cameras and Floor Overviews, 
stairwells may appear as an empty spaces. 
See “3D View Tools” on page 897.

Editing Stairs and Ramps
Staircases and ramps can be selected and 
edited in floor plan view and 3D views. See 
“Selecting Objects” on page 183. 

To select a single section of a staircase, hold 
down the Shift key before clicking on it. 
When selected in this manner, a stair section 
can be edited independent of any other 
connected stair sections.

Using the Mouse
When a staircase or ramp is selected, its edit 
handles display. These edit handles can be 
used to customize the object in many ways. 
See “Editing Objects” on page 177.
• Straight stair sections and ramps are 

edited like lines. They have additional 
edit handles for resizing the width of the 
section. See “Editing Line Based 
Objects” on page 187.

• Curved stair sections and ramps are 
edited like arcs and also include edit han-
dles for resizing the stair’s width. See 
“Editing Arc Based Objects” on page 
191.

• Ramps can be resized to a maximum top 
height of  30” (760 mm). If you extend a 
ramp’s length to greater than 360” (9120 
mm), it’s slope will decrease. For a taller 
ramp and control over the slope, uncheck 
Automatic Heights in the Ramp 
Specification dialog and specify the 
values you need. See “General Panel” on 
page 571.

• When stair sections are merged, the edit 
handles display differently depending on 
what subsection is currently selected. See 
“Merging Stair and Ramp Sections” on 
page 541.

• When moving merged stair or ramp sec-
tions, all merged sections move as one.
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• Additional edit handles display on the 
first two treads of a staircase if the 

Starter Tread  edit button is clicked. 
See “Starter Treads” on page 550. 

• Several additional edit handles display on 

a staircase if the Flare/Curve Stairs  
edit button has been clicked. See “Flared 
Stairs and Curved Treads” on page 547. 

In the Specification Dialog
Stairs and ramps can be customized 
and their structure precisely defined in 

the Staircase and Ramp Specification 
dialogs. See “Staircase Specification Dialog” 
on page 559 and “Ramp Specification 
Dialog” on page 570.

Using the Edit Tools
A selected staircase or ramp can be edited in 
a variety of ways using the buttons on the 
edit toolbar. See “The Edit Toolbar” on page 
37.

Adjusting the Radius 
of Curved Stairs

The easiest way to match the radius of a stair  
section to the radius of a curved wall is to 
draw a staircase near one side of the curved 

wall using the Straight Stairs  tool. The 
stairs snap to the wall, and the radius of the 
new staircase is defined. See “Curved Stairs 
and Ramps” on page 537. 

Existing curved stairs can be aligned with an 
existing curved wall by aligning their 
centers, much the same way that curved 
stairs on different floors can be aligned. See 
“Aligning Objects” on page 223.

If there is no curved wall, the radius of a stair 
section can be aligned to a CAD arc or circle.

To align curved stairs to an object 

1. Align the centers of the CAD object and 
the staircase. 

2. Select the curved stairs and move the 
side nearest to the arc or circle edge 
using the Resize edit handle. 

Finally, restore the stair width by dragging 
from the other side handle or using the Stair 
Specification dialog.

Merging Stair and Ramp Sections
Any combination of straight and curved stair 
sections or straight and curved ramps using 
Automatic Heights can be merged. The 
resulting staircase or ramp section is made up 
of subsections and, if there are no landings, 
functions as a single unit. 

Stair and ramp subsections must be drawn in 
the same direction if they are to be merged: 

• The top edge of a stair section or ramp 
cannot merge with the bottom edge of 
another section or ramp.

• Combinations of stairs drawn in the UP 
and DOWN directions cannot be merged. 

Stair subsections merge at the center points 
of their upper and lower edges. 
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Stair sections and ramps cannot be merged 
directly. If a combination of stairs and a ramp 
is required, connect them with a landing. See 
“Landings” on page 543.

To merge stair or ramp sections 

1. Confirm that the stairs or ramps that you 
wish to merge are using Automatic 
Heights. See “General Panel” on page 
559.

2. Position the sections so they are in the 
desired relationship to each other. 

•  In order to merge stair sections cor-
rectly, they must be parallel to one 
another.  

•  To create merged subsections that 
change direction, make one of the 
merged sections curved and then spec-
ify Winders. See “Winders” on page 
551.

3. Select either stair or ramp section so that 
its edit handles display.

4. Click the Extend handle on the end to be 
merged and drag it to the point where the 
two stairs or ramps are to meet. 

A staircase consisting of merged subsections 
resembles a single stair section in floor plan 
view. The UP (or DN) arrows join, becoming 
a single direction arrow. 

When a subsection is selected, the entire 
staircase is selected. Additional edit handles, 
indicating the presence of multiple 
subsections and allowing you to reposition 
the line along which they join.  See “Using 
the Mouse” on page 540.

Lock Tread Depth
If a staircase with Lock Tread Depth 
selected in the Staircase Specification 
dialog is resized, its length increases or 
decreases one full tread at a time. See 
“General Panel” on page 559. 

When Lock Tread Depth is checked, it can 
be difficult to merge the section with another 
section or landing. If this is a problem, you 
can temporarily uncheck Lock Tread Depth. 
After the stairs are merged, the tread depth 
can be locked again. 

Curved Subsections
Stair subsections attached at both ends by 
other sections do not have a free end that can 
be dragged into a curve. In this situation, 
change the middle sub-section to a curve 

using the Change Line/Arc  edit button. 
See “Change Line/Arc” on page 232.

To curve an enclosed stair subsection

1. Draw three straight stair sections and 
connect them end to end.

2. Select the middle subsection.
Merging parallel stair sections
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3. Click the Change Line/Arc  edit 
button. The center section turns into a 
curved stair section.

4. Use the triangular Change Curve edit 
handle to adjust the curvature of the 
middle section as needed.

Stairs joined in this manner can easily be 
turned into winders. See “Winders” on page 
551.

Landings
Stair landings are platforms between stair 
sections and/or ramps, and can be created in 
either of three ways:

• Using the Landing  tool. 
• By clicking between two stair sections 

using the Straight Stairs  tool.
• By converting a closed CAD polyline 

into a landing. See “Convert Polyline” on 
page 239.

To create a landing between stair sections:

1. Draw two stair sections going UP. They 
can be at any angle.

2. Click between the two sections using the 

Straight Stairs  tool to create a land-
ing. Notice that only one direction arrow 
displays after the sections are joined by 
a landing.

The middle stair subsection is selected After using Change Line/Arc

Creating a stair landing
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Similarly, a landing can be created between 
two ramps by clicking between them with the 

Ramp  tool active. 

Multiple stair sections and/or ramps can be 
connected to one landing. For example, two 
or three stair sections might meet at a landing 
with a single stair section continuing to the 
next level.

To be linked by a landing, all sections must 
be drawn in the same UP direction and the 
top of one section should be near the bottom 
of the next.

Stair sections connected with a landing will 
move together as a single unit unless Stair 
Sections Move Independently is checked in 
the Preferences dialog. See “Architectural 
Panel” on page 108.

A landing formed between two stair sections 
having less than a 90º angle between them 
are created with a short edge not less than 6” 
(150 mm). This is because most building 
codes require the shortest tread to be at least 
6” wide. This edge can be manually edited to 
less than 6” if needed.

Editing Landings
Landings can be selected in 2D and 3D 
views, both individually and in groups, and 
edited using the edit handles, the edit toolbar, 
and the Landing Specification dialog. See 
“Stair Landing Specification Dialog” on 
page 573. 

Landings derive their initial materials and 
railing characteristics from the stairs and/or 
ramps attached to them. You can assign a 
unique material to a landing in its 
specification dialog or using the Material 
Painter ; however, the railing style is 

always defined by the attached stairs or 
ramps. 

By default, landings have railings on all 
edges. You can suppress the railing on a 
selected edge by clicking the Remove 
Railing from Selected Edge  edit button. 
To restore a selected railing, click the Add 
Railing to Selected Edge  edit button. 
See “Selected Edge” on page 184. 

Custom Shaped Landings
Landings can be edited like other closed 
polyline-based objects. You can add or 
remove edges, convert an edge from straight 
to curved, or vice versa. A curved landing 
creates curved railings. See “Editing Closed-
Polyline Based Objects” on page 201.

You can also create a stair landing out of 
closed polyline created with the CAD tools 

using the Convert Polyline  edit button. 
See “Convert Polyline” on page 239.

You can edit the shape of a landing into a 
wide variety of shapes. So that the railings of 
stair sections connect properly to the landing 
railings, make sure that each stair section end 
is snapped to a landing edge with the same 
length as the stair’s width. If necessary, use 

the Break Line  tool to create a break in a 
landing edge if it is longer than the 
connecting stairs are wide. See “Break Line” 
on page 231.

Landing Height
A landing’s height can be either user-defined 
or controlled by the program.

A landing with a height that has not been 
specified by the user is considered unlocked, 
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and its height will adjust automatically as the 
stairs attached to it are modified so that the 
stairs maintain a consistent rise angle.

If you specify a landing’s height, that landing 
becomes locked and will maintain that height 
no matter how the stairs connected to it are 
adjusted.

Unlocked Landings
By default, new landings are unlocked, 
which means that their height is determined 
by the stair or ramp sections attached to it. 
An unlocked landing will automatically 
adjust its height as necessary to maintain the 
same riser height and rise angle for all 
attached sections. 

In this example, two stair sections with eight 
treads each are connected by a landing. 

Because the sections have the same number 
of treads, the landing height is one half of the 
distance between the two connected floors.

If a change is made to either stair section, the 
program will maintain the stairs’ connection 

to the floors above and below, and will 
instead modify the height of the landing and 
the other stair section so that a consistent 
riser height is maintained.

As long as a stair or ramp system consists of 
a landing connecting only two stair sections, 
the program can easily set landing heights 
and produce consistent a rise angle. If more 
than two stair sections meet at a landing, the 
relationship between them becomes more 
complex. In this situation, you may want to 
define the exact height of the landing instead 
of letting the program define it for you.

Locked Landings
A locked landing has a specifically defined 
height that does not adjust automatically 
when there are changes in the attached stairs. 
Instead, the stairs adjust to the landing. 

For example, start with the same staircase 
used to illustrate unlocked landings, with one  
change: the landing height is now defined at 
78 inches (1980 mm). Unlocked landings maintain 

   consistent riser height
 Locked landings produce 
independent stair sections
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Since the landing height is now closer to the 
upper floor than to the lower floor, the upper 
stair section has a very shallow riser height 
and the lower section has a tall riser height.

Stair and ramp sections attached to a locked 
landing no longer relate to one another: 
• Changes to one section do not affect the 

other. 
• The Staircase and Ramp Specification 

dialogs show only the selected section 
and those connected to it by unlocked 
landings, rather than the entire system.

• Locked landings do not move when 
attached stair or ramp sections are 
moved. Only unlocked landings and the 
sections attached to them will move.

Locked landing can be used to break up a 
complex network of stairs and landings into 
smaller pieces with known bottom and top 
heights. 

To lock a landing

1. Select the landing and click the Open 
Object  edit button to open the Stair 

Landing Specification dialog. See 
“General Panel” on page 573.

2. On the GENERAL panel, uncheck Auto 
Adjust Height When Connected to 
Stairs. 

3. Specify the desired Top Height and 
click OK. 

4. The landing moves to the specified 
height and all stairs that connect to that 
landing are redefined.

To unlock a landing, open its specification 
dialog, check Auto Adjust Height When 
Connected to Stairs, and click OK. The Top 
Height will automatically adjust to any stair 
or ramp sections attached to it and will try to 
produce a staircase with a single riser height. 

To move stair sections independently 
regardless of whether attached landings are 
locked or unlocked, select Stair Sections 
Move Independently in the Preferences 
dialog. See “Architectural Panel” on page 
108.

Maintaining Tread Depth
Most building codes require staircases to 
maintain a consistent tread depth. 

Walk Line
By default, Chief Architect measures a stair 
section’s length and tread depth along a Walk 
Line located 12" (30 cm) from the right edge 
of the stair section by default. On curved 

stairs, it is located 12” (30 cm) from the 
inside edge of the curve. 

The distance of the Walk Line from the 
staircase edge can be specified in the 
Staircase Specification dialog. See “Style 
Panel” on page 563.

Alternatively, you can turn the Walk Line 
feature off and tread depth will be measured 
at the tread center. 
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When a curved stair section has Automatic 
Treads specified in the Staircase 
Specification dialog and the Walk Line is 
used, the number and/or width of treads in a 
section or subsection changes when the inner 
edge is moved. For this reason, it is best to 
finalize stair section width as early as 
possible.

There are two ways to keep tread depth even 
throughout a stair section made of multiple 
subsections.

Lock Tread Depth
The first way to maintain tread depth is to 
Lock Tread Depth to a specified value in 
the Staircase Specification dialog. See 
“General Panel” on page 559. 

Once locked, any changes to the length of the 
stair section are achieved by keeping the 
specified tread depth and changing the 
number of treads. 

Ignore Subsection 
Boundaries

Curved stair sections typically have treads 
that are wider on one side than on the other. 
When they are connected to other stair 
sections, as with winders, it is possible to 
have treads that are too narrow at the Walk 
Line. See “Winders” on page 551. 

Uniform tread depth in a stair section with 
subsections can be maintained by checking 
Ignore Subsection Boundaries in the 
Staircase Specification dialog. See 
“General Panel” on page 559. 

When Ignore Subsection Boundaries is 
checked, the Tread Depth value may change 
when the stair section is edited, but will 
remain consistent throughout all subsections.  

Because the boundaries between stair 
sections are being ignored, the treads where a 
straight section joins a curved section may 
shift position or change angle to accomodate 
the adjustment.

Flared Stairs and Curved Treads
Any stair section can be flared and/or 
its treads curved using the Flare/

Curve Stairs edit button. 

Only exposed sides of a stair section can be 
flared. If one side of a stair section is against 
a wall or wrapped (see “Wrapped Stairs” on 

Walk Line at 12" Center Line



548

Chief Architect X8 Reference Manual

page 552), only the exposed end can be 
flared. 

Creating a Flared Stair
Flared stairs grow wider near one end, 
typically sweeping outward at the bottom. 
Stairs can also be flared at the top or on both 
ends.
 

To create flared stairs

1. Create the stairs and connect them to a 
landing, floor platform edge, or another 
stair section. 

2. Specify the section width, tread depth, 
and any other needed information.

3. Select the stairs and click the Flare/
Curve Stairs  edit button. New Flare 

edit handles display on all four corners 
of the stairs.

4. Drag one of the corner handles to flare 
that corner. As you drag the flare, the 
Status Bar shows the distance the side 
handle moves. This allows you to move 
the opposite handle the same amount.

5. When you are finished editing the flare, 

click the Main Edit Mode  to restore 
the stairs’ regular edit handles and tool-
bar buttons. 

Symmetrically Flared Stairs
Use the dimension information that displays 
in the Status Bar as a reference to create 
symmetric flares on both sides.

Adjusting the Flare Radius
After a flared staircase has been created, you 
may want to soften the radius of the flare.

Flaring, curved treads, and special
treads should be the last changes that

you make to any stairs.

Creating flared stairs

Flare 
dimensions 
display in the 
Status Bar

Flare 
dimensions 
display in the 
Status Bar

Creating symmetrically flared stairs
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The four handles at the sides and the four 
handles at the corners flare the stair section 
when dragged outward. The two handles in 
the center of the section move the starting 
point for flaring along the stair section.

To adjust the flare radius

First, adjust the curvature of the flared 
section.

1. Select the flared stair and click the 

Flare/Curve Stairs  edit button to 
access the flare handles again. 

2. Select the handle along the flared edge 
of the stair. Drag this handle outward 
very slightly. This forms a more gradual 
flare. 

Then, adjust the starting point of the flare:

1. Select the flared stair and click the 

Flare/Curve Stairs  edit button to 
access the flare handles again. 

2. This time, drag the lower of the two cen-
tral handles upward. The handle above it 
moves with it. This moves the start point 
for the bottom flare from the middle of 
the section toward its top, making the 
flare even more gradual.

Treads Perpendicular to Flare
Flared stairs often look best when the treads 
curve to meet the flared side perpendicular to 
the radius.

To curve the edges of flared treads

1. Select the flared stair and click the 

Flare/Curve Stairs  edit button to 
access the flare handles again. 

2. Drag a corner edit handle upward one 
tread depth or less.

3. When you are finished editing the curve, 

click the Main Edit Mode  to restore 
the stairs’ regular edit handles and tool-
bar buttons. 

This type of tread curving works only on 
flared edges and concentrates the curvature 
at that edge.

Adjusting the flare curvature

Adjusting the flare’s starting point

Curving the edges of flared treads
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Flared treads can also be curved using the 
Curve edit handle, which curves the treads 
more uniformly.

Curving the Treads
When treads are curved, all treads in the 
section show some degree of curvature. 
Treads close to the curved end have a greater 
curve than those at the opposite end, but both 
ends can be curved. 

To curve stair treads

1. Select the staircase, then click the Flare/
Curve Stairs  edit button. 

2. Drag the edit handle at the center of the 
bottom edge a small distance to curve 
the treads.

3. When you are finished editing the curve, 

click the Main Edit Mode  to restore 
the stairs’ regular edit handles and tool-
bar buttons. 

Starter Treads
The first and second treads of a 
staircase can be turned into starter 

treads by clicking the Starter Tread edit 
button. Starter treads extend to the side of the 
staircase, have rounded edges and are 
common on traditional staircases. 

A starter tread can be added only to open 
sides of a stair section. If one side of a stair 
section is against a wall or wrapped (see 
“Wrapped Stairs” on page 552), only the 
exposed tread end can become a starter tread. 

Creating curved stair treads
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To create starter treads

1. Click on a staircase to select it.

2. Click the Starter Tread  edit button. 
An edit handle displays on each end of 
both the first and second treads.

3. Drag either of the handles on the first 
tread outward from the stair section. If 
the stair section is against a wall, only 
one handle displays on the side opposite 
the wall.

4. As you drag, the ends of the tread 
become rounded.

5. Two additional edit handles display on 
each side of the tread, along the back 
edge. 

6. Drag either of the two square handles 
upward to increase the width of the 
rounded ends of the tread. 

7. Drag the edit handle on the second tread 
outward from the stair section to create a 
second starter tread. 

8. To make changes to existing starter 
treads, select the stairs, click the Starter 
Tread  edit button and repeat the 
above steps as needed. 

9. When you are finished editing the starter 

treads, click the Main Edit Mode  to 
restore the stairs’ regular edit handles 
and toolbar buttons. 

Winders
Winders are steps located where a staircase 
turns and are narrower on the inside of the 

turn than they are on the outside. A staircase 
defined as a winder expands to fill in any 
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gaps between the side of the stairs and 
nearby walls. 

Curved stair sections are typically used to 
create winders, although straight stairs can 
also be used. See “Curved Stairs and Ramps” 
on page 537.

To create winders

1. In an enclosed room area, place and con-
nect the stair sections that you want to 
be winders. For best results:

•  The stairs should be two straight sec-
tions connected by a curved section 
between them;

•  The curved section should be adjacent 
to a 90° corner, as illustrated.

 

2. Select the staircase and click the Open 
Object  edit button to open the 
Staircase Specification dialog. 

3. On the GENERAL panel, place a check in 
the Winders checkbox and click OK. 

4. The steps nearest the wall corner adjust 
their shapes and extend into the corner 
after the stair is changed to a winder. 

 

The Winders attribute directs the stair section 
to expand or contract to meet  nearby walls, 
and can also be used to create a partial 
railing. See “Partial Railings” on page 553.

Winders sometimes have treads that are too 
narrow at the inside curve. The Ignore 
Subsection Boundaries option can address 
this issue. See “Ignore Subsection 
Boundaries” on page 547.

Wrapped Stairs
Check Allow Wrap on the STYLE panel of 
the Staircase Specification dialog and the 
selected stairs can be wrapped around the 
corner of a deck or landing. Curved stairs 
and stairs with multiple subsections cannot 
be wrapped. See “Style Panel” on page 563.

Stair sections that wrap around a corner to 
meet one another must have identical 

attributes. As a result, edits made to one 
wrapped stair section apply to all adjacent, 
wrapped sections. 

To wrap stairs around a deck

1. Begin by drawing a deck. See “Decks” 
on page 340. 

It is often easiest to create the staircase
configuration in an open space, away

from walls, then move it into position in a wall
corner before specifying it as Winders. 

Winders must be in a room with valid
room definition. You cannot create

winders in an area composed of only 2 corner
walls. If this configuration is needed, enclose
the area in with Invisible walls so that a room
area is defined.

Winders extend to nearby walls
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2. Use the Click Stairs  tool to place a 
stair section on each side of the corner 
around which you want them to wrap.

3. Move the stair sections toward the cor-
ner of the deck. When the two sections 
are sufficiently close to the corner, they 
will merge to form wrapped steps.

To wrap stairs around a landing

1. Draw two perpendicular Straight 
Stair  sections.

2. Click between them to create a landing.
3. Rotate one stair section 180°. 

4. The stairs wrap around the corner. 
Notice that the Up arrow displays on the 
most recently edited stair section.

Other Special Railings and Stairs
Stairs can be customized to meet a variety of 
needs.

Partial Railings
A staircase can be enclosed on one side by a 
combination of wall and railing.

You can also draw stairs down from a
deck by right-clicking to draw them or by

pressing the Alt key while you drag. See “To
draw stairs going downward” on page 538.
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Partial railings can be created by specifying 
the stairs as winders and increasing the Max 
Tread Contraction in the Staircase 
Specification dialog. See “Style Panel” on 
page 563.

The Max Tread Contraction defines the 
largest distance that any section of the stair 
system is allowed to move inward when the 
stairs are turned into winders. If any point on 
the edge of the stairs would have to move 
inward more than this defined amount in 
order to locate the surface of the wall, the 
stairs do not contract and snap to that wall.

To create a partial stair railing

1. Create a staircase and draw an Interior 
Wall  against, but not underneath, the 
stairs.

2. Select the stairs and click the Auto 
Stairwell  edit button to create a 
stairwell.

3. On the GENERAL panel of the Staircase 
Specification dialog, check Winders.

4. On the STYLE panel, define the Max 
Tread Contraction. If the interior wall 
is 4" thick, setting this value to 4" should 
be sufficient. 

5. On the STYLE panel, increase the 
Stringer Bottom value to enclose the 
area under the stairs with railings. The 
best value depends on the design of your 
stairs.

6. On the NEWELS/BALUSTERS panel, 
remove the check from either Right or 
Left Railing at Wall, depending on the 
position of the stairs and wall in your 
plan.

7. Click the Object Snaps  toggle but-
ton to temporarily turn off Object Snaps. 
See “Object Snaps” on page 162.

8. Select the stairs and use the side edit 
handle to move the edge of the stairs to 
approximately the middle of the wall.

9. You may need to Zoom  in on the 
stairs and wall to move the stair edge.

Solid Railings
To create a solid rail along a staircase, 
position a solid Railing against, but not 
underneath, the stairs. Specify it as Solid and 
that it Follow Stairs. See “Rail Style Panel” 
on page 323.

Resizing stairs to the middle of the wall
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The solid railing recognizes the adjacent 
stairs and climbs alongside them. 

If any balusters extend beyond the railing, 
eliminate them by unchecking Left Railing 
or Right Railing in the Staircase 
Specification dialog. See “Style Panel” on 
page 563.

Railing Panels
You can use railing panels, including glass 
panels or cable, as stair railing instead of 
newels and balusters by drawing a 

Railing  under the stairs or ramp. 

To use railing panels with stairs

1. Create a staircase and draw a 

Railing  under the stairs. 

•  Make sure that the railing is located 
entirely within a single stair section.

•  Position it so that it is aligned with the 
left edge.

2. Select the railing and click the Open 
Object  edit button. See “Wall Speci-
fication Dialog” on page 308.

3. On the RAIL STYLE panel of the Railing 
Specification dialog, 

•  Select the Panels radio button.
•  Check Follow Stairs.

4. On the NEWELS/BALUSTERS panel, click 
the Browse button to the right of Panel 
Type and select the railing panel you 
want to use on the stairs, then click OK.

5. Select the staircase and click the Open 
Object  edit button. 

6. On the NEWELS/BALUSTERS panel of the 
Railing Specification dialog, uncheck 
Left Railing to prevent the default stair 
railing from generating in addition to the 
railing panel.

7. Repeat these steps if you want railing 
panels under the right side of the stairs, 
as well.

Inset or Middle Railing

Just as you can use a Railing  to place 
railing panels as stair or ramp railing, you 
can also use the same technique to create 
inset stair railings or a middle railing.

Solid Railing
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Concrete Stairs

To make a solid concrete staircase

1. On the STYLE panel of the Staircase 
Specification dialog: 

•  Set the Tread Overhang to zero. 
•  Set the Tread Thickness to zero.
•  Uncheck Open Risers.
•  If you want, you can also uncheck 

Open Underneath and check Large 
Stringer Base.

2. On the MATERIALS panel, specify the 
“Riser/Trim”, “Support Wall”, and 
“Tread” materials as concrete.

Masonry Stairs

To make a set of masonry stairs

1. On the STYLE panel of the Staircase 
Specification dialog: 

•  Set the Tread Overhang to zero. 
•  Set the Tread Thickness to the thick-

ness of the masonry material.
2. On the MATERIALS panel, assign the 

desired masonry material to the “Tread” 
component and specify the “Riser/Trim” 
material as concrete.

Steel Stringer

To make a steel stringer with concrete 
treads

1. On the STYLE panel of the Staircase 
Specification dialog, 

•  Check Open Underneath. 
•  Select the Single Stringer checkbox. 
•  Set the Tread Thickness to 2 inches or 

more.
•  Select the Single Stringer checkbox. 

2. On the MATERIALS panel, specify the 
“Tread” material as concrete and the 
“Riser/Trim” material as steel. 

Creating a Stairwell
An interior staircase must be located in a 
stairwell, an opening to the floor above. A 

stairwell is an Open Below room type on the 
floor above. See “Room Types” on page 335.
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If you create a stairwell away from other 
walls so the Open Below is created in the 
center of another room, connect a wall of the 
Open Below room to another wall using an 
invisible wall. 

Creating a Stairwell 
Automatically

To create a stairwell that matches the 
perimeter of a selected staircase, click 

the Auto Stairwell edit button. This button is 
only available when a living space exists 
above the staircase. It will not be available if 
the space above is Open Below or on the 
Attic Floor.

Auto Stairwell  automatically creates a 
room on the floor above enclosed by railings, 
defined as Open Below in the Room 
Specification dialog, and given a Stairwell 
room label. This room can be selected and 
edited like any other room.

Creating a Stairwell Manually
Stairwells can also be created manually. 

To create a manual stairwell

1. Draw a two-story building. Create the 
staircase on the first floor.

2. Make the second floor the Current 
Floor and the first floor the Reference 
Floor. See “The Reference Floor” on 
page 444.

3. Select Tools> Reference Floors> 
Reference Display  to show the Ref-
erence Floor, including the stairs. 

4. On the upper floor, use the Railing  
tool to create a room around the stairs. 
Use the edit handles to position the rail-
ings as needed. 

5. Select the railings one at a time and 
move them into position. 

•  When a railing is selected, its bounding 
box shows the location of the outer sur-
face of the railing’s drywall layer. For 
best results, this outer surface (which 
does not display when the railing is not 
selected) should meet the top edge of 
the stairs. See “Wall Types and Rail-
ings” on page 268.

•  If you prefer, you can also go Down 
One Floor  and adjust the top edge 
of the staircase to snap it to the surface 
of the railing on the floor above.

6. When the railings are positioned prop-
erly, select Tools> Reference Floors> 
Reference Display  to turn off the 
display of the Reference Floor.

7. Click inside the room using the Select 
Objects  tool to select it, then click 

the Open Object  edit button.
8. On the GENERAL panel of the Room 

Specification dialog, select “Open 
Below” from the Room Type list. Click 
OK to close the dialog.
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9. Place a Doorway  in the railing at the 
top step for an opening. 

10. Select the doorway and define a large 
width in the Door Specification dialog. 

If the doorway is specified wider than 
the railing, its width maximizes to fit the 
space available.

 

Rooms Below Staircases
Rooms such as closets or storage areas are 
commonly located beneath staircases.

To create a room below a staircase

1. Draw a staircase, select it, and click the 

Open Object  edit button to open the 
Staircase Specification dialog. 

•  If Winders are specified for this stair-
case, set Max Tread Contraction to 2" 
on the STYLE panel to allow walls to be 
built entirely under the staircase.

•  On the FILL STYLE panel, select None 
(Transparent) so the walls and other 
objects under the stairs can be seen.

2. On the same floor as the staircase, draw 

the Interior Walls  under them, fol-
lowing their shape. 

3. Reposition the walls as needed, making 
sure that each is entirely under the stairs.

4. The wall at the foot of the stairs should 
be placed no closer to the bottom than 
the second step.

5. Add a door and specify the Room Type.
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Staircase Specification Dialog
Staircases can be defined with the 
greatest accuracy in the Staircase 

Specification dialog. To open this dialog, 
select one or more stair sections and click the 
Open Object edit button or double-click a 

stair section using the Straight Stairs   or 
Select Objects  tool. 

If a staircase is composed of multiple stair 
sections, the section that you clicked on to 
select the staircase is the Selected Section; 

however, information about all the sections is 
available and can be edited in the dialog. 

The settings in the Staircase Specification 
dialog are similar to those in the Interior and 
Exterior Stair Defaults dialogs, but affect 
the selected staircase only. See “Stair and 
Ramp Defaults” on page 534. 

General Panel

It is recommended that all floor heights,
ceiling heights and platform thicknesses

be established before using the Staircase
Specification dialog.
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Staircase Information - Structural 
information about the selected staircase 

displays here for reference and updates as 
changes are made on the GENERAL panel. 
• The first comment tells whether or not 

the staircase reaches the next level, which 
may be a floor platform or locked land-
ing. It also indicates whether its rise 
angle is either steeper or more shallow 
than the Best Fit, described below. If 
Automatic Heights is unchecked, this 
comment instead says “Start and end 
heights are set manually”. 

• The second comment, Best fit riser 
height of ___ requires ___ total risers 
to reach ___ to next level, describes the 
ideal rise and run for the selected 
staircase. The program defines the Best 
Fit Riser Height as the riser height closest 
to 6 3/4” (168.75 mm) that allows the 
selected staircase to meet the next level 
precisely.  This comment is only active if 
Automatic Heights is checked, below.

If the staircase includes a locked landing, its 
height is used to calculate this information. 
See “Locked Landings” on page 545.
• The total number of stair Sections, 

Landings, and Risers associated with the 
selected staircase also display here. 

• The Rise Angle of the currently active 
stair section also displays here.

• Click the Make Best Fit button to add or 
remove risers to the Selected Section. 
Only available when Automatic Heights 
is checked and the staircase does not cur-
rently use the Best Fit Riser Height. 

Make Best Fit will also extend stairs drawn 
in a downward direction until they reach the 
terrain. See “Terrain Perimeter” on page 716. 

A diagram of a sample staircase’s structure 
displays here for reference, as well. 

The Advanced Options apply to all 
sections and subsections.

• Select Automatic Treads to have the 
program define the depth and number of 
stair treads. If the staircase has multiple 
sections, each may have different tread 
depths. 

• Select Lock Tread Depth to specify the 
Tread Depth for each stair section, below, 
and prevent them from changing. When 
Lock Tread Depth is selected and the 
length of the stairs is changed, the num-
ber of treads will change.

• Select Lock Number of Treads to spec-
ify the number of treads in each stair sec-
tion and prevent it from changing. When 
Lock Number of Treads is selected and 
the length of the stairs is changed, the 
tread depths will change.

• If multiple staircases or a staircase with 
multiple sections is selected, No Change 
may be an option as well. Select this to 
maintain the multiple sections’ individual 
settings. 

• Uncheck Automatic Heights if you 
would like to specify the bottom and top 
heights of each stair section, as measured 
from the default floor height of Floor 1, 
0” (mm). When checked, the program 
automatically defines the top and bottom 
heights by precisely locating floor plat-
forms and landings. This option cannot 
be disabled in the Interior and Exterior 
Stair Defaults dialogs.

The Top Height Reference values control 
what point on the staircase the Top Height 
value, below, describes. 

1

2
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• Select Floor/Landing for the Top Height 
value to describe the height of the top 
tread plus the stated Riser Height.

• Select Top Riser for the Top Height 
value to describe the height of the top 
riser. 

• Check Ignore Subsection Boundaries to 
maintain tread depth throughout a stair 
section composed of merged subsections, 
regardless of whether the subsections 
have different tread depths assigned to 
them. See “Ignore Subsection Boundar-
ies” on page 547.

• Select Lock Bottom to lock the position 
of the selected stair section’s bottom end 
to prevent it from moving. Sections and 
landings below the selected section do 
not move when you click OK, while 
those above do move. 

• Select Lock Top to lock the position of 
the selected stair section’s top end to pre-
vent it from moving. Sections and land-
ings above the selected section do not 
move when you click OK, while those 
below do move.

Lock Bottom and Lock Top are actions 
rather than settings and are not available in 
the Stair Defaults dialogs. If you make 
changes to a staircase that will affect its 
length, first lock either the bottom or top end 
of the Selected Section to prevent it from 
moving. The height of the Selected Section’s 
locked end is not affected by these settings - 
only its position on the X/Y axis.

The specifications for each stair section 
and subsection are listed and can be 

edited here. Up to ten items total can display. 

A change in one value usually affects other 
values. You may need to reposition the 
staircase after making changes.
• The Section Number column identifies 

the Selected Section and the number of 
each section of the selected staircase. If 
Ignore Subsection Boundaries is 
unchecked, subsection numbers are also 
identified. The radio button to the left 
indicates which section or subsection is 
selected. See “Displaying Stairs, Ramps, 
and Landings” on page 539.

• Define the Length, or run, of each sec-
tion or subsection measured along the 
Walk Line. The length is equal to the 
number of treads multiplied by the tread 
depth. See “Walk Line” on page 546.

When the length of a section changes, 
other sections and landings in the stair-
case unit move in response. You can 
specify whether the bottom or top edge of 
the Selected Section moves when you 
resize it by selecting either the Lock Bot-
tom or Lock Top radio button, above. 

• Define the Width of each section. Only 
one width can be defined for a section, so 
all subsections in the same section have 
the same width. If a section is connected 
to a landing, its width should equal the 
length of the landing edge that it connects 
to. See “Landings” on page 543. 

• Specify the Tread Depth, or run, of each 
stair tread in the selected section. To lock 
this value, check Lock Tread Depth, 
above. 

If you select a staircase by clicking near
its bottom end, Lock Top will be

selected; if you select it near its top end, Lock
Bottom will be selected. 

3
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If a landing is created between two stair 
sections and one of them has locked tread 
depth, the resulting staircase also has locked 
tread depth. Any landings or sections 
connected to this new staircase adjust to meet 
it and then have locked tread depth as well. 
• Define the number of Treads in a stair 

section or subsection. To lock this value, 
select Lock Number of Treads, above.

• Define the Bottom Height, the height of 
the stair section’s bottom edge. To lock 
this value, click the radio button to the 
left of the section’s number, then click the 
Lock Bottom radio button, above, and 
click OK.

• Define the Top Height, the height of the 
stair section’s top edge. To lock this 
value, click the radio button to the left of 
the section’s number, then click the Lock 
Top radio button, above, and click OK. 

• Define the Riser Height, the height of 
the risers in each stair section. 

• Check Winders to specify the Selected 
Section, including subsections, as wind-
ers. See “Winders” on page 551. 

A preview of the selected staircase 
displays on the right side of the panel. 

If the staircase includes any landings, only 
the section that was selected when the dialog 
was opened will display. See “Dialog 
Preview Panes” on page 41. 

4
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Style Panel

Specify the attributes of the selected 
staircase’s Stringers, which are the 

angled support members that support the 
treads. See “Anatomy of a Staircase” on page 
535. 
• Specify the height of the Stringer Top 

when Stringer at Wall or Closed 
Stringer is selected. This is measured 
from the top front corner of a tread. 

• Specify the height of the Stringer Bot-
tom, as measured from the bottom back 
corner of a tread. 

• Check Stringer at Wall to produce a 
raised stringer top baseboard at the sides 
of the stair sections against walls. This 
baseboard follows the slope of the stair.

• Check Single Stringer to form a single 5-
inch (125 mm) thick stringer in the center 

1
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of the staircase. Checking Single 
Stringer automatically checks Open Ris-
ers and unchecks Stringer at Wall and 
Closed Stringer. 

• Check Closed Stringer to raise the tops 
of the exposed stringers to cover the sides 
of the treads. If this is checked, no central 
stringer is applied to open riser stairs. 
This setting only affects those stringers 
that are not against a wall.

• Check Large Stringer Base to widen the 
stringers at the foot of the staircase. This 
is helpful when walls are created below 
the stairs.

• Extend Stringer Top is checked by 
default and extends a triangular portion 
of the stringer under the landing or plat-
form at the top of the stairs.

The Open Options control whether the 
selected stairs have open risers or an 

open underside. They are not available when 
Single Stringer is checked, above. 
• Specify the Side Inset of the skirt below 

the staircase. The default value of 0 
aligns the skirt with the outside of the 
surface of the stringers. Only available 
when Open Underneath is unchecked.

• Uncheck Open Underneath to add a 
skirt below the staircase along the two 
sides. It looks like a wall in 3D, but only 
has a single face. Base molding does not 

generate along the bottom of the skirt, 
and doors cannot be placed in it. In most 
cases, the recommended way to enclose 
the area beneath stairs is to use walls. See 
“Rooms Below Staircases” on page 558.

• Check Open Risers to eliminate the riser 
face under each tread and expose the 
stringers. If Closed Sides is also selected, 
no central stringer is supplied.

Specify the attributes of the staircase’s 
carpet Runner. A runner is added to all 

sections connected by unlocked landings. 
Only available when Open Risers is 
unchecked, above.
• Specify the Runner Width. The default 

value of 0 does not create a runner. 
• Uncheck Runner Tucked to have the 

runner drop straight down from the tread 
front to the riser below. This is checked  
by default. 

Winder - Define the Max Tread 
Contraction, which is the amount a 

tread’s width may be reduced when it meets a 
wall. See “Partial Railings” on page 553.
This option only takes effect when the stairs 
are specified as Winders on the GENERAL 
panel. 

Specify the characteristics of the 
staircase Treads. See “Anatomy of a 

Staircase” on page 535.
• Specify the Tread Overhang, which is 

the distance that each tread overhangs the 
riser.

• Specify the Tread Thickness.

Check Use Walk Line to have the 
program calculate the tread depth based 

on a Walk Line. Uncheck the box to disable 
this function. See “Walk Line” on page 546.

Large Stringer Base shown at right
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• Specify the distance of the Walk Line 
from Edge. The default value is 12” 
(300 mm).

• Check Show Walk Line to show the 
Walk Line in floor plan view.

Specify the appearance of the staircase 
where it meets the Top Landing. These 

options do not affect the edges of landings.
• Check Nosing at Top Landing to pro-

duce tread nosing attached to platform 
edge at the top of stairs. 

• Check Riser Surface at Top Landing to 
produce a riser surface against the plat-
form edge at the top of the stairs. This 
allows stair risers to match all the way to 
the top of the platform.

Options - 

• Check Automatic Railing Openings to 
automatically create a doorway opening 
when the selected stairs are snapped to a 
railing drawn on the same floor as the 
stairs. This is checked by default.

• Check Allow Wrap to wrap the selected 
stairs around the corner of a deck or land-
ing where another, identical stair section 
is present. See “Wrapped Stairs” on page 
552.

A preview of the selected staircase 
displays on the right side of the panel. 

If the staircase includes any landings, only 
the section that was selected when the dialog 
was opened will display. See “Dialog 
Preview Panes” on page 41. 

Break Line Panel

7
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Check Has Break Line to display a 
break line on the selected stairs and 

enable the settings that follow. 
• Select the break line symbol Style from 

the drop-down list.
• Specify the Distance from Start, which 

is the distance from the front of the stairs 
to the break line, measured from the 
staircase’s center line. 

• Specify the Break Line Angle. An angle 
of 0° produces a break line that is 
perpendicular to the sides of a straight 
stairwell.

• Specify the Gap After Break, which is 
the gap between the section of the stairs 
located below the break line and that 
located above it. A value of 0 produces 
no gap.

• Specify the Break Symbol Size, which is 
the total height of the break symbol 
measured from top corner to bottom 
corner. 

The Current Floor Display settings 
control the appearance of the portion of 

the staircase located After the Break Line, 
or upslope from it, on the floor where the 
stairs were drawn. 
• Select Normal to display the staircase 

after the break line using the same Line 
and Fill Styles as the portion located 
before the break line. 

• Select Normal to display the staircase 
after the break line with the Line and Fill 
Styles specified for the staircase. 

• Select Outline to display the staircase 
after the break line using the Line Style 
assigned to the “Stairs & Ramps, Details” 
layer and a transparent fill. 

• Select Nothing to hide the display of the 
staircase after the break line entirely. 

The Floor Above Display settings 
control the appearance of the portion of 

the staircase located Before the Break Line, 
as seen from the floor above the stairs. 
• Select Normal to display the staircase 

before the break line using the same Line 
and Fill Styles as the portion located after 
the break line. 

• Select Outline to display the staircase 
before the break line using the Line Style 
assigned to the “Stairs & Ramps, Details” 
layer and a transparent fill. 

• Select Nothing to hide the display of the 
staircase before the break line entirely. 

A preview of the selected staircase 
displays on the right side of the panel. 

If the staircase includes any landings, only 
the section that was selected when the dialog 
was opened will display. See “Dialog 
Preview Panes” on page 41. 

Newels/Balusters Panel
The settings on the NEWELS/BALUSTERS 
panel will also affect the appearance of 

1

2
Note: Stairs located on the floor below can
only be seen if a Stairwell room is defined
above them. See “Creating a Stairwell” on
page 556.
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railings on any landings attached to the 
selected staircase. See “Landings” on page 
543.

These settings are similar to those found on 
the same panel of the Ramp Specification 
and Defaults dialogs. See “Ramp 
Specification Dialog” on page 570.

Specify how the Railing is applied to 
the selected staircase. 

• Stair Rail Height defines the height from 
tread surface directly over the riser to 
railing top. 

• Landing Rail Height defines the height 
of the landing rail top from the landing 
surface.

• Railing On - Select Left and/or Right to 
specify placement of railings on stair sec-
tions.

• Railing at Wall - Select Left and/or 
Right to specify the placement of wall 
railings. Not available for ramps.

1
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• Check Railing Transitions on Left and/
or Right to create “gooseneck” connec-
tions between stair and landing railings. 
This option only has an effect when Rail 
Passes Over Newel is checked. Not 
available for ramps.

• Check Smooth Transitions on Left and/
or Right to specify the placement of 
smooth connections between stair and 
landing railings. Not available for ramps. 

Check both Railing Transitions and 
Smooth Transitions to produce a handrail 
like this:

• Check Include Bottom Rail on Land-
ings to place a low rail on the landing 
surface that receives the balusters ends. 

• Bracket Type - Click the Library button 
to apply a 1/4” (2 mm) thick decorative 
bracket to the exposed sides of the string-
ers, under each riser. A side stringer with 
brackets will be moved in moved in 1/4” 
(2 mm) to accommodate the bracket.

Newel/Balusters options - 

• Newel Type - Select Square, Round, or 
Library newels. Selecting Library from 
the drop-down list is the same as clicking 
the Library button to the right and 
allows selection of a newel from the 
library.

• Specify the Newel Width, which is the 
width or diameter of each newel. For 

2
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Library newels, this is the width at its 
widest point.

• Specify the Newel Height, which is the 
height from the landing surface to the top 
of the newel. This is used only when Rail 
passes over Newel is unchecked.

• Check Newels at First Tread to place a 
newel where the rail starts at the base of 
the stairs. A newel is placed only on a 
side of the stairs not against a wall. 

• Uncheck Rail Passes Over Newel, then 
adjust the Newel Height to as needed. 
When this is checked, the Newel Height 
setting is ignored.

• Baluster Type - Select Square, Round, 
or Library balusters. Selecting Library 
from the drop-down list is the same as 
clicking the Library button to the right 
and allows selection of a baluster from 
the library.

• Specify the Baluster Width, which is the 
width or diameter of each baluster. For 
Library balusters, this is the width at its 
widest point. 

• Cut Baluster Top - Each tread normally 
has two to three balusters, growing lon-
ger toward its back. The default is to use 
the same baluster and cut it off at the bot-
tom to shorten it toward the tread front. 
Check this box to cut the balusters at the 
top instead.

The Plan Display Options control the 
display of newels, balusters, and rails in 

floor plan view. See “In Floor Plan View” on 
page 539.
• Uncheck Use Defaults to enable the set-

tings that follow. When this is checked, 
the options set in the Staircase Defaults 
dialog are used.

• Check Draw Newels to display newel 
posts in floor plan view. Note that newels 
at the top of the staircase are associated 
with the railings defining the stairwell. 
See “Creating a Stairwell” on page 556. 

• Check Draw Balusters to display balus-
ters in floor plan view.

• Check Draw Rails to display the hand-
rails in floor plan view.

• Click the Fill Style button to open the Fill 
Style dialog and specify the fill style for 
newels, balusters, and/or rails, when set 
to display.

To display newels/balusters under the 
handrails, specify a Fill Style of “None”. 

A preview of the selected staircase 
displays on the right side of the panel. 

If the staircase includes any landings, only 
the section that was selected when the dialog 
was opened will display. See “Dialog 
Preview Panes” on page 41. 

Handrail Panel
The settings on the HANDRAIL panel are 
similar to those on the RAILS panel of the 
Wall Specification dialog. See “Rails Panel” 
on page 326.

Four unique Handrail at Wall Options are 
available on this panel for stairs:

• Specify the Extend Bottom value, which 
is the distance that the bottom of each 

3
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railing section extends past the bottom 
riser of its corresponding stair section. 

• Specify the Extend Top value, which is 
the distance that the top of each railing 
section extends past the top riser of its 
corresponding stair section. 

• Check Add Return at Bottom to add a 
return to the wall at the bottom end of all 
railing sections that are against a wall.

• Check Add Return at Top to add a 
return to the wall at the top end of all rail-
ing sections that are against a wall.

The settings on the HANDRAIL panel will also 
affect the appearance of railings on any 
landings attached to the selected staircase. 
See “Landings” on page 543. 

Line Style Panel
The settings on the LINE STYLE panel are 
available for a variety of other objects in the 
program. For information about these 
settings, see “Line Style Panel” on page 
1085.

Fill Style Panel
The settings on the FILL STYLE panel affect 
the appearance of the selected staircase in 
floor plan view. For information about these 
settings, see “Fill Style Panel” on page 1099.

Materials Panel
The settings on the MATERIALS panel affect 
the appearance of the selected staircase in 3D 
views and are available for a variety of 
objects throughout the program. For 
information about these settings, see 
“Materials Panel” on page 852.

The settings on this panel will also affect the 
materials applied to any landings attached to 
the selected staircase. See “Landings” on 
page 543.

Arrow Panel
The settings on the ARROW panel control the 
appearance of the selected staircase’s 
direction arrow in floor plan view. See “In 
Floor Plan View” on page 539.

For information about these settings, see 
“Arrow Panel” on page 1088.

Ramp Specification Dialog
Ramps can be defined with the 
greatest accuracy using the Ramp 

Specification dialog. To open this dialog, 
select one or more ramps and click the Open 

Object edit button or double-click a ramp 

section using the Ramp  or Select 
Objects  tool. 
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General Panel

A diagram of a sample ramp’s structure 
displays here for reference. 

Size - Specify the Ramp Length and 
Width.

Specify the Heights of various key 
locations on the selected ramp. 

• Uncheck Automatic Heights/Slope to 
activate the settings below, then specify 
the height and slope of the ramp. 

• Specify the Top Height, which is the 
height of the ramp at its high end.

• Specify the Bottom Height, which is the 
height of the ramp at its low end.

• Specify the Base Height, which is the 
height of the bottom surface of the ramp.

1

2

3



572

Chief Architect X8 Reference Manual

Specify the ramp’s Slope by typing its 
Rise value in the first field, and the 

Run value in the second field. See “Anatomy 
of a Staircase” on page 535. 

Options - 

• Check Automatic Railing Openings to 
automatically create a doorway opening 
when the selected ramp is snapped to a 
railing drawn on the same floor as the 
ramp. This is checked by default.

• Check Open Underneath to remove the 
skirt around the bottom of the ramp so 
that it has a uniform, sloped thickness 
that may not reach the floor or terrain at 
the high end. This is unchecked by 
default.

• Specify the Max Thickness, which is the 
ramp’s maximum thickness. At the low 
end of the ramp where it meets the floor 
or terrain, its thickness may be less than 
this value. 

Specify the structure of the ramp’s 
Tread, which an optional surface layer 

placed over the top of the ramp.
• Check Has Tread Surface to apply a top 

tread surface to the ramp and enable the 
settings below. 

• Specify the Tread Overhang, which is 
the distance the tread surface extends past 
the ramp’s edges. 

• Specify the Tread Thickness, which is 
the tread surface’s vertical depth. 

A preview of the selected ramp displays 
on the right side of the panel. If the 

ramp is composed of multiple sections 
separated by landings, only the section that 
was selected when the dialog was opened 

will display. See “Dialog Preview Panes” on 
page 41. 

Newels/Balusters Panel
The settings on the NEWELS/BALUSTERS 
panel will also affect the appearance of 
railings on any landings attached to the 
selected ramp. See “Landings” on page 543.

The settings on the NEWELS/BALUSTERS 
panel are similar to those on the same panel 
in the Staircase Specification dialog. For 
more information, see “Newels/Balusters 
Panel” on page 566.

Selected Line Panel
The SELECTED LINE panel is available when 
the selected ramp section is straight as 
opposed to curved. See “Selected Edge” on 
page 184.

The settings on this panel are available for a 
variety of other objects in the program. For 
information about the settings on this panel, 
see “Line Panel” on page 1084.

Selected Arc Panel
The SELECTED ARC panel is available only 
when the selected ramp section has been 
converted to an arc. See “Change Line/Arc” 
on page 232.

The settings on this panel are available for a 
variety of other objects in the program. For 
information about these settings, see “Arc 
Panel” on page 1093.

Handrail Panel
The settings on the HANDRAIL panel are 
similar to those on the same panel of the Wall 
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Specification dialog. See “Rails Panel” on 
page 326.

The settings on the HANDRAIL panel will also 
affect the appearance of railings on any 
landings attached to the selected ramp. See 
“Landings” on page 543.

Line Style Panel
The settings on the LINE STYLE panel are 
available for a variety of other objects in the 
program. For information about these 
settings, see “Line Style Panel” on page 
1085.

Fill Style Panel
The settings on the FILL STYLE panel affect 
the appearance of the selected ramp in floor 
plan view. For information about these 
settings, see “Fill Style Panel” on page 1099.

Materials Panel
The settings on the MATERIALS panel affect 
the appearance of the selected ramp in 3D 
views and are available for a variety of 
objects throughout the program. For 
information about these settings, see 
“Materials Panel” on page 852.

The settings on this panel will also affect the 
materials applied to any landings attached to 
the selected ramp. See “Landings” on page 
543.

Arrow Panel
The settings on the ARROW panel control the 
appearance of the selected ramp’s direction 
arrow in floor plan view. See “In Floor Plan 
View” on page 539.

For information about these settings, see 
“Arrow Panel” on page 1088.

Stair Landing Specification Dialog
Select a landing and click the Open 
Object edit button to open the Stair 

Landing Specification dialog. See 
“Landings” on page 543.

General Panel
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Uncheck Auto Adjust Height When 
Connected to Stairs to specify the selected 
landing’s Top Height. 
• A free-standing interior landing will have 

a default Top Height of 6 3/4” (169 mm) 
plus the thickness of the default floor fin-
ish. A free-standing exterior landing will 
have a default top height equal to its 
thickness. When this box is checked, the 
landing height may adjust as needed to 
maintain consistent riser height in all 
connected stair sections. 

• The Top Height field is only active when 
Auto Adjust Height When Connected to 
Stairs is unchecked. See “Locked Land-
ings” on page 545. 

Uncheck Auto Adjust Thickness When 
Connected to Stairs to specify the selected 
landing’s Thickness. 
• A free-standing landing will have a 

default thickness of 6 3/4” (169 mm). 
When checked, the thickness is based on 
the riser height of the stair sections it is 
attached to, or the thickness of the ramps 
it is attached to.

• The Thickness field is only active when 
Auto Adjust Thickness When Connected 
to Stairs is unchecked. 

Check No Rail on Selected Edge to suppress 
the railing on the selected edge of this 
landing. See “Selected Edge” on page 184.

Polyline Panel
The POLYLINE panel states the length of the 
landing’s Perimeter, its enclosed Area, and 
its Volume. 

The settings on the this panel are available 
for a variety of other objects in the program. 
See “Polyline Panel” on page 1098.

Selected Line Panel
The SELECTED LINE panel is available when 
the selected edge is a line as opposed to an 
arc. See “Selected Edge” on page 184.

The settings on this panel are available for a 
variety of other objects in the program. See 
“Line Panel” on page 1084.

Moving the Start of a line segment moves the 
end of the previous connected line. Similarly, 
moving the End of a line segment moves the 
start of the next connected line.

Selected Arc Panel
The SELECTED ARC panel is available only 
when the selected edge has been converted to 
an arc. See “Change Line/Arc” on page 232.

The settings on this panel are available for a 
variety of other objects in the program. See 
“Arc Panel” on page 1093.

Line Style Panel
The settings on the LINE STYLE panel are 
available for a variety of objects throughout 
the program. See “Line Style Panel” on page 
1085.

Fill Style Panel
The settings on the FILL STYLE panel affect 
the appearance of the selected landing in 
floor plan view. See “Fill Style Panel” on 
page 1099.
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Materials Panel
When a landing is attached to stairs or a 
ramp, its initial materials are derived from 
the stairs or ramp. When the landing is 
attached to a ramp, its top surface material is 
defined by the Landing Sides component 
unless the ramp is using a Tread material.  

The settings on this are available for a variety 
of objects throughout the program. For 
information about these settings, see 
“Materials Panel” on page 852.

Labels for stair landings display in floor plan 
view and cross section/elevation views when 
the “Polylines 3D, Labels” layer is turned on 

and use the Text Style assigned to that layer. 
See “Displaying Stairs, Ramps, and 
Landings” on page 539. 

Label Panel
Labels for stair landings display in floor plan 
view and cross section/elevation views when 
the “Polylines 3D, Labels” layer is turned on 
and use the Text Style assigned to that layer. 
See “Displaying Stairs, Ramps, and 
Landings” on page 539. 

For information about the settings on this 
panel, see “Label Panel” on page 1280.
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Chapter 16:

Framing

In Chief Architect, framing can be produced 
both manually and automatically, calculated 
in the Materials List, as well as listed in a 
schedule. 

Manual framing members are drawn by 
clicking and dragging, like drawing a CAD 
line. Automatic framing for the major 
components of a 3D model (floors, ceilings, 
walls and roofs) can be generated using the 
Build Framing dialog. 

Both manually drawn and automatically 
generated framing members can be selected 
and edited in 2D and 3D views.  

Trusses are covered in their own chapter, 
“Trusses” on page 615.

Chapter Contents
•      Framing Defaults
•      Manual vs. Automatic Framing
•      The Framing Tools
•      Build Framing Dialog
•      Framing Reference Markers
•      Joist Direction Lines
•      Bearing Lines
•      Displaying Framing
•      Editing Framing
•      Keeping Framing Current
•      Framing and the Materials List
•      Framing Specification Dialog
•      Framing Schedules
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Framing Defaults
Select Edit> Default Settings to open 
the Default Settings dialog. Select 

Framing from the list, then click the Edit 
button to open the Framing Defaults dialog. 

The Post, Floor Beam, and Roof Beam 
Defaults dialogs can also be accessed by 
double-clicking the respective drawing tools. 

Both automatic and manually-drawn framing 
are generated according to the settings in the 
Framing Defaults dialog. 

This dialog is nearly identical to the Build 
Framing dialog in both appearance and 
function. The only difference is that the 
Build Framing dialog has checkboxes that 
allow you to automatically generate different 
types of framing in your plan. See “Build 
Framing Dialog” on page 586.

Any changes made in the  Framing Defaults 
or Build Framing dialogs will affect 
subsequently drawn or generated framing, 
but not framing already present in the plan. 

Floor and Ceiling Framing
Floor and ceiling platform depths contribute 
to the overall height of a structure, so their 
default values should be set as early as 
possible. See “Floor Panels” on page 586. 

If you plan to draw floor trusses, also see 
“Trusses Panel” on page 597. 

The default floor and ceiling platform 
settings for a given floor can be overridden 
on a room by room basis in the Room 
Specification dialog, or for individual 

platforms using Joist Direction  lines. 
See “Structure Panel” on page 352 and “Joist 
Direction Lines” on page 601.

Deck rooms have special automatically 
generated framing and are not affected by the 
settings in the Framing Defaults or Build 
Framing dialogs. See “Decks” on page 340. 

Wall Framing
Like other types of framing, wall framing is 
generated based on settings in the Framing 
Defaults dialog. See “Wall Panel” on page 
589 and “Openings Panel” on page 590.

In addition, wall framing is dependent on 
settings from other sources:
• The wall type definition settings used by 

each wall type in the plan - particularly, 
the Layer Thickness and Layer Material 
assigned to the Main Layer. See “Wall 
Type Definitions Dialog” on page 305.

• The Thickness and O.C. Spacing of the 
framing material assigned to each wall 
type used in a plan. See “Material Types” 
on page 860.

• The structural specifications for individ-
ual walls in the plan. See “General Panel” 
on page 309.

In order for wall framing to automatically 
generate, a wall’s framing layer must be set 

The settings in the Framing Defaults
dialog directly affect a variety of impor-

tant structural elements in each plan which
determine floor, ceiling and roof heights; so it
is best to set your Framing Defaults before
building your model. See “Drawing a Plan” on
page 45. 
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as its Main Layer and its framing material 
must be a Framing type. See “The Main 
Layer” on page 302. 

Rough Openings
The rough openings, headers, trimmers, and 
sills for doors, windows, and fireplaces are 
set in their respective defaults and 
specification dialogs. See:
• “Door Specification Dialog” on page 374
• “Window Specification Dialog” on page 

406
• “Fireplace Specification Dialog” on page 

468

Sill Plates
Sill plates are created when floor framing is 
generated. They are created over all exterior 
walls that have either Concrete or Brick 
material type as their Main Layer material 
and support a floor platform or a framed wall 
directly above. See “The Main Layer” on 
page 302 and “Material Types” on page 860. 

Multiple sill plates can be specified in the 
Foundation Defaults dialog, along with 
their size. Only the bottommost plate that 
comes into contact with masonry is specified 
as Treated. See “Foundation Panel” on page 
449. 

These sill plates are placed on the “Framing, 
Sill Plates” layer by default. See “Displaying 
Framing” on page 604.

When a monolithic slab foundation is 
created, the bottom plates of framed walls 
built on the slab are specified as Treated and 

are placed on the “Framing, Wall” layer by 
default. 

As with sill plates, multiple bottom plates 
can be specified in the Framing Defaults 
dialog, but only the bottommost plate is 
specified as Treated. See “Wall Panel” on 
page 589. 

Roof Framing
Settings on the ROOF and TRUSSES panels of 
the Framing Defaults dialog determine the 
structure of roof planes and manually drawn 
ceiling planes as well as how they rest on 
bearing walls, so it is important that their 
default values be set before building the roof. 
See “Roof Panel” on page 595 and “Trusses 
Panel” on page 597.

If changes are made to these defaults that you 
need to apply to the entire roof plan, you will 
need to rebuild the entire roof - not just the 
roof framing. See “Roofs” on page 473. 

Framing Types
By default, all framing is set to use 
“Lumber” as the material type. You can 
select from a number of other types, 
however, including Glulam and steel. See 
“Framing Member Types” on page 610.

Note: Door and window bucks do not auto-
matically generate in concrete or block walls. 
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Manual vs. Automatic Framing
Platform, roof, and wall framing can be 
produced manually or automatically. In most 
cases, automatically-generated framing is 
preferable because it is faster than manually 
placing, replicating and editing numerous 
individual framing members. 

In many plans, though, framing is drawn 
using both approaches. For example, a 
combination of automatically generated 
rafters and manually drawn trusses can be 
used to model a roof framing plan. See 
“Mixing Trusses with Stick Framing” on 
page 622. 

Regardless of how it is created, individual 
framing members can be selected and edited. 
See “Editing Framing” on page 607. 

Automatic Framing
Automatic framing of floor and ceiling 
platforms, walls and roofs can be generated 
using the Build Framing dialog. The settings 
in this dialog control the size, spacing, and 
type of framing drawn in a plan, and related 
structural information for the major 
components of the 3D model. See “Build 
Framing Dialog” on page 586.

Automatic framing of a particular structural 
component is not generated until the Build 
Framing dialog is opened to the appropriate 
panel and one of two checkboxes selected:  
• Select the Build checkbox to build auto-

matic framing once. For example, check 
Build Wall Framing on the WALL panel, 
then click OK to build wall framing once 
based on the current state of the model. 

• Select the Automatic checkbox, then 
click OK to build automatic framing 
every time a change is made to that struc-
tural component in the plan. For example, 
check Automatic Wall Framing on the 
WALL panel to rebuild all wall framing 
any time a wall is affected by changes to 
the model. 

By default, joists automatically generate in 
the direction that results in the shortest span; 
however, you can produce different results 

using Bearing Lines , Floor/Ceiling 

Beams , and/or Joist Direction  lines. 
See “Bearing Lines” on page 603 and “Joist 
Direction Lines” on page 601.

Manual Framing
Framing objects can also be drawn manually. 
With the exception of Posts, framing objects 
are drawn by clicking and dragging in a 
straight line, the way other line-based objects 
are. See “Draw Line” on page 1080.

The manual framing tools are organized into 
families: general framing, floor and ceiling 
framing and roof framing. The family that a 
drawing tool belongs to determines where it 
can be used: 
• Roof framing objects can only be drawn 

within the area of one or more roof 
planes.

Note: When Automatic framing of a particular
type is enabled, framing of that type cannot
be manually edited or deleted. 
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• Floor and ceiling framing objects can 
only be drawn within one or more floor or 
ceiling platforms.

• General Framing  objects and 

Posts  can be drawn anywhere in a 
model.

• General Framing  objects can also be 
drawn in CAD Details. See “CAD 
Details” on page 1117.

• Wall Bridging  can only be drawn in a 
Wall Detail window. See “In Wall Detail 
Views” on page 605. 

Rebuilding and Retaining 
Framing

It is important to remember that by default, 
framing does not update automatically when 
changes are made to the model. For example, 
if a door is moved or resized, wall framing 
must be rebuilt. If the footprint is enlarged, 
the wall framing and any roof or platform 
framing that is affected must be rebuilt.

You can direct the program to rebuild the 
automatic framing of floors/ceilings, walls 
and/or roofs every time a change to the 
model affects one of these components. To 
do this, select the Automatic checkbox on  
the FLOOR, WALL, and/or ROOF panels of the 
Build Framing dialog. 

You can also rebuild the framing of a single 
wall, roof plane, or ceiling plane by clicking 

the Build Framing for Selected Object  
edit button. 

To learn more, see “Keeping Framing 
Current” on page 608.

When automatic framing associated with a 
particular panel in the Build Framing dialog 
is generated, any existing automatically 
produced framing of that type is deleted and 
replaced. You can prevent this from 
happening to a selected wall or roof plane by 
checking Retain Wall Framing or Retain 
Roof Framing in the object’s specification 
dialog. See “Structure Panel” on page 311 or 
“Structure Panel” on page 501.

Mixing Manual and Automatic 
Framing

Floor and ceiling platforms can be can be 
framed with a combination of manually-
drawn and automatically generated joists. 
Similarly, roof planes can be framed with a 
combination of manually drawn and 
automatic rafters.

If you plan to use this approach, bear in mind 
that automatically generated joists and rafters 
will not be created in the same location as an 
existing, manually drawn joist or rafter; but, 
they will not necessarily use the same layout. 
For consistent layout, consider using a 

Framing Reference Marker . See 
“Framing Reference Markers” on page 599. 

Manually drawn floor, ceiling, and roof 
framing is unaffected when automatic 
framing is rebuilt and remains along with the 
newly produced automatic framing. In 
contrast, manually drawn wall framing is 
deleted when automatic framing is rebuilt. 
You can, however, prevent this from 
happening by checking Retain Wall 
Framing in the Wall Specification dialog.
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Mixing Rafters and Trusses
Roofs can be framed with rafters, trusses, or 
a combination of the two. If you plan to 
combine roof trusses with rafters and/or 
ceiling joists, you can save time by:
• Check Trusses (No birdsmouth) in the 

Build Roof dialog before automatically 
building or manually drawing a roof. See 
“Build Roof Dialog” on page 480.

• Draw and position all roof trusses before 
automatically generating framing to pro-
duce rafters and ceiling joists. See “Roof 
Trusses” on page 616.

For more information, see “Mixing Trusses 
with Stick Framing” on page 622. 

Framing with Beams

Floor/Ceiling Beams  can be drawn in a 
plan either before or after automatic framing 
has been generated. Default settings for 
beams can be set in the Framing Defaults 
dialog. See “Beams Panel” on page 592.

If a Floor/Ceiling Beam is present and wall 
framing is generated, posts will be placed 
under the beam in any walls that pass under it 
and studs and top plates will build around the 
beam as necessary. 

If a Floor/Ceiling Beam is created before 
automatic floor or ceiling framing, you can 
specify whether joists bear on the beam or 
hang on its sides.

To build joists that bear on a beam

1. Draw a Floor/Ceiling Beam  at the 
desired location in your plan.

2. Select the beam and click the Open 
Object  edit button. On the GENERAL 
panel of the Beam Specification dialog, 
confirm that: 

•  The Top Height value is equal to the 
Ceiling Height of the room(s) over 
which the beam is placed.

•   Bearing Beam is checked. 
3. Click OK, then select Build> Framing> 

Build Framing  and build the appro-
priate floor or ceiling framing. See 
“Floor Panels” on page 586.

To build joists that butt against a beam

1. Draw a Floor/Ceiling Beam  at the 
desired location in your plan.

2. Select the beam and click the Open 
Object  edit button. On the GENERAL 
panel of the Beam Specification dialog: 

•  Specify the desired Depth value and 
then lock it.

•  Specify the Bottom Height value so 
that it is equal to the Ceiling Height of 
the room(s) over which the beam is 
placed.

•  Uncheck Bearing Beam. 
3. If necessary, select Build> Framing> 

Joist Direction  and draw a line per-
pendicular to the beam and within the 
floor or ceiling platform. 

4. Click OK, then select Build> Framing> 
Build Framing  and build the appro-
priate floor or ceiling framing. See 
“Floor Panels” on page 586.
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The Framing Tools
Select Build> Framing to access the 
automatic and manual Framing Tools.

The Framing Tools family has three separate 

parent buttons: General Framing Tools , 

Floor/Ceiling Framing Tools , and Roof 
Framing Tools .

The default settings for framing members are 
derived from their respective panels in the 
Framing Defaults dialog.

Most types of framing can be created both 
manually and automatically. Once created, 
both automatically generated and manually 
drawn framing members can be selected and 
edited. See “Editing Framing” on page 607.

Build Framing
Select Build> Framing> Build 
Framing to open the Build Framing 

dialog. Here, you can define settings that 
control how framing is drawn and generate 
automatic framing. See “Build Framing 
Dialog” on page 586. 

General Framing
General Framing objects are generic, 
framing members that can be drawn 

outside of a floor or ceiling platform or roof 
plane. Select Build> Framing> General 
Framing, then click and drag in a straight 

line to create one of these objects. In floor 
plan view, a horizontal framing member is 
created; in a Wall Detail, vertical members 
can also be drawn. See “In Wall Detail 
Views” on page 605.

Wall Bridging
Wall Bridging, or blocking, can be 
created both automatically and 

manually, but can only be drawn manually in 
a Wall Detail. To do so, open a Wall Detail 
and select Build> Framing> Wall Bridging, 
then click and drag in a straight line across 
the wall in the view. See “In Wall Detail 
Views” on page 605.

Each run of bridging has gaps where it 
crosses studs, but behaves as a single object. 

Automatic wall bridging can be created when 
wall framing is built or rebuilt. See “Wall 
Panel” on page 589.

Post
Posts can only be placed manually. To 
do so, select Build> Framing> Post 

and click in floor plan view. 

Post with Footing
Posts can also be created with footings  
beneath them. Select Build> 

Framing> Post and click in floor plan view 
to place a post centered over a footing. Post 

footings are Slab  objects and can be 
selected independent of their posts. See “The 
Slab Tools” on page 462. 

Horizontal floor/ceiling platform framing
members are referred to as "joists"; ver-

tical wall framing members are referred to as
"studs"; and sloped roof framing members
are referred to as “rafters”.
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Rafter
Rafters can be drawn both manually 
and automatically. To draw a rafter 

manually, select Build> Framing> Rafter in 
floor plan view, then click and drag in a 
straight line within a roof plane. 

Rafters are edited like other framing 
members, except that you cannot set the 
height. If a rafter is moved, its height and 
slope are automatically reset to fit under the 
roof plane at its new position.

Roof Blocking
Roof blocking can only be drawn 
manually. To do so, select Build> 

Framing> Roof Blocking in floor plan view 
and click and drag in a straight line within a 
roof plane. Blocking is typically drawn 
perpendicular to the rafters, but at the same 
pitch. 

Each run of blocking behaves as a single 
object but has gaps where it crosses rafters, 
trusses or other blocking. 

Before drawing Roof Blocking:
• Specify whether you want In Line, Stag-

ger blocking, or Cross bridging in the 
Framing Defaults dialog. 

• Build the roof framing. See “Roof Panel” 
on page 595.

In 3D, roof blocking is tilted to follow the 
pitch of the roof plane in which it is drawn. 

Roof Truss
Roof trusses can only be drawn 
manually. To do so, select Build> 

Framing> Roof Truss in floor plan view 

and click and drag  in a straight line within 
one or more roof planes. Roof planes and 
either a default or manually drawn ceiling 
must be present before a roof truss can be 
drawn. See “Roof Trusses” on page 616.

Roof Beam
Roof beams can only be drawn 
manually. To do so, select Build> 

Framing> Roof Beam in floor plan view 
and click and drag in a straight line. Roof 
beams are normally be drawn across rafters 
and placed directly under them. 

Joist
Floor and ceiling joists can be drawn 
both manually and automatically. To 

draw a joist, select Build> Framing> Joist 
in floor plan view, then click and drag in a 
straight line within a floor or ceiling 
platform. 

Joists are always drawn as the ceiling 
framing for the current floor. See “The 
Current Floor” on page 443. Whether a floor 
or ceiling joist is drawn is determined by the 
presence of a floor platform above. 
• If there is no floor platform above, a ceil-

ing joist is drawn. 
• If there is a floor platform above, a floor 

joist is drawn. 

If you want to draw floor joists for Floor 1, 
for example, you must do so on Floor 0. See 
“Foundations” on page 447.

Joists can be automatically generated for 
multiple floors in the Build Framing dialog. 
See “Floor Panels” on page 586. 
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Joist Blocking
Joist blocking can only be drawn 
manually. To do so, select Build> 

Framing> Joist Blocking in floor plan view 
and click and drag in a straight line within a 
floor or ceiling platform. 

Each run of blocking behaves as a single 
object. 

Before drawing Joist Blocking:
• Specify whether you want In Line, Stag-

ger blocking, or Cross bridging in the 
Framing Defaults dialog. 

• Build the floor and/or ceiling platform. 
See “Floor Panels” on page 586.

Floor/Ceiling Truss
Floor and ceiling trusses can only be 
drawn manually. To do so, select 

Build> Framing> Floor/Ceiling Truss in 
floor plan view and click and drag in a 
straight line within a floor or ceiling 
platform. See “Floor and Ceiling Trusses” on 
page 616.

Floor/Ceiling Beam
Floor and ceiling beams can only be 
drawn manually. To draw one, select 

Build> Framing> Floor/Ceiling Beam in 
floor plan view and click and drag in a 
straight line within a floor or ceiling 
platform.

Beams can be drawn in two different ways:

• Under Joists places the beam underneath 
the joists so the joists can bear on it. 

• With Joists places the top of the beam 
even with the tops of the joists it supports. 
The joist then butts against it. See “Beams 
Panel” on page 592.

Framing Reference Marker
Framing Reference Markers are 
manually-placed reference points that 

specify how to lay out automatically-
produced framing. To place one, select 
Build> Framing> Framing Reference 
Marker in floor plan view and click to place 
a Framing Reference Marker. 

A Framing Reference Marker can also be 

created by placing a Marker  and then 
specifing its type. See “Markers” on page 
1058 and “Framing Reference Markers” on 
page 599. 

Bearing Line
Bearing Lines direct the program to 
lap or butt joists and/or rafters where 

they cross the line instead of framing across 
it to the next wall and can only be drawn in 
floor plan view. To draw one, select Build> 
Framing> Bearing Line and click and drag 
in a straight line. See “Bearing Lines” on 
page 603.

Joist Direction
Joist Direction lines define the 
direction in which joists run in a floor 

or ceiling platform and can only be drawn in 

Ceiling joists, floor joists and rafters
have their own layers. Proper layer

assignment maximizes display and materials
flexibility.

Beams should be placed before joists
are automatically generated. 
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floor plan view. To draw one, select Build> 
Framing> Joist Direction and click and 

drag within a floor or ceiling platform. See 
“Joist Direction Lines” on page 601.

Build Framing Dialog
Automatic framing can be generated 
by selecting Build> Framing> Build 

Framing to open the Build Framing dialog. 
This dialog can also be accessed by double-

clicking the  General Framing  button or 

any of the Floor/Ceiling Framing Tools , 

or Roof Framing Tools  buttons.

The settings in this dialog are similar to those 
found in the Framing Defaults dialog.

Each major structural component of the 
model has its own panel or panels in the 
Build Roof dialog. The number of panels in 
the dialog varies depending on how many 
floors are in your model. There will be a 
panel called  “1st” for the first floor, “2nd” 
for the second floor, and so on.
• Floor and ceiling framing settings are 

found on the Floor panels. See “Floor 
Panels” on page 586. 

• Wall framing settings are located on the 
WALL, OPENINGS, and FIREPLACES pan-
els. See “Wall Panel” on page 589, 
“Openings Panel” on page 590 and “Fire-
places Panel” on page 592.

• Floor/Ceiling Beam and Roof Beam set-
tings are found on the BEAMS panel. See 
“Beams Panel” on page 592.

• Post, floor/ceiling beam and roof beam 
settings are found on the POSTS panel. See 
“Posts Panel” on page 594.

• Roof framing settings are located on the 
ROOF and TRUSSES panels. See “Roof 
Panel” on page 595 and “Trusses Panel” 
on page 597.

• The settings on the ROOF panel are the 
same as those on the STRUCTURE panel of 
the Build Roof dialog. See “Roof Panel” 
on page 595.

• You can set the default materials used for 
framing on the MATERIALS panel. See 
“Materials Panel” on page 599.

The Build Framing dialog opens to the panel 
for the current floor, for example: 1st, 2nd, or 
Foundation. 

Floor Panels
The floor framing for a given floor is always 
created on the floor below. As such, the floor 
framing settings for a given floor are found 
on the FLOOR panel for the floor below it. 
For example, the floor framing settings for 
Floor 2 are found on the 1ST panel, while the 

floor framing settings for Floor 1 are found 
on the FOUNDATION panel. See “Floor and 
Ceiling Platforms” on page 344.

In order to create the floor framing for Floor 
1, a Floor 0 must be present. If a Floor 0 has 
not been built, the Build Floor Framing 

For best results, create roof framing
before or at the same time that ceiling

joists are generated. 
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checkbox on the FOUNDATION panel will not 
be available. See “Foundations” on page 447. 

Check Automatic Floor/Ceiling 
Framing to regenerate floor and ceiling 

framing whenever changes are made to the 
model. See “Automatic Framing” on page 
580. 
• Check Use Framing Reference to build 

ceiling framing to a Framing Reference 
Marker. If a reference is present, the cen-
ter of the first joist is placed at this point 
and spacing goes from there. If joists are 

lapped, the surface is placed at this point. 
When this is unchecked, the program tries 
to position ceiling joists so that they coin-
cide with rafters. See “Framing Reference 
Markers” on page 599. 

Specify how the Ceiling Above Floor 
X is built. These settings are relevant 

only for rooms that do not have living space 
above them. 

1

2
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• Check Build Ceiling Framing to gener-
ate or regenerate ceiling framing when the 
OK button is clicked. Only available 
when there is no living space above at 
least part of the current floor. Not avail-
able in the Framing Defaults dialog.

• The Ceiling Structure depth displays 
here for reference. Click the Edit button 
to open the Ceiling Structure Definition 
dialog and define the layers of materials 
that form the ceiling platform. Check 
Default to use the Ceiling Structure Defi-
nition set in the Normal Room Defaults 
dialog. See “Material Layers Definition 
Dialogs” on page 802.

• Enter a value for the On Center Spacing 
of ceiling joists above the current floor. 

• Specify the Joist Width, which is their 
horizontal thickness. 

• Specify how the ceiling framing members 
Bear on Beams: they can either Lap or 
Butt over beams and bearing walls. The 
lap is 8” (200 mm) and centered over the 
support. 

• Specify what style of Blocking / Bridg-
ing is produced for the ceiling when Joist 
Blocking  is manually drawn after 
joists are in place. See “Joist Blocking” 
on page 585. 

• In Line produces blocking pieces that 
align with each other.

• Stagger produces blocking that alternates 
on either side of the line you draw. 

• Cross produces cross bridging that looks 
like in line blocking in floor plan view, 
but shows as cross bridging in 3D views 
and the materials list.

Specify how the Subfloor for Floor X 
is built. These settings are relevant only 

for rooms that have living space above them. 
• Check Build Floor Framing to generate 

or regenerate floor framing when the OK 
button is clicked. Not available in the 
Framing Defaults dialog or if there is no 
floor located below the floor in question. 

• The Floor Structure depth displays here 
for reference. Click the Edit button to 
open the Floor Structure Definition dia-
log and define the layers of materials that 
form the floor platform. Check Default to 
use the Floor Structure Definition set in 
the Normal Room Defaults. Only avail-
able if there is living space above at least 
part of the current floor. See “Material 
Layers Definition Dialogs” on page 802.

• Enter a value for the on center Spacing of 
floor joists above the current floor. 

• Specify the Joist Width, which is their 
horizontal thickness. 

• Check Rim Joist to create rim joists 
across the ends of the floor joists when 
floor framing is generated. If this is 
unchecked, line blocking across the ends 
of the floor joists is usually drawn in later. 

• Specify the Rim Joist Width, which is 
the horizontal thickness. 

• Select the Rim Joist Type from the drop-
down list. 

• Specify how the floor framing members 
Bear on Beams: they can either Lap or 
Butt over beams and bearing walls. The 
lap is 8” (200 mm) and centered over the 
support. 

• Specify what style of Blocking / Bridg-
ing is produced for the floor when Joist 

3
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Blocking  is manually drawn after 
joists are in place. See #2, above. 

Wall Panel

Check Automatic Wall Framing to 
regenerate wall framing whenever 

changes are made to the model. See 
“Automatic Framing” on page 580.

Specify how Wall studs are created.
 

• Check Build Wall Framing to build wall 
framing for the entire model. Framing is 
built in walls whose Main Layer material 

type is “framing”. Not available in the 
Framing Defaults dialog. See “Wall Type 
Definitions” on page 302.

• Check Use Wall Framing Material to 
use the stud thickness and spacing defined 
for the framing material used by each wall 
type. See “Define Material Dialog” on 
page 864. Uncheck this box to use the 
thickness and spacing values below for all 
wall types. 

1

2
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• Specify the Stud Thickness for all walls 
in the plan. Stud depth is equal to the 
thickness of each wall layer that has a 
Framing material. Not available when 
Use Wall Framing Material is checked.

• Specify the Stud Spacing for all walls in 
the plan, starting from the Framing Refer-
ence Marker, if one is present. See “Fram-
ing Reference Markers” on page 599. Not 
available when Use Wall Framing Mate-
rial is checked.

Define how top and bottom Plates are 
generated.

• Specify the Top Plate Count, as well as 
their Thickness.

• Specify the Bottom Plate Count, as well 
as their Thickness.

Specify where and how Blocking is 
drawn. Each run of blocking behaves as 

a single object but has gaps where it crosses 
studs. See “Wall Bridging” on page 583.
• Check Exterior to automatically produce 

blocking on exterior walls when wall 
framing is built. 

• Check Interior to automatically produce 
blocking on internal walls when wall 
framing is built.

• In Line produces blocking pieces that 
align with each other. 

• Stagger produces blocking that alternates 
on either side of a center line along the 
wall. 

Wall blocking is generated exactly half-way 
up each wall’s total height. Once created, it 
can be selected in a Framing Overview or 
Wall Detail. 

Mitre Ends of Angle Walls - Specify 
how wall corners that are not right 

angles are framed. 90° corners are not 
affected by these settings. 
• Select Mitre Plate Ends to mitre the ends 

of the top and bottom plates. If 
unchecked, top and bottom plates will be 
butted together.

• Select Rotate End Studs to rotate the 
studs closest to mitre ends to the angle of 
the mitre. If unchecked, studs will remain 
perpendicular to the angle of the walls.

• Select Horizontal Frame Thru to frame 
through the horizontal walls in floor plan 
view, butting vertical walls against them. 
If unchecked, walls that are vertical in 
floor plan view will frame through.

Check Build Wall Framing Details 
from Exterior to have Wall Detail 

views display from the exterior of the plan 
rather than the interior. See “In Wall Detail 
Views” on page 605.

Openings Panel
The rough openings for doors and windows 
can be specified in the Door and Window 

Defaults and Specification dialogs. See 
“Default Settings” on page 74.

Note: If the Stud Thickness is equal to the
stud depth, only one stud will be created at
wall corners.

3

4

5

6
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Specify default Header Sizes, 
dependent on width of the door, 

window, or fireplace, including its Rough 
Opening. These values should be set so that 
the wider the opening, the deeper the header. 
• If the top of an opening’s Rough Opening 

is closer to the top plate than the Maxi-
mum Depth, a solid header is produced 
to fill the entire space. Short cripple studs 
between the header and top plate are not 
produced. 

Specify how Bay/Box/Bow Trimmers, 
are generated. 

• Specify the Maximum Number of trim-
mers that a Bay, Box, or Bow Window 
with a lowered top height can have on 
each side of the opening. 

• Specify the Component Thickness, 
which is the thickness of a thinner trim-
mer for manually resized Bay/Box/Bow 
Window components if a standard trim-
mer does not fit. See “Resizing Compo-
nents” on page 426. 

Check List Cut Header Lengths in 
Mixed Reporting to show precut 

headers in the Materials List. Precut headers 
are shown only if the walls have been framed 
and Mixed Reported is selected as the 
reporting method. See “Structural Member 
Reporting” on page 1286.

If this is unchecked, the Materials List 
produces a total footage for all headers. 
When checked, each different length of 
precut header is listed separately. Note that 
the total number of headers is affected by the 
Count value of each door and window.

1

2

3
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Fireplaces Panel

The rough openings for Fireplaces  
placed in walls can be set on the FIREPLACES 
panel. See “Fireplaces” on page 467.

Specify the characteristics of fireplace 
Headers. 

• Specify the Type of material used for fire-
place headers. 

• Specify the Thickness of fireplace head-
ers. 

• Specify the Count of boards used to form 
a fireplace header. 

Specify when to generate multiple 
Trimmers on each side of a fireplace. 

These values include the fireplace’s Rough 
Opening. See “Rough Openings” on page 
579.

• Double Trimmer At - Fireplace openings 
of this width or greater receive two trim-
mers on each side when framed. 

• Triple Trimmer At - Fireplace openings 
of this width or greater receive three trim-
mers on each side when framed. 

Specify the characteristics of fireplace 
Sills. A sill is only generated if a 

fireplace is raised sufficiently off the floor.
• Specify the Thickness of fireplace sills. 
• Check Double Sills to specify a double 

sill for all fireplaces. 

Beams Panel

Floor/Ceiling Beams  and Roof 
Beams  are not automatically generated: 

they can only be drawn manually. See 
“Manual Framing” on page 580. 

1

2

3
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Click the Edit Floor Beam Defaults to 
open the Floor/Ceiling Beam Defaults 

dialog. This dialog is similar to the Framing 
Specification dialog. See “Framing 
Specification Dialog” on page 610.

Click the Edit Roof Beam Defaults to 
open the Roof Beam Defaults dialog. 

This dialog is also similar to the Framing 
Specification dialog. 

The Options settings affect the 
positioning of Floor/Ceiling 

Beams . 

• Specify the Placement of Floor/Ceiling 
Beams relative to the joists. With Joists 
places beams at the same height as the 
joists so they hang on the beams; Under 
Joists places beams below joists so they 
bear on the beams. See “Bearing Lines” 
on page 603. 

• Align Exterior with Outer Layer/Main 
Layer - When a Floor/Ceiling Beam is 
drawn along and over an exterior wall, its 
exterior surface can snap to either the 
wall’s outer layer or outer Main Layer, as 
specified here. See “The Main Layer” on 
page 302.

Posts and beams may be created under
a Deck room automatically, depending

on its size, location, and other variables.
Deck Framing defaults are set in the Deck
Room Defaults dialog. See “Deck Framing
and Planking” on page 341.

1

2

3
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Posts Panel

Posts  are not automatically generated: 
they can only be drawn manually. See 
“Manual Framing” on page 580. 

Click the Edit Post Defaults to open 
the Post Defaults dialog. This dialog is 

similar to the Framing Specification dialog 
for posts. See “Framing Specification 
Dialog” on page 610.

The Post Footings settings control the 
initial attributes of footings created 

with the Post with Footing  tool. 
• Specify the Height Above Floor value, 

measured from the top of the subfloor of 
the room in which the post is placed.

• Specify the top to bottom Thickness of 
the footing.

• Specify the Width of the footing. This is 
the length of each side of a square footing 
and the diameter of a round footing.

• Select the Square or Round radio button 
to specify the initial shape of post foot-
ings. Once created, a post footing can be 
edited like other closed polylines. See 
“Editing Closed-Polyline Based Objects” 
on page 201.

• Specify the Rebar Size Number for post 
footing Rebar. 

• Specify the Rebar Count, or number of 
bars, for Post Footings.

Posts and beams may be created under
a Deck room automatically, depending

on its size, location, and other variables.
Deck Framing defaults are set in the Deck
Room Defaults dialog. See “Deck Framing
and Planking” on page 341.

1

2
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Roof Panel
The settings on the ROOF panel of the Build 
Framing dialog are exactly the same as those 
on the STRUCTURE panel of the Build Roof 
dialog. See “Build Roof Dialog” on page 
480.

These settings are also found on the STRUC-
TURE panel of the Roof Plane Specification 
dialog. Those settings that apply to ceiling 

planes are available in the Ceiling Plane 
Specification dialog. See “Roof Plane 
Specification Dialog” on page 498. 

Note: Changes made on the Roof panel will
not affect the structure of existing roof planes.
To make changes take effect, rebuild the roof.
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Check Automatic Roof Framing to 
automatically rebuild roof framing if 

changes are made to the roof plan. See 
“Automatic Framing” on page 580.
• Check Use Framing Reference to use a 

defined starting point for rafter layout. 
See “Framing Reference Markers” on 
page 599.

Roof - 

• Check Build Roof Framing to build roof 
framing for the entire model. Not avail-
able in the Framing Defaults dialog. See 
“Roofs” on page 473.

• Uncheck Angled Dormer Hole to frame 
dormers using rafters under the dormer 
valleys and a double header where the 
peak of the dormer roof meets the main 
roof plane. When checked, a five-sided 
hole is framed with two angled double 
rafters located under the dormer valleys. 
If a double header does not fit within the 
main roof plane, an angled dormer hole is 
produced regardless of this setting. 

• Uncheck Trim To Soffits to generate full-
depth rafters all the way to the subfascia. 
If checked, rafter depths are trimmed to 
the top surface of the soffits in the eave 
area. Does not affect decorative rafter tail 
ends. See “Rafter Tails Panel” on page 
487.

• Select the Rafter Type from the drop-
down list. See “Framing Member Types” 
on page 610.

• Specify the Spacing of automatically 
generated rafters. This also sets the initial 
offset value for laying out rafters using 

the Multiple Copy  edit button. See 
“Multiple Copy” on page 173.

• Specify the Maximum Lookout Spac-
ing. Depending on a roof plane’s length, 
its lookouts may be spaced closer than 
this value, but not further.

Specify the Blocking Style. See “Roof 
Blocking” on page 584. 
• Check Vertical to generate blocking that 

is oriented vertically, or plumb. When 
unchecked, blocking is perpendicular to 
the roof framing. 

• In Line produces blocking pieces that 
align with each other.

• Stagger produces blocking that alternates 
on either side of the line you draw. 

• Cross/Bridging produces cross bridging 
that looks like in line blocking in floor 
plan view, but shows as cross bridging in 
3D views and the materials list. 

Roof Layers - Define the layers of 
materials that together form the default 

roof plane assembly. 
• The roof Surface depth displays here for 

reference. Click the Edit button to open 

Note: Use Framing Reference is useful when
framing a gable roof, but not necessarily a hip
roof. See “Framing References and Roof
Framing” on page 601.

1

2

Angled Dormer Holerectangular dormer
hole

3
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the Roof Surface Definition dialog and 
define the layers of materials located 
above the structural layers. See “Material 
Layers Definition Dialogs” on page 802. 

• The roof Structure depth displays here 
for reference. Click the Edit button to 
open the Roof Structure Definition dia-
log and define the layers of materials that 
form the roof structure. 

• The roof Ceiling depth displays here for 
reference only if Use Room Ceiling Fin-
ish is unchecked. Click the Edit button to 
open the Roof Ceiling Finish Definition 
dialog and define the layers of materials 
located below the structural layers. 

• Check Use Room Ceiling Finish to sup-
ply a ceiling surface based on the specifi-
cations of the room(s) below. This ceiling 
finish is only generated over rooms with 
Ceiling Over This Room unchecked. See 
“To create a cathedral ceiling” on page 
347. 

• Check Soffits to include soffits under the 
eaves and specify their Thickness. 

• Check Flat Under Eave Sub Fascia to 
extend soffits downward until they meet 
the subfascia. When unchecked, soffits 
slope downward to the fascia, if the fascia 
depth is sufficient. 

Roof Size - Specify the desired Width 
and Depth for Rafters, the Ridge, 

Lookouts, Gable Sub Fascia (barge rafter), 
Eave Sub Fascia, Gable Fascia, Eave 
Fascia and Blocking.

Note that the Gable Sub Fascia setting 
controls the height of both gable and eave 
soffits, and thus the depth of rafter tails when 
Trim to Soffits is checked, above.

Uncheck the boxes beside Lookout, Eave 
Sub Fascia, Gable Fascia and/or Eave 
Fascia to prevent these framing members 
from generating when roof framing is built. 
When these boxes are checked, these items 
will generate as specified here. 

Trusses Panel
Changes to the settings on this panel do not 
affect any trusses that are already present in 
the current plan. See “Trusses” on page 615.

4

Chief Architect does not engineer
trusses. Always consult an engineer or

truss company to have your trusses profes-
sionally designed.
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Specify the Roof Truss Member 
Depths.

• Specify the depth of the Top Chord.
• Specify the depth of the Bottom Chord.
• Specify the depth of the Webbing.

The Maximum Horizontal Span 
settings control the maximum length 

between junctions of the webbing and the 
Top Chord and Bottom Chord. Changing 
these values can create different truss 
configurations such as kingpost, queenpost, 
fink, double fink, fan, howe, or double howe. 

These distances are measured horizontally 
for both roof and floor and ceiling trusses. In 

some instances, especially in more complex 
trusses, making these spans equal may result 
in the webbing appearing more normal or 
standard. See “Trusses” on page 615.

Options - 

• Check Require Kingpost to include a 
central vertical webbing member. If this is 
unchecked, a vertical member may still be 
created, depending on the Maximum Hor-
izontal Span settings and the length of the 
truss. 

• Specify the Ceiling Step, which is the 
maximum distance its bottom chord can 
step down to locate a ceiling on the floor 

1

2

3
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below the top floor. See “Ceiling Steps” 
on page 630.

Specify the Floor/Ceiling Truss 
Member Depths.

• Specify the depth of the Top Chord.
• Specify the depth of the Bottom Chord.
• Specify the depth of the Webbing.

The Maximum Horizontal Span 
setting controls the maximum length 

between junctions of the webbing and the top 
and bottom chords.

Truss Spacing
Trusses are always drawn manually, so while 
their depth, span and kingpost defaults are 
specified in the Build Framing dialog, their 
spacing is not. 

Trusses are typically replicated using the 

Multiple Copy  edit button, and their 
spacing can be set in the Multiple Copy 
dialog. See “Multiple Copy Dialog” on page 
174.

Materials Panel
The default materials that display on General 
Framing objects are specified on the MATE-
RIALS panel. These materials are used in 3D 
views only and are not used in the Materials 
List. Materials List information is derived 
from the structure Type of each framing 
object. See “Framing and the Materials List” 
on page 609.

Changes made on the MATERIALS panel of 
the Build Framing dialog only affect 
subsequently created framing: both manually 
drawn and automatically generated.

The settings on this panel of the Build 
Framing dialog are the same as in many 
other specification dialogs. See “Materials 
Panel” on page 852.

Framing Reference Markers
Framing Reference Markers are 
reference markers that specify the 

starting point for the layout of automatically-
produced framing. 
• Wall and floor framing always build to the 

Framing Reference Marker if one is pres-
ent.

• Ceiling and roof framing only build to the 
Framing Reference Marker when Use 
Framing Reference is specified for that 
type of framing.

Typically, a single Framing Reference 
Marker on Floor 1 is used for the entire 
model.
• When more than one Framing Reference 

Marker is present, framing layout starts at 
the one closest to the center of the area to 
be framed. 

• If no Framing Reference Marker is found 
on the floor being framed, the closest 
Framing Reference Marker on Floor 1 is 
used. 

4

5
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When Automatic Wall Framing is checked, 
wall framing automatically rebuilds if a 
Framing Reference Marker is added or 
moved. See “Automatic Framing” on page 
580.

Automatic Floor/Ceiling Framing and 
Automatic Roof Framing, on the other 
hand, do not respond when a Framing 
Reference Marker is added or moved. These 
framing types must be rebuild using the 
Build Framing dialog. See “Build Framing 
Dialog” on page 586.

Using Framing 
Reference Markers

To place a Framing Reference Marker, select 
Build> Framing> Framing Reference 
Marker . Click in floor plan view to 
place the Framing Reference Marker. 

When Object Snaps  are enabled, 
Framing Reference Marker snap to framing 
members and other CAD-based objects first, 
and then to a wall Main Layer surface or 
corner if possible. See “Object Snaps” on 
page 162.

Framing Reference Markers can be modified 
just like other markers. See “Markers” on 
page 1058.

When framing is generated using a Framing 
Reference Marker, the first framing member 
of a given type snaps to this point and all 

other framing members are laid out from 
there. 
• Wall and roof framing snap to the Fram-

ing Reference Marker at their centers.
• Floor and ceiling framing snaps to the 

Framing Reference Marker at their cen-
ters when when it is set to Butt Over 
Support in the Build Roof dialog. See 
“Floor Panels” on page 586.

• Floor and ceiling framing snaps to the 
Framing Reference Marker along an edge 
when it is set to Lap over a supporting 
beam or wall. If Lap is selected, the sur-
faces where the joists lap are placed at 
reference spacing, so that joists are placed 
on either side of the framing reference 
locations. 

Move to Framing Reference
Manually drawn framing and 
automatic framing that was not 

generated using a Framing Reference Marker 
can be moved relative to a Framing 
Reference Marker using the Move to 
Framing Ref edit button. 

When a framing member using the Move to 

Framing Ref  edit button, the on-center 
spacing distance set in the Build Framing 
dialog is used.  

The Move to Framing Ref  edit button 
may also reference spacing specific to a 
particular floor or ceiling platform. See 
“Joist Direction Lines” on page 601.

A group of selected framing objects that are 
all parallel to each other can be moved using 

the Move to Framing Ref  edit button. 
Only one of the objects in the group is 

Note: If no Framing Reference Markers exist
in your plan, the point at 0, 0 is used as the
Framing Reference Markers location and
unexpected results may occur.
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compared to the Framing Reference Marker 
and moved; the remaining objects are simply 
moved the same amount as the first object. 
Ideally, therefore, the group should have 
proper spacing relative to each other before 
the move. 

To move framing objects to a framing 
reference marker

1. Group select the framing objects.

2. Click the Move to Framing Ref  edit 
button.

3. The framing members are moved to the 
nearest Framing Reference Marker.

Framing References and 
Ceiling Framing

For floor joists, the starting point for layout 
is always the Framing Reference Marker. 
Ceiling joists, on the other hand, only use a 
Framing Reference Marker if Use Framing 
Reference is checked in the Build Roof 
dialog. See “Floor Panels” on page 586.

If the Use Framing Reference checkbox is 
cleared, the program will try to position 
ceiling joists so that they coincide with 
rafters. Be sure to build the roof framing first 
if you are doing this.

A Framing Reference Marker is not usually 
used for both ceiling joists and nearby rafters 
that run the same way because one is placed 
on top of the other.

Framing References and 
Roof Framing

Framing Reference Markers are useful when 
framing a gable roof, but not necessarily a 
hip roof. When a Framing Reference is used, 
common rafters on either side of a hip rafter 
do not meet in the same place. 

If the Framing Reference is not used, the 
automatic framing utility starts common 
rafter spacing from each end of the 
horizontal ridges, which results in common 
rafters on either side of hip jacks meeting 
each other. 

Joist Direction Lines
By default, automatically-generated 
floor and ceiling joists will run in the 

direction that results in the shortest span 
between bearing walls and/or beams. A Joist 
Direction line allows you to define the 
direction that joists in a particular floor or 
ceiling platform run, regardless of span.

To draw a Joist Direction line, select Build> 
Framing> Joist Direction , then click 
and drag as you would draw a CAD line. In 
order to have any effect, a Joist Direction line 

must be drawn within the area of a single 
floor or ceiling platform. 

To avoid unexpected results, only one Joist 
Direction line should be present in a given 
floor or ceiling platform, and it should not 
extend outside of the extents of that platform.

Joist Direction lines are located on the 
“Framing, Bearing Lines” layer by default 
and use the Text Style assigned to the layer 
that the Joist Direction line is on. See “Text 
Styles” on page 1061. 
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Multiple Joist Directions
By default, all of the rooms on each living 
floor share a single floor platform and a 
single ceiling platform. If you require joists 
that run in two directions in either of these 
platforms, begin by dividing the platform in 
question in two. There are a number of ways 
to do this:
• Divide the living area into separate rooms 

with different platform thicknesses and/or 
heights. See “Floor and Ceiling Plat-
forms” on page 344.

• Specify one or more interior walls as 
Bearing Walls. See “Structure Panel” on 
page 311.

• Draw a Floor/Ceiling Beam  speci-
fied as a Bearing Beam. See “Floor/Ceil-
ing Beam” on page 585.

• Draw a Bearing Line . See “Bearing 
Lines” on page 603.

Bearing Walls, Floor/Ceiling Beams, and 
Bearing Lines should be drawn on the same 
living floor as the joists they will interact 
with. Floor framing for a living floor is 

created on the floor below, while ceiling 
framing for a living floor is created on that 
floor. See “Floor and Ceiling Framing” on 
page 578.  

Joist Size and Spacing
The text along a Joist Direction line states the 
joist size and spacing for the platform. By 
default, these values reflect the settings in the 
Framing Defaults dialog. See “Floor Panels” 
on page 586. 

If you  modify joist depth or spacing in a 
platform via the Room Specification dialog, 
your change will not be reflected in the Joist 
Direction line’s text.  When this is the case, 
you may wish to edit the Joist Direction 
line’s text in the Joist Direction 
Specification dialog. 

It is important to note that if a Joist Direction 
line is set to use non-default Spacing and 
Depth values, they will override the settings 
in both the Framing Defaults and Room 
Specification dialogs. It will not, however, 
change the settings in either dialog.

Joist Direction Specification Dialog
A Joist Direction line can control the 
joist depth and spacing in the floor or 

ceiling platform in which it is drawn. To 
change these values, select a Joist Direction 
line and click the Open Object edit button. 
The Joist Direction Specification dialog 
opens. 

Any changes made in the Joist Direction 
Specification dialog will not affect any joists 
present in its floor or ceiling platform. Only 
subsequently produced framing in its 
platform will be affected.
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Floor Joist Panel

• Define the Spacing of the joists in the 
platform associated with the selected Joist 
Direction line.

• Define the Depth of these joists. 

Line Style Panel
For information about the settings on this 
panel, see “Line Style Panel” on page 1085.

Arrow Panel
For information about the settings on this 
panel, see “Arrow Panel” on page 1088.

Bearing Lines
A Bearing Line directs the program 
to lap or butt joists where they cross 

the line instead of framing across to a wall. 
Joists lap or butt over the line depending on 
the option selected in the Build Framing 
dialog. See “Floor Panels” on page 586.

In most cases, when joists lap or butt in the 
middle of a span rather than build across a 
platform, they bear on a wall or beam at that 
point. When this is the case, place a Bearing 
Wall or Bearing Beam instead of using a 
Bearing Line. See “Structure Panel” on page 
311 and “Floor/Ceiling Beam” on page 585. 

Select Build> Framing> Bearing Line , 
then click and drag to draw a Bearing Line as 

you would draw a CAD line. A Bearing Line 
should start outside the floor or ceiling 
platform and end outside of it, passing 
completely through the building. 

Note: This is not the recommended method
for specifying joist depth and spacing in most
cases. You should instead use the settings in
the Room Specification dialog. See “Room
Specification Dialog” on page 350.

Joists lapping over a Bearing Line polyline
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Bearing Lines are edited just like CAD lines, 
and can be connected to form polylines. See 
“Editing Line Based Objects” on page 187 or 
“Editing Open Polyline Based Objects” on 
page 196.

Bearing Lines are one of the ways that a floor 
or ceiling platform can be divided into 
separate smaller platforms with different 

Joist Directions . See “Joist Direction 
Lines” on page 601.

Displaying Framing
The display of framing members is 
controlled in the Layer Display 

Options dialog. By default, framing objects 
are created on one of over twenty layers with 
names that begin with “Framing,”: Ceiling 
Beams, for example, are placed on the 
“Framing, Ceiling Beams” layer. Once 
created, though, framing objects can be 
placed on any layer you wish. See 
“Displaying Objects” on page 144.

In Floor Plan View
In floor plan view, wall studs and posts are 
represented by box-based CAD objects that 
look like Cross Boxes. See “Cross Box” on 
page 1102 and “Editing Box-Based Objects” 
on page 206. 

Joists, rafters, and trusses are represented in 
floor plan view by line-based CAD objects 
that are essentially long, thin rectangles. See 
“Editing Line Based Objects” on page 187.

If you prefer, joists, rafters, and trusses can 
instead be represented by a single line. See 
“CAD Defaults Dialog” on page 1072.

By default, framing polylines have a solid 
white fill, and new members display in front 
of older ones, helping to distinguish newer 
members from those drawn previously. You 

can specify whether new framing members 
are drawn with this fill. See “CAD Defaults 
and Preferences” on page 1072.

By default, posts display in front of beams, 
but behind joists. You can specify the 
drawing order of framing members in their 
specification dialogs. See “Line Style Panel” 
on page 613.

Framing Labels
Framing labels are located on the “Framing, 
Labels” layer and can be set to display in 
floor plan view, Wall Details, and cross 
section/elevation views. See “Object Labels” 
on page 1279.  
• Headers, posts and beams have automatic 

labels consisting of the object’s depth and 
width followed by the member type. In 
Imperial plans, the nominal size is used. 

• Joists, rafters, studs, plates, and wall 
blocking do not have automatic labels; 
however, you can specify a custom label 
in their specification dialog. See “Fram-
ing Specification Dialog” on page 610. 

Framing objects have named value pairs 
associated with them, so you can create 
custom labels using Text Macros. See “Text 
Macros” on page 1064. 
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In 3D Views
The easiest way to view framing in 3D is to 
use either the Orthographic Framing 
Overview  or Perspective Framing 
Overview  tool, which display the model 
using the 3D Framing Set layer set. See 
“Framing Overview” on page 901. 

Framing objects can display in other 3D and 
cross section/elevation views, although by 
default they are not set to do so. If you wish 
to see framing in these views, turn on the 
framing layers in the appropriate layer set.

To reveal framing covered by other objects 

or wall layers, use the Delete Surface  
tool. See “Delete 3D Surface” on page 910. 

In Cross Section/
Elevation Views

To display framing in a cross section/
elevation view, make sure the framing layers 
are turned on in that view. See “Layer 
Display Options Dialog” on page 149. 

You can also use the Delete Surface  tool 
to temporarily delete the surfaces of wall 
layers or other objects that block the view. 

In cross section/elevation views, horizontal 
framing objects that are cut by the cross 
section plane display as boxes containing an 

’X’. Wall Blocking , Joist Blocking , 

and Roof Blocking  cut by the cross 
section plane displays as a box containing a 
single diagonal line. See  “Cross Section/
Elevation Views” on page 902.

In Wall Detail Views
Wall Details are a special type of wall 
elevation view in which only the studs, plates 
and headers used to frame a selected wall 
display. They are the only views in which 

Wall Bridging  can be created. See “Wall 
Bridging” on page 583.

A Wall Detail view for each framed wall in 
your plan is automatically created by the 
program when its wall framing is built. To 
view the Wall Detail associated with a 
specific wall, select the wall and click the 

Wall Detail  edit button. See “Editing 
Walls” on page 285. 

Wall Details are also listed and can be 
accessed in the Project Browser. The name of 
each Wall Detail is the same as the 
Automatic Label of the wall it is associated 
with. See “Project Browser” on page 1125.

Most wall framing members occupy the 
entire thickness of its wall layer. Some, 
notably doubled headers or corner sheetrock 
nailers, may be turned sideways. If a wall has 
multiple framing layers, they will display in 
the same Wall Detail view, but in separate 
locations. Double or triple headers display 
one behind the other in a Wall Detail. You 

I-joists, a rim joist, and wall plates 
       cut in a cross section view
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can select them using the Select Next 
Object   edit button. See “Select Next 
Object” on page 185. 

By default, Wall Details show walls as 
viewed from the exterior. You can specify 
whether Wall Details are viewed from the 
interior or exterior in the Build Framing 
dialog. See “Wall Panel” on page 589. 

Each Wall Detail is created with a text object 
that states what wall layer is shown as well as 
from which side the framing is being viewed.

The framing members of an individual wall 
can be selected and edited in its Wall Detail. 
If you rebuild wall framing after manually 
editing in a Wall Detail, your changes will be 
lost. To protect changes made to a wall’s 
framing, check Retain Wall Framing in the 
Wall Specification dialog. See “General 
Panel” on page 309.

As with regular 3D views, Wall Details can 
be sent to layout and printed. See “Layout” 
on page 1235 and “Printing and Plotting” on 
page 1211.

Framing Materials and Types
The appearance of a framing member in 3D 
and cross section/elevation views is affected 
by the material assigned to it and also by its 
Type.

The material specified for a framing member 
determines what it looks like in camera 
views by applying a texture, pattern, or color 
to its surface. Materials have no effect on 
how the framing is calculated in the 
Materials List, however.

The default materials for framing are set:

• In the Floor and Ceiling Structure 
Definition dialogs for floor and ceiling 
framing. See “Floor and Ceiling Platform 
Definitions” on page 344.

• In the Wall Type Definitions dialog for 
wall framing. See “Wall Type Definitions 
Dialog” on page 305.

• In the Framing Defaults dialog for Gen-
eral Framing, Posts, and Rafters. See 
“Materials Panel” on page 599. 

Framing Types can also influence how a 
framing member looks in camera views 
because some types have special profiles - 
for example, I-Joists, Steel-I, and C-Channel. 
Framing types are also stated in the 
Description column in the Materials List. See 
“Framing Member Types” on page 610. 

In the Materials List
When framing is calculated in the materials 
list, its dimensions and type are noted. 
Treated lumber is also counted separately 
form regular lumber. See “Framing Member 
Types” on page 610. 

Framing lengths can be counted using one of 
several methods to produce, for example, cut 
lists and buy lists. See “Structural Member 
Reporting” on page 1286.

If framing is not present in a plan when a 
Materials List is created, it will not be 

Materials and framing types control how 
           framing looks in 3D views 
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calculated.  See “Framing and the Materials 
List” on page 609. 

Editing Framing
Framing members can be individually 
selected in all views, and some types can be 
group selected. To group-select wall framing 
in floor plan view, first select any of the 
Framing Tools. See “Marquee Select” on 
page 185.

Once selected, they can be edited muck like 
other line-based objects can using the edit 
handles, edit toolbar buttons, or the Framing 
Specification dialog. See “Framing 
Specification Dialog” on page 610.

When Start and End Indicators are enabled 
in the Preferences dialog, a selected framing 
member will display an S and an E at its start 
and end points. This makes it easier to 
choose which end to lock when specifing its 
Length or Angle. See “Edit Panel” on page 
111.

Framing is organized into families which 
determine where it is generated and where it 
can be manually drawn. See “Manual vs. 
Automatic Framing” on page 580. Once 
framing has been created, however, it can be 
moved out of its structural component. In 
order to move roof framing above or below a 
roof plane, you must first check Manual 
Rafter Height in the Framing Specification 
dialog. See “General Panel” on page 611. 

Using the Edit Handles
Framing members can be drawn, edited, and 
moved much the way CAD lines can. See 
“Editing Line Based Objects” on page 187. 

In Cross Section/Elevation views, joists and 
rafters cut by the cross section and displaying 
a cross box can also be edited. See “Editing 
Box-Based Objects” on page 206. Also, in 
Cross Section/Elevation views headers can 
be edited like closed polylines. See “Editing 
Closed-Polyline Based Objects” on page 
201. 

In a camera view or overview, the handles 
that display on a framing member depend on 
where it is clicked for selection and your 
current zoom factor.
• Click the top surface to display the same 

edit handles as in floor plan view, allow-
ing you to rotate, move, and extend or 
shorten the length of the member.

• Click a side surface to display the same 
edit handles as in an elevation view, one 
at each end and one at the center.

• Zoom in and click on the appropriate edge 
to display edit handles that control the 
width and depth of framing members.

Using Dimensions
Framing members can be both moved and 
resized using dimensions. See “Moving 
Objects Using Dimensions” on page 1019. 

Using the Edit Tools
A selected framing member can be edited in 
a variety of ways using the buttons on the 
edit toolbar. See “The Edit Toolbar” on page 
37.
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Mitered and Lapped Joints
Mitered joints can be created using the Join 
and Mitre Ends  edit button. Click on a 
framing member such as a joist, click the 

Join and Mitre Ends  edit button, then 
click on another nearby joist to extend and/or 
trim the two objects as needed so that they 
join at an angled cut. See “Fillet Lines” on 
page 233.

You can instead make two framing members 
meet at a lapped intersection using the Join 
and Lap Ends  edit button. The selected 
framing member will butt against the second 
one, which laps the end of the first. 

The Join and Mitre Ends  and Join and 
Lap Ends  tools not available for Posts, 
Floor/Ceiling Trusses, or Roof Trusses.

Multiple framing objects can also be 
trimmed to length using the Trim Object(s) 

 and Extend Objects  edit tools. See 
“Trim and Extend” on page 244. 

Steel and Concrete
You can set framing defaults to generate steel 
framing and concrete structural members as 
well as lumber and other framing types. 
Individual framing members can also be 
specified as concrete or steel, as well.  

When setting up defaults or modifying an 
individul object, make sure you specify both 
the desired framing Type and the material. 
See “Framing Materials and Types” on page 
606. 

Roof and Floor Trusses
Roof and floor trusses cannot be edited like 
regular framing members can and are 
discussed in their own chapter. See “Editing 
Truss Envelopes” on page 620.

Deleting Framing
Individual and group-selected framing 
members can be deleted the way other 
objects in the program are. See “Deleting 
Objects” on page 255. 

Categories of framing, such as wall framing 
or floor and ceiling framing, can also be 
deleted in the Delete Objects dialog. See 
“Delete Objects Dialog” on page 255.

Keeping Framing Current
When you modify your plan, move walls, 
raise or lower platforms or redesign the roof, 
any framing present in the plan will not 
update to reflect your changes. In order for 
the framing to be updated, you must 
regenerate automatically produced framing 

and either edit or delete and replace manual 
framing. 

For this reason, it is recommended that you 
wait until your model is finished, or nearly 
finished, before creating framing. See 
“Drawing a Plan” on page 45.
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Automatic Framing
Automatically-generated framing can be 
rebuilt using either of two checkboxes in the 
Build Framing dialog:
• Select a Build checkbox to build auto-

matic framing once. For example, check 
Build Wall Framing on the WALL panel 
to build wall framing once based on the 
current state of the model. If the model is 
changed later, you may need to do this 
again. 

• Select an Automatic checkbox to build 
automatic framing every time a change is 
made to that structural component in the 
plan. For example, check Automatic 
Wall Framing on the WALL panel to 
rebuild all wall framing any time a wall is 
affected by changes to the model. 

When floor, ceiling or roof framing is 
regenerated, all automatically produced 
framing objects and any copies of them are 
deleted and new framing is calculated. See 
“Rebuilding and Retaining Framing” on page 
581.

Manual Framing
It is vital to remember that manually drawn 
framing objects and copies of them are not 
retained when automatic framing is rebuilt. 

If a plan is not final, therefore, do not spend a 
lot of time altering or copying automatically 
produced framing objects. It is best to wait 
until your design is final before doing 
manual framing work. 

Build Framing for 
Selected Object

If changes are made to a wall, roof 
plane, or ceiling plane that require its 

framing to be rebuilt, you do not have to 
rebuild all of the framing in that object’s 
category.  Instead, you can click the Build 
Framing for Selected Object edit button.

Build Framing for Selected Object  is 
only available for walls using a framed wall 
type, and for railings specified as Solid. See 
“Wall Type Definitions” on page 302.

Build Framing for Selected Object  is 
not available if the selected object has 
Retain Framing specified. See “Rebuilding 
and Retaining Framing” on page 581. 

Framing and the Materials List
Each framing member created in a plan is 
counted in the Materials List. See “Materials 
Lists” on page 1283.

Framing can be calculated using one of 
several reporting methods. See “Structural 
Member Reporting” on page 1286.

Depending on what a framing member is 
used for, it may be listed in the Framing (F), 
Subfloor (SF), or Roofing (R) category. See 
“Categories” on page 1290.
• Framing includes all wall framing, posts, 

and General Framing objects.
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• Sub Floor lists floor and ceiling framing 
joists as well as sheathing.

• Roofing includes trusses, rafters, and 
sheathing.

It is important to note that the floor, ceiling, 
and roof framing counted in the Materials 
List may vary considerably depending on 
whether framing of those types is actually 
present in the plan: 
• If no framing is present in the model, then 

the required floor, ceiling, and roof fram-
ing is estimated. Total lineal footage for 
various depths of rafters and joists is esti-
mated, rather than a quantity of specific 
lumber lengths and sizes. Wall framing is 
not estimated. 

• If even one floor, ceiling, or roof framing 
object exists in the plan, then objects  in 
that category are counted instead of esti-
mated for the Materials List. 

Framing Member Types
A variety of framing member Types is 
available for use in Chief Architect: Lumber, 
I-Joist, Glulam, Engineered Lumber, LVL, 
Steel I, Steel Box, Solid Concrete, C 
Channel, and U Channel. In addition, Round 
is an available Type for posts.

You can select any of these Types as the 
default for floor and ceiling framing, 

headers, posts and beams, and roof framing. 
See “Build Framing Dialog” on page 586. 

You can also specify the Type for individual 
framing members in their specification 
dialog. See “General Panel” on page 611.

Changing the framing member Type does not 
affect how framing is placed, but it may 
change its profile in cross section and 3D 
views and will affect its description in the 
Materials List. 

The framing member Type does not affect 
the appearance of the material used by a 
framing member in 3D views. See “Framing 
Materials and Types” on page 606. 

Structural Member Reporting
You can specify whether framing materials 
are calculated by lineal foot, as a cut list, or 
as a buy list. See “Structural Member 
Reporting” on page 1286. 

Framing Materials and 
the Materials Panel

The materials applied to framing objects in 
3D views are not used in the Materials List. 
Materials List information is derived from 
the structural use of each framing object and 
its Type - not the material seen on its 
surfaces in 3D views. See “Materials Panel” 
on page 599.

Framing Specification Dialog
Select a framing member and click the 
Open Object edit button to open the 

Framing Specification dialog for the type of 
framing member selected. 

The settings in this dialog are similar to those 
in the Post and Beam Specification and 
Defaults dialogs. See “Framing with Beams” 
on page 582.
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General Panel
The options available in on the GENERAL 
panel will vary depending on the type of 
framing member selected.

For Roof Rafters, Roof Beams, and 
Roof Blocking only, uncheck 

Automatic Height to enable the Manual 
Height settings that follow. 

Depth and Height - 

• Check the box beside Raise/Lower, then 
enter a positive value to raise or negative 
value to lower the framing object from its 
current position. The amount is added to 
both the Top and Bottom Heights when 
you click either Apply or OK, and does 
not affect the Depth. When Raise/Lower 

1

2
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is checked, the other Depth and Height 
settings are disabled. 

• Select a radio button to specify whether to 
Lock the Top, Bottom, or Total Height of 
the selected object. Click the radio button 
beside one of the height values to lock it, 
then change a value that remains avail-
able. 

• Specify the Top Height of the post, as 
measured from the first floor subfloor at 
0”. For a rafter, this is the top height at its 
low end.

• Specify the Bottom Height of the post, as 
measured from the first floor subfloor at 
0”. For a rafter, this is the bottom height 
its low end.

• Specify the Depth of the framing object. 
For a rafter, this is the depth measured 
perpendicular to the roof plane.

• Manual Rafter Height - Normally, the 
height of each Rafter or Roof Beam end is 
reset after any move or edit so that it is 
located just under the roof surface. Check 
this box to allow the height of the object 
to be changed. Only available for Rafters 
and Roof Beams. 

Options - 

• Set the framing member’s Width, as seen 
in floor plan view.

• Specify a selected wall framing member’s 
Thickness, as seen in floor plan view. 
Only available for wall framing.

• Select a structural member Type from the 
drop-down list. The Round Type is unique 

to Posts. See “Framing Member Types” 
on page 610.

• Check Show Cross to display the selected 
Post as a cross box in floor plan view. 
Only available for Posts. See “Displaying 
Framing” on page 604.

• Check Bearing Beam to specify the 
selected Floor/Ceiling Beam as a load-
bearing beam. When checked, automati-
cally generated joists run perpendicular to 
the selected beam and either lap or butt 
over it, as specified in the Build Framing 
dialog. If the beam’s Top Height is at least 
1” higher than the joists’ bottom height, 
the joists will instead butt against the 
sides of the beam. See “Framing with 
Beams” on page 582. Only available for 
Floor/Ceiling Beams. 

• Check Treated to specify that the selected 
framing member be counted as treated in 
framing schedules and the Materials List.

• The Rotate options let you rotate and 
align a selected wall stud or blocking 
within the wall’s framing layer. Select 
None for the framing member’s Thick-
ness to span the depth of the framing 
layer; select Flat to Outside to rotate the 
member 90° and align it with the outside 
of the framing layer; select Flat to Inside 
to rotate the member 90° and align it with 
the inside of the framing layer. 

3

Note: Instead of counting individual concrete
posts and beams in the Materials List, the
total volume of their concrete is calculated.
The square footage for beam and post forms
is also listed.
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Length and Angle - Lock the point 
about which you want like the selected 

object to resize and/or rotate, then specify its 
exact length and angle. See “Editing 
Framing” on page 607. 
• Specify the Length of the framing object. 

Rafter length is measured along the top of 
the rafter, and so is greater than the length 
measured in floor plan view. Not avail-
able for Posts.

• Width 1 and 2 - Specify the Post width in 
each dimension. When a Round Post is 
specified, Width 1 refers to its diameter 
and Width 2 is not available.

• Specify the Angle of the framing object in 
floor plan view. Changing this rotates the 
object about the location specified by the 
radio buttons described below.

• Select Lock Center to resize or rotate the 
object about its center point. 

• Select Lock Start to resize or rotate the 
object about the location from which you 
started drawing the framing object.

• Select Lock End to resize or rotate the 
object about the location where you 
stopped drawing it.

Specify the Rebar and Stirrups for 
concrete Posts and Beams. The Rebar 

and Stirrup settings are only available when 
the selected object is a Post or Beam and 

“Solid Concrete” is selected from the Type 
drop-down list. 
• Specify the Size Number for both Rebar 

and Stirrups.
• Specify the Count, or number of bars, for 

both Rebar and Stirrups.
• Specify the length of Rebar Extensions. 
• Specify the distance that Stirrups Over-

lap.

Rafter Tails Panel
The RAFTER TAILS panel is only available for 
Rafters, Subfascia, and Roof Beams. The 
settings here allow you to specify a rafter tail 
profile for exposed end rafter ends under roof 
eaves. See “Rafter Tails Panel” on page 487. 

Line Style Panel
The settings on the LINE STYLE panel affect 
the selected object’s line style, its bumping 
behaviors, and its drawing order. For more 
information about the settings on this panel, 
see “Line Style Panel” on page 1085.

Fill Style Panel
The settings on the FILL STYLE panel affect 
the selected object’s appearance in floor plan 
view. For information about these settings, 
see “Fill Style Panel” on page 1099.

Materials Panel
The default materials on this panel are set in 
the Build Framing dialog. If you change the 
selected object’s framing Type, the material 
here may update - unless you have specified 
a non-default material. For information about 
the settings on this panel, see “Materials 
Panel” on page 852.

Flat to Inside

Flat to OutsideNone

4

5
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Label Panel
Framing labels can display in floor plan view 
and cross section/elevation views when the 
“Framing, Labels” layer is turned on and use 
the Text Style assigned to that layer. See 
“Text Styles” on page 1061.

Automatically generated wall framing can 
also display in Wall Detail views. When 
accessed from a Wall Detail, this panel will 

have Wall Detail Position and Orientation 
settings.  

For more information about the settings on 
this panel, see “Label Panel” on page 1280.

Framing Schedules
The Framing Schedule tool allows 
you to produce customizable framing 

schedules as well as framing labels that 
display schedule numbers. See “Schedules 
and Object Labels” on page 1267.

Schedules of particular types of framing can 
be created by controlling which Objects to 
Include in the schedule. For example, a 
Deck Framing Schedule can be created by 
including “Deck” Objects while excluding 
all other Object types. See “General Panel” 
on page 1274. 

Framing schedules created in Wall 
Detail  views use a special Only Include 
Objects from this Detail setting and a 
selection of Objects to Include that report 
only wall framing members present in the 
current view. See “In Wall Detail Views” on 
page 605. 

If placed into a Truss Detail, a framing 
schedule’s Objects to Include will be 
restricted to floor, ceiling, and roof trusses. 
Only Include Objects from this Detail is 
also used. See “Truss Details” on page 621.

Note: If a framing member is listed in a
schedule using callout labels, the settings
here are overridden and the schedule label is
used instead. 
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Chapter 17:

Trusses

There are two basic ways to frame a roof. 
The first is commonly called “stick framing,” 
or sometimes “handstacking” or “cut-and-
stack.” This type of roof incorporates 
framing such as rafters, ridges, and ceiling 
joists. See “Framing” on page 577.

The other method is to use prefabricated, 
engineered roof trusses. Chief Architect 
allows you to design and display a wide 
variety of trusses.

Disclaimer
Chief Architect does not engineer trusses. 
The trusses displayed by Chief Architect are 
for illustrative purposes only. They can show 
how trusses are used in your plan, and help 
you communicate to the licensed engineer 
who produces your final truss design where 
you want your trusses and how you would 
like them to work.

Chapter Contents
•      Truss Defaults
•      Floor and Ceiling Trusses
•      Roof Trusses
•      Drawing Trusses
•      Displaying Trusses
•      Editing Trusses
•      Editing Truss Envelopes
•      Truss Details
•      Truss Labels
•      Mixing Trusses with Stick Framing
•      Truss Bases
•      Truss Base Specification Dialog
•      Hip Trusses
•      Special Roof Trusses
•      Roof Truss Specification Dialog
•      Floor/Ceiling Truss Specification Dialog
•      Framing and Truss Schedules

Always have your truss designs
approved by a licensed engineer.
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Truss Defaults
The default settings for floor, ceiling 
and roof trusses are set in the Framing 

Defaults dialog. Select Edit> Default 
Settings and in the Default Settings dialog, 
select Framing and click the Edit button.
• The default settings for truss chord and 

webbing depth, maximum span, and king-
post are set in the Framing Defaults dia-
log. See “Trusses Panel” on page 597. 

• The overall depth of individual Floor/
Ceiling Trusses  are based on the 
thicknesses of the platforms in which they 
are drawn. See “Floor Panels” on page 
586. 

• The structure of Roof Trusses  is 
determined by the position of the roof 
plane(s) above and the ceiling plane(s) 
below. See “Roof Planes” on page 488 
and “Ceiling Planes” on page 511. 

Floor and Ceiling Trusses
Floor and ceiling trusses can be used 
instead of joists to frame platforms. 

As with manually-drawn floor and ceiling 
framing, the presence of a room above 
determines whether a floor or ceiling truss is 
drawn. For example, a truss drawn on the 
first floor of a single story home will be a 
ceiling truss, while a truss drawn on the first 
floor of a two-story building will be a floor 
truss for the 2nd floor.

Floor and ceiling trusses can only be drawn 
manually. To place a floor or ceiling truss in 

your plan, select Build> Framing> Floor/
Ceiling Truss , then click and drag within 
a floor or ceiling platform in floor plan view. 
See “Drawing Trusses” on page 617. 

The TRUSSES panel of the Build Framing 
dialog contains default settings for floor and 
ceiling trusses. See “Trusses Panel” on page 
597. These default settings can be overridden 
by the settings in the Floor/Ceiling Truss 
Specification dialog. See “Floor/Ceiling 
Truss Specification Dialog” on page 634.

Roof Trusses
Roof trusses can be used instead of or 
in combination with rafters to frame 

roofs and ceilings.  

Roof trusses can only be drawn manually, 
and can only be created where roof and 
ceiling planes already are present. Select 

Build> Framing> Roof Truss , then 

click and drag in floor plan view within one 
or more roof planes to manually draw a roof 
truss. See “Drawing Trusses” on page 617. 

If you intend to use roof trusses, you need 
first to build your roof planes with this in 
mind. Before building the roof, select the 
Trusses (no Birdsmouth) checkbox in the 
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Build Roof dialog. When this is checked, 
roof plane thickness is based on the default 
Top Chord Depth set in the Framing 
Defaults dialog. See “Trusses Panel” on page 
597.

If Trusses (no Birdsmouth) is not checked, 
the roof plane thickness is determined by the 
rafter Depth setting on the ROOF panel of the 
Framing Defaults dialog. If you plan to use 
both trusses and rafters, you should leave this 
unchecked. 

Roof Truss Placement
A roof truss can only exist in the space 
defined by the roof planes above it and the 
ceiling planes below it. This is because the 
shape of a truss is defined by the location of 
the roof and the ceiling. 

If Ceiling Over This Room is unchecked in 
the Room Specification dialog, you must 

manually draw a Ceiling Plane  before a 
roof truss can be drawn over that room. See 
“Structure Panel” on page 352.

If the program either does not find both roof 
and ceiling planes, or if there is not enough 
room between them, to model a truss, a 
warning message displays. For example, if 
you draw a truss in a roof overhang where 
there is no ceiling, this message displays:

“Roof and ceiling surfaces too close together 
or cannot be found, so cannot make truss.” 

The incorrect truss may still display in floor 
plan view with a label of the form “TR-*”. If 
it does, it should be deleted or moved. See 
“Editing Trusses” on page 619.

One or both ends of a truss may be truncated 
if they are drawn across another truss. If this 
happens, it will end exactly on the surface of 
the existing truss, producing a girder truss. 
See “Girder Trusses” on page 631.

Trusses can end on interior walls. You can 
draw a truss that partially crosses the 
building by starting and/or ending it within 
24” (600mm) of an interior wall. The truss 
extends over the wall’s Main Layer. Its end 
lines up with the Main Layer surface on the 
far side of the wall.

Roof Truss Webbing
The webbing in a newly drawn truss is 
controlled by the Top Chord and Bottom 
Chord settings in the Framing Defaults 
dialog. See “Trusses Panel” on page 597.

Changing these default values may cause 
different truss configurations such as 
kingpost, queenpost, fink, double fink, fan, 
howe, or double howe to be represented. 

Drawing Trusses
Trusses cannot be generated automatically: 
the must be manually drawn and then 
replicated. All trusses are drawn similar to 
the way CAD lines are and can be drawn in 
floor plan view only. See “Draw Line” on 
page 1080. 

To draw and replicate trusses

1. Select the either the Floor/Ceiling 
Truss  or Roof Truss  tool, then 
click and drag within either a floor/ceil-
ing platform or one or more roof planes.
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•  Roof trusses seek an exterior wall and 
adjust their length automatically. 

•  Floor/Ceiling trusses will snap to the 
wall surfaces, the exterior surface of a 
wall’s Main Layer, as well as to a vari-
ety of CAD-based objects, and can be 
drawn to any length.

2. Reposition the truss:
•  Floor/ceiling trusses are often posi-

tioned relative to an exterior wall or 

Framing Reference Marker . See 
“Framing Reference Markers” on page 
599.

•  Roof trusses are can be positioned over 
a gable end wall or at the ridge end of a 
hip. 

3. Open the truss’s specification dialog and 
edit its settings to meet your needs. See 
“Roof Truss Specification Dialog” on 
page 631 or “Floor/Ceiling Truss Speci-
fication Dialog” on page 634. 

4. Make multiple copies of the truss at 
specified intervals using the Multiple 
Copy  edit tool.

The copies of Roof Trusses automatically 
conform to the structural conditions in their 
new locations. As a result, replicated Roof 
Trusses and their labels may be different 

from the original. See “Truss Labels” on 
page 621. 

Unlike Roof Trusses, Floor/Ceiling Trusses 
do not conform to new structural conditions 
when they are either moved or copied. See 
“Moving Trusses” on page 620.

To replicate trusses using Multiple Copy

1. Select the truss to be copied in floor plan 
view.

2. Click the Multiple Copy  edit 
button. 

3. Click the Multiple Copy Interval  
edit button to open the Multiple Copy 
dialog. See “Multiple Copy” on page 
173.

4. Enter the correct spacing in the All 
Trusses box. Once set, click OK.

5. Select the truss and use the Move edit 
handle to drag it perpendicularly. The 
pointer becomes a four-headed arrow  
when it is over the Move handle. 

6. New trusses appear as you drag. Drag as 
far as necessary to produce all desired 
trusses. Each truss is created according 
to the particular Roof/Ceiling/Truss 
Base planes above and below it. 

Displaying Trusses
The display of trusses and their labels 
is controlled in the Layer Display 

Options dialog. See “Layer Display Options 
Dialog” on page 149.

Truss labels display in floor plan view, cross 
section/elevation views, and the Truss Detail, 

and are used in the Materials List. See “Truss 
Labels” on page 621.

In 3D Views
The easiest way to view trusses in 3D is to 
use either the Orthographic Framing 
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Overview  or Perspective Framing 
Overview  tool, which display the model 
using the 3D Framing Set layer set. See 
“Framing Overview” on page 901. 

Trusses can display in other 3D and cross 
section/elevation views, although by default 
they are not set to do so. If you wish to see 
trusses in these views, turn on the “Framing, 
Trusses” layer in the appropriate layer set.

You can create exposed trusses by placing 
roof and ceiling planes to produce the desired 
truss structure, drawing the trusses, and then 
removing the ceiling. See “Vaulted and 
Cathedral Ceilings” on page 347. 

To reveal trusses covered by other objects, 

you can use the Delete Surface  tool. See 
“Delete 3D Surface” on page 910.

In the Truss Detail
All the floor, ceiling and roof trusses present 
in the current plan display in the Truss 
Detail, which is a special CAD Detail 
window in which a diagram of each truss 
configuration present in the plan is 
automatically generated. See “Truss Details” 
on page 621.

In the Materials List
All trusses are listed under the Roofing 
category in the Materials List. Their labels 
appear in the Size column, along with their 
length. See “The Materials List Tools” on 
page 1284. 

Editing Trusses
Trusses can be selected like other objects in 
Chief Architect. See “Selecting Objects” on 
page 183 for more information.

Once selected, trusses can be edited using 
dimensions, their edit handles, the edit 
toolbar buttons, or by opening them for 
specification.

When Start and End Indicators are enabled 
in the Preferences dialog, a truss selected in 
floor plan view will display an S and an E at 
its start and end points.  See “Edit Panel” on 
page 111.

Trusses can be deleted all at once in the 
Delete Objects dialog. See “Delete Objects 
Dialog” on page 255.

Using Dimensions
Trusses can be relocated precisely using 
dimensions. See “Moving Objects Using 
Dimensions” on page 1019.

Using the Edit Handles
When selected in floor plan view, trusses edit 
like CAD lines. See “Editing Line Based 
Objects” on page 187.

The depth of truss chords can be changed in 
the truss’s specification dialog, but not using 
the edit handles.

When selected in Cross Section/Elevation 
views and 3D views, trusses edit like closed 
polylines. See “Editing Closed-Polyline 
Based Objects” on page 201.
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Like joists or rafters, trusses can be selected 
and moved in 3D views. The only difference 
is that the Lock Truss and Webbing setting 
in the Roof Truss Specification dialog 
prevents the truss from moving back to 
between the roof and ceiling planes the next 
time it is edited or otherwise changed. 

Using the Edit Tools
A selected truss can be edited in a variety of 
ways using the buttons on the edit toolbar. 
See “The Edit Toolbar” on page 37.

Moving Trusses
Trusses can be moved using their Move edit 

handle, the Multiple Copy  edit tool, or 

the Transform/Replicate Object  edit 
tool. 

When a Roof Truss  is moved, it snaps to 
two things: 
• If drawn along an exterior wall, it snaps 

so that its outer surface is flush with the 
outer surface of the wall's Main Layer. 

• The center line can snap to the edge or 
corner of a nearby roof plane. 

To prevent this, special snapping, check No 
Special Snapping in the Roof Truss 
Specification dialog. See “General Panel” 
on page 631.

In addition, when a Roof Truss  is 
moved, its shape updates to conform to the 
structural conditions defined by the roof and 
ceiling in its new location. As a result, a Roof 
Truss’s label could change when the truss is 
moved to a new location. To prevent this 
from occurring, check Lock Truss Envelope 
in the Roof Truss Specification dialog 
before moving the truss. See “Roof Truss 
Specification Dialog” on page 631.

This is not the case with Floor/Ceiling 
Trusses : when moved to a location with 
a different platform structure, a Floor/Ceiling 
Truss will not update to conform to its new 
surroundings. It is important to draw, 
position, and copy them within the same 
floor or ceiling platform structure. If a 
different Floor/Ceiling Truss depth is 
needed, a new truss should be drawn. 

Editing Truss Envelopes
When a truss is viewed at a 90° angle in a 3D 
view, its envelope, or shape, can be edited. 
Click on the truss to select it and edit handles 
display on a surrounding polyline. Change 
the shape of this polyline and the truss 
regenerates inside it. Use this function to 
change overhang or truss end details rather 
than the overall truss shape.

The Lock truss and webbing attribute is set 
after editing so that the truss does not reshape 
itself back between the roof and ceiling 
planes the next time it is edited or otherwise 
changed. See “Roof Truss Specification 
Dialog” on page 631. 
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Truss Details
A Truss Detail is a special CAD 
Detail window in which a diagram of 

each truss configuration present in the plan is 
drawn. To open a plan’s Truss Detail, select 

CAD> CAD Detail Management . See 
“CAD Details” on page 1117. 

You can also select a Floor/Ceiling or Roof 

Truss and click the Open Truss Detail  
edit button. The Truss Detail will open 
centered on the selected truss. 

A Truss Detail is created automatically when 
a truss is created, and displays all trusses 
present in the current plan. If multiple trusses 
are identical, they share a single diagram. 
Each truss’s label displays centered below 
the truss diagram. When automatic or custom 

labels are in use, the quantity of each truss 
configuration is also listed.

In a Truss Detail, individual chords and 
webbing are represented using framing 
members. The truss label information is 
presented in a Text object. 

The trusses in a Truss Detail are linked to the 
actual trusses in the plan. If you move a truss 
in a Truss Detail, it will move in the model as 
well. To modify the information in a Truss 
Detail without affecting the model, use CAD 
Detail From View  to create a line-drawn 
copy first. See “CAD Detail from View” on 
page 1118.

To restore an edited Truss Detail diagram

1. Delete any new members you have 
drawn in the detail view.

2. In floor plan view, select the truss and 

click the Open Object  edit button to 
open the Roof Truss Specification dia-
log.

3. Check Force Truss Rebuild and click 
OK and the truss regenerates along with 
its Truss Detail diagram.

Truss Labels
Labels for roof  trusses display when the 
“Framing, Roof Truss Labels” layer is turned 

on in the current view. Similarly, floor and 
ceiling trusses display when the “Framing, 

Note: The Truss Detail is for display of
trusses only. Editing the members that make
up the trusses in the Truss Detail is possible
but not recommended. 
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Floor/Ceiling Truss Labels” is turned on. See 
“Layer Display Options Dialog” on page 
149.

Truss labels are available in three formats: 
automatic, user-specified, and schedule 
callouts. See “Object Labels” on page 1279.

Truss labels can display in floor plan view, 
cross section/elevation views, and the Truss 
Detail. Automatic and user-specified labels 
are used in the Label column of the Materials 
List. See “Displaying Trusses” on page 618. 

Truss labels use the Text Style specified for 
their layer in the current view. See “Text 
Styles” on page 1061.

By default, truss labels are centered on the 
truss that they identify. If the truss is moved 
or deleted, the label is moved or deleted as 
well. With the exception of those in the Truss 
Detail, truss labels have their own Move edit 
handle which displays when the truss is 
selected. See “Editing Trusses” on page 619.

Truss labels obey the Minimum Display 
Size for labels set in the Preferences dialog. 
See “Appearance Panel” on page 92. 

If two or more trusses share the same 
configuration with identical chords and 
webbing, they will also share the same truss 
label. In the Truss Detail, automatic and user-
specified labels shared by multiple trusses 
will be followed by the total number of those 
trusses, in parentheses.

Automatic Truss Labels
Automatic roof truss labels use the format 
TR-X, where X is a number indicating the 
order in which each distinct truss 
configuration was created. For example, the 
first truss type created in a plan is labeled 
TR-1; the second, TR-2; and so on. 

Floor and ceiling trusses are labeled FTR-X 
and use the same numbering convention. 

Mixing Trusses with Stick Framing
After the trusses for your roof are in place, 
additional roof framing can be added. See 
“Roof Framing” on page 579. 

Framing Defaults
Roof planes created using defaults set up for 
trusses will continue to use those defaults 
when stick framing is added. If you intend to 
add rafters, the roof planes should be created 
while Trusses (no Birdsmouth) is 
unchecked in the Build Roof dialog. See 
“Roof Panel” on page 481.

Leaving Trusses (no Birdsmouth) 
unchecked has a similar effect on roof trusses 

to that of Raise Off Plate: roof truss bottom 
chords may be longer than expected and their 
top chords, higher. This is necessary to create 
the space needed to accommodate the rafter’s 
depth.
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Automatic Framing
The Build Framing dialog can be used to 
generate roof framing in areas not framed by 
the trusses, including gable eaves and the 
ends of hips. Note that rafters will not 
generate closer than 14” (350mm) to an 
existing, parallel truss. 

Automatically generated roof framing will 
not extend through an existing roof truss. 
Instead: 
• Automatically produced rafters generate 

inward from the eave until they butt into a 
truss. 

• Blocking for standard and hip ridges gen-
erates as individual rafter objects between 
trusses. 

• Lookouts will pass over Reduced Gable 
trusses and will end at the next truss in. 
See “Roof Truss Specification Dialog” on 
page 631.

• Hip ridges and common rafters at the end 
of a hip roof will pass over a Drop Hip 
Truss. See “Drop Hip or California Hip” 
on page 628.

Manually Drawn Framing
Unlike automatically generated roof framing, 
manually drawn rafters will extend through 
trusses. Rafters can also snap to truss edges 
as they are being drawn or when they are 
being edited. See “Manual Framing” on page 
580. 

Truss Bases
A Truss Base is a closed polyline that 
defines the area in which valley fill 

roof trusses are to be built across and above 
the tops of normal, full size roof trusses. 

Valley fill trusses are often used in reverse 
gable conditions, where a roof ridge builds 
onto a roof plane that has a ridge running at a 
different angle. A classic example of this is 
an “L” shaped house with a gable roof. The 
main portion of the house is trussed through 
from end to end with normal trusses. Starting 

at its outside end, the smaller wing is trussed 
with normal trusses until the main house is 
reached. Where the wing’s roof builds over 
the main house, valley fill trusses are used. 

Normal roof trusses are built between roof 
planes and ceiling planes. See “Roof 

Valley fill trusses (shown darker)

Truss Base (in red) with valley fill trusses 
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Trusses” on page 616. Valley fill roof trusses 
created using a Truss Base, on the other 
hand, are built between a larger, supporting 
roof plane below and overbuilt roof planes 
above.

Truss bases are drawn and can be edited 
much like roof planes, with some limitations. 
See “Truss Base Specification Dialog” on 
page 626. 

To work correctly, a truss base must be in the 
same plane with the underlying roof plane, 
so their baselines should be collinear.

To create a truss base

1. Create an L-shaped house with a reverse 
gable roof.

The triangular area of overlap between the 
main roof and the gable must be defined as a 
Truss Base. 

2. Select Build> Roof> Truss Base , 
then draw a baseline that is collinear 
with the baseline of the roof plane that 

will support the overbuild. See “The 
Baseline” on page 489. 

3. Move the pointer and click on the point 
where the gable intersects the main roof.

4. A rectangular Truss Base is created. Use 
its edit handles to reposition it and 
change its shape as needed.

•  The two angled sides should be collin-
ear with the roof valleys.

•  The straight bottom edge must remain 
collinear with the Truss Base baseline 
and that of the underlying roof plane.



Truss Bases

 625

5. Draw the normal Roof Trusses  
across the length of the main portion of 
the house. See “Roof Trusses” on page 
616. 

•  The trusses of the underlying roof gen-
erate through the Truss Base, but stop 
at the Truss Base’s bottom edge so that 
no overhang is produced in that area. 

6. When the trusses of the underlying roof 
are in place, draw the first truss of the 
reverse gable and position it over the 
outer wall. 

7. With this truss selected, click the 
Multiple Copy  edit button and drag 

the Move edit handle up to the peak of 
the Truss Base. 

•  Copies of the truss appear as you drag 
the pointer. 

•  The truss copies all appear to be full 
length until you release the mouse.

8. When you release the mouse button, any 
copies drawn in the Truss Base are 
clipped by it. 

Trusses drawn perpendicular to the
baseline of a Truss Base go under the

Truss Base. Trusses drawn parallel to the
baseline of the Truss Base become valley fill
trusses drawn over it..
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Editing Truss Bases
A selected truss base can be edited in floor 
plan view using edit handles, edit toolbar 
buttons, and the Truss Base Specification 
dialog.

Truss bases can be edited much the way roof 
planes can, with some limitations. They are 
not actual 3D objects, so they cannot be 
assigned materials, moldings or other design 
attributes; however, their shape, height, pitch 
and display can be edited.  See “Editing Roof 
and Ceiling Planes” on page 492.

Truss Base Specification Dialog
Select a truss base and click the Open 
Object edit button to open the Truss 

Base Specification dialog. 

This dialog  is almost identical to the Roof 
Plane Specification dialog. Although truss 
bases are not the same as roof planes, Chief 
Architect handles the positioning of the two 
in a similar manner. 

General Panel

Four values define 3D orientation of a truss 
base: Ridge/Top Height, Baseline Height, 
Fascia Top Height, and Pitch. These values 
are related; if one is changed, the others 
change as well. 

These values are measured from the first 
floor elevation of 0’ 0". Baseline Height and 

Pitch should be set identical to those for the 
roof plane that surrounds the truss base.

Click the radio button to the right of a value 
to define it as the pivot point for the truss 
base and prevent it from being changed.
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Changing these values does not affect the 2D 
representation of the truss base.

Specify the Height/Pivot of the selected 
truss base.
• Specify the Ridge/Top height, which is 

the truss base’s highest point.
• Specify the Baseline height. 
• Specify the Fascia top height, which is 

the truss base’s lowest point. Usually, this 
is the same height as the Baseline.

• Specify the Pitch of the selected truss 
base. If you lock the pitch and change one 
of the Height values, the truss base moves 
vertically keeping the same slope. 

• Check Pitch in Degrees to display pitch 
in degrees rather than run-and-rise units. 

Polyline Panel
The POLYLINE panel states the length of the 
truss base’s Perimeter and its enclosed 
Area. Truss bases have no thickness, so they 

do not have a Volume. See “Polyline Panel” 
on page 1098.

Selected Line Panel
For information about the SELECTED LINE 
panel, see “Line Panel” on page 1084.

Line Style Panel
The settings on the LINE STYLE panel affect 
the appearance of the selected Truss Base in 
floor plan view. For information about these 
settings, see “Line Style Panel” on page 
1085.

Fill Style Panel
The settings on the FILL STYLE panel affect 
the appearance of the selected Truss Base in 
floor plan view. For information about the 
settings on this panel, see “Fill Style Panel” 
on page 1099.

Hip Trusses
A variety of different hip truss configurations 
can be created, including: 
•      Step Down Hip trusses
•      Drop Hip or California Hip trusses
•      Subgirder Hip trusses 

Step Down Hip
Step Down hip roofs are the quickest style of 
hip truss framing to produce. 

To create a step down hip truss system 

1. First, draw a Roof Truss  at the apex 
of the triangular hip roof plane. When 

Object Snaps  are enabled, it will 
snap into position. See “Object Snaps” 
on page 162.

2. Select the truss; click the Multiple 
Copy  edit button; and click and drag 
the Move handle down into the hip to 
create copies at regular intervals. See 



628

Chief Architect X8 Reference Manual

“To replicate trusses using Multiple 
Copy” on page 618. 

3. Stop when the height of the hip truss 
reaches a reasonable minimum. 

4. Using the Roof Truss  tool, draw hip 
jacks along the hip ridge from the last 
truss out into the overhang.

5. Using the Roof Truss  tool, draw a 
jack truss from the intersection of the 
last hip truss and the hip jack to the eave. 

6. Select the jack truss; click the Multiple 
Copy  edit button; and lay out jack 
trusses up to the other hip jack.

Drop Hip or California Hip
A Drop Hip, or California Hip, system uses 
trusses with lowered top chords to support 
stick frame hip ridges and common rafters. 

To create a drop hip truss system

1. Start a drop hip truss system as you 
would a step down hip system.

2. When the hip trusses are drawn, group 
select them, open the Truss 
Specification dialog, and select the 
Drop Hip Truss checkbox. See “Gen-
eral Panel” on page 631.

3. Use the Build Framing dialog to pro-
duce the common rafters, and the short 

joists at the hip end. See “Build Framing 
Dialog” on page 586.

The amount that the top chord is lowered is 
derived from the rafter Depth on the ROOF 
panel of the Framing Defaults dialog. 
Because both common rafters and hip ridges 
must pass over this truss, the ridge depth 
should be set equal to that of the rafter depth. 

Subgirder Hip
Subgirders are the partial trusses that butt 
into the doubled truss at the end of the main 
run. 

To create a subgirder truss system

1. Draw a Roof Truss  where the hip 
apex meets the ridge.

2. Double it by drawing a second truss on 
the far side from the hip section. 

3. Using the Roof Truss  tool, draw the 
first subgirder from the hip apex out to 
the eaves. 

4. Select it and use the Multiple Copy  
edit button to make copies in both direc-
tions. Stop when the height of the sub-
girders reach a reasonable minimum.

5. Finish off with hip jacks and jack trusses 
as in a step down hip system.

Special Roof Trusses
A number of special purpose roof trusses can 
be created in Chief Architect. 

Energy Heels
To provide more space for ceiling insulation 
at the exterior walls, roofs are sometimes 



Special Roof Trusses

 629

raised off of the top plate with an energy 
heel. To create a truss with an energy heel, a 
vertical member is added over the supporting 
wall and the bottom chord stops there rather 
than extending into the overhang. 

To create an energy heel

1. In the Build Roof dialog:
•  Check Trusses (no Birdsmouth);
•  Uncheck Automatic Birdsmouth Cut;
•  Specify the desired energy heel height 

as a positive Raise Off Plate value.
2. Automatically generate or manually 

draw the roof planes.
3. Draw and position the first truss. See 

“To draw and replicate trusses” on page 
617. 

4. Open this truss’s specification dialog 
and check Energy Heel and Force 
Truss Rebuild, then click OK. See 
“Roof Truss Specification Dialog” on 
page 631. 

5. Use the Multiple Copy  edit tool to 
replicate the truss as needed. 

Attic Trusses
Attic trusses, a variation of roof trusses, can 
be drawn if a plan contains an Attic area on 
both sides and above an upstairs room, such 
as in a Cape Cod style home. The following 
is a typical cross section view of a building 
with attic trusses:

Certain conditions must be met before an 
attic truss can be built: 
• The structure should be sufficiently wide 

to allow for a loft and attic spaces.
• The loft area must be on a living floor. It 

cannot be on the Attic floor. See “The 
Attic Floor” on page 444.

• The loft area must have Attic rooms on 
both sides. See “Room Types” on page 
335.

• The loft area must be separated from the 
Attic rooms on both sides by Knee Walls. 
See “Knee Walls” on page 297.

• A flat ceiling in the loft area and a floor 
below must be present. 

• The roof pitch must be steep enough to 
provide appropriate ceiling height for the 
loft area. Typical pitches for such a condi-
tion are 8 in 12 or greater.

• The roof should bear on the walls of the 
floor below the loft area and form contin-
uous planes from ridge to baselines.

Energy Heel

No Energy Heel

 Flat ceilings

 Knee walls
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Once these conditions are met, a roof truss is 
ready to be designated as an attic truss. 

1. Select the roof truss in floor plan view 

and click the Open Object  edit 
button to display the GENERAL panel of 
the Roof Truss Specification dialog. 

2. Select the Attic Truss checkbox and 
click OK. See “Roof Truss Specification 
Dialog” on page 631.

The final product can be scrutinized in a 
framing overview or in the Truss Detail 
window. See “Truss Details” on page 621.

Ceiling Steps
If a roof truss is drawn across areas with 
different ceiling heights on the top floor of a 
plan, the bottom chord will automatically 
step to accomodate those ceiling heights.

In addition, a roof truss can be made to 
recognize ceiling heights on two different 
floors: one on the top floor of the structure 
and one on the floor below. 

To create a ceiling step

1. The area in which the step is to be pro-
duced must be a separate room specified 
as an “Attic”. See “Room Types” on 
page 335.

2. Select the roof truss in floor plan view 

and click the Open Object  edit 
button to display the GENERAL panel of 
the Roof Truss Specification dialog. 

3. In the Ceiling Step field, specify the dis-
tance that the bottom chord must step 
down to locate the ceiling platform of 
the room beneath the Attic.

•  If the Ceiling Step value will place the 
bottom of the stepped bottom chord 
within the ceiling platform, a step will 
be created to the bottom of the ceiling 
platform.

•  Check Force Truss Rebuild, then click 
OK to regenerate the truss.

4. Use the Multiple Copy  edit tool to 
replicate the truss within the area of the 
roof plan requiring a step. 

For best results, you may want to make sure 
that the Bottom Chord is the same depth as 
the ceiling platform framing. See “Structure 
Panel” on page 352.

Scissors Trusses
Trusses drawn between roof planes and 
sloping ceiling planes of a different pitch 
than the roof are called  Scissor trusses. See 
“Ceiling Planes” on page 511.

The following is an example of a scissors 
truss drawn beneath a 8 in 12 pitch gable roof 
and above 4 in 12 pitch ceiling planes. 
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Girder Trusses
Girder trusses provide support for trusses 
that are cut short, for example, by a reverse 
gable or a skylight. They are often doubled- 
or tripled-up for strength. 

Draw a new truss from an existing truss to 
the roof edge, as you would to draw a hip or 
end jack truss; or draw a truss between two 
trusses, forming a girder. This may be 

necessary for a large opening, such as a 
skylight.

Trusses cannot be drawn through each other. 
If a truss is drawn through an existing truss, 
the program automatically shortens it so that 
it butts into the existing truss.

Roof Truss Specification Dialog
Select a roof truss or group of roof 
trusses and click the Open Object edit 

button to open the Roof Truss Specification 
dialog. 

The Roof Truss Specification dialog allows 
you to redefine parts of an existing truss or 
group of trusses. Some settings affect only 
individual trusses, such as gable trusses, 
while others affect the whole group.

The shape or volume of a roof truss is 
controlled by the roof planes above it and the 
ceiling planes below it. It cannot be changed 
from this dialog.

General Panel
The defaults for many of the settings on the 
GENERAL panel are set in the Build Framing 
dialog. See “Trusses Panel” on page 597. 

Truss webbing is drawn for representa-
tional purposes only and as with trusses

in Chief Architect in general, is not engi-
neered.
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Member Sizing - Specify the sizes of 
the different members that form the 

selected truss.
• Specify the depths of the Top Chord and 

Bottom Chord.
• Specify the depth of the Webbing.
• Specify the Thickness, which is the width 

of the truss in floor plan view. 
• Specify the Maximum Height of the 

selected truss. 
• Specify the Ceiling Step of the selected 

truss, which is the maximum distance its 
bottom chord can step down to locate a 
ceiling on the floor below the top floor. 
See “Ceiling Steps” on page 630.

Specify the Maximum Span, which is 
the maximum horizontal distance 

between supports along the Top Chord and 

the Bottom Chord. When these values are 
equal, the truss webbing often appears more 
regular.

Additional Options allow you to create 
special truss types.

• Check Require Kingpost to require a 
vertical webbing member from the roof 
peak to the bottom chord.

If Require Kingpost is unchecked, a kingpost 
may still be supplied, depending on the truss 
length and the specified maximum spans. 

1

2

3

Kingpost
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• Check End Truss to replace the webbing 
with vertical members positioned and 
spaced the same as the wall studs below.

If an End Truss is in the same position as a 
gable attic wall, it replaces the framing that 
would otherwise be produced for that wall.
• Check Energy Heel to model remove the 

bottom chord from the overhang area. For 
an energy heel to be modeled, the roof 
should also be raised off the top plates by 
at least 7”, depending on the roof pitch. 
See “Energy Heels” on page 628. 

• Check Drop Hip Truss to lower the flat 
top of a truss in the hip area of a roof so 
that common rafters and hip ridges can 
pass over and be supported by it. See 
“Drop Hip or California Hip” on page 
628.

• Check Reduced Gable to lower the top 
chord of an End Truss so that lookouts 
can pass over the truss. Reduced trusses 

do not have overhangs, but you can draw 
short rafters drawn at the ends of the truss.

• Check Attic Truss to specify an attic 
truss. See “Attic Trusses” on page 629. 

• Check Force Truss Rebuild to rebuild 
the truss envelope based on the current 
state of the ceiling and roof when you 
click OK. Not available if Lock Truss 
Envelope is checked. 

• Check Lock Truss Envelope to lock the 
size and configuration of the selected 
truss. If a locked truss is moved, it will 
maintain its original settings and will not 
fit properly if the new roof and ceiling 
conditions are different from the original.

• Check No Special Snapping to prevent 
the selected truss from snapping along its 
long edge to a wall’s Main Layer or to the 
corner of a roof plane. If enabled, Object 
Snaps  may still occur. See “Object 
Snaps” on page 162.

Line Style Panel
The settings on this panel affect the 
appearance of the selected truss in floor plan 

End Truss with vertical supports

Energy Heel

No Energy Heel

Reduced Gable 
End Truss

Lookouts
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view only. See “Line Style Panel” on page 
1085.

Fill Style Panel
The settings on this panel affect the 
appearance of the selected truss in floor plan 
view. See “Fill Style Panel” on page 1099.

Materials Panel
The settings on the MATERIALS panel affect 
the appearance of the selected truss in 3D 
views. See “Materials Panel” on page 852.

Label Panel
Roof truss labels can display in floor plan 
view and cross section/elevation views when 
the “Framing, Roof Truss Labels” layer is 
turned on and use the Text Style assigned to 
that layer. See “Text Styles” on page 1061.

Truss labels also display in the Truss Detail. 
See “Truss Details” on page 621.   

For more information about the settings on 
this panel, see “Label Panel” on page 1280.

Floor/Ceiling Truss Specification Dialog
To open the Floor or Ceiling Truss 
Specification dialog, select one or 

more floor or ceiling trusses and click the 
Open Object edit button. See “Floor and 
Ceiling Trusses” on page 616. 

Default values for trusses are set in the Build 
Framing dialog. See “Trusses Panel” on 
page 597. 

Note: If a truss is listed in a schedule using
callout labels, the settings here are overrid-
den and the schedule label is used instead. 
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General Panel

Specify the Member Depth of the 
different components of the selected 

truss.
• Specify the depth of the Top Chord.
• Specify the depth of the Bottom Chord.
• Specify the depth of the Webbing.

Specify the Thickness of the truss’s 
chords and webbing.

• Specify the Overall Thickness of the 
selected truss.

• Specify the Webbing Thickness thick-
ness of the webbing. 

Specify the Maximum Span, which is 
the maximum horizontal distance 

between supports along the Top and Bottom 
Chord. 

Options - 

• Check Vertical Supports to use vertical 
supports in the selected truss. 

• Check Force Truss Rebuild to rebuild 
the truss envelope based on the existing 
floor or ceiling platform when you click 
OK. Not available if Lock truss envelope 
is checked, below. 

• Check Lock Truss Envelope to lock the 
size and configuration of the truss. A 

1

2

3

Top Chord Vertical Support

Bottom Chord Webbing

4
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locked truss which has been relocated will 
maintain its original settings.

• Check No Special Snapping to prevent 
the selected truss from snapping along its 
long edge to a wall’s Main Layer or to the 
corner of a roof plane. If enabled, Object 
Snaps  may still occur. See “Object 
Snaps” on page 162.

Line Style Panel
The settings on this panel affect the 
appearance of the selected truss in floor plan 
view only. See “Line Style Panel” on page 
1085.

Fill Style Panel
The settings on this panel affect the 
appearance of the selected truss in floor plan 
view only. See “Fill Style Panel” on page 
1099. 

Materials Panel
The settings on the MATERIALS panel affect 
the appearance of the selected truss in 3D 
views. See “Materials Panel” on page 852.

Label Panel
Floor and ceiling truss labels can display in 
floor plan view and cross section/elevation 
views when the “Framing, Floor/Ceiling 
Truss Labels” layer is turned on and use the 
Text Style assigned to that layer. See “Text 
Styles” on page 1061.

Truss labels also display in the Truss Detail. 
See “Truss Details” on page 621.   

For more information about the settings on 
this panel, see “Label Panel” on page 1280.

Framing and Truss Schedules
The Framing Schedule tool allows 
you to produce customizable framing 

and truss schedules as well as object labels 
that display schedule numbers. See 
“Schedules and Object Labels” on page 
1267.

Framing schedules created in a Truss Detail 
use a special Only Include Objects from 
this Detail setting and a selection of Objects 
to Include that report only floor, ceiling, and 
roof trusses. See “Truss Details” on page 
621.

Note: If a truss is listed in a schedule using
callout labels, the settings here are overrid-
den and the schedule label is used instead. 
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Chapter 18:

Electrical

The electrical plan shows the location of all 
electrical objects such as lights, switches, 
outlets, smoke detectors and vent fans. Basic 
wiring diagrams show which objects share 
circuits and the locations of the controlling 
switches.

Electrical objects can be displayed in 2D and 
3D views. Some electrical light fixtures also 
add light sources to 3D and ray trace views. 
See “Lighting” on page 936.

Usually, the electrical plan is one of the last 
additions to a plan since the position of most 
electrical objects is determined by the 
location of walls, cabinets and other objects.

Chapter Contents
•      Electrical Defaults
•      The Electrical Tools
•      Auto Place Outlets
•      Creating Wiring Schematics
•      Electrical Library Content
•      Displaying Electrical Objects
•      Editing Electrical Objects
•      Electrical Service Specification Dialog
•      Electrical Schedules

Building requirements vary throughout
the country and around the world. It is

your responsibility to comply with local codes.
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Electrical Defaults 
Default Settings for electrical objects 
control which symbols are placed in 

the current plan when the Electrical Tools are 
used. It can be accessed by selecting Edit> 
Default Settings or by double-clicking the 

Electrical Tools , 110V , 220V , 

Light , or Switch  toolbar button. See 
“Default Settings” on page 74.

Default heights and other attributes of 
individual objects can be overridden in the 
Electrical Service Specification dialog. See 
“Electrical Service Specification Dialog” on 
page 645. 

Electrical Defaults Dialog

The Default Library Objects are the 
objects created using the Electrical 

Tools. Select an item in the scrollable list to 
see and edit its settings.
• The name of the object shown in the pre-

view image displays here.

• Select an item in the Default Library 
Objects list and click the Library button 
to select a new default object from the 
library. See “Select Library Object Dia-
log” on page 838.

• Click the Edit button to open the specifi-
cation dialog for the selected object. Any 
changes you make in the specification 

1
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dialog are saved with the plan as long as 
the selected object is not replaced. See 
“Electrical Service Specification Dialog” 
on page 645.

Default Heights - Specify the heights 
at which electrical outlets and switches 

are initially placed.
• Check Use Default Heights to apply the 

default heights specified here to electrical 
objects placed in floor plan view. When 
this is unchecked, electrical objects use 
the height saved with their symbol. See 
“Placing Library Objects” on page 836. 

• Outlet - Specify the default height for 
outlets, and phone, cable and tv jacks.

• Switch - Specify the default height for  
switches, doorbells and thermostats.

• Above Cabinet - Specify the default 
height for switches and outlets placed 
above most cabinets in floor plan view, as 

measured from the countertop. See 
“Adjusting Electrical Object Heights” on 
page 645.

A preview of the selected object 
displays here. See “Dialog Preview 

Panes” on page 41. 

Set as Default
The Set as Default edit tool can be 
used to modif ythe current plan’s 

Electrical Defaults. Select an electrical 
symbol and click the Set as Default edit 
button. See “Set as Default” on page 76.

The default electrical object that is updated 
depends on the type of electrical object 
selected as well as its placement. An Outlet, 
for example, might be 110V or 220V, interior 
or exterior; wall or floor mounted, and/or 
GFCI. 

The Electrical Tools
Select Build> Electrical to access the 
Electrical Tools. 

Click in floor plan view to place an electrical 
object. Some can only be placed against 
walls, some only on the ceiling or floor, and 
some automatically change as needed. If you 
click within 12" of the wall, the selected 
object is placed on the wall. 

Electrical objects are placed according to the 
settings in the Electrical Defaults dialog.

Once an electrical object has been placed, it 
can be edited in the Electrical Service 
Specification dialog. See “Electrical Service 
Specification Dialog” on page 645.

Outlets
Select Build> Electrical> 110V 
Outlet to place 110 volt duplex 

outlets in walls or on the floor. Select Build> 
Electrical> 220V Outlet to place 220 volt 
outlets. 

The type and height of an outlet will vary 
depending on  where it is placed. For 
example:
• In rooms defined as Bath or Master Bath, 

Ground Fault Circuit Interrupt (GFCI) 
outlets are placed. 

2
3
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• An outlet placed at the back of a base 
cabinet in floor plan view is positioned 
above the counter. 

• An outlet placed at the back of a base 
cabinet containing a kitchen sink is 
placed at the standard 11 1/2" (300 mm) 
above the floor. 

• Outlets placed outside the building or in 
an exterior area such as a deck or porch 
are labeled WP, or Water Proof.

To take advantage of the program’s 
capabilities, define room types properly 
before placing electrical objects. See “Room 
Types” on page 335.

Light Fixtures
Select Build> Electrical> Light to 
place light fixtures as specified in the 

Electrical Defaults dialog. All light fixtures 
placed in a plan can also serve as light 
sources in most 3D and ray trace views. To 
place a light fixture using the Light tool
• Click near a wall to place a wall-mounted 

fixture at that location. 
• Click away from a wall to place a ceiling 

mounted light. 
• Click outside of a room and away from a 

wall to place a path light.
• Some light symbols from the library can 

be mounted under wall cabinets, as well. 

The rendering characteristics of individual 
lights that control how they appear in Render 
and ray trace views can be specified on the 

LIGHT DATA panel of the Electrical Service 
Specification dialog. See “Light Data Panel” 
on page 647.

Switches
Select Build> Electrical> Switch to 
place electrical switches as specified 

in the Electrical Defaults dialog. Like 
outlets, the height of switches is measured 
from the floor to the center of the object.

An electrical switch can be placed on either a 
wall or a cabinet, depending on the type of 
switch. A selection of each type is available 
in the Library Browser. See “Placing Library 
Objects” on page 836.

Switches placed from the Electrical Library 
do not automatically update by default, but 
can be specified to do so. See “Electrical 
Service Specification Dialog” on page 645.

Auto Place Outlets
Select Build> Electrical> Auto Place 
Outlets and click in a room tool to 

place outlets at regular intervals around the 
entire room. See “Auto Place Outlets” on 
page 641.

Connect Electrical
Select Build> Electrical> Connect 
Electrical, then click and drag to draw 

splines that snap to electrical switches, 
outlets, and lights to illustrate wiring circuits. 
See “Creating Wiring Schematics” on page 
641.

If standard outlets are placed in a room
prior to defining it as a Bath, you should

replace them with GFCI outlets.

If you connect two or more switches in a
circuit, they update to 3-way or 4-way

switches automatically.
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Lighting and Electrical 
Library Catalogs

A selection of free-standing and 
ceiling-, wall- and cabinet-mounted 

light fixtures is available in the Library 

Browser at Chief Architect Core Catalogs> 
Architectural> Lighting. 

Special use outlets, switches, jacks and 
numerous other electrical items can be found 
at Chief Architect Core Catalogs> 
Mechanical, Electrical, Plumbing> 
Electrical. See “The Library” on page 819. 

Auto Place Outlets
Select Build> Electrical> Auto Place 
Outlets and click in a room to place 

110 volt outlets around the entire room, 
spaced so that no wall position is farther than 
six feet (1800mm) from the nearest outlet. 
110 or 220 volt outlets are also placed behind 
large appliances. In addition, a light is placed 
above each sink. 

Outlets and sink lights are placed based on 
settings in the Electrical Defaults dialog. 
See “Electrical Defaults” on page 638.

It is important that a room’s Type be defined 

before Auto Place Outlets  is used so 
that outlets are placed appropriately. For 
example, GFCI (Ground Fault Circuit 
Interrupter) outlets are placed over cabinets 
in Kitchen, Bath and Master Bath rooms.  
See “Room Types” on page 335.

Auto Place Outlets  does not work in 
rooms assigned an exterior room type such as 
Deck. To place outlets in an exterior room, 
place them from the Electrical Library or use 

the 110V Outlets  tool.

Railings and invisible walls are ignored by 

Auto Place Outlets . If it is used in a 
room defined by railings or invisible walls, 
outlets are automatically placed in any 
adjacent rooms on the other side of these 
wall types. See “Room Definition” on page 
331. 

Once placed, any outlet can be moved, 
edited, or deleted. See “Editing Electrical 
Objects” on page 644. 

Creating Wiring Schematics
Electrical schematics can be created in two 

ways. Using the Connect Electrical  tool 
is quick and easy, but if you need detailed 

schematics, you can create your own wiring 
diagrams using the CAD tools. See “CAD 
Objects” on page 1071. 

Note: Auto Place Outlets requires that a room
have a door before outlets can be placed.
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Connect Electrical

Select Build> Electrical> Connect 
Electrical, then click and drag to draw 

splines that snap to electrical switches, 
outlets, and lights to illustrate wiring circuits. 
See “Splines” on page 1106. 

To create a new circuit or add to an existing 
circuit, click on a switch, outlet, or light 

while the Connect Electrical  tool is 
active, drag to the next object and release. 
You can also draw electrical circuits using 

the Alternate  continuous drawing mode. 
See “Alternate” on page 179. 

When a Connect Electrical  spline is first 
drawn, it looks like an arc but actually 
consists of two segments that are defined by 
vertex points. When selected, its edit handles 
display at each of these vertices. If you click 
and drag one of these edit handles, the 
length, angle, and curvature of the spline will 
change but the other vertices will not move.

Connect Electrical  splines cannot be 
snapped to one another: they can only snap to 
electrical objects. Once drawn, though, 
additional vertices can be added and used to 
form complex curves. See “Editing Spline 
Based Objects” on page 209. 

To remove a connection from a circuit, 

simply select and Delete  it. If you 
remove an electrical object from a circuit, 
any Connect Electrical splines snapped to it 
will also be deleted. See “Deleting Objects” 
on page 255.

Three- and Four-Way Switches
Multiple switches can control an object or 
group of objects. 
• Two switches controlling the same 

objects are referred to as three-way 
switches. 

• Three switches controlling the same 
objects are called four-way switches. 

In floor plan view, a three- or four-way 
switches’s “way” number will automatically 
display in its 2D symbol.

Electrical Library Content
Select View> Library Browser to 
accesses a variety of electrical 

symbols. See “The Library” on page 819.

Browse for electrical objects such as bath 
vent fans, an electrical panel, fluorescent 
lights, chandeliers, a smoke detector, 

Vertex points

Spline segments

Vertex points

Spline segments
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thermostat, and more. Select a symbol, then 
click in your plan to place it on a wall, floor, 
or ceiling.

You can specify which electrical object in the 
library is used by each of the Electrical 
Tools. See “Electrical Defaults” on page 638. 

You can also assign electrical objects from 
the library to toolbar buttons for easy access 
and placement to frequently-used library 
objects. See “Place Library Object Button” 
on page 838.

Adding Electrical Content
Any electrical symbol placed into a plan can 
be customized and added to the User Catalog 
in the Library Browser. Customized settings 

and Components  data are retained. See 
“Add to Library” on page 829.

You can also create electrical symbols and 
save them in the User Catalog. See “Custom 
Symbols” on page 1195. 

Displaying Electrical Objects
The display of electrical objects and 
connections is controlled in the Layer 

Display Options dialog. See “Displaying 
Objects” on page 144.

When displayed in 3D views, light fixtures 
act as sources of light that help illuminate the 
3D model. See “Lighting” on page 936.

By default, electrical symbols are placed on 
the “Electrical” layer. You can, however: 
• Specify a different default layer for each 

type of object placed using the Electrical 
Tools by clicking the Edit button in the 
Electrical Defaults dialog. See “Electri-
cal Defaults” on page 638. 

• Specify a different layer for an individual 
object after it has been placed. See 
“Layer Panel” on page 154. 

Connect Electrical splines are drawn on the 
“Electrical, Connections” layer by default. 
While the default layer for these objects 
cannot be changed, you can specify a 
different layer for a Connect Electrical spline 
after it has been drawn. See “Line Style 
Panel” on page 1085.

Like most other symbols, electrical objects 
are represented in floor plan view by a CAD 
block. You can specify a symbol’s 2D CAD 
block in the Symbol Specification dialog. 
See “2D Block Panel” on page 1199.

Electrical Labels
Electrical labels display in floor plan and 
cross section/elevation views when the 
“Electrical, Labels” layer is turned on and 
use the Text Style assigned to their layer. See 
“Object Labels” on page 1279.

Customized labels using text and Text 
Macros as well as label position and 
orientation can be specified in the Electrical 
Service Specification dialog. See      Text 
Macros. 

Electrical objects can display callout labels 
as specified in the Electrical Schedule 
Specification dialog. See “Label Panel” on 
page 1280.

Electrical labels have their own edit handles 
and can be moved and rotated when the 
electrical object is selected. 
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In the Materials List
Electrical objects, including outlets, 
switches, lights, and symbols from the 
library such as jacks and fans, are listed 
under the Electrical Category in the 
Materials List. See “Materials Lists” on page 
1283. 

Editing Electrical Objects
Electrical objects can be selected as a group 
and individually in 2D and 3D and edited 
using the edit handles, the edit toolbar and 
their specification dialog. See “Electrical 
Service Specification Dialog” on page 645.

Light fixtures and Added Lights can be 
group-selected, but their light data cannot be 
edited unless each has the same number of 
light sources. See “Lighting” on page 936.

Lights can also be edited using the Adjust 
Lights dialog. See “Adjust Lights Dialog” on 
page 940.

Moving Electrical Objects 
Using Dimensions

Electrical objects can be moved precisely 
using manual dimensions. See “Moving 
Objects Using Dimensions” on page 1019. 
First, dimensions must be checked on the 
LOCATE OBJECTS panel of the Dimension 
Defaults dialog. See “Dimension 
Preferences and Defaults” on page 986. 

Using the Edit Handles
The edit handles for electrical objects vary 
depending on the location of the object. Wall 
mounted electrical objects cannot be rotated, 
so only the Move edit handle displays.

Electrical objects placed on floors and 
ceilings can be rotated.

Electrical connections edit like splines. See 
“Editing Spline Based Objects” on page 209.

Using the Edit Tools
A selected electrical symbol can be edited in 
a variety of ways using the buttons on the 

Note: Some electrical objects are repre-
sented in floor plan view by a CAD block that
includes text. This text is not part of the
object’s label and does not use the Text Style
assigned to the “Electrical, Labels” layer. 

Wall-mounted outlet in 2D and 3D views

Ceiling-mounted outlet in 2D and 3D views
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edit toolbar. See “The Edit Toolbar” on page 
37.

Adjusting Electrical Object 
Heights

When a wall-mounted electrical object is 
placed in floor plan view, its initial height is 
based on settings in the Electrical Defaults 
dialog. See “Electrical Defaults” on page 
638. 

An electrical object placed on a wall in a 3D 
view is positioned wherever you click on the 
wall, regardless of the height at that point. 

Once placed, a wall-mounted electrical 
object’s height can be edited in either of three 
ways: 
• Specify the height in the Electrical 

Service Specification dialog. See “Elec-

trical Service Specification Dialog” on 
page 645.

• In 3D views, the position of an electrical 
object can be adjusted using its edit han-
dles.

• In any view, use the Transform/Repli-
cate Object  tool. See “Transform/
Replicate Object Dialog” on page 242. 

Deleting Electrical Objects
An electrical object can be deleted by 

selecting it and clicking the Delete  edit 
button or by pressing the Delete key.

All electrical objects in a room, on a floor, or 
in the entire plan can also be deleted as a 
group using the Delete Objects dialog. See 
“Deleting Objects” on page 255.

Electrical Service Specification Dialog
Select one or more electrical objects 
and click the Open Object edit button 

to open the Electrical Service Specification 
dialog. The settings in this dialog vary, 
depending on the type of object(s) you select. 
This dialog can also be accessed by clicking 
the Edit button in the Electrical Defaults 
dialog. See “Electrical Defaults” on page 
638.

The Electrical Service Specification dialog 
has five panels: 

• The GENERAL PANEL specifies the loca-
tion of the selected electrical object(s). 

• The LIGHT DATA PANEL specifies how 
lights appear in rendered views. Not 
available for switches or outlets. See 
“Lighting” on page 936. 

• The LAYER PANEL specifies the layer the 
object is placed on.

• The MATERIALS PANEL allows you to 
change materials on electrical objects. 

• The LABEL PANEL lets you specify the 
selected object’s label. 

General Panel
The items on this panel vary, depending on 
the type of electrical object selected.
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The Name of the selected object as 
used in the Library Browser and 

Materials List displays here.

Specify the Position of the selected 
electical object. The options available 

depend on the type of object selected.
• Specify the Offset From Ceiling of a 

ceiling outlet or ceiling mounted light. If 
the light is mounted to a cabinet, this 
value is the offset from the cabinet.

• Specify the Height to Center of a 
switch, wall outlet or wall light. 

• Specify the Offset From Floor of a floor 
outlet or floor lamp. 

• Specify the Distance From Wall of a 
wall mounted symbol. A negative value 
will recess the symbol into the wall and 
may prevent it from being seen in 3D. 

Specify the Size of the selected 
electical symbol. 

• Specify the Height, Width and Depth of 
the selected symbol. 

• Click the Reset button to restore the elec-
trical symbol’s original size. 

Options - 

• Check Reverse Symbol to reverse the 
object’s appearance so that features on its 
left are located on its right and vice versa. 
Does not affect symmetrical symbols.

• Check Automatically Change Switch 
Type When Wiring for a selected switch 
to become a three- or four-way switch if 
your wiring plan uses it as such. This 
setting is not avaible when the dialog is 
accessed via the Electrical Defaults 

1

2

3

4
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dialog. See “Connect Electrical” on page 
642. 

Switches placed from the toolbar use this 
option by default; switches placed from 
the library do not. 

• Check Include in Schedule to include 
the selected light fixture in electrical 

schedules. See “Schedules and Object 
Labels” on page 1267.

Any Copyright information associated 
with the selected symbol will be stated 

here.

A preview of the selected object 
displays here. See “Dialog Preview 

Panes” on page 41. 

Light Data Panel
The LIGHT DATA panel is available when the 
selected electrical object is a light fixture. 
The available options vary depending on the 
type of light selected. If multiple light 
fixtures with different numbers of light 

sources are selected, the settings on this 
panel are not available.

The settings on this panel are similar to those 
on the same panel of the Light Specification 
dialog. See “Light Specification Dialog” on 
page 942.

5

6
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Each fixture can have multiple Light 
Sources, listed here. Not available for 

Added Lights. See “Lighting” on page 936.
• Select a Light Source assigned to the 

selected light fixture from the drop-down 
list. The selected light source can be 
edited using the settings on this panel.

• Click Add Light or Delete Light to add 
or delete light sources from the list. If the 
selected fixture has only one light source, 
Delete Light will not be available.

Specify the Light Characteristics of 
the currently selected Light Source. 

• Select a light Source Type from the drop-
down list. The type selected determines 
what options are enabled on this panel. 
See “Light Types” on page 940. 

• Select an Intensity from the drop-down 
list. The available options are described 
using lumens and correspond to com-
monly used light bulb wattages. 

• Select “Custom” from the Intensity list 
to open the Custom Light Intensity 
dialog and create a custom Intensity 
setting. See “Custom Light Intensity 
Dialog” on page 650.

1

2
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• Click the Color bar to define the color of 
the selected light source. Colored lights 
alter the appearance of textures and can 
be used to achieve special effects. See 
“Color Chooser/Select Color Dialog” on 
page 875. 

The Angle and Drop Off Rate settings below 
are not available when the Source Type is 
Point Light. 
• The Tilt Angle controls the angle of the 

illumination with respect to the horizon. 
A value of -90° points the light straight 
down and a value of 90° points it straight 
up. 0° is parallel to the horizon.

• The Direction Angle defines the 
direction of the illumination relative to 
the ground. 0° is measured horizontally 
pointing to the right. Positive values 
rotate in a counter-clockwise direction 
from there. Enter a value up to 360°. If 
you enter a negative value, the program 
adds 360° to it when you click OK or 
press the Tab key.

• The Cut Off Angle controls the angle of 
the cone of illumination for Spot Lights 
only. A cone angle of 180° creates a spot 
light that shines in a half sphere on one 
side of the light source. A small cone 
angle, for example 10°, creates a very 
narrow cone of light. The cut off angle 
should always be between 0° and 180°. 

• The Drop Off Rate affects how fast a 
Spot Light’s intensity drops off from the 
center of the cone to the outside edge. 
Only available for Spot Lights.

A value of 0 produces a cone of light with 
the same intensity from the center to the 
outside edge. The default drop off value 
is 7.5, causes the light intensity to drop 
off fairly quickly. 

Limitations in the OpenGL lighting 
model can create a jagged circle of light 
on a large flat surface if the Drop Off 
Rate value is too low. You can address 
this by decreasing the Maximum Triangle 
Size and increasing the Drop off Rate.

Check Soft Shadows (Ray Tracing) to 
have the selected Point Light source 

cast soft shadows in Ray Trace views. Not 
active for Spot and Parallel Light sources. 
• Specify the Light Diameter, which is 

how big the source of illumination 
appears in Ray Trace views.  

The Offset settings control the location 
of the selected Light Source relative to 

the fixture. 
• From Base controls how far the light 

source is from the fixture base. The 
fixture base is determined by the surface 
that it is attached to (i.e. wall, floor, or 
ceiling). 

• X Position and Y Position allow you to 
position the light source relative to the 
center of the fixture, along the floor/
ceiling.

Additional Options that affect how the 
selected light source behaves are 

available.
• Select Use in Camera View to turn the 

selected light source on in regular 3D 
views only. 

The default color of light is pure white,
which has the least affect on the

appearance of material colors and textures.

3

4

5
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• Select Use in Ray Tracing to turn the 
selected light source on in ray trace views 
only. 

• Select Use in Both to turn the selected 
light source on in both camera and ray 
trace views. 

• When multiple lights are selected and 
they are set to be used in different types 
of views, No Change will be available. 
Leave this option selected unless you 
want the lights to all be used in the same 
types of views. 

• Check On to use the light source in 
camera or ray trace views, or uncheck it 
if you prefer that the light source not be 
used. See “Lighting” on page 936. 

• Casts Shadows controls whether or not 
the light source casts shadows in camera 
and ray trace views. See “Shadows” on 
page 934. 

Shadow calculations can slow rendering 
speed significantly; however, when ray 
tracing, it is recommended that this box 
be checked. 

• Check Show Position in Camera View 
to indicate the position of a selected Point 
or Spot Light source in the preview pane 
and in 3D views that support lighting 
when it is turned On. This tool can be 
used to determine if your light source is 
positioned correctly. Not available for 
Parallel lights. See “Displaying Lights” 
on page 938.

A preview of the selected object 
displays here. The selected light 

source’s Position in Camera View will 
display in the Standard Rendering Technique 
if the light source is On. See “Dialog 
Preview Panes” on page 41. 

Custom Light Intensity Dialog
Select “Custom” from the Intensity drop-
down list on the LIGHT DATA panel to open 
the Custom Light Intensity dialog. 

• Intensity - Use the slider bar or text field 
to control how bright the light appears in 
camera and ray trace views.

• Check Auto Adjust Intensity to have the 
program to scale the Intensity depending 
on the number of lights in the room. 
When unchecked, the Intensity set here is 
used. 

• Check Attenuated to control how 
quickly a light source’s intensity drops as 
its distance from the light source grows. 
When unchecked, the light does not drop 
off. Only Spot and Point Lights have 
attenuation.

The three Attenuated values represent the 
three coefficients (a, b, and c) in the 
expression 1 / (a + b*d+c*d*d), where d is 
the distance from the light source. Increasing 
any of these values results in the light 

Note: Many more lights can be included in ray
trace views than in rendered views. Some fix-
tures may have four or five lights for use in
ray trace views but only one in rendered
views. See “3D Rendering” on page 933. 

6
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intensity dropping faster (the light does not 
travel as far). Decreasing any value results in 
the light intensity dropping slower (the light 
travels farther). Small changes in these 
coefficients can have significant impact on 
lighting effects. You may need to experiment 
to fully understand how to use them.

Layer Panel
The LAYER panel is found in the 
specification dialogs for a variety of objects, 
including electrical objects. For more 
information, see “Layer Panel” on page 154.

Materials Panel
The MATERIALS panel is found in the 
specification dialogs for a variety of objects. 

For more information, see “Materials Panel” 
on page 852.

Label Panel
Labels for electrical fixtures display in floor 
plan view and cross section/elevation views 
when the “Electrical, Labels” layer is turned 
on and use the Text Style assigned to that 
layer. See “Electrical Labels” on page 643. 

For information about the settings on this 
panel, see “Label Panel” on page 1280.

Electrical Schedules
The Electrical Schedule tool allows 
you to produce customizable electrical 

schedules as well as electrical labels that 

display schedule numbers. See “The 
Schedule Tools” on page 1268.

Note: If you choose a label shape in the Elec-
trical Schedule Specification dialog, the set-
tings here are overridden and the schedule
label is used instead. See “Label Panel” on
page 1277.
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Chapter 19:

Trim and Molding

Chief Architect offers a wide selection of 
trim and molding options. Corner boards, 
quoins, and frieze moldings can be added to 
a building’s exterior. Molding polylines and 
3D molding polylines can be edited as 2D 
CAD objects using the CAD editing tools, 
then extruded to display in 3D for a variety 
of powerful applications.

In addition, Chief Architect offers a wide 
selection of trim and molding options for 
doors, windows, rooms, and many interior 
objects. See “The Library” on page 819.

You can also assign moldings to a variety of 
objects, such as rooms and cabinets, in those 
objects’ specification dialogs. See 
“Specification Dialogs” on page 41.

Chapter Contents
•      Trim and Molding Defaults
•      Corner Boards
•      Corner Board Specification Dialog
•      Quoins
•      Quoin Specification Dialog
•      Editing Corner Boards and Quoins
•      Millwork
•      Moldings Panel
•      Molding Profiles
•      Symbol Moldings
•      Molding Polylines
•      Displaying Molding Polylines
•      Editing Molding Polylines
•      Molding Polyline Specification Dialog
•      3D Molding Polyline Specification Dialog
•      Frieze Moldings
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Trim and Molding Defaults
Select Edit> Default Settings to open 
the Default Settings dialog where 

you can access the defaults for a variety of 
drawing tools, including a number that affect 
trim and moldings. 
• Click the + beside “Corner Trim” to 

access the defaults for Corner Boards and 
Quoins. See “Corner Boards” on page 
654 and “Quoins” on page 656. 

• Select “Floor” and click the Edit button 
to specify the default moldings for rooms 
on the current floor. See “Floor Defaults” 
on page 330. 

• Click the + beside “Door” to access the 
defaults for Interior and Exterior Doors. 
See “Door Defaults” on page 361. 

• Select “Window” and click the Edit but-
ton to specify the default casing for win-
dows. See “Window Defaults” on page 
392.

• Click the + beside “Cabinet” to access the 
defaults for the Cabinet Tools, where you 
can specify default crown and other 
moldings. See “Cabinet Defaults” on 
page 676.

Corner Boards
Corner boards are added to a building 
exterior in any view by selecting 

Build> Trim> Corner Boards.

Click at a wall corner where you want to add 
trim. Be sure to click where the outside wall 
surfaces meet. If you click where the inside 
surfaces meet, corner trim will be created 
inside the room.

You can also add Corner Boards to all 
exterior corners at once by selecting Build> 

Trim> Auto Place Corner Boards .

By default, Auto Place Corner Boards  
adds Corner Boards to outside corners only. 
If you prefer, you can specify that inside 
corners receive corner boards in the Corner 
Board Defaults dialog. See “General Panel” 
on page 655.

Corner boards extend from the top plate 
down to the bottom of the floor platform of 
the floor on which it is placed, but do not 
extend to other floors. You must add corner 
boards to all floors of the building that you 
want to have corner boards. 

A selected corner board or boards can be 
moved, but only to another wall corner or 
corners.  In 3D views, corner boards can be 

Note: The Auto Place Corner Boards tool
does not place corner boards on manually
drawn dormers or at intersections with Attic
Walls. See “Attic Walls” on page 297.
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lengthened or shortened using the edit 
handles. Corner boards can be copied, 
deleted and resized similar to other objects 
using the edit toolbar or  the Corner Board 
Specification dialog. 

The default material for corner boards is 
defined by the Exterior Trim entry in the 
Material Defaults dialog. See “Material 
Defaults” on page 848.

Corner Board Specification Dialog
Select one or more corner boards and 
click the Open Object edit button to 

open the Corner Board Specification 
dialog.

The settings in this dialog are similar to those 
in the Corner Board Defaults dialog, but 
affect the selected corner boards rather than 
all subsequently created corner boards. 

General Panel

Specify the Width and Thickness of the 
selected corner board(s).

Check Set Top/Set Bottom to specify the top 
and bottom heights of the corner board(s). 
• If Set Top is unchecked, the top of the 

corner board automatically extends to the 
top plate.

• If Set Bottom is unchecked, the bottom 
of the corner board automatically extends 
to the bottom of the floor platform.

In the Corner Board Defaults dialog, an 
additional Auto Place Option is available.

• Check Include Inside Corners to place 
Corner Boards on inside corners when 

the Auto Place Corner Boards  tool 
is used. When unchecked, only outside 
corners receive corner boards. 

Inside Corner

Outside Corners
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Layer Panel
For information about the LAYER panel, see 
“Layer Panel” on page 154.

Materials Panel
The settings on the MATERIALS panel are 
available for a wide variety of objects in the 
program. For information about these 
settings, see “Materials Panel” on page 852.

Quoins
Select Build> Trim> Quoins in any 
view and click at a wall corner where 

you want to place quoins. 

You can also add Quoins to all exterior 
corners at once by selecting Build> Trim> 

Auto Place Quoins .

By default, Auto Place Quoins  adds 
Quoins to outside corners only. If you prefer, 
you can specify that inside corners receive 
quoins in the Quoin Defaults dialog. See 
“General Panel” on page 655.

A selected quoin or quoins can be moved, 
but only to another wall corner or corners. In 
3D views, quoins can be lengthened or 
shortened using the edit handles. Quoins can 
be copied, deleted and resized similar to 
other objects using the edit toolbar or  the 
Quoin Specification dialog. 

The size of quoins in floor plan view is 
relative on their size in 3D.

Initially, quoins use the same material as the 
default material of the wall surface they are 
placed against. This material is specified in 
the Wall Type Definitions dialog. See “Wall 
Specification Dialog” on page 308.

Quoin Specification Dialog
Select one or more quoins and click 
the Open Object edit button to open 

the Quoin Specification dialog.

The settings in this dialog are the same as 
those in the Quoin Defaults dialog, but 
affect the selected quoins rather than all 
subsequently created quoins.

Note: The Auto Place Quoins tool does not
place quoins on manually drawn dormers or
at intersections with Attic Walls. See “Attic
Walls” on page 297.
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General Panel

Specify the Size and Position of the 
quoins in the selected Quoin object. 

• Specify the Width, which is the horizon-
tal dimension of each quoin in the 
selected Quoin object. The dimension 
along the other wall is half this value 
when they are staggered or mirrored.

• Specify the Thickness, which is the 
amount that the quoin protrudes from the 
exterior surface of the wall.

• Specify the Quoin Height for individual 
quoins in the selected Quoin object.

• Specify the Quoin Gap, which is the dis-
tance between successive quoins.

Check Set Top/Set Bottom to specify the top 
and bottom heights of the quoin(s) in the text 
fields. 

• If Set Top is unchecked, the top of the 
corner board automatically extends to the 
top plate.

• If Set Bottom is unchecked, the bottom 
of the quoin automatically extends to the 
bottom of the floor platform.

Specify the arrangement of quoins used 
by the selected Quoin object. 

• Uniform - Produce quoins that are of 
equal length on both sides of the corner.

• Staggered - Produce quoins that have 
one long side and one short side stag-
gered on opposite sides of the corner.

• Mirrored - Produce quoins that alternate 
having either two long sides or two short 
sides.

• When Staggered or Mirrored is selected, 
check Swap Start Block to switch the 
starting order for the quoins. 

1

2
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In the Quoin Defaults dialog, an additional 
Auto Place Option is available.
• Check Include Inside Corners to place 

Quoins on inside corners when the Auto 

Place Quoins  tool is used. When 
unchecked, only outside corners receive 
quoins.

Layer Panel
For information about the LAYER panel, see 
“Layer Panel” on page 154.

Materials Panel
The settings on the MATERIALS panel are 
available for a wide variety of objects in the 
program. For information about these 
settings, see “Materials Panel” on page 852.

Editing Corner Boards and Quoins
Before a corner board or quoin can be edited, 
it must be selected. Click on a trim object 

when the Select Objects  tool is active. 
Corner boards and quoins can also be group 
selected and edited. See “Selecting Objects” 
on page 183

Corner boards and quoins can be edited using 
their edit handles, the edit toolbar buttons, 
and their specification dialogs. 

Using the Mouse
Depending on the type of view, a corner 
board or quoin displays a different set of edit 
handles when selected. 
• In floor plan view, corner boards and 

quoins display one edit handle and can be 
moved from one eligible location at a 
wall corner to another.

Staggered
Uniform

Mirrored

Inside Corner

Outside Corners
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• In 3D views, corner boards and quoins 
can be moved, lengthened, and shorted 
much the other line-based objects are. 
See “Editing Line Based Objects” on 
page 187. 

Using the Edit Buttons
A selected corner board or quoin can be 
edited in a variety of ways using the buttons 

on the edit toolbar. See “The Edit Toolbar” 
on page 37.

Deleting Corner Trim
Corner boards and quoins can be selected 
individually or in groups and deleted using 

the Delete  edit button or the Delete key 
on the keyboard. They can also be removed 
using the Delete Objects dialog. See 
“Deleting Objects” on page 255. 

Millwork
A selection of various types of millwork 
including columns, corbels and finials is 
available in the Library Browser. See “The 
Library Browser” on page 820. 

Most millwork items can be placed in a plan 
as free-standing objects.  Some items - 
notably, newels and balusters - can be 

assigned to objects such as railings, stairs 
and ramps. Other examples of millwork that 
can be assigned to objects include lintels on 
doors and windows and pilasters and feet on 
cabinets. See “Placing Library Objects” on 
page 836. 

Moldings Panel
The specification dialogs for a variety of 
objects in the program include a MOLDINGS 
panel. Objects that can have moldings 
assigned to them include rooms, cabinets, 
custom countertops, and molding polylines. 

There are also a number of roof attributes 
that are assigned the way moldings are. 
Rafter tails, ridge caps, gutters, frieze 
molding, and shadow boards are all created 
by specifying a specially shaped profile and 
extruding it down a predetermined path. As a 

result, the settings on the RAFTER TAILS, 
RIDGE CAPS, GUTTER, FRIEZE, and SHADOW 
BOARDS panels function the same as those on 
the MOLDINGS panel. See “Build Roof 
Dialog” on page 480.

Select an object or group of similar objects 

and click the Open Object  edit button to 
open the specification dialog for that 
selection. 
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Only available for rooms, uncheck Use 
Floor Default to make the settings that 

follow active. Check this box to use the 
defaults set in the Floor Defaults dialog for 
the current floor. See “Floor Defaults” on 
page 330.

Check No Ridge Caps on Selected Edge to 
prevent a ridge cap from being created on the 
selected edge of a roof plane. Only available 
on the RIDGE CAPS panel of the Roof Plane 
Specification dialog. See “Selected Edge” 
on page 184.

Check No Shadow Boards on Selected 
Edge to prevent shadow boards from being 
created on the selected edge of a roof plane. 
Only available on the SHADOW BOARDS 

panel of the Roof Plane Specification 
dialog. See “Roof Plane Specification 
Dialog” on page 498.

Molding Profile - Specify the molding 
profile(s) and/or symbol molding(s) 

assigned to the selected object. The Default 
Base Molding is a basic rectangular stock 
profile rather than a profile from the library.
• A drop-down list of the Molding pro-

file(s) or symbol(s) assigned to the 
selected object displays here. Select the 
name of a molding to edit it or remove it 
from the list. 

• If multiple objects with different mold-
ings assigned to them are selected, a No 
Change checkbox will be available just 

1

2
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above the Molding drop-down list.

Uncheck this box to make the settings 
that follow active but note that only 
moldings that all selected objects have in 
common will be retained. 

• Click the Add New button to open the 
Select Library Object dialog and add a 
new molding profile or symbol to the list. 
See “Select Library Object Dialog” on 
page 838. 

• Click the Replace button to remove the 
selected profile or symbol and replace it 
with a new one from the Select Library 
Object dialog. Only available when a 
profile is already selected.

• Click the Delete button to remove the 
currently selected profile or symbol from 
the list. 

• Choose the currently selected molding’s 
Type from the drop-down list. For frieze 
molding and shadow boards, the choices 
are Eave and Gable, Eave only, and 
Gable only. For rooms, they are Base 
Molding, Chair Rail, and Crown 
Molding. If no Type is selected, the 
molding will not be listed in the Room 
Finish Schedule. See “Schedules and 
Object Labels” on page 1267.

Specify Selected Profile Size. These 
setttings only affect the molding profile 

or symbol selected above. 
• Specify the Height of the selected mold-

ing profile. 
• Specify the selected profile’s Width. 

This option is not available for molding 

polylines created from default room 
moldings.

• Specify the Repeat Distance of a 
selected symbol molding. This option is 
only available when a symbol molding is 
selected. See “Symbol Moldings” on 
page 663,

• When Retain Aspect Ratio is checked, if 
you change either the Height or Width, 
the other value changes to maintain their 
original ratio. When this is unchecked, 
the two values can be edited indepen-
dently. This option also affects the Repeat 
Distance of a symbol molding.

Define the Selected Profile Offset, 
which is the offset of the selected 

molding relative to the object it is assigned 
to. 
• Specify the offset From Floor of the 

selected molding profile; for objects 
other than rooms, specify the Vertical 
offset. A positive offset moves the mold-
ing upward and a negative offset moves 
the molding downward.

• Select To Top to specify that the top of 
the molding is offset vertically from the 
top of the object it is applied to. 

• Select To Bottom to specify that the bot-
tom of the molding is offset vertically 
from the bottom of the object it is applied 
to. 

• Specify the Horizontal offset, which is 
how close the molding is to the perimeter 
of the selected object. Increase this value 
to create a gap between the selected 
object and the molding. See “Built-Up 
and Recessed Moldings” on page 663. 

3

4
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Molding Profiles
A molding profile is a polyline that 
represents a 2D cross section of a particular 
style of molding. A molding profile does not 
display in 3D on its own; it must be applied 
to an object like a room, a cabinet, or a 
molding polyline. See “Moldings Panel” on 
page 659 and “Molding Polylines” on page 
664.

The library contains a selection of moldings, 
as well as curbs, gutters, handrails and rafter 
tails. You can customize library molding 
profiles and also create your own custom 
profiles and add them to the library. See 
“Adding Library Content” on page 829.

Creating a Molding Profile
You can easily create custom molding 
profiles using the CAD Line and Arc Tools 
by following a few basic guidelines. The 
object is to draw a polyline, closed or not. 
• Moldings can be drawn in either floor 

plan view or in a CAD Detail window. 
• Draw the profile at its actual, unscaled 

size. 
• The profile must be drawn with the 

proper orientation. The back of most pro-
files, or the side facing the wall, must be 
drawn as a vertical edge on the left side 
of the polyline.

• Similarly, curbs and gutters are drawn 
with the back of the profile as a vertical 
edge on the left side of the polyline. 

• Open polylines should be used for gutter 
and rafter tail profiles. Gutter profiles 

attach to the roof on the left side, and 
rafter tail profiles should be open on the 
left side. 

• Ridge cap profiles must be closed poly-
lines drawn to match the pitch of the roof 
planes they will cap. 

• Rail, handrail, and railing beam profiles 
should be drawn with the bottom edge 
facing downward.

When the molding profile suits your needs, 

select it and click the Add to Library  
edit button.  

Place Molding Profile
An existing molding profile can be placed in 
floor plan view or a CAD Detail, edited, and 
added to the library as a new profile.

Right-click on a molding profile in the 
library and select Place Molding Profile 
from the contextual menu. Move your 
pointer into the drawing area and click once 
to place a closed polyline identical to the 
selected profile at that location. The polyline 
can then be edited to suit your needs.

Closed polyline with 
back on the left side

Base molding and gutter profiles

Open polyline with 
back on the left side
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Built-Up and Recessed 
Moldings

Built up or stacked moldings can be created 
in a couple of ways. One way is to draw the 
entire build-up in a single molding profile.

Another way is to apply multiple molding 
profiles to an object and specify the vertical 
and horizontal offsets of each. See 
“Moldings Panel” on page 659. 

To build up two molding profiles

1. On the MOLDINGS panel of the specifi-
cation dialog of any object that molding 

can be applied to, click the Add New 
button 

2. Add a molding profile to the object and 
specify its Height, Width, and Vertical 
and Horizontal Offset values. Make a 
note of these values.

3. Click the Add New button and add a 
second molding profile to the object.

4. Specify the second molding profile’s 
Height, Width and Offset values.

•  To define the Vertical Offset, add the 
first profile’s Height and Vertical Off-
set values.

•  To define the Horizontal Offset, add 
the first profile’s Width and Horizontal 
Offset values.

Similarly, molding can be recessed by 
specifying a negative Horizontal Offset - for 
example, to create an under cabinet light rail. 
See “Editing Cabinet Styles” on page 690. 

Symbol Moldings
Symbol Moldings are 3D symbols that are 
repeated along a path to form molding. 
Molding symbols are different from molding 
profiles because they are replicated 3D 
sumbols instead of extruded 2D shapes.

Creating a Symbol Molding
Begin by opening a new, blank plan and 
creating a single instance of the molding 

symbol using the Primitive Tools . See 
“Primitive Tools” on page 778. For example, 
to create the molding shown in the 
illustration above, make an object that looks 
like this: 

Note: Place Molding Profile cannot be used
to apply a molding profile to an object - it is
only used to place a profile polyline.
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When you are satisfied with its appearance, 
convert it to a 3D symbol. See “Convert to 
Symbol” on page 1206.

You can also import a 3D symbol from 
another application. See “Importing 3D 
Symbols” on page 1184.

To import a molding symbol

1. Select File> Import> 3D Symbol  
from the menu. See “Import 3D Symbol 
Dialog” on page 1185. 

2. In the Import 3D Symbol dialog, specify 
the symbol as Molding and click the 
Advanced button.

•  If you plan to use the molding symbol 
more than once, check the box beside 
Add to Library. See “Add to Library” 
on page 829.

3. On the 3D panel of the Symbol 
Specification dialog, rotate the symbol 
as needed so that it faces you in the pre-
view image.

Once created, a symbol molding can be 
assigned to an object or replicated along a 
molding polyline. See “Molding Polylines” 
on page 664. 

Symbol moldings are center aligned. Both 
ends have a 45° miter, so the end instances 
may appear chopped. You can specify the 
Repeat Distance of a symbol molding 
applied to an object to control the width of 
each instance of the symbol on the object. 
See “Moldings Panel” on page 659.

Molding Polylines
A molding polyline is a 3D path that either a 
2D molding profile is extruded along or a 
series of molding symbols is repeated along. 
Molding polylines can be used to create 
custom room moldings and decorations 
anywhere in your 3D model.

The Molding Polyline tools are 
accessed by selecting Build> Trim 

from the menu. 

There are four types of molding polylines:

• Molding Polylines  

• Molding Lines  

• 3D Molding Polylines  

• 3D Molding Lines  

To create a  molding polyline, first select the 
desired Molding Polyline tool. The Select 
Library Object dialog will open. Select a 

 Symbol moldings work best if you make
them symmetrical.



Molding Polylines

 665

molding profile or symbol from the library, 
then click and drag to draw the path for the 
selected molding profile or symbol. 

If a molding profile or symbol has been 
previously selected during the current 
session in the program, you can begin 
drawing using this molding without selecting 
anything from the library. 

Molding polylines can also be created using 

the Make Room Molding Polyline  and 

the Convert Polyline  edit tools. 

Molding Polyline Tool
Select Build> Trim> Molding 
Polyline in floor plan view, a camera 

view or overview to create a molding 
polyline with a closed shape and a single 
height off the floor along its entire perimeter. 
Molding Polylines are drawn like rectangular 
polylines. 

In floor plan view, Molding Polylines can 
also be created by selecting a profile from the 
Library Browser. Single-click to place a 
2’x2’ closed polyline or click and drag to 
draw a rectangular polyline. 

Molding Line Tool
Select Build> Trim> Molding Line 
in floor plan view, a camera view or 

overview to create a molding line with a 
single height off the floor along its entire 
length. Multiple Molding Lines can be 
connected to form open or closed polylines 
as long as they share the same height.  

3D Molding Polyline Tool
Select Build> Trim> 3D Molding 
Polyline in floor plan or cross section/

elevation view to create a closed molding 
polyline. 
• When drawn in a cross section/elevation 

view, a 3D Molding Polyline’s top and 
bottom edges have two different heights. 
Its sides have different heights at their 
start and end points.

• If drawn in floor plan view, a camera 
view or overview, a 3D Molding Polyline 
has a single height along its perimeter. 

In either case, its edges can be edited so that 
it travels in three dimensions rather than two. 

3D Molding Line Tool
Select Build> Trim> 3D Molding 
Line in floor plan or cross section/ele-

vation view to create a molding line. 
• If drawn in a cross section/elevation 

view, a 3D Molding Line’s start and end 
points can have two different heights. 

• If drawn in floor plan view, a camera 
view or overview, a 3D Molding Line has 
a single height along its length. 

3D Molding Lines can be connected to form 
polylines as long as the ends at which two 
segments connect have identical heights. 

Molding polyline and molding line in 
Floor Plan View and 3D overview
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Once drawn, a 3D Molding Line can be 
edited so that it travels in three dimensions. 

Moldings Library
In the floor plan view, select a molding 
profile from the library. The Molding 

Polyline  tool becomes active, allowing 
you to draw a molding polyline with using 
the selected profile.

Converting a Room Molding
Select a room and click on the Make 
Room Molding Polyline edit button. 

This opens the Make Room Molding 
Polyline dialog, allowing you to select which 
type of room molding to convert to a 
molding polyline. See “Room Polylines” on 
page 349.

Converting a CAD Polyline
Select a CAD polyline and click the 
Convert Polyline edit button to covert 

it into a molding polyline or a 3D molding 
polyline. See “Convert Polyline” on page 
239.

Displaying Molding Polylines
As with other objects, the display of 
molding polylines in 2D and 3D views 

is controlled in the Layer Display Options 
dialog. See “Displaying Objects” on page 
144. 

There are a number of different types of 
molding polyline objects.  By default:
• Molding polylines are placed on the 

“Moldings” layer.
• Roof ridge caps, gutters, frieze molding, 

and shadow boards are placed on the 
“Roofs, Ridge Caps”, “Roofs, Gutters”, 
and “Roofs, Trim” layers, respectively.

In floor plan view, manually drawn molding 
polylines display as two sets of lines: one 

representing the molding’s front and one its 
back. The distance between them is 
determined by the Width of the molding 
profile.  If a Horizontal offset is specified, 
that value is added to the distance between 
the two lines. See “Moldings Panel” on page 
659. 

Profiles on the Selected Edge
By default, the molding(s) assigned to a 
molding polyline display along all of its 
edges in 3D views. If you wish, you can 
suppress the display of moldings on the 
Selected Edge by clicking the Remove 
Molding from Selected Edge   edit 
button or checking No Molding on Selected 

3D Molding polyline and 3D molding line 
as they appear in three different views.

Floor Plan View

Cross Section/
Elevation View 
(selected)

3D Overview
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Edge in the molding polyline’s specification 
dialog. See “Selected Edge” on page 184. 

Suppressed moldings can be restored to the 
selected edge by clicking the Add Molding 
to Selected Edge  edit button or by 
unchecking No Molding on Selected Edge 

These edit buttons are also available for a 
selected Gutter, Ridge Cap, or Shadow Board 
polyline and for Custom Countertops. See 
“Roof Returns and Other Details” on page 
527 and “Custom Countertops” on page 683. 

Editing Molding Polylines
Molding polylines can be edited much the 
way CAD polylines are. See “Editing Open 
Polyline Based Objects” on page 196 and 
“Editing Closed-Polyline Based Objects” on 
page 201. 

Molding lines and polylines also can be 
edited in their specification dialogs. See 
“Molding Polyline Specification Dialog” on 
page 668 and  “3D Molding Polyline 
Specification Dialog” on page 669.

Changing Profiles on Existing 
Moldings

In 3D views, select a molding profile or 
symbol from the Library Browser and move 
your mouse pointer into the view window. 

The pointer displays the Moldings  icon. 
Click on a molding polyline, 3D molding 
polyline, room molding, cabinet molding, 

door molding, or window molding in the 
view to change its molding profile. This is 
the same as changing the molding profile in 
the object’s specification dialog. See 
“Moldings Panel” on page 659.

Deleting Molding Polylines
Molding polylines can be deleted like other 

objects using the Delete  edit button or 
the Delete key on your keyboard.

Molding Polylines are also deleted when the 
Delete Objects dialog is used to delete CAD 
objects. See “Deleting Objects” on page 255. 

Note: 3D Molding Polyline edges that slope
rather than having a single height are best
edited in a camera or elevation view. See “3D
Views” on page 887. Click on a molding in 3D view to change it
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Molding Polyline Specification Dialog
To open the Molding Polyline 
Specification dialog, select a molding 

polyline or group of molding polylines and 
click the Open Object edit button. 

General Panel

• Specify the Molding Polyline’s Height, 
relative to 0.

• Check No Molding on Selected Edge to 
create blank section in the molding poly-
line along the selected line segment.

Polyline Panel
The POLYLINE panel states the Length of an 
open molding polyline, and the Perimeter 
and Area of a closed molding polyline. See 
“Polyline Panel” on page 1098.

Selected Line Panel
The SELECTED LINE panel is available when 
the selected segment of the molding polyline 
is a line, as opposed to an arc. For more 

information, see “Line Style Panel” on page 
1085.

Selected Arc Panel
The SELECTED ARC panel displays when the 
selected segment of the molding polyline is 
an arc, as opposed to a line. See “Arc Panel” 
on page 1093.

Moldings Panel
The MOLDINGS panel can be found in dialogs 
throughout the program. See “Moldings 
Panel” on page 659. 

One setting on this panel is unique to the 
Molding Polyline and 3D Molding Polyline 
Specification dialogs: 
• Check Inside to extrude the molding pro-

file on the inside of closed polyline or 
right side of an open polyline. 

• When unchecked, the molding profile 
extrudes on the outside or left side of the 
polyline.

Molding extruded inside
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Line Style Panel
The LINE STYLE panel can be found in 
dialogs throughout the program. For 
information about the settings on this panel, 
see “Line Style Panel” on page 1085.

Fill Style Panel
The settings on the FILL STYLE panel affect 
the appearance of the selected Molding 

Polyline in floor plan view. For more 
information, see “Fill Style Panel” on page 
1099.

Materials Panel
The MATERIALS panel can be found in 
dialogs throughout the program. For 
information about the settings on this panel, 
see “Materials Panel” on page 852.

Label Panel
Molding Polyline labels display when the 
“Polylines 3D, Labels” layer is turned on and 
use the Text Style assigned to that layer. See 
“Text Styles” on page 1061. 

For more information about the settings on 
this panel, see “Label Panel” on page 1280. 

3D Molding Polyline Specification Dialog
Select a 3D molding polyline and click 
the Open Object edit button to open 

the 3D Molding Polyline Specification 
dialog.

General Panel

• Uncheck Molding on Selected Edge to 
turn off the display of the specified mold-

ing on the selected edge of the polyline. 
See “Selecting Objects” on page 183.

Molding extruded outside (Inside unchecked)
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• If the selected object is an automatically 
generated ridge cap, frieze molding, or 
shadow boards polyline, this checkbox’s 
label will reflect the object type. See 
“Roof Returns and Other Details” on 
page 527. 

An Automatically Generated checkbox will 
be present if a ridge cap, frieze molding, or 
shadow boards polyline is selected. This 
checkbox is for reference only and cannot be 

edited. See “Roof Returns and Other Details” 
on page 527. 
• When this box is checked, the selected 

roof trim is updated whenever you check 
Build Fascia and Roof Trim in the 
Build Roof dialog and click OK. 

• If the selected object is edited, this box 
will become permanently unchecked. To 
restore the automatic updating behavior, 
the frieze, shadow boards, or ridge caps 
must be deleted and regenerated. 

Selected Line Panel
The SELECTED LINE panel is available when 
the selected segment of the 3D molding 
polyline is a line as opposed to an arc.

Most of the settings on this panel are the 
same as those on the LINE panel of the Line 
Specification dialog. See “Line Panel” on 
page 1084. 

The Length/Angle settings in the 3D 
Molding Polyline Specification dialog are 
unique to this dialog.

• Length specifies the 3D length of the 
selected edge of the 3D molding polyline.

• Angle in XY Plane specifies the counter-
clockwise angle that the selected line 
makes with the positive X axis when 
viewed from above, as in floor plan view.

• Angle from XY Plane specifies the 
angle that the selected line makes with 
the horizontal XY plane when viewed 
from the side, as in a cross section/eleva-
tion view. A positive value means that the 
line slopes up; a negative value means 
that it slopes down.

Selected Arc Panel
The SELECTED ARC panel is available when 
the selected segment of the 3D molding 
polyline is an arc as opposed to a line.

Numerous other specification dialogs in the 
program have a SELECTED ARC panel as 
well; however, most of the settings on this 
panel work differently for 3D Molding 
Polylines than they do for other objects. 
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The Lock options specify how 
changing one value affects other values.

• Select Start to keep the start and center 
of the arc fixed and move the end.

• Select End to keep the end and center of 
the arc fixed and move the start.

• Select Center to keep the center of the 
arc fixed and move the start or end.

• Select Arc to keep the arc geometry fixed 
and translate the arc.

• Select Chord to keep the start and end 
fixed and change the radius.

1
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Specify the coordinates of the selected 
arc’s Start point. Only available when 

Lock End or Lock Arc is selected.

Specify the coordinates of the selected 
arc’s End point. Only available when 

either Lock Start or Lock Arc is selected.

Specify the length and angle of the 
selected arc’s Chord. Only available 

when Lock Start or Lock End is selected. 
• Specify the Chord Length, which is the 

3D distance between arc start and end.
• Specify the Chord Angle: the angle cre-

ated by the chord and the positive X axis.

The Arc options specify radius, angle 
and length values of the selected arc:

• Radius - The distance from the arc to the 
arc center.

• Start Angle - The angle created by a line 
from the arc center to the start and the 
positive X axis.

• End Angle - The angle that a line from 
the center to the end

• Arc Angle - The angle created by a line 
from the arc center to the start and a line 
from the center to the end.

• Arc Length - The length of the arc.

Specify the coordinates of the selected 
arc’s Center point. Only available 

when Lock Arc is selected.

The items under the Normal heading 
state the coordinates of the normal of 

the plane that the arc exists in. The normal is 
a vector that is parallel to that plane and is 
expressed as a line between two points: 
(0,0,0) and the point defined in the dialog.

The arc direction in plan view is counter 
clockwise if the normal has a positive value 
on the z axis (0,0,1) and clockwise if the 
value on the z axis is negative (0,0,-1). 

Moldings Panel
The MOLDINGS panel can be found in the 
specification dialogs for a variety of different 
objects in the program. See “Moldings 
Panel” on page 659. 

One setting on this panel is unique to the 
Molding Polyline and 3D Molding Polyline 
Specification dialogs: 
• Check Inside to extrude the molding pro-

file on the inside or right side of the poly-
line. 

• When unchecked, the molding profile 
extrudes on the outside or left side of the 
polyline.

2

3

4

5

6

7

Molding extruded inside

Molding extruded outside (Inside unchecked)
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Line Style Panel
The LINE STYLE panel can be found in 
dialogs throughout the program. For more 
information, see “Line Style Panel” on page 
1085.

If an automatic frieze or shadow board 
polyline is edited, it will no longer be 
considered Automatic and the Default Layer 
checkbox on this panel will be unchecked.

Fill Style Panel
The settings on the FILL STYLE panel affect 
the appearance of the selected 3D Molding 
Polyline in floor plan view. For more 

information, see “Fill Style Panel” on page 
1099.

Materials Panel
The MATERIALS panel is found in dialogs 
throughout the program. See “Materials 
Panel” on page 852.

Label Panel
3D Molding Polyline labels display when the 
“Polylines 3D, Labels” layer is turned on and 
use the Text Style assigned to that layer. See 
“Text Styles” on page 1061. 

For more information about the settings on 
this panel, see “Label Panel” on page 1280. 

Frieze Moldings
Frieze moldings, also known as freize 
boards, are mounted below the eaves of roof 
planes and can be generated automatically 
using the Build Roof dialog. 

Creating Frieze Moldings
To create automatic frieze moldings, specify 
a molding profile on the FRIEZE panel of the 
Build Roof dialog; check Build Fascia, 
Gutters on the BUILD panel of the Build 
Roof dialog; and click OK. See “Frieze 
Molding” on page 530.

Displaying Frieze Moldings
By default, frieze molding displays in 3D 
views but not in floor plan view and its 
default layer, “Roofs, Trim”, is locked. See 
“Layer Display Options Dialog” on page 
149.

Selecting Frieze Moldings
To select a frieze molding, its layer must first 
be unlocked and turned on. See “Locking 
Layers” on page 145. In floor plan or a cross 

Frieze moldings under a dormer’s eaves
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section/elevation view, click on a frieze 
molding. If the wall behind it is selected, 

click the Select Next Object  edit button 
or press the Tab key until the frieze molding 
is selected. When the frieze molding is 
selected the Status Bar says “3D Molding 
Polyline.” See “The Status Bar” on page 42.

Editing Frieze Moldings
Like other 3D Molding Polyines, frieze 
molding can be edited much the way CAD 
polylines are in floor plan and cross section/
elevation views. See “Editing Molding 
Polylines” on page 667.

Frieze molding can also be edited in the 3D 
Molding Polyline Specification dialog. See 
“3D Molding Polyline Specification Dialog” 
on page 669.

If you edit a frieze molding, it is no longer 
considered an Automatic frieze and will not 
be deleted and replaced if Fascia and Roof 
Trim is rebuilt. Once Automatic is 
unchecked, it cannot be checked again.To 
restore the automatic updating behavior of 
frieze molding, it must be regenerated. 
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Chapter 20:

Cabinets

With Chief Architect’s cabinet tools you can 
create base, wall, and full height cabinets as 
well as soffits, shelves, partitions, and 
custom countertops. These objects are very 
versatile, allowing for a wide range of 
customization. 

A selection of cabinet door and drawer styles 
are available in the Library Browser and, in 
addition, a numerous cabinet manufacturer 
catalogs are available for download on our 
web site,  chiefarchitect.com.

Chief Architect also has many customized 
cabinet symbols and cabinet groups available 
in the library. Cabinets you have customized 
can be saved to your own library for future 
use.

Chapter Contents
•      Cabinet Defaults
•      The Cabinet Tools
•      Cabinet Fillers
•      Placing Cabinets and Fillers
•      Custom Countertops
•      Displaying Cabinets
•      Cabinet Labels
•      Editing Cabinets
•      Editing Cabinet Styles
•      Special Cabinets
•      Cabinet Specification Dialog
•      Cabinet Shelf Specification Dialog
•      Shelf/Partition Specification Dialog
•      Custom Countertop Specification Dialog
•      Cabinet Schedules

http://www.chiefarchitect.com/
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Cabinet Defaults
Access default settings for each 
cabinet tool by selecting Edit> 

Default Settings, then clicking the white 
arrow beside Cabinets. Select a subheading 
and click the Edit button to open the defaults 
dialog associated with your selection. 

The Cabinet Defaults dialogs can also be 
accessed by double-clicking the Cabinet 
Tools  parent button. 

Double-clicking a Cabinet Tools child button 
also opens its corresponding defaults dialog, 
if that object has a defaults dialog.

Each type of cabinet object has default 
definitions for size, style, materials and much 
more. In fact, the default dialog for each 
cabinet type is similar to its corresponding 
specification dialog. For descriptions of 
these settings, see “Cabinet Specification 
Dialog” on page 696, “Shelf/Partition 
Specification Dialog” on page 710 and 
“Soffit Specification Dialog” on page 796.

Cabinet Fillers, Custom Backsplashes, and 
Custom Countertops do not have defaults 
dialogs. Instead, their initial settings are 
based on the those of other objects. 

• Base Cabinet Fillers’ initial settings are 
based on Base Cabinet Defaults.

• Wall Cabinet Fillers’ initial settings are 
based on Wall Cabinet Defaults.

• Full Height Cabinet Fillers’ initial set-
tings are based on Full Height Cabinet 
Defaults.

• Custom Backsplashes’ initial settings are 
based on the Base Cabinet Defaults for 
backsplash thickness and material.

• Custom Countertops’ initial settings are 
based on Base Cabinet Default settings 
but are also influenced by the settings of 
cabinets beneath them. See “Custom 
Countertops” on page 679.

Dynamic Cabinet Defaults
When a dynamic default is changed, existing 
cabinet objects using the default value are 
affected. See “Dynamic Defaults” on page 
76. 

The following cabinet default values are 
dynamic: Separation, Backsplash Height 
and Thickness, Countertop Overhang and 
Thickness, Toe Kick Height and Depth, 
Side and Vertical Overlap, Stiles, and  
Hardware spacing. 

All Materials are also dynamic. In addition, 
the Cabinet Defaults can be set up to refer 
dynamically to information in the Material 
Defaults dialog. This makes it easy to have 
all cabinet objects in a plan use the same 
default materials. See “Material Defaults 
Dialog” on page 849. 
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To use dynamic cabinet Material Defaults

1. Specify the desired materials for the 
cabinet categories in the Material 
Defaults dialog:

•  “Cabinets” can be linked to the default 
cabinet box, shelves, and toe kicks as 
well as to Shelves and Partitions.

•  “Cabinet Door/Drawer” can be linked 
to the default frames and panels of cab-
inet doors and drawers.

•  “Countertop” can be linked to the 
default countertop. 

•  “Hardware” can be linked to the default 
door and drawer pulls and hinges.

2. On the MATERIALS panel of the Base 
Cabinet Defaults dialog, select the first 
object component and click the Select 
Material button.

3. The Select Material dialog opens:

•  On the LIBRARY MATERIAL panel, 
check Use default material, or

•  On the PLAN MATERIAL panel, select 
“Use Default” at the top of the list.

4. Click OK, then repeat this step for each 
of the components in the list.

5. Repeat steps 2-4 in each of the Cabinet 
Defaults dialogs.

Set as Default
You can set the attributes for a cabinet 
placed in your plan as the defaults for 

that cabinet type. See “Set as Default” on 
page 76 

General Cabinet Defaults
The General Cabinet Defaults dialog can be 
accessed only from the Default Settings 
dialog. • Specify the Minimum Cabinet Width. 

The minimum allowable width is 1/16 of 
an inch (10 mm). 

• Uncheck Create Automatic Fillers to 
prevent fillers from automatically gener-
ating in spaces between cabinets. This 
setting is dynamic: changing it will affect 
cabinets already present in your plan. See 
“Cabinet Fillers” on page 681.

• Uncheck Create Automatic Blind Cor-
ner Cabinets to prevent blind corner 
cabinets from being created. This setting 
is dynamic: changing it will affect cabi-

Note: Set as Default is not available for spe-
cial shaped cabinets. Only Standard cabinets
can be the default cabinet type. See “Special
Cabinets” on page 692. 

1
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nets already present in your plan. See 
“Blind Cabinets” on page 695.

Specify how Cabinet Resizing takes 
place when the edit handles are used.

• Select Use Grid Snaps to resize cabinets 
using Snap Grid increments. See “Grid 
Snaps” on page 166.

• Select Use Resize Increment to resize 
cabinets using the increment specified 
here. 

• Set the Resize Increment at which cabi-
nets resize. The minimum allowable 
increment is 1/16 of an inch (10 mm).

Check Show Partial Module Lines to 
represent module lines as grey lines that 

do not extend across the cabinets. When this 
is unchecked, lines between merged cabinet 
modules display as specified by the 
“Cabinets, Module Lines” layer. See 
“Displaying Cabinets” on page 684.

The Cabinet Tools
Select Build> Cabinet to access the 
Cabinet Tools.

Cabinets are easily created with a single click 
in floor plan view or any camera view. See 
“Click-to-Create” on page 167.

Typically, groups of cabinet objects are 
positioned closely together and arranged to 
form work spaces, and there are some special 
behaviors and techniques to be aware of. See 
“Placing Cabinets and Fillers” on page 681.

Once created, cabinets, soffits, shelves, 
partitions and fillers can be selected and 
edited much like other box-based objects. 
See “Editing Cabinets” on page 688.

Base Cabinets
Select Build> Cabinet> Base 
Cabinet and click in any view. Base 

cabinets can be placed directly under wall 
cabinets and generate a countertop and toe 
kick by default.

Wall Cabinets
To place a wall cabinet, select Build> 
Cabinet> Wall Cabinet and click in 

any view. Wall cabinets can be placed 
directly over base cabinets. 

Full Height Cabinets
To place a full height cabinet, select 
Build> Cabinet> Full Height and 

click in any view. Full height cabinets 
generate a toe kick by default and cannot be 
placed on top of other cabinets.

Soffits
Soffits typically fill the space between 
cabinet tops and the ceiling, but can 

also be used to create any object that can be 
modeled as a 3D box. To place a soffit, select 
Build> Cabinet> Soffit and click in any 
view.

By default, soffits use the material assigned 
to interior walls in the Material Defaults 
dialog. Like cabinets, soffits can have 
molding profiles applied to them.

2
3
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For more information about using soffits for 
a variety of purposes, see “Other Objects” on 
page 777.

Shelves
Select Build> Cabinet>  Shelf and 
click in any view to create a shelf. 

Create corner shelves by placing one shelf on 
each wall, then moving or stretching them 
until they touch.

Once created, shelves can be selected and 
edited. See “Shelf/Partition Specification 
Dialog” on page 710.

You can also specify shelves inside of base, 
wall, and full height cabinet boxes. See 
“Cabinet Shelf Specification Dialog” on 
page 709.

Partitions
Select Build> Cabinet> Partition 
button and click in any view to create 

a vertical partition. 

Like shelves, partitions can be selected and 
edited after they are placed.  

Partitions can be used with shelves to create 
complex storage systems.

Custom Countertops
Custom Countertops are drawn and 
edited just like other closed-polyline 

based objects. Select Build> Cabinet> 
Custom Countertop, then either click and 
drag a rectangle or single-click to place a 
2’x2’ countertop. See “Custom Countertops” 
on page 683.

You can also generate a custom countertop 
over one or more base cabinets using the 

Generate Custom Countertop  edit tool. 
See “Using the Edit Tools” on page 689.

Custom Counter Holes
Select Build> Cabinet> Custom 
Counter Hole, then either click and 

drag a rectangle or single-click to place a 
2’x2’ countertop hole. Custom Counter 
Holes must be drawn within an existing 
Custom Countertop, can be drawn in any 
view except cross section/elevation views 
and can be edited to any shape. See “Editing 
Custom Countertops” on page 684.

Custom Backsplashes
Select Build> Cabinet> Custom 
Backsplash while an elevation or 

camera view is active, then either click and 
drag a rectangle or single-click on a wall 
surface to place a Custom Backsplash 
Layered Material Polyline on that wall. See 
“Custom Backsplashes” on page 800.

Cabinet Library Catalogs
In the Library Browser, browse to 
Chief Architect Core Catalogs> 

Architectural> Cabinets to access a selection 
of specialty cabinets. Select the library object 
you want, then click in any view to place it in 
the plan. Once placed, library cabinets can be 
edited. See “The Library” on page 819.

A selection of cabinet manufacturer catalogs 
is also available for download. These 
catalogs include door and drawer styles and 
may also provide moldings and millwork, 
finishes, and hardware. See “Manufacturer 
Catalogs” on page 826. 
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In addition, you can add single cabinets and 
blocked units to the library. See “Adding 
Library Content” on page 829 and 
“Architectural Blocks” on page 811. 

Cabinet Doors, Drawers, 
and Panels Catalogs

A selection of cabinet door, drawer, 
and panel styles is available in  Chief 

Architect Core Catalogs> Architectural. 
Select an item, then click on a cabinet in your 
plan to place the door or drawer onto that 
cabinet. Doors, drawers, and panels can be 
assigned to a cabinet in its specification 
dialog, as well. Cabinet doors, drawers, and 
panels can also be placed as stand-alone 
fixtures. 

You can create custom cabinet doors and 
drawers and save them in the library for 
future use. See “Convert to Symbol” on page 
1206.

Built-In Sinks and Appliances
A variety of fixtures and appliances such as 
sinks, cooktops, and dishwashers can be 
placed into cabinets. See “Inserted Objects” 
on page 837. 

To insert a fixture into a cabinet, select the 
fixture in the Library Browser, then click on 
a cabinet. There must be enough space in the 
cabinet or adjoining cabinets to contain the 
selected fixture. 

Only one front mounted appliance can be 
inserted in this manner. Additional front 
fixtures can be added in the Cabinet 
Specification dialog. See “Front/Sides/Back 
Panel” on page 701. 

If a sink or cooktop is inserted into a cabinet 
with a top Drawer or Double Drawer, its Item 
Type will automatically change to a False 
Drawer or False Double Drawer.

Once placed, an inserted fixture can be 
selected and edited:
• To select a fixture in a cabinet top, click 

on it and then click the Select Next 
Object  edit button. See “Select Next 
Object” on page 185.

• Front fixtures can only be modified or 
deleted in the Cabinet Specification dia-
log. See “Front/Sides/Back Panel” on 
page 701. 

When a cabinet has a fixture on either its top 

or front, the Open Symbol  edit button 
opens its specification dialog. When a 

cabinet has both, the Open Symbol  
button opens the specification dialog for the 
fixture on the front. When a cabinet has 
multiple front appliances, the Open 
Symbol  edit button will not be available. 

Electrical Switches and Outlets
Electrical switches and outlets can be 
placed on cabinets in most views. See 

“The Electrical Tools” on page 639.

Place fixtures and appliances into cabi-
nets early, so that any resizing can be

done while there is adequate free space. Fixtures can be added to both the top
and front of the same cabinet. It is up to

you to determine which can be effectively and
safely combined in the real world. 
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Cabinet Fillers
Cabinet fillers can be created automatically 
or placed manually. See “General Cabinet 
Defaults” on page 677.

Both automatic and manually placed cabinet 
fillers are included in the Materials List. 
Cabinet filler sizes in the Materials List are 
rounded to the nearest 1/16” (1 mm). 

Automatic Fillers
By default, Chief Architect models a 
continuous countertop and generates fillers 
automatically when cabinets of the same 
height are either touching or placed with 3” 
(75 mm) of one another. 

If two cabinets meeting at a corner are 
separated from each other by 3” (75 mm) or 
less, the program will automatically generate 
a filler in the angle between them. A filler is 
used to separate the front of one of these 
cabinets from the one it meets so that 
drawers and doors have room to operate.

Cabinet Filler Tools
If you prefer, you can place cabinet 
fillers manually using the Cabinet 

Filler Tools. Select Build> Cabinet Filler to 
access these tools.

To create a cabinet filler, select Build> 
Cabinet Filler , choose the desired tool 
from the submenu, then click to place a filler 
just as you would a cabinet, in any view.

Base Cabinet Fillers  are composed 
of a front surface, a toe kick and a 

section of countertop.

Wall Cabinet Fillers are composed of 
a front surface only.

Full Height Cabinet Fillers are 
composed of a front surface and a toe 

kick.

You can also convert a regular base, wall or 
full height cabinet into a filler by checking 
Filler in the Cabinet Specification dialog. 
Similarly, a cabinet filler can be converted to 
a regular cabinet by unchecking this box. See 
“General Panel” on page 697. 

Once created, manually placed cabinet fillers 
can be edited much like regular cabinets. 

Placing Cabinets and Fillers
Cabinets and cabinet fillers are easily created 
with a single click in any view. See “Click-
to-Create” on page 167. 

 When used near a wall corner, the Cabinet 
Tools will produce corner cabinets and 
soffits. See “Corner Cabinets” on page 693.

Two base cabinets and the filler between them
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When created, cabinets are positioned 
relative to the floor of the room in which they 
are placed. Base and full height cabinets 
typically rest on the floor while wall cabinets 
are placed a set distance above the floor. See 
“Cabinet Defaults” on page 676.

If the ceiling height of the room does not 
accomodate the height of a cabinet, its Floor 
to Bottom value will be retained and its 
Height will be reduced so that it fits under 
the ceiling. When this happens, some front 
items may be removed from the cabinet if 
there is not enough room for them. See 
“Front/Sides/Back Panel” on page 701.

Because cabinets are typically organized into 
groups with shared attributes, they have 
some special behaviors. 

Cabinet Snapping and Aligning
Cabinets have several special snapping and 
aligning behaviors which help you create 
precisely aligned cabinets quickly and easily.
• When Base and/or Full Height cabinets 

are within 3” of one another’s sides, they 
will snap together. Wall cabinets snap in a 
similar manner, but only with other Wall 
cabinets.

• When Base and/or Full Height cabinets 
are within 3” of one another’s sides and 
their front or back surfaces are within 3” 
of aligning, they will become aligned. 
Wall cabinets snap in a similar manner 
with other Wall cabinets as well as Full 
Height cabinets.

• When a Base and/or Full Height cabinet 
is placed against the back of another Base 
or Full Height cabinet, its back surface 
will automatically face the other cabinet’s 
back. Wall cabinets snap in a similar 

manner with other Wall as well as Full 
Height cabinets.

• When a cabinet or cabinet filler is placed 
against a wall, its back and/or side will 
snap to the wall and, if the wall is moved, 
the cabinet will move with it.

When cabinets are snapped to a wall or to 
other cabinets, only exposed end cabinets 
have side counter overhangs, closed toe 
kicks, feet and corner pilasters. Adjacent 
cabinet fronts share front pilasters.

Cabinet snapping and aligning occurs even 

when when Object Snaps  are turned off; 
however, you can override this behavior by 
moving a cabinet into the desired position 
using dimensions. See “Moving Objects 
Using Dimensions” on page 1019.

Cabinet Merging
When cabinets of the same height and type 
are placed side-by-side within 3” (30 mm) of 
one another they will automatically merge, 
making any shared components such as the 
toe kick, countertop, backsplash, and 
moldings continuous. Any gap between 
merged cabinets will be automatically filled.

The exposed ends of merged cabinets have 
side counter overhangs, closed toe kicks, feet 
and corner pilasters. Adjacent merged 
cabinets share front pilasters.

Cabinets placed at different angles will also 
merge if they face toward one another and 
meet at a front corner. Cabinets that meet at a 
back corner will also merge provided that 
they face away from one another at an angle 
no greater than 87°. In either case, a filler is 
created in the angle between the two. 
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If the side of a cabinet is placed within 3” (30 
mm) of a wall, the countertop will extend to 
the wall and a filler will be created. 

Cabinet merging occurs even when Object 
Snaps  are turned off; however, you can 
suppress this behavior for cabinets that do 
not actually touch by turning off Create 
Automatic Fillers. See “General Cabinet 
Defaults” on page 677.

Base and Wall Cabinets
Base and wall cabinets have different default 
heights, so they can be placed directly above 
or below one another without interference. 

You can use Object Snaps  to center a 
wall cabinet’s back center point above that of 
a base cabinet, or vice versa. See “Click-to-
Create” on page 167.

Minimum Cabinet Size
If you try to place a cabinet into a space that 
is too narrow for its default size, the program 

will place a smaller cabinet with a width that 
is a multiple of the default Resize 
Increment. For example, if you try to place a 
24” wide cabinet in a 20” wide space and 
your Resize Increment is 3”, the program 
places an 18” cabinet. See “General Cabinet 
Defaults” on page 677.

If you try to place a cabinet into a space 
narrower than the default Minimum 
Cabinet Width, a cabinet will not be placed. 
If, for example, you have a space that is 8” 
and your Minimum Cabinet Width is 9”, no 
cabinet is placed. 

Cabinet Fillers
By default, the program will automatically 
place a filler between cabinets that are within 
3” of one another. You can instead turn off 
Create Automatic Fillers and place fillers 
manually. 

Custom Countertops
Countertops are automatically 
generated on top of base cabinets. 

These default countertops are basically 
components of the cabinets. They can be 
edited in the Cabinet Specification dialog 
but cannot be selected and modified 
separately. You can instead use Custom 
Countertops, which are drawn and edited 
just like other closed-polyline based objects 
can be selected and edited independent of the 
cabinets beneath. See  “Rectangular 
Polyline” on page 1101.

Select Build> Cabinet> Custom 
Countertop , then either click and drag a 
rectangle or single-click to place a 2’x2’ 
countertop. Custom Countertops can be 
drawn in any view except cross section/
elevation views.

You can also generate a custom countertop 
over one or more selected base cabinets by 
clicking the Generate Custom Countertop 

 edit button. See “Using the Edit Tools” 
on page 689.
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When a Custom Countertop covers any 
portion of a base cabinet, it overrides the 
default countertop. 

If a sink or built-in appliance is added to the 
cabinet, a hole for the fixture is automatically 
cut in the custom countertop.

A custom countertop bases its thickness and 
height on the base cabinet(s) below. 
• If there are multiple cabinets below, it 

uses the specifications for the cabinet 
with the greatest overall height.

• If there is no base cabinet below, its 
height and thickness are based on the 
base cabinet defaults. See “Cabinet 
Defaults” on page 676.

Editing Custom Countertops
Once created, a custom countertop or 
Custom Counter Hole can be selected in 2D 
and 3D views and edited like other closed-

polyline based objects. See “Editing Closed-
Polyline Based Objects” on page 201.

Customcountertops initially use the default 
countertop material set in the Base Cabinet 
Defaults dialog. You can specify a different 
material as well as the height and position in 
the Custom Countertop Specification 
dialog. See “Custom Countertop 
Specification Dialog” on page 712.

You can also specify the edge profile of a 
custom countertop in the Custom 
Countertop Specification dialog. See 
“Moldings Panel” on page 711.

Displaying Cabinets
The display of the various cabinet 
object types, labels, module lines, 

door opening indicators and more is 
controlled in the Layer Display Options 
dialog. See “Displaying Objects” on page 
144.

In Floor Plan View
Cabinets are drawn so that wall cabinets, 
soffits and shelves are always in front of base 
and full height cabinets, countertops and 
partitions. You can select a cabinet of any 
type, though, and click the Move to Front 

 edit button to make that object display in 
front of other cabinets of the same type. See 
“Move to Front of Group” on page 219. 

Objects assigned to cabinets, including 
doors, drawers, moldings, and hardware are 
located on the same layer as their parent 
object. They display in 3D views, but not in 
floor plan view. 

Cabinet labels display in floor plan and cross 
section/elevation views when the “Cabinets, 
Labels” layer is turned on Text Style 
assigned to their layer. See “Cabinet Labels” 
on page 686.
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Fill Styles and colors can be assigned to 
cabinet objects. Custom Countertops use a 
transparent fill style by default. If generated 

using the Generate Custom Countertop  
edit tool, a Custom Countertop uses the same 
fill style as the selected cabinet. See “Fill 
Style Panel” on page 1099. 

Both automatic and Custom Countertops 
display if the “Cabinets, Countertops” layer 
is turned on. Custom Countertops can be 
assigned a molding profile, and can display 
the width of this profile if Display Molding 
Edges is selected in the Custom Countertop 
Specification dialog. See “General Panel” 
on page 712.

By default, cabinet module lines display in 
floor plan view when cabinet objects of the 
same type are placed side by side. If you 
prefer that these lines not display, turn off the 
“Cabinets, Module Lines” layer. You can 
also specify whether module lines are full or 
partial. See “General Cabinet Defaults” on 
page 677.

You can also display cabinet front indicator 
arrows in floor plan view by turning on the 
“Cabinets, Front Indicators” layer. 

In 3D Views
A cabinet’s label will display in cross 
section/elevation views when the “Cabinets, 
Labels” layer is turned on and the center 
point of the cabinet’s front is visible in the 
view. See “Cabinet Labels” on page 686.

To show door opening indicator arrows in 
cross section/elevation and Orthographic 
views, turn on the “Opening Indicators” 
layer. Opening indicators display in Vector 
Views only. See “Vector View” on page 952. 

In the Materials List
The materials associated with cabinet objects 
are listed under different Categories in the 
Materials List:
• Cabinets - Lists Cabinets, Shelves, Parti-

tions, Custom Countertops, Custom 
Backsplashes, Cabinet Fillers, and cabi-
net doors and drawers placed indepen-
dently from the library.

• Interior Trim - Lists Soffits and any 
moldings assigned to cabinet objects 
located in Interior room. Note that Soffits 
are not listed in the Materials List unless 
a non-default material is applied to them. 
See “Calculating Materials on Soffits” on 
page 795.

• Exterior Trim - Lists any Soffits and 
moldings assigned to cabinet objects 
located in Exterior rooms. See “Room 
Types” on page 335.

• Fixtures - Lists any sinks inserted into 
base cabinets. See “Inserted Objects” on 
page 837.

• Appliance - Lists any appliance fixtures 
inserted into cabinets. If a base cabinet 
has an under-counter appliance inserted 
into it, that cabinet will not be counted in 
the Materials List - only the countertop 
and backsplash materials associated with 
it will be listed. The cabinet will also 
display the appliance’s label information 
instead of its own. 

As with other objects, there are a number of 
ways to control how, or whether, cabinets are 
included in the Materials List. See 
“Organizing Materials Lists” on page 1289. 

You can add and edit information about a 
cabinet’s accessories and sub-accessories in 
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its Components dialog. See “Components 
Dialog” on page 1300. 

Note that cabinet door and drawer height is 
described in two different ways: 
• In the Cabinet Specification dialog, the 

Item Height for cabinet doors and draw-
ers describes the height of the opening in 

the cabinet box rather than that of the 
door or drawer front. See “Front/Sides/
Back Panel” on page 701. 

• In the Components dialog and Materials 
List, the full height of cabinet door and 
drawer front is listed in the Size column. 

Cabinet Labels
Labels for cabinets and cabinet fillers display 
in floor plan and cross section/elevation 
views when the “Cabinets, Labels” layer is 
turned on. See “Object Labels” on page 
1279. 

Shelves and Partitions can also display labels 
when the “Cabinets, Labels” layer is turned 
on, while Custom Countertop labels display 
when the “Polylines 3D, Labels” layer is 
turned on. Unlike cabinets and cabinet fillers, 
the Automatic Label for these objects is 
blank; however, you can specify a custom 
label in their specification dialogs. 

Cabinet labels have their own edit handles 
and can be moved and rotated when a cabinet 
is selected. They use the Text Style specified 
for the “Cabinets, Labels” layer. See “Text 
Styles” on page 1061. 

If a base cabinet’s only front item aside from 
Separations and Blank Areas is an 
Appliance, the appliance’s label will display 
instead of the cabinet’s, and will be placed on 
the “Cabinets, Labels” layer. 

Cabinet labels are available in three different 
formats: 

• Automatic Labels, which include size, 
type and other information in abbreviated 
form. 

• User-Specified, which are entered in the 
Cabinet Specification dialog. See 
“Label Panel” on page 1280.

• Schedule Callout Labels, which are 
specified in the Cabinet Schedule 
Specification dialog. See “Label Panel” 
on page 1277.

The minimum on-screen display size of 
object labels can be specified in the 
Preferences dialog. See “Appearance 
Panel” on page 92.

Automatic Labels
The format for automatic cabinet labels has 
four parts: Key, Code, Size, and Door Swing. 

The Key provides basic information about 
the cabinet box and its use. B refers to base 
cabinets, W refers to wall cabinets and U 
refers to full height cabinets. 

Together with the key, the Code provides 
additional information about the shape of the 
cabinet box:
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Blind corner cabinets are dependent on the 
cabinet’s position in the plan. A cabinet can 
only be a blind corner cabinet when its front 
is partially hidden by another cabinet. See 
“Blind Cabinets” on page 695. If a cabinet is 
moved, therefore, its Code information may 
change. 

Peninsula cabinets are only designated as 
such when they have one or more doors on 

the back side. See “Front/Sides/Back Panel” 
on page 701.

The Size follows the Code in a cabinet label. 
Cabinet width is always included in the label; 
depth and height, on the other hand, may be 
included depending on the cabinet type and 
whether they are standard or non-standard.

Base and full height cabinet labels present 
Size information in this order: width, depth, 
height. Wall cabinet labels present it in a 
slightly different order: width, height, depth.

Door Swing is included at the end of the 
label as either L or R, but only if all the 
doors on a cabinet have the same swing.

Here are a few examples of automatic 
cabinet labels and their meanings: 

Code
All Cabinets

LS + Key Lazy Susan
LSD + Key Lazy Susan Diagonal Door
DC + Key Diagonal Door 
LC + Key Left Corner
BC + Key Blind Corner
PBC + Key Peninsula Blind Corner
Key + P Peninsula
Key + F Filler
E + Key Right or Left End
A + Key Angled Front
PR + Key Peninsula Radius
R + Key Radius End
B Base
     OB       Oven Base
     SB       Sink Base
     RB       Range Base
     #DB       Drawer Bank (# is the 

      number of drawers
     FHB       Full Height Base (1 full 

      height door 

W Wall
    Code from
above + #D

      Drawer (# is the number 
     of drawers

U Full Height (Utility)
     OTC       Tall Oven
     RTC       Tall Refrigerator

Sizes
Base W(D)(H)
     Width (W) Always included
     Depth (D) 24” (60 cm)
     Height (H) 34 1/2” (90 cm)
     Corner 
     Depth (D)

Depth = Width

Wall WH(D)
     Width (W) Always included
     Height (H) Always included
     Depth (D) 12” (30 cm)
     Corner 
     Depth (D)

Depth = Width

Full Height WDH
     Width (W) Always included
     Depth (D) Always included
     Height (H) Always included
     Corner 
     Depth (D)

Always included
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• 3DB24: Base cabinet with 3 drawers, 24” 
wide. Depth and height are standard.

• SB24R: Sink base, 24” wide, with a right 
door. Depth and height are standard.

• BCW2436R: Blind wall cabinet, 24” 
wide, 36” high, with a right door. Depth 
is standard.

• DCW2436L: Diagonal corner wall 
cabinet, 24” wide, 36” high, with a left 
door. Depth is standard (equal to width).

• OTC362490: Full height cabinet with 
oven, 36” wide, 24” deep, 90” high.

Editing Cabinets
Cabinets and cabinet fillers can be selected in 
2D and 3D views both individually and in 
groups and edited using the edit handles, the 
edit toolbar and their specification dialog.

Using the Mouse
Cabinets can be edited like other box-based 
objects. See “Editing Box-Based Objects” on 
page 206. The edit handles that a cabinet 
displays when selected will vary depending 
on the view. 

When a cabinet is selected in floor plan view 
or on its top surface in a 3D view, ten edit 
handles display: the Move handle at the 
center, the Rotate handle, and a Resize 
handle on each edge and at each corner.

In 3D views, cabinets can be selected on any 
surface: front, side, back or top. When the 
side of a cabinet is selected, five edit handles 
are available: the Move handle and a Resize 
handle on each edge. 

When cabinet labels are displayed, a label 
will move as its cabinet is moved or resized. 
When a cabinet is selected, its label will have 
its own Move and Rotate edit handles, as 
well. See “Displaying Cabinets” on page 
684. 

Cabinets cannot be concentrically resized, 
even when the Concentric edit behavior is 
enabled. See “Edit Behaviors” on page 178.

In the Specification Dialog
A selected cabinet can be customized 
in a variety of ways in its specification 

dialog. See “Cabinet Specification Dialog” 
on page 696. 

The Automatic Labels for Shelves and
Partitions are blank, but you can specify

custom labels for both. See “Shelf/Partition
Specification Dialog” on page 710.



Editing Cabinets

 689

Multiple Cabinets
When multiple cabinets are selected as a 
group, any specifications that they share in 
common can be modified in the Cabinet 
Specification dialog. 

When you group select cabinets of different 
types, some options are not available in the 
Cabinet Specification dialog. For example, 
you cannot modify the crown molding on a 
full height cabinet if it is selected with a base 
cabinet that does not have crown molding.

Soffits, shelves, and partitions can be group 
selected and edited using their corresponding 
specification dialog. It is important that only 
soffits, or only shelves, or only partitions be 
a part of the selection set in order to access 
the needed specification dialog. 

You can use the Object Painter  tools to 
assign the properties of one cabinet to other 
cabinets. See “Matching Properties” on page 
249. 

Using the Edit Tools
A cabinet or cabinets can be edited in a 
variety of ways using the buttons on the edit 
toolbar. See “The Edit Toolbar” on page 37.

Add to Library
Cabinets can be saved in the 
Library Browser. Select a base, 

wall or full height cabinet or cabinet filler 
and click either the Add to Library or Add 
to Library As edit button. See “Add to 
Library” on page 829. 

If you use Add to Library As , you can 
add the selected cabinet to the library in 
either of two ways:  

• Select Cabinet Module to save the cabi-
net along with its doors, drawers and pan-
els and any fixtures or appliances. 

• Select Cabinet Doors and Drawers to 
save the cabinet door style only. 

Using Dimensions
Like various other objects, cabinets 
can be moved and resized using 

dimensions. See “Moving Objects Using 
Dimensions” on page 1019. 

In order to be edited using dimensions, 
cabinets must be located by them. In the 
Dimension Defaults dialog, you can specify 
whether or not cabinets are located as 
dimension lines are drawn. See “Locate 
Objects Panel” on page 992. 

You can also specify what components of a 
cabinet are located by dimensions:
• Cabinet sides, corners, centers, and back-

splashes can be located in both floor plan 
and elevation views.

• Cabinet backsplashes, toe kicks, and 
moldings can be located in elevation 
views; they cannot, however, be edited 
using dimensions.

Dimensions locate the sides and/or corners of 
cabinet boxes - not the countertop or the 
center. If you wish, you can move a 
dimension’s extension lines to locate these 
items in floor plan view after the dimension 
line is drawn. In elevation views, the heights 
of the toe kick, backsplash, and/or moldings 
can also be located in this manner. See 
“Editing Extension Lines” on page 1016. 

Temporary Dimensions will locate the wall 
surface nearest the selected object edge or 
either cabinet boxes or Custom Countertops, 
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depending on which type of object is 
selected: 
• If a cabinet box is selected, Temporary 

Dimensions will locate the nearest wall 
surface or another cabinet box, but not 
Custom or automatically generated 
Countertops.

• If a Custom Countertop is selected, Tem-
porary Dimensions will locate the nearest 
wall surface or another Custom Counter-
top, but not cabinet boxes or automati-
cally generated counters.

Moving Walls with 
Cabinets Attached

When a cabinet is placed or moved against a 
wall, it will snap to the wall and become 
attached to it. When a wall is moved, all 
attached cabinets move with it. 

Moving a wall to an unattached cabinet will 
not attach the cabinet to it: the cabinet must 
be moved to the wall. A cabinet can also be 

attached to a wall when Plan Check  is 
used. See “Plan Check” on page 1130. 

When wall layers are resized or the wall 
layer definition redefined, the cabinets may 
become unattached. To reattach, select them, 
drag them away from the wall, and then drag 
them back again.

Editing Cabinet Styles
A variety of settings allow you customize the 
appearance of your cabinets to create styles 
ranging from traditional to contemporary.

If the desired style is known before cabinets 
are placed, you can save time by specifing 
that style in the Cabinet Defaults dialogs 
before you start drawing. See “Cabinet 
Defaults” on page 676.

Cabinet Face Items
A variety of different face items can be 
added to the front of any cabinet, including 
doors, drawers, cutting boards, and 
horizontal separations. Face items can be 
moved, resized, as well as removed and can 
also be split vertically or horizontally to 
produce a variety of custom configurations. 
See “Front/Sides/Back Panel” on page 701.

When adding, removing, or resizing face 
items, it is helpful to keep a few rules in 
mind: 
• Door and drawer Item Height settings 

reflect the height of the opening rather 
than that of the front item. When Tradi-
tional Overlay is specified, an item’s 
front height will be equal to its Item 
Height plus its top and bottom Vertical 
Overlap. 

• When the overall height of a cabinet or 
the height of a face item is changed, the 
height of the lowest face item that is not a 
Separation is adjusted to accommodate 
the change. 

• If you increase the height of the lowest 
face item, the non-Separation item 
directly above is adjusted; if you decrease 
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its height, a Blank Area and Separation 
are created below it. 

When editing a cabinet’s width, or when 
adding or removing features that affect the 
width of a cabinet’s front items, the program 
will try to maintain the relative sizes of face 
items in any vertically split layouts.

Doors, Drawers and Panels
Cabinet doors, drawers, and panels can be 
applied in either of two ways:  
• In the Cabinet Specification dialog. See 

“Door/Drawer Panel” on page 704 and 
“Front/Sides/Back Panel” on page 701.

• Directly from the Library Browser.

Select a style in the library, then click on a 
cabinet to apply the selected style to that 
cabinet. In 3D views, click on a face item to 
apply the selected library object to that item. 
See “Placing Library Objects” on page 836.

A secondary door or drawer style can also be 
specified - for example, to create glass doors 
above solid doors in wall cabinets. See 
“Front/Sides/Back Panel” on page 701.

Cabinet Hardware
Cabinet handles, pulls, and hinges can be 
assigned in the Cabinet Specification 
dialog. See “Door/Drawer Panel” on page 
704.

In 3D views, pulls and handles can also be 
applied directly from the Library Browser. 
Select a hardware item, then click on the 
cabinet face item to apply it to that face item. 
See “Inserted Objects” on page 837.

Pilasters, Feet, and Moldings
Pilasters can be applied to any cabinet in its 
Cabinet Specification dialog. Cabinet feet 
can also be applied to base and full height 
cabinets. See “Accessories Panel” on page 
706.

Multiple molding profiles can also be applied 
around the perimeter of a cabinet at any 
height. For example, you may want a wood 
edge around base cabinet countertops and a 
crown molding that ties together the tops of 
the wall cabinets and full height cabinets. 

Note: To ensure that Face Item heights
always equal the total cabinet front height,
the program automatically adjusts the bottom
Face Item as changes are made elsewhere.
This means you should start editing Face
Items at the top and work down. 

Base cabinet with front pilasters and feet
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Moldings can be built up or stacked, and can 
be recessed, as well - for example, to produce 
a light rail or light valance. See “Moldings 
Panel” on page 659. 

Framed and Frameless 
Cabinets

Both framed and European-style frameless 
cabinets can be specified in Chief Architect. 

For both types of cabinet, you can define the 
door and drawer overlay or specify inset 
doors. On a traditional framed cabinet, you 
can also control the size of the rails and 
stiles. See “Front/Sides/Back Panel” on page 
701. 

Countertops and Backsplashes
The countertop thickness, overhang, corner 
shape, and material for a selected base 
cabinet can be specified in the Cabinet 
Specification dialog. See “General Panel” 
on page 697. 

Backsplashes can be applied to base cabinets 
as well as down from wall cabinets on the 
GENERAL panel of their specification dialogs.

Custom Countertops, Counter Holes, and 
Backsplashes can also be created 
independent of base or wall cabinets. See 
“The Cabinet Tools” on page 678.

Cabinet Shelves
You can customize the shelves inside of base, 
wall, and full height cabinet boxes. See 
“Cabinet Shelf Specification Dialog” on 
page 709.  

You can also specify the material assigned to 
a cabinet’s shelves on the MATERIALS panel 
of the Cabinet Specification dialog. See 
“Cabinet Specification Dialog” on page 696.  

Special Cabinets
There are a number of special cabinet shapes 
that can be specified. Certain requirements 
must be met before some special cabinet 
shapes can be specified. If the requirements 
are not met, a warning message will explain 
what is needed. See “Cabinet Specification 
Dialog” on page 696.

Standard Cabinets

Select Build> Cabinet> Base Cabinet  
and click in floor plan view to place a 
standard, rectangular base cabinet.

Wall cabinet with crown molding and light rail

Note: Only Standard cabinets can be the
default cabinet Type. See “Cabinet Defaults”
on page 676. 
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Corner Cabinets
To create a corner cabinet, click as close to 
an inside wall corner as possible in using 

either the Base Cabinet , Wall Cabinet 
, or Full Height  cabinet tool. A 

corner cabinet remains a corner cabinet when 
it is moved, edited or copied.

You can turn an existing cabinet into a corner 
cabinet by selecting “Corner” from the 
Special drop-down list in its specification 
dialog. See “General Panel” on page 697.
• Before a corner cabinet can be specified 

in the Cabinet Specification dialog, the 
cabinet’s Width must be greater than its 
Depth.

• The Left and the Right Side Widths can 
be set independently for corner cabinets. 

• You can specify a Diagonal Door on cor-
ner cabinets to create an angled corner 

cabinet. See “Front/Sides/Back Panel” on 
page 701.

• The diagonal door on corner cabinets can 
be curved by entering a negative value in 
the second Right Side Width field. See 
“General Panel” on page 697.

Exposed End Cabinets
A cabinet that is merged on one side but not 
the other is referred to as an Exposed End. 

Pilasters, feet, countertop overhangs and 
closed toe kicks all behave differently when 
groups of cabinets are merged: 
• If multiple cabinets are joined together, 

only Exposed End cabinets have corner 
pilasters, cabinet feet, side counter over-
hangs, and closed toe kicks. 

Standard (default) cabinet

Corner cabinet with sides of equal width

Corner cabinet with diagonal door

Corner cabinet with curved door

Exposed End Cabinets
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• If multiple joined cabinets have both 
Front Pilasters and Corner Pilasters 
specified, the Exposed End cabinets 
include corner pilasters and inside cabi-
nets have front pilasters.

• If multiple cabinets are joined, inside 
cabinets share Front Pilasters. 

• Corner pilasters and cabinet legs are 
eliminated on the back if the cabinet is 
against a wall, and on either side if it’s 
joined with another cabinet.

End Cabinets
Open a cabinet for specification and select 
Left or Right End Cabinet from the Special 
drop-down list to create an end cabinet.

• End Cabinets have an angled front and 
side.

• The cabinet width must be no greater 
than its depth for an end cabinet to be 
specified.

Radius End Cabinets
Open a cabinet for specification and select 
Right or Left Radius End from the Special 
drop-down list to create a radius end cabinet.

As you face the cabinet, a right radius end 
curves to the right, and a left radius end 
curves to the left.

Peninsula Radius Cabinets
Open a cabinet for specification and select 
Peninsula Radius from the Special drop-
down list to create peninsula radius cabinet.

The radius can be adjusted by changing the 
Depth/Bow Depth value. See “General 
Panel” on page 697.

Angled Front Cabinets
Open a cabinet for specification and select 
Angled Front from the Special drop-down 
list to create an angled front cabinet.

Left End Cabinet

Radius End cabinets have a 90° arch

Left 
Radius 
End

Right 
Radius 
End

Peninsula Radius Cabinet
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• The length of the left and right side of an 
Angled Front cabinet can be defined by 
changing the Depth/Bow Depth value. 
See “General Panel” on page 697.

Bow Front Cabinets
Open a cabinet for specification and select 
Bow Front from the Special drop-down list 
to create a bow front cabinet.

• The bow depth of a Bow Front cabinet 
can be defined. See “General Panel” on 
page 697.

• The bow depth cannot exceed half the 
cabinet width.

• The doors and drawers on a Bow Front 
cabinet automatically match the curva-
ture of the cabinet.

Kitchen Islands
To create a kitchen island, simply place 
several cabinets back-to-back and/or side-to-

side. Match the widths so that each cabinet 
back or side meets the back or side of only 
one other cabinet. If this is not done, the lines 
separating the cabinets cannot be suppressed. 

A given side of a single cabinet cannot merge 
with the edges of two different cabinets. The 
example below shows two instances of 
cabinets placed back-to-back. Cabinet fronts 
and joining surfaces are shown.

Blind Cabinets
Often, when two cabinets meet in a corner, 
one is partially hidden by the other. This 
partially hidden cabinet is called a “blind” 
cabinet. Chief Architect will resize and offset 
the front items of the partially hidden cabinet 
so that they are not located in the hidden 
portion of the cabinet face.

You can turn off this automatic behavior in 
the General Cabinet Defaults dialog. See 
“General Cabinet Defaults” on page 677.

You can also create a blind cabinet manually 
by controlling the widths of a cabinet’s left or 

Angled Front Cabinet

Bow Front Cabinet

Correct - 
Widths of front and 

back cabinets match

Incorrect - 
Solid line here is not 

suppressed.
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right stile in its Cabinet Specification 
dialog. See “Front/Sides/Back Panel” on 
page 701.

Cabinet Specification Dialog
Select one or more cabinet and click 
the Open Object edit button to open 

the Cabinet Specification dialog.

If the selected cabinet is an imported symbol, 
the Cabinet Symbol Specification dialog 
opens instead and has fewer options than the 

Cabinet Specification dialog. See “Symbol 
Specification Dialog” on page 1195.

The options in the Cabinet Specification 
dialogs are similar to the corresponding 
Cabinet Defaults dialog. See “Cabinet 
Defaults” on page 676.
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General Panel

A number of Cabinet Types are 
available in the drop-down list. Certain 

requirements must be met before some types 
can be specified. Not available in the 
Cabinet Defaults dialogs.  See “Special 
Cabinets” on page 692. 
• Check Filler to specify the selected cabi-

net as a filler of the same type instead of a 
true cabinet. See “Cabinet Fillers” on 

page 681. Not available in the Cabinet 
Defaults dialogs. 

Size/Position - The selected cabinet’s 
dimensions and position relative to the 

floor can be specified here. Fractional values 
are supported to 1/16th of an inch (1 mm).
• Specify the Height (Including Counter) 

of the cabinet box, as measured from bot-
tom to top. For base cabinets, this value 

1

2
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includes the countertop thickness, but not 
the height of the backsplash. 

• Specify the Width of the cabinet box, as 
measured across the front of the cabinet 
box from left to right. This does not 
include the countertop overhang.

• Specify the Depth of the cabinet box, as 
measured from front to back. It does not 
include the thickness of overlay doors or 
the countertop overhang. 

• For Corner cabinets, the Width and 
Depth fields are instead named Right 
Side Width and Left Side Width.

• For Corner and Bow Front cabinets, 
specify the Bow Depth. A positive num-
ber creates a bow and a negative number, 
an inside bow. Not available for Corner 
cabinets if Diagonal is unchecked on the 
Front panel. See “Front/Sides/Back 
Panel” on page 701.

• For Angled Front cabinets, specify the 
Left Depth and Right Depth rather than 
the Depth and Bow Depth.

• Select the Elevation Reference from the 
drop-down list. This determines where 
the next two settings are measured from 
and also affects their setting labels. 

• Specify the to Top distance, measured 
from the Elevation Reference to the top 
of the cabinet’s countertop. 

• Specify the to Bottom distance, mea-
sured from the Elevation Reference to the 

bottom of the cabinet, including the toe 
kick.

Specify the dimensions and style of the 
Countertop here. Only available for 

base cabinets and fillers. 
• Specify the countertop Thickness. 

Changing this value does not alter the 
cabinet height, but it does affect the 
height of face items. See “Front/Sides/
Back Panel” on page 701.

• Specify the countertop Overhang. The 
Overhang is used for any side of a cabinet 
not against a wall or another cabinet. 

• Check Flat Sides to eliminate the counter 
overhang on the cabinet’s exposed ends.

• Check Flat Back to eliminate the over-
hang on cabinets with an exposed back. 

• Corner Treatment - Specify Clipped or 
Rounded countertop corners. The 
options here are the same as those for the 
Cabinet Corner Treatment, but affect the 
countertop rather than the cabinet box. 
See “Front/Sides/Back Panel” on page 
701. 

• When Clipped or Rounded is selected, 
specify the Corner Width, which is mea-
sured from the original location of the 
corner to the point where the straight 
front edge ends. 

The dimensions and style of the 
Backsplash are specified here. Only 

available for base and wall cabinets.
• Specify the backsplash Height and 

Thickness. Height is only available for 
base cabinets - not wall cabinets.

• Check Side to add the backsplash to the 
side of the cabinet if it is against a wall or 

Note: Height refers to the height of the entire
cabinet, including countertop and toe kick. If
you change the Countertop Thickness or Toe
Kick Height, the cabinet’s total height is not
altered. Instead, the cabinet face height and
the heights of face items change in response. 

3

4
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a taller cabinet. Not available for Corner 
cabinets.

• Check Always Present to display the 
backsplash at all times. If unchecked, a 
backsplash is present only when the cabi-
net is against a wall.

• Check Backsplash to Base Below to 
extend a backsplash from the selected 
wall cabinet down to the backsplash or 
countertop of the base cabinet below. 
Only available for wall cabinets. 

Note that while a base cabinet’s backsplash is 
measured from the countertop up, a wall 
cabinet’s backsplash extends downward. 

The dimensions and style of the Toe 
Kick are specified here. Only available 

for base and full height cabinets.
• Specify the toe kick’s Height and Depth. 

Changing the Height does not alter the 
cabinet height but does affect the heights 
of the cabinet face and face items. 

• Flat Sides can be added to base and full 
height cabinets. Checking Flat Sides 
eliminates the toe kick area on the 
exposed end(s) of the cabinet.

• Check Flat Back to eliminate the toe 
kick on a cabinet with an exposed back. 

This does not eliminate the toe kick on 
the cabinet front.

• Check Closed Toe to extend the cabinet 
sides to cover the sides of the toe kick. If 
pilasters that do not extend to the floor 
are specified, checking this places a sup-
port block under them at Exposed Ends.

Options - 
 

• Uncheck Diagonal Door to create double 
doors at right angles instead of a single 
diagonal door. This option is checked by 
default in the Cabinet Defaults dialog 
and is only available for Corner Cabinets. 
See “Corner Cabinets” on page 693.

• Check Lazy Susan to indicate a lazy 
Susan in the cabinet’s label and its 
appearance in floor plan view. This 
option does not display in 3D views.

• Check Include in Schedule to include 
the selected cabinet(s) in the Cabinet 
Schedule. See “The Schedule Tools” on 
page 1268. 

A preview of the selected cabinet 
displays on the right side of the panel. 

See “Dialog Preview Panes” on page 41. 

5

6

7
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Box Construction Panel

Define the Box Construction of the 
selected cabinet. Select Framed to 

create a traditional framed cabinet and enable 
the settings below, or choose Frameless for a 
European style cabinet. 
• Specify the Separation value, which is 

the width of the horizontal face frame 
piece between doors, drawers, and other 
face items. 

• Specify the widths of the Left and Right 
Stiles, which are the vertical frame pieces 
to the left and right of all face items. 
When set to default (D), the program uses 
the selected cabinet’s Separation value. 

Define the Door/Drawer Overlay of 
the selected cabinet.  

• Select Traditional Overlay, then specify 
the Side and Vertical Overlap values.

The Side Overlap is the distance that 

doors and drawers overlap the vertical 
stiles of the cabinet box and is applied to 
both sides of the doors and drawers.

The Vertical Overlap is the distance that 
doors and drawers overlap the horizontal 
separations between front items and is 
applied to both the top and bottom of the 
doors and drawers.

• Select Full Overlay, then specify the 
Reveal, which is the distance between 
door and drawer front items. 

• Select Inset to produce doors and draw-
ers that are flush with the rails and stiles 
rather than overlaying it. 

Cabinet Corner Treatment - Specify 
clipped or rounded corners for the 

selected cabinet’s box. These settings are 
only available for Standard, Corner, and Bow 
Front cabinet types. 

1
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• Select Rounded to create rounded cabi-
net corners, then specify the length of the 
chords of those rounded corners.

• Select Clipped to create 45° angled 
edges at the cabinet corners, then specify 
the length of those angled edges.

• Select None for cabinet corners that are 
neither clipped nor rounded.

• Specify the Corner Width value, as 
measured from the original corner to the 
point at which the clip or curve begins. 
Only available if Clipped or Rounded is 
selected. 

A preview of the selected cabinet 
displays on the right side of the panel. 

See “Dialog Preview Panes” on page 41. 

FRONT/SIDES/BACK Panel
If you click on a cabinet face item in the 
preview on the right side of the dialog, the 

Front/Sides/Back panel will become active 
and that face item will be selected. 

4
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Select which Cabinet Side you would 
like to edit: the Front, Back, Left or 

Right side.
• Assign a Side Type to the selected Side. 

Only “Use Default” and “Custom Face” 
are available for the Front. The options 
are: 

• Select “Use Default” to use the default 
configuration set in the Cabinet Defaults 
dialog. See “Cabinet Defaults” on page 
676.

• Select “Finished” to specify the selected 
side as finished or “Unfinished” to spec-
ify it as unfinished.”Finished” and 
“Unfinished” are only used in Cabinet 
Schedules. See “Columns and Objects to 
Include” on page 1271. 

• Select “Auto Finished” to finish the side 
only when it is not adjacent to another 
cabinet or a wall.

• Select “Paneled” to apply a panel to the 
selected side.

• Select “Auto Paneled” to apply a panel to 
the side only when it is not adjacent to 
another cabinet or a wall. 

• Select “Match Front” to apply the same 
face items as the cabinet front to the 
selected side. 

• Select “Custom Face” to enable the Face 
Items settings below. 

Most of the Face Items settings are 
only active when a door, drawer, or 

other face item is selected.

To select a face item, click on its name in the 
list or click on it in the preview on the right. 
When a face item is selected, it is  
highlighted in the list as well as in the 
preview; its attributes can be edited; and the 

list can be navigated using the arrow and 
number keys. The vertical frame pieces on 
the sides of the cabinet front are referred to 
as stiles and cannot be selected in the 
preview. See “Cabinet Face Items” on page 
690.
• A numbered tree list of face items dis-

plays here. Item numbers start at the top 
of the cabinet and go down the face to the 
bottom of the cabinet. Item 1 is usually 
the top face frame Separation, or rail. The 
selected face item is highlighted; if no 
item is selected, the “Vertical Layout Par-
ent” heading will be highlighted.

• Click Add New to add a new face item 
directly below the currently selected 
item. When a face item is added, the 
height of the lowest item on the cabinet 
front is reduced to make room for the 
new item. If you click Add New with no 
face item selected, the new item is added 
to the bottom of the cabinet face.

• In the New Cabinet Face Item dialog, 
define the Item Type, Item Height, and 
click OK. If the Item Type is “Separa-
tion”, you can check Default to use the 
default Separation Height. 

• Click Delete to remove the selected face 
item. When an Auto Left, Auto Right, 
Left, Right, or Double Door is deleted, it 
is replaced by an Opening; when other 
face item types are deleted, the height of 
the lowest item is increased to make up 
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the difference. You can also press the 
Delete key on the keyboard. 

• Click Move Up to move the currently 
selected item up one position, switching 
places with the item directly above.

• Click Move Down to move the currently 
selected item down one position, switch-
ing places with the item directly below.

• Click Split Vertical to divide the selected 
face item into two separate side-by-side 
items of the same Item Type and Height. 
A vertical separation is added between 
them and together the three new items 
have the same Width as the original item. 
Not available for Horizontal or Vertical 
Layouts, Appliances, Separations, or for 
items 1 1/2” (50 mm) wide or less.

• Click Split Horizontal to divide the 
selected face item into two separate items 
of the same Item Type and Width, 
stacked one above the other. A horizontal 
separation is added between them and 
together the three new items have the 
same Height as the original item. Not 
available for Horizontal or Vertical Lay-
outs, Appliances, Separations, or for 
items 1 1/2” (51 mm) tall or less.

• Click Equalize to make the sizes of a 
face item’s sub-items equal in size. Only 
available if the selected item is a Vertical 
or Horizontal Layout with sub-items.

• Choose the selected face item’s Item 
Type from the drop-down list:

• Specify the selected face item’s Item 
Height. Fractional values are supported 
to 1/16th of an inch (1 mm). For doors 
and drawers, this is the height of the 
opening rather than the item front height. 
A door or drawer’s front height is equal 
to its Height plus its top and bottom Ver-
tical Overlap. For best results, edit face 
item heights starting at the top of the cab-
inet and work down. See “Cabinet Face 
Items” on page 690.

The program tries to maintain a single
separation between all face items.

When you add or delete a face item, separa-
tions are usually added or deleted with them.

Item Type Special Behaviors
Blank Area Creates a solid, flat surface.
Horizontal 
Layout

Creates a group of identical,
side-by-side items sepa-
rated by vertical separa-
tions.

Vertical Layout Creates a group of identical,
stacked items separated by
horizontal separations.

False Drawer
and False Dou-
ble Drawer

Assumes the appearance of
specified the drawer style,
including hardware.

Drawer and
Double Drawer

As specified.

Cutting Board As specified.
Auto Right and
Auto Left Door

Become double doors when
cabinet width is greater than
24” (600 mm).

Left, Right, and
Double Door

As specified, regardless of
cabinet width.

Door Panel Assumes the appearance of
the specified door style but
with no hardware.

Opening Creates an opening with
shelves.

Separation Creates a horizontal rail, or
frame piece. 

Appliance Creates an opening with no
shelves, for which an appli-
ance can be specified.
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• Specify the selected face item’s Item 
Width. Fractional values are supported to 
1/16th of an inch (1 mm). For doors and 
drawers, this is the width of the opening 
rather than the item front width. Only 
available for components of a Horizontal 
Layout.

• Check Lock from Auto Resize to pre-
vent the selected face item from resizing 
when the cabinet is resized, new face 
items are added, or when the Equalize 
button is clicked.

• Shelves - Click the Specify button to 
open the Cabinet Shelves Specification 
dialog and specify the shelf configuration 
for a selected Door or Opening Face 
Item. See “Cabinet Shelf Specification 
Dialog” on page 709. 

• When an Appliance/Door/ or Drawer is 
selected, click the Library button to 
choose an appliance, secondary door 
style, or secondary drawer style for the 
selected face item from the library. The 
options available depend on the type of 
face item currently selected. See “Select 
Library Object Dialog” on page 838. 

• Click the Clear button to remove the 
library appliance, door, or drawer from 
the selected face item. 

Appliance Options - 

Select Reverse Appliance to reverse any 
appliances inserted into the selected cabinet 
from left to right: for example, to change a 
left hand door on a built-in refrigerator to a 
right hand door. This option is only available 
for cabinets with an inserted appliance. See 
“Inserted Objects” on page 837.
• Specify the Front Offset, which is the 

distance from the front of a top-mounted 
appliance to the counter edge. Only avail-
able for base cabinets with a top-mounted 
fixture, such as a sink or cooktop.

A preview of the selected cabinet 
displays on the right side of the panel. 

See “Dialog Preview Panes” on page 41.  

• Click the Select Cabinet Face Item  
button, then click on an item on the front 
of the cabinet in the preview to select that 
item. The selected face item is high-
lighted in grey. 

• Face items identified as “Horizontal Lay-
out” in the list on the left cannot be 
selected in the preview. 

• The cabinet Label displays below the 
preview pane. See “Cabinet Labels” on 
page 686. 

DOOR/DRAWER Panel
The settings on the DOOR/DRAWER panel 
allow you to control the appearance of the 

selected cabinet’s doors, drawers and 
hardware. 

Note: If the Height of an Appliance has been
changed, entering a “d” restores its default
height. See “Built-In Sinks and Appliances”
on page 680. 3
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Specify the appearance of the Doors 
applied to selected cabinet.

Select a door Style from the drop-down list. 
See “Doors, Drawers and Panels” on page 
691.
• Select “Use Default” to apply the door 

style specified in the defaults dialog for 
the selected cabinet’s type. See “Cabinet 
Defaults” on page 676. 

• Select “Slab Doors” to apply a flat door 
front or “Framed Doors” to apply a door 
with a frame and flat panel front.

• Select “Library” or click the Library 
button to select a cabinet door from the 

library. If a library door has been previ-
ously selected, its name will display in 
the list. See “Select Library Object Dia-
log” on page 838.

• Check Glass Doors to use a glass mate-
rial for the panel of Framed doors or for 
the entire door for Slab doors. Not avail-
able when “Library” is the selected door 
Style. 

• Check Stile Between Doors to separate 
double doors and double drawers with a 
stile. Other face items types are not 
affected by this setting. 

1
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Specify the characteristics of the 
selected cabinet’s Door Handles. 

• Select a door handle Style from the drop-
down list or choose one from the 
Library. 

• Specify the position of the handle In 
From Edge, as measured from the edge 
of the door opposite the hinges.

• Specify the height of the handle Down 
From Top, as measured from the top 
edge of the door. For wall cabinets, this 
value is measured Up From Bottom.

Specify the characteristics of the 
cabinet Door Hinges. 

• Select a door hinge Style from the drop-
down list or choose one from the 
Library. 

• Specify the location of the hinges Up/
Down From Edge, as measured from the 
door edge. If the cabinet door is more 
than 35 1/4” (880 mm) high, three hinges 
will be created instead of two. 

Select a Drawer Style from the drop-
down list or choose one from the 

Library. For best results, “Framed” drawers 
should be at least  6” (150 mm) high.

Specify the characteristics of the 
selected cabinet’s Drawer Handles.  

• Select a drawer Handle Style from the 
drop-down list or choose one from the 
Library. 

• Specify the Horizontal Position of the 
drawer handle(s): Choose Use Default to 
use the default position; One Handle 
Centered for a single handle centered on 
the drawer face; or Two Handles In 
From Edge for two handles set in from 
the drawer sides by the value specified in 
the text field. 

• Specify the Vertical Position of the 
drawer handle(s): Choose Use Default to 
use the default position, Centered for 
handle(s) centered on the drawer face, or 
specify the handle’s Distance From Top. 

Options - 

• Enter a Slab Bevel width to create bev-
eled edges on Slab drawers and doors. 
The bevel width, as viewed from the 
front, has a maximum value of 3” (75 
mm). Framed and Library doors are not 
affected by this setting. 

A preview of the selected cabinet 
displays on the right side of the panel. 

See “Dialog Preview Panes” on page 41.  
• The cabinet Label displays below the 

preview pane. See “Cabinet Labels” on 
page 686.

Accessories Panel
The settings on the ACCESSORIES panel let 
you apply pilasters and feet to the selected 
cabinet(s). These options only apply to 

Standard and Corner cabinets. Cabinet feet 
can also be applied to Bow Front cabinets. 
See “Editing Cabinet Styles” on page 690.

2

3

4

5

6

7



Cabinet Specification Dialog

 707

Specify the desired Pilasters for the 
selected Standard or Corner cabinet(s).  

• Front Pilaster - Select the default front 
pilaster, a pilaster from the library, or 
None. 

• Corner Pilaster - Select the default cor-
ner pilaster, a pilaster from the library, or 
None. Specifying a corner pilaster auto-
matically creates a flat corner surface and 
overrides the Flat Corner setting on the 
General Panel. Does not apply to Corner 
cabinets with Diagonal Doors selected.

• Specify the Width of the selected cabi-
net’s pilasters. This value applies to both 
front and corner pilasters. 

• Check Extend to Bottom to extend front 
and corner pilasters to the bottom of the 

toe kick. When this is unchecked, pilas-
ters stop at the top of the toe kick.

Specify Cabinet Feet for the selected 
Standard or Bow Front cabinet(s). 

Select the Default cabinet foot, a cabinet foot 
from the Library, or None. Not available for 
wall cabinets. 
• Specify the Width Offset, which is the 

offset of the cabinet feet relative to the 
sides of the cabinet box. 

• Specify the Depth Offset, which is the 
offset of the cabinet feet relative to the 
front and back of the cabinet box. 

• Check Always Present to place cabinet 
feet under the selected cabinet regardless 
of where it is located. When checked, any 
adjacent cabinet edges will display feet as 

1
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well. When unchecked, the cabinet will 
only receive feet along its outside edge if 
it is an end cabinet. 

• Check Stretch to Fit to resize the cabinet 
feet so that they extend from each corner 
to the midpoint of each edge. Only affects 
cabinet foot symbols with stretch planes 
defined. See “Stretch Planes and Zones” 
on page 1209.

• Check Retain Toe Kick to place a toe 
kick under the cabinet. When unchecked, 
the toe kick is suppressed.

Specify the characteristics of the 
selected cabinet’s  Panels. You can 

specify whether a panel is applied or inset by 
selecting the desired Item Type. See “Front/
Sides/Back Panel” on page 701.
• Choose “Use Default” or select a Slab, 

Framed, or Library Panel Style from the 
drop-down list. 

• Click the Library button to select a panel 
style from the Library Browser. Cabinet 
doors are typically used, although draw-
ers can be used, as well. See “Select 
Library Object Dialog” on page 838.

• Specify the selected panel’s Thickness.

Specify additional characteristics of the 
selected cabinet’s  Side Panels. 

• Check Full Size Panel to apply a single 
panel to the entire side. When unchecked, 
the panel uses the same Style and Over-
lap values as the front. If the cabinet has 
multiple levels of doors on its front, the 
side will have matching panels.

• Check Full Overlay to extend Left and 
Right Side Panels to the outer surfaces of 
the cabinet’s front and back, including 

any doors, panels, or finishes that may be 
present. 

• Check Extend to Bottom to extend pan-
els on the Left, Right, or Back Sides to 
the bottom of the cabinet, including the 
toe kick.

A preview of the selected cabinet 
displays on the right side of the panel. 

To see the cabinet’s pilasters and feet, you 
may want to zoom in.  See “Dialog Preview 
Panes” on page 41. 

Moldings Panel
The settings on the MOLDINGS panel allow 
you to assign one or more horizontal 
moldings around the selected cabinet. See 
“Editing Cabinet Styles” on page 690.

For information about the settings on this 
panel, see “Moldings Panel” on page 659.

Layer Panel
The LAYER panel is found in the 
specification dialogs for many different 
objects. For more information, see “Layer 
Panel” on page 154.

Fill Style Panel
The settings on the FILL STYLE panel affect 
the appearance of the selected cabinet in 
floor plan view. For more information, see 
“Fill Style Panel” on page 1099.

Materials Panel
The settings on the MATERIALS panel affect 
the appearance of the selected cabinet in 3D 
views. For information about these settings, 
see “Materials Panel” on page 852.
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Some material options may be disabled if the 
selected cabinet is a manufacturer symbol. 

Label Panel
Cabinet labels display in floor plan and cross 
section/elevation views when the “Cabinets, 
Labels” layer is turned on and use the Text 

Style assigned to that layer. See “Cabinet 
Labels” on page 686. 

For more information about the settings on 
this panel, see “Label Panel” on page 1280.

Cabinet Shelf Specification Dialog
In the Base Cabinet, Wall Cabinet, or Full 
Height Cabinet Specification dialog, select 
a door or opening face item and click the 

Specify Shelves button to open the Cabinet 
Shelf Specification dialog.  See “Front/
Sides/Back Panel” on page 701.

Shelf Management - Specify how 
shelves in the selected face item are 

created.

• By default, cabinet doors and openings 
receive Automatic cabinet shelves. The 

Note: If you choose a label shape in the Cab-
inet Schedule Specification dialog, the set-
tings here are overridden and the schedule
label is used instead.

1
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number of shelves, shelf type, thickness, 
spacing, and depth display below.

• Select the Manual radio button to specify 
the shelving for the selected door or 
opening. If the cabinet is resized after 
shelving has been manually edited, the 
specifications are maintained, but all 
shelves may not display in all situations.

The Automatic Settings display here 
for reference only. 

The Manual Shelf Specification 
settings are available when Manual is 

selected, above. 
• Specify the total Number of Shelves in 

the selected door or opening front item. 
• Select a Shelf from the drop-down list to 

customize its settings. To edit all shelves 
at once, choose “All Shelves”. 

• Specify the shelf Type from the drop-
down list. 

• Specify the Thickness of the shelves. 
• Specify the Spacing From Previous, 

which is the distance from the bottom of 
the selected shelf to the top of the shelf 
below it.

• If the Spacing From Previous value is 
changed, Equal Spacing will become 
unchecked. Check this box to produce 
evenly space the shelves within the 
selected cabinet front item.

• Specify the selected shelf’s Depth: 
choose Full, Half, or Specify a custom 
value in inches (mm).

The preview shows shelf numbers and 
spacing. Shelf thickness and depth are 

also represented. Press the Tab key to update 
the preview as changes are made.

Shelf/Partition Specification Dialog
Select a shelf or partition and click the 
Open Object edit button to open the 

Shelf Specification or Partition 
Specification dialog.

The options in these specification dialogs are 
similar to the corresponding defaults dialogs. 
See “Cabinet Defaults” on page 676.

Note: If “All Shelves” is selected after
changes are made to an individual shelf, “No
Change” may display in the settings that fol-
low.
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General Panel

Size/Position - Specify the Height, 
Width, and Depth of the shelf or 

partition. 
• Select the Elevation Reference from the 

drop-down list. This determines where 
the next two settings are measured from 
and also affects their setting labels. 

• Specify the to Top distance, measured 
from the Elevation Reference to the top 
of the shelf or partition. 

• Specify the to Bottom distance, mea-
sured from the Elevation Reference to the 
bottom of the shelf or partition.

A preview of the selected object 
displays on the right side of the panel. 

See “Dialog Preview Panes” on page 41.  

Fill Style Panel
The settings on the FILL STYLE panel affect 
the appearance of the selected object in floor 

plan view. For information about these 
settings, see “Fill Style Panel” on page 1099.

Moldings Panel
The settings on the MOLDINGS panel allow 
you to apply molding to the selected object. 
For information about these settings, see 
“Moldings Panel” on page 708.

Layer Panel
For information about the settings on this 
panel, see “Layer Panel” on page 154.

Materials Panel
The settings on the MATERIALS panel affect 
the appearance of the selected object in 3D 
views. For information about these settings, 
see “Materials Panel” on page 852.

1
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Label Panel
Shelf and Partition labels display in floor 
plan and cross section/elevation views when 
the “Cabinets, Labels” layer is turned on and 
use the Text Style assigned to that layer. The 

Automatic Labels for Shelves and Partitions 
re blank, but you can specify custom labels 
See “Cabinet Labels” on page 686. 

For more information about the settings on 
this panel, see “Label Panel” on page 1280.

Custom Countertop Specification Dialog
Select a custom countertop and click 
the Open Object edit button to open 

the Custom Countertop Specification 
dialog.

General Panel

Options - 

• Check Hole in Countertop to convert 
the selected countertop, which must be 
contained within another single Custom 
Countertop, into a countertop hole. 

• Check No Molding On Selected Edge to 
turn off the display of molding on the 
selected edge. Only has an effect when a 

molding is specified for the countertop on 
the MOLDINGS panel of this dialog.

• Check Display Molding Edges to dis-
play two edge lines instead of one, indi-
cating the width of any molding applied 
to the countertop. Only has an effect 
when a molding is specified for the coun-
tertop. 

Countertop Thickness - 

1
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• Uncheck Set Thickness From Cabinet, 
then specify the Thickness of the selected 
Custom Countertop below. When this is 
checked, the thickness is inherited from 
the cabinet below or from the Base 
Cabinet Defaults dialog if no cabinet is 
present below.

Countertop Height - 

• Uncheck Set Height from Cabinet, then 
specify the height of the selected Custom 
Countertop using the settings below. 
When this is checked, Countertop height 
is determined by the cabinet below or by 
the default base cabinet counter thickness 
if no cabinet is present below.

• Select the Elevation Reference from the 
drop-down list. This determines where 
the next two settings are measured from 
and also affects their setting labels. 

• Specify the height to Top, which is mea-
sured from the selected Elevation Refer-
ence to the top of the countertop.

• Specify the height to Bottom, which is 
measured from the selected Elevation 
Reference to the bottom of the counter-
top.

Polyline Panel
The POLYLINE panel states the length of the 
countertop’s Perimeter, its Area, and its 
Volume. See “Polyline Panel” on page 1098. 

If the selected countertop has any Holes, they 
will be subtracted from the Area and 
Volume values. See “Custom Counter 
Holes” on page 679.

Selected Line/Arc Panel
The SELECTED LINE panel is available when 
the selected edge is a line as opposed to an 
arc. For more information, see  “Line Panel” 
on page 1084.

The SELECTED ARC panel is available when 
the selected edge has been converted to an 
arc. For more information, see “Arc Panel” 
on page 1093.

See, too, “Selected Edge” on page 184 and 
“Change Line/Arc” on page 232. 

Moldings Panel
The settings on the MOLDINGS panel allow 
you to apply an edge profile to the selected 
countertop. For information about these 
settings, see “Moldings Panel” on page 708.

Line Style Panel
For information about the settings on this 
panel, see “Line Style Panel” on page 1085.

Fill Style Panel
The settings on the FILL STYLE panel affect 
the appearance of the selected countertop in 
floor plan view. For information about these 
settings, see “Fill Style Panel” on page 1099.

Materials Panel
The settings on the MATERIALS panel affect 
the appearance of hte selected countertop in 
3D views. For information about these 
settings, see “Materials Panel” on page 852.

Label Panel
Custom Countertop labels display in floor 
plan and cross section/elevation views when 
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the “Polylines 3D, Labels” layer is turned on 
and use the Text Style assigned to that layer. 
The Automatic Label for countertops is 

blank, but you can specify a custom label. 
See “Cabinet Labels” on page 686.

For information about the settings on this 
panel, see “Label Panel” on page 1280.  

Cabinet Schedules
The Cabinet Schedule tool allows 
you to produce customizable cabinet 

schedules as well as cabinet labels that 
display schedule numbers. See “Schedules 
and Object Labels” on page 1267. 

Some cabinets with built-in appliances will 
not be included in a cabinet schedule, even if 
Include in Schedule is checked in the 
Cabinet Specification dialog. Examples 

include base cabinets with dishwashers or 
built-in ranges.

Built-in appliances can also be listed in 
customizable fixture schedules. Note that 
free-standing appliances can display 
schedule callout labels, but built-in 
appliances cannot because they share their 
label with the cabinet. 
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Chapter 21:

Terrain

Chief Architect allows you to model the 
terrain around a house. Begin by specifying 
elevation data that creates the surface 
contours, and then add surface features such 
as planting areas and water features.

You can import terrain data from a variety of 
sources and use this data to produce your 3D 
model. 

Once the terrain is modeled, shadows that 
follow the terrain can be created using the 
Sun Angle tool. See “Sun Angles and 
Shadows” on page 943. 

Driveways, parking lots and sidewalks as 
well as plants and sprinklers are among the 
objects that can be placed in your terrain and 
are discussed in “Plants and Sprinklers” on 
page 765 and  “Roads, Driveways and 
Sidewalks” on page 755. 

Chapter Contents
•      Terrain Toolbar Configuration
•      Terrain Perimeter
•      Elevation Data Tools
•      Terrain Modifier Tools
•      Terrain Feature Tools
•      Garden Bed Tools
•      Water Feature Tools
•      Stepping Stone Tools
•      Terrain Wall and Curb Tools
•      Sun Shadows
•      Terrain Objects in the Library
•      Displaying Terrain
•      Editing Terrain Objects
•      Importing Elevation Data
•      Converting CAD Objects to Terrain Data
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Terrain Toolbar Configuration
The Terrain and Road Tools can be 
accessed through the Terrain menu. 

You can also display these tools on your 
toolbar using the Terrain Configuration. 
See “Toolbar Configurations” on page 131. 

The Terrain Configuration and Terrain menu 
both display the following Terrain, Road, 
Plant, and Sprinkler parent tools:

• Elevation Data Tools  allow you to 
add elevation data to your terrain.

• Terrain Modifier Tools  model 
changes in elevation within a defined 
area.

• Terrain Feature Tools  let you add 
materials over the top of the terrain. 

• Garden Bed Tools  create Terrain 
Features with a mulch material.

• Water Feature Tools  create Terrain 
Features with a water material.

• Stepping Stone Tools  are used to cre-
ate paths composed of multiple Terrain 
Features.

• Terrain Wall and Curb Tools  let you 
draw walls and curbs that follow the ter-
rain.

• Road, Driveway and Sidewalk 
Tools  allow you to create paved areas 
that can form intersections.

• Plant Tools  allow you to place plant 
images and 3D plant symbols.

• Sprinkler Tools  are used to lay out 
sprinkler symbols and irrigation lines.

Terrain Perimeter
The Terrain Perimeter is a closed 
polyline defining the boundary of the 

terrain that generates in 3D views and of the 
contour lines that generate in floor plan view. 
Select Terrain> Create Terrain Perimeter 
to create a terrain perimeter.

A CAD polyline can also be converted into a 
terrain perimeter. See “Editing Terrain 
Objects” on page 731.

If you create a terrain perimeter in floor plan 
view but do not see it, select Window> Fill 

Terrain Perimeter
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Window . See “Zoom Tools” on page 
881. 

When created in a new, blank plan, a new 
terrain perimeter will be 50’ x 100’. If you 
create a terrain perimeter after you have 
drawn all or part of a 3D model, it may 
increase in size as needed to encompass 
everything in floor plan view. 

Once created, the terrain perimeter can be 
resized and edited like other polyline-based 
objects. See “Editing Closed-Polyline Based 
Objects” on page 201. 

When a terrain perimeter is first created, it is 
completely flat and is placed at a height of 
0’-0”, or sea level.

The terrain perimeter by itself does not have 
elevation data associated with it. You can use 

the Elevation Data  and Terrain 
Modifier  tools to create terrain that 
slopes in a wide variety of ways. If you do 
not create elevation data within the terrain 
perimeter, the terrain remains flat at an 
elevation of 0' - 0". See “Elevation Data 
Tools” on page 719 and “Terrain Modifier 
Tools” on page 723.

Terrain Height vs Floor Height
Chief Architect always defines the default 
height of Floor 1 at 0’-0”. This height value 
is the constant by which the heights of 

structural elements in the program like walls, 
floors, and ceilings are measured. The 
heights of architectural object can be 
measured relative this absolute height, as 
well. See “Floor 1 Default Height” on page 
330.

The default height of Floor 1 is not, however, 
the absolute by which terrain elevation is 
measured. Instead, elevation data is  
measured relative to sea level. This means 
that if you want to, you can use real-world 
elevation data to generate a 3D terrain model 
without also having to measure floor and 
ceiling heights from sea level. See 
“Importing Elevation Data” on page 747. 

The program automatically positions Floor 1 
a set distance above the terrain. To do this, it 
first finds the center point of the building 
footprint. Then, it determines the elevation of 
the terrain at that point. Finally, it adds 6” 
(150 mm) plus the thickness of the floor 
platform and treated sill plate to this value. 
The resulting value, referred to as the 
Subfloor Height Above Terrain, is how far 
the default height of Floor 1 is above sea 
level in the current plan. See “Foundations 
and the Terrain” on page 461.

In a plan with a foundation present, the 
Subfloor Height Above Terrain distance will 
equal the exact terrain elevation at the 
building footprint center point, plus 6” (150 
mm), plus the thickness of the floor platform.
• In a plan with no elevation data, the ter-

rain is assumed to be at sea level and this 
Subfloor Height Above Terrain distance 
is 6” (150 mm) plus the thickness of the 
floor platform plus any treated sill plates 
when a foundation is present. 

• In a plan with flat terrain at 100’ (30 m) 
and a foundation present, the Subfloor 

Terrain perimeter at 0' - 0" in a 3D view
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Height Above Terrain distance is 100’ 6” 
(30.468 m) plus the thickness of the floor 
platform.

Once terrain has been built, the Subfloor 
Height Above Terrain distance is stated in 
the Terrain Specification dialog. You can 
specify a custom value to produce a daylight 
or walkout basement. See “General Panel” 
on page 732. 

Build Terrain
Select Terrain> Build Terrain to 
generate the terrain surface based on 

the provided elevation data. Build Terrain 
also updates the Building Pad Elevation 
value in the Terrain Specification dialog. 
See “Building the Terrain” on page 730.

Auto Rebuild Terrain
By default, terrain will automatically build 
any time a 3D view is created, ensuring that 
the terrain in the view is up-to-date. If your 
terrain is large and/or highly detailed and has 
not been modified, and you find that this 
unnecessarily slows down the generation of 
3D views, consider turning this behavior off 
in the 3D View Defaults dialog. See “Options 
Panel” on page 893.

Clear Terrain
To remove the generated terrain 
contours, select Terrain> Clear 

Terrain. When the terrain is cleared, 
contours do not display in 3D and contour 
lines do not display in floor plan view.

Clear Terrain  does not remove the 
terrain perimeter, elevation data, or terrain 
features from the model. Rather it deletes all 
program-generated 2D contour lines and 3D 
contours.

The Terrain Perimeter has a variety of  
editable properties, including many that 
affect the appearance of the terrain in 2D and 
3D views.  See “Terrain Specification 
Dialog” on page 732.

Terrain Surface Triangles
Chief Architect generates 3D terrain surfaces 
by dividing them into triangles. The size of 
the triangles determines how detailed 
contour lines and terrain surfaces in the 3D 
model can be. You can specify triangle size 
in the Terrain Perimeter Specification 
dialog. See “General Panel” on page 732.

Increasing the triangle count decreases 
triangle size, yielding more detailed contour 
lines and a better 3D approximation of the 
terrain. Smaller triangles demand longer 
terrain generation time and increased 
memory requirements. If you select a large 
number of small triangles for a large site, you 
may wait a long time for the calculation. 

Decreasing the triangle count increases 
triangle size. Elevation lines are sampled less 
frequently, speeding up terrain generation. If 
you specify a small number of triangles for a 
plan with detailed elevation data, contour 
lines and 3D surfaces may not generate 
correctly. 

Note: When no foundation has been built, the
distance from Floor 1 to the terrain is 12” (320
mm). 

When a large terrain perimeter is used,
consider increasing the Triangle Count

to help make sure all Elevation Data and Ter-
rain Modifiers generate contours. 
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Elevation Data Tools
Select Terrain> Elevation Data to 
add elevation information to your 

terrain. 

When terrain is generated, this data is used to 
calculate the surface of your site and is 
represented by contour lines in floor plan 
view and a curved surface in 3D. See 
“Displaying Terrain” on page 729.

Elevation data can be specified using the 

Elevation Point , Elevation Line , 
Elevation Spline , Elevation Region 

, and Terrain Break  tools. 

Elevation data can also be imported. See 
“Importing Elevation Data” on page 747.

The elevation of each Elevation Line, Spline 
and Region is specified relative to sea level. 

In order to create rising and/or falling terrain, 
multiple terrain data objects with different 
elevation values must be used. If only one 
terrain data object is placed, the terrain will 
be flat regardless of the object’s specified 
elevation.

Elevation Points
An Elevation Point contains the 
absolute elevation data for one point 

in the terrain model. Typically, Elevation 
Points are imported rather than placed 
manually. 

Chief Architect requires many points to 
make an accurate approximation of your site. 
Even small sites may require over a hundred 
points to generate an accurate model of the 
terrain if it is sloped. For the sake of 
illustration, the following example shows 
only a few elevation points.

To place an elevation point

1. Select Terrain> Elevation Data> Ele-
vation Point  and click in floor plan 
view at the point where you would like 
to place elevation data. See “Place 
Point” on page 1077.

2. The Elevation Point Specification dia-
log opens. Enter an elevation value and 
click OK. See “Elevation Point Specifi-
cation Dialog” on page 736.

3. Click somewhere else in floor plan view 
and the Elevation Point Specification 
dialog opens again with the last eleva-
tion value entered. 

To avoid unexpected results, do not
draw Elevation Data objects - including

Terrain Breaks - with different elevation infor-
mation at the same location. 

Elevation Points before terrain generation
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4. Repeat steps 1, 2 and 3 to place addi-
tional elevation points with varied eleva-
tion values as needed.

5. Select Terrain> Build Terrain . See 
“Building the Terrain” on page 730.

Elevation Lines
An Elevation Line contains absolute 
elevation data for many points along a 

line at a constant elevation. Elevation lines 
can be connected to create a polyline with 
many straight sections. For the sake of 
illustration, the images in the following 
example show single-section elevation lines.

To draw an elevation line

1. Select Terrain> Elevation Data> Ele-
vation Line , then click and drag a 
line inside the Terrain Perimeter in floor 
plan view. 

2. Click on the elevation line to select it, 

then click the Open Object  edit but-
ton.

3. At first, an elevation line is at elevation 
0' - 0". In the Elevation Line 
Specification dialog, specify the desired 
elevation and click OK. See “Elevation 
Line/Region Specification Dialog” on 
page 737.

4. Repeat steps 2 and 3 to draw additional 
elevation lines as needed. 

5. Select Terrain> Build Terrain . See 
“Building the Terrain” on page 730.

Elevation Points are most effective
when they are imported. When adding

elevation data manually, use Elevation Lines
and Splines instead. See “Importing Elevation
Data” on page 747.

Contour lines after terrain generation

120"

0"

Elevation Lines before terrain generation

Contour lines after terrain generation
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After it is drawn, an Elevation Line can be 
edited much the way other line-based objects 
can. See “Editing Line Based Objects” on 
page 187. 

Elevation Splines
Elevation Splines can be used to form 
complex curves and shapes. Like 

elevation lines, elevation splines contain 
absolute elevation data for many points along 
a constant elevation.

To place an elevation spline, select Terrain> 

Elevation Data> Elevation Spline  and 
click and drag multiple sections in floor plan 
view.  See “Splines” on page 1106.

Elevation splines are initially placed at 
elevation 0' - 0"and must be opened and 
assigned an elevation. See “Elevation Line/
Region Specification Dialog” on page 737.

After it is drawn, an Elevation Spline can be 
edited much the way other spline-based 
objects can. See “Editing Spline Based 
Objects” on page 209.

Elevation Regions
An Elevation Region contains 
absolute elevation data for an 

enclosed region and is ideal for creating a flat 
surface in your terrain. 

Elevation Regions are similar to Flat Regions 
in that they produce an area with a flat 
surface; however, they differ in that an 

Full Overview after terrain generation

Elevation splines before terrain generation

60"

36"

0"

Contour lines after terrain generation
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Elevation Region affects the contours of the 
terrain outside of its perimeter and may also 
have some sloping within its perimeter. See 
“Flat Regions” on page 724.

To create an elevation region

1. Select Terrain> Elevation Data> Ele-
vation Region . 

2. There are two ways to add a Terrain 
Modifier to your plan: 

•  Click once to place an 8’ (0.6 m) 
square feature at that location.

•  Click and drag from end to end to draw 
a feature sized as needed. See “Rectan-
gular Polyline” on page 1101.

3. Click on the region to select it, then click 

the Open Object  edit button.
4. At first, an elevation line is at elevation 

0' - 0". In the Elevation Region 
Specification dialog, specify the desired 
elevation and click OK. See “Elevation 
Line/Region Specification Dialog” on 
page 737.

An Elevation Region  can also be created 
by drawing a closed polyline using Eleva-
tion Lines . 

After it is drawn, and Elevation Region can 
be reshaped much the way other closed 
polyline-based objects can. See “Editing 
Closed-Polyline Based Objects” on page 
201.

Terrain Breaks
A Terrain Break creates a division 
along the terrain surface that affects 

terrain generation. Elevation data on one side 
of the terrain break does not affect the terrain 
generation on the other side, allowing you to 
create immediate drops in terrain.

240"

0"

120"

Elevation lines create a terrain grade; an 
elevation region creates a building pad.

Contour lines after terrain generation

Full Overview after terrain generation
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To place a Terrain Break, select Terrain> 
Elevation Data> Terrain Break  and 
click and drag a line in floor plan view. 
• If the Terrain Break divides the terrain 

perimeter into two separate pieces, the 
terrain data on either side is calculated 
independently and smoothed separately, 
resulting in sharp terrain contours. 

• If the Terrain Break does not extend com-
pletely from one side of the terrain perim-
eter to the other, the areas near each end 
of the Terrain Break are blended. 

The Retaining Wall  tool creates a 
similar effect by drawing a Terrain Break as 
well as a retaining wall that rests against the 
break. By default, the top height of the 
retaining wall matches the terrain on the high 
side of the break and the bottom matches the 
low side. See “Retaining Walls” on page 728.

Terrain Modifier Tools
Select Terrain> Modifier to access 
tools that allow you to modify the 

existing elevation data by drawing a closed 
polyline. Their height is relative to the terrain 
surface generated from the Elevation Data 
provided in your plan. 

The elevation data associated with a Terrain 
Modifier only affects the terrain within its 
perimeter. The rest of the terrain is 
unaffected. 

240"

0"

120"

A Terrain Break (dashed line) 
creates a vertical drop.

84"
18"

Contour lines after terrain generation

Full Overview after terrain generation
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Raised and Lowered Regions
The Raised Region tool creates a 
raised area with a top surface that 

is flattened like a plateau but follows the 
surface of the terrain. The Lowered Region 
tool creates a depression with a bottom that 
follows the terrain and is flattened. 

Hills and Valleys
The Hill and Valley tools create 
raised and lowered areas in the 

terrain that come to a point rather than  
flattening at their highest or lowest 
elevations. 

Flat Regions
The Flat Region tool creates an area 
with a surface that is flattened like a 

plateau but is level rather than following the 
contours of the terrain. 

There are two ways to add a Terrain Modifier 
to your plan: 
• Click once to place a modifier with end-

points that form a 10’ (4 m) square at that 
location. 

• Click and drag from end to end to draw a 
feature sized as needed. See “Rectangular 
Polyline” on page 1101.

Terrain Modifiers can only be drawn when a 
Terrain Perimeter is present, and will only 
display in 3D when they are drawn within the 
perimeter. See “Displaying Terrain” on page 
729.

Once created, Terrain Modifiers can be 
selected and edited in a variety of ways. See 
“Editing Spline Based Objects” on page 209. 

Terrain Feature Tools
Select Terrain> Feature to access 
tools for drawing bounded areas that 

follow the contours of the terrain rather than 
modifying them. 

Terrain Features are useful for creating 
landscaping features because they have 
specified heights and materials. You can, for 
example, create paths and planting beds with 

Lowered 
Region

Raised 
Region

Valley
Hill

Terrain modifiers can be blocked with
images and stored in the library for

future use. See “Creating Architectural
Blocks” on page 812.

Flat Region

Raised 
RegionLowered 

Region
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gravel or mulch materials that stand out in a 
grassy Terrain Perimeter. See “Adding 
Terrain Features” on page 166 of the User’s 
Guide. 

In fact, Garden Beds , Water Features 

 and Stepping Stones  are special 
Terrain Features with material and height 
attributes already applied to them, saving 
you time when drawing these objects.

Terrain Features can only be drawn when a 
Terrain Perimeter is present, and will only 
display in 3D when they are drawn within the 
perimeter. See “Displaying Terrain” on page 
729.

Terrain Features can be created in either of 
two ways: 
• Click once to place a feature with end-

points that form a 10’ (4 m) square at that 
location. 

• Click and drag from end to end to draw a 
feature sized as needed. See “Rectangular 
Polyline” on page 1101.

Once created, Terrain Features can be edited 
into nearly any shape you require. See “Edit-
ing Closed-Polyline Based Objects” on page 
201 and “Editing Spline Based Objects” on 
page 209.

Rectangular Features
The Rectangular Feature tool can be 
used to create straight-sided features 

that can be edited into a wide variety of 
shapes. 

Rectangular Features can also be edited like 
other closed polyline-based objects. See 
“Editing Closed-Polyline Based Objects” on 
page 201.

Spline Feature
The Spline Feature tool can be used 
to create features with rounded edges 

and smoothly curved corners. 

Spline Features can be edited like other 
closed spline-based objects. See “Editing 
Spline Based Objects” on page 209.

Kidney Shaped Features
The Kidney Shaped Feature tool 
allows you to quickly create features 

with curved edges, smooth corners and a 
right angle bend in its shape.

Kidney Shaped Features can be edited like 
other closed spline-based objects. See “Edit-
ing Spline Based Objects” on page 209.

Terrain features can also be converted from 
closed 2D polylines or splines using the 

Convert Polyline  edit tool. See “Convert 
Polyline” on page 239. 

For information about adding height and 
material information to Terrain Features, see 
“Terrain Feature Specification Dialog” on 
page 741.

Terrain Holes
A Terrain Hole is a region that cuts a 
hole in the terrain. Using this tool is 

the same as creating a Terrain Feature and 
checking Make Hole in the Terrain Feature 
Specification dialog. See “Terrain Feature 
Specification Dialog” on page 741.

Terrain Features can be drawn in 2D
and 3D views. 
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Terrain Holes  are useful for manually 
clipping the terrain around a foundation that 
does not match the footprint of the first floor.

Garden Bed Tools
Select Terrain> Garden Bed to 
access tools that can be used to place 

garden bed features in your terrain. 

Garden Beds are basically Terrain Features 
with material and height attributes typical of 
planting beds. See “Terrain Feature Tools” 
on page 724.

In addition, you can choose to distribute 
copies of a plant image within a Garden Bed. 
See “Distributed Plant Panel” on page 742.

Polyline Garden Bed
This tool draws a garden bed with 
straight sides and four right angles. 

See “Rectangular Features” on page 725.

Round Garden Bed
Use this tool to draw garden beds with 
rounded edges and smoothly curved 

corners. See “Spline Feature” on page 725. 

Kidney Shaped Garden Bed
You can draw a kidney shaped garden 
bed with this tool. See “Kidney 

Shaped Features” on page 725.

Once drawn, Garden Beds can be selected 
and edited just like other Terrain Features. 

Specify the material and set the height of 
Garden Beds in the Terrain Feature 
Specification dialog.  See “Terrain Feature 
Specification Dialog” on page 741. 

Water Feature Tools
Select Terrain> Water Feature to 
access tools for drawing ponds and 

streams in your terrain.

Ponds are basically Terrain Features with 
material and height attributes typical of 
bodies of water. See “Terrain Feature Tools” 
on page 724.

Similarly, Streams are Terrain Curbs with a 
water material. See “Terrain Wall and Curb 
Tools” on page 727. 

Round Pond
Use this tool to draw a pond with 
rounded edges. See “Spline Feature” 

on page 725. 

Kidney Shaped Pond
This tool draws a kidney shaped pond. 
See “Kidney Shaped Features” on 

page 725.

Terrain features can be blocked with
images and stored in the library for

future use as planting beds. See “Creating
Architectural Blocks” on page 812.
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Stream
Select the Stream tool, then click and 
drag to draw a stream. Streams are 

drawn and edited the same way that splines 
are. See “Splines” on page 1106 and “Editing 
Spline Based Objects” on page 209.

Click the Advanced Splines  edit button 
to activate additional edit handles that you 
can use to reshape the stream.  See 
“Advanced Splines” on page 213. 

Streams follow the contours of the terrain, so 
they may appear to flow uphill if they are not 
drawn correctly in the terrain. Try to draw 
them so that they follow a downward course 
for their entire length.

Once drawn, Water Features can be selected 
and edited just like any other Terrain Feature. 

Specify the material and set the height of 
Water Features in their specification dialogs.  
See “Terrain Feature Specification Dialog” 
on page 741 and “Terrain Path Specification 
Dialog” on page 745.  

Stepping Stone Tools
Select Terrain> Stepping Stone to 
place a walkway made of individual 

stepping stones. 

Stepping Stones are basically Terrain 
Features with material and height attributes 
typical of walking paths. See “Terrain 
Feature Tools” on page 724.

There are two ways to draw Stepping Stones: 
• Click once to place a stepping stone with 

endpoints that form a 1’ (300 mm) square 
at that location. 

• Click and drag from end to end to draw a 
stepping stone sized as needed. See 
“Rectangular Polyline” on page 1101.

Polyline Stepping Stone
The Polyline Stepping Stone tool 
draws rectangular stepping stones. See 

“Rectangular Features” on page 725. 

Round Stepping Stone
The Round Stepping Stone tool 
draws stepping stones with rounded 

edges. See “Spline Feature” on page 725.

Once drawn, Stepping Stones can be selected 
and edited just like any other Terrain Feature. 

By default, Stepping Stones have a concrete 
material; however, you can specify the 
material and set the height of Stepping 
Stones in the Terrain Feature Specification 
dialog.  See “Terrain Feature Specification 
Dialog” on page 741. 

Terrain Wall and Curb Tools
Select Terrain> Terrain Wall and 
Curb to draw landscaping walls and 

curbs that follow the contours of the terrain. 
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Straight and curved Terrain Walls and Curbs 
are drawn just as other walls are. See 
“Drawing Walls” on page 276.

Terrain Walls and Curbs are examples of 
Terrain Paths. Other examples include 
Sidewalks and Streams. See “Terrain Path 
Specification Dialog” on page 745.

Terrain Walls
Use the Straight Terrain Wall tool to 
draw a wall that sits on top of and 

follows the terrain. 

Use the Spline Terrain Wall to draw 
a curved terrain wall. This wall is 

drawn the same way as a CAD Spline. See 
“Splines” on page 1106.

Once drawn, a Terrain Wall can be like other 
line-based objects. See “Editing Line Based 
Objects” on page 187 and “Editing Spline 
Based Objects” on page 209.

Terrain walls are 5’ (1500 mm) high and con-
crete by default, but you can specify the 
material, height and more in the Terrain Path 
Specification. See “Terrain Path 
Specification Dialog” on page 745. 

Retaining Walls
The Retaining Wall tools function similarly 
to Terrain Breaks, but include a wall. See 
“Terrain Breaks” on page 722.

Use the Straight Retaining Wall tool 
draws a straight wall that holds back 

sloped terrain.

Use the Curved Retaining Wall tool 
to draw a curved retaining wall. 

A Retaining Wall’s height is determined by 
the elevation of the terrain on each side. By 
default, the height of the wall matches the 
terrain on the high side of the break and the 
bottom matches the low side. If you insert a 
Retaining Wall into flat terrain, it looks like a 
concrete strip in 3D views.

Once drawn, a Retaining Wall can be edited 
much like other walls. See “Editing Walls” 
on page 285.

Terrain Curbs
Terrain Curbs are useful for creating curbs 
around planting beds and along paths.

Use the Straight Terrain Curb tool 
to draw a straight landscaping curb.

 Use the Spline Terrain Curb tool to 
draw a curved landscaping curb. This 

curb is drawn the same way as a CAD 
Spline. See “Splines” on page 1106. 

Once drawn, a Terrain Curb can be like other 
line-based objects. See “Editing Line Based 
Objects” on page 187 and “Editing Spline 
Based Objects” on page 209.

You can specify the height of straight and 
spline terrain curbs on the GENERAL panel of 
the Terrain Path Specification. See “Terrain 
Path Specification Dialog” on page 745. 

You can also add Fencing to your ter-
rain, complete with gates from the

Doors Library. See “Fencing Tools” on page
268. 
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Sun Shadows
Sun shadows are generated by the program 
and represent shadows cast at a particular 
location on the Earth and at a specific date 
and time. See “Sun Angles and Shadows” on 
page 943. 

Sun shadows are computed based on the 
contour of the terrain. If a terrain perimeter 
exists, the sun shadow adjusts to the terrain.

A sun shadow is automatically rebuilt 
whenever terrain is rebuilt. If you generate a 
sun Shadow and the terrain is not up-to-date, 
the terrain automatically rebuilds. You can 
turn off the automatic rebuild. See “Sun 
Angle Specification Dialog” on page 946.

Terrain Objects in the Library
The Library Browser contains a 
variety of objects that can be placed in 

a plan’s terrain, including plants, exterior 

fixtures, accessories and roadway objects. 
See “The Library Browser” on page 820. 

Displaying Terrain
The display of terrain objects in 2D 
and 3D views is controlled in the 

Layer Display Options dialog. See “Layer 
Display Options Dialog” on page 149.

You can customize appearance of Terrain 
Features, Roads and other terrain objects in 
floor plan view by changing their line and fill 
styles.  

Plant images are represented in floor plan 
view by 2D CAD symbols. You can select a 
plant’s symbol in the Plant Image 
Specification dialog. See “Image Panel” on 
page 771. 

Contour Lines
When elevation data has been drawn or 
imported into a plan, contour lines will 

display in floor plan view. See “Elevation 
Data Tools” on page 719.

Chief Architect can produce both primary 
and secondary contours. They are on two 
different layers so you can control their 
display separately. Contour line labels use 
the Text Styles assigned to the “Terrain, 
Primary Contours” and “Terrain, Secondary 
Contours” layers. 

By default, all contour lines are set to be 
primary, but you can specify secondary 
contours, frequency and other attributes of 
contour lines in the Terrain Specification 
dialog.  See “Contours Panel” on page 733. 

Terrain and Road Labels
Labels for terrain objects - including the 
Terrain Perimeter, most Elevation Data 
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objects, Terrain Features, Terrain Modifiers, 
Terrain Paths, and Roads - display in floor 
plan view when the “Terrain Labels” layer is 
turned on. Labels for all but Elevation Data, 
Terrain Modifiers, and Road Markings can 
display in cross section/elevation views, as 
well. See “Object Labels” on page 1279.

The Automatic Labels for terrain objects are 
blank; however, you can specify a custom 
label using text in their specification dialogs. 

In 3D Views
In order for objects such as Terrain Features 
and Roads to be visible in 3D views, they 
must be drawn within the Terrain Perimeter. 
Any portions of these objects drawn outside 
of the Terrain Perimeter will not be seen in 
3D views. See “Terrain Feature Tools” on 
page 724.

A variety of tools are available to help you 
adjust the perspective of your 3D views. See 
“Editing 3D Views” on page 916.

Building the Terrain
When terrain is generated, Chief 
Architect gathers all elevation data 

that has been added to the model and creates 
a terrain surface. The program interpolates 
the data to produce smooth contours. 

A terrain perimeter with no additional 
elevation data drawn within it generates 
terrain that is flat at the elevation 0' - 0", or 
sea level. 

By default, the terrain is automatically built 
before a 3D view is generated and when a 

sun shadow is created. This process takes a 
variable amount of time, depending on the 
amount of elevation data and number of 
terrain features in the plan. The Building 
Terrain progress dialog displays as terrain is 
generated, sometimes only briefly, indicating 
the progress.

You can turn off Auto Rebuild Terrain in 
the 3D View Defaults dialog for 3D views 
and in the Sun Angle Specification dialog 
for sun shadows, and rebuild the terrain 
manually only when needed by selecting 

Terrain> Build Terrain . When Auto 
Rebuild Terrain is turned off and the terrain 
is not up to date, the Rebuild Terrain  icon 
displays near your mouse pointer. See 
“Options Panel” on page 893 and “Earth 
Data Panel” on page 946.

Terrain and 3D Drawing Time
Terrain is typically large with many surface 
triangles, which often increases the drawing 
time of 3D views. The time required is 
affected by the quality of the terrain, the 
amount of elevation data and number of 
terrain features present. For information 
about surface triangles and how they 
influence terrain quality, see “General Panel” 
on page 732. 

Lights and symbols can be placed outdoors 
and included in 3D views when the terrain is 
generated. These objects can also contribute 
to the time needed to generate 3D views. See 
“Rendering Tips” on page 934.



Editing Terrain Objects

 731

Editing Terrain Objects
Before a terrain object can be edited, it must 
be selected. All terrain objects can be 
selected in floor plan view. In addition, the 
Terrain Perimeter and Terrain Features can 
be selected in 3D views. See “Selecting 
Objects” on page 183. 

A selected terrain object can be edited using 
its edit handles, edit tools and specification 
dialog. See “Specification Dialogs” on page 
41.

Any time elevation data is changed, the 
terrain must be regenerated. This occurs 
automatically when a 3D view is created. It 
can also be done manually by selecting 

Terrain> Build Terrain .

Using the Edit Handles
• The shape of the Terrain Perimeter can be 

edited like other polyline-based objects. 
See “Editing Closed-Polyline Based 
Objects” on page 201. 

• Elevation Points can be moved in floor 
plan view using the Move edit handle.

• Elevation Lines, Elevation Splines and 
Terrain Breaks are edited like other line- 
and spline-based objects. See “Editing 
Line Based Objects” on page 187, “Edit-
ing Closed-Polyline Based Objects” on 
page 201, and “Editing Spline Based 
Objects” on page 209. 

• The shape of a Raised Region, Lowered 
Region, Hill, Valley, and Flat Region 
can be edited like a spline. See “Editing 
Spline Based Objects” on page 209.

• Terrain Features are edited like other 
spline- and polyline-based objects. See 

“Editing Closed-Polyline Based Objects” 
on page 201 and “Editing Spline Based 
Objects” on page 209.

Using the Edit Tools
A selected terrain object can be edited in a 
variety of ways using the buttons on the edit 
toolbar. The edit tools available for a terrain 
object depends on the type of terrain object 
selected. See “The Edit Toolbar” on page 37.

Moving Terrain Objects 
Using Dimensions

If dimensions display when a terrain object is 
selected, the object can be moved using the 
them. For more information see “Moving 
Objects Using Dimensions” on page 1019.

Plot Plans and 
Plan Footprints

There are two different ways to create a plot 
plan in Chief Architect: 
• In floor plan view using the Terrain and 

CAD Tools. 
• In a CAD Detail using the Plan Foot-

print  tool and other CAD Tools. 

Each method has its advantages. For more 
information, see “Creating a Plot Plan” on 
page 190 of the User’s Guide. 

Note: If you copy terrain objects from one
plan to another, you cannot view the pasted
objects in 3D unless a Terrain Perimeter
exists. 
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Terrain Specification Dialog
The Terrain Specification dialog 
controls how your terrain is modeled, 

as well as its appearance.

The Terrain Specification dialog can be 
accessed in any of three ways:

• Select Terrain> Terrain 
Specification .

• Select the Terrain Perimeter and click the 

Open Object  edit button.
• Double-click the Terrain Perimeter using 

the Select Objects  tool. 

General Panel

Specify how the Building Pad is 
generated beneath the structure. See 

“Foundations and the Terrain” on page 461. 

• To specify the distance between Floor 1 
and the terrain at the building footprint 
center, uncheck Automatic and enter a 

1
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value in the Subfloor Height Above Ter-
rain field.

• Check Automatic to have Chief Architect 
automatically lower the terrain relative to 
the first floor. See “Terrain Height vs 
Floor Height” on page 717.

• Check Flatten Pad to flatten the area 
beneath the building. To create a walkout 
basement, uncheck this box.

Define the thickness of the Skirt added 
to the terrain. The skirt is only visible in 

3D views and gives the viewer a sense of 
depth when viewing the terrain. 
• Flat specifies that the skirt be flat at its 

base. Chief Architect determines the low-
est point in the terrain and then offsets 
this value by the user specified thickness 
value. The resulting value is used as a uni-
form elevation for the base of the skirt. 

• Follow Terrain specifies that the skirt 
base maintains a consistent distance 
below the terrain. The distance is equiva-
lent to the specified Thickness value.

 Terrain Surface Smoothing - Control 
the amount of rounding applied to 

terrain edges. A low value for smoothing 
produces terrain that has sharp peaks and 
abrupt changes in slope. A high value results 
in terrain that continuously flows from point 
to point. 

Triangle Count - Specify the number 
of surface triangles used to generate the 

terrain in 3D views. A lower count value will 

generate more quickly but with reduced 
quality.
• Custom - Specify a custom triangle count 

value. 
• Triangle Size - Specify the maximum tri-

angle size in the terrain surface. Smaller 
triangles produce better quality results in 
3D but take longer to generate.

Chief Architect builds 3D terrain surfaces by 
splitting them into triangles. See “Terrain 
Surface Triangles” on page 718.

Triangles are computed roughly as follows:

Size of Triangle = Area of Terrain Perimeter / 
Number of Triangles

The Low (1000), Medium (2000), and High 
(4000) values work well for a terrain 
perimeter of approximately 20,000 sq ft 
(1858 m²). If your terrain perimeter varies 
greatly from this, consider defining the 
number of triangles using the Custom setting 
or the Triangle Size setting. 

Clipping - Check Hide Terrain 
Intersected by Building to cut out the 

portion of the terrain that is intersected by the 
first floor footprint. Checking this box 
prevents the generation of contour lines 
inside the house. 

If your foundation footprint differs from your 
first floor footprint, you may need to use the 

Terrain Hole  tool for custom clipping 
instead. See “Terrain Feature Tools” on page 
724.

Contours Panel
Chief Architect identifies two types of 
contour lines: Primary and Secondary. They 
are drawn on different layers, so you can 

control how they display in floor plan view. 
See “Contour Lines” on page 729.

2

3

4

5
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Specify the Frequency at which 
contour lines are generated.

• Define the Interval between contour 
lines, which is the change in elevation 
between contours. If the interval is set to 
12”, a contour line is computed for each 
elevation change of 12”.

• Specify the Offset value. When the Offset 
is 0, a contour line will be drawn at zero 
elevation and additional contours will 
generate based on the Interval value. If 
the Offset is changed to 5, a contour line 
will be drawn 5 units from zero elevation 
rather than at 0, and additional contours 
will generate from there.

• Primary contour every__contours - 
Specify the interval for primary contours. 
A value of 1 produces only primary con-
tours, while a value of 5 defines every 
fifth contour line as a primary contour.

If contour Smoothing is turned on, 
Chief Architect attempts to remove 

sharp bends and jagged sections from the 2D 
contour lines.
• Specify the number of Passes to perform 

when smoothing. The more passes, the 
smoother the contour lines become, but 
contours become less accurate.

Control the display of Contour Labels 
in floor plan view. 

• Check Label Primary Contours to label 
primary contour lines with their elevation 
data using the Units specified below. 

• Check Label Secondary Contours to 
label secondary contour lines with their 
elevation data. 

• Check Highlight Negative Elevations to 
display labels of contour lines with eleva-
tions below 0 in red. When unchecked, 

1 2

3
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they use the color set in the Text Style 
assigned to their layer. 

Specify the Label Units used by 
contour labels. Select either Inches or 

Decimal Feet (Millimeters or Meters for 
metric).

Polyline Panel
The POLYLINE panel states the length of the 
Terrain Perimeter’s Perimeter, its enclosed 
Area, and its Volume. 

The settings on the this panel are available 
for a variety of other objects in the program. 
For information about these settings, see 
“Polyline Panel” on page 1098.

Spline Panel
The SPLINE panel has a single option and is 
only available if the Terrain Perimeter has 
been converted to a spline.  See “Convert to 
Spline” on page 234.

New Segment Angle - Specify the angle 
between line segments that are used to draw 
the spline. Specifying a smaller angle makes 
the spline’s curvature smoother. Specify a 
larger angle to draw the spline faster.

Selected Line Panel
The SELECTED LINE panel is available when 
the selected edge of the Terrain Perimeter is a 

line as opposed to an arc. See “Selected 
Edge” on page 184.

The settings on this panel are available for a 
variety of other objects in the program. For 
information about these settings, see “Line 
Panel” on page 1084.

Selected Arc Panel
The SELECTED ARC panel is available when 
the selected segment of the polyline is an arc 
as opposed to a line. See “Change Line/Arc” 
on page 232.

The settings on this panel are available for a 
variety of other objects in the program. For 
information about these settings, see “Arc 
Panel” on page 1093.

Line Style Panel
The settings on the LINE STYLE panel are 
available for a variety of other objects in the 
program. For information about these 
settings, see “Line Style Panel” on page 
1085.

Fill Style Panel
The settings on the FILL STYLE panel affect 
the appearance of the Terrain Perimeter in 
floor plan view. For information about these 
settings, see “Fill Style Panel” on page 1099.

Materials Panel
The settings on the MATERIALS panel let you 
specify the terrain surface and terrain skirt 
materials used in 3D views. These materials 
are not calculated in the Materials List. See 
“Materials Panel” on page 852.

Primary and secondary contour line
labels use the Text Style assigned to

their respective layers. See “Text Styles” on
page 1061.

4
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Label Panel
The Terrain Perimeter label displays in floor 
plan and cross section/elevation views when 
the “Terrain Labels” layer is turned on and 

use the Text Style assigned to that layer. See 
“Terrain and Road Labels” on page 729.

For more information, see “Label Panel” on 
page 1280.

Elevation Point Specification Dialog
To open the Elevation Point 
Specification dialog, select an eleva-

tion point and click the Open Object edit 
button, or double-click on an Elevation Point 

using the Select Objects  tool.

Use the Elevation Point Specification 
dialog to define the selected elevation point 
and control its appearance in floor plan view. 

General Panel

Location - Specify the exact location of 
the elevation point.

• Specify the Elevation of the selected Ele-
vation Point. 

• X Coordinate - Enter the x coordinate of 
the elevation point.

• Y Coordinate - Enter the y coordinate of 
the elevation point.

Display -  

• In the Text field, type any notes that you 
would like to display beside the selected 
Elevation Point in floor plan view. You 
can also enter a pound (#) sign to display 
the point’s elevation value. 

Click the Number Style button to specify
the units of measurement used in this

and other dialogs. See “Dialog Number/Angle
Style Dialog” on page 127. 

1

2
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• Enter the Marker Radius , which is size 
of the point marker, measured from the 
center to an edge. 

Line Style Panel
The settings on the LINE STYLE panel are 
available for a variety of other objects in the 
program. For information about these 

settings, see “Line Style Panel” on page 
1085.

Text Style Panel
The settings on the TEXT STYLE panel control 
the appearance of the selected Elevation 
Point’s text. For more information, see “Text 
Style Panel” on page 1063. 

Elevation Line/Region Specification Dialog
To open the Elevation Line or 
Elevation Region Specification dia-

log, select one or more Elevation Line/
Splines, or a polyline composed of elevation 
Lines/Splines, or an Elevation Region and 
click the Open Object edit button. You can 
also double-click an Elevation Line/Spline 

using the Select Objects  tool.

The Elevation Line Specification dialog is 
used to define the selected Elevation Line/

Spline and controls its appearance in floor 
plan view. 

The settings in this dialog are the same as 
those in the Elevation Region Specification 
dialog. See “Elevation Regions” on page 
721. 

Elevation Panel

• Specify the Elevation of the selected Ele-
vation Line, Spline, or Polyline. Click the Number Style button to specify

the units of measurement used in this
and other dialogs. See “Dialog Number/Angle
Style Dialog” on page 127. 
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• Check Interior is Flat to maintain a flat 
surface at the specified Elevation. When 
unchecked, the perimeter of the region 
maintains the specified Elevation, but the 
interior elevation may vary depending on 
other elevation data in the drawing. Only 
available for closed Elevation Regions.

• Check Interpolate Tangent to Edge to 
flatten the terrain surface as it approaches 
the edges of the Elevation Region. This 
option is only available for closed Eleva-
tion Regions, and only when Interior is 
Flat is unchecked. 

Polyline Panel
The POLYLINE panel states the Length of an 
open polyline or the Perimeter of a closed 
polyline. If multiple Elevation Line/Spline 
segments form a closed Elevation Region, its 
Area will be calculated. Elevation Lines/
Splines do not have a thickness, so they have 
no Volume. 

Spline Panel
The SPLINE panel has a single option and is 
only available when the selected object is an 
elevation spline. See “Splines” on page 1106.

New Segment Angle - Specify the angle 
between line segments that are used to draw 
the spline. Specifying a smaller angle makes 
the spline smoother. Specify a larger angle to 
draw the spline faster.

Selected Line Panel
The SELECTED LINE panel is available when 
the selected object or segment is a line as 
opposed to one that has been converted to an 
arc. See “Selected Edge” on page 184.

The settings on this panel are available for a 
variety of other objects in the program. For 
information about these settings, see “Line 
Panel” on page 1084.

Selected Arc Panel
The SELECTED ARC panel is available when 
the selected object or segment is an arc as 
opposed to a line.

The settings on this panel are available for a 
variety of other objects in the program. For 
information about these settings, see “Arc 
Panel” on page 1093.

Line Style Panel
The settings on the LINE STYLE panel are 
available for a variety of other objects in the 
program. For information about these 
settings, see “Line Style Panel” on page 
1085.

Label Panel
Elevation Line, Polyline, and Region labels 
displays in floor plan view when the “Terrain 
Labels” layer is turned on and use the Text 
Style assigned to that layer. See “Terrain and 
Road Labels” on page 729.

For more information, see “Label Panel” on 
page 1280.



Flat Region Specification Dialog

 739

Flat Region Specification Dialog
To open the Flat Region 
Specification dialog, select a Flat 

Region and click the Open Object edit 
button, or double-click a Flat Region using 

the Select Objects  tool. See “Flat 
Regions” on page 724. 

The options in the Flat Region Specification 
dialog are similar to those a number of other 
dialogs in the program.

Polyline Panel
The POLYLINE panel states the length of the 
region’s Perimeter and its enclosed Area. 
Flat Regions do not have a Volume 
measurement. See “Polyline Panel” on page 
1098. 

Spline Panel
The SPLINE panel has a single option and is 
only available when the selected object is a 
spline.  See “Splines” on page 1106.

New Segment Angle - Specify the angle 
between line segments that are used to draw 
the spline. Specifying a smaller angle makes 
the spline smoother. Specify a larger angle to 
draw the spline faster.

Selected Line Panel
The SELECTED LINE panel is available when 
the selected edge of the polyline is a line as 

opposed to an arc. See “Selected Edge” on 
page 184.

Moving the Start of a line segment moves the 
end of the previous connected line, if there is 
one. Similarly, moving the End of a line 
segment moves move the start of the next 
connected line, if there is one. 

The settings on this panel are available for a 
variety of objects in the program. For 
information about these settings, see “Line 
Panel” on page 1084.

Selected Arc Panel
The SELECTED ARC panel is available when 
the selected segment of the polyline is an arc 
as opposed to a line.  See “Change Line/Arc” 
on page 232.

The settings on this panel are available for a 
variety of objects in the program. For 
information about these settings, see “Arc 
Panel” on page 1093.

Line Style Panel
The settings on the LINE STYLE panel are 
available for a variety of objects in the 
program. For information about these 
settings, see “Line Style Panel” on page 
1085.

Fill Style Panel
The settings on the FILL STYLE panel affect 
the appearance of the selected object in floor 
plan view. For information about these 
settings, see “Fill Style Panel” on page 1099.
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Label Panel
Labels for Flat Regions display in floor plan 
view when the “Terrain Labels” layer is 
turned on and use the Text Style assigned to 

that layer. See “Terrain and Road Labels” on 
page 729.

For more information, see “Label Panel” on 
page 1280.

Hill / Valley Specification Dialog
The Hill/Valley Specification defines 
the selected Hill or Valley and 

controls its appearance in floor plan view. 

To open the Hill/Valley Specification dialog, 
select one or more Hill or Valley and click 
the Open Object edit button, or double-click 

the region(s) using the Select Objects  
tool.

Hill / Valley Panel

• Enter a Height for the selected Hill or 
Valley. This height is relative to the ter-
rain surface that is generated from the 
Elevation Data in your plan. See “Terrain 
Modifier Tools” on page 723.

Polyline Panel
The POLYLINE panel states the length of the 
hill or valley’s Perimeter and its enclosed 
Area. Hills and Valleys do not have a volume 
measurement. 

Spline Panel
The SPLINE panel has a single option and is 
only available when the selected object is a 
spline.  See “Splines” on page 1106.

New Segment Angle - Specify the angle 
between line segments that are used to draw 
the spline. Specifying a smaller angle makes 
the spline smoother. Specify a larger angle to 
draw the spline faster.

Selected Line Panel
The SELECTED LINE panel is available when 
the selected edge of the polyline is a line as 
opposed to an arc. See “Selected Edge” on 
page 184.

Moving the Start of a line segment moves the 
end of the previous connected line, if there is 
one. Similarly, moving the End of a line 
segment moves move the start of the next 
connected line, if there is one. 

This panel is similar to the LINE panel of the 
Line Specification dialog. See “Line Panel” 
on page 1084.

Selected Arc Panel
The SELECTED ARC panel is available when 
the selected segment of the polyline is an arc 
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as opposed to a line. See “Change Line/Arc” 
on page 232.

This panel is similar to the ARC panel of the 
Arc Specification dialog. See “Arc Panel” 
on page 1093.

Line Style Panel
The settings on the LINE STYLE panel are 
available for a variety of other objects in the 
program. For information about these 
settings, see “Line Style Panel” on page 
1085.

Fill Style Panel
The settings on the FILL STYLE panel affect 
the appearance of the selected object in floor 
plan view. For information about these 
settings, see “Fill Style Panel” on page 1099.

Label Panel
Hill and Valley labels display in floor plan 
view when the “Terrain Labels” layer is 
turned on and use the Text Style assigned to 
that layer. See “Terrain and Road Labels” on 
page 729.

For more information, see “Label Panel” on 
page 1280.

Raised / Lowered Region Specification Dialog
To open the Raised/Lowered Region 
Specification dialog, select one or 

more raised or lowered regions and click the 
Open Object edit button, or double-click the 

region(s) using the Select Objects  tool.

The Raised / Lowered Region 
Specification dialog is similar to the Hill / 
Valley Specification dialog. See “Hill / 
Valley Specification Dialog” on page 740.

Terrain Feature Specification Dialog
To open the Terrain Feature 
Specification dialog, select a Terrain 

Feature or group of Terrain Features and 
click the Open Object edit button, or dou-
ble-click the Terrain Feature(s) using the 

Select Objects  tool.

Most of the panels in this dialog are similar 
to those for a variety of other objects in the 

program, including Water Features and 
Stepping Stones.

Garden Beds are also a type of Terrain 
Feature and have an additional Distributed 
Plant panel in their specification dialog. 
Garden Beds also have a preview pane on the 
right side of their specification dialog. 
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General Panel

• Specify the top Height of the Terrain Fea-
ture, relative to the terrain surface, using a 
positive or negative number. 

• Specify the feature’s Thickness.

If a feature’s height above the terrain is 
greater than its thickness, the program will 
fill in the resulting gap.
• Check Make Hole to specify the selected 

Terrain Feature as a Terrain Hole. See 
“Terrain Holes” on page 725.

• Check Clip Overlapping Terrain Fea-
tures to suppress the 3D display of any 
part of the selected Terrain Feature inter-
sected by other Terrain Features with a 
lower Height value. Clipping is useful for 
creating features that contain other fea-
tures such as planters or swimming pools.

Distributed Plant Panel
This panel is only available when the 
selected Terrain Feature is a Garden Bed. For 
information, see “Distributed Object Panel - 
Distribution Region” on page 806.

Polyline Panel
The POLYLINE panel states the length of the 
garden bed’s Perimeter, its enclosed Area, 
and its Volume. See “Polyline Panel” on 
page 1098. 

Spline Panel
The SPLINE panel has a single option and is 
only available when the selected object is a 
spline.  See “Splines” on page 1106.

New Segment Angle - Specify the angle 
between line segments that are used to draw 
the spline. Specifying a smaller angle makes 
the spline smoother. Specify a larger angle to 
draw the spline faster. 

Selected Line Panel
The SELECTED LINE panel is available when 
the selected edge of the polyline is a line as 
opposed to an arc. See “Selected Edge” on 
page 184.

The settings on this panel are available for a 
variety of other objects in the program. For 
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information about these settings, see “Line 
Panel” on page 1084.

Selected Arc Panel
The SELECTED ARC panel is available when 
the selected segment of the polyline is an arc 
as opposed to a line. See “Change Line/Arc” 
on page 232.

The settings on this panel are available for a 
variety of other objects in the program. For 
information about these settings, see “Arc 
Panel” on page 1093.

Line Style Panel
The settings on the LINE STYLE panel are 
available for a variety of other objects in the 
program. For information about these 
settings, see “Line Style Panel” on page 
1085.

Fill Style Panel
The settings on the FILL STYLE panel affect 
the appearance of the selected object in floor 
plan view. For information about these 
settings, see “Fill Style Panel” on page 1099.

Materials Panel
The settings on the MATERIALS panel affect 
the appearance of the selected object in 3D 
views. See “Materials Panel” on page 852.

Label Panel
Terrain Feature labels display in floor plan 
and cross section/elevation views when the 
“Terrain Labels” layer is turned on and use 
the Text Style assigned to that layer. See 
“Terrain and Road Labels” on page 729.

For more information, see “Label Panel” on 
page 1280.

Garden Bed Specification Dialog
To open the Garden Bed 
Specification dialog, select a Garden 

Bed or group of Garden Beds and click the 
Open Object edit button or double-click the 

Garden Bed(s) using the Select Objects  
tool.

Because a Garden Bed is a type of Terrain 
Feature, the settings in this dialog are 

essentially the same as those in the Terrain 
Feature Specification dialog. See “Terrain 
Feature Specification Dialog” on page 741.

Garden Beds also include the Distributed 
Objects panel found in the Distribution 
Region Specification dialog. See 
“Distribution Region/Path Specification 
Dialogs” on page 805.

Terrain Break Specification Dialog
To open the Terrain Break 
Specification dialog, select a Terrain 

Break or group of Terrain Breaks and click 
the Open Object edit button or double-click 

the Terrain Break(s) using the Select Objects 
 tool. See “Terrain Breaks” on page 722. 
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General Panel

• Define the Transition Distance, which is 
the distance from the edge of the terrain 
break to where the break stops affecting 
the terrain. 

Polyline Panel
The POLYLINE panel states the Length of an 
open polyline or the Perimeter of a closed 
polyline. If multiple Terrain Break segments 
form a closed polyline, its Area will be 
calculated. Terrain Breaks do not have a 
thickness, so they have no Volume. See 
“Polyline Panel” on page 1098. 

Spline Panel
The SPLINE panel has a single option and is 
only available when the selected object was 
converted to a Terrain Break from a spline.  
See “Splines” on page 1106.

New Segment Angle - Specify the angle 
between line segments that are used to draw 
the spline. Specifying a smaller angle makes 
the spline smoother. Specify a larger angle to 
draw the spline faster.

Selected Line Panel
The SELECTED LINE panel is available when 
the selected edge of the polyline is a line as 
opposed to an arc. See “Selected Edge” on 
page 184.

Moving the Start of a line segment moves the 
end of the previous connected line, if there is 
one. Similarly, moving the End of a line 
segment moves move the start of the next 
connected line, if there is one. 

This panel is similar to the LINE panel of the 
Line Specification dialog. See “Line Panel” 
on page 1084.

Selected Arc Panel
The SELECTED ARC panel is available when 
the selected segment of the polyline is an arc 
as opposed to a line.  

This panel is similar to the ARC panel of the 
Arc Specification dialog. See “Arc Panel” 
on page 1093.

Line Style Panel
For information about the LINE STYLE panel, 
see “Line Style Panel” on page 1085.

Fill Style Panel
The FILL STYLE panel is only available when 
multiple Terrain Break segments enclose an 
area. The settings on this panel affect the 
appearance of the closed shape in floor paln 
view. For more information, see “Fill Style 
Panel” on page 1099.
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Terrain Path Specification Dialog
To open the Terrain Path 
Specification dialog, select one or 

mores Streams, Terrain Walls or Terrain 
Curbs and click the Open Object edit button 

or double-click the terrain path(s) using the 

Select Objects  tool.

Most of the panels in this dialog are similar 
to those for a variety of other objects in the 
program.

General Panel

Size - Enter the Width of the object and 
the Height above the terrain. If the 

Height value is a negative number, the object 
sinks into the terrain. 

When one terrain path joins another, 
you can Flare the intersection. 

• Check Start to create a flare at the start-
ing end of the selected terrain path, then 
specify the Radius of that flare.

• Check End to create a flare at that end of 
the terrain path, then specify the Radius of 
that flare.

1

2

Sidewalk flares with 24” Radius
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Polyline Panel
The POLYLINE panel states the length of the 
Terrain Path’s Perimeter, its enclosed Area, 
and its Volume. See “Polyline Panel” on 
page 1098. 

Spline Panel
The SPLINE panel has a single option and is 
only available when the selected object is a 
spline path. See “Splines” on page 1106.

• New Segment Angle - Specify the angle 
between line segments that are used to 
draw the spline. Specifying a smaller 
angle makes the spline smoother. Specify 
a larger angle to draw the spline faster.

Selected Line Panel
The SELECTED LINE panel is available when 
the selected edge of the Terrain Perimeter is a 
line as opposed to an arc. See “Selected 
Edge” on page 184.

The settings on this panel are available for a 
variety of other objects in the program. For 
information about these settings, see “Line 
Panel” on page 1084.

Selected Arc Panel
The SELECTED ARC panel is available when 
the selected segment of the polyline is an arc 
as opposed to a line. See “Break Line” on 
page 231.

The settings on this panel are available for a 
variety of other objects in the program. For 

information about these settings, see “Arc 
Panel” on page 1093.

Line Style Panel
The settings on the LINE STYLE panel are 
available for a variety of other objects in the 
program. For information about these 
settings, see “Line Style Panel” on page 
1085.

Fill Style Panel
The settings on the FILL STYLE panel affect 
the appearance of the selected object in floor 
plan view. For information about these 
settings, see “Fill Style Panel” on page 1099.

Materials Panel
The settings on the MATERIALS panel affect 
the appearance of the selected object in 3D 
views. See “Materials Panel” on page 852.

Label Panel
Terrain Path labels display in floor plan and 
cross section/elevation views when the 
“Terrain Labels” layer is turned on and use 
the Text Style assigned to that layer. See 
“Terrain and Road Labels” on page 729.

For more information, see “Label Panel” on 
page 1280.
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Importing Elevation Data
Elevation data can be added to a plan using 
the tools and techniques described in this 
chapter or it can be imported from a file. 

Chief Architect can import elevation data 
saved in DXF/DWG, GPS Exchange (.gpx) 
and a variety of text file formats (.txt, .csv, 
.prn, .xyz, .auf and .nez). If your terrain data 
is not saved in one of these file formats, there 
are third party programs available that can 
convert to these formats. 

DXF/DWG Files
If you have a model of your terrain created 
on another program that contains contour 
lines and elevation data, that information can 
be imported directly as elevation data into 
Chief Architect as a .dxf or a .dwg file. See 
“Importing DXF/DWG Elevation Data” on 
page 753. 

Text Files
Elevation data can be saved in text files as x, 
y, and z coordinates where x and y define the 
location of a point on a Cartesian grid, and z 
defines the elevation for that point. Each data 
point must be on a separate line in the text 
file. 

Importable text files can come from 
surveyors, other software programs, or you 
can create your own using a GPS system. 

Elevation data saved in text files can be 
imported using the Import Terrain 
Assistant. 

GPS Exchange Files
Elevation data in standard format .gpx files 
created using a GPS system can also be 
imported using the Import GPS Data 
Assistant. See “Import GPS Data Assistant” 
on page 750. 

GPS data may include three types of points - 
Way, Track, and Route. Chief Architect can 
only import a .gpx file if it includes one or 
more Way Points, and cannot use Route 
Points at all. If a .gpx file does not include 
any Way Points, it will not be imported, and 
if it includes any Route Points, they will be 
ignored.  

Chief Architect supports the import of data in 
standard .gpx files that adhere to the GPX 
1.1 Schema. Files that do not follow this 
standard cannot be imported.

Import Terrain Assistant
The Import Terrain Assistant allows 
you to import elevation data saved in 

text (.txt) file format into a plan.

Each data point in this format has informa-
tion about its X-axis (East to West location), 

Y-axis (North to South location), and Z-axis 
(elevation). It might also have a brief 
description. In order to import elevation data 
from a text file, you need to know how the 
data in the file is organized. 
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To launch the Import Terrain Assistant, 

select File> Import> Terrain Data . 
Click Next.

Select File

Select a file to import.  

• Click the Browse button to locate a file 
on your computer. See “Importing Files” 
on page 62. 

• If a file has been selected, its full path-
name displays here for reference; if a file 
has not been selected, the directory of the 
last file imported displays. If the path-
name is not that of a valid .txt file, this 
text will display in red. 

Select the organization of the data.  

Elevation information can be organized in 
one of six different ways, and can be 
separated by either a comma (comma 
delimited) or a space (space delimited). 
• XYZ - Information in this format begins 

with the X coordinate, followed by the Y 
coordinate and the Z coordinate.

• #XYZ - Information in this format begins 
with a number that belongs to each data 
point followed by the X coordinate, the Y 
coordinate, and the Z coordinate.

• #XYZ Description - Information in this 
format begins with a number that belongs 
to each data point followed by the X coor-
dinate, the Y coordinate, the Z coordinate, 
and a description.

• YXZ - Information in this format begins 
with the Y coordinate followed by the X 
coordinate and the Z coordinate.

• #YXZ - Information in this format begins 
with a number that belongs to each data 
point followed by the Y coordinate, the X 
coordinate, and the Z coordinate.

• #YXZ Description - Information in this 
format begins with a number that belongs 
to each data point followed by the Y coor-
dinate, the X coordinate, the Z coordinate, 
and a description.

1

2
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Click Next to continue.

Filter Data

The number of elevation points that the 
text file contains displays here for 

reference. Building terrain with a lot of 
elevation data can take a long time. 

If your text file has more than 1000 or 2000 
elevation points, consider filtering it using 
the settings that follow or using the Linear 
Smoothing option in the Terrain 
Specification dialog. See “General Panel” 
on page 732. 

Restrict the imported data to these 
ranges: 

One way to filter the data used is to define a 
range for each axis: X, Y, and Z. Data within 
these ranges is imported, while data outside 
these ranges is not. 

In the following diagram, the outer box and 
the points within it represent all of the data 
contained in a given text file. The smaller 

box represents a subset of this data, defined 
by ranges on the X and Yaxes.

Reduce the amount of data imported. 

Another way to filter the imported data is by 
skipping data points. Specify every 2 points 
to reduce this data by 50%; specify every 10 
points to reduce the data by 90%.

Click Next to continue.

1

2

3
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Scale Data

The total number of data points to be 
imported and the ranges of their 

coordinates are described here.

Select the Units of measurement used 
for each axis. 

Map a data point in the file to the origin 
in Chief Architect to position the terrain 

data relative to your plan. See “3D Drafting” 
on page 31.

Change the scale of the terrain.  

• Multiply the coordinates of each axis by a 
specific number to decrease or increase 
the relative size or relief of your terrain.

Rotate North Counterclockwise: 

• Specify an amount to rotate the terrain 
data counterclockwise, or to the left.

Click Next to finish.

Import GPS Data Assistant
The Import GPS Data Assistant 
allows you to import terrain data from 

the standard .gpx file format. See “GPS 
Exchange Files” on page 747.

Select File> Import> GPS Data to open the 
Import GPS Data Assistant, then click Next 
to continue.

1

2

3

4

5
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Select File

Select a file to import.  

• Click the Browse button to locate a .gpx 
file on your computer. See “Importing 
Files” on page 62. 

• If a file has been selected, its full path-
name displays here for reference; if a file 
has not been selected, the directory of the 

last file imported displays. If the path-
name is not that of a valid .gpx file, this 
text will display in red. 

Click Next to continue.

Due to the lack of accuracy in some
GPS systems, exact distances using

the Import GPS Data Assistant are not guar-
anteed.

1

Note: Not all GPS programs use the standard
.gpx file format; however, only files using the
standard format can be imported. 
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Import Data As

Specify which items you want to import 
by checking the box to the left of the 

Name. Items with unchecked boxes are not 
imported.

Specify what you would like the 
selected item to Import As from the 

drop-down list.
• Only Way Points have elevation data 

associated with them. To import this data, 
import them as “Elevation Points”. 

• Select “Marker” to import either Way 
Points or Track Points as location mark-
ers. Markers have no elevation data asso-
ciated with them.

• Select “Polyline” to create an open CAD 
polyline based on the position of Way 

Points or Track Points. The points them-
selves are not imported. Polylines have no 
elevation data associated with them.

• Select “Terrain Perimeter” to create a 
closed Terrain Perimeter polyline based 
on the position of either Way Points or 
Track Points. The points themselves are 
not imported. A Terrain Perimeter has no 
elevation data associated with it. See 
“Terrain Perimeter” on page 716. 

Click Next to continue.

1

2

Way Points are typically imported as
“Elevation Data”, while Track Points are

imported as “Markers”, “Polylines’, or “Terrain
Perimeter”. 



Importing DXF/DWG Elevation Data

 753

Transform Coordinates

Lower Elevation Data by: 

• Specify the amount that you would like to 
lower all imported elevation data.

Rotate North Counterclockwise: 

• Specify an amount to rotate the terrain 
data counterclockwise, or to the left. 

Map this point to the origin. 

• Specify a point in the imported terrain 
data, defined by degrees Latitude and 
Longitude, that you would like to locate 
at the origin in the Chief Architect plan.

Click Next to finish. 

If you do not see the imported terrain, select 

Window> Fill Window . 

Importing DXF/DWG Elevation Data
Select File> Import> Drawing 
(DWG/DXF)  to open the Import 

Drawing Assistant, which you can use to 
import elevation data in .dwg/.dxf format. 
See “Import Drawing Assistant” on page 
1172. 

By default, the Import Drawing Assistant 
imports entities as regular CAD objects; 
however, you can specify that any layer in 
the drawing be converted to either a Terrain 
Perimeter or Elevation Data. If a layer is 

converted to Elevation Data, any points and 
lines on that layer are converted to Elevation 
Points and Lines, and any elevation data 
associated with them is preserved. 
• If an imported line has vertices with the 

same Z values, an Elevation Line is cre-
ated.

• If the vertices have differing Z values, an 
Elevation Point is created for each vertex.

• Imported points are converted to Eleva-
tion Points.

1

2

3
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• Other imported entities (solids, faces, 
etc.) are imported normally.

If a Terrain Perimeter does not exist in the 
plan or if a layer in the .dwg/.dxf file is not 
converted to a Terrain Perimeter, a Terrain 
Perimeter is created around the extents of the 
Elevation Data when it is imported.  

Converting CAD Objects to Terrain Data
CAD lines, splines, and polylines - 
either imported or drawn using Chief 

Architect’s CAD Tools - can be selected and 
converted to terrain data using the Convert 
Polyline edit tool.

In floor plan view, select a CAD line, spline, 
or polyline and click the Convert 
Polyline  edit button to open the Convert 
Polyline dialog. See “Convert Polyline 
Dialog” on page 239.

A Terrain Perimeter must exist before any 
other types of terrain object can be created. If 
no Terrain Perimeter is present in the current 
plan, this will be the only terrain item 
available in the Convert Polyline dialog.  

When you click OK, the terrain object’s 
specification dialog opens, allowing you to 
specify elevation data or other attributes. 

To avoid unexpected results when
importing a drawing, only convert layers

with elevation information to Elevation Data. 
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Chapter 22:

Roads, Driveways
and Sidewalks

Roads and sidewalks are modeled in 3D like 
other terrain objects in Chief Architect. 
Because they have much in common with 
terrain objects and rely upon terrain data to 
be viewed in 3D, it is helpful to be familiar 
with terrain modeling before using these 
tools. See “Terrain” on page 715.

Chapter Contents
•      Road and Sidewalk Defaults
•      Road, Driveway and Sidewalk Tools
•      Displaying Road Objects
•      Editing Road Objects
•      Adding Road Objects to the Library
•      Road Specification Dialog
•      Median Specification Dialog
•      Driveway Specification Dialog
•      Road Marking Specification Dialog

Road and Sidewalk Defaults
Default Settings can be accessed by 
selecting Edit> Default Settings. 

Click the + beside Roads, Sidewalks and 
Driveways to display the subheadings. See 
“Default Settings” on page 74.

The settings in the Road Defaults, Driveway 
Defaults, Road Marking Defaults, and 
Sidewalk Defaults dialogs determine the 
initial settings when the road and sidewalk 

tools are used. It is a good idea to check these 
settings before placing any roads or 
sidewalks in your plan. 

Road Defaults
You can access the Road Defaults dialog 
from the Default Settings dialog, or by 

double-clicking the Road Tools  button. 



756

Chief Architect X8 Reference Manual

The settings in this dialog are the same as 
those in the Road Specification dialog. See 
“Road Specification Dialog” on page 761.

Driveway Defaults
You can access the Driveway Defaults 
dialog from the Default Settings dialog, or 

by double-clicking the Driveway  button. 

The settings in this dialog are the same as 
those in the Driveway Specification dialog. 
See “Driveway Specification Dialog” on 
page 763.

Road Marking Defaults
You can access the Road Marking Defaults 
dialog from the Default Settings dialog, or 

by double-clicking the Road Marking  
button. 

The settings in this dialog are the same as 
those in the Road Marking Specification 
dialog. See “Road Marking Specification 
Dialog” on page 764.

Sidewalk Defaults
You can access the Sidewalk Defaults dialog 
from the Default Settings dialog, or by 

double-clicking the Sidewalk  button. 

The settings in this dialog are the same as 
those in the Terrain Path Specification 
dialog, but only affect sidewalks and not 
other types of terrain paths. See “Terrain Path 
Specification Dialog” on page 745.

Road, Driveway and Sidewalk Tools
Road objects can be drawn in floor 
plan view, camera views and 

overviews, but only when a Terrain 
Perimeter exists in the plan. See “Terrain 
Perimeter” on page 716. 

When road objects are first placed into your 
plan, their initial dimensions and properties 
are controlled by their default settings. See 
“Road and Sidewalk Defaults” on page 755.

Road objects created with the Road Tools 
have a consistent width that can be defined in 
their specification dialogs. See “Road 
Specification Dialog” on page 761, “Terrain 
Feature Specification Dialog” on page 741, 
and “Terrain Path Specification Dialog” on 
page 745.  

Road objects are flat along their widths, 
which makes it easy to create roads on 
sloping terrain. 

Roads have curbs, and Sidewalks and 
Driveways cut out curbs and gutters 
wherever they meet a Road or a Road 
Polyline. 
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Once road objects have been placed, they can 
be edited individually or as a group. See 
“Editing Road Objects” on page 760.

Straight Road
To place a road without any curves, 
select Terrain> Road> Straight 

Road and click and drag to draw a line in 
floor plan view. The ends of multiple road 
sections can be connected together.

Roads are edited alone their center line like 
CAD lines and polylines. See “Editing Line 
Based Objects” on page 187.

Spline Road
Use Terrain> Road> Spline Road to 
draw a curved road. Spline roads are 

drawn and edited like CAD splines. See 
“Splines” on page 1106. 

Polyline Road
A polyline can be used to model roads 
of any shape. It is ideal for creating 

parking lots and other non-linear road 
surfaces. Roads created with the Polyline 
Road  tool conform to the surface of the 
terrain beneath them.

To place a road polyline select Terrain> 
Road> Polyline Road  and click and 
drag to draw a rectangular polyline in floor 
plan view. 

Road Polylines are edited alone their center 
line like polylines. See “Polylines” on page 
1097.

Median
A median is a polyline that can be 
used within a road. The median is 

made of the same material as the terrain 
beneath it and has a curb if the road that 
encompasses it has one. 

To place a median select Terrain> Road> 
Median  and click and drag to draw a 
rectangular polyline in floor plan view. Road 
median polylines must be contained within a 
road. 

Road medians are edited just like CAD 
polylines. See “Polylines” on page 1097.

Polylines can be converted to road medians. 
See “Converting Objects” on page 238.

Cul-de-sac
A Cul-de-sac is a road object with a 
special, rounded shape that can be 

placed at the end of a Road object. Select 
Terrain> Road> Cul-de-sac and click on 
the end of a road to place a cul-de-sac at that 
location. 

Culs-de-sac cannot be placed on road 
polylines.
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Culs-de-sac can be edited just like CAD 
polylines. See “Editing Closed-Polyline 
Based Objects” on page 201.

Road Stripe
The Road Stripe tool allows you to 
paint lines on a road surface. 

To place a road stripe, select Terrain> 
Road> Road Stripe  and click and drag 
to draw a line within a road in floor plan 
view. Multiple road stripes can be connected 
together. 

Road Stripes are edited like CAD lines. See 
“Editing Line Based Objects” on page 187.

Road Marking
A Road Marking paints polylines on 
a road surface, allowing any shape to 

be created.

To place a road marking select Terrain> 
Road> Road Marking  and click and 
drag to draw a rectangular polyline within a 
road in floor plan view.

Road markings are edited like CAD 
polylines. See “Polylines” on page 1097.

A driveway is a road without a curb. A 
driveway cuts out a curb wherever it meets a 

road or a road polyline. Like a road, the 
elevation of a driveway is flat across its 
width. 

Straight Driveway
To create a driveway, select Terrain> 
Driveway> Straight Driveway, then 

click and drag to draw a line. Multiple 
driveway sections can be connected together.

Height, thickness and material information 
can be specified in a driveway’s specification 
dialog. See “Driveway Specification Dialog” 
on page 763.

Driveways are edited like other line-based 
objects. See “Editing Line Based Objects” on 
page 187. 

Spline Driveway
Use the Spline Driveway tool to 
create a curved driveway. Select 

Terrain> Driveway> Spline Driveway. 
Spline driveways are drawn and edited like 
CAD splines. See “Splines” on page 1106.

Polyline Driveway
Use the Polyline Driveway tool to 
create a sidewalk of any shape. 

Driveway polylines conform to the surface of 
the terrain beneath them.

To place a driveway polyline, select 
Terrain> Driveway> Driveway 
Polyline  and click and drag to draw a 
rectangular polyline in floor plan view. 

Driveway polylines are edited just like CAD 
polylines. See “Polylines” on page 1097.
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Straight Sidewalk
To create a sidewalk with no curves, 
select Terrain> Sidewalk> Straight 

Sidewalk, then click and drag from end to 
end to draw a line. The ends of multiple 
sidewalk sections can be connected together.

Sidewalks are edited along their center line 
like line- and polyline- based objects. See 
“Editing Line Based Objects” on page 187. 

Sidewalks can be edited in their specification 
dialog. See “Terrain Path Specification 
Dialog” on page 745.

Spline Sidewalk
Use the Spline Sidewalk tool to 
create a curved sidewalk. Select 

Terrain> Sidewalk> Spline Sidewalk. 
Spline roads are drawn and edited like CAD 
splines. See “Splines” on page 1106.

Polyline Sidewalk
Use the Polyline Sidewalk tool to 
create a sidewalk of any shape. 

Sidewalk Polylines conform to the surface of 
the terrain beneath it.

To create a Sidewalk Polyline, select 

Terrain> Sidewalk> Sidewalk Polyline  
and click and drag to draw a rectangular 
polyline in floor plan view. 

Sidewalk polylines are edited just like CAD 
polylines. See “Polylines” on page 1097.

Auto Generate Sidewalks
Select a road or median and click the 
Auto Generate Sidewalk edit button 

to open the Auto Generate Sidewalks 
dialog.

• Left/Right Side of Road - Check one or 
both boxes to generate a sidewalk on  the 
selected road object.

• Check All Connected Roads to generate 
a sidewalk along all other roads con-
nected to the selected road object.

• Offset From Road - Specify a gap 
between the generated sidewalk and the 
selected road object.

Displaying Road Objects
Roads and sidewalks display in floor 
plan and 3D views based on the 

settings for their layers in the Layer Display 
Options dialog. See “Layers” on page 143.
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In 3D Views
In order for Road objects to be visible in 3D 
views, they must be drawn within the Terrain 
Perimeter. Any portions of these objects 
drawn outside of the Terrain Perimeter will 
not be seen in 3D views. 

By default, the terrain rebuilds automatically 
when road objects are added, removed or 
edited. If it does not, you can select Terrain> 
Build Terrain . See “Terrain Perimeter” 
on page 716.

Editing Road Objects
Road objects can be selected individually 
and as a group in 2D and 3D views and 
edited using the edit handles, the edit toolbar 
and their specification dialogs. 

Using the Mouse
The edit handles available for a selected road 
object depend on the type of object selected. 

• Straight Roads , straight Driveways 

, straight Road Stripes , and 

Straight Sidewalks  are edited along 
their centerline like a line or open poly-
line. See “Editing Line Based Objects” 
on page 187. 

• Spline Roads  and Spline Sidewalks 

 are edited along their centerline like 
CAD splines. See “Splines” on page 
1106.

• Polyline Roads , Cul-de-sacs , 

Medians , Road Markings  

Polyline Driveways  and Polyline 
Sidewalks  are edited along their 
perimeter, like standard polylines. The 
width is determined by the polyline’s 
shape. See “Editing Closed-Polyline 
Based Objects” on page 201. 

• Medians  are also edited like poly-
lines. 

In the Specification Dialog
Road objects can be customized in 
their specification dialogs. See “Road 

Specification Dialog” on page 761, “Terrain 
Feature Specification Dialog” on page 741, 
and “Terrain Path Specification Dialog” on 
page 745.

Using the Edit Tools
A selected road object can be edited in a 
variety of ways using the buttons on the edit 
toolbar. See “The Edit Toolbar” on page 37.

Convert to Polyline Object
A selected Straight or Spline Road, 
Sidewalk or Driveway can be 

converted into a Polyline Road, Sidewalk or 
Driveway by clicking the Convert to 
Polyline Object edit button. 

Polyline Roads, Sidewalks and Driveways 
display the same edit handles as closed 
polylines, allowing you to edit their shapes 
as much as needed. 
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Adding Road Objects to the Library
You can create your own road objects and 
save them to the library. Select any 
combination of elevation points, elevation 
lines, terrain features, roads, sidewalks, road 
markings, or even the terrain perimeter itself 
and send them to the library as one unit. 

When a group of terrain objects from the 
library is placed into a plan, each object  
becomes independent and can be edited 
individually. See “Adding Library Content” 
on page 829. 

Road Specification Dialog
To open the Road Specification 
dialog, select a Straight Road, Spline 

Road, Polyline Road, Median or Cul-de-sac 
and click the Open Object edit button. 

Many of the settings in this dialog are similar 
to those in the Terrain Path Specification 
dialog. See “Terrain Path Specification 
Dialog” on page 745.

General Panel

Size - Specify the Width and Height of 
the road relative to the terrain. The 

Width option is not available for culs-de-sac 
and non-centerline roads.

When one road joins another, you can 
Flare the intersection. 

• Check Start to create a flare at the start-
ing end of the selected road, then specify 
the Radius of that flare.

• Check End to create a flare at the end of 
the selected road, then specify the 
Radius of that flare.

1

2
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Flaring is not available for culs-de-sac or 
non-centerline roads.

Curb Panel

• Check Has Curb if you want the selected 
road to include a curb. 

• Click Select Curb Profile to apply a dif-
ferent curb profile to the selected road.

• Click Default Curb Profile to use the 
default curb profile.

• Enter a Width value for the curb.
• Enter a Height value for the curb.

• Check Cut Curb for Driveways and 
Sidewalks to cut the curb for driveways 
and sidewalks. 

Polyline Panel
The POLYLINE panel states the length of the 
road’s Perimeter, its Area and its Volume. 
Not available in the Road Defaults dialog. 
For more information, see “Polyline Panel” 
on page 1098. 

Road flares with 24” Radius



Median Specification Dialog

 763

Selected Line/Arc Panel
The SELECTED LINE panel is available when 
a Straight Road is selected. For more 
information, see “Line Panel” on page 1084.  

The SELECTED ARC panel is available when 
the curved segment of a  Straight Road is 
selected. See “Arc Panel” on page 1093.  

Spline Panel
The SPLINE panel is available when a Spline 
Road is selected. Specify the angle between 
the line segments used to draw the spline. 
For more information, see “Spline Panel” on 
page 1099. 

Line Style Panel
This panel is the same as the LINE STYLE 
panel in many other specification dialogs. 
See “Line Style Panel” on page 1085. 

Fill Style Panel
The settings on the FILL STYLE panel affect 
the appearance of the selected object in floor 
plan view. For information about these 
settings, see “Fill Style Panel” on page 1099.

Materials Panel
The settings on the MATERIALS panel affect 
the appearance of the selected object in 3D 
views. For information about these settings, 
see “Materials Panel” on page 852.

The material selected here is not calculated 
in the Materials List. See “Materials Lists” 
on page 1283. 

Label Panel
Road labels displays in floor plan and cross 
section/elevation views when the “Terrain 
Labels” layer is turned on and use the Text 
Style assigned to that layer. See “Terrain and 
Road Labels” on page 729.

For more information, see “Label Panel” on 
page 1280.

Median Specification Dialog
Select a median and click the Open 
Object edit button to open the Median 

Specification dialog. 

The settings in this dialog are similar to those 
in the Road Specification dialog. 

Driveway Specification Dialog
Select a driveway and click the Open 
Object edit button to display the 

Driveway Specification dialog.

The settings in this dialog are also found in 
the Driveway Defaults dialog and are similar 
to those in the Road Specification dialog. 
See “Road Specification Dialog” on page 
761.
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Road Marking Specification Dialog
Select a Road Marking or Road Stripe 
and click the Open Object edit button 

to open the Road Marking Specification 
dialog.

The settings in this dialog are also found in 
the Road Marking Defaults dialog and are 
similar to those in the Road Specification 
dialog. See “Road Specification Dialog” on 
page 761.

General Panel
The Width setting on the GENERAL panel is 
only available for Road Stripes. 

Enter a Width value for the selected Road 
Marking. 

Polyline Panel
The POLYLINE panel states the length of the 
road marking’s Perimeter, its Area, and its 
Volume.  Not available in the Road Marking 
Defaults dialog. For more information, see 
“Polyline Panel” on page 1098.

Selected Line/Arc Panel
The SELECTED LINE panel is available when 
the straight segment of a road marking is 
selected. See “Line Panel” on page 1084. 

The SELECTED ARC panel is available when 
the curved segment of a road marking is 
selected. See “Arc Panel” on page 1093.  

Line Style Panel
This panel is the same as the LINE STYLE 
panel in many other specification dialogs and 
affects the appearance of the selected object 
in floor plan view. See “Line Style Panel” on 
page 1085. 

Fill Style Panel
The settings on the FILL STYLE panel affect 
the appearance of the selected object in floor 
plan view. For information about these 
settings, see “Fill Style Panel” on page 1099.

Materials Panel
The settings on the MATERIALS panel affect 
the appearance of the selected object in 3D 
views. For information about these settings, 
see “Materials Panel” on page 852.

The material selected here is not calculated 
in the Materials List. See “Materials Lists” 
on page 1283.

Label Panel
Road Marking labels displays in floor plan 
view when the “Terrain Labels” layer is 
turned on and use the Text Style assigned to 
that layer. See “Terrain and Road Labels” on 
page 729.

For more information, see “Label Panel” on 
page 1280.
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Chapter 23:

Plants and
Sprinklers

The Plant Tools and sprinklers from the 
Library Browser allow you to create planting 
designs and irrigation systems in your 
terrain. 

The Terrain Tools are discussed in their own 
chapter. See “Terrain” on page 715.

Chapter Contents
•      Plant Tools
•      Plant Chooser Dialog
•      Hardiness Zones
•      Plant Image Specification Dialog
•      Plant Specification Dialog
•      Sprinkler Tools 
•      Sprinkler Specification Dialog
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Plant Tools
Select Terrain> Plant to add plants 
to your landscaping plan. Plants can 

also be placed in a plan directly from the 
library. See “Placing Library Objects” on 
page 836.

Plant objects are actually images, which 
provide realism while avoiding high 3D 
surface count. Once created, plant images 
can be selected and edited much like other 
image objects. See “Editing Images” on page 
1136.

Plants have labels which you can display in 
floor plan view. You can also create a Plant 

Schedule . See “Schedules and Object 
Labels” on page 1267. 

Select Terrain> Plant> Plant 
Chooser to open the Plant Chooser 

dialog and find plants based on their 
characteristics and requirements. See “Plant 
Chooser Dialog” on page 767.

Select Terrain> Plant> Create Plant 
Image to create a plant image. Once a 

plant image is created, it can be added to the 
library for future use. See “Creating Images” 
on page 1134. 

Select Terrain> Plant> Grow All 
Plants to open the Grow Plants 

dialog. 

Click and drag the slider bar and select a 
growth period from zero to twenty years. 
This only works for plants that have a mature 
height and mature age specified in the Plant 
Image Specification dialog. See “Plant 
Information Panel” on page 772.

Select Terrain> Plant> Show 
Hardiness Zones  to access regional 

climate zone maps. See “Hardiness Zones” 
on page 769.

Garden Beds
Garden Beds are special Terrain 
Features with material and height 

attributes typical of planting beds.  In 
addition, you can choose to distribute copies 
of a plant image within a Garden Bed. See 
“Garden Bed Tools” on page 726.

Plants Library Catalogs
In the Library Browser, browse to 
Chief Architect Core Catalogs> Plants 

to access a selection of plant images and 
symbols. Select the library object you want, 
then click in any view to place it in the plan. 
See “The Library” on page 819.

A selection of Bonus Catalogs of plants is 
also available for download. See “Chief 
Architect Bonus Catalogs” on page 826. 

In addition, you can add single plants and 
blocked groups of plants to the library. See 
“Adding Library Content” on page 829 and 
“Architectural Blocks” on page 811. 
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Plant Schedules
The Plant Schedule tool allows you 
to create customizable plant schedules 

and plant labels that display schedule 
numbers. See “The Schedule Tools” on page 
1268. 

Plant Chooser Dialog
Select Terrain> Plant> Plant 
Chooser to open the Plant Chooser 

dialog or click the Plant Chooser button at 
the bottom of the Library Browser window.

Use the Plant Chooser to search the library 
for plant images and symbols that meet your 
search parameters. You can search using any 
or all of the options in this dialog.

The search parameters in the Plant Chooser 
dialog correspond to the settings on the Plant 
Information panel of the Plant Image 
Specification dialog. See “Plant Information 
Panel” on page 772.
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Type the Name of a plant that you 
would like to find. 

• Specify the plant’s Common Name, Sci-
entific Name, or its Variety Name. 

• A Pronunciation field is also provided. 
In the Plant Image Specification dialog, it 
is populated with a phonetic pronuncia-
tion guide for the plant’s scientific name. 

Check one or more boxes to indicate 
selected plant Type to search for.

Check one or more boxes to specify the 
selecte Sub-Type to search for.

Specify the plant Needs to search for. 
These include the Sun, Water, Soil pH, 

and Hardiness Zone range. See “Hardiness 
Zones” on page 769.

1 2

3

4
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Flowers and Foliage -

• Specify the Flower Color to search for. 
Multiple colors can be selected.

• Specify the Leaf Color to search for. 
Multiple colors can be selected

• Specify the Bloom Time to search for, 
which is the season when the plant pro-
duces flowers. 

Specify the plant Height at maturity to 
search for. This is used with the Grow 

Plants feature. See “Plant Tools” on page 
766.
• An average mature height range can be 

entered using the From and To drop-
down lists.

• A specific Height at Maturity to search 
for can be entered in the text field.

• A specific Starting Age, in months, can 
be entered in the text field.

• A specific Age at Maturity, in months, 
can be entered in the text field.

Check one or more boxes to search for 
plants with Special Characteristics.

Select which types of plant Object 
Type to search for. 3D Plants are 

symbol objects, while Plant Images are two 
dimensional images. 

Click the Search button at the bottom 
of the dialog to search for plants that 

meet your search criteria. The search results 
display to the right. 

Your search results display here. 

• The Number of Items that match your 
search criteria is stated.

• Specify whether you want the search 
results to use the Common Name or Sci-
entific Name. 

• Click on the name of a plant in the list to 
see its location in the Library Browser.

Click the View Item button to see more 
information about the selected plant in 

the Plant Information dialog. See “Plant 
Image Specification Dialog” on page 770.

Hardiness Zones
Select Terrain> Plant> Show 
Hardiness Zones to view a selection 

of regional Hardiness Zone Maps. Click the 
drop-down list at the top left to select various 
regions.

5

6

7

8

9

10

11
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Plant Image Specification Dialog
Select one or more plant in a floor 
plan or 3D view and click the Open 

Object edit button to open the Plant Image 
Specification dialog. 

This dialog can also be accessed by selecting 

Terrain> Plant> Create Plant Image .

The Plant Information and Plant Description 
panels are also found in the Plant 
Information dialog, which can be accessed 
from the Plant Chooser dialog. See “Plant 
Chooser Dialog” on page 767.
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Image Panel

General - 

• The path and name of the selected plant’s 
Image File displays here. 

• Click Browse to specify the saved loca-
tion on your computer of the image that 
represents the plant in 3D views.

• A number of 2D Plant Symbols are avail-
able to represent the image in floor plan 
view. Select one from the drop-down list 
or click the Library button to choose a 
CAD block from the Library Browser.

Specify the Size of the plant image, as 
seen in 3D views. 

• Enter a Height for the image. 
• Enter a Width for the image. 
• When Retain Aspect Ratio of is checked, 

if you change either the Height or Width, 
the other value changes to maintain this 
ratio. If this is unchecked and you resize 
the plant image, it may become distorted.

1 2
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• Click Reset Original Aspect Ratio of to 
reset the image’s original aspect ratio and 
remove any distortion caused by resizing.

Specify the location of the selected 
plant image’s Center Point.

• Position the selected plant image in refer-
ence to the plan coordinates by specifying 
its X Coordinate and Y Coordinate.

• Specify the selected plant image’s Height 
Above Ground.

Specify the Block Line/Fill Style of the 
selected plant image’s 2D symbol in 

floor plan view. Only available when a CAD 
block from the library is selected as the 
image’s 2D Plan Symbol. 
• Select Use Image Settings to use the 

image’s line style, which is set by layer, 
and its fill style, which is “None (Trans-
parent)”. 

• Select Use Block Settings to use the 2D 
CAD block’s line and fill styles. See 
“Custom 2D Symbols” on page 1113. 

Options  - 

• Check Reverse Image to reflect the 
appearance of the image about an imagi-
nary vertical line through its center. 

• Check Do not rotate in 3D view to pre-
vent the plant image from rotating with 
the camera.

• Check Include in Schedule to include the 
selected plant in the Plant Schedule. See 
“Schedules and Object Labels” on page 
1267. 

If the selected plant image has been 
copyrighted, its Copyright 

Information displays here. 

A preview of the selected sprinkler 
symbol displays here. The Glass House 

Rendering Technique is not available for 
plant images. See “Dialog Preview Panes” 
on page 41.

Transparency Panel
The settings on the Transparency panel of 
this dialog are similar to those on the same 
panel of the Image Specification dialog. For 

more information, see “Transparency Panel” 
on page 1139.

Plant Information Panel
The settings on the Plant Information panel 
correspond to the search parameters in the 
Plant Chooser. See “Plant Chooser Dialog” 
on page 767.

3

4

5

6

7

When multiple plants with differing attri-
butes are selected, some button icons

may be replaced by an X symbol, which signi-
fies “No Change”.
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Plant Description Panel

A detailed Description of the plant 
displays in this text field.

Information in the Lighting 
Comments fields describes the plant’s 

light requirements.

Hardiness Zone Comments are given 
here. See “Hardiness Zones” on page 

769.

Layer Panel
For information about the Layer panel, see 
“Layer Panel” on page 154.

Fill Style Panel
The Fill Style panel controls the appearance 
of the selected plant’s 2D Plant Symbol in 
floor plan view.  By default, plant images’ 
fill style is None (Transparent). For 
information about the settings on this panel, 
see “Fill Style Panel” on page 1099.

22

1

2

3
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If the plant’s 2D Plan Symbol does not form 
a closed shape or is a CAD block is selected 
from the library, the settings on the Fill Style 
panel will have no effect on the appearance 
of the plant in floor plan view. If you wish, 
you can create a custom CAD block with the 
desired fill pattern. See “CAD Blocks” on 
page 1111. 

Label Panel
Plant labels display in floor plan view when 
the “Plants, Labels” layer is turned on and 
use the Text Style assigned to that layer. See 
“Object Labels” on page 1279. 

For information about the settings on this 
panel, see “Label Panel” on page 1280.

Plant Specification Dialog
Select a 3D plant symbol and click the 
Open Object edit button to open the 

Plant Specification dialog. This dialog is the 
same as that for a variety of symbol objects 
in the program. See “Symbol Object 
Specification Dialogs” on page 844. 

3D plants also have a Symbol Specification 
dialog, which can be accessed by clicking the 

Open Symbol  edit button. See “Symbol 
Specification Dialog” on page 1195.

Sprinkler Tools
Use the Sprinkler Tools to design a 
sprinkler system in your plan. 

Select Terrain> Sprinkler> 
Sprinkler Head to open the Select 

Library Object dialog. Browse to a sprinkler 
type in the library, click OK, then click in the 
drawing area to place as many as you need. 
Once drawn, sprinkler heads can be selected 
and edited. See “Sprinkler Specification 
Dialog” on page 775.

Select Terrain> Sprinkler> 
Sprinkler Line to draw sprinkler 

lines in your plan. Sprinkler lines are 2D 
objects and are drawn and edited much like 
CAD Lines. See “Line Tools” on page 1080.

Select Terrain> Sprinkler> 
Sprinkler Spline to draw curved 

sprinkler lines in your plan. Sprinkler splines 
are 2D objects and are drawn and edited like 
CAD Splines. See “Splines” on page 1106.

Displaying Sprinklers
The display of Sprinkler Heads, Lines and 
Splines can be controlled in the Layer 
Display Options dialog. See “Displaying 
Objects” on page 144.

In floor plan view, Sprinkler Head symbols 
indicate the spray angle. 



Sprinkler Specification Dialog

 775

Sprinkler head display in 3D views; 
however, Sprinkler Lines and Splines do not. 

Sprinkler Heads are counted in the Materials 
List, as is the total length of Sprinkler Lines 
and Splines. See “Materials Lists” on page 
1283. 

Editing Sprinklers
Sprinklers can be edited much the way other 
objects from the library can: using their edit 
handles, edit tools, and in their specification 
dialog. See “Editing Library Objects” on 
page 841.

Sprinkler Specification Dialog
To open the Sprinkler Specification 
dialog, select a sprinkler or group of 

sprinklers and click the Open Object edit 
button. You can also double-click the sprin-

kler(s) using the Select Objects  tool.

This dialog an example of a Symbol Object 
Specification dialog. See “Symbol Object 
Specification Dialogs” on page 844. 

Sprinkler Line Sprinkler Spline

90° 
Spray 

180° 
Spray 

360° 
Spray 

The elevation of a sprinkler can be
edited in cross section/elevation views. 



776

Chief Architect X8 Reference Manual



 777

Chapter 24:

Other Objects

Chief Architect has additional objects that 
can be used to customize your design. 

Chapter Contents
•      Primitive Tools
•      Creating Primitives
•      Editing Primitives
•      3D Box Specification Dialog
•      Sphere Specification Dialog
•      Cylinder Specification Dialog
•      Cone Specification Dialog
•      Pyramid Specification Dialog
•      Polyline Solids
•      Polyline Solid Specification Dialog
•      General Shapes
•      Soffits
•      Special Applications for Soffits
•      Soffit Specification Dialog
•      Floor and Wall Material Regions
•      Material Region Specification Dialog
•      Material Layers Definition Dialogs
•      Distributed Objects
•      Distribution Region/Path Specification 

Dialogs
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Primitive Tools
The Primitive Tools allow you to 
create basic solid geometric shapes, 

which can be combined to create a wide 
variety of custom solid objects. Select 
Build> Primitive to display the Primitive 
Tools. 

With the exception of Faces, objects made 
with the Primitive Tools are included in 
materials list calculations, although it is best 
that their specified materials are either 
Concrete or Volume material types. See 
“Define Material Dialog” on page 864.

Box
Select the Box tool, then click and 
drag to draw a solid 3D box.

Sphere
Select the Sphere tool, then click and 
drag to draw a solid 3D sphere.

Cylinder
Select the Cylinder tool, then click 
and drag to draw a solid 3D cylinder.

Cone
Select the Cone tool, then click and 
drag to draw a solid 3D cone.

Pyramid
Select the Pyramid tool, then click 
and drag to draw a solid 3D pyramid.

Polyline Solid
Select the Polyline Solid tool, then 
click and drag to draw a polyline solid. 

Despite their name, polyline solids are not 
true solids; however, they can be converted 
into solids. See “Polyline Solids” on page 
791.

Face
Select the Face tool, then click and 
drag to draw the edges of a two-

dimensional surface. Faces are two-sided, 
can display in 3D views and be used to create 
custom Solid objects. See “Face Objects” on 
page 779.

Creating Primitives
Primitive solids are drawn similar to the way 
CAD boxes and circles are. Depending on 
the view in which they are created, however, 
the method may differ somewhat. 

In Floor Plan View
In floor plan view, primitive solids are drawn 
much the way boxes and circles are. Select a 
tool, then click and drag to define an area.

• To create 3D Box , click and drag in 
any direction other than vertical or hori-
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zontal to define the width and depth of 
the box’s base. Its initial height is 1”.

• To create a Sphere , Cylinder , 

Cone , or Pyramid , click and 
drag in any direction to define the radius.

• As it is drawn, the height of a Cylinder 
, Cone  or Pyramid  is equal to 

its radius. 

Initially, the bottom surface of boxes, 
cylinders and cones, and the center point of 
spheres, are all set at 0” on the Z axis. See 
“Entering Coordinates” on page 168.

In 3D Views
In 3D views, the height of boxes, cylinders 
and cones can be defined as they are drawn.

• To create 3D Box , Cylinder  or 

Cone , click and drag to define the 
width and depth of the box’s base, then 
drag upward or downward to define its 
height.

• Drag upward to set the height of the bot-
tom surface at 0”, or drag downward to 
set the top surface at 0”.

• To create a Sphere  or Pyramid , 
click and drag in any direction to define 
its radius.

In Cross Section/Elevation 
Views

With the exception of Polyline Solids  

and Faces , primitives cannot be created 
in cross section/elevation views. See 
“Polyline Solids” on page 791.

Convert to Solid
Click the Convert To Solid edit 
button to convert the selected polyline 

solid or slab into a solid so that it can be used 
with other solids to create complex 
structures.  

Face Objects
Regardless of the view, primitive faces are 
drawn the way line-based objects are when 

the Alternate  edit behavior is active. See 
“Alternate” on page 179.  

To draw a Face

1. Select Build> Primitive> Face , 
then click, drag and release the  mouse 
button to draw the first edge. 

2. Click to define the endpoints of addi-
tional edges. A Face must have at least 
three edges. 

3. To finish drawing, click at the original 
starting point. This is easiest to do when 

Endpoint  snapping is enabled. See 
“Object Snaps” on page 162. 

Once drawn, Faces can be extruded to create 
Solid objects. See “Extrude Object” on page 
781.  
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Editing Primitives
Primitives can be selected individually and 
as a group and edited using the edit handles, 
the edit toolbar, dimensions, and their 
respective specification dialogs. 

Using the Mouse
Objects drawn using the Primitive Tools can 
be edited similar to CAD boxes or circles. 
When selected, a Primitive displays six edit 
handles: a Move handle, a Rotate handle and 
a Resize handle on each edge. Unlike CAD 
boxes or circles, Primitives do not have 
corner Resize edit handles.

In 3D views, most Primitives have a different 
set of edit handles for each selected edge, 
allowing you to rotate them in along more 
than one axis. These edit handles correspond 
to the object’s Rotation settings in its 
specification dialog. To rotate a Primitive, it 
is often easiest to use its edit handles in a 3D 
view to orient it approximately the way you 
want it, then use the Rotation seettings in its 
specification dialog to fine-tune its angles. 

Faces are the exception to this statement. 
Like Polyline Solids, they have Resize edit 
handles on each edge and can be edited like 
closed polylines. See “Editing Closed-
Polyline Based Objects” on page 201.

Using the Edit Tools
A selected Primitive can be edited in a 
variety of ways using the buttons on the edit 
toolbar.  See “The Edit Toolbar” on page 37. 

Using Dimensions
Like various other objects, Primitives 
can be moved and resized using 

dimensions.  See “Moving Objects Using 
Dimensions” on page 1019. 

Creating Complex Structures 
with Primitives

Primitive objects can be manipulated and 
combined to produce complex structures. 

Use the Union , Intersection  and 

Subtract  edit tools to create unique 3D 
shapes and combine shapes into Architec-

tural Blocks . See “Architectural Blocks” 
on page 811. 

A simple fireplace, for example, can be 

created by arranging 3D Boxes . 

Decorative stone columns can be modeled 

using 3D Boxes  and the Union , and 

Subtract  edit tools. 
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A custom chimney can be designed using 3D 

Boxes  and Cylinders  and the Union 
 and Subtract  edit tools.

A detailed model truck can be created using 

3D Boxes  and Cylinders  and the 

Union , Intersection , and Subtract 
 edit tools.

When a primitive has been manipulated 

using the Union , Intersection  and 

Subtract  edit tools, it is no longer a 
primitive that can be resized or reshaped 
using the edit handles or specification dialog. 
Instead, it is a considered a solid. See “Shape 
Specification Dialog” on page 790.

Structures created using the Primitive Tools 
can be converted to symbols. See “Convert 
to Symbol” on page 1206. 

Explode Shape
The Explode Shape edit tool allows 
you to explode a selected Solid object 

into a collection of faces. 

Extrude Object
The Extrude Object edit tool allows 
you to produce a Solid object by 

extruding a selected Face  object in any 
direction. See “3D Drafting” on page 31. 
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To use Extrude Object

1. Select a Face  object and click the 

Extrude Object  edit button.

2. In the Extrude Object dialog, specify 
the Extrusion Delta, which is the direc-
tion and distance that the object is 
extruded.

•  Specify the distances that the object 
should extrude in the directions of each 
of the three axes.

3. Click OK.

Revolve Object
The Revolve Object edit tool allows 
you to produce a Solid object by 

extruding a selected Face  object around 
an axis or point that you specify. 

To use Revolve Object

1. Select a Face  object and click the 

Revolve Object  edit button.

2. In the Revolve Object dialog, specify 
the Axis of Rotation, which determines 
the direction that the object will rotate. 
The Axis of Rotation is a line that is per-
pendicular to the direction in which the 
object will rotate. 

•  Select X-Axis to revolve the object 
around a line that runs parallel to the X 
Axis in the current plan. The object 
will revolve in the Y and Z axes.

•  Select Y-Axis to revolve the object 
around a line that runs parallel to the Y 
Axis in the current plan. The object 
will revolve in the X and Z axes.

•  Select Z-Axis to revolve the object 
around a line that runs parallel to the Z 
Axis in the current plan. The object 
will revolve in the X and Y axes.

•  Select User Defined to define the axis 
around which the object will revolve.
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3. When User Defined is selected, the X, Y 
and Z Direction fields become active. 
Type a length value in each field to spec-
ify the direction of a custom Axis of 
Rotation. All three values cannot be 0. 
No specific unit is used: instead, the 

ratio between these numbers is used to 
define an axis of rotation. 

4. Specify the Rotate About Point, which 
is the point around which the object will 
rotate.

5. Specify the Angle of Rotation, which is 
how far around the axis of rotation that 
the object will rotate. A value of 180° 
will rotate the object half-way around 
the axis, while 360° will rotate it in a 
complete circle.

6. Click OK.

3D Box Specification Dialog
Select a 3D box and click the Open 
Object edit button to open the 3D Box 

Specification dialog.

When you first draw a 3D box, the origin of 
the box is the point where you start drawing 
it; the width of the box is the X axis 
dimension. 

Specify the Origin of the selected box 
in relation to the origin point of your 

plan. See “Entering Coordinates” on page 
168.

The Axis of Rotation cannot be normal,
or perpendicular, to the plane of the

selected Face object. If it is, a warning mes-
sage will display and the object will not be
revolved.

1
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• Enter the X, Y, and Z Position coordi-
nates of the box’s origin.

The Dimensions settings control the 
size of the selected box.

• Specify the Width, Height, and Depth.

The Rotation settings allow you to 
rotate the selected box about the X, Y, 

and Z axes. See “3D Drafting” on page 31.
• Select the X, Y, or Z Axis as the axis 

around which the box will rotate.
• Specify the Angle to rotate the box in the 

text field. The default value is 90°. 
• Click the Rotate + button to rotate the 

box around the selected axis in a clock-
wise direction.

• Click the Rotate - button to rotate the 
box around the selected axis in a counter-
clockwise direction.

A preview of the 3D box displays on 
the right side of the dialog box. See 

“Dialog Preview Panes” on page 41.

Shape Panel
For information about the settings on this 
panel, see “Shape Panel” on page 790.

Line Style Panel
For information about the settings on this 
panel, see “Line Style Panel” on page 1085.

Materials Panel
For information about the settings on this 
panel, see “Materials Panel” on page 852.

2

3

4
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Sphere Specification Dialog
Select a sphere and click the Open 
Object edit button to open the Sphere 

Specification dialog.

Specify the Center Point of the 
selected sphere in relation to the origin 

point of your plan. See “Entering 
Coordinates” on page 168.
• Enter the X, Y, and Z Position coordi-

nates of the sphere’s center point.

Size - Specify the Radius of the 
selected sphere. 

A preview of the sphere displays on the 
right side of the dialog box. See 

“Dialog Preview Panes” on page 41.

Shape Panel
For information about the settings on this 
panel, see “Shape Panel” on page 790.

Line Style Panel
For information about the settings on this 
panel, see “Line Style Panel” on page 1085.

Materials Panel
For information about the settings on this 
panel, see “Materials Panel” on page 852.

1

2

3
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Cylinder Specification Dialog
Select a cylinder and click the Open 
Object edit button to open the 

Cylinder Specification dialog.

Specify the Center Point of the 
selected cylinder’s base in relation to 

the origin point of your plan. See “Entering 
Coordinates” on page 168.
• Enter the X, Y, and Z Position coordi-

nates of the cylinder’s center point.

Size - Specify the Radius and Height 
of the selected cylinder. 

The Rotation settings allow you to 
rotate the selected cylinder about the X, 

Y, and Z axes. See “3D Drafting” on page 31.
• Select the X, Y, or Z Axis as the axis 

around which the cylinder will rotate.
• Specify the Angle to rotate the cylinder 

in the text field. The default value is 90°. 

• Click the Rotate + button to rotate the 
cylinder around the selected axis in a 
clockwise direction.

• Click the Rotate - button to rotate the 
cylinder around the selected axis in a 
counterclockwise direction.

A preview of the cylinder displays on 
the right side of the dialog box. See 

“Dialog Preview Panes” on page 41.

Shape Panel
For information about the settings on this 
panel, see “Shape Panel” on page 790.

Line Style Panel
For information about the settings on this 
panel, see “Line Style Panel” on page 1085.

1

2

3

4
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Materials Panel
For information about the settings on this 
panel, see “Materials Panel” on page 852.

Cone Specification Dialog
Select a cone and click the Open 
Object edit button to open the Cone 

Specification dialog.

Specify the Base Center Point of the 
selected cone in relation to the origin 

point of your plan. See “Entering 
Coordinates” on page 168.
• Enter the X, Y, and Z Position coordi-

nates of the center point of the cone’s 
base.

Size - Specify the Radius and Height 
of the selected cone. 

The Rotation settings allow you to 
rotate the selected cone about the X, Y, 

and Z axes. See “3D Drafting” on page 31.

• Select the X, Y, or Z Axis as the axis 
around which the cone will rotate.

• Specify the Angle to rotate the cone in 
the text field. The default value is 90°. 

• Click the Rotate + button to rotate the 
cone around the selected axis in a clock-
wise direction.

• Click the Rotate - button to rotate the 
cone around the selected axis in a coun-
terclockwise direction.

A preview of the cone displays on the 
right side of the dialog box. See 

“Dialog Preview Panes” on page 41.

1

2

3
4
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Shape Panel
For information about the settings on this 
panel, see “Shape Panel” on page 790.

Line Style Panel
For information about the settings on this 
panel, see “Line Style Panel” on page 1085.

Materials Panel
For information about the settings on this 
panel, see “Materials Panel” on page 852.

Pyramid Specification Dialog
Select a pyramid and click the Open 
Object edit button to open the 

Pyramid Specification dialog.

Specify the Base Center Point of the 
selected pyramid in relation to the 

origin point of your plan. See “Entering 
Coordinates” on page 168.

• Enter the X, Y, and Z Position coordi-
nates of the center point of the pyramid’s 
base.

1
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Specify the Height of the selected 
pyramid.

• Specify the height of the Apex, measured 
from the base to the peak.

• Check Truncated to cut off the top of the 
pyramid and create a flat top.

• Specify the Height of a truncated pyra-
mid, measured from the base to the flat 
truncated top.

The Rotation settings allow you to 
rotate the selected pyramid about the X, 

Y, and Z axes. See “3D Drafting” on page 31.
• Select the X, Y, or Z Axis as the axis 

around which the pyramid will rotate.
• Specify the Angle to rotate the pyramid 

in the text field. The default value is 90°. 
• Click the Rotate + button to rotate the 

pyramid around the selected axis in a 
clockwise direction.

• Click the Rotate - button to rotate the 
pyramid around the selected axis in a 
counterclockwise direction.

Specify the selected pyramid’s Base 
Shape.

• Specify what you would like the pyra-
mid’s size to be Defined By:

• Select Side Length to enable the Side 
Length field to the right and specify the 
length of each side of the pyramid’s base. 

• Select Radius to Corner to define the 
distance from the center point of the pyr-
amid’s base to any of its corners. 

• Select Radius to Side to define the dis-
tance from the center point of the pyra-
mid’s base to the midpoint of any of its 
edges. 

• Specify the Number of Sides that the 
selected pyramid has. The default value 
is 4.

• Specify the Side Length, which is the 
corner to corner length of one each side 
of the pyramid’s base. Only available 
when Define Polyline by Side Length is 
selected to the left.

• Specify the Radius of the pyramid’s 
base, as measured from its center point to 
a corner or to the midpoint of a side. Only 
available when Define Polygon by 
Radius to Corner or Radius to Side is 
selected.

A preview of the pyramid displays on 
the right side of the dialog box. See 

“Dialog Preview Panes” on page 41.

Shape Panel
For information about the settings on this 
panel, see “Shape Panel” on page 790.

Line Style Panel
For information about the settings on this 
panel, see “Line Style Panel” on page 1085.

Materials Panel
For information about the settings on this 
panel, see “Materials Panel” on page 852.

2

3
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Shape Specification Dialog
Select a Face, a solid created using the 

Union , Intersection  and Sub-
tract  edit tools, or a solid created by 

converting a slab or polyline solid and click 
the Open Object edit button to open the 
Shape Specification dialog. 

Shape Panel

The 3D Surface Quality settings 
control how any curved surfaces on the 

selected object are rendered in 3D views. 
• Check Automatic to have the program 

define the Maximum Deflection, which is 
the amount each flat, triangular surface 
used to represent a curved surface in 3D 
can deviate from the true curvature of the 
object. For more information about trian-
gles, see “Higher Quality Rendering” on 
page 936.

• Specify the Maximum Deflection in 
plan inches (mm). This value is the maxi-
mum distance that a point on a triangle 
can be from the true location of the 
curved surface. Lower values produce 

more triangles and a smoother appear-
ance in 3D views. 

A preview of the shape displays on the 
right side of the dialog box. See 

“Dialog Preview Panes” on page 41.

Line Style Panel
For information about the settings on this 
panel, see “Line Style Panel” on page 1085.

Materials Panel
For information about the settings on this 
panel, see “Materials Panel” on page 852.

1

2
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Polyline Solids
Polyline Solids are polyline shaped 
3D objects with a specified thickness. 

They can be oriented either horizontally or 
vertically and are useful for creating custom 
details anywhere in your 3D model.

Creating Polyline Solids
A horizontal polyline solid can be created in 
floor plan view or any 3D view by selecting 

Build> Primitive> Polyline Solid , then 
either clicking or clicking and dragging to 
draw a rectangle. See “Rectangular Polyline” 
on page 1101.

A vertical polyline solid can be created in a 
cross section/elevation view in the same 
manner as in floor plan view. The polyline 
solid is placed in front of any objects visible 
in the view. If no objects are behind it, the 
polyline solid is placed one foot in front of 
the camera. 

Polyline solids can be edited the way other 
closed polyline-based objects are. See 
“Editing Closed-Polyline Based Objects” on 
page 201. 

Holes in Polyline Solids
You can create a hole in a polyline solid by 
drawing one polyline solid entirely inside of 
another. Select the smaller of the two and 
check Hole in Polyline Solid in its 
specification dialog.

Both the larger and smaller polyline solid 
must be drawn in the same type of view in 
order for the smaller one to become a hole.

Converting CAD Polylines
A closed CAD polyline can be 
converted into a polyline solid in floor 

plan and cross section/elevation views using 
the Convert Polyline edit button. See 
“Convert Polyline” on page 239.

Convert to Solid
You can convert a polyline solid to a 
primitive in order to build complex 

solid structures. Select the polyline solid you 
want to convert and click Convert to Solid 
on the edit toolbar. 

Polyline Solid Specification Dialog
To open the Polyline Solid 
Specification dialog, click on a 

polyline to select it, then click the Open 
Object edit button. 
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General Panel

• Check Hole in Polyline Solid to convert 
the polyline solid into a hole in a sur-
rounding polyline solid.

• Specify the Thickness of the polyline 
solid. Increasing the thickness will cause 
the polyline solid to grow upward (hori-
zontal) or toward the elevation/cross sec-
tion camera (vertical). 

The settings that follow are only available for 
polyline solids drawn in floor plan view. 
• Select the Elevation Reference, which is 

where the Floor to Top and Floor to Bot-
tom are measured from. The selection 
here will influence the labels of these two 
settings, below. 

• Specify the polyline solid Top height, 
which is measured from the Elevation 
Reference selected above. The label for 
this setting will vary depending on which 
Elevation Reference is selected.

• Specify the polyline solid’s Bottom 
height, which is the height of its bottom 
surface, measured from the Elevation 
Reference. 

Polyline Panel
The POLYLINE panel states the length of the 
polyline solid’s Perimeter, its enclosed 
Area, and its Volume. See “Polyline Panel” 
on page 1098.

If the selected polyline solid has any Holes in 
it, they will be subtracted from the Area and 
Volume values. See “Holes in Polyline 
Solids” on page 791. 

Selected Line/Arc Panel
The SELECTED LINE panel is available when 
the selected edge is a line as opposed to an 
arc. See “Line Panel” on page 1084.

The SELECTED ARC panel is available when 
the selected edge has been convered into an 
arc. See “Arc Panel” on page 1093.

Line Style Panel
For information about the settings on this 
panel, see “Line Style Panel” on page 1085.
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Fill Style Panel
For information about the settings on this 
panel, see “Fill Style Panel” on page 1099.

Materials Panel
For information about the settings on this 
panel, see “Materials Panel” on page 852.

General Shapes
Items in the Chief Architect Core 
Catalogs> Shapes library catalog 

allow you to create a variety of custom 
objects using basic geometric shapes. These 
shapes can can be used individually or 

combined to create a wide variety of custom 
objects. 

General Shape objects are placed and edited 
much like other library objects. See “Editing 
Box-Based Objects” on page 206.

Soffits
Soffits typically fill the space between 
the tops of wall cabinets and the 

ceiling, but they are very versatile and can be 
used to create almost any other object that 
can be modeled as a 3D box. Select Build> 
Cabinet> Soffit to activate this tool.

Soffit Defaults
The default settings for soffits are set in the 
Soffit Defaults dialog. The settings in this 
dialog are similar to those in the Soffit 
Specification dialog. See “Soffit 
Specification Dialog” on page 796.

For best results when placing soffits above 
wall cabinets:
• The default soffit should be the same 

width as and 1" (20mm) deeper than the 
default wall cabinet. See “Cabinet 
Defaults” on page 676. 

• The default soffit Floor to Bottom value 
should equal the sum of the default wall 
cabinet’s Floor to Bottom value plus its 

Height. See “General Panel” on page 
797.

• The default soffit Height should be equal 
to or greater than the space between the 
ceiling and the top of the wall cabinets. 

If the sum of the default soffit’s Floor to 
Bottom value and Height is larger than the 
ceiling height of the room in which a soffit is 
placed, the Floor to Bottom value will be 
retained and its Height will be adjusted so 
that it fits under the ceiling. 

The maximum soffit width is 250 feet (48m), 
and the minimum width is 1/16" (1 mm).

Once a soffit is placed in a plan, you can 
change its size and position to meet a variety 
of needs. 

Placing Soffits
Soffits can be created in both 2D and 3D 

views by simply clicking with the Soffit  
tool active. See “Click-to-Create” on page 
167. 
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They can be assigned materials that are 
calculated in the Materials List, but by 
default they use the material assigned to the 
default wall. See “Wall, Railing, and Fencing 
Defaults” on page 260.

When positioned against a wall in a room, 
soffits will display any moldings present in 
that room that are at the same height as the 
soffit. See “Moldings Panel” on page 359.

Like cabinets, soffits can also have custom 
molding profiles specified. See “Moldings 
Panel” on page 708.

To create a corner soffit, click as close to an 
inside wall corner as possible. A corner soffit 
retains its shape when it is moved, edited, or 
copied. 

When a soffit is created, it is placed on the 
“Cabinets, Soffits” layer. See “Displaying 
Objects” on page 144. 

Special Applications for Soffits
Nearly any object with straight, flat sides can 
be represented by one or more Soffits. They 
can be resized to as small as 1/16" (1mm) per 
side, or as large as 250 feet (48m).

Soffits can have materials applied to them to 
represent simple mirrors, posts, chimneys 
and so on. Following are some additional 
examples.

Roof Beams and Coffered 
Ceilings

Sloped soffits can be used to represent beams 
or rafters that follow the pitch of the roof in 

rooms with cathedral ceilings. See “Sloped 
Soffits” on page 798.

Soffits can also be used to create coffered 
ceilings. They will display any moldings 
assigned to the room it is in that are at its 
height. In addition, you can assign moldings 
directly to a soffit in its specification dialog. 
See “Moldings Panel” on page 798.

Polyline Solids can be used to create
irregular or curved shapes. See
“Polyline Solids” on page 791..
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Accent Tiles
A material such as ceramic tile can be 
assigned to one or more soffits applied to the 
walls above tubs or in showers.

Masonry Veneer
As an alternative to a pony wall, you can use 
a soffit to create a brick or stone veneer over 
part of a wall. Specify a soffit depth equal to 
the masonry material to be used. 

Soffits automatically stop at the floor 
platform when moved downward or at the 
ceiling platform when moved upward - even 
when the soffit is not located in a room. To 
move or resize a soffit through a floor or 
ceiling platform, select it and hold the Ctrl 
key down while dragging its edit handles. 
See “Unrestricted Movement” on page 221.

Calculating Materials on Soffits
By default, soffit materials are not calculated 
in the Materials List. In order for a soffit’s  
material to be counted, it must be edited so 
that it is not using the default material. See 
“Material Defaults” on page 848. 

The number of bricks, tiles, shingles, shakes 
or other materials applied to a soffit is 
calculated using the following rules:
• If the soffit depth is less than the larger of 

4 inches (10 mm) or 1 ½ times the mate-
rial thickness, then only the front area of 
the soffit is used. Thus if a soffit is 
48"x48”x4” thick, and the Dark Red 
brick material is used (3"x 8" with 3/8” 
mortar joint) the front of the soffit is 
48"x48”=2304 square inches. Including 
the mortar joint, each brick requires 3 3/
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8” x 8 3/8” = 28.26 square inches. 2304 
sq. in. divided by 28.26 sq. in. per brick 
gives 81.5 bricks.

• If the soffit depth is greater than both 4 
inches (10 mm) and 1 ½ times the mate-
rial thickness, then the surface areas of 
the soffit back, sides and top are used in 
addition to the front, if these surfaces are 
not attached to a wall or other soffit. 
However, only those portions of the 
sides, top and bottom remaining after 
subtracting twice the material thickness 
are used. So, for Dark Red brick, which 
has a depth of 4", the sides, top and bot-
tom surface areas cannot contribute to the 
brick count unless the soffit depth is 
greater than 8 inches.

• If surface materials such as brick are 
applied to a large soffit, the soffit center 
is assumed to be hollow, with only a sin-
gle layer of the material applied to each 
applicable face.

• For shingles and shakes, the overlap 
amount should be subtracted from the 
height, as opposed to brick or tile, where 
the joint width is added to the size.

• For materials in the area category, the 
soffit area calculation above is used, with 
the material thickness treated as zero.

• For materials in the volume, concrete or 
earth categories, the true volume of the 
soffit is used.

Soffit Specification Dialog
To open the Soffit Specification 
dialog, select the soffit and click the 

Open Object edit button or double-click on 

a soffit using the Soffit  tool.

The settings in this dialog are similar to those 
in the Soffit Defaults dialog, but affect only 
the selected object(s). 
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General Panel

Define the Size and Position of the 
selected soffit relative to the floor or 

terrain. 
• Specify the Width of the soffit. 
• Define the vertical Height of the soffit. 
• Define the Depth, which is the distance 

between the front and the back of the sof-
fit. When selected in floor plan view, the 
front of a soffit has a “V,” and the back of 
the soffit has a triangular rotation handle.

• If the selected soffit is a corner soffit, the 
Width controls its left side width, and 
Depth controls its right side width. 

• Floor to Bottom - Specify the distance 
from the bottom of the soffit to the floor. 
This is sometimes more easily done by 
positioning the soffit in a 3D view.

• When the selected soffit is outside a 
room, its Floor to Bottom height is mea-
sured relative to the terrain. Check Auto 
Adjust Height to maintain the same dis-
tance above the terrain if the soffit is 
moved to a location with different terrain 

height. Uncheck this to maintain the 
same absolute height regardless of the 
terrain below. When Auto Adjust Height 
is unchecked, the Floor to Bottom value 
may automatically adjust if the soffit is 
moved.

• Check Use Floor Finish to measure the 
Floor to Bottom distance from the surface 
of the floor finish. When unchecked, this 
height is measured from the subfloor. 
Only available when Auto Adjust Height 
is checked. 

• Height at Front applies to sloped soffits 
and becomes enabled when Sloped Soffit 
is checked. See “Sloped Soffits” on page 
798.

Options - Specify a sloped soffit and/or 
position relative to the roof or ceiling. 

• Check Sloped Soffit to slope the soffit 
vertically from the back up towards the 
front. When you specify a soffit as 
sloped, the options on the GENERAL panel 

1

2
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change. See “Sloped Soffits” on page 
798.

• Check Place Under Roof to have the sof-
fit’s slope follow that of the roof. The 
soffit moves up and the top of the soffit is 
in the same plane as the roof, at the same 
pitch as the roof. Be sure to place the 
front of the soffit toward the high side of 
the roof. Only available when Sloped 
Soffit is checked. Not available in the 
Soffit Defaults dialog.

• Check Place Under Ceiling to move the 
soffit vertically until the top contacts the 
ceiling plane. Not available in the Soffit 
Defaults dialog. 

Check Ignore Room Moldings to prevent 
the selected soffit from displaying moldings 
assigned to the room that it is placed in. See 
“Special Applications for Soffits” on page 
794. 

A preview of the soffit displays on the 
right side of the dialog box. See 

“Dialog Preview Panes” on page 41.

Moldings Panel
For information about the settings on this 
panel, see “Moldings Panel” on page 708.

 Layer Panel
For information about the settings on this 
panel, see “Layer Panel” on page 154.

Fill Style Panel
The settings on the FILL STYLE panel affect 
the selected soffit’s appearance in floor plan 
view. For information about the settings on 
this panel, see “Fill Style Panel” on page 
1099.

Materials Panel
Soffits are not calculated in the Materials 
List unless a non-default material is 
specified. See “Calculating Materials on 
Soffits” on page 795. 

For information about the settings on this 
panel, see “Materials Panel” on page 852.

Label Panel
Soffit labels display in floor plan view when 
the “Cabinets, Labels” layer is turned on and 
use the Text Style assigned to that layer. The 
Automatic Label for Soffits is blank, but you 
can specify a custom label. See “Cabinet 
Labels” on page 686. 

For more information about the settings on 
this panel, see “Label Panel” on page 1280.

Sloped Soffits
When a soffit is specified as a sloped soffit, 
the options on the GENERAL panel of the 
Soffit Specification dialog change. 

3
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• Width is measured left to right across the 
soffit, parallel to the front of the soffit.

• Thickness is measured perpendicular to 
the slope of the soffit.

• Horizontal Length is measured from 
back to front in floor plan view. Since the 
soffit is sloped, this measurement is not 
the actual length of the soffit. It cannot, 
for example, be used to determine the 
length of a sloped beam.

Both the front and back heights of a sloped 
soffit must be defined.
• Height at Back is measured from the fin-

ished floor to the lowest point at the back 
of the soffit.

• Height at Front is measured from the 
finished floor to the underside of the sof-
fit at the upper end.

Floor and Wall Material Regions
Floor and Wall Material Regions allow 
you to create areas within a wall or floor that 
use different materials than the parent object. 
There are three types of Material Regions:
• Floor Material Regions
• Wall Material Regions
• Custom Backsplashes

Material Regions are CAD-based objects 
composed of one or more layers. The 
thickness of these layers and their materials 
can be set in the Material Region 
Specification dialog. See “Material Region 
Specification Dialog” on page 801.

By default, Material Regions use the 
materials specified in the Floor and Wall 
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Material Region Defaults dialogs. See 
“Default Settings” on page 74.

By default, a Material Region cuts into the 
finish layers of its parent object and replaces 
those layers with its own within its 
perimeter; it can, however, can be affixed to 
the parent’s surface instead if you prefer.

In general, Material Regions are created and 
edited in the same manner that other closed 
polylines are. Bear in mind that their shapes 
can only be edited in the view type in which 
they were created and that Floor Material 
Regions cannot be moved in cross section/
elevation views. See “Polylines” on page 
1097 and “Editing Closed-Polyline Based 
Objects” on page 201.

Like most other architectural objects, a 
Material Region can be added to the library. 
Its material layers and the information in its 
specification dialog are saved; however, the 
shape of its polyline is not. See “Add to 
Library” on page 829.

Material Regions can span multiple parent 
objects; however, for best results the parent 
objects should have structural, or Main, layer 
surfaces that are in alignment. 

Floor Material Regions
To create a Floor Material Region, 
select Build> Floor> Material 

Region. Floor Material Regions must be 
drawn within a room area and are always 
drawn in floor plan view. If you create one 

by clicking once, it will fill the extents of the 
room.

Floor Material Regions set to cut the finish 
layers of their parent object will replace the 
layers of that floor’s Finish Definition with 
its own layers. See “Floor and Ceiling 
Platform Definitions” on page 344. 

Wall Material Regions
To create a Wall Material Region, 
select Build> Wall> Material 

Region. Wall Material Regions are drawn on 
the vertical surface of a wall and are always 
drawn in camera or elevation views. If you 
create one by clicking once, it will cut 
around doors, windows, and fireplaces but 
will otherwise fill the entire surface of the 
parent wall.

Wall Material Regions set to cut the finish 
layers of their parent object will replace the 
layers of the wall between itself and the 
wall’s Main Layer with its own layers. See 
“Wall Type Definitions” on page 302.

Custom Backsplashes
To create a Custom Backsplash, select 
Build> Cabinet> Custom 

Backsplash. Custom Backsplashes are 
drawn on the vertical surface of a wall and 
are always drawn in camera or elevation 
views. If you create one by clicking once, it 
will behave the way a Wall Material Region 
would, provided that no cabinets or 
appliances are positioned against the wall. 

By default, Custom Backsplashes use the 
backsplash material and thickness specified 
in the Base Cabinet Defaults dialog. If the 
default backsplash thickness is set to 0, 
Custom Backsplashes will be assigned an 

You can also convert a closed CAD
polyline into a Material Region in floor

plan and cross section/elevation views. See
“Convert Polyline” on page 239.
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initial thickness of 1” (25 mm). See “Cabinet 
Defaults” on page 676.

If any cabinets and/or appliances are present, 
a Custom Backsplash will:
• Seek to fill the area between any base 

cabinets or floor appliances against that 
wall surface and any wall cabinets and/or 
windows above them. 

• If nothing is above any base cabinets, it 
will fill the area between the cabinets and 

the ceiling; if nothing is below any wall 
cabinets, it will fill the area between the 
cabinets and the floor. 

• Replace the backsplash associated with 
any base or wall cabinets. 

Like Wall Material Regions, Custom 
Backsplashes set to cut the finish layers of 
their parent object will replace the layers of 
the wall between itself and the wall’s Main 
Layer with its own layers. 

Material Region Specification Dialog
Select a Material Region or a Custom 
Backsplash and click the Open 

Object edit button to open the Material 
Region or Custom Backsplash 
Specification dialog.

The settings in these two dialogs are also 
found in the Material Region Defaults 
dialogs, and most of its panels are also found 
in the specification dialogs for a variety of 
other CAD-based objects.

Material Layers Panel

• Click the Edit button to open the 
Material Layers Definition dialog. See 
“Material Layers Definition Dialogs” on 
page 802. 

• Uncheck Cut Finish Layers of Parent 
Object to fix the selected Material 
Region to the surface of its parent floor 
platform or wall. When checked, it cuts 

into the finish layers of the polyline’s par-
ent object and replaces those layers with 
its own within its perimeter. 

Polyline Panel
The POLYLINE panel indicates the length of 
the region’s Perimeter and its enclosed 
Area. See “Polyline Panel” on page 1098.
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If the selected region has any Holes in it, 
they will be subtracted from the Area and 
Volume values. See “Polyline Holes” on 
page 206. 

Selected Line/Arc Panel
The SELECTED LINE panel is available when 
the selected edge is a line as opposed to an 
arc. See “Line Panel” on page 1084.

The SELECTED ARC panel is available when 
the selected edge has been convered into an 
arc. See “Arc Panel” on page 1093.

See, too, “Selected Edge” on page 184 and 
“Change Line/Arc” on page 232.

Line Style Panel
For information about the settings on this 
panel, see “Line Style Panel” on page 1085.

Fill Style Panel
The FILL STYLE panel is only available for 
Floor Material Regions. For information 
about the settings on this panel, see “Fill 
Style Panel” on page 1099.

Label Panel
Material Region labels display in floor plan 
and cross section/elevation views when the 
“Polylines 3D, Labels” layer is turned on and 
use the Text Style assigned to that layer. The 
Automatic Label for Material Regions is 
blank, but you can specify a custom label.

For information about the settings on this 
panel, see “Label Panel” on page 1280.  

Material Layers Definition Dialogs
The Material Layers Definition dialogs 
allow you to define the layers that make up 
wall, floor, ceiling, slab, and roof assemblies. 
The names of these dialogs vary and are 
determined by the type of object or 
component being edited. They include:
• Backsplash Layers Definition Dialog
• Ceiling Structure Definition
• Ceiling Finish Definition

• Floor Structure Definition
• Floor Finish Definition
• Roof Surface Definition
• Roof Structure Definition
• Roof Ceiling Finish Definition

See “Floor and Wall Material Regions” on 
page 799, “Floor and Ceiling Platforms” on 
page 344, and “Roof Planes” on page 488.
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The layers of the floor or ceiling 
platform structure definition are listed 

here. Layers are numbered and listed from 
the top of the structure to its bottom. 

To select a layer for editing, click on it in the 
structure diagram at the bottom right of the 
dialog: the arrow to the right of the diagram 
points to the selected layer. 

• Specify the Thickness for each structural 
layer by typing in the text field. The layer 
thickness format can be changed by click-
ing the Number Style button.

• The Total thickness of the structure defi-
nition displays here as a reference.

• Click the Insert button to create a new 
layer directly above the currently selected 
layer in the structure definition. 

• To insert a layer at the bottom of the 
structure definition, click on the bottom 
line in the structure diagram.

• Click Delete to remove the currently 
active layer. The arrow to the right of the 
structure diagram points to the active 
layer.

Specify the characteristics of the 
Selected Layer.

• A preview of the selected layer’s fill style 
displays above the Fill Style button. Click 

You can also select a layer by clicking
in its Thickness text field.

1

2
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on either the button or the preview to 
open the Layer Fill Style dialog and spec-
ify the fill style created when the Auto 
Detail  tool is used in a cross section 
view. This dialog is similar to the Fill 
Style tab for CAD objects. See “Fill Style 
Panel” on page 1099. 

• Previews of the selected layer’s material 
display above the Select Material button. 
Click on either preview or this button to 
open the Select Library Object dialog 
and select a material from the library. See 
“Select Library Object Dialog” on page 
838.

• Click the Structure Type drop-down and 
select the type of framing member used 
for the platform structure. Only available 
when the selected material is a Framing 
type. See “Framing Member Types” on 
page 610.

• Check Auto Detail as Insulation to dis-
play insulation in the selected layer when 

the Auto Detail  tool is used in a cross 

section view. Not available in the 
Backsplash Layers Definition dialog or 
if the selected material is of the “Gap” 
Material Type. See “Auto Detail” on page 
905. 

• A diagram of the Material Layers assem-
bly displays below the Selected Layer set-
tings. To select a layer, click on a layer in 
the diagram or click in its Thickness 
field. The arrow to the right of the dia-
gram points to the Selected Layer. 

Specify the Energy Values of the 
selected Floor or Ceiling Structure. Not 

available for any object or component types 
other than Floor and Ceiling Structures. 
• Specify the structure’s Cavity R-Value, 

which is the R-value of its cavity insula-
tor: most commonly, the insulation 
between wood or metal joists.

• Specify the Continuous R-Value, which 
is the R-value of continuous insulators 
such as rigid foam sheets. 

Distributed Objects
The Distributed Object tools allow 
you to place multiple copies of an 

object in an evenly spaced array, either 
within a region or along a path. Select 
Build> Distributed Object to access these 
tools.

3

Distribution 
   Regions

Distribution 
    Paths
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To create distributed objects 

1. Select Build> Distributed Object and 
choose the desired Distributed Object 
tool.

2. Distribution regions are drawn like other 
closed polyline and spline-based objects.  

•  Click once to place a region with end-
points that form a 10’ (4 m) square. 

•  Click and drag from end to end to draw 
a region sized as needed. 

3. Distribution paths are drawn like other 
open polyline and spline-based objects. 

•  Click and drag from end to end to draw 
one or more connected lines or spline 
segments. 

4. Select the region and click the Open 
Object  edit button.

5. In the Distribution Region 
Specification dialog:

•  Select the object to be distributed 
within the region.

•  Specify the distributed objects’ spac-
ing, orientation and positioning.

•  Click OK to close the dialog.

Once created, Distribution Regions and 
Paths can be edited into nearly any shape you 
require. See “Editing Closed-Polyline Based 
Objects” on page 201 and “Editing Spline 
Based Objects” on page 209.

Explode Distributed Objects
Objects grouped in a Distribution 
Region or Path cannot be individually 

selected. You can, however, click the 
Explode Distributed Object edit button to 
separate a region or path into its individual 
components.  Once exploded, a Distribution 
Region or Path cannot be regrouped.

Distribution Region/Path Specification Dialogs
Select a Distribution Region or Path 
and click the Open Object edit button 

to open the Distribution Region or 
Distribution Path Specification dialog.

The settings in these two dialogs are similar 
and most panels are also found in the 
specification dialogs for a variety of other 
CAD-based objects.
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Distributed Object Panel - Distribution Region

Specify the Current Object assigned 
to the selected region. When an objects 

is assigned, its name and a preview of a 
single instance of it display here.
• Click the Select button to choose an 

object from the library. See “Select 
Library Object Dialog” on page 838.

• Click the Delete button to unassign the 
Current Object from the selected region.

• Click the Edit button to open the Current 
Object’s specification dialog. Changes 

made here affect all objects generated 
within the region. See “Specification 
Dialogs” on page 41.

• Check Show Objects to display the dis-
tributed objects in floor plan view.

• Check Show Region to display the edges 
of the distribution region in floor plan 
view.

Display Options - 

1

2
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• Check Show Objects to display the dis-
tributed objects in floor plan view.

• Check Show Region to display the distri-
bution region outline in floor plan view.

Object Spacing - Specify how the 
objects in the region are spaced. 

• Specify the Distance between the objects 
in the region, as measured from their cen-
ter points. 

• Select Standard Grid to position the 
objects in rows and columns based on the 
standard X/Y grid in the program. This 
grid is affected by Rotate View. See 
“Rotate Plan View” on page 237. 

• Select Alternate Grid to position the 
objects in rows and columns based on the 
shape of the region. 

Object Orientation - Specify how or if 
the objects in the region are rotated. 

These settings do not affect the region itself 
or its edges.
• Specify the Angle that the distributed 

objects should be placed at. 
• Select Absolute Angle to rotate the 

objects relative to an imaginary horizon-
tal line drawn in the positive X direction 
from the origin. See “3D Drafting” on 
page 31. 

• Select Relative Angle to rotate the 
objects relative to the angle of the 

region’s first edge or, if that edge is 
curved, to the angle of its chord. The first 
edge is typically located at the top of the 
region when it is first created; however, 
this can change as the region is edited.

• Select Random Angle to rotate the 
objects in the region at a variety of ran-
dom angles. 

Object Positioning - Specify the 
positioning of the distributed objects 

relative to a point of origin within the region. 
• Specify the X Offset, the horizontal dis-

tance in floor plan view from the region’s 
specified point of origin. 

• Specify the Y Offset, the vertical dis-
tance in floor plan view from the region’s 
specified point of origin. 

• Select From Polyline Center to measure 
the offset from the region’s center point. 

• Select Polyline Start to measure the off-
set from the region’s start point. This start 
point is typically located at the top left of 
the region when it is first created; how-
ever, this can change as the region is 
edited.  

A preview of the region displays on the 
right side of the dialog box. If no object 

has been assigned to the selected region, Plan 
View will be the default preview type.See 
“Dialog Preview Panes” on page 41.

3

4

5

6
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Distributed Object Panel - Distribution Path

Current Object - Specify the object 
assigned to the selected path. When an 

objects is assigned, its name and a preview of 
a single instance of it display here.
• Click the Select button to choose an 

object from the library. See “Select 
Library Object Dialog” on page 838.

• Click the Delete button to unassign the 
Current Object from the selected path.

• Click the Edit button to open the Current 
Object’s specification dialog. Changes 

made here affect all objects distributed 
along the path. See “Specification Dia-
logs” on page 41.

Display Options - 

• Check Show Objects to display the dis-
tributed objects in floor plan view.

• Check Show Path to display the distribu-
tion path in floor plan view.

1

2
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Object Spacing - Specify how the 
objects along the path are spaced.

• Select Distance Between Object Cen-
ters, then specify the distance between 
all object centers. If the path is resized, 
the total number of objects may change. 

• Select Number of Evenly Distributed 
Objects, then specify the number of 
objects. If the path is resized, the spacing 
between objects may change. 

Object Orientation - Specify how or if 
the objects on the path are rotated. 

• Specify the Angle that the distributed 
objects should be placed at. 

• Select Absolute Angle to rotate the 
objects to the specified Angle as mea-
sured from an imaginary horizontal line 
drawn from the origin towards the right. 

• Select Relative Angle to rotate each 
object relative to the edge of the polyline 
or spline that it is located on.

• Select Random Angle to rotate the 
objects in the region at a variety of ran-
dom angles. 

Object Positioning - Specify the 
positioning of the distributed objects 

relative to the path itself. 
• Specify the Side Offset, the distance that 

the objects are offset to the side of the 
path, using positive or negative numbers 
to offset to one side or the other. 

• Specify the Start Offset, the distance that 
the first object on the path is offset from 
the path’s starting point. 

• Check Alternate Sides to position 
objects on alternating sides of the path, 
creating a stepped pattern. 

A preview of the path displays on the 
right side of the dialog box. If no object 

has been assigned to the selected path, Plan 
View will be the default preview type.See 
“Dialog Preview Panes” on page 41.

Polyline Panel
The POLYLINE panel states the length of the 
region’s Perimeter and its enclosed Area. 
See “Polyline Panel” on page 1098. 

Spline Panel
The SPLINE panel has a single option and is 
only available when the selected object is 
spline-based. See “Splines” on page 1106.

New Segment Angle - Specify the angle 
between line segments that are used to draw 
the spline. Specifying a smaller angle makes 
the spline smoother. Specify a larger angle to 
draw the spline faster.

Selected Line Panel
The SELECTED LINE panel is available when 
the selected edge of the region or path is a 
line as opposed to an arc. See “Selected 
Edge” on page 184.

Moving the Start of a line segment moves the 
end of the previous connected line, if there is 
one. Similarly, moving the End of a line 
segment moves move the start of the next 
connected line, if there is one.

The settings this panel are found in a variety 
of specification dialogs throughout the 
program. See “Line Panel” on page 1084.

Selected Arc Panel
The SELECTED ARC panel is available when 
the selected edge of the region or path is an 

3

4

5

6
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arc as opposed to a line. See “Change Line/
Arc” on page 232.

The settings on this panel are found in a 
variety of specification dialogs throughout 
the program. See “Arc Panel” on page 1093.

Line Style Panel
For information about the settings on this 
panel, see “Line Style Panel” on page 1085.

Fill Style Panel
For information about the settings on this 
panel, see “Fill Style Panel” on page 1099.

Label Panel
Distribution Path labels display in floor plan 
and cross section/elevation views when the 
“Polylines 3D, Labels” layer is turned on and 
use the Text Style assigned to that layer. 

For more information, see “Label Panel” on 
page 1280.
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Chapter 25:

Architectural
Blocks

An architectural block is a collection of 
individual 3D objects that are grouped 
together so that they can be placed and 
moved as a single object. Although blocked 
together, these objects retain many of their 
own attributes, such as materials.

Architectural blocks can also be exploded so 
that the individual sub-objects become 
independent of one another.

Chapter Contents
•      Architectural vs CAD Blocks
•      Creating Architectural Blocks
•      Displaying Architectural Blocks
•      Editing Architectural Blocks
•      Architectural Block Specification Dialog
•      Architectural Blocks, Sub-Objects, and 

Components
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Architectural vs CAD Blocks
Just as there are two types of objects in Chief 
Architect, architectural and CAD, there are 
two types of blocks. See “Architectural vs 
CAD Objects” on page 160.

Architectural objects such as cabinets and 
fixtures can be included in architectural 
blocks, while CAD objects such as lines, 
arcs, text and dimensions can be included in 
CAD blocks. See “CAD Blocks” on page 
1111.

Knowing the differences between these two 
types of blocks helps you decide which type 
of block can best meet your needs.

A CAD block can include and also be nested 
in a larger block with CAD objects, text and 
dimensions, but cannot include or be blocked 
with architectural objects.

An architectural block can include and also 
be nested in a larger block with architectural 
objects, but cannot include or be blocked 
with CAD objects, text or dimensions. 

Creating Architectural Blocks
An architectural block is created by 
group-selecting multiple architectural 

objects and then clicking the Make 
Architectural Block edit button. 
Architectural blocks can be created in any 
view. 

The following is a list of objects that can be 
included in architectural blocks:
• Cabinets (Base, Wall, Full Height)
• Custom Countertops and Counter Holes
• Soffits, Shelves, Partitions
• Fixture and Furniture symbols 
• Hardware symbols

• Millwork symbols
• Geometric Shapes
• Electrical objects
• Images
• Slabs and Foundation Slabs
• Primitives and Polyline Solids
• Molding Polylines
• Roads, Driveways, Sidewalks
• Terrain Features and Terrain Modifiers

Once blocked, the set of blocked objects is 
contained in a bounding box, indicating that 
they are now an architectural block. 

Displaying Architectural Blocks
As with individual objects, the display 
of architectural blocks is controlled in 

the Layer Display Options dialog. See 
“Displaying Objects” on page 144.

• If an architectural block is composed of 
objects that are on the same layer, the 
block will be placed on that layer, as well. 
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• If an architectural block is composed of 
objects on different layers, the block will 
be placed on the “Architectural Blocks” 
layer.

• Once created, an architectural block can 
be placed on any layer you wish.

In Floor Plan View
The sub-objects of a block can use the layer 
attributes assigned to their current layer or 
the layer attributes assigned to the block. See 
“General Panel” on page 815. 

You can control the appearence of the 
bounding box by changing the display 
properties of the architectural block’s layer 
or you can turn off its display in the 
Architectural Block Specification dialog. 
See “General Panel” on page 815. 

You can select an architectural block and 

click the Move to Front of Group  edit 
button to make that block display in front of 
other objects in the same drawng group, 
including cabinets and some library symbols. 
See “Move to Front of Group” on page 219. 

Architectural Block Labels
Architectural blocks can display labels for 
both the block and any component objects 
that have labels in floor plan and cross 
section/elevation views.  Labels  for 
architectural blocks are placed on the 
“Architectural Blocks, Labels” layer and use 
the Text Style assigned to that layer. See 
“Object Labels” on page 1279.

You can turn off the display of component 
labels either by layer or by checking Treat as 
One Object in the Architectural Block 
Specification dialog. See “General Panel” 
on page 815. 

The label for an architectural block can be 
generated automatically, user-specified, or 
suppressed. See “Label Panel” on page 1280. 

In Materials Lists and 
Schedules

The display of an architectural block in 
materials lists and schedules can be turned 
off completely. The block can appear as a 
single unit or its sub-objects and components 
can be listed separately. See “Materials 
Lists” on page 1283 and “Schedules and 
Object Labels” on page 1267.

Editing Architectural Blocks
Architectural blocks can be selected and 
edited in 2D and 3D views. See “Selecting 
Objects” on page 183. 

Once selected, an architectural block can be 
edited using its edit handles, edit toolbar 
buttons, and specification dialog. See 
“Architectural Block Specification Dialog” 
on page 814.Note: Moving an architectural block in 3D

view regenerates the view. If the architectural
block contains terrain objects, the terrain is
rebuilt.
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Using the Edit Handles
A selected architectural block displays a 
Move handle and a Rotate handle. If the 
block has a label, it also has its own Move 
and Rotate handles.

Architectural blocks cannot be resized, but 
the individual objects in the block can be. 

In the Specification Dialog
Architectural blocks can be edited in 
their specification dialog.

Using the Edit Tools
A selected architectural block or blocks can 
be edited in a variety of ways using the 
buttons on the edit toolbar. See “The Edit 
Toolbar” on page 37.

Editing Sub-Objects
The individual objects included in an 
architectural block can also be selected and 

edited. See “To select a sub-object” on page 
816.

Explode Architectural Block
You can break an architectural block 
to make its objects independent. 

Select the architectural block and click the 
Explode Architectural Block edit button.  

Adding Architectural Blocks 
to the Library

You can create your own architectural 
blocks and save them in the library. 

See “Add to Library” on page 829.

Architectural Block Specification Dialog
The Architectural Block 
Specification dialog controls the way 

architectural blocks display in floor plan 
view, in schedules, and in materials lists.

Select one or more architectural blocks and 

click the Open Object  edit button to 
open this dialog.

Note: If you open a plan created in the Pre-
mier version of Chief Architect and an archi-
tectural block includes an object that you
cannot create in your version of the software,
you cannot unblock it or edit its components. 
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General Panel

The Display Options control the 
appearance of the selected architectural 

block in floor plan view. See “Displaying 
Architectural Blocks” on page 812.
• Check Display Bounding Box to show 

the bounding box of the objects in the 
architectural block. 

• Uncheck Display Sub-Objects to sup-
press the display of the sub-objects and 
display only the bounding box. If Display 
Bounding Box is unchecked, it will 
become checked. 

• Check Display Sub-Objects Using 
Block Layer to apply the display proper-
ties of the architectural block’s layer to its 
sub-objects. When this box is unchecked, 
sub-objects use the display properties set 
for their layers. 

The Schedule and Materials List 
settings control how the selected 

architectural block appears in schedules and 
the materials list. 
• Check Treat as One Object to treat the 

architectural block as a single unit in 
materials lists and schedules. 

Include in Schedule - Specify which 
schedule the architectural block appears in 
when Treat as One Object is checked. 

Specify the selected architectural 
block’s Size/Position relative to the 

floor or terrain. Not available if the selected 

1

Note: "Other" must be checked in the Sched-
ule Specification dialog for the architectural
block to appear in the schedule. See “Gen-
eral Panel” on page 1274.

2

3
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block includes any objects that do not have 
these settings in their specification dialogs. 
• Select the Elevation Reference from the 

drop-down list. This determines where 
the next two settings are measured from 
and also affects their setting labels.

• Specify the height to Top, measured from 
the selected Elevation Reference to the 
top of the architectural block.

• Specify the height to Bottom, measured 
from the selected Elevation Reference to 
the bottom of the architectural block.

Layer Panel
For information about the LAYER panel, see 
“Layer Panel” on page 154.

Label Panel
Labels for Architectural Blocks display in 
floor plan view when the “Architectural 
Blocks, Labels” layer is turned on and use 
the Text Style assigned to that layer. See 
“Architectural Block Labels” on page 813.

The LABEL panel is available for a variety of 
different objects. For more information, see 
“Label Panel” on page 1280.

Architectural Blocks, Sub-Objects, and Components
An architectural block is composed of a 
group of sub-objects that have been blocked 
together. For example, a kitchen island 
architectural block may consist of cabinets, 
appliances, a custom countertop, and other 
accessories.

Each of the sub-objects in an architectural 
block may contain additional parts called  
components. The cabinets in a kitchen island, 
for example, may contain handles, hinges, 
and drawer glide.

Architectural blocks can be treated as a 
single unit in materials lists and schedules, 
ignoring sub-objects and their components. 
See “General Panel” on page 815.

Sub-Objects
Certain attributes of an architectural block 
can be edited at the sub-object level. A sub-
object can be edited by accessing its 
specification dialog in either of two ways:

• Explode the architectural block, select 
the sub-object, and click the Open 
Object  edit button.

• Select the sub-object while it is part of 
the architectural block and click the 

Open Object  edit button. Some attri-
butes may not be editable while the 
object is part of a block. See “Editing 
Architectural Blocks” on page 813.

To select a sub-object

1. Click the Select Objects  button, 
then click on the sub-object that you 
would like to edit.

2. With the architectural block selected, 

click the Select Next Object  edit 
button or press the Tab key. 
The selection switches to the individual 
object and it can be edited using its edit 
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handles, edit toolbar and specification 
dialog.

The options for editing a sub-object may be 
more restricted than if the object were 
independent. If more extensive editing is 
required, the architectural block must be 
exploded.  

Components
You can view and modify the 
components of an architectural block 

or group of blocks in the Components 
dialog. The Components dialog lists all the 
sub-objects that comprise an architectural 
block, as well as the components that make 
up each sub-object.

To open the Components dialog, select an 
architectural block and click the 

Components  edit button. See 
“Components Dialog” on page 1300.
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Chapter 26:

The Library

Chief Architect’s library offers thousands of 
symbols, materials, and images that can 
enhance any plan. 

New library catalogs and enhancements are  
made available by Chief Architect on a 
continuing basis and are available for 
download for the current program version. 

You can also customize items from the 
library or import new items from outside the 
program and then save them in the library for 
future use.

The Library Browser shares its window with 
the Project Browser, which is discussed 
separately. See “Project Browser” on page 
1125.

Chapter Contents
•      The Library Browser
•      Searching the Library
•      Library Content
•      Downloading Library Content
•      Importing Library Catalogs
•      Adding Library Content
•      Organizing the Library
•      Filtering the Display of Library Content
•      Exporting Library Catalogs
•      Placing Library Objects
•      Select Library Object Dialog
•      Place Library Object Button
•      Replace From Library
•      Displaying Library Objects
•      Editing Library Objects
•      Symbol Object Specification Dialogs
•      Fixture and Furnishing Schedules
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The Library Browser
The Chief Architect Library Browser 
allows you to manage the contents of 

the library as well as add library content to 
your drawings. 

To open the Library Browser:

• Select View> Library Browser .

• Click the Library Browser button .
• Press Ctrl + L on your keyboard.

By default, the Library Browser is docked to 
the right side of the program window, but can 
be undocked or docked to another side. See 
“Docking the Library Browser” on page 823.

The Library Browser has four sections: 
• The filter and search options at the top. 
• The Directory and Search Results Pane. 
• The Selection Pane. 
• The Preview Pane. 

To adjust the height or width of a section, 
place the pointer over the split bar you want 
to move. When the double-headed arrow  
displays, click and drag. 

You can work on your drawing with the 
Library Browser open. To close the Browser, 
click the Close  button or double-click on 
an object in the Selection Pane. 

The library directory is presented in a tree list 
with five categories: Chief Architect Core 

Catalogs, Chief Architect Bonus Catalogs, 
Manufacturer Catalogs, User Catalog and 
Trash. See “Library Content” on page 825. 

Specify what displays in the Directory 
Pane’s tree list by selecting a filter from 

the drop-down list. See “Filtering the Dis-
play of Library Content” on page 834. 
• When “Not Filtered” is selected, all 

installed library content will display in 
the tree list.

• “Not Filtered” will be the only available 
option until you create a custom filter.

• Click the Manage Library Filters  
button to open the Manage Library 

You can control the configuration of the
Library Browser panes in the Prefer-

ences dialog. See “Library Browser Panel” on
page 96.

1
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Filters dialog. See “Manage Library Fil-
ters Dialog” on page 835. 

Search the library using keywords and 
optional search filters. See “Searching 

the Library” on page 824.
• Begin typing in the text field to search for 

library items. As you type, search results 
will display in the Directory Pane. 

• Right-click on an item in the Search 
Results list and select Show in Browser 
to view the item’s location in the Direc-
tory list.

• Click the Browse  button to stop 
searching and restore the Directory list.

• Click the Search  button to display 
the search results for your search entry.

• Click the Search Filtering Options  
button to customize your search parame-
ters. If the Library Browser is resized so 
that it is narrow, this button will be 
replaced by two arrows.

The library Directory and Search 
Results display here. The basic 

structure of the directory tree is: 

Library items are always placed in 
alphabetical order within their heirarchy.

The Library Browser includes a Trash bin, 
where deleted items are moved until you 
choose to Empty Trash. See “Deleting 
Library Items” on page 833.

Navigate the Directory Pane using the 
mouse. Click the gray Expand arrow  
beside a catalog or folder to display its 
contents. Once expanded, you can click the 
black Collapse arrow  to close it again. 
You can also browse the list using the arrow 
keys on your keyboard. 

Click on an item to select it. Preview images 
display in the Selection and Preview Panes 
and basic information about it also displays 
in the program’s Status Bar. See “The Status 
Bar” on page 42.

The Selection Pane shows a thumbnail 
image of the item selected in the 

Directory Pane.  

When an item is selected in the Directory 
Pane, a basic line-based representation of the 
item displays in the Selection Pane.
• If the selected item is a single object, a 

preview of that object displays in the Pre-
view Pane. You can move your cursor 
into the drawing area to place the item. 
See “Placing Library Objects” on page 
836. 

• If the selected item is a folder, a thumb-
nail image displays, representing each 
item inside. Move your pointer over an 
item in this pane to see a Tool Tip with 
the item’s name. Click on a folder in the 
Selection Pane to display its contents 
here and make it the item selected in the 
Directory Pane.

• Some folders may have too many items 
to display useful thumbnails for each; 
when this is the case, they do not display.

If you have Scrollable List checked in the 
Preferences dialog, a scroll bar is present at 
the bottom of the Selection Pane. 

2

3
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Click the Show/Hide Selection Pane  
button to toggle the Selection Pane on and 
off.

When an individual item is selected in 
either the Directory or Selection Pane, 

an image of it displays in the Preview Pane. 
If the item is designed to be inserted into 
another object such as a cabinet, that parent 
object will also display in the preview.  

You can click the Toggle Preview Display 

 button at the bottom of the browser 
window to switch between preview images 
in Standard Render and Vector View styles. 

If the selected object is a 3D symbol, you can  
rotate and zoom in or out on the Preview 
using the mouse. Two-dimensional objects, 
such as CAD Blocks or Line Styles cannot be 
adjusted in this manner in the Preview Pane.

If you have rotated a view in the Preview 
Pane, you can restore the default angle either 
by clicking in the Selection Pane or by right-
clicking on the Preview Pane and selecting 
Reset Preview.  

Click the Show/Hide Preview Pane  
button to toggle the Preview Pane on and off. 

The toolbar at the bottom of the 
browser aids in searching, displaying 

panes, and managing library content. 

Click the Plant Chooser button to 
open the Plant Chooser dialog. See 

“Plant Chooser Dialog” on page 767.

Click the Get Additional Online 
Content button to launch your default 

web browser to the Chief Architect web site, 
where additional library content is available 
for download.

Click the Show/Hide Selection Pane 
button to toggle the Selection Pane on 

and off.

Click the Show/Hide Preview Pane 
button to toggle the Preview Pane on 

and off.

Click the Toggle Preview Display 
button to switch between Standard 

Render and Vector View images of a selected 
library object in the Preview Pane. See 
“Rendered and Vector Views” on page 888. 

Click the Preferences button at the 
bottom of the Library Browser to open 

the Preferences dialog, where display 
properties for the Library Browser can be 
controlled. See “Library Browser Panel” on 
page 96. 

Using the Contextual Menus
A number of important library functions can 
be accessed using the contextual menus. 
Right-click on an item in the Library 
Browser to open a contextual menu 
displaying options related to that item. See      
Contextual Menus.

5
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The options in the contextual menu vary 
depending on the item selected, but may 
include: 
• Cut/Copy/Paste
• Paste Shortcut
• New
• Rename
• Delete
• Export Library
• Open Object/Open Symbol
• Components
• Search Attributes
• Text Macro Management
• Place Molding Profile 
• Reset Preview
• Expand All/Collapse All
• Show in Browser

Keyboard Commands
The Library Browser can be navigated using 
the arrow keys on your keyboard. 
• The right and left arrow keys expand and 

collapse folders.
• The up and down keys change which 

library object is currently selected.
• Select an item and press F2 to rename it.
• Select an item and press the Delete key to 

delete it. 

If you have Scrollable List selected in the 
Preferences dialog, pressing the Tab key 
switches focus between the Directory and 
Selection Panes. Use your mouse to select an 
object for placement. See “Library Browser 
Panel” on page 96.

If you have Tiled To Fit Window selected 
instead, pressing the Tab key switches focus 
between the tree view and the Selection 
Pane. You can then use the arrow keys to 
select a library object within the Selection 
Pane.

Expand/Collapse All
When a library category or folder is selected 
in the Directory Pane, Expand All and 
Collapse All are available in the contextual 
menu, allowing you to expand or contract its 
contents in the tree view.

Docking the Library Browser
Initially, the Library Browser side window is 
docked to the right side of the main Chief 
Architect program window. To undock it, 
click and drag its title bar towards the center 
of the program window. Once undocked, it 
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can be moved and redocked in the same 
manner. See “Side Windows” on page 36. 

When moved to the top, bottom, or side of 
the program window, it automatically docks 
in a vertical or horizontal orientation, 
depending on its location. You can prevent 
the Library Browser from docking when 
dragged: 
• In the Preferences dialog. See 

“Appearance Panel” on page 92. 
• By holding down the Ctrl key while 

dragging it.

To return the Library Browser to its original 
position and size, click the Restore Position/
Size button in the Preferences dialog.

Closing the Library Browser
The Library Browser can be closed in either 
of two ways: 

• Click the Close  button at the top right 
corner of the browser window.

• Select View> Library Browser .

Searching the Library
The Library Browser filtering options let you 
focus your searches to meet parameters that 
you define. 

Search filters do not affect the display of 
items in the Directory Pane tree list. You can 
filter the display of the tree list separately. 
See “Filtering the Display of Library 
Content” on page 834.

To search the Library Browser

1. Select View> Library Browser  and 
click in the Search field at the top of the 
Library Browser.

2. Begin typing a keyword to search for. As 
you type, the search results will populate 
in the Directory Pane below.

3. You can click the Clear  button on 
the right side of the Search field to 
remove anything typed in this field. 

4. If you move your mouse pointer over the 
Search field, a Tool Tip will state the 
number of results of your search.

5. Right-click on an item in the Search 
Results list and select Show in Browser 
to view the item’s location in the Direc-
tory list.

Substrings are not included. For example, 
searching for “windows” will not produce 
“window” as a search result. On the other 
hand, searching for “window” will produce 
“windows” as a search result.

To search using custom filters

1. Click the Turn on search filtering 
options  button. 

•  Check Keyword to match the entered 
search keyword with an object’s search 
attributes. 

•  Check Entire Word to match the entire 
keyword or words with the complete 
name of the object. 
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•  Check Folders to include library fold-
ers in your search.

•  Check Include Filtered to include all 
library catalogs not currently display-
ing in the tree list in your search. See 
“Filtering the Display of Library Con-
tent” on page 834.

2. Click the arrow beside Type, Style, or 
Manufacturer to expand that category. 

•  Check the box beside one or more 
Type of library item that you want to 
include in your search. 

•  Check the box beside one or more 
architectural or design Style to include 
items of that style in your search. 

•  Check the box beside one or more 
Manufacturer to include in your 
search. Manufacturer catalogs that 
were imported during the current pro-
gram session will not be listed here 
until you exit out of and restart Chief 
Architect.

3. Type a keyword in the Search field. The 
results will be filtered to match your 
selected filtering options. 

Searching Filtered Content
When Include Filtered is checked, any 
items in your search results that are currently 
filtered out of the tree list cannot be shown in 
the browser. If you right-click on such an 
item and select Show in Browser, a warning 
message will display. 

Search Attributes
Objects in the library all have one or more 
search attributes, which are keywords and 
architecural styles that can be used to find 
them in a library search. The Search 
Attributes dialog lists these attributes for 
each library object. See “Search Attributes” 
on page 843.

Library Content
The Chief Architect library has five 
categories: Chief Architect Core Catalogs, 
Chief Architect Bonus Catalogs, 
Manufacturer Catalogs, User Catalog and 
Trash. See Getting Started Guide, “Deleting 
Library Items” on page 833.

Chief Architect Core Catalogs
The Chief Architect Core Catalogs category 
contains a wide selection of 3D symbols, 

images, CAD objects, and materials. When 
you install the program from DVD, this 
library content will also be installed; if you 
download the software, you will be able to 
download the Core Catalogs separately, after 
the program is installed. 

When you launch the program for the first 
time, it will ask if you want to download the 
Core Catalogs. Click Yes to begin the 
download. If you click No, you can 

To save time, check the box beside
Type, Style, or Manufacturer to select

all of the options in that category at once;
uncheck the box to deselect all of the options.
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download at any time by selecting Library> 
Install Core Content from the menu. 

Chief Architect 
Bonus Catalogs

Chief Architect regularly posts new library 
catalogs available for download. Select  
Library> Get Additional Content 
Online  from the menu to access the 
bonus catalogs and content. 

Most Bonus Catalogs can be purchased for a 
nominal fee, while others are available free 
of charge. In addition, some Bonus Catalogs 
are only available to Chief Architect Support 
and Software Assurance program members. 
For more information, visit  chiefarchi-
tect.com. 

Manufacturer Catalogs
A variety of name brand library catalogs is 
available for download on the Chief 
Architect web site with content ranging from 
materials to fixtures to CAD blocks.

Select Library> Get Additional Content 
Online  to access these Manufacturer 
Catalogs. 

As with the Bonus Catalogs, some 
Manufacturer Catalogs are available free of 
charge while others can be purchased, and 
some are available for Support and Software 
Assurance members only. 

The User Catalog
The User Catalog is the location for items 
that you add to the library either from a 
drawing or by importing. See “Adding 
Library Content” on page 829. 

You can create and organize custom library 
folders and imported items such as symbols, 
images, backdrops, CAD blocks, line styles, 
and materials. See “Organizing the Library” 
on page 831.

Copy Item List
Copy Item List is available in the contextual 
menu when a library category or folder is 
selected in the Library Browser Directory 
Pane. Select this option to copy a list of all 
objects in the selected library item to the 
system clipboard. You can then paste this list 
into a text application such as Notepad. See 
“To Copy, Cut and Paste text” on page 1049.

Updating Library Catalogs
The Chief Architect Core Catalogs, Bonus 
Catalogs, and Manufacturer Catalogs are 
updated periodically to include new and 
improved content. You can update your 
installed catalogs to include the latest content 
by selecting Library> Update Library 
Catalogs at any time. 

The program will gather information about 
the content in each of these three categories, 
and then download and replace any content 
that is not up to date, and you may see a 
progress indicator at the bottom of the 
Library Browser while it is doing so. See 
“Download Progress” on page 827.

Backing up Library Content
The Chief Architect User Catalog File, 
User_Library.calib, is located in the Chief 
Architect X8 Data folder. See “Chief 
Architect Data” on page 53. 

The best way to back up your custom library 
content is to export the items in your User 

http://www.chiefarchitect.com/products/ssa/
http://www.chiefarchitect.com/products/ssa/
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Catalog, as this will ensure that the textures 
used by custom materials or imported 
symbols are not lost. See “Backing Up Your 
Files” on page 58. 

Exported libraries use the .calibz file format: 
a zipped file type that can include textures 
and images along with other library data.

To back up your custom library content

1. Launch Chief Architect and select 

View> Library Browser  from the 
menu.

2. Right-click on a folder or item in the 
User Catalog. 

3. Select Export Library from the contex-
tual menu.

4. The Export Library Data dialog is a typ-
ical Save dialog. See “Exporting Files” 
on page 58.

•  Notice that the file type in the Save as 
type field is “Library File with Tex-
tures/Images (*.calibz)”.

Downloading Library Content
The Chief Architect Core Catalogs, Chief 
Architect Bonus Catalogs, Manufacturer 
Catalogs are all available for internet 
download. 

Core Catalogs
When you launch Chief Architect for the first 
time, you will be asked if you want to 
download the Core Catalogs. Click Yes to 
begin the download. 

If you click No, you can download at any 
time by selecting Library> Install Core 
Content from the menu. 

Bonus and Manufacturer 
Catalogs

Bonus and Manufacturer Catalogs can be 
downloaded from our web site,
 www.chiefarchitect.com. Select Library> 
Get Additional Content Online  to 
launch your default internet browser to our 
Content Resources page. 

Download Progress
When library content is downloading, a 
green progress bar will display at the bottom 
of the Library Browser. If you choose to 
download the Core Catalogs while the library 
is not open, the Browser will open so the 
progress indicator can display. 

Click on the progress bar to display the name 
of the current file being downloaded, the 
total amount of data to be downloaded in 
KB, and the amount downloaded so far.

Pausing and Resuming
Library downloads can only take place while 
Chief Architect is running. If you close the 
program while a download is in progress, a 

http://www.chiefarchitect.com/useraccess/content.html
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dialog will confirm whether you wish to stop 
the download.
• Click Stop Download and Close Pro-

gram to stop the download and close the 
program. 

• Click Cancel to leave the program open 
and continue downloading. 

Most catalogs are composed of a single file. 
If you stop the download midway, none of 
the downloaded data will be retained.

The Core Catalogs, on the other hand, 
contain a large volume of data saved in 
multiple files. If you close the program and 

stop the Core Catalogs download midway, 
only data associated with the file currently 
being downloaded will be lost. You can 
resume the download beginning with that file 
at a later time by selecting Library> Install 
Core Content.

Download Errors
If any problems occur during the library 
download process, a dialog box will notify 
you at the end of the download. Click Retry 
Download to repeat the download and 
correct any errors or click Cancel to discard 
the downloaded catalog. 

Importing Library Catalogs
Chief Architect library files have two 
different file extensions: .calib and .calibz. 
Both files can include any combination of 
Chief Architect library items; in addition, 
.calibz files are able to save data associated 
with textures and images. Both file types can 
be imported into the Chief Architect library.

There are several ways to import a .calib or 
.calibz file into the program library:
• Double-click on the file in an operating 

system window while a plan or layout file 
is open.

• Drag the file from an operating system 
window and drop it into the Chief Archi-
tect program window. 

• Select Library> Import Library from 
the program menu.

To import library files into the library

1. Select Library> Import Library to dis-
play the Import Library Data dialog.

2. Browse to the .calib or .calibz file(s) 
that you want to import and either single 
or group-select the files so that their 
names display in the File Name field.

•  To select a group of files, click on the 
first one, hold down the Shift key, then 
click on another file. The two files plus 
all files in between are selected.

•  To select multiple files individually, 
click on one, hold down the Ctrl key, 
then click on additional files. Only the 
files you click on are selected.

•  To select all files in the directory, click 
on one and press Ctrl + A. Only do this 
if you wish to import all files in the 
folder.

3. Click the Open button. 
Note: Library files cannot be imported if no
plan or layout file is open, or when a Materi-
als List or Ray Trace view window is active. 
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4. A progress bar will display, telling you 
the progress of each library data file as it 
is imported. Once imported, each file 
will be located in the User Catalog.

When a .calib or .calibz file is imported into 
the program, its contents are automatically 
placed in the User Catalog. Any images or 
textures saved in a .calibz file will be copied 
into the Chief Architect X8 Data\ Images and 
Textures folders for backup purposes. The 
program will only reference these copies if it 
cannot locate the files in their original 
locations. See “Chief Architect Data” on 
page 53. 

Legacy Library Conversion
If you have Chief Architect  X7 library 
content, the initial startup of Chief Architect 
X8 will give you the option to migrate this 
content for use in Chief Architect X8. See 
“Migrating Library Catalogs” on page 15 of 
the User’s Guide. 

You can also import legacy .calib and .calibz 
files created in Chief Architect X4, X3, or 
X2  for use in version X8 at any time. See 
“Exporting Library Catalogs” on page 835.

In addition, legacy .alb files created in Chief 
Architect X1 and prior can be converted for 
use in version X8. 

To convert legacy library files

1. Select Library> Convert Legacy (.alb) 
Library Files. 

2. In the Select a Legacy Library File 
Folder dialog, select one or more .alb  
files that you want to bring in to Chief 
Architect X8.

3. The selected files’ names will display in 
the File name: field.

4. Click the Open button to import these 
prior version third party .alb files into 
the User Catalog.

5. Organize the imported content to suit 
your needs. See “Organizing the 
Library” on page 831.

Third Party Library Content
There are a variety of third party sources for 
3D symbols, textures and other items that 
may be of use in Chief Architect. Some 
sources even provide this content in .alb file 
format, which was the library file format 
used by Chief Architect versions 8.0 through 
X1. These third party libraries can be 
converted for use in Chief Architect X8 as 
described above. 

Adding Library Content
In addition to downloading Chief Architect 
Content and importing entire catalogs into 
the library, you can also add a variety of 
individual objects to the library. 

Add to Library
Nearly any object imported into a plan, 
converted into a symbol, or placed from the 

Note: Library content exported from Chief
Architect X3 will not include catalog names.
Any subscribed content from version X3 that
has not been downloaded will not be
included, either. 
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Library Browser can be added to the User 
Catalog in the library. 
• Check Add to Library in the Import 3D 

Symbol dialog. See “Importing 3D 
Symbols” on page 1184.

• Check Add to Library in the Convert to 
Symbol dialog. See “Convert to Symbol” 
on page 1206.

• Select an object in your plan and click the 

Add to Library  edit button.

A few objects cannot be added to the library: 
notably imported pictures, metafiles, and 
PDF files. With the exception of closed poly-
lines, which are added to the library as Mold-
ing Profiles, CAD objects cannot be added to 
the library either. These objects can be 
added, though, if they are part of a CAD 
block. See “CAD Blocks” on page 1111. 

Any object created using a drawing tool in 
Chief Architect will automatically be added 
to the User Catalog using the name of that 
tool, whereas a symbol will automatically 
use the Symbol Name. See “Native Objects 
vs Symbols” on page 841. 

Once added to the library, objects in the User 
Catalog can be renamed. See “Renaming 
Library Items” on page 832. 

Some objects, notably cabinets and doors 
with custom door styles, have other library 
objects inserted into them. See “Inserted 
Objects” on page 837. You can choose to add 
the containing object to the library, or the 
inserted object: 

• Click the Add to Library As  edit 
button to choose which symbol category 
to add the object to. Depending on your 
choice, either the inserted object is added 
to the Import library category, or the con-

taining object with the inserted one 
included is added. 

To use Add to Library As

1. Select an object that has another object 
inserted into it, such as a cabinet and 

click the Add to Library As  edit 
button.

2. In the Add to Library As dialog, select 
what part of the selected object should 
be added to the library. 

• In the case of a cabinet, select “Cabinet 
Doors and Drawers” to save the selected 
cabinet’s door style to the library rather 
than the entire cabinet.

• Or, select “Cabinet Modules” to save the 
entire cabinet, including its doors, draw-
ers and panels. 

3. If you selected more than one object for 

which Add to Library As  is avail-
able: 

•  The dialog will open separately for 
each different type of object selected.

•  The dialog will open just once if all 
selected objects are the of the same 
type.

Adding Materials and Images
New materials, images, plant images, and 
line styles can be created in the User Catalog. 
Right-click on the User Catalog or a folder 
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within it, select New> from the contextual 
menu, then select the type of item you wish 
to create from the submenu. 

Chief Architect can use materials and images 
in a variety of file formats and provides 
several means of adding new material and 
image files to the library. For more 
information, see “Creating Materials” on 
page 857 and “To create an image in the 
Library Browser” on page 1135. 

Adding New Backdrops
A backdrop is an image, typically of an 
exterior view, that displays in the background 
of 3D views to help place the model into a 
realistic setting and add a sense of 
perspective. See “3D Backdrops” on page 
1155. 

A new backdrop image can be created using 
a variety of graphic file formats and can be 
imported into Chief Architect in several 
ways: 

• Select File> Import> Backdrop  to 
open the Import Backdrop File dialog, 
which is similar to the Import Picture 
File dialog. See “Importing Pictures” on 
page 1143. 

• Right-click on the User Catalog and 
select New> Backdrop from the contex-
tual menu.

• Copy and paste an image into Chief 
Architect. See “Copying and Pasting 
Objects” on page 170. 

• Use the Screen Capture tools. See 
“Creating Screen Captures” on page 
1154. 

• Import a folder of backdrop images.

To add a folder of backdrops to the library

1. Select File> Import> Create Backdrop 
Library . 

2. Browse to the location of a folder of 
images on your hard drive that you 
would like to bring into the library as 
backdrops, select it, and click OK.

3. A folder with the same name will be cre-
ated in the User Catalog, containing the 
imported backdrop images. 

Adding 3D Symbols
An imported symbol can be added to the 
library in either of three ways.

• By selecting New> 3D Symbol  from 
the program menu. 

• By checking Add Symbol to Library 
during the symbol import process. See 
“Importing 3D Symbols” on page 1184.

• Using the Add to Library  edit tool 
after the symbol is placed in a plan. See 
“Add to Library” on page 829.

Organizing the Library
Library folders and objects can be copied, 
pasted, moved, and deleted: allowing you to 

organize your User Catalog to best suit your 
work style and needs. 
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Adding New Folders
New folders can be added to the User 
Catalog or to any folder located within it. To 
add a new folder, right-click on User Catalog 
or one of its sub-folders and select New> 
Folder from the contextual menu. 

The new folder is created inside the library 
item you right-clicked on and is initially 
named “Untitled”. Type a short, descriptive 
name and press Enter. 

Selecting Library Items
To select a library object, folder, or category, 
simply click on it. You can also multiple-
select library items:

•  To select a group of items, click on the 
first one, hold down the Shift key, then 
click on another file. The two files plus 
all files in between are selected.

•  To select multiple items individually, 
click on one, hold down the Ctrl key, 
then click on additional files. Only the 
files you click on are selected.

When an item is selected, preview images 
display in the Selection and Preview Panes 
and basic information about it also displays 

in the program’s Status Bar. See “The Status 
Bar” on page 42. 

A selected library item can be modified in a 
number of ways to help meet your 
organizational needs. When multiple items 
are selected, these options may be limited 
depending on the specific selection set. 

Renaming Library Items
Only folders and objects in the User Catalog 
can be renamed. There are several ways to do 
this from the tree list: 
• Right-click on the item, select Rename 

from the contextual menu, and type a 
new name. 

• Click once on the item, press F2 on your 
keyboard and type a new name.

• Click once on the item, pause for a 
moment, then click a second time and 
type a new name.

Library names are case-sensitive and can 
contain up to 63 characters. While you can 
have more than one library item that uses the 
same name, it is best to use short, descriptive 
and unique names.

Moving Library Items
Folders and objects in the User Catalog can 
be moved to new locations within the User 
Catalog. Folders and library objects are 
always organized alphabetically within each 
hierarchy.

To move one or more items to a different 
location, select it in the tree list, then click 
and drag it to the new location in the list. 
Directories and folders able to accept new 
content highlight as your mouse pointer 
moves over them. Release the mouse button 
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to relocate the selected library item in the 
highlighted location.

You can also cut one or more library items 
from one location and paste them in another. 
When an item is cut, it is removed from its 
current location and saved to the system 
clipboard. To cut an item:
• Right-click on it and select Cut from the 

contextual menu. 
• Click on the library item and press 

Ctrl + X on your keyboard.

To Paste the item, click on a library catalog 
or folder in the Library Browser tree view 
and either:
• Right-click on the new location and 

select Paste from the contextual menu.
• Press Ctrl + V on your keyboard. 

Copying Library Items
All library folders and library objects can be 
copied and pasted to new locations in the 
User Catalog. 

There are two ways to copy one or more 
library items to the system clipboard: 
• Right-click on it and select Copy from 

the contextual menu. 
• Click on the library item and press 

Ctrl + C on your keyboard.

To Paste the item, click on a library catalog 
or folder in the Library Browser tree view 
and either:
• Right-click on the new location and 

select Paste from the contextual menu.
• Press Ctrl + V on your keyboard. 

When a library item is copied and pasted, the 
new item that results is independent of the 

original item. If you make changes to it, the 
original item is unaffected. Similarly, 
changes to the original item do not affect the 
copy.

Library Shortcuts
In addition to copying and pasting to create 
new, independent library items, you can copy 
and paste to create Library Shortcuts. Library 
Shortcuts are not independent items - they 
are linked to the original item and are 
affected if changes are made to the original.

Library Shortcuts are advantageous because 
you can place a given library item in multiple 
locations to suit your organizational style 
without increasing the size of the library 
database and without having to maintain 
multiple copies of the same item.

To create a Library Shortcut, copy a library 
item to the system clipboard. Then, right-
click on the location where you would like to 
create a copy and select Paste Shortcut from 
the contextual menu. Library Shortcuts use 
the same name as their source item but use 

the Library Shortcut  icon.

To locate a Library Shortcut’s source item, 
right-click on it in the tree list and select 
Locate Shortcut Source 

If you move or delete an item from the 
library, any shortcuts to it will not be updated 
or removed. If you try to use a “hanging” 
shortcut, a message about its status will 
display in the library preview panes.

Deleting Library Items
The five installed library categories: Chief 
Architect Core Catalogs, Chief Architect 
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Bonus Catalogs, Manufacturer Catalogs, 
User Catalog, and Trash cannot be deleted. 

Catalog level folders in all categories can be 
deleted; however, individual subfolders and 
objects can only be deleted out of the User 
Catalog.

Items in the library that are eligible for 
deletion can be deleted in either of two ways: 
• Right-click on it and choose Delete from 

the contextual menu.
• Select it and press the Delete key on your 

keyboard.

When items from the User Catalog are 
deleted, they are moved to the Library 

Browser Trash . Items in the Trash can be 

retrieved by clicking and dragging them into 
any location in the User Catalog.

To empty the Trash , right-click on it and 
select Empty Trash from the contextual 
menu. 

Depending on how much content is in the 
Trash, emptying it can be time consuming. 
You can click the Cancel button to end the 
process if you wish. 

Filtering the Display of Library Content
Depending on how much library 
content you have imported or 

customized, the tree list in the Directory 
Pane can be very large. You can control what 
content displays in the list using Library 
Filters. 

Library Filters do not remove content from 
the library database. They do, however, 
affect the library Search: unless you check 
Include Filtered in the advanced Search 
options, library content that is not displaying 
is not included in your searches. 

You can also set up filters for your library 
Search results, but these two types of filters 
are unrelated. See “To search using custom 
filters” on page 824. 

Library filters can be created, edited, and 
deleted in the Manage Library Filters dialog. 

Click the Manage Library Filters  
button at the top of  the Library Browser to 
open this dialog or select Library> Manage 
Library Filters  from the menu.

Any library filters that you create will be 
listed in the Active Filters list at the top of 
the Library Browser. Select a filter from the 
list to display content in the library tree list 
according to its settings. See “The Library 
Browser” on page 820. 

The Empty Trash command is both
immediate and permanent. It cannot be

undone, so use care when using it. You
should back up all your library files regularly.
See “Backing up Library Content” on page
826. 

You can also add the Manage Library
Filters button to your toolbars and
assign a hotkey to it. See “Toolbars and

Hotkeys” on page 129. 
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Manage Library Filters Dialog

A list of available library filters 
displays here. Click on a name in the 

list to select it. The Selected Filter is 
highlighted and can be edited using the 
options to the right.

Click the New button to create a new 
filter or click the Delete button to 

remove the Selected Filter from the list.

Select the Active Filter from the drop-
down list. This is the filter in use in the 

Library Browser when the Manage Library 
Filters dialog is closed. 

Specify the Name of the Selected 
Filter. 

A list of all Chief Architect Core, 
Chief Architect Bonus and 

Manufacturer Catalogs installed in your 
library display here.
• Check the box beside a library catalog’s 

name to prevent it from displaying in the 
Library Browser Directory Pane tree list. 

• Click the Select All button below either 
list to prevent all catalogs in that list from 
displaying in the Directory Pane tree list. 

• Click the Clear All button below either 
list to include all catalogs in that list in 
the Directory Pane tree list. 

Exporting Library Catalogs
Exporting library files allows you to: 
• Back up your custom library content.

• Transfer library content between comput-
ers.

1

2

3

4

5
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• Share custom library content with col-
leagues.

Exporting is often preferable to simply 
copying library files because it allows you to 
include images and textures in the exported 
library. 

To export content from the library

1. Locate an object, folder, or catalog that 
you want to export, right click on it, and 
select Export Library.

2. In the Export Library Data dialog.
•  Choose the appropriate Save in: loca-

tion for your exported library file.

•  Type a short, descriptive name for your 
library file in the File Name field.

•  Click the Save as type: drop down list 
and select whether or not you want the 
library to include Textures/Images.

•  Click Save.
3. Your exported library file can now be 

copied to a network location or storage 
device in an operating system window. 

Placing Library Objects
Library objects are subject to placement 
restrictions based upon typical real-life 
placement. Most library objects require 
sufficient free space at the location where 
they are placed, for example, and some 
library objects have additional requirements.

Library windows and doors, for example, 
must be placed in a wall just like standard 
windows and doors, and some fixtures are 
designed to be placed in cabinets.

Library symbols have placement restrictions 
that are determined when the symbol is 
created but can be changed later. See “Native 
Objects vs Symbols” on page 841 and 
“Symbol Specification Dialog” on page 
1195.

If a warning message displays when placing 
a library object or symbol, it will indicate 
where the object can be placed. 

There are three main categories of items 
available in the Library Browser:
• Stand-alone objects that can be placed 

directly into a plan. Examples include 
cabinet modules, furnishings and images.

• 3D objects designed to be inserted into 
another 3D object. Examples include 
cabinet fixtures, windows and doors. 
Some items, such as cabinet doors and 
fixtures and fence panels, can be inserted 
into another object or placed as stand-
alone objects. 

• Materials, line styles and molding pro-
files, which cannot stand alone and must 
be assigned or applied to another object.

Stand-Alone Objects
Most library categories contain objects that 
can be selected in the Library Browser and 
placed directly in a 2D or 3D view. 

If any of the items being exported are
images or use textures, be sure to
select the .calibz file type.
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• Most stand-alone objects are designed to 
rest on the floor or terrain.

• Some objects will rest on top of a cabinet, 
shelf, furniture or roof plane object if one 
is located at the point where they are first 
placed.

• A few objects, notably some light fix-
tures, will mount on the bottom of a wall 
cabinet or on the ceiling.

• In addition, some objects will attach to a 
wall if one is nearby.

To place a stand alone library object

1. Click on an object in the tree view or 
Selection Pane of the Library Browser to 
select it for placement. See “The Library 
Browser” on page 820. 

2. Move your mouse pointer into the view 
area and notice that it displays an icon 
indicating the type of object selected 
instead of an arrow.

3. Click to place the selected object at that 
location. 

4. Continue clicking to place as many 
instances of the selected object as 
needed. When you are finished, click the 

Select Objects  button. 

Once a stand-alone object has been placed, it 
can be edited in a variety of ways. See 
“Editing Library Objects” on page 841.

Inserted Objects
Some objects cannot stand alone and must be 
placed into other objects in a plan. For 
example, doors and windows must be 
inserted into a wall, while some appliances 

and plumbing fixtures are designed be placed 
inside a base cabinet. See “Doors” on page 
361, “Windows” on page 391 and “Cabinets” 
on page 675.

An inserted object can only display in a 2D 
or 3D view if the object that contains it is set 
to display. This is the case even if the 
inserted object’s layer is turned on. See 
“Displaying Library Objects” on page 840. 

To insert a library object

1. Click on an object in the tree view or 
Selection Pane of the Library Browser to 
select it for placement. See “The Library 
Browser” on page 820. 

2. Move your pointer into the drawing 
area.

3. Click on the object into which you wish 
to insert the selected library item. The 
library item is inserted into the object.

4. Continue clicking to place as many 
instances of the selected item as needed. 
When you are finished, click the Select 
Objects  button.

If you try to insert an object into another 
object that is on a locked layer, nothing will 
be created. See “Object Creation and Layers” 
on page 170.

Assigned Items
Some library items, such as moldings and 
materials, are not objects in themselves but 
can be applied to objects in a variety of ways.
• Using the specification dialog of the con-

taining object. See “Select Library Object 
Dialog” on page 838.
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• By selecting the item in the library and 
then clicking on the containing object in 
floor plan view.

• Materials can be assigned to objects 
directly from the library in 3D views or 
by selecting the material and then 
clicking on an object’s surface. See “The 
Material Painter” on page 849.

• Moldings and Line Styles can also be 
added to a plan by selecting the desired 
library item, then clicking and dragging a 
line in the drawing area. The result is 
either a Molding Line or CAD Line, 
depending on the selected library item. 
See “Molding Polylines” on page 664.

Select Library Object Dialog
The Select Library Object dialog is a modal 
version of the Library Browser that is 
accessible from object specification dialogs. 
See “Specification Dialogs” on page 41. 

The Select Library Object dialog only 
displays categories of items that are related 
to the selected object. For example, if the 

dialog is accessed from the GENERAL panel 
of the Door Specification dialog, only door 
symbols will be listed: 

The Select Library Object dialog is similar 
to the LIBRARY MATERIALS panel of the 
Select Material dialog. See “Select Material 
Dialog” on page 854.

Place Library Object Button
The Place Library Object button can 
be added to your toolbar and used for 

quick access and placement of frequently 
used library items. 

If the Place Library Object  button has 
not yet been assigned a library object, click it 

once to open the Library Object Button 
Specification dialog. 

Double-click a Place Library Object  
button that has been assigned a library object 
to open the Library Object Button 
Specification dialog.
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Click the Library button to open the 
Select Library Object dialog and 

assign a library object to the button. If a 
library object has already been assigned, 
click this button to assign a new library 

object. See “Select Library Object Dialog” 
on page 838.

When a library object has been 
selected, type a Button Name in the 

text field. 

When a library object has been 
selected, assign a Button Icon. Choose 

from two automatically generated button 
icons or click Browse to browse your 
computer for a different icon.

Up to 100 Place Library Object  buttons 
can be added to the same toolbar, each 
assigned a different object.

The library object assigned to the Place 
Library Object  button is actually saved 
with that particular button. If you move or 
delete the library item from the library, the 
button will continue to function.

Replace From Library
The Replace From Library edit 
button is available for nearly any 

object that can be added to the library and 
can be used in 2D and 3D views. Click this 
button to open the Replace From Library 
dialog and replace the selected object, and 
others like it if you choose, with an object of 
the same type from the library. 

Select one of the Replacement 
Options.

• Select Replace Selected Object to 
replace only the currently selected object.

1

2

3

1
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• Select Replace Identical Objects in 
Room to replace all objects that are in the 
same room as, and are identical to, the 
currently selected object. Not available 
for doors or windows. 

• Select Replace Identical Objects on 
Floor to replace all objects that are on the 
same floor as, and are identical to, the 
currently selected object. 

Click the Library button to open the 
Select Library Object dialog and select 

an object to use as a replacement. The name 
of the object that is currently selected as a 
replacement displays above.

Replace From Library  cannot be used 
to replace a selected wall or a selected 
cabinet with a cabinet of a larger size. In 
addition, it is not available for backdrops and 
items assigned to other objects, such as 
materials. 

Displaying Library Objects
The display options available for library 
objects depend on the type of object in 
question, as well as the view.

If the display of an object is turned off in a 
2D or 3D view, any objects inserted into it 
will not display in that view, either - even if 
the inserted object’s layer is turned on. See 
“Inserted Objects” on page 837. 

In Floor Plan View
All library objects except materials, doors 
and drawers applied to cabinets, and 
backdrops can display in floor plan view. 
Library objects are represented in floor plan 
view by 2D CAD blocks that resemble the 
size and shape of the object when viewed 
from above. To learn how to specify the 
symbol that represents an object, see “2D 
Block Panel” on page 1199.

As with other architectural objects, the 
display of library objects is controlled by 

layer in the Layer Display Options dialog. 
Each library category has its own layer.  See 
“Layer Display Options Dialog” on page 
149.

Symbols belong to one of three drawing 
groups that influence which objects display 
in front of others in floor plan view. You can 

click the Move to Front of Group  edit 
button to display a selected symbol in front 
of over symbols or architectural blocks. See 
“Drawing Groups” on page 218.

Object Labels
Fixtures, Furnishings, Geometric Shapes, 
Hardware, Millwork, Architectural Blocks 
and Plants can display labels in floor plan 
and cross section/elevation views when the 
appropriate layer is set to display in the 
Layer Display Options dialog. For example, 
fixture labels are placed on the “Fixtures, 

2

If the Replace from Library edit tool is
used to replace an electrical object, any

Connect Electrical splines attached to it will
be deleted. See “Connect Electrical” on page
642.
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Labels” layer. See “Object Labels” on page 
1279.

Object labels have their own edit handles and 
can be moved and rotated when the object is 
selected. Library object labels use the Text 
Style assigned to their layer. See “Text 
Styles” on page 1061.

You can specify a custom label for many 
library objects in the Symbol Object 
Specification dialog. See “Symbol Object 
Specification Dialogs” on page 844. 

In 3D Views
All library objects except CAD blocks can 
display in 3D views. 

By default, images rotate to face the camera 
in 3D views. For information about turning 

off image rotation, see “Image Specification 
Dialog” on page 1137.

Doors, windows and cabinets from the 
library may also display opening indicators 
in Vector Views when the “Opening 
Indicators” layer is turned on. See 
“Displaying Objects” on page 144. 

In the Materials List
Most library objects are counted in the 
Materials List, as are any comments added to 
the Components dialog for a library object. 
See “Components Dialog” on page 1300.

Editing Library Objects
Like native Chief Architect objects, library 
objects can be customized to suit your design 
needs. There are three approaches to editing 
library objects:
• Select an object in the User Catalog, edit 

it using any of the options in its contex-
tual menu, and your changes will be 
reflected when you next place this library 
object in a drawing.

• Place an object in a drawing and then edit 
it using the various edit tools available 
for it. This will not affect the original 
object still saved in the library.

• Place an object in a drawing, edit it using 
the available edit tools, and then add it 
back to the library for future use. This 
will not replace the original object still 

saved in the library. See “Add to Library” 
on page 829.

Library objects placed in a drawing can be 
selected individually or as a group, like other 
objects in Chief Architect. See “Selecting 
Objects” on page 183. 

Once selected, library objects can be edited 
in a variety of ways using dimensions, the 
edit handles, the edit toolbar buttons and the 
specification dialog. See “Symbol Object 
Specification Dialogs” on page 844. 

Native Objects vs Symbols
In Chief Architect, objects created using the 
program’s standard tools, such as the Door 

Note: Although the size and materials of
many library objects can be edited, these
changes are not reflected in the Materials
List. See “Materials Lists” on page 1283.
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Tools  and Cabinet Tools , are 
referred to as native objects. 

On the other hand, objects placed from the 
library, such as fixtures and furnishings, are 
symbols. Symbols are typically more limited 
than native objects in how they can be edited.

In addition to the symbols available in the 
library, you can import additional symbols 
into the program from 3D .dxf, .dwg, .obj, 
.3ds or .skp files. See “Importing 3D 
Symbols” on page 1184. 

Any changes made to objects like fixtures 
and furniture will not be reflected in their 
Materials List Description, although they 
may be seen in other columns, such as Size. 
See “Materials Lists” on page 1283. 

You can change a symbol’s name, which is 
used in its Materials List Description, in the 
Symbol Specification dialog. You can also 
change the names of its components. See 
“3D Panel” on page 1196 and “Materials 
Panel” on page 852.

Remove Manufacturer Lock
Manufacturer symbols are limited in 
the ways that they can be edited. After 

such a symbol is placed in a plan, select it 
and click the Remove Manufacturer Lock 
edit button to remove the manufacturer data 
so that it can be edited like other symbols.

Using Edit Handles
Most library symbols are box-based objects 
and can be edited as such once placed in a 
drawing. See “Editing Box-Based Objects” 
on page 206. Depending on the type of view 
and the surface selected, the edit handles a 
symbol displays will vary. 

When a furnishing or fixture symbol is 
selected in floor plan view or on the top 
surface in a 3D view, up to ten edit handles 
display. They are the Move handle at the 
center, the Rotate handle just outside the 
front indicator (a V) and a Resize handle on 
each edge and at each corner. 

When a symbol is selected on a side in a 
cross section/elevation or 3D view, it 
displays five edit handles: the Move handle 
and a Resize handle on each edge. 

Symbols cannot be concentrically resized, 

even when the Concentric  edit behavior 
is enabled. See “Edit Behaviors” on page 
178. 

The labels of library cabinets, electrical, 
furnishings and fixtures, when displayed, 
have a separate Move edit handle that 
displays when the object is selected. 

Fixtures and furniture placed in a plan are 
subject to bumping/pushing behavior when 
moved. See “Bumping/Pushing” on page 
221.

In the Specification Dialog
The specification dialog for any symbol, 
image, material, or plant image in the library 
can be edited from the Library Browser 
Directory Pane. See “Specification Dialogs” 
on page 41. 

Specification dialogs are not available for 
native objects saved in the library. 

To open the Symbol Specification dialog, 
click on a symbol name in the tree view of 
the Library Browser and select Library> 
Open. See “Symbol Specification Dialog” 
on page 1195.
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Deleting Built-in Fixtures 
and Appliances

A fixture installed into the front of a cabinet 
becomes a cabinet face item, like a door or 
drawer. It can be resized or deleted like other 
face items in the Cabinet Specification 
dialog. See “Front/Sides/Back Panel” on 
page 701. 

Components
Many architectural objects have a 
Components dialog that lets you 

control how that object displays in the 
Materials List. In the Library Browser 
Directory Pane, right-click on a symbol and 
select Components to open the 
Components dialog. See “Components 
Dialog” on page 1300. 

Changes made to the Components of an 
object saved in the library do not affect 
instances of that object already placed in a 
plan: they are only applied to instances of the 
object placed in the future. 

Once placed in a plan, many objects have a 

Components  edit tool that allows you to 
make changes to that object’s Components 
without affecting the symbol in the library. 

Terrain objects, CAD blocks, moldings, 
images, backdrops, and materials do not 
display in the Materials List.

Search Attributes
The Search Attributes dialog lists the 
keywords and styles associated with a 

selected library object. Keywords and styles 
can be used to locate the object when 
performing a library search. See “The 
Library Browser” on page 820.

To open the Search Attributes dialog, right-
click on an item in the User Catalog and 
select Search Attributes from the contextual 
menu. See “Using the Contextual Menus” on 
page 822.

Any searchable Keywords associated 
with the object display in the list. Click 

in the list box and type in any additional 
keywords that you would like to use. Each 
keyword should be on its own line in the list.

Check the box beside any Styles that 
you want to associate with the object.

1

2
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Symbol Object Specification Dialogs
The Fixture, Furniture, Geometric 
Shape, Hardware, Millwork 

Sprinkler, and Plant Specification dialogs 
all feature the same options. The actual name 
of the dialog is determined by the type of 
object that is currently selected. 

For example, selecting a library object 
placed from the Interiors Core Catalog and 

clicking the Open Object  edit button 
opens the Furniture Specification dialog. 

Many library symbol objects can also be 
edited in the Symbol Specification dialog. 
See “Symbol Specification Dialog” on page 
1195.

General Panel

The Name of the selected symbol 
object displays here.

Size/Position - 

• Specify the Height, Width, and Depth of 
the object.

1 2
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• Check Retain Aspect Ratio to maintain 
the ratio between the object’s Height, 
Width, and Depth when it is resized in the 
specification dialog. Does not affect the 
behavior of the object’s edit handles. 

• Click Reset Size to reset the symbol’s 
original, unmodified size. The Floor to 
Bottom value, below, is not affected by 
this button.

• Select the Elevation Reference from the 
drop-down list. This determines where 
the next two settings are measured from 
and also affects their setting labels.

• Specify the height to Top, measured from 
the selected Elevation Reference to the 
top of the object.

• Specify the height to Bottom, measured 
from the selected Elevation Reference to 
the bottom of the object.

The Sprinkler Settings are only 
available if the selected object is a 

sprinkler. See “Sprinkler Tools” on page 774. 
• Specify the Spray Angle, which is the 

angle within which the sprinkler sprays. 
An angle of 360° sprays in a complete cir-
cle.

• Specify the Spray Radius, which is the 
distance from the sprinkler head that the 
spray reaches. 

Options - 

Check Reverse Symbol to reverse the 
object’s appearance, so that features on its 
left are positioned on its right, and vice versa. 

This turns a right-hand refrigerator, for 
example, into a left-hand refrigerator. This 
option has no effect on objects that are 
symmetrical. 
• Check Include in Schedule to include 

the selected symbol(s) in the schedule 
associated with that type of object. See 
“The Schedule Tools” on page 1268. 

• Check Flush Mounted to specify that the 
selected object follow the pitch of either 
the ceiling or roof. Only available when 
“From Ceiling” or “From Roof” is 
selected as the Elevation Reference, 
above. 

If the selected object has a Copyright, 
information about it displays here.

A preview of the selected library object 
displays here and updates with changes. 

If the selected symbol is inserted into another 
object, such as an appliance in a cabinet, the 
parent object will also display.  See “Dialog 
Preview Panes” on page 41.

Layer Panel
For information about the settings on this 
tab, see “Layer Panel” on page 154.

Fill Style Panel
The FILL STYLE panel is available when the 
selected object is a sprinkler and controls 
how the area within its spray radius displays 
in floor plan view. It is similar to the FILL 
STYLE panel found in many dialogs. See “Fill 
Style Panel” on page 1099. 

Materials Panel
For information about the settings on this 
tab, see “Materials Panel” on page 852.

Note: Some very thin custom symbols may
have a Height, Width, or Depth value of 0. In
these cases, the 0 value cannot be edited. 

3

4
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Label Panel
A variety of library objects can display labels 
in floor plan view and cross section/elevation 
views. Labels use the Text Style assigned to 
the layer they are on.

For information about the settings on this 
tab, see “Label Panel” on page 1280.

Manufacturer Panel
If the selected symbol or material is from a 
Manufacturer’s catalog, the MANUFACTURER 
panel lists contact information about the 
manufacturer. See “Manufacturer Catalogs” 
on page 826.

Fixture and Furnishing Schedules
The Fixture and Furnishing 
Schedule tools allow you to 

produce customizable fixture and furnishing 
schedules as well as fixture and furnishing 
labels that display schedule numbers. See 
“The Schedule Tools” on page 1268.

Fixture schedules in particular can be 
customized for specific purposes: for 
example, to create appliance, plumbing, or 
HVAC schedules. See “Working with 
Multiple Schedules” on page 1272.
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Chapter 27:

Materials

The objects used in Chief Architect have a 
variety of 3D properties. These objects - 
walls, windows, doors, cabinets, roof planes, 
lot perimeters, etc. - can have materials 
assigned to them so that they look realistic in 
3D views. These materials can also be used 
to generate materials lists that can help with 
cost estimations. 

Designing with objects that look correct in 
3D and calculate properly in the Materials 
List requires that you use realistic material 
definitions and apply them appropriately to 
objects in your plan.

Chief Architect comes with many materials 
that are ready for use. From siding, roofing, 
flooring, masonry, tile, and paneling, to road 
surfaces, grass, water, and wood materials, 
Chief Architect has materials for every 
application, inside and out. If you cannot find 
a material that suits your needs, you can 
customize the materials provided or create 
your own.

Learning how to create, manage, apply, and 
edit materials saves time and adds that 
professional touch to your designs.

Chapter Contents
•      About Materials
•      Material Defaults
•      The Material Painter
•      Materials Panel
•      Select Material Dialog
•      Viewing Materials
•      Editing Materials
•      Creating Materials
•      Mapping Patterns and Textures
•      Material Types
•      Managing Plan Materials
•      Define Material Dialog
•      Color Chooser/Select Color Dialog

Redefining only the visual properties of a
material may create unexpected results.

For example, changing the image of a brick
material to represent siding does not cause
the material to be considered as siding during
material calculations.
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About Materials
The materials that are assigned to objects in 
Chief Architect perform two important roles:
• They determine what the surfaces of 

objects look like in 3D views. 
• They influence how objects are calculated 

in the Materials List. See “Materials 
Lists” on page 1283.

Materials are stored in the Materials library 
in the Library Browser and can be applied to 
objects in either of two ways:

• Using the Material Painter . 
• In an object’s specification dialog. See 

“Materials Panel” on page 852.

Patterns and Textures
In Chief Architect, materials have two 
attributes that determine what they look like 
in 3D views: Textures and Patterns.
• Textures are created using special image 

files that tile seamlessly when applied to 
surfaces and are visible in Ray Trace 

views and most Rendering Techniques. 
See “In Rendered Views” on page 909.

• Patterns are composed of CAD lines and 
are seen in Technical Illustration, Line 
Drawing and Vector Views. See “Render-
ing Techniques” on page 951.

Unlike textures, patterns are associated with 
a Type that determines if and how materials 
are calculated in the Materials List.

Material Types
Every material is classified by Type, which 
defines how the material is calculated in the 
Materials List. Not every Type is calculated 
in the Materials List; however, most 
determine whether a material is counted by 
piece, area, volume and so on. See “Material 
Types” on page 860.

Some Types are associated with patterns. 
Only Chief Architect Pattern Types are 
figured in the Materials List. If a .pat file is 
selected, the pattern type is listed as Custom. 
See “Pattern Panel” on page 867.

Material Defaults
Most objects in the program have 
defaults dialogs which allow you to 

set up a variety of attributes, including 
materials, before the objects are created. 
These defaults dialogs are accessed by 
selecting Edit> Default Settings. See 
“Preferences and Default Settings” on page 
73.

Material defaults are dynamic, which means 
that if you change a particular material in a 

defaults dialog, all objects of that type that 
are set to use that default will automatically 
update to use the new material. See 
“Dynamic Defaults” on page 76. 

Default materials can be identified on the 
MATERIALS panel of an object’s specification 
dialog. When a component is selected in the 
tree list, a default material’s name will be 
preceded by the word “Default:”. See 
“Materials Panel” on page 852. 
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Material Defaults Dialog

Select Edit> Default Settings  from the 
menu, select “Materials”, and click the Edit 
button to open the Material Defaults dialog. 

The Material Defaults dialog serves two 
purposes. It allows you to:
• Set the default materials for objects that 

do not have a defaults dialog. Fireplaces 
and furnishings from the library are 
examples of objects that do not have a 
defaults dialog. 

• Set the initial materials that can then pop-
ulate a variety of defaults dialogs for 
objects that do have them. Door, Window, 
and Cabinet Defaults are examples of 
defaults dialogs that can draw their mate-
rial assignments from the Material 
Defaults dialog. 

Because material defaults are Dynamic 
Defaults, you can use the Material Defaults 
dialog to apply a material to multiple objects 
that share similar components. For example:
• The “Room Moldings” Material Default 

applies to the base, crown, and chair rail 
moldings that can be assigned to rooms, 
as well as to interior door and window 
casing. If you change this Material 
Default, all of these objects in the plan 
can be affected.

• The “Cabinet”, “Cabinet Door/Drawer”, 
“Countertop”, and “Hardware” Material 

Defaults can be used in your Cabinet 
Defaults dialogs to ensure that all cabi-
nets use the same materials. See 
“Dynamic Cabinet Defaults” on page 676. 

The settings here are similar to those on the 
MATERIALS panel found in object 
specification dialogs throughout the 
program. See “Materials Panel” on page 852.

• Select a category from the scrollable list. 
• Click the Select Material button or either 

material preview box to open the Select 
Material dialog. See “Select Material Dia-
log” on page 854.

The Material Painter
Select 3D> Material Painter to 
access the Material Painter Tools, 

which are used to apply materials to object 

surfaces in 3D views. The Material Painter 
tool can also be activated by selecting a 
material in the library while a 3D view is 
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active. The Material Painter tools are not 
available in Glass House views. See “Glass 
House” on page 952.

Material Painter Modes
There are five Material Painter Modes. Each 
mode specifies how broadly or narrowly the 
selected material will be applied to surfaces 
in your plan. 
• The Material Painter Component Mode 

 is the default mode and applies the 
selected material to an object component. 
For most types of objects, using this tool 
is the same as opening an object’s specifi-
cation dialog and changing the material of 
one of its components on the MATERIALS 
panel. See “Materials Panel” on page 852.

• The Material Painter Object Mode  
applies a material to all components of an 
object that share the same material assign-
ment. 

• The Material Painter Room Mode  
applies a material to all the objects in the 
room that currently have the same mate-
rial. For example, if you apply a material 
to a dining room chair, this mode applies 
the material to all other objects in the 
room with the same original material, 
such as other chairs and the dining table.

• The Material Painter Floor Mode  
applies the selected material to all sur-
faces on the floor that currently have the 
same material. For example, if you apply 
a material to the kitchen countertops 
using this mode, the bathroom counter-
tops on the same floor also have the mate-
rial applied.

• The Material Painter Plan Mode  
applies the selected material to all sur-
faces in the entire plan that currently have 
the same material. For example, if you 
have the same carpet on all floors in a 
plan, applying a selected material while 
this mode is active will change all carpet 
on all floors. 

When the Material Painter  tool is 
active, the Material Painter Mode toolbar 
buttons display in the edit toolbar, allowing 
you to quickly change modes.

You can also specify the active mode by 
selecting 3D> Material Painter. A check 
displays next to the active mode in the 
submenu.

If you use the Material Painter to change
a room’s floor or ceiling finish material, it

will add that material to the room’s Floor or
Ceiling Finish Definition. Changes to a Deck
room’s planking or framing will affect its floor
structure definition. See “Floor and Ceiling
Platform Definitions” on page 344. 
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Blend Colors With Materials
In addition to the Material Painter 
Modes, the Blend Colors With 

Materials option allows you to apply a solid 
color to a surface displaying a pattern or 
texture and blend the two. 

Blend Colors With Materials  works in 
all five Material Painter Modes. See 
“Blending Materials” on page 858.

To use the Material Painter tool

1. Create a 3D view in which the patterned/
textured material is visible.

2. Select 3D> Material Painter> Mate-
rial Painter . 

3. Select a solid color material from the 
Select Library Object dialog. See 
“Select Library Object Dialog” on page 
838.

•  Check Use Default Material at the 
bottom left of the dialog to apply the 
default material to any object that has a 
defaults dialog. See “Material 
Defaults” on page 848.

4. Select a Material Painter Mode from the 
edit toolbar, which displays at the bot-
tom of the program window when the 
Material Painter is enabled.

5. Click the Blend Colors With Textures 

 edit button to turn this feature on or 
off depending on your needs.

6. Note that the name of the material being 
painted displays on the left side of the 
Status Bar at the bottom of the program 
window. See “The Status Bar” on page 
42. 

•  Move your pointer over a surface in the 
3D view. The Status Bar now states 
both the material being painted and the 
current material on the target surface.

7. Click on the surface to apply the 
selected material to that surface. The 
material is applied to surfaces in the 
model based on the active Material 
Painter Mode. 

•  When both the Material Painter  
and Blend Colors With Textures  are 
active, the cursor displays a paint roller 

icon .

•  When the Material Painter  is 
active and Blend Colors With 
Textures  is not, the cursor displays 

a spray can icon . 

8. If either the Component  or Object 
Mode  is active, you can continue to 
click on surfaces to apply the selected 
material. When you are finished, select a 
different tool. 

Material Painter and Walls
Painting walls is an obvious use for the 

Material Painter ; however, it is 
important to note that the Material Painter 
Modes affect walls and rooms somewhat 
differently than they do other objects: 
particularly if a wall defines multiple rooms 
on the side that is being painted.

• Component  and Object Modes  
only paint the section of the wall that 
defines the room located where you click 
to apply a new material. Sections of the 
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same wall that define other rooms are 
unaffected. 

• Room Mode  applies the material to 
all walls and solid railings that define the 
room where you click provided that they 
have the same original surface material as 
the one being painted. Any other objects 
in the room with that original material are 
also affected, but railings are not unless 
they are specified as Solid. 

• Floor  and Plan Modes  apply the 
material to all walls, all railings, and any 
other objects with the same original sur-
face material as the one being painted: 
either on the current floor, or throughout 
the plan.

Material Eyedropper
The Material Eyedropper tool 
allows you to load the material 

assigned to an existing object and apply that 
material to other objects.

In a 3D view, select 3D> Material Painter> 
Material Eyedropper  and then move 
your mouse pointer over a surface in the 
view. The name of the material on that 
surface is stated on the left side of the Status 
Bar. Click on the surface to load its material 
assignment. The pointer then changes to 
indicate that the material is ready to be 
applied to another object using the Material 
Painter  tool. Depending on the currently 
active Material Painter Mode, you can 
continue to apply the material to the surfaces 
of other objects.

Materials Panel
The specification dialogs for most objects 
include a MATERIALS panel. Select an object 
or a group of similar objects and click the 

Open Object  edit button to open the 
specification dialog for that selection. 

On the MATERIALS panel, you can specify 
material assignments for the components that 
make up that object. When a new material is 

assigned, the appearance of the preview 
image on the right side of the dialog updates. 

If the selected object is using a material that 

is missing its texture, a Caution  symbol 
will display next to the Materials panel name 
in the list on the left side of the object’s 
specification dialog. See “Referenced Files” 
on page 68.

Note: Wall materials applied using the Mate-
rial Painter tool are not calculated in the
Materials List.
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The table on the left side of the panel 
lists the components of the selected 

object that can be assigned unique materials, 
along with the names of those materials and 
whether or not the default materials are used. 
Some objects may have only one component 
while more complex objects may have many. 
As changes are made to the selected object, 
components may be added to or removed 
from this table. 
• Click on a Component in the table to 

select it. 
• The selected component’s Material is 

stated in the list, to the right of the com-
ponent name. If the component is using 
the default material, the name will be pre-
ceded by the word “Default:”. If it is 
using a Material Default, it will be pre-
ceded by the word “Default” followed by 
the name of an object type. See “Material 
Defaults” on page 848.

• If the selected component belongs to a 
symbol object from the library, you can 
click on it a second time to rename it. See 
“Native Objects vs Symbols” on page 
841.

The two boxes to the right of the table 
display previews of the color, pattern, 

and texture of the material assigned to the 
selected component. If “No Texture” 
displays in the preview window, the material 

has no texture assigned to it; if a Caution  
symbol and the words,“Texture Missing” 
display, the texture file could not be found on 
the system. 

1

Note: If the selected object is a wall or a room
modified using the Material Painter, a compo-
nent’s Material may be described as “No
Change”. See “Material Painter and Walls” on
page 851.

2
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• Click Select Material to open the Select 
Material dialog. Choose a material and 
click OK to assign that material to the 
selected component. See “Select Material 
Dialog” on page 854. 

A preview of the selected object 
displays on the right side of the panel. 

To view material textures, select Standard 
as the View Type; to view material patterns, 
select Vector View. See “Dialog Preview 
Panes” on page 41. 

Select Material Dialog
The Select Material dialog allows you to 
select a material to apply to one or more 
objects and is opened by clicking the Select 
Material button on the MATERIALS panel of 
most specification dialogs or by using the 

Material Painter . See “Materials Panel” 
on page 852 and “The Material Painter” on 
page 849. 

Depending on how it is accessed, the Select 
Material dialog will have either two or three 
panels:

• The Library Materials Panel allows you to 
select materials from the Library Browser.

• The Plan Materials Panel panel lets you to 
select materials from the Plan Materials 
dialog.

• The Material Defaults Panel lets you 
associate an object component with a 
Material Defaults category rather than a 
specific material and is only available 
when the component of a library symbol 
is selected on the MATERIALS panel of the 
object’s specification dialog.

Library Materials Panel
The LIBRARY MATERIALS panel is a modal 
version of the Library Browser that lists only 
materials. See “The Library Browser” on 
page 820.

The settings on this panel are also found in 
the Select Library Object dialog. See 
“Select Library Object Dialog” on page 838.

3
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The LIBRARY MATERIALS panel has most of 
the functionality that the Library Browser 
has: including the search and search filtering 
options, the toggleable, resizable Preview 
and Selection Panes, and the Toggle Preview 
Display  button.
• To locate a material, either search using 

keywords or browse the tree list. See 
“Searching the Library” on page 824.

• To apply a material to an object, either 
click on the material and click OK or 
double-click on the item in the Selection 
Pane. 

• Click the Add New Material  button 
to open the Define Material dialog and 
create a new material saved in the user 
Catalog. See “Define Material Dialog” on 
page 864.

• Check Use default material to apply the 
default material to the selected object, if 
one exists. See “Material Defaults” on 
page 848. 

Plan Materials Panel
The PLAN MATERIALS panel is similar to the 
Plan Materials dialog and lets you select 
from a list of materials already present in the 
plan as well as manage that list. See “Plan 
Materials Dialog” on page 863. 
• Select “Use Default” from the top of the 

list to apply the default material to the 
selected object, if one exists.

Material Defaults Panel
The MATERIAL DEFAULTS panel will only be 
present if the Select Material dialog was 
accessed via an object specification dialog 
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where a component of a library symbol was 
selected.

Rather than apply a specific material to the 
selected component, you can dynamically 
associate it with a Material Default category. 
See “Material Defaults” on page 848.

Viewing Materials
Textures display in Ray Trace views and 
most Rendering Techniques, while patterns 
display in Technical Illustration, Line 
Drawing and Vector Views. See “Displaying 
3D Views” on page 907. 

In Technical Illustration, Line Drawing, and 
Vector Views, you can turn the display of 
material patterns on and off by selecting 3D> 

Toggle Patterns . See “Rendering 
Techniques” on page 951.

When most other Rendering Techniques are 
used, you can turn the display of textures on 
and off by selecting 3D> Camera View 
Options> Toggle Textures .

Editing Materials
Much like objects, materials in Chief 
Architect can be edited so that they better 
suit your design needs. There are two 
approaches to material editing:
• Select a material in an unlocked library in 

the Library Browser, edit it, and your 
changes will be used when you next use 
the material in any plan. Changes made in 
this manner do not affect materials 
already in use in a plan. 

• Apply a material to an object in a plan and 
then edit that applied material using either 
the Plan Materials dialog or Adjust 
Material Definition  tool. Changes 
made in this way will affect any instances 
of that material in the current plan only. 

Editing the material applied to an object is 
not the same as applying a different material 

to that object. See “The Material Painter” on 
page 849.

Library Browser
Right-click on a material in an unlocked 
library and select Open from the contextual 
menu to open the Define Material dialog for 
that material. See “Define Material Dialog” 
on page 864.

Plan Materials
Select 3D> Materials> Plan 
Materials to open the Plan Materials 

dialog for the current plan. Select a material 
and click the Edit, Copy, or New button to 
open the Define Materials dialog. You can 
add a newly defined material to the library 
from the Plan Materials dialog by selecting 
it and clicking the Add to Library button. 
See “Plan Materials Dialog” on page 863. 
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Adjust Material Definition
The Adjust Material Definition tool 
is useful for changing plan materials 

directly from a 3D view. 

Select 3D> Materials> Adjust Material 
Definition  and then click any surface in 
a 3D view to modify the material currently 
assigned to that surface in the Define 

Material dialog. See “Define Material 
Dialog” on page 864.

Changing a material definition with this tool 
affects all objects in the current plan that are 
using that material but does not affect any 
materials saved in the library or materials 
used in other plans. See “Adding Library 
Content” on page 829.

Creating Materials
Chief Architect provides a wide variety of 
materials - including numerous name brand 
material catalogs - that are ready to 
download and use. If you cannot find a 
suitable material, you can edit an existing 
material or create a new one. See “Editing 
Materials” on page 856.

In the Plan Materials Dialog
There are two ways to create a new material 
in the Plan Materials dialog. See “Plan 
Materials Dialog” on page 863.
• Click the New button to create a new 

material for use in the current plan file. 
• Select a material and click the Copy but-

ton to make a new material based on the 
original, which can then be edited and 
used in the current plan.

To make a plan material available for use in 
other plans, select it and click the Add to 
Library button. See “Adding Library 
Content” on page 829.

In the Library Browser
Materials can be created in the Library 
Browser, making them available for use in 

any plan. See “Adding Library Content” on 
page 829. 

In the directory pane of the Library Browser, 
right-click on an unlocked folder and select 

New> Material  from the contextual 
menu. See “Using the Contextual Menus” on 
page 822.

The Define Material dialog opens, allowing 
you to specify the new material’s attributes. 
See “Define Material Dialog” on page 864. 

Using Paste Image
A new material can be created by copying an 
image that will serve as its texture to the 
system clipboard, then navigating to a Chief 
Architect window and selecting Edit> 
Paste> Paste  from the menu. See 
“Paste” on page 171. 

From a Screen Capture
You can use the Screen Capture tools to 
create a texture based on a screen capture 
from any application and use it to create a 
new material in the My Materials library. See 
“Creating Screen Captures” on page 1154.
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By default, materials created from a screen 
capture will be set to Stretch to Fit. If you 
would like the texture to tile instead, uncheck 
this box. See “Stretch to Fit” on page 860.

Blending Materials
In 3D views, you can create a new 
material by blending a solid color 

such as a paint color with a textured and/or 
patterned material. Select 3D> Material 
Painter> Blend Colors With Materials to 
toggle this feature on or off. See “Blend 
Colors With Materials” on page 851.

The result is a new material that is saved in 
the current plan. It can be found in the Plan 
Materials dialog, edited as needed, and 
added to the library if desired. See “Plan 
Materials Dialog” on page 863.

Materials created using the Blend Colors 
With Materials  tool are given the name 
of the patterned/textured material with the 
extension “--PAINTED:” followed by the 
name of the solid color material. 

Convert Textures to Materials
An entire folder of textures can be 
converted into a library of materials. 

Select 3D> Materials> Convert Textures to 
Materials and then browse to a folder of 
textures on your computer. The converted 
library folder assumes the same file structure 
as the original folder. 

Create Plan Materials Library
Select 3D> Materials> Create Plan 
Materials Library to create a library 

of materials based on the materials used in 
the current plan. This is useful for converting 
material template plans, a common way to 
store material definitions in prior versions of 
Chief Architect, into a materials library. This 
command creates a new library in the 
Materials category using the same name as 
the plan. Adding materials to the library 
individually allows you to store the material 
within the existing directory structure.

Mapping Patterns and Textures
Materials have two attributes that determine 
what they look like in 3D views: patterns and 
textures. See “About Materials” on page 848. 

Both patterns and textures have points of 
origin, which determine where the pattern or 
texture begins on an X/Y axis. By default, 
this origin is 0,0; however, you can specify a 
different origin in the Define Material dialog. 
• The origin of a texture can be set either 

globally or independently for each object. 

By default, texture mapping is per object. 
See “Texture Panel” on page 869.

• The origin of a pattern is always per 
object. See “Pattern Panel” on page 867.

If a texture is set to map globally, it may not 
look right on some surfaces in 3D views. If 
this is the case and you do not wish to map 
the texture independently on each object, you 
can create a copy of the material for each 
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surface that requires modification and 
specify its texture’s origin.

Determining the Origin
Before a new origin can be specified, the 
display of coordinates in the Status Bar 

should be enabled. See “The Status Bar” on 
page 42.

To determine origin coordinates on the 
horizontal plane, place your cursor over the 
origin location in floor plan view. When the 
pointer is in the position you want to 
establish as the material origin, take note of 
the coordinates that display in the Status Bar. 

To determine origin coordinates on the 
vertical plane, place your cursor over the 
origin location in a cross section/elevation 
view.

Once you have taken note of the new origin 
coordinates, enter them on either the PAT-
TERN or TEXTURE panel of the Define 
Material dialog. See “Define Material 
Dialog” on page 864.

A texture or pattern origin is a property of the 
material rather than of the object that the 
material is assigned to. When an object is 
moved, the pattern or texture maintains its 
absolute position and may not look right. It is 
a good idea to assign pattern or texture 

The pointer’s current coordinates display in the Status Bar
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origins only after the position of the object 
has been finalized.

Stretch to Fit
Some special textures, often used for 
artwork, do not tile. Instead, these textures 
resize to stretch across any surfaces that they 
are applied to. Materials that behave this way 

are specified as Stretch to Fit in the Define 
Material dialog. 

To display an artwork texture, first place a 
wall or desk frame in your plan. A selection 
of both are available in the library. See 
“Placing Library Objects” on page 836.

Next, simply apply a material specified as 
Stretch to Fit to the center portion of the 
frame. See “The Material Painter” on page 
849. 

For more information about creating and 
using custom materials, see “Materials 
Tutorial” on page 137 of the User’s Guide.

Material Types
Every material is classified by Type in the 
Define Material dialog. See “General Panel” 
on page 865. The Type defines how the 
material is calculated in the Materials List 
when it is applied to structural components 
like wall, floor and ceiling, or roof layers; 
slabs; or to generic objects like Primitives. 

Some but not all Types are associated with 
patterns that display in some Rendering 
Techniques. See “Patterns and Textures” on 
page 848. 

Note that not every material Type is 
calculated in the Materials List. 

Following are the available Material Types 
and their characteristics:

If you have multiple objects using the
same material, they all share the same

origin. Duplicate materials can be created if
you want different origins specified for the
same texture or pattern.

Type Pattern Options Materials List

Framing None n/a Calculates stick framing quantities when
assigned to a layer in a wall type defini-
tion or a floor or ceiling structure or finish
definition. See “Framing” on page 577. 



Material Types

 861

Brick Typical staggered
running bond brick
course. 

Height, Length, Depth
and Mortar Width.

Calculates the number of units based on
the total surface area. For a masonry wall
with two layers of brick, create a wall type
with two layers to get the right count.
This Type can be specified for anything
using this style of layout, such as plywood
with staggered joints. 

Strip Parallel lines. Height, Grouping, and
Overlap Amount.

Calculates lineal footage based on the
surface area and the height of the strip
minus the Overlap amount. Grouping can
be used to model a material that has a
repeating pattern across its width.

Sheet None n/a Calculates the number of sheets required
to cover the surface area. 

Gap None n/a Gap materials create a space between
materials. This is equivalent to defining no
material at all and is not calculated in the
Materials List. 

Area None n/a Calculates the total surface area. 

Volume None n/a Calculates cubic feet (meters). 

Concrete None n/a Calculates cubic yards (meters). 

Tile Grid Height, Width, Thick-
ness, and Joint Width.

Calculates the number of units required to
cover the surface area.

Shingles Rows of staggered
rectangles. 

Height, Width, Thick-
ness, and Overlap
Amount.

Calculates the number of shingles
required to cover the surface area. 

Flooring None n/a Calculates the total surface area. 

Shakes Staggered rows of
uneven rectangles.

Height, Width, Thick-
ness, and Overlap
Amount.

Calculates the number of shingles
required to cover the surface area.

Herring-
bone

Herringbone. Height, Length, Depth
and Mortar Width.
Height and Length are
restricted to a 2:1 ratio.

Calculates the number of units required to
cover the surface area. 

Type Pattern Options Materials List
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Managing Plan Materials
The Plan Materials dialog allows you 
to manage the materials used in the 

current plan. Select 3D> Materials> Plan 
Materials to open this dialog. You can also 
access its settings in the Select Material 
dialog. See “Select Material Dialog” on page 
854. 

When a material is applied to an object in a 
plan, a copy of that material is created and 
saved with the plan. If you use the Define 

Materials dialog to modify that material, 
your changes affect it wherever it is found 
throughout that plan. All objects in that plan 
that use that material are affected, but objects 
placed in other plans are not. 

Octagon Octagons and
small squares. 

Height, Length, Depth
and Mortar Width.
Height and Length refer
to the small square
edges and are
restricted to a 1:1 ratio.

Calculates the number of units required to
cover the surface area. Units are com-
posed of one octagon and four squares. 

Hexagon Hexagon Height, Length, Depth
and Mortar Width.
Height and Length are
restricted to a 1:1 ratio.. 

Calculates the number of units required to
cover the surface area. 

Parquet Square parquet
units

Size. Calculates the required number of par-
quet units to cover the surface area.

Textured Similar to a Sand
fill style.

Spacing. The Materials List does not calculate this
material Type.

Earth Alternating hatch
pattern similar to
Parquet. 

Size. The Materials List does not calculate this
material Type.

Stars Six sided stars. Size. The Materials List does not calculate this
material Type.

Custom Multiple options Depends on the
selected pattern. 

Calculates the surface area. If you select
Use Custom Pattern File, the Material
Type will be Custom regardless of the
selected pattern. 

Type Pattern Options Materials List

All materials that come with Chief Archi-
tect are stored in the Library Browser.

You can also create your own materials and
save them in the Library Browser. See “Creat-
ing Materials” on page 857.
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Plan Materials Dialog

A scrollable, alphabetical list of the 
materials saved in the current plan 

displays here. Click on the name of a 
material to select it. Select multiple materials 
by holding down the Shift or Ctrl key.
• If there is a checkmark in the In Use col-

umn, the material is used by one or more 
objects in your plan or is defined as a 
default material for one or more objects in 
your plan.

• If the In Use column is empty, the mate-
rial was used at one time but is no longer 
assigned to any objects or used as a 
default.

Previews of the selected material 
display to the right of the list of names. 

If multiple materials are selected at once, no 
previews will display. 
• The top preview window shows the mate-

rial’s pattern, as seen in Vector Views.
• The bottom preview shows how the tex-

ture appears in rendered views. If the 

words “No Texture” display, either a tex-
ture has not been assigned to the material 
or the texture file could not be found on 
your system. In either case, the material 
will be represented in rendered views by a 
solid color.

The buttons on the right allow you to 
modify the selected material and 

manage the items in the list of material 
names.
• Click Edit to open the Define Material 

dialog for the selected material. See 
“Define Material Dialog” on page 864.

• Click New to open the Define Material 
dialog to create a new material.

• Click Copy to create a copy of the 
selected material and open the Define 
Material dialog where you can make 
changes to the copied material.

• Click Purge to remove all unused materi-
als from the plan.

1

2

3
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• Click Delete to remove the selected mate-
rial from the plan. If the material is used 
in the model, you cannot delete it.

• Click Add to Library to add the selected 
material to the Library Browser, making it 
available for use in other plans. See “Add-
ing Library Content” on page 829.

• Click the Replace button to replace the 
selected material with a new one from the 
library. Materials assigned to objects as 
well as those set in object defaults dialogs 
are affected. See “Select Library Object 
Dialog” on page 838.

• Click the Merge button to merge multiple 
selected materials into one. The material 
that is listed first is retained and all other 
materials in the selection set are deleted. 
Any instances of the deleted materials in 
the plan are replaced by the first material. 
Only available when multiple materials 
are selected. 

Define Material Dialog
The Define Material dialog allows you to 
adjust how materials look in 3D views and 
can be accessed in a number of ways:

• Use the Adjust Material Definition  
tool. See “Adjust Material Definition” on 
page 857. 

• Select a material from the Plan Materials 
dialog and click Edit, New, or Copy. See 
“Managing Plan Materials” on page 862.

• Right-click on a material in an unlocked 
library in the Library Browser and select 
Open from the contextual menu. See 
“Using the Contextual Menus” on page 
822. 

• You can also right-click on an unlocked 
library and select New> Material. 

If you select a manufacturer’s material, the 
options in the Define Material dialog may 
change. Some options are not available and 
the panels may vary. 

If you access the Define Material dialog 
through a menu or specification dialog, your 
edits affect that material wherever it is found 
in the current plan. Other objects in that plan 
that use that material are also affected, but 
objects outside the current plan are not. 

You can create a folder containing all of
the current plan’s Plan Materials in the

Library Browser User Catalog. See “Create
Plan Materials Library” on page 858.
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General Panel
The options on the GENERAL panel will vary 
depending on the selected material Type. See 
“Material Types” on page 860.

The Material Name displays here. You 
can type a different name if you wish. 

Renaming the material does not create a new 
material: it redefines the existing material. 
See “Creating Materials” on page 857. 

Specify the Colors used to represent 
the material’s pattern in Vector Views. 

Click a color box to open the Select Color 
dialog and select a color. See “Color 
Chooser/Select Color Dialog” on page 875.
• The Material color displays in Vector 

Views. It is also used in Rendering Tech-
niques that use textures when Toggle 

Textures  is off, or if a material has no 
texture specified. See “In Vector Views” 
on page 909.

This color also affects Transparent mate-
rials in rendered and ray trace views: 
choose white for a fully transparent mate-
rial or black for one that is completely 
opaque. See “Properties Panel” on page 
871.

• The color of the Pattern Lines, which 
display in Vector Views, displays here. 

• Specify the Shading Contrast, which is 
the amount of contrast between surfaces 

1

2
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at different angles to each other in Vector 
Views. 

The following shows a curved wall with 
three different Shading Contrasts (created in 
a separate graphics program). Notice how the 
lowest contrast at the top appears almost flat.

Specifications - 

• Select a material Type from the drop-
down list. The selected Type defines how 
- or whether - the material is calculated in 
the Materials List and may also be associ-
ated with a pattern. See “Material Types” 
on page 860.

Depending on the Type selected, additional 
settings may become available. Unless 
otherwise noted, these settings affect both the 
appearance of the material in Vector Views 
and how it is counted in the Materials List: 
• Specify the material’s Height. This value 

is restricted to a ratio of the Length for 
Parquet, Octagon, and Hexagon material 

Types. When applied to a Strip, Shingles, 
or Shakes Type, the Height - Overlap 
Amount = Exposure of the material. 

• Specify a Framing material’s Spacing 
OC. This value controls the spacing of 
wall studs only. See “Wall Framing” on 
page 578. 

• Specify the material’s Length. This value 
is restricted to a ratio of the Height for 
Parquet, Octagon, and Hexagon material 
Types. 

• Specify the Thickness of a material Type 
such as Tile. Thickness does not typically 
affect the appearance of the material in 
Vector Views, but is used for Materials 
List calculations. 

• Specify the Depth of a Brick material. 
Depth does not typically affect the mate-
rial’s appearance in Vector Views, but is 
used for Materials List calculations. 

• Some patterns are defined by relative 
Size. The number does not have any units: 
it is more like a scaling factor. Material 
Types with a Size setting are not calcu-
lated in the Materials List.

• Specify the Joint Width, which is the 
grout width between pieces of Tile. This 
affects the size of tiles in Vector Views 
but not the size of the pattern lines. 

• Specify the Mortar Width for a Brick or 
Block material. This affects the size of 
bricks and blocks in Vector Views but not 
the size of the pattern lines. 

Low Contrast

Normal Contrast

High Contrast

3

Note: With the exception of wall framing, when
a material is assigned to a wall type layer, floor
or ceiling structure or finish layer, or to a struc-
tural roofing layer, the Thickness value set
here is not used for materials list calculations. 
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• Specify the Overlap Amount, which is 
the amount that a Strip, Shingles, or 
Shakes material overlaps itself. The 
Height - Overlap Amount = Exposure 
of the material. 

• Grouping is used to describe the repeat 
of the pattern across the width of a Strip 
material. A 13" wide Strip with an Over-
lap Amt of 1" and a Grouping of 3 calcu-
lates materials based on a 12" coverage 
and a repeat line pattern of 4". 

• This DXF Code holds up to five charac-
ters that appear at the end of the layer 
names used when exporting a 3D DXF 
file. See “Exporting a 3D Model” on page 
1189. 

If the material has a Copyright, 
information about it will display here.

A preview of the material’s pattern 
displays in the square pane. It updates 

as you change the material definition.

A preview of the material applied to an 
object displays here and updates as 

changes are made to the material definition. 
Various options allow you to view different 
aspects of the material’s attributes:
• Display the material in Standard render-

ing, Vector View, or in a Ray Trace view.
• Zoom and orbit the object in the view.
• Toggle Color on or off.

• Click the Restore Original View  but-
ton to reset the material preview to its 
original perspective. 

• Select a Cube, Sphere, or Teapot shape.

Unlike other dialog previews, the Rendering 
Technique and object shape selected in this 
dialog’s preview are remembered during the 
current program session. See “Dialog 
Preview Panes” on page 41.

Pattern Panel
Patterns are used to represent materials in 
Technical Illustration, Line Drawing, and 
Vector Views. Pattern Types also affect the 

Materials List. See “Patterns and Textures” 
on page 848.

4

5
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The Material Name displays here. You 
can type a different name if you wish. 

Renaming the material does not create a new 
material: it redefines the existing material.

Pattern Specifications - 

• Specify the Horizontal and Vertical Off-
sets, if needed, so the pattern displays 
correctly on surfaces in Vector Views. See 
“Mapping Patterns and Textures” on page 
858. 

• Specify the Pattern Angle, in degrees 
measured counterclockwise.

• Specify the Line Weight, which is the 
thickness of the pattern lines.

Specify the selected material’s Pattern 
Source, which affects both how the 

material looks in Vector Views and how it is 

calculated in the Materials List. See “Mate-
rial Types” on page 860. 
• Select Use Material Type to base the 

material’s pattern on the selected Type, 
then select a Type from the drop-down 
list. This drop-down is also found on the 
GENERAL panel.

• Select Use Custom Pattern File to spec-
ify a Custom pattern and enable the 
options below. When a Custom pattern is 
used, the material will be counted as an 
Area type in the Materials List. 

The Custom Pattern Options are 
available when Use Custom Pattern 

File is selected, above.
• The File pathname of the selected .pat 

pattern file displays here.

1
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• Click the Browse to open the Custom 
Pattern File dialog and select a pattern 
file. This dialog is a typical Open dialog, 
and opens to the Patterns folder in the 
program installation directory.

• Select a Pattern from the drop-down list. 
The items available depend on the .pat  
file selected above.

• Specify the pattern’s Scale. If the pattern 
appears black in the square preview pane, 
this value should be increased.

A preview of the material’s pattern 
displays in the square pane. It updates 

as you change the material definition.

A preview of the material applied to an 
object displays here and updates as 

changes are made to the material definition. 
Various options allow you to view different 
aspects of the material’s attributes:
• Display the material in Standard render-

ing, Vector View, or in a Ray Trace view.
• Zoom and orbit the object in the view.
• Toggle Color on or off.

• Click the Restore Original View  but-
ton to reset the material preview to its 
original perspective. 

• Select a Cube, Sphere, or Teapot shape.

Texture Panel
In most Rendering Techniques, materials are 
represented by textures. See “Rendering 
Techniques” on page 951.

Transparency information may be contained 
on the alpha channel of a texture; if so, it is 
used in rendered views. 

5

6
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The Material Name displays here. You 
can type a different name if you wish. 

Renaming the material does not create a new 
material: it redefines the existing material. 

Offset and Angle - 
 

• Specify the X and Y Positions of the tex-
ture, if needed, so the texture displays 
correctly on surfaces in rendered views. 
See “Mapping Patterns and Textures” on 
page 858. 

• Specify the Angle of the texture on the 
surfaces of objects, in degrees.

• Check Global Symbol Mapping to map 
the texture using the same origin on all 
objects. When unchecked, the origin is 

defined individually for each object. See 
“Mapping Patterns and Textures” on page 
858.

Specify the Scale of the selected 
material’s texture.  

• Adjust the X Scale and Y Scale, or height 
and width, of the selected texture. 

If a rendered surface is larger than the area 
described by the Scale, the surface has “tiles” 
of the texture image. If it is smaller, only a 
portion of the texture is shown.
• Check Stretch to Fit to stretch the texture 

image to cover each surface it is applied 
to. Stretch to Fit is typically used for art-
work or photography in a frame.

1

2
3



Define Material Dialog

 871

Texture Source - Displays the path and 
file name of the selected texture. 

• Click the Browse button to browse to a 
texture file saved on your computer. Sup-
ported file formats are .jpg, .bmp, .png, 
.gif, .tif, .pcx, .tga. See “Creating 
Materials” on page 857.

• You can also type or paste the full path 
name of a texture in the text field. 

• Textures saved in .zip files can also be 
used. 

To use a texture saved in a .zip file

1. Type or copy the full path name of the 
.zip file in the text field.

2. Directly after the path name, type #zip:, 
followed immediately by the name of 
the texture file including its file exten-
sion.

Specify the characteristics of the 
Material Color. This can also be set on 

the GENERAL panel. 
• Check Blend with Texture to apply the 

Material Color over the material’s texture. 

When a new material is created using the 

Blend Colors With Materials  tool, 
the resulting material has this box 
checked. See “Blend Colors With Materi-
als” on page 851.

• Click the Color button to specify the 
Material Color. 

• Click the Set Material Color Using Tex-
ture button to use the predominant color 
of the material’s texture. See “Patterns 
and Textures” on page 848.

A preview of the material’s texture 
displays in the square pane. It updates 

as you change the material definition.

A preview of the material applied to an 
object displays here and updates as 

changes are made to the material definition. 
Various options allow you to view different 
aspects of the material’s attributes:
• Display the material in Standard render-

ing, Vector View, or in a Ray Trace view.
• Zoom and orbit the object in the view.
• Toggle Color on or off.

• Click the Restore Original View  but-
ton to reset the material preview to its 
original perspective. 

• Select a Cube, Sphere, or Teapot shape.

Properties Panel
The PROPERTIES panel controls how the 
material appears in most rendered 3D views 
and in Ray Trace views. 

A material’s rendered appearance is also 
affected by the Render settings in the 

Preferences dialog and the lights that have 
been placed in the model. See “Light Types” 
on page 940.

For special lighting effects on an object, use 
at least one point or spot light.

Note: Changing the scale or selecting Stretch
to Fit can cause textures to appear distorted if
applied to a surface with a different aspect
ratio than the original texture image.

4
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The Material Name displays here. You 
can type a different name if you wish. 

Renaming the material does not create a new 
material: it redefines the existing material. 

Select a Material Class from the drop-
down list. Each material class has its 

own set of visual characteristics.
• General Material - Most materials fall 

into this category, which gives you con-
trol over a number of properties. 

• Reflective - Similar to General Materials, 
Reflective materials are reflective rather 
than specular. 

• Plastic - Plastics are limited in that they 
are not specular, emissive, transparent, or 
reflective.

• Shiny Metal are also limited for a spe-
cific purpose. They are not diffusive, 

emissive or transparent, do not use the 
material’s pattern or texture when ray 
traced. 

• Predefined Metal use the scientifically 
measured physical properties of a selec-
tion of real-world metals. Predefined met-
als do not use the material’s pattern or 
texture when ray traced, and their editing 
options are limited to Roughness and 
metal type. 

• Polished materials represent surfaces 
with multiple layers, such as those that are 
glazed, varnished, or buffed. They are not 
emissive, transparent, or reflective, but 
are specular and have additional control 
over Roughness. 

• Mirror is another class of material lim-
ited to a specific purpose. They are not 
diffusive, specular, rough, emissive, or 

1
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transparent and do not use the material’s 
pattern or texture when ray traced. When 
Reflection in Mirrors is checked in the 
Preferences dialog, flat surfaces with a 
Mirror material will display reflections in 
camera views without ray tracing. See 
“Reflections” on page 935.

• Translucent - Similar to General Materi-
als, Translucent materials are not emis-
sive or reflective. Contrary to the name, 
Translucent materials are not transparent, 
either. They do have a Translucency set-
ting, but it only applies to light coming 
directly from a light fixture and only takes 
effect in ray trace views. Ambient light or 
reflected light cannot pass through trans-
lucent materials so objects cannot be seen 
through translucent materials at all - even 
in ray trace views. 

• Transparent is another material class 
limited for a specific purpose. Transpar-
ent materials are not diffusive, specular, 
rough, or emissive, but do allow you to 
specify how light bends when passing 
through the material. 

• Matte is another material class limited for 
a specific purpose. Matte materials are not 
specular, emissive, transparent, or reflec-
tive. 

Adjust the settings associated with the 
selected Material Class using the slide bar or 
by entering a value in the text box to specify 
the appearance of the material in 3D views in 
which textures are used. 
• Diffuse controls the degree to which the 

material’s main color contributes to its 
appearance. Not available for Metal, Mir-
ror, or Transparent materials.

• Specular controls how bright the material 
appears when illuminated by a point or 

spot light. It simulates the reflection of 
light off a surface. Not available for 
Reflective, Predefined Metal, Mirror, or 
Transparent materials.

• Roughness controls how shiny a material 
is when illuminated by a point or spot 
light. A material with a low Roughness 
value has a bright, round spot of light 
when rendered with a point or spot light 
shining on it. Not available for Polished, 
Mirror, or Transparent materials.

• Emissive controls how bright a material 
appears independent of the lighting in the 
scene. It can be used to simulate surfaces 
that are glowing with their own light, such 
as the glass on a light fixture. Only avail-
able for General materials. 

• Transparency controls how opaque or 
transparent a material is. Most materials 
are opaque while some materials, such as 
glass, are partially transparent. In some 
situations, materials with transparency 
can slow down rendering speed. See 
“Speeding up 3D View Generation” on 
page 962. Only available for General, 
Translucent, and Transparent materials. 

• Reflection controls how reflective a 
material appears in ray trace views only. 
See “Ray Trace Views” on page 965. For 
Mirror and Shiny Metal materials, click 
the Color button to select a color for light 
reflecting off the material. For most mate-

For maximum Transparency, specify the 
Material Color as white on the General 

panel of the dialog. A black material will be 
opaque regardless of its transparency setting. 

For a completely transparent material, select 
the General Material class and set the Trans-
parency to 100%.
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rial classes, reflectivity is best seen at 
glancing angles to the surface. For reflec-
tivity from all angles, use a Mirror mate-
rial. Not available for General, Plastic, 
Predefined Metal, Polished, or Matte 
materials. 

• Translucency controls the degree to 
which light coming directly from a light 
fixture shines through the material. Only 
available for Translucent materials, this 
setting only affect ray traced views.

• Select a Metal from the drop-down list. 
Only available for Predefined Metal 
materials. 

• Brushed Metal creates a brushed appear-
ance for Predefined Metal materials. 

Polished and Brushed Predefined Metals can 
have different amounts of roughness running 
in different directions on a given surface. 
These surfaces look different depending on 
the viewing angle.
• U Roughness produces reflective high-

lights oriented horizontally. Only avail-
able for Polished materials and Brushed 
Predefined Metal materials.

• V Roughness produces reflective high-
lights oriented vertically. Only available 
for Polished materials and Brushed Pre-
defined Metal materials.

• Index of Refraction controls how much 
light bends when it passes through the 
material. A value of 1 is the lowest possi-
ble value and produces no light bending. 
Only available for Transparent materials. 

Check Use Bump Map in Ray Trace 
Views to enable the settings below and 

assign a bump map to the selected material. 
A bump map is an image file that makes a 

material appear non-flat in ray trace views. 
See “Bump Maps” on page 980. 
• The full path name of the selected bump 

map image File displays here. 
• Click the Browse button to browse to a 

bump map image file saved on your com-
puter. Bump maps saved in .zip files can 
also be used. See To use a bump map 
saved in a .zip file, below.

• The Height Multiplier allows you to 
specify how drastic the effect of the bump 
map is. The default value is 1, but larger 
or smaller values may give better results, 
depending on the bump map. Values can 
be typed to 0.001 accuracy. 

• Check Invert to correspond light areas in 
the image with low points in the bump 
map and dark areas with high points. 
When unchecked, the opposite occurs.

• Specify the Ratio of the bump map’s 
height (x) to its width (y) in inches (mm). 
If a Ratio of 32”x32”is used, the bump 
map tiles every 48” in both directions to 
cover each surface. If a surface is smaller 
than 48”x48”, only a portion of the bump 
map is used.

• Check Stretch to Fit to stretch the bump 
map to cover each surface it is applied to.

The Ratio and Stretch to Fit settings are 
available when the selected material does not 
have a texture assigned to it. When the 
material does have a texture assigned to it, 
these settings display for reference only and 
use the same values as the material’s texture. 
See “Texture Panel” on page 869.

A preview of the material applied to an 
object displays here and updates as 

changes are made to the material definition. 

3
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Various options allow you to view different 
aspects of the material’s attributes:
• Display the material in Standard render-

ing, Vector View, or in a Ray Trace view.
• Zoom and orbit the object in the view.
• Toggle Color on or off.

• Click the Restore Original View  but-
ton to reset the material preview to its 
original perspective. 

• Select an object shape: Cube, Sphere, or 
Teapot.

• Select a Ray Trace Configuration from 
the drop-down list to use in the preview. 
Only available when Ray Trace is the 
selected preview view type. 

To use a bump map saved in a .zip file

1. Type or copy the full path name of the 
.zip file in the text field.

2. Directly after the path name, type #zip:, 
followed immediately by the name of 
the bump map file including its file 
extension.

Manufacturer Panel
If the selected material was copied from the 
Manufacturer library category, the MANU-
FACTURER panel lists contact information. 
See “Manufacturer Catalogs” on page 826. 

Color Chooser/Select Color Dialog
The Color Chooser dialog is opened 
by selecting Tools> Color Chooser. 

The similar Select Color dialog can be 
opened by clicking on the color bar that can 

be found in many dialogs throughout the 
Windows version of the program. In the Mac 
version, the standard Colors dialog, or Color 
Picker, is used. 
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The currently selected color displays in 
the rectangle at the lower center of the 

dialog. There are a number of ways to select 
a color in this dialog:

Click in any one of the Basic colors 
boxes to select it.

Click anywhere in the color spectrum 
area to select a color. 

• The location of the selected color is iden-
tified by a crosshairs and its Hue, Satura-
tion, and RGB values will display below 
and update as you click.

• Click anywhere in the vertical bar or drag 
the arrow to adjust the selected color’s 
Luminosity and RGB values.

Define the selected color by specifying 
its Hue, Saturation, and Luminosity 

(HSL) or its Red, Green, and Blue (RGB) 
values.

Click in one of the Custom colors 
boxes to either select it as the new color 

or to specify it as the box for a new custom 
color to be defined.
• Click the Add to Custom Colors to add 

the currently selected color to the Custom 
Colors group.

Click the Color Chooser Eyedropper, 
then click anywhere on your monitor to 

select the color displaying at that location.

• Click Create Material to add the color to 
the User Catalog in the library. The new 
material’s name is “Custom Color” fol-
lowed by its RGB values. Only available 
when the dialog was opened by selecting 

Tools> Color Chooser .

1
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You can select a color from any program
window. Before opening the Color

Chooser dialog, make sure the desired color
can be seen onscreen by tiling Chief Architect
and the other program window.

6
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If the Select Color dialog was opened via 
another dialog panel, click OK to apply the 

currently selected color to the object’s line or 
fill style, or to the material’s pattern color. 
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Chapter 28:

Window and View
Tools

The View and Window Tools let you control 
how views of your drawing are shown on 
screen, as well as toggle useful drawing aides 
on and off.

One layout file can be open at a time, but 
there is no limit to the number of plan files 
that can be open. The name of the file and the 
type of view displays at the top of each view 
window in its title bar. If the view is saved, 
its name also displays. 

Chapter Contents
•      View Tools
•      Zoom Tools
•      Undo Zoom
•      Fill Window
•      Panning the Display
•      Working in Multiple Views
•      Aerial View
•      Closing Views



880

Chief Architect  X8 Reference Manual

View Tools
The View Tools allow you to open and close 
the program’s side windows, as well as 
toggle a variety of references and drawing 
aides. Select the View menu to access these 
tools. You can also add the View Tools 
parent button to your toolbars. See “Adding 
and Removing Buttons” on page 132.

Refresh Display redraws the current 
window to clean up extra lines, show 
missing items, and correct random 

on-screen effects caused by changes to the 
model. See “Refresh Display” on page 220.

Library Browser opens and closes 
the Library Browser side window. 
See “The Library” on page 819.

Project Browser opens and closes 
the Project Browser side window. See 
“Project Browser” on page 1125.

Aerial View opens and closes the 
Aerial View side window. See 
“Aerial View” on page 885.

Tool Palette opens and closes the 
Tool Palette, which will display 
related tools. See “Child Tool 

Palette” on page 130.

Status Bar displays or suppresses the 
Status Bar at the bottom of the 
program window. See “The Status 

Bar” on page 42.

Scrollbars displays and suppresses 
scrollbars on view windows. See 
“View Windows” on page 35. 

Toolbars displays and hides the 
program’s toolbars. See “Toolbars and 

Hotkeys” on page 129.

Color toggles the display of color in 
the current view. See “Color On/Off” 
on page 217.

Reference Grid toggles the display 
of the Reference Grid in all views in 
the current plan or layout file. See 

“Grid Snaps” on page 166.

Angle Snap Grid toggles the display 
of the Angle Snap Grid in all views in 

the current plan or layout file. See “Angle 
Snap Grid” on page 165.

Temporary Dimensions toggles the 
use of Temporary Dimensions when 

objects are selected. See “Temporary 
Dimensions” on page 1008. 

Arc Centers and Ends toggles the 
display of Arc Centers and Ends in the 

current view. See “Arc Centers and Ends” on 
page 195.

Line Weights toggles the display of 
Line Weights in all views in which 

lines are drawn. See “Line Weights” on page 
1219. 

Drawing Sheet toggles the display of 
the drawing sheet. See “Print 

Preview” on page 1219. 
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Zoom Tools
Zoom is used to magnify any given 
area on the plan or 3D view. Select 

Window> Zoom, then click and drag a 
marquee around an area on screen. When 
you release the mouse, the selected area 
expands to fill the screen. 

Note that in 3D views, using Zoom  does 
not reposition the camera. This can lead to 
inconsistencies between a camera’s position 
and what is actually shown in the view if 
other methods of zooming are used later. See 
“Repositioning Cameras” on page 910.

When the zoom is complete, whatever tool 

was active prior to selecting the  Zoom  
tool automatically becomes active again. If 

another zoom is needed, click the  Zoom  
tool again.

Zoom In - Click to zoom in towards 
the screen center by a factor of two.

Zoom Out - Click to zoom out from 
the screen center by a factor of two.

Undo Zoom - Reverse the last zoom 
operation.

Fill Window - Fits all visible items on 
screen.

Fill Window Building Only - Fits all 
walls and railings on the current floor 

on screen. 

Zooming With the Mouse Wheel
Use the mouse wheel to zoom in and 
out in all view windows. Scrolling 
the mouse wheel one click up or 

down zooms in or out, centering on the 
location of your pointer and changing the 
zoom by about 10%.

By default, zooming in 3D views changes the 
camera’s position. See “Mouse Scroll 
Wheel and Trackpad” on page 911.

Undo Zoom
Select Window> Undo Zoom to 
reverse the last zoom operation. 

Zoom  and Undo Zoom  are also 
available through the contextual menu. See 
“Contextual Menus” on page 38. 

Note: Depending on the configuration of your
mouse, it may be necessary to hold down the
Ctrl key while turning the mouse wheel. If
zooming in and out are not working correctly,
contact the manufacturer of your mouse and
mouse driver for their assistance. 

Note: Undo and Redo do not affect zoom.
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Fill Window
In floor plan view, a CAD Detail or a 
cross section/elevation view, select 

Window> Fill Window or press the F6 key 
to view nearly everything on screen that is 
visible, including the Reference Display. 
CAD Points are the only objects that are not 
included when Fill Window is used. 

If you are zoomed in so that only a portion of 
the drawing displays on screen, selecting Fill 
Window  zooms out so that the entire 
view fits on the screen. If you are zoomed 
out so that the entire drawing is smaller than 

the screen, selecting  Fill Window  
zooms in until the drawing fills the screen.

When the drawing sheet is shown, Fill 
Window  zooms to the sheet borders.

Fill Window Building Only
Window> Fill Window Building 
Only is similar to Fill Window, but 

zooms in or out to so that all walls and 
railings in the view fill the current window. 
Other objects are ignored.

In 3D Views

Fill Window  and Fill Window Building 
Only  behave slightly differently in 
perspective and orthographic 3D views. In 
perspective views, the original zoom factor is 
restored, while in orthographic views the 
camera’s Field of View is adjusted so that all 
surfaces in the 3D view are included. 

Panning the Display
There are four ways to pan the display 
without changing the zoom factor.

Using the Scroll Bars
One method is to use the scroll bars on the 
right and bottom edges of the window.

• Drag the square button in the bar itself in 
order to pan a larger distance. 

• Click the end arrow keys on the scroll 
bars to shift the display in 12" incre-
ments. 

• The 12" increment is defined in the Plan 
Defaults dialog under Inches Scrolled 
by Arrow Key. See “General Plan 
Defaults Dialog” on page 88.

Using the Arrow Keys
In floor plan view, the Shift + arrow keys on 
the keyboard work exactly like clicking the 
arrow buttons on the scroll bar. They shift the 
display according to the number of inches 
defined in the Plan Defaults dialog.

Scroll Bars
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Using the Mouse
If you have a wheel mouse, you can pan the 
display by pressing the middle mouse button, 
or wheel, and moving the mouse in the 
direction you would like to pan. When the 
middle mouse button is held down, the 

pointer changes to a hand  icon. 

In the Mac version of Chief Architect, you 
can pan using the left mouse button and 
Command key.

Mouse drivers sometimes have other 
functions assigned to the wheel and buttons. 
These override the Chief Architect setting.

Using a Mac Trackpad
In the Mac version of Chief Architect, you 
can two finger drag to pan the display. See 
“Using a Trackpad” on page 34. 

Using the Pan Window Tool
The Pan Window tool works much 
like the mouse wheel method.

• Select Window> Pan Window . The 

pointer changes to a hand  icon. Click 
and drag to pan the window. The program 
reverts to the previously active tool when 
you release the mouse button.

• Double-click the Pan Window  tool 
and the command remains active.

Working in Multiple Views
Although only one layout file can be open at 
a time, there is no limit to the number of plan 
files that can be open, nor is there a limit to 
the number of plan view windows that can be 
open. The name of the file and the type of 
view is stated at the top of each view window 
in its title bar as well as in its tab. If the view 
is saved, its name displays instead of the 
view type. 

By default, Chief Architect uses a tabbed 
document interface, which means that when 
more than one view window is open in the 
program window, each open window will 
have a tab that displays in a row above the 
currently active view.
• Each tab states the name of file and either 

the name of the view or the view type. 
Click on a tab to make it the active view.

• If there is not enough room in the pro-
gram window to display all tabs, left and 
right arrow buttons allow you to scroll 
through the tabs.

• Tabs can be reordered by clicking and 
dragging.

There is no limit to the number of 3D view 
windows that you can have open at a given 
time; bear in mind, though, that each window 
demands use of your computer’s resources 
and that you may see poor performance if too 
many views are open. See “3D Views” on 
page 887.

There are several ways to close a view 
window. See “Closing Views and Files” on 
page 71.
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Tiling Views
As an alternative to tabbed views, 
windows can instead be tiled. 

Tiling allows you to display multiple views 
in a single Chief Architect window so you 

can see the results of changes in floor plan 
view in 3D or vice versa. It can also be useful 
for copying objects from one plan to another. 

There are several ways to create tiled views:
• Click and drag a view window’s title bar 

or tab into the part of the drawing area 
that you would like it to be. When a high-
lighted space is created, release the 
mouse button. 

• Select Window> Tile Horizontally  
to display views in a horizontal orienta-
tion, one above the other. 

• Select Window> Tile Vertically  or 
press Shift + F6 on the keyboard to dis-
play views in a vertical, side by side, ori-
entation. 

Views are tiled left to right or top to bottom 
in the order in which they were last active: 
the most recent view is on the left or at the 
top, while least recent is on the right or on 
the bottom. 

• To activate a view, click on its title bar or 
anywhere in the view window. Note that 
any changes you make in the active win-
dow are reflected in other views as well.

• To end window tiling, select Window> 
Tab Windows. You can also end tiling by 
double-clicking on the title bar of the pro-
gram window.

Multiple Program Windows
To create a second program window, click 
and drag the title bar or tab of a view window 
completely out of the current program 
window: for example, onto a second monitor.  
A second Chief Architect program window 
will be created with its own menu and 
toolbars. 

Although the two windows are separate, they 
nevertheless constitute a single launch of the 

Floor plan view and a camera view Tiled Vertically
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software, so only one of them can have an 
open layout file. 

Swapping Views
There are a number of ways to switch 
between open view windows:
• Click on a view window’s tab.

• Select Window> Swap Views  or 
press F7 to switch between the two most 
recent views.

• The Swap Views  button toggles 
between the current view and the view 
that was current before it. 

• Select Window> Select Next Tab  or 

Window> Select Previous Tab  to 
cycle through all open views in the order 
you prefer. 

• In Windows, press the Ctrl + Tab (Next 
Window) or Ctrl + Shift + Tab (Previous 
Window) keys to cycle through all open 
views. 

• On a Mac, press the Ctrl + } (Next Win-
dow) or Ctrl + Shift + { (Previous Win-
dow) keys to cycle through all open 
views. 

• Select Window> Show Layout to switch 
to the layout file. Only available if a lay-
out file is currently open. See “Layout” 
on page 1235.

• A list of all the views currently open is 
located at the bottom of the Window 
menu. Each view is identified by its name 
and what type of view it is. A checkmark 
is beside the view that is currently active. 
Select one to go directly to that view. 

If more than eight view windows are open, 
More Windows will be the last item in the 
Window menu. Select this option to open the 
Select Window dialog:

Select the name of a view in the list and click 
OK to make it the active view.

Aerial View
Aerial View is a side window that 
shows everything on the current floor 

or layout page along with a marquee that 
indicates the portion that is currently shown 
in the view window. This can make it easier 
to navigate in the view. Select View> Aerial 
View to open the Aerial View side window. 
See “View and Side Windows” on page 35. 

Aerial View always displays everything in 
the current view, so it has no scroll bars. As 

you zoom or pan around the view window, 
the marquee in Aerial View moves and 
resizes in response so it represents the part of 
the view that is currently visible on screen. 

Although Aerial View can be open regardless 
of the type of view that is active, it only 
displays information when a floor plan view 
or a layout page is active. 

Aerial View is initially docked on the right 
side of the window; but like other side 

Note: The Window Menu Tools parent but-
ton can be added to the toolbars. See
“Toolbar Customization Dialog” on page
135. 
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windows, it can be moved to any other edge 
or allowed to float. 

• The grey marquee that displays in Aerial 
View represents the extents of what is 
currently visible on screen. This marquee 
updates if you zoom or pan in the view.

• Use the left mouse button to drag a new 
marquee within the Aerial View side 
window. The view updates to match.

• Use the right mouse button to move  
the existing marquee within the Aerial 
View window. The focus of the view 
window updates to match.

• No matter what tool is active, when you 
move the pointer to the Aerial View win-
dow and drag a marquee, the floor plan 
view zooms in on that area. 

• The display of objects in Aerial View is 
controlled by the default layer set for 
Aerial Views. Since the purpose of Aerial 
View is to enhance navigation in plan 
view, you may want to turn off layers that 
clutter and slow it down. See “Layer Set 
Defaults” on page 147. 

Closing Views
If a view is still needed, swap to a different 
view without closing the current views. If, 
however, a view is no longer needed, it can 

be closed. See “Closing Views and Files” on 
page 71. 

The grey border that displays in the Aerial View window represents the extent of the floor plan view.
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Chapter 29:

3D Views

Little preparation is needed to create a 3D 
view of a model: simply click a button to 
create an overview or click and drag to create 
a camera or cross section/elevation view. 

To improve the quality of the rendering and 
create a custom look, you can adjust lighting 
and edit the materials used in the plan. You 
can create Final and Ray Trace views that are 
even more realistic. See “3D Rendering” on 
page 933.

Many objects can be placed and edited in 3D 
views, and any camera view or overview can 
be saved or even used to record a 
walkthrough. See “Pictures, Images, and 
Walkthroughs” on page 1133.

Chapter Contents
•      OpenGL and Hardware
•      Types of 3D Views
•      Defaults and 3D Preferences
•      Camera Defaults Dialog
•      3D View Defaults Dialog
•      3D View Tools
•      Creating Camera Views
•      Creating Overviews
•      Cross Section/Elevation Views
•      Auto Detail
•      Displaying 3D Views
•      Repositioning Cameras
•      Editing 3D Views
•      Cross Section Slider
•      Working in 3D
•      Saving and Printing 3D Views
•      Camera Specification Dialog
•      Cross Section/Elevation Camera 

Specification
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OpenGL and Hardware
Chief Architect features an easy to use 
rendering engine that makes use of OpenGL 
rendering technology, which has good 
hardware support on most video cards. 

To take full advantage of the rendering 
capabilities of Chief Architect, a graphics 
card or chipset that supports OpenGL 2.1 or 
higher hardware acceleration is required. 

Types of 3D Views
There are three categories of 3D views in 
Chief Architect: camera views, overviews 
and cross section/elevation views. Each of 
these view types can be generated using a 
variety of rendering techniques. See 
“Rendering Techniques” on page 951.

Every 3D view is also either orthographic or 
perspective in nature. Cross section/elevation 
views are always orthographic while camera 
views are always perspective. You can 
choose to generate overviews as either 
orthographic or persective. 

Perspective and 
Orthographic Views

Perspective views have a focal, or vanishing, 
point. Surface edges and lines that would be 
parallel in real life appear to converge 
towards that focal point, and objects closer to 
the camera appear larger while objects 
farther from the camera appear smaller.

Orthographic views do not have a focal or 
vanishing point. Parallel surface edges and 
pattern lines appear parallel in these views 
and objects appear to be the same size 
regardless of their distance from the camera.

Perspective views display 3D objects much 
the way that they appear to the eye in real 
life, so they are ideal for presentation views. 
By default, perspective views are created 
using the Standard rendering technique.

Orthographic views, on the other hand, are 
useful for technical drawings. By default, 
orthographic views are created using the 
Vector View technique.

Rendered and Vector Views
3D views can be generated using a variety of 
different rendering techniques. See 
“Rendering Techniques” on page 951.

Most rendered views represent materials 
using textures. Surface edge lines are 
generally not drawn and lighting is often 
modeled, creating results that range from a 
photorealistic appearance to artistic painting 
styles. Standard rendered views can also be 

Perspective Overview Orthographic Overview
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Ray Traced for additional realism. See “Ray 
Tracing” on page 965.

Vector Views are non-photorealistic views in 
which objects are drawn using surface edge 
lines, or vectors. Lighting is not calculated, 

and materials are represented using pattern 
lines and solid colors, making Vector Views 
quicker to generate and ideal for layout 
drawings and high resolution printing.

Defaults and 3D Preferences
There are a number of defaults and 
preference settings that allow you to control 
the initial characteristics of 3D views. 

 Camera positioning, field of view and 
related initial settings for camera 

views are specified in the Camera Defaults 
dialog. See “Camera Defaults Dialog” on 
page 889.

The default characteristics of the Generic 
Sun light source can be specified in the 
Generic Sun Defaults dialog. See “Adjust 
Sunlight Dialog” on page 950. 

 Ambient lighting settings, 3D 
backdrop information, and other 

settings that affect 3D views as they are 
generated are found in the 3D View Defaults 
dialog. See “3D View Defaults Dialog” on 
page 892. 

 Which objects display in a 3D view 
and which do not is controlled in the 

Layer Display Options dialog. You can 
specify which layer set is initially used when 
a view is created by each of the 3D View 
tools. See “Layer Set Defaults Dialog” on 
page 158.

3D views can be generated using any 
of the Rendering Techniques. See 

“Rendering Techniques” on page 951. 

The initial settings for each Rendering 
Technique can be set in the 

Rendering Techniques Defaults dialog. See 
“Rendering Technique Options” on page 
954. 

The RENDER panel of the Preferences 
dialog controls settings for Render 

Previews and Final Views. See “Render 
Panel” on page 123.

Camera Defaults Dialog
Default Settings can be accessed by 
selecting Edit> Default Settings or 

by double-clicking either Perspective View 
Tools parent button or any Camera toolbar 
button.

The settings in the Camera Defaults dialog 
affect how a camera clips, captures and 

renders views, how it displays in floor plan 
view, how it is positioned, and how it moves.

Once a camera is created, these settings can 
be customized in the Camera Specification 
dialog. See “Camera Specification Dialog” 
on page 924.
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General Panel

The Positioning settings control the 
position and orientation of the camera. 

See “Repositioning Cameras” on page 910.
• The Incremental Move Distance con-

trols how far the camera moves each time 
you Pan in any direction or Dolly for-
wards or backward. For interior views a 
small number is good, but for exterior 
you may want a larger increment.

• The Incremental Rotate Angle defines 
how many degrees the camera rotates 
each time you Tilt, Orbit, or Dolly side to 

side. A setting of 90° would make one 
full rotation in four moves. 

• The Height Above Floor defines the 
height that the camera is above the sub-
floor level for the current floor. See 
“Floor Defaults” on page 330.

• The Field of View defines the camera’s 
field of vision in angular degrees.

• The Tilt Angle is the camera’s angle rela-
tive to the horizon. 0° is horizontal, 5° 
points slightly upward, and -5° points 
slightly towards the ground. 

1
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The Scene Clipping settings determine 
whether surfaces located close to the 

camera display in the view.

Both of these distances are measured in a 
radius from the camera position:
• Clip Surfaces Within - Objects within 

this distance from the camera do not dis-
play.

• Remove Wall Within - Walls within this 
distance from the camera do not display. 

• Check Unless Opening to display a wall 
that is inside the Remove Wall Within 
range if the camera is pointing through a 
door or window in that wall.

Orthographic View Options - 

• Select the Rendering Technique from 
the drop-down list to be used when a 
camera view is created using the 

Default  Edit Behavior. See 
“Rendering Techniques” on page 951. 

• Select a Rendering Technique from the 
drop-down list to be used when a view is 

created using the Alternate  Edit 
Behavior. See “Edit Behaviors” on page 
178.

• Check Show Shadows to turn on the dis-
play of shadows in newly created Ortho-
graphic views. See “Shadows” on page 
934. 

The Perspective View Options are the 
same as those for Orthographic views, 

above, but apply to camera views created 
with the Perspective View tools. See 
“Perspective and Orthographic Views” on 
page 888. 

Options - 

• Uncheck Show Lower Floors in Floor 
Overviews to show only the current floor 
in Floor Overviews. When checked, the 
current floor plus any floors beneath it 
are shown. See “Floor Overview” on 
page 900. 

• Click the Advanced button to open the 
Advanced Camera Options dialog and 
specify how hidden lines are removed 
when OpenGL is not used. See “OpenGL 
and Hardware” on page 888.

Advanced Camera Options 
Dialog

• The NNS Method is Chief Architect’s 
default method. In most cases, it is both 
faster and requires less memory than the 
BSP Method. 

• Select BSP Method to use an alternative 
method. This method may provide better 
results in some situations; however, it 
may be slower and require more memory.

• When the BSP Method is used, checking 
Use Panels may increase speed and 
reduce memory usage.

2

3

4

5
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Plan Display Panel

The Plan Display settings control the 
appearance of the camera’s symbol in floor 
plan view. See “Using the Edit Handles” on 
page 917.
• Specify the Camera Symbol Size, mea-

sured in plan inches (mm). This is also 
the default size for Walkthrough Path 
Key Frames. See “Walkthroughs” on 
page 1158.

• Set the Clip Plane Indicator Length for 
Cross Section/Elevation, Backclipped 
Cross Section, and Wall Elevation cam-
era symbols. The length is measured in 
plan inches (mm). See “Cross Section/
Elevation Views” on page 902.

• Check Show Camera Focal Point to dis-
play the camera’s focal point in floor plan 
view.

• Check Show Field of View Indicators to 
display the field of view indicator for 
cameras in floor plan view. You can also 
change the FOV Indicator Length, 
which is measured in plan inches (mm).

• Uncheck Always Display Active Cam-
eras to turn off the display of active cam-
era symbols when the “Cameras” layer is 
turned off. When checked, active cam-
eras always display, regardless of the 
layer setting.

• Check Display Callouts for Sections/
Elevations to represent cross section/ele-
vation cameras in floor plan view using 
callouts instead of camera symbols. See 
“In Floor Plan View” on page 907.

3D View Defaults Dialog
Select 3D> 3D View Defaults, Edit> 
Default Settings , or double-click 

the Perspective View Tools  parent 
button to display the 3D View Defaults 
dialog.
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Some settings in the 3D View Defaults 
dialog affect rendered views, some affect 
Vector Views, and some affect both view 

types. See “Rendered and Vector Views” on 
page 888.

Options Panel

The General Options affect all 3D 
views. 

• Check Restrict Floor Camera to Room 
to suppress the generation of objects out-
side the room in which a Floor Camera is 
created. Only affects subsequently gener-
ated Floor Camera views. See “Camera 
Views” on page 897. 

When checked, a view through a door-
way into another room shows only blank 
space or the selected 3D backdrop. Use 
this option to reduce 3D view rendering 
time or to minimize file size when creat-
ing a single room 3D Walkthrough.

• Uncheck Camera Bumps Off Walls to 
allow cameras to move freely through 
walls.

1
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• Check Auto Rebuild Walls/Floors/Ceil-
ings to automatically rebuild floors and 
ceilings before a 3D view or elevation is 
displayed. When this is unchecked and 
the structure is not up to date, the Rebuild 
Walls, Floors, Ceilings  icon displays 
near your mouse pointer. See “Rebuild-
ing Walls, Floors and Ceilings” on page 
441.

• Check Auto Rebuild Terrain to auto-
matically rebuild terrain to reflect recent 
changes before generating a 3D view. If 
this option is unchecked and the terrain is 
not up to date, the Rebuild Terrain  
icon displays near your mouse pointer. 
See “Building the Terrain” on page 730.

• Check Legacy Compatible Texture 
Mapping to use global texture mapping 
settings rather than texture mapping fixed 
to individual objects. 

• When Auto Adjust Default Glass Prop-
erties is checked, the program automati-
cally adjusts the behavior of window, 
door, and electrical fixture glass in Stan-
dard rendered and ray trace views in 
response to interior and exterior lighting 
conditions. When this box is unchecked, 
these adjustments are not made. 

The Lighting Options control the 
ambient light in rendered views. Click 

and drag the slide bar or type in a percent 
value to adjust these options. See “Ambient 
Light” on page 937.
• Interior Ambient affects interior views.

• Daytime Ambient affects daytime exte-
rior views.

• Nighttime Ambient affects nighttime 
exterior views.

• Click the Reset button to to restore initial 
default values.

• Uncheck Brighten Ceilings to turn off 
the default parallel light source that 
shines upward in interior views to add 
extra illumination to ceilings. See 
“Default Interior Light” on page 937. 

The Vector View Options only affect 
views using the Vector View rendering 

technique. See “Rendered and Vector Views” 
on page 888.
• View Panel Factors adjust the perfor-

mance of Vector Views. Normally, these 
values should not need changing, but you 
may be able to get modest performance 
improvements by trying other values. See 
“Speeding up 3D View Generation” on 
page 962.

• View Panel Factor 1 determines how 
many surfaces are drawn for each hori-
zontal panel. Each horizontal panel is 
then subdivided into vertical panels - and 
View Panel Factor 2 determines how 
many surfaces are contained in each ver-
tical panel.

• View panel factors represent target num-
bers of surfaces to use in defining each 
panel. A value of 10000 for Factor 1 
means that a total of 10,000 or more sur-
faces are collected to define each panel 
vertically. A value of 2000 for Factor 2 
means that 2,000 or more surfaces are 
collected to define panels horizontally.

• Making these numbers larger results in 
fewer panels; making them smaller 

Legacy Compatible Texture Mapping
should remain unchecked except in leg-

acy plans with custom rotated textures.

2
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results in more panels. Adjusting these 
numbers either too low or too high causes 
the time required to draw to increase. 

• Framing Back Clip defines the back clip 
for framing members in cross section 
views. Framing must be set to display to 
see the effects of this value. A zero value 
does not back clip at all.

Default Color Display controls 
whether views created using the Vector 

View rendering technique are generated 
using color or not. See “Rendering 
Techniques” on page 951.
• Select a checkbox to generate that view 

type in color or uncheck to generate that 
view type as a line drawing. 

• A colored view can always be changed to 
a line drawing and vice versa by choosing 

Tools> Color Off/Color On .

Specify how the Surface Edge Lines  
display for all objects in 3D views.

• Check Use Layer Settings to display sur-
face edge lines for objects using the dis-
play settings specified by layer in the 
Layer Display Options dialog.

If this option is not checked, all edge 
lines are drawn black and solid with a 
line weight of 0.

• If Use Layer Settings is checked you can 
also check Use Object Settings. All 
objects that have special settings speci-
fied on the LINE STYLE panel of their 
specification dialog display using those 
settings, overriding the layer settings in 
the Layer Display Options dialog.

Backdrop Panel
The settings on the BACKDROP panel allow 
you to specify a backdrop image or color to 
display behind your model in 3D views. See 
“3D Backdrops” on page 1155. 

4

5
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Specify Backdrop - A preview of the 
selected backdrop image is shown here. 

A backdrop cannot be selected or removed 
when Use Generated Sky is checked, below. 
• Backdrop Name - The name of the 

selected backdrop image displays for ref-
erence. 

• Click Select Backdrop to choose a back-
drop image from the library. See “Select 
Library Object Dialog” on page 838.

• Click Remove Backdrop to use a solid 
color instead of a backdrop image in all 
3D views, then specify the color below.

• Click the Color bar to select the Back-
ground Color that displays when a back-
drop image is not being used. See “Color 
Chooser/Select Color Dialog” on page 
875. 

The Background Color is used in all views 
except Vector Views, which instead use the 

1
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Background Color set in the Preferences 
dialog. See “Colors Panel” on page 94. 

Spherical Backdrop Options - 
 

• Check Use Generated Sky to simulate a 
daytime sky backdrop. When checked, 
Spherical Panoramic Backdrop will also 
be checked and a preview of the Gener-
ated Sky will display above. 

• Specify a Haze Level of Low, Medium, 
or High. This determines the degree to 
which light in the sky backdrop appears 
to be scattered by particles in the air. 

• Specify a Horizon Level using the text 
field or slider bar. The default value of 
44% works well in most situations. 

• Check Spherical Panoramic Backdrop 
to place the selected backdrop onto a 
sphere that surrounds your model in cam-
era views and overviews. 

• The Horizontal Angle and Vertical 
Angle settings are the same as those in 
the Backdrop Specification dialog. If 
these values are changed here, the back-
drop saved in the library will be unaf-
fected. See “Backdrop Specification 
Dialog” on page 1156. 

The Show Backdrop in options let you 
specify the conditions under which the 

selected backdrop image displays.
• Specify in which View Types a backdrop 

image is used. By default, only Perspec-
tive Camera Views are set to use a back-
drop. See “3D View Tools” on page 897.

• Specify in which Rendering Techniques 
a backdrop image is used. See 
“Rendering Techniques” on page 951. By 
default, Standard, Painting and 
Watercolor use backdrops while the other 
techniques do not.

3D View Tools
Select 3D> Create 
Orthographic View to display 

the Orthographic View Tools or 3D> Create 
Perspective View to display the Perspective 
View Tools. 

Camera Views
Camera views are perspective views. They 
are not scaled and cannot be annotated but 
are ideal for creating presentation views.

The Full Camera tool creates multi-
floor views of the 3D model. It can be 

used to create interior and exterior 
perspectives, and is good for displaying 
cathedral ceilings, roofs, lofts, stairwell 

openings, and other variation in floor and 
ceiling levels.

The Floor Camera tool creates 
perspective views of the current floor 

only. Nothing above the ceiling surface is 
generated, and neither is anything below the 
floor. 

Overviews
An overview can be either 
orthographic in nature or 

perspective, depending on the tool used to 
create it. See “Creating Overviews” on page 
900.

2

3
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The Orthographic and Perspective Full 
Overview tools create views of the entire 
model including all floors, ceilings, and the 
roof. 

The Orthographic and 
Perspective Floor Overview 

tools create views of the current floor with 
the ceiling removed and all floors beneath it 
visible. 

The Orthographic and 
Perspective Framing Overview 

tools create views of the framing in the 
model. Framing must be built in order for it 
to display in a framing overview. See 
“Framing Overview” on page 901. 

The Isometric Overview tools create 
specially oriented and scaled 

overviews that are common in engineering 
drawings. These tools are only available 
when an Orthographic Overview is active. 
See “Isometric Overviews” on page 901. 

Cross Section/Elevation Views
Cross Section/Elevation views are similar 
to the traditional, scaled orthographic views 
often used in drafting. They are scaled and 
can be fully annotated. See “Cross Section/
Elevation Views” on page 902.

A Cross Section/Elevation view 
displays all floors of the model. If the 

view is created outside the structure looking 
toward it, the result is an exterior elevation. 
If the view is created inside the structure, or 
passes through any of the structure, a cross 
section is created. 

The Backclipped Cross Section tool 
includes only the objects between the 

starting point and stopping point of the cross 
section line.

The Wall Elevation tool creates an 
elevation of a wall on a single floor 

and in a single room. The Wall Elevation 
tool cannot be used to create exterior views. 

Select 3D> Create Auto Elevations  to 
access tools that create, save, and name ele-
vation views as soon as the tool is selected. 
These tools can also be added to your tool-
bars. See “Auto Elevation Tools” on page 
904. 

The Front Elevation tool creates an 
exterior elevation of the front of the 

model (on screen, the bottom).

The Back Elevation tool creates an 
exterior elevation of the back of the 

model (on screen, the top).

The Left Elevation tool creates an 
exterior elevation of the left side of 

the model.

The Right Elevation tool creates an 
exterior elevation of the right side of 

the model.

The All Elevations tool creates an 
exterior elevation of the front, back, 

left, and right sides of the model.

The Create Room Elevation Views 
edit tool creates an interior elevation 

view of each wall defining a selected room. 
This tool is found on the edit toolbar for a 
selected room rather than in the 3D menu. 
See “The Edit Toolbar” on page 37. 

The framing members of an individual
wall can also be displayed and edited in

a Wall Detail view. See “In Wall Detail Views”
on page 605.
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Ray Trace Views
Ray Trace views are a special type of 
high-quality 3D view in which the 

paths individual photons are calculated so 
that realistic lighting effects can be modeled. 

They cannot be created directly from floor 
plan view. Instead, you must first create a 
Standard rendered view of the desired scene 
and then select 3D> Ray Trace Current 
View. See “Ray Tracing” on page 965.

Creating Camera Views
All Camera views are created using the same 
method.

To create a camera view

1. In floor plan view, select the desired 
camera tool. The mouse pointer displays 

the camera  icon. 
2. Click and drag a line to define the view 

direction. 
•  Where your line begins is the camera’s 

position. 
•  The line that you drag defines the 

direction the camera is pointed. 
•  The end of the line is the focal point of 

the view, the point the camera rotates 
around.

•  By default, the field of view is 45°, 
which is similar to what the human eye 
sees or a 50mm camera lens. 

3. When you release the mouse button, a 
view generates in a new window.

4. Return to the floor plan view. A camera 
symbol now displays in floor plan view. 
See “Working in Multiple Views” on 
page 883.

In order to create a camera view, you must 
click and drag at least as far as your current 
Snap Distance. See “Snap Properties Panel” 
on page 115.

Camera Height
By default, Cameras are created at a height 
of 60” (1500 mm). Where this height is 
measured from depends on the location of 
the camera:

Camera 
(click)

Focal Point 
(release)

Line of Sight 
(drag)

1.

2.

3.
Field of View 
Indicator
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• If the camera is inside of a room, it is 
measured from that room’s subfloor.

• If the camera is outside of a room but 
inside of the Terrain Perimeter, it is mea-
sured from the terrain at the location of 
the camera.

• If the camera is located in neither a room 
nor within the Terrain Perimeter, it is 

measured from the default height of the 
subfloor for the current floor. 

Once created, a camera’s height can be 
modified in its Camera Specification dialog, 
and the initial height value can be set in the 
Camera Defaults dialog. See “Camera 
Panel” on page 924. 

Creating Overviews
In Chief Architect, there are three different 
overview types: Full, Floor and Framing 
Overviews. 

Each type of overview can be generated as 
either an orthographic or perspective view. 
An overview window’s title bar indicates 
whether it is perspective or orthographic. See 
“Perspective and Orthographic Views” on 
page 888.

Overviews generate as soon as you select the 
tool and are always created at the same 
angle. The focal point is always located at 
the center of the model; however, the 
position of the camera will vary depending 
on the size of the 3D model. The larger or 
more spread out the model, the further away 
the camera will be from the focal point so 
that the entire model can be seen in the view. 

Once generated, an overview window’s title 
bar indicates whether it is a perspective or 
orthographic view and a camera symbol 
representing the overview displays in floor 
plan view, The overview ‘camera’ can be 
edited much like regular camera views can. 
See “Editing 3D Views” on page 916.

Full Overview
Select 3D> Create 
Orthographic View> 

Orthographic Full Overview or 3D> 
Create Perspective View> Perspective Full 
Overview to generate an exterior view of the 
entire model.

Floor Overview
Select 3D> Create 
Orthographic View> 

Orthographic Floor Overview or 3D> 
Create Perspective View> Perspective 
Floor Overview to create a view of the 
current floor with the ceiling removed and all 
floors beneath it visible.

Floor Overviews are an effective tool for 
illustrating traffic flow and the relationships 
between spaces.  
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To see a different floor, select Tools> 
Reference Floors> Up One Floor  or 

Down One Floor . You can also return to 
floor plan view and make another floor 
current before generating the Floor Overview

If you prefer, you can specify in the Camera 
Defaults dialog that only the current floor be 
included in Floor Overviews. See “Camera 
Defaults Dialog” on page 889. 

Framing Overview
Select 3D> Create Ortho-
graphic View> Framing 

Overview or 3D> Create Perspective 
View> Perspective Framing Overview to 
create a view of the entire model, displaying 
only framing and the foundation. 

Select 3D> Create Orthographic View> 
Orthographic Framing Overview or 3D> 
Create Perspective View> Perspective 
Framing Overview to create a view of the 
entire model, displaying only framing and 
the foundation. 

Framing overviews include all floor, wall, 
and roof framing as well as foundations. 
Unlike other overviews, which use the 
Camera View layer set, Framing Overviews 
use the 3D Framing Set. See “Layer Sets” on 
page 146 

Framing must be built before generating this 
view or the view will be empty. 

Isometric Overviews
An Isometric Overview is a special 
orthographic view in which the 

camera is positioned in such a way that the 
angles between the X, Y, and Z axes are all 
120° in that view. See “3D Drafting” on page 
31. 

In addition, Isometric Overviews use 
scaling that is approximately 1.2 times that 
used in a normal projection so that lines 
parallel to the X, Y, and Z axes measure their 
true length in the 2D projection. As such, 
Isometric Overviews can be useful for 
technical drawings but may not be well 
suited for presentation views. 
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To create an Isometric Overview

1. Create an Orthographic Full 
Overview  or Floor Overview .

2. With the Orthographic view active, 
select 3D> Isometric Overviews and 
choose a view option from the submenu.

3. The camera’s position will adjust, as will 
the scaling used in the view.

4. If you move, orbit, or tilt the camera the 
camera will return to normal scaling.

Cross Section/Elevation Views
The Cross Section/Eleva-
tion, Back-clipped Cross 

Section, and Wall Elevation tools produce 
the traditional, orthogonal views often used 
in drafting. Regardless of their distance from 
the camera, all lines and dimensions in these 
views are their true lengths, making it easy to 
accurately see the spatial relationships of the 
3D objects in the model.

Two additional elevation tools, 
Exterior Elevations and the 

Create Room Elevation Views edit tool, 
allow you to create and save multiple 
elevation views of either the entire plan or a 
single room with a single click. 

Cross section/elevation views can be clipped 
to limit how much of the model is included in 
the view. See “Camera Panel” on page 928.

Cross section/elevation views are the only 
3D views that can be enhanced with the 2D 
CAD tools. They can be fully annotated and 
dimensioned and then printed to scale. 

Cross Section/Elevation 
Camera Tools

Each of the three cross section/elevation 
camera tools has a specific function. 

A Cross Section/Elevation view 
displays all floors of the model. The 

cross section begins at the point where the 
camera arrow is drawn and continues 
through the entire model. 

To create an Isometric Overview, begin
in an Orthographic Overview. See “Per-

spective and Orthographic Views” on page
888.
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The Backclipped Cross Section tool 
includes only the objects or portions 

of objects between the starting point and 
stopping point of the camera’s Line of Sight. 

The Wall Elevation tool creates an 
interior elevation of a single wall 

defining the room that the camera is drawn 
in. It does not cut through walls or show the 
ceiling, floor, or roof. It creates a 2D 
projection of a wall and the objects located 
between that wall and the camera and is used 
primarily for kitchen and bath elevations. 
This tool cannot be used to create exterior 
views.

By default, Wall Elevation  views 
recognize room definition created by railings 
and invisible walls; however, you can specify 
that these types of walls are ignored in the 
Wall Elevation Specification dialog. See 
“Camera Panel” on page 928. 

Cross Section/Elevation , Backclipped 
Cross Section  and Wall Elevation  
views are created in the same way.

To create a Cross Section/Elevation view

1. Select the Cross Section/Elevation , 

Backclipped Cross Section  or Wall 
Elevation  tool. The pointer changes 
to a  with crosshairs marking the 
position of the pointer.

2. Click and drag a line in floor plan view. 
•  A Camera symbol displays where you 

click, along with a Cross Section Line 
indicating the plane of the camera’s 
cross section cut line.

3. Drag in the direction of the Line of Sight 
to draw a camera arrow.

•  Always drag the camera arrow perpen-
dicular to the wall to be viewed. 

4. When you release the mouse button, the 
view generates in a new window.

•  If the view is a Backclipped Cross Sec-
tion, a second Cross Section Line at the 
end of the Line of Sight indicates the 
furthest extent of the backclip.

•  You can specify the length of the Clip 
Plane Indicators and also restrict the 
side to side extents of the view to them. 
See “Camera Panel” on page 928.

As with camera views, you must click and 
drag at least as far as your current Snap 
Distance in order to create a Cross Section/
Elevation view. See “Snap Properties Panel” 
on page 115.

If the Line of Sight does not cut through a 3D 
object and the object is within the back 
clipped distance, such as a window shown in 
elevation, the object retains its 3D definition 
and can be selected, moved, stretched, or 
otherwise modified in the view. The 3D 
model is updated in all views.

Camera 
(click)

Focal Point 
(release)

Line of Sight 
(drag)

1.
2. 3.

Clip Plane Indicators
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Auto Elevation Tools
The Auto Elevation Tools create 
exterior elevations of the front, back, 

left and right sides of the model. To use any 
of these tools, simply select it: the camera 
view - or all four camera views - are 
automatically created, saved and named. See 
“Saving 3D Views” on page 922.

At least one wall or railing must be present in 

the plan in order for the Auto Elevation  
tools to work. If no walls or railings have 
been drawn, nothing will happen when any 
of these tools is selected. 

The directions that these four elevation 
cameras point are directly related to the 
orientation of the X and Y axes, reference 
grid and snap grid in the plan. See “3D 
Drafting” on page 31. 

The front elevation is located below the 
model on-screen and points upward while the 
back elevation is found above the model and 
points downward. This may not be the case, 
however, if you have used the Rotate Plan 
View  tool. See “Rotate Plan View” on 
page 237. 

If the same Auto Elevation view is created 
more than once, the additional camera 
symbols are placed progressively further 
away from the model in floor plan view and 
are numbered. If an Auto Elevation is 
renamed and then the view created again, the 
symbols may overlap. 

The Auto Elevation Tools  parent button 
can be added to the toolbars if you wish. See 
“To add a button to a toolbar” on page 132. 

Room Elevation Views
The Create Room Elevation Views 
edit tool creates an interior elevation 

view of each wall defining or present in a 
selected room. To create elevation views for 
a room, select the room and then select this 
edit tool. See “Editing Rooms” on page 333. 

Stepped Cutting Planes
By default, cross section/elevation views 
have a single, linear cutting plane - or, in the 

case of Backclipped Cross Sections , two 
cutting planes. To cut some objects while 
avoiding others, you can one ore more steps 

to a cutting plane using the Break Line  
edit tool. See “Break Line” on page 231.

To create a stepped cutting plane

1. In floor plan view, select a Cross Sec-
tion/Elevation  or Backclipped 
Cross Section  camera. See “In Floor 
Plan View” on page 907.

2. Click the Break Line  edit button, 
then click on the front cutting plane of 
the selected camera symbol to add a new 
Resize edit handle at the point where 
you clicked.

3. Click and drag the edit handle on either 
side of the break perpendicular to the 
cutting plane to create a step.

4. Click and drag the edit handle associated 
with the break parallel to the cutting 
plane to adjust the position of the step.
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Detailing Cross Section/
Elevation Views

CAD objects, including Text and 
Dimensions, can be created in cross 

section/elevation views. These objects are 
superimposed on the view and have no effect 
on the 3D model itself. If CAD objects have 
been added to a cross section/elevation view, 
the program will prompt you to save the view 
before closing the window. This information 
is then stored in the view. 

A selection of Auto Elevation Dimension 
tools automatically generate dimension sets 
and story poles in cross section/elevation 
views. See “The Automatic Dimension 
Tools” on page 1009.

In cross section views, some objects, such as 
walls, may be represented using Cross 
Section lines. If a dimension line finds an 
object surface edge represented by a Cross 
Section line, a Point Marker will be placed at 
that location, and the dimension will locate it 
instead of the Cross Section line. See 
“Markers” on page 1058.

CAD objects will snap to the Snap Grid 

when Grid Snaps  are enabled. Note that 
the 3D model may obscure the display of the 
Snap Grid. See “Grid Snaps” on page 166. 

When the Vector View rendering 
technique is used, you can select 

CAD> CAD Detail From View to create a 
2D line drawing of the active cross section/
elevation view in a CAD Detail window. 
This drawing can then be edited as needed. 
See “CAD Detail from View” on page 1118. 

Annotated cross section/elevation views can 
also be sent to layout. See “CAD and Text in 
Layout” on page 1238.

Auto Detail
The Auto Detail tool automatically 
creates CAD objects for commonly 

detailed components of cross section views. 
To use this tool, select CAD> Auto Detail 
while a cross section view is active.

Labels for cabinets and other objects
can display in cross section/elevation

views. See “Displaying Labels” on page
1279.
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Auto Detail  creates CAD objects in 
walls, floor and ceiling platforms, foundation 
walls and footings, slabs, roof and ceiling 
planes, as well as Material Regions and 
Custom Backslashes that are intersected by 
the cross section plane as follows: 
• Walls - Creates closed CAD polylines for 

each wall layer with a fill style specified 
in the wall type definition. The polyline 
uses the same fill as that specified for the 
wall layer. See “Wall Type Definitions” 
on page 302.

• Floors and Ceilings - Creates closed 
CAD polylines for each floor and ceiling 
layer with a fill style specified in the 
Platform or Finish definition. See “Floor 
and Ceiling Platform Definitions” on 
page 344.

• Roof and Ceiling Planes - Creates 
closed CAD polylines for each roof layer 
with a fill style specified in its Surface, 
Structure, or Ceiling definition. See 
“Roof Layers” on page 490.

• Foundations - Closed polylines are 
created for foundation walls, footings, 
and floors. The fill style for walls is 
specified for the wall layer in the wall 
type definition. The fill style for footings 
is “Concrete”. The fill style for the floor 
is set in the floor platform definition.

• Slabs - Closed polylines using the 
“Concrete” fill style are created for 

Slabs . See “The Slab Tools” on page 
462. 

• Material Regions - Closed polylines for 
each layer of a Wall or Floor Material 
Region or a Custom Backsplash are 
created. The polylines use the fill style 
specified in the object’s material layers 

definition. See “Floor and Wall Material 
Regions” on page 799.

Regardless of the fill style specified for a 
layer, if the associated material is assigned 
the Material Type of “Gap”, no CAD object 
will be created to detail that layer. See 
“Material Types” on page 860.  

The CAD objects created by the Auto 
Detail  tool are placed on the Current 
CAD Layer. See “Current CAD Layer” on 
page 1107. 

Note that using the Auto Detail  tool 
twice results in two copies of the same CAD 
objects.

Once created, these CAD objects can be 
selected and edited. See “Editing Closed-
Polyline Based Objects” on page 201 and 
“Editing Box-Based Objects” on page 206.

Insulation
Instead of using the fill style specified for a 

given material layer, the Auto Detail  tool 

can generate an Insulation  CAD box. 
See “Insulation” on page 1102.

When Auto Detail as Insulation is checked 

for a layer, Auto Detail  will produce an 
Insulation box instead of a polyline with a fill 
style - even if a fill style is also specified. 

Auto Detail as Insulation is not available if 
the selected layer has a “Gap” Material Type 
assigned to it. 

See “Wall Type Definitions Dialog” on page 
305 and “Material Layers Definition 
Dialogs” on page 802.



Displaying 3D Views

 907

Displaying 3D Views
A variety of tools and settings allow you to 
control the appearance of your 3D views. 
There are also numerous ways to adjust the 
position, focal point and field of view of a 
3D view. See “Editing 3D Views” on page 
916.

The name of the current plan file and the type 
of view displays at the top of each view 
window in its title bar. If a 3D view is saved, 
its name also displays. 

There is no limit to the number of 3D view 
windows that you can have open at a given 
time; bear in mind, though, that each window 
demands use of your computer’s resources 
and that you may see poor performance if too 
many views are open. See “Working in 
Multiple Views” on page 883. 

Layer Display Options
Which objects display in a 3D view is 
controlled in the Layer Display 

Options dialog. See “Layer Display Options 
Dialog” on page 149. 

Different view types use different layer sets 
when they are created. See “Layer Sets” on 
page 146.

To show framing in a cross section/elevation 
view, framing must first be built using the 
Build Framing dialog and the appropriate 
framing layers must be turned on in the 
Section View layer set. See “Framing” on 
page 577.

In Floor Plan View
Cameras can be represented in floor plan 
view in either of two ways:

• By symbols that indicate the camera’s 
position, field of view and focal point. 

• Camera symbols representing cross sec-
tion/elevation views indicate the clip 
plane position, line of sight, and back clip 
plane position if there is one. 

• By callouts or, for cross section/elevation 
views, double callouts. 
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You can control the display of a camera’s 
focal point and line or sight, or its backclip 
plane indicator and line of sight, as well as 
specify a camera symbol or callout, in the 
camera’s specification dialog. See “Plan 
Display Panel” on page 926. 

2D camera symbols are located on the 
“Cameras” layer by default; however, you 
can place a selected camera on any layer you 
wish. See “Layers” on page 143.

By default, active camera symbols display 
regardless of whether the “Cameras” layer is 
on or off. If you prefer that their display be 
turned on or off with this layer, uncheck 
Always Display Active Cameras in the 
Camera Defaults dialog. See “Camera 
Defaults Dialog” on page 889. 

Active camera symbols use the Move color 
set in the Preferences dialog. All other 
display attributes are derived from the 
“Cameras” layer. See “Colors Panel” on page 
94.

By default, the symbols for Full Overviews, 
Cross Section/Elevation, and Backclipped 
Cross Section views display on all floors, 
while those for Full and Floor Cameras, 
Floor Overviews, and Wall Elevations 
display only on the floor where they were 
created. You can, however, specify whether 
any camera’s symbol displays on all floors or 
not in its specification dialog. See “Plan 
Display Panel” on page 926.

You can also move a camera to a different 

floor by clicking the Up One Floor  or 

Down One Floor  button while the 
camera view is active. Note that this may 
affect what is seen in the view as well as its 

display in floor plan view. See “Floor Up / 
Floor Down” on page 443. 

Camera Labels and Callouts
Both saved and unsaved active cameras can 
have labels indicating the camera or callout 
number or its name. Camera labels are 
located on the “Cameras, Labels” layer and 
use the Text Style assigned to that layer. See 
“Object Labels” on page 1279. 
• Camera labels and callout numbers are 

numbered sequentially in each plan in the 
order they were created unless you 
rename them. 

• Camera labels always use the Camera 
Name. Saved cameras’ names can be 
specified in the Camera Specification 
dialogs. See “Camera Panel” on page 
924.

• Saved camera callout labels and addi-
tional text can also be specified. See 
“Plan Display Panel” on page 926.

• If a cross section/elevation view using a 
callout is sent to layout, the layout page’s 
Label can display as the callout’s Text 
Below Line. See “Layout Page Informa-
tion” on page 1261.

Camera symbols display a letter indicating 
the Rendering Technique it uses. This letter 
uses the same text style as the camera label. 
See “Rendering Techniques” on page 951.

Camera symbols are an on-screen reference: 
they do not print unless Print Image is used 
and cannot be sent to layout except as an 
image. They are, however, included when 

CAD Detail from View  is used and in 
views exported to .dxf/.dwg.
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In contrast, camera callouts are included 
when the view is sent to layout, printed, or 
exported and when CAD Detail from View 

 is used.

In Rendered Views
There are a number of factors that contribute 
to the appearance of rendered 3D views:
• Select 3D> Camera View Options> 

Toggle Textures  in a 3D view to turn 
off the display of material textures. See 
“About Materials” on page 848. Not 
available in Glass House,Technical Illus-
tration, Line Drawing or Vector Views. 

• Select View> Color  to toggle 
between color and greyscale in 3D views. 
See “Color On/Off” on page 217. 

• Select 3D> Lighting> Adjust Lights  
to open the Adjust Lights dialog and edit 
the light sources in the current plan. See 
“Adjust Lights Dialog” on page 940.

• Select 3D> Camera View Options> 

Final View  or Final View with 
Shadows  to regenerate the rendered 
view based on the final view settings on 
the RENDER panel of the Preferences 
dialog. See “Previews vs Final Views” on 
page 936.

In Vector Views
There are also a number of factors that affect 
the appearance of 3D Vector Views:

• Select 3D> Toggle Patterns  in a 
Technical Illustration, Watercolor, Line 
Drawing, or Vector View to turn on or off 

the display of the “Patterns, 3D Views” 
layer, which controls the display of mate-
rial pattern lines. See “Layers” on page 
143. 

• Select View> Color  to toggle 
between color and black and white to 
control the display line and fill colors. 
See “Color On/Off” on page 217. 

• The line style, color, and weight of 
objects in Vector Views can be specified 
by layer or, for some objects, individually 
in their specification dialogs. See “Line 
Style Panel” on page 1085.

• The line weight, color, and style of mate-
rial patterns are set in the Define Material 
dialog. See “Define Material Dialog” on 
page 864.

• Line weights display on screen when 

Show Line Weights  is enabled. See 
“Line Weights” on page 1219.

3D Backdrops
A backdrop is an image, usually of an 
exterior view, that displays in the background 
of 3D views to help place the model into a 
realistic setting and add a sense of 
perspective. If a backdrop is not specified, 
Chief Architect applies a background color. 
See “3D Backdrops” on page 1155.

Rendering Techniques
Any 3D view can be assigned a 
Rendering Technique for a range of 

different purposes: from detail drawings to 
artistic presentation views. Select 3D> 
Rendering Techniques to access these tools. 
See “Rendering Techniques” on page 951.
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Delete 3D Surface
The individual surfaces that make up 
objects can be temporarily removed 

from any 3D view by selecting 3D> Delete 
Surface and then clicking on a surface. 
When the pointer is over a surface, that 
surface will become highlighted.

Surfaces removed in one view are removed 
in all 3D views, but are not permanently 
removed from the model. Continue clicking 
surfaces to remove them, then select another 
tool when you are finished.

Surfaces in 3D views are composed of 
multiple triangles. Hold the Alt key while 
clicking to delete one triangular face at a 
time rather than all triangles forming a  
surface. See “Higher Quality Rendering” on 
page 936. 

To restore the most recently deleted surface, 

select 3D> Delete Surface  or click the 
toolbar button. 

There are several ways to restore all deleted 
surfaces:
• Select Build> Floor> Rebuild Walls/

Floors/Ceilings , 
• Exit the 3D view and reopen it.
• Generate a new 3D view. 

Rebuild 3D
Select 3D> Rebuild 3D to regenerate 
all 3D data associated with the current 

plan. All open views will remain open.

Remove 3D
Select 3D> Remove 3D from floor 
plan view to close all 3D views 

associated with the current plan file and 
remove unsaved 3D data from memory.

Any views saved with the plan are closed but 
not deleted.

Repositioning Cameras
Once a 3D view is created, there are many 
ways to manipulate the camera location and 
the direction of its line of site using the 
mouse, the keyboard, and the menus. 

The Move Camera with Mouse buttons are 
included on the toolbars  in 3D views by 
default; but, you can add the other tools your 
toolbars as well as customize their hotkeys. 
See “Toolbars and Hotkeys” on page 129.

When the keyboard or menu commands are 
used to move or rotate a camera, the 
adjustments occur in regular increments. The 

size of these increments is specified in the 
Camera Specification dialog: 
• The Incremental Move Distance con-

trols Panning movement and forward and 
backward Dolly movement. 

• The Incremental Rotate Angle controls 
Orbit movement, Tilt movement, and side 
to side Dolly movement.

See “Camera Panel” on page 924. 

Each time you move the camera, the view is 
updated. If you are using either the toolbar or 
keyboard to move the camera,  you can hold 
down the Shift key, suppressing the redraw 
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of the view until the Shift key is released and 
allowing you to move multiple increments 
more quickly. 

You can also move a camera to a different 

floor by clicking the Up One Floor  or 

Down One Floor  button while the 
camera view is active. Note that this may 
affect what is seen in the view as well as its 
display in floor plan view. See “Floor Up / 
Floor Down” on page 443. 

Mouse Scroll Wheel and Trackpad
3D views can be panned and zoomed when 
any tool is active using the mouse scroll 
wheel or trackpad gestures. See “Using a 
Trackpad” on page 34.

The program adjusts the speed of these 
actions depending on characteristics of the 
camera: 
• Zoom speed depends on how close the 

camera is to the object located behind the 
mouse pointer. When the target object is 
far from the camera, zooming is faster; as 
the camera gets closer to the target, 
zooming slows. 

• Panning speed depends on the length of 
the camera’s Line of Sight. In general, it 
is likely to be faster in an exterior view of 
a large model, slower in an interior view 
of a small room. See “Creating Camera 
Views” on page 899.

By default, panning and zooming adjusts the 
position and direction of the camera. It does 
not, however, adjust the distances at which 
surfaces are clipped. This means that if you 
zoom in closely on an object, some of its 
surfaces may be removed from the view. One 
way to avoid this is to lower the camera’s 
Clip Surfaces Within value in the Camera 
Specification dialog. See “Camera Panel” 
on page 924. 

Another way to avoid this is using 

Perspective Crop Mode . 

When Perspective Crop Mode  is active, 
panning and zooming do not adjust the 
position of the camera. As such, using it can 
result in inconsistencies between a camera’s 
position and what is actually shown in the 
view. For this reason, it should only be used 
to zoom in closely on small objects or 
details. 

To use Perspective Crop Mode

1. Zoom in on an object that you would 
like to examine closely.

2. If any of its surfaces disappear, zoom out 
until they are restored.

3. Select 3D> Camera View Options> 
Perspective Crop Mode .

4. Zoom in on the object, but try to limit 
any panning or other changes to the 
camera’s perspective.

Press Ctrl + Alt + S while in a camera
view or overview to spin the view.

Press Esc to stop the spinning.

Perspective Crop Mode is not used
when a view is sent to layout. This

means that a view on the layout page may
not look the same as the original view. See
“Layout” on page 1235. 
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3Dconnexion® 3D Mice
3Dconnexion®'s 3D mice can be used to 
navigate in all views - including camera 
views and overviews.

In the Windows version of Chief Architect, 
pre-programmed view direction hotkeys are 
supported on devices with buttons for that 
purpose. OS X does not provide mapping 
support to the view direction commands; 
however, you can create custom hotkeys for 
the commands in Chief Architect and then 
program your 3D mouse to use those 
hotkeys. See Hotkeys.

In Orthographic views, navigation is 
centered around the camera’s focal point; for 
Perspective views, you can specify whether 
navigation is centered about the camera or its 
focal point in the Preferences dialog. See 
“Render Panel” on page 123.

Note that rolling is not supported in Chief 
Architect and that 3D mice cannot be used to 
move the mouse pointer. For details about 
using your 3D Connexion® mouse, refer to 
its documentation.

Move Camera with Mouse
An active camera’s position can be 
edited using the mouse. Select 3D> 

Move Camera With Mouse to access the 
Move Camera with Mouse modes. With the 

exception of Mouse Orbit Camera, which is 
available in Orthographic Overviews, these 
tools are not available in Orthographic 
views.

Once Perspective Crop Mode has
been enabled in a camera view, it

should remain toggled on and navigation in
that view should be limited.

Hotkey Description

Alt + O Mouse-Orbit Camera lets you move the mouse to rotate the camera 
around its focal point. The camera’s position and direction both change.

To continuously rotate the camera around its focal point, click in the 3D 
view, drag the mouse, and release the mouse button to “throw” the 
view. Click again in the view to stop it from rotating. 

Alt + 
middle 
mouse 
button

To temporarily activate Mouse-Orbit Camera, hold down the Alt key 
and then click and drag using the middle mouse button. When the Alt 
key and middle mouse button are released, whatever tool was 
previously in use will still be active. 
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Move Camera with Keyboard
An active camera’s position can be changed 
using the Arrow keys on your keyboard. 
Select 3D> Move Camera with Keyboard 
to access the Move Camera with Keyboard 
modes. With the exception of Mouse Orbit 
Camera, which is available in Orthographic 
Overviews, these modes are not available in 
Orthographic views.

These modes use the Incremental Move 
Distance and Incremental Rotate Angle set 
in the active 3D view’s Camera 
Specification dialog. 
• Keyboard-Orbit Camera lets you use 

the keyboard to rotate the camera around 

the focal point. The camera’s position 
and direction both change.

• Keyboard-Pan Camera lets you move 
the camera up, down, right, and left using 
the keyboard. The camera’s position 
changes, but its direction does not.

• Keyboard-Dolly Camera lets you move 
the camera forward and back using the 
Up and Down Arrow keys, and rotate 
side to side using the Left and Right keys. 

• Keyboard-Tilt Camera lets you use the 
Arrow keys to tilt the camera up, down, 
or side to side to change the focal point. 
The camera’s direction changes, but its 
position does not. 

Alt + P Mouse-Pan Camera lets you move the camera up, down, left and right 
using the mouse. The camera’s position changes, but its direction does 
not.

Alt + D Mouse-Dolly Camera lets you move  the camera forward and 
backward by moving mouse up and down. Move the mouse left or right 
to rotate the camera side to side. 

Alt + T Mouse-Tilt Camera lets you move the mouse to tilt the camera in any 
direction while staying in the same location. 

3D Center Camera on Point lets you focus the camera at a particular 
point in the scene. This changes the camera’s direction and focal point, 
but not its position. To use the 3D Center tool, activate the tool and 
then click on any object in the scene.

Z 3D Focus on Object lets you focus the camera on a specific object. 
This changes the camera’s position, direction, focal point, and the 
length of its line of sight. To use the 3D Center tool, activate the tool 
and then click on any object in the scene.

Hotkey Description
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Move Camera Tools
Select 3D> Move Camera in a 3D 
view to access these tools. These tools 

change the active camera’s position, but not 
its direction and are not available in  
Orthographic views. 

These tools use the Incremental Move 
Distance set in the active 3D view’s Camera 
Specification dialog. 

Orbit Camera Tools
Select 3D> Orbit Camera in a 3D 
view to access these tools. Orbiting 

the camera rotates it about the focal point 
using the Incremental Rotate Angle set in 

the active view’s Camera Specification 
dialog. 

These tools are not available in , Back 
Clipped Cross Section, or Wall Elevation 
views.

Note: Although the Arrow keys are set to
move active cameras by default, you can cre-
ate custom hotkeys for these commands if
you prefer. See “Hotkeys” on page 138.

Hotkey Description

F Move Camera Forward moves the camera and its focal point forward. 

B Move Camera Back moves the camera and the focal point back. 

L Move Camera Left moves the camera and the focal point to the left in 
a line perpendicular to the line of sight. 

R Move Camera Right moves the camera and the focal point to the right 
in a line perpendicular to the line of sight. 

U Move Camera Up moves the camera and the focal point up. 

D Move Camera Down moves the camera and the focal point down. 
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Tilt Camera Tools
Select 3D> Tilt Camera to access 
these tools. Tilting keeps the camera 

in one place and pivots the camera about its 
vertical or horizontal axis. This movement 
uses the Incremental Rotate Angle set in 
the active view’s Camera Specification 

dialog and is similar to tilting your head up 
and down or turning it side-to-side. 

These tools are not available in  
Orthographic views. 

Hotkey Description

I Move Camera In moves the camera closer to the focal point along the 
line of sight. The camera cannot move past the focal point using this 
tool.

O Move Camera Out moves the camera away from the focal point along 
the line of sight. 

Orbit Camera Upward rotates the camera up about the focal point. 
The camera cannot rotate past a vertical line looking straight down on 
the focal point.

Orbit Camera Downward rotates the camera down about the focal 
point. The camera cannot rotate past a vertical line looking straight up 
at the focal point.

Orbit Camera Left rotates the camera to the left about the focal point.

Orbit Camera Right rotates the camera to the right about the focal 
point. 

Hotkey Description

Tilt Camera Upward tilts the camera up while keeping it in the same 
location. The camera cannot tilt beyond the vertical position.

Tilt Camera Downward tilts the camera down while keeping it in the 
same location. The camera cannot tilt beyond the vertical position.
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View Direction Tools
The View Direction Tools allow you 
to view the model from a specific 

direction in a camera view, overview, or 
cross section/elevation view. While one of 
these views is active, select 3D> View 
Direction to access these tools. 

Editing 3D Views
In addition to its position and direction, there 
are other ways to modify a 3D view.

In the Specification Dialog
You can  make adjustments to a 
camera in the Camera Specification 

dialog. This dialog is particularly helpful for 
making fine adjustments to the camera’s 

position, appearance, and other attributes. 
See “Camera Specification Dialog” on page 
924.

Turn Camera Left turns the camera to the left while staying in the 
same location.

Turn Camera Right turns the camera to the right while staying in the 
same location.

Hotkey Description

Description

Front View creates a front view 
of the model.

Back View creates a back view 
of the model.

Top View creates a top view of 
the model.

Bottom View creates a bottom 
view of the model.

Left Side View create a left side 
view of the model.

Right Side View create a right 
side view of the model.

Restore Original View restores 
the original view position.

Description

Tile a 3D view and the floor plan view
and use the camera movement tools to

see how they affect the camera. See “Tiling
Views” on page 884.
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Using the Edit Tools
A camera symbol or symbols selected in 
floor plan view can be edited in a variety of 
ways using the buttons on the edit toolbar. 
See “The Edit Toolbar” on page 37.

Using the Edit Handles
Return to floor plan view without closing the 
3D view. See “Working in Multiple Views” 
on page 883. 

Using the Select Objects  tool, select the 
camera object. When a camera symbol is 
selected it displays six edit handles. 

• Drag the Rotate Label handle or smaller 
Move Label handle to rotate or move the 
camera label.

• Drag the Line of Sight handle to change 
the camera angle without moving the 
focal point.

• Drag the Move handle to relocate the 
camera while maintaining its relative 
angle.

• Drag the Focal Point handle to reposition 
the focal point and change the line of 
sight without moving the camera.

• Drag the Rotate handle to rotate the cam-
era’s line of sight about its center.

The 3D view corresponding to the camera 
symbol reflects changes made to the symbol 
in floor plan view. 

When a cross section/elevation camera is 
selected, it displays seven edit handles, three 
of which are unique to cross section/
elevations.

• Drag either of the two Resize Clip Plane 
handles to adjust the length of the clip 
plane line, which is perpendicular to the 
camera’s line of sight. Left-click to resize 
the line concentrically and maintain the 
camera’s position; right-click to move the 
selected end as well as the camera. This 
will affect what can be seen in the view if 
Clip to Sides is checked. See “Camera 
Panel” on page 928. 

• Drag the Move Clip Plane handle to 
move the camera and its clip plane paral-
lel to its line of sight.

• If a stepped cutting plane is created, addi-
tional edit handles are available. See 
“Stepped Cutting Planes” on page 904. 

Rotate

Focal Point

Line of Sight

Move

Move Label

Rotate Label

Note: Camera callouts do not display labels,
so they do not have label edit handles.

Focal Point

Move Clip 
     Plane
Move

Move Label

Rotate Label

Resize Clip 
     Plane
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Multiple camera symbols can be selected; 
however, their editing options are limited to 
being moved, rotated, and deleted. You can 
also create revision clouds around group-
selected camera symbols. 

Using the Contextual Menu
In a 3D view, right-click in an empty space in 
which the backdrop or background color 
displays to access the contextual menu. See 
“Contextual Menus” on page 38. 

• In Vector Views, the options are a selec-
tion of commonly used commands from 
the File, Edit, Tools and Window menus. 

• In rendered views, the options are a 
selection of tools and toggles specific to 
rendered views or override the settings in 
the Preferences dialog. See “Render 
Panel” on page 123.

Changing a setting in the contextual menu 
only affects the current view. It does not 
affect the settings in the Preferences dialog.

Up One Floor/Down One Floor
You can move a camera to a different floor. 
While the camera view is active, select 
Tools> Reference Floors> Up One 
Floor  or Down One Floor . Note that 
this may affect what is seen in the view as 

well as its display in floor plan view. See “In 
Floor Plan View” on page 907. 

The position and movement of a camera is 
affected by its location within the model. 
When the camera is outside a building, its 
height is relative to the terrain and follows 
the terrain as it is moved. When inside a 
building, the camera height is relative to the 
floor of the room it is drawn in.

Which floor an active camera is on 
determines which floor is affected when any 
floor-specific actions are done. For example, 
if a camera is on Floor 2 and changes are 
made to the Floor Default settings while in 
that view, Floor 2 will be affected.

If the camera is on an upper floor and you 
move the camera outside of the building, the 
camera remains at the same height relative to 
the floor it was created on.

Zooming
The Zoom Tools are available in all 
3D views. See “Zoom Tools” on page 

881. 

Selecting Window> Zoom In , Zoom 
Out  or Fill Window  does not change 
the camera’s location or field of view. 
Instead, the extents of the view are expanded 
or cropped. 

If you wish, you can instead set the 

Zoom  tools to change the  Field of View 
when used in a 3D view. See “Render Panel” 
on page 123.

Field of View
The Field of View refers to a camera’s field 
of vision. A wider field of view makes the 



Cross Section Slider

 919

focal point appear further away, as more of 
the image is included in the same view 
window. 

In floor plan view, the angled lines of a 
camera symbol indicate its field of view. 

A camera’s field of view can be adjusted in 
the Camera Specification dialog. See 
“Camera Panel” on page 924.

Cross Section Slider
Select 3D> Camera View Options> 
Cross Section Slider when a camera 

view or overview is active to open the Cross 
Section Slider dialog. 

FOV Indicators

Note: The Cross Section Slider is not avail-
able when the Vector View Rendering Tech-
nique is used. See “Rendering Techniques”
on page 951. 
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To use the Cross Section Slider

1. Check the box beside a cross section 
cutting plane to select it and make its 
Position slider and text box active.

2. Move the Position slider to adjust the 
position of the cutting plane. 

•  The cutting plane Position is measured 
from the edge of the model that is cut 
first by the selected cutting plane.

•  Position the Cutting Plane with accu-
racy using the text field to the right of 
the slider. 

3. Repeat steps 1-3 to use additional cut-
ting planes if you wish. 

4. Click OK to close the dialog. If the 
active camera is saved, its Cross Section 
Slider settings will also be retained. See 
“Saving 3D Views” on page 922. 

Working in 3D
A variety of tools are available in 3D views 
that allow you to edit your 3D model. You 
can also use the Dimension, Text, and CAD 
Tools to add annotation to cross section/
elevation views.

Creating Objects in 3D Views
You can place windows, doors, cabinets, 
electrical objects, corner trim, and most 
library objects directly into 3D views. To do 
this, select the appropriate tool and click in 
the 3D view. You can then edit the object’s 
size and placement. 

When created in 3D, most objects must be 
placed against a wall, on a floor platform, or 
within the Terrain Perimeter.  

You can also click and drag to draw some 
CAD-based objects such as custom 
countertops, roof planes, terrain features and 
road, in camera views and overviews views. 

The Build Framing and Build Roof dialogs 
are also accessible in 3D views, although the 

manual Framing Tools  and Roof 
Tools  are not. 

Selecting and Editing 
Objects in 3D Views

Most objects can be selected and edited in 

3D views. Select Edit> Select Objects  
and click on the surface of an object to select 
it. Once selected, objects can be edited using 
their edit handles, buttons on the edit toolbar, 
and the object’s specification dialog. See 
“Editing Objects” on page 177.

When you select an object, edit handles and a 
handle surface display. The handle surface is 
a rectangle around the perimeter of the object 
that indicates the overall height and width of 
the selected surface. The edit handles that 
display depend on the type of object selected. 
Walls, for example, display two resize edit 
handles when selected while a slab displays 
ten handles, allowing you to move, resize 
and reshape it.

Note: If the wall height of the Exterior Room
is adjusted in a 3D view, the default Floor or
Ceiling Height of the entire floor is changed.
See “Floor and Room Defaults” on page 330.
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All moving or resizing is in the plane of the 
handle surface. You cannot  move an object 
directly towards or away from the camera, 
for example, because that surface plane 
cannot be seen in the view. 

By default, object movement is restricted to 
one inch or 10 mm increments, but this 
restriction can be set to custom increments in 
the Plan Defaults dialog and toggled off and 

on using the Grid Snaps  button. See 
“Grid Snaps” on page 166.

Unrestricted positioning can also be enabled 
by holding down the Ctrl key while moving 
or resizing an object. See “Unrestricted 
Movement” on page 221. 

Temporary dimension lines display when 
many objects are selected to help you resize 
the object and determine its height. These are 
sometimes easier to see when the color is 
toggled off. See “Temporary Dimensions” on 
page 1008.

Because cross section/elevation views are 
orthogonal and display objects at their actual 
dimensions, they are sometimes more 
suitable for editing objects than camera 
views or overviews. See “Cross Section/
Elevation Views” on page 902.

When several 3D views are open, changes 
made in the plan automatically rebuild the 
model in all views.  Because of this, it is 
typically faster to make changes to your plan 
with as few windows open as possible.

Editing Materials in 3D Views
Select 3D> Materials> Adjust 
Material Definition, then click on a 

surface in the 3D view to open the Define 

Material dialog for that material. See “Adjust 
Material Definition” on page 857.

Select 3D> Material Painter to apply 
materials to surfaces in the view using 

the Material Painter Tools. See “The Material 
Painter” on page 849.

Select 3D> Material Painter> 
Material Eyedropper to apply the 

material on a surface in the view to other 
surfaces in the view. See “Material 
Eyedropper” on page 852. 

Rebuild 3D
As changes are made to your plan, a 
3D view automatically updates to 

reflect any changes visible in the view. If you 
find that a view is not updating as expected, 
select 3D> Rebuild 3D to rebuild the entire 
3D model.

Annotating 3D Views
The Dimension Tools, Text Tools, and CAD 
Tools are available in cross section/elevation 
views, allowing you to add technical 
information, call attention to details, and 
other tasks in these views. See “Detailing 
Cross Section/Elevation Views” on page 
905.

You can also add annotation to any other 3D 
view by first making a line-drawn copy of 
the view using the CAD Detail from 
View  tool. See “CAD Detail from View” 
on page 1118.

Cross Section Lines
Cross Section Lines are created in cross 
section views to represent any objects split 
by the cross section line of the camera. They 
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are placed on the “Cross Section Lines” 
layer, which is locked by default, and they 
get deleted and replaced whenever the view 
is redrawn.

When a dimension is drawn to locate an 
object split by a camera’s section line, it 
actually locates Cross Section Lines. So that 
dimensions can be retained when Cross 
Section Lines are regenerated, a Point 
Marker  is automatically created where a 
dimension meets a Cross Section Line and 
the dimension locates it instead of the Cross 
Section Line. See “Point Markers and 
Dimensions” on page 1059. 

Cross Section Lines will print when their 
layer is turned on; however, they are not 
included when the view is sent to layout. The 
Point Markers created when dimensions 
locate Cross Section Lines, however, will 
both print and display in views sent to layout. 
See “Layout” on page 1235.

The “Cross Section Lines” layer can be 
unlocked, allowing Cross Section Lines to be 
be selected and edited. Additional CAD 
objects can also be placed on this layer when 
it is unlocked, as well; however, when the 
view is redrawn, all CAD objects on this 
layer will be deleted and replaced with a 
fresh set of Cross Section Lines. 

Saving and Printing 3D Views
3D camera views, overviews and cross 
section/elevation views can be saved with the 
plan in which they are created, exported and 
saved as image files, as well as sent to layout 
and printed. 

Saving 3D Views
Select 3D> Save Active Camera to 
save the current camera in the plan. 

You can also save a camera view by checking 
the Saved box in the Camera Specification 
dialog. See “Camera Specification Dialog” 
on page 924. 

Saved cameras can be closed and re-opened 
for later use, and retain their Cross Section 
Slider, Sunlight, Shadows, and Rendering 
Technique settings. See “Cross Section 
Slider” on page 919, “Adjust Sunlight 
Dialog” on page 950, “Shadows” on page 
934, and “Rendering Techniques” on page 
951.

In addition, if CAD or Text objects are drawn 
in a cross section/elevation view, you will be 
prompted to save the view when you close it. 
Any CAD or Text objects added to a cross 
section/elevation view are saved with the 
view as part of the plan file. 

Once a 3D view is saved, it is listed in the 
Project Browser and can be named. The 
name displays in its label with the camera 
symbol in floor plan view and in its view 
window tab. See “Project Browser” on page 
1125. 

Activating Saved Views
There are three ways to open a saved 3D 
view: 
• Select the camera symbol in floor plan 

view and click the Open View  edit 
button.
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• Double-click the camera symbol using 

the Select Objects  tool.
• Double-click on the saved camera view 

in the Project Browser or right-click on 
it and select Open View from the contex-
tual menu.

Unsaved cameras that are open in another 
view window can also be activated using the 

Open View  edit button.

If you open a saved camera view and then 
modify its location or direction using any of 
the tools available in that view, the program 
will confirm whether you want to re-save the 
camera using these new settings when you 
close it. See “Repositioning Cameras” on 
page 910.

CAD Detail From View
In any 3D view using the Vector View 
rendering technique, you can select 

CAD> CAD Detail From View to generate 
an editable line drawing of the view in a 
CAD Detail window. CAD Details created 
from a view do not update when the model is 
changed. See “CAD Detail from View” on 
page 1118.

Exporting 3D Views
All 3D views can be exported and 
saved as .bmp, .jpg, .png, or .tif files. 

Select File> Export> Picture to save the 
current screen image as an image file. See 
“To export a picture” on page 1141.

In addition, Vector Views can be exported 
and saved as .emf files. See “Metafiles” on 
page 1145. 

Once saved, a picture can be opened and 
converted into many other formats using a 
graphics program. Picture files can be sent to 
layout or used in word processing, desktop 
publishing, and web development programs 
to create advertisements, brochures, etc.

Plan Backup
When transferring a plan to another 
computer or to another user, it is 

helpful to include all the Images, Textures, 
and Backdrops used in the plan so that 
rendered views are complete. The Backup 
Entire Plan tool allows you to do so. See 
“Backup Entire Plan” on page 70.

Printing 3D Views
Since all 3D views other than Vector 
Views are created using pixels instead 

of lines, File> Print> Print Image must be 
used when printing. Print Image is a special 
Chief Architect function that prints the 
screen in picture format. The entire view 
prints, including images such as plants and 
textures. 

3D views can also be sent to layout and then 
printed as part of your construction 
documents.

Select File> Send to Layout to send 
the current view to layout. See 

“Sending Views to Layout” on page 1240.

Select a saved, inactive camera 
symbol in floor plan view and click 

the Send Camera’s View to Layout edit 
button to send the view to layout. 

For high quality renderings, consider
using ray tracing. See “Ray Tracing” on

page 965.
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Camera Specification Dialog
The Camera Specification dialog can 
be accessed in floor plan view by 

selecting a single camera symbol and 
clicking the Open Object edit button. See 
“In Floor Plan View” on page 907.

This dialog can also be accessed while a 
camera view or overview is active by 

selecting 3D> Edit Active Camera . 

The selected view’s specific type is indicated 
in the dialog’s title bar: the specification 

dialog for a Full Camera , for example, 
is named Full Camera Specification.  

This dialog can only be opened for one 
camera at a time. If more than one camera 

symbol is selected, Open Object  will not 
be available. 

Camera Panel
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Some settings only affect some types of 
views. Depending on the type of camera 
view selected, not all the settings may be 
available. 

To change a setting, first uncheck Default, 
then type a new value in the text field. 

General - 

• Specify the Name that displays in the 
camera label in floor plan view and in the 
Project Browser. See “Project Browser” 
on page 1125.

• Check Saved to save this view with the 
plan. As soon as you type anything in the 
text field, this box becomes checked. If 
you click OK while this box is checked, it 
will become checked permanently. Saved 
cameras are listed in the Project Browser. 

• Select the Rendering Technique used by 
the selected camera from the drop-down 
list. See “Rendering Techniques” on page 
951. 

• Check Show Shadows to turn on shad-
ows in the selected camera view. When 
unchecked, shadows are not generated. 
See “Shadows” on page 934.

The Positioning settings determine the 
position and orientation of the camera. 

Check Default for any setting to use the 
value set in the Camera Defaults dialog. See 
“Repositioning Cameras” on page 910. 
• The Incremental Move Distance con-

trols how far the camera moves each time 
you Pan in any direction or Dolly for-
wards or backward. For interior views a 
small number is good, but for exterior 
you may want a larger increment.

• The Incremental Rotate Angle defines 
how many degrees the camera rotates 
each time you Tilt, Orbit, or Dolly side to 
side. A setting of 90° would make one 
full rotation in four moves.

• The Height Above Floor defines the 
height that the camera is above the floor 
level for the current floor. See “Camera 
Height” on page 899.

• The Field of View defines the camera’s 
field of vision in angular degrees. See 
“Field of View” on page 918.

• The Tilt Angle determines the vertical 
angle that the camera is tilted. The cam-
era maintains its focal point and position 
in floor plan view, but if the camera is 
tilted, the focal point is above or below 
the current camera height. 

• Specify the selected camera’s Camera 
Angle. This is an absolute value: an angle 
of 0° points the camera toward the left in 
floor plan view.

• Specify the X Position and Y Position 
for the selected camera. These are abso-
lute coordinates. Specifying zero for both 
places the camera at the plan’s origin 
point (0,0). 

The Scene Clipping settings control 
the extents of the camera view. Both of 

the Within distances are measured as a 
radius from the camera position.
• Clip Surfaces Within - Objects located 

within this distance from the camera do 

1

2

You can increase a camera’s Field of
View when the view is active by press-

ing the W key, or decrease the Field of View
by pressing the N key. 

3
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not display in the view. Decrease this 
value to display objects located very 
close to the camera; increase it to 
improve the appearance of some surfaces 
in Overview cameras with very large 
extents. 

• Remove Wall Within - Remove the view 
of walls within this distance of the cam-
era.

• Check Unless Opening to display a wall 
that is inside the Remove Wall Within 
range if the camera is pointing through an 
opening such as a door or window.

• Check Default for any value to use the 
default setting. 

Options - 

• Uncheck Show Lower Floors to show 
only the current floor in the selected 
Floor Overview. When checked, the cur-
rent floor plus any floors beneath it are 
included in the view. Only available for 
Floor Overviews. See “Floor Overview” 
on page 900. 

• Click the Advanced button to open the 
Advanced Camera Options dialog and 
specify how hidden lines are handled in 
Vector Views when OpenGL is not used. 
See “Advanced Camera Options Dialog” 
on page 891. 

Plan Display Panel
The settings on the PLAN DISPLAY panel 
control the appearance of the selected camera 

in floor plan view. See “In Floor Plan View” 
on page 907. 

4
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Check Display on All Floors to display 
the selected camera’s symbol in floor 

plan view on all floors. When unchecked, it 
only displays on the floor where the camera 
was created. See “Creating Camera Views” 
on page 899. 

Check Display As Callout to use a 
callout symbol to represent the selected 

camera in floor plan view and enable these 
settings. Most of the Standard Options, 
below, are unavailable when Display as 
Callout is checked.
• Specify the Callout Label, which is the 

text that displays inside the callout circle. 
If no Text Below Line is specified, the 
Callout Label is centered in the callout.

• Specify the Text Below Line for a bot-
tom row of text, if desired. Check Auto-
matic to populate the Text Below Line 
with the camera’s Name, as specified on 
the Camera Panel. See “Camera Labels 
and Callouts” on page 908. 

• To specify the Callout Size, uncheck 
Automatic and then type in the text field. 
When Automatic is checked, the size is 
based on the length of the Callout Label 
and the size of the current Text Style. 

• Specify the appearance of the Callout 
Arrow. Choose None, a Small arrow, or 
a Large arrow. Uncheck Filled if you do 
not want a solid filled arrow. 

The Standard Options settings allow 
you to specify the appearance of the 

selected camera’s standard symbol. Uncheck 

Default beside any of these options to 
modify it. Most of these options are disabled 
when Display As Callout is unchecked. See 
“Dynamic Defaults” on page 76. 
• The Camera Symbol Size is measured in 

plan inches (mm). 
• Check Show Camera Focal Point to dis-

play the camera’s focal point in floor plan 
view. When unchecked, the camera’s line 
of sight and focal point are hidden until 
the camera is selected. 

• Check Show Field of View Indicators to 
display the camera’s field of view indica-
tors in floor plan view. 

• You can also change the FOV Indicator 
Length, which is measured in plan 
inches (mm). 

Layer Panel
The setting on the LAYER panel lets you  
choose which layer the selected camera’s 
plan view symbol is placed on. For more 
information, see “Layer Panel” on page 154.

Label Panel
In the Camera Specification dialogs, the 
settings on the LABEL panel are limited to the 
Suppress Label checkbox and Position and 
Orientation settings. 

Camera labels always use the Camera Name 
specified on the CAMERA panel. When 
callouts are used, the Callout Label and 
Text Below Line are specified on the PLAN 
DISPLAY panel.

For information about this panel, see “Label 
Panel” on page 1280.

Note: Callout arrows only display as filled
when a camera is inactive. Inactive camera
callout arrows are unfilled. 

1

2

3
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Cross Section/Elevation Camera Specification
The Cross Section/Elevation 
Camera and Wall Elevation Camera 

Specification dialogs can be accessed in 
floor plan view by selecting a single cross 
section/elevation camera symbol and 

clicking the Open Object edit button. See 
“In Floor Plan View” on page 907.

These dialogs can also be accessed while a 
cross section/elevation camera view is active 

by selecting 3D> Edit Active Camera . 

Camera Panel

The Camera Name displays in floor 
plan view and is listed in the Project 

Browser. See “Project Browser” on page 
1125.
• Check Saved to save this view with the 

plan. As soon as you type anything in the 
text field, this box becomes checked. If 
you click OK while this box is checked, it 
will become checked permanently. Saved 
cameras are listed in the Project Browser.

• Select the Rendering Technique used by 
the selected camera from the drop-down 
list. See “Rendering Techniques” on page 
951.

• Check Show Shadows to turn on shad-
ows in the selected camera view. When 
unchecked, shadows are not generated. 
See “Shadows” on page 934.

The Scene Clipping settings control 
the extents of the camera view.

1

2
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• Back Clip After - Enter the distance in 
inches (mm) from camera to backclip 
plane. If zero, no back clipping occurs. 

• Check Clip To Sides to limit the selected 
camera view’s side-to-side extents to the 
length of its Clip Plane Indicator line(s) 
in floor plan view. When unchecked, the 
full width of the model is included in the 
view. 
The Clip Plane Indicator Length can be 
specified on the PLAN DISPLAY panel 
when callouts are not used, or using the 
camera’s edit handles in floor plan view. 
See “Editing 3D Views” on page 916. 

• Check Ignore Railings and Invisible 
Walls to ignore the room definition cre-
ated by these types of walls in a selected 

Wall Elevation  view. When this is 

unchecked, Wall Elevation  views 
only recognize room definition created 
by regular walls. See “Cross Section/Ele-
vation Camera Tools” on page 902.

Settings in the Positioning section 
determine the location of the camera in 

floor plan view.
• Specify the X Position of the camera in 

absolute coordinates.
• Specify the Y Position of the camera in 

absolute coordinates.

Click the Advanced button to open the 
Advanced Camera Options dialog and 

specify how hidden lines are handled in 
Vector Views when OpenGL is not used. See 
“Advanced Camera Options Dialog” on page 
891. 

Plan Display Panel
The settings on the PLAN DISPLAY panel 
control the appearance of the selected camera 

in floor plan view. See “In Floor Plan View” 
on page 907. 

3

4



930

Chief Architect X8 Reference Manual

Check Display on All Floors to display 
the selected camera’s symbol in floor 

plan view on all floors. When unchecked, it 
only displays on the floor where the camera 
was created. See “Creating Camera Views” 
on page 899. 

Check Display As Callout to use a 
callout symbol to represent the selected 

camera in floor plan view and enable the 
settings below. Most of the Standard 
Options, below, are unavailable when 
Display as Callout is checked.
• Specify the callout Placement, either at 

the Center, Left Side, Right Side, or Both 
Sides of the clip plane. If Center is 
selected, no clip plane line displays.

• Specify the Callout Label, which is the 
text that displays inside the callout circle. 
If no Text Below Line is specified, the 
Callout Label is centered in the callout.

• Specify the Text Below Line for a bot-
tom row of text, if desired. Check Auto-
matic to populate the Text Below Line 
with the layout page Label if the selected 
view is sent to layout. See “Camera 
Labels and Callouts” on page 908. 

• To specify the Callout Size, uncheck 
Automatic and then type in the text field. 
When Automatic is checked, the size is 
based on the length of the Callout Label 
and the size of the current Text Style. 

• Specify the appearance of the Callout 
Arrow. Choose None, a Small arrow, or 

1

2
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a Large arrow. Uncheck Filled if you do 
not want a solid filled arrow. 

• Specify the Cross Section Line Style. 
Not available when Center is selected, 
above. Check By Layer to use the line 
style specified for the selected callout’s 
layer, or choose a line style from the drop 
down list or the Library. 

• Specify the Cross Section Line Weight. 
Not available when Center is selected, 
above. Check By Layer to use the line 
weight specified for the selected callout’s 
layer, type a line weight in the text field. 

The Standard Options settings allow 
you to specify the appearance of the 

selected camera’s standard symbol. Uncheck 
Default beside any of these options to 
modify it. Most of these options are disabled 
when Display As Callout is unchecked. See 
“Dynamic Defaults” on page 76. 
• The Camera Symbol Size is measured in 

plan inches (mm). 
• Check Show Camera Focal Point to dis-

play the camera’s focal point in floor plan 
view. When unchecked, the camera’s line 

of sight, focal point, and clip plane indi-
cators are hidden until the camera is 
selected.

• Specify the Clip Plane Indicator 
Length in plan inches (mm). See “To cre-
ate a Cross Section/Elevation view” on 
page 903. 

Layer Panel
The setting on the LAYER panel lets you  
choose which layer the selected camera’s 
plan view symbol is placed on. For more 
information, see “Layer Panel” on page 154.

Label Panel
In the Cross Section/Elevation Camera 
Specification dialog, the settings on the 
LABEL panel are limited to the Suppress 
Label checkbox and Position and 
Orientation settings. 

Camera labels always use the Camera Name 
specified on the CAMERA panel. When 
callouts are used, the Callout Label and 
Text Below Line are specified on the Plan 
Display panel.

For information about this panel, see “Label 
Panel” on page 1280.

Note: Callout arrows only display as filled
when a camera is inactive. Inactive camera
callout arrows are unfilled. 

3
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Chapter 30:

3D Rendering

There are a variety of tools available to 
create 3D views of a model: simply click a 
button to create an overview, or click and 
drag to create a camera or cross section/
elevation view. See “3D Views” on page 887.

To improve the quality of the rendering and 
create a custom look, you can adjust lighting, 
edit the materials used in the plan, choose 
from a variety of rendering techniques and 
fine-tune 3D view quality settings. From 
most 3D views, you can create Final views of 
even higher quality.

You can also use Ray Tracing to create 
highly realistic images of your Chief 
Architect plans. As the name implies, ray 
tracing calculates the rays of light in a view 
as they travel through the 3D model and 
reflect off surfaces. As a result, ray tracing is 
slower than OpenGL rendering, but can be 
used to achieve much more complex effects 
such as reflections and highly realistic 
lighting. See “Ray Tracing” on page 965.

Chapter Contents
•      Rendering Tips
•      Lighting
•      Displaying Lights
•      Light Types
•      Light Specification Dialog
•      Sun Angles and Shadows
•      Sun Angle Specification Dialog
•      Adjust Sunlight Dialog
•      Rendering Techniques
•      Rendering Technique Options
•      Speeding up 3D View Generation
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Rendering Tips
There are a variety of factors which affect the 
appearance and quality of rendered 3D 
views. You can use these tools and settings to 
achieve renderings that meet your needs. 

Lighting
Lighting is extremely important in most 3D 
renderings, in ray tracing, and in VRML file 
export. Lighting controls the visibility of 
objects in a view, affects the appearance of 
surfaces, and influences the appearances of 
colors and textures on those surfaces. Even 
small changes to light intensity, direction and 
color can have a large impact on image 
quality. See “Lighting” on page 936. 

Shadows
Like lighting, shadows have an important 
effect on image quality. Shadows can be 
generated in any type of camera view using 
any Rendering Technique aside from Glass 
House. See “Rendering Techniques” on page 
951. 

There are two ways to generate shadows in 
Chief Architect: standard and legacy 
shadows. Standard shadows generate more 
quickly than legacy shadows but are of lower 
quality, while legacy shadows are slower but 
generally of higher quality. Legacy Shadows 
can be enabled or disabled in the 

Preferences  dialog and will be enabled 
automatically if your video card does not 
support standard shadows. See “Render 
Panel” on page 123.

Shadows are enabled in  Perspective camera 
views by default.You can, however, select 

3D> Lighting> Toggle Shadows  in a 
camera view to turn shadows on or off. You 
can also set shadows to generate in both 
Orthographic and Perspective previews in 
the Camera Defaults dialog. See “General 
Panel” on page 890.

Shadows are affected by the number of light 
sources in a plan, as well as what Rendering 
Technique is in use. In order for a light 
source to cast shadows, it must be On in the 
current view and have Cast Shadows 
checked in its specification dialog. See 
“Light Data Panel” on page 647.

The quality of shadows is influenced by 
several settings on the RENDER panel of the 

Preferences  dialog: 
• Legacy Shadows produce shadows with 

quality that is generally higher than stan-
dard shadows but take significantly lon-
ger to generate.

• Soft Shadows creates shadows with soft 
edges instead of hard edges. This feature 
only takes effect when Software Edge 
Smoothing is used and can slow render-
ings considerably. 

• A higher degree of Software Edge 
Smoothing, which affects the appearance 
of surface edges, can significantly 
improve the quality of shadows and other 
aspects of 3D views.

In addition to their appearance in camera 
views, sun shadows can also display in floor 
plan view to represent the shadows created 
by the sun at a particular date, time, and 
location. See “Sun Shadows” on page 945.
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When standard shadows are enabled, 
sunlight can shine through windows into 
interior rooms. See “Generic Sunlight” on 
page 938.

Reflections
Reflections are another aspect of lighting that 
can increase a 3D view’s realism. When a 
flat surface is assigned a Mirror material, it 
can display the reflections of other objects in 
the scene. A material can be assigned the 
Mirror class in the Define Material dialog. 
See “Properties Panel” on page 871.

Note that a Mirror surface cannot display the 
reflection of another mirror. When one 
mirror can be seen in another, its material is 
shown rather than a reflection.

Reflections only generate in Perspective 3D 
views using the Standard Rendering 
Technique and can slow down 3D view 
generation and responsiveness considerably 
and are turned off by default in rendered 
Previews. They can be turned on and off for 
both Previews and Final Views in the 
Preferences dialog. See “Render Panel” on 
page 123.

Material Textures
Textures are graphic files that represent 
contoured surfaces of objects such as carpet, 
bricks, tile, and wood in rendered views. 
Textures are assigned to materials which in 
turn are assigned to objects. See “Patterns 
and Textures” on page 848. 

The display of materials in rendered views is 
controlled by settings on the TEXTURE and 
PROPERTIES panels of the Define Material 
dialog. See “Define Material Dialog” on 
page 864.

For realistic rendered views, it is sometimes 
helpful to make adjustments to texture 
properties so that they map to surfaces 
correctly. See “Mapping Patterns and 
Textures” on page 858. 

Brightness, shininess and transparency 
control how light sources affect the display 
of surfaces in rendered views. See 
“Lighting” on page 936.

If no texture is selected for a material or if 
the display of textures is turned off, affected 
surfaces are a solid color instead.

Images
Images are very important for the appearance 
of rendered views and exported VRML files. 
Images are picture files that represent 
individual objects such as trees, flowers, and 
vehicles. Images are represented in floor plan 
view by 2D symbol and are visible in Vector 
views. See “Placing Images” on page 1134.

Backdrops
A backdrop is an image, usually of an 
exterior view, that displays in the background 
of 3D views to help place the model into a 
realistic setting and add a sense of 
perspective. If a backdrop is not specified, 
Chief Architect applies a background color. 
See “3D Backdrops” on page 1155.

For reflections on curved surfaces as
well as reflections within reflections,

consider ray tracing. See “Ray Tracing” on
page 965.
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Previews vs Final Views
With the exception of Vector Views, 3D 
views are generated using the Preview 
settings in the Preferences dialog. Rather 
than produce the best quality possible, the 
installed settings for Previews generate 3D 
views quickly but with reasonable quality, 
and are best when working on the model in 
3D. See “Render Panel” on page 123. 

Final Views produce much higher quality 
images that are more suitable for printing or 
saving as graphics files. Final Views often 
take significantly longer to generate than 
Previews, so the 3D view reverts back to the 
Preview settings as soon as anything is 
changed within the view.

When you have finished making adjustments 
in the 3D view, select 3D> Camera View 
Options> Final View  or Final View 
with Shadows . 

Final View  is not available in Vector 

Views. Final View with Shadows  is not 
available in Vector View, Glass House, or 
Line Drawing views. See “Rendering 
Techniques” on page 951.  

Higher Quality Rendering
The settings on the RENDER panel of the 
Preferences dialog allow you to adjust 
rendering quality and speed so that you can 
strike a balance that best suits your needs. 
For high quality Final Views, consider 
experimenting with these settings: 
• Hardware Edge Smoothing - A higher 

degree of surface edge smoothing can 
significantly improve the quality of 3D 
views.

• Software Edge Smoothing - As with 
Hardware Edge Smoothing, increasing 
surface edge smoothing improves quality.

Halt Generation with Esc Key
Using the Esc key, you can interrupt the 
modeling process at any point and display 
the incomplete model “as is.” This is 
particularly helpful when you just need to 
reorient a model on the screen for a specific 
angle or view.

The Esc option allows you to place the view 
quickly, then press the F5 function key to 
refresh the display with all 3D faces intact. 

Lighting
In most rendered views, lighting is calculated 
on a room-by-room basis; only the light 
sources in the room containing the camera 
are used. This limitation does not apply in 
ray trace views, however.

When the camera is outside a building, the 
program normally uses sunlight for lighting 
calculations and turns off all other light 
sources. You can turn the sunlight off and use 
all the other exterior lights to simulate night 
time views.

To generate a high-quality picture of
your scene, consider ray tracing. See

“Ray Tracing” on page 965.
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The maximum number of light sources that 
can be turned on in a view at the same time is 
determined by your video card. If your video 
card’s maximum number of lights is eight, 
the program only uses the eight light sources 
closest to the camera’s position. You can 
manually turn on and off individual lights in 
order to get the desired lighting effects. See 
“Displaying Lights” on page 938.

Each individual light source has a set of 
Rendering properties, such as intensity and 
color, that can be defined. See “Light Data 
Panel” on page 943. 

Ambient Light
Ambient light is used to simulate the way 
light “bounces” around a scene and 
approximates this by ensuring that all objects 
are at least as bright as the specified ambient 
value, which is set in the 3D View Defaults 
dialog. See “Options Panel” on page 893. 

Ambient light is in addition to other light 
sources in a room or scene. Too much 
ambient light can give a rendered view a flat 
appearance. 
• Interior Ambient controls the ambient 

light in interior rendered views of the 
model.

• Daytime Ambient controls the ambient 
light in exterior rendered views of the 

model when Toggle Sunlight  is on. 
See “Sun Angles and Shadows” on page 
943.

• Nighttime Ambient controls the ambient 
light in exterior rendered views of the 

model when Toggle Sunlight  is off.

In addition to the ambient lighting specified 
in the 3D View Defaults dialog, there are 

four ways to create light sources for rendered 
or ray trace views:
• Default Interior Light
• Light Fixtures
• Added Lights
• Generic Sunlight

Default Interior Light
If you create an interior rendered view of a 
room and no lights have been placed there, 
the program creates a Default Light source 
within that room. The Default interior light 
acts like a central point light source. 

By default, a parallel light source is also 
added to interior views which shines straight 
up to add extra illumination to ceilings. The 
intensity of this light is adjusted with the 
Interior Ambient intensity, and it can be 
turned off entirely in the 3D View Defaults 
dialog. 

The Default Light cannot be adjusted in any 
way. If you want to control the light in an 
interior rendered view, you must add a light 
to the room that you are rendering by placing 
a lighting fixture or by adding a light source 

using 3D> Lighting> Add Lights . 

Light Fixtures
An electric symbol that represents a Light 
Fixture can have one or more light sources 
associated with it. Properties for each light 
source such as light type, color and intensity 
can be modified in the fixture’s specification 
dialog. See “Electrical Service Specification 
Dialog” on page 645.  

If the light source is a Point or Spot Light, 
you can also adjust its Offset, or position 
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relative to the fixture. If you choose to Show 
Position in Camera View, you can see 
where the light source is located.

Light sources look most realistic when they 
are offset from a surface.

Added Lights
In floor plan view, select 3D> 
Lighting> Add Lights to quickly add 

a light source to a plan. Added Lights and 
their labels are placed on the “Light Sources” 
and “Light Sources, Labels” layers by 
default. 

Added lights only act as light sources in plan 
files that have at least one room defined. 
They display 2D symbols in floor plan view 
but do not display as objects in 3D views. 

While Added Lights do not display as objects 
in 3D, you can specify that an Added Light’s 
position be represented by a cross hairs in 
rendered views that use lighting. See “Light 
Data Panel” on page 647.

Added lights can be placed into objects that 
normally do not generate light, such as a TV.

There are three types of added light sources:
• Parallel Light sources
• Point Light sources
• Spot Light sources

See “Light Types” on page 940.

Generic Sunlight
When you create a rendered view and no Sun 
Angle exists, the program creates a Generic 
Sun. The Generic Sun acts like a parallel 
light source but its position is not based on 
any real world locations. 

When standard shadows are enabled, 
sunlight can shine through windows into 
interior rooms.See “Shadows” on page 934.

The Generic Sun’s default intensity, color, 
and angle can be set in the Generic Sun 
Defaults dialog, and can be modified in the 
Adjust Sunlight dialog. In addition, you can 
specify that it follow the camera in 3D views 
so surfaces are always illuminated. The 
Generic Sun’s settings are view specific: 
each 3D view can have its own, unique 
settings. See “Adjust Sunlight Dialog” on 
page 950. 

If you place a Sun Angle  in floor plan 
view, the Generic Sun is no longer used as a 
light source in rendered views. Instead, 
sunlight is generated based on specific date, 
time, latitude, and longitude information. See 
“Sun Angles and Shadows” on page 943.

You can specify that a particular Sun 
Angle  or the Generic Sun be used in any 
active camera view in the Adjust Sunlight 
dialog. See “Adjust Sunlight Dialog” on 
page 950.

Displaying Lights
The display of light fixtures and 
Added Lights in floor plan and 3D 

views is controlled in the Layer Display 

Options dialog. See “Layer Display Options 
Dialog” on page 149.

In addition, they can serve as sources of light 
in rendered and/or ray trace 3D views. They 
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can be turned on and off, as well as set to cast 
shadows.

In Floor Plan View
Light fixtures are placed on the “Electrical” 
layer by default, and Added Lights, on the 
“Light Sources” layer. See “Displaying 
Objects” on page 144. 

In floor plan view, both light fixtures and 
Added Lights can display labels when the 
“Electrical, Labels” and/or “Light Sources, 
Labels” layers are is turned on. See “Object 
Labels” on page 1279. 

An Added Light’s automatic label in floor 
plan view indicates which of these attributes 
the light has: 
• R - Used in Standard rendered views.
• T - Used in ray trace views.
• S - Casts shadows.

These same abbreviations can be displayed at 
the end of a light fixture’s automatic label. 
• Make sure that the “Electrical, Labels” 

layer is turned on. See “Displaying Elec-
trical Objects” on page 643.

• Check Include Type in the Electrical 
Schedule Defaults dialog. See “Label 
Panel” on page 1277.

In 3D Views
Both light fixtures and Added Lights can 
serve as sources of light in rendered and/or 
ray trace views.

To turn a light on or off

There are several ways to turn a light fixture 
or Added Light on or off: 
• Select one or more fixtures or Added 

Lights and click the Turn Light(s) Off in 
3D  or Turn Light(s) On in 3D  
edit button. 

• Uncheck On in the object’s specification 
dialog. See “Light Data Panel” on page 
647. 

• Clear the On/Off checkbox in the Adjust 
Lights dialog.

Added Lights are not associated with a 3D 
fixture, but you can specify that any light 
source’s location be represented in rendered 
3D views using a cross hairs. See “Light 
Data Panel” on page 647.

Light source position indicators will only 
display when the light is in use in the current 
3D view.  That is, it must be: 
• Turned on.
• Specified for use in Camera views.
• One of the light sources in use per your 

video card’s limitations. 
• Either located in a room or in a view with 

Sunlight toggled off. 

Sunlight will shine through windows into 
interior rooms when shadows are enabled. 
See “Shadows” on page 934.

A Point Light that casts shadows in 
both rendered and ray trace views
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Adjust Lights Dialog
Light sources in the current plan - 
including light fixtures and Added 

Lights - can be accessed and edited using the 
Adjust Lights dialog. Select 3D> Lighting> 

Adjust Lights to open this dialog in floor 
plan or any 3D view.

The Adjust Lights dialog is an efficient way 
to control which lights are turned on in 3D 
views. 

All lights in the current plan are listed here 
using the same names as their labels. 
Additional information about each light 
follows in parentheses. 
• Check the box beside a light’s name to 

turn it on or uncheck the box to turn it off. 
• To adjust the properties of a light in the 

list, double-click on its name or select it 
and click the Adjust button. Make 
changes to the light in its specification 
dialog and click OK. For more informa-
tion, see “Adjust Sunlight Dialog” on 
page 950, “Light Specification Dialog” 

on page 942 or “Electrical Service Speci-
fication Dialog” on page 645.

Multiple lights can be selected by holding 
down the Shift key. If multiple lights are 
selected, clicking the Adjust button opens the 
Light Data dialog, which is similar to the 
LIGHT DATA panel of a single object’s 
specification dialog. 

If you are in a 3D view that displays lighting, 
the view will regenerate based on the new 
light settings.

The Generic Sun and Sun Angles are not 
listed in this dialog. See “Generic Sunlight” 
on page 938. 

Light Types
There are three types of light source, each of 
which generates light in a different way and 
allows you to create a variety of lighting 
effects: 
• Parallel Light sources

• Point Light sources
• Spot Light sources 

Parallel, Point, and Spot lights can be 
specified for electrical light fixtures in the 
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Electrical Service Specification dialog. See 
“Light Data Panel” on page 647.

In addition, these three light types can 
be placed in a plan as Added Lights, 

which are light sources that are not 
associated with a fixture. As with light 
fixtures, the lighting properties of Added 
Lights can be specified in their specification 
dialog. See “Light Specification Dialog” on 
page 942.

Parallel Lights
A Parallel Light has a direction but 
no position. The light appears to 

illuminate all objects with equal intensity, as 
if it were at an infinite distance from the 
object. A Parallel Light source is commonly 
used to simulate distant light sources, such as 
the sun and works best when placed on the 
exterior of a structure.

To add a Parallel Light

1. In floor plan view, select 3D> Lighting> 
Add Lights . 

2. Click and drag in floor plan view two or 
more plan feet (600 mm) in any direc-
tion. 

3. When you have dragged a sufficient dis-
tance, the light preview will change to a 
parallel light icon. 

4. When you release the mouse, a parallel 
light pointing in the direction that you 
dragged is created.

Point Lights
Like a bare light bulb, a Point Light 
radiates light equally in all directions 

from its origin. Point lights are a realistic 
representation of non-directional electric 
lighting. 

If no user defined light exists, Chief 
Architect creates a Point Light source to 
represent a light within a room. Any light 
source, except a Sun Angle, can be changed 
into a Point Light. 

To create a Point Light source

1. In floor plan view, select 3D> Lighting> 
Add Lights .

2. Click in floor plan view. Do not drag the 
pointer when you click the screen, or 
you will create a spot or parallel light. 

Spot Lights
A Spot Light focuses the light in a 
specified direction. The location, tilt 
angle, intensity, and more can be 

specified in a Spot Light’s specification 
dialog. 

To create a Spot Light source

1. In floor plan view, select 3D> Lighting> 
Add Lights . 

2. Click and drag in floor plan view no 
more than two plan feet (600 mm) in any 
direction. 

3. As you drag, the light preview will look 
like a Spot Light icon. If you drag too 
far, it will change to a Parallel Light 
icon.

4. When you release the mouse, a Spot 
Light pointing in the direction that you 
dragged is created.
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You can also use a Spot Light’s edit handles 
in floor plan view to move it, as well as 
change its direction and Cut Off Angle. 

Light Specification Dialog
Select one or more Parallel, Point or 
Spot Lights and click the Open 

Object edit button to open the Light 
Specification dialog. 

You can also select 3D> Lighting> Adjust 
Lights  to access a list of the light sources 
present in the current plan and open the 
specification dialog for any of them. See 
“Adjust Lights Dialog” on page 940. 

Location Panel

Light Display - Specify where the selected 
Added Light displays in floor plan and 3D 
views.
• Select All Floors to display the selected 

light on all floors in floor plan view.
• Select Specify Floor Number to display 

the light on one floor only, then choose a 
floor number from the drop-down list. 

• Specify the selected light’s  Height, rela-
tive to 0, which is the default height of 
Floor 1. See “Multiple Floors” on page 
435.

Rotate light 
direction

Change Cut-
Off Angle

Move

Note: The floor or floors that an Added Light
displays on in floor plan view is totally inde-
pendent of where it displays in 3D.
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Light Data Panel
The settings on this panel are also found on 
the same panel of the Electrical Service 
Specification dialog. See “Light Data Panel” 
on page 647.

Depending on the type of light(s) selected, 
the options available here may vary. 

Layer Panel
For information about the settings on this 
panel, see “Layer Panel” on page 154.

Label Panel
Labels for Added Lights display in floor plan 
view when the “Light Sources, Labels” layer 
is turned on and use the Text Style assigned 
to that layer. See “Text Styles” on page 1061.

For information about the settings on this 
panel, see “Label Panel” on page 1280. 

Sun Angles and Shadows
In addition to the functional and aesthetic 
properties of ambient light and light sources 
in rendered views, the direction and angle of 
the sun’s light and shadows are an important 
consideration. Two tools allow you to gener-
ate sunlight and sun shadows with accuracy:

• North Pointers  allow you to specify 
the direction of true north in a plan.

• Sun Angles  let you specify an exact 
location, date, and time for sunlight and 
sun shadow generation.

North Pointer
The North Pointer tool is used to 
define the direction of true north in a 

plan. The direction of north does not affect 
the orientation of the Snap and Reference 
grids, but it does affect the direction of 
sunlight and sun shadows, how conditioned 
area totals are calculated, and how bearing 
information is interpreted by the program. 

If a North Pointer  is not used, north is 
assumed to be straight up on screen in floor 
plan view. 

Select CAD> North Pointer , then click 
and drag to draw the pointer, starting at the 
tail and dragging toward the point. Once it is 
drawn, you can define its exact length and 
angle in its specification dialog. See “Line 
Specification Dialog” on page 1084.

Multiple North Pointers can be drawn in a 
given plan file, and will always point in the 
same direction automatically. If you rotate 
one of them, the others will automatically 
rotate to match. Similarly, if you draw a new 
North Pointer at a different angle, existing 
North Pointers will rotate to that angle 
automatically. 

Every bearing is defined relative to
North, so it is best to establish this

direction before entering survey information
for a site plan. See “Creating a Plot Plan”
on page 190 of the User’s Guide. 
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If you choose to display line angles when a 
North Pointer exists, be sure to select the 
appropriate format in the CAD Defaults 
dialog. See “CAD Defaults and Preferences” 
on page 1072.
• If angles are set to Bearings, they are rel-

ative to the North Pointer. 

• If angles are set to show as Degrees, the 
angle relates to 0° (horizontal to the right) 
even if a North Pointer is present.  

A North Pointer can be selected and edited 
using its edit handles and edit toolbar 
buttons. All attributes of the N aside from its 
size are drawn from the Text Style assigned 
to the  layer it is are placed on. For more 

information, see “Editing Line Based 
Objects” on page 187. 

Sun Angles
Sun Angles let you establish exactly 
where your plan’s building site is 

located, and a precise date and time. This 
information allows the program to determine 
the sun’s location in the sky and generate 
sunlight and sun shadows with accuracy. 

Sun Angles are also Parallel Lights. When an 
exterior 3D view is rendered, the program 
looks for an active Sun Angle. If it finds 
none, the Generic Sun is used. See “Generic 
Sunlight” on page 938.

To create a Sun Angle

1. In floor plan view, go to Floor 1 or Floor 
0. Sun Angles can only be created on 
these floor levels. See “Multiple Floors” 
on page 435. 

2. Select CAD> Lines> Sun Angle  
and click in the drawing area to place a 
Sun Angle arrow at that location. 

3. In the Sun Angle Specification dialog, 
specify the Sun Angle’s Earth Data and 
other information. See “Sun Angle 
Specification Dialog” on page 946.

4. After it is created, a Sun Angle cannot 
be rotated; but it can be moved as well 
as resized using its edit handles. Shad-
ows are not affected.

The same line’s angle is set to show Bearings, 
          which reference the North Pointer.

   Line angle shown in degrees. This 
does not reference the North Pointer. 

Note: Sun Angle calculations do not adjust for
elevation. They are based on formulas pub-
lished by the United States Naval Observa-
tory and have limited accuracy as
documented by the USNO. 
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Multiple Sun Angles can be created, each 
with different specifications; however, only 
one can be used as a light source in a given 
3D view. If more than one Sun Angle is 
present, specify the one to use in the current 
view in the Adjust Sunlight dialog. See 
“Adjust Sunlight Dialog” on page 950.

Sun Angles can display their date and time in 
floor plan view and can also produce sun 
shadow polylines in floor plan view. Both 
Sun Angles and their shadows are on the 
“Sun Angles & Shadows” layer by default. 

Sun Shadows

Sun Angles  allow the program to pro-
duce shadows cast by a building that reflect 
the exact position of the sun in the sky in a 
particular location and at a specific date and 
time. This position and time information is 
specified in the Sun Angle Specification 
dialog; the date format is derived from your 
operating system settings. See “Earth Data 
Panel” on page 946 and “Region and Lan-
guage Settings” on page 75.
In floor plan view, sun shadows are repre-
sented by polylines filled with a hatch pat-
tern. If a Terrain Perimeter is present, the 
shape of a sun shadow polyline is affected by 
changes in terrain height. If no Terrain 
Perimeter exists, sun shadows fall on an 
imaginary plane at a height of zero, the 
default height for Floor 1. Sun shadows 
rebuild whenever the terrain is rebuilt. See 
“Build Terrain” on page 718.

Sun shadows can also be shown in Final 
Views with Shadows  and Ray Trace 
views provided that Casts Shadows is 
checked on the EARTH DATA panel of the 
Sun Angle Specification dialog.
No sun shadow generates if the sun is below 
the horizon or if it is so low on the horizon 
that the shadow would be extremely long.
Multiple Sun Angles can be placed in the 
same plan to allow the simultaneous display 
of shadows cast at different times in floor 
plan view. Only one should be turned on in 
3D views at any given time, however.

To generate the sun shadows associated with 
a particular Sun Angle, select it and click the 

Make Shadow  edit button or click the 

Specify different line colors and/or
styles for shadows cast by multiple Sun

Angles on the Line Style and Fill Style panels
of the Sun Angle Specification dialog.

A Sun Angle and shadows for Coeur d’Alene, ID
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Make Shadow button in the Sun Angle 
Specification dialog. See “Lighting Data 
Panel” on page 948. 
There are several ways to delete a sun 
shadow polyline:
• In floor plan view, select and delete the 

defining polyline. 
• In floor plan view, select and delete the 

Sun Angle arrow. 

• In floor plan view, select the Sun Angle 

arrow and click the Delete Shadow  
edit button. 

• In the Sun Angle Specification dialog, 
click the Delete Shadow button. See 
“Earth Data Panel” on page 946.

• In the Sun Angle Specification dialog, 
click the Make Shadow button to delete 
existing shadows and create new ones. 

Sun Angle Specification Dialog
Select CAD> Lines> Sun Angle, then 
click in floor plan view to open the 

Sun Angle Specification dialog and create a 
new Sun Angle. See “Sun Angles and 
Shadows” on page 943.

To open the Sun Angle Specification dialog 
for an existing Sun Angle, select it and click 

the Open Object  edit button. This dialog 
can also be accessed by clicking the Edit 
button in Adjust Sunlight dialog. See 
“Adjust Sunlight Dialog” on page 950.

Earth Data Panel
The settings on the EARTH DATA panel let 
you establish exactly where your plan’s 
building site is located, and exactly when the 

sun’s light should be calculated. This infor-
mation allows the program to generate sun-
light and sun shadows with accuracy. 
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The Solar Angles display for reference 
and may update as changes are made to 

the settings on this panel. 
• The Solar Altitude is the angle of the sun  

above the horizontal plane, in degrees. 
• The Solar Direction is the angle between 

true North and the sun's direction. This is 
the angle the Sun Angle arrow points in 
floor plan view relative to the direction of 
North. See “North Pointer” on page 943. 

Specify the Location of the selected 
Sun Angle. The initial location can be 

set in the Preferences dialog. See “CAD 
Panel” on page 109.

• Specify the Latitude, which is measured 
either North or South of the equator, 
depending on which radio button you 
select. 

• Specify the Longitude, which is mea-
sured either East or West of the Green-
wich meridian, depending on which radio 
button you select. 

Specify the Date and Time of the 
selected Sun Angle. The initial time 

zone can be set in the Preferences dialog.
• Specify a Date for the selected Sun 

Angle. Select a month from the first 
drop-down list, a day from the second, 
and a year from the third. 

• Specify a Time for the selected Sun 
Angle. Select an hour from the first drop-

1

2

3
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down list; minutes in 15 minute incre-
ments can be selected from the second 
list.

• If you want the Sun Angle to observe 
Daylight Savings Time, check this box.

• Specify the Time Zone that the building 
site is located in. 

Specify the Plan View Display of the 
selected Sun Angle. 

• Specify the Length of Plan Symbol, 
which is the length of the Sun Angle 
arrow in floor plan view.

•  Check Show Date on Sun Angle to have 
the date and time display on the Sun 
Angle arrow in floor plan view. This label 
uses the Text Style assigned to the “Sun 
Angle & Shadows” layer. See “Text 
Styles” on page 1061. 

• Check Auto Rebuild Terrain to rebuild 
the terrain automatically whenever you 
create a sun shadow. If this is unchecked 
and you regenerate sun shadows, the pro-
gram will prompt you to rebuild the ter-
rain. See “Building the Terrain” on page 
730. 

When you use the Build Terrain command 
in floor plan view, all sun shadows in the 
plan are automatically updated.
• Click the Make Shadow button to create 

or regenerate the sun shadow in floor 
plan view. See “Sun Shadows” on page 
945.

• Click the Delete Shadow button to 
remove the sun shadow from floor plan 
view. 

• Check Always Update to have the pro-
gram update the selected Sun Angle’s 
shadow whenever any of the defining 
information is changed. When this is 
checked, the program may be slower 
when changes are made in this dialog. 

• If Always Update is unchecked and you 
make changes in this dialog, click the 
Make Shadow button to generate a new 
shadow.

Note that the Make Shadow option does not 
affect 3D views. To view sun shadows in a 
3D view, select 3D> Lighting> Toggle 
Shadows  or use Final View with Shad-
ows . See “Shadows” on page 934. 

Lighting Data Panel
A Sun Angle can be used as a light source in 
3D views. The settings on the LIGHTING 
DATA panel control attributes of the sunlight 
associated with the selected Sun Angle. 

The settings defined on the LIGHTING DATA 
panel do not affect the sun shadow in floor 
plan view: they only affect 3D views in 
which lighting and shadows can display.

4
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• Check On to specify the selected Sun 
Angle as a Parallel Light source, replac-
ing the Generic Sun. See “Generic Sun-
light” on page 938. 

• Check Casts Shadows to have this light 
source cast shadows. These shadows are 
similar to the shadow shown in floor plan 
view, but may render differently based on 
the presence of other light sources.

• Use the Intensity slider bar or text field 
to define the relative strength of the light 
source. The time of day as set on the 
EARTH DATA panel does not affect how 
the Sun Angle renders as a light source, 
but this does.

• Click the Color button to select a color 
for the sunlight associated with the 
selected Sun Angle. See “Color Chooser/
Select Color Dialog” on page 875. 

Line Style Panel
For information about the LINE STYLE panel, 
see “Line Style Panel” on page 1085.

Fill Style Panel
The settings on the FILL STYLE panel control 
the appearance of the selected Sun Angle’s 
shadow in floor plan view. For information 
about these settings, see “Fill Style Panel” on 
page 1099.

Arrow Panel
For information about the settings on the 
ARROW panel, see “Arrow Panel” on page 
1088.

Multiple Sun Angles can be turned on;
however, only one can be used in a

given 3D view. See “Adjust Lights Dialog” on
page 940.
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Adjust Sunlight Dialog
The Adjust Sunlight dialog allows 
you to control the intensity, direction 

and color of the Generic Sun light source in 
the currently active 3D view or to select a 

Sun Angle  to serve as the source of 
sunlight in the currently active view. See 
“Generic Sunlight” on page 938.

The default Use Generic Sun settings are set 
in the Generic Sun Defaults dialog. See 
“Defaults and 3D Preferences” on page 889.

The settings in this dialog are view specific. 
Any changes made to them affect the sun in 
the currently active 3D view only. Other 3D 
views can have their own unique settings. 

There are three ways to open the Adjust 
Sunlight dialog when a 3D view is active:
• Select 3D> Lighting> Adjust 

Sunlight .

• Click the Adjust Sunlight  button.
• Right-click in an empty space in the 

background area, then select Adjust 
Sunlight  from the contextual menu.

Select Use Generic Sun to represent 
the sun in the currently active 3D view 

using the settings that follow.  
• Use the Intensity slider bar or text field 

to control how bright the Generic Sun 
light appears. 

• Click the Color bar to define the color of 
the light being modeled. Colored sunlight 
may be used to achieve special lighting 
effects, but may alter the appearance of 
your material colors and textures. 

• Check Sunlight Follows Camera to 
adjust the position of the Generic Sun so 
that it is always behind the camera, illu-
minating surfaces in the view. When this 
is checked, the Tilt and Direction Angle 
settings that follow are disabled.

• Specify the Tilt Angle, which is the angle 
of the sunlight with respect to the hori-
zon. A value of 90° means that the light 
points straight up, while a value of -90° 

1
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means that the light points straight down. 
0° is parallel to the horizon.

• Specify the Direction Angle, which is 
the direction that the sunlight points 
toward. 0° is measured horizontally on 
screen, pointing to the right. Positive val-
ues rotate in a counter-clockwise direc-
tion from there, while negative values 
rotate clockwise. 

• Click the Reset to Defaults button to 
apply the Generic Sun settings in the 
default Adjust Sunlight dialog to the 
Generic Sun in the current view. 

Select Use Sun Angle to represent the 
sun using a light source defined by a 

Sun Angle . Not available unless one or 
more Sun Angles are present in the plan and 
is not an option in the Generic Sun Defaults 
dialog. See “Sun Angles and Shadows” on 
page 943.  
• Select a Sun Angle from the drop-down 

list to serve as the source of sunlight in 
the currently active 3D view.

• Click the Edit button to open the Sun 
Angle Specification dialog for the 
selected Sun Angle. 

By default, the Generic Sun light color is 
pure white, which has the least effect on the 
apperance of material colors and textures. 
See “Materials” on page 847.

Rendering Techniques
Any camera view, cross section/
elevation view, or overview can be 

generated using a variety of Rendering 
Techniques to produce views for a range of 
different purposes: from detail drawings to 
artistic presentation views. When a 3D view 
is active, select 3D> Rendering Techniques 
to access these tools. 

There are two ways to create a view using a 
particular Rendering Technique:
• Create a 3D view, then select the desired 

rendering technique from the menu. 
• Select the desired rendering technique in 

the Camera Defaults dialog, then create 
a 3D view. See “Camera Defaults Dia-
log” on page 889. 

Once a view is created, the effects of the 
selected rendering technique can be adjusted 
in the Rendering Technique Options 

dialog. See “Rendering Technique Options” 
on page 954. 

If a camera view is saved, its Rendering 
Technique settings are saved, as well. See 
“Saving and Printing 3D Views” on page 
922. 

You can specify which Rendering 
Techniques use a backdrop image. See 
“Backdrop Panel” on page 895. 

Standard Rendering
Standard rendering is a photo-
realistic technique that represents 

2

The Painting, Watercolor and Line
Drawing techniques require more time

to generate than other Rendering Tech-
niques. To save time, adjust the camera’s
perspective before using one of these tech-
niques. See “Editing 3D Views” on page 916.



952

Chief Architect X8 Reference Manual

materials using textures, models lighting, and 
can also display shadows. Surface edge lines 
are not drawn and no special colors or effects 
are applied. Lighting is limited to the room 
containing the camera and the capabilities of 
your video card. 

In floor plan view, the camera 
symbol for a view using the 
Standard technique displays an S 
in its center. See “Displaying 3D 

Views” on page 907.

Vector View
In Vector Views, surface edge lines 
are drawn and pattern lines and colors 

are used to represent materials. Textures, 
lighting, and shadows are not used, and 
special colors and effects are not applied. 

In floor plan view, the camera 
symbol for a view using the 
Vector View technique displays a 
V in its center. 

Glass House
Glass House rendering uses different 
shades of a single color to display the 

model with surface edge lines and semi-
transparent surfaces. Lighting and shadows 
are not modeled, and materials are not 
represented, so neither pattern lines nor 
textures are used. 

In floor plan view, the camera 
symbol for a view using the Glass 
House technique displays a G in 
its center. 

Duotone
Duotone rendering represents 
materials using textures and models 

lighting and shadows. Surface edge and 
pattern lines are not drawn and two colors, 
one Light and one Dark, are applied over the 
surfaces, allowing you to create special 
effects such as sepiatone or grayscale. 
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In floor plan view, the camera 
symbol for a view using the 
Duotone technique displays a D 
in its center. 

Technical Illustration
Technical Illustration rendering 
draws surface edge and pattern lines, 

and uses shades of two colors, Warm and 
Cool. The warm shade is applied to surfaces 
that face the light source in the view, and the 
cool shade,to surfaces that face away from it.

Only one light source is used: the light with 
the highest Intensity found in the room 
containing the camera. In exterior views, this 
light is always the Generic Sun. If no lights 
are on, a fallback light is used. Lighting is 
modeled as non-photorealistic, stylized 
highlights and shadows are supported. See 
“Lighting” on page 936. 

In floor plan view, the camera 
symbol for a view using the 
Technical Illustration technique 
displays a T in its center. 

Painting
Painting rendering draws views by 
placing small regions of color and 

then stroking them along the surfaces in 
multiple layers. This technique uses textures 
to represent materials and models lighting 

and shadows, and can produce a variety of 
distinct non-photo-realistic painting styles. 

In floor plan view, the camera 
symbol for a view using the 
Painting technique displays a P 
in its center. 

Watercolor
Watercolor rendering approximates 
the effects of watercolor painting such 

as pigment pooling and flow. It uses textures 
to represent materials and models lighting 
and shadows. When Line Drawing on Top 
is enabled, pattern lines are also used.

In floor plan view, the camera 
symbol for a view using the 
Watercolor technique displays a 
W in its center. 

Line Drawing
In a Line Drawing rendering, surface 
edges are represented by lines with a 
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hand-drawn style. Surfaces are completely 
opaque and patterns are used, but textures, 
lighting,and shadows are not.  

In floor plan view, the camera 
symbol for a view using the Line 
Drawing technique displays an L 
in its center. 

Rendering Technique Options
The settings in the Rendering 
Technique Options dialog allow you 

to control the specific effects of each 
rendering technique on an active 3D view. To 
access this dialog, create a camera view, 
cross section/elevation view, or overview and 
select 3D> Rendering Techniques> 
Technique Options.

The Rendering Technique Options dialog 
can also be accessed by double-clicking the 

Rendering Techniques  parent button. 

The settings in the Rendering Technique 
Defaults dialog are the same as those in the 
this dialog, but control the initial settings of 
each technique when it is first applied. 

In the Rendering Technique Options 
dialog, select a technique from the list on the 
left to make its options active on the right. 
When this dialog is first opened, the 
technique currently used by the view is 
selected.  

As changes are made in the Rendering 
Technique Options dialog, the 3D view 
automatically updates to reflect those 
changes for all techniques except Painting, 
Watercolor and Line Drawing. To update 
views using these techniques, which take 
more time to draw than the others, click the 
Update button in the dialog. 

When a 3D view is saved, its Rendering 
Technique Options settings are saved, as 
well. See “Saving 3D Views” on page 922.

Standard Panel
The active 3D view immediately 
updates to reflect any changes made to 

the Rendering Technique Options for 
Standard renderings. 

The ambient lighting for rendered views can 
be set in the 3D View Defaults dialog. See 
“3D View Defaults Dialog” on page 892. 

There are a variety of other tools that affect 
the appearance of Standard rendered views, 

Note: In some plans, the Painting, Watercolor
and Line Drawing techniques may take a
considerable amount of time. You can press
the Esc key to cancel the rendering.
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as well. See “Displaying 3D Views” on page 
907. 

• Check Opaque Window Glass to make 
the glass in windows and doors opaque. 
When unchecked, door and window glass 
is transparent.

• Click Reset to Defaults to apply the 
Standard settings defined in the 
Rendering Technique Defaults dialog. 

• In the Rendering Technique Defaults 
dialog, the Restore Initial Settings but-
ton is available instead. Click this to reset 
the options on this panel to the originally 
installed settings.

Vector View Panel
The active 3D view immediately 
updates to reflect any changes made to 

the Rendering Technique Options for Vector 
Views. are no Rendering Technique Options 
for Vector View rendering. 

Additional settings that affect the appearance 
of Vector Views can be found in the 3D View 

Defaults dialog. See “3D View Defaults 
Dialog” on page 892.

There are a variety of other tools that affect 
the appearance of Vector Views. See 
“Displaying 3D Views” on page 907. 
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• Specify the Shadow Intensity, which is 
how dark or light shadows appear. A 
value of 100% creates shadows that hide 
any objects located within them; a value 
of 0% effectively produces no shadows.

• Check Opaque Window Glass to make 
the glass in windows and doors opaque. 
When unchecked, door and window glass 
is transparent.

• Click Reset to Defaults to apply the Vec-
tor View settings defined in the Render-
ing Technique Defaults dialog. 

• In the Rendering Technique Defaults 
dialog, the Restore Initial Settings but-
ton is available instead. Click this to reset 
the options on this panel to the originally 
installed settings.

Glass House Panel
The active 3D view immediately 
updates to reflect any changes made to 

the Rendering Technique Options settings for 
Glass House renderings. 

• Click the Color bar to select a color for 
the semi-transparent surfaces and lines in 
a Glass House view. See “Color Chooser/
Select Color Dialog” on page 875. 

• Specify the Transparency of the surfaces 
in Glass House view. For example, to cre-
ate a wireframe line drawing of your 
structure, turn transparency to full and 
minimize line thickness.

• Specify the Line Thickness of surface 
lines in Glass House view. 

• Click Reset to Defaults to apply the 
Glass House settings defined in the 
Rendering Technique Defaults dialog. 
If clicked in the defaults dialog, the origi-
nally installed settings are restored. 

• In the Rendering Technique Defaults 
dialog, the Restore Initial Settings but-
ton is available instead. Click this to reset 
the options on this panel to the originally 
installed settings.

Duotone Panel
The active 3D view immediately 
updates to reflect any changes made to 

the Rendering Technique Options settings for 
Duotone renderings. 
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• Click the Color bars to select a Light 
Color and Dark Color for surfaces and 
lines in a Duotone view. See “Color 
Chooser/Select Color Dialog” on page 
875. 

• Specify the Desaturation, which is the 
degree to which color is removed from 
the original image. A value of 0% retains 
the original colors in the view while a 
100% results in a grayscale image.

• Specify the Tone, which is the extent to 
which the Light and Dark Colors cover 
the original colors in the view. A value of 
100% completely obscures the view’s 

original colors as well as the effects of 
Desaturation. 

• Check Opaque Window Glass to make 
the glass in windows and doors opaque. 
When unchecked, door and window glass 
is transparent. 

• Click Reset to Defaults to apply the 
Duotone default settings set in the 
Rendering Technique Defaults dialog.

• In the Rendering Technique Defaults 
dialog, the Restore Initial Settings but-
ton is available instead. Click this to reset 
the options on this panel to the originally 
installed settings.

Technical Illustration Panel
The active 3D view immediately 
updates to reflect any changes made to 

the Rendering Technique Options settings for 
Technical Illustration renderings. 
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• Click the Color bar to select a Warm 
Color for surfaces that face the light 
source and a Cool Color for surfaces that 
face away from the light. See “Color 
Chooser/Select Color Dialog” on page 
875. 

• Specify the Warm Blend, which is the 
degree to which the selected Warm Color 
is blended with original colors on well-lit 
surfaces in the view. 

• Specify the Cool Blend, which is the 
degree to which the selected Cool Color 
is blended with original colors on shaded 
surfaces in the view. 

• Specify the Line Thickness of all surface 
edge and pattern lines in the view.

• Specify the Shadow Intensity, which is 
how dark shadows. A value of 0% pro-
duces no shadows. See “Shadows” on 
page 934.

• Check Opaque Window Glass to make 
the glass in windows and doors opaque. 
When unchecked, door and window glass 
is transparent.

• Click Reset to Defaults to apply the 
Technical Illustration settings defined in 
the Rendering Technique Defaults dia-
log. 

• In the Rendering Technique Defaults 
dialog, the Restore Initial Settings but-
ton is available instead. Click this to reset 
the options on this panel to the originally 
installed settings.

Painting Panel
In order for the active 3D view to 
reflect changes made to the Rendering 

Technique Options settings for Painting 

renderings, you must click either the OK 
button or the Update View button in the 
dialog. This may take several moments. 
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• Select a predefined painting Style from 
the drop-down list. The settings that fol-
low reflect the selected style. If you cus-
tomize any of the settings, the selected 
style will be “Custom”. 

• Specify the Minimum Brush Size, 
which is the size of the brush used to 
paint the final layer. 

• Specify the Number of Coats, which is 
the number of times the view is painted 
using progressively smaller brushes. 

• Specify the Minimum Stroke Length of 
the brushes used to draw the view. A low 
value produces finer detail while a higher 
value creates a choppier appearance.

• Specify the Maximum Stroke Length of 
the brushes used to draw the view. 

• Specify the Approximation Threshold, 
which is how closely the painted render-
ing conforms to the original view. 

• Specify the Blur Factor, which is the 
degree to which the original image is 
blurred. A low value retains more detail 
in the original view and thus a more accu-
rate representation of the original view

• Specify the Stroke Curvature, which is 
the degree to which brush strokes are 
curved. A low value produces straight 
curves while a high value creates small, 
tight strokes. 

• Specify the Stroke Opacity, or how 
transparent the paint brushed over the 
original view is. A value of 0% results in 
completely transparent paint.  

• Specify the Color Jitter, which is the 
amount of random colors added to brush 
strokes.

• Check Opaque Window Glass to make 
the glass in windows and doors opaque. 
When unchecked, door and window glass 
is transparent. 
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• Click Reset to Defaults to apply the 
Painting settings defined in the 
Rendering Technique Defaults dialog.

• In the Rendering Technique Defaults 
dialog, the Restore Initial Settings but-

ton is available instead. Click this to reset 
the options on this panel to the originally 
installed settings.

• Click Update View to apply these set-
tings to the active 3D view. 

Watercolor Panel
In order for the active 3D view to 
reflect changes made to the Rendering 

Technique Options settings for Watercolor 

renderings, you must click either the OK 
button or the Update View button in the 
dialog. This may take several moments. 

• Specify the Smooth Amount, which is 
the degree to which details are removed 
from the original view.

• Specify the Paint Contrast, which deter-
mines the extent to which variations in 
pigment color are used. 

• Specify the Turbulence Strength, which 
produces “pooling”, or variations in the 
strength of pigment colors.

• Specify the Turbulence Scale, which 
controls the size of the areas of pooling.

• Specify the Pigment Settling Strength, 
which is creates the appearance of pig-
ment settling into low areas in paper.

• Specify the Edge Strength, which is how 
well-defined surface edge lines are.

• Check Line Drawing on Top to generate 
pattern lines and surface edge lines with a 
hand-drawn appearance, as in the Line 
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Drawing Technique. When checked, the 
four settings that follow are enabled. 

• Click the Color bar to specify the color 
of the lines drawn on top of the render-
ing.

• Specify the Thickness of the lines drawn 
on top of the rendering.

• Specify the Extend Amount, which is 
the distance that lines may extend past 
intersecting surface edges.

• Specify the Squiggle Amplitude, which 
controls the average amount of curvature 
in the lines’ squiggles. A value of 0 pro-
duces straight lines. 

• Check Opaque Window Glass to make 
the glass in windows and doors opaque. 
When unchecked, door and window glass 
is transparent.

• Click Reset to Defaults to apply the 
Watercolor settings defined in the Ren-
dering Technique Defaults dialog. 

• In the Rendering Technique Defaults 
dialog, the Restore Initial Settings but-
ton is available instead. Click this to reset 
the options on this panel to the originally 
installed settings.

• Click Update View to apply these set-
tings to the active 3D view. 

Line Drawing Panel
In order for the active 3D view to 
reflect changes made to the Rendering 

Technique Options settings for Line Drawing 

renderings, you must click either the OK 
button or the Update View button in the 
dialog. This may take several moments. 

• Click the Color bar to select the color of 
the lines used to draw the view. See 
“Color Chooser/Select Color Dialog” on 
page 875. 

• Specify the Thickness of the lines, in 
pixels. 

• Specify the Extend Amount, which is 
the distance that lines may extend past 
intersecting surface edges.

• Specify the Squiggle Amplitude, which 
controls the average amount of curvature 
in the lines’ squiggles. A value of 0 pro-
duces straight lines. 
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• Specify the Squiggle Frequency, which 
controls how often the lines have curves. 
A value of 0 produces straight lines.

• Check Opaque Window Glass to make 
the glass in windows and doors opaque. 
When unchecked, door and window glass 
is transparent. 

• Click Reset to Defaults to apply the Line 
Drawing settings defined in the 
Rendering Technique Defaults dialog. 

• In the Rendering Technique Defaults 
dialog, the Restore Initial Settings but-
ton is available instead. Click this to reset 
the options on this panel to the originally 
installed settings. 

• Click Update View to apply these set-
tings to the active 3D view. 

• Click OK to close the dialog and redraw 
the active 3D view based on these set-
tings. Depending on your plan, this may 
take several moments.

Speeding up 3D View Generation
When you have a large, complex model with 
a lot of detail, many objects, extensive 
terrain, or patterns composed of many lines, 
it may take some time to generate a 3D view 
of everything in the model. During this 
process, progress information may display in 
the Status Bar and in a message window. 

There are several ways to speed up the 
generation time of views.

Halt Generation with Esc Key
In a large, complex model, repositioning the 
camera can be time-consuming. You can 
speed up this process using the Esc key. 
When you press the Esc key, the modeling 
process is interrupted and the view is 
displayed “as is”. Then, press the  F5 key to 
refresh the display. 

Turn Off Layers
The display of objects in 3D views 
can be turned on or off in the Layer 

Display Options dialog. Turning off 
unneeded layers in 3D views can speed up 
3D view generation time. See “Layer 
Display Options Dialog” on page 149. 

Each camera view and overview uses the 
default layer set for Camera Views. Changes 
made to this layer set in one view affect all 
other views using that set. See “Layer Set 
Management” on page 147.

Rendering Preferences
In the Preferences dialog, there are a 
number of settings that you can use to 

balance rendering quality and generation 
time. See “Render Panel” on page 123.

View Panel Factors
Vector Views are drawn using an 
adaptive method that saves time by 

dividing the screen into horizontal and 
vertical panels. 

You can turn on "Show Screen Redraw
Time" in the Preferences dialog to see

how your changes affect 3D view generation
time. See “Appearance Panel” on page 92.
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The OPTIONS panel of the 3D View Defaults 
dialog has two tuning factors that allow you 
to adjust the way the adaptive method works. 
See “Options Panel” on page 893.

To generate a high-quality picture of
your scene, consider ray tracing. 
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Chapter 31:

Ray Tracing

You can  use Ray Tracing to create highly 
realistic images of your Chief Architect 
plans. As the name implies, ray tracing 
calculates the rays of light in a view as they 
travel through the 3D model and reflect off 
surfaces. As a result, ray tracing is slower 
than OpenGL rendering, but can be used to 
achieve much more complex effects such as 
reflections and highly realistic lighting.

Chapter Contents
•      Ray Trace Views
•      Ray Trace Configurations
•      Ray Trace Options
•      Ray Trace Assistant
•      Adjusting Ray Trace Properties and Effects
•      Ray Tracing Tips
•      POV-Ray

Ray Trace Views
Ray tracing is a method of generating 
high-quality 3D views in which the 

paths of individual rays of light are 
calculated, making it possible to model 
effects like reflectivity. Ray tracing a scene 
can be time consuming, but when lighting 
and materials are set up properly, the results 
can be impressively realistic.

Ray trace views are generated in their own 
view window and are static images of the 
model - not dynamic. That is, if you make 
changes to the 3D model, any previously 
created ray trace views will not be affected. 

To create a ray trace

1. Create a 3D camera view or overview.
•  The Standard Rendering Technique 

must be used. See “Standard 
Rendering” on page 951.

•  Perspective views are preferable to 
Orthographic views for ray tracing 
because they are more realistic to the 
human eye. See “Perspective and 
Orthographic Views” on page 888. 
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2. Position the camera as needed. Do not 
use the Zoom or Pan tools. See “Editing 
3D Views” on page 916. 

3. Adjust the shape of the view window as 
needed. 

4. Select 3D> Ray Trace Current 
View . 

5. In the Ray Trace Current View dialog: 
•  Select a Ray Trace Configuration from 

the drop-down list and click the Ray 
Trace button. See “Ray Trace Current 
View/Ray Trace Defaults Dialog” on 
page 967. 

6. A ray trace can be cancelled at any time:  
•  In the Preparing to Ray Trace prog-

ress dialog, click the Cancel button. 
•  Once the ray trace view window is 

open, you can cancel the process by 
selecting File> Close . 

7. To stop a ray trace in progress without 
cancelling it, select File> Stop Ray 
Trace . 

8. When the ray trace is completed, save 
the resulting image for future use: 

•  Select File> Print Image  to print 
the image. See “Print Image Dialog” 
on page 1229. 

•  Select File> Export Picture  to 
save the image in any of several file 
formats including .jpg, .bmp, and 
.png. See “Exporting Pictures” on page 
1141. 

•  Select File> Send to Layout  to 
send the ray trace view to a layout 
page. See “Sending Views to Layout” 
on page 1240. 

Progressive Ray Tracing
Chief Architect’s ray tracer begins by 
generating a low-quality preview of the 
model based on the current Ray Trace 
Configuration’s settings. Once the initial ray 
trace is complete, the ray tracer performs 
additional passes to incrementally refine the 
view’s lighting quality and effects. 

If Save Image to File is checked in the Ray 
Trace Options dialog, the program will save 
the ray trace as an image file and will update 
the file after every pass of the ray tracer. See 
“General Panel” on page 969. 

You can specify the how long these 
additional passes are performed in the Ray 
Trace Options dialog, and can stop a ray 
trace in progress whenever it meets your 
needs by selecting File> Stop Ray 
Trace . See “General Panel” on page 969.

The Ray Trace Window
When the ray trace view window is active, 
the image will regularly update as the ray 
trace progresses and its status will display in 
the Status Bar. When it is finished, the 
number of passes and  cumulative time, 
including pre-processing time, will display 
there. See “The Status Bar” on page 42. 

Unlike rendered views, you can minimize a 
ray trace window or switch to a different 
view while the view is being generated and 
perform other tasks. Simply restore your ray 
trace window when you are ready to view the 
image. See “Working in Multiple Views” on 
page 883. 

You can specify whether your computer’s 
processor allocates more resources for the 
ray trace or for working in the program in the 
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Preferences dialog. See “Ray Trace Panel” 
on page 125. 

If you have specified an image size larger 
than your monitor and saved the results as an 
image file, you may only see one corner of 

the total view. You can, however, use the 

scroll bars and/or Zoom In  or Zoom 
Out . See “Zoom Tools” on page 881.

Ray Trace Configurations
Ray trace views are generated based 
on settings that control lighting 

properties as well as the size of the final 
image. Two configurations are included in 
the installed template plans: Default Interior 
Ray Trace and Default Exterior Ray Trace.

You can save multiple ray trace 
configurations for different purposes and 
then select the one best suited to the view 
you want to ray trace.  See “Multiple Saved 
Defaults” on page 77. 

To access the ray trace configurations saved 
in the current plan, select Edit> Default 
Settings . Click the + beside “Camera”, 
then select “Ray Trace” and click the Edit 
button to open the Ray Trace Defaults 
dialog. See “Default Settings” on page 74. 

You can also access the available ray trace 
configurations by selecting 3D> Ray Trace 
Current View  while a 3D camera view 
or overview is active. The Ray Trace 
Current View dialog will open.

Ray Trace Current View/
Ray Trace Defaults Dialog

• Select the name of the Current Configu-
ration from the drop down list. A Sum-
mary of the selected configuration’s 
setting displays in the bottom portion of 
the dialog box.

• Click the Launch Assistant button to 
launch the Ray Trace Assistant. See 
“Ray Trace Assistant” on page 974. 

• Click the Copy button to create a copy of 
the Current Configuration.

• Click the Edit button to open the Ray 
Trace Options dialog, where you can 
make changes to the selected Current 
Configuration. See “Ray Trace Options” 
on page 968. 
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• Click the Delete button to permanently 
remove the Current Configuration from 
the plan. Not available if there is only one 
configuration in the list.

• If the Ray Trace Current View dialog 
was accessed via Ray Trace Current 
View , click the Save and Close but-
ton to close the dialog without ray tracing 
the current view. Any new configurations 
or changes that you may have made to 
existing configurations are retained.  

• If the Ray Trace Current View dialog 
was accessed via Ray Trace Current 
View , click the Ray Trace button to 
begin ray tracing the active 3D view 
using the Current Configuration and 

retain any new configurations or changes 
made to existing configurations.

• If the Ray Trace Defaults dialog was 

accessed via Default Settings , click 
OK to close the dialog and save any 
newly created or renamed configurations.

• Click the Cancel button to close the dia-
log without saving any changes. Any 
renamed or newly created configurations 
will not be retained unless you click Next 
in the warning message box that displays. 

Ray Trace Options
The Ray Trace Options dialog can be 
opened in either of two ways: 
• In any view, select Edit> Default Set-

tings  and expand the “Camera” cate-
gory. See      Default Settings. 

• In a Standard rendered view, select 3D> 
Ray Trace Current View . 

In either case, you will first need to select the 
current ray trace configuration in the Ray 
Trace Configurations/Ray Trace Current 
View dialog. See “Ray Trace Current View/
Ray Trace Defaults Dialog” on page 967. 

When the Ray Trace Options dialog opens, 
the Current Configuration specified in the 
Ray Trace Current View dialog is active. 
See “Ray Trace Configurations” on page 
967.

The Ray Trace Options dialog has four 
panels: 
• General Panel
• Lighting Panel
• Advanced Panel
• Image Properties Panel

You can add your preferred ray trace
configurations to your template plan.
See “Template Files” on page 84.



Ray Trace Options

 969

General Panel

Specify the Name of the current Ray 
Trace Configuration. Names must be 

unique.

Check Save Image to File, then click 
the Browse button to save the ray trace 

image directly to a .jpg, .bmp, .png, or .tif 
file after every pass of the progressive ray 
tracer. If a file has been specified, its 
pathname will display to the right of the 
Choose button. 

If the specified file already exists, the 
program will ask if you to wish to overwrite 
the existing file or choose a new name and/or 
location when you start a ray trace. 

Specify the Image Size of the ray trace.

• Check Use Active Window Size to save 
the ray trace image at the same size as the 

ray trace view window. The Width and 
Height of the currently active view win-
dow are stated below: if these values are 
changed, this box becomes unchecked 
automatically. 

• Specify whether the ray trace image’s 
Width/Height Dimensions are measured 
using Pixels or drawing Units (inches or 
mm). 

• Specify the Width and Height of the ray 
trace image in either Pixels or Units. 

• Specify the Resolution of the ray trace 
image, in either Pixels/Inch or Pixels/
mm. 

• Check Retain Aspect Ratio to maintain 
the width to height ratio of the original 
image and prevent the ray trace from 
being stretched or distorted. 

1

2

3
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Specify a Time to Ray Trace, which 
determines how long a ray trace runs 

and thus its final quality. See “Progressive 
Ray Tracing” on page 966. 
• Select No Limit to run the ray tracer until 

you select File> Stop Ray Trace .

• Select a Time to ray trace from the drop-
down list. The ray tracer will complete as 
many passes as possible during this time.

• Specify a Number of Passes. The ray 
tracer will run as long as needed to com-
plete this number of passes. 

You can stop any ray trace at any time by 

selecting File> Stop Ray Trace .

Lighting Panel
The settings on the LIGHTING panel control 
the appearance of light in a ray trace scene 

that isn’t associated with a particular light 
source. See “Lighting” on page 936. 

The Ambient Light Settings control 
the appearance of the light present 

throughout a scene that does not come from a 
particular source. Ambient light exists 

everywhere, including shadowed areas. See 
“Ambient Light” on page 937.
• Uncheck User Camera View Settings to 

enable the Color bar and specify the 

4

1
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color of the ambient light. See “Color 
Chooser/Select Color Dialog” on page 
875. 

• When Use Camera View Settings is 
checked, the ambient light is grey in 
color and its brightness is based on the 
ambient light settings in the 3D View 
Defaults dialog. Low ambient values 
result in darker grey; higher values result 
in lighter grey. See “Options Panel” on 
page 893.

• Click the Uniform Intensity radio button 
to enable the Intensity setting below, 
then specify the strength of the ambient 
light throughout the scene either by typ-
ing a decimal value in the text field or by 
clicking the up and down arrows. Values 
between 0 and 10 can be used. 

• Click the Use Ambient Occlusion radio 
button to enable the Min and Max Inten-
sity settings below. Ambient Occlusion 
allows variation in the strength of the 
Ambient Light and is more realistic than 
Uniform Intensity, but takes longer to ray 
trace.

• Specify the Minimum Intensity, which 
is the strength of the ambient light on sur-
faces with minimum exposure to it. 

• Specify the Maximum Intensity, which 
is the strength of the ambient light on sur-
faces fully exposed to it. 

Specify the Intensity of the Direct 
Sunlight throughout the scene either by 

typing a decimal value in the text field or by 

clicking the up and down arrows. Values 
between 0 and 10 can be used. 

Specify the appearance of atmospheric 
lighting in exterior views. 

• Check Enable Environment Light to 
enable the settings below. When checked, 
exterior scenes are lit using an encom-
passing sphere of light, which simulates 
how light bounces around within the 
atmosphere. When unchecked, only the 
Generic Sun is used. See “Generic Sun-
light” on page 938. 

• Specify the Intensity value, which is the 
strength of the Environmental Light.  

• Click the Use Sky radio button to use the 
Generated Sky as a basis for the Environ-
mental Light’s color. See “3D Back-
drops” on page 909.

• Click the Use Color radio button, then 
click the Color bar to specify the color of 
the outdoor Environmental Light.

• Click the Use Image radio button, then 
browse to select an image to use as a 
basis for the Environmental Light’s color. 
The image is wrapped around the scene’s 
encompassing sphere and influences the 
color of the Environmental Light, but 
does not actually appear in the ray trace 
view.

• Click the Select Image button to select a 
different image. 

• Click the Remove Image button to 
remove the currently selected image and 
use a color instead.

Advanced Panel
The settings on the ADVANCED panel allow 
you to specify lighting quality and focal blur.

2

3
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Global Illumination - 
 

• Check Use Photon Mapping to accu-
rately calculate bounced lighting in a 
scene. When unchecked, ray traces have 
low quality lighting effects but generate 
more quickly. Use Photon Mapping 
should be checked for all interior scenes 
and unchecked for most exterior scenes.

• Check Compute Caustics, to use caustic 
photons, which are photons used in areas 
of focused light. Caustic photons are 
helpful when modeling certain effects 
such as light shining through glass.

Check Enable Focal Blur to enable the 
F-Number setting below and set the 

amount of focal blur that occurs outside the 
camera’s focal range. 
• Specify the F-Number value, which 

defines the camera focal blur and is the 
like the f-stop in photography. Decrease 
this value for more focal blur or increase 
it for less blur. 

Image Properties Panel
The settings on the IMAGE PROPERTIES panel 
allow you to customize the properties of 
colors in Ray Trace views. Once a Ray Trace 

has been started, these settings can be 
modified. See “Adjusting Ray Trace 
Properties and Effects” on page 978. 

In order for Photon Mapping to func-
tion, at least two different objects must

be present in the model. If there are too few
surfaces in the model, a ray trace with Photon
Mapping cannot run.

1

2
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Chief Architect’s ray tracer works with 
a color range greater than what your 

monitor or printer can display. When Use 
Tone Mapping is checked, these colors are 
intelligently mapped to a displayable range. 
Uncheck this box to simplify how the colors 
are converted and disable the settings below.
• Uncheck Auto Contrast to enable the 

Contrast setting below. When checked, 
the program chooses a Contrast value 
based on the image’s properties. 

• Specify the Contrast, which is the rela-
tive difference between light and dark 
colors in the view, using the slider bar or 
by typing in the text field 

• Specify the Intensity. or brightness of the 
image. This value not necessarily uni-
form throughout the view and is similar 
to a camera’s exposure setting.

• Specify the Softness, which determines 
whether color intensity is based on pixel 
or overall image intensity. 

• Specify the Color Correction, which is 
the extent to which strong color casts are 
removed from the image. 

General Properties - 

• Specify the Brightness of the image, 
which controls how dark or light the 
image is overall. 

• Specify the Contrast, or relative differ-
ence between light and dark colors. This 
setting is similar to the setting of the 
same name, above, but is not as fine a 
control because it takes place after tone 
mapping has been done. 

• Specify the Saturation, which is the 
intensity of colors in the view. 

1

It’s not unusual for ray traced images to
initially be too dark or too bright. Try
adjusting the Tone Mapping Intensity.

2
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Don’t be afraid to over-saturate your image 
slightly in very bright scenes – this is a 
common occurrence in actual photographs.

If you are ray tracing an interior scene where 
the primary source of light is the sun through 

a window or door, you may need to adjust 
your image brightness. 

Click the Reset to Defaults button to 
restore the settings in this dialog to their 

initial, installed values. 

Ray Trace Assistant
The Ray Trace Assistant is an easy way to 
set up new ray trace configurations. It can be 
accessed by clicking the Create New button 
in the Ray Trace Current View/Ray Trace 
Defaults dialog. See “Ray Trace Current 

View/Ray Trace Defaults Dialog” on page 
967. 

The choices in the Ray Trace Assistant 
correspond to settings in the Ray Trace 
Options dialog. See “Ray Trace Options” on 
page 968.

Welcome

Specify the level of quality for the ray trace 
you would like to create.  The options here 
correspond to the number of Samples 

selected in the Ray Trace Options dialog. 
See “General Panel” on page 969.

3
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• Select Indoor or Outdoor for a ray trace 
with lighting effects suitable for the type 
of view. 

• Select High Quality for a high quality 
image that takes a long time to produce. 

• Select Standard to create an image that 
balances quality and time. 

• Select Quick for a relatively low quality 
image, useful to preview effects such as 
lighting in the scene. 

Image Size

Specify the size of the final ray trace image. 
The options here correspond to the Image 
Size settings in the Ray Trace Options 
dialog See “General Panel” on page 969. 
• Check Use Active Window Size to set 

the ray trace to the current size of the 
active 3D view window. When this is 
checked, the other settings on this panel 
are disabled.

• Check Retain Aspect Ratio to maintain 
the width to height ratio of the original 

image and prevent the ray trace from 
being stretched or distorted. 

• Specify the Dimensions used to measure 
the Width and Height of the ray trace 
image: either Pixels or drawing Units. 

• Specify theWidth and Height of the ray 
trace image, in either Pixels or Units. 

• Specify the Resolution of the ray trace 
image, in either Pixels/Inch or Pixels/
mm. 
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Environment Lighting

The ENVIRONMENT LIGHTING panel is only 
available when Exterior is selected on the 
Welcome page. Specify the atmospheric 
conditions of the exterior view you would 
like to ray trace. The options here correspond 
to the Outdoor Render Settings in the Ray 
Trace Options dialog. See “Lighting Panel” 
on page 970.
• Select Sunny for environmental lighting 

that is white in color. 

• Select Overcast for environmental light-
ing that uses a pale gray color. 

• Select Sunset for environmental lighting 
that uses a pale orange color. 

• Select Dark for environmental lighting 
that uses a dark blue color. 

• Select Nighttime for environmental 
lighting that uses a dark blue color with a 
greater intensity than Dark uses. 

Focal Blur



Ray Trace Assistant

 977

Specify the amount of focal blur to use in the 
ray trace. The options here correspond to the 
F-Number in the Ray Trace Options dialog. 
See “Advanced Panel” on page 971.
• Select No Focal Blur to disable Focal 

Blur when this option is used. 

• Select Some Focal Blur to use an F-
Number of 5.6. 

• Select Lots of Focal Blur for to use an F-
Number of 2.8. 

Completing the Assistant

Specify a Name for the newly created ray 
trace configuration. This name will be listed 
in the Ray Trace Current View/Ray Trace 
Defaults dialogs, and can also be changed 
there. See “Ray Trace Current View/Ray 
Trace Defaults Dialog” on page 967.

The initial name created by the program is 
based on the settings from the Welcome 
page. If you click the Back button and 
change these settings, this name will adjust 
as well, provided that you did not change it 
in any way. 

Click Finish to create the new ray trace 
configuration and return to either the Ray 
Trace Current View or Defaults dialog, 
where it will be selected as the Current 
Configuration. 

In order to retain a newly created ray
trace configuration, you must click the
Ray Trace button in the Ray Trace Cur-

rent View dialog. If you click Cancel, the con-
figuration will not be saved. 
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Adjusting Ray Trace Properties and Effects
A number of attributes of a ray trace image 
can be adjusted while the view is being 
generated or after it is complete. 

If Save Image to File is checked in the Ray 
Trace Options dialog, the program will 
automatically save to the specified image file 
if changes are made to it using either the 

Adjust Image Properties  or Adjust 
Effects  tools and the ray trace view 
window is closed. See “General Panel” on 
page 969. 

Adjust Image Properties
Select File> Adjust Image 
Properties to open the Image 

Properties dialog. The settings in this dialog 
are the same as those in the Ray Trace 
Options dialog, where their initial values are 
set. See “Image Properties Panel” on page 
972.

Adjust Effects
Select File> Adjust Effects to open 
the Adjust Effects dialog. 

• Check Enable Bloom to enable the set-
tings below. Bloom, or light bloom, can 
occur around areas of intense illumina-
tion and looks as though the light is 
‘bleeding’ beyond the edges of the light 
source. 

• Specify the Radius, which is the width of 
the bloom area beyond a light source. 
The higher the Radius setting, the longer 
the bloom calculation will take. 

• Specify the Weight, which is the inten-
sity or strength of the bloom effect. 

• Click OK to close the dialog and apply 
your changes to the view. Depending on 
your settings, this could take some time. 
A progress indicator will display at the 
bottom of the window. You can press the 
Esc key to cancel the bloom operation at 
any time. 

Ray Tracing Tips
Ray Tracing gives you the ability to produce 
high quality, photo-realistic images of your 
model; however, it is also a resource 
intensive process that can be quite time-
consuming. For best results, there are a 
number of variables to consider.

Ray Trace Configurations
A Ray Trace Configuration is a group of Ray 
Trace Options settings saved in the current 
plan. You can create your own custom 
configurations for a variety of purposes. See 
“Ray Trace Options” on page 968.
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Ray Trace Configurations can be saved in 
your template plans, saving you the effort of 
reproducing them for each new project. See 
“Template Files” on page 84.

Creating the Camera View
To create a ray trace image in Chief 
Architect, begin by creating a camera view 
or overview of the model. The camera 
position, field of view, and orientation 
determine the scene’s appearance in the ray 
trace window. See “Editing 3D Views” on 
page 916. 

In order to ray trace a view, the Standard 
Rendering Technique must be active. See 
“Standard Rendering” on page 951. 

Ray trace views can be created from both 
Orthographic and Perspective views; 
however, Perspective views appear more 
realistic to the human eye and are better 
suited to producing photo-realistic images. 
See “Perspective and Orthographic Views” 
on page 888. 

Lighting
Lighting is an extremely important aspect of 
high-quality ray trace views. For photo-
realistic results, be prepared to add light 
sources to your model and spend some time 
making adjustments to their positions and 
light data settings. See “Lighting” on page 
936.

Unlike rendered views, which can support 
only a limited number of lights, ray trace 
views can handle as many lights as you like. 
Lighting in ray trace views is also more 
realistic than the lighting used in rendered 
views in that lights are not limited to the 
current room. Instead, all light sources that 

are turned “On” in their specification dialog 
and have been set to Use in Ray Tracing can 
be used. See “Light Data Panel” on page 647.

To increase ray tracing speed, the program 
will identify any lights that do not contribute 
direct lighting to the scene when a ray trace 
is preprocessing and will remove them from 
the ray trace lighting calculations. 

For light sources that cast shadows in a ray 
trace scene, consider using the Soft Shadows 
option. Soft Shadows requires more ray 
tracing time, but smooths the appearance of 
shadows created by a light, improving their 
appearance. See “Light Data Panel” on page 
647.

Most other Render settings, including those 
in the Preferences dialog, are not used for 
generating a ray trace view, although 
Ambient Light, set in the 3D View Defaults 
dialog, is. See “Options Panel” on page 893. 

Material Definitions
The attributes of the materials applied to 
objects in the scene have an extremely 
important effect on the final quality of any 
ray trace. Material definitions can affect ray 
trace views can be adjusted in the Define 
Material dialog. See “Properties Panel” on 
page 871.

A prime example is reflectivity, which helps 
convince the eye that a ray trace image is a 
real photograph. For example:

It’s not unusual for ray traced images to
initially be too dark or too bright. Try
adjusting the Tone Mapping Intensity.

See “Adjusting Ray Trace Properties and
Effects” on page 978.
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• For outdoor scenes, ensure that your win-
dows are slightly reflective. You may 
want to set up a building across the street 
that, though not in the scene, appears in 
the reflections in the windows. 

• In interior scenes, use partly reflective 
materials on objects such as stovetops, 
tile floors, and coffee pots. 

Bump Maps
A bump map is an image that can be used to 
make a surface appear contoured rather than 
flat in ray trace views. Though the effects of 
bump maps are sometimes subtle, they add to 
an image’s quality. For example, wood grain 
that shades appropriately to the lighting in 
the room lends to an appearance of realism.

Any image file or texture can be used as a 
bump map, with dark areas of the image 
corresponding to low points in the bump 
map, and brighter areas corresponding to 
high points. A bump map can be assigned to 
any material in the Define Material dialog. 
See “Properties Panel” on page 871.

Bump map calculation can be time-
consuming, so bump maps should not be 
used when ray tracing speed is a primary 
concern. 

Interior Views
When creating an interior ray trace view in 
which sunlight shines through windows, bear 
these settings mind:  
• To produce effective lighting in interior 

ray traces, Use Photon Mapping needs 
to be checked. See “Advanced Panel” on 
page 971.

• For colored shadows created by light 
passing through colored semi-transpar-
ent objects, check Compute Caustics as 
well. See “Advanced Panel” on page 971.

• The Direct Sunlight Intensity setting for 
interior views should be set higher than 
for exterior views. A value of 5 is a good 
starting point, but you may wish to exper-
iment. See “Lighting Panel” on page 970.

• When your ray trace is finished and the 
ray trace window is active, select Edit> 
Adjust Image Properties  and adjust 
the Brightness value as needed. See 
“Adjust Image Properties” on page 978. 

Nighttime Views
For best results when creating a nightime ray 
trace view, there are a few considerations to 
bear in mind:  
• While the Standard rendered view you 

wish to ray trace is active, select 3D> 
Lighting> Toggle Sunlight  to turn 
off the sun as a light source. See “Generic 
Sunlight” on page 938.

• Use the Ray Trace Assistant to create an 
Outdoor ray trace configuration. Choose 
Dark or Nighttime as the outdoor condi-
tions on the Environment Lighting page. 
See “Ray Trace Assistant” on page 974.

• When the new configuration is finished, 
click the Edit button in the Ray Trace 
Options dialog and enable Photon Map-
ping. The Use Caustics option improves 
the quality of light shining through trans-
parent objects. See “Advanced Panel” on 
page 971.

• When your ray trace is finished and the 
ray trace window is active, select Edit> 
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Adjust Image Properties  and either 
lower the Intensity value or uncheck Use 
Tone Mapping to turn this feature off 
altogether. See “Adjust Image Properties” 
on page 978. 

Faster Ray Tracing
Depending on the scene, a ray trace can quite 
literally take days to produce. There are 
several things you can do to reduce the time 
required:
• Reduce the number of surfaces in the 3D 

model by turning off all layers not used in 
the scene to be ray traced. For example, 
you may be able to turn off terrain layers 
for interior views, or cabinet layers for 
exterior views. See “Layers” on page 
143.

• An even more effective way to reduce the 
size and complexity of a 3D model is to 

use Save As  to create a copy of the 
plan, then delete all areas of the model 
that do not affect the scene to be ray 
traced. Depending on the scene, you may 
be able to delete entire rooms - or even 
entire floors. 

• Image size is a significant factor in the 
speed of a ray trace. As you adjust the 
lighting and other variables in a scene, 
you can save time by creating smaller ray 
traces for preview purposes. To do this, 
specify a relatively small image size in 
the Ray Trace Options dialog. When you 
are ready to create a final ray trace, spec-
ify a larger image size. See “General 
Panel” on page 969.

CPU Usage
Ray tracing is a data intensive process that 
can require a lot of resources on any 
computer. You can specify whether Chief 
Architect or the ray trace engine has access 
to more of your computer’s processor 
resources when both are running in the 
Preferences dialog. See “Ray Trace Panel” 
on page 125. 

Queueing Ray Trace Jobs
Because Chief Architect’s ray trace engine is 
a separate process from the program, you can 
set up a queue of multiple ray trace jobs, 
much like you can queue multiple print jobs 
for a printer. 

Ray traces are generated one at a time, so in 
order for a queue of multiple ray traces to be 
completed, they must all use Ray Trace 
Configurations set to use a defined period of 
time or number of passes. See “General 
Panel” on page 969. 

To queue multiple ray traces

1. Start your first ray trace and then return 
to floor plan view without closing the 
ray trace window. See “Working in Mul-
tiple Views” on page 883.

2. Open or create the next camera view that 
you would like to ray trace. 

3. Choose the desired Ray Trace Configu-
ration and begin the ray trace.

4. Repeat these steps to queue as many ray 
traces as you need. As soon as one fin-
ishes, the next one will begin. 

Do not use the No Limit option when
queueing ray trace jobs.



982

Chief Architect X8 Reference Manual

You can work on other tasks on your 
computer while your ray traces run, or you 
can walk away. You can lock your computer 

and even turn off the monitor; but do not exit 
out of Chief Architect or shut down the 
computer or your queue will be lost.

POV-Ray
The Persistence of Vision Ray Tracer 
(POV-Ray) is a high-quality ray tracer that 
has been used for years to generate images of 
virtually anything imaginable. POV-Ray has 
even been used on the Space Shuttle! 

Hobbyist ray tracers can learn more about 
POV-Ray by visiting the POV-Ray Web site 
at www.povray.org.

Chief Architect version X2 and prior used a 
special version of POV-Ray to generate ray 
trace images. If you have a copy of POV-Ray 
installed and wish to use it rather than Chief 
Architect’s ray tracer, you can export a 
Standard rendered view from Chief Architect 
and ray trace it in POV-Ray.

Positioning the Camera

Using the Zoom Tools  or panning the 
display in a Perspective view has no effect on 

a view exported to POV-Ray. If you have 
zoomed or panned in a Perspective view and 
then try to ray trace it, a warning message 
will inform you that these changes will not 
be reflected in the ray trace. See “Window 
and View Tools” on page 879.

To position a Perspective camera prior to 
exporting to POV-RAY, use any of the 
camera editing tools:
•      Move Camera with Mouse
•      Move Camera with Keyboard
•      Move Camera Tools
•      Orbit Camera Tools
•      Tilt Camera Tools

For more information, see “Editing 3D 
Views” on page 916.

POV-Ray Export Options Dialog
While a Standard rendered view is active, 
select File> Export> POV-Ray (.POV).
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Ray Trace Configurations are saved 
groups of ray trace settings. Please note 

that the configurations saved for POV-Ray 
export are different from those saved for ray 
tracing within Chief Architect and are only 
listed in this dialog.
• Select a configuration from the drop-

down list. 
• Click the New button to create a new 

configuration, and make any changes to 
the settings that follow to customize it. 

• Click the Save button to save a new con-
figuration or any changes made to the 
selected configuration.

• Click the Delete button to remove the 
selected configuration from the list. Not 
available if there is only one configura-
tion in the list.

Ray Trace Window - Specify the size 
of the final ray trace image. 

• Check Use Current Window Size to set 
the ray trace to the size of the original 3D 
view window. 

1

2
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• Specify the Height and Width of the ray 
trace image you wish to create, in pixels. 

• Check Retain Aspect Ratio to maintain 
the width to height ratio of the original 
image and prevent the ray trace image 
from appearing stretched or distorted. 

Ray Trace Parameters - Specify the 
lighting properties and image quality of 

the ray trace. 
• Specify the level of Radiosity, or the cal-

culation of light bouncing around in the 
scene. None produces lighting effects 
similar to Standard rendering but is fast, 
while High Quality produces photo-real-
istic effects but is very time-consuming.

• Specify the Time of Day. Similar to the 
Toggle Sunlight options in a rendered 
view, choose whether to create a Day-
time or Nighttime ray trace view. 

• Specify the level of Anti-aliasing, which 
generates smooth edges in the ray trace 
view. 

Specify the Sunlight Contribution in 
the view. Only available when Radios-

ity is used. 
• The Direct Sunlight setting controls the 

intensity of the light coming from the 
sun.

• The Diffuse Sunlight setting controls the 
brightness of the sunlight in the surround-
ing atmosphere. 

Lighting and Shadows - 

• Check Use Soft Shadows to display 
shadows with soft edges instead of hard 
edges and can add to ray tracing time. 
Only light sources set to create soft shad-
ows will produce them. See “Light Data 
Panel” on page 647. 

• When Create default light if none exists 
is checked, a light source is created in 
views where none are present so that the 
ray trace is not calculated in total dark-
ness. Uncheck this box only if you do not 
want this to occur. See “Default Interior 
Light” on page 937. 

Export Settings - 

• Check Execute POV-Ray Once Export 
is Complete to launch POV-Ray so you 
can begin ray tracing the scene as soon as 
the export process is finished.

• Check Copy Texture and Image Files to 
Export Folder to make a copy of all tex-
tures and images used in the model into 
the same directory as the destination for 
your POV-Ray export. 

Write POV-Ray File Dialog
After you click OK in the POV-Ray Export 
Options dialog, the Write POV-Ray File 
dialog will open. This is a standard Save 
dialog which lets you specify the file name 
and save location of your .pov file and any 
associated textures and images. See 
“Exporting Files” on page 58. 

3

4
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Chapter 32:

Dimensions

Chief Architect provides a variety of manual 
and automatic dimensioning tools for 
measuring walls, doors, windows, and many 
other objects in various 2D and 3D views. 

Dimensions can be used to accurately 
position objects relative to other objects. In 
addition, dimension lines and extensions can 
be selected and customized. 

Chapter Contents
•      Compatibility With Previous Versions
•      Dimension Preferences and Defaults
•      Dimension Defaults Dialog
•      Auto Dimension Defaults Dialogs
•      Auto Elevation Dimension Defaults
•      Temporary Dimension Defaults Dialog
•      The Manually Drawn Dimension Tools
•      The Automatic Dimension Tools
•      Displaying Dimension Lines
•      Selecting Dimension Lines
•      Editing Dimension Lines
•      Editing Extension Lines
•      Add Additional Text
•      Moving Objects Using Dimensions
•      Dimension Line Specification Dialog

Compatibility With Previous Versions
Dimensions function differently in versions 
9.0 and later of Chief Architect than they did 
in previous versions. Being familiar with 
these changes is necessary if you plan to 
open plans from earlier versions.

Extension Lines
In Version 8, extension lines had two modes: 
normal and short. Version 9 and later offer 
full control over extension lines. If Chief 
Version 8 Compatible Extensions is 
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checked, you do not have this control. See 
“Extensions Panel” on page 996.

Accuracy
When the model is drawn with greater 
accuracy than dimensions are set to display, 
rounding may be required. The Rounding 
Method in the Dimension Defaults dialog 
controls how Chief Architect handles 
dimensions that require rounding. See “Setup 
Panel” on page 988.

In Chief Architect version 8 and prior, 
dimensions used Distance Rounding, which 
shows the distance between equally spaced 
objects correctly, but dimension runs are not 
always accurate when added. 

In Versions 96 and later, dimensions use Grid 
Rounding, which always add up dimension 
runs correctly, but individual distances may 
be inaccurate in order to achieve this. 

Dimensioning the same object using these 
two rounding methods will obtain the same 
results as long as  objects are placed with the 
same accuracy as the precision of the 

dimension lines. If an object is placed using 
more precision than the dimensions, results 
may vary between methods.

Dimension Preferences and Defaults
There are a number of settings in the 
Preferences dialog that affect dimensions, 
as well as several dimension defaults dialogs. 

Preferences
All plan and layout files save 
measurements in either Imperial or 

metric units. The type of unit used is 
determined when the file is first created and 
cannot be changed later. See “Creating a 
New Plan or Layout” on page 54.

You can specify either metric or Imperial 
files to be used as the templates whenever 
you open a new, blank plan or layout file in 
the Preferences dialog. See “New Plans 
Panel” on page 103. 

You can also specify the minimum on-screen 
display size for dimension numbers in the 
Preferences dialog. See “Appearance 
Panel” on page 92. 

A good approach to accurate dimen-
sioning is to turn on the accuracy indi-

cators and position objects so that the
inaccuracy indicators do not display. 

smallest fraction of 1/16”

no fractions
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Default Settings
Select Edit> Default Settings or 

double-click the Dimension Tools  
parent button or any of its child buttons . 
There are eight dimension defaults dialogs:
• Dimension Defaults Dialog 
• Three Auto Dimension Defaults Dialogs 
• Three Auto Elevation Dimension 

Defaults Dialogs
• Temporary Dimension Defaults Dialog 

When Angle Snaps  are enabled, 
dimensions can be drawn at the Allowed 

Angles set in the General Plan Defaults 
dialog. Regardless of their angles, however, 
dimensions will only locate objects that are 
parallel to one another. See “General Plan 
Defaults Dialog” on page 88. 

Annotation Sets
Manually drawn dimensions are 
among the items associated with 

Annotation Sets, which are groups of Saved 
Defaults that can be customized and 
activated for specific drawing tasks. See 
“Annotation Sets” on page 80.

Dimension Defaults Dialog
Select Edit> Default Settings, 
expand the “Dimension” category, 

select “Dimensions”, and click the Edit 
button to open the Dimension Defaults 
dialog. 

You can also double-click either the Dimen-
sion Tools  or Automatic Dimension 
Tools  parent button to open the this 
dialog.

Manually drawn dimensions are able to 
support multiple Saved Defaults for specific 
drawing tasks.  See “Multiple Saved 
Defaults” on page 77.
• When you access the Dimension 

Defaults dialog via the Default Settings 
dialog, the Saved Defaults dialog will 
open first, allowing you to select which 
Saved Manual Dimension Default that 
you wish to edit.

• When you access this dialog by double-

clicking the Dimension Tools  button, 
the defaults dialog for the currently active 
Saved Default is opened directly. If you 
would like the Saved Defaults dialog to 
open first in this situation, you can enable 
this option in the Preferences dialog. 
See “General Panel” on page 98. 

• In either case, the name of the Saved 
Default being edited will display in the 
title bar at the top of the dialog box. 

The settings in this dialog are dynamic 
defaults, which means that any changes 
made here may affect existing dimension 
lines in the drawing that are using the Saved 
Manual Dimension Default being edited. See 
“Dynamic Defaults” on page 76. 
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Setup Panel

General - 

• Specify the Baseline Separation, which 
is the distance between Baseline Dimen-
sion lines in plan inches (mm). This value 
should always be greater than the font 
size. If two formats are used, it should be 
at least twice the font size. 

• Specify how far manually drawn dimen-
sion lines Reach to locate walls and/or 
objects specified on the LOCATE OBJECTS 
panel. The default is 24” (450 mm) in 
plan files and 1” (10 mm) in layout.

Specify the initial spacing of 
Automatic Dimensions. See “The 

Automatic Dimension Tools” on page 1009. 
• Specify the Line Separation, which is 

the distance between Auto Exterior 
Dimension lines in plan inches (mm). 
This value should always be greater than 

the font size. If two formats are used, it 
should be at least twice the font size. 

• Specify the 1st Line Offset, which is the 
distance between each wall and the near-
est Automatic Dimension line that mea-
sures its length in plan inches (mm). 

Specify the use and appearance of 
Rounded Value Indicators, which can 

display when the degree of accuracy in use is 
not sufficient to describe a dimension’s true 
value. 
• Check + or - After Number to indicate 

that the actual dimension value is higher 
or lower than the value shown.

• Check ~ Before Number to indicate 
dimension values that are not accurate 
with the ~ symbol.

Rounding Method - Specify how the 
sections of dimension lines that locate 

more than two objects are rounded. 

1

2

3

4
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• Grid Rounding ensures that the sum of 
the parts of a dimension line add up to the 
whole distance. To produce this result, 
some sections may not be rounded accu-
rately. This is the recommended rounding 
method and is selected by default.

• Distance Rounding addresses each sec-
tion of a dimension line individually, 
which could result in the sum of these 
sections not being equal to the whole. 

This option is selected by default for files 
created in Version 8 or prior but is not 
recommended for newer files. See “Com-
patibility With Previous Versions” on 
page 985. 

Primary Format Panel
The settings on the PRIMARY FORMAT panel 
allow you to specify the units, degree of 
accuracy, and position of dimension 
numbers. 

These settings are the same as those on the 
PRIMARY FORMAT panel of the Dimension 
Line Specification dialog and the DIMEN-
SION FORMAT panel of the Room Label 
Defaults dialog. See “Dimension Line 
Specification Dialog” on page 1021 and 
“Room Label Defaults” on page 330. 

These settings are also similar to those on the 
INNER, OUTER, and MARKER FORMAT panels 
of the Auto Story Pole Dimension Defaults 
and Dimension Line Specification dialogs. 
See “Auto Elevation Dimension Defaults” on 
page 999.

In addition to these Primary dimension 
numbers, you can display a set of Secondary 
dimension numbers that indicate the 
dimension’s length using different units, 
degree of acuracy, and/or location. 

The settings on this panel also control the 
format of numbers indicating object length in 
the Status Bar. See “The Status Bar” on page 
42. 

To avoid the appearance of inaccuracy
that rounding may cause, draw with

Grid Snaps enabled and place objects in your
plan using the same accuracy as your dimen-
sions. See “Grid Snaps” on page 166. 
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In the Auto Story Pole Dimension Defaults 
and Specification dialogs only, check Use 
Default Formatting to use the Primary 
Format settings of the currently active 
Dimension Defaults as the Inner Format. 

Specify the numbering Format for 
dimension numbers. 

• Select the Units of measurement to be 
used by dimensions from the drop-down 
list. The choices in this list correspond to 
all units measuring length specified in the 
Preferences dialog. See “Unit Conver-
sions Panel” on page 104.

• Check Unit Indicators to display the unit 
of measurement along with the dimen-
sion number.

• Check Leading Zeros to include the zero 
before a decimal less than 1 or to display  
0’ or 0” when the ft-in or ’-” unit formats 
is used. 

• Check Trailing Zeros to display trailing 
zeros at the end of decimal values. When 
the ft-in or ’-” unit format is used and 

1

Note: Although you can select Imperial or
metric units in any plan or layout, it is best to
use the same unit type that the file uses to
save measurements. See “Units of Measure-
ment” on page 55.
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fractional inches are specified, 0” will be 
included. 

• Check Thousands Separator to use a 
digit grouping symbol for values greater 
than 999. 

• Select the Use Comma, Use Dot, or Use 
Non-Breaking Space radio button to 
specify the thousands separator used by 
dimensions. Which option is available 
will depend on your operating system set-
tings. See “Region and Language Set-
tings” on page 75.

• Select the Use Space radio button to use 
a space as the thousands separator. 

Specify the degree of Accuracy used 
by dimension numbers. 

• Select the Decimal Places radio button 
for dimension numbers in decimal for-
mat. In the text field, specify the number 
of decimal places to use, from 0 to 20. If 
0 is used, no decimal places are used.

• Select the Smallest Fraction radio but-
ton for dimension numbers using whole 
numbers and fractions. In the text field, 
specify the largest denominator to use, 
from 1 to 128. If 1 is entered, whole num-
bers are used. 

• Uncheck Show Denominator to turn off 
the display of fraction denominators used 
by dimension lines. Typically, denomina-
tors are only turned off when eighths are 
desired.  

• Uncheck Reduce Fractions to always 
use the denominator specified above. 

When checked, the lowest possible 
denominator will be used.

When Smallest Fraction is selected, specify 
how fractions are reduced:
• Select the Greatest Common Divisor 

radio button to reduce fractions using the 
largest value that divides equally into the 
numerator and the denominator specified 
above. This option is best for fractional 
inches. 

• Select the Closest Fraction radio button 
to reduce fractions without referring to 
the denominator specified above. Should 
only be used with Distance Rounding. 
Not recommended when fractional inches 
are used.

A value of 0.33333 is represented by the 
fraction 5/16 when Greatest Common 
Divisor is used and the Smallest Fraction 
denominator is 16. When Closest Fraction is 
selected, this value is represented by 1/3. 

Specify the Dimension Text Position, 
which is the location of dimension 

numbers relative to the dimension line. 
• Center primary dimension numbers on 

the dimension line. If two formats are 
used, the primary format is placed above 
the line and the secondary format, 
beneath it. 

• Position dimension numbers Above 
Line. 

• Position dimension numbers Below Line. 

Secondary Format Panel
In addition to the Primary dimension label, 
you can display a set of secondary numbers 

2

3
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that indicate the dimension’s length using 
different units and/or degree of accuracy. 

The settings on the SECONDARY FORMAT 
panel of the Dimension Defaults dialog are 
similar to those on the PRIMARY FORMAT 
panel, with one addition:
• Check Include Second Format to use a 

secondary dimension label and enable the 
settings on this panel. 

The settings on this panel are also the same 
as those on the same panel of the Dimension 
Line Specification dialog. See “Dimension 
Line Specification Dialog” on page 1021. 

If you choose to use a second format, you 
may want to increase the default Line 
Separation on the Setup panel. 

Locate Objects Panel
The settings on the LOCATE OBJECTS panel 
specify whether or not dimension lines locate 
specific types of objects. Changes made on 
this panel only affect new dimension lines, 
not those already drawn.

These settings affect dimension lines as they 
are drawn. Once created, their extension 
lines can be edited so that they locate objects 
in ways not specified here. See “Editing 
Extension Lines” on page 1016. 

The LOCATE OBJECTS panel is also found in 
most Auto Dimension Defaults dialogs. The 
options available will vary for each defaults 
dialog. See “Auto Dimension Defaults 
Dialogs” on page 998. 

In the NKBA® Auto Elevation Dimension 
Defaults and in the Dimension Defaults 
dialogs for a layout file or CAD Detail 
window, only the CAD Objects settings on 
this panel will be available.
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The Walls settings affect Manual and 
Interior Dimensions and are also 

available in most Auto Dimension Defaults 
dialogs. See “The Manually Drawn 
Dimension Tools” on page 1005 and “Auto 
Dimension Defaults Dialogs” on page 998. 

The first two settings also determine the 
marked location in wall assemblies referred 
to by Extension Lines as well as the Reach 
and 1st Line Offset settings. See “The 
Dimension Layer” on page 303. 

• Select Surfaces to locate exterior walls 
by outer surface and interior walls by one 
of their surfaces.

• Select Wall Dimension Layer to locate 
walls at the Dimension Layer. A wall’s 
Dimension Layer is specified in its wall 
type. See “Wall Type Definitions Dialog” 
on page 305. 

• Select None to prevent Manual and End 
to End Dimensions from locating walls.

1
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The Wall Options settings control how 
dimensions locate interior walls where 

they intersect exterior walls, and only apply 
to interior walls drawn perpendicular to the 
exterior walls they intersect. They are 
available in the Auto Exterior Dimension 
Defaults dialog but not the other Auto 
Dimension Defaults dialogs.
• Select Interior Wall Centers to have 

dimension lines locate the centers of inte-
rior walls. If Wall Dimension Layer is 
selected above, dimensions locate interior 
walls at the center of their Main Layers. 
See “The Main Layer” on page 302. 

• Select Primary Wall Side to have 
dimension lines locate one side of interior 
walls. 

• Select Both Wall Sides to have dimen-
sion lines locate both surfaces of interior 
and exterior walls. Wall thicknesses are 
also dimensioned. 

• Check Interior Walls Only for dimen-
sions to ignore the interior surface of 
exterior walls and the thicknesses of inte-
rior walls. Only available when Both 
Wall Surfaces is selected. 

The Cabinets options affect how 
dimension lines locate objects cabinets 

and cabinet fillers within the Reach area and 
are also available in the Auto Interior and 
Auto Elevation Dimension Defaults 
dialogs. See “Using Dimensions” on page 
689.

• Check Sides to locate the sides of cabinet 
objects. The sides do not need to be per-
pendicular to the dimension line.

• Check Corners to locate the corners of 
cabinet objects. Angled cabinets are 
dimensioned to their corners at a right 
angle to the dimension line. A cabinet’s 
front or sides do not need to be perpen-
dicular or parallel to the dimension line 
for its corners to be located. 

• Check to locate the Centers of cabinet 
objects. A cabinet’s front or sides do not 
need to be perpendicular or parallel to the 
dimension line for its center to be 
located. 

• Check to locate cabinet Countertop 
edges. A cabinet’s front or sides must be 
perpendicular or parallel to the dimension 
line for its countertop to be located. In 
elevation views, only the height can be 
located when the dimension is being 
drawn. Does not affect Custom 

Countertops . 
• Check to locate top and bottom Back-

splash edges in elevation views. 
• Check to locate top and bottom Toe Kick 

edges in elevation views. 
• Check to locate tops and bottoms of 

Moldings in elevation views. 

The Fixtures/Appliances options 
affect how dimension lines locate 

appliances and other fixtures including 
hardware, millwork, sprinklers, and 
Geometric Shapes. These options are also 
available in the Auto Interior and Auto 
Elevation Dimension Defaults dialogs. 
• Check to locate the Sides/Corners of 

appliances and other fixtures. For sides to 

Note: Walls specified as No Locate will not be
located by some dimension tools. See “No
Locate” on page 285. 

2
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be located, they must be perpendicular to 
the dimension line. 

• Check to locate the Centers of all fix-
tures within the Reach area. An object’s 
front or sides do not need to be perpen-
dicular or parallel to the dimension line 
for its center to be located. 

The Furniture options control how 
interior and exterior furnishings are 

located by dimension lines and are also 
available in the Auto Interior and Auto 
Elevation Dimension Defaults dialogs.
• Check to locate the Sides/Corners of fur-

nishings. For sides to be located, they 
must be perpendicular to the dimension 
line.

• Check to locate the Centers of all fur-
nishings within the Reach area. An 
object’s front or sides do not need to be 
perpendicular or parallel to the dimension 
line for its center to be located. 

The Openings options control how 
wall openings are located by dimension 

lines and are also available in most Auto 
Dimension Defaults dialogs.
• Select Centers for dimensions to locate 

the centers of wall openings.
• Select Sides to locate both sides of wall 

openings. This option locates the nominal 
width - not the rough opening.

• Select Casing to locate both sides of wall 
openings at the outer edges of the casing. 
Because interior and exterior casing often 
has different widths, an opening may 

have different interior and exterior 
dimensions when this option is selected.

• Select Rough Opening to locate both 
sides of windows and doors at the rough 
opening. 

• Select None for dimensions to not locate 
wall openings. This setting does not 
affect Auto Exterior Dimensions. 

The CAD Objects options control how 
dimension lines locate 2D CAD objects 

as well as CAD-based objects such as slabs 
and polyline solids, and stairs. They are also 
available in the NKBA® Auto Dimension 
Defaults dialog. 
• Check Line/Sides to locate lines and 

edges that are perpendicular to the 
dimension line. If the lines or edges are 
not perpendicular to the dimension line, 
they are not dimensioned. 

• Check Ends/Corners to locate all ends 
of lines or corners of polylines, no matter 
what angle they are in relation to the 
dimension line.

• Check Callouts/Markers to locate these 
objects.

• Check Text to locate text objects.

The Primitives/Shapes options affect 
how dimension lines locate objects 

drawn with the Primitive Tools . See 
“Primitive Tools” on page 778.
• Check Sides to locate the sides of primi-

tive/shape objects. The sides must be per-
pendicular to the dimension line.

Note: In cross section/elevation views,
dimensions can only locate furniture at points
where a surface is present. 

5

6

Note: Openings in walls specified as No
Locate will not be located by Auto Exterior
Dimensions. See “No Locate” on page 285. 

7

8
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• Check Corners to locate the corners of 
all primitive/shape objects within the 
Reach area. Corners are dimensioned at a 
right angle to the dimension line. An 
object’s front or sides do not need to be 
perpendicular or parallel to the dimension 
line for its corners to be located. 

• Check to locate the Centers of all primi-
tive/shape objects within the Reach area. 
An object’s front or sides do not need to 
be perpendicular or parallel to the dimen-
sion line for its center to be located. 

The Framing options affect how 
dimension lines locate framing objects. 

• Select Centers for dimensions to locate 
the centers of framing objects.

• Select Sides to locate both sides of fram-
ing objects. 

The Other Objects options affect how 
dimension lines locate additional object 

types. The Electrical option  is available in 
the Auto Interior and Auto Elevation 
Dimension Defaults dialogs. 
• Check Electrical to locate electrical 

objects. Use this option when you want to 
precisely position electrical objects.

• Check Plants and Images to locate these 
objects.

Locate Elevations Panel
The settings on the LOCATE ELEVATIONS 
panel determine what elevation marks are 
located by vertically oriented, manually 

drawn dimension lines in cross section/
elevation views. For more information, see 
“Locate Elevations Panel” on page 1002.

Extensions Panel

Specify the Extension Length relative 
to the marked location on an object. 

• Select Gap From Marked Object to 
specify the distance between the end of 
extension lines and their marked location 
in plan inches or mm. If a dimension line 

9

10
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is moved, extension lines update, and the 
size of this gap is maintained. 

• Select Length Towards Marked Object 
to specify a fixed length for the portion of 
an extension line that extends from the 
dimension line toward the object it 
locates. If the dimension line is moved, 
this length remains the same but the size 
of the gap updates.

• Specify the Length Away From Marked 
Object, which is the length of the portion 
of an extension line that extends from the 
dimension line in the opposite direction 
of the object it locates. 

Check Proximity Fixed to specify a 
fixed distance between the marked 

object and the dimension line. You can only 
fix the proximity for a single extension line. 
See “Using Proximity Fixed” on page 1017.
• Distance to Marked Object - When 

Proximity Fixed is checked, you can 
specify the distance from the dimension 
line to the marked object using a positive 
value. 

           Gap From Marked Object 

       +  Length Toward Marked Object

       =  Distance to Marked Object

Proximity Fixed only affects dimension lines 
that locate an object using an extension line. 
When a dimension line arrowhead points 
directly to the object without using an 
extension line, this option has no effect. 

Auto Exterior Dimensions ignore Distance to 
Marked Object and use the default 1st Line 
Offset and Line Separation values. See 
“Setup Panel” on page 988.

Legacy Support - Specify how 
dimensions behave in files created in 

Chief Architect Version 8 or prior. See 
“Compatibility With Previous Versions” on 
page 985. 
• Check Chief Version 8 Compatible 

Extensions to make extensions function 
as they did in Chief Architect Version 8. 

• Check Short Extensions to have short, 
uniform-length extension lines instead of 
extension lines that reach all the way to 
the objects they locate. 

Layer Panel
The LAYER panel is found in the 
specification dialogs for many different 
objects. For more information, see “Layer 
Panel” on page 154. 

If an automatic dimension line is edited, it 
will no longer be considered Automatic and 
the Default checkbox on this panel will be 
unchecked. See “Editing Dimension Lines” 
on page 1014. 

Arrow Panel
For information about the ARROW panel, see 
“Arrow Panel” on page 1088.

2

Extension Line and Gap lengths are
measured from the marked location on

a wall. See “The Dimension Layer” on page
303. 

Note: If you select an extension line, Chief
Version 8 Compatible Extensions will be
turned off automatically.

3
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Text Style Panel
The settings on the TEXT STYLE panel control 
the size, font and other attributes of 
automatic, manually drawn, and temporary 
dimension line labels. See “Dimension 
Labels” on page 1012. 

For information about the settings on this 
panel, see “Text Style Panel” on page 1063.

Temporary dimension labels always use the 
color assigned to their layer - not the color 
specified in the Dimension Defaults dialog. 

Auto Dimension Defaults Dialogs
There are two categories of Automatic 
Dimensions: those that can be created 

in floor plan view, and those that can be 
created in cross section/elevation views. The 
settings in the Auto Dimension Defaults 
dialogs allow you to control the initial 
appearance and behavior of dimensions 

created using the Auto Dimension  tools 
available in floor plan view. See “The 
Automatic Dimension Tools” on page 1009. 

Select Edit> Default Settings or double-
click either the Automatic Dimension 
Tools  or Dimension Tools  parent 
button. Expand the Dimension category, 
select one of the “Auto” subcategories, and 
click the Edit button. 

You can also add buttons to your toolbars 
that you can click to quickly open each of 
these dialogs. See “To add a button to a 
toolbar” on page 132.

• Auto Exterior Dimensions Defaults 

• Auto Interior Dimensions Defaults 

• NKBA® Auto Dimensions Defaults 

The default Line Separation and First Line 
Offset values for automatic dimensions are 
set in the Dimension Defaults dialog. See 
“Setup Panel” on page 988.

See, too, “Auto Elevation Dimension 
Defaults” on page 999. 

General Panel
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• Specify how far Auto Exterior Dimen-
sion  lines Reach to locate objects set 
back from exterior walls. The default is 
192 inches (4800 mm). If exterior walls 
are set back further than this distance, 
additional dimension lines are produced 
to dimension the set-back walls. Only 
available in the Auto Exterior 
Dimension Defaults dialog.

• Specify the Minimum Area: the mini-
mum enclosed area needed for Auto 
Dimensions to generate.

• Check Overall Dimension to generate 
the overall dimensions of a plan when 
Auto Dimensions are created.

• Check Auto Refresh Dimensions to 
delete and replace Auto Exterior Dimen-
sions whenever a change is made to the 
model that affects them. Not available for 
other Auto Dimensions.

• Check Ignore Interior Walls to prevent 
interior walls that intersect exterior walls 
from being located by Auto Exterior 

Dimensions. Not available for other Auto 
Dimensions. 

Locate Objects Panel
The settings on the LOCATE OBJECTS panel 
are also found on the same panel of the 
Dimension Defaults dialog. The available 
options will vary in each defaults dialog, 
depending on the functionality of the tool. 
See “Locate Objects Panel” on page 992. 

The LOCATE OBJECTS panel is not available 
in the NKBA® Auto Dimension Defaults 
dialog. 

Layer Panel
The LAYER panel allows you to specify what 
layers dimensions created using the Auto 
Dimension tools are placed on. It is found in 
the specification dialogs for many different 
objects. For more information, see “Layer 
Panel” on page 154. 

Auto Elevation Dimension Defaults
The settings in the Auto Elevation, 
NKBA® Auto Elevation, and Auto 

Story Pole Dimension Defaults dialogs 
allow you to control how automatic 
dimensions and Auto Story Poles are created 
in cross section/elevation views. See “The 
Automatic Dimension Tools” on page 1009. 

Select Edit> Default Settings , expand 
the Dimension category, select one of these 
“Auto” subcategories, and click Edit to 
access the associated defaults dialog. 

Each of these defaults dialogs also can be 
opened by clicking an associated toolbar 
button of the same name, which can be added 
to your toolbars. See “To add a button to a 
toolbar” on page 132.

• Auto Elevation Dimensions Defaults 
• NKBA® Auto Elevation Dimensions 

Defaults 

• Auto Story Pole Dimensions Defaults 
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The appearance of Auto Elevation and Story 
Pole Dimensions, including their size, 
primary and secondary formats, and 
extension lines, are set along with those of 

manual and the other automatic dimensions 
in the Dimension Defaults dialog. See 
“Dimension Defaults Dialog” on page 987. 

General Panel
The settings available on the GENERAL panel 
will vary somewhat depending on which 
defaults dialog is open.

The Position settings control where 
automatic elevation dimensions are 

generated, relative to the model.
• Check Dimension on Left to create a 

dimension string or story pole on the left 
side of the model in cross section/
elevation views. 

• Check Dimension on Right to create a 
dimension string or story pole on the 
right side of the model.

• Check Dimension on Top to create a 
dimension string above the model.

• Check Dimension on Bottom to create a 
dimension string below the model.

Additional Options control how many 
dimension strings are created.

• Check Overall Dimension to generate an 
overall dimension underneath the model 

when Auto Elevation Dimensions  
are created. Only available for in the 
Auto Elevation Dimension Defaults dia-
log. 

• Uncheck Inner Dimension to suppress 
the inner dimension string and generate 
only one outer dimension. Only available 
in the Auto Story Pole Dimension 
Defaults dialog. See “Auto Story Pole 
Dimensions” on page 1011.

• Uncheck Dimensions Between 
Elevation Markers to suppress the outer 
dimension string that measures the 
distances between each of the elevation 

1

2
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markers. Only available in the Auto 
Story Pole Dimension Defaults dialog.

Inner Format Panel
The settings on the INNER FORMAT panel 
control the format of the inner string of 
dimensions on a Story Pole, if present, and 
are similar to those on the PRIMARY FORMAT 
panel of the Dimension Defaults dialog. See 
“Primary Format Panel” on page 989.
• Check Use Default Formatting to use 

the Primary and Secondary Format 
settings of the Dimension Defaults that 
are active when a Story Pole is created as 
the Inner Format. See “Multiple Saved 
Defaults” on page 77.

This panel is only available in the Auto 
Story Pole Dimension Defaults dialog. It is 
not found in the Auto Elevation Defaults or 
the NKBA® Auto Elevation Dimension 
Defaults dialogs.

Outer Format Panel
The settings on the OUTER FORMAT panel 
control the format of the outer string of 
dimensions on a Story Pole and are similar to 
those on the PRIMARY FORMAT panel of the 
Dimension Defaults dialog. See “Primary 
Format Panel” on page 989.
• Check Use Default Formatting to use 

the Primary and Secondary Format 
settings of the currently active Dimension 
Defaults as the Outer Format. 

This panel is only available in the Auto 
Story Pole Dimension Defaults dialog. It is 
not found in the Auto Elevation Defaults or 

the NKBA® Auto Elevation Dimension 
Defaults dialogs.

Marker Format Panel
The settings on the MARKER FORMAT panel 
control the format of the elevation value 
stated in elevation markers’ bottom line of 
text on a Story Pole and are similar to those 
on the PRIMARY FORMAT panel of the 
Dimension Defaults dialog. See “Primary 
Format Panel” on page 989.
• Check Use Default Formatting to use 

the Primary Format settings of the 
currently active Dimension Defaults as 
the Marker Format. 

This panel is only available in the Auto 
Story Pole Dimension Defaults dialog. It is 
not found in the Auto Elevation Defaults or 
the NKBA® Auto Elevation Dimension 
Defaults dialogs.

Once a Story Pole dimension has been 
created, Additional Text can be added to the 
bottom line of marker text in the Dimension 
Line Specification dialog. See “Segments 
Panel” on page 1025. 

Locate Objects Panel
The settings on the LOCATE OBJECTS panel 
specify whether or not dimension lines locate 
specific types of objects and will vary 
depending on which Dimension Defaults 
dialog is open. In the NKBA® Auto 
Elevation Dimension Defaults dialog, only 
the CAD Objects options are available. 

For more information, see “Locate Objects 
Panel” on page 992.
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Locate Elevations Panel
The settings on the LOCATE ELEVATIONS 
panel control what marks dimension lines 
locate in cross section/elevation views as 
well as how Elevation Markers report their 
heights.

This panel is also found in the Dimension 
Defaults dialog, but is not available in other 
Dimension Defaults dialogs.

Automatic elevation dimensions can also be 
set to locate additional types of objects. See 
“Locate Objects Panel” on page 992. 

Specify the position of the Grade 
Level Marker measured Relative to 

1st Floor Subfloor. This value determines 
the height at which Grade Level is marked by 
dimension line Elevation Markers, but is not 
tied to the location of the terrain. 
• If this value is greater than or less than 0 

and Grade Level is a Mark to Include, it 
will be located at this distance above or 
below the Default 1st Floor Subfloor. See 
“Floor 1 Default Height” on page 330.

• When this value is 0, Grade Level is 
marked at the same elevation as the 
Default 1st Floor Subfloor. 

• There is only one Grade Level Marker 
height in each plan, and it is a dynamic 
setting. If it is modified in one defaults 
dialog, its value will change automati-
cally in the other two defaults dialogs and 
any dimensions with Elevation Markers 
in the plan will update as well.

1
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Select the desired Elevation Reference, 
which is the elevation mark that all other 
marks’ elevations are measured relative to.
• Select Grade Level Marker to specify 

the elevation of the Grade Level Marker 
as 0 and measure all other marks relative 
to it.

• Select 1st Floor Subfloor to specify the 
elevation of the Default 1st Floor Sub-
floor as 0 and measure all other marks 
relative to it.

Specify which elevation Marks are 
included in vertically-oriented 

automatic elevation dimensions by default.
• An alphabetical list of Available Marks 

displays on the left. 
• Select one or more names in the list, then 

click the Add button to move them to the 
Marks to Include list on the right. See 
“Shift and Ctrl Select” on page 186.

• You can also double-click on an item in 
this list to add it to the Marks to Include. 

• A list of the Marks to Include displays 
on the right. At least one column must be 
included to create a vertical automatic 
elevation dimension. 

• In the Marks to Include list, click in the 
Outer column of any line item to add or 
remove a checkmark. When checked, the 
selected mark will be included on the 
outer dimension line of an Auto Story 
Pole . Only available in the Auto 
Story Pole Dimension Defaults dialog.

• Select or double-click on an item in the 
Marks to Include list and click the 
Rename button to specify a new name.

• Click the Reset button to restore the 
default names for the selected Marks to 
Include.

• Select one or more items in the Marks to 
Include list, then click the Remove but-
ton to move those items back to the 
Available Marks list on the left. 

Layer Panel
The LAYER panel allows you to specify what 
layers dimensions created using each of the 
Auto Dimension tools are placed on. It is 
found in the specification dialogs for many 
different objects. For more information, see 
“Layer Panel” on page 154. 

Temporary Dimension Defaults Dialog
The settings in the Temporary 
Dimension Defaults dialog allow you 

to control how Temporary Dimensions locate 
walls and CAD objects. See “Temporary 
Dimensions” on page 1008. 

Select Edit> Default Settings , expand 
the Dimension category and choose 
“Temporary”, and click Edit to access this 
dialog. You can also open this dialog by 

Note: The Grade Level setting and the terrain
in the plan are completely independent of one
another. See “Terrain” on page 715. 

2

Note: Deck framing and planking cannot be
automatically located by vertically oriented
elevation dimensions. They can, however, be
located by manually added extensions. See
“Adding Extension Lines” on page 1016. 
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clicking the Temporary Dimension 
Defaults  button, which you can add to 
your toolbars. See “To add a button to a 
toolbar” on page 132. 

The appearance of Temporary Dimensions, 
including their size, format, and extension 
lines, are set along with those of manual and 
automatic dimensions in the Dimension 
Defaults dialog. See “Dimension Defaults 
Dialog” on page 987. 

With Wall Selected - Specify how 
walls are located by temporary 

dimensions when a wall is selected. 
• Select Locate Wall Surface to locate 

wall surfaces.

• Select Locate Wall Dimension Layer to 
locate wall dimension layers as specified 
in the Wall Type Definitions dialog. See 
“Wall Type Definitions” on page 302.

The next two settings control how temporary 
dimensions locate interior walls. 
• Select Primary Wall Side to locate one 

side of interior walls. 
• Select Both Wall Sides to locate both 

surfaces of a selected interior wall. Wall 
thicknesses are not dimensioned. 

With Opening Selected - Specify how 
walls are located by temporary 

dimensions when a door, window, or 
masonry fireplace in that wall is selected. 
• Select Locate Wall Surface to locate the 

wall’s surfaces, or Locate Wall Dimen-
sion Layer to locate the wall’s dimension 
layer. 

• Select Locate Primary Wall Side to 
always locate the wall along the exterior 
side.

• Select Automatic to locate the wall’s 
exterior by clicking on the wall opening 
near its exterior side, or locate the wall’s 
interior by clicking on the wall opening 
near its interior side. 

1

Note: Temporary Dimension Defaults do not
affect the temporary wall length dimensions
that displays when a wall is selected. See
“Measuring Walls” on page 284.

2
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Check Locate Interior Wall Centers 
to locate interior walls at their centers 

instead of their surfaces. When checked, this 
option overrides the other settings in this 
dialog for interior walls.

CAD Options - Specify how CAD 
objects inside a selected CAD object 

are located by temporary dimensions.
• Select Ignore Objects Inside for tempo-

rary dimensions to ignore any other 
objects inside a selected CAD object. 

• Select Locate First Objects Inside to 
locate the first edge of another CAD 
object drawn inside a selected CAD 
object. 

The Manually Drawn Dimension Tools
Select CAD> Dimensions to access 
the Dimension Tools. Manually drawn 

dimensions are created by clicking and 
dragging like other line-based objects and 
can be drawn in floor plan view, cross 
section/elevation views, CAD Details, and 
on layout pages. 

With the exception of Angular 
Dimensions , dimension lines only locate 
objects that are parallel or nearly parallel to 

one another and should be drawn orthogonal, 
or at right angles, to the objects being 
located. 

Dimension lines locate objects using Object 
Snaps , although they do not need to be 
enabled in order to draw dimensions. See 
“Object Snaps” on page 162. Bear in mind, 
though, that Object Snaps must be enabled in 
order to:

Clicking on the exterior side of a window Clicking on the interior side of a window

  produces temporary dimensions 
that locate the wall’s exterior side

  produces temporary dimensions 
that locate the wall’s interior side

3

4

Ignore Objects Inside Locate First Objects Inside
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• Locate parallel objects drawn at angles 
other than Allowed Angles. 

• Locate more than one object drawn in the 
same space, such as a CAD line drawn 
over a wall. 

The zoom factor of the current view affects 
whether objects drawn close together are 
dimensioned or not. If you try to dimension 
an array of objects but the dimension line 
locates only the first and last objects along its 

path, Zoom  in on the objects and try 
again. Similarly, if you want to dimension 
between two objects but the dimension 
locates unwanted objects between them, 

Zoom  out. See “Zoom Tools” on page 
881.

Once created, both manually drawn and 
automatically generated dimension lines can 
be selected and edited.  See “Editing 
Dimension Lines” on page 1014. 

Manual Dimensions
To display the distance between two 
objects, select CAD> Dimensions> 

Manual Dimension and drag a dimension 
line near or through the objects. 

Manual Dimensions locate objects as 
specified on the LOCATE OBJECTS panel and 
lying within the Reach distance specified in 
the Dimension Defaults dialog. See 
“Dimension Defaults Dialog” on page 987.

End-to-End Dimensions
Use the End-to-End Dimension tool 
to dimension between any two defined 

objects in floor plan view, cross section/

elevation views, CAD Details and on layout 
pages. 

Select CAD> Dimensions> End-to-End 
Dimension , then click and drag the 
dimension from the first object to the second 
object. The dimension line snaps to each 
object, ignoring any other objects located 
between either end.

End-to-End Dimensions locate objects as 
specified on the LOCATE OBJECTS panel and 
lying within the Reach distance specified in 
the Dimension Defaults dialog. 

Angular Dimensions
The Angular Dimension tool 
measures the angle between any two 

straight edges, including lines, walls, the 
sides of boxes, the straight sides of polylines, 
cabinets, and soffits. Any straight line or side 
within a CAD block can be dimensioned, as 
well. Edges nested up to four levels deep 
within a CAD block can be dimensioned.

To create an angular dimension, click on the 
first edge to be dimensioned, then drag an arc 
and release on the second edge. 

As with other dimension lines, Angular 
Dimensions adjust if one of the dimensioned 
objects is moved. Angular Dimensions can 
also be selected and moved using its edit 
handle. As it is moved, an Angular 
Dimension maintains the location of its arc 
center. 

Like other dimension lines, an Angular 
Dimension can be included in a CAD block. 
When the block is exploded, the Angular 
Dimension may become invalid and 
disappear when edited or changed. If this 
occurs, it can be redrawn.



The Manually Drawn Dimension Tools

 1007

Interior Dimensions
Draw Interior Dimension lines 
parallel to walls in floor plan view to 

create interior dimensions. 

The Interior Dimension  tool locates 
interior wall surfaces only. It does not 
dimension between layer surfaces in the 
same wall, and it does not locate walls unless 
it actually intersects them. 

Interior Dimensions  locate either wall 
surfaces or the Main Layer, depending on the 
settings in the LOCATE OBJECTS panel of the 
Dimension Defaults dialog. See “Locate 
Objects Panel” on page 992.

Point to Point Dimensions
The Point to Point Dimension tool 
places Point Markers at the start end 

and points of a dimension line as it is drawn 
and dimensions between them. See 
“Markers” on page 1058.

Point to Point Dimensions can be drawn in 
either of two ways:

• When the Default  edit behavior is 
active, a Point to Point Dimension places 
Point Markers at its start and end points, 
which it locates. Any objects along the 
dimension line’s length are ignored. See 
“Point Markers” on page 1078.

• When the Alternate  edit behavior is 
active, a Point to Point Dimension locates 
objects along its length as well as objects 
or Point Markers at its start and end. See 
“Edit Behaviors” on page 178.

Point Markers can be selected and edited. 
See “Editing Markers” on page 1061.

If the objects or point markers located by a 

Point to Point Dimension  line are 
moved, the dimension updates to reflect the 
change. 

Objects and Point Markers located by a 

Point to Point Dimension  line can be 
accurately relocated by specifying new 
dimension values. See “Moving Objects 
Using Dimensions” on page 1019. 

Baseline Dimensions
The Baseline Dimension tool creates 
a series of dimension lines that all 

share the same origin instead of continuing 
from each previous location. Baseline 
Dimensions are independent and can be 
edited separately. This tool is not available in 
layout files. 

In floor plan view, a cross section/elevation 
view or a CAD Detail, select CAD> 
Dimensions> Baseline Dimension , click 
near an object and drag a dimension line near 
or through the objects requiring dimensions. 

The spacing between lines is the default Line 
Separation value. See “Setup Panel” on 
page 988.
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Running Dimensions
The Running Dimension tool is 
similar to the Baseline Dimension tool 

in that it produces multiple measurements 
from a single point of origin. It is different, 
though, in that these measurements display 
on the same dimension line rather than on 
multiple lines. The start point of a Running 
Dimension line is marked by a circle. The 
circle’s size is the same as the dimension 
line’s Arrow Size.

Centerline Dimensions
The Centerline Dimension tool is 
available in floor plan and cross 

section/elevation views. It allows you to 
locate the centers of walls, wall openings, 
cabinets, fixtures, appliances, electrical 
objects, CAD blocks, and CAD arc centers 
using special centerline extension lines. 
Centerline extensions can be distinguished 
by a dashed line style and a  symbol. 

Both free-standing fixtures and appliances as 
well as those placed into cabinets can be 
located by Centerline Dimensions.

Cabinet, fixture and appliance, furniture, and 
wall opening centers are only located as a 
dimension line is drawn when Centers is 
selected for these object types. See “Locate 
Objects Panel” on page 992.

The centers of a variety of other objects - 
including stairs, footings, electrical, and 
CAD objects - can also be located with a 
Centerline by adding an extension at the 
object midpoint. Electrical and CAD objects 
are only located when these options are 
selected  in the Dimension Defaults dialog.  

Centerline Dimensions can also locate the 
edges of other types of architectural objects, 
as well as CAD objects, and will locate walls 
as specified on the LOCATE OBJECTS panel of 
the Dimension Defaults dialog. 

You can also specify any extension line as a 
Centerline in the Dimension Line 
Specification dialog. See “Extensions/
Markers Panel” on page 1023.

Temporary Dimensions
Temporary Dimensions display when 
an object is selected and show the 

distance between the object’s selected edge 
and other objects. Select View> Temporary 
Dimensions to turn on or off the display of 
temporary dimensions. This toggle affects all 
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views and is saved between launches of 
Chief Architect.

As with other dimension lines, Temporary 
Dimensions only locate objects that are 
parallel or nearly parallel to one another. 
They will also locate the endpoints of CAD 
lines and the corners of objects located past 
the end of the selected edge, within 4 feet 
(1200 mm) of the point where you click to 
select the object. 

A temporary dimension will not display 
when an object is selected if a dimension line 
is already present that shows the same 
information. 

You can control how temporary dimensions 
locate objects in the Temporary Dimension 
Defaults dialog. See “Temporary Dimension 
Defaults Dialog” on page 1003.

Tape Measure
Use the Tape Measure tool to draw a 
temporary dimension line between 

any two points in the drawing area. The tool 
will place temporary markers at the start and 
end points of the dimension line. These 
points and the line both disappear when you 
release the mouse button. If Object Snaps 

 are enabled and an object is located by 
the temporary line, you can snap to it.

The Automatic Dimension Tools
The Automatic Dimension Tools 
allow you to generate dimensions in 

floor plan and cross section elevation views 
for specific purposes. 

If you edit an Auto Dimension line, it will 
be marked as edited, so if Auto Dimensions 
are later regenerated, your changes will not 
be lost. If an Auto Dimension line has been 
edited, the Default checkbox will be 
unchecked on the LAYER panel of its 
specification dialog. See “Layer Panel” on 
page 1026.

Each of the Automatic Dimension  tools 
has its own defaults dialog so that you can 
customize the functionality of each 
independent of the others. See “Auto 
Dimension Defaults Dialogs” on page 998 
and “Auto Elevation Dimension Defaults” on 
page 999.

Auto Exterior Dimensions
The Auto Exterior Dimensions tool 
generates dimensions around a plan’s 

exterior in floor plan view. The dimension 
lines locate walls and openings as specified 
in the Auto Exterior Dimension Defaults 
dialog. 

There are a maximum of three rows of 
automatically generated dimensions per 
exterior wall direction. The innermost 
dimension line locates exterior walls, interior 
walls, and all openings in exterior walls. The 
second dimension line locates exterior and 

Auto Exterior Dimensions do not gener-
ate properly if there is a gap in the exte-

rior walls. If automatic dimensions do not
generate, try Build> Wall> Fix Wall Connec-
tions. See “Fix Wall Connections” on page
280. 
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interior walls. The outermost dimension line 
is the overall exterior dimension. 

Auto Interior Dimensions
The Auto Interior Dimensions tool 
can be used in floor plan view in 

either of two ways: 
• Select one or more rooms and click the 

Auto Interior Dimensions  edit tool 
to generate interior dimensions that mea-
sure each wall defining the selected 
room(s). 

• Select CAD> Automatic Dimensions> 
Auto Interior Dimensions  to gener-
ate a set of interior dimensions in every 
room on the current floor. 

Auto Interior Dimensions  lines are 
generated inside of the rooms they measure 
and locate walls, openings, and other objects 
as specified in the Auto Interior Dimension 
Defaults dialog. 

Auto Interior Dimensions  do not 
recognize the No Locate setting for walls. If 
a wall is specified as No Locate, Auto 
Interior Dimensions will locate it anyway. 
See “No Locate” on page 285. 

NKBA® Auto Dimensions
The NKBA® Auto Dimensions tool 
can be used to measure Kitchen, Bath 

and Master Bath rooms in floor plan view in 
either of two ways: 
• Select CAD> Automatic Dimensions> 

NKBA® Auto Dimensions  to gener-
ate interior dimensions measuring each 

wall defining rooms specified as Kitchen 
and Bath types on the current floor. 

• Select one or more Kitchen and/or Bath 
rooms and click the NKBA® Auto 
Dimensions  edit tool to generate 
interior dimensions that measure each 
wall defining the selected room(s). 

NKBA® Auto Dimensions  only 
measure the walls defining Kitchen and Bath 
rooms and are generated outside of they 
measure. See “Room Types” on page 335. 

NKBA® Auto Dimensions  locate walls 
and openings in accordance with NKBA® 
standards as specified in the NKBA® Auto 
Dimension Defaults dialog. See “NKBA® 
Kitchen and Bathroom Guidelines” on page 
1309. 

NKBA® Auto Dimensions  do not 
recognize the No Locate setting for walls. If 
a wall defining a Kitchen or Bath is specified 
as No Locate, NKBA® Auto Dimensions 
will locate it anyway. 

Auto Elevation Dimensions
The Auto Elevation Dimensions tool 
generates dimensions that locate walls 

and other objects in cross section/elevation 
views, as specified in the Auto Elevation 
Dimension Defaults dialog. 

NKBA® Auto Elevation 
Dimensions

The NKBA® Auto Dimensions tool 
generates dimensions that locate walls 

and other objects in cross section/elevation 
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views in accordance with NKBA® standards, 
as specified in the NKBA® Auto Elevation 
Dimension Defaults dialog. 

Auto Story Pole Dimensions
The Auto Story Pole Dimensions 
tool generates Elevation Markers and 

dimensions that locate walls and other 

objects in cross section/elevation views, as 
specified in the Auto Story Pole Dimension 
Defaults dialog. 

Displaying Dimension Lines
The display of dimension lines is 
controlled in the Layer Display 

Options dialog. See “Displaying Objects” on 
page 144. 

You can customize the display of dimension 
lines for different purposes. See “Annotation 
Sets” on page 80. 

Dimension lines created by any of the 
dimension tools share the same components.
• Dimension Lines run parallel with the 

distance being measured.
• Extension Lines are perpendicular to 

dimension lines, indicating what they 
locate. If a dimension line locates more 
than two objects, extension lines divide 
the dimension line into segments. 

• Arrowheads display at the intersections 
of dimension and extension lines.

• Dimension Labels display at the mid-
point of dimension line segments and 
indicate the distance that each segment 
measures.

If a manual dimension line is on a layer that 
is turned off and you select an object located 
by that dimension line, it will display for 
reference using the Selection Line color 
specified in the Preferences dialog. See 
“Colors Panel” on page 94. This will happen 

only if Temporary Dimensions  are 
turned on. See “Temporary Dimensions” on 
page 1008.

Extension Lines
If a dimension line is offset from the objects 
it locates, extension lines help clarify exactly 
what is being located. Extension lines are 
numbered: when a dimension line is selected, 
an Extension Line Number displays at the 
end of each extension line. 

Note: Only one set of automatic elevation
dimensions created by any of the Auto
Dimension tools can exist in a given cross
section/elevation view at a time. If you want
to have more than one, mark them as edited.
See “Editing Dimension Lines” on page 1014.

Dimension 
Labels

Extension Line Numbers

Arrowheads
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You can specify the default length of 
extension lines in the Dimension Defaults 
dialog. See “Extensions Panel” on page 996.

Once drawn, the appearance of extension 
lines can be edited. See “Editing Extension 
Lines” on page 1016.

Any extension line can be specified as a 
Centerline that displays the  symbol. See 
“Centerline Dimensions” on page 1008.

Dimension Labels
Manually drawn, automatic, and temporary 
dimension labels use the Text Style specified 
in the Dimension Defaults dialog. Unlike 
many objects that use Text Styles, by default 
dimensions use a Text Style specified in the 
defaults dialog rather than the Text Style 
assigned to their layer. See “Text Style 
Panel” on page 998. 

By default, dimension labels have a solid fill 
that is the same as the Background Color 
set in the Preferences dialog. You can 
instead specify that labels use a Text Style 
that has a transparent or other fill. 

You can also specify the minimum size of 
dimension numbers displaying on screen in 
the Preferences dialog. See “Appearance 
Panel” on page 92.

Labels can both a primary and secondary 
format and can be centered on dimension 

lines or located either above or below them. 
See “Primary Format Panel” on page 989.

Dimension labels have their own edit handle 
and can be moved when a dimension line is 
selected.

Dimension Arrowheads
You can specify the style, color and size of  
dimension arrows in the Dimension 
Defaults and Dimension Line Specification 
dialogs. See “Arrow Panel” on page 1088. 

The arrow at the end of a dimension line will 
not display if it is close enough to to another 
dimension arrow that the two will overlap. A 
typical example of this is where two sections 
of an Interior Dimension locate two sides of 
an interior wall. 

Elevation Markers

The Auto Story Pole Dimensions  tool 
creates a story pole with dimension strings 
automatically. In addition, elevation markers 
can be added to any vertically-oriented 
dimension line in a cross section/elevation 
view. 

To add an elevation marker

1. Select an eligible dimension line and 
note the number of the extension line 
that you would like to add a marker to. 
See “Extension Lines” on page 1011. 

2. Click the Open Object  edit button. 
3. On the EXTENSIONS/MARKERS panel of 

the Dimension Line Specification dia-
log, select the number you noted in Step 
1 from the Selected Extension drop-
down list.

Like other text, dimension labels are
subject to scaling. For example, A font

size of 6” prints a 1/8” tall number at 1/4” = 1’
scale. A font size of 125 mm prints a 3 mm
tall number at 1 m = 50 m scale. See “Printing
Text and Dimensions” on page 1222.
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4. Check the box beside Draw Elevation 
Marker.

5. Type the desired Elevation Marker 
Text then click OK. 

The resulting marker will display your text 
above the line and the height above grade 
below the line. In addition to the height 
above grade, you can add Additional Text 
below the line. See “Segments Panel” on 
page 1025.

By default, grade level is set at the same 
height as the default subfloor for Floor 1; 

however, this can be changed in the 
Dimension Defaults, Auto Elevation 
Dimension Defaults, and Auto Story Pole 
Dimension Defaults dialogs. See “Locate 
Elevations Panel” on page 1002.

The elevation markers associated with 
dimension lines use the size, color, and style 
settings of the Saved Marker Defaults 
specified in the Dimension Line 
Specification dialog. See “Extensions/
Markers Panel” on page 1023. 

Selecting Dimension Lines
Before a manually-drawn or automatic 
dimension line can be edited, it must be 
selected. To select a dimension or a group of 
dimensions, click on it when the Select 
Objects  or Manual Dimension  tool 
is active.

The edit handles that are available when a 
dimension line is selected depend on where 
you clicked to select it: 
• Click on the dimension line to display a 

full set of dimension edit handles. See 
“Editing Dimension Lines” on page 
1014.

• Click on an extension line to display 
resize edit handles only on the ends of the 
dimension line’s extensions. See “Editing 
Extension Lines” on page 1016. 

If you select an extension line by mis-
take, press the Esc key to display the

full set of dimension line edit handles. 



1014

Chief Architect X8 Reference Manual

Editing Dimension Lines
With the exception of Temporary 

Dimensions , dimension lines can be 
selected and edited using the mouse, the edit 
toolbar buttons, and the Dimension Line 
Specification dialog. See “Dimension Line 
Specification Dialog” on page 1021.

If an Auto Dimension line is edited, it will no 
longer be considered an automatic dimension 
line and will not be deleted and replaced the 

next time the Auto Dimensions  tool is 
used. An automatic dimension line that has 
been edited can be identified as such in its 
specification dialog: on the LABEL panel, the 
Default checkbox will be unchecked. See 
“Layer Panel” on page 154.

Using the Mouse
When a dimension line is selected, its edit 
handles can be seen. There are four types of 
dimension line edit handles. More than one 
of some types display, depending on how 
many extension lines are present.

• The Extension Line handles mark the 
location being dimensioned and are used 
to move or delete extension lines. See 
“Moving Extension Lines” on page 1016.

• The Add Extension Line handle displays 
to the side of the Move handle and is used 
to add extension lines to the dimension 
line. Dimension lines do not extend 
unless an object can be located. See 
“Adding Extension Lines” on page 1016.

• The small, square Move Dimension 
Label handle is located at the center of 
the selected label. Use this handle to 
move the dimension number for each 
dimension line section. The pointer 
changes to a  four-headed arrow  when 
moved over this handle.

• The Move handle is located where you 
clicked to select the dimension line and is 
used to move the entire dimension line, 
including any subsections, perpendicular 
to itself. Extension lines are resized as 
appropriate. The pointer changes to a 
two-headed arrow  when moved over 
this handle.

• The Rotate handle is located one plan 
foot past the end of the dimension line 
and is used to rotate the dimension line. 

Using the Edit Tools
Dimension lines can be repositioned, copied, 
and deleted using the edit toolbar buttons just 

Rotate

Extension Line

Extension Line

Move Dimension 
Label

Move

Add Extension 
Line

Note: A selected dimension lines cannot be
moved if Proximity Fixed is checked in the
Dimension Line Specification dialog. See
“Extensions/Markers Panel” on page 1023.
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like other objects in the program can. See 
“The Edit Toolbar” on page 37. 

Click the Edit Dimension Ends  edit 
button to edit the dimension line using edit 
handles similar to those on line based 
objects. See “Editing Line Based Objects” on 
page 187.

Edit Dimension Ends  is useful for 
locating a point on an object that it might not 
locate otherwise, such as the corner of a 
polyline.

Click the Edit Extensions  edit button to 
edit the lengths of the selected dimension’s 
extension lines. See “Editing Extension 
Lines” on page 1016.

Dimension Number Size
The initial size of dimension numbers is 
specified in the Dimension Defaults dialog. 
See “Dimension Defaults Dialog” on page 
987. 

You can specify number height for individual 
dimension lines in the Dimension Line 
Specification dialog. See “Dimension 
Panel” on page 1021.

As with text and other objects, dimension 
number size is subject to scaling when sent to 
layout or printed. See “Printing Text and 
Dimensions” on page 1222.

Copying and Pasting 
Dimension Lines

Dimension lines can be copied and pasted 
into any view type that supports dimensions. 
If a dimension line is copied independent of 

the objects it originally locates, the pasted 
dimension line will locate point markers.

Dimension lines can also be copied and 
pasted from one plan or layout file to 
another. Bear in mind that dimension lines 
use dynamic defaults. If the destination file 
has a Saved Manual Dimension Default with 
the same name as that used by the dimension 
line being copied, the pasted dimension will 
refer to it. If no such saved default exists in 
the destination file, the pasted dimension will 
become associated with the currentlly active 
Saved Manual Dimension Default. 

Deleting Dimension Lines
There are several ways to delete dimension 
lines. 

You can select any manual or automatic 
dimension line or group of dimension lines, 
then press the Delete key or click the 

Delete  edit button. See “Deleting 
Objects” on page 255.

The Delete Objects dialog allows you to 
delete all manually drawn and/or automatic 
dimension lines at once. See “Delete Objects 
Dialog” on page 255.

Individual dimension line segments located 
between extension lines can also be deleted. 
If a segment is located between two other 
segments along the same dimension line, that 
dimension will be broken in two.

To delete a portion of a dimension line

1. Select any Dimension Tool aside from 
Angular or Auto Exterior Dimensions.

2. Manually draw a dimension line over 
the segment that you wish to remove, 
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dragging from extension line to exten-
sion line.

Editing Extension Lines
Extension lines can be added, edited, and 
deleted using the mouse. Extension lines are 
also affected by settings in the Dimension 
Line Specification dialog. See “Extensions/
Markers Panel” on page 1023.

Adding Extension Lines

To add an extension line

1. Select the dimension line.
2. Click the diamond-shaped Add Exten-

sion Line edit handle which displays 
near the Move edit handle. The pointer 
changes to a two-headed arrow .

3. Drag the handle to the object that you 
want to locate with a new extension han-
dle. This example adds an extension line 
to the window edge. 

4. Release the mouse button to add an 
extension line.

Moving Extension Lines
Extension lines can be moved to locate the 
centers, sides, or surfaces of most objects. In 
this example an extension line is moved from 
the windows edge to the center.

To move an extension line

1. Select the dimension line it is connected 
to, not the extension line itself.

2. Click the Extension Line edit handle. 
The pointer changes to a two-headed 
arrow .

3. Drag the handle to a new location. The 
extension line snaps to possible marks as 
the handle is moved.
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4. Release the mouse button at the new 
location.

Resizing Extension Lines
You can resize extension lines in the 
Dimension Line Specification dialog or 
using their edit handles. See “Extensions 
Panel” on page 996. 

To resize an extension line

1. Click on the extension line or select the 
dimension line and click the Edit 
Extensions  edit button to display 
two handles along the extension line. 

2. Click either handle, turning the pointer 
into a two-headed arrow .

3. Extend or contract the extension line and 
release the mouse.

Using Proximity Fixed
The Proximity Fixed option allows you to 
specify a fixed length for one extension line 
that will not change if the object the 
extension line locates is moved. 

To use Proximity Fixed

1. Select a dimension line that locates mul-
tiple independent objects and note the 
Extension Number of the extension line 
that you would like to have a fixed 
length. 

2. Open the Dimension Line 
Specification dialog and go to the 
EXTENSIONS panel. See “Extensions/
Markers Panel” on page 1023.

•  Select the Extension Number that you  
noted in step 1 from the Selected 
Extension drop-down list. 

•  Check Proximity Fixed.
•  Specify the desired Distance to 

Marked Object, which is the distance 
from the selected dimension line to the 
object that the Selected Extension 
locates. This distance includes the Gap 
From Marked Object. 

•  Click OK.

To see how Proximity Fixed works, select the 
object that the extension line with Proximity 
Fixed specified and move it.  Notice that the 
dimension line moves in response and that all 
extension lines’ lengths adjust except for the 
one with Proximity Fixed. 

Deleting Extension Lines
When an extension line is deleted, the 
remaining dimensions update. If a dimension 

Not all library symbols can be located
by a dimension line as it is drawn. Once

a dimension is drawn, however, you can
move or add an extension line to locate the
library object.
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line has only two extension lines, they cannot 
be deleted.

To remove an extension line

1. Select the dimension line it is connected 
to, not the extension line itself.

2. Click the Extension Line edit handle. 

3. Drag it perpendicular to the direction of 
the arrows, away from any dimension-
able object, and release the button when 
the extension line disappears.

Add Additional Text
Text can be added to any manual or 
automatic dimension line using the 

Add Additional Text edit tool. 

To add text to a dimension label

1. Select a dimension line that you would 
like to add text to.

2. Click the Add Additional Text  edit 
button.

3. Click on the segment of the dimension 
line with the label you wish to add text 
to.

4. In the Additonal Text dialog:

•  Type any Leading Text that you want 
to display before the dimension value

•  Type any Trailing Text that you want 
to display after the dimension value

5. When you click OK, the segment you 
selected will display the added text.

Additional Text can also be added and edited 
in the Dimension Line Specification dialog. 
See “Segments Panel” on page 1025.
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If a dimension segment has an elevation 
marker associated with it, any added text will 
also be added to the marker’s bottom line of 
text. See “Marker Format Panel” on page 
1023.

Moving Objects Using Dimensions
Most objects can be moved by changing an 
automatic, manual, or temporary dimension 
value that locates it. This technique can be 
applied in nearly any situation where 
dimensions are present, including angular 
dimensions. See “Moving Objects” on page 
220.

In addition, some objects can be resized 
using dimensions. See “Resizing Objects” on 
page 229.

Your pointer indicates which dimensions can 
be used to relocate the selected object by 
changing to a pointing hand icon. 

Another way to tell is to select an object and 
drag it in the desired direction. As you drag, 
note which dimensions update. These 
dimensions are the dimensions that can be 
used to move that object. 

To move an object using dimensions

1. Select the object and click on a dimen-
sion line that locates it. An inline text 
field opens at the location where you 
clicked. 

•  The actual distance displays in the text 
field using the default primary format. 
See “Primary Format Panel” on page 
989. 

•  If the dimension is locating two differ-
ent objects and the selected object is 
polyline-based, the Move Edge and 
Move Entire Object buttons display to 
the right of the text field. 

•  If the dimension describes a selected 
wall’s length, additional buttons dis-
play to the right. See “Using Dimen-
sions” on page 286.

2. Click the Move button of your choice. 
3. Enter a new value in text field. The unit 

of measurement is set in the Number 
Style/Angle Style dialog. 

•  To use a different unit, include its indi-
cator after the value. See “Dialog 
Number/Angle Style Dialog” on page 
127.

Note: Dimension lines with text added are not
supported when exported to .dxf/.dwg. When
exported, they are converted to text and CAD
lines. The same occurs when CAD Detail
from View is used. See “CAD Detail from
View” on page 1118. 

Move Entire Object

Move Edge (selected)

Move Both Ends

Move Start        Move End
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•  To move the selected object past a sec-
ond object, to its opposite side, enter a 
negative value. 

•  Basic math operations can also be per-
formed in the inline text box, just as 
they can in dialogs. See “Math 
Operations in Dialogs” on page 40.

4. The selected object moves or resizes 
when you press the Enter key or click 
outside of the text field. 

5. If Bumping/Pushing  is enabled, the 
object being moved will bump into any 
objects in its move path and not move 
the entire distance. Hold down the Ctrl 
key when you press Enter to override 
this move restriction. See “Bumping/
Pushing” on page 221. 

A variety of polyline- and box-based objects 
can also be resized using dimensions.

To resize an object using dimensions

1. Select the object along the edge that you 
would like to move. See “Selected 
Edge” on page 184.

2. Click on a dimension line that indicates 
its distance from the object’s opposite 
side. 

3. In the inline text field, enter a value. 
4. Click Move edge to move the selected 

edge only. 
5. The selected edge moves, resizing the 

object, when you press the Enter key. 

Resizing a House Using 
Exterior Dimensions

When resizing a house using dimensions, it 
is important to work your way around the 
house in one direction. Relocate one wall at a 
time in succession so that you do not redefine 
the same dimension more than once. 

For more information, see “Measuring 
Walls” on page 284. 

Using Angular Dimensions
Angular Dimensions are useful for 
adjusting the angles of polyline-based 

objects and walls.

To change an angular dimension

1. Draw an CAD> Dimensions> Angular 
Dimension , then click and drag to 
draw an arc within the angle you wish to 
measure.

2. Select the edge that you want to move.
3. Click the dimension value to open the 

Set Angular Dimension dialog.

The Set Angular Dimension dialog indi-
cates the Previous Value in degrees, minutes 
and seconds. 

You can cancel a move or resize opera-
tion using dimensions at any time by
pressing the Esc key.
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4. Enter a value in the New Value field.
5. Specify what you want to rotate:

•  Select Rotate edge to move the 
selected edge when you click OK, or 

•  Select Rotate entire polyline to rotate 
the entire object about the corner 
formed by the edges that the Angular 
Dimension locates, maintaining the 
previous value of that angle.

6. Click OK to apply the change.

Dimension Line Specification Dialog
To open the Dimension Line 
Specification dialog, double-click a 

dimension line using the Select Objects  

or Manual Dimension  tool, or select a 

dimension line or group of dimension lines 
and click the Open Object edit button.

The settings in this dialog are dynamic 
defaults associated with a particular Saved 
Manual Dimension Default. See “Dimension 
Defaults Dialog” on page 987. 

Dimension Panel

Inherits Default Properties From - 
The name of the Saved Dimension 

Default that the selected dimension line gets 
its default attributes from displays here. 
• If multiple dimension lines are selected, 

“No Change” may display here.
• You can select a different Saved Dimen-

sion Default from the drop down list.

• If a dimension line inherits attributes 
from a Saved Dimension Default, that 
default cannot be deleted. See “Saved 
Defaults Dialog” on page 78. 

Options - Specify the size and display 
of wall widths attributes for the selected 

dimension line. The minimum on-screen size 

1

2
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can be set in the Preferences dialog. See 
“Appearance Panel” on page 92.
• Specify the Number Height for the 

selected dimension. Type “d” in the box 
to reset the number size to the default. 

• Check Suppress Wall Widths to sup-
press those portions of the dimension line 
that measure between two surfaces of the 
same wall. Both sides of a wall may still 
be located, but its width will not display.

This option is checked by default for 
most manually drawn dimensions, but is 
unchecked for Interior Dimensions.

Specify the use and appearance of 
Rounded Value Indicators, which can 

display when the degree of accuracy in use is 
not sufficient to describe a dimension’s true 
value. 
• Check Use Default to use the default 

indicator(s). Uncheck this box to make 
the options that follow active.

• Check + or - After Number to indicate 
that the actual dimension value is higher 
or lower than the value shown.

• Check ~ Before Number to indicate 
dimension values that are not accurate 
with the ~ symbol.

Dimension Panel for Angular Dimensions

• Define a Number Height for the selected 
dimension. Type “D” in the box to reset 
the number size to the default.

• Select an Angle Style radio button to 
specify the how the selected Angular 
Dimension’s  angle value displays. See 
“Dialog Number/Angle Style Dialog” on 
page 127.

Dimension Number Height is subject to
scaling. For example, A Number Height

of 6” prints a 1/8” tall number at 1/4” = 1’
scale. A Number Height of 125 mm prints a 3
mm tall number at 1 m = 50 m scale. 

3
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Primary Format Panel
To enable the settings on the PRIMARY FOR-
MAT panel of the Dimension Line 
Specification dialog, uncheck Use Default 
Formatting.

The settings that follow are the same as those 
on the same panel of the Dimension 
Defaults dialog, but apply only to the 
selected dimension line(s). See “Primary 
Format Panel” on page 989. Not available for 
Angular Dimensions.

Secondary Format Panel
To enable the settings on the SECONDARY 
FORMAT panel of the Dimension Line 
Specification dialog, uncheck Use Default 
Formatting and then check Include Second 
Format.

The settings that follow are the same as those 
on the same panel of the Dimension 
Defaults dialog, but apply only to the 
selected dimension line(s). See “Secondary 
Format Panel” on page 991. Not available for 
Angular Dimensions.

Marker Format Panel
The settings on the MARKER FORMAT panel 
control the format of the elevation value 
stated in elevation markers’ bottom line of 
text on a Story Pole and are similar to those 
on the PRIMARY FORMAT panel of the 
Dimension Defaults dialog. See “Primary 
Format Panel” on page 989.

This panel is only available if the selected 
dimension line is drawn vertically in a cross 
section/elevation view. See “Detailing Cross 
Section/Elevation Views” on page 905. 

• Check Use Default Formatting to use 
the Primary Format settings of the 
currently active Dimension Defaults as 
the Marker Format. 

Leading and trailing text can be added before 
and after the elevation value in an elevation 
marker’s bottom line of text on the SEG-
MENTS panel of the Dimension Line 
Specification dialog. See “Segments Panel” 
on page 1025. 

Extensions/Markers Panel
The EXTENSIONS/MARKERS panel is not 
available for dimensions selected as a group 

or for Angular Dimensions .

Opening this panel will turn off Version 8
Compatible Extensions if it is enabled in

the Dimension Defaults dialog. See “Exten-
sions Panel” on page 996.
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Selected Extension - Choose an 
extension line associated with the 

currently selected dimension from the drop-
down list. The Selected Extension can then 
be edited here. 

• Uncheck Use Plan Default to enable the 
three settings that follow. Check this box 
to restore the default settings to the 
Selected Extension line. See “Dimension 
Defaults Dialog” on page 987.

The Extension Length settings are the 
same as those on the EXTENSIONS panel 

of the Dimension Defaults dialog, but apply 
to the extension lines associated with the 
selected dimension line only. See 
“Extensions Panel” on page 996.

• Click Apply to All to apply the settings 
for the Selected Extension line to all 
extension lines associated with the 
selected dimension.

Check Proximity Fixed to specify a 
fixed distance between the marked 

object and the dimension line. You can only 
fix the proximity for a single extension line.
• Distance to Marked Object - When 

Proximity Fixed is checked, you can 
specify the distance from the dimension 
line to the marked object using a positive 
value. See “Extensions Panel” on page 
996.

The Style settings provide alternatives 
to the standard extension line style. The 

selected extension line may have Mark as 
Centerline checked, or Display Elevation 
Marker, but not both.
• Check Mark as Centerline to mark the 

selected extension line with a Centerline 

When a dimension line is selected,
each extension line’s number displays

beside it.

1

2

3

4



Dimension Line Specification Dialog

 1025

symbol . Not available in the 
Dimension Defaults dialog. See “Cen-
terline Dimensions” on page 1008.

• Check Draw Elevation Marker to add 
an elevation marker to the selected exten-
sion line. Only available for vertically 
oriented dimension lines in cross section/
elevation views. See “Elevation Markers” 
on page 1012.

• Specify the Elevation Marker Text, 
which is the text that accompanies an 
Elevation Marker. This will be pre-popu-
lated if the selected extension line locates 
an elevation mark recognized by the pro-

gram. Only available when Draw Eleva-
tion Marker is selected, above. See 
“Locate Elevations Panel” on page 1002.

• Specify which Saved Marker Defaults the 
selected extension line’s Marker Inher-
its Properties From. Only available 
when Draw Elevation Marker is selected 
above, this setting determines the 
marker’s size and appearance. See “Mul-
tiple Saved Defaults” on page 77.

• Click the Define button to modify the 
selected Saved Marker Defaults. See 
“Marker Defaults” on page 1029. 

Segments Panel
Additional Text can be added to the 
dimension number of each segment of the 
selected dimension line. 

If the selected segment has an elevation 
marker associated with its extension line, the 
marker’s lower text will also receive this 

Additional Text. See “Auto Story Pole 
Dimensions” on page 1011.

Additional Text can also be added to a 
dimension line using the Add Additional 
Text  edit tool. See “Add Additional 
Text” on page 1018.

Select the Segment of the selected 
dimension line that you would like to 

modify using the settings that follow.
• Check Blank Segment to suppress the 

selected segment’s dimension label. 

Specify any required Text Added to 
Segment for the selected segment and 

elevation marker, if one is present.
• Type the Leading Text, which appears 

before the dimension value in the label. 

1 2
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• Type the Trailing Text, which appears 
after the dimension value in the label.

Layer Panel
The LAYER panel is found in the 
specification dialogs for many different 
objects. For more information, see “Layer 
Panel” on page 154. 

If the selected dimension line was 
automatically generated, the Default 

checkbox on this panel will be unchecked 
automatically if the dimension line is edited. 
See “The Automatic Dimension Tools” on 
page 1009.

Arrow Panel
For information about the settings on this 
panel, see “Arrow Panel” on page 1088.
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Chapter 33:

Text, Callouts,
and Markers

Text, callouts and markers are an ideal way 
to draw attention to special details of your 
drawings. Text can be added in floor plan 
view, in cross section/elevation views, in 
CAD Details, and to layout pages.

Text lines with arrow can be attached to text 
objects, allowing you to direct attention to 
specific plan details.

The display of text can be controlled by layer 
or set specifically for each text object.

Chapter Contents
•      Text Defaults and Preferences
•      Fonts and Alphabets
•      The Text Tools
•      Creating Text, Callouts and Markers
•      Displaying Text, Arrows, Callouts and 

Markers
•      Rich Text Specification Dialog
•      Text Specification Dialog
•      Editing Text
•      Copying and Pasting Text
•      Spell Check
•      Text Arrows
•      Callouts
•      Callout Specification Dialog
•      Editing Callouts
•      Markers
•      Marker Specification Dialog
•      Editing Markers
•      Text Styles
•      Text Macros
•      Creating User Defined Text Macros
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Text Defaults and Preferences
Text Defaults can be accessed by 
selecting Edit> Default Settings in 

any view in which text can be created. Click 
the "+" next to Text, Callouts and Markers 
to display the sub-headings. See “Default 
Settings vs Preferences” on page 74. 

The default settings for Rich Text, Text, 
Callouts, Markers, and Arrows determine 
what these objects look like when they are 
first created. Text Style Defaults determine 
the appearance of text associated with things 
like dimensions and object labels. 

Rich Text , Text , Callouts , 

Markers , and Arrows  can support 
multiple Saved Defaults. In order to open the 
defaults dialog for of these tools, you must 
first open its Saved Defaults dialog and 
choose an available saved defaults setup. See 
“Multiple Saved Defaults” on page 77. 
• When you access a defaults dialog for 

any of the Text Tools via the Default 
Settings dialog, the Saved Defaults dia-
log will open first, allowing you to select 
which Saved Default you wish to edit. 

• When you access this dialog by double-

clicking a Text Tool  button, the 
defaults dialog for the currently active 
Saved Default is opened directly. If you 
would like the Saved Defaults dialog to 
open first in this situation, you can enable 
this option in the Preferences dialog. 
See “General Panel” on page 98. 

• In either case, the name of the Saved 
Default being edited will display in the 
title bar at the top of the dialog box. 

Changes made to default settings do not alter 
existing text objects, so it is a good idea to go 
over these settings before placing text. 

Text Style Defaults
Select “Text Style” from the list in the 
Default Settings dialog and click the Edit 
button to open the Saved Text Style 

Defaults dialog. The Text Style Defaults  
button can be added to your toolbars. See “To 
add a button to a toolbar” on page 132. 

The Text Style Defaults dialog allows you to 
specify the attributes of the various Text 
Styles in use in the current file. See “Text 
Styles” on page 1061.

Rich Text Defaults

Double-click the Rich Text  or Leader 
Line  tool to open the Saved Rich Text 
Defaults dialog and edit the currently active 
Saved Default. 

The Rich Text Defaults dialog is similar to 
the Rich Text Specification dialog, but the 
name of the current Saved Default displays 
in the title bar. See “Rich Text Specification 
Dialog” on page 1034.

Leader Lines  and Text Lines with 
Arrows  use the same default layer as 
Rich Text, so by default they have the same 
color, line weight and line style. See 
“Layers” on page 143.
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Text Defaults

Double-click the Text  tool to open the 
Saved Text Defaults dialog and edit the 
currently active Saved Default. 

The Text Defaults dialog looks almost the 
same as the Text Specification dialog, but 
the name of the current Saved Default 
displays in the title bar. See “Text 
Specification Dialog” on page 1041.

Callout Defaults

Double-click the Callout  tool to open the 
Saved Callout Defaults dialog and edit the 
currently active Saved Default. 

The Callout Defaults dialog looks almost the 
same as the Callout Specification dialog, 
but the name of the current Saved Default 
displays in the title bar. See “Callout 
Specification Dialog” on page 1055.

Marker Defaults

Double-click the Marker  tool to open 
the Saved Marker Defaults dialog and edit 
the currently active Saved Default.

The Marker Defaults dialog looks almost the 
same as the Marker Specification dialog, but 
the name of the current Saved Default 
displays in the title bar. See “Marker 
Specification Dialog” on page 1059.

Arrow Defaults

Double-click the Text Line with Arrow  
tool to open the Saved Arrow Defaults and 
edit the currently active Saved Default.

The settings in the Arrow Defaults dialog 
determine the initial settings for arrows 

drawn using the Leader Line , Text Line 
with Arrow  and Line With Arrow  
tools. These settings also determine the 
initial appearance of arrows when they are 
added to CAD lines, arcs, and polylines.

The Arrow Defaults dialog looks almost the 
same as the ARROW panel of the Line 
Specification dialog, but the name of the 
current Saved Default displays in the title 
bar. See “Arrow Panel” on page 1088.

Annotation Sets
The Text Tools are among the items 
associated with Annotation Sets, which are 
groups of Saved Defaults that can be 
customized and activated for specific 
drawing tasks. See “Annotation Sets” on 
page 80.

Preferences
Specify the number of segments for 
new leader lines and whether pressing 

the Enter key creates a new line of text or 
closes the Rich Text and Text Specification 
dialogs in the Preferences dialog. See “Text 
Panel” on page 97.

Avoid typing any text in any text
Defaults dialog unless you want it to be

present in all text objects you create.
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Fonts and Alphabets
Chief Architect allows you to use any font 
found in your computer’s Fonts directory. 

For best printed results, using true-type or 
open-type fonts is recommended. 

Blueprint Fonts
Three architectural fonts: Chief Blueprint, 
City Blueprint, and Country Blueprint are 
installed in the Windows Fonts directory 
when Chief Architect is installed.

On Mac systems, these fonts are embedded 
with the Chief Architect installation but not 
installed on the system. As such, they are 
available for use in Chief Architect but not in 
other programs. 

International Alphabets

The Rich Text  tool supports unicode 
alphabets and characters. In order to use a 
unicode alphabet or characters, the 
appropriate language support must be 
installed on your computer. 

Special characters can be added to any Rich 
Text  object by: 
• Copying and pasting the character from 

another application;
• Copying and pasting the character from 

the Windows Character Map;

• Using the Mac Character Viewer;
• Typing the keystroke associated with the 

character.

See “Copying and Pasting Text” on page 
1049.

Character Size
Text, callouts, markers as well as dimension 
numbers can be sized to 1/128” accuracy 
when Inches is used as the number style 
(0.078125 mm when Decimal mm is used). 
See “Dialog Number/Angle Style Dialog” on 
page 127. 

Either of two font sizing methods may be 
used: 
• The default method specifies text size as 

the measurement from the baseline to the 
topmost part of the capital letter A. This 
method is similar to that used in most 
CAD programs. 

• Alternatively, you can use a font sizing 
method similar to most word processing 
applications, where size is based on 
information stored in the font. This infor-
mation varies from font to font and is 
responsible for apparent differences in 
font height. 

To size Rich Text  based on the size of 
the capital letter A, use CAD Style Font 
Sizing. See “Appearance Panel” on page 
1037.

To size Text , Callouts , Markers  
and dimension numbers based on font 
information, use Legacy Compatible Size.
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The sizing method used for text objects can 
be set as defaults and also specified per 
object in objects’ specification dialogs. See 
“Text Defaults and Preferences” on page 
1028.

The sizing method used for dimensions can 
only be specified in the Dimension Defaults 
dialog. See “Dimension Defaults Dialog” on 
page 987.

Missing Fonts
If you open a plan or layout file that uses a 
font that is not installed on the current 
computer, the program will give you an 
opportunity to replace it in the Replace 
Fonts dialog. 

The table lists all missing fonts and how they 
will be replaced. 
• Click on a font name in the list to select 

it. Use the Shift or Ctrl key to select mul-
tiple fonts. See “Shift and Ctrl Select” on 
page 186. 

• Select a replacement font from the 
Replace With drop-down list, or leave 
“No Change” as the selection to maintain 
the file’s association with the missing 
fonts. 

• A preview of the selected font displays 
below the Replace Width list.

If you do not plan to return the file to the 
computer where it was created, you may 
want to replace missing fonts with the fonts 
you normally use. On the other hand, if you 
do intend to return the file, you may prefer to 
not replace any missing fonts.

The Text Tools
Select CAD> Text to access the Text 
Tools. These tools are available in 

floor plan view, in cross section/elevation 
views, in CAD Details, and in layout files.

The Rich Text tool is used to create 
text objects.

The Text tool is used to create simple 
text objects with a single font and 

style format, or with Tab-delimited columns. 

It is not as flexible as the Rich Text  tool; 
however, it was the tool used to create text in 
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Chief Architect X1 and prior. See “Creating 
Text, Callouts and Markers” on page 1032.

The Text Line with Arrow tool is 
used to connect text and another 

object with an arrow. See “Text Arrows” on 
page 1051.

The Leader Line tool places either a 
Text or Rich Text object with an arrow 

attached. See “Leader Line” on page 1052.

The Callout tool is used to place 
callouts. See “Callouts” on page 1054.

The Marker tool is used to place 
markers for Level Lines, Test 

Borings and Point Markers. See “Markers” 
on page 1058.

Creating Text, Callouts and Markers
Text, callouts and markers can be created in 
floor plan view, in cross section/elevation 
views, in CAD Details, and on layout pages. 

Once created, text, callouts and markers can 
be selected and edited in a variety of ways. 
See “Editing Text” on page 1045. 

To create Rich Text

1. Select CAD> Text> Rich Text . 
2. Click and drag to draw a rectangle defin-

ing the area of the text object. 
•  The rectangle that you drag must be at 

least as tall as the default line spacing 

for a single line of text. See “Paragraph 
Options Dialog” on page 1037.

•  When you release the mouse button, a 
blank text box is created with an active 
cursor, ready for you to type.

3. Type or paste the desired text into the 
Text Field. If the program identifies any 
spelling issues, they will be underlined 
in red.

4. Use the options on the Edit Bar, which 
displays above the Text Field, to change 
the font, style and size of any portion of 

the text. See “Editing Text” on page 
1045. 

5. When you are finished, simply click out-
side of the Text Field to close it and the 

Edit Bar. The Rich Text  tool 
remains active, so you can click and 

You can convert simple Text to a Rich
Text object by clicking the Convert to

Rich Text edit button. See “Convert to Rich
Text” on page 1047. 

Text Field Edit Bar
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drag to create additional Text objects if 
you wish.

Rich Text , Callouts  and 

Markers  can also be created in the same 

manner as Text .

You can also create lines with arrows 
connecting the text that you create to items in 
the drawing. See “Text Arrows” on page 
1051. 

To create Text

1. Select CAD> Text> Text . 
2. Click where you want the upper left cor-

ner of the text to be located. The Text 

Specification dialog opens. See “Text 
Specification Dialog” on page 1041.

3. Enter text and click OK.

Up to 32,000 characters can be inserted in 

one Text  object. It is usually better to use 

several smaller Text  objects when a lot 
of text must be inserted.

Text and CAD Objects
Text can be used in combination with CAD 
objects to create legends, title blocks, and a 
wide variety of other details. See “CAD 
Objects” on page 1071 and “Layout” on page 
1235.

A selection of legends and other CAD blocks 
that use both text and CAD can be found in 
the Library Browser. See “The Library” on 
page 819.

Displaying Text, Arrows, Callouts and Markers
As with other types of objects, the display of 
Text objects is controlled in the Layer 
Display Options dialog.  By default, text 
objects are located on layers with “Text” at 
the beginning of the layer name, such as 
“Text, Callouts”. See “Layer Display 
Options Dialog” on page 149. 

Text objects can only be displayed in views 
where text can be created. 

The display attributes of each individual text 
object can be controlled independent of the 
layer it is placed on. See “Rich Text Specifi-
cation Dialog” on page 1034. 

Custom Text Layers
Text objects do not need to be shown at all 
times. For instance, electrical notes will be 
included with the electrical plan, but are not 
needed in the framing plan. You can create 
custom layers and layer sets to control the 
display of text and other objects. See “Layer 
Sets” on page 146 and “Layer Display 
Options Dialog” on page 149.

To move text to a different layer, select the 
text object or group of text objects, then click 

the Open Object  edit button to open the 
Text Specification dialog. The selected text 
object’s layer can be changed on the LINE 

Note: If you do not type anything in the Text
Field, a text object will not be created when
you click outside of it.
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STYLE panel. See “Line Style Panel” on page 
1085.

Text Arrows

If a text arrow is attached to a Text  object 
and they are on the same layer, changing the 

layer of the text will also change the layer of 
the attached text arrow. However, changing 
the layer of the text arrow will not change the 
layer of the text it is attached to. See 
“Displaying Objects” on page 144.

Rich Text Specification Dialog
The Rich Text Specification dialog 

opens if you select the Rich Text  
tool and then click once in the drawing area.

You can also open this dialog by selecting 

one or more Rich Text  objects, then 
clicking the Open Object edit button. 

When Rich Text  objects are group-
selected, the text content, zoom factor, and 
Paragraph Options cannot be changed, but 
everything else can be. 

The Rich Text Specification dialog is 
similar to the Rich Text Defaults dialog but 
affects the selected text rather than all 
subsequently created text objects. Also, the 
name of the Saved Default being edited will 
display in the title bar of the defaults dialog. 
See “Text Defaults and Preferences” on page 
1028.

Text Panel
The settings on the TEXT panel allow you to 
type the selected Rich Text object’s content 
and control many aspects of its appearance, 
including its font, size, color and style.

You can specify the appearance of the text 
before typing, and can also select and change 
the attributes of all or portions of the text 
content after it is typed. To change text that 
already exists, simply highlight it using the 

mouse and/or the Shift + arrow keys and then 
make any needed changes to its attributes. 

Note: Text objects have a different specifica-
tion dialog. See “Text Specification Dialog” on
page 1041.

Note: If you do not type anything in the text
field on this panel when creating a new
object, no object will be created when you
click OK. On the other hand, if you remove
the text from an existing object and click OK,
an empty text box will result.
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Use the options on the Edit Bar, which 
displays above the Text Entry field, to 

change the font, size, and style of the text.

The Edit bar also displays in the drawing 
area above the Text object when you click 

the Edit Text in Place  edit button. See 
“Editing Text” on page 1045. 

Select the desired options before typing to 
affect the text as it is typed, or select some or 
all of the text and then specify which options 
to apply to it.
• Select a Font from the drop-down list.
• Specify the Text Size in drawing units. 

• Click the Print Size  button to open 
the Printed Size Input dialog. See “Scal-
ing Text” on page 1047.

• Click the Color  button to specify the 
color of the selected or subsequently 
typed text. See “Color Chooser/Select 
Color Dialog” on page 875. If Layer 
Color Text is checked on the APPEAR-
ANCE panel, any custom colors specified 
here are lost. 

• Click the Bold  button to specify the 
selected text as bold.

• Click the Italic  button to specify the 
selected text as italic.

• Click the Underline  button to specify 
the selected text as underlined.

• Click the Strikethrough  button to 
specify the selected text as stricken-
through.

• Click the Uppercase  button to dis-
play the selected text in all capital letters.

• Click the Align Left , Align 
Center , or Align Right  button to 
specify the how text is aligned.

• Click the Paragraph Options  button 
to specify the selected paragraph’s align-
ment, spacing and bullets or numbering 
in the Paragraph Options dialog. 

• Click the Spell Check  button to 
check the spelling in the selected text 
object. See “Spell Check” on page 1050.

1
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• Click the Insert Macro  button to 
place a Text Macro at the location of the 
cursor. Not available when multiple text 
objects are selected. User Defined macros 
are only available when the selected Rich 
Text object points to an eligible object 
using a Leader Line or Text Line with 
Arrow. See “Text Macros” on page 1064. 

• Specify the Zoom factor of the selected 
text by typing a percentage value in the 
text field or clicking the up/down arrows. 
This setting only affects the text as it 
appears in this dialog.

Type or paste text in the Text Entry 
field. See “Copy, Cut and Paste” on 

page 1048.
• Depending on the current Preferences 

 settings, pressing the Enter key either 
forces a new line in the text box or closes 
the dialog. A carriage return can also be 
added by typing Shift + Enter or Ctrl + 
Enter. See “Text Panel” on page 97.

• Right-click in the Text Entry field to 
access a contextual menu from which you 
can select Undo, Redo, Cut, Copy, Paste, 
Spell Check and Select All. See “Contex-
tual Menus” on page 38. 

• To edit text in the entry field, click and 
drag to highlight any portion of it and 
then use the tools on the Edit Bar as 
needed.

• If the program identifies any spelling 
issues, they will be underlined in red.

Note: Some fonts cannot be drawn at certain
zoom factors. When this is the case, the
appearance of the text will not change.

2
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Paragraph Options Dialog

Specify the Alignment of the selected 
paragraph(s). See “Aligning Text” on 

page 1048.

Specify the Line Spacing of the 
selected paragraph(s). 

• Click the radio button beside Single, 1.5 
Lines, Double or User Specified.

• If you select User Specified Line 
Height, type the desired height for each 
line of text in the selected paragraph(s). 
For best results, this value should be at 
least as much as the largest character size 
used in the selected paragraph(s). 

Specify the appearance of the side 
Margins of the selected paragraph(s), 

as measured in from edges of the text box. 
Only positive Margin values can be used. 
• Specify the Indent, which is measured 

from the left side margin. A negative 
value can be used if a left Margin has 
been specified.

Specify the appearance of Bullets and 
numbering in the selected paragraph(s). 

• Select the desired bullet, numbered, or 
lettered Type from the drop-down list.

• Specify the Number Prefix, which are 
any characters that you would like to dis-
play before the selected paragraph’s num-
ber or letter. Does not affect paragraphs 
using circle or square bullets.

• Specify the Number Suffix, which are 
any characters that you would like to dis-
play after the selected paragraph’s num-
ber or letter and before its actual text. 
Does not affect paragraphs using circle or 
square bullets.

Appearance Panel

Leader Lines  and Text Lines with 
Arrows  use the same default layer as 
Rich Text, so they share the same default 

color, line weight and line style. See 
“Layers” on page 143.

1

2

3

4
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Layer Information -
 

• Check Default to place the selected 
object on the default Text layer.

• Click the drop-down list to select from all 
layers available in the plan or layout file.

• Click Define to open the Layer Display 
Options dialog and select, modify, or add 
a new layer. See “Layer Display Options 
Dialog” on page 149.

• Check Layer Color Text to apply the 
color assigned to the selected Layer to the 
text on the TEXT panel. 

Check Border to display a border 
around the selected text object and 

enable the settings that follow.
• Check Layer Color to use the line color 

assigned to the text object’s layer, or click 
the Color bar to select a different color. 
See “Color Chooser/Select Color Dialog” 
on page 875.

• Check Use Layer Line Style to use the 
line style assigned to the text object’s 
layer, or choose another style either from 

1 Note: If you change the color of some or all of
the selected object’s text, Layer Color Text
will become unchecked. If it is checked again,
the custom color(s) will be removed. 

2
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the drop-down list or by clicking the 
Library button. See “Line Styles” on 
page 1108.

• Check Use Layer Weight to use the line 
weight assigned to the text object’s layer, 
or specify a different weight. See “Line 
Weights” on page 1223.

Check Fill to display a fill color within 
selected text object(s) and enable the 

settings that follow.
• Select Custom Color then click the 

Color bar to use a fill color of your 
choosing. See “Color Chooser/Select 
Color Dialog” on page 875.

• Check Use Background Color to use 
program’s Background color as the text 
object’s fill color. See “Colors Panel” on 
page 94. 

• Check Use Layer Color to use the color 
assigned to the text object’s layer as its 
fill color.

• Use the Transparency slider bar or text 
field to control how transparent the fill 
color is. 

Specify the Top, Bottom, Left, and 
Right Margins, which are the distance 

between the text and the border of the 
selected text object(s). 

Options Panel

3

4
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Options 

• Check Add an Arrow to add a Text 
Arrow to the selected text object. See 
“Text Arrows” on page 1051.

• Check Rotate with Plan to rotate the 

selected text when Rotate Plan View  
is used. If unchecked, the selected text is 
unaffected when Rotate Plan View is 
used. See “Rotate Plan View” on page 
237. 

Rotate with Plan also affects text in 
views sent to layout if the layout box is 
rotated. See “CAD and Text in Layout” 
on page 1238. 

• Specify the Layout Page that the 
selected object(s) is located on. Only 
available in layout files, but not in the 
Rich Text Defaults dialog in layout. See 
“Layout” on page 1235. 

Specify the Origin/Angle of the 
selected text object. 

• Specify the X Position and Y Position of 
the selected object relative to the origin. 
See “3D Drafting” on page 31. 

• Specify the Angle of the selected text 
object. The default value is 0°.

Specify the Size of the selected text 
object. 

• Specify the Height of the selected text 
object(s) or check Auto Height to auto-
matically adjust the text object’s height to 
match its contents.

• Specify the Width to of the selected text 
object(s) or check Auto Width to auto-
matically adjust the text objects width to 

match its contents. When Auto Width is 
used, text extends in a single line rather 
than wrap.

• CAD Style Font Sizing measures text 
size based on the total height of the capi-
tal letter A, as most CAD programs do. 
Uncheck this to instead size text accord-
ing to information stored with the font. 

The Drawing Group options control 
how the selected object(s) display 

relative to other objects. See “Drawing 
Groups” on page 218. 
• Specify the Back Group to display the 

selected object(s) behind objects in the 
other two drawing groups. 

• Specify the Default Group to display the 
selected object(s) in front of those in the 
Back Group but behind those in the Front 
Group. 

• Specify the Front Group to display the 
selected object(s) in front of objects in 
the other two drawing groups. 

• Check Move to Front of Group to dis-
play the selected object(s) in front of 
other objects in the same drawing group. 
This is an action rather than a state and is 
not available in the Rich Text Defaults 
dialog. 

Specify the desired Bumping behaviors 
for the selected object(s). See 

“Bumping/Pushing” on page 221. 
• Check CAD Stops Move to bump the 

selected object into other CAD or CAD-
based objects as it is moved.

• Check Wall Stops Move to stop the 
selected object when it bumps into a wall. 

1

2

3

4
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Text Specification Dialog
The Text Specification dialog opens 

if you select the Text  tool and then 
click once in the drawing area. It will also 

open when you use the Leader Line  tool 
if Create Rich Text is unchecked in the 
Preferences dialog. See “Text Panel” on 
page 97. 

You can also open this dialog by selecting 

one or more Text  objects, then clicking 
the Open Object edit button. 

The Text Specification dialog is similar to 
the Text Defaults and Room Label 
Specification dialogs but affects the selected 
text object rather than all subsequently 
created text. Also, the name of the Saved 
Default being edited will display in the dia-
log box title bar. See “Text Defaults and 
Preferences” on page 1028 and “Editing 
Room Labels” on page 338.

Text Panel
The settings on the TEXT panel allow you to 
type the selected Text object’s content. Text 
cannot be added to a selected Room Label, 
however.

Note: Rich Text objects have a different spec-
ification dialog. See “Rich Text Specification
Dialog” on page 1034.

Note: If you do not type anything in the text
field on this panel when creating a new
object, no object will be created when you
click OK. On the other hand, if you remove
the text from an existing object and click OK,
an empty text box will result.
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Click Insert to choose from a list of 
special characters and text macros.  

User Defined macros are only available 
when the selected Rich Text object points to 
an eligible object using a Leader Line or Text 
Line with Arrow. See “Text Macros” on page 
1064. Not available when the selected object 
is a Room Label. See “Room Labels” on 
page 337. 
• Click Insert to choose from a list of spe-

cial characters and text macros. User 
Defined macros are only available when 
the selected text object points to an eligi-
ble object using a Leader Line or Text 
Line with Arrow. See “Text Macros” on 
page 1064. Not available when the 
selected object is a Room Label. See 
“Room Labels” on page 337. 

• Check Add an Arrow to add a Text Line 
with Arrow to the selected text object. 
See “Text Arrows” on page 1051.

• Click the Spell Check button to check 
the spelling of the text that displays in the 
Text Entry area. If Spell Check finds a 
word that may be spelled incorrectly, the 

Check Spelling dialog opens. See “Spell 
Check” on page 1050. Not available 
when multiple Text objects are selected. 

Enter text in the Text Entry field. This 
field is not available if the selected 

object is a Room Label. See “Room Labels” 
on page 337.
• Depending on the current Preferences 

 settings, pressing the Enter key either 
forces a new line in the text box or closes 
the dialog. A carriage return can also be 
added by typing Shift + Enter or Ctrl + 
Enter. See “Text Panel” on page 97.

• Text automatically wraps to a new line 
without requiring a hard return.

• Tabs can be added to the text by pressing 
the Tab key.

• If the program identifies any spelling 
issues, they will be underlined in red.

A preview of the selected text object 
displays on the right. Not available for 

Room Labels. See “Dialog Preview Panes” 
on page 41. 

1

2

3
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Attributes Panel

Tabs - Check Box/Grid to have 
gridlines separate the rows and columns 

of tabbed text. When no tabs are present, a 
simple box is drawn around the text.
• In the text field, specify the number of 

spaces from the left edge of the text box 
where each new column begins. The first 
column always starts at 0 and is not 
listed. 

• Check Display Border to turn on the dis-
play of a border polyline around the 
selected object. 

• Check Display Grid Lines to turn on the 
display of the grid formed by the speci-
fied rows and columns.

Select an Alignment option from the 
drop-down list to apply to the text.

Specify the Origin/Angle of the 
selected text object. 

• Specify the X Position and Y Position of 
the selected object relative to the origin. 
See “3D Drafting” on page 31. 

• Specify the Angle of the selected text 
object. The default value is 0°.

Specify the Size of the selected text 
object(s). 

• Specify the Height of the selected text 
object(s) or check Auto Height to auto-

1 2

3

4
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matically adjust its height to match its 
contents.

• Specify the Width to of the selected text 
object(s) or check Auto Width to auto-
matically adjust its width to match its 
contents. When Auto Width is used, text 
extends in a single line rather than wrap.

Specifying a Height and/or Width of 0 sizes 
the text box as small as the text within it 
allows without turning on the Automatic 
behavior. 

Specify the Margins to be used with 
the text. This is the distance between 

the text and the edge of the text box. 

A default Left and Right margin is applied. 
Top and Bottom margins are measured 
relative to the line height and may not extend 
to the text box completely when given a 
value of 0.

A preview of the selected text object 
displays on the right. Not available for 

Room Labels. 

Link Panel
Hyperlinks can be associated with web pages 
or files saved on your computer. If a selected 
Text object has a hyperlink specified, you 

can click the Follow Hyperlink  edit 
button to open the linked web page or file. 

Specify a Hyperlink for the selected 
Text object. Note that if no text is 

entered on the TEXT panel, a text object will 
not be created.
• Type a web page address or the pathname 

of a file on your computer in the text 
field. 

• Click the Browse button to select a file 
on your computer and add its pathname 
to the text field above. 

• Click the Test Link button to confirm 
that the address or pathname in the text 
field is associated with a web page or 
available file. 

5

6

1



Editing Text

 1045

A preview of the text entered on the 
TEXT panel displays on the right. Not 

available for Room Labels. 

To use a hyperlink
1. Select the text object.

2. Click the Follow Hyperlink  edit 
button to activate the link.

Line Style Panel
The LINE STYLE panel is found in the 
specification dialogs for many different 
objects. For more information, see “Line 
Style Panel” on page 1085.

Fill Style Panel
For information about the FILL STYLE panel, 
see “Fill Style Panel” on page 1099.

Dimension Format Panel
The DIMENSION FORMAT panel is available 
in the Room Label Defaults dialog and 
allows you to control the format of the 
portion of the room label that describes the 
room’s size. For information about these 
settings, see “Displayed Line Length Dialog” 
on page 1074.

Text Style Panel
The TEXT STYLE panel is available for a 
variety of objects in the program and control 
the appearance of the selected object’s text. 
See “Text Style Panel” on page 1063. 

Editing Text 
Once created, Rich Text  objects can be 
selected individually or as a group and edited 
using the edit handles, the edit toolbar 
buttons, and the Rich Text Specification 
dialog. See “Rich Text Specification Dialog” 
on page 1034.

Text  objects can be selected and edited 
much the way Rich Text objects can; 
however, there are a few differences which 
are described here.

Editing Text Attributes
Most text attributes, including the font, size, 
style, and the content itself, are edited in the 
Rich Text and Text Specification dialogs.

In order to edit the attributes of an existing 

Rich Text  object, you must select some 
or all of the text before making changes. See 
“Text Panel” on page 1034. 

To edit Rich Text attributes

1. Select a Rich Text  object and click 

the Open Object  edit button.
2. On the TEXT panel of the Rich Text 

Specification dialog, click and drag to 
select some or all of the text typed into 
the Text field. 

Chief Architect automatically adds the
http:// prefix for links that begin with
"www" when Test Link is clicked.

2
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3. With some or all of the text selected, 
change any of the attributes available 
along the top of the panel, including the 
font, size, color, and style.

4. As changes are made, the selected text 
updates. Only the selected text is modi-
fied.

Text  objects do not support multiple 
fonts or other attributes in the same text 
object. When you choose an attribute, it is 
applied to all characters in the text object. 

Using the Mouse

A selected Rich Text  or Text  object 
has the same edit handles as other box-based 
objects. See “Editing Box-Based Objects” on 
page 206.

As a text box’s width is made narrower or 
wider using an edit handle, its height may 
increase or decrease so that none of the text 
becomes hidden. The opposite is not true, 
however: a text box’s height cannot be 
resized smaller than the height of the rows of 
text it currently contains, plus its margins.

Depending on the active Edit Behavior , 
the text box and the characters within it may 
or may not resize together when a corner edit 
handle is dragged. See “Edit Behaviors” on 
page 178. 

• If Resize  editing is enabled, both the 
text object and the font resizes when a 
corner edit handle is dragged.

• If Default  or Concentric  editing 
is enabled, the text box resizes, but not 
the font size.

• If Fillet  editing is selecting, the cor-
ners become rounded and the font size 
does not change. See “Behaviors Panel” 
on page 113.

When text is resized using the edit han-
dles, there is a “sticky point” at the natu-

ral size of the text box. Hold down the Ctrl key
while resizing to override this behavior. 

Resize

Extend/
Contract

Rotate

Move
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Edit Text in Place
The contents and appearance of text 

objects created with the Rich Text  
tool can be edited directly in the drawing 
area using the Edit Text in Place edit tool. 

To use Edit Text in Place

1. Select a Rich Text  object and click 

the Edit Text in Place  edit button.
•  The text appears as it did when it was 

first created: inside a text field with the 
Edit Bar above. See “To create Rich 
Text” on page 1032.

2. Click inside the Text Field to type or 
select any of the existing text.

3. Use the tools on the Edit Bar to edit any 
or all of the text as needed. The tools on 
the Edit bar are the same as those on the 
TEXT panel of the Text Specification 
dialog. See “Text Panel” on page 1034.

4. When you are finished, click outside of 
the text field to close it and the Edit Bar.

Convert to Rich Text
Text objects cannot be edited to the 
same degree that Rich Text can. You 

can, however, convert a selected simple Text 
 object to Rich Text  by clicking the 

Convert to Rich Text edit button. Most 

attributes of the selected simple Text  
object are retained; however, columns 
created using the Tab key are not. See “Tab 
Spacing” on page 1049.

Using the Edit Tools

A selected Rich Text  or Text  object 
can be edited in a variety of ways using the 
buttons on the edit toolbar. See “The Edit 
Toolbar” on page 37.

Resizing Text
Both the border of a text object and the 
characters it contains can be resized.

The border of a text object can be resized 
using its edit handles or by specifying the 
Height and Width in its specification dialog. 

The default character height of Rich Text 
 and Text  objects can be specified as 

can the character height for individual 
objects, in their specification dialogs. See 
“Text Defaults and Preferences” on page 
1028.

Character height can be measured in either of 
two ways. See “Character Size” on page 
1030.

Scaling Text
As with the size of other objects, text size is 
subject to the current drawing scale specified 
in the Page Setup dialog. See “Drawing 
Sheet Setup Dialog” on page 1216. 

To determine the Height in drawing units 
that is needed to produce text of a specific 

size when printed, use the Print Size 
Calculator dialog.

To use the Print Size Calculator dialog
1. Select the text object or Text Style that 

you wish to scale and click:
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•  The Print Size  button on the TEXT 
panel of the Rich Text Specification 
dialog. See “Text Panel” on page 1034.

•  The Scale button on the TEXT panel of 
a variety of specification dialogs. See 
“Text Style Panel” on page 1063.

•  The Scale button in the Text Style 
Defaults dialog. 

2. In the Print Size Calculator dialog: 
•  Confirm the desired Printed Scale. 
•  Enter the Desired Print Size of the 

text.
•  The Text Height in View required to 

produce the Desired Print Size displays 
here for reference. 

3. Click OK to return to the previous dia-
log. The Character Height value now 
equals that of the Text Height in View.

Generally, the Printed Scale does not need 
to be changed in the Print Size Calculator 
dialog unless you intend to send the current 
view to layout at a different drawing scale. 
See “Sending Views to Layout” on page 
1240. 

Aligning Text
Text can be aligned in a number of ways. 
• The text content of a text object can be 

aligned to the left, right, center or justi-
fied in the Rich Text Specification dia-
log. See “Text Panel” on page 1034.

• The text content of a text object can be 
also be aligned by clicking the Align 

Left , Align Right , Center , 

or Justify  edit button. 
• The center points of text objects can be 

aligned with one another by assigning 
them the same X and/or Y Position. See 
“Attributes Panel” on page 1057. 

• Text objects can be aligned by bumped 
them against a CAD line or CAD based 
object such as a roof plane. See “Bump-
ing/Pushing” on page 221. 

A variety of other alignment methods are 
also available. See “Aligning Objects” on 
page 223.

Copy, Cut and Paste
Copy, Cut and Paste of text into and out of 
the text specification dialogs can be 
accomplished using keyboard hotkeys:
• Press Ctrl + X to Cut the selected text and 

save it to the system clipboard.
• Press Ctrl + C to Copy the selected text 

and copy it to the system clipboard.
• Press Ctrl + V to paste your last cut or 

copied selection in a new text object.
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For more, see “Copying and Pasting 
Objects” on page 170.

Copy, Cut and Paste use the system 
clipboard, making it possible to to transfer 
text between text objects, between Chief 
Architect files, from a plan or layout into 
another application, or vice versa. 

Tab Spacing
The Tab key functions differently in Rich 
Text  and Text  objects.

In Rich Text , the Tab key creates a 
space. CAD Style Font Sizing affects the size 
of the space created. See “Options Panel” on 
page 1039.

Tab spacing in Text  objects produces 
columns with widths that can be edited using 
edit handles.

To insert tab-spaced text
1. Highlight a block of text objects con-

taining tabs from another program or 

text from the Materials List and press 
Ctrl + C to copy them to the system clip-
board.

2. Return to the floor plan view, select the 

Text  tool, and click to place a text 
object. 

3. Press Ctrl + V to paste the copied mate-
rials into the text box, then click OK. 
The text object displays on-screen. 

4. Select the text object and note the addi-
tional lines with handles separating each 
column.

Columns automatically resize to fit the 
contained text. When a text object is selected 
you can use the edit handles that display at 
each column to adjust spacing. 

Copying and Pasting Text
The Copy, Cut and Paste commands use the 
system clipboard, making it possible to 
transfer text between text objects, between 
Chief Architect files, from a plan or layout 
into another application such as a text editor 
or spreadsheet program, or vice versa. See 
“Copying and Pasting Objects” on page 170.

All or selected portions of the Materials List 
can also be copied and pasted into a text 
object, as well as into a word processing or 
spreadsheet program. See “Materials Lists” 
on page 1283.

Cut, Copy, and Paste can also be accessed 
from the Edit menu of many applications, 
including Chief Architect. These menu 
commands are not available when the text 
specification dialogs are open, but you can 
use the associated hotkeys. 

To Copy, Cut and Paste text
1. On the TEXT panel of either text specifi-

cation dialog or in another program alto-
gether, highlight the text you wish to cut, 
copy or paste.
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2. Press Ctrl + X to Cut the selected text 
out of its original location and save it to 
the system clipboard.

3. Press Ctrl + C to Copy the selected text 
to the system clipboard without remov-
ing it from its original location.

4. Open the text object or a file in another 
application and click to place your cur-
sor in the Text field, writing area, or 
spreadsheet cell.

5. Press Ctrl + V to Paste the copied text at 
the location of your cursor.

Bear in mind that when text is copied and 
pasted, its formatting is not always retained. 
The results depend on the program or type of 
text object in which the content was created 
as well as the type of text object into which it 
is pasted. 

Pasting into Text

Text pasted into a simple Text  object 
from another source will not retain its 
formatting. Instead, the settings for that 

Text  object are always used. See “Text 
Specification Dialog” on page 1041. 

This is the case even if the text is copied 

from another Text  object unless that 
object happens to use the same formatting. 

Text pasted into a simple Text  object  
from a spreadsheet program will retain basic 

column and row information. Each row can 
only have a single line of text; however, the 
width of each column can be adjusted. See 
“Tab Spacing” on page 1049. 

Pasting into Rich Text
Text pasted into a Rich Text object 
from another source, on the other 

hand, will retain most - but not necessarily 
all - of its custom formatting. If a line of text 
is sufficiently long, however, it may be 
wrapped automatically when pasted into 
Rich Text. 

Text pasted into a Rich Text  object from 
a spreadsheet program retains basic column 
and row information. Column width cannot 

be adjusted as it can in simple Text ; 
however, as you add or remove text from a 
cell, row height will increase or decrease to 
accommodate your changes.

The background colors of two or more cells 
copied from a spreadsheet application will be 

retained if pasted in to Rich Text ; 
however, once pasted background color 
cannot be edited. 

If you want to retain the color of the actual 

text being pasted into a Rich Text  object, 
be sure to uncheck Layer Color Text in the 
Rich Text Specification dialog. See 
“Appearance Panel” on page 1037.

Spell Check
Select Tools> Checks> Spell Check 
to open the Spell Check dialog. The 

Spell Check feature checks each text object 

in the current current .plan or .layout file 
consecutively for spelling errors.
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Spell Check can also be accessed by clicking 
the Spell Check button in the Rich Text or 
Text Specification dialog or by clicking the 

Spell Check  edit button. When accessed 
in this manner, only the selected text object is 
checked for spelling errors. See “Editing 
Text” on page 1045. 

Spell Check Dialog

Spell Check looks in for each word in 
all open dictionaries. When a word that 

is not recognized is found, it displays here. 

• Click Ignore to ignore the word in ques-
tion in all Spell Checks during the current 
program session. The word will not be 
ignored the next time Chief Architect is 
launched. 

• Click Skip to ignore the current instance 
of the word, but find other instances that 
may be present.

• Click Learn to add the word in question 
to the User Dictionary. See “Chief Archi-
tect Data” on page 53. 

• Click Delete to remove the selected word 
from the text.

• Click Replace to replace the word in 
question with the suggested word, below.

Spell check displays Suggestions for 
corrections here. There are two ways to 

replace a misspelled word:
• Type a correction in the field and click 

the Replace button.
• Click on a suggestion to select it, then 

click Replace to accept it.

When Spell Check is finished checking the 
text object or file for errors, the Spell Check 
results window displays.

Text Arrows
Text arrows, which are simply CAD lines 
with arrows drawn on the “Text” layer, can 
be used to connect text objects to details of 

interest in your drawing. See “Line Tools” on 
page 1080. 

Note: Spell Check does not look for duplicate
or repeated words. 

1

2
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If a Leader Line  or Text Line with 
Arrow  is drawn with its tail end snapped 
to a text object or another Leader Line or 
Text Line with Arrow, it will be placed on the 
same layer as the text object and inherit all of 
that layer’s attributes. Regular CAD lines 
with arrows do not do this. See “Layers” on 
page 143. 

Text arrows can be snapped together to form 
open or closed polylines. If two lines with 
arrows meet within the bounding box of a 
text object, however, they will not join. This 
allows you to attach multiple, separate text 
arrows to a single text object. See “Editing 
Line Based Objects” on page 187.

Lines with arrows can be independent or 
attached to other objects. If an attached 
object is moved, the end of the Line with 
Arrow will move, as well. Arrows attach to 
closed polyline-based objects along their 
edges, but can attach to Text or an 
architectural object anywhere within its 
bounding box in floor plan view. 

If an arrow is attached to text or another 
object, deleting either the text or the object 
will also delete the arrow. 

Leader Line
The Leader Line tool places either a 
Text or Rich Text object with an arrow 

already attached. This arrow can be selected 
and moved like any other line with arrow. 

To create text with a leader line

1. Select CAD> Text> Leader Line . 
2. Starting at the point where you want the 

arrow to point, drag to where you want a 
bend in the leader line and release the 
mouse button.

3. Click at the point where you want the 
center of the first line of text to display. 
The Rich Text Specification dialog 
opens. See “Rich Text Specification 
Dialog” on page 1034.

4. Enter text and click OK.

Click in the same location to create a Rich 
Text object without a leader.

If multiple leader lines are specified, click in 
the same location to stop adding leader 
segments.

The initial alignment of text created with the 

Leader Line  tool depends on the 
direction that the leader line was drawn:
• Leader Lines drawn from left to right 

produce text that is right-aligned.
• Leader Lines drawn from right to left 

produce text that is left-aligned.
• Leader Lines drawn from vertically pro-

duce text that is center-aligned.

Text Line with Arrow
Text Lines with Arrow can be 
attached to text, CAD and 

architectural objects by selecting CAD> 
Text> Text Line with Arrow  and then 
clicking and dragging to draw a line. There is 
no limit to the number of text lines with 
arrows that can be attached to an object.

Note: Leader lines create Rich Text and have
two leader line segments by default. You can
change this in the Preferences dialog. See
“Text Panel” on page 97.
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The endpoints of Text Lines with 
Arrows  can be joined to form polylines 
with corners that can be adjusted using the 
edit handles. See “Polylines” on page 1097. 

A Text Line with Arrow  behaves like a 

Line With Arrow  with one exception: 
Text Lines with Arrow are initially placed on 
the default Text layer, not the Current CAD 
Layer. See “Layers” on page 143. 

Auto Position Arrows
If either or both ends of a line with arrow are 
attached to an object, Auto Position Tail and 
Auto Position Head will be available in the 
Line Specification dialog. See “Arrow 
Panel” on page 1088. 

The Auto Position options are designed to 
prevent lines with arrows from crossing over 
the text or other objects that they are snapped 
to. These options snap the ends of a line with 
arrow to predefined points on the object(s) it 
is attached to. If an attached object is moved, 
the end of the line with arrow will update so 
that it is snapped to the closest Auto Position 
location. Similarly, if the line with arrow is 
moved, rotated, or resized, its end may snap 
to a new Auto Position location on an 
attached object.

There are four Auto Position locations on a 
text object: one at the midpoint of each side. 
The Auto Position locations on other objects 
varies by object type. 

The following image illustrates the behavior 
of Auto Positioning. The arrow has the Auto 
Position Tail option checked, and the tail 
end of the line is snapped to the text object. 
When the head of the line with arrow is 
moved, the tail of the arrow snaps to different 

Auto Position locations on the text object, 
maintaining its connection.

In addition:
• If a selected Text Line with Arrow is 

moved away from an Auto Position loca-
tion and you check Auto Position Tail, 
the tail will snap to the nearest Auto Posi-
tion location. 

• The first segment of a polyline arrow 
attached to text maintains its angle when 
Auto Position is off and text is moved.

• Auto Position is disabled automatically 
when an arrow is not attached to one of 
the auto position locations.

• Arcs and splines with arrows can also be 
attached to text and other objects.

Special Use Arrows

A Text Line with Arrow  attached to a 

Rich Text  or Text  object and 
designated as a Special Use Arrow offers 
functionality that may be useful when 
annotating the height of various objects. A 
Special Use Arrow replaces the first number 
in the attached Text object with the height of 
the architectural object it is attached to on the 
other end. The height is relative to 0’-0” on 
Floor 1.
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To create a Special Use Arrow
1. In floor plan view, create a Rich Text 

 or Text  object that has a Text 
Line with Arrow  or Leader 
Line  attached. 

1. Make sure the text includes a dash.
2. Connect the Line with Arrow to a slab, 

foundation wall, slab footing, stair 
landing, or custom countertop.

3. Select the Line with Arrow click the 

Open Object  edit button.
4. On the ARROW panel of the Arrow 

Specification dialog, check Special Use 
and click OK.

5. The height of the connected object will 
be added after the dash, using the format 
specified in the Dialog Number/Angle 
Style dialog. See “Dialog Number/
Angle Style Dialog” on page 127. 

Callouts
Select CAD> Text> Callout, then 
click at the location where you want a 

callout to be placed in floor plan view, a 
cross section/elevation view, a CAD Detail, 
or on a layout page. The Callout 
Specification dialog displays. Make any 
needed changes and click OK to place a 
callout. See “Callout Specification Dialog” 
on page 1055.

Cross Section Lines
Check the Cross Section Line box in the 
Callout Specification dialog to add a cross 
section line perpendicular to the nearest wall. 
See “Callout Panel” on page 1056.

Cross section lines can be added to any 
callout shape. Resize or rotate the cross 
section line by dragging the triangular edit 
handle near the end of the cross section line. 

Pointers and Arrows
To add an arrow or “hat” to a callout, select 
the callout and drag the diamond-shaped 
handle away from the center of the callout. 
An arrow is created, pointing in the direction 
you dragged. Arrows can also be specified in 
the Callout Specification dialog. See 
“Attributes Panel” on page 1057. 
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• Change the arrow’s direction by selecting 
the callout and dragging the edit handle 
appearing just beyond the arrow. 

• Remove an arrow by clicking and drag-
ging the edit handle at the point of the 
arrow towards the center of the callout. 

You can also add as many lines with arrows 
as you like to callouts. To add a line with 
arrow to a callout, select CAD> Text> Text 

Line with Arrow , then click and drag to 
create a line with arrow, which can be moved 
or resized as needed.

Double Callouts
Any callout can be specified as a Double 
Callout in the Callout Specification dialog. 
See “Attributes Panel” on page 1057.

To resize the line between the two callout 
shapes, select the callout and then click and 
drag the edit handle at the center of either 
callout shape. The arrows on a double callout 
are always the same on both callouts. 

Callout Specification Dialog
To open the Callout Specification 
dialog, select a callout and click the 

Open Object edit button. This dialog also 
displays when a new callout is created using 

the Callout  tool. 

The Callout Specification dialog is similar 
to the Callout Defaults dialog but affects the 
selected callouts rather than all subsequently 
created callouts. Also, the name of the Saved 
Default being edited will display in the title 
bar of the defaults dialog. See “Text Defaults 
and Preferences” on page 1028. 
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Callout Panel

Specify the text of the selected callout’s 
Label by typing in the text fields here. 

The label’s text style can be specified on the 
TEXT STYLE panel. See “Text Styles” on page 
1061.
• Type a Callout Label, which displays 

inside the callout shape. If no Text Below 
Line is specified, the Callout Label is 
centered in the callout shape. 

• Type the Text Below Line for the bottom 
row, if desired. If Text Below Line is 
added, a line will separate this text from 
the Callout Label in the callout shape.

• Click the Insert button to the right of 
either option to choose from a list of spe-

cial characters and text macros. See “Text 
Macros” on page 1064.

Specify the Callout Shape by clicking 
the radio button beside one of the 

options here.

Additional Specifications can be set 
here.

• Uncheck Automatic to enable the Size 
field and specify a new value. When 
checked, the callout is sized so that it 
encompasses the text of its label.

• Specify the Angle of the selected callout. 

A preview of the selected callout 
displays on the right. See “Dialog 

Preview Panes” on page 41. 

1

2

3
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Attributes Panel

Specify the attributes of the selected 
callout’s Cross Section Line. 

• Check Display to apply a cross section 
line to the selected callout. When 
unchecked, no cross section line is used.

• Check Double Callout to specify two 
identical callouts connected by the cross 
section line. Only available when Display 
is checked.

• Select the cross section line’s line Style 
from the drop-down list or by clicking the 
Library button. When By Layer is 
checked, the line style specified in the 
Layer Display Options dialog is used. 
See “Line Styles” on page 1108.

• Specify the Weight of the cross section 
line or check By Layer to use the line 
weight specified in the Layer Display 
Options dialog. 

Specify the attributes of the Callout 
Arrows. 

• Check By Layer to use the color speci-
fied in the Layer Display Options dialog 
or click the Color bar to choose an arrow 
color. See “Color Chooser/Select Color 
Dialog” on page 875.

• Check Filled to specify arrows with a 
solid fill. When unchecked, arrows are 
unfilled.

• Specify the Number of arrows and 
whether they are Small or Large. 

A preview of the selected callout 
displays on the right. See “Dialog 

Preview Panes” on page 41. 

Line Style Panel
The LINE STYLE panel is found in the 
specification dialogs for many different 
objects. For more information, see “Line 
Style Panel” on page 1085.

Additional attributes for the cross section 
line and arrows can be specified on the 
Attributes panel. 

1

2

3
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Text Style Panel
The settings on the TEXT STYLE panel control 
the appearance of the selected object’s text. 

For more information, see “Text Style Panel” 
on page 1063. 

Editing Callouts
Callouts can be edited using the edit handles, 
the edit toolbar buttons and the Callout 
Specification dialog. See “Callout 
Specification Dialog” on page 1055.

When a callout is selected, it has at least four 
edit handles. An additional rotate handle 
displays for each arrow added to the callout.

• The Move handle is located at the center 
of the callout and is used to move it.

• The triangular Extend/Rotate handle is 
used to extend and/or rotate the callout’s 
cross section line, if one exists. See 
“Cross Section Lines” on page 1054.

• The small, square Resize handle is 
located on the edge of the callout and is 
used to resize it and its associated text.

• The Add Arrow handle is used to add 
arrows by dragging away from the callout 
shape.

• The small triangular Rotate Arrow han-
dle located at the end of an arrow, if one 
has been added, is used to rotate that 
arrow around the callout shape.

Resizing Callouts
Callout shapes can be resized either in the 
Callout Specification dialog or using the 
edit handles. See “Callout Panel” on page 
1056.

Callout text can be resized in the Callout 
Specification dialog. See “Attributes Panel” 
on page 1057. 

As long as Specify Callout Size box is 
checked, a callout’s shape and text resize 
independent of one another. When this box is 
unchecked, the two are dynamically linked: 
if you resize the shape, the text adjusts 
accordingly or vice versa.

Markers
Markers for Level Lines, Test 
Borings and Point Markers can be 

placed in floor plan view, cross section 

views, or CAD Details. Framing Reference 
Markers should only be placed in floor plan 
views.

ResizeAdd Arrow

Move RotateRotate 
Arrow

Extend
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To create a marker, select CAD> Text> 
Marker  and click at the location where 
you want it to be placed. The Marker 
Specification dialog opens. 

You can also place a framing reference 
marker using Build> Framing> Framing 
Reference . See “Framing Reference 
Markers” on page 599.

Point Markers and Dimensions

When the Point to Point Dimension  tool 
is used to draw a dimension line and an 

object is not available to snap to at either the 
start or end point, a Point Marker will be 
automatically created and the dimension line 
will locate it. See “Point to Point 
Dimensions” on page 1007. 

In addition, any dimensions drawn in a cross 
section/elevation view may locate Cross 
Section Lines that represent objects rather 
than the objects themselves. When this 
occurs, Point Markers will also be placed and 
the dimension lines will locate them. See 
“Cross Section Lines” on page 921. 

Marker Specification Dialog
To open the Marker Specification 
dialog, select a marker and click the 

Open Object edit button. 

This dialog also displays when a new marker 
is created by clicking in floor plan view 

using the Marker  tool. 

The Marker Specification dialog is similar 
to the Marker Defaults dialog but affects the 
selected markers rather than all subsequently 
created markers. The name of the Saved 
Default being edited will display in the title 
bar of the defaults dialog. See “Text Defaults 
and Preferences” on page 1028.
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Marker Panel

Choose a marker Type. Note that 

Framing Reference Markers  affect 
the model, while the other marker types are 
for annotation only. 

Specify the text and alignment of the 
selected marker’s Label. The label’s 

text style can be specified on the TEXT STYLE 
panel. See “Text Styles” on page 1061.
• Type the Text which displays above the 

marker’s line. 

• Type the Text Below Line that displays 
below the marker’s line, if desired. Only 
available for Level Lines. 

• Click the Insert button to the right of 
either Text option to choose from a list of 
special characters and text macros. See 
“Text Macros” on page 1064.

• When a Level Line has text both above 
and below the line, specify its Align-
ment. Select Toward Marker to align 
both lines of text next to the marker; 
select Centered to center the shorter line 
of text relative to the longer line; select 
Away From Marker to align both lines 
of text with the end of the line. 

Specify the Size of the selected marker. 

• Specify the Marker Radius, which is the 
distance from the marker’s center to the 
edge of its filled shape.

1

Level Line

Test Boring

Point Marker

Framing Reference Marker
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• Enter a number in the Height field. This 
value will display in the Label when a 
pound sign (#) is entered in either Label 
text field.

A preview of the selected marker 
displays on the right. See “Dialog 

Preview Panes” on page 41. 

Line Style Panel
The LINE STYLE panel is found in the 
specification dialogs for many different 

objects. For more information, see “Line 
Style Panel” on page 1085.

Additional attributes for the cross section 
line and arrows can be specified on the 
ATTRIBUTES panel. 

Text Style Panel
The settings on the TEXT STYLE panel control 
the appearance of the selected object’s text. 
For more information, see “Text Style Panel” 
on page 1063. 

Editing Markers
Markers can be edited using the edit handles, 
edit toolbar and Marker Specification 
dialog. See “Marker Specification Dialog” 
on page 1059.

When a marker is selected, it has four edit 
handles.

• The Move handle is located at the center 
of the marker and is used to move it.

• The Resize handle is located on the edge 
of the marker and is used to resize the 
marker and associated text.

• The triangular Rotate handle is used to 
rotate the marker and associated text.

• The Extend handle is used to adjust the 
distance between the marker and its asso-
ciated text. 

Text Styles
In Chief Architect, a Text Style is a saved set 
of attributes that can be assigned to any 
object that displays text, such as Text, 
Callouts, Markers, Dimensions, Schedules, 
CAD objects, and object labels. A given Text 
Style can be assigned to objects: 

• In the Layer Display Options dialog; 
• On the TEXT STYLE panel of various 

objects’ defaults dialogs;
• On the TEXT STYLE panel some individ-

ual objects’ specification dialog.

4

RotateResize

Move Extend
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This makes it easy to ensure that various 
objects display text with a consistent 
appearance.

You can create your own or edit existing Text 
Styles to suit your needs in the Text Style 
Defaults dialog  

Text Style Defaults
Select Edit> Default Settings, 
expand the Text, Callouts and Mark-

ers category, click on “Text Styles” and click 
Edit to open the Text Style Defaults dialog. 
The Saved Defaults dialog will open, allow-
ing you to select which Saved Text Style 
Defaults you would like to edit. See “Multi-
ple Saved Defaults” on page 77.

The Text Style Defaults dialog can also be 
accessed:
• From the Layer Display Options dialog. 

See “Layer Display Options Dialog” on 
page 149. 

• By clicking the Text Style Defaults  
button, which can be added to your tool-
bars. See “To add a button to a toolbar” 
on page 132. 

• By clicking the Define button on the 
TEXT STYLE panel of various objects 
specification dialogs.

The settings in the Text Style Defaults 
dialog are similar to those on the TEXT STYLE 
panel of object specification dialogs 
throughout the program but affect all objects 
using that style rather than an individual 
selected object. 

Note: Because of its ability to use multiple
attributes in the same object, Rich Text does
not use Text Styles. See “Rich Text Specifica-
tion Dialog” on page 1034. 
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Text Style Panel

Specify where the selected object 
should draw its Text Style from. These 

options are not available in the Text Style 
Defaults dialog. 
• Select Use Layer for Text Style to use 

the Text Style assigned to the layer that 
the selected text is located on. 

• Select Use Text Style, then choose a style 
from the drop-down list to apply that 
style to the selected object, regardless of 
what layer it is on. When this is not 
selected, the name of the selected object’s 
Text Style displays here for reference. 

• Select Use Custom Text Style to enable 
the settings below and customize the 
selected objects Text Style attributes. 

Check Use Default Text Style to use the 
default style for the selected object type, or 
uncheck this box to enable the settings below 
and define a custom style.

The settings that follow are only editable 
when Use Custom Text Style is selected. 
When it is not selected, information about 
the Text Style that is assigned to the selected 
object displays for reference.

1
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Specify the attributes of the selected 
Text Style’s Font. 

• Select a font from the drop-down list.
• The text styles Bold, Underline, Italic, 

Strikeout, and Uppercase are available. 
Check any of the boxes to apply that 
style.

Specify the Character Height of text 
using the selected Text Style. 

• Enter the Character Height in drawing 
units. This height is subject to the current 
drawing scale. 

• Click the Scale button to open the 
Printed Size Input dialog. See “Scaling 
Text” on page 1047.

• In Version 9, text size was driven by 
dimension information associated with 
the font. Check Legacy Compatible Size 
to use this information for text sizing. See 
“Character Size” on page 1030.

Options - 

• Check Rotate with Plan to rotate text 
using the selected Text Style when 

Rotate View  is used. If unchecked, 
the text is unaffected when Rotate View 
is used. See “Rotate Plan View” on page 
237. 

Rotate with Plan also affects text in a 
view sent to layout if the layout box is 
rotated. See “CAD and Text in Layout” 
on page 1238.

• Check Transparent to make text boxes 
using the selected Text Style transparent. 
When unchecked, text boxes have a solid 
fill the same color as your background 
color. Not available for objects that have 
FILL STYLE panels in their specification 
dialogs. See “Colors Panel” on page 94. 

Specify the selected Text Style’s Text 
Color. When Use Custom Text Style is 

not selected above, a Text Color does not 
display here for reference. 
• When By Layer is checked, text uses the 

line color assigned to the layer that the 
object it is assigned to is located on. See 
“Displaying Objects” on page 144. 

• Uncheck By Layer, then click the Color 
bar to select a different color. See “Color 
Chooser/Select Color Dialog” on page 
875.

A preview of the Text Style currently 
assigned to the selected object displays 

here. 

In many specification dialogs, a 
preview of the selected object displays 

on the right. See “Dialog Preview Panes” on 
page 41. 

Text Macros
Text macros insert dynamic information 
relevant to the current plan or layout file, or a 
selected object. Macros are particularly 
useful in layouts: page numbers, drawing 
scale, and information to identify drawings 

can be inserted to improve organization and 
clarity. 

Text macros can also be used to create 
customized object labels. See “Creating User 
Defined Text Macros” on page 1065. 

2
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There are three categories of text macro: 
• Global macros have information about 

the project, the plan or layout file, a 
room, and the date and time. They can be 
used to insert special characters.

• Object Specific macros have information 
specific to a selected object type and can 
be included in object labels. See “Label 
Panel” on page 1280.

• User Defined macros can include a wide 
range of values, including global and 
object specific information and text. 
They can also be written to perform cal-
culations. See “Creating User Defined 
Text Macros” on page 1065.

To insert a text macro
1. Click the Insert Macro button on:

•  The Text Panel of the Rich Text or Text 
Specification dialog. 

•  The Callout Panel of the Callout 
Specification dialog.

•  The Marker Panel of the Marker 
Specification dialog.

2. A menu of macros displays. Move your 
cursor over a menu item to view its sub-
menu.

3. Select from the list of available text 
macros. In this example Time Date> 
Short Date (%date.short) is selected.

4. Click OK to close the specification dia-
log.

5. The text object displays the date rather 
than the macro formula.

Object Specific
The macros available for a given object 
depend on its type. Additional, user defined 
macros can also be created.

Object Specific macros can be used in either 
of two ways: 
• In an object’s label. See “Object Labels” 

on page 1279.
• In a text object with an arrow pointing to 

the object. See “Text Arrows” on page 
1051.

Creating User Defined Text Macros
In addition to the text macros installed with 
the program, you can create your own 
custom text macros for a variety of purposes.
• Shortcuts for names or other written 

information.

• Custom object labels See “Object 
Labels” on page 1279.

• Custom object labels inserted into text 
objects, callouts, and markers in floor 
plan view.

The macro formula  
displays in the dialog’s 
Text Entry field
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Text Macro Management
A list of all user-defined text macros 
present in the current plan or layout 

file can be accessed by selecting CAD> 
Text> Text Macro Management.
• If you wish to create a user defined macro 

for an object, or find out whether an 
existing macro is valid for an object, 
open this dialog while the object is 
selected. 

• To create a user-defined macro to be 
inserted into a text object that describes 
another object, or to find out whether 
such a macro is valid, select a text object 
with an arrow pointing to the object in 
question and then open this dialog. See 
“Named Values and Context” on page 
1306. 

An object-specific version of this dialog is 
also available for objects saved in an 

unlocked library. Right-click on a single 
object of a type able to display labels and 
select Text Macro Management from the 
contextual menu. See “Using the Contextual 
Menus” on page 822. 
• Any Owner Object macros assigned to 

the object’s label when it is added to the 
library are listed here. Note that objects 
in some manufacturer catalogs may 
include macros. See “Manufacturer 
Catalogs” on page 826. 

• Custom macros can be imported to and 
exported from a library object, and addi-
tional macros can be added to the object, 
but you cannot specify them as part of a 
label while it is in the library. 

• When the object is added to a plan, any 
macros associated with it are added to the 
plan, as well. 



Creating User Defined Text Macros

 1067

An alphabetical list of all User-Defined 
Macros present in the current file 

displays here. 
• Click on the Name of a macro to select it. 
• If a macro is Valid in the current context, 

a checkmark will display to the right of 
its Name. See “Named Values and Con-
text” on page 1306.

• Information about a selected macro dis-
plays in the Macro Value and Expanded 
Macro Value fields to the right of the 
list.The Macro Value field shows the 
defined Value of the selected macro. The 
Expanded Macro Value shows the output 
of the macro in the current context. 

Edit or delete the text macro selected in 
the list on the left, create a new one, or 

import or export macros to and from other 
files. 
• Click the Edit button to make changes to 

the selected macro in the Edit Text Macro 
dialog. Only available when an existing 
macro is selected. 

• Click the New button to open the Edit 
Text Macro dialog and create a new 
macro. 

• Click the Copy button to create a copy of 
the currently selected macro and open the 
Edit Text Macro dialog. Only available 
when an existing macro is selected.

• Click the Delete button to remove the 
selected macro from the list. Only avail-
able when an existing macro is selected.

• Click the Import button to open the 
Import Text Macros dialog and import 
macros exported from another file into 
the current file. See “Importing Files” on 
page 62.

• Click the Export button to open the 
Export Text Macros dialog and make the 
user-defined macros in this file available 
to be imported into another file. See 
“Exporting Files” on page 58.

The Macro Value field displays the 
content, or text used to define the 

selected macro. 

The Expanded Macro Value field 
displays the information that the macro 

reports. If the selected macro is not Valid in 
the current context,  “#Evaluation Error#” 
will display here, 

Click the Show Evaluation Error 
button to open an Information box with 

a description of why the selected macro is 
not Valid. Only available when the selected 
macro is not Valid. 

Edit Text Macro Dialog
The Edit Text Macro dialog can be accessed 
by clicking the Edit, New, or Copy button in 
the Text Macro Management dialog.

Type a short, descriptive Name for the 
new object label macro. Macro names 

must be unique within a given file, or library 
object.

1
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Type a named value, reference to a 
Ruby .rb file, and/or insert an existing 

macro in the Value field. 
• You can also copy a Named Value out of 

the Ruby Console or a definition from an 
.rb file and paste it here. See “To Copy, 
Cut and Paste text” on page 1049.

• Click the Insert button above the Value 
field to insert an already existing macro 
into the selected macro. See “Text Mac-
ros” on page 1064.

Check the Evaluate box, then select a 
Context from the drop-down list. 

• Choose None if the macro performs a 
function but doesn’t refer to an object or 
if the macro’s context - or contexts - are 
stated in its Value.

• Choose Owner Object to create a macro 
for use in an object label.

• Choose Referenced Object to create a 
macro for use in a Text object with an 
arrow that points at an object that the 
macro describes.

Click OK to return to the Text Macro 
Management dialog. 

Importing and Exporting 
Macros

User-defined text macros can be exported out 
of one plan file, layout file, or library object 
and imported into another file or object using 
the Text Macro Management dialog.

If the program encounters macros with 
duplicate names when importing into a plan 
or layout file, the Text Macro Name Conflict 
dialog will display, allowing you to choose 
how to handle the name conflict.

• To keep both the existing macro and the 
one being imported, select Rename the 
imported macro. Then, type a short, 
descriptive, unique New Macro Name. 
By default, the new name is simply the 
original name appended by a number. 

• Select Discard the imported macro to 
use the existing macro already present in 
the destination file or library object rather 
than import the new one.

• Select Replace the existing macro with 
the imported macro to delete the exist-
ing macro and replace it with the one 
being imported.

• Check Do this for all remaining macro 
conflicts to apply the same choice for any 
other macros with conflicting names in 
the current import operation.

If the program encounters a macro name 
conflict when importing into a library object 
or when placing a library object in a plan, a 
Question message box will ask if you wish 
to  replace the existing macros. Click Yes to 
replace any existing macros with imported 
macros of the same name or click No to keep 
the existing macros and not import those of 
the same name.

2

3



Creating User Defined Text Macros

 1069



1070

Chief Architect X8 Reference Manual



 1071

Chapter 34:

CAD Objects

With the 2D Computer Aided Design (CAD) 
tools included in Chief Architect, you can 
add details to views of your 3D model to 
create complete working drawings. Custom 
details can be created, saved, and used in 
other plans. 

The CAD Tools are used to add information 
to 2D views of your model. CAD objects do 
not affect 3D objects or display in camera 
views or overviews, but they can be used to 
add details to layout pages, floor plan view 
and cross section/elevation views. 

CAD polylines can be converted to 3D 
objects such as countertops and terrain data, 
and shown in 3D views.  See “Convert 
Polyline” on page 239.

CAD objects are edited much like other 
objects in Chief Architect. See “Editing 
Objects” on page 177.

Chapter Contents
•      CAD Defaults and Preferences
•      The CAD Drawing Tools
•      Point Tools
•      Line Tools
•      Line Specification Dialog
•      Arc Tools
•      Drawing Arcs - Arc Creation Modes
•      Arc Specification Dialog
•      Circle Tools
•      CAD Circle/Oval/Ellipse Specification 

Dialog
•      Polylines
•      Polyline Specification Dialog
•      Box Tools
•      Box Specification Dialog
•      Revision Clouds
•      Revision Cloud Specification Dialog
•      Splines
•      Displaying CAD Objects
•      Line Styles
•      CAD Blocks
•      CAD Block Specification Dialog
•      CAD Details
•      Plot Plans and Plan Footprints
•      Plan Footprint Specification Dialog
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CAD Defaults and Preferences
CAD Defaults can be accessed by 
selecting Edit> Default Settings from 

the menu and expanding the CAD category.  

The behavior and appearance of CAD 
objects are also affected by settings on 

the CAD, LINE PROPERTIES, SUN ANGLE, 
BEHAVIORS, and SNAP PROPERTIES panels of 
the Preferences dialog. Unlike default 
settings, preference settings are global, 
affecting all plan and layout files. See 
“Preferences Dialog” on page 90.

CAD Defaults Dialog
The settings in the CAD Defaults 
dialog control the basic appearance of 

CAD objects. This dialog can also be opened 
by clicking the CAD Defaults button, which 
can be added to a toolbar See “To add a 
button to a toolbar” on page 132. 

Each plan file has multiple CAD Defaults 
dialogs: one affecting floor plan view, one 
for every cross section/elevation view, and 
one for every CAD Detail and Wall Detail. 
Each layout file has its own CAD Defaults, 
as well. Each set of CAD Defaults can be 
accessed by opening the CAD Defaults 
dialog from within that view.

Select the Current CAD Layer from 
the drop-down list. See “Current CAD 

Layer” on page 1107. 
• Click the Define button to open the Layer 

Display Options dialog. See “Layer Dis-
play Options Dialog” on page 149.

Note: Although there are multiple CAD
Defaults dialogs in each plan file, only one
layer can be specified as the Current CAD
Layer at any given time. When a new Current
CAD Layer is selected, the change affects all
views and view types.

1
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Specify the Displayed Line Length 
Format, which controls the appearance 

of line length indicators. These only display 
when Show Length is checked in an object’s 
specification dialog. See “Line Style Panel” 
on page 1085.
• A preview of the current line length for-

mat displays here.
• Click the Define button to open the 

Displayed Number Style dialog and edit 
the displayed line length format.

Display Line Angles as - Specify the 
format to use when Show Angle is 

checked in an object’s specification dialog. 
See “Line Style Panel” on page 1085.

Line angles can be displayed using three 
basic methods: 
• Degrees/Minutes/Bearings - Measured 

counterclockwise from a line drawn hori-
zontally to the right of the angle’s vertex. 
Useful for most drawing tasks. Select the 
level of accuracy that you require.

• Quadrant Bearings - Measured from a 
vertical line representing North/ South, 
Quadrant Bearings use directional bear-

ings in their measurements. Useful for 
site drawings.

• Azimuth Bearings - Measured from a 
line drawn straight up from the angle’s 
vertex (ie, North on a site plan). Useful 
for site drawings, Azimuth Bearings use 
degrees, minutes, and seconds in their 
measurements.

Select any combination of the available 
Options.

• Check Show Arc Centers and Ends  
to show arc centers and ends on the cur-
rent floor. Ends display as small lines 
where arcs connect to one another. Cen-
ters also acts as snap points. See “Arc 
Centers and Ends” on page 195. 

• Check Fill New Framing Members to 
draw all new framing members with a 
solid white fill. This settings is not view 
specific - it affects all new framing mem-
bers, regardless of the floor they are 
drawn on. 

• Check Use Line for Framing to show all 
framing members as single lines rather 
than as closed polylines in floor plan 
view. See “Displaying Framing” on page 
604. 

2

3

Minutes + Seconds

Minutes

Degrees

Quadrant Bearing

Azimuth Bearing

Line length and angle indicators use
the Text Style of the layer that their

object is on. See “Text Styles” on page 1061.

4
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Displayed Line Length Dialog
The settings in the Displayed Line Length 
dialog control the appearance of CAD line 
length indicators, when set to display. See 
“Show Length and Angle” on page 1108.

To access this dialog, click the Define button 
under the Displayed Line Length Format 
heading in the CAD Defaults dialog. 

The settings here are similar to those found 
on the DIMENSION FORMAT panel of the 
Room Label Defaults dialog and the FOR-
MAT panels of the Dimension Defaults 
dialog. See “Primary Format Panel” on page 
989.

Specify the numbering Format for 
CAD line length indicators. 

• Select the Units of measurement to be 
used by line length indicators from the 
drop-down list. 

• Check Unit Indicators to display the unit 
of measurement along with the dimen-
sion number.

• Check Leading Zeros to display the zero 
before a decimal less than 1 or to display  
0’ or 0” when the ft-in or ’-” unit formats 
are used. 

• Check Trailing Zeros to display trailing 
zeros at the end of decimal values. 

• Check Thousands Separator to use a 
thousands separator for values greater 
than 999. 

• Select the Use Comma or Use Dot radio 
button to use a comma or a dot as the 
thousands separator. See “Region and 
Language Settings” on page 75,

• Select the Use Space radio button to use 
a space as the thousands separator. 

Specify the degree of Accuracy used 
by dimension numbers. When Smallest 

Fraction is selected, additional settings are 
available, below.
• Select the Decimal Places radio button 

for length indicators in decimal format.  
In the text field, specify the number of 
decimal places to use, from 0 to 20. If 0 is 
used, no decimal places are used.

• Select the Smallest Fraction radio but-
ton for length indicators using whole 
numbers and fractions. In the text field, 
specify the largest denominator to use, 
from 1 to 128. If 1 is entered, whole num-
bers are used. When Smallest Fraction is 
selected, the settings that follow are 
available:

• Uncheck Show Denominator to turn off 
the display of fraction denominators used 

1
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by line length indicators. Denominators 
are typically only turned off when eighths 
are desired.  

• Uncheck Reduce Fractions to always 
use the denominator specified above. 
When checked, the lowest possible 
denominator will be used and the two 
options below will be available.

• Select the Greatest Common Divisor 
radio button to reduce fractions using the 
largest value that divides equally into the 
numerator and the denominator specified 
above. This option is best for fractional 
inches. 

• Select the Closest Fraction radio button 
to reduce fractions without referring to 
the denominator specified above. Not 

recommended when fractional inches are 
used.

A value of 0.33333 is represented by the 
fraction 5/16 when Greatest Common 
Divisor is used and the Smallest Fraction 
denominator is 16. When Closest Fraction is 
selected, this value is represented by 1/3. 

Revision Cloud Defaults
Settings in the Revision Cloud Defaults 
dialog determine the initial appearance of 
Revision Clouds. The settings in this dialog 
are similar to those in the Revision Cloud 
Specification dialog. See “Revision Cloud 
Specification Dialog” on page 1104. 

The CAD Drawing Tools
The CAD Tools are available in the 
CAD menu and on the toolbars. 

Point Tools
Select CAD> Points to access the 
Point Tools.

The Place Point , Input Point , Point 
Marker , and Delete Temporary 
Points  tools can be used to create or 
remove snap points for a variety of purposes. 
See “Point Tools” on page 1076.

Line Tools
Select CAD> Line to access the Line 
Tools.

The Draw Line , Input Line , Line 
With Arrow , Sun Angle , and the 
North Pointer  allow you to create 
various types of lines. See “Line Tools” on 
page 1080.

Arc Tools
Select CAD > Arcs to access the Arc 
Tools.

The Draw Arc , Input Arc , and the 
Arc With Arrow  tools allow you to 
create arcs. See “Arc Tools” on page 1091.

Box Tools
Choose CAD > Boxes to access the 
Box Tools.
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The Rectangular Polyline , Regular 
Polygon , Box , Cross Box , and 

Insulation  tools allow you to create a 
variety of polyline and box objects. See “Box 
Tools” on page 1101. 

Circle Tools
Select CAD> Circles to access the 
Circle Tools.

The Circle , Circle About Center , 

Oval , and the Ellipse  tools are 
discussed in detail later in this chapter. See 
“Circle Tools” on page 1095.

Revision Cloud
Select CAD> Revision Cloud, then 
click and drag to draw a rectangular 

shape with edges that display a series of arcs. 
See “Revision Clouds” on page 1104.

Spline
A Spline is a curve that passes 
smoothly through a set of points. 

Select CAD> Spline to draw connected line 
segments that form a spline. See “Splines” 
on page 1106.

Once created, a spline can be selected and 
edited. See “Editing Spline Based Objects” 

on page 209 and “Polyline Specification 
Dialog” on page 1098.

Dimension Tools
Select CAD> Dimensions or CAD> 
Automatic Dimensions to access the 

manually drawn and Automatic Dimension 
Tools. The Dimension Tools can be used 
with CAD and architectural objects and are 
discussed in their own chapter. See 
“Dimensions” on page 985.

Text Tools
Select CAD> Text to access the Text 
Tools. The Text Tools are discussed in 

their own chapter. See “Text, Callouts, and 
Markers” on page 1027. 

Current CAD Layer
Select CAD> Current CAD Layer to 
change the current default CAD layer. 

See “Select Layer Dialog” on page 153.

Auto Detail
Select CAD> Auto Detail while a 
cross section view is active to 

automatically generate CAD objects for 
commonly detailed structural components. 
See “Auto Detail” on page 905.

Point Tools
Select CAD> Points to access the 
Point Tools. 

Temporary points created using the Place 
Point  and Input Point  tools and 

permanent Point Markers  can be used 

with Object Snaps  to accurately position 
a variety of objects. See “Object Snaps” on 
page 162. 
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The size of temporary points is specified in 
the Preferences dialog. See “Snap 
Properties Panel” on page 115.

Place Point
Select CAD> Points> Place Point, 
then and click in the drawing area to 

place a temporary CAD point at that 
location. Temporary CAD points can be used 
for a variety of purposes: for example, as an 
anchor for snapping objects to a precise 
location  The Current CAD Point can be used 
for additional tasks. See “The Current Point” 
on page 1078.

Input Point
Temporary CAD points can be placed 
with precision by entering 

coordinates. See “3D Drafting” on page 31.

To use the Input Point tool

1. Select CAD> Points> Input Point  
to open the New CAD Point dialog.

2. Select a Location option, and enter the 
desired location of the point. 

3. Click OK to close the dialog and create 
the new point. The new point becomes 
the Current Point and is highlighted. See 
“The Current Point” on page 1078.

4. Alternatively, click Next to create the 
new point but remain in the New CAD 
Point dialog and create additional 
points. As each is created, it becomes 
the Current Point.

New CAD Point Dialog

The location of the Current Point 
displays here. If no CAD points are 

present, the origin (0, 0) displays. See “The 
Current Point” on page 1078.

Specify the location of the New Point.

• Absolute Location - Define the point in 
X Position (horizontal) and Y Position 
(vertical) coordinates, relative to the ori-
gin at (0,0).

• Relative to Current Point - Define the 
new point in X and Y coordinates that are 
relative to the Current Point, as though 
that point was at (0,0). Only available 
when a Current Point exists. 

• Check Polar to define the new point by 
its Distance and Angle from the Current 
Point rather than in X and Y coordinates. 
This is helpful when creating a plot plan. 
See “Plot Plans and Plan Footprints” on 
page 731.

The position of the New Point is defined 
here. The options available depend on the 
method chosen to define it, above.

1

2
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• X Position and Y Position coordinates 
relative to (0,0) are entered if the Abso-
lute Location method is specified.

• X Position and Y Position coordinates 
relative to the Current Point are entered if 
the Relative to Current Point method is 
specified.

• Distance and Angle from the Current 
Point are entered if the Relative to Cur-
rent Point: Polar method is specified.

• Click Next to create the new point with-
out exiting the dialog so you can input 
data for the next point. The newly created 
point becomes the Current Point.

Point Markers
Use a permanent Point Marker as a 
snap point for dimension lines and 

other CAD objects. Select CAD> Points> 
Point Marker and click in the view to place 
a permanent point marker. Point markers 
display as a simple cross, with or without a 
text label. They can be opened for 
specification and modified to include a label 
or alter their attributes.

You can also place Point Markers using the 

Marker  tool, which lets you specify the 
marker label and type. See “Markers” on 
page 1058.

Point Markers are also created when the 

Point to Point Dimension  tool is used.or 
when a dimension line is copied and pasted 
independent of the objects it locates. See 
“Point to Point Dimensions” on page 1007. 

Delete Temporary Points
All temporary points in the current 
view can be deleted at once using 

CAD> Points> Delete Temporary Points. 
In floor plan view, Delete Temporary Points 
will delete all temporary points on all floors.

You can also press the Delete key when 
nothing is selected to delete the points one by 

one; however, Delete Temporary Points  
can save time when there are many points. 

The Current Point
In any view and on any floor, there may be 
multiple temporary CAD points. The Current 
Point is either the most recently created or 
most recently selected temporary CAD point. 
The Current Point has a variety of uses:
• As the starting point for objects as they 

are drawn by entering data. See “Entering 
Coordinates” on page 168. 

• As the point about which objects are 
rotated. See “Rotating Objects” on page 
234. 

• To indicate the points at which roof 
planes can join. See “To find roof plane 
intersection points” on page 494. 

When multiple temporary points are on-
screen, the Current CAD Point is highlighted 
so it can be easily identified. 

Click the Number Style button to
change the units used in dialogs. See

“Dialog Number/Angle Style Dialog” on page
127.
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To delete the Current Point

1. Make sure no other objects are selected 

by clicking the Select Objects  but-
ton. You can also press the Esc key to 
deselect any selected objects. 

2. Press the Delete key on the keyboard to 
delete the Current Point. The temporary 
point created prior to this one becomes 
the new Current Point. 

3. If you continue pressing the Delete key, 
temporary points will be deleted in the 
reverse order that they were created.

Move Point Dialog
A CAD Point can be repositioned relative to 
itself, another point, or a CAD object such as 
a line using the Move Point dialog. When a 
Point is moved, it becomes the Current Point.

For example, you can locate the point exactly 
one-quarter the distance along a given line, 
or exactly 6 inches from one end. This new 
location can then be used for the start point 
of a new line or other purpose.

To reposition a CAD Point, double-click on it 

using the Select Objects  tool. That point 
becomes the Current Point, and the Move 
Point dialog opens.

The Current Location of the selected 
point displays at the top of the dialog 

for reference.

Specify the New Location of the point.

• Absolute Location - Define the new 
location in X (horizontal) and Y (vertical) 
Position coordinates, relative to the ori-
gin at (0,0).

• Relative to Itself - Define the new loca-
tion in X and Y Position coordinates rel-
ative to the current location, as though 
that point were the origin.  

• Relative to Previous Point - Define the 
new location relative to the point that was 
the Current Point prior to this one, as 
though that point was the origin. Only 
available if the selected point is located 
on a CAD object.

Current 
Point

There can only be one Current Point

1

2
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• Check Polar to define the new location’s 
Distance and Angle from the previous 
point instead of using X and Y coordi-
nates. Only availalbe if Relative to Itself 
or to Previous Point is selected above.

• Along Line - Define the new location rel-
ative to the edge of a nearby CAD object. 
This option is enabled only when the 
point is located near a CAD object and 
refers to the end nearest to the point’s 
original location. 

• Check Percentage (%) to specify the 
Along Line value as a percentage of the 
total line or arc length rather than as a 
distance. 0% moves the point to the clos-
est end of the nearest edge, 50% to the 
midpoint, and 100% to the other end. 
Negative numbers and percentages 
greater than 100 are allowed. 

• Specify the new position of the point 
here. The options here depend on the 
method chosen to define the New Loca-
tion.

• X Position and Y Position coordinates 
are entered if the Absolute Location 

method is specified or if either Relative 
method is used with Polar unchecked.

• Distance and Angle are entered if either 
Relative method is specified when Polar 
is checked.

• From Edge - When the Along Line 
method is used, specify the distance of 
the point’s New Location to the end of 
the CAD object’s edge that it was origi-
nally closest to. When Percentage (%) is 
checked, enter this value as a percentage 
instead.

If the point is near an arc, Along Line is 
measured along the curve.

If the point is near a box or polyline, Along 
Line is measured along the nearest side just 
as it does with an individual line or arc. 

If the point is near an oval or circle, Along 
Line is measured along an (invisible) axis 
line that the item was originally drawn along.

Line Tools
Select CAD> Draw Lines to display 
the Line Tools.

If Object Snaps  and Connect CAD 
Segments  are enabled, you can connect 
the ends of two lines and/or arcs to form a 
single entity called a polyline. See 
“Polylines” on page 1097. 

Draw Line
There are two methods that you can 
use to draw lines with the Draw Line 

tool. The standard method is to select CAD> 
Lines> Draw Line, then click and drag from 
beginning to end. 

An alternative method that allows you to 
draw multiple lines is also available. See 
“Alternate” on page 179. 

Click the Number Style button to
change the units used in dialogs. See

“Dialog Number/Angle Style Dialog” on page
127.
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To draw continuous lines

1. Select CAD> Lines> Draw Line .
2. Press the Alt key on your keyboard (or 

use the right mouse button) and click 
and drag to draw a line. You can also 
toggle to alternative mode.

3. Move your cursor to a new location in 
the drawing area and click once. A new 
line is drawn beginning at end of the 
previous line.

•  Provided that Connect CAD Segments 

 is toggled on, a polyline will be 
formed. See “Connect CAD Segments” 
on page 182.

4. To stop, press Esc on your keyboard or 
press two mouse buttons at the same 
time.

By default, this continuous drawing behavior 
will turn off when a closed shape is created. 
You can specify that this behavior remain on 
in the Preferences dialog. See “Behaviors 
Panel” on page 113.

Input Line
CAD lines can also be created using 
absolute values entered with the 

keyboard by selecting CAD> Lines> Input 
Line. This method is slower but more precise 
than using the mouse and is ideal when the 

desired length and angle of each line is 
known, such as with property lines.

Before any line is drawn using this method, a 
starting point must be defined. If a starting 
point has not been defined, Chief Architect 
assumes a starting point of 0,0.

To use the Input Line tool

1. Select CAD> Points> Place Point , 
then click the screen to place a CAD 
point. This is the Current Point, and is 
the start point for the new line. See “The 
Current Point” on page 1078.

2. Select CAD> Lines> Input Line  to 
open the New CAD Line dialog. 
The New CAD Line dialog can also be 

opened by double-clicking the Line 
Tools  parent button. 

3. If necessary, specify the start point.
4. Specify the method used to define the 

location of the End Point, then define the 
End Point. 

5. Click OK to close the dialog and draw 
the line, or click Next to draw the line 
but remain in the New CAD Line dialog 
and draw additional lines.

If you double-click the Draw Line tool,
the Input Line dialog will open. 

Note: If you accidentally click OK instead of
Next and need to continue drawing a polyline
using the New CAD Line dialog, select the
Input Line tool again and continue.
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New CAD Line Dialog

The X Position (horizontal) and Y 
Position (vertical) coordinates of the 

start point for the new line display here. They 
can also be changed, if you wish.

The new line’s End Point is defined 
here. Begin by specifying how you 

want to define the line End Point Location.
• Absolute Location - Define the end 

point of the new line in X Position (hori-
zontal) and Y Position (vertical) coordi-
nates, relative to (0,0).

• Relative to Start Point - Define the end 
point of the new line in X and Y coordi-
nates that are relative to the line’s Start 
Point, as though it were at (0,0).

• Check Polar to define the End Point of 
the new line by its Distance and Angle 
from the Start Point rather than in X and 
Y coordinates. This is helpful when cre-
ating a plot plan. See “Plot Plans and 
Plan Footprints” on page 731.

• Relative to Previous Line - Define the 
End Point of the new line by its Distance 

and Angle relative to the end of the last 
line drawn, as though that line’s angle 
were at 0° and its End Point, at  (0,0). 

• X Position (horizontal) and Y Position 
(vertical) coordinates relative to (0,0) are 
entered if the Absolute Location method 
is specified.

• X Position (horizontal) and Y Position 
(vertical) coordinates relative to the start 
point are entered if the Relative to Start 
Point method is specified.

• Distance and Angle from the start point 
are entered if the Relative to Start Point: 
Polar method is specified.

• Distance and Angle from the start point 
are entered if the Relative to Previous 
Line method is specified.

• Click Next to create the line without exit-
ing the dialog so you can input data for 
the next line. The start point of the next 
line is the end point of this line.

To enter an angle in bearings

1. While not required, you may want to 
select Quadrant or Azimuth Bearings 
in the Dialog Number/Angle Style dia-
log. 

2. For Quadrant Bearings, begin by typing  
N or S (for North or South).

3. Next, type the number of degrees fol-
lowed by either a  letter d or a space. 

4. Type the number of minutes followed by 
either a ‘ or a space. 

1

2

Click the Number Style button to
change the units used in dialogs. See

“Dialog Number/Angle Style Dialog” on page
127.
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5. Type the number of seconds followed by 
either a “ or a space. 

6. Finally, for Quadrant Bearings, type 
either E or W (for East or West).  

Following are some examples of Quadrant 
Bearings. It is not necessary to capitalize the 
letters. Spaces after each value are optional. 
• N 20d 30' E
• S 45' W
• N 89d 48' 30" W
• N 90' E

Enter Coordinates
Similar to Input Line, lines can also be 
specified by pressing the Tab key on the 
keyboard when a line is in the process of 
being drawn. This opens the Enter 
Coordinates dialog. See “Entering 
Coordinates” on page 168.

Line With Arrow
Create a line or polyline with an arrow 
on one or both ends by selecting 

CAD> Lines> Line With Arrow, then 
clicking and dragging in the drawing area. 
The initial attributes of the line’s arrow are 
set in the Arrow Defaults dialog. See “Arrow 
Defaults” on page 1029. 

As with other lines, lines with arrows can 
edited after they are created and connected to 
form polylines provided that they share the 
same layer and style attributes. See “Editing 
Line Based Objects” on page 187 and “Line 
Specification Dialog” on page 1084.

You can also create arcs with arrowheads. 
See “Arc with Arrow” on page 1092.

The ends of lines with arrows can be attached 
to other objects: if an attached object is 
moved, the end of the Line with Arrow will 
move as well. Lines with arrows attach to a 
polyline-based object along its edges and can 
attach to an architectural object or text 
anywhere within its bounding box in floor 
plan view. See “Text Arrows” on page 1051.

If a Line with Arrow is snapped to another 
object and that object is deleted, the Line 
with Arrow will be deleted, as well.

North Pointer
The North Pointer tool is used to 
define the direction of true north in a 

plan. The direction of north does not affect 
the orientation of the Snap and Reference 
grids, but it does determine the direction of 
bearing information as well as how shadows 
and conditioned area totals are calculated. 
See “North Pointer” on page 943.

If a North Pointer  is not used, north is 
assumed to be straight up on screen in floor 
plan view. 

Sun Angle
Sun Angles let you specify the date, 
time, latitude, and longitude that the 

program uses when calculating the angle of 
the Generic Sun as well as the direction and 
length of sun shadows. See “Sun Angles and 
Shadows” on page 943. 

Same Line Type Edit Handles
A new CAD line can also be drawn using the 
Same Line Type edit handles on an existing 
CAD object. The start point of the new line is 
located at one end of the existing object and 
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shares its line color, weight, style, and its 
layer. If the object has an arrow, its attributes 
are also inherited. See “Line Style Panel” on 
page 1085 and “Arrow Panel” on page 1088.

The Same Line Type edit handles are 
available for CAD lines, arcs, open 
polylines, and splines, but not for closed 
CAD shapes or CAD-based architectural 
objects. They can be turned off in the 
Preferences dialog if you wish. See “CAD 
Panel” on page 109. 

When Connect CAD Segments  is 
disabled, the new CAD line will snap to the 
existing object, forming an open polyline or 

spline. When Connect CAD Segments  

is enabled, on the other hand, the two will 
remain separate objects. 

Disconnect Edges
Select CAD> Lines> Disconnect 
Edges, then click on the edge of a 

polyline-based object to disconnect that edge 
from the rest of the polyline. See 
“Disconnect Edges” on page 184.

When Connect CAD Segments  is tog-
gled off, CAD objects will not join to form a 
single polyline, either as they are drawn or 
when edited. See “Polylines” on page 1097. 

Create Line Style
The Line Style Specification dialog 
allows you to create new line styles 

for use in Chief Architect. Select CAD> 
Lines> Create Line Style to access this 
dialog. See “Creating Line Styles” on page 
1109.

Line Specification Dialog
Select a CAD Line, Line With Arrow, 
or Text Line With Arrow and click the 

Open Object edit button to open the Line 
Specification dialog. 

The settings on the panels in this dialog are 
found in the specification and defaults 
dialogs for a variety of different objects in 
the program.

Line Panel
The information on the LINE panel of the 
Line Specification dialog is similar to that 

found on the SELECTED LINE panels of 
various specification dialogs in the program.

Same Line Type edit handles
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Lock - These lock options control how 
changing properties on this dialog 

affect the line.

Start - Select this option to keep the start of 
the line fixed when changing the length, 
angle, and end.

End- Select this option to keep the end of the 
line fixed when changing the length, angle, 
and start.

Center- Select this option to keep the center 
of the line fixed. Changing the length of the 
line moves the start and end of the line 
equally. Changing the angle rotates the line 
around the center.

Select Length/Angle to keep the length and 
angle of the line segment fixed. Moving the 
start or end moves the other end so the length 
and angle of the line do not change.

Specify the Length and Angle of the 
selected line.

Specify the X and Y coordinates of the 
line’s Start Point. Not available when 

the Start or Center Point is locked.

Specify the X and Y coordinates of the 
line’s End Point. Not available when 

the Center or End Point is locked.

The format used here can be changed by 
clicking the Num Style button. See “Dialog 
Number/Angle Style Dialog” on page 127.

Line Style Panel
The LINE STYLE panel is found in the 
specification dialogs for many different 

objects. The settings here control the 
appearance of the lines and/or arcs that make 

1

2

3

4
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up an object. Depending on the type of object 
selected, some settings may not be available. 

Line Options - 

• Check Show Border to display a border 
around the selected Picture file. Not 
available for other object types. See “Pic-
tures” on page 1141. 

• Specify the Layer that the selected object 
should be located on. Check Default to 
use the default layer for the selected 
object’s type or choose a layer from the 
drop-down list. If the selected object is an 
automatically generated dimension line, 
freize molding, or shadow board that has 
been edited, Default will be unchecked. 

• Click the Define button to open the Layer 
Display Options dialog. See “Layer Dis-
play Options Dialog” on page 149.

• Specify the line Color used to represent 
the selected object. Check By Layer to 
use the color assigned to the object’s 
layer or click the Color bar to select a 
different color. See “Color Chooser/
Select Color Dialog” on page 875.

• Specify the line Style used to represent 
the selected object. Check By Layer to 
use the line style assigned to the object’s 
layer or click the drop-down list or 
Library button to select a different style. 

1
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• Define the Line Weight (in pixels) or 
check By Layer to use the Line Weight 
assigned to the object’s layer.

Specify the desired Bumping behaviors 
for the selected object(s). These options 

are not available for Primitive objects or 
Wall Material Regions and only function 
when Bumping/Pushing is enabled. See 
“Bumping/Pushing” on page 221. 
• Check CAD Stops Move to bump the 

selected object into other CAD or CAD-
based objects as it is moved, and/or to 
push the other object(s). 

• Check Wall Stops Move to stop the 
selected object when it bumps into a wall. 
Walls cannot be pushed by other objects. 
Not available in layout files.

The Drawing Group options control 
how the selected object(s) display 

relative to other objects. Not available for 
Walkthrough Paths. See “Drawing Groups” 
on page 218. 
• Select Back Group to display the 

selected object(s) behind objects in the 
other two drawing groups.

• Select Default Group to display the 
selected object(s) in front of those in the 
Back Group but behind those in the Front 
Group.

• Select Front Group to display the 
selected object(s) in front of objects in 
the other two groups. 

• Check Move to Front of Group to dis-
play the selected object(s) in front of 

other objects in the same drawing group. 
Not available in defaults dialogs.

You can also move a selected object to 
the front of its drawing group by clicking 

the Move to Front of Group  edit 
button. See “Move to Front of Group” on 
page 219.

Select the desired Display Options. 
These options not available for CAD 

Box- or CAD Circle-based objects, or for 
Material Regions, North Pointers, or Sun 
Angles.
• Check Show Length to show the length 

of each line centered above the line. 
• Check Show Angle to show the angle of 

each line centered below the line. If the 
object is an arc, it’s radius will also dis-
play. 

The Length and Angle formats are speci-
fied in the CAD Defaults dialog. See 
“CAD Defaults Dialog” on page 1072.

• Uncheck All Angles to show only those 
angles that are neither horizontal nor ver-
tical. This is automatically checked when 
Show Angle is checked. 

• Check Reverse Angle to reverse the 
angle by 180°. This may be helpful when 
showing a line’s bearing, since the direc-
tion a line is drawn from start point to end 
point defines its bearing.

Setting the line weight to zero (0)
makes the line weight print as thin as

possible.

2

3

Note: “Move to Front of Group” is an action,
not an attribute. The box is not checked the
next time the specification dialog is opened,
and is not available in defaults dialogs at all..

4
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An additional Display Options setting is 
available In the Picture File, Metafile, and 
PDF File Box Specification dialogs. See 
“Pictures, Images, and Walkthroughs” on 
page 1133.
• Check Show Outline to display the 

selected object’s border polyline. 

Specify the Layout Page that the 
selected object(s) is located on. Only 

available in layout files, but not in defaults 
dialogs for objects such as callouts and 
markers. See “Layout” on page 1235. 

Arrow Panel
The ARROW panel is available for any line, 
arc, open polyline, or spline that can have an 
arrow: including dimension lines. The 
defaults for arrows are set in the Arrow 
Defaults dialog. See “CAD Defaults and 
Preferences” on page 1072 and “Dimension 
Defaults Dialog” on page 987. 

Lines with arrows can be attached to other 
objects. They attach to a closed polyline-

based object along its edges, but can attach to 
an architectural object anywhere within its 
2D symbol in floor plan view. If an arrow is 
attached to another object, deleting that 
object will also delete the arrow. 

Closed polylines, Sprinkler Lines and 
Electrical connections are examples of 
objects that cannot have arrows.

• Check Include Arrow to apply an arrow 
to the end of the selected object and 
enable the settings that follow. 

• Select an arrowhead Style from the drop-
down list or check Default to use the 
default arrowhead. Note that arrows with 
a white center have a transparent fill.

• Select the Fill Color used to fill the 
arrowhead or check Default to use the 
default fill color.

• Specify a Size for the arrow or check 
Default to use the default size. The 
Default Size value also affects the size of 
the start circle for Running Dimensions 

5
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. See “Running Dimensions” on page 
1008.

• Check Arrow on Both Ends to place an 
arrowhead on both ends of the selected 
object.

• Check Special Use Arrow to create an 
arrow that can be used in layouts and 
floor plan views to show platform eleva-
tions. See “Special Use Arrows” on page 
1053.

• Auto Position Tail is available when the 
tail end of the selected object is snapped 

to another object. Check this box to have 
the tail end update its position on the 
object it is snapped to if either object is 
moved. See “Auto Position Arrows” on 
page 1053.

• Auto Position Head is available when 
the arrowhead end of the selected object 
is snapped to another object. Check this 
box to have the arrow end update its posi-
tion on the object it is snapped to if either 
object is moved. 

Drawing Arcs - Arc Creation Modes
There are five Arc Creation Modes 
that control how arcs and arc-based 

objects are drawn. Each mode allows you to 
specify a different aspect of the arc, such as 
its radius or tangent. Select Edit> Arc 
Creation Modes to select a mode.

The program remembers the last creation 
mode used between sessions. Once drawn, 
all arcs are edited similarly. See “Editing Arc 
Based Objects” on page 191.

Before deciding which Arc Tool or Arc 
Creation Mode is best for the project at hand, 
it is helpful to be familiar with the different 
components that make up an arc.

• The center of an arc is the point the arc is 
drawn about.

• The radius is the distance from the center 
to the arc.

• The start is where the arc begins.
• The end is where the arc stops.
• The chord is the straight line between the 

start and end point.
• A straight line that intersects an arc and is 

perpendicular to the radius of the arc at 
that point is tangent to the arc.

Free Form Arc
Free Form Arc mode allows you to 
define an arc by clicking and dragging 

along the desired path. There are two 
methods for using this mode.

To draw a Free Form arc

1. Select CAD> Arcs> Draw Arc , 
then click at the arc’s start point. CenterRadius

ChordStart

End
Tangent
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2. Move the pointer along the desired 
curve while dragging to curve the arc.

3. Release the mouse button at the end 
point to complete the arc. 

To draw continuous Free Form arcs

This mode is useful for making custom 
revision clouds.

1. Select CAD> Arcs> Draw Arc .
2. Press the Alt key on your keyboard and 

click and drag to draw an arc. 
3. Move your cursor to a new location and 

click. A new arc is drawn that is con-
nected to the end point of the previous 
arc.

By default, this continuous drawing behavior 
will turn off when a closed shape is created. 
You can specify that this behavior remain on 
in the Preferences dialog. See “Behaviors 
Panel” on page 113.

Center/Radius/End Arc
Center/Radius/End Arc mode allows 
you to define the center and radius of 

an arc, and then its length.

To draw a Center/Radius/End arc

1. Select CAD> Arcs> Draw Arc , 
then click at the center of the arc and 
drag to define the radius. 

2. Release the mouse button, then move the 
mouse to the end of the arc and click 
again.

Start/End/On Arc
Start/End/On Arc mode allows you 
to define the start and end points of an 

arc, then adjust the curvature. 

To draw a Start/End/On arc

1. Select CAD> Arcs> Draw Arc , 
then click at the start point of the arc and 
drag to the end point. 

2. Release the mouse button at the end 
point.

3. Move the mouse to adjust the curvature 
of the arc, then click to release the 
mouse and create the arc.

Start/Tangent/End Arc
Start/Tangent/End Arc mode allows 
you to define the start and end points 

of an arc, its tangent and its curvature.

To draw a Start/Tangent/End arc

1. Select CAD> Arcs> Draw Arc , 
then click at the start of the arc and drag 
a line to define the arc’s tangent at the 
start point. 

2. Release the mouse button.
3. Move the mouse to adjust the length and 

curvature of the arc, then click to release 
the mouse and create the arc. 

Arc About Center
Arc About Center mode allows you 
to draw an arc by defining the center 

and then the start and end points. 
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To draw an Arc About Center 

1. Select CAD> Arcs> Draw Arc , 
then click once to define the center 
point. 

2. Click and drag from the start point of the 
arc to its end point.

3. Or, click and drag an arc. The Current 
Point is used as the center. See “The 
Current Point” on page 1078.

Arc Tools
Select CAD> Arcs to display the 
submenu of Arc Tools.

Draw Arc
The method used to draw an arc using 
Draw Arc depends on which Arc 

Creation Mode is currently active. Once 
drawn, an arc can be edited. See “Editing Arc 
Based Objects” on page 191.

Input Arc
An arc can be drawn to exact 
specifications using the New CAD Arc 

dialog. 

To use the Input Arc tool

1. Select CAD> Points> Place Point , 
then click the screen to place a CAD 
point. This is the Current Point, and will 
be the start point for the new arc. See 
“The Current Point” on page 1078.

2. Select CAD> Lines> Input Arc  to 
open the New CAD Arc dialog. 
The New CAD Arc dialog can also be 

opened by double-clicking the Arc 
Tools  parent button. 

3. If necessary, specify the Start Point.

4. Specify the method used to define the 
arc’s Direction, then define its angle. 

5. Specify the method used to define the 
arc’s Extension, or length, then define it. 

6. Click OK to close the dialog and draw 
the arc.

New CAD Arc Dialog

The X Position (horizontal) and Y 
Position (vertical) coordinates of the 

Start Point for the new arc display here. 
They can also be changed, if you wish.

1
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Specify how you want to define the 
arc’s Direction, then specify its angle.

• The Start Direction defines the angle of 
the tangent from the arc’s start point. 

• The Chord Direction defines the angle 
of the arc’s chord from the start point.

Define the Radius of the arc.

The Extension settings control the 
length of the arc. Define only one:

• The Arc Angle is defined by imaginary 
lines drawn from the arc center point to 
its two endpoints. 

• The Arc Length is the length of the arc 
along its curve from one endpoint to the 
other.

• The Chord Length is the length of an 
imaginary straight line drawn from one 
arc endpoint to the other.

Select the direction that the arc curves: 
either to the Right/Clockwise or to the 

Left/Counterclockwise.

Arc with Arrow
You can create an arc with an arrow on 
one or both ends, using the Arc With 

Arrow tool.

Draw an Arc With Arrow  like a regular 
arc. When you release the mouse button,  the 
arc has an arrowhead at the end. The default 
attributes of the arrow are determined by the 
settings in the  Arrow Defaults dialog. See 
“Arrow Defaults” on page 1029. 

As with regular arcs, arcs with arrows can be 
edited after they are created. See “Editing 
Arc Based Objects” on page 191 and “Arc 
Specification Dialog” on page 1093.

Continue to draw connected lines and arcs to 
form a polyline with an arrowhead at the end. 
The arrowheads display only at the free ends, 
not where the lines connect. See “Polylines” 
on page 1097.

2

Start Direction = 0° Chord Direction = 45°

3

4

Click the Number Style button to
change the units used in dialogs. See

“Dialog Number/Angle Style Dialog” on page
127.

Arc Angle = -90°

Chord Length = 
282 13/16

Arc Length = 314 3/16

Radius = 200

5
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Lines with arrowheads can also be created. 
See “Line With Arrow” on page 1083.

Arc Specification Dialog
Select an arc and click the Open 
Object edit button to open the Arc 

Specification dialog.

The settings on the ARC panel are also found 
on the SELECTED ARC panels for many 
objects.

Arc Panel

A line can be converted to an arc or vice
versa by selecting the line, pressing

and holding down the Alt key, then using the
edit handle at either end to bend the line.



1094

Chief Architect X8 Reference Manual

The Lock options control how 
changing properties on this dialog 

affects the arc. 
• Start - Select this option to keep the start 

fixed when changing the arc, chord, or 
end.

• End - Select this option to keep the end 
fixed when changing the arc, chord, or 
start.

• Center - Select this option to keep the 
center of the arc fixed when changing the 
arc.

• Arc - Select this option to keep the arc 
fixed when changing the arc location.

• Chord - Select this option to keep the arc 
chord fixed when changing the arc 
radius.

Arc - These parameters define the arc. 
Various controls are disabled depending 

on what lock option is used.
• Center X Point - Specify the X coordi-

nate for the center of the arc.
• Center Y Point - Specify the Y coordi-

nate for the center of the arc.
• Radius - The distance between the center 

of the arc and the arc surface.

• Start Angle - Specify the angle that a line 
drawn from the arc center to the arc start 
makes with a horizontal line to the right.

• End Angle - Specify the angle that a line 
drawn from the arc center to the arc end 
makes with a horizontal line to the right.

• Arc Angle - The angle between the cen-
ter of the arc and each end.

• Arc Length - The length of the arc along 
the curve.

• Uncheck Automatic Facet Angle to 
specify the Facet Angle, which is the 
angle at which the surfaces of a curved 
3D object are broken in 3D views. The 
default value is 7.5°; a smaller value pro-
duces a smoother curve while a larger 
value may generate more quickly in 3D 
views. These settings are only available 
on the SELECTED ARC panel for some 
CAD-based architectural objects such as 
Slabs. See “Architectural vs CAD 
Objects” on page 160. 

Start Point - These values define the 
start point of the arc. The Position 

settings are disabled when the Start is locked.
• Start X Position - Specify the X coordi-

nate for the beginning of the arc.

1

2

3
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• Start Y Position - Specify the Y coordi-
nate for the beginning of the arc.

• Start Direction - Specify the angle of a 
tangent line at the start of the arc.

End - These values define the end point 
of the arc. The Position settings are 

disabled when the End is locked.
• End X Position - Specify the X coordi-

nate for the end of the arc.
• End Y Position - Specify the Y coordi-

nate for the end of the arc.
• End Direction - Specify the angle of a 

tangent line at the end of the arc.

Chord - These values define the chord 
of the arc.

• Chord Length - The straight line dis-
tance between the two ends of the arc.

• Chord Angle - Specify the angle of the 
chord (the imaginary straight line going 
from the start of the arc to the end of the 
arc).

Line Style Panel
For information about the LINE STYLE panel, 
see “Line Style Panel” on page 1085.

Arrow Panel
For information about the ARROW panel, see 
“Arrow Panel” on page 1088.

Circle Tools
Select CAD> Circles to access the 
Circle Tools.

Circles
Draw a Circle by dragging across the 
diameter. If a small circle is needed, 

draw a larger circle and then resize it. 

Use the Circle Specification dialog to 
accurately define size, position and other 
attributes. See “CAD Circle/Oval/Ellipse 
Specification Dialog” on page 1096.

Draw Circle About Center
Select CAD> Circles>  Circle About 
Center to create a circle by dragging 

the radius out from the center point. 

To draw a Circle About Center

1. Click the Circle About Center  tool.
2. Click the screen to define the center.
3. Drag the radial distance and release the 

mouse button. If you are using Object 
Snaps , both the center point and the 
radius snap to any appropriate nearby 
CAD object, intersection or point.

4

5
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Ovals
An Oval is a four-arc approximation 
of an ellipse. To draw an oval, select 

CAD> Circles> Oval, then click and drag. 

Use the CAD Oval Specification dialog to 
accurately set the length and width of the 
oval and other attributes.

Ellipses
An Ellipse is a set of points with a 
constant combined distance from two 

points called foci. An ellipse looks like a 
stretched circle, or a circular surface viewed 
at an angle. 

To draw an ellipse, select CAD> Circles> 

Ellipse  and drag at an angle to define its 
maximum height and width.

Use the CAD Ellipse Specification dialog to 
accurately set the length and width of the 
ellipse and other attributes. 

CAD Circle/Oval/Ellipse Specification Dialog
Select a circle, oval or ellipse and 
click the Open Object edit button to 

open the CAD Circle, Oval or Ellipse 
Specification dialog.

The CAD Circle, Oval, and Ellipse 
Specification dialogs are almost exactly the 
same. The Oval and Ellipse Specification 
dialogs have an additional setting for Angle 
on the GENERAL panel. 

General Panel

Specify the position of the circle, oval 
or ellipse’s Center Point. 

• Specify the X Position and Y Position of 
the center of the circle, oval or ellipse.

1
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• Specify an oval or ellipse’s Angle. Not 
available for circles. 

Size - Specify the Length and Width 
of an oval or ellipse, or the Diameter 

and Radius of a circle.

Line Style Panel
For information about the LINE STYLE panel, 
see “Line Style Panel” on page 1085.

Fill Style Panel
For information about the FILL STYLE panel, 
see “Fill Style Panel” on page 1099.

Polylines
A polyline consists of two or more 
line and/or arc segments that are 

attached at their endpoints. Select CAD> 
Boxes> Rectangular Polyline, then click 
and drag from corner to corner to create a 
rectangular-shaped, closed polyline. A 
closed polyline measuring 2’x 2’ (600 mm x 
600 mm) can also be created by clicking 
once while the Rectangular Polyline tool is 
active.

When Object Snaps  and Connect CAD 
Segments  are enabled, you can also 
create a polyline by drawing lines and/or arcs 

end-to-end, allowing the end of each new 
object to snap to the end of the previous one. 
See “Edit Behaviors” on page 178.

Line- and arc-based objects will only snap 
together to form a polyline if they are on the 
same layer and share identical attributes such 
as color, line style, and arrow specifications. 

If one end of the polyline is connected to the 
other, it becomes a closed polyline. Closed 
polylines can be assigned a fill pattern and/or 
turned into special 3D objects such as slabs 
or countertops that display in 3D views. 

Lines and polylines can be distinguished by 
the edit handles that display when you select 
each. A line displays an edit handle at each 

end and one in the middle. If more than three 
edit handles display, the object is a polyline.

2

Closed Polylines Open Polylines
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Lines that appear connected to a polyline 
may prove to be unconnected when selected. 

For example, the two polylines in the 
following image appear identical until their 
left edges are selected. The polyline on the 
left reveals that its left edge is not attached. 
In contrast, the left edge of the polyline on 
the right is part of the larger polyline unit.

The Close Polyline  edit tool can be used 
to connect the edges of an open polyline. 
This tool adds a segment between the two 
open ends, closing the gap between them. 
See “Using Close Polyline” on page 201.

Polylines can be copied, moved, reshaped, or 
resized as a single unit. Additionally, the 
individual segments can be edited. See 
“Disconnect Edges” on page 184.

Once created, polylines can be edited in a 
variety of ways. See “Editing Open Polyline 
Based Objects” on page 196 and “Editing 
Closed-Polyline Based Objects” on page 
201.

Polyline Holes
Closed CAD Polylines and a variety of 
closed polyline-based architectural objects 
can contain one or more holes. See “Polyline 
Holes” on page 206.

Polyline Specification Dialog
Select an open polyline, closed 
polyline, spline, Sprinker polyline, or 

Electrical connection and click the Open 
Object edit button to open the Polyline 
Specification dialog. 

Polyline Panel
The POLYLINE panel is found in the 
specification dialogs for a variety of objects 
throughout the program. It states: 
• The Length of an open polyline-based 

object; 

• The Perimeter of a closed polyline-
based object; 

• The Area of a closed polyline-based 
object; 

• The Volume of a closed polyline-based 
object.

If the polyline is not closed, the Area and 
Volume are described as “Not closed”. The 
Volume of a 2D polyline will always be 0, 
even if it is closed.  

If the selected object is a closed polyline and 
has any Holes in it, they will be subtracted 

Line

Polyline

Unconnected Connected
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from the Area value and, if applicable, from 
its Volume. See “Polyline Holes” on page 
206. 

If multiple objects of the same type are 
selected, their total Length/Perimeter, Area, 
and Volume are stated.

Spline Panel
The SPLINE panel has a single option and is 
only available when the selected object is a 
spline.  See “Splines” on page 1106. 

New Segment Angle - Specify the angle 
between line segments that are used to draw 
the spline. Specifying a smaller angle makes 
the spline smoother. Specify a larger angle to 
draw the spline faster.

Selected Line Panel
The SELECTED LINE panel is available when 
the selected edge of the polyline is a line as 
opposed to an arc and is not available if the 

selected object is a spline. See “Editing Line 
Based Objects” on page 187.

Moving the Start of a line segment moves the 
end of the previous connected line, if there is 
one. Similarly, moving the End of a line 
segment moves the start of the next 
connected line, if there is one. 

This panel is similar to the LINE panel of the 
Line Specification dialog. See “Line Panel” 
on page 1084. 

Selected Arc Panel
The SELECTED ARC panel is available when 
the selected segment of the polyline is an arc 
as opposed to a line. It is not available if the 
selected object is a spline. 

This panel is similar to the ARC panel of the 
Arc Specification dialog. See “Arc Panel” 
on page 1093.

Line Style Panel
This panel is similar to the LINE STYLE panel 
in the Line Specification dialog. See “Line 
Style Panel” on page 1085.

Fill Style Panel
The information on the FILL STYLE panel for 
closed polylines is similar to that for many 
other objects in the program, including 
closed CAD shapes and a variety of 
architectural objects. 

The FILL STYLE panel is not available for 
Sprinkler Lines or Electrical Connections as 
these tools cannot be used to form closed 
shapes. 
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Specify the characteristics of the 
selected object’s fill Pattern. When 

“None” is the selected pattern Type, the rest 
of these settings are disabled. 
• Choose a pattern Type from the drop-

down list. If “Custom” is selected, the 
Custom Pattern options become available 
below.

• Specify the Spacing of the selected fill 
pattern. Not available for “Solid” fill.

• Specify the Angle of the selected fill pat-
tern. Not available for “Solid” fill.

• Set the Line Weight for the selected fill 
pattern. Not available for “Solid” fill.

• Check Transparent Pattern Back-
ground to make the spaces between fill 
pattern lines transparent, allowing any 
objects behind the fill pattern to be visi-

ble through it. Not available for “Solid” 
fill.

• Specify the Color of the lines that make 
up the fill pattern, or the fill color of 
“Solid” fill, by clicking the color bar. The 
layer color is used by default. See “Color 
Chooser/Select Color Dialog” on page 
875.

Select Use Background Color to use the 
background color for solid fills or patterns.

Check Use Layer Color to have the fill 
pattern use the layer color for the pattern 
lines. If it is a solid fill, the fill color is the 
same as the layer’s color.
• Use the Transparency slider bar or text 

field to control how transparent the fill 
pattern lines are. This setting also affects 
the transparency of Solid fill colors. 

1
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A preview of the selected pattern displays to 
the right. As changes are made to the settings 
on this panel, the preview will update.
• Choose a Preview Width from the drop-

down list. This value controls how large 
an area the preview represents. The 
selected value indicates the length of 
each side of the preview in actual plan 
inches (mm).

The Custom Pattern section is only 
enabled when “Custom” is selected 

from the Fill Pattern list.
• Click the Browse button to open the 

Custom Pattern File dialog and select a 
pattern (.pat) file from the Chief Archi-
tect Patterns directory or a custom .pat 
file elsewhere on your computer. The 
selected .pat file’s path name displays 
and can be edited in the text field.

• Select a Pattern from the drop-down list. 
This list includes all custom patterns 
available in the selected file.

• Specify a Scale for the selected Custom 
pattern. This setting affects all instances 
of the pattern in the current plan or layout 
file - not just in the selected object(s).

Arrow Panel
The ARROW panel is available for most open 
polylines and splines and is similar to the 
ARROW panel of the Line Specification 
dialog. See “Arrow Panel” on page 1088. 

The ARROW panel is not available for closed 
polylines, Sprinkler Lines, or Electrical 
Connections. 

Label Panel
Labels for CAD polylines display when the 
“Polylines, Labels” layer is turned on and 
use the Text Style assigned to that layer. See 
“Text Styles” on page 1061. 

For more information about the settings on 
this panel, see “Label Panel” on page 1280. 

Box Tools
Select CAD> Boxes to access the Box 
Tools.

Rectangular Polyline
A Rectangular Polyline can be drawn 
in either of two ways:

• Click in the drawing area to place a 24” x 
24” square polyline at that location.

• Click and drag from corner to corner to 
draw a rectangle of any size. 

Once created, a rectangular polyline can be 
edited into any shape or converted to a 3D 
object. See “Editing Closed-Polyline Based 
Objects” on page 201.

Regular Polygon
You can draw a regular polygon based 
on the length of a side, or the length of 

the radius to a vertex or a side. Select your 
options in the New Regular Polygon dialog 
and click OK. Click in your plan to place the 
polygon.

2
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The settings in this dialog are similar to those 
in the Polygon Shaped Rooms dialog. See 
“Polygon Shaped Rooms and Decks” on 
page 274.

Box
Draw a 2D box from the midpoint of 
one side to the midpoint of the 

opposite side. The sides of a box can be 
resized, but a box always has four 90° 
corners.

Boxes have some unique editing behaviors. 
See “Editing Box-Based Objects” on page 
206.

Cross Box
Use the Cross Box tool to create a 2D 
box with an X-shaped cross in the 

interior to represent framing in a cross 
section detail.

In cross section/elevation views, Cross 
Boxes are used to represent joists and rafters 
members that are perpendicular to and cut by 
the camera’s clip plane. See “Cross Section/
Elevation Views” on page 902. 

Blocking Box
Use the Blocking Box tool to create a 
2D box with a diagonal line in the 

interior to represent blocking or bridging in a 
cross section detail.

Insulation
Use the Insulation tool to draw 
insulation in cross section details. 

Insulation Boxes are like 2D boxes and Cross 
Boxes; however, unlike these other types of 
boxes, Insulation Boxes do not have 
perimeter lines: only the curves of the 
insulation pattern. 
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Box Specification Dialog
Select a CAD box, a framing box, a 
wall bridging box, a cross box, a 

blocking box, or an insulation box and click 

the Open Object edit button to open the Box 
Specification dialog. See “Box Tools” on 
page 1101.

General Panel

Specify a Box Style. Select Normal to 
specify a normal box, Cross to specify 

a cross box, or Insulation to specify an 
insulation box. If multiple CAD boxes are 
selected, “No Change” may display. 

Define the Position of the box. 

• Specify the X Position and Y Position of 
the center of the box.

• Specify the Angle of the box.

Define the Size of the box by 
specifying its Height and Width.

Line Style Panel
For information about the LINE STYLE panel, 
see “Line Panel” on page 1084.

Fill Style Panel
For information about the FILL STYLE panel, 
see “Fill Style Panel” on page 1099.

1

2

3

To find out which direction is the height
and which is the width of a square box,

select it. The triangular rotate handle is near-
est the side you originally dragged from when
creating the box. Changing the height
changes the length of this side.
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Revision Clouds
The Revision Cloud tool allows you 
to draw a closed polyline with a series 

of arcs or bulges displaying along each edge. 
Select CAD> Revision Cloud, then click 
and drag to draw a rectangular shape with 
edges that display a series of arcs. 

There are several additional ways to create a 
Revision Cloud:

• Click and drag using the Alternate  
edit mode to draw the first edge, then 
click to define the end points of subse-
quent edges. Click on the start point of 
the first edge to finish drawing the cloud. 

The Revision Cloud  tool is still 
active until you select a different tool. 
See “Alternate” on page 179. 

• Create Revision Clouds around one or 
more selected objects in floor plan view 
by clicking the Revision Cloud(s) 
Around Objects  edit button. A sepa-
rate revision cloud will be drawn around 
each selected object. This edit tool is also 
available for CAD objects, text, and 
dimensions in cross section/elevation 
views, but not for architectural objects.

• Convert a closed CAD polyline into a 
Revision Cloud. See “Convert Polyline 
Dialog” on page 239.

Revision Clouds are drawn based on the 
settings in the Revision Cloud Defaults 

dialog and are initially placed on the layer 
specified there. Unlike other CAD objects, 
they are not placed on the Current CAD 
Layer. See “Displaying CAD Objects” on 
page 1107.

Once created, Revision Clouds can be 
selected and edited much like other closed-
polyline based objects. See “Editing Closed-
Polyline Based Objects” on page 201.

Unlike other closed polylines, however, the 
edges of a Revision Cloud can only be seen 
when it is selected. When it is not selected, 
only the arcs along its perimeter are visible. 

The arcs along a Revision Cloud are not its 
actual edges and cannot be individually 
selected, although you can control their size 
and frequency. 

 If you wish to individually edit the arcs, 
convert it to a plain polyline. See “Convert to 
Plain Polyline” on page 241.

Revision Cloud Specification Dialog
Select one or more Revision Clouds 
and click the Open Object edit button 

to open the Revision Cloud Specification 
dialog.

Not Selected Selected
Only arcs are visible Edges are also visible
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The settings in the Revision Cloud Defaults 
dialog are similar to those in the Revision 
Cloud Specification dialog, but determine 

the initial settings of revision clouds as they 
are drawn. See “CAD Defaults and 
Preferences” on page 1072.

Cloud Panel

Specify how the arcs on the selected 
revision cloud(s) are sized.

• Select Automatic Arc Lengths to have 
the program automatically size the 
selected cloud’s arcs.

• Select Average Arc Length to specify 
the selected cloud’s average arc length, 
which is measured along its chord.

• Select Number of Arcs, then specify the 
number of arcs on the selected cloud.

Use the slider bars or text fields to 
specify the Size Variation of the 

selected cloud’s arcs. 
• Specify the Length Diversity, which is 

the maximum amount that a given arc’s 
length can deviate from the Average Arc 
Length, specified above.

• Specify the Minimum Bulge, which is 
the smallest amount that a given arc can 
extend out from its center. 0% allows arcs 
with a radius of 0, essentially flat lines; 
50% allows 180° arcs, or half-circles; 
100% only allows arcs of about 300°.

• Specify the Maximum Bulge, which is 
the largest amount that a given arc can 
extend out from its center. 100% allows 
arcs of about 300°;50% allows 180° arcs; 
0% only allows arcs with a radius of 0.

Selected Line Panel
The SELECTED LINE panel is available when 
the selected cloud edge is a line as opposed 
to an arc. See “Selected Edge” on page 184.

Moving the Start of a line segment moves the 
end of the previous connected line, if there is 

1

2
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one. Similarly, moving the End of a line 
segment moves move the start of the next 
connected line, if there is one.

This panel is similar to the LINE panel of the 
Line Specification dialog. See “Line Panel” 
on page 1084.

Selected Arc Panel
The SELECTED ARC panel is available when 
the selected segment of the cloud edge is an 
arc as opposed to a line. 

This panel is similar to the ARC panel of the 
Arc Specification dialog. See “Arc Panel” 
on page 1093.

Line Style Panel
This panel is similar to the LINE STYLE panel 
in the Line Specification dialog. See “Line 
Style Panel” on page 1085.

Fill Style Panel
This panel is similar to the FILL STYLE panel 
in the Polyline Specification dialog. See 
“Fill Style Panel” on page 1099.

Splines
A Spline is a curve that passes 
smoothly through a set of points. 

Splines are typically used in situations where 
there is an irregular curve. A contour line is a 
typical example. Splines are useful wherever 
a free-flowing curve is needed.

Once created, splines can be selected and 
edited. See “Editing Spline Based Objects” 
on page 209 and “Polyline Specification 
Dialog” on page 1098.

To use the Spline tool

1. Select CAD> Spline .
2. Click and drag to draw the first spline 

segment just as you would a line. A sin-
gle spline segment looks identical to a 
line, in fact. You may need to turn off 

Angle Snaps  to draw freely.

3. Draw the second segment from the end 
of the first at a different angle. Object 
Snaps  should be on to assure that 
new segments attach correctly to the 
ends of previous segments.

4. As soon as two straight spline segments 
connect end-to-end, the straight seg-
ments become a curve that passes 

As drawn

Result
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through the endpoints defined by the 
original segments. Each point is called a 
vertex. 

5. Draw a few more segments, connecting 
each to the free end of a previously 
drawn segment.

6. Notice as additional segments are drawn 
that the spline changes the curvature of 
the previous segment to create a contin-
uous curve between the last three points.

7. Form a closed spline by drawing a seg-
ment between its two free ends.

8. The result is an irregular curve that 
flows smoothly through each vertex.

Spline-based objects will only snap together 
to form a single spline if they are on the same 
layer and share identical attributes such as 
color, line style, and arrow specifications.

You can also convert an open or closed 
polyline into a spline using the Convert to 
Spline  edit tool. See “Convert to Spline” 
on page 234.

Displaying CAD Objects
As with architectural objects, the display of 
CAD objects is controlled in the Layer 
Display Options dialog. See “Layer Display 
Options Dialog” on page 149.

CAD objects can be drawn in floor plan 
view, CAD Details, layout, and cross section/
elevation views. They are 2D objects only, 
though, so they cannot be seen in any view 
other than the one they are drawn in and are 
never visible in camera views or overviews. 

See “Architectural vs CAD Objects” on page 
160.

Current CAD Layer
When drawn, most CAD objects are 
automatically placed on the Current 

CAD Layer. In floor plan and cross section/
elevation views, the name of this layer 
displays on the right side of the Status Bar at 

As drawn

Result

As drawn

Result

Draw segment to close

Result
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the bottom of the screen. See “The Status 
Bar” on page 42.

Initially, the “CAD, Default” layer is set as 
the Current CAD Layer, but this can be 
changed at any time in any of several ways:
• In the CAD Defaults dialog. See “CAD 

Defaults Dialog” on page 1072.
• By selecting CAD> Current CAD 

Layer  from the menu. See “Select 
Layer Dialog” on page 153.

• Activate a different Annotation Set. See 
“Annotation Sets” on page 80. 

Revision Clouds are placed on the layer 
specified in the Revision Cloud Defaults 
dialog - not on the Current CAD Layer. See 
“Revision Clouds” on page 1104.

Annotation Sets
The Current CAD Layer is among the items 
associated with Annotation Sets, which are 
groups of Saved Defaults that can be 
customized and activated for specific 
drawing tasks. See “Annotation Sets” on 
page 80.

Show Length and Angle
You can specify that line segment length and 
angle display along a CAD line, CAD arc, or 
along each segment of a CAD polyline. If the 
segment is an arc, its radius also displays. 
See “Line Style Panel” on page 1085.

The format of the length and angle can be 
specified in the CAD Defaults dialog. See 
“CAD Defaults Dialog” on page 1072.

Line length and angle indicators use the Text 
Style assigned to the layer that their CAD 
object is on. See “Text Styles” on page 1061. 

Endcaps
Dashed lines often display endcaps, which 
are dashes of a particular length. You can 
specify the Printed Length of endcaps in the 
Preferences dialog. See “CAD Panel” on 
page 109.

Line Styles
A selection of line styles is available in the 
Library Browser which you can apply to both 
CAD and architectural objects. See “The 
Library” on page 819.

If you do not see a line style that meets your 
needs, you can create your own custom line 
styles. 

Line Styles
The Line Styles library contains line styles 
that be applied to objects individually in their 
specification dialogs, by default in their 
defaults dialogs, or by layer in the Layer 
Display Options dialog. See “Line Style 

Panel” on page 1085 and “Layer Display 
Options Dialog” on page 149. 

If an object has a line style that includes text, 
that text will use the font and transparency 

Changing the Current CAD Layer
affects subsequently-drawn objects, but

existing CAD objects are unaffected by the
change. As a result, you can efficiently pro-
duce CAD drawings on multiple layers
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setting of the Text Style assigned to the layer 
that the object is on. See “Text Styles” on 
page 1061.

The MEP Toolbar Configuration  
includes a selection of toolbar buttons that 
access line styles from the library.  

You can draw a line with a selected style 
directly from the library. See “Line Tools” on 
page 1080. 

To draw with a line style from the library

1. Select a line style in the selection pane 
of the Library Browser. See “The 
Library Browser” on page 820.

2. Click and drag in a 2D view to produce a 
CAD line with the selected style.

You can also apply line styles to the Place 
Library Object  button. See “Place 
Library Object Button” on page 838.

Additional line styles can be imported into 
the library. 

To import line styles

1. Locate a line style and copy its file to a 
convenient location on your hard drive. 
These files have the extension .lin. Pre-
vious versions of Chief Architect used 
the .dat format, which also works.

2. Select File> Import> Line Style Defi-
nitions .

3. Browse to the location where you saved 
the .lin file.

4. Click Open to add the line style to the 
library.

In addition, you can create custom line styles 
for use in Chief Architect. See “Creating 
Line Styles” on page 1109.

Creating Line Styles
The Line Style Specification dialog 
allows you to create new line styles 

for use in Chief Architect. To open this 
dialog, select CAD> Lines> Create Line 
Style or right-click on an unlocked library 
folder and select New> Line Style. See 
“Adding Library Content” on page 829. 

You can also edit an existing line style by 
copying it to a User library, then right-
clicking on it and selecting Open from the 
contextual menu. See “Using the Contextual 
Menus” on page 822. 

Note: Line styles created using the Line Style
Specification dialog are not retained in views
exported to .dxf/.dwg. See “Exporting 2D
DXF/DWG Files” on page 1179.
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Line Style Specification Dialog

Line Style Name - Type the name of 
your custom line style in the text field. 

This is the name that will be listed in the 
Library Browser. 

A preview diagram of the line style 
displays here. 

• Click on a line style component in the 
preview to select it and edit it below.

• Check Highlight Selection to display a 
red rectangle around the currently 
selected line style component.

• Check Mark Repeating Segments to 
display vertical dashed lines indicating 
the division between the last component 
of one segment and the first component 
of the next in the preview diagram. 

These options allow you to add new 
components to your line style.

• Click the Dash button to add a line seg-
ment to the line style.

• Click the Dot button to add a single point 
to the line style.

• Click the Text button to add a section of 
text to the line style.

• Select the Insert Before radio button to 
add the new component before the com-
ponent that is currently selected.

• Select the Insert After radio button to 
add the new component after the cur-
rently selected component.

A list of the line style’s individual 
components displays here. 

1

2

3

4
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• Click on the name of a component in the 
list to select it. When Highlight Selec-
tion is checked, above, a red rectangle 
displays around this component in the 
preview diagram.

• Click the Up arrow to move the selected 
component up one position in the list and 
one position to the left in the preview dia-
gram.

• Click the Down arrow to move the 
selected component down one position in 
the list and one position to the right in the 
preview diagram.

• Click the Remove button to remove the 
selected component from the line style.

Control the appearance of the selected 
component.

• Specify the Length of a selected Dash or 
Text component. If the Length exceeds 
that required by a Text component, empty 
space is added on each side of the text.

• Specify the Spacing of the selected com-
ponent by defining the length of an empty 
space to the component’s right.

• Type the Text of a selected Text compo-
nent. 

• Specify the Text Height of a selected 
Text component. Each text component 
can have its own height.

CAD Blocks
A CAD block is a group of 2D CAD objects, 
text objects, and/or dimensions that have 
been grouped together so that they behave as 
a single object. A CAD block can also 
contain other CAD blocks: these are referred 
to as “nested”.

CAD blocks can be imported into the 
program and can also be added to the library. 
See “Importing and Exporting” on page 
1167.

Dimension lines can only be included in a 
CAD block if they reference objects that are 
also included in the block. They will 
continue to inherit their attributes from the 
saved Dimension Defaults that they were 
associated with before the CAD block was 

created. See “Dimension Defaults Dialog” 
on page 987. 

With the exception of a few CAD-based 
objects such as slabs, custom countertops 
and framing, CAD blocks cannot contain 
architectural objects. Such objects can 
instead be blocked as architectural blocks. 
See “Architectural Blocks” on page 811.

CAD blocks can be selected, moved, rotated 
and resized much like CAD boxes. They can 
also be exploded into their individual parts. 
See “Editing Box-Based Objects” on page 
206.

A list of the CAD blocks present in the 
current file is available in the CAD Block 
Management dialog. See “CAD Block 
Management” on page 1114.

5

Text inserted into a line style uses the
font and transparency setting of the Text

Style of the layer that it is on when assigned
to an object. See “Text Styles” on page 1061. 
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Make CAD Block
To create a CAD block, group select 
two or more eligible objects, and then 

click the Make CAD Block edit button. See 
“Marquee Select” on page 185.

Eligible CAD block component objects 
include:
• CAD objects
• Text objects
• Dimension lines
• CAD blocks
• CAD-based objects such as Slabs, Fram-

ing, and Custom Countertops.

If the Make CAD Block edit button is not 
available, then the selection set may contain 
an object that is not an eligible CAD block 
component. 

Explode CAD Block
When a block is selected, click the 
Explode CAD Block edit button to 

separate it into its individual components. 

If a CAD block includes nested blocks, these 
nested blocks are not exploded. 

When a selected CAD block is exploded, its 
definition is not affected: only the instance. 
See “CAD Block Management” on page 
1114.

If a block has been resized so that its original 
aspect ratio is altered, it cannot be exploded.  
See “CAD Block Specification Dialog” on 
page 1115.

Select Insertion Point
By default, a CAD block has one 
insertion point located at its center. 

When placing the CAD block in a drawing or 
moving it to a new location, you can snap its 
insertion point to some other snap point for 
accuracy. See “Object Snaps” on page 162. 

In some cases, it may be helpful to position a 
CAD block using an insertion point other 
than its center. For example, a CAD block 
representing a bolt or other fastener may be 
better positioned using the bottom center of 
its head or washer rather than its center. You 

can use the Select Insertion Point  edit 
button to replace the insertion point at the 
center with a different point.

To select an insertion point

1. Make sure that Object Snaps  are 
enabled, then select the CAD block.

2. Click the Select Insertion Point  edit 
button.

3. Click at the location where you would 
like the insertion point.

The available snap points on a CAD block 
are located around the perimeter of its 
bounding box. If you need a different point, 

place a temporary CAD Point  at that 
location, and then snap to it when creating 
the insertion point. 

A CAD block’s Move edit handle displays at 
the location of its insertion point. If you 
place an insertion point at the midpoint of 
one of the bounding box edges, the Move 
edit handle may display instead of the Resize 

For information about snapping an
Insertion Point to a CAD block’s sub-

objects, see “Exploding and Modifying a CAD
Block” on page 182 of the User’s Guide. 
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handle. CAD blocks also rotate about their 
insertion point.

A CAD block’s insertion point can also be 
specified relative to the blocks’ center point 
in the CAD Block Specification dialog. See 
“General Panel” on page 1115.

Add to Library
Like a variety of other objects, CAD 
blocks can be added to the library for 

future use in other files. See “Adding Library 
Content” on page 829.

Many manufacturers provide CAD details in 
DXF/DWG format. These drawings can be 
imported, blocked and added to the library. 
See “Importing 2D Drawings” on page 1170. 

If a CAD block contains an object on a 
custom layer or one that inherits properties 
from a Saved Dimension Default or Saved 
Text Style and that CAD block is placed 
from the library into a plan or layout file:
• That Saved Default, Text Style, or layer 

will be created in the destination file if it 
does not already exist. 

• If a Saved Default, Text Style, or layer 
with the same name does exist in the des-
tination file, the object will inherit its 
attributes from the existing settings.

See “Multiple Saved Defaults” on page 77 
and “Layers” on page 143.

Custom 2D Symbols
In floor plan view, 3D symbols and images 
are represented by 2D CAD blocks. 

You can specify the CAD block used by a 
symbol in its Symbol Specification dialog. 
See “2D Block Panel” on page 1199. 

The CAD block used by images and plant 
images is specified in the Image 
Specification dialog. See “Image Panel” on 
page 1138. 

If you do not see an existing CAD block that 
suits your needs, you can create your own. 
For best results, follow these guidelines:
• The CAD block should have the same X 

and Y dimensions as the 3D symbol. An 
incorrect CAD block size will result in 
inconsistent placement of your symbol.

• It is usually best to build your CAD block 
with solid filled properties. This keeps 
background patterns and other objects 
from showing through. See “Fill Style 
Panel” on page 1099.

• So that your custom CAD block can be 
easily identified, it is best to give it a 
name in the CAD Block Specification 
dialog. See “General Panel” on page 
1115. 

CAD blocks that have nested blocks
within them cannot be assigned to 3D

objects or to images. 
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CAD Block Management
A list of all CAD blocks present in the 
current plan or layout file can be 

accessed by selecting CAD> CAD Block 
Management. 

CAD Block Management Dialog
An alphabetical list of all CAD block 
definitions saved in the current file displays 
here. CAD blocks definitions that currently 
have no instance anywhere in the file may 
also be included. 

• Click on a CAD Block Name in the list 
to select it. The selected item is high-
lighted in blue.  

• CAD Block definitions with at least one 
instance in the current file have a check-
mark in the In Use column.  

• Unused CAD block definitions with no 
instances in the current file have no check 
mark after their names. 

• Select a block in the list, click the Insert 
button, then click in the current view to 
place an instance of the block into that 

view. Not available for blocks marked for 
deletion. 

• Select a block from the list, then click 
Rename to specify a new name for it. 
Not available for blocks marked for dele-
tion.

• Press the Purge button to delete any 
unused block definitions from the list. 

• Select an unused block from the list and 
click the Delete button to remove it from 
the list. 

• Check Automatically Purge CAD 
Blocks to remove unused CAD block 
definitions fromthe current file. When 
this is unchecked and all instances of a 
CAD block are removed from the current 
file, its definition will continue to be 
saved in the file and will be listed here.

CAD Block Definition
There are two aspects to each CAD block: 
• The block definition, which holds infor-

mation about the block’s component 
objects.

• The block instance, which holds informa-
tion about its position, orientation, size, 
aspect ratio and other settings specific to 
an individual block placed in a file. 

All instances of a given CAD block can have 
unique positions and sizes; however, the 
block definition that they share is the same 

Note: The CAD blocks associated with
default electrical symbols cannot be deleted,
even if no objects are present in the plan. 
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regardless of the floor, view, or layout page 
that they display in. 

Copying a block instance to a completely 
different file also copies the block definition 
to that file.

If all instances of a CAD block are deleted 
from a file, its definition will remain saved 
with the file. To control file size, it is a good 
idea to regularly purge files of unused CAD 
blocks or have the program do it for you 
automatically. Both options are available in 
the CAD Block Management dialog.

CAD Block Specification Dialog
Select one or more CAD blocks and 
click the Open Object edit button to 

open the CAD Block Specification dialog.

General Panel

Name and Copyright - Specify the 
CAD Block’s name. Not available 

when multiple CAD blocks are selected. If 

the CAD block has a copyright, information 
about it displays here. 

1
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This name is included in the CAD Block 
Management dialog and is used when you 
export the block via DXF/DWG, and is also 
imported with DXF/DWG block definitions. 

Unlike other settings in this dialog, which 
affect only the selected instance of the block, 
changing the name modifies the actual block 
definition. See “CAD Block Management” 
on page 1114.

Specify the Position and angle of the 
selected CAD block instance.

• Specify the X and Y Positions, which are 
the coordinates of the CAD block’s inser-
tion point.

• Specify the Angle at which the CAD 
block instance is placed.

Line/Fill Style - Specify how line and 
fill styles are applied to the selected 

CAD block instance.
• Select By Block to use the line and fill 

styles specified for the selected CAD 
block instance.

• Select By Object to use the line and fill 
styles of the individual objects in the 
selected CAD block instance.

New block instances use to By Block unless 
Use ‘By Object’ when creating new CAD 
blocks is checked in the Preferences dialog. 
See “CAD Panel” on page 109.

Specify the Size of the selected CAD 
block instance.

• Check Retain Aspect Ratio of x to retain 
the original ratio between the CAD 
block’s Height and Width. This only 
affects changes made in the dialog: it 
does not affect editing using the edit han-
dles. If a block is resized so that its aspect 
ratio is changed, it cannot be exploded. 
See “Explode CAD Block” on page 1112.

• Specify the Height of the selected CAD 
block instance.

• Specify the Height Factor, which is the 
ratio of the current height of the CAD 
block instance to its original height.

• Specify the Width of the selected CAD 
block instance.

• Specify the Width Factor, which is the 
ratio of the current width of the CAD 
block instance to its original width.

Specify the location of the selected 
CAD block instance’s Insertion Point 

(Relative to Center). These offset values use 
the CAD block instance’s coordinate system 
rather than that of the drawing area, so if the 
block is rotated, its insertion point will 
remain in the same location relative to the 
block itself. See “Select Insertion Point” on 
page 1112.
• Specify the X Offset, the horizontal dis-

tance of the insertion point relative to the 
CAD block’s center point.

• Specify the Y Offset, the vertical dis-
tance of the insertion point relative to the 
CAD block’s center point. 

If you assign a name that is used by
another CAD block in the current file,

the definition of the other block is overwritten.

2

3

4

Note: If the Height and Width Factors are set
to different values, the selected CAD block
instance cannot be exploded and ovals and
arcs within it may appear distorted.

4
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Line Style Panel
Many of the settings on the LINE STYLE 
panel are only available if By Block is 
selected on the GENERAL panel of this 
dialog. For information about this panel, see 
“Line Style Panel” on page 1085.

Fill Style Panel
The settings on the FILL STYLE panel are 
only available if By Block is selected on the 
GENERAL panel of this dialog. For 
information about these settings, see “Fill 
Style Panel” on page 1099.

If Always use “By Object” for CAD block 
fill style is checked in the Preferences 
dialog, the settings on this panel are not used. 
See “CAD Panel” on page 109.

CAD Details
CAD Details are special view windows for 
drawing, saving and organizing 2D drawings 
associated with the current plan or layout 
file, such as site plans and cross section 
details. They are listed in the CAD Detail 
Management dialog as well as in the Project 
Browser and can be created in both 
locations, as well. See “Project Browser” on 
page 1125.

Like other views, CAD Details are saved in 
the file they are created in and can be printed. 
If saved with a plan file, a CAD Detail can 
also be sent to layout. See “Sending Views to 
Layout” on page 1240.

2D CAD information can be copied into or 
out of a CAD Detail window using the group 
select and copy functions. See “Copying and 
Pasting Objects” on page 170.

A new CAD Detail window can be created in 
the CAD Detail Management dialog as well 
as in the Project Browser. See “Project 
Browser” on page 1125.

CAD Detail Management Dialog
Select CAD> CAD Detail Manage-
ment to open the CAD Detail 

Management dialog. 

An alphabetical list of all CAD Details in the 
current file displays here.  
• Click on a CAD Detail Name in the list 

to select it. The selected item is high-
lighted in blue. 

• If a CAD Detail is currently open, it will 
have a checkmark in the Open column.  

• Click New to open the Create New CAD 
Detail dialog:
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• Type a short, descriptive name for the 
CAD Detail, click OK, and a new CAD 
Detail view window opens. 

• To rename an existing CAD Detail, select 
it and click Rename. Type a new name 
for it in the Rename CAD Detail dialog 
and click OK.

• To delete a CAD Detail from the list, 
select it and then click Delete. An auto-
matically generated Truss Detail cannot 
be deleted if there are trusses present in 
the current plan. See “Truss Details” on 
page 621.

• To open an existing CAD Detail, select it 
and click Open. CAD Details that are 
presently open have a checkmark to the 
right of their name.

Special CAD Details
Some CAD details are created automatically 
by the program. If any roof or floor trusses 
are present in your plan, the program creates 
a Truss Detail that includes an editable 
diagram of each truss type used and a count 
of each. See “Truss Details” on page 621.

When walls are framed using the Build 
Framing dialog, a Wall Detail is created for 
each wall. These details are listed in the 
Project Browser and are also accessible by 
selecting a wall and clicking the Open Wall 
Detail  edit button. Wall Details are not 
listed in the CAD Detail Management 

dialog. See “The Library Browser” on page 
820. 

CAD Detail from View
CAD> CAD Detail from View 
converts the current view into a 2D 

CAD drawing composed of editable CAD 
objects. 

CAD Detail from View  is available in 
all line-based views, including floor plan 
view and any 3D view using the Vector View 
rendering technique. See “Rendered and 
Vector Views” on page 888.

A CAD Detail created using CAD Detail 
from View  inherits a variety of settings 
from the original view, including: 
• The layer set used by the original view. 

See “Layer Sets” on page 146.
• When the original view is a layout page 

with one or more layout boxes, a new 
“Layout Box Export Contents” layer is 
created for the contents of the layout 
boxes. See “Layout” on page 1235. 

• The Dimension Defaults settings used 
by the original floor plan or cross section/
elevation view. See “Dimension Defaults 
Dialog” on page 987.

• The rotation of the original view. See 
“Rotate Plan View” on page 237.

• Any text objects using a specific Text 
Style in the original view will maintain 
the same settings in the CAD Detail; 

Note: CAD Details created using CAD Detail
from View are not dynamically linked to the
original view. Changes made to the view do
not update in the detail or vice versa.
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however they will use a Custom Text 
Style. 

Camera views and overviews do not have 
Dimension Defaults, so the defaults for 
floor plan view are inherited by CAD Details 
created from these types of views. 

Plot Plans and Plan Footprints
Using the CAD Tools and conventional 
survey information, you can create an 
accurate plot plan in floor plan view or a 
CAD Detail. See “Creating a Plot Plan” on 
page 190 of the User’s Guide.

A plot plan can be sent to layout and 
included in working drawings. See 
“Dynamic Views” on page 1243.

A plot plan can also be converted into a 
terrain perimeter, allowing you to add 
elevation data and accurately position 
buildings for 3D modeling of home and lot.

Plan Footprint
Select CAD> Plan Footprint to 
create a CAD object representing the 

building footprint in a CAD Detail window. 
Once the Plan Footprint appears in the detail 
window, you can control what information 
displays.

To create a Plan Footprint

1. Open the floor plan view of the plan you 
want to create a plan footprint from.

2. Select CAD> Plan Footprint . The 
program creates a new CAD Detail with 
the footprint of the current floor. 

•  By default, this new CAD Detail uses 
the Plan Footprint layer set. You can 
control what displays in the footprint 

using the Layer Display Options dia-
log. See “Layer Sets” on page 146.

•  You can also control the appearance of 
a Plan Footprint in the Plan Footprint 
Specification dialog. See “Plan Foot-
print Specification Dialog” on page 
1120.

To insert a plan footprint in a CAD Detail

1. Open the CAD Detail in which you want 
to insert a Plan Footprint.

2. Select CAD> Plan Footprint . 
3. Select the floor to use from the drop-

down list and click OK.

4. The floor plan appears in the CAD 
Detail window. Select Window> Fill 
Window  to center the footprint on 
screen. 

5. The footprint can be rotated and moved 
anywhere in the window.

If the model consists of several buildings, a 
footprint is created for each. Moving one 
footprint automatically adjusts all the 
footprints in order to maintain their 
relationship. 
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If you edit a plan using Reverse Plan  or 

the Edit Area  tools, the plan footprint 
updates automatically. 

Dimension lines can be drawn to locate the 
edges of a plan footprint polyline. Note that 
if changes to the plan cause the plan footprint 
polyline to update, any dimension lines that 
locate it may be deleted as a result. See 
“Dimensions” on page 985.

Layer Display Options
When you create a plan footprint by selecting 

CAD> Plan Footprint  while in floor 
plan view, the default layer set for plan 

footprints is used.  See “Layer Set Defaults” 
on page 147.

When a plan footprint is created by selecting 

CAD> Plan Footprint  while in a CAD 
Detail, the current layer set is used. See 
“Layer Set Management” on page 147.

Regardless of the layer set in use, the 
appearance of objects in a Plan Footprint is 
controlled in the Layer Display Options 
dialog. Individual objects are on the same 
layer as in floor plan view, while the entire 
Plan Footprint is on the “CAD, Default” 
layer. See “Layer Display Options Dialog” 
on page 149.

Plan Footprint Specification Dialog
Select a plan footprint and click the 
Open Object edit button to open the 

Plan Footprint Specification dialog for the 
selected plan footprint. 

General Panel

• Select the Floor Used for Plan Foot-
print from the drop-down list. 

• Check Display Footprint Polyline to 
draw a polyline around the perimeter of 
the footprint. This polyline may not be 
visible if you also have Display Plan 

Details checked.This option must be cho-
sen if you want to use a fill pattern or 
specify a line style.

• Check Display Plan Details to show the 
walls and other details as they appear in 
floor plan view.
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• Check Use Current Layer Set to Dis-
play to control what displays in the foot-
print using Layer Display Options. If you 
uncheck this box, you lose control of 
what displays and the program makes the 
determination for you. 

Polyline Panel
The POLYLINE panel states the plan footprint 
polyline’s Perimeter and its Area. See 
“Polyline Panel” on page 1098.

Line Style Panel
The settings on the LINE STYLE panel will 
not affect the appearance of the plan 

footprint  unless Display Footprint Polyline 
is checked on the GENERAL panel.

For information about using the LINE STYLE 
panel, see “Line Style Panel” on page 1085.

Fill Style Panel
The settings on the FILL STYLE panel will not 
affect the appearance of the plan footprint  
unless Display Footprint Polyline is 
checked on the GENERAL panel.

For more information about the FILL STYLE 
panel, see “Fill Style Panel” on page 1099. 
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Chapter 35:

Project Management

The tools described in this chapter allow you 
to track the time you spend on plans, 
eliminating guesswork and making billing 
easier.

Others let you draw plans with ease and 
flexibility, run checks on plans so you can be 
more confident that they are free of common 
drawing errors, and consider loan 
calculations for your projects.

Chapter Contents
•      Time Tracker
•      Time Log Dialog
•      Project Browser
•      Project Information
•      Space Planning
•      Room Box Specification Dialog
•      Plan Check
•      Loan Calculator

Time Tracker
The Time Tracker tool monitors the 
time spent on each Chief Architect 

file. You can enter start and end times each 
time a plan or layout file is opened and 
closed, or allow it to run automtically.  The 
Time Tracker keeps a log that can be 
amended and edited as needed. 

Select Tools> Time Tracker> Start 
Time Logging to begin logging time 

for the current plan or layout file. This 
creates a new entry. Opening a plan or layout 
automatically starts a time log if you set your 

preferences to do so. See “Time Tracker 
Panel” on page 107. 

Select Tools> Time Tracker> Stop 
Time Logging to stop logging time 

for the current file. Only available when an 
entry is currently being recorded.

Select Tools> Time Tracker> View 
Time Log to open the Time Log 

dialog and view the time log for the current 
file. 
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Time Tracker information is stored with each 
file and can be printed or exported from the 
Time Log dialog.

You can control how Time Tracker  
functions, including its timeout period, in the 

Preferences dialog. See “Time Tracker 
Panel” on page 107.

Time Log Dialog
The Time Log dialog displays all 
entries logged for the current plan or 

layout file. Entries can be added, deleted, 
edited, exported, and printed. 

Select Tools> Time Tracker> View Time 
Log  to open the Time Log dialog.

A summary of current plan or layout 
file’s Log Entries displays here. Click 

in a row to select that entry.
• Click the Add button to add a new entry 

using the current time as the Start Time.
• Select an entry and click the Delete but-

ton to remove it from the current file.

• Click Export to open the Save Time Log 
dialog and specify a name and destination 
for the exported file. Time log informa-
tion can be exported as either a text (.txt) 
or Comma Separated Values (.csv) file. 
See “Exporting Files” on page 58.

Time Tracker logs times for each plan
and layout file separately, even if they

have the same project name or are saved in
the same directory on your computer.

1
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• Click Print to open the Print dialog and 
print the log. See “Print View Dialog” on 
page 1226.

The Selected Entry settings let you 
modify the entry selected in the list 

above. 
• The default User name is derived from 

the Preferences dialog. You can select 

an entry and change the User here. See 
“Time Tracker Panel” on page 107. 

• The Start and End times can be edited by 
typing new values in the text fields. You 
can also click the drop-down list and 
select a date from the calendar. The Start 
time must predate the End time. See 
“Region and Language Settings” on page 
75. 

• The Duration of the selected entry and 
the Total Duration display for reference.

• Notes about the selected entry can be 
typed into the text field on the right.

Project Browser
The Project Browser is a convenient 
way access to all of the views and 

Materials Lists saved with an open plan and 
all of the pages saved in an open layout. You 
can dock it to the top, bottom, or side of the 

Chief Architect window or let it float freely. 
To open the Project Browser, select View> 
Project Browser. See “View and Side 
Windows” on page 35.

If you have multiple plan and/or layout
files associated with a particular project

and wish to bill them together, export your
Time Logs to another application and then
combine them.

2
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The name of an open plan file displays 
here.

• All CAD Details saved with the plan are 
listed here. Right-click on the folder to 
create a new CAD Detail. See “CAD 
Details” on page 1117.

• All Cameras and overviews saved with 
the plan are listed here by floor. See “3D 
View Tools” on page 897.

• All saved Cross Sections and elevation 
views are listed here. 

• All Floors in the plan are listed here, 
including the Foundation and Attic. See 
“Multiple Floors” on page 435.

• All Materials Lists saved with the plan 
are listed here. See “Materials Lists” on 
page 1283.

• All Wall Details saved with the plan are 
listed here by floor. See “In Wall Detail 
Views” on page 605. 

The name of an open layout file 
displays here. See “Layout Page 

Management” on page 1259.
• Any CAD Details saved with the layout 

are listed here. See “CAD Details” on 
page 1117.

• Any pages that are in use in an open lay-
out display here, in numeric order. See 
“In the Project Browser” on page 1259. 

Using the Contextual Menu
Items in the Project Browser can be 
accessed, modified and organized using the 
contextual menu. To access  its contextual 
menu, simply right-click on an item. See 
“Contextual Menus” on page 38. 
• All folder level items with contents in 

them have Expand All and Collapse All 
in their contextual menus. 

• All views and pages can be accessed by 
selecting Open View or Show Page, 
respectively. You can also open a view or 
page by double-clicking on its name.

• All views aside from Floors and layout 
Pages can be Renamed. 

• All views aside from Floors and layout 
Pages specified as Templates can be 
Deleted. See “Page Templates” on page 
1236. 

• New Pages can be Inserted Before or 
After a selected layout Page. 

  Undocked Project Browser

1

2
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• A New CAD Detail can be created in the 
CAD Details folder. 

Project Information
Information about the current project, the 
client it is drawn for, and the registered Chief 
Architect user can be inserted into text 
objects to improve organization and clarity in 
your documents. See “Text Macros” on page 
1064.

Some of this information can also be 
included when exporting information to 
REScheck. See “Export to REScheck” on 
page 1192.

Designer Information
Designer Information is initially 
populated by registered user 

information, such as name and address, that 
was entered when the software installation 
was registered. This information is saved in 
the Default Designer Information dialog. 
which can be accessed through the 
Preferences dialog. See “Text Panel” on 
page 97.

If you would like to customize the Designer 
Information for a particular file, select 
Tools> Project Information> Designer 

Information  to open the Designer 
Information dialog. 

Enter information in each text field exactly 
as you want it to display when the 
corresponding text macro is used. See “Text 
Macros” on page 1064.

Client Information
Select Tools> Project Information> 
Client Information to open the 

Client Information dialog. This dialog is 
similar to the Designer Information dialog, 
but its specifications apply to Client text 
macros. This information must be filled out 
seperately for plan files and layout files.

Registered User Information
Registered User information corresponds to 
the information that was given when the 
current Chief Architect installation was 
registered and cannot be modified without 
reinstalling and registering the program.

Space Planning
The Space Planning Tools are a time-
saving way to create a preliminary 

room-by-room design of a home without 
getting caught up in the details. Once the 

shape and layout of the rooms are finalized, 
the Build House tool converts them into a 
working plan that can be edited and detailed 
to completion.

When entering new Client Information,
begin by clicking the Clear Form button.
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Space Planning Assistant
Select Tools> Space Planning> 
Space Planning. The Space 

Planning Assistant leads you through a 
series of windows that gather information 
about the rooms you want to include in your 
house. When you click Finish, the selected 
room boxes display.

Room boxes can now be arranged into a floor 
plan. 

Placing Room Boxes
In addition or as an alternative to the room 
boxes created for you by the Space 
Planning Assistant, you can create your 
own room boxes. To do so, select Tools> 
Space Planning , then choose the desired 
room type from the submenu. Click in floor 
plan view to place a room box of the selected 
type at that location. 

Displaying Room Boxes
Room boxes and their labels are located on 
the “Space Planning Boxes” layer. Space 
Planning Box labels use the Text Style 

assigned to that layer, as well. See 
“Displaying Objects” on page 144. 

Editing Rooms
Once created, room boxes can be edited in a 
variety of ways.

• Select room boxes using the Select 
Objects  tool just like other objects in 
Chief Architect. See “Selecting Objects” 
on page 183.

• Room boxes can be resized, rotated, and 
rearranged. See “Editing Box-Based 
Objects” on page 206.

• Try to line up the rooms so that they are 
just touching. Excessive overlaps may 
cause your rooms to form incorrectly. 
Closets are the exception. You can over-
lap a room with a closet, or place in 
inside another room box.

• Rooms can be copied and pasted using 

the Copy/Paste  edit button and 

deleted using the Delete  edit button.

• Select Tools> Space Planning  or 
click the Space Planning Configuration 
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 button to access the room box tools 
and place additional room boxes in your 
plan. Select a tool and click in the plan to 
place a room box of that type. 

• Select Tools> Space Planning> Toggle 
Room Boxes  or click the toggle but-
ton to hide or show the room boxes.

Build House
When the rooms are in place, select Tools> 
Space Planning> Build House  to 
convert the rooms into a building model. 
Walls and doors are inserted between the 
rooms that you arranged. 

When you Build House, the “Space Planning 
Boxes” layer is automatically turned off. The 
room boxes that you created are not deleted, 
however. 

Multiple Floors
If you specified a two-story house, follow 
these steps:

1. Edit and arrange the room boxes on 
Floor 1 as desired.

2. Select Tools> Space Planning> Build 
House  tool to create the walls on the 
first floor.

3. Go Up One Floor  and notice that 
the positions of the walls on Floor 1 dis-
play in red as a reference.

4. Arrange the rooms on Floor 2 as desired, 
using the reference display as a guide.

5. On the second floor, select Tools> 
Space Planning> Build House  to 
complete the second floor.

Room Box Specification Dialog
Select one or more room boxes and 
click the Open Object edit button to 

open the Room Box Specification dialog.
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General Panel
Most of the settings on the GENERAL panel 
are used when the selected room box is 

converted to a room using the Build 
House  tool. 

Specify the selected room box’s Room 
Type and Name. 

• Select a Room Type from the drop-down 
list. See “Room Types” on page 335. 

• If you wish, uncheck Use Room Type, 
then specify a custom Room Name for 
the selected room box. 

Specify the Size of the selected room 
box. 

• Specify the room box’s Width and 
Height. 

• Specify the Fillet Radius, which is the 
radius of the curve on each of the room 
box’s corners. Unlike the other settings 

on this panel, this value does not affect 
the shape of the room created using Build 
House . 

Line Style Panel
The settings on the LINE STYLE panel are 
available for a variety of other objects in the 
program. For information about these 
settings, see “Line Style Panel” on page 
1085.

Fill Style Panel
For information about the settings on this 
panel, see “Fill Style Panel” on page 1099.

Plan Check
Plan Check checks the floor of your 
plan currently shown on screen for 

anything that appears to violate common 

building practices. Plan Check may not find 
all the problems in a plan, but does it point 
out areas that may need improvement. 

1

2
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As your plan evolves, a number of things that 
may become incorrect can be fixed using 
Plan Check. For example, doors that change 
from exterior to interior as you add new 
rooms are redrawn without the threshold line 
that marks an exterior door. A cabinet, 
fixture or furniture item that is against a wall 
because the wall was moved into it, as 
opposed to the item moving, are attached to 
the wall.

To run Plan Check, select Tools> Checks> 
Plan Check .

Plan Check Dialog

The current error number, along with the 
total number of errors found, is stated at the 
top of the dialog.

A description of the current error displays in 
the field on the left.

Options for navigating Plan Check are found 
on the right side.

• Click Next to ignore the current error and 
proceed to the next.

• Click Previous to return to the previous 
error.

• Click Hold to suspend Plan Check so you 
can fix the current error. Select Tools> 
Checks> Plan Check again and the 
check starts where it left off.

• Click Done to terminate Plan Check.

Potential plan errors found are usually 
highlighted in floor plan view. To ensure the 
highlighted item is on-screen, make sure the 
entire plan is shown in the window before 

you run Plan Check .
If this dialog obscures the floor plan view, 
drag its title bar to move it. It remembers its 
new position and displays there the next time 

Plan Check  is run.

Room Types

Plan Check  can do a much better job of 
checking for problems if it knows what the 
rooms in your plan are to be used for, so you 
should assign a Room Type to each room in 
your plan. See “Room Types” on page 335.

The first time Plan Check  runs in a plan, 
it automatically assigns a room type to as 
many undesignated rooms as it can. Some 
rooms are determined by their size and 
shape, and others by their contents. For 
example, a shelf in a small room indicates a 
closet; a stove or refrigerator indicates a 
kitchen; or a bed, a bedroom. If the program 

cannot assign a room type, Plan Check  
highlights it and suggests that you do so 
manually. 

Disclaimer: The Plan Check feature in
Chief Architect compares your plan with

common building practices. Plan Check does
not claim to detect all building code and
design requirements. Always have your plans
checked by a licensed professional before
beginning actual construction.
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Loan Calculator
Select Tools> Loan Calculator to 
open the Loan Calculator dialog. This 

dialog lets you calculate different aspects of 
a loan for the current plan based on a variety 
of parameters. 

Specify what aspect of the loan you 
would like to calculate from the 

Calculate drop-down list:
• Monthly Payment 
• Loan Amount 
• Term 
• Interest Rate 

The calculation Result, based on the 
information you provide, displays here.

If you make changes to any of the fields in 
the dialog, click the = button to refresh the 
Result.

The Required Fields are the same as 
the options in the Calculate drop-down 

list. The option selected under Calculate will 
be inactive under Required Fields.
• Specify the desired Loan Amount.
• Specify the desired Term, in years.
• Specify the desired Interest Rate.
• Specify the desired Monthly Payment.

The Optional Fields allow you to 
include additional information in your 

loan calculation. 
• Specify the expected Property Taxes per 

year. 
• Specify the expected Homeowner’s 

Insurance cost per year. 
• Specify the expected Private Mortgage 

Insurance (PMI) cost per year.
• Specify the cost of any expected Other 

Fees.

When Monthly Payment is calculated, each 
Optional value is divided by twelve (months) 
and then added to the total payment.

When a Calculate option other than Monthly 
Payment is selected, these values are divided 
by twelve (months) and then subtracted from 
the specified Monthly Payment value. The 
result, which does not display, is then used to 
determine the Loan Amount, Term or Interest 
Rate.

1

2

3
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Chapter 36:

Pictures, Images,
and Walkthroughs

Chief Architect uses picture files in a variety 
of ways to enhance your drawings. 

The Library Browser contains images of real 
world objects like plants and vehicles that 
can display in 3D views.

Picture files can also be imported into Chief 
Architect and shown in most views. 

You can save any view using a variety of 
picture file formats. In addition, Chief 
Architect allows you to create virtual tours 
that can be saved as .avi files, shared with 
others, and played back later.

Chief Architect can also generate ray trace 
images from a Standard rendered view for 
photo-realistic rendering capabilities. Ray 
tracing is discussed in its own chapter. See 
“3D Rendering” on page 933.

Chapter Contents
•      Picture Files vs Pictures and Image Objects
•      Images
•      Displaying Images
•      Editing Images
•      Image Specification Dialog
•      Pictures
•      Picture File Box Specification Dialog
•      Metafiles
•      Metafile Box Specification Dialog
•      PDF Files
•      PDF Box Specification Dialog
•      Displaying Pictures, Metafiles, and PDF 

Boxes
•      Editing Pictures, Metafiles, and PDF Boxes
•      Copy Region as Picture
•      Creating Screen Captures
•      3D Backdrops
•      Walkthroughs
•      Walkthrough Path Specification Dialog
•      Creating VRML Files
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Picture Files vs Pictures and Image Objects
In common computer language, picture files, 
pictures and images are more or less 
synonymous. In the Chief Architect 
environment, however, there are some 
notable differences between these terms.

In Chief Architect, a two dimensional image 
file such as a .bmp, .jpg, .gif, or .png is 
referred to as a picture file or an image file. 
Examples of these files are saved on most 
computers and can be opened in a variety of 
applications. 

A Picture, on the other hand, is a file that has 
been imported into the program. Pictures can 
be imported into floor plan view, cross 
section/elevation views, CAD details, and 
layout pages. They are two-dimensional only 

and do not display in camera views or 
overviews. 

An Image object is also based on a picture 
file, but it does display in both 2D and 3D 
views. Images have 3D width and height data 
associated with them, as well as a 2D symbol 
which displays in floor plan view. 

Picture files have additional uses in Chief 
Architect, as well:
• Backdrops are picture files that display 

behind 3D views. See “3D Backdrops” 
on page 909.

• Textures are picture files that realistically 
represent materials in 3D views. See 
“About Materials” on page 848. 

Images
Images add realistic detail to 3D views 
without adding many surfaces to the 

model. For example, a tree image with a 
single surface can be used instead of a tree 
symbol with thousands, dramatically 
improving realism without compromising 
drawing time.

There are two types of Images in Chief 
Architect: 

• Images  rotate so that they always 
face the camera in 3D views.

• Billboard Images  do not rotate to 
face the camera. An example of when 
this may be useful is an image of a trellis, 
which might look awkward when facing 
a camera from a side view. 

Placing Images
A selection of Images are available in 
the Library Browser. Select one and 

click in a floor plan view, camera view or 
overview to place it. See “Placing Library 
Objects” on page 836.

Creating Images
Custom Images can be added to the 
Library Browser, as well as created in 

plan files. Chief Architect can use any image 
with a *.bmp, *.jpg, *.png, *.gif, *.tif, 
*.pcx, or *.tga extension.

Generally, .png files work best as Images 
because this format has good compression 
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and allows for the Image to contain 
transparency information.

To create an Image in floor plan view 

1. In floor plan view, select Build> 
Image> Create Image  or Billboard 
Image  to open the Image 
Specification dialog. See “Image Speci-
fication Dialog” on page 1137.

2. On the IMAGE panel:
• Click the Browse button to select a pic-

ture file on your computer or enter the 
path to a valid picture file in the Image 
File field.

• Select a 2D Plan Symbol from the drop-
down list or click the Library button 
and select a CAD block or symbol from 
the library. The selected symbol repre-
sents the image in floor plan view. See 
“Image Panel” on page 1138.

• Specify the Size and Position of the 
image. 

3. Specify transparency information on the 
TRANSPARENCY panel. 

4. Click OK to close the Image 
Specification dialog.

5. Click to place the new Image in floor 
plan view. 

To create an image in the Library Browser 

1. In the Library Browser, right-click on an 
unlocked folder.

2. Select New> Image from the contextual 
menu to open the Image Specification 
dialog. 

3. Browse to the image file you want to 
add and select your other options. See 

“Image Specification Dialog” on page 
1137.  

4. Once created, the image is listed in the 
library folder that you right-clicked on. 
Size and other data is saved. 

Using Paste Image
You can also import an image by first 
copying it to the system clipboard, 

then navigating to a Chief Architect window 
and selecting Edit> Paste> Paste from the 
menu, or by using the Screen Capture tools. 
See “Paste Special” on page 173 and 
“Creating Screen Captures” on page 1154. 

Converting a Folder 
of Images

A folder of image files can be 
converted into Image objects and 

added to the library all at once, saving the 
effort of converting them individually.

To convert a folder of images

1. Select Build> Image> Create Image 
Library .

2. In the Select an Image Folder dialog, 
select a folder of image files to convert 
and click OK. 

3. A new library with the same name and 
directory structure as the converted 
folder is listed in the Library Browser. 
Depending on the number of images in 
the folder, this may take a few moments.
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Displaying Images
The display of images in floor plan 
and 3D views is controlled in the 

Layer Display Options dialog. See 
“Displaying Objects” on page 144.

Images are placed on the”Images” layer by 
default but can be moved to other layers once 
they have been created. See “Image 
Specification Dialog” on page 1137.

In Floor Plan View
In floor plan view, most images are typically 

represented by an Image  symbol. You 
can specify a different symbol to represent an 
image if you wish. See “Image Specification 
Dialog” on page 1137. 
Any 2D CAD block from the library can 
represent an image object. If you do not see a 
CAD block that suits your needs, you can 
create one or import one from another 
application. See “Custom 2D Symbols” on 
page 1113. 

In 3D Views
The actual picture associated with an image 
object can be seen in 3D views, as can any 
transparency data associated it. See “Image 
Specification Dialog” on page 1137.

Images can be set to either rotate so that they 
always face the camera or remain stationary, 
like billboards. See “Images” on page 1134. 

You can choose to turn off the display of 
images in 3D views in the Preferences 
dialog. See “Render Panel” on page 123.

In Layout
The symbols representing images in floor 
plan view, whether 2D symbols or CAD 
blocks, can display on a layout sheet and be 
printed or plotted. See “Sending Views to 
Layout” on page 1240.

Editing Images
Images can be selected in 2D and 3D views 
and edited using the edit handles, edit tools 
and the Image Specification dialog. See 
“Image Specification Dialog” on page 1137.

Using the Mouse
In floor plan view, a selected image rotated, 
moved, and resized. In 3D views, a selected 
image only has one edit handle: the circular 
Resize handle. 
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When an image is resized using the edit 
handle, its aspect ratio is retained and 2D 
symbol resizes proportionally.

Using the Edit Toolbar
A selected image or images can be edited in a 
variety of ways using the buttons on the edit 
toolbar. As with most objects, images can be 
copied, replicated, moved, deleted, etc. See 
“The Edit Toolbar” on page 37.

Image Specification Dialog
Select an image and click the Open 
Object edit button to open the Image 

Specification dialog. 

You can also open this dialog by right-
clicking on an image in an unlocked library 
and selecting Open from the contextual 
menu.
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Image Panel

General information about the selected 
Image can be specified here.

• The Image File associated with the 
Image can be specified. Click Browse to 
choose a file saved on your computer or 
type the file’s full pathname in the text 
field. 

• Select a 2D Plan Symbol from the drop-
down list to represent the Image in floor 
plan view. See “Displaying Images” on 
page 1136.

• Click the Library button to choose a 
CAD block from the library to act as the 
Image’s 2D symbol. See “Select Library 
Object Dialog” on page 838.

Specify the Size of the image as it 
displays in 3D views.

• Enter a Height for the selected image. 

1

Note: Images cannot be assigned a 2D Plan
Symbol that contains a nested CAD block.
See “CAD Blocks” on page 1111.

2
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• Enter a Width for the selected image. 
• Uncheck Retain Aspect Ratio of X if 

you would like to modify the Height or 
Width without affecting the other value. 
If you do this, the image may appear dis-
torted. 
This checkbox does not affect editing 
performed outside of this dialog and is an 
action rather than a state: the next time 
you open this dialog, it will be checked.

• Click Reset Original Aspect Ratio of to 
reset the image’s original aspect ratio and 
remove any distortion caused by resizing.

Specify the location of the selected 
image’s Center Point.

• Position the selected image precisely by 
specifying its X and Y Coordinates.

• Specify the image’s Height Above 
Ground.

• Select the Elevation Reference from the 
drop-down list. This determines where 
the next two settings are measured from 
and also affects their setting labels.

• Specify the height to Top, measured from 
the selected Elevation Reference to the 
top of the image.

• Specify the height to Bottom, measured 
from the selected Elevation Reference to 
the bottom of the image.

Specify the appearance of the Block 
Line/Fill Style of the image’s 2D 

symbol in floor plan view. Only available 
when a CAD block from the library is 
selected as the image’s 2D Plan Symbol.
• Select Use Image Settings to use the 

image’s line style, which is set by layer, 
and its fill style, which is None (Trans-
parent).

• Select Use Block Settings to use the 2D 
CAD block’s line and fill styles. See 
“Custom 2D Symbols” on page 1113.

Options - 

• Check Reverse Image to reflect the 
appearance of the image about an imagi-
nary vertical line through its center. 

• Check Image Always Faces Camera to 
prevent the image from rotating to face 
the camera in 3D views. This box is 
unchecked for Billboard Images. See 
“Images” on page 1134. 

Any Copyright information associated 
with the selected Image will be stated 

here. 

A preview of the selected Image 
displays here. The Glass House 

Rendering Techniques is not available for 
images. See “Dialog Preview Panes” on page 
41. 

Transparency Panel
The settings on the TRANSPARENCY panel let 
you specify portions of the selected image as 
transparent.

3

4

5

6

7
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• Click the Use Transparency From The 
Image File radio button to use any trans-
parency data included in the image file.

• Click the Use Custom Transparency 
Color radio button to specify a color in 
the image to represent the transparency 
and enable the settings below. 

• Click the Color box to select a color in 
the Select Color dialog. See “Color 
Chooser/Select Color Dialog” on page 
875.

• Use the slide bar or enter a value to spec-
ify a level of Tolerance to be applied to 
colors that are almost the same as the 
specified transparency color. 

• Move your pointer over the small pre-
view image below. The pointer changes 
to an eyedropper and a magnified pre-
view displays to its right. Click to select 
the color of the pixel your pointer is over 
as the Transparency color. The selected 
color displays in the Color box, below.

• A magnified preview of the area in the 
preview image above displays here, 
allowing for accurate pixel selection.

The Transparency Color
If the portion of the image file that you wish 
to use contains the transparency color, that 
part of the image also becomes transparent. 
If this happens, the image may appear 
partially disintegrated.

You may need to experiment to find the best 
transparency color and tolerance for the 
image.

Layer Panel
For information about the settings on this 
panel, see “Layer Panel” on page 154.

Note: The  image preview will display its orig-
inal orientation, even if Reverse Image is
checked on the Image panel.
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Fill Style Panel
For information about the settings on this 
panel, see “Fill Style Panel” on page 1099.

Pictures
A variety of picture file types can be 
imported into and exported out of Chief 
Architect. 

Metafiles are also types of picture files that 
can be imported and exported. See 
“Metafiles” on page 1145.

Exporting Pictures
There are several ways to save a picture of a 
view in Chief Architect:

Using the Export Picture tool is 
similar to creating a screen capture of 

everything  in the current view window. 
Pictures can be saved in various file formats 
and used in other applications. 

Export Picture  is best suited for 
rendered and Ray Trace views. When 
exporting a line-based view, best results can 
be achieved by saving it as a Metafile. See 
“To export a metafile” on page 1146.

The Copy Region as Picture  tool also 
lets you create a picture file based on the 
current view, but allows you to specify what 
portion of the view is exported. See “Copy 
Region as Picture” on page 1153.

The current view can be saved as a PDF file 

or printed using the Print Image  tool. 
See “Print Image Dialog” on page 1229.

The Screen Capture tools offer another way 
to create a picture file based on the current 
view. See “Creating Screen Captures” on 
page 1154. 

To export a picture

1. Open the view that you would like to 
export as a picture file. 

2. Zoom, pan or otherwise adjust the view 
so that what you see on screen suits your 
needs. See “Displaying 3D Views” on 
page 907.

3. Select File> Export> Export Picture 
(BMP, JPG, PNG)  to open the 
Export Picture dialog, below, and spec-
ify the desired image size and other 
properties.

4. In the Export Picture File dialog, which 
opens next, give the file to be exported a 
name, file type, and location. See 
“Exporting Files” on page 58. 
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Export Picture Dialog

Specify the exported file’s Image Size 
in pixels or inches (mm).

• Check Use Active Window Size to 
export the picture at the same size as the 
active view window. The window’s 
Width and Height are described below: if 
those values are changed, this box 
becomes unchecked automatically. Not 
available in floor plan view, CAD Detail 
windows, or layout.

• Select either Pixels or Units as the 
method by which the picture’s dimen-
sions are measured.

• Specify the Width and Height of the 
image. The initial values correspond to 
the view window’s size. In floor plan 
view and CAD Details, they display for 
reference only.

• Specify the Resolution of the image. 
Select Dots/Inch or Dots/mm from the 
drop-down list.

• Uncheck Retain Aspect Ratio if you 
would like to modify the Height or Width 
without affecting the other value. Leave 

this box checked to prevent the image 
from becoming distorted.

Additional Image Properties can be 
specified.

• Specify the Line Weight Scale, which 
controls line thickness in Rendering 
Techniques that have a Line Thickness 
setting views. Not available if another 
Rendering Technique is active. This 
value is a multiplier: if you specify a 
scale of 2.0, lines will be twice as thick as 
in the original view. Increasing the Line 
Weight Scale may be useful when a large 
Image Size is specified. Values between 
1.0 and 10.0 are allowed. See “Rendering 
Technique Options” on page 954.

• Check Transparent Background to pro-
duce alpha transparency in the spaces 
between all objects that can be seen in the 
current view. Transparency associated 
with Fill and Text Styles is retained, as 
well. Note that the .png and .tif file types 
support transparency, while the .jpg and 
.bmp file types do not.

1

2
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Importing Pictures
Pictures can be imported into and 
displayed in floor plan view, cross 

section/elevation views, CAD Details, and 
layout pages. Pictures do not display in 
camera views or overviews. See “Displaying 
Pictures, Metafiles, and PDF Boxes” on page 
1151.

There are several ways to import a Picture 
into Chief Architect:
• Select File> Import> Import Picture 

(BMP, JPG, PNG)  to open the 
Import Picture File dialog, which is a 
typical open file dialog. See “Importing 
Files” on page 62. 

• Click and drag an image file from an 
operating system window into the Chief 
Architect window.

• In any application, copy an image to the 
system clipboard, then select Edit> 
Paste> Paste  from the Chief Archi-
tect menu in an eligible view window. 
See “Paste Special” on page 173.

• Use the Screen Capture tools. See “Creat-
ing Screen Captures” on page 1154.

An imported picture is placed in the center of 
the current view. Once imported, pictures can 
be selected and edited. See “Editing Pictures, 
Metafiles, and PDF Boxes” on page 1151.

Picture File Box Specification Dialog
Select an imported picture file and 
click the Open Object edit button to 

open the Picture File Box Specification 
dialog.

Note: Importing large, or multiple, Pictures
into a plan or layout file can result in program
slowness. 
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Information about the selected Picture 
File can be specified here.

• The Filename of the picture file displays 
here. Type a new pathname to change the 
picture assigned to this box.

• Click the Browse button to choose a new 
picture file or to relink to a missing file.

• Check Save in Plan to embed the picture 
in the plan or layout file. If a picture file 
is embedded, you do not need to include 
it when sending the plan or layout to a 
different computer.

• Click the radio button beside either PNG 
or JPEG to specify how to save the 
embedded picture data. Pictures that were 
originally .jpg or .tga files use the JPEG 
option by default; those that were .gif or 
.png files use the PNG option by default.

• Specify the picture’s Quality %. when 
JPEG is selected. A lower value results 
in better compression, while a higher 
value reduces data loss. 

1

Note: PNG is the better option for pictures of
line drawings, text, or large areas of a single
color. JPEG is the better option for photos. 
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Center/Orientation - Specify the 
position of the selected Picture’s center 

point and its angle. See “3D Drafting” on 
page 31. 
• Specify the X and Y Positions of the pic-

ture box’s center point relative to the 
absolute origin. 

• Specify the Angle of the picture box rela-
tive to a horizontal line pointing towards 
the right hand side of the screen.

Specify the Size of the picture in plan 
inches (mm).

• Specify the Width of the picture box. 
The original width in pixels displays to 
the right.

• Specify the Height of the picture box. 
The original height in pixels displays to 
the right.

• Uncheck Retain Aspect Ratio of X if 
you would like to modify the Height or 
Width without affecting the other value. 
If you do this, the picture may appear dis-
torted. 
This checkbox does not affect editing 
performed outside of this dialog and is an 
action rather than a state: the next time 
you open this dialog, it will be checked.

• Reset Original Aspect Ratio - If the 
aspect ratio is changed, you can click this 
button to return the picture to its original 
aspect ratio. 

• Check Reset Cropping to fill the extents 
of the selected Picture box with the image 
associated with it. If the box has been 
resized, the image may appear distorted. 
See “Editing Pictures, Metafiles, and 
PDF Boxes” on page 1151.

A variety of Display Options are 
available.

• Check  Black and White Dither to 
dither the selected picture file. Dithering 
creates a two tone effect that may pro-
duce better results when printed.

• Check Grayscale to replace the color in 
the selected picture with shades of gray.

• Check Reflect to reverse the image.
• Enter a degree of Brightness from 1 - 

100%.
• Enter a degree of Contrast from 1 - 

100%.

Line Style Panel
The settings on this panel are similar to those 
on the LINE STYLE panel in numerous other 
dialogs, with one exception: check Show 
Outline to turn on the display of the picture’s 
border polyline.

See “Line Style Panel” on page 1085.

Fill Style Panel
For information about using the FILL STYLE 
panel, see “Fill Style Panel” on page 1099.

Metafiles
A metafile (.emf, .wmf) is a special picture 
file format made up of vectors (lines) that 
allow the image to be rescaled without loss 

of quality. High resolution pictures of line-
based views can be exported as a metafile.

2

3

4
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Exporting Metafiles
An enhanced metafile (.emf) can be 
exported from any line-based view: 

that is, from floor plan view, CAD Details, 
layout pages, and 3D Vector Views. 

Only objects that display on screen are 
included in an exported metafile. 

To export a metafile

1. Accurately position the view on screen.
2. Select File> Export> Export Metafile 

(EMF) . 

3. Drag a marquee  from corner to cor-
ner, defining the area that will included 
in the metafile.

4. Release the mouse to open the Metafile 
Size dialog.

5. Specify the desired Width or Height of 
the metafile. When one value is edited, 
the other changes to maintain its aspect 
ratio. 

Specify, too, the desired Dots Per Inch 
(DPI) for the metafile. A larger value 
results in a higher quality metafile, but 
also a larger file size.

6. When a metafile is exported from a 3D 
Vector View, you can also specify the 
printed thickness of lines in the view. To 
increase the printing line weight, type a 
larger number in the Use Line Weight 
field.  See “Vector View” on page 952. 

Metafiles exported from floor plan view 
use the line weights defined in the Layer 
Display Options dialog. See “Layer 
Display Options Dialog” on page 149. 

7. Click OK to open the Export Metafile 
dialog, which is a typical Save As dia-
log. See “Saving, Exporting, and Back-
ing Up Files” on page 55. 

8. Enter a name and location on your com-
puter for the metafile, then click Save. 

Importing Metafiles
Metafiles can be imported into and 
displayed in floor plan view, cross 

section/elevation views, CAD Details, and 
layout pages. Metafiles do not display in 
camera views or overviews. See “Displaying 
Pictures, Metafiles, and PDF Boxes” on page 
1151.

There are two ways to import a metafile into 
Chief Architect:
• Select File> Import> Import Metafile 

(EMF,WMF)  to open the Import 
Metafile dialog, which is a typical open 
file dialog. See “Importing Files” on page 
62. 

Note: Metafiles are not supported in Mac
operating systems and cannot be imported or
exported in Mac versions of the software. 
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• You can also click and drag a metafile file 
from an operating system window into 
the Chief Architect window to import it.

An imported metafile is placed in the center 
of the current view. Once imported, metafiles 
can be selected and edited. See “Editing 
Pictures, Metafiles, and PDF Boxes” on page 
1151.

Metafile Box Specification Dialog
Select an imported metafile and click 
the Open Object edit button to open 

the Metafile Box Specification dialog. 

General Panel

Center/Orientation - Specify the 
position of the selected metafile’s 

center point and its angle. See “3D Drafting” 
on page 31. 
• Specify the X and Y Position relative to 

the absolute origin. 
• Specify the Angle of the metafile box rel-

ative to a horizontal line pointing towards 
the right hand side of the screen.

Specify the Size of the metafile in plan 
inches (mm).

• Specify the Width of the metafile box. 
• Specify the Height of the metafile box. 
• Uncheck Retain Aspect Ratio of X if 

you would like to modify the Height or 
Width without affecting the other value. 
If you do this, the metafile may appear 
distorted. 
This checkbox does not affect editing 
performed outside of this dialog and is an 
action rather than a state: the next time 
you open this dialog, it will be checked.

1

2



1148

Chief Architect X8 Reference Manual

• Reset Original Aspect Ratio - If the 
aspect ratio is changed, you can click this 
button to return the picture to its original 
aspect ratio. 

• Check Reset Cropping to fill the extents 
of the selected metafile box with the 
image associated with it. If the box has 
been resized, the image may appear dis-
torted. See “Editing Pictures, Metafiles, 
and PDF Boxes” on page 1151.

Line Style Panel
The settings on this panel are similar to those 
on the LINE STYLE panel in numerous other 
dialogs, with one exception. Check Show 
Outline to turn on the display of the picture’s 
border polyline.

See “Line Style Panel” on page 1085.

Fill Style Panel
For information about using the FILL STYLE 
panel, see “Fill Style Panel” on page 1099.

PDF Files
Portable Document Format (.pdf) files are a 
special type of file that can be viewed on 
nearly any computer and can include a wide 
variety of visual information.  

You can import .pdf files into Chief 
Architect in floor plan view, cross section/
elevation views. CAD Details, and in layout. 
Once imported, PDF boxes behave and can 
be edited similar to imported pictures and 
metafiles. See “Editing Pictures, Metafiles, 
and PDF Boxes” on page 1151.

Some .pdf files can contain both 2D and 3D 
information; however, Chief Architect can 
only support 2D data in an imported .pdf file. 
When a 3D .pdf file is imported, it may 
display text, a static image of the 3D model, 
or it may not import at all. 

You can also create a 2D .pdf from any view 
by printing. See “Printing to a PDF File” on 
page 1222.

Importing PDF Files
To import a .pdf file, select File> 
Import> Import PDF. 

You can also import a .pdf file by dragging it 
from an operating system window into the 
Chief Architect window.

Note: Importing large, or multiple, .pdf files
into a plan or layout file can result in program
slowness. 
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The full pathname of the .pdf file 
displays here. If the pathname is not 

that of a valid .pdf file, this text will display 
in red. 
• Click the Browse button to choose a new 

.pdf file or to relink to a missing file.
• Specify the Page of the .pdf file that dis-

plays in the preview on the right. Type a 
page number in the text field or use the 
arrow buttons to browse the pages 
sequentially.

A preview of the page selected above 
displays here.  

Specify how much of the .pdf file you 
wish to Import. When multiple pages 

are imported, a separate PDF box is created 
for each one.
• Select Current Page to import only the 

page specified above and shown in the 
preview to the right. 

• Select Pages, then specify the starting 
page in the From field and the ending 
pgae in the To field. 

• Select All to import the entire .pdf file. 

PDF Box Specification Dialog
Select an imported PDF box and click 
the Open Object edit button to open 

the PDF Box Specification dialog. 

1

2

3
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The full Filename of the .pdf file 
displays here. Type a new name to 

associate the selected PDF box with a 
different .pdf file. 
• Click the Browse button to choose a new 

.pdf file or to relink to a missing file.
• Specify the Page of the .pdf file that dis-

plays in the selected PDF box.
• Check Save in Plan to embed the .pdf in 

the plan or layout file. If a .pdf is embed-
ded in a file, you do not need to include it 
when sending the file to a different com-
puter.

Center/Orientation - Specify the 
position of the selected PDF box’s 

center point and its angle. See “3D Drafting” 
on page 31. 
• Specify the X and Y Positions of the 

PDF box’s center point relative to the 
absolute origin.

• Specify the Angle of the PDF box rela-
tive to an imaginary horizontal line point-
ing towards the right hand side of the 
view window.

Specify the Size of the PDF box in plan 
inches (mm).

• Specify the Width of the PDF box. 
• Specify the Height of the PDF box. 
• Uncheck Retain Aspect Ratio of X if 

you would like to modify the Height or 
Width without affecting the other value. 
If you do this, the PDF box may appear 
distorted. 
This checkbox does not affect editing 
performed outside of this dialog and is an 
action rather than a state: the next time 
you open this dialog, it will be checked.

• Reset Original Aspect Ratio - If the 
aspect ratio is changed, you can click this 

1

2
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button to return the picture to its original 
aspect ratio. 

• Check Reset Cropping to fill the extents 
of the selected PDF box with the image 
associated with it. If the box has been 
resized, the image may appear distorted. 
See “Editing Pictures, Metafiles, and 
PDF Boxes” on page 1151.

Line Style Panel
The settings on this panel are similar to those 
on the LINE STYLE panel in numerous other 
dialogs, with one exception: Check the Show 
Outline box to turn on the display of the 
PDF box’s border polyline.

See “Line Style Panel” on page 1085.

Fill Style Panel
For information about using the FILL STYLE 
panel, see “Fill Style Panel” on page 1099.

Displaying Pictures, Metafiles, and PDF Boxes
The display of Pictures, Metafiles, and 
PDF Boxes is controlled in the Layer 

Display Options dialog. See “Displaying 
Objects” on page 144.

Pictures, Metafiles, and PDF Boxes are 
placed on the Current CAD Layer by default; 
but once imported, they can be moved to 
other layers. See “Image Specification 
Dialog” on page 1137.

Pictures, Metafiles, and PDF Boxes can be 
imported into and displayed in floor plan 
view, cross section/elevation views, CAD 
Details, and layout pages. A Picture, 
Metafile, or PDF Box can only be seen in the 
view where it was imported and cannot be 
imported into a camera view or overview.

Drawing Groups
By default, imported pictures and PDF 
Boxes are placed in the Back Drawing 
Group, and imported metafiles are placed in 
the Default Drawing Group. Once imported, 
they can be moved to a different group. See 
“Drawing Groups” on page 218. 

In Layout
Pictures, metafiles, and PDF boxes are 
included when a view is sent to layout, and 
can also be imported directly onto a layout 
page. See “Pictures, Metafiles, and PDFs in 
Layout” on page 1239.

Editing Pictures, Metafiles, and PDF Boxes
Pictures, Metafiles, and PDF Boxes can be 
selected and edited using the edit handles, 
the edit toolbar, and their specification 
dialogs. 

Imported pictures, metafiles, and PDFs are 
placed on the Current CAD Layer by default; 
but once imported, these objects can be 
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placed on any layer. See “Layers” on page 
143.

In the Specification Dialog
Pictures, Metafiles, and PDF Boxes can be 
customized in their specification dialog. See: 
• “Picture File Box Specification Dialog” 

on page 1143
• “Metafile Box Specification Dialog” on 

page 1147
• “PDF Box Specification Dialog” on page 

1149

Using the Mouse
Pictures, Metafiles, and PDF Boxes have edit 
handles similar to other box-based objects. 
See “Editing Box-Based Objects” on page 
206. 
• The corner Resize handles behave do not 

behave the same for Pictures, Metafiles, 
and PDF Boxes as they do for CAD 
boxes, however. If you drag a corner han-
dle of one of these objects while the 
Default Edit Behavior is active, its con-
tents will resize and height to width ratio 
will be retained.

• If you drag an Extend handle along a 
Picture, Metafile, or PDF Box’s edge, the 
contents of the box will not be resized. If 
you resize it larger, an empty space will 
be created between that edge and the con-
tents; if you resize it smaller, the contents 
will be cropped.

Using Dimensions
Pictures, Metafiles, and PDF Boxes can be 
relocated relative to other objects with 
precision using dimensions. 

To avoid changing the selected object’s 
aspect ratio, make sure you choose to move 
the entire object rather than the selected 
edge. See “Moving Objects Using 
Dimensions” on page 1019.

Using the Edit Tools
A selected Picture, Metafile, or PDF Box can 
be edited in a variety of ways using the 
buttons on the edit toolbar. See “The Edit 
Toolbar” on page 37.

Point to Point Resize
A selected picture, metafile, or PDF 
box can be resized in either the X or Y 

direction with the Point to Point Resize edit 
tool. 

To use the Point to Point Resize tool

1. Select a picture box, metafile box, or 
PDF box.

2. Click the Point to Point Resize  edit 
button.

3. Click on two points in the selected 
object’s box area that have a known dis-
tance between them.

4. After you click at the second point, the 
Point to Point Resize dialog opens 
showing the current distance between 
the points.

5. Enter a new dimension that matches the 
desired distance between the points.
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6. Click OK to resize the picture, metafile, 
or pdf.

Resize Factor
With a bit of calculation, an imported picture, 
metafile,or PDF boxcan be resized to scale 
using the Transform/Replicate Object 
dialog. Once resized, the information in the 
object box can be traced using Chief 
Architect’s drawing tools and then deleted. 

To calculate the Resize Factor

1. Find two items in the imported object 
that are separated by a known horizontal 
or vertical distance, such as two walls or 
plot lines. 

2. Draw parallel CAD lines on top of these 
two items. See “The CAD Drawing 
Tools” on page 1075.

3. Find the distance between the CAD 
lines. See “The Manually Drawn 
Dimension Tools” on page 1005.

4. The Resize Factor for the image is the 
distance described in the picture divided 
by the distance between the CAD lines.

For example, if the items are supposed to be 
10 feet apart on the picture, but the distance 
between the two CAD lines drawn on them is 
only 2 feet, you need to set the Resize Factor 
for the picture to 5. (10’ divided by 2’ equals 
5). When the picture is 5 times the original 
size, the items on the picture are at the actual 
scale shown on the picture.
5. Select the picture and click the Trans-

form/Replicate Object  edit button. 
6. In the Transform/Replicate Object dia-

log, select the Resize Factor check box.
7. Enter the Resize Factor calculated 

above, then click OK.

Copy Region as Picture
You can copy any portion of the 
screen and save it as a picture file 

using the Copy Region as Picture tool. See 
“Exporting Pictures” on page 1141.

To use Copy Region as Picture

1. Open the view that you would like to 
copy all or part of as a picture.

2. Select Edit> Copy Region as 
Picture . Your pointer displays a 
marquee  icon.

3. Click and drag a rectangular selection 
marquee around the desired region.

4. The selection is copied to the system 
clipboard.

• If the current view is vector-based, the 
Metafile Size dialog displays because 
metafiles are better suited for line-based 
pictures. See “Metafiles” on page 1145.

It is a good idea to delete a resized pic-
ture after it is traced to help avoid pro-

gram slowness and limit your plan or layout
file’s size.
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• If the current view is a rendered or Ray 
Trace view, the region is sent directly to 
the system clipboard.

5. From there, the picture can be pasted 
into another view or another program.

Creating Screen Captures
Use the Screen Capture tools to add 
images, backdrops, or materials to the 

Chief Architect Library or to create picture 
objects. You can capture screens in Chief 
Architect or other applications. 

Begin by selecting Tools> Screen Capture> 
Screen Capture Setup  to open the 
Screen Capture Setup dialog.

Screen Capture Setup Dialog

Save Capture As - Specify in what form you 
would like the screen capture to be saved.
• If you select Backdrop as the capture 

type, the program will add the capture to 
the library, and it will display in the 
library preview panes. See “3D Back-
drops” on page 909. 

• If you select Image as the capture type, 
the program will add the capture to the 
library as an image object. The image 
will display in the preview panes and will 
be selected. Click in the plan to place it. 
See “Images” on page 1134.

• If you select Material as the capture 
type, the new material will be added to 
the My Materials library category and 
will be shown in the preview panes. Use 

the Material Painter  to apply the 
material. See “The Material Painter” on 
page 849. 

• If you choose Picture as the capture type, 
the picture displays on screen in Chief 
Architect. See “Pictures” on page 1141.

• Check Hide Chief Architect While 
Capturing to minimize the program win-
dow so you can capture an image in 
another application. 

• Click Capture to proceed with a screen 
capture and click Done when you are fin-
ished. The Screen Capture Setup set-
tings are saved between program sessions 
and are used in all files.

To create a screen capture

1. Select Tools> Screen Capture> Cap-
ture Screen , or click the Capture 
button in the Screen Capture Setup 
dialog.

2. The mouse pointer displays a cross hairs 
icon when the Screen Capture tool is 
active. Move it to the window that you 
want to capture from. This can be in 
Chief Architect, a web page, or another 
program.
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3. Click and drag a rectangular marquee to 
capture the area within the marquee.

4. A captured Picture will be placed imme-
diately in the Chief Architect drawing 
area. Captured Backdrops, Materials, 
and Images are saved in the User Cata-
log of the Library Browser. 

To change the name of a captured backdrop, 
image, or material, right-click on it’s name in 
the library list, select Rename, and type in 
the new name. See “Renaming Library 
Items” on page 832. 

3D Backdrops
A backdrop is an image, typically of an 
exterior view, that displays in the background 
of 3D views to help place the model into a 
realistic setting and add a sense of 
perspective. 

A selection of backdrop images is available 
in the Library Browser. You can also create 
your own backdrop images and import them 
into the library. See “Adding New 
Backdrops” on page 831.

Backdrops automatically adjust to fit each 
view window, so they look best when they 
are created with a height to width ratio that is 
similar to the window you are working in.

Specifying a Backdrop
You can select a backdrop image for a plan 
from the library in either of two ways: 
• In any view, select 3D> 3D View 

Defaults  to open the 3D View 
Defaults dialog. See “Backdrop Panel” 
on page 895. 

• In a 3D view, open the Library Browser. 
Select a Backdrop image, then move your 
mouse pointer  into the view window. 
Click anywhere in the view to apply the 
selected backdrop. 

Regardless of how it is selected, only one 
backdrop can be used in a plan at any given 
time. If a backdrop is not applied, Chief 
Architect applies a background color. 

You can specify which view types and 
Rendering Techniques use the selected 
backdrop in the 3D View Defaults dialog. By 
default, Perspective Camera views using the 
Standard, Painting, and Watercolor 
Rendering Techniques use backdrops while 
the other techniques and view types do not. 

You can create digital photos of a build-
ing site for use as a backdrop.

The backdrop in this view includes hills and clouds
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Spherical Panoramic 
Backdrops

Spherical Panoramic Backdrops are a special 
type of backdrop that wraps around the 
model in 3D views as though it were applied 
to a sphere surrounding it. It takes an image 
processing program or special camera to 
generate spherical panoramic backdrops.

If you have such a file, you can specify it as 
your Backdrop image, then check Spherical 
Panoramic Backdrop in the 3D View 
Defaults dialog. 

The Use Generated Sky option in the 3D 
View Defaults dialog produces a special 
Spherical Panoramic Backdrop that 
simulates a daytime sky using the Generic 

Sun or active Sun Angle  data. See “Sun 
Angles and Shadows” on page 943.

Backdrop Specification Dialog
To open the Backdrop Specification 
dialog, select File> Import> Import  

Backdrop or right-click on the User Catalog 
in the Library Browser and select New> 
Backdrop from the contextual menu. See 
“Adding New Backdrops” on page 831.

You can also open this dialog by right-
clicking on a backdrop image in the User 
Catalog in the Library Browser and selecting  

Open  from the contextual menu.  
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A preview of the selected image 
displays here. 
Backdrop - Specify backdrop’s Name 
and the image file associated with it.

• Type a Name for the selected backdrop, 
to be used in the Library Browser and 3D 
View Defaults dialog. 

• In the Location field, type the full path-
name of the image file or click the 
Browse button and browse to the file on 
your computer. 

The Spherical Backdrop Options 
should only be used if the selected 

backdrop was specially created to serve as a 
spherical panoramic backdrop. 

• Check Spherical Panoramic Backdrop 
to project the image onto a sphere that 
surrounds the model in camera views and 
overviews.

• The Horizontal Angle controls how 
many times the backdrop appears as you 
rotate in a full circle around the model. A 
value of 360° wraps the image around 
once; a value of 720°, twice; and a value 
of 180° makes only half the image wrap 
around the sphere.

• The Vertical Angle determines how 
much of the backdrop stretches up and 
down. To have it stretch from the highest 
point in the sky to the lowest point below 
the ground, use a value of 180°. To have 

1

2
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the backdrop stretch from just below a 
horizontal render to just above, use a 
smaller value, such as 100°.

Some experimenting with the Angle values 
may be necessary to achieve the desired 
results. You may prefer to do this in the 3D 

View Defaults dialog after adding the back-
drop to a plan. See “Backdrop Panel” on 
page 895.

If the selected image has a Copyright, 
information about it will display here. 

Walkthroughs
A 3D Walkthrough is a series of 
pictures saved as an .avi file that can 

be played like a video by other applications 
such as Windows Media Player.

There are two approaches to recording a 
walkthrough of a plan: 
• Draw a path in floor plan view, then 

direct the program to record a walk-
through along that path.

• Create a 3D view, then begin recording 
and use the Move Camera tools to navi-
gate through the view. 

Create Walkthrough Path
There are several ways to record a 
walkthrough along a path, but the 

Create Walkthrough Path tool is the fastest 
and most flexible option. 

To create a Walkthrough Path

1. Begin by choosing a codec for recording 
walkthroughs. See “Selecting a Codec” 
on page 1162. 

2. In floor plan view, select 3D> Walk-
throughs> Create Walkthrough 
Path , then click and drag to draw a 
Walkthrough Path. See “To use the 
Spline tool” on page 1106.

3. Edit the direction and curvature of the 
spline’s segments, as needed. See “Edit-
ing Spline Based Objects” on page 209. 

4. Add Key Frames  to the path and 
modify their specifications.

5. Select the path and click the Record 
Walkthrough Along Path  edit but-
ton. See “Record Walkthrough Along 
Path” on page 1160. 

You can also create a walkthrough based on a 
regular CAD polyline or spline by selecting 
it and clicking the Record Walkthrough 
Along Path  edit button. This was the only 
way to record a walkthrough along a path in 
Chief Architect versions X1 through X4 and 
does not provide as many options as using a 
Walkthrough Path. 

In floor plan view, you can convert a CAD 
polyline or spline into a Walkthrough Path. 
See “Convert Polyline Dialog” on page 239. 

Walkthrough Paths display in floor plan view 
when the “Walkthrough Paths” layer is 
turned on. When displayed, Walkthrough 

4

Walkthrough Paths can follow stairs
and ramps to span multiple floors. See
“Walkthrough Paths and Stairs” on

page 1159.
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Paths display in front of other objects and 
will print. They are included in views sent to 
layout or exported to .dxf/.dwg. See 
“Layers” on page 143. 

Key Frames
Key Frames are points along a 
Walkthrough Path that allow you to 

change: 
• Camera direction, tilt angle, and height; 
• Changes in walkthrough speed;
• The floor that the walkthrough is on. 

These changes are applied as the camera 
moves along the Walkthrough Path from one 
Key Frame to another.

To add a Key Frame to a Walkthrough Path, 
select the path and click the Add Key 
Frame  edit button. Then click on the 
path to add a Key Frame at that location.

In floor plan view, each Key Frame is 
represented by a camera symbol centered 
along the walkthrough path. It displays the 
frame number, is pointed in the direction of 
its Camera Angle, and its position along the 
path corresponds to its Time setting. 

Key Frame Time, Angle, and other 
properties can be edited in the Walkthrough 
Path Specification dialog. See “General 
Panel” on page 1162. 

You can also use the Edit Key Frames  
edit tool to enable Move and Rotate edit 

handles for each Key Frame on the selected 
Walkthrough Path. 

To use the Edit Key Frames edit tool

1. Select a Walkthrough Path and click the 

Edit Key Frames  edit tool.
2. Each Key Frame on the selected Walk-

through Path will display a Move and 
Rotate edit handle.

• Click and drag the square Move handle 
to reposition the Key Frame along the 
path.

• Click and drag the rectangular Rotate 
handle to change the Key Frame’s direc-
tion angle 

3. When you are finished adjusting the Key 

Frames, click the Main Edit Mode  
edit tool to restore the Walkthrough 
Path’s normal edit handles. 

Walkthrough Paths and Stairs
If you draw a Walkthrough Path up or down 
a staircase or ramp, it will follow the height 
of the stairs or ramp and continue on the next 
floor. 

To create a multiple floor walkthrough

1. Draw a Walkthrough Path so that it 
extends into a staircase or ramp in the 
same direction as its Direction Arrow. 
See “Displaying Stairs, Ramps, and 
Landings” on page 539.

• Do not drag the Walkthrough Path 
across the entire length of the stairs or 
ramp. If you do, its height will remain 
relative to the current floor.
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2. When you  release the mouse button, the 
program will automatically display a 
dashed line with an arrow extending past 
the last Key Frame on the current floor.

• If it follows stairs or a ramp going 
upward, the path will also extend to the 
top end of the staircase or ramp.

3. Go up or down one floor, select the 
Walkthrough Path, and resize and 
reshape it as needed. You can use the 

Create Walkthrough Path  tool to 
draw more segments and additional Key 
Frames can be added, as well. 

Record Walkthrough Along 
Path

Once a Walkthrough Path has been drawn, 
you can use it to record a walkthrough video. 

Before recording a walkthrough, it is a good 
idea to choose a codec that will best suit your 
needs. See “Selecting a Codec” on page 
1162.

To record a walkthrough along a path

1. Begin by selecting a codec for recording 
walkthroughs. See “Selecting a Codec” 
on page 1162.

2. In floor plan view, select a Walkthrough 
Path or a CAD polyline or spline. 

3. Click the Record Walkthrough Along 
Path  edit button.

4. In the Save Video As dialog, specify a 
name and saved location for your .avi 
walkthrough file. See “Exporting Files” 
on page 58. 

5. In the Walkthrough Options dialog: 

• Specify the desired number of Frames 
Per Second, between 1 and 100. A 
higher number results in a higher quality 
recording but also a larger .avi file.

• Specify a Duration Along Path, in sec-
onds. 

• The Total Frames to Record displays 
for reference and equals the Frames Per 
Second times the Duration along Path.

• Specify a Compression percentage 
between 0 and 100. A value of 0 gives 
the highest quality images and largest 
file sizes.

• From the drop-down list, select the Ren-
dering Technique you would like the 
walkthrough to use. See “Rendering 
Techniques” on page 951.

• Check Show Shadows to turn on shad-
ows in the walkthrough. See “Shadows” 
on page 934.

• Click OK.

To cancel the recording as it is being created, 
press the ESC key on your keyboard.
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Frame by Frame Walkthroughs
You can also create a walkthrough by 
recording it frame by frame. Although time-
consuming, creating a walkthrough in this 
manner lets you see exactly what is being 
recorded as you record it. 

As with walkthroughs recorded along paths, 
it is a good idea to select a codec that meets 
your needs before recording a walkthrough 
frame by frame. See “Selecting a Codec” on 
page 1162.

To record a walkthrough frame by frame

1. Begin by selecting the codec for record-
ing walkthroughs. See “Selecting a 
Codec” on page 1162. 

2. Create a camera view. This view is the 
first frame of the walkthrough.

3. From the view, select 3D> Walk-
throughs> Record Walkthrough . 

4. Specify a location and name for the 
walkthrough in the Save Video As dia-
log and click Save. 

5. In the Walkthrough Options dialog: 

• Select a Frame Rate between 1 and 
100. The value entered is the number of 
frames per second. 

• Select a Compression Percent between 
0 and 100. A value of 0 gives the highest 
quality images and the largest file size.

• Click OK.

6. Use the camera movement tools to cre-
ate additional views. Each time the 
screen redraws, that view is recorded as 
the next frame in sequence. See “Editing 
3D Views” on page 916.

7. To move the camera without saving a 
view, select 3D> Walkthroughs> Pause 
Recording  to temporarily stop 
recording. 

• You can then select 3D> Walk-
throughs> Save Frame  button to 
control what views are saved.

• You can start recording again by select-

ing Pause Recording  once more.
8. When the walkthrough sequence is com-

plete, select 3D> Walkthroughs> Stop 
Recording  or close the view.

If you resize the current view window while 
recording a walkthrough, the program will 
stop recording. 

Playing a Walkthrough
Once a walkthrough has been recorded, it 
can be played on any media player.

To play a walkthrough

1. Select 3D> Walkthroughs> Play 
Walkthrough  to open the Select 
Video File dialog. 

2. Browse to an .avi file on saved on your 
computer. Your default video application 
plays the walkthrough video.

Note: Zooming in and out and using the scroll
bars does not change the viewpoint and does
not produce a frame for the walkthrough.
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Selecting a Codec
A codec is a a utility that compresses and 
decompresses media files, and is used when 
both recording and viewing .avi files such as 
walkthrough videos.

You can specify which codec to use when 
recording walkthroughs in the Preferences 
dialog. See “Render Panel” on page 123. 

To choose the codec that best suits your 
needs, it is a good idea to create a test 
walkthrough using each of the codecs 
installed on your system to see how well 
their walkthrough quality and file 
compression meet your requirements. 

For more information about codecs, visit 
chiefarchitect.com.

Walkthrough Path Specification Dialog
Select a Walkthrough Path and click 
the Open Object edit button to open 

the Walkthrough Path Specification dialog. 
See “Walkthroughs” on page 1158. 

General Panel

A list of the selected path’s Key 
Frames displays on the left. Click on a 

Frame in the list to select and edit it using the 
settings on the right. When the dialog is 

opened, the last key frame edited in the cur-
rent program session will be selected auto-
matically. See “Key Frames” on page 1159. 

1

http://www.chiefarchitect.com/support/article/KB-00076/specifying-what-video-codecs-to-use-for-walkthroughs.html
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• Specify the Floor that the selected Key 
Frame is located on. See “Multiple 
Floors” on page 435.

• Specify the Time in seconds at which the 
selected Key Frame is found in the dura-
tion of the walkthrough. Frame 1 is 
always at 0.0 and cannot be moved; simi-
larly, the last frame is always at the end 
of the walkthrough Duration. 

• Specify the Speed After (ft/s), which is 
how fast the camera moves along the 
walkthrough path from the current Key 
Frame to the next. Not available if the 
last Key Frame is selected.

• Specify the Camera Angle at the 
selected Key Frame.

• Specify the Tilt Angle of the camera at 
the selected Key Frame.

• Specify the Height of the camera at the 
selected Key Frame.

• Click the Delete button to remove the 
selected Key Frame from the path.

• Specify the Key Frame Symbol Size, 
which is the size of the symbols repre-
senting the selected walkthrough path’s 
Key Frames in floor plan view. See “Key 
Frames” on page 1159. 

By default, Key Frames use the Camera 
Symbol Size set in the Camera Defaults 
dialog.  See “Camera Defaults Dialog” on 
page 889. 

Walkthrough Options - 

• Specify the Duration, or total length of 
the walkthrough video in seconds.

Specify how Camera Angles are measured:

• Select Relative to Path to measure each 
camera angle relative to the direction of 
the walkthrough path at each Key Frame 
location. 

• Select Absolute to measure each camera 
angle relative to the plan’s X, Y, and Z 
axes. See “3D Drafting” on page 31.

Specify how Camera Height is measured: 
• Select Relative to Floor/Terrain to mea-

sure camera height relative to the floor or 
terrain at each Key Frame location. 

• Select Absolute to measure camera 
height relative to the plan’s Z axis. 

Polyline Panel
The POLYLINE panel states the length of the 
path’s Perimeter. The Area and Volume of a 
walkthrough path will always be described as 
“Not closed”. See “Polyline Panel” on page 
1098. 

Selected Line Panel
The SELECTED LINE panel is available when 
the selected path edge is a line as opposed to 
an arc. See “Selected Edge” on page 184.

Moving the Start of a line segment moves the 
end of the previous connected line, if there is 
one. Similarly, moving the End of a line 
segment moves move the start of the next 
connected line, if there is one.

2

Note: When Relative Angles are used, a
Camera Angle of 0° points in the direction of
the walkthrough path. When Absolute Angles
are used, 0° always points in the positive
direction along the X axis. 
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This panel is similar to the LINE panel of the 
Line Specification dialog. See “Line Panel” 
on page 1084.

Selected Arc Panel
The SELECTED ARC panel is available when 
the selected path edge is an arc as opposed to 
a line. See “Change Line/Arc” on page 232. 

This panel is similar to the ARC panel of the 
Arc Specification dialog. See “Arc Panel” 
on page 1093.

Spline Panel
The Spline panel has a single option and is 
only available if the selected walkthrough 
path is a spline.  See “Splines” on page 1106. 

New Segment Angle - Specify the angle 
between line segments that are used to draw 
the spline. Specifying a smaller angle makes 
the spline’s curvature smoother. 

Line Style Panel
This panel is similar to the LINE STYLE panel 
in the Line Specification dialog. See “Line 
Style Panel” on page 1085.

Label Panel
Walkthrough Path labels display in floor plan 
view when the “Polylines, Labels” layer is 
turned on and use the Text Style assigned to 
that layer. 

For more information, see “Label Panel” on 
page 1280.

Creating VRML Files
VRML (Virtual Reality Modeling 
Language) is a 3D file format that can 

be used by various “walkthrough” viewers, 
as well as other rendering packages. 

VRML files use the .wrl file format and 
contain an entire 3D model, including 
lighting information. Images and textures 
can also be referenced. You can post a .wrl 
file and its associated image and texture files 
to the web or e-mail them to a customer. 

VRML files are often created from rendered 
views so that lighting and textures are used; 
however, you can export from a Vector View 
if you wish. See “Editing 3D Views” on page 
916.

The entire model is exported, but the starting 
point for the walkthrough is defined by the 
camera location at the time of export. 

When a camera view or overview is active, 

select File> Export> Export VRML . 
The VRML Export Options dialog opens.
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VRML Export Options Dialog

Define the Camera Field of View. 
Standard most closely corresponds to 

the default Chief Architect camera view. The 
other options generate a wider field of view.

Specify how Textures/Images are 
exported. 

• Check No Textures Exported to prevent 
texture files from being exported with the 
.wrl file. If textures are exported, the tex-
ture files must be in the same folder as 
the .wrl file.

• Check Copy Images to Export Folder if 
you plan to share the VRML with others. 
This copies texture bitmaps with the .wrl 
file so that they render correctly when 
exported.

Specify how Lighting is exported. 

• Turn off Ambient Lights turns off the 
default lights that are used to light a 
scene.

• Turn off Fixture Lights turns off the 
default lights that are generated for fix-
tures and used to light a scene.

• Night Sky/Ground Colors darkens the 
ground plane and sky to create a night-
time appearance.

Options 

• Walk Through Surfaces allows you to 
walk through walls and closed doors 
from room to room, instead of stopping 
when you reach a wall.

• Run Default VRML Viewer starts the 
.vrml viewer and opens the new .vrml 
file as soon as it is generated.

Once the general parameters have been 
selected, click OK. Name the .wrl file and 
save it in the desired folder and click Save.

VRML Use of Texture 
and Image Files

In order for textures to be rendered correctly, 
the texture and image files associated with an 
exported VRML file must be in the same 
directory as the .wrl file. 

VRML files do not support the use of .bmp 
textures or images. Instead, compressed file 

1

2

3

It is best to keep all .vrml files in a folder
separate from your normal Chief Archi-

tect files, since all textures used in the model
also export to the same folder. This could add
a significant number of files, creating poten-
tial organization problems. 

4
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formats such as .gif, .png, or .jpg files must 
be used. 

If you wish to use custom textures or images 
in your VRML file, you have two options:
• Make sure that they are saved in a format 

other than .bmp before you bring import 
them into Chief Architect. This is the rec-
ommended option.

• Create a .gif file with the same name and 
in the same directory as the .bmp file. 

When you export the .wrl file, Chief 
Architect automatically substitutes the 
.gif for the .bmp file. Whenever possible, 
you should use a supported file format 
instead of using .bmp and .gif pairs.

For more information about .vrml players, 
visit chiefarchitect.com.

http://www.chiefarchitect.com/
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Chapter 37:

Importing and
Exporting

Importing is the process of opening a file that 
was produced in a different program in Chief 
Architect. Exporting, on the other hand, is 
the process of saving information in a Chief 
Architect file to a format that can be read by 
another program. 

Chief Architect allows you to import and 
export a variety of information from and to 
other applications. This chapter focuses on 
importing and exporting 2D .dwg/.dxf files 
and a variety of 3D file formats. Other 
importing and exporting options are 
described in the chapters in which those 
objects or settings are discussed.  

Chapter Contents
•      Chief Architect Account Login
•      Export Chief Architect 3D Viewer File
•      Import Room Planner File
•      DXF vs DWG File Formats
•      Importing 2D Drawings
•      Import Drawing Assistant
•      Exporting 2D DXF/DWG Files
•      Additional 2D Export Information
•      3D Data Import Requirements
•      Importing 3D Symbols
•      Symbol Categories
•      3D Symbols and Materials
•      Exporting a 3D Model
•      Export to REScheck
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Chief Architect Account Login
In order to either export a 3D model to a 
Chief Architect 3D Viewer file or to import a 
drawing from the Room Planner mobile app, 
you must first be logged into your Chief 
Architect cloud account. See “Export Chief 
Architect 3D Viewer File” on page 1168 and 
“Import Room Planner File” on page 1169.

If you try to do either of these tasks while 
you are logged out of your cloud account, the 
Chief Architect Account Login dialog will 
open, giving you an opportunity to log in.

You can also log into or out of your online 
account at any time by selecting Help> Log 
in to Chief Architect Account or Help> 
Log out of Chief Architect Account.

Chief Architect Account Login 
Dialog

When importing a Room Planner file, use the 
same E-mail Address and Password that 
you used to save the drawing to the cloud in 
Room Planner.

When exporting a model as a Chief Architect 
3D Viewer file, use the E-mail Address and 
Password that you use to log in to your 
account on our website, 
chiefarchitect.com.

Export Chief Architect 3D Viewer File
The Chief Architect 3D Viewer is a 
mobile app that allows a model 

created in Chief Architect to be viewed on a 
mobile device. While a 3D view is active, 
select File> Export> Export Chief 
Architect 3D Viewer File. 

In order to export a Chief Architect 3D 
Viewer file, you must be logged in to your 
Chief Architect cloud account. 

Export 3D Viewer File Dialog

• The Name of the current plan file popu-
lates this field by default. Specify a differ-
ent name for the exported 3D Viewer file 
if you wish.

• Type a brief Description of the model.

http://www.chiefarchitect.com/


Import Room Planner File

 1169

• The Surface Count and Texture Size dis-
play here for reference. Large Surface 
Count and/or Texture Size values can 
impact performance in the mobile app.

When you click OK, the 3D model is 
exported and saved to your cloud account. A 
total of three exported models may be active 
at a time for viewing and sharing; however, 

unlimited inactive models may be stored on 
the cloud for up to 30 days. To manage the 
list, visit the 3D Viewer page in your account 
on our website, chiefarchitect.com.

You can also share an exported model with 
someone so that it can be opened in the 3D 
Viewer mobile app on the 3D Viewer page of 
your account. 

For more information about the Chief 
Architect 3D Viewer, click the Check 
Knowledge Base button or visit 
chiefarchitect.com.

Import Room Planner File
Select File> Import> Import Room 
Planner File, then select and 

download a Room Planner file from the 
cloud. See “Chief Architect Account Login” 
on page 1168.

Files created in Room Planner versions 2 - 
4.1 can be imported into Chief Architect X8.

Note that the exterior walls in an imported 
Room Planner drawing will inherit their 
thickness and other properties from the 
Exterior Wall Defaults dialog in the current 
plan, while interior walls will retain the 
thickness that was set in Room Planner. See 
“Exterior and Interior Wall Defaults 
Dialogs” on page 262.

Unless a custom ceiling height has been 
specified in Room Planner, rooms in an 
imported file use the Default ceiling height 
set in the Floor Defaults dialog. See “Floor 
Defaults” on page 330.

By default, window sizes in imported Room 
Planner drawings are measured from the 
outside of their frames, just as their Height 
and Width are in the Window Specification 
dialog. If you prefer, you can specify that 
windows are measured from the inside of the 
frames in the Preferences dialog. See 
“General Panel” on page 98.

Visit roomplanner.chiefarchitect.com for 
more information about the Room Planner 
mobile app.

DXF vs DWG File Formats
.dwg is the native AutoCAD® file format. 
Originally a proprietary format, it is now 
widely used with many different products.

.dxf (Drawing eXchange Format) is a 
standard file format created by Autodesk for 
the transfer of data between other programs.

To reduce Surface Count and Texture 
Size, consider turning off unnecessary 

layers in the current 3D view before export-
ing. See “Layers” on page 143. 

http://roomplanner.chiefarchitect.com/
http://www.chiefarchitect.com/
http://www.chiefarchitect.com/products/3d-viewer/
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Many design programs can read and write 
.dxf and .dwg files. Both formats interpret 
data as CAD objects such as lines, polylines, 
and circles. Both formats can also contain 3D 
data which can be imported into Chief 
Architect, as well. 

Binary .dxf format is another related file 
format. It is easier for computers to read, is 
more accurate, and occupies less disk space 
and regular .dxf files. When exporting, 
however, bear in mind that not all 
applications support binary .dxf. 

Importing 2D Drawings
2D drawings are imported by reading entities 
from a .dxf or .dwg file and creating the 
equivalent CAD objects in Chief Architect. 

Chief Architect X8 can import 2D .dxf or 
.dwg files compatible with AutoCAD® 
through version 2016.

A .dxf or .dwg file can be imported into floor 
plan view, a Wall Elevation view, Cross 
Section/Elevation view, or a CAD Detail. 

Only drawings created in AutoCAD®’s 
Model Space can be imported directly into 
Chief Architect. Entities drawn on the first 
page of Paper Space are imported as a CAD 
block and can be inserted into a drawing 
from the CAD Block Management dialog. 
See “CAD Block Management” on page 
1114. Entities drawn on subsequent pages of 
Paper Space are not recognized. 

External references (xrefs) are not 
recognized by Chief Architect, either.

In general, all Z coordinates are mapped to 
zero. If an entity in an imported drawing has 
thickness, Chief Architect ignores it.

Supported Entities
The following is a list of the entities that are 
imported and how they are converted. All 
other entities are ignored: 

• Lines - Both 2D and 3D lines.
• Circles - Fully supported in 2D.
• Arcs - Fully supported in 2D.
• Ellipses - Fully supported in 2D. 
• Spline entities - Fully supported as 2D 

polylines.
• Polylines and Lightweight Polylines - 

Polylines are imported as polylines. 
Bumps are converted to arcs. Line widths 
are ignored.

• Lightweight Polylines - Fully supported 
in 2D.

• Points - Points are not supported unless 
the layer they are on is converted to Ele-
vation Data. See “Importing Elevation 
Data” on page 747.

• Text and Multi-line Text - Both are 
imported as Rich Text and mapped to the 
Text layer. Multi-line text objects retain 
their original width. The first font in a 
multi-line text object is applied to the 
entire object. If that font is unavailable, 
Arial is used.

• Unicode Text - Fully supported.
• Blocks and Block Inserts - A block is a 

named group of CAD entities that have 
been joined together to behave as a single 
object. A block insert is a reference to 
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such a block. Blocks are loaded by name. 
If a duplicate name is found, you can 
specify whether a block is imported under 
a new name, replaces an existing block or 
simply uses the existing block of the same 
name. 

• Hatch entities - If Import Hatch entities 
is selected on the Select File page of the 
Import Drawing Assistant for a .dwg 
file, Hatch patterns are imported as a 
CAD block consisting of solid black filled 
polylines. 

• 2D Solids (Not ACIS Solids) - Fully sup-
ported in 2D. 

• Solids - A solid is a 3 or 4-sided filled 
area. These are imported as 2D faces.

• 2D Solids (Not ACIS Solids)
• 3D Faces/Polyface Meshes - A 3D face 

has its Z coordinate mapped to zero, and 
imports as a polyline.

• Dimensions - Rotated, aligned and 3-
point angular dimensions are supported. 
All other dimension types are imported as 
lines and text rather than functioning 
dimensions.

CAD blocks containing dimensions as 
text must be exploded before the text can 
be edited separately. For more on 
exploding, see “CAD Blocks” on page 
1111.

• Attributes - Attributes are text objects 
associated with other items, like blocks. 
These are imported as text objects at the 

appropriate location but the association 
with the original object is broken.

• Line Styles - Line styles are not imported. 
Instead, if a style of the same name dis-
plays in the Chief Architect line styles, 
that line style is used. Otherwise a solid 
line style is used. 

• Layers - You can specify which layers in 
the imported drawing to import into your 
Chief Architect file. You can also choose 
how you wish to map drawing layers to 
layers in the destination file. See “Layers” 
on page 143.

Layers
There can be some confusion between 
importing a layer and mapping a layer; the 
distinction, however, is important.

You can control which objects in a drawing 
are imported by choosing to import the layers 
they are on.

Once you have elected to import a layer, you 
can then specify how you would like to map 
it in the Chief Architect drawing. You have 
three options:
• You can map all layers in the imported 

drawing to a single Chief Architect layer.
• You can map all layers in the imported 

drawing to Chief Architect layers of the 
same name. The program will create those 
layers if they do not already exist.

• You can use Advanced Layer Mapping 
to individually map each imported layer 
to a Chief Architect layer.
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Import Drawing Assistant
A 2D .dxf or .dwg file can be 
imported into floor plan view, a Wall 

Elevation view, Cross Section/Elevation 
view, or a CAD Detail. 

To import a 2D drawing file, open the view 
in which you would like to place the drawing 
and select File> Import> Import Drawing 
(DWG/DXF)  to open the welcome page 
of the Import Drawing Assistant. Click 
Next to continue. 

You can also launch the Import Drawing 
Assistant by dragging a .dxf/.dwg file from 
an operating system window into the Chief 
Architect window. 

If the file you are importing is password 
protected, you will be prompted to enter the 
password before continuing.

Select File

Click the Browse button to select the 
file that you wish to import. When a file 

is selected, its full pathname displays to its 
left. The directory containing the last file 
selected using the Import Drawing 
Assistant displays here otherwise. If the 

pathname is not a valid dxf/.dwg file, this 
text will display in red. 

CAD Details are an excellent place to 
import and organize CAD drawings. 

See “CAD Details” on page 1117.

1

Note: If the file you are importing is password 
protected, you will be prompted to enter the 
password before continuing.
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If you want to convert lines with shared 
end points to polylines and/or boxes, 

check the appropriate options. Polylines are 
not affected by these settings, nor are lines 
that do not share end points.
• Check Polylines to import lines with 

shared end points as polylines. 
• Check Boxes to import lines with shared 

end points that form a closed rectangular 
shape as boxes. 

Specify how to treat CAD blocks 
associated with the selected drawing.

• Select Import all CAD blocks to include 
all CAD blocks associated with the file 

being imported whether or not they are in 
use. See “CAD Block Management” on 
page 1114. 

• Select Only import CAD blocks if they 
are referenced in the drawing to reduce 
the volume of transferred data. 

Check Import Hatch entities to import 
areas of hatching as solid-filled 

polylines. 

Click Next to load the file into memory so 
that Chief Architect can present information 
about the contents of the file. This can take a 
while for larger files.

Select Layers

A list of the layers found in the 
imported file and information about 

each layer displays in this table. See 
“Layers” on page 143.

• In the Layer column, check the box to the 
left of each layer name to specify which 
layers you want to import. Layers with 
checked boxes are imported; those with 
unchecked boxes are not. 

2

3

4

1
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• Layers that were Visible in the original 
program are checked by default. You can 
include a layer that is not visible by 
checking the box to the left of its name. 

• Layers that were Frozen in the original 
program are not checked by default. You 
can include a frozen layer by checking the 
box to its left.

• If a layer is set to Convert To a Terrain 
Perimeter or Elevation Data, it will be 
indicated in this column provided that you 
are importing into floor plan view.

Click Select All to check the box to the 
left of all layer names in the table. Click 

Clear All to clear the checkbox to the left of 
all layer names in the table.

The Convert To drop-down list allows 
you convert the data on any layer into a 

Terrain Perimeter or Elevation Data. See 
“Terrain Perimeter” on page 716 and 
“Importing DXF/DWG Elevation Data” on 
page 753. Only available when importing 
into floor plan view.

To convert a layer to a Terrain Perimter or 
Terrain Data, click on its name in the table 
and then select an option from the Convert 
To drop-down list. The option you choose 
will then display in the Convert To column 
in the table. 

Layer Mapping

The Layer Mapping page lets you control 
how layers in the imported drawing are 
mapped into the destination file. 

The simplest option is select A single 
layer in Chief Architect and assign all 

objects in the imported drawing to that layer. 
Original layer attributes are lost, but line 

2
Note: if an open polyline is converted into a 
Terrain Perimeter, the program will draw an 
additional edge to close the gap. 

3

1
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color, style, and weight are preserved on a 
per object basis.
• Select a layer from the drop-down list or 

click the Define button to open the Layer 
Display Options dialog and specify a 
layer and its properties. See “Layer Dis-
play Options Dialog” on page 149.

The second option is to map the layers 
in the drawing to Chief Architect 

layers by name. Layers are created in the 
destination file with the same names as those 
listed on the Select Layers window of the 

Import Drawing Assistant, and the imported 
CAD objects are placed on those layers. 
• In combination with the second alterna-

tive, you may choose to import all attri-
butes for each layer into the current Layer 
Set, or import no attributes at all.

 The third option is to map each layer 
individually with complete control of 

all layer mapping options. Selecting the third 
option opens the Advanced Layer Mapping 
page.

Advanced Layer Mapping

If you select the Advanced Layer Mapping 
option, the Advanced Layer Mapping page 
displays, allowing you complete control of 
how all imported layers are mapped. 

A list of the layers found in the 
imported file and the layers in Chief 

Architect that they are mapped to display in 
this table.
• The original name of each DWG/DXF 

Layer is found in the first column.

2
3

1
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• The name of the Chief Layer that each 
imported layer is mapped to is listed in 
the second column. The initial Chief 
Layer selections depend on which option 
was selected on the Layer Mapping page.

• If a Chief Layer does not already exist in 
the destination plan or layout file, it will 
be listed as “New” in the third column.

When a row in the table above is 
selected, the Chief Layer options 

become active. Select multiple entries by 
holding down the Shift key

• If the layer in the selected row is mapped 
to an existing Chief layer, it will display 
in the drop-down; if not, the drop-down 
will be blank.

• Select a layer already present in the desti-
nation plan or layout file from the drop-
down list. 

• Click the Browse button to open the 
Layer Display Options dialog. See 
“Layer Display Options Dialog” on page 
149.

Click Next to continue.

Duplicate CAD Blocks

If one or more CAD blocks in the imported 
file have the same name as a CAD block in 
the destination plan or layout, the Duplicate 
CAD Blocks page will display. See “CAD 
Blocks” on page 1111.

There are four options. The first three apply 
to all duplicate CAD blocks in the plan. 
• The first choice is to have the program 

automatically generate unique names for 
each duplicate. For instance, if the origi-
nal file’s name is “blockname,” the pro-

gram gives the new block a name like 
“blockname_Copy_1”.

• The second option is to replace the block 
already in the plan with the duplicate 
being imported. This option is not recom-
mended, as every instance of the CAD 
block in the plan will be replaced.

• The third is to keep the block that already 
exists in the plan and discard the duplicate 
being imported.

2
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• Select the fourth option to open the 
Advanced Duplicate CAD Blocks page 
and manage each duplicate individually. 

Click Next to continue. 

Advanced Duplicate CAD Blocks

If you chose the fourth option on the 
Duplicate CAD Block page, the Advanced 
Duplicate CAD Block page displays, 
allowing you to manage each duplicate CAD 
block individually. 

Click on a CAD block name in the list of 
Duplicate Names. Select multiple names by 
holding down the Shift key.

Click one of the three active buttons in the 
center of the dialog to specify how the 
selected block(s) are to be treated. 
• Click Auto Name to have the program 

automatically generate a unique name for 
the selected CAD block. The duplicate’s 
name is the same as the original with 
“_Copy” appended to the end. 

• Click Replace to replace the existing 
CAD block in the destination file with the 
CAD block listed here. This option is not 
recommended, as all instances of the 
CAD block are replaced.

• Click Use Existing to keep the CAD 
block already in the destination file and 
discard the CAD block listed here.

Review your choices in the tables at the 
right.
• To remove a CAD block from a field on 

the right, select it and click the Remove 
button. 

Click Next to continue. 
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Drawing Unit

Select a unit of measurement from the 
drop-down list. Selecting the correct 

unit helps ensure that your imported drawing 
is accurately sized. 

If the file being imported was drawn at a 
scale other than 1:1, you can compensate for 
this scaling by creating a custom unit of 
measurement and specifying it here. See 
“Unit Conversions Panel” on page 104. 

Specify how dimensions are imported.

• Select Import as dimensions where pos-
sible to import dimensions as Chief 
Architect-supported dimension lines.

• Select Import as CAD blocks to import 
dimensions as CAD entities that are not 
recognized by Chief Architect as dimen-
sions.

Check Move drawing to the origin to 
place the drawing at 0,0. When this is 

unchecked, it is imported to the same 
location as it was drawn in the original 
application. See “3D Drafting” on page 31. 

Import Complete
When a .dxf/.dwg file is imported into Chief 
Architect, all of its components are selected 
as a group. The selection set has Move and 
Rotate edit handles available for relocating 
the entire drawing, as well as a variety of edit 
tools. Once another object or tool is selected, 
the drawing components are no longer 
group-selected. 

If you do not see your imported drawing, 

select Window> Fill Window , as it may 
have been placed at a location not currently 

Note: During the import process, Chief Archi-
tect defaults to inches or millimeters. If you 
are importing a site plan or topo prepared by 
a surveyor, or if you are importing a metric 
drawing into an imperial plan (or vice versa), 
you may need to change units. 

1

2

3
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visible on screen. When the drawing can be 
seen, move your mouse pointer over it and 
note its coordinates in the Status Bar. If any 
coordinate value has more than six digits, use 

the Transform/Replicate Object  edit 
button to move it closer to the origin. See 
“Transform/Replicate Object Dialog” on 
page 242.

Imported CAD objects can be selected and 
edited just like objects that were drawn in the 
program. See “Editing Objects” on page 177.

Exporting 2D DXF/DWG Files
Line-based 2D files can be exported from 
Chief Architect in both .dxf and .dwg file 
formats. You can specify the version of 
AutoCAD® to export to. Compatibility with 
other software may vary.

Custom line styles created in  Chief Architect 
cannot be exported. When exported to .dxf/
dwg, they are replaced by a solid line style, 
although the line weight and color are 
retained. See “Creating Line Styles” on page 
1109.

There are two ways to export a 2D drawing 
file in Chief Architect: Export Current View 
and Export All Floors.

Export Current View
To export a floor plan view, CAD 
Detail, or 3D view that is currently 

active, select File> Export> Current View 
(DWG/DXF). 

Bear in mind that Orthographicf are drawn to 
scale and will produce a 2D drawing that can 
be accurately dimensioned. Perspective 

views, on the other hand, are not scaled and 
do not produce drawings that can be 
dimensioned accurately. See “Perspective 
and Orthographic Views” on page 888.

Export All Floors
To export the floor plan view for all 
floor plans simultaneously, select 

File> Export> All Floors  (DWG/DXF) 
from any floor of the plan. The floor plans 
are exported to a single .dxf or .dwg file.

If you choose to export all floors, the file will 
contain all floors superimposed on each 
other. Upon export, each layer in your Chief 
Architect drawing is divided into separate 
layers: one for each floor. For example: 
“Electrical-2” contains objects on Floor 2 
that were originally on the “Electrical” layer.

The CAD to Walls tool can be used to 
convert imported CAD lines in floor plan 

view into doors, windows, walls, and railings. 
See “CAD to Walls” on page 300. 

You can use the CAD Detail from View 
tool to automatically create a 2D line 

drawing from a 3D Vector View. See “CAD 
Detail from View” on page 1118. 
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Export Drawing File Dialog

AutoCAD® File Format Options - 
.dxf and .dwg files created by Chief 

Architect can be compatible with a variety of 
AutoCAD® versions. Specify which version 
from the drop-down list. 

The Layer Options settings allow you 
to control the layers associated with the 

file being exported. See “Layers” on page 
143.
• Select a Layer Set to for the drawing 

being exported. See “Layer Sets” on page 
146. Not available in layout files.

• Click the Define to open the Layer Dis-
play Options dialog and modify the 
selected Layer Set. Not available in layout 
files.

• Split Wall Assemblies Into Layers - The 
lines that represent wall layers can be 
exported onto different layers, allowing 
them to be displayed separately. See 
“Wall Type Definitions” on page 302.

• Select Export Only Displayed Layers to 
export only those layers that are displayed 
on screen. This is what always occurs 
when exporting from layout, but is not an 
available option in layout files.

• Select Export all used and named lay-
ers to export all layers that either have 
something on them or have a layer name 
specified. Not available in layout files.

Other Options  

• Scaling Unit - Select the unit of measure-
ment to be used. For best results, choose 
inches or feet for Imperial plan or layout 
files, or metric units for metric files. See 

You can create a custom layer set to 
accommodate desired naming conven-

tions or display attributes. 

1

2

 3
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“Dimension Preferences and Defaults” on 
page 986.

• Uncheck Create Associative Dimensions 
to export dimensions as simple CAD enti-
ties that are not recognized dimensions by 
other programs. Associative dimensions 
are recognized by AutoCAD® and many 
other CAD programs. 

When exporting a layout page, it is often 
best to uncheck this box. 

• Check Export Pattern Lines to export 
pattern lines. Pattern lines are exported as 
normal CAD lines.

• Check Export Filled Areas to export 
filled areas as AutoCAD® 2D solid enti-
ties. 

• Check Export AutoCAD® Index Col-
ors to automatically map all colors used 
in the drawing to the closest 256 Auto-
CAD® Index Color (ACI). Black (RGB 
0,0,0) and white (RGB 255,255,255) are 
mapped to ACI 7. When unchecked, col-
ors are exported using RGB colors. 

Dimension lines using non-default primary 
or secondary formatting will lose their 
changes and will use the default format(s) 
upon export.

When you are satisfied with your selections, 
click the Export button to save the exported 
file as either a .dxf, binary .dxf, or .dwg file. 

Additional 2D Export Information
The export process converts high level Chief 
Architect objects (doors, windows, etc) into 
simple, CAD-based objects (lines, arcs, etc). 
Chief Architect exports all data to 
AutoCAD®’s Model Space. 

Supported Entities
The following entity types are currently 
supported for 2D export:

Line - The simplest entity. In AutoCAD®, 
lines are 3 dimensional with the Z coordinate 
set to zero.

Arc - Arcs have a start angle, end angle and 
radius. 

Circle - Fully Supported.

Multi Line Text - If exporting to an 
AutoCAD® release that supports multi-line 
text, Chief Architect writes the file as multi-
line text. If exporting to a version that does 
not support multi-line text, the file is written 
as simple text. 

Unicode Text - Fully supported.

Polylines - Polylines are a collection of 
points with lines or arcs connecting them. 
Chief Architect supports both lines and arcs. 
Arcs are referred to as bulges in AutoCAD®.

Block Insert - A block insert is a reference 
to a block, which is a named collection of 

Note: Binary .dxf is easier for computers to 
read, is more accurate, and occupies less 
disk space, but some applications do not sup-
port binary .dxf. 
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entities. A block can also contain block 
inserts. 

Dimensions
Aligned, rotated, and angular dimensions can 
all be exported. CAD blocks containing 
dimensions as text must be exploded before 
the text can be edited separately. See “CAD 
Blocks” on page 1111.

Dimensions with text added using the Add 
Additional Text  tool are not supported 
when exported to .dxf/.dwg. When exported, 
they are converted to text and CAD lines. 
See “Add Additional Text” on page 1018. 

Each dimension has an associated block 
containing a representation of the dimension 
as it is drawn in Chief Architect. It also 
contains all the data to recreate that 
information.
• When an exported dimension is modified 

in AutoCAD® or other CAD program, its 
appearance changes. 

• Chief Architect does not support arrow-
head styles or fonts.

• Three kinds of dimensions are generated: 
Aligned, Rotated and 3 Point Angular. 

• Please refer to AutoCAD® documentation 
for more information.

Layers
Layers in other systems are similar to Chief 
Architect layers, but there are some subtle 
differences. Layer information is mapped as 
follows:

Line Types
A line type, or line style, is used by layers 
and entities to determine how lines are 
drawn. Chief Architect line types installed 
with the program are supported on export; 
custom, user-created line styles, however, are 
not. See “Line Styles” on page 1108.Note: Uncheck “Use Associative Dimensions” 

in the Export Drawing File dialog if the CAD 
program you are using does not support 
AutoCAD® Associative dimensions. See 
“Export Drawing File Dialog” on page 1180.

Chief 
Architect

Other Systems

Name Name

Color Nearest AutoCAD® Color. Chief 
Architect uses the default Auto-
CAD® color table to determine 
this mapping.

Display On

Size Line Weight. In AutoCAD®, line 
weights are determined by a 
table of mm line widths. Chief 
Architect maps to the closest 
match in this table based the cur-
rent view’s Line Weight Scale. 
See “Drawing Sheet Setup Dia-
log” on page 1216.

Style Line type

Lock Lock
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3D Data Import Requirements
Importing a symbol that can be used by Chief 
Architect is a relatively simple process that 
begins with previously created 3D data. This 
3D data often comes from a program other 
than Chief Architect. If you use another 3D 
modeling program to create the 3D data, be 
aware of the following requirements before 
attempting to create symbols.

There are a number of requirements that 
must be met before any 3D data can be used 
to create a symbol in Chief Architect:
• The 3D data must be stored in a standard 

Drawing Exchange File (.dxf), Auto-
CAD® Drawing (.dwg), object (.obj), 3D 
Studio® Mesh (.3ds), stereolithography 
(.stl), COLLADA (.dae), or SketchUp 
version 2016 and prior (.skp) file format. 
If you have 3D data in another format, 
you must convert it into one these formats 
first.

• Geometry and material information stored 
in .3ds files are imported; cameras and 
lights are not.

• The 3D model must be composed of 3D 
DWG or 3DSOLID solid entities, or face 
data. Faces are typically referred to as 3D 
faces, polygonal faces, or poly meshes. 
Other types of entities such as lines, 
curves, circles, polylines, and free form 
surfaces can exist in the file but are not 
imported when the symbol is created. 
This is true for all (.dxf/.dwg/.obj/.3ds/
.skp) file types.

• The face data should be assigned to dif-
ferent layers so that you can map them to 
the correct materials when viewing them 
in 3D. It is helpful to name your layers 
using a convention that identifies that 
materials should be assigned to each sub-
component.

• Pay attention to the origin and orientation 
of the 3D data when designing symbols. 
Chief Architect allows some adjustment 
when creating the symbol, but it is easier 
to build the 3D data correctly before 
importing it into Chief Architect. For 
more information about defining the ori-
gin, see “Symbol Origin” on page 1207.

• If a symbol with faces that have more 
than four vertices is imported, the faces 
are truncated, resulting in an object that 
appears to have holes. The best remedy is 
to re-export the model from the original 
application using only triangular or quad-
rilateral faces.

• Chief Architect does not support grouped 
objects in symbols imported from .3ds 
files. 

Surface Normals
If you use third party software to create a 
.dxf /.dwg/.obj/.3ds./skp files that will be 
imported as a symbol, you should be familiar 
with the concept of surface normals.

If you use third party software to create a 
.dxf/.dwg/.obj/.3ds./skp file that will be 
imported as a symbol, you should be familiar 
with the concept of surface normals.

Chief Architect is not able to provide 
support for any third party software.
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A surface normal is a vector that is 
perpendicular to the plane of a surface. This 
vector points in one direction, determined by 
the way the face is drawn.

If a face is drawn clockwise, the surface 
normals are directed outward; if a face is 
drawn counter-clockwise, the surface 
normals point inward. Chief Architect 
assumes that the face on the positive side of 
the normal vector is the outside face.

Many objects can be drawn using only one 
side of each face. A cube is a good example: 
the inside of a cube is not visible, so it is not 
necessary to create its inside faces. When 
inside faces are not calculated, 3D views in 
Chief Architect can generate more quickly. 

Importing 3D Symbols
Chief Architect supports the import of 
3D surface and 3D solid objects saved 

in .dwg, .dxf, .3ds, .obj, .stl, .dae, and .skp 
formats.

For most file types, there are three ways to 
import a 3D symbol into Chief Architect:
• By selecting File> Import> Import 3D 

Symbol  tool.

• By selecting New> 3D Symbol  from 
the contextual menu in the Library 
Browser. See “Using the Contextual 
Menus” on page 822.

• By dragging and dropping the file from an 
operating system window into floor plan 
view. 

3D .dxf/.dwg files can only be imported by 
selecting File> Import> Import 3D 
Symbol . 

Symbols imported by clicking and dragging 
are imported for use in the current plan, 
while those imported using the Import 3D 

Symbol dialog can also be saved in the 
library. See “The Library” on page 819. 

To drag and drop a 3D symbol file

1. Open the plan in which you would like 
to import a 3D symbol and remain in 
floor plan view.

2. Open an operating system window in 
front of the Chief Architect program 
window.

3. Resize and position the window so that 
the Chief Architect program window can 
be seen behind it.

4. Click on the desired  .3ds, .obj .stl, .dae, 
or .skp file and drag it into the Chief 
Architect program window.

5. When your cursor changes to a +, click 
in the drawing area to place as many 
copies of the symbol as desired. When 
you are finished, select a different tool. 

Symbols imported by clicking and dragging 
are imported as generic stand-alone interior 
fixtures. If you wish to assign different 



Importing 3D Symbols

 1185

characteristics to a symbol, use the Import 
3D Symbol dialog to import it. 

Importing Multiple Symbols
More than one symbol can be imported into 
the Chief Architect library at a time provided 
that the following requirements are met:
• The symbols are located in the same 

folder on your computer. 
• Multiple symbols can only be imported 

using the Import 3D Symbol dialog. If 

you try to drag and drop group-selected 
files in an operating system window, only 
the file that was selected first is imported. 

• When imported as a group, symbols must 
be assigned to the same symbol category. 
If you wish to assign them to different 
categories, they must be imported sepa-
rately.

Symbols that are imported as a group are 
assigned names based on their original file 
names with the file extension omitted.

Import 3D Symbol Dialog
To import a symbol object, select 
File> Import> Import 3D Symbol. 

The Import 3D Symbol File dialog, which 
opens first, is a typical Open File dialog in 

which multiple files can be group-selected 
for import. See “Importing Files” on page 62.

The Import 3D Symbol dialog, which opens 
next, allows you to specify additional 
information about the symbol.

• The Files Selected for Import display 
here for reference. 

• Choose a symbol Category from the 
drop-down list. The category affects how 
and where the symbol can be used, and 
cannot be changed after it is imported. 

• Check Add Symbol to Library to save 
the symbol in the User Catalog. This is 
always checked when multiple symbols 
files are selected. See “Add to Library” on 
page 829.  

• Check Show Advanced Options to open 
the symbol’s specification dialog. See 
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“Symbol Specification Dialog” on page 
1195.  

• Click OK to import the symbol, then click 
in floor plan view to place the symbol at 
that location. Continue clicking to place 
as many copies of the symbol as needed. 
Select another tool when finished. 

Note: If you import a .obj, .3ds or .skp file 
with textures that are already present in your 
library, the Texture Filename Conflict 
dialog opens. See “Texture Filename 
Conflict” on page 1188. 

Symbol Categories
The category that you assign to a symbol will 
influence how the symbol can be placed in a 
plan and how it will appear in the Materials 

List and in schedules. See “Materials Lists” 
on page 1283 and “Schedules and Object 
Labels” on page 1267.

Category Placement Schedules and Materials Lists
Cabinet Can only be placed as a free-standing 

object. See “Cabinets” on page 675.
Listed in Cabinets category of Materials 
Lists; can be included in Cabinet Sched-
ules.

Cabinet 
Door/Drawer

Can be assigned to a cabinet or free-
standing. See “Cabinets” on page 
675.

When free-standing, listed in Cabinets 
category of Materials Lists. When 
assigned to a cabinet, listed as a compo-
nent of the cabinet in Materials Lists and 
Cabinet Schedules.

Door Can only be placed in a wall or 
assigned to a doorway. See “Doors” 
on page 361.

Listed in Doors category of Materials 
Lists; can be included in Door Schedules. 

Doorway Can only be placed in a wall. See 
“Doorways” on page 363.

Listed in Doors category of Materials 
Lists; can be included in Door Schedules.

Electrical Can be specified as a variety of free-
standing electrical items and may be 
ceiling-, floor-, wall- or cabinet-
mounted. See “Electrical” on page 
637.

Listed in Electrical category of Materials 
Lists; can be included in Electrical 
Schedules.

Fixture 
(Exterior)

Exterior Fixtures can act as plumbing 
items or appliances and have many 
different options. They may be free-
standing, inserted into a cabinet, 
mounted on the ceiling, a wall, under 
a cabinet or on a roof. 

Listed in Fixtures category of Materials 
Lists; can be included in Fixture Sched-
ules.
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3D Symbols and Materials
When a symbol is imported into Chief 
Architect, material definitions may be 
included with it. Whether and how material 
information is included depends on the 
symbol’s file format. See “About Materials” 
on page 848. 

DXF/DWG and STL Files

.dxf/.dwg and .stl files do not include 
information about material definitions. When 
imported, default materials for the selected 
symbol type will be assigned. If the .dxf/
.dwg or .stl file associated with a symbol is 

Fixture 
(Interior)

Interior Fixtures can act as plumbing 
items or appliances and, like Exterior 
Fixtures, have many different options. 

Listed in Fixtures category of Materials 
Lists; can be included in Fixture Sched-
ules.

Furnishings 
(Exterior)

Can only be placed as a free-standing 
object but can be ceiling-, floor- or 
roof-mounted.

Listed in Furniture category of Materials 
Lists; can be included in Furniture Sched-
ules.

Furnishings 
(Interior)

Can only be placed as a free-standing 
object but can be ceiling-, floor- or 
roof-mounted.

Listed in Furniture category of Materials 
Lists; can be included in Furniture Sched-
ules. 

Geometric 
Shapes

Can only be placed as free-standing 
object. See “General Shapes” on 
page 793.

Listed in General category of Materials 
Lists. 

Hardware Can be specified as a hinge, handle 
or lock and assigned to a cabinet, to a 
door, or free-standing.

Listed as a component of the object it is 
assigned to in Materials Lists or in Hard-
ware category when free-standing; can 
be included in schedules as a component 
of the object it is assigned to. 

Millwork Can be free-standing or assigned to 
an object such as a railing or cabinet. 
See “Millwork” on page 659. 

Listed in Exterior Trim, Interior Trim, or 
Fixtures category of Materials Lists. May 
be included in Fixtures Schedules.

Molding Can only be assigned to a room, cabi-
net, countertop or molding polyline. 
See “Trim and Molding” on page 653. 

Listed in Exterior Trim or Interior Trim cat-
egory of Materials Lists. 

Plant Can only be placed as a free-standing 
object. See “Plant Tools” on page 766.

Listed in Landscaping category of Materi-
als Lists; can be included in Plant Sched-
ules. 

Sprinkler Can only be placed as a free-standing 
object. See “Sprinkler Tools” on page 
774.

Listed in Landscaping category of Materi-
als Lists. 

Window Can only be placed in a wall. See 
“Windows” on page 391.

Listed in Windows category of Materials 
Lists; can be included in Window Sched-
ules. 
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changed, all previously specified material 
information for the symbol will be lost.

All layers, layer names, solids and instances 
of blocked solids from the .dxf/.dwg or .stl 
file display in the list of components on the 
left side of the MATERIALS panel of its 
specification dialog. See “Materials Panel” 
on page 852.

OBJ Files

Material definitions for most .obj files are 
saved in a separate file with the .mtl file 
extension. If such a file exists, the materials 
associated with the .obj file display in the list 
on the left side of the MATERIALS panel of its 
specification dialog. 

If Chief Architect does not receive material 
definition information in an accompanying 
.mtl file, default material properties are 
assigned. 

Material definitions for .obj files can also 
include texture information in the form of 
image files (.jpg, .png, etc). 

In order to properly import an .obj file, Chief 
Architect needs the .obj file, the .mtl file, 
and any referenced texture files. If a texture 
file is not available, the material it is 
associated with is created without a texture.

The material definitions associated with an 
imported .obj symbol are not available for 
use by other objects in Chief Architect until 
that symbol has been placed into a plan. The 
associated texture files are then copied to the 
user’s Textures folder. See “Chief Architect 
Data” on page 53. 

3DS and DAE Files

Material definitions for .3ds and .dae files 
refer to texture information in separate image 
files. 

In order to properly import a .3ds and .dae 
file, Chief Architect needs these referenced 
image files. If a texture file is not available, 
the material it is associated with will be 
created without it. The associated texture 
files are copied to the user’s Textures folder. 

SKP Files

The textures associated with a .skp file are 
saved in the file. After you import a symbol 
and either place it in a plan or add it to the 
Library, these textures are saved in the Chief 
Architect Textures folder. 

Chief Architect does not support deformed 
textures. If a texture associated with a .skp 
file is deformed, it will be imported without 
the deformations. 

Texture Filename Conflict
If a texture of the same name already exists 
in the plan when an .obj, .3ds, or .skp file is 

imported, the Texture Filename Conflict 
dialog displays. 
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• Select Rename the imported texture, 
then click the Browse button to create a 

copy of the texture’s image file with a 
new name that you specify. 

• Select Use the existing texture instead 
of the imported texture to keep the 
existing texture.

• Select Replace the existing texture with 
the imported texture to replace the tex-
ture already present in the plan with the 
new, imported one.

• Check Do this for all remaining textures 
in this object to use the same selection 
for all textures with filename conflicts 
associated with this symbol. 

Exporting a 3D Model
The entire 3D model, o rany part of it that 
you choose, can be exported from Chief 
Architect int o one of four different formats:
•      3DS Format
•      DAE Format
•      STL Format
•      DXF/DWG Format

To export the 3D model

1. A camera view or overview must be 
active. See “Types of 3D Views” on 
page 888. 

2. Make sure that everything that you want 
to export is set to display in the current 
view, and everything you do not want to 
export is not set to display. See “Layers” 
on page 143. 

•  Any surfaces removed using the Delete 
Surfaces  tool will not be exported. 
See “Displaying 3D Views” on page 
907. 

3. When the model is ready, select File> 
Export and choose the format that you 
want to use. 

4. Give the file a name, making sure to 
save it in the desired location. See 
“Exporting Files” on page 58.

3DS Format
A .3ds file can be opened by any 
program that uses 3D Studio®’s .3ds 

format. When the model is ready, select 
File> Export> 3D Model (3DS) to export to 
this format.

The Export 3D Studio (3DS) Mesh dialog 
opens: 
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• Check Truncate Texture Names to 8.3 
format to truncate material and object 
names to an eight character file name with 
a three character extension. This allows 
import into applications that support only 
legacy .3ds files. 

The Export 3D Studio® (3DS) Mesh dialog, 
which opens next, is a typical File Save 
dialog. 

Any material textures used in the model are 
saved as image files in the same location as 
the saved .3ds file. You may find it helpful to 
export the .3ds file to an empty folder 
created for this purpose.

DAE Format
A .dae file can be opened by any 
program that uses COLLADA™’s 

.dae format. When the model is ready, select 
File> Export> 3D COLLADA Model to 
export to this format.

The Export COLLADA Model dialog is a 
typical File Save dialog. 

Any material textures used in the model are 
saved as image files in a folder in the same 
location as the saved .dae file. The folder has 
the same name as the .dae file, appended 
with “_textures”. 

STL Format
An .stl file can be opened by any 
program that uses Stereolithography 

format, and can be printed using a 
stereolithography machine, or 3D printer. 
When the model is ready, select File> 
Export> 3D Model (StL). 

The Export StL Model dialog is a typical 
File Save dialog. 

A 3D model exported to .StL format does not 
include any material or texture information.

DXF/DWG Format
A .dxf or .dwg file can be opened by 
any program that uses AutoCAD®’s 

3D .dxf or .dwg format. When the model is 
ready, select File> Export> 3D Model 
(DWG/DXF) to export to this format.

The entire 3D model, including geometry, is 
exported, with all surfaces exported as 
3DFACE entities. 

3D DXF/DWG Layer Names
When you export a 3D model to .dxf/.dwg 
format, all surfaces are exported as 3DFACE 
entities. Each entity represents a surface in 
the 3D model. The entities are placed on 
layers that are named by Chief Architect: 

A 3D model exported to .dxf/.dwg does 
not include any material or texture infor-

mation. 

AutoCAD® 
Layer Name

Chief Architect  
Surface / Object

A-APPL-MAIN Appliance
A-CASE-CABF Cabinet Door
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DXF Codes
Each exported layer name can include a DXF 
Code for the materials applied to objects on 
that layer. If a material has been specified for 
an object and appears on its surface, the DXF 
code for the material is included in the layer 
name. 

DXF Codes are specified for each material in 
the Plan Materials dialog. See “Plan 
Materials Dialog” on page 863.

A-CASE-CABN Cabinet Box
A-CASE-CNTR Cabinet Counter Top
A-CASE-GLAS Cabinet Glass
A-CASE-SOFF Soffit
A-CASE-TOEA Cabinet Toe Area
A-CEIL-BAY Bay / Bow Window 

Ceiling
A-CEIL-MAIN Platform Ceiling
A-CEIL-SLOP Roof Ceiling
A-DOOR-STND Door
A-EQPM-DOOR Window Hardware
A-EQPM-HDWR Cabinet Hardware
A-FIXT-GLAS Fixture Glass
A-FIXT-MAIN Fixture
A-FLOR-BAY Bay / Bow Window 

Floor
A-FLOR-MAIN Platform Floor
A-FOOT-FOOT Footing Top
A-FRAM-CEIL Ceiling Framing
A-FRAM-DECK Deck Framing
A-FRAM-GENL Framing
A-FRAM-JOIS Floor Framing
A-FRAM-ROOF Roof Framing
A-FRAM-TRUS Truss Framing
A-FRAM-WALL Wall Framing
A-FURN-MAIN Furniture
A-GLAZ-DOOR Door Glass
A-GLAZ-WIND Window
A-HRAL-BAL Stair Baluster
A-HRAL-BLST Railing Baluster
A-HRAL-NWEL Newel
A-HRAL-RAIL Handrail
A-CASE-CABD Cabinet Drawer
A-MASN-FIRE Fireplace
A-NONE-NONE Miscellaneous
A-PLAT-RIM Platform Rim
A-RISR-MAIN Stair Riser
A-ROOF-EAVE Roof Soffit
A-ROOF-FASC Roof Fascia

A-ROOF-MAIN Roof
A-STRS-RUNR Stair Runner
A-STRS-TRED Stair Tread
A-STRS-UNDR Stair Bottom
A-WALL-BAY Bay / Bow Window 

Wall
A-WALL-EXTW Corner Board
A-WALL-MAIN Wall
A-WALL-PAPE Wallcovering
A-WALL-PONY Pony Wall
A-WDWK-EXTR Exterior Door / Window 

Trim
A-WDWK-EXTTRIM Exterior Sash
A-WDWK-MOLD Molding
A-WDWK-SHLF Shelf
A-WDWK-TRIM Interior Door / Window 

Trim
C-PROP-CURB Curb
C-PROP-ROAD Road
C-PROP-TERA Terrain
C-PROP-TRFE Terrain Feature
C-PROP-TRSK Terrain Skirt
E-ELEC-TRIM Electrical
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Export to REScheck
REScheck™ is a residential energy 
code compliance program offered by 

the U.S. Department of Energy that evaluates 
the thermal envelope of a structure and 
determines how well it meets various energy 
codes. For more information, visit: 
http://www.energycodes.gov/rescheck.

To export a plan’s thermal envelope 
information for use in REScheck™, select 

File> Export> Export to REScheck . 
Chief Architect exports using the .rxl file 
format, which can be used by both the 
desktop and web-based versions of 
REScheck™.

Exported Project Data
Chief Architect can export the following 
REScheck Project data: 
• Front Faces - The side of the house that 

faces down on-screen is considered the 
front, and North is considered up on-
screen unless a North Pointer is used. See 
“North Pointer” on page 943. 

• The Conditioned Floor Area is calcu-
lated and exported by Chief Architect. 
See “Conditioned Area Totals” on page 
1297. 

• The Owner/Agent information is drawn 
from the plan file’s Client Information. 
See “Client Information” on page 1127.

• The Designer Contractor information is 
drawn from the plan file’s Designer Infor-
mation. See “Designer Information” on 
page 1127.

In a REScheck report exported from Chief 
Architect, the Project Type is set as “New 
Construction” and “1-and-2 Family, 
Detached” is selected under Building 
Characteristics. Location and Title/Site/
Permit are not exportable 

Exported Envelope Data
Nearly all REScheck Envelope data can be 
exported from a Chief Architect plan: 
• Floors - The Assembly type, Gross Area, 

and Cavity and Continuous R-Values are 
exported. See “Floor and Ceiling Platform 
Definitions” on page 344. 

• Slabs on Grade - The Slab Perimeter and 
Continuous R-Value are exported.  Slab 
Depth of Insulation is not included and 
must be entered manually. See “Founda-
tions” on page 447.

• Ceilings - The Assembly type, Gross 
Area, and Cavity and Continuous R-Val-
ues are exported. 

• Walls - The Assembly type, Orientation, 
Gross Area, and Cavity and Continuous 
R-Values are exported. All are exported as 
Walls rather than Basement or Crawl 
Walls. Like walls on the same floor are 
grouped by orientation. See “Wall Type 
Definitions Dialog” on page 305. 

• Doors and Windows - The Assembly 
type, Orientation, Gross Area, U-Factor, 

Note: The On Center Spacing of Framed 
walls is derived from the framing material 
assigned to the wall type’s Main Layer. See 
“Material Types” on page 860. 

http://www.energycodes.gov/rescheck
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and Solar Heat Gain Coefficient (SHGC) 
are exported. See “Energy Values Panel” 
on page 388. 

Information about skylights and mulled units 
is not exported. 

Wall Labels
If any walls forming the thermal envelope 
have labels, they will be exported and used in 
the REScheck report. If similar walls are 
grouped, their labels will not be used unless 
the labels are all identical. See “Wall Labels” 
on page 282.

Export to REScheck Dialog

• Uncheck Group Similar Walls to treat 
walls on multiple floors separately. When 
checked, walls with the same properties 
and orientation are added together and 
treated as one wall, regardless of the 
floors they are on. 

• Uncheck Group Similar Doors/Win-
dows to treat all doors and windows sepa-
rately. When checked, doors and windows 
with the same properties and orientation 
are added together and treated as one item 

Click the Export button to open the Export 
REScheck File dialog, which is a typical 
Save File dialog. See “Exporting Files” on 
page 58.
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Chapter 38:

Custom Symbols

Chief Architect provides a complete set of 
architectural tools for highly customized 
design, as well as the vast selection of 
objects in the Library Browser that can be 
used to add more detail to a plan. 

In addition, if you don’t find precisely what 
you need, you can either import symbols 
from third party sources or create your own 
symbols in Chief Architect. See “Importing 
3D Symbols” on page 1184.

Custom symbols can also be edited and 
added to the library. See “The Library” on 
page 819.

Chapter Contents
•      Symbol Specification Dialog
•      Get Last Symbol
•      Convert to Symbol
•      Editing Custom Symbols

Symbol Specification Dialog
The Symbol Specification dialog 
allows you to specify the attributes of 

a symbol before it is imported, as well as to 
edit existing symbols in either a plan or the 
Library Browser. 

This dialog can be accessed in several ways: 
• Select a symbol and click the Open 

Symbol  edit button. Only the 
selected symbol is affected by any 
changes that you make: other instances of 
the symbol in plans are not affected, nor 

is the symbol saved in the library. Cabinet 
symbols cannot be edited in this manner.

• Right-click on a symbol in the library and 
select Edit> Open. Editing a symbol in 
the library changes does not affect any 
instances of the symbol already placed in 
a plan. Cabinet symbols cannot be edited 
in this manner. See “In the Specification 
Dialog” on page 842.

• Check Show Advanced Options in the 
Import 3D Symbol dialog. Editing a 



1196

Chief Architect X8 Reference Manual

symbol as it is imported determines the 
initial attributes that it will have once 
brought into a plan or saved in the library. 
See “Importing 3D Symbols” on page 
1184. 

• Check Show Advanced Options in the 
Convert to Symbol dialog. See “Convert 
to Symbol” on page 1206.

3D Panel
The options on the 3D panel primarily affect 
the symbol’s appearance in 3D views. 

Specify how the symbol’s Name should 
appear in its object specification dialog, 

its label, in the Materials List, and in 

schedules. See “Materials Lists” on page 
1283.
• Enter a Symbol Name. When imported 

into the program, a 3D symbol is given 

1
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the same name as its file name. Not avail-
able when multiple symbols are selected. 
See “Importing 3D Symbols” on page 
1184.

• Select a Display Size format from the 
drop-down list to append the name of the 
symbol with size information. 

3D Geometry - 

• The pathname of the file being imported 
displays here for reference. If multiple 
symbols are being imported, only one file 
displays. If the symbol is not in the pro-
cess of being imported, “Embedded 
Geometry” displays instead. 

• Click the Replace Geometry button to 
choose a file to associate with the 
selected symbol. Not available when a 
symbol is being imported or converted. 

• Select the Drawing Unit that was used to 
create the symbol. If any units other than 
inches or mm are selected, the program 
will convert the data into units appropri-
ate for Chief Architect. Only available 
when a symbol is being imported. To 
apply a change to this setting, you must 
also click the Browse button and reload 
the symbol data from the original file. 

• Click the Use Imported Origin Offset 
button to use the symbol origin saved in 
the file being imported rather than use an 
origin based on the symbol’s type. Only 
available when a symbol is being 
imported. See “Symbol Origin” on page 
1207.

Specify the Origin Offset, which 
affects how the selected symbol is 

positioned when placed in a Chief Architect 
plan. Specifying a particular origin is helpful 
if the selected symbol will be inserted into 
another object, such as a sink to be placed in 
a cabinet. See “Symbol Origin” on page 
1207.
• Leave these values at 0 to use Chief 

Architect’s default origin for the symbol. 
For most symbols, this is the appropriate 
option.

• Enter new values to manually adjust the 
origin. The values in the X, Y, and Z 
fields represent the offset of the symbol’s 
origin point from the default Chief 
Architect origin. This option is appropri-
ate for symbols that will be placed within 
other objects.

Rotation - These settings allow you to 
rotate the selected symbol(s) about the 

X, Y, and Z axes. Note that rotating a symbol 
will affect the location of its top, bottom, 
front, and /or back - and thus the location of 
its default origin. 
• Select the X, Y, or Z Axis. 
• Specify the Angle to rotate the symbol in 

the text field. 90° is set by default.
• Click the Rotate + or Rotate - button to 

rotate the object around the selected axis 
in a clockwise or counterclockwise direc-
tion, respectively. 

Specify how the selected symbol’s 3D 
Faces are generated. 

• The Number Of Faces that a selected 
symbol has displays here for reference. 
When multiple symbols are being 
imported, nothing displays. Although 
there is no limit to the number of faces, 

Note: SKP files are always imported using
inches, regardless of the default units used in
the plan file.

2

3

4

5
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large numbers can increase rendering 
time significantly. 

• Specify the Smoothing Angle, which 
determines whether two adjacent surfaces 
are shown with a smooth or sharp angle 
between them in rendered views. If the 
angle between two surface normals is less 
than this angle, normal averaging is used 
to give the effect of a curved surface. 
This value also effects the generation of 
automatic edge lines.

A good example is a hexagonal cylinder. 
The angle between adjacent surfaces is 
360/8, or 45°. If you want it to look cylin-
drical, set the Surface Smoothing Angle 
to something greater than 45°. If you 
want to make the cylinder look hexago-
nal, set it to less than 45°. 

• Automatic Edge Lines is checked by 
default so the program can choose an 
appropriate Smoothing Angle for legacy 
symbols migrated into version X8. It 
applies specifically to legacy symbols as 
they are brought into the program and in 
most cases, should remain checked.

• Reverse Surface Direction will be either 
checked or unchecked by the program 
automatically, depending on where the 
selected symbol was created: it is 
checked for symbols created in the pro-
gram or imported from an .skp file, and 
typically unchecked for symbols 
imported from other file types. 

In most cases, this setting should not be 
changed; however, if you export a sym-
bol and encounter problems with its sur-
faces, changing this setting may help.

Note that Chief Architect imports the 
front side of faces in .skp files; however, 
it does not support faces with different 
textures on the front and back and will 
import the back side as a separate face.

• Check Draw Self Intersection Lines to 
display lines where parts of the selected 
symbol are drawn in such a manner that 
they occupy the same 3D space as other 
parts of the same symbol. In most cases, 
this box should be unchecked; and if the 
selected symbol does not have self inter-
section lines, it will not be available. 

• Check Cull Layered Transparent Sur-
faces to if you need to troubleshoot the 
appearance of a transparent symbol. Gen-
erally, this box should be left unchecked.

• When a symbol is being imported, check 
Use Imported UV Map to preserve the 
UV map that was created for it. When 
unchecked, the symbol’s textures are 
mapped using a modified version of its 
UV map that assumes square shaped tex-
ture images. When the symbol uses a 
“decal sheet” style texture or one that is 
not square in shape, this box should be 
checked. 

A preview of the symbol’s appearance 
displays here and updates as changes 

are made to the settings in this dialog. When 
multiple symbols are selected, the most 
recently selected symbol displays. See 
“Dialog Preview Panes” on page 41. 

• Click the Show Origin  button to dis-
play the location of the selected symbol’s 
origin in the preview. Not available if 
Show Plan View is selected. See “Sym-
bol Origin” on page 1207. 

6
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2D Block Panel
The 2D BLOCK panel allows you to select a 
2D CAD block to represent the selected 
symbol in floor plan view. See “CAD 
Blocks” on page 1111. 

This panel is not available for Doors, 
Doorways, or Cabinet Doors, nor is it 
available when multiple symbols are being 
imported.

Selected CAD Block - 

• The CAD block associated with the 
selected symbol is selected in the list of 
Available CAD Blocks and displays in 
the preview.

• The CAD block name of an imported 
symbol will be based on the symbol’s 
original file name. See “Importing 3D 
Symbols” on page 1184. 

• You can select a different CAD block 
from the list if you wish.

If changes are made to an existing sym-
bol in a plan or the Library Browser, you

may also want to generate a new 2D Block to
represent it in floor plan view.

1
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• Click the Generate Block button to auto-
matically generate a CAD block based on 
an overhead projection of the selected 
symbol and add it to the list. 

• Enter a Rotation Angle to rotate the 2D 
CAD block from its original angle of 0°. 
The orientation of the 2D CAD block in 
floor plan view does not affect the sym-
bol’s orientation in 3D views.

Check Fill to display a fill color in 
selected symbol’s CAD block and 

enable the settings that follow.
• Click the Color bar to select a fill color 

for the 2D block. See “Color Chooser/
Select Color Dialog” on page 875. 

• Use the Transparency slider bar or text 
field to control how transparent the fill 
color is. 

• Check Use Original Plan Colors to 
make the symbol’s fill color white.

A preview of the selected CAD Block 
displays here when Show Plan View is 

selected. See “Dialog Preview Panes” on 
page 41.

Options Panel
The settings on the OPTIONS panel affect how 
a symbol behaves and can be placed. 

The options that display in this window vary, 
depending on the type of symbol selected. 

Only available for Cabinet Door/Drawer, 
Doorway, Electrical, Fixture, Furnishings, 
and Hardware symbols.

If you do not see a CAD block in this list
that suits your needs, you can create

your own. See “Custom 2D Symbols” on
page 1113. 

2

3
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If the selected object is an Electrical symbol, 
a selection of Placement Options specifies 
where the object is mounted: on the floor, 
ceiling, wall, or under a cabinet.

The Special Placement options add 
placement restrictions and abilities to 

the selected symbol. When none of these is 
selected, the symbol will sit on the floor or 
terrain. Once placed, its height can be 
adjusted in its specification dialog. See 
“Placing Library Objects” on page 836. 

The Schedules options are available for 
interior and exterior fixture symbols 

and allow you to include the selected symbol 
in specific types of schedules. See “Working 
with Multiple Schedules” on page 1272. 

Requirements - Specify whether the 
selected fixture symbol requires 

Natural Gas, Water/Drain, Standard Voltage, 
or High Voltage. 

Additional Options specify the selected 
symbol’s purpose. 

• Select a symbol Type from the drop-
down list. Available for doorway, cabinet 
door/drawer, fixture, furniture and win-
dow symbols. 

• A variety of checkboxes may be avail-
able, depending on the selected symbol’s 
Category and Type. 

• The Default Light Offset field is only 
available only for electrical symbols in 

1

2

3

4
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the process of being imported or con-
verted, and is enabled when the Light 
option is checked. Enter a distance to off-
set the light source from the symbol’s ori-
gin. The Light Offset for an existing 
symbol can be specified in its Electrical 

Service Specification dialog. See “Light 
Data Panel” on page 943.

A preview of the selected symbol 
displays on the left. See “Dialog 

Preview Panes” on page 41. 

Materials Panel
The MATERIALS panel allows you to assign 
materials to the symbol’s components and is 
similar to the Materials panel in many 
specification dialogs. See “Materials Panel” 
on page 852.

If the selected symbol is in the process of 
being imported, bear in mind that .dxf/.dwg 
files do not include material information, so 
the symbol’s components will not have 
materials assigned to them. See “3D 
Symbols and Materials” on page 1187. 

Sizing Panel
The settings on the SIZING panel allow you to 
control the size of a symbol’s bounding box 
and how the symbol behaves when resized. 

Bounding Box Dimensions - Specify 
the Width, Depth and Height of the 

selected symbol’s bounding box, measured 
from the symbol’s origin with 1/16" (1 mm) 

5

A symbol’s actual size cannot be
changed in the Symbol Specification

dialog. See “Resizing Objects” on page 229.

1
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accuracy. Not available when multiple 
symbols are selected. 

When a symbol is first created, its bounding 
box is the same size as the actual 3D object. 
See “Bounding Boxes” on page 1208.

Stretch Planes define where a symbol 
stretches when resized. If no stretch 

planes are used, the symbol resizes 
uniformly. See “Stretch Planes and Zones” 
on page 1209.
• Width planes are oriented vertically and 

run from the back of the symbol to its 
front, or along the symbol’s X axis. 

• Depth planes are oriented vertically and 
run from one side of the symbol to the 
other, or along the symbol’s Y axis. 

• Height planes are oriented horizontally, 
or along the symbol’s Z axis. 

Uniform Stretch Zones define an area 
between two planes that stretches 

uniformly when the object is resized, leaving 
the area outside of the zone unaffected. 

Cabinet Panel
The CABINET panel is only available for 
Cabinet symbols as they are being imported. 
The settings on this panel control the 

function of both the cabinet and its individual 
parts once it is imported.

2

Note: Stretch Planes and Stretch Zones do
not affect a symbol’s 2D CAD block, which
always resizes in a uniform manner. If you
resize a symbol using custom Stretch Planes
and Zones, consider generating a new CAD
Block. See “2D Block Panel” on page 1199.

3
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Specify the symbol’s Cabinet Type: 
Base Cabinet, Wall Cabinet or Full 

Height Cabinet.

Layer/Component Assignment - 
Specify the type of component for each 

layer associated with the cabinet symbol.
• Click on a Layer Name in the list, then 

select the type of cabinet component type 

from the Component Type drop-down 
list.

Opening Panel
The settings on the OPENING panel define the 
selected Window or Doorway symbol’s 
rough opening when placed in a wall. 

The OPENING panel is only available for 
Windows and Doorways.

An editable diagram of the symbol’s 
wall opening displays here. 

Edit the symbol’s opening size and shape by 
clicking on a dimension number and typing 

1

2 Cabinet symbols should not include
hardware. Handles and hinges are

assigned according to cabinet defaults when
the cabinet is created. See “Door/Drawer
Panel” on page 704.

1
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the desired value. To update the preview, 
press the Tab key.

If the Window or Doorway has an 
angled or arched top, click the Opening 

Sections drop-down and choose the section 
diagram that most closely resembles the 

rough opening shape that you want. You can 
then edit the section as needed.

Plan View Panel
The PLAN VIEW panel controls the 
appearance of Window and Doorway 
symbols in floor plan view. 

The PLAN VIEW panel is only available for 
Windows and Doorways. 

An editable diagram of the symbol’s 
representation in floor plan view 

displays here. The settings here also affect 
how many units the symbol contains as well 
as their size in both 2D and 3D views. 
• To change the size of the symbol’s units 

in floor plan view, click on a dimension 
number and type the desired value. Press 
the Tab key to update the diagram.

• To change a unit in the preview from a 
window to a door swing, click on the unit 
in the diagram.

Click the Plan View Sections drop-
down and choose the number of units 

contained by the Doorway or Window 
symbol. Up to five units are possible. 

2 The size and shape of a symbol’s open-
ing is independent of the symbol’s size.

Make sure that the two are compatible.

1 The size of a symbol’s units is entirely
independent of the size of the symbol

itself. Make sure that the total width of the
symbol’s units in plan view equals the width
of the 3D symbol.

2
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Plant Information Panel
This panel is available when the Symbol 
Specification dialog is opened for a plant. 
The options are the same as the Plant 

Information panel of the Plant Symbol 
Specification dialog. See “Plant Information 
Panel” on page 772.

Plant Description Panel
This panel is available when the Symbol 
Specification dialog is opened for a plant. 
The options are the same as the Plant 

Description panel of the Plant Symbol 
Specification dialog. See “Plant Description 
Panel” on page 773.

Get Last Symbol
If you import or convert a symbol that 
cannot be placed in the current view 

or must be contained by another object that is 
not present in the view, you can quickly 
select it for placement once the needed 
conditions are met using the Get Last 
Symbol command. 

Open a view in which the symbol can be 
placed or create an object to place the symbol 
into, then select Tools> Symbol> Get Last 
Symbol  to retrieve the last symbol 
created and click in your plan to place the 
symbol. 

Convert to Symbol
While 3D symbols can be imported 
from third parties, you can also create 

your own symbols in Chief Architect using 
any combination of architectual objects.

To create a custom symbol, begin by opening 
a new, blank plan and then use any 
combination of architectural objects to 
produce a model of what you would like your 
custom symbol to look like. 

When the objects are configured as desired, 

use the Convert to Symbol  tool to create 
a single symbol that is assigned to a category 
that reflects how the object will be used. For 
example, if you design a cabinet door, select 
Cabinet Door/Drawer as the symbol’s 

category so you can assign the resulting 
symbol to a cabinet.

To convert an object to a symbol

1. Create a camera view or overview in 
which the object or objects that you wish 
to convert to a single symbol are the 
only things displaying.

2. Select Tools> Symbol> Convert to 
Symbol .

3. The Convert to Symbol dialog displays:

A wide variety of unique objects can be
created using the Primitive Tools. See

“Primitive Tools” on page 778.
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•  Choose a Symbol Category from the 
drop-down list. 

•  Check Add To Library if you would 
like the symbol to be added to the 

library. See “Add to Library” on page 
829.

•  Check Show Advanced Options to 
open the Symbol Specification dialog 
when you click OK, where you have 
more extensive control over the 
symbol’s settings. See “Symbol 
Specification Dialog” on page 1195.

4. Click OK to close the dialog and con-
vert your custom object to a symbol.

Editing Custom Symbols
Custom symbols can be selected and edited 
much like other objects in the program. A 
symbol’s category determines exactly what 
editing options are available; however, most 
symbols can be edited using the edit handles, 
edit toolbar and specification dialog. See 
“Editing Objects” on page 177.

Symbols have some additional options that 
allow you to control how the symbol behaves 
when it is placed, selected, moved and 
resized.

Symbol Origin
All symbols have an origin point, which 
determines how the object is positioned 
when it is placed in a plan. The origin point 
also determines the location of a symbol’s 
bounding box and 2D block. 

The location of a symbol’s origin point is 
typically on its back surface, at the bottom 
center; however, this may vary, depending on 
the symbol’s category. You can see the 
location of a selected symbol’s origin in 
preview pane of the Symbol Specification 
dialog. See “3D Panel” on page 1196.

The following table lists these default origins 
by symbol type.

Symbol objects have two specification
dialogs: one based on its object type

and accessed using the Open Object edit
button, and the Symbol Specification dialog
accessed using the Open Symbol edit button.

Symbol origin located 
at the back, middle, 
bottom of object
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You can offset a symbol from its origin point. 
This can make it easy to insert the object 
inside of another object, but does not affect 

the location of the bounding box or the 2D 
block that displays in floor plan view.

To create an insertable symbol 

1. Make a note of the symbol’s actual size 
on the GENERAL panel of its specifica-
tion dialog. 

2. Click the Open Symbol  edit button 
to open the Symbol Specification dia-
log.

3. On the 3D panel, check Specify Origin.
4. Adjust the X, Y and/or Z values as 

needed: 
•  To insert the back of the symbol into 

the side of another object at a particular 
distance, specify that distance in the Y 
field as a positive value.

•  To insert the bottom of the symbol into 
the top of another object, specify the 
distance that it should be dropped as a 
negative value in the Z field.

Bounding Boxes
An object’s bounding box determines the 
amount of space it requires in 3D and thus 
how close it can be moved to other objects 
before it bumps into them. 

The bounding box also defines the selectable 
area around a symbol: when you click within 
an object’s bounding box, it will become 
selected. Similarly, the bounding box affects 
whether an object is included in a selection 
marquee. See “Selecting Objects” on page 
183. 

When a symbol is selected, its edit handles 
display around the perimeter of its bounding 
box. See “Edit Handles” on page 34.

Symbol Type Origin location
Cabinet Bottom, Back, Center
Cabinet Door Bottom, Back, Center
Doors Bottom, Back, Center
Doorways Bottom, Outside, Center
Electrical, 
Ceiling Mounted

Center Top

Electrical, 
Wall Mounted

Back, Center

Electrical, 
Floor Mounted

Center, Bottom

Electrical,
Wall Mounted

Center, Back

Furniture Bottom, Back, Center
Fixture Bottom, Back, Center
Geometric Shapes Bottom, Back, Center
Hardware Bottom, Back, Center
Millwork Bottom, Back, Center
Molding n/a
Plant Bottom, Back, Center
Sprinkler Back, Center. Height

varies. 
Windows Bottom, Outside, Center

(of sill)

Window origin located bottom, outside, center.
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You can create setback space for a symbol by 
increasing its bounding box size on the SIZ-
ING panel of the Symbol Specification 
dialog. See “Sizing Panel” on page 1202.

To create setback space for a symbol 

1. Make a note of the symbol’s actual size 
on the GENERAL panel of its specifica-
tion dialog. 

2. Click the Open Symbol  edit button 
to open the Symbol Specification dia-
log.

3. On the SIZING panel, increase the 
Width, Depth and/or Height values by 
the amount of the desired setback space.

•  The bounding box Width is always 
centered on the symbol’s origin point.

•  The Depth is measured from the sym-
bol’s origin point towards its front.

•  The Height is measured from the sym-
bol’s origin point towards its top.

You can also allow a symbol to set into 
another object by reducing its bounding box 
size. Unlike the symbol itself, the bounding 
box and 2D block cannot be offset from the 
origin.

Stretch Planes and Zones
Stretch Planes and Stretch Zones define 
where a symbol stretches when resized. 

If a symbol has no Stretch Planes or Zones, 
its surfaces will all resize uniformly; if, on 
the other hand, a Stretch Plane or Zone is 
defined, the object will resize only within the 
plane or zone. Any portions of the symbol 
located outside of the plane or zone will not 
resize at all.

• A Stretch Plane is a two dimensional 
plane within a symbol which increases or 
decreases in thickness as the symbol is 
resized. 

• A Stretch Zone defines an area between 
two Stretch Planes that resizes uniformly, 
leaving the area outside unaffected.

Stretch Plane coordinates are relative to the 
symbol’s origin point. For many object types, 
the origin is located at the bottom center of 
its back surface. 

To define a Width stretch plane

1. Open a symbol’s Symbol Specification 
dialog using any of the available meth-
ods. See “Symbol Specification Dialog” 
on page 1195. 

2. On the SIZING panel, under the Stretch 
Planes heading, check the box beside 1 
to the left of the Width column. The 
field to its right becomes active.

3. The new plane has an initial value of 0.
•  Leave it at 0” to run the plane through 

the object’s default origin point.
•  Specify a negative number to define a 

plane to the left of the origin.
•  Specify a positive number to define a 

plane to the right of the origin.
4. Click OK. When the symbol’s width is 

changed, only the cross section defined 
by the Stretch Plane will be affected.
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To define a Depth or Height stretch plane

1. On the SIZING panel of the Symbol 
Specification dialog, under the Stretch 
Planes heading, check the box beside 1 
to the left either the Depth or Height 
column. The field to its right becomes 
active.

2. The new plane has an initial value of 0.
•  To define a Height stretch plane, spec-

ify a positive number between 0 and 
the overall height of the symbol.

•  To define a Depth stretch plane, specify 
a negative number.

3. Click OK. When the symbol’s depth or 
height is changed, only the cross section 
defined by the Stretch Plane will be 
affected.

A symbol can have up to three Stretch Planes 
in each direction, for a total of nine. 

To define two stretch planes

1. Open a symbol’s Symbol Specification 
dialog. 

2. On the SIZING panel, check the boxes 
beside 1 and 2 to the left of a column 
under Stretch Planes. The fields to their 
right becomes active. 

3. Specify the desired values to define each 
Stretch Plane within the symbol.

4. Click OK. When the symbol is resized, 
the two cross sections defined by the 
Stretch Plane will be affected.

To define a stretch zone

1. Open a symbol’s Symbol Specification 
dialog. 

2. On the SIZING panel, under the Stretch 
Planes heading, check the boxes beside 
1 and 2 to the left of a column under 
Stretch Planes. The fields to their right 
becomes active. 

3. Specify values for both planes.
4. Check the box beside the corresponding 

option in the Stretch Zones section of the 
panel.

5. Click OK. When the symbol is resized, 
only the area within the Stretch Zone 
will be affected.

Location and effect of Width stretch planes

Location and effect of Z-axis stretch planes

Location and effect of two Width stretch planes
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Chapter 39:

Printing and Plotting

Chief Architect provides a variety of printing 
options, from printing scaled plan views and 
3D perspectives, to a set of templates that 
can be assembled into a 3D model.

To create working drawings, you can use the 
program’s Layout facility. Multiple views of 
the model can be arranged on pages along 
with a border and title block. For more 
information, see “Layout” on page 1235.

Chief Architect also allows you to save your 
drawings in .pdf file format that can then be 
sent to a printing service.

Chapter Contents
•      Introduction to Printing
•      Printers and Plotters
•      Printing Defaults
•      The Printing Tools
•      Drawing Sheet Setup Dialog
•      Print Preview
•      Printing to Scale
•      Printing Across Multiple Pages
•      Printing to a PDF File
•      Line Weights
•      Print View Dialog
•      Print Image Dialog
•      Print Model

Note: Screen captures are provided for
illustrative purposes only and are not an
endorsement of any products.



1212

Chief Architect X8 Reference Manual

Introduction to Printing
Chief Architect offers printing options to suit 
a variety of needs. It is helpful to be familiar 
with these options and choose the one that 
makes the most sense for the project at hand.

Output Options
Printing From Layout - For professional 
quality documents with a title block, border, 
and multiple views of the model, printing 
from layout provides the best results. For 
more information, see “Layout” on page 
1235.

Printing Directly From a View - You may 
prefer to print individual drawings directly 
from a view. See “Print Tools” on page 1215.

Printing to PDF - Plans can be printed to a 
.pdf file and printed remotely. See “Printing 
to a PDF File” on page 1222.

Print Model - Creates a set of templates that 
can be used to create a 3D model of your 
design. See “Print Model” on page 1231.

Terminology
Drawing Sheet Size - The dimensions of the 
final printed output. This may or may not be 
the same as the printer paper size. If the sheet 
and paper sizes are the same, only one page 

is required per sheet. See “Drawing Sheet 
Setup Dialog” on page 1216.

Paper Size - The dimensions of the paper to 
be printed on. Specifying a paper size that is 
smaller than the Sheet Size allows large 
drawings to be printed across multiple pages.

Check Plot - A test printing, typically at a 
smaller scale, made before final output to 
large paper format. For more information, 
see “Check Plots” on page 1221.

Line Weight - The thickness of a line. A 
thicker line weight is easier to see, but may 
not show as much detail. See “Line Weights” 
on page 1223.

Drawing Scale - You can specify this scale 
in the Drawing Sheet Setup dialog. See 
“Drawing Sheet Setup Dialog” on page 
1216. 

When a particular scale is not important, 
drawings can also be sized to fill a particular 
area. See “Printing to Scale” on page 1220.

Printing Problems
If you encounter difficulties when trying to 
print, see “Troubleshooting Common 
Technical Issues” on page 1312.

Note: Student, Academic, and Presentation
versions of the software produce a watermark
on all printed documents.

Always familiarize yourself with your
printer or plotter before a deadline is

near, and bear in mind that it can take a little
time to configure a new printer.
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Printers and Plotters
There are many different types of printers 
and plotters. In general, a printer is smaller, 
normally outputting 8½ x 11" (Letter or 
ANSI A size), 8½ x 14" (Legal Size) or 
sometimes as large as 11 x 17" (Tabloid or 
ANSI B size).

Plotters are typically used to output larger 
sheets of paper such as 17 x 22" (ANSI C), or 
18” x 24” (ARCH C).

Printer Drivers
A printer driver is a program that allows a 
printer to communicate with the rest of the 
computer system. Drivers are usually created 
by the printer manufacturer, are typically 
updated regularly, and can usually be 
downloaded free of charge from the 
manufacturer’s web site. 

In addition to interpreting between the 
printer and the rest of the system, printer 
drivers save default page size, orientation, 
margin size, and other information that Chief 
Architect refers to unless you specify 
otherwise. See “Print View Settings” on page 
1214.

If you experience printing problems, 
consider installing updated drivers for your 

printer. Visit your printer manufacturer’s web 
site for more information. 

Printing to File
If your print service requires you to print to a 
file that can be read by their plotter, you can 
install that printer’s drivers on your system 
and then use the Windows System Print 
dialog to Print to File. See “Print View 
Dialog” on page 1226. 

Please note that printing to a file is not an 
option in the Mac System Print dialog. 

Clearing Printer Information
Some information specific to individual 
printers and plotters, such as available paper 
sizes, is saved with each plan and layout file. 
You can select File> Print> Clear Printer 
Info to clear the printer-specific information 
stored with the plan or layout file.

Printing Defaults
You can print to any printer or plotter that is 
supported on your operating system and can 
specify the current printer at any time in 
either the Drawing Sheet Setup or Print 
View dialog.  

Drawing Sheet Setup
When any orthographic view is active, 
you can specify its Drawing Sheet 

size, orientation, margins, its printed 
Drawing Scale, and more in the Drawing 

Options available with one driver may
not be available with another. Printers

and plotters supported in one operating
system may not be supported by the
manufacturer in another.
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Sheet Setup dialog. Select File> Print> 
Drawing Sheet Setup to open this dialog. 
See “Drawing Sheet Setup Dialog” on page 
1216.

The settings in the Drawing Sheet Setup 
dialog are view-specific. This means that in a 
plan file, they can be set up independently 
for floor plan view and each cross section/
elevation view and CAD Detail. When a new 
view is created, its initial settings are derived 
from the current settings in floor plan view.

The Drawing Scale set in the Drawing Sheet 
Setup dialog acts as the default scale for the 
active view’s Print, Printed Size Input, and 
Send to Layout dialogs. See “Send To 
Layout Dialog” on page 1241. 

The settings in the Drawing Sheet Setup 
dialog can be customized and saved in your 
template plans and layout files. See 
“Template Files” on page 84. 

Print View Settings
When you are ready to print an 
orthographic view, select File> 

Print> Print. The initial settings in the Print 
View dialog are drawn from the Drawing 
Sheet Setup for the view. The system’s 
default printer is selected and if possible, the 
paper size and orientation are set to match 
those of the Drawing Sheet. 

Once a view has been printed, the settings in 
the Print View dialog are saved and will be 
applied to all views of the same type, in all 
Chief Architect files. View types with 
separate Print View settings are: 
• Floor plan view
• Cross Section/Elevation views
• Layout

• Materials Lists
• CAD Details
• Time Tracker Logs

If you prefer that the Print View settings not 
be retained in this manner, uncheck 
Remember Print Settings after Printing in 
the Drawing Sheet Setup dialog.

Displaying Objects
You can control the display of objects 
when printing directly from a view in 

the Layer Display Options dialog. See 
“Layer Display Options Dialog” on page 
149.

Objects must be visible in order for them to 
print; however, not all items that are visible 
will print. See “Print Preview” on page 1219.

To control the display of objects in an 
orthogonal view sent to layout, select the 

view, click the Layout Box Layers  edit 
button, and make any needed changes in the 
Layer Display Options dialog. See      
Layout View Layers.

To control the display of objects in a camera 
view sent to layout, turn layers on/off  in the 
view before it is sent to layout. You may find 
it helpful to create a custom layer set for 
printing directly from a view. See “Layer 
Sets” on page 146

Print Preview
To get a sense of whether your current 
settings will meet your needs when 

printed, you can use the Print Preview 
toggle to view the printed output on screen 
before any paper is used. See “Print 
Preview” on page 1219.
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The Printing Tools
Select File> Print to view the Print 
Tools submenu. These tools fall into 

four categories. 

Print Setup Tools
Drawing Sheet Setup - Opens the 
Drawing Sheet Setup dialog. See 

“Drawing Sheet Setup Dialog” on page 
1216.

Scale to Fit - Automatically selects a 
scale that fits your plan to the drawing 

sheet. See “Printing to Scale” on page 1220.

Center Sheet - Automatically centers 
the drawing sheet on your drawing. 

See “Center Sheet” on page 1220.

Print Preview - Shows on screen how 
the current view will appear printed, 

based on the current scale and other settings. 
See “Print Preview” on page 1219.

Print Tools
Print - Prints the current floor plan 
view, Vector View, CAD Detail, or 

layout sheet to a specified scale. See “Print 
View Dialog” on page 1226.

Print Image - Prints the current view 
including images, textures, and 

backdrop. Views printed with Print Image 
are not scaled. See “Print Image Dialog” on 
page 1229.

Print Model - Opens the Print Model 
dialog, allowing you to print templates 

for making a physical model of your plan. 
See “Print Model” on page 1231.

Display Toggles
A number of toggles allow you to turn 
various aspects of the display on or off. See 
“Interface Toggles” on page 32. 

Color  - Turn the on-screen display of 
color on or off in all views except 

perspective views. See “Color” on page 
1219.

Line Weights - When this is on, line 
weights appear on screen as they will 

print. See “Line Weights” on page 1219.

Drawing Sheet - Turn this on for a 
preview of your plan relative to the 

current Drawing Sheet. See “Drawing Sheet” 
on page 1220.

Reference Grid - The Reference Grid 
does not print, so you can turn this off 

to get a better sense of what the view will 
look like printed. See “Reference Grid” on 
page 1219.

Additional Print Tools
Customize Sheet Sizes - Allows you to 
create custom sheet sizes. See “Customize 
Sheet Sizes Dialog” on page 1218.

Clear Printer Info - Clears the printer 
information associated with the current page 
setup.  
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Drawing Sheet Setup Dialog
Select File> Print> Drawing Sheet 
Setup to open the Drawing Sheet 

Setup dialog. 

The Drawing Sheet Setup dialog is only 
available when an orthogonal view or layout 

is active. See “Orthogonal Views” on page 
1220.

The settings in this dialog are specific to the 
current orthogonal view and are saved with 
the .plan or .layout file. See “Printing 
Defaults” on page 1213. 

Specify the Orientation and Size of the 
Drawing Sheet, which is the final 

printed output. 

• Click the Customize button to open the 
Customize Sheet Sizes dialog. See 

1
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“Customize Sheet Sizes Dialog” on page 
1218.

Specify the Drawing Scale for the 
active view. This scale is applied only 

when the view is printed. 

The scale is specified in two parts, which by 
default are 1 ft = 1 ft or 1 m = 1 m for layout 
views, and ¼ inch = 1 ft or 1 m = 50 m for all 
other views. Both imperial and metric units 
of measurement are available and can be 
selected independently. 

The units of measurement available here can 
be controlled in the Preferences dialog. See 
“Unit Conversions Panel” on page 104.

The Drawing Scale acts as the default scale 
for the active view’s Print, Print Size 
Calculator, and Send to Layout dialogs. 

Specify the Printer for View. which is 
the printer for the active view in the 

current file. These settings are global, 
affecting all plan and layout files.
• Uncheck Remember Print Settings 

after Printing to enable the Choose but-
ton, below. When this is checked, the 
printer is selected in the Print View dia-
log. See “Printing Defaults” on page 
1213.

• Click the Choose button to select a 
printer and edit its paper settings in the 
Default Printer for View dialog.

The name of a Printer displays to the left of 
the Choose button for reference.

• If the Remember box is checked, the last 
printer used in the current view type is 
shown; if no printer has been used in the 
current view, “None” will display.

• If the Remember box is unchecked, the 
system’s default printer will be shown.

If you have questions about your printer’s 
settings, consult its documentation. 

Specify the Drawing Margins. which 
define the extents of the printable area 

of the active view’s Drawing Sheet. 
• Click the Populate from Printer button 

to set the margins based on the selected 
printer’s default settings. See “Printers 
and Plotters” on page 1213.

• Specify the width of the desired Top, 
Left, Right, and Bottom margins.

The Advanced Line Weight Options 
allow you to specify the active view’s 

line weight scale. A layout file’s line weight 
scale should always be the same as that of 
any plan views associated with it. See “Line 
Weights and Scaling” on page 1224. 
• Check Use 1 for all line weights (Home 

Designer compatibility) to have the pro-
gram maintain a consistent line thickness 
and dash size when the drawing scale is 
changed. When checked, the Line Weight 
Scale is based on a 1/4 inch = 1 foot 
drawing scale and 1= 1/300 inch line 
weight scale. Plans originally created in 
any of the Home Designer programs have 
this checked by default; however, this 
option is not available for layouts and is 
not normally recommended. See “Line 
Weights” on page 1223. 

• Select the Line Weight Scale. See “Line 
Weights and Scaling” on page 1224. This 
setting should always be the same for 

Paper can often be inserted into plotters
in either of two orientations. Refer to

your plotter’s documentation to find out which
way to insert the paper for correct results.

2

3

4

5
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both a given layout file and any plan 
views associated with it.

A line weight Preview illustrates how 
changes to the line weight scale affect 

the printed size of various line weights at the 
current Drawing Scale. 

Default Printer for View Dialog
To open the Default Printer for View dialog, 
click the Choose button in the Drawing 
Sheet Setup dialog.

• Select a Printer from the drop-down list.
• Choose the Orientation of the paper 

used by the selected printer.
• Select a Paper Size from the drop-down 

list. The options available will depend on 
the selected printer.

• Select a Paper Source from the drop-
down list. The options available will 
depend on the selected printer.

Customize Sheet Sizes Dialog
To open the Customize Sheet Sizes dialog, 
select File> Print> Customize Sheet Sizes, 
or click the Customize button in the 
Drawing Sheet Setup dialog. 

Several options are available:

• Click New to create a new sheet size.
• Select a sheet size and click Copy to cre-

ate a duplicate sheet size.
• Click Delete to remove the selected sheet 

size.
• Select a sheet size and click Edit to open 

the Edit Paper Size dialog and change its 
description, dimensions, and units of 
measurement.

6
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• Click OK to close the dialog. Any new 
sheet sizes created are now available in 
the Drawing Sheet Setup dialog.

• The data for this dialog is stored in the 
“sheetSizes.sheet” file in the program’s 
Data folder. 

Clearing Printer Information
Select File> Print> Clear Printer Info to 
clear the printer-specific information stored 
in the Drawing Sheet Setup dialog. 

This is useful for creating plan and layout 
templates without an associated printer. See 
“Template Files” on page 84.

Print Preview
Print Preview and its related display 
toggles allow you to get a sense of 

what the current view will look like when it 
is printed. 

Print Preview
Select File> Print> Print Preview for 
an on-screen representation of how 

the current view will appear when printed. 
Print Preview is only available in views that 
can be scaled. See “Printing to Scale” on 
page 1220.

When Print Preview   is on, the Drawing 
Sheet and line weights are displayed, and the 

toggle buttons Drawing Sheet  and Line 
Weights  are overridden.

Objects such as camera symbols, CAD 
points, and the Snap and Reference Grids 
that do not print do not display in Print 
Preview . Text and dimension objects 
appear on-screen as they will on the printed 
page.

When Print Preview  is enabled, color 
will display depending on whether Print in 

Color is selected in the Print View dialog. 
See “Print View Dialog” on page 1226. 

The Reference Display does print if it is 
visible. See “Reference Floor Display” on 
page 444. 

Color
The Color toggle turns the on-screen 
display of color on or off in all views. 

When Color is toggled off, views print in 
either black and white or greyscale 
depending on your Preferences setting. See 
“Colors Panel” on page 94.

Reference Grid
The Reference Grid is an on-screen 
grid composed of regular squares that 

can be used to convey a sense of scale while 
drawing.  It does not print, and its size can be 
specified in the General Plan Defaults 
dialog. See “General Plan Defaults Dialog” 
on page 88.  

Line Weights
Select View> Line Weights for an on-
screen representation of line weights 
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and line styles.  Turning Line Weights on or 
off does not affect the final printed output.

When Line Weights is turned on, you can 

Zoom In  to see the location of lines and 
dashed lines as they will appear on the 
printed page. 

When Line Weights  is off, dashed lines look 
the same, regardless of the zoom factor. 

Line Weights  can also be turned on or off in 
the Preferences dialog. See “Appearance 
Panel” on page 92.

Drawing Sheet
Select View> Drawing Sheet to show 
the drawing sheet on screen. The sheet 

size is specified in the Drawing Sheet Setup 
dialog. See “Drawing Sheet Setup Dialog” 
on page 1216.

A blue border represents the margins of the 
printable area. If the margins have been set to 
populate from the selected printer, this 
border may not display on all edges of the 
drawing sheet. See “Printer Drivers” on page 
1213. 

When Drawing Sheet  is on, the drawing 
sheet behaves as an object. 

• When selected at its border the sheet has 
edit handles, allowing it to be moved. See 
“Editing Objects” on page 177.

• You can also resize the sheet using its edit 
handles; however, for best results, it is 
recommended that you instead select an 
available sheet size in the Drawing Sheet 
Setup dialog. See “Drawing Sheet Setup 
Dialog” on page 1216.

• Dimension lines can locate the edges of 
the sheet and can be used to position 
other objects relative to it. See “Moving 
Objects Using Dimensions” on page 
1019.

The drawing sheet cannot be rotated or 
copied. 

Center Sheet
Select File> Print> Center Sheet to 
center the drawing sheet on the 

drawing. This moves the sheet relative to the 
drawing but does not affect the coordinates 
of objects in the drawing. The location of the 
drawing sheet is independent for each floor 
of the model.

Printing to Scale
Several different print scaling options are 
available. The type of view that you are 
printing determines which options you may 
choose from.

Orthogonal Views
Floor plan views, Orthographic 3D views, 
CAD Details, and layout pages are 
orthogonal views, which means: 

Note: Specifying a sheet size in the
Drawing Sheet Setup dialog is prefera-

ble to editing the sheet size on-screen.
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• Your line of sight is at a right angle to all 
objects in the view. 

• Objects do not appear to decrease in size 
as their distances from the viewer 
increase.

Orthogonal views can be printed to scale; 
however, Orthographic 3D views can only be 
printed to scale when the Vector View 
Rendering Technique is used.

The scale set in the Page Setup dialog is 
inherited by the Print and Send to Layout 
dialogs. This scale can be overridden on an 
individual basis in either of these dialogs. 
See “Print View Dialog” on page 1226 and 
“Sending Views to Layout” on page 1240. 

Select File> Print> Scale to Fit  in an 
orthogonal view to select a suitable scale and 
re-center the drawing sheet so that 
everything fits on the sheet.

Imperial drawing scales are typically noted 
in inches per foot. Larger scales, such as 1 
inch = 50 feet or 1:200m, are often used for 
property layouts.

Once a view has been sent to layout, there 
are a variety of additional scaling options. 
See “Rescaling Views” on page 1249.

Perspective Views
Camera views and Perspective overviews 
display the model much the way the eye 
would see it and cannot be scaled.
• Objects in the view may be at any angle 

relative to your line of sight. 
• Objects seem to decrease in size as their 

distances from the viewer increase.

Perspective views can only be printed using 

the Print Image  tool. See “Print Image 
Dialog” on page 1229.

While perspective views cannot be scaled, 
you can control the printed size of the view. 
If Fit to Paper is selected in the Print View 
dialog, a percent value can be set that defines 
how much of the printed page to fill. See 
“Print View Dialog” on page 1226. 50% 
causes the print to be 50% of both the height 
and width of the paper, including the non-
printable border. 

For example, if printing to an 8½ x 11 page 
with a 1" non-printable border in each 
direction: 
• 100% would print an area 8½ x 11. This 

is not recommended, as part of the output 
could fall outside the printable area.

• 50% would print an area 4¼ x 5½. 
• Each printer may vary slightly.

Check Plots
A check plot is a test print that allows you to 
print at a reduced scale on smaller, less 
expensive paper so you can check that the 
drawing will print as expected. The drawing 
scale is temporarily adjusted to a specified 
fraction of its true value. Both drawing scale 
and line weights are subject to this scale 
adjustment. 

For example, if a layout has a border 
designed to fit on a Drawing Sheet of 24” x 
36”, a check plot at 1/2 scale would allow it 
to fit on a 12” x 18’ page. A view sent to that 
layout at a Drawing Scale of 1/4” = 1’ would 
be scaled at 1/8” = 1’ when printed at 1/2 
scale. 
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To create a check plot

1. Select File> Print> Print View . In 
the Print View dialog: 

•  Click the Check Plot at radio button, 
then choose the desired scale fraction 
from the drop-down list. 

•  The Paper Size will automatically 
adjust to fit the selected Check Plot 
Scale. 

•  Confirm that the Paper Size is the size 
you wish to use, then click Print.

2. The next time you print a view, remem-
ber to choose To Scale or Fit to Paper 
again in the Print View dialog. 

Printing Text and Dimensions
As with other objects your drawings, text and 
dimension numbers are subject to scaling 

when views are sent to layout or printed. See 
“Scaling Text” on page 1047.

Printed text size is also influenced by the 
selected font and the method used to specify 
its size. See “Character Size” on page 1030.

Text may not print exactly as it appears on-
screen. To get a better idea of how text and 
dimension characters will print, you may 

find it helpful to Zoom In  on them. 

For best printed results, using true-type or 
open-type fonts is recommended. 

Printing Across Multiple Pages
When printing directly from a floor plan 
view, cross section/elevation view, or layout 
it is possible to print at a scale that does not 
fit the drawing on one page.

When printing to a paper size that is smaller 
than the sheet size, a 2% overlap is used. 
Crop marks print where the paper needs to be 
cut between pages. A solid line is drawn at 

the drawing sheet boundary on the sides that 
need to be cut.

To see on-screen what the drawing will look 
like when printed, select View> Drawing 
Sheet  and then Window> Fill 
Window . Grey lines across the drawing 
sheet  indicate where the page breaks will 
occur. See “Drawing Sheet” on page 1220.

Printing to a PDF File
Portable Document Format, or .pdf files, are  
one of the most universally compatible and 
efficient file formats and can be viewed and 
printed on most computer platforms. 

You can save any view as a 2D .pdf file by 
selecting “Chief Architect Save as PDF” as 
the Destination printer Name in either the 
Print View or Print Image dialog. See “Print 

Text may not appear accurately on
screen when the font used by the

printer is different than the font used on
screen. Consult your printer documentation
for more information on font substitution.
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View Dialog” on page 1226 and “Print Image 
Dialog” on page 1229. 

If you have a .pdf writer installed on your 
system, you can use it to create a 2D .pdf file 
instead. To print to .pdf, simply select it as 
your printer in the Print View or Print Image 
dialog. 

When you either save as or print to .pdf, you 
will be asked to create a file name and 
choose a destination automatically. For more 
information, see “Saving, Exporting, and 
Backing Up Files” on page 55.

You can also import .pdf files into Chief 
Architect. See “Importing PDF Files” on 
page 1148. 

Line Weights
The weight of a line refers to its thickness on 
the printed page and is described in absolute 
terms as a fraction of a unit, often 1/100th of 
a millimeter or 1/1000 of an inch. In Chief 
Architect, line weights are assigned to 
objects, patterns, and layers using whole 
numbers that correspond to the numerator of 
this fraction.

You can specify the Line Weight Scale by 
defining the denominator and the unit used in 
this fraction in the Drawing Sheet Setup 
dialog. See “Drawing Sheet Setup Dialog” 
on page 1216. 

Your preferred line weights and line weight 
scale can be saved in your template plan and 
layout files. See “Template Files” on page 
84. 

The method for specifying an object’s line 
weight depends on the object and the type of 
view.

• Most objects’ line weights can be set by 
layer. See “Layer Display Options Dia-
log” on page 149.

• Some objects’ line weights can be set in 
their specification dialogs. See “Line 
Style Panel” on page 1085.

• The line weights for walls in floor plan 
view are defined by wall type in the Wall 
Type Definitions dialog. See “Wall Type 
Definitions Dialog” on page 305.

• The line weights of material pattern lines, 
which are visible in Vector Views, can be 
set in the Define Material dialog. See 
“Define Material Dialog” on page 864. 

• The line weight for fill patterns is set for 
individual objects in their specification 
dialogs. See “Fill Style Panel” on page 
1099.

• The line weight applied to surface edges 
in Vector Views can be set in the Print 
dialog. See “Print View Dialog” on page 
1226.

• The end cap length of dashed lines in 
floor plan view is set in the Preferences 
dialog.  See “CAD Panel” on page 109.

• An assigned line weight of 0 draws a line 
weight of 1 pixel, the thinnest line weight 

It is extremely important that every view
sent to layout and the layout file share

the same Line Weight Scale. When they do
not, unwanted printed output will result.
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a printer allows. How thick this is varies 
from printer to printer. See “Printers and 
Plotters” on page 1213. 

Line Weights and Scaling
When a view is sent to layout, line weights 
may be affected by the drawing scale 
selected for the view. This occurs when the 
layout view’s scale is different from the 
drawing scale of the original view. 

For example, assume that you have an object 
in a view with a line weight of 20, and that 
the view’s drawing scale is 1 mm = 50 mm. 
• If you send the view to layout at 1 mm = 

25 mm scale, twice the original scale, the 
resulting printed line weight for this 
object will increase to 40 instead of 20. 

• If you send the view to layout at 1 mm = 
100 mm scale, half the original scale, the 
resulting printed line weight for this 
object will decrease to 10 instead of 20. 

You can specify the drawing scale for any 
orthogonal view by opening the Drawing 
Sheet Setup dialog while in that view. See 
“Printing to Scale” on page 1220. 

For any layout view, you can specify whether 
the original line weight is maintained or not 
in the Send to Layout and Change Scale 
dialogs. See “Send To Layout Dialog” on 
page 1241 and “Rescaling Views” on page 
1249. 

Note that in order to produce exact line 
weights, a Vector View must be sent to 
layout using the Plot Lines option. See “Plot 
Line Views” on page 1245.

Line weight scaling affects both line weights 
and line styles and can be particularly 
noticeable with dashed line styles. 

In the following image, the same floor plan 
view has been sent to layout twice, at two 
different scales. The view on the left was sent 
at the same scale as the original view, 
1/8” = 1’.  The view on the right was sent at 
1” = 1’, or magnified eight times, to show an 
area of the plan in greater detail. 

Because the view on the right was sent to 
layout at a scale other than that of the 
original, it is subject to layout line scaling. 

The solid lines representing walls, cabinets 
and doors are rescaled to be eight times 
thicker than in the original view.

Similarly, the dashed lines representing the 
door jambs are rescaled so that the dashes 
and the spaces between them are eight times 
larger than in the original view. 

Note: Under most circumstances, you should
select Use Layout Line Scaling when sending
views to layout.
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If Use Layout Line Scaling is enabled, line 
weights are no longer scaled and the dashed 
lines display at the same size as in the 
original view. 

Because the view in this example is scaled 
eight times larger in this case, the dashes and 
line weights look relatively small and fine 
when Use Layout Line Scaling is enabled. 
Were the view rescaled to be smaller instead, 
the line weights would look relatively large 
and thick.

Printers and Line Weight
Line weight and print scaling are subject to 
the limitations of the printer being used. For 
example, you will not be able to see the 
difference between a line that is 1/150th of 
an inch wide and one that is 1/300th of an 
inch wide when they are printed using a 
printer that prints 150 dots per inch (DPI). 

That is, a CAD line with a line weight of 1 
will look the same as a CAD line with a line 
weight of 4 when the Line Weight Scale is 
set at 1 = 1/600th of an inch and you print to 
a printer capable of 150 DPI. 

Setting an object’s or group of objects’ line 
weight to zero causes the lines to print as 
thinly as possible.

with Use Layout Line Scaling disabled

with Use Layout Line Scaling enabled

The default Line Weight Scale of 
1 = 1/100 mm makes it easy to meet

many professional drawing standards and in
most cases should not be changed.
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Print View Dialog
To print from floor plan view, 3D 
Vector Views, layout, CAD Details, 

Time Tracker Logs, and the Materials  List, 
select File> Print> Print. The Print View, or 
Print Layout, Print Time Tracker Log, or 
Print Materials List dialog opens. The 
settings that are available will vary 
depending on which version of the dialog is 
open. 

If Remember Print Settings after Printing 
is checked in the Drawing Sheet Setup 
dialog, the settings in this dialog will be 
saved and applied globally to all views of the 
same type in all Chief Architect files. See 
“Print View Settings” on page 1214.

Note: 3D views that are not Vector Views can
be printed using Print Image.
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Select the Name of the Printer that you 
would like to use from the drop-down 

list. To print to .pdf, select “Chief Architect 
Save as PDF” from the list, or choose a .pdf 
writer installed on your system. See 
“Printing to a PDF File” on page 1222. 
• Select the DPI, or Dots Per Inch to use 

when printing, from the drop-down list. 

The available options may vary depend-
ing on the selected printer.

Select the Paper Orientation, Size, 
and Source. The available Size and 

Source options are controlled by the selected 
printer’s driver. See “Printer Drivers” on 
page 1213.
• When possible, the program will auto-

matically set the Size and Orientation to 

1

2
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match those of the Drawing Sheet. See 
“Drawing Sheet Setup Dialog” on page 
1216.

• The Paper Size may be automatically 
adjusted if the Drawing Scale option is 
changed, below.

In layout files only, specify the Print 
Range. Only pages that have views or 

objects drawn directly on them and are not 
specified as Page Templates will print. Page 
Templates and empty pages do not print. See 
“Layout Page Templates” on page 1261.
• Select All to print the entire drawing. 
• Select Current Sheet to print only the 

currently active layout page. 
• Select Sheets to specify which layout 

pages to print, then type the page num-
bers you wish to print, separated by com-
mas or by a dash. Not available in plan 
files. 

Specify the Print Source. Not available 
in the Print Materials List dialog.

• Select Drawing Sheet to print the entire 
sheet even though you may be zoomed in 
on a portion of the view. 

• Select Current View to print only that 
portion of the active view that is currently 
visible on screen. If you are zoomed out, 
any blank space outside of the printable 
objects in the view is ignored. 

Specify the Drawing Scale of the 
printed output. Changes to these 

options may cause the Paper Size to change, 
above. Not available in the Print Materials 

List dialog or in camera views or overviews. 
See “Printing to Scale” on page 1220.
• Fit to Paper prints the view on one page. 

The program uses whatever scale is nec-
essary to fit the plan on one page. 

• When Fit to Paper is selected, specify 
the percentage of the paper to be used. 
The default value is 95%.

• Select To Scale to print at the scale speci-
fied in the Drawing Sheet Setup dialog. 
See “Drawing Sheet Setup Dialog” on 
page 1216.

• To print a check plot, select Check Plot 
at and choose a scale adjustment from the 
drop-down list. See “Check Plots” on 
page 1221.

Options - Only the Copies setting is 
available in the Print Materials List 

dialog.
• Specify the number of Copies you would 

like to print. 
• Check Print in Color to print in color or 

clear the checkbox to print in either gray-
scale or black and white. 

• To print in grayscale, check Obey Color 
On/Off Setting in the Preferences dia-
log before printing, then uncheck Print 
in Color. See “Appearance Panel” on 
page 92. 

• To print in black and white, uncheck 
Obey Color On/Off Setting in the 
Preferences dialog before printing, then 
uncheck Print in Color. Lines and fill 
colors print as either black or white, 

Note: To produce collated multiple copies,
specify the sheets in the desired order, sepa-
rated by commas.

3

4

5

Note: The Fit to Paper percentage value is
global - affecting all views in all files, and is
retained between sessions.

6
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depending on which is closer to the line 
or fill’s actual color. 

Most black and white printers print a grey 
scale approximation of the colors if Print in 
Color is selected. 

Advanced Options - Click the Open 
System Print Dialog button to close 

the Print View dialog and print using your 
operating system’s Print dialog instead. Not 
available when No Printer is selected.

Control the appearance of the print job 
Preview on the right side of the dialog.

• Specify the Page that displays in the Pre-
view area.

• Click the buttons to Zoom In, Zoom 
Out, or Fit the selected Page to the 
extents of the Preview area. 

• Uncheck Update Automatically to turn 
off the print job Preview and prevent it 

from updating as changes are made to the 
settings in this dialog. 

• Click the Update button to update the 
print job Preview to reflect the current 
settings in this dialog. If Update Auto-
matically is unchecked, clicking Update 
may force the Preview to be blank.

When Update Automatically is 
checked, a preview of the current print 

job displays here. The drawing sheet displays 
as a white rectangle, and if multiple sheets 
are required, you can scroll through them. If 
the print job is large, a progress dialog may 
display briefly as the preview draws or 
updates.

To help prevent unwanted printed 
output, information messages regarding 

page size, resolution, and scale may display 
here, depending on the settings in this dialog. 

Print Image Dialog
Any view can be printed by selecting 
File> Print Image. This is the only 

way to print a Ray Trace or most 3D views. 
See “3D Rendering” on page 933.

The Print Image dialog is similar to the Print 
View dialog; however, the printing process is 
different. Print Image prints individual 
pixels as opposed to vectors (lines).

7

8

9

10
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Select the Name of the Printer you 
wish to use from the drop-down list. To 

print to .pdf, select “Chief Architect Save as 
PDF” from the list, or choose a .pdf writer 
installed on your system. See “Printing to a 
PDF File” on page 1222.
• Select the DPI,or Dots Per Inch to use 

when printing, from the drop-down list. 
The available options may vary depend-
ing on the selected printer.

Select the Paper Orientation, Size, 
and Source. The available Size and 

Source options are controlled by the selected 
printer’s driver. See “Printer Drivers” on 
page 1213.

Specify the number of Copies you 
would like to print. 

Advanced Options - Click the Open 
System Print Dialog button to close 

the Print View dialog and print using your 
operating system’s Print dialog instead. Not 
available when No Printer is selected.

Control the appearance of the print job 
Preview on the right side of the dialog.

• Specify the Page that displays in the Pre-
view area.

• Click the buttons to Zoom In, Zoom 
Out, or Fit the selected Page to the 
extents of the Preview area. 

• Uncheck Update Automatically to turn 
off the print job Preview and prevent it 
from updating as changes are made to the 
settings in this dialog. 

• Click the Update button to update the 
print job Preview to reflect the current 
settings in this dialog. If Update Auto-
matically is unchecked, clicking Update 
may force the Preview to be blank.

1

2

3

4

5
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When Update Automatically is 
checked, a preview of the current print 

job displays here. If the print job is large, a 
progress dialog may display briefly as the 
preview draws or updates.

To help prevent unwanted printed 
output, information messages regarding 

page size and resolution may display here, 
depending on the settings in this dialog. 

Print Model
The Model Maker allows you to print 
scaled drawings of wall and roof 

surfaces in your plan that can be assembled 
into a 3D model. Three types of prints are 
created: walls, roof planes, and a floor plan 
wall layout template for each floor.

The system arranges as many wall or roof 
sections as possible onto a single sheet. For 
larger scale models, a printer with a larger 
sheet sizes is helpful. If any wall surface, 
roof surface, or floor plan view covers more 
than one sheet, it prints by itself on the 

number of sheets required. Models with large 
surfaces may require a lot of paper.

Printing the Model
To print the model templates, choose File> 
Print> Print Model . The Print Model 
dialog opens.

A good way to understand which options 
best meet your needs is to make a very 
simple two story plan and try them out.

6 7
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Print Model Dialog

Select the Name of the Printer that you 
would like to use from the drop-down 

list.  To print to .pdf, select “Chief Architect 
Save as PDF” from the list, or choose a .pdf 
writer installed on your system. See 
“Printing to a PDF File” on page 1222

Select the Paper Orientation, Size, 
and Source. The available Size and 

Source options are controlled by the selected 
printer’s driver. See “Printer Drivers” on 
page 1213.

1 2
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• Larger page sizes and Landscape orienta-
tion are usually best for Print Model. 

• Select All to print the entire drawing. 

Wall Settings - 

• Uncheck Walls to prevent walls from 
printing. When Walls is unchecked, most 
of the other Wall Settings are disabled.

• Uncheck Exterior Only to print interior 
wall surfaces in addition to exterior sur-
faces. Printing interior wall surfaces 
requires a lot more paper and is typically 
only desirable when creating a model of 
the current floor without a roof.

• Check Fold Interior Down to print the 
interior surface of each wall directlly 
above its corresponding exterior surface 
and upside down. This allows both walls 
to be cut in one piece and folded over. 

• Check Combine Floors to print together 
the exterior surfaces of walls that are on 
top of each other. Interior surfaces of 
those walls still print separately.

• Allow Offset modifies the outcome of 
the Combine Floors option. Normally, 
the main layers of stacked walls must be 
closely aligned and have the same thick-
ness for walls to combine. Check this box 
to allow an offset of up to six inches (15 
cm) and allow different thicknesses. 

• Check Railings to print railings along 
with walls.

• Check Outdoor Walls to print Fencing, 
Retaining Walls, walls that define Exte-
rior type rooms, or that define no room. 
Printing Outdoor Walls can require a con-
siderable amount of paper.

• Check Foundation Walls to print walls 
specified as Foundation Walls. When this 
is unchecked, walls on Floor Zero that 
are not specified as Foundation Walls 
will print. See “Foundation Walls” on 
page 269. 

Uncheck Roofs to prevent roof planes 
from printing.

Uncheck Plan View to prevent the Plan 
View Wall Layout from printing. 

Options -  
 

• Specify the Floor Thickness, which is 
the thickness of the material you plan to 
use for the model’s floor platform. 

• Specify the Scale to be used when print-
ing the model. 

• Specify the number of Copies to be 
printed. 

• Check Print in Color to print in color.

Advanced Options - Click the Open 
System Print Dialog button to close 

the Print Model dialog and print using your 
operating system’s Print dialog instead. Not 
available when No Printer is selected. 

Control the appearance of the print job 
Preview on the right side of the dialog.

• Specify the Page that displays in the Pre-
view area.

• Click the buttons to Zoom In, Zoom 
Out, or Fit the selected Page to the 
extents of the Preview area. 

• Check Update Automatically to have 
the print job Preview display and update 
as changes are made to the settings in this 
dialog. This is not unchecked by default 

3

4

5
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7
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because updating the Preview in the Print 
Model dialog can be time-consuming. 

• Click the Update button to update the 
print job Preview to reflect the current 
settings in this dialog. If Update Auto-
matically is unchecked, clicking Update 
may force the Preview to be blank.

A preview of the current print job 
displays here. The drawing sheet for 

each page displays as a white rectangle, and 
you can scroll through the pages. If the print 
job is large, a progress dialog may display 
briefly as the preview draws or updates.

To help prevent unwanted printed 
output, information messages regarding 

page size and resolution may display here, 
depending on the settings in this dialog. 

Assembling the Model
Once the templates have been printed, they 
can be assembled. You need scissors, an 
adhesive, and a rigid material like cardboard 
or foamboard that can be easily cut and glued 
to provide support for the 3D model.

The Model Maker produces templates of 
wall and roof surfaces in the model, but does 
not include tabs or other means of connecting 
them together. If you wish, you can leave 
extra paper beyond the template edges as you 
cut them out for use assembling the model. 

Wall Layout Template

Begin by laying out the Wall Layout 
template. If it printed on multiple sheets, they 
should be combined into one. Make sure that 
exterior and interior wall surfaces line up 
where the sheets join together.

Fasten the Wall Layout Template to a sturdy 
surface to provide support for your walls.

Walls

Walls should be cut and fixed to a rigid 
backing so that they can stand on their own 
and support the weight of the roof or floors 
above them. How they are cut and assembled 
varies depending on the desired final 
appearance of the model and how they were 
printed. 

Roofs

Roof planes are joined together when 
possible before printing. For each roof 
surface, the fascia and soffit surfaces are 
attached at the eave. 

All flattened roof/fascia/soffit surfaces are 
placed into a CAD detail named “Model 
Detail.” This is overwritten and updated each 
time the roof group is printed for a particular 
model. If the roof or portions of the roof need 
to be reprinted, those pieces can be printed 
from the detail.

9

10



 1235

Chapter 40:

Layout

The Chief Architect layout facility provides a 
set of easy to use tools for creating printed 
construction documents. You can create your 
own title block and border, then arrange 
multiple views, details, notes, and more on a 
page for printing. Working drawings or 
blueprints can be created in almost any paper 
size. 

Each layout can contain many pages, and 
each page can contain multiple views, 
details, images, CAD objects, text, or 
contents and revision tables.

For detailed information about printing in 
Chief Architect, see “Printing and Plotting” 
on page 1211. 

Chapter Contents
•      Layout Defaults
•      The Layout Tools
•      Creating a Layout File
•      CAD and Text in Layout
•      Pictures, Metafiles, and PDFs in Layout
•      Sending Views to Layout
•      Keeping Layout Views Current
•      Displaying Layout Views
•      Editing Layout Views
•      Editing Layout Lines
•      Layout Box Specification Dialog
•      Opening Layout Views
•      Managing Layout Links
•      Layout Page Management
•      Layout Page Information
•      Layout Page and Revision Tables
•      Printing Layout Files
•      Exporting Layout Files

Layout Defaults
To access the layout defaults for the 
current layout file, select Edit> 

Default Settings. The options in the Default 

Settings dialog are similar to those found in 
this same dialog in a plan file, although there 
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are fewer choices in the list. See “Default 
Settings” on page 74. 

Drawing Sheet Setup
The settings in the Drawing Sheet Setup 
dialog are file-specific and are particularly 
important considerations in layout files. See 
“Drawing Sheet Setup Dialog” on page 
1216.

Layout Page Display Options
Select Tools> Display Settings> 
Display Options to open the Layout 

Page Display Options dialog. 

This dialog is  similar to the Layers Display 
Options dialog, but controls only the display 
of objects drawn on the layout page, such as 
CAD objects, text, dimensions, and imported 
objects. The display of layout view boxes is 
also controlled by the Layout Page Display 
Options - but not the objects within those 
views. 

For information about how to use this dialog, 
see “Layer Display Options Dialog” on page 
149.

For information about controlling the display 
of objects in views sent to layout, see 
“Displaying Layout Views” on page 1246. 

Page Templates
In addition to the default settings available in 
layout files, you can create one or more Page 
Templates. Page Templates let you create 
features like a title block and border and then 
apply those features to any of the pages of 
your layout that you wish. See “Layout Page 
Templates” on page 1261.

Layout File Templates
You can customize layout default settings 
and Page Templates for future layouts and 
create a template. See “Template Files” on 
page 84.

The Layout Tools
There are a variety of tools available 
to send views to layout and edit them, 

as well as manage layout pages and links. 

Many of the tools available in layout are 
described in the Printing chapter. See “The 
Printing Tools” on page 1215. 

Sending Views to Layout
Select File> Send to Layout to open 
the Send to Layout dialog and send 

the current view to the specified layout page. 
See “Sending Views to Layout” on page 
1240.

In floor plan view, select a saved cross 
section/elevation view symbol and 

click the Send Camera’s View to Layout 
edit button. See “Saving and Printing 3D 
Views” on page 922.

Select Tools> Layout> Referenced Plan 
Files to see a list of the files that are 
referenced by the layout. See “Referenced 
Plan Files Dialog” on page 1257.

Editing Layout Views
A selected layout view can be edited much 
like other box-based objects. See “Editing 
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Box-Based Objects” on page 206. In 
addition, a variety of edit tools allow you to 
control the appearance of each view. 

Select a layout view and click the 
Open View edit button to open the 

view that was originally sent to layout. This 
tool is only available for dynamic views. See 
“Editing Dynamic Views” on page 1248. 

Select a layout view and click the 
Rescale Layout edit button to open 

the Change Scale dialog and apply a 
different scale. See “Rescaling Views” on 
page 1249.

Select a layout view and click the 
Relink File edit button to open the 

Choose Layout File Reference dialog and 
relink the selected layout view. See 
“Relinking Layout Views” on page 1257.

Select a layout view and click the 
Layout Box Layers edit button to 

open the Layer Display Options dialog for 
the selected view. See “Displaying Layout 
Views” on page 1246. 

Select Tools> Layout> Edit Layout 
to allow the lines of a Vector View 

sent to layout to be edited individually. See 
“Editing Layout Lines” on page 1249.

Managing Layout Pages
Select Tools> Layout> Edit Page 
Information to open the Layout 

Page Information dialog. See “Layout Page 
Information” on page 1261. 

Select Tools> Layout> Insert Page 
Before to add a new layout page, 

moving the current page and all following 
pages up one page, as long as there is nothing 
on page 1000. 

Select Tools> Layout> Insert Page 
After to add a new layout page, 

leaving the current page where it is but 
moving all following pages up one page, as 
long as there is nothing on page 1000. 

Select Tools> Layout> Delete Page 
to delete the current layout page, 

moving all following pages down one page, 
as long as nothing is on the current page. 

Select Tools> Layout> Exchange 
With Next Page to switch the current 

layout page with the following page. Not 
available on Layout Page 1000. 

Select Tools> Layout> Exchange 
With Previous Page to switch the 

current layout page with the page preceding 
it. Not available on Layout Page 0.

Select Tools> Layout> Layout Page 
Table to place a Layout Page Table. 

See “Layout Page Tables” on page 1264. 

Select Tools> Layout> Layout 
Revision Table to place a Revision 

Table. See “Revision Tables” on page 1264. 

Viewing Layout Files
Use Tools> Layout> Page 

Note: You can also modify the layers of the
layout file itself. See “Layout Page Display
Options” on page 1236.

You can also specify the page that an
object or group of objects displays on

in its specification dialog. See “Line Style
Panel” on page 1085.



1238

Chief Architect X8 Reference Manual

Up, Page Down, and Change Layout Page 
to navigate the layout document. See “The 
Current Page” on page 1259.

Select Window> Swap Views to 
switch between the current view and 

the view that was current before it. See 
“Working in Multiple Views” on page 883.

Click the Show Layout button to 
switch to a layout file that is currently 

open. 

Creating a Layout File
To open an existing layout file, select 
File> Open Layout. Browse to a 

directory and select the layout file to open. 
See “Opening and Importing Files” on page 
61.

Only one layout can be open at a time. When 
a layout file is open, it is listed at the bottom 
of the Window menu as an open view. 
Layout files are also listed in the Project 
Browser. See “Project Browser” on page 
1125.

In order to create a layout file, you must open 
a new file and then save it.

Choose File> New Layout to create a 
blank layout file. A layout file is 

created with the name untitled.layout. New 
layout files open to the first regular, non-
Template page and use the default and layer 
settings associated with your layout 
template. See “Template Files” on page 84. 

If a layout file is not open when you try to 
send a view to layout, a warning message 

will ask you if you want to create a new 
layout file. See “Sending Views to Layout” 
on page 1240.

Select File> Save to save the layout 
file. It is important that you save the 

layout in the same directory as the plan file 
from which views will be or have been sent 
to the layout pages. See “File Management” 
on page 51.

Although it is possible to use multiple plan 
files with a layout, it is generally best to 
associate only one plan file with a layout and 
to use the same file name for both. If more 
than one plan file is used, all should be saved 
in the same directory as the layout file. 

When you save your layout, take a moment 
to also save the plan file associated with it. 

CAD and Text in Layout
CAD objects, text objects, as well as 
dimensions can be incorporated into 

your layout by both including them in your 

views sent to layout and by drawing them on 
the layout page. 

When a view is sent to layout, the plan
and layout files become linked. If you

rename or move either file, this link will be
broken and the view will not display. See
“Managing Layout Links” on page 1255.
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On the Layout Page
CAD, text, and dimensions can be drawn 
directly on any layout page, allowing you to 
create a title block, border, as well as notes 
and other annotations. A variety of Layout 
Info text macros  with information about 
page numbers, revisions, and more can be 
inserted into text objects on layout pages. 
See “Text Macros” on page 1064. 

CAD, text, and dimensions created in layout 
can be selected, edited, and deleted just as 
they can in other views. See “Editing Text” 
on page 1045 and “CAD Objects” on page 
1071.

To move a text or CAD object to another 
page, change the Page number in its 
specification dialog. See “Line Style Panel” 
on page 1254. 

Any text or CAD objects that you would like 
to display on multiple pages of your layout 
file - for example, a title block and border - 
should be drawn on a page specified as a 
Page Template. See “Layout Page 
Templates” on page 1261. 

In Views Sent to Layout
CAD, text, and dimensions in views sent to 
layout are scaled just like other objects in the 
view. If you want text in a layout view to 
print at a particular size, specify its size 
based on the scaling you will use when you 
send the view to layout. See “Character Size” 
on page 1030.

If you rotate a view on the layout page, any 
text in that view will rotate as well, provided 
that its Text Style is using the Rotate with 
Plan setting. See “Text Styles” on page 
1061. 

If you wish to use Global Text Macros that 
provide information about a view, such as its 
drawing scale or the plan’s file name, make 
sure that the text object is in the view sent to 
layout - not on the layout page. 

A number of macros with information about 
the layout view can also be added to a layout 
view’s label as Object Specific Macros. See 
“Layout Box Borders and Labels” on page 
1247. 

Pictures, Metafiles, and PDFs in Layout
Picture files, metafiles, and PDF files can be 
included in views sent to layout or imported 
directly onto a layout page. See “Displaying 
Pictures, Metafiles, and PDF Boxes” on page 
1151.

Like CAD and text objects, imported 
pictures, metafiles, and PDFs can be 
included on Page Templates. See “Layout 
Page Templates” on page 1261. 

Views can also be sent to layout as pictures 
embedded in the layout file. See “Static 
Views” on page 1245. 

A picture, metafile, or PDF file imported 
onto the layout page can be selected and 
edited using its edit handles, edit tools and 
specification dialog. See “Editing Pictures, 
Metafiles, and PDF Boxes” on page 1151. 
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Sending Views to Layout
Layout files can contain many 
different views and details sent to it 

from one or more plan files. To send the 
active view from a plan file to layout, select 
File> Send to Layout.

You can also send one or more saved, closed 
cross section/elevation views to layout by 
selecting the camera symbol and clicking the 

Send Camera’s View to Layout  edit 
button. See “Saving and Printing 3D Views” 
on page 922.

When a view is sent to layout, the program 
sends it to the layout file that is currently 
open. While more than one plan file can be 
open at once, only one layout file can be 
open at a time. 

If no layout file is open, the program 
searches for a layout file with the same file 
name as the plan that the view is being sent 
from. If it cannot find such a layout file, it 
will ask if you want to create a new layout 
and send the view to it.

To send a view to layout

1. Prepare the view so that objects that 
should be seen are visible and those that 
should not are suppressed. See “Layer 
Display Options Dialog” on page 149.

2. Select File> Send to Layout . In the 
Send to Layout dialog, the available 
options vary depending on the type of 
view being sent to layout.

3. Click OK to send the view to the speci-
fied layout page. Depending on the type 
of view and size of the model, you may 
see a progress indicator in the Status 
Bar. See “The Status Bar” on page 42. 

Embedded pictures and pdf files
increase layout file size. Limit the

number of large and/or multiple pictures.

If there are layer settings that you use
often, it may be helpful to define custom

layer sets for your layout files. See “Layer
Sets” on page 146.
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Send To Layout Dialog

Specify the desired Send Position for 
the view. These options are available 

for all types of views.
• Send to Layout Page # - Enter a page 

number to send the view to.
• Check Snap to Active CAD Point to 

snap the view you are sending to layout 
to the active CAD Point. See “Point 
Tools” on page 1076.

• Check Show Layout Page to go to the 
selected layout page when you click OK.

Which Send Options are available 
depends on the type of view being sent 

to layout.
• Select Entire Plan/View to send to lay-

out the extent of the plan that is visible 

when you click Fill Window . This 
option is available for Vector Views, Wall 

1

2
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Details, and cross section/elevation 
views.

• Select Current Screen to send only what 
is shown on screen to layout. This option 
is available for Vector Views and Wall 
Details.

• Select Current Screen As Image to send 
only what is shown on screen to layout as 
an embedded image. See “Picture File 
Box Specification Dialog” on page 1143. 
This option is available for all views, and 
is the only option available for rendered 
and Ray Trace views.

• Uncheck Make Copy of Active Layer 
Set to reference the currently active layer 
set in the layout view. When this option is 
checked, a copy of the currently active 
layer set is created for use by the layout 
view. You can specify a New Name for a 
copied layer set if you wish. The copied 
layout set is saved with the plan file that 
the view is sent from. Your choice is 
maintained between sessions. See “Lay-
out Layer Sets” on page 156.

The Camera View Options are 
available for cross section/elevation, 

camera views, and overviews sent to layout - 
provided that Current Screen as Image is 
not selected, above. 
• Select Live View to make the view 

dynamically linked to the plan file.
• Select Update on Demand to update the 

view only when prompted. See “Keeping 
Layout Views Current” on page 1243.

• Select Always Update to update the view 
any time a change is made to the model. 
This option ensures that the view is 
always current but may cause program 
slowness.

• Select Plot Lines to send a Vector View 
to layout that uses automatically gener-
ated Plot Lines to represent surface edges 
and material pattern lines in the model. 
See “Plot Line Views” on page 1245. 

• Check Color Fill to include colors that 
correspond to the materials used in the 
model.

Select a radio button to specify the 
method of Scaling for the view sent to 

layout.
• Select Fit to Sheet (No Scale) to send the 

view to layout at approximately half the 
size of the layout drawing sheet. Once on 
the layout page, the view can be resized. 

• Specify the exact scale for the view in 
layout. The view can be rescaled later 
from layout if necessary. Both Imperial 
and metric units of measurement are 
available and can be selected indepen-
dently. 

• When views are sent to layout at different 
scales, line weights and line styles are 
subject to the same scaling. See “Line 
Weights and Scaling” on page 1224. In 
most cases this is not desirable. When 
Use Layout Line Scaling is checked, the 
lines in views sent to layout appear the 
same as lines drawn directly on layout. 
This option is not available for rendered 
views.

The Plot Line Options are only avail-
able when the Plot Lines option is 

selected, above.
These settings are preserved between ses-
sions and provide the initial settings for simi-
lar settings in the Layout Box Specification 
dialog. See “General Panel” on page 1252. 

3

4

5
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• Check Use Edge Line Defaults and 
specify a Default Line Weight to over-
ride all layer- and object-specific line 
weight settings when the view is sent to 
layout. When unchecked, the layout view 
respects the Surface Edge Lines settings 
in the 3D View Defaults dialog. See “3D 
View Defaults Dialog” on page 892.

• Check Use Pattern Line Defaults and 
specify a Default Pattern Weight to 
override material Line Weight settings set 
in the Define Material dialog. See “Gen-
eral Panel” on page 865.

• Uncheck Merge Generated Lines to 
prevent the merging of collinear lines. 
Horizontal and vertical lines still merge.

If Merge Generated Lines is selected 
and a cross section/elevation view is sent 
to layout, the program merges any lines 
that are superimposed or parallel with 
each other so that the layout has only one 
line rather than several. This makes the 
final view easier to edit in layout if neces-
sary, but may slow down the process of 
sending 3D views containing non-vertical 
or horizontal lines to layout. 

Keeping Layout Views Current
It is not uncommon for changes to be made 
to a plan after views have been sent to layout. 
In order to make sure that your layout file is 
up-to-date, it is important to recognize that 
there are four types of layout views: 
• Dynamic Views, which update automati-

cally every time changes are made to the 
original view in the plan.

• Semi-Dynamic Views, which fully 
update when printed or prompted by you.

•      Static Views, which do not reference 
the plan and cannot be updated: only 
replaced.

• Plot Line Views have elements that are 
Dynamic or Semi-Dynamic and others 
that are Static. 

Note that while convenient, Dynamic views 
require use of your computer’s resources and 
may slow program performance. Consider 
sending cameras, overviews, and cross 
section/elevations to layout as Semi-
Dynamic views.

Dynamic Views
Dynamic views reference the original view 
in the plan and update automatically 
whenever changes are made to that view, 
including:
• Changes to the model.
• Changes to annotations in the view.
• Changes to the layer set used by the lay-

out view. See “Layout View Layers” on 
page 1246.

The Edge and Pattern Line Defaults set-
tings are included for legacy files and

are not the recommended method of specify-
ing this information. See “Edge and Pattern
Lines” on page 145. 
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In order for a view to be Dynamic, it must be 
sent to layout using either the Entire Plan/
View or Current View Send Option. In 
addition, camera views must have Update 
Always specified. See “Send To Layout 
Dialog” on page 1241.

When a floor plan view has been sent to 
layout, a few elements are Static and 
unaffected by changes in the plan: 
• The default Display in Plan View setting 

for pony walls becomes a permanent part 
of the layout view. See “Pony Walls” on 
page 272.

• The floor level shown in a view sent to 
layout does not change if you move to a 
different floor in the plan. See “Multiple 
Floors” on page 435.

• The Reference Display  setting in a 
view sent to layout is unaffected if the 
Reference Display is turned on or off in 
the plan. See “Reference Floor Display” 
on page 444. 

• The Color  setting in a view sent to 
layout is unaffected if Color is toggled on 
or off in the plan. See “Color On/Off” on 
page 217.

• The Rotate Plan View  angle 
becomes a permanent part of the layout 
view. See “Rotate Plan View” on page 
237. 

• The Active Defaults  that are in use 
when a floor plan view is sent to layout 
are retained with the view and are not 
affected when you switch to different 
defaults in the plan. See “Using Active 
Defaults” on page 81. 

• The layer set used by a layout view does 
not change if you switch layer sets in the 
plan. See “Layout Layer Sets” on page 
156. 

Although changes in the plan do not affect a 
layout view’s floor level, its Reference 
Display setting, or its Active Defaults, you 
can specify all of these in the view’s Layout 
Box Specification dialog. See “Plan View 
Panel” on page 1253.

You can also change the layer set used by a 
layout view using the Layout Box 
Layers  edit tool. See “Layout View 
Layers” on page 1246.

For information about controlling the display 
of dynamic views in layout, see “Displaying 
Layout Views” on page 1246.

Semi-Dynamic Views
Camera views, overviews, and cross section/
elevation views can all be sent to layout as 
Semi-Dynamic views. Semi-Dynamic views 
reference the original view in the plan but no 
information about the model or the view’s 
layer settings update unless you prompt the 
layout view to update. 

When a cross section/elevation view has 
been sent to layout, CAD objects, text, and 
dimensions in that view are fully Dynamic - 
even if the view is set to Update on 
Demand. See “Detailing Cross Section/Ele-
vation Views” on page 905.

In order for a view to be Semi-Dynamic, it 
must be sent using either the Entire Plan/
View or Current View Send Option and 
have Update on Demand specified. See 
“Send To Layout Dialog” on page 1241.
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There are several ways to update a Semi-
Dynamic view:

• Select it and click the Update View  
edit button. 

• Select Tools> Layout> Update Layout 
Views> Update All Views .

• Select Tools> Layout> Update Layout 
Views> Update All Live Views .

• Update on Demand views also update 
automatically when you print the layout 
page that they are on. 

Note that views set to Update on Demand 
may experience a loss in quality as you zoom 
and pan on the layout page. To restore a 
view’s resolution, simply update it.

Static Views
Static views are like a snapshot of the model 
taken at a specific time: they do not update 
when the plan changes. If changes to the plan 
need to be shown in a Static view, that view 
must be deleted and resent to layout. 

All views sent to layout using the Current 
Screen as Image option are Static. They are 
treated as imported images embedded in the 
layout file. See “Picture File Box 
Specification Dialog” on page 1143.

Because Ray Trace views are themselves 
static images of the model, Current Screen 
as Image is the only option available when 

sending them to layout. See “Ray Tracing” 
on page 965. 

Plot Line Views
Camera views, overviews, and cross section/
elevation views using the Vector View 
Rendering Technique can be sent to layout as 
Plot Lines. See “Rendered and Vector 
Views” on page 888.

In Plot Line views, the lines in the layout 
view that represent the 3D model are 
automatically generated copies of those in 
the original view, allowing them to maintain 
the line weights that were specified in the 
plan. See “Line Weights” on page 1223.
• Plot Line views are Semi-Dynamic in 

that they are linked to the original view 
and can be updated.

• Plot Line views are Static in that they will 
not update automatically when printed: 
they can only be updated manually by 
you.

• The Plot Lines themselves are also Static: 
they can be edited using the Edit Layout 
Lines  tool, but if the view is updated, 
these lines are deleted and replaced. For 
this reason, you should only use the Edit 
Layout Lines  tool after the model 
has been finalized. See “Editing Layout 
Lines” on page 1249.

• Any CAD objects, text, or dimensions 
drawn in a cross section/elevation view 
sent to layout will not be copied and 
represented by Plot Lines. These objects 
are fully Dynamic and will update 
immediately in the layout view if changes 
are made to them. See “Detailing Cross 
Section/Elevation Views” on page 905.

If a camera view using Perspective
Crop Mode is sent to layout as a semi-

dynamic view, it may not look the same as
the original view. See “To use Perspective
Crop Mode” on page 911. 
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• The Color  setting in a Plot Line view 
is unaffected if Color is toggled on or off 
in the original view in the plan. See 
“Color On/Off” on page 217.

Plot Line views do not automatically update 
when printed, nor can they be set to update 
automatically. In order to update a Plot Line 
view, you must do one of the following: 

• Select it and click the Update View  
edit button,

• Select Tools> Layout> Update Layout 
Views> Update All Views , or

• Select Tools> Layout> Update Layout 
Views> Update All Plot Line Views .

In addition, if a camera view sent to layout 
using the Plot Lines option and the camera 
view is later closed while the layout sheet is 
open, you will be asked to choose whether to 
update the view on the layout page. 
• If the layout view is up-to-date with the 

3D model or if you do not want your 
changes to be seen in the layout view, 
select No. 

• To update the view on the layout page 
and replace all the Plot Lines, choose 
OK. 

Displaying Layout Views
Select Window> Show Layout to 
make an open layout file the current 

view. Only available when a layout file is 
open but not active.

Just as some elements in a view window do 
not print, they are not included when a view 
is sent to layout: for example, the Reference 
Grid and camera symbols in floor plan view. 
See “Print Preview” on page 1219. 

Layout View Layers
When a view is sent to layout, the active 
layer set is used. Some view types give you 
the option of duplicating and renaming the 
active layer set before sending the view to 

layout. See “Sending Views to Layout” on 
page 1240.

Whether or not the layer settings in a view 
can be edited after it has been sent to layout 
depends on the view’s type.  See “Keeping 
Layout Views Current” on page 1243.
• The layer set used by a Dynamic or Semi-

Dynamic view can be modified using the 
Layout Box Layers  edit tool.

• A different layer set can also be selected 
for Dynamic and Semi-Dynamic views 

using the Layout Box Layers  edit 
tool.

• In addition, Dynamic and Semi-Dynamic 
views’ layer settings can be modified by 
opening the original view. See “Opening 
Layout Views” on page 1255. 

• Static views cannot be changed. Simi-
larly, even in Dynamic views, some fea-
tures are static and cannot be altered. 

Although camera symbols are not
included in views sent to layout, camera

callouts are when the “Cameras” layer is
turned on in the view. See “Camera Labels
and Callouts” on page 908. 
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The layer set referenced by a Dynamic layout 
view is saved with the plan rather than the 
layout file.

To use the Layout Box Layers tool

1. Select a layout view. 

2. Click the Layout Box Layers  edit 
button to open the Layer Display 
Options dialog for the selected view. 
See “Layer Display Options Dialog” on 
page 149.

•  If this edit button is not available, the 
view is not dynamic. 

•  The layer set for the layout view dis-
plays at the top of the dialog.

•  The settings for the currently selected 
layer display below.

3. You can make changes to settings of the 
current layer set.

Changes made to this layer set affect all 
other views that use it, not necessarily 
the selected layout view alone.

4. Alternatively, you can select a different 
layer set for the layout view from the 
Layer Set drop-down list.

5. Be sure to Save  your changes in the 
plan file before closing the layout.

Layout Box Borders and Labels
A border will display around each layout box 
when the “Layout Box Borders” layer is set 
to display in the Layout Page Display 
Options dialog. See “Layout Page Display 
Options” on page 1236. 

Layout boxes can also display labels when 
the “Layout Box Labels” layer is set to 
display. See “Object Labels” on page 1279. 

Automatic layout box labels display basic 
information about the original view in the 
plan. For example, floor plan view sent to 
layout from Floor 1 will have an automatic 
label that says, “1st Floor”. A camera view 
sent to layout will have a label that states the 
camera’s name. Layout box labels have their 
own edit handles and can be customized to 
include text as well as Object Specific Text 
Macros. See “Text Macros” on page 1064.

Missing Layout Views
If a view on the layout page can be selected 
but cannot be seen, its link to the plan from 
which it was sent may have been broken. See 
“Managing Layout Links” on page 1255. 

Editing Layout Views
To edit a layout view, first select its layout 

box using the Select Objects  tool. Once 
selected, the view box can be edited using its 

edit handles, edit toolbar or specification 
dialog. See “Layout Box Specification 
Dialog” on page 1251.

Do not delete layer sets that are used in
layouts.
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Using the Edit Handles
Layout view boxes can be edited like CAD 
boxes. See “Editing Box-Based Objects” on 
page 206. 

Floor plan views and CAD Details can be 
rotated. Both the layout box and the view 
inside it rotate. Cross section/elevation and 
3D views sent to layout cannot be rotated.

In the Specification Dialog
Layout view boxes can be customized in 
their specification dialog. See “Layout Box 
Specification Dialog” on page 1251.

Using the Edit Tools
A selected layout view or views can be 
edited in a variety of ways using the buttons 
on the edit toolbar. See “The Edit Toolbar” 
on page 37.

Using Dimensions
Like other CAD box-based objects, layout 
views can be moved and resized using 
dimensions. See “Moving Objects Using 
Dimensions” on page 1019.

Moving Views to a 
Different Page

To move a view from one layout page to 
another, select the view, click the Open 
Object  edit button, and change the Page 
on the LINE STYLE panel of the Layout Box 
Specification dialog. See “Layout Box 
Specification Dialog” on page 1251.

Copying Views
Just like many objects, views sent to layout 
can be copied and pasted onto different 
layout pages or even into different layout 
files. 

As a general rule, though, if multiple copies 
of a view are needed, it is best to send the 
view to layout as many times as necessary 
because each view can then be controlled 
independently.

Bear in mind, too, that if a layout has views 
copied from a different layout file and is later 
moved to a different location on your 
computer, the link to the original plan file 
may be broken. See “Keeping Layout Views 
Current” on page 1243. 

Editing Dynamic Views
Select a Dynamic or Semi-Dynamic view 

and click the Open View  edit button to 
open the original view that was sent to 
layout. You can also double-click a view of 
either type in layout to open the original 
view. See “Opening Layout Views” on page 
1255.

Resizing Scaled Views
Scaled views retain their scale regardless of 
how you resize the border. You can resize the 
border proportionally from a corner handle 
or select one of the handles on an edge to 
change the size in one direction only. The 
image may be cropped if the border is resized 
small enough. 

Resizing Non-Scaled Views
If the view was sent to layout using the Fit to 
Sheet setting, or if a view is set to Fit to 



Editing Layout Lines

 1249

Drawing Sheet in the Change Scale dialog, 
resizing may have one of several results:
• Drag a corner handle in or out to resize 

both the border and the image proportion-
ally. 

• If you drag a side handle in or out, the 
image stays the same size, but the border 
changes. If you make the border smaller, 
it may crop the image; if you make it 
larger, you may show more of the image.

Rescaling Views
To change the scale of a floor plan, 
CAD Detail, cross section/elevation, 

or wall elevation sent to layout, select the 
view and click the Rescale Layout View edit 
button. The Change Scale dialog opens.

• Choose No Scale to remove any specific 
scale factor associated with the selected 
view. 

• Select the second option to specify a 
scale for the view. When its scale is 
changed, the layout view will resize. In 
most cases, you should specify a scale for 
floor plan views, CAD Details, and cross 
sections/elevation views. Typical scales 
are ¼ in = 1ft and 1 m = 50 m.

• When a view is sent to layout at a scale 
other than that of the original view, line 
weights and line styles are affected. In 
many cases, this is not desirable. Check 
Use Layout Line Scaling to make lines 
in the selected view appear the same as 
lines of the same weight drawn on the 
layout page. See “Line Weights and Scal-
ing” on page 1224.

Editing Layout Lines
Individual object edge and material 
pattern lines in a Vector View sent to 

layout using the Plot Lines option can be 
selected, edited, and drawn using the Edit 
Layout Lines tool. Changes made using this 
tool have no effect on the 3D model. See 
“Rendered and Vector Views” on page 888.

Bear in mind that automatically generated 
Plot Lines are not dynamically linked to the 
model: if the layout view is updated, these 
lines are deleted and replaced. For this 

reason, you should only use the Edit Layout 
Lines  tool after the model has been 
finalized. See “Keeping Layout Views 
Current” on page 1243.

The full set of CAD editing tools is not
available when using Edit Layout Lines.

It is often more efficient to edit lines in a Vec-
tor View by sending it to a CAD Detail for edit-
ing first. See “CAD Detail from View” on page
1118.
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CAD lines drawn in cross section/elevation 
views sent to layout cannot be edited using 

the Edit Layout Lines  tool. Only Plot 
Lines generated by the program can be edited 
using this tool. See “CAD and Text in 
Layout” on page 1238.

Selecting Layout Lines
To select a line in a layout view, click the 

Edit Layout Lines  button and click on 
the line. You can select additional lines in the 
same layout view using the marquee select or 
group select methods.  See “Selecting 
Objects” on page 183. 

Adding New Layout Lines
Add a line to a layout Vector View by 

clicking the Edit Layout Lines  button, 
selecting a layout view, and drawing a new 
line within the layout box. Once drawn, this 
line can be edited like any other layout line 
and maintains its position in relation to the 
layout view it was drawn in.

Editing Layout Lines
When a layout line is selected, you can use 
the edit handles to change its size, angle, and 
position, as with standard CAD lines. A 
selected layout line can also be deleted like a 
standard CAD line; however, many of the 
edit tools that are available for standard CAD 
objects are not availble for layout lines.

Angle Snaps , Object Snaps , and 
Grid Snaps are all available in layout. See 
“Snap Settings” on page 160.

Layout line properties can be changed in the 
Layout Line Specification dialog. 

Layout Line Specification 
Dialog

Use the Edit Layout Lines tool to 
select one or more lines in a Vector 

View sent to layout, then click the Open 
Object edit button to open the Layout Line 
Specification dialog. 

The dialog lets you to change the properties 
of the selected line(s) without changing the 
properties of all lines in the view.

Specify the selected line or lines’ Line 
Type. 

• Select Edge Line to specify the selected 
line(s) as defining the edges of the sur-
face of 3D objects.

• Select Pattern Line to specify the 
selected line(s) as patterns lines for mate-
rials such as brick, siding, and shingles.

• When multiple lines are selected, No 
Change may be available. 

1
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Specify the Line Weight of the selected 
layout line(s). See “Line Weights” on 

page 1223. 
• Type the desired Weight, or thickness, of 

the selected line(s) in the text field. 
• Check Use Default Weight to use the 

default value set in the view’s Layout 
Box Specification dialog. See “General 
Panel” on page 1252. 

Specify the Line Style of the selected 
line(s). See “Line Styles” on page 1108. 

• Select a line style from the drop-down list 
or click the Library button and choose 
one from the Library. 

• Check Use Default Style to use the 
default style set in the Layout Box 
Specification dialog.

Specify the Line Color of the selected 
line(s). 

• Click the Color bar to select a line color. 
See “Color Chooser/Select Color Dialog” 
on page 875.

• Check Use Default Color to use the 
default color set in the Layout Box 
Specification dialog.

Layout Box Specification Dialog
Select a layout view and click the 
Open Object edit button to open the 

Layout Box Specification dialog.

2

3
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General Panel

Specify the Center Point of the 
selected view’s bounding box. See “3D 

Drafting” on page 31.
• X Position - The location of the layout 

box relative to the absolute origin.
• Y Position - The location of the layout 

box relative to the absolute origin.

Specify the Size/Orientation of the 
selected view’s bounding box. 

• Angle - The current angle of the layout 
box relative to a horizontal line pointing 
towards the right hand side of the screen.

Specify the Number Height for 
Dimensions in the selected view. Type 

a (D) to use the default height for the selected 
view. See “Dynamic Defaults” on page 76. 

This setting is only available for views sent 
to layout from floor plan view and CAD 
Details. It affects the size of dimension 
numbers in the layout view but not in the 
original view in the plan file. 

1
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The Camera View Options are 
available for Dynamic and Semi-

Dynamic cross section/elevation, camera 
views, and overviews sent to layout. See 
“Keeping Layout Views Current” on page 
1243. 
• Select Live View to make the view 

dynamically linked to the plan file.
• Select Update on Demand to update the 

view only when prompted. See “Keeping 
Layout Views Current” on page 1243.

• Select Always Update to update the view 
any time a change is made to the model. 
This option ensures that the view is 
always current but may cause program 
slowness.

• Select Plot Lines to use automatically 
generated Plot Lines to represent surface 
edges and material pattern lines in the 
model. See “Plot Line Views” on page 
1245. 

• When Plot Lines is selected, check Color 
Fill to include colors that correspond to 
the materials used in the model.

Specify the Edge Line Defaults for a 
selected cross section/elevation view. 

Note that edge lines only use these values if 
Use Edge Line Defaults was checked when 
the selected view was sent to layout. See 
“Send To Layout Dialog” on page 1241.
• Specify the default Line Weight, or 

thickness, for all edge lines in the view.
• Specify the default Line Color for all 

edge lines in the view. 

Specify the Pattern Line Defaults for 
a selected cross section/elevation view. 

Pattern lines only use these values if Use 
Edge Line Defaults was checked when the 
selected view was sent to layout. 
• Specify the default Line Weight, or 

thickness, for all pattern lines in the view.
• Specify the default Line Color for all 

pattern lines in the view. 

Plan View Panel
The PLAN VIEW panel is only available when 
the selected view is a floor plan view. See 
“Dynamic Views” on page 1243.

The Number Height setting is included
for legacy files and is not the recom-

mended method of specifying dimension
size. See “Dimension Labels” on page 1012. 

4

The Edge and Pattern Line Defaults set-
tings are included for legacy files and

are not the recommended method of specify-
ing these line styles. See “Edge and Pattern
Lines” on page 145. 

5
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Specify the floor and Annotation Set 
associated with the selected view. 

• Select the Current Floor shown in the 
layout view from the drop-down list. 

• Select the Current Annotation Set from 
the drop-down list. The options available 
are limited to the Annotation Sets saved 
in the view’s plan file. 
The Current Annotation Set does not 
affect the layout view’s appearance, but 
will determine what Annotation Set is 

active if you use the Open View  edit 
tool to return to the original view. See 
“Annotation Sets” on page 1255. 

Check Show Reference Floor to 
include the Reference Floor in the 

selected view and enable the settings below. 
See “Reference Floor Display” on page 444. 
• Select which floor to use as the Refer-

ence Floor from the drop-down list. 

• Select the Reference Layer Set to use 
from the drop-down list. 

• Check Draw Reference Floor First to 
draw the Reference Floor before the 
drawing the objects on the floor shown in 
the view. When this is unchecked, the 
Reference Floor draws last and appears in 
front of the objects on the current floor. 

Line Style Panel
The settings on the LINE STYLE panel let you 
to set the properties of the selected layout 
box’s border and to specify what layout page 
it is located on. 

For more information, see “Line Style Panel” 
on page 1085. 

Fill Style Panel
For information about the FILL STYLE panel, 
see “Fill Style Panel” on page 1099.

Label Panel
Layout box labels display in layout when the 
“Layout Box Labels” layer is turned on and 
use the Text Style assigned to that layer. See 

Note: “Active Defaults” will be included in the
Current Annotation Set list if Make Copy of
Active Layer Set was checked when the view
was sent to layout, or if Active Defaults were
in use when it was sent to layout. 

1
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“Layout Box Borders and Labels” on page 
1247. 

For more information about the settings on 
this panel, see “Label Panel” on page 1280.

Opening Layout Views
Dynamic and Semi-Dynamic views 
sent to layout refer to an original view 

in a plan. From the layout page, you can 
access that original view by selecting a 
layout box, then clicking the Open View edit 
button. The original view can also be opened 
by double-clicking the layout view using the 

Select Objects  tool.

Changes made in this view update in the 
original layout view. Be aware that 
depending on the changes you make, other 
views may also be affected. 

Layer Sets
Notice the name of the current layer set that 
displays in the Active Layer Set Control 
drop-down list. Changes made to this layer 
set affect not only the current view, but also 
the associated layout view and any other 
views that use this layer set. See “Layer 
Sets” on page 146. 

Annotation Sets
Floor plan views, cross section/elevation 
views, and CAD Details sent to layout each 
have a set of Active Defaults associated with 
it. When you send one of these view types to 
layout, these defaults become associated 
with the layout view; and when you open the 
original view of one of these types of layout 
views, its defaults will become active 
automatically. See “Multiple Saved 
Defaults” on page 77. 

You can specify which defaults are 
associated with a floor plan view sent to 
layout by specifying the view’s Current 
Annotation Set in the Layout Box 
Specification dialog  See “Plan View Panel” 
on page 1253. 

Please note that the Current Annotation Set 
associated with a layout view always uses the 
layer set assigned to the layout view, 
regardless of how the Annotation Set itself 
may be defined. 

Managing Layout Links
Chief Architect allows you to review plan 
files linked to a current layout, change 
existing links from one plan file to another, 

and reestablish links to plan files that have 
been moved or renamed.

It is important to remember that when a
plan view is accessed by opening a

dynamic layout view, that view uses the same
layer set as the layout view.
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Protecting Layout Links
Careful file management is needed to avoid 
missing files and disrupted layout links. See 
“File Management” on page 51.

The following guidelines can help prevent 
layout links from being broken:
• Save plan files in the same folder as the 

layout, or in a sub-folder in that folder.
• Legacy plan files referenced by a layout 

must have the .plan file extension. Plans 
from version 9.5 and prior with the .pl 
file extension cannot link to .layout files.

• Custom graphics included in a plan or 
layout should be embedded in the file or 
saved in the same folder as the layout.

• Plan files used to save CAD details or 
other information should be copied and 
saved in the same folder as the layout.

• Plan files should never be renamed. If a 
new name is desired, make a copy of the 
file and rename the copy. Changes made 
in the copy do not affect views sent to 
layout from the original plan.

• Avoid sending cross section/elevations to 
layout more than once. Changes made to 
the view can affect layout views in unin-
tended ways.

• Layout files should never be moved. If a 
layout file must be moved, the entire 
folder it is saved in should be moved or 
copied and then moved.

• Use File> Backup Entire Plan  to 
create an independent copy of the origi-
nal layout. Avoid use of “Save As.”  See 
“Backup Entire Plan” on page 70.

• Do not delete any layer sets that are used 
by a view that was sent to layout. See 
“Layer Sets” on page 146.

• If you relink a layout view to a new plan, 
be sure to save the plan file so the layer 
sets are updated.

Finding Missing Files
When a layout file is opened, the program 
performs a breadth-first search for 
dynamically linked views. This means that it:
• Looks first in the same folder as the lay-

out. 
• Looks next in the folders located closest 

to the layout’s folder. 
• If a missing file is not found, it expands 

its search further from the location of the 
layout file until the files with the linked 
views are located.

• If a missing file is not found, a second 
breadth-first search will be performed, 
searching all zipped files found in the 
first search. 

If a file remains missing after the program 
performs a search of your system, a Warning 
message will indicate that the program could 
not successfully open all of the layout’s 
associated plan files. When you click OK, 
the Referenced Plan Files dialog will open, 
allowing you to relink the layout to its 
missing associated files.

You can also open this dialog at any time by 
selecting Tools> Layout> Referenced Plan 
Files while a layout file is open.
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Referenced Plan Files Dialog

The Plan Files Present section lists all 
files with intact links to the layout.

The Plan Files Not Found section lists 
the names of files with disrupted links 

to the layout. Any files listed here have been 
moved, renamed, or deleted and cannot be 
found by the program. Intervention is 
required to find these files and reestablish 
their links to the layout. 

Select a missing file and click the Browse 
button just above the Plan Files Not Found 
field to open the Browse For Missing File 
dialog, which is a typical Open dialog. See 
“Opening and Importing Files” on page 61.
• Locate the missing file in your system’s 

directory structure. When the missing file 
is selected, click Open to link it to the 
layout. 

• You can also redirect an intact link to 
from a File Present in Layout to a differ-
ent file in the same manner.

Be sure to choose File> Save  in the 
layout file when the missing files have been 
located to save their links to the layout file.

Results of Missing Files
If all missing files are correctly redefined, 
the layout opens when you click OK. 

If an error message displays, one or more of 
the missing files could not be replaced by the 
redefined file. Click OK to continue. The 
layout opens, but with the following 
characteristics:

1. Any floor plan views or CAD Details 
associated with the missing file(s) are 
blank. Only the border displays if the 
“Layout Box Borders” layer is set to dis-
play. See “Layout Page Display 
Options” on page 1236.

2. Any elevations or cross sections associ-
ated with the missing file(s) show the 
automatically generated lines, but any 
added CAD objects are absent. 

Relinking Layout Views
You can change the file that a dynamic 
layout view is linked to by selecting 

the view and clicking the Relink File edit 
button to open the Choose Layout File 

1
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Reference dialog. This dialog is a typical 
Open File dialog: select the file that you want 
to link to and click Open. See “Opening and 
Importing Files” on page 61.

In the Windows version of the software, this 
dialog opens to the linked file’s specified 

directory and populates the Filename field 
with that files’s  name. 

If you want to relink all references to this 
file, use the Referenced Plan Files dialog. 

Missing Layer Sets
The layer set associated with each view in a 
layout is saved with the plan file from which 
the view was sent. Just as it is important to 
not move, rename, or delete the plan file, it is 
important that you not rename or delete a 

layer set used by a layout view. See 
“Opening and Importing Files” on page 61. 

If a layer set used by a layout view cannot be 
found when the layout is opened, the 
Missing Layer Set dialog will display.

The Layout Box Information 
describes the layout view that is 

missing a layer set, indicating:
• The Layout Page where the view in 

question is located; 
• View Information, which describes the 

contents of the view in question, 
• The Plan Filename of the plan file that 

the layer set is missing from.

The Layer Sets options allow you to 
replace the missing layer set.

• The name of the Missing Layer Set dis-
plays for reference.  

• Select a replacement layer set from the 
Available Layer Sets drop-down list. 

• Click the Define button to open the 
Layout Page Display Options dialog, 
where you can make changes to the 
selected layer set.

1 2
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Layout Page Management
There are a variety of tools that let you 
navigate and organize the pages of a layout 
file.

In the Project Browser
All pages in a layout file that are in use are 
listed in the Project Browser, including all 
pages with content and Page Templates. See 
“Project Browser” on page 1125.

Typically, blank layout pages are not listed in 
the Project Browser; however, if a new page 
is inserted using the contextual menu in the 
Project Browser, that new, blank page will be 
listed..

The three types of pages can be distinguished 
by the icon to the left of their names: 

The contextual menu for a layout page in the 
Project Browser allows you to view it, edit 
its Layout Page information, move it relative 
to other pages, or delete it. See “Contextual 
Menus” on page 38. 

The Current Page
The current layout page is 
indicated at the center of the 

Layout Page Up/Down buttons. When a 
layout file is first created, the current page is 
page one.

The current layout page is the default target 
of any view sent to layout. If sent to the 
wrong page, a view may be moved from one 

page to another. To do this, select the view 
you want to move, then click the Open 

Object  edit button to open the Layout 
Box Specification dialog. You can change 
the page number on the LINE STYLE panel. 
See “Layout Box Specification Dialog” on 
page 1251.

To navigate between layout pages
• Click the arrow buttons on either side of 

the Layout Page button. 
• Click the Current Page number between 

the arrows to open the Go To Layout 
Page dialog. Enter a page number and 
click OK.

• Select Page Up or Page Down from the 
Tools> Layout> menu.

• Press Shift + N (up one page) or Shift + 
M (down one page) on the keyboard.

• Double-click on a page in the Project 
Browser. 

Adding and Deleting Pages
To begin work on a new page, simply send a 
view to that page, or navigate to it and begin 
drawing.

Note: Layout pages do not print if they are
blank, even if a border and title block are
present.
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To insert a layout page in front of 
or behind the current page, select 

Tools> Layout> Insert Page Before or 
Insert Page After. Any pages that follow the 
new page move up one, provided that 
nothing is located on page 1000.

You can also right-click on a page in the 
Project Browser and select either Insert 
Page Before or Insert Page After from the 
contextual menu. 

To remove the current page from the 
layout file, select Tools> Layout> 

Delete Page. The current page and all 
information on it - including any views - will 
be completely removed. You can also right-
click on a layout page in the Project Browser 
and select Delete Page. 

Page Templates assigned to other pages 
cannot be deleted, and neither can page zero. 
See “Layout Page Zero” on page 1261.

Exchanging Pages
Select Tools> Layout> Exchange 
With Next Page to switch the current 

layout page with the following page. Not 
available on Layout Page 1000. 

Select Tools> Layout> Exchange 
With Previous Page to switch the 

current layout page with the page preceding 
it. Not available on Layout Page 0.

Layout Page Information
The Edit Page Information tool lets 
you specify any layout page as a Page 

Template or add information about it which 
can then be included in layout and revision 
tables. 

Layout Page Numbering
By default, layout pages begin with zero, 
which is the default Page Template, and 
proceed in ascending order to page 1000. If 
this does not meet your needs, you can create 
your own numbering convention using the 
Label setting in the Layout Page 
Information dialog. See “Layout Page 
Information” on page 1261. 

To do this, begin by typing a prefix of your 
choice followed by a pound (#) sign in the 
Label field - for example, “A#”. The 
program will replace the # with a numeral 1 
on the first page with that particular prefix in 
its Label, and will increase the number by 
one on every page that follows if it too has 
the identical prefix in its Label. 

Custom page numbering can be added to any 
page - including Page Templates. Regular 
pages do not inherit this information from 
their specified Template, however: it must be 
added to each page individually. 

There is also a selection of text macros that 
can be used to insert dynamic page 
numbering information: 
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Layout Page Templates
Layout Page Templates allow you to create a 
title block and border in one place and then 
assign them for use on any other layout pages 
that you wish. Multiple Page Templates can 
be created in the same layout file. Note that if 
a layout page is specified as a Page Template, 
it will not print as part of a print range. Page 
Templates can be printed as the Current 
Sheet, however. See “Print View Dialog” on 
page 1226. 

Add anything to a Page Template that you 
want on some or all of your printed layout 
pages, such as:

• Title Block. See “Text, Callouts, and 
Markers” on page 1027.

• Borders. See “CAD Objects” on page 
1071.

• Text Macros. See“Text Macros” on page 
1064.

• Imported images. See “Images” on page 
1134.

You can assign a Page Template to any 
layout page, or specify any page as a Page 
Template, in the Layout Page Information 
dialog. 

For more information about creating a title 
block and border for your layout template, 
see “Creating a Border and Title Block” on 
page 206 of the User’s Guide.

Layout Page Zero
In version X5 and prior, Layout Page Zero 
was the only available Page Template. In 
version X8, it functions in much the same 
way by default: it is specified as a Page 
Template with the title “Default Page 
Template”, and it is assigned to all pages. 

Because of its special purpose, page zero 
cannot be deleted. 

Layout Page Information
The Edit Page Information tool 
opens the Layout Page Information 

dialog, which you can use to add title, 
revision, and other information to the current 

layout page. This information can then be 
used to create layout and revision tables, as 
well as used in text macros. 

Macro
     %page% Layout Page Number -

States the absolute page
number of the current layout
page.

%page.print% Printed Page Number -
States the printed page num-
ber of the current page.
Blank pages are not
included in this count.

%numpages% Number of Printed Pages -
States the total number of
printed pages in the layout. 

 %lastpage% Last Used Layout Page -
States the absolute page
number of the last printed
page.

Note: The printable area varies from printer to
printer. For best results, inset layout borders
1/2" to 3/4" from the paper edge. 
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You can also use this tool to specify the 
current page as a Template, or to assign a 
Template to the current page. 

The Layout Page Information dialog can be 
opened in several ways:
• Select Tools> Layout> Edit Page Infor-

mation . 

• Click the Edit Page Information  
toolbar button.

• Right-click on a layout page in the Proj-
ect Browser and select Edit Page Infor-
mation from the contextual menu. 

Layout Page Information Dialog

The Page Information options let you 
add information to layout pages that 

can be shown in a Layout Page Table or 
added to text using a macro. The Label and 
Title will also display in the Project Browser.
• Choose the Selected Page, which is the 

page selected for editing in this dialog, 
from the drop-down list. Not available 

when the dialog is opened via the Project 
Browser contextual menu.

• Specify the selected page’s Label. If a 
cross section/elevation view is sent to this 
layout page, this Label can display in the 
camera’s callout label in floor plan view. 
See “Camera Labels and Callouts” on 
page 908. 

1
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• Specify the selected page’s Title.
• Specify the selected page’s Description.
• Specify the selected page’s Comments.
• Check Include in Layout Table to 

include the above information about the 
selected page in a Layout Table. If Use as 
Page Template is checked, this box will 
be unchecked automatically.

The Page Template Options let you 
associate the selected layout page with 

a template, or specify it as a template. See 
“Layout Page Templates” on page 1261.
• Check Use as Page Template to specify 

the selected page as a template that can 
be assigned to other pages, but not 
printed. This box cannot be unchecked if 
the current page is the Page Template 
assigned to other pages. 

• Assign a Page Template to the selected 
page by choosing one from the drop-
down list. Not available when Use as 
Page Template is checked.

The Page Revisions settings let you 
manage the revisions associated with 

the selected page. Revisions can be shown in 
a Revision Table or added to text using a 
macro. See “Revision Tables” on page 1264.
• A table listing any revisions associated 

with the selected page displays for refer-
ence. Click on a line item in the table to 
select it. 

• Click the New button to open the Layout 
Revision Specification dialog and add a 
new revision to the selected page. 

• Click the Edit button to open the Layout 
Revision Specification dialog and edit 
the selected revision.

• Click the Delete button to remove the 
selected revision from the table.

• Click the Move Up or Move Down but-
ton to adjust the position of the selected 
revision in the table accordingly.

Revision Specification Dialog
Select Tools> Layout> Add Layout 
Revision to open the Revision 

Specification dialog. You can also click the 
New or Edit button in the Layout Page 
Information dialog to open this dialog.

Revised Pages - Specify which pages 
the selected revision applies to. Only 

available when a new revision is being 
created.

Revision Information - 

• Specify the revision’s Label.

If you type a pound sign # in the Label
field, it will be replaced by the current

layout page number on the layout sheet. See
“Layout Page Numbering” on page 1260.

2

3
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• Specify the Date that the revision was 
made. The program populates this field 
with the current date automatically.

• Specify who the revision was Revised 
By. The program populates this field with 
your Designer Information by default. 

See “Designer Information” on page 
1127. 

• Specify a Description of the revision.
• Check Include in Revision Table to 

include this revision in a Layout Table for 
the selected page.

Layout Page and Revision Tables
Title, revision, and other information can be 
added to each layout page and used to create 
tables of contents and revision schedules. 

Layout Tables are similar to schedules and 
can be edited much the same way that 
schedules can. See “Editing Schedules” on 
page 1269. 

Layout Page Tables
Select Tools> Layout> Layout Page 
Table, then click on a layout page to 

place a Layout Page Table that that location. 
Layout Page Tables list all pages in the 
current file that have Layout Page 
Information specified, are set to be included 
in Layout Page Tables, and have data on 
them. See “Layout Page Information” on 
page 1261.

If you place a Layout Page Table on a Page 
Template, it will display on every page in the 
current layout that uses that template and will 
list all pages that have data and are set to be 
included in Layout Page Tables.

Revision Tables
Select Tools> Layout> Layout 
Revision Table, then click on a layout 

page to place a Layout Revision Table that 
that location. Layout Revision Tables list all 
revisions associated with the current page.

Unlike Layout Page Tables, Layout Revision 
Tables are page-specific. If you place a 
Layout Revision Table on a Page Template, it 
will display on every page that uses that 
template, but it will only list revisions 
associated with the current page. See 
“Layout Page Templates” on page 1261.

Printing Layout Files 
Printing layout files is similar to 
printing a view in a plan file. Select 

File> Print> Print to open the Print dialog. 
See “Print View Dialog” on page 1226. 

As in plan views, printing options for layouts 
are set in the Drawing Sheet Setup dialog. 
These options apply to all pages of the layout 

file. See “Drawing Sheet Setup Dialog” on 
page 1216.

If a page does not have any data on it, it will 
not print. Only pages with one or more views 
sent to them or Text, CAD, or Dimensions 
drawn on them are printed. 
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Pages specified as Page Templates do not 
print unless the template is the current page 
and you specifically choose the Current 
Page Print Range option. See      Print View 
Dialog.

Printing to Scale
A layout file’s drawing scale is specified in 
the Drawing Sheet Setup dialog. While you 
can specify any drawing scale that you wish, 
in nearly all circumstances, you will want the 
scale to be 1 in = 1 in or 1 mm = 1 mm for 
all layout files. 

The views sent to your layout pages have 
already been assigned a scale, and if you 
select a scale other than one to one for the 
layout, these views will be scaled a second 
time when printed. 

To see or change the current scale of a layout 
view, select the view and click the Rescale 
Layout View  edit button. See “Rescaling 
Views” on page 1249.

When a view is sent to layout at a scale other 
than that used by the original view, line 
weights may be affected. See “Line Weights 
and Scaling” on page 1224. 

Printing Services
If you plan to use a printing service, you may 
want to install a PDF writer. See “Printing to 
a PDF File” on page 1222. 

You can also print to file using the driver for 
the printer that the service will use. See 
“Printing to File” on page 1213.

Find out what paper size the print service 
uses and select it in the Drawing Sheet 
Setup dialog. See “Drawing Sheet Setup 
Dialog” on page 1216.

Check Plots
When a large drawing sheet size has been 
specified, you can print a check plot at a 
reduced scale so that it can be printed on a 
smaller printer. This allows you to make final 
checks before printing to the larger size. See 
“Check Plots” on page 1221.

Exporting Layout Files
Layout pages can be exported to .dxf/
.dwg files much like any other vector-

based view. 

The main difference is in the scale of the 
output, which is in scaled paper units rather 
than model units. If a 50” line in a plan 

would be scaled to 1” inch when printed, it is 
exported as a 1” line instead of its length 
before prior to scaling. See “Exporting 2D 
DXF/DWG Files” on page 1179.

Layout views will print at their specified
scales only when the drawing scale for

the layout file is 1 in = 1 in or 1 mm = 1 mm.
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Chapter 41:

Schedules and Object
Labels

A schedule is similar to a simple Text object 
with grid lines separating rows and columns, 
but are dynamically linked to objects in your 
plan and automatically update whenever an 
object is created, deleted, moved, or altered.

Schedules are available for doors, windows, 
cabinets, fixtures, framing objects, furniture, 
electrical items, plants, and rooms. Each 
schedule can contain information for one or 
all floors of your plan.

Schedules are highly customizable, so you 
should check each schedule that you create to 
be sure it presents the information that you 
want it to. 

A variety of objects in Chief Architect have 
labels that display information about them in 

floor plan and cross section/elevation views. 
Some of those objects also have schedules 
associated with them and may display 
schedule callout labels. 

Chapter Contents
•      Schedule Defaults
•      The Schedule Tools
•      Editing Schedules
•      Schedule Numbering
•      Columns and Objects to Include
•      Working with Multiple Schedules
•      Create Schedule from Room
•      Schedule Specification Dialog
•      Object Labels
•      Label Panel

Schedule Defaults
The initial settings for each type of 
schedule can be set in its Schedule 

Defaults dialog. Default Settings are 
accessed by selecting Edit> Default 



1268

Chief Architect X8 Reference Manual

Settings. Click the “+” next to Schedules to 
display the schedule sub-headings. Select a 
subheading and click the Edit button to open 
the Schedule Defaults dialog associated 
with your selection. See “Default Settings” 
on page 74. 

Schedule defaults can also be accessed by 

double-clicking the Schedule Tools  
parent button or any of the child tools.

When a schedule is created, its initial 
characteristics are determined by the settings 
in the Schedule Defaults dialog for its 
schedule type. Default settings for callout 
schedule labels are also set here.

Each Schedule Defaults dialog looks the 
same as its corresponding Schedule 
Specification dialog. See “Schedule 
Specification Dialog” on page 1273. 

The Schedule Tools
In floor plan view, a cross section/
elevation view, or a CAD Detail 

window, select Tools> Schedules to access 
the Schedule Tools. Select a Schedule Tool, 
then click anywhere in the view to place a 
schedule of the selected type at that location. 
You can continue clicking to place additional 
copies of the schedule. See “Click-to-Create” 
on page 167.

While you can place schedules in floor plan 
view, you may find it helpful to place them in 
one or more CAD Detail windows instead. 
Saving schedules in organized CAD Details 
allows you to send them to layout without 
including extra data or needing to resize the 
layout view box. See “CAD Details” on page 
1117. 

Plan Schedules
Select Tools> Schedules> Cabinet, 
then click to create a Cabinet 

Schedule. 

Select Tools> Schedules> Door, then 
click to create a Door Schedule. 

Select Tools> Schedules> Electrical, 
then click to create an Electrical 

Schedule. 

Select Tools> Schedules> Fixture, 
then click to create a Fixture 

Schedule. 

Select Tools> Schedules> Framing, 
then click to create a Framing 

Schedule. 

Select Tools> Schedules> Furniture, 
then click to create a Furniture 

Schedule. 

Select Tools> Schedules> Plant, then 
click to create a Plant Schedule. 

Select Tools> Schedules> Room 
Finish, then click to create Room 

Finish Schedule. 

Select Tools> Schedules> Window, 
then click to create a Window 

Schedule.

Room Schedules
Select a room and click the Create 
Schedule from Room edit button to 
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create a schedule of that type showing only 
contents of the room. See “Create Schedule 
from Room” on page 1273. 

Layout Schedules
In addition to the Schedule Tools available in 
plan files, there are two that can be used in 

layout. See “Layout Page and Revision 
Tables” on page 1264. 

Select Tools> Layout> Layout Page 
Schedule, then click to create a 

Layout Page Schedule. 

Select Tools> Layout> Layout 
Revision Schedule, then click to 

create a Layout Revision Schedule.

Editing Schedules
Schedules can be edited using the edit 
handles, the edit toolbar buttons, or the 
Schedule Specification dialog. 

Using the Edit Handles
A selected schedule has edit handles similar 
ot those of a CAD box. See “Editing Box-
Based Objects” on page 206. 

In addition, schedules have edit handles that 
let you control the order of the rows and 
columns, as well as column width: 

• Resize Column edit handles are located 
in the Title row, centered on the grid lines 
that divide the columns, and can be 
dragged left or right. If a column is 
resized sufficiently small, the text within 
will wrap to multiple rows. 

• Move Column edit handles are located in 
the Heading row, centered in each cell, 
and can be dragged left or right.  See 

“Adding Custom Columns” on page 
1272. 

• Move Row edit handles are located in the 
first column, centered in each cell, and 
can be dragged up or down.  See “Editing 
Schedule Order” on page 1270.

In the Specification Dialog
The appearance and other attributes of 
schedules can be modified in the 

Schedule Specification dialog. See 
“Schedule Specification Dialog” on page 
1273.

You can control how objects are listed by 
specifying which Columns to Include. For 
example, if you were to uncheck “Common 
Names” and “Scientific Names” in the Plant 
Schedule Specification dialog, and then 
check “Flower Color”, the resulting schedule 
would list all red flowers in one line item, 
regardless of their species. See “Columns 
and Objects to Include” on page 1271.

Move Row

Resize Column Move Column

The behavior of edit handles may
depend on the currently active Edit

Behavior. See “Edit Behaviors” on page 178.
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Using the Edit Tools
A selected schedule or schedules can be 
edited in a variety of ways using the buttons 
on the edit toolbar. See “The Edit Toolbar” 
on page 37.

Converting Schedules to Text
Click the Schedule to Text edit button 
to convert the selected schedule to a 

tabbed text object. You can then edit the 
schedule as text. 

When a schedule is converted to text, it no 
longer updates automatically. In addition, 
shaped labels displaying as specified in the 
schedule’s specification dialog will no longer 
be present. 

Schedule Numbering
By default, schedule numbering is dependent 
on the order in which objects are placed in 
the plan, as well as the floor they are on. 
• Any objects present in your plan before a 

schedule is created will be listed first in 
ascending alphanumeric order, according 
to their Label information.

• A new, unique objects placed in the plan 
after the schedule is created will be added 
to the bottom of the schedule in the order 
that they are placed, regardless of its 
Label information.

When an object is edited, its schedule 
number may or may not change: 
• If an object with a Quantity of 1 in the 

schedule is edited, its position in the 
schedule will not change.

• If a group of objects listed on the same 
row in a schedule are edited simultane-
ously, their position will not change.

• If an object listed on the same row in a 
schedule with other similar objects is 
edited so that it is no longer similar 

enough to share the same row, it will 
move to the bottom of the schedule. See 
“Columns and Quantity” on page 1271.

Editing Schedule Order
If a schedule’s order does not meet your 
needs, you can change it in either of two 
ways: 
• Using the schedule’s Move Row edit han-

dles. See “Using the Edit Handles” on 
page 1269.

• Using an object’s Move Up in Schedule 
and Move Down in Schedule edit tools. 

When an item in a schedule is moved to a 
different row, its schedule Number will 
change, as will that of any other item whose 
position is affected by that move. 

When a given object is included 
in only one schedule, its position 

in that schedule can be modified using the  
Move Up in Schedule and Move Down in 
Schedule edit tools.

You can copy the text from the Text
Specification dialog and paste it into

other applications.
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Renumber Schedule
To remove any gaps in numbering that 
might have been created when objects 

were edited or deleted, select the schedule 
and click the Renumber Schedule edit 
button. 

Columns and Objects to Include
Every schedule has a selection of Columns 
to Include and Objects to Include in its 
Schedule Defaults and Specification 
dialogs. The columns that are available 
depend on the type of schedule selected. See 
“General Panel” on page 1274. 

Information in the Description, Code, 
Manufacturer, and Comments columns is 
drawn from an object’s Components dialog.

Some objects have several components, but 
the schedule refers to only one. To find the 
correct row, look at the Description column. 
Often but not always, the first item in the ID 
column is the one the schedule refers to; for 
doors, this is D1, for windows, W1, for 
cabinets, C1, and so on.  See “Components 
Dialog” on page 1300. 

Most schedules also have a selection of 
Objects to Include, as well. For example, 
you can specify whether to include 
Plumbing, Appliances, and HVAC in a 
Fixture Schedule. Objects to include can be 
used to create a variety of special purpose 
schedules. See “Working with Multiple 
Schedules” on page 1272.

Columns and Quantity
It is important to remember that by default, 
the number of columns you choose to include 
in a schedule influences the number of 
separate line items that will be listed in the 
schedule. 

For example, if you have three 30” wide 
doors, and do not include the Size and 
Description columns, the three doors will be 
listed in the same line item - even if one is a 
hinged door, one a slider and one a pocket 
door. 

If you prefer, you can uncheck Group 
Similar Objects in the Schedule 
Specification dialog to place every object in 
its own row, regardless of any shared 
attributes. See “General Panel” on page 
1274. 

Column Totals
If a Door, Window, or Room Finish Schedule 
includes an Area column, an additional 
“Totals” row will display at the bottom of the 
schedule for total area calculations. Room 
Finish Schedules will also include a “Totals” 
row if multiple rooms included in the 
schedule have identical objects in them.

Object Previews
Aside from those for Framing, Rooms, and 
Layouts, schedules have a selection of 
Columns that display object preview images. 

With the exception of plant images, 3D 
object previews are drawn using plot lines. 
Each object preview inherits its line color, 
weight, and style from the object’s layer 
settings in the “Camera View Set” layer set.  
See “Layer Sets” on page 146. 
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The 2D Symbol preview uses the settings for 
the layer set that is currently active in floor 
plan view. The 2D Symbol column is not 
available for Doors, Windows, or Cabinets.

Adding Custom Columns
With the exception of Room Finish 
Schedules, schedules can be customized by 
adding user-defined columns. 

For example, you could create a column for 
locksets to be included in door schedules. 
The information in this column can also be 
included in Materials Lists. See “Materials 
Lists” on page 1283. 

In this example, a custom column for lock 
sets is created for a door schedule; however, 
the same steps apply to any object that can be 
included in a schedule with the exception of 
rooms.

To create a custom schedule column

1. Select a door in your plan and click the 

Components  edit button.
2. In lower left corner of the Components 

dialog, click the Edit Sub Categories 
button. See “Components Dialog” on 
page 1300. 

3. In the Preferences dialog, select the 
“Doors” category and create a new 
“LKS” Materials List subcategory. See 
“Categories Panel” on page 122. 

4. Click OK to return to the Components 
dialog, then click the Add button to add 
a new accessory to the list. 

5. Select the new accessory and click in the 
Sub Category column. Choose the new 
subcategory from the drop-down list, 
then replace “accessory” with a brief 
description in the Description column. 
Click OK.

6. Next, include the new subcategory in the 
Door Defaults dialog. See “Schedule 
Defaults” on page 1267. 

7. Create a schedule and note that the cus-
tom column is present and includes the 
Components information for the door 
that you edited. 

If a door schedule is already present, the new 
column is available but will not display. You 
can include this new column in the 
schedule’s specification dialog. See “General 
Panel” on page 1274.

If you would like to use your door with 
custom Components information in other 
plans, you can add it to the library. See 
“Adding Library Content” on page 829. 

Working with Multiple Schedules
You can create multiple versions of any type 
of schedule for a variety of purposes. For 
example:
• Multiple Fixture Schedules can be set up 

for use as Plumbing, Appliance or HVAC 
schedules.

• Separate Electrical Schedules can be cre-
ated for light fixtures and other electrical 
items. 

• Separate Cabinet Schedules can be set up 
for each floor of a plan, or even for indi-
vidual rooms.
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• Special Door or Window Schedules can 
be prepared for Energy Ratings, Fire 
Doors or other information.

If you intend to use schedule callout labels, it 
is best to avoid including a given object in 
more than one schedule. If you choose to do 
so, the object will display a separate callout 
label for each schedule it is included in. 

If you create multiple schedules of the same 
type, bear in mind that it is possible for 
different objects in those schedules to be 
assigned the same callout number. To avoid 
this, consider specifying different callout 
prefixes and/or callout shapes. 

For more information about customizing 
schedules, refer to the Chief Architect 
Knowledge Base at chiefarchitect.com.

Create Schedule from Room
Select a room and click the Create 
Schedule from Room edit button to 

create a schedule of that type showing only 
contents of the room. 

Select a Schedule Type, then click OK and 
click in the drawing area to create a schedule 
of the selected type that lists objects located 
in the room that you selected.

You can also turn any schedule into a Room 
Schedule using the Include Objects from 
Room setting in the Schedule Specification 
dialog. See “General Panel” on page 1274.

Schedule Specification Dialog
Schedules and the object labels 
associated with them can be edited in 

the Schedule Specification dialog. To open 
this dialog, either select a schedule and click 
the Open Object edit button or double-click 

the schedule using the Select Objects  
tool.

The Schedule Specification dialog is 
similar to the specification dialogs for layout 
tables. See “Layout Page and Revision 
Tables” on page 1264.

The options in these dialogs are also similar 
to those found in their corresponding 
Schedule Defaults dialogs. 

http://www.chiefarchitect.com/support/database.html
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General Panel

Specify a Main Title for the selected 
schedule. 

• Check Display to include the Main Title 
at the top of the schedule.

Include Options - 

• To create a schedule of objects on a sin-
gle floor, uncheck Include Objects from 
All Floors and then specify the floor. 
When this box is checked, objects from 

all floors are included. Not available in 
the Layout Table Specification dialog. 

• If Include Objects on All Floors is 
unchecked in the Schedule Defaults dia-
log, each schedule will include objects on 
the floor that it is created on by default. 

• When Include Objects from All Floors is 
unchecked, you can further limit the 
schedule to an individual room on the 
specified floor. Select that room from the 
Include Objects from Room drop-down 

1

2
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list. See “Create Schedule from Room” 
on page 1273.

• When a Framing Schedule is placed in a 
Wall Detail or Truss Detail, the Only 
Include Objects from this Detail check-
box is available. Uncheck this to include 
objects from throughout the plan. When 
checked, only objects present in the cur-
rent view are listed.

• Uncheck Group Similar Objects to list 
all objects in their own row, even when 
they share all attributes. When this is 
unchecked, objects that share the same 
attributes are counted in a single row. See 
“Columns and Quantity” on page 1271.

• If the selected schedule is a layout table, 
specify the Minimum Rows that it dis-
plays, regardless of its actual content. 

Display Options - 

• Uncheck Display Column Headings to 
hide the selected schedule’s Heading row. 
When this is checked, each column has a 
heading at the top. 

• Uncheck Display Totals Row to suppress 
the bottom row stating the total area for 
all objects in the selected schedule. Only 
available when one or more “Area” col-
umns are included in the selected Door, 
Window, or Room Schedule. 

The Object Preview Options affect the 
appearance of previews in the 2D 

Symbol, 3D Elevation, and 3D Perspective 
Columns, when included in the schedule. See 
“Object Previews” on page 1271.
• Check Show Color to draw 3D Elevation 

and 3D Perspective object previews using 
colored lines. When this is unchecked, 

lines are black and 3D plant previews are 
shown in grayscale.

• Check Scale Images to display object 
previews at the same relative scale. When 
unchecked, each preview fills its cell to 
the extent possible. 

• Check Show Opening Indicators to 
show opening indicator symbols in 3D 
Elevation previews for doors, windows, 
and cabinets. 

Specify which Columns are included in 
the selected schedule. The columns that 

are available will vary depending on the type 
of schedule selected. See “Columns and 
Objects to Include” on page 1271.
• An alphabetical list of all Available Col-

umns for the selected schedule type dis-
plays on the left. 

• Select one or more names in the list, then 
click the Add button to add them to the 
Columns to Include list on the right. See 
“Shift and Ctrl Select” on page 186.

• You can also double-click on an item in 
the list to add it to the Columns to Include 
list on the right. 

• A list of the Columns to Include in the 
selected schedule displays on the right. 
The top-to bottom order in this list corre-
sponds to the columns’ left-to-right order 
in the schedule. At least one column must 
be included to create a schedule.

• Select or double-click on an item in the 
list and click the Rename button to spec-
ify a new name.

• Click the Reset button to restore the 
default names for all Columns to Include 
in the current schedule.

3

4

5
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• Select one or more items in the list, then 
click the Remove button to remove those 
items from the list. 

• Select one item in the list and click the 
Move Up button to adjust its position 
upward in the list.

• Select one item in the list and click the 
Move Down button to adjust its position 
downward in the list.

Objects to Include - Check the box 
beside each type of object you want to 

include in the selected schedule. For a 
description of these options, see “Columns 
and Objects to Include” on page 1271.

Attributes Panel

Specify the appearance of the selected 
schedule’s Box/Grid. 

• Check Display Border to display lines 
around the outside of the schedule.

• Check Display Grid Lines to display 
lines around the rows and columns of 
schedule, forming boxes around each 
item, or cell.

Specify the Alignment of the selected 
schedule’s text within its columns by 

choosing an option from the drop-down list. 

Define the Position of the selected 
schedule. Not available in the 

Schedule Defaults dialogs. 
• Specify the X and Y Positions of the 

schedule’s center point.
• Specify the schedule’s Angle.

Line Style Panel
The LINE STYLE panel lis found in the 
specification dialogs for many different 

You can create multiple unique sched-
ules using the Columns to Include and

Objects to Include as filters. See “Working
with Multiple Schedules” on page 1272.

6

1

2

3
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objects. For more information, see “Line 
Style Panel” on page 1085.

Fill Style Panel
For information about the settings on this 
panel, see “Fill Style Panel” on page 1099. 

Text Style Panel
The settings on this panel control the 
appearance of the selected schedule’s text. 
For more information, see “Text Style Panel” 
on page 1063. 

Label Panel
The LABEL panel of the Plant Schedule 
Specification dialog controls the type, size 
and appearance of the labels that display in 
floor plan view. 

This panel is not available in the Room 
Finish Schedule Specification dialog. 

General - Check Show Labels to 
display object labels in floor plan view. 

This also turns on the appropriate layer for 
the objects’ labels in the Layer Display 

Options dialog. See “Layer Display Options 
Dialog” on page 149. 

You can suppress the label for an individual 
door or window by checking Suppress 

1
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Label in the specification dialog for that 
object. See “Label Panel” on page 1280. 

Additional Label Text options are 
available here.

• Label Prefix - Specify the leading char-
acters used in callout labels or when 
Include Schedule # is checked.

The Height/Width Display options control 
the format of Automatic Labels as well as the 
Labels and Size columns of the schedule, and 
are only available for Door and Window 
Schedules. 
• Select Width/Height for automatic 

labels that use a numeric format in which 
the width in inches (mm) is followed by 
the height. 

• Select Height/Width for automatic 
labels that use a numeric format in which 
the height in inches (mm) is followed by 
the width.

• Select Width Only for automatic labels 
that use a numeric format in which only 
the width in inches (mm) is indicated.

The Additional Text options affect the 
format of Automatic Labels only. 
• Check Include Schedule Number to 

include the object’s schedule number at 
the beginning of its Automatic Label text 
and in the Label and Size columns of the 
schedule. 

• In a window schedule, check Include 
Type to include the abbreviation for each 
window’s type in its Automatic Label. 
For example, 3050DH describes a 3050 
double hung window. Also affects the 
Label column of the schedule.

• In a door schedule, check Include Type 
to include the hinge side and whether 
each door is interior or exterior in the 
Size column of the Door Schedule. Also 
affects the Label column of the schedule, 
but does not affect door labels.

• In an electrical schedule, check Include 
Type to include abbreviations indicating 
how light are used at the end of Auto-
matic Labels. See “Displaying Lights” on 
page 938. 

When Use Callout For Label is 
checked, the callout shape and size can 

be specified below. When this option is 
unchecked, Automatic or user specified 
labels are used. See “Label Panel” on page 
1280.

• Select a Callout Shape. There are ten 
shapes to choose from. 

When callout labels are used, the schedule 
numbers are included in the labels. Like 
other object labels, callout labels use the Text 

2

An alternative to displaying Type infor-
mation in the Label and/or Size col-

umns is to include the Type column in a
schedule. See “Columns and Objects to
Include” on page 1271.

Include Type

Include Type and Include Schedule #

3
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Style assigned to the layer they are on. See 
“Text Styles” on page 1061. 

Specify the label Callout Size:

• Select Calculate from Text for callout 
labels that are sized to accommodate the 
text within them. 

• Select Size and then type the radius in 
inches (mm). This radius will be used 
regardless of the size of the label text. 

Object Labels
Object labels can display in floor plan and 
cross section/elevation views for a variety of 
different object types using one of several 
formats: 
• Automatic Labels provide basic informa-

tion about the object, such as its type, 
size, or name.

• You can create a custom label for an 
object in its specification dialog using 
text and/or a Text Macro. See “Label 
Panel” on page 1280.

• Objects associated with a schedule can 
display a shaped callout label with each 
object’s schedule number. See “Schedule 
Specification Dialog” on page 1273. 

The Automatic and custom labels for a 
variety of objects have their own edit handles 
that display when their object is selected, and 
can be both moved and rotated. Schedule 
callout labels can be moved but not rotated. 
See “Edit Handles” on page 34. 

Automatic Labels
Most objects that can display labels have an 
Automatic Label created by the program that 
states basic information about it. 
• Native objects such as doors, windows, 

and cabinets dynamically derive their 
automatic label from their size and type. 

See “Native Objects vs Symbols” on 
page 841. 

• Symbol objects such as fixtures and fur-
nishings derive their automatic label from 
the Symbol Name specified in the 
Symbol Specification dialog. See “3D 
Panel” on page 1196.

When Automatic Labels is selected in the 
object’s specification dialog, this is usually 
the label that will be used; however:
• If a user-defined label is specified in the 

object’s defaults dialog, that label will be 
used instead of the Automatic Label.

• If the object is included in a schedule and 
callout labels are specified in that sched-
ule, a callout label will be used. 

• Fixtures and appliances inserted into cab-
inets do not have labels of their own 
unless they are associated with a schedule 
set to use shaped callout labels.

Displaying Labels
The display of object labels in floor 
plan and cross section/elevation views 

can be controlled by layer in the Layer 
Display Options dialog. Label layer names 
begin with the object type, followed by the 
word Label: for example, cabinet labels are 
located on the “Cabinets, Labels” layer. See 
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“Layer Display Options Dialog” on page 
149.

You can choose to suppress the label for an 
individual object on the LABEL panel of its 
specification dialog. 

You can also turn the display of labels for a 
particular object type on or off in the 
Schedule Specification dialog for that 
object type. See “Label Panel” on page 1277.

Object labels use the Text Style assigned to 
each label’s layer. For example, cabinet 

labels use the “Cabinets, Labels” layer’s Text 
Style. See “Text Styles” on page 1061. 

The minimum on screen display size of 
labels can be specified in the Preferences 
dialog. See “Appearance Panel” on page 92.

With the exception of those for rooms, roofs, 
and cameras, labels can also be included in 
the Materials List, Master List and in the 
Components dialog. Items in the Labels 
column of the Materials List are editable; 
however, any changes will not be applied to 
the objects’ labels. See “Materials List 
Columns” on page 1293. 

Label Panel
The LABEL panel is found in the 
specification and defaults dialogs for a 
variety of different objects. 

Note: If you choose a callout shape in the
Schedule Specification dialog, the settings
here are overridden and the schedule label is
used instead. See “Label Panel” on page
1277.
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Most objects have a Suppress Label 
option. Check this box to prevent the 

selected object’s label from displaying in 
floor plan view. 

Bay, Box and Bow Windows and Mulled 
Window units have several settings for 
controlling Multiple Component labels. See 
“Window Labels” on page 403. 
• Select Suppress All Labels to display no 

label in floor plan view. Individual com-
ponents are counted in schedules and in 
the Materials List. 

• Select Show Component Labels to pro-
duce labels for each component in floor 
plan view. Individual components are 
counted in schedules and in the Materials 
List.

• Select Show Single Label for Entire 
Unit to produce one label for the unit and 
suppress component labels. When this 
option is selected, the settings that follow 
on the LABEL panel become enabled.

These settings also affect how Bay, Box and 
Bow Windows and Mulled Window units are 
counted in schedules and the Materials List. 
See “Window Labels” on page 403 and 
“Displaying Mulled Units” on page 399.

The Label Options control what 
information is contained in the label. 

Not available for cameras. See “Displaying 
3D Views” on page 907. 
• Select Automatic Labels to use the 

default label for the selected object. See 
“Automatic Labels” on page 1279. 

1

2
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• Select Specify Label to replace the 
selected object’s Automatic Label with 
whatever you type in the text field below. 
Press the Enter key while the cursor is in 
the text field to begin a new line. 

When Specify Label is chosen, the 
selected object’s Automatic Label ini-
tially populates the text field.

• Click the Insert arrow to insert a Global, 
User Defined or Object Specific Text 
Macro into the custom label. See “Text 
Macros” on page 1064.

Specify the Plan View Position and 
Orientation, relative to the object it 

describes, in floor plan view or in the 
currently active cross section/elevation view. 
The defaults for these settings only affect 
floor plan view - in cross section/elevation 
views, labels are always initially placed at 0, 
0, 0°. See “Default Settings” on page 74. 

• Specify the X Offset value, moves the 
label side to side relative to the midpoint 
of the object’s front face.

• Specify the Y Offset value, which moves 
the label forward or backward relative to 
the object’s front face.

• Specify the Angle, which rotates the 
label either relative to the angle of its 
object’s front face or to an absolute angle.

• Select Relative Angle to measure the 
label’s Angle relative to its object’s front 
face.

• Select Absolute Angle to measure the 
label’s Angle relative to an imaginary 
horizontal line drawn in the positive X 
direction from the origin. See “3D Draft-
ing” on page 31.

Regardless of which way the selected object 
is facing, in floor plan view the X Offset will 
move the label parallel with the object’s front 
face. The Y Offset value will move the label 
perpendicular to the object’s front.  

In cross section/elevation views, the Offset 
X will move the label side to side and the 
Offset Y will move it up or down.  

The Camera View Display settings are 
only active if you open an object’s 

specification dialog in a cross section/
elevation view, and only affect the display of 
the selected object’s label in the current view. 
Not available for selected  cameras. 
• Select Automatic to display the object’s 

label when the surface at its center point 
is visible in the view. 

• Select Show in this View to display the 
object’s label regardless of whether its 
center point is visible. 

• Select Hide in this View to suppress the 
object’s label regardless of whether its 
center point is visible. 

In most specification dialogs, a preview 
of the selected object displays here. In 

the preview pane, labels can be seen in Plan 
View only. See “Dialog Preview Panes” on 
page 41. 

Note: When accessed from a Wall Elevation
view, Wall Detail Position and Orientation set-
tings will be available here instead.

3 4
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Chapter 42:

Materials Lists

Chief Architect can calculate a Materials List 
in three ways: for All Floors, From Area, or 
for Room. In addition, a polyline or multiple 
polylines can be used to define areas in a 
plan a Materials List can be generated from.

Materials Lists can be created, edited, and 
printed directly from the program. They can 
also be exported as text, .xml, or .html files 
for use in other programs.

Chapter Contents
•      The Materials List Tools
•      Creating an Accurate Materials List
•      Structural Member Reporting
•      Organizing Materials Lists
•      Materials List Display Options Dialog
•      Materials List Columns
•      Editing Materials Lists
•      Materials List Polylines
•      Saving and Managing Materials Lists
•      Printing and Exporting the Materials List
•      Conditioned Area Totals
•      The Master List
•      Components Dialog

The Materials List is based on certain 
assumptions that may not match your 

building style. Chief Architect makes no repre-
sentation as to the accuracy or reliability of the 
Materials List generated by Chief Architect. 
Always compare the Materials List with a man-
ual take-off before providing a quote or ordering 
materials for a job. 
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The Materials List Tools
Select Tools> Materials List to 
access the Materials List tools.

A Materials List is like a snapshot of the 
current plan at the time that the list is made. 
Any changes made to the model after a 
Materials List is generated are not included 
in that list. Create a new Materials List if you 
would like it to include these changes. 

It is not necessary to wait until the plan is 
complete to generate a Materials List. In fact, 
you can create a series of Materials Lists 
reflecting costs at various stages of a project.

When you close a Materials List window, the 
program will ask if you want to save the 
Materials List. Type a name and click Yes to 
save the list or click No to close the list 
without saving it. See “Saving and Managing 
Materials Lists” on page 1295.

Calculate from All Floors
Select Tools> Materials List> 
Calculate Materials for All Floors to 

generate a Materials List for the entire 
model.

Materials lists calculated from all floors can 
be lengthy, and only a portion of the list may 
display on your screen at one time. Use the 
scroll bars to scroll through the complete list. 
Move the pointer to cells in the list and click 
to make changes. 

Calculate From Area
In floor plan view only, select Tools> 
Materials List> Calculate From 

Area to produce a Materials List for the 
portion of a plan on a single floor that is 
included within a temporary rectangular 
Materials List Polyline. 

Calculate for Room
To create the Materials List for a 
room, select the room and then select 

Tools> Materials List> Calculate Materi-
als for Room. 

Calculate Materials for Room  is also 
available on a selected room’s edit toolbar. 
See “Editing Rooms” on page 333. 

A Materials List calculated from a room is 
created for only the contents of that room: 
wall materials are not included.

Materials List Polyline
You can also produce a Materials List 
for a defined area of a plan in floor 

plan viw using a Materials List Polyline. 
Materials List Polylines are advantageous 
because they can be edited to any shape, 
saved, and used as many times as needed. 
There are also several ways to create them. 
See “Materials List Polylines” on page 1294. 

Master List
Select Tools> Materials List> Mas-
ter List to open the Master List, a list 

of previously used materials and any added 

For comparison, generate Materials Lists 
with and without a proposed plan modifi-

cation.
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information such as price or manufacturer. 
See “The Master List” on page 1298.

Materials List Management
Select Tools> Materials List> 
Materials List Management to open 

a list of saved Materials Lists associated with 
the current plan. See “Saving and Managing 
Materials Lists” on page 1295. 

Materials List Preferences
A number of settings that affect the 
appearance and contents of Materials 

Lists are found in the Preferences dialog. 
See “Preferences Dialog” on page 90. 

• The MATERIALS LIST panel lets you spec-
ify which Categories are initially included 
in new Materials Lists.

• The REPORT STYLE panel lets you specify 
which columns are initially included in 
new Materials Lists, as well as modify the 
appearance of all Materials Lists.

• The MASTER LIST panel lets you specify 
the current Master List file and the col-
umns used in it. 

• The CATEGORIES panel lets you create 
Sub-Categories for all of the main Cate-
gories.

Creating an Accurate Materials List
In order to take full advantage of Chief 
Architect’s Materials List capabilities, there 
are several things to keep in mind. 
• The accuracy of your Materials List is 

directly related to the accuracy of your 
model. Floor and ceiling heights, wall 
lengths, and structural settings all directly 
affect Materials List calculations.

• It takes more than just making your draw-
ing look right to generate an accurate 
Materials List. If, for example, you use 
CAD lines to draw an item on a floor 
plan, that item will not be included in the 
Materials List. A better way would be to 
use a symbol or structural element. See 
“Architectural vs CAD Objects” on page 
160.

• If you use custom materials, make sure 
their material definitions are set up cor-
rectly. See “Creating Materials” on page 
857.

• Bear in mind that using generic objects 
like geometric shapes from the library to 
represent objects that aren’t available in 
Chief Architect can result in items being 
calculated in the Materials List in a man-
ner that you might not expect.

Framing in the Materials List
You can specify whether framing materials 
are calculated by lineal foot, as a cut list, or 
as a buy list in the Structural Member 
Reporting dialog.

For more information about how framing 
appears in the Materials List, see “Framing 
and the Materials List” on page 609.
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Structural Member Reporting
The Structural Member Reporting 
dialog allows you to specify the 

method used to calculate framing members 
in the Materials List. There are four options 
to choose from: 
• Lineal Length calculates the framing 

materials of the different structural com-
ponents of the plan in linear feet. 

• Cut List calculates the framing materials 
of the different structural components of 
the plan by counting the individual pieces 
present in the model.

• Buy List calculates the framing materials 
of the different structural components of 
the plan by counting individual pieces and 
matching them to a list of board sizes that 
you specify.

• Mixed Reporting calculates framing 
materials using a combination of lineal 
lengths and piece counts and is recom-

mended for saved Materials Lists in leg-
acy plans. 

When a Materials List is active, you can use 
the Lumber Reporting Method Control 
drop-down list in the toolbar to choose which 
method the Materials List uses.

Structural Member Reporting supports 
multiple saved defaults, which means that 
you can set up different Buy Lists for 
different purposes. See “Multiple Saved 
Defaults” on page 77.

When a Materials List is created, the 
Currently Active Default specified in the 
Saved Structural Member Reporting 
Defaults dialog will be used. Note that while 
an existing Materials List’s Reporting 
Method can be changed, the defaults used to 
create a Buy List cannot. To use a different 
Buy List, change your Active Default and 
generate a new Materials List. 

Structural Member Reporting Dialog
To open the Structural Member 
Reporting dialog, select Edit> 

Default Settings , then select “Structural 
Member Reporting” from the tree list and 
click the Edit button. See “Default Settings 
vs Preferences” on page 74. 

In the Saved Structural Member Reporting 
Defaults dialog, which opens next, select a 
default in the list and click the Edit button.

You can also open this dialog by selecting 
Tools> Materials List> Structural Member 
Reporting or by clicking the Structural 
Member Reporting  button, which can 
be added to your toolbars. See “To add a 
button to a toolbar” on page 132. 

The name of the Saved Default being edited 
is stated in the dialog box title bar. 
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Choose a Materials List Report 
Method. The selected method will 

affect subsequently created Materials Lists, 
but not any that may already exist. 
• Select Mixed Reporting to calculate 

framing materials using a combination of 
lineal lengths and piece counts. 

• Select Total Lineal Length to calculate 
framing materials in linear feet. 

• Select Cut List to calculate framing 
materials by counting the individual 
pieces present in the model.

• Select Buy List to calculate framing 
materials by counting individual pieces 

and matching them to items in the list of 
Buy List Board Sizes, below. 

• Check Consolidate Unhandled Boards 
to handle short board segments by com-
bining them so they can be cut from 
lengths found in the Buy List Board 
Sizes list. 

• Select the Length Units that you want to 
use from the drop-down list. The selected 
unit(s) are used in the Structural Member 
Reporting dialog as well as in the Materi-
als List when either Cut List or Buy List 
is the selected method of reporting. Not 
available when Mixed Reporting or 
Total Lineal Length is selected. 

1
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The Buy List Board Sizes table is only 
active when Buy List is selected above. 

An effective Buy List include all types of 
framing materials that you typically use, as 
well as each of the different lengths that you 
expect to purchase. 
• Click on a line item to select it.
• Click the Edit button to open the Board 

Specification dialog for the selected line 
item in the table. 

• You can also double-click on a line item 
to open its Board Specification dialog.

• Click the New button to open the Board 
Specification dialog for a new line item 
in the table. 

• Click the Delete button to remove the 
selected line item from the table. 

Items in the Boards to buy table are listed in 
order of priority. If an item in a Materials 
List could be cut out of more than one item in 
this table, the program will select the item 

with the highest priority. Specify the Priority 
of the selected line item in the table.
• Click the Increase Priority button to 

move the selected item one line up in the 
table. Only available when a line item is 
selected and it is not first in the list.

• Click the Decrease Priority button to 
move the selected item one line down in 
the table. Only available when a line item 
is selected and it is not last in the list.

Buy List tables can be saved as .json files 
and shared between plans. 
• Click the Import button to import a saved 

Buy List table into the currently active 
Structural Member Reporting saved 
default. 

• Click the Export button to save the Buy 
List table as a .json file which can be 
imported into other plans. 

Specify the Kerf Width, which is the 
width of the material lost to the saw 

blade when a framing member is cut. 

Board Specification Dialog
Click either the New or the Edit button in the 
Structural Member Reporting dialog to 
open the Board Specification dialog, where 
you can define a line item for the Boards to 
buy table. You also double-click on a line 
item in the table to modify it. 

• Specify the Actual Thickness - as 
opposed to the nominal thickness - of the 
selected item in the Buy List table. 

• Specify the Actual Depth - as opposed to 
the nominal depth - of the selected item in 
the Buy List table. 

• Specify the Length of the selected item in 
the Buy List table. 

• Select the Type of structural member 
from the drop-down list. See “Framing 
Member Types” on page 610.

• Check Treated if the selected item is a 
treated lumber product. 

2

3
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• Click OK to close the dialog and add the 
information specified here to a line item 
in the Buy List table. 

Organizing Materials Lists
There are two basic ways to control what 
items are calculated in the Materials List:
• By specifying which layers in the plan are 

included in the list.
• By specifying which categories and sub-

categories are used. 

In addition, you can control how much 
information about each item is included by 
specifying which columns to display. 

There are some parts of a model that cannot 
be excluded from the Materials List. Floor 
and ceiling platforms are prime examples. If 
you need to generate a Materials List for only 
part of a plan, such as an addition, consider 
making a copy of the plan file. In the copy, 
delete the as-built portion of the plan and 
then generate a Materials List.

Categories

Columns
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Materials Lists and Layers
You can control which objects are included 
in the Materials List by layer in the Layer 
Display Options dialog. The inclusion of 
objects in the Materials List is controlled 
using the Mat column: an “M” in this 
column indicates that objects in a layer are 
included in the Materials List. Click in the 
cell to add or remove the “M.”  See “Layer 
Display Options Dialog” on page 149.

Categories
The line items in the Materials and Master 
Lists are organized into a set of predefined 
categories, such as Electrical and Framing, 
which display in the ID column.

You can specify which category each item 
belongs to in the Materials List and Master 
List. In addition, many objects can be 
assigned to a category prior to generating a 
Materials List in the Components dialog. 
See “Components Dialog” on page 1300.

Unlike other categories that calculate 
materials or objects, the General category 
lists information about the building’s thermal 
envelope. See “Conditioned Area Totals” on 
page 1297. 

To specify a line item’s category

1. Create a Materials List, open the Master 
List, or open the Components dialog 
for a particular object.

2. Click in the cell in the ID column for a 
line item.

3. Select the desired category from the 
drop-down list that becomes available.

The categories that are available cannot be 
altered; however, you can specify which 
categories are included in the Materials List 
in either of two ways:
• Globally, in the Preferences dialog. See 

“Materials List Panel” on page 119. 
• For individual lists in the Materials List 

Display Options dialog. See “Materials 
List Display Options Dialog” on page 
1291.

Subcategories
You can create any number of subcategories 
for each Materials List category in the 
Preferences dialog. See “Categories Panel” 
on page 122. 

Items can be assigned to a subcategory in the 
Materials List and, for many items, in their 
object’s Components dialog in the same 
manner that they can be assigned to a 
category. 

Subcategories can be useful when creating 
schedules. See “Adding Custom Columns” 
on page 1272.

Materials List Columns
There are two ways to specify which 
columns are included in the Materials List as 
well as the order in which they display:
• Globally, in the Preferences dialog. See 

“Report Style Panel” on page 120. 
• For individual lists in the Materials List 

Display Options dialog.
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Materials List Display Options Dialog
When a Materials List or the Master 
List is open, select Tools> Display 

Options to open the Materials List Display 
Options dialog for the current list.

The Master List Display Options dialog is 
similar to this dialog, but only the COLUMNS 
panel is available. See “The Master List” on 
page 1298.

Categories Panel

The Categories  listed here appear in the ID 
column of the Materials List in the order they 
are presented here. 
• Check the box beside the name of each 

category that you want to display in the 
currently active Materials List. 

• Click the Select All button to display all 
categories in the active Materials List.

• Click the Clear All button to suppress the 
display of all categories in the active 
Materials List.

• Multiple rows can also be selected 
together using Shift and Ctrl keys. See 
“Shift and Ctrl Select” on page 186. 

Note: The information in a suppressed category 
is still part of the Materials List. If the Materials 
List is exported, suppressed categories are 
exported, as well.
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Columns Panel

• Check the box beside each column you 
want to include in the Materials List. To 
suppress a column’s display, remove the 
checkmark next to its name. Columns 
appear in the Materials List in the order 
that they display in this list. 

• Move Up - Click on a column name, then 
click this button to move that item up one 
place in the list. 

• Move Down - Click this button to move 
the selected column down in the list.

Options Panel
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• Check Restrict to Floor to limit the cur-
rent Materials List to objects on a single 
floor, then select that floor number from 
the drop-down list. When unchecked, the 
Materials List includes all floors. 

• If you plan to buy materials from multiple 
suppliers, you can create a Materials List 
for each. Check Restrict to Supplier, 

then choose a supplier from the drop-
down list. The resulting materials list will 
include only materials to be purchased 
from that supplier.

Suppliers can be added to this list in the 
Components dialog for various objects. See 
“Components Dialog” on page 1300.

Materials List Columns
The columns in the Materials List, the 
Components dialog, and the Master List are 
very similar, but not all columns appear in all 
places. 

A table of all of thes e columns and their 
capabilities is available in the program’s 
Help. See “Getting Help” on page 49.

Editing Materials Lists
Materials lists can be edited in a variety of 
ways. You can adjust the width of a column 
by clicking and dragging the bar on the right 
side of the column name. 

Adding Information
You can enter information in the Price, 
Supplier, Code, Comment and Manufacturer 
columns for each item. 

Adding price or other information for any 
item is straightforward. Simply click in the 
cell and type the desired information. When 
the information is correct, you can add it to 
the Master List. See “Adding to the Master 
List” on page 1298. 

You can switch between several existing 
suppliers or manufacturers for a given item 
by double-clicking on the right side of the 
cell in an appropriate column. A drop-down 
arrow displays to the left of the cell. Click it 

to view a list of suppliers or manufacturers 
for that item and select one.

When a Materials List is calculated, you can 
have the program search the Master List for 
Price, Supplier, and Code information for 
each item by selecting Tools> Update From 
Master. The information used is marked as 
“Default” in the Master List. See “Materials 
List Columns” on page 1293.

Changing Information
Although the information in some columns 
cannot be saved to the Master List, you can 
change the information in any column in an 
individual Materials List. As with added 
information, click in a cell to select the 
existing text, then type in the desired text. 

To move an item in a Materials List to a new 
category, select the cell in the ID column and 
choose a new category from the drop-down 
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list that becomes available. You can also 
select a subcategory by clicking in the cell in 
the Sub Category column. See “Categories” 
on page 1290.

Total Cost
Total Cost is calculated using the Count, 
Unit, Price, %Markup, Labor and Equipment 
columns to calculate the cost. The formula 
used is: 

(Count + Extra) * Price * (1 + (%    
Markup/100)) + ((Count + Extra) * Labor) 
+ ((Count + Extra) * Equipment)

If a column does not appear, 0 is used for the 
value of that column with the exception of 
Count and Price, which are always used in 
the calculation even if they are not shown.

Copying Information
Portions of a Materials List can be copied 

and then pasted into a Text  object or into 
a word processing program or spreadsheet 
program using the standard Windows Copy 
(Ctrl + C), Cut (Ctrl + X), and Paste 
(Ctrl + V) commands. See “Copying and 
Pasting Text” on page 1049.

Changing the Font
The font used for Materials Lists, the Master 
List and the Components dialog can be 
specified in the Preferences dialog. See 
“Font Panel” on page 95.

The size of this font can also be specified in 
the Preferences dialog. See “Report Style 
Panel” on page 120.

Materials List Polylines
A Materials List Polyline lets you 
create a Materials List that only 

includes objects within its area on the current 
floor. 

To create a Materials List Polyline

1. In floor plan view, select Tools> Mate-
rials List> Materials List Polyline and 
draw a rectangular polyline. 

2. Select the Materials List Polyline and 
edit its position and shape as needed. 
Materials List Polylines can be edited 
like other closed polylines. See “Editing 
Closed-Polyline Based Objects” on page 
201.

3. With the Materials List Polyline 
selected, click the Calculate Materials 

List  edit button. A Materials List is 
created for objects within the polyline 
on the current floor. 

•  Objects such as cabinets, windows, 
doors, and studs are included in the 
Materials List only if their center point 
is within the Materials List Polyline.

•  Larger objects such as walls, floor and 
ceiling platforms, and joists can be par-
tially selected by a Materials List 
Polyline, so that only portions of them 
are included in the Materials List. 

•  A few objects, such as joists, are 
counted as pieces in a full Materials 
List but must be counted in linear 
lengths when partially selected by a 
Materials List Polyline. For example, if 
a 16-foot joist crosses a 4 foot square 
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Materials List Polyline, the Materials 
List will count 4 linear feet of joist 
material. This can be useful for addi-
tions and/or remodels. 

You can also convert a closed CAD polyline 
into a Materials List Polyline using the 

Convert Polyline  edit tool. See “Convert 
Polyline” on page 239.

Categories
The categories included in a Materials List 
created using a Materials List Polyline can be 
specified prior to the generation of the list in 

the Materials List Polyline Specification 
dialog. 

To specify Materials List Polyline categories

1. Select the Materials List Polyline and 

click the Open Object  edit button.
2. On the CATEGORIES panel of the 

Materials List Polyline Specification 
dialog, specify which categories you 
want to include in the materials calcula-
tion. This panel is identical to the panel 
of the same name in the Materials List 
Display Options dialog. See 
“Categories Panel” on page 1291.

Saving and Managing Materials Lists
To save an open Materials List, select File> 
Close. The Save Materials List dialog will 
open, giving you the option to name the list 
and save it or to close it without saving. 

Once a Materials List has been saved, it is 
listed in the Materials List Management 
dialog.

Saved Materials Lists can also be 
accessed, renamed, and deleted in the 

Project Browser. See “Project Browser” on 
page 1125. 

Materials List Management 
Dialog

Select Tools> Materials List>  
Materials List Management to open 

the Materials List Management dialog,.

Click on the name of a saved Materials List 
in the list on the left to select it.
• Edit - Open the selected Materials List. 

You can also double-click an item in the 
list.

• Rename - Open the Rename Materials 
List dialog and type a new name for the 
list.

• Delete - Delete the selected Materials 
List.
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Printing and Exporting the Materials List
To print a Materials List, select File> 
Print while the Materials List window 

is active. See “Print View Dialog” on page 
1226.

A Materials List can also be exported 
into a one of several different file 

formats that can be opened by various 
programs. In a Materials List window, or in 
the Master List, select File> Export Materi-
als List to open the Materials List Export 
dialog.

Materials List Export Dialog

Specify the File Type that you would 
like to export to.

• Select Tab Delimited (TXT) to create a 
text file with a tab between each field 
entry in the Materials List, and a carriage 
return between each row. 

• Select Comma Delimited (CSV) to cre-
ate a text file with a comma between each 
field entry in the Materials List and a car-
riage return between each row. 

• Select Excel (XML) to create a file that 
can be opened by Microsoft Excel.

• Select HTML to create an html file that 
you can view with a web browser.

Additional export options are available 
here.

• Uncheck Include Column Headers to 
prevent column headings from appearing 
in the first row of the exported file. Col-
umn headers are always included in 
HTML files.

• Uncheck Include Hidden Columns to 
only export columns currently displayed 
in the active Materials List. When this is 
checked, all columns are exported, 
regardless of whether they are currently 
displayed.

• Check Run Default Spreadsheet or Edi-
tor to open the exported file with the pro-
gram specified on your computer when 
you finish exporting. 

When you click OK, the Write Materials 
Export File dialog will open. This is a typical 
File Save dialog. See “Exporting Files” on 
page 58. 

Estimating Software
You can export a Materials List to a word 
processor or spreadsheet program to arrange 
it in your estimating format. You can also 
export the Materials List to a number of 
commercial estimating programs in whose 
databases you can keep your current pricing, 
labor costs, and  markups and generate 
reports based on this data. 

1

2
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Before purchasing an estimating software 
program, be sure that the program supports 
the direct import of Chief Architect Materials 
Lists. 

Any questions regarding estimating software 
packages and how they interact with Chief 
Architect should be directed toward the 
company providing the estimating software. 
Chief Architect is unable to provide any 
technical support for third party programs.

Conditioned Area Totals
Conditioned Area is the space within a 
building that is heated and/or air conditioned, 
and a Thermal Envelope is a three 
dimensional boundary built around the 
Conditioned Space that separates it from the 
unconditioned space around it. Thermal 
Envelopes are composed of floor platforms, 
ceiling platforms, walls, doors, and windows.  

When a Materials List is created, Chief 
Architect calculates the total areas of the 
components that make up a structure’s 
Thermal Envelope and lists them in the 
General category of the Materials List. See 
“Categories” on page 1290. 

Doors are always categorized as doors rather 
than as windows. This is the case even when 
a door is specified as a Glass Door or when it 
is part of a mulled unit. 

Chief Architect does not check plans for 
compliance with building or energy codes; 
however, you can export relevant thermal 
envelope data from a plan file for use in 
REScheck™. See “Export to REScheck” on 
page 1192.

Conditioned Area
With the exception of Unspecified rooms, 
rooms that are assigned an interior Room 
Type are included in the Conditioned Area 

by default. “Open Below” rooms are also 
included; however, other hybrid Room Types 
as well as exterior Room Types are not. See 
“Room Types” on page 335.

You can, however, specify that any room be 
included in or excluded from the 
Conditioned Area, in the Room 
Specification dialog. See “General Panel” 
on page 351. 

Building Orientation
Walls, doors, and windows are categorized as 
north-, south-, east-, or west-facing for the 
purposes of conditioned area totals. These 
directions  are based on the orientation of the 

plan’s North Pointer . If no North 
Pointer is used, north is assumed to be 
straight up on screen in floor plan view. See 
“North Pointer” on page 943.
• If a wall is oriented at 45º or less to north 

in a plan, it will be categorized as a 
“North” wall. Any doors and windows in 
this wall will also be categorized as 
“North”.

• Similarly, walls, doors, and windows ori-
ented within 45º of south, east, or west 
will be classified as “South”, “East” or 
“West”, respectively.
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The orientation of a curved wall is based on 
the direction of its chord. See “Drawing Arcs 
- Arc Creation Modes” on page 1089. 

The General Category
The General category of the Materials List 
lists information about the Thermal Envelope 

of the current plan. The total linear length of 
each wall type used in the plan is also 
calculated in the General category. Walls 
with different heights are each listed 
separately. See “Wall Type Definitions” on 
page 302. 

The Master List
The Master List saves price, supplier, 
manufacturer, and other information 

about items in your Materials Lists and 
allows you to apply that information to items 
in future Materials Lists. Select Tools> 
Materials List> Master List to open the 
Master List. 

Chief Architect allows you to have more than 
one Master List. Only one can be active, 
however, and only the active list is updated 
with new information. You can specify 
which Master List is active in the 
Preferences dialog. See “Materials List 
Panel” on page 119. 

Adding to the Master List
You can edit line items in a Materials List 
and then add them to the Master List for 
future use.

To use Update to Master

1. Create a Materials List and change or 
add information in any editable column 
of a line item.

2. Select the line item by clicking on its 
line number on the left side of the list. 
When selected, then entire line becomes 
highlighted. 

3. Select multiple adjacent rows by holding 
down the Shift key while clicking. 

4. Select Tools> Update to Master. The 
information in the selected line is saved 
in the Master List. 

Once Master List information exists for a 
particular item, you do not need to enter it 
again until you want to update it. 

Update from Master
Similarly, items in a Materials List can be 
updated to include information in the Master 
List.

To use Update from Master

1. When a Materials List is active, click on 
a row number to select the row. 

2. Select Tools> Update from Master to 
have the program search the Master List 
for a record for the selected line item. If 
an identical record is available, its infor-
mation is included in the Materials List. 

• Multiple rows can be selected by clicking 
on one row number, then holding down 
the Shift key and clicking on additional 
row numbers.
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• Select all rows by clicking the cell at the 
top left corner of the Materials List, above 
the row numbers.

If the Master List contains more than one 
record for an item, the program references 
the last one entered. You can override this by 

defining one specific entry as the default. 
This is achieved by clicking on the check box 
in the Def column. 

The Master List is almost identical to a 
Materials List, but has a few additional 
controls to help with viewing. 

The Category drop-down list at the top 
left corner of the window lets you select 

one particular category for display, or all 
categories.

As with individual Materials Lists, you 
can specify which Columns display in 

the list. See “Materials List Display Options 
Dialog” on page 1291.

Use the Find field near the bottom of 
the window to search for text in the 

Master List.

The search starts from the currently selected 
cell and moves to the right, then moves down 
to the next row starting at the left column, 
and so on, until it finds an instance of the text 
you entered. 

The Status Bar at the bottom indicates 
how many entries are listed.

Editing the Master List
In the Master List, existing line items can be 
modified or deleted. For information about 

1

2

3

4
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the editability of columns in the Master List, 
see “Materials List Columns” on page 1293.

Often, the Master List will include items that 
you may not want to include in all Materials 
Lists.
• Checkboxes in the Use column indicate 

whether each item is included in the 
Materials List. If Use is unchecked, the 
item is not included. This is useful in 
cases where several line items will be pur-
chased as a single unit.

• This Quantity column is used to specify 
how many of an item must be found 
before information from the Master List is 
applied to it in a Materials List. If at least 
this many of the item are found, price, 
supplier, and other information is used. 
Quantity is useful for applying a quantity 
discount.

• When more than one line item is available 
for a specific component or accessory, the 
Default column indicates which item is to 
be used. Click this column to specify this 
item as the default. This is useful when a 
line item has been updated to the Master 
List more than once with different price, 
supplier or other information.

To delete a row from the Master List, click 
on the row number at the far left. The entire 
row highlights. Select Edit> Delete, click the 

Delete  button, or press the Delete key on 
your keyboard.

Components Dialog
Many architectural objects in the 
program, from walls to cabinets to 

images, have components and accessories 
associated with them that are calculated in 
the Materials List as well as listed in 
schedules.

In addition to editing and adding information 
for objects and their accessories in the 
Materials and Master Lists, you can edit and 
add information directly to these objects in 
the Components dialog. 

Select an object, then click the 

Components  edit button to open the 
Components dialog for that object. 

You can also define the Components for a 
variety of items saved in the Library 
Browser. To do this, right-click on an 
architectural object in the User Catalog and 

select Components  from the contextual 
menu. When a library item is placed into a 
plan, its Components information goes along 
with it. See “Editing Library Objects” on 
page 841. 

You should regularly back up your Master 
List (mmaster.mat) or lists. See “Backing 

Up Your Files” on page 58. 
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The information in the Components dialog 
is the same as the Materials List line item(s) 
for the selected object and can be edited in 
much the same way. See “Editing Materials 
Lists” on page 1293. 

The Description may also be used if the 
selected object is included in a schedule. See 
“Schedules and Object Labels” on page 
1267.

Price, Supplier, Manufacturer, Comments, 
Code and Type information can be added and 
saved with the object itself. When that object 
is copied, even into a different plan, this 
information is transferred, as well, and will 
be calculated in the Materials List and listed 
in schedules.

In addition to their components, cabinets also 
have subcomponents such as their doors, 
drawers and hardware. Subcomponent 
information in the ID, Size and Description 

columns is indented to help distinguish it 
from regular component information. 

Accessories
In the Components dialog, you can add 
additional Materials List entries to a selected 
object. These user-created entries are called 
Accessories. 

To create a new accessory

1. Select an object and click the 

Components  edit button to open the 
Components dialog.

2. Click the Add button and a new line is 
added to the spreadsheet. 

Note: Accessory quantities can only be edited 
when one object is selected. If multiple objects 
are group selected, accessory quantities are 
locked. 
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3. The new entry is given an item name of 
Accessory#. You can give it any name 
you wish. 

4. All other columns for accessory items 
except ID can also be edited. 

5. To remove an accessory, click any part 
of its row and click the Delete button.

To create a new cabinet sub-accessory

1. Select an object and click the 

Components  edit button to open the 
Components dialog.

2. Click in any cell in the row of the com-
ponent with the Description that 
matches the cabinet type: base, wall or 
utility cabinet. 

3. Click the Add button. A new line is 
added to the spreadsheet and its ID, Size 
and Description information is indented 
to denote that it is a sub-accessory. 
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Chapter 43:

Ruby Console

Ruby is a popular, open-source programming 
language that can be used for a wide variety 
of purposes.

In Chief Architect, the Ruby Console allows 
you to create custom text macros which can 
be used to produce object labels for specific 
needs. 

Ruby is considered to be easy to use by its 
many users - not all of whom are software 
developers. If you’d like to learn more, visit:  
http://www.ruby-lang.org/.

Chapter Contents
•      The Ruby Console
•      Viewing the Interactive Tutorial
•      Working with Named Values
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The Ruby Console
Select Tools> Ruby Console to open 
the Ruby Console window. The Ruby 

Console can be open while you work using 
other tools in the program. 

The Ruby Console interface is simple: at the 
bottom of the window is an Input field where 
you can type commands, and the results of 
your commands display in the Output field 
above.

Type expressions, or commands, in the 
Input field at the bottom of the window.

• Press Enter on your keyboard to enter 
your expressions and see the results.

The results of your expressions display 
in the larger Output field, above.  

• > at the beginning of a line indicates that 
what follows is your expression.

• => at the beginning of a line indicates that 
what follows is a result.

• As you type multiple expressions, they 
and the new results are added below the 
previous ones.

• Use the scroll bar on the right to scroll up 
and down the results field.

Click the Tutorial button to view an 
interactive written tutorial presented in 

the Ruby Console. See “Viewing the 
Interactive Tutorial” on page 1305.

Click the size grip and drag to resize the 
Ruby Console window. 

1
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3
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Useful Expressions
The following are a few commonly used 
expressions that you can use to obtain the 
attributes of one or more selected objects.

Viewing the Interactive Tutorial
An introductory tutorial is included with 
Chief Architect and can be run in the Ruby 
Console. To run it, select Tools> Ruby 
Console , then click the Tutorial button 
at the bottom of the dialog or simply type 
show in the Input field. 

If you have previously run the tutorial during 
the current program session, the tutorial will 
open to the last topic shown. If you have not 
run the tutorial this session, its Table of 
Contents will open.

To view the tutorial’s Table of Contents at 
any time, type toc in the Input field.

Working with Named Values
The Ruby Console can be used to access 
information about a variety of objects in 
Chief Architect: information which can then 
be used to create custom text macros and 
object labels. See “Text Macros” on page 
1064.

This information is in the form of Named 
Values. In the Ruby Console, these values 

appear as the names of various attributes of 
the object such as its height or the presence 
of a special feature. Named Values use all 
lower case characters and separate words 
using an underscore _ instead of a space.

Objects for which these Named Values are 
available in the Ruby Console are referred to 
as NVPublishers, or just publishers. 

Macro Description
owner Returns the selected publisher
selected Returns an array of multiple 

selected publishers
referenced Returns the publishers
.names Preceded by owner, selected, or 

referenced, this returns an array 
of named values for the selected 
publisher(s).

.<variable
_name>

Preceded by owner, selected, or 
referenced, this returns the value 
of the named value bounded by 
the brackets for the selected pub-
lishers(s).

puts Returns a list instead of an array.
$ Indicates a global variable rather 

than a local variable.
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Named Values and Context
A Named Value only makes sense in context: 
that is, when its publisher and its publisher’s 
purpose are identified. There are two types of 
publisher:
• Owner Objects are literally those that 

‘own’ the Named Values - the values 
describe that object. Macros created 
using Owner Object Named Pairs can be 
inserted into an objects’s label. See 
“Object Labels” on page 1279.

• A Referenced Object, on the other hand, 
is a text object with an arrow pointing to 
the object described by the Named Val-
ues. Macros created using Referenced 
Object Named Values can be inserted into 
text objects. 

To view a publisher’s named values

1. Select Tools> Ruby Console .

2. Select an object in your plan - for exam-
ple a base cabinet. This is an Owner 
Object.

3. Type owner.names in the Input text 
field of the Ruby Console and press the 
Enter key. 

4. An array of Named Values will display 
in the Output field. These values are all 
attributes of the selected object.

5. To view the array as a list, type puts 
owner.names and press Enter. 

You can request the Named Values for a 
Referenced Object just as you can for an 
Owner Object: select the Referenced Object 
and open the Ruby Console. Then, instead of 
typing owner.names in the Ruby Console, 
type referenced.names (or puts 
referenced.names). 

Named Values and Defaults
A number of Named Values for various 
objects end in ‘_is_default’. These Named 
Values will return either ‘true’ or ‘false’, 
depending on whether the object in question 
is set to use the dynamic default for that 
attribute. See “Dynamic Defaults” on page 
76.

Note: The named values for rooms cannot be
used to create Referenced Object macros.
They only work as Owner Object macros. A
number of macros that describe rooms are
available as Global Macros, which do work
when placed in a Text object located inside of
a room.
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Appendix A

Additional
Resources

Chief Architect offers a variety of resources 
to help you become familiar with the many 
features it offers.

•      Reference Manual
•      User’s Guide

•      Online Help Videos
•      Chief Architect Web Site
•      Online Chief Architect Gallery
•      ChiefTalk Online User Forum
•      Technical Support

Reference Manual
The Chief Architect Reference Manual is a 
comprehensive source of information for 
Chief Architect X8. Chapters are organized 
by subject, beginning with the fundamental 
concepts and progressing to the more 
advanced features. The Reference Manual is 
presented in .pdf file format and includes a 
Table of Contents and Index. This manual is 

available online by selecting Help> View 
Reference Manual  from the program 
menu.

The Reference Manual is also available for 
optional purchase in printed form.For more 
information, visit  chiefarchitect.com.

User’s Guide
Written for new Chief Architect users, but a 
helpful reference for users of all experience 
levels as well, the User’s Guide features a 
series of tutorials designed to introduce the 
basics of using the program.

The Chief Architect User’s Guide is 
organized by topic and walks you through 
the process of creating a complete model, 
from the first wall to the interior design and 
landscaping.  

http://www.chiefarchitect.com/products/addon/
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This guide is available online by selecting 
Help> View User’s Guide from the program 
menu.

Like the Reference Manual, the User’s Guide 
is available for optional purchase in printed 
form at  chiefarchitect.com.

Online Help Videos
Another resource designed to illustrate Chief 
Architect’s tools is the set of tutorial videos 
available on our web site. These videos are 
available to users who participate in the 
Support and Software Assurance program. 

To view the online videos, select Help> 
View Online Help Videos from the program 
menu or visit 
 video.chiefarchitect.com/videos.

Chief Architect Web Site
If you have questions that the Reference 
Manual and online Help feature have not 
answered, feel free to turn to the our web 
site. 

A database of common technical support 
questions and answers related to supported 

versions of Chief Architect is available 
through a searchable interface. 

Select Help> Visit Chief Architect Web 
Site  from the menu to launch your 
default internet browser to 
chiefarchitect.com.

Online Personal Training
With a Personal Trainer, it's fast and easy to 
meet your personal training needs from the 
comfort of your own computer. 

While connected to the Internet, you 
converse by telephone with a trainer and 
draw in Chief Architect. You can observe 
each other as you draw, taking turns 

controlling the screen. The action can be 
very close to real time, depending on your 
Internet connection.

To learn more about Personal Training, visit 
the Chief Architect web site at chiefarchi-
tect.com.

Training Seminars
Chief Architect regularly offers live online 
training seminars to meet the needs of  
beginners, proficient users, and everyone in 
between. On site seminars are also held from 

time to time at locations in both the U.S. and 
Canada, delivering two full days of hands-on 
work with Chief Architect. 

http://www.chiefarchitect.com/products/addon/
http://video.chiefarchitect.com/videos
http://www.chiefarchitect.com/support/database.html
http://www.chiefarchitect.com/training/
http://www.chiefarchitect.com/training/
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For information about upcoming seminars, 
visit chiefarchitect.com. 

NKBA® Kitchen and Bathroom Guidelines
A copy of the National Kitchen and Bath® 
Association’s Kitchen and Bath Planning 
Guidelines and Access Standards is available 
on our web site to participants in the Support 
and Software Assurance program. 

Select Tools> Checks> View the NKBA® 
Kitchen & Bathroom Guidelines to launch 
your internet browser to 
chiefarchitect.com. 

Online Chief Architect Gallery
A collection of plan sets, detail 
drawings, and renderings is available 
for viewing and download on our 

web site.

Select File> Download Sample Plans  to 
launch your internet browser to 
chiefarchitect.com

ChiefTalk Online User Forum
The ChiefTalk Bulletin Board offers several 
ongoing discussions about a variety of topics 
related to the use of Chief Architect. It's rich 
with useful tips and available free of charge 
to all registered Chief Architect users. 
• Discussions are initiated and carried out 

by users. 
• The tone is professional and friendly. 

• Experienced users share knowledge with 
each other and beginners. 

• Chief Architect Staff members post 
announcements, advice and technical 
information. 

To visit the ChiefTalk forum, select Help> 
ChiefTalk or go to 
 chieftalk.chiefarchitect.com.

Technical Support
Chief Architect takes pride in offering world 
class technical support services that can be 
accessed by telephone or on our web site. 
Select Help> Technical Support from the 
program menu to visit 
 chiefarchitect.com.

Before contacting Technical Support, take a 
moment to see if the answer to your question 
is found in the Reference Manual, tutorial 
videos, or in our online Knowledge Base at: 
chiefarchitect.com. 

https://chieftalk.chiefarchitect.com/
http://www.chiefarchitect.com/training/
http://www.chiefarchitect.com/
http://www.chiefarchitect.com/products/samples.html
http://www.chiefarchitect.com/support/
http://www.chiefarchitect.com/
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When you contact us, Technical Support will 
refer you to these resources if the answer can 
be found there.

So that our Technical Support specialists can 
assist you as efficiently as possible, please 
refer to “Technical Support Services” on 

page 1311 for additional trouble-shooting 
suggestions and information that will be 
needed before placing your call.
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Technical Support
Services

Chief Architect is committed to providing 
world-class technical support to complement 
our professional products. 

The primary function of technical support is 
to make sure our software is functioning 
correctly and to help you quickly resolve 
problems that prevent its normal use. Our 
technical support professionals are eager to 

work with you to make certain our software 
is functioning as designed. 

We have also assembled a team of certified 
trainers offering instruction in the use of our 
software. Training is available via online 
seminars, online personal training, and on-
site classroom seminars.

Reference and Training Resources
Chief Architect offers a variety of reference 
and training options in addition to the 
resources that come standard with the 
program. Many of these resources are 
available for free or at a significant discount 
to Support and Software Assurance program 
members.

Online Knowledge Base
The Chief Architect online Knowledge Base 
contains a variety of articles describing how 
to resolve common technical problems and 
achieve specific design goals. 

The Knowledge Base is found in the 
Technical Support section of the Web site 
and can be referred to again and again at your 
convenience at  chiefarchitect.com.

http://www.chiefarchitect.com/support/database.html
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Video Training
Chief Architect has developed a collection of 
training videos that contain in-depth training 
on a wide range of topics from beginning to 
advanced experience levels. These videos are 
available on our Web site, 
 chiefarchitect.com .

Playlists are divided into two categories: 
Free Playlists, and SSA Playlists for users 
who participate in the Support and Software 
Assurance program.

Live Seminars
Chief Architect regularly conducts live, 
online training seminars on a variety of 
topics. Learn the basics of using Chief 
Architect the right way by joining a Jump 
Start class, then progress through topics of 
interest, such as Construction Documents, 
Kitchens and Baths, and Terrain. A list of 
upcoming seminars is available online at  
chiefarchitect.com.

Throughout the year, Chief Architect also 
conducts training seminars in various 
locations around the United States and 

Canada. Information about these seminars is 
also posted at  chiefarchitect.com.

Interactive Training
If you have questions about how to use Chief 
Architect, consider contacting our Training 
Department for a Personal Training session. 

Personal Training is an excellent way to 
learn how to use the program, providing one-
on-one interaction with a certified Chief 
Architect trainer via the internet. Discuss  
topics that interest you and learn how to 
accomplish your specific design goals.

User Forum
Our ChiefTalk User Forum is a great place to 
discuss and exchange ideas with other Chief 
Architect users. Here you can post questions, 
read discussions from other users, and post 
suggestions to improve our product. In 
addition to our regular users, from time to 
time our support and engineering teams 
monitor the forum and provide input and 
discussion on current topics. This resource is 
available free of charge at  
chieftalk.chiefarchitect.com. 

Troubleshooting Common Technical Issues
Chief Architect strives to make certain our 
software works correctly; however, from 
time to time issues arise that prevent its 
normal operation. 

Installation Issues
The following are common reasons for 
installation failure of Chief Architect and 
other software:

• Anti-virus software is enabled and inter-
fering with installation. Anti-virus soft-
ware is the most common cause of 
installation failures for any type of soft-
ware. Refer to your anti-virus software’s 
documentation for details on how to dis-
able the software and re-enable it once 
installation is complete.

http://video.chiefarchitect.com/videos
https://chieftalk.chiefarchitect.com/
https://secure.chiefarchitect.com/seminar/
https://secure.chiefarchitect.com/seminar/
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• The recommended minimum system 
requirements are not met. See “System 
Requirements” on page 7.

• The computer has a CD drive but not a 
DVD drive. A standard CD drive will not 
read DVD discs. 

• The DVD has fingerprints, scratches, or 
other defects. Sometimes a small finger-
print can prevent the program from 
installing. Clean the disk with soft cotton 
cloth. Be sure to use soft cotton rather 
than paper products on disks to avoid 
scratching.

• You do not have sufficient rights to install 
the software. Verify that you have admin-
istrative rights and the administrative 

password during the installation process. 
If you are on a corporate network, consult 
your network administrator for assis-
tance.

Refer to the online Knowledge Base for 
solutions to common installation problems. 
If the answer to your question is not found 
there, contact our Technical Support 
department for assistance.

Hardware Lock Not Recognized
If you are using Hardware Lock Security and 
your hardware lock is not recognized on 
startup, launch the Hardware Lock 
Troubleshooter. The Troubleshooter can 
diagnose and provide solutions to most 
common problems with hardware locks. 

The Hardware Lock Troubleshooter can also 
be launched manually by selecting Help > 
Hardware Lock Troubleshooter. 

Troubleshooting Printing Problems
Printing problems fall into two main 
categories: those that prevent the printer 
from working in any program and problems 
printing from Chief Architect. To determine 
if the problem is specific to Chief Architect, 
try the following:

1. Begin by clicking on the Windows Start 
button, and select Printers. 

2. Right-click the printer that is not func-
tioning properly in the Printers folder. 

3. Click Properties from the menu that 
appears.

4. On the General tab, click the Print Test 
Page button. 

If the printer does not produce a test page, 
the problem is not one that Chief Architect 
Technical Support can solve. Follow these 
suggestions:
• Check the connection between the com-

puter and the printer.
• Check your printer documentation for 

troubleshooting printer problems.
• Contact your printer's manufacturer or 

check their Web site for support informa-
tion. 

If you see visible cracking on a CD or
DVD, do not insert it in your CD/DVD

drive. Cracked disks can fly apart and cause
damage to your drive.
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Your printer manufacturer is the best 
resource for solving problems of this type. 
Chief Architect Technical Support is not able 
to help diagnose and solve problems that 
prevent printing from any program. 

Printers and plotters vary widely in how they 
function. Sometimes a faulty cable can be a 
problem. Other times, a plotter may require 
that the paper be loaded in a different 
orientation. Often, solving a printing 
problem is as simple as downloading and 
installing an updated printer driver. See 
“Printer Drivers” on page 1213.

If you can print from Chief Architect but are 
not satisfied with the output, refer to 
“Printing and Plotting” on page 1211 for 
information on how to set up and use the 
printing functions in the program. Legacy 
users should bear in mind that each release 
has new features and enhancements, so 
techniques that were used in prior versions 
may not work in the current version. 

Make sure that you use Print Preview  
before printing. Print Preview displays the 
printed paper, or drawing sheet, as a white 
rectangle on screen, and shows how the sheet 
is scaled and positioned relative to your 
drawing. If the drawing is not on the drawing 
sheet on-screen, it will not be on the sheet 
when you print. See “Print Preview” on page 
1219.

Make sure that your scaling is correct for the 
paper size. If the plan is much smaller or 
much larger than the drawing sheet, you may 
need to change your Scale. See “Printing to 
Scale” on page 1220.

64 Bit Versions of Windows
Some printers may not function correctly on 
64 bit Windows operating systems. If you are 
experiencing a printing problem while using 
a 64 bit version of Windows, please contact 
the printer’s manufacturer to verify that you 
have the correct driver installed.

Printing to a legacy parallel printer port on a 
Windows 64 bit machine may not work 
correctly when using a hardware lock. USB 
printers should not be affected. If you run 
into difficulty with this type of setup, you 
may want to consider Software Lock 
Security. 

Clearing Printer Information
Some information specific to individual 
printers and plotters, such as available printer 
paper sizes, is saved with each plan and 
layout file. 

If you are encountering problems when 
printing, or unexpected options in the Page 
Setup dialog, select File> Print> Clear 
Printer Info to clear the printer-specific 
information stored with the plan or layout 
file. 

After using Clear Printer Info, select File> 
Print> Page Setup . Make sure the 
settings in the Page Setup dialog are correct, 

and then click OK and Save  the file.

It is a good idea to keep the Owner’s
Manual for your printer or plotter close

at hand. Write inside the Owner’s Manual the
various phone numbers for technical support
for that printer or plotter – for the original
manufacturer and for your local dealer.
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Slow Printing from Layout
The most common reason for unusually slow 
printing from layout is the presence of a 
rotated view. To avoid this issue, rotate the 
view prior to sending it to layout, or change 
the orientation of the paper in layout so you 
do not need to rotate the view. See “Layout” 
on page 1235.

Online Knowledge Base
For answers to frequently asked questions 
regarding printing and other topics, select 

Help> Visit Chief Architect Web Site  
and browse the Technical Support section of 
our Web site,  chiefarchitect.com.

Our Technical Support specialists post new 
articles periodically to help resolve problems 
that you may encounter. 

Error Messages
Most common error messages have a known 
cause and simple resolution. When you 
encounter an error or warning message in 
Chief Architect, you can click the Check 
Knowledge Base button in the message box 
to launch your default internet browser to the 
Chief Architect Knowledge Base on our Web 
site,  chiefarchitect.com.

If an article discussing the message is 
available it will display, providing 
information about the message and how best 
to avoid it. 

It is important that abnormal errors be 
reported to Chief Architect Technical 
Support so that we can identify and resolve 
any problems. 

The content of an error message is useful in 
diagnosing its cause. If you encounter an 
error message, read it carefully and write 
down the error number and the exact text of 
the error message. 

If you encounter the error more than once, 
make a note of your steps prior to receiving 
the message.

Before you report an error, check the 
Knowledge Base to see if the error is already 
documented by typing the error message or 
part of the error message into the search 
form. 

Finally, check to see if there are program 
updates available. These updates are 
provided free for the current version of Chief 
Architect and contain enhancements and 
other changes that allow the program to 
perform at an optimum level. Select Help> 
Download Program Updates from the 
Chief Architect menu and follow the 
instructions on our Web site,
 chiefarchitect.com.

Press the Print Screen key on your key-
board to capture a picture of the error

message. Open a new word processing doc-
ument or e-mail message and choose Edit>
Paste to paste a copy of the error message
into the document for later reference.

http://www.chiefarchitect.com/support/
http://www.chiefarchitect.com/support/database.html
http://www.chiefarchitect.com/support/updates.html
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Error Reporting
When an error occurs, you may have the 
option in the message box to send the report 
to Chief Architect. 

No personal information is sent. When you 
click Send, your default internet browser 
launches and a Web page appears on screen 
This message confirms that the report was 
sent successfully and may give you further 
instructions on how to proceed.

Contacting Technical Support
Chief Architect provides free online and tele-
phone support to users participating in the 
Support and Software Assurance program. 
Users who have not purchased SSA receive 
installation support for 30 days after pur-
chase. If you would like to sign up for Sup-
port and Software Assurance, please contact 
the Chief Architect Sales Department.

Before contacting Technical Support, take a 
moment to see if the answer to your question 
is found in the Reference Manual, Help 
index, or in our online Knowledge Base. 
When you contact us, Technical Support will 
refer you to these resources if the answer can 
be found there.

Chief Architect's world-class technical 
support is available Monday through Friday 
from 6 AM to 5 PM Pacific Standard Time 
and can be reached at (208) 292-3399 or via 
our Web site,  chiefarchitect.com.

There are several things you can do to ensure 
a speedy answer to your question when you 
contact Technical Support.
• Before contacting Technical Support, 

select Help> About Chief Architect and 
make a note of the first characters of your 
Product Key and the exact version of 
Chief Architect you are using. Technical 
support is available to the owners of soft-
ware licenses. When you contact Techni-

cal Support, be prepared to verify that 
you are the owner of the software license.

• Before contacting Technical Support, 
check to see if there are program updates 
available for download. Our engineering 
team periodically creates updates to the 
program to resolve functionality or pro-
gram issues that were unknown at the 
time of release. These updates are pro-
vided free of charge for the current 
released version and can be accessed by 
selecting Help> Download Program 
Updates from the menu. 

• When you first encounter a problem or 
error message, copy the exact wording of 
the message or a detailed description of 
the problem. This helps us isolate the 
problem and provide you with a solution 
as quickly as possible. 

• When placing a call to Technical Support, 
be at the computer or work station that is 
experiencing the problem and have Chief 
Architect running. If you do not have 
access to the problem computer at the 
time of the call, the technician may be 
unable to reproduce the issue and/or sug-
gest a remedy that can be implemented 
and verified immediately.

• Be prepared to reproduce the problem 
when you contact us. If the problem can-
not be reproduced, there is a reduced 

http://www.chiefarchitect.com/
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chance that we will be able to resolve the 
problem on your first phone call.

Priority Support
Chief Architect X8 users who participate in 
the Support and Software Assurance 
program should use the Priority Support 
telephone number provided in their SSA 
documentation. The Priority Support number 
bypasses the regular phone queues to give 
you the fastest possible answers to your 
questions. 

Online Information
Chief Architect has a variety of support 
resources available on our Web site. These 
include our Technical Support Knowledge 
Base, the How do I…? Solution Finder, 
downloadable program updates, and ways to 
contact our Technical Support department. 
To access these resources, visit: 
 chiefarchitect.com .

Our support team is happy to assist you in 
finding the best resource to answer your 
questions, and can resolve most issues in just 

a few minutes. In order to allow us to quickly 
answer your calls, we ask that you limit 
yourself to one question per support call. 

Online Support
Questions can be answered online by the 
Technical Support department. To submit a 
technical inquiry online, visit the Technical 
Support section of our Web site and use the  
Online Support Center. 

This route ensures that your question is 
delivered to the first available support 
professional. Requesting assistance of an 
individual specialist is not recommended, 
since that person may not be available to 
answer your question in a timely manner.

Telephone Support
Our Technical Support team is committed to 
answering your questions as quickly as 
possible and in the order received. Your call 
is important to us; however, there are times 
when we get more calls than expected and 
you may have to wait a few minutes before 
speaking to a technician. 

Program Paths Dialog
Some technical issues can be caused by 
problems with support files used by Chief 
Architect. In the event of such an issue, Chief 
Architect Technical Support may direct you 
to the Program Paths dialog. This dialog 
displays a list of files utilized by the software 
along with the pathname of each.  

To avoid unintended problems that could 
prevent you from using the software, it is 
strongly recommended that you make no 
changes to any of the files in this list except 
with the direct assistance of Technical 
Support.

http://www.chiefarchitect.com/
http://support.chiefarchitect.com/
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Appendix C

What’s New in
Chief Architect X8

Welcome to Chief Architect X8. This 
appendix has been written to help our 
upgrading customers make a smooth 
transition from earlier versions of Chief 
Architect to Chief Architect X8. 

Chapter Contents
•      Before You Begin
•      New and Improved Features by Chapter

Before You Begin
There are many new features in Chief Architect X8, and many existing features have changed. 
These changes affect the way Chief Architect functions, so it is very important to be familiar 
with them. 

• “Getting Started Check List” on page 1320

• “Files Created in Version X7 and Prior” on page 1323

• “Files Created in Version X6 and Prior” on page 1323

• “For Files Created in Version X5 and Prior” on page 1324

• “For Files Created in Version X4 and Prior” on page 1324

• “For Files Created in Version X3 and Prior” on page 1326

• “For Files Created in Version X2 and Prior” on page 1326

Be sure to read this section before opening any plans created in earlier versions
of Chief Architect.
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Chief Architect X8 can open the .plan, .layout, .PL1, and .LA1 files from prior versions. 
Before opening any files created in earlier versions of Chief Architect, it is important to be 
aware of changes made in the newest version and the effect they may have on your legacy plan 
and layout files. For details, see “Files Created in Version X7 and Prior” on page 1323,  “For 
Files Created in Version X2 and Prior” on page 1326. 

Please note that files saved in the latest program version cannot be read by older versions of the 
software. When a legacy file is saved in the version X8, an unaltered copy of the original file is 
created which can still be opened in the original version. See “Legacy Archive Files” on page 
60.

As in all software, every new program version introduces changes to its functionality as well as 
to the user interface. If you choose to bring a project forward, be sure to take a few moments to 
look it over in the new version and confirm that the new functionality does not require you to 
make any modifications. Particularly if you have an approaching deadline, you may find it best 
to finish the current project in the version of the software in which you began it. 

Getting Started Check List
The following checklist suggests steps you should take before migrating your files to Chief 
Architect X8. More information about each of these steps can be found after the checklist.

1.      Check for and Install Program Updates
2.      Migrate Legacy Library Files
3.      Migrate Custom Graphics Files
4.      Review the New Features List
5.      Review Your Preferences Settings
6.      Create new custom Template Plan and Layout files
7.      Set up Custom Toolbar Configurations
8.      Backup Entire Plan
9.      Check chiefarchitect.com for more information

1. Check for and Install Program Updates
Program updates contain improvements to the original release version and we recommend 
using the most current version available. By default, Chief Architect checks for program 
updates every day when you launch the program. For information about changing this, see 
“General Panel” on page 98. Please note that program updates are available for download, 
which means that you need internet access to acquire them.

You can check for updates at any time: 

• Select Help> Download Program Updates from the menu. 

• Visit the Program Updates page on the Chief Architect Web site at chiefarchitect.com. 

http://www.chiefarchitect.com/
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2. Migrate Legacy Library Files 

Library content from previous program versions cannot be installed or copied into the Chief 
Architect X8 library. If you upgraded from version X1 or later and have custom library content 
on your computer from that program version, the program installer will locate it and ask if you 
want to migrate it into the Chief Architect X8 library. See “Migrating Library Catalogs” on 
page 15. 

You can import library files from versions X1 through X5 at any time by selecting Library> 
Import Library (.calib, .calibz) from the program menu. In addition, library files from 
versions 10 and prior can be imported by selecting Library> Convert Legacy (.alb) Library 
Files from the program menu. Bear in mind, though, that older content may not be of the same 
quality as currently offered catalogs and that legacy Manufacturer catalogs may be out of date. 
See “Importing Library Catalogs” on page 828. 

3. Migrate Custom Graphics Files
If you have custom graphics files, including textures, images or backdrops, that you were using 
in a previous program version, you can copy them manually using your operating system for 
use in Chief Architect X8. See “Chief Architect Data” on page 53. 

• Copy custom texture files to the Chief Architect X8 Textures folder located in the Chief 
Architect X8 Data folder. 

• Copy custom image files to your Chief Architect X8 Images folder located in the Chief 
Architect X8 Data folder. 

• Copy custom backdrop files to your Chief Architect X8 Backdrops folder located in the 
Chief Architect X8 Data folder. 

In Chief Architect X7 through X1, custom graphics were saved in the Chief Architect Data 
folder, as they are in version X8. In version 10 and prior, they were located in the program’s 
installation directory, in folders that began with “My”. Custom backdrops, for example, were 
saved in “My Backdrops”. 

Texture and image files are not listed in the Library Browser. These files can be assigned to 
material and image objects, however, which are stored in the library so it is important to retain 
them. There are several tools available for adding materials and images to the library. For more 
information, see “Images” on page 1134 and “Creating Materials” on page 857.

4. Review the New Features List 
There are a number of important reasons why you should familiarize yourself with the new and 
improved features in Chief Architect X8:

• New and improved features allow you to produce drawings more efficiently, so it is to your 
advantage to use them. 
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• Some changes to existing functionality may affect your accustomed drawing style and thus 
your productivity if you are not aware of them. 

• New features may affect your choice of settings in your template files, as well as your pre-
ferred Preferences settings. 

See “New and Improved Features by Chapter” on page 1328. 

5. Review Your Preferences Settings 

Any changes that you made to the Preferences settings in your previous version do not migrate 
into Chief Architect X8. You should review all the settings in the Preferences dialog to make 
sure that they are set to suit your drawing needs. For more information, see “Preferences 
Dialog” on page 90.

6. Create new custom Template Plan and Layout files 

Chief Architect X8 installs a selection of template plan and layout files that have been set up to 
take advantage of the program’s updated tools and features. See “Template Files” on page 84. 
For best results, it is recommended that you either: 

• Use the installed templates when creating new plans and layout files in Chief Architect X8

• Use the installed templates as the basis for creating new custom templates.

If you choose to continue using custom template files that you created in a previous program 
version, it is very important that you take the time to carefully review all the default settings in 
the file, making sure that they will continue to suit your needs in X8. First, make copies of your 
custom templates in the Chief Architect X8 Templates directory The Templates directory is 
located in the Chief Architect X8 Data folder. Next, open each template as you would a regular 
plan or layout file, by selecting File> Open, and then save any changes you make by selecting 
File> Save.

If you do choose to continue using a legacy template plan, it is best to also use a legacy layout 
template from the same program version, as well. As with a template plan, take the time to go 
through the layout template’s defaults and make sure they are suited for use in X8 and that their 
line weight scales do not conflict with those in your template plans. See “Line Weights and 
Scaling” on page 1224.

7. Set up Custom Toolbar Configurations 

It is possible to migrate toolbar configuration files from previous versions to Chief Architect 
X8; however, it is not recommended because it is likely that you will be missing new tools 
available in version X8. 

Instead, we recommend that you set up your custom toolbars the way you would like them in 
Chief Architect X8. You may find it most effective to customize your toolbars as you get used 
to working in the new program version, rather than beforehand. See “Toolbar Configurations” 
on page 131. 



Before You Begin

 1323

8. Backup Entire Plan
Before migrating a legacy file created in Chief Architect X7 or prior, it is a good idea to open 
the plan in the program version in which it was created and use the Backup Entire Plan tool 
(Export Entire Plan in version X3 and prior) to export the plan with all associated support files, 
including textures, backdrops and images. See “Backup Entire Plan” on page 70. 

9. Check chiefarchitect.com for more information
If you have additional questions about the changes in Chief Architect, up to date information is 
available in the Support section of our web site. You can also post questions on the ChiefTalk 
web forum at chieftalk.chiefarchitect.com.

Files Created in Version X7 and Prior
In addition to the above recommendations, if you wish to open files created in Chief Architect 
Version X7 or prior, bear in mind the following before you open legacy files in Chief Architect 
X8. 

1. Boxed Eaves
In Chief Architect X8, improvements to the generation of Boxed Eaves ensure that they extend 
into exterior rooms with “Use Soffit Surface for Ceiling” specified when located between the 
roof baseline and an interior room. In some legacy plans opened in Version X8, the Length 
value for Boxed Eaves may need to be modified in the Roof Plane Specification dialog. See 
“Options Panel” on page 485. 

2. Uppercase Text
The Uppercase option was added to Text Styles in Version X8, whereas in Version X7 and 
prior, it was an option for Room Labels and Schedules only. In legacy plans opened in Version 
X8, any Schedules present in the drawing will be assigned a Custom Text Style, as will their 
associated Schedule Defaults. If any Schedule Default is set to Use Layer for Text Style and no 
objects are present on that layer, a new Schedule Text Style will be created and assigned to that 
layer. Room Labels are treated similarly: if any are present, they and their defaults will use a 
Custom Text Style. If a given Room Label or Schedule has been sent to layout more than once 
and was set to use different Text Styles in each layout view, it is possible that its appearance 
may be affected in some views. See “Text Styles” on page 1061. 

Files Created in Version X6 and Prior
In addition to the above recommendations, if you wish to open files created in Chief Architect 
Version X6 or prior, bear in mind the following before you open legacy files in Chief Architect 
X8. 

https://chieftalk.chiefarchitect.com/
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1. Built-in Appliances
In Chief Architect X6 and prior, some appliance symbols designed to be inserted into base 
cabinets had incorrect sizing data. In legacy plans opened in version X8, these appliances will 
not fit into the cabinet correctly and will need to be replaced. Built-in dishwashers are 
particularly affected. See “Built-In Sinks and Appliances” on page 680. 

2. Formatting of Bulleted and Numbered Lists
In Version X7, various improvements were made to the way lines of Rich Text are spaced. In 
legacy plans opened in Version X7, Rich Text objects with bulleted and numbered lists may 
require adjustments. See “Paragraph Options Dialog” on page 1037. 

3. Chief Blueprint Font
The Chief Blueprint font was improved for Version X6, with decreased top and bottom spacing. 
The change in spacing may increase the overall height of text objects using this font in X6 files 
opened in Version X8. X5 and prior legacy files will not be affected by this change. See 
“Blueprint Fonts” on page 1030. 

For Files Created in Version X5 and Prior
In addition to the above recommendations, if you wish to open files created in Chief Architect 
Version X5 or prior, bear in mind the following before you open legacy files in Chief Architect 
X8. 

1. Named Values for Doors and Windows
In Version X6, the Named Values door_style_name, door_type_name, and window_type_name 
were shortened to style_name and type_name. Any object labels or text macros using these 
Named Values in legacy plans opened in Version X8 will need to be replaced. See “Working 
with Named Values” on page 1305. 

For Files Created in Version X4 and Prior
In addition to the above recommendations, if you wish to open files created in Chief Architect 
Version X4 or prior, bear in mind the following before you open legacy files in Chief Architect 
X8. 

1. Roof Overhangs and Framing
In Chief Architect X4 and prior, roof overhangs were measured to the outside of the subfascia, 
whereas in Version X5, they are measured to the outside of the fascia or shadow boards, if 
present. In legacy plans opened in Version X5, this will not affect the appearance of roof planes 
in floor plan view because in X4 and prior, roof plane polylines represented the projected 
framing area whereas in Version X5 they represent the total projected area. But, the position of 
the fascia and subfascia will shift, as will the length of the rafters. See “Eave and Gable 
Overhangs” on page 490. 



Before You Begin

 1325

2. Door Swing Direction and Materials
In Chief Architect X4 and prior, exterior doors that swing outward display interior material on 
exterior side of door. This was corrected in Version X8. Doors modified to work around the old 
behavior could be affected in legacy plans opened in Version X5. See “Changing Door Swings” 
on page 369. 

3. Door Swing Direction and Louvers
Improvements to door louver direction may affect louvers in all doors with the exception of 
bifold doors. See “Changing Door Swings” on page 369. 

4. Wrapped Door/Window Lintels and Window Sills
In Chief Architect X4 and prior, wrapped lintels and sills extended out further than those that 
were not wrapped. In legacy plans opened in Version X8, the extents of wrapped lintels and 
sills will be adjusted so that they equal their Extend setting. See “Door Casing” on page 368 
and “Window Casing and Sills” on page 405. 

5. Cabinet Feet
The offsets for cabinet foot millwork symbols in Version X4 and prior were set per millwork 
symbol to insert into cabinets effectively. In Version X8, the offset is set in the Cabinet 
Specification dialogs. When legacy plans are opened in Version X5, cabinet foot offsets are set 
to 0 and transferred to their containing cabinet, if one exists. Any customized or independently 
placed cabinet feet will be affected. See “Pilasters, Feet, and Moldings” on page 691. 

6. Object Labels in Cross Section/Elevation Views
If a “Label” layer is turned on in a cross section/elevation view and objects of that type are 
visible in the view, then those objects’ labels will display in that view when the plan is opened 
in Version X8. See “Object Labels” on page 1279. 

7. Transparent Materials
In Chief Architect X4, materials assigned to the Transparent Material Class for ray tracing were 
visible in rendered views even when their Index of Refraction was set to 1.0. When legacy 
plans are opened in Version X8, Transparent materials with an Index of Refraction of 1.0 are 
transferred to the General Material class and assigned a Transparency value of 100%. This will 
not affect these materials’ appearance in ray trace views, but will make them completely 
invisible in rendered views. See “Properties Panel” on page 871. 

8. Invisible Beams
The legacy Invisible Beam checkbox was removed from the Wall Specification dialog. When 
legacy plans are opened in Version X8, any Invisible Beam walls will be converted to Invisible 
Walls. See “General Panel” on page 309. 
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For Files Created in Version X3 and Prior
In addition to the above recommendations, if you wish to open files created in Chief Architect 
Version X3 or prior, bear in mind the following before you open legacy files in Chief Architect 
X8.

1. Text Styles
The appearance of a number of objects that include text - including object labels, the North 
Pointer, Sun Angles, Joist Direction Lines, the Up/Down arrows for stairs and ramps - can now 
be controlled using Text Style. Their appearance may be altered somewhat in legacy plans 
opened in Chief Architect X8. See “Text Styles” on page 1061.

2. Light Sources
The illumination created by light fixtures and Added Lights was improved in Chief Architect 
X8. Lighting in legacy plans may appear noticeably brighter when viewed in version X8. See 
“Light Data Panel” on page 647. 

For Files Created in Version X2 and Prior
If you wish to open files created in Chief Architect Version X2 or prior, bear in mind the 
following file management changes and structural enhancements before you open legacy files 
in Chief Architect X8.

1. Material textures, images, and backdrops
Chief Architect X2 and prior installed with a catalog of library content, including a selection of 
material textures, images, and backdrops. This library catalog is no longer installed with the 
program because it is now available for download on-demand, so it will be possible to open a 
legacy plan in version X8 and encounter numerous missing file warnings. To avoid this, we 
recommend using the Export Entire Plan feature in the original program version to create a 
folder that includes the plan and all associated textures, images, and backdrops before opening 
this file in X8. This tool is renamed Backup Entire Plan in version X8. See “Backup Entire 
Plan” on page 70.

2. Floor and ceiling finish thicknesses
In Chief Architect X2 and prior, floor and ceiling finish layers were not modeled in 3D, and 
objects such as railings, stairs, landings, cabinets, fixtures, and furnishings measured their 
Floor to Bottom height from the subfloor. These objects now measure their Floor to Bottom 
height from the floor finish surface by default, so it is possible that you may notice height 
changes for these objects - particularly in saved, annotated cross section/elevation views. See 
“Floor and Ceiling Platform Definitions” on page 344.
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3. Riser heights and landing thicknesses
The default Best Fit Riser Height for stairs that do not reach the next level has been updated 
from 9” (225 mm) in version X2 and prior to 6 3/4” (169 mm) in Chief Architect X8. This may 
affect the riser heights of stairs, as well as the thicknesses of landings attached to those stairs. 
See “Staircase Specification Dialog” on page 559. 

4. Auto Adjust Height
The Follow Terrain option in some specification dialogs was replaced by the Auto Adjust 
Height checkbox. If a cabinet, fireplace, fixture, furniture, or other library symbol had Follow 
Terrain unchecked in version X2 or prior and was located in a room with a floor height other 
than the default for the current floor, then the object’s Floor to Bottom Height will change to 
equal that room’s floor height. The object’s position in the model will not change, however. See 
“Terrain Height vs Floor Height” on page 717 of the Reference Manual. 

5. Adjustable Thickness Walls
In Chief Architect X2 and prior, generic, single-layer wall types were available for use. When a 
legacy plan file is opened in version X8 and these wall types are detected, they are replaced by 
an updated, non-generic wall type. Framed walls and Railings will also acquire 1/2” (13 mm) 
thick layers of sheetrock on each side. Railings that define a Deck room with Advanced Deck 
Framing Built will not acquire sheetrock layers. See “Legacy Wall Types” on page 304.

6. Stairwells defined by railings
Interior railings that used a generic, single-layer wall type drawn in older program versions will 
acquire layers of sheetrock when the plan is opened in version X8. This can affect the 
appearance of staircases where they join to a floor platform. To address this issue, select the 
railing and move it 1/2” (13 mm) away from the top edge of the staircase. See “Creating a 
Stairwell Manually” on page 557. 

7. Deck rooms
In legacy plans opened in Chief Architect X8, Deck rooms with Advanced Deck Framing built 
retain the framing but have Automatic Deck Framing turned off by default. Decks with no 
Advanced Deck Framing built are converted to Balcony rooms. See “Decks” on page 340.

8. Material definitions and light sources
Settings in the Define Material dialog that affect materials’ appearance of brightness have been 
modified. The Ambient setting was removed, and the Diffuse setting for materials in legacy 
plans will be set to 100% when opened in version X8. 

The Quality setting for light sources set to use Soft Shadows in ray tracing was also modified. 
Lights using Soft Shadows in legacy plans will be set to use Medium quality. The Light 
Diameter of light sources in legacy plans is capped at 4” (100 mm). See “Texture Panel” on 
page 869 and “Light Data Panel” on page 647.
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9. Structural Member Reporting
When a plan created in Chief Architect X2 or prior is opened in Chief Architect X8, Materials 
Lists are set to calculate Total Lineal Length. For a combination of lineal length and piece 
count, select Mixed Reporting in the Structural Member Reporting dialog. See “Structural 
Member Reporting” on page 1286.

10. Fill New Framing Members
In Chief Architect X2 and prior, Fill New Framing Members was view-specific; in Chief 
Architect X8 it applies to the entire plan. As a result, it is turned off by default in legacy plans 
opened in version X8. See “CAD Defaults Dialog” on page 1072.

New and Improved Features by Chapter
The following is a list of new and improved 
features in Chief Architect Version X8. 
Where possible, cross-references to 
additional information has been provided.

Program Overview
• Added support for 3D Connexion's 3D 

mice. See “3D Mice” on page 34.
• Enhanced support for basic math in dia-

logs and when moving objects using 
dimensions. See “Math Operations in 
Dialogs” on page 40. 

• The Move edit handle of a selected fram-
ing object, Soffit, or group-selection will 
now shift position to remain on-screen 
when you zoom in. See “Edit Handles” 
on page 34.

• Improved how names with numbers at 
the end are sorted in the Project Browser. 
See “Project Browser” on page 1125. 

File Management

• The Backup Entire Plan  tool now 
automatically creates a zipped folder. See 
“Backup Entire Plan” on page 70. 

• New Missing Files dialog assists in han-
dling of missing referenced graphics 
files. See “Referenced Files” on page 68. 

Preferences and 
Default Settings

• New Enable ‘Show Room Labels’ 
Automatic Behavior When Changing 
Room Types setting in the Preferences 
dialog gives the option of leaving Show 
Room Labels unchecked when a Room 
Type is assigned to a room. See “Archi-
tectural Panel” on page 108. 

• New Reset Toolbars button in the 
Preferences dialog. See “Reset Options 
Panel” on page 126. 

• New Measure Windows from Inside of 
Frame setting for drawings imported 
from the Room Planner mobile app in the 
Preferences dialog. See “General Panel” 
on page 98. 

• Obsolete Record undo state only if idle 
longer than setting was removed from 
the Preferences dialog. See “General 
Panel” on page 98. 
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Layers
• Layer sets can now be renamed. See 

“Layer Set Management” on page 147. 

Editing Objects

• New Object , Room , Floor , 

and Plan  Modes for the Object 
Painter tool. See “Matching Properties” 
on page 249.

• New properties including Fill Style can 
be applied using the Object 
Eyedropper  and Apply Properties 

 tools. See “Matching Properties” on 
page 249.

• New Elevation Reference setting for a 
variety of architectural objects lets you 
specify where their height is measured 
from. See “Specification Dialogs” on 
page 41.

• The heights of various architectural 
objects can now be measured from either 
their top or bottom surface. See “Specifi-
cation Dialogs” on page 41.

• The Edit Object Parts toggle has been 
replaced by a Connect CAD Segments 

 toggle, Disconnect Edges  tool, 

and Disconnect Selected Edge  edit 
tool. See “Connect CAD Segments” on 
page 182 and “Disconnect Edges” on 
page 184.

• Sticky Mode  is now available for the 

Break Line  edit tool. See “Break 
Line” on page 231.

• New Complete Break  edit tool 
replaces double-clicking the Break 

Line  edit button. See “Break Line” 
on page 231.

• New Corner Edit Handles  and Edge 
Edit Handles  toggles for the Break 
Line  edit tool. See “Break Line” on 
page 231.

Walls, Railings, and Fencing
• The Wall Specification dialog now has a 

LABEL panel. See “Wall Specification 
Dialog” on page 308. 

• Railing newels, balusters, and rails can 
now be displayed in floor plan view. See 
“In Floor Plan View” on page 281. 

• Wall Hatching  now only covers wall 
layers that are set to display, improving 
its usability with railings. See “Hatch 
Wall” on page 275. 

Rooms
• Living Area labels are no longer created 

for structures that are not included in the 
Living Area Calculation such as detached 
garages and decks. See “Living Area” on 
page 339.

• New Make Room Area Polyline  edit 
tool creates a polyline showing the 
extents of its Standard Area. See “Room 
Area” on page 339. 

• Deck Planking and Joists can now be 
specified as Treated. See “Deck Panel” 
on page 356.

• Improved how deck joists are generated 
when Border Planks have been specified. 
See “Deck Framing and Planking” on 
page 341.
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• Improved how deck joists and planking 
are automatically generated when deck 
joists have been rotated. See “Deck 
Framing and Planking” on page 341.

• Improved ability of planking in separate 
deck rooms to miter along an angled 
Room Divider. See “Deck Framing and 
Planking” on page 341.

• Improved how deck planking is automati-
cally generated for adjacent decks. See 
“Deck Framing and Planking” on page 
341.

• The Display in Uppercase checkbox for 
room labels was moved to the TEXT 
STYLE panel of the Room Label 
Specification dialog. See “Text Style 
Panel” on page 1063.

Doors and Windows
• Doors and windows can now span the 

intersections of straight, collinear walls. 
See “The Door Tools” on page 362 and 
“The Window Tools” on page 392.

• Corner windows can now be pushed fur-
ther into a wall corner to produce a mini-
mal corner post. See “Corner Windows” 
on page 395. 

• Fixed glass corner windows can now 
have no corner post. See “Frame Panel” 
on page 415. 

• Architectural objects like cabinets will 
now bump against door and window cas-
ings and sills. See “Bumping/Pushing” 
on page 221. 

• When a wall type is specified for a Bay, 
Box, or Bow Window placed in a Pony 
Wall, it now replaces both wall types and 
spans the entire unit. See “General Panel” 
on page 430. 

Foundations

• Slabs  now have a LABEL panel in 
their specification dialog. See “Slab 
Specification Dialog” on page 463. 

• Slabs  now have a Footing Offset set-
ting in their specification dialog. See 
“General Panel” on page 464. 

• Post footings can now be specified as 
Round or Square. See “General Panel” 
on page 464. 

Roofs
• New Roof Defaults dialog is accessible 

via the Default Settings dialog. See 
“Roof Defaults Dialog” on page 475. 

• Roof framing can now be generated at the 
same time as roof planes in the Build 
Roof dialog. See “Structure Panel” on 
page 487. 

• The Surface, Structure, and Ceiling lay-
ers of roof planes can now be specified. 
See “Structure Panel” on page 487. 

• The Surface, Structure, and Ceiling lay-
ers of roof planes can now be Auto 

Detailed . See “In Cross Section 
Views” on page 491. 

• The Framing Member Type can now be 
specified for the rafters of individual roof 
and ceiling planes. See “Structure Panel” 
on page 487. 

• New option for a Rebuild Fascia and 
Roof Trim hotkey. See “Roof Panel” on 
page 481. 

Stairs, Ramps, and Landings
• Stairs and Ramps now have object pre-

view panes in their specification dialogs. 
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See “Staircase Specification Dialog” on 
page 559 and “Ramp Specification Dia-
log” on page 570.

• New Top Height Reference settings con-
trol where a staircase’s Top Height mea-
sures to. See “General Panel” on page 
559. 

• New Break Line settings allow you to 
create a break or cut line with optional 
transparency on staircases. See “Stair 
Break Lines” on page 539. 

• New settings for creating stair railing 
returns and extensions. See “Handrail 
Panel” on page 572. 

• Stair and ramp newels, balusters, and 
rails can now be displayed in floor plan 
view. See “In Floor Plan View” on page 
539. 

• New “Stair & Ramp, Details” layer con-
trols the display of stair and ramp over-
hangs and tread nosing in floor plan view. 
See “In Floor Plan View” on page 539. 

• New “Stair & Ramp, Stringers” layer 
controls the display of stair stringers in 
floor plan view. See “In Floor Plan View” 
on page 539. 

• New Handrail at Wall settings allow 
railing returns and extensions. See 
“Handrail Panel” on page 569. 

• The Stringer Top and Bottom values in 
the Staircase Specification dialog are 
now measured from the top front and bot-
tom back corners of stair treads, respec-
tively. Both can now be set to zero, as 
well. See “Style Panel” on page 563.

• Improved how stairs snap to nearby 
walls. See “Drawing Stairs and Ramps” 
on page 537. 

Framing
• Improved wall framing around floor/ceil-

ing beams. See “Framing with Beams” 
on page 582. 

• New Rotate options in the Framing 
Specification dialog allow you to rotate 
and align wall framing and blocking 
within the wall framing layer. See “Gen-
eral Panel” on page 611. 

• Wall Blocking  now displays as a box 
with a single diagonal line when cut by a 
cross section plane. See “In Cross Sec-
tion/Elevation Views” on page 605.

• Improved information text in Wall 
Detail   views. See      In Wall Detail 
Views.

• When multiple sill plates are specified, 
only the bottom one is now Treated. See 
“Sill Plates” on page 579. 

Trusses
• The text of truss labels can now be speci-

fied. See “Truss Labels” on page 621. 
• Unnecessary Measurements informa-

tion removed from the Truss Base 
Specification dialog. See “General 
Panel” on page 626. 

• Automatic Truss label numbering now 
begins with 1 instead of 0. See “Truss 
Labels” on page 621. 

Cabinets
• Enhanced control of face items on cabi-

net sides and back. See “Front/Sides/
Back Panel” on page 701 and “Accesso-
ries Panel” on page 706. 
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• New “Door - Hinge Bottom” and “Door - 
Hinge Top” face items create awning and 
hopper doors. See “Front/Sides/Back 
Panel” on page 701. 

• New “Side Panel - Applied” and “Side 
Panel - Inset” face items. See “Front/
Sides/Back Panel” on page 701. 

• New Full Overlay and Extend to Bot-
tom options for side panels. See “Acces-
sories Panel” on page 706. 

• New Floor to Top setting in the Cabinet 
Specification dialog. See “General 
Panel” on page 697. 

• Box construction, overlay, and corner 
treatment settings are now grouped on the 
new BOX CONSTRUCTION panel in the 
Cabinet Specification dialogs. See “Box 
Construction Panel” on page 700. 

• New Lock from Auto Resize option for 
cabinet face items. See “Front/Sides/
Back Panel” on page 701. 

• The list of cabinet face items is now 
alphabetized. See “Front/Sides/Back 
Panel” on page 701. 

• Cabinet front settings can now be modi-
fied when multiple cabinets are selected. 
See “Front/Sides/Back Panel” on page 
701. 

• New Always Present option places cabi-
net feet under cabinets that are not end 
cabinets. See “Accessories Panel” on 
page 706. 

• New Retain Toe Kick option preserves 
the toe kick on cabinets with cabinet feet. 
See “Accessories Panel” on page 706. 

• Improved functionality of Stretch to Fit 
option for toe kicks. See “Accessories 
Panel” on page 706. 

• Cabinet feet no longer display on Corner 
cabinets. See “Accessories Panel” on 
page 706. 

• The Custom Countertop and Custom 
Backsplash Specification dialogs now 
have a LABEL panel. See “Custom Coun-
tertop Specification Dialog” on page 712 
and “Material Region Specification Dia-
log” on page 801. 

Plants and Sprinklers
• New “Unknown” option for plant Hardi-

ness Zones. See “Plant Chooser Dialog” 
on page 767. 

• New Object Type filter in the Plant 
Chooser dialog. See “Plant Chooser Dia-
log” on page 767. 

The Library
• Improved Library Search sorts the most 

relevant results first. See “Searching the 
Library” on page 824. 

• The Export Library command is now 
available for the User Catalog. See 
“Exporting Library Catalogs” on page 
835. 

• All specification settings are now saved 
when a symbol object is added to the 
library. See “Add to Library” on page 
829. 

Materials
• Improved ability to paint a single wall in 

a room using the Material Painter . 
See “Material Painter and Walls” on page 
851. 
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• Improved interface of the MATERIALS 
panel. See “Materials Panel” on page 
852. 

3D Views

• The Cross Section Slider  now sup-
ports multiple cutting planes. See “Cross 
Section Slider” on page 919. 

• Enhanced panning and zooming in Per-
spective 3D views. See “Repositioning 
Cameras” on page 910. 

• New 3D Focus on Object  tool. See 
“Move Camera with Mouse” on page 
912. 

• Zoom Using Field of View setting 
replaced by the Perspective Crop Mode 

toggle . See “To use Perspective Crop 
Mode” on page 911. 

• The active Sun Angle , Toggle 
Shadows , and Toggle Sunlight  
status are saved on a per-camera basis. 
See “Saving and Printing 3D Views” on 
page 922. 

Rendering and Ray Tracing

• New Adjust Sunlight  tool opens the 
Adjust Sunlight dialog. See “Adjust 
Sunlight Dialog” on page 950. 

• Sun Angles  and the Generic Sun are 
no longer listed in the Adjust Lights dia-
log. See “Adjust Lights Dialog” on page 
940. 

• The Generic Sun now has a defaults dia-
log. See “Generic Sunlight” on page 938. 

• The Generic Sun can now be set to follow 
the camera. See “Generic Sunlight” on 
page 938. 

• The active Sun Angle  can now be 
specified on a per-camera basis. See 
“Adjust Sunlight Dialog” on page 950. 

• Sun Angles  now derive their date 
format from your operating system set-
tings. See “Sun Angles” on page 944. 

• The Opaque Window Glass option was 
moved from the 3D View Defaults dialog 
and made available for most Rendering 
Techniques. See “Rendering Technique 
Options” on page 954. 

• New Toggle Shadows  tool. See 
“Shadows” on page 934. 

• Show Shadows moved from the 
Preferences dialog to the Camera 
Defaults dialog. See “General Panel” on 
page 890. 

• Shadows are now supported in the Vector 
View Rendering Technique. See “Vector 
View” on page 952. 

• Now Shadow Intensity option for the 
Vector View and Technical Illustration 
Rendering Techniques. See “Rendering 
Technique Options” on page 954.

• Show Shadows can now be specified per 
camera view. See “Camera Panel” on 
page 924. 

• Improved handling of reflective surfaces 
in Ray Trace views. See “Ray Trace 
Views” on page 965. 

• New Interior and Exterior Ray Trace 
Configurations available in the installed 
template plans. See “Ray Trace Configu-
rations” on page 967. 
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Dimensions

• New Auto Story Pole Dimensions  
tool. See “Auto Story Pole Dimensions” 
on page 1011. 

• New Blank Segment setting added to the 
SEGMENTS panel of the Dimension Line 
Specification dialog (formerly the ADDI-
TIONAL TEXT panel). See “Segments 
Panel” on page 1025. 

• New Location settings for automatic ele-
vation dimensions. See “General Panel” 
on page 1000. 

• New Elevation Marker settings for ver-
tically oriented dimension lines in cross 
section/elevation views. See “Extensions/
Markers Panel” on page 1023. 

Text, Callouts, and Markers
• New Ellipse, Capsule, Diamond, and 

Rectangle callout shapes for Callouts. 
See “Callout Panel” on page 1056.

• Callouts and Markers now have an object 
preview in their specification dialogs. 
See “Callout Specification Dialog” on 
page 1055 and “Marker Specification 
Dialog” on page 1059. 

• New options for specifying the Align-
ment of Level Line Marker  text. See 
“Marker Panel” on page 1060. 

• New Uppercase option for Text Styles as 
well as Rich Text. See “Rich Text Speci-
fication Dialog” on page 1034 and “Text 
Style Panel” on page 1063.

CAD Objects

• New Blocking Box  tool draws a 
CAD box with a single diagonal line 

through it. See “Blocking Box” on page 
1102. 

Importing and Exporting
• Import of .skp files created in SketchUp 

version 2016 is now supported. See “3D 
Data Import Requirements” on page 
1183. 

• Import and export of .dxf//dwg files cre-
ated in AutoCAD® version 2016 is now 
supported. See “Importing 2D Drawings” 
on page 1170. 

Custom Symbols

• New Show Origin  option for custom 
symbols in the Symbol Specification 
dialog. See “3D Panel” on page 1196. 

• New Use Imported UV Map option in 
the Symbol Specification dialog. See 
“3D Panel” on page 1196. 

• The Height off Floor setting was moved 
from the Symbol Specification dialog to 
the regular specification dialog. See 
“General Panel” on page 844. 

• Obsolete Components button removed 
from the Symbol Specification dialog. 
See “Options Panel” on page 1200. 

Printing and Plotting
• Super B (13” x 19”) and E1 (30” x 42”) 

sheet sizes added to plan and layout tem-
plate files. See “Drawing Sheet Setup 
Dialog” on page 1216. 

Layout
• New Live View options for camera 

views, overviews, and cross section/ele-
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vation views sent to layout. See “Keeping 
Layout Views Current” on page 1243. 

• New Color Fill option for Vector Views 
sent to layout using Plot Lines. See “Send 
To Layout Dialog” on page 1241. 

Schedules and Object 
Labels

• New schedule columns allow you to 
insert dynamic object previews into most 
types of schedules. See “General Panel” 
on page 1274. 

• New Framing Schedule  tool can be 
used to create framing, deck framing, and 
truss schedules. See “Schedules and 
Object Labels” on page 1267. 

• New Ellipse, Capsule, Diamond, and 
Rectangle callout shapes for schedule 
labels. See “Label Panel” on page 1277. 

• Object labels and schedules now support 
multiple lines of text. See “Label Panel” 
on page 1280 and “Using the Edit Han-
dles” on page 1269.

• CAD objects as well as CAD-based 
architectural objects like slabs now have 
labels. See “Label Panel” on page 1280. 

• The Display All Text in Uppercase set-
ting for schedules replaced by Uppercase 
style option for Text Styles. See “General 
Panel” on page 1274. 

Materials Lists
• New Include Hidden Columns option 

when exporting a Materials List. See 
“Materials List Export Dialog” on page 
1296. 

• The Structural Member Reporting dia-
log can now be accessed via the Tools 
menu. See “Structural Member Report-
ing” on page 1286. 

• New Structural Member Reporting 
Method drop-down in the toolbar lets 
you change the reporting method used by 
an active Materials List. See “Structural 
Member Reporting” on page 1286. 

Ruby Console
• New named values for layers, stairs, cabi-

nets, and trusses. See “Working with 
Named Values” on page 1305. 
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Index
Numerics

3D
Backdrops ......................................... 895
Box ................................................... 778
Close all 3D Views ............................. 910
Data Import...................................... 1183
Delete Surface ................................... 910
Face .................................................. 778
Mice ................................................... 34
Molding Polyline................................. 665
Origin .............................................. 1197
Remove 3D Data................................ 910
Symbols, Importing .......................... 1184

3D Box
Specification Dialog ........................... 783

3D Molding Polyline
Specification Dialog ........................... 669

3D Roof Designer .............................. 492
3D View Defaults Dialog ................... 892
3D Views

Display .............................................. 907
Editing ............................................... 920
Floor Overview................................... 900
Framing Overview .............................. 901
Full Overview ..................................... 900
Generation, Speed up ........................ 962
Line Weights .................................... 1223
Overviews ......................................... 897
Panels ............................................... 894
Save ................................................. 922
Working in ......................................... 920

3D Wall Designer ............................... 276
3DS Files

Export ............................................. 1189

A
Absolute Location

New point ....................................... 1077
Active Layer Display Options ......... 152
Active Layer Set Control ................. 148
Added Lights ..................................... 938
Adding

Floor Between Existing Floors ............ 438
to the Library..................................... 829
Toolbar Buttons ................................. 136

Adjust
Effects .............................................. 978
Image Properties ............................... 978
Material Definition ............................. 857
Wall Angle ........................................ 108

Adjust Lights Dialog ........................ 940
Advanced

Splines ............................................. 213
Aerial View ........................................ 885

Layer Set .......................................... 886
Alcove Roofs ..................................... 517
Align

Curved Stairs Between Floors ............ 229
Curved Walls Between Floors ............ 293
Objects ............................................. 223
Pony Walls Between Floors ............... 293
Roof Edges ....................................... 493
Stem Walls and Footings ................... 458
Text ................................................ 1048
Walls ................................................ 292

Align/Distribute Along Line............. 225
Align/Distribute Objects .................. 224
Allowed

Angles Dialog .................................... 254
Alpha Channel................................... 869
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Alphabets
International .................................... 1030
Unicode .......................................... 1030

Ambient Light
Daytime ............................................ 937
Interior .............................................. 937
Nighttime .......................................... 937

Angle Snap Grid ............................... 165
Angle Snaps ...................................... 164
Angled Front Cabinets ..................... 694
Angles

Entered as bearings ........................ 1082
Angular Dimensions ...... 235, 1006, 1020
Annotation Sets .................................. 80
Appearance Preferences ................... 92
Appliances

Built into cabinets .............................. 680
Apply Properties ............................... 250
Arc

Creation Modes ............................... 1089
Panel .............................................. 1093
Specification Dialog ......................... 1093
Tools .............................................. 1091
with Arrow ....................................... 1092

Architectural Block
Specification Dialog ........................... 814

Architectural Blocks ........................ 811
Components...................................... 817
Displaying ......................................... 812
Edit Sub-Objects ............................... 814
Explode ............................................ 814
Sub-objects....................................... 816

Architectural Preferences ............... 108
Archive Files ....................................... 59

Manage Auto Archives ......................... 60
Arcs

Aligning Centers ................................ 229
Arc About Center............................. 1090
Arc Creation Modes ......................... 1089
Lock Center ...................................... 195
Make Arc Tangent ............................. 228
Show Arc Centers ............................. 195
Start and End Points.......................... 113
Tangent, make .......................... 291, 294

Area
Living Area calculation ....................... 336
of a Polyline .................................... 1098
of Roof Planes................................... 502
of Rooms .......................................... 338

Arrow
Auto Positioning .............................. 1053
Panel .............................................. 1088
Special use ..................................... 1053
Text Line With ................................. 1052

Artwork
Creating textures ............................... 860

Attenuation ........................................ 650
Attic

Floor ................................................. 444
Rooms .............................................. 335
Trusses ............................................. 629
Walls ................................................ 297

Auto
Archive ....................................... 59, 100
Check for Program Updates ................. 98
Connect Island Rooms ....................... 261
Detail ................................................ 905
Dormer Tool ...................................... 522
Dormers, Editing................................ 523
Elevation Dimensions ...................... 1010
Elevation Views ................................. 904
Exterior Elevations............................. 904
Floating Dormer................................. 521
Floating Dormer Tool ......................... 521
Interior Dimensions .......................... 1010
NKBA® Dimensions ......................... 1010
NKBA® Elevation Dimensions .......... 1010
Place Corner Boards.......................... 654
Place Outlets............................. 337, 641
Place Quoins ..................................... 656
Roof Returns ..................................... 527
Save Files ................................... 60, 100
Stairwell ............................................ 557

Auto Dimension
Defaults ............................................ 998

Auto Rebuild
Attic Walls ......................................... 261
Framing ............................................ 581
Roofs ................................................ 479
Terrain .............................................. 730



 1339

Walls/Floors/Ceilings .......................... 441
Automatic

Framing ............................................. 580
Roofs ................................................ 474
Roofs vs. Manual Roofs...................... 474
Walls ................................................. 261

B
Backclipped Cross Section .............. 903
Backdrops ........................................ 1155

3D ..................................................... 895
Definition ......................................... 1155
Generated Sky ................................... 897
in Rendering Techniques .................... 897
Panoramic ....................................... 1156

Background Color .............................. 94
Backup

Entire Plan.......................................... 70
Files ................................................... 58

Balloon Through Ceiling .................. 312
Balusters ............................................ 323

Definition ........................................... 535
Base

Cabinets ............................................ 678
Baseline

Dimensions...................................... 1007
Polylines (Roofs)................................ 504
Roofs ................................................ 489

Basements
Daylight ............................................. 461
Walkout ............................................. 461

Bay Windows ..................................... 393
Bay/Box Window

Specification Dialog ........................... 429
Beams

Bearing.............................................. 612
Floor/Ceiling ...................................... 585
Roof .................................................. 584
Roof, exposed ................................... 794

Bearing
Beam ................................................ 612
Line ................................................... 603

Wall .................................................. 314
Bearings .......................................... 1082
Behaviors Preferences .................... 113
Birdsmouth

Cut ................................................... 497
Blend Colors with Materials ............ 851
Blind Cabinets .................................. 695

Automatic ......................................... 677
Blocking

Joist ................................................. 585
Roof ................................................. 584
Wall .................................................. 590

Blocks
Architectural...................................... 811
Architectural vs CAD ......................... 812
CAD ............................................... 1111
Mulled Doors and Windows ................ 373

Bonus
Library Catalogs ................................ 826
Rooms .............................................. 444

Borders (Layout)............................. 1261
Bounding Box ................................. 1208
Bow

Front Cabinets .................................. 695
Window Specification ........................ 429

Bow Windows .................................... 393
Box

Tools .............................................. 1101
Windows ........................................... 393

Break
Line .................................................. 231
Line, complete................................... 231
Line, partial ....................................... 231
Terrain Breaks .................................. 722
Wall .................................................. 276

Brick Ledges ..................................... 270
Build

Foundation................................ 439, 452
Framing Dialog.................................. 586
House ............................................. 1129
New Floor ......................................... 437
Roof Dialog ....................................... 480
Terrain .............................................. 730

Bump Map
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Use .................................................. 874
Bump Maps ........................................ 980
Bumping/Pushing ............................. 221

C
Cabinet

Defaults ............................................ 676
Designer ........................................... 675
Modules Library ................................ 679
Shelf Specification Dialog .................. 709
Specification Dialog ........................... 696
Tools ................................................ 678

Cabinets
Angled front ...................................... 692
Backsplash ....................................... 698
Base ................................................. 678
Bevel ................................................ 706
Blind ................................................. 695
Blind Corners, automatic.................... 677
Built-in appliances ............................. 680
Corner .............................................. 693
Countertop, custom ................... 679, 683
Countertops ...................................... 683
Delete face items .............................. 702
Dimension to corners/sides ................ 994
Door/Drawer Overlay ......................... 700
Door/drawer style .............................. 680
Doors, diagonal ................................. 699
Doors, glass ...................................... 705
Editing .............................................. 688
End cabinets ..................................... 692
Exposed End..................................... 693
Fillers ............................................... 681
Fillers, automatic ............................... 677
Frameless ......................................... 700
Front Indicators ................................. 685
Front/Sides/Back Panel ..................... 701
Full Height ........................................ 678
General Defaults ............................... 677
Glass doors ...................................... 705
Island ............................................... 695
Labels .............................................. 686
Lazy Susan ....................................... 699
Minimum Width ................................. 677
Module Lines .................................... 685

Module lines, partial........................... 678
Moving, with Wall .............................. 690
Normal .............................................. 692
Opening Indicators ............................ 685
Panels .............................................. 701
Peninsula radius ................................ 692
Pilasters ............................................ 707
Radius end ........................................ 692
Resize Increment............................... 678
Reverse Appliance............................. 704
Schedules ......................................... 714
Separation ........................................ 700
Shaped ............................................. 692
Shelves ............................................. 709
Special shapes .......................... 692, 697
Stile .................................................. 705
Toe kick ............................................ 699
Wall .................................................. 678

CAD
Angle Snaps ...................................... 164
Angles in Degrees/Bearings ............. 1073
Blocking box.................................... 1102
Blocks ............................................. 1111
Box ................................................. 1102
Circle about center .......................... 1095
Circle Tools ..................................... 1095
Convert to Terrain.............................. 754
Cross box........................................ 1102
Current CAD Layer .......................... 1107
Current Point ................................... 1078
Delete Current Point ........................ 1079
Drawing Tools ................................. 1075
Ellipses ........................................... 1096
Extend Object(s)................................ 246
Fillet ................................................. 233
In Layout ......................................... 1238
Line Length Format.......................... 1073
Lines............................................... 1080
Move to Front of Group ...................... 219
Ovals .............................................. 1096
Points, moving................................. 1079
Polylines ......................................... 1097
Preferences....................................... 109
Rectangular Polyline Tool ................ 1101
Resize .............................................. 114
Rotate around ................................... 115
Rotate items ...................................... 114
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Rotate Jump ...................................... 115
Temporary Points ............................. 1078
to Walls ..................................... 238, 300
Trim Object(s) .................................... 245

CAD Block ........................................ 1111
Add to library ................................... 1113
Explode ........................................... 1112
Insert............................................... 1114
Insertion Point ................................. 1116
Make CAD Block .............................. 1112
Management .................................... 1114
Nested ............................................ 1111
Purge unused .................................. 1114
Select Insertion Point ....................... 1112
Specification Dialog ......................... 1115

CAD Box
Specification Dialog ......................... 1103

CAD Defaults ................................... 1072
CAD Detail ........................................ 1117

from View ........................................ 1118
Management Dialog ......................... 1117
Truss Detail ....................................... 621

CAD Objects
Converting ......................................... 238
Dimensions to .................................... 995
Displaying........................................ 1107

Calculate
From All Floors ................................ 1284
From Room...................................... 1284
Loan ................................................ 1132
Materials on soffits ............................. 795

Callout
Arrows ............................................. 1054
Defaults ........................................... 1029
Shape ............................................. 1056
Size................................................. 1056
Specification Dialog ......................... 1055

Callouts ............................................ 1054
Camera

Activating .......................................... 922
Change Settings ................................ 924
Clip Surfaces Within ................... 891, 929
Create Views ..................................... 899
Defaults ............................................. 889
Field of View .............................. 890, 918
Height above floor .............................. 890

Move Increments ............................... 890
Move Tools ....................................... 914
Move Up/Down One Floor .................. 918
Orbit Tools ........................................ 914
Plan Display Tab ............................... 926
Remove Wall within ................... 891, 926
Restrict to room................................. 893
Rotate Increments ............................. 890
Specification Dialog ........................... 924
Tilt Angle .......................................... 890
Tilt Tools........................................... 915

Casing
Door ......................................... 368, 379
Window............................................. 405

Cathedral Ceilings ............................ 347
Ceiling

Break Lines ....................................... 348
Framing ............................................ 586
Heights ............................................. 342
Plane ........................................ 476, 511
Trusses ............................................ 616

Ceiling Plane
Specification Dialog ........................... 512

Ceiling Structure Definition ............ 802
Ceilings

Automatic ......................................... 586
Basement ......................................... 450
Cathedral .......................................... 347
Coffered ........................................... 348
Dropped............................................ 343
Hole in Platform ................................ 345
Lowered............................................ 346
Over this room .................................. 355
Special ............................................. 346
Stepped Trusses ............................... 630
Tray .................................................. 347
Vaulted ............................................. 347

Center
Doors ............................................... 368
Object edit tool .................................. 227
Sheet.............................................. 1220
Snapping to ...................................... 117
Text ................................................ 1048

Centerline Dimensions .................. 1008
Chamfer

Footings ........................................... 318
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Two Lines ......................................... 233
Change

Door Swings ..................................... 369
Floor/Reference ........................ 443, 445
Line to arc......................................... 542
Roof Pitch or Height Dialog ................ 495
Scale .............................................. 1249
View Panel Factors ........................... 962
Wall Types for Pony Walls ................. 273

Check
Plots ...................................... 1212, 1221
Spelling .......................................... 1051

Chief Architect
Premier vs Interiors ............................. 29
Product Key ........................................ 50
Version Number .................................. 50
Viewer ................................................ 48

Chimneys ........................................... 471
Circle

Specification Dialog ......................... 1096
Tools .............................................. 1095

Circles
Aligning Centers ................................ 229
Circle about center .......................... 1095
Draw using center and radius ........... 1095
Ovals .............................................. 1096

Clear Terrain ..................................... 718
Clear the Terrain ............................... 718
Click Stairs ........................................ 535
Client Information........................... 1127
Close

Plans and Views.................................. 71
Program.............................................. 71
Views ............................................... 886

Color
Off/On .............................................. 217

Color Chooser ................................... 875
Create Material Using ........................ 876
Eyedropper ....................................... 876

Color Chooser Dialog ...................... 875
Colors

Selecting .......................................... 875
Compatibility

with other programs ............................. 52

Components ...................................... 843
Dialog ............................................. 1300

Compound Raked Walls ................... 299
Concentric

Resizing ............................................ 180
Concrete

Pour Numbers ................................... 455
Cone ................................................... 778

Specification Dialog ........................... 787
Configurations Panel ....................... 138
Connect

Electrical ........................................... 642
Walls ................................................ 279

Contextual Menus ............................... 92
In Render views................................. 918

Contour Lines.................................... 729
Convert

Arc/Circle to Polyline ......................... 234
CAD Lines to Terrain Data ................. 754
CAD Objects ..................................... 238
Polyline ............................................. 239
Polyline Solid to Solid ........................ 791
Polyline to Spline ............................... 241
Room Molding ................................... 666
Special Polylines into Polylines .......... 241
Spline to Polyline ............................... 241
Textures to Materials ......................... 858
To Polyline Object ............................. 760
to Solid ............................................. 241
to Symbol ........................................ 1206

Coordinates ....................................... 169
Copy

Floors ............................................... 440
Folders and Library Objects ............... 833
Library List ........................................ 826
Multiple Copy .................................... 173
Region as Picture ............................ 1153
Trusses ............................................. 618
Views .............................................. 1248

Copy/Paste
Main Edit Mode ................................. 172
Sticky Mode ...................................... 172

Corner
Boards .............................................. 654
Windows ........................................... 395
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Corner Board
Specification Dialog ........................... 655

Countertops
Custom...................................... 679, 683
Edge Profiles ..................................... 684
Edit Custom ....................................... 684
Holes in ............................................. 679

Create
Line Style .............................. 1084, 1109
Plan Database File .............................. 63
Plan Materials Library ........................ 858
Plant Image ....................................... 770
Schedule from Room ........................ 1273

Create Hole ........................................ 206
Cross Hairs ........................................ 112

Mouse ............................................... 226
Turn On/Off ....................................... 112

Cross Section Lines
Callouts ........................................... 1057
In Camera Views................................ 921

Cross Section Slider ......................... 919
Cross Section Views

Stepped Cutting Plane........................ 904
Cross Section/Elevation ................... 902
Cross Section/Elevation Camera

Specification Dialog ........................... 928
Cross Section/Elevation Views ....... 902
Cross Section/Elevations ................. 898

Detailing ............................................ 905
Sent to Layout ................................. 1243

Crown Molding
Cabinets ............................................ 691

Culs-de-sac ........................................ 757
Curbs .................................................. 762
Current

CAD Layer ....................................... 1107
CAD Point ....................................... 1078
Floor ................................................. 443
Floor, Delete ...................................... 441
Layout Page .................................... 1259

Curved
Deck Edge ......................................... 267
Deck Railing ...................................... 267
Roof Planes ....................................... 508

Stairs ................................................ 535
Walls, Draw ...................................... 278

Custom
Counterholes .................................... 679
Countertops .............................. 679, 683
Countertops, Editing .......................... 684

Custom Backsplash
Specification Dialog ........................... 801

Custom Countertop
Specification Dialog ........................... 712

Custom Light Intensity Dialog ........ 650
Customize

Hotkeys Dialog .................................. 140
Sheet Sizes Dialog .......................... 1218
Toolbars ........................................... 135

Cylinder ............................................. 778
Specification Dialog ........................... 786

D
Deck ................................................... 340

Designer ........................................... 267
Edges ............................................... 267
Framing .................................... 341, 356
Planking ........................................... 356
Railing .............................................. 267
Railing Defaults ................................. 264
Roof Over ......................................... 341

Decks ................................................. 340
Default

Lights ............................................... 937
Set as ................................................. 76
Wall Heights...................................... 312

Default Sun Light
Specification Dialog ........................... 950

Defaults
Auto Dimensions ............................... 998
Cabinet ............................................. 676
Camera............................................. 889
DeckRailing ...................................... 264
Defined ............................................... 74
Dimension......................................... 986
Door ................................................. 361
Dormer ............................................. 475
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Dynamic ............................................. 76
Electrical........................................... 638
Fencing ............................................ 264
Floor ......................................... 330, 436
Foundation........................................ 448
Framing .................................... 578, 586
General Plan ....................................... 88
Importing ............................................ 86
Layer Set .......................................... 158
Layout ............................................ 1235
Material ............................................ 848
Object Labels .................................. 1267
Railing .............................................. 264
Reset.................................................. 87
Road and Sidewalk............................ 755
Roofs................................................ 475
Room................................................ 330
Schedule ........................................ 1267
Settings .............................................. 74
Structural Member Reporting ........... 1286
Wall .................................................. 262
Window............................................. 392

Define Material Dialog...................... 864
Delete

3D Surface........................................ 910
Built-in Fixtures and Appliances ......... 843
Current Floor..................................... 441
Current Point................................... 1079
Floors ............................................... 441
Foundation........................................ 459
Framing ............................................ 608
Gable Over Opening .......................... 517
Library Content ................................. 833
Objects ............................................. 255
Objects, warning before ....................... 89
Roof Planes .............................. 477, 498
Temporary Points ............................ 1078
Tools from Toolbars .......................... 132
Wall Hatching .................................... 275

Designer Information ..................... 1127
Details

Auto Detailing ................................... 905
CAD ............................................... 1117
Cross section/elevations .................... 905
Truss ................................................ 621

Dialog Number/Angle Style ............. 127

Dimension
Defaults ............................................ 987
Tab ................................................. 1021
Tools .............................................. 1005

Dimension Defaults .......................... 986
Dialog ............................................... 987

Dimension Line
Specification Dialog ......................... 1021

Dimensions
Add Text ......................................... 1018
Angular .......................... 235, 1006, 1020
Auto Elevation ................................. 1010
Auto Interior .................................... 1010
Auto NKBA® ................................... 1010
Auto NKBA® Elevation..................... 1010
Centerline ....................................... 1008
Display size ......................................... 94
Editing ............................................ 1014
To electrical items ............................. 994
End to end ...................................... 1006
Interior ............................................ 1007
Interior, minimum area ....................... 999
Locate Objects .................................. 992
Locating railings ................................ 310
Minimum Interior Area........................ 999
Move Objects Using ......................... 1019
Moving Labels ................................. 1014
Number Height ................................ 1022
Overall .............................................. 999
Point to point ................................... 1007
Printing ........................................... 1222
Rounding Method .............................. 988
Running .......................................... 1008
Story Pole ....................................... 1011
Tape Measure ................................. 1009
Temporary....................................... 1008
Wall Layers ....................................... 303
Wall Widths ..................................... 1022
Zeroes in........................................... 990

Disconnect Edges ............................. 184
Display

3D Views........................................... 907
Arc Centers and Ends ...................... 1073
CAD Objects ................................... 1107
Drawing Groups................................. 218
Drawing Sheet ................................. 1220
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Electrical ........................................... 643
Foundations ....................................... 454
Images ............................................ 1136
Line Weights .................................... 1219
Objects .............................................. 144
Options, Layout................................ 1236
Pointer CAD Coordinates .................... 93
Pony Walls in Floor Plan View ............ 272
Roof Planes ....................................... 491
Room labels ...................................... 338
Terrain .............................................. 729
Walls, Railings, and Fences................ 281

Displayed Line Length
Dialog.............................................. 1074

Distributed Object Tab ..................... 806
Distributed Objects ........................... 804
Distribution Path

Specification Dialog ........................... 805
Distribution Region

Specification Dialog ........................... 805
Door

Casing ............................................... 368
Defaults ............................................. 361
Specification Dialog ........................... 374
Swing Angle ...................................... 375
Tools ................................................. 362
Trim .................................................. 368

Doors
Arched .............................................. 383
Bifold Doors ............................... 364, 371
Blocked Units..................................... 373
Casing ............................................... 379
Center ............................................... 368
Change Opening/Hinge Side............... 370
Change Swing Side ............................ 370
Custom Symbols ................................ 374
Doorways .......................................... 363
Double-swing ..................................... 378
Frame ............................................... 382
Framing ............................................. 590
Gables Over ...................................... 515
Garage .............................................. 364
Garage, opening direction .................. 371
Garage, panels .................................. 378
Handles ............................................. 384
Hardware........................................... 384

Hinged Doors ............................ 363, 369
Hinges .............................................. 384
Ignore Casing when Resizing ............... 89
Labels .............................................. 366
Library ...................................... 364, 375
Lites ................................................. 382
Locks................................................ 384
Opening Indicators ............................ 366
Openings in railings ........................... 372
Plinth Blocks ..................................... 378
Pocket Doors ............................ 363, 371
Recessed.................................. 373, 378
Rough opening .................................. 375
Size .................................................. 375
Sliding Doors .................................... 370
Style ................................................. 375
Swing from Center............................. 378
Swing, change .................................. 369
Threshold lines.................................. 365
Transoms.......................................... 372
Type ................................................. 375
Wrapped Openings ............................ 372

Doorways
Adding a Door ................................... 364
with Railing ....................................... 373

Dormer
Defaults ............................................ 475
Specification Dialog ........................... 524

Dormers ............................................. 521
Auto Dormer ..................................... 522
Auto Floating..................................... 521
Explode ............................................ 524
Framing ............................................ 596
Gable Over Door/Window .................. 515
Manually drawn ................................. 523
Windows in ....................................... 524

Double
Trusses ............................................ 628
Walls ................................................ 299

Draw
Arc About Center ............................. 1090
Circle About Center ......................... 1095
Curved Railing .................................. 278
Curved wall ....................................... 278
Lines .............................................. 1080
Roof Planes ...................................... 489
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Drawing Groups ................................ 218
Drawing Sheet

Center ............................................ 1220
Select ............................................. 1220
Show .............................................. 1220

Driveway
Polyline............................................. 758
Specification Dialog ........................... 763

Driveway Tools ................................. 756
Driveways .......................................... 758
DWG

File Format ..................................... 1169
DXF

File Format ..................................... 1169
DXF/DWG

Advanced Layer Mapping ................ 1175
DXF Code ....................................... 1191
DXF vs. DWG ................................. 1169
Elevation Data, Import ....................... 753
Export 3D ....................................... 1190
Files, Import 2D............................... 1172
Layer mapping ................................ 1174
Layers, exporting............................. 1190
Line Type........................................ 1182

Dynamic
Defaults ........................................ 44, 76
Print Preview................................... 1219
Views ............................................. 1243

E
Earth Data Panel ............................... 946
Eaves

Boxed ............................................... 485
Fascia .............................................. 595
Framing ............................................ 595
Plumb Cut ......................................... 485
Square cut ........................................ 485

Edit
All Roof Planes ................................. 477
Files in Home Designer ....................... 89
Handles .............................................. 34
Layout Lines ................................... 1249
Layout Lines Dialog ......................... 1250

Paper Size Dialog ............................ 1218
Preferences....................................... 111
Text in Place ................................... 1047
Toolbar ............................................... 37

Edit Area
(All Floors) ........................................ 253
(All Floors) Visible ............................. 253
Polyline as marquee .......................... 253
Tools ................................................ 252
Visible ............................................... 252

Edit Behaviors ................................... 178
Alternate ........................................... 179
Concentric......................................... 180
Default .............................................. 178
Edit Indicators ................................... 115
Fillet ................................................. 182
Move................................................. 179
Resize .............................................. 180

Edit Handles
Same Line Type .............................. 1083
Size .................................................. 112
Tolerance .......................................... 113

Edit Text Macro Dialog ................... 1067
Egress Windows ............................... 409
Electrical

Auto Place Outlets ............................. 641
Connections ...................................... 642
Defaults ............................................ 638
Deleting ............................................ 645
Dimension to ..................................... 994
Dimensions to ................................... 996
Displaying ......................................... 643
Editing Objects .................................. 644
General ............................................. 637
Labels ............................................... 643
Library .............................................. 642
Lights................................................ 640
Outlets .............................................. 639
Switches ........................................... 640
Tools ................................................ 639
Wiring ............................................... 642

Electrical Service
Specification Dialog ........................... 645

Elevation
Auto Dimensions ............................. 1010
Data Tools ........................................ 719
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Points ................................................ 719
Regions ............................................. 721
Splines .............................................. 721
Tab ................................................... 737

Elevation Data
Import DXF/DWG ............................... 753
Importing from DXF/DWG ................... 753
Tools ................................................. 719

Elevation Line
Specification Dialog ........................... 737

Elevation Point
Specification Dialog ........................... 736

Elevation Region
Specification Dialog ........................... 737

Elevation Views ................................. 902
Auto .................................................. 904

Elevations
Interior .............................................. 898

Elevations, Wall ................................. 903
Ellipse ............................................... 1096

Specification Dialog ......................... 1096
End

Cabinets ............................................ 694
Caps ................................................. 111
To-End Dimensions .......................... 1006
Trusses ............................................. 633

Energy Heel ........................................ 628
Enhanced Metafiles ......................... 1145
Enter

Coordinates ..................................... 1083
Coordinates Dialog............................. 169

Error Messages ............................... 1315
Estimating Software........................ 1296
Exit Program ....................................... 71
Expand Room Polyline ..................... 349
Expand/Collapse All.......................... 823
Explode

Architectural Blocks ........................... 814
CAD Block ....................................... 1112
Distributed Objects............................. 805
Dormers ............................................ 524
Shape ............................................... 781

Export

2D Drawings ................................... 1179
3D DXF, Material Code .................... 1191
3D DXF/DWG Model........................ 1190
3D Files .......................................... 1189
3D Viewer File................................. 1168
All Floors ........................................ 1179
Current View ................................... 1179
Drawing File Dialog ......................... 1180
EMF ............................................... 1146
From the Library ................................ 835
Layers Sets ....................................... 157
Layout Files .................................... 1265
Materials List .................................. 1296
Picture Files .................................... 1141
REScheck ....................................... 1192
Text Macros .................................... 1068
to POV-Ray....................................... 982
VRML ............................................. 1164
Wall Definitions ................................. 308
Windows Metafiles .......................... 1146
Windows Metafiles Dialog ................ 1146
WMF............................................... 1146

Extend
Object(s) ........................................... 246
Slope Downward ............................... 295

Extension Lines
Adding ............................................ 1016
Centerline ....................................... 1008
Deleting .......................................... 1017
Edit Extensions tool ......................... 1015
Editing ............................................ 1016

Extension Snaps ....................... 118, 163
Extensions Tab ................................. 996
Exterior

Room types....................................... 335
The Exterior Room ............................ 332
Walls ................................................ 269

Extrude
Object ............................................... 781

Eyedropper
Object ............................................... 249

F
F6 Key
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Fill Window ....................................... 882
Faces

3D .................................................... 778
Fascia ................................................. 528
Faster Rendering .............................. 962
Fence Designer ................................. 268
Fence Select ...................................... 186
Fencing

Defaults ............................................ 264
Field of View..................... 890, 918, 1165
File

Backing Up Your Files ......................... 58
Create New ......................................... 54
Management ....................................... 51
Open .................................................. 61
Organization ....................................... 53
Recent File List ................................. 100

File Management Preferences........... 99
Fill

Patterns .......................................... 1099
Window............................................. 882
Window Building Only ........................ 882

Fill Style Panel ................................ 1099
Fillet ................................................... 182
Fillet Lines ......................................... 233
Filter

Imported Terrain Data........................ 749
Library Search .................................. 824
Library Tree View .............................. 834

Final View .......................................... 936
with Shadows .................................... 936

Find Plan Wizard................................. 66
Fire Box Panel................................... 470
Fireplace

Direction facing ................................. 467
Interior wall ....................................... 467
Library .............................................. 471
Masonry............................................ 467
No Fire Box....................................... 470
Prefabricated .................................... 471
Specification Dialog ........................... 468
Symbol ............................................. 471

Fireplaces .......................................... 467

Chimneys .......................................... 471
Foundations ...................................... 468
Freestanding ..................................... 468
In walls ............................................. 467
Types................................................ 467

Fix
Roofs ................................................ 477
Wall Connections............................... 280

Fixtures
Lights................................................ 640

Flare/Curve Stairs ............................. 547
Flat Region ........................................ 724

Specification Dialog ........................... 739
Floating Auto Dormer ....................... 521
Floor

3D Overview...................................... 898
Build New Floor ................................. 437
Camera ............................................. 897
Defaults .................................... 330, 436
Framing ............................................ 586
Heights ............................................. 342
Overview ................................... 898, 900
Tools ................................................ 436
Trusses ............................................. 616

Floor Plan
Drawing .............................................. 45
View ................................................... 47

Floor Structure Definition ................ 802
Floor/Ceiling

Beam ................................................ 585
Floor/Ceiling Truss

Specification Dialog ........................... 634
Floors

Adding .............................................. 437
Attic .................................................. 444
Change Floor/Reference ............ 443, 445
Copying ............................................ 440
Current Floor ..................................... 443
Deleting ............................................ 441
Exchange With Floor Above ............... 440
Exchange With Floor Below................ 440
Floor Up/ Floor Down ......................... 443
FloorTabs.......................................... 586
Hole in Platform ................................. 345
Insert New Floor ................................ 438
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Maximum number............................... 437
Raised ............................................... 343
Reference Floor ................................. 444
Swap Floor/Reference ........................ 446

Folders Preferences.......................... 100
Follow Terrain .................................... 733
Font

Materials List ...................................... 95
Preferences ........................................ 95

Fonts ................................................. 1030
and Alphabets .................................. 1030
Blueprint .......................................... 1030

Footings
Alignment .......................................... 458
Chamfer ............................................ 318
Editing ............................................... 457
Monolithic Slab .................................. 318
Offset From Walls .............................. 318
Size................................................... 318
Stem wall........................................... 458
Stepped ............................................. 298

Footprint, Plan ................................. 1119
Foundation

Defaults ............................................. 448
Panel................................................. 317
Thickness .......................................... 317
Walls ................................................. 269

Foundations
Alignment .......................................... 458
Build.................................................. 452
Daylight Basement ............................. 461
Delete ............................................... 459
Display .............................................. 454
Footing Offset .................................... 318
Footing size ....................................... 318
Garage .............................................. 459
Mixed Types ...................................... 453
Piers ................................................. 451
Rebar ................................................ 451
Room supplies floor ........................... 354
Slab at top of stem wall ...................... 450
Slab thickness ................................... 450
Slab Tools ......................................... 462
Stem Wall .......................................... 450
Step markers ..................................... 450
Stepped ............................................. 462

Types ............................................... 449
Use Mesh ......................................... 452
Walkout Basement ............................ 461

Framing
3D Overview ..................................... 901
Auto Rebuild ..................................... 581
Automatic ......................................... 580
Barge Rafter ..................................... 597
Beams ...................................... 592, 594
Bearing Line...................................... 603
Blocking Box ................................... 1102
Build Framing Dialog ......................... 586
Butt Joints......................................... 586
Ceiling .............................................. 586
Cross Box ....................................... 1102
Deck ......................................... 341, 356
Defaults ............................................ 578
Defaults Dialog.................................. 586
Deleting ............................................ 608
Dimensions to ................................... 996
Displaying ......................................... 604
Doors ............................................... 590
Dormer Holes .................................... 596
Editing .............................................. 607
Floor ................................................. 586
Furring .............................................. 300
Joist Spacing .................................... 588
Joists ................................................ 584
Keeping current ................................. 608
Lap Joints ......................................... 586
Layer ................................................ 302
Lookouts ........................................... 595
Manual vs. Automatic ........................ 580
Materials List .................................... 609
Mitered Joints ................................... 608
Mixing Trusses with Rafters ............... 622
Plates ............................................... 590
Platforms .......................................... 586
Posts ................................................ 594
Reference Marker.............................. 599
Represented by single line ............... 1073
Rim Joist........................................... 586
Roof ................................................. 595
Rough Openings ............................... 590
Schedules ......................................... 614
Sill Plates ......................................... 579
Specification Dialog ........................... 610



1350

Chief Architect X8 Reference Manual

Steel ......................................... 608, 610
Structural Member Reporting ........... 1286
Stud Spacing ............................ 590, 866
Stud Thickness ................................. 590
Tools ................................................ 583
Trimmers .......................................... 591
Truss Spacing ................................... 599
Trusses ............................................ 597
Types ............................................... 610
Wall Blocking .................................... 590
Wall Bridging..................................... 583
Walls ................................................ 589
Windows ........................................... 590

Frieze
Molding............................................. 673

Full
Height Cabinets ................................ 678
Overview .................................. 898, 900

Furring ............................................... 300

G
Gable

Gable/Roof Line Tool......................... 515
Over Door/Window ............................ 515

Garage
Door panels ...................................... 378
Door Tool.......................................... 364

Garages
Foundation........................................ 459

Garden Bed
Kidney Shaped .................................. 726
Polyline............................................. 726
Round............................................... 726
Tools ................................................ 726

General
Cabinet Defaults................................ 677
Framing Tool..................................... 583
Preferences ........................................ 98
Wall Defaults..................................... 260

Get Last Symbol ............................. 1206
Getting Help ........................................ 49
GFCI Outlet ........................................ 639
Girder Trusses .................................. 631

Glass, Stained ................................... 396
GPS

Importing........................................... 750
Grade beams ..................................... 449
Grayscale

On Screen ........................................... 93
Printed ............................................ 1228

Grid
Materials list reports .......................... 120
Snaps ............................................... 166

Ground Fault Circuit Interrupt ........ 639

H
Half

Walls ................................................ 323
Half-Walls........................................... 265
Handrail Tab

Railings ............................................. 326
Stairs ................................................ 569

Hardiness Zone Maps ....................... 769
Hardware

for Doors ........................................... 384
Lock Issues ..................................... 1313

Hatch
Fill Patterns ..................................... 1099
Wall .................................................. 275

Height
Basement ceiling ............................... 450
Railings ............................................. 325

Help
Tool Tips ............................................. 49

Hill / Valley
Specification Dialog ........................... 740

Hill/Valley ........................................... 724
Hip

Truss ................................................ 627
Holes

Creating ............................................ 206
In ceiling platforms ............................ 345
In floor platform ................................. 345
In Slabs ............................................ 462
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In terrain ............................................ 725
Home Designer

Allow editing in.................................... 89
Software Compatibility......................... 52

Hotkeys .........................................37, 138
Create List ......................................... 139
Customize ......................................... 140
Snap Behaviors ................................. 162

House Wizard
Editing Rooms ................................. 1128
Multiple Floors ................................. 1129
Placing Rooms................................. 1128

I
Image

Specification Dialog ......................... 1137
Images ................................................ 935

Adding to Library.............................. 1135
Convert Folder ................................. 1135
Creating .......................................... 1135
Displaying........................................ 1136
Editing ............................................. 1136
In Schedules .................................... 1275
Place ............................................... 1134
Printing............................................ 1229
Transparency Color .......................... 1140

Import
2D DXF/DWG Files .......................... 1172
3D Data ........................................... 1183
3D Symbols ..................................... 1184
Defaults .............................................. 86
Drawing Wizard ............................... 1172
DXF/DWG Elevation Data ................... 753
GPS Data .......................................... 750
Layer Sets ......................................... 157
Line Styles....................................... 1108
PDF ................................................ 1148
Terrain Assistant ................................ 747
Terrain Data ...................................... 747
Text Macros ..................................... 1068
Wall Definitions .................................. 308

Information
Client .............................................. 1127
Designer .......................................... 1127

Project ............................................ 1127
Input

Arc ................................................. 1091
Line ................................................ 1081
Point ............................................... 1077

Insert
Floor Dialog ...................................... 438
Layout Page.................................... 1259

Insulation ......................................... 1102
Auto Detailing ................................... 905
Show in Elevation .............................. 905

Interior
Dimension Tool ............................... 1007
Dimensions, Auto ............................ 1010
Fireplace, wall ................................... 467
Room types....................................... 335

Invisible Walls ................................... 273
Isometric Overviews ........................ 901

J
Join Roof Planes .............................. 493
Joist

Direction Line .................................... 601
Joist Direction

Specification Dialog ........................... 602
Joists ................................................. 584

Bearing Line...................................... 603
Blocking ............................................ 585
Spacing ............................................ 588
Use Framing Reference ..................... 587
see also Framing

K
Key Frames...................................... 1159
Keyboard

Commands ......................... 37, 138, 823
Commands, customize ...................... 140

Kidney Shaped
Garden Bed ...................................... 726
Pond................................................. 726
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Terrain Features................................ 725
Kingpost ............................................ 632
Kitchen Island ................................... 695
Knee Walls ................................. 297, 315

L
Label Panel ...................................... 1280
Labels

Cabinet ............................................. 686
Display size ........................................ 94
Displaying ....................................... 1279
Door ................................................. 366
Electrical........................................... 643
Plant ................................................. 774
Roof Plane ........................................ 491
Room................................................ 337
Trusses ............................................ 621
Window............................................. 403

Landing .............................................. 543
Unlocked .......................................... 545

Landings
Custom Shapes ................................. 544
Height............................................... 544
Locked.............................................. 545

Layer
Display Options Dialog ...................... 149
Eyedropper Tool................................ 155
Hider ................................................ 156
Layer Sets ........................................ 146
Painter Tool ...................................... 155
Panel ................................................ 154

Layer Set
Control, Active .................................. 148
Defaults Dialog.................................. 158
Management Dialog........................... 147

Layer Sets
Exporting .................................. 157, 308
Importing .......................................... 157
Layout Views .................................... 156
Missing in Layout ............................ 1258
Modify all .......................................... 147

Layered Material Polyline
Specification Dialog ........................... 801

Layers
3D DWG/DXF Models ...................... 1190
Adding new layers ............................. 151
Colors ............................................... 152
DXF/DWG files ................................ 1174
Locking ............................................. 145
Mapping .......................................... 1174
Materials Lists ................................... 144
Preferences....................................... 104
Primary and Secondary ...................... 144
Rename ............................................ 151
Reset Names .................................... 151
Turn off to speed up 3D views ............ 962

Layout
Adding Lines ................................... 1250
Borders ........................................... 1261
CAD ................................................ 1238
Change Pages................................. 1259
Change Scale .................................. 1249
Create............................................. 1238
Create Template .................................. 85
Cross Section/Elevations ................. 1243
Current Page ................................... 1259
Defaults .......................................... 1235
Edit Layout Lines ............................. 1249
Edit Vector Views ............................ 1249
Editing Views .................................. 1247
Exchange Page ............................... 1260
Exporting ........................................ 1265
Files, Opening ..................................... 61
Floor plan view ................................ 1243
Insert Page ..................................... 1259
Layer Sets......................................... 156
Layout Box Layers ........................... 1247
Links, Managing .............................. 1255
Managing Pages.............................. 1237
Missing Files ................................... 1256
Missing Layer Sets .......................... 1258
Moving Views .................................. 1248
Open View ............................ 1237, 1248
Page Display Options ...................... 1236
Page Information ............................. 1261
Page Numbering.............................. 1260
Page Templates .............................. 1261
Page Up/Down ................................ 1259
Page Zero ....................................... 1261
Pictures in ....................................... 1239
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Printing............................................ 1264
Relink File ....................................... 1257
Rescale Layout View ........................ 1249
Resizing, Non-Scaled Views ............. 1248
Resizing, Scaled Views .................... 1248
Saving ................................................ 56
Sending views to .............................. 1240
Templates .......................................... 84
Text................................................. 1238
Title Blocks ...................................... 1261

Layout Box
Labels ............................................. 1247
Layers ............................................. 1247
Specification Dialog ......................... 1251

Layout Line Scaling ........................ 1242
Layout Views

Copy ............................................... 1248
Keeping views current ...................... 1243

Leader Lines .................................... 1052
Left Mouse Button

Definition ............................................ 33
Legacy Plans

Text Conversion .................................. 95
Legends ............................................ 1033
Library

Adding Folders................................... 832
Bonus Catalogs ................................. 826
Content ............................................. 825
Deleting Content ................................ 833
Export ............................................... 835
Filter Tree View ................................. 834
Manage Library Filters Dialog ............. 835
Manufacturer Libraries ....................... 826
Renaming Libraries ............................ 832
Search .............................................. 824
Shortcuts ........................................... 833
Third Party Libraries ........................... 829
Trash................................................. 833

Library Browser ................................. 820
Adding Items...................................... 829
Docking ............................................. 823
Panes................................................ 820
Preferences ........................................ 96

Library Object
Specification Dialog ........................... 844

Library Object Button
Specification Dialog ........................... 838

Library Objects
and the Materials List ........................ 841
Editing .............................................. 841
Placing ............................................. 836

Light
Ambient ............................................ 937
Specification Dialog ........................... 942

Light Sources .................................... 936
Added Lights ..................................... 938
Default Lights .................................... 937
Default Sun Light............................... 938
Fixtures ............................................ 937
Parallel Lights ................................... 941
Point Lights ....................................... 941
Spot Lights........................................ 941
Sun Angles ....................................... 943

Lights
Added ............................................... 938
Adjust ............................................... 940
Attenuation ....................................... 650
Casts Shadows ................................. 650
Color ................................................ 649
Custom Intensity ............................... 650
Cut Off Angle .................................... 649
Direction ........................................... 649
Drop Off Rate.................................... 649
Fixtures .................................... 640, 937
Floor Number .................................... 942
Height ............................................... 942
Intensity ............................................ 648
Light Data Tab .................................. 647
Show Position in 3D .......................... 650
Turn On/Off ....................................... 939
Types of sources ............................... 940

Line
Angle Format .................................. 1073
CAD Drawing Tools ......................... 1080
Endcaps ........................................... 111
Length Format................................. 1073
Panel .............................................. 1084
Specification Dialog ......................... 1084
Start and End Points.......................... 113
Styles, Importing ............................. 1108
Styles, Library ................................. 1108
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Weight ................................... 1212, 1223
Weight Scaling ................................ 1224
Weights, Show .......................... 93, 1219
with Arrow ....................................... 1083

Line Style
Creating.......................................... 1084
Panel .............................................. 1085
Reverse direction .............................. 238
Specification Dialog ......................... 1109

Line Styles, Creating...................... 1109
Lines

Reverse direction .............................. 238
Lites

Craftsman ......................................... 417
Diamond ........................................... 417
Doors ............................................... 382
Normal.............................................. 417
Prairie............................................... 417

Living Area ........................................ 339
and Room Types ............................... 336
Calculation ........................................ 339
Delete label....................................... 339
Label ................................................ 339
Make Polyline ................................... 340
Restore label..................................... 339
Show .................................................. 90
vs. Footprint ...................................... 339

Load
Custom Muntins ................................ 405

Loan Calculator .............................. 1132
Locate

Roof Plane Intersections .................... 494
Lock

Arc Center ........................................ 195
Center .............................................. 195
Control Handle Angle ........................ 214
Layers .............................................. 145
Roof planes ...................................... 498
Tread Depth ...................................... 547

Lock Toolbars ................................... 133
Lookouts ............................................ 595

M
Macros .............................................. 1064
Main

Edit Mode.......................................... 172
Layer ................................................ 302

Make
Arc Tangent ...................... 228, 291, 294
CAD Block....................................... 1112
Living Area Polyline ........................... 340
Mulled Unit ........................................ 397
Parallel Dialog ................................... 236
Parallel/Perpendicular ................ 227, 236
Room Molding Polyline Dialog ............ 349

Manage
Auto Archives ...................................... 60
CAD Blocks ..................................... 1114
CAD Details .................................... 1117
Layout Links .................................... 1255
Library Filters .................................... 835
Materials Lists ................................. 1295

Manual
Dimensions ..................................... 1006
Roofs ........................................ 474, 488

Manufacturer Libraries..................... 826
Marker .............................................. 1058

Defaults .......................................... 1029
Editing ............................................ 1061
Framing Reference ............................ 599
Specification Dialog ......................... 1059
Types.............................................. 1060

Marquee Select.................................. 185
Marriage Walls .................................. 299
Masonry

Fireplace ........................................... 467
Stairs ................................................ 556

Master List ....................................... 1298
Columns to display ............................ 121
File Location...................................... 121
Materials List ..................................... 121
Name of file ....................................... 121
see also Materials List
Update to Master ............................. 1298

Match Properties ............................... 250
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Material
Defaults ............................................. 848
Eyedropper ........................................ 852

Material Painter ................................. 849
and Walls .......................................... 851
Blending ............................................ 851
Modes ............................................... 850
Using................................................. 851

Materials
Add to Library .................................... 830
Artwork .............................................. 860
Blending ............................................ 858
Calculating amounts ........................... 795
Classes ............................................. 872
Creating ............................................ 857
Define Material Dialog ........................ 864
Editing ............................................... 856
Mapping ............................................ 858
On Soffits .......................................... 795
Panel................................................. 852
Patterns............................................. 867
Plan Materials Dialog ......................... 862
Polyline ........................................... 1294
Render properties .............................. 871
Stained glass ..................................... 396
Textures .................................... 869, 935
Types ................................................ 860
Walls ................................................. 282

Materials List ................................... 1283
Calculate from All Floors .................. 1284
Calculate from Room ........................ 1284
Categories ......................................... 119
Columns, editing .............................. 1293
Conditioned Areas............................ 1297
Display Options Dialog ..................... 1291
Editing ............................................. 1293
Estimating software .......................... 1296
Export ............................................. 1296
Font ................................................... 95
Framing ............................................. 609
Grid display on reports ....................... 120
Library Objects .................................. 841
Manage ........................................... 1295
Master List Preferences...................... 121
Preferences ....................................... 119
Report Style Preferences.................... 120
Restrict to Floor ............................... 1293

Restrict to Supplier .......................... 1293
Save ............................................... 1295
Saving ............................................ 1284
Subcategories ................................... 122

Max Tread Contraction .................... 554
Median................................................ 757
Menus ................................................... 38
Mesh, in Foundations ...................... 452
Message Boxes

Reset.................................................. 43
Metafile Size Dialog ........................ 1146
Metafiles .......................................... 1145
Middle Mouse Button ................. 33, 881
Missing Layer Sets Dialog ............. 1258
Mitre Ends of Angle Walls ............... 590
Model Maker

Printing ........................................... 1231
Wall Layout Template ...................... 1234

Modify
All Layer Sets.................................... 147
Name In All Layer Sets ...................... 104
Plan Database File .............................. 64

Molding
3D Molding Line tool .......................... 665
3D Molding Polyline ........................... 665
Frieze ............................................... 673
in Rooms .......................................... 359
Molding Line tool ............................... 665
Molding Polyline tool ......................... 665
Place Molding Profile ......................... 662
Polyline Specification Dialog .............. 668
Polylines ........................................... 658
Profiles ............................................. 662
Profiles, changing.............................. 667
Profiles, custom ................................ 662
Symbol ............................................. 663

Molding Polyline
Specification Dialog ........................... 668

Moldings
Built Up............................................. 663
Library .............................................. 666

Moldings Panel ................................. 659
Moldings Tab

for Rooms ......................................... 359
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Mouse
3D ...................................................... 34
Pointer Icons ....................................... 35

Mouse Buttons
Using .................................................. 33

Move
Along Rails ....................................... 287
CAD Points ..................................... 1079
Folders and Library Objects ............... 832
Nudging ............................................ 222
Object Using Dimensions ................. 1019
Objects ............................................. 220
Restrictions ....................................... 221
to be Coplanar .................................. 495
to Framing Reference ........................ 223
to Front of Group ............................... 219
Views to a Different Page ................ 1248
Walls with Cabinets Attached ............. 690

Move Point Dialog .......................... 1079
Mulled Unit

Specification Dialog ........................... 406
Mulled Units

Framing ............................................ 410
Labels ............................................ 1281
Mullion Depth .................................... 410
Treat as Door .................................... 409

Mullions
Window............................................. 416

Multiple
Copy................................................. 173
Select ............................................... 185

Multiple Copy Dialog ........................ 174
Muntins

Custom ............................................. 405
Load Custom..................................... 405
Window............................................. 416

N
Named Values ................................. 1305
New

CAD Arc Dialog ............................... 1091
CAD Line Dialog.............................. 1082
CAD Point Dialog ............................ 1077

Layer Name Dialog ............................ 151
Plans Preferences ............................. 103
Polygon Shaped Room ...................... 274

Newels
Definition........................................... 535

Newels/Balusters Tab....................... 325
NKBA

Guidelines ....................................... 1309
NKBA®

Auto Dimensions ............................. 1010
Auto Elevation Dimensions............... 1010

No Locate Wall .................................. 310
North Pointer ..................................... 943
Nudging .............................................. 222
Number Style/Angle Style

Dialog ............................................... 127

O
Object

Based Design ...................................... 31
Layer Properties ................................ 154

Object Snaps ..................................... 162
Extension Snaps........................ 118, 163
Object locations ................................. 163
Preferences....................................... 115

Objects
Distributed ........................................ 804

One-Click Stairs ................................ 535
Open

Below................................................ 336
Layout................................................. 61
Object ................................................. 41
Plan Files ............................................ 61
Symbol.................................... 842, 1195
Template Files..................................... 84
View ................................................. 922

OpenGL .............................................. 888
Openings

Dimensions to ................................... 995
Organizing

your Files ............................................ 53
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Orthogonal Views ............................ 1220
Outlets ................................................ 639

Above cabinet .................................... 640
Automatic .......................................... 641
Dishwasher........................................ 640
GFCI ................................................. 639
Manually placed ................................. 639
Place ................................................. 641
Sink................................................... 640
WP .................................................... 640

Oval ................................................... 1096
Specification Dialog ......................... 1096

Overall Dimension ............................. 999
Overhang ............................................ 489
Overview .............................................. 29

Floor ................................................. 900
Full.................................................... 900
Isometric ........................................... 901

P
Page

Down............................................... 1259
Up ................................................... 1259

Page Setup Dialog ........................... 1216
Painting

Over Materials ................................... 858
Pan

Pan Window Tool ............................... 883
the Display ........................................ 882
Using the Keyboard ............................ 882
Using the Mouse ................................ 883
Using the Scroll Bars.......................... 882

Panels
Cabinets ............................................ 701

Paragraph Options Dialog .............. 1037
Parallel Light...................................... 941
Partition Tool ..................................... 679
Pass-Through .................................... 394
Paste ................................................... 171

Hold Position ..................................... 173
in Place ............................................. 173
Special .............................................. 173

Pattern Panel..................................... 867
Patterns

Mapping............................................ 858
Patterns and Textures...................... 858
PDF ................................................... 1148

Importing ........................................ 1148
Print to............................................ 1222

Peninsula Radius Cabinets ............. 694
Personal Tutor ....................... 1308, 1312
Picture

Copy Region as............................... 1153
Picture File Box

Specification Dialog ......................... 1143
Picture Files

Export ............................................. 1141
Import ............................................. 1143
Scale .............................................. 1151

Pier/Pad
Specification Dialog ........................... 466

Piers
and Pads .......................................... 462
Foundation........................................ 451

Piers and Pads
Editing .............................................. 465

Pitch
Above Wall ....................................... 295
Show as degrees................................. 90

Place
Gable Over Window(s)....................... 396
Images ........................................... 1134
Library Object Button ......................... 838
Library Objects .................................. 836
Outlets ...................................... 337, 641

Plan
Create New ......................................... 54
Database File ...................................... 63
Drawing .............................................. 45
Files, Opening ..................................... 61
Find Plan Wizard ................................. 66
Footprint ......................................... 1119
General Defaults ................................. 88
Materials Dialog ................................ 862
Saving ................................................ 55
Templates ........................................... 84
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Trace .............................................. 1153
View ................................................... 47

Plan Check ...................................... 1130
and room labels ................................ 337
Dialog ............................................. 1131
Hold ............................................... 1131
Restart ........................................... 1131

Plan Footprint
Specification Dialog ......................... 1120

Plant
2D Symbols ...................................... 771
Chooser Dialog ................................. 767
Encyclopedia .................................... 767
Labels .............................................. 774
Specification Dialog ........................... 774
Tools ................................................ 766

Plant Image
Create .............................................. 770
Specification Dialog ........................... 770

Plinth Blocks ..................................... 378
Plot Plan

North pointer ..................................... 943
Plotters ............................................ 1213
Point

Light ................................................. 941
Markers .......................................... 1078

Point to Point
Dimensions ..................................... 1007
Move ................................................ 222
Resize ............................................ 1152

Pointer
Coordinates .................................. 43, 93
Cross Hairs ....................................... 112

Polygon
Shaped Deck .................................... 267

Polyline
3D Molding Polyline ........................... 665
Area ............................................... 1098
Definition ........................................ 1097
Edit Area .......................................... 253
Garden Bed ...................................... 726
Molding Polylines .............................. 664
Panel .............................................. 1098
Rectangular Polyline Tool ................ 1101
Room Polyline ................................... 349

Specification Dialog ......................... 1098
Polyline Intersection ........................ 248
Polyline Solid

Convert to Solid ................................. 791
Create............................................... 791
Specification Dialog ........................... 791

Polyline Subtract .............................. 248
Polyline Union ................................... 247
Ponds ................................................. 726

Round ............................................... 726
Pony Walls ......................................... 272

Align upper and lower ........................ 263
Change wall types ............................. 273
Default height .................................... 263
Dimensioning .................................... 287
Display.............................................. 272
Display Openings in ........................... 263
Show lower wall................................. 263

Post .................................................... 583
With Footing ...................................... 583

POV-Ray ............................................. 982
Preferences

Appearance Panel ............................... 92
Architectural Panel ............................ 108
Behaviors Panel ................................ 113
CAD Panel ........................................ 109
Categories Panel ............................... 122
Colors Panel ....................................... 94
Definition of ......................................... 75
Dialog ................................................. 90
Edit Panel ......................................... 111
File Management Panel ....................... 99
Folders Panel .................................... 100
Font Panel .......................................... 95
General Panel ..................................... 98
Global settings .................................... 90
Layers Panel ..................................... 104
Library Browser Panel.......................... 96
Master List Panel............................... 121
Materials List Panel ........................... 119
New Plans Panel ............................... 103
Render Panel .................................... 123
Report Style Panel............................. 120
Reset preferences ............................. 126
Ruby Panel ....................................... 102
Snap Properties Panel ....................... 115
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Text Panel .......................................... 97
Time Tracker Panel ............................ 107
Unit Coversion Panel.......................... 104

Primitive Tools .................................. 778
Box ................................................... 778
Cone ................................................. 778
Pyramid ............................................. 778
Sphere .............................................. 778

Primitives
Convert to Solid ................................. 791
Editing ............................................... 780
Face .................................................. 778

PrimitiveTools
Cylinder ............................................. 778

Print .................................................. 1211
3D Views ......................................... 1221
Across Multiple Pages ...................... 1222
Center Sheet ................................... 1220
Check Plots ........................... 1212, 1221
Clear Printer Info.......... 1213, 1215, 1314
Color or Black and White .................. 1228
Custom Sheet Size .......................... 1218
Dialog.............................................. 1226
Dimensions...................................... 1222
Drawing Scale ................................. 1212
Drivers ............................................ 1213
Layout ............................................. 1264
Line Weights .................................... 1223
Line Weights and Scaling ................. 1224
Model .............................................. 1231
Options............................................ 1215
Paper Size ....................................... 1212
Perspective Views ............................ 1221
Plotters............................................ 1213
Preview ........................................... 1219
Printable Area .................................. 1220
Scale to Fit ...................................... 1221
Services .......................................... 1265
Sheet Size ............................. 1212, 1218
Terminology ..................................... 1212
Text................................................. 1222
Tiled ................................................ 1222
To File ............................................. 1213
to PDF File ...................................... 1222
To Scale .......................................... 1220
Troubleshooting ............................... 1312

Print Image ......................................... 923

Dialog ............................................. 1229
Print Model

Wall Layout Template ...................... 1234
Print Size Calculator ...................... 1047
Printers ............................................ 1213

Select Printer ......................... 1227, 1232
Priority Support .............................. 1317
Profile Plans ........................................ 84
Program Updates

Auto Check ......................................... 98
Project

Information...................................... 1127
Project Browser .............................. 1125
Property lines.................................. 1081

North pointer ..................................... 943
Pyramid .............................................. 778

Specification Dialog ........................... 788

Q
Quoin

Specification Dialog ........................... 656
Quoins ................................................ 656

R
Radius

End Cabinets .................................... 694
of Tangent Curved Wall Dialog ........... 291

Rafter Tails ........................................ 530
Decorative Profiles ............................ 487

Rafters ............................................... 584
Barge ............................................... 597
Bearing Line...................................... 603
Blocking ............................................ 584
Depth ............................................... 500
Mixing with Trusses ........................... 622
Use Framing Reference ..................... 596

Rail Style Tab .................................... 323
Railing

Defaults ............................................ 264
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Railings .............................................. 266
Balusters .......................................... 323
Bottom Rail ....................................... 324
Cable................................................ 268
Decks ............................................... 267
Glass ................................................ 268
Half Walls ......................................... 265
in a Doorway ..................................... 373
Locate with dimensions ..................... 310
Middle Rail ........................................ 323
Newels ............................................. 325
No Rail ............................................. 323
Open ................................................ 323
Openings .......................................... 372
Solid ................................................. 323
Stairs ................................................ 553
Type ................................................. 323

Raised / Lowered Region
Specification Dialog ........................... 741

Ramp
Slope ................................................ 572
Specification Dialog ........................... 570

Ray Trace
Adjust Effects .................................... 978
Adjust Image Properties..................... 978
Aspect Ratio ..................................... 969
Assistant ........................................... 974
Bump Maps ....................................... 980
Configurations ................................... 967
CPU Usage ....................................... 125
Create .............................................. 965
Export to POV-Ray ............................ 982
Image Size........................................ 969
Multiple Views ................................... 981
Options Dialog .................................. 968
Saving Images .................................. 966
Speed, increasing ............................. 981
Window............................................. 966

Rebar
In Foundations .................................. 451

Rebuild ............................................... 479
3D .................................................... 921
Roof Framing .................................... 507
Roofs................................................ 479
Walls/Floors/Ceilings ......................... 441

Recent File List ................................. 100

Recessed
Doors ........................................ 373, 378
Windows ................................... 396, 410

Rectangular Polyline ...................... 1101
Redo ................................................... 257
Reduced Gable .................................. 633
Reference

Display Options ................................. 444
Referenced Plan Files Dialog ........ 1257
Reflect

About Object ..................................... 237
Objects ............................................. 237

Regular Polygon ............................. 1101
Relative

to Current Point, new point ............... 1077
Remove

3D .................................................... 910
Backdrop........................................... 896
Manufacturer Lock ............................. 842

Render
Added Lights ..................................... 938
Daytime Ambient ............................... 937
Graphics card .................................... 888
Interior Ambient ................................. 937
Light Fixtures .................................... 937
Light Sources .................................... 936
Nighttime Ambient ............................. 937
Preferences....................................... 123
Status ............................................... 126
Tips .................................................. 934

Rendering Techniques ..................... 951
Backdrops in ..................................... 897
Defaults ............................................ 954
Options ............................................. 954
Painting Styles .................................. 959

Replace from Library
Button ............................................... 839
Dialog ............................................... 839

Report Style Preferences ................. 120
REScheck

Export ............................................. 1192
Reset

Defaults .............................................. 87
Message Boxes ................................... 43
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Preferences ....................................... 126
Reshape objects ................................ 230
Resize

Factor.............................................. 1153
House using Dimensions .................. 1020
Objects .............................................. 229
Point to Point ................................... 1152

Restore
Toolbars ............................................ 134

Restrictions
Moving objects ................................... 221

Retain
Wall Framing ..................................... 314

Retaining Wall ................................... 728
Reverse

Plan .................................................. 238
Reverse Direction .............................. 238
Revision Cloud

Specification Dialog ......................... 1104
Revision Clouds .............................. 1104
Revision Specification Dialog ....... 1263
Revolve Object .................................. 782
Rich Text

Border Color .................................... 1038
Defaults ........................................... 1028
Specification Dialog ......................... 1034
Text Color........................................ 1035

Right Button Definition ..................... 33
Rim Joist ............................................ 586
Road

Defaults ............................................. 755
Marking ............................................. 758
Median .............................................. 757
Polyline ............................................. 757
Specification Dialog ........................... 761
Stripe ................................................ 758

Road Marking
Specification Dialog ........................... 764

Road Objects
Different Types .................................. 756

Roads .................................................. 756
Convert to Polyline Object .................. 760
Curbs ................................................ 762

Displaying ......................................... 759
Roof .................................................... 473

Automatic ......................................... 474
Baseline Polyline ............................... 504
Baseline Polyline, Example Using ...... 505
Baseline, Angled ............................... 501
Baselines .......................................... 489
Beams .............................................. 584
Birdsmouth Cut ................................. 497
Birdsmouth Depth.............................. 500
Extend Slope Downward .................... 315
Full Gable Wall.................................. 315
Groups ............................................. 477
Over this room .................................. 354
Panel ................................................ 314
Pitches in Degrees ............................ 532
Second pitch ..................................... 316
Styles, Automatic .............................. 477
Tools ................................................ 476
Truss ................................................ 616
Truss Details ..................................... 621
Truss Specification Dialog ................. 631

Roof Baseline
Specification Dialog ........................... 505

Roof Beams ....................................... 794
Roof Designer ................................... 476
Roof Hole/Skylight

Specification Dialog ........................... 519
Roof Plane

Labels .............................................. 491
Specification Dialog ........................... 498

Roof Planes ............................... 476, 489
Aligning ............................................ 493
Area ................................................. 502
Curved.............................................. 508
Delete ............................................... 498
Display ............................................. 491
Edit................................................... 492
Intersections, Locate ......................... 494
Join .................................................. 493
Low roof planes ................................. 484
Move to be Coplanar ......................... 495
Raising/Lowering............................... 495

Roof Truss
Specification Dialog ........................... 631

Roofs .......................................... 473, 479
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Auto Rebuild ............................. 479, 481
Auto Roof Return .............................. 316
Automatic vs. Manual ........................ 474
Boxed Eaves ..................................... 485
Build Roof Dialog .............................. 480
Crickets ............................................ 523
Defaults ............................................ 475
Dormers............................................ 521
Eaves, aligning.................................. 494
Edit All Roof Planes........................... 477
Energy Heel ...................................... 628
Fascia .............................................. 528
Fix Roofs Tool ................................... 477
Framing ............................................ 595
Gutters ............................................. 529
Heights ............................................. 499
Hip Trusses ...................................... 627
Hole for skylights............................... 518
Ignore Top Floor................................ 483
Knee walls ........................................ 297
Lock roof planes ........................ 484, 498
Manual ............................................. 488
Minimum Alcove Size ........................ 484
Over Alcoves .................................... 517
Over curved walls .............................. 478
Overhang .................................. 483, 489
Pitch ......................................... 295, 499
Plumb Cut Eaves............................... 485
Rafter Tails ....................................... 530
Raise off plate ................................... 484
Retain edits....................................... 501
Returns............................................. 527
Roof Group ....................................... 352
Roof Plane ........................................ 476
Shadow Boards ................................. 528
Show pitch as degrees ................ 90, 500
Skylights ........................................... 518
Soffits ............................................... 597
Square Cut Eaves ............................. 485
Step Down Hip .................................. 627
Story-and-a-half ................................ 297
Subgirders ........................................ 628
Trusses ............................................ 482
Upslope Mark .................................... 489
Vertical Rafter Depth ......................... 500

Room .................................................. 330
Defaults ............................................ 330

Molding Polylines .............................. 349
Polylines ........................................... 349
Specification Dialog ........................... 350

Room Elevation Views ..................... 904
Room Labels...................................... 337

Custom ............................................. 337
Defaults ............................................ 330
Dimension Format ........................... 1045
Display.............................................. 338
Edit ................................................... 338
Interior room area .............................. 338
Interior room dimensions .................... 338
Room area ........................................ 338
Standard room area ........................... 338

Rooms
Area.................................................. 338
Attic .................................................. 335
Auto Place Outlets ............................. 337
Below Stairs ...................................... 558
Ceiling over ....................................... 355
Editing .............................................. 333
Exterior types .................................... 335
Foundation floor definition .................. 354
Interior .............................................. 335
Interior area ...................................... 338
Interior dimensions ............................ 338
Living Area ........................................ 336
Name for PlanCheck ........................ 1131
Open Below ...................................... 336
Polygon Shaped ................................ 274
Roof over .......................................... 354
Room Definition ................................. 331
Room Types ...................................... 335
Selecting ........................................... 331
Standard area ................................... 338
The Exterior Room............................. 332
Types................................................ 335

Rotate
CAD items ......................................... 115
Jump................................................. 115
Plan View .......................................... 237

Rotate objects ................................... 234
Rough Openings ............................... 590
Round

Garden bed ....................................... 726
Pond ................................................. 726
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Window ............................................. 421
Ruby

Console ........................................... 1304
Named Values ................................. 1305

Ruby Preferences .............................. 102
Running Dimensions ...................... 1008

S
Same

Height Eaves ..................................... 483
Roof Height at External Wall ............... 483

Same Line Type edit handles......... 1083
Sample Plans

Download ........................................ 1309
Save

3D Views ........................................... 922
and Save As ....................................... 55
Layout ................................................ 56
Materials Lists ................................. 1295
Plan ................................................... 55
Plan as Template ................................ 85
Thumbnail Image ................................ 59

Saved Defaults Dialog ....................... 78
Scale

Picture Files .................................... 1151
Printing to ........................................ 1220
Terrain Data ...................................... 750
Text Size ......................................... 1047
to Fit ............................................... 1221

Schedule
Defaults ........................................... 1267
Specification Dialog ......................... 1273

Schedules
Creating .......................................... 1268
Images in......................................... 1275

Schematics, Wiring ........................... 641
Scissors Trusses............................... 630
Screen Capture Setup Dialog ........ 1154
Scroll Bars ......................................... 882
Seat

in Bay Window ................................... 427

Section Views ................................... 902
Segment Angle at Curved Wall ....... 484
Select

All..................................................... 186
Backdrop .......................................... 896
Components of Blocked Units ............ 399
Ctrl+Click .......................................... 186
Fence Select ..................................... 186
Insertion Point ................................. 1112
Library Object Dialog ......................... 838
Marquee ........................................... 185
Material Dialog .................................. 854
Multiple Objects ........................ 185–186
Next Object ....................................... 185
Objects button ................................... 183
Objects in 3D Views .......................... 920
Room................................................ 331
Same Type ....................................... 250
Selected Edge................................... 184
Shift+Click ........................................ 186
Similar Objects .................................. 184
Similar Objects Dialog ....................... 250

Select Color Dialog .......................... 875
Select Layer Dialog .......................... 153
Selection Fill Color............................. 94
Send

to Layout Dialog .............................. 1241
Views to layout ................................ 1240

Service Data Tab............................... 645
Set Angular Dimension Dialog ....... 235, 

1020
Set as Default ...................................... 76
Set Baseline Height Dialog.............. 497
Set Chamfer Distance ...................... 233
Set Fillet Radius ............................... 233
Setup

Screen Capture ............................... 1154
Shadow Boards ................................. 528
Shadows ............................................ 945
Shelf ................................................... 679
Shelf Tool .......................................... 679
Shelf/Partition

Specification Dialog ........................... 710
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Shelves in Cabinets ......................... 709
Shift Key

Marquee selection ............................. 185
Select multiple objects ....................... 186

Short Extensions .............................. 997
Shortcut Keys ............................. 37, 138
Show

Arc Centers....................................... 195
Line Weights ............................. 93, 1219
Living Area.......................................... 90
Pitch as degrees ................................. 90
Sheet.............................................. 1220
Short extensions ............................... 997

Shutters ............................................. 424
Side Windows ..................................... 36
Sidewalk ............................................ 759

Defaults ............................................ 755
SidewalkTools ................................... 756
Sill Plates .......................................... 579
Skylights .................................... 476, 518
Slab

At top of stem wall ............................. 450
Foundation........................................ 450
Monolithic,Footings ........................... 318
Pour Numbers ................................... 455
Specification Dialog ........................... 463

Slabs
and the Materials List ........................ 463
Holes ................................................ 462
Interior Footings ................................ 458
Slab Tool .......................................... 462
Tools ................................................ 462

Sliding Doors .................................... 363
Sloped Soffits ................................... 798
Snap Behaviors................................. 162

Angle Snaps ..................................... 164
Extension Snaps ....................... 118, 163
Grid Snaps........................................ 166
Hotkeys ............................................ 162
Object locations ................................ 163
Object Snaps .................................... 162
Wall Intersections .............................. 164

Snap Properties
Preferences ...................................... 115

Soffit
Defaults ............................................ 793
Specification Dialog ........................... 796

Soffits ......................................... 678, 793
Calculating Materials ......................... 795
Corner .............................................. 794
Place under ceiling ............................ 798
Place under Roof ............................... 798
Roof.................................................. 597
Sloped .............................................. 798
Special applications ........................... 794

Solid
Definition........................................... 781
Specification Dialog ........................... 790
Tools ................................................ 778

Space Planner
Toolbar Configuration ........................ 131

Space Planning ............................... 1127
Spacing

Joists ................................................ 588
Wall Framing ............................. 590, 866

Special
Shaped Cabinets ............................... 692

Specification Dialogs
3D Box .............................................. 783
3D Molding Polyline ........................... 669
Arc.................................................. 1093
Architectural Block ............................. 814
Bay/Box Window ............................... 429
Board .............................................. 1288
Bow Window ..................................... 429
Cabinet ............................................. 696
Cabinet Shelf .................................... 709
CAD Block....................................... 1115
CAD Box ......................................... 1103
CAD Circle ...................................... 1096
CAD Ellipse ..................................... 1096
CAD Oval ........................................ 1096
Callout ............................................ 1055
Camera ............................................. 924
Ceiling Plane ..................................... 512
Cone ................................................. 787
Corner Boards ................................... 655
Cross Section/Elevation Camera ........ 928
Custom Backsplash ........................... 801
Custom Countertop ............................ 712
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Cylinder ............................................. 786
Default Sun Light ............................... 950
Dimension Line ................................ 1021
Distribution Path ................................ 805
Distribution Region............................. 805
Door .................................................. 374
Dormer .............................................. 524
Driveway ........................................... 763
Electrical Service ............................... 645
Elevation Line .................................... 737
Elevation Point................................... 736
Elevation Region ................................ 737
Fireplace ........................................... 468
Flat Region ........................................ 739
Framing ............................................. 610
Hill / Valley ........................................ 740
Image .............................................. 1137
Joist Direction .................................... 602
Layered Material Polyline ................... 801
Layout Box ...................................... 1251
Library Object .................................... 844
Library Object Button ......................... 838
Light .................................................. 942
Line ................................................. 1084
Line Style ........................................ 1109
Marker ............................................. 1059
Molding Polyline................................. 668
Pier/Pad ............................................ 466
Plan Footprint .................................. 1120
Plant ................................................. 774
Plant Image ....................................... 770
Polyline ........................................... 1098
Polyline Solid ..................................... 791
Pyramid ............................................. 788
Quoins .............................................. 656
Raised/Lowered Region ..................... 741
Ramp ................................................ 570
Revision .......................................... 1263
Revision Cloud................................. 1104
Rich Text ......................................... 1034
Road ................................................. 761
Road Marking .................................... 764
Roof Baseline .................................... 505
Roof Hole/Skylight ............................. 519
Roof Plane......................................... 498
Room ................................................ 350
Schedule ......................................... 1273
Shelf/Partition .................................... 710

Slab.................................................. 463
Soffit................................................. 796
Solid ................................................. 790
Sphere.............................................. 785
Sprinkler ........................................... 775
Stair Landing..................................... 573
Staircase .......................................... 559
Sun Angle ......................................... 946
Symbol ........................................... 1195
Terrain .............................................. 732
Terrain Break .................................... 743
Terrain Feature ................................. 741
Terrain Path ...................................... 745
Text ................................................ 1041
Truss Base ....................................... 626
Wall .................................................. 308
Wall Hatch ........................................ 328
Window............................................. 406

Speed
3D View Generation .......................... 962
3D views ........................................... 894

Spell Check ..................................... 1050
Sphere ................................................ 778

Specification Dialog ........................... 785
Splines ............................................. 1106

Advanced Splines.............................. 213
Control Handles ................................ 213
Lock Control Handle Angle ................ 214

Split
Level Entries ..................................... 442
Level Floor Plans .............................. 442
Walls ................................................ 276

Spot Light .......................................... 941
Sprinkler

Designer ........................................... 774
Specification Dialog ........................... 775
Tools ................................................ 774

Stacked Windows ............................. 396
Stair

Landing Specification Dialog .............. 573
Sections Move Independently ............ 108
Tools ................................................ 535

Stair Designer ................................... 535
Stair Landing

Specification Dialog ........................... 573
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Stair Landings
Custom Shapes ................................. 544
Height............................................... 544
Locked.............................................. 545

Stair Railing
Middle Rail ........................................ 555
Panels .............................................. 555
Partial ............................................... 553
Solid ................................................. 554

Stair Treads
Automatic ......................................... 560
Depth ............................................... 561
Lock Number..................................... 560
Lock Tread Depth .............................. 560
Number............................................. 562
Overhang .......................................... 564
Thickness ......................................... 564

Staircase
Specification Dialog ........................... 559

Stairs
Align Curved Stairs............................ 229
Auto Stairwell .................................... 557
Balusters .......................................... 566
Change Line/Arc ............................... 542
Click ................................................. 535
Concrete ........................................... 556
Curved...................................... 535, 537
Curved Treads .................................. 550
Deck to ground.................................. 538
Direction ........................................... 537
Down ................................................ 538
Edit Handles ..................................... 540
Editing .............................................. 540
Flare Radius ..................................... 548
Flared ............................................... 547
Handrails .......................................... 569
Landings ........................................... 543
Landings, unlocked ........................... 545
Large Stringer Base .......................... 564
Lock Tread Depth .............................. 547
Make Reach ...................................... 559
Masonry............................................ 556
Merge Sections ................................. 541
Newels ..................................... 566, 568
Railings ............................................ 553
Reach Next Floor .............................. 559
Rooms Below .................................... 558

Section Width .................................... 561
Stairwell ............................................ 556
Starter Treads ................................... 550
Straight ............................................. 535
Stringers ........................................... 563
Stringers, steel .................................. 556
Subsections .............................. 547, 559
Symmetrically Flared ......................... 548
Terminology ...................................... 535
Tread Depth ...................................... 546
Treads .............................................. 559
Walk Line .......................................... 546
Winders .................................... 551, 562
Wrapped ........................................... 552

Stairwell
Automatic .......................................... 557

Startup Options ................................... 30
Static Views ..................................... 1243
Status Bar ...................................... 42, 93

Angle style ........................................ 127
Steel

Framing ............................................ 608
Stem Walls ......................................... 450

Align ................................................. 458
and Footings, Align ............................ 458

Stepped Foundations ....................... 462
Stepping Stones................................ 727
Stick Framing

Mixing with Trusses ........................... 622
Sticky Mode ....................................... 172
Story Pole ........................................ 1011
Story-and-a-half ................................ 297
Straight

Deck Edge ........................................ 267
Stairs ................................................ 535

Streams .............................................. 727
Structural Member Reporting ........ 1286
Stud

Spacing..................................... 590, 866
Thickness.......................................... 590

Subgirders ......................................... 628
Sun

Shadows ........................................... 729
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Sun Angle ........................................... 943
Create ............................................... 944
Render Data ...................................... 948
Specification Dialog ........................... 946

Swap
Views ................................................ 883
Work-Reference ................................. 446

Switch
Three way ......................................... 642

Symbol
Bounding Box .................................. 1208
Bounding box size ............................ 1202
Convert to........................................ 1206
Custom 2D ...................................... 1113
Editing Custom ................................ 1207
Faces .............................................. 1197
Get Last Symbol .............................. 1206
Insertion point .................................. 1197
Moldings ............................................ 663
Open Symbol ................................... 1195
Options............................................ 1200
Origin .............................................. 1197
Reset origin ..................................... 1197
Resizing .......................................... 1202
Setback space ................................. 1208
Smoothing Angle.............................. 1198
Specification Dialog ......................... 1195
Surface Normals .............................. 1183
vs. Native Objects .............................. 841

T
Tab Key ............................................... 185
Tabs

Columns in Text ............................... 1043
Text................................................. 1043

Tangent
Curved walls .............................. 291, 294
Make arc, edit button.................. 291, 294

Tape Measure................................... 1009
Technical Support ................. 1311, 1319

Contact............................................ 1316
Error Messages ............................... 1315
Hardware Lock Issues ...................... 1313
Installation Issues ............................ 1312

Online ............................................. 1317
Online Articles................................. 1317
Priority ............................................ 1317
Telephone....................................... 1317

Template Files..................................... 84
Template Layout

Creating .............................................. 85
Template Plan

Creating .............................................. 85
Templates

Layout Page.................................... 1261
Temporary

CAD Points ..................................... 1076
Dimension Defaults ......................... 1003
Dimensions ..................................... 1008
File Directories .................................. 101

Temporary Dimensions .................. 1008
Terrain

and 3D Draw Time............................. 730
Auto Rebuild ..................................... 730
Breaks .............................................. 722
Build ................................................. 730
Clear ................................................ 718
Contour Lines ................................... 729
Contour Smoothing............................ 734
Contours Panel ................................. 733
Displaying ......................................... 729
Editing .............................................. 731
Elevation Data Tools ......................... 719
Feature Tools .................................... 724
Flat Region ....................................... 724
Grow All Plants Dialog ....................... 766
Hill.................................................... 724
Holes ................................................ 725
Modifier Tools ................................... 723
Specification Dialog ........................... 732
Sprinkler Tools .................................. 774
Sun Shadows .................................... 729
Toolbar Configuration ................ 131, 716
Valley ............................................... 724
Wall and Curb Tools .......................... 727

Terrain Break
Specification Dialog ........................... 743

Terrain Data
Convert CAD Lines to ........................ 754
Import ............................................... 747
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Terrain Feature
Specification Dialog ........................... 741

Terrain Features
Clip................................................... 741
Height............................................... 741

Terrain Modeler
3D Views .......................................... 730
Clear Terrain ..................................... 718

Terrain Path
Specification Dialog ........................... 745

Terrain Perimeter .............................. 716
Text

Add to Dimension Label ................... 1018
Aligning .......................................... 1048
Arrows ............................................ 1051
Bullets ............................................ 1037
Character Size ................................ 1030
Convert Simple to Rich .................... 1047
Copy, Cut and Paste ....................... 1048
Creating.......................................... 1032
Defaults .......................................... 1029
Displaying ....................................... 1033
Edit in Place.................................... 1047
Editing ............................................ 1045
Layer .............................................. 1033
Layout ............................................ 1238
Leader Lines ................................... 1052
Line Spacing ................................... 1037
Lists ............................................... 1037
Macros ........................................... 1064
Maximum Characters ....................... 1033
Move .............................................. 1046
Numbering ...................................... 1037
Paragraph Options .......................... 1037
Printed Size .................................... 1047
Printing ........................................... 1222
Reshape ......................................... 1046
Resize ............................................ 1047
Rotate ............................................ 1046
Scaling ........................................... 1047
Specification Dialog ......................... 1041
Spell Check .................................... 1050
Tab Spacing........................... 1043, 1049
Tabbed Objects ............................... 1049
Tables ............................................ 1049

Text Macro Management ................ 1066

Text Macros
Edit User Defined ............................ 1067
Exporting ........................................ 1068
Importing......................................... 1068
User Defined ................................... 1065

Text Style Defaults Dialog ............. 1062
Text Styles ....................................... 1061
Texture

Filename Conflict Dialog .................. 1188
Panel ................................................ 869

Textures ............................................. 935
Convert to Materials........................... 858
Mapping ............................................ 858
View ................................................. 869

Thumbnails .......................................... 59
Creating .............................................. 59
Enable .............................................. 100
Size .................................................. 100

Tiling Views ....................................... 884
Time Log Dialog .............................. 1124
Time Tracker .................................... 1123

Preferences....................................... 107
Time Log Dialog .............................. 1124

Title Blocks ...................................... 1261
Toolbars ............................................... 37

Add Tools.......................................... 136
Configurations ................................... 131
Customize ......................................... 135
Delete Tools ...................................... 132
Drop-Down ........................................ 129
Edit ..................................................... 37
Hide .................................................. 129
Lock.................................................. 133
Parent-Child ...................................... 129
Restore ............................................. 134

Transform/Replicate Object Dialog 243
Transom Windows ............................ 372
Transparency

Color............................................... 1140
Treated

Lumber ............................................. 612
Sill Plates .......................................... 579

Trim
Door ................................................. 368
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Window ............................................. 405
Trim Objects ...................................... 245
Trimmers ............................................ 591
Truss

Base ................................................. 623
Details ............................................... 621
Envelope ........................................... 620
Spacing ............................................. 599

Truss Base
Specification Dialog ........................... 626

Trusses ....................................... 482, 597
Attic trusses ....................................... 629
Ceiling Steps ..................................... 630
Copy ......................................... 616, 618
Create ............................................... 616
Details ............................................... 621
Double .............................................. 628
Drop Hip truss.................................... 633
Edit ................................................... 619
End truss ........................................... 633
Energy Heel ....................................... 628
Floor and Ceiling................................ 616
Force Truss Rebuild ........................... 633
Force truss rebuild ............................. 635
Girder ................................................ 631
Hip .................................................... 627
Hip jack ............................................. 627
Jack .................................................. 627
Kingpost ............................................ 632
Labels ............................................... 621
Laying out.......................................... 616
Lock Envelope ................................... 633
Member Depth ........................... 632, 635
Mixing with Rafters............................. 622
Reduced Gable .................................. 633
Roof .................................................. 616
Scissors ............................................ 630
Shape, editing.................................... 620
Spacing ............................................. 599
Special Snapping ....................... 633, 636
Step Down Hip ................................... 627
Subgirders ......................................... 628
Truss Base ........................................ 623
Webbing .................................... 632, 635

U
Undo ................................................... 257

Files ................................................... 61
Preferences ........................................ 98
Undo Zoom ....................................... 881

Unit Conversions .............................. 104
Unrestricted Movement.................... 221
Updates

Auto Check ......................................... 98
Use Layout Line Scaling ................ 1242

V
Valley ................................................. 724
Vaulted Ceilings ............................... 347
Vents .................................................. 396
Video Card

Memory ............................................ 888
OpenGL ............................................ 888
Status ............................................... 126

Videos
View Online Help Videos ................. 1308

View
to CAD............................................ 1118

Views
Static and Dynamic ......................... 1243
Tiling ................................................ 884

Virtual Graph Paper ............................ 88
Virtual Reality Modeling Language ......

1164
Visual CAD Snaps............................... 88
Volume

Of a Polyline ................................... 1098
VRML ................................................ 1164

Export ............................................. 1164
Textures and Images ....................... 1165

W
Walk Line ........................................... 546
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Walkthroughs .................................. 1158
Along a Path ................................... 1158
Codecs ........................................... 1162
Create Path .................................... 1158
Key Frames .................................... 1159
Pause Recording ............................. 1161
Playing ........................................... 1161
Recording ....................................... 1161
Save Frame .................................... 1161
Stop Recording ............................... 1161
VRML ............................................. 1164

Wall
Assemblies ....................................... 302
Blocking............................................ 590
Bridging ............................................ 583
Cabinets ........................................... 678
Defaults ............................................ 262
Detail Views ...................................... 605
Elevation .......................................... 898
Layer Fill Style .................................. 306
Specification Dialog ........................... 308
Tools ................................................ 264
Type Definitions Dialog ...................... 305
Types Tab......................................... 319

Wall Elevation ................................... 903
Wall Framing

Staggered ......................................... 314
Wall Hatch

Specification Dialog ........................... 328
Wall Type Definitions Dialog........... 305
Walls

Align between floors .......................... 293
Align collinear ................................... 292
Align pony walls ................................ 263
and Material Painter .......................... 851
Attic Walls......................................... 297
CAD to Walls .................................... 300
Compound Raked.............................. 299
Connecting ....................................... 279
Curved.............................................. 278
Curved, align between floors .............. 293
Delete hatching ................................. 275
Dimensioning to ................................ 303
Display surfaces only......................... 281
Double walls ..................................... 299
Drawing ............................................ 276

Editing .............................................. 285
Exporting Definitions .......................... 308
Exterior and Interior ........................... 269
Fill styles........................................... 306
Fix Connections................................. 280
Flip layers ......................................... 277
Footing size ...................................... 318
Foundation ........................................ 269
Foundation thickness ......................... 317
Framing ............................................ 589
Framing Detail Views ......................... 605
Framing Layer ................................... 302
Full Gable Wall .................................. 315
Furred Walls...................................... 300
Grid snapping .................................... 277
Half................................................... 323
Half Walls ......................................... 265
Hatching ........................................... 275
Heights ............................................. 288
Importing Definitions .......................... 308
Interior, fireplace in ............................ 467
Invisible ............................................ 273
Knee Wall ......................................... 315
Layer fill style .................................... 306
Layers............................................... 302
Layers, Resize About ......................... 261
Length .............................................. 288
Main Layer ........................................ 302
Make Arc Tangent ............................. 294
Marriage walls ................................... 299
Materials ........................................... 282
Move Along Rails............................... 287
No Locate ......................................... 310
No Room Def .................................... 310
Opening with Railing .......................... 373
Openings in ....................................... 278
Pony Wall.......................................... 272
Pony wall height ................................ 263
Raked ............................................... 298
Removing Breaks .............................. 280
Resizing Using Dimensions .............. 1020
Retain wall framing ............................ 314
Retaining Wall ................................... 728
Reverse Layers ................................. 277
Roofs over curved ............................. 478
Same Wall Type handles ................... 290
Show length when editing .................. 261
Show lower pony wall ........................ 263
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Solid Railings..................................... 323
Split .................................................. 272
Stepped ............................................. 298
Thickness .......................................... 287
Wall Coverings................................... 320
Widths, Dimensioning ....................... 1022

Water Features .................................. 726
Water Proof Outlet ............................ 640
Webbing

Thickness .......................................... 635
Winders ...................................... 551, 562

Definition ........................................... 535
Window

Casing ............................................... 405
Casing, reveal.................................... 412
Defaults ............................................. 392
Seat .................................................. 427
Specification Dialog ........................... 406
Trim .................................................. 405

Windows
Bay and Bow dimensions.................... 426
Bay, Box, Bow ................................... 425
Bench Seat ........................................ 427
Component ................................ 393, 426
Corner ............................................... 395
Custom Muntins ................................. 405
Custom Symbols ................................ 396
Egress ............................................... 409
Framing ............................................. 590
Gables Over ...................................... 515
Labels ............................................... 403
Levels ............................................... 400
Library ............................................... 394
Load Muntins ..................................... 405
Make Mulled Unit ............................... 397

Match roof ........................................ 419
Minimum Separation .......................... 392
Mulled Units ...................................... 397
Mullions ............................................ 416
Muntins............................................. 416
Opening Indicators ............................ 402
Pass-Through ................................... 394
Recessed.................................. 396, 410
Shape ............................................... 418
Shutters ............................................ 424
Special Shapes ................................. 395
Stacked ............................................ 396
Stained glass material ....................... 396
Standard ........................................... 393
Transom ........................................... 372
Trapezoid ......................................... 418
Treatments ....................................... 422
Types ............................................... 392
Vents ................................................ 396

Windows Metafiles ......................... 1145
Wiring Schematics, Creating .......... 641
Wrapped

Openings .......................................... 372
Stairs ................................................ 552

Z
Zero

in Dimensions ................................... 990
Zoom .................................................. 881

Fill Window ....................................... 882
Mouse Wheel .............................. 34, 881
Tools ................................................ 881
Undo Zoom ....................................... 881
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