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Chapter 1
 

Program Overview

Chief Architect is specifically designed for the residential and light commercial design professional. It allows you to easily 
and  efficiently produce 3D models and construction documents for your projects. We thank you for choosing Chief 
Architect and wish you the best in your design work.
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Chief Architect Premier vs Interiors
Not all of the features described in this document are available in the Interiors version of Chief Architect.            

For a list of the features in each program, visit our website, chiefarchitect.com.          

 

Dashboard
When Chief Architect opens, the Dashboard window displays, allowing you to choose how you want to begin 
working in the program or access useful resources. The Dashboard can also be opened at any time by selecting File> 

Dashboard.

You can control whether the Dashboard automatically opens and closes in the Preferences dialog. See General Panel on 
page 107.   
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New/Open File

Select a File command to open a .plan or .layout file.

 l Click New Plan  or New Layout  to open a new, blank file. See Creating a New Plan or Layout on page 38.         

 l Click New from Template  to open a new, blank plan based on a template that you select. See Template Files on 

page 87.         

 l Choose Open Plan  or Open Layout  to work on an existing or layout file.               See Opening and Importing Files 

on page 44.

 
Recent Files

The full pathnames of the most recently opened files are listed here. Click on a name to open the file. You set the number of 
files in this list in the Preferences dialog. See General Panel on page 107.

Move your mouse pointer over a name to see the file’s full 
pathname. 

 
Getting Started & Resources

A selection of useful online Getting Started options and Resources are available here. Click on an option to launch your 
default internet browser to chiefarchitect.com.   

 l Click Getting Started to visit the Getting Started page on our website with links to a variety of resources to help 
you begin using the program.

 l Click Training Videos to access a searchable collection of videos focused on specific topics.   

 l Click Download Catalogs to visit our 3D Library of downloadable bonus and manufacturer library catalogs. See 
Library Content on page 969.         

 
Announcements

When an internet connection is available, the Announcements section displays updated messages and news from Chief 
Architect. 

 
My Account

Click My Account to launch your default internet browser to the My Account page on our website. If you are not currently 
logged in, you will instead go to the Login page.

 
Build & Product Key

Your software version’s Build number and the first five characters of your Product Key display here for reference. If your 
software license has an expiration date, it will also display here. See License Expiration.

 

The Chief Architect Premier Environment
Chief Architect is designed to be intuitive and efficient.          

3D DRAFTING

In Chief Architect, the drawing area is laid out on a Cartesian grid, a three dimensional coordinate system described using 
the X, Y, and Z axes. The current position of your mouse pointer displays in the Status Bar at the bottom of the program 
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window.         

Architectural objects take up space in all three dimensions and their height, width and depth can be specified in U.S. or 
metric units. In addition, the location of objects can be precisely defined using coordinates, again specified in U.S. or metric 
units.         

CAD objects such as lines and arcs take up space in two dimensions in the current view. Their dimensions can also be 
specified in U.S. or metric units and their locations precisely defined using coordinates.         

Objects can be rotated relative to the Cartesian grid system, as well. When the program presents the option to rotate to an 
Absolute Angle, this angle will be measured relative to an imaginary horizontal line drawn in floor plan view from the 
origin in the positive X direction.           

EASY ACCESS TO TOOLS

You can access Chief Architect’s features in various ways using the mouse and keyboard. 

 l Convenient toolbar buttons allow fast access to frequently-used tools and let you customize the interface.             
 l Menus provide access to most tools and settings.             
 l Keyboard shortcuts are available for most tools and can be customized.             
 l Contextual menus display with a right-click of the mouse.             
 l The Status Bar on page 25 at the bottom of the screen provides tool descriptions and other information about the 

current task.             

OBJECT-BASED DESIGN

Chief Architect’s parametric, object-based design technology means you place and edit objects, rather than work with the 
many individual lines or surfaces used to represent them.          

You can quickly select and edit the location, size, shape, style and other properties of objects as well as change the materials 
applied to their surfaces.          

Use Chief Architect’s editing capabilities to make the objects you place in a plan match the objects they represent in real 
life. For example, you can set up your windows and doors to match those available from your supplier.          
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INTERFACE TOGGLES

A number of useful drawing and editing behaviors, as well as the display of important elements in the interface, can be 
easily enabled and disabled using the menus and toolbars.

 l Object Snaps, Angle Snaps, and Grid Snaps can be toggled on or off as needed. Individual Object Snaps and Extension 
Snaps can be toggled as well. See Snap Behaviors on page 163.             

 l Display Elements like Print Preview, Show Line Weights, and the Reference Display can be turned on when needed 
and then toggled off.             

 l Special Edit Behaviors can be enabled for particular tasks, then replaced by the Default Behavior. See Defaults, 
Preferences, and Edit Behaviors on page 208.             

When a setting is turned on, or a tool is selected, its  toolbar icon will be shaded and a small check is displayed at its lower 
right corner. In Windows its menu icon will appear the same, but in Mac OS only a large check will be displayed to the left 
of the icon.

Menu in Windows

Menu in Mac OS

Many of these interface elements are global Preferences while others are file-specific default settings. See Default Settings 
vs Preferences on page 76.   

 

Using Input Devices
You can interact with Chief Architect using a variety of input devices. 

KEYBOARD

A keyboard is necessary for entering text and size values. See Dialogs on page 19.

Your keyboard can also be used to navigate the dialog panels, as well as navigate the program menus. Many commands can 
also be invoked using keyboard hotkeys. See Menus, Toolbars, and Hotkeys on page 18.

In addition to the keyboard, a mouse or other device that can move a pointer is necessary in order to draw, select, and edit 
objects in your drawings. 

THREE BUTTON MICE

Left Button
The left button is the primary button used in Chief Architect. Unless specified otherwise, Chief Architect 
documentation refers to the left mouse button.
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Many objects, such as doors and cabinets, are created by clicking the left mouse button. Others, such as walls, stairs and 
dimension lines, are created by dragging the pointer from one end of the object to the other.   

Note: If you are left-handed and have re-programmed your mouse, 
reverse the instructions for left and right buttons in this manual. 

Right Button
The right button has several uses:

 l Right-click to select any object. If, for example, the Straight Exterior Wall  tool is active, the left mouse button 

only allows you to select walls. You can, however, select other types of objects such as cabinets with the right mouse 
button.             

 l Use the right mouse button to temporarily switch to the Alternate edit behavior. See Defaults, Preferences, and Edit 
Behaviors on page 208.              

 l You can also use the right mouse button to open a context sensitive menu with additional editing commands. See 
Contextual Menus on page 19.             

Middle Button
The middle button can be used to pan in most view types or to temporarily use the Move edit behavior. To close a 
tabbed view window, click on its tab using the middle mouse button. You can also program it to work as a double-
click.

If your mouse does not have a middle mouse button, in the Mac version of Chief Architect you can use the left button and 
the Command key to achieve the same results.

Mouse Wheel
The mouse wheel can be used to zoom in and out in most view types. See Zoom Tools on page 157.

The Back, or X1, button on a 5-button mouse can be used to temporarily enable the Concentric edit behavior. See the 
documentation for your mouse.    

The Forward, or X2, button on a 5-button mouse can be used to temporarily enable the Resize edit behavior. See the 
documentation for your mouse.    

             3D MICE

3Dconnexion®'s 3D mice can be used to navigate in Chief Architect. For information about navigating in camera views and 
overviews, see 3Dconnexion® 3D Mice on page 1100.

TRACKPADS

In addition to the standard trackpad gestures on your system, in Chief Architect you can pinch to zoom.

In macOS™, you can Option + click to pan. Panning with a trackpad is not supported in the Windows version of the 
software, however. 

TOUCH SCREENS

Standard one-finger touch screen gestures are supported in both the Windows and Mac versions of the software. In the 
Windows version, touching with a second finger to cancel an action is also supported, as are two-finger pan and two-finger 
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pinch to zoom. 

You can set the Pinch Zoom Sensitivity for both trackpads and 
touch screens in the Preferences dialog. See General Panel on 

page 107.

GAMEPADS

In the Windows version of Chief Architect, gamepads can be used to navigate in camera views, overviews, as well as 
elevation views. See Gamepads on page 1100.

CROSSHAIRS

Crosshairs help you position the pointer relative to objects in a view while drawing and editing. They can be set to 
display in Plan and Cross Section/Elevation views and CAD Details, and in Perspective and Orthographic camera 

views. Select View> Crosshairs to toggle crosshairs on or off in the current view type.

You can customize the Crosshairs’ appearance    and control their display in different view types in the Preferences dialog. 
See Edit Panel on page 119.

POINTER ICONS

The appearance of the pointer or cursor in Chief Architect will vary, depending on which tool is active. For example, when 
the Select Objects  tool is active, it will look like a white arrow, and when a Cabinet Tool  is active, it will look like 

a base cabinet with a small cross.

In addition, one or more additional icons may follow the pointer if a recommended setting is not in use or if a problematic 
condition exists in the file:     

Icon Reason

Angle Snaps has been disabled.
See Angle Snaps on page 166.

The Alternate Edit Behavior has been selected.
See Alternate on page 209.

The Move Edit Behavior has been selected.
See Move on page 209.

The Resize Edit Behavior has been selected.
See Resize on page 210.

The Concentric Edit Behavior has been selected.
See Concentric on page 210.

The Fillet Edit Behavior has been selected.
See Fillet on page 211.

Connect CAD Segments has been disabled.
See Connect CAD Segments on page 212.

The Rotate/Resize About Current Point Edit Behavior has been selected.
See Rotate/Resize About Current Point on page 212
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Icon Reason

Auto Rebuild Terrain has been disabled.
See Auto Rebuild Terrain on page 1252

Rebuild Walls, Floor and Ceilings has been disabled.
See Rebuilding Walls, Floors and Ceilings on page 748

A bad wall connection has been detected.
See Fix Wall Connections on page 365

An irregular wall angle has been detected.
See Wall Angles on page 362

A reversed wall has been detected.
See Reverse Layers on page 373

You can turn off the display of these informative pointer icons in the Preferences dialog if you wish. See Behaviors Panel 
on page 120.

 

View and Side Windows
Chief Architect Premier’s main program window has a number of important features that let you interact with the program, 
such as toolbars and menus. It also features two different kinds of windows: view windows and side windows.         

VIEW WINDOWS

View windows are sometimes referred to as “the drawing area” because most of them are windows in which you can draw 
or place architectural and/or CAD objects. There are a number of different types of view windows in Chief Architect:

 l Plan views
 l Camera views and overviews
 l Cross section/elevation views
 l CPU Ray Trace views         
 l CAD Details         
 l Materials Lists         
 l Layout         

View windows can be navigated by panning and zooming. You can also enable scrollbars on their right side and bottom. 
Select View> Scrollbars  to toggle their display. See View Tools on page 156. 

Although only one view window can be active at any given time, there is no limit to the number of view windows that can 
be open. View windows can be tiled or tabbed, and you can navigate between them in a number of different ways. See 
Window and View Tools on page 148.

You can also tear a view window out of the main program window. This creates a second, separate program window 
complete with toolbars and menus.  Individual view windows can be torn out and transferred between program windows. 

SIDE WINDOWS

Side windows provide access to a variety of tools, content, and information that helps you organize and add detail your 
drawings.         
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Side windows are so-named because they are typically docked to either the left or right side of the program window - 
although, they can also be docked to the top or bottom, or undocked entirely.  There are several different side windows in 
Chief Architect:         

 l Child Tool Palette on page 134
 l The Library Browser on page 962
 l Project Browser on page 58
 l Active Layer Display Options on page 190
 l Walkthrough Previews on page 1210

Each of these side windows can be opened via the View menu or by clicking the toolbar button associated with it. Similarly, 
each can be closed by clicking the Close button in its title bar or tab, via the View menu, or by clicking its toolbar button. 
See View Tools on page 156.         

To undock a side window, either drag its title bar out into the drawing area or click the Undock button on its title bar. To 
dock a side window, drag its title bar to any side of the program window. You can also double-click on its title bar to return 
it to its last docked location.         

Two or more side windows can be docked together to form a shared side window, and can be tiled and/or tabbed within that 
shared window. To create a shared side window, begin by docking a side window to a side of the main program window, 
then:         

 l To create tabbed side windows, drag a second side window over the first. When the docked window becomes 
highlighted, release the mouse button.         

 l To create tiled side windows, drag a second side window over the first. When the docked window becomes 
highlighted, slowly drag the mouse towards one of its sides. When a highlighted space is created along that side, 
release the mouse button.         

You can choose to disable Side Window Drag Docking in the Preferences dialog, and you can also enable Top/Bottom 
Docking. See Appearance Panel on page 99.         

Side windows can also be set to their initial states in the Preferences dialog. See Reset Options Panel on page 131.         

 

Menus, Toolbars, and Hotkeys
Chief Architect's drawing, editing, and view tools can be accessed via menus, toolbar buttons, and keyboard hotkeys.

PROGRAM MENUS

Chief Architect's program menus are located below the title bar in the program window and can be used to access nearly all 
tools in the program. Click on a menu name to expand it, then click on a menu item to either activate that tool or access the 
item’s submenu. Items with a submenu have an arrow to the right of the name.

In the Chief Architect documentation, menu paths are written in this format: Tools> Floor/Reference Display> Up One 
Floor .

The menus can be accessed using the keyboard:

 l Press the Alt key once to enable this functionality - one letter in each menu will become underlined.
 l Press the key associated with one of these underlined letters to expand its menu - one letter in each menu item’s name 

will be underlined. Press the key associated with one of these letters to activate that tool or access the item’s submenu.
 l Press the Esc key to undo your last selection, or click with the mouse to exit out of this functionality. 
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Menu items with an icon to their left have a toolbar button associated with them. In addition, many tools can also be 
activated using keyboard hotkeys. If a menu item has a default hotkey, it will display to the right of the item’s name. 

Edit menu items with button icons to the left 
and hotkeys to the right

TOOLBARS AND HOTKEYS

Chief Architect installs with a set of toolbars docked to the margins of the program window. Using these toolbar buttons is a 
fast and easy way to access many program features. If a tool is active, a small check mark will display at the lower right of 
its button icon. See Toolbars and Hotkeys on page 133.

The Edit Toolbar is a special toolbar with buttons that can be used to modify a selected object or objects. The buttons on 
this toolbar vary, depending on the type(s) of object selected, the current view, and how you selected the object; when no 
object is selected, the Edit Toolbar is blank. See The Edit Toolbar on page 135.

You can move the toolbars, customize them by adding or removing buttons, or create your own toolbars from scratch. See 
Toolbar Customization Dialog on page 139.

Many tools also have a keyboard hotkey associated with them. Hotkeys are customizable and can be created for tools that 
do not have one by default. See Hotkeys on page 142.

CONTEXTUAL MENUS

Contextual menus are context-sensitive menus that display tools relevant to a selected object or view. To open a contextual 
menu, right-click on an object, in an empty space in a view window, on a line item in the Library Browser or Project 
Browser, or in a text field in a dialog box.

Contextual Menu for Plan Views

The options in an object’s contextual menu are usually the same as those on an object’s Edit Toolbar. See The Edit Toolbar 
on page 135.

Contextual Menu for a selected 

Contextual menus can be enabled or disabled in the Preferences dialog. When contextual menus are disabled, right-clicks 
perform generic object selection, much like when the Select Objects  tool is active. See Appearance Panel on page 99.         

 

Dialogs
Default and preference settings, object specifications, display settings, and many other functions are accessed through dialog 
boxes. 
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Note: Some of the dialog box images in the software documentation have 
been resized smaller than their actual minimum size. 

DIALOG PANELS

Many dialogs have multiple panels, which are listed in a tree list on the left side of the dialog. Click on a panel name in the 
list to make it active. In Windows, panels can also be navigated using the keyboard. Press:         

 l Ctrl + Tab or Ctrl + F6 to navigate forward;           
 l Ctrl + Shift + Tab or Ctrl + Shift + F6 to navigate backward.           

When a panel name is actively selected in the list, you can also navigate the tree list using the Up and Down arrow keys.          

By default, dialogs always open to the first panel in the list; if you prefer, you can choose to Open Dialogs to the Last 
Panel Visited. See General Panel on page 107.         

UNITS AND MATH OPERATIONS IN DIALOGS

The units of measurement used in dialogs are determined by your choice of template files. See Creating a New Plan or 
Layout on page 38.    

The number format used in dialogs are set based on your operating system’s defaults. See Region and Language Settings on 
page 78. You can change the number format as well as the angle format in the Dialog Number Style/Angle Style dialog. See 
Dialog Number/Angle Style Dialog on page 131.

Basic addition, subtraction, multiplication, and division can be performed in the text boxes where numeric values are 
entered.         

Note that settings for angle, pitch, or bearing do not support math, nor do those with spin controls or slider bars.         

 l To add, type the + character followed by the amount that you wish to add. Spaces are ignored and including a unit of 
measurement is optional.             

 l To subtract, type the - character followed by the amount you wish to subtract. As with adding, spaces are ignored and 
a unit of measurement is optional.             

 l To multiply, type the * character followed by the amount you wish to multiply by. Spaces are ignored, and only one of 
the values being multiplied can have a unit of measurement.             

 l To divide, type the / character followed by the amount you wish to divide by. To divide, there must be a space before 
the / - if there is not, the input may be treated as a fraction. The denominator, or value typed after the /, cannot have a 
unit of measurement.             

Math expressions support a single operation only: more than one operation character (+, -, *, /) at a time is not allowed.         

Basic math operations can also be used to move objects using dimensions. See Moving Objects Using Dimensions on page 
491. 

ELEVATION REFERENCES IN DIALOGS

A variety of different architectural objects can be placed at a particular elevation in the 3D drawing space. That elevation 
can be set relative to a number of different references; the options available may vary depending on the object type:
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 l Absolute is measured from Z = 0. See 3D Drafting on page 12.
 l From Floor is measured relative to top of the Floor Structure at the object's location. See Floor and Ceiling Heights 

on page 431.                 
 o If the object is not in a room, it is measured relative to the default Floor Height for its Floor Level. See Multiple 

Floors on page 743.
 o If the object is not in a room and is on the same Floor Level as the Terrain, it is instead measured relative to the 

Terrain.
 l From Finished Floor is measured relative to the object to  the surface of the Floor Finish at the object's location.     

 o If the object is not in a room, it is measured in the same manner as From Floor.
 l From Terrain is measured relative to the object to the surface of the terrain at the object's location. See Terrain on 

page 1249.                 
 o If no terrain is present, it is measured relative to the default Floor Height for its Floor Level. 

 l From Ceiling is measured relative to the object to the Ceiling surface at the object's location.                 
 o If the object is not in a room, it is measured relative to the default ceiling height for its Floor Level.

 l From Roof  is measured relative to the object to the Roof surface at the object's location. See Roofs on page 803.                 
 o If the object is not in a room, it is measured relative to the default ceiling height for its Floor Level.

DIALOG SIZE AND POSITION

Dialog boxes can be both moved and resized to suit your needs. By default, the program will remember both the position 
and size that you specify for a dialog and use it the next time you open it. The size of dialog preview panes can also be 
changed, and are remembered as well. You can specify whether the program does this always, per session, or never in the 
Preferences dialog. See General Panel on page 107.         

 l To move a dialog, position your mouse pointer within its title bar and then simply click and drag.             
 l To resize a dialog, position your mouse pointer on any edge or corner and then click and drag outward or inward. If 

you drag an edge, only that edge will move; if you drag a corner, the two adjacent edges will move.             
 l To resize a preview pane, click and drag the vertical grab handle to its left. See Dialog Panel Splitters on page 22, 

below.             

When a dialog is resized, some elements such as list boxes and text fields within it may resize in response.         

All dialogs have a minimum size limitation but no maximum size. If a dialog opens on a monitor with resolution too low to 
display its full extents, it will have vertical and/or horizontal scrollbars.         

You can reset the default sizes and positions of all dialogs in the Preferences dialog. See Reset Options Panel on page 131.         

SPECIFICATION DIALOGS

Each object in Chief Architect has a unique specification dialog where you can enter size, style and other information 
specific to the selected object. To access it, select the object and click the Open Object edit button.

You can also double-click on an object with the Select Objects  tool active to open its specification dialog. See Selecting 

Objects on page 212.

In addition, you can access an active camera view's specification dialog by selecting 3D> Edit Active Camera . The 3D 

View tools also have defaults dialogs where you can specify the initial attributes of camera views. See 3D Views on page 
1080.

In addition, you can open the specification dialog for objects associated with a schedule row. See Open Row Object(s) on 
page 699.          
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Most objects also have a defaults dialog that lets you specify the initial values in the specification dialog.  See Default 
Settings on page 76.      

You can open the specification dialog for group-selected objects if they are of the same type, such as base cabinets.           

 l If a particular setting varies among the different objects, its check box will have a solid fill instead of a check mark. 
Click once to clear the box for all selected objects, or click a second time to place a check mark for all selected 
objects.           

 l In some dialogs, if a particular setting varies among the different objects, it will have a “No Change” radio button. 
Leave this button selected, or choose a different option to apply it to all objects in the selection set.           

 l If the setting has a text field or drop-down list, it will say “No Change”. Changes made to such a setting can be 
undone by replacing the value in the text field with the letter N before you click OK.           

If you select multiple objects of different types, the Open Object  edit button is usually not available. This button may 

be available if the objects have data in common, but you can only edit the common data.           

DIALOG PREVIEW PANES

Many specification dialogs have a preview pane that shows how changes to settings affect the selected object. This preview 
updates when you click in a different field or press the Tab key on your keyboard.         

If you switch to a panel with settings that affect the selected object’s appearance in a certain view, that view will be shown 
in the preview. For example, if you select the GENERAL panel, a 3D view will be shown; but if you select the FILL STYLE 
panel, floor plan view will be shown. When floor plan view is shown, the primary and all secondary layers associated with 
the object will display. See Primary and Secondary Layers on page 181.           

When you click in the preview pane, your mouse pointer changes to a four-headed arrow and you can rotate around the 
object as well as zoom in and out using the mouse scroll wheel. Some objects, notably walls, doors, and windows, have 
Interior and Exterior labels to indicate which side is visible in the preview. Click the Fill Window  button above the 

preview pane to zoom in or out so that the object fills the extents of the pane, maintaining the current rotation.         

In most dialogs, the Standard, Vector View, and Glass House Rendering Techniques can be applied to the preview. See 
Rendering Techniques on page 1147. You can specify whether Standard or Vector View is used by default in the 
Preferences dialog. See Appearance Panel on page 99.

Click the Color  button to turn color in the preview off or on. Some objects have additional tools that affect object 

previews. For example, the Cabinet Specification dialogs have a Select Cabinet Face Item  button. Object specific tools 

like this are discussed in the documentation for that object type.         

Note: When multiple objects are selected, their shared specification 
dialog preview will typically only show one of the objects. 

DIALOG PANEL SPLITTERS

Many dialog panels are divided into up to three sections: a list of panels on the left, an object preview on the right, and a 
central area where settings are located. The vertical splitters separating these sections each have a pale grey, vertical grab 
handle.         

To resize the panel list or preview, as well as the area in the middle, move your mouse pointer over the vertical grab handle: 
when the splitter cursor   can be seen, click and drag to the left or right.         

22



Chief Architect Premier X14 Reference Manual - Edit Handles

KEYBOARD NAVIGATION

Dialog panels and settings can be accessed using the mouse. You can also navigate the settings on a given dialog panel 
using the keyboard. For example:

 l Line items in tree lists can be browsed using the arrow keys. Up and Down navigate the list, while Left and Right 
expand and contract categories.

 l Press the Tab key to shift focus from the tree list to the first setting on the selected panel. 
 l Press the Tab key to shift focus from one setting to the next, or Shift + Tab to go in the reverse direction. 
 l A check box can be checked or cleared by pressing the Spacebar or the + or - keys, respectively, while it is in focus. 
 l Columns of radio buttons can be navigated using the Up and Down arrow keys; rows can be navigated using the Left 

and Right arrows. Select a radio button by pressing the Spacebar while it is in focus.
 l Settings in list boxes can be navigated using the Up and Down arrow keys. When a check box is in focus, it can be 

checked or cleared by pressing the Spacebar. 
 l Drop-down lists can be browsed using the Up and Down arrow keys. When the mouse pointer is directly over the 

drop-down, the mouse scroll wheel can also be used; on a Mac, the list must also be expanded. In Windows only, you 
can press Tab to select the highlighted item in the list and proceed to the next setting. 

 l Settings with spin control arrows   can be adjusted by typing in the text field or using the Up and Down arrow keys. 
When the mouse pointer is directly over the setting, the mouse scroll wheel can also be used.

 l Slider bars   can be adjusted by typing in the text field or using the Left and Right arrow keys. When the 
mouse pointer is directly over the slider bar, the mouse scroll wheel can also be used.

 l Line items in tables can be group selected using the Ctrl or Shift keys, or by pressing Ctrl + A.
 l Press Enter on your keyboard to close most dialogs and apply your changes.
 l In the Mac version, Command + . closes dialogs.

Note: Keyboard navigation in dialogs may vary somewhat depending on 
your computer platform. 

In the Mac version of the software, Dictation is supported in dialogs. Select Edit> Start Dictation, then open a dialog. Say 
the word “Numeral” before a number to enter it as a numeric value or immediately follow a number with a unit such as 
“foot” to enter it as a measurement. 

 

Edit Handles
A selected object has edit handles that can be used to modify its size, position, and orientation. When you move the pointer 
over an edit handle, information about what it does displays in the Status Bar and the pointer changes to suggest how you 
can use it. 

The edit handles that display depend on the type of object selected, the current view, and how far you are zoomed out. Edit 
handles do not resize as you zoom in or out. If you are zoomed out far enough, some edit handles may be hidden so that 
they do not stack over one another. As you zoom in, these handles become visible again.

How each handle behaves when it is clicked and dragged may depend on which Edit Behavior  is currently active. See 

Defaults, Preferences, and Edit Behaviors on page 208.     

You can cancel any edit handle operation before it is completed 
by pressing the Esc key on your keyboard or by pressing any two 

mouse buttons at the same time. 
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MOVE EDIT HANDLE

The square Move handle located at the center of a selected box or polyline-based object, or at the center of a group of 
selected objects, lets you move the selection orthogonal, or at right angles to, its edges. When you position the mouse 

pointer over the Move handle, it displays a four-headed arrow. See Moving Objects on page 245.

Depending on the type of object(s) selected and how far you are zoomed in or out, the position of the Move handle may 
shift so that it remains on-screen. See Zoom Tools on page 157.

RESHAPE/RESIZE EDIT HANDLES

Square edit handles on the edges and corners of a selected object allow you to resize the object by moving its edges. 
A two-headed arrow indicates that the object's edge or corner can be moved in the direction of the arrows. When 

multiple objects are selected, the Resize handle is not available. See Resizing Objects on page 256.

Depending on the type of object selected and how far you are zoomed in or out, the Resize handles may not display on-
screen.

In the case of a selected line-based object, clicking and dragging the Resize edit handle will move the object perpendicular 
to itself. See Editing Line-Based Objects on page 218.

ROTATE EDIT HANDLE

The triangular Rotate handle lets you rotate the selected object or group of objects. The Rotate handle is located 
adjacent to either the object's selected edge or its front if it has one, and when you move your mouse pointer over this 

handle, it displays a circular arrow. See Rotating Objects on page 261.

A selection's Rotate handle will display regardless of how far you are zoomed out; however, it is possible to zoom in far 
enough that it no longer can be seen.

OTHER EDIT HANDLES

In addition to the Move, Reshape/Resize, and Rotate edit handles, a variety of objects in Chief Architect have additional edit 
handles for special purposes. Examples include:

 l Same Wall Type and Edit Wall Intersection edit handles. See Edit Handles for Walls on page 375.
 l Change Swing/Hinge Side edit handle for doors. See Changing Door Swings on page 561.
 l Add Extension and Extension Line End edit handles for dimension lines. See Editing Dimension Lines on page 484.
 l Move and Rotate edit handles for object labels. See Label Panel on page 712.
 l Resize edit handles for Schedule columns. See Editing Schedules on page 698.
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The Status Bar
The Status Bar at the bottom of the main program window displays information about the current state of the program. 

This information depends on a variety of conditions such as settings in the Preferences dialog, the type of object selected, 
and the current position of the pointer. Examples of information that may be reported include:

 l The type of object currently selected or the total number of group-selected objects. 
 l Plan file name and view information when a layout box is selected.
 l A description of the edit handle that the pointer is over.
 l A brief description of the toolbar button or menu item that the mouse pointer is positioned over.
 l The name of the active tool, a brief description of that tool, and its hotkey, if it has one.
 l The length and/or angle of an object as it is being drawn.
 l Basic information about a selected library object, folder, or catalog.
 l The current floor level or layout page.
 l The layer that the selected object is on and its Drawing Group.
 l The size of the active window in pixels.
 l Whether a camera view is rendering or has finished rendering.
 l Samples of indirect lighting per second in camera views with GPU Ray Tracing.
 l The screen redraw time.
 l The Current CAD Layer.
 l The current CAD coordinates of the mouse pointer.

The number format used in the Status Bar is set in the Dimension Defaults dialog, while the angle style can be specified in 
the Number Style/Angle Style dialog. See Primary Format Panel on page 465 and Dialog Number/Angle Style Dialog on 
page 131.          

 

Message Boxes
As you work in Chief Architect, the program will occasionally prompt you to examine your settings, alert you if you 
command it to do something that could potentially cause a problem, or notify you if it encounters a problem that needs your 
attention.

Situations where such message boxes may display include: 

 l Closing a file or view without saving;
 l Modifying an object that is set to rebuild automatically;
 l A file referenced outside the program, such as an image or texture, is missing;
 l Creating an object in a space too small to contain it.

As with dialog boxes, you can access the options in a message box using the mouse or navigate them using the keyboard.
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A few messages have a Send Report button. Click this button to send details regarding the issue that prompted the message 
to Chief Architect via the internet. 

Some message boxes include a “Remember my choice” or a “Do not show this again” check box. Check this box to prevent 
messages of this specific type from displaying in the future. When this box is checked, some options in the message box 
may become inactive.

To allow all message boxes to display again, click the Reset Message Boxes button in the Preferences dialog. See Reset 
Options Panel on page 131. 

NAME PROMPT

In dialogs throughout the program, there are opportunities to create new entities that require a name. Examples include:          

 l The Copy button in the Saved Defaults dialog.          
 l The Copy Set button in the Layer Display Options dialog.          
 l The Rename button in the Schedule Specification dialog.          

When you click a New, Copy, or Rename button in a dialog, a Name Prompt dialog will open.           

For best results, type a short, descriptive, and unique name and then click OK.          

 

Preferences and Default Settings
Preferences and default settings control many aspects of the user interface and tool behavior in Chief Architect. You can use 
these settings to customize the program to suit your personal work style.

For more information about defaults and preferences, see Preferences and Default Settings on page 75.

PREFERENCES

Preference settings let you change program behavior to suit your workflow. For example, you can: 

 l Turn certain display elements on or off.
 l Choose background and editing feedback colors.
 l Select a color theme for the dialog boxes, toolbars, and other elements of the program interface.           
 l Set the frequency of autosaves, the maximum number of “undos,” and file locking.          
 l Set the default folders for various files.          
 l Control the editing behaviors of objects.          
 l Setup the materials list categories, sub-categories, and report style, as well as manufacturer and supplier information.          
 l Set rendering specifications to maximize efficiency and quality. 

Preference settings are global, affecting all plan and layout files.

DEFAULTS

Most objects in Chief Architect derive their initial properties from their respective default dialogs. 
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For example, a newly placed Window  gets its initial values from the Window Defaults dialog and a newly placed 

Hinged Door  gets its initial values from the Door Defaults dialog. 

Once an object is placed in a plan, its initial properties can be overridden, but setting up your defaults before you begin 
drawing can save you considerable time as you build a model in the program.

Default settings, unlike Preferences, are file specific.

DYNAMIC DEFAULTS

Most default settings are static: if you change one, any objects of that type in the current file will not be affected. A few 
defaults, however, are dynamic: they are tied to existing objects in the drawing and if you change the default, those objects 
may be affected. See Dynamic Defaults on page 79. 

TEMPLATE PLANS

You can set up an otherwise empty plan with the default settings of your choice and use it as your template for new, blank 
plans. See Template Files on page 87.          

 

Drawing a Plan
When you draw a plan in Chief Architect, you are placing 3D objects that represent building components. Chief Architect 
comes with predefined default settings so you can start drawing plans immediately. You should review these default settings 
to be sure they match your drawing and building methods. See Preferences and Default Settings on page 75.         

SET THE DEFAULTS

 1.  Open a new plan using the template of your choice. See Template Files on page 38.           

 2.  Set the structural defaults:          

 l Floor Defaults. Set the default ceiling height for Floor 1. See Floor Defaults Dialog on page 744.          

 l Foundation Defaults. Set the foundation specifics such as type, footing size, and stem wall height. See 
Foundation Defaults on page 718.          

 l Framing Defaults. Set the floor framing specifications, including type and dimensions. See Framing Defaults 
on page 865.          

 l Default Wall Types. Specify the defaults for walls and railings. See Wall, Railing, and Fencing Defaults on 
page 346.           

 3.  Set material defaults for roof, walls, and rooms (optional). See Material Defaults on page 1052.          

 4.  Set style defaults for doors, windows, molding, cabinets and other objects.           

DRAW THE FLOORS

 1.  While the size of the drawing area in Chief Architect is limited only by the resources on your computer, it is best to 
begin your drawing near the origin, 0,0. See 3D Drafting on page 12.         

 2.  Draw the exterior walls on Floor 1. See Creating Walls on page 361.         

 3.  Adjust the perimeter shape and size as required. See Using the Edit Handles on page 372.         
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 4.  Place any first floor bearing walls.          

 5.  Define types for special rooms such as garages and decks in the plan. See Room Types and Functions on page 420.          

 6.  Place perimeter doors and windows. See Doors on page 551 and Windows on page 584.         

 7.  Build additional floors. See Adding Floors on page 745.         

 8.  Specify the default ceiling height for each floor as soon as it is created. See Floor Defaults Dialog on page 744.         

 9.  Adjust the perimeter shape of additional floors as needed. See Editing Walls on page 372.         

 10.  Align edited or moved walls with those above or below where appropriate. See Aligning Walls on page 378.         

ENTERING DIMENSIONS

When using U.S. Units, enter distances as inches or feet and inches, in fractional or decimal form. Millimeters are the 
default unit for all metric distances. See Dimensions on page 454.         

 l To enter feet, include the ( ' ) marker or the program assumes inches.         
 l In most cases, the program allows precision to 1/128th of an inch. Fractions with denominators 2, 4, 8 and 16 are 

allowed.
 l The program usually converts decimals to fractions.         
 l You can enter angles as decimal degrees, degrees, minutes, and seconds, quadrant bearings, or azimuth bearings. See 

Dialog Number/Angle Style Dialog on page 131.          

BUILD THE FOUNDATION

 1.  Derive the foundation plan from the first floor. See Building a Foundation on page 722.         

 2.  Adjust the foundation perimeter shape as needed.         

 3.  Place interior foundation walls as needed for the first floor bearing walls.         

 4.  Place any other foundation walls required.         

 5.  Align with Above as needed. See Aligning Walls on page 378.         

ADD STRUCTURE AND DETAILS

 1.  Build non-structural interior walls. Begin on floor one and work up in multiple story structures.          

 2.  Add walls where needed to create features such as chimney chases, plumbing walls, or Open Below areas.         

 3.  Finish the relevant interior structure including interior doors, doorways, cabinets, fixtures, and fireplaces.         

 4.  Build the roof planes. If you generate the roof automatically, remember to carry the roof directives in the walls from 
the first floor up to the top floor for multiple story structures. See Roofs on page 803.           

 5.  Build the framing. See Framing on page 864.           

 6.  Build the terrain and landscaping. See Terrain on page 1249.         

 7.  Create the plot plan and plan footprint. See Plot Plans and Plan Footprints on page 1251.   

 8.  Create any necessary views and print the plan and use CAD Detail from View to create 2D elevations and plan 
details. Use and modify details from the Library, as well. See CAD Details on page 340.         

28



Chief Architect Premier X14 Reference Manual - Viewing Your Plan

CREATE THE LAYOUT

 1.  If one does not exist, create a Layout file with a title block, placing the border, title block, and other text on page 0. 
See Layout on page 1338.          

 2.  Send views to the layout, starting with layout page 1. See Sending Views to Layout on page 1343.

 3.  Print the layout. See Printing and Plotting on page 1368.          

 

Viewing Your Plan
You can see your model in a variety of different 2D and 3D views. You can display more than one view at a time; and in 
any view, you can pan or zoom in or out. See Window and View Tools on page 148. 

Plan view is a 2D view of the model most commonly used for drawing and editing. Each floor displays separately; however, 
you  have extensive control over which objects display at any given time, can easily switch between floors, and can also 
display items other floors for reference. See Multiple Floors on page 743.

You can create interior and exterior 3D views of your model from any perspective. As in plan view, you can select and edit 
many objects in 3D views and control which objects are visible. See 3D Views on page 1080. 

You can also create Floor Overviews that show only the current floor plus any floors beneath it. Ceilings on the current 
floor are omitted so you can see the interior, visualize the relationships between spaces, and plan traffic flow.
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Framing Overviews display framing in 3D, provided that framing has been built. You can customize 3D views to serve 
special purposes such as this.         

A variety of rendering techniques let you produce customized 3D views, from detail drawings to photorealistic Ray Trace 
views to artistic presentation views.           

The Cross Section and Elevation camera tools create scaled 2D views of a model’s exterior and interior that can be 
dimensioned and annotated. Just as in other views, you can select and edit objects in a Cross Section/Elevation view as well 
as control which objects display.           

LAYOUT FILES

All plan views can be sent to a layout where they can be arranged to produce full construction documentation. See 
Sending Views to Layout on page 1343.         

All views can also be exported as a graphic image. See To export a picture on page 1188.   
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Sharing Your Files with Clients
Chief Architect users have the option of letting their clients review plan and layout files on their own computers, at their 
convenience, using the Chief Architect Viewer. The Chief Architect Viewer allows clients to open plan and layout files, 
create 3D views, and add text annotations without making any changes to the actual model.          

To share files using the Chief Architect Viewer, first invite a client to request a copy of the Viewer at chiefarchitect.com.          

To ensure that all custom backdrops, images and material textures are included, use the Backup Entire Plan  tool when 

preparing to send files to your client. See Backup Entire Plan or Layout on page 55. 

You can also invite clients to explore the 3D model of their project using the 3D Viewer mobile app. Learn more 
at:chiefarchitect.com/products/3d-viewer/

 

Getting Help
There are many forms of help available in Chief Architect Premier including: Tool Tips, the Status Bar, and the 
online Help menu. See Resources and Support on page 1409.

All these forms of help assume you have a basic working knowledge of your operating system, including how to use a 
mouse, open, close and save files, copy, paste, and right-click to access contextual menus. Help also assumes you are 
familiar with basic computer terminology.

More information is available on Chief Architect’s website, chiefarchitect.com. 

TOOL TIPS

When you move the pointer over a toolbar button or menu item, a Tool Tip displays, offering a brief description of the tool. 
More information displays in the Status Bar at the bottom of the window. The Status Bar also reports information about the 
currently active tool or the currently selected object. See The Status Bar on page 25.

CONTEXTUAL HELP

Chief Architect Premier's Help is a searchable menu that provides information about all of the tools in the program. 
Select Help> Launch Help or press the F1 key to open the program’s Help and explore the table of Contents, browse 

the Index, or Search for keywords.

The Help can be used to provide instant information about toolbar buttons, menu items, and objects in your plan.

 l Position the mouse pointer over a toolbar button or menu item, then press the F1 key to open the Help to a page with 
more information about the tool.

 l When an object is selected, press the F1 key to open the Help to a page with information about that object. If you 
position the mouse pointer over one of the selected object's edit handles and press F1, a page with information about 
that handle will display instead. 

 l Press the Help button in any dialog box to open online Help to a page describing the options in that dialog. 

When the Help is open, it will update automatically to show information about the currently selected object, active tool or 
dialog, or highlighted item. If you would like to turn off this dynamic behavior, click the Prevent Help from Updating 
Dynamically  button at the top of the Help window.

Additional buttons at the top of the Help window allow you to zoom as well as search the current page.
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Chief Architect strives to make our documentation as helpful as possible. 
Please send any suggestions to: documentation@chiefarchitect.com.

 

About Chief Architect
Select Help> About Chief Architect in Windows® or Chief Architect> About Chief Architect in macOS™ to view 
information about your software license, the program’s version number, and its release date. If your license has an 
expiration date, it will also display here.

Contact information for Chief Architect, Inc. is available on the MORE INFORMATION panel.

 

Chief Architect Trial Software
Both Chief Architect Premier and Interiors have Trial versions available for free download at chiefarchitect.com.           

The Trial software offers the same functionality as a purchased license with a few limitations:         

 l File Saving         
 l Printing         
 l File Exporting         
 l Recording of Walkthroughs         
 l Printing or Exporting of Materials Lists         
 l Library Browser restrictions         
 l Linked Plans in the Reference Display
 l Linked Callouts
 l Use of the Time Tracker utility          
 l Use of the CAD Detail from View tool          
 l Creating or saving Plan Database files          
 l Exporting of Layer Sets          

Full details can be found in the software’s Help and at  chiefarchitect.com.          

CONVERTING THE TRIAL VERSION

An installation of any of our Trial programs can be converted into a full working version of the program at any time by 
purchasing a software license. There are several ways to begin this process in the Trial:          

 l Click the Purchase Full Version Now button in any Trial Restriction message box.         
 l Select Help> Purchase Chief Architect Premier . 

 l Select File> Dashboard  and then click the Purchase Full Version Now button.

Once you have purchased a license, you can activate it while the Trial software is running.         

To activate the full version
 1.  Select Help> Activate Full Version.         

 2.  In the Product Activation dialog, type or paste the Product Key associated with your software license.         
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 3.  Click the Activate Full Version button.         
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Chapter 2
 

File Management

Chief Architect Premier reads and edits two main document types: .plan files and .layout files. The complete 3D model of a 
structure, surrounding terrain and any CAD data associated with it are stored in the plan file. Data used to create working 
drawings and the links to various views or details are stored in the layout file.

All commands related to opening, saving and closing plans are located in the File menu. You can also open plans from the 
Dashboard window. See Dashboard on page 11.

Just as with files created in other software applications, you should back up your plan and layout files externally on a 
regular basis to avoid accidental loss of work.

TOPICS

Compatibility with Previous Versions 35
Organizing Your Files 36
Chief Architect Premier Data 37
Creating a New Plan or Layout 38
Saving, Exporting, and Backing Up Files 39
Auto Archive 42
Opening and Importing Files 44
Plan Databases 46
Searching for Plans 48
Linked and Referenced Files 51
Backup Entire Plan or Layout 55
Exiting Chief Architect 56

34



Chief Architect Premier X14 Reference Manual - Compatibility with Previous Versions

 

Compatibility with Previous Versions
Plans and layout files produced in the following programs can all be read by Chief Architect Premier X14. 

 l Chief Architect® 10.0 through X13

 l All Better Homes and Gardens Home Designer® products, Interior Designer, and Landscaping and Deck Designer, 
Versions 7 and 8.

 l All Chief Architect Home Designer® products, Interior Designer, and Landscaping and Deck Designer, Versions 9 
through 2022.

Only the .plan and .layout files from prior versions can be opened in Chief Architect Premier X14.               A number of steps are 
recommended when migrating plans created in an earlier program version into Chief Architect Premier X14. Before doing 
so, see Getting Started Checklist on page 1415.

Chief Architect automatically archives plans created in prior 
versions. See Auto Archive on page 42.

Files that have been opened and saved in Chief Architect Premier X14 cannot be read by any of the program versions listed 
above. To continue to read files in the program in which they were created, be sure to create copies of your files before 
opening them in version X14. 

Plans and layout files produced in the Windows® version of Chief Architect Premier X14 can be read in the Mac® version, 
and vice versa. 

FILE ASSOCIATION

Although multiple versions of Chief Architect can be installed on a computer, the operating system will only associate
 .plan, .layout, .calib, and .calibz files with one of them. If they are not associated with Chief Architect Premier X14, click 
the Associate Files with this Program button in the Preferences dialog. See File Management Panel on page 109. 

OPENING CHIEF ARCHITECT PLANS IN HOME DESIGNER PROGRAMS

Plans created in Chief Architect Versions 10 through X14 can be opened in the latest Home Designer programs for viewing 
and annotating, but not for general editing or drawing of architectural objects.         

Plans created in build 11.4 or later of Chief Architect X1, or in later program versions, can be set to allow limited editability 
in Home Designer programs. When this permission is enabled, a Home Designer user can use all of their program’s drawing 
tools and can edit objects in the plan that those tools can create. If an object cannot be created in the Home Designer 
program, however, it will not be editable.         

Please note, too, that if a plan has more floors than the Home Designer program supports, the entire plan can be viewed and 
annotated only.         

To protect some objects from being edited when a file with editing permission is opened in a Home Designer program, 
consider locking their layers. See Locking Layers on page 182.   

Allow Editing in Select Home Designer Products can be enabled or disabled only when the file is opened in Chief 
Architect Premier. See General Plan Defaults Dialog on page 96.           
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Organizing Your Files
You should keep your plan              and layout files separate from the support files needed to run Chief Architect. To keep files 
organized, you may find it helpful to create a new folder for each project.         

Chief Architect files may use imported images, textures and other custom content saved in their own external data files. 
Consider storing copies of all external files in the same folder as the plan              and layout files that use them so that they are 
easily found.              See Adding Library Content on page 973.

Here is one way to organize your files:         

 l Create a folder in your Documents directory called “Chief Architect Plans” or another name you prefer. See your 
operating system’s Help to learn how to create folders.         

 l Inside this folder, make a new folder for each client or project. Save all the files for that client or project inside this 
folder, including plan and layout files and referenced external files. See Saving, Exporting, and Backing Up Files on 
page 39.         

Bear in mind, though, that path names exceeding 260 characters cannot be opened by Chief Architect. As a result, it is a 
good idea to limit the number of embedded folders you use in your file organization method.         

Once you understand the file management of Chief Architect, you              should decide on a naming convention that suits your 
needs.          

It is recommended that each layout file be saved in the same 
folder as the plan file(s) associated with it. See Managing Layout 

Links on page 1358. 

To specify a default Save As location
 1.  Select Edit> Preferences , then select New Plans from Category list. See New Plans Panel on page 113.           

 2.  Under Open and Save As, click Use this Folder. The Browse button becomes available.          

 3.  Browse to the folder you plan to save your projects in. Click OK.          

THUMBNAIL IMAGES

A thumbnail is a miniature image that helps identify a file in the Open Plan File dialog in the Windows version of the 
software and in the Find Plan Assistant. See Searching for Plans on page 48.

If thumbnails are enabled in the Preferences dialog, the program automatically creates one when you first save a new plan or 
layout. You can, however, create a custom thumbnail using any view as well as choose to generate small or large 
thumbnails. See File Management Panel on page 109.

To create a custom thumbnail image
 1.  You must save the file and give it a name before you can save a thumbnail.

 2.  Create the 2D or 3D view that you want to use as a thumbnail for the current file.

 3.  With the desired view active, select File> Save Thumbnail Image .

Thumbnail images are saved in the plan or layout file that they are associated with. 
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Chief Architect Premier Data
When Chief Architect Premier X14 is installed, the program automatically creates a folder in the user Documents directory 
called  Chief Architect Premier X14 Data. This folder contains important user-specific information saved in the following 
folders and files and should not be moved, renamed or deleted: 

 l Archives - A folder of automatically archived plan and layout files. See Auto Archive on page 42.
 l Backdrops - A folder of custom backdrop images. See 3D Backdrops on page 1099.         
 l Hotkeys - A folder of hotkey assignments. See Hotkeys on page 142.         
 l Images - A folder of custom images. See Using the Contextual Menu on page 975.         
 l lex - A folder of customized dictionaries. See Spell Check on page 526.             
 l Database Libraries - A folder of user library data. See Library Content on page 969.             
 l Scripts - A folder for custom Ruby scripts. See Ruby in Chief Architect on page 1391.
 l Templates - A folder of plan                  and layout template files. See                  Template Files on page 87.             
 l Textures - A folder where you can save image files used to create custom material textures. See Creating Materials 

on page 1060.             
 l Toolbars - A folder of                  customized toolbar files. See                  Toolbar Customization Dialog on page 139.             
 l mmaster.mat - The Master Materials List file. See The Master List on page 1332.             
 l sheetSizes.sheet - A list of user-created Drawing Sheets. See Customize Sheet Sizes Dialog on page 1375.             
 l _MigrateBackup - If you migrated legacy settings into Version X14, additional folders with names appended with _

MigrateBackup may also be present. 

If the Chief Architect Premier X14 Data folder is renamed, 
moved or deleted, the program will automatically replace it 

using default information from the program's installation folder. When 
this occurs, customized user settings and custom user library content will 
not be available.

DATA FOLDER NAME AND LOCATION

The name of the Chief Architect Premier X14 Data folder cannot be changed, but you can specify its location on your 
system in the Preferences dialog. See Folders Panel on page 111.

If you specify a new location for this folder, the program will not migrate any custom user settings that you might have. 
Instead, it will automatically create a new folder at that location containing default information from the Chief Architect 
Premier X14 installation folder. If you would like to copy custom settings to the new location, you can do this yourself in an 
operating system window.         

When specifying a location for the Data folder, bear these considerations in mind:         

 l If you move the Chief Architect Premier X14 Data folder on your computer without specifying its location in 
Preferences, the program will automatically replace the folder in its default location using default information from the 
software's installation folder.             

 l The same will result if you specify a location on a network or removable device and that location becomes 
inaccessible. For this reason, it is best to use a location on your local hard drive.              

 l The User Database Libraries in particular may contain a large amount of data. Whatever location you choose to use 
must be located on a hard drive with sufficient space to hold these files.             

Just as with your plan and layout files, it is a good idea to back up your Chief Architect Premier X14 Data folder.           
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Because the Chief Architect Premier X14 Data contains custom user data, it is not deleted when the program is uninstalled.

 

Creating a New Plan or Layout
To create a new, blank plan, select File> New Plan.

You can also choose New Plan in the Dashboard window. See Dashboard on page 11.

Create a new layout file by selecting File> New Layout or by sending a view to layout when no layout file is yet 
open or associated with the current plan file. See Creating a Layout File on page 1341.             

By default, a new layout file will be assigned the same name of the first plan file sent to it, associating the layout files with 
the plan files used.           

New plan and layout files derive their default settings from the currently selected template files. See Template Files on page 
87.           

New, blank plans are called Untitled.plan and new, blank layout files, Untitled.layout. Unless these files are named and 
saved, they will be lost when closed. See Saving, Exporting, and Backing Up Files on page 39.          

UNITS OF MEASUREMENT

All plan and layout files save measurements in either U.S. or metric units. New files are created using one or the other, 
depending on the current setting in the Preferences dialog. When the program is first installed, the Windows OS setting for 
units determines what system is used. See New Plans Panel on page 113.          

A plan or layout file’s unit of measurement must be specified before it is created and cannot be changed later.               If you 
normally work in one set of units but need to create a new file using the other, select File> Templates> New Plan From 
Template  to open a new file using an appropriate template without changing your Preferences settings. See Using 

Template Files on page 88. 

While it is recommended that you create new plans using the type of unit that you plan to use, you can display dimensions 
using any type of unit. See Dimension Preferences and Defaults on page 455.          

TEMPLATE FILES

New plan and layout files are created as copies of the current template files specified in the Preferences dialog. See 
Template Files on page 87.           

Commonly used settings, defaults and other information are included in template files. You can customize the settings in a 
template file to fit your work style and then save your changes as a new template file. See To create a plan template on 
page 89.          

If no template has been specified in the Preferences dialog, new plans and layouts are created using the system defaults. 
System defaults cannot be modified.          

When Chief Architect opens a new, blank plan or layout file, the new file is actually a copy of a template using either metric 
or U.S. units of measurement and predefined default settings, layer settings, wall definitions, and page setup information.

SELECT TEMPLATE DIALOG

When a new, blank plan or layout file is opened in Chief Architect, the new file is actually a copy of a template using either 
metric or U.S. units of measurement and predefined default settings, layer settings, wall definitions, and page setup 
information. 
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Creating a new plan without referencing a template file is not recommended. If you try to create a new plan              or layout using 
a template file that is not available, the Select Template dialog will prompt you to specify a template for the new file you 
are creating. 

 l Select Load Installed Template (Recommended), then select a template file from the drop-down list. 
 l Select Load Custom Template, then click the Browse button and browse to a plan or layout file saved on your 

computer.
 l You can also type or paste the full path name of a file in the text field.

If you encounter this dialog, make sure that the program Data folder is at a location that can be accessed by the program. 
You may also want to reset your template files to the defaults installed with the program. See Chief Architect Premier Data 
on page 37 and Reset Options Panel on page 131.         

 

Saving, Exporting, and Backing Up Files
Saving, exporting, and backing up your files are three separate tasks that accomplish different things: 

 l Saving a plan or layout file retains your work so that it can be later opened in Chief Architect.         
 l Exporting a file allows you to save certain kinds of data in a format that can be used by a program other than Chief 

Architect.
 l Backing up your files involves taking steps to make sure that your valuable data is protected and available when 

needed. 

Whether you are saving, exporting, or backing up your data, it is important that you select a location on your computer for 
the files you create, and also specify a short, meaningful name that you will be able to identify in the future. 

To save an untitled plan or layout file
 1.  Select File> Save As  to open the Save File dialog.

 2.  Specify a location on your local computer where you would like to save the file. See Organizing Your Files on page 
36.

 3.  In the File name text field, type a name for the file. 

 4.  Chief Architect automatically assigns the File of type and file extension .plan to plan files and .layout to layout 
files.

 5.  When both the Save in location and File name are correct, click Save.
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Although the program warns you if you try to exit without 
saving, you should get in the habit of saving plan files before 

exiting the program.

SAVING PLAN AND LAYOUT FILES

When you first save a new, untitled file, you must select a location for it on your computer and give it a name. There are 
two options for saving plan and layout files: File> Save  and File> Save As .        

Both Save and Save As can be used to save your plan and layout files; however, they accomplish this in two different ways:

  Save saves the current state of your plan or layout file without changing its name and should normally be used 
for saving your work.

  Save As opens the Save File dialog, allowing you to save the plan or layout file using a different name or 
location on your computer. 

Initially, all Open  and Save As  operations go to your Documents directory. After that, the location last visited is 

remembered and subsequent Open or Save As commands default to the directory last used for that operation. This path is 
saved when the program exits. The next time Chief Architect is launched, these defaults are used.

If you prefer, you can instead specify a directory to be used for all Open or Save As operations in the Preferences  

dialog. See New Plans Panel on page 113.          

SAVED VIEWS

All saved camera views, plan views, and CAD Details are saved with their plan file. See View Windows on page 149.

When saving a layout, the program saves all pages of the layout, all the links to the various views saved in the layout, and 
all the CAD objects added to the .layout file.

By default, a new layout file is assigned the same name as the first plan file from which a view is sent to it. It is also saved 
in the same directory as the plan file. If no view has been sent to a layout, it remains untitled until you save it.          

SAVE FILE DIALOG

The Save File dialog uses the operating system’s file save dialog format, and is also used when exporting files. The dialog 
name may vary, depending on the type of file being saved or exported.

A similar Select Folder dialog allows you to select a folder to which files can be exported. 
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 Location

Choose a location on your local computer for the file you are saving.

 
 Files

Any existing folders and/or files in the current location display here.

 
 File Name

In the File Name field, type a name for the file. If you select an existing file from the space above, its name will display 
here automatically.

 
 Save as Type

When saving a file, the program will choose the appropriate file type from the Save as type drop-down list. When 
exporting, you may need to choose a specific file type.

SAVING REVISION FILES

Revisions are a common aspect of any design project. There are a number of possible strategies for organizing revision files:

 l Prepending the file name;
 l Appending the file name;
 l Saving revisions in separate folders.

To avoid confusion and potential mistakes, it is recommended that you always give files unique names - including revision 
files. If you choose to organize your revisions by saving them in separate folders, you should also give each file a unique 
name that makes it impossible to confuse it with another file saved in a different folder.

EXPORTING FILES

Chief Architect has a number of options for exporting information out of  and importing information into your drawings. 
See Importing and Exporting on page 1222. 

Often, file export dialogs are simply versions of the Save File dialog. See Save File Dialog on page 40, above.
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Similarly, file import dialogs are often similar to the Open File dialog. See Importing Files on page 45. 

BACKUP ENTIRE PLAN

File> Save As  is a simple way to transfer a plan or layout to a different location on your computer. Bear in mind, 

though, that plan and layout files often reference external data files such as imported textures, images, and backdrops. These 
external files are not affected when Save As is used.          

If you transfer a plan file from one computer to another, the program will warn you of missing files if the external data files 
used by the plan cannot be found when you open it. 

Layouts are also dynamically linked to plan files. When transferring layout files to another computer, be aware that the plan 
files are also external file references and are not actually contained in the layout.         

When transferring plans              or layouts to another computer that does not have these external files, use the Backup Entire Plan 
 tool. See Backup Entire Plan or Layout on page 55.         

BACKING UP YOUR FILES

It is always a good idea to create backup copies of all your important files on your computer. 

It is strongly recommended, however, that you never save directly:

 l Across a network, such as onto a server;
 l Onto removable media such as a USB thumb drive.
 l Across the Internet.

Instead, copy your files to such locations only after you have saved them on your computer’s hard drive and exited the 
program.

Similarly, you should never open files saved in these locations. Copy the files to the local hard drive, and then open them. 
See Opening and Importing Files on page 44.         

Archive folders are used by Chief Architect to manage prior versions of your files. You should not view these files as a 
substitute for your own backup routine, and should never save a file in an archive folder. See Auto Archive on page 42.   

When backing up your Chief Architect files, consider backing up not only your .plan and .layout files, but your custom user 
data, as well - including library content, toolbar configurations, and textures. This custom data is all located in the Chief 
Architect Premier Data folder, so it can be easily backed up. See Chief Architect Premier Data on page 37.

You can, if you wish, create a folder inside the Data folder for your .plan and .layout files, as well. See Organizing Your 
Files on page 36.         

 

Auto Archive
The first time a plan or layout is saved, an Archive folder is automatically created in the Chief Architect Premier X14 Data 
folder. The Archive folder contains Auto Save and Archive files. 

The program will also create Auto Save files for unsaved plans and layouts provided that they have been open for longer 
than the Auto Save frequency setting in the Preferences dialog. See Auto Save Files on page 44, below. 
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Auto Save and Archive files should not be viewed as a substitute 
for regularly saving your work by selecting File> Save or 

pressing Ctrl + S on the keyboard, nor should they be considered an 
alternative to your own file backup routine.

ARCHIVE FILES

Every time a drawing is saved, Archive files that keep a historical archive of your plan are automatically created or updated. 

Files can be archived by hour, day or most recent save. They are renamed according to which archiving option is selected in 
the Preferences dialog. See File Management Panel on page 109. 

JonesResidence.plan

JonesResidence_2022_1_15.plan

JonesResidence_2022_1_15_13.plan

Regardless of what archiving option you select in the 
Preferences dialog, if you do not save your work regularly, your 

archive files will not be updated.         

Plan, layout and related files from previous versions of the program are automatically moved to the archive folder when the 
plan is opened and saved in Chief Architect Premier X14.         

Archive files are meant to be for emergency use only. If you must access an archive file, open it as you would any other 
file. As soon as the file is open, use Save As  to save this file to another location.

LEGACY ARCHIVE FILES

Plan              and layout files saved in the current program version are not backwards-compatible: that is, they cannot be opened in 
older versions of the software.         

If you open a Chief Architect plan or layout file from a previous program version and immediately Save it (not Save As), 
the Auto Archive utility will create an additional archive file using the original program version format. This archive file is 
a copy of the original and can still be opened in the original program version.         

If you open and Save a Chief Architect Version 10 plan or layout file, the legacy archive file name will be appended “_v10” 
to help distinguish it from other archived .plan or .layout files of the same name, and a copy of its archive folder will be 
created in the Chief Architect Premier X14 Archives folder.          

MANAGE ARCHIVES

Chief Architect offers two convenient ways to access Archive folders.           

 l Select File> Manage Auto Archives  to open the current plan’s Archive folder.          

 l Click Yes in the Archived Files dialog when the program warns you that the number of archive files exceeds the Auto 
Archive Files value.          

You can also move or delete archived files using your operating system. See your operating system’s Help for more 
information.          
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AUTO SAVE FILES

As you work, Chief Architect automatically creates Auto Save files at regular intervals when changes are made to a file but 
not saved by selecting File> Save . 

These Auto Save files are appended _auto_save.plan or _auto_save.layout and are saved in the Archive folder. 

When you close a file normally, its Auto Save file is retained until the next time the file is opened - at which time the Auto 
Save file is overwritten.

JonesResidence_auto_save.plan

Auto Save file after normal shutdown

You can enable Auto Save and set its frequency in the Preferences dialog. See File Management Panel on page 109.           

Auto save files created as a result of an improper program shutdown are appended _auto_save_bak.plan or _auto_save_
bak.layout.

    JonesResidence_auto_save_bak.plan

Auto Save file after abnormal shutdown

If your computer shuts down accidentally, you can recover some of your work by opening the _auto_save_bak file.

When you reopen a file after a computer shut down or system crash, the program will notify you if an Auto Save file newer 
than the original file is found and give you the option to one that file. 

Even with Auto Save, you should save your work manually on a regular basis using any of the following methods: 

 l Click the Save  button.

 l Select File> Save .

 l Press Ctrl + S on the keyboard.

 

Opening and Importing Files
Opening and importing files are often similar tasks, but accomplish two very different things:

 l Opening a file refers to opening it in the program in which it was created. Only plan or layout files can be opened in 
Chief Architect. See Compatibility with Previous Versions on page 35.         

 l Importing a file brings data that was created in a different program into Chief Architect. A number of different file 
types can be imported into Chief Architect.

Select File> Open Plan to open an existing .plan file or File> Open Layout to open an existing .layout file              located on 
your computer. Chief Architect automatically browses to either the directory last used or to a specific directory, depending 
on your current Preferences settings. See New Plans Panel on page 113.         

Before opening a file located on a removable storage device, 
server, or other computer on a network, copy it to your local 

machine’s hard drive first.
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OPEN FILE DIALOG

The Open File dialog uses the operating system’s file open dialog format, and is also used when importing files. The dialog 
name may vary, depending on your operating system and the type of file being opened or imported.         

A similar Select Folder dialog allows you to select an entire folder of files to import.         

 
File Path

Choose the location on your local computer for the file you are opening.

 
Folder Contents

Any existing folders and/or files in the current location display here.         

 
File Name

When selecting a file, its name will automatically display in the File Name field. You can also type the file’s name to locate 
a specific file. When importing  some types of files, multiple files may be selected.

 
File Type

When opening or importing a file, the program will usually choose the appropriate file type from the File type drop-down 
list. When importing, you may need to choose a specific file type. 

Plan files open to the floor that was active when the file was last saved and closed; layout files open to the page that was 
active.         

IMPORTING FILES

Chief Architect has a number of options for exporting and importing information out of and into your drawings. Often, file 
import dialogs are simply versions of the Open File dialog. See              Importing and Exporting on page 1222.          

Similarly, file export dialogs are often similar to the Save File dialog. See Exporting Files on page 41.          
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RECENTLY OPENED FILES

A list of recently opened and saved plan and layout              files can be accessed by selecting File> Open Recent Files. Select one 
of these files to open it without using the Open File dialog.          

The maximum number of recent files listed in the File menu can be changed in the Preferences  dialog. You can also 

specify that the recent files list display at the bottom of the File menu rather than in a submenu. See File Management Panel 
on page 109.         

The names of recent files also display in the Dashboard window. Click on the name of a file to open it. See Dashboard on 
page 11.

 

Plan Databases
A Plan Database is a collection of plan files along with search information about those files. You can create one or more 
Plan Databases and use them to find drawings that you have created that meet a set of search criteria that you specify. See 
Searching for Plans on page 48.           

CREATING A PLAN DATABASE FILE

Select Tools> Plan Database> Create Plan Database to create a new plan database file that can be used to search 
for plans using the Plan Find Assistant. The Create Plan Database dialog opens.

 
Database File

Use the Database File field to name the plan database file to be created. Click the Browse button to save this file at the 
location of your choice, as well as name it. 

 
Plan Search Path

Specify the Plan Search Path, which is the pathname of the folder where plans to be included in the plan database are 
saved. Any plan files in this folder will be added to the plan database. Click the Browse button to navigate to a folder on 
your computer.

  Options

 l The Include Subfolders check box allows you to specify whether the search only looks in the Plan Search Path or if 
it also searches any subfolders found.     

 l Check Use Relative Path if you anticipate moving the folder containing the database and plans to another location. 
As long as the database and the plans it references remain in the same folder, that folder can be moved to another 
location.     

When you click OK, the program searches for plan files and adds them to the plan database file. The program must read 
each plan and analyze it so this process may take some time.           
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You can Cancel the search process at any time. If you do, your plan database will have incomplete information and will not 
contain entries for all plans in your search folder. When all plans have been found and added to the plan database, the 
program automatically opens the new plan database file for modification.          

EDITING A PLAN DATABASE FILE

Once a plan database file is created, it can be modified. Select Tools> Plan Database> Edit Plan Database, then 
select the plan database file you want to modify. 

Click OK to open the Edit Plan Database dialog. You can edit any of the information in the plan database and add and 
remove plans from the database.          

 
Plans in the Database

All plans that currently have information stored in the plan database are listed here.

 l Click Add Plan to select a plan file to add to the plan database.          

 l Click Remove to remove the currently selected plan from the plan database.          
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Plan Information

Information about the selected plan displays and can be edited here. This information displays when a plan is found and 
selected using the Search for Plans  tool.

 l The Thumbnail preview image of the selected plan displays to the right. See Thumbnail Images on page 36.          

 l Select a plan Style from the drop-down list.           

 l Click the Add Style button to add the name of a style to the list.          

 l Enter the Price range for this plan.          

 l The Area is automatically calculated by the program based on the living area of the plan when it is added to the 
database. You can enter a different value if you wish.          

 l The number of Bedrooms is automatically calculated when a plan is added to the database. You can enter a different 
number if you wish.          

 l The number of Baths is automatically calculated when a plan is added to the database. You enter a different number 
if you wish.          

 l The number of Floors is automatically calculated when a plan is added to the database. You can enter a different 
number of floors if you wish.          

 l The selected plan file’s Path name displays here.          

 l Click Select File to relink the selected plan to a file on your computer. If a plan file is renamed, moved, or removed 
from your system, the plan database will be unable to locate it. You must then relink the plan database to the file or 
remove it to keep the plan database information accurate.          

 l Click Open Plan to open the selected plan. Opening a plan closes the Plan Database dialog. If you have not saved 
any changes you made before clicking the Open Plan button, you are asked to do so before you continue.          

 l Enter a Description for the plan, if desired.           

 

Searching for Plans
Select Tools> Plan Database> Search for Plans to open the Find Plan Assistant, which helps you search specific 
plan database files based on search parameters that you define. 

At the bottom of each page, the number of plans that match your current search parameters displays. As you modify the 
parameters, this number increases or decreases as matching plans are found. If this number is zero, the Next button will be 
disabled. 

On any page, click the Back button to modify any  previously selected parameters.   

FIND PLAN ASSISTANT

The Find Plan Assistant can be used to search for plans using stored information about each plan, such as the style of 
construction and the number of bedrooms and other room types. 

When you open the Find Plan Assistant, choose a plan database to search. Click the Browse button to select a plan database. 
Once a plan database is selected, click Next and proceed through the Find Plan Assistant. 
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HOUSE STYLE

 
Style

Select a style of house from the drop-down list.

 
# of Floors

Specify the maximum number of floors that you would like. 

 
# of Bedrooms

Specify the minimum and maximum number of bedrooms that you would like. 

 
Matches

The number of plans in the database that match your search parameters thus far displays here for reference. 

Click Next to continue. 

HOUSE SIZE
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# of Bathrooms

Specify the minimum and maximum number of bathrooms you would like. 

 
Size

Specify the minimum and maximum number of square feet that you would like. 

 
Price Range

Define a price range by specifying Minimum and Maximum prices.  

 
Matches

The number of plans in the database that match your search parameters thus far displays here for reference. 

Click Next to continue. 

PLAN DETAILS

 
Matches

Click on the name of a plan to select it and view information about it.

 
Details

Basic information about the selected plan display here. 

 
Preview

A preview of the selected plan displays here. 

 
Description

A written description of the selected plan provides additional details displays here. 
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Click Next to continue, then click Finish to view the selected plan. 

 

Linked and Referenced Files
A Chief Architect plan or layout file typically includes information from a variety of external files. When an external file is 
another Chief Architect plan or layout file, the two files are referred to as linked. When the external file is a different file 
type, it is referred to as a referenced file.

LINKED FILES

There are several ways in which plan and layout files can be linked to one another:

 l Sending views from a plan to a layout file. See Managing Layout Links on page 1358.
 l Referencing a plan in the Reference Display. See The Reference Display on page 69.
 l Linking a callout to a view in a different file. See Linked Callouts on page 533.

LINK VIEW DIALOG

The Link View dialog is used when adding a link to a callout or to the Reference Display, or when relinking a layout box to 
a view.

 
Open Files

The names of open plan files display in the tree list. If this dialog was accessed via the Callout Specification dialog, layout 
files may also be listed.     

 l Click on a view to select it, then click OK to link the selected object or Reference Display to that view.     
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Preview

A preview of the selected view displays in the pane on the right. Previews can be updated in the Project Browser. See 
Project Browser on page 58.     

 

 l Click the Show/Hide Preview Panel  button to toggle the display of the view preview off or on.

 l Click the Open Plan button to open a plan file not listed above. See Open File Dialog on page 45.

 l When accessed via the Callout Specification dialog, the Open Plan/Layout button is available instead.

 l When Keep Layout Box Contents' Position when Relinking is checked, the selected layout box will show the 
same coordinates when it is linked to a new view. When this is unchecked, the contents of the new view will be 
centered in the layout box. Only available when the Link View dialog is accessed via the Layout Box Specification 
dialog, and only when a scaled view is linked to another view of the same type.       

REFERENCED PLAN FILES DIALOG

The Referenced Plan Files dialog lists all plan files that the current file is linked to and allows you to relink these files. To 
open this dialog:

In a plan file, select Tools> Checks> Referenced Plan Files.

In a layout file, select Layout> Referenced Plan Files.

 
Plan Files Present

The names of all plan files with intact links to the current plan or layout are listed here.
If you want, you can select a file and click the Browse button just above the Plan Files Present field and replace the 
selected plan with a different plan saved on your system.
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Plan Files Not Found

The names of all plan files with disrupted links to the current plan or layout are listed here. Any files listed here have been 
moved, renamed, or deleted and cannot be found by the program. Intervention is required to find these files and reestablish 
their links to the current file. 
Select a missing file and click the Browse button just above the Plan Files Not Found field to open the Browse For 
Missing File dialog, which is a typical Open dialog. See Opening and Importing Files on page 44.

 l Locate the missing file in your system’s directory structure. When the missing file is selected, click Open to link it 
to the layout. 

 l You can also redirect an intact link to from a File Present in Layout to a different file in the same manner.
Be sure to choose File> Save  in the layout file when the missing files have been located to save their links to the 

layout file.

RESULTS OF MISSING FILES
If all missing files are correctly redefined, the layout opens when you click OK. 
If an error message displays, one or more of the missing files could not be replaced by the redefined file. Click OK to 
continue. The layout opens, but with the following characteristics:

 l Any plan views or CAD Details associated with the missing file(s) are blank. Only the border displays if the 
“Layout Box Borders” layer is set to display. See Layout Page Display Options on page 1339.

 l Any elevations or cross sections associated with the missing file(s) show the automatically generated lines, but any 
added CAD objects are absent. 

REFERENCED FILES

Chief Architect plan and layout files often reference a variety of external files for added detail, including: 

 l Material Textures and Maps
 l Images
 l Plant Images
 l 3D Backdrops
 l Picture Files
 l PDF Files

Whenever any view in a plan or any page in a layout is opened, the program checks for referenced files used in that view 
and will notify you if any of those files cannot be found by opening the Missing Files dialog.

The Missing Files dialog will also open whenever you Export 3D Model or Export VRML. See Importing and Exporting on 
page 1222.           

If a layout file is missing referenced files on pages that you do not view during the current session, this dialog may also 
open when you print the layout. See Layout on page 1338.           

You can also open this dialog at any time by selecting Tools> Checks> Missing Files. When accessed this way, all missing 
files associated with the current file are listed: not just those used in the current view.         
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MISSING FILES DIALOG

 
File Information

The table lists any Missing Files as well as useful information about each: 

 l Missing File reports the name and file extension of the missing file.    

 l File Usage indicates how the missing file is used in the program.    

 l Object Name states the name of the object in Chief Architect that references the file.    

 l Object Location indicates where in the file the object can be found.    

 l The next column indicates whether a missing texture is in use in the plan.    

 l File Path states the last known location of the missing file on your computer system.
Click on a line item in the table to select it and resolve it using the options on the right. Multiple line items can be 
selected; however, the selections on the right may be limited. See Shift and Ctrl Select on page 217.

 
Options

The buttons on the right offer options for resolving a selected missing file. The names of these buttons will vary somewhat, 
depending on the type of file(s) selected in the list on the left.                 

 l Click the top Replace Object button to replace any instances of an object or material referencing the selected 
missing file with a different object or material from the library. Not available for material maps, PDF files, or picture 
files.

 l Click the Replace File button to open the Browse for Missing File dialog and select a file saved on your system to 
replace the missing one. See Opening and Importing Files on page 44.

 l Click the Delete Object button to remove the object or material referencing the missing file from the plan. Not 
available for material textures that are In Use.                     

 l Click the Add Search Directory button to direct the program to a particular folder to search for missing files in. The 
list of Search folders can be reset in the Preferences dialog. See Reset Options Panel on page 131.

You can prevent this dialog from opening automatically by checking Do not display missing files again during this 
session at the bottom of the dialog. This option is not available when the dialog is opened manually. 
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Backup Entire Plan or Layout
Because Chief Architect plans contain many references to external files such as material textures and images, it is a 
good idea to make copies all the associated files when a plan is moved to a new location. You can easily do this by 

selecting File> Backup Entire Plan.         

Layout files also rely on references to plan files, images, and other files. Select File> Backup Entire Layout to copy these 
files when you want to move a layout file to a new location.          

Backing up an entire plan or layout is important when:         

 l Migrating legacy files created in older program versions.
 l Transferring files to another computer or sending them to another user.
 l Archiving or backing up your work.

Note: Always use File> Backup Entire Plan or Layout when sending files 
to a user of the Chief Architect Viewer. See Sharing Your Files with 
Clients on page 31. 

To back up a plan or layout
 1.  To copy all associated plan or layout files to a new directory, select File> Backup Entire Plan or Layout 

 2.  The Backup Entire Plan or Layout dialog opens.

 l Choose Backup Plan Files and All Referenced Files to copy the plan or layout file and all externally referenced 
files such as linked plan files, inserted picture files, metafiles, .pdf files, and texture, image,  backdrop, and material 
map files.

 l Choose Backup Plan Files Only to copy all associated plan files and any externally linked files and inserted 
picture files, but no graphics or texture files. This is best used only when transferring a file to a computer that 
already has the graphics files installed.

 l When Send Backup Files to Zip Archive is checked, the files are saved in a zipped folder. Uncheck this if you 
prefer to save them in a regular folder instead.

 l Click OK.

 3.  The Select the Plan or Project Backup Folder or Choose Zip Archive to Backup dialog opens next. This is a typical 
Save File dialog. See Saving, Exporting, and Backing Up Files on page 39.

 l Navigate to a folder on your system and select it.

 l With the destination folder for the backup selected, click OK.

 4.  If the destination folder already contains files, the program will confirm whether you want to overwrite them.
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The resulting folder contains a copy of the plan or layout file and all referenced files, and can be moved to a new 
computer.         

RETURNING VIEWER FILES
When customers review and annotate files using the Chief Architect Viewer, they only need to return the .plan and/or
 .layout files. The associated files do not need to be returned.          

 

Exiting Chief Architect
Select File> Exit to exit the program. If you have not saved any open files, you will be reminded to do so. It is better to 
save your work before exiting than to save on exit. See Closing Views and Files on page 159.

When you exit from the program using File> Exit, all Autosave files and Undo files are automatically deleted. See Auto 
Save Files on page 44 and Undo and Redo on page 293.

On a Mac, if you click the program window’s red Close button, the window will close but the program itself will continue 
to run. To close it down completely, right-click on its icon on the Dock and select Quit from the contextual menu.
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Chapter 3
 

Project Planning

The tools described in this chapter allow you to conduct preliminary budget and space planning, manage project information 
and saved views of your projects, and keep track of your time spent working on each file. 

TOPICS

Project Browser 58
Project Information 60
Time Tracker 61
Space Planning 62
Room Box Specification Dialog 64
Construction Lines 65
Construction Line Specification Dialog 66
The Reference Display 69
Finding Objects 71
Plan Check 72
Loan Calculator 73

57



Chief Architect Premier X14 Reference Manual - Project Browser

 

Project Browser
The Project Browser is a convenient way to access all of the views and Materials Lists saved with an open plan and 
all of the pages saved in an open layout. You can dock it to the top, bottom, or side of the Chief Architect window or 

let it float freely. To open the Project Browser, select View> Project Browser. See View and Side Windows on page 17.
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Plan File

The name of an open plan file displays here, and the views saved in that file are listed below. Click on a view's name to 
select it; double-click on its name to open the view; right-click on it to access its contextual menu. See Using the Contextual 
Menu on page 59, below.

 l All CAD Details saved in the plan are listed here. See CAD Details on page 340.          

 l All Cameras and overviews saved with the plan are listed here by floor. See 3D View Tools on page 1085.          

 l All saved Cross Sections and elevation views are listed here.           

 l All Floor Levels in the plan are listed here, including the Foundation and Attic. See Multiple Floors on page 743.          

 l All Materials Lists saved in the plan are listed here. See Materials Lists on page 1309.          

 l All saved Plan Views in the plan are listed here. See Plan Views on page 150.          

 l All Schedules in the plan are listed here. See The Schedule Tools on page 695.           

 l All Wall Details saved with the plan are listed here by floor. See In Wall Detail Views on page 896.           

 
Layout File

The name of an open layout file displays here. See Layout Page Management on page 1360. 

 l Any CAD Details saved with the layout are listed here. See CAD Details on page 340.          

 l Any pages that are in use in an open layout display here, in numeric order.           

 l Drag a layout page in the list from one location to another to change its position in the document.           

 l Any Layout Page or Revision Tables in the layout file are listed here. See Layout Page and Revision Tables on page 
1366.          

 
Preview Pane

A preview of the view or layout page selected in the list above displays here. Double-click on the preview to open the 
selected view or page.

  Toolbar

  Show/Hide Preview Pane toggles the Preview Pane on and off.      

  Update Preview(s) updates the previews for views associated with open plan and layout files.    

USING THE CONTEXTUAL MENU

Items in the Project Browser can be accessed, modified and organized using the contextual menu. To access its contextual 
menu, simply right-click on a line item. See Contextual Menus on page 19.           

You can also select multiple line items in the same folder as a group and then right-click to open a shared contextual menu. 
The options that are available in the menu depend on the type of objects selected. See Shift and Ctrl Select on page 217.           

 l Plan and Layout file level items have Save Plan, Close All Views, Save Layout, Close Layout, Expand All, and 
Collapse All in their contextual menus.          

 l All folder level items with contents in them have Select All, Expand All, and Collapse All in their contextual menus.           
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 l All views, floor levels, and pages can be accessed by selecting Open View or Show Page, respectively. You can also 
open a view or page by double-clicking on its name or its preview.

 l All views, floor levels, and pages have the Update Preview(s) option in their contextual menu when selected 
individually or in groups.         

 l If a plan view is open, Save View will be an option in its contextual menu. Similarly, if a camera is open, Save 
Camera will be among its options.          

 l An open a view can be closed by selecting Close View from the contextual menu.          
 l Plan Views and CAD Details have specification dialogs that can be accessed by selecting Edit View. See Plan View 

Specification Dialog on page 153 and CAD Detail Specification Dialog on page 341.          
 l Layout pages have an Edit Page Information option. See Layout Page Information Dialog on page 1364.           
 l All views aside from Floors and layout Pages can be Renamed.           
 l Plan Views, CAD Details, and layout Pages can be Duplicated.          
 l All views aside from Floors and layout Pages specified as Templates can be Deleted. See Page Templates on page 

1339.           
 l New Pages can be Inserted Before or After a selected layout Page. Layout Pages can be Exchanged, as well. 
 l Schedules and Layout Tables have a Find in Project option. See Finding Objects on page 213.         
 l A New Saved Plan View can be created in the Plan Views folder for plans and layouts.           
 l A New CAD Detail can be created in the CAD Details folder for plans and layouts.           

 

Project Information
Information about the current project, the client it is drawn for, and the registered Chief Architect user can be inserted into 
text objects to improve organization and clarity in your documents. See Text Macros on page 549.

Some of this information can also be included when exporting information to REScheck. See Export to REScheck on page 
1247.

DESIGNER INFORMATION

Designer Information is saved in the Default Designer Information dialog, which can be accessed through the 
Preferences dialog. See Text Panel on page 106.

If you would like to customize the Designer Information for a particular file, select Tools> Project Information> Designer 
Information  to open the Designer Information dialog. 

Enter information in each text field exactly as you want it to display when the corresponding text macro is used. See Text 
Macros on page 549.

CLIENT INFORMATION

Select Tools> Project Information> Client Information to open the Client Information dialog. This dialog is 
similar to the Designer Information dialog, but its specifications apply to Client text macros. This information must 

be filled out separately for plan files and layout files.

When entering new Client Information, begin by clicking the 
Clear Form button.
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Time Tracker
The Time Tracker tool monitors the time spent on each Chief Architect file. You can enter start and end times each 
time a plan or layout file is opened and closed, or allow it to run automatically. The Time Tracker keeps a log that 

can be amended and edited as needed. You can control how Time Tracker functions, including its timeout period, in the 
Preferences dialog. See Time Tracker Panel on page 116.    

Time Tracker information is stored with each file and can be printed or exported from the Time Log dialog.    

Select Tools> Time Tracker> Start Time Logging to begin logging time for the current plan or layout file. This 
creates a new entry. Opening a plan or layout automatically starts a time log if you set your preferences to do so. See 

Time Tracker Panel on page 116. 

Select Tools> Time Tracker> Stop Time Logging to stop logging time for the current file. Only available when an 
entry is currently being recorded.

Select Tools> Time Tracker> View Time Log to open the Time Log dialog and view the time log for the current 
file.

Time Tracker logs times for each plan and layout file separately, 
even if they have the same project name or are saved in the same 

directory on your computer.

TIME LOG DIALOG

The Time Log dialog displays all entries logged for the current plan or layout file. Entries can be added, deleted, 
edited, exported, and printed. 

Select Tools> Time Tracker> View Time Log to open the Time Log dialog.
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Log Entries

A summary of current plan or layout file’s Log Entries displays here. Click a column header to sort all line items in the 
table by that column. An arrow above the column indicates that it is being used to sort the table, and in which direction it is 
being sorted. Click in a row to select that entry.    

 l Click the Add button to add a new entry using the current time as the Start Time.

 l Select an entry and click the Delete button to remove it from the current file.

 l Click Export to open the Save Time Log dialog and specify a name and destination for the exported file. Time log 
information can be exported as either a text (.txt) or Comma Separated Values (.csv) file. See Exporting Files on 
page 41.

Click Print to open the Print dialog and print the log. See Print View Dialog on page 1385.

 
Selected Entry

The Selected Entry settings let you modify the entry selected in the list above.     

 l The default User name is derived from the Preferences dialog. You can select an entry and change the User here. 
See Time Tracker Panel on page 116. 

 l The Start and End times can be edited by typing new values in the text fields. You can also click the drop-down list 
and select a date from the calendar. The Start time must predate the End time. See Region and Language Settings on 
page 78. 

 l The Duration of the selected entry and the Total Duration display for reference.

 l Notes about the selected entry can be typed into the text field on the right.

 

Space Planning
The Space Planning Tools are a time-saving way to create a preliminary room-by-room design of a home without 
getting caught up in the details. When the room boxes are laid out, the Build House tool converts them into a 

working plan that can be edited and detailed to completion.         

SPACE PLANNING ASSISTANT

In plan view, select Tools> Space Planning> Space Planning. The Space Planning Assistant gathers information about the 
rooms you want to include in your house. When you click Finish, the selected room boxes display.

Room boxes can now be arranged into a floor plan. 
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Note: Each Bedroom called for in the Space Planning Assistant also 
produces a Closet.

PLACING ROOM BOXES

In addition to or as an alternative to the room boxes created for you by the Space Planning Assistant, you can create your 
own room boxes. In plan view, select Tools> Space Planning , choose the desired room type from the submenu, then 

click to place a room box of that type. 

DISPLAYING ROOM BOXES

Room boxes and their labels are located on the “Space Planning Boxes” layer. Space Planning Box labels use the Text Style 
assigned to that layer, as well. See Displaying Objects on page 180.

EDITING ROOM BOXES

Once created, room boxes can be edited in a variety of ways.

 l Select room boxes using the Select Objects  tool just like other objects in Chief Architect. See Selecting Objects 

on page 212.
 l Room boxes can be resized, rotated, and rearranged. See Editing Box-Based Objects on page 234.
 l When arranging room boxes, make sure Object Snaps  are enabled so their edges snap to one another. See Object 

Snaps on page 164.
 l Rooms can be overlapped: when this is the case, the room box edges drawn in front will be converted to walls when 

the Build House  tool is used. By default, smaller rooms draw over larger rooms; however, you can control their 

drawing order. See Drawing Groups on page 194.
 l Rooms can be copied and pasted using the Copy/Paste  edit button and deleted using the Delete  edit button.

 l Select Tools> Space Planning  or click the Space Planning Configuration  button to access the room box 

tools and place additional room boxes in your plan. Select a tool and click in the plan to place a room box of that type. 

 l Select Tools> Space Planning> Toggle Room Boxes  or click the toggle button to hide or show the room boxes.
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BUILD HOUSE

When the room boxes are in place, select Tools> Space Planning> Build House to convert them into a building 
composed of walls and railings. Doors are inserted between the rooms, as well.

When you Build House, the “Space Planning Boxes” layer is automatically turned off. The room boxes that you created are 
not deleted, however. 

MULTIPLE FLOORS

If you specified a two-story house in the Space Planning Assistant:

 1.  Edit and arrange the room boxes on Floor 1 as desired.

 2.  Select Tools> Space Planning> Build House  tool to create the walls on the first floor.

 3.  Go Up One Floor  and notice that the positions of the walls on Floor 1 display in red as a reference.

 4.  Arrange the rooms on Floor 2 as desired using the red polylines as a guide.

 5.  On the second floor, select Tools> Space Planning> Build House  to complete the second floor.

 

Room Box Specification Dialog
Select one or more room boxes and click the Open Object edit button to open the Room Box Specification dialog. 
See Space Planning on page 62.

GENERAL PANEL

Most of the settings on the GENERAL panel are used when the selected room box is converted to a room using the Build 
House  tool. 
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General

Specify the selected room box’s Room Type and Name. 

 l Specify a Room Name for the selected room box. When the default is specified, the Function selected below is used 
as the name. 

 l Select a Function from the drop-down list. See Room Types and Functions on page 420. 

 
Size

Specify the Size of the selected room box. 

 l Specify the room box’s Width and Height. 

 l Specify the Fillet Radius, which is the radius of the curve on each of the room box’s corners. Unlike the other 
settings on this panel, this value does not affect the shape of the room created using Build House . 

LINE STYLE PANEL

The LINE STYLE panel is available for a variety of other objects in the program. For more information, see Line Style Panel 
on page 310.

FILL STYLE PANEL

The FILL STYLE panel is available for a variety of other objects in the program. See  Fill Styles on page 197.

 

Construction Lines
The Construction Line tool allows you to create guide lines to help locate features of a design and ensure that 
objects are correctly aligned. In a plan view or cross section/elevation view, select CAD> Line> Construction Line, 

then click and drag to draw a line. See Line Tools on page 305.

Construction Lines can be drawn at various angles, can snap to other objects, and can be replicated. See Snap Behaviors on 
page 163. 

Once drawn, a Construction Line can be edited in a variety of ways using its edit handles, edit tools, and specification 
dialog. See Construction Line Specification Dialog on page 66.

Once in place, Construction Lines can be used to align objects in a variety of ways:

 l CAD and architectural objects can snap to Construction Lines. 
 l Dimension lines can locate them. See Dimensions on page 454.
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 l Edit tools such as Center Object and Make Parallel/Perpendicular work with them. See Aligning Objects on page 249. 
 l The Trim Object(s) and Extend Object(s) edit tools work with them. See Trim and Extend on page 276.

DISPLAYING CONSTRUCTION LINES

Construction Lines are placed on the "Construction Lines" layer by default and are included in printed views and views sent 
to layout when this layer is turned on. You can place Construction Lines on custom layers as needed for different purposes. 
You can also lock their layer to prevent Construction Lines from being selected while you are working. See Layers on page 
180.

Construction Lines can display callouts on either or both ends. They can also display as the length they are drawn, or of 
infinite length. Infinite-length lines are not included in the view extents, and if they have callouts specified, these are always 
visible at the edges of the view. See Construction Line Panel on page 66.

By default, Construction Lines are placed in Drawing Group 21, with other CAD objects. You can place them in a different 
group if you prefer, so that they display in front of or behind other objects in plan view to suit your needs. See Drawing 
Groups on page 194.

IN PLAN AND CROSS SECTION/ELEVATION VIEWS

Unlike other CAD objects, Construction Lines can display in both plan views and cross section/elevation views under 
certain conditions.

 l A Construction Line may be set to Display on All Floors in Plan View, or only on the floor level where it was drawn. 
 l If a Construction Line is drawn in plan view, it can display in any cross section/elevation view with a line of sight that 

is parallel to it, regardless of whether it is set to Display on All Floors in Plan View, and regardless of which floor 
level the view is on.

 l If a Construction Line is drawn vertically in a cross section/elevation view, it can display in plan view.

 

Construction Line Specification Dialog
To open the Construction Line Specification dialog, select a Construction Line and click the Open Object edit 
button. See Construction Lines on page 65.

The Construction Line Specification dialog is similar to the Construction Line Defaults dialog but affects the selected 
Construction Line rather than all subsequently created Construction Lines.

CONSTRUCTION LINE PANEL
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Infinite Line

Infinite Construction Lines do not affect the extents of any views they display in.                 

 l Check Draw Infinite Line in Plan View to display the selected Construction Line as infinite in length in plan 
views.          

 l Check Draw Infinite Line in Elevation View to display the selected Construction Line as infinite in length in cross 
section/elevation views.         

  Options

 l When Display on All Floors in Plan View is checked, the selected Construction Line displays on all floor levels in 
the current plan. Uncheck this to display it only the floor level where it was drawn in plan view. This setting does 
not affect the Construction Line's display in cross section/elevation views. See Multiple Floors on page 743.

 
Preview

A preview of the selected Construction Line displays on the right. See Dialog Preview Panes on page 22.         

CALLOUTS PANEL

 
Display Callout on

Specify the use of callouts in Plan View and, separately, in Elevation View. See Selected Edge on page 214.     

 l Select Both for callouts on both ends of the selected Construction Line.     

 l Select Start for a callout on the line's Start point only.     

 l Select End for a callout on the line's End point only.     

 l Select None for no callouts on either end.    
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Label

Specify the text you would like inside the selected Construction Line's callout(s).     

 l Type the Callout Label, which displays inside the callout shape. This text is centered in the callout when no Text 
Below Line is specified.      

 l Type the Text Below Line for the bottom row, if desired. If Text Below Line is added, a line centered in the callout 
shape will separate this text from the Text Above Line.      

 l Click the Insert button to the right of either Text option to choose from a list of special characters and text macros. 
See Text Macros on page 549.     

 
Shape

Select a callout shape by clicking the radio button beside one of the options.             

  Size/Orientation

 l Uncheck Automatic to enable the Size field and specify a new value. When checked, the callout is sized so that it 
encompasses its Label.     

 l Specify the Angle of the callout shape(s). Not available for Ellipse, Capsule, or Rectangle shaped callouts.

 
Custom Callout Line Options

When this box is unchecked, the callout shapes are outlined using the same attributes as the Construction Line between 
them. Check this box to enable the settings that follow and outline the callouts using custom attributes.     

 l Click the Color bar to choose a color for the callout shape outlines in the Select Color dialog. See  Color 
Chooser/Select Color Dialog on page 204.      

 l Select a Line Style for the callout shape outlines from the drop-down list or click the Library button to select a line 
style from the library. See  Line Styles on page 200.     

 l Specify the Line Weight, or thickness, for the callout shape outlines. See Line Weights on page 1379. 

 l Check the By Layer box beside any of these options to use the attribute assigned to the selected Construction Line's 
layer.    

 
Preview

A preview of the selected Construction Line displays on the right. See Dialog Preview Panes on page 22.

LINE STYLE PANEL

The LINE STYLE panel is found in the specification dialogs for many different objects. See Line Style Panel on page 310.

TEXT STYLE PANEL

The settings on the TEXT STYLE panel control the appearance of the selected object’s text. See Text Style Panel on page 
547.           
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The Reference Display
Objects     on the Current Floor can snap to objects on the Reference Floor; however, objects on the Reference Floor cannot 
be selected or edited.   

The Reference Display allows you to show the positions of objects on a different floor or even in a different plan file in the 
current view. This allows you to confirm correct placement of objects; show an as-built structure in the same view as a 
remodel drawing; compare different options; and more. The Reference Display can be used in plan, camera, and cross 
section/elevation views. 

REFERENCING A FLOOR PLAN

In plan view, the Reference Display can show one or more Reference Floors from the current plan or from another plan file 
or files.          

 l By default, the current plan file is used, the Reference Floor is the floor below the Current Floor, and the Reference 
Display uses the “Reference Display Layer Set”.

 l If you specify that the Reference Display refer to another plan file, it will show the same floor level as the current plan 
by default, if possible, and will use the “Reference Display Layer Set” as defined in that other plan file.

While the default “Reference Display Layer Set” is sufficient for most purposes, you can create additional reference layer 
sets and use any of them individually or in combination in the Reference Floor Display. See Layer Set Management on page 
188.           

Any layer set can be used as in the Reference Floor Display; 
however, for best results you should use a layer set designed 

specifically for this purpose. See Layer Sets on page 186. 

Reference Floor Display settings, including whether its display is toggled on, which floor level or levels are shown, and 
which layer set or sets it uses, are plan view specific and can be customized in the Saved Plan View Specification dialog. 
See Layout Box Specification Dialog on page 1354.           

These settings can also be customized in plan views sent to layout. See Layout Box Specification Dialog on page 1354.           

REFERENCING A 3D MODEL

In camera and cross section/elevation views, the Reference Display can show objects from another plan file, as well as 
specify whether they are shown using Standard or Glass House Rendering.           

In camera and cross section/elevation views, the default layer set for the current view type as set in the current plan is used. 
The actual layer set is saved in the referenced plan, and can be changed to use any other layer set saved in that plan. See 
Layer Set Management on page 188.

CHANGE FLOOR / REFERENCE DIALOG

Select Tools> Floor/Reference Display> Change Floor/Reference or click the toolbar button that reports the 
current floor level. See The Current Floor on page 750.

In the Change Floor/Reference dialog, you can specify which floor level is the Current Floor. You can also specify a 
Reference Floor from one or more different plan files, multiple Reference Floors, and Reference Floor layer sets and 
drawing order here, as well.          

69



Chief Architect Premier X14 Reference Manual - The Reference Display

When this dialog is accessed from a camera view, the Reference Display settings instead allow you to specify one or more 
referenced plan files, layer sets, and Rendering Techniques.           

 
Current Floor

The Current Floor is highlighted here. Select another floor from the list to make it the Current Floor instead. 
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Reference Display

The Reference Display settings control the display and appearance of the Reference Floor in the current plan view. 

 l Check Show Reference Floor(s) to turn on the Reference Floor Display in the current plan view. When a camera 
view is active, this option is instead Show Reference Model(s).          

 l Click on a line item in the table to select and edit it. Items with an arrow on the right side are drop-down lists.         

 l The floors in the table are listed in the order that they are drawn in plan view: The floor in row 1 is drawn on top of 
the floor in row 2, which is drawn on top of the floor in row 3, and so on. Drawing order can be edited using the 
buttons to the right of the table.          

 l In plan view, the Current column indicates which line item in the table is the Current Floor, selected above. In 
camera and cross section/elevation views it indicates which line item is the Current Plan. The Current line item’s 
attributes cannot be edited in this table.          

 l In plan view, specify which Floor level is associated with each line item. When “Automatic” is selected, the floor 
level below the Current Floor is always used; if there is no floor below, the floor above is used instead. If you 
instead choose a specific floor level from the list, it will be used, regardless of which floor level is the Current Floor. 
Not available for camera or cross section/elevation views.           

 l Specify which Layer Set each line item uses. See Layer Sets on page 186.           

 l Click in the Define column to open the Layer Display Options dialog and edit the Layer Set assigned to the selected 
line item.           

 l In camera views, specify which Rendering Technique each referenced plan uses. Select Standard, Glass House, 
Technical Illustration, or Vector View from the drop-down list. See Rendering Techniques on page 1147.           

 l Click in the Define column to open the Layer Display Options dialog and edit the Layer Set assigned to the selected 
line item. Not an option for the Current view.         

 l Click to place a check in the Details column and include fill patterns in the Reference Floor Display. When 
unchecked, only object edge lines are drawn. Details are always included in the Current Floor.          

 l XOR drawing changes the color of lines in the Reference Floor Display when they are drawn on top of lines on the 
Current Floor. If the lines have identical properties, they are not drawn at all. When this is unchecked, the Reference 
Display color does not change, and identical lines are not suppressed.          

Use the buttons on the right to manage the list of Reference Floors in the table. New Reference Floors use the Automatic 
floor behavior and Reference Floor Layer Set by default.          

 l Click the Insert Above button to add a new Reference Floor directly above the selected line item.           
 l Click the Insert Below button to add a new Reference Floor directly below the selected line item.           
 l Click the Move Up button to move the selected line item up one place in the list and in the display order.           
 l Click the Move Down button to move the selected line item down one place in the list and in the display order.          
 l Click the Delete button to remove the selected Reference Floor from the list. Not available if only one Reference Floor 

is present in the list, or if the Current Floor is selected.           

 

Finding Objects
There are a variety of tools in the program designed to help you locate specific objects. These tools often open a new view 
window in which the object in question is either highlighted or selected.           
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 l To find out where a line item in               a schedule or the Materials List is located in the model, select its row or any cell in 
its row and click the Find Object in Plan  edit button. See Find Object in Plan on page 703. 

 l To locate a string of text, select Edit> Find/Replace Text. See Find/Replace Text on page 524.          
 l To find objects that are similar to a selected object in the current view, click the Match Properties  edit button. 

See Matching Properties on page 286.          
 l In a               Wall Detail, Framing Overview or other 3D view in which wall framing can be seen, select a wall framing 

member and click the Find Wall  edit button to locate its owner wall in plan view. See Selecting Walls on page 

372.
 l In the Truss Detail, select a truss and click the Find Trusses  edit button to switch to a plan view in which the truss 

is selected. See Truss Details on page 916. 
 l In the Project Browser, right-click on a schedule or Layout Table and select Find in Project from the contextual 

menu. The view in which the schedule is located opens, if necessary, and the schedule or table is selected. See Project 
Browser on page 58.

Additional tools are available to help you find files referenced by your plans and layout files.           

 l Select Tools> Checks> Missing Files Check to identify and locate any missing referenced files. See Linked and 
Referenced Files on page 51.          

 l Select Tools> Layout> Referenced Plan Files to identify and locate any plans linked to the current layout file. See 
Managing Layout Links on page 1358.          

 

Plan Check
Plan Check examines the current floor of a plan, checking for anything that appears to violate common building 
practices. Plan Check may not find all the problems in a plan, but does it point out areas that may need improvement. 

Disclaimer: The Plan Check feature in Chief Architect does not 
claim to detect all building code and design requirements. It 

merely compares your plan with common building practices. 

To run Plan Check, select Tools> Checks> Plan Check .

Potential plan errors found are usually highlighted in plan view. To ensure the highlighted item is on-screen, make sure the 
entire plan is shown in the window before you run Plan Check.

PLAN CHECK DIALOG

The current error number, along with the total number of errors found, is stated at the top of the dialog.

A description of the current error displays in the field on the left.
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Options for navigating Plan Check are found on the right side.

 l Click Next to ignore the current error and proceed to the next.
 l Click Previous to return to the previous error.
 l Click Hold to suspend Plan Check so you can fix the current error. Select Tools> Checks> Plan Check again and the 

check starts where it left off.
 l Click Done to terminate Plan Check.

If this dialog obscures the plan view, drag its title bar to move it. It remembers its new position and displays there the next 
time Plan Check is run.

ROOM TYPES

Plan Check can do a much better job of checking for problems if it knows what the rooms in your plan are to be used for, 
so you should assign a Room Type to each room in your plan. See Room Types and Functions on page 420.

The first time Plan Check runs in a plan, it automatically assigns a room type to as many undesignated rooms as it can. 
Some rooms are determined by their size and shape, and others by their contents. For example, a shelf in a small room 
indicates a closet; a stove or refrigerator indicates a kitchen; or a bed, a bedroom. If the program cannot assign a room type, 
Plan Check highlights it and suggests that you do so manually. 

 

Loan Calculator
Select Tools> Loan Calculator to open the Loan Calculator dialog. This dialog lets you calculate different aspects of 
a loan for the current plan based on a variety of parameters. 
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Calculate

Specify what aspect of the loan you would like to calculate from the Calculate drop-down list:

 l Monthly Payment 

 l Loan Amount 

 l Term 

 l Interest Rate 

 
Result

The calculation Result, based on the information you provide, displays here.

 l If you make changes to any of the fields in the dialog, click the = button to refresh the Result.

 
Required Fields

The Required Fields are the same as the options in the Calculate drop-down list. The option selected under Calculate will 
be inactive under Required Fields.

 l Specify the desired Loan Amount.

 l Specify the desired Term, in years.

 l Specify the desired Interest Rate.

 l Specify the desired Monthly Payment.

 
Optional Fields

The Optional Fields allow you to include additional information in your loan calculation. 

 l Specify the expected Property Taxes per year. 

 l Specify the expected Homeowner’s Insurance cost per year. 

 l Specify the expected Private Mortgage Insurance (PMI) cost per year.

 l Specify the cost of any expected Other Fees.

When Monthly Payment is calculated, each Optional value is divided by twelve (months) and then added to the total 
payment.

When a Calculate option other than Monthly Payment is selected, these values are divided by twelve (months) and then 
subtracted from the specified Monthly Payment value. The result, which does not display, is then used to determine the 
Loan Amount, Term or Interest Rate.
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Chapter 4
 

Preferences and Default Settings

Preferences are global settings that affect the functionality and appearance of the Chief Architect environment, while default 
settings control what objects look like when they are initially created. You can save time and increase your productivity by 
becoming familiar with these settings and customizing them before you begin a new project or as needed thereafter.

If you regularly use the same customized settings, it is a good 
idea to save them in a template plan. See To create a plan 

template on page 89.
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Default Settings vs Preferences
Default and preference settings have important effects on how the tools in Chief Architect function. Default settings are file 
specific, while Preferences are global, taking effect regardless of what file is open. 

Defaults and Preferences can be customized to suit your needs and improve your efficiency, so it is recommended that you 
become familiar with them and learn how you can use them to your advantage.

DEFAULT SETTINGS

Default settings determine the initial characteristics of objects when they are first drawn. For example, when you 
place a base cabinet in a plan, its size, materials, front items, and hardware are determined by settings in the Base 

Cabinet Defaults dialog.

Some defaults affect the structure of your model: for example, Floor, Foundation, Framing, and Wall defaults.           

Defaults are file-specific, which means that any changes that you make to the default settings in one plan or layout file will 
have no effect on other plans or layout files. You can, however, import the defaults settings saved in one plan file into 
another. See Importing Default Settings on page 93.

Default settings are an important aspect of template files, which determine the initial settings of new plan and layout files 
and can be used to save you considerable time. See Template Files on page 87.           

You can access a complete list of the various default settings in the current plan or layout file by selecting Edit> Default 
Settings  from the menu.
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 l Click the + beside a category to expand it and access the defaults for items related to that category.         
 l To open the defaults dialog associated with an item in the list, double-click on the line item, or click on the item and 

then click the Edit button.
 l General CAD defaults are view-specific and are only available in views where CAD objects can be drawn. See CAD 

Defaults Dialog on page 295.           

Many defaults dialogs can also be opened by double-clicking on a parent and/or child toolbar button of a tool affected by 
the settings in that dialog. For example, you can:          

 l Double-click the Cabinet Tools  parent button to open the Defaults Settings dialog for Cabinet tools only;          

 l Double-click the Base Cabinet  child button to open the Base Cabinet Defaults dialog.          

A few defaults dialogs, such as CAD and Layer Set Defaults, do not have a parent or child tool associated with them. You 
can add optional buttons to your toolbars to quickly access these dialogs. See To add a button to a toolbar on page 137.           

You can create Hotkeys to open any of the defaults dialogs listed 
in the Default Settings dialog. See Hotkeys on page 142.

Most items have one defaults dialog that affects all objects of that type. Manual Dimensions and the Text, Callouts, and 
Markers tools, on the other hand, support multiple Saved Defaults. If you double-click one of these line items, a Saved 
Defaults dialog will open, allowing you to access and manage all defaults associated with that item. See Multiple Saved 
Defaults on page 79.          

Some objects have similar defaults dialogs which can be selected and edited as a group. Multiple Saved Defaults, Camera 
Defaults, Door Defaults, the Base, Wall, and Full Height Cabinet Defaults, and the Floor Defaults are examples. See Shift 
and Ctrl Select on page 217.          

PREFERENCES

Preference settings influence the overall environment of the program, such as what the interface looks like, how the 
tools are accessed, and the basic rules governing how objects are drawn and edited. See Preferences Dialog on page 

99. 

Unlike default settings, Preferences are global, which means that any changes that you make to them will take effect in all 
plan and layout files. 

To access the Preferences dialog, select Edit> Preferences  from the menu.

REGION AND LANGUAGE SETTINGS

There are a few formatting considerations in Chief Architect that are set based on your  operating system’s Region settings:           

 l Units of measurement - When you first install and launch the program, your template plan and layout files will be set 
to use either U.S. or metric units, depending on your operating system settings. See New Plans Panel on page 113.           

 l Currency - The currency associated with your Region settings will be used in the Materials List, Components dialogs, 
and Loan Calculator. See Materials Lists on page 1309 and Loan Calculator on page 73.           

 l Decimal mark format - Depending on your operating system settings, either a dot or a comma will be used in 
dimension lines, dialogs, and anywhere the program can display a numeric value using decimals.          

 l Thousands separator - Depending on your operating system settings, a comma, dot, or non breaking space may be 
specified as a thousands separator, or digit grouping symbol, for dimension lines.             

 l Date format - The format of                  date text macros and Sun Angle date labels vary depending on your operating system 
settings. See                  Text Macros on page 549 and Sun Angles on page 1141.
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Dynamic Defaults
Dynamic defaults are values that can be changed globally throughout the current plan or layout file. They are available for a 
variety of objects, including dimension lines, walls, doors, cabinets and rooms. 

 l If you change a dynamic default value in a defaults dialog, all objects of that type that are set to use the default will 
update automatically to use the new value.

 l Any objects of that type that are not using the default value because of editing will not be affected if you change the 
default. 

Dynamic defaults are presented in several different ways in specification dialogs. Some settings have a Use Default radio 
button, or a “Use Default” option in a drop-down list.

Dynamic default check boxes have a Default check box. Uncheck this box to make the setting not dynamic, or check it 
again to restore the dynamic behavior.

Dynamic default text fields have an Active Defaults   icon in the value field.

 l Click on the Active Defaults   icon to remove the red check mark and prevent the value from being dynamic.

 l Type a value into the text field. The red check mark is removed from the Active Defaults icon and the setting is no 
longer dynamic.

 l Click on the Defaults   icon to restore the red check mark and make the setting dynamic again. 

Materials are another example of an attribute that uses Dynamic Defaults. See Material Defaults on page 1052.

 

Set as Default
The Set as Default edit button allows you to apply the settings in a selected object’s specification dialog to the 
defaults for that type of object. 

Set as Default affects the attributes of both subsequently created objects as well as any objects using Dynamic Defaults. See 
Dynamic Defaults on page 79.           

Attributes of already existing objects that are not Dynamic Defaults are not affected when Set as Default is used, so it 
should not be viewed as an alternative to setting up defaults before you begin drawing. See Default Settings on page 76.           

The Set as Default edit tool is not available for Terrain Paths, including Sidewalks, Streams, Terrain Walls and Terrain 
Curbs. See Terrain Wall and Curb Tools on page 1261.           

 

Multiple Saved Defaults
While most objects in Chief Architect have one defaults dialog that controls how all objects of that type are created in 
a given plan, Manual Dimensions, Revision Clouds, Rich Text, Text, Callouts, Markers, and Arrows can each have 

Multiple Saved Defaults rather than just one. This lets you set these tools up for more than one requirement or task in 
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advance, and then simply specify which default you want to use as the Active Default at any given time. See Default Sets on 
page 83. 

Structural Member Reporting and CPU Ray Trace Options also have Multiple Saved Defaults. Rather than affect drawing 
tools, though, these affect the information in Materials Lists and the properties of ray trace views. See Structural Member 
Reporting on page 1312 and CPU Ray Trace Options on page 1167.

USING MULTIPLE SAVED DEFAULTS

There are a couple of different approaches to using Multiple Saved Defaults:

 l They can be created for specific tasks. For example, dimension defaults for a site plan can be placed on the 
“Dimensions, Plot Plan” layer and use a large font size and a format using feet, yards, or meters, while the defaults for 
cabinet elevations can use the “Dimensions, Kitchen and Bath” layer, a smaller font, and inches or millimeters.

 l They can be set up for use at particular scales, such as 1/4” = 1’ and 1/2” = 1’, or 1 mm = 50 mm and 1 mm = 100 
mm.

 l You can also use a combination of these two strategies.

A selection of Multiple Saved Defaults are included in the template plans installed with Chief Architect to serve as 
examples of these two approaches. You can use these sets as they are, customize them, or create new ones.

Saved Defaults are all view-specific. This means that if a Saved Default is active in a particular saved view, and you then 
Save  your work and close the view, that Saved Default will be active the next time you open the view - regardless of 

what is in use in other views. See Saved Views on page 149.

The settings associated with Saved Defaults are static, which means that objects created while one Saved Default is active 
are not affected when you switch to another Active Default. See Dynamic Defaults on page 79. 

Manually-drawn dimension lines are not affected when you switch Active Defaults; however, they do use dynamic defaults 
inherited from a Saved Dimension Defaults and will be affected if that Saved Dimension Defaults is edited. See Dimension 
Defaults Dialog on page 457. 

If an object is placed into a new file, either from the library or by 
copy/pasting, its association with a Saved Dimension Default 

and/or a Text Style is preserved. See Copying and Pasting Objects on 
page 171 and Add to Library on page 335. 

TEXT STYLES

In addition to multiple saved defaults, objects that include text within them as well as object labels can be assigned a Text 
Style, which includes properties like font, color and size. See Text Styles on page 547.

Objects that have text within them are not affected if you assign a new Text Style to their Active Defaults. If a given Text 
Style is modified, however, any objects that it is assigned to will be affected. 

             SAVED DEFAULTS DIALOG

Tools that have Multiple Saved Defaults have a Saved Defaults dialog which lets you: 

 l Make changes to existing Saved Defaults.
 l Add and remove Saved Defaults from the list of those available in the current file.
 l Specify which Saved Default is active.
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To open the Saved Defaults dialog for any annotation object type, double-click on its name in the Default Settings dialog. 
See Default Settings on page 76.

If Edit Active Default on Double-Click is selected in the Preferences dialog, you can also access the Saved Defaults dialog 
by double-clicking on the toolbar button for one of these object types. See General Panel on page 107.

Structural Member Reporting and CPU Ray Trace Options also 
have Multiple Saved Defaults. See Structural Member Reporting 

on page 1312 and CPU Ray Trace Options on page 1167.   

 
Available Saved Defaults

A list of the saved defaults for the selected object type displays and can be managed here.

 l Click on the name of a Saved Default for the selected object type in the list to select it. Select multiple line items 
using the Shift or Ctrl key. See Shift and Ctrl Select on page 217.    

 l Click the Edit button to open the defaults dialog for the selected Saved Default.    

 l Click the Copy button to create a new Saved Default. The new Saved Default is a copy of the one selected in the 
list. Multiple selected Saved Defaults can be copied as well.    

 l In the New Default Name dialog, which opens when you click Copy, type a short, descriptive, unique name for the 
new saved default. The Defaults dialog for the new Saved Default opens next. Make any needed changes to its 
settings and click OK.    

 l Click the Rename button to open the Rename Current Default dialog and type a new name for the current Saved 
Default. Names are case-sensitive and must be unique.    

 l Click the Delete button to remove the selected Saved Default from the list. Saved Defaults assigned to a Default Set 
in the current file cannot be deleted, nor can a Saved Dimension Default used by a dimension line. See Dimension 
Line Specification Dialog on page 493.    

 l Click the Select All button to select all Saved Defaults in the list.    

 l Click the Clear All button to deselect all Saved Defaults in the list.
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Currently Active Saved Defaults

The Currently Active Saved Defaults for the selected object type displays and can be changed here.    

 l Select a Saved Default from the drop-down list to make it active when you click OK.    

 l Click the Edit button to open the Defaults dialog for the Saved Default selected in the drop-down list.

Note: if you click Cancel or press Esc in the Saved Defaults dialog 
after editing, renaming, or copying a Saved Default, your changes will 
not be retained.

Click Cancel to close the dialog without retaining any of your changes. Any newly added Saved Defaults will not be 
retained. 

 

Active Defaults Dialog
You can view and modify the defaults that are currently active by selecting Tools> Active Defaults to open the 
Active Defaults dialog. 

The name of the currently active view is stated in the dialog’s title bar. In an unsaved plan view, the floor level will be 
stated instead. See View Windows on page 149. 

The settings in this dialog are also found on the SELECTED DEFAULTS panel of the specification dialog for most view types 
in the program, as well as in the Camera Defaults dialogs. See View Windows on page 149 and Camera Defaults Dialogs on 
page 1082.

Saved Defaults can also be managed in the Default Sets dialog, 
and can be grouped into Default Sets for specific drawing tasks. 

See Default Sets on page 83.
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Default Set

The Default Set that you are Currently Using is selected in the drop-down list.    

 l Select a different Default Set from the drop-down list to load its settings below and activate it when you click OK. 

 l When "Active Defaults" is selected instead of the name of a saved Default Set, you can click the Save New Default 
Set  button to create a new Default Set using the Selected Defaults and Layers settings below.    

 l Click the Edit Default Set  button to open the Default Sets dialog. See Default Sets Dialog on page 85.    

 l Click the Rename Default Set  button to give the selected set a different name. 

 l If “Active Defaults” is selected from the Currently Using drop-down list, it means that the Selected Defaults, 
below, are not associated with a saved Default Set.

When “Active Defaults” is selected, you can click the Save New Default Set button to create a new Default Set based 
on the current Active Defaults. 

 
Selected Defaults

The Selected Defaults for each of the annotation object types display and can be changed here. Note Defaults are not 
available in layout; however, they are the only defaults available in the Camera Specification dialogs. See Multiple Saved 
Defaults on page 79.    

 l Select a Saved Default from the drop-down list associated with any of the annotation object types.    

 l Click the Add  button beside any Saved Default to create a new Saved Default for the object type based on the 

one that is currently selected. Type a short, descriptive name for the new Saved Default, then modify its settings as 
needed.    

 l Click the Edit  button to open the defaults dialog for the object type and make any changes you may need to the 

selected Saved Default.    

 l Click the Rename  button to type a new name for the saved default that is currently selected.    

 l Click the Delete  button to remove the selected Saved Default from the list of those available in the plan or 

layout. Note that if a Saved Default is either in use or assigned to a Default Set, it cannot be deleted.

  Layers

 l Select a Layer Set from the drop-down list or click the Define button to open the Layer Display Options dialog. See 
Layer Sets on page 186.       

 l Select the Current CAD Layer from the drop-down list or click the Define button to open the Layer Display 
Options dialog. Not available for camera views or overviews. See Current CAD Layer on page 332.           

 

Default Sets
Default Sets are a fast, easy way to switch from one collection of Saved Defaults created for one particular purpose 
to another collection set up for a different task. 
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Default Sets include defaults for: manually-drawn Dimensions, Text, Revision Clouds, Callouts, Markers, Notes, Arrows, 
the Current CAD Layer, as well as the Active Layer Set. Multiple Default Sets can be saved in any plan, each for a specific 
purpose, and you can quickly switch from one set to another as you work. See Multiple Saved Defaults on page 79. 

Many of the objects included in Default Sets can be assigned a Text Style.               See Text Styles on page 547. 

Saved Defaults are all view-specific; so by extension, Default Sets are as well. This means that if a Default Set is active in a 
particular saved view, and you then Save  your work and close the view, that Set will be active the next time you open 

the view - regardless of what is in use in other views.          

USING DEFAULT SETS

As with Saved Defaults, there are a couple of approaches to using Default Sets:          

 l They can be created for specific tasks.           
 l They can be set up for use at particular scales.          
 l You can also use a combination of these two strategies.          

A selection of Default Sets are included in the template plans installed with Chief Architect to serve as examples of these 
two approaches. You can use these sets as they are, customize them, or create new Sets.           

ACTIVATING A DEFAULT SET

A Default Set can be selected in any view that supports Dimensions, CAD, and Text: plan view, cross section/elevation 
views, CAD Details, and Wall Details.           

Activating a Default Set really means activating all of the Saved Defaults and layer settings associated with it. There are 
three ways to activate a Default Set:          

 l Select a set from the Active Default Set Control   Default Set  drop-down, which you can add to your 
toolbars. See To add a button to a toolbar on page 137.           

 l Select a Default Set from the Currently Using drop-down list in the Active Defaults dialog. See Active Defaults 
Dialog on page 82.           

 l Open a saved view in which the Default Set was previously active.           

USING ACTIVE DEFAULTS

If a particular Default Set is active and you switch one of its Saved Defaults to a different Saved Default, the Default Set 
will no longer be considered active and “Using Active Defaults” will display in the Active Default Set Control drop-down. 
This is not a problem: it simply means that you aren’t using all of the defaults that you may have set up for a specific 
purpose.          

You can view and modify the currently active Saved Defaults in the Active Defaults dialog. You can also save the current 
defaults as a Default Set for future use, if you wish. See Active Defaults Dialog on page 82.           

CREATING DEFAULT SETS

There are two ways to create a new Default Set:           

 l Click either the New button in the Default Sets dialog.           
 l Click the Save New Default Set  button in the Active Defaults dialog.           
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DEFAULT SETS DIALOG

The Default Sets dialog lists the Default Sets available in the current plan file and lets you add, remove, edit, and 
save them. There are a number of ways to access this dialog:

 l Select Edit> Default Settings  from the menu. Select “Default Sets” and click the Edit button. See Default 

Settings on page 76.           
 l Click the Default Sets  button, which you can add to your toolbars. See To add a button to a toolbar on page 137.          

 l Click the Edit Default Set button found in the Active Defaults dialog as well as on the SELECTED DEFAULTS panel of 
various dialogs. See Active Defaults Dialog on page 82.          

 
Default Sets

The Default Sets available in the current plan or layout are listed here.  

 l Click on an item in the list to select it.           

 l The selected set is highlighted and its name displays in the Name field to the right.          

 l When a set is selected, its name and other attributes can be edited.           

 l Click the New button below the list to create a copy of the selected Default Set. Type a short, descriptive name for 
the new set in the New Default Set dialog.          

 l Click the Delete button to delete the selected Default Set from the list and the current file.          

  Default Set

 l The Name of the selected Default Set displays here. 

 l You can change its name by typing in the text field. Names are case-insensitive and must be unique. 
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Selected Defaults

The Saved Defaults for the selected Default Set are listed and can be managed here. See Multiple Saved Defaults on page 
79.     

 l Click the Add  button to create a new Saved Default for the object type based on the currently selected Saved 

Default. Type a short, descriptive name for the new Saved Default, then modify its settings as needed.      

 l Click the Edit  button to open the defaults dialog for the object type and make any changes you may need to the 

selected Saved Default.       

 l Click the Rename  button to assign a different name to the selected Saved Default.       

 l Click the Delete  button to remove the selected saved default from the list of those available in the plan or layout.       

  Layers

 l Select a Layer Set from the drop-down list or click the Define button to open the Layer Display Options dialog. See 
Layer Sets on page 186.       

 l Select the Current CAD Layer from the drop-down list or click the Define button to open the Layer Display 
Options dialog. Not available for camera views or overviews. See Current CAD Layer on page 332.        

 

Exporting and Importing Default Sets
Default Sets can be exported out of a plan or layout file and then imported into other plans or layouts.

When you export Default Sets, all of the Multiple Saved Defaults in the file are exported, regardless of whether they are 
used by a Default Set. See Multiple Saved Defaults on page 79. 

EXPORTING DEFAULT SETS

To export a plan or layout’s Default Sets, open that file and then select File> Export> Export Default Sets. The 
Export Default Sets dialog is a typical Save As dialog that lets you specify the exported file’s name and its saved 

location on your computer. See Exporting Files on page 41.

Exported Default Sets files use the .cadefs file format. Information exported in .cadefs files includes:

 l All Default Sets saved in the current file.
 l All Saved Defaults for Manual Dimensions, Text, Rich Text, Callouts, Markers, and Arrows. 
 l All Layer Sets that are associated with a Default Set. Layer Sets not associated with a Default Set are not exported.

IMPORT DEFAULT SETS DIALOG

To import Default Sets into a plan or layout, open that file and then select File> Import> Import Default Sets. After 
you select a file to import, the Import Default Sets dialog opens.
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File

The current file pathname displays here. Click the Browse button and browse to the location of a different .cadefs file you 
wish to import. If the pathname is not that of a valid .cadefs file, this text will display in red. 

 
Imported Defaults

Specify how Imported Defaults - including Default Sets and Layer Sets - are handled. 

 l Check Overwrite Existing Defaults to delete all Saved Defaults for Text, Rich Text, Callouts, Markers, Arrows, 
and Dimensions in the file and replace them with imported Saved Defaults. When this is unchecked, which it is by 
default, existing defaults are retained along with those that are imported. See Multiple Saved Defaults on page 79. 

Note: Saved Dimension Defaults are not overwritten when Default Sets 
are imported - even when Overwrite Existing Defaults is checked - if 
dimensions are present in the active file. 

 
Duplicate Names

Specify how Saved Defaults with Duplicate Names are handled. 

 l Choose Replace Existing Defaults to replace any Saved Defaults already present in the plan. 

 l Choose Rename Duplicate Defaults to retain existing Saved Defaults and rename imported defaults by appending 
them with a “2”. If subsequent Saved Defaults with duplicate names are imported, the number will increase.

If a specific Layer Set is associated with a Default Set, it will not be imported unless it does not exist in the destination file.

 

Template Files
When Chief Architect opens a new, blank plan or layout file, the new file is actually a copy of a template using either 
metric or U.S. units of measurement and predefined default settings, layer settings, wall definitions, page setup 

information, and more. 

Once you are familiar with the default settings in Chief Architect, you can create template files to fit your needs, store them 
in your Templates directory, and even specify them as the defaults for new files.

If you make changes to a default template file, all subsequently created plans or layouts will use the new default settings.

 If a template file is not specified or cannot be found, the 
program starts new plans using a set of system defined defaults. 

System defaults are very basic and unlikely to meet your drawing needs, 
so you should always specify a template plan and layout.
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USING TEMPLATE FILES

A template is used every time you create a new plan or layout file. You can specify which template files are used in the 
Preferences  dialog. 

To set a template as your default
 1.  Select Edit> Preferences  and go to the NEW PLANS panel of the Preferences dialog. See New Plans Panel on 

page 113.

 2.  Select U.S. Units or Metric Units.

 3.  Click the Browse button for either the plan or layout template.

 4.  Select a template file from the Templates directory or navigate to a different location and select a template from 
there. 

To create a new plan or layout file using a template other than the current preference, choose File> Templates> New Plan 
from Template  or New Layout from Template . The program browses to the Templates directory in your Chief 

Architect Premier X14 Data folder. See Chief Architect Premier Data on page 37. 

Note: When creating a new plan or layout using a template, be sure to 
select the appropriate units of measurement. The units used in the new 
file - U.S. Units or metric - are the same as those in the template used to 
create it.

DATA IN PLAN AND LAYOUT TEMPLATES

File-specific content and settings in a plan template include: 

 l Default Settings  . See Default Settings on page 76.

 l Default Sets  . See Default Sets on page 83.

 l Layers, layer sets, and layer settings  . See Layers on page 180.

 l Saved Plan Views. See Plan Views on page 150. 
 l Wall Type Definitions  . See Wall Type Definitions Dialog on page 390. 

 l Detail drawings, notes, and schedules in CAD Detail views. See CAD Details on page 340. 
 l Custom text macros. See Text Macros on page 549.
 l If anything is drawn in the template plan, it will be present in all new plans created with that template. 

File-specific content and settings in a layout template include: 

 l Default Settings  . See Layout Preferences and Defaults on page 1339.

 l Layers and layer settings  . See Layers on page 180.

 l Layout Page Information. See Layout Page Information on page 1363. 
 l A title block and border. See CAD and Text in Layout on page 1342.
 l Drawing Sheet Setup   settings. See Drawing Sheet Setup Dialog on page 1372.

 l Any text, dimensions, or CAD drawn on any pages of the layout will be present in all new layout files created using 
that template. Consider adding General notes and other generic text used in multiple projects, however.
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SAVE AS TEMPLATE

Template files can be created from scratch; however, if you have a plan or layout with settings and data that you 
would like to use in future projects, you can use the Save as Default tool to purge unnecessary data and save a copy 

in your Templates directory.

To create a plan template
 1.  Open the plan file with settings and data that you would like to use as a basis for a template. 

 2.  Select File> Templates> Save As Template . 
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 3.  In the Save as Template dialog for plans:    

 l Check the box beside each category of object or data that you want to delete from the current file. 

 l Unless you have a specific reason to retain a particular category, it is best to delete them all.

 l Check Set Template as Default for U.S. Units/Metric Plans to use the new template as your default template 
whenever you select File> New Plan . Leave this unchecked if you prefer to access this template by 

selecting File> New Plan From Template . See Units of Measurement on page 38.

 4.  In the Save Plan File dialog, give the template file a short, descriptive name and save it in your Templates directory.

 5.  When you click Save, the original plan file remains open, and a new plan with the specified name and save location 
is created. 

The primary difference between plan and layout files is that there are fewer default settings in layouts. In addition, most 
layout templates include a border and title block whereas plan templates are often blank.
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To create a layout template
 1.  Open the layout file with settings and data that you would like to use as a basis for a template. 

 2.  Select File> Templates> Save As Template . 
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 3.  In the Save as Template dialog for layouts:     

 l Check the box beside each category of object or data that you want to delete from the current file.      

 l Check the box beside each category of Non-Template Page Data that you want to remove from non-templates 
pages. Data on Page Templates is not affected. See Layout Page Templates on page 1363.      

 l Check Set Template as Default for U.S. Units/Metric Layouts to use the new template as your default 
template whenever you select File> New Layout . Leave this unchecked if you prefer to access this 

template by selecting File> New Layout From Template . See Units of Measurement on page 38.
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 4.  In the Save Plan Layout dialog, give the template file a short, descriptive name and save it in the Templates 
directory.

 5.  When you click Save, the original layout file remains open, and a new layout with the specified name and save 
location is created. 

UPDATING TEMPLATE FILES

To change the default settings in your template, you must open the template file as though it were a regular plan or layout 
by selecting File> Open Plan  or Open Layout .

After the necessary changes are made, save your work and close the file. 

 

Importing Default Settings
Default settings are file-specific; however, you can transfer many important default settings from one plan file to 
another by selecting File> Import> Import Default Settings. 

Not all defaults settings saved in a plan can be imported from one file to another. For example, Electrical, CAD, Floor, 
Framing, Foundation, and General Plan Defaults are not imported. 

 l Defaults associated with Default Sets are not imported but can be exported and imported separately. See Exporting and 
Importing Default Sets on page 86.

 l Saved plan views can also be separately imported. See Importing Saved Plan Views on page 152. 
 l Layer Sets can be separately exported and imported, as well. See Exporting and Importing Layer Sets on page 193. 
 l Wall Type Definitions can also be exported and imported. See Exporting and Importing Wall Types on page 395.

If the source file that you import from is from an older program version, it may be missing settings available in Version 
X14. If a default setting is missing, the system default will be imported instead. For this reason, it is best to review defaults 
before importing them and to avoid importing any defaults that are not actually present in the source file. See Template 
Files on page 87.

Bear in mind that some default settings are dynamic and, if changed, can affect existing objects in the plan. See Dynamic 
Defaults on page 79.

To import default settings
 1.  Open the plan that you would like to import default settings into. 

 2.  Select File> Import> Import Default Settings .

 3.  In the Open Plan File dialog, browse to and select the plan file that you would like to import defaults from and click 
OK. See Importing Files on page 45. 

 4.  In the Import Default Settings dialog:
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 l Use the scrollbar on the right to scroll through the list.
 l Check the box beside any defaults that you want to import.
 l Click the Select All button to place checks in the boxes beside all defaults in the list, or click Clear All to clear all of 

the check boxes.
 l Multiple line items can be selected by Shift+ or Ctrl+clicking their names. Then check or uncheck the box beside any 

selected item to affect the entire selection set. See Shift and Ctrl Select on page 217.
 l Click OK to close the dialog and import the selected defaults.

 

Reset to Defaults
Select Edit> Reset to Defaults to open the Reset to Defaults dialog. 

This dialog allows you to reset critical structural settings in the current plan to the default values. 

94



Chief Architect Premier X14 Reference Manual - Reset to Defaults

 
Reset Scope

The settings can be cleared for the current floor or for All Floors.
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Default

Specify which settings you want to reset to Default.    

 l Check Floor and/or Ceiling Heights to reset the default values as specified in the Floor Defaults dialog. Floor and 
ceiling heights for any room can be changed in the Room Specification dialog. See Floor Defaults Dialog on page 
744.    

 l Roof Groups - You can specify a room’s Roof Group in the Room Specification dialog. This builds the roof over 
this room and others in the same Roof Group independent of the roof built over other parts of the plan. Check to 
reset to the default Roof Group, zero. See Roof Groups on page 807.    

 l When Roof Directives in Walls are reset, all items on the ROOF panel of the Wall Specification dialog are reset to 
the default. See Roof Directives in Walls on page 807.    

 l Check Roof Gable Lines (Delete) to delete any Roof Gable Lines in the plan. See Gable/Roof Lines on page 846.    

 l Wall Top Heights and Wall Bottom Heights - Wall shape and height can be edited in 3D views. Check to reset 
wall shapes and heights. See Editing Walls on page 372.    

 l Overridden Dimension Text (Entire Plan) - You can suppress the dimension value associated with a dimension 
segment and replace it with text of your own. Check this to restore any suppressed dimension values and remove the 
replacement text. See Add Additional Text on page 490.

 

General Plan Defaults Dialog
The settings in the General Plan Defaults dialog control basic features of the Chief Architect environment in plan 
files. Just as with other default settings, they are file specific, which means that they can be set differently in 

individual plan files. To open this dialog, select Edit> Default Settings, select "Plan", and click the Edit button.

You can also open this dialog by double-clicking the Select Objects  button.

The General Layout Defaults dialog is similar to the General Plan Defaults dialog, but has fewer settings and is available in 
layout files only. Its settings, too, are file specific.         
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  General Settings

 l Check Warn Before Delete Selected Item if you want the program to require confirmation before an item is 
deleted.         

 l Check Ignore Casing for Opening Resize to allow wall openings such as doors to be positioned against an 
intersecting interior wall. Clear this box retain sufficient space for the opening’s specified interior trim width. Not 
available in layout files.

 l Check Allow Editing in Select Home Designer Products to allow limited editing of the current file in compatible 
Home Designer programs. See Compatibility with Previous Versions on page 35.         

 l Check Warn Before Delete Selected Item if you want the program to require confirmation before an item is 
deleted.         

 l The Arrow Key Scroll Distance setting determines how far to scroll in plan view when you press an arrow key. The 
initial default is 12 inches (300 mm). Not available in layout files. See Using the Arrow Keys on page 158.

97



Chief Architect Premier X14 Reference Manual - General Plan Defaults Dialog

 
Allowed Angles

See Angle Snaps on page 166.         

 l Select 15 Degrees to enable Angle Snaps in 15° increments.             

 l Select 7 1/2 Degrees to enable Angle Snaps in 7 ½° increments.              

 l Check Additional Angles and enter up to eight custom Allowed Angle values. Click the Number Style button to 
specify the format used to enter angles in dialogs. See Dialog Number/Angle Style Dialog on page 131.             

 
Snap Grid

See Grid Snaps on page 167.    

 l Check Use Snap Grid/Units to enable Grid Snaps.

 l Specify the Snap Unit you wish to use. The initial default is 1 inch (10 mm).

It may be helpful to temporarily change the Snap Unit when 
working with large objects such as terrain or small objects 

such as molding profiles.      

 l Uncheck Show Snap Grid to turn off the display of the Snap Grid, a visual indicator of the location of the snap 
points.           

 l Click the Color bar to specify the Snap Grid Color. See Color Chooser/Select Color Dialog on page 204.           

 l Check Display as Dots to display the Snap Grid using dots rather than lines.     

 l You can also click the Grid Snaps  toggle button to turn on/off grid snapping.     

  Reference Grid

 l Check Show Reference Grid to display the Reference Grid, the virtual graph paper used to create a sense of scale in 
plan view.             

 l Specify the Reference Grid Size.    

 l Click the Color bar to specify the Reference Grid Color. See Color Chooser/Select Color Dialog on page 204.      

 l Check Display as Dots to display the Reference Grid using dots rather than lines.           

 l You can also click the Display Reference Grid  toggle button to turn on/off the grid display.           

 
Living Area

 Not available in layout files. See Living Area on page 429. 

 l Select Main Layer to have the Living Area calculation measure from the walls’ Main Layer.

 l Select Surface to have the Living Area calculation measure from the walls’ exterior surface.

 l Uncheck Show “Living Area” to turn off the display of the Living Area label. 
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Opening Indicators

 Not available in layout files. Opening Indicators display on doors, windows, and cabinet doors in camera views when the 
"Opening Indicators" layer is turned on. See Opening Indicators on page 557.                 

 l Check Hinge Indicators Point to Handle for opening indicators to point towards the handle side of openings. When 
unchecked, opening indicators point towards the hinge side.

 

Preferences Dialog
The settings in the Preferences dialog are global: they apply to all plan and layout files and are preserved between 
sessions. To access this dialog, select Edit> Preferences in Windows® or Chief Architect> Preferences in 

macOS™. Unlike most dialogs in the program, it is not necessary to have a plan or layout file open to access the Preferences 
dialog.

The Preferences dialog has the following panels:

APPEARANCE PANEL
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Contextual Menus

 l Check Contextual Menus to activate contextual menus that display when you right-click. See Contextual Menus on 
page 19.

 l Check Click Twice to Display to require two right-clicks on an object before the contextual menu displays. This 
allows the first right-click to be used for object selection. See Selecting Objects on page 212.

 

Note: In 3D views, the two clicks must be on the same object surface 
in order for the contextual menu to display: Clicking on two different 
surfaces of the same object is treated like two single-clicks. 

 

Status Bar

 l Check Status Bar to activate the Status Bar at the bottom of the main program window. See The Status Bar on page 
25.

 l Check Show Screen Redraw Time to display the number of seconds it takes to redraw the current view. In camera 
views, multiple redraw times are reported for individual processes rather than one cumulative time.

 l Check Show Coordinates to display the coordinates of your cursor at all times on the right side of the Status Bar.

 l The coordinates’ number style is controlled in the Number Style/Angle Style dialog.  See Dialog Number/Angle Style 
Dialog on page 131.

 
Show Line Weights

Specify the on-screen display of Line Weights. See Line Weights on page 1379.     

 l Check Show Line Weights to represent line weights on-screen. Depending on your zoom factor and your monitor’s 
resolution, lines may appear to be wider on screen than when they are printed. Zooming closer may reflect a more 
accurate idea of the actual line width.

 l Specify the Minimum Display Weight, in Pixels. This is the lowest line weight possible on screen, regardless of 
how far you zoom out. A Minimum Display Weight of 0 is the same as 1. This setting is ignored when printing or 
when Print Preview  is enabled.

  Display

 l Images and Pictures - Check Display in Color when Possible to display pictures and images in color even when 
Color   is toggled off. Does not affect the display of images in any 3D views aside from Vector Views. See Color 

On/Off on page 196.

 l Menus - Check Show Icons to display tool icons next to items in the menus.

 l Color Off is - Specify whether views appear in Black and White or Grayscale when color is toggled off. Does not 
apply to any 3D views aside from Vector Views. See Vector View on page 1147.
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Dialog Previews

Specify whether Dialog Previews use the Standard or Vector View Rendering Technique by default. See Dialog Preview 
Panes on page 22.

 
Toolbars

Specify how the program's toolbars present child tools when a parent button is clicked.     

 l Choose Parent-Child to display child tools as buttons at the end of the toolbar where the parent button resides.

 l Choose Drop Down to display child tools when the drop-down arrow to the right of the parent button is clicked.

 l Uncheck Scale Toolbar Icons for High DPI to prevent toolbar icons from becoming larger on systems running 
Windows and using Custom Scaling to increase DPI resolution. When checked, toolbar buttons will increase in size 
when high DPI is used. Not available in the Mac version of the software.

 l Specify the desired toolbar Button Size, in pixels. Increasing this value will proportionally resize the text in the 
drop-down toolbars, as well. See Toolbar Button Size on page 136.

 
Side Window Drag Docking

Specify whether side windows dock to the edges of the program window. See View and Side Windows on page 17.      

 l Uncheck Side Window Drag Docking to prevent undocked side windows from docking when moved using the 
mouse. A side window can still be docked to its last docked location by double-clicking its title bar.

 l Top/Bottom Docking - Check the box beside a side window’s name to allow it to dock on the top and bottom edges 
of the program window. Does not affect docking to the left and right sides.

 
Minimum Display Size

Specify the minimum display size of Dimensions and Labels, in pixels. This is the on-screen size and does not affect 
printed or exported output. To use the printed scale, set these values to 0 or turn on Print Preview .     

 l Dimension sizes are set in the Dimension Defaults dialog. See Dimension Defaults Dialog on page 457.

 l Printed label sizes are set in the Schedule Defaults dialogs. See Labels Panel on page 709.
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COLORS PANEL
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View Colors

Specify view background colors and colors associated with selected objects by clicking a color bar to open the Select Color 
dialog. See Color Chooser/Select Color Dialog on page 204.      

 l Specify the Background color for plan view and CAD Details. The background colors for 3D views can be set in 
their defaults and specification dialogs. See Backdrop Panel on page 1121.

 l Specify the Layout Background color, which is the background color in layout files. See Layout on page 1338.

 l Specify the Selection Line color, which is the color of the lines that represent object(s) and their edit handles when 
they are selected. The opacity of this color can also be specified.

 l Specify the Selection Fill, which is the fill color for selected objects and its level of opacity. Note that depending on 
the fill assigned to a selected object, its Selection Fill color may vary.    

 l Specify the Secondary Handle Fill, which is used to identify special edit handles such as the Key Frame handles on 
Walkthrough Paths. Both color and opacity level can be set. See Key Frames on page 1206.

 l Specify the Selected Edge Handle Fill, which is the fill color of the edit handle on a selected object’s Selected Edge 
and its level of opacity. See Selected Edge on page 214.

Note: If the Selection Line and Handle Fill Colors are similar, it may 
be difficult to distinguish between active and inactive CAD Points.

 
Interface Colors

Specify the colors for a variety of different elements in the software’s interface by selecting an option from the drop-down 
list:     

 l Select “System” to use your operating system’s color settings.      

 l In the Mac version of the software, select “Force Light” to use Light Mode in Chief Architect regardless of the 
system settings, or “Force Dark” to use Dark Mode in Chief Architect regardless of the system settings.     

 l Select “Custom Color Theme” to apply a color theme to the program interface and select its characteristics below.     

The table and settings that follow are only available when “Custom Color Theme” is selected, above:

 l The table lists all available Color Themes. Click on a line item to select and activate that color theme.     

 l Locked themes are installed with the program and cannot be modified or deleted.     

 l To create an unlocked theme, select any theme in the list and click the Copy button.     

 l Select an unlocked theme and click the Rename button to specify a new name.

 l Select an unlocked theme and click the Delete button to remove the theme from the list.

 l When an unlocked theme is selected, the settings below the table are enabled, allowing you to specify the colors for 
a variety of elements in the program interface.

 l When Toolbar Button/Image Backgrounds is unchecked, toolbar buttons and images in dialogs use the 
Dialog/Toolbar Background color.

The program interface will update as you select different color themes or edit the selected unlocked theme’s color settings.

FONT PANEL

The FONT panel controls the font used by dimensions in legacy plans when they are opened in Chief Architect Premier X14, 
as well as the font used in the Materials List.
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Fonts

Specify the Fonts for use in Legacy Dimension Conversion and Materials Lists.      

 l Select Legacy Dimension Conversion from the list to specify the font used by dimensions in legacy files from 
Versions  10 to X3. See Dimensions on page 454.    

 l Select Materials Lists from the list to specify the font used by Materials Lists and the Master List. See Materials 
Lists on page 1309.    

Legacy Dimension Conversion settings only affect plans 
from previous versions when they are opened in Chief 

Architect Premier X14. Set these values to the default font that you 
used in previous versions before opening legacy files.

 l Select a Font from the drop-down list for the use selected to the left. See Fonts and Alphabets on page 503.    

 l Select one or more font styles to apply to the selected use: Bold, Italic, Underline, and/or Strikeout.

 
Preview

A sample of the selected font and style displays here.

For information about text in Chief Architect Premier X14 files, see Text, Callouts, and Markers on page 501.

LIBRARY BROWSER PANEL

The LIBRARY BROWSER panel controls the appearance of the Library Browser window. See The Library Browser on page 
962.
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View

Control the display of the main sections of the Library Browser.     

 l Check Hide Selection Pane to hide the pane that displays objects in a selected catalog or folder.

 l Check Hide Preview Pane to hide the pane that shows a preview of a selected object.

 
Selection Pane View

Specify how objects in the Selection Pane are presented.      

 l Select Tiled to Fit Window to display all items in a catalog or folder. If there are many items, their previews may 
be very small to fit in the pane.

 l Select Scrollable List to display all items in the selected catalog or folder in a scrollable list. If there are many 
objects, the list may be long but each object preview will be sized to fit the pane.

 l Check Show Names in Selection Pane to display the names of the objects in the Selection Pane.

 
Preview Pane/Selection Pane Layout

Select a radio button to change the layout of the Library Browser's sections.     

 l Vertical - Displayed sections of the Library Browser are divided vertically.

 l Horizontal - Displayed sections are divided horizontally.

 l Stacked - Displayed sections are divided both horizontally and vertically.

 
Preview Pane

Specify whether selected library items are displayed in the Preview Pane using the Standard or Vector View Rendering 
Technique. See Rendering Techniques on page 1147.

To restore the original size and position of the Library Browser and other 
side windows, click the Restore Side Windows button on the Reset 
Options Panel on page 131.
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TEXT PANEL

The settings on the TEXT panel control some behaviors affecting text objects. See Text, Callouts, and Markers on page 501.

  Text Specification Enter Key

 l Uncheck Create New Line to close the Text and Rich Text Specification dialogs when the Enter key is pressed. 
When this is checked, a new line of text is created when Enter is pressed and the dialog remains open.

 l Default Designer Information - Click the Define button to enter designer information that applies to all plans 
drawn in Chief Architect. This default may be overridden for individual plans. See Designer Information on page 60.

 
Leader Lines

Specify how the Leader Lines  tool functions. See The Text Tools on page 505.     

 l Specify the Number of Segments that text Leader Lines have. Changes to this setting affect subsequently drawn 
Leader Lines: existing lines are not affected.

 l Uncheck Create Rich Text to create Text  objects when the Leader Line tool is used. When checked, Rich Text 

 is created.
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GENERAL PANEL

  Undo

 l When Undo is checked, the Undo and Redo commands can be used. See Undo and Redo on page 293.

 l Maximum Undos - Specify how many levels of Undo and Redo you want available, from 1 to 100. Undo files are 
saved in the Undo Directory.

  Check For Program Updates

 l When Check For Program Updates is checked, Chief Architect will check for updates when the program is 
launched.

 l By default, Chief Architect checks for program updates once a day when the program is launched. You can specify a 
different frequency, in days, if you prefer.

  Dashboard

 l When Show on Startup is checked, the Dashboard window opens when Chief Architect is launched. See Dashboard 
on page 11.

 l When Show When No Other Tabs are Open is checked, the Dashboard will open when all other view tabs are 
closed. See View Windows on page 149.

 l Check Close When a New Tab is Created to close the Dashboard tab whenever a new view is opened. When this is 
unchecked, the Dashboard remains open when a new tab is created.
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  Troubleshooting

 l Check Automatically Send Error Reports to automatically send a report to Chief Architect in the event of a 
program error. This box becomes checked automatically if you click the Send Report button in an error message box. 
If an unsent error report generated during the current program session exists, it will be sent automatically if this box 
is checked by the user. See Error Messages on page 1412.

 l Uncheck Optimize for Multi-Core CPUs to turn off program optimizations for multi-core processors. This box is 
checked by default and should only be unchecked for technical troubleshooting purposes.

 l Uncheck 2D Zoom and Panning Optimizations to turn off program speed optimizations for zooming and panning 
in 2D views.

 l Check Record Timing Log to have the program create an event timing log in the Hidden User Settings Folder for 
troubleshooting purposes. Unless you are actively troubleshooting program performance, this box should be 
unchecked.

 l Check Highlight Overridden Dimension Text to highlight the text in any dimension labels where the actual 
dimension label has been suppressed. See Add Additional Text on page 490.

 l Specify the desired Pinch Zoom Sensitivity, which affects the zoom rate for touch screens, trackpads, as well as 
Ctrl+scroll wheel actions in Chief Architect. The default value is 1. See Using Input Devices on page 14.

Additional options are available in the Mac version of the software only:

   l When Mouse Movement Optimizations is checked, zooming using the mouse scroll wheel is optimized for Mac 
systems. This box is checked by default and should only be unchecked when troubleshooting issues with the mouse 
scroll wheel in the Mac version of the software.

 l Use the Mouse Scroll Sensitivity scrollbar or text field to control how sensitive the mouse scroll wheel is when 
zooming using the mouse scroll wheel in the Mac version of the software.

  Defaults

 l Uncheck Edit Active Default on Double-Click to open the Saved Defaults dialog when you double-click the toolbar 
button associated with a drawing tool that has multiple saved defaults. When this box is checked, the defaults dialog 
for the currently active saved default opens. See Multiple Saved Defaults on page 79.

 
Save Dialog Size and Position

Specify when the program should remember dialog sizes and positions: Always, Per Session, or Never. See Dialog Size 
and Position on page 21.     

 l Check Open Dialogs to the Last Panel Visited to open paneled dialogs to the last panel that you accessed during 
the current program session. When unchecked, dialogs always open to the first panel. See Dialogs on page 19.

 
Room Planner Import

Specify how window sizes in Room Planner Imports are measured. See Import Room Planner File on page 1226.     

 l Check Measure Windows from Inside of Frame to measure window heights and widths from the inside of the 
frame. When unchecked, window sizes are measured from the outside of the window frame, as they are in the 
Window Specification dialog in Chief Architect. See General Panel on page 600.
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FILE MANAGEMENT PANEL

The settings on the FILE MANAGEMENT panel let you modify functions related to the program’s plan and layout file 
management.

 

Auto Save

 l Check Auto Save, then enter a value greater than zero in the text field to specify the frequency in minutes that Auto 
Save files are created. Auto Save files are stored in the Archive folder. See Auto Save Files on page 44.

Even with Auto Save active, you should frequently save your 
work to the hard drive by selecting File> Save.
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File Locking

Choose whether or not to lock .plan and .layout files when they are open. File Locking prevents another program or copy 
of Chief Architect software from opening and modifying the same file at the same time and is recommended in nearly all 
circumstances.      

 l Select Use File Locking to lock files.

 l Select Disable File Locking to disable this feature.

 
Recent File List

Specify the maximum size and location of the Recent File List.     

 l Specify the maximum number of recently opened files to list in the Dashboard window and at File> Open Recent 
Files. You can open any of the files in this list by selecting it, making it a quick way to access your most recent 
work.

 l Uncheck Show in Submenu to display the Recent File List at the bottom of the File menu rather than in a submenu.

 
Thumbnail Images

Thumbnail images are file previews that display when opening or searching for saved plan and layout files. Thumbnail 
Images on page 36.     

 l Check  Thumbnail Images to automatically create thumbnail images when a plan or layout is first saved. If this 
option is disabled, you can still create thumbnails manually.

 l Select either Small or Large thumbnails. Large thumbnails provide a higher quality image but result in larger file 
sizes.

 
Auto Archive Files

Select an Auto Archive Files option. Every time a file is saved, the current archive file is overwritten. See Auto Archive on 
page 42.     

 l Select Hourly to save and append archive files based on an hourly format.

 l Select Daily to save and append archive files based on a daily format.

 l Select Previous Save to archive only the most recently saved file, unappended.

  Auto Archive Warning

 l Uncheck Auto Archive Warning to prevent the program from prompting you to manage archive files. When 
checked, you will be reminded to manage the current file’s archives when they reach the number specified below.

 l Enter the Maximum Files, which is the number of files that must be in a file’s Archive directory before the Manage 
Archives warning will display. See Manage Archives on page 43.
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  Auto Copy Files

 l When Copy Externally Referenced Material Files to My Data Folder is checked, the program automatically 
makes a copy of the material texture and map files associated with any custom materials that you create in your 
Chief Architect Premier X14 Data folder. This can help prevent these files from becoming lost if the originals are 
deleted. See About Materials on page 1051 and Chief Architect Premier Data on page 37.

  File Association

 l Click the Associate Files With This Program button to direct your computer’s operating system to associate all
 .plan, .layout, .calib, and .calibz files with Chief Architect Premier X14. This button will not be active if plan, 
layout, and library files are already associated with this program and version. See File Association on page 35.

FOLDERS PANEL

Chief Architect stores many support files in various folders on your computer. The default locations of these directories are 
listed and can be redefined on the FOLDERS panel if necessary.

You do not need to change default locations under normal circumstances, but sometimes it may be preferable to locate 
certain files in another location. To specify a new default folder for a particular purpose, click the Browse button to the right 
of that item.

Changing settings on the Folders panel can result in unexpected 
program functionality.

 l Important user-specific information is stored in the Chief Architect Premier X14 Data folder, which is located in 
your Documents directory by default. See Chief Architect Premier Data on page 37.
If you specify a new location, any custom toolbars or other settings that you may have will not be copied to the new 
location: you can do this yourself if you wish.

Make sure that the location you specify is accessible and has 
adequate space for the files in this folder. See Data Folder 

Name and Location on page 37.
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 l The User Library Folder contains custom library objects saved in the User Catalog in the Library Browser. When 
Keep User Library and Referenced Files in Data Folder is checked, this folder’s location will update if you specify 
a new location for the Data folder, above. When this is unchecked, this folder will remain in the location specified 
below. If you specify a new location, the program will automatically copy your existing User Library content as well 
as your Backdrops, Images, Patterns, and Textures folders to the new location. See The User Catalog on page 970.

 l By default, Temporary files and Undo files are stored in the same folder. If you wish to use a different folder, you 
must specify a directory on a hard drive with sufficient space to hold these files. See Undo and Redo on page 293.

 l Chief Architect will not let you save your work in the Temporary or Undo folder, or open files saved in either 
location.

 l All library content aside from your User Catalog is stored in the System Library Database Folder. By default, this 
folder is created in the directory intended for shared application data in your operating system (C:\ProgramData in 
Windows;/Library/Application Support in macOS). If you specify a new location, the program will automatically copy 
your library content to that location. See Library Content on page 969.

If you choose to use a different folder, you must specify a 
directory on a hard drive with sufficient space to hold these 

files. 

 l All Program Paths - Click the Show button to open the Program Paths dialog, where you can find the location of files 
that may be needed for troubleshooting purposes. See Program Paths Dialog on page 1413.

RUBY PANEL

The settings on the RUBY panel let you specify the Ruby safe level and the location of any Ruby files you may run in the 
Ruby Console. See The Ruby Console on page 1405.    

 l Select the Ruby $SAFE level you wish to use from the drop-down list. A level of 0 is unprotected and could allow a 
malicious script to be run, while a level of 5 may prevent you from using the Ruby Console productively. Level 2 is 
chosen by default.

 l In the Include in $LOAD_PATH field, specify the pathname of the directory where your Ruby scripts are stored. 
Separate multiple locations with a semi-colon.
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NEW PLANS PANEL

 
New Plans and Layouts

Specify what system of measurement new plans and layout files use, as well as what files are used as the templates for new 
files. See Template Files on page 87.     

 l Select the U.S. Units or Metric Units radio button to determine the units used in your new files. Once a new plan or 
layout is created, its measurement system cannot be changed.

Be sure that you use U.S. Unit files for your U.S. Unit 
templates and metric files for your metric templates. When a 

new file is created, it uses units of the template file regardless of your 
Preference setting.

 l Plan Template - Displays the template file the program uses when you open a new plan. Click the Browse button to 
select a new plan template.

 l Layout Template - Displays the template file the program uses when you open a new layout file. Click the Browse 
button to select a new layout template.

 
Open and Save As

Control how the program behaves when a new plan is opened or an existing plan is saved.      

 l Use Last Folder refers the program to the directory last used to save or open a plan file.

 l Use This Folder refers the program to a particular location specified by you.

 l Click the Browse button to define a particular directory when Use This Directory is selected.

UNIT CONVERSIONS PANEL

In many places throughout Chief Architect, you can specify the size of an object with any Length unit listed on the UNIT 
CONVERSIONS panel. Using the data on this panel, the program will convert your entry into the unit set in the Dialog 
Number/Angle Style dialog. See Dialog Number/Angle Style Dialog on page 131.

These conversions are also useful when you import drawings. When an object is drawn in a Chief Architect plan file, it is 
always at its true, unscaled size and the drawing is only scaled when you print it. This means that if you import a scaled 
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drawing, you must compensate for its scaling by creating a custom unit of measurement. See Import Drawing Assistant on 
page 1228.

You can also create units that measure area and volume, which can be used in custom Materials List formulas and Ruby 
macros. See Materials List Formulas on page 1325 and Ruby in Chief Architect on page 1391.

The default unit conversions are locked and cannot be changed, but custom conversions can be added to the list and later 
modified.

 
Units

A list of available units of measurement displays here. Click on the name of a unit to select it.      

 l Add, Edit, Delete, or Copy the unit conversions. Certain unit conversions are locked and cannot be edited or 
deleted.

 l If you click Add, Edit or Copy, the Add Unit Conversion dialog displays.

 
Sample

An example of how the unit selected above converts to a selection of similar units. You can use this to verify that any unit 
conversion you create is correct.
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ADD UNIT CONVERSION DIALOG

  Unit Name

 l Type a short, descriptive name of the new unit. Names must be unique: the names of units installed with the program 
cannot be used.

 l Names can include any characters, as well as spaces. Bear in mind, though, that names of units for measuring length 
that have numbers in them may be unusable if entered in some dialogs in the program.

 l Check Default Unit to display this new unit in places that present lists of available units. For example, if you have 
inches as units and make inches a default, inches appear on the list when you are given a choice of units, such as in 
the Import Drawing Assistant. In other places, such as the Materials List, all units are listed.

 
Measurement Type

Specify what the new unit measures.      

 l Select the appropriate radio button: Length, Area, or Volume.

  Conversion

 l Specify how much to Multiply by your custom unit to convert to the unit you select from the drop-down list. A 
measurement type must be selected before the list is populated.

 
Sample

An example of the Unit Conversion defined above displays here.

When importing a drawing with a 1” = 20’ scale, for example, create a unit to convert this scaling to 1” = 1”.

To create a new unit of measurement
 1.  Click the Add button to open the Add Unit Conversion dialog.

 2.  Type a short, descriptive name like “convert 1:20” in the Unit Name field.

 l Because this unit will be used only for scaling conversion, including numbers in its name will not cause any issues.

 3.  Select Length as the Measurement Type.
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 4.  Type 20 in the Multiply by field.

 5.  Select “ft” from the drop-down list.

Note: You can achieve the same results if you Multiply by 240 to 
convert to inches.

 6.  Click OK to close the dialog.

TIME TRACKER PANEL

 l Uncheck Automatically Start Timer on File Open if you do not want to begin logging time whenever a file is 
opened. If this is not checked, you must select Tools> Time Tracker> Start Time Logging  to begin logging.

 l Check Stop timer if idle for __ minutes, and enter the number of minutes to stop logging time when a plan has been 
idle.

 l Check Display Idle Timeout Dialog to warn when a plan is considered idle.
 l Specify the Default User Name used in Time Log entries. This field is initially populated by the name that you 

entered when you registered your software license. See Designer Information on page 60.

For more information, see Time Tracker on page 61.

ARCHITECTURAL PANEL
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Walls

Select the desired default behaviors for selected walls.     

 l Check Show Same Wall Type Handles to display edit handles on selected walls that draw new walls of the same 
type when dragged. See Same Wall Type Edit Handles on page 376.

 l Check Select Room Before Wall in 3D to select the room defined by a wall when you click on the wall in 3D 
views. See Selecting Rooms on page 423.

 l Check Turn on Connect Island Rooms When Opening Legacy Plans to automatically connect “island” rooms an 
Invisible wall in legacy plans opened in Version X14. See Room Definition on page 418.

 

Stairs

 l Check Stair Sections Move Independently to allow stair sections connected by landings to move separately, 
without moving the entire staircase. See Editing Stairs and Ramps on page 761.

  Rooms

 l Uncheck Enable ‘Show Room Label’ Automatic Behavior When Changing Room Types to prevent a room’s 
label from displaying when an “Unspecified” room is assigned a different Room Type in its Room Specification 
dialog. When this box is checked, the room label’s display will be enabled when the Room Type is changed from 
“Unspecified”. See General Panel on page 443.

  Roofs

 l Check Automatically Place Roof Intersection Points to automatically generate temporary CAD points that 
correspond to roof plane intersection points. When unchecked, these temporary points are not created. See Locating 
Intersections on page 826.

 
Skylight Ceiling Hole Default

See Skylights and Roof Holes on page 849.     

 l When Skylights Automatically Generate Ceiling Holes is selected, the program automatically generates a ceiling 
hole for a new skylight.

 l Select Manually Edit Ceiling Hole Polylines to create your own ceiling holes.

 
Legacy File Configuration

Specify how obsolete settings are handled when legacy files are opened in the current program version. See Considerations 
for Legacy Files on page 1417.                 

 l When Opening Indicators Point to Hinge Side is checked, the opening indicators for hinged openings point to the 
hinge side of the opening in legacy files opened in Chief Architect Premier X14. When unchecked, opening 
indicators in these files point to the handle side. See Opening Indicators on page 557.

CAD PANEL

The CAD panel contains settings that define how CAD blocks, Sun Angles and other CAD and CAD-based objects behave.
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CAD Blocks

These settings affect how fill styles are applied to CAD blocks. See CAD Blocks on page 333.     

 l Check Always use ‘By Object’ for CAD block fill style to retain the fill patterns of the component objects of all 
CAD blocks, regardless of what is specified in a given CAD block's specification dialog. When this option is 
checked, the By Block Layer setting in the CAD Block Specification dialog only affects a CAD block's line style; 
any fill style settings are ignored entirely. See CAD Block Specification Dialog on page 338.

 l Check Use ’By Object’ when creating new CAD blocks to have By Object selected in the CAD Block 
Specification dialog when a new CAD block is created. See General Panel on page 338.
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  Options 

 l Uncheck Connect CAD Segments  to prevent CAD objects from snapping together to form polylines as they are 

drawn or edited. See Connect CAD Segments on page 212.

Note: Unlike other Preferences, the program always resets Connect 
CAD Segments to be on whenever you close the program.

 l Check Advanced Splines to enable the advanced spline setting as the default editing behavior for all subsequently 
drawn splines. You can also enable this function for an individual spline by clicking the Advanced Splines  edit 

button. See Advanced Splines on page 240.

 
Line Properties

These settings affect open CAD shapes, including lines, arcs, and splines.     

 l Endcap Printed Length - The beginning and end of CAD lines that use a dashed line style are sometimes difficult 
to distinguish. Endcaps can be placed to eliminate this problem. Specify the printed endcap length in inches (mm).

 l Uncheck Show Same Line Type Handles to turn off the display of these edit handles on selected CAD objects. See 
Same Line Type Edit Handles on page 308.

 
Sun Angle

See Sun Angles and Shadows on page 1140.     

 l Define the default Latitude, Longitude and Time Zone used when creating Sun Angles.

EDIT PANEL

The settings on the EDIT panel of the Preferences dialog control the appearance of the cursor and selection behavior of edit 
handles. See Using the Crosshairs on page 251.   
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Crosshairs

You can use a cursor with Crosshairs in different view types and control its appearance. See Crosshairs on page 16.     

 l Check Enable in Plan and Cross Section/Elevation Views to use a cursor with crosshairs in plan and cross 
section/elevation views. This option is checked by default.

 l Check Enable in Perspective Views to use a cursor with crosshairs in perspective camera views and overviews.

 l When Synchronize with Cursor is checked, the mouse pointer and crosshairs always move together on screen. If 
you feel that they do not keep up with your mouse movements, try unchecking this option.

 l Click the Color bar to open the Select Color dialog and specify the color of the crosshairs.

 l Specify the Width of the crosshairs lines, in pixels.

 l Crosshairs Size is specified as a percentage of the view Window Width. Specify the Size as 100% to extend the 
crosshairs across the entire screen.

 l Set the Aperture Size, measured in pixels. The aperture is the space where the crosshairs meet. A value of 0 makes 
the crosshairs meet at a point. Larger numbers leave a gap in the center.

 
Selection

Customize the appearance of some types of selected objects, and edit handle sensitivity.      

 l Enter an Edit Handle Size in pixels. The edit handles are twice this number of pixels plus one. For example, the 
default value is 4, which results in a handle that is 9 x 9 pixels (4 x 2 = 8, and 8 + 1 = 9). The minimum value is 1, 
which results in a handle that is 3 x 3 pixels.

 l Enter a value, in pixels, for Edit Handle Tolerance to specify how close to an edit handle you must click in order to 
select it. The default value is 0.

 l Check Show Start and End Indicators to display an S and an E at the start and end points of a selected wall or the 
selected edge of a CAD-based object. This can make it easier to edit the selected edge in the object’s specification 
dialog. See Selected Edge on page 214.

 l Specify the Size of the Start and End Indicators, in pixels.

 
Marquee Selection

Specify program behavior when selecting objects using a marquee. See Marquee Select on page 216.

  Select Intersected Objects selects any objects whose bounding boxes are intersected by or located within 
the marquee. See Bounding Boxes on page 1004.

  Select Contained Objects selects only objects located entirely within the marquee. This option provides the 
best results in most situations.

  Select Objects by Center selects only objects whose center points are located within the marquee.

 You can add the Selection Modes tools to your toolbars. See To 
add a button to a toolbar on page 137. 

BEHAVIORS PANEL

The settings on the BEHAVIORS panel of the Preferences dialog define basic editing behaviors of CAD and architectural 
objects.
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Rotate/Resize About

Define the point about which an object or a group of objects rotates or resizes. See Rotate/Resize About on page 163.     

 l Select Object Center to rotate or resize the selection about its center point. Object Center is the default setting.     

 l Select Current Point to rotate the object about the current CAD point instead.

 l To resize a CAD object about a current point, select the Resize Edit Type.     

 l This function can also be accessed by selecting Edit> Edit Behaviors> Resize . See Defaults, Preferences, and 

Edit Behaviors on page 208.

 l Rotate Jump defines the angles an object or group of objects jumps to as it is rotated. When this value is set to 0°, 
the Allowed Angles set in the Plan Defaults dialog are used; otherwise, Allowed Angles are ignored.

 
Primary Movement Methods

Control the directions that you can move objects using their edit handles.     

 l Select Orthogonal to move an object perpendicular to any of its edges.     

 l Select Polar to move an object at Allowed Angles.
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Continuous Drawing Behavior

Specify whether the Continuous Drawing Behavior restarts after a closed shape is formed. See Alternate on page 209.

 l Uncheck Stop When Connected to remain in the continuous Alternate drawing mode after a closed shape is formed. 
When checked, the continuous drawing mode is halted but can be started again.

 
Edit Type

Specify the active Edit Behavior. See Defaults, Preferences, and Edit Behaviors on page 208.     

 l If Concentric is selected, specify the desired Jump increment.     

 l Uncheck Behavior Indicators to turn off the display of the mouse pointer icons associated with these Edit 
Behaviors. This box is checked by default.

Note: Unlike other Preferences, the program always restores the Default 
Edit Behavior whenever you close the program.

SNAP PROPERTIES PANEL

The settings on the SNAP PROPERTIES panel of the Preferences dialog control the behavior of Object Snaps as well as the 
appearance of snap indicators. See Object Snaps on page 164.
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  Options

 l Specify the Objects in History, which is the number of Extension Line Anchors that can display at one time.

 l Specify the Snap Distance, which is how far the cursor can be from a snap point for the snap to occur. This value is 
measured in screen pixels; the default value is 12. 
When working with very small objects, you may find it helpful to reduce this value; when working with very large 
objects, it may be helpful to increase it. 
This setting also controls the minimum length of camera and cross section/elevation lines of sight. See Creating 
Camera Views on page 1087.

 l Specify the Maximum Bump Distance, which is the distance that a selected object must be dragged to override 
bumping and move past an obstructing object.

 l Check Snap Cabinets After Paste to make the cabinets snap together after you paste them.

 l Check Always Snap Walls on Allowed Angles to limit walls to Allowed Angles. When unchecked, Object Snaps 
can override Angle Snaps, allowing walls to snap at off angles as they are drawn or edited. See Angle Snaps on page 
166.

  Snap Indicators

 l Specify a snap Indicator Size in pixels. This setting also controls the size of temporary CAD Points. See Place 
Point on page 301.

 l Click the color bar to select a snap Indicator Color from the Select Color dialog. See Color Chooser/Select Color 
Dialog on page 204.

 l Click the color bar to select an Extension Color from the Select Color dialog.

 l Click the color bar to select an Angle Snap Grid Color from the Select Color dialog.

 l Check Display Angle Snap Grid to turn on the display of the Angle Snap Grid. See Angle Snap Grid on page 167.
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Object Snaps

These options can also be turned on and off using the toggle buttons on the toolbar and/or keyboard hotkeys.     

Check Object Snaps to enable the object snap and extension snap options, below.

  Endpoint enables snapping to the ends of lines, arcs, splines and other objects.

Endpoint snaps

  Midpoint enables snapping to the midpoint of an object such as a line or arc. For objects such as boxes, you 
can snap to the midpoint of any side of the box.

Midpoint snaps

  Center enables snapping to the center of cabinets, fixtures, furniture, as well as circles and arcs.

Center snap

  Quadrant enables snapping to the left, right, top, or bottom of an object. Only used for arcs and circles.

Quadrant snaps

  On Object enables snapping to any point on the selected object, including CAD objects and cabinets.

On Object snap

124



Chief Architect Premier X14 Reference Manual - Preferences Dialog

  Points/Markers allows you to snap to temporary CAD points. Note that this only affects CAD Points, not 
Text Markers. See Point Tools on page 301.

Points/Markers snap

  Intersection enables snapping to the intersection of two objects, such as the intersection of a line with another 
line. Intersection snapping also snaps extension lines to objects, and allows you to snap two extension lines to 

each other.

Intersection snap

When Intersection snapping is enabled, wall extension line snapping will also occur. See Creating Walls on page 361.

Check any combination of Extension Snaps.

  Tangent Extensions enables snapping to a point tangent to the point where the extension anchor sits.

Tangent extension

  Perpendicular Extensions enables snapping to a point perpendicular to the point where the extension anchor 
sits.

Perpendicular extension

  Orthogonal Extensions enables snapping to a point on a 90° axis from the extension anchor.

Orthogonal extension
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  Other Snaps

  Check Bumping/Pushing to allow objects to bump into and move other objects. See Bumping/Pushing on 
page 246.       

 o Check Bumping/Pushing for Type-in Movement to cause objects moved using dimensions or the Enter 
Coordinates dialog to bump into objects in their path of movement and stop. When unchecked, objects 
moved using type-in methods move to their specified destination locations. See Moving Objects on page 
245.

  Check Angle Snaps  to enable snapping to Allowed Angles. See Angle Snaps on page 166.

MATERIALS LIST PANEL

The settings on the MATERIALS LIST panel control which categories are included in Materials Lists. The names of all 
categories and their ID prefixes are listed here. They are defined by the program and cannot be changed. See Materials Lists 
on page 1309.

When a material is entered in the Materials List, the program decides what category it goes in and assigns it an ID, which is 
the prefix followed by a number. EX1 would be the first exterior trim piece entered in the Materials List for a particular 
plan.   

 l Include These Categories - Check the categories you want to include in every new materials list generated. Before 
you hide a category, make sure you know what items are listed within it.

 l Click Select All to check the boxes beside all categories, or click Clear All to clear the check boxes beside all 
categories.

It is usually better to remove categories from individual plan lists 
in the Layer Display Options dialog, rather than globally. See 

Layer Display Options Dialog on page 183.
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REPORT STYLE PANEL

The REPORT STYLE panel controls the appearance of Materials Lists and the Master List.

 
Include These Columns

Columns can be specified for an individual Materials List by choosing Tools> Active View> Edit Active View while that 
Materials List is active. See Materials List Specification Dialog on page 1319.     

 l Check the box beside each column to include it in newly created Materials Lists.

 l Use the Move Up and Move Down buttons to change the order that columns appear. To change the order, select one 
or more items in the list and click the button. The selected columns move up or down by one in the list.

 
When Querying Suppliers and Manufacturers

Select an option to narrow or broaden your query when searching the Master List.
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Grid

Choose whether grid lines display in the Materials and Master Lists, both on-screen and printed.     

 l Check Horizontal Lines for lines between Materials List rows.

 l Check Vertical Lines for lines between Materials List columns.

 l Check Solid Lines for a solid line style. When unchecked, dotted lines are used.

  Custom Colors

 l When Custom Colors is checked, Materials Lists use the colors defined below. When this is unchecked, either the 
colors associated with the active Color Theme or your operating system’s default colors are used. See Colors Panel 
on page 102.

 l Background Colors can be specified for Odd and Even numbered rows.

 
Text Font Size

Specify the height of the font used in the Materials List and Master List. See Editing Materials Lists on page 1324.

MASTER LIST PANEL

The MASTER LIST panel specifies how the Master List(s) for materials appears. You can maintain Multiple Master Lists, but 
only one may be used at any given time. See Materials Lists on page 1309.

  Include These Columns

 l Use the Move Up and Move Down buttons to change the order of columns. To change the order, select one or more 
items in the list and click the button. The selected columns move up or down by one in the list.
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Master List File

The name and pathname of the currently referenced Master List is shown. It is referenced for all subsequently opened plans 
when a materials list is generated.     

 l Click the Browse button to select a different Master List. Navigate the directory structure until you find the new 
Master List to be used, select it, and click OK.

Note: If the Master List file is saved in the program Data folder, and 
the location of My Data Folder is changed, this pathname will 
automatically update. See Folders Panel on page 111.

 l Click the New button to create a new Master List. Name and save it in the location of your choice. When you create 
a new Master List, it is blank until you build a materials list and enter prices, supplier or manufacturer information. 
The Master List is saved automatically when you close.

RENDER PANEL

The settings on the RENDER panel control how 3D views are generated and navigated.

   General Options

 l Horizon Lines are lines that generate along the curved edges of symbol objects in Vector Views. Uncheck this box 
to increase the speed of Vector View generation but also suppress these lines. See Vector View on page 1147.

 l Hardware Edge Smoothing uses the video card to reduce the jagged appearance of angled surface edges and 
pattern lines, producing cleaner lines. The higher the smoothing effect, the longer the rendering time. See Edge 
Smoothing on page 1132.
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3Dconnexion® 3D Mouse and Gamepad

See 3Dconnexion® 3D Mice on page 1100.     

 l Select Navigate about Camera to center mouse movement about the location of the camera.

 l Select Navigate about Camera Focal Point to center mouse movement about the location of the camera’s focal 
point. See To create a camera view on page 1087.

  Troubleshooting

 l In the Windows version of the program, uncheck Enable GPU Ray Tracing to disable real-time ray tracing in the 
Physically Based and Clay Rendering Techniques. This box is checked by default and should only be unchecked for 
troubleshooting purposes. If this option is disabled, it is not supported on the system. See GPU Ray Tracing on page 
1130.

 l In the Windows version of the software, the Enable Diagnostics (Requires Restart) option makes it possible for 
information about certain errors to be collected. Restarting with Diagnostics enabled will degrade program 
performance and should only be done when requested Chief Architect Technical Support. See Contacting Technical 
Support on page 1411.

 l Manage GPU Residency helps improve performance when printing very large files. This option is checked by 
default and should only be unchecked for troubleshooting of printing issues in the Windows version of the software 
only. See Printing and Plotting on page 1368.

 l In the Mac version of the software, checking Disable Render Target Aliasing may address pixelation in camera 
views. This option is unchecked by default on most systems.

 l In the Mac version of the software, the Enable Retina Render Targets option is checked by default but should be 
unchecked on systems that do not have Retina displays.

RAY TRACE PANEL

The settings on RAY TRACE panel allow you to specify how much of your computer’s processor resources to allocate to the 
Chief Architect Ray Tracer. Changes to these settings do not affect ray traces that are in progress or queued: only ray traces 
that you start in the future. See CPU Ray Tracing on page 1163.

 l Specify the Number of Cores Used by typing in the text field or clicking the up or down arrows. The number of cores 
available will vary, depending on the number of cores your system has and whether it uses hyper threading.

 l Check Use Maximum to use the highest number of cores available on the system.

VIDEO CARD STATUS PANEL

The VIDEO CARD STATUS panel displays information about your video card, including the vendor and whether it supports 
the software's minimum requirements. See System Requirements.

This information may be important if you are having problems generating 3D views.
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RESET OPTIONS PANEL

In order for some of the Reset Options to take effect, you will need to restart Chief Architect. 

 l If message boxes have been suppressed, you can make them display again by clicking Reset Message Boxes. See 
Message Boxes on page 25.

 l Click the Reset Dialog Sizes button to restore all dialog boxes to their original sizes and positions. See Dialogs on 
page 19.

 l Click the Reset Toolbars button to reset all toolbars to their original states. If you are encountering warning messages 
regarding toolbars, this option may resolve the issue. Note that any custom toolbar configurations that you may have 
created will be discarded if you click this button. See Creating Custom Toolbar Configurations on page 138.

 l Click the Reset Templates button to restore the templates used for creating new plan and layout files. Any custom 
template files saved in the user Templates folder will not be affected by this action. See Template Files on page 87.

 l Click the Reset Side Windows button to restore all side windows to their original sizes and positions. Side window 
Settings   are also reset, as are the panes in the Library Browser. See Side Windows on page 17.

 l Chief Architect retains a list of locations where you have located missing files in the past. If you find that the program 
takes a long time searching before informing you that files are missing, you can click the Reset Search Folders button 
to clear this list. See Linked and Referenced Files on page 51.

 l Click the Reset Migration button to be prompted to migrate your content and settings from an older program version 
the next time you launch the software. 

 l Click the Reset Preferences button to restore all preferences to those originally installed with the program.

Resetting all preferences to default can be a drastic step and 
should be done with caution.

 

Dialog Number/Angle Style Dialog
At the bottom of many dialogs, you can click the Number Style button to open the Dialog Number/Angle Style dialog.

The settings in this dialog are global and control the format of distances, coordinates and angles of angles in dialog boxes 
and inline text fields, as well as in the Status Bar. They are also persistent for the current program session only: when you 
restart the program, they are reset. See The Status Bar on page 25.

These settings control the format of values used in dialogs but do not limit how you must enter these values. For example, if 
you set your Number Style to use Inches, values will display using fractional inches. You can, however, enter values using 
decimal inches, inches and feet, or even decimal feet by including the appropriate unit indicators. When the dialog you’re 
typing in updates, the value will be converted to fractional inches.    
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When U.S. Units are used, the Fractional Inches and Feet, Fractional Inches options use fractional inches with 
denominators of 2, 4, 8 and 16. A few objects, notably text, dimensions, and floor, ceiling and wall structure layers can be 
sized using smaller fractions with  larger denominators. 

Angles can be displayed using one of the following methods: 

 l Degrees/Minutes/Seconds - Measured counterclockwise from a line drawn horizontally to the right of the angle’s 
vertex. Useful for most drawing tasks. Select the level of accuracy that you require.             

 l Quadrant Bearings - Measured from a vertical line representing North/ South, Quadrant Bearings use directional 
bearings in their measurements. Useful for site drawings.             

 l Azimuth Bearings - Measured from a line drawn straight up from the angle’s vertex (ie, North on a site plan). Useful 
for site drawings, Azimuth Bearings use degrees, minutes, and seconds in their measurements.             

 l Pitch - Defined as a ratio of vertical rise to horizontal run. In U.S. Unit plans, the run is always 12”; in metric plans, it 
is 1000 mm. Useful for roofs.             

Quadrant and Azimuth Bearings are affected by the orientation of the North Pointer , if one is present in the current 

plan. See North Pointer on page 1140.

132



Chief Architect Premier X14 Reference Manual - Toolbars and Hotkeys

Chapter 5
 

Toolbars and Hotkeys

Two of the most efficient ways to access Chief Architect’s tools and settings are the toolbars and keyboard shortcuts, also 
referred to as hotkeys.

Both toolbars and hotkeys can be customized to suit your workflow.           

TOPICS

Toolbar Arrangement 134
Customizing Toolbars 136
Creating Custom Toolbar Configurations 138
Toolbar Customization Dialog 139
Hotkeys 142
Exporting and Importing Hotkeys 145
Gamepad Settings Dialog 145
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Toolbar Arrangement
Chief Architect’s toolbars provide fast access to the program’s most commonly used tools and settings, and are organized so 
that related tools are grouped together and easy to find. 

If a tool or setting is active, a small check mark will display at 
the lower right corner of its button icon.

The toolbars that display in a given view depend on the view type. For example, the toolbars that are available in floor plan 
and 3D views are not available in Materials Lists or CPU Ray Trace views. Some toolbars are available in more than one 
type of view. If a tool cannot be used in that view, its icon will appear pale grey in color.

You can turn off the display of toolbars entirely or turn them on again by selecting View> Toolbars .    

Many of Chief Architect’s tools are organized into families of related tools which can be accessed using either of two styles 
of toolbar interface: the Child Tool Palette or Drop Down tools. You can select the interface that you prefer in the 
Preferences dialog. See Appearance Panel on page 99. 

DROP-DOWN TOOLS

Click on the arrow to the right of a button to display a drop-down list of related tools. For example, click the arrow to the 
right of the Window  button to display a drop-down list of the other Window Tools. 

The most recently selected tool displays in the toolbar.   

CHILD TOOL PALETTE

An alternative to Drop-Down toolbars is the Parent button and Child Tool Palette interface. Parent toolbar buttons have a 
blue triangle in the lower right corner. When you select a Parent button, its Child tools display in the Child Tool Palette. If 
the Child Tool Palette has been closed, it will open.

By default, the Child Tool Palette is docked on the left side of the program window; but it can be undocked and moved, as 
well as resized and closed, just like other side windows. See Side Windows on page 17.

As long as it is open, the Child Tool Palette will also display the members of a selected tool’s family when the Drop Down 
interface is active. If you select a tool that does not belong to a family, the previously selected tool’s family will continue to 
display in the Tool Palette.

When you click the Window Tools  Parent button, for example, its Child buttons display in the Child Tool Palette.
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Click the Settings  button at the bottom of the palette to select how the tools within it are presented: 

   Fit Palette: resize the palette so that it is one row wide. 

   Grid View: display only the button icons of the child tools in a grid that may have multiple rows, depending on 
the width of the palette side window.

   List View: display child tools in a vertical list with each tool’s button icon and name in a row.

You can open the Tool Palette at any time, even when Drop Down tools are enabled, by selecting View> Tool Palette . 

See View Tools on page 156.

DROP-DOWN CONTROLS

In addition to tool and setting buttons, there are a number of drop-down controls   Plan View  that let you choose 
between a selection of layer and active default settings, and can be added to your toolbars:          

  Saved Plan View Control - See Plan Views on page 150. 

   Active Layer Set Control - See Activating a Layer Set on page 187. 

   Active Dimension Defaults Control - See Saved Dimension Defaults on page 456. 

  Saved Plan Views and Default Sets allow you to quickly switch layer sets and activate multiple saved defaults at once:               

   Active Default Set Control - See Activating a Default Set on page 84. 

THE EDIT TOOLBAR

The Edit Toolbar is a special toolbar that only features buttons when one or more objects in the drawing window is selected. 
By default, it is located at the bottom of the program window, just above the Status Bar. The buttons on this toolbar vary, 
depending on the type of object selected, the current view, and how you selected the object; when no object is selected, it is 
blank.

TOOLBAR CONFIGURATIONS

Chief Architect installs a set of Toolbar Configurations, which control what tools are initially included in the toolbars, as 
well as where these toolbars are located.         

   The Default Configuration displays architectural tools used for house design, including walls, windows, doors, 
stairs, cabinets, etc. 

   The Terrain Configuration displays buttons associated with the terrain and road tools, including the plant and 
sprinkler tools. See Terrain Toolbar Configuration on page 1250.

   The Space Planning Configuration displays buttons associated with the Space Planning Assistant. See Space 
Planning on page 62.             

   The Extended Configuration displays an extensive selection variety of tools for various uses.           
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To switch toolbar configurations
There are several ways to switch from one Toolbar Configuration to another.          

 l Click a Toolbar Configuration button.          
 l Choose a configuration in the Toolbar Customization dialog. See Configurations Panel on page 141.          
 l Right-click in an empty space on any toolbar and select a Toolbar Configuration from the contextual menu.           

TOOLBAR BUTTON SIZE

By default, toolbar buttons are sized at 20 pixels, which works well on most computer monitors running default system 
settings. If you wish, you can increase or decrease this size in the Preferences dialog. See Appearance Panel on page 99.

 

Customizing Toolbars
The Toolbar Configurations installed with the program are designed to help make tools quickly and easily accessible; 
however, for greatest efficiency, you may want to customize them to meet your own particular needs. A number of options 
are available:          

Any changes made to an existing Toolbar Configuration will be saved whenever you:          

 l Switch to a different configuration;              
 l Close the Toolbar Configuration dialog;              
 l Exit out of Chief Architect.             

Bear in mind that the size of the Chief Architect program window and the space available for toolbar button depends on 
your monitor’s size and screen resolution settings.          

TOGGLING TOOLBARS

You can turn off the display of all toolbars entirely or turn them on again by selecting View> Toolbars.   

There are also several ways to toggle individual toolbars on or off:         

 l Right-click in an empty space on any toolbar and mouse over Toolbars in the contextual menu. In the submenu, 
toolbars with a check mark next to their name are on in the current view. Click on a toolbar name to turn it off if it is 
on, or vice versa.             

 l Toolbars can be turned on or off in the Toolbar Customization dialog. See Toolbar Panel on page 140.
 l If a toolbar is undocked, click the Close button at its top right corner.             

MOVING TOOLBARS

You can move any toolbar to a different location by clicking and dragging its dotted grab bar. Toolbars can be docked to 
any side of the program window, or they can be undocked and left floating. 

Undocked toolbars can be moved outside the program window, and they can be closed completely. They can also be 
reshaped; however, they cannot be resized in such a manner that any buttons become hidden.

Changes to toolbars are saved between program sessions.          
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ADDING AND REMOVING BUTTONS

Toolbar buttons can be added to or removed from toolbars using the Toolbar Customization dialog.         

To add a button to a toolbar
 1.  Select Tools> Toolbar and Hotkeys> Customize Toolbars  and go to the TOOLS panel of the Toolbar 

Customization dialog. See Tools Panel on page 139.             

 2.  Select the View Type that you want to add a toolbar button in.             

 l You can add any buttons you like to any View Type; however, not all buttons will necessarily be available for use 
in all views.                  

 3.  Search or browse to find the desired button or its parent in the Available Toolbar Buttons list.             

 4.  Click and drag the button you wish to add to a toolbar out of the dialog box.             

 l Drop it onto an existing toolbar to add the button to that toolbar.                 

 l Drop it away from an existing toolbar to create a new toolbar. See To create a new toolbar on page 137.                  

To remove a button from a toolbar, open the Toolbar Customization dialog, then click and drag the button out of the toolbar 
area.          

Buttons cannot be added to or removed from the Edit Toolbar. See The Edit Toolbar on page 135.         

ADDING AND REMOVING TOOLBARS

Toolbars can be added to or removed from each View Type using either the toolbar contextual menu or the Toolbar 
Customization dialog.         

To add or remove an existing toolbar
 1.  Right-click on an empty space in a toolbar.              

 2.  In the contextual menu, click on the name of a toolbar.              

 l If the toolbar has a check mark next to it, clicking on it will clear the check mark and remove the toolbar from the 
current View Type.                 

 l If the toolbar does not have a check mark next to it, clicking on it will add the toolbar to the current View Type.                 

You can also specify which toolbars are used in each View Type in the Toolbar Customization dialog. See Toolbar Panel 
on page 140.           

CREATING NEW TOOLBARS

New toolbars can be created using the Toolbar Customization dialog.         

To create a new toolbar
 1.  Select Tools> Toolbar and Hotkeys> Customize Toolbars  and go to the TOOLS panel of the Toolbar 

Customization dialog.             

 2.  Select the View type to which you want to add a new toolbar.             

 3.  Select the first button that you want on the toolbar from the Available Toolbar Buttons list.             

 4.  Click and drag the button out of the dialog box and drop it:
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 l In an empty section of the program window border to create a new toolbar docked at that location.

 l In the drawing area to create a new, undocked toolbar.

 5.  Additional buttons can be added by dragging them onto to this new toolbar.

Use the Empty Space button in your toolbars as a spacer.
 

 6.  A new toolbar will inherit the name of the first tool that was added to it, preceded by the word Custom. You can 
assign a new name on the TOOLBAR panel of the Toolbar Customization dialog.

 7.  Also on the TOOLBAR panel, specify the View Types that the new toolbar should be used in.

LOCKING TOOLBARS

When your toolbars are organized the way you want them, you can select Tools> Toolbars and Hotkeys> Lock 
Toolbars to prevent them from being moved. Select the same tool to unlock toolbars. Lock Toolbars is also 

available in the contextual menu for toolbars: right-click in an empty space on any toolbar to access it. See Contextual 
Menus on page 19.         

RESTORING TOOLBARS

To discard your changes and restore all installed Toolbar Configurations to their original condition, click the Reset 
Toolbars button in the Toolbar Customization dialog. See Toolbar Panel on page 140.         

Because resetting toolbars affects all installed Toolbar Configurations, you may find it worthwhile to create your own 
custom Toolbar Configurations. See Creating Custom Toolbar Configurations on page 138.         

You can also restore toolbars to their original state in the Preferences dialog; however, please note that if toolbars are 
restored using this option, any custom configurations that you have created will be discarded. See Reset Options Panel on 
page 131.         

 

Creating Custom Toolbar Configurations
If you extensively edit your toolbars, consider creating one or more custom Toolbar Configurations so that your changes can 
be backed up as well as transferred to a different computer if you wish. 

To create a custom configuration
 1.  Go to the CONFIGURATIONS panel of the Toolbar Customization dialog. See Configurations Panel on page 141.

 2.  Select a configuration similar to the one you want to create and click Copy.             

 3.  Give the new configuration a short, unique name. It will be saved in the Chief Architect Premier X14 Toolbars 
folder. See Chief Architect Premier Data on page 37.             

 4.  When you click OK, the new configuration will appear in the list, and it will be active.             

 5.  On the TOOLBARS panel, select each of the different View Types to see the toolbars active in each and confirm that 
they suit your needs.             

 6.  You can now move toolbars, add or remove buttons, and add or remove toolbars to meet your requirements.             

 7.  When you are satisfied with your new Toolbar Configuration, click Close.             
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It is a good idea to back up your custom Toolbar Configurations 
files. See Chief Architect Premier Data on page 37.

CUSTOM CONFIGURATION BUTTONS

By default, new Toolbar Configurations display a default configuration   button; however, if you want you can make your 

own button icon for your custom Toolbar Configuration.          

Create a .bmp file with the same name as the configuration and save it in the Toolbars folder. To see an example, look at 
the Default .bmp file in the Chief Architect Premier Toolbars folder, which corresponds to the Default Toolbar 
configuration. See Chief Architect Premier Data on page 37.          

 l Toolbar button bitmaps must be 20 x 20 pixels in size.             
 l The color (R:192, G:192, B:192) maps to the system 3D face color.             
 l The color (R:128, G:128, B:128) maps to the system 3D Shadow color.             
 l The color (R:223, G:223, B:223) maps to the system 3D light color.             

IMPORTING CUSTOM CONFIGURATIONS

Toolbar Configurations can be imported into the program, allowing you to transfer custom configurations between 
computers as well as add backed up configurations to new installations.          

To import a custom configuration
 1.  Go to the Configurations tab of the Toolbar Customization dialog.             

 2.  Click Add.             

 3.  Browse to the location of the toolbar you want to import.             

 4.  Click Open. If the .toolbar file is not in the Chief Architect Premier X14 Toolbars folder, a copy of the file will be 
created there.             

 

Toolbar Customization Dialog
Select Tools> Toolbars and Hotkeys> Customize Toolbars to open the Toolbar Customization dialog. You can 
also right-click in an empty space in any toolbar and select Customize Toolbars from the contextual menu.

In the Toolbar Customization dialog, you can:

 l Add and remove buttons from toolbars.
 l Specify which toolbars display in different view types. 
 l Select the active Toolbar Configuration.

The Toolbar Customization Specification dialog has the following panels:

TOOLS PANEL

From the TOOLS panel, you can add or remove buttons from your toolbars, as well as create new toolbars.
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View Type

Select the View Type that you would like to add toolbar buttons to. When the dialog is first opened, the selected View Type 
is that of the current view. If you select a different View Type, the toolbars associated with it will display behind the dialog 
for reference until you click the Done button.         

 
Available Toolbar Buttons

The Available Toolbar Buttons display in a list that can be searched or browsed.         

 l Type a keyword or the name of a tool in the Search field. As you type, only buttons that match your search will 
display. 
When nothing is typed in this field, all buttons will display in the list. 
If a child tool matches your search, its parent will display in the search results. Click the arrow next to the parent’s 
name to see the child tools.         

 l The Available Toolbar Buttons list can be browsed using the scrollbar to the right.          

 l Click on a button in the list to display a description of that tool, below.          

 l Parent tools have an arrow to the right of their button icon in the list. Click on this arrow to display the child tools 
below the parent. See Toolbar Arrangement on page 134.          

If you do not see a particular button in the list, it may be the child of a parent tool.

 
Tool Description

When a button is selected in the list above, a description of it displays here.         

TOOLBAR PANEL

The TOOLBAR panel allows you to manage the use of individual toolbars.         
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View Type

When this dialog is first opened, the selected View Type is that of the current view. If you select a different View Type, the 
toolbars associated with it will display behind the dialog for reference until you click the Done button.         

 
Toolbars

The Toolbars table displays the names of all available toolbars, along with the View Types in which they are in use.         

 l Select a toolbar by clicking on its name.          

 l Click to place a check mark in a column to add the selected toolbar to that View Type; click on check mark to 
remove it.         

 l Double-click on a toolbar in the Toolbar Name column to rename it. Toolbar names must be unique.         

 l Click Delete to remove the selected toolbar from the list. A deleted toolbar is no longer available in any View Type.         

 l Click Reset Toolbars to restore all the toolbars to their original configuration. See Restoring Toolbars on page 138.          

Clicking the Reset Toolbars button removes all changes that you 
may have made to all installed Toolbar Configurations.

CONFIGURATIONS PANEL

The CONFIGURATIONS panel allows you to add, remove, and switch between Toolbar Configurations. See Toolbar 
Configurations on page 135.
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A list of Toolbar Configurations displays here. Select a configuration before clicking the Remove, Copy, or Switch To 
buttons.         

 l Click Switch To to switch to the selected Toolbar Configuration, making it active. See To switch toolbar 
configurations on page 136.

 l Click Copy to create a copy of the selected Toolbar Configuration.          
 l Click Remove to remove the selected Toolbar Configuration. This removes the configuration from the list but does not 

delete the configuration file permanently. If only one configuration is listed, it cannot be deleted.          
 l The location of the Current Toolbars Folder displays below. See Chief Architect Premier Data on page 37.         

 

Hotkeys
Many Chief Architect tools have a keyboard shortcut, or hotkey, associated with them. If such a hotkey exists, it will display 
to the right of the tool’s name in the menu.

To use a hotkey, simply press the appropriate key or combination of keys on your keyboard instead of selecting the menu 
item or clicking the toolbar button. For example, press the Ctrl and Z keys at the same time to perform an Undo .

Note: If a key or key combination is in use as a system hotkey, it cannot 
be used as a program hotkey.   

You can specify the hotkeys associated with Chief Architect tools in the Customize Hotkeys dialog. In this dialog, you can 
program hotkeys to activate tools and invoke a variety of commands such as opening dialogs, including Defaults dialogs.          

Number keys can be, and are, used as hotkeys. Bear in mind that if a number key is assigned as a hotkey, the corresponding 
number pad key will invoke the same command as long as it is not assigned to something else. The converse, however, is 
not true: if a number pad key is assigned as a hotkey, the corresponding number key will not invoke that command.           
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CREATE HOTKEY LIST

A list of the hotkeys available to the current program user can be saved in .html or .xhtml format.    

Select Tools> Toolbars and Hotkeys> Create Hotkey List to open the Save Hotkey List File dialog, a standard Save 
dialog, and create a hotkey list that can then be opened in a web browser window and printed, if you wish.    

NEXT/LAST COMMAND

You can navigate a list of up to 100 recently used tools using the Cancel Selection/Previous Command, Next Command 
and Previous Command hotkeys. The tools in this list are organized according to the order in which you selected them 
during the current program session.           

Cancel Selection/Previous Command, Next Command and Previous Command are hotkeys only: they do not have 
toolbar buttons associated with them and are not found in the menu.           

By default, Cancel Selection/Previous Command is assigned to the Esc key. This command can be used to:          

 l Cancel a current object selection.          
 l Cancel a current drawing or editing action that is in progress.          
 l Activate the previously used tool or command if no object is selected or action in progress.          

When canceling a selection or a command, be careful to press 
the Esc key only once to avoid changing the currently active 

tool.

By default, Next Command is assigned to the Shift+Esc keys. This command can be used to deactivate the current 
command and instead activate the one that is next in the list of recently used tools.           

If you prefer, you can assign two different hotkeys to the Cancel Selection and Previous Command instead of one single 
hotkey.           

CUSTOMIZE HOTKEYS DIALOG

Select Tools> Toolbars and Hotkeys> Customize Hotkeys to open the Customize Hotkeys dialog.         
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  Show Commands/Hotkeys Containing

 l Click on an item in the list of Command Names and Hotkeys to select it.          

 l To filter the list, type part or all of a tool name or hotkey in the Search field, above. As you type, the list below will 
be filtered to only show items with either a Command Name or Hotkey that contains what you have typed.           

 
Tool Available In

A list of the View Types that the selected command can be used in displays here.         

 
Description

A brief Description of the selected command displays here.         

 l Click on an item in the list of Commands and Hotkeys to select it.          
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Edit hotkey for this command

Click in this field, then press the key or key combination that you would like to use.         

 l Create a simultaneous hotkey combination by holding down the Shift, Ctrl, and/or Alt keys and typing an additional 
letter or number.          

 l Create a hotkey sequence by typing up to four hotkeys or hotkey combinations, one after the other.           

Note: Default hotkeys use the number keys and number keypad 
interchangeably. User defined hotkeys, however, do not. As such, when a 
custom hotkey is defined here, characters typed using the numpad begin 
with “Num +” in Windows, and “Num” on a Mac.

Bear in mind that while nearly all commands can be assigned custom hotkeys, a few cannot: Delete and Enter Coordinates 
are two notable examples. Hotkeys reserved by the operating system cannot be used, either.

 
Reset Hotkeys

Click the Reset Hotkeys button to restore the default hotkeys that were originally installed with the program.         

 

Exporting and Importing Hotkeys
Customized hotkeys are user specific and are saved in the Chief Architect Premier X14 Data folder. See Chief Architect 
Premier Data on page 37. 

Hotkeys can be exported, making them available for import on another computer, or even by another user on the same 
computer.

EXPORTING HOTKEYS

To export hotkeys, select File> Export> Hotkeys. The Export Hotkeys dialog is a typical Save As dialog that lets 
you specify the exported file’s name and its saved location on your computer. See Exporting Files on page 41. 

Exported hotkey files use the .xml file format. Information exported includes both customized hotkeys and hotkeys installed 
with the program. 

IMPORTING HOTKEYS

To import hotkeys, select File> Import> Hotkeys. The Import Hotkeys dialog is a typical Open File dialog. See 
Importing Files on page 45. 

When hotkeys are imported, the existing User Hotkeys.xml file is replaced by the imported data. Any previously 
programmed custom hotkeys will not be retained. 

 

Gamepad Settings Dialog
The Gamepad Settings dialog allows you to map gamepad buttons to commands and specify thumbstick behavior in 
Chief Architect. Select Tools> Toolbars and Hotkeys> Customize Gamepad to open this dialog. See Gamepads on 

page 1100.

You can also open this dialog by clicking the Gamepad Settings button, which you can add to your toolbars. See To add a 
button to a toolbar on page 137.
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You can also specify whether navigation is centered about the location of the camera or its focal point in the Preferences 
dialog. See Render Panel on page 129. 

BUTTONS PANEL

 
Enable Gamepad

Check this box to allow Chief Architect to recognize a gamepad on your system and enable the other settings in this dialog.         

 
Command Names

On the left side of the dialog is a list of tools and commands in Chief Architect that have a programmable hotkey.         

 l Filter the list by typing in the Show Commands/Hotkeys Containing text field.

 l Click on a line item to select it.          

 
Button Assignments

On the right side of the dialog is a list of typical gamepad buttons and the commands in Chief Architect that they are 
mapped to.         

 l Click on a line item in this list to select it.

 l Click the Assign Selected Hotkey to Selected Button button above the list of assignments to assign the command 
selected on the left to that gamepad button.          

 
Reset Commands

Click this button to restore the default commands associated with each gamepad button.         
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THUMBSTICKS PANEL

 
Speed

When Linear Acceleration is checked, camera acceleration is always directly proportional to the amount the thumbstick is 
pushed. When unchecked, acceleration is increased on a curve, allowing more precision on the low end, and more speed on 
the high end.

  Left Thumbstick

 l When Change Camera Height When Moving in 3D, the left thumbstick can be used to change the camera height 
in 3D. Uncheck this to maintain a consistent camera height instead.    

 l Use the slider bar or text field to specify the 2D Sensitivity, which controls how quickly the view pans in plan and 
elevation views.    

 l Use the slider bar or text field to specify the 3D Sensitivity, which controls how quickly the camera moves in 3D 
views. 

  Right Thumbstick

 l When Invert X-Axis in 3D is unchecked, pushing the right thumbstick to the left rotates the camera to the left. 
When checked, pushing this thumbstick to the left rotates the camera to the right.    

 l When Invert Y-Axis in 3D is unchecked, pushing the right thumbstick to the up rotates the camera upward. When 
checked, pushing the thumbstick up rotates the camera downward.    

 l Use the slider bar or text field to specify the 2D Sensitivity, which controls how quickly the view zooms in plan and 
elevation views.    

 l Use the slider bar or text field to specify the 3D Sensitivity, which controls how quickly the camera rotates in 3D 
views. 

 
Reset Thumbsticks

Click this button to restore the default Left and Right Thumbsticks settings on this panel. 

147



Chief Architect Premier X14 Reference Manual - Window and View Tools

Chapter 6
 

Window and View Tools

The View and Window Tools let you control how views of your drawing are shown on screen, as well as toggle useful 
drawing aides on and off.

By default, Premier uses a tabbed document interface. The name of the file and the type of view displays at the top of each 
view window in its title bar. If the view is saved, its name also displays. 

TOPICS

View Windows 149
Plan Views 150
Plan View Specification Dialog 153
Working in Multiple Views 154
View Tools 156
Zoom Tools 157
Fill Window 158
Panning the Display 158
Closing Views and Files 159
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View Windows
In Chief Architect Premier, there are several different types of views:

 l Plan Views, see page 150
 l 3D Views, see page 1080
 l Cross Section/Elevation Views, see page 1086
 l Materials Lists, see page 1309
 l CAD Details, see page 340
 l Layout, see page 1338

Each view displays in a view window. While multiple views can be open and display on screen, only one view window can 
be active at any given time. See Working in Multiple Views on page 154. 

 l Plan, 3D, and cross section/elevation views are found in plan files only. Each view window can show the model from 
a different perspective and display a unique set of information about it, making them useful for a variety of drawing 
tasks and print requirements.             

 l Materials Lists are found in plan files only and contain a list of objects found in the model along with their 
components and information like floor level and counts.           

 l CAD Details can be found in both plan and layout files and only contain 2D objects like CAD and Text.           
 l Layout files are composed of multiple pages. A given layout view window can only display a single page at a time.             

SAVED VIEWS

Most new views in plan files are temporary: if you close the view window, the view will not be retained. Two exceptions to 
this rule are CAD Details and Auto Elevations, which are saved automatically when they are created. See CAD Details on 
page 340. 

If you add view-specific information to a view: for example, by adding text to a cross section/elevation view, you will be 
prompted to save the view.          

ACTIVE VIEW TOOLS

When a plan file is active, select Tools> Active View for tools that allow you to manage the current view. Not 
available when a layout file is active.           

You can specify that any view be saved by selecting Tools> Active View> Save Active View. If the current view is 
unsaved, you will be prompted to give it a name. If it was previously saved, its saved attributes will be updated. If the 

active view is currently using all of its saved attributes, this tool will not be active.

You can also use Tools> Active View> Save Active View As to create an exact copy of the currently active view. 
Regardless of whether the current view is saved or not, you will be prompted to give the new view a name.          

You can specify that any plan, camera, cross section/elevation view, or Materials List be saved. See Plan Views on page 150 
and Saving 3D Views on page 1114.         

When a view is saved, all of its attributes are retained, including the:          

 l Floor level         
 l Extents of the view         
 l Color toggle         
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 l Active Layer Set           
 l Active Saved Defaults          
 l Watermark           

If any of these attributes are changed, the changes will not be retained when you close the view unless the view is first re-
saved.           

Some additional settings are also view specific, although they do not require that a view be re-saved when they are changed:          

 l Saved Defaults or active Default Set          
 l Print Preview toggle          
 l Drawing Sheet Setup dialog settings          

Saved views are listed in and can be managed the Project Browser. See Project Browser on page 58.           

VIEW SPECIFICATION DIALOGS

Each saved view has a specification dialog that can be opened by right-clicking on it in the Project Browser or by selecting 
Tools> Active View> Edit Active View while that view is active:

 l Plan View Specification Dialog, see page 153
 l Camera Specification Dialogs, see page 1116
 l Cross Section/Elevation Specification Dialogs, see page 1123
 l Materials List Specification Dialog, see page 1319
 l CAD Detail Specification Dialog, see page 341

CLOSING VIEW WINDOWS

There are a number of ways to close view windows. See Closing Views and Files on page 159.         

 

Plan Views
Plan view is where most drawing and editing is done, and when you open a new plan file, a plan view is active. When an 
existing plan file is opened, the most recently used saved plan view will be active. If there are no saved views in a given 
plan, or if an unsaved plan view was last active, an  unsaved plan view will open instead.

NEW PLAN VIEW

To create a new plan view, select Tools> New Plan View. An identical copy of the current plan view is created and 
will become the active view. You can also right-click on the Plan Views folder in the Project Browser and select New 

Saved Plan View from the contextual menu.

Note: A new Saved Plan View can be created by selecting a plan view 
sent to layout and clicking the Create Saved Plan View edit tool. See 
Saved and Unsaved Plan Views on page 1346.

There are three ways to save a plan view:           

 l Select Tools> Active View> Save Active View  to save the current view.           

 l Select Tools> Active View> Save Active View As  to create a copy of the current view.          
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 l In the Project Browser, right-click on a view that is currently open and select Save View from the contextual menu.          

There are three ways to open a saved plan view:           

 l Select a view from the Saved Plan View Control   Plan View  drop-down in the toolbars.          

 l Right-click on a view in the Plan Views folder in the Project Browser and select Open View from the contextual 
menu. See Project Browser on page 58.           

 l If a saved plan view has been sent to layout, select its layout box and click the Open View  edit button. See Editing 

Layout Views on page 1340.           

ROTATE PLAN VIEW

To rotate everything in a plan view, including all objects on all floors, the Snap and Reference Grids, the plan’s 
Cartesian coordinates, and the drawing sheet, select Tools> Rotate Plan View to open the Rotate Plan View dialog. 

See 3D Drafting on page 12.       

Enter the degrees to rotate the plan view to using decimal units with either positive or negative values. The degrees rotated 
displays in ±180º format. For example, if you enter 270º, it displays as -90º when the dialog is reopened.          

Rotate Plan View  rotates a plan relative to its original orientation. For example, entering 90º twice results in a rotation 

of 90º, not 180º.          

Text objects rotate with the plan unless you uncheck Rotate with Plan in the Text Specification dialog for each object. See 
Rich Text Specification Dialog on page 507.          

Rotate Plan View only affects the currently active plan view. If you would like the current plan view to retain its rotation 
the next time it is opened, check Remember Zoom/Rotation in its specification dialog. See Plan View Specification Dialog 
on page 153.           

If you use Rotate Plan View  and then use either the CAD Detail from View  or Plan Footprint  tool, the CAD 

Detail window that is created will permanently inherit the same rotation as the plan view. If you later modify the plan 
view’s rotation, the CAD Detail will not be affected. See CAD Details on page 340 and Plan Footprint on page 342.           

The Rotate Plan View tool does not rotate objects; it literally 
rotates only your view of those objects. As a result, it does not 

alter the orientation of the plan in layout views or on the printed page. 

REVERSE PLAN

The Reverse Plan tool is a quick way to mirror a plan so that everything on all floors of the entire plan is swapped 
left to right.   

Select Tools> Reverse Plan to reflect an entire plan right to left, as though it were flipped about a vertical line.   

Reversing a plan rebuilds the entire model and affects views sent to layout.   
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IMPORTING SAVED PLAN VIEWS

To copy saved plan views from one plan file and import them into the current plan, select File> Import> Import 
Saved Plan Views.          

Most attributes of a saved plan view are, potentially, imported. The Active Defaults, Layer Sets including Reference Display 
Sets, and the Current CAD Layer will all be imported provided that items of the same name do not already exist in the 
destination plan. If items of the same name do exist, they will be assigned to the imported saved plan view instead.           

Two attributes are not imported: the Zoom/Rotation of the original view, and the Default Set. Even when the Active 
Defaults are imported into the destination plan, the imported saved plan view will be set to “Using Active Defaults.” Default 
Sets can be imported separately if you wish. See Exporting and Importing Default Sets on page 86.           

To import saved plan views
 1.  Open the plan that you would like to import saved plan views into.           

 2.  Select File> Import> Import Saved Plan Views .          

 3.  In the Open Plan File dialog, browse to and select the plan file that you would like to import views from and click 
OK. See Importing Files on page 45.           

 4.  In the Import Saved Plan Views dialog:          

 l Check the box beside all defaults that you would like to import.          

 l If the list of views is sufficiently long, a scrollbar will display on the right side of the list.          

 l Multiple line items can be selected by Shift+ or Ctrl+clicking their names. Then check or uncheck the box beside 
any selected item to affect the entire selection set. See Shift and Ctrl Select on page 217.          

 l Click the Select All button to place checks in the boxes beside all views in the list, or click Clear All to clear all of 
the check boxes.          

 l Select how to handle Existing Saved Plan Views in the current plan with the same name as those being imported. 
When Replace is chosen, the attributes of the saved plan view will be replaced, but not those of its Active 
Defaults, Layer Sets or Current CAD Layer.          

 l Click OK to close the dialog and import the selected saved plan views.          
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Plan View Specification Dialog
To open the Plan View Specification dialog for any saved plan view, right-click on its name in the Project Browser and 
select Edit View from the contextual menu. See Project Browser on page 58. 

You can also open this dialog for the currently active view by selecting Tools> Active View> Edit Active View.    

GENERAL PANEL

  General

 l Specify the Name of the saved plan view. This setting is not available if the view is unsaved.

 l When an unsaved plan view is active, you can check Saved to make it saved. Once a view is saved, this box is 
shown for reference only and cannot be unchecked.

 l Select the Floor level that the selected Plan View displays when it is opened. When “Use Any Floor” is selected, the 
view will return to whatever floor was active in it when the file was last saved.

 l Check Remember Zoom/Rotation to maintain the extents of the view as well as its rotation the next time the view 
is opened. Not available for unsaved views. See Zoom Tools on page 157 and Rotate Plan View on page 151.          

 l Uncheck Show Color to turn color off in the selected view. See Color On/Off on page 196.          

 l Check Show Watermark to display the watermark specified for the current plan file in the selected view. See 
Watermarks on page 1382.           

 l When Link to Layout is checked and the view is sent to layout, the layout view will be linked to the plan view. 
When this is unchecked, the layout view will use the current settings but will not be linked to the view. Not available 
for unsaved views. See Saved and Unsaved Plan Views on page 1346.           

153



Chief Architect Premier X14 Reference Manual - Working in Multiple Views

 
Pony Wall Display

These options control which part(s) of pony walls display by default in the current view. They are also found in the Pony 
Wall Defaults dialog. See Displaying Pony Walls on page 358.

 
Save Options

These settings control how or whether changes to the current view’s attributes are saved when those changes are made 
outside this dialog. Not available for unsaved views. See Saved Views on page 149.

 l When Prompt to Save is selected, the program will ask whether you want to save any unsaved changes to the view 
when you close it.          

 l When Always Save is selected, any changes that you make to the view’s attributes are saved automatically.          

 l When Never Save is selected, any changes that you make to the view’s attributes are discarded when the view is 
closed.           

SELECTED DEFAULTS PANEL

The settings on the SELECTED DEFAULTS panel control which Saved Defaults and layer settings are used in the view. These 
settings are also found in the Active Defaults dialog. See Active Defaults Dialog on page 82.          

REFERENCE DISPLAY PANEL

The settings on the REFERENCE DISPLAY panel control the appearance of the Reference Display in the view. These settings 
are also found in the Change Floor/Reference dialog. See The Reference Display on page 69.           

 

Working in Multiple Views
There is no limit to the number of plan or layout files that can be open, nor is there a limit to the number of view windows 
that can be open. The name of the file and the type of view is stated at the top of each view window in its title bar as well as 
in its tab. If the view is saved, its name displays instead of the view type. 

By default, Premier uses a tabbed document interface, which means that when more than one view window is open in the 
program window, each open window will have a tab that displays in a row above the currently active view.

 l Each tab states the name of the file, the view type, and the view’s name. Wall Detail tabs also state the floor that the 
associated wall is found on.

 l Each tab features an icon indicating its type of view. These icons are also used in the Project Browser. See Project 
Browser on page 58. 

 l Click on a tab to make it the active view.
 l If there is not enough room in the program window to display all tabs, left and right arrow buttons allow you to scroll 

through the tabs.
 l Tabs can be reordered by clicking and dragging.

There is no limit to the number of 3D view windows that you can have open at a given time; bear in mind, though, that each 
window demands use of your computer’s resources and that you may see poor performance if too many views are open. See 
3D Views on page 1080.

There are several ways to close a view window. See Closing Views and Files on page 159.
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TILING VIEWS

As an alternative to tabbed views, windows can instead be tiled. Tiling allows you to display multiple views in 
a single Premier window so you can see the results of changes in plan view in 3D or vice versa. It can also be 

useful for copying objects from one plan to another. 

There are several ways to create tiled views:

 l Click and drag a view window’s title bar or tab into the part of the drawing area that you would like it to be. When a 
highlighted space is created, release the mouse button. 

 l Select Window> Tile Horizontally  to display views in a horizontal orientation, one above the other. 

 l Select Window> Tile Vertically  or press Shift + F6 on the keyboard to display views in a vertical, side by side, 

orientation. 

Views are tiled left to right or top to bottom in the order in which they were last active: the most recent view is on the left or 
at the top, while least recent is on the right or on the bottom. 

 l To activate a view, click on its title bar or anywhere in the view window. Note that any changes you make in the 
active window are reflected in other views as well.

 l To end window tiling, select Window> Tab Windows. You can also end tiling by double-clicking on the title bar of 
the program window.

MULTIPLE PROGRAM WINDOWS

To create a second program window, click and drag the title bar or tab of a view window completely out of the current 
program window: for example, onto a second monitor.  A second Premier program window will be created with its own 
menu and toolbars. 

SWAPPING VIEWS

There are a number of ways to switch between open view windows:

 l Click on a view window’s tab.
 l Select Window> Swap Views  or press F7 to switch between the two most recent views.          

 l The Swap Views  button toggles between the current view and the view that was current before it.           
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 l Select Window> Select Next Tab  or Window> Select Previous Tab  to cycle through all open views in the 

order you prefer. 
 l In Windows, press the Ctrl + Tab (Next Window) or Ctrl + Shift + Tab (Previous Window) keys to cycle through all 

open views. 
 l On a Mac, press the Ctrl + } (Next Window) or Ctrl + Shift + { (Previous Window) keys to cycle through all open 

views. 
 l A list of all the views currently open is located at the bottom of the Window menu. Each view is identified by its name 

and what type of view it is. A check mark is beside the view that is currently active. Select one to go directly to that 
view. 

If more than eight view windows are open, More Windows will be the last item in the Window menu. Select this option to 
open the Select Window dialog:

Select the name of a view in the list and click OK to make it the active view.

Note: The Window Menu Tools parent button can be added to the 
toolbars. See Toolbar Customization Dialog on page 139. 

 

View Tools
The View Tools allow you to open and close the program’s side windows, as well as toggle a variety of references and 
drawing aides. Select the View menu to access these tools. You can also add the View Tools parent button to your toolbars. 
See Adding and Removing Buttons on page 137.

  Refresh Display redraws the current window to clean up extra lines, show missing items, and correct random 
on-screen effects caused by changes to the model. See Refresh Display on page 196.

  Library Browser opens and closes the Library Browser side window. See The Library on page 961.

  Project Browser opens and closes the Project Browser side window. See Project Browser on page 58.

  Tool Palette opens and closes the Tool Palette, which will display related tools. See Child Tool Palette on page 
134.

  Active Layer Display Options opens and closes the side window of the same name. See Drawing Groups on 
page 194.

  Status Bar displays or suppresses the Status Bar at the bottom of the program window. See The Status Bar on 
page 25.         

  Scrollbars displays and suppresses scrollbars on view windows. See View Windows on page 17. 

  Toolbars displays and hides the program’s toolbars. See Toolbars and Hotkeys on page 133.         

  Color toggles the display of color in the current view. See Color On/Off on page 196.

  Crosshairs toggles the use of the blue crosshairs centered on the mouse pointer in most views. 

  Reference Grid toggles the display of the Reference Grid in all views in the current plan or layout file. See Grid 
Snaps on page 167.

  Angle Snap Grid toggles the display of the Angle Snap Grid in all views in the current plan or layout file. See 
Angle Snap Grid on page 167.
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  Temporary Dimensions toggles the use of Temporary Dimensions when objects are selected. See Temporary 
Dimensions on page 480. 

  Arc Centers and Ends toggles the display of Arc Centers and Ends in the current view. See Arc Centers and 
Ends on page 225.

  Line Weights toggles the display of Line Weights in all views in which lines are drawn. See Line Weights on 
page 1376.

  Drawing Sheet toggles the display of the drawing sheet. See Print Preview on page 1376. 

  Watermarks toggles the display of the current plan or layout file's watermark. See Watermarks on page 1382.             

 

Zoom Tools
Zoom is used to magnify any given area on the plan or 3D view. Select Window> Zoom, then click and drag a 
marquee around an area on screen. When you release the mouse, the selected area expands to fill the screen. 

Note that in 3D views, using Zoom does not reposition the camera. This can lead to inconsistencies between a camera’s 
position and what is actually shown in the view if other methods of zooming are used later. See Navigating in Camera 
Views on page 1099.

When the zoom is complete, whatever tool was active prior to selecting the  Zoom tool automatically becomes active again. 
If another zoom is needed, click the  Zoom tool again.

These additional commands are also found in the Window menu:

  Zoom In - Click to zoom in towards the screen center by a factor of two.

  Zoom Out - Click to zoom out from the screen center by a factor of two.

  Undo Zoom - Reverse the last zoom or fill window operation. This option is also found in the contextual menu, 
as is the Zoom tool. See Menus, Toolbars, and Hotkeys on page 18.

  Fill Window Selected Objects - Fits all selected items on screen.

  Fill Window Building Only - Fits all walls and railings on the current floor on screen. 

  Fill Window - Fits all visible items on screen. See Fill Window on page 158.

Note: Undo and Redo do not affect zoom.

ZOOMING WITH THE MOUSE WHEEL

Use the mouse wheel to zoom in and out in all view windows. Scrolling the mouse wheel one click up or down 
zooms in or out, centering on the location of your pointer and changing the zoom by about 10%.

By default, zooming in 3D views changes the camera’s position. See Mouse Scroll Wheel and Trackpad on page 1100.

Note: Depending on the configuration of your mouse, it may be 
necessary to hold down the Ctrl key while turning the mouse wheel. 
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Fill Window
In plan view, a CAD Detail or a cross section/elevation view, select Window> Fill Window or press the F6 key to 
view nearly everything on screen that is visible, including the Reference Display. CAD Points are the only objects 

that are not included when Fill Window is used. 

If you are zoomed in so that only a portion of the drawing displays on screen, selecting Fill Window zooms out so that the 
entire view fits on the screen. If you are zoomed out so that the entire drawing is smaller than the screen, selecting  Fill 
Window zooms in until the drawing fills the screen.

When the drawing sheet is shown, Fill Window zooms to the sheet borders.

FILL WINDOW SELECTED OBJECTS

Window> Fill Window Selected Objects is similar to Fill Window, but zooms in or out so that the current selected 
object or objects fill the current window. See Selecting Multiple Objects on page 215.

FILL WINDOW BUILDING ONLY

Window> Fill Window Building Only is similar to Fill Window, but zooms in or out to so that all walls, railings, 
and roof planes in the view fill the current window. These objects are included in the extents of the view even if their 

layers are turned off. Other objects are ignored.

IN 3D VIEWS

The Fill Window tools behave slightly differently in perspective and orthographic 3D views. In perspective views, the 
original zoom factor is restored, while in orthographic views the camera’s Field of View is adjusted so that all surfaces in 
the 3D view are included. 

 

Panning the Display
There are a number of ways to pan the display without changing the zoom factor.

USING THE ARROW KEYS

In plan view, the Shift + arrow keys on the keyboard work exactly like clicking the arrow buttons on the scrollbar. They 
shift the display according to the number of inches defined in the Plan Defaults dialog.

USING THE MOUSE

If you have a wheel mouse, you can pan the display by pressing the middle mouse button, or wheel, and moving the mouse 
in the direction you would like to pan. When the middle mouse button is held down, the pointer changes to a hand   icon. 

In the Mac version of Chief Architect, you can pan using the left mouse button and Option key. 

Mouse drivers sometimes have other functions assigned to the wheel and buttons. These override the Chief Architect setting.

The Scale Layout Box Contents to Fit  edit tool also allows you to pan within a layout box. See Editing Layout Views 

on page 1350.
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USING A MAC TRACKPAD

In the Mac version of Chief Architect, you can two finger drag to pan the display. See Trackpads on page 15. 

USING THE PAN WINDOW TOOL

The Pan Window tool works much like the mouse wheel method.

 l Select Window> Pan Window. The pointer changes to a hand   icon. Click and drag to pan the window. The 
program reverts to the previously active tool when you release the mouse button.

 l Double-click the Pan Window tool and the command remains active.     

USING THE SCROLLBARS

One method is to use the scrollbars on the right and bottom edges of the window. See View Windows on page 17.

 l Click the end arrow keys on the scrollbars to shift the display in 12" increments. 
 l The 12" increment is defined in the Plan Defaults dialog under Inches Scrolled by Arrow Key. See General Plan 

Defaults Dialog on page 96.         

 

Closing Views and Files
If a view is still needed, you can swap to a different view without closing it. If, however, a view is no longer needed, it can 
be closed. There are several ways to close a view window:

 l Select File> Close View to close the active window. 
 l Press Ctrl + W or Ctrl + F4 on the keyboard to close the active window.
 l Click the Close button in the active view’s title bar or in any view’s tab.
 l A tabbed view can be closed by clicking on its tab using the middle mouse button.
 l Right-click on a Camera, Cross Section, or Plan View in the Project Browser and select Close View from the 

contextual menu.          
 l Select File> Close All 3D Views  to close all currently open camera view windows instead of just the active 

window. 
 l Select File> Close All Views to close all currently open view windows instead of just the active window. 

If a plan has only one view window open and you try to close it, the program will prompt you to save before closing if there 
are any unsaved changes. Edited cross section/elevation and saved plan views also prompt you to save before closing. See 
Saving Plan and Layout Files on page 40 and Saved Views on page 149.
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Although the program warns you if you try to exit without 
saving, you should get in the habit of saving plan files before 

exiting. 

Even if all view windows are closed, the program can still be open. See Exiting Chief Architect on page 56. 

 

160



Chief Architect Premier X14 Reference Manual - Creating Objects

Chapter 7
 

Creating Objects

There are a wide variety of objects in Chief Architect that you can use to create complete 3D models and working drawings. 
Although these objects are sometimes very different from one another, the methods used to create them are similar. 

Once an object is created, it can be selected and edited to meet the requirements of your project. The editing characteristics 
common to most objects are described elsewhere. See Editing Objects on page 207.
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Architectural vs CAD Objects
There are two broad categories of objects in Chief Architect: architectural objects and CAD objects.          

CAD objects such as  lines, arcs, text, and dimensions are 2D objects that can be created and edited in plan view, cross 
section/elevation views, CAD detail windows, and on layout pages but do not display in 3D camera views and overviews. 
See The CAD Drawing Tools on page 300.

In contrast, architectural objects such as walls, cabinets, doors, windows, and stairs display in 2D and 3D views.              
Architectural objects can be created and edited in 2D and 3D views but not in CAD Detail windows or on layout pages.

Some architectural objects, such as custom countertops and slabs, have some behaviors in common with CAD objects and 
are referred to as CAD-based.         

 

Defaults and Preferences
The ways that objects in the program behave as they are created and edited are affected by a number of default and 
preference settings. See Preferences and Default Settings on page 75.          

It is a good idea to be familiar with these options and how they 
affect both drawing and editing in the program.             

SNAP SETTINGS

Select Edit> Snap Settings to access the three categories of Snap Settings that determine how objects snap to one 
another and whether they snap to allowed angles or to points on a grid, as well as object bumping and pushing 

behaviors.         

The available Snap Settings are:

  Object Snaps - enables snapping to objects. See Object Snaps on page 164.         

  Angle Snaps - enables snapping at Allowed Angles. See Angle Snaps on page 166.         

  Grid Snaps - enables snapping to the Snap Grid.  See Grid Snaps on page 167.          

  Bumping/Pushing - enables bumping and pushing behaviors. See Bumping/Pushing on page 246.         

EDIT BEHAVIORS

Select Edit> Edit Behaviors to access the six global edit behavior modes that determine how dragging the edit 
handles with the left mouse button affects a selected object and may also affect how objects are drawn.          

The available Edit Behaviors are:

  Default - provides the most commonly used editing options. See Default on page 208.         

  Alternate - provides an alternative to the Default behaviors that may be more useful in some situations. See 
Alternate on page 209.         
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  Move - allows you to move a selected object using the corner handles and the Move handle. See Move on page 
209.         

  Resize - scales an object as you drag a corner handle. See Resize on page 210.         

  Concentric - allows you to resize objects so that the distance moved by each edge is the same as all other edges. 
See Concentric on page 210.         

  Fillet - allows you to add a fillet at any corner of an object. See Fillet on page 211.         

CONNECT CAD SEGMENTS

Select Edit> Edit Behaviors> Connect CAD Segments to toggle the ability to edit the individual segments of 
polyline-based objects and connected walls. See Disconnect Edges on page 214.

Unlike Object Snaps, Connect CAD Segments also affects the ability to snap line- and arc-based objects together as they are 
drawn to form a polyline. See Object Snaps on page 164.

ROTATE/RESIZE ABOUT

Objects can be rotated or resized about either their own centers or the Current CAD point. See Rotate/Resize About 
on page 262.          

Specify which behavior is used by selecting Edit> Edit Behaviors> Rotate/Resize About Current Point  or in the 

Preferences dialog. See Behaviors Panel on page 120.           

ARC CREATION MODES

Select Edit> Arc Creation Modes to access the five Arc Creation Modes that control how arcs and curved walls are 
drawn.         

The available Arc Creation Modes are:

  Free Form Arc - mode allows you to define an arc by clicking and dragging along the desired path. See Free 
Form Arc on page 314.         

  Center/Radius/End Arc - mode allows you to define the center and radius of an arc, and then its length. See 
Center/Radius/End Arc on page 314.         

  Start/End/On Arc - mode allows you to define the start and end points of an arc, then adjust the curvature. See 
Start/End/On Arc on page 315.         

  Start/Tangent/End Arc - mode allows you to define the start and end points of an arc, its tangent and its 
curvature. See Start/Tangent/End Arc on page 315.         

  Arc About Center - mode allows you to draw an arc by defining the center and then the start and end points. 
See Arc About Center on page 315.         

 

Snap Behaviors
There are three categories of snap behavior in Chief Architect that affect how objects are created and how they can be 
edited: 

  Object Snaps, which snap CAD and architectural objects to other objects. See Object Snaps on page 164.
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  Angle Snaps, which snap objects at specific angles. See Angle Snaps on page 166.

  Grid Snaps, which snap objects to points on a grid. See Grid Snaps on page 167.

Snap behaviors can be controlled in the Preferences dialog and in the Plan or Layout Defaults dialogs.
See Snap Properties Panel on page 122 and General Plan Defaults Dialog on page 96.          

You can select Edit> Snap Settings  to quickly turn Object, Angle and Grid Snaps on or off. 

To temporarily disable Snap Behaviors and other move restrictions, press the Ctrl key while dragging an edit handle.
See Moving Objects on page 245.   

HOTKEYS

You can also temporarily enable individual Snap Behaviors during a mouse editing operation using hotkeys. This can be 
helpful if you wish to use one particular type of snap behavior when you begin an operation, but a different behavior when 
you end it.           

The Snap Behavior hotkeys are listed on the right side of the Edit> Snap Settings  submenu.

See Hotkeys on page 142.          

To use snap behavior hotkeys
 1.  Select Edit> Snap Settings  and toggle off the snap behavior category that you wish to control using hotkeys.          

 2.  Select a tool that you wish to draw with or an object you wish to edit.          

 3.  Begin drawing or editing and hold down the left mouse button without releasing.          

 4.  Press and hold the appropriate key on your keyboard to enable the snap behavior associated with it.           

 5.  When you are finished using the snap behavior, release the hotkey but continue holding down your left mouse 
button.          

 6.  If you wish, you can press and hold a different hotkey on your keyboard and continue the drawing or editing 
operation.          

 7.  When you are finished, release the left mouse button.          

 

Object Snaps
Object Snaps allow you to position objects precisely relative to each other; for example, to position lines so that 
their endpoints meet or roof plane edges so that they are collinear.

Object Snaps can be turned on or off by selecting Edit> Snap Settings> Object Snaps , by clicking the toggle button, 

or in the Preferences dialog. See Snap Properties Panel on page 122.

Object Snaps are indicated visually as you create or edit objects. To remove any object snap indicators that are visible on 
screen, press the 1 (one) key. As you continue drawing or editing, new indicators may appear.          

With the exception of On Object  snaps, Object Snaps have priority over all other types of snapping in Chief Architect. 

Bumping/Pushing  overrides Object Snaps, however. See Bumping/Pushing on page 246.          
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OBJECT SNAP LOCATIONS

There are many locations on an object that other objects can snap to. In addition to snap points located on objects, Extension 
Snaps locate points away from objects. Each type of object snap can be toggled by selecting Edit> Snap Settings  or in 

the Preferences dialog. See Snap Properties Panel on page 122.

Regardless of which Object Snaps are active, when multiple objects are selected the selection set’s only snap point is its 
midpoint.

EXTENSION SNAPS

For some operations, it is helpful to snap to a point far away from an original object, while maintaining a relationship to a 
point on that object. For example, you may want to snap to a point exactly perpendicular to a line’s endpoint. Extension 
Snaps are helpful in these situations.          

Extension anchors and lines

Extension Snaps are indicated by extension anchors, indicated by small blue circles.           

Anchors display for Endpoint, Midpoint, and Quadrant snaps when these snap behaviors are enabled.          

When an anchor is established, you can create Tangent , Perpendicular  and Orthogonal  extension lines 

relative to it.           

To use extension snaps
 1.  Toggle on Object Snaps  and make sure the extension snaps are enabled.          

 2.  Draw a Rectangular Polyline .          

 3.  Select the Draw Line  tool and move your pointer along the edges of the polyline.          

 4.  When your pointer passes over an endpoint or midpoint, an extension anchor is created.          

 5.  Move your pointer perpendicular edge displaying the anchor to create a blue, dashed extension line.          

Only a limited number of anchors can exist at one time; creating a new anchor removes the oldest existing anchor. You can 
specify the number of possible anchors in the Preferences dialog. See Snap Properties Panel on page 122.          

WALL INTERSECTION EXTENSION SNAPS

As walls are drawn, extension lines identify points that are either collinear or orthogonal to the end points of other walls. 
These extension lines identify potential intersection points and display only when Intersection Snaps  are enabled. See 

Creating Walls on page 361.           

OBJECT SNAPS HOTKEYS

 l Press the “1” key to clear out all current extension anchors.           
 l Hold down the “S” key to temporarily disable Object Snaps.               You are still able to use Extension Snaps to existing 

anchors, so the “S” key can be used to avoid picking up unwanted extension anchors.
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THE “S” KEY - CASE STUDY

In the following example, there are several lines. Suppose we want to start a line at the intersection of two orthogonal 
extension lines drawn from two lines, A and B. To establish an extension anchor, we need to drag the mouse over line A’s 
endpoint, but there are several lines between the endpoints of lines A and B. We need to establish the two extension anchors 
without snapping to the intervening objects.     

To establish two extension anchors
 1.  Drag the mouse over the endpoint for line A to establish the first endpoint anchor.          

 2.  Temporarily disable object snapping by holding down the “S” key.          

 3.  Move the mouse to the end of line B.          

 4.  Release the “S” key to establish the second endpoint anchor.          

 5.  Move the mouse to the intersection of the two extension lines and draw the new object.          

The S key can help establish Extension snaps 
when other objects may interfere

 

Angle Snaps
It is often important that objects be drawn at exact angles. This can be accomplished using Angle Snaps. Angle 
Snaps allow you to draw walls, lines, and other objects at specified Allowed Angles. Angle Snaps also affect the way 

objects rotate, the radius of arcs, and a variety of other operations.

You can specify whether Angle Snaps use 15° increments or 7.5° increments plus any additional Allowed Angles that you 
may specify. See General Plan Defaults Dialog on page 96.           

Angle Snaps can be turned on or off by selecting Edit> Snap Settings> Angle Snaps , by clicking the toggle button, or 

in the Preferences dialog. See Snap Properties Panel on page 122. 

Because drawing at regular angles is extremely important, when Angle Snaps are disabled, the Angle Snaps   icon will 
display near and follow the pointer. See Pointer Icons on page 16.

ANGLE SNAP SETTINGS

You can change Allowed Angle settings for Angle Snaps in the Plan Defaults or Layout Defaults dialog. See General Plan 
Defaults Dialog on page 96.         

Specify 15 Degree or 7 ½ Degree angle snaps. You can also specify Additional Angles.           
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ANGLE SNAPS AND OBJECT SNAPS

Angle Snaps have a higher priority than Grid Snaps and On Object Snaps , but a lower priority to all other Object 

Snaps. If a valid Object Snap exists, the program uses that instead of an Angle Snap.           

Walls are an exception to this snapping prioritization. When 
walls are drawn or edited, Angle Snaps take higher priority than 

Object Snaps. See Creating Walls on page 361. 

Sometimes both Angle Snaps and Object Snaps apply. For example, suppose a CAD line is drawn at 15°  using Angle Snaps 
and another line is approached. You can draw the new line at 15° using Intersection Snaps  to snap to a point on the 

existing line.           

Use Object Snapping and Angle Snapping to 
draw a line at a 15° angle that intersects and 

existing line

Now suppose that we don't want the new line to end on the existing line. Hold down the “S” key to temporarily disable 
Object Snaps, allowing only Angle Snaps.  See The “S” Key - Case Study on page 166.

ANGLE SNAP GRID

The Angle Snap Grid is a visual reference aide that displays the Allowed Angles in the current plan when line-based 
objects are being drawn. Select View> Angle Snap Grid to toggle this feature on or off. The Angle Snap Grid can be 

also turned on and off in the Preferences dialog and is disabled by default. See Snap Properties Panel on page 122.         

When Grid Snaps are enabled, small perpendicular hatch lines display along the lengths of the Angle Snap Grid lines, 
indicating the Snap Grid Unit. See Grid Snaps on page 167.         

CAD Line drawn with Angle Snap Grid on, 
Grid Snaps on vs off

 

Grid Snaps
Grid Snaps allow you to snap objects to points on an on-screen grid as they are created, moved, and resized. See 
Moving Objects on page 245 and Resizing Objects on page 256.

It is recommended that you draw and position the exterior walls of your plan with Grid Snaps enabled. Once these walls 
are in place, you may choose to turn Grid Snaps off to finish the rest of the drawing.          
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Grid Snaps are turned on and off by selecting Edit> Snap Settings> Grid Snaps, by clicking the toggle button, or in the 
Plan or Layout Defaults dialog. 

REFERENCE GRID

In addition to the Snap Grid, the Reference Grid is provided to give you a visual sense of scale. It is useful for 
zooming in and out, or for general layout guidelines, but is not used for snapping. The Reference Grid can be toggled 

on and off by selecting View> Reference Grid. See View Tools on page 156.         

The appearance and size of the Snap and Reference Grids can be controlled in the Plan Defaults and Layout Defaults 
dialogs. See General Plan Defaults Dialog on page 96. 

GRID SNAPS AND ANGLE SNAPS

Of the three snap behaviors, Grid Snaps have the lowest priority and are overridden by Angle Snaps and Object Snaps. 

When Grid snaps and Angle Snaps are both enabled, objects are drawn and edited using Polar Coordinates. For example, if 
the grid Snap Unit is set to 12" (1 foot), drawing a new wall at an Allowed Angle snaps the wall length to 0", 12", 24", and 
so on. The Angle Snap Grid illustrates this nicely: when Grid Snaps are enabled, small perpendicular hatch lines display 
along the lengths of the Angle Snap Grid lines. These hatches are at regular intervals equal to the Snap Grid Unit, but do not 
necessarily align with the Snap Grid itself. See Angle Snap Grid on page 167. 

To draw a line or wall at an Allowed Angle but with unrestricted 
length, disable Grid Snaps and leave Angle Snaps on.

 

Creating Objects
In Chief Architect Premier, there are five ways to add new objects to your drawing: by clicking to place an object, by 
clicking and dragging to draw an object, by entering coordinates, by placing a distribution path or region, or by importing 
custom symbols, CAD drawings, pictures or metafiles.

If you create an object using any of these methods and the layer it will go on is either locked or turned off, the program will 
ask you if you want to unlock or display the layer. Objects can be created on layers that are not set to display, but they 
cannot be created on locked layers. See Object Creation and Layers on page 171.

While the size of the drawing area in Chief Architect is limited only by the resources on your computer, it is best to begin 
your drawing near the origin, 0,0. The current position of your mouse pointer displays in the Status Bar at the bottom of the 
program window. See 3D Drafting on page 12.          

CLICK-TO-CREATE

Many objects, including doors and windows, cabinets, library symbols, text, pictures, and images are created by clicking. 
Select a library object or one of the drawing tools mentioned above, then click in the drawing area to place the object at that 
location. 

Continue clicking to place the selected object until another tool is selected.         

If you click at a location where there is not enough room for the object to be placed, one of two things may happen:         

 l Some objects, notably cabinets, doors, and windows, will resize smaller to fit into the space.          
 l Most objects cannot resize in this manner, so the program will present a warning message indicating that there is not 

sufficient space at the current location.         
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When most drawing tools are active or library symbols selected for placement, a preview outline follows your mouse 
pointer, indicating the size and shape of the object to be created. If your pointer is positioned at a location where the object 
cannot be placed, this preview outline will not display.         

As you move the mouse pointer, the center point of the object’s back edge will snap to active snap points when Grid Snaps 
 or Object Snaps  are enabled. See Snap Behaviors on page 163.

Many architectural objects can be created in plan view or any 3D view. In order to place a stand-alone, click-to-create object 
in 3D, it is necessary to click near a wall or within the Terrain Perimeter as these objects help orient the new object within 
the 3D space.          

CLICKING AND DRAGGING

Other objects, including walls and railings, straight stairs, and CAD and CAD-based objects are created by clicking and 
dragging to define either a path or an enclosed area. Select a tool, then click and drag in the drawing area to draw an object 
between your start and end points.

Continue drawing the selected object until another tool is selected.

You can temporarily slow the movement of the mouse as you drag by holding down the Shift key on your keyboard.

You can cancel any click-and-drag drawing operation before it is completed by pressing the Esc key on your keyboard, or 
by pressing any two mouse buttons at the same time. 

When the Alternate  edit behavior is active, a continuous drawing behavior is enabled, allowing you to click at the start 

and end points of line- and arc-based objects without dragging. See Alternate on page 209.           

To continuously draw by right-clicking
 1.  Select a tool that creates line- or arc-based objects.          

 2.  Right-click, drag, and release the mouse button to draw the first object.          

 3.  Move the pointer to a different location and notice the drawing indicator that begins at the object’s endpoint and 
follows your pointer as it moves.          

 4.  Click to create a second object beginning at the first object’s starting point and ending where you clicked.          

 5.  Continue moving the pointer and clicking to create additional objects until:           

 l Another tool is selected,           

 l The Esc key is pressed,          

 l Two mouse buttons are pressed at the same time,           

 l The left mouse button is double-clicked,          

 l A closed shape is formed.          

To keep the Alternate Drawing Mode enabled when a closed 
shape is formed, uncheck Stop When Connected in the 

Preferences dialog. See Behaviors Panel on page 120. 

Polyline- and Spline-based objects can be created by snapping multiple Line-, Arc-, and/or Spline-based objects together. 
These objects will only snap together to form a polyline or spline if they are on the same layer and share identical attributes 
such as color, line style, and arrow specifications. See Editing Objects on page 207.           
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ENTERING COORDINATES

Objects created by clicking and dragging can also be drawn by entering coordinates.  See 3D Drafting on page 12.           

Coordinates can be either absolute or relative. Absolute coordinates refer to a fixed point of origin at 0,0, while relative 
coordinates treat the current location of the selected object as the point of origin.           

To use the Enter Coordinates dialog
 1.  Select any tool that requires you to click and drag to create an object.          

 2.  Click and begin dragging to draw the object.          

 3.  Before you finish dragging and with the mouse button pressed, press either the Tab or Enter key on your keyboard.          

 4.  In the Enter Coordinates dialog:              

 l The Start Location, where you clicked and began dragging, displays at the top.          

 5.  Specify the method used to define the New Location, or end point.          

 l Select Absolute to define the end point using absolute coordinates on the snap grid.          

 l Select Relative to Start to define the end point relative to the start point, as though the start point was at (0,0).          

 l Check Polar to define the end point of the new line by its Distance and Angle from the start point rather than 
as X and Y coordinates.           

 l The program remembers which option you last used in this dialog.           

 6.  Specify the position of the end point, either as X and Y Position coordinates, or as Distance and Angle.          

 7.  Click OK to close the dialog and create the object.          

CAD lines, arcs and points can also be created using the Input Line, Input Arc and Input Point dialogs. See Input Point on 
page 301, Input Line on page 306, or Input Arc on page 315.

You can also move objects using the Enter Coordinates dialog. 
Click and drag the Move edit handle of an existing object, then 

press the Tab key and proceed with steps 4 and 5. See Moving Objects on 
page 245.

AUTO REBUILD

A number of objects, notably foundations, roofs, and framing, can be automatically generated and rebuilt as changes are 
made to the model. Objects created in this manner can be edited just like other objects; however, the Auto Rebuild 

170



Chief Architect Premier X14 Reference Manual - Copying and Pasting Objects

functionality will be disabled.           

DISTRIBUTING OBJECTS

You can place multiple copies of any object in an evenly-spaced array either within a region or along a path using the 
Distributed Objects  tools. See Distributed Objects on page 1043.          

IMPORTING OBJECTS

Custom symbols, CAD drawings, pictures and metafiles can be imported into the program and placed in the drawing area 
with a click. See Importing and Exporting on page 1222 and Pictures, Images, and Walkthroughs on page 1180.   

CONVERTING OBJECTS

A variety of objects can be created by converting existing CAD objects and many CAD-based objects into another type of 
object. See Converting Objects on page 265.           

OBJECT CREATION AND LAYERS

When it is created, every object is placed on a layer which controls whether and how it displays. See Layers on page 180. 

If you try to create an object on a layer that is not set to display in the current view, the program will ask if you want to turn 
that layer on. See Message Boxes on page 25. 

 l Click Yes to create the object and turn on its layer in the current view.
 l Click No to create the object but leave its layer turned off in the current view. 
 l Click Cancel to not create the object and leave the layer turned off.

If you try to create an object on a layer that is locked, the program will prompt you to unlock the layer. If you choose to 
leave the layer locked, the object will not be created.  See Locking Layers on page 182.          

Similarly, if you try to insert an object into another object that is on a locked layer, nothing will be created. See Inserted 
Objects on page 981.          

If you place an object on a renamed or custom layer and then paste it into a new plan or layout file, a new layer will be 
created in the destination file.               See Copying and Pasting Objects on page 171.

 

Copying and Pasting Objects
New objects can also be created by cutting, copying, and pasting existing objects, either individually or in groups. Objects 
can be copied from one floor to another, one view window to another, and one file to another. Because copying uses your 
system’s clipboard, some objects can be pasted into other applications, as well.

Objects created in a plan or layout using U.S. Units should not 
be pasted into a metric file, or vice versa. See Units of 

Measurement on page 38.

Objects cannot be pasted into any views that they cannot be created in normally. For example, CAD objects cannot be 
pasted into a 3D camera view or overview, while Architectural objects cannot be pasted onto a layout page or into a CAD 
Detail window.

If an object on a custom layer or one that inherits properties from a Saved Dimension Default or Saved Text Style is pasted 
into a different plan or layout file:         
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 l That Saved Default, Text Style, or layer will be created in the destination file if it does not already exist.         
 l If a Saved Default, Text Style, or layer with the same name does exist in the destination file, the object will inherit its 

attributes from the existing settings.         

See Multiple Saved Defaults on page 79 and Layers on page 180.         

Note: Terrain Perimeters can be copied and pasted, but will be pasted as 
a Standard Polyline which can then be converted into a Terrain Perimeter 
or other type of polyline. See Convert Polyline on page 265.

There are a number of ways that objects can be cut, copied, and pasted:   

CUT, COPY, AND PASTE

The Cut, Copy, and Paste tools allow you to copy a selection to the system clipboard and then paste it into a different view 
window, onto a different floor level, or even into a different application.

Select Edit> Cut or press Ctrl + X to remove the selected object(s) from the file and save them in the system 
clipboard so that the selection can be pasted in a different location in Chief Architect or in another application, 

depending on the type of selection.   

Select Edit> Copy or press Ctrl + C to save a copy of the selected object(s) to the system clipboard while 
maintaining the original(s). The selection can then be pasted in a different location in Chief Architect or in another 

application, depending on the type of selection.

Select Edit> Paste or press Ctrl + V to enable Paste mode, then left- or right-click in the current view to paste the 
selected object(s) previously copied to the system clipboard at that location. If pasting from another application, click 

in the destination view in Chief Architect first to make sure it is active. 

To Cut, Copy, and Paste
 1.  Select an object or objects to copy, then:

 l Select Edit> Cut or press Ctrl + X to remove the original selection from the file and copy it to the system 
clipboard.

 l Select Edit> Copy or press Ctrl + C to copy the selection to the clipboard while retaining the original.

 2.  If you wish to paste the copy in a different view or program window, open that window and click in it to make it 
active.

 3.  Select Edit> Paste from the menu or press Ctrl + V. 

 4.  When pasting in Chief Architect, the mouse pointer will display the Copy/Paste   icon. Left- or right-click once 
to paste a copy of the object at that location.

If the new object(s) are pasted into Chief Architect, they will be selected. Objects pasted in 3D views are selected on their 
top surfaces.

If the selection being pasted consists of text, it is placed in a Text object.

If the selection being pasted is an image, the Paste Image dialog opens.
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The options in the Paste Image dialog and their results are similar to those in the Screen Capture Setup dialog. See Creating 
Screen Captures on page 1200.         

COPY/PASTE

The Copy/Paste edit tool allows you to copy the selected object(s) to the system clipboard and immediately enable 
the Paste function so that a copy can be made in the current view. Edit handles and a variety of edit tools let you 

control the location, orientation, and size/shape of the pasted object(s).    

To Copy/Paste by clicking
 1.  Select an object or objects to copy.

 2.  Click the Copy/Paste  edit button. The cursor displays the Copy/Paste   icon.

 3.  Left- or right-click once to paste a copy of the selection at that point where you clicked.

The Copy/Paste edit tool can be used in combination with the original selection's edit handles to move, rotate, or reshape the 
copy relative to the original. The available edit handles will vary depending on the type and number of objects selected. See 
Edit Handles on page 23.

To Copy/Paste by dragging
 1.  Select an object or objects to copy.

 2.  Click the Copy/Paste  edit button. The cursor displays the Copy/Paste   icon.

 3.  Click and drag an edit handle:

 l Drag the Move edit handle to position the copy at a new location. As you drag, a preview of the selection follows 
the mouse pointer.

 l CAD lines and some line-based objects have a round Orthogonal Move edit handle. When dragged, movement is 
restricted to directions that are perpendicular to the selected line.

 l Other types of CAD and CAD-based objects have a round Concentric Resize edit handle. Click and drag this 
handle to create a concentric copy that is either larger or smaller than the original.

 l Drag a corner handle to create a copy in the same location as the original but with a different shape or size. The 
result depends on which Edit Behavior  you use. See Defaults, Preferences, and Edit Behaviors on page 208. 

 l Drag the Rotate handle to create a copy in the same location as the original, but rotated to a different angle.

 4.  You can resize or position the copy accurately with respect to the original by watching the moved distance in the 
Status Bar at the bottom of the screen.

The Copy/Paste  edit button activates Paste mode in which each available edit tool and handle makes a copy in addition 

to its primary function and seven new edit buttons display on the Edit Toolbar.
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  Click the Sticky Mode edit button to remain in the current mode and place multiple copies of the selected object
(s). See Sticky Mode on page 174, below.

  Click the Paste Hold Position edit button create a copy of the selection at the same location as the original. See 
Paste Hold Position on page 175, below. 

  Click the Point to Point Move edit button to make a copy of the selection at a specific location. See Point to 
Point Move on page 247.         

  Click the Point to Point Center edit button to make a copy of the selection centered between two points. See 
Point to Point Center on page 254.    

  Click the Center Object edit button to make a copy of the selection and center it relative to another object. See 
Center Object on page 253.

  Click the Reflect About Object edit button to make a copy of the selection reflected about another object. See 
Reflect About Object on page 264.         

  Click the Main Edit Mode edit button or press the Esc key to return to the selection's main edit toolbar.

To use Copy/Paste with other edit tools
 1.  Select the object(s) to be copied and click the Copy/Paste  edit button.

 2.  Notice that the options in the Edit Toolbar change and include several tools for moving and centering:

 l Click the Point to Point Move  edit button, then click at the start and end points to position the copy at a 

particular point. After your click on the start point, an extension line, selection preview outline, and Point B   
icon follow the mouse pointer.

 l Click the Point to Point Center  edit button, then click on the two points that you would like to center the 

copy between.    

 l Click the Center Object  edit button, then mouse over the object you want to center the copy relative to and 

click once when the desired centering axis and selection preview outline displays. 

 l Click the Reflect About Object  edit button, then mouse over the object you want to reflect the copy about and 

click once when the desired reflection axis and selection preview outline displays.    

 3.  An exact copy of the selected object(s) is created and is positioned and oriented based on the actions performed 
using the second edit tool.      

STICKY MODE

Normally, after an action is performed using the edit tools or handles while in an edit mode such as Paste mode, you  
return to the Main Edit Mode. Click the Sticky Mode edit button to remain in Paste mode and continue pasting 

copies of the selected object(s). 

To exit Paste mode and return to the main edit toolbar for the selected object, click the Main Edit Mode  edit button or 

press the Esc key on your keyboard. If you have not pasted a copy of the selected object and immediately click Copy/Paste 
 after returning to the Main Edit Mode, Sticky Mode  is still enabled. 

Sticky Mode is available when the Trim Object(s), Extend 
Object(s), Copy/Paste or Multiple Copy edit button is clicked. 

See Trim and Extend on page 276. 
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PASTE HOLD POSITION

Click the Paste Hold Position edit button to create a copy of the selected object(s) at the same location as the 
original. The copy remains selected so you can perform additional operations.

Because multiple walls, railing and fencing cannot share the same space, the Paste Hold Position  edit button is not 

available for these objects.

When copying between different floors or view windows, you can paste a copy at the same absolute position as the original 
selection using the Paste Hold Position command.

To use Paste Hold Position
 1.  Select the object(s) to be copied.

 2.  Click the Copy/Paste  edit button.

 3.  Switch to the desired floor or plan file and select Edit> Paste> Paste Hold Position .

 4.  A copy is placed at the same X, Y coordinates on the new floor or in the new plan as the original’s position.

When a CAD-based object is moved to a new floor, only its 
display in plan view is moved - its physical location in the 

model remains unchanged. See Architectural vs CAD Objects on page 
162.

COPY AND PASTE IN PLACE

Select Edit> Copy and Paste in Place to create a copy of the selected object(s) at the same location as the original. 
The copy remains selected so you can perform additional operations.

Because multiple walls, railings, and fencing cannot share the same space, the Copy and Paste in Place command is not 
available for these objects.

PASTE SPECIAL

The Paste Special tool allows you to choose a representation for the selection to be pasted. 

Selections can be pasted as:

 l Enhanced Windows Metafiles (EMF). See Metafiles on page 1191. 
 l Device Independent Bitmaps (BMP). See Importing Pictures on page 1189.
 l Unformatted non-unicode text (TXT).
 l File Name (a path to a file). Depending on the file type, it will be either opened or imported (if supported). 
 l Unformatted text (HTML). Pastes as text.
 l Model Objects - Chief Architect format, not compatible with other programs.

To use Paste Special
 1.  Select an object, image, text or file on your computer and copy it.

 2.  Switch to the desired Chief Architect view window and select Edit> Paste> Paste Special .
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 3.  In the Paste Special dialog, select the desired representation for the selection and click OK.

 4.  Click in the drawing area to place the copy at that location. 

MULTIPLE COPY

The Multiple Copy edit button makes it easy to create regularly spaced or concentric copies of any object or group 
of objects, including CAD Blocks and Architectural Blocks.

The copy intervals, or offsets, between copies can be specified in the Multiple Copy dialog. See Multiple Copy Dialog on 
page 177.          

To use Multiple Copy
 1.  Select the object(s) to copy.          

 2.  Click the Multiple Copy  edit button.          

 3.  Click the Sticky Mode  edit button if you wish to make more than one set of multiple copies.          

 4.  Regardless of the object type selected, these two edit handles will display on the selected object:           

 l Click and drag the square Move edit handle. Copies of the selection are made at regular intervals between the 
original and the pointer’s location.          

 l Click and drag the triangular Rotate edit handle. Rotated copies of the selection are made at regular intervals.          

The Rotate handle can create an array about the selection's 
center or about a CAD point. See Rotate/Resize About on 

page 163.

 5.  Some CAD-based objects have a third edit handle:

 l CAD lines and some line-based objects have a round Orthogonal Move edit handle. Click and drag this handle to 
create an array of copies that is perpendicular to the original selection.

 l Other types of CAD and CAD-based objects have a round Concentric Resize edit handle. Click and drag this 
handle to create concentric copies of the selection at regular intervals either within or surrounding the selection.

 6.  Release the mouse button to place the copies. The dragged distance determines the number of copies placed.          

 7.  If you clicked the Sticky Mode  edit button, you can drag the last object created to make additional copies.          

 8.  Click the Main Edit Mode  edit button or press the Esc key to return to the selected object’s main edit toolbar.          

The Multiple Copy  tool can be used with the Alternate  edit behavior to create arrayed copies of objects. See 

Alternate on page 209.          

To create an array of copies
 1.  Select the object(s) to copy.          

 2.  Click the Multiple Copy  edit button.          

 3.  Right-click to enable the Alternate  edit behavior and drag the either Move or the Rotate edit handle in any 

direction. The Primary Offset or Primary Number of Copies is used.          
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 4.  Release the mouse button and move the pointer in another direction. The Secondary Offset or Secondary Copies 
value is used.           

 5.  Click the left or right mouse button to place the array of copies.          

MULTIPLE COPY DIALOG

The Multiple Copy dialog lets you specify separate multiple copy intervals for:          

 l General objects          
 l Roof and floor trusses          
 l Rafters          
 l Floor and ceiling joists, posts, and beams          
 l Wall studs          

To open this dialog, click the Multiple Copy  button and then click the Multiple Copy Interval  button.           

Note: The settings in the Multiple Copy dialog are global rather than file-
specific and are retained between program sessions.           

 
Offset Between Copies When Dragging

Click the Offset Between Copies When Dragging radio button to specify the offsets, or copy intervals, at which objects are 
copied as you drag with the mouse.         

 l Primary Offset - Specify the offset, or copy interval, for each object type.          

 l You can also specify a Secondary Offset for each object type that is used when the Alternate  edit behavior is 

active. See Alternate on page 209.          

 l Rotation Of All Objects - Specify the copy interval, in degrees, to be used when objects are rotated as they are 
copied.           

 
Evenly Distribute Copies When Dragging

Click this radio button to specify a set number of copies to be made as you drag with the mouse. The further you drag, the 
wider the spaces between the copies. These settings apply to all object types.                 
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 l Primary Number of Copies - Specify the number of copies to be made.           

 l Secondary Copies - Specify the number of copies to be made when the Alternate  edit behavior is active.           

TRANSFORM/REPLICATE OBJECT

Objects and groups of objects can be copied and pasted using the Transform Replicate Object dialog. See 
Transform/Replicate Object Dialog on page 269.
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Chapter 8
 

Displaying Objects

The way that objects display is an important in all stages of the design process. There are two primary ways that  the display 
of objects is controlled: Drawing Groups and Layers.         
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Displaying Objects
There are two broad categories of objects in Chief Architect: architectural objects and CAD objects. See Architectural vs 
CAD Objects on page 162.         

CAD objects are two-dimensional and display only in the view in which they were drawn. Architectural objects, on the 
other hand, are 3D and are represented in 2D and 3D views in different ways.

LAYER SETTINGS

By default, CAD and CAD-based objects use the settings assigned to their layer: including line style, color, and weight. 
They can be assigned custom line attributes in their specification dialogs. See Line and Text Styles on page 182.          

In plan view, architectural objects are represented much like CAD objects, using the attributes assigned to their layer. In 
addition, the edge lines of architectural objects in Vector Views also use these layer settings. See Vector View on page 1147.

In addition, layers can be used to turn the display of objects on and off in different views. See Layer Attributes on page 181.
         

FILL STYLES

Closed CAD objects and can also be assigned a fill style for their interior areas. Fill styles may be a solid color or a pattern, 
and can be specified as transparent. See Fill Styles on page 197.         

Many architectural objects              can also be assigned a fill style; however, it is only used in plan view. In 3D views, architectural 
objects are represented using surfaces that have materials assigned to them.         

PATTERNS AND TEXTURES

The appearance of architectural objects in 3D views is determined by the materials applied to the objects’ surfaces. See 
Materials on page 1050.         

Material patterns display in Technical Illustration, Line Drawing, and Vector Views, while textures display in other types of 
rendered views. See Rendering Techniques on page 1147.

You can turn the display of patterns on or off in 3D views that use them by selecting 3D> Toggle Patterns .         

 

Layers
Layers are used to organize and manage the display of all objects in all views and in the Materials List. A layer can be 
thought of as a transparency sheet with objects placed on it for viewing. Nearly all views use multiple layers, like a stack of 
transparencies put together to show different types of objects. 

You can find out which layer an object is on in its specification dialog or by selecting the object and looking at the Status 
Bar. And, you can customize how each layer displays in the Layer Display Options dialog. See The Status Bar on page 25 
and Layer Display Options Dialog on page 183.

Multiple layers are organized into Layer Sets, which are designed to help you perform different tasks efficiently or produce 
specific views for your construction documents or for presentation purposes. You can customize the display settings for 
individual layer sets and can also copy, add and delete layer sets. See Layer Sets on page 186.

Different types of 2D and 3D views use their own layer sets. You can specify the initial layer set used by a particular type 
of view in the Layer Set Defaults dialog. See Layer Set Defaults on page 188.         
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Layer Attributes
The display of objects in different views is controlled by layer sets and layers in the Layer Display Options dialog. See 
Layer Display Options Dialog on page 183.

IN-USE LAYERS

A layer is considered to be in use in the current plan or layout file if one or more objects are assigned to it; if it is selected in 
one or more defaults dialogs; or, if it is a system default layer for one or more drawing tools.           

In the Layer Display Options dialog, the Used column identifies in use layers:          

 Indicates that one or more objects are assigned to the layer.             

 Indicates that there are no objects on the layer, but that it is specified in a defaults dialog.             

 Indicates that the layer is not used elsewhere, but is a system default layer.             

Move your mouse pointer over an icon to display a tool tip summarizing where the layer is in use.           

PRIMARY AND SECONDARY LAYERS

Every object is placed on a layer which controls whether it displays in a given view. This layer is referred to as the object’s 
primary layer, and you can see its name in the Status Bar when the object is selected. See The Status Bar on page 25.          

In addition, some objects have secondary layers which may alter the appearance of objects on the primary layer, but do not 
control whether the objects display or not.          

For example, the default primary layer for base cabinets is “Cabinets, Base”. In addition, base cabinets have a number of 
secondary layers that control the display of the countertop, face indicators, door opening indicators, module lines and labels.
         

Note: If an object’s primary layer is turned off, information on its 
secondary layers will not display - even if those layers are turned on.

You can view a list of an object’s primary and secondary layers  by selecting it and clicking the Object Layer Properties 
 edit button. See Object Layer Properties on page 192.           

IN PLAN AND 3D VIEWS

All layers with a check in the Disp column display when the current layer set is active. Objects that are not displayed cannot 
be seen or selected. If you try to place or draw an object on a layer that is hidden, the program asks if you want to turn the 
layer on.         
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Some objects are designed to be inserted into another object rather than standing alone. If the display of an object that 
contains an inserted object is turned off, the inserted object’s display will be turned off, as well  For example, if the display 
of a wall is turned off, any doors and windows in that wall will not display either. See Inserted Objects on page 981.         

Only displayed objects are included when DXF/DWG and EMF files are exported, and only displayed objects print.         

LINE AND TEXT STYLES

A layer’s Color, Weight, Line Style and Text Style attributes determine how an object on that layer appears in plan view. 
These attributes also affect Surface Edge Lines in 3D views using the Vector View Rendering Technique. The Color 
attribute is also used for Surface Edge Lines in Technical Illustration renderings. See 3D View Defaults Dialog on page 
1084.         

Many objects, including all CAD and text objects, allow you to override these settings for an individual instance without 
changing its layer. See Line Style Panel on page 310.          

EDGE AND PATTERN LINES

In 3D Vector Views, objects are represented using lines to define their surface edges. By default, Edge Lines use the 
attributes set for the object’s layer, as described above.           

Some CAD-based architectural objects, such as Slabs, have line style settings in their specification dialogs; however, these 
specifications are not used unless Use Object Settings is checked in the 3D View Defaults dialog. See 3D View Defaults 
Dialog on page 1084.           

In addition, a material applied to an object surface may have a pattern associated with it. Pattern line color, weight, and 
spacing is set in the Define Material dialog. See Pattern Panel on page 1067.           

LOCKING LAYERS

Objects on layers with a lock icon in the Lock column cannot be selected by the user.           

New objects cannot be drawn on a locked layer, either. If you lock a layer and then attempt to draw a new object on that 
layer, a message box will ask you to unlock the layer.           

Layers with objects that you need to see as a reference while working, but not select, are good candidates for locking. For 
example:           

 l Locking the “Rooms” layer can make it easier to select objects located inside rooms.
 l Locking the “Roof Planes” layer can make it easier to select objects located under the eaves.

Another use for locking layers is to protect them from editing in plans opened by clients or others in select Home Designer 
programs. See Opening Chief Architect Plans in Home Designer Programs on page 35.          
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Locking a layer does not prevent objects on that layer from 
being modified. In addition, most objects can be deleted using 

the Delete Objects dialog. Objects are also deleted if the floor they are 
placed on is deleted. See Deleting Objects on page 289. 

COPYING AND PASTING

If you place an object on a renamed or custom layer and then paste it into a new plan or layout file, a new layer will be 
created in the destination file. See Copying and Pasting Objects on page 171.          

 

Layer Display Options Dialog
The Layer Display Options dialog controls the display of layers in a selected layer set. From any view, select Tools> 
Layer Settings>  Display Options to open this dialog. 

The Layer Display Options dialog consists of a table that lists all layers and their attributes. See Layer Attributes on page 
181.

There are a number of dialogs similar to Layer Display Options in the program:           

 l The Object Layer Properties  edit tool allows you to access and edit the layer or layers associated with one or 

more selected objects. See Object Layer Properties on page 192.          
 l Select Tools> Layer Settings> Display Options  in a layout to open the  Layout Page Display Options dialog. See 

Layout Page Display Options on page 1339. 
 l The Layer Display Options dialog is also available for views sent to layout. See Displaying Layout Views on page 

1348. 
 l The Layer Display Options dialog can also be accessed via the Materials List Specification dialog, in which case it 

will only have the Name and Disp columns in the table of layers. See Options Panel on page 1320.         

To edit the attributes of a Reference Floor Layer Set, click the Define button in the Change Floor/Reference dialog. See The 
Reference Display on page 69.
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Layer Sets

The Layer Sets options let you specify which layer set - or sets - is affected by changes made in this dialog as well as 
which layer set is active in the current view. These options are not available in the Object Layer Properties dialog.

 l The currently active layer set displays in the drop-down list. 

 l Click the Copy Set button to create a copy of the current layer set.

 l Check Modify All Layer Sets, then make changes to one or more layer’s attributes and click OK. The changes 
will be applied to the layer(s) in all layer sets. See Modify All Layer Sets on page 187.

Modify All Layer Sets is a one-time action. It is always 
unchecked when the Layer Display Options dialog is opened.

 l Click the Reset Layer Names button to restore the original names to any system layers that have been renamed in 
the current file. Not available in the Active Layer Display Options side window. See Active Layer Display Options 
on page 190.

 l Click the Delete Unused Layers button to remove any layers in the current file that are not in use. Not available in 
the Active Layer Display Options side window. See In-Use Layers on page 181.
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Properties for Selected Layer Set

The Properties for Selected Layer Set are presented in a table of layers and their attributes. You can filter the names that 
display in the list by typing in the Name Filter text field. When nothing is typed in this field, all layers display. You can 
also click a column header to sort all layers in the table by that column. An arrow above a column indicates that it is being 
used to sort the table, and in which direction it is being sorted. 
The Name column is sorted alphabetically. Layers are named so that similar object types are listed near one another, and 
sorting is case sensitive to allow greater control over organization.               Double-click a layer in the Name column to rename it. 

 l An icon in the Used column indicates that the layer is in use. The information in this column can be sorted, but not 
edited here. See In-Use Layers on page 181.           

 l A check in the Disp column indicates which layers are set to be visible. If a layer is turned off, this column is 
blank.          

 l A lock icon   in the Lock column indicates which layers are locked, preventing objects on that layer from being 
selected. See Locking Layers on page 182.          

 l The Color column shows the line color for each layer and can be sorted so that like colors are listed together.          

 l The Line Style column shows the line style for each layer and can be sorted so that like line styles are listed 
together.          

 l The Line Weight column displays the line weight used by each layer and can be sorted so that like line weights 
are listed together. See Line Weights on page 1379.           

 l The Text Style column shows the text style assigned to each layer and can be sorted so that layers using the same 
style are listed together. See Text Styles on page 547.          

The buttons below the table offer additional control over the layers in the table.          

 l Click the Select All button to select all layers in the table at once. This allows changes to be quickly applied to all 
layers.          

 l Click the New button to open the New Layer Name dialog and create a new layer with a unique name of your 
choice. Duplicate layer names are not allowed.

Note: New layers are added to all layer sets. However, in all but the 
current layer set, their display will be turned off. 

 l Click the Copy button to create a copy of the selected layer. The new layer is added directly below the original in 
the table. 

 l When two or more non-system layers are selected, click the Merge button to consolidate them into a single layer. 
The layer selected first is retained and the others are merged into it. Any objects on those merged layers or defaults 
set to use those merged layers are moved to the remaining layer.         

 l Click the Delete button to delete the selected layer. You cannot delete used layers or any of the system layers used 
by Chief Architect.          

 l Click the Reset Names button to revert layer names for system layers back to the original names that installed with 
Chief Architect. This does not affect layers you created.          

 l Click OK to close the dialog and apply your changes.          

 l Click Cancel to close the dialog, ignoring any edits.          

185



Chief Architect Premier X14 Reference Manual - Layer Sets

Layers are selected by clicking on them in the table. Hold down the Shift key or the Ctrl key to select multiple layers at 
once. Press Ctrl + A or click the Select All button to select all layers in the table. When selected, a layer’s attributes 
display and can be edited below.           

The program remembers what layer(s) are selected when you 
click OK and selects them again when you return to this 

dialog.

 
Properties for “Selected Layer”

The Properties for “Selected Layer” options let you modify the attributes of one or more selected layers. Line Color, 
Style, and Size affect lines in plan view and surface edge lines in Vector Views. When multiple layers are selected, “No 
Change” may display for attributes that are not shared by the selected layers.

 l To turn off a selected layer, uncheck Display. See Layer Attributes on page 181.                 

 l To protect the objects on a selected layer from accidental changes, check Lock. Items on locked layers can display 
but cannot be selected. See Locking Layers on page 182.          

 l To change the color of lines on a selected layer, click the Color bar to open the Select Color dialog. See  Color 
Chooser/Select Color Dialog on page 204. 

 l Specify the default Line Weight, or thickness, for objects on the selected layer. See Line Weights on page 1379.          

 l To change the Line Style of a selected layer, click the drop-down arrow or the Library button to select a line style 
from the library. See  Line Styles on page 200.

 l To change the Text Style of a selected layer, click the drop-down arrow or click the Define button to open the 
Text Style Defaults dialog. The Define button is not available when multiple layers with different Text Styles are 
selected. See Text Styles on page 547.

Note: Not all objects display in all views. For instance, invisible walls do 
not appear in camera views or materials lists, regardless of the layer they 
are placed on or whether that layer is turned on or not.

 

Layer Sets
Layer Sets are used to control the layer settings for different views in a plan or layout file. All views associated with a plan 
file - including views sent to layout - make use of layer sets stored in that .plan file. 

A layer set consists of a complete list of the layers in the current plan or layout along with the display settings for each layer 
as set for a particular type of view or purpose. These display settings can be modified, and can be different for each layer 
set. See Layer Display Options Dialog on page 183.

Any changes made to a layer set in one view  affects all other views using the same layer set.  If this is not desired, you can 
create a unique layer set for a particular view.  See Layer Set Management on page 188.          

Layer sets are file specific, which means that changes made in one plan or layout file have no effect on the settings in other 
files. If you find that you use the same settings often, you should consider adding these layer sets to your template files. See 
Template Files on page 87.

Layer sets are also view specific, so you can use a different layer set in each plan view, camera view, cross section/elevation 
view, and CAD Detail if you wish. See View Windows on page 149.          
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ACTIVATING A LAYER SET

There are five ways to activate a Layer Set:          

 l Select a Layer Set from the Active Layer Set Control   Layer Set  drop-down. This control is available in 
camera views and can be added to the toolbars for other view types as well. See To add a button to a toolbar on page 
137.          

 l Activate a Default Set. See Default Sets on page 83.          
 l Open a saved view in which the Layer Set was previously active.           
 l Select a Layer Set in the Active Layer Display Options side window. See Active Layer Display Options on page 190.           
 l Select a Layer Set in the Active Defaults dialog. See Active Defaults Dialog on page 82.           

LAYOUT LAYER SETS

Views sent to layout use layer sets saved with the plan, rather than with the layout.  See Displaying Layout Views on page 
1348.          

LAYER SETS AND TEMPLATES

Layers and layer sets are plan-specific. A custom layer set that you created in one plan file may not be available in another. 
To include a custom layer set in all new plan files, add it to your template plan.  See Exporting and Importing Layer Sets on 
page 193 and Template Files on page 87.          

MODIFY ALL LAYER SETS

If you want changes made in one layer set to apply to all other layer sets in the current plan, check Modify All Layer Sets 
in the Layer Display Options dialog before making changes. The layer name and display attributes are applied to all other 
layer sets.           

For example, if you check Modify All Layer Sets and then change the color and line style for the Text layer of the 
Electrical Set, the same changes are applied to the Text layer of the Framing Set of the same plan.          

In order for changes to a layer to be applied to all layer sets, you 
must check Modify All Layer Sets before making the changes. 

LAYER SET DEFAULTS

Whenever a particular type of view is created, such as floor plan view or a framing overview, a specific layer set is activated 
for that view. Which layer set becomes active depends on the type of view created.          

The default layer sets for nine different view types, including the Reference Floor, are specified in the Layer Set Defaults 
dialog.           

Each of these layer sets can be edited as needed in the Layer Display Options dialog. See Layer Display Options Dialog on 
page 183.          

Normally, it is best to change the settings in the existing default layer sets rather than select different default layer sets, but 
you can do so if needed. See Layer Set Defaults on page 188.
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Layer Set Defaults
The Layer Set Defaults dialog is used to specify the initial layer sets for a variety of special view types. Select Edit> 
Default Settings to open the Default Settings dialog, then select “Layer Sets” from the list and click the Edit button. 

See Default Settings on page 76. 

When  a new view window is created, Chief Architect sets the default layer set listed here as the active layer set for that 
view type. See View Windows on page 149. 

 l Click the drop-down list to change the initial layer set for each type of view.
 l Select “Use Active Layer Set” from the list to use whatever layer set is currently active in the new view when it is 

created.
 l Click the Define button to open the Layer Display Options dialog and change the layer settings for the layer set. See 

Layer Display Options Dialog on page 183.

The default layer sets for camera views can be set in the Camera 
Defaults dialogs. See Camera Defaults Dialogs on page 1082. 

 

Layer Set Management
The Layer Set Management dialog lists the layer sets available in the current plan or layout file and lets you add and 
remove layer sets and modify and copy existing layer sets. Select Tools> Layer Settings> Layer Set Management 

to open this dialog.

188



Chief Architect Premier X14 Reference Manual - Layer Set Management

 
Available Layer Sets

Use the Available Layer Sets options to manage the layer sets saved with the current plan or layout file.

 l Click on a layer set name in the list to select it.

 l Click the Define button or double-click on the layer set name to open the Layer Display Options dialog and make 
changes to the selected layer set. 

 l Click the New button to open the New Layer Set Name dialog and create a new layer set based on system default 
settings. 

 l Click the Copy button to open the New Layer Set Name dialog and create a new layer set based on a copy of the 
currently selected layer set.

 l Click the Rename button to open the Rename Layer Set dialog and type a new name for the selected layer set. Not 
available for the Default Set.
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 l Click the Delete button to delete the selected layer set from the current file. The Delete button is enabled if the 
layer set can be deleted: you cannot delete the active layer set, the Default Set, or any layer set in use as a default. 

Do not delete any layer sets that are used by a layout. 

 l Click the Import button to import layer settings from a .layers file. See Exporting and Importing Layer Sets on 
page 193.

 l Click the Export button to export the layer settings in the current plan in a .layers file. 

 
Active Layer Set for Current View

The Active Layer Set for Current View options affect only the layer set used in the view that was active when the Layer 
Set Management dialog was opened. 

 l Select a new Active Layer Set from the drop-down list or click the Define button to make changes to the active 
layer set in the Layer Display Options dialog.

 

Active Layer Display Options
The Active Layer Display Options side window allows you to access the layer settings for the currently active Layer 
Set or the Object Layer Properties for the currently selected object. Select View> Active Layer Display Options to 

open or close this side window.         

 l When no object is selected, the settings for the active Layer Set are shown. See Layer Sets on page 186.          
 l When one or more objects are selected, the objects’ Object Layer Properties are shown. See Object Layer Properties 

on page 192.          

The list of layers and the options for editing their attributes are similar to those in the Layer Display Options dialog. See 
Layer Display Options Dialog on page 183.           

Click the Options  button at the bottom of the side window to specify what settings and information are presented:          

 l Select Layer Set Control to display the Layer Set drop-down list at the top of the side window. The name of the 
active layer set is stated and can be changed here.          

 l Select Layer Management to display the Reset Layer Names and Delete Unused Layers buttons.          
 l Select Layer Name Filter to display the Name Filter text box above the layer table. Type in this field to filter the 

names shown in the table; when nothing is typed, all relevant layers are listed.           
 l Select Layer Edit Buttons to display the Select All, New, Copy, Merge, Delete, and Reset Names buttons below the 

layer table.           
 l Select Layer Properties to display the Properties for Selected Layer settings below the label table.          
 l Select Show All Layers to list all layers in the table, even when an object is selected.          
 l Select which Columns to include in the table.           

By default, when the Active Layer Display Options side window is opened, it will be docked on the right side of the 
program window. Like other side windows, though, it can be moved. See Side Windows on page 17.          

 

Select Layer Dialog
The Select Layer dialog allows you to select a layer for one of two purposes: 
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  Select CAD> Current CAD Layer to open this dialog and specify which layer is the Current CAD Layer. See 
Current CAD Layer on page 332.

  This dialog also opens when the Layer Painter tool is used. See Layer Painter, Eyedropper, and Hider on page 
193.

The Current CAD Layer and Layer Painter buttons can be added to your 
toolbars. See To add a button to a toolbar on page 137.

The Select Layer dialog contains the table of layers and Name Filter found in the Layer Display Options dialog. See Layer 
Display Options Dialog on page 183. Click on a layer in the table to select it, then click OK.

 l If the dialog was opened using the Current CAD Layer  tool, the selected layer will become the Current CAD 

Layer. 
 l If the dialog was opened using the Layer Painter  tool, you can click on objects in the current view to assign them 

to the selected layer. 

 

Layer Panel
The LAYER panel is found in the specification dialogs for many different objects. Here you can specify the layer that the 
program uses to display the selected object.

Note: In some specification dialogs, layer information is located on the 
Line Style or Appearance panel rather than the Layer panel.

 
Layer

Specify the layer that the selected object(s) is located on. 

 l Check Default to place the selected object on the default layer for that object type. See Dynamic Defaults on page 
79.    

 l Click the drop-down list to select a layer from those available in the current file. 

 l Click Define to open the Layer Display Options dialog and select, modify, or add a new layer. See Layer Display 
Options Dialog on page 183.

 
Drawing Group

See Drawing Groups on page 194.
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Object Layer Properties
The Object Layer Properties edit tool allows you to access and edit the layer or layers associated with one or more 
selected objects. See Primary and Secondary Layers on page 181.

Some objects, such as CAD lines, only have one layer associated with them. Other objects, including many architectural 
objects like cabinets, have multiple layers that affect their display in various views. A few objects, such as active camera 
symbols and layout boxes, do not have this edit tool. 

When you click the Object Layer Properties  edit button, the Object Layer Properties dialog opens. 

The settings in this dialog are similar to those in the Layer Display Options dialog. See Layer Display Options Dialog on 
page 183.

 
Properties

The Properties of the selected object(s) layers in the currently active layer set display in the table. The name of the 
currently active layer set is included in this heading. See Layer Sets on page 186.

 l Type in the Name Filter text field to filter the names that display in the list below. When nothing is typed in the 
field, no layers are suppressed. 

 l A table listing the layers associated with the selected object(s) displays here. This sortable table functions like that 
in the Layer Display Options dialog. 

 l Check Show All Layers to list all layers in the current file rather than just those associated with the selected 
object. When unchecked, only the layers associated with the selected object(s) display.

 
Properties for Selected Layer

The Properties of the selected layer(s) display and can be edited here. 

 l As in the Layer Display Options dialog, when multiple layers with different properties are selected, drop-down 
lists may display “No Change” and check boxes may have a solid fill. See Dialogs on page 19. 

192



Chief Architect Premier X14 Reference Manual - Layer Painter, Eyedropper, and Hider

 

Layer Painter, Eyedropper, and Hider
The Layer Painter and Layer Eyedropper tools allow you to move an object to any layer in any view 
without opening its specification dialog. 

The Layer Hider tool lets you turn off the display of any layer in the currently active layer set by clicking on an 
object on that layer. 

To use the Layer Painter
 1.  In any view, select Tools> Layer Settings> Layer Painter .

 2.  In the Select Layer dialog, choose a layer and click OK. Your cursor will display the painter   icon. See Select 
Layer Dialog on page 190.

 3.  Note that the name of the layer being painted is noted on the left side of the Status Bar at the bottom of the program 
window. See The Status Bar on page 25. 

 4.  Move your cursor over an object and notice that the Status Bar now states both the layer being painted and the 
current layer of the target object. 

 5.  Click on objects in the view to move them to the selected layer. 

To use the Layer Eyedropper
 1.  In any view, select Tools> Layer Settings> Layer Eyedropper .

 2.  Click on an object to load the layer it is on into the Layer Painter. 

 3.  Your cursor will display the painter   icon, and you can click on other objects to place them on the selected layer.

To use the Layer Hider
 1.  In any view, select Tools> Layer Settings> Layer Hider .

 2.  Your cursor will display the layer   icon. 

 3.  Move your cursor over an object and notice that the Status Bar states the object’s primary layer. 

 4.  Click on the object to turn off the display of its primary layer in the currently active layer set. See Layer Sets on 
page 186.

 

Exporting and Importing Layer Sets
Layer sets created in one plan can be exported as a .layers file and imported into other plans. This is a convenient 
alternative to re-creating one or more layer sets that may already exist in another plan.

EXPORTING LAYER SETS

To export layer sets from the current plan or layout file, select File> Export> Export Layer Sets or click the Export 
button in the Layer Set Management dialog.

The Save Layer Set File dialog is a typical Save File dialog. Exported layer set files use the .layers file extensions. See 
Exporting Files on page 41.
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IMPORTING LAYER SETS

To import layer sets into the current plan or layout, select File> Import> Import Layer Sets or click the Import 
button in the Layer Set Management dialog.

The Import Layer Set File dialog is a typical Open File dialog. See Importing Files on page 45.

When the desired .layers file is selected, click Open. The Import Layer Sets dialog will open next.

 
Layer Sets to Import

Specify which layer sets you would like to import.

 l Check the box beside the name of each layer set that you would like to import. 

 l Click the Select All button to select all sets in the list.

 l Click the Clear All button to deselect all sets in the list.

 
Existing Layer Sets

Specify how to handle Existing Layer Sets in the current file that have the same names as layer sets being imported. 

 l When Replace is selected, any layer sets in the current file with names identical to those being imported are deleted 
and replaced with imported sets. 

 l Select Create a New Copy to retain all existing layer sets and rename imported layer sets by appending them with a 
2. If a layer set with the same name is imported later, this number is increased.

 

Drawing Groups
Each object in a plan              or layout file belongs to a Drawing Group, which influences whether it displays in front of or behind 
other objects. Drawing Groups control the display of objects in plan view, CAD Details, and on the layout page. They also 
control the display of CAD objects drawn in cross section/elevation views. They do not affect the display of objects in 
camera views and overviews.         

Most categories of objects have their own Drawing Group; however, a few objects are instead placed in the Front or Back 
Group. Imported pictures, which are placed in the Back Group, are a notable example. A selected object’s Drawing Group is 
reported in the Status Bar. See The Status Bar on page 25.          
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Within a given Drawing Group, drawing order is determined by the order in which objects are placed. By default, an object 
will display in front of any objects that were created before it was. For example, if you place a chair and then a table, the 
table will display in front of the chair; if you instead place a table and then the chair, the chair will display in front.          

Drawing order also affects how objects are selected. If two objects are positioned so that they overlap one another, and you 
click at a point that they both share, the frontmost object will become selected first. See Select Next Object on page 215.          

DRAWING GROUP EDIT TOOLS

Once an object has been placed, its position in the drawing order can be modified. To do this, select one or more 
objects and click the View Drawing Group Edit Tools edit button.         

There are two options for moving a selection towards the back of the drawing order:          

  Click the Send to Back edit button to move the selected object(s) to the back of the Back Group so it displays 
behind all other objects.         

  Click the Send Backward edit button to move the selected object(s) to the back of its current Drawing Group. If 
it is already at the back of its current group, it will be moved to the next group down in the drawing order.

There are two options for moving a selection towards the front of the drawing order:          

  Click the Bring to Front edit button to move the selected object(s) to the front of the Front Group so that it 
displays in front of all other objects.          

  Click the Bring Forward edit button to move the selected object(s) to the front of its current Drawing Group. If 
it is already at the front of its current group, it will be moved to the next group up in the drawing order.

SELECT DRAWING GROUP DIALOG

The Select Drawing Group edit button reports the Drawing Group number that the selected object(s) is in. When multiple 
objects are selected, a horizontal line may display instead. Click this button to open the Select Drawing Group dialog.          

 l Select a Drawing Group from the drop-down list to place the selected object(s) into that group. The default group for 
the selected object is noted as such.           

 l When multiple objects in different groups are selected, “No Choice” will initially display. You can select “Default: 
Multiple Values” to return each object to its respective default group.          

You can specify the default Drawing Group for most types of objects in their defaults dialogs. See Default Settings on page 
76.           
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You can also assign a selected object to a particular Drawing Group in its specification dialog. See Line Style Panel on 
page 310 and Layer Panel on page 191.          

 

Display Toggles
There are a number of toggles and tools that can be used to affect the appearance of the on-screen display. 

PRINT PREVIEW

Print Preview and its related display toggles allow you to get a sense of what the current view will look like when it 
is printed. See Print Preview on page 1376.

REFRESH DISPLAY

Refresh Display redraws the current window to clean up extra lines, show missing items, and correct random on-
screen effects caused by changes to a model. Select View> Refresh Display or press the F5 key to refresh the on-

screen display. 

COLOR ON/OFF

The display of color on-screen can be toggled on and off in any view by selecting View> Color or by clicking the 
toggle button. 

 l If Color is toggled off in any 3D view other than a Vector View or a Line Drawing view, the view will be displayed in 
grayscale.

 l If Color is toggled off in any line based view, including plan view, Vector Views,  Line Drawing views, CAD Details, 
and layout, the view will be displayed  either in black and white or grayscale, depending on the Color Off Is setting in 
the Preferences dialog. See Appearance Panel on page 99.             

The Color toggle can be set on a view by view basis and can be saved in the Plan View Specification dialog, Camera 
Specification and Cross Section/Elevation Specification dialogs. See General Panel on page 153, Camera Panel on page 
1116 and Camera Panel on page 1124.

To display views in grayscale
 1.  Select View> Color  to toggle color off.             

 2.  Select Edit> Preferences  to open the Preferences dialog.             

 3.  On the APPEARANCE panel, select Grayscale as the Color Off Is setting. See Appearance Panel on page 99.             

To display views in black and white
 1.  Select View> Color  to toggle color off.    

 2.  Select Edit> Preferences  to open the Preferences dialog.    

 3.  On the APPEARANCE panel, select Black and White as the Color Off Is setting.    

When Color  is toggled off and Black and White is specified, all lines appear as black, regardless of their color. Solid 

fill colors appear as either white or black, depending on which is closer to the actual fill color when Color is turned on. The 
background remains as defined in the Preferences dialog. See Colors Panel on page 102.          
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You can specify whether cross section/elevations, camera views, and overviews using the Vector View Rendering 
Technique are generated with colors turned on in the 3D View Defaults dialog. See 3D View Defaults Dialog on page 1084.          

You can also print in color, black and white, or grayscale. See Print View Dialog on page 1385.         

ARC CENTERS AND ENDS

The display of arc center- and endpoints, and the display of circle center points can be toggled by selecting View> 
Arc Centers and Ends, by clicking the toggle button, or in the CAD Defaults dialog. See Arc Centers and Ends on 

page 225.         

DELETE SURFACE

In any 3D view, select 3D> Delete Surface, then click a surface in the view to temporarily remove the surface from 
the current view. See Delete 3D Surface on page 1099.

 

Fill Styles
Fill styles are CAD-based patterns that can be used to fill the interiors of closed CAD shapes. In plan view, fill styles can 
also be applied to a variety of architectural objects.         

The Fill Styles library contains fill styles that can be applied to objects individually in their specification dialogs, by default 
in their defaults dialogs, as well as using the Fill Style Painter tools.           

You can use the Place Library Object  tool to create a custom toolbar button that has a fill style associated with it. See 

Place Library Object Button on page 982.          

FILL STYLE EYEDROPPER AND PAINTER TOOLS

The Fill Style Eyedropper tool allows you to load a fill style assigned to an existing object into the Fill Style Painter 
and apply that fill style to other eligible objects.         

Select Tools> Fill Style Painter to access the Fill Style Painter tools, which are used to apply fill styles to closed CAD 
objects. In plan view, the Fill Style Painter tools can be used to apply fill styles to a variety of architectural objects, as well.         

These tools are similar to other Painter Tools in the program. See Eyedropper and Painter Tools on page 281.         

Patterns, which are similar to fill styles, can be used to represent 
materials in Vector Views. See Patterns and Textures on page 

1051.

IMPORT PATTERNS

Select File> Import> Import Patterns to open the Import Custom Patterns file and import a .pat file. See Importing 
Files on page 45.

Patterns are imported directly to the User Catalog in the Library Browser. See The User Catalog on page 970.         
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Fill Style Panel and Dialogs
The FILL STYLE panel is found in the specification dialogs for a variety of objects in the program. This panel is not available 
for Connect Electrical splines or Sprinkler Lines as these objects cannot be used to form closed shapes. 

The settings on this panel are also found in a number of dialogs:

 l To open the Fill Style Specification dialog, right-click on a fill style in the library and select Open Object or right-
click on an unlocked library folder and select New> Fill Style. See Using the Contextual Menus on page 965.

 l You can also create a new fill style by clicking the Add New Fill Style  button in the Select Library Object dialog. 

See Select Library Object Dialog on page 982.
 l To open the Layer Fill Style dialog, click in the Fill column in the Wall Type Definitions or any Material Layers 

Definition dialog. See Wall Type Definitions Dialog on page 390 and Material Layers Definition Dialogs on page 
1040. 

 l The Default Framing and Default Header Fill Style dialogs can be accessed by clicking the Fill Style button on the 
PLAN DISPLAY and OPENINGS panels of the Build Framing dialog. See Build Framing Dialog on page 873.          

 
Fill Style Name

 In the Fill Style dialog only, specify the Fill Style Name.
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Pattern

Select a  Pattern Type from the drop-down list and specify its characteristics.         

 l Select “Library” from the list or click the Library button to choose a pattern from the library. When a Library fill 
style is selected, a custom name may display in the list instead of a system default Type. See Assigned Items on page 
981.              

When a fill style from the library is selected, it is possible for 
some or all of the settings in this dialog to change.

 
Scale

Specify the fill style’s Scale.         

 l Specify the Width of the selected fill pattern.              For Concrete and Sand fills, instead adjust the overall Spacing. Not 
available for Solid fill.

 l Specify the Height of the selected fill pattern.              Only available for the Grid fill Types, as well as Herringbone and 
U’s.

 l Specify a Scale for the selected fill pattern. Only available when the name of a library fill style from the library is 
listed as the fill Type, above.             

 
Offsets and Angle

Specify the fill’s Offsets and Angle.         

 l Specify the Horizontal and Vertical Offsets. See Mapping Patterns and Textures on page 1062.              

 l Specify the Angle of the selected fill pattern. Not available for Solid fill.         

 
Appearance

Additional Pattern Appearance settings control the fill’s              line weight and color.

 l Set the Line Weight for the selected fill pattern. Not available for “Solid” fill.          

 l Specify a custom Pattern Color for the lines that make up the fill pattern or Solid fill by clicking the color bar. 
The Layer Color is used by default. See Color Chooser/Select Color Dialog on page 204.

 l Custom Color is selected automatically if you click the color bar above.         

 l Select Use Layer Color to have the fill pattern use the layer color for the pattern lines or solid fill.              

 l Select Use Background Color to use the view’s background color for the pattern lines or solid fill.             

 l Use the Transparency slider bar or text field to control how transparent the fill pattern lines are. This setting also 
affects the transparency of Solid fill colors.         

 
Background

Check Background to add a solid background color to the fill pattern and enable the settings below. When unchecked, the 
fill pattern has a transparent background. Not available when “Solid” is the selected Pattern Type.          

 l Specify a custom Background Color by clicking the color bar. The Background Color set in the Preferences 
dialog is used by default. See Colors Panel on page 102.

 l Custom Color is selected automatically if you click the color bar above.         
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 l Select Use Layer Color to have the fill pattern use the layer color for the pattern lines or solid fill.              

 l Select Use Background Color to use the view’s background color for the pattern lines or solid fill.             

 l Use the Transparency slider bar or text field to control how transparent the background color is.          

 l On the FILL STYLE panel only, click the Add to Library button to add the fill pattern as it is currently defined to 
the User Catalog. See Add to Library on page 973.             

 
Preview

A preview of the selected pattern displays to the right. As changes are made to the settings on this panel, the preview will 
update.         

 l Choose a Preview Width from the drop-down list. This value controls how large an area the preview represents. 
The selected value indicates the horizontal width of the preview pane in actual plan inches (mm).         

 

 Line Styles
Line styles can be applied to objects by layer in the Layer Display Options dialog. See Layer Display Options Dialog on 
page 183.           

CAD and CAD-based objects can also be assigned a line style in their specification dialogs. See Line Style Panel on page 
310.          

LINE STYLES IN THE LIBRARY

A selection of line styles is available in the library, and additional styles can be created or imported into the User Catalog.           

You can draw a line that uses a selected style directly from the library. See Line Tools on page 305.           

To draw with a line style from the library
 1.  Select a line style in the tree list or Selection Pane of the Library Browser. See The Library Browser on page 962.          

 2.  Click and drag in a 2D view to produce a CAD line with the selected style.          

 3.  Continue drawing CAD lines with the same style until another line style or drawing tool is selected.          

You can use the Place Library Object  tool to create a custom toolbar button that has a line style associated with it. See 

Place Library Object Button on page 982.          

LINE STYLE MANAGEMENT

Once a line style has been assigned to an object or a layer, it is saved in the plan or layout file. Select CAD> Lines> 
Line Style Management to access a list of the line styles saved in the current file in the Line Style Management 

dialog.         
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 Line Styles

All line styles saved in the current file are presented in a table. Click a column header to sort all line items in the table by 
that column. An arrow above the column indicates that it is being used to sort the table, and in which direction it is being 
sorted. Line Styles that are not currently assigned to a layer, an object, or a default may also be included in the list.         

 l Click on a line style to select it. Multiple line items can be selected, as well. See Shift and Ctrl Select on page 217.          

 l The Style column shows a sample of each line style.           

 l The Name of each line style is listed. Click in this column and type a letter to locate names that begin with that 
letter.          

 l Line styles with at least one instance in the current file have a plus sign in the Used column. See In Use Line Styles 
on page 202, below.          

 l Move your mouse pointer over a plus sign. A tool tip will summarize where the line style in question is in use.           

 l Unused line styles have no icons in the Used column and can be deleted.           

 
 Edit Buttons

The buttons on the right allow you to add, edit, remove, and reorganize the items in the list.         

 l Click the Edit button to open the Line Style Specification dialog for the selected line style. See Line Style 
Specification Dialog on page 202.          

 l Click the New button to open the Line Style Specification dialog and create a new line style.          

 l Click the Copy button to make a copy of the selected line style and add it to the list. The new line style has the 
same name as the original, appended with a number.           

Note: Line styles created in Chief Architect are not retained in 
views exported to .dxf/.dwg. See Exporting 2D DXF/DWG Files on 
page 1234.

The items in this list and their order are also found in the Style drop-down list found in various object specification 
dialogs. See Line Style Panel on page 310.          

 l Click the Move Up button to move one or more selected line styles up one position in the list.          

 l Click the Move Down button to move one or more selected line styles down one position in the list.           
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 l Click the Purge button to delete all unused line styles from the list.          

 l Select an unused line style and click the Delete button to remove it from the list.           

 l Click the Add to Library button to add the selected line style to the User Catalog. See Adding Library Content on 
page 973.           

 
 Auto Purge Line Styles

When Auto Purge Line Styles is unchecked and all instances of a line style are removed from the current file, it will 
continue to be saved in the file and listed here. Check this box to remove unused line styles from the file.         

IN USE LINE STYLES

A line style is considered to be in use in the current plan or layout file if it is assigned to one or more objects; if it is 
selected in one or more defaults dialogs; or, if it is a system default line style.           

In the Line Style Management dialog, these icons are shown Used column:          

  A red plus sign indicates that the line style is assigned to one or more objects.          

  A white wrench indicates that the line style is specified in a defaults dialog but is not assigned to any objects 
currently.          

  A grey S indicates that the line style is not used elsewhere, but is a system default.           

  Move your mouse pointer over an icon to display a tool tip summarizing where the line style is in use.           

These icons are also used in the CAD Block Management dialog. See CAD Block Management on page 336.          

IMPORT LINE STYLES

Select File> Import> Import Line Styles to open the Import Line Styles dialog and import a .lin or .dat file. See 
Importing Files on page 45.         

Line styles are imported directly to the User Catalog in the Library Browser. See The User Catalog on page 970.          

 

Line Style Specification Dialog
The Line Style Specification dialog allows you to create new line styles for use in Chief Architect Premier. There are 
several ways to open this dialog: 

 l Click the New or Copy button in the Line Style Management dialog. See Line Style Management on page 200. 
 l Right-click on an unlocked library folder and select New> Line Style. See Adding Library Content on page 973. 
 l Click the Add New Line Style  button in the Select Library Object dialog. See Select Material/Library Object 

Dialog on page 1057.
 l Right-click on a line style in the User Catalog, then select Open Object  from the contextual menu. See Using the 

Contextual Menus on page 965. 
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Line Style Name

Type the name of your Line Style Name in the text field. This is the name that will be listed in the Library Browser. 

 
Line Style Preview

A preview diagram of the line style displays here. 

 l Click on a line style component in the preview to select it and edit it below.

 l Check Highlight Selection to display a red rectangle around the currently selected line style component.

 l Check Mark Repeating Segments to display vertical dashed lines indicating the division between the last 
component of one segment and the first component of the next in the preview diagram. 

 
Line Style Components

These options allow you to add new components to your line style.

 l Click the Dash button to add a line segment to the line style.

 l Click the Dot button to add a single point to the line style.

 l Click the Text button to add a section of text to the line style.

 l Select the Insert Before radio button to add the new component before the component that is currently selected.

 l Select the Insert After radio button to add the new component after the currently selected component.
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Component Order

A list of the line style’s individual components displays here. 

 l Click on the name of a component in the list to select it. When Highlight Selection is checked, above, a red 
rectangle displays around this component in the preview diagram.

 l Click the Up arrow to move the selected component up one position in the list and one position to the left in the 
preview diagram.

 l Click the Down arrow to move the selected component down one position in the list and one position to the right in 
the preview diagram.

 l Click the Remove button to remove the selected component from the line style.

 
Component Specifications

Control the appearance of the selected component. The Length, Spacing, and Text Height values are all subject to the 
current Drawing Scale. See Line Weights and Scaling on page 1380.

 l Specify the Length of a selected Dash or Text component when printed. If the Length exceeds that required by a 
Text component, empty space is added on each side of the text.

 l Specify the Spacing of the selected component by defining the length of an empty space to the component’s right.

 l Type the Text of a selected Text component. 

 l Specify the Text Height of a selected Text component. Each text component can have its own height.

Text inserted into a line style uses the font and transparency 
setting of the Text Style of the layer that it is on when assigned 

to an object. See Text Styles on page 547. 

 

Color Chooser/Select Color Dialog
The Color Chooser dialog is opened by selecting Tools> Color Chooser. 

The similar Select Color dialog can be opened by clicking on the Color bar that can be found in many dialogs throughout 
the Windows version of the program. 

Mouse over a Color bar to display a tool tip reporting the 
selected color’s RGB values. 

In the Mac version, the standard Colors dialog, or Color Picker, is used instead.
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Current Color

The currently selected color displays in the rectangle at the lower center of the dialog. There are a number of ways to select 
a color in this dialog.

 
Basic Colors

Click in any one of the color boxes to select it.

  Color Spectrum

 l Click anywhere in the color spectrum area to select a color. The location of the selected color is identified by 
crosshairs.     

 l Click anywhere in the vertical bar or drag the arrow to adjust the selected color’s Luminosity and RGB values.    

  Color Definition

 l Define a color by specifying its Hue, Saturation, and Luminosity (HSL) or its Red, Green, and Blue (RGB) 
values.     

 l Specify the color’s Alpha channel percentage, which is its degree of transparency. 100% is totally transparent. Only 
available when specifying a custom Toolbar Button/Image Background color for a Color Theme. See Colors Panel 
on page 102. 

 l Specify the color's Opacity. 0% is totally transparent. Only available when Selection and Edit Handle colors are 
being set via the COLORS panel of the Preferences dialog. See Colors Panel on page 102.    

  Custom Colors

 l Click in one of the Custom colors boxes to either select it or to specify it as the box for a new custom color to be 
defined.    

 l Click the Add to Custom Colors button to add the selected color to the Custom Colors group.    

 
Color Chooser Eyedropper

Click this button, then click anywhere on your monitor to select the color displaying at that location.
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Create Material

Click this button to create a new material that uses the selected material as its Material Color. The new material is saved in 
the User Catalog of the Library Browser. See The User Catalog on page 970.

If the Select Color dialog was opened via another dialog panel, click OK to apply the currently selected color to the object’s 
line or fill style, or to the material’s pattern color. 
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Chapter 9
 

Editing Objects

Just as the methods used to create different objects in Chief Architect are similar, the options for moving, rotating, resizing, 
and otherwise editing them are also alike. 

Edit handles allow objects to be resized, relocated, or rotated using the mouse. Edit toolbar buttons and the contextual 
menus access edit tools relevant to the selected object(s). Most objects have a specification dialog that allows you to edit it 
in ways that are specific to that type of object. 

The editing characteristics common to most objects are described in this chapter. Unique, object-specific editing behaviors 
and the specification dialogs are covered in their respective chapters. 
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Selecting Objects 212
Selecting Multiple Objects 215
Editing Line-Based Objects 218
Editing Arc-Based Objects 221
Editing Open Polyline-Based Objects 226
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Editing Box-Based Objects 234
Editing Spline-Based Objects 237
Editing Circles, Ovals and Ellipses 242
Editing Multiple Objects 244
Moving Objects 245
Aligning Objects 249
Resizing Objects 256
Reshaping Objects 257
Rotating Objects 261
Reflecting Objects 264
Converting Objects 265
Transform/Replicate Object Dialog 269
Edit Area Tools 273
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Trim and Extend 276
Union, Intersection, and Subtraction 278
Eyedropper and Painter Tools 281
Style Palettes 284
Matching Properties 286
Deleting Objects 289
Delete Objects Dialog 289
Undo and Redo 293

207



Chief Architect Premier X14 Reference Manual - Defaults, Preferences, and Edit Behaviors

 

Defaults, Preferences, and Edit Behaviors
The same defaults and preference settings that affect how objects are drawn also influence how they can be edited. See 
Defaults and Preferences on page 162.          

In addition, the Edit Behavior modes that determine how edit handles affect an object, and may also affect how 
objects are drawn. The currently active Edit Behavior is a global preference setting, affecting all plan and layout files.

         

Two of these modes, Default and Alternate, are useful for most drawing and editing needs and can be considered primary 
editing modes. Default mode, in particular, accesses the most commonly used behaviors and is the best choice in most 
circumstances.

When an Edit Behavior other than Default is active, its icon displays near the mouse pointer. For example, when Connect 
CAD Segments is disabled, CAD objects cannot connect to form polylines and the Connect CAD Segments   icon follows 
the mouse pointer to remind you that this behavior is active. See Pointer Icons on page 16.         

Regardless of which Edit Behavior is active, the Default behavior is restored when you close the program. 

The other modes, Move, Resize, Concentric, and Fillet, offer special editing behaviors that may be useful only in certain 
situations and can be considered secondary. 

Each edit behavior can be temporarily enabled using the different buttons on your mouse or by pressing the keyboard keys 
associated with each. See Using Input Devices on page 14 and Hotkeys on page 142.           

You can also specify which edit behavior mode is active when the left mouse button is used in the Preferences dialog, by 
selecting Edit> Edit Behaviors , or by clicking the corresponding toggle button, which can be added to your toolbar. 

See Behaviors Panel on page 120.          

DEFAULT

The Default mode is one of the primary edit behavior modes. It offers access to the most commonly used edit 
behaviors and should be selected as your preference in most situations.         

When the use of a tool is described in this manual, it is assumed 
that the Default edit behavior mode is active.

 l Drawing - Standard click and drag drawing behavior is enabled. See Creating Objects on page 168.           
 l Resize/Reshape - Default allows you to adjust the angle of any corner of a polyline without affecting adjacent corners, 

changing the object’s shape.           

 l For box-based objects, the Default mode functions the same as the Alternate mode.           
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 l Movement - Default allows you to move objects orthogonal, or at a right angle, to any of their edges.          
 l Rotation - In Default mode, objects snap at Allowed Angles as they are rotated.          

You can temporarily enable the Default  edit mode when another mode is active by pressing Alt + Z or Alt + / while 

performing an edit or drawing operation.          

ALTERNATE

The Alternate mode is the second primary edit behavior mode. When this mode is active, the Alternate   icon 
displays near the mouse pointer.         

Note: Not all commands have an Alternate edit behavior. If a selected 
tool does not, it will not work when this edit mode is active. 

 l Drawing - Continuous drawing behavior is enabled. See Clicking and Dragging on page 169.         
 l Resize/Reshape - Alternate allows you to keep the angle between adjacent edges fixed when a corner edit handle is 

moved. Instead, adjacent corners move and adjacent edges lengthen or shorten.           

 l Alternate allows you to drag an end handle on an open polyline to change it from a line to an arc or vice versa.           
 l Alternate overrides the Lock Center  setting of arc-based objects.

 l Movement - Alternate allows you to move objects at Allowed Angles when Angle Snaps  are enabled, or 

orthogonal to any of its edges when they are not. See Angle Snaps on page 166.           
 l Rotation - Alternate snaps objects at Allowed Angles as they are rotated.          

You can temporarily enable the Alternate edit mode when another mode is active by pressing Alt or using the right mouse 
button while performing an edit               or drawing operation.    

MOVE

The Move mode allows you to move an object using edit handles that would otherwise be used for resizing, as well 
as with the Move handle. When this mode is active, the Move   icon displays near the mouse pointer.         

 l Drawing - Standard click and drag drawing behavior is enabled.           
 l Resize/Reshape - Move allows you to move the selected object when any edit handle is used.           
 l Movement - Move mode allows you to move objects at Allowed Angles.          
 l Rotation - In Move mode, objects snap at Allowed Angles as they are rotated.          

You can temporarily enable the Move edit mode when another mode is active by pressing Z or / while performing an edit or 
drawing operation.          
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RESIZE

The Resize edit behavior allows you to rescale an object. As you drag a corner edit handle of an object, you get an 
exactly scaled version of the original. For example, you can resize an object to 50% of its original size while 

maintaining the same proportions. When this mode is active, the Resize   icon displays near the mouse pointer.         

 l Drawing - Standard click and drag drawing behavior is enabled.            
 l Resize/Reshape - Resize allows you to keep the angle between adjacent edges fixed when a corner handle is moved.           

To proportionally resize an object, always drag a corner edit 
handle and not an edge handle.

 l Movement - Resize allows you to move an object orthogonal, or at a right angle, to any of its edges.          
 l Rotation - In Resize Mode, objects snap at Allowed Angles as they are rotated.           

You can temporarily enable the Resize edit mode when another mode is active by pressing X or the period key, or using the 
X2 button on a five-button mouse while performing an edit or drawing operation. See Using Input Devices on page 14.          

CONCENTRIC

The Concentric mode allows you to resize objects so that the distance moved by each edge is the same. For example, 
you can resize an irregularly shaped polyline so that each edge is exactly ten feet in from the original position, which 

is useful for creating site plans with setbacks. When this mode is active, the Concentric   icon displays near the mouse 
pointer.         

 l Drawing - Standard click and drag drawing behavior is enabled.            
 l Resize/Reshape - Concentric allows you to resize an irregularly-shaped polyline so that each edge is moved the same 

distance from its original location.           

 l Concentric mode also allows you to move opposite edges of an object so that each edge is moved the same distance 
from its original location.           
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 l Movement - Concentric mode allows you to move an object orthogonal, or at a right angle, to any of its edges.          
 l Rotation - In Concentric mode, objects snap at Allowed Angles as they are rotated.          

In some cases, the Concentric and Resize edit behaviors have the same result, such as when a circle is resized. Usually, 
though, the two behaviors are different because concentric resizing does not maintain the original ratio between an irregular 
polyline’s edges.           

In Concentric mode, objects resize in Concentric Jump increments specified in the Preferences dialog. See Behaviors 
Panel on page 120.           

When the Concentric Jump distance is set at 0", objects resize according to the Snap Unit specified in the Plan Defaults 
dialog. See Grid Snaps on page 167.           

To concentrically resize an object with no restrictions, set the 
Concentric Jump value on the Behaviors panel of the Preferences 

dialog to zero and turn off Grid Snaps.

You can temporarily enable the Concentric edit mode when another mode is active by pressing C or the command key, or 
using the X1 button on a five-button mouse while performing an edit or drawing operation. See Using Input Devices on 
page 14.          

FILLET

The Fillet mode allows you to add a fillet, or curve, at any corner of an object. Dragging a corner edit handle adjusts 
the fillet radius at that corner. When this mode is active, the Fillet   icon displays near the mouse pointer.         

 l Drawing - Standard click and drag drawing behavior is enabled.           
 l Resize/Reshape - Fillet allows you to create a fillet at by dragging a corner edit handle inward.           
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 l Movement - Move mode allows you to move objects at Allowed Angles.          
 l Rotation - In Move mode, objects snap at Allowed Angles as they are rotated.          

The Fillet edit behavior adjusts all the corners of a box at once. The radius of each corner is the same.          

Fillet does not have an effect on circles, ovals, ellipses or arc segments.          

You can temporarily enable the Fillet edit mode when another mode is active by pressing F while performing an edit or 
drawing operation.          

To produce fillets or chamfers of an exact radius, use the Fillet 
Lines or Chamfer Lines edit button. See Fillet Lines on page 260 

and Chamfer Lines on page 260.

CONNECT CAD SEGMENTS

Typically, when two CAD objects share the same properties and Endpoint Snaps are enabled, they can be snapped 
end-to-end to form a polyline. Connect CAD Segments controls whether CAD objects with the same properties can 

be snapped together to form polylines. It also controls whether spline segments can be snapped together. See Polylines on 
page 322 and Splines on page 330.         

Select Edit> Edit Behaviors> Connect CAD Segments to toggle this behavior on or off. You can also turn Connect CAD 
Segments on or off in the Preferences dialog. See CAD Panel on page 117.     

In addition to CAD objects, Connect CAD Segments also affects stairs, ramps, and road objects. See Stairs, Ramps, and 
Landings on page 752 and Roads, Driveways, and Sidewalks on page 1289.           

When Connect CAD Segments is disabled, CAD objects cannot connect to form polylines and the Connect CAD Segments 
 icon displays near the mouse pointer. See Pointer Icons on page 16.          

ROTATE/RESIZE ABOUT CURRENT POINT

Objects can be rotated or resized about either their own centers or the current CAD point. See The Current Point on 
page 303.         When this mode is active, the Rotate/Resize About Current Point   icon displays near the mouse 

pointer. See Rotate/Resize About on page 262.

 

Selecting Objects
“Select” refers to selecting an object for editing. An object must be selected before it can be edited. There are a number of 
ways that objects can be selected:

Groups of objects can also be selected simultaneously. See Selecting Multiple Objects on page 215.

In order for an object to be selected, it must be both unlocked and visible in the current view. See Layers on page 180. 

When an object is selected, it displays edit handles and a selection fill color. See Colors Panel on page 102.

In 3D views, a selected object will also display lines representing the selected edge or surface. The size of the edit handles 
does not change as you zoom in or out and is set in the Preferences dialog. See Edit Panel on page 119. To prevent them 
from stacking on one another, some edit handles may not display as you zoom away from the selected object. 

When an object is selected, its edit toolbar also displays, typically at the bottom of the Chief Architect program window just 
above the Status Bar.  See The Edit Toolbar on page 135.
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Information about the selected object or objects will also display in the Status Bar. See The Status Bar on page 25.

A selected object remains selected until another object is selected, a different tool is activated, the Esc key on the keyboard 
is pressed, or any two mouse buttons are pressed at the same time. 

FINDING OBJECTS

In order to select an object for editing, you may first need to find it. There are a variety of tools in the program designed to 
help you locate specific objects. These tools often open a new view window in which the object in question is either 
highlighted or selected.     

 l To find out where a line item in      a schedule or the Materials List is located in the model, select its row or any cell in 
its row and click the Find Object in Plan  edit button. See Find Object in Plan on page 703. 

 l To locate a string of text, select Edit> Find/Replace Text. See Find/Replace Text on page 524.     
 l To find objects that are similar to a selected object in the current view, click the Match Properties  edit button. 

See Matching Properties on page 286.     
 l In a      Wall Detail, Framing Overview or other 3D view in which wall framing can be seen, select a wall framing 

member and click the Find Wall  edit button to locate its owner wall in plan view. See Selecting Walls on page 

372.
 l In the Truss Detail, select a truss and click the Find Trusses  edit button to switch to a plan view in which the truss 

is selected. See Truss Details on page 916. 
 l In the Project Browser, right-click on a schedule or Layout Table and select Find in Project from the contextual 

menu. The view in which the schedule is located opens, if necessary, and the schedule or table is selected. See Project 
Browser on page 58.

Additional tools are available to help you find files referenced by your plans and layout files.     

 l Select Tools> Checks> Missing Files Check to identify and locate any missing referenced files. See Linked and 
Referenced Files on page 51.     

 l Select Tools> Layout> Referenced Plan Files to identify and locate any plans linked to the current layout file. See 
Managing Layout Links on page 1358.     

SELECT OBJECTS

With the exception of temporary CAD points, any object created using Chief Architect Premier's drawing tools can 
be selected using the Select Objects tool. Select Edit> Select Objects, click the toolbar button or press the Space bar 

on your keyboard to activate this tool, then click on an object or its label to select it. See Object Labels on page 711.

You can also select objects or open context sensitive menus using the right mouse button when any tool is active.

By default, you can select an object by clicking within 12 pixels of it. You can adjust this distance by changing the Snap 
Distance in the Preferences dialog. A lower value, for example, can be helpful for working with small objects but can also 
make it very difficult to select larger objects. See Snap Properties Panel on page 122.           

SELECTING SIMILAR OBJECTS

If a tool other than Select Objects  is active, you can only select objects of that type using the left mouse button. For 

example, if the Straight Exterior Wall  tool is active, you can only select walls using the left mouse button. 

This can be useful for selecting an object when many objects of a different type occupy the same space in plan view. 
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Objects can be selected using the right mouse button, regardless of which tool is active. 

RIGHT-CLICKING

Regardless of which tool is active, you can select an object by right-clicking on it once. When you right-click to select an 
object a contextual menu also appears, displaying the object’s edit tools. You can turn contextual menus on or off in the 
Preferences dialog. See Contextual Menus on page 19.

If a drawing tool is active and you right-click to select an object, you can unselect it by left-clicking in an empty space in 
the drawing area. Although a drawing tool is active, it is not used. If you then left-click a second time, the active tool will be 
used.   

SELECTED EDGE

When you click on a polyline- or box-based object, the edge that you click nearest becomes the selected edge and displays 
an edit handle larger and of a different color than those on other edges. The handle on this edge may also display at the 
point where you clicked to select it. You can specify the Selected Edge Handle Fill color in the Preferences dialog. See 
Colors Panel on page 102. 

This edge can be edited on the SELECTED LINE or SELECTED ARC panel of the object’s specification dialog, as well as using 
a variety of edit toolbar buttons. It can also be moved using dimensions. See Moving Objects Using Dimensions on page 
491, Line Panel on page 309 and Arc Panel on page 318.

The Start and End points of a CAD-based object’s selected edge or of a wall can be indicated by an S and an E when the 
object is selected. These Start and End indicators can be helpful when editing the selected edge in the object’s specification 
dialog, and their display can be turned on and off in the Preferences dialog. See Edit Panel on page 119.           

DISCONNECT EDGES

Polyline-based objects are composed of lines and arcs that are connected end to end. The individual edges of open 
and closed polylines can be selected and edited independently of the object’s other edges when Disconnect Edges is 

in use. Select CAD> Lines> Disconnect Edges to enable this ability.         

Disconnect Edges also affects terrain paths and molding polylines, but does not affect Walkthrough Paths, Connect 
Electrical or Sprinkler splines, or closed polyline-based objects such as slabs and roof planes.         

To use Disconnect Edges
 1.  Select CAD> Lines> Disconnect Edges .         

 2.  Click on an individual edge of an eligible polyline-based object to select it.         
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 3.  Notice that it is no longer connected to the rest of the polyline.         

 4.  The individual segment can now be edited entirely independent of its neighbors.         

 5.  Continue clicking on polyline edges to disconnect them from their polyline.        

 6.  When you are finished, click the Select Objects  button or activate another tool.         

 7.  To connect the segment to the polyline again, move the end handles so that they snap to the ends of adjacent 
segments.         

 8.  When Disconnect Edges  is used, only edges that you click on are actually affected by it. Any polylines that you 

do not click on will remain intact.          

You can also separate the selected edge of an open or closed polyline from the rest of the polyline by clicking the 
Disconnect Selected Edge  edit button. See Selected Edge on page 214.         

SELECTED SIDE

Most architectural objects can be selected in 3D views. When selected, the outline of their bounding box displays, and edit 
handles are located on the side where you clicked to select the object. The edit handles can be used to move, resize, or rotate 
the object in different directions, depending on which side is selected. Depending on which side is selected, the available 
edit handles may vary, as well. 

Groups of objects can be selected by holding down either the Shift or Ctrl key when the Select Objects  tool is active 

and then dragging a marquee around the objects to be selected. 

SELECT NEXT OBJECT

If there is more than one object in a particular space, it may be difficult to select the desired object. When a nearby 
object is selected, click the Select Next Object edit button or press the Tab key until the desired object becomes 

selected. This function cannot be applied to groups of selected objects.

 

Selecting Multiple Objects
Multiple objects can be selected and edited in groups. The options available for editing them will vary depending on the 
type or types of objects selected. See Editing Multiple Objects on page 244.
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MARQUEE SELECT

Groups of objects can be selected by holding down either the Shift or Ctrl key when the Select Objects  tool is active 

and then dragging a marquee around the objects to be selected. 

When using the marquee-select method, both CAD and architectural objects included in the marquee are selected. To 
remove an object from the selection set, hold down the Ctrl key and click on it.

If an object is selected and a selection marquee is drawn around it using the Ctrl key, that object becomes deselected.  If the 
Shift key is used instead, the original object  remains selected and the other objects are added to the selection set.

The Shift key can be used to marquee-select objects of a similar type when the drawing tool used to create those objects is 
active. 

To marquee-select objects by type
 1.  Select a drawing tool used to create the type of object you wish to select: for example, the Hinged Door  tool. 

 2.  Hold down the Shift key, then click and drag a rectangular selection marquee in the drawing area.

 3.  When you release the mouse button, objects of the selected drawing tool’s type - here, door objects - located in the 
marquee will be selected.

You can specify whether objects must be totally contained in or intersected by the marquee, or whether an object’s center 
point must be contained in the marquee, in the Preferences dialog or using the Selection Mode  buttons, which can be 

added to your toolbars. See Edit Panel on page 119.         

To make marquee selection easier, you can turn off the display 
of objects you do not want to include in your selection set. See 

Layers on page 180.

MARQUEE SELECT SIMILAR

The Marquee Select Similar edit tool lets you group-select objects in the current plan view or CAD Detail that are 
similar to the selected object(s). 

To use Marquee Select Similar
 1.  In plan view, select one or more objects, then click the Marquee Select Similar  edit button.

 2.  The Restrictive Selection  toggle controls whether objects are selected by similar type(s) only, or if additional 

attributes are taken into account. 

 l Restrictive Selection  is disabled by default, so objects of the same type will be selected.

 l Click the Restrictive Selection  edit button to toggle it on and select only objects with additional attributes like 

materials or layer in common. 

 3.  Click and drag a rectangular selection marquee in the drawing area to select similar objects within its area.

 4.  Alternatively, click the Select All Similar  edit button to select all similar objects in the current view.

 5.  The Marquee Select Similar  tool is not available for all object types in all views. For example, it is not 

available for wall framing in plan view, although it is in Wall Detail views.         
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SHIFT AND CTRL SELECT

You can select a group of objects by adding them to the selection set one by one. Select an object, hold down either the 
Shift or Ctrl key, and click additional objects to select them. 

More than one type of object can be selected using this method, but the ability to edit the group-selected items is limited to 
attributes that all selected objects have in common.

To remove an object from a selection set, click on it once more with the Ctrl key pressed.

The Shift and Ctrl keys can be used to select multiple items in a variety of contexts, such as: the and Project Browsers, lists 
in dialog boxes, and files to be imported. They can also be used to marquee-select objects in plan view. See Marquee Select 
on page 216, above.   

SELECT ALL

Select Edit> Select All to select all objects drawn on the current floor, in the current cross section/elevation view or CAD 
Detail window, or on the current layout page.          

EDIT AREA

The Edit Area Tools allow you to define an area of your plan and select the objects within that area for editing. See 
Edit Area Tools on page 273.   

USING A FENCE

The Fence Select edit tool allows you to group-select multiple CAD and CAD-based objects in contact with the 
selected CAD line, arc, polyline or spline.         

Using a Fence to make a group-selection can be helpful in a number of situations, for example:           

 l When many CAD objects must be selected, particularly when they occupy the same area.         
 l When a selection marquee would be the wrong shape or include too many objects.         
 l When a selection group needs to be selected more than once.         

The Fence Select  edit tool cannot be used to select architectural objects - only CAD and CAD-based objects. See 

Architectural vs CAD Objects on page 162.          

Fences are often used with the Trim Objects  and Extend Objects  edit tools. See Trim and Extend on page 276.           

To Fence Select a group of objects
 1.  Draw a CAD line, arc, open polyline, closed polyline or spline that crosses or touches all the objects you wish to 

group-select.         

 2.  Click the Fence Select  edit button.         

 3.  The originally selected object serves as a fence to select the objects it touches, while becoming deselected itself.         

 4.  You can hold either the Shift or Ctrl key and click objects to add or remove them from the selection set.         

You can keep all fences on their own custom layer and turn off 
their display when not needed. See Layers on page 180.
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MATCH PROPERTIES

Rooms, cabinets, windows and doors on the current floor can be selected based on a set of attributes that you specify 
using the Match Properties edit tool. See Match Properties on page 286.         

 

Editing Line-Based Objects
Objects are considered line-based when they can be edited similar to CAD lines using their edit handles.         

CAD lines, framing members, straight walls and railings, straight stairs, and straight roads are examples of line-based 
objects. 

Most line-based objects can be connected to the ends of other like objects to form polylines or polyline-based objects 
provided that they are on the same layer and have identical attributes such as line color and arrow specifications.  See 
Editing Open Polyline-Based Objects on page 226 and Editing Closed Polyline-Based Objects on page 230.

Some objects, notably walls, have line-based editing behavior only when selected on certain surfaces. See Editing Walls on 
page 372.

Wall openings such as doors and windows have line-based editing behavior in  plan view only but cannot be rotated, 
reversed or converted to an arc. See Editing Doors on page 558 and Editing Windows on page 597.

Other objects, such as stairs, foundation walls with footings, and roads, have additional edit handles that allow you to 
concentrically adjust the object’s width. 

USING THE EDIT HANDLES

When selected, a typical line-based object displays six edit handles: a Move handle, two Extend/Change Angle handles, two 
Same Line Type handles, and a Rotate handle.

Any action performed using the edit handles can be canceled by pressing the Esc key or any two mouse buttons at the same 
time.

The behavior of the edit handles may depend on the currently 
active Edit Behavior. See Defaults, Preferences, and Edit 

Behaviors on page 208.
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A. Move
 l Click and drag the Move handle to move the object according to the currently active Edit Behavior . See Defaults, 

Preferences, and Edit Behaviors on page 208.              
 l Movement may be limited or stopped by other objects or Snap Behaviors. Move restrictions can be overridden by 

holding down the Ctrl key while dragging. See Unrestricted Movement on page 246.

B. Rotate
 l The Rotate handle is used to rotate the object, either about its center or about the current CAD point. See Rotating 

Objects on page 261.

C. Extend/Change Angle
 l Drag a square end handle parallel to the selected line to change its length. 
 l Drag a square end handle at an angle to the selected line to change its angle. When Angle Snaps  are on, the line 

snaps to Allowed Angles. See Angle Snaps on page 166.
 l Right-click and drag it to change the adjacent line into an arc, or vice versa. See Alternate on page 209.              

D. Same Line Type
 l Drag a diamond-shaped end handle in any direction to draw a new line that shares the original’s color, weight, line 

style, and layer. See Same Line Type Edit Handles on page 308.             

Adjust Width
Some line-based objects, such as stairs and roads, have additional handles that allow the width of the object to be adjusted.

Adjust width

 l Click and drag a small, round Expand handle to increase or decrease the object’s width. By default, objects are resized 
in 1" increments. This Snap Unit is defined in the Plan Defaults dialog. See General Plan Defaults Dialog on page 96.

USING DIMENSIONS

Dimensions can be used to position line-based objects relative to other objects. See Moving Objects Using 
Dimensions on page 491.         

Dimensions cannot, however, be used to adjust the length of line-based objects, or the width of line-based objects such as 
stairs.         

USING EXTENSION LINE SNAPS

Extension line snaps can be useful when editing line-based objects. See Extension Snaps on page 165.           

USING THE SPECIFICATION DIALOG

Line-based objects can be edited using their specification dialogs. See Line Specification Dialog on page 309.
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USING THE EDIT TOOLBAR

A selected line-based object can be edited in a variety of ways using the buttons on the Edit Toolbar. 

The following toolbar buttons may display on the Edit Toolbar for a selected line-based object: 

  Select Next Object selects nearby objects instead of the selected object. See Selecting Objects on page 212.

  Open Object opens the specification dialog for the selected object(s). See Specification Dialogs on page 21.

  Copy/Paste copies the selected object(s) to the system clipboard so they can be pasted elsewhere. See Copying 
and Pasting Objects on page 171.

  Delete deletes the selected object(s). See Deleting Objects on page 289.

  Transform/Replicate Object copies, moves, rotates, resizes, or reflects the selected object(s). See 
Transform/Replicate Object Dialog on page 269.             

  Multiple Copy make a series of copies at set intervals. See Multiple Copy on page 176.             

  Make Parallel/Perpendicular makes the selected object(s) parallel or perpendicular to a straight edge. See Make 
Parallel/Perpendicular on page 252.             

  Point to Point Move accurately moves the selected object(s). See Point to Point Move on page 247.              

  Center Object centers an object along a wall within a room or relative to a cabinet fixture. See Center Object on 
page 253.             

  Reflect About Object reflects the selected object(s) about another object. See Reflecting Objects on page 264.              

  View Drawing Group Edit Tools modifies the selected object’s place in the drawing order. See Drawing Group 
Edit Tools on page 195.             

  Add Break adds a new corner or pivot point to the selected object. See Add Break on page 257.             

  Complete Break breaks the selected object into two separate objects. See Add Break on page 257.             

  Reverse Direction reverses the direction of the selected object(s). See Reverse Direction on page 264.             

  Convert Polyline converts the object into a special polyline-based object. See Convert Polyline on page 265.             

  Revision Cloud(s) Around Objects creates a revision cloud around each of the selected object(s). See Revision 
Clouds on page 328.             

  Change Line/Arc changes a line-based object to an arc, or vice versa. See Change Line/Arc on page 259.             

  Fence Select uses the selected object(s) as a selection fence. See Using a Fence on page 217.             

  Object Layer Properties accesses and edits layer information about the selected object. See Object Layer 
Properties on page 192.             

  Intersect/Join Two Lines joins two non-parallel lines or arcs. See Intersect/Join Two Lines on page 259.             

  Fillet Lines create an additional arc connecting two non-parallel lines or arcs. See Fillet Lines on page 260.             
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  Chamfer Lines chamfers the corner between adjacent edges. See Chamfer Lines on page 260.             

  Extend Object(s) lengthens other object(s) until they intersect the selected object. See Trim and Extend on page 
276.

Not available for Sun Angles or North Pointers.              
  Trim Object(s) shortens the length of object(s) intersected by the selected object. See Trim and Extend on page 

276.
Not available for Sun Angles or North Pointers.             

  Align/Distribute Objects specifies how the selected objects are distributed. See Align/Distribute Objects on 
page 249.

Only available when multiple objects are selected.             
  Align/Distribute Along Line aligns the selected object(s) relative to another line. See Align/Distribute Along 

Line on page 250.              
  Set as Default allows you to apply the settings in a selected object’s specification dialog to the defaults for that 
type of object. Available for Construction Lines and various line-based architectural objects but not standard 

CAD objects. See Set as Default on page 79.    

 

Editing Arc-Based Objects
Objects are considered arc-based when they can be edited similar to CAD arcs using their edit handles.           

CAD arcs, curved walls and railings, curved stairs, and curved roads are examples of arc-based objects.

Most arc-based objects can be connected to other like objects to form polylines or polyline-based objects provided that they 
are on the same layer and have identical attributes such as line color and arrow specifications. See Editing Open Polyline-
Based Objects on page 226 and Editing Closed Polyline-Based Objects on page 230.

Some objects, notably curved walls, have arc-based editing behavior only when selected on certain surfaces. See Editing 
Walls on page 372.

Other objects, such as curved stairs and roads, have additional edit handles that allow you to concentrically adjust the 
object’s width. 

The currently active Arc Creation Mode  determines how an arc-based object is drawn. Once an arc is drawn, the active 

Arc Creation Mode does not affect it. See Drawing Arcs - Arc Creation Modes on page 313.          

USING THE EDIT HANDLES

When selected, a typical arc-based object displays seven edit handles. 

Any action performed using the edit handles can be canceled by pressing the Esc key or any two mouse buttons at the same 
time.
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The behavior of the edit handles may depend on the currently 
active Edit Behavior. See Defaults, Preferences, and Edit 

Behaviors on page 208.

A. Resize (changes radius)
B. Reshape (moves center)
C. Move Chord
D. Extend (along arc or chord)
E. Same Line Type
F. Move Arc Center
G. Rotate

Move
 l Two Move edit handles allow the arc to be relocated without changing its shape. One is located at the center of the 

chord and the other, at the arc center. 
 l If you would like to snap one of these center points to another point, use that handle when moving the arc. See 

Aligning Arc Centers on page 255.          
 l Click and drag the Move handle to move the object according to the currently active Edit Behavior . See Defaults, 

Preferences, and Edit Behaviors on page 208.           
 l Movement may be limited or stopped by other objects or Snap Behaviors. Move restrictions can be overridden by 

holding down the Ctrl key while dragging. See Unrestricted Movement on page 246.

Dragging the Move edit handle downward

Rotate
 l The Rotate handle is used to rotate the arc, either about its center or about the current CAD point. See Rotating 

Objects on page 261.

Extend
 l The end edit handles expand or contract the arc when moved along the arc radius or chord. 
 l If you follow the path of the arc, the end edit handles allow you to adjust the arc length.
 l The angle formed by the center point of the arc and its two endpoints is referred to as the Included Angle. If Angle 

Snaps are on, the Included Angle of the arc, as measured in degrees, can be rotated at Allowed Angles. See Angle 
Snaps on page 166.

 l Right-click and drag it to change the adjacent arc into a line, or vice versa. See Alternate on page 209.           
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Dragging an End edit handle to lengthen an 
arc

Resize
 l Drag the small, round Resize edit handle to change the radius and included angle of the arc while maintaining its 

center. 

Dragging the Resize edit handle toward the 
center

Reshape
 l Drag the small triangular Reshape handle to change the length and location of the center without moving the 

endpoints.             

Dragging the Reshape edit handle away 
from the center

 l If the object has a locked center, the Reshape edit handle does not display. See Lock Center on page 225.          

Same Line Type
 l Drag a diamond-shaped end handle in any direction to draw a new line that shares the arc’s color, weight, line style, 

and layer. See Same Line Type Edit Handles on page 308.          

Adjust Width
Some arc-based objects, such as stairs, have additional handles that allow the width of the object to be adjusted. 

Adjust Width edit handles
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 l Click and drag a small, round edit handle to increase or decrease the object’s width. By default, objects are resized 
according to the Snap Unit defined in the Plan Defaults dialog. See General Plan Defaults Dialog on page 96.

USING DIMENSIONS

Dimensions can be used to position arc-based objects. Dimension lines typically locate tangent extension lines and 
any extension lines that may be parallel to those lines rather than the arc itself. See Moving Objects Using 

Dimensions on page 491.         

USING EXTENSION LINE SNAPS

Extension line snaps can be useful when editing arc-based objects. See Extension Snaps on page 165.           

USING THE SPECIFICATION DIALOG

Arc-based objects can be edited using their specification dialogs. See Arc Specification Dialog on page 318.

USING THE EDIT TOOLBAR

A selected arc-based object can be edited in a variety of ways using the buttons on the Edit Toolbar. 

The following toolbar buttons may display on the Edit Toolbar for a selected arc-based object:

  Select Next Object selects nearby objects instead of the selected object. See Selecting Objects on page 212.

  Open Object opens the specification dialog for the selected object(s). See Specification Dialogs on page 21.

  Copy/Paste copies the selected object(s) to the system clipboard so they can be pasted elsewhere. See Copying 
and Pasting Objects on page 171.

  Delete deletes the selected object(s). See Deleting Objects on page 289.

  Transform/Replicate Object copies, moves, rotates, resizes, or reflects the selected object(s). See 
Transform/Replicate Object Dialog on page 269.          

  Multiple Copy makes a series of copies at set intervals. See Multiple Copy on page 176.          

  Point to Point Move accurately moves the selected object(s). See Point to Point Move on page 247.           

  Center Object centers an object along a wall within a room or relative to a cabinet fixture. See Center Object on 
page 253.         

  Reflect About Object reflects the selected object(s) about another object. See Reflecting Objects on page 264.           

  View Drawing Group Edit Tools modifies the selected object’s place in the drawing order. See Drawing Group 
Edit Tools on page 195.         

  Add Break adds a new corner or pivot point to the selected object. See Add Break on page 257.         

  Complete Break breaks the selected object into two separate objects. See Add Break on page 257.         

  Reverse Direction reverses the direction of the selected object(s). See Reverse Direction on page 264.          
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  Convert Polyline converts the object into a special polyline-based object. See Convert Polyline on page 265.          

  Revision Cloud(s) Around Objects creates a revision cloud around each of the selected object(s). See Revision 
Clouds on page 328.          

  Change Line/Arc changes an arc-based object to a line, or vice versa. See Change Line/Arc on page 259.         

  Convert Curve to Polyline converts the selected arc into a polyline. See Convert Curve to Polyline on page 261.          

  Lock Center locks the selected arc-based object’s center. See Lock Center on page 225.          

  Make Arc Tangent adjusts the arc and attached line(s) so they transition smoothly. See Make Arc Tangent on 
page 254. Only available when a selected arc is attached on one or both ends to another line or arc.          

  Fence Select uses the selected object(s) as a selection fence. See Using a Fence on page 217.          

  Object Layer Properties accesses layer information about the selected object. See Object Layer Properties on 
page 192.          

  Intersect/Join Two Lines joins two non-parallel  lines or arcs. See Intersect/Join Two Lines on page 259.          

  Fillet Lines creates an additional arc connecting two lines. See Fillet Lines on page 260.          

  Chamfer Lines creates an additional edge connecting two lines. See Chamfer Lines on page 260.          

  Extend Object(s) lengthens other object(s) until they intersect the selected object. See Trim and Extend on page 
276.          

  Trim Object(s) shortens the length of object(s) intersected by the selected object. See Trim and Extend on page 
276.          

  Align/Distribute Objects specifies how the selected objects are distributed. See Align/Distribute Objects on 
page 249. Only available when multiple objects are selected.          

  Align/Distribute Along Line aligns the selected object(s) relative to a line-based object. See Align/Distribute 
Along Line on page 250.           

ARC CENTERS AND ENDS

When working with arc-based objects or circles, it can be helpful to see their center points. Similarly, when snapping 
arcs together to form a polyline, seeing their endpoints can be helpful. Select View> Arc Centers and Ends to toggle 

the display of both on the current floor. You can also turn on their display in the CAD Defaults dialog. See CAD Defaults 
Dialog on page 295.         

Arc-based objects can be aligned using their center points. See Aligning Arc Centers on page 255.           

LOCK CENTER

Click the Lock Center edit button to lock or unlock the selected arc-based object’s center. When an arc’s center is 
locked, it cannot be moved except by using one of its Move edit handles or when the Alternate  edit behavior is 

enabled.          

An arc-based object with a locked center lengthens and shortens along its curve when it is resized. When this is not possible, 
its radius changes. In either case, its center remains locked in the same place.           
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Resizing with center unlocked vs with center 
locked

Locked-center arcs do not display a Reshape edit handle when selected. See Using the Edit Handles on page 221.          

When it is part of a polyline, a locked-center arc resizes along its arc rather than its chord when an adjacent line or arc is 
moved. Thus, the radius remains constant for an unlocked center arc, while the center does not change for a locked-center 
arc.           

 

Editing Open Polyline-Based Objects
Open polyline-based objects are composed of individual line- and arc-based objects that are connected at their end points 
but do not form an enclosed area. See Polylines on page 322. 

Objects are considered open polyline-based when they can be edited similar to open CAD polylines using their edit handles.          

Open CAD polylines, connected walls, stairs, and connected roads are examples of open polyline-based objects. 

For information about editing closed polyline-based objects, see Editing Closed Polyline-Based Objects on page 230.

Other objects, such as connected stair and road segments, have additional edit handles that allow you to concentrically 
adjust the width of all segments of the object. 

If Connect CAD Segments is disabled, clicking on a CAD 
polyline edge selects the individual edge rather than the entire 

polyline. See Disconnect Edges on page 214.    

USING THE EDIT HANDLES

A polyline can be composed of many segments. See Polylines on page 322. 

When selected, an open polyline-based object displays a Move handle, a Rotate handle, a Reshape handle at the intersection 
of each segment, and an Extend handle at each end.
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Each straight, line-based segment also has a Move edit handle along its length. 

Each curved, arc-based segment has its own Move handle at the center of its chord, a Resize handle and, if it has an 
unlocked center, a Reshape handle. See Editing Arc-Based Objects on page 221.

When a polyline is selected, the edge that you click nearest is called the selected edge, and certain operations affect only this 
edge. The Move handle of the selected edge is larger than that of other edges. It displays along the length of a line segment, 
or at the center of the chord on an arc segment. See Selected Edge on page 214.

Any action performed using the edit handles can be canceled by pressing the Esc key or any two mouse buttons at the same 
time.

The behavior of the edit handles  depends on the currently active 
Edit Behavior. See Defaults, Preferences, and Edit Behaviors on 

page 208.    

A. Move
 l Click and drag the Move handle to move the object according to the currently active Edit Behavior . 

 l Movement may be limited or stopped by other objects or Snap Behaviors. Move restrictions can be overridden by 
holding down the Ctrl key while dragging. See Unrestricted Movement on page 246.

B. Rotate
 l The Rotate handle is used to rotate the object, either about its center or about the current CAD point. Its position 

varies depending on which edge is currently selected. See Rotating Objects on page 261.

C. Extend
 l Click and drag an Extend handle to lengthen or shorten the unconnected end of the selected line or arc segment, or to 

change the radius of the selected arc. See Editing Arc-Based Objects on page 221.
 l Right-click and drag it to change the adjacent line into an arc, or vice versa. See Alternate on page 209.           

D. Reshape
 l Click and drag a Reshape edit handle to change the angle and/or length of the segments on either side of it, or the size 

of the object, depending on the currently active Edit Behavior . 

E. Move Line Segment
 l The Move Line Segment edit handle is found on straight segments of open polylines and moves the straight section 

according to the currently active Edit Behavior . Adjacent segments may extend or contract in their original 

directions to maintain their connections. 
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F. Move Arc
 l Click and drag the Move Arc edit handle to change the radius and/or chord length or position, depending on the 

currently active Edit Behavior  and whether the arc has a locked center. Adjacent segments may extend, contract, 

or change angle to maintain their connections. 

G. Resize Arc
 l Click and drag the Resize Arc edit handle to change the radius, chord length and chord position of the arc segment, 

depending on the currently active Edit Behavior  and whether the arc has a locked center. Adjacent segments may 

extend, contract, or change angle to maintain their connections. 

H. Reshape Arc
 l Click and drag the Reshape Arc edit handle to change the radius of the arc without moving its end points. Only 

available if the arc has an unlocked center.

I. Same Line Type
 l Drag a diamond-shaped end handle in any direction to draw a new line that shares the original polyline’s color, 

weight, line style, and layer. See Same Line Type Edit Handles on page 308.          

J. Adjust Width
Some open polyline-based objects, such as stairs and roads, have additional handles that allow the width of the object to be 
adjusted. 

 l Click and drag a small, round edit handle to increase or decrease the object’s width. By default, objects are resized in 
1" increments. This Snap Unit is defined in the Plan Defaults dialog. See General Plan Defaults Dialog on page 96.

USING DIMENSIONS

Dimensions can be used to move or reshape polyline-based objects. See Moving Objects Using Dimensions on page 
491.         

USING EXTENSION LINE SNAPS

Extension line snaps, especially tangent snaps, can be useful when editing polyline vertices. See Extension Snaps on page 
165.          

USING THE SPECIFICATION DIALOG

Open polyline-based objects can be edited using their specification dialogs. See Polyline Specification Dialog on 
page 323.

USING THE EDIT TOOLBAR

A selected open polyline-based object can be edited in a variety of ways using the buttons on the Edit Toolbar. 

The following toolbar buttons may display on the Edit Toolbar for a selected open polyline-based object:

  Select Next Object selects nearby objects instead of the selected object. See Selecting Objects on page 212.

  Open Object opens the specification dialog for the selected object(s). See Specification Dialogs on page 21.

  Copy/Paste copies the selected object(s) to the system clipboard so they can be pasted elsewhere. See Copying 
and Pasting Objects on page 171.
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  Delete deletes the selected object(s). See Deleting Objects on page 289.

  Disconnect Selected Edge disconnects the selected edge of the polyline, turning it into a separate object. See 
Disconnect Edges on page 214.           

  Transform/Replicate Object copies, moves, rotates, resizes, or reflects the selected object(s). See 
Transform/Replicate Object Dialog on page 269.          

  Multiple Copy makes a series of copies at set intervals. See Multiple Copy on page 176.          

  Make Parallel/Perpendicular makes the selected straight edge parallel or perpendicular to another straight edge. 
See Make Parallel/Perpendicular on page 252. Not available when the selected edge is an arc.         

  Point to Point Move accurately moves the selected object(s). See Point to Point Move on page 247.           

  Add to Library adds the selected object(s) to the library. See Add to Library on page 973.          

  Center Object centers an object along a wall within a room or relative to a cabinet fixture. See Center Object on 
page 253.         

  Reflect About Object reflects the selected object(s) about another object. See Reflecting Objects on page 264.           

  View Drawing Group Edit Tools modifies the selected object’s place in the drawing order. See Drawing Group 
Edit Tools on page 195.         

  Add Break adds a new corner or pivot point to the selected object. See Add Break on page 257.         

  Complete Break breaks the selected object into two separate objects. See Add Break on page 257.          

  Reverse Direction reverses the direction of the selected object(s). See Reverse Direction on page 264.          

  Close Polyline converts the selected open polyline into a closed polyline. See Close Polyline on page 230.           

  Convert to Spline changes the selected polyline into a spline. See Splines on page 330.            

  Convert Polyline converts the object into a special polyline-based object. See Convert Polyline on page 265.          

  Revision Cloud(s) Around Objects creates a revision cloud around each of the selected object(s). See Revision 
Clouds on page 328.          

  Change Line/Arc changes a line-based polyline edge to an arc, or vice versa. See Change Line/Arc on page 259.
         

  Convert Curve to Polyline converts the selected arc into a polyline. See Convert Curve to Polyline on page 261. 
Only available when the selected edge is an arc.           

  Lock Center locks the center of the selected curved edge. See Lock Center on page 225. Only available when 
the selected edge is an arc.           

  Make Arc Tangent adjusts the selected curved edge and attached edge(s) so they form a smooth shape. See 
Make Arc Tangent on page 254. Only available when the selected edge is an arc attached on one or both ends to 

another line or arc.           
  Fence Select uses the selected object(s) as a selection fence. See Using a Fence on page 217.          

  Object Layer Properties accesses layer information about the selected object. See Object Layer Properties on 
page 192.          
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  Intersect/Join Two Lines joins two a non-parallel lines or arcs. See Intersect/Join Two Lines on page 259.          

  Fillet Lines creates an arc connecting two non-parallel lines. See Fillet Lines on page 260. Cannot be used if the 
adjacent edge is an arc.           

  Chamfer Lines creates a line connecting two non-parallel lines. See Chamfer Lines on page 260.          

  Extend Object(s) lengthens other object(s) until they intersect the selected object. See Trim and Extend on page 
276.          

  Trim Object(s) shortens the length of object(s) intersected by the selected object. See Trim and Extend on page 
276.          

  Align/Distribute Objects specifies how the selected objects are distributed. See Align/Distribute Objects on 
page 249. Only available when multiple objects are selected.          

  Align/Distribute Along Line  specifies how the selected objects are distributed relative to a line. See 
Align/Distribute Along Line on page 250.           

CLOSE POLYLINE

An open polyline-based object can be converted into a closed polyline using the Close Polyline edit tool. This tool 
adds an edge to the open polyline, connecting its two ends and closing the gap between them.

Close Polyline is not available when Connect CAD Segments  is enabled. See Disconnect Edges on page 214.         

 

Editing Closed Polyline-Based Objects
Closed polyline-based objects are composed of individual line- and arc-based objects joined end-to-end and forming an 
enclosed area. See Polylines on page 322. 

Objects are considered closed polyline-based when they can be edited similar to closed CAD polylines using their edit 
handles.          

Closed CAD polylines, slabs and roof planes are examples of closed polyline-based objects.          

Some objects, notably walls, have closed polyline-based editing behavior only when they are selected on certain surfaces in 
3D views. See Editing Walls on page 372.          

For information about editing open polyline-based objects, see Editing Open Polyline-Based Objects on page 226.

If Connect CAD Segments is disabled, clicking on a polyline 
edge selects the individual edge rather than the entire polyline. 

See Disconnect Edges on page 214.    
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USING THE EDIT HANDLES

A polyline can be composed of many segments. See Polylines on page 322. 

When selected, a closed polyline-based object displays a Move handle, a Rotate handle, and a Reshape handle at the 
intersection of each segment. 

Each straight, line-based segment has a Move edit handle along its length. 

Each curved, arc-based segment has its own Move handle at the center of its chord, a Resize handle and, if it has an 
unlocked center, a Reshape handle. See Editing Arc-Based Objects on page 221.

When a polyline is selected, the edge that you click nearest is called the selected edge, and certain operations affect only this 
edge. The Move handle of the selected edge is larger than that of other edges. It displays along the length of a line segment, 
or at the center of the chord on an arc segment. See Selected Edge on page 214.

Any action performed using the edit handles can be canceled by pressing the Esc key or any two mouse buttons at the same 
time.

The behavior of the edit handles may depend on the currently 
active Edit Behavior. See Defaults, Preferences, and Edit 

Behaviors on page 208.

A. Move
 l Click and drag the Move handle to move the object according to the currently active Edit Behavior . 

 l Movement may be limited or stopped by other objects or Snap Behaviors. Move restrictions can be overridden by 
holding down the Ctrl key while dragging. See Unrestricted Movement on page 246.

B. Rotate
 l The Rotate handle is used to rotate the object, either about its center or about the current CAD point. Its position 

varies depending on which edge is currently selected. See Rotating Objects on page 261.

C. Reshape
 l Click and drag a Reshape edit handle to change the angle and/or length of the segments on either side of it, or the size 

of the object, depending on the currently active Edit Behavior . 

D. Move Line Segment
 l The Move Line Segment edit handle is found on straight segments of closed polylines and moves the straight section 

according to the currently active Edit Behavior . Adjacent segments may extend or contract in their original 

directions to maintain their connections. 
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E. Move Arc
 l Click and drag the Move Arc edit handle to change the radius and/or chord length or position, depending on the 

currently active Edit Behavior  and whether the arc has a locked center. Adjacent segments may extend, contract, 

or change angle to maintain their connections. 

F. Resize Arc
 l Click and drag the Resize Arc edit handle to change the radius, chord length and chord position of the arc segment, 

depending on the currently active Edit Behavior  and whether the arc has a locked center. Adjacent segments may 

extend, contract, or change angle to maintain their connections. 

G. Reshape Arc
 l Click and drag the Reshape Arc edit handle to change the radius of the arc without moving its end points. Only 

available if the arc has an unlocked center.

Other    objects, such as connected road segments, have additional edit handles that allow you to concentrically adjust the 
width of all segments of the object.    

USING DIMENSIONS

             Dimensions can be used to move or reshape closed polyline-based objects. See Moving Objects Using Dimensions 
on page 491.         

USING EXTENSION LINE SNAPS

Extension line snaps, especially tangent snaps, can be useful when editing polyline vertices. See Extension Snaps on page 
165.          

USING THE SPECIFICATION DIALOG

 Closed polyline-based objects can be edited using their specification dialogs. See Polyline Specification Dialog on 
page 323.

USING THE EDIT TOOLBAR

A selected closed polyline-based object can be edited in a variety of ways using the buttons on the Edit Toolbar. 

The following toolbar buttons may display on the Edit Toolbar for a selected closed polyline-based object:

  Select Next Object                 selects nearby objects instead of the selected object. See Selecting Objects on page 212.

  Open Object opens the specification dialog for the selected object(s). See Specification Dialogs on page 21.

  Copy/Paste copies the selected object(s) to the system clipboard so they can be pasted elsewhere. See Copying 
and Pasting Objects on page 171.

  Delete                 deletes the selected object(s). See Deleting Objects on page 289.

  Disconnect Selected Edge disconnects the selected edge of the polyline, turning it into a separate object. See 
Disconnect Edges on page 214.           

  Transform/Replicate Object                  copies, moves, rotates, resizes, or reflects the selected object(s). See 
Transform/Replicate Object Dialog on page 269.          
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  Multiple Copy                 makes a series of copies at set intervals. See Multiple Copy on page 176.          

  Make Parallel/Perpendicular                 makes the selected straight edge parallel or perpendicular to another straight edge 
by either rotating the selected edge or the entire polyline. See Make Parallel/Perpendicular on page 252. Not 

available when the selected edge is an arc.         
  Point to Point Move                 accurately moves the selected object(s). See Point to Point Move on page 247.           

  Add to Library adds the selected object(s) to the library. See Add to Library on page 973.          

  Center Object centers an object along a wall within a room or relative to a cabinet fixture. See Center Object on 
page 253.         

  Reflect About Object  reflect the selected object(s) about another object. See Reflecting Objects on page 264.           

  View Drawing Group Edit Tools                 modifies the selected object’s place in the drawing order. See Drawing Group 
Edit Tools on page 195.         

  Add Break                 adds a new corner or pivot point to the selected object. See Add Break on page 257.         

  Complete Break                 breaks an edge of the selected object into two separate objects. See Add Break on page 257.         

  Reverse Direction                 reverses the direction of the selected object(s). See Reverse Direction on page 264.          

  Convert to Spline                 changes the selected polyline into a spline. See Splines on page 330.          

  Union joins two or more objects. See Union, Intersection, and Subtraction on page 278. Not available for 
objects specified as holes.

  Intersection                 creates a new object defined by the areas shared by the original objects. See Union, Intersection, 
and Subtraction on page 278. Not available for objects specified as holes.

  Subtract                 removes the area shared by two objects. See Union, Intersection, and Subtraction on page 278. Not 
available for objects specified as holes.

  Convert Polyline converts the object into a special polyline-based object. See Convert Polyline on page 265.          

  Revision Cloud(s) Around Objects                  creates a revision cloud around each of the selected object(s). See Revision 
Clouds on page 328.          

  Change Line/Arc changes a line-based polyline edge to an arc, or vice versa. See Change Line/Arc on page 259.
         

  Convert Curve to Polyline converts the selected arc into a polyline. See Convert Curve to Polyline on page 261. 
Only available when the selected edge is an arc.           

  Lock Center locks the center of the selected curved edge. See Lock Center on page 225. Only available when 
the selected edge is an arc.           

  Make Arc Tangent adjusts the selected curved edge and attached edge(s) so they form a smooth shape. See 
Make Arc Tangent on page 254. Only available when the selected edge is an arc attached on one or both ends to 

another line or arc.           
  Fence Select allows you to use the selected object(s) as a selection fence. See Using a Fence on page 217.          

  Object Layer Properties accesses layer information about the selected object. See Object Layer Properties on 
page 192.          

  Intersect/Join Two Lines joins two non-parallel lines or arcs. See Intersect/Join Two Lines on page 259.          
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  Fillet Lines creates an arc connecting two non-parallel lines. See Fillet Lines on page 260. Cannot be used if the 
adjacent edge is an arc.           

  Chamfer Lines creates a straight line between two non-parallel lines. See Chamfer Lines on page 260.          

  Extend Object(s) lengthens other object(s) until they intersect the selected object. See Trim and Extend on page 
276.          

  Trim Object(s)                 shortens the length of object(s) intersected by the selected object. See Trim and Extend on page 
276.          

  Align/Distribute Objects                 specifies how the selected objects are distributed. See Align/Distribute Objects on 
page 249. Only available when multiple objects are selected.          

  Align/Distribute Along Line specifies how the selected objects are distributed relative to a line. See 
Align/Distribute Along Line on page 250.           

  Create Hole creates a rectangular hole in the selected object. See Polyline Holes on page 234, below.

POLYLINE HOLES

Most closed polyline-based objects can contain one or more holes. There are several ways to create a hole; the methods 
available may vary depending on the object type.           

 l Some closed polyline-based object drawing tools have an associated Hole drawing tool.          
 l Many closed polyline-based objects have a Hole in check box on the GENERAL panel of their specification dialog that 

will convert the object into a hole if it is located within a larger object of the same type.          
 l Click the Create Hole  edit button, then click and drag to draw a rectangular hole in the selected object. If the 

selected object has an associated Hole tool or Hole in check box, the Create Hole will create an object of that type; if 
the selected object does not, a standard closed polyline will be created.           

 l Using the Convert Polyline  tool, a CAD Polyline can be converted into a variety of different types of objects, 

some of which may contain holes. If the selected CAD polyline contains any holes, those holes will be converted to 
holes in the converted object, when appropriate. See Convert Polyline on page 265.           

 l A CAD Polyline can be converted into a hole in a floor, ceiling, or roof assembly using the Convert Polyline  tool.           

Holes in polyline-based objects can be selected, edited, and deleted independent of their containing object. Bear in mind that 
by definition, a hole cannot exist where its containing object does not. It must be drawn entirely within the extents of its 
containing object without touching or crossing over an edge.           

A few closed polyline-based objects cannot have holes: notably, Molding Polylines and Rope Lights.          

 

Editing Box-Based Objects
Objects are considered box-based when they can be edited similar to CAD boxes using their edit handles.          

Box-based objects are similar to closed polyline-based objects, but must always have four sides with right-angled corners. 

In addition to the CAD Box tools, Text objects, many library symbols,              CAD blocks, pictures and images are examples of 
box-based objects.
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USING THE EDIT HANDLES

When selected, a box-based object displays ten edit handles. Unlike polylines, boxes must always have four sides with right-
angled corners.

Any action performed using the edit handles can be canceled by pressing the Esc key or any two mouse buttons at the same 
time.

The behavior of the edit handles may depend on the currently 
active Edit Behavior. See Defaults, Preferences, and Edit 

Behaviors on page 208.

 l Click and drag the Move handle to move the object according to the currently active Edit Behavior . See Defaults, 

Preferences, and Edit Behaviors on page 208. 

Movement may be limited or stopped by other objects or Snap Behaviors. Move restrictions can be overridden by 
holding down the Ctrl key while dragging. See Unrestricted Movement on page 246.

 l The four Resize handles located at each corner are used to increase or decrease the size of the object. 

 l The four Extend handles display along each edge. If you select an object on an edge, the Extend handle displays at the 
point where you clicked; otherwise, it displays at the center of the edge.
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 l The triangular Rotate handle located near the selected edge of the object is used to rotate it either about its center or 
the current CAD point. The pointer changes to a circular arrow   when moved over this handle. See Rotating Objects 
on page 261.

USING DIMENSIONS

             Dimensions can be used to move or reshape box-based objects. See Moving Objects Using Dimensions on page 491.         

USING THE SPECIFICATION DIALOG

Box-based objects can be edited using their specification dialogs. See Box Specification Dialog on page 327.

USING THE EDIT TOOLBAR

A selected box-based object can be edited in a variety of ways using the buttons on the Edit Toolbar.  

The following toolbar buttons may display on the Edit Toolbar for a selected box-based object:

  Select Next Object selects nearby objects instead of the selected object. See Selecting Objects on page 212.

  Open Object opens the specification dialog for the selected object(s). See Specification Dialogs on page 21. 

  Copy/Paste copies the selected object(s) to the system clipboard so they can be pasted elsewhere. See Copying 
and Pasting Objects on page 171.

  Delete deletes the selected object(s). See Deleting Objects on page 289.

  Transform/Replicate Object copies, moves, rotates, resizes, or reflects the selected object(s). See 
Transform/Replicate Object Dialog on page 269.          

  Multiple Copy makes a series of copies at set intervals. See Multiple Copy on page 176.          

  Make Parallel/Perpendicular makes the selected straight edge parallel or perpendicular to another straight edge. 
Not available when the selected edge is an arc. See Make Parallel/Perpendicular on page 252.

  Point to Point Move accurately moves the selected object(s). See Point to Point Move on page 247.

  Center Object              centers an object along a wall within a room or relative to a cabinet fixture. See Center Object on 
page 253.
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  Reflect About Object reflects the selected object(s) about another object. See Reflecting Objects on page 264.           

  View Drawing Group Edit Tools              modifies the selected object’s place in the drawing order. See Drawing Group 
Edit Tools on page 195.         

  Convert Polyline converts the object into a special polyline-based object. See Convert Polyline on page 265.          

  Revision Cloud(s) Around Objects creates a revision cloud around each of the selected object(s). See Revision 
Clouds on page 328.          

  Extend Object(s) lengthens other object(s) until they intersect the selected object. See Trim and Extend on page 
276.          

  Trim Object(s) shortens the length of object(s) intersected by the selected object. See Trim and Extend on page 
276.          

  Align/Distribute Objects specifies how the selected objects are distributed. See Align/Distribute Objects on 
page 249. Only available when multiple objects are selected.          

  Object Layer Properties accesses layer information about the selected object. See Object Layer Properties on 
page 192.          

  Align/Distribute Along Line aligns the selected object(s) relative to a line-based object. See Align/Distribute 
Along Line on page 250.           

 

Editing Spline-Based Objects
A Spline is a curve that passes smoothly through a set of points, or vertices. Splines are typically used in situations where an 
irregular, free-flowing curve is needed.

Objects are considered spline-based when they can be edited similar to CAD splines using their edit handles. See Splines on 
page 330.

Sprinkler lines, spline terrain curbs, spline terrain walls and both round and kidney-shaped terrain features are spline-based 
objects. See Terrain on page 1249.         

USING THE EDIT HANDLES

When a spline is selected, several different types of handles display. How many handles display depends on whether the 
Advanced Splines  edit button is on or not. See Advanced Splines on page 240. 

Any action performed using the edit handles can be canceled by pressing the Esc key or any two mouse buttons at the same 
time.

The behavior of the edit handles may depend on the currently 
active Edit Behavior. See Defaults, Preferences, and Edit 

Behaviors on page 208.
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A. Move
 l Click and drag the Move handle to move the object according to the currently active Edit Behavior . See Defaults, 

Preferences, and Edit Behaviors on page 208. 
 l Movement may be limited or stopped by other objects or Snap Behaviors. Move restrictions can be overridden by 

holding down the Ctrl key while dragging. See Unrestricted Movement on page 246.

B. Rotate
 l Click and drag the Rotate edit handle to rotate the entire spline. 

C. Vertex
 l The Vertex edit handles display along the spline at each vertex. Click and drag a Vertex edit handle to change the 

length, angle and curve of adjacent segments without affecting other vertices. 

Same Line Type
 l Drag a diamond-shaped end handle in any direction to draw a new spline segment that shares the original spline’s 

color, weight, line style, and layer. See Same Line Type Edit Handles on page 308.          

Advanced Splines
Additional edit handles, called Control Handles, display beside each spline vertex when Advanced Splines is 
enabled. See Advanced Splines on page 240.          

A. Vertex
B. Control Handle
C. Tangent Line

USING THE SPECIFICATION DIALOG

Spline-based objects can be edited using their specification dialogs. See Polyline Specification Dialog on page 323.
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USING THE EDIT TOOLBAR

A selected spline-based object can be edited in a variety of ways using the buttons on the Edit Toolbar.  

The following toolbar buttons may display on the Edit Toolbar for a selected spline-based object: 

  Select Next Object selects nearby objects instead of the selected object. See Selecting Objects on page 212.

  Open Object opens the specification dialog for the selected object(s). See Specification Dialogs on page 21. 

  Copy/Paste copies the selected object(s) to the system clipboard so they can be pasted elsewhere. See Copying 
and Pasting Objects on page 171.

  Delete deletes the selected object(s). See Deleting Objects on page 289.

  Transform/Replicate Object copies, moves, rotates, resizes, or reflects the selected object(s). See 
Transform/Replicate Object Dialog on page 269.          

  Multiple Copy makes a series of copies at set intervals. See Multiple Copy on page 176.          

  Make Parallel/Perpendicular makes the selected spline edge parallel or perpendicular to another straight edge. 
See Make Parallel/Perpendicular on page 252.         

  Point to Point Move accurately moves the selected object(s). See Point to Point Move on page 247.           

  Add to Library adds the selected object(s) to the library. See Add to Library on page 973.          

  Center Object centers an object along a wall within a room or relative to a cabinet fixture. See Center Object on 
page 253.         

  Reflect About Object reflects the selected object(s) about another object. See Reflecting Objects on page 264.           

  View Drawing Group Edit Tools modifies the selected object’s place in the drawing order. See Drawing Group 
Edit Tools on page 195.         

  Add Break adds a new corner or pivot point to the selected object. See Add Break on page 257.         

  Complete Break breaks an edge of the selected object into two separate objects. See Add Break on page 257.         

  Trim Object(s) shortens the length of object(s) intersected by the selected object. See Trim and Extend on page 
276.          

  Extend Object(s) lengthens other object(s) until they intersect the selected object. See Trim and Extend on page 
276. 

  Reverse Direction reverses the direction of the selected object(s). See Reverse Direction on page 264.     

  Convert Polyline converts the object into a special polyline-based object. See Convert Polyline on page 265.          

  Revision Cloud(s) Around Objects creates a revision cloud around each of the selected object(s). See Revision 
Clouds on page 328.          

  Fence Select uses the selected object(s) as a selection fence. See Using a Fence on page 217.          

  Convert Spline to Polyline converts the selected spline into a polyline. See Convert Spline to Polyline on page 
269.          
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  Object Layer Properties accesses and edits layer information about the selected object. See Object Layer 
Properties on page 192.          

  Advanced Splines enables advanced spline editing for the selected spline. See Advanced Splines on page 240.          

  Straighten Spline Segment straightens a segment of an Advanced Spline. See Straighten Spline Segment on 
page 241. Only available when Advanced Splines is turned on.          

  Lock Control Handle Angle maintains the relative angle between the vertex and its control handles. See Lock 
Control Handle Angle on page 241. Only available when Advanced Splines is turned on.          

  Align/Distribute Objects specifies how the selected objects are distributed. See Align/Distribute Objects on 
page 249. Only available when multiple objects are selected.          

  Align/Distribute Along Line- Click this, then click on a line-based object align the selected object(s) relative to 
that line. See Align/Distribute Along Line on page 250.           

ADVANCED SPLINES

Click the Advanced Splines edit button to display additional edit handles called Control Handles on the selected 
spline. These edit handles allow you to reshape the spline with more control at each vertex.         

A. Vertex
B. Control Handle
C. Tangent Line

The line between the two Control Handles is tangent to the spline’s curvature at the point of the vertex.           

 l Move a Control Handle around the vertex to change the direction of the spline’s curvature at the vertex point.  

 l Move a Control Handle away from the vertex to increase the curvature of the spline segment adjacent to that handle.

 l Move a Control Handle towards the vertex to decrease the curvature.

You can specify that splines be Advanced Splines by default in the Preferences dialog. See CAD Panel on page 117.          
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LOCK CONTROL HANDLE ANGLE

The Lock Control Handle Angle edit button is available when Advanced Splines is enabled, and is turned on by 
default. This tool maintains the relative angle between the vertex and its Control Handles.    

Clicking to uncheck the Lock Control Handle Angle  edit button frees the control of the relative edit angles between 

each vertex and its Control Handles. The Control Handles can now be adjusted independent of one another.

Rechecking Lock Control Handle Angle  will again lock the handles at their current angles.

STRAIGHTEN SPLINE SEGMENT

The Straighten Spline Segment edit button allows you to straighten the selected segment of an Advanced Spline 
between two vertex points.         

To use, click on the spline segment that you would like to straighten, then click the Straighten Spline Segment  edit 

button. See Selected Edge on page 214.          

When a spline segment has been straightened, the Control Handles and tangent lines associated with it are aligned with the 
segment. If either Control Handle is moved around the vertex, the straightened edge will become curved again.      
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Editing Circles, Ovals and Ellipses
Objects created using the Circle Tools are unusual in that no architectural objects share their functionalities.

USING THE EDIT HANDLES

When selected, circles, ovals and ellipses display eleven edit handles. 

Unlike Ovals  and Ellipses , a Circle  cannot be edited into any other shapes; it can only be a circle unless it is 

converted into a polyline. See Convert Curve to Polyline on page 261.

Any action performed using the edit handles can be canceled by pressing the Esc key or any two mouse buttons at the same 
time.

The behavior of the edit handles may depend on the currently 
active Edit Behavior. See Defaults, Preferences, and Edit 

Behaviors on page 208.

A. Move
B. Rotate
C. Reshape
D. Concentric Resize

Move
 l Click and drag the Move handle to move the object according to the currently active Edit Behavior . See Defaults, 

Preferences, and Edit Behaviors on page 208.
 l Movement may be limited or stopped by other objects or Snap Behaviors. Move restrictions can be overridden by 

holding down the Ctrl key while dragging. See Unrestricted Movement on page 246.

Rotate
 l Click and drag the Rotate handle of an oval or ellipse to change its orientation.

Reshape
 l The eight edit handles beyond the perimeter are Reshape edit handles. Move them in or out to resize and reshape an 

oval or ellipse.
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 l Unlike ovals and ellipses, circles cannot be reshaped. When a Reshape handle is dragged on a circle, it is only resized.

Concentric Resize
 l The Concentric Resize edit handle displays on the perimeter of a circle between a corner Reshape handle and the 

center. Click and drag this handle to resize the circle without moving its center point. 

USING DIMENSIONS

             Dimensions can be used to move or resize circle-based objects. See Moving Objects Using Dimensions on page 491.

USING THE SPECIFICATION DIALOG

             Circles, ovals and ellipses can be edited using their specification dialogs. See Circle/Oval/Ellipse Specification 
Dialog on page 321. 

USING THE EDIT TOOLBAR

A selected circle, oval or ellipse can be edited in a variety of ways using the buttons on the Edit Toolbar.  

The following toolbar buttons may display on the Edit Toolbar for a selected circle, oval or ellipse:

  Select Next Object selects nearby objects instead of the selected object. See Selecting Objects on page 212.

  Open Object opens the specification dialog for the selected object(s). See Specification Dialogs on page 21.
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  Copy/Paste copies the selected object(s) to the system clipboard so they can be pasted elsewhere. See Copying 
and Pasting Objects on page 171.

  Delete deletes the selected object(s). See Deleting Objects on page 289.

  Transform/Replicate Object copies, moves, rotates, resizes, or reflects the selected object(s). See 
Transform/Replicate Object Dialog on page 269.          

  Multiple Copy makes a series of copies at set intervals. See Multiple Copy on page 176.          

  Make Parallel/Perpendicular makes the selected edge parallel or perpendicular to another straight edge. See 
Make Parallel/Perpendicular on page 252.         

  Point to Point Move accurately moves the selected object(s). See Point to Point Move on page 247.           

  Center Object centers an object along a wall within a room or relative to a cabinet fixture. See Center Object on 
page 253.         

  Reflect About Object reflects the selected object(s) about another object. See Reflecting Objects on page 264.           

  View Drawing Group Edit Tools modifies the selected object’s place in the drawing order. See Drawing Group 
Edit Tools on page 195.         

  Extend Object(s) lengthens other object(s) until they intersect the selected object. See Trim and Extend on page 
276. Not available for ellipses.           

  Trim Object(s) shortens the length of object(s) intersected by the selected object. See Trim and Extend on page 
276. Not available for ellipses.           

  Convert Polyline converts the object into a special polyline-based object. See Convert Polyline on page 265.          

  Revision Cloud(s) Around Objects creates a revision cloud around each of the selected object(s). See Revision 
Clouds on page 328.          

  Convert Curve to Polyline converts the selected circle, oval or ellipse into a polyline. See Convert Curve to 
Polyline on page 261.           

  Align/Distribute Objects specifies how the selected objects are distributed. See Align/Distribute Objects on 
page 249. Only available when multiple objects are selected.          

  Object Layer Properties accesses layer information for the selected object. See Object Layer Properties on 
page 192.          

  Align/Distribute Along Line aligns the selected object(s) relative to a line-based object. See Align/Distribute 
Along Line on page 250.           

 

Editing Multiple Objects
There are a               number of options for accurately and efficiently editing multiple objects at once. See Selecting Multiple Objects 
on page 215. 

DYNAMIC DEFAULTS

Dynamic defaults are a useful way to apply certain attributes to multiple objects of the same type throughout a plan. They 
are found in the defaults dialogs for a variety of different architectural objects, and when these default values are changed, 
all objects that are set to use them throughout the current plan will update automatically. Dynamic defaults are particularly 
valuable for applying critical defaults like ceiling heights and floor structure. See Dynamic Defaults on page 79.          
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IN THE SPECIFICATION DIALOG

When multiple objects are selected, the Open Object edit button is often available. The settings available in a shared 
specification dialog will vary, depending on the types of objects that are selected. If the objects are of the same type, 

their shared specification dialog will have many of the settings that their individual specification dialogs have; if they are 
not similar, the dialog may have only a few settings. When multiple objects are selected, their shared specification dialog 
may also have settings in a “No Change” state. See Specification Dialogs on page 21.         

USING THE EDIT TOOLBAR

Group-selected objects can also be edited using the buttons on edit toolbar. The available tools will vary, depending on 
which types of objects are selected. See The Edit Toolbar on page 135.         

OBJECT PAINTER

The Object Eyedropper tool allows you to apply selected attributes of one object to other, similar objects. See 
Object Eyedropper on page 286.

 

Moving Objects
Objects can be moved using the edit handles as well as a variety of edit tools. Multiple selected objects can also be moved 
as a group. See Selecting Objects on page 212.

USING THE EDIT HANDLES

Select an object, then click the Move edit handle and drag it to a new location. When your pointer is over the Move handle, 
it displays a four-headed arrow  . 

As an object is moved, it jumps at set increments when Grid Snaps  are enabled. See Grid Snaps on page 167.

When Object Snaps  are enabled, a selected object snaps to its original location if it passes over that location while 

being moved.          

The behavior of the Move edit handle varies depending on the currently active Edit Behavior . See Defaults, 

Preferences, and Edit Behaviors on page 208.            

 l If the Default , Resize , Concentric  or Fillet  edit behavior is active, the object moves orthogonal, or at 

a right angle to, any of its edges.          
 l If the Alternate  edit behavior is active, the selected object(s) can be moved at Allowed Angles if Angle Snaps 

 are enabled, or orthogonal to any of its edges if they are not. See Alternate on page 209.          
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 l If the Move edit behavior is active, the selected object(s) can be moved by clicking and dragging any edit handle that 
would otherwise be used for resizing. See Move on page 209.          

You can temporarily slow the movement of your mouse as you drag an edit handle by  holding down the Shift key on your 
keyboard.

BUMPING/PUSHING

When Edit> Snap Settings> Bumping/Pushing is enabled, architectural objects will bump into and can push one 
another as they are moved. This setting also affects CAD and CAD-based objects with CAD Stops Move and/or 

Wall Stops Move enabled. See Line Style Panel on page 310.         

When an object bumps into another object while it is being moved, it stops. If you do not release the mouse button and 
continue to drag, however, the selected object resumes movement and continues past the obstructing object. 

Instead of dragging through and past obstructing objects, you can instead push them. To do this, bump an object into an 
obstructing object and release the mouse button. Then, click and drag the Move edit handle a second time in the same 
direction. 

Walls, wall openings, cabinets, furnishings and fixtures, and CAD and CAD-based objects are examples of objects that can 
bump into as well as push other objects. 

By default, Bumping/Pushing  does not affect objects moved using dimensions or the Enter Coordinates dialog. See 

Moving Objects Using Dimensions on page 491 and Entering Coordinates on page 170. 

The Maximum Bump Distance, which is the distance you must drag to override bumping, is set in the Preferences dialog. 
Bumping/Pushing for Type-in Movement can also be enabled there. See Snap Properties Panel on page 122.           

Certain types of objects, notably roof planes, and objects on locked layers can be bumped but cannot be pushed. See Layer 
Display Options Dialog on page 183.           

CAD STOPS MOVE/WALL STOPS MOVE

CAD and CAD-based objects can be set to stop at other CAD objects and/or at walls as they are being moved. See Line 
Style Panel on page 310.          

Some objects, such as cross boxes, framing members and insulation, are automatically set to stop when moved against other 
CAD objects.           

CAD Stops Move and Wall Stops Move do not function if Bumping/Pushing  is turned off.          

UNRESTRICTED MOVEMENT

Many objects have restrictions placed on their movement by their own properties or specification settings. Architectural 
objects, for example, bump into other 3D objects as they are being moved when Bumping/Pushing  is enabled.

CAD-based objects can be set to stop at other CAD objects or at walls. See Line Style Panel on page 310. 

Other move restrictions are activated by the Snap Settings . See Snap Behaviors on page 163.

These restrictions can be overridden when necessary by holding down the Ctrl key while dragging to move an object.
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To move an object freely
 1.  Select the object. 

 2.  Hold down the Ctrl key.

 3.  Click the Move edit handle and drag it to the new location.

You can also press the Ctrl key while dragging an object’s Move handle to override move restrictions. 

NUDGING

You can use your keyboard to move a selected object or objects by single Snap Grid increments in 2D and 3D views. This 
is referred to as nudging. See Grid Snaps on page 167.

By default, the Nudge commands are not assigned hotkeys and the arrow keys are programmed to nudge a selected object. If 
you press an arrow key when no object is selected, you will instead pan the view window. See Panning the Display on page 
158.          

If you wish, you can program assign hotkeys to the Nudge commands. When Nudge hotkeys are assigned, they cannot also 
be used to pan the display. See Hotkeys on page 142.           

In Plan View
To nudge an object in plan view, select it and press any of the four arrow keys: Up, Down, Left, or Right. These directions 
are relative to the Snap Grid: if Rotate Plan View  is used to rotate plan view, the definitions of up, down, left, and right 

are affected. See Rotate Plan View on page 151.

In 3D Views
To nudge an object in camera views, overviews, and cross section/elevation views, you can program the keys of your choice 
for use as nudging hotkeys. See Hotkeys on page 142.          

In 3D views, nudging is relative to the selected surface. If, for example, you select the front of a cabinet in 3D and nudge it 
to the left, it will move to the left in plan view. If you instead select the back of a cabinet in 3D and nudge it to the left, it 
will move to the right in plan view. 

When multiple objects are selected, the surface that was clicked on last is considered the selected surface. When nudged, all 
selected objects will move relative to that surface. See Shift and Ctrl Select on page 217. 

If an object is rotated, the directions that it can be nudged in 2D are not affected; however, in 3D, they are. If, for example, 
a cabinet is rotated 45º, it will nudge to the left as defined by the Snap Grid in plan view. When nudged in 3D, however, it 
will move at a 45º angle to the Snap Grid: or parallel to the selected surface.

POINT TO POINT MOVE

The Point to Point Move edit button allows a selected object or group of objects to be accurately moved.          

The Point to Point Move tool is often most effective when used in combination with Object Snaps. Bear in mind that it is 
also affected by Grid Snaps, and that in some situations you may want to toggle snaps off. See Snap Behaviors on page 163. 

To use Point to Point Move
 1.  Select one or more objects that you would like to move, then click the Point to Point Move  edit button.          

 2.  A temporary CAD point   preview follows the mouse pointer, which displays the Point A   icon. Click on a point 
that you want to accurately reposition: a temporary point is placed at that location.          
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 3.  An extension line extends from Point A to the mouse pointer, which now displays the Point B   icon and is 
followed by a preview outline of the selection and another temporary point preview.           

 4.  Click on the point in the plan where you would like the selected point to be relocated when it is moved.         

 5.  The selected object(s) are moved so that they maintain their position relative to the point and both temporary points 
are deleted.         

To retain a copy of the selected object(s) in the original location, the Copy/Paste  edit button before clicking the Point 

to Point Move button. See To use Copy/Paste with other edit tools on page 174.

Point to Point Move can also be used with the Edit Area  tools. See Edit Area Tools on page 273.         

USING CENTER OBJECT

The Center Object edit button allows you to move walls, cabinets and other objects so that they are centered along a 
wall within a room or relative to a window or cabinet.              See Center Object on page 253.          

MOVE TO FRAMING REFERENCE

Framing members can be positioned relative to a Framing Reference using the Move to Framing Reference edit 
tool. See Framing Reference Markers on page 890.         

USING DIMENSIONS

Objects or the selected edges of some objects can be moved using dimensions. See Moving Objects Using 
Dimensions on page 491.         

When Bumping/Pushing for Type-in Movement is checked in the Preferences dialog, adjacent objects can be pushed 
when an object is moved using dimensions.         

ENTER COORDINATES

Objects or the selected edges of some objects can be moved using the Enter Coordinates dialog. See Entering Coordinates 
on page 170.           

To push additional objects using the Enter Coordinates dialog, check Bumping/Pushing for Type-in Movement in the 
Preferences dialog, then bump an object into another object. Click and drag a second time to begin pushing and press the 
Tab key to open the Enter Coordinates dialog.           

Note: By default, objects moved using either the Enter Coordinates 
dialog or dimensions are not subject to Bumping/Pushing. See 
Bumping/Pushing on page 246.

USING THE TRANSFORM/REPLICATE OBJECT DIALOG

Objects and groups of objects can be moved relative to themselves or an absolute location using the Transform 
Replicate Object dialog. See Transform/Replicate Object Dialog on page 269.         
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Aligning Objects
It is often important to align objects such as text boxes, roof plane edges, or walls, or to align objects on different floors. 
There are several methods to choose from.   

ALIGN/DISTRIBUTE OBJECTS

Select two or more objects and click the Align/Distribute Objects edit button to open the Align/Distribute Objects 
dialog and specify how to align or distribute the selected objects vertically and/or horizontally.    

Align/Distribute Objects is available in all views for most CAD objects. For architectural objects, it is only available in 
plan view.       
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Move Objects Vertically to

Specify what edges or points on the selected objects to Move Objects Vertically to.      

 l Select Don’t Move Vertically to make no changes to the vertical alignment of the selected objects.         

 l Select Top Edges to move the selected objects so their top edges are aligned. The object with the highest top edge in 
the selection set does not move.        

 l Select Centers to move the selected objects so their centers are aligned vertically. The object with the center closest 
to the vertical center of the selection set does not move.         

 l Select Bottom Edges to move the selected objects so their bottom edges are aligned. The object with the lowest 
bottom edge in the selection set does not move.        

 l Select Space Evenly to produce consistent vertical spacing between the top and bottom edges of the objects in the 
selection set. The highest and lowest objects on screen do not move and the ones in between move up or down as 
needed. Only available if three or more objects are selected.        

 l Select Distribute Centers Evenly to produce consistent on-center vertical spacing between the objects in the 
selection set. The highest and lowest objects on screen do not move and the ones in between move up or down as 
needed. Only available if three or more objects are selected.      

 
Move Objects Horizontally to

Specify what edges or points on the selected objects to Move Objects Horizontally to.      

 l Select Don’t Move Horizontally to make no changes to the horizontal alignment of the selected objects.         

 l Select Left Edges to move the selected objects so their left edges are aligned. The object in the selection set with the 
leftmost edge does not move.        

 l Select Centers to move the selected objects so their centers are aligned horizontally. The object with the center 
closest to the horizontal center of the selection set does not move.        

 l Select Right Edges to move the selected objects so their right edges are aligned. The object in the selection set with 
the rightmost edge does not move.        

 l Select Space Evenly to produce consistent horizontal spacing between the left and right edges of the objects in the 
selection set. The left- and rightmost objects on screen do not move and the ones in between move left or right as 
needed.        

 l Select Distribute Centers Evenly to produce consistent on-center horizontal spacing between the objects in the 
selection set. The left- and rightmost objects on screen do not move and the ones in between move left or right as 
needed.      

ALIGN/DISTRIBUTE ALONG LINE

Select one or more objects, click the Align/Distribute Along Line edit button, then click on a line or line-based 
object to open the Align To Line dialog and specify how to align the selected objects relative to the line.

Align/Distribute Along Line  is available in all views for most CAD objects.  For architectural objects, it is only 

available in plan view.     
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Alignment

Specify the Alignment to apply to the selected object(s) relative to the line.     

 l Select None to make no changes to the alignment of the selected objects.       

 l Select Centers to move the selected objects so their centers are aligned with the line.      

 l Select Closest Edges to move the selected objects so the edges closest to the line are aligned with the line.       

 
Distribution

Specify the Distribution of the selected objects relative to the line.      

 l Select None to make no changes to the spacing of the selected objects.       

 l Select Space Evenly to produce consistent spacing between the edges of the objects in the selection set in the same 
direction as the line. The outermost objects in the group do not move and the ones in between move as needed.       

 l Select Distribute Centers Evenly to produce consistent on-center spacing in the same direction as the line 
between the objects in the selection set. The outermost objects in the group do not move and the ones in between 
move as needed.      

Specify, too, how the first and last objects align with the line’s endpoints. These options are only available if three or 
more objects are selected.       

 l Select Distribute To Endpoints to position the first and last objects in the array so they align with the line’s 
endpoints.       

 l Select Distribute Between Endpoints to position the first and last objects in the array so inside the line’s 
endpoints, spaced as though there were additional objects aligned with the endpoints.       

 l Select None to make no changes to the alignment of the selected objects.      
 l Select Centers to move the selected objects so their centers are aligned with the line.     
 l Select Closest Edges to move the selected objects so the edges closest to the line are aligned with the line.      

USING THE CROSSHAIRS

Objects can be aligned by eye using the mouse pointer crosshairs as a reference. This method can help you draw, place and 
edit objects quickly, easily, and with reasonable accuracy, but is not necessarily as accurate as some of the other approaches 
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described here. See Crosshairs on page 16.

The mouse pointer crosshairs can be turned on and off and their size and aperture set in the Preferences dialog. See Edit 
Panel on page 119.

USING SNAP SETTINGS

With Object Snaps  on, you can snap the edge of a selected object to that of another. Select an edge of an object. 
Drag it to the edge of another object to reveal an Object Snap point, then release the mouse.

With Grid Snaps on and Angle Snaps off, select the left side of the object, and drag from the center move 
handle. This snaps the selected side to the grid.

When both Grid Snaps     and Angle Snaps    on, objects snap at increments equal to the Snap unit specified in the Plan 
Defaults dialog rather than onto the grid itself. This does not align objects to the grid unless they were already snapped to 
the grid. See Snap Behaviors on page 163. 

USING DIMENSIONS

Create a temporary or manual dimension relative to an object such as a wall or line, and relocate the objects to the 
same dimension. See Moving Objects Using Dimensions on page 491.    

Text objects can be aligned using settings in the Text 
Specification dialog. See Aligning Text on page 522.

CAD STOPS MOVE/WALL STOPS MOVE

CAD and CAD-based objects can be aligned using another CAD object or a wall as a guide. Check the CAD Stops Move 
and/or Wall Stops Move boxes in the objects’ specification dialogs, then move them until they bump into the CAD object 
or wall that you wish to use as a guide for alignment. See Line Style Panel on page 310.    

MAKE PARALLEL/PERPENDICULAR

The Make Parallel/Perpendicular edit button allows you to make a selected object parallel or perpendicular to any 
straight line or edge.   

If you select an edge of a polyline-based object, adjacent edges extend or contract to maintain contact, but other edges 
remain unchanged. The selected edge rotates about its endpoint if selected near the end, or about its center if you click 
within its middle third. 

The Make Parallel edit button displays for a selected CAD block instance when a line, including a straight polyline edge, 
or box edge within a block instance, straight polyline edge is selected. The entire block is rotated to make the selected line 
or edge perpendicular or parallel to the item subsequently clicked on.     

A few objects, such as camera symbols, are not eligible to be used as an axis for the Make Parallel/Perpendicular tool.   

To use Make Parallel/Perpendicular
 1.  Select an object such as a roof plane on the edge that you would like to make parallel or perpendicular to another 

object.     

 l Click near the center of the edge to rotate it about the center.      

 l Click near an end to rotate the edge about that end.    
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 2.  Click the Make Parallel/Perpendicular  edit button.

 3.  Click on a straight edge of an eligible object such as a wall.    

 4.  If the first object is within 45° of parallel to the second object, it is made parallel. Otherwise, it is made 
perpendicular to the second object.     

You can also make the selected edge parallel by rotating the entire object. See Make Parallel/Perpendicular with Polyline-
Based Objects on page 263.    

CENTER OBJECT

The Center Object edit button can be used to center a variety of objects either relative to another object or between 
two points. Center Object can be used to center architectural objects in plan view, cross section/elevation, and 3D 

views. It can also be used to center CAD objects in plan view, cross section/elevation views, layout, and CAD Details. 

A few objects, such as camera symbols, are not eligible to be used as a centering axis.    

To center an object
 1.  Select an object.    

 2.  Click the Center Object      edit button.    

 3.  Move the mouse pointer over the object you would like to center the selected object relative to.    

 l As the pointer passes over an eligible object, it becomes highlighted and a dashed centering axis line displays.     

 4.  When the desired centering axis displays, click once to center the selected object along that axis line.    

To center an object in a room
 1.  Select an object such a cabinet.    

 2.  Click the Center Object      edit button.    

 3.  Move the mouse pointer in the room that you would like to center the selected object relative to.    

 l As you move the pointer, a centering axis will display along the wall it is closest to.     

 l The selected object does not have to be inside a room in order to be centered relative to that room.     

 4.  When a centering axis displays along the correct wall, click once.     

 5.  The object is moved perpendicular to the centering axis.     
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 l As you move the pointer, a centering axis will display along the wall it is closest to.     

 l The selected object does not have to be inside a room in order to be centered relative to that room.     

 6.  When a centering axis displays along the correct wall, click once.     

 7.  The object is moved perpendicular to the centering axis.     

If you click outside an exterior wall instead of clicking inside, the selected object is centered along the edge of the Exterior 
Room. See The Exterior Room on page 424.    

To retain a copy of the selected object(s) in the original location, the Copy/Paste  edit button before clicking the Center 

Object button. See To use Copy/Paste with other edit tools on page 174.

POINT TO POINT CENTER

The Point to Point Center edit button can be used to center an object between two points. 

To center an object between two points
 1.  Select an object and click the Center Object  edit button.      

 2.  Click the Point to Point Center  edit button.      

 3.  The mouse pointer displays the Point A   icon. Move the mouse pointer over one of the points you want to center 
the selection between and click once.       

 l Object Snaps like the Center, Midpoint or Endpoint of an object can be used, although any point in the drawing 
area is valid. See Object Snaps on page 164.       

 4.  An extension line extends from Point A to the mouse pointer, which now displays the Point B   icon.       

 5.  When the mouse pointer is over the second centering point, click once more.      

 6.  When the two centering points are defined, a set of temporary CAD points are created, identifying the points that the 
selected object can be moved to.       

 l When the extension line is either horizontal or vertical, two CAD points are created.       

 l If the line is angled, five CAD points are created.        

 7.  Move your mouse pointer over a CAD point and click one more time to move the selected object to that location.      

To retain a copy of the selected object(s) in the original location, the Copy/Paste  edit button before clicking the Point 

to Point Center Object button. See To use Copy/Paste with other edit tools on page 174.

MAKE ARC TANGENT

If a selected arc is attached on one or both ends to another line or arc, the Make Arc Tangent edit button displays. 
Click this button to adjust the arc and attached lines so they transition smoothly.    
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To use Make Arc Tangent
 1.  Select an arc-based object attached to like objects on one or both ends.       

 2.  Click the Make Arc Tangent  edit button.       

 l If the arc is attached to an object on one end, it will adjust so that it is tangent to that object.       

 l If the arc is attached to objects on both ends, the Radius of Tangent Arc dialog opens.        

 3.  The radius from the center of curvature to the middle of the arc-based object displays.       

 l If the arc is attached to an object on one end, it will adjust so that it is tangent to that object.       

 l If the arc is attached to objects on both ends, the Radius of Tangent Arc dialog opens.        

 4.  The radius from the center of curvature to the middle of the arc-based object displays.       

 l If the objects attached to each end of the arc are parallel to one another, this value displays for reference only.       

 l Keep this radius or change it, and click OK.       

 5.  The arc and attached segments adjust so that the arc radius matches the target as closely as possible and the arc is 
made tangent to the attached segments.       

ALIGNING ARC CENTERS

The center points of circles and arc-based objects can be aligned, even if the objects are on different floors, when the 
Reference Display is turned on and Arc Centers and Ends  is toggled on. Note that Arc Centers and Ends is a floor-

specific toggle. See The Reference Display on page 69 and Arc Centers and Ends on page 225.    

To align center points easily, it is helpful to turn on Object Snaps  and turn off Angle Snaps . See Object Snaps on 

page 164 and Angle Snaps on page 166.    
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ALIGNING OBJECTS ON DIFFERENT FLOORS

Objects on different floors can be aligned with one another using Object Snaps  and the Reference Display . See 

Object Snaps on page 164 and The Reference Display on page 69.

 

Resizing Objects
Objects can be resized using the edit handles, specification dialogs, and the Transform/Replicate Object dialog. 

USING THE EDIT HANDLES

Depending on the currently active Edit Behavior , the end, corner and/or side edit handles can be used to resize a 

selected object. See Defaults, Preferences, and Edit Behaviors on page 208.

When the Concentric  edit behavior is active, dragging an object’s corner or end handle  resizes it according to the 

Concentric Jump value set in the Preferences dialog. See Concentric on page 210.          

Objects can be resized about either their center points or the current CAD point. See Rotate/Resize About on page 262.          

To override any movement restrictions caused by snap settings or the presence of other objects, press the Ctrl key while 
dragging an edit handle.

As an object is resized, any dimensions indicating its size will update to reflect your changes. You can use dimensions as 
references to help you achieve the correct size for most objects. 

You can temporarily slow the movement of your mouse as you drag an edit handle by  holding down the Shift key on your 
keyboard.

USING THE SPECIFICATION DIALOG

Most objects can be accurately resized in their specification dialogs. Some objects, such as images and some 
symbols, have a Retain Aspect Ratio option that lets you easily resize the object without distorting its shape. See 

Specification Dialogs on page 21. 

USING DIMENSIONS

Many objects can be resized by selecting an edge and then moving that edge using dimensions. See Moving Objects 
Using Dimensions on page 491.         

Walls can also be resized using dimensions; however, it is important to understand that the selected edges of other objects 
cannot be resized using dimensions - they can only be moved. To resize an edge, select an adjacent edge and move that edge 
instead.         

USING THE TRANSFORM/REPLICATE OBJECT DIALOG

Most objects can be resized about either their centers or an absolute point using the Transform Replicate Object 
dialog. See Transform/Replicate Object Dialog on page 269.         
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Reshaping Objects
There is a variety of ways to reshape objects using the edit handles, specification dialogs and edit toolbar buttons.

Some objects, notably circles and box-based objects, cannot be reshaped - only resized. See Resizing Objects on page 256.

USING THE EDIT HANDLES

Depending on the Edit Behavior  in use, the end, corner and/or side edit handles can be used to reshape a selected 

object. See Defaults, Preferences, and Edit Behaviors on page 208.

When a line-based, arc-based, or open polyline-based object is selected, you can right-click and drag an end handle to 
change a line into an arc or vice versa. This behavior does not apply to closed polylines.         

To override any movement restrictions caused by snap settings or the presence of other objects, press the Ctrl key while 
dragging an edit handle.

You can temporarily slow the movement of your mouse as you drag an edit handle by  holding down the Shift key on your 
keyboard.

USING THE SPECIFICATION DIALOG

A variety of CAD and CAD-based objects can be reshaped by editing values on either the SELECTED LINE or 
SELECTED ARC panel of their specification dialogs. See Polyline Specification Dialog on page 323.

USING DIMENSIONS

Both temporary and manually drawn dimensions can be used to increase or decrease the distance between the edge a 
line- or polyline-based object and another, parallel edge or line. See Moving Objects Using Dimensions on page 491.         

Angular Dimensions  can be used to adjust the angle where two polyline segments meet. See Using Angular 

Dimensions on page 262.         

ADD BREAK

The Add Break edit tool can be used to break an individual line-, arc-, or spline-based object into two segments. The 
edges of a polyline-based object can also be broken.         

The Add Break edit tool can also be used to create stepped cross section cutting planes. See Stepped Cutting Planes on 
page 1093.         

Note: The Add Break edit button is not available for box-based objects, 
objects created with the Circle Tools, North Pointers, Sun Angles, Joist 
Direction Lines, or some architectural objects such as stairs and trusses.

There are two types of breaks: partial and complete. A partial break creates a new corner or pivot point between two 
connected segments, while a complete break actually severs an edge into two disconnected segments.         
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To create a partial break
 1.  Select the object, object edge, or the centerline of the object that you want to add a pivot point or corner to.         

 2.  Click the Add Break  edit button once or press the 3 key. 

 3.  If you would like to create more than one break, click the Sticky Mode  edit button. 

 4.  If you would like to move the edges of the object as you add breaks, click the Edge Edit Handles  edit button to 

toggle on their display.         

 5.  If you want, you can click the Corner Edit Handles  edit button to toggle off their display.         

 6.  Click the edge to create a new corner edit handle at that location and two separate edges on either side of that 
handle.         

 7.  If you enabled Sticky Mode , continue clicking to place additional breaks.         

 8.  Click the Main Edit Mode  edit button or press the Esc key to return to the selected object’s main edit toolbar.         

If you click and drag one of the edit handles on either side of the partial break, the edge moves at a right angle to itself and 
another edge forms, connecting the moved edge with the one on the other side that does not move.         

You can remove an edge from a polyline-based object by clicking and dragging a corner handle until it snaps to an adjacent 
corner handle.         

When a complete break is created, the object or edge is totally severed at that point.          

With the exception of framing members, complete breaks cannot be created on CAD-based architectural objects. In the case 
of framing members, only complete breaks can be created.         

To create a complete break
 1.  Click the object, object edge, or object centerline that you want to break into two segments.         

 2.  Click the Add Break  edit button. 

 3.  Click the Complete Break  edit button. 

 4.  If you would like to create more than one complete break, click the Sticky Mode  edit button. 

 5.  If you would like to move the edges of the object as you add breaks, click the Edge Edit Handles  edit button to 

toggle on their display         

 6.  If you want, you can click the Corner Edit Handles  edit button to toggle off their display.         

 7.  Click on an edge to create a complete break at that location.         

 8.  If you enabled Sticky Mode , continue clicking to place additional breaks.         

 9.  Click the Main Edit Mode  edit button or press the Esc key to return to the selected object’s main edit toolbar.         

The edge that you clicked on will be divided into two separate sections, one of which will be selected. You can now move 
or edit the selected edge completely independent of the object or edge on the other side of the break. Click on the other edge 
to select it instead.         
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When Object Snaps  are enabled, breaks can be placed at snap locations such as midpoints. See Object Snaps on page 

164.          

To remove a break from an edge
 1.  Make sure that Object Snaps  are enabled. See Object Snaps on page 164.

 2.  Select the object that has a break that you want to remove.         

 3.  Click on the corner edit handle associated with the break that you want to remove and drag it to an adjacent corner 
handle.         

 4.  When you see an Endpoint  snap indicator, release the mouse button. The handle that you selected will be 

removed.         

CHANGE LINE/ARC

Select an individual line-based or arc-based object or a segment of a polyline-based object and click the Change 
Line/Arc edit button to convert the selected segment from a line to an arc or vice versa.

USING MAKE PARALLEL/PERPENDICULAR

The Make Parallel edit button can be used to reshape a polyline by making a selected edge parallel or perpendicular 
to another straight edge. See Make Parallel/Perpendicular on page 252.         

INTERSECT/JOIN TWO LINES

The Intersect/Join Two Lines edit tool allows you to connect two non-parallel line- and/or arc-based objects or to 
join two edges of an open or closed polyline-based object. The lines or edges will shorten or lengthen as need to 

intersect at a point and join. If one or more edges exists between the two polyline edges, they will be removed.         

To use Intersect/Join Two Lines
 1.  Click on a line, arc, or polyline segment that you would like to connect to another line or segment.         

 2.  Click the Intersect/Join Two Lines  edit button.         

 3.  Click on the other line or polyline edge.         

 4.  If there are intervening polyline edges, a message will confirm that you would like them to be removed. Click Yes.         
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FILLET LINES

The Fillet Lines edit tool allows you to replace the angled corner where two polyline edges meet with an arc.          

Fillet Lines can also be used to join two non-parallel line-based objects with an arc. If one or both of the two objects is an 
arc, both will extend or contract as needed to become connected. No additional arc is created.         

To use Fillet Lines
 1.  Click on a line or polyline segment that you would like to connect to another line or segment with a fillet, or arc.         

 2.  Click the Fillet Lines  edit button, then click the Fillet Radius  edit button.         

 3.  In the Set Fillet Radius dialog, specify the desired Fillet Radius and click OK. If this value is 0, no fillet will be 
created.         

 4.  To apply the specified radius to all corners of a selected polyline, click the Fillet All Corners  edit button. If the 

selected polyline is a Custom Countertop or Molding Polyline, any corners that touch a wall will not be filleted by 
this tool.         

 5.  To apply a fillet to more than one corner of the selected polyline, click the Sticky Mode  edit button.         

 6.  Click on the line or polyline segment that you want the selected line or edge to connect to with a fillet.         

 7.  If you enabled Sticky Mode , continue clicking on edges to create additional fillets.         

 8.  Click the Main Edit Mode  edit button or press the Esc key to return to the selected object’s main edit toolbar.         

Once two lines are filleted, the arc between them can be edited. See Editing Arc-Based Objects on page 221.         

CHAMFER LINES

The Chamfer Lines edit tool allows you to create a straight corner bevel of a specified size connecting any two non-
parallel lines or polyline edges. The Chamfer Distance set in the Chamfer Distance dialog describes the distance both 

lines that form the corner are shortened to produce the bevel: not the length of the bevel itself.

The Chamfer Lines tool can also be used to extend an arc so that it joins to another arc or line. If one or both of the two 
objects is an arc, both will extend or contract as needed to become connected. No additional chamfer is created.          

The Chamfer Lines edit tool is used much the way the Fillet Lines edit tool is. See To use Fillet Lines on page 260, above.           

The Fillet Lines and Chamfer Lines edit tools can also be used 
the same way as the Intersect/Join Two Lines tool to join lines 

and polyline edges and remove any intervening polyline edges. 

USING CLOSE POLYLINE

An open polyline-based object can be converted into a closed polyline using the Close Polyline edit tool. See Close 
Polyline on page 230.          
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SIMPLIFY POLYLINE

The Simplify Polyline edit button is available for an open or closed polyline or polyline-based object with a segment 
that is unusually short and can cause problems when editing the polyline’s shape. Click this edit button to remove the 

segment.         

CONVERT CURVE TO POLYLINE

The Convert Curve to Polyline edit button allows you to convert a selected arc- or circle-based object or object edge 
to a polyline composed of line segments. Not available for some architectural objects such as walls or stairs.         

To convert curve to polyline
 1.  Select an arc-based object or circle.         

 2.  Click the Convert Curve to Polyline  edit button.         

 3.  In the Convert Curve to Polyline dialog, specify the number of sides you would like the converted arc or circle-based 
object to have.         

 l The initial values in this dialog may vary depending on the type of object selected.         

 l Click OK to convert the selected arc or circle-based object into a polyline with the specified number of edges.         

CONVERT TO SPLINE

CAD polylines, most 3D Solids, as well as some CAD-based objects such as Slabs can be converted to splines or 
spline-based objects using the Convert to Spline edit tool. See Editing Spline-Based Objects on page 237.     

Unlike polylines, splines form smooth curves rather than angled corners where their direction changes. See Splines on page 
330. 

Line- and arc-based objects cannot be converted to splines, nor can polylines with one or more curved edges.

USING UNION, INTERSECTION, SUBTRACT

Closed polyline-based objects, including Primitives, can be used to create new shapes using the Union, 
Intersection and Subtract edit buttons. See Union, Intersection, and Subtraction on page 278.         

 

Rotating Objects
Objects can be rotated using the edit handles as well as a variety of edit tools. Multiple selected objects can also be rotated 
as a group. See Selecting Objects on page 212. 

By default, an object or group of objects  rotate about the center point of the selection set. You can instead specify that 
objects rotate about the current CAD point.  See The Current Point on page 303.
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USING THE EDIT HANDLES

Select an object, then click the triangular Rotate edit handle and drag it in any direction. When your pointer is over the 
Rotate handle, it displays a curved arrow  .

The angles of line-based objects can also be changed by dragging an end handle in a direction other than parallel to the 
object. The object rotates about the opposite end point. See Editing Line-Based Objects on page 218.

When Angle Snaps  are enabled, objects snap to Allowed Angles as specified in the Plan Defaults dialog as they are 

rotated. See Angle Snaps on page 166. 

To override any movement restrictions caused by snap settings or the presence of other objects, press the Ctrl key while 
dragging an edit handle.

You can temporarily slow the movement of your mouse as you drag an edit handle by  holding down the Shift key on your 
keyboard.

USING THE SPECIFICATION DIALOG

The exact angle of some objects such as lines, arcs, walls and the selected edges of polylines can be specified on 
either the GENERAL panel, SELECTED LINE panel, or SELECTED ARC panel of that object’s specification dialog. See 

Polyline Specification Dialog on page 323.

ROTATE/RESIZE ABOUT

Objects can be rotated about either their own centers or the current CAD point. See The Current Point on page 303.          

Rotate About Object Center Rotate About Object Center

You can specify which behavior is used by selecting Edit> Edit Behaviors> Rotate/Resize About Current Point . 

When this option is selected, objects rotate about the current CAD point; when it is not selected, object rotate about their 
centers.           

The Rotate/Resize About behavior can also be specified in the Preferences dialog. See Behaviors Panel on page 120.           

ENTERING COORDINATES

Objects can be rotated by entering coordinates or a distance and angle in the Enter Coordinates dialog. See Entering 
Coordinates on page 170.          

USING ANGULAR DIMENSIONS

Angular Dimensions are useful for adjusting the angles of a variety of objects with straight edges. See Angular 
Dimensions on page 478.         
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To change an angular dimension
 1.  Draw an Angular Dimension  between the objects you want to move.          

 l Begin and end as close as possible to the two objects you wish to locate.          

 2.  Select the edge that you want to move.          

 3.  Click the dimension value to open the Set Angular Dimension dialog.          

 l The Previous Value is indicated degrees, minutes and seconds.           

 4.  Enter a value in the New Value field.          

 5.  Select Rotate Edge to move the selected edge when OK is clicked or select Rotate entire polyline to rotate the 
entire object the selected edge is a part of, maintaining the Previous Value of the angle.          

 6.  Click OK to apply the change.          

When an entire polyline is rotated using the Set Angular Dimension dialog, it rotates around the vertex of the angle.           

MAKE PARALLEL/PERPENDICULAR WITH POLYLINE-BASED OBJECTS

The Make Parallel/Perpendicular edit button usually adjusts the angle of a selected polyline edge. See Make 
Parallel/Perpendicular on page 252.          

To rotate the entire polyline instead, double-click the Make Parallel  edit button to open the Make Parallel dialog.           

Choose to either Rotate Selected Edge Only, or Rotate Entire Polyline. This setting is global, affecting all files, and is 
retained during the current program session.           

Polylines rotate according to the current Rotate/Resize About setting. See Behaviors Panel on page 120.          

USING THE TRANSFORM/REPLICATE OBJECT DIALOG

Objects and groups of objects can be rotated to a relative or absolute angle using the Transform Replicate Object 
dialog. See Transform/Replicate Object Dialog on page 269.         

USING MULTIPLE COPY

A rotated array of copies of the selected object(s) can be created using the Multiple Copy edit tool. See To create an 
array of copies on page 176.         
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Reflecting Objects
There are several ways to reflect an object, group of objects, or an entire plan about an axis or another object. Either the 
original object(s) or copies of the original(s) can be reflected.         

REFLECT ABOUT OBJECT

A selected object or objects can be reflected about another object, regardless of its angle, using the Reflect About 
Object edit tool.         

Line-based objects are often used for reflecting a selection, but most objects have an axis that can be used.         

 l When an open or closed polyline-based object is used as the reflective object, the edge that is clicked on acts as the 
axis.         

 l When a circle or box-based object such as a CAD box or cabinet is used as the reflective object, the axis runs down 
the center of the object from back to front.         

 l In 3D views, architectural objects can only be reflected about a vertical axis - not a horizontal axis.         
 l A few objects, such as camera symbols, are not eligible to be used as a reflective object.         

To use Reflect About Object
 1.  Draw a CAD line to act as the reflection line.         

 2.  Select the object(s) to be reflected.         

 3.  Click the Reflect About Object  edit button.         

 4.  Move your mouse pointer over a CAD line, object edge, or other object that you would like to reflect the selection 
about.

 5.  When the mouse pointer is over a valid reflection axis, a preview of the selection to be pasted will display on the 
opposite side of the axis as the original.          

 6.  Click once when the preview meets your needs. The selection is reflected around the CAD line, and the original is 
no longer there.         

To retain a copy of the selected object(s) in the original location, click the Copy/Paste  edit button before clicking the 

Reflect About Object button. See To use Copy/Paste with other edit tools on page 174.         

USING TRANSFORM/REPLICATE OBJECT

Objects and groups of objects can also be reflected horizontally or vertically using the Transform Replicate Object 
dialog. See Transform/Replicate Object Dialog on page 269.         

REVERSE DIRECTION

Select a line-based, arc-based, open spline-based, or open polyline-based object and click the Reverse Direction edit 
button to reverse its direction. Not available for Terrain Path objects.         

Reversing an object's direction switches its Start and End points and can be useful with certain line styles or if the selected 
object has an arrow at one end. The Reverse Direction tool also reverses the direction in which a selected Walkthrough 
Path is recorded. See Walkthrough Paths on page 1204.
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REVERSE PLAN

The Reverse Plan tool reflects architectural and CAD objects on all floors of an entire plan, as though they were 
flipped about a vertical line. See Reverse Plan on page 151.

Note: Reverse Plan does not affect the Terrain objects. See Terrain on 
page 1249.

 

Converting Objects
CAD objects and many CAD-based objects can be converted into a variety of other types of objects.

CAD TO WALLS

CAD to Walls allows you to convert a 2D line drawing into a 3D model. Double CAD lines and arcs drawn to 
represent wall layers and other structural items can be converted to actual Chief Architect walls, railings, windows, or 

doors. See CAD to Walls on page 387.         

CAD DETAIL FROM VIEW

Select CAD> CAD Detail from View to create a CAD drawing of the current view. See CAD Detail from View on 
page 341.         

CAD Detail from View does not truly convert objects in the current view into CAD objects; instead, it creates a copy of the 
original view composed of CAD objects instead of architectural objects, leaving the original view intact.         

CONVERT POLYLINE

The Convert Polyline edit tool lets you turn CAD objects into CAD-based architectural objects such as countertops 
and stair landings, special polylines such as Materials List Polylines, and a variety of slab, hole and terrain objects.         

To convert a CAD object into one of these 3D objects, select the object               and click the Convert Polyline  edit button to 

open the Convert Polyline dialog.         

If the selected CAD polyline contains any holes, those holes will be converted to holes in the converted object, when 
appropriate. See Polyline Holes on page 234.           
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Click the radio button beside one of the objects in this dialog, then click OK. The options that are available will depend on 
whether a plan view is active or a cross section/elevation view.
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Architectural

The Architectural settings are only available if the selected polyline is closed. See Polylines on page 322.         

 l Slab and Slab with Footing - See The Slab Tools on page 731.          

 l Hole in Ceiling Platform - Only available when the selected polyline is contained inside a single ceiling platform. 
See Floor and Ceiling Platforms on page 433.         

 l Hole in Floor Platform - Only available when the selected polyline is contained inside a single floor platform.           

 l Hole in Roof/Custom Ceiling - Only available when the selected polyline is contained inside a single roof plane or 
ceiling plane. See Roof Hole/Skylight Specification Dialog on page 850.          

 l Tray Ceiling - See Tray and Coffered Ceilings on page 435.           

 l Countertop - See Countertops on page 637.         

 l Landing - Not available if the polyline is a spline. See Landings on page 765.          

 l 3D Solid - See 3D Solid on page 1016.         

 l 3D Solid Hole - See 3D Solid Feature on page 1018.   

 l Backsplash - Only available in cross section/elevation views. See Floor and Wall Material Regions on page 1037.         

  Moldings

 l Molding Polyline - See Molding Polylines on page 951.         

 l 3D Molding Polyline - See 3D Molding Polyline on page 952.         

 
Terrain

Most of the Terrain options are only available when a Terrain Perimeter is present.         

 l Elevation Line - See Elevation Lines on page 1254.           

 l Garden Bed - Only available when the selected object is a closed polyline. See Terrain Feature Tools on page 
1258.          

 l Sprinkler Line - See Sprinkler Tools on page 1307.          

 l Terrain Break - See Elevation Data Tools on page 1252.           

 l Terrain Feature - Only available when the selected object is a closed polyline. See Terrain Feature Tools on page 
1258.           

 l Terrain Perimeter - See Terrain Perimeter on page 1250. This option is only available when: the polyline is closed, 
a terrain perimeter does not yet exist, and only one polyline is currently selected.
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Roads

The Roads options are only available when a terrain perimeter is present. See Road Tools on page 1291 and Sidewalk Tools 
on page 1292.         

 l Road (Perimeter) - Only available when the selected polyline is closed.           

 l Road (Center Line) - Convert to a road where the polyline represents the center line of the road.          

 l Road Median - This is helpful for creating medians on curved roads.           

 l Road Marking (Perimeter) - Convert to a road marking where the polyline represents the perimeter of the road 
marking. Only available when the selected polyline is closed.          

 l Road Stripe (Center Line) - Convert to a road stripe where the polyline represents the center line of the road stripe.           

 l Sidewalk (Perimeter) - Convert to a sidewalk polyline where the polyline represents the perimeter of the sidewalk. 
Only available when the selected polyline is closed.          

 l Sidewalk (Center Line) - Convert to a sidewalk where the polyline represents the center line of the sidewalk.           

   Other

 l Walkthrough Path - See Walkthrough Paths on page 1204.          

 l Material Region - See Floor and Wall Material Regions on page 1037.         

 l Materials List Polyline - Only available when the selected object is a closed polyline. See Calculate From Area on 
page 1310.          

 l Revision Cloud - Only available when the selected object is a closed polyline. See Revision Clouds on page 328. 

 l Construction Line - Only available when the selected object is composed of a single line segment. See Construction 
Lines on page 65.         

 
Layer Options for Converted Object

The Layer Options for Converted Object let you control which layer the selected object is on once converted. See Layers 
on page 180.                  

 l Select Default Layer for Converted Object Type to put the object on the default layer for its type. That layer is 
reported in parentheses for reference.          

 l Select Same Layer as Original Object to keep the object on the same layer it was on before it was converted. That 
layer is also reported for reference.          

 l Select Specify Layer to select the desired layer from the drop-down list.          

 l Click the Define button modify the attributes of the selected layer. See Layer Display Options Dialog on page 183.          

Click OK to convert the object or objects.          

The specification dialog appropriate to the newly converted object opens, allowing you to specify its height, material and 
other information.          

CONVERT TO PLAIN POLYLINE

Click the Convert to Plain Polyline edit button to convert a special polyline-based object to a plain 2D CAD 
polyline. See Polylines on page 322.         

268



Chief Architect Premier X14 Reference Manual - Transform/Replicate Object Dialog

After a special polyline is converted into a plain polyline, it can be converted into a special polyline of the same or different 
type.          

Bear in mind that some special polylines can only be converted to a plain polyline in the view type that they were created 
in. If a special polyline is selected and converted in a 3D view, the resulting plain polyline will be created in plan view.          

CONVERT TO SOLID

Click the Convert To Solid edit button to convert the selected object into a Primitive object, or solid, so that it can 
be used with other solids to create complex structures. See Primitive Tools on page 1016.         

CONVERT TO SYMBOL

Create a 3D view of a custom object, then select Tools> Symbol> Convert to Symbol to convert the object into a 
symbol. See Convert to Symbol on page 1002.         

CONVERT TO SPLINE

Click the Convert to Spline edit button to convert CAD polylines as well as some CAD-based objects such as Slabs 
to spline-based objects. See Editing Spline-Based Objects on page 237.          

Unlike polylines, splines form smooth curves rather than angled corners where their direction changes. See Splines on page 
330. 

CONVERT SPLINE TO POLYLINE

Click the Convert Spline to Polyline edit button to convert the selected spline-based object into a polyline.         

A curved portion in a spline is represented as a number of smaller straight lines. You can change a spline into a normal 
polyline that is made up of these straight lines using this edit tool.          

 

Transform/Replicate Object Dialog
Select any object or group of objects and click the Transform/Replicate Object edit button to open the 
Transform/Replicate Object dialog.         

If multiple options are selected in the Transform/Replicate Object dialog, they are performed in the order they appear in the 
dialog, from top to bottom.         
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Always double-check values entered in the Transform/Replicate 
Object dialog. Large offset values, resize factors, or numbers of 

copies can result in objects that are time-consuming to create or may be 
off the screen. 
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Copy

Check Copy, then specify the Number of Copies to make.         
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Move

Check Move, then specify how far and in what direction to move the selected object(s).    

There are three ways to define where you want to move the selection in the horizontal XY plane:

 l Specify the desired X Delta and Y Delta values, which are the object’s changes in position along the X and Y axes.
Only available when the Relative to Itself or Relative to Current Point radio button is selected as the movement 
reference. See The Current Point on page 303.     

 l Specify the desired X Position and Y Position values, which define a point along the X and Y axes.
Only available when Absolute Location is selected as the movement reference. See 3D Drafting on page 12.     

 l Specify the Angle of movement and the Distance that you want the selection to move.     

 o Select Relative Angle to Itself to move the selection relative to its current orientation. When this option is selected, 
the selection's current absolute orientation is reported in the Angle field and can be changed.    

 o Select Absolute Angle to move the selection relative to an imaginary horizontal line drawn in the positive X 
direction from the origin.

When the X/Y Delta or X/Y Position settings are changed, 
the information in the Angle and Distance fields will update 

automatically, and vice versa.

You can also specify the Z Delta, which is the selection's elevation on the vertical Z axis. This setting is always relative 
to the selection's original elevation.

 
Rotate

Select this option, then specify the Angle to rotate the object(s).         

 l Select Absolute Angle to rotate the object relative to an imaginary horizontal line drawn in the positive X direction 
from the origin. 

 l Select Relative Angle to rotate the object the specified angle relative to its current orientation.
You can also specify the point the selected object(s) rotate about, below.          

 
Resize

Specify the Resize Factor in decimals. A resize factor of 2 doubles the size of the object, while a resize factor of 0.5 halves 
the object’s size. Not available for all objects, including line- and arc-based objects and Primitives.          
You can also specify the point the selected object(s) is resized about, below.          

 
Reflect

Select this option, then specify which axis to reflect about.         

 l Horizontally - Select this option to reflect the object horizontally.

 l Vertically - Select this option to reflect the object vertically.

You can also specify the point the selected object(s) is reflected about, below.          
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Rotate/Resize/Reflect About

This section is enabled when the Rotate, Resize and/or Reflect functions are selected.         

 l X Position - Specify the X coordinate of the point to perform the selected edit function(s) about when About 
Absolute Point is selected.

 l Y Position - Specify the Y coordinate of the point to perform the selected edit function(s) about when About 
Absolute Point is selected.

 l About Object Center - Select this option to perform the selected edit function(s) about the object’s center.

 l About Absolute Point - Select this option to perform the selected edit function(s) about the specified point.

 l About Current Point - Select this option to perform the selected edit function(s) about the current CAD point.

 

Edit Area Tools
The Edit Area Tools allow you to quickly define an area of your plan and select the objects in that area. Once 
selected, they can then be repositioned, copied or deleted. Select Edit> Edit Area to access the Edit Area Tools.

Unlike other selection methods, the Edit Area Tools cut walls, railing and fencing where the selection marquee intersects 
them, allowing you to edit only the selected portion of these objects. 

Some objects, such as cabinets, are included in the selection only if more than half of the object is contained within the 
marquee.  

Camera and cross-section/elevation symbols are included in the selection and can be moved with it. While cameras can also 
be rotated as well as copied, cross section/elevations cannot. See Editing 3D Views on page 1105. 

A few objects, notably CAD points, are not affected by the Edit Area Tools.

The Edit Area tools can cause wide-spread changes across an 
entire plan and should always be used with caution.

EDIT AREA

Select Edit> Edit Area> Edit Area and draw a rectangular marquee around the area of the plan to be edited. 

Edit Area affects all objects included in the selection marquee that are located on the current floor, regardless of whether 
they are displaying in plan view or not.

EDIT AREA VISIBLE

Select Edit> Edit Area> Edit Area Visible and draw a marquee around the area of the plan to be edited. 

Edit Area Visible only affects visible objects included in the selection marquee: objects not currently displayed in plan 
view are unaffected.

EDIT AREA (ALL FLOORS)

Select Edit> Edit Area> Edit Area (All Floors) and draw a marquee around the area of the plan to be edited. 
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Edit Area (All Floors) affects all objects on all floors of the plan that are included in the selection marquee, regardless of 
whether they display in plan view. 

EDIT AREA (ALL FLOORS) VISIBLE

Select Edit> Edit Area> Edit Area (All Floors) Visible and draw a marquee around the area of the plan to be 
edited. 

Edit Area (All Floors) Visible affects all visible objects on all floors of the plan that are included in the selection marquee. 
Objects not currently displaying in plan view are not affected.

EDIT AREA POLYLINE

If a rectangular marquee’s shape does not allow you to define an area precisely, use a closed polyline instead. 

Select a polyline that defines the desired area in plan view and then select one of the Edit Area Tools . The polyline 

becomes temporarily highlighted and acts as an Edit Area marquee. 

USING THE EDIT HANDLES

An Edit Area marquee displays edit handles that are similar to those of a closed polyline. See Using the Edit Handles on 
page 231.

 l Click the Move edit handle to move the entire selection set. See Moving Objects on page 245.
 l Click the Rotate edit handle to rotate the entire selection set. See Rotating Objects on page 261.
 l Click and drag the Reshape and Resize edit handles at each corner and along each edge to adjust the size and shape of 

the marquee. See Using the Edit Handles on page 231.

Adjusting the size or shape of an Edit Area marquee may change which objects are included in the selection set but does not 
otherwise affect those objects.

USING THE EDIT TOOLBAR

A selected Edit Area marquee and/or the objects within it can be edited in a variety of ways using the buttons on the Edit 
Toolbar.  See Using the Edit Toolbar on page 232. 

The following toolbar buttons may display on the Edit Toolbar for an Edit Area marquee:

  Copy/Paste copies the selection set to the system clipboard so it can be pasted elsewhere. See Copying and 
Pasting Objects on page 171.

  Delete deletes the selection set. See Deleting Objects on page 289.

  Transform/Replicate Object copies, moves, rotates, resizes, or reflects the selection set. See 
Transform/Replicate Object Dialog on page 269.

  Multiple Copy makes a series of copies of the selection set at regular intervals. Concentric copies are not 
possible using the Edit Area tools. See Multiple Copy on page 176.          

  Make Parallel/Perpendicular rotates the Edit Area marquee and the selection set so that the selected marquee 
edge is parallel or perpendicular to another straight edge. See Make Parallel/Perpendicular on page 252.           

  Point to Point Move accurately moves the selection between two points. See Point to Point Move on page 247.           

  Center Object centers the selection relative to another object. See Center Object on page 253.          
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  Reflect About Object reflects the selection set about another object. See Reflecting Objects on page 264.           

  Allowed Angles opens the Place at Allowed Angles dialog.           

PLACE AT ALLOWED ANGLES DIALOG

If more than one percent of the straight walls included in an Edit Area marquee are not at an Allowed Angle, the 
Allowed Angles edit button displays. 

Click the Allowed Angles edit button to display the Place at Allowed Angles dialog.          

Select the first option and click OK to rotate the plan so that the largest group of off-angle walls move to an Allowed 
Angle. This may place this largest group at Allowed Angles, but has two disadvantages.           

 l First, other groups of off angle walls remain off angle.           
 l Second, any walls that were at an allowed angle before this action will move to an off angle. The dialog shows how 

much (weighted by length) of the selected walls are in each category.           

Select the second option and click OK to add new entries to the Allowed Angles list and allow new walls to be placed at 
these angles. Walls already at Allowed Angles remain so. See Angle Snaps on page 166.          

Select the third option and click OK to do nothing, which is the same as clicking Cancel.          

You may want to rotate the majority of the walls to one of the normal allowed angles. Then, use an Edit Area  tool to 

select everything again and select the second option to provide new angle entries to cover the remaining walls.              

 

Stretch CAD
The Stretch CAD tool allows you to reshape or move a variety of CAD-based objects using a temporary closed 
polyline.          

To use the Stretch CAD tool
 1.  Select Edit> Stretch CAD .          

 2.  Click and drag to draw a rectangular polyline through the CAD objects that you would like to stretch.          

 3.  You can edit the shape of the Stretch CAD polyline so that it intersects the objects you want to stretch along the 
desired planes. See Editing Closed Polyline-Based Objects on page 230.          

 l An edge of the polyline must extend through each of the objects that you would like to stretch.          

 l The opposite polyline edge should be located outside those objects.          
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 4.  When the Stretch CAD polyline’s shape and position meet your needs, click and drag its Move edit handle.          

 5.  As you drag, intersected objects will either stretch, contract, or move.          

 l An edge of the polyline must extend through each of the objects that you would like to stretch.          
 l The opposite polyline edge should be located outside those objects.          

 1.  When the Stretch CAD polyline’s shape and position meet your needs, click and drag its Move edit handle.          

 2.  As you drag, intersected objects will either stretch, contract, or move.          

Not all CAD-based objects can be reshaped using the Stretch CAD  tool:          

 l Road and Text objects are examples of objects that can be moved but not reshaped by this tool.          
 l Stairs, Ramps, and Sun Shadows are examples of objects that are not affected by this tool at all.           

 

Trim and Extend
The Extend Object(s) and Trim Object(s) edit tools allow you to use the edge of a selected CAD-based 
object as a baseline for lengthening or shortening a variety of other CAD objects and framing members. See 

Editing Framing on page 897.         

When either the Extend Object(s) or Trim Object(s) edit button is clicked, its edit mode is enabled and three new edit 
buttons display on the Edit Toolbar:         

  Sticky Mode allows you to remain in the current mode and edit multiple objects or select multiple fences.           

  Click the Select Fence edit button, then click on an object to use it as a fence for selecting objects to either trim 
or extend. See Using a Fence on page 217.          

  Main Edit Mode or the Esc key returns you to the selected object’s main edit toolbar. If Sticky Mode is enabled 
when you click this button, it will still be enabled if you click either the Extend Object(s) or Trim Object(s) 

edit button after returning to the Main Edit Mode.           

Note: Trim Objects and Extend Objects cannot be used to modify closed 
polyline-based objects. See Editing Closed Polyline-Based Objects on 
page 230.

TRIM OBJECTS

Lines, arcs, open polylines, circles and framing items can be trimmed. The trimming, or cutting, object may be any 
CAD-based object, a group of CAD objects, or even a CAD block. Select the trimming object(s) and click the Trim 

Object(s) edit button.         

The Trim Object(s) edit tool can be used in three different ways:           

 l Individually clicking on objects to be trimmed.           
 l Selecting objects to be trimmed using a fence. See Using a Fence on page 217.          
 l Selecting objects to be trimmed using a temporary fence.          
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To trim by clicking
 1.  Draw the cutting line(s) or polyline(s) through the objects to be trimmed.          

 2.  Select the cutting line(s) and click the Trim Object(s)  edit button.          

 3.  Click the Sticky Mode  edit button if you wish to click multiple objects to trim them.          

 4.  Click each segment intersected by a cutting line one-by-one to trim it back to the cutting line.          

To trim using a fence
 1.  Draw the cutting line(s) or polyline(s) through the objects to be trimmed.          

 2.  Draw a fence through the object segments to be trimmed. Be sure that the fence intersects the objects on the side of 
the cutting line(s) that you want to edit. See Using a Fence on page 217.          

 3.  Select the cutting line(s) and click the Trim Object(s)  edit button.          

 4.  Click the Sticky Mode  edit button if you wish to trim objects using multiple fences.          

 5.  Click the Select Fence  edit button.          

 6.  Click the fence(s) to trim the object segments intersected by the fence.          

To trim using a temporary fence
 1.  Draw the cutting line(s) or polyline(s) through the objects to be trimmed.          

 2.  Select the cutting line(s) and click the Trim Object(s)  edit button.          

 3.  Click the Sticky Mode  edit button if you wish to trim objects using multiple temporary fences.          

 4.  Click and drag a temporary line to act as a fence, trimming the object segments intersected by it. Be sure to draw this 
fence on the side of the cutting object(s) that you wish to edit.          

EXTEND OBJECTS

Lines, arcs, open polylines, and framing items can also be extended to any CAD-based object, group of CAD objects, 
or CAD block.         

As with Trim Objects, there are three ways to use Extend Objects:           

 l Individually clicking on objects to be extended.           
 l Selecting objects to be extended using a fence.          
 l Selecting objects to be extended using a temporary fence.          

To extend by clicking
 1.  Draw the boundary line(s) or polyline(s)  you want the objects to extend to.          

 2.  Select the boundary line(s) and click the Extend Objects  edit button.          

 3.  Click the Sticky Mode  edit button if you wish to extend multiple objects.          

 4.  Click an object that you would like to extend to the boundary line(s).           
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To extend using a fence
 1.  Draw the boundary line(s) or polyline(s)  you want the objects to extend to.           

 2.  Draw a fence through the objects to be extended. See Using a Fence on page 217.          

 3.  Select the boundary line(s) and click the Extend Objects  edit button.          

 4.  Click the Sticky Mode  edit button if you wish to extend objects using multiple fences.          

 5.  Click the Select Fence  edit button.          

 6.  Click the fence to extend the objects segments intersected by the fence until they meet the boundary line(s).          

To extend using a temporary fence
 1.  Draw the boundary line(s) or polyline(s)  you want the objects to extend to.           

 2.  Select the boundary line(s) and click the Extend Objects  edit button.          

 3.  Click the Sticky Mode  edit button if you wish to extend objects using multiple temporary fences.          

 4.  Click and drag a temporary line to act as a fence, trimming the object segments intersected by it.          

 

Union, Intersection, and Subtraction
New closed polyline-based objects of varying shapes can be created based on the shapes of existing 
closed polyline-based objects using the Union, Intersection and Subtraction edit tools. See Editing 

Primitives and 3D Solids on page 1018.

The type of object that gets created by a Union, Intersection, or Subtraction operation depends on the types of objects that 
were involved in that operation:

 l If the original objects are of the same type, the new object that is created will also be of that same type. 
 l If the initially selected object is a CAD polyline and other objects are not, the resulting object will be a CAD polyline.
 l If the objects are of different types and a CAD polyline is not the initially selected object, the new object will be a 3D 

Solid.

Note: The Union Intersection and Subtraction edit tools are not available 
for objects specified as holes, such as Slab Holes or Custom Countertop 
Holes. 

UNION

Use the Union edit button to combine two or more closed polylines or solids into a single object.

The following example shows three closed polylines and the single polyline that results when the three are merged using the 
Union edit button. 
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Three separate closed polylines merges into a 
single object

There are two methods of combining closed polylines or solids using the Union edit button: the single selection and group 
selection methods. 

Begin by creating two or more overlapping objects of the same type. If one object is a countertop, for example, the others 
should be countertops, as well. 

If the original objects do not overlap, they will either not produce a new object or will be duplicated on top of themselves.

To use the single selection method
 1.  Select a single closed polyline or solid object. 

 2.  Click the Union  edit button.

 3.  Click another closed polyline or solid.

 4.  If the object is a polyline, a message box will let you choose to either retain or delete the original objects.

 5.  A new polyline of the same type as the originals is created and is selected. Its shape is defined by the boundaries of 
the original objects. If the original objects were retained, it is superimposed over them and can be moved.

To use the group selection method
 1.  Group-select two or more closed polylines or solid objects.

 2.  Click the Union  edit button.

 3.  If the object is a polyline, choose to retain or delete the original objects in the dialog that opens.

 4.  A new object of the same type as the originals is created, is selected, and is superimposed over the originals if they 
were retained.

This second method allows you to combine more than two polylines simultaneously. 

Note: If the original objects do not overlap, the Union edit tool duplicates 
them and then either deletes or retains the originals.

INTERSECTION

Use the Intersection edit button to create a single polyline based on the overlap area of two or more closed polyline-
based objects or solids.

The following shows two polylines and the single polyline that results when the Intersection edit tool is used. 
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A single polyline is created based on the 
space where two polylines overlap

There are two methods of combining closed polylines or solids using the Intersection edit button: the single selection and 
group selection methods. The second method allows you to work with more than two objects simultaneously. 

Begin by creating two or more overlapping objects of the same type. If one object is a countertop, for example, the others 
should be countertops, as well.

If the original objects do not intersect, no new object is created.

To use the single selection method
 1.  Select a single closed polyline or solid object. 

 2.  Click the Intersection  edit button.

 3.  Click another closed polyline or solid.

 4.  If the object is a polyline, choose to retain or delete the original objects in the dialog that opens.

 5.  A new object of the same type as the originals is created and is selected. Its shape is defined by the area shared by 
the original objects and, if the originals were retained, it is superimposed over them and can be moved.

To use the group selection method
 1.  Group select two or more closed polylines or solid objects. 

 2.  Click the Intersection  edit button.

 3.  If the object is a polyline, choose to retain or delete the original objects in the dialog that opens.

 4.  A new object of the same type as the originals is created, is selected, and is superimposed over the originals if they 
were retained. 

SUBTRACTION

Use the Subtraction edit button to subtract the area of one object that overlaps another object of the same type to 
create a third, new object. 
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A new polyline is created when the area 
defined by two overlapping polylines is 

deleted from one of them

There is one method for using the Subtraction edit button.

To use the Subtraction edit tool
 1.  Draw two or more closed polyline-based objects or solids that overlap. One object can be completely enclosed by 

another.

 2.  Select the object or objects that you want to remove a portion from. 

 3.  Click the Subtraction  edit button and then click the unselected object that defines the area you want to remove.

 4.  When prompted, choose to retain or delete the original objects in the dialog that opens.

 5.  A new object of the same type as the originals is created, is selected, and is superimposed over the originals if they 
were retained.

Note: If the original objects do not overlap, the Subtraction edit tool 
duplicates the first object selected and then either deletes or retains it.

 

Eyedropper and Painter Tools
There are a number of tools in Chief Architect that allow you to apply attributes to objects by clicking on them.    

 l The Eyedropper tools allow you to load attributes from one object and apply them to other objects.     
 l The Painter tools allow you to apply attributes to one or more objects. Depending on the tool, attributes may be loaded 

from another object using an Eyedropper tool or selected from a dialog.     
 l Some object attributes can also be replaced directly from the library. See To replace an inserted object on page 983.     
 l The  Match Properties  and Apply Properties  edit tools allow you to apply attributes from a selected object to 

other objects. See Matching Properties on page 286.    

Attributes cannot be either loaded from or painted onto objects on locked layers or on layers that are not set to display. They 
can be used to modify automatically generated objects such as roof planes and framing; however, the associated Auto 
Rebuild function will be turned off. See Auto Rebuild on page 170.     

EYEDROPPER TOOLS

The Eyedropper tools allow you to select attributes from one object and apply them to other objects. There are     four    
Eyedropper tools in the program:   
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  Material Eyedropper, see Material Eyedropper on page 1054

  Object Eyedropper, see Object Eyedropper on page 286

  Fill Style Eyedropper, see Fill Style Eyedropper and Painter Tools on page 197

  Layer Eyedropper, see Layer Painter, Eyedropper, and Hider on page 193

To use an eyedropper tool
 1.  Select the Eyedropper tool that you want to use and notice that the mouse pointer displays an eyedropper   icon.    

 2.  Move the mouse pointer over an object in the current view. If the object is eligible for use with the selected 
Eyedropper:     

 l It will become highlighted in the view.      

 l The left side of the Status bar will report information about that object or the attribute that the Eyedropper can load 
from it.      

 3.  Click once to load the object’s attributes so they can be applied to other, similar objects.    

 4.  Notice that your mouse pointer now displays a spray can   icon. This means that the Painter tool associated with the 
selected Eyedropper is now active.    

 5.  Depending on the tool in use, additional buttons may now display on the Edit Toolbar. Select the option or options 
that you need:    

 l The Painter Scoping Mode buttons. See Painter Scoping Modes on page 283, below.     

 l Blend Colors with Materials. See Material Painter Tools on page 1053.     

 l Select Properties to Paint . See Object Eyedropper on page 286.     

 l Toggle Library Replacement Mode . See Replace From Library on page 983.

 6.  Move your mouse pointer over an object that is similar to the one selected in step 2. If it is eligible to receive the 
loaded attribute(s):     

 l It will become highlighted in the view.      

 l The left side of the Status bar will report information about the attribute to be painted or loaded.      

 7.  Click on an eligible object to apply the specified     attributes to it as well as to any other identical objects, depending 
on which Painter Scoping Mode is active.    

 8.  Continue clicking to apply attributes until the Esc key is pressed or another tool is activated.    

PAINTER TOOLS

The Painter Tools let you apply attributes to a wide variety of objects by clicking on them. When a Painter tool is active, the 
mouse pointer will display a spray can   icon. There are a number of ways to load attributes into a Painter tool.   

 l Click on an object using any Eyedropper tool to load its attribute(s). The associated Painter tool will become active, 
ready to paint the loaded attributes.     
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 l Select a material      or fill style     in the Library Browser and move the mouse pointer into the current view window. If that 
item can be applied in the current view type, the associated Painter will be active and you can apply the selection to 
eligible objects in that view.    

 l When you select the Material Painter                   tool, the Select Material dialog will open, allowing you to choose a 

material from the library. See Select Material/Library Object Dialog on page 1057.     
 l When you select the Fill Style Painter  tool, the Select Library Object dialog will open, allowing you to choose a 

fill style from the library. See Select Library Object Dialog on page 982.
 l When you select the Layer Painter  tool, the Select Layer dialog will open, allowing you to choose a layer. See 

Select Layer Dialog on page 190.    
 l When you activate the Object Painter, click the Select Properties to Paint  button to open the Select Properties to 

Load dialog and select the attributes that you want to apply to other objects. See Matching Properties on page 286.    
 l When you select a Style Palette in the User Catalog of the Library Browser, the Style Painter tool will become active, 

ready to paint the specified attributes. See Style Palettes on page 284.     

Once a Painter tool is loaded, simply click on an object to apply the selected attributes. See To use the Material Painter tool 
on page 1053.   

PAINTER SCOPING MODES

There are five Painter Scoping Modes that control how broadly or narrowly a selected Painter tool will apply an attribute or 
attributes to objects in the current plan. These modes are listed in the same submenu as the associated Eyedropper and/or 
Painter tool. When a Painter tool is active, they are also found on the Edit Toolbar. In both locations, a small check mark 
will display at the lower left of the active Mode’s button icon. 

Depending on the type of object attributes have been loaded from, not all Object Painter Scoping Modes may be available.     
The Layer Painter does not have scoping modes: it always paints individual target objects one at a time.

Rather than modify instances of an object type, the Material Painter Scoping Modes replace instances of a material based on 
the selected scope.    

  Object Mode applies attributes to or replaces a material on individual target objects, one at a time. All instances 
of the original material on a target object are replaced by the one being painted.    

  Marquee Mode is available in plan view for the Style Palette Painter, Fill Style Painter, and Object Painter 
tools. In addition, it is available in CAD Detail views for the Fill Style and Object Painter tools. To use this 

mode, click and drag a marquee around the objects you would like to paint instead of clicking on them.    
  Room Mode applies attributes to a target object as well to as all instances of that object type in the same room 
with a single click. All instances of the original material throughout the room are replaced by the one being 

painted.    
  Floor Mode applies attributes to a target object as well as all instances of that object type on the same floor with 
a single click. All instances of the original material on the current floor are replaced by the one being painted.    

  Plan Mode applies attributes to a target object as well as all instances of that object type in the entire plan with a 
single click. All instances of the original material throughout the plan are replaced by the one being painted.    

  An additional mode, the Component Mode, is only available for the Material Painter and Adjust Material 
Definition tools. It is also available when replacing an inserted object with another from the library. See Material 

Painter Scoping Modes on page 1054, Adjust Material Definition on page 1059, and Replace From Library on page 
983.   
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Chief Architect will remember your Painter Scoping Mode selection until you quit the program. The next time you launch 
the program, Object Mode will be active.    

 

Style Palettes
A Style Palette is a collection of object properties that you can use to quickly change the appearance of doors, windows, 
cabinets, Custom Countertops and Backsplashes, any of these objects included in Architectural Blocks, and/or rooms in a 
plan as a group. These objects are referred to collectively as Style Palette Objects. Style Palettes can potentially modify a 
large number of object properties, allowing you to make considerable changes to a plan’s appearance very quickly. They can 
be used in plan view, but are particularly effective in camera views.           

Style Palettes are saved in the library, making them available for use in any plan. See Adding Library Content on page 973.          

To use the Style Painter
 1.  Select a Style Palette in the Library Browser. See Assigned Items on page 981.          

 2.  Move your mouse pointer into the active plan or camera view window and notice that it displays a spray can   icon.          

 3.  Select the desired Painter Scoping Mode:          

  Object Mode applies relevant properties to an individual Style Palette Object.          

  Marquee Mode applies relevant properties to Style Palette Objects located inside a marquee that you draw 
in plan view.          

  Room Mode applies relevant properties to all Style Palette Objects in a room.          

  Floor Mode applies relevant properties to all Style Palette Objects on the current floor level.          

  Plan Mode applies relevant properties to all Style Palette Objects in the current plan file.           

 4.  Apply the properties of the selected Style Palette to objects in the current plan:          

 5.  If you selected Marquee Mode, click and drag a rectangular marquee around the objects you that would like to apply 
the selected Style Palette’s properties to.           

 6.  For all other Painter Scoping Modes, click on a door, window, cabinet, Custom Countertop, Custom Backsplash or 
room surface to apply properties according to the active Painter Scoping Mode.          

CREATING A STYLE PALETTE

There are three ways to create a Style Palette:           

 l Select a door, window, cabinet, any combination of these objects, or a room, and click the Add Object(s) to Style 
Palette  edit button. In the Add to Style Palette dialog, click the Create New button. A new Style Palette with the 

selected objects loaded into it is created. The Add Object(s) to Style Palette edit button is also available in the 
contextual menu for Style Palette Objects in the Library Browser. See Using the Contextual Menus on page 965.          

 l Right-click on the User Catalog or a folder within it and select New> Style Palette from the contextual menu. A new, 
blank Style Palette is created.           

 l You can also create a copy of an existing Style Palette in the library and then customize it.           
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USING STYLE PALETTES

In order to apply a particular property using a Style Palette, two conditions must be met:           

 l The object saved in the Style Palette must have that property set in its specification dialog. The easiest way to do this 
is to select an object that has the desired attributes and then click the Add Object(s) to Style Palette edit button.           

 l The Style Palette must be set to apply that property when the Style Painter is used.           

You can make changes to both the properties of a Style Palette’s objects and which of those properties will be applied using 
the Style Painter in the Style Palette Dialog.          

While most object properties are eligible to be applied using Style Palettes, a few are not, for example: waterfall edges on 
Custom Countertops. In addition, interior and exterior door properties are only applied to doors of the same Type as the one 
in the selected Style Palette.          

STYLE PALETTE SPECIFICATION DIALOG

To open the Style Palette Specification dialog, right-click on a Style Palette in the User Catalog and select Open 
Object from the contextual menu. This dialog also opens when you create a new Style Palette or add an object to a 

Style Palette.           

 
Style Palette Name

Type a short, descriptive Style Palette Name in the text field.               

285



Chief Architect Premier X14 Reference Manual - Matching Properties

 
Objects in Style Palette

The Objects in Style Palette are listed in a table and can be managed here.             

 l Select an object type from the Add Object drop-down list. When all Style Palette Objects are already represented in 
the Style Palette, this option will not be available.           

 l Select an item in the Object column to display it in the preview pane to the right.          

 l Click in the Open Object column to open the specification dialog for the object in that row and make changes to its 
properties. See Specification Dialogs on page 21.          

 l When a check mark is present in the Use Object column for an object, its properties will be applied to objects of the 
same type when the Style Painter is used. When no check mark is present, objects of that type are unaffected when 
the Style Painter is used. Click in this column to add or remove the check mark for any of the objects in the table.           

 l Click in the Set Properties column to specify which of the associated object’s properties are assigned to objects 
when the Style Painter is used. See Select Properties to Load Dialog on page 287.          

 l Click in the Delete column to remove the object in that row from the Style Palette. A replacement can be added 
using the Add Item drop-down list if you wish.          

  Settings

 l When Only Apply Properties to Doors of Same Type is checked, door properties are only applied to doors of the 
same type as that added to the selected Style Palette. If the selected Style Palette's door is a Sliding door, for 
example, only Sliding doors will be affected when this Style Palette is used. Uncheck this box to apply door 
properties to doors of all types. See Door Tools on page 553.              

 
Preview

A preview of the selected Style Palette Object displays on the right side of the dialog. See Dialog Preview Panes on page 
22.    

 

Matching Properties
A variety of attributes can be copied from one object to another using the Object Painter tools. In addition, the Match 
Properties and Apply Properties tools allow you to identify and select similar objects, as well as copy attributes from one 
object to another.

OBJECT EYEDROPPER

Select Tools> Object Painter> Object Eyedropper to apply the attributes of one object to other objects. The Object 
Eyedropper functions like other Eyedropper tools. See To use an eyedropper tool on page 282.   

When the Object Painter is active, you can specify which attributes are loaded by clicking the Select Properties to Paint 
 edit button. You can also choose a Painter Scoping Mode to control how broadly or narrowly the selected attributes are 

applied to other objects. See Painter Scoping Modes on page 283.    

MATCH PROPERTIES

The Match Properties edit tool allows you to quickly select all objects in the current view that share the same set of 
specified attributes as the selected object. This tool is available in plan view and CAD Details only. 
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APPLY PROPERTIES

The Apply Properties edit tool can be used to apply the selected attributes to any other objects in the current view 
that do not yet share them. 

Apply Properties becomes available only after the Match Properties edit tool has been used to select a group of objects 
sharing the same attributes. 

To use the Match and Apply Properties tools
 1.  In plan view or a CAD Detail, select an object with attributes that you would like to apply to other like objects in the 

current view.

 2.  Click the Match Properties  edit button.

 3.  In the Match Properties dialog, check the box beside each attribute that you want to apply to other similar objects 
and click OK. See Select Properties to Load Dialog on page 287, below.

 4.  All objects sharing all of the specified attributes become selected. 

 5.  Click the Apply Properties  edit button, then either: 

 l Click on a like object that is not highlighted to apply the specified attributes to it and add it to the selection set. 

 l Click and drag a rectangular selection marquee. Any like objects within its area will receive the specified attributes 
and be added to the selection set.

 6.  You can continue clicking on objects until the Esc key is pressed or another tool is activated. 

SELECT PROPERTIES TO LOAD DIALOG

Select Tools> Object Painter> Object Eyedropper, click on an object, then click the Select Properties to Paint 
edit button.

The settings in this dialog are also found in the Match Properties dialog. To open this version of the dialog, select an 
object and click the Match Properties edit button.           

This dialog is also similar to the Set Properties dialog. To open this version, click a Set Properties button in the Style Palette 
Specification dialog. See Style Palettes on page 284.          
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Search

Filter the attributes that display in the list below by typing in the Search field.          

 l When all or part of a keyword is typed in the Search field, this list is divided into two categories: Found Properties 
which match your Search criteria followed by the remaining Other Properties.          

 l Click the Clear   button on the right side of the Search field to remove anything typed in this field.          

 
Properties

A list of the selected object’s Properties and the associated Values displays here. The available Properties vary, depending 
on the type of object selected.         

 l Check the box beside a Property to apply its Value to similar objects. In the Match Properties dialog, checking 
boxes also allows you to select objects that share the same attributes when you click OK.

 l Click the Select All button to select all Properties, regardless of whether they are shown in the list or filtered out.          

 l Click the Clear All button to deselect all Properties, regardless of whether they are shown in the list or filtered out.
         

 l Line items can also be group-selected and then checked or unchecked together. See Shift and Ctrl Select on page 
217.         

The Select and Clear Transferrable buttons are available in the Match Properties dialog only, and only when the Search 
field is empty, above.          

 l Click the Select Transferrable button to select all items that can be transferred to other objects. Non-transferrable 
properties are not selected.          

 l Click the Clear Transferrable button to deselect all items that can be transferred to other objects. Non-transferrable 
properties may remain selected.          

The Select and Clear Found buttons are available when there is text in the Search field.          

 l Click the Select Found button to select all items shown in the search results.          
 l Click the Clear Found button to deselect all items shown in the search results. 
 l In the Set Properties dialog only, click the Reset to Default button to reset the selected attributes back to the defaults.         
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A few Properties can only be used for selecting objects and cannot be loaded from one object to another. These Properties 
display in the Match Properties dialog followed by an asterisk but do not display in the Select Properties to Load dialog at 
all.          

 

Deleting Objects
Objects can be deleted in a variety of ways:

 l Select an object or group of objects, then: click the Delete  edit button; select Edit> Delete  from the menu; or 

press either the Delete or Backspace key on your keyboard.          
 l Entire categories of objects can be deleted using the Delete Objects dialog.         
 l Objects are deleted if the floor they are placed on is deleted. See Deleting Floors on page 748.         

If an object has a line with arrow attached to it, the line with arrow is deleted if the object is deleted. To prevent the arrow 
from being deleted, drag the attached end away from the object before deleting it. 

A variety of objects in the program can be generated automatically, including roofs, the foundation, and framing. 
Automatically generated objects cannot be deleted unless the automatic creation option is disabled.           

Objects such as roofs, framing, and Auto Exterior Dimensions that are set to automatically rebuild or refresh cannot be 
deleted while that behavior is enabled. Automatically generated objects cannot be deleted unless the automatic creation 
option is disabled.          

Although objects on locked layers cannot be selected, most can 
nevertheless be deleted using the Delete Objects dialog. 

DELETING POLYLINE EDGES

There are a number of different ways to delete individual edges of polyline-based objects:          

 l Select Connect CAD Segments . Select the edge and delete. See Disconnect Edges on page 214.          

 l Drag a corner handle until it overlaps an adjacent corner handle to remove the edge between them and merge them 
into a single handle.          

 l Create a complete break at both ends. Select the edge and delete. See To create a complete break on page 258.          
 l The Fillet Lines  and Chamfer Lines  tools can be used to delete polyline edges. See Reshaping Objects on 

page 257.          

DELETE SURFACE

In any 3D view, select 3D> Delete Surface, then click a surface in the view to temporarily remove the surface from 
the current view without permanently affecting the object. See Delete 3D Surface on page 1099.

 

Delete Objects Dialog
The Delete Objects dialog lets you delete categories of objects in a plan or layout file. Select Edit> Delete Objects to 
access this dialog. The settings in the dialog vary depending on whether a plan or a layout file is active:
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IN PLAN VIEWS

The Delete Objects dialog only deletes objects in plan view - it does not delete CAD objects or schedules drawn in cross 
section/elevation views or CAD Details. If this dialog is opened while a camera view is active, CAD objects and schedules 
cannot be deleted.

  Delete Scope

 l Choose All Floors to delete objects on all floors in the current plan.          

 l Choose All Rooms on This Floor to delete objects in all rooms on the current floor.         

 l Choose Single Room to delete objects only in rooms on the current floor that you specify.          

 l Click the Select All button to check all boxes in all categories.

 l Click the Clear All button to uncheck all boxes.

 
Objects

Specify which types of architectural Objects you want to delete.         
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CAD

Specify which types of CAD objects you want to delete. See CAD Objects on page 294.         

 
Framing

Specify which types of Framing objects you want to delete. See Framing on page 864.

 
Schedules

Specify which types of Schedules you want to delete. See The Schedule Tools on page 695.         

 
Walls

Specify which kinds of Walls you want to delete. See Walls, Railings, and Fencing on page 345.         

To use the Delete Objects dialog
 1.  Specify the Delete Scope as Single Room, All Rooms On This Floor, or All Floors.          

 2.  Click Select All to check all the boxes or Clear All to uncheck all boxes.         

 3.  Check the box for each category of objects you want to delete.          

 l Check the box beside any heading to select all of the categories within it; clear the box beside a heading to 
deselect all of its categories.         

 4.  Check the box for each subcategory of objects that you want to delete.         

 l If “Roof Planes” cannot be selected, they may be locked. See Editing Roof and Ceiling Planes on page 823.          

 5.  When the scope is set to Single Room:         

 l Move your cursor into the drawing area and click in a room of the plan to delete objects of the selected type 
within that room without closing the dialog.          

 l Only objects with their center point located in the room are deleted.          

 l Continue clicking on rooms or choose a different Delete Scope.         

 l Click Done when all selections have been deleted.          

Note: If you click in or try to switch to a view window other than the 
active view, the Delete Objects dialog will close. 

 6.  If you select All Rooms On This Floor or All Floors, you do not need to click in plan view. The Delete button 
becomes available, and clicking it closes the dialog and deletes the specified objects.          
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IN LAYOUT

  Delete Scope

 l Choose Current Page to delete objects from the current page of the layout file.

 l Choose All Pages to delete objects from all pages of the layout file and enable the additional scope options below.

 l Check Within Range specify which pages to delete objects from, then specify the page numbers, separated by 
commas or by a dash.

 l Specify which Page Types to delete objects from: check Template Pages to delete objects from Template pages, 
and/or, check Non Template Pages to delete objects from regular pages. See Page Templates on page 1339.

  Delete Options

 l Click the Select All button to check all boxes in both categories.

 l Click the Clear All button to uncheck all boxes.

 
Layout Objects

Specify which types of objects that you want to delete. See On the Layout Page on page 1342.   

 
Page Information

Specify the which types of Page Information that you would like to have cleared from the pages specified above. See Layout 
Page Information on page 1363.             
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Undo and Redo
The Undo and Redo commands allow you to both undo the last action performed, as well as redo actions that 
were recently Undone. 

Undo files are stored in the Undo Directory, which can be specified in the Preferences dialog. See Folders Panel on page 
111.    

The 50 most recent actions can be Undone or Redone, depending on your settings in the Preferences dialog. See General 
Panel on page 107. Actions that can be Undone and Redone include creating, editing, and deleting objects as well as the 
Delete, Rename, and Copy actions in the Project Browser.

The maximum number of Undo files is specified in the Maximum Undos value in the Preference settings. If you have 
Undo enabled, be sure to define a directory on a hard drive with enough space for these files.    

To Undo an action, select Edit> Undo, click the Undo  button, or press Ctrl + Z on your keyboard.

The Redo command is only available after Undo has been used. To Redo an Undone action, select Edit> Redo, click the 
Redo  button or press Ctrl + Y on your keyboard. 

It is important to note that Undo and Redo do not affect all actions in the program, including:

 l Save and Save As. See Saving Plan and Layout Files on page 40. 
 l Changes made in the Library Browser. See The Library Browser on page 962. 
 l Changes made in a dialog while the dialog box is open. See Dialogs on page 19.
 l Changes made to lights using the Adjust Lights dialog. See Adjust Lights Dialog on page 1137.          
 l Changes made to Note Types in the Note Type Management dialog. See Note Type Management Dialog on page 543.          
 l Changes made to the display by panning the display or zooming in or out. See Zoom Tools on page 157.
 l Changes made to the position of a camera, or its Rendering Technique. See Editing 3D Views on page 1105. 
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Chapter 10
 

CAD Objects

The CAD tools allow you to add details to 2D views of your design to create complete working drawings. Custom details 
can be created, saved, and used in other plans. 

CAD objects do not affect 3D objects or display in camera views or overviews, but they can be used to add details to layout 
pages, plan views and cross section/elevation views. 

CAD polylines can be converted to 3D objects such as countertops and terrain data, and shown in 3D views.  See Convert 
Polyline on page 265.          

CAD objects are edited much like other objects in Chief Architect. See Editing Objects on page 207.
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CAD Defaults and Preferences
CAD Defaults can be accessed by selecting Edit> Default Settings from the menu and expanding the CAD category.  

The behavior and appearance of CAD objects are also affected by settings on the CAD, LINE PROPERTIES, SUN 
ANGLE, BEHAVIORS, and SNAP PROPERTIES panels of the Preferences dialog. Unlike default settings, preference 

settings are global, affecting all plan and layout files. See Preferences Dialog on page 99.

REVISION CLOUD DEFAULTS

Settings in the Revision Cloud Defaults dialog determine the initial appearance of Revision Clouds. The settings in this 
dialog are similar to those in the Revision Cloud Specification dialog. See Revision Cloud Specification Dialog on page 328.           

Revision Clouds can support multiple Saved Defaults. In order to open the defaults dialog for this tool, you must first open 
its Saved Defaults dialog and choose an available saved defaults setup. See Multiple Saved Defaults on page 79.

CAD DEFAULTS DIALOG
The settings in the CAD Defaults dialog control the basic appearance of CAD objects. This dialog can also be opened 
by clicking the CAD Defaults button, which can be added to the toolbars. See To add a button to a toolbar on page 

137. 

Each plan file has multiple CAD Defaults dialogs: one affecting each floor level in all plan views, one for every cross 
section/elevation view, and one for every CAD Detail and Wall Detail. Each layout file has its own CAD Defaults, as well. 
The CAD Defaults associated with a given view can be accessed by opening the CAD Defaults dialog while that view is 
active.

The CAD Defaults dialog cannot be opened when a camera view or overview is active.          

Note: Although there are multiple CAD Defaults dialogs in each plan 
file, only one layer can be specified as the Current CAD Layer at any 
given time. When a new Current CAD Layer is selected, the change 
affects all views and view types.
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Current CAD Layer

Select the Current CAD Layer from the drop-down list. See Current CAD Layer on page 332.   

 l Click the Define button to open the Layer Display Options dialog. See Layer Display Options Dialog on page 183.          

 
Displayed Line Length Format Preview

Line Length Indicators report the length of the edges of some CAD-based objects and only display when Show Length is 
checked in an object’s specification dialog. See Line Style Panel on page 310.    

 l A preview of the format used by all Line Length Indicators in the current file displays here.

 l Click the Define button to open the Displayed Number Style dialog and edit the Displayed Line Length format.          

 
Display Line Angles as

Specify the format to use when Show Angle is checked in an object’s specification dialog. See Line Style Panel on page 
310.

Line angles can be displayed using three basic methods: 

 l Degrees/Minutes/Bearings - Measured counterclockwise from a line drawn horizontally to the right of the angle’s 
vertex. Useful for most drawing tasks. Select the level of accuracy that you require.

 l Quadrant Bearings - Measured from a vertical line representing North/ South, Quadrant Bearings use directional 
bearings in their measurements. Useful for site drawings.

 l Azimuth Bearings - Measured from a line drawn straight up from the angle’s vertex (i.e., North on a site plan). 
Useful for site drawings, Azimuth Bearings use degrees, minutes, and seconds in their measurements.

Line length and angle indicators use the Text Style of the layer 
that their object is on. See Text Styles on page 547.

 
Options

Select any combination of the available Options.

 l Check Show Arc Centers and Ends  to show arc centers and ends on the current floor. Ends display as small 

lines where arcs connect to one another. Centers also acts as snap points. See Arc Centers and Ends on page 225.         

296



Chief Architect Premier X14 Reference Manual - CAD Defaults and Preferences

DISPLAYED LINE LENGTH DIALOG

The settings in the Displayed Line Length dialog control the appearance of CAD line length indicators, when set to display. 
See Show Length and Angle on page 332.          

To access this dialog, click the Define button under the Displayed Line Length Format heading in the CAD Defaults 
dialog.           

Most of the settings here are also found in the Number Formatting dialog accessible from the Materials List. They are also 
similar to settings found on the DIMENSION FORMAT panel of the Room Label Defaults dialog and the FORMAT panels of the 
Dimension Defaults dialog. See Number Formatting Dialog on page 1326 and Primary Format Panel on page 465.          
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Format

Specify the numbering Format for CAD line length indicators. 

 l Select the Units of measurement to be used by line length indicators from the drop-down list.           

 l Check Unit Indicators to display the unit of measurement along with the dimension number.          

 l Check Leading Zeros to display the zero before a decimal less than 1 or to display 0’ or 0” when the ft-in or ’-” unit 
formats are used.           

 l Check Trailing Zeros to display trailing zeros at the end of decimal values.           

 l Check Thousands Separator to use a thousands separator for values greater than 999.           

 o Select the Use Comma or Use Dot radio button to use a comma or a dot as the thousands separator. See Region and 
Language Settings on page 78.          

 o Select the Use Space radio button to use a space as the thousands separator.           

 l Check Display as Inches to display dimension line indicators of sufficiently short segments in inches rather than the 
Unit selected above. This option is only available when the specified Unit is a form of either feet or yards, or a 
format that includes feet. Not available in the Number Formatting dialog.   

 l The Less than or equal to value specifies how short a segment must be before its number uses inches rather than 
the specified Unit.  Not available in the Number Formatting dialog.   

 l Select a Fraction Style from the drop-down list. This option affects the angle of the fraction's vinculum line.    

 l Specify the desired Fraction Text Size as a percentage of a selected dimension line's Number Height. Only available 
when either "Diagonal" or "Vertical" are selected as the Fraction Style.  Not available in the Number Formatting 
dialog.

 
Accuracy

Specify the degree of accuracy used by line length indicators.

 l Select the Decimal Places radio button for length indicators in decimal format. In the text field, specify the number 
of decimal places to use, from 0 to 20. If 0 is used, no decimal places are used.          

 l Select the Smallest Fraction radio button for length indicators using whole numbers and fractions. In the text field, 
specify the largest denominator to use, from 1 to 128. If 1 is entered, whole numbers are used. When Smallest 
Fraction is selected, the settings that follow are available:          

 o Uncheck Show Denominator to turn off the display of fraction denominators used by line length indicators. 
Denominators are typically only turned off when eighths are desired.            

 o Uncheck Reduce Fractions to always use the denominator specified above. When checked, the lowest possible 
denominator will be used and the two options below will be available.          

 o Select the Greatest Common Divisor radio button to reduce fractions using the largest value that divides equally 
into the numerator and the denominator specified above. This option is best for fractional inches.           

 o Select the Closest Fraction radio button to reduce fractions without referring to the denominator specified above. 
Not recommended when fractional inches are used.          

A value of 0.33333 is represented by the fraction 5/16 when Greatest Common Divisor is used and the Smallest Fraction 
denominator is 16. When Closest Fraction is selected, this value is represented by 1/3.           

 
Format Preview

A preview of the specified line length format displays here.    
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The CAD Drawing Tools
The following CAD Tools are available in the CAD menu and the toolbars.

POINT TOOLS

Select CAD> Points to access the Point Tools.         

The Place Point , Input Point , Point Marker , and Delete Temporary Points  tools can be used to create or 

remove snap points for a variety of purposes. See Point Tools on page 301.          

LINE TOOLS

Select CAD> Line to access the Line Tools.         

The Draw Line , Input Line , Line With Arrow , Sun Angle , and the North Pointer  allow you to 

create various types of lines. See Line Tools on page 305.          

ARC TOOLS

Select CAD > Arcs to access the Arc Tools.         

The Draw Arc , Input Arc , and the Arc With Arrow  tools allow you to create arcs. See Arc Tools on page 

315.          

BOX TOOLS

Choose CAD > Boxes to access the Box Tools.         

The Rectangular Polyline ,               Regular Polygon , Box , Cross Box , and Insulation  tools allow you to 

create a variety of polyline and box objects. See Box Tools on page 325.

CIRCLE TOOLS

Select CAD> Circles to access the Circle Tools.

The Circle , Circle About Center , Oval , and the Ellipse  tools are discussed in detail later in this chapter. 

See Circle Tools on page 320.

REVISION CLOUD

Select CAD> Revision Cloud, then click and drag to draw a rectangular shape with edges that display a series of 
arcs. See Revision Clouds on page 328.         
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SPLINE

A Spline is a curve that passes smoothly through a set of points. Select CAD> Spline to draw connected line 
segments that form a spline. See Splines on page 330.

Once created, a spline can be selected and edited. See Editing Spline-Based Objects on page 237 and Polyline Specification 
Dialog on page 323.

DIMENSION TOOLS

Select CAD> Dimensions or CAD> Automatic Dimensions to access the manually drawn and Automatic 
Dimension Tools. The Dimension Tools can be used with CAD and architectural objects and are discussed in their 

own chapter. See Dimensions on page 454.

TEXT TOOLS

Select CAD> Text to access the Text Tools. The Text Tools are discussed in their own chapter. See Text, Callouts, 
and Markers on page 501.

CURRENT CAD LAYER

Select CAD> Current CAD Layer to change the current default CAD layer. See Current CAD Layer on page 332.         

AUTO DETAIL

Select CAD> Auto Detail while a cross section view is active to automatically generate CAD objects for commonly 
detailed structural components. See Auto Detail on page 1095.         

 

Point Tools
Select CAD> Points  to access the Point Tools.         

Temporary points created using the Place Point  and Input Point  tools and permanent Point Markers  can be 

used with Object Snaps  to accurately position a variety of objects. See Object Snaps on page 164.           

The size of temporary points is specified in the Preferences dialog. See Snap Properties Panel on page 122.          

PLACE POINT

Select CAD> Points> Place Point, then and click in the drawing area to place a temporary CAD point at that 
location. Temporary CAD points can be used for a variety of purposes: for example, as an anchor for snapping 

objects to a precise location  The Current CAD Point can be used for additional tasks. See The Current Point on page 303.         

INPUT POINT

Temporary CAD points can be placed with precision by entering coordinates. See 3D Drafting on page 12.         
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To use the Input Point tool
 1.  Select CAD> Points> Input Point  to open the New CAD Point dialog.              

 2.  Select a Location option, and enter the desired location of the point.              

 3.  Click OK to close the dialog and create the new point. The new point becomes the Current Point and is highlighted. 
See The Current Point on page 303.              

 4.  Alternatively, click Next to create the new point but remain in the New CAD Point dialog and create additional 
points. As each is created, it becomes the Current Point.              

NEW CAD POINT DIALOG

 
Current Point

The location of the Current Point displays here. If no CAD points are present, the origin (0, 0) displays. See The Current 
Point on page 303.         

 
New Point

Specify the location of the New Point.

 l Absolute Location - Define the point in X Position (horizontal) and Y Position (vertical) coordinates, relative to 
the origin at (0,0).              

 l Relative to Current Point - Define the new point in X and Y coordinates that are relative to the Current Point, as 
though that point was at (0,0). Only available when a Current Point exists.               

 l Check Polar to define the new point by its Distance and Angle from the Current Point rather than in X and Y 
coordinates. This is helpful when creating a plot plan. See Plot Plans and Plan Footprints on page 1251.              

The position of the New Point is defined here. The options available depend on the method chosen to define it, above.          

 l X Position and Y Position coordinates relative to (0,0) are entered if the Absolute Location method is specified.              

 l X Position and Y Position coordinates relative to the Current Point are entered if the Relative to Current Point 
method is specified.              

 l Distance and Angle from the Current Point are entered if the Relative to Current Point: Polar method is specified.             

 l Click Next to create the new point without exiting the dialog so you can input data for the next point. The newly 
created point becomes the Current Point.              
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Click the Number Style button to change the units used in 
dialogs. See Dialog Number/Angle Style Dialog on page 131.

POINT MARKERS

Use a permanent Point Marker as a snap point for dimension lines and other CAD objects. Select CAD> Points> 
Point Marker and click in the view to place a permanent point marker. Point markers display as a simple cross, with 

or without a text label. They can be opened for specification and modified to include a label or alter their attributes.         

You can also place Point Markers using the Marker  tool, which lets you specify the marker label and type. See 

Markers on page 538.          

Point Markers are also created when the Point to Point Dimension  tool is used or when a dimension line is copied and 

pasted independent of the objects it locates. See Point to Point Dimensions on page 478.           

DELETE TEMPORARY POINTS

All temporary points in the current view can be deleted at once using CAD> Points> Delete Temporary Points. In 
plan view, Delete Temporary Points will delete all temporary points on all floors.         

You can also press the Delete key when nothing is selected to delete the points one by one; however, Delete Temporary 
Points  can save time when there are many points.           

THE CURRENT POINT

In any view and on any floor, there may be multiple temporary CAD points. The Current Point is either the most recently 
created or most recently selected temporary CAD point. The Current Point has a variety of uses:          

 l As the starting point for objects as they are drawn by entering data. See Entering Coordinates on page 170.               
 l As the point about which objects are rotated. See Rotating Objects on page 261.               
 l To indicate the points at which roof planes can join. See To find roof plane intersection points on page 827.              

When multiple temporary points are on-screen, the Current CAD Point is highlighted so it can be easily identified.           

To delete the Current Point
 1.  Make sure no other objects are selected by clicking the Select Objects  button. You can also press the Esc key to 

deselect any selected objects.           

 2.  Press the Delete key on the keyboard to delete the Current Point. The temporary point created prior to this one 
becomes the new Current Point.           

 3.  If you continue pressing the Delete key, temporary points will be deleted in the reverse order that they were created.          

MOVE POINT DIALOG

A CAD Point can be repositioned relative to itself, another point, or a CAD object such as a line using the Move Point 
dialog. When a Point is moved, it becomes the Current Point.          

For example, you can locate the point exactly one-quarter the distance along a given line, or exactly 6 inches from one end. 
This new location can then be used for the start point of a new line or other purpose.          
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To reposition a CAD Point, double-click on it using the Select Objects  tool. That point becomes the Current Point, and 

the Move Point dialog opens.          

 
Current Location

The Current Location of the selected point displays at the top of the dialog for reference.         

 
New Location

Specify the New Location of the point.

 l Absolute Location - Define the new location in X (horizontal) and Y (vertical) Position coordinates, relative to 
the origin at (0,0).          

 l Relative to Itself - Define the new location in X and Y Position coordinates relative to the current location, as 
though that point were the origin.            

 l Relative to Previous Point - Define the new location relative to the point that was the Current Point prior to this 
one, as though that point was the origin. Only available if the selected point is located on a CAD object.          

 l Check Polar to define the new location’s Distance and Angle from the previous point instead of using X and Y 
coordinates. Only available if Relative to Itself or to Previous Point is selected above.          

 l Along Line - Define the new location relative to the edge of a nearby CAD object. This option is enabled only 
when the point is located near a CAD object and refers to the end nearest to the point’s original location.           

 l Check Percentage (%) to specify the Along Line value as a percentage of the total line or arc length rather than as 
a distance. 0% moves the point to the closest end of the nearest edge, 50% to the midpoint, and 100% to the other 
end. Negative numbers and percentages greater than 100 are allowed.           

 l Specify the new position of the point here. The options here depend on the method chosen to define the New 
Location.          

 l X Position and Y Position coordinates are entered if the Absolute Location method is specified or if either 
Relative method is used with Polar unchecked.          

 l Distance and Angle are entered if either Relative method is specified when Polar is checked.          
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 l From Edge - When the Along Line method is used, specify the distance of the point’s New Location to the end of 
the CAD object’s edge that it was originally closest to. When Percentage (%) is checked, enter this value as a 
percentage instead.          

If the point is near an arc, Along Line is measured along the curve.          
If the point is near a box or polyline, Along Line is measured along the nearest side just as it does with an individual line 
or arc.           
If the point is near an oval or circle, Along Line is measured along an (invisible) axis line that the item was originally 
drawn along.          

Click the Number Style button to change the units used in 
dialogs. See Dialog Number/Angle Style Dialog on page 131.

 

Line Tools
Select CAD> Draw Lines to access the Line Tools.

If Object Snaps  and Connect CAD Segments  are enabled, you can connect the ends of multiple lines and/or arcs 

to form a single entity called a polyline. See Polylines on page 322.   

DRAW LINE

There are three methods that you can use to draw lines with the Draw Line tool. The standard method is to select 
CAD> Lines> Draw Line, then click and drag from beginning to end.          

An alternative method that allows you to draw multiple lines is also available. See Alternate on page 209.          

To draw continuous lines
 1.  Select CAD> Lines> Draw Line .             

 2.  Press the Alt key on your keyboard (or use the right mouse button) and click and drag to draw a line. You can also 
toggle to alternative mode.             

 3.  Move your cursor to a new location in the drawing area and click once. A new line is drawn beginning at end of the 
previous line.             

 l Provided that Connect CAD Segments  is toggled on, a polyline will be formed. See Connect CAD Segments 

on page 212.                 

 4.  To stop, press Esc on your keyboard or press two mouse buttons at the same time.             

By default, this continuous drawing behavior will turn off when a closed shape is created. You can specify that this behavior 
remain on in the Preferences dialog. See Behaviors Panel on page 120.         

In addition, you can select a line style in the Library Browser and then click and drag in the drawing area to draw lines 
using that line style. See  Line Styles on page 200.         

If you double-click the Draw Line tool, the Input Line dialog 
will open. 

305



Chief Architect Premier X14 Reference Manual - Line Tools

INPUT LINE

CAD lines can also be created using absolute values entered with the keyboard by selecting CAD> Lines> Input 
Line. This method is slower but more precise than using the mouse and is ideal when the desired length and angle of 

each line is known, such as with property lines.         

Before any line is drawn using this method, a starting point must be defined. If a starting point has not been defined, Chief 
Architect assumes a starting point of 0,0.         

To use the Input Line tool
 1.  Select CAD> Points> Place Point , then click the screen to place a CAD point. This is the Current Point, and is 

the start point for the new line. See The Current Point on page 303.         

 2.  Select CAD> Lines> Input Line  to open the New CAD Line dialog. This dialog can also be opened by double-

clicking the Line Tools  parent button.         

 3.  If necessary, specify the start point.         

 4.  Specify the method used to define the location of the End Point, then define the End Point.          

 5.  Click OK to close the dialog and draw the line, or click Next to draw the line but remain in the New CAD Line 
dialog and draw additional lines.         

Note: If you accidentally click OK instead of Next and need to continue 
drawing a polyline using the New CAD Line dialog, select the Input Line 
tool again and continue.

NEW CAD LINE DIALOG

 
Start Point

The X Position (horizontal) and Y Position (vertical) coordinates of the start point for the new line display here. They can 
also be changed, if you wish.         

 
End Point

The new line’s End Point is defined here. Begin by specifying how you want to define the line End Point Location.         
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 l Absolute Location - Define the end point of the new line in X Position (horizontal) and Y Position (vertical) 
coordinates, relative to (0,0).         

 l Relative to Start Point - Define the end point of the new line in X and Y coordinates that are relative to the line’s 
Start Point, as though it were at (0,0).         

 l Check Polar to define the End Point of the new line by its Distance and Angle from the Start Point rather than in 
X and Y coordinates. This is helpful when creating a plot plan. See Plot Plans and Plan Footprints on page 1251.         

 l Relative to Previous Line - Define the End Point of the new line by its Distance and Angle relative to the end of 
the last line drawn, as though that line’s angle were at 0° and its End Point, at  (0,0).          

 l X Position (horizontal) and Y Position (vertical) coordinates relative to (0,0) are entered if the Absolute Location 
method is specified.         

 l X Position (horizontal) and Y Position (vertical) coordinates relative to the start point are entered if the Relative to 
Start Point method is specified.         

 l Distance and Angle from the start point are entered if the Relative to Start Point: Polar method is specified.         

 l Distance and Angle from the start point are entered if the Relative to Previous Line method is specified.         

 l Click Next to create the line without exiting the dialog so you can input data for the next line. The start point of 
the next line is the end point of this line.         

Click the Number Style button to change the units used in 
dialogs. See Dialog Number/Angle Style Dialog on page 131.

To enter an angle in bearings
 1.  While not required, you may want to select Quadrant or Azimuth Bearings in the Dialog Number/Angle Style 

dialog.          

 2.  For Quadrant Bearings, begin by typing  N or S (for North or South).         

 3.  Next, type the number of degrees followed by either a  letter d or a space.          

 4.  Type the number of minutes followed by either a ‘ or a space.          

 5.  Type the number of seconds followed by either a “ or a space.          

 6.  Finally, for Quadrant Bearings, type either E or W (for East or West).           

Following are some examples of Quadrant Bearings. It is not necessary to capitalize the letters. Spaces after each value are 
optional.          

 l N 20d 30' E         
 l S 45' W         
 l N 89d 48' 30" W         
 l N 90' E         

ENTER COORDINATES

Similar to Input Line, lines can also be specified by pressing the Tab key on the keyboard when a line is in the process of 
being drawn. This opens the Enter Coordinates dialog. See Entering Coordinates on page 170.         
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LINE WITH ARROW

Create a line or polyline with an arrow on one or both ends by selecting CAD> Lines> Line With Arrow, then 
clicking and dragging in the drawing area. The initial attributes of the line’s arrow are set in the Arrow Defaults 

dialog. See Arrow Defaults on page 503.          

As with other lines, lines with arrows can be edited after they are created and connected to form polylines provided that they 
share the same  layer and style attributes. See Editing Line-Based Objects on page 218 and Line Specification Dialog on 
page 309.         

You can also create arcs with arrowheads. See Arc with Arrow on page 317.         

If either end of a Line with Arrow is snapped to an object, it 
maintains its connection if that object is moved. See Text Arrows 

on page 528. 

CONSTRUCTION LINE

The Construction Lines tool allows you to create guide lines to help locate features of a design and ensure that 
objects are correctly aligned in plan view and cross section/elevation views. See Construction Lines on page 65.

SUN ANGLE

Sun Angles let you specify the date, time, latitude, and longitude that the program uses when calculating the angle of 
the Generic Sun as well as the direction and length of sun shadows. See Sun Angles and Shadows on page 1140.         

NORTH POINTER

The North Pointer tool is used to define the direction of true north in a plan. The direction of north does not affect 
the orientation of the Snap and Reference grids, but it does determine the direction of bearing information as well as 

how shadows and conditioned area totals are calculated. See North Pointer on page 1140.    

If a North Pointer is not used, north is assumed to be straight up on screen in plan view.     

DISCONNECT EDGES

Select CAD> Lines> Disconnect Edges, then click on the edge of a polyline-based object to disconnect that edge 
from the rest of the polyline. See Disconnect Edges on page 214.         

When Connect CAD Segments  is toggled off, CAD objects will not join to form a single polyline, either as they are 

drawn or when edited. See Polylines on page 322.          

LINE STYLE MANAGEMENT

The Line Style Management dialog allows you to manage the line styles saved in the current plan or layout file. 
Select CAD> Lines> Line Style Management to access this dialog. See Line Style Management on page 200.         

SAME LINE TYPE EDIT HANDLES

A new CAD line can also be drawn using the Same Line Type edit handles on an existing CAD object. The start point of 
the new line is located at one end of the existing object and shares its line color, weight, style, and its layer. If the object has 
an arrow, its attributes are also inherited. See Line Style Panel on page 310 and Arrow Panel on page 312.   
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The Same Line Type edit handles are available for CAD lines, arcs, open polylines, and splines, but not for closed CAD 
shapes or CAD-based architectural objects. They can be turned off in the Preferences dialog if you wish. See CAD Panel on 
page 117.    

When Connect CAD Segments  is disabled, the new CAD line will snap to the existing object, forming an open 

polyline or spline. When Connect CAD Segments is enabled, on the other hand, the two will remain separate objects.   

 

Line Specification Dialog
Select a CAD Line, Line With Arrow, or Text Line With Arrow and click the Open Object edit button to open the 
Line Specification dialog. 

The settings on the panels in this dialog are found in the specification and defaults dialogs for a variety of different objects 
in the program.

The Line Specification dialog has the following panels:

LINE PANEL

The information on the LINE panel of the Line Specification dialog is similar to that found on the SELECTED LINE panels of 
various specification dialogs in the program.

309



Chief Architect Premier X14 Reference Manual - Line Specification Dialog

 
Lock

These lock options control how changing properties on this dialog affect the line.

 l Select Start to keep the start of the line fixed when changing the length, angle, and end.          

 l Select End to keep the end of the line fixed when changing the length, angle, and start.          

 l Select Center to keep the center of the line fixed. Changing the length of the line moves the start and end of the line 
equally. Changing the angle rotates the line around the center.          

 l Select Length/Angle to keep the length and angle of the line segment fixed. Moving the start or end moves the other 
end so the length and angle of the line do not change.          

When editing a polyline, moving the Start of a line segment moves the end of the previous connected line, if there is one. 
Similarly, moving the End of a line segment moves the start of the next connected line, if there is one.           

 
Length/Angle

Specify the Length and Angle of the selected line.

 
Start Point

Specify the X and Y coordinates of the line’s Start Point. Not available when the Start or Center Point is locked.

 
End Point

Specify the X and Y coordinates of the line’s End Point. Not available when the Center or End Point is locked.

The format used here can be changed by clicking the Number Style button. See Dialog Number/Angle Style Dialog on page 
131.          

LINE STYLE PANEL

The LINE STYLE panel is found in the specification dialogs for many different objects. The settings here control the 
appearance of the lines and/or arcs that make up an object. Depending on the type of object selected, some settings may not 
be available. The available settings vary slightly depending on whether the object was drawn in a plan or a layout file. See  
Line Styles on page 200.
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  Line Options

 l Check Show Border to display a border around the selected Picture file. Not available for other object types. See 
Pictures on page 1187.           

 l Specify the Layer that the selected object should be located on. Check Default to use the default layer for the 
selected object’s type or choose a layer from the drop-down list. If the selected object is an automatically generated 
dimension line, frieze molding, or shadow board that has been edited, Default will be unchecked.           

 l Click the Define button to open the Layer Display Options dialog. See Layer Display Options Dialog on page 183.          

 l Specify the line Color used to represent the selected object. Check By Layer to use the color assigned to the 
object’s layer or click the Color bar to select a different color. See Color Chooser/Select Color Dialog on page 204.          

Mouse over the Color bar to display a tool tip reporting the 
selected color’s RGB values. 

 l Specify the line Style used to represent the selected object. Check By Layer to use the line style assigned to the 
object’s layer or click the drop-down list               or Library button to select a different style. The items in the drop-down 
list can be managed in the Line Style Management dialog. See Line Style Management on page 200.

 l Define the Line Weight or check By Layer to use the Line Weight assigned to the object’s layer. See Line 
Weights on page 1379.          

Setting the line weight to zero makes the line weight print as 
thin as possible.
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Bumping

Specify the desired Bumping behaviors for the selected object(s). These options are not available for Wall Material Regions 
and only function when Bumping/Pushing is enabled. See Bumping/Pushing on page 246. 

 l Check CAD Stops Move to bump the selected object into other CAD or CAD-based objects as it is moved, and/or to 
push the other object(s).           

 l Check Wall Stops Move to stop the selected object when it bumps into a wall. Walls cannot be pushed by other 
objects. Not available in layout files.          

 
Drawing Group

Specify which Drawing Group the selected object(s)  is in. These options are not available in camera views. See Drawing 
Groups on page 194. 

 
Display Options

Select the desired Display Options. These options not available for CAD Box- or CAD Circle-based objects, or for 
Primitives, 3D Solids, Material Regions, North Pointers, or Sun Angles.

 l Check Show Length to show the length of each line centered above the line.           

 l Check Show Angle to show the angle of each line centered below the line. If the object is an arc, its radius will also 
display. 

The Length and Angle formats are specified in the CAD Defaults dialog. See CAD Defaults Dialog on page 295.          

 l Uncheck All Angles to show only those angles that are neither horizontal nor vertical. This is automatically checked 
when Show Angle is checked.           

 l Check Reverse Angle to reverse the angle by 180°. This may be helpful when showing a line’s bearing, since the 
direction a line is drawn from start point to end point defines its bearing.          

An additional Display Options setting is available In the Picture File, Metafile, and PDF File Box Specification dialogs. 
See Pictures, Images, and Walkthroughs on page 1180.          

 l Check Show Outline to display the selected object’s border polyline.           

 
Layout Page

Specify the layout page that the selected object(s) is located on. Only available for objects drawn in layout files, but not in 
defaults dialogs for objects such as callouts and markers. See Layout on page 1338. 

ARROW PANEL

The ARROW panel is available for any line, arc, open polyline, or spline that can have an arrow: including dimension lines. 
The defaults for arrows are set in the Arrow Defaults dialog. See CAD Defaults and Preferences on page 295 and 
Dimension Defaults Dialog on page 457. 

A similar SECTION ARROW panel can also be found in the Callout Specification and Callout Label Specification dialogs. See 
Callout Specification Dialog on page 535.

A line, polyline, or spline with an arrow can be attached to other objects. It attaches to a closed polyline-based object along 
its edges, but can attach to an architectural object anywhere within its 2D symbol in plan view. If an arrow is attached to 
another object, deleting that object will also delete the arrow. 

Some objects, notably Joist Direction Lines, do not have the Attach or Auto Position settings. Other objects, including 
closed polylines, Sprinkler Lines and Electrical connections are examples of objects that cannot have arrows at all.
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 l Check Include Arrow to apply an arrow to the tail end of the selected object and enable the settings that follow. If a 
selected Callout does not have a Cross Section Line specified, one will be created.         

 l Select an arrowhead Style from the drop-down list or check Default to use the default arrowhead. Arrowheads with a 
white center have a transparent fill. Arrowhead styles that draw perpendicular to the line are positioned at a positive 
90° angle relative to the line's direction.         

 l The arrowhead's Fill Color displays in the Color bar. Click the bar to specify a custom color. See Color 
Chooser/Select Color Dialog on page 204.
 l Select Default Fill Color to use the fill color specified in the Arrow Defaults or Callout Defaults dialog.
 l Select Match Line Color to use the color specified on the LINE STYLE panel. See Line Style Panel on page 310.
 l Custom Color is selected automatically if you click the Color bar above.     

 l Specify the arrowhead's Size, measured from its front to its back.               The Default Size value also affects the size of the 
start circle for Running Dimensions . See Running Dimensions on page 479.

The options that follow are not available for Callout Section Arrows:
 l Check Arrow on Both Ends to place an arrowhead on both ends of the selected object.          
 l When Attach Tail to Other Objects is checked, the tail end of the arrow will attach to another object when snapped 

to it, and will maintain its attachment if the object is moved. When this is checked and the arrow is selected, its tail 
end edit handle will display the Selected Edge Handle Fill color.          

 l Check Auto Position Tail to have the tail end update its position on the object it is attached to if either object is 
moved. See Auto Position Arrows on page 529.          

 l When Attach Head to Other Objects is checked, the head of the arrow will attach to another object when snapped to 
it, and will maintain its attachment if the object is moved. When this is checked and the arrow is selected, its arrow 
end edit handle will display the Selected Edge Handle Fill color.          

 l Check Auto Position Head to have the arrow end update its position on the object it is snapped to if either object is 
moved.           

 

Drawing Arcs - Arc Creation Modes
There are five Arc Creation Modes that control how arcs and arc-based objects are drawn. Each mode allows you to 
specify a different aspect of the arc, such as its radius or tangent. Select Edit> Arc Creation Modes to select a 

mode.         
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The program remembers the last creation mode used between sessions. Once drawn, all arcs are edited similarly. See 
Editing Arc-Based Objects on page 221.          

Before deciding which Arc Tool or Arc Creation Mode is best for the project at hand, it is helpful to be familiar with the 
different components that make up an arc.          

A. Center - the point the arc is drawn about.          
B. Radius - the distance from the center to 
the arc.          
C. Start / End - where the arc begins and 
ends.          
D. Chord - the straight line between the start 
and end point.          
E. Tangent - a straight line that intersects an 
arc and is perpendicular to the radius of the 
arc at that point.

FREE FORM ARC

Free Form Arc mode allows you to define an arc by clicking and dragging along the desired path. There are two 
methods for using this mode.

To draw a Free Form arc
 1.  Select CAD> Arcs> Draw Arc , then click at the arc’s start point.           

 2.  Move the pointer along the desired curve while dragging to curve the arc.          

 3.  Release the mouse button at the end point to complete the arc.           

To draw continuous Free Form arcs
 1.  Select CAD> Arcs> Draw Arc .          

 2.  Press the Alt key on your keyboard and click and drag to draw an arc.           

 3.  Move your cursor to a new location and click. A new arc is drawn that is connected to the end point of the previous 
arc.          

By default, this continuous drawing behavior will turn off when a closed shape is created. You can specify that this behavior 
remain on in the Preferences dialog. See Behaviors Panel on page 120.          

CENTER/RADIUS/END ARC

Center/Radius/End Arc mode allows you to define the center and radius of an arc, and then its length.

To draw a Center/Radius/End arc
 1.  Select CAD> Arcs> Draw Arc , then click at the center of the arc and drag to define the radius.           

 2.  Release the mouse button, then move the mouse to the end of the arc and click again.          
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START/END/ON ARC

Start/End/On Arc mode allows you to define the start and end points of an arc, then adjust the curvature. 

To draw a Start/End/On arc
 1.  Select CAD> Arcs> Draw Arc , then click at the start point of the arc and drag to the end point.           

 2.  Release the mouse button at the end point.          

 3.  Move the mouse to adjust the curvature of the arc, then click to release the mouse and create the arc.          

START/TANGENT/END ARC

Start/Tangent/End Arc mode allows you to define the start and end points of an arc, its tangent and its curvature.

To draw a Start/Tangent/End arc
 1.  Select CAD> Arcs> Draw Arc , then click at the start of the arc and drag a line to define the arc’s tangent at the 

start point.           

 2.  Release the mouse button.          

 3.  Move the mouse to adjust the length and curvature of the arc, then click to release the mouse and create the arc.           

ARC ABOUT CENTER

Arc About Center mode allows you to draw an arc by defining the center and then the start and end points.          

To draw an Arc About Center
 1.  Select CAD> Arcs> Draw Arc , then click once to define the center point.

 2.  Click and drag from the start point of the arc to its end point.          

 3.  Or, click and drag an arc. The Current Point is used as the center. See The Current Point on page 303.          

 

Arc Tools
Select CAD> Arcs to display the submenu of Arc Tools.

DRAW ARC

The method used to draw an arc using Draw Arc depends on which Arc Creation Mode is currently active. Once 
drawn, an arc can be edited. See Editing Arc-Based Objects on page 221.

INPUT ARC

An arc can be drawn to exact specifications using the New CAD Arc dialog. 
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To use the Input Arc tool
 1.  Select CAD> Points> Place Point , then click the screen to place a CAD point. This is the Current Point, and 

will be the start point for the new arc. See The Current Point on page 303.

 2.  Select CAD> Lines> Input Arc  to open the New CAD Arc dialog.

  The New CAD Arc dialog can also be opened by double-clicking the Arc Tools  parent button. 

 3.  If necessary, specify the Start Point.

 4.  Specify the method used to define the arc’s Direction, then define its angle. 

 5.  Define the arc’s Radius. In order to create an arc, a value greater than 0 must be specified.

 6.  Define the arc’s Extension, or length, using one of the three methods. In order to create an arc, one of these values 
must be greater than 0, and only one method should be used. 

 7.  Click OK to close the dialog and draw the arc.

NEW CAD ARC DIALOG

 
Start Point

The X Position (horizontal) and Y Position (vertical) coordinates of the Start Point for the new arc display here. They can 
also be changed, if you wish.

 
Direction

Specify how you want to define the arc’s Direction, then specify its angle.

 l The Start Direction defines the angle of the tangent from the arc’s start point. 

 l The Chord Direction defines the angle of the arc’s chord from the start point.

316



Chief Architect Premier X14 Reference Manual - Arc Tools

Start Direction at 0° vs Chord Direction at 
0°

  Curve

 l Define the arc's Radius.

 l Select the direction that the arc curves: either to the Right/Clockwise or to the Left/Counterclockwise.

 
Length

Control the length of the arc by defining one of these:

 l A. Arc Angle - the arc's central angle as measured between the radii of both start and end points. 

 l B. Arc Length - the length of the arc along its curve from one endpoint to the other.

 l C. Chord Length - the linear distance between start and end point.

Click the Number Style button to change the units used in 
dialogs. See Dialog Number/Angle Style Dialog on page 131.

ARC WITH ARROW

You can create an arc with an arrow on one or both ends, using the Arc With Arrow tool. Draw an Arc With 
Arrow like a regular arc. When you release the mouse button,  the arc has an arrowhead at the end. The default 

attributes of the arrow are determined by the settings in the  Arrow Defaults dialog. See Arrow Defaults on page 503. 

As with regular arcs, arcs with arrows can be edited after they are created. See Editing Arc-Based Objects on page 221 and 
Arc Specification Dialog on page 318.

Continue to draw connected lines and arcs to form a polyline with an arrowhead at the end. The arrowheads display only at 
the free ends, not where the lines connect. See Polylines on page 322.

Lines with arrowheads can also be created. See Line With Arrow on page 308.

A line can be converted to an arc or vice versa by selecting the 
line, pressing and holding down the Alt key, then using the edit 

handle at either end to bend the line.
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Arc Specification Dialog
Select an arc and click the Open Object edit button to open the Arc Specification dialog.

The settings on the ARC panel are also found on the SELECTED ARC panels for many objects.

ARC PANEL

 
Lock

These options control how changing properties in this dialog affects the arc. 

 l Start - Select this option to keep the start fixed when changing the arc, chord, or end.          

 l End - Select this option to keep the end fixed when changing the arc, chord, or start.          

 l Center - Select this option to keep the center of the arc fixed when changing the arc.          

 l Arc - Select this option to keep the arc fixed when changing the arc location.          

 l Chord - Select this option to keep the arc chord fixed when changing the arc radius.          
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Arc

These parameters define the arc. Various controls are disabled depending on what lock option is used.

 l Center X Point - Specify the X coordinate for the center of the arc.          

 l Center Y Point - Specify the Y coordinate for the center of the arc.          

 l Radius - The distance between the center of the arc and the arc surface.          

 l Start Angle - Specify the angle that a line drawn from the arc center to the arc start makes with a horizontal line to 
the right.          

 l End Angle - Specify the angle that a line drawn from the arc center to the arc end makes with a horizontal line to 
the right.          

 l Arc Angle - The angle between the center of the arc and each end.          

 l Arc Length - The length of the arc along the curve.          

 l Uncheck Automatic Facet Angle to specify the Facet Angle, which is the angle at which the surfaces of a curved 
3D object are broken in 3D views. The default value is 7.5°; a smaller value produces a smoother curve while a 
larger value may generate more quickly in 3D views. These settings are only available on the SELECTED ARC panel 
for some CAD-based architectural objects such as Slabs. See Architectural vs CAD Objects on page 162.           

 
Start Point

 These values define the start point of the arc. The Position settings are disabled when the Start is locked.

 l Start X Position - Specify the X coordinate for the beginning of the arc.          

 l Start Y Position - Specify the Y coordinate for the beginning of the arc.          

 l Start Direction - Specify the angle of a tangent line at the start of the arc.          
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End

These values define the end point of the arc. The Position settings are disabled when the End is locked.

 l End X Position - Specify the X coordinate for the end of the arc.          

 l End Y Position - Specify the Y coordinate for the end of the arc.          

 l End Direction - Specify the angle of a tangent line at the end of the arc.          

 
Chord

These values define the chord of the arc.

 l Chord Length - The straight line distance between the two ends of the arc.          

 l Chord Angle - Specify the angle of the chord (the imaginary straight line going from the start of the arc to the end 
of the arc).          

LINE STYLE PANEL

For information about the LINE STYLE panel, see Line Style Panel on page 310.

ARROW PANEL

For information about the ARROW panel, see Arrow Panel on page 312.

 

Circle Tools
Select CAD> Circles to access the Circle Tools.         

CIRCLE

To draw a circle, select CAD> Circles> Circle, then click and drag across the diameter, in any direction.    

Once a circle is created, it can be edited. See Editing Circles, Ovals and Ellipses on page 242 and Circle/Oval/Ellipse 
Specification Dialog on page 321.    

DRAW CIRCLE ABOUT CENTER

Select CAD> Circles > Circle About Center to create a circle by dragging the radius out from the center point.       
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To draw a Circle About Center
 1.  Click the Circle About Center  tool.          

 2.  Click the screen to define the center.          

 3.  Drag the radial distance and release the mouse button. If you are using Object Snaps , both the center point and 

the radius snap to any appropriate nearby CAD object, intersection or point.          

OVAL

An Oval is a four-arc approximation of an ellipse. To draw an oval, select CAD> Circles> Oval, then click and drag 
at an angle to define the oval's maximum height and width.          

Once an oval is created, it can be edited. See Editing Circles, Ovals and Ellipses on page 242 and Circle/Oval/Ellipse 
Specification Dialog on page 321.    

ELLIPSE

An Ellipse is a set of points with a constant combined distance from two points called foci. An ellipse looks like a 
stretched circle, or a circular surface viewed at an angle. To draw an ellipse, select CAD> Circles> Ellipse and drag 

at an angle to define its maximum height and width.          

Once an ellipse is created, it can be edited. See Editing Circles, Ovals and Ellipses on page 242 and Circle/Oval/Ellipse 
Specification Dialog on page 321.    

 

Circle/Oval/Ellipse Specification Dialog
Select a circle, oval or ellipse and click the Open Object  edit button to open the CAD Circle, Oval or Ellipse 

Specification dialog.

The CAD Circle, Oval, and Ellipse Specification dialogs are almost exactly the same. The Oval and Ellipse Specification 
dialogs have an additional setting for Angle on the GENERAL panel.           

GENERAL PANEL
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Center Point

Specify the position of the circle, oval or ellipse’s Center Point. 

 l Specify the X Position and Y Position of the center of the circle, oval or ellipse.          

 l Specify an oval or ellipse’s Angle. Not available for circles.           

  Size

 l Specify the Length and Width of an oval or ellipse, or the Diameter and Radius of a circle.

 l Specify the Circumference of a selected circle. Not available for ovals or ellipses.

LINE STYLE PANEL

For information about the LINE STYLE panel, see Line Style Panel on page 310.

FILL STYLE PANEL

For information about settings on this panel, see Fill Styles on page 197.

 

Polylines
A polyline consists of two or more line and/or arc segments that are attached at their endpoints. Select CAD> Boxes> 
Rectangular Polyline, then click and drag from corner to corner to create a rectangular-shaped, closed polyline. A 

closed polyline measuring 2’x 2’ (600 mm x 600 mm) can also be created by clicking once while the Rectangular Polyline 
tool is active.

When Object Snaps  and Connect CAD Segments  are enabled, you can also create a polyline by drawing lines 

and/or arcs end-to-end, allowing the end of each new object to snap to the end of the previous one. See Defaults, 
Preferences, and Edit Behaviors on page 208.

Line- and arc-based objects will only snap together to form a polyline if they are on the same layer and share identical 
attributes such as color, line style, and arrow specifications.

If one end of the polyline is connected to the other, it becomes a closed polyline. Closed polylines can be adjusted in a 
variety of ways that open polylines cannot. For example, closed polylines can be assigned a fill pattern and/or turned into 
special 3D objects such as slabs or countertops that display in 3D views. 

Lines and polylines can be distinguished by the edit handles that display when you select each. A line displays an edit 
handle at each end and one in the middle. If more than three edit handles display, the object is a polyline.         

Selected line
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Selected polyline with two collinear edges

Lines that appear connected to a polyline may prove to be unconnected when selected.         

For example, the two polylines in the following image appear identical until their left edges are selected. The entire polyline 
on the left is highlighted, showing it is a closed polyline. The polyline on the right, however reveals that its left edge is not 
fully attached. In contrast, the left edge of the polyline on the left is part of the larger polyline unit.         

The Close Polyline  edit tool can be used to connect the edges of an open polyline. This tool adds a segment between the 

two open ends, closing the gap between them. See Close Polyline on page 230.         

Polylines can be copied, moved, reshaped, or resized as a single unit. Additionally, the individual segments can be edited. 
See Disconnect Edges on page 214.

Once created, polylines can be edited in a variety of ways. See Editing Open Polyline-Based Objects on page 226 and 
Editing Closed Polyline-Based Objects on page 230.

POLYLINE HOLES

Closed CAD Polylines and a variety of closed polyline-based architectural objects can contain one or more holes. See 
Polyline Holes on page 234.         

 

Polyline Specification Dialog
Select an open polyline, closed polyline, spline, Sprinkler Line polyline, or Electrical connection and click the Open 
Object edit button to open the Polyline Specification dialog. 

The information on the FILL STYLE panel of the Polyline Specification dialog is similar to that for many other objects in the 
program. See Fill Styles on page 197. 

The panels that are available in the Polyline Specification dialog will vary, depending on the attributes of the selected 
polyline as well as those of its selected edge.

POLYLINE PANEL

The POLYLINE panel is found in the specification dialogs for a variety of objects throughout the program. It states: 

 l The total number of Polylines or Holes Selected;          
 l The Length of an open polyline; 
 l The Perimeter of a closed polyline; 
 l The Area of a closed polyline; 
 l The Volume of a closed polyline;
 l The Number of Lines that form an open polyline or the perimeter of a closed polyline or polyline hole;
 l The Number of Holes located inside a closed polyline;
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 l The Hole Perimeter is the total length of the perimeter(s) of any holes inside a closed polyline;
 l The Hole Area is the total area of the holes located inside a closed polyline.

If the polyline is not closed, the Area and Volume are described as “Not closed”. The Volume of a 2D polyline will always 
be 0, even if it is closed. 

If the selected object is a closed polyline and has any Holes in it, they will be subtracted from the Area value and, if 
applicable, from its Volume. See Polyline Holes on page 234.           

If multiple objects of the same type are selected, the combined totals of these values are stated.           

SPLINE PANEL

The SPLINE panel has a single option and is only available when the selected object is a spline.  See Splines on page 330.           

 l New Segment Angle - Specify the angle between line segments that are used to draw the spline. Specifying a smaller 
angle makes the spline smoother. Specify a larger angle to draw the spline faster.          

SELECTED LINE PANEL

The SELECTED LINE panel is available when the selected edge of the polyline is a line as opposed to an arc and is not 
available if the selected object is a spline. See Editing Line-Based Objects on page 218.

Moving the Start of a line segment moves the end of the previous connected line, if there is one. Similarly, moving the End 
of a line segment moves the start of the next connected line, if there is one. 

This panel is similar to the LINE panel of the Line Specification dialog. See Line Panel on page 309. 

SELECTED ARC PANEL

The SELECTED ARC panel is available when the selected segment of the polyline is an arc as opposed to a line. It is not 
available if the selected object is a spline. 

This panel is similar to the ARC panel of the Arc Specification dialog. See Arc Panel on page 318.

LINE STYLE PANEL

This panel is similar to the LINE STYLE panel in the Line Specification dialog. See Line Style Panel on page 310.

FILL STYLE PANEL

The FILL STYLE panel is found in the specification dialogs for a variety of objects in the program. Only available for closed 
polylines. See Fill Styles on page 197.

ARROW PANEL

The ARROW panel is available for most open polylines and splines and is similar to the ARROW panel of the Line 
Specification dialog. See Arrow Panel on page 312. 

The ARROW panel is not available for closed polylines, Sprinkler Lines, or Electrical Connections. 
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LABEL PANEL

Labels for CAD polylines display when the “Polylines, Labels” layer is turned on and use the Text Style assigned to that 
layer. See Text Styles on page 547.           

For more information about the settings on this panel, see Label Panel on page 712.           

COMPONENTS PANEL

The COMPONENTS panel is available for a selected Sprinkler Line or Sprinkler Spline. See Sprinkler Tools on page 1307.          

The information on this panel can be used in the materials list. See Components Panel on page 1335.          

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 1335.

OBJECT INFORMATION PANEL

The information entered on the OBJECT INFORMATION panel can be used in schedules. Not available for Electrical 
Connections, Sprinkler Lines, or CAD polylines drawn in layout files. For more information, see Object Information Panel 
on page 1336.   

SCHEDULE PANEL

The settings on the SCHEDULE panel determine which schedule categories the selected object is included in. Not available 
for Electrical Connections, Sprinkler Lines, or CAD polylines drawn in layout files. See Schedule Panel on page 716.

 

Box Tools
Select CAD> Boxes to access the Box Tools.         

RECTANGULAR POLYLINE

A Rectangular Polyline can be created in either of two ways:         

 l Click in the drawing area to place a 24” x 24” square polyline at that location.          
 l Click and drag from corner to corner to draw a rectangle of any size.           

CAD polylines can also be created by connecting CAD lines and/or arcs. See Polylines on page 322.

Once created, a rectangular polyline can be edited into any shape or converted to a 3D object. See Editing Closed Polyline-
Based Objects on page 230.

REGULAR POLYGON

You can draw a regular polygon based on the length of a side, or the length of the radius to a vertex or a side. Select 
your options in the New Regular Polygon dialog and click OK, then click in the drawing area to place the polygon.         
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The settings in this dialog are similar to those in the Polygon Shaped Rooms dialog. See              Polygon Shaped Rooms and Decks 
on page 359.          

BOX

Select CAD> Boxes> Box to draw a 2D rectangular polygon shape. CAD Boxes are drawn from corner to corner, 
forming a rectangle.

The sides of a Box can be resized, but unlike a polyline, a Box always has four 90° corners. See Editing Box-Based Objects 
on page 234 and Box Specification Dialog on page 327.         

CROSS BOX

Use the Cross Box tool to create a 2D box with an X-shaped cross in the interior to represent framing in a cross 
section detail.         

In cross section/elevation views, Cross Boxes are used to represent joists and rafters members that are perpendicular to and 
cut by the camera’s clip plane. See Cross Section/Elevation Views on page 1090.           

BLOCKING BOX

Use the Blocking Box tool to create a 2D box with a diagonal line in the interior to represent blocking or bridging in 
a cross section detail.         

INSULATION

Use the Insulation tool to draw insulation in cross section details. Insulation Boxes are like 2D boxes and Cross 
Boxes; however, unlike these other types of boxes, Insulation Boxes do not have perimeter lines: only the curves of 

the insulation pattern.          
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Box Specification Dialog
Select a CAD box, a framing box, a wall bridging box, a Cross box, a Blocking box, or an Insulation box and click 
the Open Object edit button to open the Box Specification dialog. See Box Tools on page 325.

GENERAL PANEL

 
Box Style

Specify a Box Style. Select Normal to specify a normal box, Cross to specify a cross box, or Insulation to specify an 
insulation box. If multiple CAD boxes are selected, “No Change” may display. 

 
Position

Define the Position of the box. 

 l Specify the X Position and Y Position of the center of the box.          

 l Specify the Angle of the box.          

 
Size

Define the Size of the box by specifying its Height and Width.

LINE STYLE PANEL

For information about the LINE STYLE panel, see Line Panel on page 309.

FILL STYLE PANEL

For information about the FILL STYLE panel, see Fill Styles on page 197.
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Revision Clouds
The Revision Cloud tool allows you to draw a closed polyline with a series of arcs or bulges displaying along each 
edge. Select CAD> Revision Cloud, then click and drag to draw a rectangular shape with edges that display a series 

of arcs.         

There are several additional ways to create a Revision Cloud:          

 l Click and drag using the Alternate  edit mode to draw the first edge, then click to define the end points of 

subsequent edges. Click on the start point of the first edge to finish drawing the cloud. The Revision Cloud  tool is 

still active until you select a different tool. See Alternate on page 209.         
 l Create Revision Clouds around one or more selected objects in plan view by clicking the Revision Cloud(s) Around 

Objects  edit button. A separate revision cloud will be drawn around each selected object. This edit tool is also 

available for CAD objects, text, and dimensions in cross section/elevation views, but not for architectural objects.
 l Convert a closed CAD polyline into a Revision Cloud. See Convert Polyline on page 265.

Revision Clouds are drawn based on the settings in the Revision Cloud Defaults dialog and are initially placed on the layer 
specified there. Unlike other CAD objects, they support multiple Saved Defaults and can be included in Default Sets. See 
Multiple Saved Defaults on page 79.

Once created, Revision Clouds can be selected and edited much like other closed-polyline based objects. See Editing Closed 
Polyline-Based Objects on page 230.

Unlike other closed polylines, however, the edges of a Revision Cloud can only be seen when it is selected. When it is not 
selected, only the arcs along its perimeter are visible. 

Unselected vs selected Revision Cloud

The arcs along a Revision Cloud are not its actual edges and cannot be individually selected, although you can control their 
size and frequency. See Revision Cloud Specification Dialog on page 328.

If you wish to individually edit the arcs, convert it to a plain polyline. See Convert to Plain Polyline on page 268.

 

Revision Cloud Specification Dialog
Select one or more Revision Clouds and click the Open Object edit button to open the Revision Cloud Specification 
dialog.

The settings in the Revision Cloud Defaults dialog are similar to those in the Revision Cloud Specification dialog, but 
determine the initial settings of revision clouds as they are drawn. See Revision Cloud Defaults on page 295.

The Revision Cloud Specification dialog has the following panels:
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CLOUD PANEL

 
Arc Length and Number

Specify how the arcs on the selected revision cloud(s) are sized.

 l Select Automatic Arc Lengths to have the program automatically size the selected cloud’s arcs.

 l Select Average Arc Length to specify the selected cloud’s average arc length, which is measured along its chord.

 l Select Number of Arcs, then specify the number of arcs on the selected cloud.

 
Size Variation

Use the slider bars or text fields to specify the Size Variation of the selected cloud’s arcs. 

 l Specify the Length Diversity, which is the maximum amount that a given arc’s length can deviate from the Average 
Arc Length, specified above.

 l Specify the Minimum Bulge, which is the smallest amount that a given arc can extend out from its center. 0% 
allows arcs with a radius of 0, essentially flat lines; 50% allows 180° arcs, or half-circles; 100% only allows arcs of 
about 300°.

 l Specify the Maximum Bulge, which is the largest amount that a given arc can extend out from its center. 100% 
allows arcs of about 300°;50% allows 180° arcs; 0% only allows arcs with a radius of 0.

 
Preview

A preview of the selected revision cloud displays on the right side of this panel. See Dialog Preview Panes on page 22.

SELECTED LINE/ARC PANEL

The SELECTED LINE panel is available when the selected cloud edge is a line as opposed to an arc. See Line Panel on page 
309.

The SELECTED ARC panel is available when the selected segment of the cloud edge is an arc as opposed to a line. See Arc 
Panel on page 318.

See, too, Selected Edge on page 214 and Change Line/Arc on page 259. 
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LINE STYLE PANEL

For information about the settings on this panel, see Line Style Panel on page 310.

FILL STYLE PANEL

The FILL STYLE panel is found in various dialogs throughout the program. See Fill Styles on page 197.

 

Splines
A Spline is a curve that passes smoothly through a set of points. Splines are typically used in situations where there is 
an irregular curve. A contour line is a typical example. Splines are useful wherever a free-flowing curve is needed.

Once created, splines can be selected and edited. See Editing Spline-Based Objects on page 237 and Polyline Specification 
Dialog on page 323.

To use the Spline tool
 1.  Select CAD> Spline .

 2.  Make sure that Connect CAD Segments  are enabled so multiple spline segments can snap together. See 

Connect CAD Segments on page 163.

 3.  Click and drag to draw the first spline segment just as you would a line. A single spline segment looks identical to a 
line, in fact. You may need to turn off Angle Snaps  to draw freely.

Spline line drawn between two points

 4.  Draw the second segment from the end of the first at a different angle. Object Snaps  should be on to assure that 

new segments attach correctly to the ends of previous segments.

Spline polyline drawn between three 
points

 5.  As soon as two straight spline segments connect end-to-end, the straight segments become a curve that passes 
through the endpoints defined by the original segments. Each point is called a vertex. 

 6.  Draw a few more segments, connecting each to the free end of a previously drawn segment.
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Spline polyline drawn between four 
points

 7.  Notice as additional segments are drawn that the spline changes the curvature of the previous segment to create a 
continuous curve between the last three points.

Spline polyline drawn between five 
points

 8.  Form a closed spline by drawing a segment between its two free ends.

Draw additional segment to close 
polyline

 9.  The result is an irregular curve that flows smoothly through each vertex.

Spline-based objects will only snap together to form a single spline if they are on the same layer and share identical 
attributes such as color, line style, and arrow specifications.

Note: Spline-based objects with the same properties will only snap 
together when Connect CAD Segments is enabled. See Connect CAD 
Segments on page 212.

You can also convert an open or closed polyline into a spline using the Convert to Spline  edit tool. See Convert to 

Spline on page 261.          

 

Displaying CAD Objects
As with architectural objects, the display of CAD objects is controlled in the Layer Display Options dialog. See Layer 
Display Options Dialog on page 183.
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CAD objects can be drawn in plan views, CAD Details, layout, and cross section/elevation views. They are 2D objects only, 
though, so they cannot be seen in any view other than the one they are drawn in and are never visible in camera views or 
overviews. See Architectural vs CAD Objects on page 162.

Open and closed CAD Polylines can be listed in schedules. See Schedule Categories on page 697.

CURRENT CAD LAYER

When drawn, most CAD objects are automatically placed on the Current CAD Layer. In floor plan and cross 
section/elevation views, the name of this layer displays on the right side of the Status Bar at the bottom of the screen. 

See The Status Bar on page 25.         

Initially, the “CAD, Default” layer is set as the Current CAD Layer, but this can be changed at any time in any of several 
ways:          

 l In the CAD Defaults dialog. See CAD Defaults Dialog on page 295.          
 l By selecting CAD> Current CAD Layer  from the menu. See Select Layer Dialog on page 190.          

 l Activate a different Default Set. See Default Sets on page 83.           

Revision Clouds are placed on the layer specified in the Revision Cloud Defaults dialog - not on the Current CAD Layer. 
See Revision Clouds on page 328.          

Changing the Current CAD Layer affects subsequently-drawn 
objects, but existing CAD objects are unaffected by the change. 

As a result, you can efficiently produce CAD drawings on multiple 
layers.

SAVED PLAN VIEWS AND DEFAULT SETS

The Current CAD Layer is among the items associated with Saved Plan Views and Default Sets, both of which can be 
customized and activated for specific drawing tasks. See Plan Views on page 150 and Default Sets on page 83.          

DRAWING GROUPS

Each object in a plan or layout file is included in a Drawing Group, which influences whether it displays in front of or 
behind other objects. By default, CAD objects are placed in Drawing Group 21. Their drawing order relative to one another 
is based on the order in which they were placed: an object will display in front of any objects that were created before it 
was. 

Once created, however, the drawing order of CAD objects can be customized. See Drawing Groups on page 194.

SHOW LENGTH AND ANGLE

You can specify that line segment length and angle display along a CAD line, CAD arc, or along each segment of a CAD 
polyline. If the segment is an arc, its radius also displays. See Line Style Panel on page 310.          

The format of the length and angle can be specified in the CAD Defaults dialog. See CAD Defaults Dialog on page 295.          

Line length and angle indicators use the Text Style assigned to the layer that their CAD object is on. See Text Styles on page 
547.           
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ENDCAPS

Dashed lines often display endcaps, which are dashes of a particular length. You can specify the Printed Length of endcaps 
in the Preferences dialog. See CAD Panel on page 117.          

LINE STYLES

A selection of line styles is available in the Library Browser which you can apply to both CAD and architectural objects. 
See  Line Styles on page 200.          

If you do not see a line style that meets your needs, you can create your own custom line styles. See Line Style Management 
on page 200.         

FILL STYLES

A selection of fill styles can be applied to closed CAD and CAD-based architectural objects. See Fill Styles on page 197.

 

CAD Blocks
A CAD block is a group of 2D CAD objects, text objects, and/or dimensions that have been grouped together so that they 
behave as a single object. A CAD block can also contain other CAD blocks: these are referred to as “nested”. 

CAD blocks can be imported into the program and can also be added to the library. See Importing and Exporting on page 
1222.    

Dimension lines can only be included in a CAD block if they reference objects that are also included in the block. They will 
continue to inherit their attributes from the saved Dimension Defaults that they were associated with before the CAD block 
was created. See Dimension Defaults Dialog on page 457.           

Terrain objects cannot be included in CAD blocks and, with the exception of a few CAD-based objects such as slabs, 
custom countertops and framing, CAD blocks cannot contain architectural objects. Such objects can instead be blocked in 
Architectural Blocks. See Architectural Blocks on page 1008.          

CAD blocks can be selected, moved, rotated, resized, and deleted much like CAD boxes. They can also be exploded into 
their individual parts. See Editing Box-Based Objects on page 234.          

A list of the CAD blocks present in the current file is available in the CAD Block Management dialog. See CAD Block 
Management on page 336.          

MAKE CAD BLOCK

To create a CAD block, group-select two or more eligible objects, and then click the Make CAD Block edit button. 
See Marquee Select on page 216.         

Eligible CAD block component objects include:          

 l CAD objects          
 l Text objects          
 l Dimension lines          
 l CAD blocks          
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 l CAD-based objects such as Slabs, Framing, and Custom Countertops.          
 l Distribution Paths and Regions that have CAD objects as their distributed object.          

If the Make CAD Block edit button is not available, then the selection set may contain an object that is not an eligible CAD 
block component.           

EXPLODE CAD BLOCK

When a block is selected, click the Explode CAD Block edit button to separate it into its individual components.         

If a CAD block includes nested blocks, these nested blocks are not exploded. They can, however, be selected and exploded 
separately.         

When a selected CAD block is exploded, its definition is not affected: only the instance. See CAD Block Definition on page 
337.          

If a block has been resized so that its original aspect ratio is altered, it cannot be exploded. See CAD Block Specification 
Dialog on page 338.          

EDIT CAD BLOCK

The Edit CAD Block tool lets you make changes to a CAD block and then apply your changes to the selected CAD 
block instance or to all instances in the current plan or layout file. To access this edit tool:

 l Select a CAD block or a symbol object that is represented by a CAD block in plan views. See In Plan View on page 
985.

 l Right-click on a CAD block or symbol represented by a CAD block in plan views in the User Catalog of the Library 
Browser. See Using the Contextual Menus on page 965.

 l You can also select a CAD block in the CAD Block Management dialog and click the Edit button. See CAD Block 
Management on page 336.

When you click the Edit CAD Block  edit button, a CAD Block Window opens. A copy of the selected block is created 

in that window, exploded into its component parts and ready to be edited. A CAD Block Window is similar to a CAD 
Detail: the objects in the view can be selected and edited and the CAD, Text, and Dimension tools are available for use. See 
CAD Details on page 340.

Unlike regular CAD Details, however, neither the CAD Detail Management dialog nor the CAD Detail from View tool are 
available when a CAD Block Window is active. Layer settings in this view are customizable; however, when opened via the 
Library Browser, no changes are retained when the view is saved or closed. In addition, when you select Tools> Active 
View> Save Active View , the program updates the definition of the originally selected CAD block. If the selected block 

is present in a plan or layout file, a message box will first provide you with a count of all instances of it in the current file 
and will present you with a choice:

 l Update All Instances of the CAD block in question throughout the current plan or layout file.
 l Update Only This Instance, which refers to the instance that was selected when you clicked the Edit CAD Block 

button. When this option is used, a new CAD block definition is created and assigned to the selected block instance. 
The original CAD block definition is unchanged and remains assigned to any other CAD block instances in the plan 
that were using it. See CAD Block Definition on page 337.

 l Cancel and do nothing.
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SELECT INSERTION POINT

By default, a CAD block has one insertion point located at its center. When placing the CAD block in a drawing or 
moving it to a new location, you can snap its insertion point to some other snap point for accuracy. See Object Snaps 

on page 164.         

In some cases, it may be helpful to position a CAD block using an insertion point other than its center. For example, a CAD 
block representing a bolt or other fastener may be better positioned using the bottom center of its head or washer rather than 
its center. You can use the Select Insertion Point  edit button to replace the insertion point at the center with a different 

point.          

To select an insertion point
 1.  Make sure that Object Snaps  are enabled, then select the CAD block.          

 2.  Click the Select Insertion Point  edit button.          

 3.  Click at the location where you would like the insertion point.          

The available snap points on a CAD block are located around the perimeter of its bounding box. If you need a different 
point, place a temporary CAD Point  at that location, and then snap to it when creating the insertion point.           

A CAD block’s Move edit handle displays at the location of its insertion point. If you place an insertion point at the 
midpoint of one of the bounding box edges, the Move edit handle may display instead of the Resize handle. CAD blocks 
also rotate about their insertion point.          

A CAD block’s insertion point can also be specified relative to the blocks’ center point in the CAD Block Specification 
dialog. See General Panel on page 338.          

ADD TO LIBRARY

Like a variety of other objects, CAD blocks can be added to the library for future use in other files. See Adding 
Library Content on page 973.         

Many manufacturers provide CAD details in DXF/DWG format. These drawings can be imported, blocked and added to the 
library. See Importing 2D Drawings on page 1226.           

If a CAD block contains an object on a custom layer or one that inherits properties from a Saved Dimension Default or 
Saved Text Style and that CAD block is placed from the library into a plan or layout file:          

 l That Saved Default, Text Style, or layer will be created in the destination file if it does not already exist.           
 l If a Saved Default, Text Style, or layer with the same name does exist in the destination file, the object will inherit its 

attributes from the existing settings.          

See Multiple Saved Defaults on page 79 and Layers on page 180.          

CUSTOM 2D SYMBOLS

In plan views, 3D symbols and images are represented by 2D CAD blocks.           

You can specify the CAD block used by a symbol in its Symbol Specification dialog. See 2D Block Panel on page 996.           

The CAD block used by images and plant images is specified in the Image Specification dialog. See Image Panel on page 
1184.           
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A CAD block representing a monitor, 
keyboard, and mouse

If you do not see an existing CAD block that suits your needs, you can create your own. For best results, follow these 
guidelines:          

 l The CAD block should have the same X and Y dimensions as the 3D symbol. An incorrect CAD block size will result 
in inconsistent placement of your symbol.          

 l It is usually best to build your CAD block with solid filled properties. This keeps background patterns and other 
objects from showing through. See Fill Styles on page 197.          

 l So that your custom CAD block can be easily identified, it is best to give it a name in the CAD Block Specification 
dialog. See General Panel on page 338.           

CAD blocks that have nested blocks within them cannot be 
assigned to images. 

 

CAD Block Management
A list of all CAD blocks present in the current plan or layout file can be accessed by selecting CAD> CAD Block 
Management. 

CAD BLOCK MANAGEMENT DIALOG

 
CAD Blocks

All CAD block definitions saved in the current file are listed here. CAD block definitions that currently have no instance 
anywhere in the file may be included. 
Click on a column header to sort the table by the information in that column. An arrow above a header indicates that it is 
being used to sort the table, and in which direction it is being sorted.
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 l Click on the Name of a CAD block definition in the list to select it. The selected line item is highlighted in blue. 

 l CAD block definitions with at least one instance in the current file have a red plus   sign in the Used column, 
while those specified in a Defaults dialog have a white wrench  icon.

 l Move your mouse pointer over an icon in the Used column for a summary of where the CAD block is in use. See 
In Use Line Styles on page 202 for information about the different icons.

 l Unused CAD block definitions with no instances in the current file have no icons in the Used column and can be 
deleted. 

 l When Automatically Purge CAD Blocks is unchecked and all instances of a CAD block are removed from the 
current file, its definition will continue to be saved in the file and will be listed here. Leave this box checked to 
remove unused CAD blocks from the list.

 
Management Options

The buttons on the right side of the list of CAD blocks allow you to manage the items in the list, as well as insert instances 
into the current view.    

 l Select one or more blocks in the list, click the Insert button, then click in the current view to place an instance of the 
block into that view. Not available in 3D camera views and overviews.

 l Select a block in the list and click the Edit button to open a CAD Block Window where it can be edited. If multiple 
blocks are selected, a separate CAD Block Window is opened for each one. See Edit CAD Block on page 334.    

 l Select a block in the list, then click the Rename button to specify a new name for it.    

 l Click the Purge button to delete all unused block definitions from the list.    

 l Select an unused block and click the Delete button to remove it from the list. Not available for blocks that are Used.    

 l Click the Add to Library button to save a copy of the selected block in the User Catalog. See Adding Library 
Content on page 973. 

 
Preview

A preview of the selected CAD block displays on the right side of the dialog. See Dialog Preview Panes on page 22.

CAD BLOCK DEFINITION

There are two aspects to each CAD block: 

 l The block definition, which holds information about the block’s component objects.
 l The block instance, which holds information about its position, orientation, size, aspect ratio and other settings specific 

to an individual block placed in a file. 

All instances of a given CAD block can have unique positions and sizes; however, the block definition that they share is the 
same regardless of the floor, view, or layout page that they display in. 

Copying a block instance to a completely different file also copies the block definition to that file.

If all instances of a CAD block are deleted from a file, its definition will remain saved with the file. To control file size, it is 
a good idea to regularly purge files of unused CAD blocks or have the program do it for you automatically. Both options are 
available in the CAD Block Management dialog.
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CAD Block Specification Dialog
Select one or more CAD blocks and click the Open Object edit button to open the CAD Block Specification dialog.

GENERAL PANEL

 
Name

Specify the CAD block’s Name. Not available when multiple CAD blocks are selected. If the CAD block has a copyright, 
information about it displays here. 
This name is listed in the CAD Block Management dialog and is used when you export the block via DXF/DWG, and is 
also imported with DXF/DWG block definitions. 
Unlike other settings in this dialog, which affect only the selected instance of the block, changing the name modifies the 
actual block definition. See CAD Block Management on page 336.

If you assign a name that is used by another CAD block in the 
current file, the definition of the other block is overwritten.

 
Position

Specify the Position and angle of the selected CAD block instance.

 l Specify the X and Y Positions, which are the coordinates of the CAD block’s insertion point.

 l Specify the Angle at which the CAD block instance is placed.
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Line/Fill Style

Specify how line and fill styles are applied to the selected CAD block instance.

 l Select By Block Layer to use the line and fill styles specified for the selected CAD block instance.

 l Select By Object to use the line and fill styles of the individual objects in the selected CAD block instance.

New block instances use to By Block Layer unless Use ‘By Object’ when creating new CAD blocks is checked in the 
Preferences dialog. See CAD Panel on page 117.

 
Size

Specify the Size of the selected CAD block instance.         

 l Check Retain Aspect Ratio of x to retain the original ratio between the CAD block’s Height and Width. This only 
affects changes made in the dialog: it does not affect editing using the edit handles. If a block is resized so that its 
aspect ratio is changed, it cannot be exploded. See Explode CAD Block on page 334.   

 l Specify the Height of the selected CAD block instance.   

 l Specify the Height Factor, which is the ratio of the current height of the CAD block instance to its original height.   

 l Specify the Width of the selected CAD block instance.   

 l Specify the Width Factor, which is the ratio of the current width of the CAD block instance to its original width.

Note: If the Height and Width Factors are set to different values, the 
selected CAD block instance cannot be exploded and ovals and arcs 
within it may appear distorted.

 
Insertion Point (Relative to Center)

Specify the location of the selected CAD block instance’s Insertion Point (Relative to Center). These offset values use the 
CAD block instance’s coordinate system rather than that of the drawing area, so if the block is rotated, its insertion point 
will remain in the same location relative to the block itself. See Select Insertion Point on page 335.

 l Specify the X Offset, the horizontal distance of the insertion point relative to the CAD block’s center point.

 l Specify the Y Offset, the vertical distance of the insertion point relative to the CAD block’s center point. 

 
Copyright

Any Copyright information associated with the selected CAD block will be stated here.          

LINE STYLE PANEL

Many of the settings on the LINE STYLE panel are only available if By Block is selected on the GENERAL panel of this 
dialog. For information about this panel, see Line Style Panel on page 310.

FILL STYLE PANEL

The settings on the FILL STYLE panel are only available if By Block is selected on the GENERAL panel of this dialog. See 
Fill Styles on page 197.

If Always use “By Object” for CAD block fill style is checked in the Preferences dialog, the settings on this panel are not 
used. See CAD Panel on page 117.
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CAD Details
CAD Details are special view windows for drawing, saving and organizing 2D drawings associated with the current plan or 
layout file, such as site plans and section details. They are listed in the Project Browser and CAD Detail Management 
dialog, and  can be created in both locations, as well. See Project Browser on page 58.

Like other views, CAD Details are saved in the file they are created in, have a specification dialog, use a Layer Set, and can 
be printed. CAD Details can also be sent to layout. See View Windows on page 149.

2D CAD information can be copied into or out of a CAD Detail window using the group select and copy functions. See 
Copying and Pasting Objects on page 171.

CAD DETAIL MANAGEMENT DIALOG

Select CAD> CAD Detail Management to open the CAD Detail Management dialog. 

An alphabetical list of all CAD Details in the current file displays here.  

 l Click on a CAD Detail Name in the list to select it. The selected item’s row is highlighted. 
 l If a CAD Detail is currently open, it will have a check mark in the Open column. 
 l Click New to open the Create New CAD Detail dialog. Type a short, descriptive name for the CAD Detail, click OK, 

and a new CAD Detail view window opens. 
 l To rename an existing CAD Detail, select it and click Rename. 
 l To create an exact copy of an existing CAD Detail, select it and click the Copy button. 
 l To delete a CAD Detail from the list, select it and click Delete. The automatically generated Truss Detail cannot be 

deleted if there are trusses in the current plan. See Truss Details on page 916.
 l To open an existing CAD Detail, select it and click Open. CAD Details that are presently open have a check mark to 

the right of their name.

SPECIAL CAD DETAILS

Some CAD details are created automatically by the program and function somewhat differently than regular CAD Detail 
windows:

 l If any roof or floor trusses are present in a plan, the program creates a Truss Detail that includes an editable diagram 
of each truss type used and a count of each. See Truss Details on page 916.

 l A Wall Detail is created for each wall with framing that has been automatically generated. Wall Details are listed in 
the Project Browser but not in the CAD Detail Management dialog. See In Wall Detail Views on page 896. 
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 l If you select a CAD Block and click the Edit CAD Block  edit button, the program creates a CAD Block Window 

and pastes a copy of the block in that window where it can be edited. CAD Block Windows are not listed in the 
CAD Detail Management dialog or in the Project Browser, however. See Edit CAD Block on page 334.

CAD DETAIL FROM VIEW

CAD> CAD Detail from View converts the current view into a 2D CAD drawing composed of editable CAD 
objects. 

CAD Detail from View is available in line-based views including most CAD Detail windows, plan views, and any 3D view 
using the Vector View Rendering Technique. It is not, however, available in CAD Block Windows. See Rendered and 
Vector Views on page 1081.

Note: CAD Details are not dynamically linked to the model. Changes 
made to the view do not update in the detail or vice versa.

A CAD Detail created using CAD Detail from View inherits a variety of settings from the original view, including: 

 l The layer set used by the original view. See Layer Sets on page 186.
 l When the original view is a layout page with one or more layout boxes, a new “Layout Box Export Contents” layer is 

created for the contents of the layout boxes. See Layout on page 1338. 
 l The Dimension Defaults settings used by the original floor plan or cross section/elevation view. See Dimension 

Defaults Dialog on page 457.
 l The rotation of the original view. See Rotate Plan View on page 151.
 l Any text objects using a specific Text Style in the original view will maintain the same settings in the CAD Detail; 

however they will use a Custom Text Style. 

Camera views and overviews do not have Dimension Defaults, so the currently active defaults for plan view are inherited by 
CAD Details created from these types of views. 

 

CAD Detail Specification Dialog
To open the CAD Detail Specification dialog for any CAD Detail, right-click on its name in the Project Browser and 
select Open Object from the contextual menu. See Project Browser on page 58. 

You can also open this dialog for the currently active view by selecting Tools> Active View> Edit Active View. 

GENERAL PANEL

341



Chief Architect Premier X14 Reference Manual - Plot Plans and Plan Footprints

 
Name

Specify the Name of the view. 

  General

 l Check Remember Zoom/Rotation to maintain the extents of the view and its rotation the next time the view is 
opened. See Zoom Tools on page 157 and Rotate Plan View on page 151.          

 l Uncheck Show Color to turn color off in the selected view. See Color On/Off on page 196.          

 l Check Show Watermark to display the watermark specified for the current plan file in the selected view. See 
Watermarks on page 1382.           

SELECTED DEFAULTS PANEL

The settings on the SELECTED DEFAULTS panel control which Saved Defaults and layer settings are used in the view. These 
settings are also found in the Active Defaults dialog. See Active Defaults Dialog on page 82.          

 

Plot Plans and Plan Footprints
Using the CAD Tools and conventional survey information, you can create an accurate plot plan in plan view or a CAD 
Detail. 

A plot plan can be sent to layout and included in construction documents. See Dynamic Views on page 1346.

A plot plan can also be converted into a terrain perimeter, allowing you to add elevation data and accurately position 
buildings for 3D modeling of home and lot.

PLAN FOOTPRINT

Select CAD> Plan Footprint to create a CAD object representing the building footprint in a CAD Detail window. 
Once the Plan Footprint is created, you can control what information it displays. 

To create a Plan Footprint
 1.  Open the plan view that you want to create a Plan Footprint from.

 2.  Select CAD> Plan Footprint . The program creates a new CAD Detail with the footprint of the current floor. 

 l By default, this new CAD Detail uses the Plan Footprint layer set. You can control what displays in the footprint using 
the Layer Display Options dialog. See Layer Sets on page 186.

 l You can also control the appearance of a Plan Footprint in its specification dialog. See Plan Footprint Specification 
Dialog on page 343.

To insert a plan footprint in a CAD Detail
 1.  Open the CAD Detail in which you want to insert a Plan Footprint.

 2.  Select CAD> Plan Footprint. 

 3.  Select the floor to use from the drop-down list and click OK.
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 4.  The floor plan appears in the CAD Detail window. Select Window> Fill Window  to center the footprint on 

screen. 

 5.  The footprint can be rotated and moved anywhere in the window.

If the model consists of several buildings, a footprint is created for each. Moving one footprint automatically adjusts all the 
footprints in order to maintain their relationship. 

If you edit a plan using Reverse Plan  or the Edit Area  tools, the plan footprint updates automatically. 

Dimension lines can be drawn to locate the edges of a plan footprint polyline. Note that if changes to the plan cause the plan 
footprint polyline to update, any dimension lines that locate it may be deleted as a result. See Dimensions on page 454.

LAYER DISPLAY OPTIONS

When you create a plan footprint by selecting CAD> Plan Footprint while in plan view, the default layer set for Plan 
Footprints is used.  See Layer Set Defaults on page 187.

When a plan footprint is created by selecting CAD> Plan Footprint while in a CAD Detail, the current layer set is used. 
See Layer Set Management on page 188.

Regardless of the layer set in use, the appearance of objects in a Plan Footprint is controlled in the Layer Display Options 
dialog. Individual objects are on the same layer as they are elsewhere, while the Plan Footprint itself is on the “CAD, 
Default” layer. See Layer Display Options Dialog on page 183.

 

Plan Footprint Specification Dialog
Select a plan footprint and click the Open Object edit button to open the Plan Footprint Specification dialog for the 
selected plan footprint. 

GENERAL PANEL

 l Select the Floor Used for Plan Footprint from the drop-down list. 
 l Check Display Footprint Polyline to draw a polyline around the perimeter of the footprint. This option must be 

selected if you want to use a fill pattern or specify a line style. Note that the footprint polyline may not be visible if 
you also have Display Plan Details checked. 

 l Check Display Plan Details to show the walls and other details as they appear in plan view.
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 l Check Use Current Layer Set to Display to control what displays in the footprint using Layer Display Options. If 
you uncheck this box, you lose control of what displays and the program makes the determination for you. See Layer 
Display Options on page 343.

POLYLINE PANEL

The POLYLINE panel states the plan footprint polyline’s Perimeter and its Area. See Polyline Panel on page 323.

LINE STYLE PANEL

The settings on the LINE STYLE panel do not affect the appearance of the plan footprint unless Display Footprint Polyline 
is checked on the GENERAL panel.

For information about using the LINE STYLE panel, see Line Style Panel on page 310.

FILL STYLE PANEL

The settings on the FILL STYLE panel do not affect the appearance of the plan footprint unless Display Footprint Polyline 
is checked on the GENERAL panel.

For more information about the FILL STYLE panel, see Fill Styles on page 197. 
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Chapter 11
 

Walls, Railings, and Fencing

To draw a wall, select one of the Wall Tools on page 350, then click and drag in a line to the approximate length that you 
want. When you enclose an area with walls, a room is created, complete with floor and ceiling. The Door Tools on page 553 
and Window Tools on page 585 can be used to add openings, while Dimensions on page 454 are used to position walls and 
openings with accuracy.

Walls are the single most important structural component in Chief Architect. They define Rooms on page 417, are used to 
create Foundations on page 717, and even influence how Roofs on page 803 are built. It is helpful to understand how Wall 
Type Definitions, wall connections, and wall alignment all affect your design.

TOPICS

Wall, Railing, and Fencing Defaults 346
Wall Tools 350
Railing and Deck Tools 352
Fencing Tools 354
Exterior and Interior Walls 355
Foundation Walls 355
Pony Walls 357
Room Dividers and Invisible Walls 358
Polygon Shaped Rooms and Decks 359
Wall Hatching 360
Creating Walls 361
Connecting Walls 364
Displaying Walls 366
Measuring Walls 369
Editing Walls 372
Edit Handles for Walls 375
Editing Straight/Curved Wall Combinations 377
Aligning Walls 378
Roof Directives in Walls 381
Attic Walls 383
Stepped and Raked Walls 384
Double Walls 386
CAD to Walls 387
Wall Type Definitions 388
Wall Type Definitions Dialog 390
Exporting and Importing Wall Types 395
Wall Specification Dialog 395
Railing and Fencing Specification Dialogs 411
Wall Hatching Specification Dialog 416
Wall Schedules 416
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Wall, Railing, and Fencing Defaults
There are several defaults dialogs for walls. Default Settings can be accessed by selecting Edit> Default Settings. 
Click the arrow next to “Walls” to display the walls sub-headings. Select a subheading and click the Edit button to 

open the Wall Defaults dialog associated with your selection:

The defaults dialog for each wall tool can also be accessed by double-clicking the tool’s toolbar button.          

The settings in the various wall defaults dialogs determine what wall types are drawn when the different wall tools are used. 
It is a good idea to be familiar with these settings and how they relate to your style of building. See Wall Type Definitions 
on page 388.

SET AS DEFAULT

You can set the attributes for a selected wall in your plan as a default wall type by clicking the Set as Default edit 
button. See Set as Default on page 79.         

Which Wall Defaults gets updated depends on the attributes of the selected wall. If the selected wall is specified as:         

 l A Foundation wall, its attributes will become the Foundation Wall Defaults.         
 l A Slab Footing, its attributes will become the Slab Footing Defaults.         
 l A Railing or Deck Railing that is not specified as Solid or set to Follow Terrain, its attributes will become the Railing 

or Deck Railing Defaults.         
 l A Solid Railing or Deck Railing, its attributes will become the Half Wall Defaults.         
 l A Railing or Deck Railing set to Follow Terrain, its attributes will become the Fencing Defaults.         
 l A wall specified as Invisible, its attributes will become the Room Divider Defaults.         

If a wall does not have a setting listed above and defines:         

 l Only interior rooms, its attributes will become the Interior Wall Defaults.         
 l An exterior room or forms part of the structure’s exterior, its attributes will become the Exterior Wall Defaults.          

The Set as Default  edit tool is not available for Pony Walls.          

GENERAL WALL DEFAULTS

The General Wall Defaults dialog controls the general behavior and display attributes of all walls, railings and 
fencing.         

For quick access, the General Wall Defaults  button can be added to the toolbar or you can press Alt+Q on your 

keyboard.          
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Resize About

These radio buttons determine what part of a wall retains its position when its wall type or wall type definition is changed. 
See Resize About on page 379.          

The Resize About location is also where any snap points will be located along a wall as it is drawn or connected to other 
walls, and is where a wall’s length is measured.

 l Outer Surface - Snap to and resize about the exterior surface. When a wall is resized, its exterior surface does not 
move.          

 l Main Layer Outside - Snap to and resize about the outer line of the Main Layer. When a wall is resized, the outer 
line of its Main Layer does not move. When multiple Main Layers are specified, the outer line of the outermost Main 
Layer is used.

 l Wall Center - Snap to and resize about the center line. When a wall is resized, its center line does not move, but 
wall layers on either side may.          

 l Main Layer Inside - Snap to and resize about the inner line of the Main Layer. When a wall is resized, the inner 
line of its Main Layer does not move. When multiple Main Layers are specified, the inner line of the innermost Main 
Layer is used.

 l Inside Surface - Snap to and resize about the interior surface. When a wall is resized, its interior surface does not 
move.         
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Note: In most circumstances, it is recommended that you Resize About the Main Layer Outside to avoid unexpected 
results.

  Automatic Walls

 l Uncheck Auto Rebuild Attic Walls to prevent Attic walls from automatically generating when the model changes. 
When checked, Attic Walls are automatically generated. See Attic Walls on page 383.

 l Uncheck Connect Island Rooms to prevent Room Dividers from automatically connecting “island” rooms to the 
larger structure around them. When checked, Room Dividers are generated to prevent room definition problems. See 
Room Definition on page 418.           

 l When Auto Reverse Wall Layers is checked, walls will automatically reverse their layers to ensure that exterior 
layers face the exterior of the structure. Uncheck this to leave the orientation of the wall layers unchanged. See 
Creating Walls on page 361. 

 l When Auto Merge Collinear Walls is checked, collinear walls with the same wall type and specifications 
automatically merge to form a single wall. Uncheck this to force these walls to remain separate. See Removing Wall 
Breaks on page 366.         

EXTERIOR AND INTERIOR WALL DEFAULTS DIALOGS

Specify the initial attributes of walls drawn using the Exterior  and Interior Wall  tools in the Exterior and Interior 

Wall Defaults dialogs. See Wall Tools on page 350. 

The panels in this dialog are the same as their respective panels in the Wall Specification dialog. See Wall Specification 
Dialog on page 395.          

FOUNDATION WALL DEFAULTS

Specify the initial attributes of walls created by the Foundation Wall  tool when it is either used manually or when a 

stem wall or pier foundation is generated in the Foundation Wall Defaults dialog. See Foundation Walls on page 355.         

The Foundation Wall Defaults dialog also controls the wall type drawn by the Retaining Wall  tool. Unlike other walls, 

Retaining Walls  are used to modify your terrain rather than build a structure. See Terrain Wall and Curb Tools on page 

1261.         

Footing size and other information used when building stem wall or pier foundations is also specified here. For more 
information, see Foundation Defaults Dialog on page 718.         

The panels in this dialog are the same as their respective panels in the Wall Specification dialog. See Wall Specification 
Dialog on page 395.         

SLAB FOOTING DEFAULTS

Specify the initial attributes of walls created by the Slab Footing  tool when it is either used manually or when a 

foundation is generated in the Slab Footing Defaults dialog. See Foundation Walls on page 355.          

Footing size and other information used when building a monolithic slab foundation is also specified here. See Foundation 
Defaults Dialog on page 718.          

The panels in this dialog are the same as their respective panels in the Wall Specification dialog. See Wall Specification 
Dialog on page 395.          
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PONY WALL DEFAULTS

Specify the initial attributes of walls drawn using the Pony Wall  tool. See Pony Walls on page 357.         

The Display in Plan and Display of Openings in Non-Displayed Parts of Walls settings on the WALL TYPES panel of the 
Pony Wall Defaults dialog are     saved with and can be different in each Saved Plan View. See Plan Views on page 150.         

The panels in this dialog are the same as those in the Wall Specification dialog. See Wall Specification Dialog on page 395.         

RAILING AND DECK RAILING DEFAULTS

Specify the types of railings created when the Railing and Deck Railing tools are used. See Railing and Deck Tools on page 
352.         

Note: By default, Railings and Deck Railings are drawn using two 
separate wall types: “Interior Railing” and “Deck Railing/Fence”. See 
Wall Type Definitions on page 388.

The panels in these dialogs are the same as their respective panels in the Wall Specification dialog. See Wall Specification 
Dialog on page 395.         

GLASS WALL DEFAULTS

Specify the initial attributes of walls drawn using the Straight Glass Wall  tool. See Glass Walls and Half-Walls on 

page 351.         

The panels in this dialog are the same as their respective panels in the Wall Specification dialog. See Wall Specification 
Dialog on page 395.         

GLASS PONY WALL DEFAULTS

Specify the initial attributes of walls drawn using the Straight Glass Pony Wall  tool. See Glass Walls and Half-Walls 

on page 351.         

The panels in this dialog are the same as their respective panels in the Wall Specification dialog. See Wall Specification 
Dialog on page 395.         

HALF-WALL DEFAULTS

Specify the attributes of a solid railing drawn using either the Straight Half Wall  or Curved Half Wall  tool. See 

Glass Walls and Half-Walls on page 351.         

The panels in this dialog are the same as their respective panels in the Wall Specification dialog. See Wall Specification 
Dialog on page 395.         

FENCING DEFAULTS

Specify the initial attributes of walls drawn using either of the Fencing Tools . See Fencing Tools on page 354.         

The panels in this dialog are the same as their respective panels in the Wall Specification dialog. See Wall Specification 
Dialog on page 395.         
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ROOM DIVIDER DEFAULTS

Specify the initial attributes of walls drawn using the Room Divider  tool. See Room Dividers and Invisible Walls on 

page 358.         

The panels in this dialog are the same as their respective panels in the Wall Specification dialog. See Wall Specification 
Dialog on page 395.         

WALL HATCHING DEFAULTS

Specify the initial attributes of Wall Hatching  tool. See Wall Hatching on page 360.   

The panels in this dialog are the same as their respective panels in the Wall Hatching Specification dialog. See Wall 
Hatching Specification Dialog on page 416.  

 

Wall Tools
Select Build> Wall  to access the Wall Tools. The type of wall drawn by each wall tool is specified in its 
corresponding defaults dialog. 

The Curved Wall tools are similar to their corresponding Straight Wall Tools. Select Build> Wall to access these 
tools as well. 

EXTERIOR WALLS

The Exterior Wall and Curved Exterior Wall tools draw walls using the default wall type specified for 
exterior walls in the Exterior/Interior Wall Defaults dialog. See Exterior and Interior Walls on page 355.

INTERIOR WALLS

The Interior Wall and Curved Interior Wall tools draw walls using the wall type specified for interior walls. 
The interior wall type is defined in the Exterior/Interior Wall Defaults dialog.          

Note: Whether a wall is recognized as an exterior or interior wall by the 
program is determined by its position in the model, not by the tool used 
to draw it. See Exterior and Interior Walls on page 355.

FOUNDATION WALLS

The Foundation Wall and Curved Foundation Wall tools draw foundation walls according to the 
information specified in the Foundation Defaults dialog. Foundation walls normally have a footing and can be 

drawn on any floor of the model, not just the foundation floor. See Foundation Walls on page 355.         

The Slab Footing tool draws a single-layer concrete wall the same width as that specified for footings in the 
Foundation Defaults dialog. Rooms defined entirely by Slab Footings will have a Ceiling Height of 0 and a 

Monolithic Slab Foundation specified. See Foundation Defaults on page 718.         

PONY WALLS

A Pony Wall, also called a split wall, is defined as a wall with two separate wall types, one for the upper 
portion and another for the lower portion.         
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The Pony Wall and Curved Pony Wall tools draw pony walls using the information specified in the Pony Wall Defaults 
dialog.  You can also convert a normal wall into a pony wall and vice versa in the Wall Specification dialog. See Pony 
Walls on page 357.         

GLASS WALLS AND HALF-WALLS

The Straight Glass Wall tool creates single-layer glass walls that do not cut the surfaces of the floor, ceiling, or 
adjacent walls.              The wall type and other attributes of glass walls drawn with this tool are defined in the Straight Glass 

Wall Defaults dialog. See Glass Wall Defaults on page 349 and Partition Walls on page 365.

The Straight Glass Pony Wall tool creates a pony wall with a glass upper partition.              The height and other attributes 
of walls drawn with this tool are defined in the Straight Glass Pony Wall Defaults dialogs. See Glass Pony Wall 

Defaults on page 349.

The Half-Wall and Curved Half-Wall tools create solid railings: walls that are 36” (900 mm) high topped 
with a handrail.              The height and other attributes of solid railings drawn with this tool are defined in the Half-

Wall Defaults dialog. See Half-Wall Defaults on page 349. 

ROOM DIVIDERS

Room Dividers are Invisible walls with a thickness of 0” (mm) that are used to define separate room areas in a plan. 
They can display in plan view but not in 3D views. See Room Dividers and Invisible Walls on page 358.

POLYGON SHAPED ROOM

The Polygon Shaped Room tool opens the New Polygon Shaped Room dialog, where you can specify the exact size 
and number of sides of a new polygonal room and then click in plan view to create that room. See              Polygon Shaped 

Rooms and Decks on page 359.         

WALL HATCHING

The Wall Hatching tool applies a hatch pattern to a wall that displays in plan views. You must click the wall that 
you want to apply the hatch pattern to. You can then select the hatch and resize it if you want to only hatch a portion 

of a wall. See Wall Hatching on page 360.

WALL MATERIAL REGIONS

Select Build> Wall> Wall Material Region to create an area on a wall that has different materials than the wall. See 
Floor and Wall Material Regions on page 1037.         

FIX WALL CONNECTIONS

The Fix Wall Connections tool connects walls whose ends are within a few inches of each other but are not 
connected. See Fix Wall Connections on page 365.

WALL BREAK

The legacy Wall Break tool divides walls into separate segments. It is similar to the Break edit tool, but can be used 
to modify multiple walls without having to select them first. The Wall Break tool has been deprecated but can be 

activated using the hotkey Ctrl + B. In addition, it may be available if legacy toolbars have been migrated into Version X14. 
It can also be added to the toolbars or assigned a custom hotkey if you wish. See Add Break on page 257 and Toolbars and 
Hotkeys on page 133.         
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DEFINE WALL TYPES

The Define Wall Types tool opens the Wall Type Definitions dialog, where wall types can be created, copied and 
edited. See Wall Type Definitions Dialog on page 390.         

LIBRARY WALLS

You can also add a wall to the library, and then draw a new wall in any plan using its wall type and specifications by 
simply selecting it and then clicking and dragging in the drawing area. See Adding Library Content on page 973.         

When a new wall is drawn, it inherits the wall type of the library wall. If a wall type of that name already exists in the plan 
and the two are not identical, a new wall type will be created in that plan, and its name appended with “_2”. See Wall Type 
Definitions on page 388.          

 

Railing and Deck Tools
Railings are a special type of wall that have a specified height rather than building all the way to a room’s ceiling 
height. Select Build> Railing and Deck to access the Railing and Deck Tools. Railings are typically used to define 

interior spaces, while the various Deck tools are used to define exterior Deck rooms. 

With the exception of the Polygon Shaped Deck tool, each of the tools in this family have both Straight and Curved 
versions, and are created and edited just like walls. See Creating Walls on page 361.

To create a break in a railing for a stairway or other access, use a Doorway . This keeps the railing continuous and 

maintains room definition. See Room Definition on page 418. 

When first drawn, railings are specified as No Locate, which prevents Auto Exterior Dimensions  from locating them. 

This attribute may also be helpful if you do not want a railing to divide an area into two separate rooms. See General Panel 
on page 395.

The attributes for railings when they are first drawn are defined in the Railing Defaults dialog. See Railing and Deck Railing 
Defaults on page 349.          

RAILINGS

The Railing and Curved Railing tools create railings that are primarily used to define interior spaces. The 
style and height of railings drawn with this tool are defined in Railing Defaults dialog. See Railing and Deck 

Railing Defaults on page 349.

Railings are ideal for a number of tasks:

 l Creating changes in floor and/or ceiling height. See Floor and Ceiling Heights on page 431.
 l Creating stairwells. See Creating a Stairwell on page 779.
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DECK RAILING

The Straight Deck Railing and Curved Deck Railing tools draw decks, complete with framing and bounded 
by a railing. If a foundation level exists, supports for the deck are also created. See Decks on page 430.         

When a room is defined using deck railing, its Room Type is automatically set to “Deck”. See Decks on page 430.         

DECK EDGES

The Straight Deck Edge and Curved Deck Edge draw decks complete with framing, but without a railing. No 
deck supports are created.          

POLYGON SHAPED DECK

The Polygon Shaped Deck tool opens the New Polygon Shaped Deck dialog, where you can specify the exact size 
and number of sides of a new polygonal deck room and then click in plan view to create that deck room. See              

Polygon Shaped Rooms and Decks on page 359.         

RAILING TYPES

A variety of railing types can be specified in the Railing and Deck Railing Specification dialogs. See Rail Style Panel on 
page 412. Available types include:

 l Baluster creates railings composed of newel posts, balusters, a railing, and an optional bottom rail. 
 l Solid produces a framed railing wall, or Half Wall. See Glass Walls and Half-Walls on page 351. 
 l If Panels is selected, you can choose a panel style such as cable, glass, or ironwork from the library. See 

Newels/Balusters Panel on page 414.

By default, newels and balusters do not display in plan view, but their display can be turned on. See Newels/Balusters Panel 
on page 414.
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WALL TYPES AND RAILINGS

Just like regular walls, railings are assigned a wall type: “Interior Railing”. This wall type has three layers: a framing layer 
in the middle and a layer of drywall on each side. See Wall Type Definitions on page 388.           

You can use a different wall type definition for railings if you wish, but bear in mind that this wall type definition 
determines several important things:           

 l The railing’s appearance in plan view. See Displaying Walls on page 366.           
 l The actual thickness of Solid railings in 3D views.           
 l The extent of the floor platform, if a platform edge is defined by the railing is defined by the outer surface of the wall 

type. See Floor and Ceiling Platforms on page 433.           
 l If the railing is used to create a change in floor height, this wall type controls the structure and position of the partial 

wall built beneath the railing, if one is required. See Floor and Ceiling Heights on page 431.           

If the railing is a type other than Solid, its sizing is specified on the NEWELS/BALUSTERS panel of the Railing Specification 
dialog, and the railing is centered along the width of the wall type. This will not be evident in plan view unless newels and 
balusters are set to display.           

Deck Railing is also assigned a wall type: “Deck Railing/Fencing”. This wall type has a single framing layer and is 
recommended for use only with deck railing and fencing.           

RAILINGS OVER WALLS

To produce a railing over a solid wall, specify it as both a Railing and a Pony Wall. See Pony Walls on page 357.          

To create a solid glass partition over a partial-height wall, specify the “Glass Shower” wall type as the Upper Wall.           

To create a glass panel above a half wall
 1.  Draw a Half Wall  and open its specification dialog.           

 2.  On the WALL TYPES panel of the Railing Specification dialog, check the box beside Pony Wall.          

 3.  On the WALL CAP panel, confirm that Full Wall Width is checked.             

 4.  On the RAIL STYLE panel, select Panel and uncheck Include Top Rail, Include Bottom Rail, and Raise Bottom.           

 5.  On the NEWELS/BALUSTERS panel, select “Solid” and adjust the Newels/Posts Width and Spacing values to meet 
your needs.           

 6.  On the MATERIALS panel, specify a glass material for the Panel component.          

 

Fencing Tools
Fencing is a special type of wall that is designed to follow the terrain rather than define a room with a flat floor platform.         

Select Build> Fencing or click the Fencing Tools to access the fencing tools. Fencing automatically follows the 
shape of the terrain.  You can choose to have the fencing follow the terrain smoothly or to have each segment step as 

it follows the terrain. See Rail Style Panel on page 412.

The Fencing and Curved Fencing tools are used to draw fences, which are similar to railings but by default 
do not define room areas. Fencing is created and edited much like walls and railings, and normally used 

outside a building and follows the shape of the terrain. See Terrain on page 1249.         
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Define the default fence style in the Fencing Defaults dialog. See Fencing Defaults on page 349.          

 

Exterior and Interior Walls
Most walls are drawn using either the Straight Exterior Wall and Straight Interior Wall tools.          

Exterior and interior walls can also be drawn using the Curved Exterior Wall and Curved Interior Wall 
tools.          

The only difference between the Exterior and Interior Wall Tools is the wall type used: Exterior Walls use a wall type set up 
to model a wall with siding, while Interior Walls model interior walls with sheetrock. See Wall Type Definitions on page 
388.         

To draw a wall using a different wall type, you can change the default wall type for either tool in the Exterior and Interior 
Wall Defaults dialogs. You can also draw a wall using the default type and then change the wall type in the Wall 
Specification dialog. See              Wall Types Panel on page 407.         

Whether a wall is recognized by the program as an actual exterior or interior wall is based on its position in the model, not 
by which tool you used to draw the wall. 

 l Any wall or wall segment that is entirely surrounded by interior room areas is considered to be an interior wall. 
 l Any wall or wall segment that defines an exterior room or is exposed to the outside of the building is considered to be 

an exterior wall. See Room Types and Functions on page 420. 

For some purposes, a wall is considered to be exterior based on whether it forms part of the Thermal Envelope that 
surrounds the plan’s Conditioned Area. For example, a Framed wall that separates Conditioned Area from Unconditioned 
Area will be included when Thermal Envelope information is exported to REScheck. It will also have insulation counted in 
the Materials List. See Exported Envelope Data on page 1247 and In the Materials List on page 368.         

 

Foundation Walls
Foundation walls are similar to the interior and exterior walls but also have a footing. Foundation walls can 
either be created automatically when a foundation floor is created or manually by drawing them using the 

Straight or Curved Foundation Wall tool. See Building a Foundation on page 722. 
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The initial foundation wall type and footing size              are specified in the Foundation Wall Defaults dialog. These values can be 
changed for individual walls in the Wall Specification dialog. See Wall Specification Dialog on page 395.         

You can draw a foundation wall on any floor of a plan, not just on the foundation level. Any wall can be specified as a 
foundation wall, regardless of the tool used to draw it. See Foundation Panel on page 405.           

Foundation walls are placed on the “Walls, Foundation” layer by default, but can be put on any layer you choose. In plan 
view, foundation wall footings are placed on the “Footings” layer and cannot be moved; in 3D views, they are on the 
“Walls, Foundation” layer. See Displaying Walls on page 366.

SLAB FOOTING

The Slab Footing tool draws a single-layer concrete wall using the wall type and other attributes specified in the Slab 
Footing Defaults dialog. Slab Footings are used to define Monolithic Slab foundations, garage curbs, and interior 

footings. Typically, that wall type should have the same width as that specified for footings. For Garage curbs, the footings 
should be wider than the wall type. See Foundation Panel on page 405.         

Rooms defined by Slab Footings will have a Ceiling Height of 0 and a Monolithic Slab Foundation. See Structure Panel on 
page 444.         

FOUNDATION WALL FOOTINGS

Normally, a foundation wall’s footing is centered on the wall. If you prefer, you can:          

 l Center the footing on the main wall layer.          
 l Align the footing along the wall’s exterior.          
 l Specify an offset, as measured from the wall’s center line.          

These offset options are set in the Wall Specification dialog. See Foundation Panel on page 405.           

You can select the footing in 3D views and edit its size and shape using the edit handles. See Stepped and Raked Walls on 
page 384.          

Foundation wall footings extend past the end of a foundation wall the same amount that they extend past each side when 
centered on the wall.           

To create a footing that extends more than that amount, create a short segment of foundation wall at that location and 
specify it as Invisible.          

BRICK LEDGES

Brick ledges can be produced in monolithic slab, stem wall, and grade beam foundations. They do not extend under door 
openings in monolithic slab foundations.          

Brick ledges are represented in plan view by lines on the “Brick Ledge Lines” layer. See In Plan View on page 366.         
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In order for a brick ledge to be produced, the foundation wall material directly under the brick ledge must be             the “Concrete” 
Structure Type              and the wall material that drops into the brick ledge must be              the "Masonry" Type. See Material Structure 
Types on page 1064. 

In addition, the Wall Type Definition for the foundation wall must have a Brick Ledge Depth value greater than zero. See 
Wall Type Definitions on page 388.

Additional settings that control whether a brick ledge is produced as well as its size are found in the Wall Type Definition of 
the wall that is located above the brick ledge.

 l The width of the ledge is equal to that of the Exterior Layers of the wall type.          
 l The Foundation to Exterior of Layer setting must be the wall type’s exterior layer.           
 l The Build Platform to Exterior of Layer setting cannot be the wall type’s exterior layer.          

If the floor platform inside a brick ledge is hung on the foundation wall, Subflooring to Wall Interior must be checked in 
the Wall Specification dialog in order for a brick ledge to generate. See Structure Panel on page 398.          

 

Pony Walls
A Pony Wall, sometimes called a split wall, is a wall with two separate wall types, one above the other.         

Walls drawn using the Pony Wall  tool are created using the wall types and other information specified in the Pony Wall 

Defaults dialog. See Pony Wall Defaults on page 349.         

Most pony walls combine two exterior or two interior wall types; however, a pony wall can also produce an individual wall 
to be an exterior wall near its top and an interior wall near its bottom. See Exterior/Interior Pony Walls on page 383.         

When a pony wall is also specified as a Railing, its upper wall is replaced by a railing. See Wall Types and Railings on page 
354.          

You can also convert a normal wall into a pony wall and vice versa in the Wall Specification dialog. See Wall Types Panel 
on page 407.          

The height where the upper portion meets the lower can be adjusted in 3D views using the wall’s edit handles as well as in 
the Wall Specification dialog. The upper and lower sections of a pony wall are linked, so if either portion is modified along 
the division between the two, the other portion of the pony wall adjusts to match.              See Stepped and Raked Walls on page 
384.

357



Chief Architect Premier X14 Reference Manual - Room Dividers and Invisible Walls

DISPLAYING PONY WALLS

You can specify whether the upper and lower portion of pony walls displays in plan view in the Pony Wall Defaults dialog. 
This Display in Plan option can also be set for individual walls in the Wall Specification dialog. See Wall Types Panel on 
page 407.         

Just as with other walls, the appearance of the portion of a pony wall that displays in plan view can be controlled. See 
Displaying Walls on page 366.          

Only the portion of a pony wall that displays can be snapped to; however, regardless of what part is displaying, the upper 
wall will be used to Align with Wall Above , and the lower part will be used to Align with Wall Below . See 

Editing Walls on page 372 and Aligning Walls on page 378.   

By default, when a door or window is located entirely in one part of a pony wall, and that part is not displayed in plan view, 
the opening’s outline is shown but the wall’s layer lines and fill drawn through it. You can instead display openings in the 
non-displayed parts of pony walls the same as in the displayed parts, or not at all. See Pony Wall Defaults on page 349.          

If a window or door is completely contained by one part of a pony wall, it will display in plan view if the other part of the 
pony wall is shown; but the wall’s layer fill pattern or Wall Hatching fill pattern will display over it.          

The Display in Plan and Display of Openings in Non-Displayed Parts of Walls settings on the WALL TYPES panel of the 
Pony Wall Defaults dialog are saved with and can be different in each Saved Plan View. See Plan Views on page 150.          

LOWER PONY WALL CAPS

You can specify a cap over the top of a lower Pony Wall. See Wall Cap Panel on page 409.          

By default, the cap generates on the exterior side of a Pony Wall, outward from the surface of the upper wall. This detail is 
sometimes referred to as a “water table”.          

You can also specify that the cap build between the two parts of the Pony Wall, splitting them, as well as span the full width 
of the wall, which is the default for Pony Walls with Railings above. See Railings Over Walls on page 354.          

CHANGING WALL TYPES

The default upper and lower parts of a Pony Wall can be specified in the Pony Wall Defaults dialog. See Pony Wall 
Defaults on page 349.         

The upper and lower parts of a Pony Wall can be redefined as different wall types in the Wall Specification dialog. See Wall 
Types Panel on page 407.         

 

Room Dividers and Invisible Walls
The Room Divider tool is used to define separate room areas in a plan; typically, by dividing a large room area into 
two or more smaller areas. See Room Definition on page 418.

Common uses for Room Dividers                                           include dividing areas of an open floor plan into areas with different purposes.          
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Room Dividers can also be used to define areas with different floor or ceiling materials or heights. 

Room Dividers  are drawn using the attributes specified in the Room Divider Defaults dialog; which means they are 

simply walls that are specified as Invisible and have a single layer of an “Air Gap” material with a thickness of 0” (mm). 

If a zero-thickness Room Divider  separates two rooms with different floor and/or ceiling heights, its wall type will be 

changed to the current plan’s default Interior Wall so that the platform step created by the height difference can be enclosed. 
See Floor and Ceiling Platforms on page 433.

INVISIBLE WALLS

Any wall, regardless of its wall type or thickness, can also be specified as Invisible - or vie versa - in the Wall Specification 
dialog or by clicking the Make Wall(s) Invisible  or Make Wall(s) Visible  edit button. See General Panel on page 

395.

Room Dividers are placed on the “Walls, Invisible” layer by default, as are walls that are specified as Invisible. A wall 
placed on a non-default layer and then specified as Invisible, however, will not move to the “Walls, Invisible” layer. See 
Room Divider Defaults on page 350. 

Walls specified as Invisible can display in plan view but not in 3D views or the Materials List. See Displaying Walls on 
page 366.

It is not possible to place doors or windows  into an Invisible wall; however, if a wall with openings in it is specified as 
Invisible, any openings in it will remain. 

IMPORTANT NOTES ON INVISIBLE WALLS

 l Floor, wall and ceiling areas are calculated separately for rooms divided by Invisible walls.
 l Invisible walls are ignored by the Auto Place Outlets  tool; it functions as though they were not present. 

 l Cabinets, fixtures and furniture can be moved freely through Invisible walls. 
 l Invisible walls can be drawn through a cabinet to attach to the wall behind.         
 l By default, Room Dividers are automatically generated to connect “island” rooms to the larger structure around them. 

You can turn this behavior off in the General Wall Defaults dialog. See General Wall Defaults on page 346.

 

             Polygon Shaped Rooms and Decks
The Polygon Shaped Room and Polygon Shaped Deck tools allow you to create rooms with regular sides and work 
similar to the Regular Polygon  CAD tool. See Regular Polygon on page 325.           

Select Build> Wall> Polygon Shaped Room to open the New Polygon Shaped Room dialog and create a polygon 
shaped room with regular sides.         
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Select Build> Railing and Deck> Polygon Shaped Deck to open the New Polygon Shaped Deck dialog and create a 
polygon shaped deck with regular sides.         

The settings in these two dialogs are identical and are saved between program sessions. They are also independent of one 
another so different settings can be retained for each.           

To create a polygon shaped room or deck
 1.  Click the radio button beside an option to specify whether you want to Define Polygon by Side Length, Radius to 

Corner or Radius to Side.         

 2.  Specify the desired Number of Sides.         

 3.  Specify the desired Side Length or,         

 4.  Specify the desired Radius.         

 5.  Uncheck Include Railing to produce a deck platform defined by Deck Edges. This option is not available in the 
New Polygon Shaped Room dialog.         

 6.  Click OK, then click once in plan view to create the specified polygon shaped room or deck.         

 

Wall Hatching
The Wall Hatching tool can be used to fill wall segments with a single hatch pattern in plan view. To apply wall 
hatching, select Build> Wall> Wall Hatching, then click on a wall. The hatch pattern covers the entire length and 

width of the wall segment.

Note: The Wall Hatching tool cannot be used to apply a hatch pattern to 
Invisible Walls or to walls on a locked layer. See Room Dividers and 
Invisible Walls on page 358 and Locking Layers on page 182.

Wall Hatching places a hatch pattern across all layers of the selected wall layers displaying in the current view, covering 
any fill styles specified for that wall type. When wall hatching is applied to a railing, or when the “Walls, Main Layer Only” 
layer is turned on, wall hatching only displays in the Main Layer(s). See The Main Layer on page 388.

In many cases, it is preferable to create a wall type definition rather than use the Wall Hatching tool because multiple fill 
styles can be used. See Wall Type Definitions Dialog on page 390.         

Wall hatching can be selected, edited and deleted much like other line-based objects. See Editing Line-Based Objects on 
page 218.

The initial appearance of wall hatching can be specified in the Wall Hatching Defaults dialog. Once created, the wall hatch 
pattern and its line weight can be customized in the Wall Hatching Specification dialog. See Wall Hatching Specification 
Dialog on page 416. 
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If you use the Wall Hatching tool to apply a hatch pattern to a wall that has been divided into multiple segments using the 
Add Break  edit tool, the pattern is only applied to the segment that you clicked on. See Add Break on page 257.

Like doors and windows, wall hatching must be placed within a single wall segment but can be edited to extend across 
multiple collinear wall segments after it is created. Unlike doors and windows, only the midpoint of Wall Hatching can be 
located by dimension lines.

If three or more wall hatching objects occupy the same space in a wall, a Caution   symbol will display at the problem 
location in plan view. Click on the Caution   symbol that displays over the wall to open a contextual menu, then select 
Delete to delete a duplicate wall hatching. When no more Caution symbols remain, you should then confirm that the 
remaining two wall hatching objects meet your needs and delete any that are unnecessary.

When editing or deleting wall hatching, make sure that it is selected rather than the wall by noting that “Wall Hatching” 
displays in the Status Bar. See The Status Bar on page 25. 

 

Creating Walls
Walls, railings, and fencing are drawn similar to the way CAD lines are drawn: select a Wall Tool or a wall saved in the 
Library Browser, and then click and drag from end to end in the drawing area by clicking and dragging from end to end. 
Walls can be drawn in plan view, camera views, and overviews. See Line Tools on page 305.

There are several other ways that walls can be created in Chief Architect:

 l Exterior walls can be generated automatically when a new floor is built by using another floor as a model. See Adding 
Floors on page 745.

 l Foundation walls are created when a foundation is automatically generated on Floor 0. See Foundations on page 717. 
 l Attic walls are generated automatically when the program perceives a gap between a wall that defines a room and the 

roof above. See Attic Walls on page 383.
 l The Space Planning Assistant creates room boxes which can be arranged and then converted into walls. See Space 

Planning on page 62.
 l 2D CAD lines can be converted into walls using the CAD to Walls tool. See CAD to Walls on page 387.             

DRAWING WALLS

Drawing walls to create a floor plan is simple if you keep a few things in mind: 

 l Draw exterior walls first to define the building’s footprint, then draw the interior walls after the perimeter is in place. 
 l It is easiest to draw walls at the approximate location and length needed and then move or resize them precisely using 

dimensions later. See Moving Objects Using Dimensions on page 491. 
 l When drawing and positioning exterior walls, make sure Grid Snaps  are enabled. Once these walls are in place, 

you may prefer to turn Grid Snaps off to draw and position interior walls and other objects. See Grid Snaps on page 
167. 

 l If you wish to input wall lengths as you draw, make sure your General Wall Defaults are set to Resize About Outer 
Surface. See Entering Wall Lengths and Angles on page 363.           

 l As walls are drawn, Intersection Snap indicators, “sticky” points and extension lines identify points that are either 
collinear or orthogonal to the end points of other walls, making alignment easier. See Wall Intersection Extension 
Snaps on page 165. 

361



Chief Architect Premier X14 Reference Manual - Creating Walls

 l As walls are drawn, Angle Snaps take priority over Object Snaps. If you prefer that walls draw at any angle so that 
they can snap to other objects, uncheck Always Snap Walls On Allowed Angles in the Preferences dialog. See Snap 
Properties Panel on page 122.             

 l When walls enclose an area to form a room, the program will orient all exterior walls so that the siding material faces 
outward. You can disable this behavior if you wish. See Interior and Exterior Surfaces on page 390 and General Wall 
Defaults on page 346. 

 l To flip the layers of a wall after it is drawn, select it and click the Reverse Layers  edit button. See Editing Walls 

on page 372.
 l Initial wall heights are determined by the default floor and ceiling heights of the current floor. See Floor Defaults 

Dialog on page 744.

WALL ANGLES

With very few exceptions, walls should be drawn and edited with Angle Snaps  enabled. Walls that are drawn at 

irregular angles can result in wall connection,  alignment, and room definition problems. 

If a wall is drawn at an off angle, the Off Angle Wall   icon will follow the mouse pointer and a Caution   symbol will 
display over the problem wall in plan view. See Pointer Icons on page 16.

To correct the wall’s angle, click on the Caution   symbol that displays over the wall and select Fix Off Angle Wall from 
the contextual menu. In the Fix Off Angle Wall dialog:

 l The Old Angle is stated for reference.
 l Enter a New Angle in the text field.
 l Specify whether to Lock the Start, Center, or End point of the wall when its angle is changed.

There are several other ways to fix a selected wall if it has been drawn at an off angle: 

 l Click the Open Object  edit button and specify the correct angle. See General Panel on page 395.

 l Click and drag an end edit handle until the wall snaps to an Allowed Angle. See Angle Snaps on page 166.
 l If the wall in question should be aligned with a wall directly above or below it, click the Align with Wall Above  

or Align with Wall Below  edit button. See Aligning Walls on page 378.

You can also suppress the Caution symbol by specifying the needed angle in the wall’s specification dialog or adding that 
angle to the list of Allowed Angles. See General Plan Defaults Dialog on page 96. 

Although not recommended unless the walls in question are Fencing, Terrain Walls, and/or Retaining Walls, you can choose 
to Ignore Off Angle Wall or Ignore  All Off Angle Walls by clicking on the Caution   symbol that displays over an off 
angle wall. See Fencing Tools on page 354 and Terrain Wall and Curb Tools on page 1261.

WALL POSITIONING

The recommended method of drawing walls is to draw them at their approximate location and length, then move them into 
position with accuracy using dimensions. To make this task quick and efficient: 
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 l Notice the temporary wall that displays as you draw. Its length and angle display in the Status Bar at the bottom of the 
window and adjust as you move the mouse. Release the mouse button to draw the wall at the displayed length and 
angle. See The Status Bar on page 25. 

 l Use Snaps to help ensure proper wall alignment and orientation. See Snap Behaviors on page 163. 

Once walls are drawn, they can be accurately dimensioned and moved as needed. See Measuring Walls on page 369. 

ENTERING WALL LENGTHS AND ANGLES

The fastest way to draw walls is to draw them at their approximate position and length, and then move or resize them 
accurately using dimensions. See Using Dimensions on page 373.          

For those that wish to enter walls’ lengths and angles as they are drawn, first select Resize About Outer Surface in the 
General Wall Defaults dialog. See Resize About on page 379.          

Then draw a wall, select it, and specify its Length and Angle in the Wall Specification dialog.  Draw a second wall and 
specify its length and angle, and so on. See General Panel on page 395.          

You can also press the Tab key while you are dragging to draw a wall to open the Enter Coordinates dialog, where you can 
enter the wall’s Distance, or length, and Angle. See Entering Coordinates on page 170.           

WALL OPENINGS

To create a door or doorway, do not draw wall sections with a gap between them. Walls should be drawn to completely 
enclose rooms, and then door and window objects should be placed in the walls to create openings later. See Doors on page 
551 and Windows on page 584. 

TEMPORARY DIMENSIONS

Temporary dimensions will display along the length of a wall as it is drawn when Temporary Dimensions are 
toggled on. See Temporary Dimensions on page 480. 

CONTINUOUS WALL DRAWING

You can draw walls continuously by right-clicking, Alt+clicking or Alt+dragging. See To draw continuous lines on page 
305.          

By default, this continuous drawing behavior will turn off when walls are drawn to form an enclosed area. You can specify 
that this behavior remain on in the Preferences dialog. See Behaviors Panel on page 120.          

DRAWING CURVED WALLS

Drawing a curved wall, curved railing, or curved fence is similar to drawing a CAD arc. See Arc Tools on page 315.         

As with CAD arcs, the method used to draw a curved wall depends on which Arc Creation Mode  is currently active.  

See Drawing Arcs - Arc Creation Modes on page 313.          

A straight wall can also be converted into a curved wall and vice versa using the Change Line/Arc  edit button. See 

Change Line/Arc on page 259.

To create a room in the shape of a circle, you must draw two 
curved walls.
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A curved wall always has a center point. The center displays as a small cross when Show Arc Centers and Ends  is 

enabled. See Arc Centers and Ends on page 225.         

The radius of a curved wall is measured from the center to a surface or layer of the wall. The radius can be defined in the 
Wall Specification dialog. You may elect to define the radius to the exterior or interior wall layers. See  General Panel on 
page 395.         

SPACE PLANNING ASSISTANT

The Space Planning Assistant Tools allow you to place and arrange room  boxes that can then be converted into a 
fully editable house plan, including walls. See Space Planning on page 62.         

WALL FRAMING

Once walls have been drawn, they can be framed. For best results, avoid generating framing until your model is in its final 
form. See Wall Framing on page 866.           

Framing for an individual wall can be built or rebuilt using the Build Framing for Selected Object  edit tool. This tool 

is only available if the selected wall has a framing material assigned to its Main Layer, and is not available if Retain Wall 
Framing is checked in the Wall Specification dialog. See Build Framing for Selected Object(s) on page 900.           

Once created, wall framing can be viewed and edited in floor plan and 3D views, as well as in Wall Detail  views. See 

In Wall Detail Views on page 896.          

 

Connecting Walls
When walls are drawn sufficiently close to one another, they will snap together to form an intersection. This snapping 
occurs when the walls’ center lines are within a distance defined by the larger of the two walls’ widths and will occur even 
when Object Snaps  are turned off. See Object Snaps on page 164.

If the two walls in question have identical specifications and are collinear, they will merge to become a single wall. See 
Aligning Collinear Walls on page 379.  

When three or more walls connect to form a completely enclosed area, that area defines a room. See Rooms on page 417.

When walls snap together to form an intersection and Object Snaps  are enabled, the program joins them at their Resize 

About line, which is specified in the General Wall Defaults dialog. See Aligning Walls on page 378. 

 l The wall that is being drawn or edited will move, lengthen, or shorten slightly to meet the other wall. 
 l The other wall will not move; however, its length may be affected. 
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WALL INTERSECTIONS

Any time two walls intersect, one wall will build through the other. You can turn on the display of the “Walls, Through 
Wall Lines” layer in plan view to see which walls build through and which do not. See Layer Attributes on page 181.           

When a wall builds through another wall, it will extend into the intersected wall until it meets the interior surface of that 
wall’s Main Layer. See The Main Layer on page 388.          

You can specify which walls build through wall intersections at corners in the Wall Specification dialog. See Structure 
Panel on page 398.          

You can also control how the individual layers of one wall build into another using the Edit Wall Layer Intersections  

edit tool. See Wall Layer Intersections Edit Handles on page 377.           

PARTITION WALLS

By default, walls not only build to an intersecting wall’s Main Layer, they also build through the finish layers of the floor 
below and the ceiling above to reach the structural layers.          

In some situations, though, this is not desirable: for example, glass shower walls are typically installed against the surfaces 
of walls, floors and ceilings rather than building into them. To achieve this, use               a wall type that is specified as a Partition 
Wall. See Wall Type Definitions Dialog on page 390.

FIX WALL CONNECTIONS

Occasionally, intersecting walls  may not properly connect. When this is the case and the connection in question is on 
the current floor, a Caution   symbol will display at the problem location in plan view and the Connect Walls   

icon will follow your mouse pointer.

Click on the Caution   symbol that displays over the wall to open a contextual menu: 

 l Select Delete to delete the wall.
 l Select Ignore Unconnected Wall to leave the wall unchanged and suppress the Caution symbol.

To correct wall connections throughout the current plan, select Build> Walls> Fix Wall Connections .           

Alternatively, you can fix an individual wall connection using the Connect Walls  edit tool.          

To use the Connect Walls edit tool
 1.  Select a wall.          

 2.  Click the Connect Walls  edit button.          

 3.  Click on a wall that you want to connect to the selected wall.           
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 l If the unconnected wall ends are sufficiently close to one another, the tool connects them.           

 l If the separation is too great, extend one towards the other and try again.           

REMOVING WALL BREAKS

The Add Break  edit tool allows you to break a wall into two or more separate wall segments. See Add Break on page 

257.

To merge two collinear walls separated by a break, select one of the segments, then click the end edit handle located at the 
break and drag it a few plan inches (mm) away from the break. 

If the two walls do not merge, either the walls are not collinear or their specifications are not identical. You can open the 
Wall Specification dialog for each wall and determine how they differ. See Wall Specification Dialog on page 395.

You can prevent collinear walls from merging by unchecking Auto Merge Collinear Walls in the General Wall Defaults 
dialog. Turning this option off is useful when representing panelized walls. See General Wall Defaults on page 346.

 

Displaying Walls
 While the structure and appearance of each wall type is controlled in the Wall Type Definitions dialog, the display of 
walls in all views is controlled in the Layer Display Options dialog. See Layer Attributes on page 181.

The program installs with a number of layers intended for specifically for various types of walls; however, you can specify 
any layers as the defaults for most of these walls. Once created, you can also place a selected wall on any layer. See Layer 
Panel on page 410.          

If a “Walls” layer is turned off in plan view, any doors and windows placed in walls on that layer will not display, either. 
See Displaying Doors on page 556 and Displaying Windows on page 594.

IN PLAN VIEW

The appearance of each wall type, including line weights and colors and wall layer fill styles, is specified in the Wall Type 
Definitions dialog. See Wall Type Definitions Dialog on page 390.

In addition, a separate custom fill style can be specified for the footings of foundation walls. See Foundation Panel on page 
405.

There are also several options for controlling how walls are displayed in plan view. In the Layer Display Options dialog, 
you can specify whether or not various types of walls display.

 l By default, walls are placed on layers with “Walls” at the beginning of the layer name, such as “Walls, Normal”. 
 l The display of the wall layers specified in the Wall Type Definitions dialog can be controlled. If you turn off the 

display of the layer called “Walls, Layers”, wall types display with two lines representing the inside and outside 
surfaces.           

 l In addition, you can turn off the display of non-structural layers and show only the walls’ Main Layers by turning on 
the display of the “Walls, Main Layer Only” layer. This allows you to create both fully configured walls and framing 
layouts. The “Walls, Main Layer Only” layer affects the display of walls in plan view only. See The Main Layer on 
page 388.          

 l The “Walls, Through Wall Lines” layer controls the display of lines indicating which walls build through at wall 
intersections.          
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 l Foundation Walls have footings that display in all view when the “Footings” layer is turned on. You can place footings 
on a custom layer if you wish. See Displaying Foundations on page 723. 

 l Foundation Walls may also have brick ledge lines that display in plan view when the "Brick Ledge Lines" layer is 
turned on. See Brick Ledges on page 356.

Note: In plan view, railings not specified as Solid display their Main 
Layer regardless of whether “Walls, Layers” or “Walls, Main Layer 
Only” is turned on. See Wall Types and Railings on page 354. 

Either the upper or lower portion of a Pony Wall can display in plan view. Only the portion that displays can be snapped to 
or aligned with walls above or below. See Pony Walls on page 357.         

Railing newels, balusters, and rails can be set to display in plan view in the Railing Specification dialog. See 
Newels/Balusters Panel on page 414.          

It is sometimes helpful to display the walls from a floor other than the current floor. To do this, select and display a 
reference floor. See The Reference Display on page 69. You can also specify which layers are included in the Reference 
Display Layer Set in the Layer Display Options dialog. 

NOTIFICATION ICONS

Occasionally, the program may detect a problem with one or more walls in a plan. When this is the case, notification icons 
will display on the floor where the problem has occurred:

 l If a wall is drawn at an off angle, the Off Angle Wall   icon will follow the mouse pointer and a Caution   symbol 
will display over the problem wall in plan view. 

 l If there is a problem with a wall connection, the Connect Walls   icon will follow the mouse pointer and a Caution 
 symbol will display at the problem location.

The recommended response to either situation is to fix the problem, although you can choose to ignore it if you prefer. See 
Wall Angles on page 362 and Fix Wall Connections on page 365. 

If an issue has been ignored, notification icons for it will not display. Select Tools> Checks> Reset Notification Icons to 
display any suppressed notifications so that any wall angle or connection problems can be corrected.

IN 3D VIEWS

As in plan view, the display of walls can be controlled by layer in the Layer Display Options dialog. 

Each layer of a wall is generated when you create a 3D view. You can see the different layers in 3D using the Delete 
Surface  tool. See Delete 3D Surface on page 1099.         

A wall’s framing layer displays as a solid layer rather than studs and plates until wall framing is built. See Framing on page 
864. Wall framing is placed on the “Framing, Wall” layer by default.

When a camera is located on the exterior of a structure, you can select 3D> Camera View Options> Hide Camera-Facing 
Exterior Walls , allowing the interior to be seen as you rotate around the model. Interior walls set as Attic walls are also 

hidden when this setting is active. See Hide Camera-Facing Exterior Walls on page 1132. 

While most architectural objects in the program can display in both floor plan and 3D views, a few cannot. Invisible walls 
and Wall Hatching are examples of objects that do not display in 3D, regardless of what layer they are placed on.

Unlike in plan view, doors and windows placed in a wall can display in 3D views even if the wall’s layer is turned off. See 
3D View Defaults Dialog on page 1084.
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IN CROSS SECTIONS

When the Auto Detail  tool is used in a cross section view, the fill style of each wall layer as set in its Wall Type 

Definition is used. See Auto Detail on page 1095.           

WALL LABELS

Wall labels are located on the “Walls, Layers” layer and can be set to display in plan and cross section/elevation views. See 
Label Panel on page 712.    

Walls do not have Automatic Labels by default. Once wall framing has been built, however, framed walls will be assigned 
Automatic Labels that correspond to each wall’s Wall Detail . See In Wall Detail Views on page 896.

Concrete and masonry walls’ automatic labels are always blank; however, custom labels can be assigned to any wall in the 
Wall Specification and Defaults dialogs. If you wish, you can use Named Values to create custom text macros for wall 
labels. See Working with Name-Value Pairs on page 1394. 

Wall label information included when Export to REScheck  is used. See Export to REScheck on page 1247.         

WALL MATERIALS

There are several ways that materials can be assigned to walls, depending on how the walls and the rooms they define have 
been defined. See Rooms on page 417. 

When you draw a wall, it uses the materials specified in its wall type definition. See Wall Type Definitions on page 388. 

You can change the surface material of an individual wall in the Wall Specification dialog. If you select “Use Default” as 
the material and the wall is used to define a room, the program refers to the material specified in the Room Specification 
dialog. See Wall Specification Dialog on page 395.

You can also change a room’s wall material in the Room Specification dialog. See Materials Panel on page 1055. To 
restore the default Wall Type material, select Use Default in the Select Material dialog. See Select Material/Library Object 
Dialog on page 1057. 

Wall materials can also be changed using the Material Painter  tool, but bear in mind that depending on which Material 

Painter Scoping Mode is in use, only a portion of the wall may be painted and that the entire room may be affected rather 
than the individual wall. See Material Painter and Walls on page 1055.

When neither the wall nor the room has a material assigned to it, the program refers to the general material for walls in the 
Material Defaults dialog. See Material Defaults on page 1052.          

Note: Wall materials that are specified on the Materials panel of either 
the Wall or Room Specification dialog are not calculated in the Materials 
List.

IN THE MATERIALS LIST

The materials that make up wall assemblies are listed under different Categories in the Materials List: 
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 l Siding - Lists the materials assigned to each wall’s Exterior Layers, such as siding, sheathing, and housewrap. 
 l Framing - Lists the framing material(s) for all walls as well as railings specified as Solid. Non-framed walls’ Main 

Layer materials are also listed here when those walls are not specified as Foundation. Wall framing, including studs, 
plates, and headers, is only counted when a framing material has been assigned to a wall type and wall framing has 
been built. See Framing on page 864.

 l Insulation - Insulation is calculated for all walls that separate Conditioned from Unconditioned space, are not defined 
as Railings, and have one or more Framing layers. Insulation thickness is equal to that of the framing layer. See 
Exterior and Interior Walls on page 355.

 l Wallboard - Lists the materials assigned to each wall's Interior Layers, such as drywall. 

Does not include Wall Coverings or materials specified in either the Room or Wall Specification dialog. See Materials 
Panel on page 410.

 l Interior Trim - Lists base, crown and chair rail moldings, and Wall Covering materials specified in the Wall and 
Room Specification dialogs. See Wall Covering Panel on page 409.

 l Foundation - Lists the concrete, block, and rebar for all walls specified as Foundation as well as their footings. See 
Foundation Walls on page 355.

 l General - Reports the thickness of glass wall materials and their total lengths. 

With the exception of wallboard, windows and doors are taken into account in the calculation of these totals.

Slab Footings as well as the room areas that they define can be assigned Pour Numbers in their specification dialogs. Pour 
Numbers are listed separately under the Foundation category of the Materials List. See Foundation Panel on page 405.          

Wall framing members can be reported in a Materials List using one of four methods: Linear Length, Buy List, Cut List, or 
Mixed Reporting. See Structural Member Reporting on page 1312.

WALL SCHEDULES

The Wall Schedule tool allows you to produce customizable wall schedules or legends with information about wall 
types, wall assembly layers, length, and more. See The Schedule Tools on page 695.         

All wall types present in the current plan are listed in the Schedule Specification dialog. See Wall Type Definitions on page 
388.    

When a new wall type is created, it will be included in any existing Wall Schedules as well as in the Wall Schedule Defaults 
automatically. See General Panel on page 705.     

A wall type that is not set to be included may still be listed in a Wall Schedule if it is part of a Pony Wall. See Pony Walls 
on page 357.   

You can also specify which individual walls are included in a Wall Schedule in the Wall Specification dialog. This affects 
totals like "Total Length" and "Count". If the wall in question is the only instance of its wall type, that wall type will not be 
listed even if it is set to be included in the Wall Schedule. See General Panel on page 395.    

An Invisible Wall will be included in a Wall Schedule provided that its wall type is set to be included and it has Include in 
Schedule checked.    

 

Measuring Walls
Accurate wall measurements are an essential aspect of any drawing, and can be achieved by following two basic rules:

 l Be aware of what part of a wall assembly dimensions are locating;
 l Position walls using dimensions rather than edit handles or edit tools.
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These rules can easily be met when you keep the following recommendations in mind.

For information about changing the value reported in a dimension line label, see Using Dimensions on page 373.   

DIMENSION DEFAULTS

Manually-drawn, automatic, and temporary dimensions can all be set to locate walls at their Dimension Layers or at their 
surfaces. Before drawing dimensions - and particularly, before using them to move your walls into position - make sure that 
all of your Dimension Defaults are set up to meet your needs. See Dimension Preferences and Defaults on page 455.

If a wall is specified as Invisible, dimensions will locate it at its centerline regardless of its Wall Type Definition or your 
Dimension Defaults settings. If the Invisible wall divides rooms with different floor heights, dimensions will locate the edge 
of the wall facing the room where the floor is lower. 

Be aware, too, that the wall length dimension that displays when a wall is selected as well as the Length specification in the 
Wall Specification dialog do not inherit their settings from the Dimension Defaults. Instead, they follow the Resize About 
line. See Resize About on page 379. 

Manually-drawn and automatic dimensions can also be set to locate a number of elevation marks associated with walls. See 
Locate Elevations Panel on page 473.         

PRIMARY AND SECONDARY SIDES

When dimensions that locate walls are drawn or generated in plan view, a Primary and a Secondary Side for each wall is 
identified. For exterior walls, the Primary Side is always the exterior side of the Wall Type Definition and the Secondary 
side is always the interior. See Wall Type Definitions on page 388.

For interior walls, the functionality is more complex:

 l For vertical interior walls with perfectly symmetrical wall layers, the Primary Side is always on the left side of the 
wall as it is drawn in the plan, regardless of the orientation of its layers.

 l For horizontal interior walls with perfectly symmetrical wall layers, the Primary side is always on the bottom side of 
the wall as it is drawn in the plan.

 l For both vertical and horizontal interior walls with wall layer that are not symmetrical, the functionality is the same as 
that for exterior walls: the Primary Side is always the exterior side of the Wall Type Definition and the Secondary side 
is always the interior.

With the exception of Interior and Auto Room Dimensions, you can specify whether the various dimension tools locate the 
Primary Side, Secondary Side, or both in the Dimension Defaults dialog. See Locate Manual Panel on page 460.

EDIT DIMENSION LINES

Once a dimension line has been drawn, its extension lines can be edited to locate a number of locations on a wall assembly:

 l The exterior surface
 l The Wall Dimension Layer’s exterior          
 l The center line of the wall assembly
 l The Main Layer’s center line
 l The Main Layer’s interior
 l The interior surface

Dimension lines that are drawn through a wall can also be set to measure and report the widths of walls, or to suppress that 
information. See Dimension Panel on page 494.

370



Chief Architect Premier X14 Reference Manual - Measuring Walls

See Editing Extension Lines on page 486. 

MOVING WALLS USING DIMENSIONS

By far, the most precise method of positioning walls is using dimension lines. To produce accurate measurements, 
remember to: 

 l Be aware of what part of your walls is being located by each type of dimension.
 l Avoid specifying dimension values with greater accuracy than your dimensions are set to display. See Primary Format 

Panel on page 465. 

See Using Dimensions on page 373.

Remember that the temporary wall length dimension that displays when a wall is selected may be set to locate a different 
part of the wall assembly than other dimension lines. See Wall Length on page 375.           

USE OBJECT, ANGLE AND GRID SNAPS

Object Snaps, Angle Snaps, and Grid Snaps make it easier to align walls when they are being drawn as well as when they 
are edited. See Snap Behaviors on page 163. 

Object Snaps  help to ensure consistent wall connections and are particularly helpful when aligning collinear walls. 

When Grid Snaps  are enabled, walls are drawn on a regularly spaced grid, which helps avoid inaccurate wall 

placement. This can become particularly important if you forego positioning walls using dimensions in favor of using edit 
handles to move them. 

Using Grid Snaps is recommended when you are laying out 
exterior shell walls, but may be inconvenient when positioning 

interior walls or other objects. 

Angle Snaps  make it easy to accurately draw walls at regular angles, ensuring walls that are truly parallel or 

perpendicular to one another and separated by consistent distances.

NO LOCATE

If a wall is specified as No Locate in the Wall Specification dialog, it will be ignored by Auto Exterior Dimensions  in 

plan view, as will any doors or windows placed in it. See Dimensions on page 454.

By default, Railings, Deck Railings, and Room Dividers are specified as No Locate. See General Panel on page 395.

If a wall is on its default layer and is specified as No Locate, it will be moved to the “Walls, No Locate” layer. If this box is 
later unchecked, the wall will return to its default layer. If a wall is on a non-default layer, it will remain there. See 
Displaying Walls on page 366.           

Once a dimension line has been created, it can be edited so that it locates a No Locate wall or railing that is perpendicular to 
it. See Editing Dimension Lines on page 484. 
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Editing Walls
Walls can be selected in all views. When a wall is selected, it displays edit handles and an edit toolbar that can be used to 
modify it in various ways. When a wall is selected, temporary dimensions may also display. See Temporary Dimensions on 
page 480. 

The ways in which a wall can be edited depend on the current view and which edge is selected. See Selecting Objects on 
page 212. 

SELECTING WALLS

Like other objects, walls can be selected in a variety of ways. See Selecting Objects on page 212.

In plan view, if wall hatching has been applied to a wall using the Wall Hatching  tool, it is possible that the hatching 

may be selected first. If it is, click Select Next Object  to select the wall itself. See Wall Hatching on page 360.

 l When Select Room Before Wall in 3D is checked in the Preferences dialog and you click on a wall in a cross 
section/elevation or camera view, the room defined by that side of the wall will become selected instead of the wall. 
See Appearance Panel on page 99 and Selecting Rooms on page 423.

When this is the case, you can select the wall by clicking the Select Next Object  edit button or pressing the Tab 

key.          
 l In plan views, the Edit Area  tools allow you to select only part of a wall or walls. See Edit Area Tools on page 

273.          
 l In a Wall Detail, Framing Overview or other 3D view in which wall framing can be seen, select a wall framing 

member and click the Find Wall  edit button to switch to a plan view in which the wall associated with the 

selected framing is selected. A wall selected in this manner can then be edited even when its layer is turned off and/or 
locked. See Locking Layers on page 182. 

USING THE EDIT HANDLES

A selected wall can be modified in a variety of ways using its edit handles in any view. The handles that are available will 
depend on the current view type. See Edit Handles for Walls on page 375.

IN THE SPECIFICATION DIALOG

The appearance and structure of walls can be customized in the Wall Specification dialog. See Wall Specification 
Dialog on page 395.

The characteristics of the roof directly above a selected wall can also be specified in the Wall Specification dialog. See Roof 
Panel on page 401.

USING THE EDIT TOOLS

A selected wall or walls can be edited in a variety of ways using the buttons on the Edit Toolbar. See The Edit Toolbar on 
page 135.
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When a wall has been customized to meet your needs, you can apply its attributes to other walls using either the Object 
Eyedropper  tool or the Match Properties  edit tool. See Matching Properties on page 286.

REVERSE LAYERS

When walls enclose an area to form a room, the program will orient all exterior walls so that the siding material faces 
outward. When needed, you can click the Reverse Layers edit button to flip the orientation of the interior and 

exterior layers of a selected wall. Its wall type definition is not affected by this change. See Interior and Exterior Surfaces 
on page 390.

When a wall has Lower Wall Type if Split By Butting Roof checked in its specification dialog and its interior wall layers 
are oriented to face adjacent roof planes, a Caution   symbol will display at the problem location in plan view and the 
Reverse Layers   icon will follow your mouse pointer. See Roof Panel on page 401.

Click on the Caution   symbol that displays over the wall to open a contextual menu: 

 l Select Reverse Layers to flip the wall's interior and exterior layers.
 l Select Ignore Reversed Wall to leave the wall unchanged and suppress the Caution symbol.

USING DIMENSIONS

Automatic, manually-drawn, and temporary dimension lines can be used to both resize and move walls with accuracy. 
Select a wall, then click on a dimension line that locates it and type in the value that you need. See Moving Objects 

Using Dimensions on page 491.

When a wall is resized using dimensions, the inline text field used to edit the dimension will have three unique buttons:

 l Horizontal walls have Move Left End , Move Both Ends , and Move Right End . 

 l Vertical walls have Move Top End , Move Both Ends , and Move Bottom End . 

Note: If only one of these buttons is available, the wall end that the 
button references is the only part of the selected wall that the dimension 
line actually locates, and only that end can be moved using the selected 
dimension.

Choose the option that you want to use before pressing the Enter key.

If both ends of the selected wall intersect walls that are not parallel to one another, a fourth option will be available: Move 
Along Rails . When this option is used, the selected wall both resizes and changes position so that it remains connected 

to the other walls when you press the Enter key.

Depending on your Dimension Defaults settings, manual, automatic, and/or temporary dimension lines may locate wall 
surfaces or wall dimension lines. See Locate Manual Panel on page 460.
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Dimensions can be set to locate Wall Steps in elevation views. Steps in foundation walls in plan views can also be located. 
Wall steps cannot be moved using dimensions, however. See Stepped Walls and Footings on page 384.

Dimension lines do not locate foundation wall footings when they are first drawn. Their extension lines can be edited to do 
so, however. See Editing Extension Lines on page 486.          

Unlike other types of walls, the thickness of a Slab Footing  can be resized using dimensions. A new wall type may 

result. See Editing Foundations on page 725.          

Bear in mind that temporary dimensions can be set up to locate different wall layers than automatic and manual dimensions. 
As a result, they may appear to give different measurements between the same walls. See Temporary Dimension Defaults 
Dialog on page 475.          

Only the portions of pony walls that display are located by dimensions. The upper and lower parts of pony walls typically 
have different thicknesses, so which  part you choose to display may affect your plan’s dimensions. See Pony Wall Defaults 
on page 349.         

Dimension Defaults and Temporary Dimension Defaults can 
have a significant effect on wall position. It is recommended that 

you review these settings and make sure that they meet your needs.

WALL THICKNESS

The initial thickness of a wall is determined by its wall type definition. You can change a wall’s thickness by modifying its 
wall type. If you do this, all instances of the wall type used in the plan will be affected - not just an individual object. See 
Wall Type Definitions on page 388. 

You can also specify a selected wall’s thickness in its Wall Specification dialog. See General Panel on page 395. 

If a selected wall’s thickness is changed: 

 l A copy of the wall’s wall type is created with the same name but appended with a number equal to the thickness of the 
Main Layers, and that new type is assigned to the wall. See The Main Layer on page 388.

 l The change in thickness will be applied to new wall type’s innermost Main Layer. 
 l The Main Layer must be at least 1/16” thick, and the wall’s thickness cannot be less than the original wall type’s total 

thickness minus the thickness of its Main Layer.  

If a wall type’s thickness is modified, the wall will resize about the Resize About line specified in the General Wall 
Defaults dialog. In some instances, the wall may appear to move as a result of changes made to the thicknesses of its layers. 
See General Wall Defaults on page 346. 

WALL HEIGHTS

The height of a wall is controlled by the ceiling height of the room(s) it defines. If the ceiling or floor height of a room is 
changed, the height of the walls that define it also change. 

 l The initial ceiling height for all rooms on a floor is set in the Floor Defaults dialog for that floor. See Floor Level 
Defaults on page 419. Whenever possible, it is best to set all ceiling heights using the default.         

 l The ceiling height of a single room can be set in its Room Specification dialog. See General Panel on page 443.
 l The default Floor and Ceiling Heights for a given floor can be adjusted by editing the top and/or bottom edges of the 

Exterior Room in a 3D view. See The Exterior Room on page 424.           
 l The top or bottom edge of any wall can be adjusted independent of floor or ceiling heights using the mouse in Cross 

Section/Elevation and 3D views. Top and bottom edges can also be stepped and raked. See Stepped and Raked Walls 
on page 384.          
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 l The top height of a selected Railing can also be edited in Cross Section/Elevation and 3D views. The bottom height, 
however, cannot. See Railing and Deck Tools on page 352.          

 l The                  edge dividing an upper and lower pony wall can be edited in Cross Section/Elevation and 3D views. In addition, 
its height can be defined in the Wall Specification dialog. See Wall Types Panel on page 407. 

WALL LENGTH

Wall length can be modified in several different ways: 

 l Using dimensions. See Measuring Walls on page 369.
 l In the Wall Specification dialog. See General Panel on page 395.
 l Using the Add Break  edit tool to divide a selected wall into two segments. See Add Break on page 257.

 l By dragging the end edit handles. See Editing Line-Based Objects on page 218 and Editing Arc-Based Objects on 
page 221. 

Bear in mind that if you try to resize a wall by a small amount using one of its edit handles and that wall is connected to 
another wall at that end, its length will not change because its end will snap back to the existing intersection. See 
Connecting Walls on page 364. 

The most accurate way to specify wall length is using dimensions. By default, wall length is measured at the outside edge of 
the Main Layer. You can instead specify that manual, automatic, and/or temporary dimension lines locate surfaces in the 
Dimension Defaults dialogs. See Dimension Preferences and Defaults on page 455.

Be aware that the wall length dimension that displays when a wall is selected as well as the Length specification in the Wall 
Specification dialog do not inherit their settings from the Dimension Defaults. Instead, they follow the Resize About line. 
See Resize About on page 379.           

Note: By default, dimensions and the Resize About line all use the 
exterior edge of the Main Layer. When Resize About is set to use a 
different location, dimension lines may not agree with a wall’s length 
specification. See Measuring Walls on page 369. 

LOCKED VS. UNLOCKED CENTERS

The default for curved walls is an unlocked center because it is easier to draw and edit when the center is unlocked.           

Once walls are in place and curved walls are properly aligned with straight walls, it is a good idea to lock the curved walls’ 
centers.          

To lock the center of a curved wall, select it and click the Lock Center  edit button. See Lock Center on page 225. The 

curved wall remains selected, but its edit handles change.           

The locked status can also be changed in the GENERAL panel of the Wall Specification dialog. See General Panel on page 
395.          

 

Edit Handles for Walls
Walls can be edited extensively using their edit handles. Depending on the type of view, a wall displays a different set of 
edit handles when selected. 

Moving a wall in any view will move any cabinets attached to that wall, as well.    
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IN PLAN VIEW

In plan view, straight and curved walls and their footings can be edited like other line- and arc-based objects. See Editing 
Line-Based Objects on page 218 and Editing Arc-Based Objects on page 221.

In addition:

 l A wall’s edit handles display along its Resize About line. See Resize About on page 379.          
 l A wall can only be moved perpendicular to itself or, in the case of curved walls, perpendicular to its chord using the 

Move edit handle. To move a wall at Allowed Angles, use the Alternate  Edit Behavior. See Alternate on page 

209.          

IN CAMERA VIEWS

The edit handles that are available for a selected wall in a camera view depends whether the wall is selected on its interior 
or exterior surface or on its top or bottom edge.

 l In a cross section/elevation view, the top and bottom edges of straight and curved walls can be edited like closed 
polylines. See Editing Closed Polyline-Based Objects on page 230. Only the top and bottom edges of walls can be 
broken, angled, or curved: the side edges cannot.    

 l In a camera view or overview, click on an interior or exterior surface to display the same edit handles as in an 
elevation view: one at each corner and one on the top and bottom edges.    

 l In a camera view or overview, click on the top surface of a wall to display the same edit handles as in plan view, 
allowing you to rotate, move, and extend or shorten the length of the wall.      

 l The footings of Foundation Walls and Slab Footings can be selected in 3D views and edited using the edit handles. 
See Footing Width and Height on page 727.     

SAME WALL TYPE EDIT HANDLES

The Same Wall Type edit handles allow you to draw a new wall extending out from either end of a selected wall and 
with identical properties as that wall. These edit handles are enabled globally in the Preferences dialog. If you prefer, 

you can disable them globally and enable them only as needed by selecting a wall and clicking the Same Wall Type edit 
button. See Architectural Panel on page 116.         

When the Same Wall Type edit handles are enabled, two edit handles display just beyond a selected wall’s Extend edit 
handles in plan view or when the top edge of the wall is selected in a 3D view.          

Click and drag a Same Wall Type edit handle at any angle to draw a new wall segment of the same type as the selected 
wall.           
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WALL LAYER INTERSECTIONS EDIT HANDLES

The Edit Wall Layer Intersections edit tool lets you control how a wall’s layers build into another intersecting wall. 
When you click this edit button, the selected wall’s standard set of edit handles are replaced by a set of Wall Layer 

Intersection handles which you can use to modify the length of each wall layer. See Connecting Walls on page 364.         

To edit wall layer intersections
 1.  Select a wall and click the Edit Wall Layer Intersections  edit button.          

 l This edit button is not available if the wall is not connected to another wall at either end.          

 2.  Zoom  in on either end of the wall so its edit handles can be clearly seen.          

 l A Wall Layer Intersection edit handle is located at the midpoint of each wall layer.          

 3.  Click and drag a Wall Layer Intersection handle either towards or away from the opposite edge of the intersecting 
wall.          

 l As you drag, the wall layer will snap to the wall layer lines of the intersecting wall.          

 4.  When you are finished, click the Main Edit Mode  edit button or press the Esc key.           

 

Editing Straight/Curved Wall Combinations
If you move a straight wall connected to a curved wall with a locked center and the connection cannot be maintained 
without changing the center of the arc, the walls lose their connection.           

When an Extend edit handle of a curved wall with a locked center is dragged with the Alternate  Edit Behavior active, 

the locked center setting will be overridden. See Defaults, Preferences, and Edit Behaviors on page 208.           

If you move a straight wall connected to a curved wall with a locked center, the curved wall extends along its curve and the 
straight wall will either lengthen or shorten as needed to stay connected to the curved wall. 

If the connection between the straight and curved wall cannot be maintained because of the curved wall’s radius, it will be 
broken.
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MAKE ARC TANGENT

If both ends of a selected curved wall are connected to other walls at angles of 45° or less, the Make Arc Tangent 
edit button is available. Click this button to open the Radius of Tangent Curved Wall dialog.         

 l Specify the Wall Radius, which is measured from the curved wall’s Arc Center to the Measured to location, 
specified below.           

 l Specify where along the curved wall’s thickness the radius should be Measured to. The wall’s radius is usually 
changed by this action and a locked center automatically becomes unlocked. See Wall Type Definitions on page 388.          

When you click OK, the curved wall will adjust its length and position so that its ends become tangent to the walls it is 
attached to.          

 

Aligning Walls
Wall alignment refers to the way wall segments line up with one another, either on the same floor or on the floor above or 
below.  Walls may need to be aligned in a variety of situations.

To make alignment easier when drawing or resizing walls, “sticky” points and extension lines identify points that are either 
collinear or orthogonal to the end points of other walls. See Extension Snaps on page 165. 
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RESIZE ABOUT

The Resize About line specified in the General Wall Defaults dialog controls two important aspects of wall alignment:          

 l What part of a wall retains its position when its wall type or wall type definition is changed. See Wall Type Definitions 
on page 388.          

 l Where walls snap together to form an intersection. See Connecting Walls on page 364.          

See General Wall Defaults on page 346.          

The Resize About line is the line along which a selected wall’s length is measured in the Wall Specification dialog. See 
Wall Length on page 375.           

The Resize About line is also the line along which a selected wall’s edit handles display, and is the line along which any 
snap points will be located. See Editing Walls on page 372.           

ALIGNING COLLINEAR WALLS

Collinear walls are parallel walls connected end to end and drawn on the same floor. When collinear walls join end-to-end, 
the walls snap together. If these walls have the same wall type and identical specifications, and if Object Snaps  are 

enabled, they will merge to become a single wall segment.

CREATING A NOOK

Walls can be aligned across an opening such as a nook, so that they are collinear, using the Add Break  edit tool.          

To align walls across a gap
 1.  Select a wall to build a nook into and click the Add Break  edit button.          

 2.  Click at a point on the wall close to one side of the nook area. Do not worry about exact placement right now.          

 3.  Click again near the other side of the nook. Two short lines at each location where you clicked indicate Breaks in the 
walls.          

 4.  Right-click the middle section of the wall to select the wall section.          

 5.  Click the middle Move handle and drag the wall outward.          

 6.  Draw side walls to connect the wall back to the rest of the house.          

 7.  Move these short walls using dimensions to accurately size the nook.          
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ALIGNING WALLS BETWEEN FLOORS

Walls can be aligned between floors by clicking the Align With Wall Above and Align With Wall Below edit 
buttons.

By default, walls on different floors are aligned by the outer edges of their Main Layers. See The Main Layer on page 388.         

In order for these edit tools to be available, the areas of the walls 
in question must be partially aligned, or overlapping.

To align walls between floors
 1.  Select a wall that you want to align with another wall either above or below it.

 2.  If the wall is above or below the other wall along only part of its length, you must click on it along that part. Select 
Tools> Floor/Reference Display> Reference Display On  to help make sure you click on the correct part of the 

wall.

 3.  When you have selected the wall at the desired location, click either the Align With Wall Above  or Align With 

Wall Below  edit button.

ALIGNING CURVED WALLS BETWEEN FLOORS

Curved walls are aligned between floors using the same technique to align straight walls. If the centers and radii of the walls 
are within a few inches of each other, the Align With Wall Above  and Align With Wall Below  edit buttons are 

enabled for the selected wall. The selected curved wall will take on the radius and center of the referenced wall when the 
walls are aligned.

ALIGNING PONY WALLS BETWEEN FLOORS

When aligning a pony wall with either the wall above or below:         

  Align With Wall Below will always align the lower pony wall with the wall below, as specified in the lower 
pony wall’s Wall Type Definition. See Wall Type Definitions on page 388.

  Align With Wall Above will always align the upper pony wall with the wall above, as specified in the upper 
pony wall’s Wall Type Definition.              

ALIGNING FOUNDATION WALLS

By default, foundation walls and slab footings will align with walls on the floor above along the outside surface of the Main 
Layer of both wall types. If you prefer, you can specify that foundation walls align to a different part of the walls above. 
The Foundation To This Line setting in the Wall Type Definitions dialog controls how a wall of a given type aligns with 
foundation walls directly below on Floor 0. See Wall Type Definitions on page 388.   

By default, Foundation To This Line is specified for the Main Layer of most wall types. An exception to this are brick 
wall types, which have Foundation To This Line specified for the exterior siding layer. See Brick Ledges on page 356.          

If there is only one layer for both the stem wall and the first floor wall above it, the exterior surfaces of the walls align. The 
footing is centered on the stem wall unless this option is unchecked in the Wall Specification dialog. See Foundation Panel 
on page 405.   
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ALIGNING CURVED WALLS WITH STRAIGHT WALLS

  Curved walls can be drawn tangent to an existing straight wall using the Start/Tangent/End Arc Mode. See 
Drawing Arcs - Arc Creation Modes on page 313.         

  If both ends of a selected curved wall are connected to other walls, the Make Arc Tangent edit button is 
available. Click this button to move and resize the wall so that both ends are tangent to the connected walls. See 

Make Arc Tangent on page 378.         

ALIGNING RAILINGS ON DIFFERENT PLATFORMS

Two collinear Railings or Deck Railings on the same floor can be aligned one above the other when they define rooms with 
different floor heights.          

To align railing on different platforms
 1.  Click and drag to draw a Railing or Deck Railing that divides a room such as a deck in two.          

 2.  Click the Select Objects  button, then click in one of the room areas.          

 3.  Click the Open Object  edit button, and on the GENERAL panel of the Room Specification dialog:          

 l Specify a Floor Height that differs from that of the other by at least the height of the railing, then click OK.          

 l The default railing height is 36”, so for best results the Floor Height should be changed by at least this amount.          

 4.  Click on the railing drawn in step 1, then click the Open Object  edit button. On the RAIL STYLE panel of the 

Railing or Deck Railing Specification dialog, check Generate on Low Platform. See Rail Style Panel on page 412.           

 5.  Click and drag a second railing parallel to the one drawn in step 1.          

 6.  Select this second railing and click the Open Object  edit button. On the GENERAL panel of the Railing or Deck 

Railing Specification dialog, check the box beside No Room Def and click OK.           

 7.  With the railing still selected, Ctrl + drag it into the same position as the first railing. See To move an object freely 
on page 247.          

 

Roof Directives in Walls
To automatically generate a roof plane using values other than the defaults or to not generate a roof plane bearing on a 
particular wall (as for a gable or the sides of a shed roof), you can change the settings in the Wall Specification dialog. See 
Roof Panel on page 401. 

HIP, GABLE, AND SHED ROOFS

By default, the program will produce a roof plane over each exterior wall to create a hip roof. You can specify a different 
condition over a selected wall, however. For example:
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 l Check Full Gable Wall to create a gable with a ridge centered above the selected wall(s).
 l Check High Shed/Gable Wall for the side walls or the wall under the high side of a shed roof. 
 l You can also select a wall and click the Change to Gable Wall(s)  edit button, or change it back by clicking the 

Change to Hip Wall(s)  edit button. 

PITCH

The default pitch for roof planes is set in the Build Roof dialog. However, any exterior wall can define the pitch of the roof 
plane built above it.

You can also specify a second, upper pitch above a given wall. Mansard, gambrel, gull wing and half-hip are examples of 
roof styles that use two pitches. 

OVERHANGS AND ROOF RETURNS

You can specify the overhang of the roof plane to be generated above the selected wall. This setting only takes effect when 
Same Height at Exterior Walls is unchecked in the Build Roof dialog, which is also where the default Overhang value is set.           

Check Auto Roof Return to generate roof returns on the selected wall. In most cases, roof returns only generate on Full 
Gable Walls. See Roof Returns on page 859.         

EXTEND SLOPE DOWNWARD

Check Extend Slope Downward to extend the roof plane downward over a bump-out, instead of creating additional roof 
planes. The two connecting walls that create the bump-out must be Full Gable walls.

In the following image, the bearing wall of the bump-out has Extend Slope Downward checked. The two short side walls 
are Full Gable Walls. 

CLERESTORY AND DORMER WALLS

Occasionally, walls are built between two roof planes rather than between a roof plane and a floor platform. Common 
examples include clerestory walls and the side, or the cheek, walls of floating dormers.          
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Check Roof Cuts Wall at Bottom to have the bottom of the selected wall clipped by the roof plane below, as where a 
floating dormer wall meets the main roof plane.          

EXTERIOR/INTERIOR PONY WALLS

It’s not uncommon for an individual wall to be an exterior wall near its top, and an interior wall near its bottom.           

Check Lower Wall Type If Split By Butting Roof to achieve this. When this option is checked, the selected wall is 
specified as a pony wall and a second, lower wall type can be specified. Unlike with other pony walls, the change in wall 
type occurs wherever a roof plane builds to the exterior of the wall. See Pony Walls on page 357.           

 

Attic Walls
In Chief Architect, walls are built between the floor and ceiling platforms of the current floor.  See Floor and Ceiling 
Heights on page 431. When the program detects an open space between a wall and the roof plane above it, it automatically 
creates an Attic Wall on the floor above that wall to fill in the gap. 

Attic Walls are typically found above Full Gable Walls, forming a gable or closing the top portion of a side wall of a shed 
roof. They are also generated above all exterior walls when the Raise Off Plate value in the Build Roof dialog is 3” (175 
mm) or greater. See Build Roof Dialog on page 809. 

Attic Walls are often found on the Attic floor, but can be generated on other floors, as well. See The Attic Floor on page 
751.

Attic Walls are specified as such in the Wall Specification dialog; if automatically generated, that will be noted as well. If 
needed, you can specify a regular wall as an Attic Wall. If you specify a wall as an Attic Wall and it is currently on its 
default layer, it will be moved to the “Walls, Attic” layer, See General Panel on page 395.

When you Rebuild Walls/Floors/Ceilings , all automatically generated Attic Walls in the plan are deleted and rebuilt 

unless Auto Rebuild Attic Walls is also checked in the General Wall Defaults dialog. See General Wall Defaults on page 
346.

REMOVING ATTIC WALLS

Occasionally, the program will generate an Attic Wall where one is not wanted. There are several ways to address this:

 l Turn off the display of the  layer that the Attic Wall is on.
 l Specify the Attic Wall as Invisible. See Room Dividers and Invisible Walls on page 358.
 l Some interior Attic Walls can be suppressed by specifying space they enclose as a Shelf Ceiling. See Shelf Ceilings on 

page 433.
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 l Select the Attic Wall and Delete  it. When Auto Rebuild Attic Walls is on, the program will specify the wall as 

Invisible automatically. If you delete this Invisible wall, a new Attic Wall will be created.
 l Turn off Auto Rebuild Attic Walls in the General Wall Defaults dialog and then Delete  the wall.          

 l Combine the Attic Wall with the wall below. To do this, select Combine with Above Wall in the Wall Specification 
dialog for the wall below. See Roof Panel on page 401.          

KNEE WALLS

Knee Walls are a bit like Attic Walls in that they are not meant to generate to full ceiling height. Instead, they build upward 
until they encounter a roof plane. Unlike Attic Walls, however, Knee Walls are used in the interior of a structure, typically 
to separate unused areas from rooms on the upper floor of a story-and-a-half structure. See Room Types and Functions on 
page 420.

Chief Architect does not specify walls as Knee Walls automatically. If an interior wall is drawn in a location where the roof 
is lower than the ceiling height, you should specify it as a Knee Wall in the Wall Specification dialog. See Roof Panel on 
page 401.

For best results, Knee Walls should be drawn perpendicular to the pitch of the roof and should intersect with Full Gable 
Walls on each end. 

 

Stepped and Raked Walls
Stepped and raked walls can be created using the Add Break  edit tool and the wall’s edit handles in any 3D or cross 

section/elevation view. In many cases, working in a Back Clipped Cross Section  is easiest and allows the greatest 

accuracy.          

When you try to select a wall in a 3D view, the interior or 
exterior room that it defines may be selected first. Click the 

Select Next Object edit button to select the wall itself. See Selecting 
Walls on page 372. 

STEPPED WALLS AND FOOTINGS

A typical example of stepped walls is a stepped foundation with pony walls. In the illustration below, the lower part of the 
pony wall is the concrete wall with footing, and the upper part of the pony wall is a framed wall with brick siding built to 
the first floor platform. See Pony Walls on page 357.           
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To add a step to a wall
 1.  Select the wall in a Back Clipped Cross Section  view.           

 2.  Click the Add Break  tool, then click the top or bottom edge of the wall to place the break.           

 3.  In addition to the corner handles, two handles display along the broken edge.           

 4.  Select one of these two handles, and drag up or down.          

 5.  A square step is created.          

The vertical edges of a wall cannot be broken, although they can be raked as well as moved side to side.          

By default, a stepped foundation wall  displays an “S” symbol at the location of each step in plan view. The display of this 
“S” is controlled in the Foundation Defaults dialog. See Foundation Defaults on page 718. 

Steps in walls can be located by dimensions in elevation views when Wall Steps is checked in the Dimension Defaults 
dialog. In addition, steps in foundation walls can be located in plan view. Wall steps cannot be moved using dimensions, 
however. See Locate Manual Panel on page 460.

RAKED WALLS

A raked wall has an angled top or bottom edge.           

To create a simple raked wall
 1.  Select the wall in Cross Section/Elevation or 3D view.           

 2.  Click one of the corner edit handles and drag that handle either up or down.           

 3.  To rake a wall at a specific angle, you can:           

 l Use Angle Snaps  and Allowed Angles. See Angle Snaps on page 166.          

 l Draw a CAD Line  at the desired angle and use the Make Parallel/Perpendicular  edit tool. See Make 

Parallel/Perpendicular on page 252.           

COMPOUND RAKED WALLS

A compound raked wall is a wall that has a top or bottom edge with multiple angles.           
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To create a compound raked wall
 1.  Select the wall in Cross Section/Elevation or 3D view.           

 2.  Use the Add Break  tool to add breaks to the wall edge, as for a stepped wall.           

 3.  Select a segment of the edge and adjust its angle, as for a raked wall.           

 

Double Walls
Most wall assemblies can be modeled using a single wall type. In some situations, such as where the walls of two modular 
home units meet, two walls are drawn side-by-side. When two walls are both parallel and touching, they are referred to as 
Double Walls.           

There are three types of Double Walls in Chief Architect Premier: Frame Through, Split Framing and Furred Wall.           

Note: The Double Wall options are not enabled for curved walls.

FRAME THROUGH

Frame Through walls can be considered the basic Double Wall type. A Frame Through wall could be used as a double 
wall between hotel rooms for sound insulation.           

By default, all walls are specified as Frame Through in the Wall Specification dialog. See Structure Panel on page 398.          

SPLIT FRAMING

Split Framing walls divide floor and ceiling platforms, as well as any walls they intersect. The split occurs at the boundary 
where the two double walls touch and is useful for separating modular home units.          

Chief Architect Premier frames walls and platforms separately on either side of the Split Framing wall boundary, with no 
framing members crossing it.           

You can make floor platform rim joists touch each other at the boundary between Split Framing walls or provide spacing to 
carry sheathing over them using the Build Platform to Exterior of Layer setting in the Wall Type Definitions dialog. See 
Wall Type Definitions Dialog on page 390.           

To create a pair of Split Framing walls, specify both walls as such on the STRUCTURE panel of the Wall Specification dialog.           

FURRED WALLS

The recommended method for creating furring is to simply add the required air gap, framing, and finish layers to the wall 
type of your choice. Alternatively, though, Double Walls can be used, with the inner wall being specified as a Furred Wall.          

Furred Walls are placed against the inside of a primary wall, typically an exterior wall. An example is a concrete wall 
furred out by a framed wall with an air gap or insulation between them.           

Rooms are defined in the normal manner by the primary wall, but the layers of the Furred Wall are treated by the program 
as though they were added to the primary. An air gap between the primary and furred walls should be defined as a layer of 
one of the walls, usually the furred wall.           

As with Frame Through walls, Furred Walls do not split platforms or connected walls.  Unlike Frame Through walls, they do 
not connect or frame to non-parallel walls like normal walls. Instead, they will connect to other Furred Walls.           

To create a Furred Wall, specify the primary wall as a Frame Through wall and the furred wall as a Furred Wall on the 
STRUCTURE panel of the Wall Specification dialog.          
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OPENINGS IN DOUBLE WALLS

Doors and windows placed in one Double Wall extend through both walls. You can specify how an opening builds through 
the Double Walls on the CASING panel of either the Door or Window Specification dialog. See Door Specification Dialog 
on page 566 or Window Specification Dialog on page 599.           

 

CAD to Walls
The CAD to Walls tool can be used to convert CAD lines in plan view into architectural objects. Two or more 
parallel CAD lines can be converted to both straight or curved walls or rails. CAD lines representing windows and 

doors can also be converted. 

All lines that you want to convert to walls must be located on one layer. The same is true for windows, doors, and rails. It 
may be helpful to place like items on a single layer with unique layer attributes. See Layer Display Options Dialog on page 
183. 

To convert the lines of an imported drawing using CAD to Walls , map its layers in the Import Drawing Assistant. Do 

not convert lines with shared endpoints to either Boxes or Polylines. See Select File on page 1228. 

To convert to a specific wall type, the lines representing the wall’s surfaces must be within one inch or 25mm of that wall 
type’s width. If two wall types are specified, new walls are assigned the type having the closest width. 

For best results, delete any wall lines or polylines located 
between interior and exterior wall surface lines before using 

Convert CAD to Walls. 

When CAD objects are located properly, select CAD> CAD to Walls  to open the Convert CAD to Walls dialog.

CONVERT CAD TO WALLS DIALOG
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  Set Layers

 l From the drop-down lists, select the source layers of lines to be converted to walls, windows, doors, and rails.

 l Click Define to open the Layer Display Options dialog.

Note: If the same layer is specified as the Wall Layer and Rail Layer, 
all eligible walls will be converted into railings. 

 
Set Wall Types

Specify the wall types for the new walls. 

If the distance between the surface lines is less than the total width of the specified wall type, a copy of that wall type will 
be created. The width of its Main Layer will adjust so that the overall width is equal to the specified wall’s Main Layer.

Click OK to complete the conversion. 

 

Wall Type Definitions
Every wall drawn in a plan is assigned a wall type, and its Wall Type Definition determines its structure, its appearance in 
plan view, and its default materials. Wall types can be viewed, edited, and created in the Wall Type Definitions dialog. See 
Wall Type Definitions Dialog on page 390.

Wall types typically have multiple layers, each representing a different material. All of these layers can be calculated in the 
Materials List. The materials assigned to the surface layers of the wall type definition also determine the wall’s appearance 
in 3D views. See Materials Lists on page 1309.         

You can specify the default wall type that is drawn by each Wall Tool and can specify the wall type of any wall after it is 
drawn in the Wall Specification dialog. See Wall, Railing, and Fencing Defaults on page 346 and Wall Types Panel on page 
407.   

Wall types are plan specific, which means that wall types available in one plan file may not be available in other plans. You 
can, however:          

 l Export and import wall types. See Exporting and Importing Wall Types on page 395.             
 l Add a wall to the library for use in other plans. See Add to Library on page 973.             

THE MAIN LAYER

In most circumstances, each wall type’s Main Layer should be specified as the structural layer. A wall type is considered to 
be:

 l “Framed” if it has a Main Layer specified as Framing;             
 l “Concrete” if it has a Main Layer with the “Concrete” Material Structure Type;             
 l “Masonry” if it has a Main Layer with a “Masonry” Material Structure Type.             

See Materials and the Materials List on page 1064.         

 l The Main Layer determines many things in addition, including:             
 l Floor and ceiling platforms and automatically built foundation walls normally build to the outer edge of the Main 

Layer.             
 l The Main Layers of exterior walls build through slab floors while interior wall layers stop at the slab surface.              
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 l At intersections, walls join at the interior surfaces of their Main Layers. See Connecting Walls on page 364. 
 l Windows are placed relative to the outer surface of the outermost Main Layer.
 l Exterior walls on different floors are aligned by the exterior edges of their outermost Main Layer. 
 l Roof baselines are placed at the outer edge of the outermost Main Layer when roofs are automatically generated. See 

The Baseline on page 819.
 l Roof baselines and gable/roof lines that are manually drawn snap to the outermost edge of the Main Layer.              
 l By default, walls resize about the exterior surface of their Main Layers when their thickness, wall type, or Wall Type 

Definition is changed. See Resize About on page 379. 
 l Object Snaps                  locate the interior and exterior edges of a wall’s Main Layers. See Object Snaps on page 164. 

 l The Sheathing Layer that windows and doors may be recessed to is the layer located just outside the outer Main Layer.               

All of this information is reliant on the Main Layer, so creating your wall type definitions accurately beforehand and 
specifying the Main Layer correctly is very important.         

MULTIPLE MAIN LAYERS

In standard light frame construction, walls build to one another’s framing layers, and floor and ceiling platforms are built to 
bear over the wall framing; however, some building techniques configure these components in other ways. You can control 
how walls of a given type are intersected, and also where platforms build to, by specifying multiple Main Layers.         

 l By default, when multiple Main Layers are specified:         
 l Intersecting walls build to the interior surface of the innermost Main Layer.          
 l Floor platforms build to the exterior surface of the outermost Main Layer.         
 l A selected wall’s edit handles display along the exterior of the outermost Main Layer.         
 l The exterior surface of the outermost Main Layer is the Dimension Layer.          

See Wall Type Definitions Dialog on page 390.         

THE DIMENSION LAYER

Dimension Defaults can be set to locate walls at their surfaces or at the exterior line of their Wall Dimension Layer. See 
Locate Manual Panel on page 460.         

For installed wall types, the default Wall Dimension layer is the Main Layer; however, this can be changed in the Wall Type 
Definitions dialog. In addition to the Wall Dimension Layer, dimensions can locate the inside surface of the Main Layer, as 
well.         

Whether Surface or Wall Dimension Layer is selected on the LOCATE OBJECTS panel of the Dimension Defaults dialog 
determines a number of aspects related to how dimensions locate walls:         

 l How Auto Exterior and Manual Dimensions measure the lengths of walls.                 
 l Where both Manual and Automatic Reach are measured from.                 
 l Where Extension line lengths and their Gap From Marked Object are measured from.                 
 l Where First Line Offset for Auto Exterior Dimensions  is measured from.                 

 l How the minimum enclosed area required by Auto Exterior Dimensions  is measured.                 

The settings on the LOCATE OBJECTS panel control how dimensions initially locate walls. Once a dimension line has been 
created, you can move its extension lines or add new extensions to locate other points along a wall’s assembly. See 
Measuring Walls on page 369.             
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INTERIOR AND EXTERIOR SURFACES

Every wall has an interior and exterior surface - including walls in a plan that are recognized by the program as being 
interior walls. See Exterior and Interior Walls on page 355.

Having separate designations for a wall’s two sides serves several purposes:

 l It allows the program to orient each wall’s exterior side toward the outside of a structure. See Creating Walls on page 
361.

 l It allows you to specify different materials for each side’s surface in the Wall Specification dialog. See Materials 
Panel on page 410.

 l It also allows you to specify which direction Wall Detail views face. See In Wall Detail Views on page 896.              

In the Wall Type Definitions dialog, the exterior surface is shown at the top of the Wall Layers table. In plan view, you can 
identify a selected wall’s exterior surface by the location of its edit handles, which display on the exterior of the Main Layer 
by default. See Resize About on page 379.

LEGACY WALL TYPES

In Chief Architect version X2 and prior, generic, single-layer wall types were used as the default for railings, deck railings 
and fencing. In the earliest program versions, they were the defaults for walls, as well.

 l In Chief Architect X1 and prior, there were two such wall types: “Default (wood frame 16” OC)” and “Default 
(concrete)”.             

 l In Chief Architect X2, these two wall types were replaced by one named “Adjustable Thickness Wall”.             

When plans that include either of these wall types - in the drawing itself or set as a default - are opened in Chief Architect 
X14, the legacy wall type is replaced by a new wall type named “Wall-X”, where X is the thickness of the wall’s Main 
Layer, rounded up. There are a few exceptions:

 l If legacy wall types with the same thickness but different materials are found, they use the same naming convention 
appended with an additional _X.          

 l If a wall using a legacy wall type is specified as a Foundation wall, the resulting wall type will be named “Foundation 
Wall-X”.          

 l If a legacy wall type has the same attributes as a wall type installed with Chief Architect X14, such as 8” Concrete 
Stem Wall, it will be replaced by that wall type.          

Unless a wall is specified as a Foundation wall, Deck Railing, or Fencing, it will be treated as a framed wall and its new 
wall type will acquire two additional 1/2” (13 mm) thick wall layers: an interior and an exterior layer. These new layers will 
use the interior and exterior materials of the original wall. The wall’s original layer will maintain its original thickness, 
acquire a framing material, and will become the new wall type’s Main Layer.         

Foundation, Deck Railing, and Fencing wall types converted in this manner will continue to have only one layer.         

 

Wall Type Definitions Dialog
The Wall Type Definitions dialog is used to define new wall types and redefine existing wall types in the current plan 
file. Select Build> Wall> Define Wall Types to open this dialog.          

You can also click the Define button on the WALL TYPES panel of the Wall Specification dialog or in most Wall Defaults 
dialogs. See Wall Types Panel on page 407.          
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Changes made to an existing wall type definition affect all walls in the current plan using that wall type. Walls in other plan 
files are unaffected.         

If changes to a wall type affect its thickness, the position of any walls in the plan using that wall type may be affected. See 
General Wall Defaults on page 346.         

 
Wall Types

Manage the list of wall types available in the current plan. See Wall Type Definitions on page 388.             

 l Click the drop-down list to display all wall types in the current plan. Select a wall type from the list to display its 
definition. You can rename a wall type by typing in a new name. Note that wall type names in a plan must be 
unique.             

 l To create a new wall type, click New to define a new wall type from scratch or click Copy to copy the current wall 
type. A copied wall type can then be renamed and redefined.             

 l Click Rename to rename an existing wall type, or simply click on its name and type a new name.             

 l To remove a wall type from the current plan, select it and click Delete. Wall types that are in use or set as plan 
defaults cannot be deleted.             

 l To remove all wall types that are not in use or set as a default from the current plan, click Delete All Unused.             
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Wall Layers

The selected wall type’s Wall Layers are listed here. Wall layers are listed from exterior at the top to interior at the bottom. 
The last item listed is the interior surface line rather than a true layer.             

 l The list is divided into three sections: Exterior, Main, and Interior Layers. To move a layer from one section to 
another, use the Move Up and Move Down buttons to the right.             

 l A wall type’s thickest structural layer is typically set as the Main Layer; however, multiple Main Layers can be 
specified. See The Main Layer on page 388.             

 l Click in either the Pattern or Texture column to open the Select Material dialog and choose a material for the 
selected wall layer. See Select Material/Library Object Dialog on page 1057.             

 l Click in the Fill column to open the Layer Fill Style dialog and specify a fill style for the selected wall layer. See 
Fill Styles on page 197.              

Wall layer fill styles are overridden if you use the Wall 
Hatching tool on a wall in plan view. See Wall Hatching on 

page 360.      

 l Click in the Thickness column to type the selected layer’s thickness, or depth. Very thin layers can be created, but 
for best results, avoid using a thickness of 0. For very small values, it can be helpful to temporarily change the 
dialog number format: click the Number Style button.

The buttons to the right of the table allow you to reorganize the wall type definition’s layers.         

 l Click the Insert Above button to create a new layer directly above, or outside, the selected layer in the wall type 
definition. The new layer is a copy of the original.              

 l Click the Insert Below button to create a new layer directly below, or inside, the selected layer in the wall type 
definition. The new layer is a copy of the original.             

 l Click the Move Up button to swap the selected layer’s position with that of the layer immediately outside it or to 
move it into the layer section directly outside it. Not available for the outer-most layer or for a single Main Layer.              

 l Click the Move Down button to swap the selected layer’s position with that of the layer immediately inside it or to 
move it into the layer section directly inside it. Not available for the inner-most layer or for a single Main Layer.              

 l Click Delete to remove the selected layer from the wall type definition.              

 l The Total Thickness of the wall assembly displays here. If you change this value, the thickness of the Main Layer 
automatically updates to account for the difference.             
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Material Layer

Specify whether the selected wall layer has special attributes. Defaults for the Spacing, Width, Count, and Length settings 
can be set in the Framing Defaults dialog. See Wall Panel on page 877.    

 l Check Framing to produce framing in the selected layer when wall framing is generated. See Framing Defaults on 
page 865.

 l Check Use Default Framing Material to apply the default framing material set in the Build Framing dialog to the 
selected wall layer. See Materials Panel on page 890.    

 l Select the framing Type from the drop-down list. See Displaying Framing on page 894.    

 l Specify the on-center Stud Spacing of the selected wall layer. The default value is set in the Build Framing dialog. 
See Wall Panel on page 877.

 l Specify the Stud Width of the framing in the selected layer. The default value is set in the Build Framing dialog.    

 l Specify the Top Plate Count, which is the number of plates stacked one above the other on top of the wall studs. 
When multiple plates are specified, their ends are staggered 48" (1200 mm).   

 l Specify the Top Plate Width, which is the vertical thickness of the top plate(s).    

 l Specify the Bottom Plate Count, which is the number of plates stacked under the wall studs.

 l Specify the Bottom Plate Width, which is the vertical thickness of the bottom plate(s).

 l Check Max Plate Length, then specify the maximum allowed length for the boards that make up the top and bottom 
plates. When unchecked, top and bottom plates run the entire length of each wall, regardless of its length. See Export 
to EasyFrame on page 906.    

 l Check Horizontal Framing to produce framing that runs horizontally instead of vertically, sometimes referred to as 
girts.     

 l When Horizontal Framing is checked, specify the Bottom Run Elevation. This value is absolute, measured from the 
center of the lowest horizontal framing member relative to zero, the default top height of the subflooring on Floor 1. 
For horizontal framing on Floor 0, enter the absolute elevation of the bottom run on that floor. See Floor 1 Default 
Height on page 419.    

 l When Horizontal Framing is checked, check Max Girt Length and then specify the maximum allowed length for 
the girt boards. When unchecked, girt boards run the entire length of the wall, regardless of its length.

 l Check Auto Detail as Insulation to generate Insulation boxes in the selected layer when Auto Detail  is used in 

cross section views. See Auto Detail on page 1095.

 l Check Air Gap to prevent the selected layer from displaying in 3D views or being calculated in the Materials List.

 
Selected Wall Layer Line

Specify the attributes of the Selected Wall Layer Line, which is the line defining the selected layer’s exterior.     

 l Define the Color, Style, and Weight for the selected Wall Line.       

 l Check By Layer if you want the line to assume the attributes of the wall’s layer as defined in the Layer Display 
Options dialog. See Layer Attributes on page 181.       

 l Click the Library button to select a Line Style from the Library. See  Line Styles on page 200.        
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Energy Values

Specify the selected wall type’s Energy Values. This information is used when exporting to REScheck. See Export to 
REScheck on page 1247.             

 l Select a Wall Type from the drop-down list. When “Framed” is selected, the on center spacing is derived from the 
material definition of the wall’s framing layer. See Materials and the Materials List on page 1064.    

 l Specify a Cavity R-Value for the selected wall type definition.      

 l Specify a Continuous R-Value for the selected wall type definition.     

  Wall Settings

 l Specify the Brick Ledge Depth, which is the vertical depth of the brick ledge under walls of this type when a Brick 
material Type is specified for the exterior layer and a monolithic slab foundation is built. See Brick Ledges on page 
356. 
By default, the Brick Ledge Depth is equal to the Height value of the Brick material. See Materials and the 
Materials List on page 1064.             

 l Build Platform to Exterior of Layer - Select a wall layer from the drop-down list to build floor and ceiling 
platforms to. By default, the exterior side of the outermost Main Layer is selected.             

Note: If Build Platform to Exterior of Layer is set to the exterior wall 
layer, no siding material will generate to cover the floor platform. 

 l Dimension to Exterior of Layer  - Select the wall type’s Dimension Layer from the drop-down list. By default, the 
outermost Main Layer is selected. This setting does not affect Interior Dimensions. See The Dimension Layer on 
page 389.             

 l Foundation to Exterior of Layer - Select a wall layer from the drop-down list to align the Main Layer of a 
foundation wall or slab footing on the floor below to. By default, the outermost Main Layer is selected. See Aligning 
Foundation Walls on page 380.             

 l Foundation Offset - Specify how far to offset the Main Layer of a foundation wall on the floor below relative to the 
Foundation to Exterior of Layer selected above. A positive value offsets toward the exterior; a negative value offsets 
toward the interior.             

 l Check Partition Wall to prevent walls of this type from cutting through the surface layers of floors, ceilings, and 
other walls. See Partition Walls on page 365.             

 
Preview

             A preview of the selected wall type definition displays here. See Dialog Preview Panes on page 22.         

 l When the selected preview type is a 3D view, a gap is shown between each of the wall layers in the preview. Click 
the Explode Layers  button remove or restore these gaps.             

 l When Plan View is the selected preview type, click the Line Weights  button to toggle the display of the wall 

layer and pattern line weights, or thicknesses. See Line Weights on page 1379.             
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Exporting and Importing Wall Types
Wall type definitions created in one plan can be exported as a .dat file and imported into other plans. This is a 
convenient alternative to re-creating one or more wall type definitions that already exist in another plan.         

The wall type definitions available to export from the current plan are listed in the Wall Type Definitions dialog. See Wall 
Type Definitions Dialog on page 390.          

EXPORTING WALL TYPES

To export wall type definitions from the current plan file, select File> Export> Export Wall Definitions.         

The Export Wall Definitions File dialog is a typical Save File dialog. Exported wall types are saved using the .dat file 
extension. See Exporting Files on page 41.          

IMPORTING WALL TYPES

To import wall type definitions into the current plan or layout, select File> Import> Import Wall Definitions.         

The Import Wall Definitions File dialog is a typical Open File dialog. See Importing Files on page 45.          

When wall type definitions are imported, the names of the wall type definitions in the .dat file are compared with those 
already present in the current plan. If the program finds identical names, it will ask you if you want to replace existing wall 
definitions with the same name. Click Yes to replace existing files in the plan file, or No to keep the definitions already in 
the plan.           

Wall type definitions that you use often should be saved in your 
default template plan. See To create a plan template on page 89.

 

Wall Specification Dialog
To open the Wall Specification dialog, select a wall or group of walls and click the Open Object edit button. 

The panels of the Wall Specification dialog are also found in the Footing, Railing, Deck Railing, and Fencing Specification 
dialogs. See Railing and Fencing Specification Dialogs on page 411.   

The settings in this dialog are also similar to those in the various Wall Defaults dialogs. The settings in these defaults 
dialogs determine the initial characteristics of railings, deck railings, foundation walls and footing walls, and fencing when 
they are first drawn. See Wall, Railing, and Fencing Defaults on page 346.         

The Wall Specification dialog has the following panels:

GENERAL PANEL

The settings on the GENERAL panel determine the basic use of the selected wall, as well as its length, angle, and other 
attributes.         

395



Chief Architect Premier X14 Reference Manual - Wall Specification Dialog

 
General

Specify General properties of the selected wall(s) or railing(s).             

 l Check Foundation Wall to specify the selected wall as a foundation wall. More foundation wall settings are 
available on the FOUNDATION panel. See Foundation Walls on page 355.         

 l Check Railing to specify the selected wall as a railing. More railing settings are found on the RAILING, 
NEWELS/BALUSTERS, and RAILS panels. See Railing and Fencing Specification Dialogs on page 411.   

 l Check Terrain Retaining Wall to treat the selected wall as a terrain retaining wall. See Retaining Walls on page 
1262.         

 l Check Attic Wall to prevent the selected wall from extending through the roof above. See Attic Walls on page 383.          

 l The Thickness of the selected wall displays and can be changed here. If the wall is a Post to Overhead Beam railing, 
this setting can also affect the width of the beam. See Wall Thickness on page 374.   

 l Wall Angle - The current absolute angle of the wall in plan view is shown. If you type in a new angle, the wall 
rotates about its locked point and any walls attached to it will not move. If the selected wall is curved, this value 
describes the angle of the chord and cannot be modified. See 3D Drafting on page 12.   

 l Wall Length - The current length, as measured along the Resize About line, is shown. If you type a new length, the 
wall will extend or contract according to how it is locked. Any walls attached to the selected wall will not move. If 
the selected wall is curved, this value cannot be modified. See Resize About on page 379. 

 l Select a radio button to Lock the selected straight wall at its Start, End or Center. When the Wall Angle or Wall 
Length of the selected wall is changed, this point along the wall does not move. Not available for curved walls.         
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  Options

 l Check Invisible to specify the wall as invisible. Invisible walls can display in plan view but not in 3D views or the 
Materials List. Room Dividers  are invisible by default. See Room Dividers and Invisible Walls on page 358. 

 l Check No Room Definition to display the wall in floor plan and/or 3D views but not create room definition. See 
Room Definition on page 418. 

 l Check No Locate to prevent Auto Exterior Dimensions  from locating the wall in plan view. See No Locate on 

page 371.

 l Check Lock Center to prevent the arc center of a selected curved wall from moving when the wall is edited using its 
edit handles. Not available for straight walls.      

 l Check No Room Moldings Exterior to prevent any room moldings from generating along the Exterior side of the 
selected wall. If a Room Molding Polyline is created, it will also be affected by this setting. See Room Moldings on 
page 441. 

 l Check No Room Moldings Interior to prevent any room moldings from generating along the Interior side of the 
selected wall. If a Room Molding Polyline is created, it will also be affected by this setting. 

 l Automatically Generated Wall displays for reference and is checked whenever the selected wall was generated by 
the program. Typically, automatic walls are also Attic walls.

 l Check Ignored by Hide Exterior Walls to prevent the selected wall from being hidden in 3D views when the Hide 
Camera-Facing Exterior Walls option is in use. See Hide Camera-Facing Exterior Walls on page 1132.

 
Curved Wall

The Curved Wall settings control the definition of a selected curved wall’s radius and are only available when the selected 
wall is curved.             

 l Select Outer Surface to measure the selected wall’s radius from its center point to its outer surface.             

 l Select Main Layer Outside to measure the radius from the wall’s center point to the outside of its Main Layer. See 
The Main Layer on page 388.             

 l Select Main Layer Inside to measure the radius from the wall’s center point to the inside of its Main Layer.             

 l Select Inner Surface to measure the radius from the wall’s center point to its inner surface.             

 l Specify the selected wall’s Radius, as defined by the radio button selected above.         

 l Select Arc Center to move the selected wall’s ends and prevent its center point from moving when its Radius is 
changed.             

 l Select Ends to move the selected wall’s center point and prevent its ends from moving when its Radius is changed.             

 l Uncheck Automatic Facet Angle to specify the Facet Angle, which is the angle at which the surfaces of the curved 
wall are broken in 3D views. The default value is 7.5°; a smaller value produces a smoother curve but may take 
longer to generate in 3D views.             

 
Preview

A preview of the selected wall, including any doors or windows inserted into it, displays on the right. If the selected wall is 
specified as Invisible, its plan view will display here by default. See Dialog Preview Panes on page 22.     
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STRUCTURE PANEL

The settings on the STRUCTURE panel control the height and other structural attributes of the selected wall(s).         

 
Default Wall Heights

The Default Wall Heights settings allow you to reset a wall’s default top and bottom heights if they have been manually 
edited. See Wall Heights on page 374.         

 l Default Wall Top Height and Default Wall Bottom Height are only enabled if the selected wall’s top and/or 
bottom height has been edited. Check these boxes to restore the default heights.         
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Platform Intersections

These settings control the relationship between the selected wall and the Ceiling Platform above and the Floor Platform 
below it. They only take effect when the selected wall is positioned at a platform edge, such as at the exterior of a building 
or Open Below room. See Floor and Ceiling Platforms on page 433.     

 l Check Generate Between Platforms to fill in the gap between floor and/or ceiling platforms when the selected 
railing or invisible wall separates rooms with different floor and/or ceiling heights. When unchecked, this gap is not 
closed. Only available for railings, Invisible railings, and Invisible walls, this setting has no effect when the selected 
wall type has only one layer.      

The Ceiling Platform settings control how the selected wall's top plates are generated.     

 l Select Automatic to set the wall's top plates under the ceiling above if there is a floor/ceiling platform above, or to 
balloon frame the wall if there is not a platform above.     

 l Select Stop at Ceiling Above to have the top of the wall top at the bottom of the ceiling platform above, as is 
typical in light frame construction.     

 l Select Balloon Through Ceiling Above to have the top of the wall go past the ceiling platform. If there is a framed 
wall directly above, the framing will continue upward to that wall's top plate. The two walls remain separate objects 
on different floors, however, unless the wall above is an Attic Wall. This setting does not affect interior walls.             

 l Select Hang Floor Platform Above on Wall to produce a platform that hangs on the inside of the selected wall 
rather than bearing on top of it. When checked, the two options that follow are available.             

 l Select Subflooring to Interior Wall to hang the platform on the inside surface of the wall. When unchecked, the 
platform builds to the inside surface of the wall’s Main Layer. See The Main Layer on page 388.              

 l Select Include Ledger to hang the platform from a ledger board attached to the wall. When unchecked, no ledger is 
created when platform framing is generated. See Floor and Ceiling Framing on page 865.              

The Floor Platform settings control how the selected wall's bottom plate is generated.       

 l Select Automatic to set the wall's bottom plate on top of the floor platform below, or to balloon frame the wall if 
there is not a platform below. If the wall is a Concrete type, the floor platform instead hangs on the inside the 
selected wall. See The Main Layer on page 388.

 l Select Stop at Floor Below to have the bottom of the wall stop at the top surface of the floor platform, as is typical 
in light frame construction.     

 l Select Balloon Through Floor Below to have the bottom of the wall go through the floor platform below. If the 
selected wall is framed and there is a framed wall directly below, the studs of the wall below will extend up produce 
balloon framing. If the wall below is set to Stop at Ceiling Above, the selected wall's bottom plates will rest on that 
wall's top plates. This setting does not affect interior walls.              

Note: Whether a wall is a framed or concrete type is determined by 
the material assigned to its Main Layer. See Wall Type Definitions 
Dialog on page 390.

 
Wall Intersection

The Wall Intersection settings control whether the selected wall builds through wall corners at its Start and End points. 
The display of Start and End Indicators can be turned on or off in the Preferences dialog. See Edit Panel on page 119.
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 l Select Through Wall at Start to build the wall through the wall corner located at its start point.         

 l Select Through Wall at End to build the wall through the wall corner located at its end point.         

 l When neither box is checked, the program will determine whether the wall builds through the corners at each of its 
endpoints.         

 
Rim Joists

Specify the number of Rim Joists for the floor platform below the selected wall(s). See Framing on page 864.         

 l Select Single or Double to generate one or two rim joists, respectively.         

 l Select Automatic to generate two rim joists if there is no wall below the selected wall, and one rim joist when there 
is a wall below. Automatic produces a single rim joist for Deck Railing.              

 
Double Wall

The Double Wall options specify how a selected straight wall frames when it is parallel to and touching a second wall. 
These settings are only available for straight walls. See Double Walls on page 386.         

 l Select Frame Through to create a basic double wall.         

 l Select Split Framing to create a double wall that splits platforms and connecting walls at its boundary.         

 l Select Furred Wall to treat the selected wall as additional layers added to another wall.         

Note: The Double Wall options are not available for curved walls.   

400



Chief Architect Premier X14 Reference Manual - Wall Specification Dialog

  Framing

 l Check Retain Wall Framing to preserve the framing of the selected wall when the wall framing is globally 
rebuilt. See Keeping Framing Current on page 899.    

 l Check Stagger Multiple Framing Layers to produce wall studs that are offset from one another when wall 
framing is created. This setting only has an effect if a wall type with multiple Framing layers is specified. See 
Wall Type Definitions Dialog on page 390.    

 l Check Use Framing Reference to use a Framing Reference Marker as the starting point for the selected wall's 
stud layout. When unchecked, stud rollout begins at the wall's Start. See Framing Reference Markers on page 
890.    

 l Check Reverse Stud Rollout Direction to begin stud rollout at the selected wall's End instead of its Start. Only 
available when Use Framing Reference is unchecked. The display of Start and End Indicators can be turned on 
or off in the Preferences dialog. See Edit Panel on page 119

 l Specify the Stud Rollout Offset, which is the distance from the selected wall's Start or End that you want stud 
rollout to begin. Only available when Use Framing Reference is unchecked.    

 l Check Bearing Wall to specify the selected wall as load-bearing. When checked, automatically generated joists 
run perpendicular to the selected wall and either lap or butt over it, as specified in the Build Framing dialog. See 
Floor and Ceiling Framing on page 865.    

 l Check Create Wall/Footing Below to create a stem wall or slab footing below the selected wall on Floor 1 when 
an automatic foundation is built. Has no effect if the selected wall is on any floor other than Floor 1. See 
Building a Foundation on page 722.

Note: If Create Wall/Footing Below is checked, Foundation 
Wall and Slab Footing will become unchecked on the 
Foundation Panel on page 405.

 
Preview

      A preview of the selected wall, including any doors or windows inserted into it, displays on the right. See Dialog 
Preview Panes on page 22.     

ROOF PANEL

Any automatically generated roof style other than a hip requires roof information to be defined in the exterior walls. On the 
ROOF panel, you can specify how the selected wall interacts with the roof plan, defining the portion of the roof plan that 
bears on it. See Automatic vs. Manual Roofs on page 804.
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Roof Options

Specify the shape of the wall relative to the roof.             

 l Select Hip Roof to create a roof plane that bears on top of the selected wall.

 l Select Full Gable Wall to create a gable end over the selected wall. 

 l Select Dutch Gable Wall to create a small gable part way up a hip roof. Use the Pitch Options below to specify the 
location of the gable.             

 l Select High Shed/Gable Wall to specify the selected wall as the high end of a shed roof.    

 l Select Knee Wall to define the selected interior wall as a knee wall. Only an interior wall can be defined as a knee 
wall. A knee wall’s height is defined by the roof above, not the ceiling height. See Knee Walls on page 384.    

 l Select Extend Slope Downward to continue a roof down over a bump-out in an exterior wall. See Extend Slope 
Downward on page 382.    

 l Check Roof Cuts Wall at Bottom to prevent the portion of a selected wall located below an intersecting roof plane 
from building.    

 l When Include Frieze is checked, the frieze molding specified in the Build Roof dialog is generated along the 
selected wall at the roof line. Uncheck this to prevent the frieze from generating. See Frieze Molding on page 862.    

 l Combine with Above Wall is only available when a selected wall has an Attic wall above it. Check this box to 
balloon frame the two walls when automatic framing is built. The two walls remain separate objects. See Attic Walls 
on page 383.         

 
Pitch Options

Specify the pitch or pitches of the roof plane(s) above the selected wall.             

 l Enter a value to define the Pitch of the roof plane bearing on the selected wall. 

 l Check Upper Pitch to create a roof with two pitches or, if the selected wall is a Full Gable Wall, a half hip 
condition.

 l Enter the Pitch of the second, upper roof.

 l Specify the Height that the Upper Pitch Starts at, or define the distance In from Baseline that the second pitch 
begins. The two values are dynamic. Press the Tab key to update the relative numbers. These settings are also used 
to position a Dutch Gable Wall.

 
Overhang Length

Specify the Overhang Length, which is the horizontal distance from the baseline to the eave. See The Baseline on page 
819.    
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Auto Roof Return

    Check Auto Roof Return to generate roof returns on the selected wall. In most cases, roof returns only work for Full 
Gable Walls. See Roof Returns on page 859.             

 l Specify the horizontal Length of the roof return in inches (mm).             

 l Enter a value in inches (mm) to Extend the roof returns past the overhang.             

 l Specify a Gable, Hip, or Full roof return.             

 l Specify a Sloping or Flat roof return.                 

 l Check the boxes to  Include Shadow Boards, Ridge Caps, Frieze molding, and/or Gutters on the roof returns.             

 
Lower Wall Type if Split by Butting Roof

Check Lower Wall Type if Split by Butting Roof to specify the wall type for any portion of the selected wall located 
beneath an adjacent, abutting roof plane, should one be present. A wall affected by this setting is specified as a Pony Wall 
and the upper wall is defined on the WALL TYPES panel. See Exterior/Interior Pony Walls on page 383.         

 
Treat As Part Of Bay/Bow/Bow Window

These options correspond to the Roof options in the Bay/Bow/Bow Window Specification dialog and should only be used 
by groups of three or more walls that form a bay or bow shaped bump-out. See Bay, Box, Bow Windows and Roofs on page 
620.    

 l Check Treat As Part Of Bay/Box/Bow Window to create a hip roof with California ridge over the bump-out 
formed by the selected walls when the roof is rebuilt.

 l Check Use Existing Roof to ignore the bump-out formed by the selected walls when the roof is rebuilt.     

 l Check Extend Existing Roof Over to extend the eave of the main roof plane to cover the bump-out created by the 
selected walls and follow its footprint.    

 l Check Rectangular Roof Over to create a rectangular hip roof over the bump-out formed by the selected walls 
instead of one that follows its footprint. 

 
Preview

             A preview of the selected wall, including any doors or windows inserted into it, displays on the right. See Dialog Preview 
Panes on page 22.   
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FOUNDATION PANEL

 
Foundation

Specify the Foundation properties of the selected wall(s).         

 l Check Foundation Wall to specify the selected wall as a foundation wall and enable additional settings on this 
panel. This box is checked by default for automatically generated foundation walls as well as walls drawn with the 
Foundation Wall tool  and Slab Footing tools .         

 l Check Slab Footing to specify the selected wall as a slab footing. See Foundation Walls on page 355. When this 
is checked, Foundation Wall will also be checked.         

Note: Rooms defined by walls drawn using the Slab Footing tool 
will have a Ceiling Height of 0 and a Monolithic Slab Foundation. 
Rooms defined by walls that are later specified as Slab Footings 
will not unless the room is on Floor 0 and the plan has a 
Monolithic Slab foundation specified.

 l The Wall Thickness of the selected wall displays and can be changed here.         

 l If Slab Footing is checked, the Curb Width can be specified instead.         
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Footing

Check Footing to assign a concrete footing to the selected wall(s) and enable the settings below. Only available when 
Foundation Wall is checked, above.         

 l Specify the Width and Height of the footing below the selected foundation wall(s). The Height value will be 
unavailable if the bottom height of the footing has been edited. See Stepped Foundations on page 731.         

 l Check Automatic Footing Bottom Height to restore the default height of the selected wall’s footing. Only 
available when the footing bottom height has been edited.         

 l Check Vertical Footing to generate footings that run up and down along any steps in the foundation wall’s bottom 
height.         

 l Specify the Footing Offset, which is the distance between the center of the footing and the center of the wall. A 
value of 0 centers the footing under the wall; a positive value offsets the footing towards the wall’s interior 
surface; and a negative value offsets it towards the wall’s exterior. Not available if either Center Footing on Main 
Layer or Align Footing on Outside are checked, below.     

 l Check Center Footing on Main Layer to center the footing on the wall’s Main Layer. See The Main Layer on 
page 388.           

 l Check Align Footing on Outside to align the footing along the wall’s exterior surface.  See Wall Type Definitions 
on page 388. 

 l Click the Fill Style button to specify a custom fill for the selected wall's footings. A preview of the fill displays in 
the pane above the button. See Fill Styles on page 197.

 l Specify the Layer that the selected wall's footing is drawn on. See Layer Panel on page 191.

 
Monolithic Slab

Specify how Monolithic Slab footings generate. These settings apply only when the selected wall defines the side of a 
Monolithic Slab. See Foundations on page 717.             

 l Specify the Chamfer Width and Height, which define the angled corners where the footing meets the underside of 
the slab.         

 l Specify the Pour Number of the selected Slab Footing. Pour Numbers are listed separately in the Materials List. See 
In the Materials List on page 725.         

 
Sill Plate

Check Sill Plate to reserve space for one or more sill plates, or mud sills between the selected foundation stem wall or grade 
beam and the floor platform or framed wall that bears on it. Sill plates are generated when the floor framing is generated. 
See Sill Plates on page 866.             

 l Specify the Width and Height of the treated sill plates. If the Height is set to zero, no sill plates are produced. Not 
available if Monolithic Slab is the selected Foundation Type.    

 l Specify the Max Length, then specify the maximum allowable length for sill plate boards generated over the 
selected wall. When unchecked, sill plates run the full length of the wall, regardless of length.    

 l Specify the Count, which is the number of sill plates stacked vertically on each stem wall or grade beam.             
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Preview

     A preview of the selected wall, including any doors or windows                           inserted into it, displays on the right. See Dialog Preview 
Panes on page 22.         

WALL TYPES PANEL

 
Wall Type

Choose the selected wall’s Wall Type from the drop-down list of all currently available types. A preview of the selected 
wall type displays below the drop-down list.             

 l Click the Define button to open the Wall Type Definitions dialog to create or modify existing wall types. See Wall 
Type Definitions Dialog on page 390.         
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Pony Wall

Check Pony Wall to specify the selected wall as a pony wall having different wall types on its upper and lower portions. 
See Pony Walls on page 357. 

If the selected wall is a Foundation Wall, its initial wall type will become the Lower Wall Type. For all other walls, the 
initial wall type will be the upper Wall Type.

 l Select the Lower Wall Type, the wall type of the lower portion of the pony wall, from the drop-down list. A 
preview of the selected wall type displays directly below.         

 l Click the Define button to open the Wall Type Definitions dialog.         

Specify the height of the division between the upper and lower walls. These two settings are dynamic: if one is changed, the 
other will update accordingly.         

 l Specify the Elevation of Lower Wall Top, which is the division between the upper and lower walls.              If the top of 
the lower pony wall is stepped or raked, this value will be “No Change”. This is an absolute value: regardless of the 
wall’s location, it is always measured from 0” (mm) - the default floor height for Floor 1. See Floor Defaults Dialog 
on page 744.         

 l Specify the Height Off Floor of the division between the upper and lower walls. This value is measured from the 
floor height of the room(s) defined by the selected wall. If the wall defines rooms with different floor heights, “No 
change” will display.         

Align Pony Walls - Specify how the layers of the selected wall’s Upper and Lower portions align.         

 l Select Outer Surface to align wall types at their outer surfaces.         

 l Select Main Layer Outside to align wall types at the exterior edge of their main layers.         

 l Select Wall Center to align the centers of the main layers of both wall types.         

 l Select Main Layer Inside to align the wall types at the interior side of their main layers.         

 l Select Inner Surface to align wall types at their interior surfaces.         

 l No Change is used by default when multiple pony walls with different alignment settings are selected. Choose this 
to leave the alignment as it was when the dialog was opened.         

Specify which part of the pony wall you would like to Display in Plan View. See Displaying Pony Walls on page 358.         

 l Select Default to display the portion of the pony wall specified in the Pony Wall Defaults dialog. The default portion 
is stated in parentheses.

 l Select Upper Wall to display the upper portion of this pony wall in plan view regardless of the default setting.         

 l Select Lower Wall to display the lower portion of this pony wall in plan view regardless of the default setting.         

 l When walls are group-selected, choose No Change to allow each wall in the selection set to maintain its own 
setting.         

In the Pony Wall Defaults dialog only, specify the Display of Openings in Non-Displayed Parts of Walls. This controls 
how doors and windows display in plan view when they are located entirely in the part of a pony wall that is not visible.         

 l Select Outline to display the lines associated with openings but draw the wall layers’ lines and fill through them.         

 l Select Always to display doors and windows the same regardless of where they are located: drawing their outlines 
and preventing wall layers from drawing through them.         

 l Select Hide to not draw door and window outlines at all, so they cannot be seen.         
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Note: The Display of Openings in Non-Displayed Parts of Walls as well 
as the default Display in Plan View settings can be set differently in each 
Saved Plan View. See Plan Views on page 150.

 
Preview

A preview of the selected wall, including any doors or windows              inserted into it, displays on the right. See Dialog Preview 
Panes on page 22. 

WALL CAP PANEL

The settings on the WALL CAP panel allow you to apply a cap to the top of a wall or, if the wall is a Pony Wall, over the top 
of the lower Pony Wall. See Lower Pony Wall Caps on page 358.          

The settings on this panel are like those on the MOLDINGS panel found in a variety of dialogs in the program. See Moldings / 
Profiles Panels on page 943.         

WALL COVERING PANEL

The WALL COVERING panel is also available in the Room Specification dialog. See Room Specification Dialog on page 442.
         

 
Materials

All wall covering materials applied to the selected wall are listed here. Select one from the drop-down list to edit its position 
or remove it from the wall.         

 l Click Add New to apply a new wall covering to the selected wall. See Select Library Object Dialog on page 982.         

 l Click Replace to replace the current wall covering with a new one from the library.         

 l Click Delete to remove the current wall covering from the selected wall.         
Preview panes showing the current wall covering display the row of buttons.         
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Position

Specify the Position of the selected wall covering.         

 l Enter the heights of the current wall covering’s Top To Ceiling and Floor To Bottom. The wall covering’s 
Height from its top edge to its bottom edge can also be specified.         

 l Check Interior and/or Exterior to apply the wall covering to the inside and/or outside of the selected wall. Interior 
is checked by default. Not available for rooms. See Wall Type Definitions on page 388.         

 
Options

Check No Room Wall Coverings to prevent any wall coverings assigned to rooms from generating on the selected wall.         

 
Preview

Most wall coverings are best previewed  using the Standard Rendering Technique. See Dialog Preview Panes on page 22.          

RAIL STYLE PANEL

The settings on the RAIL STYLE panel are  only available for Railings, Half Walls, Deck Railings, and Fencing. See Rail 
Style Panel on page 412.   

NEWELS/BALUSTERS PANEL

The settings on the NEWELS/BALUSTERS panel are only available for Railings, Half Walls, Deck Railings, and Fencing. See 
Newels/Balusters Panel on page 414.

RAILS PANEL

The settings on the RAILS panel are used to specify the style and size of the horizontal components of a selected Railing, 
Deck Railing, or Fence. See Railing and Deck Tools on page 352.

A similar panel is also found in the Staircase and Ramp Specification dialogs and has additional settings for handrails at 
walls. See Rails Panel on page 796.

The settings on this panel are like those on the MOLDINGS panel found in a variety of dialogs in the program. See Moldings / 
Profiles Panels on page 943. 

LAYER PANEL

For information about the settings on this panel, see Layer Panel on page 191.          

MATERIALS PANEL

All walls - including interior walls, railings and fencing - have an “Exterior Wall Surface” and an “Interior Wall Surface”. 
See Interior and Exterior Surfaces on page 390. 

The materials specified on the MATERIALS panel affect the appearance of walls and Solid Railings in 3D views but are not 
calculated in the Materials List. See Materials Lists on page 1309. 

For most railing types, the “Exterior Wall Surface” component only affects the appearance of the floor platform under the 
railing and the “Interior Wall Surface” component is not used. For fencing, neither material component is used. 
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LABEL PANEL

Wall labels display in plan view              and cross section/elevation views when the “Walls, Labels” layer is turned on and use the 
Text Style assigned to that layer. See Wall Labels on page 368.

For information about the settings on this panel, see              Label Panel on page 712.

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 1335.         

OBJECT INFORMATION PANEL

The information entered on the OBJECT INFORMATION panel can be used in schedules and the materials list. For more 
information, see Object Information Panel on page 1336.   

SCHEDULE PANEL

The settings on the SCHEDULE panel determine which schedule categories the selected wall is included in. See Schedule 
Panel on page 716.          

 

Railing and Fencing Specification Dialogs
To open the Railing or Fencing Specification dialog, select a railing or fencing, or a group of railings or fencing, and 
click the Open Object edit button. 

The Railing and Fencing Specification dialogs are the same as the Wall Specification dialog, but have three panels that 
apply only to Railings, Half Walls, Deck Railings, and Fencing. See Wall Specification Dialog on page 395. 

The RAILS panel is similar to the HANDRAIL panel found in the Staircase and Ramp Specification dialogs. See Stairs, 
Ramps, and Landings on page 752.          
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RAIL STYLE PANEL

 
Specify Railing

Check Specify Railing to specify the selected wall as a railing and enable the other options on this panel. Railings drawn 
using the Railing  or Deck Railing  tools have this checked by default.     

Select the radio button for the desired Railing Type:

 l Select Balusters to create regularly spaced balusters between larger newel posts. 

 l Select Solid to create a solid railing or Half Wall. Not available if the selected railing is also a Pony Wall. See 
Pony Walls on page 357. 

 l Select Open to create a railing with only newel posts and top and bottom rails.

 l Select Open with Middle Rail to create a railing with newel posts and top, bottom, and middle rails.

 l Select Panels to create a railing composed of panels, then click the Library button to select a panel style from the 
Library Browser. See Select Library Object Dialog on page 982. You can specify the panel style on the 
NEWELS/BALUSTERS panel. See Newels/Balusters Panel on page 414.

 
Newels/Posts

Check Newels/Posts to assign these to the selected railing, then specify their properties. 

 l Select Post to Rail to create newel posts from the floor to the top rail. This option is selected by default.

 l Select Post to Beam to create newel posts from floor to a beam placed just under the ceiling height. The beam’s 
width is based on the Thickness of the selected railing wall.

 l Select Post to Ceiling to extend the newel posts to the ceiling.
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 l Select Rail to Post to produce newel posts of the Height specified on the NEWELS/BALUSTERS panel, with rails 
that build to the sides of the newels. 

 
Start/End Posts

If either the Start or End of the selected railing is connected to another railing, the settings associated with that end will not 
be available. These options are not available at all when Newels/Posts is unchecked above.           

 l Select the Type of post at the railing’s Start and End points: “Full Post”, “Half Post”, or “None.” The “Auto Post” 
options place either a Half post or None if the railing intersects a wall and a Full post otherwise: the currently 
applicable Type is indicated in parentheses. A Full Post is always placed where railings meet at a corner.              

 l Specify the Start and End Wall Offsets, which are the distances between the railing’s half posts and the intersecting 
wall.             

 l Check Uniform Offsets to apply the same offset to both ends of the railing.             

 l Check Square Half Post to use a square half post where the railing intersects a wall instead of the post Type 
specified on the NEWELS/BALUSTERS panel. This only applies when a railing end is set to have a Half Post.             

 
Top/Bottom Rail

These options control the placement of the top and bottom rail, or shoe. 

 l Uncheck Include Top Rail to eliminate the top rail.

 l Uncheck Include Bottom Rail to eliminate the bottom rail and extend the balusters to the floor. Not available for 
Solid railings.

 l Check Raise Bottom, then specify the Floor to Bottom distance, measured up from the floor platform to the 
bottom rail or panel.

 
Build From

Specify where the selected railing or fencing should Build From. With the exception of Follow Stairs, these settings are not 
available for Solid railings.             

 l Check Step Terrain to have the railing or fencing follow the terrain in horizontal steps between each newel post. 
Not available if the selected railing is a Pony Wall.          

 l Check Follow Terrain to have the railing or fencing follow the terrain smoothly. Not available if the selected railing 
is a Solid or a Pony Wall.          

 l Check Generate on Low Platform to build the selected railing on the lower floor platform when the railing defines 
two room areas with different floor heights. See Aligning Railings on Different Platforms on page 381.          

 l Check Follow Stairs to have the railing or fencing follow the rise of stairs drawn in the same location. See Inset or 
Middle Railing on page 778 for more information.         

 
Preview

A preview of the selected railing or fence, including any doorways or gates inserted into it, displays on the right. See Dialog 
Preview Panes on page 22. 
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NEWELS/BALUSTERS PANEL

 
Railing

Specify the height of the railing, as well as its appearance in plan view.              

 l For interior railings, the Railing Height is measured from the height of the floor finish.              See Floor and Ceiling 
Platform Definitions on page 434. 

 
Newels/Posts

Specify the characteristics of the selected railing’s newel posts.    

 l Specify the Width of each newel at its widest point.           

 l Check Use Wall Width to assign the width of the wall type assigned to the selected railing to its newels.          

 l Specify the Height, which is the height from the floor or ground to the top of the newel. Not available if Post to 
Rail, Post to Overhead Beam or Post to Ceiling is selected on the RAIL STYLE panel. See Rail Style Panel on page 
412.    

 l Specify the Offset, which is the amount each newel is offset from the center of the railing. Use this to create a fence 
with the newels on one side of the fence boards.          

 l Specify the on-center Spacing of the newel posts.          

 l Type - Select Square, Round, or Library newels.         

Note: Selecting Library from the drop-down list is the same as clicking 
the Library button to the immediate right and allows you to select a 
symbol from the library. See Select Library Object Dialog on page 
982.
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Balusters

These settings are only available when the railing type is “Balusters” on the RAIL STYLE panel.         

 l Specify the Width or diameter of each baluster at its widest point.          

 l Specify the on-center Spacing of the balusters.         

 l Type - Select Square, Round, or Library balusters.          

 
Panels

These settings are only available when the railing type is specified as Panels on the RAIL STYLE panel. 

 l Specify the panel’s Thickness.         

 l Select “Solid” or “Library” from the Panel Type drop-down list.          

You can also apply newels, balusters, and panels onto a railing 
directly from the Library Browser. See Inserted Objects on 

page 981. 

 
Plan Display

These settings control how newels, balusters, and rails display in plan view. See In Plan View on page 366.          

 l Uncheck Use Defaults to enable the settings that follow. When this is checked, the settings in the Defaults dialog for 
the tool used to draw the selected railing are used. This check box is also found in the Defaults dialogs for all wall 
tools except Railing: when checked, the defaults set in the Railing Defaults are used.             

 l Check Draw Newels to display newel posts in plan view.             

 l Check Draw Balusters to display balusters in plan view.             

 l Check Draw Rails to display the rails in plan view.             

 l Click the Fill Style button to open the Fill Style dialog and specify the fill style for newels, balusters, and/or rails, 
when set to display.             

 
Preview

 A preview of the selected railing or fence, including any doorways or gates inserted into it, displays on the right. See 
Dialog Preview Panes on page 22.          

RAILS PANEL

The settings on the RAILS panel are used to specify the style and size of the horizontal components of a selected Railing, 
Deck Railing, or Fence. See Railing and Deck Tools on page 352.         

A similar panel is also found in the Staircase and Ramp Specification dialogs and has additional settings for handrails at 
walls. See Rails Panel on page 796.         

The settings on this panel are like those on the MOLDINGS panel found in a variety of dialogs in the program. See Moldings / 
Profiles Panels on page 943.         
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Wall Hatching Specification Dialog
To open the Wall Hatching Specification dialog, select a Wall Hatching and click the Open Object edit button. The 
settings in this dialog are also found in the Wall Hatching Defaults dialog. See Wall Hatching on page 360.

LAYER PANEL

Specify the layer that the selected Wall Hatching is placed on. See Layer Panel on page 191.         

FILL STYLE PANEL

The FILL STYLE panel is found in the specification dialogs for many different objects. See Fill Styles on page 197.   

LABEL PANEL

Wall Hatching labels display in plan view when the "Walls, Labels" layer is turned on and use the Text Style assigned to 
that layer. The Automatic Label for wall hatching is blank, but you can specify a custom label. For information about the 
settings on this panel, see Label Panel on page 712.   

 

Wall Schedules
The Wall Schedule tool allows you to produce customizable wall schedules or legends with information about wall 
types, wall assembly layers, length, and more. See The Schedule Tools on page 695.         

All wall types present in the current plan are listed in the Schedule Specification dialog. See Wall Type Definitions on page 
388.          

When a new wall type is created, it will be included in any existing Wall Schedules as well as in the Wall Schedule Defaults 
automatically. See General Panel on page 705.           

A wall type that is not set to be included may still be listed in a Wall Schedule if it is part of a Pony Wall.          

You can also specify which individual walls are included in a Wall Schedule in the Wall Specification dialog. This affects 
totals like Length and Count. If the wall in question is the only instance of its wall type, that wall type will not be listed 
even if it is set to be included in the Wall Schedule. See General Panel on page 395.          

An Invisible Wall will be included in a Wall Schedule provided that its wall type is set to be included and it has Include in 
Schedule checked.          
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Chapter 12
 

Rooms

Rooms are created when walls are drawn to enclose an area. When a room is defined in this way, it automatically receives 
both a floor and ceiling as well as features like moldings and finish materials that can be seen in 3D Views.  

Rooms can be selected and edited. Each room can be assigned a Room Type with predefined characteristics. For example, a 
room defined as a Deck is assigned certain attributes that are different from a Kitchen. 

TOPICS
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Room Definition
A room is a totally enclosed area defined by any combination of joined walls or railings, visible or invisible. To be 
recognized as a room by Chief Architect, a room must have an unbroken perimeter.

Unless otherwise specified, rooms generate floor and ceiling platforms automatically. Most rooms are also automatically 
covered by the roof when one is built. There are exceptions to this, such as rooms defined as Decks. See Room Types and 
Functions on page 420.

If a room is drawn within a larger structure and none of its walls connect to the exterior walls, either directly or indirectly 
by connecting to walls that do, it is referred to as an “island” room. The program will connect such a room to the larger 
structure with an Invisible Wall. See Room Dividers and Invisible Walls on page 358.

Room definition disappears if part or all of a surrounding wall is deleted. It is a good idea to finalize the position of walls 
before specifying Room Types or defining room attributes such as floor or ceiling height.

SUBDIVIDING ROOMS

When a room area is first defined, it inherits its characteristics from the Floor Defaults dialog for that floor. If the room is 
then specified as a particular type, it may inherit properties from the Room Defaults dialog associated with its type. See 
Floor and Room Defaults on page 418.         

If a new room is created by subdividing a larger room, it inherits its characteristics from that larger room - including any 
non-default settings.          

If two rooms are separated by an Invisible wall, their interior areas will be measured from the wall’s centerline and 
characteristics like the floor finish materials and moldings will break along that line.          

 l If the two rooms have different floor heights, the break will occur at the wall edge that faces the room where the floor 
is lower.          

 l If the two rooms have different ceiling heights, the break will occur at the wall edge that faces the room where the 
ceiling is higher.          

COPYING AND PASTING ROOMS

A room can be copied into the same or a different plan by copying and pasting the walls that define it. Rooms copied in this 
manner retain their size and shape, as well as any finish materials assigned to the walls. See Copying and Pasting Objects 
on page 171. 

If you want to retain the room’s Type and other specifications, copy and paste it and the walls that define it using the Edit 
Area  tools. See Edit Area Tools on page 273.

 

Floor and Room Defaults
Select Edit> Default Settings to open the Default Settings dialog, then click the arrow to the left of “Floors and 
Rooms” to expand the category.  Here, you can access several defaults dialogs which directly affect rooms. Select a 

line item and click the Edit button to open the defaults dialog associated with it.
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FLOOR LEVEL DEFAULTS

Many important default values that affect rooms are specified in the Floor Defaults dialog for each floor in a plan. This 
dialog controls important information that the program uses to create a 3D model - particularly floor and ceiling heights and 
materials. Moldings can also be specified in the Floor Defaults dialog.          

Only the defaults for Floor 1 can be set ahead of time. The program uses the settings from Floor 1 to create subsequent 
floors. Once a new floor is created, its floor defaults can be changed. See Floor Defaults Dialog on page 744.         

The Floor Defaults dialog for the current floor can also be opened by clicking the Floor Defaults button, which can 
be added to the toolbars. See Adding and Removing Buttons on page 137.         

FLOOR 1 DEFAULT HEIGHT

Chief Architect always defines the default height of Floor 1 at 0’-0”. This height value is measured from the top of the 
subfloor and is the constant by which the heights of structural elements in the program like walls, floors, and ceilings are 
measured. The heights of architectural objects can be measured relative to this absolute height, as well. As such, this default 
cannot be changed. 

FLOOR/CEILING PLATFORM DEFAULTS

Floor and Ceiling Structure and Finish definitions assigned to rooms have a hierarchy of dynamic defaults. See Dynamic 
Defaults on page 79.          

 l The plan-wide defaults for platforms are set in the Floor/Ceiling Platform Defaults dialog.          
 l The plan-wide defaults can be overridden for each floor level in the Floor Defaults dialogs.          
 l Floor-wide platform defaults can be overridden in the Room Type Defaults dialogs.           
 l The platform defaults for Room Types can be overridden for individual rooms in the Room Specification dialog. See 

Structure Panel on page 444.          

See Floor and Ceiling Platforms on page 433.           

ROOM TYPE DEFAULTS

The Room Types dialog can also be opened by clicking the Room Types button, which can be added to the toolbars.          

Select an Available Room Type from the list, then:         
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 l Click the Edit button to modify the selected Room Type in the Room Type Defaults dialog.         
 l Click the Copy button to create a new Room Type based on the selected one, and customize it in the Room Type 

Defaults dialog to meet your needs.          
 l Click the Rename button to specify a new Name for the selected Room Type, which will affect its room label as well 

as how it is listed in room schedules.         
 l Click the Delete button to remove the selected Room Type from the list of those available in the plan.          

The settings in the Room Type Defaults dialogs allow you to specify the following for each Room Type:          

 l The Name, as used in its default Room Label               and in Room Schedules. See Schedules and Object Labels on page 694.
 l The room Function. See Room Types and Functions on page 420.             
 l Inclusion in the Living Area. See Living Area on page 429.          
 l Inclusion in the Conditioned Area. See Exported Envelope Data on page 1247.          
 l Ceiling Structure and Finish. See Floor and Ceiling Platforms on page 433.         
 l Floor Structure and Finish.           
 l Framing and Supports for Deck rooms. See Decks on page 430.          
 l Moldings. See Room Moldings on page 441.          
 l Components information for use in the Materials List. See Components Panel on page 1335.          

These settings are also found in the Room Specification dialog. See General Panel on page 443, Structure Panel on page 
444, Deck Panel on page 449, and Deck Support Panel on page 451.          

ROOM LABEL DEFAULTS

The Room Label Defaults dialog allows you to specify the initial appearance of room labels. This dialog is also accessed by 
expanding the “Rooms” category in the Default Settings dialog. See Room Labels on page 427.           

The options on most panels of the Room Label Defaults dialog are similar to those in the Text Specification dialog.               See 
Text Specification Dialog on page 514.

The options on the DIMENSION FORMAT panel are similar to those in the Displayed Line Length dialog. See Displayed Line 
Length Dialog on page 297.         

Any text added to the Room Label Defaults dialog displays in all subsequently created room labels, after the Room Name. 
Changes made to default settings do not alter existing room labels. To update existing labels so that they reflect changes 
made to the defaults, delete and replace them. See Editing Room Labels on page 428.          

 

Room Types and Functions
Room Types are used to quickly apply useful structural, functional, and appearance properties to different kinds of rooms. 
For example, a room assigned the “Garage” Room Type will receive concrete curbs under its walls when the Foundation is 
built, while a “Kitchen” will get GFCI Outlets when the Auto Place Outlet tool is used. 

When a room is first created by enclosing an area with walls, it is assigned a generic room type of “Unspecified.” Once a 
room is created, though, it can be assigned a Room Type in the Room Specification dialog. See General Panel on page 
443. 

A selection of pre-defined Room Types is available for use; they are, however, editable; and, you can create your own, as 
well. See Room Type Defaults on page 419.         
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ROOM TYPE DEFAULTS

Each Room Type is composed of two sets of characteristics: those set by the program, and those that are directly editable.         

Characteristics set by the program are grouped together based on typical requirements for different types of rooms. These 
non-editable sets of properties is referred to as Room Functions.         

Characteristics of a Room Type that can be modified include the default room Name, whether it is included in the Living 
Area and Conditioned Area, and the floor structure, finish, and deck supports. A default Function can also be specified. See 
Room Type Defaults on page 419. 

When you specify that a room be a certain Room Type, all of the characteristics associated with that Room Type are 
assigned to the room, overriding existing settings. After you specify a Room Type, though, various settings can be 
customized.           

ROOM FUNCTIONS

A room Function is a set of non-editable characteristics that are typical of a certain type of room.           

There are three broad categories of room Functions: Interior, Exterior and Hybrid.

 l Interior - Most room Functions are Interior.
 l Exterior - Balcony, Court, Deck.
 l Hybrid - Attic, Garage, Open Below, Porch, Slab.

EFFECTS OF ROOM FUNCTIONS

Chief Architect applies specific properties to rooms depending on the assigned Room Function.    

Living and Conditioned Areas
 l All interior type rooms are included in Living Area calculations by default; exterior and hybrid type rooms are not.         
 l All interior type rooms are included in Conditioned Area calculations by default. Open Below rooms are also included; 

however, exterior and other hybrid type rooms are not. See Exported Envelope Data on page 1247.         

Ceilings and Roofs
 l Interior rooms have a flat ceiling and are set to generate a roof above them.
 l Exterior rooms are assumed to be open to the outside and do not have a flat ceiling or generate a roof above them.
 l Attic rooms do not receive a ceiling and are ignored by the program’s automatic roof generator.
 l Garage, Slabs, and Porches are treated like exterior rooms in all cases except that they generate a ceiling and a roof 

above them by default.

Floors and Foundations
 l A room’s default floor structure and finish definitions are determined by its Room Type. See Room Type Defaults on 

page 419.
 l Open Below rooms have no floor platform and influence how adjacent walls are framed. Stairwells and Crawl Spaces 

are created using the Open Below Room Function. 
 l Garages have a foundation under them as defined by the Foundation Defaults dialog with a concrete slab at the top of 

stem wall or grade beam.
 l The floor in Garage and Slab rooms display in 3D on Floor 0, not the first floor. See Garages on page 728.
 l Defining a room as Slab causes the floor platform thickness to equal the slab thickness value in the Foundation 
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Defaults dialog.         
 l Deck rooms do not generate foundations. See Decks on page 430.

Doors and Windows
 l A window placed in a wall between an exterior room and an interior room always faces out toward the exterior. 
 l Doors placed between interior and exterior type rooms inherit their settings from the Exterior Defaults for the door 

tool, if hinged or sliding; they display threshold lines and are considered Exterior. See Interior vs Exterior Doors on 
page 552.

 l Doors placed between interior type rooms do not display thresholds and are considered Interior. 
 l Open Below rooms are treated as interior rooms for window and door placement. All other hybrid type rooms are 

treated as interior.     

Electrical
 l An electrical object placed on the wall of an exterior room using the Light , Switch , 110V Outlet  or 220V 

Outlet  tool will automatically be a waterproof or outdoor type fixture, as specified in the Electrical Defaults 

dialog. See Electrical Defaults on page 678. 
 l The Auto Place Outlets  tool adds outlets automatically to all interior rooms. In Bath rooms, only one outlet over 

each sink is added. See Auto Place Outlets on page 682.             
 l Auto Place Outlets  places GFCI outlets in Kitchens and Baths.             

 l Auto Place Outlets  places fewer outlets in hybrid type rooms.             

 l Auto Place Outlets  does not place outlets in exterior type rooms, Porches or Open Below rooms.             

Dimensions
 l Auto NKBA® Dimensions  only generate in rooms specified as Kitchens or Baths. See The Automatic Dimension 

Tools on page 480.             

Plan Check
 l Plan Check  uses Room Functions and their characteristics for basic plan checking. For example, a closet does not 

need a smoke detector but a bedroom does. See Plan Check on page 72.             

 

Displaying Rooms
Unlike most things in Chief Architect, a room is not an individual object. Rather, a room is a space defined by the walls that 
enclose it.

You can see the primary and secondary layers associated with a room by selecting it and clicking the Object Layer 
Properties  edit button. See Object Layer Properties on page 192.          

IN PLAN VIEWS

Rooms typically display a transparent fill in plan view. You can, however, specify a solid color or fill pattern for all the 
rooms on an entire floor in the Floor Defaults dialog, or for individual rooms in the Room Specification dialog. See Fill 
Style Panel on page 452.

In order for room fill styles to display, the “Rooms” layer must be turned on. See Layer Attributes on page 181. 
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Room labels that include the room’s name as well as its size and other information can be set to display in plan view. See 
Room Labels on page 427. 

IN 3D VIEWS

Rooms can be viewed in views created by any of the 3D view tools. The              Floor Overview tool             s can be used to see all 
rooms on the current floor without their ceilings. See Creating Overviews on page 1088.         

IN THE MATERIALS LIST

The contents of a room, including furnishings and floor and ceiling materials can be calculated using the Calculate in 
Room tool. See Calculate Materials in Room on page 1310.         

The Calculate Materials From Selection edit tool creates a Materials List that calculates the finish materials in a selected 
room or rooms. Room moldings and wall, floor, and ceiling finish materials are counted, as is subflooring; but doors, 
windows, and structural materials like framing and other structural materials are not.           

IN SCHEDULES

Information about rooms and their contents can be reported in different types of schedules. See Room Finish 
Schedules on page 453. 

You can also create any type of schedule that lists the contents of a selected room using the Create Schedule from 
Room edit tool. See Create Schedule from Room on page 696.

 

Selecting Rooms
Room definition is established when a room is completely enclosed by walls. You can confirm that a room has room 
definition by using the Select Objects  tool to select it. When a fully-enclosed room is selected, its interior space 

becomes highlighted. See Selecting Objects on page 212. 

Rooms can be group-selected using the Shift or Ctrl key. They can also be marquee-selected using the Marquee Select 
Similar  edit tool. To select rooms of a particular type, us the Restrictive Selection  option. See Selecting Multiple 

Objects on page 215.

Although rooms may be visible, if the “Rooms” layer is locked in the               currently active layer set, it will not be possible to 
select a room. See Locking Layers on page 182. 

Note: The selection color can be specified in the Preferences dialog. See 
Colors Panel on page 102.
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As with many other objects in the program, rooms can be group-selected. Not all attributes of multiple selected rooms can 
be edited; however, many - such as moldings, materials, and fill style - can be.          

THE EXTERIOR ROOM

Each floor level of a plan has an Exterior Room, which allows you to control its exterior wall coverings and materials in the 
Exterior Room Specification dialog. See Room Specification Dialog on page 442.

To select the Exterior Room in plan view, click just outside an exterior wall using the Select Objects  tool. If a wall or 

other object becomes selected instead, click the Select Next Object  edit button or press the Tab key until the Exterior 

Room becomes selected. The Status Bar indicates which object is currently selected. See The Status Bar on page 25. 

When it is selected, a highlighted band around the plan’s exterior displays. 

IN 3D VIEWS

A room can be selected in a 3D view by clicking on an empty space on its floor or a wall surface while the Select Objects 
 tool is active. 

If you select a wall or other object instead of the room, click Select Next Object  edit button or press the Tab key until 

the room becomes selected. 

In exterior camera views and overviews, the Exterior Room for each floor can be selected by clicking on the exterior surface 
of an exterior wall using the Select Objects  tool and then clicking the Select Next Object  edit button. 

SELECT ROOM BEFORE WALL IN 3D

By default, when you click on a wall surface in a 3D view, the individual wall will become selected. If you prefer to always 
select the room first instead of the wall, check  Select Room Before Wall in 3D in the Preferences dialog. See Architectural 
Panel on page 116.          

MATCH PROPERTIES

Click a room to select it, then click the Match Properties edit button and group-select rooms with shared attributes. 
See Match Properties on page 286.         

424



Chief Architect Premier X14 Reference Manual - Editing Rooms

 

Editing Rooms
A room’s structure and appearance can be modified using its edit tools and specification dialog. Rooms can be selected in 
all views, and the ways in which they can be edited depend somewhat on the current view. See Selecting Rooms on page 
423. 

IN 3D VIEWS

The top and bottom heights of individual walls, the floor and ceiling heights of individual rooms, and the floor and ceiling 
heights for entire floor levels can be edited using edit handles in 3D views. Lowered ceilings cannot be edited in 3D. See 3D 
Views on page 1080. See The Exterior Room on page 424.

The default floor and ceiling heights for an entire floor level can be edited by selecting the Exterior Room. See The Exterior 
Room on page 424 and Floor and Room Defaults on page 418.

To change default ceiling heights in 3D
 1.  Create a 3D or Cross Section/Elevation view of the exterior of your plan. 

 2.  Click on the exterior surface of a wall, then click the Select Next Object  edit button.

 3.  When the Exterior Room is selected in 3D:

 l The wall that you clicked on remains highlighted and an edit handle displays along its top edge.

 l When the wall is on any floor other than Floor 1, an edit handle also displays along its bottom edge.

 l A bounding box displays around each wall of the selected floor level. 

 l The Status Bar says “Exterior Room”. See The Status Bar on page 25.

 l A temporary dimension will display, measuring from the floor’s default rough floor to default rough ceiling. See 
Temporary Dimensions on page 480.

 4.  Click and drag the edit handle on the top wall edge to adjust the default ceiling height, or the edit handle on the 
bottom edge to adjust the default floor height. 

 5.  As you drag a handle, notice that the entire floor level is affected.

 l The wall that you clicked on remains highlighted and an edit handle displays along its top edge.
 l When the wall is on any floor other than Floor 1, an edit handle also displays along its bottom edge.
 l A bounding box displays around each wall of the selected floor level. 
 l The Status Bar says “Exterior Room”. See The Status Bar on page 25.
 l A temporary dimension will display, measuring from the floor’s default rough floor to default rough ceiling. See 

Temporary Dimensions on page 480.

 1.  Click and drag the edit handle on the top wall edge to adjust the default ceiling height, or the edit handle on the 
bottom edge to adjust the default floor height. 

 2.  As you drag a handle, notice that the entire floor level is affected.
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Note: Any rooms that do not update when the default floor or ceiling 
height is changed are not using the default values. To use the default 
values for a specific room, check Default for any of the room height 
values in its specification dialog. See General Panel on page 443.

To adjust room heights in 3D
 1.  Create a 3D or Cross Section/Elevation view of your plan.

 2.  Click on the surface of a wall that faces a room to select it, then click the Select Next Object  edit button. 

 3.  When a room is selected in 3D:

 l The wall that you clicked on remains highlighted and an edit handle displays along its top and bottom edges.

 l The Status Bar says “Room”. 

 l A temporary dimension will display in cross section/elevation views, and measure from the room’s rough floor to 
rough ceiling. 

 4.  Click and drag the edit handle on the top wall edge to adjust the room ceiling height, or the handle on the bottom 
edge to adjust its floor height. Temporary dimensions display.

 5.  As you drag a handle, notice that all walls defining that room are affected.

To adjust the height of a wall in 3D
 1.  Create a 3D or cross section/elevation view of your plan.           

 2.  Click on a surface of the wall to select it.          

 3.  Click and drag the edit handles along its top and bottom surfaces. See Wall Heights on page 374.          

Room materials such as floor, ceiling, and wall materials can be changed in 3D views using the Material Painter . See 

Material Painter Tools on page 1053.

Room moldings can be replaced directly from the library in 3D views, as well. See Replace From Library on page 983.

If you use the Material Painter to change a room’s floor or 
ceiling finish material, it will add that material to the room’s 

Floor or Ceiling Finish Definition. Changes to a Deck room’s planking or 
framing will affect its floor structure definition.

IN THE SPECIFICATION DIALOG

Floor and ceiling heights and structure, moldings, wall coverings, and materials can all be specified in the Room 
Specification dialog. See Room Specification Dialog on page 442.

When multiple rooms are selected, the options available in the Room Specification dialog will be limited. You can, 
however, apply attributes to multiple rooms using the Match Properties  and Apply Properties  edit tools. See 

Match Properties on page 286.          

You can also apply a variety of attributes to rooms using Style Palettes. See Style Palettes on page 284.    

USING THE EDIT TOOLS

A variety of options are available on the Edit Toolbar for a selected room. See The Edit Toolbar on page 135.         
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  Calculate Materials for Room creates a materials list of the contents of the selected room, not including walls. 
See Calculate Materials in Room on page 1310.          

  Add Selected Object(s) to Style Palette  adds the selected room’s attributes to a Style Palette. See Style Palettes 
on page 284.          

  Build Framing for Selected Object(s) builds or rebuilds the framing for the selected room. See Build Framing 
for Selected Object(s) on page 900.          

  Make Room Polyline creates a CAD polyline that follows the surfaces of the selected room. See Room Polylines 
on page 441.          

  Make Standard Area Polyline creates a CAD polyline that follows the perimeter of the room’s Standard area. 
See Displaying Room Labels on page 428.           

  Make Room Molding Polyline creates a room molding polyline. See Make Room Molding Polyline on page 
441.          

  Make Tray Ceiling in Room creates a tray ceiling in the room. See Tray and Coffered Ceilings on page 435.          

  Expand Room Polyline creates a temporarily enlarged room definition that ignores invisible walls and railings. 
See Expand Room Polyline on page 442.           

  Create Schedule from Room creates a schedule showing only objects of a particular type located in that room. 
See Create Schedule from Room on page 696.          

  Create Room Elevation Views  creates an interior elevation view of each wall defining the selected room. See 
Cross Section/Elevation Views on page 1090.          

  Auto Room Dimensions edit button to generate interior dimensions that measure each wall defining the selected 
room(s). See Auto Room Dimensions on page 481.          

 

Room Labels
A label can display in plan view for any area defined as a room. There are two parts to each room label: 

 l The Room Name, which is set in the Room Specification dialog.
 l The room size, which can be reported as dimensions and/or an area and is determined by the configuration of the walls 

that define the room. 

Room labels can move or even disappear when room entries are 
revalidated.

CUSTOM ROOM NAMES

The Room Names that display in room labels are based on the Room Types assigned in the Room Specification dialog. See 
Room Types and Functions on page 420.

You can, however create a custom name for a selected room, also in the Room Specification dialog. See General Panel on 
page 443.

Before creating a custom Room Name, assign the Room Type most similar to the room’s actual use.  For example, if you 
wish to name a room “Guest Room”, begin by specifying it as a “Bedroom” since these rooms have similar uses. 

You can assign a custom Room Name, move a room label or even delete it without affecting the Room Type. 
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ROOM LABEL DEFAULTS

The initial settings that control the size, font, color and other aspects of room label appearance are controlled in the 
Room Label Defaults dialog. See Room Label Defaults on page 420.          

You can also add additional text to the default room label if you wish. This text will appear in the labels for all rooms.          

Room labels can be customized using a variety of text macros. 
See Text Macros on page 549. 

DISPLAYING ROOM LABELS

The display of room labels is controlled in the Layer Display Options dialog.             By default, room labels are placed on the 
“Rooms, Labels” layer and use the Text Style assigned to that layer. See Layer Display Options Dialog on page 183.         

You can specify how the area of rooms is reported by the program by turning on the display of one or more of these layers:         

 l Rooms, Standard Area is measured from the center of interior walls that define the room and from either the outside 
surface or the outside of the Main Layer of exterior walls, depending on the Living Area to setting in the General Plan 
Defaults dialog. It is rounded to the nearest square foot or mm and does not include the area within bay, box and bow 
windows. See Exterior and Interior Walls on page 355 and General Plan Defaults Dialog on page 96.         

 l Rooms, Interior Area is measured from the inner surfaces of all the room's walls.         
 l Rooms, Interior Dimensions is also measured from the inner surfaces of the room walls. Its format is set on the 

DIMENSION FORMAT panel of the Room Label Defaults dialog. See Room Label Defaults on page 420.

The display of room labels can also be controlled on a room by room basis in the Room Specification dialog. See General 
Panel on page 443.         

EDITING ROOM LABELS

Room labels are similar to simple Text  objects and can be moved and resized much like any other text object. You can 

also modify a room label’s Text Style and other attributes in the Room Label Specification dialog. See Text Specification 
Dialog on page 514. 

The text of a room label cannot be modified in its specification dialog, however. The Room Name can only be specified in 
the Room Specification dialog and additional text can only be added in the Room Label Defaults dialog. 

If you delete a room label, the Room Type and Room Name remain unchanged in the Room Specification dialog. To restore 
the label, check the Show Room Label check box on the GENERAL panel of that dialog.

If you wish to further customize an individual room’s label by adding text or a text macro, uncheck Show Room Label in 
the Room Specification dialog and create your own label using a Text object. See The Text Tools on page 505.

Note: If you use the Convert to Rich Text edit tool to convert a Room 
Label to a Text object, it will no longer be display room size information 
or update if the room type is changed. See Convert to Rich Text on page 
521.

ROOM AREA

Unlike the rest of a room label, the room area and dimensions are not standard text entries and cannot be edited or changed. 
The room area moves, resizes and rotates with the rest of the room label, but you can turn the area and dimensions on or off 
separately in the Layer Display Options dialog. See Displaying Rooms on page 422.
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All three area formats measure the room's size at floor level. The Interior Area room area calculation includes the areas 
within bay, box or bow windows, while the Standard Area and Interior Dimensions calculations do not. 

You can use the Make Room Area Polyline  edit button to see the exact extents of the selected room’s Standard Area.           

You can also insert room areas as well as other information into text objects using Text Macros. See Text Macros on page 
549.          

LIVING AREA

The Living Area label is an automatically generated Text object that reports the area of the current floor specified as living 
space. By default, interior type rooms are defined as part of the Living Area, while exterior and hybrid type rooms are not. 
In addition, rooms with a Rough Ceiling height that is less than 48" (1200 mm) are excluded from the Living Area by 
default. See Room Functions on page 421.

Regardless of its Room Type, you can specify whether any room is included in the Living Area Calculation in the Room 
Specification dialog. See General Panel on page 443.

A Living Area label is created as soon as a room area is defined by walls and/or railings and is recalculated every time you 
add, remove, resize, or redefine a room or when you Rebuild Walls/Floors/Ceilings . If multiple buildings are created, 

each will have its own Living Area label. If none of a structure’s rooms are included in the Living Area Calculation, 
however, no Living Area label will display for it. 

Each Living Area label can be edited in its specification dialog. Bear in mind, though, that if a new floor is added, any 
existing Living Area labels will be deleted and replaced. See Text Specification Dialog on page 514.

Living Area labels are placed on the "Room Labels" layer by default. To turn off the display of all Living Area labels in a 
plan without affecting individual room labels, you can uncheck Show Living Area Label in the General Plan Defaults 
dialog. See General Plan Defaults Dialog on page 96.

Living Area labels cannot be deleted: if you select one and click the Delete  edit button, Show Living Area Label in the 

General Plan Defaults dialog will become unchecked.          

LIVING AREA VS. FOOTPRINT

The Living Area should not be mistaken for the footprint of a house. Only true livable areas are included in the Living Area 
calculation. By default, exterior and hybrid room types such as Garage, Deck, and Porch are not included. Neither is any 
room labeled Open Below or Attic. See Room Functions on page 421. 

Regardless of its room type, you can specify whether a room is included in the Living Area calculation in the Room 
Specification dialog. See General Panel on page 443. 

You can quickly see which rooms are included in the Living 
Area using the Match Properties edit tool. See Matching 

Properties on page 286.

Living Area is measured from either the outside surface or the outer surface of the Main Layer of exterior walls. See Wall 
Type Definitions on page 388. 

You can use the Make Living Area Polyline  edit button to see the exact extents of the current Living Area Calculation.           
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To find the extents of the Living Area
 1.  Click just outside an exterior wall to select the current floor’s Exterior Room. See The Exterior Room on page 424.         

 2.  Click the Make Living Area Polyline  edit button. This creates a polyline surrounding the area included in the 

Living Area on the current floor.         

 3.  You can edit the polyline’s shape to include or exclude portions of the plan if you wish. See Using the Edit Toolbar 
on page 232.         

Note: Editing the shape of the Living Area Polyline does not affect 
the Living Area Calculation. 

 4.  Select the polyline and click the Open Object  edit button. The polyline’s Area is stated in the Polyline 

Specification dialog. See Polyline Panel on page 323.         

A polyline created using the Make Living Area Polyline  edit tool is a static representation of the current Living Area 

Calculation. If changes are made to the model that affect the Living Area, any previously created Living Area Polylines will 
not be affected.         

To find the footprint of a floor
 1.  Select the Exterior Room.         

 2.  Click the Make Room Polyline  edit button. This creates a polyline around the exterior walls.         

 3.  Edit the shape of the polyline if you wish.         

 4.  Select the polyline and click the Open Object  edit button. The polyline’s Area is stated in the Polyline 

Specification dialog.         

 

Decks
A Deck room is an exterior-type room that uses deck planking and framing to create a floor platform rather than using a 
floor finish that spans the entire room area. See Floor and Ceiling Platform Definitions on page 434. 

The default settings for deck planking and framing are set in the Deck Room Defaults dialog. See Room Type Defaults on 
page 419.         

To draw a deck, select Build> Railing and Deck> Straight Deck Railing , then click and drag to draw a railing. Once 

room definition is established, the area defined by the railing can be assigned the “Deck” room type. 

 l To create a deck without a railing, use one of the Deck Edge tools. See Fencing Tools on page 354.         
 l You can also create a regular, polygon-shaped deck using the Polygon Shaped Deck  tool. See Polygon Shaped 

Deck on page 353.         

A room does not have to be defined by Deck Railing to be specified as a “Deck.” See Room Types and Functions on page 
420. You can also define a room as a “Deck” in the Room Specification dialog. See General Panel on page 443. 

By default, decks do not have roofs. If you want a roof over a deck, check Roof Over This Room in the Room 
Specification dialog. See Structure Panel on page 444.

To give the roof a visible means of support, you can select the Post to Beam option in the Wall Specification dialog. See 
Rail Style Panel on page 412.
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Openings in deck railings can be created using Doorways . See Openings in Railings on page 564. 

DECK FRAMING AND PLANKING

When a Deck room is created, the floor platform is modeled using joists, beams, posts, and planking as specified in the 
Deck Room Defaults dialog. See Structure Panel on page 444, Deck Panel on page 449, and Deck Support Panel on page 
451. 

 l If a floor level is present below the one that the Deck room is created on, the framing will be created there. If needed, 
beams may be generated with posts beneath them, if specified. When terrain is present, the posts will have footings, 
again, if specified.           

 l If a floor level is not present below the Deck, framing will be generated on the same floor as the room. Beams may be 
created but posts will not.           

 l Deck framing, planking, posts, and beams are placed on their own layers with names that begin with “Framing, Deck”: 
for example, “Framing, Deck Posts”. These layers are often turned off in plan view but are typically turned on in 3D 
views. See Displaying Framing on page 894.

If standard floor framing is present when a room is specified as a Deck, that framing is deleted and replaced with deck 
framing.           

If changes are later made to the settings on the DECK panel of the Room Specification dialog, the deck framing and planking 
will be automatically rebuilt in response. To prevent this from happening, uncheck Automatic Deck Framing.          

Once created, the individual planking and framing objects generated for a Deck room can be selected and edited like other 
framing objects, provided that Automatic Deck Framing is turned off. See Editing Framing on page 897.           

To rebuild a deck’s framing and remove any changes you may have made to individual deck framing or planks, select the 
Deck room and click the Build Deck Framing  edit button.          

If you delete a Deck room, its deck framing and planking will be automatically deleted, as well. To prevent this from 
happening, check Keep Deck Framing After Deck Room is Deleted. See Deck Panel on page 449.          

The structural materials for a selected deck can be calculated in a Materials List by clicking the Calculate Structural 
Materials for Deck edit button. See Materials Lists on page 1309.

DECK FRAMING SCHEDULES

The framing components that make up the decks in a plan can be listed in a Framing Schedule. See Framing Schedules on 
page 897.          

 

Floor and Ceiling Heights
Default floor and ceiling heights are defined in the Floor Defaults dialog for each floor, including the foundation. Use the 
Floor Defaults dialog to change these values on a floor-by-floor basis. See Floor and Room Defaults on page 418.

Use the Room Specification dialog to set floor heights on a room-by-room basis. See Room Specification Dialog on page 
442. 

Different rooms on the same floor can have unique floor and ceiling heights, allowing you to create: 

 l Split levels and bi-levels
 l Sunken living rooms and garages
 l Cathedral, vaulted, and coffered ceilings.
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In 3D views, you can adjust the default floor and ceiling height for the entire floor, the floor and ceiling height for an 
individual room, or the top and bottom heights of an individual wall. See In 3D Views on page 425.

In order to raise or lower an area’s floor or ceiling height, you must give it a room definition. To create room definition 
without enclosing an area with solid walls, use Railings . 

Invisible walls and railings will fill in the vertical space between floor platforms of different heights as long as Generate 
Between Platforms is checked in their specification dialog. See General Panel on page 395.           

Ceiling and floor heights are interrelated. Changing the floor height in one room can affect ceiling heights of the rooms 
below. 

 l If a room’s floor is lowered, its ceiling height is increased while the ceiling below that room drops. 
 l If the floor is raised, the ceiling height decreases while the ceiling below that room is raised. 

If the rooms above a particular room have more than one floor height, the room’s ceiling is stepped.

In a situation like this, a Lowered Ceiling can be used to cover “steps” made by different floor heights on the floor above. 
See General Panel on page 443.

DROPPED CEILINGS AND RAISED FLOORS

The structure of a dropped, or suspended, ceiling can be specified in the Ceiling Finish Definition dialog either for a room 
or the defaults for a floor. See Floor and Ceiling Platform Definitions on page 434.         

To create a framed dropped ceiling
 1.  Select a room and click the Open Object  edit button.           

 2.  On the STRUCTURE panel of the Room Specification dialog, click the Ceiling Finish button. See Structure Panel on 
page 444.          
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 3.  In the Ceiling Finish Definition dialog:         

 l Specify Layer 1 as the plenum, or air gap, space.          

 l Specify Layer 2 as the horizontal framing. Framing member spacing and width are set in the material 
definition. See Define Material Dialog on page 1066.          

 l Specify Layer 3 as the drywall.          

 l Specify Layer 4 as the paint color.          

A dropped ceiling composed of a metal grid requires only two layers: one for the plenum and one for the tiles.              

You can create a raised floor, such as for a shower pan, in a similar manner by specifying it in the Floor Finish Definition 
dialog.           

SHELF CEILINGS

In rooms with high or vaulted ceilings, it is possible to have a smaller room such as a closet that has a flat, lower ceiling. By 
default, the area above the flat ceiling will be enclosed by automatically-generated Attic walls. See Attic Walls on page 383. 

If you prefer, you can specify that these Attic walls be suppressed and an open space be created instead. This condition is 
referred to as a Shelf Ceiling, or plant shelf, and can be specified in the Room Specification dialog of the room with the 
lower flat ceiling. See Structure Panel on page 444. 

SPLIT LEVELS

A split level can be created by raising or lowering the floor and ceiling heights of various areas of the plan.

In the following example, the lowest floor height is 0, the next is 24, and the next is 48 inches. The ceiling height in each 
room is set at 109 inches. See Split Levels on page 749.

 

Floor and Ceiling Platforms
In many ways, rooms in Chief Architect are defined by the floor platforms below them and the floor and/or ceiling 
platforms above.          

All floor and ceiling platform and finish materials are used for the calculation of the materials list. See Materials Lists on 
page 1309.         

433



Chief Architect Premier X14 Reference Manual - Floor and Ceiling Platforms

FLOOR VS CEILING PLATFORMS

Floor and ceiling platforms are not the same thing in Chief Architect. Floor platforms have living space above them and are 
designed to be weight-bearing. Ceiling platforms, on the other hand, have living space below them but not above them. 
They are not designed to bear weight and are typically less strong - and less thick - than floor platforms.         

FLOOR AND CEILING PLATFORM DEFINITIONS

Floor and ceiling platforms are made up of layers of different materials such as framing, subflooring, drywall, and finish 
materials.              So, typically, are Floor Material Regions. See Floor and Wall Material Regions on page 1037. 

Floor and ceiling platform definitions play a role in determining floor and ceiling heights. Floor and ceiling finishes can be 
used to create              raised floors as well as dropped ceilings. See Floor and Ceiling Heights on page 431. 

 l You can specify the composition of the default floor and ceiling platforms for an entire plan in the Floor/Ceiling 
Platform Defaults dialog. The settings in this dialog are also found in the Room Specification dialog. See Structure 
Panel on page 444.         

 l Floor and ceiling platforms can be customized on a floor-by-floor basis in the Floor Defaults dialog. See Floor Level 
Defaults on page 419.         

 l Floor and ceiling platforms can also be customized for individual rooms in the Room Specification dialog. See 
Structure Panel on page 444.         

Regardless of how they are accessed, floor and ceiling structure are defined in the Floor and Ceiling Structure Definition 
dialogs. See Material Layers Definition Dialogs on page 1040.         

In addition to the structural layers of a platform, floors and ceilings typically have one or more finish layers. You can 
specify floor and ceiling finish materials for an entire floor or individual room much the way you can structural layers: by 
clicking the Floor Finish and/or Ceiling Finish button on the STRUCTURE panel of either the Floor Defaults or Room 
Specification dialog to open the Floor or Ceiling Finish Definition dialog.         

FLOOR AND CEILING FINISHES AND THE MATERIAL PAINTER

If you use the Material Painter to change a room’s floor or ceiling finish material, it will add that material to the 
room’s Floor or Ceiling Finish Definition. Changes to a Deck room’s planking or framing will affect its Floor 

Structure Definition. See Material Painter Tools on page 1053.         

When the Material Painter is used to add a floor or ceiling finish material in a room where one does not currently exist, a 
new finish layer is created and the material Depth is used as its Thickness. See Materials List Panel on page 1076.         

FLOOR MATERIAL REGIONS

Floor Material Regions allow you to create areas within a floor that use different layers of materials than the parent 
object. See Floor and Wall Material Regions on page 1037.         

STEPPED FLOOR AND CEILING PLATFORMS

Each floor has default floor and ceiling heights. You can, however, use the Room Specification dialog to specify floor and 
ceiling heights on a room by room basis to create stepped floors and ceilings. See Structure Panel on page 444.    

If you require a single floor platform with a uniform height and thickness but different ceiling heights for the rooms below, 
specify a lowered ceiling using the Ceiling Finish Specification dialog. See Lowered Ceilings on page 439.   

434



Chief Architect Premier X14 Reference Manual - Tray and Coffered Ceilings

Either way, by default, any gap between floor and ceiling platforms that step at a railing or invisible wall is closed off by a 
short section of solid wall. If you require a gap between the platforms, either select a single-layer wall type or uncheck 
Generate Between Platforms in the Wall or Railing Specification dialog. See General Panel on page 395.    

PLATFORM EDGES

Typically, floor and ceiling platforms are built so that they bear on top of walls. The edges of the platform structures extend 
through exterior walls to the layer of the wall type definition with the Build Platform to This Line setting. See Wall Type 
Definitions on page 388.    

 l For framed walls, the Build Platform to This Line layer is set as the outside of the wall’s Main Layer,     
 l For concrete walls, it’s the inside of the wall’s Main Layer.     
 l The platforms of rooms with raised floors and/or lowered ceilings build in the same manner: to the Build Platform to 

This Line layer of the wall type assigned to the railing or invisible wall defining the room. See Floor and Ceiling 
Heights on page 431.     

For a given wall type, you can specify a different Build Platform to This Line wall layer surface provided that it  is on the 
exterior side of the Main Layer.    

In addition, you can specify that individual walls build through floor and ceiling platforms in the Wall Specification dialog.  
See General Panel on page 395.   

PLATFORM HOLES

Select Build> Floor> Hole in Floor Platform or Hole in Ceiling Platform, then click and drag a rectangular 
polyline that forms a hole in the designated platform.   

You can also create a hole in a floor or ceiling platform by drawing a closed CAD polyline and then using the Convert 
Polyline  edit button to convert it into a platform hole. See Convert Polyline on page 265.    

Platform hole edges derive their material from the ceiling finish of the room directly below the hole.    

Note: The Hole in Ceiling Platform tool only forms holes in the flat 
ceiling that is automatically generated in a room. It does not create holes 
in manually drawn Ceiling Planes. See Ceiling Planes on page 841.

 

Tray and Coffered Ceilings
A wide variety of different tray and coffered ceiling configurations can be created using Tray Ceiling Polylines. A basic 
Tray Ceiling Polyline is made up of an upper and lower Ceiling Plane and a ceiling plane hole, but you can add moldings 
and rope lights if you wish. You can also add sloped sides formed by additional Ceiling Planes, and you can recess the tray 
ceiling into the ceiling platform rather than build it below the room’s ceiling. 

In addition to placing a single Tray Ceiling Polyline, smaller polylines can be nested inside larger ones and you can 
replicate nested polylines to create a coffered ceiling. See Multiple Copy on page 176. 

There are four ways to create Tray Ceiling Polylines:

Select Build> Roof> Tray Ceiling Polyline and then click inside a room. A Tray Ceiling Polyline that follows the 
shape of the room is created. Tray Ceiling Polylines can also be created by clicking and dragging. See Polylines on 

page 322. 

Create a Tray Ceiling Polyline that follows the perimeter of a room by selecting that room and clicking the Make 
Tray Ceiling in Room edit button.
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You can also convert a closed CAD polyline into a Tray Ceiling Polyline. See Convert Polyline on page 265.

In addition, you can select a Tray Ceiling Polyline and create a new, smaller one that follows the perimeter of the 
original by clicking the Make Nested Tray Ceiling edit button.

In order for a Tray Ceiling Polyline to generate in 3D, it must be located in a room with a flat ceiling. Tray Ceiling 
Polylines do not have surfaces on their sides, so while one can be positioned next to a room with no ceiling, it will not have 
a closed side. See Structure Panel on page 444.

If a Tray Ceiling Polyline is shaped or positioned in a way that is not supported, a Caution   symbol will display in its 
interior. In this state, the tray ceiling will not generate framing or display in 3D views. Move the mouse pointer over the 
symbol to display a Tool Tip with information about how to fix the problem.

EDITING TRAY CEILING POLYLINES

Once created, Tray Ceiling Polylines can be edited much the way other closed CAD polylines are. See Editing Closed 
Polyline-Based Objects on page 230.

Tray Ceiling Polylines can also be edited in their specification dialogs. See Tray Ceiling Specification Dialog on 
page 436.

To generate framing for a selected Tray Ceiling Polyline, select it and click the Build Framing for Selected Object 
edit button. See Build Framing for Selected Object(s) on page 900.

EXPLODE TRAY CEILING

Click the Explode Tray Ceiling edit button to explode a selected Tray Ceiling Polyline into its component parts. The 
ceiling planes as well as the ceiling and/or platform hole and any Molding Polylines and Rope Lights can then be 

edited individually.

Once exploded, the components of a Tray Ceiling Polyline cannot be blocked together again.

This option is not available if the polyline displays a Caution   symbol.

 

Tray Ceiling Specification Dialog
The Tray Ceiling Specification dialog opens if you select one more Tray Ceiling Polylines and click the Open 
Object edit button.

This dialog also opens when you select a room and click the Make Tray Ceiling in Room or Make Nested Tray Ceiling 
edit button. See Tray and Coffered Ceilings on page 435.

The Tray Ceiling Specification dialog has the following panels:          
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GENERAL PANEL

 
Tray Ceiling

Specify the tray ceiling's structure.         

 l Specify the Width of the outer ceiling, from the outside edge to the hole in its center. The Width setting is only 
present when this dialog is opened using the Make Tray Ceiling in Room or Make Nested Tray Ceiling edit tool.           

 l Specify the vertical Depth, which is the distance from the surface of the lower ceiling to that of the upper ceiling.          

 l Check Recess into Ceiling to build the outer ceiling at the room’s specified ceiling height and raise the inner ceiling 
into the room’s ceiling platform. When unchecked, the inner ceiling is positioned at the room’s specified ceiling 
height and the outer ceiling is dropped.           

 l Specify the Pitch of the tray’s sides. When a non-Vertical value is specified, a sloped Ceiling Plane is created along 
each edge. When this is the case, rope lights and moldings cannot be specified.           

 l Check Vertical to produce vertical sides with no side Ceiling Planes.          

 l Check Pitch in Degrees to display the pitch value in degrees in all dialogs as well as in roof plane labels. Values 
between -89° and 89° can be entered. When this is unchecked, Pitch is described in terms of rise and run: x inches in 
12 or in metric plans, x mm in 1000.           

  Ceiling Layers

 l The total thickness of the Structure displays here for reference. Click the Edit button to modify the structure. See 
Material Layers Definition Dialogs on page 1040.          

 l Check Use Room Ceiling Material for Sides to apply the room’s ceiling finish material to the sides of the tray 
ceiling.          

 l Check Use Room Ceiling Material for Top to apply the room’s ceiling finish material to the top of the tray ceiling.          
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  Framing

 l Check Retain Framing to prevent the framing associated with the selected Tray Ceiling Polyline from being rebuilt. 
See Build Framing for Selected Object(s) on page 900.       

 l Specify the Tray Ceiling's on-center Rafter Spacing.

 l Specify the Rafter Width.

POLYLINE PANEL

The POLYLINE panel indicates the length of the tray ceiling interior’s Perimeter and its enclosed Area. See Polyline Panel 
on page 323.          

MOLDINGS PANEL

Crown or other moldings can be assigned to a Tray Ceiling Polyline on the MOLDINGS panel. Moldings are placed around 
the inside perimeter of the polyline at the specified height.          

The settings on the MOLDINGS panel are similar to those found in other specification dialogs throughout the program. See 
Moldings / Profiles Panels on page 943.          

The settings on  this panel are only available when the Pitch of the tray ceiling sides is set to “Vertical” on the GENERAL 
panel.           

ROPE LIGHTS PANEL

The settings on the ROPE LIGHTS panel allow you to assign rope lights to the inside perimeter of the selected Tray Ceiling 
Polyline. See Rope Lights on page 680.          

The settings on this panel are similar to those on the MOLDINGS panel found in a variety of dialogs in the program. See 
Moldings / Profiles Panels on page 943.           

Two things about the ROPE LIGHTS panel are unique:          

 l No attributes of the rope light aside from its Horizontal and Vertical Offset can be specified here.           
 l Click the Edit button to open the Rope Light Specification dialog for the rope light selected in the table. See Rope 

Light Specification Dialog on page 691.          

The settings on the ROPE LIGHTS panel are only available when the Pitch of the tray ceiling sides is set to “Vertical” on the 
GENERAL panel.           

LINE STYLE PANEL

For information about the settings on this panel, see Line Style Panel on page 310.          

FILL STYLE PANEL

The settings on the FILL STYLE panel affect the appearance of the selected polyline in plan view. For information about 
these settings, see Fill Styles on page 197.          

MATERIALS PANEL

The MATERIALS panel can be found in dialogs throughout the program. For information about the settings on this panel, see 
Materials Panel on page 1055.          
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LABEL PANEL

Tray Ceiling Polyline labels display in plan  views when the “Roofs, Labels” layer is turned on and use the Text Style 
assigned to that layer. The Automatic Label for Tray Ceiling Polylines is blank, but you can specify a custom label.          

For information about the settings on this panel, see Label Panel on page 712.            

 

Special Ceilings
By default, the program builds a flat ceiling platform on top the wall plates of a room. More varied and complex ceilings are 
made using settings in the Room Specification dialog and the Ceiling Plane  tool. Ceiling planes are drawn and can be 

edited much like roof planes. See Ceiling Planes on page 841.

LOWERED CEILINGS

If you require uniform top plate heights and a single floor platform with a uniform height and thickness but different ceiling 
heights for the rooms below, specify a lowered ceiling. You can define a lowered or dropped ceiling in a room without 
affecting the top height of the walls by specifying the lowered ceiling framing as a layer in the Ceiling Finish Definition. 
See Floor and Ceiling Platforms on page 433.

In the following illustration, the default ceiling height for the entire first floor is 120", and the room on the right has a 
ceiling finish lowered to 96".  

When a Soffit is positioned against the ceiling in a room, the Ceiling Finish layers located directly above it - including any 
lowered ceiling framing - will not generate. See Placing Soffits on page 1034.          

To create a lowered ceiling
 1.  Select the room in which you would like to specify a lowered ceiling.

 2.  Click the Open Object  edit button to open the Room Specification dialog.

 3.  On the STRUCTURE panel, click the Ceiling Finish button to open the Ceiling Finish  Definition dialog. See Material 
Layers Definition Dialogs on page 1040.             

 l Select Layer 1 of the ceiling finish definition, then click the Insert button to create a new layer above the current 
Layer 1.                  

 l Specify the desired Thickness of the new layer, which will form the lowered ceiling framing.                   
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 l Click the Select Material button and specify the new layer’s material as a Framing material.                   

 l Specify the Structural Type, the type of framing member you want to use to frame the lowered ceiling.                  

 4.  Repeat step 3 if you require additional layers, such as an air gap, above the lowered framing.             

 5.  When you are finished, click OK to close the Ceiling Finish Definition dialog.             

 6.  On the Structure panel, notice that the preview diagram represents the Finished Ceiling height (F).

    VAULTED AND CATHEDRAL CEILINGS

A cathedral ceiling has the same pitch as the roof and is created using the underside of the roof above the room. A vaulted 
ceiling typically has a different pitch from that of the roof and is often framed using scissor trusses. See Scissors Trusses on 
page 927.

To create a cathedral ceiling
 1.  Build a roof for your plan. See Roofs on page 803. 

 2.  Select the room and open the Room Specification dialog. See Room Specification Dialog on page 442.

 3.  On the STRUCTURE panel, uncheck Flat Ceiling Over This Room.

By default, cathedrals ceiling use the ceiling material set in the Room Specification dialog. If you require a different 
material on a given roof plane, uncheck Use Room Ceiling Finish in the Roof Plane Specification dialog. See Options 
Panel on page 832.          

To create a vaulted ceiling
 1.  To create a ceiling pitch different from the roof’s, select Build> Roof> Ceiling Plane  and draw ceiling planes. 

See Ceiling Planes on page 841.              

 2.  Select each ceiling plane and specify its pitch. See Ceiling Plane Specification Dialog on page 843.              

TRAY CEILINGS

A tray ceiling is an area within a ceiling that is raised and has either vertical or sloping sides. A variety of different tray and 
coffered ceiling configurations can be created using Tray Ceiling Polylines. See Tray and Coffered Ceilings on page 435.

CANTILEVER UNDERSIDES

Occasionally, a room will cantilever out past an exterior wall. You can specify the surface material of the underside of a 
cantilever on the MATERIALS panel of the Room Specification dialog. For no material, select “No Material” from the Plan 
Materials dialog. See Room Specification Dialog on page 442.
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Room Moldings
Base molding, chair rail, and crown moldings can be applied to rooms on a floor by floor basis in the Floor Defaults 
dialogs, to different room types in the Room Type Defaults dialogs, and to individual rooms in the Room Specification 
dialog. See Floor and Room Defaults on page 418 and Room Specification Dialog on page 442.

By default, Chief Architect does not automatically add room moldings to exterior or hybrid room types. Baseboards and 
chair rails are not automatically added to Open Below rooms, either; however, crown molding is if it is specified in the 
defaults for the room’s floor. See Room Types and Functions on page 420.

Base molding and chair rail heights are both offset from the floor, while crown molding is offset from the ceiling. For 
additional information, see Moldings / Profiles Panels on page 943.

By default, room moldings are suppressed behind cabinets placed against a wall. You can prevent this from occurring by 
checking Suppress Adjacent Room Moldings in the Cabinet Specification dialog. See General Panel on page 653.

Suppress Adjacent Room Moldings is also an option for in the Architectural Block Specification dialog. See General 
Panel on page 1012.

Room Moldings can be suppressed along an individual wall by checking No Room Molding in the Wall Specification 
dialog. See General Panel on page 395.          

Room Moldings can be converted into Molding Polylines that can be selected and edited as independent objects. See Room 
Polylines on page 441.

 

Room Polylines
Polylines for a variety of purposes can be created using the buttons on the Edit Toolbar for a selected room. See Using the 
Edit Tools on page 426.

Once they are created, these polylines are not linked to the room in any way and are not affected if the room is altered.

MAKE ROOM POLYLINE

Click the Make Room Polyline edit button to create a standard CAD polyline on the Current CAD Layer that 
follows the surfaces of the selected room. See Current CAD Layer on page 332.

MAKE STANDARD AREA POLYLINE

Click the Make Standard Area Polyline edit button to create a CAD polyline on the Current CAD Layer that 
follows the extents of the selected room’s Standard Area. See Room Area on page 428. 

MAKE ROOM MOLDING POLYLINE

To create a molding polyline that follows the interior surfaces of a room, select the room and click the Make Room 
Molding Polyline edit button.

If a Room Molding Polyline crosses a door or window, or a cabinet set to not cut room moldings, it will have a separate line 
segment at that location, with No Molding on Selected Edge. No Molding on Selected Edge will also be checked for any 
line segment associated with an Invisible wall or a wall that is set to have No Room Molding. 

Room molding polylines can be edited just like other molding polylines. Their shape and height can be altered and the 
molding profile can be changed. Additional molding profiles can also be assigned. See Molding Polylines on page 951.
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MAKE ROOM MOLDING POLYLINE DIALOG

 l From the Convert Molding drop-down list, select the molding profile that you would like to convert from a room 
molding to a molding polyline. The available options will be the molding profiles assigned to the selected room.

 l Alternatively, select “Blank Molding” from the list to generate a molding polyline that follows the room perimeter and 
has separate edges with “No Molding” where it passes through door and window openings, but has no molding profile 
assigned to it. 

 l Specify the Height of the molding polyline being created, as measured from the selected room’s floor. 

When you convert a base, crown, or chair rail molding to a molding polyline, that molding is removed from the room itself. 
See Moldings Panel on page 452.

MAKE TRAY CEILING IN ROOM

Click the Make Tray Ceiling in Room edit button to create a Tray Ceiling Polyline that follows the shape of the 
selected room. See Tray and Coffered Ceilings on page 435. 

EXPAND ROOM POLYLINE

The Expand Room Polyline edit button is available when you select a room separated from other rooms by invisible 
walls or railings. Select this edit tool to create and select a temporarily enlarged room definition that ignores those 

invisible walls and railings. With this expanded room selected, you can then use one of the room polyline tools, create a 
Revision Cloud, or create a Materials List based on that selection.

To use the Expand Room Polyline tool
 1.  Click in a room defined by at least one invisible wall or railing.

 2.  Click the Expand Room Polyline  edit button.

 3.  Click any of the edit buttons that remain available on the Edit Toolbar. 

Expand Room Polyline does not create a new room and cannot be used in combination with the Auto Room Dimensions 
 edit tool.

 

Room Specification Dialog
The Room Specification dialog controls the structural characteristics and appearance of a selected room. To open the 
Room Specification dialog, select one or more rooms and click the Open Object edit button. See Selecting Rooms on 

page 423. 

Some of the panels in this dialog are also found in the Exterior Room Specification dialog as well as in the Floor, 
Floor/Ceiling Platform, and Room Type Defaults dialogs. See Floor and Room Defaults on page 418. 

The Room Specification dialog has the following panels:          

442



Chief Architect Premier X14 Reference Manual - Room Specification Dialog

Some values in this dialog are dynamic. A value with Default specified references the Floor Defaults dialog. To return a 
value to the default, replace the check mark. See Dynamic Defaults on page 79.         

The settings in this dialog are similar to those in the Floor Defaults dialog, but affect only the selected room See Floor 
Defaults Dialog on page 744.         

If multiple rooms are selected, not all of the settings in this dialog will be available. See Selecting Objects on page 212.          

Many of the settings in this dialog can be included in a Room Finish Schedule. See Schedules and Object Labels on page 
694.          

GENERAL PANEL

The GENERAL panel is also available in the Room Type Defaults dialogs. See Floor and Room Defaults on page 418.           

 
General

Specify the Room Type, the appearance of the Room Label, and how the room appears in the Room Finish Schedule.

 l Select the Room Type from the drop-down list. Changing the Room Type can affect settings throughout the dialog. 
See Room Types and Functions on page 420.    

 l Click the Define button to open the Room Types dialog where you can customize the settings of the selected Room 
Type.    

 l In the Room Type Defaults dialog only, specify the Function of the selected room type. See Room Functions on 
page 421.             

 l If you wish to use a custom name in the room’s label and in Room Schedules, type the desired Room Name in the 
text field. 

 l Check Show Room Label to display the room label in plan view. See Room Labels on page 427.
Show Room Label is unchecked automatically if you select “Unspecified” as the Room Type, and checked 
automatically if you select any other Room Type; however, you can turn this behavior off if you wish in the 
Preferences dialog. See Architectural Panel on page 116.
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Living Area

See Living Area on page 429.         

 l Select Include in Total Living Area Calculation to include the room in the Living Area regardless of its Room 
Type.              

 l Select Exclude from Total Living Area Calculation exclude the room from the Living Area regardless of its Room 
Type.              

 l Select Use Default for Room Type (Included/Excluded) to base the selected room’s inclusion in the Living Area 
on its Room Type. The default for the selected Room Type is stated in parentheses.             

 
Conditioned Room

Conditioned Area totals are included when data is exported to REScheck. See Exported Envelope Data on page 1247.         

 l Select Conditioned to include the room in the Conditioned Area of the structure, regardless of its Room Type.             

 l Select Unconditioned exclude the room from the Conditioned Area, regardless of its Room Type.             

 l Select Use Default for Room Type (Conditioned/Unconditioned) to base the selected room’s inclusion in the 
Living Area on its Room Type. The default for the selected Room Type is stated in parentheses.             

  Options

 l Specify the Roof Group of the selected room. Change this value to control how the program combines the selected 
room’s roof system with that of the rest of the building when automatic roofs are built. This value is nearly always 
left at zero. Not available in the Room Type Defaults dialogs. See Roof Groups on page 807.         

 
Preview

The preview on the right side of this dialog features a cross section diagram showing the relationships between the room’s 
heights and platform thicknesses. 

 l If present, the floors above and below the selected room are also shown. The left side of the floor above is offset for 
clarity.

 l The height and thickness values shown in this diagram are set on the Structure Panel on page 444. 

STRUCTURE PANEL

Some settings on the STRUCTURE panel are also found in the Floor, Floor/Ceiling Platform, and Room Type Defaults 
dialogs. 

In the Floor/Ceiling Platform and Room Type Defaults dialogs, only the Floor and Ceiling settings are available. See Floor 
and Room Defaults on page 418.    
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Active Defaults   icons in the Elevation and Height fields, as well as Default check boxes next to the Structure and Finish 
fields indicate that these settings are Dynamic Defaults. See Dynamic Defaults on page 79. 

Note: Many of the settings on this panel are interdependent. For example, 
if the Ceiling Structure thickness is modified, the Absolute Ceiling and 
Rough Ceiling heights will change in response. 
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Absolute Elevations

These height values are measured from zero, which is the default top height of the subflooring on Floor 1. See Floor and 
Ceiling Heights on page 431.     

 l The Floor Above height displays here for reference. If multiple rooms with differing floor heights exist directly 
above, “No Change” will display.     

 l Specify the Ceiling height of the selected room, as measured from zero to the bottom of the ceiling framing. Not 
available in the Room or Floor Defaults dialog or if multiple floor heights are specified above the selected room.     

 l Specify the Floor height, as measured from zero to the top of the subfloor.

Note: The default floor height for Floor 1 is 0. It can be modified in the Room Specification dialog, but not in the Floor 
1 Defaults dialog. See Floor and Room Defaults on page 418.    

 l If a room is defined directly beneath the selected room on the floor below, additional settings may be available.    

 l Specify the Floor Below height, which is the subfloor height of the room directly below where you clicked to select 
the currently selected room. If there are multiple rooms with differing floor heights located below, this value may 
change depending on where you click.    

 l If the selected room is directly above a Garage and there is a foundation present, you can specify the SWT Below 
height, which is the top height of the concrete stem walls around the perimeter of the garage. 

 
Relative Heights

These height values are measured from surfaces within the selected room or the room below.    

 l Specify the Rough Ceiling height, as measured from the subfloor surface to the bottom of the ceiling framing. Not 
available if multiple floor heights are specified directly above the selected room.    

 l Specify the Finished Ceiling height, as measured from the finished floor surface to the finished ceiling surface. Not 
available if multiple floor heights are specified directly above the selected room.    

 l Specify the distance from the Stem Wall Top to Ceiling. Only available when Floor for this Room is Supplied by 
the Foundation ‘Room’ from the Floor Below is checked, below.    

 l Specify the Floor to Stem Wall Top for rooms with Floor for this Room is Supplied by the Foundation ‘Room’ 
from the Floor Below specified.    

 l Specify the Ceiling Below height, which is the height of the ceiling of the room below, as measured from that 
room’s subfloor to rough ceiling surfaces. Not available when Auto Rebuild Foundation is enabled or if there is no 
room below the selected room. See Rebuilding Foundations on page 725.    

 l Specify the Stem Wall height, which is measured from the top of the foundation wall footing to the top of the 
treated sill plate, if one is specified. Only available if the selected room or the room below it is defined by 
foundation walls.
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Ceiling

Only the Ceiling Finish and Structure settings are available in the Room Type Defaults dialogs.

 l If Roof Over This Room is checked, a roof automatically generates over the room. If unchecked, no automatic roof 
generates.

If this option is unchecked and a roof plane is manually drawn over this room, its structure will be that of an eave 
rather than a regular roof. In most cases, if a roof is present over a room, this box should be checked. See Roof Panel 
on page 884.

 l If Flat Ceiling Over This Room is checked, the room has a flat ceiling. If unchecked, the ceiling follows the 
underside of the roof or manually drawn ceiling planes.

 l Check Shelf Ceiling to prevent Attic Walls from generating over the interior walls that define the selected room. 
When unchecked, interior Attic Walls will generate if surrounding rooms have higher ceilings than the selected 
room. See Shelf Ceilings on page 433.

 l Check Use Soffit Surface for Ceiling to frame the roof over the selected room using the framing defaults for fascia 
rather than for rafters.             

 l The Ceiling Structure depth displays here for reference. Click the Edit button to open the Ceiling Structure 
Definition dialog and define the layers of materials that form the ceiling platform. Check Default to use the Ceiling 
Structure Definition set in the current floor’s Floor Defaults dialog. Not available for rooms on Floor 0. See Material 
Layers Definition Dialogs on page 1040.             

 l The Ceiling Finish depth displays here for reference. Click the Edit button to open the Ceiling Finish Definition 
dialog and define the layers of materials that form the finished ceiling surface. Check Default to use the Ceiling 
Finish              Definition set in the current floor’s Floor Defaults dialog. See Material Layers Definition Dialogs on page 
1040.             

 l Check the Default box to the right of either button to restore the default structure and/or finish. See Floor/Ceiling 
Platform Defaults on page 419.             
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Floor

Only the Floor Finish, Structure, and On Structure Resize settings are available in the Room Type Defaults dialogs.         

 l When Floor Under This Room is checked, the room has a floor platform as specified below.             

 l If Floor Supplied by the Foundation Room Below is checked, the floor platform for this room is a slab located on 
the floor below and cannot be edited here.             

 l If Monolithic Slab Foundation is checked, the current Floor Structure will be replaced by a single 4” (100 mm) 
layer of concrete with footings that can be seen in camera views only. When a stem wall or grade beam foundation is 
generated, a slab will be created beneath the selected room.             

If the selected room has a living space located anywhere 
beneath it, avoid checking Monolithic Slab Foundation.

 l Check Retain Floor/Ceiling Framing to preserve the selected room’s floor and ceiling framing when floor and/or 
ceiling framing is globally rebuilt. See Rebuilding and Retaining Framing on page 868.             

 l When Monolithic Slab Foundation is checked, specify the room’s Slab Pour Number. Pour Numbers are listed 
separately in the Materials List. See In the Materials List on page 725.             

 l When Monolithic Slab Foundation is unchecked, specify the selected room’s Framing Group instead. See Framing 
Groups on page 865.             

 l The Floor Finish depth displays here for reference. Click the Edit button to open the Floor Finish Definition dialog 
and define the layers of materials that form the finished floor surface. Check Default to use the Floor Finish 
Definition set in the current floor’s Floor Defaults dialog. See Material Layers Definition Dialogs on page 1040.             

 l Specify which part of the floor platform moves On Structure Resize. Select Lock Floor Top to keep the top of the 
floor structure at the same height and raise or lower its bottom when the platform depth is changed. Select Lock 
Floor Bottom to keep the bottom of the floor structure at the same height and raise or lower the top when the depth 
is changed.             

 l The Floor Structure depth displays here for reference. Click the Edit button to open the Floor Structure Definition 
dialog and define the layers of materials that form the floor platform. Check Default to use the Floor Structure 
Definition set in the current floor level’s Floor Defaults dialog. See Material Layers Definition Dialogs on page 
1040.             

 l If the selected room is a Deck, the Floor Structure button will be labeled Planks, Joists instead. See Decks on page 
430.             

 l Check the Default box to the right of either button to restore the default structure and/or finish. See Floor/Ceiling 
Platform Defaults on page 419.             

Note: The default floor and ceiling platform and finish definitions for 
rooms are set in the current floor’s Floor Defaults dialog. In the Floor 
Defaults dialog, the defaults are drawn from the Floor/Ceiling Platform 
Defaults dialog. See Floor and Room Defaults on page 418.
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Preview

The preview on the right side of this dialog features a cross section diagram showing the relationships between the room’s 
heights and platform thicknesses. 

 l If present, the floors above and below the selected room are also shown. The left side of the floor above is offset for 
clarity.

 l The callout or dimension line associated with selected height or thickness value will be highlighted in the preview, 
as will any height or thickness value that you move your mouse point over. 

 l The font used by the callouts and dimensions is set in the               currently active Dimension Defaults dialog, while the unit 
of measurement is specified in the Dialog Number/Angle Style dialog. See Dimension Defaults Dialog on page 457 
and Dialog Number/Angle Style Dialog on page 131.             

 l What appears in both the diagram and in the settings on the STRUCTURE panel may be affected by the location where 
you clicked to select the room. For example:

 l If the selected room is located above two rooms with different structural settings, the position of the pointer relative 
to these two lower rooms determines which of them displays as the floor below.

 l If the selected room is located below two rooms with different floor heights, its absolute and relative ceiling height 
settings will be disabled. 

DECK PANEL

The options on the DECK panel are only available for rooms designated as Decks, and control how deck planking and joists 
are generated. See Deck Framing and Planking on page 431.

The settings on this panel are also found in the Deck Room Defaults dialog, but affect the selected Deck room(s) only rather 
than Decks as they are initially created. See Room Type Defaults on page 419.          
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  Automatic Deck Framing

 l Check Automatic Deck Framing to generate planking and support framing for the deck that updates as changes are 
made to the deck. See Decks on page 430.

 l Check Keep Deck Framing After Deck Room is Deleted to retain the automatically generated framing and 
planking when the selected deck room is deleted. When this box is unchecked, the framing is automatically removed 
if the room is deleted.           

  Deck Planking

 l Specify how far the deck planking Overhangs the rim joists.         

 l Specify the Plank Width of the deck planking. 

 l Check Max Plank Length, then specify the maximum allowable length for the selected Deck's planks. When 
unchecked, planks run the full length of the Deck room.

 l Specify the Plank Gap Width, which is the distance between individual planks.         

 l If you want to enter a Plank Direction, remove the check mark from Automatic. Enter the direction as degrees.         

 l Specify the Number of Border Planks. These are planks that follow the outside edge of the deck and may not be 
parallel with the rest of the planking. Border planks generate as long as the length of an inside edge is greater than 
0”. They do not generate on curved deck edges.         

Note: Planking thickness and joist depth are specified in the Floor 
Structure Definition dialog. See Floor and Ceiling Platform 
Definitions on page 434.      

 l Check No Border Against Walls to prevent border planking from being generated along any walls defining the 
deck.             

 l Check Herringbone to produce a herringbone pattern where the border planks meet.             

 l Check Treated to specify that the deck planking is counted as treated in               framing schedules and the Materials List.             

  Deck Joists

 l Enter the Width of the joists that support the deck.             

 l Specify the Spacing between joists, as measured from joist center to joist center.             

 l If you want to specify joist Direction, uncheck Automatic and enter the direction in degrees. When checked, joists 
are run in the direction that results in the shortest spans.             

 l Check Treated to specify that the deck joists are counted as treated in framing schedules and the Materials List.             

 
Preview

The preview on the right side of this dialog features a cross section diagram showing the relationships between the room’s 
heights and platform thicknesses.         

 l If present, the floors above and below the selected room are also shown. The left side of the floor above is offset for 
clarity.         

 l The height and thickness values shown in this diagram are set on the Structure Panel on page 444.         
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DECK SUPPORT PANEL

The options on the DECK SUPPORT panel are only available for Deck rooms and control how deck beams and posts are 
generated. See Deck Framing and Planking on page 431.          

The settings on this panel are also found in the Deck Room Defaults dialog, but affect the selected Deck room(s) only rather 
than Decks as they are initially created. See Room Type Defaults on page 419.          

 
Deck Beams

Specify the configuration of the beams under the selected Deck room.                     

 l Uncheck Deck Beams to prevent the automatic generation of support beams under the selected Deck room.             

 l Click the Edit Beam button to open the Deck Beam Defaults dialog and define the beam size and other 
characteristics. See Framing Specification Dialog on page 902.             

 l Specify the maximum on-center Beam Spacing. Beams may be positioned closer than this value, but not further 
apart.             

 
Deck Posts

Specify the configuration of the posts under the selected Deck room.    

 l Uncheck Deck Posts to prevent the automatic generation of support posts under the selected Deck room.    

 l Click the Edit Post button to open the Deck Post Defaults dialog and define the size and other characteristics of the 
posts associated with the selected Deck. See Framing Specification Dialog on page 902.    

 l Specify the maximum Post Spacing. Posts may be positioned closer together than this value, but not further apart.    

 l Specify the Offset from End, which is the distance from the outermost beam to the edge of the deck platform. For 
railings directly over the outside of the beam, set this value to 0.    
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Deck Post Footings

These settings are not available if Deck Posts is unchecked, above.         

 l Uncheck Deck Post Footings to prevent the automatic generation of footings under the selected Deck room’s posts.             

 l Specify the footings’ Height Above Terrain. See Foundations and the Terrain on page 730.             

 l Specify the footings’ Thickness and Width.             

 l Specify whether the footings are Square or Round in shape.             

 l Specify the Rebar Size Number.             

 l Specify the Rebar Count, or number of bars in each footing.             

 
Preview

The preview on the right side of this dialog features a cross section diagram showing the relationships between the room’s 
heights and platform thicknesses.         

 l If present, the floors above and below the selected room are also shown. The left side of the floor above is offset for 
clarity.          

 l The height and thickness values shown in this diagram are set on the Structure Panel on page 444.         

MOLDINGS PANEL

Chair rail, crown and base moldings can be assigned to one or more selected rooms on the MOLDINGS panel. Moldings are 
placed on a room’s wall surfaces and continue around the surface of any soffit that is attached to the wall at the molding 
height.         

The settings on this panel are also similar to those found in the Floor Defaults dialog, but affect only the selected room 
instead of all rooms on the current floor.          

The settings on this panel are similar to those found in other specification dialogs throughout the program. See Moldings / 
Profiles Panels on page 943.         

WALL COVERING PANEL

The settings on the WALL COVERING panel of the Room Specification dialog are the same as those on the same panel of the 
Wall Specification dialog. When a wall covering is assigned in the Room Specification dialog, it is applied to all walls in 
the selected room only. See Wall Covering Panel on page 409.         

FILL STYLE PANEL

The settings on the FILL STYLE panel affect the appearance of the room in plan view.  This panel is also found in the Floor 
Defaults dialog. For more information, see Fill Styles on page 197.

MATERIALS PANEL

The settings on this panel affect the appearance of a selected room’s walls, floor, ceiling, and moldings in 3D views. See 
Materials Panel on page 1055. 

The materials that make up the floor and ceiling platforms can be defined on the STRUCTURE panel. See Structure Panel on 
page 444.          
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Default molding and ceiling and floor covering materials can be set on this panel in the Floor Defaults and Room Defaults 
dialogs.         

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 1335.          

SCHEDULE PANEL

The settings on the SCHEDULE panel determine which schedule categories the selected room is included in. See Schedule 
Panel on page 716.          

 

Room Finish Schedules
The Room Finish Schedule tool allows you to produce customizable room finish schedules with information about 
room size, structure, materials and moldings. Information about door and window trim can also be included. See The 

Schedule Tools on page 695. 

By default, Room Finish Schedules are set to include all Room Types: including any new Room Types that you may create. 
You can specify which Room Types are included in a Room Finish Schedule in its Schedule Specification dialog. See 
General Panel on page 705.

Additional information about tray ceiling moldings and door and window trim can be included in any schedule set up to 
include items in the Molding category.

You can also create any type of schedule that lists the contents of a selected room using the Create Schedule from 
Room edit tool. See Create Schedule from Room on page 696. 
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Chapter 13
 

Dimensions

Chief Architect provides a variety of manual and automatic dimensioning tools for measuring walls, doors, windows, and 
many other objects in various 2D and 3D views. 

Dimensions can be used to accurately position objects relative to other objects. In addition, dimension lines and extensions 
can be selected and customized. 

TOPICS

Compatibility With Previous Versions 455
Dimension Preferences and Defaults 455
Dimension Defaults Dialog 457
Auto Story Pole Dimension Defaults Dialog 471
Temporary Dimension Defaults Dialog 475
The Manually Drawn Dimension Tools 477
The Automatic Dimension Tools 480
Displaying Dimension Lines 482
Selecting Dimension Lines 483
Editing Dimension Lines 484
Editing Extension Lines 486
Add Additional Text 490
Moving Objects Using Dimensions 491
Dimension Line Specification Dialog 493
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Compatibility With Previous Versions
Dimensions function differently in Versions 9 and later of Chief Architect than they did in              previous versions. Being 
familiar with these changes is helpful if you have plans that were originally created in these legacy program versions.         

EXTENSION LINES

In Chief Architect 8, extension lines had two modes: normal and short. Version 9 and later offer full control over extension 
lines. If Legacy Compatible Extensions is checked, you do not have this control. See Extensions Panel on page 468.         

ACCURACY

When the model is drawn with greater accuracy than dimensions are set to display, rounding may be required. The 
Rounding Method in the Dimension Defaults dialog controls how Chief Architect handles dimensions that require 
rounding. See General Panel on page 457.          

In Chief Architect Version 8 and prior, dimensions used Distance Rounding, which shows the distance between equally 
spaced objects correctly, but dimension runs are not always accurate when added.          

In Versions               9 and later, dimensions use Grid Rounding, which always add up dimension runs correctly, but individual 
distances may be inaccurate in order to achieve this.          

Dimensioning the same object using these two rounding methods will obtain the same results as long as  objects are placed 
with the same accuracy as the precision of the dimension lines. If an object is placed using more precision than the 
dimensions, results may vary between methods.          

A good approach to accurate dimensioning is to turn on the 
accuracy indicators and position objects so that the inaccuracy 

indicators do not display. 

 

Dimension Preferences and Defaults
There are a number of defaults settings as well as options in the Preferences dialog that affect dimensions.           
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PREFERENCES

All plan and layout files save measurements in either U.S. or metric units. The type of unit used is determined when 
the file is first created and cannot be changed later. See Creating a New Plan or Layout on page 38.

You can specify either metric files or those using U.S. Units to be used as the templates whenever you open a new, blank 
plan or layout file in the Preferences dialog. See New Plans Panel on page 113.           

You can also specify the minimum on-screen display size for dimension numbers in the Preferences dialog. See Appearance 
Panel on page 99.         

DEFAULT SETTINGS

Select Edit> Default Settings to open the Default Settings dialog, then click the arrow next to "Dimension" to 
expand the category.

The Dimension Defaults dialogs can also be accessed by double-clicking the Dimension Tools  parent button or the 

Automatic Dimension Tools  parent button.

There are three dimension defaults dialogs:

 l Dimension Defaults Dialog on page 457
 l Auto Story Pole Dimension Defaults Dialog on page 471
 l Temporary Dimension Defaults Dialog on page 475

When Angle Snaps  are enabled, dimensions can be drawn at the Allowed Angles set in the General Plan Defaults 

dialog. Regardless of their angles, however, dimensions will only locate objects that are parallel to one another. See General 
Plan Defaults Dialog on page 96.

When a Marker is created in association with a manually drawn dimension or Auto Elevation Dimension, the Marker will 
inherit its initial settings from the currently active Saved Marker Defaults. See Markers on page 538.

SAVED DIMENSION DEFAULTS

Dimensions are an example of objects that use Multiple Saved Defaults. This lets you set dimensions up for more than one 
task or requirement in advance, and then simply specify which default you want to use as the Active Default at any given 
time. See Multiple Saved Defaults on page 79.         

A Saved Dimension Default can be activated in any view that supports dimensions: plan view, cross section/elevation views, 
CAD Details, and Wall Details. A Saved Dimension Default can be activated in any of five ways:         

 l Select a default from the Active Dimension Defaults Control   Default  drop-down, which can be added to the 
toolbars. See To add a button to a toolbar on page 137.         

 l Select a Currently Active Dimension Defaults in the Active Defaults dialog. See Active Defaults Dialog on page 82.         
 l Select a default in the Saved Dimension Defaults dialog. See              Saved Defaults Dialog on page 80.         
 l Open a saved view in which dimensions are supported. See Saved Views on page 149.         
 l Select a Default Set. See Default Sets on page 83.         
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Dimension Defaults Dialog
Select Edit> Default Settings, expand the “Dimension” category, select “Dimensions”, and click the Edit button to 
open the Dimension Defaults dialog.         

You can also double-click either the Dimension Tools  or Automatic Dimension Tools  parent button to open this 

dialog.

The Manually drawn dimension tools support multiple Saved Defaults for specific drawing tasks.  See Multiple Saved 
Defaults on page 79.         

 l When you access the Dimension Defaults dialog via the Default Settings dialog, the Saved Defaults dialog will open 
first, allowing you to select which Saved Manual Dimension Default that you wish to edit. Multiple Defaults can be 
selected and edited if you wish. See Shift and Ctrl Select on page 217.         

 l When you access this dialog by double-clicking the Dimension Tools  button, the defaults dialog for the currently 

active Saved Default is opened directly. If you would like the Saved Defaults dialog to open first in this situation, you 
can enable this option in the Preferences dialog. See General Panel on page 107.         

 l In either case, the name of the Saved Default being edited will display in the title bar at the top of the dialog box.         

The settings in this dialog are dynamic defaults, which means that any changes made here may affect existing dimension 
lines in the drawing that are using the Saved Manual Dimension Default being edited. See Dynamic Defaults on page 79.

In addition, you can specify how Temporary Dimensions locate walls and CAD objects in the Temporary Dimension 
Defaults dialog. See Temporary Dimension Defaults Dialog on page 475.         

GENERAL PANEL
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  General

 l Specify the Line Separation, which is the distance between Baseline Dimension lines in plan inches (mm). This 
value should always be greater than the Character Height. If two formats are used, it should be at least twice the 
Character Height. See Text Style Panel on page 471.

 l Specify how far manually drawn dimension lines Reach to locate walls and/or objects specified on the LOCATE 
panels. The default is 24” (450 mm) in plan files and 1” (10 mm) in layout. See Locate Manual Panel on page 
460.          

 
Rounded Value Indicators

Rounded Value Indicators can display when the degree of accuracy in use is not sufficient to describe a dimension’s true 
value.         

 l Check + or - After Number to indicate that the actual dimension value is higher or lower than the value shown.         

 l Check ~ Before Number to indicate dimension values that are not accurate with the ~ symbol.         

  Rounding Method

 l Grid Rounding ensures that the sum of the parts of a dimension line add up to the whole distance. To produce this 
result, some sections may not be rounded accurately. This is the recommended rounding method and is selected by 
default.         

 l Distance Rounding addresses each section of a dimension line individually, which could result in the sum of these 
sections not being equal to the whole. This option is available for legacy purposes only and is not recommended. 
See Compatibility With Previous Versions on page 455.         

To avoid the appearance of inaccuracy that rounding may 
cause, draw with Grid Snaps enabled and place objects in 

your plan using the same accuracy as your dimensions. See Grid 
Snaps on page 167. 

 
Dimension Text Position and Orientation

Specify the location and angle of dimension numbers relative to the dimension line.    

 l Centered on Dimension Line centers the primary dimension numbers on the dimension line. If two formats are 
used, the primary format is placed above the line and the secondary format, beneath it.    

 l Position dimension numbers Above Dimension Line.    

 l Position dimension numbers Below Dimension Line.    

 l If you would like to specify a specific angle for dimension label text, uncheck Automatic. Then, type the desired 
Angle, in degrees, in the text field.

 
Preview

A preview of the selected dimension line displays on the right side of the panel. This preview shows a summary of the 
dimension line's general style attributes rather than its actual appearance. See Dialog Preview Panes on page 22. 

SETUP AUTOMATIC PANEL

The settings on the SETUP AUTOMATIC panel affect how   automatically generated dimensions are created. See The 
Automatic Dimension Tools on page 480. 
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  General

 l Specify the Line Separation, which is the distance between Auto Exterior Dimension lines in plan inches (mm). 
This value should always be greater than the Character Height used by the label. If two formats are used, it should be 
at least twice the Character Height. See Dimension Labels on page 482.   

 l Specify the 1st Line Offset, which is the distance between each wall and the nearest Automatic Dimension line that 
measures its length in plan inches (mm).   

 
Exterior

These settings control how Auto Exterior Dimensions generate.    

 l Specify how far Auto Exterior Dimensions Reach to locate objects set back from exterior walls. If exterior walls are 
set back further than this distance, additional dimension lines are produced to locate the set-back walls.    

 l Specify the Minimum Area, which is the minimum area defined as a room needed for Auto Exterior Dimensions to 
generate.    

 l When Overall Dimension is checked, a dimension line reporting the overall length of each side of the structure is 
created.

 l When Inner Dimension is checked, up to three rows of Auto Exterior Dimensions per exterior wall are generated. 
Uncheck this box to suppress these inner dimension strings.     

 l Check Auto Refresh to delete and replace Auto Exterior Dimensions whenever a change is made to the model that 
affects them.    

459



Chief Architect Premier X14 Reference Manual - Dimension Defaults Dialog

 
Room

These settings control how Auto Room Dimensions generate.    

 l Specify the Minimum Area, which is the minimum area defined as a room needed for Auto Room Dimensions to 
generate.    

 l When Overall Dimension is checked and a room's Auto Room Dimensions locate objects in addition to its walls, an 
overall dimension for each wall is also generated.

 l Check Outer Dimension to generate an outer dimension that locates objects as specified on the LOCATE ROOM 
panel.

 l Check Auto Refresh to delete and replace Room Dimensions whenever a change is made to the model that affects 
them.

 l Check Allow Duplicates to generate a full set of dimensions along each wall, potentially creating duplicate overall 
dimensions.

 l Specify the Line Position: select Outside Room to generate Room Dimensions outside the selected room, or select 
Inside Room to generate them inside the room.   

 
Elevation

These settings control how Auto Elevation Dimensions generate in cross section/elevation views.

 l When Overall Dimension is checked, an overall dimension is created outside each Auto Elevation Dimension string.

 l Check Outer Dimension (Top/Bottom) to generate an outer dimensions that locate the marks specified on the 
LOCATE ELEVATIONS panel.

 l Check Auto Refresh to delete and replace dimensions created by the Auto Elevation Dimensions tool whenever a 
change is made to the model that affects them.     

 l Dimension on/Across - Check any of these boxes to generate a dimension string on the Left, Right, across the Top, 
and/or across the Bottom of the model.      

LOCATE MANUAL PANEL

The settings on the MANUAL panel specify how and whether or not Manual Dimensions , Baseline Dimensions , 

and Running Dimensions  locate specific types of objects.    

Similar settings are also found on other panels in this dialog, on the LOCATE OBJECTS panel of the Auto Story Pole 
Dimension Defaults dialog and in the Temporary Dimension Defaults dialogs.

Changes made on this panel only affect new dimension lines as they are drawn, not those already drawn. Once created, a 
dimension line's extensions can be edited so that they locate objects in ways not specified here. See Editing Extension Lines 
on page 486.
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In the Dimension Defaults dialog for a layout file, only the CAD Objects settings on this panel is available.   

 
Walls

Specify the marked location in wall assemblies referred to by Extension Lines as well as the Reach and 1st Line Offset 
settings. See The Dimension Layer on page 389.             

 l Select Surfaces to locate exterior and interior walls at their surfaces.   

 l Select Wall Dimension Layer to locate walls at their Dimension Layer. A wall’s Dimension Layer is specified in its 
wall type. See Wall Type Definitions Dialog on page 390.   

 l Select None to prevent Manual and Baseline Dimensions from locating walls. Also available for End to End and 
Centerline dimensions.
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Wall Options

These settings control how or whether exterior and interior walls are located by Manual  and Baseline Dimensions. See 
Exterior and Interior Walls on page 355 and Primary and Secondary Sides on page 370.           

 l Specify how Exterior walls are located:     

 o Check Primary Side to have dimensions locate the exterior side of exterior walls.     

 o Check Secondary Side to have dimensions locate the interior side of exterior walls.     

 o When neither box is checked, exterior walls are not located by Manual  and Baseline Dimensions.

 l Specify how Interior walls are located:     

 o Check Primary Side to have dimensions locate the interior side of interior walls.     

 o Check Secondary Side to have dimensions locate the exterior side of interior walls.     

 o Check Centers to have dimensions locate the centers of interior walls.     

 o When neither box is checked, interior walls are not located by Manual  and Baseline Dimensions.

 l Check Wall Steps to have dimensions locate steps in walls in elevation views. Steps in foundation walls in plan 
views are also located. See Stepped Walls and Footings on page 384.    

 l When Display Wall Widths is checked, the thicknesses of any walls that a dimension line crosses will be measured. 
Uncheck this box to suppress the segments dimension line segments that report these measurements.

Note: Walls specified as No Locate will not be located by some 
dimension tools. See No Locate on page 371.     

  Locate Objects

 l Each category corresponds to a type of object in Chief Architect. Under each category are locations, or marks, on 
these objects that dimensions can locate.

 l Check the box beside an option to have dimension lines locate that mark on objects of that type as they are drawn or 
generated.   

 l Uncheck the box beside a category to not locate objects in that category: any checked boxes in that category remain 
checked, but disabled. Check the box beside a category to locate the selected marks on objects of that type.

 l On the LOCATE AUTO ROOM and LOCATE AUTO ELEVATION panels only, there are two scrollable lists: Outer 
Dimension and Inner Dimension. Check Outer Dimension to generate a second dimension line further from the 
marked objects than the Inner Dimension, as well as specify the marks that it locates. Not available for other 
dimension types.   

 Cabinets

 Cabinets can be moved and resized in plan and cross section/elevation views. See Using 
Dimensions on page 646.

Sides The sides do not have to be perpendicular to the dimension line

Corners Angled cabinets are dimensioned to their corners at a right angle to the dimension line. A 
cabinet’s front or sides do not need to be perpendicular or parallel to the dimension line for its 
corners to be located.

462



Chief Architect Premier X14 Reference Manual - Dimension Defaults Dialog

Centers A cabinet’s front or sides do not need to be perpendicular or parallel to the dimension line for its 
center to be located.

Moldings In elevation views only, locate the tops and bottoms of cabinet moldings.

Countertop In plan view, a cabinet’s front or sides must be perpendicular or parallel to the dimension line for 
its countertop to be located. In elevation views, only the top and bottom edges can be located 
when the dimension is being drawn.

Backsplash In elevation views only, locate the tops and bottoms of backsplash edges.

Toe Kick In elevation views only, locate the tops and bottoms of toe kicks.

 Fixtures/Appliances

 These options affect how dimension lines locate appliances and other fixtures such as hardware, 
millwork, sprinklers, and Geometric Shapes. In cross section/elevation views, dimensions can 
only locate furniture at points where a surface is present.

Sides/Corners For sides to be located, they must be perpendicular to the dimension line

Centers An object’s front or sides do not need to be perpendicular or parallel to the dimension line for its 
center to be located.

 Furniture

 These options affect how dimension lines locate furniture and furnishing accessories. See Stand-
Alone Objects on page 980.

Sides/Corners For sides to be located, they must be perpendicular to the dimension line.

Centers An object’s front or sides do not need to be perpendicular or parallel to the dimension line for its 
center to be located.

 Openings

 Specify how dimensions locate doors and windows. Openings in walls specified as No Locate 
will not be located by Auto Exterior Dimensions. See Doors on page 551, Windows on page 584, 
and No Locate on page 371.

Casing Locate the outer edges of both sides of wall openings’ casing. Because interior and exterior 
casing often have different widths, an opening may have different interior and exterior 
dimensions when this option is selected.

Centers Locate the centers of wall openings.

Rough Opening Locate both sides of the rough opening of doors and windows.

Sides Locate the both sides of wall openings. This option locates the nominal width - not the rough 
opening.

 CAD Objects

 These options control how dimension lines locate 2D CAD objects as well as CAD-based objects 
such as slabs and stairs. See CAD Objects on page 294.

Line/Sides For a line/side to be located, it must be perpendicular to the dimension line.

Ends/Corners Locate all ends/corners of polylines, no matter what angle they are in relation to the dimension 
line.

Callouts/Markers See Callouts on page 530 and Markers on page 538.

Clip Lines See Side Clipping on page 1094.
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Text See The Text Tools on page 505.

Construction Lines See Construction Lines on page 65.

 Primitives/3D Solids

 All Primitive objects can be moved using dimensions. 3D Solids, Pyramids, and Faces can also 
be resized. See Primitive Tools on page 1016.

Sides The sides must be perpendicular to the dimension line.

Corners Locate the corners of all primitive/solid objects within the Reach area. Corners are dimensioned 
at a right angle to the dimension line. An object’s front or sides do not need to be perpendicular 
or parallel to the dimension line for its corners to be located.

Centers Locate the centers of all primitive/solid objects within the Reach area. An object’s front or sides 
do not need to be perpendicular or parallel to the dimension line for its center to be located.

 Framing

 See Using Dimensions on page 898.

Sides Locate both sides of framing objects.

Centers Locate the centers of framing objects.

 Other Objects

 Electrical and image objects can be moved using dimensions, but not resized.

Electrical See Using Dimensions on page 686.

Plants and Images See Using Dimensions on page 1184.

LOCATE END TO END PANEL

The settings on the LOCATE END TO END panel are the same as those on the LOCATE MANUAL panel, but control how 
objects are located when an End to End Dimension  or Point to Point Dimension  is drawn. See End-to-End 

Dimensions on page 478 and Locate Manual Panel on page 460.   

LOCATE CENTERLINE PANEL

The settings on the LOCATE CENTERLINE panel are the same as those on the LOCATE MANUAL panel, but control how 
objects are located when a Centerline Dimension  is drawn. See Centerline Dimensions on page 479 and Locate 

Manual Panel on page 460. 

LOCATE INTERIOR PANEL

The settings on the LOCATE INTERIOR panel are also found on the LOCATE MANUAL panel, but control how objects are 
located when an Interior Dimension  is drawn. See Interior Dimensions on page 478 and Locate Manual Panel on page 

460. 

LOCATE AUTO EXTERIOR PANEL

The settings on the LOCATE AUTO EXTERIOR panel are also found on the LOCATE MANUAL panel, but control how objects 
are located when Auto Exterior Dimensions  are generated. See Auto Exterior Dimensions on page 481 and Locate 

Manual Panel on page 460.   
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LOCATE AUTO ROOM PANEL

The settings on the LOCATE AUTO ROOM panel are also found on the LOCATE MANUAL panel, but control how objects are 
located when Auto Room Dimensions  are generated. See Auto Room Dimensions on page 481 and Locate Manual 

Panel on page 460.   

LOCATE AUTO ELEVATION PANEL

The settings on the LOCATE AUTO ELEVATION panel are also found on the LOCATE MANUAL panel, but control how objects 
are located when Auto Elevation Dimensions  are generated. See Auto Elevation Dimensions on page 481 and Locate 

Manual Panel on page 460.   

LOCATE ELEVATIONS PANEL

The settings on the LOCATE ELEVATIONS panel determine what elevation marks are located by vertically oriented, manually 
drawn dimension lines in cross section/elevation views. This panel is also found in the Auto Story Pole Dimension Defaults 
dialog. See Locate Elevations Panel on page 473.   

PRIMARY FORMAT PANEL

The settings on the PRIMARY FORMAT panel allow you to specify the units, position, and degree of accuracy of dimension 
numbers. The settings on this panel also control the format of object length numbers in the Status Bar. See The Status Bar 
on page 25. 

These settings are the same as those on the  PRIMARY FORMAT  panel of the Dimension Line Specification dialog and the 
DIMENSION FORMAT panel of the Room Label Defaults dialog. See Dimension Line Specification Dialog on page 493 and 
Room Label Defaults on page 420. 

These settings are also similar to those on the INNER, OUTER, and MARKER FORMAT panels of the Auto Story Pole 
Dimension Defaults and Dimension Line Specification dialogs. See Auto Story Pole Dimension Defaults Dialog on page 
471.         

In addition to these Primary dimension numbers, you can display a set of Secondary dimension numbers that indicate the 
dimension’s length using different units, degree of accuracy, and location. See Secondary Format Panel on page 468.         
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In the Auto Story Pole Dimension Defaults and Specification dialogs only, check Use Default Formatting to use the 
Primary Format settings of the currently active Dimension Defaults as the Inner Format.         
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Format

Specify the numbering Format for dimension numbers.             

 l Select the Units of measurement to be used by dimensions from the drop-down list. The choices in this list 
correspond to all units measuring length specified in the Preferences dialog. See Unit Conversions Panel on page 
113.

Note: Although you can select U.S. or metric units in any plan or 
layout, it is best to use the same unit type that the file uses to save 
measurements. See Units of Measurement on page 38.

 l Check Unit Indicators to display the unit of measurement along with the dimension number.

 l Check Leading Zeros to include the zero before a decimal less than 1 or to display  0’ or 0” when the ft-in or ’-” unit 
formats is used. 

 l Check Trailing Zeros to display trailing zeros at the end of decimal values. When the ft-in or ’-” unit format is used 
and fractional inches are specified, 0” will be included. 

 o Check Thousands Separator to use a digit grouping symbol for values greater than 999.         

 o Select the Use Comma, Use Dot, or Use Non-Breaking Space radio button to specify the thousands separator used 
by dimensions. Which option is available will depend on your operating system settings. See Region and Language 
Settings on page 78.         

 l Select the Use Space radio button to use a space as the thousands separator.   

 l Check Display as Inches to display the dimension number of sufficiently short segments in inches rather than the 
Unit selected above. This option is only available when the specified Unit is a form of either feet or yards, or a 
format that includes feet.   

 l The Less than or equal to value specifies how short a segment must be before its number uses inches rather than 
the specified Unit.   

 l Select a Fraction Style from the drop-down list. This option affects the angle of the fraction's vinculum line and is 
also applied to the Secondary Format if one is used. See Secondary Format Panel on page 468, below.   

 l Specify the desired Fraction Text Size as a percentage of a selected dimension line's Number Height. Only available 
when either "Diagonal" or "Vertical" are selected as the Fraction Style.
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Accuracy

Specify the degree of accuracy used by dimension numbers.             

 l Select the Decimal Places radio button for dimension numbers in decimal format. In the text field, specify the 
number of decimal places to use, from 0 to 20. If 0 is used, no decimal places are used.    

 l Select the Smallest Fraction radio button for dimension numbers using whole numbers and fractions. In the text 
field, specify the largest denominator to use, from 1 to 128. If 1 is entered, whole numbers are used.    

 l Uncheck Show Denominator to turn off the display of fraction denominators used by dimension lines. Typically, 
denominators are only turned off when eighths are desired.          

 l Uncheck Reduce Fractions to always use the denominator specified above. When checked, the lowest possible 
denominator will be used. When Smallest Fraction is selected, specify how fractions are reduced:         

 o Select Use Greatest Common Divisor to reduce fractions using the largest value that divides equally into the 
numerator and the denominator specified above. This option is best for fractional inches.         

 o Select Use Closest Fraction to reduce fractions without referring to the denominator specified above. Should only 
be used with Distance Rounding. Not recommended when fractional inches are used.         

A value of 0.33333 is represented by the fraction 5/16 when Greatest Common Divisor is used and the Smallest Fraction 
denominator is 16. When Closest Fraction is selected, this value is represented by 1/3.         

 
Angular Format

Specify format used by Angular Dimensions. See Angular Dimensions on page 478.     

 l Select an Angle Style. For a description of each, see Dialog Number/Angle Style Dialog on page 131.   

 l When Degrees is selected, you can specify the number of Decimal Places to report.

SECONDARY FORMAT PANEL

In addition to the Primary dimension label, you can display a set of secondary numbers that indicate the dimension’s length 
using different units and/or degree of accuracy.         

The settings on the SECONDARY FORMAT panel of the Dimension Defaults dialog are similar to those on the PRIMARY 
FORMAT panel, but without the Angular Format settings and with one addition:         

 l Check Include Second Format to use a secondary dimension label and enable the settings on this panel.         

The settings on this panel are also the same as those on the same panel of the Dimension Line Specification dialog. See 
Dimension Line Specification Dialog on page 493.         

If you choose to use a second format, you may want to increase the default Line Separation on the GENERAL panel. See 
General Panel on page 457.         

EXTENSIONS PANEL

The settings on the EXTENSIONS panel control the length of extension lines.   
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Extension Length

Specify the Extension Length relative to the marked location on an object.     

 l Specify the Length Away From Marked Object, which is the length of the portion of an extension line that 
extends from the dimension line in the opposite direction of the object it locates.      

 l Select Length Towards Marked Object to specify a fixed length for the portion of an extension line that extends 
from the dimension line toward the object it locates. If the dimension line is moved, this length remains the same but 
the size of the gap updates.     

 l Select Gap From Marked Object to specify the distance between the end of extension lines and their marked 
location in plan inches or mm. If a dimension line is moved, extension lines update, and the size of this gap is 
maintained.    

Gap From Marked Object  +  Length Toward Marked Object =  
Distance to Marked Object
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Fixed Proximity

Specify a fixed length for one extension line that will not change if the object the extension line locates is moved. See Using 
Fixed Proximity on page 490.             

 l Check Fixed Proximity to specify a fixed distance between the marked object and the dimension line. You can only 
fix the proximity for a single extension line.    

 l Specify the Distance to Marked Object, which is the distance from the dimension line to the marked object, using a 
positive value.         

Extension Line and Gap lengths are measured from the marked 
location on a wall. See The Dimension Layer on page 389. 

Fixed Proximity only affects dimension lines that locate an object using an extension line. When a dimension line 
arrowhead points directly to the object without using an extension line, this option has no effect.         

Auto Exterior Dimensions ignore Distance to Marked Object and use the default 1st Line Offset and Line Separation values. 
See Setup Automatic Panel on page 458.

 
Legacy Support

These settings are only recommended for files originally created in Chief Architect              Version 8 and prior. See 
Compatibility With Previous Versions on page 455.          

 l Check Legacy Compatible Extensions to assign a program-defined length to extension lines that cannot be edited.         

 l Check Short Extensions to have short, uniform-length extension lines that do not reach all the way to the objects 
they locate.         

Note: If you select an extension line, Legacy Compatible Extensions 
will be turned off automatically.

 
Centerline

See Centerline Dimensions on page 479.                 

 l When Auto Mark Centerlines is checked, extension lines that locate the midpoint or center of an object are 
automatically marked as Centerlines.

 l Check Same Angle as Dimension to orient Centerline   symbols at the same angle as the dimension line's text. 
When unchecked, Centerline symbols are oriented vertically, regardless of the angle of the dimension line's text.

 l Specify the Offset From Extension, which is the distance from the Centerline   symbol and the end of the 
associated extension line.

 
Preview

A preview of the selected dimension line displays on the right side of the panel. This preview shows a summary of the 
dimension line's general style attributes rather than its actual appearance. See Dialog Preview Panes on page 22. 

LAYER PANEL

The LAYER panel is found in the specification dialogs for many different objects. For more information, see Layer Panel on 
page 191.         

If an automatic dimension line is edited, it will no longer be considered Automatic and the Default check box on this panel 
will be unchecked. See Editing Dimension Lines on page 484.         
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ARROW PANEL

The settings on the ARROW panel control the size and style of dimension line arrows. See Arrow Panel on page 312.   

TEXT STYLE PANEL

The settings on the TEXT STYLE panel control the size, font and other attributes of automatic, manually drawn, and 
temporary dimension line labels. Individual dimension lines inherit their text style from a Saved Dimension Default: they 
cannot have a non-default text style assigned to them. See Dimension Labels on page 482. 

For information about the settings on this panel, see Text Style Panel on page 547.

Temporary dimensions and their labels always use the Selection Line color set in the Preferences dialog. See Colors Panel 
on page 102.

 

Auto Story Pole Dimension Defaults Dialog
The settings in the Auto Story Pole Dimension Defaults dialogs allow you to control how Auto Story Pole Dimensions are 
created in cross section/elevation views. See The Automatic Dimension Tools on page 480. 

Select Edit> Default Settings , expand the Dimension category, select "Auto Story Pole Dimensions", and click Edit to 

access this dialog. It can also be opened by clicking the Auto Story Pole Dimension Defaults  button, which can be 

added to your toolbars. See To add a button to a toolbar on page 137.

As with other types of dimensions, the appearance of Auto Story Pole Dimensions, including size, primary and secondary 
formats, and extension lines can be set in the Dimension Defaults dialog. The defaults for Auto Elevation Dimensions can 
be set there, as well. See Dimension Defaults Dialog on page 457. 

GENERAL PANEL
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Position

The Position settings control where automatic elevation dimensions are generated, relative to the model.         

 l Check Dimension on Left to create a dimension string or story pole on the left side of the model in cross 
section/elevation views.         

 l Check Dimension on Right to create a dimension string or story pole on the right side of the model.         

 l When either Dimension on Left or on Right is selected, a corresponding Reach value can be specified. A Reach of 
100% locates marks across the width of the structure while a Reach of 1% only locates marks located 1/100 of the 
way across. Reach is measured from the structural surface that is closest to the dimension line in the current view, 
including roof eaves but not including gutters or shadow boards.         

 l Check Dimension on Top to create a dimension string above the model.         

 l Check Dimension on Bottom to create a dimension string below the model.         

 
Options

Additional Options control how many dimension strings are created.         

 l Uncheck Inner Dimension to suppress the inner dimension string and generate only one outer dimension. Only 
available in the Auto Story Pole Dimension Defaults dialog. See The Automatic Dimension Tools on page 480.         

 l Uncheck Dimensions Between Elevation Markers to suppress the outer dimension string that measures the 
distances between each of the elevation markers.         

 l When Primary Ridge Marks Only is checked, Auto Story Pole extension lines only locate roof ridges that are 
exposed to the horizon or backdrop on the surface edge that faces the Auto Story Pole. When unchecked, Auto 
Story Poles will locate all roof ridges within the specified Reach distance. In order to be located, "Ridges" must be 
selected on the LOCATE ELEVATIONS panel.

 l When Primary Height Marks Only is checked, Auto Story Pole extension lines only locate top of subfloor and 
top plate heights that they can reach without crossing any portion of the model. Uncheck to locate all top of 
subfloor and top of plate heights located within the Reach distance. In order to be located, "Top of Plate" and "Top 
of Subfloor" must be selected on the LOCATE ELEVATIONS panel. 

 
Preview

A preview of an Auto Story Pole dimension line displays on the right side of the dialog box. This preview shows a summary 
of the dimension's general style attributes only. See Dialog Preview Panes on page 22.

INNER FORMAT PANEL

The settings on the INNER FORMAT panel control the format of the inner string of dimensions on a Story Pole, if present, and 
are similar to those on the PRIMARY FORMAT panel of the Dimension Defaults dialog. See Primary Format Panel on page 
465.         

 l Check Use Default Formatting to use the Primary and Secondary Format settings of the Dimension Defaults that are 
active when a Story Pole is created as the Inner Format. See Multiple Saved Defaults on page 79 and Primary Format 
Panel on page 465.         

OUTER FORMAT PANEL

The settings on the OUTER FORMAT panel control the format of the outer string of dimensions on a Story Pole and are 
similar to those on the PRIMARY FORMAT panel of the Dimension Defaults dialog. See Primary Format Panel on page 465.         
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 l Check Use Default Formatting to use the Primary and Secondary Format settings of the currently active Dimension 
Defaults as the Outer Format.         

MARKER FORMAT PANEL

The settings on the MARKER FORMAT panel control the format of the elevation value stated in elevation markers’ bottom 
line of text on a Story Pole and are similar to those on the PRIMARY FORMAT panel of the Dimension Defaults dialog. See 
Primary Format Panel on page 465.         

 l Check Use Default Formatting to use the Primary Format settings of the currently active Dimension Defaults as the 
Marker Format.         

Once a Story Pole dimension has been created, Additional Text can be added to the bottom line of marker text in the 
Dimension Line Specification dialog. See Segments Panel on page 498.         

LOCATE OBJECTS PANEL

The settings on the LOCATE OBJECTS panel specify whether or not Auto Story Pole Dimensions locate specific types of 
objects. See Locate Manual Panel on page 460.         

LOCATE ELEVATIONS PANEL

The settings on the LOCATE ELEVATIONS panel control what marks Auto Story Pole Dimensions locate, as well as how 
Elevation Markers report their heights.         

This panel is also found in the Dimension Defaults dialog.         

Auto Story Pole Dimensions can also be set to locate additional object types on the LOCATE OBJECTS panel. See Locate 
Manual Panel on page 460.         

 
Grade Level Marker

Specify the position of the Grade Level Marker measured Relative to 1st Floor Subfloor. This value determines the 
height at which Grade Level is marked by dimension line Elevation Markers, but is not tied to the location of the terrain.         
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 l If this value is greater than or less than 0 and Grade Level is a Mark to Include, it will be located at this distance 
above or below the Default 1st Floor Subfloor. See Floor 1 Default Height on page 419.         

 l When this value is 0, Grade Level is marked at the same elevation as the Default 1st Floor Subfloor.         

 l There is only one Grade Level Marker height in each plan, and it is a dynamic setting. If it is modified in one 
defaults dialog, its value will change automatically in the other two defaults dialogs and any dimensions with 
Elevation Markers in the plan will update as well.         

Note: The Grade Level setting and the terrain in the plan are 
completely independent of one another. See Terrain on page 1249. 

Select the desired Elevation Reference, which is the elevation mark that all other marks’ elevations are measured relative 
to.         

 l Select Grade Level Marker to specify the elevation of the Grade Level Marker as 0 and measure all other marks 
relative to it.         

 l Select 1st Floor Subfloor to specify the elevation of the Default 1st Floor Subfloor as 0 and measure all other 
marks relative to it.         

 
Marks

Specify which elevation Marks are included in vertically-oriented automatic elevation dimensions by default.         

 l An alphabetical list of Available Marks displays on the left.          

 l Select one or more names in the list, then click the Add button to move them to the Marks to Include list on the 
right. See Shift and Ctrl Select on page 217.         

 l You can also double-click on an item in this list to add it to the Marks to Include.          

 l A list of the Marks to Include displays on the right. At least one column must be included to create a vertical 
automatic elevation dimension.          

 l In the Marks to Include list, click in the Outer column of any line item to add or remove a check mark. When 
checked, the selected mark will be included on the outer dimension line of an Auto Story Pole.    

 l Select or double-click on an item in the Marks to Include list and click the Rename button to specify a new name.         

 l Click the Reset button to restore the default names for the selected Marks to Include.         

 l Select one or more items in the Marks to Include list, then click the Remove button to move those items back to 
the Available Marks list on the left.          

Note: Deck framing and planking cannot be automatically located by 
vertically oriented elevation dimensions. They can, however, be located 
by manually added extensions. See Adding an Extension Line on page 
486. 

LAYER PANEL

The LAYER panel allows you to specify what layers Auto Story Pole Dimensions are placed on when they are created. It is 
found in the specification dialogs for many different objects. For more information, see Layer Panel on page 191.          
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Temporary Dimension Defaults Dialog
The settings in the Temporary Dimension Defaults dialog allow you to control how Temporary Dimensions locate walls and 
CAD objects. See Temporary Dimensions on page 480. 

Select Edit> Default Settings , expand the Dimension category and choose “Temporary”, and click Edit to access this 

dialog. You can also open this dialog by clicking the Temporary Dimension Defaults  button, which you can add to 

your toolbars. See To add a button to a toolbar on page 137. 

The appearance of Temporary Dimensions, including their size, format, and extension lines, are set along with those of 
manual and automatic dimensions in the Dimension Defaults dialog. See Dimension Defaults Dialog on page 457. 

The default settings for manually drawn dimensions are set in the Dimension Defaults dialog.          
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With Wall Selected

Specify how walls are located by temporary dimensions when a wall is selected.           

 l Select Locate Wall Surface to locate wall surfaces.          

 l Select Locate Wall Dimension Layer to locate wall dimension layers as specified in the Wall Type Definitions 
dialog. See Wall Type Definitions on page 388.          

The next two settings control how temporary dimensions locate interior walls.           

 l Select Primary Wall Side to locate one side of interior walls.           

 l Select Both Wall Sides to locate both surfaces of a selected interior wall. Wall thicknesses are not dimensioned.           

Note: Temporary Dimension Defaults do not affect the temporary wall 
length dimensions that displays when a wall is selected. See Measuring 
Walls on page 369.

The next two settings control how temporary dimensions locate interior walls.           

 l Select Primary Wall Side to locate one side of interior walls.           

 l Select Both Wall Sides to locate both surfaces of a selected interior wall. Wall thicknesses are not dimensioned.           

Note: Temporary Dimension Defaults do not affect the temporary wall 
length dimensions that displays when a wall is selected. See Measuring 
Walls on page 369.

 
With Opening Selected

Specify how walls are located by temporary dimensions when a door, window, or masonry fireplace in that wall is selected.               

 l Select Locate Wall Surface to locate the wall’s surfaces, or Locate Wall Dimension Layer to locate the wall’s 
dimension layer.           

 l Select Locate Primary Wall Side to always locate the wall along the exterior side.          

 l Select Automatic to locate the wall’s exterior by clicking on the wall opening near its exterior side, or locate the 
wall’s interior by clicking on the wall opening near its interior side.           

 
Locate Interior Wall Centers

                 Check Locate Interior Wall Centers to locate interior walls at their centers instead of their surfaces. When checked, this 
option overrides the other settings in this dialog for interior walls.             
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CAD Options

Specify how CAD objects inside a selected CAD object are located by temporary dimensions.              

 l Select Ignore Objects Inside for temporary dimensions to ignore any other objects inside a selected CAD object.           

 l Select Locate First Objects Inside to locate the first edge of another CAD object drawn inside a selected CAD 
object.           

 

The Manually Drawn Dimension Tools
Select CAD> Dimensions to access the manually-drawn Dimension Tools.

Manually drawn dimensions are created by clicking and dragging like other line-based objects and can be drawn in plan 
view, cross section/elevation views, CAD Details, and on layout pages.

The Automatic Dimension tools can also be used to create 
dimensions in plan and cross section/elevation views. See The 

Automatic Dimension Tools on page 480.

There are nine manually drawn Dimension Tools:         

With the exception of Angular Dimensions , dimension lines only locate objects that are parallel or nearly parallel to 

one another and should be drawn orthogonal, or at right angles, to the objects being located.         

Dimension lines locate objects using Object Snaps , although they do not need to be enabled in order to draw 

dimensions. See Object Snaps on page 164. Bear in mind, though, that Object Snaps must be enabled in order to:         

 l Locate parallel objects drawn at angles other than Allowed Angles.         
 l Locate more than one object drawn in the same space, such as a CAD line drawn over a wall.         

The zoom factor of the current view affects whether objects drawn close together are dimensioned or not. If you try to 
dimension an array of objects but the dimension line locates only the first and last objects along its path, Zoom  in on the 

objects and try again. Similarly, if you want to dimension between two objects but the dimension locates unwanted objects 
between them, Zoom  out. See Zoom Tools on page 157.   

Once created, both manually drawn and automatically generated dimension lines can be selected and edited.  See Editing 
Dimension Lines on page 484.   

If the object or objects located by a dimension are resized or moved, the dimension will update to reflect the change. 
Objects located by a dimension can also be accurately relocated or resized by specifying a new dimension value. See 
Moving Objects Using Dimensions on page 491.         
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MANUAL DIMENSIONS

The Manual Dimension tool creates dimension lines that locate all eligible objects positioned between their start and 
end points and within the default Reach distance.   

Manual Dimensions locate walls and a variety of other object types as specified in the  Dimension Defaults dialog. See 
Locate Manual Panel on page 460.   

END-TO-END DIMENSIONS

The End-to-End Dimension tool creates dimension lines that locate an eligible object at its start and end points but 
ignores any objects in between.    

End to End Dimensions locate walls and a variety of other object types as specified in the  Dimension Defaults dialog. See 
Locate End to End Panel on page 464.         

ANGULAR DIMENSIONS

The Angular Dimension tool measures the angle between any two straight edges, including walls, cabinets, and the 
straight sides of polyline-based objects. Edges nested up to four levels deep within a CAD block can be dimensioned, 

as well. To create an angular dimension, click on the first edge to be dimensioned, then drag an arc and release on the 
second edge.         

Like other dimension lines, an Angular Dimension can be included in a CAD block. When the block is exploded, however, 
the Angular Dimension may become invalid and disappear when edited or changed.   

By default, Angular Dimensions use the Angle Style specified in the  Dimension Defaults dialog. See Primary Format 
Panel on page 465.   

INTERIOR DIMENSIONS

The Interior Dimension tool creates dimension lines that measure the interiors of rooms. Interior Dimensions do not 
locate the exterior sides of exterior walls by default, although they can be edited to do so, and they have Display 

Wall Widths unchecked by default in their specification dialog so they do not report the thicknesses of walls or wall layers. 
See Dimension Panel on page 494.          

Interior Dimensions locate either wall surfaces or the Main Layer, as well as a variety of other objects, depending on the 
settings in the Dimension Defaults dialog. See Locate Interior Panel on page 464.         

POINT TO POINT DIMENSIONS

The Point to Point Dimension tool creates dimension lines that locate an eligible object at their start and end points 
if possible. If no object is present at either location, a Point Marker is created and the dimension line locates it 

instead. See Markers on page 538.         

Point to Point Dimensions can be drawn in either of two ways:         

 l When the Default  edit behavior is active, a Point to Point Dimension places Point Markers at its start and end 

points, which it locates. Any objects along the dimension line’s length are ignored. See Point Markers on page 303.         
 l When the Alternate  edit behavior is active, a Point to Point Dimension locates objects along its length as well as 

objects or Point Markers at its start and end. See Defaults, Preferences, and Edit Behaviors on page 208.         

The Point Markers created by the Point to Point Dimension tool can be selected and edited. See Editing Markers on page 
539.         
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Point to Point Dimensions locate walls and a variety of other objects depending on the settings in the Dimension Defaults 
dialog. See Locate End to End Panel on page 464.   

BASELINE DIMENSIONS

The Baseline Dimension tool creates a series of dimension lines that all share the same origin instead of continuing 
from each previous location. Baseline Dimensions are independent and can be edited separately. This tool is not 

available in layout files.          

In plan view, a cross section/elevation view or a CAD Detail, select CAD> Dimensions> Baseline Dimension , click 

near an object and drag a dimension line near or through the objects requiring dimensions.         

Baseline Dimensions locate walls and a variety of other objects depending on settings on the MANUAL panel of the 
Dimension Defaults dialog, while the spacing between lines is determined by the Line Separation value set on the 
GENERAL panel. See Dimension Defaults Dialog on page 457.         

RUNNING DIMENSIONS

The Running Dimension tool is similar to the Baseline Dimension tool in that it produces multiple measurements 
from a single point of origin. It is different, though, in that these measurements display on the same dimension line 

rather than on multiple lines. The start point of a Running Dimension line is marked by a circle. The circle’s size is the 
same as the dimension line’s Arrow Size.         

Running Dimensions locate walls and a variety of other objects as specified on the LOCATE MANUAL panel of the 
Dimension Defaults dialog. See Locate Manual Panel on page 460.   

CENTERLINE DIMENSIONS

The Centerline Dimension tool is available in floor plan and cross section/elevation views. It allows you to locate 
the centers of a variety of object types using special centerline extension lines, which can be distinguished by a 

dashed line style and a   symbol.         

479



Chief Architect Premier X14 Reference Manual - The Automatic Dimension Tools

Centerline Dimensions locate walls and a variety of other objects as specified on the CENTERLINE panel of the Dimension 
Defaults dialog. In order for the centers of an object type such as cabinets, fixtures, and wall openings to be located as a 
dimension line is drawn, Centers must be selected for that object type. Both free-standing fixtures and appliances as well as 
those placed into cabinets can be located by Centerline Dimensions. See Locate Centerline Panel on page 464.         

The centers of a variety of other objects - including stairs, footings, electrical, and CAD objects - can also be located with a 
Centerline by adding an extension at the object’s midpoint.   

You can also specify any extension line on any dimension line as a Centerline using the Mark as Centerline  edit tool 

as well as in the Dimension Line Specification dialog. See Mark as Centerline on page 490.         

TAPE MEASURE

Use the Tape Measure tool to draw a temporary dimension line between any two points in the drawing area. The 
tool will place temporary markers at the start and end points of the dimension line. The Tape Measure line and its 

start and end points all disappear when you release the mouse button. If Object Snaps  are enabled and an object is 

located by the temporary line, you can snap to it.

 

The Automatic Dimension Tools
The Automatic Dimension Tools allow you to generate dimensions in floor plan and cross section/elevation views 
for specific purposes. Select CAD> Automatic Dimensions to access these tools.

If you edit an Auto Dimension line, it will be marked as edited, so if Auto Dimensions are later regenerated, your changes 
will not be lost. If an Auto Dimension line has been edited, the Default check box will be unchecked on the LAYER panel of 
its specification dialog. See Layer Panel on page 499.

Each of the Automatic Dimension  tools has its own defaults settings so that you can customize the functionality of 

each independent of the others. See Dimension Defaults Dialog on page 457.

There are seven Automatic Dimension Tools:

The manually drawn Dimension tools can also be used to draw 
dimensions in plan and cross section/elevation views. See The 

Manually Drawn Dimension Tools on page 477.

TEMPORARY DIMENSIONS

Temporary Dimensions display automatically when an object is selected and report the distance between that 
object’s selected edge and other objects. Select View> Temporary Dimensions to turn on or off the display of 

Temporary Dimensions. This toggle affects all views and is saved between launches of Chief Architect.
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A Temporary Dimension will only display when an object is selected, and as with other dimension lines, it will only locate 
objects that are parallel or nearly parallel to one another. Temporary Dimensions will also locate the endpoints of CAD lines 
and the corners of objects located past the end of the selected edge, within 4 feet (1200 mm) of the point where you click to 
select the object.

You can control how Temporary Dimensions locate objects in the Temporary Dimension Defaults dialog. See Temporary 
Dimension Defaults Dialog on page 475.

AUTO EXTERIOR DIMENSIONS

The Auto Exterior Dimensions tool generates dimensions around a plan’s exterior in plan view, locating walls and 
openings as specified in the Dimension Defaults dialog.

Auto Exterior Dimensions require one or more rooms to be 
defined in order to generate. See Room Definition on page 418.

Up to three rows of automatically generated dimensions may be created per exterior wall:

 l The innermost dimension line locates exterior walls, interior walls, and all openings in exterior walls.
 l The second dimension line locates exterior and interior walls.
 l The outermost dimension line is the overall exterior dimension.

AUTO ELEVATION DIMENSIONS

The Auto Elevation Dimensions tool generates dimensions that locate walls and other objects in cross 
section/elevation views, as specified in the Dimension Defaults dialog. See Locate Auto Elevation Panel on page 465.

AUTO STORY POLE DIMENSIONS

The Auto Story Pole Dimensions tool generates Elevation Markers and dimensions that locate walls and other 
objects in cross section/elevation views, as specified in the Auto Story Pole Dimension Defaults dialog. See Auto 

Story Pole Dimension Defaults Dialog on page 471.

Note: Only one set of automatic elevation dimensions created by any of 
the Auto Dimension tools can exist in a given cross section/elevation 
view at a time. If you want to have more than one, mark them as edited. 
See Editing Dimension Lines on page 484.

AUTO ROOM DIMENSIONS

Select one or more rooms and click the Auto Room Dimensions edit button to generate interior dimensions that 
measure each wall defining the selected room(s).

Auto Room Dimensions lines are generated inside the rooms they measure and locate walls and wall openings, as well as 
other objects, as specified in the Dimension Defaults dialog. See Locate Auto Room Panel on page 465. 

Auto Room Dimensions do not recognize the No Locate setting for walls. If a wall is specified as No Locate, Auto Room 
Dimensions will locate it anyway. See No Locate on page 371.
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Displaying Dimension Lines
The display of dimension lines is controlled in the Layer Display Options dialog as well as by using Drawing Groups. 
See Displaying Objects on page 179. 

You can customize the both appearance and the display of dimension lines for different purposes. See Default Sets on page 
83.         

Dimension lines created by any of the dimension tools share the same components:

 l Dimension Lines run parallel with the distance being measured.
 l Extension Lines are perpendicular to dimension lines, indicating what they locate. If a dimension line locates more 

than two objects, extension lines divide the dimension line into segments. 
 l Arrowheads display at the intersections of dimension and extension lines.
 l Dimension Labels display at the midpoint of dimension line segments and indicate the distance that each segment 

measures.

EXTENSION LINES

If a dimension line is offset from the objects it locates, extension lines help clarify exactly what is being located. Extension 
lines are numbered: when a dimension line is selected, an Extension Line Number displays at the end of each extension line.
         

You can specify the default length of extension lines in the Dimension Defaults dialog. See Extensions Panel on page 468.         

Once drawn, the appearance of extension lines can be edited. See Editing Extension Lines on page 486.         

Any extension line can be specified as a Centerline that displays the   symbol. See Centerline Dimensions on page 479.         

In cross section/elevation views, vertically-oriented dimension lines can display Elevation Markers along their extension 
lines. See Extensions/Markers Panel on page 496.         

DIMENSION LABELS

Manually drawn, automatic, and temporary dimension labels use the Text Style specified in the Dimension Defaults dialog. 
Unlike many objects that use Text Styles, by default dimensions use a Text Style specified in the defaults dialog rather than 
the Text Style assigned to their layer. See Text Style Panel on page 547. 

Like other text, dimension labels are subject to scaling. For 
example, A Character Height of 6” prints a 1/8” tall number at 

1/4” = 1’ scale. A Character Height of 125 mm prints a 3 mm tall number 
at 1 m = 50 m scale. See Printing Text, Dimensions, and Line Styles on 
page 1378.

By default, dimension labels have a solid fill that is the same as the Background Color set in the Preferences dialog. You 
can instead specify that labels use a Text Style with a transparent fill.   

You can also specify the minimum size of dimension numbers displaying on screen in the Preferences dialog. See 
Appearance Panel on page 99.         
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Labels can have both a primary and secondary format and can be centered on dimension lines or located either above or 
below them. See Primary Format Panel on page 465.

Dimension labels have their own edit handles and can be moved and rotated when a dimension line is selected. See Editing 
Dimension Lines on page 484.

DIMENSION ARROWHEADS

You can specify the style, color and size of  dimension arrows in the Dimension Defaults and Dimension Line Specification 
dialogs. See Arrow Panel on page 312. 

The arrow at the end of a dimension line will not display if it is close enough to another dimension arrow that the two will 
overlap. A typical example of this is where two sections of an Interior Dimension locate two sides of an interior wall.   

ELEVATION MARKERS

The Auto Story Pole Dimensions  tool creates a story pole with Elevation Markers and dimension strings automatically. 

See The Automatic Dimension Tools on page 480.         

In addition, Elevation Markers can be added to any vertically-oriented dimension line in a cross section/elevation view.         

To add an elevation marker
 1.  Select an eligible dimension line and note the number of the extension line that you would like to add a marker to. 

See Extension Lines on page 482.         

 2.  Click the Open Object  edit button.         

 3.  On the EXTENSIONS/MARKERS panel of the Dimension Line Specification dialog, select the number you noted in 
Step 1 from the Selected Extension drop-down list.         

 4.  Check the box beside Draw Elevation Marker.         

 5.  Type the desired Elevation Marker Text then click OK.         

The resulting marker will display your text above the line and the height above grade below the line. In addition to the 
height above grade, you can add Additional Text below the line. See Segments Panel on page 498.         

By default, grade level is set at the same height as the default subfloor for Floor 1; however, this can be changed in the Auto 
Story Pole Dimension Defaults dialog and for dimensions created with other tools, the Dimension Defaults dialog. See 
Locate Elevations Panel on page 473.         

These Elevation Markers inherit their attributes, including marker Type, from the Saved Marker Defaults specified in the 
Dimension Line Specification dialog. See Extensions/Markers Panel on page 496.          

 

Selecting Dimension Lines
Before a manually-drawn or automatic dimension line can be edited, it must be selected. A dimension line can be selected in 
one of three ways, each of which affects the ways that the dimension line can then be edited.         

The standard way to select an individual dimension line is to click anywhere along its length when the Select Objects  

or any of the Manual Dimension  tools is active. When selected in this manner, the dimension line’s full range of 

editing options are available.          
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You can instead click on one of the dimension line’s extension lines. When selected in this way, the selected extension 
line’s length can be edited and a Centerline marker added to or removed from it; however, fewer edit handles are available 
overall. See Editing Extension Lines on page 486.          

If you select an extension line by mistake, press the Esc key to 
display the full set of dimension line edit handles. 

Dimension lines can also be group-selected, with limited editing options. See Selecting Multiple Objects on page 215.          

 

Editing Dimension Lines
Before a dimension line can be edited, it must be selected. See Selecting Dimension Lines on page 483.         

With the exception of Temporary Dimensions , dimension lines can be selected and edited using the mouse, the Edit 

Toolbar buttons, and the Dimension Line Specification dialog. See Dimension Line Specification Dialog on page 493.

If an Auto Dimension line is edited, it will no longer be considered an automatic dimension line and will not be deleted and 
replaced the next time the tool used to create it is used.

For information about changing the value reported in a dimension line label, see Moving Objects Using Dimensions on page 
491.   

USING THE EDIT HANDLES

When a dimension line is selected, its edit handles can be seen. There are seven types of dimension line edit handles. The 
total number of edit handles a dimension line has depends on how many extension lines it has.  

 A.  The Extension Line End handles are positioned at the point that each extension line locates and are used to move or 
delete extension lines. See Moving an Extension Line on page 487.

 B.  The Add Extension Line handle displays to the side of the Move handle and is used to add extension lines to the 
dimension line. Extension lines added in this manner are able to locate marks that the dimension line might not 
locate as it was being drawn. See Adding an Extension Line on page 486.

 C.  The Move handle is located where you clicked to select the dimension line and displays the Selected Edge Handle 
Fill color. It is used to move the entire dimension line, including any subsections, perpendicular to itself. Extension 
lines are resized as appropriate. The pointer changes to a two-headed arrow   when moved over this handle.

 D.  The Add Segments handles are located just past the ends of the dimension line and are used to increase the length of 
the dimension line and locate additional objects with it. The types of objects and their mark points that can be 
located with this method are dependent on the Dimension Defaults that the selected dimension line inherits its 
settings from, as well as the tool used to draw it. The Status Bar reports a selected dimension line's type, as does its 
specification dialog. See Dimension Panel on page 494.    
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 E.  A small triangular Rotate Dimension Label handle is located near the center of each dimension segment's label. Use 
this handle to rotate an individual dimension label.

 F.  The small, square Move Dimension Label handle is located at the center of the selected label. Use this handle to 
move the dimension number for each dimension line section. The pointer changes to a  four-headed arrow   when 
moved over this handle. When Object Snaps are enabled, dimension label centers will snap to their associated 
dimension line.         

 G.  The Rotate handle is located past the end of the dimension line and can be used to rotate the dimension line.

Note: A selected dimension line cannot be moved if Fixed Proximity is 
checked in the Dimension Line Specification dialog. See 
Extensions/Markers Panel on page 496.

A selected Angular Dimension has only one edit handle. When you click and drag this handle, the selected Angular 
Dimension will move. Its length will increase or decrease concentrically depending on which direction it is moved, and the 
location of its arc center will be maintained.

As a selected dimension line is resized, it's drawing behavior and the objects it locates may vary, depending on the 
Dimension Tool that was used to create it. When selected, Interior, Centerline, Baseline, and Running Dimensions are 
described as such in the Status Bar. See The Status Bar on page 25.

USING THE EDIT TOOLS

Dimension lines can be repositioned, copied, and deleted using the Edit Toolbar buttons just like other objects in the 
program can. See The Edit Toolbar on page 135. 

Click the Edit Extensions  edit button to edit the lengths of the selected dimension’s extension lines. See Editing 

Extension Lines on page 486.         

Click the Add Additional Text  edit button to add or replace the text in a dimension line segment’s label. See Add 

Additional Text on page 490.         

DIMENSION NUMBER SIZE

The initial size of dimension numbers is specified in the Dimension Defaults dialog. See Dimension Defaults Dialog on 
page 457. 

You can specify number height for individual dimension lines in the Dimension Line Specification dialog. See Dimension 
Panel on page 494.

As with text and other objects, dimension number size is subject to scaling when sent to layout or printed. See Printing Text, 
Dimensions, and Line Styles on page 1378.

COPYING AND PASTING DIMENSION LINES

Dimension lines can be copied and pasted into any view type that supports dimensions. If a dimension line is copied 
independent of the objects it originally locates, the pasted dimension line will locate Point Markers. See Point Markers and 
Dimensions on page 539.

Dimension lines can also be copied and pasted from one plan or layout file to another. Bear in mind that dimension lines use 
dynamic defaults. If the destination file has a Saved Manual Dimension Default with the same name as that used by the 
dimension line being copied, the pasted dimension will refer to it. If no such saved default exists in the destination file, the 
pasted dimension will become associated with the currently active Saved Manual Dimension Default.         
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DELETING DIMENSION LINES

There are several ways to delete dimension lines. 

You can select any manual or automatic dimension line or group of dimension lines, then press the Delete key or click the 
Delete  edit button. See Deleting Objects on page 289.

The Delete Objects dialog allows you to delete all manually drawn and/or automatic dimension lines at once. See Delete 
Objects Dialog on page 289.

Individual dimension line segments located between extension lines can also be deleted. If a segment is located between two 
other segments along the same dimension line, that dimension will be broken in two.

To delete a portion of a dimension line
 1.  Select any Dimension Tool aside from Angular or Auto Exterior Dimensions.

 2.  Manually draw a dimension line over the segment that you wish to remove, dragging from extension line to 
extension line.

 

Editing Extension Lines
Before extension lines can be edited, either they or their dimension line must be selected. See Selecting Dimension Lines on 
page 483.         

Extension lines can be added, edited, and deleted using the edit handles when their dimension line is selected. In addition, 
extension lines can be individually selected and edited.

Extension lines are also affected by settings in the Dimension Line Specification dialog. See Extensions/Markers Panel on 
page 496.         

ADDING AN EXTENSION LINE

The Add Extension Line edit handle allows you to locate marks that the dimension line might not have been able to locate 
as it was being drawn. Interior Dimensions, for example, do not locate cabinets as they are drawn; however, you can add an 
extension line that locates a cabinet.

To add an extension line
 1.  Select the dimension line anywhere along its length.

 2.  Click the diamond-shaped Add Extension Line edit handle which displays near the Move edit handle. The pointer 
changes to a two-headed arrow  .

 3.  Drag the handle to the object that you want to locate with a new extension handle. This example adds an extension 
line to the left side of the window. 
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 4.  Release the mouse button to add an extension line.

Additional extension lines can also be created by clicking and 
dragging an Add Segments edit handle. See Editing Dimension 

Lines on page 484.

MOVING AN EXTENSION LINE

Extension lines can be moved to locate the centers, sides, or surfaces of most objects. Here, an extension line is moved from 
the windows edge to the center.

To move an extension line
 1.  Select the dimension line anywhere along its length: do not click on the extension line itself.

 2.  Click the Extension Line edit handle. The pointer changes to a two-headed arrow  .
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 3.  Drag the handle to a new location. The extension line snaps to possible marks as the handle is moved.

 4.  Release the mouse button at the new location.

Not all library symbols can be located by a dimension line as it 
is drawn. Once a dimension is drawn, however, you can move or 

add an extension line to locate the library object.

DELETING AN EXTENSION LINE

When an extension line is deleted, the remaining dimensions update. If a dimension line has only two extension lines, they 
cannot be deleted.

To remove an extension line
 1.  Select the dimension line anywhere along its length: do not click on the extension line itself.

 2.  Click the Extension Line edit handle. 
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 3.  Drag it perpendicular to the direction of the arrows, away from any dimensionable object, and release the button 
when the extension line disappears.

In addition, individual extension lines can be selected, allowing you to resize them and/or mark them as Centerlines.         

RESIZING EXTENSION LINES

You can resize extension lines in the Dimension Line Specification dialog or using their edit handles. See Extensions Panel 
on page 468.         

To resize an extension line
 1.  Click on the extension line or select the dimension line and click the Edit Extensions  edit button to display two 

handles along the extension line.         

 2.  Click either handle, turning the pointer into a two-headed arrow  .         

 3.  Extend or contract the extension line and release the mouse.         
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USING FIXED PROXIMITY

The Fixed Proximity option allows you to specify a fixed length for one extension line that will not change if the object the 
extension line locates is moved.         

To use Fixed Proximity
 1.  Select a dimension line that locates multiple independent objects and note the Extension Number of the extension 

line that you would like to have a fixed length.         

 2.  Open the Dimension Line Specification dialog and go to the EXTENSIONS panel. See Extensions/Markers Panel on 
page 496.         

 l Select the Extension Number that you  noted in step 1 from the Selected Extension drop-down list.          

 l Check Fixed Proximity.          

 l Specify the desired Distance to Marked Object, which is the distance from the selected dimension line to the 
object that the Selected Extension locates. This distance includes the Gap From Marked Object.          

 l Click OK.          

To see how Fixed Proximity works, select the object that the extension line with Fixed Proximity specified and move it.  
Notice that the dimension line moves in response and that all extension lines’ lengths adjust except for the one with Fixed 
Proximity specified.         

MARK AS CENTERLINE

Any extension line can be specified as a Centerline. Click on an extension line to select it, and then click the Mark as 
Centerline  edit button. See Centerline Dimensions on page 479.         

Similarly, the Centerline can be removed from an extension line using the Remove Centerline Mark  edit button.         

 

Add Additional Text
Text can be added to any manual or automatic dimension line using the Add Additional Text edit tool. 

To add text to a dimension label
 1.  Select a dimension line that you would like to add text to.

 2.  Click the Add Additional Text  edit button.

 3.  Click on the segment of the dimension line with the label you wish to add text to.

 4.  In the Additional Text dialog:
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 l Type any Leading Text that you want to display before the dimension value.

 l Type any Trailing Text that you want to display after the dimension value.

 l Check Suppress Dimension Value to prevent the dimension value from displaying in the selected segment at all. 

 5.  When you click OK, the segment you selected will display the added text.

Additional Text can also be added and edited in the Dimension Line Specification dialog. See Segments Panel on page 498.

If a dimension segment has an elevation marker associated with it, any added text will also be added to the marker’s bottom 
line of text. See Marker Format Panel on page 496.

You can check Highlight Overridden Dimension Text in the Preferences dialog to identify any dimension label text that 
replaces a suppressed dimension value. See General Panel on page 107. 

Note: Dimension lines with text added are not supported when exported 
to .dxf/.dwg. When exported, they are converted to text and CAD lines. 
The same occurs when CAD Detail from View is used. See CAD Detail 
from View on page 341. 

 

Moving Objects Using Dimensions
Most objects can be moved by changing an automatic, manual, or temporary dimension value that locates it. This technique 
can be applied in nearly any situation where dimensions are present, including angular dimensions. See Moving Objects on 
page 245.

In addition, some objects can be resized using dimensions. See Resizing Objects on page 256.

Your pointer indicates which dimensions can be used to relocate the selected object by changing to a pointing hand   icon. 

Another way to tell is to select an object and drag it in the desired direction. As you drag, note which dimensions update. 
These dimensions are the dimensions that can be used to move that object. 

Note: A selected object can be moved and resized using a dimension line 
even when that dimension’s layer is locked. See Locking Layers on page 
182.

To move an object using dimensions
 1.  Select the object and click on a dimension line that locates it. An inline text field opens at the location where you 

clicked. 

491



Chief Architect Premier X14 Reference Manual - Moving Objects Using Dimensions

 l The actual distance displays in the text field using the default primary format. See Primary Format Panel on page 
465. 

 l If the dimension is locating two different objects and the selected object is polyline-based, the Move Edge and 
Move Entire Object buttons display to the right of the text field. 

 l If the dimension describes a selected wall’s length, additional buttons display to the right. See Using Dimensions 
on page 373.

 2.  Click the Move button of your choice. 

 3.  Enter a new value in the text field. The unit of measurement is set in the Number Style/Angle Style dialog. See 
Dialog Number/Angle Style Dialog on page 131.

 l To use a different unit, include its indicator after the value.    

 l To move the selected object past a second object, to its opposite side, enter a negative value. 

 l Basic math operations can also be performed in the inline text box, just as they can in dialogs. See Units and Math 
Operations in Dialogs on page 20.

 4.  The selected object moves or resizes when you press the Enter key or click outside the text field. 

 5.  If Bumping/Pushing  is enabled, the object being moved will bump into any objects in its move path and not 

move the entire distance. Hold down the Ctrl key when you press Enter to override this move restriction. See 
Bumping/Pushing on page 246.         

A variety of polyline- and box-based objects can also be resized using dimensions.

To resize an object using dimensions
 1.  Select the object along the edge that you would like to move. See Selected Edge on page 214.

 2.  Click on a dimension line that indicates its distance from the object’s opposite side. 

 3.  In the inline text field, enter a value. 

 4.  Click Move edge to move the selected edge only. 

 5.  The selected edge moves, resizing the object, when you press the Enter key. 

You can cancel a move or resize operation using dimensions at 
any time by pressing the Esc key.

RESIZING WALLS USING EXTERIOR DIMENSIONS

When resizing a structure using dimensions, it is important to work your way around it in one direction. Relocate one wall 
at a time in succession so that you do not redefine the same dimension more than once. 

For more information, see Measuring Walls on page 369. 

USING ANGULAR DIMENSIONS

Angular Dimensions are useful for adjusting the angles of polyline-based objects and walls.         
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To change an angular dimension
 1.  Draw an CAD> Dimensions> Angular Dimension , then click and drag to draw an arc within the angle you 

wish to measure.         

 2.  Select the edge that you want to move.         

 3.  Click the dimension value to open the Set Angular Dimension dialog.         
The Set Angular Dimension dialog reports the Previous Value in degrees, minutes and seconds.

 4.  Enter a value in the New Value field.         

 5.  Specify what you want to rotate:         

 l Select Rotate edge to move the selected edge when you click OK, or          

 l Select Rotate entire polyline to rotate the entire object about the corner formed by the edges that the Angular 
Dimension locates, maintaining the previous value of that angle.          

 6.  Click OK to apply the change.         

 

Dimension Line Specification Dialog
To open the Dimension Line Specification dialog, select one or more dimension lines and click the Open Object edit 
button.   

The settings in this dialog are dynamic defaults associated with a particular Saved Manual Dimension Default. See 
Dimension Defaults Dialog on page 457. 

The Dimension Line Specification dialog has up to nine panels, depending on the type of dimension line selected:
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DIMENSION PANEL

 
Inherits Default Properties From

The name of the Saved Dimension Default that the selected dimension line gets its default attributes from displays here. If 
a dimension line inherits attributes from a Saved Dimension Default, that default cannot be deleted. See              Saved Defaults 
Dialog on page 80.             

 l If multiple dimension lines are selected, “No Change” may display here.         

 l You can select a different Saved Dimension Default from the drop-down list.   

 l The Locate Settings associated with the tool used to draw the selected dimension line is stated here for reference. A 
Manual Dimension line uses Locate Settings from the LOCATE MANUAL panel of the Dimension Defaults dialog, for 
example, while an Interior Dimension line uses settings from the LOCATE INTERIOR panel.  These settings affect how 
the dimension line behaves when edited. See Using the Edit Handles on page 484. 

 l Depending on the type of dimension line selected, you may be able to choose between the Locate Settings of two 
tools: the one that originally created the dimension line, and Manual Dimension.
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Options

Specify the text size and display of wall widths attributes for the selected dimension line. The minimum on-screen size can 
be set in the Preferences dialog. See Appearance Panel on page 99.             

 l Specify the Number Height of the selected dimension's labels. See Dynamic Defaults on page 79.

Dimension Number Height is subject to scaling. See Scaling 
Text on page 521.

 l Uncheck Display Wall Widths to suppress those portions of the dimension line that measure between two surfaces 
of the same wall. Both sides of a wall may still be located, but its width will not display. This option is checked by 
default for most manually drawn dimensions, but is unchecked for Interior Dimensions .    

 l Check Display Gaps Between Cabinet Face Items to show those portions of the dimension line that measure the 
gaps between cabinet face items in elevation views. This option also controls dimension lines that locate opening 
edges and the nearest cabinet box edge. When unchecked, these gaps are measured but will not display.

 
Rounded Value Indicators

Specify the use and appearance of Rounded Value Indicators, which can display when the degree of accuracy in use is not 
sufficient to describe a dimension’s true value.         

 l Check Use Default to use the default indicator(s). Uncheck this box to make the options that follow active.         

 l Check + or - After Number to indicate that the actual dimension value is higher or lower than the value shown.         

 l Check ~ Before Number to indicate dimension values that are not accurate with the ~ symbol.         

 
Dimension Text Position and Orientation

Specify the location and angle of dimension numbers relative to the dimension line. These settings are also found in the 
Dimension Defaults dialog. See General Panel on page 457.

 
Preview

A preview of the selected dimension line displays on the right side of the panel. This preview shows a summary of the 
dimension line's general style attributes rather than its actual appearance. See Dialog Preview Panes on page 22. 

DIMENSION PANEL FOR ANGULAR DIMENSIONS
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 l The name of the Saved Dimension Default that the selected dimension gets its default attributes from displays here. 
You can select a different Saved Default from the drop-down list.     

 l Specify a Number Height for the selected dimension. See Dynamic Defaults on page 79.

 
Use Default Angle Style

When this box is checked, the selected dimension uses the angle style set in the Dimension Defaults dialog. Uncheck this 
box to select a different Angle Style and number of Decimal Places. See Primary Format Panel on page 465.

 
Preview

A preview of the selected dimension line displays on the right side of the panel. This preview shows a summary of the 
dimension line's general style attributes rather than its actual appearance. See Dialog Preview Panes on page 22. 

PRIMARY FORMAT PANEL

To enable the settings on the PRIMARY FORMAT panel of the Dimension Line Specification dialog, uncheck Use Default 
Formatting.         

The settings that follow are the same as those on the same panel of the Dimension Defaults dialog, but apply only to the 
selected dimension line(s). See Primary Format Panel on page 465. Not available for Angular Dimensions.         

SECONDARY FORMAT PANEL

To enable the settings on the SECONDARY FORMAT panel of the Dimension Line Specification dialog, uncheck Use Default 
Formatting and then check Include Second Format.         

The settings on this panel are the same as those on the same panel of the Dimension Defaults dialog, but apply only to the 
selected dimension line(s). See Secondary Format Panel on page 468. Not available for Angular Dimensions.         

MARKER FORMAT PANEL

The settings on the MARKER FORMAT panel control the format of the elevation value stated in elevation markers’ bottom 
line of text on a Story Pole and are similar to those on the PRIMARY FORMAT panel of the Dimension Defaults dialog. See 
Primary Format Panel on page 465.         

This panel is only available if the selected dimension line is drawn vertically in a cross section/elevation view. See Detailing 
Cross Section/Elevation Views on page 1092.          

 l Check Use Default Formatting to use the Primary Format settings of the currently active Dimension Defaults as the 
Marker Format.          

Leading and trailing text can be added before and after the elevation value in an elevation marker’s bottom line of text on 
the SEGMENTS panel of the Dimension Line Specification dialog. See Segments Panel on page 498.          

EXTENSIONS/MARKERS PANEL

The settings on the EXTENSIONS/MARKERS  panel allow you to edit the selected dimension line's extensions. See Editing 
Extension Lines on page 486.

This panel is not available for multiple dimensions selected as a group or for Angular Dimensions .         
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Opening this panel will turn off Legacy Compatible Extensions 
if it is enabled in the Dimension Defaults dialog. See Extensions 

Panel on page 468.

 
Extension Lines

An editable table lists the selected dimension line's extensions here. Initially, the extension closest to the point where you 
clicked to select the dimension line will be highlighted. The highlighted extension line is selected and can be edited.    

Each extension line’s number displays beside it when a 
dimension line is selected. See Displaying Dimension Lines on 

page 482.     

 l Click on a line item to select and edit it. The Properties for Selected Extension are listed and can be edited using 
the settings below.     

 l The available Extension Length and Marker Style settings can also be edited in the table. The available options 
depend on which Extension Length option is selected below, as well as the view type.

 l Only available in the table, click in the Fixed Proximity column to specify a fixed distance between the marked 
object and the dimension line. You can only fix the proximity for a single extension line. See Using Fixed Proximity 
on page 490.     

 l When Fixed Proximity is checked, specify the Distance to Marked Object, which is the distance from the 
dimension line to the marked object, using a positive value.

 
Extension Length

These settings are the same as those in the Dimension Defaults dialog, but apply to the extension lines associated with the 
selected dimension line only.  See Extensions Panel on page 468.         
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 l Uncheck Use Default to enable the three settings that follow as well as the equivalent fields for the selected line 
item in the table above. 

 l Check Use Default to restore the default settings to the Selected Extension line.

 l Specify the Length Away From Marked Object, which is the length of the portion of an extension line that 
extends from the dimension line in the opposite direction of the object it locates.      

 l Select Length Towards Marked Object to specify a fixed length for the portion of an extension line that extends 
from the dimension line toward the object it locates. If the dimension line is moved, this length remains the same 
but the size of the gap updates.     

 l Select Gap From Marked Object to specify the distance between the end of extension lines and their marked 
location in plan inches or mm. If a dimension line is moved, extension lines update, and the size of this gap is 
maintained.    

 
Marker Style

These settings provide alternatives to the standard extension line style. The selected extension line may have Mark as 
Centerline checked, or Display Elevation Marker, but not both.             

 l Check Mark as Centerline to mark the selected extension line with a Centerline   symbol. Not available in the 
Dimension Defaults dialog. See Mark as Centerline on page 490.         

 l Check Draw Elevation Marker to add an elevation marker to the selected extension line. Only available for 
vertically oriented dimension lines in cross section/elevation views. See Elevation Markers on page 483.         

 l Specify the Elevation Marker Text, which is the text that accompanies an Elevation Marker. This will be pre-
populated if the selected extension line locates an elevation mark recognized by the program. Only available when 
Draw Elevation Marker is selected, above. See Locate Elevations Panel on page 473.         

 l Specify which Saved Marker Defaults the selected extension line’s Marker Inherits Properties From. Only 
available when Draw Elevation Marker is selected above, this setting determines the marker’s size and appearance. 
See Multiple Saved Defaults on page 79.         

 l Click the Define button to modify the selected Saved Marker Defaults. See Marker Defaults on page 503.          

SEGMENTS PANEL

Additional Text can be added to the label of any segment of the selected dimension line on this panel as well as using the 
Add Additional Text  edit tool. See Add Additional Text on page 490.         

If the selected segment has an elevation marker associated with its extension line, the marker’s lower text will also receive 
this Additional Text. See The Automatic Dimension Tools on page 480.         

This panel is not available for multiple dimensions selected as a group or for Angular Dimensions .
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Segments

An editable table lists the selected dimension line's segments here. Initially, the segment that was clicked on when the 
dimension line was selected will be highlighted. The highlighted extension line is selected and can be edited.      

Each extension line’s number displays beside it when a 
dimension line is selected. See Displaying Dimension Lines on 

page 482.      

 
Blank Segment

Check Blank Segment to suppress the selected segment’s dimension label. When this box is checked, the settings that 
follow are disabled.

 
Text Added to Segment

Specify any required text to add to the selected segment and elevation marker, if one is present.         

 l Type the Leading Text, which appears before the dimension value in the label.         

 l Type the Trailing Text, which appears after the dimension value in the label.         

 l Check Suppress Dimension Value to prevent the dimension value from displaying in the selected segment at all. 

 l To specify the Angle of the dimension label associated with the selected segment, uncheck Automatic and then 
enter a value in the text field, in degrees. If the label has been rotated using its edit handle, Automatic will be 
unchecked and its angle will be reported.

LAYER PANEL

The LAYER panel is found in the specification dialogs for various objects. For more information, see Layer Panel on page 
191.         

If the selected dimension line was automatically generated, the Default check box on this panel will be unchecked 
automatically if the dimension line is edited. See The Automatic Dimension Tools on page 480.         
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ARROW PANEL

For information about the settings on this panel, see Arrow Panel on page 312.
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Chapter 14
 

Text, Callouts, and Markers

The Text Tools help you draw attention to special details of your drawings. Text objects can be added in plan view, in cross 
section/elevation views, in CAD Details, and to layout pages.

The display of text can be controlled by layer or set specifically for each text object.

TOPICS

Text Defaults and Preferences 502
Fonts and Alphabets 503
The Text Tools 505
Creating Text Objects 505
Displaying Text Objects 507
Rich Text Specification Dialog 507
Text Specification Dialog 514
Editing Text 518
Copying and Pasting Text 523
Find/Replace Text and Spell Check 524
Text Arrows 528
Callouts 530
Linked Callouts 533
Callout Specification Dialog 535
Markers 538
Marker Specification Dialog 540
Notes, Note Types, and Note Schedules 542
Note Specification Dialog 544
Note/Callout Panel 545
Text Styles 547
Text Macros 549
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Text Defaults and Preferences
Text Defaults can be accessed by selecting Edit> Default Settings in any view in which text can be created. Click 
the "+" next to Text, Callouts and Markers to display the sub-headings. See Default Settings vs Preferences on 

page 76.          

The default settings for Rich Text, Text, Callouts, Markers, and Arrows determine what these objects look like when they 
are first created. Text Style Defaults determine the appearance of text associated with things like dimensions and object 
labels.          

Rich Text , Text , Callouts , Markers , and Arrows  can support multiple Saved Defaults. In order to 

open the defaults dialog for of these tools, you must first open its Saved Defaults dialog and choose an available saved 
defaults setup. See Multiple Saved Defaults on page 79.         

 l When you access a defaults dialog for any of the Text Tools via the Default Settings dialog, the Saved Defaults dialog 
will open first, allowing you to select which Saved Default you wish to edit. Multiple Defaults can be selected if you 
wish. See Shift and Ctrl Select on page 217.          

 l When you access this dialog by double-clicking a Text Tool button, the defaults dialog for the currently active Saved 
Default is opened directly. If you would like the Saved Defaults dialog to open first in this situation, you can enable 
this option in the Preferences dialog. See General Panel on page 107.           

 l In either case, the name of the Saved Default being edited will display in the title bar at the top of the dialog box.           

Changes made to default settings do not alter existing text objects, so it is a good idea to go over these settings before 
placing text.           

TEXT STYLE DEFAULTS

Select “Text Style” from the list in the Default Settings dialog and click the Edit button to open the Saved Text Style 
Defaults dialog.              The Text Style Defaults  button can be added to your toolbars. See To add a button to a toolbar on 

page 137. 

The Text Style Defaults dialog allows you to specify the attributes of the various Text Styles in use in the current file. See 
Text Styles on page 547.         

RICH TEXT DEFAULTS

Double-click the Rich Text  or Leader Line  tool to open the Saved Rich Text Defaults dialog and edit the currently 

active Saved Default.           

The Rich Text Defaults dialog is similar to the Rich Text Specification dialog, but the name of the current Saved Default 
displays in the title bar. See Rich Text Specification Dialog on page 507.         

Leader Lines and Text Lines with Arrows use the same default layer as Rich Text, so by default they have the same color, 
line weight and line style. See Layers on page 180.         

TEXT DEFAULTS

Double-click the Text  tool to open the Saved Text Defaults dialog and edit the currently active Saved Default.           

The Text Defaults dialog looks almost the same as the Text Specification dialog, but the name of the current Saved Default 
displays in the title bar. See Text Specification Dialog on page 514.          
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CALLOUT DEFAULTS

Double-click the Callout  tool to open the Saved Callout Defaults dialog and edit the currently active Saved Default.           

The Callout Defaults dialog looks almost the same as the Callout Specification dialog, but the name of the current Saved 
Default displays in the title bar. See Callout Specification Dialog on page 535.

MARKER DEFAULTS

Double-click the Marker  tool to open the Saved Marker Defaults dialog and edit the currently active Saved Default.          

The Marker Defaults dialog looks almost the same as the Marker Specification dialog, but the name of the current Saved 
Default displays in the title bar. See Marker Specification Dialog on page 540.

ARROW DEFAULTS

Double-click the Text Line with Arrow  tool to open the Saved Arrow Defaults and edit the currently active Saved 

Default.          

The settings in the Arrow Defaults dialog determine the initial settings for arrows drawn using the              Leader Line , Text 

Line with Arrow  and Line With Arrow tools. These settings also determine the initial appearance of arrows when they 

are added to CAD lines, arcs, and polylines.

The Arrow Defaults dialog looks almost the same as the ARROW panel of the Line Specification dialog, but the name of the 
current Saved Default displays in the title bar. See Arrow Panel on page 312.          

Avoid typing any text in any text Defaults dialog unless you 
want it to be present in all text objects you create.

DEFAULT SETS

The Text Tools are among the items associated with Default Sets, which are groups of Saved Defaults that can be 
customized and activated for specific drawing tasks. See Default Sets on page 83.          

PREFERENCES

Specify the number of segments for new leader lines and whether pressing the Enter key creates a new line of text or 
closes the Rich Text and Text Specification dialogs in the Preferences dialog. See Text Panel on page 106.

 

Fonts and Alphabets
Chief Architect allows you to use any font found in your computer’s Fonts directory.         

For best printed results, using true-type or open-type fonts is recommended.         

CHIEF BLUEPRINT FONT

The Chief Blueprint font is installed in the Windows Fonts directory when Chief Architect is installed.         

On Mac systems, this font is embedded with the Chief Architect Premier X14 installation but not installed on the system. As 
such, it is available for use in Chief Architect Premier X14 but not in other programs.         
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INTERNATIONAL ALPHABETS

The Rich Text  tool supports unicode alphabets and characters. In order to use a unicode alphabet or characters, the 

appropriate language support must be installed on your computer. See The Text Tools on page 505.         

Special characters can be added to any Rich Text  object by:         

 l Copying and pasting the character from another application;         
 l Copying and pasting the character from the Windows Character Map;         
 l Using the Mac Character Viewer;         
 l Typing the keystroke associated with the character.         

See Copying and Pasting Text on page 523.         

CHARACTER SIZE

Rich Text , Text , Callouts , Markers , Schedules , and dimension numbers can be sized to 1/128” 

accuracy (0.078125 mm). See Text Style Panel on page 547.          

These objects use CAD Style Font Sizing, which specifies text size as the measurement from the baseline to the topmost 
part of the capital letter A, as in most CAD programs.         

In legacy files migrated into Version X14, an additional Legacy Compatible Size option will be available for some objects 
if it was specified in the original program version. When this method is used, text size is based on information stored in the 
font that is then modified to approximate the specified Character Height.         

Rich Text  objects have two font sizing methods to choose from: CAD Style Font Sizing and a method similar to most 

word processing applications, where size is based on information stored in the font. See Options Panel on page 513.         

MISSING FONTS

If you open a plan or layout file that uses a font that is not installed on the current computer, the program will give you an 
opportunity to replace it in the Replace Fonts dialog. 

The table lists all missing fonts and how they will be replaced. 
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 l Click on a font name in the list to select it. Use the Shift or Ctrl key to select multiple fonts. See Shift and Ctrl Select 
on page 217. 

 l Select a replacement font from the Replace With drop-down list, or leave “No Change” as the selection to maintain 
the file’s association with the missing fonts. 

 l A preview of the selected font displays below the Replace With list.

If you do not plan to return the file to the computer where it was created, you may want to replace missing fonts with the 
fonts you normally use. On the other hand, if you do intend to return the file, you may prefer to not replace any missing 
fonts. 

 

The Text Tools
Select CAD> Text to access the Text Tools. These tools are available in plan view, in cross section/elevation views, 
in CAD Details, and in layout files.         

  The Rich Text tool is used to create text objects. See Creating Text Objects on page 505.             

  The Text tool is used to create simple text objects with a single font and style format, or with Tab-delimited 
columns. It is not as flexible as the Rich Text tool; however, it was the tool used to create text in Chief Architect 

X1 and prior. See Creating Text Objects on page 505.             

You can convert simple Text to a Rich Text object by clicking 
the Convert to Rich Text edit button. See Convert to Rich Text 

on page 521.

  The Text Line with Arrow tool is used to connect text and another object with an arrow. See Text Arrows on 
page 528.             

  The Leader Line tool places either a Text or Rich Text object with an arrow attached. See Leader Line on page 
528.             

  The Callout tool is used to place callouts. See Callouts on page 530.             

  The Marker tool is used to place markers for Level Lines, Test Borings and Point Markers. See Markers on 
page 538.             

  The Note tool is used to create callouts that are associated with a Note Schedule. See Notes, Note Types, and 
Note Schedules on page 542.             

  The Text Macro Management tool allows you to create and manage text macros in the current file. See Text 
Macro Management Dialog on page 1401.             

  The Note Type Management tool allows you to manage the different types of Notes available in the current file. 
See Note Type Management Dialog on page 543.             

 

Creating Text Objects
Text, callouts and markers can be created in plan view, in cross section/elevation views, in CAD Details, and on layout 
pages. See View Windows on page 149. 

Notes can be created in these views as well. In addition, they can be created in camera views. See Notes, Note Types, and 
Note Schedules on page 542.          

Once created, text, callouts and markers can be selected and edited in a variety of ways. See Editing Text on page 518. 
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To create Rich Text
 1.  Select CAD> Text> Rich Text . 

 2.  Click and drag to draw a rectangle defining the area of the text object.           

 l The rectangle that you drag must be at least as tall as the default line spacing for a single line of text. See Rich Text 
Specification Dialog on page 507.          

 l When you release the mouse button, a blank text box is created with an active cursor, ready for you to type.          

 3.  Type or paste the desired text into the Text Field. If the program identifies any spelling issues, they will be 
underlined in red.

 4.  Use the options on the Edit Bar, which displays above the Text Field, to change the font, style and size of any 
portion of the text. See Editing Text on page 518.

 5.  When you are finished, simply click outside the Text Field to close it and the Edit Bar. The Rich Text  tool 

remains active, so you can click and drag to create additional Text objects if you wish.         

Note: If you do not type anything in the Text Field, a text object will not 
be created when you click outside it.

To create Text
 1.  Select CAD> Text> Text .           

 2.  Click where you want the upper left corner of the text to be located. The Text Specification dialog opens. See Text 
Specification Dialog on page 514.          

 3.  Enter text and click OK.          

Up to 32,000 characters can be inserted in one Text object. It is usually better to use several smaller Text objects when a lot 
of text must be inserted.          

Rich Text , Callouts ,              Markers , and Notes  can also be created              in the same manner as Text : by clicking 

where you want the upper left corner of the object to be created. The object’s specification dialog will open: enter text and 
click OK.         

You can also create lines with arrows connecting the text that you create to items in the drawing. See Text Arrows on page 
528. 

PLACING TEXT FROM THE LIBRARY

Rich Text, Text, Callouts, Markers, and Notes can be added to the User Catalog in the Library and then placed into 
plans and layout files as needed. See Add to Library on page 973 and Replace From Library on page 983.    

TEXT AND CAD OBJECTS

Text can be used in combination with CAD objects to create legends, title blocks, and a wide variety of other details. See 
CAD Objects on page 294 and Layout on page 1338.          
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A selection of legends and other CAD blocks that use both text and CAD can be found in the Library Browser. See The 
Library on page 961.          

 

Displaying Text Objects
As with other types of objects, the display of Text objects is controlled in the Layer Display Options dialog.  By default, text 
objects are located on layers with “Text” at the beginning of the layer name, such as “Text, Callouts”. See Layer Display 
Options Dialog on page 183. 

Text objects can only be displayed in views where text can be created. 

The display attributes of each individual text object can be controlled independent of the layer it is placed on. See Rich Text 
Specification Dialog on page 507. 

CUSTOM TEXT LAYERS

Text objects do not need to be shown at all times. For instance, electrical notes will be included with the electrical plan, but 
are not needed in the framing plan. You can create custom layers and layer sets to control the display of text and other 
objects. See Layer Sets on page 186 and Layer Display Options Dialog on page 183.          

To move text to a different layer, select the text object or group of text objects, then click the Open Object  edit button 

to open the Text Specification dialog. The selected text object’s layer can be changed on the LINE STYLE panel. See Line 
Style Panel on page 310.          

TEXT ARROWS

If a text arrow is attached to a Text  object and they are on the same layer, changing the layer of the text will also 

change the layer of the attached text arrow. However, changing the layer of the text arrow will not change the layer of the 
text it is attached to. See Layer Attributes on page 181.          

NOTES

Unlike other text objects, Notes can be created and display in camera views. See Notes, Note Types, and Note Schedules on 
page 542.          

 

Rich Text Specification Dialog
The Rich Text Specification dialog opens if you select one or more Rich Text objects, then click the Open Object 
edit button.

This dialog also opens when you select the Rich Text  tool and then click once in the drawing area. 

When Rich Text objects are group-selected, the text content, zoom factor, and Paragraph Options cannot be changed, but 
everything else can be. 

The Rich Text Specification dialog is similar to the Rich Text Defaults dialog but affects the selected text rather than all 
subsequently created text objects. Also, the name of the Saved Default being edited will display in the title bar of the 
defaults dialog. See Text Defaults and Preferences on page 502.         
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Note: Text objects have a different specification dialog. See Text 
Specification Dialog on page 514.

TEXT PANEL

The settings on the TEXT panel allow you to type the selected Rich Text object’s content and control many aspects of its 
appearance, including its font, size, color and style.

You can specify the appearance of the text before typing, and can also select and change the attributes of all or portions of 
the text content after it is typed. To change text that already exists, simply highlight it using the mouse and/or the Shift + 
arrow keys and then make any needed changes to its attributes. 

Note: If you do not type anything in the text field on this panel when 
creating a new object, no object will be created when you click OK. On 
the other hand, if you remove the text from an existing object and click 
OK, an empty text box will result.
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Edit Bar

Use the options on the Edit Bar, which displays above the Text Entry field, to change the font, size, and style of the text.             

The Edit bar also displays in the drawing area above the Text object when you click the Edit Text in Place  edit button. 

See Editing Text on page 518.

Select the desired options before typing to affect the text as it is typed, or select some or all of the text and then specify 
which options to apply to it.

 l Select a Font from the drop-down list.

 l Specify the Text Size in drawing units. 

 l Click the Print Size  button to open the Printed Size Input dialog. See Scaling Text on page 521.          

 l Click the Color  button to specify the color of the selected or subsequently typed text. See Color Chooser/Select 

Color Dialog on page 204. If Layer Color Text is checked on the APPEARANCE panel, any custom colors specified 
here are lost. See Appearance Panel on page 511.

 l Click the Bold  button to specify the selected text as bold. The Ctrl+B hotkey can also be used.

 l Click the Italic  button to specify the selected text as italic. The Ctrl+I hotkey can also be used.

 l Click the Underline  button to specify the selected text as underlined. The Ctrl + U hotkey can also be used.

 l Click the Strikethrough  button to specify the selected text as stricken-through.

 l Click the Uppercase  button to display the selected text in all capital letters.

 l Click the Align Left , Align Center , or Align Right  button to specify how the selected text is aligned.

 l Click the Paragraph Options  button to specify the selected paragraph’s alignment, spacing and bullets or 

numbering in the Paragraph Options dialog. 

 l Click the Spell Check  button to check the spelling in the selected text object. See Spell Check on page 526.          

 l Click the Insert Macro  button to place a Text Macro at the location of the cursor. Not available when multiple 

text objects are selected. User Defined macros are only available when the selected Rich Text object points to an 
eligible object using a Leader Line or Text Line with Arrow. See Text Macros on page 549.           

 l Specify the Zoom factor of the selected text by typing a percentage value in the text field or clicking the up/down 
arrows. This setting only affects the text as it appears in this dialog.

Note: Some fonts cannot be drawn at certain zoom factors. When this 
is the case, the appearance of the text will not change.
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Text Entry Field

Type or paste text in the Text Entry field. See Copy, Cut and Paste on page 522.

 l Depending on the current Preferences  settings, pressing the Enter key either forces a new line in the text box or 

closes the dialog. A carriage return can also be added by typing Shift + Enter or Ctrl + Enter. See Text Panel on 
page 106.          

 l Right-click in the Text Entry field to access a contextual menu from which you can select Undo, Redo, Cut, Copy, 
Paste, Spell Check and Select All. See Contextual Menus on page 19. 

 l To edit text in the entry field, click and drag to highlight any portion of it and then use the tools on the Edit Bar as 
needed.

 l If the program identifies any spelling issues, they will be underlined in red.          

PARAGRAPH OPTIONS DIALOG

 
Alignment

Specify the Alignment of the selected paragraph(s). See Aligning Text on page 522.

 
Line Spacing

Specify the Line Spacing of the selected paragraph(s). 

 l Click the radio button beside Single, 1.5 Lines, Double or User Specified.

 l If you select User Specified Line Height, type the desired height in the text field. For best results, this value should 
be at least as much as the largest text size used in the selection. 
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Margins

Specify the appearance of the selection’s side Margins, as measured in from edges of the text box. Only positive Margin 
values can be used. 

 l Specify the Indent, which is measured from the left side margin. A negative value can be used if a left Margin has 
been specified.

 
Bullets

Specify the appearance of Bullets and numbering in the selection. 

 l Select the desired bullet, numbered, or lettered Type from the drop-down list.

 l Specify the Number Prefix, which are any characters that you would like to display before the number or letter. 
Does not affect paragraphs using circle or square bullets.

 l Specify the Number Suffix, which are any characters that you would like to display after the number or letter and 
before its actual text. Does not affect paragraphs using circle or square bullets.

APPEARANCE PANEL

Leader Lines  and Text Lines with Arrows  use the same default layer as Rich Text, so they share the same default 

color, line weight and line style. See Layers on page 180.         
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  Layer Information

 l Check Default to place the selected object on the default Text layer.       

 l Click the drop-down list to select from all layers available in the plan or layout file.       

 l Click Define to open the Layer Display Options dialog and select, modify, or add a new layer. See Layer Display 
Options Dialog on page 183.       

 l Check Layer Color Text to apply the color assigned to the selected Layer to the text on the TEXT panel. See Text 
Panel on page 508.

Note: If you change the color of some or all of the selected object’s text, 
Layer Color Text will become unchecked. If it is checked again, the 
custom color(s) will be removed. 

 
Border

 Check Border to display a border around the selected text object and enable the settings that follow.         

 
Fill

Check Fill to display a fill color within selected text object(s) and enable the settings that follow.         

 l Select Custom Color then click the Color bar to use a fill color of your choosing.             

 l Check Use Layer Color to use the color assigned to the text object’s layer as its fill color.             

 l Check Use Background Color to use program’s Background color as the text object’s fill color. See Colors Panel 
on page 102.             

 l Use the Transparency slider bar or text field to control how transparent the fill color is.             

 
Margins

Specify the Top, Bottom, Left, and Right Margins, which are the distance between the text and the border of the selected 
text object(s).         
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OPTIONS PANEL

  Options

 l Check Add an Arrow to add a Text Arrow to the selected text object. It will be attached to the left side of the 
selected object if the text is set to Align Left, or to the right side if it is set to Align Right or Align Center. See Text 
Arrows on page 528.          

 l Check Rotate with Plan to rotate the selected text when Rotate Plan View  is used. If unchecked, the selected 

text is unaffected when Rotate Plan View is used. See Rotate Plan View on page 151. 

Rotate with Plan also affects text in views sent to layout if the layout box is rotated. See CAD and Text in Layout 
on page 1342.           

 l Specify the Layout Page that the selected object(s) is located on. Only available in layout files, but not in the Rich 
Text Defaults dialog in layout. See Layout on page 1338.           

  Origin/Angle

 l Specify the X Position and Y Position of the selected object relative to the origin. See 3D Drafting on page 12.           

 l Specify the Angle of the selected text object. The default value is 0°.          
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Size

Specify the Size of the selected text object.         

 l Specify the Height of the selected text object(s) or check Auto Height to automatically adjust the text object’s 
height to match its contents.          

 l Specify the Width to of the selected text object(s) or check Auto Width to automatically adjust the text objects 
width to match its contents. When Auto Width is used, text extends in a single line rather than wrap.          

 l CAD Style Font Sizing measures text size based on the total height of the capital letter A, as most CAD programs 
do. Uncheck this to instead size text according to information stored with the font, as most word processing 
programs do. See Character Size on page 504.           

 
Drawing Group

See Drawing Groups on page 194.         

 
Bumping

See Bumping/Pushing on page 246.         

 l Check CAD Stops Move to bump the selected object into other CAD or CAD-based objects as it is moved.          

 l Check Wall Stops Move to stop the selected object when it bumps into a wall.           

 

Text Specification Dialog
The Text Specification dialog opens if you select the Text  tool and then click once in the drawing area. It will 

also open when you use the Leader Line  tool if Create Rich Text is unchecked in the Preferences dialog. See 

Text Panel on page 106.         

You can also open this dialog by selecting one or more Text objects or Room Labels, then clicking the Open Object edit 
button. See Editing Room Labels on page 428.          

The Text Specification dialog is similar to the Text Defaults dialog but affects the selected text object rather than all 
subsequently created text. Also, the name of the Saved Default being edited will display in the dialog box title bar. See Text 
Defaults and Preferences on page 502.          

Note: Rich Text objects have a different specification dialog. See Rich 
Text Specification Dialog on page 507.

The Text Specification dialog has the following panels:

TEXT PANEL

The settings on the TEXT panel allow you to type the selected Text object or Living Area Label's content. Text cannot be 
added to a selected room's label, however.          

Note: If you do not type anything in the text field on this panel when 
creating a new object, no object will be created when you click OK. On 
the other hand, if you remove the text from an existing object and click 
OK, an empty text box will result.
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 l Click Insert to choose from a list of special characters and text macros.  User Defined macros are only available 
when the selected Rich Text object points to an eligible object using a Leader Line or Text Line with Arrow. See 
Text Macros on page 549. Not available when the selected object is a Room Label. See Room Labels on page 427.

 l Check Add an Arrow to add a Text Line with Arrow to the selected text object. It will be attached to the left side of 
the selected object if the text is set to Align Left, or to the right side if it is set to Align Right or Align Center. See 
Text Arrows on page 528.          

 l Click the Spell Check button to check the spelling of the text that displays in the Text Entry area. If Spell Check 
finds a word that may be spelled incorrectly, the Check Spelling dialog opens. See Spell Check on page 526. Not 
available when multiple Text objects are selected.           

  Text Entry

 l Enter text in the Text Entry field. This field is available for the Living Area but not for a selected room's label. See 
Room Labels on page 427. 

 l Depending on the current Preferences  settings, pressing the Enter key either forces a new line in the text box or 

closes the dialog. A carriage return can also be added by typing Shift + Enter or Ctrl + Enter. See Text Panel on 
page 106.          

 l Text automatically wraps to a new line without requiring a hard return.          

 l Tabs can be added to the text by pressing the Tab key.          

 l If the program identifies any spelling issues, they will be underlined in red.          

 
Preview

In the Text Specification dialog only, a preview of the selected text object displays on the right. Not available for Room 
Labels. See Dialog Preview Panes on page 22.
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ATTRIBUTES PANEL

  Box/Grid

 l Specify the positions of the selected text object's Tab Stops.

 l In the text field, specify the number of spaces from the left edge of the text box where each new column begins. The 
first column always starts at 0 and is not listed.

 l Check Display Border to turn on the display of a border polyline around the selected object.

 l Check Display Grid Lines to turn on the display of the grid formed by the specified rows and columns.          

  Alignment

 l Select "Left", "Centered", "Right", or "Justified" from the drop-down list.      

  Origin/Angle

 l Specify the X Position and Y Position of the selected object relative to the origin. See 3D Drafting on page 12.           

 l Specify the Angle of the selected text object. The default value is 0°.          
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  Size

 l Specify the Height of the selected text object(s) or check Auto Height to automatically adjust its height to match its 
contents.          

 l Specify the Width to of the selected text object(s) or check Auto Width to automatically adjust its width to match 
its contents. When Auto Width is used, text extends in a single line rather than wrap.          

 l Specifying a Height and/or Width of 0 sizes the text box as small as the text within it allows without turning on the 
Automatic behavior.           

  Margins

 l A default Left and Right margin is applied. Top and Bottom margins are measured relative to the line height and 
may not extend to the text box completely when given a value of 0.          

 
Preview

In the Text Specification dialog only, a preview of the selected text object displays on the right. Not available for Room 
Labels.         

LINK PANEL

Hyperlinks can be associated with web pages or files saved on your computer. If a selected Text object has a hyperlink 
specified, you can click the Follow Hyperlink  edit button to open the linked web page or file.           

  Hyperlink

 l Type a web page address or the pathname of a file on your computer in the text field.           

 l Click the Browse button to select a file on your computer and add its pathname to the text field above.           

 l Click the Test Link button to confirm that the address or pathname in the text field is associated with a web page or 
available file.           

Chief Architect automatically adds the http:// prefix for links 
that begin with "www" when Test Link is clicked.

 
Preview

A preview of the text entered on the TEXT panel displays on the right. Not available for Room Labels.              

517



Chief Architect Premier X14 Reference Manual - Editing Text

To use a hyperlink
 1.  Select the text object.          

 2.  Click the Follow Hyperlink  edit button to activate the link.          

LINE STYLE PANEL

The LINE STYLE panel is found in the specification dialogs for many different objects. For more information, see Line Style 
Panel on page 310.          

FILL STYLE PANEL

For information about the Fill Styles on page 197.          

TEXT STYLE PANEL

The TEXT STYLE panel is available for a number of objects in the program and control the appearance of the selected 
object’s text. See Text Style Panel on page 547.           

DIMENSION FORMAT PANEL

The DIMENSION FORMAT panel is available in the Room Label Defaults dialog and allows you to control the format of the 
portion of the room label that describes the room’s size. For information about these settings, see Displayed Line Length 
Dialog on page 297.   

 

Editing Text
Once created, Rich Text  objects can be selected individually or as a group and edited using the edit handles, the Edit 

Toolbar buttons, and their specification dialogs. See Rich Text Specification Dialog on page 507.

Text  objects can be selected and edited much the way Rich Text objects can; however, there are a few differences 

which are described here.

A customized text object can be added to the Library for future 
use. See Add to Library on page 973.

Text objects can be edited using a variety of methods:         

Callout and Marker editing are described separately. See Editing Callouts on page 531 and Editing Markers on page 539.         

EDITING TEXT ATTRIBUTES

Most text attributes, including the font, size, style, and the content itself, are edited in the Rich Text and Text Specification 
dialogs.

In order to edit the attributes of an existing Rich Text object, you must select some or all of the text before making changes. 
See Text Panel on page 508. 
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To edit Rich Text attributes
 1.  Select a Rich Text object and click the Open Object  edit button.

 2.  On the TEXT panel of the Rich Text Specification dialog, click and drag to select some or all of the text typed into 
the Text field. 

 3.  With some or all of the text selected, change any of the attributes available along the top of the panel, including the 
font, size, color, and style.

 4.  As changes are made, the selected text updates. Only the selected text is modified.

Text objects do not support multiple fonts or other attributes in the same text object. When you choose an attribute, it is 
applied to all characters in the text object. 

USING THE EDIT HANDLES

A selected Rich Text or Text object has the same edit handles as other box-based objects with one addition: the Add Text 
Line with Arrow handle.
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Click and drag the diamond-shaped Add Text Line with Arrow handle in any direction to draw a Text Line with Arrow that 
is snapped to the selected text object at its tail end. You can also right-click and drag to draw multiple line segments. See 
Text Arrows on page 528 and To continuously draw by right-clicking on page 169.

As a text box’s width is made narrower or wider using an edit handle, its height may increase or decrease so that none of the 
text becomes hidden. The opposite is not true, however: a text box’s height cannot be resized smaller than the height of the 
rows of text it currently contains, plus its margins.

Depending on the active Edit Behavior , the text box and the characters within it may or may not resize together when a 

corner edit handle is dragged. See Defaults, Preferences, and Edit Behaviors on page 208.         

 l If Resize  editing is enabled, both the text object and the font resize when a corner edit handle is dragged.         

 l If Default  or Concentric  editing is enabled, the text box resizes, but not the font size.         

 l If Fillet  editing is selecting, the corners become rounded and the font size does not change. See Behaviors Panel 

on page 120.         

When text is resized using the edit handles, there is a “sticky 
point” at the natural size of the text box. Hold down the Ctrl key 

while resizing to override this behavior. 

EDIT TEXT IN PLACE

The contents and appearance of text objects created with the Rich Text  tool can be edited directly in the drawing 

area using the Edit Text in Place edit tool.         
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To use Edit Text in Place
 1.  Select a Rich Text object and click the Edit Text in Place  edit button.         

 l The text appears as it did when it was first created: inside a text field with the Edit Bar above. See To create Rich 
Text on page 506.         

 2.  Click inside the Text Field to type or select any of the existing text.         

 3.  Use the tools on the Edit Bar to edit any or all of the text as needed. The tools on the Edit bar are the same as those 
on the TEXT panel of the Text Specification dialog. See Text Panel on page 508.         

 4.  When you are finished, click outside the text field to close it and the Edit Bar.         

CONVERT TO RICH TEXT

Text objects cannot be edited to the same degree that Rich Text can. You can, however, convert a selected simple 
Text object to Rich Text by clicking the Convert to Rich Text  edit button. Most attributes of the selected 

simple Text object are retained; however, columns created using the Tab key are not. See Tab Spacing on page 523.         

USING THE EDIT TOOLS

A selected Rich Text or Text object can be edited in a variety of ways using the buttons on the Edit Toolbar. See The Edit 
Toolbar on page 135. 

The Match Properties  and Apply Properties  tools can be used to apply selected attributes of a selected text object 

to other objects in the current view. See Matching Properties on page 286.

RESIZING TEXT

Both the border of a text object and the characters it contains can be resized.         

The border of a text object can be resized using its edit handles or by specifying the Height and Width in its specification 
dialog.         

The default character height of Rich Text  and Text objects can be specified as can the character height for individual 
objects, in their specification dialogs. See Text Defaults and Preferences on page 502.

Character height can be measured in either of two ways. See Character Size on page 504.          

SCALING TEXT

As with the size of other objects, text size is subject to the current drawing scale specified in the Page Setup dialog. See 
Drawing Sheet Setup Dialog on page 1372.         

To determine the Height in drawing units that is needed to produce text of a specific size when printed, use the Print Size 
Calculator dialog.         

To use the Print Size Calculator dialog
 1.  Select the text object or Text Style that you wish to scale and click:         

 l The Print Size  button on the TEXT panel of the Rich Text Specification dialog. See Text Panel on page 508.         

 l The Scale button on the TEXT panel of a variety of specification dialogs. See Text Style Panel on page 547.         
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 l The Scale button in the Text Style Defaults dialog.         

 2.  In the Print Size Calculator dialog:         

 l Confirm the desired Printed Scale.         

 l Enter the Desired Print Size of the text.         

 l The Text Height in View required to produce the Desired Print Size displays here for reference.         

 3.  Click OK to return to the previous dialog. The Character Height value now equals that of the Text Height in View.         

Generally, the Printed Scale does not need to be changed in the Print Size Calculator dialog unless you intend to send the 
current view to layout at a different drawing scale. See Sending Views to Layout on page 1343.         

ALIGNING TEXT

Text can be aligned in a number of ways.         

 l The text content of a text object can be aligned to the left, right, center or justified in the Rich Text Specification 
dialog. See Text Panel on page 508.

 l The text content of a text object can be also be aligned by clicking the Align Left , Align Right , Center , 

or Justify  edit button.             

 l The center points of text objects can be aligned with one another by assigning them the same X and/or Y Position. See 
Attributes Panel on page 536.           

 l Text objects can be aligned by bumped them against a CAD line or CAD based object such as a roof plane. See 
Bumping/Pushing on page 246.           

A variety of other alignment methods are also available. See Aligning Objects on page 249. 

The text in the columns of a schedule can also be aligned. See Editing Schedules on page 698.

COPY, CUT AND PASTE

Copy, Cut and Paste of text into and out of the text specification dialogs can be accomplished using keyboard hotkeys:

 l Press Ctrl + X to Cut the selected text and save it to the system clipboard.
 l Press Ctrl + C to Copy the selected text and copy it to the system clipboard.
 l Press Ctrl + V to paste your last cut or copied selection in a new text object.

For more, see Copying and Pasting Objects on page 171.         

Copy, Cut and Paste use the system clipboard, making it possible to transfer text between text objects, between Chief 
Architect files, from a plan or layout into another application, or vice versa. See Copying and Pasting Text on page 523.   
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TAB SPACING

The Tab key functions differently in Rich Text and Text objects:        

 l In Rich Text , the Tab key creates a space. CAD Style Font Sizing affects the size of the space created. See 

Options Panel on page 513.         
 l Tab spacing in Text  objects produces columns with widths that can be edited using edit handles.         

To insert tab-spaced text
 1.  Highlight a block of text objects containing tabs from another program or text from the Materials List and press Ctrl 

+ C to copy them to the system clipboard.         

 2.  Return to the plan view, select the Text  tool, and click to place a text object.         

 3.  Press Ctrl + V to paste the copied materials into the text box, then click OK. The text object displays on-screen.         

 4.  Select the text object and note the additional lines with handles separating each column.         

Columns automatically resize to fit the contained text. When a text object is selected, you can use the edit handles that 
display at each column to adjust spacing.         

 

Copying and Pasting Text
The Copy, Cut and Paste commands use the system clipboard, making it possible to transfer text between text objects, 
between Chief Architect files, from a plan or layout into another application such as a text editor or spreadsheet program, or 
vice versa. See Copying and Pasting Objects on page 171.

All or selected portions of the Materials List can also be copied and pasted into a text object, as well as into a word 
processing or spreadsheet program. See Materials Lists on page 1309.         

Cut, Copy, and Paste can also be accessed from the Edit menu of many applications, including Chief Architect. These menu 
commands are not available when the text specification dialogs are open, but you can use the associated hotkeys. 

To Copy, Cut and Paste text
 1.  On the TEXT panel of either text specification dialog or in another program altogether, highlight the text you wish to 

cut, copy or paste.

 2.  Press Ctrl + X to Cut the selected text out of its original location and save it to the system clipboard.

 3.  Press Ctrl + C to Copy the selected text to the system clipboard without removing it from its original location.

 4.  Open the text object or a file in another application and click to place your cursor in the Text field, writing area, or 
spreadsheet cell.

 5.  Press Ctrl + V to Paste the copied text at the location of your cursor.

Bear in mind that when text is copied and pasted, its formatting is not always retained. The results depend on the program or 
type of text object in which the content was created as well as the type of text object into which it is pasted. 
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PASTING INTO TEXT

Text pasted into a simple Text object from another source will not retain its formatting. Instead, the settings for that 
Text  object are always used. See Text Specification Dialog on page 514.           

This is the case even if the text is copied from another Text object unless that object happens to use the same formatting.           

Text pasted into a simple Text object  from a spreadsheet program will retain basic column and row information. Each row 
can only have a single line of text; however, the width of each column can be adjusted. See Tab Spacing on page 523.           

PASTING INTO RICH TEXT

Text pasted into a Rich Text object from another source, on the other hand, will retain most - but not necessarily all - 
of its custom formatting. If a line of text is sufficiently long, however, it may be wrapped automatically when pasted 

into Rich Text. 

To retain the same character size when text is pasted from a word processing program into the Rich Text Specification 
dialog, uncheck CAD Style Font Sizing. See Options Panel on page 513.           

If you want to retain the original color(s) of the text being pasted into a Rich Text object, be sure to uncheck Layer Color 
Text in the Rich Text Specification dialog. See Appearance Panel on page 511.          

Text pasted into a RichText object from a spreadsheet program retains basic column and row information. Column width 
cannot be adjusted as it can in simple Text ; however, as you add or remove text from a cell, row height will increase or 
decrease to accommodate your changes.

PASTING INTO A VIEW

Text can also be pasted directly into a plan view, CAD Detail, or cross section/elevation view. When you use the Paste 
command, a new Rich Text object is created, the text is pasted into that object, and it is selected. In order to see the new 
object, you may need to Fill Window. 

 

Find/Replace Text and Spell Check
Find/Replace Text and Spell Check locate text in Rich Text, Text, Callouts, Markers, CAD blocks, schedule titles and 
headings, and custom labels for objects and rooms. They do not locate text in automatic object labels, default room labels, 
suppressed labels, the Materials List, or in the bodies of schedules, however.          

Find/Replace Text and Spell Check locate text even when an object’s layer is turned off and/or locked.              They can also find 
text in objects on locked layers. See Locking Layers on page 182.         

FIND/REPLACE TEXT

Select Edit> Find/Replace Text to find a particular word or string of text in your plan or layout file and replace it if 
you wish.          
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  Find and Replace

 l Type the string of text that you want to Find in the text field.         

 l Type the string of text that you want the text you find to be Replaced With.          

 l Select the scope of your search from the Searching In drop-down list. Choose “Current View”, “Current File”, “All 
Open Files” or “Selected Objects”.          

 
Search Options

These settings allow you to refine your search.         

 l Check Case Sensitive to distinguish between capitalized and lowercase letters when searching. When unchecked, 
capitalization is ignored while searching. The Replace function is always case sensitive.         

 l When Expand Percent Signs is checked, the program will ignore strings of one or two % signs in a row, which may 
be used to mark up imported text with style commands. Uncheck this to find individual % signs in the search results.
         

 l Check Show in File to open a new view window or go to a new layout page and highlight the object associated with 
the current search Result. When unchecked, the current search Result will only be highlighted if it is located in the 
current view window. See Working in Multiple Views on page 154.          

 l Click the Highlight Color button to specify the color used to highlight the object associated with the current search 
Result.              This color is also used to identify misspelled words using the Check Spelling tool. See Color 
Chooser/Select Color Dialog on page 204.
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Macro Options

These settings control whether macros are included in the search Results. The text of the actual macro are searched See Text 
Macros on page 549.         

 l Select Exclude Macros to ignore macros in the Search.         

 l Select Macros Only to only include macros in the search Results.         

 l Select Include All to include both macros and regular text in the search Results.         

 
Results

The current search results are shown for reference in the field on the left. The location of the associated object, including 
file name, view name, and its object type is stated above the Results field as well. Click a button to perform the associated 
action:         

 l Click Find Previous to find the previous search Results.          

 l Click Find Next to search for additional Results.          

 l Click to Replace the current search Results with the replacement specified above.         

 l Click to Replace All instances of the current search Results found throughout the Searching In scope, selected 
above.          

Although the Find options do not locate text in suppressed 
labels, Replace All will replace that text. See Displaying Labels 

on page 712. 

SPELL CHECK

Select Tools> Checks> Spell Check to open the Spell Check dialog. The Spell Check feature checks each text 
object in the current .plan or .layout file consecutively for spelling errors.         

Spell Check can also be accessed by clicking the Spell Check button in the Rich Text, Text, Note, or  Schedule 
Specification dialog or by clicking the Spell Check  edit button. When accessed in this manner, only the selected object 

is checked for spelling errors. See Editing Text on page 518.
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SPELL CHECK DIALOG

 
Results

Spell Check looks for each word in all open dictionaries. When a word that is not recognized is found, it displays here.         

 l The location that the spelling error was Found in is reported at the top of the dialog for reference.          

 l The text where the error was found displays in the top field for reference. The error itself is highlighted.          

 l Click Ignore to ignore the word in question in all Spell Checks during the current program session. The word will 
not be ignored the next time Chief Architect Premier is launched.           

 l Click Skip to ignore the current instance of the word, but find other instances that may be present.          

 l Click Learn to add the word in question to the User Dictionary. See Chief Architect Premier Data on page 37.           

 l Click Delete to remove the selected word from the text.          

 l Click Replace to replace the word in question with the suggested word, below.          

527



Chief Architect Premier X14 Reference Manual - Text Arrows

 
Suggestions

Spell check displays Suggestions for corrections here. There are two ways to replace a misspelled word:         

 l Type a correction in the field and click the Replace button.          

 l Click on a suggestion to select it, then click Replace to accept it.          

 
Highlight Color

Click the Color bar to specify the Highlight Color for misspelled words when Check Spelling is used. This color is used to 
identify misspelled words in this dialog, text objects with misspelled words in views where an error is found, and text 
objects located using Find/Replace Text. See Color Chooser/Select Color Dialog on page 204.         

When Spell Check is finished checking the text object or file for errors, the Spell Check results window displays.          

Note: Spell Check does not look for duplicate or repeated words. 

 

Text Arrows
Text arrows, which are simply CAD lines with arrows drawn on the “Text” layer, can be used to connect text objects to 
details of interest in your drawing. See Line Tools on page 305. 

There are several ways to create text arrows, and special snapping behaviors to take advantage of.

LEADER LINE

The Leader Line tool places either a Rich Text or a Text object with an arrow attached. This line with arrow can be 
selected and moved like any other line with arrow.         

Note: Leader lines create Rich Text and have two leader line segments by 
default. You can change this in the Preferences dialog. See Text Panel on 
page 106.

To create text with a leader line
 1.  Select CAD> Text> Leader Line .           

 2.  Starting at the point where you want the arrow to point, drag to where you want a bend in the leader line and release 
the mouse button.          

 3.  Click at the point where you want the center of the first line of text to display. The Rich Text Specification dialog 
opens. See Rich Text Specification Dialog on page 507.          

 4.  Enter text and click OK.          

Alternatively, you can click in the same location twice without dragging to create a Rich Text object without a leader.          

If multiple leader lines are specified, click in the same location twice to stop adding leader segments.          
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The initial alignment of text created with the Leader Line tool depends on the direction that the leader line was drawn:          

 l Leader Lines drawn from left to right produce text that is right-aligned.          
 l Leader Lines drawn from right to left produce text that is left-aligned.          
 l Leader Lines drawn from vertically produce text that is center-aligned.          

TEXT LINE WITH ARROW

Text Lines with Arrow can be attached to text, CAD and architectural objects by selecting CAD> Text> Text Line 
with Arrow and then clicking and dragging to draw a line. There is no limit to the number of text lines with arrows 

that can be attached to an object.   

The endpoints of Text Lines with Arrow can be joined to form polylines with corners that can be adjusted using the edit 
handles. See Polylines on page 322. 

A Text Line with Arrow behaves like a Line With Arrow  with one exception: Text Lines with Arrow are initially 

placed on the default Text layer, not the Current CAD Layer. See Layers on page 180.

ADD TEXT LINE WITH ARROW EDIT HANDLE

Rich Text, Text, and Callout objects have a diamond-shaped Add Text Line with Arrow edit handle that you can click and 
drag in any direction to draw a Text Line with Arrow that is snapped to the selected object at its tail end. See Using the Edit 
Handles on page 519 and Editing Callouts on page 531.

TEXT ARROWS AND SNAPPING

Text lines with arrows with the same Line Style and Arrow attributes can be snapped together to form open or closed 
polylines. If two lines with arrows meet within the bounding box of a text object, however, they will not join. This allows 
you to attach multiple, separate text arrows to a single text object. See Editing Line-Based Objects on page 218.

Text lines with arrows can be independent or attached to other objects at both their tail and head ends. Arrows attach to 
closed polyline-based objects along their edges, but can attach to Text or an architectural object anywhere within its 
bounding box in plan view.  

 l When a selected Text Line with Arrow or Leader Line is snapped to an object on either end, its end edit handle will 
display the Selected Edge Handle Fill color. See Colors Panel on page 102.

 l If an attached object is moved, the end of the Line with Arrow will move, as well.
 l When a selected text object is connected to another object using a Text Line with Arrow or Leader Line, a selection of 

Referenced Object macros that report information about that other object will be available to insert into the text. See 
Text Macros on page 549.    

 l If a Leader Line  or Text Line with Arrow  is drawn with its tail end snapped to a text object or another 

Leader Line or Text Line with Arrow, it will be placed on the same layer as the text object and inherit all of that 
layer’s attributes. Regular CAD lines with arrows do not do this. See Layers on page 180.     

 l If a text arrow is attached to text or another object, deleting either the text or the object will also delete the text arrow.

AUTO POSITION ARROWS

If either or both ends of a line with arrow are attached to an object, Auto Position Tail and Auto Position Head will be 
available in the Line Specification dialog. See Arrow Panel on page 312.           

The Auto Position options are designed to prevent lines with arrows from crossing over the text or other objects that they 
are snapped to. These options snap the ends of a line with arrow to predefined points on the object(s) it is attached to. If an 
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attached object is moved, the end of the line with arrow will update so that it is snapped to the closest Auto Position 
location. Similarly, if the line with arrow is moved, rotated, or resized, its end may snap to a new Auto Position location on 
an attached object.          

There are four Auto Position locations on a text object: one at the midpoint of each side. The Auto Position locations on 
other objects varies by object type.           

The following image illustrates the behavior of Auto Positioning. The arrow has the Auto Position Tail option checked, and 
the tail end of the line is snapped to the text object. When the head of the line with arrow is moved, the tail of the arrow 
snaps to different Auto Position locations on the text object, maintaining its connection.

In addition:          

 l If a selected Text Line with Arrow is moved away from an Auto Position location and you check Auto Position Tail, 
the tail will snap to the nearest Auto Position location.           

 l The first segment of a polyline arrow attached to text maintains its angle when Auto Position is off and text is moved.          
 l Auto Position is disabled automatically when an arrow is not attached to one of the auto position locations.          
 l Arcs and splines with arrows can also be attached to text and other objects.          

 

Callouts
To create a callout, select CAD> Text> Callout, then click at the location where you want a callout to be placed in 
plan view, a cross section/elevation view, a CAD Detail, or on a layout page. The Callout Specification dialog 

displays. Make any needed changes and click OK to place a callout. See Callout Specification Dialog on page 535.

Newly created callouts derive their attributes, including their shape and size, from the currently active Saved Callout 
Defaults. See Multiple Saved Defaults on page 79.

Callouts can be used to make connections between information on different pages of your construction documents. See 
Linked Callouts on page 533.

CROSS SECTION LINES

Check the Cross Section Line box in the Callout Specification dialog to add a cross section line with the length, angle, and 
other attributes that you specify. See Attributes Panel on page 536.          
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Callout with Cross Section Line and Section 
Arrow

Cross section lines can be added to any callout shape. You can specify the cross section line's length and angle in the 
Callout Specification dialog, as well as add text above and/or below the line. A cross section line can also be resized as well 
as rotated using the square edit handle located at the end of the cross section line. You can also add an arrow to the end of a 
cross section line that is perpendicular to the angle of that line. See Editing Callouts on page 531, below.         

CALLOUT ARROWS

To add an arrow or “hat” to a callout, select the callout and drag the diamond-shaped handle away from the center of the 
callout. An arrow is created, pointing in the direction you dragged. See Editing Callouts on page 531, below.

Arrows can also be specified in the Callout Specification dialog. See Attributes Panel on page 536.     

You can also add as many CAD Lines with Arrows as you like to callouts. To add a line with arrow to a callout:

 l Select the callout, then click and drag the diamond-shaped Add Text Line with Arrow edit handle located below the 
callout.

 l Select CAD> Text> Text Line with Arrow , then click and drag to create a line with arrow, which can be moved 

or resized as needed.          

See Text Arrows on page 528.

DOUBLE CALLOUTS

Any callout can be specified as a Double Callout in the Callout Specification dialog. See Attributes Panel on page 536.          

To resize the line between the two callout shapes, select the callout and then click and drag the edit handle at the center of 
either callout shape. The arrows on a double callout are always the same on both callouts.           

EDITING CALLOUTS

Callouts can be edited using the edit handles, the Edit Toolbar buttons and the Callout Specification dialog. See Callout 
Specification Dialog on page 535.
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When a callout is selected, it has at least five edit handles. An additional rotate handle displays at the end of the cross 
section line and at the point of each callout arrow, if the callout has any of these specified.

A. Move
 l The Move handle is located at the center of the callout shape. Click and drag this handle to move the callout according 

to the currently active Edit Behavior . 

B. Concentric Resize
 l The small circular Concentric Resize handle displays on the perimeter of the callout shape. If the callout has a cross 

section line, it will be found where that line meets the perimeter. Click and drag this handle to resize the callout 
without moving its center point.

 l If the callout's Size is set to Automatic in its specification dialog, any text displaying inside its shape will also resize 
when this edit handle is used. See Note/Callout Panel on page 545.  

C. Rotate
 l The large triangular Rotate handle displays outside the callout shape perimeter, just past the end of the cross section 

line if one is present. It is used to rotate the callout shape. The callout's text does not rotate along with the shape unless 
the Text Angle is set to Automatic.

D. Extend Cross Section Line
 l The  square Extend handle is at the end of the cross section line, if there is one. Click and drag this handle to change 

the cross section line's length and/or angle.

E. Add Text Line with Arrow
 l The diamond-shaped Add Text Line with Arrow handle is located below the callout shape. Click and drag this 

handle away from the callout shape in any direction to draw a Text Line with Arrow with its tail end snapped to either 
the callout center or the end of the cross section line and the arrow head end snapped to an object of your choosing.

F. Add Callout Arrow
 l The diamond-shaped Add Callout Arrow handle is located just outside the callout shape. Click and drag this handle 

away from the callout shape in any direction to draw a callout arrow, or hat, to the perimeter. See Callout Arrows on 
page 531.

G. Rotate Callout Arrow
 l The small triangular Add Callout Arrow handle is located at the end of each callout arrow, or hat. Click and drag this 

handle to rotate that arrow around the callout shape.
 l Remove an arrow by clicking and dragging this handle towards the center of the callout.
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Linked Callouts
In construction documents, callouts are used to make connections between information on different pages. For 
example, a callout in a plan view can mark the location where the information in a detail drawing is relevant. That 

callout will include an identifier for the detail drawing and may also report the page where that drawing can be found. 
Meanwhile, a similar callout in or near the detail drawing will report its identifier along with the page with the plan view 
showing where its information is relevant. 

Callout with Cross Section Line and Section 
Arrow

In Chief Architect, you can add this information and help ensure that it stays current using Linked Callouts.

CREATING LINKED CALLOUTS

To link a callout to a view or a layout page, select it and click the Link View  edit button. A selected callout can also be 

linked to a view or a layout page in its specification dialog. See Link Panel on page 538.

There are several things you should do in order to use Linked Callouts:

 l The file in which the callout is created must be saved. If it links to a view in a different file, that file must also be 
saved. See Saving Plan and Layout Files on page 40.

 l Set up your layout file to include Page Labels with a page numbering convention that meets your needs. See Layout 
Page Information on page 1363.

 l Create, save, and assign names to the views that you want to link using callouts:
 l Plan Views on page 150
 l Cross Section/Elevation Views on page 1090
 l CAD Details on page 340

 l Send these views to layout. See Sending Views to Layout on page 1343.
 l Specify callouts for the layout box labels of section views and CAD Details sent to layout and link them to the page in 

layout where a plan view referencing them is found. See Layout Box Specification Dialog on page 1354.
 l Alternatively, you can add Callouts to section views and CAD Details themselves and link them to the page in layout 

where a plan view referencing them is found. See Callouts on page 530.

 l By default, cross section/elevation views are represented in plan view using a callout that has a label and - if the view 
is sent to layout, it will also report the layout page it was sent to. See Camera Labels and Callouts on page 1098.

 l CAD Details are not represented in plan view automatically, but you can add a Callout, link it to a CAD Detail view, 
and set it up to report that view's name and the layout page it was sent to.

By default, cross section/elevation views are represented in plan view using a round callout shape that has a label and - if 
the view is sent to layout, it will also report the layout page it was sent to.
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CAD Details are not represented in plan view automatically, but you can place a Callout in plan view, link it to a CAD 
Detail view, and set it up to report that view's name and the layout page it was sent to.

You can also direct a camera view to report the layout page it is sent to using the %layout_page_label% macro.

CAD DETAILS AND PLAN VIEWS

One application for linked callouts is creating an association between a detail drawing and a location in a plan view where 
that information is relevant.

To create a Linked Callout in plan view
 1.  Select CAD> Text> Callout , then click to place a callout.

 2.  In the Callout Specification dialog, which opens next, go to the LINK panel, then:

 l Click the Link button.

 l If the current file is unsaved, you will be prompted to save it.

 l In the Link View dialog, expand the "CAD Details" folder under the current plan's file name, click on the name of 
the view you want to link to, and click OK.

 3.  On the CALLOUT panel of the Callout Specification dialog:

 l Click the Insert button to the right of the Callout Label field, mouse over "Object Specific", and select %linked_
view_name%.

 l Click the Insert button to the right of the Text Below Line field, mouse over "Object Specific", and select 
%linked_view_layout_page_label%.

 4.  Click OK to create a Callout that reports the name of a CAD Detail as well as the layout page it was sent to. 

 5.  If the CAD Detail in question has not been sent to layout, the Text Below Line will be blank. Open the CAD Detail 
view and send it to layout. See Sending Views to Layout on page 1343.

When using Linked Callouts, consider assigning CAD Details 
names that consist of a single capital letter.

LAYOUT BOX LABELS

Linked Callouts can also be used in layout box labels. See Layout Box Borders and Labels on page 1349.

To create a Linked Callout layout box label
 1.  If you have not done so already, open the plan view where the Linked Callout was created and send it to layout.

 2.  Go to the layout page where the CAD Detail was previously sent to layout, select its layout box, and click the Open 
Object  edit button.

 3.  On the LABEL panel of the Layout Box Specification dialog, select Use Callout, then click the associated Edit 
button.

 4.  On the CALLOUT panel of the Callout Label Specification dialog:

 l By default, the Callout Label uses the %referenced_view_callout_label% macro. This macro reports information 
for camera views, but not plan or CAD Detail views.
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 l Delete the %referenced_view_callout_label% text and replace it with %automatic_label%, which reports the view's 
name.

 5.  On the ATTRIBUTES panel, 

 l The Text Above Line uses %automatic_label% by default.

 l Delete the %automatic_label% text and replace it with a short, descriptive name for the detail.

 6.  On the LINK panel, link the view to a layout page in the current file with a plan view where a Linked Callout 
references the selected detail:

 l Click the Link button.

 l If the current file is unsaved, you will be prompted to save it.

 l In the Link View dialog, expand the Pages" folder under the current layout's file name, click on the page you want 
to link to, and click OK.

RELINKING CALLOUTS

There are a couple of ways to relink a Linked Callout to a different view. One way is to select it and click the Link 
View edit button to open the Link View dialog. See Link View Dialog on page 51

You can also relink a callout to a view in the Callout Specification dialog. See Link Panel on page 538.

If you want to relink all references to a particular plan file so they refer to equivalent views in a different plan, use the 
Referenced Plan Files dialog. See Referenced Plan Files Dialog on page 52.   

 

Callout Specification Dialog
To open the Callout Specification dialog, select a Callout and click the Open Object edit button. This dialog also 
displays when a new Callout is created using the Callout  tool. See Callouts on page 530.

The Callout Specification dialog is similar to Callout Label Specification dialog, which allows you to create callout labels 
for layout views. See Layout Box Borders and Labels on page 1349.

This dialog is also similar to the Callout Defaults dialog but affects the selected callouts rather than all subsequently created 
callouts. Also, the name of the Saved Default being edited will display in the title bar of the defaults dialog. See Text 
Defaults and Preferences on page 502.

CALLOUT PANEL

For information about the settings on this panel, see Note/Callout Panel on page 545.
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ATTRIBUTES PANEL
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Cross Section Line

Check Cross Section Line to apply a cross section line to the selected callout and enable the settings that follow.                 

 l Check Double Callout to specify two identical callouts connected by the cross section line. Only available when 
Display is checked.            

 l Select the cross section line’s line Style from the drop-down list or by clicking the Library button. When By Layer 
is checked, the line style specified in the Layer Display Options dialog is used. See  Line Styles on page 200.

 l Specify the Weight of the cross section line or check By Layer to use the line weight specified in the Layer Display 
Options dialog.     

 l Specify the Length of the cross section line.     

 l Specify the Relative Angle of the cross section line. This setting is not absolute: rather, it is measured relative to the 
Shape Angle of the callout object.     

 l When Auto Adjust Text Direction is checked, label text is oriented relative to the bottom or the right side of the 
view window, depending on the cross section line's angle. When unchecked, label text is oriented relative to the 
cross section line, regardless of its angle.     

 l Specify the Text Above Line, which is positioned above the cross section line.      

 l Click the Insert button to the right of the Text field to choose from a list of special characters and text macros. See 
Text Macros on page 549.     

 l Specify the Text Style of the Text Above Line. When Match Callout is checked, the Text Above Line uses the 
Main Text Style used by the text inside the callout shape; uncheck this box to select a Text Style from the drop-
down list or to click the Define button to open the Saved Text Styles dialog. See Text Styles on page 547.     

 l Specify the Alignment of the Text Above Line: "Toward Callout", "Centered", or "Away from Callout".     

 l Text Below Line can also be specified, along with its Text Style and Alignment. These options are the same as for 
the Text Above Line with one exception: a "Match Text Above" Alignment option.

  Callout Arrows

 l Specify whether the arrows are Small or Large.           

 l Check Filled to specify arrows with a solid fill. When unchecked, arrows are unfilled.          

 l Specify the Color of the callout's arrow(s): check By Layer to use the color specified in the Layer Display Options 
dialog or click the Color bar to choose an arrow color. See Color Chooser/Select Color Dialog on page 204.          

 l Specify the Number of Arrows. 

 l The angle of each arrow can be set using the callout's edit handles. See Editing Callouts on page 531.

 
Preview

A preview of the selected callout displays on the right. See Dialog Preview Panes on page 22.         

LINE STYLE PANEL

The LINE STYLE panel is found in the specification dialogs for many different objects. For more information, see Line Style 
Panel on page 310.          

Additional attributes for the cross section line and arrows can be specified on the Attributes Panel on page 536.
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SECTION ARROW PANEL

The settings on the SECTION ARROW panel are also found on the ARROW panel in the specification dialogs for a variety of 
different objects. For more information, see Arrow Panel on page 312.

MAIN TEXT STYLE PANEL

The settings on the MAIN TEXT STYLE panel control the appearance of the selected callout's Label and its Text Below Line, 
which can be specified on the CALLOUT panel. See Note/Callout Panel on page 545.

The Text Style of the text above and below the cross section line, if present, can be specified on the Attributes Panel on 
page 536.

For information about the settings on this panel, see Text Style Panel on page 547.           

LINK PANEL

The settings on the Link panel allow you to link the selected callout to a particular view and use text macros to report 
information about that view, such as its name, in the callout's text. See Linked Callouts on page 533.

 
Link Information

The File Name, View Name, and View Type of the view currently linked to the selected callout are reported here, along 
with page number and page label of the view's linked Layout Page. See Linked Callouts on page 533. 

 l Click the Link button to create a link between the selected callout and a saved view or layout page in an open file, 
or click the Relink button to replace the existing link with a different one.

 l Click the Unlink button to remove the existing link from the layout without replacing it.

 
Preview

A preview of the selected callout displays on the right. You can use macros to report information about a linked view in the 
Callout Label, Text Below Line, and in the text above and below the cross section line. See Dialog Preview Panes on page 
22.    

 

Markers
To create a marker, select CAD> Text> Marker and click at the location where you want it to be placed. The 
Marker Specification dialog opens.               See Marker Specification Dialog on page 540.

538



Chief Architect Premier X14 Reference Manual - Markers

Markers for Level Lines, Test Borings and Point Markers can be placed in plan view, cross section/elevation views, as 
well as CAD Details.

You can also place a framing reference marker using Build> Framing> Framing Reference . Framing Reference 

Markers should only be placed in plan views. See Framing Reference Markers on page 890.          

EDITING MARKERS

Markers can be edited using the edit handles, edit toolbar and Marker Specification dialog. See Marker Specification Dialog 
on page 540.

When a marker is selected, it has four edit handles.

A. Move
 l The Move handle is located at the center of the callout shape. Click and drag this handle to move the callout according 

to the currently active Edit Behavior . 

B. Concentric Resize
 l The small circular Concentric Resize handle displays on the perimeter of the callout shape. If the callout has a cross 

section line, it will be found where that line meets the perimeter. Click and drag this handle to resize the callout 
without moving its center point.

 l If the callout's Size is set to Automatic in its specification dialog, any text displaying inside its shape will also resize 
when this edit handle is used. See Note/Callout Panel on page 545.

C. Extend Cross Section Line
 l The  square Extend handle is at the end of the cross section line, if there is one. Click and drag this handle to change 

the cross section line's length and/or angle.

D. Rotate
 l The large triangular Rotate handle displays outside the callout shape perimeter, just past the end of the cross 

section line if one is present. It is used to rotate the callout shape. The callout's text does not rotate along with the 
shape unless the Text Angle is set to Automatic.

A customized marker can be added to the Library for future use. 
See Add to Library on page 973.

POINT MARKERS AND DIMENSIONS

There are a number of scenarios in which Markers may be created in conjunction with dimension lines. These Point Markers 
derive their initial attributes from the               currently active Saved Marker Default and can be selected and edited:         

 l When the Point to Point Dimension  tool is used to draw a dimension line and an object is not available to snap to 

at either the start or end point, a Point Marker will be automatically created and the dimension line will locate it. See 
Point to Point Dimensions on page 478.           
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 l Dimensions drawn in a cross section/elevation view may locate Cross Section Lines that represent objects rather than 
the objects themselves. When this occurs, Point Markers will also be placed and the dimension lines will locate them. 
See Cross Section Lines on page 1109.           

 l If a dimension line is copied independent of the objects it locates, the pasted dimension line will locate Point Markers. 
See Copying and Pasting Dimension Lines on page 485.          

In addition, Auto Story Pole Dimensions  and other vertically-oriented dimension lines in cross section/elevation views 

can display Elevation Markers along their extension lines. These markers are not individually editable but inherit their 
attributes, including marker Type, from the Saved Marker Defaults specified in the Dimension Line Specification dialog. 
See Elevation Markers on page 483.          

 

Marker Specification Dialog
To open the Marker Specification dialog, select a marker and click the Open Object edit button.         

This dialog also displays when a new marker is created by clicking in plan view using the Marker  tool.           

The Marker Specification dialog is similar to the Marker Defaults dialog but affects the selected markers rather than all 
subsequently created markers.               The name of the Saved Default being edited will display in the title bar of the defaults 
dialog. See Text Defaults and Preferences on page 502.         

MARKER PANEL

 
Type

Choose a marker Type. Note that Framing Reference Markers  affect the model, while the other marker types are for 

annotation only. See Framing Reference Markers on page 890.
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Line

Specify the Length and Angle of the marker's line and text. For Test Boring and Point Markers, the Length controls the gap 
between marker and text. 

 
Label

Specify the text and alignment of the selected marker’s Label. The label’s text style can be specified on the TEXT STYLE 
panel. See Text Styles on page 547.         

 l When Auto Adjust Text Direction is checked, label text is oriented relative to the bottom or the right side of the 
view window, depending on the cross section line's angle. When unchecked, label text is oriented relative to the 
cross section line, regardless of its angle.   

 l Type the Text which displays above the marker’s line. 

 l Select a text Alignment option from the drop-down list. Only available for Level Line and Framing Reference 
markers. 

 l Toward Marker positions the text next to the marker shape.

 l Centered centers the text along the length of the marker's line.

 l Away From Marker positions the text at the end of the marker's line.

Text Below Line and the related settings below it are only available for Level Line markers.

 l Type the Text Below Line that displays below the Level Line marker’s line, if desired.   

 l Click the Insert button to the right of either Text option to choose from a list of special characters and text macros. 
See Text Macros on page 549.          

 l Specify the Text Style used by the Text Below Line:   

 l When Match Text Above is checked, the Text Below Line uses the same Text Style as the text above the line.   

 l Uncheck this box, then select a different Text Style from the drop-down list.   

 l Select a text Alignment option for the Text Below Line from the drop-down list. "Match Text Above" is selected by 
default.         

 
Size

Specify the Size of the selected marker.         

 l Specify the Marker Radius, which is the distance from the marker’s center to the edge of its filled shape.          

 l In a cross section/elevation view, specify the Height of the marker, relative to 0. This setting is also available in plan 
view but does not affect the marker’s position.               This value will display in the Label when a height macro is entered in 
either Label text field. See Detailing Cross Section/Elevation Views on page 1092.         

 
Preview

A preview of the selected marker displays on the right. See Dialog Preview Panes on page 22.          
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LINE STYLE PANEL

The LINE STYLE panel is found in the specification dialogs for many different objects. For more information, see Line Style 
Panel on page 310.          

Additional attributes for the cross section line and arrows can be specified on the ATTRIBUTES panel. See Attributes Panel 
on page 536.         

TEXT STYLE PANEL

The settings on the TEXT STYLE panel control the appearance of the selected object’s text. For more information, see Text 
Style Panel on page 547.           

 

Notes, Note Types, and Note Schedules
Notes are a special type of callout that link directly to a line item in a Note Schedule. Notes can be created for a 
variety of purposes, such as General Notes and Framing Notes. See Note Type Management Dialog on page 543, 

below.         

Notes are typically used in plan view but can also be created in CAD Details, cross section/elevation views, and camera 
views. Like other schedules, it is recommended that Note Schedules be placed in CAD Details; however, they can also be 
placed in plan and cross section/elevation views. See CAD Details on page 340.         

A Note created in plan view can be seen in camera views, and vice versa, provided that its layer is turned on. In contrast, a 
Note created in a cross section/elevation view only exists in that view. If the note’s position in plan view puts it behind one 
or more surfaces in a camera view, it will be partially transparent.         

Notes created in either plan or camera view can be included with exported Chief Architect 3D Viewer models. See Export 
Chief Architect 3D Viewer File on page 1223.         

Note callouts are created using the settings in the Note Defaults dialog. Once created, they can be edited much like standard 
Callouts. One exception is that standard Callouts can display arrows and cross section lines while Notes cannot. See Editing 
Callouts on page 531.         

A customized Note can be added to the Library for future use. 
See Add to Library on page 973.

To create a note schedule with notes
 1.  Select CAD> Text> Note , then click at the location where you want a note callout to be placed.         

 2.  The Note Specification dialog opens automatically. On the NOTE panel:         

 l Type the desired Text that you would like the new Note callout to be associated with in its Note Schedule.         

 l Specify the Type of Note Schedule to associate the new Note with.         

 l Notice that the Label Text Above Line uses the %simple_schedule_number% text macro by default. See Text 
Macros on page 549.         

 3.  Make any other needed changes, and click OK to place a Note callout. See Note Specification Dialog on page 544. 

 4.  The new Note callout is blank and has a Caution   symbol because it is not yet associated with a Note Schedule.

 5.  If you click on the Caution symbol, a contextual menu displays:
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 l Create Note Schedule from Note(s)  creates a Note Schedule in the current view that reports information 

about the selected Note's Type.

 l Ignore Note With No Schedule removes the Caution symbol from the selected Note and leaves it unlinked to a 
schedule.

 l Ignore All Notes With No Schedule removes the Caution symbol from all unlinked notes in the current view.

 6.  Select none of these and instead open a CAD Detail window and select Tools> Schedules> Note Schedule .         

 7.  Select the new schedule and click the Open Object  edit button.         

 8.  On the GENERAL panel of the Note Schedule Specification dialog:         

 l Type the desired Main Title for the schedule.         

 l Under Objects to Include, all Note Types that are currently present in the plan will be listed. Choose the Types 
that you wish to include in this schedule.         

 9.  Make any other needed changes to the schedule’s settings and click OK. See Schedule Specification Dialog on page 
704.         

 10.  Return to the view where you created the Note in step 1 and notice that the Note callout now displays a schedule row 
number.         

NOTE SCHEDULES

The Note Schedule tool allows you to produce customizable schedules that report information about Note objects 
created for a variety of purposes. See The Schedule Tools on page 695.          

All Note Types present in the current plan are listed in the Schedule Specification dialog, under the Categories to Include 
heading. See General Panel on page 705.         

By default, when a new Note Type is created, it will not be included in any existing schedules or in the Note Schedule 
Defaults automatically. You can specify which Note Types to include in a selected Note Schedule in the Schedule 
Specification dialog. See General Panel on page 705.         

You can also create a Note Schedule in the current orthographic view by selecting one or more Note callouts and 
clicking the Create Note Schedule from Note(s) edit button. The resulting schedule will only report information 

about the selected Note Type(s). This edit tool is not available in camera views or overviews.          

NOTE TYPES

Note Types are used to indicate a unique purpose for each Note Schedule and to determine which Note objects each 
schedule lists.         

Note Types are saved with each plan, so if you expect to use certain custom Note Types on a regular basis, you should add 
them to your plan template file(s). See Template Files on page 87.         

Note Types can be exported from a plan file and then imported into other plans. Select File> Export> Export Note Types 
or File> Import> Import Note Types. They can also be imported and exported using the Note Type Management dialog. 
See Importing Files on page 45 and Exporting Files on page 41.         

NOTE TYPE MANAGEMENT DIALOG

Select CAD> Text> Note Type Management to manage the various Note Types available in the current file.         
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The Available Note Types in the current plan file are listed on the left. Click on a name to select it.         

The buttons on the right let you manage the Note Types in the list.         

 l Click the New button to create a new Note Type. In the New Note Type dialog, type a short, descriptive, unique name 
for the new Note Type.         

 l Click the Rename button to open the Rename Note Type dialog and type a new name for the selected Note Type.         
 l Click the Delete button to remove the selected Note Type from the list. Only available when a custom Note Type is 

selected in the list.         
 l Click the Import button to import Note Types previously exported from another plan into the current file.         
 l Click the Export button to export the Note Types in the current file into a .json file so that they can be imported into 

other plan files.         

You can specify a selected Note object’s Note Type in the Note Specification dialog. See Note/Callout Panel on page 545.         

 

Note Specification Dialog
To open the Note Specification dialog, select a note callout and click the Open Object edit button. This dialog also 
displays when a new note callout is created using the Note  tool. See Notes, Note Types, and Note Schedules on 

page 542.

The Note Specification dialog is similar to the Note Defaults dialog but affects the selected Note callout(s) rather than all 
subsequently created Notes. Also, the name of the Saved Default being edited will display in the title bar of the defaults 
dialog. See Text Defaults and Preferences on page 502. 

NOTE PANEL

For information about the settings on this panel, see Note/Callout Panel on page 545.

LINE STYLE PANEL

The LINE STYLE panel is found in the specification dialogs for many different objects. For more information, see Line Style 
Panel on page 310.          

TEXT STYLE PANEL

The settings on the TEXT STYLE panel control the appearance of the selected object’s text. For more information, see Text 
Style Panel on page 547.           
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OBJECT INFORMATION PANEL

The information entered on the OBJECT INFORMATION panel can be used in Note Schedules. For more information, see 
Object Information Panel on page 1336.          

SCHEDULE PANEL

The settings on the SCHEDULE panel determine which schedule categories the selected Note is included in. See Schedule 
Panel on page 716. 

 

Note/Callout Panel
The NOTE panel is found in the Note Specification dialog, while the CALLOUT panel is found in the CALLOUT 
SPECIFICATION dialog. The NOTE and CALLOUT panels have numerous settings in common. See Notes, Note Types, 

and Note Schedules on page 542 and Callouts on page 530.
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Schedule

The Schedule settings determine how and where the selected Note will be represented in a Note Schedule. These settings 
are not available for Callouts. See Notes, Note Types, and Note Schedules on page 542.

 l Specify the Text associated with the selected Note that will display in the Note Schedule.    

 l Click the Insert button to the right of the Text field to choose from a list of special characters and text macros. See 
Text Macros on page 549.    

 l Click the Spell Check button to check the selected Note’s Text for errors. See Spell Check on page 526.    

 l Specify the Type of Note Schedule to associate the selected Note with. See Note Type Management Dialog on page 
543.    

 l Click the New Note Type button to create a new type to choose from. See Note Types on page 543.

  Label

By default, the Text Above Line for Notes is populated by the 
%simple_schedule_number% macro. See Schedule Number 

Format on page 701.

 l Type the Callout Label or Text Above Line, which displays inside the callout shape. This text is centered in the 
callout shape when no Text Below Line is specified.         

 l Type the Text Below Line for the bottom row, if desired. If Text Below Line is added, a line centered in the callout 
shape will separate this text from the Text Above Line.      

 l Click the Insert button to the right of either option to choose from a list of special characters and text macros. See 
Text Macros on page 549.     

 
Shape

                 

 l Check Generate Shape from Schedule to use the callout shape set in specification dialog of the Note Schedule 
associated with the selected Note. See Labels Panel on page 709.         

 l Select a callout shape by clicking the radio button beside one of the options.         

  Size/Orientation

 l Check Generate Size from Schedule to set the Note’s callout size based settings in the Note Schedule Specification 
dialog.          

 l Uncheck Automatic to enable the Size field and specify a new value. When checked, the callout is sized so that it 
encompasses its Label.

 l When Generate Angles from Schedule is checked, you can specify the selected Note's shape below. Check this box 
to instead set the Note's Shape and Text Angles based on settings in the Note Schedule Specification dialog.         

 l Specify the Shape Angle of the callout shape. Does not affect the Ellipse, Capsule, or Rectangle shapes.

 l Specify the Text Angle of the text inside the callout shape. Check Automatic for the Text Angle to match the Shape 
Angle. 
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Position

Specify the X, Y, and Z Position of the selected Note relative to the origin. These settings are not available for Callouts. 
See 3D Drafting on page 12.         

 
Preview

As in many specification dialogs, a preview of the selected object displays on the right. See Dialog Preview Panes on page 
22.         

Note: When the %simple_schedule_number% macro is used in a Note’s 
Label, the schedule number it reports will not be shown in this preview.           

 

Text Styles
In Chief Architect, a Text Style is a saved set of attributes that can be assigned to any object that displays text, such as Text, 
Callouts, Markers, Dimensions, Schedules, CAD objects, and object labels. A given Text Style can be assigned to objects:

 l By layer, in the Layer Display Options dialog;           
 l On the TEXT STYLE panel of various objects’ defaults dialogs;          
 l On the TEXT STYLE panel of some individual objects’ specification dialog.          

This makes it easy to ensure that various objects display text with a consistent appearance.          

Note: Because of its ability to use multiple attributes in the same object, 
Rich Text does not use Text Styles. See Rich Text Specification Dialog 
on page 507. 

You can create your own or edit existing Text Styles to suit your needs in the Text Style Defaults dialog.

TEXT STYLE DEFAULTS

Select Edit> Default Settings,              expand the Text, Callouts and Markers category, click on “Text Styles” and click the 
Edit button. The Saved Text Styles dialog will open, allowing you to select which Saved Text Style Defaults you 

would like to edit. See Multiple Saved Defaults on page 79.

The Text Style Defaults dialog can also be accessed:          

 l From the Layer Display Options dialog. See Layer Display Options Dialog on page 183.           
 l By clicking the Text Style Defaults  button, which can be added to your toolbars. See To add a button to a toolbar 

on page 137.           
 l By clicking the Define button on the TEXT STYLE panel of various objects specification dialogs.          

TEXT STYLE PANEL

The TEXT STYLE panel is found in various specification and defaults dialogs in the program.          

The settings on this panel are also found in the Text Style Defaults dialog, where they affect all objects using that style 
rather than a single selected object.          
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Source of Text Style

Specify where the selected object should draw its Text Style from. These options are not available in the Text Style Defaults 
dialog.                 

 l Select Use Layer for Text Style to use the Text Style assigned to the layer that the selected text is located on.                     

 l Select Use Text Style, then choose a style from the drop-down list to apply that style to the selected object, 
regardless of what layer it is on. When this is not selected, the name of the selected object’s Text Style displays here 
for reference.                      

 l Select Use Custom Text Style to enable the settings below and customize the selected objects Text Style attributes.                     

 l Check Use Default Text Style to use the default style for the selected object type, or uncheck this box to enable the 
settings below and define a custom style.         

 l The settings that follow are only editable when Use Custom Text Style is selected. When it is not selected, 
information about the Text Style that is assigned to the selected object displays for reference.

  Font

 l Select a font from the drop-down list.         

 l The text styles Bold, Underline, Italic, Strikeout, and Uppercase are available. Check any of the boxes to apply 
that style.         
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  Character Height

 l Enter the Character Height in drawing units. This height is subject to the current drawing scale.          

 l Click the Scale button to open the Printed Size Input dialog. See Scaling Text on page 521.          

 l If the selected object was originally created in an older program version and had Legacy Compatible Size checked 
in that version, this check box will be available. If you uncheck the box and click OK, however, the option will be 
removed. See Character Size on page 504.          

  Options

 l Check Rotate with Plan to rotate text using the selected Text Style when Rotate Plan View  is used. If 

unchecked, the text is unaffected when Rotate View is used. See Rotate Plan View on page 151. 

Rotate with Plan also affects text in a view sent to layout if the layout box is rotated. See CAD and Text in Layout 
on page 1342.          

 l Check Transparent to make text boxes using the selected Text Style transparent. When unchecked, text boxes have 
a solid fill the same color as your background color. Not available for objects that have FILL STYLE panels in their 
specification dialogs. See Colors Panel on page 102.           

  Text Color

 l When By Layer is checked, text uses the line color assigned to the layer that the object it is assigned to is located 
on. See Layer Attributes on page 181.          

 l Uncheck By Layer, then click the Color bar to select a different color. See Color Chooser/Select Color Dialog on 
page 204.         

 
Preview of Text Style

A preview of the Text Style currently assigned to the selected object displays here.          

 
Object Preview

In some specification dialogs, a preview of the selected object displays on the right. See Dialog Preview Panes on page 22.          

 

Text Macros
Text macros insert dynamic information relevant to the current plan or layout file, or a selected object. Macros can be used 
to create customized object labels and Materials List formulas. See Creating User Defined Macros on page 1392. 

Macros can be inserted into Text objects as well as added to object labels, object information, and in the materials list. 
There are four categories of insertable text macro: 

 l Global macros have information about the project, the plan or layout file, a room, and the date and time. They can also 
be used to insert special characters. 

 l User Defined macros can include a wide range of values, including global and object specific information and text. 
They can also be written to perform calculations. See Creating User Defined Macros on page 1392.         

 l Object Specific macros have information specific to a selected object type and can be included in object information 
and labels. See Label Panel on page 712.         
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 l Some Object Specific and User Defined macros can also be inserted into Materials List cells and used to create custom 
Materials List formulas. See Materials List Formulas on page 1325.         

 l Referenced Object macros can be inserted into text objects that have an arrow attached to another object. These 
macros report information about that object rather than the text. See Text Arrows on page 528 and Referenced Object 
Context on page 1396.         

In layouts, macros can be used to add page numbers, drawing scale, and information to identify drawings can be inserted to 
improve organization and clarity.          

To insert a macro
 1.  The Insert Macro  button can be found on a variety of dialog panels where text can be specified.          

 2.  When you click it, a menu of macros displays. Move your cursor over a menu item to view its submenu.         

 3.  Select from the list of available macros. In this example Global> Time Date> Short Date (%date.short%) is used.         

 4.  Depending on the context, some menu items may appear inactive; however, they can still be selected and inserted. 

 5.  Click OK to close the dialog.         

 6.  The text object displays the date rather than the macro formula.         

As an alternative to creating and then inserting a custom macro, you can 
also type ruby macro code directly into a text object or label and it will 
be evaluated provided that it is placed between two percent signs. 
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Chapter 15
 

Doors

Chief Architect comes with tools for creating a wide variety of interior and exterior doors. In addition, the library offers a 
large selection of specialty doors and doorways including hinged, sliding, pocket, bifold, and garage doors. Additional 
name-brand door catalogs are also available for download from our website, chiefarchitect.com.

TOPICS

Door Defaults 552
Door Tools 553
Displaying Doors 556
Editing Doors 558
Changing Door Swings 561
Special Doors 563
Door Specification Dialog 566
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Door Defaults
There are several defaults dialogs for doors. Default Settings are accessed by selecting Edit> Default Settings . Click 

the arrow next to “Doors” to expand the category. Select a subheading and click the Edit button to open the defaults dialog 
associated with your selection: 

Door Defaults can also be accessed by double-clicking the Door Tools  parent button or the Hinged Door  or Sliding 

Door  child button. Double-clicking the other Door Tools child buttons will open the defaults dialog for that particular 

door type.           

The various Door Defaults in the list can be multiple-selected by holding down the Shift or Ctrl keys. See Shift and Ctrl 
Select on page 217.          

The Door Defaults dialogs look nearly the same as the Door Specification dialog. See Door Specification Dialog on page 
566. There are only a couple of differences: 

 l Since default settings are specified here, “Use Default” is not an option for some settings as it is in the Door 
Specification dialog. 

 l The Door Type cannot be changed in the Defaults dialogs.

Because Hinged and Sliding Doors are often used in both interior and exterior applications, they have both Interior and 
Exterior Door Defaults. 

INTERIOR VS EXTERIOR DOORS

Regardless of its Door Type or the tool used to create it, a door will be: 

 l An Interior Door if it is created in a wall that separates two interior rooms;
 l An Exterior Door if it is created in a wall that separates an interior room from either an exterior room or the building’s 

exterior. See Room Types and Functions on page 420. 

This rule does not apply to doors placed from the Library or copied and pasted from one location to another, however. If, 
for example, you place a hinged door in an interior wall between two rooms and then paste a copy of that door in an exterior 
wall, the copy will remain an interior door. See Exterior and Interior Walls on page 355.
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DYNAMIC DOOR DEFAULTS

A variety of door default values are dynamic, including the Door Style, Casing, Lintel, Jamb, Hardware, Framing, and 
Rough Opening. When a dynamic default is changed, existing door using the default value are affected. See Dynamic 
Defaults on page 79. 

All Materials listed under “Doorway” on the MATERIALS panel are also dynamic. Materials assigned to doors and hardware 
items from the library, however, are listed separately and are dynamically linked to the “Interior Door”, “Exterior Door” and 
“Fixture Trim” and “Hardware” materials set in the Material Defaults dialog rather than the Door Defaults dialogs. See 
Material Defaults Dialog on page 1052.           

DOOR FRAMING

The default headers, trimmers, rough opening, and sill for doors can be defined in the Door Defaults dialogs. You can also 
specify an additional amount to cutout for door openings in concrete garage curbs and foundation walls. See Rough Opening 
Panel on page 579 and Framing Panel on page 579.

The default header depths for different spans can be set in the Framing Defaults dialog. See Openings Panel on page 880.

 

Door Tools
To place a door, select the type you want from the Build> Door submenu. Move your mouse pointer over a wall 
section. When a preview outline can be seen, click to place a door at that location.

The minimum initial size for doors varies by Door Type. For example, If there is room enough along the wall to fit a 12” 
(300 mm) wide Hinged Door, a preview outline will display and a door can be placed. Garage doors, in contrast, must 
initially be at least 6’ (1800 mm) wide.

Doors can be placed in both straight and curved walls, as well as span across straight, collinear wall segments.         

A newly created door inherits the settings in the Door Defaults dialog for its door type. Once created, doors can be edited in 
a variety of ways. See Door Defaults on page 552. 

Doors cannot be placed in a wall specified as Invisible or if the wall in question is on a locked layer. See Locking Layers on 
page 182.

Once placed, any door may be changed into any other type of door in the Door Specification dialog. See General Panel on 
page 566.

HINGED DOORS

Select Build> Door> Hinged Door and click on a wall to place a hinged door at that location. Hinged doors have 
separate defaults for interior and exterior doors. By default, a hinged door becomes a double door when its width is 

four feet (1200 mm) or greater. 

The initial swing direction of a hinged door depends on the location of the mouse pointer relative to the wall when you 
click. The door will swing towards the side of the wall that you click nearest. 

The initial hinge side of a hinged door can be set by clicking to place the door and then holding the mouse button down 
rather than releasing it. Move the mouse toward the end of the door that you would like the hinges to be on: as the mouse 
pointer nears either end, the door preview’s hinge side will move to that end. You can also adjust the door’s swing direction 
in this manner. When the swing direction and hinge side are correct, release the mouse button.
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DOORWAYS

Select Build> Door>  Doorway and click on a wall to place a doorway. Doorways are simply openings without a 
door and can be placed in interior and exterior walls, railings, and fences. You can assign a door from the library to a 

doorway if you wish.

SLIDING DOORS

Select Build> Door> Sliding Door and click on a wall to place a sliding door. Sliding doors have separate defaults 
for interior and exterior doors: interior sliding doors are typically solid while exterior sliding doors are Glass Panel 

doors. 

The initial opening side of a sliding door can be specified by moving the mouse pointer along the wall while the mouse 
button is still pressed.  

POCKET DOORS

Select Build> Door> Pocket Door and click on a wall where you want to place a pocket door.

As with sliding doors, the initial opening side of a pocket door can be specified by moving the mouse pointer along the wall 
while the mouse button is still pressed.  

By default, a pocket door becomes a double pocket door if its width is four feet  (1200 mm) or greater. 

BIFOLD DOORS

Select Build> Door> Bifold Door and click on a wall where you want to place a bifold door.

Like a hinged door, the initial opening side of a bifold door depends on the location of the mouse pointer relative to the wall 
when you click. The door will open towards the side of the wall that you click nearest. 

Similarly, the initial hinge side of a bifold door can be specified by moving the mouse pointer along the wall while the 
mouse button is still pressed.  

By default, a bifold door becomes a double bifold if its width is greater than three feet (900 mm).

GARAGE DOORS

Select Build> Door> Garage Door and click on a wall to place a garage door.

In plan view, dashed lines show the size and location of the garage door when open.

Garage doors will build into a garage stem wall provided the room is designated as a garage before the door is inserted. See 
Room Types and Functions on page 420.

FIXED DOOR

Select Build> Door> Fixed Door and click on a wall to place a fixed door.
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BARN DOOR

Select Build> Door> Barn Door and click on a wall to place a surface mounted sliding door, sometimes referred to 
as a barn style door.

SHOWER DOOR

Select Build> Door> Shower Door and click on a wall to place a hinged glass slab shower door.

Place a Shower Door in a Straight Glass Wall. See Wall Tools on 
page 350.

 

THE DOORS & DOORWAYS LIBRARY CATALOG

The Doors & Doorways library catalog can be accessed by selecting View> Library Browser and browsing to Chief 
Architect Core Catalogs> Architectural> Doors and Doorways. This catalog contains a variety of interior and exterior 

doors, as well as special entryways and wrapped openings. 

Entryways and wrapped openings are examples of Doorways, which are wall openings that do not have doors within them.

To add a door to the Doorway, select a Door Type other than “Doorway” from the drop-down list in the Door Specification 
dialog. See General Panel on page 566. 

You can also select a door from the library and place it into a doorway in plan view or any 3D view.

To place a library door in a doorway
 1.  Go to plan view or any 3D view. 

 2.  Open the Library Browser. 

 3.  Browse or search to find a door style that suits your needs. 

 4.  Select the door in the Library Browser, then click on the doorway to place the selected door within it. If a door 
already exists, it is replaced. 

 5.  Continue clicking other doorways as needed.

CUSTOM DOORS AND DOORWAYS

You can import or create custom doors and doorways and save them in your own library for use in future plans. See Custom 
Symbols on page 992.          

You can also specify the Door Type associated with a custom door symbol saved in the library in its Symbol Specification 
dialog. See Options Panel on page 997.          
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Displaying Doors
The display of doors, door labels, opening indicators, header lines, and casing is controlled in the Layer Display 
Options dialog. See Layer Display Options Dialog on page 183. 

Doors can only be placed in walls, so if a wall’s layer is turned off in plan view, any doors placed in that wall will not 
display, either. Doors can display independent of their containing walls in 3D views, however. See Displaying Walls on 
page 366. 

If the “Doors” layer is turned off, doors and their casing do not display but openings in the walls where they are located are 
visible.

IN PLAN VIEWS

A door’s jamb, casing, and swing are all represented in plan view. If a door is recessed, the affected wall layers will adjust 
to accommodate the casing.

A threshold line will display across a door opening in plan view when the door:

 l Is located in an exterior wall. See Exterior and Interior Walls on page 355.
 l Opens to an exterior room such as a Garage or Deck. See Room Types and Functions on page 420.
 l Is located between rooms with different floor heights. See Floor and Ceiling Platforms on page 433.

Doorways display dashed lines that represent the wall surface between the doorway and the ceiling. Other types of doors do 
not display these wall surface lines, however, you can specify that any door display them or not in its specification dialog. 
See Options Panel on page 568.          

If an exterior door to a Garage room on Floor 1 extends into a Garage stem wall or curb on Floor 0, its location will be 
indicated on Floor 0. You can control the display of this concrete cutout in the Door Specification dialog. See Garages on 
page 728. 

When the “Opening Header Lines” layer is turned on in plan view, headers are represented by dashed lines within each 
door’s opening. These lines do not correspond to actual framing objects and cannot be selected. In addition, header framing 
members can be set to display. See Wall Framing on page 866.           

The vertical casing on the sides of doors will display in plan view when the “Casings, Exterior” and “Casings, Interior” 
layers are turned on. See Casing Panel on page 571.           
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IN 3D VIEWS

You can specify whether a selected door is shown open or closed in 3D views by clicking the Show Door Open in 3D  

and Show Door Closed in 3D  edit buttons as well as in the Door Specification dialog. See Options Panel on page 568.

If a door is set to display open in 3D, the angle of the open door can be changed using the edit handles in plan view. See 
Using the Edit Handles on page 559.

You can specify whether an exterior door has a threshold in the Door Specification dialog. See Casing Panel on page 571.

You can also specify whether window and door glass is opaque or transparent in the Rendering Technique Options dialog. 
See Rendering Technique Options on page 1150.          

When displayed as opaque, window and door glass uses the Material Color set in the Define Material dialog. See Pattern 
Panel on page 1067.           

OPENING INDICATORS

Doors, windows and cabinet doors can all display opening indicator arrows in Vector Views. See Vector View on page 
1147.

To display an object's opening indicator arrows in a Vector View:

 l Turn on the “Opening Indicators” layer in the Layer Display Options dialog.
 l Make sure the object is set to Show its opening indicators in its specification dialog. See Opening Indicators Panel on 

page 578. 

Opening indicators on a cabinet, window, and 
doors in a Vector View

You can specify whether opening indicators point to the opening hinge side or the opening side in the General Plan Defaults 
dialog. See General Plan Defaults Dialog on page 96.

DOOR LABELS

Door labels display in floor plan and cross section/elevation views, centered on the doors they represent, when the “Doors, 
Labels” layer is turned on and use the Text Style assigned to their layer. See Label Panel on page 712. 

Automatic door labels indicate Width and Height. For example: 

 l In U.S. Unit plans, the automatic label for a 3’-0” wide, 6’-8” high double hung window will read 3068. 
 l In metric plans, the automatic label for a 900 mm wide, 2100 mm high double hung window will read 900x2100.
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If you prefer, you can use one of two other formats: Height/Width and Width Only. Label formats are specified in the Door 
Specification dialog or in the Door Defaults dialog if no schedule is present. See Labels Panel on page 709.           

Customized labels               using text and Object Specific Text Macros as well as label position and orientation can also be specified 
in the Door Specification dialog. See Text Macros on page 549.

IN THE MATERIALS LIST

The materials associated with doors are listed under different Categories in the Materials List:

 l Doors - Lists door panels, handles, and hinges.                 
 l Interior Trim - Lists interior casing and lintels as well as interior door jambs.                 
 l Exterior Trim - Lists exterior casing, lintels, shutters. Exterior jambs and thresholds are also listed here.                 

As with other objects, there are a number of ways to control how, or whether, doors are included in the Materials List. See 
Organizing Materials Lists on page 1317.     

You can add and edit information about a door’s accessories in the Door Specification dialog. See Components Panel on 
page 1335.     

DOOR SCHEDULES

The Door Schedule tool is set up to produce customizable door schedules as well as door labels that display schedule 
numbers. Any schedule, however, can be set up to include doors. See Schedules and Object Labels on page 694. 

In addition, any information about door casing and lintels can also be included in any schedule set up to include items in the 
Room and/or Molding categories. See Room Finish Schedules on page 453.   

Hinge and Swing Side
Hinge Side and Swing Side columns can be added to door schedules. See Columns to Include on page 701.   

There are various methods for describing hinge side as well as door swing direction, or door hand. In Chief Architect, both 
are described from the perspective of someone standing on the exterior side of the door.   

 l The hinge side will be described as L if the hinges are on the left side of the door, as viewed from its exterior side. If 
the hinges are on the right side, they will be described as R.

 l The swing direction will be Out if the door swings towards the viewer on the exterior side.
 l The swing direction will be In if the door swings away from the viewer, towards the interior.

Regardless of where they are located in a plan, all doors have an interior and an exterior side, as do the walls they are placed 
in. See Interior and Exterior Surfaces on page 390.

 

Editing Doors
Before a door can be edited, it must be selected. To select a door, click it when the Select Objects  tool or any of the 

Door Tools  are active. Doors and/or windows can also be group selected and edited. See Selecting Objects on page 212.

Blocked units are made up of individual doors and windows that have been grouped together to act as one object. You can 
create a blocked door unit  or by creating a Mulled Unit  composed of doors and/or windows.  See Mulled Units on page 

591. 
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Select a blocked unit by clicking on it in any view. To select a door that is a component of a blocked unit, click at the 
location of the component in question, then click the Select Next Object  edit button. See Selecting Objects on page 

212.

USING THE EDIT HANDLES

In plan view, click either of the two end handles and drag along the wall to change the width. The label showing the size 
updates as the handles are dragged. Click and drag the Move handle at the center to move the door along the wall it is 
placed in. Use the triangular Rotate handle to adjust the door’s swing. If the door’s label displays, an additional handle is 
available to move it.

In 3D views, a selected door has five edit handles: the Move handle at the center and a Resize handle on each edge.  Click 
and drag an edge handle to resize the door.  

Using the edit handles, doors resize according to the currently active Edit Behavior . See Defaults, Preferences, and 

Edit Behaviors on page 208.   

A door or window moved against an intersecting wall temporarily stops when the casing meets the intersecting wall. You 
can continue to drag and it resumes movement past the intersecting wall. 

IN THE SPECIFICATION DIALOG

The most precise method of editing a door or group of doors is to use the Door Specification dialog. Door type, size, casing, 
materials, shape, and more can all be specified in this dialog. See Door Specification Dialog on page 566. 

You can use the Object Painter  tools to assign the properties of one door to other doors. See Matching Properties on 

page 286.     

You can also apply a variety of door attributes to multiple doors at once using Style Palettes. See Style Palettes on page 
284.    

USING THE EDIT TOOLS

A selected door or doors can be edited in a variety of ways using the buttons on the Edit Toolbar. See The Edit Toolbar on 
page 135.

  Change Opening/Hinge Side changes the side of the door that its hinges are on. See Changing Door Swings on 
page 561.

  Change Swing Side changes which direction the selected door swings.

  Show Door Open in 3D or Show Door Closed in 3D controls the selected door’s appearance in 3D 
views. See In 3D Views on page 557.

  Gable Over Door/Window creates a gable over the selected door(s) the next time the roof is rebuilt. See 
Gable/Roof Lines on page 846. 

  Make Mulled Unit  can be used to block multiple selected doors and/or windows into a single unit, while 
Explode Mulled Unit breaks a mulled unit into its individual components. See Mulled Units on page 591. 

USING DIMENSIONS

Like various other objects, doors can be moved using dimensions. See Moving Objects Using Dimensions on page 
491. 
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You can specify how doors and windows are located by dimensions in the Dimension Defaults dialog. Dimensions can be 
set to locate the centers, sides, casing, and/or rough openings of doors and windows, or you can choose to not locate them at 
all. See Locate Manual Panel on page 460.           

Once a dimension line has been drawn, you  can move or add its extension lines to locate non-default locations on a door. 
See Editing Extension Lines on page 486. 

CENTERING DOORS

The Center Object edit button allows you to center a selected door along a wall within a room or relative to a 
cabinet or window. See Center Object on page 253.

To center a door along a wall
 1.  Select a door or combination of windows and doors in plan view. 

 2.  Click the Center Object  edit button then choose from one of the following options: 

 l Click near a wall inside a room to center the door along that wall in that room.

 l Click outside the house (on the exterior room) near an exterior wall to center the door along an exterior wall.

DOOR STYLE AND PANELS

There are a number of Door Styles available for use, including Slab, basic Panel, and Louvered. In addition, a selection of 
door panel symbols is available in the Library. See Placing Library Objects on page 980.

By default, most door types are either single or double, depending on their width. You can specify how many panels a 
selected door has in the Door Specification dialog. See Options Panel on page 568.          

DOOR SIDES

Like walls, all doors have two sides: an interior side and an exterior side. This is the case even for doors placed in interior 
walls. See Exterior and Interior Walls on page 355.          

By default, the interior side of the door will face the direction that the door swings to open. If you prefer, you can specify 
that the interior side face the opposite direction in the Door Specification dialog. See General Panel on page 566.           

You can specify the materials for the two sides separately in the Door Specification dialog. See Materials Panel on page 
582.          

You can also specify different casing for the interior and exterior sides of exterior doors - that is, doors placed in exterior 
walls or walls defining a Garage or other exterior room type. See Room Types and Functions on page 420.           

DOOR CASING

Doors typically feature casing, or trim, on both sides of the wall opening. See Moldings / Profiles Panels on page 943.         

 l By default, interior doors use the same casing profile on both sides. You can specify that both sides be edited 
separately in the Door Specification dialog. See General Panel on page 566.         

 l Exterior doors can have different casing profiles on their interior and exterior sides.         

The default casing for interior and exterior doors is a basic rectangular stock profile. You can specify a door’s casing 
profiles  in the Door Specification dialog, or you can choose to suppress casing altogether. See Casing Panel on page 571.         

A separate molding profile can be specified for the lintel, or top horizontal molding. See Lintel Panel on page 572.          
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Exterior and interior door casing will display in all views when the “Casings, Exterior” and “Casings, Interior” layers are 
turned on. In plan view, only the vertical side casing is shown.           

DOOR HARDWARE

Handles, locks, and hinges can be assigned to a door in the Door Specification dialog. See Hardware Panel on page 576.

In 3D views, handles and locks can also be applied directly from the Library Browser. Select a hardware item in the library, 
then click on the door to apply it to that side of the door. See Inserted Objects on page 981.          

 

Changing Door Swings
Door swing direction and hinge side can be changed using the edit handles and the Change Opening/Hinge 
Side and Change Swing Side edit buttons.

Swing and hinge side can also be applied from one door to another using the Match Properties  tool. See Matching 

Properties on page 286.          

Note: If the door is set to draw closed, the swing as it appears in plan 
view has no effect on the 3D view. See Options Panel on page 568.

The Change Opening/Hinge Side  edit button is available for all doors except doors with multiple panels and garage 

doors.

The Change Swing Side  edit button is available for all doors except pocket doors. 

HINGED DOORS

In addition to using the edit buttons, Hinged Doors and Shower Doors’ hinge side and swing direction can be changed using 
the triangular Rotate edit handle.

To adjust the angle of swing:
 1.  In plan view, select the door and grab the triangular handle.

 2.  Drag to change the amount of swing. 

 3.  Release the mouse. 

If you drag near the closed position, the door snaps to a closed position.
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To change the swing using edit handles:
 1.  In plan view, select the door and grab the triangular edit handle.

 2.  Drag the pointer along the path of the new arc to change the hinge side and/or swing direction.

 3.  Release the mouse.

You can specify a Double Hinged Door to swing from its center 
in the Door Specification dialog. See Options Panel on page 

568.

To change the swing using edit buttons:
 1.  In plan view, select the door.

 2.  To change the hinge side, click the Change Opening/Hinge Side  edit button.

 3.  To change the swing direction, click the Change Swing Side  edit button.
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You can also specify a Hinged Door to swing in both directions 
in the Door Specification dialog. See Options Panel on page 

568.

SLIDING TYPE DOORS

Sliding, Pocket, Bifold, and Barn Doors are types of sliding door. 

Similar to hinged doors, the Opening/Hinge and Swing sides of a Sliding, Pocket, Bifold, or Barn Door can be changed by 
clicking and dragging its diamond-shaped edit handle. 

To change the side of a Sliding, Pocket, Bifold or Barn door that opens, select the door and click the Change 
Opening/Hinge Side  edit button.

Note: For a Pocket Door to change Opening Side, there must be enough 
room for the entire door to fit in the wall on that side.

To flip the fixed and moving sides of the door, click the Change Swing Side  edit button.

GARAGE DOORS

To change the side of a garage door that it faces, select it and click the Change Swing Side  edit button.

Unlike other door types, the Swing side of a garage door cannot be modified using the edit handles. 

IN DOOR SCHEDULES

Both Hinge Side and Swing can be included in Door Schedules. See Columns to Include on page 701.           

 

Special Doors
A variety of special doors and doorways can be created in Chief Architect.

563



Chief Architect Premier X14 Reference Manual - Special Doors

TRANSOMS ABOVE DOORS

Transom windows above doors are created the same as other stacked windows. See Grouped Windows on page 590.

WRAPPED OPENINGS

Wrapped openings of various shapes are available in the Doors & Doorways Library.          

You can also create a wrapped opening by unchecking Use Interior Casing and/or Use Exterior Casing in a Doorway’s 
Door Specification dialog. See Casing Panel on page 571. If base molding is present, it will wrap around the opening. 

RECESSED DOORS

A door placed in a brick or stone wall is often recessed into the wall’s exterior. In the illustration below, the door to the 
right is recessed, so the brick wraps the opening. The door on the left is not recessed, so the casing is outside the brick.           

You can specify a door as recessed in the Door Specification dialog. See Options Panel on page 568.          

BLOCKED DOORS AND WINDOWS

Combinations of doors and windows can be blocked. Blocked units are mulled together and can be copied together as a unit. 
Blocked units containing doors can be treated as either windows or doors for materials list and schedule generation. See 
Mulled Units on page 591.          

OPENINGS IN RAILINGS

Use the Doorway  tool to open a railing for a stairway or other access. 

To open a railing across an entire section, resize the doorway’s Width so that it is greater than the length of the railing in 
the Door Specification dialog. The opening resizes to the maximum width possible for that space. See General Panel on 
page 566.

To add a gate, specify the doorway’s Door Type as a Door, then choose an appropriate gate as the Door Style. A selection 
of gates is available in the Fences & Railings library folder. See Placing Library Objects on page 980.          

564



Chief Architect Premier X14 Reference Manual - Special Doors

CREATING A DOORWAY WITH A RAILING

When a railing is specified as No Room Def, it can be positioned within a Doorway .

To create a doorway with railing
 1.  Place a Doorway  at the desired location in your plan.

 2.  Select Build> Railing and Deck> Straight Railing , then click and drag to draw a railing parallel to the wall 

with the doorway. 

 3.  Select the railing, then use the Resize edit handles to adjust the length of the railing as needed. See Using the Edit 
Handles on page 218.

 4.  With the railing selected, click the Open Object  edit button.

 5.  On the GENERAL panel of the Railing Specification dialog, check No Room Def and click OK. See General Panel 
on page 395.

 6.  With the railing still selected, Ctrl + drag it into position within the doorway. See To move an object freely on page 
247.

PLACING A GABLE OVER A DOOR

Click the Gable Over Door/Window edit button to produce a gable roof over the selected door(s) the next time 
automatic roofs are built. See Gable/Roof Lines on page 846.

You can manually edit or delete this gable line at any time. Your changes take effect when the automatic roofs are rebuilt. 
This can also be used with group selected doors.

CUSTOM MUNTINS

Like windows, doors that are specified as “Glass” can have custom muntins. Custom muntins are created from CAD lines. 
See Custom Muntins on page 598.          
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Door Specification Dialog
To open the Interior or Exterior Door Specification dialog, select a door or group of doors and click the Open Object 
edit button or double-click on a door using the Select Objects  or any Door  tool.

Whether a selected door is Interior or Exterior depends on where it is placed. See Interior vs Exterior Doors on page 552.

You can also open the specification dialog for the door(s) associated with a schedule row. See Open Row Object(s) on page 
699.

The Lintel, Framing, and Energy Values panels are also found in 
the Window Specification dialog. In addition, the Frame panel 

for windows is similar to the Jamb panel for doors. See Window 
Specification Dialog on page 599. 

The Door Specification dialog has the following panels:

GENERAL PANEL
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  General

 l Door Style - Select Slab, Glass Slab, Panel, Glass Panel, Louvered, or Glass Louver from the drop-down list; select 
a style from the Library; or choose “Use Default” to use the default door style set in the Door Defaults dialog. See 
Door Defaults on page 552.

 l Select “Library” from the drop-down list or click the Library button to choose a door symbol from the library. Once 
a library door is selected, its name is added to the Door Style list. See Select Library Object Dialog on page 982.

 l Specify the Door Type as Doorway, Hinged, Sliding, Pocket, Bifold, Garage, Fixed, Barn, or Shower. In the Door 
Defaults dialogs, the Door Type cannot be changed. 

 l Specify the Swing Angle of the selected door in plan view, between 0° and 180°. An angle of 0° displays the door as 
closed and an angle of 180° displays it as wide open. The Swing Angle for Bifold doors and double doors that swing 
from the center can be no more than 90°. 

The Swing Angle also affects the door’s appearance in 3D views if Draw Closed is unchecked on the OPTIONS 
panel. See Options Panel on page 568.

 
Size and Position

                 Specify the Size and Position of the selected door. 

 l Specify the Width, Height, and Thickness of the door. These values do not include the jamb. See Jamb Panel on 
page 573.

 l Select the Elevation Reference from the drop-down list. This determines where the next two settings are measured 
from and also affects their labels.

 l Specify the height to Top, measured from the selected Elevation Reference to the top of the door frame. 

 l Specify the height to Bottom, measured from the selected Elevation Reference to the bottom of the door frame. 

 
Sliding Doors

                 The Sliding Doors settings are available for Slider, Pocket, and Barn Doors. 

 l Specify the Side and Top Overhang values, which control how much the selected door extends past its wall 
opening. Only available for Barn Doors.

 l Specify the Offset from Wall, which is how far the selected door is offset from its default location. Slider and 
Pocket Doors are centered in the wall’s Main Layer by default, while Barn Doors are positioned against the wall 
surface. 

 
Panel Frame Widths

Specify the dimensions of the selected door’s rails and stiles. Only available for Glass, Panel, and Louvered doors.          

 l Specify the Width of the stiles and top rail. Uncheck Uniform to specify separate values for the Left, Right, and 
Top of the frame, or leave it checked to use the same value for all three.

 l Specify the height of the Bottom rail.
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  Louvers

 l Specify the Size, or vertical height, of the selected door’s louvers. Only available for Louvered and Glass Louvered 
doors.

 l By default, louvers face the direction that the door swings. Check Reverse Direction to reverse the direction that 
they face.

 
Options

 

 l Check Reverse Interior/Exterior to reverse the two sides of the selected door so that they face the opposite 
direction. Only available when a door symbol from the Library is specified as the Door Style. See Door Sides on 
page 560.

 l Check Separate Trim and Materials for Each Side to specify the casing, lintels, and all materials for each side of 
the selected interior door independently. When unchecked, the two sides of the door use the same trim and materials. 
Only available when the selected door is placed in an interior wall. See Exterior and Interior Walls on page 355.

 
Preview

A preview of the door displays on the right side of the dialog box. A label indicates which side of the door is its Interior and 
which is its Exterior. See Dialog Preview Panes on page 22.

OPTIONS PANEL
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Door Panels

                 Specify the number of Door Panels or sections that the selected door has.  See Door Style and Panels on page 560.

 l Select Single Door Only to force the selected hinged, pocket or bifold door to be a single door, regardless of its 
width.

 l Select Double Door Only to force the selected hinged, pocket or bifold door to be a double door, regardless of its 
width.

 l Select Calculate From Width to use the program defaults. Hinged and pocket doors default to Single Door when 
less than four feet (1200 mm) wide; bifold doors do so when less than three feet (900 mm) wide. If the width is 
greater than this, Double Door is the default. 

Note: The Calculate From Width defaults are not editable.

 l Select Custom, then specify the number of panels on the Left and/or Right door components. Only available for 
sliding, pocket, and bifold doors.          

 l For a selected Garage Door, specify the number of Vertical Panels.

 l When All Glass is unchecked, only the third panel from the bottom the door is a glass panel: the rest are solid 
panels. Check this box to make all of the panels glass. The number and style of the lites and the Muntin Width can 
be specified on the LITES panel.

 
Plan Display

The Plan Display settings control the display of dashed wall surface lines above the door in plan view. See In Plan Views 
on page 556.                 

 l Select Automatic to display wall surface lines only when the selected door is a Doorway.

 l Select Show Top Edge to display wall surface lines regardless of the door type.

 l Select Hide Top Edge to not show wall surface lines regardless of door type.

 
3D Display

Specify whether the selected door is shown open or closed in 3D and cross section/elevation views. 

 l If Show Open is selected, the Swing Angle set on the General Panel on page 566 is used. 

 
Door Swing

Specify how the selected door swings. Most options here are only available when the selected Hinged or Pocket door is a 
Double Door. Not available for Bifold, Slider or Garage doors. See Changing Door Swings on page 561.         

 l Check Both Doors Swing to allow both sides of a Double Door to swing. 

 l Check Left Swing Only or Right Swing Only to allow only the left or right side of a Double Door to swing. 

 l Check Swings from Center to create a Double Door with hinges at the center rather than at the outside edges. 

 l Check Swings Both Directions to allow a door or both sides of a Double Door to swing both directions. 
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Safety

The Safety settings affect how the selected door is listed in the Door Schedule. See Schedules and Object Labels on page 
694.                 

 l Check Tempered Glass to specify the selected door as having tempered glass.                      

 l Check Fire Door to specify the selected door as being a fire door.                      

 
Recessed Into Wall

The Recessed into Wall options allow you to recess the selected door’s jamb into a wall, away from the exterior surface. 
This setting also affects the exterior casing and lintel, if used. Only available if the door is placed in a multi-layered wall. 
See Wall Type Definitions on page 388.     

 l Check Recessed to activate the settings that follow.                 

Not Recessed

 l Select To Main Layer to recess the door to the wall’s Main Layer.

Recessed to Main Layer

 l Select To Sheathing Layer to recess the door to the wall’s sheathing layer. 

Recessed to Sheathing Layer

 
In Curved Wall

Specify whether a door placed in a curved wall is Straight or Curved. Curved is selected for Slider, Pocket, and Barn 
Doors and cannot be changed. See Drawing Curved Walls on page 363.

 
Plinth Blocks

Add an Interior Plinth Block and/or Exterior Plinth Block to the selected door. Plinth blocks do not display in 3D views, 
but are counted in the Materials List. 

 
Preview

A preview of the door displays on the right side of the dialog box. See Dialog Preview Panes on page 22.   
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CASING PANEL

By default, interior and exterior casing is suppressed for doorways placed into railings: including solid railings and railing 
pony walls.         

 
Use Interior Casing

When this box is unchecked, no casing is used and the settings that follow are disabled.    

 l Casing Profile - Click the Library button to select a molding profile for the casing. A preview of the casing profile 
displays to the right. See Select Library Object Dialog on page 982.    

 l Click the Clear button to remove a selected casing profile from the door. When no profile from the library is 
selected, a basic rectangular stock profile is used.    

 l Specify the Width of the selected casing.    

 l Define the Depth of the selected casing, as measured from the back to the front of the casing profile.          

 l Define the Reveal, which is the distance between the inside edge of the door frame and the inside edge of the casing. 

 
Use Exterior Casing

Check this box to enable the settings that follow, then specify the exterior casing for the selected door(s) These settings are 
the same as those for the Interior Casing, and are not available for doors in interior walls unless Separate Trim and 
Materials on Each Side is checked on the GENERAL panel. See General Panel on page 566. 

 
Sill/Threshold

Uncheck this box to prevent a sill from being generated under the door. See Displaying Doors on page 556. 
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Double Wall Options

These options affect doors placed in a Double Wall. See Double Walls on page 386.                  

 l Select Through to create a single jamb running through both Double Walls. This option is selected by default.                     

 l If Enlarged is selected, casing is created only on the wall the door is inserted in. The opening on the other wall is 
enlarged to accommodate the casing.                     

 l Select Double to place a second door in the Double Wall opposite the selected door. This second door cannot be 
selected. Casing is produced as with the Through type window.                     

 l Select Not Through to place the door in one wall with no corresponding opening in the other wall.                     

 
Curved Wall Casing

These settings are enabled if the selected door is located in a curved wall. See Drawing Curved Walls on page 363.                  

 l Door and window casing and jamb can be constructed three ways in curved walls:            

 l Straight - Both the door and casing are straight. This can be used where the wall’s curvature is not too sharp and the 
opening is not too wide. Not available for Sliding, Pocket, or Barn Doors. 

 l Radial - A vertical surface that would be perpendicular to a straight wall has its plane pass through the wall's center 
of curvature. 

 l Parallel - A vertical surface that would be perpendicular to a straight wall remains parallel to the line from the wall 
center through the opening center. 

 
Preview

A preview of the door displays on the right side of the dialog box. If casing is not specified for a Doorway, the Show Wall 
option will be toggled on automatically. See Dialog Preview Panes on page 22.

LINTEL PANEL

The settings on the LINTEL panel allow you to assign a lintel, or top molding that meets the side casing using a butt joint 
instead of a mitered joint. These settings are not available if the door has a reflected arch. See Arch Panel on page 574.         

  The profiles and materials of door and window lintels can be included in Room Finish Schedules. See The Schedule Tools 
on page 695.
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Use Interior Lintel

Check Use Interior Lintel to enable the settings that follow, then specify the lintel applied to the interior side of the 
selected door(s) using these settings. When this box is unchecked, no lintel is used.         

 l Lintel Profile - Click the Library button to select a molding profile for the lintel. A preview of the selected profile 
displays to the right. See Select Library Object Dialog on page 982.

 l Click the Clear button to remove a selected lintel profile from the door. 

 l Specify the Width of the lintel. This value is independent of the casing’s width; however, the lintel does inherit its 
depth from the casing.

 l Specify how far to Extend the lintel past the outside edges of the casing on each side. 

 l Check Wrap to wrap the lintel profile back toward the wall. 

 
Use Exterior Lintel

Check Use Exterior Lintel to enable the settings that follow, then specify the exterior lintel for the selected door(s) using 
these settings. These settings are the same as those for the Interior Lintel, and are not available for doors in interior walls 
unless Use Exterior Trim and Materials is checked on the GENERAL panel. See General Panel on page 566.          

 
Preview

A preview of the door displays on the right side of the dialog box. See Dialog Preview Panes on page 22.         

LITES PANEL

The settings on the LITES panel of the Door Specification dialogs are only available when the selected door is specified as a 
Glass door on the General Panel on page 566. These settings are also found on the LITES panel of the Window 
Specification dialog. See Lites Panel on page 609.   

JAMB PANEL

The settings on the JAMB panel are similar to those on the FRAME panel of the Window Specification dialog. See Frame 
Panel on page 608.         

By default, Has Jamb is unchecked for doorways placed into railings: including solid railings and railing pony walls.          
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Has Jamb

Check Has Jamb to enable the settings that follow, then specify the attributes of the selected door’s jamb using those 
settings. The jamb is not included in the door’s size, which is set on the General Panel on page 566.         

 l Specify the Sides Width, which is the thickness of the pieces of the door jamb that display in plan view. Changing 
this value does not affect the door’s size. This value is subtracted from the "pocket" side rough opening for Pocket 
Doors when wall framing is generated. See Pocket Doors on page 554.

 l Uncheck Fit Jamb to Wall to specify the Depth and Inset of the selected door’s jamb. When this box is checked, the 
jamb Depth automatically extends from the Recessed Into Wall layer to the wall’s inside surface with an Inset of 0”. 
The Recessed Into Wall layer is specified on the Options Panel on page 568 of this dialog.

 l Specify the Depth of the door jamb from front to back.

 l Specify the jamb’s Inset, which is measured from the Recessed Into Wall layer and moves the door jamb towards its 
interior side. If used, the casing and lintel are not affected by this setting.

 
Preview

A preview of the door displays on the right side of the dialog box. See Dialog Preview Panes on page 22.         

ARCH PANEL

The settings on the ARCH panel are also found in the Window Specification dialog.         

The settings on this panel are not available if the selected door is a Sliding, Bifold or Garage door, or if the selected door 
has been assigned a lintel. See Lintel Panel on page 572.         

The ARCH panel is not available for window symbols, and its settings are not available if a selected window has been 
modified using the SHAPE panel. See Shape Panel on page 611.         
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Arch

Define the style and size of the Arch.          

 l Select a Type of arch from the drop-down list.         

 l Specify the Height of the arch, as measured from the base of the arch to the top of the door. Not available for Round 
Top and Octagonal Arches.         

 l The Radius can also be defined for Tudor and Double Arches.
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Options

Define the orientation of the arch. 

 l Check Reflect to reflect the arch, top to bottom. This is typically used with windows rather than doors. Not available 
if a lintel is specified for the selected door. See Lintel Panel on page 572.         

 l Select Full Arch to produce an arch with the apex at the door’s center.         

 l Select Left Arch to produce an arch with the apex on the door’s right side.         

 l Select Right Arch to produce an arch with the apex on the door’s left side.         

Note: The Left and Right settings here on this panel refer to the door 
or window as viewed from its exterior.

 
Preview

A preview of the door displays on the right side of the dialog box. See Dialog Preview Panes on page 22.         

HARDWARE PANEL

Many of the settings on the HARDWARE panel are Dynamic Defaults: if “Use Default” is selected, the setting in the Door 
Defaults dialog for the selected door’s Type is used. See Dynamic Defaults on page 79. 

 
Handles

Specify the Handles to be used on the selected door. 

 l Select an Interior Handle and/or Exterior Handle from the drop-down lists. Select “Library” or click the Library 
button to select a handle from the library. See Select Library Object Dialog on page 982.

 l Specify the location of the door handles In From Door Edge.

 l Specify the location of the door handles Up From Bottom.
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Locks

Specify the door’s interior and exterior Locks. 

 l Select an Interior Lock and/or Exterior Lock from the drop-down lists. Select “Library” or click the Library 
button to select a lock from the library. 

 l Specify the location of the door locks Up From Bottom. The locks use the same In From Door Edge value as the 
handles.

To use the same handle and lock on both sides of a door, select 
“Match Interior” as the Exterior option. 

 
Hinges

Specify the Hinges to be used on the selected door.

 l Select a style of Hinges from the drop-down list. Select “Library” or click the Library button to select a hinge style 
from the library. 

 l Specify the distance In From Top/Bottom of the door to the center of the top and bottom hinges. 

Note: For hinges to look right, it is best to have at least a 1/4" (6 
mm) reveal for the interior, or hinge side, door casing. 

 l Specify the Number of Hinges on the selected door. Interior hinged doors and bifold doors typically have two 
hinges while exterior hinged doors have three.

 
Sliding Tracks

Specify the Sliding Tracks to be used on the selected Barn Door.

 l Select a Sliding Track from the drop-down list. Select “Library” or click the Library button to select a track from 
the library. See Select Library Object Dialog on page 982.

 l Specify the track’s Height Above Door.

 l Select a style of Hangers from the drop-down list. Select “Library” or click the Library button to select a hanger 
from the library. 

 l Specify the distance In From Sides of the door to the center of the outermost hangers. 

 l Specify the number of Hangers to be evenly spaced along the door.

 
Options

Check Hardware on Fixed Section to include handles, locks, and hinges on the fixed side of a double Hinged door. Only 
available for Double Doors with Left or Right Swing Only selected. See Options Panel on page 568.         

 
Preview

A preview of the door displays on the right side of the dialog box. See Dialog Preview Panes on page 22.

SHUTTERS PANEL

The settings on the SHUTTERS panel of the Door Specification dialogs are also found on the Shutters panel of the Window 
Specification dialog. See Shutters Panel on page 577.         
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OPENING INDICATORS PANEL

The settings on the OPENING INDICATORS panel control the appearance of the selected hinged or sliding door's opening 
indicator in camera views using the Vector View Rendering Technique. These settings are also available for windows and 
cabinets. See Opening Indicators on page 557.

 
Opening Indicators

Specify whether the selected door's opening indicators display.

 
Sliding Indicator Style

Available for Sliding, Pocket, Barn, and Garage doors, as well as Single Hung, Double Hung, and Sliding windows. Sliding 
indicator arrows display centered over all movable door panel(s) or window component(s).    

 l Select Fixed Length, then specify the desired Length of the indicator arrow in the text field.

 l Select Relative Length for an indicator arrow sized relative to the movable component it is drawn over.

 l Specify the Inset from Edge, which is the distance of each end of the indicator arrow line from the adjacent edge of 
the associated door panel or window component. If a panel or component is not wide or tall enough to accommodate 
the Inset distance on both ends of the arrow line, this value will be ignored and an arrow 10" (250 mm) long will be 
used.    

 l Specify the Horizontal Offset, which allows you to offset the arrow line to the right or left using a positive or 
negative value.    

 l Specify the Vertical Offset, which allows you to offset the arrow line upwards or downwards using a positive or 
negative value.

 
Preview

A preview of the door displays on the right side of the dialog box. Opening indicators only display in Vector Views. See 
Dialog Preview Panes on page 22.
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ROUGH OPENING PANEL

  Rough Opening

 l Specify the amount to add to Each Side, the Top and the Bottom for the door’s framed rough opening. The rough 
opening should be large enough to accommodate the door frame and space for shims. Window frames do not need to 
be included in the rough opening: only shim space.

  Add for Concrete Cutout

 l Specify the amount to add to Each Side of the door opening when the upper part of the door is in a framed wall and 
the lower part is located in a concrete or masonry wall, stem wall, or garage curb. See Wall Type Definitions on page 
388.

 l Uncheck Show in Plan to suppress the display of the concrete cutout in plan views. A concrete cutout will only 
display in plan views if it is located in a garage curb. See In Plan Views on page 556.

FRAMING PANEL

The settings on the FRAMING panel control how the selected door or doors is framed. A similar panel is also found in the 
Window Specification dialog. See Window Specification Dialog on page 599.         

Chief Architect is dependent upon user input and does not 
calculate loads or perform structural analysis. Always consult 

your local building authorities and contact a licensed engineer for 
structural calculations.
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Header

Specify the characteristics of the selected door’s header. See Headers on page 866.         

 l Uncheck Include Header to prevent a structural header from generating when wall framing is created. When this 
box is checked, a header as defined below is generated; when it is unchecked, a single, non-structural, horizontal 
framing member of the same type as the wall studs is created above the door opening.    

 l Select the header’s framing member Type from the drop-down list. See Structure Types on page 901.    

 l When Automatic is checked, the program will confirm that the Type selected above agrees with the framing 
material used by the wall, and will generate a different header Type if it does not. The Type that will be generated is 
reported in parentheses for reference. When unchecked, the specified Type is used regardless of the wall’s structural 
material.    

 l Specify the Thickness of each header framing member.    

 l Specify the Count, which is the number of the framing members used to create the header. Up to 10 header boards 
can be specified, but only those that fit within the wall’s framing layer will be generated when wall framing is 
created.    

 l Specify the vertical Depth of the header. This value does not include the top and bottom chords of a Box Header.    

 l In the Door and Window Defaults dialogs, an additional Calculate from Width check box is available. When 
checked, the header Depth is automatically calculated based on settings in the Framing Defaults dialog and the 
door’s current width. See Openings Panel on page 880.    

 l When Evenly Spaced is checked, the boards that comprise the header are evenly spaced within the wall's framing 
layer. Uncheck this box to specify the spacing of the header boards, below.    

 l When Evenly Spaced is unchecked, specify the Spacing of the vertical boards that comprise the header.    

 l Check Box Header to add horizontal top and bottom rails above and below the vertical rails. These horizontal 
boards are not included in the header Depth.  See Headers on page 866.    

 l Specify the attributes of the Header Label for the selected door’s headers. See Framing Labels on page 895.          

 
Header Placement

Specify where the selected door's header is positioned within the wall assembly. The defaults for these values are set in the 
Door Defaults dialogs. See Headers on page 866.    

 l Depth Placement - A header that does not span the full thickness of the wall's framing layer can be Flush Against 
Exterior Edge of that layer, or Flush Against Interior Edge.     

 l Vertical Placement - A header may be positioned directly above the Top of Opening, just above the Rough 
Opening, or at the Top of Wall, just below the wall's bottom top plate. 

 
Adjacent Openings

These options are only available when Top of Wall is selected for the Vertical Header Placement, above.    

 l Check Combine Headers to have any doors and/or windows close to the selected opening share the same header. In 
addition to being closely positioned, the other openings must have the same header Depth and have Top of Wall 
selected. Not all openings must have this box checked, however.

 l Specify the Maximum Combine Distance, which is the largest distance between openings that will allow them to 
share a header. 
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Supports

Specify the number of Trimmers and King Studs to be generated on each side of the selected door.          

 
Sills

When the bottom of a door is raised sufficiently off the floor, it will require a sill as part of its framing.          

 l Specify the Bottom Sill Thickness, which is the vertical thickness of the sill board.

 l Check Double Bottom Sill to generate two bottom sill members of the specified thickness instead of one.

 l Check Include Top Sill to include a sill board across the top of the Rough Opening. If Top of Opening is selected as 
the header's Vertical Placement, the header will be positioned on top of the sill.

 l Specify the Top Sill Thickness.

 l Check Double Top Sill to generate two top sill members of the specified thickness instead of one.

ENERGY VALUES PANEL

The settings on the ENERGY VALUES panel are also found on the panel of the same name in the Window Specification 
dialog. See Energy Values Panel on page 616.   

LAYER PANEL

The LAYER panel is available for a variety of different objects. For more information, see Layer Panel on page 191.

MATERIALS PANEL

The MATERIALS panel is available for a variety of objects throughout the program. For more information, see Materials 
Panel on page 1055.

LABEL PANEL

Door labels display in plan view and cross section/elevation views when the “Doors, Labels” is turned on and use the Text 
Style assigned to that layer. See Door Labels on page 557. 

For information about the settings on this panel, see Label Panel on page 712.

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 1335.         

OBJECT INFORMATION PANEL

The information entered on the OBJECT INFORMATION panel can be used in schedules and the materials list. For more 
information, see Object Information Panel on page 1336.         

SCHEDULE PANEL

The settings on the SCHEDULE panel determine which schedule categories the selected door is included in. See Schedule 
Panel on page 716. 
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MANUFACTURER PANEL

The MANUFACTURER panel provides contact information for the selected door’s manufacturer. Only available for doors from 
Manufacturer library catalogs. See Manufacturer Catalogs on page 970.         
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Chapter 16
 

Windows

Chief Architect can model a wide variety of windows. Fixed glass, hung, casement, sliding, awning, hopper, and louver 
window styles can all be created with the standard Window tool. The shape of a window can be angled or made into a round 
top or other arch styles. Chief Architect can create bay, box, and bow windows with a single click. In addition, the library 
contains many mulled window combinations and additional name-brand door catalogs are also available for download from 
our website, chiefarchitect.com.

Once windows have been placed in the model, the program can automatically generate a window schedule. See The 
Schedule Tools on page 695.         

TOPICS

Window Defaults 585
Window Tools 585
Special Windows 587
Grouped Windows 590
Mulled Units 591
Window Levels 593
Displaying Windows 594
Editing Windows 597
Custom Muntins 598
Window Specification Dialog 599
Bay, Box, and Bow Windows 618
Bay, Box, Bow Windows and Roofs 620
Bay/Box and Bow Window Specification Dialogs 624
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Window Defaults
Default Settings can be accessed by selecting Edit> Default Settings. Select Window from the Default Settings 
dialog and click the Edit button.

You can also double-click the Window Tools  parent button to open the Window Defaults dialog.           

The settings in the Window Defaults dialog control the attributes of a window when it is initially placed in a plan, so you 
should define the type of window that will be placed most often in your model. See Default Settings on page 76.

The panels in the Window Defaults dialog are similar to those found in the Window Specification dialog, with one 
exception: 

On the GENERAL panel of the Window Defaults dialog, you can specify the Minimum Separation between window and/or 
door units in the plan.

The Minimum Separation value in the Window Defaults dialog specifies how close window and/or door units can be to 
each other. This setting also determines the width of the shared casing between windows. 

For more information, see Window Specification Dialog on page 599.

DYNAMIC WINDOW DEFAULTS

A variety of window default values are dynamic, including the Window Type, Casing, Lintel, Sash, Frame, Treatments, 
Framing, and Rough Opening. All Materials are also dynamic. When a dynamic default is changed, existing windows using 
the default value are affected. See Dynamic Defaults on page 79. 

WINDOW FRAMING

The defaults for window framing can be defined in the Window Defaults dialogs. You can also specify an additional amount 
to cutout for window openings in concrete walls when the upper part of the window is located in a framed wall. See Rough 
Opening Panel on page 616 and Framing Panel on page 616.

The default header depths for different spans can be set in the Framing Defaults dialog. See Openings Panel on page 880.

 

Window Tools
To place a window, select Build> Window and choose the desired Window Tool. Move your mouse pointer over a 
wall section, then click to place a window in the wall at that location.

 l If there is room enough along the wall to fit a 6” (150 mm) wide Standard Window, a preview of the window will 
display and a window can be placed. 

 l The Bay, Box, and Bow Window tools do not have preview outlines. If a minimum width of 30” (725 mm) cannot be 
accommodated at the location where you click, a warning message will display and a window unit will not be created.

Standard Windows, Passthroughs, and Wall Niches can be placed in both straight and curved walls, as well as span across 
straight, collinear wall segments. In contrast, a Bay, Box, or Bow Window can only be placed in a single, straight wall.

Windows can also be placed in the Pony Walls; however, if the upper wall is a Railing, only Windows, Passthroughs, and 
Wall Niches can be placed provided that they are located entirely within the lower wall. See Pony Walls on page 357.
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Windows cannot be placed in a wall specified as Invisible or if the wall in question is on a locked layer. See Locking Layers 
on page 182.

STANDARD WINDOWS

Select Build> Window> Window, then click on a straight or curved wall to place a Standard Window at that 
location.

A Standard Window is a single window that is not a bay, box, bow window, a corner window or a blocked unit. These 
special types are made up of multiple Standard Windows. 

A Standard Window that is part of a special window is called a Component Window.

Standard Windows can be specified as any of a variety of window types, such as double hung, casement and awning. See 
Window Specification Dialog on page 599.

BAY WINDOWS

The roof is affected by Bay, Box and Bow Windows. These 
windows should therefore be placed before the roof is built.

A Bay Window is composed of three wall sections, each with a single component window. The two side walls are at 
an angle to the main wall. Select Build> Window> Bay Window and click on a straight wall to produce a bay 

window. 

When initially placed, bay windows measure  2’-2” across at the front, 4’-2” across at the back, and are 1’-0” deep. The 
component windows are specified in the Window Defaults dialog and their sizes adjust to fit the available space. 

BOX WINDOWS

A Box Window is a bay window with side angles set at 90°. Select Build> Window> Box Window and click on a 
straight wall to produce a box window. 

Box windows initially measure 4’-2” wide with a depth of 1’-6”. The component windows are specified in the Window 
Defaults dialog and their sizes adjust to fit the available space. 

BOW WINDOWS

A Bow Window is a group of identical wall segments that form a segmented curve. Select Build> Window> Bow 
Window and click on a straight wall to produce a 5-section bow window. 

Bow windows can be composed of between two and twenty sections. The number of bow window components can be 
changed in the Bow Window Specification dialog. See Bay/Box and Bow Window Specification Dialogs on page 624.          

The component windows are specified in the Window Defaults dialog. Their sizes adjust to fit the available space.
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The 5-section bow below has a 4’-10” radius centered 3’-9” inside the wall, giving an opening 5’-10” across and a depth of 
11½”.

Note that for a bow with an odd number of sections, the radial dimension is from the center of the arc to an outside corner 
where two window sections join. The depth (11 ½”) is measured to the flat area of the center section, not to a corner. As a 
result, the radius is a bit greater than the sum of the depth and the distance from the center of the bow’s curve to the exterior 
of the wall.          

Note: Bay, box, and bow window areas are not included in the living area 
or in room standard area calculations. They are included in room interior 
area calculations.

PASS-THROUGHS

Select Build> Window> Pass-Through, then click on a straight or curved wall to place a Pass Through at that 
location.         

A Pass-Through is simply a wall opening without a window unit placed inside. Like a window, it can have casing and a sill. 
It does not, however, have a sash, frame, or glass. It is one of the window Types available in the Window Specification 
dialog. See General Panel on page 600.         

WALL NICHES

Select Build> Window> Wall Niche, then click on a straight or curved wall to place a Wall Niche at that location.

A Wall Niche is a wall opening that does not extend through the entire depth of the wall. You can specify the niche’s depth 
in the Window Specification dialog. See General Panel on page 600.

WINDOWS LIBRARY

Select View> Library Browser, then browse to Chief Architect Core Catalogs> Architectural> Windows to access a 
selection of special window units. Select the desired window, then click on a wall to place the window at that 

location. 

 

Special Windows
A variety of special windows can be created using multiple standard windows, the edit tools or custom symbols.

CREATING MANUAL BAY, BOX AND BOW WINDOWS

Sometimes it is easier to draw bay, box and bow windows manually than to use the automatic tools. Bays created using 
walls can have more than one window per section, which is not possible using a bay window unit.

Bear in mind that moving a manually created bay, box or bow window is generally more difficult than moving a unit 
created with one of the Window Tools  since it is composed of individual walls.
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CORNER WINDOWS

To create a corner window, first create the desired window on each side of the corner. For best results, the heights, casing, 
and sills of both windows should be the same. For glass that meets at the corner: 

 l Specify both windows as Fixed Glass.          
 l Use each window’s Move edit handle to position it all the way in the corner. To do this, drag the Move handle past the 

corner and parallel to the wall that the window is placed in. When the preview outline moves into the middle of the 
wall corner, release the mouse button.          

 l You can also position a window in a corner using its end Resize handle.          
 l Uncheck Has Corner Post in the Window Specification dialog. See Frame Panel on page 608.          

Angled top, or shaped windows can be components of corner windows as long as their heights are equal at the corners. 
Windows with single or two segment tops can be used, but windows with three cannot. If a two segment window is used, 
the segment nearest the corner must be flat.          

When a corner post is required, there are a number of ways to control its size.          

 l Use dimensions to position the windows relative to the corner. By default, windows will stop when their interior 
casing bumps into the adjacent wall. See Editing Windows on page 597. 

 l To move a window all the way into a corner, check Ignore Casing for Opening Resize. See General Plan Defaults 
Dialog on page 96. 

 l To produce a minimal corner post and no siding or casing between the windows, use their Move edit handles. Click 
and drag each window past the exterior corner until its preview outline moves into the middle of the wall corner. 

SPECIAL WINDOW SHAPES

A selection of special shaped windows is available in the Windows Library, including arched windows and mulled units. 

In addition, you can create a wide variety of window shapes in the Window Specification dialog, including:         

 l Arched windows. See Arch Panel on page 613.         
 l Trapezoidal windows. See Shape Panel on page 611.         
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 l Round windows can be created by reflecting a Round Arch window vertically. See Arch Panel on page 613.          

RECESSED WINDOWS

A window or mulled unit placed in a brick or stone wall is often recessed into the wall’s exterior, so the brick wraps the 
opening.         

You can specify a window as recessed in the Window Specification dialog. See Options Panel on page 602.          

WINDOW SYMBOLS

You can import custom windows and save them in your own library for use in future plans. See Custom Symbols on page 
992.          

By default, window symbols are assigned the “Custom” Type in Window Schedules and in the Window Symbol 
Specification dialog, and they use automatic labels appended with the letters CU. The Type is derived from the Symbol 
Specification dialog, where you can also select the CAD block used to represent the symbol in plan view. See Symbol 
Specification Dialog on page 993.           

PLACING A GABLE OVER A WINDOW

Click the Gable Over Door/Window edit button to produce a gable roof over the selected window(s) the next time 
automatic roofs are built. See Gable/Roof Lines on page 846.         

You can manually edit or delete this gable line at any time. Your changes take effect when the automatic roofs are rebuilt. 
This tool can also be used with group selected windows.         

STAINED GLASS

A selection of solid stained glass materials is available in the Chief Architect Core Catalogs> Materials> Glass library. See 
Materials on page 1050.         

VENTS

A selection of attic, foundation and gable vents are available in the Library Browser. See The Library on page 961.

Vents are placed in the same manner as regular windows and can be edited in much the same way, as well. 
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Grouped Windows
Windows can be grouped together to create a wide variety of custom configurations. Stacked windows are easy to create in 
3D views, particularly cross section/elevation views, using their edit handles. See Editing Windows on page 597.

Notice how the windows and door in this example are separate, with spaces between them. Doors and/or windows can also 
be organized into a unit in which  there are no spaces between the windows and door units, and the casing between them is 
shared. To help organize their display in plan view, you can place stacked windows of varying heights on different Window 
Levels. See Window Levels on page 593.

AUTOMATICALLY MULLED OPENINGS

To form a mulled group of windows and/or doors, move them close enough together so that their casings touch. Once the 
casings touch, the windows are mulled together with one casing between the two of them. 

The sill of each window in the group must be at the same level for them to share the middle casing; however, the casing 
tops do not. The casings are modeled as if they are one unit but the windows remain separate objects for dimensioning and 
the Materials List.

Windows can be automatically mulled to doors if the bottom of the window is at the elevation of the floor, equal to the 
bottom of the door. 

The Minimum Separation value in the Window Defaults dialog specifies how close window and door units can be to each 
other. This setting also controls the width of the shared casing between adjacent windows. See Window Defaults on page 
585.          

MULLED UNITS IN THE LIBRARY

A selection of mulled window units is available in the Windows library. To place one in your plan, select it and click 
on a wall in any view. See Placing Library Objects on page 980.

MAKE MULLED UNIT

Windows and doors can be selected as a group and blocked together into a single unit by clicking the Make Mulled 
Unit edit button. See Mulled Units on page 591.         

MULTIPLE STACKED OPENINGS

If four or more multiple windows or doors occupy the same space in a wall, a Caution   symbol will display at the 
problem location in plan view.
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Click on the Caution   symbol that displays over the wall to open a contextual menu, then select Delete Duplicate to 
delete a duplicate opening. When no more Caution symbols remain, you should then confirm that the remaining three 
openings meet your needs and delete any that are unnecessary.

 

Mulled Units
A mulled unit is a group of two or more windows and/or doors blocked together to form a single unit. A selection of mulled 
units is available in the Library Browser, and you can also create your own using the Make Mulled Unit edit tool.

MAKE MULLED UNIT

The Make Mulled Unit edit tool allows you to block a group of selected windows and/or doors into a single unit. 

Wall openings in a mulled unit are referred to as components. Components of a mulled unit must be within 24” (600 mm) of 
one another in order to become a blocked unit; however, their casings do not have to touch.

Windows and doors in a mulled unit can be framed as a single opening or as multiple openings, and can be listed as a single 
unit or individual objects in the Materials List. See Materials Lists on page 1309. 

To create a mulled unit
 1.  Make sure that dimensions are set to locate Opening Sides, then use dimensions to position the windows and doors 

the desired distance apart. See Moving Objects Using Dimensions on page 491. 

 2.  In any view, group-select multiple windows and doors on the same wall that are within 24” of each other. 

 3.  Click the Make Mulled Unit  edit button to create a block. 

The Make Mulled Unit  edit tool can be used to block component windows and/or doors only if they meet the following 

requirements:

 l They must be placed in the same wall.
 l Adjacent objects be within 24” (600 mm) of one another (side to side or top to bottom).
 l The edges of adjacent components that face one another must be parallel.
 l The edges of adjacent components that face one another must be straight, not curved.
 l The selected components can be adjacent vertically or horizontally, but not a combination of the two. Complex units 

can be formed only by mulling several blocks together.

Unlike automatically mulled openings, adjacent component edges of mulled units do not need to be the same length.

MULLING STACKED OPENINGS

Group selection can be done in plan view or any 3D view. Plan views work well for blocking windows that are side-by-side, 
but a camera or elevation view is needed to block vertically stacked objects. 

To block stacked openings
 1.  In a cross section/elevation view, select the door and the windows on level 1 and 2 above it, then click the Make 

Mulled Unit  edit button. 

 2.  Repeat step 1 with the sidelight on the right and the window above it. 
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 3.  Repeat step 1 with the sidelight on the left and the window above it.

 4.  Group select the three vertically joined units and click the Make Mulled Unit  edit button to join them side to 

side. 

The configuration of the horizontal and vertical mullions in a mulled unit will vary depending on the order in which you 
block stacked openings. 

 l If you form a mulled unit by first blocking objects vertically, the vertical mullions of the larger unit will extend 
continuously from the bottom to the top of the entire unit, breaking any horizontal mullions. 

 l If you form a mulled unit by first blocking objects horizontally, the horizontal mullions of the larger unit will extend 
from side to side, breaking any vertical mullions.

In a complex unit composed of smaller units, there may be a variety of ways to organize the sub-units. 

SELECTING COMPONENTS OF MULLED UNITS

To select a component of a mulled unit, click at the location of the component in question, then click the Select Next 
Object  edit button or press the Tab key until that individual component is selected. Only the component clicked on is 

selectable using this method. If you need to select a different component, click on it and repeat the process.

The selected component may be on any window level in the mulled unit. If there are multiple levels, it is easiest to select the 
components in a 3D view. When you have selected an individual component, you can change its parameters in the Window 
Specification dialog. See Window Specification Dialog on page 599.

If the selected component is not itself a mulled unit and has no components above it, its Height and Arch parameters can be 
changed. Changing the Height causes the component top to move. The bottom remains stationary.

DISPLAYING MULLED UNITS

As with other windows, the display of mulled window units is controlled in the Layer Display Options dialog. See 
Layer Attributes on page 181.

Mulled units are placed on the “Windows” layer by default and have a single label, which is on the “Windows, Labels” 
layer. Mulled units are also included in the windows category of the Materials List and in window schedules. If the 
component objects of a mulled unit have unique moldings or materials, they will not be noted in the Materials List or in 
room finish schedules. See Schedules and Object Labels on page 694.

If a mulled unit includes a door, Treat as Door will be checked in the Mulled Unit Specification dialog. When this box is 
checked, the unit’s default layer is “Doors” and its label is placed on the “Doors, Labels” layer. Units set to Treat as Door 
are also included in the “Doors” category of the Materials List, and these units’ Auto Schedule Category is “Mulled Door 
Units” instead of “Mulled Window Units”. Similarly, their casing is recognized as door casing in Room Finish Schedules. 
See Options Panel on page 602. 

You can, if you wish, display a mulled unit’s individual component labels instead of a single label for the unit. Labels are 
placed on the layers they would be on were the unit not mulled. A mulled unit’s label setting also affects how it is listed               in 
schedules and in the Materials List. See Label Panel on page 712.         

 l When Suppress All Labels is selected, individual components are counted               in schedules and in the Materials List.         
 l When Show Component Labels is selected, components are counted               in schedules and in the Materials List.
 l When Show Single Label for Entire Unit is selected, the unit is treated as a single object in schedules and the 

materials list.

Mulled units can be placed on different Window Levels to control their appearance in plan view. See Window Levels on 
page 593.          
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EDITING MULLED UNITS

A mulled unit moves as a single standard window in both floor plan and 3D views.           

The components of a mulled unit cannot be moved relative to one another. If this is required, you will first need to explode 
the mulled unit.           

To explode a mulled unit
 1.  Select the mulled unit.          

 2.  Click the Explode Mulled Unit  edit button.          

 

Window Levels
It is often necessary to position more than one window, mulled unit, and/or door at the same location along a wall in plan 
view: for example, to create an entry with side lites and transom. 

To help control and organize the appearance of stacked wall openings in plan view, you can assign windows at various 
heights to different Window Levels.           

Window Levels do not define the height of a window, just the appearance and behavior of windows and doors in plan view.          

 l In plan view, windows and doors on the Default Level display the line color and style of the layer they are on. See 
Layers on page 180.           

 l Windows on any other level appear light gray, regardless of the layer they are on.           

THE DEFAULT LEVEL

The Default Level is the Window Level that Standard Windows are initially placed on when created and affects several 
things:           

 l In plan view, windows and doors on the Default Level display the line color and style of the layer they are on.           
 l When you click on stacked doors and windows in plan view, those on the Default Level are selected first. To select an 

opening on another level, use the Select Next Object  edit button. See Select Next Object on page 215.           

Typically, the Default Level is set as 0 (zero).          

WINDOW LEVEL ZERO

Window Level 0 (zero) is the level that all Bay, Box and Bow windows and doors are always placed on. Typically, it is 
also the Default Level that standard windows are placed on, as well.           
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Because doors are always on Level 0 and because Window Levels affect line colors in printouts, it is usually best to keep 
the Default Level at 0. If you do change the Default Level, remember to change it back before printing.          

Once the window is created, its parameters, including Window Level, can be changed. See Editing Windows on page 597.            

In addition to using Window Levels to manage the appearance of stacked windows, you can combine them into a single 
blocked unit. See Mulled Units on page 591.           

 

Displaying Windows
The display of windows and window labels in floor plan and 3D views can be controlled in the Layer Display 
Options dialog. See Layer Display Options Dialog on page 183.

Along with the windows themselves, the display of a number of window components can also be controlled by layer:

 l Interior and exterior window casings are located on the “Casings, Exterior” and “Casings, Interior” layers and can 
display in all views. In plan view, the sills and vertical side casings will be shown, but the horizontal top casing or 
lintel will not. If a window is recessed, the affected wall layers will adjust to accommodate the casing. 

 l Window and door shutters are located on the "Shutters" layer and can display in all views. Shutters can also be set to 
Show Closed or open. See Shutters Panel on page 614.

 l When the “Opening Header Lines” layer is turned on in plan view, headers are represented by dashed lines within each 
window. These lines do not correspond to actual framing objects and cannot be selected. In addition, header framing 
members can be set to display. See Wall Framing on page 866.      

 l If a window is placed in a Garage room at a height where it extends into the stem wall or curb, a cutout in the concrete 
will display on the floor below. You can specify the cutout’s size and whether it displays in plan view in the Window 
Specification dialog. See General Panel on page 600.      

If the “Windows” layer is not set to display, window casing and other components are not visible, but the openings in the 
walls where they are located can still be seen.

Windows can only be placed in walls, so if a wall’s layer is turned off in plan view, any windows placed in that wall will 
not display, either. Windows can display independent of their containing walls in 3D views, however. See Displaying Walls 
on page 366. 

IN PLAN VIEW

A window’s frame, glass, and sill are all represented in plan view. This makes some window types, notably Sliding and 
Double and Triple Casement windows, distinguishable. 
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Window Types in plan view

By default, when a window is located entirely in one part of a pony wall, and that part is not displayed in plan view, the 
window’s outline is shown but the wall’s layer lines and fill drawn through it. You can instead display windows in the non-
displayed parts of pony walls the same as in the displayed parts, or not at all. See Pony Wall Defaults on page 349.          

Bay, box, and bow windows have dimensions lines associated with them. 

 l You can suppress their display by turning off the “Manual Dimensions” layer or on a unit by unit basis in the unit’s 
specification dialog. See Bay/Box and Bow Window Specification Dialogs on page 624. 

 l The arrow style and fill are set in the Dimension Defaults dialog. See Dimension Defaults Dialog on page 457.             

IN 3D VIEWS

In 3D Vector Views, windows can display opening indicator arrows. See Opening Indicators on page 557.           

You can also specify whether window and door glass is opaque or transparent in the Rendering Technique Options dialog. 
See Rendering Technique Options on page 1150.          

When displayed as opaque, window and door glass uses the Material Color set in the Define Material dialog. See Pattern 
Panel on page 1067.           
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WINDOW LABELS

Window labels display in floor plan and cross section/elevation views, centered on the windows they represent, when the 
“Windows, Labels” layer is turned on and use the Text Style assigned to their layer. Similarly, Wall Niche labels display in 
the same manner when the "Wall Niches, Labels" layer is turned on. See Label Panel on page 712.

Automatic window and niche labels indicate Width and Height, followed by Type. For example: 

 l In U.S. Unit plans, the automatic label for a 3’-0” wide, 4’-0” high double hung window will read 3040 DH.
 l In metric plans, the automatic label for a 900 mm wide, 1200 mm high double hung window will read 900x1200 DH.

If you prefer, you can use one of two other formats: Height/Width followed by Type and Width Only followed by Type. 
Label formats are specified in the Window Schedule Specification dialog or in the Window Schedule Defaults dialog if no 
schedule is present. See Labels Panel on page 709.           

You can specify whether a Bay, Box or Bow Window displays a single label or displays the labels of its component 
windows. This choice will affect how the unit displays in schedules. See Bay, Box, and Bow Windows on page 618.

 l When Suppress All Labels is selected, individual components of Bay, Box and Bow Windows are counted in 
schedules and in the Materials List.              

 l When Show Component Labels is selected, components of Bay, Box and Bow Windows are counted                  in schedules 
and in the Materials List.             

 l When Show Single Label for Entire Unit is selected, the Bay, Box or Bow Windows is treated as a single object in 
schedules but not in the materials list.           

These options are also available for mulled units but affect their display in schedules and the materials list somewhat 
differently. See Displaying Mulled Units on page 592.          

Customized labels using text and Object Specific Text Macros as well as label position and orientation can also be specified 
in the Window Specification dialog. See Text Macros on page 549.

IN THE MATERIALS LIST

The materials associated with windows are listed under different Categories in the Materials List:

 l Windows - Lists windows units, including Passthroughs.     
 l Interior Trim - Lists interior casing, lintels, aprons, and sills.     
 l Exterior Trim - Lists exterior casing, lintels, aprons, sills, and shutters.     
 l Wall Board - Lists the backerboard associated with Wall Niches.     

As with other objects, there are a number of ways to control how, or whether, windows are included in the Materials List. 
See Organizing Materials Lists on page 1317.      

You can add and edit information about a window’s accessories in the Window Specification dialog. See Components Panel 
on page 1335.      

WINDOW SCHEDULES

The Window Schedule tool is set up to produce customizable window schedules as well as window labels that 
display schedule numbers. Any schedule, however, can be set up to include windows. See Schedules and Object 

Labels on page 694. 

In addition, any information about window casing and lintels can also be included in any schedule set up to include items in 
the Room and/or Molding categories. See Room Finish Schedules on page 453.
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Editing Windows
Before a window can be edited, it must be selected. Click on a window when the Select Objects  tool or any of the 

Window Tools  are active. Doors and/or windows can also be group-selected and edited. See Selecting Objects on page 

212.

To select a window that is part of a blocked unit, click the component window, then click the Select Next Object  edit 

button. See Selecting Components of Mulled Units on page 592.

Once selected, windows can be edited using their edit handles, the Edit Toolbar buttons, and their specification dialogs.

USING THE EDIT HANDLES

In plan view, click either of the two end handles and drag along the wall to change the width. The label showing the size 
updates as the window is resized. 

In 3D views, a selected window has five edit handles: the Move handle at the center and a Resize handle on each edge. 
Click and drag an edge handle to resize the window.

Using the edit handles, a window resizes according to the currently active Edit Behavior . See Defaults, Preferences, 

and Edit Behaviors on page 208.    

A single window or a group of windows can be moved with the center edit handle.

A door or window moved against an intersecting wall temporarily stops when it is the casing distance from the intersecting 
wall. Enable Ignore Casing for Opening Resize in the Plan Defaults dialog to turn off this behavior. See General Plan 
Defaults Dialog on page 96.

You can continue to drag the selected window and  it will resume movement past or onto the intersecting wall. 

To create a corner window, drag the Move handle straight out past the wall corner, parallel to the selected window’s wall. 
See Corner Windows on page 588.

IN THE SPECIFICATION DIALOG

The most precise method of editing an individual window or group of windows is to use the Window Specification 
dialog. The window type, size, casing, materials, shape, and more can all be specified in this dialog. See Window 

Specification Dialog on page 599.

You can apply a variety of window attributes to multiple windows - including bay, box, and bow windows - at once using 
Style Palettes. See Style Palettes on page 284.    

You can also use the Object Painter  tools to assign the properties of one window to other windows. The Object Painter 

tools do not affect bay/box/bow windows. See Matching Properties on page 286.     

USING THE EDIT TOOLS

A selected window or windows can be edited in a variety of ways using the buttons on the Edit Toolbar. See The Edit 
Toolbar on page 135.

597



Chief Architect Premier X14 Reference Manual - Custom Muntins

  Gable Over Door/Window  creates a gable over the selected window(s) the next time the roof is rebuilt. See 
Gable/Roof Lines on page 846.     

  Change Wall Side moves a selected Wall Niche to the opposite side of the wall. See Wall Niches on page 587.

  Make Mulled Unit  can be used to block multiple selected windows and/or doors into a single unit, while 
Explode Mulled Unit breaks a mulled unit into its individual components. See Mulled Units on page 591. 

USING DIMENSIONS

Like various other objects, windows can be moved using dimensions. See Moving Objects Using Dimensions on page 
491. 

You can specify how windows and doors are located by dimensions in the Dimension Defaults dialog. Dimensions can be 
set to locate the centers, sides, casing, and/or rough openings of windows and doors, or you can choose to not locate them at 
all. See Locate Manual Panel on page 460.           

Once a dimension line has been drawn, you  can move or add its extension lines to locate non-default locations on a window. 
See Editing Extension Lines on page 486. 

WINDOW CASING, SILLS, AND MILLWORK

Windows often feature casing, or trim, on both sides of the wall opening as well as a sill on one or both sides. See Moldings 
/ Profiles Panels on page 943.          

The default casing for windows is a basic rectangular stock profile. You can specify a window’s casing profiles in the 
Window Specification dialog, or you can choose to suppress casing altogether. See Casing Panel on page 603.          

A separate molding profile can be specified for the lintel, or top horizontal molding. A sill profile can be specified, as well. 
See Lintel Panel on page 606.          

Additional millwork items can be applied above and below the window’s casing on its exterior side. See Treatments Panel 
on page 613.           

Each of these objects can be replaced with a different profile or object directly from the library in 3D views. Select a 
molding profile or millwork item, then click on the window component you want it to replace. See Replace From Library 
on page 983.           

 

Custom Muntins
You can design your own muntins for the glazing of a window or door. Muntins are formed from a CAD block composed of 
lines and arcs drawn over window or door glass in a cross section/elevation view. The CAD block should cover at least half 
the glass horizontally and one quarter of the area vertically, but should not overlap it in either direction by more than five 
percent. Nested CAD blocks cannot be used. See CAD Blocks on page 333.          

CREATING MUNTINS

Custom muntins are created by drawing their pattern using the CAD tools, blocking the pattern to create a CAD 
block, and then selecting the window and clicking the Load Muntins edit button.         
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To create custom muntins
 1.  Create a Cross Section/Elevation  view of the wall the window or door is in and Zoom  in on the window or 

door.           

 2.  Use the Draw Line  and Draw Arc  tools to design the desired muntins. Try to make them start and end as 

close to the edge of the glass as possible.          

 3.  When the muntin design is complete, group-select all lines and arcs and click the Make CAD Block  edit button. 

See Selecting Objects on page 212.           

 4.  Select the door or window and click the Load Muntins  edit button to convert the CAD block into custom 

muntins.          

 l If the window in question is the component of a mulled unit, bay, or box window, click on it and, then click the Select 
Next Object  edit button.          

 l If the window in question is the component of a bow window, the custom muntins will load onto all of its components 
- not just one of them.          

If your window has more than one sash (a double-hung window, for example, has two), you must create a separate CAD 
block for each pane. When you click Load Muntins , all CAD blocks are loaded.          

Custom muntins move with the opening and copy with their opening. They also stretch or compress when the glass area is 
resized. This stretching may not be perfect for non-rectangular glass areas that are resized by a large amount.          

Custom muntins can be created for the components of Bay Windows , Box Windows , and mulled units. To create 

custom muntins for a Bow Window , you must draw them on the one component that is selectable. When the muntins 

are loaded, they will be applied to all of the components See Component Windows on page 619.          

The Load Muntins  edit tool can also be used to add custom muntins to glass doors. See Special Doors on page 563.          

A selection of CAD blocks created for use as custom muntins is 
available in the library in Chief Architect Core Catalogs> 

Architectural> Windows> Custom Muntins.

EDITING MUNTINS

Once blocked and loaded, custom muntins cannot be edited. If you wish to make changes to them, you must first remove 
them.          

REMOVING MUNTINS

Remove custom muntins from a door or window by selecting the opening in cross section/elevation view and clicking 
the Unload Muntins edit button. The muntins disappear and the original CAD block takes their place.         

 

Window Specification Dialog
To open the Window Specification dialog, select a window or a group of windows and click the Open Object edit 
button; or double-click the window using the Select Objects  or a Window  tool. 
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This dialog is also available for the components of Bay, Box, and Bow Windows. See Bay, Box, and Bow Windows on page 
618.

You can also open the specification dialog for the window(s) associated with a schedule row. See Open Row Object(s) on 
page 699.          

The settings in this dialog are similar to those in the Window Defaults dialog. See Window Defaults on page 585.

The settings in this dialog are also similar to those in the Wall Niche, Mulled Unit and Window Symbol Specification 
dialogs. Although similar, a number of the options cannot be edited when either a window symbol or a mulled unit is 
selected, and some panels are not available. See Grouped Windows on page 590.

The panels that are available in the Window Specification dialog will vary depending on whether the selected window is a 
regular window, a mulled unit, or a symbol object.

GENERAL PANEL

In the Wall Niche Specification dialog, only the Size and Position and Include in Schedule settings on this panel are 
available. See Wall Niches on page 587.

 
Window Type

Select the type of window from the list. The first entry in the list is the “Use Default”, which is set in the Window Defaults 
dialog. 
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  Size and Position

 l Specify the window’s Width and Height. These values include the window frame. See Frame Panel on page 608.

 l Select the Elevation Reference from the drop-down list. This determines where the next two settings are measured 
from and also affects their setting labels.

 l Specify the height to Top, measured from the selected Elevation Reference to the top of the window frame. 

 l Specify the height to Bottom, measured from the selected Elevation Reference to the bottom of the window frame.

 l Specify the Depth of the selected Wall Niche, measured from the wall surface to the back of the niche. Only 
available for Wall Niches.

Note: When either the Floor to Top or Floor to Bottom setting is 
modified, the other will adjust in response to prevent the window’s 
Height from changing.

 
Component Options

These settings affect windows with movable sections and are not available for Pass-Throughs, Fixed glass windows, mulled 
units, or window symbols.  

 l Specify the Bottom Component Size for Single Hung, Double Hung, Double Awning, Double Hopper, and Triple 
Hopper windows; specify the Top/Bottom Component Size for Triple Awning windows; or, 

 l Specify the Side Component Size for Triple Casement and Triple Sliding windows, the Right Component Size for 
Left Sliding windows, or the Left Component Size for Right Sliding and Double Casement windows. A 
Component Size value of 0 creates  a window with identically sized components. 

 l Specify how each Component Opens from the available options. Only available for Casement, Double and Triple 
Awning, and Double and Triple Hopper windows.           

 
Interior Windows

These settings are only present when the selected window is a Pass-Through placed in an interior wall. See Exterior and 
Interior Walls on page 355. 

 l Check Separate Trim and Materials for Each Side to specify the casing, lintels, sills, and all materials for each 
side of the selected Pass-Through independently. When unchecked, the two sides use the same trim and materials. 

  Options

 l Louver Size - Specify the vertical height of the selected window’s louvers. Only available for Louvered and Glass 
Louver windows.           

 l Check Include in Schedule to include the selected window(s) in Window Schedules. See The Schedule Tools on 
page 695.           

 
Preview

A preview of the selected window displays here. A label indicates which side of the window is its Interior and which is its 
Exterior. See Dialog Preview Panes on page 22. 

Window opening directions can best be seen using the Vector View Rendering Technique.          
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OPTIONS PANEL

The OPTIONS panel is not available in the Wall Niche Specification dialog.          

The Mulled Units and Mullion Depth settings on the OPTIONS panel are only available in the Mulled Unit Specification 
dialog. See Grouped Windows on page 590.          

  Options

 l Check Interior Corner Block to count interior corner blocks in the materials list. These do not display in 3D views.          

 l Check Exterior Corner Block to count exterior corner blocks in the materials list. These do not display in 3D 
views.           

 l Check Egress to specify the window as an egress window in window schedules and the Materials List. Not available 
for Pass-Throughs.                 

Consult your local building and fire code authorities for your 
local egress window requirements.

 l Check Tempered Glass to specify the selected window’s glass as tempered in the Window Schedule. See Columns 
to Include on page 701.           

 l Check Reverse Symbol to reverse a window symbol as though it were reflected about a vertical line through its 
center. Only available in the Window Symbol Specification dialog.  See Window Symbols on page 589.

 
Mulled Units

Only available when a mulled unit is selected. See Make Mulled Unit on page 591.       

 l Check Treat as Door to include the unit in the “Doors” category of the Materials List and in the “Mulled Door 
Units” Auto Schedule Category. Only available when the selected unit contains a door.

 l Uncheck Single Wall Hole to produce individually framed wall openings for each unit in a mulled unit. When this 
box is checked, a single wall opening with one header for the entire unit is produced.           
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Mullion Depth

Specify the depth of the casing between the components of a mulled unit, measured from the wall surface. Positive values 
move the mullion surface towards the wall center; negative values, away from it. Only available when a mulled unit is 
selected.         

 l Specify the Inside depth of the mullion on the interior surface of the wall.           

 l Specify the Outside depth of the mullion on the exterior surface of the wall.           

 
Recessed into Wall

These settings allow you to recess the selected window or mulled unit into a wall, away from the exterior surface. Only 
available if the window or mulled unit is in a multi-layered wall.         

 l Check Recessed to enable the options below.

 l Select To Main Layer to recess the window to the wall’s Main Layer.

 l Select To Sheathing Layer to recess the window to the wall’s sheathing layer, which is the layer located just 
outside the wall type’s Main Layer(s). See Wall Type Definitions on page 388.           

  Vertical Stacking

 l Specify the window Level that the selected window is placed on. Not available for mulled units or window symbols. 
See Window Levels on page 593.         

 
Preview

A preview of the selected window displays here. See Dialog Preview Panes on page 22.         

CASING PANEL

The CASING panel is not available in the Window Symbol Specification dialog.
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Use Interior Casing

When this box is unchecked, no casing is used and the settings that follow are disabled.                 

 l Casing Profile - Click the Library button to select a molding profile for the casing. A preview of the casing profile 
displays to the right. See Select Library Object Dialog on page 982.             

 l Click the Clear button to remove a selected casing profile from the window. When no profile from the library is 
selected, a basic rectangular stock profile is used.    

 l Specify the Width of the selected casing.    

 l Define the Depth of the selected casing, as measured from the back to the front of the casing profile.           

 l Define the Overlap Frame value, which is the distance between the outside edge of the window frame and the 
inside edge of the casing. The default is 0”, which places the inside edge of the casing against the outside edge of the 
frame.

Type a positive value to overlap the casing over the frame by that amount. 

Type a negative value to produce a gap between the casing and the frame.
To produce a reveal of a certain width, subtract the desired reveal from the total width of the frame and type the 
result here.           

 
Use Exterior Casing

If the selected window is a Pass-Through placed in an interior wall, these settings will be unavailable unless Separate Trim 
and Materials on Each Side is checked on the GENERAL panel. See General Panel on page 600.     

 l Check Use Exterior Casing to apply exterior casing to the selected window and enable the settings that follow. 
These settings are the same as those for the Interior Casing, above. When this box is unchecked, no exterior casing is 
used. 
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Double Wall Options

These settings affect windows placed in a Double Wall. See Double Walls on page 386.         

 l Select Through to create a single frame running through both Double Walls. This option is selected by default.             

 l If Enlarged is selected, casing is created only on the wall the window is inserted in. The opening on the other wall is 
enlarged to accommodate the casing.             

 l Select Double to place a second window in the Double Wall opposite the selected window. This second window 
cannot be selected. Casing is produced as with the Through type window.             

 l Select Not Through to place the window in one wall with no corresponding opening in the other wall.             

 
Curved Wall Casing

These settings are only available when the selected window is placed in a curved wall. See Drawing Curved Walls on page 
363.         

 l Door and window casing and jamb can be constructed three ways in curved walls:          

 l Straight - Both window sash and casing are straight. Straight casing may not fit properly into a wall if the window 
is too wide or the curvature of the wall, too tight.

 l Radial - The sides of the casing or jambs are inserted in the wall at an angle that passes through the center of the 
curve. 

 l Parallel - The sides of the casing are inserted in the wall at a right angle to the line tangent to the curved wall at the 
center of the window.             

  Normally, parallel casing has a straight sash. Radial casing is more like traditional curved windows, and typically has a 
curved sash.         

 
Preview

A preview of the selected window displays here. You may need to rotate the preview to see the casing on the side of the 
door you are editing. If casing is not specified for a Pass-Through, the Show Wall  option will be toggled on 

automatically.  See Dialog Preview Panes on page 22. 
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LINTEL PANEL

The settings on the LINTEL panel of the Window and Mulled Unit Specification dialogs are also found on the panel of the 
same name in the Door Specification dialog. See Lintel Panel on page 572.          

The LINTEL panel is not available in the Window Symbol Specification dialog.          

These settings are not available if the window has a reflected arch. See Arch Panel on page 613.          

The profiles and materials of window lintels and sills can be included in Room Finish Schedules. See The Schedule Tools on 
page 695.          

SILL PANEL

The settings on the SILL panel of the Window and Mulled Unit Specification dialogs are not available if the window has a 
reflected arch. See Arch Panel on page 613.          

The SILL panel is not available in the Window Symbol Specification dialog.          

The profiles and materials of window lintels and sills can be included in Room Finish Schedules.
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User Interior Sill

Check Use Interior Sill to enable the settings that follow, then specify the sill applied to the interior side of the selected 
window(s) using these settings. When this box is unchecked, no interior sill is used.         

 l Sill Profile - Click the Library button to select a molding profile for the sill. A preview of the selected profile 
displays to the right. See Select Library Object Dialog on page 982.          

 l Click the Clear button to remove the selected sill profile from the window. When no library profile is selected, a 
basic rectangular profile is used.          

 l Specify how far to Extend the sill past the outside edges of the casing on each side. If an Apron is specified, it will 
also be affected by this setting.          

 l Specify how far to Inset the sill into the window. A value of 0 positions the sill profile against the surface of the 
wall. Only available when a sill profile from the library is selected.          

 l Check Wrap to wrap the sill profile back toward the wall.           

 l Check Apron to include an apron under the sill. When Wrap is checked, the apron will be 1/2” (12 mm) shorter than 
the sill on each side; when it is unchecked, it will be the same length as the sill.           

 
Use Exterior Sill

Check Use Exterior Sill to enable the settings that follow, then specify the exterior sill for the selected window(s) using 
these settings. These settings are the same as those for the Interior Sill, above.         

 
Preview

A preview of the selected window displays here. See Dialog Preview Panes on page 22.         

SASH PANEL

The settings on the SASH panel control the size and position of the selected window’s sash. Note that increasing the Side, 
Middle, Top or Bottom Width decreases the area of the glass and vice versa. 

The SASH panel is not available in the Wall Niche, Mulled Unit, and Window Symbol Specification dialogs, and the settings 
on this panel are not available for Pass-Throughs.
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Sash

Specify the width and depth of the selected window’s sash, which are the pieces of the window that hold the glass; or, 
uncheck this box to prevent it from having a sash.

 l Specify the Side Width of all vertical sash members: those at the window sides as well as the central members of 
Casement and Sliding windows. This is also the width of the top portion of the window when an arch is specified.    

 l Specify the Middle width of horizontal components between the top and bottom sash in Double Hung, Double and 
Triple Awning, and Double and Triple Hopper windows. It does not affect Casement and Sliding windows.    

 l Specify the Top and Bottom Widths. The Top value is not used if the window has an arch.    

 l Specify the Depth, or thickness, of the sash stock measured from the exterior to the interior.    

 l Specify the Inset, the distance between the frame and the outermost sash. If there is no frame, the inset is measured 
from the outer surface of the wall’s Main Layer.          

 l Curved Options - When the selected window is placed in a curved wall, specify whether it has a curved or straight 
sash. A curved sash is typically used with Radial casing. See Casing Panel on page 603.          

 
Preview

A preview of the selected window displays here. See Dialog Preview Panes on page 22. 

FRAME PANEL

The FRAME panel is not available for mulled units or window symbols. The settings on the FRAME panel are similar to those 
on the JAMB panel of the Door Specification dialog. See Jamb Panel on page 573.          
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Has Frame

Specify the attributes of the selected window’s Frame. Note that a window’s frame is included in its size, while a door’s 
jamb is not.    

 l Check Has Frame to include a frame and enable the settings below. When this is unchecked, the selected window 
has no frame around it.          

 l Specify the Side, Top, and Bottom Widths of the window’s frame. Changing these values modifies the interior of a 
window but does not affect its size.          

 l Uncheck Fit Frame to Wall to specify the Depth and Inset of the selected window’s frame. When this box is 
checked, the frame Depth automatically extends from the Recessed Into Wall layer to the wall’s inside surface with 
an Inset of 0”. The Recessed Into Wall layer is specified on the Options Panel on page 602 of this dialog.          

 l Specify the Depth of the window frame from front to back.          

 l Specify the frame’s Inset, which is measured from the Recessed Into Wall layer and moves the window frame 
towards its interior side. If used, the casing and lintel are not affected by this setting.          

 
Options

Has Corner Post is only available when the selected Fixed glass window is one of a pair forming a corner window. See 
Corner Windows on page 588.    

 
Preview

A preview of the selected window displays here. See Dialog Preview Panes on page 22.

LITES PANEL

The LITES panel allows you to add muntins to windows, and is also available for Glass doors. See Doors on page 551. 

There are four possible styles of muntin bars for regular windows, plus two additional options for arched windows.

A window that has been modified using the SHAPE panel cannot have divided lites or shutters added. You can, however, 
create Custom Muntins for such a window. See Custom Muntins on page 598.

The LITES panel is not available in the Wall Niche, Mulled Unit, and Window Symbol Specification dialogs, and the 
settings on this panel are not available for Pass-Throughs.
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Lites

Specify the number, position and style of lites for the selected window.    

 l Select a Type, or style, of window lite from the drop-down list. 

 l Normal style is the most common, with muntins going horizontally and vertically. Colonial windows are an example 
of the normal style.     

 l Diamond style uses angled muntin bars to divide up the lites. French windows are an example of the diamond style.     

 l Prairie style is based on the normal style, but with all the central muntin bars removed, leaving only the two outside 
muntin bars both horizontally and vertically. Typically, both Lites Across and Lites Vertical should be set between 6 
and 8. Federal or Federation windows are an example of the Prairie style.     

 l Craftsman style is based on the normal style, but only the topmost horizontal muntin bar is kept with all the 
portions of the vertical muntin bars above it. Typically, both Lites Across and Lites Vertical should be set between 4 
and 8.     

 l Enter the number of horizontal Lites Across in each sash.      

 l Enter the number of vertical Lites Vertical in each sash.     

 l Specify the Muntin Width, which is the width of the bars dividing the panes of glass.     

 l Check or uncheck Lites in Top and/or Lites in Bottom - or Lites in Left and/or Lights in Right - to specify either 
one or both of the sashes to have divided lites.     

 l Check Muntin in Corner to add a vertical muntin bar where two corner windows meet. Only available when Has 
Corner Post is unchecked on the FRAME panel. See Corner Windows on page 588.           

 l Check Auto Adjust Lites for Component Size to have the program produce lites that are consistent in size across 
all components. When this is checked, the window’s lites and its specification settings may not agree; when 
unchecked, lites in the components may not be consistent in size. 

 l Note: Because the fixed window in a Triple Sliding window is twice the size of the movable windows, the fixed 
section has a vertical muntin bar. To eliminate this, uncheck Auto Adjust Lites for Component Size.
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Round Top Arch

These options are only available if the window has an Arch specified.

 l Specify a Ray Count of up to 10 radial muntin bars in the portion of the window within the arch. There is one more 
pane of glass than the number of rays specified. See Arch Panel on page 613.          

 l Check Concentric to produce muntins radiating from a curved inner muntin that is concentric with the window’s 
arch. You must have at least three Lites Across for this to be used.          

 
Preview

A preview of the selected window displays here. See Dialog Preview Panes on page 22. 

SHAPE PANEL

The settings on the SHAPE panel control the position of the selected window’s corners, allowing you to create angled edges 
and mitered top corners.          

If any of these settings are used to create a custom shape, the selected window will be automatically specified as “Fixed 
Glass” on the GENERAL panel. If the selected window has an arch specified on the ARCH panel, it will be removed.         

The SHAPE panel is not available for mulled units or window symbols.         

Note: The Left and Right settings on this panel refer to the window’s 
exterior.
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Window Width

The Window Width displays for reference here. It can be changed on the General Panel on page 600.         

 l Click Match Roof to match the angle of the top of the window to the pitch of the roof above by changing its Sides 
heights, below. If either Top Inside Corner box is checked, it will become unchecked. 

Match Roof does not work for curved roofs, has no effect if the window is not in a gable end wall, and is not 
available in the Window Defaults dialog.         

 l Click Revert All to restore the window to its original shape, type and arch settings.          

 
Sides

Specify the height of the window’s Left and Right sides, as measured from the bottom of the window. By default, these 
settings match the window’s Height.             

 
Top Inside Corners

These settings allow you to create a second set of top corners with angled edges between them and the outside top corners.                 

 l Check Left to add an additional corner along the top edge.          

 l Specify the Height of the left inner corner, as seen from the exterior, measured from the bottom of the window.         

 l Specify the Offset of the left inner corner, as measured from the left side of the window.          

 l An additional Right Inside Corner can be specified in a similar manner.          

 
Bottom Corners

These settings allow you to raise the heights of the bottom corners, as measured from the bottom of the window specified on 
the General Panel on page 600.                 

 l Check Left to raise the height of the bottom left corner.          

 l Specify the Height of the bottom left corner. This value cannot exceed the Height of the Left Side.           

 l The height of the Bottom Right corner can be raised in a similar manner.          

 l The height of the Bottom Right corner can be raised in a similar manner.
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Preview

A preview of the selected window displays here. You may want to rotate the view so the window’s exterior can be seen. See 
Dialog Preview Panes on page 22.              

Note: The Left and Right settings on this panel refer to the window’s 
exterior.

The following diagram represents added Inner corners using open circles and the left and right corners using solid black 
circles:          

 l A has different left and right Side Heights with no Top Inside Corner added.           
 l B has matching left and right heights with an added Top Inside Corner.           
 l C is the same as B, except that the left and right Side Heights have been shortened to 1/4”.           
 l D is the same as B except it has two added Top Inside Corners.          
 l E is the same as A except that the Bottom Right Corner has been raised.          

ARCH PANEL

The settings on the ARCH panel of the Window and Mulled Unit Specification dialogs are also found on the panel of the 
same name in the Door Specification dialog. See Arch Panel on page 574.         

The settings on this panel of the Mulled Unit Specification dialog define the overall shape of the blocked unit’s top. If the 
mulled unit already includes a component window with an arch, these settings cannot be modified.               If you intend to arch the 
top of a mulled unit, the top components should be constructed with horizontal, straight tops all at the same height.

The ARCH panel is not available for window symbols, and its settings are not available if the selected window has been 
modified using the SHAPE panel.         

TREATMENTS PANEL

The settings on the TREATMENTS panel allow you to add embellishments to the interior and exterior of the selected window 
or mulled unit.         

The TREATMENTS panel is not available in the Wall Niche and Window Symbol Specification dialogs.           
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Curtains

Curtains are applied to the selected window or mulled unit’s interior side.             

 l Specify a style of Curtains by selecting “Use Default”, “None” or “Library” from the drop-down list.  If a non-
default library item has been selected, its name will display in the list, as well.          

 l Click the Library button or select “Library” from the drop-down list to choose a style of curtain from the library. 
See Select Library Object Dialog on page 982.          

 l Specify the Height Off Floor of the bottom edge of the curtains.          

 l Specify the Height Above Casing of the top of curtains.          

 
Blinds

Blinds are specified in the same manner that Curtains are chosen, above.             

 
Exterior Millwork Above Casing

Exterior millwork above the casing can be specified in the same manner that Curtains are chosen, above.     

 l Specify the selected millwork's Height and Width.     

 
Exterior Millwork Below Casing

Exterior millwork below the casing can be specified in the same manner that Curtains are chosen, above.    

 l Specify the Height of the millwork and the distance that it should Extend past the side casing.

 
Preview

A preview of the selected window displays on the right. You may want to rotate the view so the window’s interior can be 
seen, as needed. See Dialog Preview Panes on page 22.             

SHUTTERS PANEL

The settings on the SHUTTERS panel allow you to specify exterior shutters for the selected window or mulled unit.          

The SHUTTERS panel is not available in the Wall Niche and Window Symbol Specification dialogs.         
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Shutters

Select a Type of shutters from the drop-down list or click the Library button to select a style of shutters from the Library 
Browser. See Select Library Object Dialog on page 982.          

  Size

 l When Match Opening Width is checked, each shutter’s width is exactly half that of the window, excluding casing.         

 l Uncheck Match Opening Width to specify a Width in the text field. If the window is later resized, the shutters will 
not adjust in response.         

 l When Match Opening Height is checked, each shutter’s height equals that of the window, excluding casing.         

 l Uncheck Match Opening Height to specify a Height in the text field. If the window is later resized, the shutters 
will not adjust in response.         

 
Position

Specify the position of the shutters relative to the window.          

 l Select On Casing to position the shutters just outside the window frame, like functional shutters.          

 l Select Outside Casing to position shutters outside the window casing, as decorative shutters often are.         

 l Select Custom to create a custom position for the shutters by specifying the Offset from Side and Offset from 
Bottom in the fields below.          
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Options

Additional shutter Options can be specified here.         

 l Specify the Louver Size. Only available when "Louvered" is selected as the Type, above.

 l Check Reverse Direction to orient the shutters so their exterior sides face outward and their interior sides face the 
wall. For functional shutters, this should remain unchecked.          

 l Check No Arch for shutters with flat tops that reach the bottom of the curved portion of an arched window. Only 
available when an Arch is selected. See Arch Panel on page 613. 

 l Check Show Closed  to draw the shutters so they cover the exterior of the selected window. When this is unchecked, 
the shutters are positioned against the wall on either side of the window.     

 
Sides

Specify which sides of the selected window receive shutters.         

 l Select Automatic to assign shutters to both sides of the window as long as there is sufficient room on the wall. If the 
window is next to a wall intersection or corner, the shutter closest to the intersection will not generate.           

 l Select Left Side Only to assign a shutter to the left side of the window and none on the right.           

 l Select Both Sides to assign shutters to both sides of the window under all circumstances, even if there isn’t enough 
room on the wall for one or both of them.          

 l Select Right Side Only to assign a shutter to the right side of the window and none on the left.          

 
Preview

A preview of the selected window displays on the right. Shutters will only generate if there is sufficient room for them 
along the window's containing wall. In order to see the shutters, you may need to rotate the preview to show the Exterior. 
See Dialog Preview Panes on page 22.          

OPENING INDICATORS PANEL

The settings on the OPENING INDICATORS panel are also found on the panel of the same name in the Door Specification 
dialog. See Opening Indicators Panel on page 578.    

ROUGH OPENING PANEL

The settings on the ROUGH OPENING panel are also found on the panel of the same name in the Door Specification dialog. 
See Rough Opening Panel on page 579.    

FRAMING PANEL

The settings on the FRAMING panel are also found on the panel of the same name in the Door Specification dialog. See 
Framing Panel on page 579.          

ENERGY VALUES PANEL

The settings on the ENERGY VALUES panel let you specify information used for export to REScheck. See Export to 
REScheck on page 1247.
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This panel is not available in the Wall Niche Specification dialog.              

  Assembly

 l Select a Frame Type and Glazing Type from the drop-down lists.     

 l In the Door Specification dialog, instead select a Door Type from the drop-down list.     

  Energy Values

 l Specify the selected window’s U-Factor.      

 l Specify the selected window’s SHGC (Solar Heat Gain Coefficient).       

LAYER PANEL

The settings on the LAYER panel are the same as those found on the same panel in dialogs throughout the program. See 
Layer Panel on page 191.          

MATERIALS PANEL

The settings on the MATERIALS panel are the same as those found on the same panel in dialogs throughout the program. See 
Materials Panel on page 1055.

The settings on the MATERIALS panel of the Mulled Unit Specification dialog apply to all components of the blocked unit. 
Any settings made for individual components of the blocked unit are overridden here.          

LABEL PANEL

Window labels display in plan view and cross section/elevation views when the “Windows, Labels” layer is turned on and 
use the Text Style assigned to that layer. See Window Labels on page 596.          

Similarly, Wall Niche labels display in plan view              and cross section/elevation views              when the “Wall Niches, Labels” layer is 
turned on and use the Text Style assigned to that layer. See Window Labels on page 596.          

For more information about the settings on this panel. See Label Panel on page 712.         
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COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 1335.          

OBJECT INFORMATION PANEL

The information entered on the OBJECT INFORMATION panel can be used in schedules and the materials list. For more 
information, see Object Information Panel on page 1336.   

SCHEDULE PANEL

The settings on the SCHEDULE panel determine which schedule categories the selected window is included in. See Schedule 
Panel on page 716.          

MANUFACTURER PANEL

The MANUFACTURER panel provides contact information for the selected window’s manufacturer. Only available for 
windows from Manufacturer library catalogs. See Manufacturer Catalogs on page 970.         

 

 

Bay, Box, and Bow Windows
Bay, Box and Bow Windows are created much the way regular windows are: select a tool, then click a 
wall to place that window type. 

Chief Architect automatically builds a foundation under bay/box/bow windows placed on Floor 1 unless they are raised 
from their original position. That section of the foundation wall is also a bay/box/bow, but without windows. If the 
foundation was generated before the window is placed, the foundation must be rebuilt or edited manually.

DISPLAYING BAY, BOX, AND BOW WINDOWS

The display of bay, box, and bow windows is controlled in the Layer  Display Options dialog. See Layer Display Options 
Dialog on page 183. 

Like other windows, bay, box, and bow windows can display labels. Either a single label for the unit can be used, or a 
separate label for each component. See Window Labels on page 596. 

Bay, box, and bow window width and radius dimensions, which display in plan view when specified to do so in the 
window’s specification dialog, are placed on the “Dimensions” layer. See Options Panel on page 626.   

EDITING BAY, BOX, AND BOW WINDOWS

Bay, box, and bow windows are edited similar to regular windows with one exception: in plan view, a diamond-shaped 
Depth edit handle displays on the section. Drag this Depth handle outward to increase the depth, or inward to decrease the 
depth of the unit. See Editing Windows on page 597.
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Bay, box, and bow windows can also be edited in their respective specification dialogs. See Bay/Box and Bow Window 
Specification Dialogs on page 624.

A variety of style attributes can be assigned to bay/box/bow windows using Style Palettes. See Style Palettes on page 284.

COMPONENT WINDOWS

A component window within a bay, box, or bow window can be edited like others standard window, with a few restrictions. 
To select a component window, click at the location of the component in question, then click the Select Next Object  

edit button or press the Tab key. 

 l Only the bay or box window component that was clicked on is selected using this method. If you need to select a 
different component, click on it and repeat the process.

 l In a bow window, all components are identical, so only one component can be selected. Changing this component 
changes them all.

An individual component window can be resized using the edit handles or by changing settings in the component’s Window 
Specification dialog. Component windows can also be resized using the Transform/Replicate Object dialog. See 
Transform/Replicate Object Dialog on page 269.

When a bay/box/bow window is first created, there is room for one standard trimmer on each side of each component 
window. When the bay as a whole is moved and resized, its components automatically resize so that a standard trimmer is 
still accommodated. 

If you increase a component window’s width to the point where there is not enough room for standard trimmers, a thinner 
trimmer can be used. The size of this thinner trimmer is specified in the Build Framing dialog. See Openings Panel on page 
880.           

If a component window is resized, it retains its size if at all possible when the containing bay/box/bow window is moved or 
resized. If the bay is resized in such a way that the component is too large to fit even with a thinner trimmer, the component 
resumes its default behavior, resizing as the containing bay window is resized.

FLOORS AND CEILINGS

When originally created, the floor and ceiling within a bay, box, or bow window are the same heights as the floor and 
ceiling of the room in which it is placed. 
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Both the top and bottom heights of these window units can be adjusted in its specification dialog or a 3D view using its edit 
handles to create a lowered ceiling and/or a bench seat or garden window.

When the ceiling is lowered, the top heights of the walls that define the window unit are also lowered. When a roof is built 
over the unit, its height will be affected, as well.

When the bottom of the window is raised to create a bench seat, the unit’s walls will not reach the ground. As a result, 
window units with bench seats will have no foundation beneath them when the foundation is built.

EXPLODE BAY/BOW WINDOW

Click the Explode Bay/Bow Window edit button to explode a selected Bay/Box/Bow Window into its component 
parts. The walls and windows can be edited individually and, if the original window had a Lowered Ceiling or Raised 

Floor, a new, editable room will be also created.

Walls created when the Explode Bay/Bow Window tool is used will have Treat As Part Of Bay/Bow/Bow Window 
checked in the Wall Specification dialog, which affects how the roof above is generated. See Roof Panel on page 401.    

Once exploded, it is not possible to block the components into a Bay/Box/Bow Window object again.   

 

Bay, Box, Bow Windows and Roofs
Several different roof styles can be specified for Bay, Box and Bow window units in the Bay/Box and Bow Specification 
dialogs. See General Panel on page 624. 

If you change a Bay, Box, or Bow Window’s roof specification, you will need to rebuild the roofs to see the changes. See 
Rebuilding Roofs on page 808. 

HIP ROOFS

By default, a hip roof is built above the unit when roofs are automatically generated. Bay and Bow Windows with angled 
side walls also receive two additional roof planes that produce a ridge at the back of the bump-out's roof, sometimes referred 
to as a California ridge. No roof directives need to be selected in the Bay/Box/Bow Specification dialog to produce this roof.
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Hip roofs over Bay, Box, and Bow Windows

USE THE EXISTING ROOF

To generate a standard roof that ignores a Bay, Box, or Bow Window, check Use Existing Roof. 

Existing roof extending over and following 
the shape of Bay, Box, and Bow Windows

With this option the Bay, Box, or Bow Windows is tucked under the roof eave. You may find it necessary to increase the 
width of the eave. See Roof Panel on page 810.

EXTEND THE EXISTING ROOF

To have the main roof extend down over the window unit and follow the shape of the unit, select Extend Existing Roof 
Over. 
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Existing roof extending over and following 
the shape of Bay, Box, and Bow Windows

To extend the main roof down over a window unit to create a rectangular roof over it rather than one that follows its shape, 
select both Extend Existing Roof over and Rectangular Roof Over. 

Existing roof extending rectangular bump-
outs over Bay, Box, and Bow Windows

For this roof style, the ceiling heights of the window unit and the adjacent room must be the same. If you lower the ceiling 
of the window unit and then build the roof, a lower hip roof over the window is created. See Floors and Ceilings on page 
619.

If a header is desired over the window unit, first build the roof, then lower the ceiling of the window unit. Once the ceiling 
is lowered, select Rebuild Walls/Floors/Ceilings . Do not rebuild roof planes.

RECTANGULAR HIP ROOFS

To create a rectangular-shaped hip roof above a Bay, Box, or Bow window, select Rectangular Roof Over.
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Rectangular-shaped hip roofs over Bay, Box, 
and Bow Windows

GABLE ROOF

A gable roof is not one of the automatic options for the roof above a Bay, Box, or Bow Window. A gable can be created by 
manually editing the rectangular hip roofs that are automatically created. See Roof Planes on page 819.

To create a gable over a bay window
 1.  Select a Bay, Box, or Bow window, open its specification dialog, and choose the Rectangular Roof Over option.

 2.  Rebuild the roof.

 3.  Select one of the side roof planes and drag the corner edit handle located at front end of the ridge forward until the 
fascia snaps to the edge of the front hip section. 

 4.  Edit the other side roof plane in the same manner.         

 5.  Delete the front hip section.           

 6.  Adjust the roof’s overhang as needed.           
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To create a gable roof over a normal window, use the Gable 
Over Door/Window edit button. See Gable/Roof Lines on page 

846.

 

Bay/Box and Bow Window Specification Dialogs
To open the Bay/Box Window Specification or the Bow Window Specification dialog, select one or more Bay, Box, 
or Bow Windows and click the Open Object edit button. See Bay, Box, and Bow Windows on page 618.

The options in this dialog can only be set for objects placed in a plan: Bay, Box, and Bow Windows do not have defaults 
dialogs. 

The settings that are available in these dialogs depend on whether the selected object is a Bay, Box, or Bow Window.         

The Bay/Box and Bow Window Specification dialogs have the following panels:         

GENERAL PANEL

 
Sections

The setting that displays here depends on whether the selected window is a Bay, Box, or Bow Window.   

 l Specify the Bay Angle, which is the angle of the side components of a Bay or Box Window. Bay Windows have an 
angle of 45° by default; Box Windows have an angle of 90°.

 l Specify the Quantity, which is the number of component windows in a Bow Window.    

 
Size

Specify the Width and Depth of the Bay, Box, or Bow Window. 
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Wall Type

Specify the Wall Type used by the walls embedded in the selected Bay, Box, or Bow Window. See Wall Type Definitions 
on page 388. 

 l Select “Use Main Wall Type” from the drop-down list to use the same wall type as that of the wall that the window 
unit is placed in. If the main wall is a Pony Wall, both wall types are used.           

 l Select a specific wall type from the drop-down list to use it instead of the Main Wall Type.           

 l When a specific wall type is selected, click the Define button to modify its definition. See Wall Type Definitions 
Dialog on page 390.           

 
Ceiling

Specify the height and structure of the Ceiling within the selected window. 

 l Check Has Lowered Ceiling to enable the settings that follow. When this is unchecked, the ceiling height and finish 
material within the window is the same as that for the adjacent room.

 l Specify the Height Lowered, which is measured from the ceiling height of the adjacent room. 

Note: If the Height Lowered is 0”, Has Lowered Ceiling will become 
unchecked when you click OK.

 l Specify the Finish Thickness, which is the thickness of the ceiling’s finish material.           

 l Specify the Structure Thickness, which is the thickness of the ceiling’s structural layer.          

 
Floor

Specify the height and structure of the Floor within the selected window. 

 l Check Has Raised Floor to enable the settings that follow. When this is unchecked, the floor height and material 
within the window is the same as that for the adjacent room. 

 l Specify the Height Raised, which is the measured from the floor height of the adjacent room. 

Note: If the Height Raised is 0”, Has Raised Floor will become 
unchecked when you click OK.

 l Check Use Floor Finish to measure the Height Raised distance from the surface of the floor finish. When 
unchecked, as it is by default, this height is measured from the subfloor.           

 l Specify the Finish Thickness, which is the thickness of the floor’s finish material.          

 l Specify the Structure Thickness, which is the thickness of the floor’s structural layer.          
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OPTIONS PANEL

 
Roof

Specify the structure of the automatic roof over the selected window unit. See Bay, Box, Bow Windows and Roofs on page 
620. 

 l Check Use Existing Roof if the existing roof needs no changes to accommodate the bay window.

 l Check Extend Existing Roof Over to extend the existing roof plane to cover the bay window below.

 l Check Rectangular Roof Over to create a roof over the bay window that is square across the end instead of 
following the profile of the roof. 

 
Dimensions

Specify the appearance of the selected window unit’s dimensions in plan view. These dimensions are drawn on the 
"Dimensions" layer but cannot be selected. See Dimensions on page 454.

 l Check Display Standard Dimension to display the automatically-produced dimensions that show the window’s 
width and depth.

 l Check Display Dimensions to Center to display a Bow Window’s radial dimension.

 
Components

Specify the structure of the selected window unit’s components and the wall sections containing them.

 l Uncheck Has Component Windows to remove the component windows of the selected Bay, Box, or Bow 
Window and disable the settings that follow.          

 l Check No Trimmers for Components to eliminate the trimmer studs for Bay and Box Window components, 
allowing the width of each component window to increase. See Wall Framing on page 866.          

 l Check No Framing Between Components to remove both studs between the component windows.          
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Note: If the selected unit is moved or resized, its components 
automatically resize to use a standard trimmer, regardless of whether 
either of the two options above are selected.

 l Check Connect Outer Casing to have exterior casing surround the component windows of a Bow Window as a 
group rather than individually. Mullions are provided between components. This is how interior casing is always 
created.           

 l Check Components Recessed to recess the component windows into the wall and enable the settings that follow. 
Typically used if the window is placed in a brick wall and you want to produce a brick molding.           

 l Select To Main Layer to recess the components to the wall’s Main Layer instead of the exterior wall surface. See 
The Main Layer on page 388.           

 l Select To Sheathing Layer to recess the components to the sheathing layer instead of the exterior wall surface.          

LAYER PANEL

For information about using the LAYER panel, see Layer Panel on page 191.          

MATERIALS PANEL

The settings on the MATERIALS panel are the same as those found on the same panel in dialogs throughout the program. See 
Materials Panel on page 1055.

LABEL PANEL

Bay, Box, and Bow Window labels display in plan view              and cross section/elevation views              when the “Windows, Labels” 
layer is turned on and use the Text Style assigned to that layer. See Window Labels on page 596.          

For more information about the settings on this panel. See              Label Panel on page 712.         

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. See Components Panel on page 1335.          

OBJECT INFORMATION PANEL

The information entered on the OBJECT INFORMATION panel can be used in schedules and the materials list. For more 
information, see Object Information Panel on page 1336.   

SCHEDULE PANEL

The settings on the SCHEDULE panel determine which schedule categories the selected object is included in. See Schedule 
Panel on page 716.    
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Chapter 17
 

Cabinets

With Chief Architect’s cabinet tools you can create base, wall, and full height cabinets as well as soffits, shelves, partitions, 
and custom countertops. These objects are very versatile, allowing for a wide range of customization. 

A selection of cabinet door and drawer styles are available in the Library Browser and, in addition, a numerous cabinet 
manufacturer catalogs are available for download on our website, chiefarchitect.com.

Chief Architect also has many customized cabinets and cabinet groups available in the library. Cabinets you have 
customized can be saved to your own library for future use.

TOPICS

Cabinet Defaults 629
The Cabinet Tools 631
Cabinet Fillers 634
Placing Cabinets and Fillers 635
Countertops 637
Displaying Cabinets 638
Cabinet Labels 641
Cabinet Construction 643
Editing Cabinets 644
Editing Cabinet Styles 646
Special Cabinets 649
Cabinet Specification Dialog 653
Cabinet Shelf Specification Dialog 669
Hardware Size/Orientation Dialog 670
Shelf/Partition Specification Dialog 671
Custom Countertop Specification Dialog 673
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Cabinet Defaults
There are several defaults dialogs for cabinets. Access Default Settings by selecting Edit> Default Settings, then clicking 
the arrow beside “Cabinets”. Select a subheading and click the Edit button to open the defaults dialog associated with your 
selection.

The Cabinet Defaults dialogs can also be accessed by double-clicking the Cabinet Tools  parent button.          

Double-clicking a Cabinet Tools child button also opens its corresponding defaults dialog, if that object has a defaults 
dialog.          

The Base, Wall, and Full Height Cabinet Defaults can be multiple-selected by holding down the Shift or Control keys. See 
Shift and Ctrl Select on page 217.           

Each type of cabinet object has default definitions for size, style, materials and much more. In fact, the default dialog for 
each cabinet type is similar to its corresponding specification dialog. For descriptions of these settings, see Cabinet 
Specification Dialog on page 653, Shelf/Partition Specification Dialog on page 671 and Soffit Specification Dialog on page 
1034.

Cabinet Fillers and Custom Countertops do not have defaults dialogs. Instead, their initial settings are based on the those of 
other objects.         

 l Base Cabinet Fillers’ initial settings are based on Base Cabinet Defaults.         
 l Wall Cabinet Fillers’ initial settings are based on Wall Cabinet Defaults.         
 l Full Height Cabinet Fillers’ initial settings are based on Full Height Cabinet Defaults.         
 l Custom Countertops’ initial settings are based on Base Cabinet Default settings but are also influenced by the settings 

of cabinets beneath them. See Countertops on page 637.             

DYNAMIC CABINET DEFAULTS

When a dynamic default is changed, existing cabinet objects using the default value are affected. See Dynamic Defaults on 
page 79.           

The following cabinet default values are dynamic: Separation, Backsplash Height and Thickness, Countertop Overhang 
and Thickness, Toe Kick Height and Depth, Side and Vertical Overlap, Stiles, and  Hardware spacing.           

All Materials are also dynamic. In addition, the Cabinet Defaults can be set up to refer dynamically to information in the 
Material Defaults dialog. This makes it easy to have all cabinet objects in a plan use the same default materials. See 
Material Defaults Dialog on page 1052.           
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To use dynamic cabinet Material Defaults
 1.  Specify the desired materials for the cabinet categories in the Material Defaults dialog:              

 l “Cabinets” can be linked to the default cabinet box, cabinet interior, shelves, and toe kicks as well as to Shelves 
and Partitions.              

 l “Cabinet Door/Drawer” can be linked to the default frames and panels of cabinet doors and drawers.              

 l “Countertop” can be linked to the default countertop.               

 l “Hardware” can be linked to the default door and drawer pulls and hinges.              

 2.  On the MATERIALS panel of the Base Cabinet Defaults dialog, select the first object component and click the Select 
Material button.              

 3.  The Select Material dialog opens:              

 l On the LIBRARY MATERIAL panel, check Use default material, or              

 l On the PLAN MATERIAL panel, select “Use Default” at the top of the list.              

 4.  Click OK, then repeat this step for each of the components in the list.              

 5.  Repeat steps 2-4 in each of the Cabinet Defaults dialogs.              

SET AS DEFAULT

You can set the attributes for a cabinet placed in your plan as the defaults for that cabinet type. See Set as Default on 
page 79.

Note: Set as Default is not available for special shaped cabinets. Only 
Standard cabinets can be the default cabinet type. See Special Cabinets 
on page 649. 

GENERAL CABINET DEFAULTS

The General Cabinet Defaults dialog can be accessed only from the Default Settings dialog.
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  Automatic Behaviors

 l Specify the Minimum Cabinet Width. The smallest allowable value is 1/16 of an inch (10 mm).

 l Specify the Auto Door Threshold, which controls when Auto Left and Auto Right doors switch from single to 
double doors. When the opening behind an Auto door is this size or smaller, the Auto door is single; when the 
opening is larger than this value, a double door is applied. See Front/Sides/Back Panel on page 658.    

 l Uncheck Create Automatic Fillers to prevent fillers from automatically generating in spaces between cabinets. This 
setting is dynamic: changing it will affect cabinets already present in your plan. See Cabinet Fillers on page 634.             

 l Uncheck Create Automatic Fillers for Angled Connected Cabinets to prevent fillers from automatically 
generating in spaces between cabinets that meet at only one corner. See Special Cabinets on page 649.

 l Uncheck Create Automatic Blind Corner Cabinets to prevent blind corner cabinets from being created. This 
setting is dynamic: changing it will affect cabinets already present in your plan. See Blind Cabinets on page 652.             

 
Cabinet Resizing

Specify how Cabinet Resizing takes place when the edit handles are used.

 l Select Use Grid Snaps to resize cabinets using Snap Grid increments. See Grid Snaps on page 167.    

 l Select Use Resize Increment to resize cabinets using the increment specified here.    

 l Set the Resize Increment at which cabinets resize. The minimum allowable increment is 1/16 of an inch (10 mm).

  Display Options

 l Check Show Partial Module Lines to represent module lines as grey lines that do not extend across the cabinets. 
When this is unchecked, lines between merged cabinet modules display as specified by the “Cabinets, Module 
Lines” layer. See Displaying Cabinets on page 638.          

 l Check Show Closed Doors/Drawers in Plan Views to display closed cabinet doors and drawers in plan view. When 
unchecked, closed doors and drawers are not shown. See Displaying Cabinets on page 638.             

 

The Cabinet Tools
Select Build> Cabinet to access the Cabinet Tools.

Cabinets are easily created with a single click in plan view or any camera view. See Click-to-Create on page 168.

Typically, groups of cabinet objects are positioned closely together and arranged to form work spaces, and there are some 
special behaviors and techniques to be aware of. See Placing Cabinets and Fillers on page 635.

Once created, cabinets, soffits, shelves, partitions and fillers can be selected and edited much like other box-based objects. 
See Editing Cabinets on page 644.

BASE CABINETS

Base cabinets can be placed directly under wall cabinets and generate a countertop and toe kick by default.
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WALL CABINETS

Wall cabinets can be placed directly over base cabinets. 

FULL HEIGHT CABINETS

Full height cabinets generate a toe kick by default and cannot be placed on top of other cabinets.

BASE, WALL, AND FULL HEIGHT FILLERS

The Base, Wall, and Full Height Filler tools place fillers that look and behave similarly to their 
corresponding cabinet tools. See Cabinet Filler Tools on page 635.

SOFFITS

Soffits typically fill the space between cabinet tops and the ceiling, but can also be used to create any object that can 
be modeled as a 3D box. To place a soffit, select Build> Cabinet> Soffit and click in any view.

By default, soffits use the material assigned to interior walls in the Material Defaults dialog. Like cabinets, soffits can have 
molding profiles applied to them.

For more information about using soffits for a variety of purposes, see Other Objects on page 1015.

SHELVES

Select Build> Cabinet>  Shelf and click in any view to create a shelf. 

Create corner shelves by placing one shelf on each wall, then moving or stretching them until they touch.

Once created, shelves can be selected and edited. See Shelf/Partition Specification Dialog on page 671.

You can also specify shelves inside base, wall, and full height cabinet boxes. See Cabinet Shelf Specification Dialog on 
page 669.          

PARTITIONS

Select Build> Cabinet> Partition button and click in any view to create a vertical partition. 

Like shelves, partitions can be selected and edited after they are placed.

Partitions can be used with shelves to create complex storage systems.

CUSTOM COUNTERTOPS

Custom Countertops are drawn and edited just like other closed-polyline based objects. Select Build> Cabinet> 
Custom Countertop, then either click and drag a rectangle or single-click to place a 2’x2’ countertop. See 

Countertops on page 637.         

You can also generate a custom countertop over one or more base cabinets using the Generate Custom Countertop  

edit tool. See Using the Edit Tools on page 645.         
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CUSTOM COUNTER HOLES

Select Build> Cabinet> Custom Counter Hole, then either click and drag a rectangle or single-click to place a 2’x2’ 
countertop hole. Custom Counter Holes must be drawn within an existing Custom Countertop, can be drawn in any 

view except cross section/elevation views and can be edited to any shape. See Editing Custom Countertops on page 638.         

CUSTOM BACKSPLASHES

Select Build> Cabinet> Custom Backsplash while an elevation or camera view is active, then either click and drag 
a rectangle or single-click on a wall surface to place a Custom Backsplash Layered Material Polyline on that wall. 

See Custom Backsplashes on page 1038.

A custom backsplash can also be created using the Convert Polyline  edit tool. See Convert Polyline on page 265.         

CABINET LIBRARY CATALOGS

In the Library Browser, browse to Chief Architect Core Catalogs> Architectural> Cabinets to access a selection of 
specialty cabinets. Select the library object you want, then click in any view to place it in the plan. Once placed, 

library cabinets can be edited. See Placing Library Objects on page 980.

A selection of cabinet manufacturer catalogs is also available for download. These catalogs include door and drawer styles 
and may also provide moldings and millwork, finishes, and hardware. See Manufacturer Catalogs on page 970.           

In addition, you can add single cabinets and blocked units to the library. See Adding Library Content on page 973 and 
Architectural Blocks on page 1008.           

CABINET DOORS, DRAWERS, AND PANELS CATALOGS

A selection of cabinet door panels, drawer fronts, and specialty cabinet storage options can be found in the Library 
Browser in Chief Architect Core Catalogs> Architectural> Cabinet Doors, Drawers, and Panels. 

 l Doors, drawers, and panels can be assigned to a cabinet in its specification dialog. See Door/Drawer Panel on page 
663 and Accessories Panel on page 666.

 l Select a door or drawer in the library, then click on a cabinet in your plan to place the door or drawer onto that 
cabinet. Side and back panels cannot be applied to cabinets using this approach. See Inserted Objects on page 981.

 l Cabinet doors and drawers can also be placed as stand-alone fixtures. Once placed, they can be edited like other stand-
alone library objects. See Editing Library Objects on page 986.

You can create custom cabinet doors and drawers and save them in the library for future use. See Convert to Symbol on 
page 1002.          

BUILT-IN SINKS AND APPLIANCES

A variety of fixtures and appliances such as sinks, cooktops, and dishwashers can be placed into cabinets. See Inserted 
Objects on page 981. 

Place fixtures and appliances into cabinets early, so that any 
resizing can be done while there is adequate free space.

To insert a fixture into a cabinet, select the fixture in the Library Browser, then click on a cabinet. There must be enough 
space in the cabinet or adjoining cabinets to contain the selected fixture. Only one front mounted appliance can be inserted 
in this manner; however, additional front fixtures can be added in the Cabinet Specification dialog. See Front/Sides/Back 
Panel on page 658.           
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If a sink or cooktop is inserted into a cabinet with a top Drawer or Double Drawer, its Item Type will automatically change 
to a False Drawer or False Double Drawer.

Once placed, an inserted fixture can be selected and edited:

 l To select a fixture in a cabinet top, click on it and then click the Select Next Object  edit button. See Select Next 

Object on page 215.
 l Front fixtures can only be modified or deleted in the Cabinet Specification dialog. See Front/Sides/Back Panel on page 

658. 

When a cabinet has a fixture on either its top or front, the Open Symbol  edit button opens its specification dialog. 

When a cabinet has both, the Open Symbol  button opens the specification dialog for the fixture on the front. When a 

cabinet has multiple front appliances, the Open Symbol  edit button will not be available.           

Fixtures can be added to both the top and front of the same 
cabinet. It is up to you to determine which can be effectively and 

safely combined in the real world. 

STORAGE AND ORGANIZATION INSERTS

Rollout organizing and storage items can be specified  for any Door or Opening front item in the Cabinet Shelf Specification 
dialog. See Rollout Shelves and Storage on page 639.           

Inserts for drawers and the backs of doors can be specified in the Door and Drawer Face Item Specification dialogs. See 
Door/Drawer Panel on page 663.           

ELECTRICAL SWITCHES AND OUTLETS

Electrical switches and outlets can be placed on cabinets in most views. See The Electrical Tools on page 679.

 

Cabinet Fillers
Cabinet fillers can be created automatically, placed manually, or specified as part of a cabinet's face frame.          

All three types of fillers are included in the Materials List and are rounded to the nearest 1/16” (1 mm). Automatic and 
manually placed fillers are listed as individual items, while extended stiles are listed as components of their cabinets. 
Manually placed Cabinet Fillers can be listed in Cabinet Schedules, as can information about any cabinets' extended stiles. 
Auto fillers, however, are not listed. See Cabinet Schedules on page 640.         

AUTOMATIC FILLERS

By default, Chief Architect automatically generates fillers when cabinets of the same height are either touching or placed 
with 3” (75 mm) of one another. Automatic fillers receive the same toe kick, moldings, and backsplash as adjacent cabinets, 
and model a continuous countertop.

If two cabinets meeting at a corner are separated from each other by 3” (75 mm) or less, the program will automatically 
generate a filler in the angle between them. A filler is used to separate the front of one of these cabinets from the one it 
meets so that drawers and doors have room to operate.
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You can specify whether these automatic fillers generate in both situations the General Cabinet Defaults dialog. See General 
Cabinet Defaults on page 630.          

CABINET FILLER TOOLS

If you prefer, you can place cabinet fillers manually using Cabinet Fillers. Select Build> Cabinet, choose the desired tool 
from the submenu, then click to place a filler just as you would a cabinet, in any view.         

  Base Cabinet Fillers are composed of a front surface, a toe kick and a section of countertop.         

  Wall Cabinet Fillers are composed of a front surface only.         

  Full Height Cabinet Fillers are composed of a front surface and a toe kick.         

By default, fillers are 3" (75 mm) wide with a single Blank face item, and inherit their other attributes from the defaults for 
their associated cabinet type. See Cabinet Defaults on page 629.

You can convert a regular base, wall or full height cabinet into a filler by checking Filler in the Cabinet Specification 
dialog. Similarly, a cabinet filler can be converted to a regular cabinet by unchecking this box. See General Panel on page 
653.           

Once created, manually placed cabinet fillers can be edited much like regular cabinets. See Editing Cabinets on page 644.         

EXTENDED FACE FRAMES

You can also produce fillers by extending the front face on either side of a Framed cabinet. These extended stiles take 
precedence over the automatic fillers, but otherwise behave much like them. They affect the generation of toe kicks, 
moldings, backsplashes, and countertops but do not extend into adjacent walls or cabinets. See Box Construction Panel on 
page 657.

In plan view, extended stiles on cabinets are represented using lines on the cabinet's primary layer. In cabinet labels, they 
are indicated using "XL", "XR", and "XLR". See In Plan View on page 638 and Cabinet Labels on page 641. 

 

Placing Cabinets and Fillers
Cabinets and cabinet fillers are easily created with a single click in any view. See Click-to-Create on page 168. 

When used near a wall corner, the Cabinet Tools will produce corner cabinets and soffits. See Corner Cabinets on page 
649.

When created, cabinets are positioned relative to the floor of the room in which they are placed. Base and full height 
cabinets typically rest on the floor while wall cabinets are placed a set distance above the floor. See Cabinet Defaults on 
page 629.

635



Chief Architect Premier X14 Reference Manual - Placing Cabinets and Fillers

If the ceiling height of the room does not accommodate the height of a cabinet, its Floor to Bottom value will be retained 
and its Height will be reduced so that it fits under the ceiling. When this happens, some front items may be removed from 
the cabinet if there is not enough room for them. See Front/Sides/Back Panel on page 658.

Because cabinets are typically organized into groups with shared attributes, they have some special behaviors. 

CABINET SNAPPING AND ALIGNING

Cabinets have several special snapping and aligning behaviors which help you create precisely aligned cabinets quickly and 
easily.

 l When Base and/or Full Height cabinets are within 3” of one another’s sides, they will snap together. Wall cabinets 
snap in a similar manner, but only with other Wall cabinets.

 l When Base and/or Full Height cabinets are within 3” of one another’s sides and their front or back surfaces are within 
3” of aligning, they will become aligned. Wall cabinets snap in a similar manner with other Wall cabinets as well as 
Full Height cabinets.

 l When a Base and/or Full Height cabinet is placed against the back of another Base or Full Height cabinet, its back 
surface will automatically face the other cabinet’s back. Wall cabinets snap in a similar manner with other Wall as 
well as Full Height cabinets.

 l When a cabinet or cabinet filler is placed against a wall, its back and/or side will snap to the wall and, if the wall is 
moved, the cabinet will move with it.

When cabinets are snapped to a wall or to other cabinets, only exposed end cabinets have side counter overhangs, closed toe 
kicks, feet and corner pilasters. Adjacent cabinet fronts share front pilasters.

Cabinet snapping and aligning occurs even when Object Snaps  are turned off; however, you can override this behavior 

by moving a cabinet into the desired position using dimensions. See Moving Objects Using Dimensions on page 491.

CABINET MERGING

When cabinets of the same height and type are placed side-by-side within 3” (30 mm) of one another they will automatically 
merge, making any shared components such as the toe kick, countertop, backsplash, and moldings continuous. Any gap 
between merged cabinets will be automatically filled.

The exposed ends of merged cabinets have side counter overhangs, closed toe kicks, feet and corner pilasters. Adjacent 
merged cabinets share front pilasters.

Cabinets placed at different angles will also merge if they face toward one another and meet at a front corner. Cabinets that 
meet at a back corner will also merge provided that they face away from one another at an angle no greater than 87°. In 
either case, a filler is created in the angle between the two. 

If the side of a cabinet is placed within 3” (30 mm) of a wall, the countertop will extend to the wall and a filler will be 
created. 

Cabinet merging occurs even when Object Snaps  are turned off; however, you can suppress this behavior for cabinets 

that do not actually touch by turning off Create Automatic Fillers. See General Cabinet Defaults on page 630.

BASE AND WALL CABINETS

Base and wall cabinets have different default heights, so they can be placed directly above or below one another without 
interference. You can use Object Snaps  to center a wall cabinet’s back center point above that of a base cabinet, or vice 

versa. See Click-to-Create on page 168.
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MINIMUM CABINET SIZE

If you try to place a cabinet into a space that is too narrow for its default size, the program will place a smaller cabinet with 
a width that is a multiple of the default Resize Increment. For example, if you try to place a 24” wide cabinet in a 20” wide 
space and your Resize Increment is 3”, the program places an 18” cabinet. See General Cabinet Defaults on page 630.

If you try to place a cabinet into a space narrower than the default Minimum Cabinet Width, a cabinet will not be placed. 
If, for example, you have a space that is 8” and your Minimum Cabinet Width is 9”, no cabinet is placed. 

CABINET FILLERS

By default, the program will automatically place a filler between cabinets that are within 3” of one another. You can instead 
turn off Create Automatic Fillers and place fillers manually.           

 

Countertops
Countertops are automatically generated on top of base cabinets, but can also be drawn manually. 

AUTOMATIC COUNTERTOPS

Base cabinets automatically receive countertops as specified in the Base Cabinet Defaults dialog. These default countertops 
are components of the cabinets and can be edited in the Cabinet Specification dialog, but cannot be selected and modified 
separately.

The overhangs on automatic countertops are clipped on any side where the cabinet is positioned against or within 3" (75 
mm) of a wall, a Full Height Cabinet, a Partition, or free-standing appliance from the Library. Edge profiles on those sides 
are also suppressed, as are toe kicks.

CUSTOM COUNTERTOPS

When an automatic countertop does not meet your needs, you can instead use a Custom Countertop. In any view 
except a cross section/elevation, select Build> Cabinet> Custom Countertop, then either click and drag a rectangle 

or single-click to place a 2’x2’ countertop polyline. This countertop can be selected independent of any cabinets beneath it 
and is edited just like other closed-polyline based objects. See Editing Closed Polyline-Based Objects on page 230.

When a Custom Countertop covers any portion of a base cabinet, it overrides that cabinet's automatic countertop and bases 
its thickness and height on the base cabinet below.          

 l If there are multiple cabinets below, it uses the specifications for the cabinet with the greatest overall height.         
 l If there is no base cabinet below, its height and thickness are based on the base cabinet defaults. See Cabinet Defaults 

on page 629. 

If a sink or built-in appliance is added to the cabinet, a hole for the fixture is automatically cut in the Custom Countertop. 

By default, if a side of a Custom Countertop is positioned against a wall, the edge profile on that side will not generate.

You can also generate a Custom Countertop over one or more selected base cabinets by clicking the Generate 
Custom Countertop edit button. See Using the Edit Tools on page 645.

When created in this manner, the Custom Countertop inherits the cabinet's countertop material. If the cabinet has a To Top 
molding profile at counter height, the Custom Countertop will inherit it, as well. See Pilasters, Feet, and Moldings on page 
648.   
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EDITING CUSTOM COUNTERTOPS

Once created, a custom countertop or Custom Counter Hole can be selected in 2D and 3D views and edited like other 
closed-polyline based objects. See Editing Closed Polyline-Based Objects on page 230.         

Custom countertops initially use the default countertop material set in the Base Cabinet Defaults dialog. You can specify a 
different material as well as the height and position in the Custom Countertop Specification dialog. See Custom Countertop 
Specification Dialog on page 673.         

You can also specify the edge profile of a custom countertop in the Custom Countertop Specification dialog. See Moldings 
Panel on page 672.         

WATERFALL COUNTERTOPS

To add a vertical waterfall to the edge of a Custom Countertop, select that edge and click the Add Waterfall to 
Selected Edge edit button. See Selected Edge on page 214.         

You can also specify a waterfall edge as well as edit its attributes in the Custom Countertop Specification dialog. See 
General Panel on page 673.         

To remove a waterfall from a countertop edge, select that edge and click the Remove Waterfall from Selected Edge 
edit tool.         

 

Displaying Cabinets
The display of the various cabinet object types, labels, module lines, door opening indicators, and more is controlled 
in the Layer Display Options dialog. See Layer Attributes on page 181.

IN PLAN VIEW

Fill Styles and colors that display in plan view can be assigned to cabinet objects. See Fill Styles on page 197.           

Like other objects, cabinets are placed in Drawing Groups that affect whether they display in front of or behind other 
objects in plan view. By default, wall cabinets, soffits and shelves are drawn in front of base and full height cabinets, 
countertops and partitions. You can modify a selected  cabinet’s place in the drawing order by clicking the View Drawing 
Group Edit Tools  edit button. See Drawing Group Edit Tools on page 195. 

Objects assigned to cabinets, including hardware and moldings, are located on the same layer as their parent object. They 
display in 3D views, but are not shown in plan view. There are two notable exceptions: countertops and doors/drawers.
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 l Both automatic and Custom Countertops are drawn on the “Cabinets, Countertops” layer in all views. In plan view, 
countertops use the line style, color, and weight assigned to this layer; in 3D views, the line attributes of the parent 
object’s layer is used instead.

 l Cabinet doors and drawers are drawn on the “Cabinets, Doors & Drawers” layer in all views, but only display in 3D 
views by default. See Cabinet Doors and Drawers on page 639, below.

Custom Countertops can be assigned an edge profile, and can display the width of this profile if Display Molding Edges is 
selected in the Custom Countertop Specification dialog. See General Panel on page 673.          

By default, cabinet module lines display in plan view when cabinet objects of the same type are placed side by side. If you 
prefer that these lines not display, turn off the “Cabinets, Module Lines” layer. This layer also controls the display of the 
lines associated with extended face frames. You can also specify whether module lines are full or partial. See General 
Cabinet Defaults on page 630.

You can also display cabinet front indicator arrows in plan view by turning on the “Cabinets, Front Indicators” layer. 

Cabinet labels display in plan and cross section/elevation views when the “Cabinets, Labels” layer is turned on Text Style 
assigned to their layer. See Cabinet Labels on page 641.

IN 3D VIEWS

A cabinet’s label will display in cross section/elevation views when the “Cabinets, Labels” layer is turned on and the center 
point of the cabinet’s front is visible in the view. See Cabinet Labels on page 641.          

In 3D Vector Views, cabinet doors can display opening indicator arrows. See Opening Indicators on page 557.           

CABINET DOORS AND DRAWERS

There are several options for controlling the display of cabinet doors and drawers in plan and 3D views.           

Cabinet doors and drawers are drawn on the “Cabinets, Doors & Drawers” layer. In plan view, they use the line style, color, 
and weight assigned to that layer when they are set to display. In 3D Vector Views, they use the line style, color, and weight 
assigned to their parent cabinet’s layer.          

 l Cabinet doors and drawers can be drawn open or closed in both plan and 3D views.           
 l To draw a selected cabinet’s doors open in all views, click the Open Cabinet Doors  edit button. Any shelves set 

as Rollout will display in 3D views as well.             
 l To draw its drawers open in all views, click the Open Cabinet Drawers  edit button.             

 l To close the doors and/or drawers, click the Close Cabinet Doors  or Close Cabinet Drawers  edit button.             

Cabinet doors and drawers also can be set to Show Open in the Cabinet Specification dialog. In addition, you can specify 
how far open each is drawn. See Front/Sides/Back Panel on page 658.          

By default, doors and drawers do not display in plan view when they are closed- even when the “Cabinets, Doors & 
Drawers” layer is set to display. You can, however, check Show Closed Doors/Drawers in Plan Views in the General 
Cabinet Defaults dialog. See General Cabinet Defaults on page 630.           

ROLLOUT SHELVES AND STORAGE

Shelves can be specified for Door and Opening cabinet front items and are visible in 3D views. Those inside Doors will 
only display in 3D views when Doors and Rollout Shelves are set to Show Open. See Front/Sides/Back Panel on page 658.           
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Shelves can be specified as Rollout, each with its own rollout percentage, and will display in 3D views when Doors and 
Rollout Shelves are set to Show Open. If a Rollout shelf is in a Door item, the door must be set to 100% Percent Open in 
order for the shelf to draw open. See Cabinet Shelf Specification Dialog on page 669.           

Cabinet shelves and added storage items do not display in plan view.          

IN THE MATERIALS LIST

The materials associated with cabinet objects are listed under different Categories in the Materials List:          

 l Cabinets - Lists Cabinets, Shelves, Partitions, Custom Countertops, Custom Backsplashes, Cabinet Fillers, storage and 
organization inserts, as well as cabinet doors and drawers placed from the library as free-standing objects.             

 l Interior Trim - Lists Soffits and any moldings assigned to cabinet objects located in Interior rooms. Note that Soffits 
are not listed in the Materials List unless a non-default material is applied to them. See Calculating Materials on 
Soffits.             

 l Exterior Trim - Lists any Soffits and moldings assigned to cabinet objects located in Exterior rooms. See Room Types 
and Functions on page 420.             

 l Fixtures - Lists any sinks inserted into base cabinets. See Inserted Objects on page 981.             
 l Appliance - Lists any appliance fixtures inserted into cabinets. If a base cabinet has an under-counter appliance 

inserted into it, that cabinet will not be counted in the Materials List - only the countertop and backsplash materials 
associated with it will be listed. The cabinet will also display the appliance’s label information instead of its own. See 
Cabinet Labels on page 641.             

As with other objects, there are a number of ways to control how, or whether, cabinets are included in the Materials List. 
See Organizing Materials Lists on page 1317.           

You can add and edit information about a cabinet’s accessories in the Cabinet Specification dialog. See Components Panel 
on page 1335.           

Note that cabinet door and drawer height is described in two different ways:           

 l In the Cabinet Specification dialog, the Item Height for cabinet doors and drawers describes the height of the opening 
in the cabinet box rather than that of the door or drawer front. See Front/Sides/Back Panel on page 658.             

 l In the Materials List, the full height of cabinet door and drawer front is listed in the Size column.             

CABINET SCHEDULES

The Cabinet Schedule tool is set up to produce customizable cabinet schedules as well as cabinet labels that display 
schedule numbers. Cabinet objects can, however, be included in any schedule. See Schedules and Object Labels on 

page 694.   

In addition to cabinets, Soffits, Shelves, Partitions, free-standing cabinet panels, Countertops, Custom Backsplashes, and 
holes in Custom Countertops and Custom Backsplashes can also be listed in schedules. Manually-placed Cabinet Fillers can 
be listed, as well; however, automatically-generated fillers cannot. See Cabinet Fillers on page 634. 

Cabinet moldings and counter profiles can be included in schedules, as well. They are found in the "Molding" category, and 
have several molding-specific Columns, including "Total Length". If you specify a Type for a cabinet molding, it will be 
reported in the Description column. See Cabinet Moldings and Counter Profiles on page 946.

Individual cabinets in Architectural Blocks are also included in cabinet schedules provided that they are set to be included 
and Treat as One Object is unchecked in the Architectural Block Specification dialog. See General Panel on page 1012.    

By default, some cabinets with built-in appliances will not be included in a schedule. Examples include base cabinets with 
dishwashers or built-in ranges. You can, however, specify that the cabinet be included in one or more schedule categories if 
you wish. See Schedule Panel on page 716.   
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Cabinet Labels
Labels for cabinets and cabinet fillers display in plan and cross section/elevation views when the “Cabinets, Labels” layer is 
turned on. See Label Panel on page 712.

Shelves and Partitions can also display labels when the “Cabinets, Labels” layer is turned on, while Custom Countertop 
labels display when the “Polylines 3D, Labels” layer is turned on. Unlike cabinets and cabinet fillers, the Automatic Label 
for these objects is blank; however, you can specify a custom label in their specification dialogs.

Cabinet labels  have their own edit handles and can be moved and rotated when a cabinet is selected. They use the Text 
Style specified for the “Cabinets, Labels” layer. See Text Styles on page 547.         

If a base cabinet’s only front item aside from Separations and Blank Areas is an Appliance, the appliance’s label will 
display instead of the cabinet’s, and will be placed on the “Cabinets, Labels” layer.           

Cabinet labels are available in three different formats:           

 l Automatic Labels, which include size, type and other information in abbreviated form.           
 l User-Specified, which are entered in the Cabinet Specification dialog. See Label Panel on page 712.          
 l Schedule Callout Labels, which are specified in the Cabinet Schedule Specification dialog. See Labels Panel on page 

709.          

The minimum on-screen display size of object labels can be specified in the Preferences dialog. See Appearance Panel on 
page 99.          

AUTOMATIC LABELS

The format for automatic cabinet labels has four parts: Key, Code, Size, and Door Swing.           

The Key provides basic information about the cabinet box and its use. B refers to base cabinets, W refers to wall cabinets 
and U refers to full height cabinets.           

Together with the key, the Code provides additional information about the shape of the cabinet box:          

Code  

 All Cabinets

LS + Key Lazy Susan

LSD + Key Lazy Susan Diagonal Door

DC + Key Diagonal Door 

LC + Key Left Corner

BC + Key Blind Corner

PBC + Key Peninsula Blind Corner

Key + P Peninsula

Key + F Filler

E + Key Right or Left End

A + Key Angled Front

PR + Key Peninsula Radius

R + Key Radius End

641



Chief Architect Premier X14 Reference Manual - Cabinet Labels

Code  

Key + XL Extend Left Face Frame

Key + XR Extend Right Face Frame

Key + XLR Extend Left and Right Face Frame

B Base

OB Oven Base

SB Sink Base

RB Range Base

#DB Drawer Bank (# is the number of drawers

FHB Full Height Base (1 full height door)

W Wall

Code above + #D Drawer (# is the number of drawers

U Full Height (Utility)

OTC Tall Oven

RTC Tall Refrigerator

Blind corner cabinets are dependent on the cabinet’s position in the plan. A cabinet can only be a blind corner cabinet when 
its front is partially hidden by another cabinet. See Blind Cabinets on page 652. If a cabinet is moved, therefore, its Code 
information may change.           

Peninsula cabinets are only designated as such when they have one or more doors on the back side. See Front/Sides/Back 
Panel on page 658.           

The Size follows the Code in a cabinet label. Cabinet width is always included in the label; depth and height, on the other 
hand, may be included depending on the cabinet type and whether they are standard or non-standard.          

Base and full height cabinet labels present Size information in this order: width, depth, height. Wall cabinet labels present it 
in a slightly different order: width, height, depth.          

 Sizes

Base W(D)(H)

Width (W) Always included

Depth (D) 24” (60 cm)

Height (H) 34 1/2” (90 cm)

Corner Depth (D) Depth = Width

Wall WH(D)

Width (W) Always included

Depth (D) Always included

Height (H) 12” (30 cm)

Corner Depth (D) Depth = Width

Full Height WDH

Width (W) Always included
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 Sizes

Depth (D) Always included

Height (H) Always included

Corner Depth (D) Always included

Door Swing is included at the end of the label as either L or R, but only if all the doors on a cabinet have the same swing.          

Here are a few examples of automatic cabinet labels and their meanings:           

 l 3DB24: Base cabinet with 3 drawers, 24” wide. Depth and height are standard.          
 l SB24R: Sink base, 24” wide, with a right door. Depth and height are standard.          
 l BCW2436R: Blind wall cabinet, 24” wide, 36” high, with a right door. Depth is standard.          
 l DCW2436L: Diagonal corner wall cabinet, 24” wide, 36” high, with a left door. Depth is standard (equal to width).          
 l OTC362490: Full height cabinet with oven, 36” wide, 24” deep, 90” high.          

The Automatic Labels for Shelves and Partitions are blank, but 
you can specify custom labels for both. See Shelf/Partition 

Specification Dialog on page 671.

 

Cabinet Construction
Both framed and frameless, or European-style, cabinet construction can be specified in Chief Architect. You can also 
specify either the overlay or reveal of cabinet doors, drawers, and panels. 

If you know what cabinet construction style you want, you can save time by specifying that style in the Cabinet Defaults 
dialogs before you start placing cabinets. See Cabinet Defaults on page 629.

A wide variety of cabinet attributes, including construction, can be included in and applied to multiple cabinets and cabinet 
fillers at once using Style Palettes. See Style Palettes on page 284. 

FRAMED AND FRAMELESS

A cabinet can be specified as Framed or Frameless on the BOX CONSTRUCTION panel of the Cabinet Specification dialog. 
See Box Construction Panel on page 657.

The sides of both Framed and Frameless cabinet boxes are 3/4" (18 mm) thick. This value is also the system default Item 
Height for Separation face items in Frameless cabinets. See Cabinet Defaults on page 629.

Framed cabinets have left and right stiles with widths that can be specified. The stiles on the Front face of a cabinet can also 
be set to Extend past its sides. The Separation value set on the BOX CONSTRUCTION panel of the Cabinet Specification 
dialog serves as the default Height value for separation face items as well as the default width for left and right stiles. These 
can be set individually on the FRONT/SIDES/BACK panel. See Front/Sides/Back Panel on page 658.

TRADITIONAL OVERLAY

To specify how far doors, drawers and panels overlap vertical stiles and horizontal separations, select Traditional Overlay 
on the BOX CONSTRUCTION panel of the Cabinet Specification dialog and then specify the Overlap of all doors, drawers, 
and panels on the selected cabinet. 

When Traditional Overlay is selected, the widths of stiles can be specified on the FRONT/SIDES/BACK panel, as can the 
heights of selected Separation items; however, the overlap of individual items cannot.
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FULL OVERLAY AND REVEAL

To specify the reveal on horizontal separations and vertical stiles, select Full Overlay on the BOX CONSTRUCTION panel and 
then specify the desired Reveal. Both the sizes and the reveals on the Left and Right Stiles and on individual Separation 
items can be customized on the FRONT/SIDES/BACK panel.

INSET DOORS AND DRAWERS

Cabinet doors and drawers can be specified as Inset instead of overlaid on the BOX CONSTRUCTION panel of the Cabinet 
Specification dialog.

 

Editing Cabinets
Cabinets and cabinet fillers can be selected in 2D and 3D views both individually and in groups and edited using the edit 
handles, the Edit Toolbar and their specification dialog.

You can marquee-select cabinets of multiple types when the Full 
Height Cabinet tool is active. See Marquee Select on page 216.

USING THE EDIT HANDLES

Cabinets can be edited like other box-based objects. See Editing Box-Based Objects on page 234. The edit handles that a 
cabinet displays when selected will vary depending on the view. 

When a cabinet is selected in plan view or on its top surface in a 3D view, ten edit handles display: the Move handle at the 
center, the Rotate handle, and a Resize handle on each edge and at each corner.

In 3D views, cabinets can be selected on any surface: front, side, back or top. When the side of a cabinet is selected, five 
edit handles are available: the Move handle and a Resize handle on each edge. 

When cabinet labels are displayed, a label will move as its cabinet is moved or resized.               When a cabinet is selected, its label 
will have its own Move and Rotate edit handles, as well. See Displaying Cabinets on page 638. 

Cabinets cannot be concentrically resized, even when the Concentric edit behavior is enabled. See Defaults, Preferences, 
and Edit Behaviors on page 208.          

IN THE SPECIFICATION DIALOG

A selected cabinet can be customized in a variety of ways in its specification dialog. See Cabinet Specification 
Dialog on page 653. 
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When you group select cabinets of different types, some options are not available in the Cabinet Specification dialog. For 
example, you cannot modify the crown molding on a full height cabinet if it is selected with a base cabinet that does not 
have crown molding. Any specifications that they share in common, however, can be edited.         

Soffits, shelves, and partitions can also be group-selected and edited using a shared specification dialog. It is, however, 
necessary that only soffits, or only shelves, or only partitions be a part of the selection set in order to access a shared 
specification dialog.           

You can use the Object Painter  tools to assign the properties of one cabinet to other cabinets. See Matching Properties 

on page 286.           

You can also apply a variety of cabinet attributes to multiple cabinets and cabinet fillers at once using Style Palettes. See 
Style Palettes on page 284.          

EDITING BUILT-IN SINKS AND APPLIANCES

The Library Browser features a selection of fixtures that can be inserted into cabinet fronts and countertops. Once placed, 
these fixtures can be edited via the Cabinet Specification dialogs: 

 l Top-mounted fixtures can be edited on the Accessories Panel on page 666.
 l Cabinet front fixtures can be edited on the Front/Sides/Back Panel on page 658.

In addition, top-mounted fixtures can be selected and edited in plan and 3D views using the Select Next Object  edit 

tool. See Select Next Object on page 215.

When an inserted top-mounted cabinet fixture is selected:

 l The Open Object  edit button opens the Fixture Specification dialog. See Symbol Object Specification Dialogs on 

page 989.
 l The Open Symbol  edit button opens the Symbol Specification dialog. See Symbol Specification Dialog on page 

993.

USING THE EDIT TOOLS

A cabinet or cabinets can be edited in a variety of ways using the buttons on the Edit Toolbar. See The Edit Toolbar on 
page 135.

  The Open Cabinet Doors/Drawers and Close Cabinet Doors/Drawers tools affect the cabinet's doors 
and drawers in 2D and 3D views. See Cabinet Doors and Drawers on page 639.

  Generate Custom Countertop replaces a base cabinet's countertop with a separate Custom Countertop object. 
See Custom Countertops on page 637.

  Select Next Object allows you to select a fixture inserted into a cabinet. See Select Next Object on page 215.

  Open Symbol  allows you to edit an inserted fixture's symbol data. See Symbol Specification Dialog on page 
993.

ADD TO LIBRARY

Cabinets can be saved in the Library Browser. Select a base, wall or full height cabinet or cabinet filler and 
click either the Add to Library or Add to Library As edit button. See Add to Library on page 973. 

If you use Add to Library As , you can add the selected cabinet to the library in either of two ways:            
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 l Select Cabinet Module to save the cabinet along with its doors, drawers and panels and any fixtures or appliances.           
 l Select Cabinet Doors and Drawers to save the cabinet door style only.           

USING DIMENSIONS

Like various other objects, cabinets can be moved and resized using dimensions. See Moving Objects Using 
Dimensions on page 491. 

In order to be edited using dimensions, cabinets must be located by them. In the Dimension Defaults dialog, you specify 
what components of a cabinet are located by dimensions as they are drawn:          

 l Cabinet sides, corners, and centers can be located in both plan and elevation views.          
 l Cabinet face items, openings, backsplash heights, countertop heights, toe kick heights, and molding heights can be 

located in elevation views. The heights of cabinet components cannot, however, be edited using dimensions.     
 l Automatic Countertops can be located as well as edited in both plan and elevation views provided that Countertops are 

set to be located.
 l Automatic Backsplashes can also be located and edited in both types of views provided that CAD Objects are set to be 

located.         

See Locate Manual Panel on page 460.           

If you wish, you can add or move a dimension’s extension lines to locate countertop edges in plan view after the dimension 
line is drawn. In elevation views, the heights of cabinet face items, openings, the toe kick, backsplash, and/or moldings can 
also be located in this manner. 

Depending on whether a cabinet box or Custom Countertop is selected, Temporary Dimensions will locate objects near the 
Selected Edge somewhat differently: See Temporary Dimensions on page 480.

 l If a cabinet box is selected, Temporary Dimensions will locate the nearest wall surface or another cabinet box, but not 
automatically generated or Custom Countertops.             

 l If a Custom Countertop is selected, Temporary Dimensions will locate the nearest wall surface, Custom Countertop, or 
automatically generated countertop edge.             

MOVING WALLS WITH CABINETS ATTACHED

When a cabinet is placed or moved against a wall, it will snap to the wall and become attached to it. When a wall is moved, 
all attached cabinets move with it. 

When wall layers are resized or the wall layer definition redefined, the cabinets may become unattached. To reattach, select 
the cabinets, drag them away from the wall, and then drag them back again.          

 

Editing Cabinet Styles
A variety of settings allow you to customize the appearance of your cabinets to create styles ranging from traditional to 
contemporary.

If the desired style is known before cabinets are placed, you can save time by specifying that style in the Cabinet Defaults 
dialogs before you start drawing. See Cabinet Defaults on page 629.

A wide variety of cabinet style attributes can be included in and applied to multiple cabinets and cabinet fillers at once using 
Style Palettes. See Style Palettes on page 284. 
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A variety of cabinet style attributes, including doors and drawers, 
moldings, and millwork accessories can be replaced with 

different items selected in the library. See Replace From Library on page 
983.

CABINET FACE ITEMS

A variety of different face items can be added to the front of any cabinet, including doors, drawers, cutting boards, and 
horizontal separations. Face items can be moved, resized, as well as removed and can also be split vertically or horizontally 
to produce a variety of custom configurations. See Front/Sides/Back Panel on page 658.

When adding, removing, or resizing face items, it is helpful to keep a few rules in mind:

 l Door and drawer Item Height settings reflect the height of the opening rather than that of the front item. When 
Traditional Overlay is specified, an item’s front height will be equal to its Item Height plus its top and bottom 
Vertical Overlap.           

 l When the overall height of a cabinet or the height of a face item is changed, the height of the lowest face item that is 
not a Separation is adjusted to accommodate the change. 

 l If you increase the height of the lowest face item, the non-Separation item directly above is adjusted; if you decrease 
its height, a Blank Area and Separation are created below it. 

 l If the bottom-most face item on a cabinet is a Separation and you increase its height to be greater than the default 
value, it will extend down past the bottom of the cabinet, creating a recessed bottom.

 l By default, if the bottom-most face item on a cabinet is anything other than a Separation or Blank Area, the cabinet 
box will be treated as an appliance garage and will not have a bottom. 

Note: To ensure that Face Item heights always equal the total cabinet 
front height, the program automatically adjusts the bottom Face Item as 
changes are made elsewhere. This means you should start editing Face 
Items at the top and work down. 

When editing a cabinet’s width, or when adding or removing features that affect the width of a cabinet’s front items, the 
program will try to maintain the relative sizes of face items in any vertically split layouts.          

DOORS, DRAWERS AND PANELS

 l Cabinet doors, drawers, and panels can be applied in either of two ways:  
 l In the Cabinet Specification dialog. See Door/Drawer Panel on page 663 and Front/Sides/Back Panel on page 658.
 l Directly from the Library Browser.

Select a style in the Library, then click on a cabinet to apply the selected style to that cabinet. See Replace From Library on 
page 983.

A secondary door or drawer style can also be specified - for example, to create glass doors above solid doors in wall 
cabinets. See Front/Sides/Back Panel on page 658.          

FRAMED AND FRAMELESS CABINETS

Both framed and European-style frameless cabinets can be specified in Chief Architect.     

For both types of cabinet, you can define the door and drawer overlay or specify inset doors. On a traditional framed 
cabinet, you can also control the size of the rails and stiles. See Front/Sides/Back Panel on page 658.     
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CABINET HARDWARE

Cabinet handles, pulls, and hinges can be assigned in the Cabinet Specification dialog. See Door/Drawer Panel on page 
663.

The hardware on individual doors and drawers can also be customized. See Front/Sides/Back Panel on page 658.    

In 3D views, cabinet hardware can also be applied directly from the Library Browser. Select a cabinet hardware item in the 
Library, then click on a cabinet door or drawer to assign it to all face items of that type, including custom hardware on 
individual face items. See Inserted Objects on page 981.          

PILASTERS, FEET, AND MOLDINGS

Pilasters can be applied to any cabinet in its Cabinet Specification dialog. Cabinet feet can also be applied to base and full 
height cabinets. See Moldings and Millwork on page 942 and Accessories Panel on page 666.          

Multiple molding profiles can also be applied around the perimeter of a cabinet at any height. For example, you may want 
an edge profile around base cabinet countertops and a crown molding that ties together the tops of the wall cabinets and full 
height cabinets. Moldings can be built up or stacked, and can be recessed, as well - for example, to produce a light rail or 
light valance. You can also choose to offset cabinet moldings from either the box or face items. Moldings are automatically 
suppressed along any side where the cabinet is within 3" (75 mm) of a wall, another cabinet, a Partition, or free-standing 
appliance from the Library. See Moldings / Profiles Panels on page 943.          
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Wall cabinet with crown molding and light 
rail

COUNTERTOPS AND BACKSPLASHES

The countertop thickness, overhang, corner shape, edge profile, and material for a selected base cabinet can be specified in 
the Cabinet Specification dialog. See General Panel on page 653 and Moldings / Profiles Panels on page 943.

Backsplashes can be applied to base cabinets as well as down from wall cabinets on the GENERAL panel of their 
specification dialogs.         

Custom Countertops, Counter Holes, and Backsplashes can also be created independent of base or wall cabinets. See The 
Cabinet Tools on page 631.

CABINET SHELVES

You can customize the shelves inside base, wall, and full height cabinet boxes. See Cabinet Shelf Specification Dialog on 
page 669.            

You can also specify the material assigned to a cabinet’s shelves on the MATERIALS panel of the Cabinet Specification 
dialog. See Cabinet Specification Dialog on page 653.            

 

Special Cabinets
There are a number of special cabinet shapes that can be specified. Certain requirements must be met before some special 
cabinet shapes can be specified. If the requirements are not met, a warning message will explain what is needed. See 
Cabinet Specification Dialog on page 653.

Note: Only Standard cabinets can be the default cabinet Type. See 
Cabinet Defaults on page 629. 

STANDARD CABINETS

Select Build> Cabinet> Base Cabinet  and click in plan view to place a standard, rectangular base cabinet.

CORNER CABINETS

To create a corner cabinet, click as close to an inside wall corner as possible using either the Base Cabinet , Wall 

Cabinet , or Full Height  cabinet tool. A corner cabinet remains a corner cabinet when it is moved, edited or copied.

You can turn an existing cabinet into a corner cabinet by selecting “Corner” from the Special drop-down list in its 
specification dialog. See General Panel on page 653.
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 l Before a corner cabinet can be specified in the Cabinet Specification dialog, the cabinet’s Width must be greater than 
its Depth.

 l The Left and the Right Side Widths can be set independently for corner cabinets. 

 l You can specify a Diagonal Door on corner cabinets to create an angled corner cabinet. See Front/Sides/Back Panel on 
page 658.

 l The diagonal door on corner cabinets can be curved by entering a negative value in the second Right Side Width field. 
See General Panel on page 653.         

EXPOSED END CABINETS

A cabinet that is merged on one side but not the other is referred to as an Exposed End.           

Pilasters, feet, countertop overhangs and closed toe kicks all behave differently when groups of cabinets are merged:           

 l If multiple cabinets are joined together, only Exposed End cabinets have corner pilasters, cabinet feet, side counter 
overhangs, and closed toe kicks.          

 l If multiple joined cabinets have both Front Pilasters and Corner Pilasters specified, the Exposed End cabinets 
include corner pilasters and inside cabinets have front pilasters.         

 l If multiple cabinets are joined, inside cabinets share Front Pilasters.          
 l Corner pilasters and cabinet legs are eliminated on the back if the cabinet is against a wall, and on either side if it’s 

joined with another cabinet.         

END CABINETS

To turn a cabinet into an end cabinet, specify its Type as “Left End” or “Right End”.
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 l End Cabinets have an angled front and side.
 l The cabinet width must be no greater than its depth for an end cabinet to be specified.

RADIUS END CABINETS

To turn a cabinet into a radius end cabinet, specify its Type as “Left Radius End” or “Right Radius End”.

As you face the cabinet, a right radius end curves to the right, and a left radius end curves to the left.

PENINSULA RADIUS CABINETS

To turn a cabinet into an end cabinet, specify its Type as “Peninsula Radius”.

The radius can be adjusted by changing the Depth/Bow Depth value. See General Panel on page 653.          

ANGLED FRONT CABINETS

To assign an angled front to a cabinet, specify its Type as “Angled Front”.         
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 l The length of the left and right side of an Angled Front cabinet can be defined by changing the Depth/Bow Depth 
value. See General Panel on page 653.             

BOW FRONT CABINETS

To assign a bow front to a cabinet, specify its Type as “Bow Front”.          

 l The bow depth of a Bow Front cabinet can be defined. See General Panel on page 653.         
 l The bow depth cannot exceed half the cabinet width.         
 l The doors and drawers on a Bow Front cabinet automatically match the curvature of the cabinet.         

KITCHEN ISLANDS

To create a kitchen island, simply place several cabinets back-to-back and/or side-to-side. Match the widths so that each 
cabinet back or side meets the back or side of only one other cabinet. If this is not done, the lines separating the cabinets 
cannot be suppressed. 

A given side of a single cabinet cannot merge with the edges of two different cabinets. The example below shows two 
instances of cabinets placed back-to-back. Cabinet fronts and joining surfaces are shown.

BLIND CABINETS

Often, when two cabinets meet in a corner, one is partially hidden by the other. This partially hidden cabinet is called a 
“blind” cabinet. Chief Architect will resize and offset the front items of the partially hidden cabinet so that they are not 
located in the hidden portion of the cabinet face.

You can turn off this automatic behavior in the General Cabinet Defaults dialog. See General Cabinet Defaults on page 630.          

You can also create a blind cabinet manually by controlling the widths of a cabinet’s left or right stile in its Cabinet 
Specification dialog. See Front/Sides/Back Panel on page 658.          
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Cabinet Specification Dialog
Select one or more cabinets and click the Open Object edit button to open the Cabinet Specification dialog.

You can also open the specification dialog for the cabinet(s) associated with a schedule row. See Open Row Object(s) on 
page 699.          

If the selected cabinet is an imported symbol in a legacy plan, the Cabinet Symbol Specification dialog opens instead and 
has fewer options than the Cabinet Specification dialog.           

The options in the Cabinet Specification dialogs are similar to the corresponding Cabinet Defaults dialog. See Cabinet 
Defaults on page 629.   

The Cabinet Specification dialogs have the following panels:

GENERAL PANEL

 
Cabinet Style

A number of Cabinet Types are available in the drop-down list. Certain requirements must be met before some types can 
be specified. Not available in the Cabinet Defaults dialogs. See Special Cabinets on page 649. 

 l Check Filler to specify the selected cabinet as a filler of the same type instead of a true cabinet. See Cabinet Fillers 
on page 634. Not available in the Cabinet Defaults dialogs.          

653



Chief Architect Premier X14 Reference Manual - Cabinet Specification Dialog

 
Size/Position

The selected cabinet’s dimensions and position relative to the floor can be specified here. Fractional values are supported to 
1/16th of an inch (1 mm).

 l Specify the Width of the cabinet box, as measured across the front of the cabinet box from left to right. This does 
not include the countertop overhang.

 l Specify the Height (Including Counter) of the cabinet box, as measured from bottom to top. For base cabinets, this 
value includes the countertop thickness, but not the height of the backsplash. 

Note: Height refers to the height of the entire cabinet, including 
countertop and toe kick. If you change the Countertop Thickness or 
Toe Kick Height, the cabinet’s total height is not altered. Instead, the 
cabinet face height and the heights of face items change in response. 

 l Specify the Depth of the cabinet box, as measured from front to back. It does not include the thickness of overlay 
doors or the countertop overhang. 

 l For Corner cabinets, the Width and Depth fields are instead named Right Side Width and Left Side Width.

 l For Corner and Bow Front cabinets, specify the Bow Depth. A positive number creates a bow and a negative 
number, an inside bow. Not available for Corner cabinets if Diagonal is unchecked on the Front panel. See 
Front/Sides/Back Panel on page 658.

 l For Angled Front cabinets, specify the Left Depth and Right Depth rather than the Depth and Bow Depth.

 l Select the Elevation Reference from the drop-down list. This determines where the next two settings are measured 
from and also affects their setting labels. 

 l Specify the to Top distance, measured from the Elevation Reference to the top of the cabinet’s countertop. 

 l Specify the to Bottom distance, measured from the Elevation Reference to the bottom of the cabinet, including the 
toe kick.
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Countertop

Specify the dimensions and style of the selected cabinet’s Countertop, or uncheck this box to prevent it from having a 
countertop. Only available for base cabinets and fillers.              

 l Specify the countertop Thickness. Changing this value does not alter the cabinet height, but it does affect the height 
of face items. See Front/Sides/Back Panel on page 658.         

 l Specify the countertop Overhang. Uncheck Uniform to specify separate values for each side in the fields below, or 
leave it checked to use the same value for all sides. Overhangs do not generate on sides that are against a wall, free-
standing appliance, Partition, or another Base or Full Height Cabinet. See Cabinet Snapping and Aligning on page 
636.         

 l Corner Treatment - Specify Clipped or Rounded countertop corners. The options here are the same as those for 
the Cabinet Corner Treatment, but affect the countertop rather than the cabinet box. See Box Construction Panel on 
page 657.

 l When Clipped or Rounded is selected, specify the Corner Width, which is measured from the original location of 
the corner to the point where the straight front edge ends. 

 l When Include Countertop in Schedule is checked, the selected cabinet's countertop is listed in any schedule set up 
to include Countertops. Uncheck this box to exclude the selected cabinet's countertop from schedules. See Cabinet 
Schedules on page 640.             

 
Backsplash

Check the box beside Backsplash, then specify its dimensions and when it should generate, or leave this box unchecked to 
prevent the selected base or wall cabinet or filler from having a backsplash.              

 l Specify the backsplash Height and Thickness.              Height is only available for base cabinets - not wall cabinets.

 l Check Side to add the backsplash to the side of the cabinet if it is against a wall or a taller cabinet. Not available for 
Corner cabinets.         

 l Check Always Present to display the backsplash at all times. If unchecked, a backsplash is present only when the 
cabinet is against a wall.         

 l The Backsplash to Base Below check box is only available in legacy plan files if it was checked in the original 
program version. When checked, a backsplash extends from the selected wall cabinet down to the backsplash or 
countertop of the base cabinet below. If this box is unchecked and you click OK, the setting will be removed from 
the dialog.   

 l When Include Backsplash in Schedule is checked, the selected cabinet's backsplash is listed in any schedule set up 
to include Backsplashes. Uncheck this box to exclude the selected cabinet's backsplash from schedules. See Cabinet 
Schedules on page 640.    
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Toe Kick

Specify the dimensions and style of the selected cabinet’s  Toe Kick, or uncheck this box to prevent it from having a toe 
kick. Only available for base and full height cabinets and fillers. Regardless of the settings here, toe kicks do not generate  
on sides that are against a wall, free-standing appliance, Partition, or another Base or Full Height Cabinet.            

 l Specify the toe kick’s Height and Depth. Changing the Height does not alter the cabinet height but does affect the 
heights of the cabinet face and face items.             

 l Flat Sides can be added to base and full height cabinets. Checking Flat Sides eliminates the toe kick area on the 
exposed end(s) of the cabinet.             

 l Check Flat Back to eliminate the toe kick on a cabinet with an exposed back. This does not eliminate the toe kick 
on the cabinet front.             

 l Check Closed Toe to extend the cabinet sides to cover the sides of the toe kick. If pilasters that do not extend to the 
floor are specified, checking this places a support block under them at Exposed Ends. See Accessories Panel on page 
666.    

 l Check Always Present to preserve the Closed Toe at all times. When this is unchecked, the Closed Toe is removed 
where cabinets are side by side. Only available when Closed Toe is checked.              

  Options

 l Uncheck Diagonal Door to create double doors at right angles instead of a single diagonal door. This option is 
checked by default in the Cabinet Defaults dialog and is only available for Corner Cabinets. See Corner Cabinets on 
page 649.

 l Check Lazy Susan to indicate a lazy Susan in the cabinet’s label and its appearance in plan view. This option does 
not display in 3D views.

 l When Suppress Adjacent Room Moldings is checked, room moldings do not generate on walls where the selected 
cabinet touches them. Uncheck this box to allow room moldings to generate through the cabinet. See Room Moldings 
on page 441.

 
Preview

A preview of the selected cabinet displays on the right side of the panel. See Dialog Preview Panes on page 22. 
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BOX CONSTRUCTION PANEL

 
Box Construction

Define the Box Construction of the selected cabinet. Select Framed to create a traditional framed cabinet and enable the 
settings below, or choose Frameless for a European style cabinet.           

 l Specify the Separation value, which is the width of the horizontal face frame piece between doors, drawers, and 
other face items.     

 l The Left and Right Side Extend settings allow you to extend the front frame beyond the box sides. See Cabinet 
Filler Tools on page 635.    

 
Top/Bottom

Specify whether the selected cabinet or filler has a Top/Bottom. 

 l By default, base cabinets do not have tops while wall and full height cabinets do.

 l When the Bottom Auto option is selected and the selected cabinet's bottom-most face item is a Separation or a 
Blank Area, it will receive a bottom; if it is any other face Item Type, it will not. See Cabinet Face Items on page 
647.

 
Door/Drawer Overlay

Define the Door/Drawer Overlay of the selected cabinet. See Cabinet Construction on page 643.    

 l Select Traditional Overlay, then specify the Overlap value.    

 l Select Full Overlay, then specify the Reveal, which is the distance between door and drawer front items. This 
serves as the default for the Left and Right Reveal settings on THE FRONT/SIDES/BACK panel.    

 l Select Inset to produce doors and drawers that are flush with the rails and stiles rather than overlaying it.             
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Cabinet Corner Treatment

Specify clipped or rounded corners for the selected cabinet’s box. These settings are only available for Standard, Corner, 
and Bow Front cabinet types.         

 l Select Rounded to create rounded cabinet corners, then specify the length of the chords of those rounded corners.   

 l Select Clipped to create 45° angled edges at the cabinet corners, then specify the length of those angled edges.   

 l Select None for cabinet corners that are neither clipped nor rounded.   

 l Specify the Corner Width value, as measured from the original corner to the point at which the clip or curve begins. 
Only available if Clipped or Rounded is selected.   

 
Preview

A preview of the selected cabinet displays on the right side of the panel. See Dialog Preview Panes on page 22. 

FRONT/SIDES/BACK PANEL

If you click on a cabinet face item in the preview on the right side of the dialog, the FRONT/SIDES/BACK panel will become 
active and that face item will be selected and can be edited. 
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Cabinet Side

Select which Cabinet Side you would like to edit: the Front, Back, Left or Right side.         

 l Assign a Side Type to the selected Side. Only “Use Default” and “Custom Face” are available for the Front. The 
options are:              

 l Select “Use Default” to use the default configuration set in the Cabinet Defaults dialog. See Cabinet Defaults on 
page 629.             

 l Select “Finished” to specify the selected side as finished or “Unfinished” to specify it as unfinished. “Finished” and 
“Unfinished” are only used in Cabinet Schedules. See Columns to Include on page 701.              

 l Select “Auto Finished” to finish the side only when it is not adjacent to another cabinet or a wall.             

 l Select “Paneled” to apply a panel to the selected side.             

 l Select “Auto Paneled” to apply a panel to the side only when it is not adjacent to another cabinet or a wall.              

 l Select “Match Front” to apply the same face items as the cabinet front to the selected side.              

 l Select “Custom Face” to enable the Face Items settings below. 

 l Select "None" to generate no face items on the selected side or back: including the frame, if specified.             
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Face Items

Most of the Face Items settings are only active when a door, drawer, or other face item is selected. To select a face item, 
click on its name in the list or click on it in the preview on the right.             

When a face item is selected, it is highlighted in the list as well as in the preview; its attributes can be edited and the list can 
be navigated using the arrow and number keys. The vertical frame pieces on the sides of the cabinet front are referred to as 
stiles and cannot be selected in the preview. See Cabinet Face Items on page 647.

 l A numbered tree list of face items displays here. Item numbers start at the top of the cabinet and go down the face to 
the bottom of the cabinet. Item 1 is usually the top face frame Separation, or rail. The selected face item is 
highlighted; if no item is selected, the “Vertical Layout Parent” heading will be highlighted. 

 l The name of inserted library objects associated with doors, drawers, and appliance items is stated in the list. If a door 
or drawer is using the default  style, it s name will be preceded by "Default".

 l Click Add New to add a new face item directly below the currently selected item. When a face item is added, the 
height of the lowest item on the cabinet front is reduced to make room for the new item. If you click Add New with 
no face item selected, the new item is added to the bottom of the cabinet face.

 l In the New Cabinet Face Item dialog, define the Item Type, Item Height, and click OK. If the Item Type is 
“Separation”, you can check Default to use the default Separation Height. 

 l Click Delete to remove the selected face item. When an Auto Left, Auto Right, Left, Right, or Double Door is 
deleted, it is replaced by an Opening; when other face item types are deleted, the height of the lowest item is 
increased to make up the difference. You can also press the Delete key on the keyboard. 

The program tries to maintain a single separation between all 
face items. When you add or delete a face item, separations 

are usually added or deleted with them.

 l Click Move Up to move the currently selected item up one position, switching places with the item directly above.    

 l Click Move Down to move the currently selected item down one position, switching places with the item directly 
below.    

 l When the selected face item is part of a “Layout - Horizontal”, the Move Left and/or Move Right buttons will be 
available instead. Click either to have the selected item switch places with its neighbor.              

 l Click Split Vertical to divide the selected face item into two separate side-by-side items of the same Item Type and 
Height. A vertical separation is added between them and together the three new items have the same Width as the 
original item. Not available for Horizontal or Vertical Layouts, Appliances, Separations, or for items 1 1/2” (50 mm) 
wide or less.              

 l Click Split Horizontal to divide the selected face item into two separate items of the same Item Type and Width, 
stacked one above the other. A horizontal separation is added between them and together the three new items have 
the same Height as the original item. Not available for Horizontal or Vertical Layouts, Appliances, Separations, or 
for items 1 1/2” (51 mm) tall or less.              
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 l Click Equalize to make the sizes of a face item’s sub-items equal in size. Only available if the selected item is a 
Vertical or Horizontal Layout with sub-items.              
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  Selected Item Properties

 l Choose the selected face item’s Item Type from the drop-down list:    

Item Type Special Behaviors

Blank Area Creates a solid, flat surface.

Horizontal 
Layout

Creates a group of identical, side-by-side items separated by vertical 
separations.

Vertical 
Layout

Creates a group of identical, stacked items separated by horizontal 
separations.

False 
Drawer and

False 
Double 
Drawer

Assumes the appearance of specified the drawer style, including 
hardware.

Drawer and 
Double 
Drawer

Creates a single or double drawer of the specified drawer style, 
including hardware.

Cutting 
Board

Creates a cutting board. 

Auto Right 
and Auto 
Left Door

Become double doors when the width of the opening is greater than the 
Auto Door Threshold. See General Cabinet Defaults on page 630. 

Left, Right, 
and Double 

Door

As specified, regardless of opening width.

Door Panel Assumes the appearance of the specified door style but with no 
hardware.

Opening Creates an opening with shelves.

Separation Creates a horizontal rail, or frame piece. 

Appliance Creates an opening with no shelves, for which an appliance can be 
specified.

 l Specify the selected face item’s Item Height. Fractional values are supported to 1/16th of an inch (1 mm). For 
doors and drawers, this is the height of the opening: the selected door or drawer's Front Height is reported to the 
right for reference. A door or drawer’s front height is equal to its Height plus its top and bottom Vertical 
Overlap. For best results, edit face item heights starting at the top of the cabinet and work down. See Cabinet 
Face Items on page 647.    

 l Specify the selected face item’s Item Width. Fractional values are supported to 1/16th of an inch (1 mm). For 
doors and drawers, this is the width of the opening: the selected door or drawer's Front Width is reported to the 
right for reference. Only available for components of a Horizontal Layout.              

 l Check Lock from Auto Resize to prevent the selected face item from resizing when the cabinet is resized, new 
face items are added, or when the Equalize button is clicked.
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 l Shelves - Click the Specify button to open the Cabinet Shelves Specification dialog and specify the shelf 
configuration for a selected Door or Opening Face Item. See Cabinet Shelf Specification Dialog on page 669.             

 l When an Appliance/Door/Drawer or panel is selected, click the Specify button to choose an appliance from the 
Library or to customize the selected door, drawer, or panel’s front style and hardware. The options available 
depend on the type of face item currently selected. See Select Library Object Dialog on page 982 and 
Door/Drawer Panel on page 663.               

 l Click the Edit button to open the selected appliance's Fixture Specification dialog. See Symbol Object 
Specification Dialogs on page 989.

 l Click the Clear button to remove the selected appliance from the cabinet or to reset the selected door or drawer 
so it uses hardware and front style assigned to the cabinet.               

 l Check Reverse Appliance to reverse the selected face item from left to right: for example, to move a 
dishwasher’s controls from the left side to the right. Only available when an “Appliance” item is selected. See 
Inserted Objects on page 981.    

 l Specify the Percent Open of a selected drawer, which controls how far it is shown open in plan and 3D views. 
See Cabinet Doors and Drawers on page 639.    

 l Specify the Swing Angle of a selected door in plan and 3D views. An angle of 0° displays the door completely 
closed and an angle of 180° displays it as wide open.    

  Side Properties

 l Specify the widths of the Left Stile and Right Stile. Only available when the selected cabinet has Framed Box 
Construction specified. See Framed and Frameless Cabinets on page 647.             

 l Specify the Left Reveal and Right Reveal. For Framed cabinets, this is the reveal on the Left and Right Stiles; for 
Frameless cabinets, this is the reveal on the sides of cabinet box.    

  Options

 l Specify which types of front items you would like to Show Open in plan, 3D, and cross section/elevation views. See 
Cabinet Doors and Drawers on page 639.      

 
Preview

A preview of the selected cabinet displays on the right side of the panel. See Dialog Preview Panes on page 22.             

 l Select Cabinet Face Item  mode is active by default and allows you to click on a face item like a door, drawer, 

or separation in the preview to select it for editing. The selected face item is highlighted in grey. 

 l Mouse-Orbit Camera  mode allows you to orbit around the preview of the cabinet. When this is active, you can 

right-click on a front item to select it. 

 l Face items identified as “Horizontal Layout” in the list on the left cannot be selected in the preview.          

DOOR/DRAWER PANEL

The settings on the DOOR/DRAWER panel allow you to control the appearance of the selected cabinet’s doors, drawers and 
hardware. 

Similar settings are also found in the Door, Drawer, and Side Panel Face Item Specification dialogs, which allow you to 
customize the door, drawer, and panel style as well as the hardware for individual cabinet face items. See Front/Sides/Back 
Panel on page 658.
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  Door

 l Select a door Main Style from the drop-down list. See Doors, Drawers and Panels on page 647.    

 l Select “Use Default” to apply the door style specified in the defaults dialog for the selected cabinet’s type. See 
Cabinet Defaults on page 629.    

 l Select “Slab Doors” to apply a flat door front or “Framed Doors” to apply a door with a frame and flat panel front.    

 l Select “Library” or click the Library button to select a cabinet door from the library. If a library door has been 
previously selected, its name will display in the list. See Select Library Object Dialog on page 982.    

 l Check Glass Doors to use a glass material for the panel of Framed doors or for the entire door for Slab doors. Not 
available when “Library” is the selected door Style. 

 l Check Stile Between Doors to separate double doors and double drawers with a stile. Other face items types are not 
affected by this setting.               

  Door Handle

 l Select a door handle Main Style from the drop-down list or choose one from the Library. 

 l When a handle from the Library is selected, you can click the Edit button to customize the handle's size and angle. 
See Hardware Size/Orientation Dialog on page 670.

 l Specify the position of the handle In From Edge, as measured from the edge of the door opposite the hinges.

 l Specify the height of the handle Down From Top, as measured from the top edge of the door. For wall cabinets, this 
value is measured Up From Bottom.
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  Door Hinges

 l Select a door hinge Style from the drop-down list or choose one from the Library. 

 l When a handle from the Library is selected, you can click the Edit button to customize the handle's size and angle. 
See Hardware Size/Orientation Dialog on page 670.

 l Specify the location of the hinges Up/Down From Edge, as measured from the door edge. If the cabinet door is 
more than 35 1/4” (880 mm) high, three hinges will be created instead of two. 

 
Drawer

Select a drawer Style from the drop-down list or choose one from the Library. For best results, “Framed” drawers should 
be at least  6” (150 mm) high.

  Drawer Handle

 l Select a drawer handle Style from the drop-down list or choose one from the Library. 

 l When a handle from the Library is selected, you can click the Edit button to customize the handle's size and angle. 
See Hardware Size/Orientation Dialog on page 670.

 l Specify the Horizontal Position of the drawer handle(s): Choose Use Default to use the default position; One 
Handle Centered for a single handle centered on the drawer face; or Two Handles In From Edge for two handles 
set in from the drawer sides by the value specified in the text field. 

 l Specify the Vertical Position of the drawer handle(s): Choose Use Default to use the default position, Centered for 
handle(s) centered on the drawer face, or specify the handle’s Distance From Top. 

  Options

 l Enter a Slab Bevel width to create beveled edges on Slab drawers and doors. The bevel width, as viewed from the 
front, has a maximum value of 3” (75 mm). Framed and Library doors are not affected by this setting.               

 
Preview

A preview of the selected cabinet displays on the right side of the panel. See Dialog Preview Panes on page 22.

DOOR AND DRAWER FACE ITEM SPECIFICATION DIALOGS

Additional settings are available in the Door and Drawer Face Item Specification dialogs. See Storage and Organization 
Inserts on page 634.          

The Door Back Inserts settings allow you to choose one or more storage items for the back of a selected door.          

 l A drop-down list of the inserts assigned to the selected door displays here. Select the name of an object to edit it or 
remove it from the list.          

 l Click the Add New button to open the Select Library Object dialog and add a new symbol to the list. See Select 
Library Object Dialog on page 982.          

 l Click the Replace button to remove the selected symbol and replace it with a new one from the library. Only available 
when an object is already selected.         

 l Click the Delete button to remove the currently selected symbol from the list.          
 l Select Top to Bottom to place the first insert at the top of the selected door and place additional ones evenly spaced 

below it.          
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 l Select Bottom to Top to place the first insert at the bottom of the selected door and place additional ones evenly 
spaced above it.          

The Drawer Box/Pullout setting allows you to select an insert for a selected drawer from the library.           

ACCESSORIES PANEL

The settings on the ACCESSORIES panel let you apply pilasters, feet, and panels to the selected cabinet(s), as well as specify 
a fixture set into the countertop. The accessories specified here can be seen in 3D views, schedules, and the Materials List; 
however, with the exception of Top Appliance/Fixtures, they do not display in plan view. 

 
Pilasters

                 Specify the desired Pilasters for the selected Standard or Corner cabinet(s).  See Editing Cabinet Styles on page 646.         

 l Front Pilaster - Select the default front pilaster, a pilaster from the library, or None.          

 l Corner Pilaster - Select the default corner pilaster, a pilaster from the library, or None. Specifying a corner pilaster 
automatically creates a flat, clipped corner of the Width specified below and overrides the Cabinet Corner 
Treatment setting on the Box Construction Panel on page 657. Corner Pilasters are not applied to Corner cabinets 
with Diagonal Doors selected.         

 l Specify the Width of the selected cabinet’s pilasters. This value applies to both front and corner pilasters.          

 l Check Extend to Bottom to extend front and corner pilasters to the bottom of the toe kick. When this is unchecked, 
pilasters stop at the top of the toe kick.         
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Feet

                 Specify Feet for the selected Standard or Bow Front cabinet(s). Select the Default cabinet foot, a cabinet foot from the 
Library, or None. Not available for wall cabinets. See Editing Cabinet Styles on page 646.         

 l Specify the Width Offset, which is the offset of the cabinet feet relative to the sides of the cabinet box.          

 l Specify the Depth Offset, which is the offset of the cabinet feet relative to the front and back of the cabinet box.          

 l Check Always Present to place cabinet feet under the selected cabinet regardless of where it is located. When 
checked, any adjacent cabinet edges will display feet as well. When unchecked, the cabinet will only receive feet 
along its outside edge if it is an end cabinet.          

 l Check Stretch to Fit to resize the cabinet feet so that they extend from each corner to the midpoint of each edge. 
Only affects cabinet foot symbols with stretch planes defined. See Stretch Planes and Zones on page 1005.         

 l Check Retain Toe Kick to place a toe kick under the cabinet. When unchecked, the toe kick is suppressed.         

 
Panels

Specify the characteristics of the selected cabinet’s  Panels. You can specify whether a panel is applied or inset by selecting 
the desired Item Type. See Front/Sides/Back Panel on page 658.         

 l Choose “Use Default” or select a Slab, Framed, or Library Panel Style from the drop-down list.          

 l Click the Library button to select a panel style from the Library Browser. Cabinet doors are typically used, although 
drawers can be used, as well. See Select Library Object Dialog on page 982.         

 l Specify the selected panel’s Thickness.         

 
Side Panel Options

The Side Panel Options control how the side panels are applied to the cabinet.         

 l Check Full Size Panel to apply a single panel to the entire side. When unchecked, the panel uses the same Style and 
Overlap values as the front. If the cabinet has multiple levels of doors on its front, the side will have matching 
panels.         

 l Check Full Overlay to extend Left and Right Side Panels to the outer surfaces of the cabinet’s front and back, 
including any doors, panels, or finishes that may be present.          

 l Check Extend to Bottom to extend panels on the Left, Right, or Back Sides to the bottom of the cabinet, including 
the toe kick.         
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Top Appliance/Fixture

The Top Appliance/Fixture settings apply to a fixture inserted into a base cabinet’s countertop. These settings are not 
available in the Base Cabinet Defaults dialog. See Built-In Sinks and Appliances on page 633.    

 l Select a fixture Symbol from the drop-down list, or choose “None”. If a fixture is inserted into the countertop, its 
name will be listed. If no top fixture is present, you can select “Library” to select a fixture symbol from the Library.    

 l Specify the Front Offset, which is the distance from the front of the fixture to the front of the cabinet box. A 
positive value offsets the fixture towards the back of the cabinet while a negative value moves it forward. 

 l Specify the Center Side Offset, which is the distance between the fixture’s center and that of the cabinet. A positive 
value offsets the fixture to the right while a negative value offsets it to the left.    

 l Check Reverse to reverse the selected fixture from left to right: for example, to move a cooktop’s controls from the 
left side to the right. See Inserted Objects on page 981.

 
Preview

A preview of the selected cabinet displays on the right side of the panel. To see the cabinet’s pilasters and feet, you may 
want to zoom in. See Dialog Preview Panes on page 22. 

OPENING INDICATORS PANEL

The settings on the OPENING INDICATORS panel allow you to control whether an opening indicator displays on the selected 
cabinet's door(s) in camera views. See Opening Indicators Panel on page 578.

MOLDINGS PANEL

The settings on the MOLDINGS panel allow you to assign one or more horizontal moldings around the selected cabinet. See 
Editing Cabinet Styles on page 646.

For information about the settings here, see Moldings / Profiles Panels on page 943.

LAYER PANEL

The LAYER panel is found in the specification dialogs for many different objects. For more information, see Layer Panel on 
page 191.

FILL STYLE PANEL

The settings on the FILL STYLE panel affect the appearance of the selected cabinet in plan view. For more information, see 
Fill Styles on page 197.

MATERIALS PANEL

The settings on the MATERIALS panel affect the appearance of the selected cabinet in 3D views. For information about these 
settings, see Materials Panel on page 1055.

Some material options may be disabled if the selected cabinet is a manufacturer symbol. 

LABEL PANEL

Cabinet labels display in plan and cross section/elevation views when the “Cabinets, Labels” layer is turned on and use the 
Text Style assigned to that layer. See Cabinet Labels on page 641. 
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For more information about the settings on this panel, see Label Panel on page 712.

Note: If you choose Use Callout for Label in the Cabinet Schedule 
Specification dialog, the settings here are overridden and the schedule 
label is used instead.

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 1335.

OBJECT INFORMATION PANEL

The information entered on the OBJECT INFORMATION panel can be used in schedules and the materials list. For more 
information, see Object Information Panel on page 1336.   

SCHEDULE PANEL

The settings on the SCHEDULE panel determine which schedule categories the selected cabinet is included in. See Schedule 
Panel on page 716.

 

Cabinet Shelf Specification Dialog
In the Base Cabinet, Wall Cabinet, or Full Height Cabinet Specification dialog, select a door or opening face item and click 
the Specify Shelves button to open the Cabinet Shelf Specification dialog.  See Front/Sides/Back Panel on page 658.          
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Shelf Management

Specify how shelves in the selected face item are created.

 l By default, cabinet doors and openings receive Automatic cabinet shelves. The number of shelves, shelf type, 
thickness, spacing, and depth display below.          

 l Select the Manual radio button to specify the shelving for the selected door or opening. If the cabinet is resized after 
shelving has been manually edited, the specifications are maintained, but all shelves may not display in all situations.          

 
Automatic Settings

Displayed for reference only. 

 
Manual Shelf Specification

 The following settings are available when Manual is selected, above:             

 l Specify the total Number of Shelves in the selected door or opening front item.           

 l Select a Shelf from the drop-down list to customize its settings. To edit all shelves at once, choose “All Shelves”.           

Note: If “All Shelves” is selected after changes are made to an individual 
shelf, “No Change” may display in the settings that follow.

 l Click the Library button to select a shelf, storage, or organization object from the Library Browser. See Inserted 
Objects on page 981.           

 l Click the Clear button to restore the default shelf style.          

 l Check Rollout, then specify the amount that the shelf rolls out when set to Show Open. Only available for Standard 
cabinets. See Rollout Shelves and Storage on page 639.           

 l Specify the Thickness/Height of the shelves or storage item.           

 l Specify the Spacing From Previous, which is the distance from the bottom of the selected shelf to the top of the 
shelf below it.          

 l If the Spacing From Previous value is changed, Equal Spacing will become unchecked. Check this box to produce 
evenly space the shelves within the selected cabinet front item.          

 l Specify the selected shelf’s Depth: choose Full, Half, or Specify a custom value in inches (mm).          

 
Preview

The preview shows shelf numbers and spacing. Shelf thickness and depth are also represented. Press the Tab key to update 
the preview as changes are made.

 

Hardware Size/Orientation Dialog
In the Base Cabinet, Wall Cabinet, or Full Height Cabinet Specification dialog, click the Edit button associated with either 
door/drawer handles or drawer hinges to open the Cabinet Shelf Specification dialog.  See Door/Drawer Panel on page 663.          
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Name

The Name of the selected hardware symbol is reported here for reference.

  Size/Position

 l Specify the Width, Height, and Depth of the object.     

 l Check Retain Aspect Ratio to maintain the ratio between the object’s Height, Width, and Depth when it is resized 
in this dialog. 

 l Click Reset Size to reset the symbol’s original, unmodified size. The symbol’s elevation is not affected by this 
option.     

  Rotation

 l Specify an exact Angle by typing it in the text field.           

 l Click the Rotate +90° or Rotate -90° button to add or subtract 90° from the Angle value.           

 
Preview

The preview shows the hardware's containing cabinet with the specified hardware. See Dialog Preview Panes on page 22.

 

Shelf/Partition Specification Dialog
Select a shelf or partition and click the Open Object edit button to open the Shelf Specification or Partition 
Specification dialog.

The options in these specification dialogs are similar to the corresponding defaults dialogs. See Cabinet Defaults on page 
629.
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GENERAL PANEL

 
Size/Position

Specify the Height, Width, and Depth of the shelf or partition.    

 l Select the Elevation Reference from the drop-down list. This determines where the next two settings are measured 
from and also affects their setting labels. 

 l Specify the to Top distance, measured from the Elevation Reference to the top of the shelf or partition. 

 l Specify the to Bottom distance, measured from the Elevation Reference to the bottom of the shelf or partition.

 
Preview

A preview of the selected object displays on the right side of the panel. See Dialog Preview Panes on page 22.  

FILL STYLE PANEL

The settings on the FILL STYLE panel affect the appearance of the selected object in plan view.               

MOLDINGS PANEL

The settings on the MOLDINGS panel allow you to apply molding to the selected object. For information about these settings, 
see Moldings / Profiles Panels on page 943.         

LAYER PANEL

For information about the settings on this panel, see Layer Panel on page 191.          

MATERIALS PANEL

The settings on the MATERIALS panel affect the appearance of the selected object in 3D views. For information about these 
settings, see Materials Panel on page 1055.

LABEL PANEL

Shelf and Partition labels display in plan and cross section/elevation views when the “Cabinets, Labels” layer is turned on 
and use the Text Style assigned to that layer. The Automatic Labels for Shelves and Partitions are blank, but you can specify 
custom labels if you wish.  See Cabinet Labels on page 641.

For more information about the settings on this panel, see              Label Panel on page 712.         
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COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 1335.          

OBJECT INFORMATION PANEL

The information entered on the OBJECT INFORMATION panel can be used in schedules and the materials list. For more 
information, see Object Information Panel on page 1336.   

SCHEDULE PANEL

The settings on the SCHEDULE panel determine which schedule categories the selected cabinet is included in. See Schedule 
Panel on page 716.          

 

Custom Countertop Specification Dialog
Select a custom countertop and click the Open Object edit button to open the Custom Countertop Specification 
dialog.         

GENERAL PANEL
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  Options

 l Check Hole in Countertop to convert the selected countertop, which must be contained within another single 
Custom Countertop, into a countertop hole.          

 l Check No Molding On Selected Edge to turn off the display of molding on the selected edge. Only has an effect 
when a molding is specified for the countertop on the MOLDINGS panel of this dialog.             

 l Check Display Molding Edges to display two edge lines instead of one, indicating the width of any molding applied 
to the countertop. Only has an effect when a molding profile is specified for the countertop.              

  Countertop Thickness

 l Uncheck Set Thickness From Cabinet, then specify the Thickness of the selected Custom Countertop below. When 
this is checked, the thickness is inherited from the cabinet below or from the Base Cabinet Defaults dialog if no 
cabinet is present below.             

  Countertop Height

 l Uncheck Set Height from Cabinet, then specify the height of the selected Custom Countertop using the settings 
below. When this is checked, Countertop height is determined by the cabinet below or by the default base cabinet 
counter thickness if no cabinet is present below.             

 l Select the Elevation Reference from the drop-down list. This determines where the next two settings are measured 
from and also affects their setting labels.              

 l Specify the height to Top, which is measured from the selected Elevation Reference to the top of the countertop.             

 l Specify the height to Bottom, which is measured from the selected Elevation Reference to the bottom of the 
countertop.             

 
Waterfall Edge

Control whether the selected countertop edge has a waterfall and specify its attributes. See Waterfall Countertops on page 
638.          

 l Check Add Waterfall to Selected Edge to add a vertical extension to the selected edge of the countertop.              

 l Uncheck Mitre All Waterfall Edges to create butt joints with seams that may be visible in some views where the 
waterfall meets the horizontal countertop and any adjacent waterfall edges. When checked, these joints are mitered 
so the only visible seams are located at the corners.             

 l When Automatic Height is checked, the waterfall builds down to the floor height countertop’s room, or the default 
floor height for the current floor if it is not in a room. Uncheck this to specify the waterfall’s vertical height, below.              

 l Specify the Height from Counter Bottom, measured from the bottom of the horizontal countertop to the bottom of 
the waterfall.          
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Molding on Selected Edge

An edge profile for the selected counter can be specified on the Moldings panel. See Selected Edge on page 214.     

 l Select Automatic to remove the edge profile from the selected edge when it is positioned against a wall and generate 
it otherwise.      

 l Select No Molding to remove the edge profile from the selected edge regardless of where it is positioned.       

 l Select Has Molding to generate the edge profile on the selected edge regardless of where it is positioned.       

 l Check Apply to All Edges to apply the option specified for the currently selected edge to all edges of the 
countertop. This is an action rather than a state: the next time this dialog is opened, this box will be unchecked.

 
Preview

A preview of the selected countertop displays on the right side of the panel. See Dialog Preview Panes on page 22.          

POLYLINE PANEL

The POLYLINE panel states the length of the countertop’s Perimeter, its Area, and its Volume. See Polyline Panel on page 
323.          

If the selected countertop has any Holes, they will be subtracted from the Area and Volume values. See Custom Counter 
Holes on page 633.          

SELECTED LINE/ARC PANEL

The SELECTED LINE panel is available when the selected edge is a line as opposed to an arc. For more information, see  Line 
Panel on page 309.         

The SELECTED ARC panel is available when the selected edge has been converted to an arc. For more information, see Arc 
Panel on page 318.         

See, too, Selected Edge on page 214 and Change Line/Arc on page 259.          

MOLDINGS PANEL

The settings on the MOLDINGS panel allow you to apply an edge profile to the selected countertop. For information about 
these settings, see Moldings / Profiles Panels on page 943.

LINE STYLE PANEL

For information about the settings on this panel, see Line Style Panel on page 310.         

FILL STYLE PANEL

The settings on the FILL STYLE panel affect the appearance of the selected countertop in plan view. For information about 
these settings, see Fill Styles on page 197.         

MATERIALS PANEL

The settings on the MATERIALS panel affect the appearance of the selected countertop in 3D views. For information about 
these settings, see Materials Panel on page 1055.         

675



Chief Architect Premier X14 Reference Manual - Custom Countertop Specification Dialog

LABEL PANEL

Custom Countertop labels display in plan and cross section/elevation views when the “Polylines 3D, Labels” layer is turned 
on and use the Text Style assigned to that layer. The Automatic Label for countertops is blank, but you can specify a custom 
label. See Cabinet Labels on page 641.          

For information about the settings on this panel, see Label Panel on page 712.           

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 1335.          

OBJECT INFORMATION PANEL

The information entered on the OBJECT INFORMATION panel can be used in schedules and the materials list. See Object 
Information Panel on page 1336.   

SCHEDULE PANEL

The settings on the SCHEDULE panel determine which schedule categories the selected object is included in. See Schedule 
Panel on page 716. 
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Chapter 18
 

Electrical

The electrical plan shows the location of all electrical objects such as lights, switches, outlets, smoke detectors and vent 
fans. Basic wiring diagrams show which objects share circuits and the locations of the controlling switches.

Electrical objects can be displayed in 2D and 3D views. Some electrical light fixtures also add light sources to 3D and CPU 
Ray Trace views. See Lighting on page 1133.

Usually, the electrical plan is one of the last additions to a plan since the position of most electrical objects is determined by 
the location of walls, cabinets and other objects.

Building requirements vary throughout the country and around 
the world. It is your responsibility to comply with local codes.

TOPICS

Electrical Defaults 678
The Electrical Tools 679
Placing Electrical Objects 681
Auto Place Outlets 682
Creating Wiring Schematics 682
Electrical Library Content 683
Displaying Electrical Objects 684
Editing Electrical Objects 685
Electrical Service Specification Dialog 686
Rope Light Specification Dialog 691
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Electrical Defaults
Default Settings for electrical objects control which symbols are placed in the current plan when the Electrical Tools 
are used. It can be accessed by selecting Edit> Default Settings or by double-clicking any of the electrical toolbar 

buttons, except Rope Light or Connect Electrical. See Default Settings on page 76. 

 l Electrical Defaults Dialog on page 678
 l Rope Light Defaults on page 679
 l Set as Default on page 679

Default heights and other attributes of individual objects can be overridden in the Electrical Service Specification dialog. 
See Electrical Service Specification Dialog on page 686.

ELECTRICAL DEFAULTS DIALOG

 
Default Library Objects

The Default Library Objects are the objects created using the Electrical Tools. Select an item in the scrollable list to see 
and edit its settings.                 

 l The name of the object shown in the preview image displays here.          

 l Select an item in the Default Library Objects list and click the Library button to select a new default object from the 
library. See Select Library Object Dialog on page 982.          

 l Click the Edit button to open the specification dialog for the selected object. Any changes you make in the 
specification dialog are saved with the plan as long as the selected object is not replaced. See Electrical Service 
Specification Dialog on page 686.          
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Default Heights

Specify the heights at which electrical outlets and switches are initially placed when the Switch or any of the Outlet tools 
are used.                 

 l Check Use Default Heights to apply the default heights specified here to electrical objects placed in plan view using 
the Electrical Tools. When this is unchecked, electrical objects use the height saved with their symbol. See Placing 
Library Objects on page 980.           

 l Outlet - Specify the default height for outlets, as well as phone, cable and TV jacks.          

 l Switch - Specify the default height for switches, doorbells and thermostats.          

 l Above Base Cabinet - Specify the default height for switches and outlets placed above base cabinets in plan view, 
as measured from the countertop. See Adjusting Electrical Object Heights on page 686.          

 l On Cabinet Side - Specify the default height for switches and outlets placed on the sides of cabinet boxes, measured 
relative to the side of the cabinet in question. See Placing Electrical Objects on page 681.          

 
Preview

A preview of the selected object displays here. See Dialog Preview Panes on page 22.             

ROPE LIGHT DEFAULTS

Select Edit> Default Settings, then click the arrow beside “Electrical”. Select “Rope Light” and click the Edit button 
to open the Rope Light Defaults dialog. The settings in this dialog are also found in the Rope Light Specification 

dialog. See Rope Light Specification Dialog on page 691.         

SET AS DEFAULT

The Set as Default edit tool can be used to modify the current plan’s Electrical Defaults and Rope Light Defaults. 
Select an electrical symbol and click the Set as Default edit button. See Set as Default on page 79.         

The default electrical object that is updated depends on the type of electrical object selected as well as its placement. An 
Outlet, for example, might be 110V, 220V, or GFCI; interior or exterior; wall or floor mounted.           

 

The Electrical Tools
Select Build> Electrical to access the Electrical Tools. Some electrical objects are designed to be inserted into walls, 
floors, ceilings or cabinets, although some can also be free-standing. With the exception of Rope Lights and Connect 

Electrical splines, they can be created with a single click in plan and camera views. See Placing Electrical Objects on page 
681.

The Electrical Tools place objects according to the settings in the Electrical Defaults dialog. The default heights for Outlets 
and Switches that follow can also be specified. See Electrical Defaults on page 678.

Different outlet, switch, and light fixture symbols can be placed in different room types. To take advantage of the program’s 
capabilities, define room types properly before placing electrical objects. See Room Types and Functions on page 420.

Once created, outlets, switches, and lights can be selected and edited. See Editing Electrical Objects on page 685.
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OUTLETS

The outlet tools can place receptacles on walls, the floor, and on the sides of cabinets and soffits.

Select Build> Electrical, then choose:

  110V Outlet to place 110 volt duplex outlets. 

  GFCI Outlet to place ground fault circuit interrupter outlets. 

  220V Outlet to place 220 volt outlets. 

The type and height of an outlet will vary depending on  where it is placed. For example:

 l An outlet placed on a wall at the back of a base cabinet in plan view is positioned above the counter.    
 l An outlet placed on a wall at the back of a base cabinet containing a kitchen sink is placed at the standard 11 1/2" (300 

mm) above the floor.    
 l An outlet placed on the side of a cabinet or soffit will be positioned 32” (800 mm) up from that object’s bottom.    
 l An outlet placed outside the building or in an exterior area such as a deck or porch will be weatherproof.
 l An outlet placed in the central area of a room in plan view will be positioned on the floor, with one exception: 110V 

Outlets placed in Garage or Slab rooms will be positioned on the ceiling.

In camera views, 110V Outlets can be placed on ceilings in any 
room type.

LIGHT FIXTURES

Select Build> Electrical> Light to place light fixtures on walls, the ceiling, or on soffits. All light fixtures placed in 
a plan can also serve as light sources in most 3D and CPU Ray Trace views. To place a light fixture using the Light 

tool:

 l Click near a wall or the side of a soffit to place a wall-mounted fixture at that location. 
 l Click away from a wall to place a ceiling mounted light. 
 l Click inside a soffit in plan view or on its bottom surface in a camera view to place a ceiling mounted light on the 

soffit’s bottom surface.
 l Click outside a room and away from a wall to place a path light.
 l Some light symbols from the library can be mounted under wall cabinets, as well. 

The rendering characteristics of individual lights that control how they appear in    rendered and CPU Ray Trace views can be 
specified on the LIGHT DATA panel of the Electrical Service Specification dialog. See Light Data Panel on page 688.

ROPE LIGHTS

Select Build> Electrical> Rope Light, then click and drag to draw a rope light path with regularly-spaced light 
sources along its length. Rope Lights are a type of Molding Polyline so their rope profile can be customized. See 

Rope Light Specification Dialog on page 691.   

SWITCHES

Select Build> Electrical> Switch to place electrical switches on walls or on the sides of cabinets or soffits. Like 
outlets, the height of switches is measured from the floor to the center of the object.
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 l A switch placed on the side of a cabinet or soffit will be positioned 32” (800 mm) up from that object’s bottom.    
 l Switches placed outside the building or in an exterior area such as a deck or porch will be weatherproof.

If you connect two or more switches in a circuit, they update to 
3-way or 4-way switches automatically.

Switches placed from the Electrical Library do not automatically update by default, but can be specified to do so. See 
Electrical Service Specification Dialog on page 686.    

AUTO PLACE OUTLETS

Select Build> Electrical> Auto Place Outlets and click in a room tool to place outlets at regular intervals around the 
entire room. See Auto Place Outlets on page 682.

CONNECT ELECTRICAL

Select Build> Electrical> Connect Electrical, then click and drag to draw splines that snap to electrical switches, 
outlets, and lights to illustrate wiring circuits. See Creating Wiring Schematics on page 682.

LIGHTING AND ELECTRICAL LIBRARY CATALOGS

A selection of free-standing and ceiling-, wall- and cabinet-mounted light fixtures is available in the Library Browser 
at Chief Architect Core Catalogs> Architectural> Lighting. 

Special use outlets, switches, jacks and numerous other electrical items can be found at Chief Architect Core Catalogs> 
Mechanical, Electrical, Plumbing> Electrical. See Placing Library Objects on page 980. 

 

Placing Electrical Objects
Electrical switches, outlets, lights, and other symbols can be created with a single click in any view. They can also be placed 
from the Library. See Click-to-Create on page 168. 

When the Switch, Light, or an outlet tool is used, the type and height of the object that is created will vary depending on 
where it is placed. As you move your mouse pointer around the view, an object preview will display near the pointer 
whenever it is over a location where an object can be placed. Specific details for each tool are noted in The Electrical Tools 
on page 679.

The electrical objects in the Library are typically designed for a specific use and can only be placed on a wall, on the floor, 
or on the ceiling. Some are instead free-standing and are designed to be placed on a table or the floor. See Placing Library 
Objects on page 980. 

Wall mounted outlets, switches, and Library symbols can also be placed on the sides of cabinets and soffits. They will snap 
to the outside of the cabinet box or to the outside of Side or Back Panels, but will ignore doors and drawers.

When a light fixture is created using any method, including copying and pasting, it will always be turned On. This is the 
case even if the default symbol is turned Off. See Light Data Panel on page 688.

ELECTRICAL OBJECT HEIGHTS

When a wall-mounted electrical object is placed in plan view using one of the Electrical Tools, its initial height off the floor 
is based on settings in the Electrical Defaults dialog. See Electrical Defaults on page 678. 

Wall mounted electrical symbols placed directly from the Library derive their initial heights from specification settings 
saved with each object. See Electrical Service Specification Dialog on page 686.
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Similarly, cabinet-mounted electrical objects are placed using height information set in either the Electrical Defaults dialog 
or the symbol’s specification dialog. If the default height is higher or lower than the cabinet it’s being placed on, the 
electrical object will be placed along the top or bottom edge of the cabinet box. 

In 3D views, an electrical object placed on a wall in a 3D view will snap to its default height provided that the mouse 
pointer is near that height when you click. If you move the mouse pointer away from the default height, the object will be 
positioned wherever you click on the wall, regardless of the height at that point. 

 

Auto Place Outlets
Select Build> Electrical> Auto Place Outlets and click in a room to place 110 volt outlets on the walls around the 
entire room, spaced so that no wall position is farther than six feet (1800 mm) from the nearest outlet. 110 or 220 volt 

outlets are also placed behind large appliances. In addition, a light is placed above each sink. 

Outlets and sink lights are placed based on settings in the Electrical Defaults dialog. See Electrical Defaults on page 678.          

It is important that a room’s Type be defined before Auto Place Outlets is used so that outlets are placed appropriately. For 
example, GFCI Outlets  (Ground Fault Circuit Interrupter) are placed over cabinets in Kitchen, and Bath rooms.  See 

Room Types and Functions on page 420.

Auto Place Outlets               does not work in rooms assigned an exterior room type such as Deck. To place outlets in an exterior 
room, place them from the Electrical Library or use the 110V Outlet  tool.

Railings and invisible walls are ignored by Auto Place Outlets. If it is used in a room defined by railings or invisible walls, 
outlets are automatically placed in any adjacent rooms on the other side of these wall types. See Room Definition on page 
418. 

Once placed, any outlet can be moved, edited, or deleted. See Editing Electrical Objects on page 685. 

 

Creating Wiring Schematics
Electrical schematics can be created in two ways. Using the Connect Electrical  tool is quick and easy, but if you need 

detailed schematics, you can create your own wiring diagrams using the CAD tools. See CAD Objects on page 294.         

CONNECT ELECTRICAL

Select Build> Electrical> Connect Electrical, then click and drag to draw splines that snap to electrical switches, 
outlets, and lights to illustrate wiring circuits. See Splines on page 330. 

To create a new circuit or add to an existing circuit, click on a switch, outlet, or light while the Connect Electrical tool is 
active, drag to the next object and release. You can also draw electrical circuits using the Alternate  continuous drawing 

mode. See Alternate on page 209.

When a Connect Electrical spline is first drawn, it looks like an arc but actually consists of two segments that are defined 
by vertex points. When selected, its edit handles display at each of these vertices. If you click and drag one of these edit 
handles, the length, angle, and curvature of the spline will change but the other vertices will not move.
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Connect Electrical splines cannot be snapped to one another: they can only snap to electrical objects. Once drawn, though, 
additional vertices can be added and used to form complex curves. See Editing Spline-Based Objects on page 237. 

To remove a connection from a circuit, simply select and Delete  it. If you remove an electrical object from a circuit, any 

Connect Electrical splines snapped to it will also be deleted. See Deleting Objects on page 289.

THREE- AND FOUR-WAY SWITCHES

Multiple switches can control an object or group of objects. 

 l Two switches controlling the same objects are referred to as three-way switches. 
 l Three switches controlling the same objects are called four-way switches. 

In plan view, a three- or four-way switch’s “way” number will automatically display in its 2D symbol.

 

Electrical Library Content
Select View> Library Browser  to accesses a variety of electrical symbols. See The Library Browser on page 962.

Browse for electrical objects such as bath vent fans, an electrical panel, fluorescent lights, chandeliers, a smoke detector, 
thermostat, and more. Select a symbol, then click in your plan to place it on a wall, floor, or ceiling.

You can specify which electrical object in the library is used by each of the Electrical Tools. See Electrical Defaults on 
page 678.           

You can also assign electrical objects from the library to toolbar buttons for easy access and placement to frequently-used 
library objects. See Place Library Object Button on page 982.          

ADDING ELECTRICAL CONTENT

Any electrical symbol placed into a plan can be customized and added to the User Catalog in the Library Browser. See Add 
to Library on page 973.

You can also create electrical symbols and save them in the User Catalog. See Custom Symbols on page 992.           
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Displaying Electrical Objects
The display of electrical objects and connections is controlled in the Layer Display Options dialog. See Layer 
Attributes on page 181.

When displayed in 3D views, light fixtures act as sources of light that help illuminate the 3D model. See Lighting on page 
1133.

IN PLAN VIEW

In plan view, electrical objects are represented by commonly used CAD symbols that represent the type of object rather than 
its appearance in 3D. You can specify a different symbol for a selected electrical object in its Symbol Specification dialog if 
you wish. See 2D Block Panel on page 996.

Like other objects, electrical objects are placed in Drawing Groups that affect whether they display in front of or behind 
other objects in plan view. You can modify a selected  object’s place in the drawing order by clicking the View Drawing 
Group Edit Tools  edit button. See Drawing Group Edit Tools on page 195. 

By default, electrical symbols are placed on the “Electrical” layer. You can, however:           

 l Specify a different default layer for each type of object placed using the Electrical Tools by clicking the Edit button in 
the Electrical Defaults dialog. See Electrical Defaults on page 678.           

 l Specify a different layer for an individual object after it has been placed. See Layer Panel on page 191.           

Connect Electrical splines are drawn on the “Electrical, Connections” layer by default. While the default layer for these 
objects cannot be changed, you can specify a different layer for a Connect Electrical spline after it has been drawn. See Line 
Style Panel on page 310.   

ELECTRICAL LABELS

Electrical labels display in plan and cross section/elevation views when the “Electrical, Labels” layer is turned on and use 
the Text Style assigned to their layer. See Label Panel on page 712.

Customized labels              using text and Text Macros as well as label position and orientation              can be specified in the Electrical 
Service Specification dialog.              See Text Macros on page 549. 

Electrical objects can display callout labels as specified in the Electrical Schedule Specification dialog. See Label Panel on 
page 712.         

Electrical labels have their own edit handles and can be moved and rotated when the electrical object is selected.

Note: Some electrical objects are represented in plan view by a CAD 
block that includes text. This text is not part of the object’s label and 
does not use the Text Style assigned to the “Electrical, Labels” layer. 

IN THE MATERIALS LIST

Electrical objects, including outlets, switches, lights, and symbols from the library such as jacks and fans, are listed under 
the Electrical Category in the Materials List. Connect Electrical splines are 2D objects only, however, and are not 
calculated. See Materials Lists on page 1309. 
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As with other objects, there are a number of ways to control how, or whether, electrical objects are included in the Materials 
List. See Organizing Materials Lists on page 1317.           

You can add and edit information about an electrical object’s accessories and sub-accessories in specification dialog. See 
Components Panel on page 1335.           

ELECTRICAL SCHEDULES

The Electrical Schedule tool allows you to produce customizable electrical schedules as well as electrical labels that 
display schedule numbers. See The Schedule Tools on page 695.

To create an electrical legend, you can create an Electrical Schedule, customize it to include the 2D Symbol exclude most 
other columns. See General Panel on page 705.

 

Editing Electrical Objects
Electrical objects can be selected individually as well as in a group in 2D and 3D views and edited using the edit handles, 
the Edit Toolbar and their specification dialog. See Electrical Service Specification Dialog on page 686.

Electrical objects can be marquee-selected by type when the drawing tool used to create them is active. The Marquee Select 
Similar edit tool can also be used to group-select electrical objects. See Selecting Multiple Objects on page 215.

Light fixtures and Added Lights can be group-selected, but their light data cannot be edited unless each has the same 
number of light sources. See Lighting on page 1133.         

Lights can also be edited using the Adjust Lights dialog. See Adjust Lights Dialog on page 1137.         

USING THE EDIT HANDLES

The edit handles for electrical objects vary depending on the location of the object. 

 l Wall mounted electrical objects cannot be rotated, so only the Move edit handle displays.
 l Electrical objects placed on floors and ceilings can be rotated.
 l In 3D views, some ceiling mounted and free-standing light fixtures can be resized.
 l Rope Lights  are edited like open polylines. See Editing Open Polyline-Based Objects on page 226.          

 l  Electrical connections  are edited like splines. See Editing Spline-Based Objects on page 237.

IN THE SPECIFICATION DIALOGS

Electrical objects can be edited in the Electrical Service Specification dialog. See Electrical Service Specification 
Dialog on page 686.

The symbol data associated with an electrical object can be edited in the Symbol Specification dialog. See Symbol 
Specification Dialog on page 993.    

Rope Lights  are a type of Molding Polyline with options for controlling the rope profile, light spacing, and more. See 

Rope Light Specification Dialog on page 691.    
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USING THE EDIT TOOLS

A selected electrical symbol can be edited in a variety of ways using the buttons on the Edit Toolbar. See The Edit Toolbar 
on page 135.

  Change to GFCI Outlet changes a selected 110V Outlet to a GFCI Outlet, as specified in the Electrical Defaults 
dialog.

  Change to 110V Outlet changes a selected GFCI Outlet to a 110V Outlet.

  Turn Light(s) On in 3D toggles a selected light on so that it emits light in 3D views while Turn Light(s) 
Off in 3D toggles it off. See Displaying Lights on page 1136.

  Edit CAD Block allows you to edit the 2D CAD block associated with an electrical symbol. See Edit CAD 
Block on page 334.

USING DIMENSIONS

Electrical objects can be moved precisely using dimensions. See Moving Objects Using Dimensions on page 491.

By default, electrical objects are not located by dimension lines as the lines are drawn. Once created, though, you can edit a 
dimension line’s extensions to locate the center of any electrical object. See Editing Extension Lines on page 486.

In order to locate electrical objects by a dimension line as it is being drawn, first check the box beside Electrical on the 
LOCATE OBJECTS panel of the Dimension Defaults dialog. See Locate Manual Panel on page 460.    

ADJUSTING ELECTRICAL OBJECT HEIGHTS

When a wall- or cabinet-mounted electrical object is placed, its initial height is based on settings in the Electrical Defaults 
dialog. See Placing Electrical Objects on page 681.

Once placed, a wall-mounted electrical object’s height can be edited in  three ways: 

 l Specify the height in the Electrical Service Specification dialog. See General Panel on page 687.
 l In 3D views, the position of an electrical object can be adjusted using its edit handles.
 l In any view, use the Transform/Replicate Object  tool. See Transform/Replicate Object Dialog on page 269.           

DELETING ELECTRICAL OBJECTS

An electrical object can be deleted by selecting it and clicking the Delete  edit button or by pressing the Delete key.

All electrical objects in a room, on a floor, or in the entire plan can also be deleted as a group using the Delete Objects 
dialog. See Deleting Objects on page 289.

 

Electrical Service Specification Dialog
Select one or more electrical objects and click the Open Object edit button to open the Electrical Service 
Specification dialog. The settings in this dialog vary, depending on the type of objects you select. This dialog can 

also be accessed by clicking the Edit button in the Electrical Defaults dialog. See Electrical Defaults on page 678.

You can also open the specification dialog for the electrical object(s) associated with a schedule row. See Open Row Object
(s) on page 699.          

The Electrical Service Specification dialog has the following panels:

686



Chief Architect Premier X14 Reference Manual - Electrical Service Specification Dialog

GENERAL PANEL

The items on this panel vary, depending on the type of electrical object selected.

 
Name

The Name of the selected object as used in the Library Browser and Materials List displays here. 

 
Position

Specify the Position of the selected electrical object. The options available depend on the type of object selected.

 l Specify the Offset From Ceiling of a ceiling outlet or ceiling mounted light. If the light is mounted to a cabinet, this 
value is the offset from the cabinet.

 l Specify the Height to Center of a switch, wall outlet or wall light. 

 l Specify the Offset From Floor of a floor outlet or floor lamp. 

 l Specify the Distance From Wall of a wall mounted symbol. A negative value will recess the symbol into the wall 
and may prevent it from being seen in 3D. 

 
Size

Specify the Size of the selected electrical symbol. 

 l Specify the Height, Width and Depth of the selected symbol. 

 l Uncheck Retain Aspect Ratio if you would like to modify one of the above values without affecting the others. 
Doing so may cause the symbol’s shape to become distorted. This check box does not affect editing performed 
outside  this dialog and is an action rather than a state: the next time you open this dialog, it will be checked. 

 l Click the Reset button to restore the electrical symbol’s original size. 
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  Options

 l Check Reverse Symbol to reverse the object’s appearance so that features on its left are located on its right and vice 
versa. Does not affect symmetrical symbols.

 l Check Automatically Change Switch Type When Wiring for a selected switch to become a three- or four-way 
switch if your wiring plan uses it as such. This setting is not available when the dialog is accessed via the Electrical 
Defaults dialog. See Connect Electrical on page 682. 

Switches placed from the toolbar use this option by default; switches placed from the library do not. 

 l Check Include in Schedule to include the selected light fixture in electrical schedules. See Schedules and Object 
Labels on page 694.          

 
Copyright

Any Copyright information associated with the selected symbol will be stated here.

 
Preview

A preview of the selected object displays here. See Dialog Preview Panes on page 22.    

LIGHT DATA PANEL

The LIGHT DATA panel is available when the selected electrical object is a light fixture. The available options vary 
depending on the type of light selected. If multiple light fixtures with different numbers of light sources are selected, the 
settings on this panel are not available.

The settings on this panel are similar to those on the same panel of the Light Specification dialog. See Light Specification 
Dialog on page 1139.         
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Light Sources

Each fixture can have multiple Light Sources, listed here. Not available for Added Lights. See Lighting on page 1133.         

 l Select a Light Source assigned to the selected light fixture from the drop-down list. The selected light source can be 
edited using the settings on this panel.         

 l Click Add Light or Delete Light to add or delete light sources from the list. If the selected fixture has only one light 
source, Delete Light will not be available.          

  Light Characteristics

 l Select either Point Light or Spot Light as the light Source Type. The Type determines which options are enabled 
below. See Light Types on page 1135.          

 l Select an Intensity from the drop-down list. The available options are described using lumens and correspond to 
commonly used light bulb wattages. You can also use the text box or spin controls to make fine adjustments to the 
Intensity value. When a non-standard value is specified, the Intensity is described as “Custom Lumens”.          

 l Click the Color bar to define the color of the selected light source. Colored lights alter the appearance of textures 
and can be used to achieve special effects. See Color Chooser/Select Color Dialog on page 204.          

The default color of light is pure white, which has the least 
effect on the appearance of material colors and textures.

The Angle and Drop Off Rate settings below are only available for Spot Lights.          

 l The Tilt Angle controls the angle of the illumination with respect to the horizon. A value of -90° points the light 
straight down and a value of 90° points it straight up. 0° is parallel to the horizon.         

 l The Direction Angle defines the direction of the illumination relative to the ground. 0° is measured horizontally 
pointing to the right. Positive values rotate in a counter-clockwise direction from there. Enter a value up to 360°. If 
you enter a negative value, the program adds 360° to it when you click OK or press the Tab key.         

 l The Cut Off Angle controls the angle of the cone of illumination for Spot Lights only. A cone angle of 180° 
creates a spot light that shines in a half sphere on one side of the light source. A small cone angle, for example 
10°, creates a very narrow cone of light.          

 l The Drop Off Rate affects how fast a Spot Light’s intensity drops off from the center of the cone to the outside 
edge. 

A value of 0 produces a cone of light with the same intensity from the center to the outside edge and a sharp 
distinction between lit areas within the cone and unlit areas outside it. As this value is increased, the light intensity 
decreases closer to the edge of the cone and the distinction between lit and unlit areas becomes softer. Only 
available for Spot Lights.

 
Soft Shadows (CPU Ray Tracing)

These settings affect the selected light source in CPU Ray Trace views only. See CPU Ray Tracing on page 1163.     

 l Check Soft Shadows (CPU Ray Tracing) to have the selected Point Light source cast soft shadows in CPU Ray 
Trace views. Not active for Spot Light sources.           

 l Specify the Light Diameter, which is how big the source of illumination appears in CPU Ray Trace views.            
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Offset

The Offset settings control the location of the selected Light Source relative to the fixture.         

 l From Base controls how far the light source is from the fixture base. The fixture base is determined by the surface 
that it is attached to (i.e. wall, floor, or ceiling).             

 l X Position and Y Position allow you to position the light source relative to the center of the fixture, along the 
floor/ceiling.             

 
Options

Additional Options that affect how the selected light source behaves are available.         

 l Select Use in Camera View to turn the selected light source on in regular 3D views only.           

 l Select Use in CPU Ray Tracing to turn the selected light source on in CPU Ray Trace views only.           

 l Select Use in Both to turn the selected light source on in both camera and CPU Ray Trace views.           

Note: Some fixtures may have four or five lights for use in CPU Ray 
Trace views but only one in rendered views. See 3D Rendering on 
page 1129. 

 l When multiple lights are selected, and they are set to be used in different types of views, No Change will be 
available. Leave this option selected unless you want the lights to all be used in the same types of views.           

 l The On check box’s label is followed by the name of a Light Set because each light source’s On status is saved on 
a per Light Set basis rather than with the light. When this dialog is opened in plan view, the light’s status in the 
Default Light Set will be used. If it is opened in a camera view, its status in the Light Set that is active that view 
will be used. See Light Sets on page 1136.          

 l Casts Shadows controls whether or not the selected light source casts shadows in camera and CPU Ray Trace 
views. See Shadows on page 1130.

 l Check Show Position in Camera View to indicate the position of a selected Point or Spot Light source in the 
preview pane and in              all 3D views              aside from Line Drawing renderings when it is turned On. This tool can be 
used to determine if your light source is positioned correctly. See In 3D Views on page 1136.         

 
Preview

A preview of the selected object displays here. The selected light source’s Position in Camera View will display in all views 
except Plan View if the light source is On. See Dialog Preview Panes on page 22.         

LAYER PANEL

The LAYER panel is found in the specification dialogs for a variety of objects, including electrical objects. For more 
information, see Layer Panel on page 191.          

MATERIALS PANEL

The MATERIALS panel is found in the specification dialogs for a variety of objects. For more information, see Materials 
Panel on page 1055.

690



Chief Architect Premier X14 Reference Manual - Rope Light Specification Dialog

LABEL PANEL

Labels for electrical fixtures display in plan view and cross section/elevation views when the “Electrical, Labels” layer is 
turned on and use the Text Style assigned to that layer. See Electrical Labels on page 684.         

For information about the settings on this panel, see              Label Panel on page 712.         

Note: If you choose a label shape in the Electrical Schedule Specification 
dialog, the settings here are overridden and the schedule label is used 
instead. See Labels Panel on page 709.

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 1335.          

OBJECT INFORMATION PANEL

The information entered on the OBJECT INFORMATION panel can be used in schedules and the materials list. For more 
information, see Object Information Panel on page 1336.   

SCHEDULE PANEL

The settings on the SCHEDULE panel determine which schedule categories the selected room is included in. See Schedule 
Panel on page 716.          

 

Rope Light Specification Dialog
Select a Rope Light and click the Open Object edit button to open the Rope Light Specification dialog. 

The settings in this dialog are also found in the Rope Light Defaults dialog. See Electrical Defaults on page 678.

The Rope Light Specification dialog has the following panels:

GENERAL PANEL
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  Elevation

 l Select the Elevation Reference from the drop-down list. This determines where the next setting is measured from, 
and also affects its setting label.            

 l Specify the Height of the rope light, measured from the Elevation Reference to the top of the rope profile.          

 
Light Spacing

Specify the Distance Between Lights, measured from the centers of the light sources. 

  Plan View Display

 l Check Show Lights to represent the light sources as circles inside the rope path. When unchecked, only the path is 
shown.          

 l Specify the Light Display Size, which is the diameter of the circles representing the light sources in plan view.           

 
Preview

A preview of the selected rope light displays here. The selected light source’s Position in Camera View will display in all 
views but Plan View if the light source is On. See Dialog Preview Panes on page 22. 

LIGHT DATA PANEL

The settings on the LIGHT DATA panel are also found on the same panel of the Electrical Service Specification dialog. See 
Light Data Panel on page 688.          

POLYLINE PANEL

The POLYLINE panel states the Length of an open polyline, and the Perimeter and Area of a closed polyline. See Polyline 
Panel on page 323.          

SELECTED LINE/ARC PANEL

The SELECTED LINE panel is available when the selected segment of the Rope Molding polyline is a line as opposed to an 
arc. See Line Panel on page 309.          

The SELECTED ARC panel is available when the selected segment of the polyline has been converted into an arc. See Arc 
Panel on page 318.          

See, too, Selected Edge on page 214 and Change Line/Arc on page 259.          

MOLDINGS PANEL

The MOLDINGS panel is found in dialogs throughout the program. Here, its settings allow you to specify a rope profile. See 
Moldings / Profiles Panels on page 943.           

LAYER PANEL

The LAYER panel is found in the specification dialogs for a variety of objects, including electrical objects. For more 
information, see Layer Panel on page 191.          
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MATERIALS PANEL

The MATERIALS panel is found in the specification dialogs for a variety of objects. For more information, see Materials 
Panel on page 1055.          

LABEL PANEL

Labels for electrical fixtures display in plan view and cross section/elevation views when the “Electrical, Labels” layer is 
turned on and use the Text Style assigned to that layer. See Electrical Labels on page 684.           

For information about the settings on this panel, see Label Panel on page 712.          

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 1335.          

OBJECT INFORMATION PANEL

The information entered on the OBJECT INFORMATION panel can be used in Electrical Schedules and the materials list. See 
Object Information Panel on page 1336.          

SCHEDULE PANEL

The settings on the SCHEDULE panel determine which schedule categories the selected rope light is included in. See 
Schedule Panel on page 716.          
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Chapter 19
 

Schedules and Object Labels

A schedule is similar to a simple Text object with grid lines separating rows and columns, but are dynamically linked to 
objects in your plan and automatically update whenever an object is created, deleted, moved, or altered.

Schedules are available for doors, windows, cabinets, fixtures, framing objects, furniture, electrical items, plants, and the 
contents of rooms. You can also create custom schedules with a combination of these categories as well as create custom 
categories. Each schedule can contain information for one or all floors of your plan.

Schedules are highly customizable, so you should check each schedule that you create to be sure it presents the information 
that you want it to.         

A variety of objects in Chief Architect have labels that display information about them in plan and cross section/elevation 
views. Some of those objects also have schedules associated with them and may display schedule callout labels.         

TOPICS

Schedule Defaults 695
The Schedule Tools 695
Create Schedule from Room 696
Schedule Categories 697
Editing Schedules 698
Schedule Numbering 700
Columns to Include 701
Custom Object Fields 702
Find Object in Plan 703
Working with Multiple Schedules 704
Schedule Specification Dialog 704
Object Labels 711
Label Panel 712
Schedule Panel 716
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Schedule Defaults
The initial settings for each type of schedule can be set in its Schedule Defaults dialog. Default Settings are accessed 
by selecting Edit> Default Settings. Click the “+” next to Schedules to display the schedule sub-headings. Select a 

subheading and click the Edit button to open the Schedule Defaults dialog associated with your selection. See Default 
Settings on page 76. 

Schedule defaults can also be accessed by double-clicking the Schedule Tools  parent button or any of the child tools.

When a schedule is created, its initial characteristics are determined by the settings in the Schedule Defaults dialog for its 
schedule type. Default settings for callout schedule labels are also set here.

Each Schedule Defaults dialog looks the same as its corresponding Schedule Specification dialog. See Schedule 
Specification Dialog on page 704. 

 

The Schedule Tools
Different types of schedules and tables can be created in plan and layout files for a variety of purposes.

All schedules present in a file are listed in the Project Browser. See Project Browser on page 58. 

PLAN SCHEDULES

In plan view, a cross section/elevation view, or a CAD Detail window, select Tools> Schedules to access the 
Schedule Tools. Select a Schedule Tool, then click in the view to place a schedule of the selected type at that 

location. You can continue clicking to place additional copies of the schedule if you wish. See Click-to-Create on page 168.

While you can place schedules in plan view, you may find it helpful to place them in one or more CAD Detail windows 
instead. This allows you to send schedules to layout without including extra data or needing to resize the layout view box. 
See CAD Details on page 340. 

 
Cabinet Schedules on page 640

 
Door Schedules on page 558

 
Electrical Schedules on page 685

 
Fixture and Furnishing Schedules on page 991

 
Framing Schedules on page 897

 
Fixture and Furnishing Schedules on page 991

 
Notes, Note Types, and Note Schedules on page 542

 
Plant Schedules on page 1301

 
Room Finish Schedules on page 453

 
Wall Schedules on page 369
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Window Schedules on page 596

 
Custom Schedule Categories on page 697

ROOM SCHEDULES

Select a room and click the Create Schedule from Room edit button to create a schedule of that type showing only 
contents of the room. See Create Schedule from Room on page 696. 

CUSTOM SCHEDULE CATEGORIES

Select Tools> Schedules> Manage Custom Categories to create, rename, and delete custom schedule categories in 
the current plan file. See Schedule Categories on page 697. 

LAYOUT SCHEDULES

In addition to the Schedule Tools available in plan files, there are two that can be used in layout. See Layout Page and 
Revision Tables on page 1366. 

  Select Tools> Layout> Layout Page Table, then click to create a Layout Page Table. 

  Select Tools> Layout> Layout Revision Schedule, then click to create a Layout Revision Schedule.

 

Create Schedule from Room
Select a room and click the Create Schedule from Room edit button to create a schedule showing only objects of a 
particular type in the room. You can also turn any schedule into a Room Schedule using the Include Objects from 

Room setting in the Schedule Specification dialog. See General Panel on page 705.

An object will be listed in a schedule if its center point is located inside the room. All objects associated with a Distribution 
Path or Region will be listed in a schedule if the center point of the path or region is located inside the room. If the center 
point of the path or region is not located in the room, none of its objects will be listed. See Distributed Objects on page 
1043. 

Select a Schedule Type, then click OK and click in the drawing area to create a schedule of the selected type that lists 
objects located in the room that you selected.
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Schedule Categories
Chief Architect has a set of system schedule categories that correspond to the types of objects that can be included in a 
schedule. Examples of these object types include:

 l The object types created by the program’s Cabinet and Electrical Tools.
 l The various Door and Window Types.
 l Fixture and Furniture symbol Types.
 l The various types of framing members.
 l Millwork, Molding, and Roof Trim
 l Wall Types
 l Room Types
 l Note Types
 l CAD polylines
 l Plants and Sprinklers each have a single system category.
 l Architectural Blocks in legacy plans may be included in an “Other” category. 

You can find a complete list of categories and specify which is included in a given schedule in its specification dialog. See 
General Panel on page 705.

You can also assign any object that can be listed in a schedule to one or more of these categories. See Schedule Panel on 
page 716.

CUSTOM SCHEDULE CATEGORIES

When the system categories do not meet your needs, you can use Custom Schedule Categories to include an object or group 
of specific objects in the schedule(s) of your choice regardless of their actual object type. For example: 

 l To include a glass door along with windows in a glazing schedule.
 l To include a dishwasher in a cabinet schedule. 

To use a Custom Schedule Category, first create it; then assign one or more objects in your plan to that category; and 
finally, set one or more schedules to include that category. 

To create and use a custom category
 1.  Select  Tools> Schedules> Manage Custom Schedule Categories . 

 2.  In the Manage Custom Schedule Categories dialog, click the New button and type a short, descriptive name for your 
new category. 

 3.  Select an object that you would like to assign to your new custom category and click the Open Object  edit 

button.

 4.  On the SCHEDULE panel of the object’s specification dialog, under the Categories to Include heading, check the box 
to the left of the new category’s name. See Schedule Panel on page 716.

 5.  Create a schedule and open its specification dialog. On the GENERAL panel, check the box to the left of the new 
category’s name. See General Panel on page 705.
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 6.  When the custom category is for objects that insert into other objects, you may wish to specify a custom label in the 
containing object’s specification dialog. 

MANAGE CUSTOM SCHEDULE CATEGORIES DIALOG

To open the Manage Custom Schedule Categories dialog, select Tools> Schedules> Manage Custom Categories. You can 
also access this dialog via Default Settings :  click the “+” next to “Schedules” to display the schedule sub-headings, 

then select “Custom Schedule Categories” and click the Edit button. 

 

Editing Schedules
Schedules can be edited using the edit handles, the Edit Toolbar buttons, and the Schedule Specification dialog. 

USING THE EDIT HANDLES

A selected schedule has edit handles similar to those of a CAD box. See Editing Box-Based Objects on page 234. 

In addition, schedules have edit handles that let you control the order of the rows and columns, as well as column width. 
Simple Text  objects with tabbed contents also have these handles: 

 l Resize Column edit handles are located in the Title row, centered on the grid lines that divide the columns, and can be 
dragged left or right. If a column is resized sufficiently small, the text within will wrap to multiple rows. 

 l Move Column edit handles are located in the Heading row, centered in each cell, and can be dragged left or right. 
 l Move Row edit handles are located in the first column, centered in each cell, and can be dragged up or down.  See 

Editing Schedule Order on page 700.

The behavior of edit handles may depend on the currently active 
Edit Behavior. See Defaults, Preferences, and Edit Behaviors on 

page 208.

By default, the objects listed in the selected schedule are arranged in rows and information about them is presented in 
columns. You can Swap Rows/Columns to instead list objects in columns and information about those objects, in rows. See 
General Panel on page 705.

IN THE SPECIFICATION DIALOG

The contents, Text Styles, and other attributes of schedules can be modified in the Schedule Specification dialog. See 
Schedule Specification Dialog on page 704.

You can control how objects are listed in a  schedule by specifying which Columns to Include. For example, if you were to 
include "Flower Color" but exclude “Common Names” and “Scientific Names” in the Schedule Specification dialog, the 
resulting plant schedule would list all red flowers in one line item, regardless of their species. See Columns to Include on 
page 701.
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You can also control the appearance of the callout labels associated with objects listed in a schedule. See Object Labels on 
page 711.

USING THE EDIT TOOLS

A schedule can be edited in a variety of ways using the buttons on the Edit Toolbar. See The Edit Toolbar on page 135.

The Align Left, Align Right , Center , or Justify  edit tools allow you to specify how the contents of schedule 

columns are aligned. See Aligning Text on page 522.

The Spell Check  edit tool checks the spelling of the selected schedule's title and column headers. Information about 

objects reported in the schedule body, however, is not checked. See Spell Check on page 526.   

OPEN ROW OBJECT(S)

Click the Open Row Object(s) edit button to open the specification dialog of the object or objects associated with 
the currently selected schedule row. See Specification Dialogs on page 21. 

Depending on the objects associated with the row, some settings may be reported as “No Change”, and some may not be 
available to edit.

In some instances, this edit button may not be available: for example, if identical rooms on separate floors are associated 
with the same row of a Room Finish Schedule.

CONVERTING SCHEDULES TO TEXT

Click the Schedule to Text edit button to convert the selected schedule to a tabbed text object. You can then edit the 
schedule as text. 

When a schedule is converted to text, it no longer updates automatically. In addition, shaped labels displaying as specified 
in the schedule’s specification dialog will no longer be present. 

You can copy the text from the Text Specification dialog and 
paste it into other applications.

EXPORT TEXT

A selected schedule can be exported into one of several different file formats that can be opened by various programs. 
Select an individual schedule and click the Export Text edit button to open the Export Text dialog. 
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File Type

Specify the File Type that you would like to export to.         

 l Select Tab Delimited (TXT) to create a text file with a tab between each field entry in the Materials List, and a 
carriage return between each row.   

 l Select Comma Delimited (CSV) to create a text file with a comma between each field entry in the Materials List 
and a carriage return between each row.   

 l Select Spreadsheet (XML) to create a file that can be opened by Microsoft Excel.   

   

Options

 l Uncheck Include Schedule Title to prevent the schedule's Main Title from being exported.   

 l Uncheck Include Column Headers to prevent column headings from appearing in the first row of the exported file. 

 l Check Include Totals Row to export the "Totals" row from schedules that report door, window, or room finish 
information. See Columns to Include on page 701.     

 l Check Open in Default Spreadsheet Editor to open the exported file with the default program specified on our 
computer for that file type when you finish exporting.    

When you click OK, the Write Export File dialog will open. This is a typical File Save dialog. See Exporting Files on page 
41.

 

Schedule Numbering
By default, schedule numbering is dependent on the order in which objects are placed in the plan, as well as the floor they 
are on. 

 l Any objects present in your plan before a schedule is created will be listed first in ascending alphanumeric order, 
according to their Label information.

 l A new, unique objects placed in the plan after the schedule is created will be added to the bottom of the schedule in 
the order that they are placed, regardless of its Label information.

When an object is edited, its schedule number may or may not change: 

 l If an object with a Quantity of 1 in the schedule is edited, its position in the schedule will not change.
 l If a group of objects listed on the same row in a schedule are edited simultaneously, their position will not change.
 l If an object listed on the same row in a schedule with other similar objects is edited so that it is no longer similar 

enough to share the same row, it will move to the bottom of the schedule. See Columns and Quantity on page 701.

EDITING SCHEDULE ORDER

If a schedule’s order does not meet your needs, you can change it in either of two ways: 

 l Using the schedule’s Move Row edit handles. See Using the Edit Handles on page 698.
 l Using an object’s Move Up in Schedule and Move Down in Schedule edit tools. 

When an item in a schedule is moved to a different row, its schedule Number will change, as will that of any other item 
whose position is affected by that move. 
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When a given object is included in only one schedule, its position in that schedule can be modified using the  
Move Up in Schedule and Move Down in Schedule edit tools.

RENUMBER SCHEDULE

To remove any gaps in numbering that might have been created when objects were edited or deleted, select the 
schedule and click the Renumber Schedule edit button. 

SCHEDULE NUMBER FORMAT

The numbering for each schedule begins with 1 by default, and schedule number formatting includes a leading zero along 
with an optional prefix. You can choose a different Prefix, Schedule Number Start, and omit the leading zero if you wish in 
the Schedule Specification dialog. See Labels Panel on page 709. 

You can specify that an object’s Schedule Number be included as part of its Automatic Label in its specification dialog. See 
Label Panel on page 712. 

The Schedule Number can also be inserted into an object’s Label or Object Information fields using the %schedule_
number% text macro. Alternatively, you can use the %simple_schedule_number% macro, which excludes the leading zero 
and prefix and simply reports the number. See Text Macros on page 549. 

 

Columns to Include
Every schedule has a selection of Columns to Include in its specification dialog. The columns that are available depend on 
the type of schedule selected. See General Panel on page 705.

Information in the Code, Comment, Description, Manufacturer, and Supplier columns is drawn from an object’s 
specification dialog. See Object Information Panel on page 1336.

Schedules also have a selection of Categories to Include, as well. For example, you can specify whether to include 
Plumbing, Appliances, and HVAC in a Fixture Schedule. Categories can be used to create a variety of special purpose 
schedules. See Working with Multiple Schedules on page 704.

Note: Cabinet, Electrical, Fixture, and Furniture Schedules have an 
"Other" Objects to Include option that refers to architectural blocks set to 
be included in that schedule type. See Architectural Block Specification 
Dialog on page 1011. 

COLUMNS AND QUANTITY

It is important to remember that the columns you choose to include in a schedule can influence the number of separate line 
items that will be listed in the schedule. 

For example, if you have three 30” wide doors and do not include the "Size" and "Description" columns, the three doors 
will be listed in the same line item - even if one is a hinged door, one a slider and one a pocket door. 

If you prefer, you can uncheck Group Similar Objects in the Schedule Specification dialog to place every object in its own 
row, regardless of any shared attributes. See General Panel on page 705. 

Note: The object preview columns do not affect whether or not objects 
are grouped in the same line.
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COLUMN AND ROW TOTALS

If a Door, Window, or Room Finish Schedule includes an Area column, an additional “Totals” row will display at the 
bottom of the schedule for total area calculations. Room Finish Schedules will also include a “Totals” row if multiple rooms 
included in the schedule have identical objects in them.

In addition, the "Total Length" column is available in schedules set to include wall types, moldings, or roof trim.

OBJECT PREVIEWS

Aside from those for Framing, Rooms, and Layouts, schedules have a selection of Columns that display object preview 
images. 

With the exception of plant images, 3D object previews are drawn using plot lines. Each object preview inherits its line 
color, weight, and style from the object’s layer settings in the “Camera View Set” layer set.  See Layer Sets on page 186. 

The 2D Symbol preview uses the settings for the layer set that is currently active in plan view. The 2D Symbol column is 
not available for Doors, Windows, or Cabinets.

CUSTOM COLUMNS

In all schedules aside from Framing and Room Finish Schedules, there are two ways to create custom columns: by creating 
custom Sub Categories in the Preferences dialog and by creating Custom Fields. See Custom Object Fields on page 702.   

Custom Sub Categories are assigned to an object on the COMPONENTS panel of its specification dialog. To make an object in 
a custom Sub Category available for use in other plans, add it to the library. See Adding Library Content on page 973.         

Objects with Custom Fields can also be added to the library. In addition, Custom Fields are plan-specific and can be 
specified in many objects’ specification and defaults dialogs. See Custom Object Fields on page 702.         

Both Sub Categories and Custom Fields are listed as columns in the Schedule Specification dialog. See General Panel on 
page 705.         

 

Custom Object Fields
Custom Object Fields allow you to create custom columns in schedules as well as specify the data that goes into those 
columns for each object. 

Custom Fields can be assigned to a wide variety of objects in their specification dialogs. A value for each Custom Field can 
also be specified for individual objects, as well. See Object Information Panel on page 1336. 

MANAGE CUSTOM FIELDS DIALOG

To open the Manage Custom Fields dialog, select Edit> Default Settings  and click the arrow next to “Schedules” to 

expand the category. Select “Custom Object Fields” and click the Edit button.
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 l A list of Custom Fields present in the current plan displays on the left. Click on the name of a field in the list to select 
it.

 l Click the New button to open the Add New Field dialog, type a short descriptive name, and create a new Custom Field 
 l Click the Rename button to rename the selected Custom Field.
 l Click the Delete button to delete the selected Custom Field from the current plan. A Custom Field can be deleted from 

a plan even if it is assigned to an object and included as a schedule column. 

 

Find Object in Plan
To find out where a line item in a schedule or the Materials List is located in the model, select its row or any cell in 
its row and click the Find Object in Plan edit button. This tool opens a view window and selects the object or 

objects associated with that line item. 

If a plan view showing the floor that the object is on is open, that view will become active and the object will be selected. If 
no such view is open, a new unsaved view showing the object’s floor will be created. See View Windows on page 149. 

When a wall framing object is selected in a Framing Schedule, the Wall Detail of its parent wall will open instead. See In 
Wall Detail Views on page 896.

If the selected item is a component of a complex object like an Auto Dormer, Mulled Unit, Bay Window, or Architectural 
Block, the parent object will be selected in the plan instead of the individual component. 

If the selected row or rows in a Materials List refer to objects on different floors, the Details dialog will open when you 
click the Find Object in Plan  edit button. See Details Dialog on page 1319.

SELECT LOCATION DIALOG

The Select Location dialog will open if you click the Find Object in Plan  edit button when the selected line item in a 

Materials List or the selected row in a schedule refers to objects located on more than one floor. 

Select a floor in the list and click the Find button or double-click on a floor in the list to open a plan view window showing 
the objects on the selected floor. 
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Working with Multiple Schedules
You can create multiple versions of any type of schedule for a variety of purposes. For example:

 l Multiple Fixture Schedules can be set up for use as Plumbing, Appliance or HVAC schedules.
 l Separate Electrical Schedules can be created for light fixtures and other electrical items. 
 l Separate Cabinet Schedules can be set up for each floor of a plan, or even for individual rooms.
 l Special Door or Window Schedules can be prepared for Energy Ratings, Fire Doors or other information.

You can also specify that any object be listed in multiple schedule categories, as well as create custom schedules that list 
multiple types of objects. See Custom Schedule Categories on page 697. 

If you intend to use schedule callout labels, it is best to avoid including a given object in more than one schedule. If you 
choose to do so, the object will display a separate callout label for each schedule it is included in. 

If you create multiple schedules of the same type, bear in mind that it is possible for different objects in those schedules to 
be assigned the same callout number. To avoid this, consider specifying different callout prefixes and/or callout shapes. 

 

Schedule Specification Dialog
Schedules and the object labels associated with them can be edited in the Schedule Specification dialog. To open this 
dialog, either select a schedule and click the Open Object edit button or double-click the schedule using the Select 

Objects  tool.    

The Schedule Specification dialog is similar to the specification dialogs for layout tables. See Layout Page and Revision 
Tables on page 1366.

The options in these dialogs are also similar to those found in their corresponding Schedule Defaults dialogs. 

The Schedule Specification dialog has the following panels:          
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GENERAL PANEL

  Main Title

 l Specify a Main Title for the selected schedule.         

 l Check Display to include the Main Title at the top of the schedule.         
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  Include Options

 l To create a schedule of objects on a single floor, uncheck Include Objects from All Floors and then specify the 
floor. When this box is checked, objects from all floors are included. Not available in the Layout Table Specification 
dialog.

 l If Include Objects on All Floors is unchecked in the Schedule Defaults dialog, each schedule will include objects 
on the floor that it is created on by default.          

 l When Include Objects from All Floors is unchecked, you can further limit the schedule to an individual room on the 
specified floor. Select that room from the Include Objects from Room drop-down list. See Create Schedule from 
Room on page 696.         

 l When a Framing Schedule is placed in a Wall Detail or Truss Detail, the Only Include Objects from this Detail 
check box is available. Uncheck this to include objects from throughout the plan. When checked, only objects 
present in the current view are listed.         

 l Uncheck Group Similar Objects to list all objects in their own row, even when they share all attributes. When this 
is checked, objects that share the same attributes are counted in a single row. See Columns to Include on page 701.         

 l If the selected schedule is a layout table, specify the Minimum Rows that it displays, regardless of its actual content.          

 
Categories to Include

Check the box beside each type of object you want to include in the selected schedule. See Schedule Categories on page 
697.             

 l Custom Note Types, Room Types, and Wall Types will be listed here, under their respective headings. By default, 
Room and Wall Schedules include newly created Room and Wall Types automatically, while Note Schedules do not.          

 l Click the New Custom Category button to new custom schedule category. See Custom Schedule Categories on 
page 697.         

You can create multiple unique schedules using Categories and 
Columns to Include as filters. See Working with Multiple 

Schedules on page 704.
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Columns

Specify which columns are included in the selected schedule.  See Columns to Include on page 701.         

 l An alphabetical list of Available Columns displays on the left.    

 l When Limit to Included Categories is checked, the Available Columns will only list the columns that are available 
for the Categories selected above. Uncheck this box to list the columns available for all Categories. See Columns to 
Include on page 701.    

 l Select one or more names in the list of Available Columns, then click the Add button to add them to the Columns 
to Include list on the right. See Shift and Ctrl Select on page 217.    

 l You can also double-click on an item in the list to add it to the Columns to Include list on the right.

 l A list of the Columns to Include in the selected schedule displays on the right. The top-to bottom order in this list 
corresponds to the columns’ left-to-right order in the schedule. At least one column must be included to create a 
schedule.

 l Select or double-click on an item in the list and click the Rename button to specify a new name.    

 l Click the Reset button to restore the default names for all Columns to Include in the current schedule.

 l Select one or more items in the list, then click the Remove button to remove those items from the list.    

 l Select one item in the list and click the Move Up button to adjust its position upward in the list.    

 l Select one item in the list and click the Move Down button to adjust its position downward in the list.

  Display Options

 l Uncheck Display Column Headings to hide the selected schedule’s Heading row. When this is checked, each 
column has a heading at the top.

 l Uncheck Display Totals Row to suppress the bottom row stating the total area for all objects in the selected 
schedule. Only available in schedules set to include Door, Window, or Room categories, and only when one or more 
“Area” columns are included.

 l When Swap Rows/Columns is checked, the objects listed in the selected schedule are arranged in rows and 
information about them is presented in columns. Uncheck this box to instead list objects in columns and information 
about those objects, in rows.
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Object Preview Options

These options affect the appearance of previews in the 2D Symbol, 3D Elevation, and 3D Perspective Columns, when 
included in the schedule. See Object Previews on page 702.         

 l Check Show Color to draw 3D Elevation and 3D Perspective object previews using colored lines. When this is 
unchecked, lines are black and 3D plant previews are shown in grayscale.    

 l Check Scale Images to display object previews at the same relative scale. When unchecked, each preview fills its 
cell to the extent possible.    

 l In Electrical, Fixture, Furniture, Note, Plant, and Wall Schedules, check Use Plan View Scale to apply the same 
scale used in plan view to the 2D Symbol column.    

 l Check Show Opening Indicators to show opening indicator symbols in 3D Elevation previews for doors, windows, 
and cabinets. Only available in schedules set to include Door, Window, and/or Cabinet categories.    

 l Check Show Casing, Lintel, Sill to include these items in 3D Elevations and 3D Perspectives for doors and 
windows. Only available in schedules set to include Door and/or Window categories.    

 l Check Show Treatments, Shutters to include these items in 3D Elevations and 3D Perspectives for doors and 
windows. Only available in schedules set to include Door and/or Window categories.

ATTRIBUTES PANEL

 
Box/Grid

Specify the appearance of the selected schedule’s border and grid.          

 l Check Display Border to display lines around the outside of the schedule.

 l Check Display Grid Lines to display lines around the rows and columns of schedule, forming boxes around each 
item, or cell.

 
Alignment

Specify the selected schedule’s text alignment within its columns by choosing an option from the drop-down list.          
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Position

Define the position of the selected schedule. Not available in the Schedule Defaults dialogs.          

 l Specify the X and Y Positions of the schedule’s center point.

 l Specify the schedule’s Angle.

 
Margins

Specify the Left, Right, Top,  and Bottom Margins, which define the distance between the text and border of each schedule 
cell.          

LINE STYLE PANEL

The LINE STYLE panel is found in the specification dialogs for many different objects. For information about the settings on 
this panel, see Line Style Panel on page 310.         

FILL STYLE PANEL

The FILL STYLE panel is found in the specification dialogs for many different objects. For information about the settings on 
this panel, see Fill Styles on page 197.          

TEXT STYLE PANELS

The Schedule Specification dialog has three Text Style panels with settings that control the appearance of the selected 
schedule's text: 

 l MAIN TEXT STYLE controls the text style used in the body of the schedule
 l TITLE TEXT STYLE controls the text style used in the schedule's title
 l HEADER TEXT STYLE controls the text style used in the schedule's column headers.

For information about the settings on these panels, see Text Style Panel on page 547.          

LABELS PANEL

The LABELS panel of the Schedule Specification dialog controls the type, size and appearance of the labels that display in 
plan view.          
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  Specify which type(s) of label objects in the selected schedule use.      

 l Select Use Both Callout and Label for objects listed in the schedule to display both regular labels and schedule 
callouts.      

 l Select Use Callout for objects to display schedule callouts but not their regular labels.      

 l Select Use Label for objects to display only their regular labels and no callouts. See Label Panel on page 712.

  Label Text

 l Schedule Number Prefix - Specify the leading characters used in callout labels or when Include Schedule Number 
is checked in the object’s specification dialog. See Label Panel on page 712.    

 l Schedule labels usually start with the number 1, but you can select a different Schedule Start Number if you wish.    

 l When Include Leading Zeroes is checked, single-digit callout labels include a zero in front of the callout number. 
Uncheck this box to remove these leading zeroes from the labels.

 
Callout Shape

When either Use Both Callout and Label or Use Callout is selected above, the callout shape can be selected here. There 
are ten shapes to choose from.    
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  Size/Orientation

 l Uncheck Automatic to enable the Size field and specify a new value. When checked, the callout is sized so that it 
encompasses the Label Text that displays inside its shape.    

 l Specify the Shape Angle.    

 l Specify the Text Angle relative to the orientation of the callout shape. Not available when Ellipse, Capsule, or 
Rectangle is selected as the Callout Shape.    

 l When Automatic is checked, the Text Angle automatically matches the Shape Angle.    

 
Callout Layer

Specify the layer that the callouts associated with the selected schedule are placed on. See Layers on page 180.      

 l Select Use Object Label Layer to place each callout on the layer specified for that object's label.    

 l Select Use Object Layer to place the object's label on the same layer as the selected schedule. The name of this 
layer is reported here in parentheses for reference.    

 l Select Use Custom Layer to select any layer saved in the current file from the drop-down list.    

 l When Use Custom Layer is selected, you can click the Define button to open the Layer Display Options dialog and 
select, modify, or add a new layer. See Layer Display Options Dialog on page 183.    

Like other object labels, callout labels use the Text Style assigned to the layer they are on. See Text Styles on page 547.

 

Object Labels
Object labels can display in plan and cross section/elevation views for a variety of different object types using one of several 
formats: 

 l Automatic Labels provide basic information about the object, such as its type, size, or name.
 l You can create a custom label for an object in its specification dialog using text and/or Text Macros. See Label Panel 

on page 712.
 l Objects associated with a schedule can display a shaped callout label with each object’s schedule number instead of or 

in addition to their regular object label. See Schedule Specification Dialog on page 704.

Object labels have their own edit handles that display when their object is selected, and can be both moved and rotated 
using edit handles as well as settings in the object's specification dialog. Schedule callout labels can be moved in the same 
manner but can only be rotated using settings in the Schedule Specification dialog. When an object has both label types 
displaying, they share a single Move handle and can only be rotated using settings in the object specification dialog and 
Schedule Specification dialog. See and Labels Panel on page 709 and Edit Handles on page 23.

AUTOMATIC LABELS

Most objects that can display labels have an Automatic Label created by the program that states basic information about it. 

 l Native objects such as doors, windows, and cabinets dynamically derive their automatic label from their size and type. 
See Native Objects vs Symbols on page 986. 

 l Symbol objects such as fixtures and furnishings derive their automatic label from the Symbol Name specified in the 
Symbol Specification dialog. See 3D Panel on page 993.

When Automatic Label is selected in the object’s specification dialog, this is usually the label that will be used; however:
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 l If a user-defined label is specified in the object’s defaults dialog, that label will be used instead of the Automatic 
Label.

 l If the object is included in a schedule and callout labels are specified in that schedule, a callout label will be used. 
 l Fixtures and appliances inserted into cabinets do not have labels of their own unless they are associated with a 

schedule set to use shaped callout labels.

DEFAULT LABEL FORMATTING

Custom labels can include a variety of macros that report size information about the object. This information can be 
reported in either of two ways:

 l Default Formatting includes the unit of measurement after each macro reporting size information. In files using US 
Units, sizes are described using fractional inches with up to 1/16” accuracy.

 l When Default Formatting is not used, units of measurement are not shown and decimal inches are used. 

You can specify whether to Use Default Formatting in the object’s specification dialog. See Label Panel on page 712.

DISPLAYING LABELS

The display of object labels in plan and cross section/elevation views can be controlled by layer in the Layer Display 
Options dialog. System Default label layer names begin with the object type, followed by the word Label: for 

example, cabinet labels are located on the “Cabinets, Labels” layer. See Layer Display Options Dialog on page 183.

You can choose to place an object's label on a different layer if you wish, as well as suppress the label for an individual 
object on the LABEL panel of its specification dialog. This setting does not affect schedule callouts. See Label Panel on page 
712.

Object labels use the Text Style assigned to each label’s layer. For example, cabinet labels are placed on the “Cabinets, 
Labels” layer by default and use the Text Style assigned to that layer. The callouts associated with a schedule also use the 
Text Style associated with the layer they are placed on. See Text Styles on page 547. 

With the exception of those for rooms, roofs, and cameras, labels can also be included in the Materials List and Master List. 
Items in the Labels column of the Materials List are editable; however, any changes will not be applied to the actual objects’ 
labels. See Materials List Columns on page 1322. 

The minimum on-screen display size of labels can be specified in the Preferences dialog. See Appearance Panel on page 99.

 

Label Panel
The LABEL panel is found in the specification and defaults dialogs for a variety of different objects. The settings that 
are available will vary depending on the type of object that is selected.

Note: If you choose a callout shape in the Schedule Specification dialog, 
the settings here are overridden and the schedule label is used instead. 
See Labels Panel on page 709.

712



Chief Architect Premier X14 Reference Manual - Label Panel

 
Suppress Label

Most objects have this option; however, Bay, Box, and Bow Windows and Mulled Units instead have several settings for 
controlling Multiple Component labels. See Window Labels on page 596.     

 l Check Suppress Label to prevent the selected object’s label from displaying in plan and cross section-elevation 
views. This option does not affect the display of schedule callouts. See Object Labels on page 711.

For Bay, Box and Bow Windows and Mulled Window units:

 l Select Suppress All Labels to display no label in plan view. Individual components are counted in schedules and in 
the Materials List.     

 l Select Show Component Labels to produce labels for each component in plan view. Individual components are 
counted in schedules and in the Materials List.     

 l Select Show Single Label for Entire Unit to produce one label for the unit and suppress component labels. When 
this option is selected, the settings that follow on the LABEL panel become enabled.     

 l These settings also affect how Bay, Box and Bow Windows and Mulled Window units are counted in schedules and 
the Materials List. See Window Labels on page 596 and Displaying Mulled Units on page 592.
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Label Options

Specify the information reported in the label. Not available for cameras. See Displaying 3D Views on page 1096.

 l Select Automatic Labels to use the default label for the selected object. See Automatic Labels on page 711.

The Height/Width Display settings are only available for doors and windows.

 l Select Width/Height to use a numeric format in which the width in inches (mm) is followed by the height.    

 l Select Height/Width to use a numeric format in which the height in inches (mm) is followed by the width.    

 l Select Width Only to use a numeric format in which only the width in inches (mm) is indicated.    

The Additional Text options add extra information to the Automatic Label as well as any schedules that the selected 
object is listed in. See Columns to Include on page 701.    

 l Check Include Schedule Number to include the object’s Schedule Number at the beginning of its Automatic Label 
text, as well as in the Label and Size columns of any schedule that it is listed in. See Schedule Number Format on 
page 701.    

 l For a selected window, check Include Type to include the abbreviation for each window’s type in its Automatic 
Label. For example, 3050DH describes a 3050 double hung window. This also affects the Label column of any 
schedule the window is listed in.    

 l For a selected door, check Include Type to include the hinge side and whether each door is interior or exterior in the 
Size column of any schedule that the door is listed in. This also affects the Label column of the schedule, but does 
not affect the door’s Automatic Label itself.

An alternative to displaying Type information in the Label 
and/or Size columns is to include the Type column in a 

schedule. See Columns to Include on page 701.    

 l Select Specify Label to replace the selected object’s Automatic Label with whatever you type in the text field 
below. Press the Enter key while the cursor is in the text field to begin a new line. When Specify Label is chosen, 
the text of the selected object’s Automatic Label initially populates the text field.    

 l Click the Insert Macro  button to insert a Global, User Defined or Object Specific Text Macro into the custom 

label. See Text Macros on page 549.    

 l Only available for layout boxes, select Use Callout to replace the regular text label with a callout shape. Click the 
Edit button to specify the callout's attributes, including macros that report information about the view, in the Callout 
Specification dialog. See Callout Specification Dialog on page 535.    

 l Only available for layout boxes, select Use Marker to replace the regular text label with a marker. Click the Edit 
button to specify the marker's attributes, including macros that report information about the view, in the Marker 
Specification dialog. See Marker Specification Dialog on page 540.    
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 l Specify whether to Use Default Formatting for any inserted macros that report size information. See Default Label 
Formatting on page 712.    

 l Check Display Border to turn on the display of a border polyline around the selected object's label.    

 l Select an Alignment option from the drop-down list to apply to the selected object's label text.

 l When Auto Adjust Text Direction is checked, label text is oriented relative to the bottom or the right side of the 
view window, depending on the object's angle. When unchecked, label text is oriented relative to the object's front 
edge or interior side, regardless of the object's angle.

 
Position and Orientation

In plan files, these settings affect a selected object's label in either all plan views or the currently active cross 
section/elevation view. The defaults for these settings only affect plan views - in other types of views, labels are always 
initially placed at 0, 0, 0°. See Default Settings on page 76. 

Note: The type of view that is currently active is noted at the 
beginning of this heading label: Plan View, Camera View, Wall 
Detail, or CAD Detail. If an architectural object's specification dialog 
is accessed using the Open Row Object(s) edit tool in a CAD Detail, 
the Plan View settings will be available. See Open Row Object(s) on 
page 699.

 l Specify the X Offset value, moves the label side to side relative to the midpoint of the object’s front face.    

 l Specify the Y Offset value, which moves the label forward or backward relative to the object’s front face.    

 l Specify the Angle, which rotates the label either relative to the angle of its object’s front face or to an absolute angle.
    

 l Select Relative Angle to measure the label’s Angle relative to its object’s front face.    

 l Select Absolute Angle to measure the label’s Angle relative to an imaginary horizontal line drawn in the positive X 
direction from the origin. See 3D Drafting on page 12.    

 l Regardless of which way the selected object is facing, in plan view the X Offset will move the label parallel with the 
object’s front face. The Y Offset value will move the label perpendicular to the object’s front.  

 l In cross section/elevation views, the Offset X will move the label side to side and the Offset Y will move it up or 
down.

 l Specify the Reference, which is the point on the selected object from which the X and Y Offset are measured from. 
Only available for layout boxes and, in plan view only, for cabinets, symbol objects, and architectural blocks.

 
Camera View Display

These settings are only active if you open an object’s specification dialog in a cross section/elevation view, and only affect 
the display of the selected object’s label in the current view. Not available for cameras or layout boxes.     

 l Select Automatic to display the object’s label when the surface at its center point is visible in the view.

 l Select Show in this View to display the object’s label regardless of whether its center point is visible.

 l Select Hide in this View to suppress the object’s label regardless of whether its center point is visible.
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Label Layer

Specify which layer the object's label is placed on. See Layers on page 180. 

 l Select Use System Layer to place the object's label on the system default layer for the selected object type's labels. 
The name of this layer is reported here in parentheses for reference. 

 l Select Use Object Layer to place the object's label on the same layer as the object itself. The name of this layer is 
reported here in parentheses for reference.

 l Select Use Custom Layer to select any layer saved in the current file from the drop-down list. 

 l When Use Custom Layer is selected, you can click the Define button to open the Layer Display Options dialog and 
select, modify, or add a new layer. See Layer Display Options Dialog on page 183.

 
Preview

In most specification dialogs, a preview of the selected object displays here. In the preview pane, labels can be seen in Plan 
View only. Only the regular object label is shown: even when the object has a schedule callout label. See Dialog Preview 
Panes on page 22. 

 

Schedule Panel
The SCHEDULE panel is found in the specification and defaults dialogs for a variety of different objects. The settings 
on this panel let you assign the selected object to one or more schedule categories. See Schedule Categories on page 

697. 

The settings on this panel are not active in for architectural blocks unless Treat as One Object is checked in the 
Architectural Block Specification dialog. See General Panel on page 1012.

 l Check Include in Schedule to list the selected object in any schedule that includes its Schedule Category. 
 l Select Auto Schedule Category to assign the selected object to a schedule category based on its type. 
 l Select Include in Schedule As to enable the settings that follow and assign the selected object to one or more 

categories in the list.

In the list of schedule categories:

 l Click the arrow to the left of a heading to expand it and see the categories listed under it, or to collapse it again.
 l Check the box beside a category to list the selected object in any schedule set to include that category.
 l Heading level items often have a check box with a solid fill, indicating that some items listed under it are checked 

while others are not. If you click to check the box, all items under the heading will become selected; if you click again 
to clear the box, no items under it will be selected. 

 l The “Custom” heading will not be available to select if no Custom Schedule Categories have been created.
 l Click the New Custom Category button to open the New Custom Category dialog. Type a short, descriptive name 

and click OK to have the new category display in the list under the “Custom” heading. See Custom Schedule 
Categories on page 697.
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Chapter 20
 

Foundations

There are three foundation types in Chief Architect Premier: stem walls with footings, grade beams on piers, and monolithic 
slab. All three can be generated automatically or manually. The foundation type can be specified in the Foundation Defaults 
dialog when the foundation is built on Floor 0. 

There can be only one foundation level in a plan, Floor 0; however, foundation structures can be drawn on any floor using 
the Foundation and Slab Tools.          

Always consult registered geotechnical and civil engineers for 
information regarding the proper foundation for your site. 

TOPICS

Foundation Defaults 718
Foundation Defaults Dialog 718
Building a Foundation 722
Displaying Foundations 723
Editing Foundations 725
Deleting Foundations 728
Foundations and Rooms 728
Foundations and the Terrain 730
The Slab Tools 731
Editing Slabs 732
Slab Specification Dialog 732
Editing Piers and Pads 735
Pier/Pad Specification Dialog 735
Fireplaces 736
Fireplace Specification Dialog 738
Library Fireplaces 741
Chimneys 741
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Foundation Defaults
There are several defaults dialogs that affect the foundation. They can be accessed by selecting Edit> Default 
Settings.

In the Default Settings dialog, select “Foundation” and click the Edit button to open the Foundation Defaults dialog.

If a foundation has been built, it will have a Floor 0 Defaults dialog. The structural settings in this dialog are initially drawn 
from those in the Foundation Defaults dialog.  See Floor Defaults Dialog on page 744.         

The Foundation Wall Defaults and Slab Footing Defaults dialogs control the default setup of Foundation Walls and Slab 
Footings. See Wall, Railing, and Fencing Defaults on page 346.    

The default attributes for Slabs and Slabs with Footings can be set in the Slab Defaults dialogs. See The Slab Tools on page 
731.

The default attributes for Post footings can be set in the Framing Defaults/Build Framing dialog. See Build Framing Dialog 
on page 873.

 

Foundation Defaults Dialog
The Foundation Defaults dialog allows you to specify stem wall height, slab thickness, sill plates, and other  
characteristics of an automatically-generated foundation. These values determine how a new foundation is generated 

as well as the sizes for manually drawn foundation walls added to an existing foundation. Select Edit> Default Settings, 
and in the Default Settings dialog, select "Foundation" and click the Edit button.

The settings in the Foundation Defaults dialog are similar to those in the Build Foundation dialog, which opens when 
Build> Floor> Build Foundation  is selected. The primary difference is that when you click OK in the Foundation 

Defaults dialog, no changes are made to the model. See Building a Foundation on page 722.
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FOUNDATION PANEL

 
Automatically Rebuild Foundation

Check Auto Rebuild Foundation to automatically rebuild the foundation whenever changes are made to Floor 1 that affect 
the structure of the foundation. See Rebuilding Foundations on page 725.
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Foundation Type

Three different Foundation Types can be created in Chief Architect. Each type of foundation has different default settings, 
options, and behaviors. Select the radio button next to the desired type.         

 l Select Walls with Footings to produce a foundation composed of stem walls with footings that run continuously 
under the base of the walls.         

 l Select Grade Beams on Piers to generate a pier and grade beam foundation. The floor framing rests directly on top 
of the grade beams.         

 l Select Monolithic Slab to build a slab foundation defined by Slab Footings. The foundation forms the floor platform 
for Floor 1. It is visible on Floor 0 and can be selected and edited. See Foundation Walls on page 355.

 l Check Hang 1st Floor Platform Inside Foundation Walls to produce stem walls that build up to the top of the 
floor platform of Floor 1. When unchecked, the stem walls build to the bottom of the floor platform, which bears on 
top of them. Only available when Walls with Footings is selected, above.         

 l Check Show “S” Markers on Step Foundation to include an “S” symbol in plan view anywhere there is a step in 
foundation wall height. Not available when Grade Beams on Piers is selected, above. See Displaying Foundations on 
page 723.

  Slab

 l The name of the Default Slab Footing Wall Type displays here for reference. Click the Edit Default Slab Footing 
button to open the Wall Type Definitions dialog and change the definition of the default wall type. Only available 
when Monolithic Slab is the selected Foundation Type.         

 l Specify the Slab Thickness, which is the thickness of the slab produced above the footing or at the top of the stem 
wall.         

 l Check Slab at top of Stem Wall to raise the slab so its top is flush with the top of the stem walls. Only available 
when Walls with Footings is the selected Foundation Type.
If Slab at top of Stem Wall is selected, all rooms on the first floor are automatically set to Floor Supplied by the 
Foundation Room Below in the Room Specification dialog. See Structure Panel on page 444.

  Stem Walls

 l The name of the Default Foundation Wall Type displays here for reference.         

 l Click the Edit Default Foundation Wall button to open the Foundation Wall Defaults dialog and change the default 
settings for foundation walls. See Foundation Walls on page 355.

 l If Monolithic Slab is the selected Foundation Type, the Edit Garage Curb button will be available. Click it to open 
the Foundation Wall Defaults dialog and define the walls that form curbs around Garage and Slab rooms.         

 l Specify the Minimum Height, which is the minimum height for foundation stem walls and grade beams and 
includes the sill plates.         

 l The Basement Ceiling Height displays here as a reference. This is the distance from the top of the slab floor to the 
basement ceiling and is equal to the Minimum Wall Height minus the Slab Thickness. 

If the Minimum Wall Height is at least 76” (1900 mm), a Ceiling Finish is added to the foundation room 
automatically. A slab floor is also generated above the footing. The ceiling height and finish can be changed later. 
To remove this slab, specify the room areas in the basement as “Open Below”. See Room Specification Dialog on 
page 442.
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Piers

These settings are only available when Grade Beams on Piers is the selected Foundation Type.         

 l Specify the Width, Depth, and Maximum Separation of the piers.         

 l Choose either Round or Square piers.         

 
Garage Options

These settings only apply to rooms defined as Garages. See Garages on page 728.                 

 l Specify the Garage Floor to Stem Wall Top, which is the distance between the slab and the tops of the stem walls 
in both Garage and Slab rooms. Available for Walls with Footings and Grade Beams on Piers foundation types. See 
Foundation Defaults on page 718.

Note: The Garage Floor to Stem Wall Top setting only affects 
Garage rooms that have a Floor Height of 0. See Structure Panel on 
page 444. 

 l Specify the Lower Garage Floor height, which is the distance that Garage and Slab room floors are lowered when a 
Monolithic Slab foundation is  built. This value is also the height of the curbs around these rooms. 

 l Specify the Minimum Garage Height, which is the minimum height that stem walls defining a Garage foundation 
will be, regardless of the Minimum Stem Wall Height for the rest of the foundation.         

OPTIONS PANEL

The OPTIONS panel allows you to include rebar and other materials related to the foundation in the Materials List. See 
Materials Lists on page 1309.

Some options on this panel may be unavailable depending on the foundation type selected on the FOUNDATION panel.         
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Rebar

Specify the Rebar used in the major foundation components: Footing, Wall Horizontal courses, Wall Vertical courses, 
Pier, and Slab. Rebar and mesh are calculated in the Materials List provided that the wall or footing they are associated 
with is the “Concrete” Structure Type; but, they do not display in any 2D or 3D views of the model. See The Materials List 
Tools on page 1310.

 l Bars per Course - Specify the number of bars of rebar to be used per course for each foundation component.         

 l Course Spacing - Define the spacing for Vertical and Horizontal Wall courses, and for Slabs. If slabs are to have 
rebar instead of mesh, this spacing value applies to both directions.         

 l Rebar size - Define the rebar size in 1/8th inches. 4 represents 4/8, or 1/2 inch.         

 l Specify the Overlap where sticks of rebar meet, in terms of the rebar’s Diameter. A value of 40.0, for example, 
equals 40 times the Rebar Size.         

 l Check Use Mesh to reinforce the slab floor with mesh instead of rebar, or uncheck it to use rebar.         

 
Foundation Options

Select either Foam Seal, Termite Flashing, or both. These options are added to the Materials List, but do not display in the 
model.         

 

Building a Foundation
Foundations can be generated automatically or drawn manually. A combination of the two methods can also be used.         

Three foundation types are available: stem walls with footings, grade beams on piers, and monolithic slabs. The first two 
options are created using walls; the last creates concrete slabs with footings.

Automatically built foundations are placed on Floor 0 and are based on wall positions and floor heights on Floor 1. 
Foundation walls or slab footings are generated under:

 l All exterior walls on Floor 1 that define a room other than a Deck type room. See Room Definition on page 418.
 l Any Railings, Invisible Walls, and interior walls on Floor 1 that have Create Wall/Footing Below checked in the 

Wall Specification dialog. See Foundation Panel on page 405.           
 l Any interior walls on Floor 1 defining rooms with different floor heights. See Floor and Ceiling Heights on page 431. 

At least one room must be defined on Floor 1 for a foundation to be automatically generated. If no rooms are defined on 
Floor 1, a blank Floor 0 is created. 

There can be only one Floor 0 per plan. If your plan requires a foundation on more than one floor, you will need to draw the 
required foundation walls or slabs yourself.         

To build an automatic foundation
 1.  Specify the desired floor heights for the rooms on Floor 1: particularly Porch and Garage rooms.

 2.  Select Build> Floor> Build Foundation . 

 3.  Specify the desired foundation type and other information in the Build Foundation dialog. The settings in this dialog 
are similar to those in the Foundation Defaults dialog. See Foundation Defaults Dialog on page 718.

 4.  In the New Floor dialog, select Derive new Foundation plan from the 1st floor plan and click OK to build a 
foundation based on Floor 1.
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If you prefer, you can instead select Make new (blank) plan for the Foundation to create an empty foundation level where 
you can manually draw foundation walls or slabs.

In most cases, it is preferable to base Floor 0 off the first floor plan and then manually edit the foundation as needed. See 
Editing Foundations on page 725.

FOUNDATION WALL ALIGNMENT

By default, foundation walls and slab footings will align with walls on the floor above along the outside surface of the Main 
Layer of both wall types.     If you prefer, you can specify that foundation walls align to a different part of the walls above. 
See Aligning Walls on page 378.

MIXING FOUNDATION TYPES

You can also create a foundation that combines stem walls, grade beams and piers, and/or monolithic slabs.

To create a foundation of multiple types
 1.  Begin by specifying any rooms on Floor 1 that require a slab floor as either a Garage or Slab Room Type. See 

Foundations and Rooms on page 728.

 2.  Alternatively, or in addition, you can specify any rooms on Floor 1 as having a Monolithic Slab Foundation. See 
Structure Panel on page 444.          

 3.  Build Foundation , as described above.   

 l If the foundation will include any grade beams and piers, specify Grade Beams on Piers as the Foundation 
Type and build the foundation.          

 l If the foundation will include a combination of stem walls and slabs, specify Walls with Footings as the 
Foundation Type.          

 4.  Once the foundation walls have been generated, they can be moved or deleted, and new Foundation Walls , Slab 

Footings , and/or Slabs  can be drawn. See Foundation Walls on page 355 and The Slab Tools on page 731.         

OPENINGS IN FOUNDATION WALLS

Any doors placed in walls around a Garage will receive cutouts in the garage stem wall or curb. The width of that cutout 
can be specified in the Door Specification dialog. See General Panel on page 566.          

 

Displaying Foundations
The objects associated with foundations can be displayed in a variety of ways in Chief Architect.

FOUNDATION LAYERS

The display of foundation walls, slabs, curbs, piers and footings is controlled in the  Layer Display Options dialog. 
See Layer Display Options Dialog on page 183. 

 l Foundation Walls, including grade beams, Slab Footings and Garage curbs, are placed on the “Walls, Foundation” 
layer by default.
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 l Footings under Slab Footings and Foundation Walls are placed on the “Footings” layer by default, as are foundation 
piers. 

 l Post footings and deck post footings are placed on the “Footings, Post” and “Footings, Deck Post” layers by default.
 l Slabs created using the Slab Tools  are placed on the “Slabs, Custom” layer by default.         

 l Wall labels and slab labels are placed on the “Walls, Labels” and “Polylines 3D, Labels” layers, respectively.          
 l In stem wall and grade beam foundations, brick ledge lines in plan view are on the “Slabs” layer; in monolithic slab 

foundations, they are on the “Walls, Foundation” layer. See Brick Ledges on page 356.
 l The “Foundations” layer controls the display of all objects on Floor 0 in 3D views but does not affect plan view. 

IN PLAN VIEW

The appearance of foundation wall types, including line weights, colors and fill styles, is specified in the Wall Type 
Definitions dialog. See Wall Type Definitions Dialog on page 390.         

The fill style for wall footings can be set in the Wall Specification dialog, while footing line style is controlled by the 
"Footings" layer. You can place footings on a custom layer if you wish. See Foundation Panel on page 405.

Changes in stem wall and monolithic slab foundation heights are represented in plan view with S markers. These markers 
are located on the “Footings, Step Markers” layer and use the Text Style assigned to that layer. See Stepped Foundations on 
page 731.          

If a door on Floor 1 extends into a stem wall or curb defining a Garage room, its location will be indicated on Floor 0. See 
Displaying Doors on page 556.

WALL AND SLAB LABELS

Foundation walls and Slabs can both display labels when the “Walls, Labels” and “Polylines 3D, Labels” layers are on. 
Unlike some objects, walls and slabs have blank Automatic Labels; however, you can specify a custom label in their 
specification dialogs. See Wall Specification Dialog on page 395 and Slab Specification Dialog on page 732.    

Wall and Slab labels display in floor plan and cross section/elevation views when their respective layer is turned on and use 
the Text Style assigned to that layer. See Label Panel on page 712.    

IN 3D VIEWS

In 3D views, all objects on Floor 0 will only display when the “Foundation” layer is turned on. 

While the display of foundation walls and their footings can be controlled independent of one another in plan view, in 3D 
views this is not the case. If a foundation wall is set to display, its footing will as well - even if the “Footings” layer is 
turned off. The reverse is also true - if a foundation wall’s display is turned off, so will its footing’s.

The display of monolithic slab foundations in 3D views is controlled by the “Foundation” layer. Slab Footings  are 

located on the “Walls, Foundation” layer; but if this layer is turned off, any Slab Footings  that define a foundation 

room will continue to display as long as the “Foundation” layer is on. 

IN CROSS SECTIONS

When the Auto Detail  tool is used in a cross section view, the fill style of each wall layer as set in its Wall Type 

Definition is used. See Auto Detail on page 1095.          

Foundation wall footings and Slabs  use a concrete fill that cannot be specified beforehand but can be edited once Auto 

Detail has been generated.           
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Monolithic slabs and their footings use the fill style specified for the slab room’s Floor Structure definition. See Floor and 
Ceiling Platform Definitions on page 434.           

IN THE MATERIALS LIST

The materials that make up foundation walls, footings, and slab floors are listed under the Foundation category in the 
Materials List, including:          

 l Concrete for walls, slabs, and footings
 l Rebar for walls and footings
 l Rebar or mesh for slabs

Slab Footings and the room areas that they define can be assigned Pour Numbers in their specification dialogs. Typically, a 
Slab Footing will have the same Pour Number as the room it defines, although it is possible for it to define multiple rooms 
with differing Pour Numbers. Pour Numbers are listed separately under the Foundation category of the Materials List. See 
Foundation Panel on page 405 and Structure Panel on page 444.          

Other objects relevant to foundations can be found in these categories:          

 l Exterior Trim - Lists slabs drawn with the Slab  tools that are located outside a structure.          

 l Interior Trim - Lists slabs drawn with the Slab  tools that are located inside a structure.          

See Materials Lists on page 1309.           

IN SCHEDULES

Foundation walls, Round Piers/Square Pads, Slabs, as well as holes in Slabs, can be included in schedules. See The Schedule 
Tools on page 695.

Foundation walls are listed in the "Walls" category by default; Piers and Pads are listed in the "Piers/Pads" category; and 
Slabs and Slab Holes are listed in the "Slabs" category. You can, however, assign a selected object to the category of your 
choice in its specification dialog. See Schedule Panel on page 716.

 

Editing Foundations
Stem wall with footings, wall with piers and monolithic slab foundations are all created using walls which enclose room 
areas.

 l Foundation walls can be selected and edited much like other walls. See Editing Walls on page 372.
 l Footing size can be changed on a wall by wall basis. See Footing Width and Height on page 727.           
 l Foundation rooms can also be selected and edited like other rooms. See Foundations and Rooms on page 728.

REBUILDING FOUNDATIONS

By default, foundations do not update automatically when changes are made to the structure on Floor 1. For example, if 
exterior walls are moved or floor platforms are raised or lowered, the foundation must be rebuilt.

You can direct the program to rebuild an automatically generated foundation whenever changes are made on Floor 1 that 
affect the foundation by checking Auto Rebuild Foundation in the Foundation Defaults dialog. See Foundation Defaults 
on page 718.          
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You can also rebuild an automatically generated foundation by selecting Build> Floor> Build Foundation  from the 

menu. 

When Auto Rebuild Foundation is enabled, walls cannot be edited, manually drawn or deleted on Floor 0. When the 
foundation is rebuilt, any manually drawn or edited walls are deleted. Similarly, rooms on Floor 0 cannot be edited while 
this option is enabled. If you try to draw a wall or edit a room or a wall while Auto Rebuild Foundation is turned on, a 
warning message will display.         

CHANGING FOUNDATION TYPES

When a foundation is generated, the program creates Floor Defaults settings for Floor 0 based on the information in the 
Build Foundation dialog. If you specify a Monolithic Slab foundation, the default Floor Structure on Floor 1 will also be 
changed to a slab rather than a framed platform. See Floor Defaults Dialog on page 744.   

 

To avoid unexpected results, it is recommended that you not 
change the Foundation Type once the foundation is built.

STEM WALL HEIGHT

When a foundation is created, all of Floor 0 uses the stem wall height specified in the Foundation Defaults dialog, 

This height is measured from the bottom of floor platform of Floor 1 to top of the stem walls’ footings. If Floor 1 has 
multiple floor platform heights, the foundation stem walls will be stepped.

Once a foundation is created, stem wall heights can be adjusted either on a room-by-room basis or for individual walls.

To change a room’s stem wall height
 1.  Select a room on Floor 0 and click the Open Object  edit button. 

 2.  Specify the desired Stem Wall Height in the Room Specification dialog. See General Panel on page 443.

 3.  If you wish to reduce the Stem Wall Height, you will first need to reduce the Ceiling Height value by the same 
amount. 

If adjacent rooms have stem wall heights that differ by at least 1/16 of an inch, the stem wall separating them uses the larger 
of these two values.

In 3D views, individual stem walls can be selected and edited. In most cases, this method should only be used for stepping 
the bottom of the foundation wall. See Stepped Walls and Footings on page 384.           
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FOOTING WIDTH AND HEIGHT

Foundation Wall footings derive their Width, Height, and Offset from in the Foundation Wall Defaults dialog, Similarly, 
Slab Footings use the width and height specified in the Slab Footing Defaults dialog. Once a Foundation Wall or Slab 
Footing is created, its footing can be adjusted in its specification dialog. See Foundation Panel on page 405.

Footing Width can be adjusted using the edit handles in both floor plan and 3D views. Each side of the footing can be edited 
independently, which means that the Offset can also be modified using the footing resize edit handles.           

If the selected wall is a Slab Footing, the footing width can also be resized using dimensions and will resize the Wall 
Thickness, creating a new wall type if necessary. See Editing Walls on page 372.           

Stem wall footing heights can also be edited in 3D views just as the rest of the stem wall can. Slab               Footing heights, on the 
other hand, cannot be adjusted in 3D. See Stepped and Raked Walls on page 384.

You can specify whether stepped stem walls have vertical footings on the FOUNDATION panel of the Foundation Wall 
Defaults and Specification dialogs.               You can also specify the chamfer width and height of monolithic slab foundation 
footings. 

INTERIOR FOOTINGS

Slab foundations often have interior footings: to support posts, for example. You can specify that an interior footing be 
created under an interior wall on Floor 1 when the foundation is built by checking Create Wall/Footing Below. See 
Foundation Panel on page 405.

You can also draw interior footings using the Slab Footing  tool. See Foundation Walls on page 355.

If an interior footing is inside a room with a slab foundation and a curb, as in a garage, specify the Slab Footing  as 

Invisible to prevent a curb from generating inside the room. See Room Dividers and Invisible Walls on page 358.          

THICKENED SLABS

A thickened slab can be created by selecting a Slab Footing  and specifying its Chamfer Height to equal the Footing 

Height. The Chamfer Width can be increased, as well.           

 l When the Slab Footing is drawn on the interior of a slab room, a thickened slab is created.           
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 l When the Slab Footing defines the edge of a slab, a thickened slab edge results.           

You can also specify the Chamfer Height and Width before the Slab Footings are created in the Slab Footing Defaults 
dialog. See Foundation Panel on page 405.           

 

Deleting Foundations
Select Build> Floor> Delete Foundation to delete the entire foundation floor. 

You can also select and delete individual foundation walls and slabs by clicking the Delete  edit button or pressing the 

Delete key. See Deleting Objects on page 289.

Deleting and rebuilding the foundation is often the quickest way to update the model when substantial changes are made to 
Floor 1 after the foundation is built.

 

Foundations and Rooms
When a foundation plan is created, rooms included in the Living Area calculation generate a stem wall, grade beam, or slab 
foundation below them. Garage rooms generate slab foundations, but exterior rooms such as Decks, Courts and Balconies 
do not generate any foundation. See Room Types and Functions on page 420. 

Interior foundation walls are not generated unless:

 l They separate the area under a Slab or Garage room from the rest of the plan;
 l They separate the area under a room specified as having a slab foundation from the rest of the plan;         
 l They define areas under rooms with different floor heights.
 l A wall on Floor 1 is specified as a Bearing Wall in the Wall Specification dialog. See Foundation Panel on page 405.

         

Note: To remove all or part of the concrete slab in the basement area, 
select a basement room and define it as Open Below in the Room 
Specification dialog.

GARAGES

When a foundation is generated based on the floor plan of Floor 1, a room on the first floor specified as either a Garage or 
Slab type will receive a stem wall or pier foundation with a slab floor and stem walls. If a monolithic slab foundation is 
generated, the room will receive a slab floor with curbs.
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An opening placed in a wall defining a Garage will receive a cutout in the stem wall or curb that displays in plan view on 
the floor below provided that the stem wall or curb’s Main Layer has a Concrete or Brick material type.           

The width of the concrete cutout can be defined and you can specify whether the cutout displays in the Door or Window 
Specification dialog. See Framing Panel on page 579.           

By default, a room on Floor 1 specified as a Garage or a Slab will be assigned a lower floor height when the foundation is 
built. The amount that it is lowered depends on the foundation type:

 l The floor height will drop the default thickness of the floor platform for Floor 1 plus 12” (300 mm) in a Walls with 
Footings or Grade Beams on Piers foundation.

 l The floor height will drop 3 1/2” (88 mm) in a Monolithic Slab foundation. 

These values are set in the Foundation Defaults dialog. See Foundation Defaults on page 718.           

To build a Garage slab with stem walls
 1.  Before the foundation is generated, specify the room as a Garage or Slab. 

 2.  Build an automatic Wall with Footings or Grade Beam on Piers foundation.

In the Floor 1 Garage’s Room Specification dialog, Floor Supplied by the Foundation Room Below will now be checked. 
See Structure Panel on page 444.          

By default, the program produces a  4" (100 mm) slab and 24” (600 mm) high stem walls around the garage. These stem 
walls are drawn on Floor 0 and will indicate the locations of any doors that extend into them.           

To build a Garage slab with curbs
 1.  Before the foundation is generated, specify the room as a Garage or Slab. 

 2.  Build an automatic Monolithic Slab foundation, specifying the required Lower Garage Floor value.

By default, the program produces a  4" (100 mm) slab and 3 1/2” (88 mm) high curb around the garage. The curbs are drawn 
using Slab Footings on Floor 0, use the Default Foundation Wall type, and will indicate the locations of any doors that 
extend into them.         

The floor height of the garage and the stem wall or curb height can then be adjusted, if necessary, in the Garage room’s 
Room Specification dialog. See Structure Panel on page 444.         

BASEMENT ROOMS

When a foundation’s type is Walls with Footings or Grade Beams on Piers, and it is assigned a Basement Ceiling Height of 
48" (1200 mm) or greater, the resulting basement is automatically included in the Living Area calculation. It does not, 
however, have a floor or ceiling finish.

When a foundation is assigned a Basement Ceiling Height of 72" (1800 mm) or greater, the resulting basement is 
automatically created with a 4” (100 mm) concrete slab floor and a default Floor Finish like that on Floor 1. Similarly, it is 
automatically given a painted drywall Ceiling Finish. See  Foundation Defaults on page 718.   

Regardless of its ceiling height, however, you can specify a floor or ceiling finish for any room in the Room Specification 
dialog. See Structure Panel on page 444.

The resulting basement can be divided into separate rooms using Interior Walls  or any wall type you wish. If the rooms 

in a basement have different floor heights, it is best to separate them using walls specified as Foundation Walls .
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Foundations and the Terrain
Chief Architect automatically raises the structure in a plan a set distance above the terrain. See Terrain Height vs Floor 
Height on page 1251.         

In a plan with a foundation present, the terrain will be:          

 l 6” (187 mm) below the top of the stem walls or grade beams in a Walls with Footings or Grade Beams on Piers 
foundation.    

 l 8” (200 mm) below the top of the slab in a Monolithic Slab foundation.             

By default, the program will also create a flattened pad under the building footprint.         

Not all foundations have these requirements, of course, so you can customize your foundation and terrain to suit your needs.
         

DAYLIGHT BASEMENTS

Daylight basements, also referred to as look-out basements, have walls that are tall enough for basement windows to be 
positioned above the terrain. They are often found in split level or split entry structures.         

To create a daylight basement condition,  build a stem wall foundation and modify these settings in the Terrain Specification 
dialog:          

 l Uncheck Auto Calculate Elevation.             
 l Increase the Building Pad Elevation, which is the distance between the default floor height of Floor 1 and the terrain.              

WALKOUT BASEMENTS

Walkout basements are a type of daylight basement typically located on sloped terrain. They feature walls that are above 
ground at the lower end of the slope so that a door can be positioned above the terrain at that end.          

To create a walkout basement, build a stem wall foundation and modify these settings in the Terrain Specification dialog:          

 l Uncheck Flatten Pad.             
 l Uncheck Auto Calculate Elevation.             

You will also need to create sloped terrain and adjust the Building Pad Elevation and/or terrain data so that the terrain is at 
the appropriate height relative to the structure at both the high and low ends of the slope.         
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STEPPED FOUNDATIONS

Stepped foundations are usually built on sloping terrain. A stepped foundation will be produced automatically if more than 
one floor height is present on Floor 1 when the foundation is built. 

In plan view, steps in stem wall and monolithic slab foundations are represented using S markers. See Displaying 
Foundations on page 723.          

As with a walkout basement, you will need to build a stem wall foundation and modify these settings in the Terrain 
Specification dialog:          

 l Uncheck Flatten Pad.             
 l Uncheck Auto Calculate Elevation.             

You will also need to create sloped terrain and adjust the Building Pad Elevation and/or terrain data so that the terrain is at 
the appropriate height relative to the structure at both the high and low ends of the slope.         

You can also create a stepped foundation by editing foundation rooms and walls. See Stem Wall Height on page 726.

 

The Slab Tools
Select Build> Slab to access the Slab Tools.         

SLABS

Select Build> Slab> Slab or Slab With Footing, then either click or click and drag a rectangle to draw a slab. 
The Slab Tools are intended for generic purposes than foundations and should not be substituted for a 

foundation plan. See Rectangular Polyline on page 325.         

A newly drawn Slab or Slab With Footing inherits the settings in the Slab Defaults or Slab with Footing Defaults dialog. 
Once created, slabs can be edited like other closed polylines. See Editing Slabs on page 732.         

A slab is also created when the Post with Footing  tool is used. See Post with Footing on page 871.         

SLAB HOLES

A hole can be placed in a slab or in the floor of a foundation slab with footings. Select Build> Slab> Slab 
Hole or Build> Slab> Slab Hole With Footing, then either click or click and drag within an existing slab to 

create a hole.         

You can also create a Slab Hole in a Slab, or a Slab Hole with Footing in a Slab with Footing, using the Create Hole  

edit tool. See Polyline Holes on page 234.         

PIERS AND PADS

Piers and pads can be manually placed under walls, railings, or beams on any floor. Select Build> Slab> 
Round Pier or Build> Slab> Square Pad and click in plan view to place a pier or pad.         

For information about editing Round Piers and Square Pads, see Editing Piers and Pads on page 735.         
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EDITING SLABS AND PIERS/PADS

Once created, slabs and Slab Holes can be selected in 2D and 3D views both individually and as a group and can be edited 
using the edit handles, the Edit Toolbar, and the Slab Specification dialog. See Slab Specification Dialog on page 732.   

Slabs and Slab Holes can be edited like other closed-polyline base objects in both 2D and 3D views. See Editing Closed 
Polyline-Based Objects on page 230.   

USING THE EDIT TOOLS

One or more selected Slabs or Slab Holes can be edited in a variety of ways using the buttons on the Edit Toolbar. As with 
most objects, Slabs can be copied, replicated, moved, deleted, etc. See The Edit Toolbar on page 135.   

You can set the attributes of a selected Slab or Slab with Footing as the defaults for that slab type by clicking the Set as 
Default  edit button. This tool is not available for Post Footings. See Set as Default on page 79.

SLABS AND THE MATERIALS LIST

If a slab's material type is specified as Concrete or Volume, the materials list  calculates the total volume of the slab and all 
footings. See Define Material Dialog on page 1066.         

 

Editing Slabs
Slabs and Slab Holes can be selected in 2D and 3D views both individually and as a group and can be edited using the edit 
handles, the Edit Toolbar, and the Slab Specification dialog. See Slab Specification Dialog on page 732.         

USING THE EDIT HANDLES

Slabs and Slab Holes can be edited like other closed-polyline base objects in both 2D and 3D views. See Editing Closed 
Polyline-Based Objects on page 230.         

USING THE EDIT TOOLS

One or more selected Slabs or Slab Holes can be edited in a variety of ways using the buttons on the Edit Toolbar. As with 
most objects, Slabs can be copied, replicated, moved, deleted, etc. See The Edit Toolbar on page 135. 

You can set the attributes of a selected Slab or Slab with Footing as the defaults for that slab type by clicking the Set as 
Default  edit button. This tool is not available for Post Footings. See Set as Default on page 79.

 

Slab Specification Dialog
Select one or more Slabs and click the Open Object edit button to open the Slab Specification dialog.

The options in this dialog are similar to those in the Slab Defaults and Slab with Footing Defaults dialogs, but affect the 
selected slab(s) only.
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GENERAL PANEL

 
Slab

Specify the characteristics of the selected Slab.         

 l Check Hole in Slab to convert the selected slab into a slab hole. A slab hole must be contained within a larger slab. 
Not available in either Slab Defaults dialog. See Slab Holes on page 731.             

 l Specify the Thickness, which is the measurement from the slab’s top to bottom surfaces.             

 l Select the Elevation Reference, from the drop-down list. This determines where the next two settings are measured 
from and also affects their setting labels.             

 l Specify the slab’s height to Top, which is of its top surface measured from the selected Elevation Reference. 

 l Specify the slab’s height to Bottom, which is the height of its bottom surface, measured from the Elevation 
Reference. 

 l When the selected slab is a Post Footing or Deck Post Footing, specify whether it is Square or Round. Not 
available for manually drawn slabs or if the slab’s shape has been modified using the Change Line/Arc  edit 

tool. See Post with Footing on page 871.             

 
Footing

Specify the characteristics of the selected slab’s Footing. Not available in the Slab Defaults dialog.

 l Check Has Footing if you would like the slab to have a footing around the inside of its perimeter.    

 l Specify the Height and Width for the footing.    

 l Specify the Footing Offset, which is the distance that the footing extends out past the edges of the slab. A value of 0 
aligns the outside of the footing with the outside of the slab. 

 
Preview

A preview of the selected slab displays on the right side of the panel. See Dialog Preview Panes on page 22.         

POLYLINE PANEL

The POLYLINE panel states the length of the selected slab’s Perimeter, its enclosed Area, and its Volume See Polyline 
Panel on page 323.         
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If the selected Slab has any Holes in it, they will be subtracted from the Area and Volume values. See Slab Holes on page 
731.         

SELECTED LINE PANEL

The SELECTED LINE panel is available when the selected edge is a line as opposed to an arc. For information about the 
settings on this panel, see Polyline Specification Dialog on page 323.         

SELECTED ARC PANEL

The SELECTED ARC panel is available when the selected edge is an arc as opposed to a line. See Change Line/Arc on page 
259.         

LINE STYLE PANEL

For information about the settings on this panel, see Line Style Panel on page 310.         

FILL STYLE PANEL

The settings on the FILL STYLE panel affect the selected slab’s appearance in plan view. For information about these 
settings, see Fill Styles on page 197.         

MATERIALS PANEL

For information about the settings on this panel, see Materials Panel on page 1055.         

LABEL PANEL

Slab labels display in floor plan and cross section/elevation views when the “Polylines 3D, Labels” layer is turned on and 
use the Text Style assigned to that layer. The Automatic Label for slabs is blank, but you can specify a custom label.         

For information about the settings on this panel, see Label Panel on page 712.         

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 1335.         

OBJECT INFORMATION PANEL

The information entered on the OBJECT INFORMATION panel can be used in schedules and the materials list. For more 
information, see Object Information Panel on page 1336.   

SCHEDULE PANEL

The settings on the SCHEDULE panel determine which schedule categories the selected object is included in. See Schedule 
Panel on page 716.
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Editing Piers and Pads
Round Piers and Square Pads can be selected individually and in groups in 2D and 3D views  and edited using their edit 
handles and edit toolbars. 

There are several ways to move piers and pads; however, they must always be positioned under a wall. A pier or pad can 
only be moved away from the wall it is placed beneath if it is moved to another wall.

USING THE MOUSE

In plan view, piers and pads can be edited like CAD lines. Three edit handles allow the pier or pad to be resized and moved 
along the wall it is placed beneath. See Editing Line-Based Objects on page 218. 

In 3D views, piers and pads can be edited like CAD boxes. See Editing Box-Based Objects on page 234. 

USING DIMENSIONS

In plan view, piers and pads can also be moved using dimensions. See Moving Objects Using Dimensions on page 491.

If you move a foundation wall or beam, any piers or pads it 
contains will move with it.

USING THE EDIT TOOLS

A selected pier or pad can be edited in a variety of ways using the buttons on the Edit Toolbar. As with most objects, piers 
and pads can be replicated, moved, deleted, etc. See The Edit Toolbar on page 135. 

 

Pier/Pad Specification Dialog
Select a Round Pier or Square Pad and click the Open Object edit button to open the Pier/Pad Specification dialog.         

GENERAL PANEL

 
Type

Specify whether the selected object is a Round Pier or Square Pad.         
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Size and Position

Specify the Size and Position of the selected pier or pad.         

 l Specify the Top Height and Bottom Height, as measured from zero.          

 l Specify the selected pier or pad’s Width.          

LAYER PANEL

For information about the settings on this panel, see Layer Panel on page 191.          

FILL STYLE PANEL

The settings on the FILL STYLE panel affect the selected pier or pad’s appearance in plan view. For information about these 
settings, see Fill Styles on page 197.          

MATERIALS PANEL

For information about the settings on this panel, see Materials Panel on page 1055.          

LABEL PANEL

Round Pier and Square Pad labels display in floor plan and cross section/elevation views when the “Footings” layer is 
turned on and use the Text Style assigned to that layer. The Automatic Label for these objects is blank, but you can specify 
a custom label.   

For information about the settings on this panel, see Label Panel on page 712.   

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 1335.          

OBJECT INFORMATION PANEL

The information entered on the OBJECT INFORMATION panel can be used in schedules and the materials list. For more 
information, see Object Information Panel on page 1336.   

SCHEDULE PANEL

The settings on the SCHEDULE panel determine which schedule categories the selected object is included in. See Schedule 
Panel on page 716.

 

Fireplaces
A selection of freestanding fireplace symbols is available in the Architectural Core Catalog. See The Library on page 
961.    

A masonry fireplace can be placed in or away from a wall by selecting the legacy Fireplace tool and then clicking in 
the drawing area.         
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 l If created in a wall, it is considered a wall opening and can be moved or resized like a window or door.           
 l If created away from a wall, it moves and resizes similar to a cabinet.         

The legacy Fireplace  tool can be added to the toolbars. See Adding and Removing Buttons on page 137.          

The display of fireplaces is controlled in the Layer Display Options dialog. See Layer Display Options Dialog on page 183.          

Fireplaces can be edited, moved, resized, and deleted similar other objects. See Editing Objects on page 207.          

BUILT INTO A WALL

Flush and Mantle fireplace symbols are available in different styles in the Library Browser and can be positioned against a 
wall to create the front face of a built-in fireplace. For information about adding a chimney, see Chimneys on page 741.

To place a masonry fireplace in a wall, click the Fireplace  button, then click on a wall. A fireplace is created with the 

outside of the fireplace flush with the outside of the wall.          

Fireplaces cannot be placed in a wall specified as Invisible or if the wall in question is on a locked layer. See Locking 
Layers on page 182. 

A selected masonry fireplace inserted into a wall has four edit handles, all located along the wall.          

Click the diamond-shaped Depth handle and drag toward the outside of the wall. The fireplace will stop when the firebox 
front is flush with the inside edge of the wall.          

In 3D views, fireplaces placed in walls have five edit handles: a Resize handle along each edge and a Move handle at the 
center.           

Fireplaces always face the interior when placed on an exterior wall. When placing a fireplace in an interior wall, click on the 
edge of the wall that you want the fireplace to face. The fireplace is created with the firebox on the same side as the wall 
edge you clicked on to create it.           
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FREESTANDING FIREPLACES

A selection of freestanding metal and adobe fireplace unit symbols is available in the Library Browser.

To place a free-standing masonry fireplace, click the Fireplace  button, then click in an open area away from a wall.    

Both fireplace symbols and freestanding legacy masonry fireplace objects have ten edit handles when selected and may be 
rotated, resized, or moved in any direction, similar to the way CAD boxes can. See Editing Box-Based Objects on page 234.    

Free-standing fireplaces can be selected and replaced with a symbol from the library by clicking the Replace From Library 
 edit button. See Replace From Library on page 983.     

MASONRY FIREPLACE FOUNDATIONS

When a Walls with Footings or Grade Beams on Piers foundation is built, a fireplace foundation will be generated under 
any Fireplaces  present on Floor 1. See Building a Foundation on page 722.           

Fireplace foundations are the same material type as the original fireplace, but do not have a firebox or a hearth. Fireplace 
foundations can be edited or deleted as needed. A firebox and hearth can be added in the Fireplace Specification dialog. See 
Fireplace Specification Dialog on page 738.          

 

Fireplace Specification Dialog
Select a legacy Fireplace and click the Open Object edit button to display the Fireplace Specification dialog. 
Multiple fireplaces can be group-selected, but all objects in selection group must be either placed in a wall or free-

standing. 
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GENERAL PANEL

  Size and Position

 l Specify the Height, Width, and Depth of the fireplace.          

 l Specify the Hearth Depth. This is measured from the front of the fireplace out into the room. To eliminate the 
hearth altogether, enter a zero for this value.          

 l Specify the Hearth Height, relative to the floor in the room that the fireplace faces.          

 l Select the Elevation Reference from the drop-down list. This determines where the next two settings are measured 
from and also affects their setting labels.          

 l Specify the height to Top, measured from the selected Elevation Reference.           

 l Specify the height to Bottom, measured from the selected Elevation Reference.          

 
Plan Display

Check Suppress Dimensions to turn off the display of the selected fireplace’s width and firebox width dimensions in floor 
plan view.         

 
Preview

The preview of the fireplace updates as changes are made.
See Dialog Preview Panes on page 22.         
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FIREBOX PANEL

 
No Firebox

Check No Firebox to eliminate the firebox from the fireplace. This is checked by default for a fireplace object generated on 
Floor 0 to serve as a solid matching base for a fireplace on Floor 1.         

  Size

 l Specify the firebox’s Height and Width.          

 l Specify the Depth of the firebox.          

  Offset

 l Enter the offset Distance, which is how far the firebox is offset from the fireplace center. A value of 0 centers the 
firebox in the fireplace.           

 l Offset to Left/Right - Choose to offset the firebox to the left or to the right.           

 
Preview

The preview of the fireplace updates as changes are made. See Dialog Preview Panes on page 22.         

ROUGH OPENING PANEL

The settings on the ROUGH OPENING panel are also found on the panel of the same name in the Door Specification dialog. 
See Rough Opening Panel on page 579.    

LAYER PANEL

For information about the settings on this panel, see Layer Panel on page 191.          

MATERIALS PANEL

For information about the settings on this panel, see Materials Panel on page 1055.          
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COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 1335.          

 

Library Fireplaces
A variety of fireplace symbols are available in the library. Flush fireplaces are designed to snap to wall surfaces. Some 
fireplace symbols can be enclosed by walls or positioned to project through a wall. See Placing Library Objects on page 
980.         

Always check the manufacturer’s product information for the 
framing and clearance requirements of the fireplace unit you 

plan to use, and design your plan accordingly

 

Chimneys
Chimneys can be created using a variety of methods. 

MASONRY FIREPLACE CHIMNEYS

To create a chimney on a masonry fireplace
 1.  Select the fireplace in a 3D view. 

 2.  Ctrl + drag the top edge of the chimney upward through all the floors and the roof until it is to the desired height. 
See Unrestricted Movement on page 246.

 3.  When the chimney is approximately the correct height, select the fireplace, click the Open Object  edit button, 

and type in the exact height.

CHIMNEY CHASES AND CAPS

There are two ways to draw a chimney chase: 

 l Place a 3D Solid, closed box Geometric Shape, or Soffit over the chimney chase, resize it to match, then increase its 
height either in its specification dialog or in a 3D view using the same method as extending a masonry fireplace. 

 l Use walls to define the chimney chase as a room area, making sure these walls are aligned between floors. The 
chimney chase “room” on the uppermost floor should have a much higher ceiling than the other rooms on that floor 
and should also have no ceiling or roof. See Room Specification Dialog on page 442.
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A selection of chimney tops is available in the library. In addition, custom chimney caps can be made using 3D Solids or 
other primitive objects, Geometric Shapes, and/or Soffits. See Other Objects on page 1015.
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Chapter 21
 

Multiple Floors

When a new plan file is opened in Chief Architect Premier, two floor levels are present: Floor 1 and the Attic Floor. You 
can add more floors whenever you like: up to 30  total. Once created, floors can also be copied, swapped, and deleted.         

Chief Architect also supports special floors for foundations and attics. Only one foundation level and one attic can exist in a 
plan. Foundations are discussed in their own chapter. See Foundations on page 717.         

TOPICS
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Displaying Floor Levels 747
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Floor Defaults Dialog
There is a Floor Defaults dialog for each floor in a plan file aside from the Attic floor, which can be accessed by 
selecting Edit> Default Settings. Click the arrow to the left of “Floors and Rooms” to expand the category, then 

expand the “Floor Levels” subcategory. Select              one or more floor levels and click the Edit button to open the Floor Defaults 
dialog for that floor. See Default Settings vs Preferences on page 76.         

 l Floor Defaults can also be accessed by double-clicking the Floor Tools  parent button.             

 l In addition, the Floor Defaults  button can be added to the toolbars. See Toolbar Customization Dialog on page 

139.             

The Floor Defaults dialog also opens whenever you add a new floor to the plan. See Adding Floors on page 745.          

The Floor Defaults dialog does not open when you build a foundation; however, the Floor 0 Default settings are created 
based on the current Foundation Defaults. See              Foundation Defaults on page 718.          

The Floor Defaults dialog is similar to the Room Specification dialog, but controls the default settings for all rooms on the 
floor in question. The settings here also control the height of individual walls as they are drawn on that floor. See Room 
Specification Dialog on page 442.          

Note: The default floor height for Floor 1 is 0. It can be modified in the 
Room Specification dialog, but not in the Floor 1 Defaults dialog. See 
Floor and Room Defaults on page 418.

STRUCTURE PANEL

The settings on the STRUCTURE panel are similar to those in the Room Specification dialog. See Structure Panel on page 
444.          

MOLDINGS PANEL

The settings on the MOLDINGS panel are similar to those in the Room Specification dialog. See              Moldings / Profiles Panels 
on page 943.          

FILL STYLE PANEL

The settings on the FILL STYLE panel are similar to those in the specification dialogs for many objects throughout the 
program. See Fill Styles on page 197.          

MATERIALS PANEL

The settings on the MATERIALS panel are similar to those in the specification dialogs for many objects throughout the 
program. See Materials Panel on page 1055.          

 

Floor Tools
Select Build> Floor to access the following floor tools:        
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  Build New Floor builds a new floor; a new floor can be generated based upon the perimeter of the floor below 
or a blank floor can be created and drawn from scratch. See Adding Floors on page 745.             

  Insert New Floor inserts a new floor below the Current Floor. See Adding Floors on page 745.             

  Delete Current Floor removes the Current Floor from the plan. For more information, see Deleting Floors on 
page 748.             

  Exchange With Floor Above moves the Current Floor up one floor and the floor above it down. See 
Exchanging Floors on page 748.             

  Exchange With Floor Below moves the Current Floor down one floor and the floor below it, up. See 
Exchanging Floors on page 748.             

  Build Foundation opens the Foundation Defaults dialog and build a foundation floor. See Building a 
Foundation on page 722.             

  Delete Foundation removes the foundation from the plan. See Deleting Foundations on page 728.             

  Hole in Floor Platform allows you to draw a hole in a floor platform on the Current Floor. See Floor and 
Ceiling Platforms on page 433.             

  Hole in Ceiling Platform allows you to draw a hole in a ceiling platform on the Current Floor. See Floor and 
Ceiling Platforms on page 433.             

  Floor Material Region allows you to create an area within a floor platform that uses different materials than the 
floor. See Floor and Wall Material Regions on page 1037.             

  Rebuild Walls/Floors/Ceilings forces Chief Architect to recalculate the relationship between the walls, floors, 
and ceilings in your model. See Rebuilding Walls, Floors and Ceilings on page 748.             

 

Adding Floors
When a new plan file is opened in Chief Architect Premier, two floor levels are present: Floor 1 and the Attic Floor. You 
can add up to 30 total living floors, as well as create a foundation below Floor 1.         

Floors can be added whenever you like; and once created, they can also be copied, swapped, and deleted.          

Note: Chief Architect allows only one floor, the foundation/basement, 
below Floor 1. See Foundations on page 717. 

BUILD NEW FLOOR

New floors can be created in plan view as well as in 3D views, and are always added above the top living floor. To 
create a new floor, select Build> Floor> Build New Floor.          

 l Derive new 2nd floor plan from the 1st floor plan creates a new top floor with exterior walls generated directly over 
the exterior walls of the floor below. Wall types and roof directives associated with the walls on the floor below are 
duplicated; however, interior walls are not. See Roof Panel on page 401.         
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 l Check Move Highest Floor’s Roof Up to move any roof planes displaying on the highest floor in the plan up one 
floor when the new floor is created. Roof planes displaying on floors other than the top floor are unaffected. This 
option is only available if there are roof planes built on the top floor and is not available when Auto Rebuild Roofs is 
enabled. See Build Roof Dialog on page 809.         

When Move highest floor roof up is checked, roof planes on 
the top floor will move even if the “Roof Planes” layer is 

locked and manually edited roof planes are set to be retained. See 
Roof Panel on page 810.

 l Check Step floor/ceiling elevations to match existing floor to maintain all ceiling heights on the existing floor by 
stepping floor heights on the new floor to match. Ceiling heights on the new floor also become stepped accordingly. 
See Floor and Ceiling Platforms on page 433.          

 l Make new (blank) plan for the # floor creates a new top floor that is blank. This option is typically useful only if 
none of the exterior walls on the new floor will be directly above the exterior walls on the floor below. If you choose 
this method, it may be helpful to turn on the Reference Floor when drawing walls on the new floor. See The Reference 
Display on page 69.         

When you click OK, the Floor Defaults dialog for the newly created floor opens. Make any necessary changes to the floor 
structure, moldings, or materials and click OK. See Floor Defaults Dialog on page 744.         

The new floor becomes the Current Floor in plan view. If, however, the new floor is created in a 3D view, the camera 
remains on its original floor and does not move.          

INSERT NEW FLOOR

A floor level can also be inserted beneath the Current Floor in both plan and 3D views. Begin by going to the floor 
level you would like to insert a floor under to make it the Current Floor, then select Build> Floor> Insert New 

Floor.  See The Current Floor on page 750.         

 l Select Derive new # Floor plan from the # Floor plan to insert a new floor below the Current Floor, with exterior 
walls based on those of the Current Floor.           

 l Check Move Highest Floor’s Roof Up to move any roof planes displaying on the highest floor in the plan up one 
floor when the new floor is created. Roof planes displaying on floors other than the top floor are unaffected. This 
option is only available if there are roof planes built on the top floor and is not available when Auto Rebuild Roofs is 
enabled. See Build Roof Dialog on page 809.          

When Move highest floor roof up is checked, roof planes on 
the top floor will move even if the “Roof Planes” layer is 

locked and manually edited roof planes are set to be retained. See 
Roof Panel on page 810.

 l Check Step floor/ceiling elevations to match existing floor to maintain the floor and ceiling heights on the existing 
floors by stepping floor and ceiling heights on the new floor to match. See Floor and Ceiling Platforms on page 433.           

 l Select Make new (blank) plan to insert a blank floor below the Current Floor.           
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ADDING A FOUNDATION

To add a foundation, select Build> Floor> Build Foundation . See Building a Foundation on page 722.         

 

Displaying Floor Levels
Chief Architect allows you to view the floor levels in a plan in a variety of ways.

IN PLAN VIEW

In plan view, only one floor level can be active for editing at a time. This is referred to as the Current Floor. See The 
Current Floor on page 750. 

In addition to the Current Floor, one or more other floors can be displayed for reference purposes: the Reference Floor. 
Objects on the Current Floor can snap to those on the Reference Floor, helping you align objects. See The Reference 
Display on page 69.

Floor and ceiling platforms do not display in plan view. When floor and/or ceiling framing is present, its display can be 
turned on; however, other components of floor and ceiling platforms like sheathing, drywall, and finish materials, cannot.          

IN 3D VIEWS

In 3D views, all floor levels in a plan are visible, from the foundation up to the attic. There are two exceptions:

  Orthographic and Perspective Floor Overviews, which show the Current Floor, not including its ceiling, 
plus any floors beneath it.

  Wall Elevation views, which show a wall on a single floor, in a single room.             

See 3D View Tools on page 1085. 

IN THE MATERIALS LIST

The materials that make up floor and ceiling platform assemblies are listed under different Categories in the Materials List:           

 l Subfloor - Lists floor framing and structural subflooring materials specified in all Floor Structure Definitions in the 
current plan. See Floor and Ceiling Platform Definitions on page 434.          

 l Flooring - Lists flooring and subflooring materials specified in all Floor Finish Definitions in the current plan.          
 l Framing - Lists ceiling framing and any other materials specified in all Ceiling Structure Definitions in the current 

plan.          
 l Wall Board - Lists ceiling finish materials specified in all Ceiling Finish Definitions in the current plan.          
 l Insulation - Floor insulation is calculated for all rooms that have a floor, and ceiling insulation is calculated for all 

rooms that have a ceiling - regardless of the Floor or Ceiling Structure Definition. When a ceiling is not present, 
insulation is calculated for the roof. See Structure Panel on page 444.           

 l Foundation - Lists the concrete and mesh for all Floor Structure Definitions in the current plan with a layer of 
concrete material. See Materials and the Materials List on page 1064.          

See Materials Lists on page 1309.           
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Exchanging Floors
Select Build> Floor> Exchange With Floor Above or Exchange With Floor Below to swap the Current 
Floor with the floor above or below.         

The floor that was moved becomes the Current Floor at its new location. You can easily move a floor up or down several 
floors by using either one of these buttons repeatedly.         

 

Copying Floors
The Edit Area  tools can be used to make copies of entire floors in a plan. See Edit Area Tools on page 273.  You can 

use these tools to:          

 l Make a copy of an existing floor to be pasted onto a new floor.          
 l Make a copy of all existing floors in a plan to be pasted into a different plan.          

You can also copy the information on a floor by pressing Ctrl + A (Select All), then using Copy  and Paste Hold 

Position . See Paste Hold Position on page 175.          

COPYING BETWEEN PLANS

While you can copy and paste floors from one plan file to another, this is not always the best approach.           

 l To make a copy of the plan for backup or your records, use Save As  to save the file using a new name. See Saving 

Plan and Layout Files on page 40.          
 l To copy the model into another plan with multiple structures, consider exporting it as a symbol and importing it into 

the new plan. See Custom Symbols on page 992.          

 

Deleting Floors
Select Build> Floor> Delete Current Floor to remove the Current Floor from the plan. If there is a floor above, it 
becomes the Current Floor; if there is no floor below, the floor beneath becomes the Current Floor.

To delete Floor 0, select Build> Floor> Delete Foundation. You can delete the foundation without actually being on 
Floor 0. Floor 0 cannot be deleted while Auto Rebuild Foundation is turned on. See Deleting Foundations on page 

728.         

When a floor is deleted, all objects on that floor are deleted with 
it, including locked roof planes and any other objects on locked 

layers. See Locking Layers on page 182.

 

Rebuilding Walls, Floors and Ceilings
When you make a change to the walls or to the floor or ceiling platforms in your plan, they may not immediately 
resize or move in the 3D model. The program does detect such changes, though, and the next time you generate a 3D 
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or section/elevation view, walls,  floors and ceilings are rebuilt.         

By default, walls, floors and ceilings are also rebuilt when an automatic roof is generated. See Build Roof Dialog on page 
809.          

You can direct the program to rebuild walls, floors, and ceilings at any time by selecting Build> Floor> Rebuild 
Walls/Floors/Ceilings .          

If you do not want the program to rebuild walls, floors and ceilings when a 3D view is created, uncheck Auto Rebuild 
Floors and Ceilings in the 3D View Defaults dialog. This may speed up plan view editing for very large plans. When this is 
unchecked and the structure is not up-to-date, the Rebuild Walls, Floors, Ceilings   icon displays near your mouse 
pointer. See 3D View Defaults Dialog on page 1084.           

 

Split Levels
Both split level floor plans and split level entries can be created by controlling the floor and ceiling heights of individual 
rooms in a multiple story structure.         

For more detailed information about both types of structure, visit chiefarchitect.com.

SPLIT LEVEL FLOOR PLANS

A split level, or tri-level, structure is a building where the floor level in one part of the plan is located approximately 
halfway between the floor and ceiling levels of another part of the plan.         

To create a simple split level plan
 1.  Draw a simple rectangular structure divided into two separate halves by an interior wall.         

 2.  Select one of the rooms and click the Open Object  edit button. See Room Specification Dialog on page 442.         

 3.  Raise the Floor Height then press the Tab key.         

 4.  Restore the Relative Rough Ceiling to the default value, then click OK.         

 5.  Build a stem wall foundation. See Foundations on page 717.         

 l The foundation under the room with the lower floor height will have the specified Min Stem Wall Height.         

 l The foundation under the room with the raised floor will have taller stem walls.         

 l Both can be edited in the Room Specification dialog.         

 6.  If you add a Floor 2, note that the Ceiling Height in the room on Floor 1 will be reset to the default value.         

 l To maintain a stepped condition on multiple floors, return to this room and set the Relative Rough Ceiling back to 
using the default.         
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SPLIT LEVEL ENTRIES

A split level entry, or divided entry, is characterized by an entry door that opens onto a landing positioned halfway between 
the basement floor and first floor levels.         

To create a simple split level entry
 1.  Create a plan file with a full basement at the location of the entry door. See Basement Rooms on page 729.         

 2.  Go to Floor 0 and draw a stair Landing  at the location of the entry. See Landings on page 765.         

 3.  Specify the desired height of the landing. See Stair Landing Specification Dialog on page 799.          

 4.  Draw stairs upward from the basement floor to the landing.         

 5.  Draw a second stair section from the landing upward.         

 6.  Select the stairs and click the Auto Stairwell  edit button. See Creating a Stairwell on page 779.         

Split level entries are often associated with daylight basements. See Daylight Basements on page 730.         

 

The Current Floor
In a given plan view window, only one floor level can be active at any given time. The active floor is referred to as the 
Current Floor, and it is the only floor on which objects can be edited.

If you would like to view two different floor levels side by side, open a second plan view, navigate to the desired floor, and 
then tile the two views. Although both are visible, only one of these view windows is active. See Working in Multiple Views 
on page 154.   

FLOOR UP / FLOOR DOWN

If you are working with more than one floor, you can select Tools> Floor/Reference Display> Up One Floor or Down 
One Floor to switch from one floor to another. 

You can change the Current Floor in floor plan, cross section/elevation and 3D views. The Current Floor displays on the 
Change Floor/Reference  button, which can be found between the Down One Floor and the Up One Floor buttons. 

Floors become available once they have been built. The Attic and foundation levels are also accessible using these tools. 

CHANGE FLOOR / REFERENCE

If there are multiple floors, select Tools> Floor/Reference Display> Change Floor/Reference to open the Change 
Floor/Reference dialog, where you can select both the Current Floor and which floor is used in the Reference Floor, 
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as well as control the appearance of the Reference Floor. See The Reference Display on page 69.

 

The Attic Floor
Chief Architect automatically creates a floor above the top numbered floor level of each plan. This floor is called the 
Attic floor and has only one purpose: to provide a space for automatically generated Attic walls. See Attic Walls on 

page 383.         

In some situations, you may find it necessary to draw one or more walls on the Attic floor; however, even if you enclose an 
area with walls, rooms cannot be created on this floor level. If you wish to create an attic loft or bonus room in your plan, 
you must do so on a numbered floor level.         

Because the Attic floor is not meant to be a living area, a warning message will display if you try to draw walls or other 
objects on this floor level.         

 

The Reference Floor
CHANGE FLOOR/REFERENCE

When the Reference Floor Display is turned on, the floor level below the Current Floor is used as the Reference Floor. If 
there is no floor level below, the floor above is used. By default, the Reference Floor displays in red using the Reference 
Floor Layer Set. 

You can specify which floor(s) and layer set(s) are used in the Reference Display in the Change Floor/Reference dialog: 
select Tools> Floor/Reference Display> Change Floor/Reference or click the floor level  toolbar button. See Change 

Floor / Reference Dialog on page 69.

Note: When objects on the Current Floor and the Reference Floor align 
and lines of two different colors are superimposed upon each other, 
discoloration may result.

REFERENCING OTHER PLAN FILES

In addition to displaying other floors in the current plan file for reference, you can display information from other plan files 
in both 2D and 3D views. See The Reference Display on page 69.          
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Chapter 22
 

Stairs, Ramps, and Landings

Staircases can be composed of one or more straight or curved stair sections, ramps, and landings. Stairs and ramps can be 
drawn, selected and edited in 2D and 3D views.

Starter treads can be defined, stair sections can be flared, treads can be wrapped, and curved sections can be turned into 
winders.           

Landings can be created automatically or manually and their shape customized. You can edit an existing landing, or create a 
landing from a closed CAD polyline. Landing heights can be defined or you can let them automatically adjust as needed.          

Stairwells can be created automatically or manually and can be seen in 3D views. 

Local building and fire authorities must be consulted for specific 
stair construction codes and access requirements.

TOPICS

Stair and Ramp Defaults 753
The Stair Tools 753
Anatomy of a Staircase 755
Drawing Stairs and Ramps 756
L- and U-Shaped Stairs 757
Displaying Stairs, Ramps, and Landings 759
Editing Stairs and Ramps 761
Stair and Ramp Sections and Subsections 762
Landings 765
Maintaining Tread Depth 767
Flared Stairs and Curved Treads 768
Starter Treads 771
Winders 773
Wrapped Stairs 774
Other Special Railings and Stairs 775
Creating a Stairwell 779
Rooms Below Staircases 781
Staircase Specification Dialog 782
Ramp Specification Dialog 796
Stair Landing Specification Dialog 799
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Stair and Ramp Defaults
Default settings for stairs and ramps determine the initial attributes of these objects when they are first created. 
Access the defaults by selecting Edit> Default Settings, then clicking the + beside Stairs and Ramps. Select an 

item and click the Edit button to open the defaults dialog associated with your selection. See Default Settings vs Preferences 
on page 76.         

The Stair and Ramp Defaults dialogs can also be accessed by double-clicking the Stair Tools  parent button or any child 

tool aside from the Landing tool.           

Both interior and exterior stairs have default definitions for size, style, materials and much more. In fact, the default dialogs 
for stairs and ramps are similar to the Staircase and Ramp Specification dialogs. See Staircase Specification Dialog on page 
782 and Ramp Specification Dialog on page 796.          

Interior and Exterior stairs are drawn using the same tools: stairs created inside a room are considered Interior while those 
drawn outside a structure are considered Exterior.           

Landings do not have a defaults dialog. Instead, they get their initial attributes from the stairs or ramps that they are 
connected to.            

STRUCTURAL DEFAULTS

The purpose of interior stairs is to provide passage from one floor platform to another, so the attributes that influence floor 
heights - including ceiling heights, floor platform thicknesses, and floor finish materials - also influence the structure of 
stairs. When considering a staircase’s structure, bear in mind that riser height is directly dependent on the distance from one 
floor platform to another. 

When Automatic Heights are used, stairs are built so that they rest on the top of the floor structure of the floor where they 
are drawn, and build up to the top of the floor structure on the floor above. Risers are measured to the floor finish surfaces 
on both floors. See Floor and Ceiling Platform Definitions on page 434.           

Ramps are built in a similar manner: interior ramps bear on the floor structure, and when Automatic Heights are used, the 
top surface of both interior and exterior ramps locates floor finish surfaces.           

 

The Stair Tools
Select Build> Stairs to access the Stair Tools.

DRAW STAIRS

To draw a straight staircase select Build> Stairs> Draw Stairs, then click and drag in floor plan or a 3D view. You 
can also click once to place a staircase that extends from the current floor up to the next floor. See Drawing Stairs 

and Ramps on page 756.
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STRAIGHT STAIRS

Select Build> Stairs> Straight Stairs, then click to create stairs between the current floor and the floor above. To 
create stairs between two floor platforms on the current floor, click on the low side, within a few feet of where the 

floor changes height. 

 l If you click on the low side of a floor platform defined by a railing, a doorway will be created in the railing, adjacent 
to the stairs. 

 l If you click on the low side of a floor platform defined by a wall, stairs will be created but a doorway will not.
 l If you click at a location that is not near the edge of a floor platform, a full height staircase will be created.

CURVED STAIRS

Select Build> Stairs> Curve to Left or Curve to Right and click once in plan view to place a curved 
staircase. See Curved Stairs and Ramps on page 756.

L-SHAPED STAIRS

Select Build> Stairs> L-Shaped Stairs, then click to create two equal stair sections that form a 90° corner and are 
connected by a landing. See L- and U-Shaped Stairs on page 757.

U-SHAPED STAIRS

Select Build> Stairs> U-Shaped Stairs, then click to create two stair sections that form a 180° turn and are 
connected by a landing. 

LANDING

Select Build> Stairs> Landing to draw a landing, which is a platform connecting two or more stair sections. See 
Landings on page 765.

There are two ways to create a landing using this tool:

 l Click once to place a landing measuring 39” (975 mm) on each side.
 l Click and drag to draw a rectangular landing sized as needed. See Polylines on page 322. 

You can also create a landing by converting a CAD polyline. See Convert Polyline on page 265.          

RAMP

Select Build> Stairs> Ramp to draw a sloped ramp. By default, ramps are drawn at a 1:12 slope to a maximum 
height of 30” (760 mm). See Drawing Stairs and Ramps on page 756.

SPIRAL STAIRS

In the Library Browser, browse to Chief Architect Core Catalogs> Architectural> Spiral Stairs to access a selection of 
spiral staircase fixtures. Select the object that you want, then click in any view to place it in the plan. See The Library 

on page 961. 

Because spiral staircase symbols are fixture symbols, they do not have an Auto Stairwell edit tool. An opening in the floor 
above a spiral staircase must be created manually. See Creating a Stairwell on page 779. 
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Anatomy of a Staircase
Stairs as well as ramps are often described in terms of rise and run. Rise is typically between 6" and 8", and the run 
between 10" and 12". In metric plans,  rise is 177 to 190 mm, and the run is about 250 mm. Whenever possible, Chief 
Architect will automatically apply reasonable rise and run values that meet most building codes to stairs and ramps as they 
are drawn.

In Chief Architect, staircases automatically have a consistent rise and run along their length because this is also a typical 
requirement of most building codes. When this is not desired, however, stairs and ramps can be divided into multiple 
sections subsections. See Stair and Ramp Sections and Subsections on page 762.

STAIRCASE TERMINOLOGY

Balusters - The vertical members that run between the handrail and the treads or bottom rail. 

Bracket - Decorative L-shaped supports on the exposed side of stairs below each tread.

Landing - A platform connecting two or more stair sections.

Newels - The end post of a stair railing located at landings and the beginnings and endings of new stair sections.

Rise - The height of a riser, measured from tread surface to tread surface, Also referred to as Unit Rise. 

Rise Angle - The angle of the staircase or stair section, defined by a line drawn through the back surfaces of its treads.

Riser - The vertical stair member located between the treads. Risers may be solid or open. When open, the front surfaces of 
the stringers are considered the risers. 

Run - The depth of a tread, measured from riser surface to riser surface. Run does not include the Tread Overhang. Also 
referred to as Unit Run. 

Runner - The carpet that runs down the center of the staircase.

Shoe - The bottom railing, placed on the landing floor, that anchors the balusters at landings. 

Stringer - The inclined support member of a staircase that supports the treads and risers.

Tread - The horizontal member of a stair that the foot is placed on. 

Tread Overhang - The portion of a tread extending past the front surface of the riser and over the tread below. Also 
referred to as Nosing or Nosing Extension, it is not included in the Run or Tread Depth measurements.

Tread Thickness - The vertical depth of the tread material.

Winder - A wedge-shaped stair tread used where curved or angled stairways change direction.

STAIR STRUCTURE AND THE MODEL

By default, stairs locate the height of the floor platform that they are drawn on and seek the next level, which may be the 
floor platform of the floor above or a landing. The stringers locate the subfloor of the floor platforms and maintain 
consistent riser height. If the stairs are long enough to reach the next level at a reasonable rise angle, their tread depth and 
number of treads are automatically calculated to create a staircase with consistent tread and riser dimensions along its entire 
length. 

You can modify this behavior or turn off it off altogether in the Staircase Specification dialog and specify your own rise and 
run values. Bear in mind, though, that if you turn it off, you will need to specify the correct Top and Bottom Heights to 
make sure that the stairs actually meet both floor platforms correctly. See General Panel on page 782.           
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Drawing Stairs and Ramps
Stairs and ramps can be drawn in floor plan and 3D views but not in cross section/elevation views. There are a few things to 
keep in mind when drawing stairs:

 l Before stairs are created, make sure that the heights for both the lower and upper floors are correctly defined. 
 l Stairs are drawn going UP, so they should be drawn from the lower of the two floors they connect. 
 l By default, stairs adjust their riser and tread dimensions to connect two floor heights if possible. The rise and run are 

calculated so that the steps are consistent in size. 
 l Stairs drawn within 1” (25 mm) of a wall will snap to the outer surface of the wall. 
 l Stairs will snap to the Reference Display , if you have it turned on. See The Reference Display on page 69.

 l Hold down the Ctrl key to suppress these snapping behaviors. 
 l If a stairwell room has been defined on the floor above, the top of the stairs can be dragged until it stops at the railing 

or wall defining the stairwell.
 l When drawing stairs or a ramp up from the terrain, it is a good idea to make sure the terrain is up-to-date. See 

Building the Terrain on page 1263.

STRAIGHT STAIRS AND RAMPS

The Draw Stairs  tool can be used in two different ways:

 l Click and drag in a straight line to draw stairs that are the length that you drag.
 l Click once to place stairs that go from the current floor up to the height of the next floor level.

You can also click once using the Straight Stairs  tool to create stairs between rooms on the same floor with different 

floor heights or between exterior rooms and the terrain. When the Straight Stairs tool is active, a preview outline of the 
stairs will follow the mouse pointer. Hold down the Alt key to reverse the direction of the Up arrow in the preview.

Similarly, Ramps  can be created by either clicking and dragging or by clicking. A ramp created with a single click will 

be 30” (760 mm) high, have a slope of 1:12, and be 360” (9120 mm) long. 

An individual stair or ramp section must be between 6” (150 mm) and 100’ (30 m) in length. If a greater length is needed, 
connect two sections using a landing.

CURVED STAIRS AND RAMPS

You can make a straight stair or ramp section curved, or vice versa: 

 l Select the stairs or ramp and click the Change Line/Arc  edit button. See Change Line/Arc on page 259.

 l Select the stairs or ramp, hold down the Alt key (or right-click), and drag an end edit handle. See Alternate on page 
209.          
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You can also curve straight stairs and ramps by drawing them against a curved wall.

Curved Stairs can also be created in plan view by selecting Build> Stairs> Curve to Left or Curve to Right. 
Click to place a 90º curved stair section that can then be edited. You can continue clicking to place additional 

curved staircases until another tool is selected.

DRAWING STAIRS AND RAMPS DOWNWARD

Stairs              and ramps can be drawn from the current floor level downward; however, drawing stairs or ramps between floors in 
this manner is not recommended. Drawing downward should only be used to create a staircase or ramp between a porch or 
deck and the terrain when you require the direction arrow to say “DN” instead of “UP”. See Displaying Stairs, Ramps, and 
Landings on page 759.             

To draw stairs going downward
 1.  Select Build> Stairs> Draw Stairs .

 2.  Hold down the Alt key or the right mouse button.         

 3.  Click and drag to create straight stairs.         

When drawing stairs or ramps from a floor platform to the terrain, or vice versa, they will locate the height of the terrain as 
long as it is lower than the floor height. You can also create a landing or “room” outside the structure and use it to establish 
the bottom height of the stairs or ramp. Then, draw in an upward direction from the lower platform to the upper platform. 

 

L- and U-Shaped Stairs
The L-Shaped Stairs and U-Shaped Stairs tools allow you to place staircases composed of two stair sections 
connected by one or more landings with a single click. 

The staircases created with these tools build from the current floor to the floor above. If you need a staircase that builds 
between platforms on the same floor level, or in a downward direction, you will need to draw it manually. See Landings on 
page 765.
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When you select either tool, the New Shaped Staircase dialog opens. 

NEW SHAPED STAIRCASE DIALOG

The settings in this dialog retained between sessions in the software and are global, affecting all plans. 

 

 l Check Only Show This Dialog on Double Click to suppress this dialog unless the L-Shaped Stairs or U-Shaped 
Stairs is double-clicked. 

 l Specify the Default Direction of the stairs as they build upward: Clockwise, or Counterclockwise. These settings 
only apply to staircases when they are not placed next to a wall.

 l Check Make Winders to create multiple landings with angled edges between the two stair sections When 
unchecked, a single rectangular landing is produced.

  U-Shaped Stairs

 l Specify the width of the Gap between the two stair sections. 

 l Check Split Landing to create two rectangular landings instead of one. When Make Winders is also checked, each 
of these two landings is further divided into triangular shaped winders.

When you click OK, a preview outline will follow the mouse pointer.

PLACING L- AND U-SHAPED STAIRS

You can control the staircase’s orientation and direction prior to placing it by moving the mouse pointer towards a wall.

In the case of a L-Shaped  staircase with Clockwise set as the Default Direction:
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 l As you move the mouse pointer close to a wall, the upper stair section in the preview outline will snap to the wall first.
 l As you move the mouse pointer closer to the wall, the preview outline will rotate so that the bottom stair section snaps 

to the wall instead.    
 l If you move the mouse pointer into a wall corner, the preview outline will rotate so the landing is in the corner and the 

Default Direction is used.

In the case of a U-Shaped  staircase with Clockwise set as the Default Direction:

 l As you move the mouse pointer close to a wall, the back of the landing in the preview outline will snap to the wall 
first.

 l As you move the mouse pointer closer to the wall, the preview outline will rotate so that the upper stair section snaps 
to the wall.    

 l If you continue to move the mouse closer, the lower stair section will snap to the wall instead.    
 l If you move the mouse pointer into a wall corner, the preview outline will rotate so that the bottom stair section snaps 

to the wall that is nearest to the mouse pointer.

When an L- or U-Shaped Staircase preview outline is in a wall corner, you can use the mouse to further control position and 
direction:

 l When an L-Shaped  staircase preview is in a wall corner, move the mouse pointer over the stair sections to control 

which is the bottom section.
 l When a U-Shaped  staircase preview is in a wall corner, move the mouse pointer within the landing area to control 

which wall the back of the landing snaps to. 
 l With the landing in place, move the mouse pointer over the two stair sections to control which is the bottom section. 

You can use keyboard hotkeys to override these behaviors:

 l Press the Alt key to reverse these snapping behaviors and the stairs’ direction.    
 l Hold down the Ctrl key to prevent the stairs from rotating or snapping to walls.

 

Displaying Stairs, Ramps, and Landings
The display of stairs, ramps, and landings in all views is controlled in the Layer Display Options dialog. Stairs, 
ramps, and landings are placed on the “Stairs & Ramps” layer by default but, once created, can be placed on any 

layer. See Layer Attributes on page 181.

IN PLAN VIEW

In plan view, stairs, ramps and landings display on the floor they were drawn on and are only visible from the floor above if 
there is a stairwell. See Creating a Stairwell on page 779.

Stairs and ramps have an arrow indicating the direction they run. Interior stairs and ramps have an UP arrow on the floor 
they were created on and a DN arrow when viewed from the floor above. See Drawing Stairs and Ramps on page 756.

The style and size of the direction arrow can be specified in the Staircase or Ramp Specification dialog. The Text Style, 
color, and display are controlled by the “Stairs & Ramps, Up/Down Arrows” layer. See Arrow Panel on page 312. 

In addition, staircases can use and display a Walk Line in plan views. The Walk Line is drawn on the same layer as its 
staircase and can be specified in the Staircase Specification dialog. See Style Panel on page 786.         
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Stair landings can also display labels in plan and cross section/elevation views when the “Polylines 3D, Labels” layer is 
turned on.  Landings do not have an automatic label; however, you can specify a custom label in the Landing Specification 
dialog. See Label Panel on page 712.           

You can specify whether newels, balusters, and/or rails display in plan view in the Staircase Specification dialog. See 
Newels/Balusters Panel on page 794.           

The display of stair and ramp overhangs and tread nosing in plan view can be controlled using the “Stairs & Ramps, 
Details” layer. The display of stair stringers in plan view is controlled using the “Stairs & Ramps, Stringers” layer.           

You can create custom labels for stairs, ramps, and landings using the Text Tools and custom text macros. See Creating 
User Defined Macros on page 1392.           

When a staircase is selected in plan view, the numbers associated with each of its sections and subsections display. Stair 
sections are assigned a single number, while subsection numbers have two parts: a section number and subsection number 
separated by a hyphen.

To see the center of a stair section curve in plan view, click Show Arc Centers and Ends . See Arc Centers and Ends 

on page 225. 

ON MULTIPLE FLOORS

Stairs and ramps display on the floor level on which they are drawn.  If they are located beneath an Open Below room, they 
will be visible within the area of that room on the floor level above, as well.

To display exterior stairs on multiple floors, you can create a custom Reference Display Layer Set with just the stairs in 
question set to display. See The Reference Display on page 69.         

STAIR BREAKLINES

In plan view, staircases can display a breakline symbol. The portion of the staircase located above the breakline can display 
as either a dashed outline with transparency or it can be suppressed altogether. See Breakline Panel on page 789.          

A breakline can be added to a selected staircase in either of two ways:          

 l Click the Add Breakline  edit button.          

 l Check Has Breakline in the Staircase Specification dialog.          

A breakline’s position along the staircase can be adjusted using the small, circular Move Breakline edit handle that displays 
along the breakline, as well as in the Staircase Specification dialog.          

To remove a breakline from a staircase, click the Remove Breakline  edit button or uncheck Has Breakline.           

IN 3D VIEWS

Although stairs span between two floors, they can only belong to one floor. As a result, only multi-floor views show the 
upper floor with the platform opening and the lower floor with the staircase simultaneously. In Floor Overviews, stairwells 
may appear as an empty spaces. See 3D View Tools on page 1085.
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Editing Stairs and Ramps
Staircases and ramps can be selected and edited in plan view and 3D views. See Selecting Objects on page 212. 

To select a single section of a staircase, hold down the Shift key before clicking on it. When selected in this manner, a stair 
section can be edited independent of any other connected stair sections.          

USING THE EDIT HANDLES

When a staircase or ramp is selected, its edit handles display. These edit handles can be used to customize the selected 
object in many ways. See Editing Objects on page 207.

 l Straight stair sections and ramps are edited like lines. They have additional edit handles for resizing the width of the 
section. See Editing Line-Based Objects on page 218.

 l Curved stair sections and ramps are edited like arcs and also include edit handles for resizing the stair’s width. See 
Editing Arc-Based Objects on page 221.

 l Ramps can be resized to a maximum top height of  30” (760 mm). If you extend a ramp’s length to greater than 360” 
(9120 mm), its slope will decrease. For a taller ramp and control over the slope, uncheck Automatic Heights in the 
Ramp Specification dialog and specify the values you need. See General Panel on page 797.         

 l When stair sections are merged, the edit handles display differently depending on what subsection is currently 
selected. See Merging Stair and Ramp Sections on page 763.

 l When moving merged stair or ramp sections, all merged sections and landings move as one unless Stair Sections 
Move Independently is checked in the Preferences dialog. To temporarily enable this behavior, hold down the Alt key 
on the keyboard. See Architectural Panel on page 116 and Alternate on page 209.

 l Additional edit handles display on the first two treads of a staircase if the Starter Tread  edit button is clicked. See 

Starter Treads on page 771. 
 l Several additional edit handles display on a staircase if the Flare/Curve Stairs  edit button has been clicked. See 

Flared Stairs and Curved Treads on page 768.         

IN THE SPECIFICATION DIALOG

Stairs and ramps can be customized and their structure precisely defined in the Staircase and Ramp Specification 
dialogs. See Staircase Specification Dialog on page 782, Ramp Specification Dialog on page 796, and Stair Landing 

Specification Dialog on page 799.

Stair, ramp, and landing railings can also be customized. See Railing Panel on page 790, Newels/Balusters Panel on page 
794, and Staircase Specification Dialog on page 782.

USING THE EDIT TOOLS

A selected staircase or ramp can be edited in a variety of ways using the buttons on the Edit Toolbar. See The Edit Toolbar 
on page 135.

  Starter Tread allows you to create one or two rounded starter treads at the base of a selected staircase. See 
Starter Treads on page 771.

  Flare/Curve Stairs allow you to flare or curve the sides of the selected staircase's base. See Flared Stairs and 
Curved Treads on page 768.
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  Add Stair Breakline adds a breakline to the selected staircase while Remove Stair Breakline removes it. 
See Stair Breaklines on page 760.

  Auto Stairwell creates a Stairwell room on the floor above the selected staircase. See Creating a Stairwell on 
page 779.

ADJUSTING THE RADIUS OF CURVED STAIRS

The easiest way to match the radius of a stair  section to the radius of a curved wall is to draw a staircase near one side of the 
curved wall using the Draw Stairs  tool. The stairs snap to the wall, and the radius of the new staircase is defined. See 

Curved Stairs and Ramps on page 756.           

Existing curved stairs can be aligned with an existing curved wall by aligning their centers, much the same way that curved 
stairs on different floors can be aligned. See Aligning Objects on page 249.          

If there is no curved wall, the radius of a stair section can be aligned to a CAD arc or circle.          

To align curved stairs to an object
 1.  Align the centers of the CAD object and the staircase.           

 2.  Select the curved stairs and move the side nearest to the arc or circle edge using the Resize edit handle.           

Finally, restore the stair width by dragging from the other side handle or using the Stair Specification dialog.          

 

Stair and Ramp Sections and Subsections
In Chief Architect, staircases and ramps can be composed of multiple sections. In addition, each section can be broken into 
multiple subsections. 

 l Both sections and subsections can be curved while their neighbors are straight and can have different tread depths.
 l Stair sections can also have different tread widths, can be disconnected from adjacent sections using the edit handles, 

and are usually separated from other sections by landings.
 l Subsections both move and rotate as a single object, while sections move with other sections but rotate separately.

You can identify sections and subsections by clicking on a stair or ramp to select it: sections are identified with labels using 
whole numbers (1, 2, etc), while subsections are identified using hyphens (1-1, 1-2, etc). In addition, when a stair or ramp is 
selected, only the selected section will have edit handles. 

The selected section or subsection can be identified by the Move edit handle, which is red by default. See Selected Edge on 
page 214. 

CREATING STAIR AND RAMP SUBSECTIONS

There are several ways to create a stair section with multiple subsections:
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 l Draw one section, then draw a second section that begins at the first one’s endpoint.
 l Draw two separate segments, then snap the start point of one segment to the endpoint of the other using the edit 

handles. 
 l Draw one segment and use the Add Break  edit tool to divide it into two subsections. See Add Break on page 257.

CREATING STAIR AND RAMP SECTIONS

There are also three ways to create multiple stair sections:

 l Draw two separate stair sections and join them using a landing.
 l Use the Complete Break  edit tool to divide a section into two sections. See To create a complete break on page 

258.
 l Use the Disconnect Selected Subsection  edit tool to change a subsection into a section. 

MERGING STAIR AND RAMP SECTIONS

Any combination of straight and curved stair sections or straight and curved ramps using Automatic Heights can be 
merged. The resulting staircase or ramp section is made up of subsections and, if there are no landings, functions as a single 
unit. 

Stair and ramp subsections must be drawn in the same direction if they are to be merged: 

 l The top edge of a stair section or ramp cannot merge with the bottom edge of another section or ramp.
 l Combinations of stairs drawn in the UP and DOWN directions cannot be merged. 

Stair subsections merge at the center points of their upper and lower edges. 

Stair sections and ramps cannot be merged directly. If a combination of stairs and a ramp is required, connect them with a 
landing. See Landings on page 765.

To merge stair or ramp sections
 1.  Confirm that the stairs or ramps that you wish to merge are using Automatic Heights. See General Panel on page 

782.

 2.  Position the sections so they are in the desired relationship to each other. 

 l In order to merge stair sections correctly, they must be parallel to one another. 

 l To create merged subsections that change direction, make one of the merged sections curved and then specify 
Winders. See Winders on page 773.

 3.  Select either stair or ramp section so that its edit handles display.

 4.  Click the Extend handle on the end to be merged and drag it to the point where the two stairs or ramps are to meet. 
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A staircase consisting of merged subsections resembles a single stair section in plan view. The UP (or DN) arrows join, 
becoming a single direction arrow. 

When a subsection is selected, the entire staircase is selected. Additional edit handles, indicating the presence of multiple 
subsections and allowing you to reposition the line along which they join.  See Using the Edit Handles on page 761.

LOCK TREAD DEPTH

If a staircase with Lock Tread Depth selected in the Staircase Specification dialog is resized, its length increases or 
decreases one full tread at a time. See General Panel on page 782.           

When Lock Tread Depth is checked, it can be difficult to merge the section with another section or landing. If this is a 
problem, you can temporarily uncheck Lock Tread Depth. After the stairs are merged, the tread depth can be locked again.           

CURVED SUBSECTIONS

Stair subsections attached at both ends by other sections do not have a free end that can be dragged into a curve. In this 
situation, change the middle sub-section to a curve using the Change Line/Arc  edit button. See Change Line/Arc on 

page 259.

To curve an enclosed stair subsection
 1.  Draw three straight stair sections and connect them end to end.

 2.  Select the middle subsection.

 3.  Click the Change Line/Arc  edit button. The center section turns into a curved stair section. 

764



Chief Architect Premier X14 Reference Manual - Landings

 4.  Use the triangular Change Curve edit handle to adjust the curvature of the middle section as needed.

Stairs joined in this manner can be turned into winders, which are steps located where a staircase turns and are narrower on 
the inside of the turn than they are on the outside. See Winders on page 773.

 

Landings
Stair landings are platforms between stair sections and/or ramps, and can be created in either of five ways: 

 l Click and drag using the Landing  tool. 

 l Single-click using the Landing  tool to create a 3’-3” (975 mm) square landing. 

 l Click between two stair sections using the Draw Stairs  tool.

 l Convert a closed CAD polyline into a landing. See Convert Polyline on page 265.          
 l One or more landings are also created when the L-Shaped Stairs  or U-Shaped Stairs  tool is used.

To create a landing between stair sections
 1.  Draw two stair sections going UP. They can be at any angle.

 2.  Click between the two sections using the Draw Stairs  tool to create a landing. Notice that only one direction 

arrow displays after the sections are joined by a landing.

Similarly, a landing can be created between two ramps by clicking between them with the Ramp  tool active. 

Multiple stair sections and/or ramps can be connected to one landing. For example, two or three stair sections might meet at 
a landing with a single stair section continuing to the next level.

To be linked by a landing, all sections must be drawn in the same UP direction and the top of one section should be near the 
bottom of the next.

Stair sections connected with a landing will move together as a single unit unless Stair Sections Move Independently is 
checked in the Preferences dialog. See Architectural Panel on page 116.
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A landing formed between two stair sections having less than a 90º angle between them are created with a short edge not 
less than 6” (150 mm). This is because most building codes require the shortest tread to be at least 6” wide. This edge can 
be manually edited to less than 6” if needed.

ADJACENT LANDINGS

Some staircases have more than one landing adjacent to one another. When Auto Adjust Height is used, landings in Chief 
Architect recognize other nearby landings and will automatically adjust their heights and railings when their edges are 
sufficiently close to one another.

To create adjacent landings, draw two landings and then position them so that their edges are within 1” (25 mm) of one 
another. The landing that was drawn first will maintain its position while the height of the one drawn later will be the 
equivalent of one riser higher than the first. The railings on adjacent edges are suppressed, as well. 

Adjacent landings can be used to represent winders. See Winders on page 773.          

EDITING LANDINGS

Once created, landings can be selected in 2D and 3D views and edited like other closed-polyline based objects. See Editing 
Closed Polyline-Based Objects on page 230.

Landings derive their initial materials, height, thickness, and railings  from the stairs and/or ramps attached to them. You can 
assign a unique railing or material to a landing in the Stair Landing Specification dialog. See Stair Landing Specification 
Dialog on page 799.

When moving a landing, all stair or ramp sections connected to it move as one unless Stair Sections Move Independently 
is checked in the Preferences dialog. To temporarily enable this behavior, hold down the Alt key on the keyboard. See 
Architectural Panel on page 116 and Alternate on page 209.

LANDING HEIGHT AND THICKNESS

A landing’s height and thickness can either be dynamically controlled by the program or user-defined and static.

By default, landing top height and thickness are both set to Auto Adjust. This means that if the structure of the attached 
stairs is edited so that their length or riser height is affected, the landing’s height and thickness will adjust automatically to 
maintain consistent riser height in all connected stair sections.

If you uncheck either Auto Adjust box in the Stair Landing Specification dialog, the landing will maintain the specified 
height and/or thickness no matter how the attached stairs or ramps are modified. This can result in stairs that have 
inconsistent risers. See General Panel on page 800.

LANDING RAILINGS

By default, landings have railings on all edges, but will automatically suppress the railing along any portion of an edge that 
connects to a stair or ramp section or has an adjacent landing. You can specify whether this automatic behavior is used, the 
railing is suppressed, or the railing is always applied in the Stair Landing Specification dialog. See General Panel on page 
800. 

You can  also suppress the railing on a selected edge by clicking the Remove Railing from Selected Edge  edit button. 

To always generate the railing on a selected edge, click the Add Railing to Selected Edge  edit button. See Selected 

Edge on page 214. 
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Landings can be edited into a wide variety of shapes. So that the railings of stair sections connect properly to the landing 
railings, you may find it helpful to use the Add Break  edit tool to create a break in a landing edge if it is longer than the 

connecting stairs are wide. See Add Break on page 257.

 

Maintaining Tread Depth
Most building codes require staircases to maintain a consistent tread depth. 

WALK LINE

By default, Chief Architect measures a stair section’s length and tread depth along a Walk Line located 12" (30 cm) from 
the right edge of the stair section. On curved stairs, it is located 12” (30 cm) from the inside edge of the curve. 

The distance of the Walk Line from the staircase edge can be specified in the Staircase Specification dialog. See Style Panel 
on page 786.          

Alternatively, you can turn the Walk Line feature off and tread depth will be measured at the tread center.           

When a curved stair section has Automatic Treads specified in the Staircase Specification dialog and the Walk Line is 
used, the number and/or width of treads in a section or subsection changes when the inner edge is moved. For this reason, it 
is best to finalize stair section width as early as possible.

There are two ways to keep tread depth even throughout a stair section made of multiple subsections.          

LOCK TREAD DEPTH

The first way to maintain tread depth is to Lock Tread Depth to a specified value in the Staircase Specification dialog. See 
General Panel on page 782.           

Once locked, any changes to the length of the stair section are achieved by keeping the specified tread depth and changing 
the number of treads.           

IGNORE SUBSECTION BOUNDARIES

Curved stair sections typically have treads that are wider on one side than on the other. When they are connected to other 
stair sections, as with winders, it is possible to have treads that are too narrow at the Walk Line. See Winders on page 773.           

Uniform tread depth in a stair section with subsections can be maintained by checking Ignore Subsection Boundaries in 
the Staircase Specification dialog. See General Panel on page 782.           

When Ignore Subsection Boundaries is checked, the Tread Depth value may change when the stair section is edited, but 
will remain consistent throughout all subsections.            

Because the boundaries between stair sections are being ignored, the treads where a straight section joins a curved section 
may shift position or change angle to accommodate the adjustment.          
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Flared Stairs and Curved Treads
Any stair section can be flared and/or its treads curved using the Flare/Curve Stairs edit button. 

Only exposed sides of a stair section can be flared. If one side of a stair section is against a wall or wrapped (see Wrapped 
Stairs on page 774), only the exposed end can be flared. 

Flaring, curved treads, and special treads should be the last 
changes that you make to any stairs.

CREATING A FLARED STAIR

Flared stairs grow wider near one end, typically sweeping outward at the bottom. Stairs can also be flared at the top or on 
both ends.

To create flared stairs
 1.  Create the stairs and connect them to a landing, floor platform edge, or another stair section. 

 2.  Specify the section width, tread depth, and any other needed information.

 3.  Select the stairs and click the Flare/Curve Stairs  edit button. New Flare edit handles display on all four corners 

of the stairs.
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 4.  Drag one of the corner handles to flare that corner. As you drag the flare, the Status Bar shows the distance the side 
handle moves. This allows you to move the opposite handle the same amount.

 5.  When you are finished editing the flare, click the Main Edit Mode  to restore the stairs’ regular edit handles and 

toolbar buttons. 

SYMMETRICALLY FLARED STAIRS

Use the dimension information that displays in the Status Bar as a reference to create symmetric flares on both sides.

ADJUSTING THE FLARE RADIUS

After a flared staircase has been created, you may want to soften the radius of the flare.

The four handles at the sides and the four handles at the corners flare the stair section when dragged outward. The two 
handles in the center of the section move the starting point for flaring along the stair section.

To adjust the flare radius
First, adjust the curvature of the flared section.

 1.  Select the flared stair and click the Flare/Curve Stairs  edit button to access the flare handles again. 

 2.  Select the handle along the flared edge of the stair. Drag this handle outward very slightly. This forms a more 
gradual flare. 

Then, adjust the starting point of the flare:
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 1.  Select the flared stair and click the Flare/Curve Stairs  edit button to access the flare handles again. 

 2.  This time, drag the lower of the two central handles upward. The handle above it moves with it. This moves the start 
point for the bottom flare from the middle of the section toward its top, making the flare even more gradual.

TREADS PERPENDICULAR TO FLARE

Flared stairs often look best when the treads curve to meet the flared side perpendicular to the radius.

To curve the edges of flared treads
 1.  Select the flared stair and click the Flare/Curve Stairs  edit button to access the flare handles again. 

 2.  Drag a corner edit handle upward one tread depth or less.

 3.  When you are finished editing the curve, click the Main Edit Mode  to restore the stairs’ regular edit handles and 

toolbar buttons. 

This type of tread curving works only on flared edges and concentrates the curvature at that edge.

Flared treads can also be curved using the Curve edit handle, which curves the treads more uniformly.

CURVING THE TREADS

When treads are curved, all treads in the section show some degree of curvature. Treads close to the curved end have a 
greater curve than those at the opposite end, but both ends can be curved. 
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To curve stair treads
 1.  Select the staircase, then click the Flare/Curve Stairs  edit button. 

 2.  Drag the edit handle at the center of the bottom edge a small distance to curve the treads.

 3.  When you are finished editing the curve, click the Main Edit Mode  to restore the stairs’ regular edit handles and 

toolbar buttons. 

 

Starter Treads
The first and second treads of a staircase can be turned into starter treads by clicking the Starter Tread edit button. 
Starter treads extend to the side of the staircase, have rounded edges and are common on traditional staircases. 

A starter tread can be added only to open sides of a stair section. If one side of a stair section is against a wall or wrapped 
(see Wrapped Stairs on page 774), only the exposed tread end can become a starter tread. 
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To create starter treads
 1.  Click on a staircase to select it.

 2.  Click the Starter Tread  edit button. An edit handle displays on each end of both the first and second treads.

 3.  Drag either of the handles on the first tread outward from the stair section. If the stair section is against a wall, only 
one handle displays on the side opposite the wall.

 4.  As you drag, the ends of the tread become rounded.

 5.  Two additional edit handles display on each side of the tread, along the back edge. 

 6.  Drag either of the two square handles upward to increase the width of the rounded ends of the tread. 

 7.  Drag the edit handle on the second tread outward from the stair section to create a second starter tread. 

 8.  To make changes to existing starter treads, select the stairs, click the Starter Tread  edit button and repeat the 

above steps as needed. 
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 9.  When you are finished editing the starter treads, click the Main Edit Mode  to restore the stairs’ regular edit 

handles and toolbar buttons. 

 

Winders
Winders are steps located where a staircase turns and are narrower on the inside of the turn than they are on the outside. A 
staircase defined as a winder expands to fill in any gaps between the side of the stairs and nearby walls.           

Curved stair sections are typically used to create winders, although straight stairs can also be used. See Curved Stairs and 
Ramps on page 756.          

To create winders
 1.  In an enclosed room area, place and connect the stair sections that you want to be winders. For best results:          

 l The stairs should be two straight sections connected by a curved section between them;          

 l The curved section should be adjacent to a 90° corner, as illustrated.          

It is often easiest to create the staircase configuration in an 
open space, away from walls, then move it into position in a 

wall corner before specifying it as Winders. 

 2.  Select the staircase and click the Open Object  edit button to open the Staircase Specification dialog.           

 3.  On the GENERAL panel, place a check in the Winders check box and click OK.           

 l The stairs should be two straight sections connected by a curved section between them;          

 l The curved section should be adjacent to a 90° corner, as illustrated.          

It is often easiest to create the staircase configuration in an 
open space, away from walls, then move it into position in a 

wall corner before specifying it as Winders. 

 4.  Select the staircase and click the Open Object  edit button to open the Staircase Specification dialog.           

 5.  On the GENERAL panel, place a check in the Winders check box and click OK.           

 6.  The steps nearest the wall corner adjust their shapes and extend into the corner after the stair is changed to a winder.           

Winders must be in a room with valid room definition. You 
cannot create winders in an area composed of only 2 corner 

walls. If this configuration is needed, enclose the area in with Invisible 
walls so that a room area is defined.

The Winders attribute directs the stair section to expand or contract to meet  nearby walls, and can also be used to create a 
partial railing. See Partial Railings on page 777.          
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Winders sometimes have treads that are too narrow at the inside curve. The Ignore Subsection Boundaries option can 
address this issue. See Ignore Subsection Boundaries on page 767.          

In situations where the conditions for stair winders cannot be met, you can use adjacent landings. See Landings on page 
765.          

 

Wrapped Stairs
Check Allow Wrap on the STYLE panel of the Staircase Specification dialog and the selected stairs can be wrapped around 
the corner of a deck or landing. Curved stairs and stairs with multiple subsections cannot be wrapped. See Style Panel on 
page 786.

Stair sections that wrap around a corner to meet one another must have identical attributes. As a result, edits made to one 
wrapped stair section apply to all adjacent, wrapped sections.           

To wrap stairs around a deck
 1.  Begin by drawing a deck. See Decks on page 430. 

 2.  Use the Straight Stairs  tool to place a stair section on each side of the corner around which you want them to 

wrap.

 3.  Move the stair sections toward the corner of the deck. When the two sections are sufficiently close to the corner, 
they will merge to form wrapped steps.

You can also draw stairs down from a deck by right-clicking to 
draw them or by pressing the Alt key while you drag. See To 

draw stairs going downward on page 757.

To wrap stairs around a landing
 1.  Use the Draw Stairs  tool to create two perpendicular stair sections with top ends that share a corner. 

 2.  Click between them to create a landing.

 3.  Rotate one stair section 180°. 
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 4.  The stairs wrap around the corner. Notice that the Up arrow displays on the most recently edited stair section.

 

Other Special Railings and Stairs
Stairs can be customized to meet a variety of needs.

SOLID RAILINGS

To create a solid rail along a staircase, position a solid Railing against, but not underneath, the stairs. Specify it as 
Solid and that it Follow Stairs. See Rail Style Panel on page 412.

The solid railing recognizes the adjacent stairs and climbs alongside them. 
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If any balusters extend beyond the railing, eliminate them by unchecking Left Railing or Right Railing in the Staircase 
Specification dialog. See Style Panel on page 786.

FULLY HOUSED STRINGERS WITH BALUSTERS

Fully housed stringers with balusters can also be created by positioning a pony wall next to the stairs.          

To create fully housed stringers
 1.  Create a staircase, then select the stairs and click the Open Object  edit button.             

 2.  On the STYLE panel of the Staircase Specification dialog, uncheck Stringer at Wall and click OK.             

 3.  Draw an Interior Wall  or Half Wall  against, but not underneath, the stairs.             

 4.  Select the wall and click the Open Object  edit button.             

 5.  On the GENERAL panel of the Wall or Railing Specification dialog, make sure Railing is checked.             

 6.  On the WALL TYPES panel:             

 l Check Pony Wall.                 

 l Specify the Lower Wall Type as the same interior wall as the upper wall.                 

 l Specify the Elevation of Lower Wall Top. This value should equal the stairs’ riser height plus the height above 
the treads.                 

 7.  On the RAIL STYLE panel:             

 l Check Follow Stairs.             
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 l Specify desired Railing Height.             

 l Click OK.             

Note: To create housed stringers, check Trim Against Wall in the 
Staircase Specification dialog. See Stringers Panel on page 787.

PARTIAL RAILINGS

A staircase can be enclosed on one side by a combination of wall and railing.          

Partial railings can be created by creating a staircase composed of two sections, each with a different tread width. See Stair 
and Ramp Sections and Subsections on page 762.       

To create a partial stair railing
 1.  Create a staircase and draw an Interior Wall  against, but not underneath, the stairs.         

 2.  In plan view, select the stairs and click the Add Break  edit button. See Add Break on page 257.      

 3.  Next, click the Complete Break  edit button.

 4.  With Object Snaps  enabled, click once on the stairs where they meet the end of the interior wall to add a 

complete break to the stairs at that location. The staircase is broken into two separate sections. See Object Snaps on 
page 164.       

 5.  Select the stair section that is not adjacent to the interior wall and, using either its edit handles or its specification 
dialog, increase its tread width.    

 6.  You may need to Zoom  in on the stairs and wall to move the stair edge.             
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RAILING PANELS

You can specify panels, including glass panels or cables, as a stair or ramp’s railing in the Staircase and Ramp Specification 
dialogs. See Railing Panel on page 790.         

INSET OR MIDDLE RAILING

You can use a Railing  to create inset stair railings or a middle railing.         

To use railing panels with stairs
 1.  Create a staircase and draw a Railing  under the stairs.         

 l Make sure that the railing is located entirely within a single stair section.         

 l Position it so that it is aligned with the left edge.         

 2.  Select the railing and click the Open Object  edit button. See Wall Specification Dialog on page 395.         

 3.  On the RAIL STYLE panel of the Railing Specification dialog:         

 l Select the Panels radio button.         

 l Check Follow Stairs.         

 4.  On the NEWELS/BALUSTERS panel, click the Browse button to the right of Panel Type and select the railing panel 
you want to use on the stairs, then click OK.         

 5.  Select the staircase and click the Open Object  edit button.         

 6.  On the NEWELS/BALUSTERS panel of the Railing Specification dialog, uncheck Left Railing to prevent the default 
stair railing from generating in addition to the railing panel.         

 7.  Repeat these steps if you want railing panels under the right side of the stairs, as well.         

CONCRETE STAIRS

To make a solid concrete staircase
 1.  Select the stairs and click the Open Object  edit button.    

 2.  On the STYLE panel of the Staircase Specification dialog:         

 l Set the Tread Overhang to zero.         

 l Set the Tread Thickness to zero.         
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 l Uncheck Open Risers. 

 l Uncheck Open Underneath.

 3.  On the STRINGERS panel, you can also check Large Stringer Base.         

 4.  On the MATERIALS panel, specify the “Riser/Trim”, “Support Wall”, and “Tread” materials as concrete.         

MASONRY STAIRS

To make a set of masonry stairs
 1.  On the STYLE panel of the Staircase Specification dialog:         

 l Set the Tread Overhang to zero.         

 l Set the Tread Thickness to the thickness of the masonry material.         

 2.  On the MATERIALS panel, assign the desired masonry material to the “Tread” component and specify the 
“Riser/Trim” material as concrete.         

STEEL STRINGER

To make a steel stringer with concrete treads
 1.  On the STYLE panel of the Staircase Specification dialog:         

 l Check Open Underneath.         

 l Set the Tread Thickness to 2 inches or more.         

 2.  On the STRINGERS panel, select 1 Center Stringer.         

 3.  On the MATERIALS panel, specify the “Tread” material as concrete and the “Riser/Trim” material as steel.         

 

Creating a Stairwell
An interior staircase must be located in a stairwell, an opening to the floor above. A stairwell is an Open Below room type 
on the floor above. See Room Types and Functions on page 420.

If you create a stairwell away from other walls so the Open Below is created in the center of another room, connect a wall 
of the Open Below room to another wall using an invisible wall. 
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CREATING A STAIRWELL AUTOMATICALLY

To create a stairwell that matches the perimeter of a selected staircase, click the Auto Stairwell edit button. This 
button is only available when a living space exists above the staircase. It will not be available if the space above is 

Open Below or on the Attic Floor.

Auto Stairwell automatically creates a room on the floor above enclosed by railings, defined as Open Below in the Room 
Specification dialog, and given a Stairwell room label. This room can be selected and edited like any other room.

CREATING A STAIRWELL MANUALLY

Stairwells can also be created manually. 

To create a manual stairwell
 1.  Draw a two-story building. Create the staircase on the first floor.

 2.  Make the second floor the Current Floor and the first floor the Reference Floor. See The Reference Display on 
page 69.

 3.  Select Tools> Floor/Reference Display> Reference Display  to show the Reference Floor, including the stairs. 

 4.  On the upper floor, use the Railing  tool to create a room around the stairs. Use the edit handles to position the 

railings as needed. 

 5.  Select the railings one at a time and move them into position. 

 l When a railing is selected, its bounding box shows the location of the outer surface of the railing’s drywall layer. 
For best results, this outer surface (which does not display when the railing is not selected) should meet the top 
edge of the stairs. See Wall Types and Railings on page 354.

 l If you prefer, you can also go Down One Floor  and adjust the top edge of the staircase to snap it to the 

surface of the railing on the floor above.

 6.  When the railings are positioned properly, select Tools> Floor/Reference Display> Reference Display  to turn 

off the display of the Reference Floor.

 7.  Click inside the room using the Select Objects  tool to select it, then click the Open Object  edit button.

 8.  On the GENERAL panel of the Room Specification dialog, select “Open Below” from the Room Type list. Click OK 
to close the dialog.
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 9.  Place a Doorway  in the railing at the top step for an opening. 

 10.  Select the doorway and define a large width in the Door Specification dialog. If the doorway is specified wider than 
the railing, its width adjusts to fit the available space.

 

Rooms Below Staircases
Rooms such as closets or storage areas are commonly located beneath staircases.         

To create a room below a staircase
 1.  Draw a staircase, select it, and click the Open Object  edit button to open the Staircase Specification dialog. See 

Staircase Specification Dialog on page 782.         

 l If Winders are specified for this staircase, set Max Tread Contraction to 2" on the STYLE panel to allow walls to 
be built entirely under the staircase.          

 l On the FILL STYLE panel, select “No Pattern” so the walls and other objects under the stairs can be seen.         

 2.  On the same floor as the staircase, draw the Interior Walls  under them, following their shape.

 3.  Reposition the walls as needed, making sure that each is entirely under the stairs.         

 4.  The wall at the foot of the stairs should be placed no closer to the bottom than the second step.         

 5.  Add a door and specify the Room Type.         
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Staircase Specification Dialog
Staircases can be defined with the greatest accuracy in the Staircase Specification dialog. To open this dialog, select 
one or more staircases and click the Open Object edit button, or double-click a stair section using the Draw Stairs 

, Straight Stairs , or Select Objects  tool. 

If a staircase is composed of multiple stair sections, the section that you clicked on to select the staircase is the Selected 
Section; however, information about all the sections is available and can be edited in the dialog. 

The settings in the Staircase Specification dialog are similar to those in the Interior and Exterior Stair Defaults dialogs, but 
affect the selected staircase only. See Stair and Ramp Defaults on page 753.         

The Staircase Specification dialog has the following panels:         

It is recommended that all floor heights, ceiling heights and 
platform thicknesses be established before using the Staircase 

Specification dialog.

GENERAL PANEL

782



Chief Architect Premier X14 Reference Manual - Staircase Specification Dialog

 
Staircase Information

Structural information about the selected staircase displays here for reference and updates as changes are made on the 
GENERAL panel.     

 l The first comment tells whether or not the staircase reaches the next level, which may be a floor platform or locked 
landing. It also indicates whether its rise angle is either steeper or more shallow than the Best Fit, described below. If 
Automatic Heights is unchecked, this comment instead says “Start and end heights are set manually”.     

 l The second comment, Best fit riser height of ___ requires ___ total risers to reach ___ to next level, describes 
the ideal rise and run for the selected staircase. The program defines the Best Fit Riser Height as the riser height 
closest to 6 3/4” (168.75 mm) that allows the selected staircase to meet the next level precisely.  This comment is 
only active if Automatic Heights is checked, below.

  If the staircase includes a landing with a user-specified height, that height is used to calculate this information. See Landing 
Height and Thickness on page 766.           

 l The total number of stair Sections, Landings, and Risers associated with the selected staircase also display here.    

 l The Rise Angle of the currently active stair section also displays here.

 l Click the Make Best Fit button to add or remove risers to the Selected Section. Only available when Automatic 
Heights is checked and the staircase does not currently use the Best Fit Riser Height. 

  Make Best Fit will also extend stairs drawn in a downward direction until they reach the terrain. See Terrain Perimeter on 
page 1250.     

A diagram of a sample staircase’s structure displays here for reference, as well. 

783



Chief Architect Premier X14 Reference Manual - Staircase Specification Dialog

 
Advanced Options

The Advanced Options apply to all sections and subsections.

 l Select Automatic Treads to have the program define the depth and number of stair treads. If the staircase has 
multiple sections, each may have different tread depths. 

 l Select Lock Tread Depth to specify the Tread Depth for each stair section, below, and prevent them from changing. 
When Lock Tread Depth is selected and the length of the stairs is changed, the number of treads will change.

 l Select Lock Number of Treads to specify the number of treads in each stair section and prevent it from changing. 
When Lock Number of Treads is selected and the length of the stairs is changed, the tread depths will change.

 l If multiple staircases or a staircase with multiple sections is selected, No Change may be an option as well. Select 
this to maintain the multiple sections’ individual settings. 

 l Uncheck Automatic Heights if you would like to specify the bottom and top heights of each stair section, as 
measured from the default floor height of Floor 1, 0” (mm). When checked, the program automatically defines the 
top and bottom heights by precisely locating floor platforms and landings.               This option cannot be disabled in the 
Interior and Exterior Stair Defaults dialogs.

The Top Height Reference values control what point on the staircase the Top Height value, below, describes.

 l Select Floor/Landing for the Top Height value to describe the height of the top tread plus the stated Riser Height.          

 l Select Top Riser for the Top Height value to describe the height of the top riser.           

 l Check Ignore Subsection Boundaries to maintain tread depth throughout a stair section composed of merged 
subsections, regardless of whether the subsections have different tread depths assigned to them. See Ignore 
Subsection Boundaries on page 767.          

 l Select Lock Bottom to lock the position of the selected stair section’s bottom end to prevent it from moving. 
Sections and landings below the selected section do not move when you click OK, while those above do move.           

 l Select Lock Top to lock the position of the selected stair section’s top end to prevent it from moving. Sections and 
landings above the selected section do not move when you click OK, while those below do move.          

  Lock Bottom and Lock Top are actions rather than settings and are not available in the Stair Defaults dialogs. If you 
make changes to a staircase that will affect its length, first lock either the bottom or top end of the Selected Section to 
prevent it from moving. The height of the Selected Section’s locked end is not affected by these settings - only its 
position on the X/Y axis.         

If you select a staircase by clicking near its bottom end, Lock 
Top will be selected; if you select it near its top end, Lock 

Bottom will be selected. 
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Specifications

The specifications for each stair section and subsection are listed and can be edited here. Up to ten items total can display.    

A change in one value usually affects other values. You may need to reposition the staircase after making changes.

 l The Section Number column identifies the Selected Section and the number of each section of the selected 
staircase. If Ignore Subsection Boundaries is unchecked, subsection numbers are also identified. The radio button 
to the left indicates which section or subsection is selected. See Displaying Stairs, Ramps, and Landings on page 
759.

 l Define the Length, or run, of each section or subsection measured along the Walk Line. The length is equal to the 
number of treads multiplied by the tread depth. See Walk Line on page 767.

When the length of a section changes, other sections and landings in the staircase unit move in response. You can specify 
whether the bottom or top edge of the Selected Section moves when you resize it by selecting either the Lock Bottom or 
Lock Top radio button, above.

 l Define the Width of each section. Only one width can be defined for a section, so all subsections in the same section 
have the same width. If a section is connected to a landing, its width should equal the length of the landing edge that 
it connects to. See Landings on page 765. 

 l Specify the Tread Depth, or run, of each stair tread in the selected section. To lock this value, check Lock Tread 
Depth, above.

If a landing is created between two stair sections and one of them has locked tread depth, the resulting staircase also has 
locked tread depth. Any landings or sections connected to this new staircase adjust to meet it and then have locked tread 
depth as well.

 l Define the number of Treads in a stair section or subsection. To lock this value, select Lock Number of Treads, 
above.

 l Define the Bottom Height, the height of the stair section’s bottom edge. To lock this value, click the radio button to 
the left of the section’s number, then click the Lock Bottom radio button, above, and click OK.         

 l Define the Top Height, the height of the stair section’s top edge. To lock this value, click the radio button to the left 
of the section’s number, then click the Lock Top radio button, above, and click OK. 

 l Define the Riser Height, the height of the risers in each stair section. 

 l Check Winders to specify the Selected Section, including subsections, as winders. See Winders on page 773.           

 
Preview

A preview of the selected staircase displays on the right side of the panel. If the staircase includes any landings, only the 
section that was selected when the dialog was opened will display. See Dialog Preview Panes on page 22. 
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STYLE PANEL

 
Tread

See Anatomy of a Staircase on page 755.

 l Specify the Tread Overhang, which is the distance that each tread overhangs the riser.

 l Specify the Tread Thickness.

 
Open Options

The Open Options control whether the selected stairs have open risers or an open underside. 

 l Check Open Risers to eliminate the riser face under each tread and expose the stringers.

 l Uncheck Open Underneath to add a skirt below the staircase along the two sides. It looks like a wall in 3D, but 
only has a single face. Base molding does not generate along the bottom of the skirt, and doors cannot be placed in 
it. In most cases, the recommended way to enclose the area beneath stairs is to use walls. See Rooms Below 
Staircases on page 781.

 l Specify the Side Inset of the skirt below the staircase. The default value of 0 aligns the skirt with the outside of the 
surface of the stringers. Only available when Open Underneath is unchecked.          

 
Runner

Specify the attributes of the staircase’s carpet Runner. Only available when Open Risers is unchecked, above.

 l Specify the Runner Width. The default value of 0 does not create a runner. 

 l Uncheck Runner Tucked to have the runner drop straight down from the tread front to the riser below. This is 
checked by default. 
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Winder

Define the Max Tread Contraction, which is the amount a tread’s width may be reduced when it meets a wall. See Partial 
Railings on page 777.
This option only takes effect when the stairs are specified as Winders on the GENERAL panel. See General Panel on page 
782.

 
Use Walk Line

See Walk Line on page 767.    

 l Check Use Walk Line to have the program calculate the tread depth based on a Walk Line. Uncheck the box to 
disable this function.    

 l Specify the distance of the Walk Line from Edge. The default value is 12” (300 mm).          

 l Check Show Walk Line to show the Walk Line in plan view.          

 
Top Landing

Specify the appearance of the staircase where it meets the next floor platform. These options do not affect the edges of 
landings.                 

 l Check Nosing at Top Landing to produce tread nosing attached to platform edge at the top of stairs.         

 l Check Riser Surface at Top Landing to produce a riser surface against the platform edge at the top of the stairs. 
This allows stair risers to match all the way to the top of the platform.         

  Options

 l Check Automatic Railing Openings to automatically create a doorway opening when the selected stairs are snapped 
to a railing drawn on the same floor as the stairs. This is checked by default.           

 l Check Allow Wrap to wrap the selected stairs around the corner of a deck or landing where another, identical stair 
section is present. See Wrapped Stairs on page 774.           

 
Preview

A preview of the selected staircase displays on the right side of the panel. If the staircase includes any landings, only the 
section that was selected when the dialog was opened will display. See Dialog Preview Panes on page 22. 

STRINGERS PANEL

The settings on the STRINGERS panel affect all sections of a selected staircase.         
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  Stringer Style

 l Click a radio button to specify the number of stringers assigned to the staircase.              Select Custom Stringers to enable 
the Left, Middle, and Right settings below.

 l Specify the Height Above Tread, measured straight down from the top outer edge of the tread nosing to the top of 
the stringer. Only available when 2 Closed Side Stringers is selected, above.          

 l Specify the Height Below Tread, measured straight down from the back bottom edge of the tread to the bottom of 
the stringer. Not available when Custom Stringers is selected, above.         

The Left, Middle, and Right settings are enabled when Custom Stringers is selected. For each of these:          

 l Specify the Count for each stringer location. Multiple Left and Right stringers are butted side to side while multiple 
Middle stringers are evenly spaced between them.          

 l Specify the Thickness, measured horizontally.           

 l Specify the Offset of each stringer from its default location. A positive value offsets the stringer(s) to the right; a 
negative value offsets them to the left.           

 l Specify the Height Below the treads, measured straight down from the back bottom edge of the tread to the bottom 
of the stringer.           

 l Check Ext to specify the stringer(s) as Exterior and allow them to extend up past the top of the stair treads.           

 l Specify the Height Above the stair treads, measured straight down from the top outer edge of the tread nosing to the 
top of the stringer.          

 l The vertical Depth of the stringers is reported here for reference. This value is affected by the Heights above and 
below the treads, as well as the stairs Rise Angle.          
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Trim Against Wall

Specify the attributes of the Trim Against Wall that generates when the staircase is positioned against a wall.  

 l Specify the Height Above Tread, measured straight down from the top outer edge of the tread nosing to the top of 
the tread.           

 l Specify the Height Below Tread, measured straight down from the back bottom edge of the tread to the bottom of 
the trim.           

 l Specify the Thickness of the trim, measured horizontally.           

 l Clip Top - Specify whether to clip the top of the trim where it meets the upper floor level. Trim can be clipped on 
the Left and/or Right sides of the staircase.          

  Options

 l Extend Stringer Top is checked by default and extends a triangular portion of the stringer under the landing or 
platform at the top of the stairs.          

 l Check Large Stringer Base to widen the stringers at the foot of the staircase. This is helpful when walls are created 
below the stairs.         

 
Preview

A preview of the selected staircase displays on the right side of the panel. To see the stringers, click in the preview and drag 
upward to rotate. See Dialog Preview Panes on page 22. 

BREAKLINE PANEL
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Has Breakline

Check Has Breakline to display a breakline on the selected stairs and enable the settings that follow.          

 l Select the breakline symbol Style from the drop-down list.             

 l Specify the Distance from Start, which is the distance from the front of the stairs to the breakline, measured from 
the staircase’s center line.              

 l Specify the Breakline Angle. An angle of 0° produces a breakline that is perpendicular to the sides of a straight 
stairwell.             

 l Specify the Gap After Break, which is the gap between the section of the stairs located below the breakline and that 
located above it. A value of 0 produces no gap.             

 l Specify the Break Symbol Size, which is the total height of the break symbol measured from top corner to bottom 
corner.              

 
Current Floor Display

The Current Floor Display settings control the appearance of the portion of the staircase located After the Breakline, or 
upslope from it, on the floor where the stairs were drawn.          

 l Select Normal to display the staircase after the breakline using the same Line and Fill Styles as the portion located 
before the breakline.              

 l Select Outline to display the staircase after the breakline using the Line Style assigned to the “Stairs & Ramps, 
Details” layer and a transparent fill.              

 l Select Nothing to hide the display of the staircase after the breakline entirely.              

 
Floor Above Display

The Floor Above Display settings control the appearance of the portion of the staircase located Before the Breakline, as 
seen from the floor above the stairs.          

 l Select Normal to display the staircase before the breakline using the same Line and Fill Styles as the portion located 
after the breakline.              

 l Select Outline to display the staircase before the breakline using the Line Style assigned to the “Stairs & Ramps, 
Details” layer and a transparent fill.              

 l Select Nothing to hide the display of the staircase before the breakline entirely.              

Note: Stairs located on the floor below can only be seen if a Stairwell 
room is defined above them. See Creating a Stairwell on page 779.

 
Preview

A preview of the selected staircase displays on the right side of the panel. If the staircase includes any landings, only the 
section that was selected when the dialog was opened will display. See Dialog Preview Panes on page 22.         

RAILING PANEL

By default, the settings on the RAILING panel also affect the railings on any landings attached to the selected staircase or 
ramp. See Landings on page 765.           

This panel is also found in the Ramp and Landing Specification dialogs.
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  Railing

 l Stair Rail Height defines the height from tread surface directly over the riser to railing top.         

 l Landing Rail Height defines the height of the landing rail top from the landing surface.         

 l Railing On - Select Left and/or Right to specify placement of railings on stair sections.         

 l Railing at Wall - Select Left and/or Right to specify the placement of wall railings. Not available for ramps.         

 l Check Railing Transitions on Left and/or Right to create “gooseneck” connections between stair and landing 
railings. This option only has an effect when Rail Passes Over Newel is checked. Not available for ramps.          

 l Check Smooth Transitions on Left and/or Right to specify the placement of smooth connections between stair and 
landing railings. Not available for ramps.           

 l Check both Railing Transitions and Smooth Transitions to produce a handrail like this:          
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  Style

 l Select Balusters to create regularly spaced balusters between larger newel posts.         

 l Select Open to create with only newels posts.          

 l Select Open with Middle Rail to create railings with newel posts and a middle rail.          

 l Select Panels to create railings composed of panels. The panel style is specified on the NEWELS/BALUSTERS panel. 
See Newels/Balusters Panel on page 794.         

  Top/Bottom Rail

 l Check Include Handrail/Top Rail to produce a top rail on the stair railings that receives the top baluster ends and 
typically acts as a handrail.          

 l Check Include Bottom Rail to place a low rail on the landing surface that receives the balusters ends.          

 l Check Raise Bottom, then specify the distance to raise the bottom rail or panel from the stair tread.         

  Handrail Options

 l Specify the Extend Top End value, which is the distance that the top of each railing section extends past the top 
riser of its corresponding stair section.        

 l Specify the Extend Bottom End value, which is the distance that the bottom of each railing section extends past the 
bottom riser of its corresponding stair section.        

 l Specify where to Add Return to Wall:       

 o Check Top End to add a return to the wall at the top end of all railing sections that are against a wall.        

 o Check Bottom End to add a return to the wall at the bottom end of all railing sections that are against a wall.      
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Brackets

Click the Library button to apply a 1/4” (2 mm) thick decorative bracket to the exposed sides of the stringers, under each 
riser. A side stringer with brackets will be moved in 1/4” (2 mm) to accommodate the bracket. See Select Library Object 
Dialog on page 982.

 
Preview

A preview of the selected staircase displays on the right side of the panel. If the staircase includes any landings, only the 
section that was selected when the dialog was opened will display. See Dialog Preview Panes on page 22.          

NEWELS/BALUSTERS PANEL

The settings on the NEWELS/BALUSTERS panel will also affect the appearance of railings on any landings attached to the 
selected staircase. See Landings on page 765.         

These settings are similar to those found on the same panel of the Ramp and Landing Specification dialogs. See Ramp 
Specification Dialog on page 796.         
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Newels

 l Uncheck Has Newel Posts to prevent newels from generating in the selected staircase’s railings. When this box is 
checked, newels are generated and can be edited using the settings that follow.

 l Type - Select Square, Round, or newels from the Library. Selecting Library from the drop-down list is the same 
as clicking the Library button to the right and allows selection of a newel from the library.

 l Specify the Width, which is the width or diameter of each newel. For Library newels, this is the width at its widest 
point.

 l Specify the Height, which is the height from the landing surface to the top of the newel. Only available when Rail 
Passes Over Newel is unchecked below.

 l Specify the Offset, which is the amount each newel is offset from the center of the railing.

 l Specify the on-center Spacing of the newel posts.

 
Balusters

The first three Balusters settings are similar to the Newels options of the same names, above.         

 l Cut Baluster Top - Each tread normally has two to three balusters, growing longer toward its back. The default is to 
use the same baluster and cut it off at the bottom to shorten it toward the tread front. Check this box to cut the 
balusters at the top instead.         

 
Panels

These settings are only available when the railing Style specified as “Panels” on the Railing Panel on page 790.

 l Specify the panel’s Thickness.         

 l Select “Solid” or “Library” from the Type drop-down list.         

You can also apply newels, balusters, and panels onto stair 
or ramp railing directly from the Library Browser. See 

Inserted Objects on page 981.    

 
Plan Display

These settings the display of newels, balusters, and rails in plan view. See In Plan View on page 759.                 

 l Uncheck Use Defaults to enable the settings that follow. When this is checked, the options set in the Staircase 
Defaults dialog are used.

 l Check Draw Newels to display newel posts in plan view. Note that newels at the top of the staircase are associated 
with the railings defining the stairwell. See Creating a Stairwell on page 779. 

 l Check Draw Balusters to display balusters in plan view.

 l Check Draw Rails to display the handrails in plan view.

 l Click the Fill Style button to open the Fill Style dialog and specify the fill style for newels, balusters, and/or rails, 
when set to display.

To display newels/balusters under the handrails, specify a Fill Style of “None”. 
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Preview

             A preview of the selected staircase displays on the right side of the panel. If the staircase includes any landings, only the 
section that was selected when the dialog was opened will display. See Dialog Preview Panes on page 22.          

RAILS PANEL

The settings on the RAILS panel are similar to those on the RAILS panel of the Wall Specification dialog as well as the 
MOLDINGS panel of a variety of other dialogs. See Moldings / Profiles Panels on page 943.

By default, the settings on the RAILS panel will also affect the appearance of railings on any landings attached to the 
selected staircase. See Landings on page 765. 

LINE STYLE PANEL

The settings on the LINE STYLE panel are available for a variety of other objects in the program. For information about these 
settings, see Line Style Panel on page 310.

FILL STYLE PANEL

The settings on the FILL STYLE panel affect the appearance of the selected staircase in plan view. For information about 
these settings, see Fill Styles on page 197.

MATERIALS PANEL

The settings on the MATERIALS panel affect the appearance of the selected staircase in 3D views and are available for a 
variety of objects throughout the program. For information about these settings, see Materials Panel on page 1055.

The settings on this panel will also affect the materials applied to any landings attached to the selected staircase. See 
Landings on page 765.

ARROW PANEL

The settings on the ARROW panel control the appearance of the selected staircase’s direction arrow in plan view. See In Plan 
View on page 759.          

For information about these settings, see Arrow Panel on page 312.          

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. See Components Panel on page 1335.          

 

Ramp Specification Dialog
Ramps can be defined with the greatest accuracy using the Ramp Specification dialog. To open this dialog, select one 
or more ramps and click the Open Object edit button or double-click a ramp section using the Ramp  or Select 

Objects  tool. 

The Ramp Specification dialog has the following panels:         
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GENERAL PANEL

 
Diagram

A diagram of a sample ramp’s structure displays here for reference. 

 
Size

Specify the Ramp Length and Width.

 
Heights

Specify the Heights of various key locations on the selected ramp.                  

 l Uncheck Automatic Heights/Slope to activate the settings below, then specify the height and slope of the ramp. 

 l Specify the Top Height, which is the height of the ramp at its high end.

 l Specify the Bottom Height, which is the height of the ramp at its low end.

 l Specify the Base Height, which is the height of the bottom surface of the ramp.
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Slope

Specify the ramp’s Slope by typing its Rise value in the first field, and the Run value in the second field. See Anatomy of a 
Staircase on page 755. 

  Options

 l Check Automatic Railing Openings to automatically create a doorway opening when the selected ramp is snapped 
to a railing drawn on the same floor as the ramp. This is checked by default.

 l Check Open Underneath to remove the skirt around the bottom of the ramp so that it has a uniform, sloped 
thickness that may not reach the floor or terrain at the high end. This is unchecked by default.

 l Specify the Max Thickness, which is the ramp’s maximum thickness. At the low end of the ramp where it meets the 
floor or terrain, its thickness may be less than this value. 

 
Tread

Specify the structure of the ramp’s Tread, which an optional surface layer placed over the top of the ramp.

 l Check Has Tread Surface to apply a top tread surface to the ramp and enable the settings below. 

 l Specify the Tread Overhang, which is the distance the tread surface extends past the ramp’s edges. 

 l Specify the Tread Thickness, which is the tread surface’s vertical depth. 

 
Preview

             A preview of the selected ramp displays on the right side of the panel. If the ramp is composed of multiple sections 
separated by landings, only the section that was selected when the dialog was opened will display. See Dialog Preview 
Panes on page 22.          

SELECTED LINE/ARC PANEL

The SELECTED LINE panel is available when the selected ramp segment is a line as opposed to an arc. For more information, 
see  Line Panel on page 309.         

The SELECTED ARC panel is available when the selected ramp segment has been converted to an arc. For more information, 
see Arc Panel on page 318.         

See, too, Selected Edge on page 214 and Change Line/Arc on page 259.          

RAILING PANEL

The settings on the RAILING panel are similar to those on the same panel in the Staircase Specification dialog. For 
information about these settings, see Railing Panel on page 790.         

By default, the settings on this panel will also affect the appearance of railings on any landings attached to the selected 
ramp. See Landings on page 765.         

NEWELS/BALUSTERS PANEL

The settings on the NEWELS/BALUSTERS panel are similar to those on the same panel in the Staircase Specification dialog. 
For more information, see Newels/Balusters Panel on page 794.         

By default, the settings on this panel will also affect the appearance of railings on any landings attached to the selected 
ramp. See Landings on page 765.         
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RAILS PANEL

The settings on the RAILS panel are similar to those on the RAILS panel of the Staircase Specification dialog as well as the 
MOLDINGS panel of a variety of other dialogs. See Moldings / Profiles Panels on page 943.         

By default, the settings on this panel will also affect the appearance of railings on any landings attached to the selected 
ramp. See Landings on page 765.         

LINE STYLE PANEL

The settings on the LINE STYLE panel are available for a variety of other objects in the program. For information about these 
settings, see Line Style Panel on page 310.         

FILL STYLE PANEL

The settings on the FILL STYLE panel affect the appearance of the selected ramp in plan view. For information about these 
settings, see Fill Styles on page 197.         

MATERIALS PANEL

The settings on the MATERIALS panel affect the appearance of the selected ramp in 3D views and are available for a variety 
of objects throughout the program. For information about these settings, see Materials Panel on page 1055.         

The settings on this panel will also affect the materials applied to any landings attached to the selected ramp. See Landings 
on page 765.         

ARROW PANEL

The settings on the ARROW panel control the appearance of the selected ramp’s direction arrow in plan view. See In Plan 
View on page 759.          

For information about these settings, see Arrow Panel on page 312.          

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 1335.          

 

Stair Landing Specification Dialog
Select a landing and click the Open Object edit button to open the Stair Landing Specification dialog. See Landings 
on page 765.

The Stair Landing Specification dialog has the following panels:
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GENERAL PANEL

 
Landing

Uncheck Auto Adjust Height to specify the selected landing’s Top Height. 

 l A free-standing interior landing will have a default Top Height equal to one riser plus the thickness of the default 
floor finish. A free-standing exterior landing will have a default top height equal to its thickness. When this box is 
checked, the landing height may adjust as needed to maintain consistent riser height in all connected stair sections, 
ramp sections, or adjacent landings. 

 l The Top Height field is only active when Auto Adjust Height is unchecked. See Landing Height and Thickness on 
page 766. 

Note: A network of adjacent landings can only be created when Auto 
Adjust Height is checked. See Adjacent Landings on page 766.

  Uncheck Auto Adjust Thickness to specify the selected landing’s Thickness. 

 l A free-standing landing will have a default thickness of 6 3/4” (169 mm). When checked, the thickness is based on 
the riser height of the stair sections it is attached to, or the thickness of the ramps it is attached to.

 l The Thickness field is only active when Auto Adjust Thickness is unchecked. 

 
Selected Edge

Specify how railings are applied to the landing’s Selected Edge. See Selected Edge on page 214.      

 l Select Automatic to suppress the railing on any portion of the selected edge that either connects to a stair or ramp 
section or has an adjacent landing, but to produce a railing where that is not the case. See Landing Railings on page 
766.     

 l Select No Railing to suppress the railing on the selected edge of this landing.     

 l Select Has Railing to produce a railing along the selected edge, even where it connects to a stair or ramp section or 
has an adjacent landing.     

 l Check Apply to All Edges to apply your selection to all edges of the landing. This is an action rather than a state - 
the next time this dialog is opened, this box will be unchecked.

 
Preview

A preview of the selected landing displays on the right side of the panel. See Dialog Preview Panes on page 22.
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POLYLINE PANEL

The POLYLINE panel states the length of the landing’s Perimeter, its enclosed Area, and its Volume. 

The settings on this panel are available for a variety of other objects in the program. See Polyline Panel on page 323.

SELECTED LINE/ARC PANEL

The SELECTED LINE panel is available when the selected edge is a line as opposed to an arc. For more information, see  Line 
Panel on page 309.

The SELECTED ARC panel is available when the selected edge has been converted to an arc. For more information, see Arc 
Panel on page 318.

See, too, Selected Edge on page 214 and Change Line/Arc on page 259. 

RAILING PANEL

The settings on the RAILING panel are similar to those on the same panel in the Staircase Specification dialog. For 
information about these settings, see Railing Panel on page 790.         

There is one setting that is unique to the Landing Specification dialog:         

Uncheck Use Connected Stair or Ramp Railing to enable the settings on this panel, the NEWELS/BALUSTERS panel, and 
the RAILS panel. When checked, the selected landing derives all railing settings from the connected stairs or ramp.

If the selected landing is not connected to a stair or ramp, this check box will be named Use Default Interior or Exterior 
Stair Railing, depending on where the landing is located.         

NEWELS/BALUSTERS PANEL

The settings on the NEWELS/BALUSTERS panel are similar to those on the same panel in the Staircase Specification dialog. 
For more information, see Newels/Balusters Panel on page 794.         

By default, the settings on this panel will also affect the appearance of railings on any landings attached to the selected 
ramp. See Landings on page 765.         

RAILS PANEL

The settings on the RAILS panel are similar to those on the RAILS panel of the Staircase Specification dialog as well as the 
MOLDINGS panel of a variety of other dialogs. See Moldings / Profiles Panels on page 943.          
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LINE STYLE PANEL

The settings on the LINE STYLE panel are available for a variety of objects throughout the program. See Line Style Panel on 
page 310.

FILL STYLE PANEL

The settings on the FILL STYLE panel affect the appearance of the selected landing in plan view. See Fill Styles on page 197.
   

MATERIALS PANEL

When a landing is attached to stairs or a ramp, its initial materials are derived from the stairs or ramp. When the landing is 
attached to a ramp, its top surface material is defined by the Landing Sides component unless the ramp is using a Tread 
material.

The settings on this are available for a variety of objects throughout the program. For information about these settings, see 
Materials Panel on page 1055.

LABEL PANEL

Labels for stair landings display in plan view and cross section/elevation views when the “Polylines 3D, Labels” layer is 
turned on and use the Text Style assigned to that layer. See Displaying Stairs, Ramps, and Landings on page 759.           

For information about the settings on this panel, see Label Panel on page 712.          

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 1335.          
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Chapter 23
 

Roofs

Chief Architect’s manual and automatic Roof Tools allow you to draw almost any roof style. 

Verify that all roof planes join as intended. The program does 
not confirm correct geometry between manually designed or 

edited roof planes. It is possible to design and edit roof planes with hips 
and valleys that do not meet properly. 

TOPICS

Automatic vs. Manual Roofs 804
Roof Defaults 804
The Roof Tools 805
Automatic Roofs 807
Build Roof Dialog 809
Roof Planes 819
Displaying Roofs 821
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Connecting Roof and Ceiling Planes 826
Roof Plane Specification Dialog 828
Roof Baseline Polylines 834
Roof Baseline Specification Dialog 836
Roof and Ceiling Framing 837
Curved Roof Planes 838
Ceiling Planes 841
Ceiling Plane Specification Dialog 843
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Gable Line Specification Dialog 849
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Roof Hole/Skylight Specification Dialog 850
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Editing Auto Dormers 855
Dormer Specification Dialog 856
Roof Returns and Other Details 858
Roof Pitches in Degrees 863
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Automatic vs. Manual Roofs
Chief Architect can create just about any roof style. Most common roof styles such as hips and gables can easily be 
generated automatically. 

More complex roof styles, including curved roof planes, can be created manually. The manual roof tools allow you to create 
any roof system that can be represented using roof planes.          

AUTOMATICALLY GENERATED ROOFS

The quickest and easiest way to create a roof over a structure is automatically. By default, a roof plane is generated over 
each exterior wall, creating a hip roof. The program automatically joins the roof planes at ridges, hips, and valleys and tries 
to create roof planes that join together to form a single, integrated system. See Automatic Roofs on page 807.         

Any deviations from the default hip roof can be specified on the ROOF panel of the Wall Specification dialog for any 
exterior wall. Here, you can specify a Full Gable Wall, High/Shed Gable Wall, or other options instead of a default hip roof. 
You can also specify a different overhang, pitch, an upper pitch, and the elevation where the upper pitch begins for the roof 
plane that rests on the selected wall. See Roof Directives in Walls on page 381.          

When you need the roof planes over an area of a plan to be entirely separate from those over the rest of the structure, you 
can assign those areas to a non-default Roof Group. See Roof Groups on page 807.          

Roofs can also be automatically generated based on a Roof Baseline Polyline. When a Roof Baseline Polyline is used, 
information that determines where and how roof planes are generated is contained in the Roof Baseline Specification dialog. 
See Roof Baseline Polylines on page 834.          

Bay, bow, and box windows also produce roof planes automatically. For information about these windows and the roof 
styles that can be used with them, see Bay, Box, Bow Windows and Roofs on page 620.          

MANUALLY DRAWN ROOFS

Any roof system that can be created automatically can also be created manually. Each roof plane is drawn and edited 
individually, offering full control over the process and limiting the possibilities only to your imagination.           

Note: You cannot manually draw or edit roof planes when Auto Rebuild 
Roofs is enabled in the Build Roof dialog. See Roof Panel on page 810.

USING BOTH TECHNIQUES

Another useful option is to start with an automatically generated roof and use manual design techniques to finish it. Using 
both automatic roof generation and the manual roof drawing and editing techniques, you can quickly design highly 
customized roof systems.           

 

Roof Defaults
Select Edit> Default Settings, to open the Default Settings dialog for a variety of drawing tools, several of which 
directly affect roof generation. 
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ROOF DEFAULTS DIALOG

The Build Roof and Roof Defaults dialogs are nearly identical in appearance and function. The only difference is that the 
Build Roof dialog has a number of check boxes that allow you to automatically generate roof planes and related objects. See 
Build Roof Dialog on page 809.

If changes are made to the settings in this dialog after the roof has been built, you will need to rebuild the roof in order for 
your changes to take effect.           

ROOF FRAMING DEFAULTS

Default settings for framing can be specified in either the Build Roof, Framing Defaults, or the Framing Defaults dialog. 
Framing defaults control the depth of roof planes as well as the depth of floor and ceiling platforms, which influence roof 
plane heights. See Framing Defaults on page 865.          

To create roof planes with a particular assembly of layers, begin by setting up the desired roof framing defaults, then build 
the roof. If you later need to change the structure of the roof planes, make the needed change to the Framing Defaults, and 
then rebuild the roof. You can also edit the structure of individual roof planes.          

FLOOR AND CEILING HEIGHTS

The initial heights of floors and ceilings, which influence roof heights, are specified in the Floor Defaults dialog for each 
floor. See Floor Defaults Dialog on page 744.         

The floor and ceiling heights in individual rooms also influence roof heights and are specified in the Room Specification 
dialog. See Structure Panel on page 444.

If Auto Rebuild Roofs is checked in the Build Roof dialog and 
you change floor or ceiling heights, floor or ceiling platform 

depths, wall positions or roof directives in walls, the roof rebuilds to 
reflect your changes. See Rebuilding Roofs on page 808.

WALL SPECIFICATION DIALOG

By default, when an automatic roof is built, a roof plane is generated over each exterior wall, creating a hip roof. 

Any deviations from this default hip roof, such as a gable or a different pitch, can be specified in the Wall Specification 
dialog for any exterior wall. See Roof Panel on page 401. 

DORMER DEFAULTS

The settings in the Dormer Defaults dialog determine the initial settings for automatic dormers and are much like those in 
the Dormer Specification dialog. See Dormer Specification Dialog on page 856.         

The Dormer Defaults dialog can be opened from the Default Settings dialog or by double-clicking either of the Auto 
Dormer  tools.           

 

The Roof Tools
Select Build> Roof to access the Roof Tools. 
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BUILD ROOF

Select Build> Roof> Build Roof to open the Build Roof dialog, specify the settings for automatically generated and 
manually drawn roof planes as well as manually drawn ceiling planes, and build or rebuild a roof. See Build Roof 

Dialog on page 809.

When roofs are automatically generated, a roof plane is created over each exterior wall by default, resulting in a hip roof, 
and the program tries to join them together to form a single, integrated system.

To automatically generate a roof plane using values other than the defaults or to not generate a roof plane bearing on a 
particular wall (as with a gable or the sides of a shed roof), you can change the settings in the Wall Specification dialog. See 
Roof Panel on page 401.

ROOF PLANE

Select Build> Roof> Roof Plane to draw a roof plane manually. See Roof Planes on page 819. You can also double-
click the Roof Plane button to open the Build Roof dialog.         

Note: You cannot use the Roof Plane tool when Auto Rebuild Roofs is 
enabled in the Build Roof dialog. See Manually Drawn Roofs on page 
804.

CEILING PLANE

Select Build> Roof> Ceiling Plane to draw a ceiling plane manually. Ceiling planes are drawn and behave much like 
roof planes. See Ceiling Planes on page 841.         

TRAY CEILING POLYLINE

Select Build> Roof> Tray Ceiling Polyline, then click and drag to draw a closed polyline within a room. See Tray 
and Coffered Ceilings on page 435.          

GABLE/ROOF LINE

Select Build> Roof> Gable/Roof Line to draw a gable line that generates a gable along a baseline edge when roofs 
are automatically generated. See Gable/Roof Lines on page 846.         

SKYLIGHT

Select Build> Roof> Skylight, then draw a rectangle over an existing roof plane to create a skylight. The skylight, 
skylight shaft, and ceiling hole (if a ceiling exists) are drawn at the same time. See Skylights and Roof Holes on page 

849.    

AUTO FLOATING DORMER

Select Build> Roof> Auto Floating Dormer and click within an existing roof plane to place an auto floating dormer. 
See Dormers and Crickets on page 853.

AUTO DORMER

Select Build> Roof> Auto Dormer and click within a roof plane to place a dormer. See Dormers and Crickets on 
page 853.         
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EDIT ALL ROOF PLANES

Select Build> Roof> Edit All Roof Planes to open the Roof Plane Specification dialog and edit all roof planes in the 
entire plan at once. See Roof Plane Specification Dialog on page 828.         

DELETE ROOF PLANES

Select Build> Roof> Delete Roof Planes to delete all roof planes in the plan. See Deleting Roof Planes on page 825.

DELETE CEILING PLANES

Select Build> Roof> Delete Ceiling Planes to delete all manually drawn ceiling planes in the plan. See Ceiling 
Planes on page 841.         

FIX ROOFS

Select Build> Roof> Fix Roofs to remove breaks where a single edge of one roof plane meets the broken edge of 
another along a ridge, hip or valley. Fix Roofs does not affect eave edges. See Roof Edges and Walls on page 825.         

 

Automatic Roofs
When roofs are automatically generated, a roof plane is created over each exterior wall by default, resulting in a hip roof, 
and the program tries to join them together to form a single, integrated system.

There are a number of options available to produce variations in this default roof style. 

ROOF DIRECTIVES IN WALLS

To automatically generate a roof plane using values other than the defaults or to not generate a roof plane bearing on a 
particular wall (as with a gable or the sides of a shed roof), you can change the settings in the Wall Specification dialog for 
that wall. See Roof Panel on page 401.

ROOF GROUPS

When an automatic roof is generated, the program tries to create roof planes that join together to form a single, integrated 
system. Different parts of the structure influence how the roof is generated over the whole.           

When you need the roof planes over an area of a plan to be entirely separate from those over the rest of the structure, you 
can assign those areas to a non-default Roof Group. The program treats different Roof Groups as separate buildings for the 
purpose of automatic roof generation, preventing their roofs from influencing one another.           

Bear in mind that the use of Roof Groups typically involves using a combination of both automatic roof generation and 
manual roof editing, and that changes to Attic walls may also be necessary. See Using Both Techniques on page 804.           

Roof Groups are assigned using numbers. The Default Roof Group is always 0, and you can assign rooms to other roof 
groups in the Room Specification dialog. See General Panel on page 443.          
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CURVED WALLS AND ROOFS

Automatically generated roof planes are placed over curved walls at specified increments. In the Build Roof dialog, you can 
specify the degree increments for the roof over curved walls, from 6° to 90°. The lower the number, the more roof sections 
are created over the curved wall.           

The following  illustrations show a roof created at two different curved increments: 30° and 15°.          

CONCAVE CURVED WALLS AND ROOFS

Regular roof plane sections can also generate over concave curved walls. For roof sections to generate over a concave 
curved wall, the sections’ baselines must be longer than the Minimum Alcove Size value on the BUILD panel of the Build 
Roof dialog.          

If the baselines are shorter, the automatically generated roofs are simplified by either:           

 l Ignoring the curved wall, as if the walls on either side extended to their meeting point.          

 l Spanning the concave curved wall with a straight Baseline and produce a roof plane for it from that.          

REBUILDING ROOFS

When Auto Rebuild Roofs is unchecked in the Build Roofs dialog and changes are made to the model, the roof will not 
update to reflect these changes. This is the case even if the roof was automatically built. On the other hand, when Auto 
Rebuild Roofs is checked, any changes made to the position of an exterior wall or to its roof directives will prompt the roof 
to regenerate to reflect these changes. See Roof Panel on page 810.          
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Changes made to  floor heights, ceiling heights, or floor or ceiling platform thicknesses will also cause the roof to be 
automatically rebuilt. See Editing Rooms on page 425.   

You can also rebuild the roof at any time to reflect the current state of the model by opening the Build Roof dialog, 
checking Build Roof Planes, and clicking OK.

Manually dawn roof planes are specified as such in the Roof Plane Specification dialog. If a roof plane was automatically 
generated, it will instead have a Mark as Edited check box. See Roof Plane Specification Dialog on page 828.          

When the roof is rebuilt using Auto Rebuild Roof or Build Roof Planes in the Build Roof dialog, all roof planes in the 
plan, both automatically generated and manually drawn, are deleted and replaced.          

 l To preserve any manually drawn roof planes, check Retain Manually Drawn Roof Planes on the BUILD panel of the 
Build Roof dialog before the roof is rebuilt.           

 l To preserve any automatically generated roof planes that you have edited, check Retain Edited Roof Planes on the 
BUILD panel of the Build Roof dialog before the roof is rebuilt.          

Note: Under some conditions, when the roof is rebuilt new roof planes 
may be generated in the same location as retained manually drawn or 
automatic roof planes. 

Roof planes cannot be edited or manually drawn when Auto Rebuild Roofs is turned on. If you try to either edit or draw a 
roof plane using the Roof Plane  tool, a question message will display.          

 

Build Roof Dialog
The Build Roof dialog is used to automatically build or rebuild roof planes and generate Roof Baseline Polylines. 
The settings in this dialog act as defaults for both manually drawn and automatic roofs. See Roof Defaults on page 

804.    

To open the Build Roof dialog, select Build> Roof> Build Roof . You can also double-click the Roof Tools  button 

or the Roof Plane  button to open this dialog.

Roof planes and Roof Baseline Polylines are generated based on the positions and roof directive settings for each exterior 
wall in the plan. If you make changes to any of these walls or to any of the settings in this dialog, you will need to build the 
roof again for them to take effect. See Roof Panel on page 401. 

Aside from a number of check boxes on the ROOF panel that allow you to automatically generate roof planes and related 
objects, the settings in this dialog are also found in the Roof Defaults dialog. See Roof Defaults on page 804. 

The settings in this dialog are similar to those found in the Roof Plane Specification dialog, but affect all subsequently 
created roof planes rather than one or more selected  roof planes. See Roof Plane Specification Dialog on page 828.           

The Build Roof dialog has the following panels:
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ROOF PANEL
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  Build

 l Check Build Roof Planes to build a new roof structure over the entire model. Unless you specify otherwise, the 
program discards the existing roof planes  and produces new ones.                      

 l If you check Auto Rebuild Roofs, the program automatically rebuilds the roof  whenever you make a change that 
affects the generation of roofs, such as changes to exterior walls or ceiling heights.   

 l Check Make Roof Baseline Polylines to delete the existing roof and to create Roof Baseline Polyline(s) based on 
the exterior wall layout and roof information defined in those walls. Not available when Build Roof Planes is 
checked. See Roof Baseline Polylines on page 834.   

 l You can also specify how manually drawn or edited roof planes are handled when the roof is rebuilt automatically. 
These options are only available when Build Roof Planes is checked. See Rebuilding Roofs on page 808.     

 l Check Retain Manually Drawn Roof Planes to prevent manually drawn roof planes from being deleted when roof 
planes are rebuilt. Automatic roof planes may be generated in the same location. Also available if Make Roof 
Baseline Polylines is checked.   

 l Check Retain Edited Automatic Roof Planes to prevent automatic roof planes that have been manually edited - 
including roof planes over exploded dormers - from being deleted when roof planes are rebuilt. Also available if 
Make Roof Baseline Polylines is checked.
If a newly generated roof plane is coplanar with a retained plane, and the area where they overlap is at least half the 
area of either of them, the new roof plane is deleted and only the retained plane is kept.   

Note: Under some conditions, new roof planes may be generated in 
the same location as manually drawn or automatic roof planes that 
have been retained. 

 l Check Use Existing Roof Baselines to produce a roof plan based on your Roof Baseline Polyline(s) instead of the 
exterior wall layout.   

  Specifications

 l Enter a value to describe the Pitch. In plans using U.S. units of measurement, pitch is described as a ratio over 12 by 
default; in metric plans, it is measured in degrees. For a conversion to degrees, see Roof Pitches in Degrees on page 
863.         

 l Check Pitch in Degrees to display the pitch value in degrees in all dialogs as well as in roof plane labels. Values 
between -89° and 89° can be entered. When Pitch in Degrees is unchecked, Pitch is described in terms of rise and 
run: x inches in 12 or x mm in 1000.

 l Check Trusses (no Birdsmouth) if you wish to frame the roof using trusses rather than rafters. The roof height will 
be set so that the bottom edge of the truss top chord is flush with the top of the wall. See Roof Trusses on page 911.         

 l If you plan to use both trusses with rafters, leave Trusses (no Birdsmouth) unchecked so that the rafters’ depth can 
be accommodated. See Mixing Trusses with Stick Framing on page 918.         
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Roof Overhang

An overhang is measured horizontally from the outside Main Layer of exterior walls to the top outside edge of the fascia or 
shadow boards or, if no fascia or shadow boards are present, the end of the top of the rafter. The overhang does not include 
frieze molding or gutters. See The Main Layer on page 388.    

 l Eave is the overhang distance outside bearing walls for roof planes using the default Pitch. If a particular roof plane 
has a different Pitch, its overhang will adjust to keep its fascia at the same height. Overhang may be greater for a 
shallower pitch, lesser for a greater pitch.         

 l Gable is the overhang distance at gable ends or rake walls.         

If the roof overhang values are not sufficient to extend past the 
outer surface of exterior walls, the walls may not generate 

correctly in 3D views. 
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  Roof Height

 l Specify the amount to Raise/Lower From Ceiling Height, which controls the height of roof planes relative to the 
ceiling height specified for the rooms below. See Floor and Ceiling Heights on page 431.      

 l The default value is 0, which creates roof planes that bear on the wall top plates at the Ceiling Height of the room 
below.            

 l Increase this value to raise roof planes so they do not bear directly on the wall top plates. If roofs are raised 
sufficiently, Attic walls will automatically generate to support them. The exact height depends on the roof pitch.            

 l Decrease this value to drop roof planes downward and decrease the height of the bearing walls. If roofs are lowered 
sufficiently, they may extend into rooms, producing areas with angled ceilings.            

 l Check Ignore Top Floor to ignore the top living floor when roof planes are generated. Roof planes are built on the 
top plates of the walls below the top floor.            

 l Specify how you would like the eaves of roof planes with different pitches to meet. See Aligning Eaves on page 827.             

 l Check Same Roof Height at Exterior Walls to keep bearing walls the same height and change horizontal roof 
overhang distances as needed so that eaves meet correctly. When checked, this option ignores any overhang values 
you may have entered in the Wall Specification dialog. See Aligning Eaves on page 827.

Uncheck this option to raise or lower some roof planes relative to the wall’s top plate, allowing all horizontal 
overhangs to be the same unless a non-default value has been entered in the Wall Specification dialog. See Roof 
Directives in Walls on page 381.            

 l Check Same Height Eaves to keep the eave height for all roof planes the same. Roof planes are raised and lowered 
as needed so that eaves meet correctly. 

The eave height used when this box is checked is that of a roof plane using the default Pitch and Overhang values. 
When this box is checked, all roof planes are affected, including those that do not need adjustment in order to align 
with adjacent planes.

When Same Height Eaves is checked, any non-default overhang values specified in the Wall Specification dialog 
are used. Roof planes are raised or lowered so that the eave height is the same, regardless of the horizontal overhang.
            

 l Uncheck Allow Low Roof Planes only when an upper floor overhangs roof planes below.            
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  Automatic Birdsmouth Cut

 l Uncheck Automatic Birdsmouth Cut to enable the settings below. When checked, the birdsmouth is calculated 
based on the pitch and rafter depth and its values are listed here for reference. See Birdsmouth Cut on page 824.             

 l The Raise Off Plate and Birdsmouth settings do not affect the bearing wall heights.             

 l Enter a positive Raise Off Plate value in this field to produce the trusses with an energy heel to allow for more 
insulation.            

 l Enter a negative Birdsmouth Cut value to control the Birdsmouth Depth. For example, for the Birdsmouth Depth of 
3”, enter -3”. The location of the Baseline may change if you use the Raise Off Plate setting to specify the 
birdsmouth depth. See Birdsmouth Cut on page 824.            

 l Specify the Birdsmouth Seat, which is the horizontal depth of the birdsmouth cut. If you change this value, the 
Raise Off Plate/Birdsmouth Cut value will automatically adjust.            

 l To control the Birdsmouth Cut, you should also check Same Roof Height at Exterior Walls, above.             

 l The Vertical Structure Depth displays here as a reference. It can be changed on the STRUCTURE panel. See 
Structure Panel on page 817.            

  Options

 l Enter the Segment Angle at Curved Wall, which is the angle for roof segments automatically generated to cover a 
curved wall. A smaller angle produces more roof planes. Note that in some instances, slightly smaller or larger 
values will be used instead of the specified angle.         

 l Specify the Minimum Alcove Size, which is the minimum depth and width of an alcove in an otherwise straight 
exterior wall. Alcoves with both a depth and width less than this value are roofed over, while alcoves that are either 
wider or deeper than this value do not receive a roof.         
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OPTIONS PANEL
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  Eaves

 l Specify how the rafter and truss ends are Cut by selecting either Square Cut or Plumb Cut.         

 l Check Boxed Eave to produce horizontal boxed eaves or uncheck it for sloping eaves. You can also change this for 
individual roof planes in the Roof Plane Specification dialog. See Boxed Eaves on page 860.                     

 l Check Flush Eave to produce box eaves that build flush with the adjacent exterior wall. When unchecked, boxed 
eaves build to the gable fascia.                     

 l Higher Eaves Boxed - If the selected roof plane contains more than one eave, check this box to box the higher 
eaves as well as the lower ones.                      

 l By default, Boxed Eaves extend from the inside edge of the roof fascia to the exterior Main Layer of the wall, 
enclosing the overhang area. If an exterior room with Use Soffit Surface for Ceiling checked is located between the 
roof’s baseline and an interior room, the Boxed Eave will extend across that room, as well. You can instead uncheck 
Default to Overhang and specify the Length of the boxed eaves. Not available if Flush Eave is checked.                     
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Ceiling Break Lines

See Special Ceilings on page 439.                 

 l Display At Finish Intersection positions ceiling break lines where the ceiling finish surfaces intersect. 

 l Select Display At Framing Intersection to position ceiling break lines where the ceiling framing surfaces intersect. 

 l In Chief Architect Interiors, specify how the Ceiling surface on the underside of roof planes is built. See     Vaulted 
and Cathedral Ceilings on page 440.                     

 l When Use Room Ceiling Finish is checked, the ceiling finish thickness and material on the undersides of roof 
planes are defined by the room below. Uncheck this box to enable the two settings that follow and define the ceiling 
finish as part of the roof planes instead. When this is unchecked, you can specify the Ceiling Surface material on the 
Materials Panel on page 818.                      

 l Check Has Ceiling to enable the Ceiling Thickness option. When this box is unchecked, the selected roof plane will 
have no ceiling surface at all and the “Ceiling Surface” component will not be available on the MATERIALS panel.                     

 l Specify the Ceiling Thickness, which is the thickness of the bottom surface of the ceiling plane.                      

 
Supply

Specify which material components to calculate in the Materials List. See Materials Lists on page 1309. 

 l Uncheck Gutter to not include gutters on subsequently-built roof planes. This option affects both the Materials List 
and 3D views.                     

 l Check Edge Flashing to calculate edge flashing in the Materials List when one or more roof planes is against a wall.
                     

 l Check Ridge Vent to calculate ridge venting in the Materials List.                     

 l Check Metal Drip Edge at Eave to calculate metal drip edge along the eaves in the Materials List.                     

 l Check Metal Drip Edge at Gable to calculate metal drip edge along any gable eaves in the Materials List.                     

 l Check Valley Flashing to calculate valley flashing in the Materials List when two or more roof planes form a valley.
                     

  3D Display

 l When Show All Ridges is checked, a line along each hip between roof planes forming the conical roof above a 
curved wall displays in Vector Views. Uncheck this box to suppress these lines. See Rendered and Vector Views on 
page 1081.    

STRUCTURE PANEL

The settings on the STRUCTURE panel of the Build Roof dialog are the same as those on the ROOF panel of the Build 
Framing dialog. Changes made in one dialog are also applied in the other. See Roof Panel on page 884.          

Note: Changes made on the Structure panel will not affect the structure 
of existing roof planes. To make changes take effect, rebuild the roof.

RAFTER TAILS PANEL

The settings on the RAFTER TAILS panel allow you to specify a rafter tail profile for exposed rafter ends under roof eaves. 
See Rafter Tails on page 862.          
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The settings on this panel are like those on the MOLDINGS panel found in a variety of dialogs in the program. See Moldings / 
Profiles Panels on page 943.           

A few things about the RAFTER TAILS panel are unique:          

 l Only one rafter tail profile can be specified at a time, so the Add New button is only available when no profile is 
currently selected.         

 l Uncheck Stretch to Fit Rafter to use the rafter tail profile’s default size or to specify its Height and Width, below. 
When checked, the profile is sized by the program to match the roof rafters.         

 l Specify the distance that the rafter tail profile should Extend past the inside surface of the subfascia. This distance is 
measured along the top of the rafter tail, so it is greater than the length as measured in plan view.          

RIDGE CAPS PANEL

The settings on the RIDGE CAPS panel allow you to specify a profile for ridge caps. See Ridge Caps on page 863.           

The settings on this panel are like those on the MOLDINGS panel found in many dialogs in the program. See Moldings / 
Profiles Panels on page 943.           

GUTTER PANEL

The settings on the GUTTER panel allow you to specify a gutter profile for the eaves of roof planes. See Gutters on page 
861.           

The settings on this panel are like those on the MOLDINGS panel found in many dialogs in the program. See Moldings / 
Profiles Panels on page 943.           

FRIEZE PANEL

The settings on the FRIEZE panel allow you to specify one or more frieze molding profiles to generate under the eaves 
and/or gable overhangs of roof planes. See Frieze Molding on page 862.          

The settings on this panel are like those on the MOLDINGS panel found in many dialogs in the program. See Moldings / 
Profiles Panels on page 943.           

SHADOW BOARDS PANEL

The settings on the SHADOW BOARDS panel allow you to specify one or more shadow board profiles that follow the fascia 
on eaves and/or gable eaves. See Shadow Boards on page 860.           

The settings on this panel are like those on the MOLDINGS panel found in many dialogs in the program. See Moldings / 
Profiles Panels on page 943.           

ARROW PANEL

The settings on this panel allow you to control the appearance of roof plane slope direction arrows. See Displaying Roofs on 
page 821.          

For information about these settings, see Arrow Panel on page 312.          

MATERIALS PANEL

The settings on this panel allow you to specify the default materials for the roof’s various components. Some of these 
materials, as well as their thicknesses, can be specified on the STRUCTURE panel. See Materials Panel on page 1055.
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ROOF STYLES PANEL

The ROOF STYLES panel provides links to tutorial information about creating different roof styles automatically. Click on a 
roof style to launch the online Help to a page with information about the roof style you selected.  

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 1335.          

 

Roof Planes
When creating a roof, it is helpful to know how to draw a roof plane manually and be familiar with its parts.           

DRAWING ROOF PLANES

Roof planes are CAD-based objects that are created and edited like much closed polylines, and also have pitch, 
elevation and structural properties.         

Before drawing roof planes, you should set your roof defaults so that the 3D attributes of your roof planes are correct. See 
Roof Defaults on page 804.          

To draw a roof plane
 1.  Select Build> Roof> Roof Plane .           

 2.  Click and drag a Baseline from point 1 to point 2, as in the following example:          

Most roof planes are drawn over a wall, and the Baseline 
should be located directly above the outer edge of the wall’s 

Main Layer. See The Main Layer on page 388.

 3.  Release the mouse button at point 2 and move your cursor in the upslope direction. As you move the cursor, a 
preview outline of the roof plane displays.          

 4.  Click at point 3 to build the roof plane. Point 3 is located on the ridge edge of the roof plane.           

Note: You cannot manually draw roof planes when Auto Rebuild 
Roofs is enabled in the Build Roof dialog. See Roof Panel on page 
810.

THE BASELINE

The pitch direction and initial height of any roof plane - manual or automatic - is determined by its Baseline.          

819



Chief Architect Premier X14 Reference Manual - Roof Planes

The Baseline of the roof plane is normally located over the outer main layer of the wall and is used as the pivot point for the 
roof plane when the pitch is changed.            

The Baseline height is determined by the following formula:           

Elevation of the wall top plate + (Vertical Structure Depth - Vertical Birdsmouth Depth) = Baseline Height          

In a cross section, the Baseline is located directly above the outer surface of the main wall layer, at the top surface of the 
roof framing.           

A roof Baseline displays as a separate line within its roof plane when the “Roofs, Baselines” layer is turned on. In 3D 
views, it can only be seen if the roof plane is selected.           

A Baseline has a tick mark at its center point which indicates the direction that the roof plane slopes upward. If the upslope 
tick is pointing the wrong direction, either rotate the entire roof plane or delete it and draw a new one.           

When drawing the Baseline of a roof plane, here are some things to consider:          

 l A Baseline does not have to be drawn over a wall, although it often is.          
 l A Baseline drawn along a wall should be drawn over the outer edge of the wall’s main layer. It tries to snap to that 

layer.           
 l The elevation of the top plate is defined by the ceiling height in the room. If the roof plane is not drawn over a wall, 

its height is based on the default ceiling height value for the current floor.           
 l If a Baseline is drawn over the top of any other roof plane, the Baseline height equals the height of the existing roof 

plane at the point where you started drawing.          

Once drawn, a Baseline can be selected in plan view and edited independent of the roof plane. See Editing Roof Baselines 
on page 824.           

EAVE AND GABLE OVERHANGS

Roof overhangs are measured horizontally from the outside Main Layer of exterior walls to the top outside edge of the 
fascia or shadow boards or, if no fascia or shadow boards are present, the end of the top of the rafter. The overhang does not 
include  frieze molding or gutters. See The Main Layer on page 388. 
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The location of a roof plane’s fascia and shadow boards also determines its area and the size of its polyline in plan view. 
See Polyline Panel on page 833.          

ROOF LAYERS

Each roof plane is composed of Surface, Structure, and Ceiling Finish layers. These can be specified in the Build Roof 
dialog. See Structure Panel on page 817.           

 

Displaying Roofs
The display of roof planes, their labels, and attributes such as gutters and ridge caps is controlled in the Layer Display 
Options dialog or Active Layer Display Options side window. See Layer Display Options Dialog on page 183.

Roof planes are drawn on the "Roof Planes" layer by default. If this layer is turned off and Auto Rebuild Roofs feature is 
turned on, changes made to the plan that cause the roof to rebuild will not automatically turn on its display. See Rebuilding 
Roofs on page 808. 

IN PLAN VIEW

A number of layers associated with roof planes only display information in plan view, including "Roofs, Baselines" and 
"Roofs, Gable Lines". In addition,    

If the bottom surface of the roof extends below the ceiling height of a room, Ceiling Break lines will display, indicating 
where the flat ceiling ends and sloped ceiling begins. Ceiling Break lines are drawn on the “Ceiling Break Lines” layer in 
plan view only.   

 The Roof Plan View is set up for efficient drawing and printing 
of roof plans. See Plan Views on page 150.  

In plan view, roof planes can display on any floor without affecting their height in 3D. To move the display of 
a roof plane to a new floor, select it in plan view and click either the Display on Floor Above or Display on 

Floor Below edit button. The display of group-selected roof planes can also be controlled in this manner.   

Any skylights or roof holes placed in a roof plane moved in this manner will move, as well. Other associated objects like 
Auto Dormers or gutters will not move, however.   

ROOF PLANE LABELS

Roof plane labels indicating the pitch and slope direction are located on the “Roofs, Labels” layer and can be set to display 
in floor plan              and cross section/elevation views.         
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You can specify whether roof plane labels display the pitch in terms of rise and run or in decimal degrees by checking or 
unchecking Pitch in Degrees in the Build Roof dialog. See Roof Panel on page 810.         

A roof plane’s label can be customized in its specification dialog. See Label Panel on page 712. Roof planes have named 
value pairs associated with them, so you can create custom labels using Text Macros. See Text Macros on page 549.

Manually drawn Ceiling Planes  and Skylights  can also display labels when the “Roofs, Labels” layer is on. Unlike 

roof planes, these objects’ labels do not include a slope indicator and their Automatic Labels are blank; however, you can 
specify a custom label using text in their specification dialogs. See Ceiling Planes on page 841 and Skylights and Roof 
Holes on page 849.         

When a roof plane, ceiling plane or roof hole/skylight is selected in a 3D view, its label will display on a temporary basis if 
the “Roofs, Labels” layer is turned on.          

IN CROSS SECTION AND CAMERA VIEWS

When a roof or ceiling plane is viewed in a cross section, the layers that compose it can be seen, including the roof surface, 
sheathing, and the ceiling surface:         

 l If roof framing has been built, its display can be turned on, as well. See Displaying Framing on page 894.          
 l If a roof or ceiling plane is located over a room with Flat Ceiling Over this Room checked, the ceiling surface will 

not generate. See     Vaulted and Cathedral Ceilings on page 440.         
 l The layers of roof and ceiling planes can be detailed using the Auto Detail  tool. See Auto Detail on page 1095.          

In camera views and overviews, the appearance of curved roof planes can be controlled by adjusting the Facet Angle in the 
Roof Plane Specification dialog. See General Panel on page 829.   

IN THE MATERIALS LIST

The materials that make up roof and ceiling plane assemblies are listed under different Categories in the Materials List:          

 l Roofing - Lists most materials associated with roofs, including roofing, sheathing, rafters and trusses, gutters, and 
skylights.         

 l Exterior Trim - Lists automatically generated frieze molding and shadow boards. See Roof Returns and Other Details 
on page 858.         

 l Insulation - Insulation is calculated for roof and ceiling planes above rooms that do not have Flat Ceiling Over This 
Room checked. See Structure Panel on page 444.         

 l Wallboard - Lists ceiling materials for all rooms, including those that use the underside of the roof as their ceiling.         
 l Framing - Lists ceiling framing for manually drawn ceiling planes.          

See Materials Lists on page 1309.          

IN SCHEDULES

Roof Planes, Roof Holes, Skylights, and a selection of Roof Trim items can be included in schedules. See The Schedule 
Tools on page 695.

Roof Holes and Skylights are listed in the "Windows" category by default, while Frieze, Gutter, Ridge Cap, and Shadow 
Boards are listed in the "Roof Trim" category. You can, however, assign a selected roof object to the category of your 
choice in its specification dialog. See Schedule Panel on page 716.   
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Editing Roof and Ceiling Planes
A selected roof or ceiling plane can be edited in 2D and 3D using edit handles, edit toolbar buttons, its specification dialog, 
and the Material Painter . See Material Painter Tools on page 1053.          

A roof or ceiling plane’s Baseline can also be selected and edited. To select it, first select the roof plane and then click the 
Select Next Object  edit button. See The Baseline on page 819.           

The appearance and display of roof and ceiling planes can also be customized. See Displaying Roofs on page 821 and Roof 
Plane Specification Dialog on page 828.     

By default, all roof planes are deleted and replaced whenever the roof is rebuilt using the Build Roof dialog. If you have 
manually edited roof planes and do not want them to be replaced, be sure to check Retain Edited Roof Planes. See Roof 
Panel on page 810.          

Roof planes cannot be edited while Auto Rebuild Roofs is turned 
on. If you try to do so, the program will prompt you to turn it 

off.

2D SHAPE AND 3D ORIENTATION

There are two basic aspects to editing roof planes: 2D shape and 3D orientation.           

 l The 2D shape of a roof or ceiling plane can be edited much like a closed CAD polyline. As a plane's perimeter is 
reshaped in 2D, the program maintains its height and pitch in 3D. See Editing Closed Polyline-Based Objects on page 
230.          

 l The 3D orientation of a roof or ceiling plane is defined by its height, pitch, and its structure: all of which can be edited 
in its specification dialog.          

An understanding of these two concepts allows you to design almost any kind of roof system.          

RAISING/LOWERING ROOF AND CEILING PLANES

The default height of a roof or ceiling plane is based on the ceiling height of the room below. See Floor and Ceiling Heights 
on page 805.

Roof planes can be raised or lowered in the Roof Plane Specification dialog. Begin by locking the Pitch, then change 
one of the Height values. See General Panel on page 829. 

Ceiling planes can be edited in a similar manner in their specification dialog. See General Panel on page 843.    

You can also raise or lower roof and ceiling planes using the Transform/Replicate Object edit tool. See 
Transform/Replicate Object Dialog on page 269.     

In addition, when a new floor is added to a plan, you can choose to move any roof planes displaying on the top floor up to 
the newly added floor level. Ceiling planes are not affected when a new floor is added. See Adding Floors on page 745.     
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CHANGING A ROOF OR CEILING PLANE'S PITCH

The default pitch for a roof system as well as for manually-drawn ceiling planes is set in the Build Roof dialog. Non-default 
pitches can be set in the specification dialog of each exterior bearing wall defining a room on the top floor level of the plan. 
See Roof Directives in Walls on page 381.

Just as with its height, the pitch of a roof or ceiling plane can be modified on the GENERAL panel of its specification 
dialog. Begin by locking one of the Height values and then change the Pitch. 

If you choose to lock the Top of Plate height of a roof plane, the point about which the plane will pivot depends on whether 
Automatic Birdsmouth Cut is checked in the Build Roof dialog.

 l When it is checked, the roof plane will pivot about the top inside edge of the bearing wall's top plate.
 l When it is unchecked, it will pivot about the top outside edge of the top plate.

Changing a roof plane's pitch can affect how it connects to adjacent roof planes. See Connecting Roof and Ceiling Planes on 
page 826. 

EDITING ROOF PLANE STRUCTURE

To create roof planes of a particular depth, begin by setting up the desired roof framing defaults, then build the roof. See 
Framing Defaults on page 865.      

If you later need to change the structure of the roof planes, make the needed change to the Framing Defaults, and then 
rebuild the roof. You can also edit roof structure on an individual roof plane basis. See Roof Plane Specification Dialog on 
page 828.      

BIRDSMOUTH CUT

The birdsmouth is the notch cut into a rafter where it rests on the wall top plate. You can control its vertical depth and the 
width of the birdsmouth seat in the Build Roof dialog. See Roof Panel on page 810.      

There are two ways to create a roof plane with no birdsmouth:      

 l Check Trusses (No Birdsmouth) in the Build Roof dialog before drawing the roof plane.      
 l Specify a Raise Off Plate value of at least 1/16” in the Build Roof dialog.       

To change the birdsmouth depth after the roof is built, you can move the roof planes up or down, or change the pitch. For 
example, if you lock the pitch and raise the roof plane by one inch, you decrease the birdsmouth depth by one inch.      

EDITING ROOF BASELINES

The pitch direction and initial height of any roof plane - manual or automatic - is determined by its Baseline. See The 
Baseline on page 819.           

In plan view, a Baseline can be selected and edited independent of the roof plane. To select it, click on the roof plane at the 
location of the Baseline and then click the Select Next Object  edit button. The Status Bar tells you when the roof plane 

Baseline is selected. See Select Next Object on page 215.            

If a roof plane Baseline is moved, its height will not change. Instead, the height of the roof plane will be affected. In most 
cases, therefore, moving a roof plane’s Baseline independent of the roof plane itself is not recommended.           

If the angle of a roof plane’s Baseline is changed, the direction of the roof plane’s pitch will be modified. The Baseline 
Angle can be modified in either of two ways:           
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 l In the Roof Plane Specification dialog. This will change its angle relative to the floor, and will tilt the roof plane along 
an axis perpendicular to its Baseline. This method is helpful when a specific eave angle is needed. See General Panel 
on page 829.          

 l Using its Rotate edit handle in plan view. This will change its angle relative to the roof plane’s eave or ridge and will 
modify the direction of the pitch. This method is best when the pitch direction matters more than the angle of the eave.          

 l Both of these methods can be used to modify the same roof plane, although the second approach makes it difficult to 
control both the pitch direction and eave angle, and is not recommended.           

The length of a roof plane Baseline can be lengthened or shortened using its edit handles without changing any of the roof 
plane’s attributes.           

ROOF EDGES AND WALLS

By default, the edges of a roof plane will automatically snap to the outer surface of a nearby parallel wall. You can disable 
this Special Snapping behavior for a selected roof plane in its specification dialog. See General Panel on page 829.      

After moving a corner edit handle, it may be difficult to make an edge parallel to an eave or a wall. Use the Make 
Parallel/Perpendicular  edit button to align a roof or ceiling plane edge with a wall, another roof plane edge, or another 

object with a straight edge. See Make Parallel/Perpendicular on page 252.      

If opposite sides of a roof plane are parallel, Temporary 
Dimensions will display between them when one side is selected.

Sometimes, what appears to be a single, straight roof plane edge may actually be broken into two or more edges, which can 
affect your ability to align the edge properly.      

A single edge will have three edit handles; if more than three display, more than one edge is present. An extra handle can be 
removed manually by dragging it into an adjacent handle. You can also use Build> Roof> Fix Roofs . See Fix Roofs on 

page 807.     

When Bumping/Pushing  is enabled and CAD Stops Move is checked in the Roof Plane Specification dialog, a roof 

plane will bump against another roof plane, CAD or CAD based object as it is moved. Roof planes cannot push these 
objects, however. See Bumping/Pushing on page 246.      

LOCKING ROOF PLANES

When the roof plan is correct, roof planes can be locked to prevent accidental changes. To do this, lock the “Roof Planes” 
layer in all layer sets. See Layer Display Options Dialog on page 183.

Locking roof planes will not prevent roof planes from being deleted if the floor they are on is deleted.           

DELETING ROOF PLANES

There are several ways to delete roof planes.

  Delete the entire roof quickly by selecting Build> Roof> Delete Roof Planes. 

  You can also delete all roof planes at once in the Delete Objects dialog. See Delete Objects Dialog on page 289.

  In addition, you can select any roof plane or group of roof planes, then press the Delete key or click the Delete 
edit button to delete it from the plan. See Deleting Objects on page 289.          
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Generally speaking, roof planes cannot be deleted if they are locked. An exception to this rule occurs when an entire floor of 
a plan is deleted. Any roof planes present on a floor will be deleted when the floor is deleted, locked or not. See Deleting 
Floors on page 748.          

When a roof plane is deleted, any roof framing associated with it is automatically deleted, as well.          

 

Connecting Roof and Ceiling Planes
When a roof system is drawn correctly, roof planes will meet along geometrically correct lines to form ridges, hips, and 
valleys. There are a number of tools to help you achieve this when manually drawing or editing roofs.         

To generate roof planes that do not form a single, integrated system, consider using Roof Groups. See Roof Groups on page 
807.     

By default, all roof planes are deleted and replaced whenever the roof is rebuilt using the Build Roof dialog. If you have 
manually edited roof planes and do not want them to be replaced, be sure to check Retain Edited Roof Planes in the Roof 
Plane Specification dialog. See Roof Panel on page 810.          

Roof planes cannot be edited while Auto Rebuild Roofs is turned 
on. If you try to do so, the program will prompt you to turn it 

off.

JOIN ROOF PLANES

Two roof or ceiling planes can be joined at adjacent edges in both 2D and 3D using the Join Roof Planes edit button. 
To use this tool, first identify which edges of the roof planes can extend to meet at a ridge, hip, or valley. The 

program will join the two planes along the line where they intersect whenever possible.         

To use Join Roof Planes
 1.  Select a roof or ceiling plane on the edge to be joined to another plane.          

 2.  Click the Join Roof Planes  edit button (or press 2 on the keyboard).          

 3.  Move your pointer to the edge of the second roof or ceiling plane that the first one needs to join to. When your 
pointer is over the second plane, this plane will highlight.          

 4.  Click on the edge of the second roof or ceiling plane to join it to the first plane.          

Note: Join Roof Planes cannot be used to join a roof plane and ceiling 
plane. Only planes of the same type can be joined using this tool.

If the planes are not close enough, or their shape is not correct, you may need to align their edges, remove extra edges, or 
move them closer.           

When roof or ceiling planes adjust, the program joins them at the proper location and the adjacent edges extend or contract 
to remain connected. If the joining of the two will completely eliminate or reverse an adjacent edge, the connection cannot 
be made.           

LOCATING INTERSECTIONS

When roof planes of differing slopes meet, they create a ridge, hip, or valley. The Join Roof Planes  edit tool is the 

easiest way to move roof plane edges so that they meet correctly; but you can also locate roof plane intersection points 
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where the ridge, hip or valley should be. Once you know where the planes will meet, you can drag edges or corners to those 
points.          

To find roof plane intersection points
 1.  Make sure that Automatically Place Roof Intersection Points is turned on in the Preferences dialog. See 

Architectural Panel on page 116.           

 2.  Select the roof plane you would like to place intersection points on.          

 3.  Click the edge of another roof plane to place a temporary CAD Point where it would meet the selected roof plane.            

 4.  Repeat steps 1 and 2 for the ridge edge and both fascia edges. You should have three points located on the larger 
roof plane: these are the intersection points.          

 5.  Once these intersection points are identified, you can snap the corners of the second roof plane to them.          

ALIGNING EAVES

It is not uncommon for roof plans to feature more than one pitch. In order for the eaves of roof planes with different pitches 
to meet correctly at ridges and hips, you must control the roof planes’ heights and their horizontal overhang distances. Two 
options in the Build Roof dialog allow you to control how the eaves of automatically generated roof planes align. See Roof 
Panel on page 810.          

 l Same Roof Height at Exterior Walls maintains the default height of roof planes where they bear on exterior walls. 
The horizontal overhang distances of any non-default roof planes are adjusted so that they continue to join correctly 
with default roof planes.          

 l Same Eave Heights maintains the default roof plane height at the eaves as well as any non-default horizontal 
overhang distances. All roof planes are raised or lowered so that they all have the same height at the eaves as default 
roof planes.           

Roof planes that do not join other roof planes with different pitches at ridges or hips are referred to as Independent.           

 l When Same Roof Height at Exterior Walls is checked, Independent roof planes are not affected and will maintain 
any non-default overhang values.           

 l When both Same Roof Height at Exterior Walls and Same Eave Heights are checked, the overhangs of Independent 
roof planes will be adjusted to preserve their heights at both the exterior walls and the eaves.           

MOVE TO BE COPLANAR

The Move to be Coplanar edit button allows you to move the selected roof plane to be coplanar (in the same plane) 
with the next selected roof plane. You can use this tool in both 2D and 3D views. The results can be easily seen in a 

cross section view. The two roof planes must have parallel Baselines for this to work.         
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SET BASELINE HEIGHT DIALOG

If you manually draw a roof plane so that it bears on a wall at its Baseline, and is placed in the same location as an existing 
roof plane, the Set Baseline Height dialog will display. See The Baseline on page 819.          

 l Select Over Wall Top to create a roof plane that bears on the wall it is drawn over and has an overhang as specified 
in the Build Roof dialog. This option would be appropriate to produce a full height dormer. See Manually Drawn 
Dormers on page 854.          

 l Select Over the Existing Roof Plane to produce a roof plane with a height based on that of the roof plane below it 
rather than the wall. The Baseline height equals the top height of the existing roof at the point where you began 
drawing the new roof plane Baseline, and has no overhang. This option would be appropriate to create a dormer vent 
or cricket. See Manually Drawn Crickets on page 855.          

 

Roof Plane Specification Dialog
Select one or more roof planes and click the Open Object edit button to open the Roof Plane Specification dialog. 

You can also open this dialog for all roof planes in the entire plan by selecting Build> Roof> Edit All Roof Planes .           

The Roof Plane Specification dialog has the following panels:
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GENERAL PANEL

There are four values that define the 3D orientation of a roof plane: Ridge Top Height, Baseline Height, Fascia Top 
Height, and Pitch.          

Locking any of the Height values defines that value as the pivot point for the selected roof plane. Each of these dimensions 
is measured from the first floor default elevation of 0' - 0".           

If you lock the Pitch and change a Height value, the roof plane moves vertically, keeping the same slope. It will not pivot.                
For a conversion to degrees, see Roof Pitches in Degrees on page 863.

Changing these values does not affect the 2D representation of the roof plane.          
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Height/Pitch

Specify the Height and Pitch of the selected roof plane(s). Heights are measured from the top surface of the roof plane(s) 
rafters or trusses. See Roof Planes on page 819.     

 l The Top of Plate is defined by the ceiling height of the room below and is reported here for reference. N/A displays 
if no room is below the roof plane.     

 l Define the Ridge Top Height, or lock this value to make it the roof plane’s pivot point. If the roof plane's has 
multiple ridge lines, this setting is associated with the highest ridge.

 l Define the Baseline Height, or lock this value to make it the pivot point.     

 l Define the Fascia Top Height, or lock this value to make it the pivot point.     

Note: The Fascia Top height will decrease slightly if the fascia edge is 
aligned with the ridge top of another roof plane.

   l Define the Shadow Board Top height, or lock this value to make it the pivot point. Only available when Shadow 
Boards are present on the selected roof plane. See Fascia and Shadow Boards on page 860.

 l Specify the Pitch for the selected roof plane, or lock this value to move the roof plane vertically when a Height 
value is changed.

 l Check Pitch in Degrees to display the pitch value in degrees in all dialogs as well as in roof plane labels. Values 
between -89° and 89° can be entered. When Pitch in Degrees in unchecked, Pitch is described in terms of rise and 
run: x inches in 12 or x mm in 1000.

The diagram to the right of the Height/Pitch settings shows the location of the Lock point. If a Height/Pitch setting is 
currently selected for editing, its location will also be indicated using an arrow.

   l By default, the selected Show Diagram for option is determined by whether Trusses (no Birdsmouth) was checked 
in the Build Roof dialog when the selected roof plane was created.

 l Select a radio button to choose whether to Show Diagram for Rafters or Trusses. The structure of the roof and 
location of the Top of Plate Lock point vary between these two options.
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Measurements

Information about the structure of the selected roof plane(s) displays here for reference.     

 l In Chief Architect Interiors only, specify the Structure Thickness of the selected roof plane(s). In Chief Architect 
Premier, the Structure Thickness is reported here for reference but is specified on the Structure panel. The default 
Structure Thickness is defined in the Build Framing dialog. See Build Framing Dialog on page 873.    

 l The Birdsmouth Depth is the plumb or vertical depth of the birdsmouth cut. To change it, move the roof plane 
some way. For example, if you lock the pitch and raise the roof plane by one inch, you will decrease the birdsmouth 
depth by one inch. See Birdsmouth Cut on page 824.    

 l The Birdsmouth Seat is the horizontal width of the birdsmouth cut. This value is dynamically linked to the 
birdsmouth depth - if one changes, so does the other.    

 l The Vertical Structure Depth is defined by measuring a plumb line across the roof plane structure. The degree of 
pitch affects the Vertical rafter width. The greater the pitch, the greater the vertical structure depth.    

 l Overhang from Baseline is the horizontal overhang measured from the Baseline to the eave.    

 l Mark as Edited - When an automatically generated roof plane is modified, the program marks it as "edited", giving 
you the option of retaining it when the roof is rebuilt. Uncheck this box to remove this status from the selected roof 
plane. See Rebuilding Roofs on page 808.    

 l Mark as Edited is only available for automatically generated roof planes. If a manually drawn roof plane is 
selected, the words Manual Roof Plane will display here instead.

 l When Use Special Snapping is checked, the selected roof plane's edges will automatically snap to the outside 
surface of walls that it may butt against. Uncheck this to prevent the roof plane from snapping to any nearby walls.

 
Curved Roof

Check Curved Roof to specify the selected roof plane as curved. See Curved Roof Planes on page 838.

 l Specify the roof plane’s Angle at Eave, Angle at Ridge and Radius to Roof Surface.

 l These three values are interrelated - when one is changed, the other two adjust accordingly. You may find it helpful 
to first specify the Radius value, then the Angle values.

 l A flat roof plane with a pitch of 0 has angles of 0 at both the ridge and eave, as well as a radius of 0.

 l Uncheck Automatic Facet Angle to specify the Facet Angle, which is the angle at which curved roof surfaces are 
broken in 3D views. The default value is 7.5°; a smaller value produces a smoother curve while a larger value may 
generate more quickly in 3D views. 
The Facet Angle value must divide into 360° evenly; if it does not, the program will choose the nearest value that 
does.

 
Baseline

Specify the angle of the selected roof plane’s Baseline, relative to the XY axis. See Editing Roof Baselines on page 824.     

 l A positive Baseline Angle value causes the Baseline to tilt upward from its default height. A negative value causes it 
to tilt downward. The top heights of any walls under the selected roof plane will become angled, as well.     

 l The Baseline Height defined above can be maintained at either the Start or End point. In plan view, the Baseline 
direction is clockwise around the house.
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OPTIONS PANEL

The settings on the OPTIONS panel are the same as those on the panel of the same name in the Build Roof dialog, but affect 
the selected roof plane only. See Options Panel on page 815.         

STRUCTURE PANEL

The settings on the STRUCTURE panel are similar to those on the ROOF panel of the Build Framing dialog, but apply to the 
selected roof plane only. See Roof Panel on page 884.         

One check box is unique to the STRUCTURE panel of the Roof Plane Specification dialog: check Retain Roof Framing to 
keep the selected roof plane’s framing from being deleted and replaced when roof framing is rebuilt.         

RAFTER TAILS PANEL

The settings on the RAFTER TAILS panel are the same as those on the same panel of the Build Roof dialog, but affect the 
selected roof plane only. See Rafter Tails Panel on page 817.          

Most of the settings on this panel are also like those on the MOLDINGS panel found in a variety of dialogs in the program. 
See Moldings / Profiles Panels on page 943.           

RIDGE CAPS PANEL

The settings on the RIDGE CAPS panel allow you to specify one or more ridge cap profiles on the ridge and hip edges of the 
selected roof plane and are the same as those on the same panel of the Build Roof dialog. See Ridge Caps on page 863.           

If you customize the settings on this panel, bear in mind that your changes may only take effect in the model if the same 
changes are also made to adjacent roof planes.          

Most of the settings on this panel are like those on the MOLDINGS panel found in many dialogs in the program. See 
Moldings / Profiles Panels on page 943.          

GUTTER PANEL

The settings on the GUTTER panel allow you to specify a gutter profile for the eaves of roof planes. See Gutters on page 
861.           

The settings on this panel are like those on the MOLDINGS panel found in many dialogs in the program. See Moldings / 
Profiles Panels on page 943.           

FRIEZE PANEL

The settings on the FRIEZE panel allow you to specify a frieze molding profile to generate under the eaves of the selected 
roof plane and are the same as those on the same panel of the Build Roof dialog. See Frieze Molding on page 862.          

The settings on this panel are  like those on the MOLDINGS panel found in many dialogs in the program. See Moldings / 
Profiles Panels on page 943.

SHADOW BOARDS PANEL

The settings on the SHADOW BOARDS panel allow you to specify one or more fascia shadow board profiles that follow the 
selected roof plane’s eaves. See Shadow Boards on page 860.          
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The settings on this panel are like those on the MOLDINGS panel found in many dialogs in the program. See Moldings / 
Profiles Panels on page 943.   

POLYLINE PANEL

The POLYLINE panel states the length of the roof plane’s Perimeter and its enclosed Area, calculated using several different 
methods.         

 l The Perimeter is the total length of the roof plane’s sides, not including fascia and shadow boards, with its pitch taken 
into account. It does not equal the perimeter as measured in plan view unless the roof plane has no fascia or shadow 
boards and the pitch is 0.              

 l The Framing Area is the area of the roof plane’s framing, not including the fascia or shadow boards, with the pitch 
taken into account. It is slightly smaller than the Roof Surface Area as roofing typically overhangs the framing by a 
small amount.             

 l The Projected Area is the area of the roof plane polyline, including fascia and shadow boards, as seen in plan view. It 
does not equal the Roof Surface Area unless the pitch is 0.             

 l The Roof Surface Area is the area of the roof plane’s top surface, which covers the fascia and shadow boards, with 
the pitch taken into account.             

 l The Overhang Area is the area of the roof plane’s overhang, including fascia and shadow boards, with its pitch taken 
into account.              

 l The Projected Overhang Area is the area of the roof plane’s overhang, including fascia and shadow boards, as seen 
in plan view.              

SELECTED LINE PANEL

The SELECTED LINE panel is similar to the Line panel of the Line Specification dialog. See Line Panel on page 309.          

LINE STYLE PANEL

For information about the settings on this panel, see Line Style Panel on page 310.          

FILL STYLE PANEL

The settings on the FILL STYLE panel control the appearance of the selected roof plane in plan view. For information about 
these settings, see Fill Styles on page 197.           

ARROW PANEL

The settings on the ARROW panel allow you to control the appearance of the selected roof plane’s slope direction arrow. See 
Displaying Roofs on page 821.          

For information about these settings, see Arrow Panel on page 312.          
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MATERIALS PANEL

The settings on the MATERIALS panel allow you to specify materials for the selected roof plane’s various components. For 
more information, see Materials Panel on page 1055.          

The “Ceiling Surface” component is only available when Use Room Ceiling Finish is unchecked               on the STRUCTURE panel. 
In Chief Architect Interiors this setting is found on the OPTIONS panel along with Has Ceiling, which must be checked. 

LABEL PANEL

Roof plane labels display when the “Roofs, Labels” layer is turned on and use the Text Style assigned to that layer. See 
Roof Plane Labels on page 821.          

For information about the settings on this panel, see               Label Panel on page 712.         

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. See Components Panel on page 1335.          

OBJECT INFORMATION PANEL

The information entered on the OBJECT INFORMATION panel can be used in schedules and the materials list. For more 
information, see Object Information Panel on page 1336.   

SCHEDULE PANEL

The settings on the SCHEDULE panel determine which schedule categories the selected roof plane is included in. See 
Schedule Panel on page 716.

 

Roof Baseline Polylines
Typically, the program builds an automatic roof based on the settings in the Build Roof dialog and on the ROOF panel of the 
Wall Specification dialog, along with the layout of the exterior walls and floor and ceiling heights.           

If you want to build a roof that diverges from the footprint of your building as well as the roof directives in the exterior 
walls, you can use Roof Baseline Polylines.          

To create roof baseline polylines
 1.  Select Build> Roof> Build Roof .          

 2.  On the BUILD panel of the Build Roof dialog, check Make Roof Baseline Polylines.           

 3.  Click OK. A set of roof Baselines is created along the outside edge of the Main Layer of the exterior walls, forming 
one or more closed polylines.          

As with roof planes, the heights of Roof Baseline Polylines are determined by ceiling heights in the plan. If roof planes will 
be built at more than one height, a separate baseline polyline is created for each height.          

Once created, a Roof Baseline Polyline can be edited in a variety of ways, then used as the basis for the roof then next time 
it is built automatically.           

To create a new roof using the directives in your Roof Baseline Polyline(s), check Use Existing Roof Baselines in the Build 
Roof dialog and click OK. See Roof Panel on page 810.          
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DISPLAYING ROOF BASELINE POLYLINES

Roof Baseline Polylines are placed on the “Roofs, Baseline Polylines” layer               by default and use the Text Style assigned to 
that layer. See Layer Attributes on page 181.

Roof directive information displays along each edge of the polyline, including:          

 l V - vertical (against wall);          
 l G -gable/shed;          
 l K - knee wall;          
 l L - lower (extend slope downward).          

If the directive information includes the pitch, the roof plane slopes toward that edge; if it includes the word (vert), it does 
not.          

EDITING ROOF BASELINE POLYLINES

A Roof Baseline Polyline’s shape can be edited much like a CAD polyline using its edit handles and edit toolbar buttons. 
See Editing Closed Polyline-Based Objects on page 230.            

Roof Baseline Polylines always form a closed area with straight sides only. They cannot be severed or curved, but additional 
joints or corners can be added.          

In addition to length and direction, each Roof Baseline Polyline edge has roof directives associated with it, much like the 
roof directives in individual walls. See Roof Directives in Walls on page 381.          

AN EXAMPLE

In order for it to reflect any changes that you make to a Roof Baseline Polyline, the roof must be rebuilt. For a simple 
example of Roof Baseline Polyline editing, consider an L-shaped house, with a rectangular roof. The inner part of the ’L’ is 
a patio that is covered under the same roof.          

On the left is the baseline polyline as it was originally produced and the roof plan it creates.          
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To model the roof plan shown on the right
 1.  Select the Roof Baseline Polyline along its bottom-most edge.          

 2.  Click the Intersect/Join Two Lines  edit button. See Reshaping Objects on page 257.          

 3.  Click the left-most edge to remove the two intervening edges.           

 4.  A message box informs you that “The system must delete intervening lines (those on the inside of the L) to join the 
two selected lines.” Click OK.          

 5.  Open the Build Roof dialog and select the Build Roof Planes and Use Existing Roof Baseline check boxes to 
model the roof plan shown on the right side of the image above.          

 

Roof Baseline Specification Dialog
Like walls, each line of a Roof Baseline Polyline contains roof directives that affect automatic roof generation. Select 
any edge of a Roof Baseline Polyline click the Open Object edit button open the Roof Baseline Specification dialog.

ROOF BASELINE PANEL

The settings on the ROOF BASELINE panel control the roof directives associated with the selected edge of the Roof Baseline 
Polyline. See Selected Edge on page 214.

 
Baseline Height

See The Baseline on page 819. 

  Roof Options

 l The first six options: Hip Wall, Full Gable Wall, Dutch Gable Wall, High Shed/Gable Wall, Knee Wall, and 
Extend Slope Downward are the same as those in the Wall Specification dialog. See Roof Panel on page 401.          

 l Select Against Wall if the roof plane rising from this baseline butts against an exterior wall. This is similar to 
checking High Shed/Gable Wall.          
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Pitch Options

These settings are also found in the Wall Specification dialog. See Roof Panel on page 401.         

 l Unlike the Pitch value elsewhere, this value is not a Dynamic Default here; however, you can click on the Default 
icon to load the current default Pitch. See Build Roof Dialog on page 809.          

POLYLINE PANEL

The POLYLINE panel reports general information about the size and shape of the selected Roof Baseline Polyline. See 
Polyline Panel on page 833.           

SELECTED LINE PANEL

This panel is similar to the LINE panel of the Line Specification dialog. See Line Panel on page 309.          

LINE STYLE PANEL

For information about the settings on this panel, see Line Style Panel on page 310.          

FILL STYLE PANEL

The settings on the FILL STYLE panel control the appearance of the selected Roof Baseline Polyline in plan view. See Fill 
Styles on page 197.          

 

Roof and Ceiling Framing
Roof framing can be both drawn manually and generated automatically. You can also combine the two techniques. As with 
other kinds of framing, it is often easiest to begin by generating roof framing automatically and then editing it as needed. 
See Manual vs. Automatic Framing on page 867.

Roof Trusses  cannot be generated automatically - they must be drawn manually and then replicated. If you intend to 

use Roof Trusses, make sure the settings in the Build Roof dialog are properly defined before you build the roof. See Roof 
Trusses on page 911.

When using a combination of Roof Trusses and stick framing, begin by drawing the roof planes and ceiling planes. When 
they are in place, draw and replicate the Roof Trusses.  Finally, automatically generate or manually draw the stick framing 
and edit it as needed. See Mixing Rafters and Trusses on page 869.

Framing for manually drawn Ceiling Planes  cannot be drawn manually - it must be automatically generated. The 

framing for manually drawn Ceiling Planes is generated when roof framing is built and uses the settings in the Build Roof 
dialog as defaults. Once it has been created, it can be edited. See Ceiling Planes on page 841.

Similarly, purlins that run perpendicular to rafters can be automatically generated in the Surface and Ceiling layers for roof 
and ceiling planes but cannot be drawn manually. See Material Layers Definition Dialogs on page 1040. 

REBUILDING ROOF FRAMING

If roof framing defaults are modified after the roof and roof framing are built, neither will update automatically. In order to 
update the model you need to rebuild the roof, then rebuild the roof framing. 

You can also modify the roof framing settings for individual roof planes, and then either build roof framing or click the 
Build Framing for Selected Object  edit button. See Keeping Framing Current on page 899.
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Curved Roof Planes
Any roof plane can be turned into a curved roof plane in the Roof Plane Specification dialog. See Roof Plane Specification 
Dialog on page 828.          

One way to produce a barrel roof is using a single roof plane that starts out flat (zero pitch) and covers the entire building.          

CURVING A SINGLE ROOF PLANE

To curve a roof plane
 1.  Draw a simple four wall structure with a 4 in 12 pitch shed roof.           

 2.  Select the roof plane and click the Open Object  edit button to open the Roof Plane Specification dialog.          

 3.  On the GENERAL panel, change the Pitch to 0 in 12.          

 4.  Check Curved Roof and notice that the Angle values below are both at 0.0°.          

 5.  Change the Angle at Eave from 0° to 45° and press the Tab key. Notice that the other values update and that in 
order to maintain the 0 in 12 pitch, the Angle at Ridge becomes -45°.           
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CURVING TWO ROOF PLANES

You can also create a barrel roof using  two roof planes. A 12 in 12 pitch is used because it allows the curved roof to be 
nearly vertical at the eave and nearly flat at its peak.           

To curve two roof planes
 1.  Draw a simple four wall structure with a 12 in 12 pitch gable roof.           

 2.  Select one of the roof planes and click the Open Object  edit button to open the Roof Plane Specification dialog.          

 3.  Check Curved Roof and notice that the Angle values below are identical.           

 4.  Change the Angle at Ridge from 45° to 1°. This makes the roof plane nearly flat at the ridge. The Angle At Eave 
updates to maintain the 12 in 12 pitch.          
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 5.  Repeat this process with the other roof plane.          

COMPOUND CURVED ROOF PLANES

Compound curves can be created using two or more curved roof planes or a combination of straight and curved roof planes.           

Before curving roof planes or joining the edges of any curved 
plane, make sure all flat roof planes are correctly joined. See 

Join Roof Planes on page 826.

To create a compound curved roof
 1.  Draw a simple four wall structure with a 4 in 12 pitch gable roof.          

 2.  In plan view, select one of the roof planes and pull its ridge edge back so that it is 4 feet from the wall. Do the same 
to the other roof plane.          

 3.  Select both roof planes and check Curved Roof in the Roof Plane Specification dialog. Set the Angle at Ridge to 
33.6901°, which is the same as 8 in 12. Notice that the Angle at Eave is almost flat.          
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 4.  Use the Roof Plane  tool to draw the two high roof planes. As you create each one, draw its Baseline along to the 

ridge edge of one of the low roof plane. See To draw a roof plane on page 819.           

 5.  Select the two new roof planes, click the Open Object  edit button, and change their Pitch to 33.6901° - or 8 in 

12. Viewed in 3D, the planes appear to join together into one.          

CURVED ROOF PLANE INTERSECTIONS

Curved roof planes can be joined to other roof planes using the Join Roof Planes  edit tool. Often, the result is a curved 

roof valley or hip.           

In many instances, a curved roof plane can only be joined to another roof plane if its Angle at Ridge or Radius to Roof 
Surface setting is changed. See General Panel on page 829.           

When that is the case, the Join Curved Roof Plane dialog will open when the Join Roof Planes  tool is used.           

 l Choose Lock the Radius to Roof Surface to maintain the roof plane’s curvature but change its angle at the ridge 
edge.          

 l Choose Lock the Angle at Ridge to maintain the roof plane’s angle at its ridge edge but change its curvature.          

In order to straighten a curved roof edge, select the edge in question and click the Straighten Curved Edge  edit button.          

 

Ceiling Planes
Ceiling planes are drawn the same way as roof planes and are edited using the same tools. They are useful for 
creating custom vaulted ceilings. See     Vaulted and Cathedral Ceilings on page 440.         

Ceiling planes are drawn using the same default pitch as roof planes, specified in the Build Roof dialog. See Build Roof 
Dialog on page 809.          
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If you wish, you can specify the desired pitch in the Build Roof dialog before drawing a ceiling plane, or you can change 
the pitch after it is drawn in the Ceiling Plane Specification dialog. See Ceiling Plane Specification Dialog on page 843.          

There are a few things to remember when drawing ceiling planes.          

 l Ceiling planes should be created over rooms that have Flat Ceiling Over this Room unchecked in the Room 
Specification dialog. See Structure Panel on page 444.          

 l The Baseline of a ceiling plane should be drawn along the outer surface of the bearing wall’s Main Layer. This allows 
the ceiling plane to extend over and be supported by the wall. See The Main Layer on page 388.           

 l The sloping edge at the side of a ceiling plane should butt to the inside of the wall.          
 l Ceiling planes act independent of the roof planes above.          
 l Usually, the pitch of a ceiling plane is lower than the pitch of the corresponding roof plane.           
 l Ceiling planes can be joined together using the Join Roof Planes  edit button. See Join Roof Planes on page 826.          

 l Select a ceiling plane and click the Open Object  edit button to open the Ceiling Plane Specification dialog. See 

Ceiling Plane Specification Dialog on page 843.          

DISPLAYING CEILING PLANES

Ceiling planes are drawn on the “Ceiling Planes” layer by default, although you can place a ceiling plane on any 
layer. See Line Style Panel on page 845.         

Manually drawn Ceiling Planes  can also display labels when the “Roofs, Labels” layer is on. See Roof Plane Labels on 

page 821.          

EDITING CEILING PLANES

Ceiling planes can be edited much like roof planes using their edit handles and edit toolbar buttons. See Editing Roof and 
Ceiling Planes on page 823.           

Ceiling planes can also be edited in their specification dialog. See Roof Plane Specification Dialog on page 828.           

As with roof planes, the ceiling planes layer can be locked to prevent them from being selected.           
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DELETING CEILING PLANES

There are several ways to delete ceiling planes. See Deleting Objects on page 289.          

  Select Build> Roof> Delete Ceiling Planes to delete all ceiling planes in the current plan.          

  Ceiling planes can also be deleted at once in the Delete Objects dialog. See Delete Objects Dialog on page 289.         

  Select a ceiling plane or group of ceiling planes, then click the Delete edit button or press the Delete key.          

 

Ceiling Plane Specification Dialog
Select a ceiling plane and click the Open Object edit button to open the Ceiling Plane Specification dialog.

The Ceiling Plane Specification dialog is similar to the Roof Plane Specification dialog. See Roof Plane Specification 
Dialog on page 828.

The Ceiling Plane Specification dialog has the following panels:

GENERAL PANEL

There are four values that define the 3D orientation of a ceiling plane: Ridge Height, Height Inside Wall, Height Outside 
Wall, and Pitch.          

Locking any of the Height values defines that value as the pivot point for the selected ceiling plane. Each of these 
dimensions is measured from the first floor default elevation of 0' - 0".           
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If you lock the Pitch and change a Height value, the ceiling plane moves vertically, keeping the same slope. It will not 
pivot.           

Changing these values does not affect the 2D representation of the ceiling plane.          

 
Height/Pitch

Specify the Height and Pitch of the selected ceiling plane. Heights are measured to the bottom surface of the ceiling plane’s 
rafters or trusses, at the center point of the ceiling plane’s baseline. See The Baseline on page 819.                 

 l Select the Elevation Reference, which is where the Height values below are measured from.           

 l Define the Ridge Height, or lock this value to make it the ceiling plane’s pivot point.          

 l Define the Height Inside Wall, or lock this value to make it the ceiling plane’s pivot point. If the plane is drawn 
over a wall, this is located at the inside surface of the wall’s Main Layer.          

 l Define the Height Outside Wall, or lock this value to make it the ceiling plane’s pivot point. Only available when a 
ceiling plane is drawn over a wall, this is the height of the lower edge of the ceiling rafters, were they not clipped by 
the wall below.           

 l Specify the selected ceiling plane’s Pitch, or lock this value to move the plane vertically when a Height value is 
changed.           

 l Check Pitch in Degrees to display the Pitch value in degrees               in all dialogs as well as in roof plane labels.  Values 
between -89° and 89° can be entered. When Pitch in Degrees in unchecked, Pitch is described in terms of rise and 
run: x inches in 12 or x mm in 1000. See Roof Pitches in Degrees on page 863.

 
Measurements

Information about the structure of the selected ceiling plane(s) displays here for reference.

 l In Chief Architect Interiors only, specify the Structure Thickness.                           In Chief Architect Premier, the Structure 
Thickness is reported here for reference but is specified on the STRUCTURE panel. The default Structure Thickness is 
the same as that for roof planes and is set in the Build Framing dialog. See Build Framing Dialog on page 873.         

 l The Vertical Rafter Depth is defined by measuring a plumb line through the ceiling structure. The greater the pitch, 
the greater the vertical structure depth.         

 l The Top of Plate value is the top plate height of the bearing wall, and is also the ceiling height of the room.         

 l Overhang From Wall Inside - Only appearing when a ceiling plane is drawn over a bearing wall, this is the 
horizontal distance from the Baseline to the inside Main Layer surface of the wall. The Baseline is typically drawn 
over the outside Main Layer surface, so this value is equal to the wall’s Main Layer thickness.         

 l Clip End - This is the amount a ceiling rafter’s underside must be clipped at its lower end to rest on the wall top 
plate, and is zero if the ceiling plane was not drawn over a bearing wall. This value is equal to the ceiling plane’s 
rise in slope over the distance of the Overhang from Inside Bottom.

The Outside Bottom value plus the Clip end value equals the Top of Plate value.         
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Ceiling Finish

In Chief Architect Interiors only, specify how the Ceiling Finish surface on the underside of the selected ceiling plane is 
built.              In Chief Architect Premier, the Ceiling Finish is specified on the STRUCTURE panel. 

 l When Use Room Ceiling Finish is checked, the selected ceiling plane’s ceiling finish thickness and material are 
defined by the room below and the “Ceiling Surface” component will not be available on the MATERIALS panel. 
Uncheck this box to define the ceiling finish as part of the ceiling plane and enable the Ceiling Thickness option.         

 l Specify the Ceiling Thickness, which is the thickness of the bottom surface of the ceiling plane.          

 
Curved Ceiling

Check Curved Ceiling to specify the selected ceiling plane as curved. See Curved Roof Planes on page 838.         

 l Specify the ceiling plane’s Angle at Eave, Angle at Ridge and Radius to Framing Bottom.          

 l These three values are interrelated - when one is changed, the other two adjust accordingly. You may find it helpful 
to first specify the Radius value, then the Angle values.           

A flat ceiling plane with a pitch of 0 has angles of 0 at both the ridge and eave, as well as a radius of 0.           

STRUCTURE PANEL

The settings on the STRUCTURE panel of the Ceiling Plane Specification dialog are a subset of those found on the ROOF 
panel of the Build Framing dialog. See Roof Panel on page 884.          

POLYLINE PANEL

The POLYLINE panel states the length of the ceiling plane’s Perimeter, its Framing Area, and its Projected Area. See 
Polyline Panel on page 833.           

SELECTED LINE PANEL

This panel is similar to the LINE panel of the Line Specification dialog. See Line Panel on page 309.          

LINE STYLE PANEL

For information about the settings on this panel, see Line Style Panel on page 310.          

FILL STYLE PANEL

The settings on the FILL STYLE panel affect the appearance of the selected ceiling plane in plan view. For information about 
these settings, see Fill Styles on page 197.          

MATERIALS PANEL

In Chief Architect Interiors only, the “Ceiling Surface” material can be specified here. It is only available, however, when 
Use Room Ceiling Finish is unchecked on the GENERAL panel.         

For more information about the settings on this panel, see Materials Panel on page 1055.         
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LABEL PANEL

Ceiling plane labels display when the “Roofs, Labels” layer is turned on and use the Text Style assigned to that layer. The 
Automatic Label for ceiling planes is blank, but you can specify a custom label. See Roof Plane Labels on page 821.         

For information about the settings on this panel, see Label Panel on page 712.         

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. See Components Panel on page 1335.         

 

Gable/Roof Lines
The Gable/Roof Line tool can be used to automatically generate a gable above the bearing wall of a hip roof plane. It 
is best used in situations where roof directives in walls are not possible. For example:         

 l Where a wall is not present, such as across the front of an alcove;         
 l Over a Bay, Box, or Bow Window.             

See Roof Directives in Walls on page 381.         

In addition, the Gable Over Door/Window edit button allows you to add a small Gable/Roof Line over one or more 
selected doors or windows the next time automatic roof planes are built.

Gable/Roof Lines display in plan view when the “Roofs, Gable Lines” layer is set to display and can be selected and edited 
much like regular CAD lines. See Editing Line-Based Objects on page 218.          

CREATING A GABLE

To create a gable using a Gable/Roof Line
 1.  Select Build> Roof> Gable/Roof Line , then click and drag to draw a line outside the exterior wall that you 

want to create a gable over.         

 2.  Position the Gable/Roof Line within 10 feet (2260 mm) of the wall’s Main Layer but not touching it. See The Main 
Layer on page 388.         

 l Make sure that the Gable/Roof Line is exactly parallel to the exterior wall.          

 3.  Resize the Gable/Roof Line so that it is the length of the desired gable.         

 l The length of the Gable/Roof Line determines the gable width at the wall Main Layer, not at the overhang.          

 l At the larger roof eave, a gable roof is wider than the gable line by twice the overhang distance.         

 4.  You can specify the pitch of the gable roof planes and their overhang in the Gable Line Specification dialog. See 
Gable Line Specification Dialog on page 849.         

 5.  Select Build> Roof> Build Roof  and regenerate the roof. See Build Roof Dialog on page 809.         
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To use the Gable Over Door/Window tool
 1.  Select one or more doors or windows.          

 2.  Click the Gable Over Door/Window  edit button.         

 l Gable Over Door/Window is not available for openings placed in Full Gable Walls or for Bay, Box or Bow 
Windows. See Bay, Box, Bow Windows and Roofs on page 620.         

 3.  In the Gable Line Specification dialog, specify the desired Pitch and Overhang for the gable roof. See Gable Line 
Specification Dialog on page 849.         

 4.  The next time automatic roof planes are built, gables will be created over each of these doors and windows.         

 l Each gable will extend 12” (300 mm) on either side of its door or window.         

 l If two of these openings are within 30” (750 mm) of each other on the same wall, a single gable will be created.          

 l If you move or resize the door or window(s), the associated Gable/Roof Line will not update until the roof is built 
again.          

 5.  There are several ways to remove a Gable Over Door/Window:

 l Select the door(s) or window(s) and click the Delete Gable Over Opening  edit button.

 l Select the gable line and click the Delete  edit button. 

 l All Gable/Roof Lines can be deleted using the Reset to Defaults dialog. See Reset to Defaults on page 94.

 l The next time the roof is built, the gable or gables will be removed.          

COVERING AN ALCOVE

A Gable/Roof Line  can also be used to maintain a roof plane baseline where there is no wall below. For example, you 

can use it to extend a roof plane across an alcove, rather than wrap into it.          
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In order for a Gable/Roof Line to direct the roof to extend over an alcove or other area where no wall is present, it must be 
aligned with the exterior walls’ Main Layer.          

COVERING A BAY

A Gable/Roof Line  drawn across a bay causes a gable to be built above the bay when roofs are automatically 

generated.         

In order for the gable to be built, at least one end of the Gable/Roof Line must extend past the side walls of the bay.          

If the Gable/Roof Line is drawn along the outer edge of the bay’s outer wall’s Main Layer, the resulting gable will extend 
only to the eave of the larger roof. Draw the Gable/Roof Line beyond the bay’s outer wall to extend out past the larger 
roof’s eave.           
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Gable Line Specification Dialog
Select a gable line and click the Open Object edit button to open the Gable Line Specification dialog. This dialog 
also opens whenever the Gable Over Door/Window  edit button is clicked. See Gable/Roof Lines on page 846.         

GABLE LINE PANEL

The settings on this panel affect the structure of the two roof planes associated with the selected Gable/Roof Line.         

The defaults for these settings are set in the Build Roof dialog. See Roof Panel on page 810.         

 l Specify the Pitch of the roof planes that form the gable.         
 l Specify the Overhang of the roof planes that form the gable.          

LINE PANEL

The settings on the LINE panel are available for a variety of other objects in the program. See Line Panel on page 309.         

LINE STYLE PANEL

The settings on the LINE STYLE panel are available for a variety of other objects in the program. See Line Style Panel on 
page 310.         

ARROW PANEL

The settings on the ARROW panel are available for a variety of other objects in the program. See Arrow Panel on page 312.         

 

Skylights and Roof Holes
A skylight can be created by selecting Build> Roof> Skylight and drawing a rectangular polyline within a single 
roof plane. You can also simply click once within a roof plane to place a 2’ x 2’ skylight. These measurements 

describe the skylight’s projected size, as measured in plan view: roof pitch is not taken into account.

The Skylight  tool places a flat panel skylight into a roof hole, produces a hole in the ceiling platform below, and 

automatically generates the skylight shaft between these two holes.

To place a skylight in a vaulted ceiling, uncheck Flat Ceiling Over This Room in the Room Specification dialog, draw the 
ceiling planes to produce the vault and edit them as needed, and then draw the skylight. See Structure Panel on page 444.
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Note: If a sloped ceiling plane is present under the skylight, a hole in this 
ceiling plane is automatically produced. This hole is visible, and may be 
located directly under the roof hole. It can be moved and edited 
separately. 

Skylights are placed on the "Roofs, Openings" layer by default. See Displaying Objects on page 180.

Although inserted into roof planes, skylights are able to display in both plan and 3D views when their containing roofs do 
not. 

EDITING SKYLIGHTS

Skylights can be selected individually or in groups and can be edited using the edit handles, edit toolbar buttons, or the Roof 
Hole/Skylight Specification dialog. See Roof Hole/Skylight Specification Dialog on page 850.

Skylights must always be contained by a single roof plane. If the roof plane is deleted, any skylights or holes it contains are 
also deleted. Aside from this restriction, skylights can be edited much like standard closed polylines. See Editing Closed 
Polyline-Based Objects on page 230. 

If you clear the Skylight check box in the Roof Hole/Skylight Specification dialog, the curb and glass for the skylight is 
removed but the opening remains.           

By default, the flat ceiling hole does not display separately; but it can be edited separately, and even deleted entirely. See 
Roof Hole/Skylight Specification Dialog on page 850.           

A roof hole can also be created using the Create Hole  edit tool. See Polyline Holes on page 234.          

 

Roof Hole/Skylight Specification Dialog
Select a skylight and click the Open Object edit button to open the Roof Hole/Skylight Specification dialog. See 
Skylights and Roof Holes on page 849.    
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GENERAL PANEL

  Skylight

 l Check Skylight to specify this polyline as a skylight. If unchecked, the curb and glass for the skylight are removed 
but the opening remains. 

 l Specify the Frame Width and Height of the selected skylight. These values describe the skylight’s projected size, as 
measured in plan view: roof pitch is not taken into account.

 
Inside Hole Rim

Specify how the hole for the skylight is framed as well as the shape of the skylight well where it passes through the roof 
plane.     

 l Select Square Sides to cut the framing for the skylight square to the pitch of the roof.

 l Select Plumb Sides to produce framing for the skylight that is plumb-cut.

 l Select Plumb/Square to produce framing with the bottom edge plumb-cut and the top edge, square-cut.
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Ceiling Hole

Control how the hole in a room’s Flat Ceiling is created below the roof hole/skylight. These options do not affect the hole in 
a manually drawn Ceiling Plane. See Structure Panel on page 444.          

 l Select Skylight Automatically Generates Ceiling Hole to automatically generate and maintain the skylight’s 
ceiling hole.           

Note: The hole produced in a sloping ceiling plane by a skylight 
must be always manually maintained if the skylight is moved or 
resized.

 l Select Manually Edit Ceiling Hole Polyline to display the editable ceiling hole polyline in plan view in addition to 
the polyline in the roof plane.           

 l Select Do not generate ceiling hole to generate a hole through the roof plane but not the flat ceiling.          

 l Uncheck Generate shaft to ceiling hole to generate a roof hole and a hole in the flat ceiling, but no vertical surfaces 
connecting them. When checked, a shaft between the two is produced. Not available if Do not generate ceiling hole 
is selected, above.           

POLYLINE PANEL

The POLYLINE panel states the roof hole/skylight’s Perimeter, its Framing Area, and its Projected Area. See Polyline 
Panel on page 833.

SELECTED LINE PANEL

This panel is similar to the LINE panel of the Line Specification dialog. See Line Panel on page 309.          

LINE STYLE PANEL

For information about the settings on this panel, see Line Style Panel on page 310.

FILL STYLE PANEL

The settings on the FILL STYLE panel control the appearance of the selected roof hole or skylight in plan view. See Fill 
Styles on page 197.

MATERIALS PANEL

For information about the MATERIALS panel, see Materials Panel on page 1055.

LABEL PANEL

Roof hole and skylight labels display when the “Roofs, Labels” layer is turned on and use the Text Style assigned to that 
layer. The Automatic Label for these objects is blank, but you can specify a custom label. See Roof Plane Labels on page 
821.

For information about the settings on this panel, see Label Panel on page 712.         

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. See Components Panel on page 1335.          
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Dormers and Crickets
Dormers can be drawn manually or placed automatically using the Auto Dormer tools. Automatic Dormers 
can be placed only under certain conditions:          

 l Automatic Dormers can only be placed entirely within a single roof plane. They cannot extend past the eaves or ridge 
of this roof plane.         

 l Automatic Dormer side walls cannot be positioned above other walls in the plan.         

If you click within a roof plane to place an automatic dormer, but click too close to an eave or the ridge, a dormer will not 
be created; however, its outline will. Move this outline box to a location that meets the dormer’s requirements and it will be 
created.         

Automatic dormers reside by default on their own layer, “Auto Dormers”. Their display cannot be turned off; however, you 
can lock this layer to prevent unintended editing. See Layer Display Options Dialog on page 183.          

The initial width, height, roof style and other settings of Auto Dormers are set in the Dormer Defaults dialog. See Dormer 
Defaults on page 805.         

AUTO FLOATING DORMER

Select Build> Roof> Auto Floating Dormer and click the roof plane where you would like to place the center of the 
dormer's front wall. 

The bottom edges of all floating dormer walls are cut off by the underlying roof plane.                           To produce such a dormer manually, 
check Roof Cuts Wall at Bottom for the dormer walls on the ROOF panel of the Wall Specification dialog.

Usually, no room is defined by the walls of this type of dormer.           

The images below show both the outside and inside of a typical              floating dormer.         

A floating              dormer can be placed in plan view on the same floor that its underlying roof plane displays on, or it can be 
placed on the floor above. Normally, it does not matter what floor the dormer is on; but in some cases, it may need to be on 
the floor above so that the dormer walls do not interfere with walls or railings in the room below.          

Regardless of which floor it is placed on, a dormer must always fit within a single roof plane. When placing a dormer on the 
floor above, you may find it helpful to turn on the Reference Display . See The Reference Display on page 69.          

You may also find it helpful to display the underlying roof plane on the floor above using the Roof Plane Specification 
dialog. See Roof Plane Specification Dialog on page 828.         

If the dormer is placed on the same floor as the underlying roof plane and the room below, and if the room has a flat ceiling, 
then a hole will be produced in the ceiling under the dormer.          
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AUTO DORMER

Select Build> Roof> Auto Dormer and click on a roof plane where you want the center of the dormer's front wall to 
be.         

The walls of an auto dormer go to the floor and meet a knee wall on either side on the back of the dormer. This knee wall 
must run parallel to the underlying roof plane’s Baseline.          

 l If you are creating a (non-floating) auto dormer, a knee wall must already exist. The dormer side walls run back to the 
knee wall and the knee wall is broken where the dormer walls meet it.           

 l The knee wall does not have to be designated as such in the Wall Specification dialog unless you are generating an 
automatic roof. See Knee Walls on page 384.          

 l A non-floating dormer must always be created on the same floor as the knee walls.           

MANUALLY DRAWN DORMERS

Once you are familiar with Chief Architect’s roof tools, drawing dormers manually can be quite simple. There are several 
different ways to draw dormers; some methods work better in certain applications.         

A variety of resources with information about drawing dormers manually is available at chiefarchitect.com.         

There are a few things to keep in mind.          

 l Walls extend upward until they meet an overlying roof plane.           
 l A wall can also be cut by underlying roof planes if Roof Cuts Wall at Bottom is checked in the Wall Specification 

dialog. For this to work properly, the edge of the roof plane must extend completely through the width of the wall. See 
Clerestory and Dormer Walls on page 382.          

 l Polylines can be converted into a Hole in Roof/Ceiling that allows walls to extend above or below the roof line. See 
Convert Polyline on page 265.          
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MANUALLY DRAWN CRICKETS

The automatic roof generator will not produce crickets in a roof plan; however, you can manually draw a cricket using the 
Roof Plane  tool. 

 

Editing Auto Dormers
Auto Dormers are a collection of objects that behave as one. When a dormer is selected, it can be edited using its edit 
handles, edit tools, and specification dialog. See Dormer Specification Dialog on page 856.         

If you click the Explode Dormer  edit button, the dormer’s individual components can be edited.          

USING THE EDIT HANDLES

When selected, an auto dormer displays three edit handles. The Move handle displays over the front wall and allows you to 
relocate the dormer. Two resize handles display on the side walls and allow you to change the width of the dormer.         

There are some things to keep in mind when editing auto dormers and auto floating dormers using the mouse.         

 l Dormers move at 90° angles unless the Ctrl key is pressed before moving them.         
 l The dormer must be contained within one underlying roof plane.         
 l Auto dormers cannot be moved beyond the required knee wall.         

EDITING THE WINDOW

Dormer windows can be selected, edited, deleted and replaced just like other windows. See Editing Windows on page 597. 
You can place several windows in the front wall.         

Unless the dormer's window has been edited or changed in the Window Specification dialog, when the dormer width is 
changed, its width changes automatically to fill the front dormer wall. If the window has been edited, its width stays fixed. 
If a change to the dormer makes its front wall too short to hold the window, the window reverts to auto width.         

EXPLODE AUTO DORMER

Click the Explode Auto Dormer edit button to explode a selected auto dormer into its component parts. The dormer 
walls, roof planes, window, and hole in the roof/ceiling can be edited individually. 

The program treats roof planes over an exploded auto dormer as though they were manually drawn, allowing you to protect 
them from being rebuilt in the Build Roof dialog. See Roof Panel on page 810.          

Once exploded, it is not possible to block the components into a Dormer object again.          
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Dormer Specification Dialog
Select a dormer              or dormers              and click the Open Object edit button to open the Dormer Specification dialog.         

The settings in this dialog are also found in the Dormer Defaults dialog, where they apply to all dormers as they are created 
rather than to a selected dormer.         

ROOF PANEL

  Roof Style

 l Choose a roof Type from the drop-down list.  You can choose from Hip, Gable, Shed, Gambrel, Mansard, Barrel, 
Curved Eave, Hip Curved Eave or Eyebrow.          
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  Pitch

 l Specify the Pitch of the dormer roof planes. The default dormer pitch applies to all dormer roof types except Shed, 
which has a default 3 in 12 pitch. For Gambrel and Mansard types, this applies to the lowest, or eave, roof planes.          

 l Check Pitch in Degrees to display the Pitch value in degrees in all dialogs as well as in roof plane labels; uncheck it 
to display the pitch in terms of rise and run. See Roof Pitches in Degrees on page 863.         

 l The Second Pitch specifies the upper roof of a Gambrel, Mansard, curved eave, and hip curved eave.           

 l When a Second Pitch is used, specify the In from Eave distance, measured from the lower roof plane eave to where 
the upper roof plane starts.          

 
Roof Overhang

Specify the depth of the selected dormer’s Eave and Gable Overhangs.         

  Fascia/Rafters

 l Specify the Fascia Depth for gable fascia and the Eave Fascia Depth.         

 l Specify the Rafter Depth.         

 l The Vertical Rafter Depth displays for reference.         

 l Specify whether to Include Boxed Eaves, Gutters, Frieze, and/or Shadow Boards.

 l Select either Plumb or Square Rafter Cut.         

 
Auto Roof Returns

See Roof Returns on page 859.              

 l Check Auto Roof Returns to generate roof returns on the selected dormer. Roof Returns can be only specified for 
Gable dormers. 

 l Specify the horizontal Length of the roof return in inches (mm).         

 l Enter a value in inches (mm) to Extend the roof returns past the dormer overhang.           

 l Specify a Gable, Hip, or Full roof return.          

 l Specify a Sloping or Flat roof return.         

 l Check the boxes to Include Shadow Boards, Ridge Caps, and/or Frieze molding on the roof returns.          
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WALLS PANEL

 l Select a Wall Type for the dormer walls from the drop-down list.
 l Click the Define button to open the Wall Type Definitions dialog to create or modify existing wall types. See Wall 

Type Definitions Dialog on page 390.          
 l Specify the Height of the dormer, as measured from where the top of the underlying roof plane meets the dormer front 

wall exterior to the top plate of the dormer roof’s bearing walls.

This top height is called the dormer ceiling height, even if the ceiling in the dormer is not flat. The top dormer window 
casing is usually close to this height.          

 l Check Set to Existing Ceiling to assign the ceiling height of the room behind the dormer to the dormer. Not available 
in the Dormer Defaults dialog.          

 l Height to Reach Existing shows the difference between the dormer height where the inside of the wall meets the 
underside of the roof and the ceiling of the room behind it.         

 l Specify the dormer’s Width, measured from the outside surfaces of the dormer side walls.         
 l Form Room Inside Dormer is used only for floating dormers and creates a flat ceiling in the dormer. If you check 

this option, you should define the dormer on the floor above the room it is positioned over. If this room has a flat 
ceiling, checking this option makes a hole in the ceiling under the dormer. This option should normally be left 
unchecked.         

Dormer windows can appear too narrow on the outside due to the space required for interior casing to clear the inside 
surfaces of the side walls. Two additional settings are available in the Dormer Defaults dialog to help address this.          

 l When Set Inside Window Trim Width is checked, you can set the Inside Window Trim value, which is the default 
interior casing width for dormer windows. When unchecked, dormer windows use the default interior casing width set 
in the Window Defaults dialog.          

LINE STYLE PANEL

For information about the settings on this panel, see Line Style Panel on page 310.         

 

Roof Returns and Other Details
Chief Architect offers a selection of tools to add architectural details to your roof design.
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ROOF RETURNS

A roof return is a small decorative roof plane that connects to the low side of a gable roof overhang and extends below the 
upper triangular portion of the gable wall. Three styles of roof returns that can be produced automatically.         

The first two styles are called Gable and Hip returns since the return ends in a gable or hip.          

Hip and Gable Roof Returns

The third is called a Full return because it extends under the entire gable to connect both sides and is sometimes referred to 
as a water table. In order for a Full return to be created, the roof planes on each side must have the same              Fascia Top Height.
         

Full Roof Return

It is not difficult to manually draw roof returns using small roof planes, but it is quicker to produce them automatically. 
Roof returns are generated automatically on a wall by wall basis using settings in the Wall Specification dialog. See Roof 
Panel on page 401.         

These roof return settings are also found in the Dormer Specification dialog for gable roof dormers and function similarly. 
See Roof Panel on page 856.         

The pitch of an automatically generated roof return is the same as that of the roof plane above it. Its structure is the same as 
that of the subfascia and eaves of the roof plane above. See Structure Panel on page 832. 
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BOXED EAVES

Boxed eaves have a flat, horizontal soffit surface instead of one that follows the underside of the rafter ends. Boxed eaves 
can either extend out to the gable fascia or build flush with the adjacent exterior wall.           

Boxed Eave at a gable end

You can specify Boxed Eaves for all roof planes in the Build Roof dialog and for individual roof planes in the Roof Plane 
Specification dialog. See Options Panel on page 815.          

The flush eave end uses the wall’s surface material by default; however, you can specify a different material if you wish. 
See Materials Panel on page 818.          

FASCIA AND SHADOW BOARDS

Fascia               and shadow boards can be added to both automatic and manually drawn roof planes. They can be specified in the 
Build Roof dialog and added to roof planes as they are created, and they can be added to or removed from individual roof 
planes and roof plane edges in the Roof Plane Specification dialog.

 l Fascia and eave fascia can be specified in the Build Framing and Build Roof dialogs. See Roof Panel on page 884.          
 l One or more shadow boards profiles can be specified in the Build Roof dialog. See Shadow Boards Panel on page 

818.          
 l Fascia and shadow boards are generated whenever the roof is built or rebuilt.
 l Fascia and shadow board materials can be specified separately. See Materials Panel on page 818.

Fascia and shadow boards display in 3D views and are included in the materials list. 

Fascia
The material specified for fascia in the Build Roof dialog displays as part of the roof plane rather than as a separate object. 
It displays in 3D views but not plan view.          

In addition, sub fascia boards are created when roof framing is generated and are placed on the “Framing, Roof Rafters” 
layer. The fascia material is not applied to these framing members, however.           

The width and depth of fascia and eave fascia can be specified in the Build Framing dialog. See Roof Panel on page 884.          

Shadow Boards
Shadow boards are added to both automatic and manually drawn roof planes when one more shadow board profile is 
specified in the Build Roof dialog. They can also be added to, removed from, or customized for individual roof planes in the 
Roof Plane Specification dialog. See Shadow Boards Panel on page 818.          
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Automatically generated shadow boards are 3D Molding Polylines  that follow the eaves of the roof. You can specify 

whether each profile is applied along eaves, along gable eaves, or along both. You can also use the same shadow board 
profile multiple times and adjust the offsets for each to suit different conditions. See Molding Polylines on page 951.           

Shadow boards are placed on the “Roofs, Trim” layer.  By default, this layer is locked, turned on in 3D views but not in plan 
view.           

If a shadow board polyline is edited, it will no longer be considered an Automatic shadow board, and will not be deleted and 
replaced when the roof is rebuilt.           

You can modify individual edges of an Automatic shadow board polyline indirectly by changing settings on the SHADOW 
BOARDS panel of the Roof Plane Specification dialog.          

Note: In order to generate shadow boards, you must also specify that 
fascia be used.

SOFFITS

Soffits are the layer of material that covers the rafter ends on the underside of roof eaves and can be constructed in               several 
ways:

 l By default, soffits follow the underside of the rafter ends and butt against the inside edge of the fascia. The rafter end 
depth and thus the soffit height is controlled by the Gable Sub Fascia Depth. See Roof Panel on page 884.          

 l Check Flat Under Eave Sub Fascia for soffits that follow the underside of the rafter ends until they reach the eave 
subfascia, at which point they flatten out until the butt against the inside of the fascia.          

 l Boxed eaves can be specified in the Build Roof and Roof Plane Specification dialogs. Boxed eave height is controlled 
by the Eave Sub Fascia Depth. See Options Panel on page 815.          

GUTTERS

Gutters are added to non-sloping eaves on both automatic and manually drawn roof planes when a profile is specified in the 
Build Roof dialog. They can also be added to, removed from, or customized for individual roof planes and roof plane edges 
in the Roof Plane Specification dialog. If two roof planes are assigned different gutter profile or materials, however, the 
gutters will not merge. See Gutter Panel on page 818.         

Automatically generated gutters are basically Molding Polylines  that follow the eaves of the roof but are not created on 

sloped gable eaves.           

 l Gutters are regenerated or removed whenever the roof is built. See Roof Panel on page 810.          
 l A gutter profile can be specified. See Gutter Panel on page 818.           
 l The gutter material can be specified. See Materials Panel on page 818.           

Gutters are placed on the “Roofs, Gutters” layer. By default, this layer is turned on in 3D views but not in plan view, is 
included in the materials list, and is locked. See Layer Display Options Dialog on page 183.          

If a gutter polyline is edited, it will no longer be considered an Automatic gutter, and will not be deleted and replaced when 
the roof is rebuilt.           

You can modify individual edges of an Automatic gutter polyline indirectly by changing settings on the GUTTER panel of 
the Roof Plane Specification dialog.          
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FRIEZE MOLDING

Frieze moldings are added to both automatic and manually drawn roof planes when one or more frieze profile is specified in 
the Build Roof dialog. They can also be added to, removed from, or customized for individual roof planes in the Roof Plane 
Specification dialog.          

Automatically generated frieze boards are placed along all exterior walls directly under the eaves. Frieze does not generate 
along railings; however, if an attic wall is built above a railing, it can generate along that wall.           

 l Frieze moldings are generated whenever the roof is rebuilt.           
 l You can specify whether each profile is applied under eaves, under gable eaves, or under both. You can also use the 

same profile multiple times and adjust the offsets for each to suit different conditions. See Frieze Panel on page 818.          
 l The materials used for frieze moldings can be specified. See Materials Panel on page 818.           

Automatically generated frieze moldings are 3D Molding Polylines  placed on the “Roofs, Trim” layer. By default, this 

layer is turned on in 3D views but not in plan view, and is locked.           

If a frieze molding polyline is edited, it will no longer be considered an Automatic frieze, and will not be deleted and 
replaced when the roof is rebuilt. See Frieze Moldings on page 959.          

RAFTER TAILS

Rafter tails are rafter ends that overhang the bearing walls and are located under the eaves. They can be the full rafter depth 
or trimmed to the depth of the soffits. Rafter tails can also be partially enclosed by soffits, and sometimes feature decorative 
profiles.          

To produce a particular type of rafter tail, set the correct defaults on the STRUCTURE panel of the Build Roof dialog before 
you build both the roof planes and the roof framing. See Roof Panel on page 884.          

To create full-depth exposed rafter ends
 l Uncheck Soffits.          
 l Uncheck Eave Sub Fascia.          
 l Uncheck Eave Fascia.          

To create hidden, trimmed rafter ends
 l Check Trim Framing To Soffits.           
 l Check Soffits.          

To create full-depth, partially-exposed rafter ends
 l Uncheck Trim Framing To Soffits.           
 l Check Soffits.          
 l Specify the desired Gable Sub Fascia Depth, which controls the soffit height.          

Soffit height is determined by the Gable Sub Fascia depth, which 
is set in the Build Roof dialog. See Structure Panel on page 817.

To add a decorative profile to rafter tails
 l Set soffits and fascia as needed to produce the desired rafter tail exposure, as described above.           
 l Select a rafter tail profile on the RAFTER TAILS panel of the Build Roof dialog. See Rafter Tails Panel on page 817.          
 l Decorative rafter tail profiles are molding profiles, which means that you can create your own custom profiles if you 

want. See Molding Profiles on page 948.           
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RIDGE CAPS

Ridge caps are roofing components that straddle the tops of roof ridges and hips. To generate ridge caps in Chief Architect 
Premier, specify one or more ridge cap profiles in the Build Roof dialog, and then build or rebuild the roof. Ridge caps will 
be produced on both automatically generated and manually drawn roof planes. See Ridge Caps Panel on page 818.          

The program’s default ridge cap profile has flat sides and is 1/2” (13 mm) thick and 6” (150 mm) on each side. It follows 
the pitch of each roof plane, and its thickness and size can be edited on the RIDGE CAPS panel.           

Ridge cap profiles are essentially a molding profile, though, which means that you can choose a different profile or molding 
symbol from the library or even create and use your own custom profile. See Molding Profiles on page 948.           

You can also use custom Symbol Moldings for ridge caps, but bear in mind that symbols cannot adjust their shape to match 
different pitches. As a result, different symbols will be required for different roof pitches. See Symbol Moldings on page 
950.           

Like shadow boards and frieze molding, automatically generated ridge caps are 3D Molding Polylines  placed along the 

ridges and hips. Ridge Caps are created on the “Roofs, Ridge Caps” layer. By default, this layer is locked, displays in 3D 
views but does not display in plan view.           

If a ridge cap polyline is edited, it will no longer be considered an Automatic ridge cap, and will not be deleted and replaced 
if the roof is rebuilt.           

You can modify individual edges of an Automatic ridge cap polyline indirectly by changing settings on the RIDGE CAPS 
panel of the Roof Plane Specification dialog. Bear in mind, though, that your changes may only be reflected in the model if 
you make the same changes to adjacent roof planes, as well.          

 

Roof Pitches in Degrees
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Chapter 24
 

Framing

In Chief Architect Premier, framing can be produced both manually and automatically, calculated in the Materials List, as 
well as listed in a schedule. 

Manual framing members are drawn by clicking and dragging, like drawing a CAD line. Automatic framing for the major 
components of a 3D model (floors, ceilings, walls and roofs) can be generated using the Build Framing dialog. 

Both manually drawn and automatically generated framing members can be selected and edited in 2D and 3D views.  

Trusses are covered in their own chapter, Trusses on page 910.

TOPICS

Framing Defaults 865
Manual vs. Automatic Framing 867
Framing Tools 870
Build Framing Dialog 873
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Framing Specification Dialog 902
Export to EasyFrame 906
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Framing Defaults
Select Edit> Default Settings to open the Default Settings dialog. Select Framing from the list, then click the Edit 
button to open the Framing Defaults dialog.

Both automatic and manually-drawn framing are generated according to the settings in the Framing Defaults dialog. This 
dialog is nearly identical to the Build Framing dialog in both appearance and function. The only difference is that the Build 
Framing dialog has check boxes that allow you to generate different types of framing automatically. See Build Framing 
Dialog on page 873.

Any changes made in the Framing Defaults or Build Framing dialog will affect subsequently drawn or generated framing, 
but not framing already present in the plan. 

The settings in the Framing Defaults dialog directly affect a 
variety of important structural elements in each plan which 

determine floor, ceiling and roof heights; so it is best to set your Framing 
Defaults before building your model. See Drawing a Plan on page 27. 

FLOOR AND CEILING FRAMING

Floor and ceiling platform depths contribute to the overall height of a structure, so their default values should be set as early 
as possible. See Floor Panels on page 874. 

If you plan to draw floor trusses, also see Trusses Panel on page 888. 

The default floor and ceiling platform settings for a given floor can be overridden on a room by room basis in the Room 
Specification dialog, or for individual platforms using Joist Direction  lines. See Structure Panel on page 444.

By default, automatically-generated floor and ceiling joists run in the direction that results in the shortest span between 
exterior walls, bearing walls, and/or beams. Joist Direction  lines also allow you to define the direction that joists in a 

particular floor or ceiling platform. See Joist Direction Lines on page 892.

In standard light frame construction, floor and ceiling platforms are built to pass over or bear on the wall framing; however, 
this is not always desired. You can specify that joists bear on a selected wall, that platforms hang on it, or that a wall build 
through platforms in the Wall Specification dialog. See Structure Panel on page 398.

FRAMING GROUPS

When floor or ceiling framing is automatically generated, the program tries to create a single platform that spans as much of 
the structure as possible. If you need separate floor and ceiling framing in an area of your plan, as you might for an addition 
to an existing structure, assign the rooms in that area to a non-default Framing Group.    

The program treats different Framing Groups as though they were built at different times. Wall framing builds through and 
divides the floor framing in different Groups, while ceiling framing butts against a ledger attached to the ceiling framing of 
an adjacent Group.     

Framing Groups are assigned using numbers. The Default Framing Group is 1, which is built “first”. Each subsequently 
numbered group is framed as though it were added to the structure later.     

Although Framing Groups affect how both floor and ceiling framing is generated, the Build Framing for Selected Object
(s)  edit tool only builds floor framing. See Build Framing for Selected Object(s) on page 900.    
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WALL FRAMING

Like other types of framing, wall framing is generated based on settings in the Framing Defaults dialog. See Wall Panel on 
page 877 and Openings Panel on page 880.

In addition, wall framing is dependent on settings from other sources:

 l Framing Type, Spacing, Width, Plate Count and size, and more can be specified for each Wall Type in the Wall Type 
Definitions dialog. See Wall Type Definitions Dialog on page 390.

 l Horizontal wall framing, or Girts, can be specified for each Wall Type, as well.
 l The structural specifications for individual walls can be set in the Wall Specification dialog. See Structure Panel on 

page 398. 
 l Stud layout can be pulled from a Framing Reference Marker or from the Start or End of each wall. See Framing 

Reference Markers on page 890.

DOOR AND WINDOW FRAMING

The rough openings, trimmers, and sills for doors and windows and legacy fireplace objects are set in their respective 
defaults and specification dialogs. See:

 l Door Specification Dialog on page 566
 l Window Specification Dialog on page 599
 l Fireplace Specification Dialog on page 738

Note: Door and window bucks do not automatically generate in concrete 
or block walls. 

HEADERS

The size, position, and composition of door and window headers can also be set in their respective defaults and specification 
dialogs. 

In addition, a range of header depths for openings of different widths can be specified in the Framing Defaults dialog. Check 
Calculate from Width in the Door and Window Defaults dialogs to assign header depths to openings based on their width. 
See Openings Panel on page 880.

Like other framing members, headers are assigned a Structure Type such as “Lumber” or “LVL”. By default, the program 
will try to ensure that an opening’s Header Type agrees with the framing material used by the wall it is inserted into. To do 
this, it compares the Header Type to the wall’s framing material: 

 l Wood framing types: Lumber, I-Joist, Glulam, Engineered Lumber, LVL, PSL, and VSL.
 l Steel framing types: Steel I, Steel Box, C Channel, and U Channel. 

If the Header Type agrees with the wall framing material, it will be unchanged; however, if it does not agree it will change 
to either “Lumber” in a wood-framed wall or “C-Channel” in a steel-framed wall. To prevent this from occurring and use 
the specified Header Type regardless of wall material, uncheck Automatic. See Structure Types on page 901. 

Box headers with top and bottom rails can also be specified. See Framing Panel on page 579. 

SILL PLATES

Sill plates are created when floor framing is generated. They are created over all exterior walls that have either Concrete or 
Brick material type as their Main Layer material and support a floor platform or a framed wall directly above. See The Main 
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Layer on page 388 and Materials and the Materials List on page 1064. 

Sill plate size and number can be specified in the Wall Specification dialog of the supporting masonry wall. Only the 
bottommost plate that comes into contact with masonry is specified as Treated. See Foundation Panel on page 405. 

These sill plates are placed on the “Framing, Sill Plates” layer by default. See Displaying Framing on page 894.

When a monolithic slab foundation is created, the bottom plates of framed walls built on the slab are specified as Treated 
and are placed on the “Framing, Wall” layer by default. 

As with sill plates, multiple bottom plates can be specified in the Framing Defaults dialog, but only the bottommost plate is 
specified as Treated. See Wall Panel on page 877. 

POSTS AND BEAMS

The Post, Floor Beam, and Roof Beam Defaults dialogs can be accessed via the BEAMS and POSTS panels of the Framing 
Defaults dialog. 

These defaults can also be accessed by double-clicking the respective drawing tools. In addition, the Deck Post and Deck 
Beam Defaults dialogs are similar, and can be accessed from the Deck Room Defaults dialog. See Room Type Defaults on 
page 419.

ROOF FRAMING

Settings on the ROOF and TRUSSES panels of the Framing Defaults dialog determine the structure of roof planes and 
manually drawn ceiling planes as well as how they rest on bearing walls, so it is important that their default values be set 
before building the roof. See Roof Panel on page 884 and Trusses Panel on page 888.

You can add non-structural purlins to the Roof Surface Definition and/or Roof Ceiling Finish Definition. Structural purlins 
can be added to the Roof Structure Definition. See Material Layers Definition Dialogs on page 1040.

If changes are made to these defaults that you need to apply to the entire roof plan, you will need to either manually edit or 
rebuild the entire roof - not just the roof framing. See Roofs on page 803. 

DECK FRAMING

Deck rooms have special automatically generated framing and are not affected by the settings in the Framing Defaults or 
Build Framing dialogs. Deck framing defaults are set in the Deck Room Defaults dialog. See Decks on page 430. 

FRAMING TYPES

By default, most framing is set to use “Lumber” as the material type. You can select from a number of other types, however, 
such as I-Joist and Glulam. See Structure Types on page 901.

 

Manual vs. Automatic Framing
Platform, roof, and wall framing can be produced manually or automatically. In most cases, automatically-generated framing 
is preferable because it is faster than manually placing, replicating and editing numerous individual framing members. 

In many plans, though, framing is drawn using both approaches. For example, a combination of automatically generated 
rafters and manually drawn trusses can be used to model a roof framing plan. See Mixing Trusses with Stick Framing on 
page 918. 

Regardless of how it is created, individual framing members can be selected and edited. See Editing Framing on page 897. 
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 l Automatic Framing on page 868
 l Manual Framing on page 868
 l Framing with Beams on page 869
 l Mixing Manual and Automatic Framing on page 869
 l Mixing Rafters and Trusses on page 869

AUTOMATIC FRAMING

Automatic framing of floor and ceiling platforms, walls and roofs can be generated using the Build Framing dialog. The 
settings in this dialog control the size, spacing, and type of framing drawn in a plan, and related structural information for 
the major components of the 3D model. See Build Framing Dialog on page 873.

Automatic framing of a particular structural component is not generated until the Build Framing dialog is opened to the 
appropriate panel and one of two check boxes selected:  

 l Select the Build check box to build automatic framing once. For example, check Build Wall Framing on the WALL 
panel, then click OK to build wall framing once based on the current state of the model. 

 l Select the Automatic check box, then click OK to build automatic framing every time a change is made to that 
structural component in the plan. For example, check Automatic Wall Framing on the WALL panel to rebuild all wall 
framing any time a wall is affected by changes to the model. 

Note: When Automatic framing of a particular type is enabled, framing 
of that type cannot be manually edited or deleted. 

In order for framing to generate in a particular layer of a structural component such as a wall assembly or floor platform, 
that layer must have the Framing specification. See Wall Type Definitions Dialog on page 390 and Material Layers 
Definition Dialogs on page 1040.   

By default, joists automatically generate in the direction that results in the shortest span; however, you can produce different 
results using interior walls specified as Bearing Walls, Bearing Lines , Floor/Ceiling Beams , and/or Joist 

Direction  lines. See Bearing Lines on page 893 and Joist Direction Lines on page 892.

MANUAL FRAMING

Framing objects can also be drawn manually. With the exception of Posts, framing objects are drawn by clicking and 
dragging in a straight line, the way other line-based objects are. See Line Tools on page 305.

The manual framing tools are organized into families: general framing, floor and ceiling framing and roof framing. The 
family that a drawing tool belongs to determines where it can be used: 

 l Roof framing objects can only be drawn within the area of one or more roof planes.
 l Floor and ceiling framing objects can only be drawn within one or more floor or ceiling platforms.
 l General Framing  objects and Posts  can be drawn anywhere in a model.

 l General Framing  objects can also be drawn in CAD Details. See CAD Details on page 340.

 l Wall Bridging  can only be drawn in a Wall Detail window. See In Wall Detail Views on page 896.               

REBUILDING AND RETAINING FRAMING

It is important to remember that framing does not update automatically when changes are made to the model unless it is set 
to do so. You can direct the program to rebuild the automatic framing of floors/ceilings, walls and/or roofs every time a 
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change to the model affects one of these components. To do this, select the Automatic check box on  the FLOOR, WALL, 
and/or ROOF panels of the Build Framing dialog. See Build Framing Dialog on page 873.

You can also rebuild the framing of a single wall, roof plane, or ceiling plane by clicking the Build Framing for Selected 
Object  edit button. The floor framing for a selected room can also be rebuilt using this tool.           

To learn more, see Keeping Framing Current on page 899.

When automatic framing associated with a particular panel in the Build Framing dialog is generated, any existing 
automatically produced framing of that type is deleted and replaced. You can prevent this from happening to a selected wall, 
room, or roof or ceiling plane by checking Retain Wall Framing or Retain Roof Framing in the object’s specification 
dialog. Although their framing is not generated with other ceiling framing, Tray Ceiling Polylines also have a Retain 
Framing check box in their specification dialog.

MIXING MANUAL AND AUTOMATIC FRAMING

Floor and ceiling platforms can be framed with a combination of manually-drawn and automatically generated joists. 
Similarly, roof planes can be framed with a combination of manually drawn and automatic rafters.

If you plan to use this approach, bear in mind that automatically generated joists and rafters will not be created in the same 
location as an existing, manually drawn joist or rafter; but, they will not necessarily use the same layout. For consistent 
layout, consider using a Framing Reference Marker . See Framing Reference Markers on page 890. 

Manually drawn floor, ceiling, and roof framing is unaffected when automatic framing is rebuilt and remains along with the 
newly produced automatic framing. In contrast, manually drawn wall framing is deleted when automatic framing is rebuilt. 
You can, however, prevent this from happening by checking Retain Wall Framing in the Wall Specification dialog.

MIXING RAFTERS AND TRUSSES

 l Roofs can be framed with rafters, trusses, or a combination of the two. If you plan to combine roof trusses with rafters 
and/or ceiling joists, you can save time by:

 l Check Trusses (No birdsmouth) in the Build Roof dialog before automatically building or manually drawing a roof. 
See Build Roof Dialog on page 809.

 l Draw and position all roof trusses before automatically generating framing to produce rafters and ceiling joists. See 
Roof Trusses on page 911.

For more information, see Mixing Trusses with Stick Framing on page 918. 

FRAMING WITH BEAMS

Floor/Ceiling Beams  can be drawn in a plan either before or after automatic framing has been generated. Default 

settings for beams can be set in the Framing Defaults dialog. See Beams Panel on page 882.

If a Floor/Ceiling Beam is present and wall framing is generated, posts will be placed under the beam in any walls that pass 
under it and studs and top plates will build around the beam as necessary. 

If a Floor/Ceiling Beam is created before automatic floor or ceiling framing, you can specify whether joists bear on the 
beam or hang on its sides.
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To build joists that bear on a beam
 1.  Draw a Floor/Ceiling Beam  at the desired location in your plan.

 2.  Select the beam and click the Open Object  edit button. On the GENERAL panel of the Beam Specification 

dialog, confirm that: 

 l The Top Height value is equal to the Ceiling Height of the room(s) over which the beam is placed.

 l  Bearing Beam is checked. 

 3.  Click OK, then select Build> Framing> Build Framing  and build the appropriate floor or ceiling framing. See 

Floor Panels on page 874.

To build joists that butt against a beam
 1.  Draw a Floor/Ceiling Beam  at the desired location in your plan.

 2.  Select the beam and click the Open Object  edit button. On the GENERAL panel of the Beam Specification 

dialog: 

 l Specify the desired Depth value and then lock it.

 l Specify the Bottom Height value so that it is equal to the Ceiling Height of the room(s) over which the beam is 
placed.

 3.  Uncheck Bearing Beam. 

 4.  If necessary, select Build> Framing> Joist Direction  and draw a line perpendicular to the beam and within the 

floor or ceiling platform. 

 5.  Click OK, then select Build> Framing> Build Framing  and build the appropriate floor or ceiling framing. See 

Floor Panels on page 874.

 

Framing Tools
Select Build> Framing to access the automatic and manual Framing Tools.

The Framing Tools family has three separate parent buttons: General Framing Tools , Floor/Ceiling Framing Tools 

, and Roof Framing Tools .

The default settings for framing members are derived from their respective panels in the Framing Defaults dialog. See 
Framing Defaults on page 865.

Most types of framing can be created both manually and automatically. Once created, both automatically generated and 
manually drawn framing members can be selected and edited. See Editing Framing on page 897.

Horizontal floor/ceiling platform framing members are referred 
to as "joists"; vertical wall framing members are referred to as 

"studs"; and sloped roof framing members are referred to as “rafters”.
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BUILD FRAMING

Select Build> Framing> Build Framing to open the Build Framing dialog. Here, you can define settings that control 
how framing is drawn and generate automatic framing. See Build Framing Dialog on page 873. 

Select Build> Framing> Build All Framing to build or rebuild all floor, ceiling, wall, and roof framing throughout 
the current plan. See Automatic Framing on page 868.

GENERAL FRAMING

General Framing objects are generic, framing members that can be drawn outside a floor or ceiling platform or roof 
plane. Select Build> Framing> General Framing, then click and drag in a straight line to create one of these 

objects. In plan view, a horizontal framing member is created; in a Wall Detail, vertical members can also be drawn. See In 
Wall Detail Views on page 896.    

WALL BRIDGING

Wall Bridging, or blocking, can be created both automatically and manually, but can only be drawn manually in a 
Wall Detail. To do so, open a Wall Detail and select Build> Framing> Wall Bridging, then click and drag in a 

straight line across the wall in the view. See In Wall Detail Views on page 896.         

Each run of bridging has gaps where it crosses studs, but behaves as a single object.           

Automatic wall bridging can be created when wall framing is built or rebuilt. See Wall Panel on page 877.          

POST

Posts can only be placed manually. To do so, select Build> Framing> Post and click in plan view. 

POST WITH FOOTING

Posts can also be created with footings  beneath them. Select Build> Framing> Post and click in plan view to place a 
post centered over a footing. Post footings are Slab  objects and can be selected independent of their posts. See 

The Slab Tools on page 731.

RAFTER

Rafters can be drawn both manually and automatically. To draw a rafter manually, select Build> Framing> Rafter 
in plan view, then click and drag in a straight line within a roof plane. 

Rafters are edited like other framing members, except that you cannot set the height. If a rafter is moved, its height and 
slope are automatically reset to fit under the roof plane at its new position.

ROOF BLOCKING

Roof Blocking is automatically generated in the eaves if a soffit is not present; otherwise, blocking is drawn 
manually. In plan view, select Build> Framing> Roof Blocking and click and drag in a straight line within a roof 

plane. Blocking is typically drawn perpendicular to the rafters, but at the same pitch. 

Each run of blocking behaves as a single object but has gaps where it crosses rafters, trusses or other blocking. 

Before drawing Roof Blocking:
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 l Specify whether you want In Line, Stagger blocking, or Cross bridging in the Framing Defaults dialog. 
 l Build the roof framing. See Roof Panel on page 884.

In 3D, roof blocking is tilted to follow the pitch of the roof plane in which it is drawn. 

ROOF TRUSS

Roof trusses can only be drawn manually. To do so, select Build> Framing> Roof Truss in plan view and click and 
drag  in a straight line within one or more roof planes. Roof planes and either a default or manually drawn ceiling 

must be present before a roof truss can be drawn. See Roof Trusses on page 911.

ROOF BEAM

Roof beams can only be drawn manually. To do so, select Build> Framing> Roof Beam in plan view and click and 
drag in a straight line. Roof beams are normally drawn across rafters and placed directly under them. 

ROOF PURLIN

Roof purlins can be both drawn manually and generated automatically. To draw a purlin, select Build> Framing> 
Roof Purlin in plan view and click and drag in a straight line. In order to create purlins, they must be drawn: 

 l Within a roof plane that has a Purlins layer defined in its Roof Surface Definition. See Material Layers Definition 
Dialogs on page 1040.

 l Perpendicular to the pitch of the roof plane.

JOIST

Floor and ceiling joists can be both drawn manually and generated automatically. To draw a joist, select Build> 
Framing> Joist in plan view, then click and drag in a straight line within a floor or ceiling platform. 

Joists are always drawn as the ceiling framing for the current floor. See The Current Floor on page 750. Whether a floor or 
ceiling joist is drawn is determined by the presence of a floor platform above. 

 l If there is no floor platform above, a ceiling joist is drawn. 
 l If there is a floor platform above, a floor joist is drawn. 

If you want to draw floor joists for Floor 1, for example, you must do so on Floor 0. See Foundations on page 717.

Joists can be automatically generated for multiple floors in the Build Framing dialog. See Floor Panels on page 874. 

Ceiling joists, floor joists and rafters have their own layers. 
Proper layer assignment maximizes display and materials 

flexibility.

JOIST BLOCKING

Joist blocking can only be drawn manually in plan view. To do so, select Build> Framing> Joist Blocking, then  
click and drag in a straight line within a floor or ceiling platform. 

Before drawing Joist Blocking:

 l Specify whether you want In Line, Stagger blocking, or Cross bridging in the Framing Defaults dialog. 
 l Build the floor and/or ceiling platform. See Floor Panels on page 874.

Regardless of how many joists or other objects it crosses, each run of blocking behaves as a single object. 
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FLOOR/CEILING TRUSS

Floor and ceiling trusses can only be drawn manually in plan view. Select Build> Framing> Floor/Ceiling Truss, 
then click and drag in a straight line within a floor or ceiling platform. See Floor and Ceiling Trusses on page 911.    

FLOOR/CEILING BEAM

Floor and ceiling beams can only be drawn manually in plan view. Select Build> Framing> Floor/Ceiling Beam, 
then click and drag in a straight line within a floor or ceiling platform.

Beams can be drawn in two different ways:

 l Under Joists places the beam underneath the joists so the joists can bear on it. 
 l With Joists places the top of the beam even with the tops of the joists it supports. The joist then butts against it. See 

Beams Panel on page 882.

FRAMING REFERENCE MARKER

Framing Reference Markers are manually-placed reference points that specify how automatically-generated 
framing is laid out. To place one, select Build> Framing> Framing Reference Marker in plan view and click to 

place a Framing Reference Marker. 

A Framing Reference Marker can also be created by placing a Marker  and then specifying its type. See Markers on 

page 538 and Framing Reference Markers on page 890. 

BEARING LINE

Bearing Lines direct the program to lap or butt joists and/or rafters where they cross the line instead of spanning 
from wall to wall, and can only be drawn in plan view. To draw one, select Build> Framing> Bearing Line and 

click and drag in a straight line. See Bearing Lines on page 893.

JOIST DIRECTION

Joist Direction lines define the direction in which joists run in a floor or ceiling platform and can only be drawn in 
plan view. To draw one, select Build> Framing> Joist Direction and click and drag within a floor or ceiling 

platform. See Joist Direction Lines on page 892.

 

Build Framing Dialog
Automatic framing can be generated by selecting Build> Framing> Build Framing to open the Build Framing 
dialog. This dialog can also be accessed by double-clicking the  General Framing  button or any of the 

Floor/Ceiling Framing Tools , or Roof Framing Tools  buttons.

The settings in this dialog are similar to those found in the Framing Defaults dialog.

Each major structural component of the model has its own panel or panels in the Build Roof dialog. The number of panels 
in the dialog varies depending on how many floors are in your model. There will be a panel called  “1st” for the first floor, 
“2nd” for the second floor, and so on.
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 l Floor and ceiling framing settings are found on the Floor panels. See Floor Panels on page 874. 
 l Wall framing settings are located on the WALL, OPENINGS, and FIREPLACES panels. See Wall Panel on page 877, 

Openings Panel on page 880, and Fireplaces Panel on page 882.
 l Floor/Ceiling Beam and Roof Beam settings are found on the BEAMS panel. See Build Framing Dialog on page 873.
 l Post, floor/ceiling beam and roof beam settings are found on the POSTS panel. See Posts Panel on page 883.
 l Roof framing settings are located on the ROOF and TRUSSES panels. See Roof Panel on page 884 and Trusses Panel on 

page 888.
 l The settings on the ROOF panel are the same as those on the STRUCTURE panel of the Build Roof dialog. See Roof 

Panel on page 884.
 l You can specify how framing looks in plan view on the PLAN VIEW panel. See Plan View Panel on page 889.
 l You can set the default materials used for framing on the MATERIALS panel. See Materials Panel on page 890.

For best results, create roof framing before or at the same time 
that ceiling joists are generated. 

FLOOR PANELS

The default floor and ceiling framing for individual floor levels is set here. The defaults for all floor levels, however, is set 
in the Floor/Ceiling Platform Defaults dialog. See Floor and Room Defaults on page 418. 

The floor framing for a given floor level is always generated or manually drawn on the floor below. As such, the floor 
framing settings for a given floor level are found on the FLOOR panel for the floor below it. For example, the floor framing 
settings for Floor 2 are found on the 1ST panel, while the floor framing settings for Floor 1 are found on the FOUNDATION 
panel. See Floor and Ceiling Platforms on page 433.

In order to create the floor framing for Floor 1, a Floor 0 must be present. If a Floor 0 has not been built, the Build Floor 
Framing check box on the FOUNDATION panel will not be available. See Foundations on page 717. 
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Automatic Floor/Ceiling Framing

Check Automatic Floor/Ceiling Framing to regenerate floor and ceiling framing whenever changes are made to the model. 
See Automatic Framing on page 868. 

 l Check Use Framing Reference to use a Framing Reference Marker as the starting point for joist layout. If a 
Framing Reference Marker is present, the center of the first joist is placed at this point and spacing goes from there. 
If joists are lapped, the surface is placed at this point. When this is unchecked, the program tries to position ceiling 
joists so that they coincide with rafters. See Framing Reference Markers on page 890. 
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Ceiling Above Floor X

Ceiling platforms are only present above rooms that do not have living space above them.    

 l Check Build Ceiling Framing to generate or regenerate ceiling framing when the OK button is clicked. Only 
available when there is no living space above at least part of the current floor. Not available in the Framing Defaults 
dialog.    

 l The Ceiling Structure depth displays here for reference. Click the Edit button to open the Ceiling Structure 
Definition dialog and define the layers of materials that form the ceiling platform. See Material Layers Definition 
Dialogs on page 1040.    

 l Check Default to use the Ceiling Structure Definition set in the Floor/Ceiling Platform Defaults dialog. See Floor 
and Room Defaults on page 418.    

 l Enter a value for the On Center Spacing of joists generated in ceiling platforms on Floor X.    

 l Specify the Joist Width, which is their horizontal thickness.    

 l Specify how the ceiling framing members Bear on Beams and Bearing Walls: they can either Lap side by side or 
Butt end to end. The lap is 8” (200 mm) and centered over the support.    

 l Specify what style of Blocking or bridging is produced for the ceiling when Joist Blocking  is manually drawn 

after joists are in place. See Joist Blocking on page 872.    

 l In Line produces blocking pieces that align with each other.

 l Stagger produces blocking that alternates on either side of the line you draw.    

 l Cross produces cross bridging that looks like in line blocking in plan view, but shows as cross bridging in 3D views 
and the materials list.
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Subfloor of Floor Y

If a room has a living space above it, its ceiling will be supplied by the floor platform of the room(s) above instead of a 
ceiling platform.    

 l Check Build Floor Framing to generate or regenerate floor framing when the OK button is clicked. Not available in 
the Framing Defaults dialog or if there is no floor level located below Floor Y.    

 l The Floor Structure depth displays here for reference. Click the Edit button to open the Floor Structure Definition 
dialog and define the layers of materials that form the floor platform. Only available if there is living space above at 
least part of the current floor.    

 l Check Default to use the Floor Structure Definition set in the Floor/Ceiling Platform Defaults dialog.    

 l Enter a value for the on center Spacing of floor joists above the current floor.    

 l Specify the Joist Width, which is their horizontal thickness.    

 l Check Rim Joist to create rim joists across the ends of the floor joists when floor framing is generated. If this is 
unchecked, line blocking across the ends of the floor joists is usually drawn in manually later.    

 l Check Max Rim Joist Length, then specify the maximum allowable length for rim joist boards. When unchecked, 
rim joists run the full length of each platform edge where joist ends are found.    

 l Specify the Rim Joist Width, which is the horizontal thickness.    

 l Select the Rim Joist Type from the drop-down list.    

 l Specify how the floor framing members Bear on Beams and Bearing Walls: they can either Lap side to side or Butt 
end to end. The lap is 8” (200 mm) and centered over the support.    

 l Specify what style of Blocking or bridging is produced for the floor when Joist Blocking  is manually drawn 

after joists are in place. See #2, above. 

WALL PANEL

The Thickness, Spacing, Count, and Length settings on this panel serve as the defaults for framed wall types. See Wall Type 
Definitions Dialog on page 390.
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Automatically Build Wall Framing

Check this box to regenerate wall framing whenever changes are made to the model. See Automatic Framing on page 868.
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Wall

Specify how wall studs are created.   

 l Check Build Wall Framing to build wall framing for the entire model. Framing is built in walls with one or more 
layers specified as Framing. Not available in the Framing Defaults dialog. See Wall Type Definitions on page 388.     

 l Specify the Stud Thickness for all wall Framing layers in the plan. Stud depth is equal to the thickness of each wall 
layer that has a Framing material.     

Note: If the Stud Thickness is equal to the stud depth, only one stud will 
be created at wall corners.     

 l Specify the Stud Spacing for all wall Framing layers in the plan, starting from the Framing Reference Marker, if one 
is present. See Framing Reference Markers on page 890.     

 l Stud Depth - The depth of each wall stud is determined by the thickness of its wall layer, which is set in the Wall 
Type Definitions dialog. See Wall Type Definitions Dialog on page 390.     

 l When Allow Automatic Balloon Framing is checked, walls adjacent to Open Below rooms are balloon-framed. 
Uncheck this box to instead produce wall plates separated by rim joists instead. See Effects of Room Functions on 
page 421.

 
Wall Connections

Specify how the framing at Wall Corners and Wall Intersections is generated.    

 l Select "Standard" to produce corners or intersections composed of three studs.    

 l Select "Reduced Stud" to produce corners or intersections composed of two studs.    

 l Select "Laddered" to add horizontal ladder blocking at corners or intersections.    

 
Plates

Define how top and bottom plates are generated.

 l Specify the Top Plate Count, as well as their vertical Thickness.    

 l Specify the Bottom Plate Count, as well as their vertical Thickness.    

 l Specify the Max Plate Length, which is the maximum allowed length for the boards that make up the top and 
bottom plates. This value is only applicable for wall types that are set to use a maximum plate length. 

 
Blocking

Specify where and how horizontal blocking is created. Each run of blocking behaves as a single object but has gaps where it 
crosses studs. See Wall Bridging on page 871.

 l Check Exterior to automatically produce blocking on exterior walls when wall framing is built.    

 l Check Interior to automatically produce blocking on internal walls when wall framing is built.    

 l In Line produces blocking pieces that align with each other.    

 l Stagger produces blocking that alternates on either side of a center line along the wall.    

 l Wall blocking is generated exactly half-way up each wall’s total height. Once created, it can be selected in a 
Framing Overview or Wall Detail.    
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  Girts
Specify the Max Girt Length, which is the maximum allowed length for horizontal girt boards. This value is only 
applicable for wall types that are set to use a maximum girt length.             

 
Mitre Ends of Angle Walls

Specify how wall corners that are not right angles are framed. 90° corners are not affected by these settings.    

 l Select Mitre Plate Ends to mitre the ends of the top and bottom plates. If unchecked, top and bottom plates will be 
butted together.    

 l Select Rotate End Studs to rotate the studs closest to mitre ends to the angle of the mitre. If unchecked, studs will 
remain perpendicular to the angle of the walls.    

 l Select Horizontal Frame Through to frame through the horizontal walls in plan view, butting vertical walls against 
them. If unchecked, walls that are vertical in plan view will frame through.    

  Wall Detail Views

 l Check Build Wall Framing Details from Exterior to have Wall Detail views display from the exterior of the plan 
rather than the interior. See In Wall Detail Views on page 896.             

 l Specify the Fill Style for wall framing members in Wall Detail views by clicking the Fill Style button to open the 
Default Wall Detail Fill Style dialog. See Displaying Framing on page 894.               

OPENINGS PANEL

Various defaults for door and window headers as well as the trimmers for bay/box/bow windows can be set here. 

The rough openings for doors and windows can be specified in the Door and Window Defaults and Specification dialogs. 
See Door and Window Framing on page 866.
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Header Sizes

Specify default Header Sizes, dependent on width of the door or window, including its Rough Opening. These values 
should be set so that the wider the opening, the deeper the header. 

 l If the top of an opening’s Rough Opening is closer to the top plate than the Maximum Depth, a solid header is 
produced to fill the entire space. Short cripple studs between the header and top plate are not produced. 

 
Bay/Box/Bow Trimmers

Specify how Bay/Box/Bow Trimmers, are generated. 

 l Specify the Maximum Number of trimmers that a Bay, Box, or Bow Window with a lowered top height can have 
on each side of the opening. 

 l Specify the Component Thickness, which is the thickness of a thinner trimmer for manually resized Bay/Box/Bow 
Window components if a standard trimmer does not fit. See Component Windows on page 619. 

 
Materials List

Check List Cut Header Lengths in Mixed Reporting to show precut headers in the Materials List. Precut headers are 
shown only if the walls have been framed and Mixed Reported is selected as the reporting method. See Structural Member 
Reporting on page 1312.
If this is unchecked, the Materials List produces a total footage for all headers. When checked, each different length of 
precut header is listed separately. Note that the total number of headers is affected by the Count value of each door and 
window.
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Plan Views

Specify the default Header Fill Style for door and window headers by clicking the Fill Style button to open the Wall 
Header Fill Style dialog. See Displaying Framing on page 894. 

FIREPLACES PANEL

The rough openings for legacy Fireplaces placed in walls can be set on the FIREPLACES panel. See Fireplaces on page 736.

 
Headers

Specify the characteristics of fireplace Headers. 

 l Specify the Type of material used for fireplace headers. 

 l Specify the Thickness of fireplace headers. 

 l Specify the Count of boards used to form a fireplace header. 

 
Trimmers

Specify when to generate multiple Trimmers on each side of a fireplace. These values include the fireplace’s Rough 
Opening. See Door and Window Framing on page 866.

 l Double Trimmer At - Fireplace openings of this width or greater receive two trimmers on each side when framed. 

 l Triple Trimmer At - Fireplace openings of this width or greater receive three trimmers on each side when framed. 

 
Sills

Specify the characteristics of fireplace Sills. A sill is only generated if a fireplace is raised sufficiently off the floor.

 l Specify the Thickness of fireplace sills. 

 l Check Double Sills to specify a double sill for all fireplaces. 

BEAMS PANEL

Floor/Ceiling Beams and Roof Beams are not automatically generated: they can only be drawn manually. See 
Manual Framing on page 868.
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Posts and beams may be created under a Deck room 
automatically, depending on its size, location, and other 

variables. Deck Framing defaults are set in the Deck Room Defaults 
dialog. See Deck Framing and Planking on page 431.

 
Floor/Ceiling Beams

Click the Edit Floor Beam Defaults to open the Floor/Ceiling Beam Defaults dialog. This dialog is similar to the Framing 
Specification dialog. See Framing Specification Dialog on page 902.

 
Roof Beams

Click the Edit Roof Beam Defaults to open the Roof Beam Defaults dialog. This dialog is also similar to the Framing 
Specification dialog. 

 
Options

The Options settings affect the positioning of Floor/Ceiling Beams. 

 l Specify the Placement of Floor/Ceiling Beams relative to the joists. With Joists places beams at the same height as 
the joists so they hang on the beams; Under Joists places beams below joists so they bear on the beams. See 
Bearing Lines on page 893. 

 l Align Exterior with Outer Layer/Main Layer - When a Floor/Ceiling Beam is drawn along and over an exterior 
wall, its exterior surface can snap to either the wall’s outer layer or outer Main Layer, as specified here. See The 
Main Layer on page 388.

POSTS PANEL

Posts are not automatically generated: they can only be drawn manually. See Manual Framing on page 868. 

Posts and beams may be created under a Deck room 
automatically, depending on its size, location, and other 

variables. Deck Framing defaults are set in the Deck Room Defaults 
dialog. See Deck Framing and Planking on page 431.
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Posts

Click the Edit Post Defaults to open the Post Defaults dialog. This dialog is similar to the Framing Specification dialog for 
posts. See Framing Specification Dialog on page 902.

 
Post Footings

The Post Footings settings control the initial attributes of footings created with the Post with Footing  tool. 

 l Specify the Height Above Floor value, measured from the top of the subfloor of the room in which the post is 
placed.

 l Specify the top to bottom Thickness of the footing.

 l Specify the Width of the footing. This is the length of each side of a square footing and the diameter of a round 
footing.

 l Select the Square or Round radio button to specify the initial shape of post footings. Once created, a post footing 
can be edited like other closed polylines. See Editing Closed Polyline-Based Objects on page 230.

 l Specify the Rebar Size Number for post footing Rebar.         

 l Specify the Rebar Count, or number of bars, for Post Footings.         

ROOF PANEL

The settings on the ROOF panel of the Build Framing dialog are exactly the same as those on the STRUCTURE panel of the 
Build Roof dialog. See Build Roof Dialog on page 809.

These settings are also found on the STRUCTURE panel of the Roof Plane Specification dialog. Those settings that apply to 
ceiling planes are available in the Ceiling Plane Specification dialog. See Roof Plane Specification Dialog on page 828.

Note: Changes made on the Roof panel will not affect the structure of 
existing roof planes. To make changes take effect, rebuild the roof.
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Automatic Roof Framing

Check Automatic Roof Framing to automatically rebuild roof framing if changes are made to the roof plan. See Automatic 
Framing on page 868.

 l Check Use Framing Reference to use a Framing Reference Marker as the starting point for rafter layout. See 
Framing Reference Markers on page 890.
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Note: Use Framing Reference is useful when framing a gable roof, but 
not necessarily a hip roof. See Framing References and Roof Framing 
on page 892.

  Roof

 l Check Build Roof Framing to build roof framing for the entire model. Not available in the Framing Defaults dialog. 
See Roofs on page 803.

 l Uncheck Angled Dormer Hole to frame dormers using rafters under the dormer valleys and a double header where 
the peak of the dormer roof meets the main roof plane. When checked, a five-sided hole is framed with two angled 
double rafters located under the dormer valleys. 
If a double header does not fit within the main roof plane, an angled dormer hole is produced regardless of this 
setting. 

 l Uncheck Trim Framing To Soffits to generate full-depth rafters all the way to the subfascia. If checked, rafter 
depths are trimmed to the top surface of the soffits in the eave area. Does not affect decorative rafter tail ends. See 
Rafter Tails Panel on page 817.

 l Specify the Spacing of automatically generated rafters. This also sets the initial offset value for laying out rafters 
using the Multiple Copy  edit button. See Multiple Copy on page 176.

 l Specify the Maximum Lookout Spacing. Depending on a roof plane’s length, its lookouts may be spaced closer 
than this value, but not further.

 l Uncheck Trim Framing To Soffits to generate full-depth rafters all the way to the subfascia. If checked, rafter 
depths are trimmed to the top surface of the soffits in the eave area. Does not affect decorative rafter tail ends. See 
Rafter Tails Panel on page 817.

 l Specify the Spacing of automatically generated rafters. This also sets the initial offset value for laying out rafters 
using the Multiple Copy  edit button. See Multiple Copy on page 176.

 l Specify the Maximum Lookout Spacing. Depending on a roof plane’s length, its lookouts may be spaced closer 
than this value, but not further.

Specify the Blocking Style. See Roof Blocking on page 871. 
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 l Check Vertical to generate blocking that is oriented vertically, or plumb. When unchecked, blocking is 
perpendicular to the roof framing. 

 l In Line produces blocking pieces that align with each other.

 l Stagger produces blocking that alternates on either side of the line you draw. 

 l Cross/Bridging produces cross bridging that looks like in line blocking in plan view, but shows as cross bridging 
in 3D views and the materials list. 

 
Roof Layers

Define the layers of materials that together form the default roof plane assembly.                 

 l The roof Surface depth displays here for reference. Click the Edit button to open the Roof Surface Definition dialog 
and define the layers of materials located above the structural layers. See Material Layers Definition Dialogs on 
page 1040.             

 l The roof Structure depth displays here for reference. Click the Edit button to open the Roof Structure Definition 
dialog and define the layers of materials that form the roof structure.             

When a roof plane or ceiling plane is located over a room with Flat Ceiling Over This Room unchecked, a ceiling surface 
on the underside of the plane will generate.

 l When Use Room Ceiling Finish is checked, the ceiling finish layer is based on the specifications of the room(s) 
below. See To create a cathedral ceiling on page 440.             

 l When Use Room Ceiling Finish is unchecked, the depth of the Ceiling finish depth displays for reference and can be 
edited here. Click the Edit button to define the material layers located below the structural layers in the Roof Ceiling 
Finish Definition dialog.             

 l Check Soffits to include soffits under the eaves and specify their Thickness. When Soffits is unchecked, rafter ends 
are exposed under the eaves and will display in 3D views when their layer is turned on. When this is the case, rafters 
will be assigned the same material as the Fascia when roof framing is generated. See Rafter Tails on page 862.    

 l Check Flat Under Eave Sub Fascia to extend soffits downward until they meet the subfascia. When unchecked, 
soffits slope downward to the fascia, if the fascia depth is sufficient.             

 
Roof Size

Specify the desired Width and Depth for Rafters, the Ridge, Lookouts, Gable Sub Fascia (barge rafter), Eave Sub 
Fascia, Gable Fascia, Eave Fascia, Blocking, and the Shoe Plate.         
Note that the Gable Sub Fascia setting controls the height of both gable and eave soffits, and thus the depth of rafter tails 
when Trim Framing to Soffits is checked, above.
Uncheck the boxes beside Lookout, Eave Sub Fascia, Gable Fascia and/or Eave Fascia to prevent these framing 
members from generating when roof framing is built. When these boxes are checked, these items will generate as 
specified here. 
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Roof Overframing

These settings affect how roof framing is generated at locations where roof planes are drawn to represent an overbuild 
situation.    

 l Check Roof Overframing to generate shoe plates for the upper roof's rafters to join to in overbuild situations. When 
unchecked, no shoe plates are created.    

 l Specify the Overframe Layer, which is the layer of the lower roof assembly that the shoe plate snaps to when roof 
framing is generated.    

 o Select Roof Finish to generate overbuild framing on top of the topmost layer of the roof's Surface Definition.    

 o Select Sheathing to generate overbuild framing on top of the lowermost layer of the roof's Surface Definition.    

 o Select Structural to generate overbuild framing on top of the roof's Structure Definition.

TRUSSES PANEL

Changes to the settings on this panel do not affect any trusses that are already present in the current plan. See Trusses on 
page 910.

Chief Architect Premier does not engineer trusses. Always 
consult an engineer or truss company to have your trusses 

professionally designed.
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Roof Truss Member Depth

Roof trusses use the default Width setting for Rafters. See Roof Panel on page 884.                 

 l Specify the depth of the Top Chord.

 l Specify the depth of the Bottom Chord.

 l Specify the depth of the Webbing.

 
Roof Truss Maximum Horizontal Span

These settings control the maximum distance between the junctions where webbing meets the Top Chord and Bottom 
Chord. Changing these values can create different truss configurations such as kingpost, queenpost, fink, double fink, fan, 
howe, or double howe. 
These distances are measured horizontally for both roof and floor and ceiling trusses. In some instances, especially in 
more complex trusses, making these spans equal may result in the webbing appearing more normal or standard. See 
Trusses on page 910.

  Roof Truss Options

 l Check Require Kingpost to include a central vertical webbing member. If this is unchecked, a vertical member may 
still be created, depending on the Maximum Horizontal Span settings and the length of the truss.

 l Check Energy Heel to remove the bottom chord from the overhang area. For an energy heel to be modeled, the roof 
should also be raised off the top plates by at least 7”, depending on the roof pitch. See Energy Heels on page 925.

  Floor/Ceiling Truss Member Depth

 l Specify the depth of the Top Chord.

 l Specify the depth of the Bottom Chord.

 l Specify the depth of the Webbing.

 
Floor/Ceiling Truss Options

The Maximum Horizontal Span setting controls the maximum distance between the junctions where webbing meets the 
Top Chord and Bottom Chord.

TRUSS SPACING

Trusses are always drawn manually, so while their depth, span and kingpost defaults are specified in the Build Framing 
dialog, their spacing is not.         

Trusses are typically replicated using the Multiple Copy  edit button, and their spacing can be set in the Multiple Copy 

dialog. See Multiple Copy Dialog on page 177.         

PLAN VIEW PANEL

The settings on the PLAN VIEW panel affect the appearance of Joists, Rafters, Trusses, and General Framing members in 
plan view. See Displaying Framing on page 894.
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 l Specify the Default Fill Style for joists, rafters, and General Framing members by clicking the Fill Style button to 
open the Default Framing Fill Style dialog. See Displaying Framing on page 894. 

 l The Default Fill Style is not a dynamic default setting. Any framing already present in the plan will not be affected if 
you change it.

 l Check Use Line for Framing to show joists, rafters, and General Framing members as single lines rather than as 
closed polylines. See Displaying Framing on page 894. 

Note: The Use Line for Framing setting is dynamic but affects the current 
floor only. The Default Fill Style setting affects all framing as it is 
created but is not dynamic.

MATERIALS PANEL

The default materials that display on General Framing objects are specified on the MATERIALS panel. These materials are 
used in 3D views only and are not used in the Materials List. Materials List information is derived from the structure Type 
of each framing object. See Framing and the Materials List on page 901.

Changes made on the MATERIALS panel of the Build Framing dialog only affect subsequently created framing: both 
manually drawn and automatically generated.

The settings on this panel of the Build Framing dialog are the same as in many other specification dialogs. See Materials 
Panel on page 1055.

 

Framing Reference Markers
Framing Reference Markers are markers that specify the starting point for the layout of automatically-produced 
framing. See Markers on page 538.

In order for framing to be laid out relative to a Framing Reference Marker, it must be set to do so:

 l Floor and ceiling framing as well as deck joists can be set to Use Framing Reference on a floor-by-floor basis in the 
Build Framing dialog. See Floor Panels on page 874.

 l Roof framing can be set to Use Framing Reference plan-wide in the Build Framing dialog. See Roof Panel on page 
884.

 l Wall framing for individual walls can be set to Use Framing Reference in the Wall Specification dialog. See 
Structure Panel on page 398.
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Each floor level can have its own Framing Reference Marker, which affects the layout of all framing members generated on 
that floor. If multiple markers are present on a given floor, the one that was created first is used and those created later are 
ignored. See In Plan Views on page 894.

In many cases, a single Framing Reference Marker can be used for the entire model. When this is the case, it must be placed 
on Floor 1.

Note: If no Framing Reference Markers exist in your plan, the point at 
0,0 is used as the Framing Reference location for joists, while the 
framing for roof planes and walls generate relative to their parent object.

USING FRAMING REFERENCE MARKERS

To place a Framing Reference Marker, select Build> Framing> Framing Reference Marker . Click in plan view to 

place the Framing Reference Marker and then build or rebuild some or all framing in the plan. Although Framing Reference 
Markers can be placed anywhere, a typical location is the corner of two exterior walls, at the exterior of their framing layer. 
See Wall Type Definitions on page 388.

When Object Snaps  are enabled, Framing Reference Markers snap to framing members and other CAD-based objects 

first, and then to a wall Main Layer surface or corner if possible. See Object Snaps on page 164.

Once placed, Framing Reference Markers can be modified just like other markers. See Markers on page 538.

When framing is generated using a Framing Reference Marker, the first framing member of a given type snaps to this point 
and all other framing members are laid out from there. 

 l Wall and roof framing snap to the Framing Reference Marker at their centers.
 l Floor and ceiling framing snaps to the Framing Reference Marker at their centers when it is set to Butt Over Support 

in the Build Framing dialog. See Floor Panels on page 874.
 l Floor and ceiling framing snaps to the Framing Reference Marker along an edge when it is set to Lap over a 

supporting beam or wall. If Lap is selected, the surfaces where the joists lap are placed at reference spacing, so that 
joists are placed on either side of the framing reference locations. 

MOVE TO FRAMING REFERENCE

Manually drawn or edited framing as well as automatic framing that was not generated using a Framing Reference 
Marker can be moved relative to a Framing Reference Marker using the Move to Framing Ref edit button. 

A group of selected framing objects that are all parallel to each other can be moved using the Move to Framing Ref edit 
button. Only one of the objects in the group is compared to the Framing Reference Marker and moved; the remaining 
objects are simply moved the same amount as the first object. Ideally, therefore, the group should have proper spacing 
relative to each other before the move. 

To move framing objects to a framing reference marker
 1.  Group select the framing objects.

 2.  Click the Move to Framing Ref  edit button.

 3.  The framing members are moved to the nearest Framing Reference Marker.

To determine placement, the Move to Framing Ref edit tool uses:

 l For wall studs, the default On Center Spacing for wall framing, which is set in the Build Framing/Framing Defaults 
dialog. See Wall Panel on page 877. 

891



Chief Architect Premier X14 Reference Manual - Joist Direction Lines

 l For roof rafters, the On Center Spacing of the selected object's parent roof plane. See Structure Panel on page 832.
 l For floor and ceiling joists, the default On Center Spacing for the current floor set in the Build Framing/Framing 

Defaults dialog. They may instead reference spacing specific to a particular floor or ceiling platform. See Joist 
Direction Lines on page 892.

FRAMING REFERENCES AND ROOF FRAMING

Framing Reference Markers are useful when framing a gable roof, but not necessarily a hip roof. When a Framing 
Reference is used, common rafters on either side of a hip rafter will not meet in the same place.

If a Framing Reference Marker is not used, the automatic framing utility starts common rafter spacing from each end of the 
horizontal ridges, which results in common rafters on either side of hip jacks meeting each other.

 

Joist Direction Lines
By default, automatically-generated floor and ceiling joists will run in the direction that results in the shortest span 
between bearing walls and/or beams. A Joist Direction line allows you to define the direction that joists in a 

particular floor or ceiling platform run, regardless of span.

To draw a Joist Direction line, select Build> Framing> Joist Direction , then click and drag as you would draw a CAD 

line. In order to have any effect, a Joist Direction line must be drawn within the area of a single floor or ceiling platform. 

To avoid unexpected results, only one Joist Direction line should be present in a given floor or ceiling platform, and it 
should not extend outside the extents of that platform.

Joist Direction lines are located on the “Framing, Bearing Lines” layer by default and use the Text Style assigned to the 
layer that the Joist Direction line is on. See Text Styles on page 547. 

MULTIPLE JOIST DIRECTIONS

By default, all of the rooms on each living floor share a single floor platform and a single ceiling platform. If you require 
joists that run in two directions in either of these platforms, begin by dividing the platform in question in two. There are a 
number of ways to do this:

 l Divide the living area into separate rooms with different platform thicknesses and/or heights. See Floor and Ceiling 
Platforms on page 433.

 l Specify one or more interior walls as Bearing Walls. See Structure Panel on page 398.
 l Draw a Floor/Ceiling Beam  specified as a Bearing Beam. See Floor/Ceiling Beam on page 873.

 l Draw a Bearing Line . See Bearing Lines on page 893.

Bearing Walls, Floor/Ceiling Beams, and Bearing Lines should be drawn on the same living floor as the joists they will 
interact with. Floor framing for a living floor is created on the floor below, while ceiling framing for a living floor is created 
on that floor. See Floor and Ceiling Framing on page 865.  

JOIST SIZE AND SPACING

The text of a Joist Direction line states the platform framing’s Structure Type and size, and the spacing. By default, these 
values reflect the settings in the Framing Defaults dialog. See Floor Panels on page 874. 

In plans using US Units, when the Structure Type is “Lumber”, the nominal size will be reported for the joists. For all other 
Structure Types, fractional inches are used. 
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It is important to note that if a Joist Direction line is set to use non-default Spacing and Depth values, they will override the 
settings in both the Framing Defaults and Room Specification dialogs. It will not, however, change the settings in either 
dialog.

 

Joist Direction Specification Dialog
A Joist Direction line can control the joist depth and spacing in the floor or ceiling platform in which it is drawn. To 
change these values, select a Joist Direction line and click the Open Object edit button. The Joist Direction 

Specification dialog opens. See Joist Direction Lines on page 892.

Any changes made in the Joist Direction Specification dialog will not affect any joists present in its floor or ceiling 
platform. Only subsequently produced framing in its platform will be affected.

FLOOR JOIST PANEL

 l Define the Spacing of the joists in the platform associated with the selected Joist Direction line.
 l Define the Depth of these joists. 

Note: This is not the recommended method for specifying joist depth and 
spacing in most cases. You should instead use the settings in the Room 
Specification dialog. See Room Specification Dialog on page 442.

LINE STYLE PANEL

For information about the settings on this panel, see Line Style Panel on page 310.

ARROW PANEL

Joist Direction Lines do not use the Attach or Auto Position options for arrows. For information about the settings on this 
panel, see Arrow Panel on page 312.

 

Bearing Lines
It is not unusual for joists to lap or butt in the middle of a span rather than build across a platform. When they do, 
they typically bear on a wall or beam at that point. To produce joists that break over a support, specify the wall or 

beam in question as Bearing in its specification dialog: 

 l Check Bearing Wall in the Wall Specification dialog. See Structure Panel on page 398.
 l Check Bearing Beam in the Framing Specification dialog. See General Panel on page 902. 

Joists lap or butt over the support depending on the option selected in the Build Framing dialog. See Floor Panels on page 
874.

In either case, the joists’ overlap or butted ends are centered over the support. When an offset from the center is required, do 
not specify the wall or beam as Bearing and instead draw a Bearing Line. 
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A Bearing Line directs the program to lap or butt joists where they cross the line instead of framing across to a wall. 

Select Build> Framing> Bearing Line , then click and drag to draw a Bearing Line as you would draw a CAD line. A 

Bearing Line should start outside the floor or ceiling platform and end outside it, passing completely through the building. 

Bearing Lines are edited just like CAD lines, and can be connected to form polylines. See Editing Line-Based Objects on 
page 218 or Editing Open Polyline-Based Objects on page 226.

Bearing Lines are one of the ways that a floor or ceiling platform can be divided into separate smaller platforms with 
different Joist Directions . See Joist Direction Lines on page 892.

 

Displaying Framing
The display of framing members is controlled in the Layer Display Options dialog. By default, framing objects are 
created on one of over twenty layers with names that begin with “Framing,”: Ceiling Beams, for example, are placed 

on the “Framing, Ceiling Beams” layer. Once created, though, framing objects can be placed on any layer you wish. See 
Layer Attributes on page 181.

IN PLAN VIEWS

In plan views, wall studs and posts are represented by box-based CAD objects that look like Cross Boxes. See Cross Box on 
page 326 and Editing Box-Based Objects on page 234. 

Joists, rafters, trusses,  General Framing, and headers are represented in plan view by line-based CAD objects that are look 
like long, thin rectangles. See Editing Line-Based Objects on page 218.

Note: The framing for the floor platform of a given floor level is drawn 
on the floor level below. See Floor Panels on page 874.

You can specify a default fill style for line-based framing members in the Build Framing dialog. See Plan View Panel on 
page 889, Openings Panel on page 880, and Fill Styles on page 197.

By default, newly drawn line-based framing members of a given type display in front of older ones. Posts, meanwhile, 
display in front of beams, but behind joists. You can specify the drawing order of framing members in their specification 
dialogs. See Line Style Panel on page 905.

If you prefer, joists, rafters, trusses, and General Framing can instead be represented by a single line. The Use Line for 
Framing setting can be set differently for each floor in a plan. See Plan View Panel on page 889.
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FRAMING LABELS

Framing labels are located on the “Framing, Labels” and “Framing Header Labels” layers and can be set to display in plan 
view, Wall Details, and cross section/elevation views. See Label Panel on page 712.           

 l Headers, posts, and beams have automatic labels consisting of the object’s depth and width followed by the member 
type. In U.S. Unit plans, the nominal size is used when the framing Type is “lumber”.          

 l Automatic header labels include the total number of headers for the associated opening in parentheses. By default, 
only one header for a given opening displays a label while the other(s) are suppressed.          

 l Joists, rafters, studs, plates, and wall blocking do not have automatic labels; however, you can specify a custom label 
in their specification dialog. See Framing Specification Dialog on page 902.          

Header label defaults can be set in the Door and Window Defaults dialogs, and can be preset for each door or window in its 
specification dialog. See Framing Panel on page 579.         

Framing objects have named value pairs associated with them, so you can create custom labels using Text Macros. See Text 
Macros on page 549.         

IN 3D VIEWS

The easiest way to view framing in 3D is to use either the Orthographic Framing Overview  or Perspective Framing 

Overview  tool, which display the model using the "3D Framing Layer Set". See Framing Overview on page 1089. 

Framing objects can display in other 3D and cross section/elevation views, although by default they are not set to do so. If 
you wish to see framing in these views, turn on the framing layers in the appropriate layer set.

To reveal framing covered by other objects or wall layers, use the Delete Surface  tool. See Delete 3D Surface on page 

1099. 

IN CROSS SECTION/ELEVATION VIEWS

To display framing in a cross section/elevation view, make sure the framing layers are turned on in that view. See Layer 
Display Options Dialog on page 183. 

You can also use the Delete Surface  tool to temporarily delete the surfaces of wall layers or other objects that block the 

view. 

In cross section/elevation views, horizontal framing objects that are cut by the cross section plane display as boxes 
containing an ’X’. Wall Blocking , Joist Blocking , and Roof Blocking  cut by the cross section plane displays as 

a box containing a single diagonal line. See  Cross Section/Elevation Views on page 1090.
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IN WALL DETAIL VIEWS

Wall Details are a special type of elevation view in which only the studs, plates, girts, headers, and bridging used to frame 
an individual wall display. Each Wall Detail is created with a text object that  reports which wall layer owns the framing as 
well as from which side of the wall the framing is being viewed. If the wall has more than one framing layer, they will all 
be drawn in the same Wall Detail view but will display separately, each described by its own text object. 

A Wall Detail view for each framed wall in your plan is automatically created by the program when its wall framing is built.  
They are listed in the Project Browser, and the name of each Wall Detail is the same as the Automatic Label of the wall it is 
associated with. 

There are several ways to open the Wall Detail associated with a wall:

 l Select the wall and click the Wall Detail  edit button. See Editing Walls on page 372. 

 l Right-click on the name of the detail in the Project Browser and select Open View from the contextual menu.  See 
Project Browser on page 58.         

 l Select a wall framing member in the Materials List and click the Find Object in Plan  edit button. See Find Object 

in Plan on page 703.         

To locate the owner wall of a selected wall framing member in the Wall Detail, a Framing Overview, or other 3D view in 
which wall framing can be seen, click the Find Wall  edit button. See Selecting Walls on page 372.          

The framing members of an individual wall can be selected and edited in its Wall Detail. If you rebuild wall framing after 
manually editing in a Wall Detail, your changes will be lost. To protect changes made to a wall’s framing, check Retain 
Wall Framing in the Wall Specification dialog. See General Panel on page 395.    

Wall Details are the only views in which Wall Bridging  can be created. See Wall Bridging on page 871.    

Most wall framing members occupy the entire thickness of its wall layer. Some, notably doubled headers or corner 
sheetrock nailers, may be turned sideways. If a wall has multiple framing layers, they will display in the same Wall Detail 
view, but in separate locations. Double or triple headers display one behind the other in a Wall Detail. You can select them 
using the Select Next Object  edit button. See Select Next Object on page 215.          

By default, Wall Details show walls as viewed from the exterior. You can specify whether Wall Details are viewed from the 
interior or exterior in the Build Framing dialog. You can also specify the default fill style for framing objects in Wall 
Details. See Wall Panel on page 877.          

As with regular 3D views, Wall Details can be sent to layout and printed. See Layout on page 1338 and Printing and 
Plotting on page 1368.         

FRAMING MATERIALS AND TYPES

The appearance of a framing member in 3D and cross section/elevation views is affected by the material assigned to it and 
also by its Type.

The material specified for a framing member determines what it looks like in camera views by applying a texture, pattern, or 
color to its surface. Materials have no effect on how the framing is calculated in the Materials List, however. 

The default materials for framing are set:

 l In the Floor and Ceiling Structure Definition dialogs for floor and ceiling framing. See Floor and Ceiling Platform 
Definitions on page 434.

 l In the Wall Type Definitions dialog for wall framing. See Wall Type Definitions Dialog on page 390.
 l In the Framing Defaults dialog for General Framing, Posts, and Rafters. See Materials Panel on page 890. 
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Framing Types can also influence how a framing member looks in camera views because some types have special profiles - 
for example, I-Joist, Steel-I, and C-Channel. Framing Types are also stated in the Description column in the Materials List. 
See Structure Types on page 901. 

IN THE MATERIALS LIST

When framing is calculated in the materials list, its dimensions and type are noted. Treated lumber is also counted separately 
form regular lumber. See Structure Types on page 901. 

Framing lengths can be counted using one of several methods to produce, for example, cut lists and buy lists. See Structural 
Member Reporting on page 1312.

If framing is not present in a plan when a Materials List is created, it will not be calculated.  See Framing and the Materials 
List on page 901. 

FRAMING SCHEDULES

The Framing Schedule tool allows you to produce customizable framing schedules as well as framing labels that 
display schedule numbers. See Schedules and Object Labels on page 694.

Schedules of particular types of framing can be created by controlling which Objects to Include in the schedule. For 
example, a Deck Framing Schedule can be created by including “Deck” Objects while excluding all other Object types. See 
General Panel on page 705.

In plans using US Units, when a board’s Structure Type is “Lumber”, its nominal size will be reported in the Nominal 
column of a Framing Schedule. For all other Structure Types, fractional inches are used. 

Framing schedules created in Wall Detail  views use a special Only Include Objects from this Detail setting and a 

selection of Objects to Include that report only wall framing members present in the current view. See In Wall Detail Views 
on page 896.

If placed into a Truss Detail, a framing schedule’s Objects to Include will be restricted to floor, ceiling, and roof trusses. 
Only Include Objects from this Detail is also used. See Truss Details on page 916.

 

Editing Framing
Framing can be edited much like other line-based objects can using the edit handles, edit toolbar buttons, or the Framing 
Specification dialog. See Framing Specification Dialog on page 902.

Framing is organized into families which determine where it is generated and where it can be manually drawn. See Manual 
vs. Automatic Framing on page 867. Once framing has been created, however, it can be moved out of its structural 
component. In order to move roof framing above or below a roof plane, you must first check Manual Rafter Height in the 
Framing Specification dialog. See Framing Specification Dialog on page 902. 

When Start and End Indicators are enabled in the Preferences dialog, a selected framing member will display an S and an 
E at its start and end points. This makes it easier to choose which end to lock when specifying its Length or Angle. See Edit 
Panel on page 119.
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Roof and floor/ceiling trusses cannot be edited like regular framing members can and are discussed in their own chapter. 
See Editing Truss Envelopes on page 916.

SELECTING FRAMING

Before a framing member can be edited, it must be selected. Framing can be individually selected in all views, and some 
types can be group-selected. To group-select framing in plan view, first select any of the Framing Tools. See Marquee 
Select on page 216.

To select framing objects of a particular type, use the Marquee Select Similar  tool’s Restrictive Selection  option. 

Wall framing can only be selected in this way in a Wall Detail view. See Marquee Select Similar on page 216.

USING THE EDIT HANDLES

Framing members can be drawn, edited, and moved much the way CAD lines can. See Editing Line-Based Objects on page 
218. 

In cross section/elevation views, joists and rafters cut by the cross section and displaying a cross box can also be edited. See 
Editing Box-Based Objects on page 234. Also, in cross section/elevation views headers can be edited like closed polylines. 
See Editing Closed Polyline-Based Objects on page 230. 

In a camera view or overview, the handles that display on a framing member depend on where it is clicked for selection and 
your current zoom factor.

 l Click the top surface to display the same edit handles as in plan view, allowing you to rotate, move, and extend or 
shorten the length of the member.

 l Click a side surface to display the same edit handles as in an elevation view, one at each end and one at the center.
 l Zoom in and click on the appropriate edge to display edit handles that control the width and depth of framing 

members.

USING THE EDIT TOOLS

A selected framing member can be edited in a variety of ways using the buttons on the Edit Toolbar. See The Edit Toolbar 
on page 135.

  Move to Framing Reference moves the selection into alignment with a Framing Reference Marker. See 
Framing Reference Markers on page 890.

  Join and Lap Ends and Join and Mitre Ends join horizontal framing members at either a lapped or 
mitered joint. See Lapped and Mitered Joints on page 898, below.

USING DIMENSIONS

Framing members can be both moved and resized using dimensions in plan view, elevation views, and Wall Details. 
See Moving Objects Using Dimensions on page 491. 

In order for a manually drawn Dimension Tool to locate framing objects as a dimension line is drawn, it must be set to do 
so in the Dimension Defaults dialog. See Locate Manual Panel on page 460.

LAPPED AND MITERED JOINTS

You can make two horizontal framing members meet at a lapped intersection using the Join and Lap Ends edit 
button.
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To join and lap framing members
 1.  Select a horizontal framing member such as a joist, rafter, beam, or General Framing object.

 2.  Click the Join and Lap Ends  edit button.

 3.  Click on a second horizontal framing member that is not parallel to the initially selected member.

 4.  The two members now meet at a lapped joint. The initially selected framing member butts against the second one, 
which laps the end of the first.

Alternatively, mitered joints can be created using the Join and Mitre Ends edit button. This edit tool is used in the 
same way as the Join and Lap Ends tool.

The Join and Mitre Ends and Join and Lap Ends tools not available for wall studs, Posts, Floor/Ceiling Trusses, or Roof 
Trusses.

Multiple framing objects can also be trimmed to length using the Trim Object(s)  and Extend Objects  edit tools. 

See Trim and Extend on page 276.           

STEEL AND CONCRETE

You can set framing defaults to generate steel framing and concrete structural members as well as lumber and other framing 
types. Individual framing members can also be specified as concrete or steel, as well.  

When setting up defaults or modifying an individual object, make sure you specify both the desired framing Type and the 
material. See Framing Materials and Types on page 896. 

END PROFILES AND RAFTER TAILS

End profile cuts can be specified for rafters, beams, joists, and General Framing objects in the Framing Specification dialog. 
See End Profile Panel on page 905.

DELETING FRAMING

Individual and group-selected framing members can be deleted the way other objects in the program are. See Deleting 
Objects on page 289. 

Categories of framing, such as wall framing or floor and ceiling framing, can also be deleted in the Delete Objects 
dialog. See Delete Objects Dialog on page 289.

 

Keeping Framing Current
When you modify your plan, move walls, raise or lower platforms or redesign the roof, any framing present in the plan will 
not update to reflect your changes. In order for the framing to be updated, you must regenerate automatically produced 
framing and either edit or delete and replace manual framing. 

For this reason, it is recommended that you wait until your model is finished, or nearly finished, before creating framing. 
See Drawing a Plan on page 27.

AUTOMATIC FRAMING

Automatically-generated framing can be rebuilt using either of two check boxes in the Build Framing dialog:
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 l Select a Build check box to build automatic framing once. For example, check Build Wall Framing on the WALL 
panel to build wall framing once based on the current state of the model. If the model is changed later, you may need 
to do this again. 

 l Select an Automatic check box to build automatic framing every time a change is made to that structural component 
in the plan. For example, check Automatic Wall Framing on the WALL panel to rebuild all wall framing any time a 
wall is affected by changes to the model. 

When floor, ceiling or roof framing is regenerated, all automatically produced framing objects and any copies of them are 
deleted and new framing is calculated. See Rebuilding and Retaining Framing on page 868.

MANUAL FRAMING

It is vital to remember that manually drawn framing objects and copies of them are not retained when automatic framing is 
rebuilt. 

If a plan is not final, therefore, do not spend a lot of time altering or copying automatically produced framing objects. It is 
best to wait until your design is final before doing manual framing work. 

BUILD FRAMING FOR SELECTED OBJECT

If changes are made to a wall, floor platform, roof plane, or ceiling plane that require its framing to be rebuilt, you do 
not have to rebuild all of the framing in that object’s category.  Instead, select the object and click the Build Framing 

for Selected Object edit button. The floor framing for a selected room can be rebuilt in this matter, as well. See Build 
Framing for Selected Object(s) on page 900.         

 

Build Framing for Selected Object(s)
The Build Framing for Selected Object(s) edit tool allows you to build or rebuild the framing for a selected wall, 
floor platform, Roof Plane, Ceiling Plane, or Tray Ceiling Polyline. It also allows you to ensure that a truss's 

envelope and webbing are up-to-date.

Note: The Build Framing for Selected Object(s) edit tool is not 
available if the selected object has Retain Framing specified. See 
Rebuilding and Retaining Framing on page 868.           

FRAMING FOR WALLS

The Build Framing for Selected Object(s) edit tool is available for walls using a framed wall type and for railings 
specified as Solid, but not for other types of walls and railings. See Wall Type Definitions on page 388. 

FRAMING FOR ROOMS

The Build Framing for Selected Object(s) edit tool is only available for rooms that have Floor Under This Room 
checked, Monolithic Slab Foundation unchecked, and a framing material specified in its Floor Structure Definition. See 
Structure Panel on page 444.           

If the selected room is adjacent to other rooms that are in the same Framing Group, the program will ask whether you would 
like to create a new Framing Group for the selected room:          

 l Click Yes to create a new Framing Group, assign the selected room to it, and generate floor framing for that room.          
 l Click No to generate floor framing across the entire platform using the existing Framing Group assignments.          
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See Framing Groups on page 865.           

TRAY CEILING POLYLINES

The Build Framing for Selected Object(s) edit tool will generate framing for the side walls and ceilings of a selected Tray 
Ceiling Polyline. This button is not available, however, if the selected Tray Ceiling Polyline has a Caution   symbol 
indicating that its shape or position is not supported. See Tray and Coffered Ceilings on page 435.

REBUILDING TRUSSES

If you make changes to a selected truss that affect its envelope or webbing, click the Rebuild Framing for Selected Object
(s) edit button to ensure that its configuration is up-to-date. This performs the same action as checking Force Truss 
Rebuild in the Truss Specification dialog. See Editing Truss Envelopes on page 916.

 

Framing and the Materials List
Each framing member created in a plan is counted in the Materials List. See Materials Lists on page 1309.

Framing can be calculated using one of several reporting methods. See Structural Member Reporting on page 1312.          

Depending on what a framing member is used for, it may be listed in the Framing (F), Subfloor (SF), or Roofing (R) 
category. See Categories on page 1318.

 l Framing includes all wall framing, posts, and General Framing objects.
 l Sub Floor lists floor and ceiling framing joists as well as sheathing.
 l Roofing includes trusses, rafters, and sheathing.

It is important to note that the floor, ceiling, and roof framing counted in the Materials List may vary considerably 
depending on whether framing of those types is actually present in the plan: 

 l If no framing is present in the model, then the required floor, ceiling, and roof framing is estimated. Total linear 
footage for various depths of rafters and joists is estimated, rather than a quantity of specific lumber lengths and sizes. 
Wall framing is not estimated. 

 l If even one floor, ceiling, or roof framing object exists in the plan, then objects in that category are counted instead of 
estimated for the Materials List. 

STRUCTURE TYPES

A variety of structural member Types is available for use in Chief Architect Premier. They fall into four categories: 

 l Wood framing types: Lumber, I-Joist, Glulam, Engineered Lumber, LVL, PSL, and VSL.
 l Steel framing types: Steel I, Steel Box, C Channel, and U Channel. 
 l Solid Concrete. 
 l Round (Posts only).

You can select any of these Types as the default for floor and ceiling framing, headers, roof framing, beams, and posts. See 
Build Framing Dialog on page 873. 

You can also specify the Type for individual framing members in their specification dialog. See General Panel on page 902.

Changing the framing member Type does not affect how framing is placed, but it may change its profile in cross section and 
3D views and will affect its description in the Materials List. 
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The framing member Type does not affect the appearance of the material used by a framing member in 3D views. See 
Framing Materials and Types on page 896. 

STRUCTURAL MEMBER REPORTING

You can specify whether framing materials are calculated by linear foot, as a cut list, or as a buy list. See Structural 
Member Reporting on page 1312. 

FRAMING MATERIALS AND THE MATERIALS PANEL

The materials applied to framing objects in 3D views are not used in the Materials List. Materials List information is 
derived from the structural use of each framing object and its Type - not the material seen on its surfaces in 3D views. See 
Materials Panel on page 890.

 

Framing Specification Dialog
Select a framing member and click the Open Object edit button to open the Framing Specification dialog for the type 
of framing member selected. 

The settings in this dialog are similar to those in the Post and Beam Specification and Defaults dialogs. See Framing with 
Beams on page 869.

You can also open the specification dialog for the framing objects(s) associated with a schedule row. See Open Row Object
(s) on page 699.          

The panels available in the Framing Specification dialog will vary, depending on the type of framing object that is selected.

GENERAL PANEL

The options available in on the GENERAL panel will vary depending on the type of framing member selected.
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  Automatic Height

 l When Automatic Height is checked, the selected Roof Rafter, Roof Beam, or Roof Blocking object generates 
within the structural layer of the roof plane(s) it is drawn in. Uncheck this box to enable the Manual Height settings 
that follow. 

 l If the selected object’s height is edited outside this dialog, Automatic Height will become unchecked automatically. 
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  Depth and Height

 l Check the box beside Raise/Lower, then enter a positive value to raise or negative value to lower the framing object 
from its current position. The amount is added to both the Top and Bottom Heights when you click either Apply or 
OK, and does not affect the Depth. When Raise/Lower is checked, the other Depth and Height settings are disabled. 

 l Select the radio button beside one of the height values to Lock it, then change a value that remains available. 

 l Specify the Top Height of the post, as measured from the first floor subfloor at 0”. For a rafter, this is the top height 
at its low end.

 l Specify the Bottom Height of the post, as measured from the first floor subfloor at 0”. For a rafter, this is the 
bottom height its low end.

 l Specify the Depth of the framing object. For a rafter, this is the depth measured perpendicular to the roof plane.

 l Manual Rafter Height - Normally, the height of each Rafter or Roof Beam end is reset after any move or edit so 
that it is located just under the roof surface. Check this box to allow the height of the object to be changed. Only 
available for Rafters and Roof Beams. 

  Options

 l Set the framing member’s Width, as seen in plan view.

 l Specify a selected wall framing member’s Thickness, as seen in plan view. Only available for wall framing.

 l Select a structural member Type from the drop-down list. The Round Type is unique to Posts. See Structure Types 
on page 901.

 l Check Show Cross to display the selected Post as a cross box in plan view. Only available for Posts. See Displaying 
Framing on page 894.

Note: Instead of counting individual concrete posts and beams in the 
Materials List, the total volume of their concrete is calculated. The 
square footage for beam and post forms is also listed.

 l Check Bearing Beam to specify the selected Floor/Ceiling Beam as a load-bearing beam. When checked, 
automatically generated joists run perpendicular to the selected beam and either lap or butt over it, as specified in the 
Build Framing dialog. If the beam’s Top Height is at least 1” higher than the joists’ bottom height, the joists will 
instead butt against the sides of the beam. See Framing with Beams on page 869. Only available for Floor/Ceiling 
Beams. 

 l Check Treated to specify that the selected framing member be counted as treated in framing schedules and the 
Materials List.

 l The Rotate options let you rotate and align a selected wall stud, blocking, or header within the wall’s framing layer. 
Select None for the framing member’s Thickness to span the depth of the framing layer; select Flat to Outside to 
rotate the member 90° and align it with the outside of the framing layer; select Flat to Inside to rotate the member 
90° and align it with the inside of the framing layer. 
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Length and Angle

Lock the point about which you want like the selected object to resize and/or rotate, then specify its exact length and angle. 
See Editing Framing on page 897. 

 l Specify the Length of the framing object. Rafter length is measured along the top of the rafter, and so is greater than 
the length measured in plan view. Not available for Posts.

 l Width 1 and 2 - Specify the Post width in each dimension. When a Round Post is specified, Width 1 refers to its 
diameter and Width 2 is not available.

 l Specify the Angle of the framing object in plan view. Changing this rotates the object about the location specified by 
the radio buttons described below.

 l Select Lock Center to resize or rotate the object about its center point. 

 l Select Lock Start to resize or rotate the object about the location from which you started drawing the framing 
object.

 l Select Lock End to resize or rotate the object about the location where you stopped drawing it.

 
Concrete Beam Options

Specify the Rebar and Stirrups for concrete Posts and Beams. These settings are only available when the selected object is 
a Post or Beam and “Solid Concrete” is selected from the Type drop-down list.         

 l Specify the Size Number for both Rebar and Stirrups.          

 l Specify the Count, or number of bars, for both Rebar and Stirrups.          

 l Specify the length of Rebar Extensions.           

 l Specify the distance that Stirrups Overlap.          

RAFTER TAILS PANEL

The RAFTER TAILS panel is only available for rafters, rafter lookouts, and subfascia. The settings here allow you to specify a 
rafter tail profile for exposed end rafter ends under roof eaves. The default Rafter Tail profile can be specified in the Build 
Roof dialog. See Rafter Tails Panel on page 817.     

END PROFILE PANEL

The END PROFILE panel is available for joists, beams, and General Framing members. The settings here allow you to specify 
a decorative profile for one or both ends of these objects. The default profile for beams can be set in the Floor Beam, Roof 
Beam, and Deck Beam Defaults dialogs. See Moldings / Profiles Panels on page 943.           

LINE STYLE PANEL

The settings on the LINE STYLE panel affect the selected object’s line style, its bumping behaviors, and its drawing order. 
See Line Style Panel on page 310.

FILL STYLE PANEL

For floor, ceiling, and roof framing, and General Framing, the settings on the FILL STYLE panel affect the selected object’s 
appearance in plan view. See Fill Styles on page 197.

For studs and other wall framing that displays as a cross box in plan view, the settings on this panel affect the selected 
object’s appearance in Wall Details. See In Wall Detail Views on page 896.            
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For headers only, the FILL STYLE panel allows you to control the appearance of the selected object in both plan view and 
Wall Details. Click either of the Fill Style buttons to open the Plan View Fill Style or Wall Detail Fill Style dialog.           

MATERIALS PANEL

The default materials on this panel are set in the Build Framing dialog. If you change the selected object’s framing Type, the 
material here may update - unless you have previously specified a non-default material. See Materials Panel on page 1055.

LABEL PANEL

Framing labels can display in plan view and cross section/elevation views when the “Framing, Labels” layer is turned on 
and use the Text Style assigned to that layer. See Text Styles on page 547.          

Automatically generated wall framing can also display in Wall Detail views. When accessed from a Wall Detail, this panel 
will have Wall Detail Position and Orientation settings.            

For more information about the settings on this panel, see Label Panel on page 712.          

Note: If a framing member is listed in a schedule using callout labels, the 
settings here are overridden and the schedule label is used instead. 

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 1335.          

OBJECT INFORMATION PANEL

The information entered on the OBJECT INFORMATION panel can be used in schedules and the materials list. For more 
information, see Object Information Panel on page 1336.   

SCHEDULE PANEL

The settings on the SCHEDULE panel determine which schedule categories the selected object is included in. See Schedule 
Panel on page 716.          

 

Export to EasyFrame
The EasyFrame Automated Marking System is a machine used for cutting construction framing parts and putting 
layout markings on those parts. You can export wall framing information from a Chief Architect plan for use in this 

system. For more information, visit: www.easyframesaw.com.

BEFORE EXPORTING

Before exporting to Easy Frame, you need to prepare your plan so the exported data meets your needs.

906

https://www.easyframesaw.com/


Chief Architect Premier X14 Reference Manual - Export to EasyFrame

To prepare wall framing for export to EasyFrame
 1.  Draw the plan as you normally would.

 2.  Uncheck Auto Merge Collinear Walls in the General Wall Defaults dialog. See General Wall Defaults on page 
346.

 3.  Use the Add Break edit tool to create wall segments that correspond to the panels or plate lengths you want. See 
Add Break on page 257.

 4.  Build wall framing. See Build Framing Dialog on page 873.

 5.  Inspect the framing and make any changes that you may need. See Editing Framing on page 897.

 6.  Export the wall framing information to EasyFrame:

 l Select File> Export> Export All Wall Framing to EasyFrame  to export information about all wall framing 

in the plan.

 l Select one or more walls that you would like to export the framing information for and click the Export All Wall 
Framing to EasyFrame  edit button. See The Edit Toolbar on page 135.

EXPORT TO EASYFRAME DIALOG

To export a plan’s wall framing information for use with EasyFrame, select File> Export> Export All Wall Framing to 
EasyFrame . Chief Architect Premier exports using the .ezf file format.

You can also select one or more walls in a plan and click the Export Selected Wall Framing to EasyFrame  edit 

button.

The Export to EasyFrame dialog reports any wall framing boards that either cannot be exported to EasyFrame or may be too 
long to cut from a longer board.
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  Allowed Board Lengths

 l Select a Buy List from the Allowed Board Length (Buy List) drop-down list to specify the available board lengths 
that wall framing can be cut from. See Structural Member Reporting on page 1312.    

 l Click the Add  button to create a new Buy List based on the one that is currently selected. Type a short, 

descriptive name for the new Buy List, then modify its settings as needed.    

 l Click the Edit  button to open the Structural Member Reporting dialog for the selected Buy List and make any 

changes you may need.    

 l Click the Rename  button to type a new name for the selected Buy List.    

 l Click the Delete  button to remove the selected Buy List from the list of those available in the current plan. If a 

Buy List is either set as the default or in use by a Materials List, it cannot be deleted.
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Boards Too Long to Cut

Boards that are too long to be cut from available lengths can be exported to EasyFrame, but are not set to do so by default.     

 l Click the Add, Edit, Rename, or Delete button to manage the list of available Buy Lists in the current plan.      

 l The Labels of any walls in the plan with boards that are too long to be cut from any of the boards in the selected 
Allowed Board Length Buy List are listed here. See Wall Labels on page 368.      

 l By default, no walls in this list will be included in the export. Click on a line item to select it, then click in the 
Export Anyway column to add a check mark and include it in the export.     

 l With a line item selected, click the Find in Plan button to close the dialog and select the wall in question in plan 
view. See Finding Objects on page 213.

 l Click the Skip All button to clear remove all check marks from the Export Anyway column.

 l Click the Include All button to add check marks in the Export Anyway column for all line items.    

 
Curved Wall Framing

Framing in curved walls cannot be exported to EasyFrame. This section will only be present in the dialog if there are one or 
more curved walls in the plan. See Drawing Curved Walls on page 363.     

 l The Labels of any curved walls in the plan are listed here.     

 l Select a line item in the list and click the Find in Plan button to close the dialog and select the wall in question in 
plan view.     

 
Not Orthogonal Framing

Framing that is not orthogonal to the direction of its parent wall cannot be exported to EasyFrame. This section will only be 
present in the dialog if there are one or more walls in the plan that have non-orthogonal framing members. See Editing 
Framing on page 897.     

 l The Labels of any walls in the plan that have non-orthogonal framing members are listed here.      

 l Select a line item in the list and click the Find in Plan button to close the dialog and select the wall in question in 
plan view. See Finding Objects on page 213.      

When you click OK, the Save EasyFrame File dialog opens. This is a typical Save File dialog. See Saving, Exporting, and 
Backing Up Files on page 39.

If any excluded boards are listed in this dialog when you click OK, a Confirmation message will first ask whether you want 
to continue.
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Chapter 25
 

Trusses

There are two basic ways to frame a roof. The first is commonly called “stick framing,” or sometimes “handstacking” or 
“cut-and-stack.” This type of roof incorporates framing such as rafters, ridges, and ceiling joists. See Framing on page 864.

The other method is to use prefabricated, engineered roof trusses. Chief Architect allows you to design and display a wide 
variety of trusses.

DISCLAIMER

Chief Architect does not engineer trusses. The trusses displayed by Chief Architect are for illustrative purposes only. They 
can show how trusses are used in your plan, and help you communicate to the licensed engineer who produces your final 
truss design where you want your trusses and how you would like them to work.

Always have your truss designs approved by a licensed engineer.
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Truss Defaults
The default settings for floor, ceiling and roof trusses are set in the Framing Defaults dialog. Select Edit> Default 
Settings and in the Default Settings dialog, select Framing and click the Edit button.

 l The default settings for truss chord and webbing depth, maximum span, and kingpost are set in the Framing Defaults 
dialog. See Trusses Panel on page 888. 

 l The overall depth of individual Floor/Ceiling Trusses  are based on the thicknesses of the platforms in which they 

are drawn. See Floor Panels on page 874. 
 l The structure of Roof Trusses  is determined by the position of the roof plane(s) above and the ceiling plane(s) 

below. See Roof Planes on page 819 and Ceiling Planes on page 841. 

 

Floor and Ceiling Trusses
Floor and ceiling trusses can be used instead of joists to frame platforms. As with manually-drawn floor and ceiling 
framing, the presence of a room above determines whether a floor or ceiling truss is drawn. For example, a truss 

drawn on the first floor of a single story home will be a ceiling truss, while a truss drawn on the first floor of a two-story 
building will be a floor truss for the 2nd floor.

Floor and ceiling trusses can only be drawn manually. To place a floor or ceiling truss in your plan, select Build> 
Framing> Floor/Ceiling Truss , then click and drag within a floor or ceiling platform in plan view. See Drawing 

Trusses on page 912. 

To create a sloped truss ceiling truss, draw a Roof Truss and 
specify it as a Sloping Flat Truss. See General Panel on page 

928.

The TRUSSES panel of the Build Framing dialog contains default settings for floor and ceiling trusses. See Trusses Panel on 
page 888. These default settings can be overridden by the settings in the Floor/Ceiling Truss Specification dialog. See 
Floor/Ceiling Truss Specification Dialog on page 932.

 

Roof Trusses
Roof trusses can be used instead of or in combination with rafters to frame roofs and ceilings. Roof trusses can only 
be drawn manually, and can only be created where a roof and ceiling are already present. Select Build> Framing> 

Roof Truss, then click and drag in plan view within one or more roof planes to manually draw a roof truss. See Drawing 
Trusses on page 912. 

If you intend to use roof trusses, you need first to build your roof planes with this in mind. Before building the roof, select 
the Trusses (no Birdsmouth) check box in the Build Roof dialog. When this is checked, roof plane thickness is based on 
the default Top Chord Depth set in the Framing Defaults dialog. See Trusses Panel on page 888.

If Trusses (no Birdsmouth) is not checked, the roof plane thickness is determined by the rafter Depth setting on the ROOF 
panel of the Framing Defaults dialog. If you plan to use both trusses and rafters, you should leave this unchecked. 
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ROOF TRUSS PLACEMENT

A roof truss can only exist in a space defined by the roof planes above it and the ceiling or manually drawn Ceiling Plane 
 below it. This is because the shape of a truss is defined by the location of the roof and the ceiling. 

If the program either does not find both roof and ceiling planes, or if there is not enough room between them to model a 
truss, a warning message displays. For example, if you draw a truss in a roof overhang where there is no ceiling, this 
message displays:

“Roof and ceiling surfaces too close together or cannot be found, so cannot make truss.” 

The incorrect truss may still display in plan view with a label of the form “TR-*”. If it does, it should be deleted or moved. 
See Editing Trusses on page 914.

One or both ends of a truss may be truncated if they are drawn across another truss. If this happens, it will end exactly on 
the surface of the existing truss, producing a girder truss. See Girder Trusses on page 927.

Trusses can end on interior walls. You can draw a truss that partially crosses the building by starting and/or ending it within 
24” (600mm) of an interior wall. The truss extends over the wall’s Main Layer. Its end lines up with the Main Layer surface 
on the far side of the wall.

ROOF TRUSS WEBBING

The webbing in a newly drawn truss is controlled by the Top Chord and Bottom Chord settings in the Framing Defaults 
dialog. See Trusses Panel on page 888.

Changing these default values may cause different truss configurations such as kingpost, queenpost, fink, double fink, fan, 
howe, or double howe to be represented. 

 

Drawing Trusses
Trusses cannot be generated automatically: they must be manually drawn and then replicated. All trusses are drawn similar 
to the way CAD lines are and can be drawn in plan view only. See Draw Line on page 305. 

To draw and replicate trusses
 1.  Select either the Floor/Ceiling Truss  or Roof Truss  tool, then click and drag within either a floor/ceiling 

platform or one or more roof planes.

 l As they are drawn, roof trusses will snap to any walls that they cross. 

 l When a roof truss ends over an exterior wall, it will extend into the roof eave, stopping at the inside edge of the 
Eave Sub Fascia.

 l When a roof truss is drawn over a Full Gable Wall, it will have End Truss and Reduced Gable checked 
automatically. 

 l Floor/Ceiling trusses will snap to the wall surfaces, the exterior surface of a wall’s Main Layer, as well as to a 
variety of CAD-based objects, and can be drawn to any length.

 2.  Reposition the truss:
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 l Floor/ceiling trusses are often positioned relative to an exterior wall or Framing Reference Marker . See 

Framing Reference Markers on page 890.

 l Roof trusses are can be positioned over a gable end wall or at the ridge end of a hip. 

 3.  Open the truss’s specification dialog and edit its settings to meet your needs. See Roof Truss Specification Dialog on 
page 928 or Floor/Ceiling Truss Specification Dialog on page 932. 

 4.  Make multiple copies of the truss at specified intervals using the Multiple Copy  edit tool.

The copies of Roof Trusses automatically conform to the structural conditions in their new locations. As a result, replicated 
Roof Trusses and their labels may be different from the original. See Truss Labels on page 917. 

Unlike Roof Trusses, Floor/Ceiling Trusses do not conform to new structural conditions when they are either moved or 
copied. See Moving Trusses on page 915.

To replicate trusses using Multiple Copy
 1.  Select the truss to be copied in plan view.             

 2.  Click the Multiple Copy  edit button.              

 3.  Click the Multiple Copy Interval  edit button to open the Multiple Copy dialog. See Multiple Copy on page 176.

             

 4.  Enter the correct spacing in the All Trusses box. Once set, click OK.             

 5.  Select the truss and use the Move edit handle to drag it perpendicularly. The pointer becomes a four-headed arrow 
 when it is over the Move handle.              

 6.  New trusses appear as you drag. Drag as far as necessary to produce all desired trusses. Each truss is created 
according to the particular Roof/Ceiling/Truss Base planes above and below it.              

 

Displaying Trusses
The display of trusses and their labels is controlled in the Layer Display Options dialog. See Layer Display Options 
Dialog on page 183.

Truss labels display in plan view, cross section/elevation views, and the Truss Detail, and are used in the Materials List as 
well as in schedules. See Truss Labels on page 917.

IN 3D VIEWS

The easiest way to view trusses in 3D is to use either the Orthographic Framing Overview  or Perspective Framing 

Overview  tool, which display the model using the 3D Framing Set layer set. See Framing Overview on page 1089. 

Trusses can display in other 3D and cross section/elevation views, although by default they are not set to do so. If you wish 
to see trusses in these views, turn on the “Framing, Trusses” layer in the appropriate layer set.

You can create exposed trusses by placing roof and ceiling planes to produce the desired truss structure, drawing the trusses, 
and then removing the ceiling. See     Vaulted and Cathedral Ceilings on page 440.

To reveal trusses covered by other objects, you can use the Delete Surface  tool. See Delete 3D Surface on page 1099.
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IN THE TRUSS DETAIL

All the floor, ceiling and roof trusses present in the current plan display in the Truss Detail, which is a special CAD Detail 
window in which a diagram of each truss configuration present in the plan is automatically generated. See Truss Details on 
page 916.          

IN THE MATERIALS LIST

All trusses are listed under the Roofing category in the Materials List. Their labels appear in the Size column, along with 
their length. See The Materials List Tools on page 1310. 

IN SCHEDULES

Floor, ceiling and roof trusses can be listed in schedules. See Schedules and Object Labels on page 694.   

 

Editing Trusses
Trusses can be edited much like other objects can using the edit handles, edit toolbar buttons, or the Truss Specification 
dialogs. See Roof Truss Specification Dialog on page 928 and Floor/Ceiling Truss Specification Dialog on page 932.

SELECTING TRUSSES

Before a truss can be edited, it must be selected. Like other architectural objects, Trusses can be individually and group-
selected selected in all views. See Selecting Objects on page 212.

To group-select trusses of a particular type, use the Marquee Select Similar  tool. See Marquee Select Similar on page 

216.

When Start and End Indicators are enabled in the Preferences dialog, a truss selected in plan view will display an S and 
an E at its start and end points.  See Edit Panel on page 119.

Trusses can be deleted individually, or all at once in the Delete Objects dialog. See Delete Objects Dialog on page 289.   

USING THE EDIT HANDLES

In plan view, trusses can be drawn, edited, and moved much the way CAD lines can. See Editing Line-Based Objects on 
page 218.

When editing a roof truss’s length, bear in mind that if you position either of its ends at a location that doesn’t correspond to 
a roof plane edge, interior wall, or another truss, Use Special Snapping will automatically become unchecked in its 
specification dialog. 

When selected in a camera view, a truss can be edited like a closed polyline. This is not always recommended, though, 
because the truss may no longer match the space in the structure that it is meant to occupy. See Editing Truss Envelopes on 
page 916.

The depth of truss chords can be changed in the truss’s specification dialog, but not using the edit handles.   

USING THE EDIT TOOLS

A selected truss can be edited in a variety of ways using the buttons on the Edit Toolbar. See The Edit Toolbar on page 135.
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  Build Framing for Selected Object(s) rebuilds the envelope and webbing of the selected truss. See Editing 
Truss Envelopes on page 916.

  Move to Framing Reference moves the selection into alignment with a Framing Reference Marker. See 
Framing Reference Markers on page 890.

  Open Truss Detail opens the Truss Detail with the selected truss centered in the view. See Displaying Trusses 
on page 913.             

USING DIMENSIONS

Trusses can be repositioned precisely as well as resized using dimensions. See Moving Objects Using Dimensions on 
page 491.

In order for a dimension tool to locate trusses as dimensions are drawn, that tool needs to be set to do so in the Dimension 
Defaults dialog. See Locate Manual Panel on page 460. 

MOVING TRUSSES

Trusses can be moved using either their Move edit handle or the Transform/Replicate Object  edit tool. It’s important 

to note that Roof and Floor/Ceiling Trusses may behave differently when they are moved: 

 l When a Roof Truss  is moved, its shape updates to conform to the structural conditions defined by the roof and 

ceiling in its new location. To prevent this from occurring, check Lock Truss Envelope and Webbing in the Roof 
Truss Specification dialog before moving the truss. See Lock Truss Envelope and Webbing on page 916.

 l This is not the case with Floor/Ceiling Trusses : when moved to a location with a different platform structure, a 

Floor/Ceiling Truss will not update to conform to its new surroundings. It is important to draw, position, and copy 
them within the same floor or ceiling platform structure. If a different Floor/Ceiling Truss depth is needed, a new truss 
should be drawn. 

SPECIAL TRUSS SNAPPING

By default, Roof Trusses  have a number of special snapping behaviors that are used even when Object Snaps  are 

toggled off. See Object Snaps on page 164. 

These special behaviors include:

 l As they are drawn, Roof Trusses will snap to any walls that they cross. 
 l When drawn along an exterior wall, a Roof Truss will snap so that its outer surface is flush with the outer surface of 

the wall's Main Layer. 
 l When drawn along a roof plane edge, a Roof Truss will snap to the roof plane’s edge or corner. 
 l The center line Roof Trusses will snap to the line along which two roof planes meet. 
 l When a Roof Truss ends over an exterior wall, it will extend into the roof eave, stopping at the inside edge of the Eave 

Sub Fascia.

Floor/Ceiling Trusses  can be drawn to any length but also have special snapping:

 l Floor/Ceiling trusses will snap to the wall surfaces, the exterior surface of a wall’s Main Layer, as well as to a variety 
of CAD-based objects.

If you edit a truss in such a way that its ends do not correspond to a special snapping location, Use Special Snapping will 
automatically become unchecked in its specification dialog. This allows you to easily customize a truss but may make it 
difficult to snap to commonly used locations. 
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You can check or uncheck Use Special Snapping in the Roof Truss Specification dialog. See General Panel on page 928.

DELETING TRUSSES

Individual and group-selected trusses can be deleted the way other objects in the program can. See Deleting Objects 
on page 289.

Trusses can also be deleted by category as well as floor in the Delete Objects dialog. See Delete Objects Dialog on 
page 289.

 

Editing Truss Envelopes
A truss envelope is the shape defined by a truss’s top and bottom chords.  When a truss is drawn, the envelope is derived 
from the floor platform, ceiling platform, or roof that the truss is drawn in. 

When a truss is viewed in a 3D view, its envelope can be edited like a closed polyline. See Editing Closed Polyline-Based 
Objects on page 230.

This function can be used to change a roof truss end or overhang as well as the overall truss shape. Changing the truss 
envelope does not change the structure that it is drawn in, however. 

In addition, when a Roof Truss  is moved, its shape updates to conform to the structural conditions defined by the roof 

and ceiling in its new location. As a result, a Roof Truss’s label can change when the truss is moved to a new location. 

Floor/Ceiling Trusses  do not update when moved to a location with different structural conditions.

FORCE TRUSS REBUILD

If you make changes to a selected truss that affect its envelope or webbing, click the Build Framing for Selected 
Object(s) edit button to ensure that its configuration is up-to-date. You can also achieve this by checking Force 

Truss Rebuild in the truss's specification dialog. See General Panel on page 928.

LOCK TRUSS ENVELOPE AND WEBBING

The Lock Truss Envelope and Webbing attribute can be used to prevent a Roof Truss  envelope from updating when 

it is moved or replicated. See Roof Truss Specification Dialog on page 928. 

 

Truss Details
A Truss Detail is a special CAD Detail window in which a diagram of each truss configuration present in the plan is 
drawn. To open a plan’s Truss Detail, select CAD> CAD Detail Management . See CAD Details on page 340.         

You can also select a Floor/Ceiling or Roof Truss and click the Open Truss Detail edit button. The Truss Detail will 
open centered on the selected truss.           
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A Truss Detail is created automatically when a truss is created, and displays all trusses present in the current plan. If 
multiple trusses are identical, they share a single diagram. Each truss’s label displays centered below the truss diagram. 
When automatic or custom labels are in use, the quantity of each truss configuration is also listed. See Truss Labels on page 
917.         

In a Truss Detail, individual chords and webbing are represented using framing members. The truss label information is 
presented in a Text object.         

The trusses in a Truss Detail are linked to the actual trusses in the plan. If you move a truss in a Truss Detail, it will move in 
the model as well. To modify the information in a Truss Detail without affecting the model, use CAD Detail From View 

 to create a line-drawn copy first. See CAD Detail from View on page 341.         

To locate a selected truss in plan view, click the Find Trusses  edit button.         

Note: The Truss Detail is for display of trusses only. Editing the 
members that make up the trusses in the Truss Detail is possible but not 
recommended. 

To restore an edited Truss Detail diagram
 1.  Delete any new members you have drawn in the detail view.         

 2.  In plan view, select the truss and click the Open Object  edit button to open the Roof Truss Specification dialog.         

 3.  Check Force Truss Rebuild and click OK and the truss regenerates along with its Truss Detail diagram.         

 

Truss Labels
Labels for roof  trusses display when the “Framing, Roof Truss Labels” layer is turned on in the current view. Similarly, 
floor and ceiling trusses display when the “Framing, Floor/Ceiling Truss Labels” is turned on. See Layer Display Options 
Dialog on page 183.

Truss labels are available in three formats: automatic, user-specified, and schedule callouts. See Label Panel on page 712.

Truss labels can display in plan view, cross section/elevation views, and the Truss Detail. Automatic and user-specified 
labels are used in the Label column of the Materials List. See Displaying Trusses on page 913. 

Truss labels use the Text Style specified for their layer in the current view. See Text Styles on page 547.
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By default, truss labels are centered on the truss that they identify. If the truss is moved or deleted, the label is moved or 
deleted as well. With the exception of those in the Truss Detail, truss labels have their own Move edit handle which displays 
when the truss is selected. See Editing Trusses on page 914.

Truss labels obey the Minimum Display Size for labels set in the Preferences dialog. See Appearance Panel on page 99. 

If two or more trusses share the same configuration with identical chords and webbing, they will also share the same truss 
label. In the Truss Detail, automatic and user-specified labels shared by multiple trusses will be followed by the total 
number of those trusses, in parentheses.

AUTOMATIC TRUSS LABELS

Automatic roof truss labels use the format TR-X, where X is a number indicating the order in which each distinct truss 
configuration was created. For example, the first truss type created in a plan is labeled TR-1; the second, TR-2; and so on. 

Floor and ceiling trusses are labeled FTR-X and use the same numbering convention. 

 

Mixing Trusses with Stick Framing
After the trusses for your roof are in place, additional roof framing can be added. See Roof Framing on page 867. 

FRAMING DEFAULTS

Roof planes created using defaults set up for trusses will continue to use those defaults when stick framing is added. If you 
intend to add rafters, the roof planes should be created while Trusses (no Birdsmouth) is unchecked in the Build Roof 
dialog. See Roof Panel on page 810.

Leaving Trusses (no Birdsmouth) unchecked has a similar effect on roof trusses to that of Raise Off Plate: roof truss 
bottom chords may be longer than expected and their top chords, higher. This is necessary to create the space needed to 
accommodate the rafter’s depth.

AUTOMATIC FRAMING

The Build Framing dialog can be used to generate roof framing in areas not framed by the trusses, including gable eaves and 
the ends of hips. Note that rafters will not generate closer than 14” (350mm) to an existing, parallel truss. 

Automatically generated roof framing will not extend through an existing roof truss. Instead: 

 l Automatically produced rafters generate inward from the eave until they butt into a truss. 
 l Blocking for standard and hip ridges generates as individual rafter objects between trusses. 
 l Lookouts will pass over Reduced Gable trusses and will end at the next truss in. See Roof Truss Specification Dialog 

on page 928.
 l Hip ridges and common rafters at the end of a hip roof will pass over a Drop Hip Truss. See Drop Hip or California 

Hip on page 924.
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MANUALLY DRAWN FRAMING

Unlike automatically generated roof framing, manually drawn rafters will extend through trusses. Rafters can also snap to 
truss edges as they are being drawn or when they are being edited. See Manual Framing on page 868. 

 

Truss Bases
A Truss Base is a closed polyline that defines the area in which valley fill roof trusses are to be built across and 
above the tops of normal, full size roof trusses.         

Valley fill trusses are often used in reverse gable conditions, where a roof ridge builds onto a roof plane that has a ridge 
running at a different angle. A classic example of this is an “L” shaped house with a gable roof. The main portion of the 
house is trussed through from end to end with normal trusses. Starting at its outside end, the smaller wing is trussed with 
normal trusses until the main house is reached. Where the wing’s roof builds over the main house, valley fill trusses are 
used.           

Normal roof trusses are built between roof planes and ceiling planes. See Roof Trusses on page 911. Valley fill roof trusses 
created using a Truss Base, on the other hand, are built between a larger, supporting roof plane below and overbuilt roof 
planes above.          

Truss bases are drawn and can be edited much like roof planes, with some limitations. See Truss Base Specification Dialog 
on page 922.           

To work correctly, a truss base must be in the same plane with the underlying roof plane, so their baselines should be 
collinear.          
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To create a truss base
 1.  Create an L-shaped house with a reverse gable roof.          

The triangular area of overlap between the main roof and the gable must be defined as a Truss Base.           

 2.  Select Build> Roof> Truss Base , then draw a baseline that is collinear with the baseline of the roof plane that 

will support the overbuild. See The Baseline on page 819.           

 3.  Move the pointer and click on the point where the gable intersects the main roof.          

 4.  A rectangular Truss Base is created. Use its edit handles to reposition it and change its shape as needed.          

 l The two angled sides should be collinear with the roof valleys.          

 l The straight bottom edge must remain collinear with the Truss Base baseline and that of the underlying roof plane.          
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 5.  Draw the normal Roof Trusses  across the length of the main portion of the house. See Roof Trusses on page 

911.          

 l The trusses of the underlying roof generate through the Truss Base, but stop at the Truss Base’s bottom edge so 
that no overhang is produced in that area.          

 6.  When the trusses of the underlying roof are in place, draw the first truss of the reverse gable and position it over the 
outer wall.          

 7.  With this truss selected, click the Multiple Copy  edit button and drag the Move edit handle up to the peak of the 

Truss Base.          

 l Copies of the truss appear as you drag the pointer.          

 l The truss copies all appear to be full length until you release the mouse.         
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Trusses drawn perpendicular to the baseline of a Truss Base 
go under the Truss Base. Trusses drawn parallel to the 

baseline of the Truss Base become valley fill trusses drawn over it.

 8.  When you release the mouse button, any copies drawn in the Truss Base are clipped by it.          

EDITING TRUSS BASES

A selected truss base can be edited in plan view using edit handles, edit toolbar buttons, and the Truss Base Specification 
dialog.         

Truss bases can be edited much the way roof planes can, with some limitations. They are not actual 3D objects, so they 
cannot be assigned materials, moldings or other design attributes; however, their shape, height, pitch and display can be 
edited.  See Editing Roof and Ceiling Planes on page 823.         

 

Truss Base Specification Dialog
Select a truss base and click the Open Object edit button to open the Truss Base Specification dialog. See Truss 
Bases on page 919.

This dialog  is almost identical to the Roof Plane Specification dialog. Although truss bases are not the same as roof planes, 
Chief Architect handles the positioning of the two in a similar manner.         

GENERAL PANEL

Four values define 3D orientation of a truss base: Bottom at Ridge Height, Inside Bottom Height, Outside Bottom Height, 
and Pitch. These values are related; if one is changed, the others change as well.           
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These values are measured from the first floor elevation of 0’ 0". The Pitch should be set identical to that of the roof plane 
that surrounds the truss base.          

Click the radio button to the right of a value to define it as the pivot point for the truss base and prevent it from being 
changed.          

Changing these values does not affect the 2D representation of the truss base.          

Specify the Height/Pivot of the selected truss base.          

 l Define the Bottom at Ridge Height, or lock this value to make it the truss base’s pivot point.          
 l Define the Inside Bottom Height, or lock this value to make it the truss base’s pivot point. If the truss base is drawn 

over a wall, this is located at the inside surface of the wall’s Main Layer.          
 l Define the Outside Bottom Height, or lock this value to make it the truss base’s pivot point.           
 l Specify the selected truss base’s Pitch, or lock this value to move the truss base vertically when a Height value is 

changed.           
 l Check Pitch in Degrees to display the Pitch value in degrees in all dialogs as well as in roof plane labels. Values 

between -89° and 89° can be entered. When this is unchecked, Pitch is described in terms of rise and run: x inches in 
12 or in metric plans, x mm in 1000.      

POLYLINE PANEL

The POLYLINE panel states the length of the truss base’s Perimeter and its enclosed Area. Truss bases have no thickness, so 
they do not have a Volume. See Polyline Panel on page 323.          

SELECTED LINE PANEL

For information about the SELECTED LINE panel, see Line Panel on page 309.          

LINE STYLE PANEL

The settings on the LINE STYLE panel affect the appearance of the selected Truss Base in plan view. For information about 
these settings, see Line Style Panel on page 310.          

FILL STYLE PANEL

The settings on the FILL STYLE panel affect the appearance of the selected Truss Base in plan view. For information about 
the settings on this panel, see Fill Styles on page 197.          

 

Hip Trusses
A variety of different hip truss configurations can be created, including: 

STEP DOWN HIP

Step Down hip roofs are the quickest style of hip truss framing to produce. 
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To create a step down hip truss system
 1.  First, draw a Roof Truss  at the apex of the triangular hip roof plane. When Object Snaps  are enabled, it 

will snap into position. See Object Snaps on page 164.

 2.  Select the truss; click the Multiple Copy  edit button; and click and drag the Move handle down into the hip to 

create copies at regular intervals. See To replicate trusses using Multiple Copy on page 913.           

 3.  Stop when the height of the hip truss reaches a reasonable minimum.           

 4.  Using the Roof Truss  tool, draw hip jacks along the hip ridge from the last truss out into the overhang.

 5.  Using the Roof Truss  tool, draw a jack truss from the intersection of the last hip truss and the hip jack to the 

eave. 

 6.  Select the jack truss; click the Multiple Copy   edit button; and lay out jack trusses up to the other hip jack.

DROP HIP OR CALIFORNIA HIP

A Drop Hip, or California Hip, system uses trusses with lowered top chords to support stick frame hip ridges and common 
rafters. 

To create a drop hip truss system
 1.  Start a drop hip truss system as you would a step down hip system. See Step Down Hip on page 923.

 2.  When the hip trusses are drawn, group select them, open the Truss Specification dialog, and select the Drop Hip 
Truss check box. See General Panel on page 928.

 3.  Use the Build Framing dialog to produce the common rafters, and the short joists at the hip end. See Build Framing 
Dialog on page 873.

The amount that the top chord is lowered is derived from the rafter Depth on the ROOF panel of the Framing Defaults 
dialog. Because both common rafters and hip ridges must pass over this truss, the ridge depth should be set equal to that of 
the rafter depth. 

SUBGIRDER HIP

Subgirders are the partial trusses that butt into the doubled truss at the end of the main run. 

To create a subgirder truss system
 1.  Draw a Roof Truss  where the hip apex meets the ridge.

 2.  Double it by drawing a second truss on the far side from the hip section. 

 3.  Using the Roof Truss  tool, draw the first subgirder from the hip apex out to the eaves. 

 4.  Select it and use the Multiple Copy   edit button to make copies in both directions. Stop when the height of the 

subgirders reach a reasonable minimum.

 5.  Finish off with hip jacks and jack trusses as in a step down hip system.
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Special Roof Trusses
A number of special purpose roof trusses can be created in Chief Architect. 

ENERGY HEELS

An energy heel or raised heel truss is created when the roof is raised off of the wall top plates, creating space for additional 
insulation. When this is the case, a vertical member positioned over the supporting exterior wall is added to the truss. 

Energy Heel Truss

To create an energy heel
 1.  In the Build Roof dialog:

 l Check Trusses (no Birdsmouth);

 l Uncheck Automatic Birdsmouth Cut;

 l Specify the desired energy heel height as a positive Raise Off Plate value.

 2.  Automatically generate or manually draw the roof planes.

 3.  Draw and position the first truss. See To draw and replicate trusses on page 912. 

 4.  By default, the bottom chord extends out to the subfascia. For a bottom chord that stops at the exterior wall, open the 
truss’s specification dialog, check Energy Heel and Force Truss Rebuild, then click OK. See General Panel on 
page 928. 
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Energy Heel Truss with shortened bottom 
chord

 5.  Use the Multiple Copy  edit tool to replicate the truss as needed. 

ATTIC TRUSSES

Attic trusses, a variation of roof trusses, can be drawn if a plan contains an Attic area on both sides and above an upstairs 
room, such as in a Cape Cod style home. The following is a typical cross section view of a building with attic trusses: 

Certain conditions must be met before an attic truss can be built: 

 l The structure should be sufficiently wide to allow for a loft and attic spaces.
 l The loft area must be on a living floor. It cannot be on the Attic floor. See The Attic Floor on page 751.
 l The loft area must have Attic rooms on both sides. See Room Types and Functions on page 420.
 l The loft area must be separated from the Attic rooms on both sides by Knee Walls. See Knee Walls on page 384.
 l A flat ceiling in the loft area and a floor below must be present. 
 l The roof pitch must be steep enough to provide appropriate ceiling height for the loft area. Typical pitches for such a 

condition are 8 in 12 or greater.
 l The roof should bear on the walls of the floor below the loft area and form continuous planes from ridge to baselines.

Once these conditions are met, a roof truss is ready to be designated as an attic truss. 

 1.  Select the roof truss in plan view and click the Open Object  edit button to display the GENERAL panel of the 

Roof Truss Specification dialog.

 2.  Check the box beside Attic Truss and click OK. See Roof Truss Specification Dialog on page 928.
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The final product can be viewed in a framing overview or in the Truss Detail. See Truss Details on page 916.          

SCISSORS TRUSSES

Trusses drawn between roof planes and sloping ceiling planes of a different pitch than the roof are called  Scissor trusses. 
See Ceiling Planes on page 841.

The following is an example of a scissors truss drawn beneath an 8 in 12 pitch gable roof and above 4 in 12 pitch ceiling 
planes. 

GIRDER TRUSSES

Girder trusses provide support for trusses that are cut short, for example, by a reverse gable or a skylight. They are often 
doubled- or tripled-up for strength. 

Draw a new truss from an existing truss to the roof edge, as you would to draw a hip or end jack truss; or draw a truss 
between two trusses, forming a girder. This may be necessary for a large opening, such as a skylight.

Trusses cannot be drawn through each other. If a truss is drawn through an existing truss, the program automatically 
shortens it so that it butts into the existing truss.

SLOPING FLAT TRUSSES

A sloping flat truss is a roof truss that builds within the structural layer of the roof plane(s) it is drawn in. In order to create 
one, the roof plane(s) must have a structural layer deep enough to accommodate its chords and webbing.
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To create a sloping flat truss
 1.  Select the roof plane in which you would like to draw sloping flat trusses and click the Open Object  edit button. 

 2.  On the STRUCTURE panel of the Roof Plane Specification dialog, specify the roof Structure depth as the desired 
depth of the sloping flat truss. See Structure Panel on page 832.

 3.  Select the roof truss and click the Open Object  edit button. 

 4.  On the GENERAL panel of the Roof Truss Specification dialog, check the boxes beside Sloping Flat Truss and 
Force Truss Rebuild, then click OK. See General Panel on page 928.

 5.  Use the Multiple Copy  edit tool to replicate the truss within the area of the roof plane(s) edited in step 2. 

 

Roof Truss Specification Dialog
Select a roof truss or group of roof trusses and click the Open Object edit button to open the Roof Truss 
Specification dialog. 

The Roof Truss Specification dialog allows you to redefine parts of an existing truss or group of trusses. Some settings 
affect only individual trusses, such as gable trusses, while others affect the whole group.

The shape or volume of a roof truss is controlled by the roof planes above it and the ceiling planes below it. It cannot be 
changed from this dialog.

Truss webbing is drawn for representational purposes only and 
as with trusses in Chief Architect in general, is not engineered.

The Roof Truss Specification dialog has the following panels:   

GENERAL PANEL

The defaults for many of the settings on the GENERAL panel are set in the Build Framing dialog. See Trusses Panel on page 
888. 
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Member Sizing

Specify the sizes of the different members that form the selected truss.    

 l Specify the depths of the Top Chord and Bottom Chord.

 l Specify the depth of the Webbing.

 l Specify the Thickness, which is the width of the truss in plan view. 

A. Top Chord
B. Webbing

C. Bottom Chord

 
Maximum Span

Specify the Maximum Span, which is the maximum horizontal distance between supports along the Top and Bottom 
Chords. When these values are equal, the truss webbing often appears more regular.
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Options

Additional Options allow you to create special truss types.

 l Check Require Kingpost to require a vertical webbing member from the roof peak to the bottom chord.

Roof Truss with Kingpost

 l If Require Kingpost is unchecked, a kingpost may still be supplied, depending on the truss length and the specified 
maximum spans.    

 l Check End Truss to replace the webbing with vertical members positioned and spaced the same as the wall studs 
below.

End Truss

 l If an End Truss is in the same position as a gable attic wall, it replaces the framing that would otherwise be produced 
for that wall.    

 l Check Energy Heel to remove the bottom chord from the overhang area. For an energy heel to be modeled and for 
this setting to have an effect, the roof should also be raised off the top plates by at least 7”, depending on the roof 
pitch. See Energy Heels on page 925.    
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Energy Heel Truss with shortened bottom 
chord

 l Check Drop Hip Truss to lower the flat top of a truss in the hip area of a roof so that common rafters and hip ridges 
can pass over and be supported by it. See Drop Hip or California Hip on page 924.    

 l Check Reduced Gable to lower the top chord of an End Truss so that lookouts can pass over the truss. Reduced 
trusses do not have overhangs, but you can draw short rafters drawn at the ends of the truss.

 l Check Attic Truss to specify an attic truss. See Attic Trusses on page 926.    

 l Check Sloping Flat Truss to create a truss with a bottom chord that follows the underside of the roof plane(s) it is 
drawn in. When this is unchecked, the bottom chord follows the ceiling of the room or manually drawn ceiling plane 
below. See Sloping Flat Trusses on page 927.    

 l Check Force Truss Rebuild to rebuild the truss envelope based on the current state of the ceiling and roof when you 
click OK. See Force Truss Rebuild on page 916.    

 l Check Lock Truss Envelope and Webbing to lock the size and configuration of the selected truss. If a locked truss 
is moved, it will maintain its original settings and will not fit properly if the new roof and ceiling conditions are 
different from the original. See Lock Truss Envelope and Webbing on page 916.    

 l Uncheck Use Special Snapping to prevent the selected truss from using special truss snapping behavior. This box 
may become unchecked automatically if you edit a truss using its edit handles. When unchecked, Object Snaps  

may still occur. See Special Truss Snapping on page 915.

 
Preview

A preview of the selected truss displays on the right side of the panel. See Dialog Preview Panes on page 22. 
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LINE STYLE PANEL

The settings on this panel affect the appearance of the selected truss in plan view only. See Line Style Panel on page 310.

FILL STYLE PANEL

The settings on this panel affect the appearance of the selected truss in plan view. See Fill Styles on page 197.

MATERIALS PANEL

The settings on the MATERIALS panel affect the appearance of the selected truss in 3D views. See Materials Panel on page 
1055.

LABEL PANEL

Roof truss labels can display in plan view and cross section/elevation views when the “Framing, Roof Truss Labels” layer is 
turned on and use the Text Style assigned to that layer. See Text Styles on page 547.

Truss labels also display in the Truss Detail. See Truss Details on page 916.            

For more information about the settings on this panel, see               Label Panel on page 712.         

Note: If a truss is listed in a schedule using callout labels, the settings 
here are overridden and the schedule label is used instead. 

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 1335.          

OBJECT INFORMATION PANEL

The information entered on the OBJECT INFORMATION panel can be used in schedules and the materials list. For more 
information, see Object Information Panel on page 1336.   

SCHEDULE PANEL

The settings on the SCHEDULE panel determine which schedule categories the selected object is included in. See Schedule 
Panel on page 716.          

 

Floor/Ceiling Truss Specification Dialog
To open the Floor or Ceiling Truss Specification dialog, select one or more floor or ceiling trusses and click the 
Open Object edit button. See Floor and Ceiling Trusses on page 911. 

Default values for trusses are set in the Build Framing dialog. See Build Framing Dialog on page 873. 

The Floor/Ceiling Truss Specification dialogs have the following panels:
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GENERAL PANEL

 
Member Depth

Specify the Member Depth of the different components of the selected truss.

 l Specify the depth of the Top Chord.

 l Specify the depth of the Bottom Chord.

 l Specify the depth of the Webbing.

 
Thickness

Specify the Thickness of the truss’s chords and webbing.

 l Specify the Overall Thickness of the selected truss.

 l Specify the thickness of the Webbing. 

 
Maximum Span

Specify the Maximum Span, which is the maximum horizontal distance between supports along the Top and Bottom 
Chord.                      
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  Options

 l Check Vertical Supports to use vertical supports in the selected truss. 

 l Check Force Truss Rebuild to rebuild the truss envelope based on the existing floor or ceiling platform when you 
click OK. Not available if Lock Truss Envelope and Webbing is checked, below. See Force Truss Rebuild on page 
916.

 l Check Lock Truss Envelope and Webbing to lock the size and configuration of the truss. A locked truss which has 
been relocated will maintain its original settings. See Lock Truss Envelope and Webbing on page 916.

 l Uncheck Use Special Snapping to prevent the selected truss from snapping along its long edge to a wall’s Main 
Layer or to the corner of a roof plane. If disabled, Object Snaps  may still occur. See Special Truss Snapping on 

page 915.

 
Preview

A preview of the selected truss displays on the right side of the panel. See Dialog Preview Panes on page 22. 

LINE STYLE PANEL

The settings on this panel affect the appearance of the selected truss in plan view only. See Line Style Panel on page 310.   

FILL STYLE PANEL

The settings on this panel affect the appearance of the selected truss in plan view only. See Fill Styles on page 197.   

MATERIALS PANEL

The settings on the MATERIALS panel affect the appearance of the selected truss in 3D views. See Materials Panel on page 
1055.   

LABEL PANEL

Floor and ceiling truss labels can display in plan view and cross section/elevation views when the “Framing, Floor/Ceiling 
Truss Labels” layer is turned on and use the Text Style assigned to that layer. See Text Styles on page 547.   

Truss labels also display in the Truss Detail. See Truss Details on page 916.             

For more information about the settings on this panel, see               Label Panel on page 712.         

Note: If a truss is listed in a schedule using callout labels, the settings 
here are overridden and the schedule label is used instead. 

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 1335.          

OBJECT INFORMATION PANEL

The information entered on the OBJECT INFORMATION panel can be used in schedules and the materials list. For more 
information, see Object Information Panel on page 1336.   

934



Chief Architect Premier X14 Reference Manual - Framing and Truss Schedules

SCHEDULE PANEL

The settings on the SCHEDULE panel determine which schedule categories the selected object is included in. See Schedule 
Panel on page 716.          

 

Framing and Truss Schedules
The Framing Schedule tool allows you to produce customizable framing and truss schedules as well as object labels 
that display schedule numbers. See Schedules and Object Labels on page 694.

Framing schedules created in a Truss Detail use a special Only Include Objects from this Detail setting and a selection of 
Objects to Include that report only floor, ceiling, and roof trusses. See Truss Details on page 916.
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Chapter 26
 

Trim and Moldings

Chief Architect offers a wide selection of trim and molding options. Corner boards, quoins, and frieze moldings can be 
added to a building’s exterior. Molding polylines and 3D molding polylines can be edited as 2D CAD objects using the 
CAD editing tools, then extruded to display in 3D for a variety of powerful applications.

In addition, Chief Architect offers a wide selection of trim and molding options for doors, windows, rooms, and many 
interior objects. See The Library on page 961.

You can also assign moldings to a variety of objects, such as rooms and cabinets, in those objects’ specification dialogs. See 
Specification Dialogs on page 21.

TOPICS

Trim and Molding Defaults 937
Corner Boards 937
Corner Board Specification Dialog 938
Quoins 939
Quoin Specification Dialog 939
Editing Corner Boards and Quoins 941
Moldings and Millwork 942
Moldings / Profiles Panels 943
Molding Specification Dialog 947
Molding Profiles 948
Symbol Moldings 950
Molding Polylines 951
Displaying Molding Polylines 953
Editing Molding Polylines 954
Molding Polyline Specification Dialog 954
3D Molding Polyline Specification Dialog 956
Frieze Moldings 959
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Trim and Molding Defaults
Select Edit> Default Settings to open the Default Settings dialog where you can access the defaults for a variety of 
drawing tools, including a number that affect trim and moldings. 

 l Click the + beside “Corner Trim” to access the defaults for Corner Boards and Quoins. See Corner Boards on page 
937 and Quoins on page 939.           

 l Click the + beside “Floors and Rooms”, then beside “Floor Levels”. Select a floor level and click the Edit button to 
specify the default moldings for rooms on that floor. See Floor Level Defaults on page 419.          

 l Click the + beside “Door” to access the defaults for Interior and Exterior Doors. See Door Defaults on page 552. 
 l Select “Window” and click the Edit button to specify the default casing for windows. See Window Defaults on page 

585.
 l Click the + beside “Cabinet” to access the defaults for the Cabinet Tools, where you can specify default crown and 

other moldings. See Cabinet Defaults on page 629.         

 

Corner Boards
Corner boards are added to a building exterior in any view by selecting Build> Trim> Corner Boards.

Click at a wall corner where you want to add trim. Be sure to click where the outside wall surfaces meet. If you click where 
the inside surfaces meet, corner trim will be created inside the room.

You can also add Corner Boards to all exterior corners at once by selecting Build> Trim> Auto Place Corner Boards .

         

By default, Auto Place Corner Boards  adds Corner Boards to outside corners only. If you prefer, you can specify that 

inside corners receive corner boards in the Corner Board Defaults dialog. See General Panel on page 938.

Note: The Auto Place Corner Boards tool does not place corner boards 
on manually drawn dormers or at intersections with Attic Walls. See Attic 
Walls on page 383.

Corner boards extend from the top plate down to the bottom of the floor platform of the floor on which it is placed, but do 
not extend to other floors. You must add corner boards to all floors of the building that you want to have corner boards. 

A selected corner board or boards can be moved, but only to another wall corner or corners.  In 3D views, corner boards can 
be lengthened or shortened using the edit handles. Corner boards can be copied, deleted and resized similar to other objects 
using the Edit Toolbar or the Corner Board Specification dialog. See Corner Board Specification Dialog on page 938.

The default material for corner boards is defined by the Exterior Trim entry in the Material Defaults dialog. See Material 
Defaults on page 1052. 
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Corner Board Specification Dialog
Select one or more corner boards and click the Open Object edit button to open the Corner Board Specification 
dialog.

The settings in this dialog are similar to those in the Corner Board Defaults dialog, but affect the selected corner boards 
rather than all subsequently created corner boards.           

GENERAL PANEL

Specify the Width and Thickness of the selected corner board(s).         

Check Set Top/Set Bottom to specify the top and bottom heights of the corner board(s).           

 l If Set Top is unchecked, the top of the corner board automatically extends to the top plate.          
 l If Set Bottom is unchecked, the bottom of the corner board automatically extends to the bottom of the floor platform.          

In the Corner Board Defaults dialog, an additional Auto Place Option is available.          

 l Check Include Inside Corners to place Corner Boards on inside corners when the Auto Place Corner Boards  

tool is used. When unchecked, only outside corners receive corner boards.           

LAYER PANEL

For information about the LAYER panel, see Layer Panel on page 191.          

MATERIALS PANEL

The settings on the MATERIALS panel are available for a wide variety of objects in the program. For information about these 
settings, see Materials Panel on page 1055.

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 1335.          
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Quoins
Select Build> Trim> Quoins in any view and click at a wall corner where you want to place quoins. 

You can also add Quoins to all exterior corners at once by selecting Build> Trim> Auto Place Quoins .         

By default, Auto Place Quoins  adds Quoins to outside corners only. If you prefer, you can specify that inside corners 

receive quoins in the Quoin Defaults dialog. See General Panel on page 938.

Note: The Auto Place Quoins tool does not place quoins on manually 
drawn dormers or at intersections with Attic Walls. See Attic Walls on 
page 383.

A selected quoin or quoins can be moved, but only to another wall corner or corners. In 3D views, quoins can be lengthened 
or shortened using the edit handles. Quoins can be copied, deleted and resized similar to other objects using the Edit Toolbar 
or  the Quoin Specification dialog. See Quoin Specification Dialog on page 939.

The size of quoins in plan view is relative on their size in 3D.

Initially, quoins use the same material as the default material of the wall surface they are placed against. This material is 
specified in the Wall Type Definitions dialog. See Wall Specification Dialog on page 395.

 

Quoin Specification Dialog
Select one or more quoins and click the Open Object edit button to open the Quoin Specification dialog.

The settings in this dialog are the same as those in the Quoin Defaults dialog, but affect the selected quoins rather than all 
subsequently created quoins.          
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GENERAL PANEL

  Size and Position

 l Specify the Width, which is the horizontal dimension of each quoin in the selected Quoin object. The dimension 
along the other wall is half this value when they are staggered or mirrored.

 l Specify the Thickness, which is the amount that the quoin protrudes from the exterior surface of the wall.          

 l Specify the Quoin Height for individual quoins in the selected Quoin object.

 l Specify the Quoin Gap, which is the distance between successive quoins.          

 l Check Set Top/Set Bottom to specify the top and bottom heights of the quoin(s) in the text fields.           

 l If Set Top is unchecked, the top of the corner board automatically extends to the top plate.          

 l If Set Bottom is unchecked, the bottom of the quoin automatically extends to the bottom of the floor platform.          

  Style

 l Uniform - Produce quoins that are of equal length on both sides of the corner.

 l Staggered - Produce quoins that have one long side and one short side staggered on opposite sides of the corner.

 l Mirrored - Produce quoins that alternate having either two long sides or two short sides.

 l When Staggered or Mirrored is selected, check Swap Start Block to switch the starting order for the quoins.           

In the Quoin Defaults dialog, an additional Auto Place Option is available.          
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 l Check Include Inside Corners to place Quoins on inside corners when the Auto Place Quoins  tool is used. When 

unchecked, only outside corners receive quoins.          

LAYER PANEL

For information about the LAYER panel, see Layer Panel on page 191.          

MATERIALS PANEL

The settings on the MATERIALS panel are available for a wide variety of objects in the program. For information about these 
settings, see Materials Panel on page 1055.

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 1335.          

 

Editing Corner Boards and Quoins
Before a corner board or quoin can be edited, it must be selected. Click on a trim object when the Select Objects  tool is 

active. Corner boards and quoins can also be group selected and edited. See Selecting Objects on page 212.

Corner boards and quoins can be edited using their edit handles, the Edit Toolbar buttons, and their specification dialogs. 
See Corner Board Specification Dialog on page 938 and Quoin Specification Dialog on page 939.

USING THE EDIT HANDLES

Depending on the type of view, a corner board or quoin displays a different set of edit handles when selected. 

 l In plan view, corner boards and quoins display one edit handle and can be moved from one eligible location at a wall 
corner to another.

 l In 3D views, corner boards and quoins can be moved, lengthened, and shorted much the other line-based objects are. 
See Editing Line-Based Objects on page 218. 

USING THE EDIT BUTTONS

A selected corner board or quoin can be edited in a variety of ways using the buttons on the Edit Toolbar. See The Edit 
Toolbar on page 135.
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DELETING CORNER TRIM

Corner boards and quoins can be selected individually or in groups and deleted using the Delete  edit button or the 

Delete key on the keyboard. They can also be removed using the Delete Objects dialog. See Deleting Objects on page 289. 

 

Moldings and Millwork
Moldings and millwork are often used to enhance both the interior and exterior of designs.

MILLWORK

A selection of various types of millwork objects including columns, corbels and finials is available in the Library Browser. 
See The Library Browser on page 962. 

Most millwork objects are designed to be placed in a plan as free-standing objects. Some -  notably, newels and balusters - 
can be assigned to objects such as railings and stairs.              Other examples of millwork that can be assigned to objects include 
millwork on window exteriors and pilasters and feet on cabinets. See Placing Library Objects on page 980.          

Both free-standing millwork and that assigned to an object can be replaced from the library in 3D views. See Replace From 
Library on page 983.         

MOLDINGS, RAILS, AND OTHER PROFILES

Molding profiles and symbols can be applied to a variety of different types of objects in Chief Architect, including rooms, 
doors, windows, cabinets, tray ceilings, and molding polylines. See Assigned Items on page 981 and Molding Profiles on 
page 948.

Moldings are assigned to their containing object in that object’s specification dialog. See Moldings / Profiles Panels on page 
943.

Moldings assigned to these objects can be listed in both the materials list and in schedules. See Materials Lists on page 
1309 and The Schedule Tools on page 695.

A number of other objects, including roof planes, rope lights, railings, stairs, and ramps have features like ridge caps and 
handrails that are applied in a similar manner that moldings are applied to other objects.     

REPLACING AN EXISTING MOLDING

If a molding profile or symbol has already been applied to an object, it can be replaced by another directly from the 
library in a 3D view. Select Build> Trim> Replace Moldings, select a molding profile or symbol from the Select 

Library Object dialog, then move the mouse pointer into the view window and click on a molding in the view. See Select 
Library Object Dialog on page 982 and Replace From Library on page 983.    

You can also select a molding profile or symbol directly from the Library Browser while a 3D view is active and move your 
mouse pointer into the view window. When a molding is selected, the pointer displays the Moldings   icon. When the 
mouse pointer is moved over a molding in the view, the Replace From Library   icon displays instead. Click on the 
molding's surface to change its molding profile.   
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Moldings / Profiles Panels
The specification dialogs for a variety of objects in the program include a MOLDINGS panel. Select an object or group 
of similar objects and click the Open Object edit button to open the specification dialog for that selection. The 

settings available on this panel will vary depending on the type of object selected.   

A number of roof attributes are assigned the way moldings are. Rafter tails, ridge caps, gutters, frieze molding, and shadow 
boards are all created by specifying a profile and extruding it down a predetermined path. As a result, the settings on the 
RAFTER TAILS, RIDGE CAPS, GUTTER, FRIEZE, and SHADOW BOARDS panels function the same as those on the MOLDINGS 
panel. See Build Roof Dialog on page 809.     

The RAILS panel of the Railing, Fencing, Staircase, Ramp, and Stair Landing Specification dialogs is also similar to the 
MOLDINGS panel, as is the WALL CAPS panel of the Wall Specification dialog. See Railing and Fencing Specification 
Dialogs on page 411 and Staircase Specification Dialog on page 782.     
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  At the top of the dialog, one or more settings may be present.     

 l Only available for rooms, uncheck Use Floor Default to make the settings that follow active. Check this box to use 
the defaults set in the Floor Defaults dialog for the current floor. In the Room Type Defaults dialogs, the settings for 
Floor 1 are shown in the preview when this is checked. See Floor Level Defaults on page 419.      

 l If multiple objects with different moldings assigned to them are selected, a No Change check box will be available. 
Uncheck this box to make the settings that follow active but note that only moldings that all selected objects have in 
common will be retained.

Note: If multiple rooms are selected and only some of them have Use 
Default checked, these settings on this panel will not be editable.       

 l In the Tray Ceiling Specification dialog, specify the Layer that any Molding Polylines associated with the tray 
ceiling are assigned to. See Layers on page 180.     

 
Selected Edge

The On Selected Edge settings are available on the RIDGE CAPS, GUTTERS, and SHADOW BOARDS panels of the Roof Plane 
Specification dialog when an individual roof plane is selected. They determine whether the profile(s) specified on the 
current panel generate along the selected roof plane edge. See Roof Plane Specification Dialog on page 828 and Selected 
Edge on page 214.     

Select Automatic (On/Off) to use the default behaviors for ridge caps, which generate on ridges and hips by default; 
gutters, which generate on eaves by default; and shadow boards, which generate on eaves and/or gables, as specified in the 
Build Roof dialog.      

Select On to generate the profile in question on the selected roof plane edge whenever possible.     

Select Off to suppress the profile in question on the selected roof plane edge regardless of its location.

 
Molding Profiles

The selected object’s Molding Profiles and/or symbol molding(s) are listed in a table and can be edited here.     Depending on 
the type of profile being edited, not all options will be available in the table. 
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  On the RAILS panel of the Staircase, Ramp, and Stair Landing Specification dialogs, the table is divided into three sections: 
Top Rail, Middle Rail, Bottom Rail. In the Wall Specification dialog, there is a  fourth section: Beam. 

 l Select the name of a molding to edit it or remove it from the object.       

 l Click in the Width and/or Height column and type to specify the selected molding’s size.      

 l When a Symbol Molding is selected, click in the Repeat Distance column and type the desired value. See Symbol 
Moldings on page 950.       

 l Specify the Horizontal Offset, which is how close the molding is to the perimeter of the selected object. Increase 
this value to create a gap between the selected object and the molding. See Stacked and Recessed Moldings on page 
949.        

 l Specify the Vertical Offset of the selected molding, measured relative to the default molding location on the object 
it is assigned to.       

 l A check mark in the To Top column means that the Vertical Offset value is measured from the top of the molding. 
When unchecked, this value is measured from the bottom of the molding. Click to place or remove a check mark.       

 l Specify the distance that a selected rafter tail profile should Extend past the inside surface of the subfascia. This 
distance is measured along the top of the rafter tail, so it is greater than the length as measured in plan view.        

Depending on the type of object selected, one or more check boxes will be found under the Molding Profiles table.      

 l When Retain Aspect Ratio is checked, if you change either the Height or Width, the other value changes to 
maintain their original ratio. When this is unchecked, the two values can be edited independently.       This option also 
affects the Repeat Distance of a symbol molding, and is not available when Full Wall Width is checked, below.

 l Check Auto Offset to have the program apply Horizontal and Vertical Offset values to the selected moldings based 
on their Widths and Heights.      

 l On the RAILS panel, check Full Wall Width to make the rail Width equal to the Thickness of the selected railing 
wall. Not available for stairs or ramps.      

 l On the WALL CAP panel of the Wall Specification dialog, when Full Wall Width is checked, the wall cap extends 
the width of the lower wall. When unchecked, it extends out from the exterior surface of the upper wall.      

 l Also on the WALL CAP panel, check Split Pony Wall to build a cap the between the upper and lower walls, centered 
on the lower wall. This becomes checked automatically when Full Wall Width is checked, above.      

The buttons on the right allow you to manage the moldings listed in the table.     

 l Add New opens the Select Library Object dialog and add a new molding profile or symbol to the selected object. 
See Select Library Object Dialog on page 982.

 l Click the Make Copy button to add a copy of the selected molding profile, symbol, or stacked profile at the bottom 
of the list.      

 l Click the Edit button to customize the selected molding's Object Information and Schedule settings. See Molding 
Specification Dialog on page 947.

 l Replace removes the selected profile, symbol, or stacked profile and replace it with a new profile or symbol from 
the Library.      

 l Default resets the Default Rail, Ridge Cap, Gutter, or Rope Light profile.

 l Click the        Delete button to remove the currently selected profile, symbol, or stacked profile from the table.       
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 l Make Stack groups two or more selected profiles in the list  profiles under a “Stacked Profile” line item. Changes 
made to a Stacked Profile affect all profiles in the stack. Not available for moldings with different To Top settings or 
different Types. See Stacked and Recessed Moldings on page 949.       

 l Explode Stack separates a selected stacked profile so they are no longer associated with one another.        

 l Move Up and Move Down change the order of the line items in the table. This does not change a selected item’s 
Height, Offset, To Top setting, or Type: only its position in the table.       

 l Click the Add to Library button to save a copy of the molding as specified here in the User Catalog. See Adding 
Library Content on page 973.        

 
Selected Profile Options

The Selected Profile Options only apply to the molding profile or symbol selected above. The options available will vary 
depending on the type of object that is selected. See below.

 l A preview of the molding profile(s) and/or symbol(s) displays here. When multiple moldings of the same Type, To 
Top setting, or similar Height are specified, they will display together here, even when only one is selected. The 
selected profile is identified by thicker edge lines than the others. When multiple moldings of different Types, To 
Top, or Height settings are selected, no preview will display.      

 l Specify the desired Profile Rotation. Not available for moldings in a stacked molding assembly or for molding 
symbols.      

 l Click the Reflect Horizontal button to reflect the selected profile from left to right, so its outward facing side 
becomes the profile's back.      

 l Click the Reflect Vertical button to flip the selected profile so its top becomes its bottom.    

 l When Count Components in Materials List is checked, the individual components of stacked profiles are counted 
separately in the Materials List. When unchecked, they are treated as a single profile. Only available when stacked 
profiles are specified above. See Stacked and Recessed Moldings on page 949.

Cabinet Moldings and Counter Profiles
 l Select a molding Type from the drop-down list. For base cabinets, the choices are "Edge Profile" and "Base 

Molding"; for wall cabinets, "Crown Molding" and "Light Rail"; for full height cabinets, "Crown Molding" and 
"Base Molding". Cabinet molding Type is reported in schedules and the Materials List. When a molding's Type is 
changed, its To Top setting may also change, above. See Materials Lists on page 1309.

 l Check Offset Molding For Face Items to measure the selected profile's Horizontal Offset from the cabinet's front, 
side, and/or back face items. When unchecked, the molding is offset from the cabinet box. See Pilasters, Feet, and 
Moldings on page 648.

Room Moldings
 l Choose the currently selected molding’s Type from the drop-down list: Base Molding, Chair Rail, or Crown 

Molding. When a molding's Type is changed, its To Top setting may also change, above. If no Type is selected, 
the molding will not be listed in the Room Finish Schedule. See Room Moldings on page 441 and Schedules and 
Object Labels on page 694.     

Note: The Default Base Molding is a basic rectangular stock profile 
rather than a profile from the library. 
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Molding Polylines
 l When Extrude Inside Polyline is checked, the selected molding profile generates on the inside of the molding 

polyline. Uncheck this box to generate the profile on the exterior of the polyline instead. Only available for 
Molding Polylines and 3D Molding Polylines. See Molding Polylines on page 951.      

Roofs
 l On the FRIEZE MOLDING and SHADOW BOARDS panels, select a Type from the drop-down list: Eave and Gable, 

Eave only, and Gable only. See Roof Returns and Other Details on page 858.      

 l On the RAFTER TAILS panel, uncheck Stretch to Fit Rafter to use the rafter tail profile’s default size or to specify 
its Height and Width, below. When this is checked, the profile is sized by the program to match the selected roof 
rafter.       

 l On the RIDGE CAPS panel, check Bend to Roof Pitch to adjust the shape of the selected ridge cap profile to match 
the pitch of the roof.        

Walls and Railings
 l On the WALL CAP panel of the Wall Specification dialog, check Extrude Inside Wall to position a wall cap on the 

interior side of a pony wall instead of on the exterior side. See Lower Pony Wall Caps on page 358.

Framing
 l On the END PROFILE panel of the Framing Specification dialog for joists, beams, and General Framing, uncheck 

Stretch to Fit Framing to use the end profile’s default size or to specify its Height and Width, below. When this 
is checked, the profile is sized by the program to match the selected framing member.

Many specification and defaults dialogs have previews of the selected object in which the moldings assigned to it can be 
seen. See Dialog Preview Panes on page 22.

Some specification and defaults dialogs have previews of the selected object in which the moldings assigned to it can be 
seen. See Dialog Preview Panes on page 22.

When Use Floor Default is checked in the Room Type Defaults dialog, this preview always shows the default moldings for 
Floor 1.

 

Molding Specification Dialog
Right-click on a molding profile in the Library Browser and select Open Object from the contextual menu to open 
the Molding Specification dialog. When accessed in this manner, the item in the library can be edited but no 

moldings already present in any plans will be affected. See Using the Contextual Menus on page 965. 

You can also open this dialog by clicking the Edit button on the MOLDINGS panel of various object specification dialogs. 
When accessed in this manner, only the molding on the selected object is affected. See Moldings / Profiles Panels on page 
943.

GENERAL PANEL
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Specify the selected molding's Height and Width.

Specify the selected molding's Rotation in degrees, measured in a counterclockwise direction. Not available for symbol 
moldings.    

MATERIALS PANEL

The settings on the MATERIALS panel are available for a wide variety of objects in the program. For information about these 
settings, see Materials Panel on page 1055.

If the selected molding is a stacked profile or molding symbol, multiple materials can be specified. See Stacked and 
Recessed Moldings on page 949 and Symbol Moldings on page 950.    

OBJECT INFORMATION PANEL

The information entered on the OBJECT INFORMATION panel can be used in schedules and the materials list. For more 
information, see Object Information Panel on page 1336.   

SCHEDULE PANEL

The settings on the SCHEDULE panel determine which schedule categories the selected molding is included in. See Schedule 
Panel on page 716.

 

Molding Profiles
A molding profile is a representation of  a 2D cross section of a particular style of molding created using one or more CAD 
polylines. A molding profile does not display in 3D on its own; it must be applied to an object like a room, a cabinet, or a 
molding polyline. See Moldings / Profiles Panels on page 943 and Molding Polylines on page 951.          

The library contains a selection of moldings, as well as curbs, gutters, handrails and rafter tails, which function much like 
molding profiles. You can customize library molding profiles and also create your own custom profiles and add them to the 
library. See Adding Library Content on page 973. 

CREATING A MOLDING PROFILE

You can easily create custom molding profiles using the CAD drawing and edit tools by following a few basic guidelines.           

 l Draw a molding profile at its actual, unscaled size.           
 l The profile must be drawn with the proper orientation. The back of most profiles, or the side facing the wall, must be 

drawn as a vertical edge on the left side of the polyline.          
 l Similarly, curbs and gutters are drawn with the back of the profile as a vertical edge on the left side of the polyline.           
 l Open polylines should be used for gutter and rafter tail profiles. Gutter profiles attach to the roof on the left side, and 

rafter tail profiles should be open on the left side.           
 l Ridge cap profiles must be closed polylines drawn to match the pitch of the roof planes they will cap.           
 l Rail, handrail, and railing beam profiles should be drawn with the bottom edge facing downward.          
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ADDING MOLDING PROFILES TO THE LIBRARY

When a CAD polyline meets your needs as a molding profile, select it and click the Add to Library  edit button.           

If you have drawn a molding profile using multiple closed polylines, select them as a group and click the Add to Library 
as Stacked Molding  edit button. A molding created in this manner can have more than one material assigned to it.           

A molding that has been assigned to an object can also be added to the library by clicking the Add to Library button in the 
object’s specification dialog. The Width and Height of the molding, as specified in the specification dialog, are retained; 
Offset values, however, are not. See Moldings / Profiles Panels on page 943.          

EDITING A MOLDING PROFILE

Once created, the height, width, molding profile can be edited in a limited number of ways.

 l Right-click on a molding profile in the Library Browser and select Open Object  from the contextual menu to open 

the Molding Specification dialog. See Molding Specification Dialog on page 947.    
 l The height, width, rotation, and material of a molding assigned to another object can also be edited in that object's 

specification dialog. See Moldings / Profiles Panels on page 943.

There is not a way to edit the shape of an existing molding profile. You can, however, create a new profile either from 
scratch using the CAD tools or using the Place Molding Profile option. 

PLACE MOLDING PROFILE

An existing molding profile can be placed in plan view or a CAD Detail, edited, and added to the library as a new profile.          

Right-click on a molding profile in the library and select Place Molding Profile from the contextual menu. Move your 
pointer into the drawing area and click once to place a closed CAD polyline identical to the selected profile at that location. 
The polyline can then be edited to suit your needs. See Editing Closed Polyline-Based Objects on page 230.         

Note: Place Molding Profile cannot be used to apply a molding profile to 
an object - it is only used to place a profile polyline.

STACKED AND RECESSED MOLDINGS

There are several ways to create stacked or built up moldings:           

 l Draw the entire build-up using a single polyline, then select it and click the Add to Library  edit button.          

 l Draw the build-up using multiple polylines, then select them as a group and click the Add to Library as Stacked 
Molding  edit button. A molding created in this manner can have more than one material assigned to it.           

 l Apply multiple moldings to an object, then specify their horizontal and vertical offsets, making sure they all have the 
same To Top setting. Finally, group-select the moldings and click the Make Stack button. Only room moldings of the 
same Type can be stacked in this manner. See Moldings / Profiles Panels on page 943.           
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To build up molding profiles
 1.  On the MOLDINGS panel of the specification dialog of any object that molding can be applied to, click the Add New 

button           

 2.  Add a molding profile to the object and specify its Height, Width, and Vertical and Horizontal Offset values. 
Make a note of these values.           

 3.  Click the Add New button and add a second molding profile to the object.          

 4.  Specify the second molding profile’s Height, Width and Offset values.          

 l To define the Vertical Offset, add the first profile’s Height and Vertical Offset values.          

 l To define the Horizontal Offset, add the first profile’s Width and Horizontal Offset values.         

Similarly, molding can be recessed by specifying a negative Horizontal Offset - for example, to create an under cabinet light 
rail. See Editing Cabinet Styles on page 646.           

An alternative to molding profiles are symbol moldings. Molding symbols are different from molding profiles because they 
are replicated 3D symbols instead of extruded 2D shapes. See Symbol Moldings on page 950.          

 

Symbol Moldings
Symbol Moldings are 3D symbols that are repeated along a path to form molding. Molding symbols are different from 
molding profiles because they are replicated 3D symbols instead of extruded 2D shapes.          

CREATING A SYMBOL MOLDING

Begin by opening a new, blank plan and creating a single instance of the molding symbol using the Primitive Tools . 

See Primitive Tools on page 1016. For example, to create the molding shown in the illustration above, make an object that 
looks like this:           

When you are satisfied with its appearance, convert it to a 3D symbol. See Convert to Symbol on page 1002.          

You can also import a 3D symbol from another application. See Importing 3D Symbols on page 1239.          
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To import a molding symbol
 1.  Select File> Import> 3D Symbol  from the menu. See Import 3D Symbol Dialog on page 1240.           

 2.  In the Import 3D Symbol dialog, specify the symbol as Molding and click the Advanced button.          

 l If you plan to use the molding symbol more than once, check the box beside Add to Library. See Add to Library on 
page 973.          

 1.  On the 3D panel of the Symbol Specification dialog, rotate the symbol as needed so that it faces you in the preview 
image.          

Symbol moldings work best if you make them symmetrical.
 

Once created, a symbol molding can be assigned to an object or replicated along a molding polyline. See Molding Polylines 
on page 951.           

Symbol moldings are center aligned. Both ends have a 45° miter, so the end instances may appear chopped. You can specify 
the Repeat Distance of a symbol molding applied to an object to control the width of each instance of the symbol on the 
object. See Moldings / Profiles Panels on page 943.          

 

Molding Polylines
A molding polyline is a 3D path that either a 2D molding profile is extruded along or a series of molding symbols is 
repeated along. Molding polylines can be used to create custom room moldings and decorations anywhere in your 3D 

model. The Molding Polyline tools are accessed by selecting Build> Trim from the menu.         

There are four types of molding polylines:          
 

Molding Polylines

 
Molding Lines

 
3D Molding Polylines

 
3D Molding Lines

To create a  molding polyline, first select the desired Molding Polyline tool. The Select Library Object dialog will open. 
Select a molding profile or symbol from the library, then click and drag to draw the path for the selected molding profile or 
symbol.           

If a molding profile or symbol has been previously selected during the current session in the program, you can begin 
drawing using this molding without selecting anything from the library.           

Molding polylines can also be created using the Make Room Molding Polyline  and the Convert Polyline  edit 

tools.           

MOLDING POLYLINE

Select Build> Trim> Molding Polyline in plan view, a camera view or overview to create a rectangular molding 
polyline with a closed shape and a single height off the floor along its entire perimeter.         
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In  plan view, Molding Polylines can also be created by selecting a profile from the Library Browser. Single-click to place a 
2’x2’ closed polyline or click and drag to draw a rectangular polyline.           

MOLDING LINE

Select Build> Trim> Molding Line in plan view, a camera view, or overview to create a molding line with a single 
height off the floor along its entire length. Multiple Molding Lines can be connected to form open or closed polylines 

as long as they share the same height.          

3D MOLDING POLYLINE

Select Build> Trim> 3D Molding Polyline in floor plan or cross section/elevation view to create a closed molding 
polyline.          

 l When drawn in a cross section/elevation view, a 3D Molding Polyline’s top and bottom edges have two different 
heights. Its sides have different heights at their start and end points.          

 l If drawn in plan view, a camera view, or an overview, a 3D Molding Polyline has a single height along its perimeter.           

In either case, then lengths and angles of its edges can be edited in three dimensions. Although they are polyline-based 
objects, 3D Molding Polylines do not always have the same set of edit handles as other polylines. Depending on the angles 
of the various segments of a selected 3D Molding Polyline, which edge is selected, and the current view, some or all corner 
edit handles may not be available.         

3D MOLDING LINE

Select Build> Trim> 3D Molding Line in floor plan or cross section/elevation view to create a molding line.          

 l If drawn in a cross section/elevation view, a 3D Molding Line’s start and end points can have two different heights.           
 l If drawn in plan view, a camera view, or an overview, a 3D Molding Line has a single height along its length.           

3D Molding Lines can be connected to form polylines as long as the ends at which two segments connect have identical 
heights.           

Once drawn, a 3D Molding Line can be edited so that it travels in three dimensions.           
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MOLDINGS LIBRARY

In the plan view, select a molding profile from the library. The Molding Polyline  tool becomes active, allowing you to 

draw a molding polyline with using the selected profile.          

CONVERTING A ROOM MOLDING

Select a room and click on the Make Room Molding Polyline edit button. This opens the Make Room Molding 
Polyline dialog, allowing you to select which type of room molding to convert to a molding polyline. See Room 

Polylines on page 441.         

CONVERTING A CAD POLYLINE

Select a CAD polyline and click the Convert Polyline edit button to convert it into either a Molding or 3D Molding 
Polyline. See Convert Polyline on page 265.         

 

Displaying Molding Polylines
As with other objects, the display of molding polylines in 2D and 3D views is controlled in the Layer Display 
Options dialog. See Layer Attributes on page 181. 

There are a number of different types of molding polyline objects. By default:

 l Molding polylines are placed on the “Moldings” layer.
 l Roof ridge caps, gutters, frieze molding, and shadow boards are placed on the “Roofs, Ridge Caps”, “Roofs, Gutters”, 

and “Roofs, Trim” layers, respectively.

In plan view, manually drawn Molding and 3D Molding Polylines display as two sets of lines: one representing the 
molding’s front and one its back. The distance between them is determined by the Width of the molding profile.  If a 
Horizontal offset is specified, that value is added to the distance between the two lines. See Moldings / Profiles Panels on 
page 943. 

Molding Polylines are listed in the "Interior Trim" category of the Materials List by default and can also be included in 
schedules. See Materials Lists on page 1309 and The Schedule Tools on page 695.

PROFILES ON THE SELECTED EDGE

By default, the molding(s) assigned to a molding polyline display along all of its edges in 3D views. If you wish, you can 
suppress the display of moldings on the Selected Edge by clicking the Remove Molding from Selected Edge  edit 

button or checking No Molding on Selected Edge in the molding polyline’s specification dialog. See Selected Edge on 
page 214. 

Suppressed moldings can be restored to the selected edge by clicking the Add Molding to Selected Edge  edit button or 

by unchecking No Molding on Selected Edge.

These edit buttons are also available for a selected Gutter, Ridge Cap, or Shadow Board polyline and for Custom 
Countertops. They are not, however, available for Rope Moldings. See Roof Returns and Other Details on page 858, 
Countertops on page 637, and Rope Lights on page 680. 
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Editing Molding Polylines
Molding polylines can be edited much the way CAD polylines are. See Editing Open Polyline-Based Objects on page 226 
and Editing Closed Polyline-Based Objects on page 230. 

Note: 3D Molding Polyline edges that slope rather than having a single 
height are best edited in a camera or elevation view. See 3D Views on 
page 1080. 

Molding lines and polylines also can be edited in their specification dialogs. See Molding Polyline Specification 
Dialog on page 954 and  3D Molding Polyline Specification Dialog on page 956.

DELETING MOLDING POLYLINES

Molding polylines can be deleted like other objects using the Delete  edit button or the Delete key on your keyboard.

Molding Polylines are also deleted when the Delete Objects dialog is used to delete CAD objects. See Deleting Objects on 
page 289. 

 

Molding Polyline Specification Dialog
To open the Molding Polyline Specification dialog, select a molding polyline or group of molding polylines and click 
the Open Object edit button. 

The Molding Polyline Specification dialog has the following panels:          

GENERAL PANEL

 l Specify the Molding Polyline’s Height, relative to 0.          
 l Check No Molding on Selected Edge to create blank section in the molding polyline along the selected line segment.          

POLYLINE PANEL

The POLYLINE panel states the Length of an open molding polyline, and the Perimeter and Area of a closed molding 
polyline. See Polyline Panel on page 323.          
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SELECTED LINE/ARC PANEL

The SELECTED LINE panel is available when the selected segment of the molding polyline is a line, as opposed to an arc. For 
more information, see Line Style Panel on page 310.          

The SELECTED ARC panel is available when the selected segment of the molding polyline is an arc, as opposed to a line. See 
Arc Panel on page 318.          

See, too, Selected Edge on page 214 and Change Line/Arc on page 259.           

MOLDINGS PANEL

The MOLDINGS panel can be found in dialogs throughout the program. See Moldings / Profiles Panels on page 943.           

One setting on this panel is unique to the Molding Polyline and 3D Molding Polyline Specification dialogs:           

 l Check Inside to extrude the molding profile on the inside of closed polyline or right side of an open polyline.           

 l When unchecked, the molding profile extrudes on the outside or left side of the polyline.          

LINE STYLE PANEL

The LINE STYLE panel can be found in dialogs throughout the program. For information about the settings on this panel, see 
Line Style Panel on page 310.          

FILL STYLE PANEL

The settings on the FILL STYLE panel affect the appearance of the selected Molding Polyline in plan view. For more 
information, see Fill Styles on page 197.          

MATERIALS PANEL

The MATERIALS panel can be found in dialogs throughout the program. For information about the settings on this panel, see 
Materials Panel on page 1055.          

LABEL PANEL

Molding Polyline labels display when the “Polylines 3D, Labels” layer is turned on and use the Text Style assigned to that 
layer. See Text Styles on page 547.           
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For more information about the settings on this panel, see Label Panel on page 712.           

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 1335.          

 

3D Molding Polyline Specification Dialog
Select a 3D molding polyline and click the Open Object edit button to open the 3D Molding Polyline Specification 
dialog.

The 3D Molding Polyline Specification dialog has the following panels:          

GENERAL PANEL

 l Uncheck Molding on Selected Edge to turn off the display of the specified molding on the selected edge of the 
polyline. See Selecting Objects on page 212.          

 l If the selected object is an automatically generated ridge cap, frieze molding, or shadow boards polyline, this check 
box’s label will reflect the object type. See Roof Returns and Other Details on page 858.           

An Automatically Generated check box will be present if a ridge cap, frieze molding, or shadow boards polyline is 
selected. This check box is for reference only and cannot be edited. See Roof Returns and Other Details on page 858.           

 l When this box is checked, the selected roof trim is updated whenever you rebuild the roof.           
 l If the selected object is edited, this box will become permanently unchecked. To restore the automatic updating 

behavior, the frieze, shadow boards, or ridge caps must be deleted and regenerated.           

SELECTED LINE PANEL

The SELECTED LINE panel is available when the selected edge of the 3D Molding Polyline is a line as opposed to an arc. 
Most of the settings here are the same as those on the LINE panel of the Line Specification dialog. See Line Panel on page 
309.           

The Length/Angle settings in the 3D Molding Polyline Specification dialog are unique to this dialog.          
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 l Length specifies the 3D length of the selected edge of the 3D Molding Polyline.          
 l Angle in XY Plane specifies the counter-clockwise angle that the selected edge makes with the positive X axis when 

viewed from above, as in plan view.          
 l Angle from XY Plane specifies the angle that the selected edge makes with the horizontal XY plane when viewed 

from the side, as in a cross section/elevation view. A positive value means that the line slopes up; a negative value 
means that it slopes down.          

SELECTED ARC PANEL

The SELECTED ARC panel is available when the selected segment of the 3D molding polyline is an arc as opposed to a line.          

Other specification dialogs have a SELECTED ARC panel; however, most of the settings work differently for 3D Molding 
Polylines than they do for other objects in the program.           
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Lock

The Lock options specify how changing one value affects other values.         

 l Select Start to keep the start and center of the arc fixed and move the end.          

 l Select End to keep the end and center of the arc fixed and move the start.          

 l Select Center to keep the center of the arc fixed and move the start or end.          

 l Select Arc to keep the arc geometry fixed and translate the arc.          

 l Select Chord to keep the start and end fixed and change the radius.          

 
Start

Specify the coordinates of the selected arc’s Start point. Only available when Lock End or Lock Arc is selected.         

 
End

Specify the coordinates of the selected arc’s End point. Only available when either Lock Start or Lock Arc is selected.         

 
Chord

Specify the length and angle of the selected arc’s Chord. Only available when Lock Start or Lock End is selected.         

 l Specify the Chord Length, which is the 3D distance between arc start and end.          

 l Specify the Chord Angle: the angle created by the chord and the positive X axis.          

 
Arc

The Arc options specify radius, angle and length values of the selected arc:         

 l Radius - The distance from the arc to the arc center.          

 l Start Angle - The angle created by a line from the arc center to the start and the positive X axis.          

 l End Angle - The angle that a line from the center to the end          

 l Arc Angle - The angle created by a line from the arc center to the start and a line from the center to the end.          

 l Arc Length - The length of the arc.          

 
Center

Specify the coordinates of the selected arc’s Center point. Only available when Lock Arc is selected.         

 
Normal

The items under the Normal heading state the coordinates of the normal of the plane that the arc exists in. The normal is a 
vector that is parallel to that plane and is expressed as a line between two points: (0,0) and the point defined in the dialog.         

 l The arc direction in plan view is counter clockwise if the normal has a positive value on the z axis (0,1) and 
clockwise if the value on the z axis is negative (0,-1).           

MOLDINGS PANEL

The MOLDINGS panel can be found in the specification dialogs for a variety of different objects in the program. See 
Moldings / Profiles Panels on page 943.           

One setting on this panel is unique to the Molding Polyline and 3D Molding Polyline Specification dialogs:           
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 l Check Inside to extrude the profile on the inside or right side of the polyline.           

 l When unchecked, the profile extrudes on the outside or left side of the polyline.          

LINE STYLE PANEL

The LINE STYLE panel can be found in dialogs throughout the program. See Line Style Panel on page 310.          

If an automatic frieze or shadow board polyline is edited, it will no longer be considered Automatic and the Default Layer 
check box on this panel will be unchecked.          

MATERIALS PANEL

The MATERIALS panel is found in dialogs throughout the program. See Materials Panel on page 1055.          

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 1335.          

 

Frieze Moldings
Frieze moldings, also known as frieze boards, are mounted below the eaves of roof planes and can be generated 
automatically using the Build Roof dialog.
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CREATING FRIEZE MOLDINGS

To create automatic frieze moldings, specify a molding profile on the FRIEZE panel of the Build Roof dialog and then build 
the roof. See Frieze Molding on page 862.

DISPLAYING FRIEZE MOLDINGS

By default, frieze molding displays in 3D views but not in plan view and its default layer, “Roofs, Trim”, is locked. See 
Layer Display Options Dialog on page 183.

SELECTING FRIEZE MOLDINGS

To select a frieze molding, its layer must first be unlocked and turned on. See Locking Layers on page 182. In floor plan or 
a cross section/elevation view, click on a frieze molding. If the wall behind it is selected, click the Select Next Object  

edit button or press the Tab key until the frieze molding is selected. When the frieze molding is selected, the Status Bar says 
“3D Molding Polyline.” See The Status Bar on page 25.

EDITING FRIEZE MOLDINGS

Like other 3D Molding Polylines, frieze molding can be edited much the way CAD polylines are in floor plan and cross 
section/elevation views. See Editing Molding Polylines on page 954.

Frieze molding can also be edited in the 3D Molding Polyline Specification dialog. See 3D Molding Polyline Specification 
Dialog on page 956.

If you edit a frieze molding, it is no longer considered an Automatic frieze and will not be deleted and replaced when the 
roof is rebuilt. Once Automatic is unchecked, it cannot be checked again. To restore the automatic updating behavior of 
frieze molding, it must be regenerated. 
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Chapter 27
 

The Library

Chief Architect Premier’s library offers thousands of symbols, materials, and images that can enhance any plan. 

New library catalogs and enhancements are  made available by Chief Architect Software on a continuing basis and are 
available for download for the current program version. 

You can also customize items from the library or import new items from outside the program and then save them in the 
library for future use.

The Library Browser shares its window with the Project Browser, which is discussed separately. See Project Browser on 
page 58.

TOPICS

The Library Browser 962
Searching the Library 967
Find in Library 968
Library Content 969
Downloading Library Content 971
Importing Library Catalogs 972
Adding Library Content 973
Organizing the Library 975
Filtering the Display of Library Content 978
Exporting Library Catalogs 979
Placing Library Objects 980
Select Library Object Dialog 982
Place Library Object Button 982
Replace From Library 983
Displaying Library Objects 985
Editing Library Objects 986
Symbol Object Specification Dialogs 989
Fixture and Furnishing Schedules 991
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The Library Browser
The Chief Architect Library Browser allows you to manage the contents of the library as well as add library content 
to your drawings. 

To open the Library Browser:
 l Select View> Library Browser.
 l Click the Library Browser  button.

 l Press Ctrl + L on your keyboard.

By default, the Library Browser is docked to the right side of the program window, but can be undocked or docked to 
another side. See Docking the Library Browser on page 966.

The Library Browser has four sections: 

 l The filter and search options at the top. 
 l The Directory and Search Results Pane. 
 l The Selection Pane. 
 l The Preview Pane. 

To adjust the height or width of a section, place the pointer over the split bar you want to move. When the double-headed 
arrow   displays, click and drag. 

You can control the configuration of the Library Browser panes 
in the Preferences dialog. See Library Browser Panel on page 

104.

You can work on your drawing with the Library Browser open. To close the Browser, click the Close   button or double-
click on an object in the Selection Pane. 

The library directory is presented in a tree list with five categories: Chief Architect Core Catalogs, Chief Architect Bonus 
Catalogs, Manufacturer Catalogs, User Catalog and Trash. See Library Content on page 969. 
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Active Filter

Specify what displays in the Directory Pane’s tree list by selecting a filter from the drop-down list. See Filtering the Display 
of Library Content on page 978.     

 l When “Not Filtered” is selected, all installed library content will display in the tree list.     

 l “Not Filtered” will be the only available option until you create a custom filter.     

 l Click the Manage Library Filters  button to open the Manage Library Filters dialog. See Manage Library 

Filters Dialog on page 978.

 
Search

Search the library using keywords and optional search filters. See Searching the Library on page 967.     

 l Begin typing in the text field to search for library items. As you type, search results will display in the Directory 
Pane. 

 l Search a specific catalog or folder by right-clicking on it and selecting Search Folder. Multiple items can be searched 
in this manner.

 l Right-click on an item in the Search Results list and select Show in Browser to view the item’s location in the 
Directory list.

 l Click the Browse  button to stop searching and restore the Directory list.

 l Click the Search  button to display the search results for your search entry.

 l Click the Search Filtering Options  button to customize your search parameters. If the Library Browser is 

resized so that it is narrow, this button will be replaced by two arrows.
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Library Pane

The library Directory and Search Results display here. The basic structure of the directory tree is:      

Library items are always placed in alphabetical order within their hierarchy.

The Library Browser includes a Trash bin, where deleted items are moved until you choose to Empty Trash. See Deleting 
Library Items on page 977.     

Navigate the Directory Pane using the mouse. Click the gray Expand arrow   beside a catalog or folder to display its 
contents. Once expanded, you can click the black Collapse arrow   to close it again. You can also browse the list using the 
arrow keys on your keyboard. 

Click on an item to select it. Preview images display in the Selection and Preview Panes and basic information about it also 
displays in the program’s Status Bar. See The Status Bar on page 25.

 
Selection Pane

The Selection Pane shows a thumbnail image of the item selected in the Directory Pane.       

When an item is selected in the Directory Pane, a basic line-based representation of the item displays in the Selection Pane.

 l If the selected item is a single object, a preview of that object displays in the Preview Pane. You can move your 
cursor into the drawing area to place the item. See Placing Library Objects on page 980.     

 l If the selected item is a folder, a thumbnail image displays, representing each item inside. Move your pointer over an 
item in this pane to see a Tool Tip with the item’s name. Click on a folder in the Selection Pane to display its 
contents here and make it the item selected in the Directory Pane.

 l Some folders may have too many items to display useful thumbnails for each; when this is the case, they do not 
display.     

If you have Scrollable List checked in the Preferences dialog, a scrollbar is present at the bottom of the Selection Pane.    

Click the Show/Hide Selection Pane  button to toggle the Selection Pane on and off.

 
Preview Pane

When an individual item is selected in either the Directory or Selection Pane, an image of it displays in the Preview Pane. 
If the item is designed to be inserted into another object such as a cabinet, that parent object will also display in the preview.
    

You can click the Toggle Preview Display  button at the bottom of the browser window to switch between preview 

images in Standard Render and Vector View styles.    

If the selected object is a 3D symbol, you can  rotate and zoom in or out on the Preview using the mouse. Two-dimensional 
objects, such as CAD Blocks or Line Styles cannot be adjusted in this manner in the Preview Pane.

If you have rotated a view in the Preview Pane, you can restore the default angle either by clicking in the Selection Pane or 
by right-clicking on the Preview Pane and selecting Reset Preview.    

Click the Show/Hide Preview Pane  button to toggle the Preview Pane on and off.
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Toolbar

The toolbar at the bottom of the browser aids in searching, displaying panes, and managing library content.     

  Open the Plant Chooser dialog. See Plant Chooser Dialog on page 1301.     

  Get Additional Online Content launches your default web browser to the Chief Architect website, where 
additional library content is available for download.     

  Update Library Catalogs downloads and installs updates to your installed catalogs to include the latest 
content. See Updating Library Catalogs on page 970.     

  Show/Hide Selection Pane toggles the Selection Pane on and off.     

  Show/Hide Preview Pane toggles the Preview Pane on and off.     

  Toggle Preview Display switches between Standard Render and Vector View images of a selected library 
object in the Preview Pane. See Rendered and Vector Views on page 1081.

  A selected material will display on a shape in the Preview Panel. The initial shape is a Sphere, but you can 
select a Cube, Teapot, or 2D Plane instead if you prefer. The object shape selection is also shared with the 

Define Material dialog. See Define Material Dialog on page 1066.

  Open the Preferences dialog, where display properties for the Library Browser can be controlled. See Library 
Browser Panel on page 104.

USING THE CONTEXTUAL MENUS

A number of important library functions can be accessed using the contextual menus. Right-click on an item in the Library 
Browser to open a contextual menu displaying options related to that item. See Contextual Menus on page 19.

The options in the contextual menu vary depending on the item selected, but may include: 
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 l Search Folder
 l Cut/Copy/Paste
 l Copy to User Catalog
 l Paste Shortcut
 l Locate Shortcut Source
 l New
 l Rename
 l Delete
 l Export Library
 l Open Object/Open Symbol
 l Edit CAD Block
 l Search Attributes
 l Text Macro Management          
 l Place Molding Profile           
 l Reset Preview
 l Expand All/Collapse All
 l Show in Browser

KEYBOARD COMMANDS

The Library Browser can be navigated using the arrow keys on your keyboard. 

 l The right and left arrow keys expand and collapse folders.
 l The up and down keys change which library object is currently selected.
 l Select an item and press F2 to rename it.
 l Select an item and press the Delete key to delete it. 

If you have Scrollable List selected in the Preferences dialog, pressing the Tab key switches focus between the Directory 
and Selection Panes. Use your mouse to select an object for placement. See Library Browser Panel on page 104.          

If you have Tiled To Fit Window selected instead, pressing the Tab key switches focus between the tree view and the 
Selection Pane. You can then use the arrow keys to select a library object within the Selection Pane.          

EXPAND/COLLAPSE ALL

When a library category or folder is selected in the Directory Pane, Expand All and Collapse All are available in the 
contextual menu, allowing you to expand or contract its contents in the tree view.

DOCKING THE LIBRARY BROWSER

Initially, the Library Browser side window is docked to the right side of the main Chief Architect program window. To 
undock it, click and drag its title bar towards the center of the program window. Once undocked, it can be moved and 
redocked in the same manner. See Side Windows on page 17. 

When moved to the top, bottom, or side of the program window, it automatically docks in a vertical or horizontal 
orientation, depending on its location. You can prevent the Library Browser from docking when dragged: 

 l In the Preferences dialog. See Appearance Panel on page 99.             
 l By holding down the Ctrl key while dragging it.
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To return the Library Browser to its original position and size, click the Restore Position/Size button in the Preferences 
dialog. See Reset Options Panel on page 131.

CLOSING THE LIBRARY BROWSER

The Library Browser can be closed in either of two ways: 

 l Click the Close   button at the top right corner of the browser window.

 l Select View> Library Browser .

 

Searching the Library
The Library Browser filtering options let you focus your searches to meet parameters that you define. 

Search filters do not affect the display of items in the Directory Pane tree list. You can filter the display of the tree list 
separately. See Filtering the Display of Library Content on page 978.          

To search the Library Browser
 1.  Select View> Library Browser  and click in the Search field at the top of the Library Browser.

 2.  Begin typing a keyword to search for. As you type, the search results will populate in the Directory Pane below.

 l Use Boolean keywords (NOT, AND, OR), capitalized and with spaces, to refine your search. Shortcuts (!, +, |) can 
be used, as well.

 l Boolean keywords' are prioritized from highest to lowest in this order: not, and, or. Parentheses can also be used.

 l Use quotation marks “” to search for an exact word or phrase. Quotation marks around a Boolean keyword will 
treat the keyword as a normal search term.

 3.  You can click the Clear  button on the right side of the Search field to remove anything typed in this field. 

 4.  If you move your mouse pointer over the Search field, a Tool Tip will state the number of results of your search.

 5.  Right-click on an item in the Search Results list and select Show in Browser to view the item’s location in the 
Directory list.

You can also search the contents of one or more specific catalogs and/or folders. Right-click on a catalog or folder level 
item or group-select multiple catalogs and/or folders and right-click on them, select Search Folder from the contextual 
menu, and proceed with step 2, above. See Shift and Ctrl Select on page 217. 

Substrings are not included. For example, searching for “windows” will not produce “window” as a search result. On the 
other hand, searching for “window” will produce “windows” as a search result.

To search using custom filters
 1.  Click the Search Filtering Options  button. 

 l Check Keyword to match the entered search keyword with an object’s search attributes. 

 l Check Entire Word to match the entire keyword or words with the complete name of the object. 

 l Check Folders to include library folders in your search.
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 l Check Include Filtered to include all library catalogs not currently displaying in the tree list in your search. See 
Filtering the Display of Library Content on page 978.          

 2.  Click the arrow beside Type, Style, or Manufacturer to expand that category. 

 l Check Keyword to match the entered search keyword with an object’s search attributes. 

 l Check Entire Word to match the entire keyword or words with the complete name of the object. 

 l Check Folders to include library folders in your search.

 l Check Include Filtered to include all library catalogs not currently displaying in the tree list in your search. See 
Filtering the Display of Library Content on page 978.          

 3.  Click the arrow beside Type, Style, or Manufacturer to expand that category. 

 l Check the box beside one or more Type of library item that you want to include in your search. 

 l Check the box beside one or more architectural or design Style to include items of that style in your search. 

 l Check the box beside one or more Manufacturer to include in your search. Manufacturer catalogs that were 
imported during the current program session will not be listed here until you exit out of and restart Chief Architect.

To save time, check the box beside Type, Style, or 
Manufacturer to select all of the options in that category at 

once; uncheck the box to deselect all of the options.

 4.  Type a keyword in the Search field. The results will be filtered to match your selected filtering options. 

SEARCHING FILTERED CONTENT

When Include Filtered is checked, any items in your search results that are currently filtered out of the tree list cannot be 
shown in the browser. If you right-click on such an item and select Show in Browser, a warning message will display.           

SEARCH ATTRIBUTES

Objects in the library all have one or more search attributes, which are keywords and architectural styles that can be used to 
find them in a library search. The Search Attributes dialog lists these attributes for each library object. See Search Attributes 
on page 988.          

 

Find in Library
You can find out whether a selected object is saved in the library and if so, where, using the Find Original in 
Library edit tool. 

The Find Original in Library edit tool also allows you to locate any objects inserted  into the selected object as well as any 
materials or moldings assigned to it. See Inserted Objects on page 981.

In addition, this tool provides a means of adding your choice of the object and/or any inserted and assigned objects to the 
library. See Add to Library As on page 974.           

FIND IN LIBRARY DIALOG

The Find in Library dialog opens when you select one or more objects and click the Find Original in Library  edit 

button This dialog lists all of the selected objects as well as all objects assigned to and inserted into them. 
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Highlighted line items are categories that may have multiple components beneath them. 

 l Check the box beside a line item to find that object in the library.
 l Check the box beside a category heading to select all items in that category.

When you click OK, the dialog will close and one of three things will happen:

 l If a single line item was selected in the Find in Library dialog was clicked, that item will be selected in the tree list of 
the Library Browser. 

 l If the single line item is not found in the library, a message box will inform you of this and give you the option of 
adding it to the library.

 l If multiple line items were selected, the Show in Library Results dialog will open, summarizing the status of each.

SHOW IN LIBRARY RESULTS

If multiple line items are selected in the Find in Library dialog, the Show in Library Results dialog will report where, or if, 
they are found in the library.

Each line item selected in the Find in Library dialog is listed here.

 l Click on a line item to select it. Multiple lines can also be selected. See Shift and Ctrl Select on page 217.
 l Click the Show in Library button to locate and select the selected line item in the tree list of the Library Browser. Not 

available if the selected item is “Not Found in Library Browser”, or if multiple line items are selected.
 l Click the Add to Library button to add the selected line item(s) to the User Catalog in the library. See Add to Library 

As on page 974. 
 l Click the Done button to close the dialog.

 

Library Content
The Chief Architect Premier library has five categories: Chief Architect Core Catalogs, Chief Architect Bonus Catalogs, 
Manufacturer Catalogs, User Catalog and Trash. 

CHIEF ARCHITECT CORE CATALOGS

The Chief Architect Core Catalogs category contains a wide selection of 3D symbols, images, CAD objects, and materials. 
If you install the program from USB drive, this library content will also be installed; if you download the software, you will 
be able to download the Core Catalogs separately, after the program is installed. 

When you launch the program for the first time, it will ask if you want to download the Core Catalogs. Click Yes to begin 
the download. If you click No, you can download at any time by selecting Library> Install Core Content from the menu. 

CHIEF ARCHITECT BONUS CATALOGS

Chief Architect regularly posts new library catalogs available for download. Select  Library> Get Additional Content 
Online  from the menu to access the bonus catalogs and content. 

Most Bonus Catalogs can be purchased for a nominal fee, while others are available free of charge. In addition, some Bonus 
Catalogs are only available to Chief Architect Support and Software Assurance program members. For more information, 
visit  chiefarchitect.com. 
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MANUFACTURER CATALOGS

A variety of name brand library catalogs is available for download on the Chief Architect website with content ranging from 
materials to fixtures to CAD blocks.         

Select Library> Get Additional Content Online  to access these Manufacturer Catalogs.          

As with the Bonus Catalogs, some Manufacturer Catalogs are available free of charge while others can be purchased, and 
some are available for Support and Software Assurance members only.          

THE USER CATALOG

The User Catalog is the location for items that you add to the library either from a drawing or by importing. See Adding 
Library Content on page 973. 

You can create and organize custom library folders and imported items such as symbols, images, backdrops, CAD blocks, 
line styles, and materials. See Organizing the Library on page 975.

COPY ITEM LIST

Copy Item List is available in the contextual menu when a library category or folder is selected in the Library Browser 
Directory Pane. Select this option to copy a list of all objects in the selected library item to the system clipboard. You can 
then paste this list into a text application such as Notepad. See To Copy, Cut and Paste text on page 523.          

UPDATING LIBRARY CATALOGS

The Chief Architect Core Catalogs, Bonus Catalogs, and Manufacturer Catalogs are updated periodically to include 
new and improved content. You can update your installed catalogs to include the latest content by selecting Library> 

Update Library Catalogs at any time. 

The program will gather information about the content in each of these three categories, and then download and replace any 
content that is not up-to-date, and you may see a progress indicator at the bottom of the Library Browser while it is doing 
so. See Download Progress on page 971.

LIBRARY CONTENT LOCATION

All library content aside from your User Catalog is stored in the System Library Database Folder. By default, this folder 
is created in the directory intended for shared application data in your operating system (C:\ProgramData in Windows; 
/Library/Application Support in macOS). 

The Chief Architect User Catalog File, User_Library.calib, is saved in the User Library Folder, which is located in the 
Chief Architect Premier X14 Data folder by default. See Chief Architect Premier Data on page 37.

You can specify a different location for both if you wish in the Preferences dialog. If you choose a removable drive or 
network location, library slowness may result. See Folders Panel on page 111.

If you choose to use a different location for your User Catalog, your existing User Library content as well as your 
Backdrops, Images, Patterns, and Textures folders will be moved there, as well. It is important that you specify a directory 
on a hard drive with sufficient space to hold these files.

Library catalogs are not designed to be shared between program 
titles or versions. Items designed for use in Chief Architect 

Premier X14 are not compatible with earlier program versions.
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BACKING UP CUSTOM CONTENT

The best way to back up your custom library content is to export the items in your User Catalog, as this will ensure that the 
textures used by custom materials or imported symbols are not lost. See Backing Up Your Files on page 42. 

Exported libraries use the .calibz file format: a zipped file type that can include textures and images along with other library 
data.

To back up your custom library content
 1.  Launch Chief Architect and open a plan file.

 2.  If the Library Browser is not open, select View> Library Browser  from the menu.

 3.  Right-click on a folder or item in the User Catalog. 

 4.  Select Export Library from the contextual menu.

 5.  The Export Library Data dialog is a typical Save dialog. See Exporting Files on page 41.

 l Notice that the file type in the Save as type field is “Library File with Textures/Images (*.calibz)”.

 

Downloading Library Content
The Chief Architect Core Catalogs, Chief Architect Bonus Catalogs, Manufacturer Catalogs are all available for internet 
download.         

CORE CATALOGS

When you launch Chief Architect for the first time, you will be asked if you want to download the Core Catalogs. Click Yes 
to begin the download. 

If you click No, you can download at any time by selecting Library> Install Core Content from the menu. 

BONUS AND MANUFACTURER CATALOGS

Bonus  and Manufacturer Catalogs can be downloaded from our website,  www.chiefarchitect.com. Select Library> 
Get Additional Content Online to launch your default internet browser to our Content Resources page.   

DOWNLOAD PROGRESS

When library content is downloading, a green progress bar will display at the bottom of the Library Browser. If you choose 
to download the Core Catalogs while the library is not open, the Browser will open so the progress indicator can display. 

Click on the progress bar to display the name of the current file being downloaded, the total amount of data to be 
downloaded in KB, and the amount downloaded so far.
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PAUSING AND RESUMING

Library downloads can only take place while Chief Architect is running. If you close the program while a download is in 
progress, a dialog will confirm whether you wish to stop the download.

 l Click Stop Download and Close Program to stop the download and close the program. 
 l Click Cancel to leave the program open and continue downloading. 

Most catalogs are composed of a single file. If you stop the download midway, none of the downloaded data will be 
retained.

The Core Catalogs, on the other hand, contain a large volume of data saved in multiple files. If you close the program and 
stop the Core Catalogs download midway, only data associated with the file currently being downloaded will be lost. You 
can resume the download beginning with that file at a later time by selecting Library> Install Core Content.

DOWNLOAD ERRORS

If any problems occur during the library download process, a dialog box will notify you at the end of the download. Click 
Retry Download to repeat the download and correct any errors or click Cancel to discard the downloaded catalog. 

 

Importing Library Catalogs
Chief Architect library files have two different file extensions: .calib and .calibz. Both files can include any combination of 
Chief Architect library items; in addition, .calibz files are able to save data associated with textures and images. Both file 
types can be imported into the Chief Architect library.

There are several ways to import a .calib or .calibz file into the program library:

 l Double-click on the file in an operating system window while a plan or layout file is open.
 l Drag the file from an operating system window and drop it into the Chief Architect program window. 
 l Select Library> Import Library from the program menu.

Although multiple versions of Chief Architect can be installed on a computer, the operating system will only associate .calib 
and .calibz library files with one version. If they are not associated with Chief Architect Premier X14, click the Associate 
Files with this Program button in the Preferences dialog. See File Management Panel on page 109.          

Note: Library files cannot be imported if no plan or layout file is open, or 
when a Materials List or Ray Trace view window is active. 

To import library files into the library
 1.  Select Library> Import Library to display the Import Library Data dialog.

 2.  Browse to the .calib or .calibz file(s) that you want to import and either single or group-select the files so that their 
names display in the File Name field.

 l To select a group of files, click on the first one, hold down the Shift key, then click on another file. The two files 
plus all files in between are selected.

 l To select multiple files individually, click on one, hold down the Ctrl key, then click on additional files. Only the 
files you click on are selected.
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 l To select all files in the directory, click on one and press Ctrl + A. Only do this if you wish to import all files in 
the folder.

 3.  Click the Open button. 

 4.  A progress bar will display, telling you the progress of each library data file as it is imported. 

 5.  Once imported, each file will be listed in its corresponding library category and will be selected in the Library 
Browser tree list. See Library Content on page 969.

When a .calibz file is imported into the program, any images or textures saved in it will be copied into the Chief Architect 
Premier X14 Data\ Images and Textures folders for backup purposes. The program will only reference these copies if it 
cannot locate the files in their original locations. See Chief Architect Premier Data on page 37. 

LIBRARY CATALOG MIGRATION

If you have library catalogs from Chief Architect Premier X5 through X13 installed on your computer, the initial startup of 
Chief Architect Premier X14 will give you the opportunity to migrate that content into the Version X14 Library.

LEGACY LIBRARY CONVERSION

You can also import     legacy .calib and .calibz files created in Chief Architect X4, X3, or X2  for use in Version X14 at any 
time. See Exporting Library Catalogs on page 979.         

Note: Library content exported from Chief Architect X3 will not include 
catalog names. Any subscribed content from Version X3 that has not 
been downloaded will not be included, either. 

In addition, legacy .alb files created in Chief Architect Versions X1 and 10              and prior can be converted for use in Version 
X14. Conversion of legacy .alb files from Versions 9 and 8 is not supported.         

To convert legacy library files
 1.  Select Library> Convert Legacy (.alb) Library Files.          

 2.  In the Select a Legacy Library File Folder dialog, select              one or more .alb files that you want to bring in to Chief 
Architect X14.         

 3.  The selected files’ names will display in the File name: field.         

 4.  Click the Open button to import these legacy library files into the User Catalog.         

 5.  Organize the imported content to suit your needs. See Organizing the Library on page 975.         

 

Adding Library Content
In addition to downloading Chief Architect Content and importing entire catalogs into the library, you can also add a variety 
of individual objects to the library. 

ADD TO LIBRARY

Nearly any object imported into a plan, converted into a symbol, or placed from the Library Browser can be added to the 
User Catalog in the library. 
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 l Select one or more objects in your plan and click the Add to Library  edit button.

 l Check Add to Library in the Import 3D Symbol dialog. See Importing 3D Symbols on page 1239.         
 l Check Add to Library in the Convert to Symbol dialog. See Convert to Symbol on page 1002.          

A few objects cannot be added to the library: notably imported pictures, metafiles, and PDF files. With the exception of 
closed polylines, which are added to the library as Molding Profiles, CAD objects cannot be added to the library either. 
These objects can be added, though, if they are part of a CAD block. See CAD Blocks on page 333. 

Any object created using a drawing tool in Chief Architect will automatically be added to the User Catalog using the name 
of that tool, whereas a symbol will automatically use the Symbol Name. See Native Objects vs Symbols on page 986. 

If multiple identical objects are selected when the Add to Library button is clicked, only one instance will be added to the 
User Catalog.

Once added to the library, objects in the User Catalog can be renamed and edited. See Renaming Library Items on page 976. 

ADD TO LIBRARY AS

Some objects have library items assigned to or inserted into them. Cabinets, for example, have door panels inserted 
into them and materials assigned to them. You can choose to add the containing object to the library, the inserted or 

assigned items, or any combination of the two using the Add to Library As edit tool. See Placing Library Objects on page 
980.           

To use Add to Library As
 1.  Select an object that has another item inserted into it and click the Add to Library As  edit button.          

 2.  In the Add to Library As dialog, check the box beside each line item that you would like to add to the User Catalog.          

 l The top line item is the selected object while those that follow are components of that object.          
 l Highlighted items are categories that may have multiple components beneath them. Check the box beside a category to 

add all of its components to the library.           
 l The line items under each category are components which can be added to the library by checking their boxes 

individually.           
 l Check Save Objects in Subfolders to create a new folder in the User Catalog in which the selected line items are 

saved. If the line items are associated with multiple parent objects, a folder is created for each parent and placed in an 
“Exported Objects” folder in the User Catalog.           
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USING THE CONTEXTUAL MENU

A variety of new content can be added to the User Catalog by right-clicking on it or on a folder within it and selecting 
New> from the contextual menu: 

 l Backdrops - See 3D Backdrops on page 1201.         
 l Fill Styles - See Fill Styles on page 197.         
 l Style Palettes - See Style Palettes on page 284.          
 l Images - See Images on page 1181.         
 l Line Styles - See Line Style Specification Dialog on page 202.          
 l Materials - See Creating Materials on page 1060.
 l Plant Image - See Plant Image Specification Dialog on page 1303.
 l 3D Symbols - See Importing 3D Symbols on page 1239.

See also Using the Contextual Menus on page 965 and Adding New Folders on page 975.         

CREATING A CUSTOMIZED LIBRARY ITEM

You can customize an existing library item and save your changes for future use by first copying the item into the User 
Catalog.         

To customize a library object
 1.  Right-click on a library item and select Copy to User Catalog from the contextual menu.

 2.  If the library item is already located in the User Catalog, instead select Duplicate from the contextual menu.

 3.  Right-click on the copied item and select Open Object  from the menu.             

 4.  The item’s specification dialog opens, and you can make any changes that you wish to the item.             

 5.  Make any needed changes to the item, then click OK. Your changes will be saved with this item for use in any plan.             

 

Organizing the Library
Library folders and objects can be copied, pasted, moved, and deleted: allowing you to organize your User Catalog to best 
suit your work style and needs. 

ADDING NEW FOLDERS

New folders can be added to the User Catalog or to any folder located within it. To add a new folder, right-click on User 
Catalog or one of its sub-folders and select New> Folder from the contextual menu. 

The new folder is created inside the library item you right-clicked on and is initially named “Untitled”. Type a short, 
descriptive name and press Enter. 
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SELECTING LIBRARY ITEMS

To select a library object, folder, or category, simply click on it. You can also multiple-select library items:

 l To select a group of items, click on the first one, hold down the Shift key, then click on another file. The two files plus 
all files in between are selected.              

 l To select multiple items individually, click on one, hold down the Ctrl key, then click on additional files. Only the 
files you click on are selected.              

When an item is selected, preview images display in the Selection and Preview Panes and basic information about it also 
displays in the program’s Status Bar. See The Status Bar on page 25. 

A selected library item can be modified in a number of ways to help meet your organizational needs. When multiple items 
are selected, these options may be limited depending on the specific selection set. 

RENAMING LIBRARY ITEMS

Only folders and objects in the User Catalog can be renamed. There are several ways to do this from the tree list: 

 l Right-click on the item, select Rename from the contextual menu, and type a new name. 
 l Click once on the item, press F2 on your keyboard and type a new name.
 l Click once on the item, pause for a moment, then click a second time and type a new name.

Library names are case-sensitive and can contain up to 63 characters. While you can have more than one library item that 
uses the same name, it is best to use short, descriptive and unique names.

MOVING LIBRARY ITEMS

Folders and objects in the User Catalog can be moved to new locations within the User Catalog. Folders and library objects 
are always organized alphabetically within each hierarchy.

To move one or more items to a different location, select it in the tree list, then click and drag it to the new location in the 
list. Directories and folders able to accept new content highlight as your mouse pointer moves over them. Release the mouse 
button to relocate the selected library item in the highlighted location.

You can also cut one or more library items from one location and paste them in another. When an item is cut, it is removed 
from its current location and saved to the system clipboard. To cut an item:

 l Right-click on it and select Cut from the contextual menu. 
 l Click on the library item and press Ctrl + X on your keyboard.

To Paste the item, click on a library catalog or folder in the Library Browser tree view and either:
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 l Right-click on the new location and select Paste from the contextual menu.
 l Press Ctrl + V on your keyboard. 

COPYING LIBRARY ITEMS

All library folders and library objects can be copied and pasted to new locations in the User Catalog. 

There are two ways to copy one or more library items to the system clipboard: 

 l Right-click on it and select Copy from the contextual menu. 
 l Click on the library item and press Ctrl + C on your keyboard.

To Paste the item, click on a library catalog or folder in the Library Browser tree view and either:

 l Right-click on the new location and select Paste from the contextual menu.
 l Press Ctrl + V on your keyboard.

When a library item is copied and pasted, the new item that results is independent of the original item. If you make changes 
to it, the original item is unaffected. Similarly, changes to the original item do not affect the copy.

LIBRARY SHORTCUTS

In addition to copying and pasting to create new, independent library items, you can copy and paste to create Library 
Shortcuts. Library Shortcuts are not independent items - they are linked to the original item and are affected if changes are 
made to the original.

Library Shortcuts are advantageous because you can place a given library item in multiple locations to suit your 
organizational style without increasing the size of the library database and without having to maintain multiple copies of the 
same item.

To create a Library Shortcut, copy a library item to the system clipboard. Then, right-click on the location where you would 
like to create a copy and select Paste Shortcut from the contextual menu. Library Shortcuts use the same name as their 
source item but use the Library Shortcut   icon.

To locate a Library Shortcut’s source item, right-click on it in the tree list and select Locate Shortcut Source. 

If you move or delete an item from the library, any shortcuts to it will not be updated or removed. If you try to use a 
“hanging” shortcut, a message about its status will display in the library preview panes.

DELETING LIBRARY ITEMS

The five installed library categories: Chief Architect Core Catalogs, Chief Architect Bonus Catalogs, Manufacturer 
Catalogs, User Catalog, and Trash cannot be deleted. 

Catalog level folders in all categories can be deleted; however, individual subfolders and objects can only be deleted out of 
the User Catalog.

Items in the library that are eligible for deletion can be deleted in either of two ways: 

 l Right-click on it and choose Delete from the contextual menu.
 l Select it and press the Delete key on your keyboard.

When items from the User Catalog are deleted, they are moved to the Library Browser Trash  . Items in the Trash can be 
retrieved by clicking and dragging them into any location in the User Catalog.

To empty the Trash, right-click on it and select Empty Trash from the contextual menu. 
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Depending on how much content is in the Trash, emptying it can be time consuming. You can click the Cancel button to 
end the process if you wish. 

The Empty Trash command is both immediate and permanent. It 
cannot be undone, so use care when using it. You should back 

up all your library files regularly. See Backing up Custom Content on 
page 971. 

 

Filtering the Display of Library Content
Depending on how much library content you have imported or customized, the tree list in the Directory Pane can be 
very large. You can control what content displays in the list using Library Filters.          

Library Filters do not remove content from the library database. They do, however, affect the library Search: unless you 
check Include Filtered in the advanced Search options, library content that is not displaying is not included in your 
searches.           

You can also set up filters for your library Search results, but these two types of filters are unrelated. See To search using 
custom filters on page 967.           

Library filters can be created, edited, and deleted in the Manage Library Filters dialog. Click the Manage Library Filters 
 button at the top of  the Library Browser to open this dialog or select Library> Manage Library Filters  from the 

menu.          

You can also add the Manage Library Filters button to your 
toolbars and assign a hotkey to it. See Toolbars and Hotkeys on 

page 133. 

Any filters that you create will be in the Active Filter drop-down list at the top of the Library Browser. Select a filter from 
the list to display content in the library tree list according to its settings. See The Library Browser on page 962.           

MANAGE LIBRARY FILTERS DIALOG
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Filters

A list of available library filters displays here. Click on a name in the list to select it. The Selected Filter is highlighted and 
can be edited using the options to the right.         

 
New / Delete

Click the New button to create a new filter or click the Delete button to remove the Selected Filter from the list.         

 
Active Filter

Select the Active Filter from the drop-down list. This is the filter in use in the Library Browser when the Manage Library 
Filters dialog is closed.          

 
Selected Filter

Specify the Name of the Selected Filter.          

 
Catalogs

A list of all Chief Architect Core, Chief Architect Bonus and Manufacturer Catalogs installed in your library display 
here.         

 l Check the box beside a library catalog’s name to prevent it from displaying in the Library Browser Directory Pane 
tree list.           

 l Click the Select All button below either list to prevent all catalogs in that list from displaying in the Directory Pane 
tree list.           

 l Click the Clear All button below either list to include all catalogs in that list in the Directory Pane tree list.           

 

Exporting Library Catalogs
Exporting library files allows you to: 

 l Back up your custom library content.
 l Transfer library content between computers.
 l Share custom library content with colleagues.          

Exporting is often preferable to simply copying library files because it allows you to include images and textures in the 
exported library. 

To export content from the library
 1.  Locate an object, folder, or catalog that you want to export, right click on it, and select Export Library.

 2.  In the Export Library Data dialog:

 l Choose the appropriate Save in: location for your exported library file.

 l Type a short, descriptive name for your library file in the File Name field.

 l Click the Save as type: drop-down list and select whether or not you want the library to include Textures/Images.

If any of the items being exported are images or use textures, 
be sure to select the .calibz file type.
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 l Click Save.

 3.  Your exported library file can now be copied to a network location or storage device in an operating system window. 

Any Shortcuts   present in a catalog will be converted to regular library objects when exported. See Library Shortcuts on 
page 977.

 

Placing Library Objects
Library objects are subject to placement restrictions based upon typical real-life placement. Most library objects require 
sufficient free space at the location where they are placed, for example, and some library objects have additional 
requirements. Library windows and doors, for example, must be placed in a wall just like standard windows and doors, and 
some fixtures are designed to be placed in cabinets.

Library symbols have placement restrictions that are determined when the symbol is created but can be changed later. See 
Native Objects vs Symbols on page 986 and Symbol Specification Dialog on page 993.         

There are three main categories of items available in the Library Browser:

 l Stand-alone objects that can be placed directly into a plan. Examples include cabinet modules, furnishings and images.
 l 3D objects designed to be inserted into another 3D object. Examples include cabinet fixtures, windows and doors. 

Some items, such as cabinet doors, railing balusters, and fence panels, can be inserted into another object or placed as 
stand-alone objects. 

 l Materials, line styles, fill styles, and molding profiles, which cannot stand alone and must be assigned or applied to 
another object.

If a warning message displays when placing a library object or symbol, it will indicate where the object can be placed. 

STAND-ALONE OBJECTS

Most library categories contain objects that can be selected in the Library Browser and placed directly in a 2D or 3D view. 

 l Most stand-alone objects are designed to rest on the floor or terrain.
 l Some objects will rest on top of a cabinet, shelf, furniture or roof plane object if one is located at the point where they 

are first placed.
 l A few objects, notably some light fixtures, will mount on the bottom of a wall cabinet or on the ceiling.
 l In addition, some objects will attach to a wall if one is nearby. 

To place a stand-alone library object
 1.  Click on an object in the tree view or Selection Pane of the Library Browser to select it for placement. See The 

Library Browser on page 962. 

 2.  Move your mouse pointer into the view area and notice that it displays an icon indicating the type of object selected 
instead of an arrow.

 3.  Click to place the selected object at that location. 

 4.  Continue clicking to place as many instances of the selected object as needed. When you are finished, click the 
Select Objects  button. 

Once a stand-alone object has been placed, it can be edited in a variety of ways. See Editing Library Objects on page 986.
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INSERTED OBJECTS

Some objects cannot stand alone and must be placed into other objects in a plan. For example, doors and windows must be 
inserted into a wall, while some appliances and plumbing fixtures are designed be placed inside a base cabinet. See Doors 
on page 551, Windows on page 584 and Cabinets on page 628.

With the exceptions of doors, windows, and skylights, an inserted library object can only display in a 2D or 3D view if the 
object that contains it is set to display. This is the case even if the inserted object’s layer is turned on. See Displaying 
Library Objects on page 985. 

To insert a library object
 1.  Click on an item in the tree view or Selection Pane of the Library Browser to select it for placement. See The 

Library Browser on page 962. 

 2.  Move your pointer into the drawing area.

 3.  Click on the object into which you wish to insert the selected library item. If the selected library item is designed to 
be inserted into that type of object, it will be placed into it.

 4.  Continue clicking on other objects to place as many instances of the selected item as needed. When you are finished, 
click the Select Objects  button.

When an object has been inserted into another object, it can be replaced directly from the library. See Replace From Library 
on page 983.

If you try to insert an object into another object that is on a locked layer, nothing will be created. See Object Creation and 
Layers on page 171.          

ASSIGNED ITEMS

Some library items, such as line styles, fill styles, materials and moldings, are not objects in themselves but can be applied 
to objects in a variety of ways.

 l Using the specification dialog of the containing object. See Select Library Object Dialog on page 982.
 l By selecting the item in the library and then clicking on the containing object.             
 l Fill styles, materials and moldings can be assigned to objects directly from the library in 3D views by selecting the 

library item and then clicking on an object.  See Eyedropper and Painter Tools on page 281 and Replace From Library 
on page 983.

 l An entire collection of properties can be applied to multiple objects by selecting a Style Palette in the library and then 
clicking on an eligible object. See Style Palettes on page 284.           

 l Moldings and line styles can also be added to a plan by selecting the desired library item, then clicking and dragging a 
line in the drawing area. The result is either a Molding Line or CAD Line, depending on the selected library item. See 
Molding Polylines on page 951 and  Line Styles on page 200.         

PLACE LIBRARY OBJECT BUTTON

The Place Library Object button can be added to your toolbar and used for quick access and placement of 
frequently used library items. See Place Library Object Button on page 982.         

Once a library object has been assigned, click the button and then click in a view to place or apply the assigned item.          
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Select Library Object Dialog
The Select Library Object dialog is a modal version of the Library Browser that is accessible from many object specification 
dialogs. See Specification Dialogs on page 21. 

This dialog also opens when you select the Fill Style Painter  tool. See Painter Tools on page 282.         

The Select Library Object dialog only displays categories of items that are related to the object component being edited. For 
example, if this dialog is accessed from the DOOR/DRAWER panel of the Cabinet Specification dialog, only cabinet door and 
drawer symbols will be listed. If it is accessed from the Moldings panel, only moldings will be listed.

The Select Library Object dialog is similar to the LIBRARY MATERIALS panel of the Select Material dialog. See Select 
Material/Library Object Dialog on page 1057.

 

Place Library Object Button
The Place Library Object button can be added to your toolbar and used for quick access and placement of 
frequently used library items.         

If the Place Library Object button has not yet been assigned a library object, click it once to open the Library Object 
Button Specification dialog.          

Double-click a Place Library Object button that has been assigned a library object to open the Library Object Button 
Specification dialog.         
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Library Object

Click the Library button to open the Select Library Object dialog and assign a library object to the button. If a library 
object has already been assigned, click this button to assign a new library object. See Select Library Object Dialog on page 
982.          

 
Button Name

When a library object has been selected, type a Button Name in the text field.         

 
Button Icon Choices

When a library object has been selected, assign a Button Icon. Choose from two automatically generated button icons or 
click Browse to browse your computer for a different icon.         

Up to 100 Place Library Object buttons can be added to the same toolbar, each assigned a different object.         

The library object assigned to the Place Library Object button is actually saved with that particular button. If you move or 
delete the library item from the library, the button will continue to function.         

 

Replace From Library
There are two different ways to replace an object in a plan with another object from the library.          

An inserted object or a molding profile can be replaced by a different item from the library with a single click. This 
approach is particularly effective in 3D views, where the results can immediately be seen. See Inserted Objects on page 981.

To replace an inserted object
 1.  Open the Library Browser, browse to an object of a type similar to the one you wish to replace, and click on it to 

select it. 

 2.  Select a Replace from Library Scoping Mode from the Edit Toolbar:

 l Component Mode  is the default mode and applies the selected material to a single component on the target 

object. Most object types have a list of components in their specification dialog, on the MATERIALS panel. See 
Materials Panel on page 1055.

 l Object Mode  replaces all instances of a material on the target object. 
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 l Room Mode  replaces all instances of a material in the room where the target object is located. 

 l Floor Mode  replaces all instances of a material on the floor where the target object is located. 

 l Plan Mode  replaces all instances of a material in the entire plan. 

 l Toggle Library Replacement Mode  allows you to place a free-standing object instead of replacing anything.

 3.  Move the mouse pointer into the view window. The Replace from Library   icon will display near the mouse 
pointer when it passes over an object that can be replaced by the selection from the library.

 4.  Click once to replace the object in the plan as well as to any other identical objects, depending on which Painter 
Scoping Mode is active, with the selected object from the library. 

Some types of inserted objects - notably, plants assigned to Garden Beds, cabinet doors and drawers, and doors - can also be 
replaced in this manner in plan view provided that the Alternate Edit Behavior is not active. The Replace from Library   
icon does not display in plan view, however.

In the Windows version of the program, you can temporarily 
override this replacement behavior in plan view by holding down 

the Alt key. A free-standing object will be created if there is space for it 
instead of an inserted object being replaced.

The Replace From Library edit button is available for nearly any stand-alone object that can be added to the library 
and can be used in 2D and 3D views. Click this button to open the Replace From Library dialog and replace the 

selected object, and others like it if you choose, with an object of the same type from the library.         

  Replacement Options

 l Replace Selected Object replaces only the currently selected object.    

 l Replace Identical Objects in Room replaces all objects that are in the same room as, and are identical to, the 
currently selected object. Not available for doors or windows.    

 l Replace Identical Objects on Floor replaces all objects that are on the same floor as, and are identical to, the 
currently selected object.     

 
Replace With

Click the Library button to open the Select Library Object dialog and select an object to use as a replacement. The name of 
the object that is currently selected as a replacement displays above.             

Replace From Library               cannot be used to replace a selected wall or a selected cabinet with a cabinet of a larger size. In 

addition, it is not available for backdrops and items assigned to other objects, such as materials. 
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If the Replace from Library edit tool is used to replace an 
electrical object, any Connect Electrical splines attached to it 

will be deleted. See Connect Electrical on page 682.

 

Displaying Library Objects
The display options available for library objects depend on the type of object in question, as well as the view.

If the display of an object is turned off in a 2D or 3D view, any objects inserted into it will not display in that view, either - 
even if the inserted object’s layer is turned on. The exception to this rule is doors and windows, which can display in 3D 
views when their containing wall does not. See Inserted Objects on page 981. 

IN PLAN VIEW

All library objects except materials, doors and drawers applied to cabinets, and backdrops can display in plan view. Library 
objects are represented in plan view by 2D CAD Blocks that resemble the size and shape of the object when viewed from 
above. The CAD Block representing a symbol object can be specified in the Symbol Specification dialog. See 2D Block 
Panel on page 996.

As with other architectural objects, the display of library objects is controlled by layer in the Layer Display Options dialog. 
Each library category has its own layer.  See Layer Display Options Dialog on page 183.

Like other objects, each library symbol is  placed in a Drawing Group that affects whether it displays in front of or behind 
other objects. You can modify a selected symbol’s place in the drawing order by clicking the View Drawing Group Edit 
Tools  edit button. See Drawing Group Edit Tools on page 195. 

OBJECT LABELS

Free-standing library objects, including Architectural Blocks, can display labels in plan and cross section/elevation views 
when the appropriate layer is set to display in the Layer Display Options dialog. Fixture labels, for example, are located on 
the “Fixtures, Labels” layer. See Label Panel on page 712.

Object labels have their own edit handles and can be moved and rotated when the object is selected. Library object labels 
use the Text Style assigned to their layer. See Text Styles on page 547.         

You can specify a custom label for many library objects in its specification dialog. See Symbol Object Specification Dialogs 
on page 989.         

IN 3D VIEWS

All library objects except CAD Blocks, Fill Patterns, and Line Styles can display in 3D views. 

By default, images rotate to face the camera in 3D views. For information about turning off image rotation, see Image 
Specification Dialog on page 1184.

Doors, windows and cabinets from the library may also display opening indicators in Vector Views when the “Opening 
Indicators” layer is turned on. See Layer Attributes on page 181.         

IN THE MATERIALS LIST

Most library objects are counted in the Materials List, as is any information added on the Components panel of their 
specification dialog. See Components Panel on page 1335.          

985



Chief Architect Premier X14 Reference Manual - Editing Library Objects

Note: Although the size and materials of many library objects can be 
edited, these changes are not reflected in the Materials List. See 
Materials Lists on page 1309.

IN SCHEDULES

A variety of different library symbols can be included in schedules. In addition, a number of the Schedule Tools are 
designed to list specific types of library symbols: including fixtures and electrical objects. See The Schedule Tools on page 
695.

 

Editing Library Objects
The Core, Manufacturer, and Bonus Catalogs and the objects within them cannot be edited. Library objects can, however, be 
customized to suit your design needs. There are three approaches to doing so:         

 l Select an object in the User Catalog, edit it using any of the options in its contextual menu, and your changes will be 
reflected when you next place this library object in a drawing. See Using the Contextual Menus on page 965. 

 l Place an object in a drawing and then edit it using the various edit tools available for it. This will not affect the 
original object still saved in the library.         

 l Place an object in a drawing, edit it using the available edit tools, and then add it back to the library for future use. 
This will not replace the original object still saved in the library. See Add to Library on page 973.         

To customize an object in the Core, Manufacturer, or Bonus 
Catalog, right-click on it and select Copy to User Catalog from 

the contextual menu. 

Stand-alone library symbols placed in a plan can be selected individually or as a group, like other objects in Chief Architect. 
To select a symbol object inserted into the top of a cabinet, select that cabinet and click the Select Next Object  edit 

button. See Selecting Objects on page 212. 

Once selected, a library object can be edited in a variety of ways using dimensions, the edit handles, the Edit Toolbar 
buttons and its specification dialog. See Symbol Object Specification Dialogs on page 989. 

NATIVE OBJECTS VS SYMBOLS

In Chief Architect, objects created using the program’s standard tools, such as the Door Tools  and Cabinet Tools , 

are referred to as native objects. 

On the other hand, objects placed from the library, such as fixtures and furnishings, are symbols. Symbols are typically 
more limited than native objects in how they can be edited.

In addition to the symbols available in the library, you can import additional symbols into the program from 3D .dxf, .dwg,
 .obj, .3ds, .skp, or .dae files. See Importing 3D Symbols on page 1239.

Any changes made to objects like fixtures and furniture will not be reflected in their Materials List Description, although 
they may be seen in other columns, such as Size. See Materials Lists on page 1309. 

You can change a symbol’s name, which is used in its Materials List Description, in the Symbol Specification dialog. You 
can also change the names of its components. See 3D Panel on page 993 and Materials Panel on page 1055.         
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USING EDIT HANDLES

Most free-standing library symbols are box-based objects and can be edited as such once placed in a drawing. See Editing 
Box-Based Objects on page 234. Depending on the type of view and the surface selected, the edit handles a symbol displays 
will vary. 

When a typical symbol is selected in plan view or on the top surface in a 3D view, up to ten edit handles display. They are 
the Move handle at the center, the Rotate handle just outside the front indicator (a V) and a Resize handle on each edge and 
at each corner. If the selected symbol object has a Stretch Plane defined and you resize it using its edit handles in plan view, 
the program will give you an opportunity to generate a new 2D CAD Block for it. See Stretch Planes and Zones on page 
1005.

When a symbol is selected on a side in a cross section/elevation or 3D view, it displays six edit handles: the Move handle, a 
Rotate handle, and a Resize handle on each edge. See Selected Side on page 215 and Rotating Symbols on page 1007.

When a free-standing symbol is selected on its side and rotated, you will be prompted to choose whether to update its plan 
view symbol to reflect its new orientation, as viewed from above. See In Plan View on page 985. 

Symbols cannot be concentrically resized, even when the Concentric  edit behavior is enabled. See Defaults, 

Preferences, and Edit Behaviors on page 208.         

The labels of library objects, when displayed, have a separate Move edit handle that displays when the object is selected. 
See Label Panel on page 712.         

Fixtures and furniture placed in a plan are subject to bumping/pushing behavior when moved. See Bumping/Pushing on 
page 246.

USING THE EDIT TOOLS

A selected library object placed in a plan will have a variety of edit tools available. See The Edit Toolbar on page 135.

In addition, items saved in the User Catalog can be edited. If you right-click on a line item in the Library Browser Directory 
Pane, one or more edit tools may be available in the contextual menu:

  Right-click on the name of an individual symbol, Text or Rich Text object, Callout, Marker, Note, Elevation 
Point, image, or plant image and select Open Object to open that item's specification dialog. See Specification 

Dialogs on page 21.
  Right-click on the name of an individual symbol and select Open Symbol to open that item's Symbol 
Specification dialog. See Symbol Specification Dialog on page 993.

  Right-click on the name of a CAD block and select Edit CAD Block to open a CAD Block Window where that 
block can be edited. See Edit CAD Block on page 334.

Individual or multiple group-selected materials can be edited by right-clicking and selecting Open Object as well. See 
Define Material Dialog on page 1066.          

EDITING BUILT-IN FIXTURES AND APPLIANCES

A fixture inserted into the top of a cabinet can be selected by clicking on it, then clicking the Select Next Object  edit 

tool. See Select Next Object on page 215. 

In addition, items saved in the User Catalog can be edited. If you right-click on a line item in the Library Browser Directory 
Pane, one or more edit tools may be available in the contextual menu:
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  Select Open Object to open that item's specification dialog. See Symbol Object Specification Dialogs on page 
989.

  Select Open Symbol to open that item's Symbol Specification dialog. See Symbol Specification Dialog on page 
993.

A fixture installed into the front of a cabinet becomes a cabinet face item, like a door or drawer. It can be resized or deleted 
like other face items in the Cabinet Specification dialog. See Front/Sides/Back Panel on page 658. 

COMPONENTS

Many architectural objects have a COMPONENTS panel in their specification dialog that lets you control how that object 
displays in the Materials List. See Components Panel on page 1335.           

Changes made to the components of an object saved in the library do not affect instances of that object already placed in a 
plan: they are only applied to instances of the object placed in the future.           

Terrain objects, CAD blocks, moldings, images, backdrops, and materials do not display in the Materials List.          

SEARCH ATTRIBUTES

The Search Attributes dialog lists the keywords and styles associated with a selected library object. Keywords and styles can 
be used to locate the object when performing a library search. See The Library Browser on page 962.          

To open the Search Attributes dialog, right-click on an item in the User Catalog and select Search Attributes from the 
contextual menu. See Using the Contextual Menus on page 965.

 
Keywords

Any searchable keywords associated with the object display in the list. Click in the list box and type in any additional 
keywords that you would like to use. Each keyword should be on its own line in the list.         

 
Styles

Check the box beside any architectural or design styles that you want to associate with the object.         
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Symbol Object Specification Dialogs
The Fixture, Furniture, Geometric Shape, Hardware, Millwork Sprinkler, and Plant Specification dialogs all feature 
many of the same options. The actual name of the dialog is determined by the type of object that is currently selected. 

For example, selecting a library object placed from the Interiors library catalog and clicking the Open Object edit button 
opens the Furniture Specification dialog.

The settings in the Hardware Size/Orientation dialog for cabinet hardware are also found  on the GENERAL panel of this 
dialog. See Cabinet Hardware on page 648.

In addition:

 l You can open the specification dialog for a fixture inserted into a cabinet front from within that cabinet's specification 
dialog. See Front/Sides/Back Panel on page 658.

 l You can also open the specification dialog for the fixture(s), furniture(s), or plant(s) associated with a schedule row. 
See Open Row Object(s) on page 699.          

Many library symbol objects can also be edited in the Symbol Specification dialog. See Symbol Specification Dialog on 
page 993.          

GENERAL PANEL

 
Name

The Name of the selected symbol object displays here.
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  Size/Position

 l Specify the Width, Height, and Depth of the object.                         

Note: Some very thin custom symbols may have a Width, 
Height, or Depth value of 0. In these cases, the 0 value cannot be 
edited. 

 l Check Retain Aspect Ratio to maintain the ratio between the object’s Height, Width, and Depth when it is resized 
in the specification dialog. Does not affect the behavior of the object’s edit handles. 

 l Click Reset Size to reset the symbol’s original, unmodified size. The symbol’s elevation is not affected by this 
option.

 l Select the Elevation Reference from the drop-down list. This determines where the next two settings are measured 
from and also affects their setting labels. Not available in the Hardware Size/Orientation dialog.

 l Specify the height to Top, measured from the selected Elevation Reference to the top of the object.

 l Specify the height to Bottom, measured from the selected Elevation Reference to the bottom of the object.

 
Sprinkler Settings

The Sprinkler Settings are only available if the selected object is a sprinkler. See Sprinkler Tools on page 1307. 

 l Specify the Spray Angle, which is the angle within which the sprinkler sprays. An angle of 360° forms a complete 
circle.

 l Specify the Spray Radius, which is the distance from the sprinkler head that the spray reaches. 

 
Options

Check Reverse Symbol to reverse the object’s appearance, so that features on its left are positioned on its right, and vice 
versa. This turns a right-hand refrigerator, for example, into a left-hand refrigerator. This option has no effect on objects that 
are symmetrical. 

 l Check Include in Schedule to include the selected symbol(s) in the schedule associated with that type of object. Not 
available for all object types. See The Schedule Tools on page 695.           

 l Check Flush Mounted to specify that the selected object follow the pitch of either the ceiling or roof. Only available 
when “From Ceiling” or “From Roof” is selected as the Elevation Reference, above. 

 
Copyright

If the selected object has a Copyright, information about it displays here.

 
Preview

A preview of the selected library object displays here and updates with changes. If the selected symbol is inserted into 
another object, such as an appliance in a cabinet, the parent object will also display. See Dialog Preview Panes on page 22.

LAYER PANEL

The LAYER panel is found in the specification dialogs for many different objects. For more information, see Layer Panel on 
page 191.          
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FILL STYLE PANEL

The FILL STYLE panel is available when the selected object is a sprinkler and controls how the area within its spray radius 
displays in plan view. It is similar to the FILL STYLE panel found in many dialogs. See Fill Styles on page 197.          

MATERIALS PANEL

The settings on the MATERIALS panel affect the appearance of the selected object in 3D views. See Materials Panel on page 
1055.

LABEL PANEL

A variety of library objects can display labels in plan view and cross section/elevation views. Labels use the Text Style 
assigned to the layer they are on.         

For information about the settings on this tab, see Label Panel on page 712.         

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 1335.          

OBJECT INFORMATION PANEL

The information entered on the OBJECT INFORMATION panel can be used in schedules and the materials list. For more 
information, see Object Information Panel on page 1336.   

SCHEDULE PANEL

The settings on the SCHEDULE panel determine which schedule categories the selected object is included in. Not available in 
the Sprinkler Specification dialog. See Schedule Panel on page 716.          

MANUFACTURER PANEL

The MANUFACTURER panel provides contact information for the selected object’s manufacturer. Only available for symbols 
from Manufacturer library catalogs. See Manufacturer Catalogs on page 970.         

 

Fixture and Furnishing Schedules
The Fixture and Furnishing Schedule tools allow you to produce customizable fixture and furnishing schedules as 
well as fixture and furnishing labels that display schedule numbers. See The Schedule Tools on page 695.         

Schedules can be customized for specific purposes: for example, to create appliance, plumbing, or HVAC schedules. See 
Working with Multiple Schedules on page 704.          

The fixtures or furnishings located in an individual room can be listed in their own schedule. See Create Schedule from 
Room on page 696.          
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Chapter 28
 

Custom Symbols

Chief Architect provides a complete set of architectural tools for creating highly customized designs, as well as a large 
selection of objects in the Library Browser that can be used to add more detail to a plan. 

In addition, if you don’t find precisely what you need, you can either import symbols from third party sources or create your 
own symbols in Chief Architect. See Importing 3D Symbols on page 1239.

Custom symbols can also be edited and added to the library. See The Library on page 961.

TOPICS

Symbol Specification Dialog 993
Get Last Symbol 1001
Convert to Symbol 1002
Editing Custom Symbols 1003
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Symbol Specification Dialog
The Symbol Specification dialog allows you to specify the attributes of a symbol before it is imported, as well as to 
edit existing symbols in either a plan or the User Catalog in the Library. 

The panels that are available in this dialog depend on the Category that the selected symbol is assigned to.

This dialog can be accessed in several ways: 

 l Select a symbol and click the Open Symbol  edit button. Only the selected symbol is affected by any changes that 

you make: other instances of the symbol are not affected, nor is the symbol saved in the library. Legacy cabinet 
symbols do not have this edit tool.

 l Right-click on a symbol in the library and select Edit> Open Symbol . Editing a symbol in the library changes 

does not affect any instances of the symbol already placed in a plan. Legacy cabinet symbols cannot be edited in this 
manner. See Editing Library Objects on page 986.          

 l Check Show Advanced Options in the Import 3D Symbol dialog. Editing a symbol as it is imported determines the 
initial attributes that it will have once brought into a plan or saved in the library. See Importing 3D Symbols on page 
1239. 

 l Check Show Advanced Options in the Convert to Symbol dialog. See Convert to Symbol on page 1002.          

3D PANEL

The options on the 3D panel primarily affect the symbol’s appearance in 3D views. 
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Name

Specify how the symbol’s Name should appear in its object specification dialog, its label, in the Materials List, and in 
schedules. See Materials Lists on page 1309.

 l Enter a Symbol Name. When imported into the program, a 3D symbol is given the same name as its file name. Not 
available when multiple symbols are selected. See Importing 3D Symbols on page 1239.

 l Select a Display Size format from the drop-down list to append the name of the symbol with size information. 

  3D Geometry

 l The pathname of the file being imported displays here for reference. If multiple symbols are being imported, only 
one file displays. If the symbol is not in the process of being imported, “Embedded Geometry” displays instead. 

 l Click the Replace Geometry button to choose a file to associate with the selected symbol. Not available when a 
symbol is being imported or converted. 

 l Select the Drawing Unit that was used to create the symbol. If any units other than inches or mm are selected, the 
program will convert the data into units appropriate for Chief Architect. Only available when a symbol is being 
imported. To apply a change to this setting, you must also click the Browse button and reload the symbol data from 
the original file. 

Note: SKP files are always imported using inches, regardless of the 
default units used in the plan file.

 l Click the Use Imported Origin Offset button to use the symbol origin saved in the file being imported rather than 
use an origin based on the symbol’s type. Only available when a symbol is being imported. See Symbol Origin on 
page 1003.

 
Origin Offset

Specify the Origin Offset, which affects how the selected symbol is positioned when placed in a Chief Architect plan. 
Specifying a particular origin is helpful if the selected symbol will be inserted into another object, such as a sink to be 
placed in a cabinet. See Symbol Origin on page 1003.

 l Leave these values at 0 to use Chief Architect’s default origin for the symbol. For most symbols, this is the 
appropriate option.

 l Enter new values to manually adjust the origin. The values in the X, Y, and Z fields represent the offset of the 
symbol’s origin point from the default Chief Architect origin. This option is appropriate for symbols that will be 
placed within other objects.

 
Rotation

These settings allow you to rotate the selected symbol(s) about the X, Y, and Z axes. Note that rotating a symbol will affect 
the location of its top, bottom, front, and /or back - and thus the location of its default origin. It may affect the size of the 
bounding box, as well; however, it does not affect the bounding box’s orientation. See Bounding Boxes on page 1004.    

 l Select the X, Y, or Z Axis that you wish to rotate the symbol about.    

 l Specify the Angle to rotate the symbol in the text field. An angle of 90° is set by default.    

 l Click the Rotate + button to rotate the symbol around the selected axis in a clockwise direction.    

 l Click the Rotate - button to rotate the symbol around the selected axis in a counterclockwise direction.    
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Faces

Specify how the selected symbol’s 3D Faces are generated.

 l The Number Of Faces that a selected symbol has displays here for reference. When multiple symbols are being 
imported, nothing displays. Although there is no limit to the number of faces, large numbers can increase rendering 
time significantly. 

 l Specify the Smoothing Angle, which determines whether two adjacent surfaces are shown with a smooth or sharp 
angle between them in rendered views. If the angle between two surface normals is less than this angle, normal 
averaging is used to give the effect of a curved surface. This value also effects the generation of automatic edge 
lines.

A good example is a hexagonal cylinder. The angle between adjacent surfaces is 360/8, or 45°. If you want it to look 
cylindrical, set the Surface Smoothing Angle to something greater than 45°. If you want to make the cylinder look 
hexagonal, set it to less than 45°. 

 l Automatic Edge Lines is checked by default so the program can choose an appropriate Smoothing Angle for legacy 
symbols migrated into version X14. It applies specifically to legacy symbols as they are brought into the program 
and in most cases, should remain checked.

 l Reverse Surface Direction will be either checked or unchecked by the program automatically, depending on where 
the selected symbol was created: it is checked for symbols created in the program or imported from an .skp file, and 
typically unchecked for symbols imported from other file types. 
In most cases, this setting should not be changed; however, if you export a symbol and encounter problems with its 
surfaces, changing this setting may help.
Note that Chief Architect imports the front side of faces in .skp files; however, it does not support faces with 
different textures on the front and back and will import the back side as a separate face.

 l Check Draw Self Intersection Lines to display lines where parts of the selected symbol are drawn in such a manner 
that they occupy the same 3D space as other parts of the same symbol. In most cases, this box should be unchecked; 
and if the selected symbol does not have self intersection lines, it will not be available. 

 l Check Cull Layered Transparent Surfaces to if you need to troubleshoot the appearance of a transparent symbol. 
Generally, this box should be left unchecked.

 l When a symbol is being imported, check Use Imported UV Map to preserve the UV map that was created for it. 
When unchecked, the symbol’s textures are mapped using a modified version of its UV map that assumes square 
shaped texture images. If the symbol uses a “decal sheet” style texture or one that is not square in shape, this box 
should be checked. 

 
Preview

A preview of the symbol’s appearance displays here and updates as changes are made to the settings in this dialog. When 
multiple symbols are selected, the most recently selected symbol displays. See Dialog Preview Panes on page 22.

 l Click the Show Origin  button to display the location of the selected symbol’s origin in the preview. Not 

available if Show Plan View is selected. See Symbol Origin on page 1003. 

If changes are made to an existing symbol in a plan or the 
Library Browser, you may also want to generate a new 2D 

Block to represent it in plan view.
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2D BLOCK PANEL

The 2D BLOCK panel allows you to select a 2D CAD block to represent the selected symbol in plan view. See CAD Blocks 
on page 333. 

This panel is not available for Doors, Doorways, or Cabinet Doors, nor is it available when multiple symbols are being 
imported.

  Selected CAD Block

 l The CAD block associated with the selected symbol is selected in the list of Available CAD Blocks and displays 
in the preview.

 l The CAD block name of an imported symbol will be based on the symbol’s original file name. See Importing 3D 
Symbols on page 1239. 

 l You can select a different CAD block from the list if you wish.

 l Check Auto Generate to create a new CAD block to represent the selected symbol any time the symbol is rotated 
in a way that affects the appearance of its overhead projection. 

 l Click the Generate Block button to automatically generate a CAD block based on an overhead projection of the 
selected symbol and add it to the list. 

If you do not see a CAD block in this list that suits your 
needs, you can create your own. See Custom 2D Symbols 

on page 335. 

 l Enter a Rotation Angle to rotate the 2D CAD block from its original angle of 0°. The orientation of the 2D CAD 
block in floor plan view does not affect the symbol’s orientation in 3D views.
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Fill

Check Fill to specify a fill color in selected symbol’s CAD block and enable the settings that follow. In order to apply the 
specified fill, you may need to click the Generate Block button, above.

 l Click the Color bar to select a fill color for the 2D block. See Color Chooser/Select Color Dialog on page 204. 

 l Use the Transparency slider bar or text field to control how transparent the fill color is. 

 l Check Use Original Plan Colors to make the symbol’s fill color white.

 
Preview

A preview of the selected CAD Block displays here when Show Plan View is selected. See Dialog Preview Panes on page 
22.

OPTIONS PANEL

The settings on the OPTIONS panel affect how a symbol behaves and can be placed. 

The options that display in this window vary, depending on the selected symbol’s category. 

 
Special Placement

The Special Placement options add placement restrictions and abilities to the selected symbol. When none of these is 
selected, the symbol will sit on the floor or terrain. None is not an option for Electrical symbols. Once placed, its height can 
be adjusted in its specification dialog. See Placing Library Objects on page 980. 

 
Requirements

 - Specify whether the selected fixture symbol requires Natural Gas, Water/Drain, Standard Voltage, or High Voltage. 
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Options

Additional Options specify the selected symbol’s purpose. 

 l Select a symbol Type from the drop-down list. The selection will vary depending on the symbol’s Category. 

 l A variety of check boxes may be available, depending on the selected symbol’s Category and Type. 

MATERIALS PANEL

The MATERIALS panel allows you to assign materials to the symbol’s components and is similar to the Materials panel in 
many specification dialogs. See Materials Panel on page 1055.

If the selected symbol is in the process of being imported, bear in mind that .dxf/.dwg files do not include material 
information, so the symbol’s components will not have materials assigned to them. See 3D Symbols and Materials on page 
1242. 

SIZING PANEL

The settings on the SIZING panel allow you to control the size of a symbol’s bounding box and how the symbol behaves 
when resized. 

A symbol’s actual size cannot be changed in the Symbol 
Specification dialog. See Resizing Objects on page 256.

 
Bounding Box Dimensions

Specify the Width, Depth and Height of the selected symbol’s bounding box, measured from the symbol’s origin with 
1/16" (1 mm) accuracy. Not available when multiple symbols are selected. 
When a symbol is first created, its bounding box is the same size as the actual 3D object. See Bounding Boxes on page 
1004.

 
Stretch Planes

Define where a symbol stretches when resized. If no stretch planes are used, the symbol resizes uniformly. See Stretch 
Planes and Zones on page 1005.
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 l Width planes are oriented vertically and run from the back of the symbol to its front, or along the symbol’s X axis. 

 l Depth planes are oriented vertically and run from one side of the symbol to the other, or along the symbol’s Y 
axis. 

 l Height planes are oriented horizontally, or along the symbol’s Z axis. 

 
Uniform Stretch Zones

Define an area between two planes that stretches uniformly when the object is resized, leaving the area outside the zone 
unaffected. 

Note: Stretch Planes and Stretch Zones do not affect a symbol’s 2D 
CAD block, which always resizes in a uniform manner. If you resize a 
symbol using custom Stretch Planes and Zones, consider generating a 
new CAD Block. See 2D Block Panel on page 996.

 
Preview

A preview of the selected symbol displays on the left. See Dialog Preview Panes on page 22. 

 l Click the Select Stretch Plane Item  button, then click on a stretch plane in the preview to select it. A selected 

Stretch plane can be moved using its edit handle. Only available when Show Stretch Planes is also toggled on.
 l Click the Show Origin  button to toggle the display of blue, red, and green lines showing the directions of the 

symbol’s X, Y, and Z axes and its origin. See Symbol Origin on page 1003.
 l Click the Show Stretch Planes  button to toggle the display of any stretch planes that the symbol may have. 

Stretch planes only display when the SIZING panel is active.
 l Click the Show Bounding Box  button to toggle the display of the symbol’s bounding box. This setting off by 

default but is retained during the current program session.

OPENING PANEL

The settings on the OPENING panel define the selected Window or Doorway symbol’s rough opening when placed in a wall. 

The OPENING panel is only available for Windows and Doorways.
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Opening Diagram

An editable diagram of the symbol’s wall opening displays here. 
Edit the symbol’s opening size and shape by clicking on a dimension number and typing the desired value. To update the 
preview, press the Tab key.

 
Opening Sections

If the Window or Doorway has an angled or arched top, click the Opening Sections drop-down and choose the section 
diagram that most closely resembles the rough opening shape that you want. You can then edit the section as needed.

The size and shape of a symbol’s opening is independent of 
the symbol’s size. Make sure that the two are compatible.

PLAN VIEW PANEL

The PLAN VIEW panel controls the appearance of Window and Doorway symbols in floor plan view. 

The PLAN VIEW panel is only available for Windows and Doorways. 
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Plan View Diagram

An editable diagram of the symbol’s representation in plan view displays here. The settings here also affect how many units 
the symbol contains as well as their size in both 2D and 3D views. 

 l To change the size of the symbol’s units in floor plan view, click on a dimension number and type the desired 
value. Press the Tab key to update the diagram.

 l To change a unit in the preview from a window to a door swing, click on the unit in the diagram.

The size of a symbol’s units is entirely independent of the size 
of the symbol itself. Make sure that the total width of the 

symbol’s units in plan view equals the width of the 3D symbol.

 
Plan View Sections

Click the Plan View Sections drop-down and choose the number of units contained by the Doorway or Window symbol. 
Up to five units are possible. 

PLANT INFORMATION PANEL

This panel is available when the Symbol Specification dialog is opened for a plant. The options are the same as the Plant 
Information panel of the Plant Symbol Specification dialog. See Plant Information Panel on page 1306.

PLANT DESCRIPTION PANEL

This panel is available when the Symbol Specification dialog is opened for a plant. The options are the same as the Plant 
Description panel of the Plant Symbol Specification dialog. See Plant Description Panel on page 1306.

 

Get Last Symbol
If you import or convert a symbol that cannot be placed in the current view or must be contained by another object 
that is not present in the view, you can quickly select it for placement once the needed conditions are met using the 
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Get Last Symbol command. 

Open a view in which the symbol can be placed or create an object to place the symbol into, then select Tools> Symbol> 
Get Last Symbol  to retrieve the last symbol created and click in your plan to place the symbol. 

 

Convert to Symbol
Most objects in Chief Architect can be converted into symbols. To do this, select one or more architectural objects in 
floor plan, camera, or cross section/elevation view and click the Convert to Symbol edit button. See Architectural vs 

CAD Objects on page 162.         

Note: Image objects cannot be converted into symbols. See Images on 
page 1181. 

You can create custom symbols in Chief Architect using any combination of architectural objects.

Particularly if you are designing a custom object using generic objects like Primitives, it is helpful to begin by opening a 
new, blank plan. Then, place any combination of architectural objects to produce a model of what you would like your 
custom symbol to look like. 

When the objects are configured as desired, select them and then use the Convert Selected to Symbol  edit tool to create 

a single symbol that is assigned to a category that reflects how the object will be used. For example, if you design a cabinet 
door, select Cabinet Door/Drawer as the symbol’s category so that the resulting symbol can be assigned to a cabinet.

When you want to convert a large number of objects into a single symbol, it may be easier to do so in a 3D view.

To convert a 3D model to a symbol
 1.  Create a camera view or overview in which the only objects displaying are those that you wish to convert to a single 

symbol.

 2.  Select Tools> Symbol> Convert to Symbol .

 3.  In the Convert to Symbol dialog:

 l Type a short, descriptive Symbol Name. The Symbol Category will populate this field unless a custom name is 
specified.

 l Choose a Symbol Category from the drop-down list. When you select a category, the Symbol Name will 
automatically update to use that category. 

 l Check Add to Library if you would like the symbol to be added to the library. See Add to Library on page 973.

 l Check Show Advanced Options to open the Symbol Specification dialog when you click OK, where you have 
more extensive control over the symbol’s settings. See Symbol Specification Dialog on page 993.
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 4.  Click OK to close the dialog and convert your custom object to a symbol. Depending on the size of the symbol, a 
Progress dialog may display during this process.

 

Editing Custom Symbols
Custom symbols can be selected and edited much like other objects in the program. A symbol’s category determines exactly 
what editing options are available; however, most symbols can be edited using the edit handles, edit toolbar and 
specification dialog. See Editing Objects on page 207.

Symbols have some additional options that allow you to control how the symbol behaves when it is placed, selected, moved 
and resized.

Symbol objects have two specification dialogs: one based on its 
object type and accessed using the Open Object edit button, and 

the Symbol Specification dialog accessed using the Open Symbol edit 
button.

SYMBOL ORIGIN

All symbols have an origin point, which determines how the object is positioned when it is placed in a plan. The origin 
point also determines the location of a symbol’s bounding box and 2D block. 

The location of a symbol’s origin point is typically on its back surface, at the bottom center; however, this may vary, 
depending on the symbol’s category. You can see the location of a selected symbol’s origin in preview pane of the Symbol 
Specification dialog. See 3D Panel on page 993.

The following table lists these default origins by symbol type:

Symbol Type Origin location

Cabinet (legacy) Bottom, Back, Center

Cabinet Door Bottom, Back, Center

Doors Bottom, Back, Center

Doorways Bottom, Outside, Center
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Symbol Type Origin location

Electrical, 
Ceiling Mounted

Center Top

Electrical, 
Wall Mounted

Back, Center

Electrical, 
Floor Mounted

Center, Bottom

Electrical,
Wall Mounted

Center, Back

Furniture Bottom, Back, Center

Fixture Bottom, Back, Center

Geometric Shapes Bottom, Back, Center

Hardware Bottom, Back, Center

Millwork Bottom, Back, Center

Molding N/A

Plant Bottom, Back, Center

Sprinkler Back, Center; Height varies 

Windows Bottom, Exterior, Center of sill

You can offset a symbol from its origin point. This can make it easy to insert the object inside another object, but does not 
affect the location of the bounding box or the 2D block that displays in plan view.

To create an insertable symbol
 1.  Make a note of the symbol’s actual size on the GENERAL panel of its specification dialog. 

 2.  Click the Open Symbol  edit button to open the Symbol Specification dialog.

 3.  On the 3D panel, check Specify Origin.

 4.  Adjust the X, Y and/or Z values as needed: 

 l To insert the back of the symbol into the side of another object at a particular distance, specify that distance in the Y 
field as a positive value.

 l To insert the bottom of the symbol into the top of another object, specify the distance that it should be dropped as a 
negative value in the Z field.

BOUNDING BOXES

An object’s bounding box determines the amount of space it requires in 3D and thus how close it can be moved to other 
objects before it bumps into them. 

The bounding box also defines the selectable area around a symbol: when you click within an object’s bounding box, it will 
become selected. Similarly, the bounding box affects whether an object is included in a selection marquee. See Selecting 
Objects on page 212. 

When a symbol is selected, its edit handles display around the perimeter of its bounding box. See Edit Handles on page 23.

You can create setback space for a symbol by increasing its bounding box size on the SIZING panel of the Symbol 
Specification dialog. See Sizing Panel on page 998.
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To create setback space for a symbol
 1.  Make a note of the symbol’s actual size on the GENERAL panel of its specification dialog. 

 2.  Click the Open Symbol  edit button to open the Symbol Specification dialog.

 3.  On the SIZING panel, increase the Width, Depth and/or Height values by the amount of the desired setback space.

 l The bounding box Width is always centered on the symbol’s origin point.
 l The Depth is measured from the symbol’s origin point towards its front.
 l The Height is measured from the symbol’s origin point towards its top.

You can also allow a symbol to set into another object by reducing its bounding box size. Unlike the symbol itself, the 
bounding box and 2D block cannot be offset from the origin.

STRETCH PLANES AND ZONES

Stretch Planes and Stretch Zones define where a symbol stretches when resized. 

If a symbol has no Stretch Planes or Zones, its surfaces will all resize uniformly; if, on the other hand, a Stretch Plane or 
Zone is defined, the object will resize only within the plane or zone. Any portions of the symbol located outside the plane or 
zone will not resize at all.

 l A Stretch Plane is a two dimensional plane within a symbol which increases or decreases in thickness as the symbol is 
resized. 

 l A Stretch Zone defines an area between two Stretch Planes that resizes uniformly, leaving the area outside unaffected.

Stretch Plane coordinates are relative to the symbol’s origin point. For many object types, the origin is located at the bottom 
center of its back surface. 

When one or more Stretch Planes are specified and the symbol is 
resized using its edit handles in plan view, the program will 

present you with the option of updating its 2D CAD Block. See 2D Block 
Panel on page 996.

To define a Width stretch plane
 1.  Open a symbol’s Symbol Specification dialog using any of the available methods. See Symbol Specification Dialog 

on page 993. 

 2.  On the SIZING panel, under the Stretch Planes heading, check the box beside 1 to the left of the Width column. The 
field to its right becomes active.

 3.  The new plane has an initial value of 0.

 l Leave it at 0” to run the plane through the object’s default origin point.

 l Specify a negative number to define a plane to the left of the origin.

 l Specify a positive number to define a plane to the right of the origin.

 4.  Click OK. When the symbol’s width is changed, only the cross section defined by the Stretch Plane will be affected.
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To define a Depth or Height stretch plane
 1.  On the SIZING panel of the Symbol Specification dialog, under the Stretch Planes heading, check the box beside 1 to 

the left either the Depth or Height column. The field to its right becomes active.

 2.  The new plane has an initial value of 0.

 l To define a Height stretch plane, specify a positive number between 0 and the overall height of the symbol.

 l To define a Depth stretch plane, specify a negative number.

 3.  Click OK. When the symbol’s depth or height is changed, only the cross section defined by the Stretch Plane will be 
affected.

A symbol can have up to three Stretch Planes in each direction, for a total of nine. 

To define two stretch planes
 1.  Open a symbol’s Symbol Specification dialog. 

 2.  On the SIZING panel, check the boxes beside 1 and 2 to the left of a column under Stretch Planes. The fields to their 
right becomes active. 

 3.  Specify the desired values to define each Stretch Plane within the symbol.

 4.  Click OK. When the symbol is resized, the two cross sections defined by the Stretch Plane will be affected.

To define a stretch zone
 1.  Open a symbol’s Symbol Specification dialog. 

 2.  On the SIZING panel, under the Stretch Planes heading, check the boxes beside 1 and 2 to the left of a column under 
Stretch Planes. The fields to their right becomes active. 
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 3.  Specify values for both planes.

 4.  Check the box beside the corresponding option in the Stretch Zones section of the panel.

 5.  Click OK. When the symbol is resized, only the area within the Stretch Zone will be affected.

ROTATING SYMBOLS

Symbol objects can be rotated in all three dimensions in the Symbol Specification dialog. Free-standing symbols can also be 
rotated in 3D views using the Rotate edit handle: select the symbol on different surfaces to rotate it along its different axes. 
See Selected Side on page 215. 

In either case, the symbol’s bounding box will not rotate with the symbol’s geometry. Instead, it will resize as needed to 
contain the symbol’s surfaces and its sides will remain orthogonal to the X, Y, and Z axes in the drawing space. See 3D 
Drafting on page 12.

Similarly, the symbol origin will not rotate with the symbol geometry. Instead, its position on the bounding box will remain 
constant and its position relative to the symbol’s surfaces will change. 

In contrast, stretch zones and planes do rotate with the symbol’s geometry, so if a symbol is rotated and then resized, it will 
stretch appropriately rather than become misshapen.

When a symbol is rotated in 3D, its 2D representation in plan view may need to change. The first time you rotate a symbol, 
the program will ask if you want the 2D plan view symbol to be regenerated to reflect its new orientation.  If you click Yes, 
it will be automatically regenerated every time you rotate it. You can enable or disable Auto Generate in the Symbol 
Specification dialog. See 2D Block Panel on page 996.  

EDIT WALL CUTOUT POLYLINE

The Edit Wall Cutout Polyline edit tool is available in camera views when a selected symbol has Inserts into Wall 
checked in the Symbol Specification dialog. See Options Panel on page 997.

Click this button to enable edit handles on the symbol’s wall cutout polyline so that its shape can be edited. See Editing 
Closed Polyline-Based Objects on page 230. 

To restore the original shape of the cutout polyline, click the Reset Wall Cutout Polyline  edit button while the cutout 

polyline is active for editing. 
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Chapter 29
 

Architectural Blocks

An architectural block is a collection of individual 3D objects that are grouped together so that they can be placed and 
moved as a single object. Although blocked together, these objects retain many of their own attributes, such as materials.

Architectural blocks can also be exploded so that the individual sub-objects become independent of one another.

TOPICS

Architectural vs CAD Blocks 1009
Creating Architectural Blocks 1009
Displaying Architectural Blocks 1009
Editing Architectural Blocks 1010
Architectural Block Specification Dialog 1011
Architectural Blocks, Sub-Objects, and Components 1013
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Architectural vs CAD Blocks
Just as there are two types of objects in Chief Architect, architectural and CAD, there are two types of blocks. See 
Architectural vs CAD Objects on page 162.          

Architectural objects such as cabinets and fixtures can be included in architectural blocks, while CAD objects such as lines, 
arcs, text and dimensions can be included in CAD blocks. See CAD Blocks on page 333.          

Knowing the differences between these two types of blocks helps you decide which type of block can best meet your needs.          

A CAD block can include and also be nested in a larger block with CAD objects, text and dimensions, but cannot include or 
be blocked with architectural objects.          

An architectural block can include and also be nested in a larger block with architectural objects, but cannot include or be 
blocked with CAD objects, text or dimensions.           

 

Creating Architectural Blocks
To create an architectural block, group-select multiple architectural objects, then click the Make Architectural Block 
edit button. Architectural blocks can be created in any view. See Architectural vs CAD Objects on page 162.         

The following is a list of objects that can be included in architectural blocks:         

 l Cabinets (Base, Wall, Full Height)             
 l Custom Countertops and Counter Holes
 l Soffits, Shelves, Partitions             
 l Fixture and Furniture symbols              
 l Hardware symbols             
 l Millwork symbols             
 l Geometric Shapes             
 l Electrical objects             
 l Images             
 l Slabs and Foundation Slabs             
 l Primitives and 3D Solids           
 l Molding Polylines           
 l Roads, Driveways, Sidewalks             
 l Terrain Features and Terrain Modifiers             
 l Distribution Paths and Regions that have architectural objects as their distributed object.          

Once blocked, the set of blocked objects is contained in a bounding box, indicating that they are now an architectural block.          

 

Displaying Architectural Blocks
As with individual objects, the display of architectural blocks is controlled in the Layer Display Options dialog. See 
Layer Attributes on page 181.   
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 l If an architectural block is composed of objects that are on the same layer, the block will be placed on that layer, as 
well. 

 l If an architectural block is composed of objects on different layers, the block will be placed on the “Architectural 
Blocks” layer.

 l Once created, an architectural block can be placed on any layer you wish.          

IN PLAN VIEW

The sub-objects of a block can use the layer attributes assigned to their current layer or the layer attributes assigned to the 
block. See General Panel on page 1012.           

You can control the appearance of the bounding box by changing the display properties of the architectural block’s layer or 
you can turn off its display in the Architectural Block Specification dialog. See General Panel on page 1012.          

Like other objects, an architectural block is placed in a Drawing Group that affects whether it displays in front of or behind 
other objects. You can modify a selected  architectural block’s place in the drawing order by clicking the View Drawing 
Group Edit Tools  edit button. See Drawing Group Edit Tools on page 195.         

ARCHITECTURAL BLOCK LABELS

Architectural blocks can display labels for both the block and any component objects that have labels in plan              and cross 
section/elevation views. Labels  for architectural blocks are placed on the “Architectural Blocks, Labels” layer and use the 
Text Style assigned to that layer. See             Label Panel on page 712.         

You can turn off the display of component labels either by layer or by checking Treat as One Object in the Architectural 
Block Specification dialog. See General Panel on page 1012.           

The label for an architectural block can be generated automatically, user-specified, or suppressed. See Architectural Block 
Specification Dialog on page 1011.          

IN MATERIALS LISTS AND SCHEDULES

The display of an architectural block in materials lists and schedules can be turned off completely. The block can appear as 
a single unit or its sub-objects and components can be listed separately. See Materials Lists on page 1309 and Schedules 
and Object Labels on page 694.          

 

Editing Architectural Blocks
Architectural blocks can be selected and edited in 2D and 3D views. See Selecting Objects on page 212.

Note: Moving an architectural block in 3D view regenerates the view. If 
the architectural block contains terrain objects, the terrain is rebuilt.

Once selected, an architectural block can be edited using its edit handles, edit toolbar buttons, and specification dialog. See 
Architectural Block Specification Dialog on page 1011.
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USING THE EDIT HANDLES

A selected architectural block displays a Move handle and a Rotate handle. If the block has a label, it also has its own Move 
and Rotate handles.

Architectural blocks cannot be resized, but the individual objects in a block can be. 

IN THE SPECIFICATION DIALOG

Architectural blocks can be edited in their specification dialog. See Architectural Block Specification Dialog on page 
1011.         

USING THE EDIT TOOLS

A selected architectural block or blocks can be edited in a variety of ways using the buttons on the Edit Toolbar. See The 
Edit Toolbar on page 135.   

EDITING SUB-OBJECTS

The individual objects included in an architectural block can also be selected and edited. See To select a sub-object on page 
1014.

EXPLODE ARCHITECTURAL BLOCK

You can break an architectural block to make its objects independent. Select the architectural block and click the 
Explode Architectural Block edit button.  

Note: If you open a plan created in the Premier version of Chief 
Architect and an architectural block includes an object that you cannot 
create in your version of the software, you cannot unblock it or edit its 
components. 

ADDING ARCHITECTURAL BLOCKS TO THE LIBRARY

You can create your own architectural blocks and save them in the library. See Add to Library on page 973.         

Architectural blocks, their component objects, as well as inserted symbols or assigned attributes like materials or 
moldings associated with those component objects can be added to the library using the Add to Library As edit tool. 

See Add to Library As on page 974.         

 

Architectural Block Specification Dialog
The Architectural Block Specification dialog controls the way architectural blocks display in plan view, in schedules, 
and in materials lists. Select one or more architectural blocks and click the Open Object edit button to open this 

dialog.         
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GENERAL PANEL

 
Display Options

These settings control the appearance of the selected architectural block in plan view. See Displaying Architectural Blocks 
on page 1009.         

 l Check Display Bounding Box to show the bounding box of the objects in the architectural block.             

 l Uncheck Display Sub-Objects to suppress the display of the sub-objects and display only the bounding box. If 
Display Bounding Box is unchecked, it will become checked.             

 l Check Display Sub-Objects Using Block Layer to apply the display properties of the architectural block’s layer to 
its sub-objects. When this box is unchecked, sub-objects use the display properties set for their layers.          

 l Check Display Sub-Objects Using Block Draw Order to display all component objects of the selected block using 
the block’s drawing order. When unchecked, each component displays according to its individual drawing order. See 
Drawing Groups on page 194.          

 
Schedule and Materials List

These settings control how the selected architectural block appears in schedules and the materials list.             

 l Check Treat as One Object to treat the architectural block as a single unit in materials lists and schedules. This box 
must be checked in order for the settings on the SCHEDULE PANEL to be available for use.          

 

 
Size/Position

These settings are not available if the selected block includes any objects such as electrical objects that do not have these 
settings in their individual specification dialogs.         

 l Select the Elevation Reference from the drop-down list. This determines where the next two settings are measured 
from and also affects their setting labels.             

 l Specify the height to Top, measured from the selected Elevation Reference to the top of the architectural block.             

 l Specify the height to Bottom, measured from the selected Elevation Reference to the bottom of the architectural 
block.             
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Options

 l When Suppress Adjacent Room Moldings is checked, a room's base, chair, and/or crown moldings will not 
generate where the selected block's bounding box crosses them when positioned against a wall. When unchecked, 
room moldings are not affected by the block and generate normally. See Room Moldings on page 441.

 

 
Preview

A preview of the selected cabinet displays on the right side of the panel. See Dialog Preview Panes on page 22. 

LAYER PANEL

For information about the LAYER panel, see Layer Panel on page 191.          

LABEL PANEL

Labels for Architectural Blocks display in plan view when the “Architectural Blocks, Labels” layer is turned on and use the 
Text Style assigned to that layer. See Architectural Block Labels on page 1010.         

The LABEL panel is available for a variety of different objects. For more information, see              Label Panel on page 712.    

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 1335.          

OBJECT INFORMATION PANEL

The information entered on the OBJECT INFORMATION panel can be used in schedules and the materials list. For more 
information, see Object Information Panel on page 1336.         

SCHEDULE PANEL

The settings on the SCHEDULE panel determine which schedule categories the selected architectural block is included in. 
These settings are only available when Treat as One Object is checked on the GENERAL panel. See Schedule Panel on 
page 716.          

 

Architectural Blocks, Sub-Objects, and Components
An architectural block is composed of a group of sub-objects that have been blocked together. For example, a kitchen island 
architectural block may consist of cabinets, appliances, a custom countertop, and other accessories.

Each of the sub-objects in an architectural block may contain additional parts called  components. The cabinets in a kitchen 
island, for example, may contain handles, hinges, and drawer glide.         

Architectural blocks can be treated as a single unit in materials lists and schedules, ignoring sub-objects and their 
components. See General Panel on page 1012.          
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SUB-OBJECTS

Certain attributes of an architectural block can be edited at the sub-object level. A sub-object can be edited by accessing its 
specification dialog in either of two ways:

 l Explode the architectural block, select the sub-object, and click the Open Object  edit button.

 l Select the sub-object while it is part of the architectural block and click the Open Object  edit button. Some 

attributes may not be editable while the object is part of a block. See Editing Architectural Blocks on page 1010.

To select a sub-object
 1.  Click the Select Objects  button, then click on the sub-object that you would like to edit.

 2.  With the architectural block selected, click the Select Next Object  edit button or press the Tab key. 

  The selection switches to the individual object and it can be edited using its edit handles, edit toolbar and 
specification dialog.

The options for editing a sub-object may be more restricted than if the object were independent. If more extensive editing is 
required, the architectural block must be exploded. See Explode Architectural Block on page 1011.

COMPONENTS

You can view and modify the components of an architectural block or group of blocks in the Architectural Block 
Specification dialog. The COMPONENTS panel lists all the sub-objects that comprise an architectural block, as well as the 
components that make up each sub-object. See Components Panel on page 1335.          
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Chapter 30
 

Other Objects

Chief Architect has additional objects that can be used to customize your design. 

TOPICS

Primitive Tools 1016
Creating Primitives 1016
Editing Primitives and 3D Solids 1018
Creating Complex Structures with Primitives 1021
3D Solid Specification Dialog 1023
Sphere Specification Dialog 1025
Cylinder Specification Dialog 1027
Cone Specification Dialog 1029
Pyramid Specification Dialog 1031
General Shapes 1033
Soffits 1033
Soffit Specification Dialog 1034
Floor and Wall Material Regions 1037
Material Region Specification Dialog 1039
Material Layers Definition Dialogs 1040
Distributed Objects 1043
Distribution Region/Path Specification Dialogs 1044
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Primitive Tools
The Primitive Tools allow you to create basic solid geometric shapes, which can be combined to create a wide variety 
of custom solid objects. Select Build> Primitive to access the Primitive Tools.         

With the exception of Faces, objects made with the Primitive Tools are included in materials list calculations. For best 
results, a Volume type material should be used. See Define Material Dialog on page 1066.          

3D SOLID

The 3D Solid tool can be used to create rectangular solid objects in plan, cross section/elevation, and camera views. 
See              Creating Primitives on page 1016.

SPHERE

The Sphere tool can be used to create solid 3D spheres in plan and camera views.         

CYLINDER

The Cylinder tool can be used to create solid 3D cylinders in plan and camera views.         

CONE

The Cone tool can be used to create solid 3D cones in plan and camera views.         

PYRAMID

The Pyramid tool can be used to create solid 3D pyramids in plan and camera views.         

FACE

The Face tool can be used to create two-dimensional surfaces in plan, cross section/elevation, and camera views. 
Face objects are two-sided and be revolved or extruded to create custom Solid objects. See Face Objects on page 

1017.         

 

             Creating Primitives
Primitive solids are drawn similar to the way CAD boxes are. Depending on the view in which they are created, however, 
the method may differ somewhat. 

IN PLAN VIEW

In plan view, Primitives are drawn much the way closed CAD polylines are. Select a tool, then click and drag to define an 
area.
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 l To create 3D Solid , click and drag to define the width and depth of the box’s base. Its initial Height is 1” (25 

mm).
 l To create a Sphere , Cylinder , Cone , or Pyramid , click and drag to define the radius.

 l As it is drawn, the height of a Cylinder, Cone, or Pyramid is equal to its radius. 
 l To create a spline-shaped 3D Solid, draw a  3D Solid and click the Convert to Spline  edit button. This tool is not 

available if the selected object has been extruded along more than one axis. See Convert to Spline on page 261.

Initially, the bottom surface of Boxes, Cylinders and Cones, and the center point of Spheres, are all set at 0” on the Z axis. 
See Entering Coordinates on page 170.

IN 3D VIEWS

In 3D views, the height of boxes, pyramids, cylinders and cones can be defined as they are drawn.

 l To create a 3D Solid , Cylinder  or Cone , click and drag to define the width and depth of the box’s base. 

Release the mouse button, then drag upward or downward to define its height.
 l Drag upward to set the height of the bottom surface at 0”, or drag downward to set the top surface at 0”.
 l A 3D Solid can also be drawn with its base against a wall instead of facing downward. When drawn in this manner, 

the default Height value of 1" (25 mm) is applied to the object's Depth instead. 
 l To create a Sphere  or Pyramid , click and drag in any direction to define its radius.

IN CROSS SECTION/ELEVATION VIEWS

With the exception of 3D Solids  and Faces , primitives cannot be created in cross section/elevation views. See Cross 

Section/Elevation Views on page 1090.

CONVERT TO 3D SOLID

Click the Convert To 3D Solid edit button to convert a selected Primitive, Custom Countertop, or Slab into a 3D 
Solid so that it can be used with other Solids to create complex structures. 

FACE OBJECTS

Regardless of the view, Faces are drawn the way line-based objects are when the Alternate  edit behavior is active. See 

Alternate on page 209.  

To draw a Face
 1.  Select Build> Primitive> Face , then click, drag and release the mouse button to draw the first edge. 

 2.  Click to define the endpoints of additional edges. A Face must have at least three edges. 

 3.  To finish drawing, click at the original starting point. This is easiest to do when Endpoint  snapping is enabled. 

See Object Snaps on page 164. 

Once drawn, Faces can be revolved or extruded to create Solid objects. See Extrude Object on page 1019. 
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Editing Primitives and 3D Solids
Primitives can be selected individually and as a group and edited using the edit handles, the Edit Toolbar, dimensions, and 
their respective specification dialogs. See Creating Complex Structures with Primitives on page 1021.

USING THE EDIT HANDLES

The edit handles that are available on a selected Primitive depend on its object type. In plan view:

 l 3D Solids are selected on their top edges and edited like closed polylines. If one of these objects has been rotated in 
3D, more than one top surface may be visible in plan view; however, only one of these surfaces will be editable. 
Regardless of the orientation of the object or its surface angles, when it is rotated in plan view, it will rotate relative to 
the horizontal XY plane. If you want to rotate the object relative to one of its top faces, you can do so in a 3D view. 
See Editing Closed Polyline-Based Objects on page 230.

 l Faces are edited like much like other closed polylines.
 l Pyramids have a more limited set of edit handles and can be moved, resized, and rotated.
 l Spheres, cylinders, and cones are more limited still and can be moved and resized only. 

In 3D views:

 l Faces, as well as each surface of a 3D Solid can be selected and edited like a closed polyline. 
 l Pyramids, cylinders, and cones can be moved, resized, and rotated. The axis of rotation will vary depending on where 

you click to select the object.
 l Spheres can be moved and resized only.

In 3D views, most Primitives have a different set of edit handles for each selected edge, allowing you to rotate them in 
along more than one axis. These edit handles correspond to the object’s Rotation settings in its specification dialog. To 
rotate a Primitive, it is often easiest to use its edit handles in a 3D view to orient it approximately the way you want it, then 
use the Rotation settings in its specification dialog to fine-tune its angles. 

USING THE EDIT TOOLS

A selected Primitive can be edited in a variety of ways using the buttons on the Edit Toolbar. See The Edit Toolbar on page 
135.

The Union, Intersection, and Subtraction edit tools are particularly useful edit tools for creating custom shapes. See 
Union, Intersection, and Subtraction on page 278.

3D Solids and Faces have a number of edit tools that other Primitive tools do not, including Convert to Plain Polyline, 
Convert to Spline, Fillet Lines, and Chamfer Lines. See Converting Objects on page 265, Reshaping Objects on page 
257, and Polyline Holes on page 234.

3D SOLID FEATURE

The 3D Solid Feature edit tool allows you to either create a hole in a selected 3D Solid or Face or, in 3D views, add 
an extrusion that extends out of a selected 3D Solid. 

In plan view, this tool is used the same way the Make Hole edit tool is: simply draw a shape located entirely within a 
3D Solid or Face. See Polyline Holes on page 234.
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To create an extrusion in a 3D view
 1.  In a camera view, select a 3D Solid.

 2.  Click the 3D Solid Feature  edit button. 

 3.  Click and drag to draw a rectangular polyline at least partially located within the area of one surface of the object.

 4.  Release the mouse button and then drag the mouse pointer: 

 l Towards the object surface to create a hole.

 l Away from the object surface to create an extrusion. 

EXTRUDE OBJECT

The Extrude Object edit tool allows you to produce a Solid object by extruding a selected Face or 3D Solid in any 
direction. See 3D Drafting on page 12. 

To use Extrude Object
 1.  Select a Face or 3D Solid and click the Extrude Object  edit button.

 2.  In the Extrude Object dialog, specify the Extrusion Delta, which is the direction and distance that the object is 
extruded.

 l Specify the distances that the object should extrude in the directions of each of the three axes.

 3.  Click OK.

REVOLVE OBJECT

The Revolve Object edit tool allows you to produce a Solid object by extruding a selected Face or 3D Solid around 
an axis or point that you specify. 

To use Revolve Object
 1.  Select a 3D Solid or Face.

 2.  Click the Revolve Object  edit button.

 3.  In the Revolve Object dialog, specify the Axis of Rotation, which determines the direction that the object will 
rotate. The Axis of Rotation is a line that is perpendicular to the direction in which the object will rotate. 
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 l Select X-Axis to revolve the object around a line that runs parallel to the X Axis in the current plan. The object 
will revolve in the Y and Z axes.

 l Select Y-Axis to revolve the object around a line that runs parallel to the Y Axis in the current plan. The object 
will revolve in the X and Z axes.

 l Select Z-Axis to revolve the object around a line that runs parallel to the Z Axis in the current plan. The object will 
revolve in the X and Y axes.

 l Select User Defined to define the axis around which the object will revolve.

The Axis of Rotation cannot be normal, or perpendicular, to 
the plane of the selected Face object. If it is, a warning 

message will display and the object will not be revolved.

 4.  When User Defined is selected, the X, Y and Z Direction fields become active. Type a length value in each field to 
specify the direction of a custom Axis of Rotation. All three values cannot be 0. No specific unit is used: instead, the 
ratio between these numbers is used to define an axis of rotation. 

 5.  Specify the Rotate About Point, which is the point around which the object will rotate.

 6.  Specify the Angle of Rotation, which is how far around the axis of rotation that the object will rotate. A value of 
180° will rotate the object half-way around the axis, while 360° will rotate it in a complete circle.

 7.  Click OK.

FILLET/CHAMFER EDGES

The Fillet Edges edit tool allows you to replace an angled edge on a 3D Solid with a curved edge, while the 
Fillet All Edges edit tool replaces all angled edges on a 3D Solid with curved edges. See Fillet Lines on page 

260.

The Chamfer Edges edit tool allows you to replace an angled edge on a 3D Solid with a straight beveled edge, 
while the Chamfer All Edges edit tool replaces all angled edges on a 3D Solid with beveled edges. See 

Chamfer Lines on page 260.

The Fillet Edges and Chamfer Edges edit tools are used in much the same way.
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To fillet an edge
 1.  Create a camera view of the 3D Solid object you would like to edit.

 2.  Click on a surface of a 3D Solid and click the Fillet Lines  edit button

 3.  Next, click the Fillet Radius  edit button. In the Set Fillet Radius dialog, specify the desired Fillet Radius and 

click OK. If the value is 0, no fillet will be created.    

 4.  To apply the specified radius to all straight edges on the selected 3D Solid, click the Fillet All Edges  edit button.

    

 5.  To apply a fillet to individual edges of the selected 3D solid, click the Fillet Edges  edit button.    

 6.  Move your mouse pointer over a surface edge that you would like to curve. A preview will display, showing the 
fillet that will be created if you click on that edge.

 7.  Click on additional surface edges to make them curved, as needed.    

 8.  When you are finished, click the Main Edit Mode  edit button or press the Esc key to return to the selected 

object’s main edit toolbar.   

Once two lines are filleted, the arc between them can be edited. See Editing Arc-Based Objects on page 221.   

EXPLODE 3D SOLID

The Explode 3D Solid edit tool allows you to explode a selected 3D Solid or Pyramid into a collection of faces. See 
Face Objects on page 1017.

USING DIMENSIONS

Like various other objects, Primitives can be moved using dimensions.  3D Solids, Pyramids, and Faces can also be 
resized using dimensions. See Moving Objects Using Dimensions on page 491. 

In order for a particular Dimension Tool to locate Primitives as dimensions are drawn, its defaults must be set to do so. See 
Locate Manual Panel on page 460.

 

Creating Complex Structures with Primitives
Objects created using the Primitive Tools can be manipulated and combined to produce complex structures. Use the Union 

, Intersection  and Subtract  edit tools to create unique 3D shapes and combine shapes into Architectural 

Blocks  or use them to create a custom symbol. See Architectural Blocks on page 1008, Union, Intersection, and 

Subtraction on page 278, and Convert to Symbol on page 1002.

A simple fireplace, for example, can be created by arranging 3D Solids . 
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Decorative stone columns can be modeled using 3D Solids  and the Union , and Subtract  edit tools. 

A custom chimney can be designed using 3D Solids  and Cylinders  and the Union  and Subtract  edit tools.
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A detailed model truck can be created using 3D Solids  and Cylinders  and the Union , Intersection , and 

Subtract  edit tools.

When a primitive has been manipulated using the Union , Intersection  and Subtract  edit tools, it is no longer a 

primitive that retains its specific shape when edited. Instead, it is a considered a 3D Solid. See 3D Solid Specification 
Dialog on page 1023.

Structures created using the Primitive Tools can be converted to symbols. See Convert to Symbol on page 1002. 

 

3D Solid Specification Dialog
To open the 3D Solid Specification dialog, select one or more 3D Solids and click the Open Object edit button.   

The settings in this dialog are similar to those in the 3D Solid Defaults dialog. See Default Settings on page 76.

When you first draw a 3D Solid, the origin of the box is the point where you start drawing it; the width of the box is the X 
axis dimension.

3D SOLID PANEL
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  Size

 l Specify the Width, Depth, and Height of the selected object. 

 l When the selected object was drawn with the Face tool, the Height will be 0" (mm) and will not be editable. In the 
3D Solid Defaults dialog, the Width and Height settings are not available while the Height setting determines the 
initial height of 3D Solids drawn in plan view.     

 l When Retain Aspect Ratio is checked, the ratio between the shape's Width, Height, and Depth is maintained when 
it is resized in the specification dialog. Uncheck this box to change these values independently and potentially distort 
the object's overall shape. This setting is retained when you click OK but does not affect the behavior of the object's 
edit handles.      

 l A 3D Solid's bounding box controls the position of its origin point and the orientation of its Y, X, and Z axes (width, 
depth, and height, respectively). If a 3D Solid is rotated, its bounding box also rotates, affecting how it is reshaped 
when resized. Click the Recalculate Bounding Box button to align the selected 3D Solid's bounding box with the 
current plan's Cartesian grid and position its origin point at a bottom corner of the bounding box.

  Elevation

 l Select the Elevation Reference from the drop-down list. This determines where the next two settings are measured 
from and also affects their setting labels.      

 l Specify the to Top distance, measured from the Elevation Reference to the top of the object.      

 l Specify the to Bottom distance, measured from the Elevation Reference to the bottom of the object.    

 
Rotation

These settings allow you to rotate the selected shape(s) about the X, Y, and Z axes.    

 l Select the X, Y, or Z Axis that you want to rotate the shape about.

 l Specify the Angle to rotate the shape in the text field. 90° is set by default.    

 l Click the Rotate + button to rotate the object around the selected axis in a clockwise direction.    

 l Click the Rotate - button to rotate the object around the selected axis in a counterclockwise direction.    

 
3D Surface Quality 

These settings control how any curved surfaces on the selected object are rendered in 3D views. 

 l Check Automatic to have the program define the Maximum Deflection, which is the amount each flat, triangular 
surface used to represent a curved surface in 3D can deviate from the true curvature of the object. For more 
information about triangles, see Edge Smoothing on page 1132.

 l Specify the Maximum Deflection in plan inches (mm). This value is the maximum distance that a point on a 
triangle can be from the true location of the curved surface. Lower values produce more triangles and a smoother 
appearance in 3D views. 

 
Preview

A preview of the object displays on the right side of the dialog box. See Dialog Preview Panes on page 22.

POLYLINE PANEL

The POLYLINE panel states the length of the object’s Perimeter, its Area, and its Volume. See Polyline Panel on page 323. 
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If the selected solid has any Holes, they will be subtracted from the Area and Volume values. See Polyline Holes on page 
234.

SELECTED LINE/ARC PANEL

The SELECTED LINE panel is available when the selected edge is a line as opposed to an arc. For more information, see Line 
Panel on page 309.

The SELECTED ARC panel is available when the selected edge has been converted to an arc. For more information, see Arc 
Panel on page 318.

See, too, Selected Edge on page 214 and Change Line/Arc on page 259.

LINE STYLE PANEL

For information about the settings on this panel, see Line Style Panel on page 310.

FILL STYLE PANEL

The settings on the FILL STYLE panel affect the appearance of the selected shape in plan view. See Fill Styles on page 197.   

MATERIALS PANEL

For information about the settings on this panel, see Materials Panel on page 1055.

LABEL PANEL

3D Solid labels display when the “Polylines 3D, Labels” layer is turned on and use the Text Style assigned to that layer. The 
Automatic Label for 3D solids is blank, but you can specify a custom label. For information about the settings on this panel, 
see Label Panel on page 712.

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 1335.

 

Sphere Specification Dialog
Select a sphere and click the Open Object edit button to open the Sphere Specification dialog.
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Center Point

Specify the Center Point of the selected sphere in relation to the origin point of your plan. See Entering Coordinates on 
page 170.    

 l Enter the X, Y, and Z Position coordinates of the sphere’s center point.

 
Size

Specify the Radius of the selected sphere. 

  Elevation

 l Select the Elevation Reference from the drop-down list. This determines where the next two settings are measured 
from and also affects their setting labels.      

 l Specify the to Top distance, measured from the Elevation Reference to the top of the sphere.      

 l Specify the to Bottom distance, measured from the Elevation Reference to the bottom of the sphere.      

 
3D Surface Quality

These settings control how any curved surfaces on the selected object are rendered in 3D views. 

 l Check Automatic to have the program define the Maximum Deflection, which is the amount each flat, triangular 
surface used to represent a curved surface in 3D can deviate from the true curvature of the object. For more 
information about triangles, see Edge Smoothing on page 1132.

 l Specify the Maximum Deflection in plan inches (mm). This value is the maximum distance that a point on a 
triangle can be from the true location of the curved surface. Lower values produce more triangles and a smoother 
appearance in 3D views. 

 
Preview

A preview of the sphere displays on the right side of the dialog box. See Dialog Preview Panes on page 22.

LINE STYLE PANEL

For information about the settings on this panel, see Line Style Panel on page 310.
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FILL STYLE PANEL

The settings on the FILL STYLE panel affect the appearance of the selected sphere in plan view. See Fill Styles on page 197.   

MATERIALS PANEL

For information about the settings on this panel, see Materials Panel on page 1055.

LABEL PANEL

Primitive labels display when the “Polylines 3D, Labels” layer is turned on and use the Text Style assigned to that layer. 
The Automatic Label for Primitives is blank, but you can specify a custom label. For information about the settings on this 
panel, see Label Panel on page 712.

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 1335.

 

Cylinder Specification Dialog
Select a cylinder and click the Open Object edit button to open the Cylinder Specification dialog.

 
Center Point

Specify the Center Point of the selected cylinder’s base in relation to the origin point of your plan. See Entering 
Coordinates on page 170.

 l Enter the X, Y, and Z Position coordinates of the cylinder’s center point.

 
Size

Specify the Radius and Height of the selected cylinder. 
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  Elevation

 l Select the Elevation Reference from the drop-down list. This determines where the next two settings are measured 
from and also affects their setting labels.      

 l Specify the to Top distance, measured from the Elevation Reference to the top of the object.      

 l Specify the to Bottom distance, measured from the Elevation Reference to the bottom of the object.      

 
Rotation

The Rotation settings allow you to rotate the selected cylinder about the X, Y, and Z axes. See 3D Drafting on page 12.    

 l Select the X, Y, or Z Axis as the axis around which the cylinder will rotate.    

 l Specify the Angle to rotate the cylinder in the text field. The default value is 90°.    

 l Click the Rotate + button to rotate the cylinder around the selected axis in a clockwise direction.    

 l Click the Rotate - button to rotate the cylinder around the selected axis in a counterclockwise direction.

 
3D Surface Quality

These settings control how any curved surfaces on the selected object are rendered in 3D views.    

 l Check Automatic to have the program define the Maximum Deflection, which is the amount each flat, triangular 
surface used to represent a curved surface in 3D can deviate from the true curvature of the object. For more 
information about triangles, see Edge Smoothing on page 1132.    

 l Specify the Maximum Deflection in plan inches (mm). This value is the maximum distance that a point on a 
triangle can be from the true location of the curved surface. Lower values produce more triangles and a smoother 
appearance in 3D views. 

 
Preview

A preview of the cylinder displays on the right side of the dialog box. See Dialog Preview Panes on page 22.

LINE STYLE PANEL

For information about the settings on this panel, see Line Style Panel on page 310.

FILL STYLE PANEL

The settings on the FILL STYLE panel affect the appearance of the selected cylinder in plan view. See Fill Styles on page 
197.   

MATERIALS PANEL

For information about the settings on this panel, see Materials Panel on page 1055.

LABEL PANEL

Primitive labels display when the “Polylines 3D, Labels” layer is turned on and use the Text Style assigned to that layer. 
The Automatic Label for Primitives is blank, but you can specify a custom label. For information about the settings on this 
panel, see Label Panel on page 712.
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COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 1335.

 

Cone Specification Dialog
Select a cone and click the Open Object edit button to open the Cone Specification dialog.

 
Base Center Point

Specify the Base Center Point of the selected cone in relation to the origin point of your plan. See Entering Coordinates on 
page 170.

 l Enter the X, Y, and Z Position coordinates of the center point of the cone’s base.

 
Size

Specify the Radius and Height of the selected cone. 

  Elevation

 l Select the Elevation Reference from the drop-down list. This determines where the next two settings are measured 
from and also affects their setting labels.      

 l Specify the to Top distance, measured from the Elevation Reference to the top of the object.      

 l Specify the to Bottom distance, measured from the Elevation Reference to the bottom of the object.      
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Rotation

The Rotation settings allow you to rotate the selected cone about the X, Y, and Z axes. See 3D Drafting on page 12.    

 l Select the X, Y, or Z Axis as the axis around which the cone will rotate.    

 l Specify the Angle to rotate the cone in the text field. The default value is 90°.    

 l Click the Rotate + button to rotate the cone around the selected axis in a clockwise direction.    

 l Click the Rotate - button to rotate the cone around the selected axis in a counterclockwise direction.

 
3D Surface Quality

These settings control how any curved surfaces on the selected object are rendered in 3D views. 

 l Check Automatic to have the program define the Maximum Deflection, which is the amount each flat, triangular 
surface used to represent a curved surface in 3D can deviate from the true curvature of the object. For more 
information about triangles, see Edge Smoothing on page 1132.

 l Specify the Maximum Deflection in plan inches (mm). This value is the maximum distance that a point on a 
triangle can be from the true location of the curved surface. Lower values produce more triangles and a smoother 
appearance in 3D views. 

 
Preview

A preview of the cone displays on the right side of the dialog box. See Dialog Preview Panes on page 22.

LINE STYLE PANEL

For information about the settings on this panel, see Line Style Panel on page 310.

FILL STYLE PANEL

The settings on the FILL STYLE panel affect the appearance of the selected cone in plan view. See Fill Styles on page 197.   

MATERIALS PANEL

For information about the settings on this panel, see Materials Panel on page 1055.

LABEL PANEL

Primitive labels display when the “Polylines 3D, Labels” layer is turned on and use the Text Style assigned to that layer. 
The Automatic Label for Primitives is blank, but you can specify a custom label. For information about the settings on this 
panel, see Label Panel on page 712.

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 1335.
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Pyramid Specification Dialog
Select a pyramid and click the Open Object edit button to open the Pyramid Specification dialog.

 
Base Center Point

Specify the Base Center Point of the selected pyramid in relation to the origin point of your plan. See Entering 
Coordinates on page 170.

 l Enter the X, Y, and Z Position coordinates of the center point of the pyramid’s base.

 
Height

Specify the Height of the selected pyramid.    

 l Specify the height of the Apex, measured from the base to the peak.

 l Check Truncated to cut off the top of the pyramid and create a flat top.    

 l Specify the Height of a truncated pyramid, measured from the base to the flat truncated top.
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Base Shape

Specify the selected pyramid’s Base Shape.

 l Specify what you would like the pyramid’s size to be Defined By:

 l Select Side Length to enable the Side Length field to the right and specify the length of each side of the pyramid’s 
base. 

 l Select Radius to Corner to define the distance from the center point of the pyramid’s base to any of its corners. 

 l Select Radius to Side to define the distance from the center point of the pyramid’s base to the midpoint of any of its 
edges. 

 l Specify the Number of Sides that the selected pyramid has. The default value is 4.

 l Specify the Side Length, which is the corner to corner length of one each side of the pyramid’s base. Only available 
when Define Polyline by Side Length is selected to the left.

 l Specify the Radius of the pyramid’s base, as measured from its center point to a corner or to the midpoint of a side. 
Only available when Define Polygon by Radius to Corner or Radius to Side is selected.

  Elevation

 l Select the Elevation Reference from the drop-down list. This determines where the next two settings are measured 
from and also affects their setting labels.      

 l Specify the to Top distance, measured from the Elevation Reference to the top of the object.      

 l Specify the to Bottom distance, measured from the Elevation Reference to the bottom of the object.      

 
Rotation

The Rotation settings allow you to rotate the selected pyramid about the X, Y, and Z axes. See 3D Drafting on page 12.    

 l Select the X, Y, or Z Axis as the axis around which the pyramid will rotate.    

 l Specify the Angle to rotate the pyramid in the text field. The default value is 90°.    

 l Click the Rotate + button to rotate the pyramid around the selected axis in a clockwise direction.    

 l Click the Rotate - button to rotate the pyramid around the selected axis in a counterclockwise direction.

 
Preview

A preview of the pyramid displays on the right side of the dialog box. See Dialog Preview Panes on page 22.

LINE STYLE PANEL

For information about the settings on this panel, see Line Style Panel on page 310.

FILL STYLE PANEL

The settings on the FILL STYLE panel affect the appearance of the selected pyramid in plan view. See Fill Styles on page 
197.   

MATERIALS PANEL

For information about the settings on this panel, see Materials Panel on page 1055.
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LABEL PANEL

Primitive labels display when the “Polylines 3D, Labels” layer is turned on and use the Text Style assigned to that layer. 
The Automatic Label for Primitives is blank, but you can specify a custom label. For information about the settings on this 
panel, see Label Panel on page 712.

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 1335.

 

General Shapes
Items in the Chief Architect Core Catalogs> Shapes library catalog allow you to create a variety of custom objects 
using basic geometric shapes. These shapes can be used individually or combined to create a wide variety of custom 

objects. 

General Shape objects are placed and edited much like other library objects. See Editing Box-Based Objects on page 234.

 

Soffits
Soffits typically fill the space between the tops of wall cabinets and the ceiling, but they are very versatile and can be 
used to create almost any other object that can be modeled as a 3D box. Select Build> Cabinet> Soffit to activate 

this tool.         

SOFFIT DEFAULTS

The default settings for soffits are set in the Soffit Defaults dialog. The settings in this dialog are similar to those in 
the Soffit Specification dialog. See Soffit Specification Dialog on page 1034.         

When a soffit is created, it is placed on the “Cabinets, Soffits” layer. See Layer Attributes on page 181.          

For best results when placing soffits above wall cabinets:         

 l The default soffit should be the same width as and 1" (20mm) deeper than the default wall cabinet. See Cabinet 
Defaults on page 629.          

 l The default soffit Floor to Bottom value should equal the sum of the default wall cabinet’s Floor to Bottom value plus 
its Height. See General Panel on page 1035.         

 l The default soffit Height should be equal to or greater than the space between the ceiling and the top of the wall 
cabinets.          

If the sum of the default soffit’s Floor to Bottom value and Height is larger than the ceiling height of the room in which a 
soffit is placed, the Floor to Bottom value will be retained and its Height will be adjusted so that it fits under the ceiling.          

The maximum soffit width is 250 feet (48m), and the minimum width is 1/16" (1 mm).         

Once a soffit is placed in a plan, you can change its size and position to meet a variety of needs. See Editing Box-Based 
Objects on page 234.    
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PLACING SOFFITS

Soffits can be created in both 2D and 3D views by simply clicking with the Soffit  tool active. See Click-to-Create on 

page 168.          

To create a corner soffit, click as close to an inside wall corner as possible. A corner soffit retains its shape when it is 
moved, edited, or copied.          

When positioned against a wall in a room, soffits will automatically display any moldings present in that room that are at 
the same height as the soffit. Soffits can also have custom molding profiles assigned to them. See Moldings Panel on page 
452.         

When positioned against the ceiling in a room, a soffit will prevent the Ceiling Finish layers directly above it from 
generating in 3D. See Lowered Ceilings on page 439.          

CALCULATING MATERIALS ON SOFFITS

The number of bricks, tiles, shingles, shakes or other materials applied to a soffit is calculated using the following rules:   

 l If the soffit depth is less than the larger of 4 inches (10 mm) or 1 ½ times the material thickness, then only the front 
area of the soffit is used. Thus if a soffit is 48"x48"x4" thick, and the Dark Red brick material is used (3"x 8" with 
3/8" mortar joint), the front of the soffit is 48"x48"=2304 square inches. Including the mortar joint, each brick requires 
3 3/8" x 8 3/8" = 28.26 square inches. 2304 sq. in. divided by 28.26 sq. in. per brick gives 81.5 bricks.    

 l If the soffit depth is greater than both 4 inches (10 mm) and 1 ½ times the material thickness, then the surface areas of 
the soffit back, sides and top are used in addition to the front, if these surfaces are not attached to a wall or other soffit. 
However, only those portions of the sides, top and bottom remaining after subtracting twice the material thickness are 
used. So, for Dark Red brick, which has a depth of 4", the sides, top and bottom surface areas cannot contribute to the 
brick count unless the soffit depth is greater than 8 inches.    

 l If surface materials such as brick are applied to a large soffit, the soffit center is assumed to be hollow, with only a 
single layer of the material applied to each applicable face.    

 l For shingles and shakes, the overlap amount should be subtracted from the height, as opposed to brick or tile, where 
the joint width is added to the size.    

 l For materials in the area category, the soffit area calculation above is used, with the material thickness treated as zero.    
 l For materials in the volume, concrete or earth categories, the true volume of the soffit is used.    

 

Soffit Specification Dialog
To open the Soffit Specification dialog, select the soffit and click the Open Object edit button or double-click on a 
soffit using the Soffit               tool.         

The settings in this dialog are similar to those in the Soffit Defaults dialog, but affect only the selected object(s).          

The Soffit Specification dialog has the following panels:
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GENERAL PANEL

 
Size/Position

Define the Size and Position of the selected soffit relative to the floor              or terrain.          

 l Specify the Width of the soffit.          

 l Define the vertical Height of the soffit.          

 l Define the Depth, which is the distance between the front and the back of the soffit. When selected in plan view, the 
front of a soffit has a “V,” and the back of the soffit has a triangular rotation handle.         

 l If the selected soffit is a corner soffit, the Width controls its left side width, and Depth controls its right side width.          

 l Specify the distance from Floor to Top of the soffit.         

 l Specify the distance from Floor to Bottom of the soffit.          

 l When the selected soffit is outside a room, its Floor to Bottom height is measured relative to the terrain. Check Auto 
Adjust Height to maintain the same distance above the terrain if the soffit is moved to a location with different 
terrain height. Uncheck this to maintain the same absolute height regardless of the terrain below. When Auto Adjust 
Height is checked, the Floor to Bottom value may automatically adjust if the soffit is moved.         

 l Check Use Floor Finish to measure the Floor to Bottom distance from the surface of the floor finish. When 
unchecked, this height is measured from the subfloor. Only available when Auto Adjust Height is checked.           

 l Check Sloped Soffit to slope the soffit vertically from the back up towards the front. This may become checked 
automatically if you check Place Under Ceiling or Place Under Roof, below. When you specify a soffit as sloped, 
the available options on this panel change. See  General Panel - Sloped Soffits on page 1036, below.

 l The Height at Back Face and Front Face settings become enabled when Sloped Soffit is checked. See  General 
Panel - Sloped Soffits on page 1036, below.         
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  Options

 l Check Place Under Ceiling to adjust the soffit’s height so its top contacts the ceiling above.                  If the soffit is below a 
sloped ceiling plane, Sloped Soffit will become checked and the Height at Back and Front Face will adjust to match 
the pitch. Not available in the Soffit Defaults dialog, or if the soffit is not below a ceiling.             

 l Check Place Under Roof to adjust the soffit’s height so its top contacts the bottom of the roof above.                  Provided that 
the roof above does not have a pitch of 0, Sloped Soffit will become checked and the Height at Back and Front Face 
will adjust to match the pitch. Not available in the Soffit Defaults dialog, or if there is no roof above the soffit.             

 l Check Ignore Room Moldings to prevent the selected soffit from displaying moldings assigned to the room that it is 
placed in. See Room Moldings on page 441.          

 l Check Include in Schedule to include the selected soffit in a Cabinet Schedule. See Cabinet Schedules on page 640.           

 
Preview

A preview of the soffit displays on the right side of the dialog box. See Dialog Preview Panes on page 22.         

 GENERAL PANEL - SLOPED SOFFITS

When a soffit is specified as sloped, the available options on the GENERAL panel of the Soffit Specification dialog change.          

 l Width is measured left to right across the soffit, parallel to the front of the soffit.             
 l Thickness is the top-to-bottom height of the front and back faces of the soffit.         
 l Horizontal Length is measured from back to front in plan view. When a soffit is sloped, this measurement is not the 

actual length of the soffit’s bottom or top edge. It cannot, for example, be used to determine the length of a sloped 
beam.         

Both the front and back heights of a sloped soffit must be defined. Checking Place Under Ceiling or Place Under Roof will 
automatically adjust these values to match the slope of the ceiling or roof plane above.

 l Height at Back Face is measured from the finished floor to the lowest point at the back of the soffit.         
 l Height at Front Face is measured from the finished floor to the underside of the soffit at the upper end.         

MOLDINGS PANEL

The settings on the MOLDINGS panel allow you to assign one or more horizontal moldings around the selected soffit.    

For information about the settings on this panel, see Moldings / Profiles Panels on page 943.   
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LAYER PANEL

For information about the settings on this panel, see Layer Panel on page 191.    

FILL STYLE PANEL

The settings on the FILL STYLE panel affect the selected soffit’s appearance in plan view. For information about the settings 
on this panel, see Fill Styles on page 197.    

MATERIALS PANEL

For information about the settings on this panel, see Materials Panel on page 1055.   

LABEL PANEL

Soffit labels display in plan view when the “Cabinets, Labels” layer is turned on and use the Text Style assigned to that 
layer. The Automatic Label for Soffits is blank, but you can specify a custom label.    See Cabinet Labels on page 641.

For more information about the settings on this panel, see     Label Panel on page 712.   

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 1335.    

OBJECT INFORMATION PANEL

The information entered on the OBJECT INFORMATION panel can be used in schedules and the materials list. For more 
information, see Object Information Panel on page 1336.   

SCHEDULE PANEL

The settings on the SCHEDULE panel determine which schedule categories the selected soffit is included in. See Schedule 
Panel on page 716.   

 

Floor and Wall Material Regions
Floor and Wall Material Regions allow you to create areas within a wall or floor that use different materials than the 
parent object. There are three types of Material Regions:          

Material Regions are CAD-based objects composed of one or more layers. The thickness of these layers and their materials 
can be set in the Material Region Specification dialog. See Material Region Specification Dialog on page 1039.          

By default, Material Regions use the materials specified in the Floor and Wall Material Region Defaults dialogs. See 
Default Settings on page 76.          

By default, a Material Region cuts into the finish layers of its parent object and replaces those layers with its own within its 
perimeter; it can, however, can be affixed to the parent’s surface instead if you prefer.          
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In general, Material Regions are created and edited in the same manner that other closed polylines are. Bear in mind that 
their shapes can only be edited in the view type in which they were created and that Floor Material Regions cannot be 
moved in cross section/elevation views. See Polylines on page 322 and Editing Closed Polyline-Based Objects on page 230.          

You can also convert a closed CAD polyline into a Material 
Region in floor plan and cross section/elevation views. See 

Convert Polyline on page 265.

Like most other architectural objects, a Material Region can be added to the library. Its material layers and the information 
in its specification dialog are saved; however, the shape of its polyline is not. See Add to Library on page 973.          

Material Regions can span multiple parent objects; however, for best results the parent objects should have structural, or 
Main, layer surfaces that are in alignment.           

CUSTOM BACKSPLASHES

To create a Custom Backsplash, select Build> Cabinet> Custom Backsplash. Custom Backsplashes are drawn on 
the vertical surface of a wall and are always drawn in camera or elevation views. If you create one by clicking once, 

it will behave the way a Wall Material Region would, provided that no cabinets or appliances are positioned against the 
wall.   

The initial attributes of Custom Backsplashes are set in the Custom Backsplash Defaults dialog. See Cabinet Defaults on 
page 629.    

If any cabinets and/or appliances are present, a Custom Backsplash will:    

 l Seek to fill the area between any base cabinets or floor appliances against that wall surface and any wall cabinets 
and/or windows above them.      

 l If nothing is above any base cabinets, it will fill the area between the cabinets and the ceiling; if nothing is below any 
wall cabinets, it will fill the area between the cabinets and the floor.      

 l Replace the backsplash associated with any base or wall cabinets.      

Like Wall Material Regions, Custom Backsplashes set to cut the finish layers of their parent object will replace the layers of 
the wall between itself and the wall’s Main Layer with its own layers.     

FLOOR MATERIAL REGIONS

To create a Floor Material Region, select Build> Floor> Material Region. Floor Material Regions must be drawn 
within a room area and are always drawn in plan view. If you create one by clicking once, it will fill the extents of 

the room.         

Floor Material Regions set to cut the finish layers of their parent object will replace the layers of that floor’s Finish 
Definition with its own layers. See Floor and Ceiling Platform Definitions on page 434.           

WALL MATERIAL REGIONS

To create a Wall Material Region, select Build> Wall> Material Region. Wall Material Regions are drawn on the 
vertical surface of a wall and are always drawn in camera or elevation views. If you create one by clicking once, it 

will cut around doors, windows, and fireplaces but will otherwise fill the entire surface of the parent wall.         

Wall Material Regions set to cut the finish layers of their parent object will replace the layers of the wall between itself and 
the wall’s Main Layer with its own layers. See Wall Type Definitions on page 388.          
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Material Region Specification Dialog
Select a Material Region or a Custom Backsplash and click the Open Object edit button to open the Material Region 
or Custom Backsplash Specification dialog.

The settings in these two dialogs are also found in the Material Region Defaults dialogs, and most of its panels are also 
found in the specification dialogs for a variety of other CAD-based objects.

STRUCTURE PANEL

 l The total thickness of the Material Layers displays here for reference.
 l Click the Edit button to open the Material Layers Definition dialog. See Material Layers Definition Dialogs on page 

1040. 
 l Uncheck Cut Finish Layers of Parent Object to fix the selected Material Region to the surface of its parent floor 

platform or wall. When checked, it cuts into the finish layers of the polyline’s parent object and replaces those layers 
with its own within its perimeter. 

POLYLINE PANEL

The POLYLINE panel indicates the length of the region’s Perimeter and its enclosed Area. See Polyline Panel on page 323.

If the selected region has any Holes in it, they will be subtracted from the Area and Volume values. See Polyline Holes on 
page 234. 

SELECTED LINE/ARC PANEL

The SELECTED LINE panel is available when the selected edge is a line as opposed to an arc. See Line Panel on page 309.

The SELECTED ARC panel is available when the selected edge has been converted into an arc. See Arc Panel on page 318.

See, too, Selected Edge on page 214 and Change Line/Arc on page 259.

LINE STYLE PANEL

For information about the settings on this panel, see Line Style Panel on page 310.

FILL STYLE PANEL

The FILL STYLE panel is only available for Floor Material Regions. For information about the settings on this panel, see Fill 
Styles on page 197.
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LABEL PANEL

Material Region labels display in floor plan and cross section/elevation views when the “Polylines 3D, Labels” layer is 
turned on and use the Text Style assigned to that layer. The Automatic Label for Material Regions is blank, but you can 
specify a custom label.

For information about the settings on this panel, see Label Panel on page 712.

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 1335.

OBJECT INFORMATION PANEL

The information entered on the OBJECT INFORMATION panel can be used in schedules and the materials list. For more 
information, see Object Information Panel on page 1336.   

SCHEDULE PANEL

The settings on the SCHEDULE panel determine which schedule categories the selected object is included in. See Schedule 
Panel on page 716.

 

Material Layers Definition Dialogs
The Material Layers Definition dialogs allow you to define the layers that make up wall, floor, ceiling, slab, and roof 
assemblies. The names of these dialogs vary and are determined by the type of object or component being edited. They 
include:

 l Backsplash Layers Definition Dialog
 l Ceiling Structure Definition
 l Ceiling Finish Definition         
 l Floor Structure Definition
 l Floor Finish Definition         
 l Roof Surface Definition         
 l Roof Structure Definition         
 l Roof Ceiling Finish Definition         

See Floor and Wall Material Regions on page 1037, Floor and Ceiling Platforms on page 433, and Roof Planes on page 
819.         
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Layers

The selected  assembly’s layers are numbered and listed from the top of the structure to its bottom. To select a layer for 
editing, click in its row.

 l Click in the Material, Pattern, or Texture column to open the Select Material dialog and choose a material for the 
selected layer. See Select Material/Library Object Dialog on page 1057.     

 l Click in the Fill column to open the Layer Fill Style dialog and define a fill style for the selected layer. This fill style 
is applied when the Auto Detail  tool is used in a cross section view. See Fill Styles on page 197.             

 l Click in the Thickness column to type the selected layer’s thickness or depth. Very thin layers can be created, but 
for best results avoid using a thickness of 0. For very small values, it can be helpful to temporarily change the dialog 
number format: click the Number Style button.          

 l The Total Thickness of the assembly displays to the right as a reference.          

 l Select a Structure Type from the drop-down list. Only available when the selected material is a Framing type. See 
Framing Materials and Types on page 896.           

The buttons to the right of the table allow you to reorganize the assembly’s layers.    

 l Click the Insert Above button to create a new layer directly above the currently selected layer in the assembly.    

 l Click the Insert Below button to create a new layer directly below the currently selected layer in the assembly.    

 l Click the Move Up button to swap the selected layer’s position with that of the layer above it. Not available for the 
top-most layer of the assembly.    

 l Click the Move Down button to swap the selected layer’s position with that of the layer below it. Not available for 
the bottom-most layer of the assembly.    

 l Click Delete to remove the selected layer.            
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Energy Values

Specify the selected Floor Structure or Ceiling Structure’s energy values, which are used when exporting to REScheck. Only 
available for Floor Structure and Ceiling Structure Definitions. See Export to REScheck on page 1247.         

 l Specify the structure’s Cavity R-Value, which is the R-value of its cavity insulator: most commonly, the insulation 
between wood or metal joists.          

 l Specify the Continuous R-Value, which is the R-value of continuous insulators such as rigid foam sheets.           

 
Structure

Specify whether the selected layer has special structural attributes.    

 l Check Framing to produce framing in the selected layer when framing is generated for the selected structural 
assembly's type. See Build Framing Dialog on page 873.    

 l Select the framing Type from the drop-down list. See Displaying Framing on page 894.     

 l In the Roof Structure Definition dialog, you can also check Include Structural Purlins to include structural purlins 
that run between and perpendicular to the rafters. Only available when Framing is checked, above.

 l  In the Roof Surface and Roof Ceiling Finish Definition dialogs, you can instead check Include Purlins to produce 
non-structural framing that runs perpendicular to the roof or ceiling plane's rafters. In either case:    

 o Select the purlin framing Type from the drop-down list. See Displaying Framing on page 894.    

 o Specify the on-center Spacing of purlins, measured along the direction of the pitch.

 o Specify the vertical Thickness and the Width of the purlins.    

 o Check Max Length, then specify the maximum allowed length for non-structural purlins used in Roof Surface and 
Ceiling Finish Definitions only.    

 o Specify the Bottom Run Offset, which is the distance of from the lowest purlin to the rafter ends, measured along 
the pitch of the roof or ceiling rather than horizontally.    

 o Specify the Top Run Offset, which is the distance from the highest purlin to the ridge, measured along the pitch of 
the roof or ceiling.    

 o Check Use Equal Spacing to space purlins equally between the bottom and top runs, using as close to the Spacing 
value specified above as possible.    

 o Select whether Structural Purlins are Flush Against the Exterior or top edge of the rafters, or the Interior or bottom 
edge of the rafters. Only available in the Roof Structure Definition dialog.    

 l Check Auto Detail as Insulation to generate Insulation boxes in the selected layer when Auto Detail  is used in 

cross section views. See Auto Detail on page 1095.    

 l Check Air Gap to prevent the selected layer from displaying in 3D views or being calculated in the Materials List. 
See Creating an Accurate Materials List on page 1311.    

 
Preview

A preview of the selected assembly displays here. See Dialog Preview Panes on page 22.         

 l By default, a gap is shown between each of the assembly layers. Click the Explode Layers  button to remove or 

restore these gaps.          
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Distributed Objects
The Distributed Object tools allow you to place multiple copies of an object in an evenly spaced array, either within 
a region or along a path. Select Build> Distributed Object to access these tools.         

To create distributed objects
 1.  Select Build> Distributed Object and choose the desired Distributed Object tool.          

 2.  Distribution regions are drawn like other closed polyline and spline-based objects.          

 l Click once to place a region with endpoints that form a 10’ (4 m) square.           

 l Click and drag from end to end to draw a region sized as needed.           

 3.  Distribution paths are drawn like other open polyline and spline-based objects.           

 l Click and drag from end to end to draw one or more connected lines or spline segments.           

 4.  Select the region and click the Open Object  edit button.          

 5.  In the Distribution Region Specification dialog:           

 l Select the object to be distributed within the region.          

 l Specify the distributed objects’ spacing, orientation and positioning.          

 l Click OK to close the dialog. See Distribution Region/Path Specification Dialogs on page 1044.         

Once created, Distribution Regions and Paths can be edited into nearly any shape you require. See Editing Closed Polyline-
Based Objects on page 230 and Editing Spline-Based Objects on page 237.          

You can replace the object assigned to a Distribution Region or 
Path by applying a new one directly from the library. See 

Replace From Library on page 983.   

All objects associated with a Distribution Path or Region will be listed in a schedule or materials list for a particular room if 
the center point of the path or region is located inside the room. If the center point of the path or region is not located in the 
room, none of its objects will be listed. See Create Schedule from Room on page 696 and Calculate Materials in Room on 
page 1310.           

EXPLODE DISTRIBUTED OBJECTS

Objects grouped in a Distribution Region or Path cannot be individually selected. You can, however, click the 
Explode Distributed Object edit button to separate a region or path into its individual components.  Once exploded, 

a Distribution Region or Path cannot be regrouped.         
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Distribution Region/Path Specification Dialogs
Select a Distribution Region or Path and click the Open Object edit button to open the Distribution Region or 
Distribution Path Specification dialog.

The settings in these two dialogs are similar and most panels are also found in the specification dialogs for a variety of other 
CAD-based objects.

             DISTRIBUTED OBJECT PANEL - DISTRIBUTION REGION

 
Current Object

Specify the Current Object assigned to the selected region. When an object is assigned, its name and a preview of a single 
instance of it display here.    

 l Click the Select button to choose an object from the library. See Select Library Object Dialog on page 982.    

 l Click the Delete button to unassign the Current Object from the selected region.    

 l Click the Edit button to open the Current Object’s specification dialog. Changes made here affect all objects 
generated within the region. See Specification Dialogs on page 21.    

You can replace the object assigned to a Distribution Region or 
Path by applying a new one directly from the library. See 

Replace From Library on page 983.
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  Display Options

 l Check Show Objects to display the distributed objects in plan view.

 l Check Show Region to display the distribution region outline in plan view.

 
Object Spacing

Specify how the objects in the region are spaced. 

 l Specify the Distance between the objects in the region, as measured from their center points. 

 l Objects in the region can be randomly offset from their default positions if you wish. Specify their Maximum 
Offset, measured from their center points. Not available when Evenly Scattered is selected, below.

 l Select Standard Grid to position the objects in rows and columns based on the standard X/Y grid in the program. 
This grid is affected by Rotate Plan View. See Rotate Plan View on page 151. 

 l Select Alternate Grid to position the objects in rows and columns based on the shape of the region. 

 l Select Evenly Scattered to distribute the objects evenly but not on a grid layout. 

 
Object Orientation

Specify how or if the objects in the region are rotated. These settings do not affect the region itself or its edges.

 l Specify the Angle that the distributed objects should be placed at. 

 l Select Absolute Angle to rotate the objects relative to an imaginary horizontal line drawn in the positive X direction 
from the origin. See 3D Drafting on page 12. 

 l Select Relative Angle to rotate the objects relative to the angle of the region’s first edge or, if that edge is curved, to 
the angle of its chord. The first edge is typically located at the top of the region when it is first created; however, this 
can change as the region is edited.

 l Select Random Angle to rotate the objects in the region at a variety of random angles. 

 
Object Positioning

Specify the positioning of the distributed objects relative to a point of origin within the region. 

 l Specify the X Offset, the horizontal distance in plan view from the region’s specified point of origin. 

 l Specify the Y Offset, the vertical distance in plan view from the region’s specified point of origin. 

 l Select Offset From Polyline Start to measure the offset from the region’s start point. This start point is typically 
located at the top left of the region when it is first created; however, this can change as the region is edited. 

 l Select Offset From Polyline Center to measure the offset from the region’s center point. 

 
Object Scaling

Check Object Scaling to specify a range of size variation of the objects in the region. 

 l Specify the Minimum Scale, which is the smallest resize of the objects allowed. 

 l Specify the Maximum Scale, which is the largest resize of the objects allowed.
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Preview

A preview of the region displays on the right side of the dialog box. If no object has been assigned to the selected region, 
Plan View will be the default preview type. See Dialog Preview Panes on page 22. 

DISTRIBUTED OBJECT PANEL - DISTRIBUTION PATH

 
Current Object

Specify the object assigned to the selected path. When an object is assigned, its name and a preview of a single instance of it 
display here.

 l Click the Select button to choose an object from the library. See Select Library Object Dialog on page 982.

 l Click the Delete button to unassign the Current Object from the selected path.

 l Click the Edit button to open the Current Object’s specification dialog. Changes made here affect all objects 
distributed along the path. See Specification Dialogs on page 21.

  Display Options

 l Check Show Objects to display the distributed objects in plan view.

 l Check Show Path to display the distribution path in plan view.
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Object Spacing

Specify how the objects along the path are spaced.

 l Select Distance Between Object Centers, then specify the distance between all object centers. If the path is resized, 
the total number of objects may change. 

 l Specify the Minimum Distance between object centers.

 l Specify the Maximum Distance between object centers.

 l Select Number of Evenly Distributed Objects, then specify the number of objects. If the path is resized, the 
spacing between objects may change. 

 
Object Orientation

Specify how or if the objects on the path are rotated. 

 l Specify the Angle that the distributed objects should be placed at. 

 l Select Absolute Angle to rotate the objects to the specified Angle as measured from an imaginary horizontal line 
drawn from the origin towards the right. 

 l Select Relative Angle to rotate each object relative to the edge of the polyline or spline that it is located on.

 l Select Random Angle to rotate the objects in the region at a variety of random angles. 

 
Object Positioning

Specify the positioning of the distributed objects relative to the path itself. 

 l Specify the Minimum Side Offset, which is the smallest distance objects can be offset from the path.

 l Specify the Maximum Side Offset, which is the largest distance objects can be offset from the path.

 l The Side Offset Options control which side or sides of the path objects offset to.

 l Select One Sided to offset objects on the left side of the path, as viewed from its starting point. 

 l Select Alternate Sides to position objects on alternating sides of the path, creating a stepped pattern. 

 l Select Random Sides to position objects on both sides in a random pattern.

 l Specify the Start Offset, the distance that the first object on the path is offset from the path’s starting point. 

 
Object Scaling

Check Object Scaling to specify a range of size variation of the objects along the path. 

 l Specify the Minimum Scale, which is the smallest resize of the objects allowed. 

 l Specify the Maximum Scale, which is the largest resize of the objects allowed.

 
Preview

A preview of the path displays on the right side of the dialog box. If no object has been assigned to the selected path, Plan 
View will be the default preview type. See Dialog Preview Panes on page 22.

POLYLINE PANEL

The POLYLINE panel states the length of the region’s Perimeter and its enclosed Area. See Polyline Panel on page 323. 
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SPLINE PANEL

The SPLINE panel has a single option and is only available when the selected object is spline-based. See Splines on page 
330.

New Segment Angle - Specify the angle between line segments that are used to draw the spline. Specifying a smaller angle 
makes the spline smoother. Specify a larger angle to draw the spline faster.

SELECTED LINE PANEL

The SELECTED LINE panel is available when the selected edge of the region or path is a line as opposed to an arc. See 
Selected Edge on page 214.

Moving the Start of a line segment moves the end of the previous connected line, if there is one. Similarly, moving the End 
of a line segment moves the start of the next connected line, if there is one.

The settings this panel are found in a variety of specification dialogs throughout the program. See Line Panel on page 309.

SELECTED ARC PANEL

The SELECTED ARC panel is available when the selected edge of the region or path is an arc as opposed to a line. See 
Change Line/Arc on page 259.

The settings on this panel are found in a variety of specification dialogs throughout the program. See Arc Panel on page 
318.

LINE STYLE PANEL

For information about the settings on this panel, see Line Style Panel on page 310.

FILL STYLE PANEL

The FILL STYLE panel is only available for a selected Distribution Path if it forms a closed shape. 

For information about the settings on this panel, see Fill Styles on page 197.

ARROW PANEL

The ARROW panel is only available for Distribution Paths that do not form a closed shape. For information about the 
settings on this panel, see Arrow Panel on page 312.

LABEL PANEL

Distribution Path labels display in floor plan and cross section/elevation views when the “Polylines 3D, Labels” layer is 
turned on and use the Text Style assigned to that layer. 

For more information, see Label Panel on page 712.

OBJECT INFORMATION PANEL

The information entered on the OBJECT INFORMATION panel can be used in schedules and the materials list. For more 
information, see Object Information Panel on page 1336.    
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SCHEDULE PANEL

The settings on the SCHEDULE panel determine which schedule categories the selected object is included in. See Schedule 
Panel on page 716.
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Chapter 31
 

Materials

The objects used in Chief Architect have a variety of 3D properties. These objects - walls, windows, doors, cabinets, roof 
planes, lot perimeters, etc. - can have materials assigned to them so that they look realistic in 3D views. These materials can 
also be used to generate materials lists that can help with cost estimations. 

Designing with objects that look correct in 3D and calculate properly in the Materials List requires that you use realistic 
material definitions and apply them appropriately to objects in your plan.

Chief Architect comes with many materials that are ready for use. From siding, roofing, flooring, masonry, tile, and 
paneling, to road surfaces, grass, water, and wood materials, Chief Architect has materials for every application, inside and 
out. If you cannot find a material that suits your needs, you can customize the materials provided or create your own.

Learning how to create, manage, apply, and edit materials saves time and adds that professional touch to your designs.          

Redefining only the visual properties of a material may create 
unexpected results. For example, changing the image of a brick 

material to represent siding does not cause the material to be considered 
as siding during material calculations.

TOPICS

About Materials 1051
Material Defaults 1052
Material Painter Tools 1053
Materials Panel 1055
Select Material/Library Object Dialog 1057
Editing Materials 1059
Creating Materials 1060
Mapping Patterns and Textures 1062
Materials and the Materials List 1064
Managing Plan Materials 1065
Define Material Dialog 1066
Pattern from Texture Dialog 1077
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About Materials
The materials that are assigned to objects in Chief Architect perform two important roles:

 l They determine what the surfaces of objects look like in 3D views. 
 l They influence how objects are calculated in the Materials List. See Materials Lists on page 1309.

Materials are stored in the Library Browser and can be applied to objects in either of two ways:

 l Using the Material Painter . See Material Painter Tools on page 1053.

 l In an object’s specification dialog. See Materials Panel on page 1055.

PATTERNS AND TEXTURES

In Chief Architect, materials have two attributes that determine what they look like in 3D views: Textures and Patterns.          

 l Textures are created using special image files that tile seamlessly when applied to surfaces and are visible in ray trace 
views and most Rendering Techniques. See In Rendered Views on page 1098.         

 l Patterns are composed of CAD lines and are seen in Technical Illustration, Watercolor, Line Drawing, and Vector 
Views. Pattern lines are also represented when Line Drawing on Top is used in most other Rendering Techniques, as 
well. Select 3D> Toggle Patterns  to toggle the display of patterns on or off in these views in the current plan. See 

Rendering Techniques on page 1147.         

Often, the texture and pattern for a given material are both set up to represent the characteristics of the material in the real 
world and have similar sizing and angles. When customizing such a material, check Keep Pattern/Texture in Sync before 
making changes to maintain this consistency. See Define Material Dialog on page 1066.         

MATERIAL MAPS

Material maps are specially produced image files that can add realism to a material’s appearance in rendered and CPU Ray 
Trace views by making it appear contoured instead of flat, or rough instead of smooth or glossy.          

Materials seen in the Standard, Physically Based, Clay, Duotone, and Watercolor Rendering Techniques may be affected by 
these material maps:          

 l Bump maps add the appearance of height differences to a material - for example, on bricks, stone, or textiles. In a 
bump map, dark areas of the image correspond to low points in the bump map, and light areas correspond to high 
points.           

 l Normal maps assign three dimensional data to the material on a surface, allowing lighting effects to be created - for 
example, along mortar or grout lines. In normal maps, multiple colors are used to indicate surface direction.           

 l Ambient Occlusion maps indicate which parts of a texture receive more ambient light and which parts receive less. In 
occlusion maps, light areas receive more ambient light while dark areas receive less.           

 l Roughness maps define areas of varying roughness or glossiness that affect how light reflects off those areas. 
Roughness maps are grayscale where white is very rough, black very smooth.          

 l Metal maps define areas within a single texture that are metallic. Metal maps are grayscale images in which black is 
not metallic but every other shade is.           

You can choose to ignore any or all of these maps in Clay renderings as well as override material roughness in the 
Rendering Technique Options dialog. See Clay Panel on page 1154.

All of these map types can be assigned to a material in the Define Material dialog. See Texture Panel on page 1069 and 
Properties Panel on page 1073.          
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MATERIALS LIST CALCULATION METHODS

Every material can be assigned a Calculation method which defines how the material is calculated in the Materials List: for 
example, by piece, area, volume and so on. See Materials and the Materials List on page 1064.         

 

Material Defaults
Most objects in the program have defaults dialogs which allow you to set up a variety of attributes, including 
materials, before the objects are created. These defaults dialogs are accessed by selecting Edit> Default Settings. See 

Preferences and Default Settings on page 75.

The Material Defaults dialog serves two purposes. It allows you to:

 l Set the default materials for objects that do not have a defaults dialog: for example, fireplaces and furnishings from the 
library. 

 l Set the initial materials that can then populate a variety of defaults dialogs. Door, Window, and Cabinet Defaults are 
examples of defaults dialogs that can draw their material assignments from the Material Defaults dialog. 

Material defaults are dynamic, which means that if you change a particular default material, all objects that are set to use 
that default will automatically update to use the new material. See Dynamic Defaults on page 79. 

Because material defaults are dynamic, you can use the Material Defaults dialog to apply a material to multiple objects that 
share similar components. For example:

 l The “Room Moldings” Material Default applies to the base, crown, and chair rail moldings that can be assigned to 
rooms, as well as to interior door and window casing. If you change this Material Default, all of these objects in the 
plan can be affected.

 l The “Cabinet”, “Cabinet Door/Drawer”, “Countertop”, and “Hardware” Material Defaults can be used in your Cabinet 
Defaults dialogs to ensure that all cabinets use the same materials. See Dynamic Cabinet Defaults on page 629. 

MATERIAL DEFAULTS DIALOG

Select Edit> Default Settings  from the menu, select “Materials”, and click the Edit button to open the Material 

Defaults dialog. 
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 l Select a material category from the scrollable list. Select multiple line items using the Shift or Ctrl key. See Shift and 
Ctrl Select on page 217. 

 l Click the Select Material button or either material preview box to open the Select Material dialog. See Select 
Material/Library Object Dialog on page 1057.

 

Material Painter Tools
In a 3D view, select 3D> Material Painter to access the Material Painter Tools, which are used to apply materials 
to object surfaces. The Material Painter tools are available in all Rendering Techniques except Glass House views. 

See Glass House on page 1148.

If you use the Material Painter to change a room’s floor or 
ceiling finish material, it will add that material to the room’s 

Floor or Ceiling Finish Definition. Changes to a Deck room’s planking or 
framing will affect its floor structure definition. See Floor and Ceiling 
Platform Definitions on page 434. 

MATERIAL PAINTER

The Material Painter tool allows you to apply a selected material to other objects in 3D views. It can be activated in 
several ways: 

 l Select 3D> Material Painter> Material Painter . 

 l Select a material in the Library Browser while a 3D view is active. 
 l The Material Painter also becomes active when the Material Eyedropper is used.

The Material Painter  is similar to the other Painter tools but has some additional considerations. See Painter Tools on 

page 282.

To use the Material Painter tool
 1.  In a 3D view, select 3D> Material Painter> Material Painter . 

 2.  Choose a material from the Select Material dialog. See Select Material/Library Object Dialog on page 1057.         

 l Check Use Default Material at the bottom left of the LIBRARY MATERIALS panel or select “Use Default” from the 
top of the list on the PLAN MATERIALS panel to apply the default material to any object that has a defaults dialog. 
See Material Defaults on page 1052.

 3.  If you click the Copy Selected Material  button, a copy of the selected material is created and the Define 

Material dialog will open, allowing you to customize that copy. See Copy Selected Material on page 1055.    

 4.  Select one of the Material Painter Scoping Modes from the Edit Toolbar. See Material Painter Scoping Modes on 
page 1054, below.

 5.  If you selected a solid color material, choose whether to use the Blend Colors with Materials  option and click 

the edit button to turn this feature on or off. See Blend Colors With Materials on page 1054, below.
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 l The mouse pointer displays a paint roller icon    when Blend Colors With Textures is active.

 l The mouse pointer displays a spray can icon    when the Material Painter is active and Blend Colors With 
Textures is not. 

 6.  Note that the name of the material being painted displays on the left side of the Status Bar at the bottom of the 
program window. See The Status Bar on page 25. 

 l Move your pointer over a surface in the 3D view. The Status Bar now states both the material being painted and 
the current material on the target surface.

 7.  Click on a surface to apply the selected material to that surface. The material is applied to surfaces in the model 
based on the active Material Painter Scoping Mode.          

 8.  If either the Component  or Object Mode  is active, you can continue to click on surfaces to apply the 

selected material. When you are finished, select a different tool. 

MATERIAL EYEDROPPER

The Material Eyedropper tool allows you to load the material assigned to an existing object into the Material 
Painter and apply that material to other objects and is similar to other Eyedropper tools. See Eyedropper Tools on 

page 281.

MATERIAL PAINTER SCOPING MODES

There are five Material Painter Scoping Modes, each specifying how broadly or narrowly the selected material will be 
applied to surfaces in your plan. They are similar to other Painter Scoping Modes in the program, but rather than modify 
instances of an object type, the Material Painter Scoping Modes replace instances of a material based on the selected scope. 
See Painter Scoping Modes on page 283.

These Painter Scoping Modes are also available when the Adjust Material Definition  tool is used, allowing you to 

control how extensively a change to a material is applied throughout the current plan. See Adjust Material Definition on 
page 1059.

  Material Painter Component Mode is the default mode and applies the selected material to a single component 
on the target object. For most object types, using this tool is the same as opening an object’s specification dialog 

and changing the material of one of its components on the MATERIALS panel. See Materials Panel on page 1055.
  Material Painter Object Mode replaces all instances of a material on the target object. 

  Material Painter Room Mode replaces all instances of a material in the room where the target object is located. 

  Material Painter Floor Mode replaces all instances of a material on the floor where the target object is located. 

  Material Painter Plan Mode replaces all instances of a material in the entire plan. 

BLEND COLORS WITH MATERIALS

The Blend Colors With Materials option allows you to apply a solid color to a surface displaying a texture or 
pattern and blend the two. 

Blend Colors With Materials  works in all five Material Painter Scoping Modes. See Blending Materials on page 1061.

1054



Chief Architect Premier X14 Reference Manual - Materials Panel

COPY SELECTED MATERIAL

The Copy Selected Material tool creates a copy of the selected material, gives you an opportunity to customize it as 
needed, and then lets you apply the new material to surfaces in the model. This option is helpful if you need slightly 

different versions of the same material - for example, to orient wood planks or tile in different directions.   

When you click the Copy Selected Material  button, the Define Material dialog will open, allowing you to customize 

the new material. When you click OK, the customized material is loaded into the Material Painter. See Define Material 
Dialog on page 1066.

Once you apply the material to one or more surfaces in the model, it will be listed in the Plan Materials dialog. See 
Managing Plan Materials on page 1065.   

MATERIAL PAINTER AND WALLS

Painting walls is an obvious use for the Material Painter ; however, it is important to note that the Material Painter 

Scoping Modes affect walls and rooms somewhat differently than they do other objects: particularly if a wall defines 
multiple rooms on the side that is being painted.

Component  and Object Modes  only paint the section of the wall that defines the room located where you click to 

apply a new material. Sections of the same wall that define other rooms are unaffected. 

Room Mode  applies the material to all walls and solid railings that define the room where you click provided that they 

have the same original surface material as the one being painted. Any other objects in the room with that original material 
are also affected, but railings are not unless they are specified as Solid. 

Floor  and Plan Modes  apply the material to all walls, all railings, and any other objects with the same original 

surface material as the one being painted: either on the current floor, or throughout the plan.

Note: Wall materials applied using the Material Painter tool are not 
calculated in the Materials List. See In the Materials List on page 368.

 

Materials Panel
The specification dialogs for most objects include a MATERIALS panel. Select an object or a group of similar objects 
and click the Open Object edit button to open the specification dialog for that selection. 

On the MATERIALS panel, you can specify material assignments for the components that make up that object. When a new 
material is assigned, the appearance of the preview image on the right side of the dialog updates. 

If the selected object is using a material that is missing its texture, a Caution   symbol will display next to the Materials 
panel name in the list on the left side of the object’s specification dialog. See Linked and Referenced Files on page 51. 

1055



Chief Architect Premier X14 Reference Manual - Materials Panel

 
Object Components

The table on the left side of the panel lists the components of the selected object that can be assigned unique materials, 
along with the names of those materials and whether or not the default materials are used. Some objects may have only one 
component while more complex objects may have many. As changes are made to the selected object, components may be 
added to or removed from this table.    

 l Click on a Component in the table to select it. Multiple line items can be added to the selection set by holding down 
the Shift or Ctrl key. See Shift and Ctrl Select on page 217.    

 l The selected component’s Material is stated in the list, to the right of the component name. If the component is using 
the default material, the name will be preceded by the word “Default:”. If it is using a Material Default, it will be 
preceded by the word “Default” followed by the name of an object type. See Material Defaults on page 1052.    

 l If the selected component belongs to a symbol object from the library, you can click on it a second time to rename it. 
See Native Objects vs Symbols on page 986.          

Note: If the selected object is a wall or a room modified using the 
Material Painter, a component’s Material may be described as “No 
Change”. See Material Painter and Walls on page 1055.

 
Material Preview

The two boxes to the right of the table display previews of the color, pattern, and texture of the material assigned to the 
selected component. If “No Texture” displays in the preview window, the material has no texture assigned to it; if a Caution 
 symbol and the words,“Texture Missing” display, the texture file could not be found on the system. 

  There are several ways to open the Select Material dialog and choose a different material for one or more selected line 
items:    

 l Double-click on a line item in the table.    

 l Select one or more line items and click the Select Material button.    

 l Select one or more line items and click on either of the preview boxes. 
See Select Material/Library Object Dialog on page 1057. 

 
Preview

A preview of the selected object displays on the right side of the panel. To view material textures, select Standard as the 
View Type; to view material patterns, select Vector View. See Dialog Preview Panes on page 22.   
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Select Material/Library Object Dialog
The Select Material dialog allows you to select a material to apply to one or more objects and is opened by clicking the 
Select Material button on the MATERIALS panel of most specification dialogs or by using the Material Painter . See 

Materials Panel on page 1055 and Material Painter Tools on page 1053.

The similar Select Library Object dialog allows you to select an item from the library to either apply or insert into a 
currently selected object. See Placing Library Objects on page 980.

The Select Library Object dialog has a single panel; however, depending on how it is accessed, the Select Material dialog 
will have either two or three panels:          

 l The Library Materials Panel on page 1057 allows you to select materials from the Library Browser.          
 l The Plan Materials Panel on page 1058 lets you select materials from the Plan Materials dialog.          
 l The Material Defaults Panel on page 1058 lets you associate an object component with a Material Defaults category 

rather than a specific material and is only available when the component of a library symbol is selected on the 
MATERIALS panel of the object’s specification dialog.          

LIBRARY MATERIALS PANEL

The LIBRARY MATERIALS panel is a modal version of the Library Browser that lists only materials. See The Library 
Browser on page 962.

Most of the settings on this panel are also found in the Select Library Object dialog. See Select Library Object Dialog on 
page 982.

The LIBRARY MATERIALS panel has most of the functionality that the Library Browser has, including the search, search 
filtering options, and preview options. 

 l To locate a material, either search using keywords or browse the tree list. See Searching the Library on page 967.
 l Located below the tree list, check Use default material to apply the default material to the selected object component

(s), if one exists. See Material Defaults on page 1052. 
 l A preview of the selected material displays on the right. See Dialog Preview Panes on page 22.
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 l To apply a material to an object, either click on the material and click OK or double-click on the item in the Selection 
Pane. 

A selection of buttons below the tree list allows you to control the appearance of the panes in this dialog. The Selection and 
Preview panes are always present when the dialog is first opened. See The Library Browser on page 962.

 l Click the Show/Hide Selection Pane  button to toggle the Selection Pane on and off. 

 l Click the Show/Hide Preview Pane  button to toggle the Preview Pane on and off. Not available for materials.

 l Click the Toggle Preview Display  button to switch between Standard Render and Vector View images of a 

selected library object in the Preview Pane. This setting is remembered between visits to this dialog and is not 
available for materials.

 l For materials, select an object shape to display the material on in the preview on the far right: Cube, Sphere, Teapot, 
or Plane.  

An additional button allows you to add new content to the User Catalog. The available option varies depending on the type 
of library item being assigned or inserted into another object.

 l Click the Add New Symbol  button to import a 3D symbol into the User Catalog and select it. The symbol's 

category corresponds to the object component being edited, and cannot be changed. See Importing 3D Symbols on 
page 1239.

 l Click the Add New Line Style  button to open the Line Style Specification dialog. See Line Style Specification 

Dialog on page 202.
 l Click the Add New Fill Style  button to open the Fill Style Specification dialog. See Fill Styles on page 197. 

 l Click the Add New Backdrop  button to open the Import Backdrop File dialog. See 3D Backdrops on page 1201.

 l Click the Add New Material  button to open the Define Material dialog and create a new material saved in the 

User Catalog. See Define Material Dialog on page 1066.

The OK button is only active when a library item is selected. If a library folder or catalog is selected, the OK button cannot 
be clicked. 

PLAN MATERIALS PANEL

The PLAN MATERIALS panel is similar to the Plan Materials dialog and lets you select from a list of materials already 
present in the plan as well as manage that list. See Managing Plan Materials on page 1065.           

Select “Use Default” from the top of the list to apply the default material to the selected object, if applicable.          

MATERIAL DEFAULTS PANEL

The MATERIAL DEFAULTS panel will only be present if the Select Material dialog was accessed via an object specification 
dialog where a component of an inserted library symbol was selected.

Rather than apply a specific material to the selected component, you can dynamically associate it with a Material Default 
category. See Material Defaults on page 1052.
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Editing Materials
Much like objects, materials in Chief Architect can be edited so that they better suit your design needs. There are several 
ways to customize a material:

 l Edit the original material and replace all instances of it in the current plan;
 l Create and edit a copy of the original material and replace only some instances of the original in the current plan;
 l Edit a material in the Library Browser and apply it in any plan as needed.

Editing the material applied to an object is not the same as 
applying a different material to that object. See Material Painter 

Tools on page 1053.

ADJUST MATERIAL DEFINITION

The Adjust Material Definition tool lets you make changes to the materials seen in camera views.

Adjust Material Definition has five Painter Scoping Modes that allow you to control how extensively your changes to a 
given material are applied:

  Material Painter Component Mode allows you to edit the material applied to a single component on a target 
object. If any other instances of the original material are present in the current plan, including on other 

components of the same object, you will be presented with the option of editing a copy of the original material on that 
component so those other instances can remain unchanged.

  Material Painter Object Mode allows you to edit all instances of the material on a target object. If any other 
instances of the original material are present on other objects in the current plan, you will be presented with the 

option of editing a copy of the original material on the target object so those other instances can remain unchanged.
  Material Painter Room Mode allows you to edit all instances of the material located in the same room as the 
target object. If any other instances of the original material are present in other rooms in the current plan, you 

will be presented with the option of editing a copy of the original material so those other instances can remain 
unchanged.

  Material Painter Floor Mode allows you to edit all instances of the material located on the same floor level as 
the target object. If any other instances of the original material are present on other floors in the current plan, you 

will be presented with the option of editing a copy of the original material so those other instances can remain 
unchanged.

  Material Painter Plan Mode allows you to edit all instances of the material in the current plan. When Plan 
Mode is selected, the original material is modified and creating a copy of it is not an option.

To use the Adjust Material Definition tool
 1.  Create a camera view in which a material that you would like to modify can be seen.

 2.  While the camera view is active, select 3D> Adjust Materials> Adjust Material Definition .

 3.  Notice that the  Adjust Materials Painter Scoping Mode buttons become available on the Edit Toolbar, and click 
on the Mode that suits your needs.

 4.  Select the material that you want to edit:
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 l Move your mouse pointer over a surface and notice the Status Bar reports that material's name.

 l Click on a surface displaying the material you want to edit.

 5.  If the material is assigned to any objects outside the scope set by the selected Mode, the Create Copy of Material 
dialog will open. 

 l Select Create a Copy of the Material to make a copy of the material and leave the original unchanged, then type 
a name for the new material in the Copy Name text field.

 l Select Edit the Source Material to modify the original material and apply your changes plan-wide.

 6.  The Define Material dialog opens next, allowing you to edit either the original material or a copy of it. See Define 
Material Dialog on page 1066.

 7.  When you click OK, your customized material will be applied in the current plan according to the selected Mode. 

Changing a material definition using the Adjust Material Definition tool only affects objects in the current plan that are 
using that material. It does not affect any materials saved in the library or materials used in other plans. See Adding Library 
Content on page 973.

PLAN MATERIALS

You can also edit, copy, and create new materials in the Plan Materials dialog. Select 3D> Materials> Plan 
Materials to open this dialog for the current plan. You can add a newly defined material to the library from the Plan 

Materials dialog by selecting it and clicking the Add to Library button. See Managing Plan Materials on page 1065.

IN THE LIBRARY BROWSER

Materials saved in the User Catalog of the Library Browser are editable: right-click on one and select Open Object  

from the contextual menu to open the Define Material dialog for that material. See Editing Library Objects on page 986.

 

Creating Materials
Chief Architect provides a wide variety of materials - including numerous name brand material catalogs - that are ready to 
download and use. If you cannot find a suitable material, you can edit an existing material or create a new one. See Editing 
Materials on page 1059.

TEXTURE FILE MANAGEMENT

Materials often have a texture and one or more material maps, which are images files that add realism to the material's 
appearance. In order to display a material’s texture and material maps, Chief Architect needs to be able to locate the image 
files associated with them on your computer. See Linked and Referenced Files on page 51.
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If a texture or material map referenced by a newly created material is not located in either the Chief Architect Premier X14 
Data folder or the installation folder for the program’s library textures, a copy of the file will be made in Chief Architect 
Premier X14 Data\Textures\Material Data and the material will reference that copy. See Chief Architect Premier Data on 
page 37.

IN THE PLAN MATERIALS DIALOG

There are two ways to create a new material in the Plan Materials dialog. See Managing Plan Materials on page 1065.          

 l Click the New button to create a new material for use in the current plan file.          
 l Select a material and click the Copy button to make a new material based on the original, which can then be edited 

and used in the current plan.         

To make a plan material available for use in other plans, select it and click the Add to Library button. See Adding Library 
Content on page 973.          

IN THE LIBRARY BROWSER

Materials can be created in the Library Browser, making them available for use in any plan. See Adding Library Content on 
page 973. 

In the directory pane of the Library Browser, right-click on an unlocked folder and select New> Material  from the 

contextual menu. See Using the Contextual Menus on page 965.

The Define Material dialog opens, allowing you to specify the new material’s attributes. See Define Material Dialog on 
page 1066. 

USING PASTE IMAGE

A new material can be created by copying an image that will serve as its texture to the system clipboard, then navigating to 
a Chief Architect window and selecting Edit> Paste> Paste  from the menu. See Cut, Copy, and Paste on page 172.           

FROM A SCREEN CAPTURE

You can use the Screen Capture tools to create a texture based on a screen capture from any application and use it to create 
a new material in the User Catalog in the library. See Creating Screen Captures on page 1200.          

By default, materials created from a screen capture will be set to Stretch to Fit. If you would like the texture to tile instead, 
uncheck this box. See Stretch to Fit on page 1063.          

COPYING MATERIALS

When the Adjust Material Definition tool is used with any scoping mode other than Plan Mode, the program will 
prompt you to choose whether to edit the original material or create a copy of it. See Adjust Material Definition on 

page 1059.

BLENDING MATERIALS

In 3D views, you can create a new material by blending a solid color such as a paint color with a textured and/or 
patterned material. Select 3D> Material Painter> Blend Colors With Materials to toggle this feature on or off. See 

Blend Colors With Materials on page 1054.
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The result is a new material that is saved in the current plan. It can be found in the Plan Materials dialog, edited as needed, 
and added to the library if desired. See Managing Plan Materials on page 1065.

Materials created using the Blend Colors With Materials  tool are given the name of the patterned/textured material 

with the extension “--PAINTED:” followed by the name of the solid color material. 

CONVERT TEXTURES TO MATERIALS

An entire folder of textures can be converted into a library of materials. Select 3D> Materials> Convert Textures to 
Materials and then browse to a folder of textures on your computer. The converted library folder assumes the same 

file structure as the original folder.         

Materials created using this tool do not refer to the original folder of texture files. Instead, they refer to files copied into the 
Data folder like individually-created materials do. See Texture File Management on page 1060, above.           

CREATE PLAN MATERIALS LIBRARY

Select 3D> Materials> Create Plan Materials Library to create a library of materials based on the materials used 
in the current plan. This is useful for converting material template plans, a common way to store material definitions 

in prior versions of Chief Architect, into a materials library. This command creates a new library in the Materials category 
using the same name as the plan. Adding materials to the library individually allows you to store the material within the 
existing directory structure.         

 

Mapping Patterns and Textures
Materials have two attributes that determine what they look like in 3D views: patterns and textures. See About Materials on 
page 1051.          

Both patterns and textures have points of origin, which determine where the pattern or texture begins on an X/Y axis. By 
default, this origin is 0,0; however, you can specify a different origin for each in the Define Material dialog. See Define 
Material Dialog on page 1066.         

You can also specify whether a material’s pattern and texture origins are set globally or independently for each object. By 
default, this mapping is per object; check Global Symbol Mapping on either the TEXTURE or PATTERN panel of the Define 
Material dialog to map all instances of the material throughout the plan from the same origins.         

If a material has any material maps assigned to it, they use the same Offset settings as the texture. See Material Maps on 
page 1051.          

If a material is set to map globally, it may not look right on some surfaces in 3D views. If this is the case and you do not 
wish to map the material independently on each object, you can create a copy of the material for each surface that requires 
modification and specify its texture’s origin.         

The fill styles of CAD objects are similar to material patterns 
and can also be mapped on an individual object basis. See Fill 

Styles on page 197.
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DETERMINING THE ORIGIN

Before a new origin can be specified, the display of coordinates in the Status Bar should be enabled. See The Status Bar on 
page 25.         

To determine origin coordinates on the horizontal plane, place your cursor over the origin location in floor plan view. When 
the pointer is in the position you want to establish as the material origin, take note of the coordinates that display in the 
Status Bar.          

To determine origin coordinates on the vertical plane, place your cursor over the origin location in a cross section/elevation 
view.         

Once you have taken note of the new origin coordinates, enter them as Horizontal and Vertical Offsets on either the 
PATTERN or TEXTURE panel of the Define Material dialog. See Define Material Dialog on page 1066.         

A texture or pattern origin is a property of the material rather than of the object that the material is assigned to. When an 
object is moved, the pattern or texture maintains its absolute position and may not look right. It is a good idea to assign 
pattern or texture origins only after the position of the object has been finalized.         

STRETCH TO FIT

Some special textures, often used for artwork, do not tile. Instead, these textures resize to stretch across any surfaces that 
they are applied to. Materials that behave this way are specified as Stretch to Fit in the Define Material dialog. See Define 
Material Dialog on page 1066.   

To display an artwork texture, first place a wall or desk frame in your plan. A selection of both are available in the library. 
See Placing Library Objects on page 980.         

Next, simply apply a material specified as Stretch to Fit to the center portion of the frame. See Material Painter Tools on 
page 1053.         

1063



Chief Architect Premier X14 Reference Manual - Materials and the Materials List

 

Materials and the Materials List
When applied to structural components like slabs or wall, floor and ceiling, or roof layers, materials determine how or 
whether those components are calculated in the Materials List. Each material’s Structure Type and its Calculation Method 
are specified in the Define Material dialog. See Materials List Panel on page 1076.         

MATERIAL STRUCTURE TYPES

The Material Structure Type controls how or whether certain structural features generate in the model.          

 l The Concrete type must be assigned to a wall type in order for a brick ledge to be cut into it.       This type is also required 
to produce rebar, steel mesh, and pour number calculations in the Materials List. It is recommended for concrete walls, 
footings, monolithic slabs, and Slab Footings. See Foundations on page 717 and Brick Ledges on page 356.    

 l The Masonry type must be assigned to the exterior layer of a wall type in order to generate a brick ledge in the wall 
below.

 l The Other type is useful for other structural applications such as framing, sheathing, and siding.          

CALCULATION METHODS

A material’s Calculation method controls how it is counted in the Materials List when it is applied to structural components 
like wall, ceiling, floor, ceiling, or roof layers; slabs; or to generic objects like Primitive objects.          

For walls, structural assembly layers, and slabs,  "Area", "Count" and "Linear" calculations are based on the area of the 
assembly or the top of the slab. If a material is calculated by "Count", its Depth is not used; however, the thickness of the 
layer or slab is noted in the Size column of the Materials List.          

For Primitives as well as Soffits, "Area", "Count" and "Linear" calculations are made for all sides of the object. The Depth 
of materials calculated by "Count" is used, but thickness is otherwise not noted.         

 l "Area" calculates the total area of a material in               structural     layers, slabs, and Primitives              in square feet (m).          
 l "Count" calculates a piece count based the material’s Width, Height, and Depth.          
 l "Linear" calculates the total length of strips required to cover the area in feet (m).          
 l "Volume" calculates the total volume of a material in      structural     layers, slabs, and Primitives              in cubic yards (m)         
 l "None" prevents the material from being calculated in the materials list at all.           

To prevent a structural layer from being counted in the materials 
list as well as from displaying in the 3D model, specify it as an 

Air Gap. See Wall Type Definitions Dialog on page 390 and Material 
Layers Definition Dialogs on page 1040.

Once a Materials List has been created, the unit of measurement can be changed. See Changing Count Units on page 1324.         

REPRESENTING OVERLAP

Any material using the Count or Linear Calculation method can be set up to account for material overlap in the Define 
Material dialog. To do this:          

 l On the PATTERN panel, set up the material’s pattern so that it accurately represents the size and shape of the exposed 
portion of an individual piece or strip.          

 l On the TEXTURE panel, set the Scale to represent the appearance of the exposed material in rendered 3D views.         
 l On the MATERIALS LIST panel, specify the full size of the actual material, including the overlapped portion.          
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If a material is set up to represent overlapping pieces, it is important that you not click the Update from Pattern button. 
See Materials List Panel on page 1076.         

 

Managing Plan Materials
The Plan Materials dialog allows you to manage the materials used in the current plan. Select 3D> Materials> Plan 
Materials to open this dialog. You can also access its settings in the Select Material dialog. See Select 

Material/Library Object Dialog on page 1057.          

When a material is applied to an object in a plan, a copy of that material is created and saved with the plan. If you use the 
Define Materials dialog to modify that material, your changes affect it wherever it is found throughout that plan. All objects 
in that plan that use that material are affected, but objects placed in other plans are not.           

All materials that come with Chief Architect are stored in the 
Library Browser. You can create your own materials and save 

them there, as well. See Creating Materials on page 1060.

PLAN MATERIALS DIALOG

 
Search

Begin typing in the text field. As you type, the list below will be filtered to show only materials with names that contain 
your text.

 
Plan Materials

A sortable, scrollable list of the materials referenced by the current plan displays here. Click on the name of a material to 
select it. Select multiple materials by holding down the Shift or Ctrl key.         

 l If there is a check mark in the In Use column, the material is used by one or more objects in your plan or is defined 
as a default material for one or more objects in your plan.          

 l If the In Use column is empty, the material was used at one time but is no longer assigned to any objects or used as 
a default.          
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Management Options

The buttons on the right allow you to modify the selected material and manage the items in the list.         

 l Click Edit to open the Define Material dialog for the selected material. See Define Material Dialog on page 1066.          

 l Click New to open the Define Material dialog to create a new material.          

 l Click Copy to create a copy of the selected material and open the Define Material dialog where you can make 
changes to the copied material.          

 l Click Purge to remove all unused materials from the plan.          

 l Click Delete to remove the selected material from the plan. If the material is used in the model, you cannot delete it.          

 l Click the Merge button to merge multiple selected materials into one. The material that is listed first is retained and 
all other materials in the selection set are deleted. Any instances of the deleted materials in the plan are replaced by 
the first material. Only available when multiple materials are selected.               

 l Click Add to Library to add the selected material to the Library Browser, making it available for use in other plans. 
See Adding Library Content on page 973.              

 l Click the Replace button to replace the selected material with a new one from the library. Materials assigned to 
objects as well as those set in object defaults dialogs are affected. See Select Library Object Dialog on page 982.              

 
Preview

A preview of the material applied to an object displays here. If multiple materials are selected at once, the first one in the 
list will display. Various options allow you to view different aspects of the material’s attributes:         

 l Display the material in Physically Based, Standard rendering, Vector View, or in a CPU Ray Trace view.   

 l Zoom and orbit the object in the view.          

 l Toggle Color on or off.          

 l Click the Restore Original View  button to reset the material preview to its original perspective.           

 l Select an object shape: Cube, Sphere, Teapot, or Plane.          

The Rendering Technique and object shape selections in this dialog’s preview are shared with the Define Material dialog. 
Unlike other dialog previews, these are retained when you close the dialog. The object shape selection is also shared with 
the Library Browser. See Dialog Preview Panes on page 22 and The Library Browser on page 962.          

You can create a folder containing all of the current plan’s Plan 
Materials in the Library Browser User Catalog. See Create Plan 

Materials Library on page 1062.

 

Define Material Dialog
The Define Material dialog allows you to adjust how materials look in 3D views as well as how they are calculated in the 
Materials List.

The Define Material dialog can be accessed in a number of ways:
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 l Use the Adjust Material Definition  tool. See Adjust Material Definition on page 1059. 

 l Select a material from the Plan Materials dialog and click Edit, New, or Copy. See Managing Plan Materials on page 
1065.             

 l Right-click on a material in the User Catalog in the Library Browser and select Open Object  from the contextual 

menu. When multiple materials are selected, some settings will not be available. See Using the Contextual Menus on 
page 965. 

 l You can also right-click on the User Catalog and select New> Material. 

If you select a material from a Manufacturer Catalog, some options in the Define Material dialog may not be available and 
the panels may vary. See Manufacturer Catalogs on page 970.       

If you access the Define Material dialog through a menu or specification dialog, any changes you make will affect that 
material wherever it is found in the current plan. Other objects in that plan using that material will also be affected, but 
objects outside the current plan will not. You can click the Add to Library button at the bottom of the dialog to add the 
material to the User Catalog for future use in any plan. See Adding Library Content on page 973.

The Rendering Technique and object shape selections in this dialog’s preview are shared with the Plan Materials dialog and, 
unlike other dialog previews, are remembered during the current program session. See Dialog Preview Panes on page 22.         

The Define Material dialog has the following panels:

PATTERN PANEL

Patterns are used to represent materials in Technical Illustration, Line Drawing, and Vector Views. See Patterns and 
Textures on page 1051.
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Material Name

The Material Name displays here. You can type a different name if you wish. Renaming the material does not create a new 
material: it redefines the existing material. See Creating Materials on page 1060.         

 l Check Keep Pattern/Texture in Sync to maintain consistent Scale and Offset and Angle settings for both the 
selected material’s pattern and its texture if any of these settings are modified.         

 
Colors

Specify the Colors used to represent the material’s pattern in Vector Views. Click either color box to open the Select Color 
dialog and select a color. See Color Chooser/Select Color Dialog on page 204.         

 l The Material Color displays in Vector Views and is also used if a material has no texture specified. See In Vector 
Views on page 1098. This color also affects Transparent materials in rendered and CPU Ray Trace views: choose 
white for a fully transparent material or black for one that is completely opaque. See Properties Panel on page 1073.

 l The pattern Line Color displays in Vector Views only.          

 l Specify the Shading Contrast, which is the amount of contrast between surfaces at different angles to each other in 
Vector Views. See Vector View on page 1147.         

The following shows a curved wall with three different Shading Contrasts (created in a separate graphics program). Notice 
how the lowest contrast at the top appears almost flat.         

 
Pattern

When “No Pattern” is selected as the Pattern Type, the Scale, Offset and Angle settings are disabled.         

 l Select a Pattern Type from the drop-down list. Select “Library” or click the Library button to select a pattern from 
the library. When a pattern is selected from the library, its name will display in the list. See Select Library Object 
Dialog on page 982.          

 l Click the Pattern from Texture button to create a custom pattern based on the material’s texture. When a pattern is 
created using this option, the name of the material’s texture file will display in the Type drop-down list. Only 
available if the material has a texture assigned to it. See Pattern from Texture Dialog on page 1077.               
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  Scale

 l Specify the Width of the selected pattern. For Concrete and Sand materials, instead adjust the overall pattern 
Spacing.              Not available if Pattern from Texture has been used.

 l Specify the selected pattern’s Height. Only available for Brick, Tile, Shingles, and U’s patterns.          

 l Specify the pattern’s Scale. If the pattern appears black in the square preview pane, this value should be increased. 
Only available for imported patterns and some patterns from the library.         

  Offset and Angle

 l Specify the Horizontal and Vertical Offsets, if needed, so the pattern displays correctly on surfaces. See Mapping 
Patterns and Textures on page 1062.          

 l Specify the Angle, measured counterclockwise, in degrees.         

 l Check Global Symbol Mapping to map the pattern and texture using the same origin on all objects. When 
unchecked, the origin is defined individually for each object.          

 l Specify the Line Weight, which is the thickness of the pattern lines.             

 
Copyright

If the selected pattern has a Copyright, information about it displays here.         

 
Pattern Preview

A preview of the material’s pattern displays in the square pane. It updates as you change the pattern’s specifications.         

 
Preview

A preview of the material applied to an object displays here and updates as changes are made to the material definition. 
Various options allow you to view different aspects of the material’s attributes:         

 l Display the material in              Physically Based or Standard rendering, Vector View, or in a CPU Ray Trace view.

 l Zoom and orbit the object in the view.         

 l Toggle Color on or off.         

 l Click the Restore Original View  button to reset the material preview to its original perspective. 

 l Select an object shape: Cube, Sphere, Teapot, or Plane.         

The Rendering Technique and object shape selections in this dialog’s preview are shared with              the Plan Materials dialog. 
Unlike other dialog previews, these are retained when you close the dialog. The object shape selection is also shared with 
the Library Browser. See Managing Plan Materials on page 1065.

TEXTURE PANEL

In most Rendering Techniques as well as in CPU Ray Trace views, materials are represented using textures and other 
material maps. See Material Maps on page 1051 and Rendering Techniques on page 1147. 

Transparency information may be contained on the alpha channel of a texture; if so, it is used in rendered and CPU Ray 
Trace views. 

If a texture or material map referenced by a newly created material is not located in either the Chief Architect Premier X14 
Data folder or the installation folder for the program’s library textures, a copy of the file will be made in Chief Architect 
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Premier X14 Data\Textures\Material Data and the material will reference that copy. See Chief Architect Premier Data on 
page 37.          

 
Material Name

The Material Name displays here and can be changed if you wish. Renaming the material does not create a new material: it 
redefines the existing material.         

 l Check Keep Pattern/Texture in Sync to maintain consistent Scale and Offset and Angle settings for both the 
selected material’s pattern and its texture if any of these settings are modified.         

 
Texture Source

Displays the path and file name of the selected texture.             

 l Click the Browse button to browse to a texture file saved on your computer. Supported file formats are .jpg, .bmp,
 .png, .gif, and .tif. See Creating Materials on page 1060.    

 l You can also type or paste the full path name of a texture in the text field. To remove the file, click the Remove   
button.          

 l Textures saved in .zip files can also be used. See To use an image saved in a .zip file on page 1073, below.         
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Scale

These settings affect both the selected material’s texture and any material maps assigned to it. See Material Maps on page 
1051.

 l Adjust the X Scale and Y Scale, or height and width, of the selected texture.          
If a rendered surface is larger than the area described by the Scale, the surface has “tiles” of the texture image. If it is 
smaller, only a portion of the texture is shown.

 l Check Stretch to Fit to stretch the texture image to cover each surface it is applied to. Stretch to Fit is typically 
used for artwork or photography in a frame.         

Note: Changing the scale or selecting Stretch to Fit can cause textures 
to appear distorted if applied to a surface with a different aspect ratio 
than the original texture image. 

   l Check Retain Aspect Ratio to maintain the ratio between the texture image’s height and width and prevent 
distortion when either its X or Y Scale value is adjusted.         

 
Offset and Angle

These settings affect the material's texture as well as any material maps assigned to it. See Mapping Patterns and Textures 
on page 1062.   

 l Specify the X and Y Positions of the texture’s origin, if needed, to adjust its layout on surfaces.          

 l Specify the Angle of the texture on the surfaces of objects, in degrees.         

 l Check Global Symbol Mapping to map the texture and pattern using the same origin on all objects. When 
unchecked, the origin is defined individually for each object.          

 
Material Color

Material Color can also be set on the PATTERN panel. See Pattern Panel on page 1067.         

 l Check Blend with Texture to apply the Material Color over the material’s texture. 

When a new material is created using the Blend Colors With Materials  tool, the resulting material has this box 

checked. See Blend Colors With Materials on page 1054.         

 l Click the Color button to specify the Material Color.          

 l Click the Set Material Color Using Texture button to use the predominant color of the material’s texture. See 
Patterns and Textures on page 1051.         
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Bump Map

A Bump Map is an image file that makes a material look rough or textured. See Material Maps on page 1051.         

 l The full path name of the selected bump map image File displays here. To remove the file, click the Remove   
button.              

 l Click the Browse button to browse to a bump map image file saved on your computer. Bump maps saved in .zip 
files can also be used. See To use an image saved in a .zip file on page 1073, below.              

 l The Scale setting allows you to specify how drastic the effect of the bump map is. The default value is 0.01, but 
larger or smaller values may give better results, depending on the bump map. Values can be typed to 0.001 accuracy.               

 l Check Invert to correspond light areas in the image with low points in the bump map and dark areas with high 
points. When unchecked, the opposite occurs.              

 
Normal Map

A Normal Map is an image file that makes a material appear to have depth.         

 l The full path name of the selected normal map image File displays here. To remove the file, click the Remove   
button.              

 l Click the Browse button to browse to a normal map image file saved on your computer. Normal maps saved in .zip 
files can also be used. See To use an image saved in a .zip file on page 1073, below.              

 
Ambient Occlusion Map

An  Ambient Occlusion Map is an image file that affects how much ambient light each part of the material receives.         

 l The full path name of the selected ambient occlusion map image File displays here. To remove the file, click the 
Remove   button.              

 l Click the Browse button to browse to a file saved on your computer. Ambient occlusion maps saved in .zip files can 
also be used. See To use an image saved in a .zip file on page 1073, below.              

 
Texture Preview

A preview of the material’s texture displays in the square pane. It updates as you change the material definition.

 
Preview

A preview of the material applied to an object displays here and updates as changes are made to the material definition. 
Various options allow you to view different aspects of the material’s attributes:         

 l Display the material in                  Physically Based or Standard rendering, Vector View, or in a CPU Ray Trace view.

 l Zoom and orbit the object in the view.             

 l Toggle Color on or off.             

 l Click the Restore Original View  button to reset the material preview to its original perspective.             

 l Select an object shape: Cube, Sphere, Teapot, or Plane.             
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To use an image saved in a .zip file
 1.  Type or copy the full path name of the .zip file in the text field.             

 2.  Directly after the path name, type #zip:, followed immediately by the name of the bump map file including its file 
extension.             

PROPERTIES PANEL

The PROPERTIES panel controls how the material appears in most rendered 3D views and in CPU Ray Trace views.         

A material’s rendered appearance is also affected by the Render settings in the Preferences dialog and the lights that have 
been placed in the model. See Light Types on page 1135.         

For special lighting effects on an object, use at least one point or spot light.         

If a Roughness or Metal Map file referenced by a newly created material is not located in either the Chief Architect Premier 
X14 Data folder or the installation folder for the program’s library textures, a copy of the file will be made in Chief 
Architect Premier X14 Data\Textures\Material Data and the material will reference that copy. See Chief Architect Premier 
Data on page 37.          

 
Material Name

The Material Name displays here. You can type a different name if you wish. Renaming the material does not create a new 
material: it redefines the existing material.         
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Material Class

Select a Material Class from the drop-down list. Each has its own set of characteristics that affects its appearance in 
rendered and CPU Ray Trace views.         

 l General Material - Most materials fall into this category, which gives you control over a number of properties.             

 l Matte materials are also limited for a specific purpose. They are not specular, emissive, transparent, or reflective.                

 l Mirror materials are limited to a specific purpose. They are not diffusive, specular, rough, emissive, or transparent 
and do not use the material’s texture when ray traced. When Reflections are enabled in a camera view, flat surfaces 
with a Mirror material display reflections. See Reflections on page 1131.             

 l Plastic materials are limited in that they are not specular, emissive, transparent, or reflective.             

 l Polished materials represent surfaces with multiple layers, such as those that are glazed, varnished, or buffed. They 
are not emissive, transparent, or reflective, but are specular and have additional control over Roughness.             

 l Predefined Metal use scientifically measured physical properties of a selection of real-world metals. Predefined 
metals do not use the material’s pattern or texture when ray traced, and their editing options are limited to 
Roughness and metal type.               

 l Shiny Metal is also limited for a specific purpose and are not diffuse, emissive, or transparent. When ray traced, 
they do not use the material’s texture.               

 l Translucent - Similar to General Materials, Translucent materials are not emissive or reflective. Contrary to the 
name, Translucent materials are not transparent, either. They do have a Translucency setting, but it only applies to 
light coming directly from a light fixture and only takes effect in CPU Ray Trace views. Ambient light or reflected 
light cannot pass through Translucent materials so objects cannot be seen through Translucent materials at all - even 
in CPU Ray Trace views.               

 l Transparent is another material class limited for a specific purpose. Transparent materials are not diffusive, 
specular, rough, or emissive, but do allow you to specify how light bends when passing through the material.               

Adjust the settings associated with the selected Material Class using the slide bar or by entering a value in the text box to 
specify the appearance of the material in 3D views in which textures are used.           

 l Check Metallic to give the material the appearance of metal in Physically Based renderings and in CPU Ray Trace 
views. Only available for General materials.               

 l Diffuse controls the degree to which the material’s main color contributes to its appearance. Not available for Metal, 
Mirror, or Transparent materials, or when Metallic is checked.              

 l Specular controls how bright the material appears when illuminated by a point or spot light. It simulates the 
reflection of light off a surface. Not available for Reflective, Predefined Metal, Mirror, or Transparent materials.              

 l Roughness controls how shiny a material is when illuminated by a point or spot light. A material with a low 
Roughness value has a bright, round spot of light when rendered with a point or spot light shining on it. Not 
available for Polished, Mirror, or Transparent materials, or when a Roughness Map is specified, below.              

 l Transparency controls how opaque or transparent a material is. Most materials are opaque while some materials, 
such as glass, are partially transparent. In some situations, materials with transparency can slow down rendering 
speed. Only available for General materials, this option is not available when Metallic is checked.               

For maximum Transparency, specify the Material Color as white 
on the Pattern panel of this dialog. A black material will be 

opaque regardless of its transparency setting.
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 l Emissive controls how bright a material appears independent of the lighting in the scene. It can be used to simulate 
surfaces that are glowing with their own light, such as the glass on a light fixture. Choose a level of brightness from 
the drop-down list and customize it using the spin control arrows or text field. Only available for General materials, 
this option is not available when Metallic is checked.               

 l Reflection controls how reflective a material appears in CPU Ray Trace views. See CPU Ray Trace Views on page 
1164. Click the Color button to specify the color of light reflecting off a Mirror or Shiny Metal material. For most 
material classes, Reflection is best seen at glancing angles to the surface. For reflectivity from all angles, use a 
Mirror material. Not available for General, Matte, Plastic, Polished, or Predefined Metal materials.               

 l Translucency controls the degree to which light coming directly from a light fixture shines through the material. 
Only available for Translucent materials, this setting only affect CPU Ray Trace views.              

 l Select a Metal from the drop-down list. Only available for Predefined Metals.               

 l Brushed Metal creates a brushed appearance for Predefined Metal materials.               

Polished and Brushed Predefined Metals can have different amounts of roughness running in different directions on a given 
surface. These surfaces look different depending on the viewing angle.          

 l U Roughness produces reflective highlights oriented horizontally. Only available for Polished materials and Brushed 
Predefined Metal materials.              

 l V Roughness produces reflective highlights oriented vertically. Only available for Polished materials and Brushed 
Predefined Metal materials.              

 l Index of Refraction controls how much light bends when it passes through the material in GPU and CPU Ray Trace 
views. A value of 1 is the lowest possible value and produces no light bending. Only available for Transparent 
materials.               

 
Roughness Map

A Roughness Map defines areas of varying roughness and glossiness. Not available for Mirror or Transparent materials. See 
Material Maps on page 1051.             

 l The full path name of the selected roughness map image File displays here. To remove the file, click the Remove   
button.               

 l Click the Browse button to select a file saved on your computer. Roughness maps saved in .zip files can be used. 
See To use an image saved in a .zip file on page 1073.         

 
Metal Map

A Metal Map defines areas within a texture that are metallic. Only available for General materials.             

 l The full path name of the selected metal map image File displays here. To remove the file, click the Remove   
button.              

 l Click the Browse button to select a file saved on your computer. Metal maps saved in .zip files can be used. See To 
use an image saved in a .zip file on page 1073.         
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Preview

A preview of the material applied to an object displays here and updates as changes are made to the material definition. 
Various options allow you to view different aspects of the material’s attributes:             

 l Display the material in Physically Based rendering, Standard rendering, Vector View, or in a CPU Ray Trace view.             

 l Zoom and orbit the object in the view.             

 l Toggle Color on or off.             

 l Click the Restore Original View  button to reset the material preview to its original perspective.             

 l Select an object shape: Cube, Sphere, Teapot, or Plane.             

 l Select a Ray Trace Configuration from the drop-down list to use in the preview. Only available when CPU Ray 
Trace is the selected preview view type.              

MATERIALS LIST PANEL

The settings on the MATERIALS LIST panel control how the selected material is counted in the Materials List. See Materials 
and the Materials List on page 1064.          

 
Material Name

The Material Name displays here. You can type a different name if you wish. Renaming the material does not create a new 
material: it redefines the existing material.         
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  Specifications

 l Select a Material Structure Type from the drop-down list. The selected Type defines how - or whether - the 
material is calculated in the Materials List. See Material Structure Types on page 1064.         

 l Select a Materials List Calculation method. When “Framing” is the selected Structure Type, the only available 
Calculation Method will be “Framing". See Calculation Methods on page 1064.          

 l The settings that are available below depend on which Calculation method is selected.          

 l Specify the material’s Width. This value is available for Count and Linear Calculation methods.          

 l Specify the material’s Height. Only available for the Count Calculation method.          

 l Click the Update from Pattern button to make the Width and Height values here match those set on the PATTERN 
panel. Only available when Count or Linear is selected as the Calculation method.         

 l Specify the material’s Depth. Only available for the Count Calculation method, this value is only used for Materials 
List calculations when the material is applied to a Soffit or Primitive object. This value may also be used if the 
Material Painter is used to create a floor or ceiling finish. See Floor and Ceiling Finishes and the Material Painter 
on page 434.

MANUFACTURER PANEL

If the selected material is from a Manufacturer library catalog, the Define Material dialog will have a              fifth              panel: the 
MANUFACTURER panel, which lists contact information. See Manufacturer Catalogs on page 970.          

 

Pattern from Texture Dialog
Click the Pattern from Texture button in the Define Material dialog to create a custom pattern based on the material’s 
texture. This dialog also opens if you click on the name of a custom pattern in the Type drop-down list. See Pattern Panel 
on page 1067.          
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  Source

 l Select a material map assigned to the selected material from the Source drop-down list. See Material Maps on page 
1051.

 l The full pathname of the selected Source File is reported and can be changed in the text field. Click the Browse 
button to choose a different file if you wish. See Opening and Importing Files on page 44.

 
Simple

The Simple option is selected by default. Use the Threshold slider bar or text field to control the strength of edge lines in 
the pattern output. A low value produces many pattern lines while a high value produces few.         
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Advanced

Select Advanced to enable additional controls for generating edge lines in the pattern.         

 l Use the Low and High Threshold slider bars and/or text fields to control the strength of edge lines in the pattern 
output. Low values produce many pattern lines while high values produces few.          

 l Click the Auto Compute Thresholds button to reset the Threshold values automatically generated for the current 
material texture.           

 l When Use Threshold Factor is checked, the High Threshold setting will be greater than the Low Threshold setting 
by the Threshold Factor value and the two values will be tied together. Uncheck this box to edit the two values 
separately.           

 l Specify the Threshold Factor, between 1 and 10. Not available when Use Threshold Value is unchecked.           

 l Select a Filter Size from the drop-down list. A smaller size generates fewer lines while a larger size generates more.           

 
Original Image

A preview of the material texture displays in the Original Image pane for reference.         

 
Output Image

A preview of the pattern displays in the Output Image pane. As changes are made to the settings on the left, this preview 
will update.         
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Chapter 32
 

3D Views

Little preparation is needed to create a 3D view of a model: simply click a button to create an overview or click and drag to 
create a camera or cross section/elevation view. 

To improve the quality of the rendering and create a custom look, you can adjust lighting and edit the materials used in the 
plan. See 3D Rendering on page 1129.

Many objects can be placed and edited in 3D views, and any camera view or overview can be saved or even used to record 
a walkthrough. See Pictures, Images, and Walkthroughs on page 1180.
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Types of 3D Views
There are three categories of 3D views in Chief Architect: camera views, overviews and cross section/elevation views. Each 
of these view types can be generated using a variety of Rendering Techniques. See Rendering Techniques on page 1147.         

Every 3D view is also either orthographic or perspective in nature. Cross section/elevation views are always orthographic 
while camera views are always perspective. You can choose to generate overviews as either orthographic or perspective.           

PERSPECTIVE AND ORTHOGRAPHIC VIEWS

Perspective views have a focal, or vanishing, point. Surface edges and lines that would be parallel in real life appear to 
converge towards that focal point, and objects closer to the camera appear larger while objects farther from the camera 
appear smaller.          

Orthographic views do not have a focal or vanishing point. Parallel surface edges and pattern lines appear parallel in these 
views and objects appear to be the same size regardless of their distance from the camera.          

Perspective views display 3D objects much the way that they appear to the eye in real life, so they are ideal for presentation 
views. By default, perspective views are created using the Standard Rendering Technique.          

Orthographic views, on the other hand, are useful for technical drawings. By default, orthographic views are created using 
the Vector View technique.          

RENDERED AND VECTOR VIEWS

3D views can be generated using a variety of different Rendering Techniques. See Rendering Techniques on page 1147.          

Most rendered views represent materials using textures. Surface edge lines are generally not drawn and lighting is often 
modeled, creating results that range from a photorealistic appearance to artistic painting styles. Standard rendered views can 
also be Ray Traced for additional realism. See CPU Ray Tracing on page 1163.

Vector Views are non-photorealistic views in which objects are drawn using surface edge lines, or vectors. Limited lighting 
and shadows can be calculated and materials are represented using pattern lines and solid colors. Vector Views are ideal for 
layout drawings and high resolution printing. See Vector View on page 1147.         

 

3D View Defaults and Preferences
There are a number of defaults and preference settings that allow you to control the initial characteristics of 3D views.           

  Camera positioning, field of view and related initial settings for camera views are specified in the Camera 
Defaults dialogs. See Camera Defaults Dialogs on page 1082.             

  The settings in the 3D View Defaults dialog control a variety of functions that affect views created by all 3D 
View tools. See 3D View Defaults Dialog on page 1084.             
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  The default characteristics of the Generic Sun light source can be specified in the Generic Sun Defaults dialog. 
See Adjust Sunlight Dialog on page 1145.             

  As in plan view, the display of objects in 3D views can be controlled by layer. You can specify which layer set is 
initially used when a view is created by each of the 3D View tools. See Layer Set Defaults on page 188.

  3D views can be generated using any of the Rendering Techniques. See Rendering Techniques on page 1147.             

  The initial settings for each Rendering Technique can be set in the Rendering Techniques Defaults dialog. See 
Rendering Technique Options on page 1150.             

  The RENDER panel of the Preferences dialog has settings that affect 3D views. See Render Panel on page 129.             

 

Camera Defaults Dialogs
There are several defaults dialogs for cameras, which can be accessed by selecting  or by double-clicking either the 
Orthographic or Perspective View Tools parent button. Select an item in the submenu to open the defaults dialog 

associated with your selection.

The defaults dialog for Camera Tools other than Overviews can be accessed by double-clicking the associated toolbar 
button.          

The various Camera Defaults in the list can be multiple-selected and then edited as a group by holding down the Shift or 
Control keys. Depending on the selection, not all settings may be available. See Shift and Ctrl Select on page 217.          

The settings in the Camera Defaults dialogs affect how each type of camera captures, clips, and renders views; how they 
display in  plan view; how they are positioned; and how they move.          

Once a camera is created, its attributes can be customized. See Editing 3D Views on page 1105.

FULL CAMERA DEFAULTS

Specify the initial attributes of cameras created using the Full Camera  tool. See Camera Views on page 1086.

The settings in this dialog are the same as those the Full Camera Specification dialog. See Camera Specification Dialogs on 
page 1116. 

Note: The Reflections setting in the Full Camera Defaults is used by 
walkthroughs created using the Walkthrough Path tool. See Recording a 
Walkthrough on page 1213. 
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FLOOR CAMERA DEFAULTS

Specify the initial attributes of cameras created using the legacy Floor Camera  tool. This tool is not in the menus or 

default toolbars but can be added to the toolbars               and/or assigned a hotkey if you wish. See Toolbars and Hotkeys on page 
133. 

The settings in this dialog are the same as those in the Floor Camera Specification dialog.           

PERSPECTIVE FULL OVERVIEW DEFAULTS

Specify the initial attributes of cameras created using the Perspective Full Overview  tool. See Full Overview on page 

1088.         

The settings in this dialog are the same as those in the Perspective Full Overview Specification dialog.

PERSPECTIVE FLOOR OVERVIEW DEFAULTS

Specify the initial attributes of cameras created using the Perspective Floor Overview  tool. See Floor Overview on 

page 1089.         

The settings in this dialog are the same as those in the Perspective Floor Overview Specification dialog.

PERSPECTIVE FRAMING OVERVIEW DEFAULTS

Specify the initial attributes of cameras created using the Perspective Framing Overview  tool. See Overviews on page 

1086.   

The panels in this dialog are the same as their respective panels in the Orthographic Framing Overview Specification dialog. 

CROSS SECTION/ELEVATION DEFAULTS

Specify the initial attributes of cameras created using the Cross Section/Elevation  tool. See Cross Section/Elevation 

Views on page 1086.         

The settings in this dialog are also found in the Cross Section/Elevation Specification dialog. See Cross Section/Elevation 
Specification Dialogs on page 1123.         

BACK CLIPPED CROSS SECTION DEFAULTS

Specify the initial attributes of cameras created using the Back Clipped Cross Section  tool. See Cross 

Section/Elevation Views on page 1086.          

The panels in this dialog are the same as their respective panels in the Cross Section/Elevation Specification dialog. See 
Cross Section/Elevation Specification Dialogs on page 1123.          

WALL ELEVATION DEFAULTS

Specify the initial attributes of cameras created using the Wall Elevation  tool. See Cross Section/Elevation Views on 

page 1086.         

The panels in this dialog are the same as their respective panels in the Wall Elevation Specification dialog. See Cross 
Section/Elevation Specification Dialogs on page 1123.          
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ORTHOGRAPHIC FULL OVERVIEW DEFAULTS

Specify the initial attributes of cameras created using the Orthographic Floor Overview  tool. See Full Overview on 

page 1088.          

The panels in this dialog are the same as their respective panels in the Orthographic Full Overview Specification dialog.           

ORTHOGRAPHIC FLOOR OVERVIEW DEFAULTS

Specify the initial attributes of cameras created using the Orthographic Full Overview  tool. See Overviews on page 

1086.         

The panels in this dialog are the same as their respective panels in the Orthographic Full Overview Specification dialog. 

ORTHOGRAPHIC FRAMING OVERVIEW DEFAULTS

Specify the initial attributes of cameras created using the Orthographic Framing Overview  tool. See Overviews on 

page 1086.   

The panels in this dialog are the same as their respective panels in the Orthographic Framing Overview Specification dialog.

 

3D View Defaults Dialog
Select 3D> 3D View Defaults or Edit> Default Settings  to open the 3D View Defaults dialog.         

The settings in this dialog control a variety of functions that affect views created by all 3D View tools.           

 
General Options

These settings affect all 3D views. 
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 l Check Camera Bumps Off Walls to prevent cameras from moving freely through walls. When this setting is on, 
you can "walk" up a staircase by moving the camera using the Move Camera Tools. This should be unchecked 
when using a 3D mouse or gamepad. See 3Dconnexion® 3D Mice on page 1100 and Move Camera Tools on page 
1103.

 l Check Auto Rebuild Walls/Floors/Ceilings to automatically rebuild floors and ceilings before a 3D view or 
elevation is displayed. When this is unchecked and the structure is not up-to-date, the Rebuild Walls, Floors, 
Ceilings   icon displays near your mouse pointer. See Rebuilding Walls, Floors and Ceilings on page 748.

 l Check Legacy Compatible Texture Mapping to use global texture mapping settings rather than texture mapping 
fixed to individual objects. 

Legacy Compatible Texture Mapping should remain 
unchecked except in legacy plans with custom rotated textures.

 l When Auto Adjust Electrical Default Glass Properties is checked, the program automatically adjusts the 
behavior of electrical fixture glass in Standard rendered and CPU Ray Trace views in response to interior and 
exterior lighting conditions. When this box is unchecked, these adjustments are not made. 

 l Check Always Display Active Cameras to turn on the display of active camera symbols, even when the 
“Cameras” layer is turned off. When unchecked, active camera symbols obey the layer setting.

 l When Display Openings Independent of Walls and Roofs is checked, doors, windows, and skylights display in 
3D views when their containing wall or roof plane does not. Uncheck this to prevent these objects from displaying 
in 3D when their parent objects do not. 

 
Vector View Options

                 See Vector View on page 1147.

 l Framing Back Clip defines the back clip for framing members in cross section views. Framing must be set to 
display to see the effects of this value. A zero value does not back clip at all. See Displaying Framing on page 
894.

 
Surface Edge Lines

Specify how Surface Edge Lines display for all objects in Vector View renderings. Surface edge line color in Technical 
Illustration renderings are also affected by these settings. See Rendering Techniques on page 1147.

 l Check Use Layer Settings to display surface edge lines for objects using the display settings specified by layer in 
the Layer Display Options dialog. If this option is not checked, all edge lines are drawn black and solid with a line 
weight of 0. See Layer Attributes on page 181.

 l When Use Object Settings is checked, all objects that have non-default settings specified on the LINE STYLE panel 
of their specification dialog display using those settings, overriding the layer settings in the Layer Display Options 
dialog. See Line Style Panel on page 310.

 

3D View Tools
Select 3D> Create Orthographic View to display the Orthographic View Tools or 3D> Create Perspective 
View to display the Perspective View Tools. 

There are four types of 3D Views:
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CAMERA VIEWS

Camera views are Perspective views. They are not scaled and cannot be annotated but are ideal for creating presentation 
views.          

  The Full Camera tool creates multi-floor views of the 3D model. It can be used to create interior and exterior 
perspectives, and is good for displaying cathedral ceilings, roofs, lofts, stairwell openings, and other variation in 

floor and ceiling levels.
  The Floor Camera tool creates perspective views of the current floor only. Nothing above the ceiling surface is 
generated, and neither is anything below the floor. This legacy tool is not in the menus or default toolbars but can 

be added to the toolbars              and/or assigned a hotkey if you wish. See Toolbars and Hotkeys on page 133. 

OVERVIEWS

An overview can be either orthographic in nature or perspective, depending on the tool used to create it. See Creating 
Overviews on page 1088.

  The Orthographic and Perspective Full Overview tools create views of the entire model including all 
floors, ceilings, and the roof.    

                   The  Orthographic and Perspective Floor Overview tools create views of the current floor with the 
ceiling removed and all floors beneath it visible.         

                   The Orthographic and Perspective Framing Overview tools create views of the framing in the model. 
Framing must be built in order for it to display in a framing overview. See Framing Overview on page 

1089.    
  The Isometric Overview tools create specially oriented and scaled overviews that are common in engineering 
drawings. These tools are only available when an Orthographic Overview is active. See Isometric Overviews on 

page 1089.         

CROSS SECTION/ELEVATION VIEWS

Cross Section/Elevation views are similar to the traditional, scaled orthographic views often used in drafting. They are 
scaled and can be fully annotated. See Cross Section/Elevation Views on page 1090.         

  A Cross Section/Elevation view displays all floors of the model. If the view is created outside the structure 
looking toward it, the result is an exterior elevation. If the view is created inside the structure, or passes through 

any of the structure, a cross section is created.         
  The Back Clipped Cross Section tool includes only the objects between the starting point and stopping point of 
the cross section line.         

  The Wall Elevation tool creates an elevation of a wall on a single floor and in a single room. The Wall 
Elevation tool cannot be used to create exterior views.         

Select 3D> Create Auto Elevations  to access tools that create, save, and name elevation views as soon as the tool is 

selected. These tools can also be added to your toolbars. See Auto Elevation Tools on page 1091.           

  The Front Elevation tool creates an exterior elevation of the front of the model (on screen, the bottom).         

  The Back Elevation tool creates an exterior elevation of the back of the model (on screen, the top).         

  The Left Elevation tool creates an exterior elevation of the left side of the model.         
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  The Right Elevation tool creates an exterior elevation of the right side of the model.         

  The All Elevations tool creates an exterior elevation of the front, back, left, and right sides of the model.         

  The Create Room Elevation Views edit tool creates an interior elevation view of each wall defining a selected 
room. This tool is found on the Edit Toolbar for a selected room rather than in the 3D menu. See Editing Rooms 

on page 425.          

An individual wall’s framing members can also be displayed and 
edited in a Wall Detail view. See In Wall Detail Views on page 

896.

CPU RAY TRACE VIEWS

CPU Ray Trace views are a special type of high-quality 3D view in which the paths individual photons are calculated 
so that realistic lighting effects can be modeled. They cannot be created directly from plan view. Instead, you must 

first create a Standard or Physically Based rendered view of the desired scene and then select 3D> CPU Ray Trace. See 
CPU Ray Tracing on page 1163.         

 

Creating Camera Views
All Camera views are created using the same method.

To create a camera view
 1.  In plan view, select the desired camera tool. The mouse pointer displays the camera   icon. 

 2.  Click and drag a line to define the view direction.

A. Camera Position (click)
B. Line of Sight (drag)
C. Focal Point (release)
D. Field of View

 l The camera's position is where you click to begin the line. 

 l The line that you drag defines the direction the camera is pointed. 

 l The end of the line is the focal point of the view, the point the camera rotates around.

 l The Field of View is 55° by default.

 3.  When you release the mouse button, a view generates in a new window.

 4.  Return to the plan view. A camera symbol now displays in plan view. See Working in Multiple Views on page 154.

In order to create a camera view, you must click and drag at least as far as your current Snap Distance. See Snap Properties 
Panel on page 122. 
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A new camera can also be created by copying and pasting an existing camera symbol selected in plan view. See Copying 
and Pasting Objects on page 171.

You can also create a camera view based on a single frame of a 
Walkthrough Path. See Walkthrough Previews on page 1210.

CAMERA HEIGHT

By default, Cameras are created at a height of 60” (1500 mm). Where this height is measured from depends on the location 
of the camera:

 l If the camera is inside a room, it is measured from that room’s subfloor.
 l If the camera is outside a room but inside the Terrain Perimeter, it is measured from the terrain at the location of the 

camera.         
 l If the camera is located in neither a room nor within the Terrain Perimeter, it is measured from the default height of 

the subfloor for the current floor. 

Once created, a camera’s height can be modified in its Camera Specification dialog, and the default height value can be set 
in the Camera Defaults dialog. See Camera Panel on page 1116.

 

Creating Overviews
In Chief Architect, there are three different overview types: Full, Floor, and Framing Overviews.         

Each type of overview can be generated as either an orthographic or perspective view. An overview window’s title bar 
indicates whether it is perspective or orthographic. See Perspective and Orthographic Views on page 1081.         

Overviews generate as soon as you select the tool and are always created at the same 120° angle. The initial focal point is 
located at the center of the architectural model: the terrain is not taken into consideration determining its position. The 
distance of the camera from the model will vary depending on its size: the larger the architectural model, the further away 
the camera will be from the focal point so that the entire model can be seen in the view. 

A new overview camera can also be created by selecting an existing overview camera in plan view and then copying and 
pasting it. See Copying and Pasting Objects on page 171.

Once generated, an overview window’s title bar indicates its view type and a camera symbol in plan view represents its 
location. An overview camera can be edited much like regular camera views can. See Editing 3D Views on page 1105.

FULL OVERVIEW

Select 3D> Create Orthographic View> Orthographic Full Overview or 3D> Create Perspective View> 
Perspective Full Overview to generate an exterior view of the entire model. 
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FLOOR OVERVIEW

Select 3D> Create Orthographic View> Orthographic Floor Overview  or 3D> Create Perspective View> 
Perspective Floor Overview to create a view of the current floor with the ceiling removed and all floors 

beneath it visible.

Floor Overviews are an effective tool for illustrating traffic flow and the relationships between spaces.  

To see a different floor, select Tools> Floor/Reference Display> Up One Floor  or Down One Floor . You can also 

return to plan view and make another floor current before generating the Floor Overview.

If you prefer, you can specify in the Camera Defaults dialog that only the current floor be included in Floor Overviews. See 
Camera Defaults Dialogs on page 1082.           

FRAMING OVERVIEW

Select 3D> Create Orthographic View> Orthographic Framing Overview or 3D> Create Perspective 
View> Perspective Framing Overview to create a view of the entire model, displaying only framing and the 

foundation. 

Framing overviews include all floor, wall, and roof framing as well as foundations. Unlike other overviews, which use the 
Camera View layer set, Framing Overviews use the 3D Framing Set. See Layer Sets on page 186.

Framing must be built before generating this view or the view will be empty.           

ISOMETRIC OVERVIEWS

An Isometric Overview is a special orthographic view in which the camera is positioned in such a way that the angles 
between the X, Y, and Z axes are all 120° in that view. See 3D Drafting on page 12. 

In addition, Isometric Overviews use scaling that is approximately 1.2 times that used in a normal projection so that lines 
parallel to the X, Y, and Z axes measure their true length in the 2D projection. As such, Isometric Overviews can be useful 
for technical drawings but may not be well suited for presentation views.           
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To create an Isometric Overview, begin in an Orthographic 
Overview. See Perspective and Orthographic Views on page 

1081.

To create an Isometric Overview
 1.  Create an Orthographic Full Overview  or Floor Overview .

 2.  With the Orthographic view active, select 3D> Isometric Overviews and choose a view option from the submenu.

 3.  The camera’s position will adjust, as will the scaling used in the view.

 4.  If you move, orbit, or tilt the camera, the camera will return to normal scaling.

 

Cross Section/Elevation Views
The cross section/elevation tools produce the traditional, orthogonal views often used in drafting. Regardless of their 
distance from the camera, all lines and dimensions in these views are their true lengths, making it easy to accurately see the 
spatial relationships of the 3D objects in the model. Each of these tools has a specific function:

  A Cross Section/Elevation view displays all floors of the model. The cross section begins at the point where the 
camera arrow is drawn and continues through the entire model.    

  The Back Clipped Cross Section tool includes only the objects or portions of objects between the starting point 
and stopping point of the camera’s Line of Sight.    

  The Wall Elevation tool creates an interior elevation of a single wall defining the room that the camera is drawn 
in. It creates a 2D projection of that wall and the objects located between that wall and its Cross Section Line; 

does not cut through walls or show the ceiling, floor, or roof; and is used primarily for kitchen and bath elevations. This 
tool cannot be used to create exterior views.    

Additional tools allow you to create and save multiple elevation views with a single click:    

  The Auto Elevation Tools create exterior elevations of the front, back, left and right sides of the model. See 
Auto Elevation Tools on page 1091, below.    

  The Create Room Elevation Views edit tool creates an interior elevation view of each wall defining or present 
in a selected room. To create elevation views for a room, select the room and then select this edit tool. See 

Editing Rooms on page 425.   
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Cross section/elevation views are the only 3D views that can be enhanced with the 2D CAD tools. They can be fully 
annotated and dimensioned and then printed to scale. See Detailing Cross Section/Elevation Views on page 1092, below.

Cross Section/Elevation, Back Clipped Cross Section, and Wall Elevation views are created in the same way.   

To create a cross section/elevation view
 1.  Select the Cross Section/Elevation , Back Clipped Cross Section , or Wall Elevation tool. The pointer 

changes to a   with crosshairs marking the position of the pointer.

 2.  Click and drag a line in plan view.             

 l If you selected the Wall Elevation tool, you must click inside a room area.

 l A Camera symbol displays where you click, along with a Cross Section Line indicating the plane of the camera’s 
cross section cut line.                 

A. Camera location (click)
B. Line of Sight (drag)
C. Focal Point (release)
D. Cross Section Line
E. Back Clipping Line (when 
applicable)

 3.  Drag in the direction of the Line of Sight to draw a camera arrow.             

 l Always drag the camera arrow perpendicular to the wall to be viewed.                  

 l If the view is a Back Clipped Cross Section, a second Cross Section Line at the end of the Line of Sight indicates 
the furthest extent of the back clip.     

 4.  When you release the mouse button, the view generates in a new window.             

 5.  Once created, a cross section/elevation view's extents can be edited. See Camera Panel on page 1124.

As with camera views, you must click and drag at least as far as your current Snap Distance in order to create a Cross 
Section/Elevation view. See Snap Properties Panel on page 122.          

A new cross section/elevation view can also be created by copying and pasting an existing cross section/elevation camera 
symbol selected in plan view. See Copying and Pasting Objects on page 171.

Once created, the clipping in all cross section/elevation views can be customized to control how much of the model is 
included in the view. See Camera Panel on page 1124.    

If the Line of Sight does not cut through a 3D object and the object is within the back clipped distance, such as a window 
shown in elevation, the object retains its 3D definition and can be selected, moved, stretched, or otherwise modified in the 
view. The 3D model is updated in all views.         

AUTO ELEVATION TOOLS

The Auto Elevation Tools create exterior elevations of the front, back, left and right sides of the model. To use any of 
these tools, simply select it: the camera view - or all four camera views - are automatically created, saved and named. 

See Saving 3D Views on page 1114.         
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At least one wall or railing must be present in the plan in order for the Auto Elevation  tools to work. If no walls or 

railings have been drawn, nothing will happen when any of these tools is selected.           

The directions that these four elevation cameras point are directly related to the orientation of the X and Y axes, reference 
grid and snap grid in the plan. See 3D Drafting on page 12.           

The front elevation is located below the model on-screen and points upward while the back elevation is found above the 
model and points downward. This may not be the case, however, if you have used the Rotate Plan View  tool. See 

Rotate Plan View on page 151.           

If the same Auto Elevation view is created more than once, the additional camera symbols are placed progressively further 
away from the model in plan view and are numbered. If an Auto Elevation is renamed and then the view created again, the 
symbols may overlap.           

The Auto Elevation Tools  parent button can be added to the toolbars if you wish. See To add a button to a toolbar on 

page 137.           

DETAILING CROSS SECTION/ELEVATION VIEWS

CAD objects, including Text and Dimensions, can be created in cross section/elevation views. These objects are 
superimposed on the view and have no effect on the 3D model itself. If CAD> objects have been added to a cross 

section/elevation view, the program will prompt you to save the view before closing the window. This information is then 
stored in the view.   

Labels for cabinets and other objects can display in cross 
section/elevation views. See Displaying Labels on page 712.

A selection of Auto Elevation Dimension tools automatically generate dimension sets and story poles in cross 
section/elevation views. See The Automatic Dimension Tools on page 480.          

Annotations in cross section/elevation views are created using the view’s Active Defaults, which can be set in the Cross 
Section/Elevation Specification dialog. See Selected Defaults Panel on page 1126.          

In cross section views, some objects, such as walls, may be represented using Cross Section lines. If a dimension line finds 
an object surface edge represented by a Cross Section line, a Point Marker will be placed at that location, and the dimension 
will locate it instead of the Cross Section line. See Markers on page 538.          

CAD objects will snap to the Snap Grid when Grid Snaps  are enabled. Note that the 3D model may obscure the display 

of the Snap Grid. See Grid Snaps on page 167.           

 When the Vector View rendering technique is used, you can select CAD> CAD Detail From View to create a 2D 
line drawing of the active cross section/elevation view in a CAD Detail window. This drawing can then be edited as 

needed. See CAD Detail from View on page 341.         

Annotated cross section/elevation views can               also be sent to layout. See CAD and Text in Layout on page 1342.   

CALLOUT LABELS

By default, cross section/elevation cameras display a callout symbol in plan view. When the view is sent to layout, the 
Automatic Text Below Line will report the Label of the layout page the view was sent to. To avoid  unexpected results when 
using the Automatic Text Below Line, do not send the same camera view to layout more than once. See Plan Display Panel 
on page 1126.           
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Clipped Section Views
The Cross Section/Elevation Specification dialog has Scene Clipping options that allow you to control the extents of the 
view and thus how much of the model it shows. See Camera Panel on page 1124.

In plan view, information about its front, back, and side clipping are indicated when a camera symbol is selected. In a 
clipped view, side and elevation clipping are indicated using Clip Lines on the "CAD, Clip Lines" layer. See Displaying 3D 
Views on page 1096.

FRONT AND BACK CLIPPING

All cross section/elevation views have a clipping plane positioned at the same location as the camera and running 
perpendicular to its Line of Sight. This front clipping plane is also referred to as the Cross Section Line, and is shown in 
plan view when the camera's symbol is selected. If an object is positioned so that it is cut by this plane, its edges will be 
drawn but the object will not be selectable in the view. 

There are two ways to adjust the position of the front clipping plane:

 l Specify the camera's X and Y Position value in the Cross Section/Elevation Specification dialog.
 l Use the camera's edit handles in plan view to reposition the start point of its Line of Sight. 

By default, Back Clipped Cross Section views also have a second clipping plane: the Back Clip plane, which controls how 
far into the model from the camera the view extends: objects located further from the camera than the Back Clip plane are 
not included in the view while those located between the front and back planes are. A Back Clip can be specified for any 
cross section/elevation view once it has been created. 

There are two ways to specify the distance between the front and back clipping planes:

 l Set a specific Back Clip After value in the Cross Section/Elevation Specification dialog.
 l Use the camera's edit handles in plan view to move the end of its Line of Sight, changing its length. 

STEPPED CUTTING PLANES

You can create one or more steps in the front and back clipping planes using the Add Break  edit tool, allowing you to 

cut some objects while avoiding others. See Add Break on page 257.     

To create a stepped cutting plane
 1.  In plan view, select a Cross Section/Elevation  or Back Clipped Cross Section  camera. See In Plan View 

on page 1097.     

 2.  Click the Add Break  edit button, then click on the front cutting plane of the selected camera symbol to add a 

new diamond-shaped Resize edit handle at the point where you clicked.     
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 3.  Click and drag the edit handle on either side of the break perpendicular to the cutting plane to create a step.     

 4.  Click and drag the edit handle associated with the break parallel to the cutting plane to adjust the position of the step.
     

SIDE CLIPPING

By default, cross section/elevation views include the entire width of the 3D model. You can instead choose to Clip Sides in 
the Cross Section/Elevation Specification dialog. There are three ways to specify a view's Clip Width:

 l Set a specific value in the Cross Section/Elevation Specification dialog.
 l Use the edit handles in plan view to change the length of the Cross Section Line, or front cutting plane. 
 l In the view itself, turn on the "CAD, Clip Lines" layer and adjust the position of the vertical Side Clip lines using the 

edit handles.

You can toggle side clipping in an active view by selecting 3D> Camera View Options> Clip Sides. This option is 
not available for views set to Clip to Room.

TOP AND BOTTOM CLIPPING

By default, cross section/elevation views include the entire height of the 3D model. You can instead choose to Clip 
Elevation in the Cross Section/Elevation Specification dialog. There are two ways to specify the top and bottom extents of a 
clipped view:

 l Set a specific Bottom and Top Clip Elevation values in the Cross Section/Elevation Specification dialog.
 l In the view itself, turn on the "CAD, Clip Lines" layer and adjust the position of the horizontal Elevation Clip lines 

using the edit handles.

When both Side and Top/Bottom Elevation clipping are in use, 
the Add Break and Make Parallel/Perpendicular edit tools can be 

used to customize the horizontal top and bottom clipping planes. These 
tools do not affect the vertical side clipping planes, however. See Add 
Break on page 257 and Make Parallel/Perpendicular on page 252.

You can toggle elevation clipping in an active view by selecting 3D> Camera View Options> Clip Sides. Not 
available for views set to Clip to Room.
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CLIP TO ROOM

The Clip to Room option in the Cross Section/Elevation Specification dialog is only available when a selected view camera 
is located inside a room. This option is the default for Wall Elevation views, and produces a view showing a single wall 
defining the camera's room along with any objects between the camera and that wall. When this setting is in use, the other 
clipping options are disabled.

SCENE CLIPPING AND CAMERA DEFAULTS

The default Scene Clipping settings for the Cross Section/Elevation, Back Clipped Cross Section, and Wall Elevation tools 
are restricted to preserve these tools' intended functions and avoid unexpected behavior; however, once a view is created 
using one of these tools its clipping settings are fully editable.

If you change the Scene Clipping settings of a view and then use the Set as Default  edit tool:

 l It will update the Wall Elevation Defaults if Clip to Room is checked.
 l It will update the Back Clipped Cross Section Defaults if Back Clip is checked.
 l If neither of these boxes is checked, the Cross Section/Elevation Defaults will be updated.

See Set as Default on page 79.

 

Auto Detail
The Auto Detail tool automatically creates CAD objects for commonly detailed components of cross section views. 
To use this tool, select CAD> Auto Detail while a cross section view is active.

Auto Detail creates CAD objects in walls, floor and ceiling platforms, foundation walls and footings, slabs, roof and ceiling 
planes, as well as Material Regions and Custom Backslashes that are intersected by the cross section plane as follows: 

 l Walls - Creates closed CAD polylines for each wall layer with a fill style specified in the wall type definition. The 
polyline uses the same fill as that specified for the wall layer. See Wall Type Definitions on page 388.

 l Floors and Ceilings - Creates closed CAD polylines for each floor and ceiling layer with a fill style specified in the 
Platform or Finish definition. See Floor and Ceiling Platform Definitions on page 434.

 l Roof and Ceiling Planes - Creates closed CAD polylines for each roof layer with a fill style specified in its Surface, 
Structure, or Ceiling definition. See Roof Layers on page 821.
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 l Foundations - Closed polylines are created for foundation walls, footings, and floors. 
 o The fill styles for wall layers are specified for the wall layer in the wall type definition.
 o The fill style for footings is “Concrete”.
 o The fill style for the floor is set in the floor platform definition.

 l Slabs - Closed polylines using the “Concrete” fill style are created for Slabs. See The Slab Tools on page 731. 
 l Material Regions - Closed polylines for each layer of a Wall or Floor Material Region or a Custom Backsplash are 

created. The polylines use the fill style specified in the object’s material layers definition. See Floor and Wall Material 
Regions on page 1037.

The CAD objects created by the Auto Detail tool are placed on the Current CAD Layer. See Current CAD Layer on page 
332. 

Once created, these CAD objects can be selected and edited. See Editing Closed Polyline-Based Objects on page 230 and 
Editing Box-Based Objects on page 234.

Note: Using the Auto Detail tool twice results in two copies of the same 
CAD objects.

INSULATION AND AIR GAPS

Instead of using the fill style specified for a given structural assembly Material Layer, the Auto Detail tool can generate an 
Insulation  CAD box along the length of a structural layer. See Insulation on page 326.   

To achieve this for a particular Material Layer, select that layer and check Auto Detail as Insulation in the structural 
component's definition. See Wall Type Definitions Dialog on page 390 and Material Layers Definition Dialogs on page 
1040.

Similarly, if a Material Layer has Air Gap checked, no CAD object will be created to detail that layer, regardless of its 
specified fill style.  

 

Displaying 3D Views
A variety of tools and settings allow you to control the appearance of 3D views. There are also numerous ways to adjust a 
3D view’s position, focal point and field of view. See Editing 3D Views on page 1105.

The name of the current plan file and the type of view displays at the top of each view window in its title bar. If a 3D view 
is saved, its name also displays. 

There is no limit to the number of 3D view windows that you can have open at a given time; bear in mind, though, that each 
window demands use of your computer’s resources and that you may see poor performance if too many views are open. See 
Working in Multiple Views on page 154.

The 3D model will rebuild automatically as you draw; however, if you notice any anomalies in the model in 3D, 
select 3D> Rebuild 3D to regenerate all 3D data associated with the current plan. All open views will remain open.

LAYER DISPLAY OPTIONS

As in plan view, the display of objects in 3D views can be controlled by layer. See Layer Display Options Dialog on page 
183.

Different view types use different layer sets when they are created. See Layer Sets on page 186.
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To show framing in a cross section/elevation view, framing must first be built using the Build Framing dialog and the 
appropriate framing layers must be turned on in the Section View layer set. See Framing on page 864. 

To show a view's Clip Lines, turn on the "CAD, Clip Lines" layer in that view. See Clipped Section Views on page 1093.         

IN PLAN VIEW

Cameras can be represented in plan view in either of two ways:

 l By symbols that indicate the camera’s position, field of view and focal point. 

 l A selected camera symbol representing a cross section/elevation view indicates its front clip plane position, line of 
sight, and back clip plane position if there is one.          

 l By callouts or, for cross section/elevation views, double callouts.          

You can control the display of a camera’s focal point and line or sight, or its back clip plane indicator and line of sight, as 
well as specify a camera symbol or callout, in the camera’s specification dialog. See Plan Display Panel on page 1119.           

2D camera symbols are located on the “Cameras” layer               by default; however, you can place a selected camera on any layer 
you wish. See Layers on page 180.

By default, active camera symbols display regardless of whether the “Cameras” layer is on or off. If you prefer that their 
display be turned on or off with this layer, uncheck Always Display Active Cameras in the 3D View Defaults dialog. See 
3D View Defaults Dialog on page 1084.           

Active camera symbols and callouts use the Selection Line color set in the Preferences dialog. All other display attributes 
are derived from the “Cameras” layer. See Colors Panel on page 102.          

By default, the symbols for Full Overviews, Cross Section/Elevation, and Back Clipped Cross Section views display on all 
floors, while those for Full Cameras, Floor Overviews, and Wall Elevations display only on the floor where they were 
created. You can, however, specify whether any camera’s symbol displays on all floors or not in its specification dialog. See 
Plan Display Panel on page 1119.
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You can also move a camera to a different floor by clicking the Up One Floor  or Down One Floor  button while 

the camera view is active. Note that this may affect what is seen in the view as well as its display in plan view. See Floor 
Up / Floor Down on page 750. 

CAMERA LABELS AND CALLOUTS

Both saved and unsaved active cameras can have labels indicating the camera or callout number or its name. Camera labels 
are located on the “Cameras, Labels” layer and use the Text Style assigned to that layer. See Label Panel on page 712. 

Camera labels and callout numbers are numbered sequentially in each plan in the order they were created unless you rename 
them. 

 l Camera labels always use the Camera Name. Saved cameras’ names can be specified in the Camera Specification 
dialogs. See Camera Panel on page 1116.             

 l Saved camera callout labels and additional text can also be specified. See Plan Display Panel on page 1119.         
 l If a cross section/elevation view using a callout is sent to layout, the layout page’s Label can display as the callout’s 

Text Below Line. See Layout Page Information on page 1363.         

Camera symbols display a letter indicating the Rendering Technique it uses. This letter uses the same text style as the 
camera label. See Rendering Techniques on page 1147.          

Camera symbols are an on-screen reference: they do not print unless Print Image is used and cannot be sent to layout 
except as an image. They are, however, included when CAD Detail from View  is used and in views exported to

 .dxf/.dwg.

In contrast, camera callouts are included when the view is sent to layout, printed, or exported and when CAD Detail from 
View  is used.   

IN RENDERED VIEWS

There are a number of factors that contribute to the appearance of rendered 3D views:

 l Select View> Color  to toggle between color and grayscale in 3D views. See Color On/Off on page 196. 

 l Select 3D> Rendering Technique to select a technique to apply to the current view. See Rendering Techniques on 
page 1147.

 l Select 3D> Lighting> Adjust Lights  to open the Adjust Lights dialog and edit the light sources in the current 

plan. See Adjust Lights Dialog on page 1137.             
 l Select 3D> Toggle Patterns  in a rendered view with Line Drawing on Top enabled to turn the display of 

material pattern lines on or off. See Rendering Technique Options on page 1150.

Several other factors can contribute to the overall quality of a rendered 3D view. See Rendering Tips on page 1130.         

IN VECTOR VIEWS

There are also a number of factors that affect the appearance of 3D Vector Views:         

 l Select 3D> Toggle Patterns  in a Technical Illustration, Watercolor, Line Drawing, or Vector View to turn on or 

off the display of the “Patterns, 3D Views” layer, which controls the display of material pattern lines. See Layers on 
page 180.         

 l Select View> Color  to toggle between color and black and white to control the display line and fill colors.         
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 l The line style, color, and weight of objects in Vector Views can be specified by layer or, for some objects, individually 
in their specification dialogs. See Line Style Panel on page 310.         

 l The line weight, color, and style of material patterns are set in the Define Material dialog. See Define Material Dialog 
on page 1066.             

 l Line weights display on screen when Show Line Weights  is enabled. See Line Weights on page 1376.         

3D BACKDROPS

A backdrop is an image, usually of an exterior view, that displays in the background of 3D views to help place the model 
into a realistic setting and add a sense of perspective. If a backdrop is not specified, Chief Architect applies a background 
color. See 3D Backdrops on page 1201.         

RENDERING TECHNIQUES

Any 3D view can be assigned a Rendering Technique for a range of different purposes: from detail drawings to 
artistic presentation views. Select 3D> Rendering Techniques to access these tools. See Rendering Techniques on 

page 1147.          

DELETE 3D SURFACE

The individual surfaces that make up objects can be temporarily removed from any 3D view by selecting 3D> Delete 
Surface and then clicking on a surface. When the pointer is over a surface, that surface will become highlighted.

Surfaces removed in one view are removed in all 3D views, but are not permanently removed from the model. Continue 
clicking surfaces to remove them, then select another tool when you are finished.

Surfaces in 3D views are composed of multiple triangles. Hold the Alt key while clicking to delete one triangular face at a 
time rather than all triangles forming a  surface. See Edge Smoothing on page 1132. 

To restore the most recently deleted surface, select 3D> Delete Surface  or click the toolbar button. 

There are several ways to restore all deleted surfaces:

 l Select Build> Floor> Rebuild Walls/Floors/Ceilings .

 l Exit the 3D view and reopen it.
 l Generate a new 3D view. 

 

Navigating in Camera Views
Once a 3D view is created, there are many ways to manipulate the camera location and the direction of its line of site using 
the mouse, the keyboard, and the menus. 

The Move Camera with Mouse buttons are included on the toolbars  in 3D views by default; but, you can add the other tools 
your toolbars as well as customize their hotkeys. See Toolbars and Hotkeys on page 133.          

When the keyboard, toolbar buttons, or menu commands are used to move or rotate a camera, the adjustments occur in 
regular increments. The size of these increments is specified in the Camera Specification dialog: 

 l The Incremental Move Distance controls Panning movement and forward and backward Dolly movement. 
 l The Incremental Rotate Angle controls Orbit movement, Tilt movement, and side to side Dolly movement.
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See              Camera Panel on page 1116.

Each time you move the camera, the view is updated. If you are using either the toolbar or keyboard to move the camera,  
you can hold down the Shift key, suppressing the redraw of the view until the Shift key is released and allowing you to 
move multiple increments more quickly. 

Press the Ctrl + Alt + S keys on your keyboard while in a camera 
view or overview to spin the view. To stop the spinning, press 

the Esc key.

You can also move a camera to a different floor by clicking the Up One Floor  or Down One Floor  button while 

the camera view is active. Note that this may affect what is seen in the view as well as its display in plan view. See Floor 
Up / Floor Down on page 750. 

MOUSE SCROLL WHEEL AND TRACKPAD

3D views can be panned and zoomed when any tool is active using the mouse scroll wheel or trackpad gestures. See 
Trackpads on page 15.

The program adjusts the speed of these actions depending on characteristics of the camera: 

 l Zoom speed depends on how close the camera is to the object located behind the mouse pointer. When the target 
object is far from the camera, zooming is faster; as the camera gets closer to the target, zooming slows. 

 l Panning speed depends on the length of the camera’s Line of Sight. In general, it is likely to be faster in an exterior 
view of a large model, slower in an interior view of a small room. See Creating Camera Views on page 1087.

By default, panning and zooming adjusts the position and direction of the camera. It does not, however, adjust the distances 
at which surfaces are clipped. This means that if you zoom in closely on an object, some of its surfaces may be removed 
from the view. One way to avoid this is to lower the camera’s Clip Surfaces Within value in the Camera Specification 
dialog. See Camera Panel on page 1116.   

3DCONNEXION® 3D MICE

3Dconnexion®'s 3D mice can be used to navigate in all views - including camera views and overviews.

In the Windows version of Chief Architect, preprogrammed view direction hotkeys are supported on devices with buttons 
for that purpose. MacOS™ does not provide mapping support to the view direction commands; however, you can create 
custom hotkeys for the commands in Chief Architect and then program your 3D mouse to use those hotkeys. See Hotkeys.

In Orthographic views, navigation is centered around the camera’s focal point; for Perspective views, you can specify 
whether navigation is centered about the camera or its focal point in the Preferences dialog. See Render Panel on page 129.

For best results when using a 3D mouse, uncheck Camera Bumps Off Walls. See 3D View Defaults Dialog on page 1084.          

Rolling is not supported in Chief Architect, In addition, 3D mice cannot be used to move the mouse pointer. For details 
about using your 3D Connexion® mouse, refer to its documentation.

GAMEPADS

In the Windows version of Chief Architect, gamepads can be used to navigate in camera views, overviews, and 
elevation views. To use a gamepad in Chief Architect, Select Tools> Toolbars and Hotkeys> Gamepad Settings, 

then check Enable Gamepad in the Gamepad Settings dialog. You can also adjust the sensitivity and other aspects of 
thumbstick functionality when used in Chief Architect. See Gamepad Settings Dialog on page 145.
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Note: Gamepads cannot be used in Virtual Reality. See Virtual Reality on 
page 1110.

You can also specify whether navigation is centered about the location of the camera or its focal point in the Preferences 
dialog. See Render Panel on page 129.         

Each button on the gamepad is mapped to a command in Chief Architect. You can review and customize these commands in 
the Gamepad Settings dialog, as well. If you wish, you can create a custom hotkey for Toggle Gamepad Change Height in 
3D. See Toolbar Customization Dialog on page 139.          

You can add the Gamepad Settings and Toggle 3D Mouse and 
Gamepad Navigation buttons to your toolbars if you wish. See 

To add a button to a toolbar on page 137.

MOVE CAMERA WITH MOUSE

An active camera’s position can be edited using the mouse. Select 3D> Move Camera With Mouse to access the 
Move Camera with Mouse modes, select a mode, and use the left mouse button for the primary behavior or the right 

mouse button for the secondary behavior. With the exception of Mouse Orbit Camera, which is available in Orthographic 
Overviews, these tools are not available in Orthographic views.

Tool
Primary Behavior

(Left-Click)

Alternate 
Behavior

(Right-Click)

Mouse-Orbit 
Camera

Left-click and drag to rotate the camera around its 
focal point. The camera’s position and direction both 
change.

You can temporarily activate Mouse-Tilt Camera by 
using the right mouse button while the Mouse-Pan 
Camera or Mouse-Tilt Camera mode is active.

To continuously rotate the camera around its focal 
point, left-click in the 3D view, drag the mouse, and 
release the mouse button to “throw” the view. Click 
again in the view to stop it from rotating. 

Right-click and 
drag to tilt the 
camera instead 
of orbiting.

In the Mac version of the software, you can 
temporarily activate Mouse-Orbit Camera while 
another tool is active: hold down the Option + Shift 
keys, then left-click and drag. When the mouse button 
and keys are released, the previously active tool will 
again be active. 

Mouse-Pan 
Camera

Left-click and drag to move the camera in any 
direction. The camera’s position changes, but its 
direction does not.

Right-click and 
drag to orbit 
instead of 
panning.
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Tool
Primary Behavior

(Left-Click)

Alternate 
Behavior

(Right-Click)

Mouse-Dolly 
Camera

Left-click and drag up and down to move  the camera 
forward and backward or drag left or right to rotate 
the camera side to side.

Right-click and 
drag to tilt the 
camera instead 
of dollying.

Mouse-Tilt 
Camera

Left-click and drag in any direction to tilt the camera, 
changing its view direction but not its position.

You can temporarily activate Mouse-Tilt Camera by 
using the right mouse button while the Mouse-Orbit 
Camera or Mouse-Dolly Camera mode is active.

Right-click to 
orbit instead of 
tilting.

3D Center 
Camera on 

Point

Lets you focus the camera at a particular point in the 
scene. This changes the camera’s direction and focal 
point, but not its position.

To use this tool, activate it and then click on any 
object in the scene.

N/A

3D Focus on 
Object

Lets you focus on a specific object by changing the 
camera’s position, direction, focal point, and the 
length of its line of sight.

To use this tool, activate it and then click on an object 
in the scene. Alternatively, select an object in the view 
and click the Focus on Selected edit button.

N/A

MOVE CAMERA WITH KEYBOARD

An active camera’s position can be changed using the Arrow keys on your keyboard. Select 3D> Move Camera with 
Keyboard to access the Move Camera with Keyboard modes. With the exception of Mouse Orbit Camera, which is 
available in Orthographic Overviews, these modes are not available in Orthographic views.

These modes use the Incremental Move Distance and Incremental Rotate Angle set in the active 3D view’s Camera 
Specification dialog. 

 l Keyboard-Orbit Camera lets you use the keyboard to rotate the camera around the focal point. The camera’s position 
and direction both change.

 l Keyboard-Pan Camera lets you move the camera up, down, right, and left using the keyboard. The camera’s position 
changes, but its direction does not.

 l Keyboard-Dolly Camera lets you move the camera forward and back using the Up and Down Arrow keys, and rotate 
side to side using the Left and Right keys. 

 l Keyboard-Tilt Camera lets you use the Arrow keys to tilt the camera up, down, or side to side to change the focal 
point. The camera’s direction changes, but its position does not. 

Although the Arrow keys are set to move active cameras by default, you can create custom hotkeys for these commands if 
you prefer. See Hotkeys on page 142.
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MOVE CAMERA TOOLS

Select 3D> Move Camera in a 3D view to access these tools. These tools change the active camera’s position but 
not its direction, and are not available in  Orthographic views. 

The Move Camera Forward and Move Camera Back tools allow 
you to "walk" up and down stairs when Camera Bumps Off 

Walls is checked. See 3D View Defaults Dialog on page 1084.

These tools use the Incremental Move Distance set in the active 3D view’s Camera Specification dialog. 

 Description

Move Camera Forward moves the camera and its focal point 
forward. 

Move Camera Back moves the camera and the focal point 
back. 

Move Camera Left moves the camera and the focal point to 
the left in a line perpendicular to the line of sight. 

Move Camera Right moves the camera and the focal point to 
the right in a line perpendicular to the line of sight. 

Move Camera Up moves the camera and the focal point up. 

Move Camera Down moves the camera and the focal point 
down. 

ORBIT CAMERA TOOLS

Select 3D> Orbit Camera in a 3D view to access these tools. Orbiting the camera rotates it about the focal point 
using the Incremental Rotate Angle set in the active view’s Camera Specification dialog. 

These tools are not available in Cross Section/Elevation, Back Clipped Cross Section, or Wall Elevation Defaults views.

 Description

Move Camera In moves the camera closer to the focal point 
along the line of sight. The camera cannot move past the focal 
point using this tool.

Move Camera Out moves the camera away from the focal 
point along the line of sight. 

Orbit Camera Upward rotates the camera up about the focal 
point. The camera cannot rotate past a vertical line looking 
straight down on the focal point.

Orbit Camera Downward rotates the camera down about the 
focal point. The camera cannot rotate past a vertical line 
looking straight up at the focal point.
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 Description

Orbit Camera Left rotates the camera to the left about the 
focal point.

Orbit Camera Right rotates the camera to the right about the 
focal point. 

TILT CAMERA TOOLS

Select 3D> Tilt Camera to access these tools. Tilting keeps the camera in one place and pivots the camera about its 
vertical or horizontal axis. This movement uses the Incremental Rotate Angle set in the active view’s Camera 

Specification dialog and is similar to tilting your head up and down or turning it side-to-side. 

These tools are not available in              Orthographic views.         

 Description

Tilt Camera Upward tilts the camera up while keeping it in 
the same location. The camera cannot tilt beyond the vertical 
position.

Tilt Camera Downward tilts the camera down while keeping 
it in the same location. The camera cannot tilt beyond the 
vertical position.

Turn Camera Left turns the camera to the left while staying 
in the same location.

Turn Camera Right turns the camera to the right while 
staying in the same location.

VIEW DIRECTION TOOLS

The View Direction Tools allow you to view the model from a specific direction in a camera view or overview. 
While one of these views is active, select 3D> View Direction to access these tools.         

 Description

Front View creates a front view of the model.

Back View creates a back view of the model.

Top View creates a top view of the model.

Bottom View creates a bottom view of the model.

Left Side View create a left side view of the model.

Right Side View create a right side view of the model.
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 Description

Restore Original View restores the original view position.

 

Editing 3D Views
In addition to its position and direction, there are other ways to modify a 3D view.

If you make changes to an open camera view that was saved previously, you will be prompted to resave the view when you 
close it.

IN THE SPECIFICATION DIALOG

You can  make adjustments to a camera in its specification dialog. This dialog is particularly helpful for making fine 
adjustments to the camera’s position, appearance, and other attributes such as its Rendering Technique, layer set, and 

backdrop image. See Camera Specification Dialogs on page 1116 and Cross Section/Elevation Specification Dialogs on 
page 1123.

Tile a 3D view and plan view and use the camera movement 
tools to see how they affect the camera. See Tiling Views on 

page 155.

USING THE EDIT TOOLS

A camera symbol or symbols selected in plan view can be edited in a variety of ways using the buttons on the Edit Toolbar. 
See The Edit Toolbar on page 135.

USING THE EDIT HANDLES

Return to plan view without closing the 3D view. See Working in Multiple Views on page 154.   

Using the Select Objects  tool, select the camera object. When a camera symbol is selected, it displays six edit handles. 

 l Drag the Rotate Label handle or smaller Move Label handle to rotate or move the camera label.         
 l Drag the Line of Sight handle to change the camera angle without moving the focal point.
 l Drag the Move handle to relocate the camera while maintaining its relative angle.
 l Drag the Focal Point handle to reposition the focal point and change the line of sight without moving the camera.
 l Drag the Rotate handle to rotate the camera’s line of sight about its center.

The 3D view corresponding to the camera symbol reflects changes made to the symbol in plan view. 
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Note: Camera callouts do not display labels, so they do not have label 
edit handles.

When a cross section/elevation camera is selected, it displays seven edit handles, three of which are unique to cross 
section/elevations.         

 l Drag either of the two Resize Clip Plane handles to adjust the length of the clip plane line, which is perpendicular to 
the camera’s line of sight. Left-click to resize the line concentrically and maintain the camera’s position; right-click to 
move the selected end as well as the camera. This will affect what can be seen in the view if Clip to Sides is checked. 
See Camera Panel on page 1124.               

 l Drag the Move Clip Plane handle to move the camera and its clip plane parallel to its line of sight.         
 l If a stepped cutting plane is created, additional edit handles are available. See Stepped Cutting Planes on page 1093.         

Multiple camera symbols can be selected; however, their editing options are limited to being moved, rotated, and deleted. 
You can also create revision clouds around group-selected camera symbols. 

USING THE CONTEXTUAL MENU

In a 3D view, right-click in an empty space in which the backdrop or background color displays to access the contextual 
menu. See Contextual Menus on page 19. 

 l In Vector Views, the options are a selection of commonly used commands from the File, Edit, Tools and Window 
menus.         

 l In the other Rendering Techniques, the options are a selection of tools and toggles specific to the current view.

UP ONE FLOOR/DOWN ONE FLOOR

You can move a camera to a different floor. While the camera view is active, select Tools> Floor/Reference 
Display> Up One Floor  or Down One Floor. Note that this may affect what is seen in the view as well as its 

display in plan view. See In Plan View on page 1097.

The position and movement of a camera is affected by its location within the model. When the camera is outside a building, 
its height is relative to the terrain and follows the terrain as it is moved. When inside a building, the camera height is 
relative to the floor of the room it is drawn in.

If the camera is on an upper floor and you move the camera outside the building, the camera remains at the same height 
relative to the floor it was created on.
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ZOOMING

The Zoom Tools are available in all 3D views. See Zoom Tools on page 157.   

Selecting Window> Zoom In , Zoom Out  or Fill Window  does not change the camera’s location or field of 

view. Instead, the extents of the view are expanded or cropped. 

If you wish, you can instead set the Zoom  tools to change the  Field of View when used in a 3D view. See Render 

Panel on page 129.         

FIELD OF VIEW

The Field of View refers to a camera’s field of vision. A wider field of view makes the focal point appear further away, as 
more of the image is included in the same view window.

In plan view, the angled lines of a camera symbol indicate its field of view.

A camera’s field of view can be adjusted in the Camera Specification dialog. See Camera Panel on page 1116.

 

Cross Section Slider
Select 3D> Camera View Options> Cross Section Slider when a camera view or overview is active to open the 
Cross Section Slider dialog. 

Note: The Cross Section Slider is not available when the Vector View 
Rendering Technique is used. See Rendering Techniques on page 1147. 
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To use the Cross Section Slider
 1.  Check the box beside a cross section cutting plane to select it and make its Position slider and text box active.

 2.  Move the Position slider to adjust the position of the cutting plane. 

 l The cutting plane Position is measured from the edge of the model that is cut first by the selected cutting plane.

 l Position the Cutting Plane with accuracy using the text field to the right of the slider. 

 3.  Repeat steps 1-3 to use additional cutting planes if you wish. 

 4.  Click OK to close the dialog. If the active camera is saved, its Cross Section Slider settings will also be retained. See 
Saving 3D Views on page 1114. 

 

Working in 3D
A variety of tools are available in 3D views that allow you to edit your 3D model as well as annotate it.

ANNOTATING CROSS SECTION/ELEVATION VIEWS

The Text, CAD, and a selection of Dimension tools are available in cross section/elevation views, allowing you to add 
technical information, call attention to details, and other tasks in these views. See Detailing Cross Section/Elevation Views 
on page 1092.   

The Auto Detail tool automatically creates CAD objects for commonly detailed components of cross section views. 
See Auto Detail on page 1095.

To add annotation to any other 3D Vector View, first create a line-drawn copy of the view using the CAD Detail 
from View tool. See CAD Detail from View on page 341.    

CREATING OBJECTS IN 3D VIEWS

You can place windows, doors, cabinets, electrical objects, corner trim, and most library objects directly into 3D views. To 
do this, select the appropriate tool and click in the 3D view. You can then edit the object’s size and placement.          

When created in 3D, most objects must be placed against a wall, on a floor platform, or within the Terrain Perimeter.         

You can also click and drag to draw some CAD-based objects such as              custom countertops, roof planes,              terrain features and 
roads in camera views and overviews.          

The Build Framing and Build Roof dialogs are also accessible in 3D views, although the manual Framing Tools  and 

Roof Tools  are not.           

SELECTING AND EDITING OBJECTS IN 3D VIEWS

Most objects can be selected and edited in 3D views. Select Edit> Select Objects  and click on the surface of an object 

to select it. Once selected, objects can be edited using their edit handles, buttons on the Edit Toolbar, and the object’s 
specification dialog. See Editing Objects on page 207.         

When you select an object, edit handles and a handle surface display. The handle surface is a rectangle around the perimeter 
of the object that indicates the overall height and width of the selected surface. The edit handles that display depend on the 
type of object selected. Walls, for example, display two resize edit handles when selected while the top of a cabinet displays 
ten handles, allowing you to move, resize and reshape it.         
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Note: If the wall height of the Exterior Room is adjusted in a 3D view, 
the default Floor or Ceiling Height of the entire floor is changed. See 
Floor and Room Defaults on page 418.

All moving or resizing is in the plane of the handle surface. You cannot  move an object directly towards or away from the 
camera, for example, because that surface plane cannot be seen in the view.          

By default, object movement is restricted to 1 inch (10 mm) increments, but this restriction can be set to custom increments 
in the Plan Defaults dialog and toggled off and on by selecting Edit> Snap Settings> Grid Snaps . See Grid Snaps on 

page 167.         

Unrestricted positioning can also be enabled by holding down the Ctrl key while moving or resizing an object. See 
Unrestricted Movement on page 246.          

Temporary dimension lines display when many objects are selected to help you resize the object and determine its height. 
These are sometimes easier to see when the color is toggled off. See Temporary Dimensions on page 480.

Because cross section/elevation views are orthogonal and display objects at their actual dimensions, they are sometimes 
more suitable for editing objects than camera views or overviews. See Cross Section/Elevation Views on page 1090.         

When several 3D views are open, changes made in the plan automatically rebuild the model in all views.  Because of this, it 
is typically faster to make changes to your plan with as few windows open as possible.         

EDITING MATERIALS IN 3D VIEWS

  Select 3D> Materials> Adjust Material Definition, then click on a surface in the 3D view to open the Define 
Material dialog for that material. See Adjust Material Definition on page 1059.         

  Select 3D> Material Painter to apply materials to surfaces in the view using the Material Painter Tools. See 
Material Painter Tools on page 1053.         

  Select 3D> Material Painter> Material Eyedropper to apply the material on a surface in the view to other 
surfaces in the view. See Material Eyedropper on page 1054.          

CROSS SECTION LINES

Cross Section Lines are created in cross section views to represent any objects split by the cross section line of the camera. 
They are placed on the “Cross Section Lines” layer, which is locked by default, and they get deleted and replaced whenever 
the view is redrawn.          

When a dimension is drawn to locate an object split by a camera’s section line, it actually locates Cross Section Lines. So 
that dimensions can be retained when Cross Section Lines are regenerated, a Point Marker  is automatically created 

where a dimension meets a Cross Section Line and the dimension locates it instead of the Cross Section Line. See Point 
Markers and Dimensions on page 539.           

Cross Section Lines will print when their layer is turned on; however, they are not included when the view is sent to layout. 
The Point Markers created when dimensions locate Cross Section Lines, however, will both print and display in views sent 
to layout. See Layout on page 1338.          

The “Cross Section Lines” layer can be unlocked, allowing Cross Section Lines to be selected and edited. Additional CAD 
objects can also be placed on this layer when it is unlocked, as well; however, when the view is redrawn, all CAD objects 
on this layer will be deleted and replaced with a fresh set of Cross Section Lines.           
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REBUILD 3D

As changes are made to your plan, a 3D view automatically updates to reflect any changes visible in the view. If you 
find that a view is not updating as expected, select 3D> Rebuild 3D to rebuild the entire 3D model.  

 

Virtual Reality
The Virtual Reality option  is available in the Windows version of Chief Architect and allows you to view a plan in 
3D using a VR headset. To view a model in VR, select 3D> Virtual Reality while a Perspective camera view or 

overview is active. 

SYSTEM REQUIREMENTS

The following virtual reality headset models are supported for use in Chief Architect:          

 l Oculus: Rift, Rift S, Quest (using Link Cable), Quest 2 (using Link Cable)     
 l HTC: Vive, Vive Pro, Vive Pro 2, Vive Cosmos, Vive Cosmos Elite
 l Valve Index         
 l Microsoft Mixed Reality          

In order to run Virtual Reality in Chief Architect, your computer should meet not only the program’s system requirements 
but also the system recommendations provided by your VR headset manufacturer.         

In addition, you must first install Steam, a game and software distribution program available at store.steampowered.com.           

Once it has been installed, you must also run the SteamVR Setup so that your headset runs through the Steam software. The 
setup will walk you through setting up the VR sensors in a clear area, free from obstructions, where you can walk and move 
around.          

Virtual Reality can only be activated while viewing an active Perspective View using either the Standard or Physically 
Based Rendering Technique. If Line Drawing on Top or GPU Ray Tracing is in use in the current view, it will be ignored in 
VR. See Rendering Techniques on page 1147.           

SAFETY CONSIDERATIONS

Virtual Reality should only be run in a space free of obstructions that could cause injury.           

To avoid slow performance that could result in motion sickness, turn off any other CPU and GPU intensive applications on 
your system before launching Virtual Reality.          

In addition, these settings are recommended in the current camera view prior to launching Virtual Reality:          

 l Turn Reflections off.          
 l Turn on a minimal number of lights and shadows. 

See Lighting on page 1133 and Camera Specification Dialogs on page 1116.          

Just like in a Chief Architect camera view, it is possible to navigate through objects in the model when in Virtual Reality, 
like walls and furniture. To avoid disorientation or motion sickness, you should avoid doing so.          

To avoid motion sickness while using virtual reality, gamepad style controllers are not supported. You can, however, walk 
within the area designated during your Steam VR Setup. To navigate to different  locations in the model, you can also 
teleport as well as switch between Room View and Overview modes.          
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ROOM VIEW AND OVERVIEW MODES

Chief Architect has two Virtual Reality modes:          

 l In a Room View, you can navigate a model by looking around, walking, and teleporting. Room View is active when 
you enter VR from a Perspective Camera view.          

 l In an Overview you can move and rotate the model in order to examine its exterior. Overview mode is active when 
you enter VR from a Perspective Overview.          

Note: For best results, use the Full Camera tool for Room Views rather 
than Floor Camera. See 3D View Tools on page 1085.

In both modes, your initial position and orientation in Virtual Reality are based on the position and angle of the camera. As 
you turn your head or walk, the view seen in the VR headset will update to reflect your movements. The original camera in 
Chief Architect will be unaffected, however.          

Once you enter Virtual Reality, you can switch between the two modes:          

 l To transition from Room View to Overview, point either VR controller straight up until the Teleport Line changes to a 
short gray line. Press and hold the Transition button on your VR controller until the line changes entirely to the Mode 
Transition Color and the controller vibrates, then release the button. See Virtual Reality Dialog on page 1112, below.          

 l To transition from Overview to Room View, point either VR controller toward a valid surface on the model. Press and 
hold the Transition button until the line changes entirely to the Mode Transition Color and the controller vibrates, then 
release the button.          

NAVIGATING ROOM VIEWS

In a Room View, you can explore a model by looking around, walking in your predefined VR space, and teleporting.           

To teleport to other locations within the model, press and hold the Trigger on your VR controller while aiming at a suitably 
flat surface. A Teleport Marker will appear at the location that you point at, and releasing the Trigger will teleport you to 
that location.           

In Room View, the VR controller projects a Teleport Line that indicates whether a targeted surface is a valid location to 
teleport to. A valid surface is defined as any surface that has less than 45° pitch, however if a valid surface exists less than 
12” below an invalid target location, it will show as valid and the teleport marker will be placed next to the targeted surface. 
This allows you to easily teleport next to an otherwise invalid surface, such as a wall or cabinet.          

To cancel a teleport action, aim the Teleport Line at an invalid location. When the line changes color and the Teleport 
Marker disappears, release the Trigger.           

In Room View, a number of navigation actions can be completed using your VR controller. These controls are the same on 
both right and left controllers, but specific functions differ slightly depending on the VR controller used.          

Command HTC Vive/Microsoft Oculus Rift

Teleport Trigger

Undo Trackpad Left Thumbstick Left + Click

Redo Trackpad Right Thumbstick Right + Click

Reset Menu Button Thumbstick Up + Click

Transition Trackpad Down X or A Button

Update Lighting Trackpad Upper Click Y or B Button
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NAVIGATING OVERVIEWS

In Overview mode, you can examine and model by moving and rotating it in front of you as if holding a scaled version of 
the model.          

In this mode, the Grip buttons on your VR controller allow you to “grab” and rotate the model. Using the Grip buttons on 
both VR controllers simultaneously gives a more natural rotation, as if grabbing and rotating the entire model.          

Pressing and holding the Trigger allows you to drag the model in any direction: up, down, left, right, towards you, and away 
from you.           

Pressing the Triggers while holding the Grips on both controllers simultaneously allows you to zoom in and out. Moving 
your hands apart will zoom in to the model, moving them closer together will zoom out.          

In Overview mode, a number of actions can be completed using your VR controller. These controls are the same on both 
right and left controllers, but specific functions differ slightly depending on the VR controller used.          

Command HTC Vive/Microsoft Oculus Rift

Rotate Grip

Drag Trigger

Zoom Grip + Trigger

Undo Trackpad Left Thumbstick Left + Click

Redo Trackpad Right Thumbstick Right + Click

Reset Menu Button Thumbstick Click

Transition Trackpad Down X or A Button

Update Lighting Trackpad Upper Click  

VIRTUAL REALITY DIALOG

To view a model in VR, select 3D> Virtual Reality  while a Perspective Camera view or Overview is active. The 

Virtual Reality dialog will open. 

Note: Neither Line Drawing on Top nor GPU Ray Tracing are supported 
in VR.
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VR Status

The current Virtual Reality Status is stated at the top of the dialog, along with information about graphics card or chipset 
being used on the computer.                 

 l Click the Toggle Virtual Reality button to turn Virtual Reality on or off.          

 
OpenGL Information

Information about your graphics card is displayed here for reference. Visit chiefarchitect.com for information about system 
requirements.              

  Options

 l Validity of a surface is indicated by the color of the teleport line. The Valid Teleport Line and Invalid Teleport 
Line Colors can be set here.          

 l The teleport line will display the Mode Transition Color when switching between Room View and Overview 
Modes. This color can also be set here.          

 l When Virtual Reality is active, the program window shows what the user sees in the VR headset. By default, both 
eyes’ views are shown in a split screen. If you would prefer to see only the left eye’s view, uncheck Display Both 
Eyes On Screen in the Virtual Reality dialog.           

 l When Update Lighting on Teleport is checked, the lighting in the model will update when you teleport more than 
10 feet (3 m) to ensure that your destination has lighting. Uncheck this is you prefer to only update lighting manually 
using the controller.          
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Room View

Specify how the teleport feature works in Room View Mode.                 

 l Use Curved Teleport Line changes the teleport line from a straight line to a curved arc. This is checked by default 
for Room Views.           

 l The Teleport Reference Height setting determines how the camera height is calculated when the teleport feature is 
used.          

 l When Floor Under Marker is selected, the new camera position will calculate its height based on the floor surface, 
or the floor directly beneath where the teleport marker lands if locating a raised surface such as a countertop or table. 
This may result in being teleported inside furniture or other objects.          

 l When Surface at Marker is selected, the new camera location will determine its height from the surface where the 
marker landed. This will place the camera on top of objects such as furniture and may result in the view being in or 
above the ceiling.          

 
Overview

Specify how the teleport feature works in Overview Mode.                 

 l Use Curved Teleport Line changes the teleport line from a straight line to a curved arc. This is unchecked by 
default for Overviews.          

 l Lock X-Axis Rotation prevents the model from being tilted vertically.          

 l Lock Y-Axis Rotation prevents the model from being rolled left to right.           

 l Lock Z-Axis Rotation prevents the model from being spun horizontally.           

When Virtual Reality is active, neither the camera nor the model can be edited in any way. If you wish to make 
modifications, you must Toggle Virtual Reality off in the Virtual Reality dialog, make the necessary adjustments, and then 
enter Virtual Reality again.           

 

Saving and Printing 3D Views
3D camera views, overviews, and cross section/elevation views can be saved with the plan in which they are created, 
exported and saved as image files, as well as sent to layout and printed. 

SAVING 3D VIEWS

Select Tools> Active View> Save Active View to save the current camera view in the plan. You can also save a 
camera view by checking the Saved box in the Camera Specification dialog. See Camera Specification Dialogs on 

page 1116.    

Saved cameras can be closed and re-opened for later use, and retain their Cross Section Slider, Sunlight, Shadows, and 
Rendering Technique settings. See Cross Section Slider on page 1107, Adjust Sunlight Dialog on page 1145, Shadows on 
page 1130, and Rendering Techniques on page 1147.

In addition, if              CAD or Text objects are drawn in a cross section/elevation view, you will be prompted to save the view 
when you close it. Any  CAD or Text objects added to a cross section/elevation view are saved with the view as part of the 
plan file.         

Once a 3D view is saved, it is listed in the Project Browser and can be named. The name displays in its label with the 
camera symbol in plan view and in its view window tab. Camera names must be unique. See Project Browser on page 58.           
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ACTIVATING SAVED VIEWS

There are several ways to open a saved 3D view:          

 l Select the camera symbol in plan view and click the Open View  edit button.

 l Right-click on the camera symbol in plan view and select Open View  from the contextual menu.         

 l Double-click the camera symbol using the Select Objects  tool.

 l Double-click on the saved camera view's name in the Project Browser or right-click on it and select Open View from 
the contextual menu.         

Unsaved cameras that are open in another view window can also be activated using the Open View  edit button.         

If you open a saved camera view and then modify its location or direction using any of the tools available in that view, the 
program will confirm whether you want to re-save the camera using these new settings when you close it. See Navigating in 
Camera Views on page 1099.         

CAD DETAIL FROM VIEW

In any 3D view using the Vector View rendering technique, you can select CAD> CAD Detail From View to 
generate an editable line drawing of the view in a CAD Detail window. CAD Details created from a view do not 

update when the model is changed. See CAD Detail from View on page 341.         

EXPORTING 3D VIEWS

All 3D views can be exported and saved as .bmp, .jpg, .png, or .tif files. Select File> Export> Picture to save the 
current screen image as an image file. See To export a picture on page 1188.

The Export 360 Panorama tool creates a spherical panoramic image file. See Export 360 Panorama on page 1245.         

In addition, Vector Views can be exported and saved as .emf files. See Metafiles on page 1191.         

Once saved, a picture can be opened and converted into many other formats using a graphics program. Picture files can be 
sent to layout or used in word processing, desktop publishing, and web development programs to create advertisements, 
brochures, etc.

PLAN BACKUP

When transferring a plan to another computer or to another user, it is helpful to include all the Images, Textures, and 
Backdrops used in the plan so that rendered views are complete. The Backup Entire Plan tool allows you to do so. 

See Backup Entire Plan or Layout on page 55.         

PRINTING 3D VIEWS

Since all 3D views other than Vector Views are created using pixels instead of lines, File> Print> Print Image must 
be used when printing. Print Image is a special Chief Architect function that prints the screen in picture format. The 

entire view prints, including images such as plants and textures. 

3D views can also be sent to layout and then printed as part of your construction documents.          

  Select File> Send to Layout to send the current view to layout. See Sending Views to Layout on page 1343.
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  Select a saved, inactive camera symbol in plan view and click the Send Camera’s View to Layout edit button to 
send the view to layout.         

For high quality renderings, consider using ray tracing. See CPU 
Ray Tracing on page 1163.

CLOSING 3D VIEWS

Although you can have any number of 3D views open at a time, to conserve resources on your computer it is a good idea to 
close views when you no longer need them. There are a number of different ways to do this. See Closing Views and Files on 
page 159. 

 

Camera Specification Dialogs
The Camera Specification dialog can be accessed in plan view by selecting one or more camera symbols and clicking 
the Open Object edit button. See In Plan View on page 1097.

This dialog can also be accessed while a camera view or overview is active by selecting Tools> Active View> Edit 
Active View. 

The settings in this dialog may vary somewhat depending on the tool used to create the selected view. This tool name is 
indicated in the dialog’s title bar: the specification dialog for a Full Camera , for example, is named Full Camera 

Specification. See 3D View Tools on page 1085.

The Camera Specification dialog has the following panels:

The settings in this dialog are also found in the Camera Defaults dialogs for each of the various camera tools. See Camera 
Defaults Dialogs on page 1082.

CAMERA PANEL

The CAMERA  panel is also found in the Walkthrough Path Specification and Defaults dialogs. See Walkthrough Path 
Specification Dialog on page 1207.
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Some settings only affect some types of views. Depending on the type of camera view selected, not all the settings may be 
available.         

  General

 l Specify a Name for the camera that displays in its label in plan view and in the Project Browser. Names must be 
unique. See Project Browser on page 58. 
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 l Check Saved to save this view with the plan. As soon as you type anything in the text field, this box becomes 
checked. If you click OK while this box is checked, it will become checked permanently. Saved cameras are listed 
in the Project Browser. 

 l Choose the selected camera or walkthrough path’s Rendering Technique from the drop-down list. Click the 
Define button to open the Rendering Technique Options dialog. See Rendering Techniques on page 1147.             

 l Uncheck Show Color to toggle the display off in the current view. See Color On/Off on page 196. 

 l Check Show Watermark to turn on the display of the default watermark. See Watermarks on page 1382.

 l Check Show Shadows to turn on shadows in the selected camera view. When unchecked, shadows are not 
generated. See Shadows on page 1130.

 l Check Ray Casted Sun Shadows for higher quality shadows cast by sunlight. Ray Casted Sun Shadows take 
longer to generate than regular shadows and only refresh when the camera is not moving. 

Note: Ray Casted Sun Shadows are not used in Virtual Reality. See 
Virtual Reality on page 1110.

 l Check Reflections to turn on reflections in the selected camera view. When unchecked, reflections are not 
generated. See Reflections on page 1131.             

 l Light Bloom occurs around areas of intense illumination and looks as though the light is ‘bleeding’ beyond the 
edges of the light source. It adds realism to the view but can take longer to render. Only affects Standard, Duotone, 
and Watercolor renderings. See Rendering Techniques on page 1147.             

 l Check Edge Smoothing When Idle to apply high quality edge smoothing to edge and pattern lines when the 
selected camera is not in motion. See Edge Smoothing on page 1132. 

 l Select the amount of Ambient Occlusion in the view using the slider bar or text field. Ambient Occlusion allows 
variation in the strength of the ambient light. It is more realistic than uniform ambient light, but can take longer to 
render. Only affects Standard, Duotone, Watercolor, and Physically Based renderings. See Ambient Lighting and 
Occlusion on page 1134. 

 
Lighting

The Lighting settings control which and how many light sources are used in the current view. See Light Sets on page 1136. 

 l When Use Sunlight is checked, the sun light source is on in the current view. Uncheck this box to toggle sunlight 
off. 

 l Click the Adjust Sunlight button to open the Adjust Sunlight dialog. Not available in the Camera Defaults or 
Walkthrough Path Defaults dialogs. See Generic Sunlight on page 1134.

 l Select Automatic, then specify the Maximum Number of lights that can be used in the current camera view. 

 l Select Light Set, then choose a set from the drop-down list. Click the Adjust Lights button to view and modify 
the selected Light Set’s properties. See Adjust Lights Dialog on page 1137.         

 
Positioning

The Positioning settings determine the position and orientation of the camera. See Navigating in Camera Views on page 
1099.    

 l The Height Above Floor defines the height that the camera is above the floor level for the current floor. See 
Camera Height on page 1088.
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 l The Tilt Angle determines the vertical angle that the camera is tilted. The camera maintains its focal point and 
position in plan view, but if the camera is tilted, the focal point is above or below the current camera height. 

 l Specify the selected camera’s Camera Angle. This is an absolute value: an angle of 0° points the camera toward 
the left in plan view.                 

 l Specify the X Position and Y Position for the selected camera. These are absolute coordinates. Specifying zero for 
both places the camera at the plan’s origin point (0,0).                  

 l The Incremental Move Distance controls how far the camera moves each time you Pan in any direction or Dolly 
forwards or backward using the keyboard, toolbar buttons, or menu. For interior views a small number is good, but 
for exterior you may want a larger increment.

 l The Incremental Rotate Angle defines how many degrees the camera rotates each time you Tilt, Orbit, or Dolly 
side to side using the keyboard, toolbar buttons, or menu. A setting of 90° would make one full rotation in four 
moves.

 l The Field of View defines the camera’s field of vision in angular degrees. See Field of View on page 1107.

  Options

 l Clip Surfaces Within - Objects located within this distance from the camera do not display in the view. Decrease 
this value to display objects located close to the camera; increase it to improve the appearance of some surfaces in 
Overview cameras with very large extents. 

 l Uncheck Show Lower Floors to show only the current floor in the selected Floor Overview. When checked, the 
current floor plus any floors beneath it are included in the view. Only available for Floor Overviews. See Floor 
Overview on page 1089.                  

 l Check Hide Camera-Facing Exterior Walls to suppress the display of any exterior walls that face the camera. 
Interior walls set as Attic walls are also suppressed. This setting only has an effect when the selected camera’s 
position is on the exterior of a structure and also has an associated toggle. See Hide Camera-Facing Exterior Walls 
on page 1132.

SELECTED DEFAULTS PANEL

The settings on the SELECTED DEFAULTS panel control which Saved Defaults and layer settings are used in the view. These 
settings are also found in the Active Defaults dialog. See Active Defaults Dialog on page 82.         

PLAN DISPLAY PANEL

The settings on the PLAN DISPLAY panel control the appearance of the selected camera's symbol in plan view. See In Plan 
View on page 1097.           
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Display on All Floors

                 Check this box to display the selected camera’s symbol on all floors. When unchecked, it only displays on the floor where 
the camera was created. See Creating Camera Views on page 1087.         

 
Display as Callout

                 Check this box to use a callout symbol to represent the selected camera and enable the settings that follow:             

 l Specify the Callout Label, which is the text that displays inside the callout circle. If no Text Below Line is 
specified, the Callout Label is centered in the callout.         

 l Specify the Text Below Line for a bottom row of text, if desired. Check Automatic to populate the Text Below Line 
with the camera’s Name, as specified on the Camera Panel on page 1116. See Camera Labels and Callouts on page 
1098.         

 l To specify the Callout Size, uncheck Automatic and then type in the text field. When Automatic is checked, the 
size is based on the length of the Callout Label and the size of the current Text Style.         

 l Specify the appearance of the Callout Arrow. Choose None, a Small arrow, or a Large arrow. Uncheck Filled if 
you do not want a solid filled arrow.         

Note: A camera callout arrow will only display its solid fill when the 
camera view is not open. When the view is open, the arrow will display 
as transparent.

 
Standard Options

                 These settings allow you to specify the appearance of the selected camera’s standard symbol. Most of these options are 
disabled when Display As Callout is unchecked, above.             

 l The Camera Symbol Size is measured in plan inches (mm).           

 l Check Show Camera Focal Point to display the camera’s focal point in plan view. When unchecked, the camera’s 
line of sight and focal point are hidden until the camera is selected.           

 l Check Show Field of View Indicators to display the camera’s field of view indicators in plan view.           

 l You can also change the FOV Indicator Length, which is measured in plan inches (mm).           

1120



Chief Architect Premier X14 Reference Manual - Camera Specification Dialogs

BACKDROP PANEL

The settings on the Backdrop panel allow you to specify a backdrop image or color to display behind your model in the 
selected 3D view. See 3D Backdrops on page 1201.         

The BACKDROP panel is also found in the Walkthrough Path Specification and Defaults dialogs. See Walkthrough Path 
Specification Dialog on page 1207.
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Specify Backdrop

A preview of the selected backdrop image is shown here. A backdrop cannot be selected or removed when Use Generated 
Sky is checked, below.             

 l Backdrop Name - The selected backdrop image’s name displays for reference.          

 l Click Select Backdrop to choose a backdrop image from the library. See Select Library Object Dialog on page 982.          

 l Click Remove Backdrop to use a solid color instead of a backdrop image in all 3D views, then specify the color 
below.          

  Use Generated Sky

 l Check Use Generated Sky to simulate a daytime sky backdrop. When checked, Spherical Panoramic Backdrop will 
also be checked and a preview of the Generated Sky will display above.           

Note: If Use Generated Sky is in use as the backdrop in the current 
view and Sun Follows Camera is checked, the Generated Sky will 
not update if the camera is moved. 

 l Specify a Haze Level of Low, Medium, or High. This determines the degree to which light in the sky backdrop 
appears to be scattered by particles in the air.           

 l Specify a Horizon Level using the text field or slider bar. The default value of 44% works well in most situations.           

 
Spherical Panoramic Backdrop

These settings are only available when a Backdrop image is selected.                 

 l Check Spherical Panoramic Backdrop to place the selected backdrop onto a sphere that surrounds the model in the 
current view.     

 l Horizontal Tile - Specify how many times to tile the selected backdrop image side by side.     

 l Vertical Tile -  Specify how many times to stack the selected backdrop image one above the other.     

 l Specify the Horizontal Span, which is how much of the sphere the backdrop is applied to. A Span of 360° wraps 
the entire sphere.     

 l Specify the Horizontal Offset, in degrees, to shift the backdrop image or tiled images in a clockwise direction.     

 l Specify the Vertical Max, which is the height of the bottom of the backdrop, measured relative to the top of the 
sphere.     

 l Specify the Vertical Min, which is the height of the bottom of the backdrop, measured relative to the bottom of the 
sphere.     

 l The Eye Level setting controls the vertical position of the camera within the sphere. A value of 0 positions the 
camera at the bottom of the sphere while a value of 1 positions it at the top. The default value is 0.5., which centers 
the camera inside the sphere.    

  Background Color

 l Click the Color bar to select the Background Color that displays when a backdrop image is not being used. See 
Color Chooser/Select Color Dialog on page 204.      

The Background Color for plan views and CAD Details is set in the Preferences dialog. See Colors Panel on page 102.     
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LAYER PANEL

The setting on the LAYER panel lets you  choose which layer the selected camera’s plan view symbol is placed on. For more 
information, see Layer Panel on page 191.         

LABEL PANEL

In the Camera Specification dialogs, the settings on the LABEL panel are limited to the Suppress Label check box and 
Position and Orientation settings.         

Camera labels always use the Camera Name specified on the CAMERA panel. When callouts are used, the Callout Label 
and Text Below Line are specified on the PLAN DISPLAY panel.         

For information about this panel, see Label Panel on page 712.         

 

Cross Section/Elevation Specification Dialogs
The Cross Section/Elevation Specification dialogs can be accessed in plan view by selecting one or more cross 
section/elevation camera symbols and clicking the Open Object edit button. See In Plan View on page 1097.

This dialog can also be accessed while a cross section/elevation view is active by selecting Tools> Active View> 
Edit Active View. 

The Cross Section/Elevation dialog has the following panels:

Most of the settings in this dialog are also found in the Cross Section/Elevation, Back Clipped Cross Section, and Wall  
Elevation Defaults dialogs. See Camera Defaults Dialogs on page 1082.    

1123



Chief Architect Premier X14 Reference Manual - Cross Section/Elevation Specification Dialogs

CAMERA PANEL

  General

 l Specify a Name for the camera that displays in its label in plan view and in the Project Browser. Names must be 
unique. See Project Browser on page 58.      

 l Check Saved to save this view with the plan. As soon as you type anything in the text field, this box becomes 
checked. If you click OK while this box is checked, it will become checked permanently.  Saved cameras are listed 
in the Project Browser.

 l Choose the selected camera’s Rendering Technique from the drop-down list. Click the Define button to open the 
Rendering Technique Options dialog. See Rendering Techniques on page 1147.      

 l Uncheck Show Color to toggle the display off in the current view. See Color On/Off on page 196. 

 l Check Show Watermark to turn on the display of the default watermark. See Watermarks on page 1382.

 l Check Show Shadows to turn on shadows in the selected camera view. When unchecked, shadows are not 
generated. See Shadows on page 1130.

 l Check Ray Casted Sun Shadows for higher quality shadows cast by sun light. Ray Casted Sun Shadows take longer 
to generate than regular shadows and only refresh when the camera is not moving. 

 l Check Edge Smoothing When Idle to apply high quality smoothing to edge and pattern lines when the camera is 
not in motion. See Edge Smoothing on page 1132. 

1124



Chief Architect Premier X14 Reference Manual - Cross Section/Elevation Specification Dialogs

  Lighting

 l When Use Sunlight is checked, the sun light source is on in the current view. Uncheck this box to toggle sunlight 
off. 

 l Click the Adjust Sunlight button to open the Adjust Sunlight dialog. Not available in the Camera Defaults dialogs. 
See Generic Sunlight on page 1134.

 
Positioning

These settings control the position of the camera and are not available in any of the Defaults dialogs. See 3D Drafting on 
page 12.                 

 l Specify the X Position of the camera in absolute coordinates.                     

 l Specify the Y Position of the camera in absolute coordinates.                     

 
Scene Clipping

These settings control the extents of the camera view. Only the Ignore Railings and Invisible Walls setting is available in the 
Wall Elevation Defaults dialog. See Clipped Section Views on page 1093.     

 l Check Back Clip to include only the objects or portions of objects located between the start and end points of the 
camera's Line of Sight in the view. This box is checked by default for Back Clipped Cross Section views and is not 
available in any of the Defaults dialog.      

 l Specify the Back Clip After distance, which is the length of the camera's Line of Sight from the Cross Section Line 
at its start to the Back Clip Line at its end. This text field reports the length of the camera's Line of Sight even when 
Back Clip is unchecked above, and is not available in any of the Defaults dialogs.     

 l Check Clip Sides to limit the selected view’s side-to-side extents to the Clip Width specified below. When 
unchecked, the full width of the model is included in the view.     

 l Specify the Clip Width, which is the width of the camera's side-to-side extents. This value also affects the length of 
the camera's Cross Section Line when its symbol is selected in plan view. When Clip Sides is checked, the Cross 
Section Line has end edit handles that adjust this value when they are dragged. See Editing 3D Views on page 1105.     

 l Check Clip Elevation to limit the selected view's vertical extents to the elevation values below. When unchecked, 
the full height of the model is included in the view.     

 l Specify the Bottom Clip Elevation, which is the bottommost extent of the view. Objects or parts of objects located 
below this elevation are not included in the view. When Clip Sides is checked and the bottom clipping plane has 
been edited, this value refers to the end point with the higher elevation.     

 l Specify the Top Clip Elevation, which is the topmost extent of the view. Objects or parts of objects located above 
this elevation are not included in the view. When Clip Sides is checked and the top clipping plane has been edited, 
this value refers to the end point with the lower elevation.     

 l Check Clip to Room to confine the extents of the current view to the room that the camera is located in. The view's 
clip values are reported above for reference. This box is checked by default for Wall Elevation views, is only 
available when the selected camera is located inside a room, and is not available in any of the Defaults dialogs.     

When Clip to Room is checked, two additional options are available:    
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   l Check Ignore Railings and Invisible Walls to ignore the room definition created by these types of walls in a 
selected Wall Elevation view. When this is unchecked, Wall Elevation views only recognize room definition created 
by regular walls. See Cross Section/Elevation Views on page 1090.   

 l Check Ignore Walls Above to prevent any walls located above the selected camera's room from displaying in the 
view. This option typically has an effect only when the camera's room has Flat Ceiling Over This Room unchecked, 
or the room above has Floor Under This Room unchecked, in the Room Specification dialog. See Structure Panel on 
page 444. 

SELECTED DEFAULTS PANEL

The settings on the SELECTED DEFAULTS panel control which Saved Defaults and layer settings are used in the view.           

These settings are also found in the Active Defaults dialog. See Active Defaults Dialog on page 82.          

PLAN DISPLAY PANEL

The settings on the PLAN DISPLAY panel control the appearance of the selected camera in plan view. See In Plan View on 
page 1097.           

 
Display on All Floors

Check Display on All Floors to display the selected camera’s symbol in plan view on all floors. When unchecked, it 
only displays on the floor where the camera was created. See Creating Camera Views on page 1087. 
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Display As Callout

Check Display As Callout to use a callout symbol to represent the selected camera in plan view and enable the settings 
below. Most of the Standard Options, below, are unavailable when Display as Callout is checked.                 

 l Specify the callout Placement, either at the Center, Left Side, Right Side, or Both Sides of the clip plane. If 
Center or Custom is selected, no clip plane line displays. 

 l When Custom is the specified Placement, specify the camera icon's Offset from Center.

 l Specify the Callout Label, which is the text that displays inside the callout circle. If no Text Below Line is 
specified, the Callout Label is centered in the callout.         

 l Specify the Text Below Line for a bottom row of text, if desired. Check Automatic to populate the Text 
Below Line with the layout page Label if the selected view is sent to layout. If no layout page Label is 
specified, no automatic Text Below Line will be created. See Camera Labels and Callouts on page 1098.          

 l To specify the Callout Size, uncheck Automatic and then type in the text field. When Automatic is checked, 
the size is based on the length of the Callout Label and the size of the current Text Style.          

 l Specify the appearance of the Callout Arrow. Choose None, a Small arrow, or a Large arrow. Uncheck Filled 
if you do not want a solid filled arrow.          

Note: Callout arrows only display as filled when a camera is 
inactive. Inactive camera callout arrows are unfilled.   

 l Specify the Cross Section Line Style. Not available when Center is selected, above. Check By Layer to use 
the line style specified for the selected callout’s layer, or choose a line style from the drop-down list or the 
Library.          

 l Specify the Cross Section Line Weight. Not available when Center is selected, above. Check By Layer to use 
the line weight specified for the selected callout’s layer, type a line weight in the text field.          

 
Standard Options

These settings allow you to specify the appearance of the selected camera’s standard symbol.  Most of these options 
are disabled when Display As Callout is unchecked. See Dynamic Defaults on page 79. 

 l Uncheck Default beside any of these options to modify it.

 l The Camera Symbol Size is measured in plan inches (mm). 

 l Check Show Camera Focal Point to display the camera’s focal point in plan view. When unchecked, the camera’s 
line of sight, focal point, and clip plane indicators are hidden until the camera is selected.

 l Specify the Clip Plane Indicator Length in plan inches (mm). See To create a cross section/elevation view on 
page 1091. 

BACKDROP PANEL

The settings on the BACKDROP panel allow you to specify a backdrop image or color to display behind your model in the 
selected 3D view. See Backdrop Panel on page 1121.          

LAYER PANEL

The setting on the LAYER panel lets you  choose which layer the selected camera’s plan view symbol is placed on. For more 
information, see Layer Panel on page 191.          
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LABEL PANEL

In the Cross Section/Elevation Camera Specification dialog, the settings on the LABEL panel are limited to the Suppress 
Label check box and Position and Orientation settings.           

Camera labels always use the Camera Name specified on the CAMERA panel. When callouts are used, the Callout Label 
and Text Below Line are specified on the Plan Display panel.          

For information about this panel, see               Label Panel on page 712.
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Chapter 33
 

3D Rendering

There are a variety of tools available to create 3D views of a model: simply click a button to create an overview, or click 
and drag to create a camera or cross section/elevation view. See 3D Views on page 1080.         

To improve the quality of the rendering and create a custom look, you can adjust lighting, edit the materials used in the 
plan, choose from a variety of rendering techniques, and fine-tune 3D view quality settings.   

You can also use CPU Ray Tracing to create highly realistic images of your Chief Architect plans. As the name implies, ray 
tracing calculates the rays of light in a view as they travel through the 3D model and reflect off surfaces. As a result, ray 
tracing is slower than regular rendering, but can be used to achieve much more complex effects such as complex reflections 
and highly realistic lighting. See CPU Ray Tracing on page 1163.
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Rendering Tips
There are a variety of factors which affect the appearance and quality of rendered 3D views. You can use these tools and 
settings to achieve renderings that meet your needs. 

GPU RAY TRACING

On Windows systems that support it, GPU Ray Tracing produces highly realistic lighting, shadows, and effects such as 
refraction in real time using the Graphical Processing Unit (GPU). GPU Ray Tracing calculates the paths of light rays in the 
scene and can be used in 3D views using the Physically Based and Clay Rendering Techniques. See Rendering Techniques 
on page 1147.

When GPU Ray Tracing is active in a view, multiple samples of indirect lighting in the scene are created, improving the 
lighting quality with each sample. By default, samples are run as long as a given view is active; you can, however, specify 
the Maximum Export Samples to be used when the view is exported as a picture or sent to layout, and you can also specify 
that samples in the view be capped at that value instead of running indefinitely. The current number of samples is reported 
in the Status Bar. See Physically Based (Ray Trace) Panel on page 1153 and The Status Bar on page 25.

GPU Ray Tracing can also be used when recording a Walkthrough. Each frame will use the Maximum Export Samples 
value and will take considerably more time to record. See Recording a Walkthrough on page 1213.

You can find out if your computer's graphics card supports GPU Ray Tracing in the Preferences dialog. See Video Card 
Status Panel on page 130.

In other Rendering Techniques in which lighting is supported, GPU Ray Tracing enhances the quality of shadows and 
ambient occlusion only. For troubleshooting purposes, you can turn this feature off or on in the Preferences dialog. See 
Render Panel on page 129.

If your system does not support GPU Ray Tracing, you can instead use CPU Ray Tracing to produce renderings with high 
quality lighting and effects. CPU Ray Tracing runs in its own process using the computer's processor, so you can let it run 
in the background while continuing to work in Chief Architect. See CPU Ray Tracing on page 1163.

LIGHTING

Lighting is extremely important in most 3D renderings, in ray tracing, and in VRML file export. Lighting controls the 
visibility of objects in a view, affects the appearance of surfaces, and influences the appearances of colors and textures on 
those surfaces. Even small changes to light intensity, direction and color can have a large impact on image quality. See 
Lighting on page 1133. 

SHADOWS

 Like lighting, shadows have an important effect on image quality. Shadows can be generated in any type of camera 
view using any Rendering Technique aside from Glass House. See Rendering Techniques on page 1147.

When shadows are enabled and the sun is shining directly at a window, its light can shine through the window and into an 
interior room. These shadows use Ray Casted Sun Shadows by default, but this option can be unchecked if it slows 
performance in 3D views. See Generic Sunlight on page 1134.

Shadows are enabled in Full Camera views by default. You can, however, check or uncheck Show Shadows and Ray 
Casted Sun Shadows in the defaults dialog for any camera tool or in the specification dialog for any camera view. In 

1130



Chief Architect Premier X14 Reference Manual - Rendering Tips

addition, you can select 3D> Camera View Options> Toggle Shadows  in any camera view. See Camera Panel on 

page 1116.

Shadows are affected by the number of light sources in a plan, as well as what Rendering Technique is in use. In order for a 
light source to cast shadows, it must be On in the current view and have Cast Shadows checked in its specification dialog. 
See Light Data Panel on page 688.

In addition to their appearance in camera views, sun shadows can also display in plan view to represent the shadows created 
by the sun at a particular date, time, and location. See Sun Shadows on page 1142.

REFLECTIONS

 Reflections are another aspect of lighting that can increase a 3D view’s realism. When a flat surface is assigned a 
Mirror material, it can display the reflections of other objects in the scene. Bear in mind that a Mirror surface cannot 

display the reflection of another mirror: when one mirror can be seen in another, its material is shown rather than a 
reflection. A material can be assigned the Mirror class in the Define Material dialog. See Properties Panel on page 1073.

Reflections in Mirrors only generate in Perspective 3D views using Rendering Techniques that show material textures. In 
some situations, they can slow down 3D view generation and responsiveness. See Rendering Techniques on page 1147.

When the Physically Based  Rendering Technique is in use, reflections on non-mirror surfaces are modeled, as well. See 

Physically Based (Ray Trace) on page 1148.

Reflections in Mirrors can be toggled on or off in a camera view by selecting 3D> Camera View Options> Toggle 
Reflections  as well as in the Camera Specification dialog.

GPU Ray Tracing in Physically Based renderings is capable of 
more extensive reflection effects. When GPU Ray Tracing is 

enabled, Reflections should be toggled on for best quality. See GPU Ray 
Tracing on page 1130, above.

MATERIAL DEFINITIONS

Textures are graphic files that represent contoured surfaces of objects such as carpet, bricks, tile, and wood in rendered 
views. Textures are assigned to materials which in turn are assigned to objects. See Patterns and Textures on page 1051. 

The display of materials in rendered views is controlled by settings on the TEXTURE and PROPERTIES panels of the Define 
Material dialog. See Define Material Dialog on page 1066.

For realistic rendered views, it is sometimes helpful to make adjustments to texture properties so that they map to surfaces 
correctly. See Mapping Patterns and Textures on page 1062. 

Brightness, shininess and transparency control how light sources affect the display of surfaces in rendered views. See 
Lighting on page 1133.

If no texture is selected for a material or if the display of textures is turned off, affected surfaces are a solid color instead.

Specially produced material map image files can add realism to a material’s appearance in rendered and CPU Ray Trace 
views by making it appear contoured instead of flat or glossy instead of rough. See Material Maps on page 1051.

IMAGES

Image objects use picture files to represent individual objects such as trees, flowers, and vehicles in 3D views and exported 
VRML files. Images are useful because they have only one 3D surface, allowing them to represent complicated 3D objects 
with a high degree of realism but with minimal cost in terms of performance. See Placing Images on page 1181.   
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BACKDROPS

A backdrop is an image, usually of an exterior view, that displays in the background of 3D views to help place the model 
into a realistic setting and add a sense of perspective. If a backdrop is not specified, Chief Architect applies a background 
color. See 3D Backdrops on page 1201.

EDGE SMOOTHING

Angled surface edges and pattern lines will sometimes display on screen as jagged or stair-stepped. Edge Smoothing 
softens this effect, producing cleaner looking lines.

You can specify how much Hardware Edge Smoothing occurs in 3D views in the Preferences dialog. Hardware Edge 
Smoothing is set to "High" by default. Using a lower setting will lower rendering quality but may improve performance on 
some systems. See Render Panel on page 129. 

Even higher quality Edge Smoothing can be produced by checking Edge Smoothing When Idle in the Camera 
Specification dialog. This setting does not affect a camera while its position or orientation are being changed, but applies 
additional smoothing to edge and pattern lines when the camera is not in motion. See Camera Panel on page 1116. 

This high quality Edge Smoothing option is view-specific and can also be toggled on or off by selecting 3D> Camera View 
Options> Toggle Edge Smoothing When Idle . 

HIDE CAMERA-FACING EXTERIOR WALLS

 Occasionally, it can be very helpful to view the interior of a structure from an exterior view. To achieve this, create 
an exterior camera view or overview and select 3D> Camera View Options> Hide Camera-Facing Exterior Walls. 

This option is view-specific and can also be set in the Camera Specification dialog. See Camera Panel on page 1116. 

Hide Camera-Facing Exterior Walls is also an option for Walkthrough Paths. See Walkthrough Options Dialog on page 
1214.

When Hide Camera-Facing Exterior Walls is enabled in a camera view, the CPU Ray Trace  tool will not be available. 

MATERIAL TRANSPARENCY

Most materials are opaque while some materials, such as glass, are partially transparent. Transparency can be set in the 
Define Material dialog. See Properties Panel on page 1073.

There are two ways to specify a material as transparent:

 l For General materials, the Transparency setting controls how opaque or transparent a material is and can be set along 
with other properties like Roughness.     

 l Transparent materials are instead completely transparent but have an Index of Refraction setting that controls how 
much light bends when it passes through the material in GPU and CPU Ray Trace views.     

Transparency is supported in all Rendering Techniques. Most Rendering Techniques, however, have an Opaque Window 
Glass setting that, when checked, overrides the transparency of the Glass components of exterior doors, exterior windows, 
and interior windows. Interior doors with Glass components are unaffected. When this box is checked, Glass components 
display the Material Color assigned to their material. See Rendering Technique Options on page 1150.
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Lighting
Lighting controls the visibility of objects in 3D views, affects the appearance of surfaces, and influences the appearances of 
colors and textures on those surfaces.              

Each individual light source has a set of properties, such as intensity and color, that can be defined. See Light Data Panel on 
page 688.          

By default, a maximum of eight lights can display in a given camera view or overview. If more than eight are present, those 
with the highest intensity located in the same room as the camera are rendered. Lights in adjacent rooms may also be 
rendered, with the highest intensity lights rendered first. 

 l You can specify a different Maximum Lights number in the Camera Specification dialog. See Camera Panel on page 
1116.

 l You can also manually turn on and off individual lights in order to get the desired lighting effects. See Displaying 
Lights on page 1136.              

 l In addition, you can create custom Light Sets with specific lights turned on or off as needed for specific purposes. See 
Light Sets on page 1136.          

When the camera is outside a building, the program normally uses sunlight for lighting calculations and turns off all other 
light sources. You can turn the sunlight off and use all the other exterior lights to simulate nighttime views.

There are five types of light sources in Standard rendered and CPU Ray Trace views:

DEFAULT INTERIOR LIGHTS

If you create a Standard interior camera in a room where no lights have been placed, the program creates a Default Light 
source within that room. The Default interior light acts like a central point light source but cannot be selected or edited. 

Because the Default Light cannot be adjusted, if you want to control the light in an interior rendered view, you must add 
lights to the rooms in your plan by placing light fixtures and Added Lights. 

LIGHT FIXTURES

An electric symbol that represents a Light Fixture can have one or more light sources associated with it. Properties for each 
light source such as light type, color, and intensity can be modified in the fixture’s specification dialog. See Electrical 
Service Specification Dialog on page 686.

If the light source is a Point or Spot Light, you can also adjust its Offset, or position relative to the fixture. If you choose to 
Show Position in Camera View, you can see where the light source is located.          

Light sources look most realistic when they are offset from a surface.          

ADDED LIGHTS

In plan view, select 3D> Lighting> Add Lights to quickly add a light source to a plan. Added Lights and their labels 
are placed on the “Light Sources” and “Light Sources, Labels” layers by default.         

Added lights only act as light sources in plan files that have at least one room defined. They display 2D symbols in plan 
view but do not display as objects in 3D views. 
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While Added Lights do not display as objects in 3D, you can specify that an Added Light’s position be represented by red 
crosshairs in rendered views that use lighting. Spot Lights also display a blue arrow indicating the light's direction. See 
Light Data Panel on page 688.

Added lights can be placed into objects that normally do not generate light, such as a TV.

There are two types of added light sources: Point Lights and Spot Lights. See Light Types on page 1135.

GENERIC SUNLIGHT

When you create a rendered view and no Sun Angle exists, the program creates a Generic Sun light source.          

The Generic Sun’s default intensity, color, and angle can be set in the Generic Sun Defaults dialog, and can be modified in 
the Adjust Sunlight dialog. In addition, you can specify that it follow the camera in 3D views so surfaces are always 
illuminated. The Generic Sun’s settings are view specific: each 3D view can have its own, unique settings. See Adjust 
Sunlight Dialog on page 1145. 

When standard shadows are enabled, sunlight can shine through windows into interior rooms. See Shadows on page 1130.

If you place a Sun Angle  in plan view, the Generic Sun is no longer used as a light source in rendered views. Instead, 

sunlight is generated based on specific date, time, latitude, and longitude information. See Sun Angles and Shadows on page 
1140.             

You can specify that a particular Sun Angle or the Generic Sun be used in any active camera view in the Adjust Sunlight 
dialog. See Adjust Sunlight Dialog on page 1145.             

AMBIENT LIGHTING AND OCCLUSION

Ambient lighting simulates the way light bounces around a scene, producing a basic level of uniform illumination on all 
surfaces. It is used in camera views and overviews using the Standard, Duotone, and Watercolor Rendering Techniques and 
in ray trace views.

There are three types of ambient light in Chief Architect:

 l Interior Ambient controls the ambient light in interior views.
 l Daytime Ambient controls the ambient light in exterior views when Toggle Sunlight  is on. See Sun Angles and 

Shadows on page 1140.
 l Nighttime Ambient controls the ambient light in exterior rendered views when Toggle Sunlight  is off.

You can control the brightness of each in the Rendering Technique Options dialog. See Standard Panel on page 1151. 

Ambient occlusion adds shading to surfaces near corners which, because of their location, reflect less light compared to 
other surfaces. Too little ambient occlusion can result in a view having a flat appearance. You can specify the amount of 
Ambient Occlusion to use in Standard, Duotone, Watercolor, and Physically Based renderings in the Camera Specification 
dialogs. See Camera Panel on page 1116.

Additional ambient occlusion options are available in  ray trace views. See Lighting Panel on page 1168.           

Ambient occlusion maps add the appearance of depth to materials by indicating which parts a texture receives more ambient 
light and which parts receive less. See Material Maps on page 1051.          
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Light Types
There are two types of light source, each of which generates light in a different way and allows you to create a variety of 
lighting effects:           

 l Point Light sources
 l Spot Light sources

Any light source              except a Sun Angle can be specified as a Point or Spot Light in the Electrical Service Specification dialog. 
See Light Data Panel on page 688.         

In addition to being assigned to light fixtures, these two types of light sources can be placed in a plan as Added 
Lights, which are light sources that are not associated with a fixture. As with light fixtures, the lighting properties of 

Added Lights can be specified in their specification dialog. See Light Specification Dialog on page 1139.         

POINT LIGHTS

Like a bare light bulb, a Point Light radiates light equally in all directions from its origin. Point lights are a realistic 
representation of non-directional electric lighting.         

If no user defined light exists, Chief Architect creates a Point Light source to represent a light within a room.         

To create a Point Light source
 1.  In plan view, select 3D> Lighting> Add Lights .

 2.  Click in plan view. Do not drag the pointer when you click the screen, or you will create a Spot Light.

SPOT LIGHTS

A Spot Light focuses the light in a specified direction. The Tilt and Direction Angles can be specified in a Spot Light’s 
specification dialog.         

To create a Spot Light source
 1.  In plan view, select 3D> Lighting> Add Lights .

 2.  Click and drag in plan view no more than two plan feet (600 mm) in any direction.

 3.  As you drag, the light preview will look like a Spot Light icon.

 4.  When you release the mouse, a Spot Light pointing in the direction that you dragged is created.

You can also use a Spot Light’s edit handles in plan view to move it, as well as change its direction and Cut Off Angle.         
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Displaying Lights
The display of light fixtures and Added Lights in floor plan and 3D views is controlled in the Layer Display Options 
dialog. Light fixtures are placed on the “Electrical” layer by default, and Added Lights, on the “Light Sources” layer. 

See Layer Display Options Dialog on page 183.

In addition, they can serve as sources of light in rendered and/or CPU Ray Trace 3D views. They can be turned on and off, 
as well as set to cast shadows.

IN PLAN VIEW

In plan view, both light fixtures and Added Lights can display labels when the “Electrical, Labels” and/or “Light Sources, 
Labels” layers are turned on. See Label Panel on page 712.

IN 3D VIEWS

Light fixtures and Added Lights can serve as sources of light in rendered and/or CPU Ray Trace views.         

To turn a light on or off
There are several ways to turn a light fixture or Added Light on or off:         

 l Select one or more fixtures or Added Lights and click the Turn Light(s) Off in 3D  or Turn Light(s) On in 3D 

 edit button.

 l Uncheck On in the object’s specification dialog. See Light Data Panel on page 688.
 l Clear the On/Off check box in the Adjust Lights dialog. See Adjust Lights Dialog on page 1137.

Added Lights are not associated with a 3D fixture, but you can specify that any light source’s location be represented in 3D 
views using crosshairs. Position Indicators can display in all Rendering Techniques aside from Line Drawing. See Light 
Data Panel on page 688.         

Light source position indicators will only display when the light is in use in the current 3D view. That is, it must be:          

 l Turned on.
 l Specified for use in Camera views.
 l In-use in the current view.
 l Either located in a room or in an exterior view with Sunlight toggled off.

Sunlight will shine through windows into interior rooms when shadows are enabled. See Shadows on page 1130.         

 

Light Sets
By default, cameras use an Automatic Lighting Mode that allows a set number of lights to illuminate the view. This number 
can be specified in the Camera Specification and Adjust Lights dialogs. See Camera Panel on page 1116.

If more than the set number of lights are present, lights are prioritized in this order:

 l Lights in the same room as the camera before those in different rooms.
 l Higher intensity lights before lower intensity lights.
 l Lights closer to the camera before those further away.

Regardless of their intensity or proximity to the camera:
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 l Interior lights are not used in exterior camera views.
 l Exterior lights are not used in exterior camera views when the Sunlight is toggled on. See Generic Sunlight on page 

1134.
 l Lights on floors above the camera are not used in Floor Overviews. See 3D View Tools on page 1085.

Light Sets are an alternative to this automatic behavior. When a Light Set is specified, you control which lights are in use in 
the current camera and which are not, regardless of their distance from the camera. Multiple Light Sets can be created for 
different purposes in a single plan, including CPU ray tracing. See Lighting on page 1177.          

The Automatic Lighting Mode is useful because it is an easy way to produce reasonable lighting without taxing your video 
memory. Light Sets can take some time to set up and may require more resources on your system; however, they give you 
greater control when producing presentation views. 

Light Sets are not removed when lights are deleted from a plan. They are removed, however, when objects are purged using 
the Save as Template  tool. See Save as Template on page 89.         

ADJUST LIGHTS DIALOG

Light fixtures and Added Lights in the current plan are listed and can be edited in the Adjust Lights dialog. Select 
3D> Lighting> Adjust Lights to open this dialog in floor plan or any 3D view. You can also open it by clicking the 

Adjust Lights button in the Camera Specification dialog. See Camera Panel on page 1116.         

The Adjust Lights dialog is an efficient way to control which lights are turned on in 3D views. 

 
Light Settings

The settings at the top of the dialog allow you to manage the Light Settings in the current plan. When the dialog is opened 
while a camera view is active, these settings are available:         
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 l The name of the Current Camera is stated here for reference.

 l Specify the desired Lighting Mode. Automatic uses the specified Maximum Lights while Light Set uses the 
lights as specified below. 

When Light Set is selected, several additional settings are available:          

 l Select a Light Set to edit from the drop-down list. If the dialog is opened from a camera view, this Light Set will 
become active.          

 l Check Modify All Light Sets to apply any changes made to the properties of the selected Light Sets to all Light 
Sets.          

 l Click the New Set button to create a new Light Set with all light sources turned off.         

 l Click the Copy Set button to create a new Light Set that is an exact copy of the one that is currently selected.         

 l Click the Rename Set button to type a new name for the selected Light Set. Not available for the Default Set.         

 l Click the Delete Set button to delete the selected Light Set. A Light Set can only be deleted if it is not in use, and 
only if the Adjust Lights dialog is opened from the menu in plan view. Not available for the Default Set.         

In some circumstances, performance in the Adjust Lights dialog can be slow when opened from a camera view.          

 l To avoid this, uncheck Update Lighting Automatically. 

 l When Update Lighting Automatically is checked, you can click the Update button to update the lights in the 
camera view.

 
Light Source Properties

All lights in the current plan are listed here using the same Names as their labels. A variety of light attributes can be edited 
here, but only the On setting is specific to the selected Light Set. The others are global. 

Note: If a light fixture is assigned to a Distribution Path or Region, it 
will only be listed once in the Adjust Lights dialog. See Distributed 
Objects on page 1043.

 l If a line item is a light fixture, it will have an arrow to the left of its name. Click this arrow to show the fixture’s 
light sources as individual line items.             

 l Check the box in the On column to turn it on or uncheck the box to turn it off. If a fixture has multiple light 
sources and only some are on, a solid square will display in its check box.             

 l The Count column lists the number of light sources assigned to each light fixture. This column is empty for Added 
Lights.              

 l The Room column states the location of each light. If a light is not in a room, “Outside” will be reported.             

 l The Floor column states the floor level that each light is on.             

 l The Type column states the type of light source used by each light. See Light Types on page 1135.             

 l The Intensity column states the strength of each light.             

 l The Color column displays the light’s color. Click the button to choose a different color if you wish.             

 l The Used In column states which types of views each light is used in: camera views only, CPU Ray Trace views 
only, or both.         
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 l The In Use column states whether each light is emitting light in the Current Camera view. If a fixture has multiple 
light sources and only some are in use, a blue box will display in its row.             

 
Adjust

To adjust the properties of a light in the list, double-click on its name or select it and click the Adjust button. Make changes 
to the light in its specification dialog and click OK. For more information, see Light Specification Dialog on page 1139 or 
Electrical Service Specification Dialog on page 686.         

Multiple lights can be selected by holding down the Shift key. If multiple lights are selected, clicking the Adjust button 
opens the Light Data dialog, which is similar to the LIGHT DATA panel of a single object’s specification dialog. This dialog 
will also open if a Tray Ceiling Polyline is the selected light source.

If you are in a 3D view that displays lighting, the view will regenerate based on the new light settings.         

The Generic Sun              and Sun Angles are not listed in this dialog. See Generic Sunlight on page 1134.        

 

Light Specification Dialog
Select one or more Point or Spot Lights and click the Open Object edit button to open the Light Specification dialog.
         

You can also select 3D> Lighting> Adjust Lights  to access a list of the light sources present in the current plan and 

open the specification dialog for any of them. See Adjust Lights Dialog on page 1137. 

LOCATION PANEL

 
Light Display
Specify where the selected Added Light displays in plan and 3D views.         

 l Select All Floors to display the selected light on all floors in plan view. See Multiple Floors on page 743.

 l Select Specify Floor Number to display the light on one floor only, then choose a floor number from the drop-down 
list.

Note: The floor or floors that an Added Light displays on in plan 
view is totally independent of where it displays in 3D.

 l Specify the selected light’s Absolute Elevation, measured relative to 0, which is the default height of Floor 1.

 l Specify the Display Size, which is the diameter of the circle representing the Added Light in plan view.

LIGHT DATA PANEL

The settings on this panel are also found on the same panel of the Electrical Service Specification dialog. See Light Data 
Panel on page 688.         
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Depending on the type of light(s) selected, the options available here may vary. 

LAYER PANEL

For information about the settings on this panel, see Layer Panel on page 191.          

LABEL PANEL

Labels for Added Lights display in plan view when the “Light Sources, Labels” layer is turned on and use the Text Style 
assigned to that layer. See Text Styles on page 547.          

For information about the settings on this panel, see               Label Panel on page 712.

 

Sun Angles and Shadows
In addition to the functional and aesthetic properties of ambient light and light sources in rendered views, the direction and 
angle of the sun’s light and shadows are an important consideration. Two tools allow you to generate sunlight and sun 
shadows with accuracy:

  North Pointers allow you to specify the direction of true north in a plan.

  Sun Angles let you specify an exact location, date, and time for sunlight and sun shadow generation.

NORTH POINTER

The North Pointer tool is used to define the direction of true north in a plan. The direction of north does not affect the 
orientation of the Snap and Reference grids, but it does affect the direction of sunlight and sun shadows, how conditioned 
area totals are calculated, and how bearing information is interpreted by the program. 

Every bearing is defined relative to North, so it is best to 
establish this direction before entering survey information for a 

site plan. 

If a North Pointer is not used, north is assumed to be straight up on screen in plan view. 

Select CAD> Lines> North Pointer , then click and drag to draw the pointer, starting at the tail and dragging toward the 

point. Once it is drawn, you can define its exact length and angle in its specification dialog. See Line Specification Dialog 
on page 309.

Multiple North Pointers can be drawn in a given plan file, and will always point in the same direction automatically. If you 
rotate one of them, the others will automatically rotate to match. Similarly, if you draw a new North Pointer at a different 
angle, existing North Pointers will rotate to that angle automatically. 

If you choose to display line angles when a North Pointer exists, be sure to select the appropriate format in the CAD 
Defaults dialog. See CAD Defaults and Preferences on page 295.
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 l If angles are set to Bearings, they are relative to the North Pointer.

 l If angles are set to show as Degrees, the angle relates to 0° (horizontal to the right) even if a North Pointer is present.

A North Pointer can be selected and edited using its edit handles and Edit Toolbar buttons. All attributes of the N aside from 
its size are drawn from the Text Style assigned to the  layer it is are placed on. For more information, see Editing Line-Based 
Objects on page 218. 

SUN ANGLES

Sun Angles let you establish exactly where your plan’s building site is located, and a precise date and time. This information 
allows the program to determine the sun’s location in the sky and generate sunlight and sun shadows with accuracy.           

Note: Sun Angle calculations do not adjust for elevation. They are based 
on formulas published by the United States Naval Observatory and have 
limited accuracy as documented by the USNO. 

When an exterior 3D view is rendered, the program looks for an active Sun Angle. If it finds none, the Generic Sun is used. 
See Generic Sunlight on page 1134.          

To create a Sun Angle
 1.  In plan view, go to Floor 1 or Floor 0. Sun Angles can only be created on these floor levels. See Multiple Floors on 

page 743.              

 2.  Select CAD> Lines> Sun Angle  and click in the drawing area to place a Sun Angle arrow at that location.              

 3.  In the Sun Angle Specification dialog, specify the Sun Angle’s Earth Data and other information. See Sun Angle 
Specification Dialog on page 1143.             

 4.  After it is created, a Sun Angle cannot be rotated; but it can be moved as well as resized using its edit handles. 
Shadows are not affected.             

Multiple Sun Angles can be created, each with different specifications; however, only one can be used as a light source in a 
given 3D view. If more than one Sun Angle is present, specify the one to use in the current view in the Adjust Sunlight 
dialog. See Adjust Sunlight Dialog on page 1145.          
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Sun Angles can display their date and time in plan view and can also produce sun shadow polylines in plan view. Both Sun 
Angles and their shadows are on the “Sun Angles & Shadows” layer by default.   

SUN SHADOWS

Sun Angles  allow the program to produce shadows cast by a building that reflect the exact position of the sun in the sky in a 
particular location and at a specific date and time. This position and time information is specified in the Sun Angle 
Specification dialog; the date format is derived from your operating system settings. See Earth Data Panel on page 1143 
and Region and Language Settings on page 78.          

In plan view, sun shadows are represented by polylines filled with a hatch pattern. If a Terrain Perimeter is present, the 
shape of a sun shadow polyline is affected by changes in terrain height. If no Terrain Perimeter exists, sun shadows fall on 
an imaginary plane at a height of zero, the default height for Floor 1. Sun shadows rebuild whenever the terrain is rebuilt. 
See Build Terrain on page 1251.          

No sun shadow generates if the sun is below the horizon or if it is so low on the horizon that the shadow would be 
extremely long.          

Multiple Sun Angles can be placed in the same plan to allow the simultaneous display of shadows cast at different times in 
plan view. Only one should be turned on in 3D views at any given time, however.          

Specify different line colors and/or styles for shadows cast by 
multiple Sun Angles on the Line Style and Fill Style panels of 

the Sun Angle Specification dialog.

To generate the sun shadows associated with a particular Sun Angle, select it and click the Make Shadow  edit button or 

click the Make Shadow button in the Sun Angle Specification dialog. See Lighting Data Panel on page 1144.           

There are several ways to delete a sun shadow polyline:          

 l In plan view, select and delete the defining polyline.             
 l In plan view, select and delete the Sun Angle arrow.             
 l In plan view, select the Sun Angle arrow and click the Delete Shadow  edit button.             

 l In the Sun Angle Specification dialog, click the Delete Shadow button. See Earth Data Panel on page 1143.             
 l In the Sun Angle Specification dialog, click the Make Shadow button to delete existing shadows and create new ones.
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Sun Angle Specification Dialog
Select CAD> Lines> Sun Angle, then click in plan view to open the Sun Angle Specification dialog and create a 
new Sun Angle. See Sun Angles and Shadows on page 1140.

To open the Sun Angle Specification dialog for an existing Sun Angle, select it and click the Open Object  edit button. 

This dialog can also be accessed by clicking the Edit button in Adjust Sunlight dialog. See Adjust Sunlight Dialog on page 
1145.   

EARTH DATA PANEL

The settings on the EARTH DATA panel let you establish exactly where your plan’s building site is located, and exactly when 
the sun’s light should be calculated. This information allows the program to generate sunlight and sun shadows with 
accuracy. 

 
Solar Angles

The Solar Angles display for reference and may update as changes are made to the settings on this panel. 

 l The Solar Altitude is the angle of the sun above the horizontal plane, in degrees. 

 l The Solar Direction is the angle between true North and the sun's direction. This is the angle the Sun Angle arrow 
points in plan view relative to the direction of North. See North Pointer on page 1140. 

 
Location

                  Specify the Location of the selected Sun Angle. The initial location can be set in the Preferences dialog. See CAD Panel on 
page 117.
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 l Specify the Latitude, which is measured either North or South of the equator, depending on which radio button 
you select. 

 l Specify the Longitude, which is measured either East or West of the Greenwich meridian, depending on which 
radio button you select. 

 
Date and Time

Specify the Date and Time of the selected Sun Angle. The initial time zone can be set in the Preferences dialog.

 l Specify a Date for the selected Sun Angle. Select a month from the first drop-down list, a day from the second, 
and a year from the third. 

 l Specify a Time for the selected Sun Angle. Select an hour from the first drop-down list; minutes in 15 minute 
increments can be selected from the second list.

 l If you want the Sun Angle to observe Daylight Savings Time, check this box.

 l Specify the Time Zone that the building site is located in. 

 
Plan View Display

Specify the Plan View Display of the selected Sun Angle. 

 l Specify the Length of Plan Symbol, which is the length of the Sun Angle arrow in plan view.

 l Check Show Date on Sun Angle to have the date and time display on the Sun Angle arrow in plan view. This 
label uses the Text Style assigned to the “Sun Angle & Shadows” layer. See Text Styles on page 547. 

 l Check Auto Rebuild Terrain to rebuild the terrain automatically whenever you create a sun shadow. If this is 
unchecked and you regenerate sun shadows, the program will prompt you to rebuild the terrain. >See Building the 
Terrain on page 1263.

When you use the Build Terrain command in plan view, all sun shadows in the plan are automatically updated.

 l Click the Make Shadow button to create or regenerate the sun shadow in plan view. See Sun Shadows on page 
1142.

 l Click the Delete Shadow button to remove the sun shadow from plan view. 

 l Check Always Update to have the program update the selected Sun Angle’s shadow whenever any of the defining 
information is changed. When this is checked, the program may be slower when changes are made in this dialog. 

 l If Always Update is unchecked and you make changes in this dialog, click the Make Shadow button to generate a 
new shadow.

Note: The Make Shadow option does not toggle Shadows, but may 
cause 3D views to update if they are using the selected Sun Angle. See 
Shadows on page 1130.

LIGHTING DATA PANEL

A Sun Angle can be used as a light source in 3D views. The settings on the LIGHTING DATA panel control attributes of the 
sunlight associated with the selected Sun Angle. 

The settings defined on the LIGHTING DATA panel do not affect the sun shadow in plan view: they only affect 3D views in 
which lighting and shadows can display.

1144



Chief Architect Premier X14 Reference Manual - Adjust Sunlight Dialog

 l When Casts Shadows is checked, the light source associated with the selected Sun Angle casts shadows. These 
shadows are similar to the shadow shown in plan view, but may render differently based on the presence of other light 
sources. See Shadows on page 1130.

 l Select an Intensity from the drop-down list or specify a value using the text field to define the relative strength of the 
light source. The time of day as set on the EARTH DATA panel does not affect how the Sun Angle renders as a light 
source, but this does.

 l Click the Color bar to select a color for the sunlight associated with the selected Sun Angle. See Color Chooser/Select 
Color Dialog on page 204. 

LINE STYLE PANEL

For information about the LINE STYLE panel, see Line Style Panel on page 310.

FILL STYLE PANEL

The settings on the FILL STYLE panel control the appearance of the selected Sun Angle’s shadow in plan view. For 
information about these settings, see Fill Styles on page 197.

ARROW PANEL

For information about the settings on the ARROW panel, see Arrow Panel on page 312.

 

Adjust Sunlight Dialog
The Adjust Sunlight dialog allows you to control the intensity, direction and color of the Generic Sun light source in 
the currently active 3D view or to select a Sun Angle to serve as the source of sunlight in the currently active view. 

See Generic Sunlight on page 1134.   

The settings in this dialog are view specific. Any changes made to them affect the sun in the currently active 3D view only. 
Other 3D views can have their own unique settings.     

The initial sunlight attributes used in a newly created camera are set in the Sunlight Defaults dialog. See 3D View Defaults 
and Preferences on page 1081.    

There are four ways to open the Adjust Sunlight dialog:   

 l Click the Adjust Sunlight button in the Camera and Cross Section/Elevation Specification dialogs. See Camera Panel 
on page 1116.

 l From the menu, select 3D> Lighting> Adjust Sunlight.
 l From the toolbar, click Camera View Lighting Tools , then click the Adjust Sunlight  button.

 l Right-click in an empty space in the background area, then select Adjust Sunlight from the contextual menu.
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Use Generic Sun

Select Use Generic Sun to represent the sun in the currently active 3D view using the settings that follow.

 l Use the Intensity slider bar or text field to control the brightness of the Generic Sun's light.

 l Click the Color bar to define the color of the light being modeled. Colored sunlight may be used to achieve special 
lighting effects, but may alter the appearance of your material colors and textures.

 l Check Sun Follows Camera to adjust the position of the Generic Sun so that it is always behind the camera, 
illuminating surfaces in the view. When this is checked, the Tilt and Direction Angle settings that follow are 
disabled.

Note: If Use Generated Sky is in use as the backdrop in the current 
view and Sun Follows Camera is checked, the Generated Sky will 
not update if the camera is moved.

 l Specify the Tilt Angle, which is the angle of the sunlight with respect to the horizon. A value of 90° means that 
the light points straight up, while a value of -90° means that the light points straight down. 0° is parallel to the 
horizon.

 l Specify the Direction Angle, which is the direction that the sunlight points toward. 0° is measured horizontally on 
screen, pointing to the right. Positive values rotate in a counter-clockwise direction from there, while negative 
values rotate clockwise.

 l Click the Reset to Defaults button to restore the settings set in the Sunlight Defaults dialog in the current view. 

 l In the Sunlight Defaults dialog, the Restore Initial Settings button is available instead. Click this to reset the 
options in that dialog to the originally installed settings.

 
Use Sun Angle

Select Use Sun Angle to represent the sun using a light source defined by a Sun Angle . See Sun Angles and Shadows on 

page 1140.    

 l Select a Sun Angle from the drop-down list to serve as the source of sunlight in the currently active 3D view. If no 
Sun Angle is present, the Generic Sun is used.

 l Click the Edit button to open the Sun Angle Specification dialog for the selected Sun Angle. 
By default, the Generic Sun light color is pure white, which has the least effect on the appearance of material colors and 
textures. See Materials on page 1050.
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Rendering Techniques
Any camera view, cross section/elevation view, or overview can be generated using a variety of Rendering 
Techniques to produce views for a range of different purposes: from detail drawings to artistic presentation views. To 

access these tools, while a 3D view is active, select 3D> Rendering Techniques, then select one of the following 
techniques: 

There are two ways to create a view using a particular Rendering Technique:         

 l Create a 3D view, then select the desired rendering technique from the menu.              
 l Select the desired rendering technique in the Camera Defaults dialog, then create a 3D view. See Camera Defaults 

Dialogs on page 1082.             

Once a view is created, the effects of the selected rendering technique can be adjusted in the Rendering Technique Options 
dialog. See Rendering Technique Options on page 1150.          

If a camera view is saved, its Rendering Technique settings are saved, as well. See Saving and Printing 3D Views on page 
1114.          

You can specify which Rendering Techniques use a backdrop image. See 3D Backdrops on page 1201.         

The Watercolor and Line Drawing techniques require more time 
to generate than other Rendering Techniques. To save time, 

adjust the camera’s perspective before using one of these techniques. See 
Editing 3D Views on page 1105.

STANDARD RENDERING

Standard rendering is a photo-realistic technique that represents materials using textures, models lighting and 
shadows, and can also display reflections. Surface edge lines are not drawn and no special colors or effects are 

applied; however, when Line Drawing on Top is enabled, pattern lines are used.

In plan view, the camera symbol for a view using the Standard technique displays an S in its center. See Displaying 3D 
Views on page 1096.

VECTOR VIEW

In Vector Views, surface edge lines are drawn and pattern lines and colors are used to represent materials while 
textures are not. Shadows are supported, and when in use a single light source is used to produce them. Shading 

Contrast can be applied to surfaces, but other special colors or effects are not.             
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In plan view, the camera symbol for a view using the Vector View technique displays a V in its center.         

PHYSICALLY BASED (RAY TRACE)

Physically Based rendering is similar to the photo-realistic Standard technique: it represents materials using textures, 
does not draw surface edge lines, models lighting, and can display shadows. When Line Drawing on Top is enabled, 

pattern lines are also used.

Physically Based rendering models material properties and light propagation more accurately than other rendering 
techniques and is best used when a focus on lighting and finish materials is the goal. On systems that support it, real-time 
GPU Ray Tracing is performed in Physically Based renderings. See GPU Ray Tracing on page 1130.

In plan view, the camera symbol for a view using the Physically Based technique displays a Ph in its center.

CLAY

Clay renderings emphasize the shapes and proportions of objects in the model rather than the materials on their 
surfaces.  Surfaces are rendered using a single solid color or a palette of colors of your choosing, and Ambient 

Occlusion and Metal maps are included for any materials that have them. When Line Drawing on Top is enabled, pattern 
lines are also used. Lighting and shadows are modeled, and on systems that support it, real-time GPU Ray Tracing is an 
option. See GPU Ray Tracing on page 1130.

In plan view, the camera symbol for a view using the Clay technique displays an C in its center. 

GLASS HOUSE

Glass House rendering uses different shades of a single color to display the model with surface edge lines and semi-
transparent surfaces. Lighting and shadows are not modeled, and materials are not represented, so neither pattern lines 
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nor textures are used. 

In plan view, the camera symbol for a view using the Glass House technique displays a G in its center.

TECHNICAL ILLUSTRATION

Technical Illustration rendering draws surface edge and pattern lines, and uses shades of two colors, Warm and Cool. 
The warm shade is applied to surfaces that face the light source in the view, and the cool shade, to surfaces that face 

away from it.

Only one light source is used: the light with the highest Intensity found in the room containing the camera. In exterior 
views, this light is always the Generic Sun. If no lights are on, a fallback light is used. Lighting is modeled as non-
photorealistic, stylized highlights and shadows are supported. See Lighting on page 1133.         

In plan view, the camera symbol for a view using the Technical Illustration technique displays a T in its center.         

WATERCOLOR

Watercolor rendering approximates the effects of watercolor painting such as pigment pooling and flow. It uses 
textures to represent materials and models lighting, shadows, and reflections. When Line Drawing on Top is enabled, 

pattern lines are also used.

In plan view, the camera symbol for a view using the Watercolor technique displays a W in its center.         

LINE DRAWING

In a Line Drawing rendering, surface edges are represented by lines with a hand-drawn style. Surfaces are completely 
opaque and patterns are used, but textures, lighting, and shadows are not.         
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In plan view, the camera symbol for a view using the Line Drawing technique displays an L in its center. 

Note: In some plans, the Watercolor and Line Drawing techniques may 
take a considerable amount of time. You can press the Esc key to cancel 
the rendering.

DUOTONE

Duotone rendering represents materials using textures and models lighting, shadows, and reflections. Surface edge 
lines are not drawn; however, when Line Drawing on Top is enabled, pattern lines are used. Two colors, one Light 

and one Dark, are applied over the surfaces, allowing you to create special effects such as sepia tone or grayscale.

In plan view, the camera symbol for a view using the Duotone technique displays a D in its center.

 

Rendering Technique Options
The settings in the Rendering Technique Options dialog allow you to control the specific effects of each rendering 
technique on an active 3D view. To access this dialog, create a camera view, cross section/elevation view, or 

overview and select 3D> Rendering Techniques> Technique Options.

The Rendering Technique Options dialog can also be accessed by double-clicking the Rendering Techniques  parent 

button.     

The settings in the Rendering Technique Defaults dialog are the same as those in this dialog, but control the initial settings 
of each technique when it is first applied.     

In the Rendering Technique Options dialog, select a technique from the list on the left to make its options active on the 
right. When this dialog is first opened, the technique currently used by the view is selected. 

As changes are made in the Rendering Technique Options dialog, the 3D view automatically updates to reflect those 
changes for all techniques except Watercolor, Line Drawing, and Physically Based using real-time Ray Tracing. To update 
views using these techniques, which take more time to draw than the others, click the Update button in the dialog. 

When a 3D view is saved, its Rendering Technique Options settings are saved, as well. See Saving 3D Views on page 1114.   

The Rendering Technique Options dialog has the following panels:
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STANDARD PANEL

The active 3D view immediately updates to reflect any changes made to the Rendering Technique Options for 
Standard renderings. 

There are a variety of other tools that affect the appearance of Standard rendered views, as well. See Displaying 3D Views 
on page 1096. 

  General

 l Check Opaque Window Glass to make the glass in windows and exterior doors opaque. When unchecked, door and 
window glass is transparent. See Material Transparency on page 1132.      

 l When Use Backdrop Image When Available is checked, the backdrop image specified for this view is used. When 
unchecked or if no backdrop image is specified for the current view, the specified Backdrop Color is used instead. 
See 3D Backdrops on page 1201.

 
Ambient Light

Specify the amount of Ambient light to use in different situations in Standard, Watercolor, and Duotone renderings. See 
Ambient Lighting and Occlusion on page 1134.

 l Interior Ambient affects interior views.    

 l Daytime Ambient affects exterior views.

 l Nighttime Ambient affects nighttime exterior views.
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Line Drawing on Top

Add lines with a hand-drawn style along surface edges in the current view. Material patterns are also represented. See 
Patterns and Textures on page 1051.    

 l Check Line Drawing on Top to enable the settings that follow.     

 l These settings are also found on the LINE DRAWING panel. See Line Drawing Panel on page 1160.

  Reset

 l Click Reset to Defaults to apply the Standard settings defined in the Rendering Technique Defaults dialog.     

 l In the Rendering Technique Defaults dialog, the Restore Initial Settings button is available instead. Click this to 
reset the options on this panel to the system defaults.

VECTOR VIEW PANEL

The active 3D view immediately updates to reflect any changes made to the Rendering Technique Options for Vector 
Views.   

Additional settings that affect the appearance of Vector Views can be found in the 3D View Defaults dialog. See 3D View 
Defaults Dialog on page 1084.    

There are a variety of other tools that affect the appearance of Vector Views. See Displaying 3D Views on page 1096.    

 l Check Use Backdrop Image When Available to use the backdrop image specified for this view. When unchecked or 
if no backdrop image is specified for the current view, the specified Backdrop Color is used instead.

 l Specify the Shadow Intensity, which is how dark or light shadows appear. A value of 100% creates shadows that hide 
any objects located within them; a value of 0% effectively produces no shadows.    

 l Check Apply Shading Contrast to use different levels of shading on surfaces oriented at different angles to the 
camera. When unchecked, unmodified material Colors are shown on all surfaces. Each material’s Shading Contrast can 
be set individually. See Pattern Panel on page 1067.

 l Check Opaque Window Glass to make the glass in windows and exterior doors opaque. When unchecked, door and 
window glass is transparent. See Material Transparency on page 1132.      

 l Click Reset to Defaults to apply the Vector View settings defined in the Rendering Technique Defaults dialog.     
 l In the Rendering Technique Defaults dialog, the Restore Initial Settings button is available instead. Click this to 

reset the options on this panel to the system defaults.
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PHYSICALLY BASED (RAY TRACE) PANEL

The active 3D view immediately updates to reflect any changes made to the Rendering Technique Options for 
Physically Based renderings.    

There are a variety of other tools that affect the appearance of Physically Based rendered views, as well. See Rendering Tips 
on page 1130.    

  General

 l Specify the Camera Exposure, which is the amount of light in the scene that is captured by the camera. A low value 
produces a darker view; too high a value can make the scene look washed out.       

 l When Use Backdrop Image When Available is checked, the backdrop image specified for this view is used. When 
unchecked or if no backdrop image is specified for the current view, the specified Backdrop Color is used instead.
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  Global Illumination

 l When Use Ray Tracing is active and checked, multiple samples of indirect lighting in the scene are created, 
improving the lighting quality with each sample. This setting and those below it will not be active if real-time GPU 
Ray Tracing is not supported on the system. See GPU Ray Tracing on page 1130.

 l When Refraction is active and checked, light will bend when passing through a Transparent material.

 l Specify the Maximum Export Samples, which is how many samples to run for a view that you wish to export as a 
picture or send to layout.

 l When Cap Live Samples is unchecked, a GPU Ray Traced view will run samples indefinitely. Check this box to 
instead stop running samples when the Maximum Export Samples value is reached.

 l Specify the Daytime Background Intensity, which is the brightness of the view's background color or backdrop 
image when the Sunlight is toggled on. See Backdrop Panel on page 1121. 

 l Specify the Nighttime Background Intensity, which is the background brightness when the Sunlight is toggled off. 
See Generic Sunlight on page 1134.

 
Color Adjustment

You can adjust the Hue, Saturation, and Brightness of the view, if needed.     

 
Line Drawing on Top

Add lines with a hand-drawn style along surface edges in the current view. Material patterns are also represented. See 
Patterns and Textures on page 1051.      

 l Check Line Drawing on Top to enable the settings that follow.      

 l These settings are also found on the LINE DRAWING panel. See Line Drawing Panel on page 1160.

  Reset

 l Click Reset to Defaults to apply the Physically Based settings defined in the Rendering Technique Defaults dialog.     

 l In the Rendering Technique Defaults dialog, the Restore Initial Settings button is available instead. Click this to 
reset the options on this panel to the system defaults.     

CLAY PANEL

The active 3D view immediately updates to reflect any changes made to the Rendering Technique Options for Clay 
renderings.    
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  General

 l Specify the Camera Exposure, which is the amount of light in the scene that is captured by the camera. A low value 
produces a darker view; too high a value can make the scene look washed out.

 l Check Opaque Window Glass to make the glass in windows and exterior doors opaque. When unchecked, door and 
window glass is transparent. See Material Transparency on page 1132.

 l When Use Backdrop Image When Available is checked, the backdrop image specified for this view is used. When 
unchecked or if no backdrop image is specified for the current view, the specified Backdrop Color is used instead.
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Color

 Specify the solid color or colors applied to object surfaces in the view.     

 l Select Use Layer Color to apply the colors assigned to layers in the current Layer Set to objects on those layers. See 
Line and Text Styles on page 182.     

 l Select Use Material Color to apply the Material Color associated with each material applied to the surfaces in the 
view. See Pattern Panel on page 1067.     

 l Select Use Solid Color to apply the color displayed in the Color bar to all surfaces in the view. Click the Color bar 
to choose a new color. See Color Chooser/Select Color Dialog on page 204.     

 l You can adjust the Hue, Saturation, and Brightness of the view, if needed.

 
Material

 Most material properties are represented in Clay renderings but you can choose to suppress or override some of them if you 
wish. See Properties Panel on page 1073.     

 l Check Ignore Material Bump/Normal Map to ignore the Bump and/or Normal Maps assigned to materials in the 
view.     

 l Check Ignore Material Metalness to ignore the Metallic property or Metal Map assigned to materials in the view.     

 l Check Ignore Ambient Occlusion Map to ignore the Ambient Occlusion Maps assigned to materials in the view.     

 l Check Override Material Roughness to ignore the Roughness setting of materials assigned to any surfaces in the 
view and instead us a single Roughness value.     

 l Specify the Roughness of all surfaces in the current view.

 
Lights

The lights in the current Light Set are used in Clay renderings. See Lighting on page 1133.

 l When Override Light Colors is unchecked, the colors assigned to individual light sources in the view are used. 
Check this to specify a single color for all lights in the view.

 l When Override Light Colors is checked, click the Color bar to specify the light color used by all lights in the view. 

 
Global Illumination

These settings are also found on the PHYSICALLY BASED panel. 

 
Line Drawing on Top

Add lines with a hand-drawn style along surface edges in the current view. Material patterns are also represented. See 
Patterns and Textures on page 1051.      

 l Check Line Drawing on Top to enable the settings that follow.      

 l These settings are also found on the LINE DRAWING panel. See Line Drawing Panel on page 1160.

  Reset

 l Click Reset to Defaults to apply the Clay settings defined in the Rendering Technique Defaults dialog.      

 l In the Rendering Technique Defaults dialog, the Restore Initial Settings button is available instead. Click this to 
reset the options on this panel to the system defaults. 
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GLASS HOUSE PANEL

The active 3D view immediately updates to reflect any changes made to the Rendering Technique Options settings 
for Glass House renderings. 

 l When Use Backdrop Image When Available is checked, the backdrop image specified for this view is used. When 
unchecked or if no backdrop image is specified for the current view, the specified Backdrop Color is used instead. See 
3D Backdrops on page 1201.

 l Click the Color bar to select a color for the semi-transparent surfaces and lines in a Glass House view. See Color 
Chooser/Select Color Dialog on page 204.    

 l Specify the Transparency of the surfaces in Glass House view. For example, to create a wireframe line drawing of 
your structure, turn transparency to full and minimize line thickness.    

 l Specify the Line Thickness of surface lines in Glass House view.    
 l Click Reset to Defaults to apply the Glass House settings defined in the Rendering Technique Defaults dialog.             

 o In the Rendering Technique Defaults dialog, the Restore Initial Settings button is available instead. Click this to 
reset the options on this panel to the system defaults.

TECHNICAL ILLUSTRATION PANEL

The active 3D view immediately updates to reflect any changes made to the Rendering Technique Options settings 
for Technical Illustration renderings.    
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  General

 l Check Opaque Window Glass to make the glass in windows and exterior doors opaque. When unchecked, door and 
window glass is transparent. See Material Transparency on page 1132.      

 l When Use Backdrop Image When Available is checked, the backdrop image specified for this view is used. When 
unchecked or if no backdrop image is specified for the current view, the specified Backdrop Color is used instead. 
See 3D Backdrops on page 1201.

  Effects

 l Click the Color bar to select a Warm Color for surfaces that face the light source and a Cool Color for surfaces 
that face away from the light. See Color Chooser/Select Color Dialog on page 204.     

 l Specify the Warm Blend, which is the degree to which the selected Warm Color is blended with original colors on 
well-lit surfaces in the view.      

 l Specify the Cool Blend, which is the degree to which the selected Cool Color is blended with original colors on 
shaded surfaces in the view.      

 l Specify the Line Thickness of all surface edge and pattern lines in the view. Surface Edge Line color in Technical 
Illustrations can be set by layer in the Layer Display Options dialog when Use Layer Settings is selected in the 3D 
View Defaults dialog. Some objects' Surface Edge Line color can also be set per object. See 3D View Defaults 
Dialog on page 1084.     

 l Specify the Shadow Intensity, which is how dark shadows. A value of 0% produces no shadows. See Shadows on 
page 1130.     

  Reset

 l Click Reset to Defaults to apply the Technical Illustration settings defined in the Rendering Technique Defaults 
dialog.     

 l In the Rendering Technique Defaults dialog, the Restore Initial Settings button is available instead. Click this to 
reset the options on this panel to the system defaults.

WATERCOLOR PANEL

In order for the active 3D view to reflect changes made to the Rendering Technique Options settings for Watercolor 
renderings, you must click either the OK button or the Update View button in the dialog. This may take several 

moments.    
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  General

 l Check Opaque Window Glass to make the glass in windows and exterior doors opaque. When unchecked, door and 
window glass is transparent. See Material Transparency on page 1132.        

 l When Use Backdrop Image When Available is checked, the backdrop image specified for this view is used. When 
unchecked or if no backdrop image is specified for the current view, the specified Backdrop Color is used instead.

  Effects

 l Specify the Smooth Amount, which is the degree to which details are removed from the original view.     

 l Specify the Paint Contrast, which determines the extent to which variations in pigment color are used.      

 l Specify the Turbulence Strength, which produces “pooling”, or variations in the strength of pigment colors.     

 l Specify the Turbulence Scale, which controls the size of the areas of pooling.     

 l Specify the Pigment Settling Strength, which is creates the appearance of pigment settling into low areas in paper.     

 l Specify the Edge Strength, which is how well-defined surface edge lines are.     

 
Line Drawing on Top

Add lines with a hand-drawn style along surface edges in the current view. Material patterns are also represented. See 
Patterns and Textures on page 1051.      

 l Check Line Drawing on Top to enable the settings that follow.      

 l These settings are also found on the LINE DRAWING panel. See Line Drawing Panel on page 1160.
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  Reset

 l Click Reset to Defaults to apply the Watercolor settings defined in the Rendering Technique Defaults dialog.     

 l In the Rendering Technique Defaults dialog, the Restore Initial Settings button is available instead. Click this to 
reset the options on this panel to the system defaults.     

 l Views using the Watercolor technique do not update as changes are made to the settings here as they do with most 
Rendering Techniques. Click Update View to apply any changes to these settings to the current view.

LINE DRAWING PANEL

Lines with a hand-drawn appearance can also be drawn in the Standard, Physically Based, Clay, Watercolor, and 
Duotone Rendering Techniques.    

  General

 l Check Opaque Window Glass to make the glass in windows and exterior doors opaque. When unchecked, door and 
window glass is transparent. See Material Transparency on page 1132.       

 l When Use Backdrop Image When Available is checked, the backdrop image specified for this view is used. When 
unchecked or if no backdrop image is specified for the current view, the specified Backdrop Color is used instead.

  Effects

 l Click the Color bar to select the color of the lines used to draw the view.      

 l Specify the Thickness of the lines, in pixels.      

 l Specify the Extend Amount, which is the distance that lines may extend past intersecting surface edges.     

 l Specify the Squiggle Amplitude, which controls the average amount of curvature in the lines’ squiggles. A value of 
0 produces straight lines.      

 l Specify the Squiggle Frequency, which controls how often the lines have curves. A value of 0 produces straight 
lines.
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  Reset

 l Click Reset to Defaults to apply the Line Drawing settings defined in the Rendering Technique Defaults dialog.                  

 l In the Rendering Technique Defaults dialog, the Restore Initial Settings button is available instead. Click this to 
reset the options on this panel to the system defaults.

DUOTONE PANEL

The active 3D view immediately updates to reflect any changes made to the Rendering Technique Options settings 
for Duotone renderings.    

  General

 l Check Opaque Window Glass to make the glass in windows and exterior doors opaque. When unchecked, door and 
window glass is transparent. See Material Transparency on page 1132.       

 l When Use Backdrop Image When Available is checked, the backdrop image specified for this view is used. When 
unchecked or if no backdrop image is specified for the current view, the specified Backdrop Color is used instead. 
See 3D Backdrops on page 1201.

  Color

 l Click the Color bars to select a Light Color and Dark Color for surfaces and lines in a Duotone view. See Color 
Chooser/Select Color Dialog on page 204.

 l Specify the Desaturation, which is the degree to which color is removed from the original image. A value of 0% 
retains the original colors in the view while a 100% results in a grayscale image.     

 l Specify the Tone, which is the extent to which the Light and Dark Colors cover the original colors in the view. A 
value of 100% completely obscures the view’s original colors as well as the effects of Desaturation.      

1161



Chief Architect Premier X14 Reference Manual - Rendering Technique Options

 
Line Drawing on Top

Add lines with a hand-drawn style along surface edges in the current view. Material patterns are also represented. See 
Patterns and Textures on page 1051.      

 l Check Line Drawing on Top to enable the settings that follow.      

 l These settings are also found on the LINE DRAWING panel. See Line Drawing Panel on page 1160.

  Reset

 l Click Reset to Defaults to apply the Duotone settings defined in the Rendering Technique Defaults dialog.      

 l In the Rendering Technique Defaults dialog, the Restore Initial Settings button is available instead. Click this to 
reset the options on this panel to the system defaults.      
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Chapter 34
 

CPU Ray Tracing

As the name implies, ray tracing calculates the rays of light in a view as they travel through the 3D model and reflect off 
surfaces. It can be used to achieve much more complex lighting effects than regular 3D rendering; however, it is also more 
demanding of your system's resources. There are two types of ray tracing in Chief Architect: GPU and CPU Ray Tracing. 

GPU Ray Tracing is produced in real time using the graphics card but is only supported by some newer cards on PCs 
running Windows 10. See GPU Ray Tracing on page 1130.

CPU Ray Tracing uses the system's processor, or CPU, and can be run on any system that meets Chief Architect's system 
requirements. It supports queuing of multiple jobs, can be run for extended periods of time, and runs in its own process so 
you can continue to work in Chief Architect while it runs.

TOPICS

CPU Ray Trace Views 1164
CPU Ray Trace Configurations 1165
CPU Ray Trace Options 1167
CPU Ray Trace Assistant 1172
Adjusting Ray Trace Properties and Effects 1175
CPU Ray Tracing Tips 1176
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CPU Ray Trace Views
CPU ray trace views are generated in their own view window and are static images of the model - not dynamic. That 
is, if you make changes to the 3D model, any previously created ray trace views will not be affected. In contrast, see 

GPU Ray Tracing on page 1130.

To create a CPU ray trace
 1.  Create a 3D camera view or overview.

 l The Standard or Physically-Based Rendering Technique must be used. See Rendering Techniques on page 1147.

 l Perspective views are preferable to Orthographic views for ray tracing because they are more realistic to the human 
eye. See Perspective and Orthographic Views on page 1081. 

 l The Hide Camera-Facing Exterior Walls  setting must be toggled off. See Hide Camera-Facing Exterior 

Walls on page 1132.

 2.  Position the camera as needed. Do not use the Zoom or Pan tools. See Editing 3D Views on page 1105. 

 3.  Adjust the shape of the view window as needed. 

 4.  Select 3D> CPU Ray Trace . 

 5.  In the Ray Trace Current View dialog: 

 l Select a Ray Trace Configuration from the drop-down list and click the Ray Trace button. See CPU Ray Trace 
Current View/CPU Ray Trace Defaults Dialog on page 1166. 

 6.  To pause a ray trace in progress, select File> Pause Ray Trace . 

 l Select File> Resume Ray Trace  to restart a paused ray trace.

Note: If you have ray traces in queue and pause the one in progress, 
the next ray trace will begin running. See Queuing CPU Ray Trace 
Jobs on page 1178.

 7.  A ray trace can be canceled at any time:

 l In the Preparing to Ray Trace progress dialog, click the Cancel button. 

 l Once the CPU ray trace view window is open, you can cancel the process by selecting File> Close or click the 
Close   button. 

 8.  To stop a ray trace in progress without canceling it, select File> Stop Ray Trace . 

 9.  When the ray trace is completed, save the resulting image for future use: 

 l Select File> Print Image  to print the image. See Print Image Dialog on page 1388. 

 l Select File> Export Picture  to save the image in any of several file formats including .jpg, .bmp, and .png. See 

Exporting Pictures on page 1187. 
 l Select File> Send to Layout  to send the ray trace view to a layout page. See Sending Views to Layout on page 

1343. 
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 l Select File> Export 360 Panoramic Ray Trace to Cloud  to export a completed panoramic ray trace to your 

Chief Architect cloud account. See Export 360 Panorama on page 1245.

PROGRESSIVE CPU RAY TRACING

Chief Architect’s CPU ray tracer begins by generating a low-quality preview of the model based on the current Ray Trace 
Configuration’s settings. Once the initial ray trace is complete, the ray tracer performs additional passes to incrementally 
refine the view’s lighting quality and effects. 

If Save Image to File is checked in the CPU Ray Trace Options dialog, the program will save the ray trace as an image file 
and will update the file after every pass of the ray tracer. See General Panel on page 1167. 

You can specify how long these additional passes are performed in the CPU Ray Trace Options dialog, and can stop a ray 
trace in progress whenever it meets your needs by selecting File> Stop Ray Trace . See General Panel on page 1167.

THE CPU RAY TRACE WINDOW

The tab of a CPU Ray Trace view window states the names of the plan file and of the camera the CPU Ray Trace is derived 
from. While a ray trace view is generating, you can switch to a different view and perform other tasks. See Working in 
Multiple Views on page 154. 

When the CPU Ray Trace view window is active, the image will regularly update as the ray trace progresses and its status 
will display in the Status Bar. When it is finished, the number of passes and  cumulative time, including pre-processing time, 
will display there. See The Status Bar on page 25. 

You can specify whether your computer’s processor allocates more resources for the CPU ray trace or for working in the 
program in the Preferences dialog. See Ray Trace Panel on page 130. 

If you have specified an image size larger than your monitor and saved the results as an image file, you may only see one 
corner of the total view. You can, however, use the scrollbars and/or Zoom In  or Zoom Out . See Zoom Tools on 

page 157.

 

CPU Ray Trace Configurations
CPU Ray Trace views are generated based on settings that control lighting properties as well as the size of the final 
image. Two configurations are included in the installed template plans: Default Interior Ray Trace and Default 

Exterior Ray Trace.

You can save multiple CPU Ray Trace configurations for different purposes and then select the one best suited to the view 
you want to ray trace.  See Multiple Saved Defaults on page 79. 

To access the CPU Ray Trace configurations saved in the current plan, select Edit> Default Settings . Click the + 

beside “3D View Defaults”, then select “CPU Ray Trace” and click the Edit button to open the CPU Ray Trace Defaults 
dialog. See Default Settings on page 76. 

You can also access the available CPU Ray Trace configurations by selecting 3D> CPU Ray Trace  while a 3D camera 

view or overview is active. The CPU Ray Trace Current View dialog will open.
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CPU RAY TRACE CURRENT VIEW/CPU RAY TRACE DEFAULTS DIALOG

  Current Configuration

 l Select the name of the Current Configuration from the drop-down list. A Summary of the selected configuration’s 
settings displays in the bottom portion of the dialog box.

 l Click the Launch Assistant button to launch the CPU Ray Trace Assistant. See CPU Ray Trace Assistant on page 
1172. 

 l Click the Copy button to create a copy of the Current Configuration.

 l Click the Edit button to open the CPU Ray Trace Options dialog, where you can make changes to the selected 
Current Configuration. See CPU Ray Trace Options on page 1167. 

 l Click the Delete button to permanently remove the Current Configuration from the plan. Not available if there is 
only one configuration in the list.

 
Summary

Information about the currently selected configuration is reported here.

 

 l If the CPU Ray Trace Current View dialog was accessed via the Ray Trace  tool, click the Ray Trace button to 

begin ray tracing the active 3D view using the Current Configuration and retain any new configurations or changes 
made to existing configurations.

 l If the CPU Ray Trace Current View dialog was accessed via the Ray Trace  tool, click the Save and Close 

button to close the dialog without ray tracing the current view. Any new configurations or changes that you may 
have made to existing configurations are retained. 

 l If the CPU Ray Trace Defaults dialog was accessed via Default Settings , click OK to close the dialog and save 

any newly created or renamed configurations.

 l Click the Cancel button to close the dialog without saving any changes. Any renamed or newly created 
configurations will not be retained. 
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You can add your preferred CPU Ray Trace configurations to 
your template plan. See Template Files on page 87.

 

CPU Ray Trace Options
The CPU Ray Trace Options dialog can be opened in either of two ways: 

 l In any view, select Edit> Default Settings  and expand the “3D View Defaults” category. See Default Settings on 

page 76. 
 l In a Standard or Physically Based rendered view, select 3D> CPU Ray Trace . 

In either case, you will first need to select the current ray trace configuration in the CPU Ray Trace Configurations/CPU 
Ray Trace Current View dialog. See CPU Ray Trace Current View/CPU Ray Trace Defaults Dialog on page 1166. 

When the CPU Ray Trace Options dialog opens, the Current Configuration specified in the CPU Ray Trace Current View 
dialog is active. See CPU Ray Trace Configurations on page 1165.

The CPU Ray Trace Options dialog has the following panels: 

GENERAL PANEL

 
Configuration Name

Specify the name of the current Ray Trace Configuration. Names must be unique.
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  Save Image to File

 l Check Save Image to File, then click the Browse button to save the ray trace image directly to a .jpg, .bmp, .png, 
or .png file after every pass of the progressive ray tracer.

 l If a file has been specified, its pathname will display to the right of the Choose button. 

If the specified file already exists, the program will ask if you to wish to overwrite the existing file or choose a new 
name and/or location when you start a ray trace. 

 
Image

Specify size and other characteristics of the ray trace image.    

 l Check Generate as 360° Panorama to create a spherical image that can be viewed in a variety of other applications. 
See Export 360 Panorama on page 1245.    

 l Check Use Active Window Size to save the ray trace image at the same size as the ray trace view window. The 
Width and Height of the currently active view window are stated below: if these values are changed, this box 
becomes unchecked automatically.    

 l Specify whether the ray trace image’s Width/Height Dimensions are measured using Pixels or drawing Units 
(inches or mm).    

 l Specify the Width and Height of the ray trace image in either Pixels or Units.    

 l Specify the Resolution of the ray trace image, in either Pixels/Inch or Pixels/mm. 

 l Check Limit Dimensions to Powers of Two to restrict the Width and Height to values that are powers of two. 
When this is checked and an ineligible value is entered, it will adjust up or down to the nearest power of two. This 
option recommended when Generate as 360° Panorama is checked, above.     

 l Check Retain Aspect Ratio to maintain the width to height ratio of the original image and prevent the ray trace 
from being stretched or distorted. This option cannot be unchecked when Generate as 360° Panorama is checked, 
above.

 
Time to Ray Trace

How long a ray trace runs influences its final quality. See Progressive CPU Ray Tracing on page 1165.     

 l Select No Limit to run the ray tracer until you select File> Stop Ray Trace .    

 l Select a Time to ray trace from the drop-down list. The ray tracer will complete as many passes as possible during 
this time.    

 l Specify a Number of Passes. The ray tracer will run as long as needed to complete this number of passes.    

 l You can stop any ray trace at any time by selecting File> Stop Ray Trace .

LIGHTING PANEL

The settings on the LIGHTING panel control the appearance of light in a CPU ray trace scene that isn’t associated with a 
particular light source. See Lighting on page 1133. 
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Ambient Light

Control the appearance of the light present throughout a scene that does not come from a particular source. Ambient light 
exists everywhere, including shadowed areas. See Ambient Lighting and Occlusion on page 1134.    

 l Uncheck Use Automatic Settings to enable the Color bar and specify the color of the ambient light. See Color 
Chooser/Select Color Dialog on page 204.    

 l When Use Automatic Settings is checked, the ambient light is grey in color and its brightness is based on the 
ambient light settings in the Rendering Technique Options dialog. Low ambient values result in darker grey; higher 
values result in lighter grey. See Standard Panel on page 1151.    

 l Select Uniform Intensity to enable the Intensity setting below, then specify the strength of the ambient light 
throughout the scene either by typing a decimal value in the text field or by clicking the up and down arrows. Values 
between 0 and 10 can be used.    

 l Select Use Ambient Occlusion to enable the Minimum and Maximum Intensity settings below. Ambient 
Occlusion allows variation in the strength of the Ambient Light and is more realistic than Uniform Intensity, but 
takes longer to ray trace.    

 l Specify the Minimum Intensity, which is the strength of the ambient light on surfaces with minimum exposure to it.
    

 l Specify the Maximum Intensity, which is the strength of the ambient light on surfaces fully exposed to it. 
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  Direct Sunlight

 l Specify the Intensity of the sunlight throughout the scene either by typing a decimal value in the text field or by 
clicking the up and down arrows. Values between 0 and 10 can be used. 

 
Enable Environment Light

Specify the appearance of atmospheric lighting in exterior views.     

 l Check Enable Environment Light to enable the settings below. When checked, exterior scenes are lit using an 
encompassing sphere of light, which simulates how light bounces around within the atmosphere. When unchecked, 
only the Generic Sun is used. See Generic Sunlight on page 1134. 

 l Specify the Intensity value, which is the strength of the Environmental Light.    

 l Click the Use Sky radio button to use the Generated Sky as a basis for the Environmental Light’s color. See 3D 
Backdrops on page 1099.    

 l Click the Use Color radio button, then click the Color bar to specify the color of the outdoor Environmental Light.    

 l Click the Use Backdrop Image radio button, then browse to select an image to use as a basis for the Environmental 
Light’s color. The image is wrapped around the scene’s encompassing sphere and influences the color of the 
Environmental Light, but does not actually appear in the ray trace view.

 l Click the Select button to select a different image.    

 l Click the Remove button to remove the currently selected image and use a color instead.

 
Light Sources

Control which Added Lights and light sources associated with fixtures are used in the ray trace view. See Light Types on 
page 1135.    

 l Select Use Lighting of Active Camera to use the same lighting in the ray trace as in the original camera view. See 
Camera Panel on page 1116.    

 l Select Light Set, then choose a Light Set to use in the ray trace from the drop-down list. See Light Sets on page 
1136.    

 l When Light Set is selected, you can click the Adjust Lights button to open the Adjust Lights dialog.

ADVANCED PANEL

The settings on the ADVANCED panel allow you to specify lighting quality and focal blur.
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  Global Illumination

 l Check Use Photon Mapping to accurately calculate bounced lighting in a scene. When unchecked, ray traces have 
low quality lighting effects but generate more quickly. Use Photon Mapping should be checked for all interior scenes 
and unchecked for most exterior scenes.

In order for Photon Mapping to function, at least two 
different objects must be present in the model. If there are 

too few surfaces, a ray trace with Photon Mapping cannot run.       

 l Check Compute Caustics, to use caustic photons, which are photons used in areas of focused light. Caustic photons 
are helpful when modeling certain effects such as light shining through glass.

  Enable Focal Blur

 l Check Enable Focal Blur to enable the F-Number setting below and set the amount of focal blur that occurs outside 
the camera’s focal range. 

 l Specify the F-Number value, which defines the camera focal blur and is the like the f-stop in photography. Decrease 
this value for more focal blur or increase it for less blur. 

 l Focal blur cannot be produced if the camera’s focal point is located within the Clip Surfaces Within distance set in 
its specification dialog. See Camera Panel on page 1116.  

IMAGE PROPERTIES PANEL

The settings on the IMAGE PROPERTIES panel allow you to customize the properties of colors in Ray Trace views. Once a 
Ray Trace has been started, these settings can be modified. See Adjusting Ray Trace Properties and Effects on page 1175. 
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Use Tone Mapping

Chief Architect’s CPU ray tracer works with a color range greater than what your monitor or printer can display. When Use 
Tone Mapping is checked, these colors are intelligently mapped to a displayable range. Uncheck this box to simplify how 
the colors are converted and disable the settings below.         

 l Uncheck Auto Contrast to enable the Contrast setting below. When checked, the program chooses a Contrast value 
based on the image’s properties. 

 l Specify the Contrast, which is the relative difference between light and dark colors in the view, using the slider bar 
or by typing in the text field 

 l Specify the Intensity, or brightness, of the image. This value not necessarily uniform throughout the view and is 
similar to a camera’s exposure setting.

 l Specify the Softness, which determines whether color intensity is based on pixel or overall image intensity. 

 l Specify the Color Correction, which is the extent to which strong color casts are removed from the image. 

It’s not unusual for ray traced images to initially be too dark or 
too bright. Try adjusting the Tone Mapping Intensity.

  General Properties

 l Specify the Brightness of the image, which controls how dark or light the image is overall. 

 l Specify the Contrast, or relative difference between light and dark colors. This setting is similar to the setting of the 
same name, above, but is not as fine a control because it takes place after tone mapping has been done. 

 l Specify the Saturation, which is the intensity of colors in the view. 
Don’t be afraid to over-saturate your image slightly in very bright scenes – this is a common occurrence in actual 
photographs.
If you are ray tracing an interior scene where the primary source of light is the sun through a window or door, you may 
need to adjust your image brightness. 

 
Reset to Defaults

Click this button to restore the settings in this dialog to their initial, installed values.

 

CPU Ray Trace Assistant
The CPU Ray Trace Assistant is an easy way to set up new CPU ray trace configurations. It can be accessed by clicking the 
Create New button in the CPU Ray Trace Current View/CPU Ray Trace Defaults dialog. See CPU Ray Trace Current 
View/CPU Ray Trace Defaults Dialog on page 1166. 

The choices in the Ray Trace Assistant correspond to settings in the CPU Ray Trace Options dialog. See CPU Ray Trace 
Options on page 1167.
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WELCOME

Select Indoor or Outdoor for a ray trace with lighting effects suitable for the type of view. 

IMAGE SIZE

Specify the size of the final ray trace image. The options here correspond to the Image Size settings in the CPU Ray Trace 
Options dialog. See General Panel on page 1167. 

 l Check Use Active Window Size to set the ray trace to the current size of the active 3D view window. When this is 
checked, the other settings on this panel are disabled.

 l Check Retain Aspect Ratio to maintain the width to height ratio of the original image and prevent the ray trace from 
being stretched or distorted. 

 l Specify the Dimensions used to measure the Width and Height of the ray trace image: either Pixels or drawing Units. 
 l Specify the Width and Height of the ray trace image, in either Pixels or Units. 
 l Specify the Resolution of the ray trace image, in either Pixels/Inch or Pixels/mm. 
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 l Check Limit Dimensions to Powers of Two to restrict the Width and Height to values that are powers of two. When 
this is checked and an ineligible value is entered, it will adjust up or down to the nearest power of two. This option is 
recommended if you are likely to use the Generate as 360° Panorama. See Export 360 Panorama on page 1245.

ENVIRONMENT LIGHTING

The ENVIRONMENT LIGHTING panel is only available when Exterior is selected on the Welcome page. Specify the 
atmospheric conditions of the exterior view you would like to ray trace. The options here correspond to the Outdoor 
Render Settings in the Ray Trace Options dialog. See Lighting Panel on page 1168.

 l Select Sunny for environmental lighting that is white in color. 
 l Select Overcast for environmental lighting that uses a pale gray color. 
 l Select Sunset for environmental lighting that uses a pale orange color. 
 l Select Dark for environmental lighting that uses a dark blue color. 
 l Select Nighttime for environmental lighting that uses a dark blue color with a greater intensity than Dark uses. 

FOCAL BLUR

Specify the amount of focal blur to use in the ray trace. The options here correspond to the F-Number in the Ray Trace 
Options dialog. See Advanced Panel on page 1170.

 l Select No Focal Blur to disable Focal Blur when this option is used. 
 l Select Some Focal Blur to use an F-Number of 5.6. 
 l Select Lots of Focal Blur for to use an F-Number of 2.8. 
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COMPLETING THE ASSISTANT

Specify a Name for the newly created ray trace configuration. This name will be listed in the CPU Ray Trace Current 
View/CPU Ray Trace Defaults dialogs, and can also be changed there. See CPU Ray Trace Current View/CPU Ray Trace 
Defaults Dialog on page 1166.

The initial name created by the program is based on the settings from the Welcome page. If you click the Back button and 
change these settings, this name will adjust as well, provided that you did not change it in any way. 

Click Finish to create the new ray trace configuration and return to either the CPU Ray Trace Current View or Defaults 
dialog, where it will be selected as the Current Configuration. 

In order to retain a newly created CPU Ray Trace configuration, 
you must click the Ray Trace button in the CPU Ray Trace 

Current View dialog. If you click Cancel, the configuration will not be 
saved. 

 

Adjusting Ray Trace Properties and Effects
A number of attributes of a CPU Ray Trace image can be adjusted while the view is being generated or after it is complete. 

If Save Image to File is checked in the CPU Ray Trace Options dialog, the program will automatically save to the specified 
image file if changes are made to it using either the Adjust Image Properties  or Adjust Effects  tools and the ray 

trace view window is closed. See General Panel on page 1167. 

ADJUST IMAGE PROPERTIES

Select File> Adjust Image Properties to open the Image Properties dialog. The settings in this dialog are the same 
as those in the CPU Ray Trace Options dialog, where their initial values are set. See Image Properties Panel on page 

1171.
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ADJUST EFFECTS

Select File> Adjust Effects to open the Adjust Effects dialog. 

 l Check Enable Bloom to enable the settings below. Bloom, or light bloom, can occur around areas of intense 
illumination and looks as though the light is ‘bleeding’ beyond the edges of the light source. 

 l Specify the Radius, which is the width of the bloom area beyond a light source. The higher the Radius setting, the 
longer the bloom calculation will take. 

 l Specify the Weight, which is the intensity or strength of the bloom effect. 
 l Click OK to close the dialog and apply your changes to the view. Depending on your settings, this could take some 

time. A progress indicator will display at the bottom of the window. You can press the Esc key to cancel the bloom 
operation at any time. 

 

CPU Ray Tracing Tips
CPU Ray Tracing gives you the ability to produce high quality, photo-realistic images of your model; however, it is also a 
resource intensive process that can be quite time-consuming. For best results, there are a number of variables to consider.         

CPU RAY TRACE CONFIGURATIONS

A CPU Ray Trace Configuration is a group of CPU Ray Trace Options settings saved in the current plan. You can create 
your own custom configurations for a variety of purposes. See CPU Ray Trace Options on page 1167.

CPU Ray Trace Configurations can be saved in your template plans, saving you the effort of reproducing them for each new 
project. See Template Files on page 87.

CREATING THE CAMERA VIEW

To create a CPU Ray Trace image in Chief Architect, begin by creating a camera view or overview of the model. The 
camera position, field of view, and orientation determine the scene’s appearance in the ray trace window. See Editing 3D 
Views on page 1105. 

In order to run a CPU Ray Trace, either the Standard or Physically-Based Rendering Technique must be active and the Hide 
Camera-Facing Exterior Walls  setting must be toggled off. See Standard Rendering on page 1147 and Hide Camera-

Facing Exterior Walls on page 1132.

CPU Ray Trace views can be created from both Orthographic and Perspective views; however, Perspective views appear 
more realistic to the human eye and are better suited to producing photo-realistic images. See Perspective and Orthographic 
Views on page 1081. 
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LIGHTING

Lighting is an extremely important aspect of high-quality ray trace views. For best results, be prepared to spend some time 
making adjustments to their positions and light data settings and consider adding light sources to your model. See Lighting 
on page 1133.

In CPU ray trace views, all light sources that are turned “On” and have Use in CPU Ray Tracing checked in their 
specification dialog can contribute light to the scene. See Light Data Panel on page 688.

To increase ray tracing speed, the program will identify any lights that do not contribute direct lighting to the scene when a 
CPU ray trace is preprocessing and will remove them from the ray trace lighting calculations.          

You can create your own custom Light Sets for ray tracing and can specify which set to use in the CPU Ray Trace Options 
dialog. See Lighting Panel on page 1168.         

For light sources that cast shadows in a CPU Ray Trace scene, consider using the Soft Shadows option. Soft Shadows 
requires more ray tracing time, but smooths the appearance of shadows created by a light, improving their appearance. See 
Light Data Panel on page 688.

Most other rendering settings, including those in the Preferences dialog, are not used for generating a CPU ray trace view, 
although Ambient Light, set in the 3D View Defaults dialog, is. See 3D View Defaults Dialog on page 1084. 

It’s not unusual for ray traced images to initially be too dark or 
too bright. Try adjusting the Tone Mapping Intensity. See 

Adjusting Ray Trace Properties and Effects on page 1175.

MATERIAL DEFINITIONS

The attributes of the materials applied to objects in a scene have an extremely important effect on the final quality of any 
ray trace. These attributes can be adjusted in the Define Material dialog.

All of the attributes that affect a material’s appearance in a Standard rendering will also affect its appearance in a ray trace. 
See Texture Panel on page 1069.

In addition, a number of settings specifically affect ray traces. See Properties Panel on page 1073.

One example is reflectivity. For example:

 l For outdoor scenes, ensure that your windows are slightly reflective. You may want to set up a building across the 
street that, though not in the scene, appears in the reflections in the windows. 

 l In interior scenes, use partly reflective materials on objects such as stove tops, tile floors, and coffee pots. 

INTERIOR VIEWS

When creating an interior ray trace view in which sunlight shines through windows, bear these settings mind:  

 l To produce effective lighting in interior CPU ray traces, Use Photon Mapping needs to be checked. See Advanced 
Panel on page 1170.

 l For colored shadows created by light passing through colored semi-transparent objects, check Compute Caustics as 
well. See Advanced Panel on page 1170.

 l The Direct Sunlight Intensity setting for interior views should be set higher than for exterior views. A value of 5 is a 
good starting point, but you may wish to experiment. See Lighting Panel on page 1168.

 l When your CPU ray trace is finished and the ray trace window is active, select File> Adjust Image Properties  

and adjust the Brightness value as needed. See Adjust Image Properties on page 1175. 
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NIGHTTIME VIEWS

For best results when creating a nighttime CPU ray trace view, there are a few considerations to bear in mind:  

 l While the rendered view you wish to ray trace is active, select 3D> Lighting> Toggle Sunlight  to turn off the sun 

as a light source. See Generic Sunlight on page 1134.
 l Use the CPU Ray Trace Assistant to create an Outdoor ray trace configuration. Choose Dark or Nighttime as the 

outdoor conditions on the Environment Lighting page. See CPU Ray Trace Assistant on page 1172.
 l When the new configuration is finished, click the Edit button in the CPU Ray Trace Options dialog and enable 

Photon Mapping. The Use Caustics option improves the quality of light shining through transparent objects. See 
Advanced Panel on page 1170.

 l When your CPU Ray Trace is finished and its window is active, select File> Adjust Image Properties  and either 

lower the Intensity value or uncheck Use Tone Mapping to turn this feature off altogether. See Adjust Image 
Properties on page 1175. 

FASTER CPU RAY TRACING

Depending on the scene and the quality you want to achieve, a CPU Ray Trace can quite literally take days to produce. 
There are several things you can do to reduce the time required:         

 l Reduce the number of surfaces in the 3D model by turning off all layers not used in the scene to be ray traced. For 
example, you may be able to turn off terrain layers for interior views, or cabinet layers for exterior views. See Layers 
on page 180.

 l An even more effective way to reduce the size and complexity of a 3D model is to use Save As  to create a copy of 

the plan, then delete all areas of the model that do not affect the scene to be ray traced. Depending on the scene, you 
may be able to delete entire rooms - or even entire floors. 

 l Image size is a significant factor in the speed of a CPU Ray Trace. As you adjust the lighting and other variables in a 
scene, you can save time by creating smaller ray traces for preview purposes. To do this, specify a relatively small 
image size in the CPU Ray Trace Options dialog. When you are ready to create a final CPU Ray Trace, specify a 
larger image size. See General Panel on page 1167.

CPU USAGE

CPU Ray Tracing is a data intensive process that can require a lot of resources on any computer. You can specify whether 
Chief Architect or its CPU Ray Trace engine has access to more of your computer’s processor resources when both are 
running in the Preferences dialog. See Ray Trace Panel on page 130. 

QUEUING CPU RAY TRACE JOBS

Because Chief Architect’s CPU Ray Trace engine is a separate process from the program, you can set up a queue of 
multiple ray trace jobs, much like you can queue multiple print jobs for a printer. 

CPU Ray Traces are generated one at a time, so in order for a queue of multiple ray traces to be completed, they must all 
use CPU Ray Trace Configurations set to use a defined period of time or number of passes. See General Panel on page 
1167. 

Do not use the No Limit option when queuing ray trace jobs.
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To queue multiple CPU ray traces
 1.  Start your first CPU Ray Trace and then return to plan view without closing the ray trace view window. See Working 

in Multiple Views on page 154.

 2.  Open or create the next camera view that you would like to ray trace. 

 3.  Choose the desired CPU Ray Trace Configuration and begin the CPU Ray Trace.

 4.  Repeat these steps to queue as many CPU Ray Traces as you need. As soon as one finishes, the next one will begin. 

If you have multiple ray traces queued and you Pause  the one in progress, the next job in queue will begin running. If 

you Resume  the first job, the one in progress will be paused. 

You can work on other tasks on your computer while your CPU Ray Traces run, or you can walk away. You can lock your 
computer and even turn off the monitor; but do not exit out of Chief Architect or shut down the computer or your queue will 
be lost.

1179



Chief Architect Premier X14 Reference Manual - Pictures, Images, and Walkthroughs

Chapter 35
 

Pictures, Images, and Walkthroughs

Chief Architect uses picture files in a variety of ways to enhance your drawings. 

The Library Browser contains images of real world objects like plants and vehicles that can display in 3D views.

Picture files can also be imported into Chief Architect and shown in most views. 

You can save any view using a variety of picture file formats. In addition, Chief Architect allows you to create virtual tour 
videos that can be played back later and shared with others.

Chief Architect can also generate CPU Ray Trace images from a Standard or Physically Based rendered view for photo-
realistic rendering capabilities. CPU Ray Tracing is discussed in its own chapter. See CPU Ray Tracing on page 1163.
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Picture Files vs Pictures and Image Objects
In common computer language, picture files, pictures and images are more or less synonymous. In the Chief Architect 
environment, however, there are some notable differences between these terms.         

In Chief Architect, a two dimensional image file such as a .bmp, .jpg, .gif, or .png is referred to as a picture file or an image 
file. Examples of these files are saved on most computers and can be opened in a variety of applications.          

A Picture, on the other hand, is a file that has been imported into the program. Pictures can be imported into plan view, 
cross section/elevation views, CAD details, and layout pages. They are two-dimensional only and do not display in camera 
views or overviews.          

An Image object is also based on a picture file, but it does display in both 2D and 3D views. Images have 3D width and 
height data associated with them, as well as a 2D symbol which displays in plan view.          

Picture files have additional uses in Chief Architect, as well:         

 l Backdrops are picture files that display behind 3D views. See 3D Backdrops on page 1201.         
 l Textures are picture files that realistically represent materials in 3D views. See About Materials on page 1051.          

 

Images
Images add realistic detail to 3D views without adding many surfaces to the model. For example, a tree image with a single 
surface can be used instead of a tree symbol with thousands, dramatically improving realism without compromising drawing 
time.         

There are two types of Images in Chief Architect:          

  Images rotate so that they always face the camera in 3D views.         

  Billboard Images do not rotate to face the camera. An example of when this may be useful is an image of a 
trellis, which might look awkward when facing a camera from a side view.          

PLACING IMAGES

A selection of Images are available in the Library Browser. Select one and click in a plan view, camera view or 
overview to place it. See Placing Library Objects on page 980.

CREATING IMAGES

Custom Images can be added to the User Catalog in the library, as well as created in plan files. Chief Architect can use any 
image with a *.bmp, *.jpg, *.png, *.gif, or  *.tif extension.         

Generally, .png files work best as Images because this format has good compression and allows for the Image to contain 
transparency information.         

To create an Image in plan view
 1.  In plan view, select Build> Image> Create Image  or Billboard Image  to open the Image Specification 

dialog. See Image Specification Dialog on page 1184.         

 2.  On the IMAGE panel:         
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 l Click the Browse button to select a picture file on your computer or enter the path to a valid picture file in the 
Image File field. If the file is not located in the Chief Architect Premier X14 Data folder, a copy of the file will be 
created at Chief Architect Premier X14 Data\Images\-My Images and the Image object will reference that copy. 
See Chief Architect Premier Data on page 37.          

 l Select a 2D Plan Symbol from the drop-down list or click the Library button and select a CAD block or symbol 
from the library. The selected symbol represents the image in plan view. See Image Panel on page 1184.         

 l Specify the Size and Position of the image.          

 3.  Specify transparency information on the TRANSPARENCY panel.          

 4.  Click OK to close the Image Specification dialog.         

 5.  Click to place the new Image in plan view.          

To create an image in the Library Browser
 1.  In the Library Browser, right-click on an unlocked folder.         

 2.  Select New> Image from the contextual menu to open the Image Specification dialog.          

 3.  Browse to the image file you want to add and select your other options. See Image Specification Dialog on page 
1184.           

 4.  Once created, the image is listed in the library folder that you right-clicked on. Size and other data is saved.          

USING PASTE IMAGE

You can also import an image by first copying it to the system clipboard, then navigating to a Chief Architect 
window and selecting Edit> Paste> Paste. See Paste Special on page 175.          

The Screen Capture tool can also be used to create a custom image object. See Creating Screen Captures on page 
1200.    

CONVERTING A FOLDER OF IMAGES

A folder of image files can be converted into Image objects and added to the library all at once, saving the effort of 
converting them individually.         

To convert a folder of images
 1.  Select Build> Image> Create Image Library .          

 2.  In the Select an Image Folder dialog, select a folder of image files to convert and click OK.           

 3.  A new library with the same name and directory structure as the converted folder is listed in the Library Browser. 
Depending on the number of images in the folder, this may take a few moments.          

 

Displaying Images
The display of images in floor plan and 3D views is controlled in the Layer Display Options dialog. See Layer 
Attributes on page 181.

Images are placed on the “Images” layer by default but can be moved to other layers once they have been created. See 
Image Specification Dialog on page 1184.         
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IN PLAN VIEW

In plan view, most images are represented by an Image   symbol. You can specify a different symbol to represent an 
image if you wish. See Image Specification Dialog on page 1184.          

Any 2D CAD block from the library can represent an image object. If you do not see a CAD block that suits your needs, 
you can create one or import one from another application. See Custom 2D Symbols on page 335.         

IN 3D VIEWS

The actual picture associated with an image object can be seen in 3D views, as can any transparency data associated it. See 
Image Specification Dialog on page 1184.         

Images can be set to either rotate so that they always face the camera or remain stationary, like billboards. See Images on 
page 1181.          

IN LAYOUT VIEWS

Images can be included in all views sent to layout with the exception of those using Plot Lines. See Plot Line Views on page 
1348.         

 

Editing Images
Images can be selected in 2D and 3D views and edited using the edit handles, edit tools and the Image Specification dialog. 
See Image Specification Dialog on page 1184.         

USING THE EDIT HANDLES

In plan view, a selected image can be rotated, moved, and resized. In 3D views, a selected image only has two edit handles: 
the circular Resize handle and square Move handle.          

When an image is resized using the edit handle, its aspect ratio is retained and 2D symbol resizes proportionally.         

USING THE EDIT TOOLBAR

A selected image or images can be edited in a variety of ways using the buttons on the Edit Toolbar. See The Edit Toolbar 
on page 135.         
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USING DIMENSIONS

Image objects can be moved using dimensions in plan view. See Moving Objects Using Dimensions on page 491. 

In order for a manually drawn Dimension Tool to locate image objects as a dimension line is drawn, it must be set to do so 
in the Dimension Defaults dialog. See Locate Manual Panel on page 460.

 

Image Specification Dialog
Select an image and click the Open Object edit button to open the Image Specification dialog. 

IMAGE PANEL
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General

General information about the selected Image can be specified here.         

 l The Image File associated with the Image can be specified. Click Browse to choose a file saved on your computer 
or type the file’s full pathname in the text field.              

 l Select a 2D Plan Symbol from the drop-down list to represent the Image in plan view. See Displaying Images on 
page 1182.             

 l Click the Library button to choose a CAD block from the library to act as the Image’s 2D symbol. See Select 
Library Object Dialog on page 982.             

Note: Images cannot be assigned a 2D Plan Symbol that contains a 
nested CAD block. See CAD Blocks on page 333.

 
Size/Elevation

Specify the Size/Elevation of the image as it displays in 3D views.         

 l Enter a Height for the selected image.              

 l Enter a Width for the selected image.              

 l Uncheck Retain Aspect Ratio of X if you would like to modify the Height or Width without affecting the other 
value. If you do this, the image may appear distorted. 
This check box does not affect editing performed outside this dialog and is an action rather than a state: the next time 
you open this dialog, it will be checked.             

 l Click Reset Original Aspect Ratio of to reset the image’s original aspect ratio and remove any distortion caused by 
resizing.             

 l Select the Elevation Reference from the drop-down list. This determines where the next two settings are measured 
from and also affects their setting labels.             

 l Specify the height to Top, measured from the selected Elevation Reference to the top edge of the image.         

 l Specify the height to Bottom, measured from the selected Elevation Reference to the bottom edge of the image.         

 
Center Point

Specify the location of the X and Y Coordinates of the selected image’s Center Point.         

 
Block Line/Fill Style

Specify the appearance of the Block Line/Fill Style of the image’s 2D symbol in plan view. Only available when a CAD 
block from the library is selected as the image’s 2D Plan Symbol.         

 l Select Use Image Settings to use the image’s line style, which is set by layer, and its fill style, which is None 
(Transparent).

 l Select Use Block Settings to use the 2D CAD block’s line and fill styles. See Custom 2D Symbols on page 335.
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  Options

Check Reverse Image to reflect the appearance of the image about an imaginary vertical line through its center.          

Check Image Always Faces Camera to prevent the image from rotating to face the camera in 3D views. This box is 
unchecked for Billboard Images. See Images on page 1181.              

 
Copyright

Any Copyright information associated with the selected Image will be stated here.          

 
Preview

A preview of the selected Image displays here. The Glass House Rendering Techniques is not available for images. See 
Dialog Preview Panes on page 22.          

TRANSPARENCY PANEL

The settings on the TRANSPARENCY panel let you specify portions of the selected image as transparent.         

 l Click the Use Transparency From The Image File radio button to use any transparency data included in the image 
file.             

 l Click the Use Custom Transparency Color radio button to specify a color in the image to represent the transparency 
and enable the settings below.              

 l Click the Color bar to select a color in the Select Color dialog. See Color Chooser/Select Color Dialog on page 204.             
 l Use the slide bar or enter a value to specify a level of Tolerance to be applied to colors that are almost the same as the 

specified transparency color.             
 l Move your pointer over the small preview image below. The pointer changes to an eyedropper and a magnified 

preview displays to its right. Click to select the color of the pixel your pointer is over as the Transparency color. The 
selected color displays in the Color bar, below.             

 l A magnified preview of the area in the preview image above displays here, allowing for accurate pixel selection.             

Note: The image preview will display its original orientation, even if 
Reverse Image is checked on the Image panel.

1186



Chief Architect Premier X14 Reference Manual - Pictures

THE TRANSPARENCY COLOR

If the portion of the image file that you wish to use contains the transparency color, that part of the image also becomes 
transparent. If this happens, the image may appear partially disintegrated.         

You may need to experiment to find the best transparency color and tolerance for the image.         

LAYER PANEL

For information about the settings on this panel, see Layer Panel on page 191.          

FILL STYLE PANEL

The settings on the FILL STYLE panel affect the appearance of the selected image’s 2D Plan Symbol in plan view, provided 
that the selected symbol is a closed shape. For information about these settings, see Fill Styles on page 197.         

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 1335.          

 

Pictures
A variety of picture file types can be imported into and exported out of Chief Architect.

Metafiles are also types of picture files that can be imported and exported. See Metafiles on page 1191.

EXPORTING PICTURES

There are several ways to save a picture of a view in Chief Architect:

Using the Export Picture tool is similar to creating a screen capture of everything  in the current view window. 
Pictures can be saved in various file formats and used in other applications. Export Picture is best suited for 

rendered and CPU Ray Trace views. When exporting a line-based view, best results can be achieved by saving it as a 
metafile. See To export a metafile on page 1192.

The Screen Capture tools offer another way to create a picture file based on the current view. See Creating Screen 
Captures on page 1200. 

The Save Image to File option in the CPU Ray Trace Options dialog automatically saves a completed CPU Ray Trace view 
as a picture file. See General Panel on page 1167.         

The Export 360 Panorama tool creates a spherical panoramic image file. See Export 360 Panorama on page 1245.         

Use the Print Image tool to either print or save the current view as a PDF file. See Print Image Dialog on page 
1388.
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To export a picture
 1.  Open the view that you would like to export as a picture file. 

 2.  Zoom, pan or otherwise adjust the view so that what you see on screen suits your needs. See Displaying 3D Views 
on page 1096.

 3.  Select File> Export> Export Picture (BMP, JPG, PNG)  to open the Export Picture dialog, below, and specify 

the desired image size and other properties.         

 4.  In the Export Picture File dialog, which opens next, give the new picture file a name, file type, and save location. 
See Exporting Files on page 41.          

EXPORT PICTURE DIALOG

The settings in this dialog are retained between program sessions.

 
Image Size

Specify the exported file’s Image Size in pixels or inches (mm).         

 l Check Use Active Window Size to export the picture at the same size as the active view window. The window’s 
Width and Height are described below. In camera views only, these values can be changed, in which case this box 
becomes unchecked automatically.         

 l Select either Pixels or Units as the method by which the picture’s dimensions are measured.             

 l Specify the Width and Height of the image. The initial values correspond to the view window’s size. In plan view 
and CAD Details, they display for reference only.             

 l Specify the Resolution of the image. Select Dots/Inch or Dots/mm from the drop-down list.             

 l Uncheck Retain Aspect Ratio if you would like to modify the Height or Width without affecting the other value. 
Leave this box checked to prevent the image from becoming distorted.             

 
Image Properties

Check Transparent Background to produce alpha transparency in the spaces between all objects that can be seen in the 
current view. Transparency associated with Fill and Text Styles is retained, as well. Note that the .png and .png file types 
support transparency, while the .jpg and .bmp file types do not. 

When you click OK, the Export Picture File dialog will open, allowing you to specify a name, file type, and save location 
for the picture file.
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IMPORTING PICTURES

Pictures can be imported into and displayed in plan view, cross section/elevation views, CAD Details, and layout 
pages. Pictures do not display in camera views or overviews. See Displaying Pictures, Metafiles, and PDF Boxes on 

page 1197.         

There are several ways to import a Picture into Chief Architect:         

 l Select File> Import> Import Picture (BMP, JPG, PNG) to open the Import Picture File dialog, which is a typical 
open file dialog. See Importing Files on page 45.          

 l Click and drag an image file from an operating system window into the Chief Architect window.             
 l In any application, copy an image to the system clipboard, then select Edit> Paste> Paste Special  from the 

program menu in an eligible view window. See Paste Special on page 175.         
 l Use the Screen Capture tools. See Creating Screen Captures on page 1200.          

Note: Importing large, or multiple, Pictures into a plan or layout file can 
result in program slowness. 

An imported picture is placed in the center of the current view. Once imported, pictures can be selected and edited. See 
Editing Pictures, Metafiles, and PDF Boxes on page 1198.

If the file referenced by a picture object is modified outside Chief Architect, its appearance will not update in Chief 
Architect until you close and reopen the plan or layout file it was imported into.

 

Picture File Box Specification Dialog
Select an imported picture file and click the Open Object edit button to open the Picture File Box Specification 
dialog.         
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GENERAL PANEL

 
Picture File

Information about the selected Picture File can be specified here.         

 l The Filename of the picture file displays here. You can type a new pathname to change the picture assigned to this 
box if you wish.          

 l Click the Browse button to choose a new picture file or to relink to a missing file.          

 l Check Save in Plan to embed the picture in the plan or layout file. If a picture file is embedded, you do not need to 
include it when sending the plan or layout to a different computer.          

 l Click the radio button beside either PNG or JPEG to specify how to save the embedded picture data.   

 l Specify the picture’s Quality % when JPEG is selected. A lower value results in better compression, while a higher 
value reduces data loss.           

Note: PNG is the better option for pictures of line drawings, text, or large 
areas of a single color. In addition, PNG files support alpha channel 
transparency. JPEG is the better option for photos. 
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Center/Orientation

Specify the position of the selected Picture’s center point and its angle. See 3D Drafting on page 12.         

 l Specify the X and Y Positions of the picture box’s center point relative to the absolute origin.           

 l Specify the Angle of the picture box relative to a horizontal line pointing towards the right-hand side of the screen.          

 
Size

Specify the Size of the picture in plan inches (mm).             

 l Specify the Width of the picture box. The original width in pixels displays to the right.          

 l Specify the Height of the picture box. The original height in pixels displays to the right.          

 l Uncheck Retain Aspect Ratio of X if you would like to modify the Height or Width without affecting the other 
value. If you do this, the picture may appear distorted. This check box does not affect editing performed outside this 
dialog and is an action rather than a state: the next time you open this dialog, it will be checked.          

 l Reset Original Aspect Ratio - If the aspect ratio is changed, you can click this button to return the picture to its 
original aspect ratio.           

 l Check Reset Cropping to fill the extents of the selected Picture box with the image associated with it. If the box has 
been resized, the image may appear distorted. See Editing Pictures, Metafiles, and PDF Boxes on page 1198.          

 
Display Options

A variety of Display Options are available.             

 l Check Black and White Dither to dither the selected picture file. Dithering creates a two tone effect that may 
produce better results when printed.          

 l Check Grayscale to replace the color in the selected picture with shades of gray.          

 l Check Reflect to reverse the image.          

 l Enter a degree of Brightness from 1 - 100%.          

 l Enter a degree of Contrast from 1 - 100%.          

LINE STYLE PANEL

The settings              on this panel             are similar to those on the LINE STYLE panel in numerous other dialogs, with one exception: 
check Show Outline to turn on the display of the picture’s border polyline. For more information, see Line Style Panel on 
page 310.         

FILL STYLE PANEL

For information about using the FILL STYLE panel, see Fill Styles on page 197.          

 

Metafiles
A metafile (.emf, .wmf) is a special picture file format made up of vectors (lines) that allow the image to be rescaled 
without loss of quality. High resolution pictures of line-based views can be exported as a metafile.
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Note: Metafiles are not supported in Mac operating systems and cannot 
be imported or exported in Mac versions of the software. 

EXPORTING METAFILES

An enhanced metafile (.emf) can be exported from any line-based view: that is, from plan view, CAD Details, layout 
pages, and 3D Vector Views. 

Only objects that display on screen are included in an exported metafile. 

To export a metafile
 1.  Accurately position the view on screen.

 2.  Select File> Export> Export Metafile (EMF) .

 3.  Drag a marquee   from corner to corner, defining the area to be included in the metafile.

 4.  Release the mouse button to open the Export Metafile dialog, which is a typical Save File dialog. See Exporting 
Files on page 41.

 5.  When you click the Save button, the Metafile Size dialog opens.

 6.  Specify the desired Width or Height of the metafile. When one value is edited, the other changes to maintain its 
aspect ratio. 

Specify, too, the desired Dots Per Inch (DPI) for the metafile. A larger value results in a higher quality metafile, but 
also a larger file size.

 7.  When a metafile is exported from a 3D Vector View, you can also specify the printed thickness of lines in the view. 
To increase the printing line weight, type a larger number in the Use Line Weight field. See Vector View on page 
1147. 

Metafiles exported from plan view use the line weights defined in the Layer Display Options dialog. See Layer 
Display Options Dialog on page 183. 

IMPORTING METAFILES

Metafiles can be imported into and displayed in plan view, cross section/elevation views, CAD Details, and layout 
pages. Metafiles do not display in camera views or overviews. See Displaying Pictures, Metafiles, and PDF Boxes on 

page 1197.         

There are two ways to import a metafile into Chief Architect:         
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 l Select File> Import> Import Metafile (EMF, WMF)  to open the Import Metafile dialog, which is a typical open 

file dialog. See Importing Files on page 45.             
 l You can also click and drag a metafile file from an operating system window into the Chief Architect window to 

import it.             

An imported metafile is placed in the center of the current view. Once imported, metafiles can be selected and edited. See 
Editing Pictures, Metafiles, and PDF Boxes on page 1198.         

 

Metafile Box Specification Dialog
Select an imported metafile and click the Open Object edit button to open the Metafile Box Specification dialog.          

GENERAL PANEL

 
Center/Orientation

Specify the position of the selected metafile’s center point and its angle. See The Chief Architect Premier Environment on 
page 12.         

 l Specify the X and Y Position relative to the absolute origin.           

 l Specify the Angle of the metafile box relative to a horizontal line pointing towards the right-hand side of the screen.          
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Size

Specify the Size of the metafile in plan inches (mm).         

 l Specify the Width of the metafile box.           

 l Specify the Height of the metafile box.           

 l Uncheck Retain Aspect Ratio of X if you would like to modify the Height or Width without affecting the other 
value. If you do this, the metafile may appear distorted. 
This check box does not affect editing performed outside this dialog and is an action rather than a state: the next time 
you open this dialog, it will be checked.          

 l Reset Original Aspect Ratio - If the aspect ratio is changed, you can click this button to return the picture to its 
original aspect ratio.           

 l Check Reset Cropping to fill the extents of the selected metafile box with the image associated with it. If the box 
has been resized, the image may appear distorted. See Editing Pictures, Metafiles, and PDF Boxes on page 1198.          

LINE STYLE PANEL

The settings              on this panel             are similar to those on the LINE STYLE panel in numerous other dialogs, with one exception. 
Check Show Outline to turn on the display of the picture’s border polyline. For more information, see Line Style Panel on 
page 310.         

FILL STYLE PANEL

For information about using the FILL STYLE panel, see Fill Styles on page 197.          

 

PDF Files
Portable Document Format (.pdf) files are a special type of file that can be viewed on nearly any computer and can include 
a wide variety of visual information.           

PRINTING AND EXPORTING PDF FILES

You can save any view as a 2D .pdf file by selecting File> Export> Export PDF. This will open either the Print 
View or Print Image dialog, depending on the view type.          

You can also save any view as a 2D .pdf file by selecting “Chief Architect Save as PDF” as the Destination printer Name in 
either of these dialogs. See Printing to a PDF File on page 1379.          

IMPORTING PDF FILES

To import a .pdf file, select File> Import> Import PDF. You can also import a .pdf file by dragging it from an 
operating system window into the Chief Architect window.         

You can import .pdf files into Chief Architect in plan view, cross section/elevation views. CAD Details, and in layout. Once 
imported, PDF boxes behave and can be edited similar to imported pictures and metafiles. See Editing Pictures, Metafiles, 
and PDF Boxes on page 1198.         

Some .pdf files can contain both 2D and 3D information; however, Chief Architect can only support 2D data in an imported
 .pdf file. When a 3D .pdf file is imported, it may display text, a static image of the 3D model, or it may not import at all.          
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Note: Importing large, or multiple, .pdf files into a plan or layout file can 
result in program slowness. 

 
 

The full pathname of the .pdf file displays here. If the pathname is not that of a valid .pdf file, this text will display in red.          

 l Click the Browse button to choose a new .pdf file or to relink to a missing file.         

 l Specify the Page of the .pdf file that displays in the preview on the right. Type a page number in the text field or use 
the spin control arrows to browse the pages sequentially.         

 
Preview

A preview of the page selected above displays on the right.          

 
Import

Specify how much of the .pdf file you wish to Import. When multiple pages are imported, a separate PDF box is created 
for each one.         

 l Select Current Page to import only the page specified above and shown in the preview to the right.          

 l Select Pages, then specify the starting page in the From field and the ending page in the To field.          

 l Select All to import the entire .pdf file.          

 

PDF Box Specification Dialog
Select an imported PDF box and click the Open Object edit button to open the PDF Box Specification dialog.
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GENERAL PANEL

 
PDF File

The full Filename of the .pdf file displays here. Type a new name to associate the selected PDF box with a different .pdf 
file.         

 l Click the Browse button to choose a new .pdf file or to relink to a missing file.          

 l Specify the Page of the .pdf file that displays in the selected PDF box.          

 l Check Save in Plan to embed the .pdf in the plan or layout file. If a .pdf is embedded in a file, you do not need to 
include it when sending the file to a different computer. If the .pdf file is modified, however, the PDF box in Chief 
Architect will only update automatically if this is unchecked.          

 
Center/Orientation

Specify the position of the selected PDF box’s center point and its angle. See 3D Drafting on page 12.         

 l Specify the X and Y Positions of the PDF box’s center point relative to the absolute origin.          

 l Specify the Angle of the PDF box relative to an imaginary horizontal line pointing towards the right-hand side of the 
view window.          
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Size

Specify the Size of the PDF box in plan inches (mm).         

 l Specify the Width of the PDF box.           

 l Specify the Height of the PDF box.           

 l Uncheck Retain Aspect Ratio of X if you would like to modify the Height or Width without affecting the other 
value. If you do this, the PDF box may appear distorted. 
This check box does not affect editing performed outside this dialog and is an action rather than a state: the next time 
you open this dialog, it will be checked.          

 l Reset Original Aspect Ratio - If the aspect ratio is changed, you can click this button to return the picture to its 
original aspect ratio.           

 l Check Reset Cropping to fill the extents of the selected PDF box with the image associated with it. If the box has 
been resized, the image may appear distorted. See Editing Pictures, Metafiles, and PDF Boxes on page 1198.          

LINE STYLE PANEL

The settings     on this panel are similar to those on the LINE STYLE panel in numerous other dialogs, with one exception: 
Check the Show Outline box to turn on the display of the PDF box’s border polyline.         

See Line Style Panel on page 310.         

FILL STYLE PANEL

For information about using the FILL STYLE panel, see Fill Styles on page 197.          

 

Displaying Pictures, Metafiles, and PDF Boxes
The display of Pictures, Metafiles, and PDF Boxes is controlled in the  Layer Display Options dialog. See Layer 
Attributes on page 181.

Pictures, Metafiles, and PDF Boxes are placed on the Current CAD Layer by default; but once imported, they can be moved 
to other layers. See Image Specification Dialog on page 1184.         

Pictures, Metafiles, and PDF Boxes can be imported into and displayed in plan view, cross section/elevation views, CAD 
Details, and layout pages. A Picture, Metafile, or PDF Box can only be seen in the view where it was imported and cannot 
be imported into a camera view or overview.         

DRAWING GROUPS

Each object in a plan or layout file is included in a Drawing Group, which influences whether it displays in front of or 
behind other objects. By default, imported pictures and PDF Boxes are placed in              Drawing Group 38,the Back Group, and 
imported metafiles are placed in              Drawing Group 21,the same Drawing Group as CAD objects.         

Once imported, the drawing order of pictures, metafiles, and PDF Boxes can be customized. See Drawing Groups on page 
194.          

IN LAYOUT

Pictures, metafiles, and PDF boxes are included when a view is sent to layout, and can also be imported directly onto a 
layout page. See Pictures, Metafiles, and PDFs in Layout on page 1343.          
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Editing Pictures, Metafiles, and PDF Boxes
Pictures, Metafiles, and PDF Boxes can be selected and edited using the edit handles, the Edit Toolbar, and their 
specification dialogs.          

Imported pictures, metafiles, and PDFs are placed on the Current CAD Layer by default; but once imported, these objects 
can be placed on any layer. See Layers on page 180.          

IN THE SPECIFICATION DIALOG

Pictures, Metafiles, and PDF Boxes can be customized in their specification dialog. See:          

USING THE EDIT HANDLES

Pictures, Metafiles, and PDF Boxes have edit handles similar to other box-based objects. See Editing Box-Based Objects on 
page 234.          

 l The corner Resize handles do not behave the same for Pictures, Metafiles, and PDF Boxes as they do for CAD boxes, 
however. If you drag a corner handle of one of these objects while the Default Edit Behavior is active, its contents will 
resize and height to width ratio will be retained.          

 l If you drag an Extend handle along a Picture, Metafile, or PDF Box’s edge, the contents of the box will not be resized. 
If you resize it larger, an empty space will be created between that edge and the contents; if you resize it smaller, the 
contents will be cropped.         

USING DIMENSIONS

Pictures, Metafiles, and PDF Boxes can be relocated relative to other objects with precision using dimensions.          

To avoid changing the selected object’s aspect ratio, make sure you choose to move the entire object rather than the selected 
edge. See Moving Objects Using Dimensions on page 491.         

USING THE EDIT TOOLS

A selected Picture, Metafile, or PDF Box can be edited in a variety of ways using the buttons on the Edit Toolbar. See The 
Edit Toolbar on page 135.         

POINT TO POINT RESIZE

A selected picture, metafile, or PDF box can be resized in either the X or Y direction with the Point to Point Resize 
edit tool.         

To use the Point to Point Resize tool
 1.  Select a picture box, metafile box, or PDF box.          

 2.  Click the Point to Point Resize  edit button. When you move the mouse pointer into the drawing area, it displays 

the Point A   icon.           

 3.  Click on the first of two points in the selected object’s area that have a known distance between them.          

 4.  Notice:          

1198



Chief Architect Premier X14 Reference Manual - Editing Pictures, Metafiles, and PDF Boxes

 l A temporary CAD point is created at the point where you clicked.          

 l The mouse pointer now displays the Point B   icon.   

 l As you move the mouse pointer, an extension line extends either horizontally or vertically from Point A.           

 5.  Click on the second of the two points with a known distance between them.           

 l Regardless of where the mouse pointer is positioned, Point B will be at the end of the extension line so for best 
results Points A and B should be on the same X or Y plane.          

 6.  After you click on the second point, the Point to Point Resize dialog opens.          

 7.  The current distance between the two points populates the text field. Enter a new dimension that matches the desired 
distance between the points.          

 8.  When Retain Aspect Ratio is checked, the ratio between the selected object’s height and width is maintained when 
you click OK and the object is resized. When this is unchecked, the object may become distorted-looking. If the 
selected object has been rotated, this box will be disabled and its aspect ratio will be retained.          

 9.  Click OK to resize the picture, metafile, or pdf.          

RESIZE FACTOR

With a bit of calculation, an imported picture, metafile, or PDF box can be resized to scale using the Transform/Replicate 
Object dialog. Once resized, the information in the object box can be traced using Chief Architect’s drawing tools and then 
deleted.           

It is a good idea to delete a resized picture after it is traced to 
help avoid program slowness and limit your plan or layout file’s 

size.

To calculate the Resize Factor
 1.  Find two items in the imported object that are separated by a known horizontal or vertical distance, such as two 

walls or plot lines.           

 2.  Draw parallel CAD lines on top of these two items. See The CAD Drawing Tools on page 300.          

 3.  Find the distance between the CAD lines. See The Manually Drawn Dimension Tools on page 477.          

 4.  The Resize Factor for the image is the distance described in the picture divided by the distance between the CAD 
lines.          

For example, if the items are supposed to be 10 feet apart on the picture, but the distance between the two CAD lines 
drawn on them is only 2 feet, you need to set the Resize Factor for the picture to 5. (10’ divided by 2’ equals 5). When 
the picture is 5 times the original size, the items on the picture are at the actual scale shown on the picture.          

 5.  Select the picture and click the Transform/Replicate Object  edit button.           

 6.  In the Transform/Replicate Object dialog, select the Resize Factor check box.          

 7.  Enter the Resize Factor calculated above, then click OK.          
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Creating Screen Captures
Use the Screen Capture tools to add images, backdrops, or materials to the Chief Architect Library or to create 
picture objects. You can capture screens in Chief Architect or other applications.         

Begin by selecting Tools> Screen Capture> Screen Capture Setup  to open the Screen Capture Setup dialog.          

SCREEN CAPTURE SETUP DIALOG

Save Capture As - Specify in what form you would like the screen capture to be saved.          

 l Select Backdrop to add the image to a new 3D backdrop in the User Catalog in the library, where it will be selected. 
See 3D Backdrops on page 1201.          

 l Select Image to add the image to an Image object in the User Catalog in the library, where it will be selected. See 
Images on page 1181.          

 l Select Material to add the image to a new Stretch to Fit material in the User Catalog in the library, where it will be 
selected. See Creating Materials on page 1060.          

 l Select Picture to display the picture in the current plan, cross section/elevation, or CAD Detail view. See Pictures on 
page 1187.          

 l Check Hide Chief Architect While Capturing to minimize the program window so you can capture an image in 
another application.           

 l Click Capture to proceed with a screen capture and click Done when you are finished. The Screen Capture Setup 
settings are saved between program sessions and are used in all files.          

On some systems, you must grant permission for Chief Architect 
Premier X14 to record the screen.

To create a screen capture
 1.  Select Tools> Screen Capture> Capture Screen , or click the Capture button in the Screen Capture Setup 

dialog.          

 2.  The mouse pointer displays a crosshairs icon when the Screen Capture tool is active. Move it to the window that 
you want to capture from. This can be in Chief Architect, a web page, or another program.          

 3.  Click and drag a rectangular marquee to capture the area within the marquee.          

 4.  A captured Picture will be placed immediately in the Chief Architect drawing area. Captured Backdrops, Materials, 
and Images are saved in the User Catalog of the Library Browser.           

Items added to the User Catalog are given names with a unique date and time stamp and reference image files of the same 
name saved in the Chief Architect Data folder. See Chief Architect Premier Data on page 37.
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To change the name of a captured backdrop, image, or material, right-click on its name in the library list, select Rename, 
and type in the new name. To avoid name conflicts, names should be unique. See Renaming Library Items on page 976.           

 

3D Backdrops
A backdrop is an image, typically of an exterior view, that displays in the background of 3D views to help place the model 
into a realistic setting and add a sense of perspective.          

Backdrops automatically adjust to fit each view window, so they look best when they are created with a height to width 
ratio that is similar to the window you are working in.         

You can create digital photos of a building site for use as a 
backdrop.

SPECIFYING A BACKDROP IMAGE

Backdrop images are view specific. You can select a backdrop image for a camera view from the library in either of two 
ways:          

 l In a 3D view, open the Library Browser. Select a Backdrop image, then move your mouse pointer   into the view 
window. Click anywhere in the view to apply the selected backdrop.          

 l Open the Camera Specification dialog, and on the BACKDROP panel, click the Select Backdrop button. See Backdrop 
Panel on page 1121.         

When a backdrop image is not applied, Chief Architect applies a background color instead. This color can be specified on 
the BACKDROP panel of the Camera Specification dialog, as well.          

SPHERICAL PANORAMIC BACKDROPS

Spherical Panoramic Backdrops are a special type of backdrop that wraps around the model in 3D views as though it were 
applied to a sphere surrounding it. It takes an image processing program or special camera to generate spherical panoramic 
backdrops.          

If you have such a file, you can specify it as your Backdrop image, then check Spherical Panoramic Backdrop in the 
camera’s specification dialog.           

The Use Generated Sky option produces a special Spherical Panoramic Backdrop that simulates a daytime sky using the 
Generic Sun or active Sun Angle  data. See Sun Angles and Shadows on page 1140.         

BACKDROP DEFAULTS

By default, Chief Architect uses backdrop images in Perspective Full Cameras only. You can, however, specify which types 
of views use backdrops by default, and also select the default backdrop images for each, in the Camera Tools Defaults 
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dialogs. See Camera Defaults Dialogs on page 1082.         

Similarly, backdrop images are only used by default in              a few Rendering Techniques: Standard, Watercolor, and Physically 
Based. You can choose whether a backdrop is used in any technique in the Rendering Technique Options dialog. See 
Rendering Technique Options on page 1150.         

ADDING NEW BACKDROPS

A new backdrop image can be created using a variety of graphic file formats and can be imported into Chief Architect in 
several ways:         

 l Select File> Import> Backdrop  to open the Import Backdrop File dialog, which is similar to the Import Picture 

File dialog. See Importing Pictures on page 1189.         
 l Right-click on the User Catalog and select New> Backdrop from the contextual menu.         
 l Copy and paste an image into Chief Architect. See Copying and Pasting Objects on page 171.          
 l Use the Screen Capture tools. See Creating Screen Captures on page 1200.           
 l Import a folder of backdrop images.          

To add a folder of backdrops to the library
 1.  Select File> Import> Create Backdrop Library .           

 2.  Browse to the location of a folder of images on your hard drive that you would like to bring into the library as 
backdrops, select it, and click OK.          

 3.  A folder with the same name will be created in the User Catalog, containing the imported backdrop images.           

 

Backdrop Specification Dialog
To open the Backdrop Specification dialog, select File> Import> Import Backdrop or right-click on the User 
Catalog in the Library Browser and select New> Backdrop from the contextual menu. See Adding New Backdrops 

on page 1202.         

You can also open this dialog by right-clicking on a backdrop image in the User Catalog in the Library Browser and 
selecting  Open  from the contextual menu.           
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Preview

A preview of the selected image displays here.          

 
Backdrop

Specify backdrop’s Name and the image file associated with it.         

 l Type a Name for the selected backdrop, to be used in the Library Browser and 3D View Defaults dialog.          

 l In the Location field, type the full pathname of the image file or click the Browse button and browse to the file on 
your computer. If the file is not located in the Chief Architect Premier X14 Data folder, a copy of the file will be 
created at Chief Architect Premier X14 Data\Backdrops\-My Backdrops and the program will reference that copy. 
See Chief Architect Premier Data on page 37.          

 
Spherical Backdrop Options

A backdrop should only be specified as a Spherical Panoramic Backdrop if its image file was specially created for this 
purpose.     

 l Check Spherical Panoramic Backdrop to place the selected backdrop onto a sphere that surrounds the model in the 
current view.      

 l Horizontal Tile - Specify how many times to tile the selected backdrop image side by side.      

 l Vertical Tile -  Specify how many times to stack the selected backdrop image one above the other.      

 l Specify the Horizontal Span, which is how much of the sphere the backdrop is applied to. A Span of 360° wraps 
the entire sphere.      

 l Specify the Horizontal Offset, in degrees, to shift the backdrop image or tiled images in a clockwise direction.      

 l Specify the Vertical Max, which is the height of the bottom of the backdrop, measured relative to the top of the 
sphere.      

 l Specify the Vertical Min, which is the height of the bottom of the backdrop, measured relative to the bottom of the 
sphere.     

 l The Eye Level setting controls the vertical position of the camera within the sphere. A value of 0 positions the 
camera at the bottom of the sphere while a value of 1 positions it at the top. The default value is 0.5., which centers 
the camera inside the sphere.    

Some experimenting with the Angle values may be necessary to achieve the desired results. You may prefer to do this after 
adding the backdrop to a plan. See Backdrop Panel on page 1121.         

 
Copyright

If the selected image has a Copyright, information about it will display here.          

 

Walkthrough Paths
A 3D Walkthrough is a series of pictures saved as an .mp4, .wmv, or .avi file that can be played as a video by media 
player applications. Although you can record a walkthrough video directly from a camera view, Walkthrough Paths 

offer more options and flexibility and are the preferred way to create a walkthrough video in Chief Architect.
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CREATING WALKTHROUGH PATHS

There are two ways to create a Walkthrough Path:

The Create Walkthrough Path tool allows you to define the route that a walkthrough video travels through a plan as 
well as specify details like camera height, angle, and speed before actually recording. 

Available in plan view, the Create Orbital Walkthrough Path edit tool creates a circular walkthrough path around a 
selected full overview or  camera's focal point. The path's radius is equal to the length of the camera's line of sight, 

and all frames are pointed at the camera's focal point. 3D> Walkthroughs> Create Orbital Walkthrough Path is also an 
option when a camera view or overview is active.

To use the Create Walkthrough Path tool
 1.  Begin by choosing a codec for recording walkthroughs. See Selecting a Codec on page 1219.          

 2.  Make sure that Connect CAD Segments  is enabled so multiple spline segments can snap together. See Connect 

CAD Segments on page 163.

 3.  In plan view, select 3D> Walkthroughs> Create Walkthrough Path , then click and drag to draw a 

Walkthrough Path. See To use the Spline tool on page 330.         

 4.  Edit the direction and curvature of the spline’s segments, as needed. See Editing Spline-Based Objects on page 237.          

 5.  Add Key Frames  to the path and modify their specifications. See Key Frames on page 1206.         

 6.  Select the path and click the Record Walkthrough Along Path  edit button. See Record Walkthrough Along 

Path on page 1213.          

Walkthrough Paths can follow stairs and ramps to span multiple 
floors. See Walkthrough Paths and Stairs on page 1206.

In plan view, you can convert a CAD polyline or spline into a Walkthrough Path. See Convert Polyline on page 265.   

DISPLAYING AND EDITING WALKTHROUGH PATHS

Walkthrough Paths display in plan view only and are located on the “Walkthrough Paths” layer by default. Walkthrough 
Paths display in front of most other objects, will print, and are included in views sent to layout or exported to .dxf/.dwg. See 
Layers on page 180.

Before a Walkthrough Path can be edited, it must be selected. The Key Frame closest to the point where you clicked will be 
the Selected Key Frame. See Selecting Objects on page 212.

Walkthrough Paths can be edited like other spline-based objects using the edit handles, edit toolbar, and specification dialog. 
See Editing Spline-Based Objects on page 237.

In addition to the standard edit handles for splines, Walkthrough Paths also have an edit handle for each Key Frame. The 
Key Frame closest to the point where you click displays the Selected Edge Handle Fill color, while the other Key Frame 
handles use the Secondary Handle Fill color. Both are set in the Preferences dialog. See Colors Panel on page 102.

To reverse the direction of the entire walkthrough, select it and click the Reverse Direction  edit button. See Reverse 

Direction on page 264. 
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KEY FRAMES

Key Frames are points along a Walkthrough Path that allow you to change:          

 l Camera direction, tilt angle, and height;          
 l Changes in walkthrough speed;         
 l The floor that the walkthrough is on.          

These changes are applied as the camera moves along the Walkthrough Path from one Key Frame to another.         

To add a Key Frame to a Walkthrough Path
 1.  Select the path and click the Add Key Frame  edit button. 

 2.  If you wish to add multiple Key Frames, click the Sticky Mode  edit button. See Sticky Mode on page 174.

 3.  Click on the selected path to add a Key Frame at that location. The new Key Frame receives height and angle 
attributes based on its position on the path and the attributes of the Key Frames before and after it.

 4.  If you clicked the Sticky Mode  button, continue clicking to create additional Key Frames. When you are 

finished, click the Main Edit Mode  edit button or select a different drawing tool.

In plan view, each Key Frame is represented by a camera symbol centered along the walkthrough path. It displays its Key 
Frame number, is pointed in the direction of its Camera Angle, and its position along the path corresponds to its Time 
setting.          

Key Frame Time, Angle, and other properties can be edited in the Walkthrough Path Specification dialog. See General 
Panel on page 1208.          

You can also select a Walkthrough Path and move and rotate each Key Frame using its edit handles.          

To remove a Key Frame from a Walkthrough Path, click on its symbol to select it and click the Delete Key Frame  edit 

button. The selected Key Frame can be identified by the color of its Move edit handle. This edit tool can be used to delete 
the Start and End Key Frames; however, if only two Key Frames are present it will not be available. Key Frames can also 
be deleted in the Walkthrough Path Specification dialog. See Selected Edge on page 214 and General Panel on page 1208.

WALKTHROUGH PATHS AND STAIRS

If you draw a Walkthrough Path up or down a staircase or ramp, it will follow the height of the stairs or ramp and continue 
on the next floor.          

To create a multiple floor walkthrough
 1.  Draw a Walkthrough Path so that it extends into a staircase or ramp in the same direction as its Direction Arrow. See 

Displaying Stairs, Ramps, and Landings on page 759.         

 l Do not drag the Walkthrough Path across the entire length of the stairs or ramp. If you do, its height will remain 
relative to the current floor.         
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 2.  When you release the mouse button, the program will automatically display a dashed line with an arrow extending 
past the last Key Frame on the current floor.         

 l If it follows stairs or a ramp going upward, the path will also extend to the top end of the staircase or ramp.         

 3.  Go up or down one floor, select the Walkthrough Path, and resize and reshape it as needed. You can use the Create 
Walkthrough Path  tool to draw more segments and use the Add Key Frame  edit tool, as well.          

PREVIEWING A WALKTHROUGH

Depending on the quality settings and length of a Walkthrough Path, it may take a considerable amount of time to 
record a walkthrough video. The Walkthrough Preview side window allows you to preview part or all of an existing 

walkthrough path to confirm that it meets your needs prior to actually recording it. Select View> Walkthrough Preview to 
open or close this side window. See Walkthrough Previews on page 1210.

PLAYING A WALKTHROUGH

Once a walkthrough has been recorded, it can be played using a media player on your system.         

To play a walkthrough
 1.  Select 3D> Walkthroughs> Play Walkthrough  to open the Select Video File dialog.          

 2.  Browse to the .mp4, .wmv, or .avi file on saved on your computer. Your system's default video player plays the 
walkthrough video.         

 

Walkthrough Path Specification Dialog
Select a Walkthrough Path and click the Open Object edit button to open the Walkthrough Path Specification dialog. 
See Walkthrough Paths on page 1204.          

You can also access this dialog by clicking the Define button in the Walkthrough Preview side window. See Walkthrough 
Previews on page 1210.

Most of the settings in this dialog are also found in the Walkthrough Path Defaults dialog.

The Walkthrough Path Specification dialog has the following panels:
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GENERAL PANEL
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Key Frames

A list of the selected path’s Key Frames displays on the left.  Click on a Frame in the list to select and edit it using the 
settings on the right. When the dialog is opened, the Key Frame selected in plan view will be selected in the list 
automatically. Most of these settings are also found in the Walkthrough Preview dialog. See Key Frames on page 1206 and 
Walkthrough Previews on page 1210.    

 l Specify the Floor that the selected Key Frame is located on. See Multiple Floors on page 743.    

 l Specify the Time in seconds at which the selected Key Frame is found in the duration of the walkthrough. The 
Times of the walkthrough path's first and final frames cannot be moved.    

 l Specify the Speed After (ft/s), which is how fast the camera moves along the walkthrough path from the current 
Key Frame to the next. Not available if the last Key Frame is selected.    

 l Specify the Camera Angle at the selected Key Frame.    

 l Specify the Tilt Angle of the camera at the selected Key Frame.    

 l Specify the Height of the camera at the selected Key Frame.    

 l Click the Delete button to remove the selected Key Frame from the path. Key Frames can also be deleted in plan 
view using the Delete Key Frame  edit tool. This option can be used to delete the Start and End Key Frames; 

however, if only two Key Frames are present it will not be available.    

 l Specify the Key Frame Symbol Size, which is the size of the symbols representing the selected walkthrough path’s 
Key Frames in plan view. See Key Frames on page 1206.

Specify how the Camera Angles associated with each key frame are measured:     

 l Select Absolute to measure the Camera Angles relative to the plan’s X and Y axes.    

 l Select Relative to Path to measure the Camera Angles frame relative to the direction of the path at that location.

Note: When Relative Angles are used, a Camera Angle of 0° points 
in the direction of the Walkthrough Path. When Absolute Angles are 
used, 0° always points in the positive direction along the X axis.    

Specify how the Camera Heights associated with each key frame are measured:    

 l Select Absolute to measure camera height relative to the plan’s Z axis.    

 l Select Relative to Floor/Terrain to measure camera height relative to the floor or terrain at each Key Frame 
location.

 
Resolution

Control the size of the selected walkthrough's frames.    

 l Select a size from the drop-down list. If the Width or Height is modified below, the selected Resolution will be 
"Custom".

 l The current Width, based on the selected Resolution, is stated here. If you change this value, the selected Resolution 
will be "Custom".

 l The current Height, based on the selected Resolution, is stated here. If you change this value, the selected Resolution 
will be "Custom".
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  Walkthrough Options

 l Specify the Duration, or total length of the walkthrough video in seconds.

 l Specify the desired number of Frames per Second, between 1 and 100. A higher number results in a higher quality 
recording but also a larger file size.

 l In the Walkthrough Path Defaults dialog only, specify the Video Codec to use when recording walkthroughs. See 
Selecting a Codec on page 1219.

CAMERA PANEL

The settings on the CAMERA panel let you specify lighting, a Rendering Technique, and more. These settings are also found 
in the Camera Specification dialog. See Camera Panel on page 1116.

BACKDROP PANEL

The settings on the BACKDROP panel are also found in the Camera Specification dialog. See Backdrop Panel on page 1121. 

POLYLINE PANEL

The POLYLINE panel states the length of the path’s Perimeter. The Area and Volume of a walkthrough path will always be 
described as “Not closed”. See Polyline Panel on page 323.          

SELECTED LINE/ARC PANEL

The SELECTED LINE panel is available when the selected path is a spline or the selected edge is a line as opposed to an arc. 
See Line Panel on page 309.   

The SELECTED ARC panel is available when the selected path edge is an arc as opposed to a spline or line. See Arc Panel on 
page 318.   

See, too, Selected Edge on page 214 and Change Line/Arc on page 259.  

LINE STYLE PANEL

This panel is similar to the LINE STYLE panel in the Line Specification dialog. See Line Style Panel on page 310.         

LABEL PANEL

Walkthrough Path labels display in plan view when the “Polylines, Labels” layer is turned on and use the Text Style 
assigned to that layer.         

For more information, see Label Panel on page 712.         

 

Walkthrough Previews
Depending on the quality settings and length of a Walkthrough Path, it may take a considerable amount of time to 
record a walkthrough video. The Walkthrough Preview side window allows you to preview part or all of an existing 

walkthrough path to confirm that it meets your needs prior to actually recording it. Select View> Walkthrough Preview to 
open or close this side window. See Side Windows on page 17.
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You can also open or close this side window by selecting a Walkthrough Path and clicking the Walkthrough Preview  

edit button.

 
Active Walkthrough

Select the walkthrough path that you would like to see in the preview from the drop-down list. All walkthrough paths 
present in the current plan are listed, and are described using their Label.     

 l Click the Define button to open the selected path's Walkthrough Path Specification dialog. See Walkthrough Path 
Specification Dialog on page 1207.    

1211



Chief Architect Premier X14 Reference Manual - Walkthrough Previews

 
Preview

A preview of the selected walkthrough displays here. When a preview is not playing, the Current Frame displays.    

 l Click and drag in the preview window to adjust the Camera Angle and Tilt Angle of the Current Frame.

 l Click and drag the green slider bar to control which frame of the walkthrough displays in the preview pane. You can 
also click anywhere along the slider to move the bar to that location or use the Current Frame setting, below.    

 l The yellow bar at the top of the slider indicates the duration of the walkthrough and the location of the Start and End 
Frames selected below. Click and drag the handles at each end to move the Start and End Frames.    

 l Blue diamonds along the slider show the location of the selected walkthrough's Key Frames, defined below.    

 l Specify the Start Frame of the walkthrough video. This will be the first frame of the walkthrough video when it is 
recorded using Custom Frames to Record, and is Frame 1 by default. See Record Walkthrough Along Path on page 
1213.    

 l Specify the End Frame of the walkthrough video. This will be the final frame of the walkthrough video when it is 
recorded using Custom Frames to Record, and is the last frame of the walkthrough path by default.    

 l Specify the Current Frame, which displays in the preview pane above and can also be specified using the slider 
bar. The Current Frame cannot be located before the Start Frame. 

  Preview Controls

  Use Recording Quality shows the preview using the same level of quality as set on the CAMERA panel of the 
Walkthrough Path Specification dialog. This option is selected by default but may cause slow performance in 

the preview pane. See Camera Panel on page 1210.

  Use Standard Quality may improve performance if you encounter slowness in the preview pane. This option 
shows the preview using without shadows, bloom or reflections. In addition, Watercolor and Physically Based 

Renderings are shown using the Standard Rendering Technique. This setting is retained during the current program 
session but is reset when the program is relaunched.

  Create Camera View creates a camera view window using the location and angle of the current frame. 

  Jump to Previous Key Frame moves the preview back one Key Frame. Not available if the Current Frame is 
located before the Start Frame.

  Go to Previous Frame moves the preview back one frame.  Not available if the Current Frame is located 
before the Start Frame.

  Go to Next Frame advances the preview ahead one frame. Not available if the Current Frame is located after 
the End Frame.

  Jump to Next Key Frame advances the preview ahead one Key Frame. Not available if the Current Frame is 
located after the End Frame.

  Play Walkthrough Preview from Beginning plays a preview of the walkthrough from the Start Frame 
through the End Frame.

  Play Walkthrough Preview from Current Frame plays a preview of the walkthrough from the Current 
Frame through the End Frame.

  Record Walkthrough records a preview of the walkthrough from the Start Frame through the End Frame.

1212



Chief Architect Premier X14 Reference Manual - Recording a Walkthrough

 
Key Frames

Make adjustments to the selected walkthrough path's Key Frames. These settings are also found in the Walkthrough Path 
Specification dialog. See General Panel on page 1208.    

 l Click on a Key Frame in the list on the left to select and edit it.    

 l Specify the Floor that the selected Key Frame is located on.    

 l Specify the Time in seconds at which the selected Key Frame is found in the duration of the walkthrough. The 
Times of the walkthrough paths' first and final frames cannot be moved.    

 l Specify the Speed After, which is how fast the camera moves along the walkthrough path from the current Key 
Frame to the next, in feet per second. Not available if the last Key Frame is selected.    

 l Specify the Camera Angle at the selected Key Frame.    

 l Specify the Tilt Angle of the camera at the selected Key Frame.

The Camera Angle and Tilt Angle can also be adjusted by 
clicking and dragging in the preview pane, above.

 l Specify the Height of the camera at the selected Key Frame. You can specify where the Heights are measured from 
in the Walkthrough Path Specification dialog, which is accessible by clicking the Define button, above.    

 l Click the Delete button to remove the selected Key Frame from the path.

 
Walkthrough Preview Control Options

Click the Options   button at the bottom of the side window to specify what settings are presented as well as their layout.

 l Select Preview Pane to toggle the display of the Preview Panel that plays the walkthrough preview or shows the 
Current Frame

 l Select Key Frame Settings toggle the display of the Key Frames settings.

 l Select Horizontal Layout to position the Key Frames settings to the right of the other settings, or select or Vertical 
Layout to position the Key Frame settings below the other settings. The side window's shape does not adjust when 
you switch between layout options, so you may need to resize it by clicking and dragging its edges.

 

Recording a Walkthrough
There are two approaches to recording a walkthrough of a plan: using a Walkthrough Path, and recording frame by frame, 
directly from a camera view.   

RECORD WALKTHROUGH ALONG PATH

Once a Walkthrough Path has been drawn, you can use it to record a walkthrough video. See Creating Walkthrough Paths 
on page 1205. 

Depending on the quality settings and length of a Walkthrough 
Path, it may take a considerable amount of time to record a 

walkthrough video. You can preview a walkthrough before recording it. 
See Walkthrough Previews on page 1210.
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To record a walkthrough along a path
 1.  In plan view, select a Walkthrough Path.          

 2.  Click the Record Walkthrough Along Path  edit button.         

 3.  In the Walkthrough Options dialog, specify the desired Quality, Resolution, Rendering Options, Video Codec, and 
the name and save location of your walkthrough file, then click OK.         

Note: You can specify your preferred settings, including Key Frame 
Symbol Size, Compression, and Video Codec in the Walkthrough 
Path Defaults dialog. See Default Settings on page 76.

 4.  When you click OK, a camera view will open, showing the progress as the walkthrough is recorded.         

To cancel the recording as it is being created, press the ESC key on your keyboard.         

WALKTHROUGH OPTIONS DIALOG

Most of the settings in this dialog are also found in the Walkthrough Path Defaults dialog.         
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Camera and Backdrop

Click the Define button to open the Record Walkthrough Camera Options dialog, where Rendering Technique, lighting, 
backdrop, and more for the current walkthrough can be specified. The settings in this dialog are also found in the Camera 
Specification dialog. See Camera Specification Dialogs on page 1116.              

 
Resolution

Specify the size of the walkthrough’s frames.              

 l Select a resolution from the drop-down list. If you modify the Width or Height below, “Custom” will become 
selected.         

 l The current Width, based on the selected Resolution, is stated here. If you change this value, the selected Resolution 
will become “Custom”.          

 l The current Height, based on the selected Resolution, is stated here. If you change this value, the selected Resolution 
will become “Custom”.          

 l Check Retain Aspect Ratio to retain the original ratio between the frame Width and Height. If you modify either 
value while this is unchecked, the walkthrough may appear distorted.          

  Walkthrough Options

 l Specify a Compression percentage between 0 and 100. A value of 0 gives the highest quality images and largest file 
sizes.      

 l Specify a Duration Along Path, in seconds.       

 l Specify the desired number of Frames Per Second, between 1 and 100. A higher number results in a higher quality 
recording but also a larger video file.       

 l Select a Video Codec from the drop-down list. See Selecting a Codec on page 1219.

 
Frames

This setting is retained between sessions and is also global, affecting all walkthroughs in all plan files.      

 l Specify the Frames to Record by choosing either All or a Custom range, which is set in the Walkthrough Preview 
side window. See Walkthrough Previews on page 1210.

 l The Total Frames Along Path, Total Frames to Record, and Total Recording Duration display for reference.

  Save to Disk

 l Check Save to Disk to save the walkthrough file to the local hard drive. When this is unchecked, a local copy of the 
file is not created. See Saving, Exporting, and Backing Up Files on page 39.     

 l Click the Browse button to specify a name, save location, and file format for the walkthrough file in the Save Video 
As dialog.  The available file formats may vary, depending on which codec you selected.
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  Save to Chief Architect Cloud

 l Check Save to Chief Architect Cloud to save the walkthrough file to your Chief Architect Cloud Account.     

 l Select Create New to upload a new walkthrough file or select Replace Existing to replace a walkthrough file 
already in your Cloud Account with a new one.

 l Type a short, descriptive Name for the walkthrough file.     

 l Type a brief Description of the walkthrough.

When you click OK, the program will begin recording the walkthrough video. If you selected Save to Chief Architect 
Cloud, you may first be prompted to log in to your Chief Architect Cloud Account. See Chief Architect Account Login on 
page 1223.         

FRAME BY FRAME WALKTHROUGHS

You can also create a walkthrough by recording it frame by frame. Although time-consuming and lacking many of the 
options that a Walkthrough Path provides, creating a walkthrough in this manner lets you see exactly what is being recorded 
as you record it.          

To record a walkthrough frame by frame
 1.  Create a camera view. This view is the first frame of the walkthrough.         

 2.  While the camera view is active, select 3D> Walkthroughs> Record Walkthrough .          

 3.  In the Walkthrough Options dialog:          
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 l Select a Frame Rate between 1 and 100. The value entered is the number of frames per second.          

 l Select a Compression Percent between 0 and 100. A value of 0 gives the highest quality images and the largest 
file size.         

 l Select a Codec from the drop-down list. See Selecting a Codec on page 1219, below. 

 l Check Save to Disk, then click the Browse button to specify a name and save location for the walkthrough file. 
See Exporting Files on page 41.

 l Check Save to Chief Architect Cloud to save the walkthrough file to your Chief Architect Cloud Account. See 
Chief Architect Account Login on page 1223.

 l Select Create New to upload a new walkthrough file or select Replace Existing to replace an existing 
walkthrough file in your Cloud Account with a new one.

 l Type a short, descriptive Name and a brief Description for the file.

 l Click OK.         

 4.  Use the camera movement tools to navigate the view. Each time the screen redraws, it is recorded as the next frame 
in sequence. See Editing 3D Views on page 1105.         

 5.  To move the camera without saving a view, select 3D> Walkthroughs> Pause Recording  to temporarily stop 

recording.          
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 l You can then select 3D> Walkthroughs> Save Frame               button to control what views are saved.         

 l You can start recording again by selecting Pause Recording               once more.         

 6.  When the walkthrough sequence is complete, select 3D> Walkthroughs> Stop Recording  or close the view.         

Note: Zooming in and out and using the scrollbars does not change the 
viewpoint and does not produce a frame for the walkthrough.

If you resize the current view window while recording a walkthrough, the program will stop recording.          

SELECTING A CODEC

A codec is a utility that compresses and decompresses media files, and is used when both recording and viewing videos 
such as walkthroughs. When you record a walkthrough in Chief Architect, you can choose which of the codecs installed on 
your system you want to use. This selection is universal and is retained between program sessions: when you choose a 
codec in the Walkthrough Path Defaults or either Walkthrough Options dialog, it will become selected the next time you 
open either dialog, even if you do so in another plan.          

“Windows Media Video 9” is the default codec in the Windows version and “H.264”, in the Mac version; but any codecs 
installed on your system will be available to use.          

To choose the codec that best suits your needs, it is a good idea to create a test walkthrough using each of the codecs 
installed on your system to see how well their walkthrough quality and file compression meet your requirements. Note that 
your choice of codec may affect the file formats in the Save Video As dialog.         

For more information about codecs, visit chiefarchitect.com.

 

Creating VRML Files
VRML (Virtual Reality Modeling Language) is a 3D file format that can be used by various “walkthrough” viewers, 
as well as other rendering packages. 

VRML files use the .wrl file format and contain an entire 3D model, including lighting information. Images and textures 
can also be referenced. You can post a .wrl file and its associated image and texture files to the web or e-mail them to a 
customer. 

VRML files are often created from rendered views so that lighting and textures are used; however, you can export from a 
Vector View if you wish. See Editing 3D Views on page 1105.

The entire model is exported, but the starting point for the walkthrough is defined by the camera location at the time of 
export. 

When a camera view or overview is active, select File> Export> Export VRML . The VRML Export Options dialog 

opens.
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VRML EXPORT OPTIONS DIALOG

 
Camera Field of View

Define the Camera Field of View. Standard most closely corresponds to the default Chief Architect camera view. The 
other options generate a wider field of view.

 
Textures/Images

Specify how Textures/Images are exported. 

 l Check No Textures Exported to prevent texture files from being exported with the .wrl file. If textures are 
exported, the texture files must be in the same folder as the .wrl file.

 l Check Copy Images to Export Folder if you plan to share the VRML with others. This copies texture bitmaps with 
the .wrl file so that they render correctly when exported.

 
Lighting

Specify how Lighting is exported.

 l Turn off Ambient Lights turns off the default lights that are used to light a scene.          

 l Turn off Fixture Lights turns off the default lights that are generated for fixtures and used to light a scene.          

 l Night Sky/Ground Colors darkens the ground plane and sky to create a nighttime appearance.          

  Options

 l Walk Through Surfaces allows you to walk through walls and closed doors from room to room, instead of stopping 
when you reach a wall.          

 l Run Default VRML Viewer starts the .vrml viewer and opens the new .vrml file as soon as it is generated.          

Once the general parameters have been selected, click OK. Name the .wrl file and save it in the desired folder and click 
Save.          
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It is best to keep all .vrml files in a folder separate from your 
normal Chief Architect files, since all textures used in the model 

also export to the same folder. This could add a significant number of 
files, creating potential organization problems. 

VRML USE OF TEXTURE AND IMAGE FILES

In order for textures to be rendered correctly, the texture and image files associated with an exported VRML file must be in 
the same directory as the .wrl file.           

VRML files do not support the use of .bmp textures or images. Instead, compressed file formats such as .gif, .png, or .jpg 
files must be used.           

If you wish to use custom textures or images in your VRML file, you have two options:          

 l Make sure that they are saved in a format other than .bmp before you bring import them into Chief Architect. This is 
the recommended option.          

 l Create a .gif file with the same name and in the same directory as the .bmp file. When you export the .wrl file, Chief 
Architect automatically substitutes the .gif for the .bmp file. Whenever possible, you should use a supported file 
format instead of using .bmp and .gif pairs.          

For more information about .vrml players, visit chiefarchitect.com.         
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Chapter 36
 

Importing and Exporting

Importing is the process of opening a file that was produced in a different program in Chief Architect. Exporting, on the 
other hand, is the process of saving information in a Chief Architect file to a format that can be read by another program. 

Chief Architect allows you to import and export a variety of information from and to other applications. This chapter 
focuses on importing and exporting 2D .dwg/.dxf files and a variety of 3D file formats. Other importing and exporting 
options are described in the chapters in which those objects or settings are discussed. See Pictures, Images, and 
Walkthroughs on page 1180.
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Chief Architect Account Login
Your online Chief Architect Account allows you to take advantage of a variety of valuable resources including catalog 
downloads, license management, and technical support. See Creating a Chief Architect Account.

In order to import a drawing from the Room Planner mobile app, you must first log in your Chief Architect cloud account. 
See Import Room Planner File on page 1226.         

If you try to do this while you are logged out of your cloud account, the Chief Architect Account Login dialog will open, 
giving you an opportunity to log in.         

You can also log into or out of your online account at any time by selecting Help> Log in to Chief Architect Account or 
Help> Log out of Chief Architect Account.         

CHIEF ARCHITECT ACCOUNT LOGIN DIALOG

In order to import Room Planner files, you should enter the same E-mail Address and Password that you used to save the 
drawing to the cloud in Room Planner.         

 

Export Chief Architect 3D Viewer File
The Chief Architect 3D Viewer allows a model created in Chief Architect to be viewed in either:         

 l A web browser on a computer.              
 l The 3D Viewer app on a mobile device.             

In order to export a Chief Architect 3D Viewer file, you must be logged in to your Chief Architect cloud account.         

For more information about the Chief Architect 3D Viewer, visit chiefarchitect.com.         

To export a file to the cloud for viewing with either option, select File> Export> Export Chief Architect 3D Viewer File 
 while a 3D view is active.

With the exception of Rope Lights, any light sources that are On in the current view, as well as ambient light, will be 
exported along with the model. See Lighting on page 1133. 

Note: Any 3D models referenced using the Reference Display in the 
current plan cannot be exported to the 3D Viewer. Only the model saved 
in the current plan file is included in the export. See The Reference 
Display on page 69.
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3D VIEWER EXPORT OPTIONS

 l Select Create New Model to export a new model without affecting any previously exported files.         
 l Select Replace Existing Model to select a previously-exported model in the list and replace it with the model being 

exported now.          
 l To select an existing model to replace, click on its line item in the table.          

The columns in the table are sortable: click a column header to sort all line items in the table by that column. An arrow 
above the column indicates that it is being used to sort the table, and in which direction it is being sorted.

When you click OK, the Export 3D Viewer File dialog opens, where you can specify the exported model’s name, 
description, and other details.         

EXPORT 3D VIEWER FILE DIALOG

 l The Name of the current plan file populates this field by default. Specify a different name for the exported 3D Viewer 
file if you would like.          

 l Type a brief Description of the model.         
 l Click the Cameras button to open the Select Cameras to Export dialog and specify which saved cameras to export 

with the model. See 3D Views on page 1080.         
 l Click the Notes button to open the Select Notes to Export dialog and specify which saved cameras to export with the 

model. See Select Notes to Export Dialog on page 1225, below.
 l The Surface Count and Texture Size display here for reference. Large Surface Count and/or Texture Size values can 

impact performance in the app.         

To reduce Surface Count and Texture Size, consider turning off 
unnecessary layers in the current 3D view before exporting. See 

Layers on page 180. 

When you click OK, the 3D model is exported using the layer settings in the camera view that  was active when the model 
was exported.          
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On the 3D Viewer page, you can also choose to share an exported model with someone so that it can be opened in a 3D 
Viewer page or in the 3D Viewer mobile app.          

SELECT CAMERAS TO EXPORT DIALOG

 l The Camera Name of each saved Perspective Camera and Overview in the plan is listed in a table. The camera that is 
active when you export the model, if listed, is followed by “(source)”.              Floor Overviews can be exported; however, 
they behave like Full Overviews in the 3D Viewer.          

 l In the Include column, click to add or remove a check mark for each camera that you would like to export. By default, 
only cameras of the same type, on the same floor, and using the same layer set are Included.          

 l In the Initial View column, add a check mark for the camera that you would like to be active when the model is 
opened in 3D Viewer.         

 l Click the Include All button to export all saved cameras with the model. A large number of saved cameras may slow 
down the interface of the 3D Viewer app.         

 l Click the Include None button to export no saved cameras with the model. When the model is opened, an unsaved 3D 
Overview will be the initial view.         

The columns in the table are sortable: click a column header to sort all line items in the table by that column. An arrow 
above the column indicates that it is being used to sort the table, and in which direction it is being sorted.

SELECT NOTES TO EXPORT DIALOG

Notes placed in plan and camera views in Chief Architect can be exported with a 3D Viewer model. See Notes, Note Types, 
and Note Schedules on page 542.          

 l Each Note’s Title is listed in the first column. This information corresponds to the Text Above and Below Line in the 
Note Specification dialog. In the 3D Viewer, this information is used as the note’s Title. See Note/Callout Panel on 
page 545.          

 l The Description of each note is listed in the second column. This information corresponds to the Schedule Text in the 
Note Specification dialog. In the 3D Viewer, this information is used as the note’s Description.           

 l Click in the Include column to add or remove a check mark for each Note that you would like to export.           
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 l Click the Include All button to export all Notes with the model.           
 l Click the Include None button to export no Notes with the model.          

The columns in the table are sortable: click a column header to sort all line items in the table by that column. An arrow 
above the column indicates that it is being used to sort the table, and in which direction it is being sorted.

 

Import Room Planner File
Select File> Import> Import Room Planner File, then select and download a Room Planner file from the cloud. 
See Chief Architect Account Login on page 1223.

Files created in Room Planner version 2 and newer can be imported into Chief Architect X14.

Note that the exterior walls in an imported Room Planner drawing will inherit their thickness and other properties from the 
Exterior Wall Defaults dialog in the current plan, while interior walls will retain the thickness that was set in Room Planner. 
See Exterior and Interior Wall Defaults Dialogs on page 348.

Unless a custom ceiling height has been specified in Room Planner, rooms in an imported file use the Default ceiling height 
set in the Floor Defaults dialog. See Floor Level Defaults on page 419.

By default, window sizes in imported Room Planner drawings are measured from the outside of their frames, just as their 
Height and Width are in the Window Specification dialog. If you prefer, you can specify that windows are measured from 
the inside of the frames in the Preferences dialog. See General Panel on page 107.    

Visit roomplanner.chiefarchitect.com for more information about the Room Planner mobile app.

 

DXF vs DWG File Formats
.dwg is the native AutoCAD® file format. Originally a proprietary format, it is now widely used with many different 
products.         

.dxf (Drawing eXchange Format) is a standard file format created by Autodesk for the transfer of data between other 
programs.         

Many design programs can read and write .dxf and .dwg files. Both formats interpret data as CAD objects such as lines, 
polylines, and circles. Both formats can also contain 3D data which can be imported into Chief Architect, as well.

Binary .dxf format is another related file format. It is easier for computers to read, is more accurate, and occupies less disk 
space and regular .dxf files. When exporting, however, bear in mind that not all applications support binary .dxf.          

 

Importing 2D Drawings
2D drawings are imported by reading entities from a .dxf or .dwg file and creating the equivalent CAD objects in Chief 
Architect.          

Chief Architect X14 can import 2D .dxf or .dwg files compatible with AutoCAD® through version 2023. See Import 
Drawing Assistant on page 1228.       

A .dxf or .dwg file can be imported into plan view, a CAD Detail, or a cross section/elevation view.          

Only drawings created in AutoCAD®’s Model Space can be imported directly into Chief Architect. Entities drawn on the 
first page of Paper Space are imported as a CAD block and can be inserted into a drawing from the CAD Block 
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Management dialog. See CAD Block Management on page 336. Entities drawn on subsequent pages of Paper Space are not 
recognized.          

External references (xrefs) are not recognized by Chief Architect, either.         

In general, all Z coordinates are mapped to zero. If an entity in an imported drawing has thickness, Chief Architect ignores 
it.         

SUPPORTED ENTITIES

The following is a list of the entities that are imported and how they are converted. All other entities are ignored:          

 l Lines - Both 2D and 3D lines.         
 l Circles - Fully supported in 2D.         
 l Arcs - Fully supported in 2D.         
 l Ellipses - Fully supported in 2D.          
 l Spline entities - Fully supported as 2D polylines.         
 l Polylines and Lightweight Polylines - Polylines are imported as polylines. Bumps are converted to arcs. Line widths 

are ignored.         
 l Lightweight Polylines - Fully supported in 2D.         
 l Points - Points are not supported unless the layer they are on is converted to Elevation Data. See Importing Elevation 

Data on page 1281.         
 l Text and Multi-line Text - Both are imported as Rich Text and mapped to the Text layer. Multi-line text objects 

retain their original width. The first font in a multi-line text object is applied to the entire object. If that font is 
unavailable, Arial is used.         

 l Multileaders - Fully supported in 2D.         
 l Unicode - Fully supported in text objects only.         
 l Blocks and Block Inserts - A block is a named group of CAD entities that have been joined together to behave as a 

single object. A block insert is a reference to such a block. Blocks are loaded by name. If a duplicate name is found, 
you can specify whether a block is imported under a new name, replaces an existing block or simply uses the existing 
block of the same name.          

 l Hatch entities - If Import Hatch entities is selected on the SELECT FILE page of the Import Drawing Assistant for a
 .dwg file, Hatch patterns are imported as a CAD block consisting of solid black filled polylines.          

 l 2D Solids (Not ACIS Solids) - Fully supported in 2D.          
 l Solids - A solid is a 3 or 4-sided filled area. These are imported as 2D faces.         
 l 3D Faces/Polyface Meshes - A 3D face has its Z coordinate mapped to zero, and imports as a polyline.         
 l Dimensions - Rotated, aligned and 3-point angular dimensions are supported. All other dimension types are imported 

as lines and text rather than functioning dimensions.             

CAD blocks containing dimensions as text must be exploded before the text can be edited separately. For more on 
exploding, see CAD Blocks on page 333.

 l Attributes - Attributes are text objects associated with other items, like blocks. These are imported as text objects at 
the appropriate location but the association with the original object is broken.         

 l Line Styles - Line styles are not imported. Instead, if a style of the same name displays in the Chief Architect line 
styles, that line style is used. Otherwise, a solid line style is used.          

 l Layers- You can specify which layers in the imported drawing to import into your Chief Architect file. You can also 
choose how you wish to map drawing layers to layers in the destination file. See Layers on page 180.         
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LAYERS

There can be some confusion between importing a layer and mapping a layer; the distinction, however, is important.         

You can control which objects in a drawing are imported by choosing to import the layers they are on.         

Once you have elected to import a layer, you can then specify how you would like to map it in the Chief Architect drawing. 
You have three options:         

 l You can map all layers in the imported drawing to a single Chief Architect layer.         
 l You can map all layers in the imported drawing to Chief Architect layers of the same name. The program will create 

those layers if they do not already exist.         
 l You can use Advanced Layer Mapping to individually map each imported layer to a Chief Architect layer.         

 

Import Drawing Assistant
A 2D .dxf or .dwg file can be imported into any orthographic view: plan view,cross section/elevation views, CAD 
Details, and layout. For information about supported entities, model and paper space, and other considerations, see 

Importing 2D Drawings on page 1226.       

To import a 2D drawing file, open the view in which you would like to place the drawing and select File> Import> Import 
Drawing (DWG/DXF) to open the welcome page of the Import Drawing Assistant. Click Next to continue.         

You can also launch the Import Drawing Assistant by dragging a .dxf/.dwg file from an operating system window into the 
Chief Architect window.         

CAD Details are an excellent place to import and organize CAD 
drawings. See CAD Details on page 340.

If the file you are importing is password protected, you will be prompted to enter the password before continuing.         

SELECT FILE
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Click the Browse button to select the file that you wish to import. When a file is selected, its full pathname displays to its 
left. The directory containing the last file selected using the Import Drawing Assistant displays here otherwise. If the 
pathname is not a valid dxf/.dwg file, this text will display in red. 

Note: If the file you are importing is password protected, you will be 
prompted to enter the password before continuing.

 
 

If you want to convert lines with shared end points to polylines and/or boxes, check the appropriate options. Polylines are 
not affected by these settings, nor are lines that do not share end points.             

 l Check Polylines to import lines with shared end points as polylines.          

 l Check Boxes to import lines with shared end points that form a closed rectangular shape as boxes.          

 
 

Specify how to treat CAD blocks associated with the selected drawing.         

 l Select Import all CAD blocks to include all CAD blocks associated with the file being imported whether or not 
they are in use.              See CAD Block Management on page 336.

 l Select Only import CAD blocks if they are referenced in the drawing to reduce the volume of transferred data.          

 
 

Check Import Hatch entities to import areas of hatching as solid-filled polylines.         

Click Next to load the file into memory so that Chief Architect can present information about the contents of the file. This 
can take a while for larger files.         

SELECT LAYERS
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A list of the layers found in the imported file and information about each layer displays in this table. See Layers on page 
180.         

 l In the Layer column, check the box to the left of each layer name to specify which layers you want to import. 
Layers with checked boxes are imported; those with unchecked boxes are not.          

 l Layers that were Visible in the original program are checked by default. You can include a layer that is not visible 
by checking the box to the left of its name.          

 l Layers that were Frozen in the original program are not checked by default. You can include a frozen layer by 
checking the box to its left.         

 l If a layer is set to Convert To a Terrain Perimeter or Elevation Data, it will be indicated in this column provided 
that you are importing into plan view.         

 
 

Click Select All to check the box to the left of all layer names in the table. Click Clear All to clear the check box to the left 
of all layer names in the table.

 
 

The Convert To drop-down list allows you convert the data on any layer into a Terrain Perimeter or Elevation Data. See 
Terrain Perimeter on page 1250 and Importing DWG/DXF Elevation Data on page 1287. Only available when importing 
into plan view.         

To convert a layer to a Terrain Perimeter or Terrain Data, click on its name in the table and then select an option from the 
Convert To drop-down list. The option you choose will then display in the Convert To column in the table.          

Note: If an open polyline is converted into a Terrain Perimeter, the 
program will draw an additional edge to close the gap. 

LAYER MAPPING

The Layer Mapping page lets you control how layers in the imported drawing are mapped into the destination file.          
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The simplest option is select A single layer in Chief Architect and assign all objects in the imported drawing to that layer. 
Original layer attributes are lost, but line color, style, and weight are preserved on a per object basis.         

 l Select a layer from the drop-down list or click the Define button to open the Layer Display Options dialog and 
specify a layer and its properties. See Layer Display Options Dialog on page 183.         

 
 

The second option is to map the layers in the drawing to Chief Architect layers by name. Layers are created in the 
destination file with the same names as those listed on the Select Layers window of the Import Drawing Assistant, and the 
imported CAD objects are placed on those layers.         

 l In combination with the second alternative, you may choose to import all attributes for each layer into the current 
Layer Set, or import no attributes at all.         

 
 

The third option is to map each layer individually with complete control of all layer mapping options. Selecting the third 
option opens the Advanced Layer Mapping page.         

ADVANCED LAYER MAPPING

If you select the Advanced Layer Mapping option, the Advanced Layer Mapping page displays, allowing you complete 
control of how all imported layers are mapped.          
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A list of the layers found in the imported file and the layers in Chief Architect that they are mapped to display in this table.         

 l The original name of each DWG/DXF Layer is found in the first column.         

 l The name of the Chief Layer that each imported layer is mapped to is listed in the second column. The initial Chief 
Layer selections depend on which option was selected on the Layer Mapping page. See Layer Mapping on page 
1230.         

 l If a Chief Layer does not already exist in the destination plan or layout file, it will be listed as “New” in the third 
column.         

 
 

When a row in the table above is selected, the Chief Layer options become active. Select multiple entries by holding down 
the Shift key.         

 l If the layer in the selected row is mapped to an existing Chief layer, it will display in the drop-down; if not, the drop-
down will be blank.         

 l Select a layer already present in the destination plan or layout file from the drop-down list.          

 l Click the Browse button to open the Layer Display Options dialog. See Layer Display Options Dialog on page 183.         

Click Next to continue.         

DUPLICATE CAD BLOCKS

If one or more CAD blocks in the imported file have the same name as a CAD block in the destination plan or layout, the 
Duplicate CAD Blocks page will display. See CAD Blocks on page 333.         

There are four options. The first three apply to all duplicate CAD blocks in the plan.          

 l The first choice is to have the program automatically generate unique names for each duplicate. For instance, if the 
original file’s name is “blockname,” the program gives the new block a name like “blockname_Copy_1”.         

 l The second option is to replace the block already in the plan with the duplicate being imported. This option is not 
recommended, as every instance of the CAD block in the plan will be replaced.         

 l The third is to keep the block that already exists in the plan and discard the duplicate being imported.         
 l Select the fourth option to open the Advanced Duplicate CAD Blocks page and manage each duplicate individually.          

Click Next to continue.          
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ADVANCED DUPLICATE CAD BLOCKS

If you chose the fourth option on the Duplicate CAD Block page, the Advanced Duplicate CAD Block page displays, 
allowing you to manage each duplicate CAD block individually.          

Click on a CAD block name in the list of Duplicate Names. Select multiple names by holding down the Shift key.         

Click one of the three active buttons in the center of the dialog to specify how the selected block(s) are to be treated.          

 l Click Auto Name to have the program automatically generate a unique name for the selected CAD block. The 
duplicate’s name is the same as the original with “_Copy” appended to the end.          

 l Click Replace to replace the existing CAD block in the destination file with the CAD block listed here. This option is 
not recommended, as all instances of the CAD block are replaced.         

 l Click Use Existing to keep the CAD block already in the destination file and discard the CAD block listed here.         

Review your choices in the tables at the right.         

 l To remove a CAD block from a field on the right, select it and click the Remove button.          

Click Next to continue.          

DRAWING UNIT
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Select a unit of measurement from the drop-down list. Selecting the correct unit helps ensure that your imported drawing is 
accurately sized.         

Note: During the import process, Chief Architect defaults to inches or 
millimeters. If you are importing a site plan or topo prepared by a 
surveyor, or importing a metric drawing into an U.S. Unit plan (or vice 
versa), you may need to change units. 

If the file being imported was drawn at a scale other than 1:1, you can compensate for this scaling by creating a custom 
unit of measurement and specifying it here. See Unit Conversions Panel on page 113.         

 
 

Specify how dimensions are imported.

 l Select Import as dimensions where possible to import dimensions as Chief Architect-supported dimension lines.         

 l Select Import as CAD blocks to import dimensions as CAD entities that are not recognized by Chief Architect as 
dimensions.         

 
 

Check Move drawing to the origin to place the drawing at 0,0. When this is unchecked, it is imported to the same location 
as it was drawn in the original application. See 3D Drafting on page 12. 

IMPORT COMPLETE

When a .dxf/.dwg file is imported into Chief Architect, all of its components are selected as a group. The selection set has 
Move and Rotate edit handles available for relocating the entire drawing, as well as a variety of edit tools. Once another 
object or tool is selected, the drawing components are no longer group-selected.          

If you do not see your imported drawing, select Window> Fill Window , as it may have been placed at a location not 

currently visible on screen. When the drawing can be seen, move your mouse pointer over it and note its coordinates in the 
Status Bar. If any coordinate value has more than six digits,              use the Transform/Replicate Object  edit button to move 

it closer to the origin. See Transform/Replicate Object Dialog on page 269.         

Imported CAD objects can be selected and edited just like objects that were drawn in the program. See Editing Objects on 
page 207.         

The CAD to Walls tool can be used to convert imported CAD 
lines in plan view into doors, windows, walls and railings. See 

CAD to Walls on page 387. 

 

Exporting 2D DXF/DWG Files
Line-based 2D files can be exported from Chief Architect in both .dxf and .dwg file formats. You can specify the version of 
AutoCAD® to export to. Compatibility with other software may vary.         

Custom line styles created in Chief Architect Premier cannot be exported. When exported to .dxf/dwg, they are replaced by 
a solid line style, although the line weight and color are retained. See  Line Styles on page 200.          

There are two ways to export a 2D drawing file in Chief Architect: Export Current View and Export All Floors.         

1234



Chief Architect Premier X14 Reference Manual - Exporting 2D DXF/DWG Files

EXPORT CURRENT VIEW

To export the currently active plan view, CAD Detail, or 3D view, select File> Export> Current View 
(DWG/DXF).          

Bear in mind that Orthographic views are drawn to scale and will produce a 2D drawing that can be accurately dimensioned. 
Perspective views, on the other hand, are not scaled and do not produce drawings that can be dimensioned accurately. See 
Perspective and Orthographic Views on page 1081.

EXPORT ALL FLOORS

To export the plan view for all floor plans simultaneously, select File> Export> All Floors  (DWG/DXF) from any 
floor of the plan. The floor plans are exported to a single .dxf or .dwg file.         

If you choose to export all floors, the file will contain all floors superimposed on each other. Upon export, each layer in 
your Chief Architect drawing is divided into separate layers: one for each floor. For example: “Electrical-2” contains objects 
on Floor 2 that were originally on the “Electrical” layer.         

You can use the CAD Detail from View tool to automatically 
create a 2D line drawing from a 3D Vector View. See CAD 

Detail from View on page 341. 

EXPORT DRAWING DIALOG

 
AutoCAD® File Format Options

.dxf and .dwg files created by Chief Architect can be compatible with a variety of AutoCAD® versions. Specify which 
version from the drop-down list.         
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Layer Options

The Layer Options settings allow you to control the layers associated with the file being exported. See Layers on page 180.
         

 l Select a Layer Set to for the drawing being exported. See Layer Sets on page 186. Not available in layout files.          

 l Click the Define to open the Layer Display Options dialog and modify the selected Layer Set. Not available in 
layout files.          

You can create a custom layer set to accommodate desired 
naming conventions or display attributes. 

 l Split Wall Assemblies Into Layers - The lines that represent wall layers can be exported onto different layers, 
allowing them to be displayed separately. See Wall Type Definitions on page 388.             

 l Select Export Only Displayed Layers to export only those layers that are displayed on screen. This is what always 
occurs when exporting from layout, but is not an available option in layout files.          

 l Select Export all used and named layers to export all layers that either have something on them or have a layer 
name specified. Not available in layout files.          

  Other Options

 l Scaling Unit - Select the unit of measurement to be used. For best results, choose inches or feet for U.S. Unit plan or 
layout files, or metric units for metric files. See Dimension Preferences and Defaults on page 455.          

 l Uncheck Create Associative Dimensions to export dimensions as simple CAD entities that are not recognized 
dimensions by other programs. Associative dimensions are recognized by AutoCAD® and many other CAD 
programs. 

When exporting a layout page, it is often best to uncheck this box.    

 l Check Export Pattern Lines to export pattern lines. Pattern lines are exported as normal CAD lines.          

 l Check Export Filled Areas to export filled areas as AutoCAD® 2D solid entities.

 l Check Export AutoCAD® Index Colors to automatically map all colors used in the drawing to the closest 256 
AutoCAD® Index Color (ACI). Black (RGB 0,0) and white (RGB 255,255,255) are mapped to ACI 7. When 
unchecked, colors are exported using RGB colors.           

Dimension lines using non-default               primary or secondary formatting will lose their changes and will use the default format
(s) upon export.    

When you are satisfied with your selections, click the Export button to save the exported file as either a .dwg, .dxf, or 
binary .dxf file.           

Note: Binary .dxf is easier for computers to read, is more accurate, and 
occupies less disk space, but some applications do not support binary 
.dxf. 
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Additional 2D Export Information
The export process converts high level Chief Architect objects (doors, windows, etc) into simple, CAD-based objects (lines, 
arcs, etc). Chief Architect exports all data to AutoCAD®’s Model Space.          

SUPPORTED ENTITIES

The following entity types are currently supported for 2D export:         

 l Line - The simplest entity. In AutoCAD®, lines are 3 dimensional with the Z coordinate set to zero.         

 l Arc - Arcs have a start angle, end angle and radius.          
 l Circle - Fully Supported.         
 l Multi Line Text - If exporting to an AutoCAD® release that supports multi-line text, Chief Architect writes the file as 

multi-line text. If exporting to a version that does not support multi-line text, the file is written as simple text.          
 l Unicode Text - Fully supported.         
 l Polylines - Polylines are a collection of points with lines or arcs connecting them. Chief Architect supports both lines 

and arcs. Arcs are referred to as bulges in AutoCAD®.         
 l Block Insert - A block insert is a reference to a block, which is a named collection of entities. A block can also 

contain block inserts.          

DIMENSIONS

Aligned, rotated, and angular dimensions can all be exported. CAD blocks containing dimensions as text must be exploded 
before the text can be edited separately. See CAD Blocks on page 333.

Dimensions with text added using the Add Additional Text  tool are not supported when exported to .dxf/.dwg. When 

exported, they are converted to text and CAD lines. See Add Additional Text on page 490.           

Each dimension has an associated block containing a representation of the dimension as it is drawn in Chief Architect. It 
also contains all the data to recreate that information.         

 l When an exported dimension is modified in AutoCAD® or other CAD program, its appearance changes.          

 l Chief Architect does not support arrowhead styles or fonts.         
 l Three kinds of dimensions are generated: Aligned, Rotated and 3 Point Angular.         
 l Please refer to AutoCAD® documentation for more information.         

Note: Uncheck “Use Associative Dimensions” in the Export Drawing 
File dialog if the CAD program you are using does not support 
AutoCAD® Associative dimensions. See Export Drawing Dialog on page 
1235.

LAYERS

Layers in other systems are similar to Chief Architect layers, but there are some subtle differences. Layer information is 
mapped as follows:         

Chief Architect Other Systems

Name Name
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Chief Architect Other Systems

Color Nearest AutoCAD® Color. Chief Architect uses the 
default AutoCAD® color table to determine this 
mapping.

Display On

Size Line Weight. In AutoCAD®, line weights are 
determined by a table of mm line widths. Chief 
Architect maps to the closest match in this table 
based the current view’s Line Weight Scale. See 
Drawing Sheet Setup Dialog on page 1372.

Style Line type

Lock Lock

LINE TYPES

A line type, or line style, is used by layers and entities to determine how lines are drawn. Chief Architect line types installed 
with the program are supported on export; custom, user-created line styles, however, are not. See  Line Styles on page 200.         

 

3D Data Import Requirements
Importing a symbol that can be used by Chief Architect is a relatively simple process that begins with previously created 3D 
data. This 3D data often comes from a program other than Chief Architect. If you use another 3D modeling program to 
create the 3D data, be aware of the following requirements before attempting to create symbols.

Chief Architect does not provide support for any third party 
software.

There are a number of requirements that must be met before any 3D data can be used to create a symbol in Chief Architect 
Premier:

 l The 3D data must be stored in a standard Drawing Exchange File (.dxf), AutoCAD® Drawing (.dwg), object (.obj), 
3D Studio® Mesh (.3ds), stereolithography (.stl), COLLADA (.dae), or SketchUp version 2021 and prior (.skp) file 
format. If you have 3D data in another format, you must convert it into one these formats first.

 l Geometry and material information stored in .3ds files are imported; cameras and lights are not.
 l The 3D model must be composed of 3D DWG or 3DSOLID solid entities, or face data. Faces are typically referred to 

as 3D faces, polygonal faces, or poly meshes. Other types of entities such as lines, curves, circles, polylines, and free 
form surfaces can exist in the file but are not imported when the symbol is created. This is true for all 
(.dxf/.dwg/.obj/.3ds/.skp) file types.

 l The face data should be assigned to different layers so that you can map them to the correct materials when viewing 
them in 3D. It is helpful to name your layers using a convention that identifies that materials should be assigned to 
each sub-component.

 l Pay attention to the origin and orientation of the 3D data when designing symbols. Chief Architect allows some 
adjustment when creating the symbol, but it is easier to build the 3D data correctly before importing it into Chief 
Architect. For more information about defining the origin, see Symbol Origin on page 1003.

 l If a symbol with faces that have more than four vertices is imported, the faces are truncated, resulting in an object that 
appears to have holes. The best remedy is to re-export the model from the original application using only triangular or 

1238



Chief Architect Premier X14 Reference Manual - Importing 3D Symbols

quadrilateral faces.
 l Chief Architect does not support grouped objects in symbols imported from .3ds files. 

SURFACE NORMALS

If you use third party software to create a .dxf/.dwg/.obj/.3ds./skp file that will be imported as a symbol, you should be 
familiar with the concept of surface normals.

A surface normal is a vector that is perpendicular to the plane of a surface. This vector points in one direction, determined 
by the way the face is drawn.

If a face is drawn clockwise, the surface normals are directed outward; if a face is drawn counter-clockwise, the surface 
normals point inward. Chief Architect assumes that the face on the positive side of the normal vector is the outside face.

Many objects can be drawn using only one side of each face. A cube is a good example: the inside of a cube is not visible, 
so it is not necessary to create its inside faces. When inside faces are not calculated, 3D views in Chief Architect can 
generate more quickly. 

 

Importing 3D Symbols
Chief Architect supports the import of 3D surface and 3D solid objects saved in .dwg, .dxf, .3ds, .obj, .stl, .dae, and
 .skp formats. See 3D Data Import Requirements on page 1238.

For most file types, there are four ways to import a 3D symbol into Chief Architect:

 l By selecting File> Import> Import 3D Symbol.
 l By selecting New> 3D Symbol from the contextual menu in the Library Browser. See Using the Contextual Menus on 

page 965.
 l By dragging and dropping the file from an operating system window into plan view. 
 l Some types of symbols can also be imported via the Select Library Object dialog. See Select Library Object Dialog on 

page 982.

3D .dxf/.dwg files can only be imported by selecting File> Import> Import 3D Symbol.

Symbols imported by clicking and dragging are imported for use in the current plan, while those imported using the Import 
3D Symbol dialog can also be saved in the library. See The Library on page 961. 

To drag and drop a 3D symbol file
 1.  Open the plan in which you would like to import a 3D symbol and remain in plan view.

 2.  Open an operating system window in front of the Chief Architect program window.

 3.  Resize and position the window so that the Chief Architect program window can be seen behind it.

 4.  Click on the desired  .3ds, .obj .stl, .dae, or .skp file and drag it into the Chief Architect program window.
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 5.  When your cursor changes to a +, click in the drawing area to place as many copies of the symbol as desired. When 
you are finished, select a different tool. 

Symbols imported by clicking and dragging are imported as generic stand-alone interior fixtures. If you wish to assign 
different characteristics to a symbol, use the Import 3D Symbol dialog to import it.           

IMPORTING MULTIPLE SYMBOLS

More than one symbol can be imported into the Chief Architect library at a time provided that the following requirements 
are met:          

 l The symbols are located in the same folder on your computer.           
 l Multiple symbols can only be imported using the Import 3D Symbol dialog. If you try to drag and drop group-selected 

files in an operating system window, only the file that was selected first is imported.           
 l When imported as a group, symbols must be assigned to the same symbol category. If you wish to assign them to 

different categories, they must be imported separately.          

Symbols that are imported as a group are assigned names based on their original file names with the file extension omitted.          

IMPORT 3D SYMBOL DIALOG

The Import 3D Symbol dialog, which opens next, allows you to specify additional information about the symbol.    

 l The Files Selected for Import display here for reference.     
 l Choose a symbol Category from the drop-down list. The category affects how and where the symbol can be used, and 

cannot be changed after it is imported. See Symbol Categories on page 1241. 
 l Check Add Symbol to Library to save the symbol in the User Catalog. This is always checked when multiple 

symbols files are selected. See Add to Library on page 973.      
 l Check Show Advanced Options to open the symbol’s specification dialog. See Symbol Specification Dialog on page 

993.      
 l Click OK to import the symbol, then click in plan view to place the symbol at that location. Continue clicking to place 

as many copies of the symbol as needed. Select another tool when finished.     

If you import a .obj, .3ds or .skp file with textures that are already present in your library, the Texture Filename Conflict 
dialog opens. See Texture Filename Conflict on page 1243.     

If the symbol you are importing has a high surface count, it may 
impact program performance. When this is a possibility, the 

program will warn you and present you with an option to cancel the 
import operation. 
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Symbol Categories
The category that you assign to a symbol will influence how the symbol can be placed in a plan and how it will appear in 
the Materials List and in schedules. See Materials Lists on page 1309 and Schedules and Object Labels on page 694.

Category Placement Schedules and Materials Lists

Cabinet 
Door/Drawer

Can be assigned to a cabinet or free-standing. 
See Cabinets on page 628.

When free-standing, listed in Cabinets category of 
Materials Lists. When assigned to a cabinet, listed as a 
component of the cabinet in Materials Lists and 
Cabinet Schedules.

Door Can only be placed in a wall or assigned to a 
doorway. See Doors on page 551.

Listed in Doors category of Materials Lists;
can be included in Door Schedules. 

Doorway Can only be placed in a wall. See Doorways 
on page 554.

Listed in Doors category of Materials Lists;
can be included in Door Schedules.

Electrical Can be specified as a variety of free-standing 
electrical items and may be ceiling-, floor-, 
wall- or cabinet-mounted. See Electrical on 
page 677.

Listed in Electrical category of Materials Lists;
can be included in Electrical Schedules.

Fixture 
(Exterior)

Exterior Fixtures can act as plumbing items or 
appliances and have many different options. 
They may be free-standing, inserted into a 
cabinet, mounted on the ceiling, a wall, under 
a cabinet or on a roof. 

Listed in Fixtures category of Materials Lists;
can be included in Fixture Schedules.

Fixture 
(Interior)

Interior Fixtures can act as plumbing items or 
appliances and, like Exterior Fixtures, have 
many different options. 

Listed in Fixtures category of Materials Lists;
can be included in Fixture Schedules.

Furnishings 
(Exterior)

Can only be placed as a free-standing object 
but can be ceiling-, floor- or roof-mounted.

Listed in Furniture category of Materials Lists;
can be included in Furniture Schedules.

Furnishings 
(Interior)

Can only be placed as a free-standing object 
but can be ceiling-, floor- or roof-mounted.

Listed in Furniture category of Materials Lists;
can be included in Furniture Schedules. 

Geometric 
Shapes

Can only be placed as free-standing object. 
See General Shapes on page 1033.

Listed in General category of Materials Lists. 

Hardware Can be specified as a hinge, handle or lock 
and assigned to a cabinet, to a door, or free-
standing.

Listed as a component of the object it is assigned to in 
Materials Lists or in Hardware category when free-
standing;
can be included in schedules as a component of the 
object it is assigned to. 

Millwork Can be free-standing or assigned to an object 
such as a railing or cabinet. See Moldings and 
Millwork on page 942. 

Listed in Exterior Trim, Interior Trim, or Fixtures 
category of Materials Lists. May be included in 
Fixtures Schedules.

Molding Can only be assigned to a room, cabinet, 
countertop or molding polyline. See Trim and 
Moldings on page 936. 

Listed in Exterior Trim or Interior Trim category of 
Materials Lists. 
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Category Placement Schedules and Materials Lists

Plant Can only be placed as a free-standing object. 
See Plant Tools on page 1300.

Listed in Landscaping category of Materials Lists;
can be included in Plant Schedules. 

Sprinkler Can only be placed as a free-standing object. 
See Sprinkler Tools on page 1307.

Listed in Landscaping category of Materials Lists. 

Window Can only be placed in a wall. See Windows on 
page 584.

Listed in Windows category of Materials Lists;
can be included in Window Schedules. 

 

3D Symbols and Materials
When a symbol is imported into Chief Architect, material definitions may be included with it. Whether and how material 
information is included depends on the symbol’s file format. See About Materials on page 1051. 

DXF/DWG and STL Files
.dxf/.dwg and .stl files do not include information about material definitions. When imported, default materials for the 
selected symbol type will be assigned. If the .dxf/.dwg or .stl file associated with a symbol is changed, all previously 
specified material information for the symbol will be lost.

All layers, layer names, solids and instances of blocked solids from the .dxf/.dwg or .stl file display in the list of 
components on the left side of the MATERIALS panel of its specification dialog. See Materials Panel on page 1055.

OBJ Files
Material definitions for most .obj files are saved in a separate file with the .mtl file extension. If such a file exists, the 
materials associated with the .obj file display in the list on the left side of the MATERIALS panel of its specification dialog. 

If Chief Architect does not receive material definition information in an accompanying .mtl file, default material properties 
are assigned. 

Material definitions for .obj files can also include texture information in the form of image files (.jpg, .png, etc). 

In order to properly import an .obj file, Chief Architect needs the .obj file, the .mtl file, and any referenced texture files. If 
a texture file is not available, the material it is associated with is created without a texture.

The material definitions associated with an imported .obj symbol are not available for use by other objects in Chief 
Architect until that symbol has been placed into a plan. The associated texture files are then copied to the user’s Textures 
folder. See Chief Architect Premier Data on page 37. 

3DS and DAE Files
Material definitions for .3ds and .dae files refer to texture information in separate image files. 

In order to properly import a .3ds and .dae file, Chief Architect needs these referenced image files. If a texture file is not 
available, the material it is associated with will be created without it. The associated texture files are copied to the user’s 
Textures folder. 

SKP Files
The textures associated with a .skp file are saved in the file. After you import a symbol and either place it in a plan or add it 
to the Library, these textures are saved in the user's Textures folder. 

Chief Architect does not support deformed textures. If a texture associated with a .skp file is deformed, it will be imported 
without the deformations. 
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TEXTURE FILENAME CONFLICT

If a texture of the same name already exists in the plan when an .obj, .3ds, or .skp file is imported, the Texture Filename 
Conflict dialog displays. 

 l Select Rename the imported texture, then click the Browse button to create a copy of the texture’s image file with a 
new name that you specify. 

 l Select Use the existing texture instead of the imported texture to keep the existing texture.
 l Select Replace the existing texture with the imported texture to replace the texture already present in the plan with 

the new, imported one.
 l Check Do this for all remaining textures in this object to use the same selection for all textures with filename 

conflicts associated with this symbol. 

 

Exporting a 3D Model
The entire 3D model, or any part that you choose, can be exported from Chief Architect into              one of four formats:

 l 3DS Format on page 1243
 l DAE Format on page 1244
 l STL Format on page 1244
 l DXF/DWG Format on page 1244

To export a 3D model
 1.  A camera view or overview must be active. See Types of 3D Views on page 1081.          

 2.  Make sure that everything that you want to export is set to display in the current view, and everything you do not 
want to export is not set to display. See Layers on page 180.          

 l Any surfaces removed using the Delete Surfaces  tool will not be exported. See Displaying 3D Views on page 

1096.         

 3.  When the model is ready, select File> Export> and choose the file format that you want to use.          

 4.  Give the file a name, making sure to save it in the desired location. See Exporting Files on page 41.         

3DS FORMAT

A .3ds file can be opened by any program that uses 3D Studio®’s .3ds format. When the model is ready, select File> 
Export> 3D Model (3DS) to export to this format.         
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The Export 3D Studio (3DS) Mesh dialog opens:           

 l Check Truncate Texture Names to 8.3 format to truncate material and object names to an eight character file name 
with a three character extension. This allows import into applications that support only legacy .3ds files.           

The Export 3D Studio® (3DS) Mesh dialog, which opens next, is a typical File Save dialog.           

Any material textures used in the model are saved as image files in the same location as the saved .3ds file. You may find it 
helpful to export the .3ds file to an empty folder created for this purpose.          

DAE FORMAT

A .dae file can be opened by any program that uses COLLADA™’s .dae format. When the model is ready, select 
File> Export> 3D COLLADA Model to export to this format.         

The Export COLLADA Model dialog is a typical File Save dialog.         

With the exception of Rope Lights, any light sources that are On in the current view, as well as ambient light, will be 
exported to a .dae file along with the model. See Lighting on page 1133.         

Any material textures used in the model are saved as image files in a folder in the same location as the saved .dae file. The 
folder has the same name as the .dae file, appended with “_textures”.         

STL FORMAT

An .stl file can be opened by any program that uses Stereolithography format, and can be printed using a 
stereolithography machine, or 3D printer. When the model is ready, select File> Export> 3D Model (STL).         

The Export STL Model dialog is a typical File Save dialog.         

A 3D model exported to an .stl file does not include any material or texture information.         

DXF/DWG FORMAT

A .dxf or .dwg file can be opened by any program that uses AutoCAD®’s 3D .dxf or .dwg format. When the model 
is ready, select File> Export> 3D Model (DWG/DXF) to export to this format.         

The entire 3D model, including geometry, is exported.           

3D models exported to .dxf/.dwg do not include material or 
texture information. 

3D DXF/DWG LAYER NAMES

When you export a 3D model to .dxf/.dwg format, all surfaces are exported as 3DFACE entities. These entities are placed 
on layers that are named by Chief Architect.           

A complete list of the layer names and associated objects is found in the 
program’s Help by browsing to Importing and Exporting> Exporting a 
3D Model. See Contextual Help on page 31.         
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Export 360 Panorama
The Export 360 Panorama tool creates a spherical panoramic image that can be opened in various panorama 
viewers. Select File> Export> Export 360 Panorama while a 3D view is active to access this tool.          

For best results, position the camera as near as you can to the center of the scene before exporting.         

EXPORT 360 PANORAMA FILE

All of the settings in this dialog are retained during the current program session.         
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Specify the size of the exported image, in pixels.          

 l Specify the Height and Width of the exported image file, in pixels.         

 l Check Limit Dimensions to Powers of Two to restrict the Width and Height to values that are powers of two. 
When this is checked and an ineligible value is entered, it will adjust up or down to the nearest power of two. 
Although not required, this option is recommended for best results in some panoramic image viewers.          

 l The Retain Aspect Ratio check box displays for reference and cannot be changed. The ratio between Width and 
Height is 2 to 1 when Limit Dimensions to Powers of Two is unchecked, above.         

 
Save to Disk

Check Save to Disk to save the exported panoramic image file on the local computer system.          

 l Specify the full pathname of the File you wish to export, or click the Browse button to open the Export 360 
Panorama File dialog, which is a typical File Save dialog. See Exporting Files on page 41.          

 
Save to Chief Architect Cloud

Check Save to Chief Architect Cloud to save the exported panoramic image file to your Chief Architect Cloud Account. 
See Chief Architect Account Login on page 1223.         

 l Select Create New to upload a new image or select Replace Existing to replace a panoramic image already in your 
Chief Architect Cloud Account with a new one.

 l Type a short, descriptive Name for the exported panoramic image file.          

 l Type a brief Description of the file.         

When you click OK, a panoramic image is created and a progress dialog may display. Because spherical panoramas are 
composed of multiple images stitched together, they may take longer to create than a standard exported picture.         

Note: You can also upload a previously saved panoramic image file to 
the cloud on the 360 Panoramas page of your online account. 

Generate as 360° Panorama is also an option in the CPU Ray Trace Options dialog. See General Panel on page 1167.         

 

Export Thermal Envelope Data
A thermal envelope is a three dimensional boundary built around a structure's conditioned space that separates it from the 
unconditioned space around it. Thermal Envelopes are composed of floor platforms, ceiling platforms, walls, doors, and 
windows. You can export information about the thermal envelope of the current plan by selecting File> Export> Thermal 
Envelope Data. This data is organized by floor level; notes the direction of walls, doors, and windows; and reports the area 
of each envelope component.

Thermal Envelope Data is exported to a comma delimited .csv text file which can be opened in a text editor or spreadsheet 
application. Once exported, it will automatically open in the application associated with .csv files on your system.

Thermal Envelope information is also included when data is exported to REScheck. See Export to REScheck on page 1247.
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Export to REScheck
REScheck™ is a residential energy code compliance program offered by the U.S. Department of Energy that 
evaluates the thermal envelope of a structure and determines how well it meets various energy codes. For more 

information, visit: www.energycodes.gov/rescheck.

To export a plan’s thermal envelope information for use in REScheck™, select File> Export> Export to REScheck . 

Chief Architect Premier exports using the .rxl file format, which can be used by both the desktop and web-based versions of 
REScheck™.          

EXPORT TO RESCHECK DIALOG

 l Uncheck Group Similar Walls to treat walls on multiple floors separately. When checked, walls with the same 
properties and orientation are added together and treated as one wall, regardless of the floors they are on.      

 l Uncheck Group Similar Doors/Windows to treat all doors and windows separately. When checked, doors and 
windows with the same properties and orientation are added together and treated as one item.    

Click the Export button to open the Export REScheck File dialog, which is a typical Save File dialog. See Exporting Files 
on page 41.    

EXPORTED PROJECT DATA

Chief Architect Premier can export the following REScheck Project:           

 l Front Faces - The side of the house that faces down on-screen is considered the front, and North is considered up on-
screen unless a North Pointer is used. See North Pointer on page 1140.           

 l The Conditioned Floor Area is calculated and exported by Chief Architect Premier. See Exported Envelope Data on 
page 1247, below.           

 l The Owner/Agent information is drawn from the plan file’s Client Information. See Client Information on page 60.          
 l The Designer Contractor information is drawn from the plan file’s Designer Information. See Designer Information 

on page 60.          

In a REScheck report exported from Chief Architect Premier, the Project Type is set as “New Construction” and “1-and-2 
Family, Detached” is selected under Building Characteristics. Location and Title/Site/Permit are not exportable.           

EXPORTED ENVELOPE DATA

Conditioned Area is the space within a building that is heated and/or air conditioned, and a Thermal Envelope is a three 
dimensional boundary built around the Conditioned Space that separates it from the unconditioned space around it. Thermal 
Envelopes are composed of floor platforms, ceiling platforms, walls, doors, and windows. 
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Rooms that are assigned an interior Room Type are included in the Conditioned Area by default. “Open Below” rooms are 
also included; however, other hybrid Room Types as well as exterior Room Types are not. See Room Types and Functions 
on page 420.

You can specify that any room be included in or excluded from the Conditioned Area in the Room Specification dialog. See 
General Panel on page 443.     

Nearly all REScheck Envelope data can be exported from a Chief Architect plan:           

 l Floors - The Assembly type, Gross Area, and Cavity and Continuous R-Values are exported. See Floor and Ceiling 
Platform Definitions on page 434.           

 l Slabs on Grade - The Slab Perimeter and Continuous R-Value are exported. Slab Depth of Insulation is not included 
and must be entered manually. See Foundations on page 717.          

 l Ceilings - The Assembly type, Gross Area, and Cavity and Continuous R-Values are exported.           
 l Walls - The Assembly type, Orientation, Gross Area, and Cavity and Continuous R-Values are exported. All are 

exported as Walls rather than Basement or Crawl Walls. Like walls on the same floor are grouped by orientation. See 
Building Orientation on page 1248, below, and Wall Type Definitions Dialog on page 390.        

Note: The On Center Spacing of Framed walls is derived from the 
framing material assigned to the wall type’s Main Layer. See 
Materials and the Materials List on page 1064. 

 l Doors and Windows - The Assembly type, Orientation, Gross Area, U-Factor, and Solar Heat Gain Coefficient 
(SHGC) are exported. Doors are always categorized as doors rather than as windows: even when a door is specified as 
a Glass Door or when it is part of a mulled unit. See Energy Values Panel on page 616.           

If any walls forming the thermal envelope have labels, they will be exported and used in the REScheck report. If similar 
walls are grouped, their labels will not be used unless the labels are all identical. See Wall Labels on page 368.    

Information about skylights is not exported.           

BUILDING ORIENTATION

Walls, doors, and windows are categorized as north-, south-, east-, or west-facing for the purposes of conditioned area totals. 
These directions  are based on the orientation of the plan’s North Pointer . If no North Pointer is used, north is assumed 

to be straight up on screen in plan view. See North Pointer on page 1140.

 l If a wall is oriented at 45º or less to north in a plan, it will be categorized as a “North” wall. Any doors and windows 
in this wall will also be categorized as “North”.

 l Similarly, walls, doors, and windows oriented within 45º of south, east, or west will be classified as “South”, “East” or 
“West”, respectively.

The orientation of a curved wall is based on the direction of its chord. See Drawing Arcs - Arc Creation Modes on page 
313.   
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Chapter 37
 

Terrain

Chief Architect Premier allows you to model the terrain around a house. Begin by specifying elevation data that creates the 
surface contours, and then add surface features such as planting areas and water features in level terrain around your house 
plan.

You can import terrain data from a variety of sources and use this data to produce your 3D model. 

Once the terrain is modeled, shadows that follow the terrain can be created using the Sun Angle tool. See Sun Angles and 
Shadows on page 1140.           

Driveways, parking lots, and sidewalks as well as plants and sprinklers are among the objects that can be placed in your 
terrain and are discussed in Plants and Sprinklers on page 1299 and  Roads, Driveways, and Sidewalks on page 1289.

TOPICS

Terrain Toolbar Configuration 1250
Terrain Perimeter 1250
Elevation Data Tools 1252
Terrain Modifier Tools 1257
Terrain Feature Tools 1258
Garden Bed Tools 1260
Water Feature Tools 1260
Stepping Stone Tools 1261
Terrain Wall and Curb Tools 1261
Sun Shadows 1262
Terrain Objects in the Library 1263
Displaying Terrain 1263
Editing Terrain Objects 1264
Terrain Specification Dialog 1265
Elevation Point Specification Dialog 1270
Elevation Line/Region Specification Dialog 1271
Flat Region Specification Dialog 1273
Hill / Valley Specification Dialog 1274
Raised / Lowered Region Specification Dialog 1275
Terrain Feature Specification Dialog 1275
Garden Bed Specification Dialog 1277
Terrain Break Specification Dialog 1278
Terrain Path Specification Dialog 1279
Importing Elevation Data 1281
Import Terrain Assistant 1282
Import GPS Data Assistant 1285
Importing DWG/DXF Elevation Data 1287
Converting CAD Objects to Terrain Data 1288
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Terrain Toolbar Configuration
The Terrain and Road Tools can be accessed through the Terrain menu. You can also display these tools on your 
toolbar using the Terrain Configuration. See Toolbar Configurations on page 135.          

The Terrain Configuration and Terrain menu both display the following Terrain, Road, Plant, and Sprinkler parent tools:          

  Elevation Data Tools on page 1252                  allow you to add elevation data to your terrain.         

  Terrain Modifier Tools on page 1257 model changes in elevation within a defined area.          

  Terrain Feature Tools on page 1258 let you add materials over the top of the terrain.           

  Garden Bed Tools on page 1260 create Terrain Features with a mulch material.         

  Water Feature Tools on page 1260 create Terrain Features with a water material.         

  Stepping Stone Tools on page 1261 are used to create paths composed of multiple Terrain Features.         

  Terrain Wall and Curb Tools on page 1261 let you draw walls and curbs that follow the terrain.         

  Road, Driveway, and Sidewalk Tools on page 1290 allow you to create paved areas that can form intersections.          

  Plant Tools on page 1300 allow you to place plant images and 3D plant symbols.          

  Sprinkler Tools on page 1307 are used to lay out sprinkler symbols and irrigation lines.          

 

Terrain Perimeter
The Terrain Perimeter is a closed polyline defining the boundary of the terrain that generates in 3D views and of the 
contour lines that generate in plan view. Select Terrain> Create Terrain Perimeter to create a terrain perimeter.

A CAD polyline can also be converted into a terrain perimeter. See Editing Terrain Objects on page 1264.          

If you create a terrain perimeter in plan view but do not see it, select Window> Fill Window . See Zoom Tools on page 

157. 
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When created in a new, blank plan, a new terrain perimeter will be 50’ x 100’. If you create a terrain perimeter after you 
have drawn all or part of a 3D model, it may increase in size as needed to encompass the structure(s) in plan view.           

Once created, the terrain perimeter can be resized and edited like other polyline-based objects. See Editing Closed Polyline-
Based Objects on page 230. 

When a terrain perimeter is first created, it is completely flat and is placed at a height of 0’-0”, or sea level.         

The terrain perimeter by itself does not have elevation data associated with it. You can use the Elevation Data   and 

Terrain Modifier  tools to create terrain that slopes in a wide variety of ways. If you do not create elevation data within 

the terrain perimeter, the terrain remains flat at an elevation of 0' - 0". See Elevation Data Tools on page 1252 and Terrain 
Modifier Tools on page 1257.         

The Terrain Perimeter has a variety of editable properties, including many that affect the appearance of the terrain in 2D and 
3D views. See Terrain Specification Dialog on page 1265.

PLOT PLANS AND PLAN FOOTPRINTS

Using the CAD drawing and editing tools, you can create an accurate plot plan of any building site. 

Another approach is to use the Plan Footprint  tool and other CAD Tools in a CAD Detail. See Plan Footprint on page 

342.          

TERRAIN HEIGHT VS FLOOR HEIGHT

Chief Architect always defines the default height of Floor 1 at 0’-0”. This height value is the constant by which the heights 
of structural elements in the program like walls, floors, and ceilings are measured. The heights of architectural object can be 
measured relative this absolute height, as well. See Floor 1 Default Height on page 419.

The default height of Floor 1 is not, however, the absolute by which terrain elevation is measured. Instead, elevation data is  
measured relative to sea level. This means that if you want to, you can use real-world elevation data to generate a 3D terrain 
model without also having to measure floor and ceiling heights from sea level. See Importing Elevation Data on page 1281. 

The program automatically positions Floor 1 a set distance above the terrain. To do this, it first calculates the average 
elevation of the building footprint's perimeter and then assigns that average elevation to the center point of the building 
footprint. Finally, it adds the thickness of the floor platform to this value. If a foundation is present, it also adds the 
thickness of any sill plates plus either 6” (150 mm) or 8”  (200 mm) depending on the foundation type. The resulting value, 
referred to as the automatic Subfloor Height Above Terrain, is how far the default height of Floor 1 is above sea level in the 
current plan. See Foundations and the Terrain on page 730.

The Subfloor Height Above Terrain distance is stated and can be modified in the Terrain Specification dialog. You can 
specify a custom value to produce a daylight or walkout basement. See General Panel on page 1266. 

BUILD TERRAIN

Select Terrain> Build Terrain to generate the terrain surface based on the elevation data you have provided. Build 
Terrain also updates the Building Pad Elevation value in the Terrain Specification dialog. See Building the Terrain on 

page 1263.    
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AUTO REBUILD TERRAIN

By default, terrain will automatically build any time a 3D view is created, ensuring that the terrain in the view is up-to-date. 
If your terrain is large and/or highly detailed and has not been modified, and you find that this unnecessarily slows down the 
generation of 3D views, consider turning this behavior off in the Terrain Specification dialog. See General Panel on page 
1266. 

When Auto Rebuild Terrain is turned off, the Auto Rebuild Terrain   icon will follow your mouse pointer. See Pointer 
Icons on page 16.         

CLEAR TERRAIN

To remove the generated terrain contours, select Terrain> Clear Terrain. When the terrain is cleared, contours do 
not display in 3D and contour lines do not display in plan view.         

Clear Terrain does not remove the terrain perimeter, elevation data, or terrain features from the model. Rather, it deletes all 
program-generated 2D contour lines and 3D contours.         

TERRAIN SURFACE TRIANGLES

Chief Architect generates 3D terrain surfaces by dividing them into triangles. The size of the triangles determines how 
detailed contour lines and terrain surfaces in the 3D model can be. You can specify triangle size in the Terrain Perimeter 
Specification dialog. See General Panel on page 1266.          

Increasing the triangle count decreases triangle size, yielding more detailed contour lines and a better 3D approximation of 
the terrain. Smaller triangles demand longer terrain generation time and increased memory requirements. If you select a 
large number of small triangles for a large site, you may wait a long time for the calculation.           

Decreasing the triangle count increases triangle size. Elevation lines are sampled less frequently, speeding up terrain 
generation. If you specify a small number of triangles for a plan with detailed elevation data, contour lines and 3D surfaces 
may not generate correctly.           

When a large terrain perimeter is used, consider increasing the 
Triangle Count to help make sure all Elevation Data and Terrain 

Modifiers generate contours. 

 

Elevation Data Tools
Select Terrain> Elevation Data to add elevation information to your terrain.          

When terrain is generated, this data is used to calculate the surface of your site and is represented by contour lines in plan 
view and a curved surface in 3D. See Displaying Terrain on page 1263.         

Elevation data can be specified using the Elevation Point , Elevation Line , Elevation Spline , Elevation 

Region , and Terrain Break  tools.    

Elevation data can also be imported. See Importing Elevation Data on page 1281.         

The elevation of each Elevation Line, Spline, and Region is specified relative to sea level.          

In order to create rising and/or falling terrain, multiple terrain data objects with different elevation values must be used. If 
only one terrain data object is placed, the terrain will be flat regardless of the object’s specified elevation.         
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To avoid unexpected results, do not draw Elevation Data objects 
- including Terrain Breaks - with different elevation information 

at the same location. 

ELEVATION POINTS

An Elevation Point contains the absolute elevation data for one point in the terrain model. Typically, Elevation 
Points are imported rather than placed manually.          

Chief Architect requires many points to make an accurate approximation of your site. Even small sites may require over a 
hundred points to generate an accurate model of the terrain if it is sloped. For the sake of illustration, the following example 
shows only a few elevation points.         

To place an elevation point
 1.  Select Terrain> Elevation Data> Elevation Point  and click in plan view at the point where you would like to 

place elevation data.              See Place Point on page 301.

 2.  The Elevation Point Specification dialog opens. Enter an elevation value and click OK. See Elevation Point 
Specification Dialog on page 1270.         

 3.  Click somewhere else in plan view and the Elevation Point Specification dialog opens again with the last elevation 
value entered.          

 4.  Repeat steps 1, 2 and 3 to place additional elevation points with varied elevation values as needed.         

 5.  Select Terrain> Build Terrain . See Building the Terrain on page 1263.         

Elevation Points are most effective when they are imported. 
When adding elevation data manually, use Elevation Lines and 

Splines instead. See Importing Elevation Data on page 1281.
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ELEVATION LINES

An Elevation Line contains absolute elevation data for many points along a line at a constant elevation. Elevation 
lines can be connected to create a polyline with many straight sections. For the sake of illustration, the images in the 

following example show single-section elevation lines.         

To draw an elevation line
 1.  Select Terrain> Elevation Data> Elevation Line , then click and drag a line inside the Terrain Perimeter in plan 

view.          

 2.  Click on the elevation line to select it, then click the Open Object  edit button.         

 3.  At first, an elevation line is at elevation 0' - 0". In the Elevation Line Specification dialog, specify the desired 
elevation and click OK. See Elevation Line/Region Specification Dialog on page 1271.         

 4.  Repeat steps 2 and 3 to draw additional elevation lines as needed.          

 5.  Select Terrain> Build Terrain . See Building the Terrain on page 1263.         

After it is drawn, an Elevation Line can be edited much the way other line-based objects can. See Editing Line-Based 
Objects on page 218.          
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ELEVATION SPLINES

Elevation Splines can be used to form complex curves and shapes. Like elevation lines, elevation splines contain 
absolute elevation data for many points along a constant elevation.

To place an elevation spline, select Terrain> Elevation Data> Elevation Spline  and click and drag multiple sections in 

plan view.  See Splines on page 330.

Elevation splines are initially placed at elevation 0' - 0"and must be opened and assigned an elevation. See Elevation 
Line/Region Specification Dialog on page 1271.          

After it is drawn, an Elevation Spline can be edited much the way other spline-based objects can. See Editing Spline-Based 
Objects on page 237.          

ELEVATION REGIONS

An Elevation Region contains absolute elevation data for an enclosed region and is ideal for creating a flat surface in 
your terrain.          

Elevation Regions are similar to Flat Regions in that they produce an area with a flat surface; however, they differ in that an 
Elevation Region affects the contours of the terrain outside its perimeter and may also have some sloping within its 
perimeter. See Flat Regions on page 1258.          

To create an elevation region
 1.  Select Terrain> Elevation Data> Elevation Region . 

 2.  There are two ways to add a Terrain Modifier to your plan:          

 l Click once to place an 8’ (0.6 m) square feature at that location.         

 l Click and drag from end-to-end to draw a feature sized as needed. See Rectangular Polyline on page 325.
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 3.  Click on the region to select it, then click the Open Object  edit button.

 4.  At first, an elevation line is at elevation 0' - 0". In the Elevation Region Specification dialog, specify the desired 
elevation and click OK. See              Elevation Line/Region Specification Dialog on page 1271.

 l Click once to place an 8’ (0.6 m) square feature at that location.         
 l Click and drag from end-to-end to draw a feature sized as needed. See Rectangular Polyline on page 325.

 1.  Click on the region to select it, then click the Open Object  edit button.

 2.  At first, an elevation line is at elevation 0' - 0". In the Elevation Region Specification dialog, specify the desired 
elevation and click OK. See              Elevation Line/Region Specification Dialog on page 1271.

After it is drawn, and Elevation Region can be reshaped much the way other closed polyline-based objects can. See Editing 
Closed Polyline-Based Objects on page 230.         

An Elevation Region  can also be created by drawing a closed polyline using Elevation Lines . 

TERRAIN BREAKS

A Terrain Break creates a division along the terrain surface that affects terrain generation. Elevation data on one 
side of the terrain break does not affect the terrain generation on the other side, allowing you to create immediate 

drops in terrain.         

To place a Terrain Break, select Terrain> Elevation Data> Terrain Break  and click and drag a line in plan view.

 l If the Terrain Break divides the terrain perimeter into two separate pieces, the terrain data on either side is calculated 
independently and smoothed separately, resulting in sharp terrain contours.           

 l If the Terrain Break does not extend completely from one side of the terrain perimeter to the other, the areas near each 
end of the Terrain Break are blended.           
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The Retaining Wall  tool creates a similar effect by drawing a Terrain Break as well as a retaining wall that rests against 

the break. By default, the top height of the retaining wall matches the terrain on  the high side of the break and the bottom 
matches the low side. See Terrain Wall and Curb Tools on page 1261.

 

Terrain Modifier Tools
Select Terrain> Modifier to access tools that allow you to modify the existing elevation data by drawing a closed 
polyline. Their height is relative to the terrain surface generated from the Elevation Data provided in your plan.          

The elevation data associated with a Terrain Modifier only affects the terrain within its perimeter. The rest of the terrain is 
unaffected.          

RAISED AND LOWERED REGIONS

The Raised Region tool creates a raised area with a top surface that is flattened like a plateau but follows the 
surface of the terrain. The Lowered Region tool creates a depression with a bottom that follows the terrain and 

is flattened.          
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HILLS AND VALLEYS

The Hill and Valley tools create raised and lowered areas in the terrain that come to a point rather than  
flattening at their highest or lowest elevations.         

FLAT REGIONS

The Flat Region tool creates an area with a surface that is flattened like a plateau but is level rather than following 
the contours of the terrain.         

There are two ways to add a Terrain Modifier to your plan:          

 l Click once to place a modifier with endpoints that form a 10’ (4 m) square at that location.          
 l Click and drag from end-to-end to draw a feature sized as needed. See Rectangular Polyline on page 325.         

Terrain Modifiers can only be drawn when a Terrain Perimeter is present, and will only display in 3D when they are drawn 
within the perimeter. See Displaying Terrain on page 1263.         

Once created, Terrain Modifiers can be selected and edited in a variety of ways. See Editing Spline-Based Objects on page 
237.          

Terrain modifiers can be blocked with images and stored in the 
library for future use. See Creating Architectural Blocks on page 

1009.

 

Terrain Feature Tools
Select Terrain> Feature to access tools for drawing bounded areas that follow the contours of the terrain rather than 
modifying them. 

Terrain Features are useful for creating landscaping features because they have specified heights and materials. You can, for 
example, create paths and planting beds with gravel or mulch materials that stand out in a grassy Terrain Perimeter.  

In fact, Garden Beds  are special Terrain Features with material and height attributes already applied to them, saving 

you time when drawing these objects.

Terrain Features can only be drawn when a Terrain Perimeter is present, and will only display in 3D when they are drawn 
within the perimeter. See Displaying Terrain on page 1263.

Terrain Features can be created in either of two ways: 
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 l Click once to place a feature with endpoints that form a 10’ (4 m) square at that location. 
 l Click and drag from end-to-end to draw a feature sized as needed. See Rectangular Polyline on page 325.

Once created, Terrain Features can be edited into nearly any shape you require. See Editing Closed Polyline-Based Objects 
on page 230 and Editing Spline-Based Objects on page 237.

Terrain Features can be drawn in 2D and 3D views. 
 

RECTANGULAR FEATURES

The Rectangular Feature tool can be used to create straight-sided features that can be edited into a wide variety of 
shapes. 

Rectangular Features can also be edited like other closed polyline-based objects. See Editing Closed Polyline-Based Objects 
on page 230.   

SPLINE FEATURE

The Spline Feature tool can be used to create features with rounded edges and smoothly curved corners. 

Spline Features can be edited like other closed spline-based objects. See Editing Spline-Based Objects on page 237.

KIDNEY SHAPED FEATURES

The Kidney Shaped Feature tool allows you to quickly create features with curved edges, smooth corners and a 
right angle bend in its shape.

Kidney Shaped Features can be edited like other closed spline-based objects. See Editing Spline-Based Objects on page 
237.

Terrain features can also be converted from closed 2D polylines or splines using the Convert Polyline  edit tool. See 
Convert Polyline on page 265. 

For information about adding height and material information to Terrain Features, see Terrain Feature Specification Dialog 
on page 1275.

Terrain features can be blocked with images and stored in the 
library for future use as planting beds. See Creating 

Architectural Blocks on page 1009.

TERRAIN HOLES

By default, the program automatically cuts a hole in the terrain around any structures located within and on the same floor 
as the Terrain Perimeter. The shape of these holes follow the exterior surfaces of the walls and will automatically update if 
any of those walls are moved.         

If you prefer to manually control the holes around structures, select the Terrain Perimeter and click the Make 
Terrain Hole(s) Around Building(s) edit button. See Terrain Perimeter on page 1250.         

The Make Hole(s) Around Building(s)  edit tool creates a Terrain Feature polyline with Make Hole checked in its 

specification dialog around each building on the same floor level as the Terrain Perimeter. See Terrain Feature 
Specification Dialog on page 1275.          
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The Terrain Hole tool allows you to draw Terrain Feature polylines with Make Hole specified, as well.         

 

Garden Bed Tools
Select Terrain> Garden Bed to access tools that can be used to place garden bed features in your terrain.

Garden Beds are a special type of Terrain Feature with material and height attributes typical of planting beds. See Terrain 
Feature Tools on page 1258.

You can specify a Garden Bed’s material and height in its specification dialog. See Terrain Feature Specification Dialog on 
page 1275. 

In addition, you can choose to distribute copies of a plant image within a Garden Bed. See Distributed Plant Panel on page 
1276.

POLYLINE GARDEN BED

This tool draws a garden bed with straight sides and four right angles. See Rectangular Features on page 1259.

ROUND GARDEN BED

Use this tool to draw garden beds with rounded edges and smoothly curved corners. See Spline Feature on page 
1259. 

KIDNEY SHAPED GARDEN BED

You can draw a kidney shaped garden bed with this tool. See Kidney Shaped Features on page 1259.

 

Water Feature Tools
Select Terrain> Water Feature to access tools for drawing ponds and streams in your terrain.

Ponds are basically Terrain Features with material and height attributes typical of bodies of water. See Terrain Feature 
Tools on page 1258.

Similarly, Streams are Terrain Curbs with a water material. See Terrain Wall and Curb Tools on page 1261.          

ROUND POND

Use this tool to draw a pond with rounded edges. See Spline Feature on page 1259. 

KIDNEY SHAPED POND

This tool draws a kidney shaped pond. See Kidney Shaped Features on page 1259.
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STREAM

Select the Stream tool, then click and drag to draw a stream. Streams are drawn and edited the same way that splines 
are. See Splines on page 330 and Editing Spline-Based Objects on page 237.         

Click the Advanced Splines  edit button to activate additional edit handles that you can use to reshape the stream.  See 

Advanced Splines on page 240.   

Streams follow the contours of the terrain, so they may appear to flow uphill if they are not drawn correctly in the terrain. 
Try to draw them so that they follow a downward course for their entire length.         

Once drawn, Water Features can be selected and edited just like any other Terrain Feature.         

Specify the material and set the height of Water Features in their specification dialogs.  See Terrain Feature Specification 
Dialog on page 1275 and Terrain Path Specification Dialog on page 1279.         

 

Stepping Stone Tools
Select Terrain> Stepping Stone to place a walkway made of individual stepping stones.          

Stepping Stones are basically Terrain Features with material and height attributes typical of walking paths. See Terrain 
Feature Tools on page 1258.         

There are two ways to draw Stepping Stones:          

 l Click once to place a stepping stone with endpoints that form a 1’ (300 mm) square at that location.          
 l Click and drag from end-to-end to draw a stepping stone sized as needed. See Rectangular Polyline on page 325.         

POLYLINE STEPPING STONE

The Polyline Stepping Stone tool draws rectangular stepping stones. See Rectangular Features on page 1259.          

ROUND STEPPING STONE

The Round Stepping Stone tool draws stepping stones with rounded edges. See Spline Feature on page 1259.         

Once drawn, Stepping Stones can be selected and edited just like any other Terrain Feature.          

By default, Stepping Stones have a concrete material; however, you can specify the material and set the height of Stepping 
Stones in the Terrain Feature Specification dialog.  See Terrain Feature Specification Dialog on page 1275.          

 

Terrain Wall and Curb Tools
Select Terrain> Terrain Wall and Curb to draw landscaping walls and curbs that follow the contours of the terrain.          

Straight and curved Terrain Walls and Curbs are drawn just as other walls are. See Creating Walls on page 361.         

Terrain Walls and Curbs are examples of Terrain Paths. Other examples include Sidewalks and Streams. See Terrain Path 
Specification Dialog on page 1279.         
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TERRAIN WALLS

Use the Straight Terrain Wall tool to draw a wall that sits on top of and follows the terrain.          

Use the Spline Terrain Wall to draw a curved terrain wall. This wall is drawn the same way as a CAD Spline. See 
Splines on page 330.         

Once drawn, a Terrain Wall can be like other line-based objects. See Editing Line-Based Objects on page 218 and Editing 
Spline-Based Objects on page 237.         

Terrain walls are 5’ (1500 mm) high and concrete by default, but you can specify the material, height and more in the 
Terrain Path Specification. See Terrain Path Specification Dialog on page 1279.          

RETAINING WALLS

The Retaining Wall tools function similarly to Terrain Breaks, but include a wall. See Terrain Breaks on page 1256.          

Use the Straight Retaining Wall tool draws a straight wall that holds back sloped terrain.         

Use the Curved Retaining Wall tool to draw a curved retaining wall.          

A Retaining Wall’s height is determined by the elevation of the terrain on each side. By default, the height of the wall 
matches the terrain on the high side of the break and the bottom matches the low side. If you insert a Retaining Wall into 
flat terrain, it looks like a concrete strip in 3D views.         

Once drawn, a Retaining Wall can be edited much like other walls. See Editing Walls on page 372.         

TERRAIN CURBS

Terrain Curbs are useful for creating curbs around planting beds and along paths.         

Use the Straight Terrain Curb tool to draw a straight landscaping curb.         

Use the Spline Terrain Curb tool to draw a curved landscaping curb. This curb is drawn the same way as a CAD 
Spline. See Splines on page 330.          

Once drawn, a Terrain Curb can be like other line-based objects. See Editing Line-Based Objects on page 218 and Editing 
Spline-Based Objects on page 237.         

You can specify the height of straight and spline terrain curbs on the GENERAL panel of the Terrain Path Specification. See 
Terrain Path Specification Dialog on page 1279.         

You can also add Fencing to your terrain, complete with gates 
from the Doors Library. See Fencing Tools on page 354. 

 

Sun Shadows
Sun shadows are generated by the program and represent shadows cast at a particular location on the Earth and at a specific 
date and time. See Sun Angles and Shadows on page 1140.           

Sun shadows are computed based on the contour of the terrain. If a terrain perimeter exists, the sun shadow adjusts to the 
terrain.          
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A sun shadow is automatically rebuilt whenever terrain is rebuilt. If you generate a sun Shadow and the terrain is not up-to-
date, the terrain automatically rebuilds. You can turn off the automatic rebuild. See Sun Angle Specification Dialog on page 
1143.          

 

Terrain Objects in the Library
The Library Browser contains a variety of objects that can be placed in a plan’s terrain, including plants, exterior 
fixtures, accessories and roadway objects. See The Library Browser on page 962. 

 

Displaying Terrain
The display of terrain objects in 2D and 3D views is controlled in the Layer Display Options dialog. See Layer 
Display Options Dialog on page 183.

IN PLAN VIEW

Like other objects, terrain objects are placed in Drawing Groups that affect whether they display in front of or behind other 
objects. You can modify a selected object’s place in the drawing order by clicking the View Drawing Group Edit Tools 

 edit button. See Drawing Group Edit Tools on page 195. 

You can customize appearance of Terrain Features, Roads, and other terrain objects in plan view by changing their line and 
fill styles. See  Line Styles on page 200 and Fill Styles on page 197.

Plant images are represented in plan view by 2D CAD symbols. You can select a plant’s symbol in the Plant Image 
Specification dialog. See Image Panel on page 1304. 

BUILDING THE TERRAIN

When terrain is generated, Chief Architect gathers all elevation data that has been added to the model and creates a 
terrain surface. The program interpolates the data to produce smooth contours.   

A terrain perimeter with no additional elevation data drawn within it generates terrain that is flat at the elevation 0' - 0", or 
sea level.   

By default, the terrain is automatically built before a 3D view is generated and when a Sun Shadow is created. This process 
takes a variable amount of time, depending on the amount of elevation data and number of terrain features in the plan. The 
Building Terrain progress dialog displays as terrain is generated, sometimes only briefly, indicating the progress.

You can turn off Auto Rebuild Terrain in the Terrain Specification dialog as well as in the Sun Angle Specification dialog, 
and rebuild the terrain manually only when needed by selecting Terrain> Build Terrain . When Auto Rebuild Terrain 

is turned off and the terrain is not up-to-date, the Build Terrain   icon displays near your mouse pointer. See Terrain 
Specification Dialog on page 1265 and Earth Data Panel on page 1143.    

CONTOUR LINES

When elevation data has been drawn or imported into a plan, contour lines will display in plan views. See Elevation Data 
Tools on page 1252.          
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Chief Architect Premier can produce both primary and secondary contours. They are on two different layers so you can 
control their display separately. Contour line labels use the Text Styles assigned to the “Terrain, Primary Contours” and 
“Terrain, Secondary Contours” layers.           

By default, all contour lines are set to be primary, but you can specify secondary contours, frequency and other attributes of 
contour lines in the Terrain Specification dialog.  See Contours Panel on page 1267.           

TERRAIN AND ROAD LABELS

Labels for terrain objects - including the Terrain Perimeter, most Elevation Data objects, Terrain Features, Terrain 
Modifiers, Terrain Paths, and Roads - display in plan view when the “Terrain Labels” layer is turned on. Labels for all but 
Elevation Data, Terrain Modifiers, and Road Markings can display in cross section/elevation views, as well. See Label 
Panel on page 712.          

With the exception of Elevation Lines, Splines, and Regions, the Automatic Labels for terrain objects are blank; however, 
you can specify a custom label in their specification dialogs.

IN 3D VIEWS

In order for objects such as Terrain Features and Roads to be visible in 3D views, they must be drawn within the Terrain 
Perimeter. Any portions of these objects drawn outside the Terrain Perimeter will not be seen in 3D views. See Terrain 
Feature Tools on page 1258.

A variety of tools are available to help you adjust the perspective of your 3D views. See Editing 3D Views on page 1105.   

TERRAIN AND 3D DRAWING TIME

Terrain is typically large with many surface triangles, which often increases the drawing time of 3D views. The time 
required is affected by the quality of the terrain, the amount of elevation data and number of terrain features present. For 
information about surface triangles and how they influence terrain quality, see General Panel on page 1266. 

Lights and symbols can be placed outdoors and included in 3D views when the terrain is generated. These objects can also 
contribute to the time needed to generate 3D views. See Rendering Tips on page 1130.

IN SCHEDULES

Terrain and Road objects can be included in schedules. See The Schedule Tools on page 695.

By default, the Terrain Perimeter, Driveways, Medians, Roads, and Road Markings are listed in schedule categories of the 
same names; Sidewalks, Terrain Walls, and Terrain Curbs are listed in the "Terrain Paths" category; and Terrain Features, 
Terrain Modifiers, Garden Beds, Water Features, and Stepping Stones are listed in the "Terrain Features" category. You can, 
however, assign a selected object to the category of your choice in its specification dialog. See Schedule Panel on page 716.

 

Editing Terrain Objects
Before a terrain object can be edited, it must be selected. All terrain objects can be selected in plan view. In addition, the 
Terrain Perimeter and Terrain Features can be selected in 3D views. See Selecting Objects on page 212. 

A selected terrain object can be edited using its edit handles, edit tools and specification dialog. See Specification Dialogs 
on page 21.

Any time elevation data is changed, the terrain must be rebuilt. This can be done by selecting Terrain> Build Terrain , 

and occurs automatically when a 3D view is created.         
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USING THE EDIT HANDLES

Terrain objects can be moved, resized, and reshaped using their edit handles. How a selected object can be edited depends 
on what type of object it is. See Editing Objects on page 207.

 l The Terrain Perimeter can be moved, resized, and reshaped like a polyline-based objects. 
 l Elevation Points can be moved in plan view using the Move edit handle.         
 l Elevation Lines, Elevation Splines and Terrain Breaks are edited like other line- and spline-based objects.    
 l The shape of a Raised Region, Lowered Region, Hill,              Valley, and Flat Region can be edited like a spline.          
 l Terrain Features are edited like other spline- and polyline-based objects. 

USING THE EDIT TOOLS

A selected terrain object can be edited in a variety of ways using the buttons on the Edit Toolbar. The edit tools available 
for a terrain object depends on the type of object selected. See The Edit Toolbar on page 135.

Note: If you copy terrain objects from one plan to another, you cannot 
view the pasted objects in 3D unless a Terrain Perimeter exists. 

USING DIMENSIONS

Like many other types of objects, terrain objects can be resized and moved using dimensions. For more information 
see Moving Objects Using Dimensions on page 491.

 

Terrain Specification Dialog
The Terrain Specification dialog controls how your terrain is modeled, as well as its appearance. It can be accessed in any of 
three ways:

  Select Terrain> Terrain Specification;          

  Select the Terrain Perimeter and click the Open Object edit button;

  Double-click the Terrain Perimeter using the Select Objects tool. 
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GENERAL PANEL

 
Auto Rebuild Terrain

Check Auto Rebuild Terrain to automatically rebuild terrain to reflect recent changes before generating a 3D view or a 
Sun Shadow. If this option is unchecked and the terrain is not up-to-date, the Rebuild Terrain   icon displays near your 
mouse pointer. See Building the Terrain on page 1263.

 
Building Pad

Specify how the Building Pad is generated beneath the structure. See Foundations and the Terrain on page 730. 

 l To specify the distance between Floor 1 and the terrain at the building footprint center, uncheck Automatic and enter 
a value in the Subfloor Height Above Terrain field.

 l Check Automatic to have Chief Architect automatically lower the terrain relative to the first floor. See Terrain 
Height vs Floor Height on page 1251.

 l Check Flatten Pad to flatten the area beneath the building. To create a walkout basement, uncheck this box.         
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Skirt

Define the thickness of the Skirt added to the terrain. The skirt is only visible in 3D views and gives the viewer a sense of 
depth when viewing the terrain.          

 l Flat specifies that the skirt be flat at its base. Chief Architect determines the lowest point in the terrain and then 
offsets this value by the user specified thickness value. The resulting value is used as a uniform elevation for the 
base of the skirt.           

 l Follow Terrain specifies that the skirt base maintains a consistent distance below the terrain. The distance is 
equivalent to the specified Thickness value.          

 
Terrain Surface Smoothing

The Terrain Surface Smoothing settings control the amount of curvature applied to terrain edges.           

 l Low produces terrain that has sharp peaks and abrupt changes in slope, while High results in terrain that flows 
continuously from point to point but may take longer to generate.           

 l Select Linear to apply no smoothing to the Terrain. Instead, flat triangular surfaces are created between elevation 
points. This option is only recommended when large amounts of closely spaced elevation data is present.           

 
Triangle Count

Specify the number of surface triangles used to generate the terrain in 3D views. A lower count value will generate more 
quickly but have reduced quality.          

 l Specify a Custom triangle count value.           

 l Specify the maximum Triangle Size in the terrain surface. Smaller triangles produce better quality results in 3D but 
take longer to generate.          

Chief Architect builds 3D terrain surfaces by splitting them into triangles. See Terrain Surface Triangles on page 1252.

Triangles are computed roughly as follows:

Size of Triangle = Area of Terrain Perimeter / Number of Triangles

The Low (1000), Medium (2000), and High (4000) values work well for a terrain perimeter of approximately 20,000 sq ft 
(1858 m²). If your terrain perimeter varies greatly from this, consider defining the number of triangles using the Custom 
setting or the Triangle Size setting.

 
Clipping

Check Hide Terrain Intersected by Building to cut out the portion of the terrain that is intersected by the first floor 
footprint. Checking this box prevents the generation of contour lines inside the house. 

If your foundation footprint differs from your first floor footprint, you may need to use the Terrain Hole  tool for 

custom clipping instead. See Terrain Feature Tools on page 1258.

CONTOURS PANEL

Chief Architect Premier identifies two types of contour lines: Primary and Secondary. They are drawn on different layers, so 
you can control how they display in plan view. See Contour Lines on page 1263.          
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Frequency

Specify the Frequency at which contour lines are generated.         

 l Define the Interval between contour lines, which is the change in elevation between contours. If the interval is set to 
12”, a contour line is computed for each elevation change of 12”.          

 l Specify the Offset value. When the Offset is 0, a contour line will be drawn at zero elevation and additional contours 
will generate based on the Interval value. If the Offset is changed to 5, a contour line will be drawn 5 units from zero 
elevation rather than at 0, and additional contours will generate from there.          

 l Primary contour every__contours - Specify the interval for primary contours. A value of 1 produces only primary 
contours, while a value of 5 defines every fifth contour line as a primary contour.          

 
Smoothing

If contour Smoothing is turned on, Chief Architect attempts to remove sharp bends and jagged sections from the 2D 
contour lines.         

 l Specify the number of Passes to perform when smoothing. The more passes, the smoother the contour lines become, 
but contours become less accurate.          
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Label Options

Control the display of Contour Labels in plan view.          

 l Check Label Primary Contours to label primary contour lines with their elevation data using the Units specified 
below.           

 l Check Label Secondary Contours to label secondary contour lines with their elevation data.           

 l Check Highlight Negative Elevations to display labels of contour lines with elevations below 0 in red. When 
unchecked, they use the color set in the Text Style assigned to their layer.           

Primary and secondary contour line labels use the Text Style 
assigned to their respective layers. See Text Styles on page 

547.

 
Label Units

Specify the Label Units used by contour labels. Select either Inches or Decimal Feet (Millimeters or Meters for metric).         

POLYLINE PANEL

The POLYLINE panel states the length of the Terrain Perimeter’s Perimeter, its enclosed Area, and its Volume. 

The settings on this panel are available for a variety of other objects in the program. For information about these settings, 
see Polyline Panel on page 323.

SPLINE PANEL

The SPLINE panel has a single option and is only available if the Terrain Perimeter has been converted to a spline.  See 
Convert to Spline on page 261.          

New Segment Angle - Specify the angle between line segments that are used to draw the spline. Specifying a smaller angle 
makes the spline’s curvature smoother. Specify a larger angle to draw the spline faster.          

SELECTED LINE/ARC PANEL

The SELECTED LINE panel is available when the selected edge is a line as opposed to an arc. See Line Panel on page 309.

The SELECTED ARC panel is available when the selected edge has been converted into an arc. See Arc Panel on page 318.

See, too, Selected Edge on page 214 and Change Line/Arc on page 259.

LINE STYLE PANEL

The settings on the LINE STYLE panel are available for a variety of other objects in the program. See Line Style Panel on 
page 310.

FILL STYLE PANEL

The settings on the FILL STYLE panel affect the appearance of the Terrain Perimeter in plan view. See Fill Styles on page 
197.
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MATERIALS PANEL

The settings on the MATERIALS panel let you specify the terrain surface and terrain skirt materials used in 3D views. These 
materials are not calculated in the Materials List. See Materials Panel on page 1055.

LABEL PANEL

The Terrain Perimeter label displays in floor plan and cross section/elevation views when the “Terrain Labels” layer is 
turned on and use the Text Style assigned to that layer. In order for the label to display in a cross section/elevation view, the 
camera must be located outside the Terrain Perimeter so the surface of the skirt is visible. See Terrain and Road Labels on 
page 1264.          

For more information, see Label Panel on page 712.          

OBJECT INFORMATION PANEL

The information entered on the OBJECT INFORMATION panel can be used in schedules and the materials list. For more 
information, see Object Information Panel on page 1336.   

SCHEDULE PANEL

The settings on the SCHEDULE panel determine which schedule categories the selected object is included in. See Schedule 
Panel on page 716.   

 

Elevation Point Specification Dialog
To open the Elevation Point Specification dialog, select an elevation point and click the Open Object edit button, or 
double-click on an Elevation Point using the Select Objects  tool.

Use the Elevation Point Specification dialog to define the selected elevation point and control its appearance in plan view.          

GENERAL PANEL
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Location

Specify the exact location of the elevation point.         

 l Specify the Elevation of the selected Elevation Point.          

Click the Number Style button to specify the units of 
measurement used in this and other dialogs. See Dialog 

Number/Angle Style Dialog on page 131. 

 l X Position - Enter the x coordinate of the elevation point.         

 l Y Position - Enter the y coordinate of the elevation point.         

  Display

 l In the Text field, type any notes that you would like to display beside the selected Elevation Point in plan view.          

 l Click the Insert Macro  button to add a Text Macro such as %elevation% to the elevation point’s text, which 

displays in plan view. See Text Macros on page 549.           

 l Enter the Marker Radius, which is the size of the point marker, measured from the center to an edge.          

LINE STYLE PANEL

The settings on the LINE STYLE panel are available for a variety of other objects in the program. For information about these 
settings, see Line Style Panel on page 310.         

TEXT STYLE PANEL

The settings on the TEXT STYLE panel control the appearance of the selected Elevation Point’s text. For more information, 
see Text Style Panel on page 547.          

 

Elevation Line/Region Specification Dialog
To open the Elevation Line or Elevation Region Specification dialog, select an Elevation Line, Spline, a polyline 
composed of Elevation Lines or Splines, or an Elevation Region and click the Open Object edit button. You can also 

double-click an Elevation Line/Spline using the Select Objects  tool.

The Elevation Line Specification dialog is used to define the selected Elevation Line             /Spline and controls its appearance in 
plan view.          

The settings in this dialog are the same as those in the Elevation Region Specification dialog. See Elevation Regions on 
page 1255.          
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ELEVATION PANEL

 l Specify the Elevation of the selected Elevation Line, Spline, or Polyline.         

Click the Number Style button to specify the units of 
measurement used in this and other dialogs. See Dialog 

Number/Angle Style Dialog on page 131. 

 l Check Interior is Flat to maintain a flat surface at the specified Elevation. When unchecked, the perimeter of the 
region maintains the specified Elevation, but the interior elevation may vary depending on other elevation data in the 
drawing. Only available for closed Elevation Regions.          

 l Check Interpolate Tangent to Edge to flatten the terrain surface as it approaches the edges of the Elevation Region. 
This option is only available for closed Elevation Regions, and only when Interior is Flat is unchecked.           

POLYLINE PANEL

The POLYLINE panel states the Length of an open polyline or the Perimeter of a closed polyline. If multiple Elevation Line             
/Spline segments form a closed Elevation Region, its Area will be calculated. Elevation Lines             /Splines do not have a 
thickness, so they have no Volume.         

SPLINE PANEL

The SPLINE panel has a single option and is only available when the selected object is an Elevation Spline. See Splines on 
page 330.          

New Segment Angle - Specify the angle between line segments that are used to draw the spline. Specifying a smaller angle 
makes the spline smoother. Specify a larger angle to draw the spline faster.          

SELECTED LINE/ARC PANEL

The SELECTED LINE panel is available when the selected edge is a line as opposed to an arc. See Line Panel on page 309.         

The SELECTED ARC panel is available when the selected edge has been converted into an arc. See Arc Panel on page 318.         

See, too, Selected Edge on page 214 and Change Line/Arc on page 259.         

LINE STYLE PANEL

The settings on the LINE STYLE panel are available for a variety of other objects in the program. See Line Style Panel on 
page 310.         
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LABEL PANEL

Elevation Line, Polyline, and Region labels displays in plan view when the “Terrain Labels” layer is turned on and use the 
Text Style assigned to that layer. The default label reports the selected object's Elevation value in feet (mm). See Terrain 
and Road Labels on page 1264.          

For more information, see Label Panel on page 712.          

 

Flat Region Specification Dialog
To open the Flat Region Specification dialog, select a Flat Region and click the Open Object edit button, or double-
click a Flat Region using the Select Objects  tool. See Flat Regions on page 1258.          

The options in the Flat Region Specification dialog are similar to those a number of other dialogs in the program.          

POLYLINE PANEL

The POLYLINE panel states the length of the region’s Perimeter and its enclosed Area. Flat Regions do not have a Volume 
measurement. See Polyline Panel on page 323.           

SPLINE PANEL

The SPLINE panel has a single option and is only available when the selected object is a spline.  See Splines on page 330.         

New Segment Angle - Specify the angle between line segments that are used to draw the spline. Specifying a smaller angle 
makes the spline smoother. Specify a larger angle to draw the spline faster.          

SELECTED LINE/ARC PANEL

The SELECTED LINE panel is available when the selected edge is a line as opposed to an arc. See Line Panel on page 309.          

The SELECTED ARC panel is available when the selected edge has been converted into an arc. See Arc Panel on page 318.          

See, too, Selected Edge on page 214 and Change Line/Arc on page 259.          

LINE STYLE PANEL

The settings on the LINE STYLE panel are available for a variety of objects in the program. See Line Style Panel on page 
310.          

FILL STYLE PANEL

The settings on the FILL STYLE panel affect the appearance of the selected object in plan view. See Fill Styles on page 197.          

LABEL PANEL

Labels for Flat Regions display in plan view when the “Terrain Labels” layer is turned on and use the Text Style assigned to 
that layer. In order to display in a cross section/elevation view, the camera must be located outside the Terrain Perimeter so 
the surface of the skirt is visible. See Terrain and Road Labels on page 1264.     
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For more information, see Label Panel on page 712.     

OBJECT INFORMATION PANEL

The information entered on the OBJECT INFORMATION panel can be used in schedules and the materials list. For more 
information, see Object Information Panel on page 1336.    

SCHEDULE PANEL

The settings on the SCHEDULE panel determine which schedule categories the selected object is included in. See Schedule 
Panel on page 716.     

 

Hill / Valley Specification Dialog
The Hill/Valley Specification defines the selected Hill or Valley and controls its appearance in plan view.          

To open the Hill/Valley Specification dialog, select one or more Hills or Valleys and click the Open Object edit button, or 
double-click the region(s) using the Select Objects  tool.

HILL / VALLEY PANEL

 l Enter a Height for the selected Hill or Valley. This height is relative to the terrain surface that is generated from the 
Elevation Data in your plan. See Terrain Modifier Tools on page 1257.         

POLYLINE PANEL

The POLYLINE panel states the length of the hill or valley’s Perimeter and its enclosed Area. Hills and Valleys do not have 
a volume measurement.          

SPLINE PANEL

The SPLINE panel has a single option and is only available when the selected object is a spline. See Splines on page 330.

New Segment Angle - Specify the angle between line segments that are used to draw the spline. Specifying a smaller angle 
makes the spline smoother. Specify a larger angle to draw the spline faster.          

SELECTED LINE/ARC PANEL

The SELECTED LINE and/or SELECTED ARC panels are only available if the selected Hill or Valley has been converted to a 
polyline. See Convert Spline to Polyline on page 269.          

The SELECTED LINE panel is available when the selected edge is a line as opposed to an arc. See Line Panel on page 309.          
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The SELECTED ARC panel is available when the selected edge has been converted into an arc. See Arc Panel on page 318.          

See, too, Selected Edge on page 214 and Change Line/Arc on page 259.          

LINE STYLE PANEL

The settings on the LINE STYLE panel are available for a variety of other objects in the program. See Line Style Panel on 
page 310.         

FILL STYLE PANEL

The settings on the FILL STYLE panel affect the appearance of the selected object in plan view. See Fill Styles on page 197.         

LABEL PANEL

Hill and Valley labels display in plan view when the “Terrain Labels” layer is turned on and use the Text Style assigned to 
that layer. Hill and Valley labels do not display in elevation views. See Terrain and Road Labels on page 1264.          

For more information, see Label Panel on page 712.          

OBJECT INFORMATION PANEL

The information entered on the OBJECT INFORMATION panel can be used in schedules and the materials list. For more 
information, see Object Information Panel on page 1336.    

SCHEDULE PANEL

The settings on the SCHEDULE panel determine which schedule categories the selected object is included in. See Schedule 
Panel on page 716.     

 

Raised / Lowered Region Specification Dialog
To open the Raised/Lowered Region Specification dialog, select one or more raised or lowered regions and click the 
Open Object edit button, or double-click the region(s) using the Select Objects  tool.

The Raised / Lowered Region Specification dialog is similar to the Hill / Valley Specification dialog. See Hill / Valley 
Specification Dialog on page 1274.         

 

Terrain Feature Specification Dialog
To open the Terrain Feature Specification dialog, select a Terrain Feature or group of Terrain Features and click the 
Open Object edit button, or double-click the Terrain Feature(s) using the Select Objects  tool.

Most of the panels in this dialog are similar to those for a variety of other objects in the program, including Ponds and 
Stepping Stones.

Garden Beds are also a type of Terrain Feature and have an additional Distributed Plant panel in their specification dialog. 

The panels that are available in the Terrain Feature Specification dialogs will vary, depending on the type of Terrain Feature 
that is selected.
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GENERAL PANEL

 l Specify the Terrain to Top value, which is the distance from the top surface of the terrain to that of the terrain 
feature. If this value is a negative number, the feature sinks into the terrain.    

 l Specify the feature’s Thickness.
 l Check Make Hole to specify the selected Terrain Feature as a Terrain Hole. See Terrain Holes on page 1259.          
 l Check Clip Overlapping Terrain Features to suppress the 3D display of any part of the selected Terrain Feature 

intersected by other Terrain Features with a lower Terrain to Top value. Clipping is useful for creating features that 
contain other features such as planters or swimming pools.

DISTRIBUTED PLANT PANEL

This panel is only available when the selected Terrain Feature is a Garden Bed. See              Distributed Object Panel - Distribution 
Region on page 1044.

POLYLINE PANEL

The POLYLINE panel states the length of the garden bed’s Perimeter, its enclosed Area, and its Volume. See Polyline Panel 
on page 323. 

SPLINE PANEL

The SPLINE panel has a single option and is only available when the selected object is a spline.  See Splines on page 330.         

New Segment Angle - Specify the angle between line segments that are used to draw the spline. Specifying a smaller angle 
makes the spline smoother. Specify a larger angle to draw the spline faster. 

SELECTED LINE/ARC PANEL

The SELECTED LINE panel is available when the selected edge is a line as opposed to an arc or when the selected object is a 
spline. See Line Panel on page 309.

The SELECTED ARC panel is available when the selected edge has been converted into an arc. See Arc Panel on page 318.

See, too, Selected Edge on page 214 and Change Line/Arc on page 259.
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LINE STYLE PANEL

The settings on the LINE STYLE panel are available for a variety of other objects in the program. See Line Style Panel on 
page 310.

FILL STYLE PANEL

The settings on the FILL STYLE panel affect the appearance of the selected object in plan view. See Fill Styles on page 197.

MATERIALS PANEL

The settings on the MATERIALS panel affect the appearance of the selected object in 3D views. See Materials Panel on page 
1055.

LABEL PANEL

Terrain Feature labels display in floor plan and cross section/elevation views when the “Terrain Labels” layer is turned on 
and use the Text Style assigned to that layer. In order for the label to display in a cross section/elevation view, the feature's 
Terrain to Top value must be a positive value so a side surface is visible above the terrain and the camera must be located 
outside the feature's perimeter so a side surface is visible. See Terrain and Road Labels on page 1264.          

For more information, see Label Panel on page 712.          

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 1335.          

OBJECT INFORMATION PANEL

The information entered on the OBJECT INFORMATION panel can be used in schedules and the materials list. For more 
information, see Object Information Panel on page 1336.    

SCHEDULE PANEL

The settings on the SCHEDULE panel determine which schedule categories the selected object is included in. See Schedule 
Panel on page 716.   

 

Garden Bed Specification Dialog
To open the Garden Bed Specification dialog, select one or more Garden Beds and click the Open Object edit 
button, or double-click on a Garden Bed using the Select Objects  tool.

Because a Garden Bed is a type of Terrain Feature, the settings in this dialog are essentially the same as those in the Terrain 
Feature Specification dialog. See Terrain Feature Specification Dialog on page 1275.

Garden Beds also include the Distributed Objects panel found in the Distribution Region Specification dialog. See 
Distribution Region/Path Specification Dialogs on page 1044.          
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Terrain Break Specification Dialog
To open the Terrain Break Specification dialog, select a Terrain Break or group of Terrain Breaks and click the Open 
Object edit button or double-click the Terrain Break(s) using the Select Objects  tool. See Terrain Breaks on 

page 1256. 

GENERAL PANEL

 l Define the Transition Distance, which is the distance from the edge of the terrain break to where the break stops 
affecting the terrain.           

POLYLINE PANEL

The POLYLINE panel states the Length of an open polyline or the Perimeter of a closed polyline. If multiple Terrain Break 
segments form a closed polyline, its Area will be calculated. Terrain Breaks do not have a thickness, so they have no 
Volume. See Polyline Panel on page 323.           

SELECTED LINE/ARC PANEL

The SELECTED LINE panel is available when the selected edge is a line as opposed to an arc. See Line Panel on page 309.          

The SELECTED ARC panel is available when the selected edge has been converted into an arc. See Arc Panel on page 318.          

See, too, Selected Edge on page 214 and Change Line/Arc on page 259.          

SPLINE PANEL

The SPLINE panel has a single option and is only available when the selected object was converted to a Terrain Break from a 
spline.  See Splines on page 330.          

New Segment Angle - Specify the angle between line segments that are used to draw the spline. Specifying a smaller angle 
makes the spline smoother. Specify a larger angle to draw the spline faster.          

LINE STYLE PANEL

For information about the LINE STYLE panel, see Line Style Panel on page 310.          

FILL STYLE PANEL

The FILL STYLE panel is only available when multiple Terrain Break segments enclose an area. The settings on this panel 
affect the appearance of the closed shape in plan view. See Fill Styles on page 197.          
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Terrain Path Specification Dialog
To open the Terrain Path Specification dialog, select one or more Sidewalks, Streams, Terrain Walls, or Terrain 
Curbs and click the Open Object edit button, or double-click the terrain path(s) using the Select Objects  tool.

Most of the panels in this dialog are similar to those for a variety of other objects in the program.

GENERAL PANEL

The settings on the GENERAL panel are also found in the Road Specification dialog. See General Panel on page 1295.

  Size

 l Specify the path's Width.     

 l Specify the Terrain to Top value, which is the distance from the top surface of the terrain to that of the path. If this 
value is a negative number, the object sinks into the terrain.     

 l Specify the path's Thickness.    

 
Flare

When one terrain path joins another, you can flare the intersection.          

 l Check Start to create a flare at the starting end of the selected terrain path, then specify the Radius of that flare.          

 l Check End to create a flare at that end of the terrain path, then specify the Radius of that flare.          

 
Preview

A preview of the selected cabinet displays on the right side of the panel. See Dialog Preview Panes on page 22. 

1279



Chief Architect Premier X14 Reference Manual - Terrain Path Specification Dialog

POLYLINE PANEL

The POLYLINE panel states the length of the Terrain Path’s Perimeter, its enclosed Area, and its Volume. See Polyline 
Panel on page 323. 

SPLINE PANEL

The SPLINE panel has a single option and is only available when the selected object is a spline path. See Splines on page 
330.          

 l New Segment Angle - Specify the angle between line segments that are used to draw the spline. Specifying a smaller 
angle makes the spline smoother. Specify a larger angle to draw the spline faster.          

SELECTED LINE/ARC PANEL

The SELECTED LINE panel is available when the selected edge is a line as opposed to an arc. See Line Panel on page 309.

The SELECTED ARC panel is available when the selected edge has been converted into an arc. See Arc Panel on page 318.

See, too, Selected Edge on page 214 and Change Line/Arc on page 259.

LINE STYLE PANEL

The settings on the LINE STYLE panel are available for a variety of other objects in the program. See Line Style Panel on 
page 310.

FILL STYLE PANEL

The settings on the FILL STYLE panel affect the appearance of the selected object in plan view. See Fill Styles on page 197.

MATERIALS PANEL

The settings on the MATERIALS panel affect the appearance of the selected object in 3D views. See Materials Panel on page 
1055.

LABEL PANEL

Terrain Path labels display in floor plan and cross section/elevation views when the “Terrain Labels” layer is turned on and 
use the Text Style assigned to that layer. In order for the label to display in a cross section/elevation view, one of the path's 
side surface must be visible in the view. See Terrain and Road Labels on page 1264.          

For more information, see Label Panel on page 712.          

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 1335.   
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OBJECT INFORMATION PANEL

The OBJECT INFORMATION panel is only available for Distribution Regions. The information entered on this panel can be 
used in schedules and the materials list. For more information, see Object Information Panel on page 1336.    

SCHEDULE PANEL

The SCHEDULE panel is only available for Distribution Regions. The options this panel determines which schedule 
categories the selected object is included in. See Schedule Panel on page 716.     

 

Importing Elevation Data
Elevation data can be added to a plan using the tools and techniques described in this chapter or it can be imported from a 
file. See Elevation Data Tools on page 1252.         

Chief Architect Premier can import elevation data saved in              DXF/DWG, GPS Exchange (.gpx) and a variety of text file 
formats (.txt, .csv, .prn, .xyz, .auf and .nez). If your terrain data is not saved in one of these file formats, there are third 
party programs available that can convert to these formats.          

DXF/DWG FILES

If you have a model of your terrain created on another program that contains contour lines and elevation data, that 
information can be imported directly as elevation data into Chief Architect Premier as a .dxf or a .dwg file. See Importing 
DWG/DXF Elevation Data on page 1287.          

TEXT FILES

Elevation data can be saved in text files as x, y, and z coordinates where x and y define the location of a point on a 
Cartesian grid, and z defines the elevation for that point. Each data point must be on a separate line in the text file.          

Importable text files can come from surveyors, other software programs, or you can create your own using a GPS system.          

Elevation data saved in text files can be imported using the Import Terrain Assistant.              See Import Terrain Assistant on page 
1282.         

GPS EXCHANGE FILES

Elevation data in standard format .gpx files created using a GPS system can also be imported using the Import GPS Data 
Assistant. See Import GPS Data Assistant on page 1285.          

GPS data may include three types of points - Way, Track, and Route. Chief Architect Premier can only import a .gpx file if 
it includes one or more Way Points, and cannot use Route Points at all. If a .gpx file does not include any Way Points, it 
will not be imported, and if it includes any Route Points, they will be ignored.           

Chief Architect supports the import of data in standard .gpx files that adhere to the GPX 1.1 Schema. Files that do not 
follow this standard cannot be imported.         
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Import Terrain Assistant
The Import Terrain Assistant allows you to import elevation data saved in text (.txt) file format into a plan.         

Each data point in this format has information about its X-axis (East to West location), Y-axis (North to South location), and 
Z-axis (elevation). It might also have a brief description. In order to import elevation data from a text file, you need to know 
how the data in the file is organized.          

To launch the Import Terrain Assistant, select File> Import> Terrain Data . Click Next.         

SELECT FILE

  Select a file to import

 l Click the Browse button to locate a file on your computer. See Importing Files on page 45.          

 l If a file has been selected, its full pathname displays here for reference; if a file has not been selected, the directory 
of the last file imported displays. If the pathname is not that of a valid .txt file, this text will display in red.          
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  Select the organization of the data

 l Elevation information can be organized in one of six different ways, and can be separated by either a comma 
(comma delimited) or a space (space delimited).          

 l XYZ - Information in this format begins with the X coordinate, followed by the Y coordinate and the Z coordinate.         

 l #XYZ - Information in this format begins with a number that belongs to each data point followed by the X 
coordinate, the Y coordinate, and the Z coordinate.         

 l #XYZ Description - Information in this format begins with a number that belongs to each data point followed by the 
X coordinate, the Y coordinate, the Z coordinate, and a description.         

 l YXZ - Information in this format begins with the Y coordinate followed by the X coordinate and the Z coordinate.         

 l #YXZ - Information in this format begins with a number that belongs to each data point followed by the Y 
coordinate, the X coordinate, and the Z coordinate.         

 l #YXZ Description - Information in this format begins with a number that belongs to each data point followed by the 
Y coordinate, the X coordinate, the Z coordinate, and a description.         

Click Next to continue.         

FILTER DATA

 
Imported Data

The number of elevation points that the text file contains displays here for reference.         

Building terrain with a lot of elevation data can take a long time. If your text file has more than 1000 or 2000 elevation 
points, consider filtering it using the settings that follow.           

You may also want to use the Linear Smoothing option in the Terrain Specification dialog. See General Panel on page 
1266.           
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  Restrict the imported data to these ranges

One way to filter the data used is to define a range for each axis: X, Y, and Z. Data within these ranges is imported, while 
data outside these ranges is not.           

In the following diagram, the outer rectangle and the points within it represent all of the data contained in a given text file. 
The smaller rectangle represents a subset of this data, defined by ranges on the X and Y axes.

  Reduce the amount of data imported

Another way to filter the imported data is by excluding elevation points.           

Enter the total number of points to be imported. The points selected for import are found evenly distributed in the original 
file.           

Click Next to continue.          

SCALE DATA

  Imported Data

 l The total number of data points to be imported and the ranges of their coordinates are described here.
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  Units

 l Select the Units of measurement used for each axis.

  Map

 l Map a data point in the file to the origin in Chief Architect to position the terrain data relative to your plan. See 3D 
Drafting on page 12.

  Scale 

 l To change the scale of the terrain, multiply the coordinates of each axis by a specific number to decrease or increase 
the relative size or relief of your terrain.

  Rotate North Counterclockwise

 l Specify an amount to rotate the terrain data counterclockwise, or to the left.
Click Next to finish.

 

Import GPS Data Assistant
The Import GPS Data Assistant allows you to import terrain data from the standard .gpx file format. See GPS 
Exchange Files on page 1281.         

Select File> Import> GPS Data to open the Import GPS Data Assistant, then click Next to continue.         

 Due to the lack of accuracy in some GPS systems, exact 
distances using the Import GPS Data Assistant are not 

guaranteed.

SELECT FILE
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  Select a file to import

 l Click the Browse button to locate a .gpx file on your computer. See Importing Files on page 45.          

 l If a file has been selected, its full pathname is reported here for reference; if a file has not been selected, the 
directory of the last file imported displays. If the pathname is not that of a valid .gpx file, this text will display in 
red.          

Note: Not all GPS programs use the standard .gpx file format; 
however, only files using the standard format can be imported.

Click Next to continue.

IMPORT DATA AS

 
Name

Specify which items you want to import by checking the box to the left of the Name. Items with unchecked boxes are not 
imported.         

 
Import As

Specify what you would like the selected item to Import As from the drop-down list.         

 l Only Way Points have elevation data associated with them. To import this data, import them as “Elevation Points”.          

 l Select “Marker” to import either Way Points or Track Points as location markers. Markers have no elevation data 
associated with them.         

 l Select “Polyline” to create an open CAD polyline based on the position of Way Points or Track Points. The points 
themselves are not imported. Polylines have no elevation data associated with them.         

 l Select “Terrain Perimeter” to create a closed Terrain Perimeter polyline based on the position of either Way Points 
or Track Points. The points themselves are not imported. A Terrain Perimeter has no elevation data associated with 
it. See Terrain Perimeter on page 1250.          

Way Points are typically imported as “Elevation Data”, 
while Track Points are imported as “Markers”, “Polylines’, 

or “Terrain Perimeter”. 

Click Next to continue.
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TRANSFORM COORDINATES

  Lower Elevation Data by

 l Specify the amount that you would like to lower all imported elevation data.          

  Rotate North Counterclockwise

 l Specify an amount to rotate the terrain data counterclockwise, or to the left.           

  Map this point to the origin

 l Specify a point in the imported terrain data, defined by degrees Latitude and Longitude, that you would like to 
locate at the origin in the Chief Architect plan.          

Click Next to finish.

If you do not see the imported terrain, select Window> Fill Window .

 

Importing DWG/DXF Elevation Data
Select File> Import> Drawing (DWG/DXF)  to open the Import Drawing Assistant, which you can use to import 
elevation data in .dwg/.dxf format. See Import Drawing Assistant on page 1228. 

By default, the Import Drawing Assistant imports entities as regular CAD objects; however, you can specify that any layer 
in the drawing be converted to either a Terrain Perimeter or Elevation Data. If a layer is converted to Elevation Data, any 
points and lines on that layer are converted to Elevation Points and Lines, and any elevation data associated with them is 
preserved. Elevation data associated with objects in CAD blocks is not recognized, however.

 l If an imported line has vertices with the same Z values, an Elevation Line is created.
 l If the vertices have differing Z values, an Elevation Point is created for each vertex.
 l Imported points are converted to Elevation Points.
 l Other imported entities (solids, faces, etc.) are imported normally.

To avoid unexpected results when importing a drawing, only 
convert layers with elevation information to Elevation Data. 
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If a Terrain Perimeter does not exist in the plan or if a layer in the .dwg/.dxf file is not converted to a Terrain Perimeter, a 
Terrain Perimeter is created around the extents of the Elevation Data when it is imported.  

 

Converting CAD Objects to Terrain Data
CAD lines, splines, and polylines - either imported or drawn using Chief Architect Premier’s CAD Tools - can be 
selected and converted to terrain data using the Convert Polyline edit tool.

In plan view, select a CAD line, spline, or polyline and click the Convert Polyline  edit button to open the Convert 

Polyline dialog. See Convert Polyline on page 265.

A Terrain Perimeter must exist before any other types of terrain object can be created. If no Terrain Perimeter is present in 
the current plan, this will be the only terrain item available in the Convert Polyline dialog.            

When you click OK, the terrain object’s specification dialog opens, allowing you to specify elevation data or other 
attributes.
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Chapter 38
 

Roads, Driveways, and Sidewalks

Roads, sidewalks, driveways and parking lots are modeled in 3D like other terrain objects in Chief Architect. Because they 
have much in common with terrain objects and rely upon terrain data to be viewed in 3D, it is helpful to be familiar with 
terrain modeling before using these tools. See Terrain on page 1249.

TOPICS

Road and Sidewalk Defaults 1290
Road, Driveway, and Sidewalk Tools 1290
Displaying Road Objects 1293
Editing Road Objects 1294
Road Specification Dialog 1295
Road Marking Specification Dialog 1297
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Road and Sidewalk Defaults
Default Settings can be accessed by selecting Edit> Default Settings. Click the + beside Roads, Sidewalks and 
Driveways to display the subheadings. See Default Settings on page 76.

The settings in the Road Defaults, Driveway Defaults, Road Marking Defaults, and Sidewalk Defaults dialogs determine the 
initial settings when the road and sidewalk tools are used. It is a good idea to check these settings before placing any roads 
or sidewalks in your plan. 

ROAD DEFAULTS

You can access the Road Defaults dialog from the Default Settings dialog, or by double-clicking the Road Tools  button. 

The settings in this dialog are the same as those in the Road Specification dialog. See Road Specification Dialog on page 
1295.

DRIVEWAY DEFAULTS

You can access the Driveway Defaults dialog from the Default Settings dialog, or by double-clicking the Driveway  

button. 

The settings in this dialog are the same as those in the Terrain Path Specification dialog. See Terrain Path Specification 
Dialog on page 1279.

ROAD MARKING DEFAULTS

You can access the Road Marking Defaults dialog from the Default Settings dialog, or by double-clicking the Road 
Marking  button. 

The settings in this dialog are the same as those in the Road Marking Specification dialog. See Road Marking Specification 
Dialog on page 1297.

SIDEWALK DEFAULTS

You can access the Sidewalk Defaults dialog from the Default Settings dialog, or by double-clicking the Sidewalk  

button. 

The settings in this dialog are the same as those in the Terrain Path Specification dialog, but only affect sidewalks and not 
other types of terrain paths. See Terrain Path Specification Dialog on page 1279.

 

Road, Driveway, and Sidewalk Tools
Roads objects can be drawn in plan view, camera views and overviews, but only when a Terrain Perimeter exists in 
the plan. See Terrain Perimeter on page 1250. 

When road objects are first placed into your plan, their initial dimensions and properties are controlled by their default 
settings. See Road and Sidewalk Defaults on page 1290.          

Straight and Spline road objects:
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 l Are typical line- and spline-based objects, and can be edited as such. 
 l Are flat along their widths, which makes it easy to create roads on sloping terrain.
 l Can be joined end-to-end to form intersections and networks.
 l Have a consistent width that can be defined in their specification dialogs. See Road Specification Dialog on page 1295 

and Terrain Path Specification Dialog on page 1279. 

Polyline road objects, on the other hand, are actually Terrain Features which follow the contours of the terrain rather than 
cut into them. They are drawn as rectangles but can be edited to any shape. See Terrain Feature Tools on page 1258 and 
Editing Closed Polyline-Based Objects on page 230.

Roads have curbs, and Sidewalks and Driveways cut out curbs and gutters wherever they meet a Road or a Road Polyline.         

The Convert Polyline  edit tool can be used to convert a CAD polyline into a number of types of road object. See 

Convert Polyline on page 265.          

Once road objects have been placed, they can be edited individually or as a group. See Editing Road Objects on page 1294.

ROAD TOOLS

Select Terrain> Road> Straight Road, then click and drag to draw a line within the Terrain Perimeter to draw a 
Straight Road. 

The ends of multiple road sections can be connected together. Roads are edited along their center line and can be edited 
much like other line-based objects. See Editing Line-Based Objects on page 218.

Select Terrain> Road> Spline Road, then click and drag to draw a curved road composed of spline segments. 

Spline roads are drawn and edited like other spline-based objects. See Editing Spline-Based Objects on page 237. 

Select Terrain> Road> Polyline Road, then click and drag to draw a rectangular polyline which can then be edited 
to any shape.         

Select Terrain> Road> Median, then click and drag within a road to draw a rectangular polyline that cuts a hole in a 
road, revealing the terrain material beneath. If the road has a curb, the Median receives one as well.         
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A Cul-de-sac is a road object with a special, rounded shape that can be placed at the end of a Road object. Select 
Terrain> Road> Cul-de-sac and click on the end of a road to place a cul-de-sac at that location. Culs-de-sac cannot 

be connected to the edge of Road Polylines.         

Select Terrain> Road> Road Marking, then click and drag within a road to draw a rectangular region with a 
different material than the road surface.         

Select Terrain> Road> Road Stripe, then click and drag within a road to draw a stripe of road marking material on 
the road surface. Multiple road stripes can be connected together.         

DRIVEWAY TOOLS

Select Terrain> Driveway> Straight Driveway, then click and drag a line within the Terrain Perimeter. Multiple 
driveway sections can be connected together.         

Driveways are edited like other line-based objects. See Editing Line-Based Objects on page 218.           

Use the Spline Driveway tool to create a curved driveway. Select Terrain> Driveway> Spline Driveway. Spline 
driveways are drawn and edited like CAD splines. See Splines on page 330.         

Select Terrain> Driveway> Driveway Polyline, then click and drag within the Terrain Perimeter to draw a 
rectangular polyline which can then be edited to any shape.          

Driveway polylines are edited just like CAD polylines. See Editing Closed Polyline-Based Objects on page 230.          

SIDEWALK TOOLS

To create a sidewalk with no curves, select Terrain> Sidewalk> Straight Sidewalk, then click and drag a line 
within the Terrain Perimeter.

Sidewalks are edited along their center line like line-based objects. See Editing Line-Based Objects on page 218. 
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Select Terrain> Sidewalk> Spline Sidewalk, then click and drag to draw a curved sidewalk composed of spline 
segments. 

Select Terrain> Sidewalk> Sidewalk Polyline, then click and drag within the Terrain Perimeter to draw a 
rectangular polyline which can then be edited to any shape.          

Select a Road or Median and click the Auto Generate Sidewalk edit button to open the Auto Generate Sidewalks 
dialog.         

 l Left/Right Side of Road - Check one or both boxes to generate a sidewalk on the selected road object.             
 l Check All Connected Roads to generate a sidewalk along all other roads connected to the selected road object.             
 l Offset From Road - Specify a gap between the generated sidewalk and the selected road object.             

 

Displaying Road Objects
Roads and sidewalks display in floor plan and 3D views based on the settings for their layers in the Layer Display 
Options dialog. See Layers on page 180.

IN 3D VIEWS

In order for Road objects to be visible in 3D views, they must be drawn within the Terrain Perimeter. Any portions of these 
objects drawn outside the Terrain Perimeter will not be seen in 3D views. 

By default, the terrain rebuilds automatically when road objects are added, removed or edited. If it does not, you can select 
Terrain> Build Terrain . See Terrain Perimeter on page 1250.

IN SCHEDULES

Like a variety of other objects, Road objects can be included in schedules. See The Schedule Tools on page 695.

By default, Driveways, Medians, Roads, and Road Markings are listed in schedule categories of the same names while 
Sidewalks are listed in the "Terrain Paths" category. You can, however, assign a selected object to the category of your 
choice in its specification dialog. See Schedule Panel on page 716.
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Editing Road Objects
Road objects can be selected in 2D and 3D views and edited using the edit handles, the Edit Toolbar, and their specification 
dialogs. 

Terrain Walls  and Terrain Curbs are also Road objects. See Terrain Wall and Curb Tools on page 1261.

USING THE EDIT HANDLES

The edit handles available for a selected road object depend on the type of object selected. 

 l Straight Roads , straight Driveways , straight Road Stripes , straight Terrain Walls , and straight 

Terrain Curbs  are edited along their centerline like a line or open polyline. See Editing Line-Based Objects on 

page 218. 
 l Spline Roads , Spline Sidewalks, Spline Terrain Walls  are edited along their centerline like CAD splines. 

See Editing Spline-Based Objects on page 237.
 l Polyline Roads , Culs-de-sac , Medians , Road Markings  Polyline Driveways  and Polyline 

Sidewalks  are edited along their perimeter, like standard polylines. The width is determined by the polyline’s 

shape. See Editing Closed Polyline-Based Objects on page 230.             
 l Medians  are also edited like polylines.             

IN THE SPECIFICATION DIALOG

Road objects can be customized in their specification dialogs. See Road Specification Dialog on page 1295, Terrain 
Feature Specification Dialog on page 1275, and Terrain Path Specification Dialog on page 1279.

USING THE EDIT TOOLS

A selected road object can be edited in a variety of ways using the buttons on the Edit Toolbar. See The Edit Toolbar on 
page 135.

CONVERT TO POLYLINE OBJECT

A selected Straight or Spline Road, Sidewalk or Driveway can be converted into a Polyline Road, Sidewalk or 
Driveway by clicking the Convert to Polyline Object edit button.          

Polyline Roads, Sidewalks and Driveways display the same edit handles as closed polylines, allowing you to edit their 
shapes as much as needed.           

ADDING ROAD OBJECTS TO THE LIBRARY

You can create your own road objects and save them to the library. Select any combination of elevation points, elevation 
lines, terrain features, roads, sidewalks, road markings, or even the terrain perimeter itself and send them to the library as 
one unit. 

When a group of terrain objects from the library is placed into a plan, each object  becomes independent and can be edited 
individually. See Adding Library Content on page 973. 
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Road Specification Dialog
To open the Road Specification dialog, select a Straight Road, Spline Road, Polyline Road, Median, or Cul-de-sac 
and click the Open Object edit button.          

The settings in this dialog are also found in the Road Defaults dialog. See Road and Sidewalk Defaults on page 1290.          

Many of the settings in this dialog are similar to those in the Terrain Path Specification dialog. See Terrain Path 
Specification Dialog on page 1279.         

GENERAL PANEL

  Size

 l Specify the road's Width. Not available for culs-de-sac and non-centerline roads.

 l Specify the Terrain to Top value, which is the distance from the top surface of the terrain to that of the road. If this 
value is a negative number, the road sinks into the terrain.      

 l Specify the road's Thickness.       

 
Flare

When one road intersects another, flares can be specified.                 

 l Check Start to create a flare at the starting end of the selected road, then specify the Radius of that flare.          

 l Check End to create a flare at the end of the selected road, then specify the Radius of that flare.          

Flaring is not available for culs-de-sac, medians, or non-centerline roads.     
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Preview

A preview of the selected road displays on the right side of the panel. See Dialog Preview Panes on page 22. 

CURB PANEL

  Curb

 l Check Has Curb if you want the selected road to include a curb.           

 l Click Select Curb Profile to apply a different curb profile to the selected road.          

 l Click Default Curb Profile to use the profile set in the Road Defaults dialog. In the Road Defaults dialog, clicking 
this button will reset the straight-sided system default curb profile.          

 l Enter Height and Width values for the curb.          

 l Check Cut Curb for Driveways and Sidewalks to cut the curb for driveways and sidewalks.           

 l A preview of the selected profile displays to the right of the settings.           

 
Preview

A preview of the selected cabinet displays on the right side of the panel. See Dialog Preview Panes on page 22. 

POLYLINE PANEL

The POLYLINE panel states the length of the road’s Perimeter, its Area and its Volume.              Not available in the Road Defaults 
dialog. For more information, see Polyline Panel on page 323.          

SELECTED LINE/ARC PANEL

The SELECTED LINE panel is available when a Straight Road is selected. For more information, see Line Panel on page 309.           

The SELECTED ARC panel is available when the curved segment of a  Straight Road is selected. See Arc Panel on page 318.           

See, too, Selected Edge on page 214 and Change Line/Arc on page 259. 

SPLINE PANEL

The SPLINE panel is available when a Spline Road is selected. Specify the angle between the line segments used to draw the 
spline. For more information, see Spline Panel on page 324.           
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LINE STYLE PANEL

This panel is the same as the LINE STYLE panel in many other specification dialogs. See Line Style Panel on page 310.          

FILL STYLE PANEL

The settings on the FILL STYLE panel affect the appearance of the selected object in plan view. For information about these 
settings, see Fill Styles on page 197.         

MATERIALS PANEL

The settings on the MATERIALS panel affect the appearance of the selected object in 3D views. For information about these 
settings, see Materials Panel on page 1055.         

The Curb material is not calculated in the Materials List. See Materials Lists on page 1309.          

LABEL PANEL

Road labels displays in floor plan and cross section/elevation views when the “Terrain Labels” layer is turned on and use the 
Text Style assigned to that layer. See Terrain and Road Labels on page 1264.          

For more information, see Label Panel on page 712.          

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 1335.  

 

Road Marking Specification Dialog
Select a Road Marking or Road Stripe and click the Open Object edit button to open the Road Marking Specification 
dialog.

The settings in this dialog are also found in the Road Marking Defaults dialog.

GENERAL PANEL

The GENERAL panel is only available for Road Stripes . See Road Tools on page 1291.

Enter a Width value for the selected Road Stripe. 

POLYLINE PANEL

The POLYLINE panel states the length of the road marking’s Perimeter, its Area, and its Volume.  Not available in the Road 
Marking Defaults dialog. For more information, see Polyline Panel on page 323.
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SELECTED LINE/ARC PANEL

The SELECTED LINE panel is available when the straight segment of a road marking is selected. See Line Panel on page 309. 

The SELECTED ARC panel is available when the curved segment of a road marking is selected. See Arc Panel on page 318.

See, too, Selected Edge on page 214 and Change Line/Arc on page 259. 

LINE STYLE PANEL

This panel is the same as the LINE STYLE panel in many other specification dialogs and affects the appearance of the 
selected object in plan view. See Line Style Panel on page 310. 

FILL STYLE PANEL

The settings on the FILL STYLE panel affect the appearance of the selected object in plan view. For information about these 
settings, see Fill Styles on page 197.

MATERIALS PANEL

The settings on the MATERIALS panel affect the appearance of the selected object in 3D views. For information about these 
settings, see Materials Panel on page 1055.

The material selected here is not calculated in the Materials List. See Materials Lists on page 1309.

LABEL PANEL

Road Marking labels displays in plan view when the “Terrain Labels” layer is turned on and use the Text Style assigned to 
that layer. See Terrain and Road Labels on page 1264.

For more information, see Label Panel on page 712.
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Chapter 39
 

Plants and Sprinklers

The Plant Tools and sprinklers from the Library Browser allow you to create planting designs and irrigation systems in your 
terrain. 

The Terrain Tools are discussed in their own chapter. See Terrain on page 1249.

TOPICS

Plant Tools 1300
Plant Chooser Dialog 1301
Hardiness Zones 1303
Plant Image Specification Dialog 1303
Plant Specification Dialog 1307
Sprinkler Tools 1307
Sprinkler Specification Dialogs 1308
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Plant Tools
Select Terrain> Plant to add plants to your landscaping plan. Plants can also be placed in a plan directly from the 
library. See Placing Library Objects on page 980.

Plant objects are actually images, which provide realism while avoiding high 3D surface count. Once created, plant images 
can be selected and edited much like other image objects. See Editing Images on page 1183.         

Select Terrain> Plant> Plant Chooser to open the Plant Chooser dialog and find plants based on their 
characteristics and requirements. See Plant Chooser Dialog on page 1301.

Select Terrain> Plant> Create Plant Image to create a plant image. See Plant Image Specification Dialog on page 
1303. Once a plant image is created, it can be added to the library for future use. See Creating Images on page 1181. 

Select Terrain> Plant> Grow All Plants to open the Grow Plants dialog. 

Click and drag the slider bar and select a growth period from zero to twenty years. This only works for plants that have a 
mature height and mature age specified in the Plant Image Specification dialog. See Plant Information Panel on page 1306.         

Select Terrain> Plant> Show Hardiness Zones  to access regional climate zone maps. See Hardiness Zones on 
page 1303.         

Chief Architect’s Library Browser features a Plants category with a selection of plant, shrub and tree images which you can 
place in your plan. See The Library on page 961.         

Once placed in your plan, these plant images can be selected, moved, copied and resized to produce a wide variety of 
unique landscaping designs. See Editing Images on page 1183.         

GARDEN BEDS

Garden Beds are a special type of Terrain Feature with material and height attributes typical of planting beds.  In 
addition, you can choose to distribute copies of a plant image within a Garden Bed. See Garden Bed Tools on page 

1260.

PLANTS LIBRARY CATALOGS

In the Library Browser, browse to Chief Architect Core Catalogs> Plants to access a selection of plant images and 
symbols. Select the library object you want, then click in any view to place it in the plan. See The Library on page 

961.   

A selection of Bonus Catalogs of plants is also available for download. See Chief Architect Bonus Catalogs on page 969.    

In addition, you can add single plants and blocked groups of plants to the library. See Adding Library Content on page 973 
and Architectural Blocks on page 1008. 
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PLANT SCHEDULES

The Plant Schedule tool allows you to create customizable plant schedules and plant labels that display schedule 
numbers.  See The Schedule Tools on page 695.         

 

Plant Chooser Dialog
Select Terrain> Plant> Plant Chooser or click the Plant Chooser button at the bottom of the Library Browser 
window to open the Plant Chooser.         

Use this dialog to search the library for plant images and symbols that match your search parameters. You can search using 
any or all of the options in the Plant Chooser.         

The search parameters in this dialog correspond to the settings on the PLANT INFORMATION panel of the Plant Image 
Specification dialog. See Plant Information Panel on page 1306.          
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Name

Type the Name of a plant that you would like to find.         

 l Specify the plant’s Common Name, Scientific Name, or its Variety Name.          

 l A Pronunciation field is also provided. In the Plant Image Specification dialog, it is populated with a phonetic 
pronunciation guide for the plant’s scientific name.          

 
Type

Check one or more boxes to indicate selected plant Type to search for.         

 
Sub-Type

Check one or more boxes to specify the selected Sub-Type to search for.         

 
Needs

Specify the plant Needs to search for. These include the Sun, Water, Soil pH, and Hardiness Zone range. See Hardiness 
Zones on page 1303.         

 
Flowers and Foliage

 -         

 l Specify the Flower Color to search for. Multiple colors can be selected.         

 l Specify the Leaf Color to search for. Multiple colors can be selected.         

 l Specify the Bloom Time to search for, which is the season when the plant produces flowers.          

 
Height

Specify the plant Height at maturity to search for.              This is used with the Grow Plants feature. See Plant Tools on page 
1300.

 l An average mature height range can be entered using the From and To drop-down lists.         

 l A specific Height at Maturity to search for can be entered in the text field.         

 l A specific Starting Age, in months, can be entered in the text field.         

 l A specific Age at Maturity, in months, can be entered in the text field.         

 
Special Characteristics

Check one or more boxes to search for plants with Special Characteristics.         

 
Object Type

Select which types of plant Object Type to search for. 3D Plants are symbol objects, while Plant Images are two 
dimensional images.         

 
Search

Click the Search button at the bottom of the dialog to search for plants that meet your search criteria. The search results 
display to the right.         
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Search Results

Your search results display here.         

 l The Number of Items that match your search criteria is stated.         

 l Specify whether you want the search results to use the Common Name or Scientific Name.          

 l Click on the name of a plant in the list to see its location in the Library Browser.         

 
View Item

Click the View Item button to see more information about the selected plant in the Plant Information dialog. See Plant 
Image Specification Dialog on page 1303.         

 

Hardiness Zones
Select Terrain> Plant> Show Hardiness Zones to view a selection of regional Hardiness Zone Maps. Click the 
drop-down list at the top left to select various regions.

 

Plant Image Specification Dialog
Select one or more plant images in a plan view or 3D view and click the Open Object edit button to open the Plant 
Image Specification dialog. 

This dialog can also be accessed by selecting Terrain> Plant> Create Plant Image  or by selecting New> Plant Image 

from the Library Browser contextual menu.         

The PLANT INFORMATION and PLANT DESCRIPTION panels are also found in the Plant Information dialog, which can be 
accessed from the Plant Chooser dialog. See Plant Chooser Dialog on page 1301.         
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IMAGE PANEL

  General

 l The path and name of the selected plant’s Image File displays here.

 l Click Browse to specify the saved location on your computer of the image that represents the plant in 3D views.

 l A number of 2D Plant Symbols are available to represent the image in plan view. Select one from the drop-down 
list or click the Library button to choose a CAD block from the Library Browser.
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Size/Elevation

Specify the Size/Elevation of the plant image, as seen in 3D views.    

 l Specify the Height and Width of the image.    

 l When Retain Aspect Ratio of is checked, if you change either the Height or Width, the other value changes to 
maintain this ratio. If this is unchecked and you resize the plant image, it may become distorted.    

 l Click Reset Original Aspect Ratio of to reset the image’s original aspect ratio and remove any distortion caused by 
resizing.    

 l Select the Elevation Reference from the drop-down list. This determines where the next two settings are measured 
from and also affects their setting labels.    

 l Specify the to Top distance, measured from the Elevation Reference to the top edge of the image.    

 l Specify the to Bottom distance, measured from the Elevation Reference to the bottom edge of the image.

 
Center Point

Specify the location of the selected plant image’s Center Point.    

 l Position the selected plant image in reference to the plan coordinates by specifying its X Coordinate and Y 
Coordinate.

 
Block Line/Fill Style

Specify the Block Line/Fill Style of the selected plant image’s 2D symbol in plan view. Only available when a CAD block 
from the library is selected as the image’s 2D Plan Symbol.                  

 l Select Use Image Settings to use the image’s line style, which is set by layer, and its fill style, which is “No 
Pattern”.     

 l Select Use Block Settings to use the 2D CAD block’s line and fill styles. See Custom 2D Symbols on page 335. 

  Options

 l Check Reverse Image to reflect the appearance of the image about an imaginary vertical line through its center.     

 l Check Image Always Faces Camera to prevent the plant image from rotating with the camera.     

 l Check Include in Schedule to include the selected plant in the Plant Schedule. See Schedules and Object Labels on 
page 694.          

 
Copyright

If the selected plant image has been copyrighted, its Copyright Information displays here.          

 
Preview

A preview of the selected plant image displays here. The Glass House Rendering Technique is not available for plant 
images. See Dialog Preview Panes on page 22.

TRANSPARENCY PANEL

The settings on the Transparency panel of this dialog are similar to those on the same panel of the Image Specification 
dialog. For more information, see Transparency Panel on page 1186.         

1305



Chief Architect Premier X14 Reference Manual - Plant Image Specification Dialog

PLANT INFORMATION PANEL

The settings on the Plant Information panel correspond to the search parameters in the Plant Chooser. See Plant Chooser 
Dialog on page 1301.         

When multiple plants with differing attributes are selected, some 
button icons may be replaced by an X symbol signifying “No 

Change”.

PLANT DESCRIPTION PANEL

 
Description

A detailed Description of the plant displays in this text field.         

 
Lighting Comments

Information in the Lighting Comments fields describes the plant’s light requirements.         

 
Hardiness Zone Comments

Hardiness Zone Comments are given here. See Hardiness Zones on page 1303.         

LAYER PANEL

For information about the Layer panel, see Layer Panel on page 191.         
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FILL STYLE PANEL

The Fill Style panel controls the appearance of the selected plant’s 2D Plant Symbol in plan view.  By default, plant images’ 
fill style is None (Transparent). For information about the settings on this panel, see Fill Styles on page 197.

If the plant’s 2D Plan Symbol does not form a closed shape or is a CAD block is selected from the library, the settings on 
the Fill Style panel will have no effect on the appearance of the plant in plan view. If you wish, you can create a custom 
CAD block with the desired fill pattern. See CAD Blocks on page 333. 

LABEL PANEL

Plant labels display in plan view when the “Plants, Labels” layer is turned on and use the Text Style assigned to that layer. 
See Label Panel on page 712.         

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 1335.          

OBJECT INFORMATION PANEL

The information entered on the OBJECT INFORMATION panel can be used in schedules and the materials list. For more 
information, see Object Information Panel on page 1336.   

SCHEDULE PANEL

The settings on the SCHEDULE panel determine which schedule categories the selected object is included in. See Schedule 
Panel on page 716.    

 

Plant Specification Dialog
Select a 3D plant symbol and click the Open Object edit button to open the Plant Specification dialog. This dialog is 
the same as that for a variety of symbol objects in the program. See Symbol Object Specification Dialogs on page 

989.         

3D plants also have a Symbol Specification dialog, which can be accessed by clicking the Open Symbol  edit button. 

See Symbol Specification Dialog on page 993.          

 

Sprinkler Tools
  Use the Sprinkler Tools to design a sprinkler system in your plan.          

  Select Terrain> Sprinkler> Sprinkler Head to open the Select Library Object dialog. Browse to a sprinkler 
type in the library, click OK, then click in the drawing area to place as many as you need. Once drawn, sprinkler 

heads can be selected and edited. See Sprinkler Specification Dialogs on page 1308.   
  Select Terrain> Sprinkler> Sprinkler Line to draw sprinkler lines in your plan. Sprinkler lines are 2D objects 
and are drawn and edited much like CAD Lines. See Line Tools on page 305.         
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DISPLAYING SPRINKLERS

The display of Sprinkler Heads, Lines and Splines can be controlled in the Layer Display Options dialog. See Layer 
Attributes on page 181.

In plan view, Sprinkler Head symbols indicate the spray angle.         

Sprinkler head display in 3D views; however, Sprinkler Lines and Splines do not.         

Sprinkler Heads are counted in the Materials List, as is the total length of Sprinkler Lines and Splines. See Materials Lists 
on page 1309.         

Sprinkler heads can be included in schedules. See The Schedule Tools on page 695.

EDITING SPRINKLERS

Sprinklers can be edited much the way other objects from the library can: using their edit handles, edit tools, and in their 
specification dialog. See Editing Library Objects on page 986.         

 

Sprinkler Specification Dialogs
To open the Sprinkler Specification dialog, select a sprinkler or group of sprinklers and click the Open Object edit 
button. You can also double-click the sprinkler(s) using the Select Objects  tool.

The Sprinkler Specification dialog an example of a Symbol Object Specification dialog. See Symbol Object Specification 
Dialogs on page 989. 

Sprinkler Lines and Sprinkler Splines also have a specification dialog which is very similar to the Polyline Specification 
dialog. See Polyline Specification Dialog on page 323.
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Chapter 40
 

Materials Lists

Chief Architect can calculate a Materials List in three ways: for All Floors, From Area, or for Room. In addition, a 
polyline or multiple polylines can be used to define areas in a plan a Materials List can be generated from.

Materials Lists can be created, edited, and printed directly from the program. They can also be exported as text, .xml, or
 .html files for use in other programs.

The Materials List’s calculations are based on assumptions that 
may not match your building style. Chief Architect Software 

makes no representation as to the accuracy or reliability of the Materials 
List generated by Chief Architect Premier. Always compare the Materials 
List with a manual take-off before providing a quote or ordering 
materials for a job. 

TOPICS

The Materials List Tools 1310
Creating an Accurate Materials List 1311
Structural Member Reporting 1312
Organizing Materials Lists 1317
Materials List Specification Dialog 1319
Materials List Columns 1322
Editing Materials Lists 1324
Materials List Formulas 1325
Materials List Polylines 1327
Materials List Polyline Specification Dialog 1327
Saving and Managing Materials Lists 1329
Printing and Exporting the Materials List 1330
The Master List 1332
Object Components 1334
Object Information Panel 1336
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The Materials List Tools
A Materials List is like a snapshot of the current plan at the time that the list is made. Any changes made to the 
model after a Materials List is generated are not included in that list. Create a new Materials List if you would like it 

to include these changes. Select Tools> Materials List to access the Materials List tools.         

It is not necessary to wait until the plan is complete to generate a Materials List. In fact, you can create a series of Materials 
Lists reflecting costs at various stages of a project.

When you close a Materials List window, the program will ask if you want to save the Materials List. Type a name and 
click Yes to save the list or click No to close the list without saving it. See Saving and Managing Materials Lists on page 
1329.         

CALCULATE FROM ALL FLOORS

Select Tools> Materials List> Calculate Materials for All Floors to generate a Materials List for the entire model.

Materials lists calculated from all floors can be lengthy, and only a portion of the list may display on your screen at one 
time. Use the scrollbars to scroll through the complete list. Move the pointer to cells in the list and click to make changes.          

CALCULATE FROM AREA

In plan view only, select Tools> Materials List> Calculate From Area to produce a Materials List for the portion 
of a plan  on a single floor that is included within a temporary rectangular Materials List Polyline.          

The Calculate from Area tool includes categories of objects and floor levels based on settings in the Materials List 
Polyline/Area Defaults dialog. See Materials List Polyline Specification Dialog on page 1327.           

CALCULATE MATERIALS FROM SELECTION

Select one or more objects and click the Calculate Materials From Selection edit button to create a Materials List that 
calculates only the selected object(s) and their components.           

When the selected object is a room, its moldings and wall, floor, and ceiling finish materials are counted, as is its 
subflooring; but doors, windows, and structural materials like framing and other structural materials are not.           

CALCULATE MATERIALS IN ROOM

To create the Materials List for a room, select the room and then select Tools> Materials List> Calculate Materials 
for Room. 

Calculate Materials in Room  is also available on a selected room’s edit toolbar. See Editing Rooms on page 425.          

A Materials List calculated from a room is created for only the contents of that room: wall materials are not included. An 
object will be counted in the Materials List if its center point is located inside the room.         

All objects associated with a Distribution Path or Region will be listed in a schedule if the center point of the path or region 
is located inside the room. If the center point of the path or region is not located in the room, none of its objects will be 
listed. See Distributed Objects on page 1043.           
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MATERIALS LIST POLYLINE

You can also produce a Materials list for a defined area of a plan in plan view using a Materials List Polyline. 
Materials List Polylines are advantageous because they can be edited to any shape, saved, and used as many times as 

needed. There are also several ways to create them. See Materials List Polylines on page 1327.         

CALCULATE STRUCTURAL MATERIALS FOR DECK

The structural materials for a selected deck can be calculated in a Materials List by clicking the Calculate Structural 
Materials for Deck edit button. Any accessories added on the COMPONENTS panel of a deck's Room Specification 

dialog will be included in a Materials List created using this tool. See Decks on page 430 and Components Panel on page 
1335.

MASTER LIST

Select Tools> Materials List> Master List to open the Master List, a list of previously used materials and any added 
information such as price or manufacturer. See The Master List on page 1332.         

MATERIALS LIST MANAGEMENT

Select Tools> Materials List> Materials List Management to open a list of saved Materials Lists associated with 
the current plan. See Saving and Managing Materials Lists on page 1329.         

MATERIALS LIST PREFERENCES

A number of settings that affect the appearance and contents of Materials Lists are found in the Preferences dialog. 
See Preferences Dialog on page 99.         

 l The MATERIALS LIST panel lets you specify which Categories are initially included in new Materials Lists.          
 l The REPORT STYLE panel lets you specify which columns are initially included in new Materials Lists, as well as 

modify the appearance of all Materials Lists.          
 l The MASTER LIST panel lets you specify the current Master List file and the columns used in it.           

 

Creating an Accurate Materials List
In order to take full advantage of Chief Architect’s Materials List capabilities, there are several things to keep in mind. 

 l The accuracy of your Materials List is directly related to the accuracy of your model. Floor and ceiling heights, wall 
lengths, and structural settings all directly affect Materials List calculations.         

 l It takes more than just making your drawing look right to generate an accurate Materials List. If, for example, you use 
CAD lines to draw an item on a floor plan, that item will not be included in the Materials List. A better way would be 
to use a symbol or structural element. See Architectural vs CAD Objects on page 162.         

 l Specify Components and Object Information before creating a Materials List. Ideally, specify this information in 
objects’ defaults dialogs or in the Library Browser before placing the objects in the plan. See Object Information Panel 
on page 1336 and Components Panel on page 1335.         

 l If you use custom materials, make sure their material definitions are set up correctly. See Creating Materials on page 
1060 and Materials and the Materials List on page 1064.         

 l Bear in mind that using generic objects like Geometric Shapes from the library can result in items being calculated in 
the Materials List in a manner that you might not expect. See Other Objects on page 1015.
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OBJECT INFORMATION AND COMPONENTS

Code, Comment, Manufacturer, and Supplier information can be specified for many objects before a Materials List is 
created. See Object Information Panel on page 1336.   

Price, Extra, Markup, Labor, and Equipment information can also be specified in an object’s specification dialog. See 
Components Panel on page 1335.          

You can add this information to some objects before they are created in their defaults dialogs. See Default Settings on page 
76.          

You can also add this information to objects placed from the library. See Editing Library Objects on page 986.           

MATERIAL DEFINITIONS

The material assigned to structural components like walls, floors and ceilings, roofs, and slabs determines how each 
component is calculated in the Materials List. See Calculation Methods on page 1064.          

FRAMING IN THE MATERIALS LIST

You can specify whether framing materials are calculated by linear foot, as a cut list, or as a buy list in the Structural 
Member Reporting dialog. See Structural Member Reporting on page 1312. 

For more information about how framing appears in the Materials List, see Framing and the Materials List on page 901.          

CUSTOM FORMULAS

Calculations in the Materials List are based on the properties of the objects in the model and the materials assigned to those 
objects. If the default calculations do not meet your needs, you can replace them with custom formulas. See Materials List 
Formulas on page 1325.           

 

Structural Member Reporting
Structural Member Reporting allows you to specify how framing members are calculated in the Materials List. 
Structural Member Reporting supports multiple saved defaults, which means that you can set up different reporting 

methods for different purposes. See Multiple Saved Defaults on page 79.

When a Materials List is created, the Currently Active Default specified in the Saved Structural Member Reporting 
Defaults dialog is used. Once created, the default a Materials List references can be changed using the Structural Member 
Reporting Control drop-down in the toolbars. See Organizing Materials Lists on page 1317.   

There are four Reporting Methods to choose from:

 l Buy List calculates the framing materials of the different structural components of the plan by counting individual 
pieces and matching them to a list of board sizes that you specify.    

 l Cut List calculates the framing materials of the different structural components of the plan by counting the individual 
pieces present in the model.         

 l Linear Length calculates the framing materials of the different structural components of the plan in linear lengths.     
 l Mixed Reporting calculates framing materials using a combination of linear lengths and piece counts and is 

recommended for saved Materials Lists in legacy plans.    
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SAVED STRUCTURAL MEMBER REPORTING DEFAULTS DIALOG

This dialog lets you manage the saved Structural Member Reporting defaults in the current plan and specify which one is 
active.

 
Available Defaults

The Structural Member Reporting Defaults in the current plan are listed and can be managed here.     

 l Click on a name in the list to select it.    

 l Click the Edit button to open the defaults dialog for the selected line item.

 l Click the Copy/Convert button to create a new Structural Member Reporting Default. See New Structural Member 
Reporting Default Dialog on page 1314, below.    

 l Click the Rename button to open the Rename Current Default dialog and type a new name for the selected default. 
Names are case-sensitive and must be unique.    

 l Click the Delete button to remove the selected default from the list. This option is not available when there is only 
one default in the list. Saved Defaults assigned to saved Materials List in the current file cannot be deleted.    

 l Click the Import button to import a Structural Member Reporting Default into the current plan.      

 l Click the Export button to save the selected Structural Member Reporting Default as a .calumber file, which can be 
imported into other plans.      

 
Currently Active Saved Defaults

The Currently Active Saved Defaults for the selected object type displays and can be changed here.     

 l Select a Saved Default from the drop-down list to make it active when you click OK.    

 l Click the Edit button to open the Defaults dialog for the Saved Default selected in the drop-down list.

Note: if you click Cancel or press Esc in this dialog after editing, 
renaming, copying, or importing a Saved Default, your changes will 
not be retained.

Click Cancel to close the dialog without retaining any of your changes. Any newly added Saved Defaults will not be 
retained. 
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NEW STRUCTURAL MEMBER REPORTING DEFAULT DIALOG

This dialog lets you create a new Structural Member Reporting default and specify its reporting method.

 l Type a short, descriptive, unique Name for the new Structural Member Reporting default.             
 l Select which Reporting Method the new default will use. Only one default using "Mixed Reporting" can be present in 

a plan, so this option is not available if one already exists.             
 l Select a source to Copy Board Lengths From. This option is not present if the new default was created by copying a 

"Buy List", and is only active if Buy List is the Reporting Method selected above.             

STRUCTURAL MEMBER REPORTING DIALOG

To open the Structural Member Reporting dialog, select Edit> Default Settings, then select “Structural Member 
Reporting” from the tree list and click the Edit button. See Default Settings vs Preferences on page 76.          

You can also open this dialog by selecting Tools> Materials List> Structural Member Reporting or by clicking 
the Structural Member Reporting button, which can be added to your toolbars. See To add a button to a toolbar on 

page 137. 

In the Saved Structural Member Reporting Defaults dialog, which opens next, select a default in the list and click the Edit 
button. You can also specify which reporting method is currently set as the default in this dialog. See              Saved Defaults 
Dialog on page 80.         

The name of the Saved Default being edited is stated in the dialog box title bar.           
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  Format

 l The selected default's Reporting Method is reported here.

 l Select the Length Units that you want to use in the Structural Member Reporting dialog as well as in the Materials 
List. Not available when Linear Length is selected.          
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Board Sizes

Board Sizes are presented in a table. An effective list will include all types of framing materials that you typically use, as 
well as each of the different lengths that you expect to use. Click a column header to sort all line items in the table by that 
column. An arrow above the column indicates that it is being used to sort the table, and in which direction it is being sorted.          

 l Click on a line item to select it.          

 l Click the Edit button to open the Board Specification dialog for the selected line item in the table. You can also 
double-click on a line item to open its Board Specification dialog.          

 l Click the New button to open the Board Specification dialog for a new line item in the table.           

 l Click the Delete button to remove the selected line item from the table.     

Note: The Length column is not available for defaults that use the Linear 
Length Reporting Method.     

Items in the Board Sizes table are listed in order of priority. If an item in a Materials List could be cut out of more than one 
item in this table, the program will select the item with the highest priority. Specify the Priority of the selected line item in 
the table.          

 l Click the Increase Priority button to move the selected item one line up in the table. Only available when a line 
item is selected and it is not first in the list.          

 l Click the Decrease Priority button to move the selected item one line down in the table. Only available when a line 
item is selected and it is not last in the list.          

  Buy List Cut Board Options

 l Specify the Kerf Width, which is the width of the material lost to the saw blade when a framing member is cut. 

 
Buy List Options for Long Board Runs

These settings control how to handle framing elements that are typically composed of long runs of multiple collinear boards, 
such as Wall Plates and Girts, Deck Planking, and Rim Joists. The Other category includes any boards or beams that 
exceed the length of the longest board in the Buy List. There are three options:

 l Report Actual Lengths reports the lengths of individual long runs.

 l Report Total Linear Length adds the lengths of all individual long runs and reports the total.

 l Use Longest Buy List Board calculates the Total Linear Length and reports the number of the longest board in 
the Buy List required to reach that length. Not available for the Other category.

BOARD SPECIFICATION DIALOG

Click either the New or the Edit button in the Structural Member Reporting dialog to open the Board Specification dialog, 
where you can define a line item for the Boards to buy table. You also double-click on a line item in the table to modify it.           
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 l Specify the Actual Thickness - as opposed to the nominal thickness - of the selected item in the Buy List table.           
 l Specify the Actual Depth - as opposed to the nominal depth - of the selected item in the Buy List table.           
 l Specify the Length of the selected item in the Buy List table.           
 l Select the Type of structural member from the drop-down list. See Structure Types on page 901.          
 l Check Treated if the selected item is a treated lumber product. 
 l The table is similar to the one found on the COMPONENTS panel in the Framing Specification and other specification 

dialogs. See Components Panel on page 1335.         
 l Click OK to close the dialog and add the information specified here to a line item in the Buy List table.           

 

Organizing Materials Lists
There are two basic ways to control what items are calculated in the Materials List:

 l By specifying which categories and subcategories are used.      
 l By specifying which layers in the plan are included in the list.     

In addition, you can control how much information about each item is included by specifying which columns to display.           

You can also use the Structural Member Reporting Control drop-down list in the toolbars to choose which method the 
Materials List uses. See Structural Member Reporting on page 1312.          

There are some parts of a model that cannot be excluded from the Materials List. Floor and ceiling platforms are prime 
examples. If you need to generate a Materials List for only part of a plan, such as an addition, consider making a copy of the 
plan file. In the copy, delete the as-built portion of the plan and then generate a Materials List.
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MATERIALS LISTS AND LAYERS

You can control which objects are included in a Materials List by layer by selecting a Layer Set in the Materials List 
Specification dialog. See Options Panel on page 1320.

You can also specify which layers are included in a Materials List before it is created by customizing the default Layer Set 
used by Materials List. See Layer Set Defaults on page 188.

CATEGORIES

The line items in the Materials List and Master List are organized into a set of predefined categories, such as Electrical and 
Framing, which display in the ID column. 

You can specify which category each item belongs to in the Materials List and Master List. In addition, many objects can be 
assigned to a category prior to generating a Materials List in their specification dialog. See Components Panel on page 
1335. 

To specify a line item’s category
 1.  Create a Materials List, open the Master List, or open an object’s specification dialog and go to the COMPONENTS 

panel.

 2.  Click in the cell in the ID column for a line item.

 3.  Select the desired category from the drop-down list that becomes available.

The categories that are available cannot be altered; however, you can specify which categories are included in the Materials 
List in either of two ways:

 l Globally, in the Preferences dialog. See Materials List Panel on page 126.           
 l For individual lists in the Materials List Specification dialog. See Materials List Specification Dialog on page 1319.          

SUBCATEGORIES

By default, the Subcategory column of the Materials List is empty for all line items. You can add text to any Subcategory 
cell by clicking in the cell and typing.          
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Items can be assigned to a subcategory in the Materials List and, for many items, in their object’s specification dialog in the 
same manner that they can be assigned to a category. See Components Panel on page 1335.           

MATERIALS LIST COLUMNS

Each column in the Materials List reports a different category of information about objects in the list. You can specify most 
of this information for a variety of objects prior to generating a Materials List. See Object Components on page 1334.          

There are two ways to specify which columns are included in the Materials List as well as the order in which they display:          

 l Globally, in the Preferences dialog. See Report Style Panel on page 127.           
 l For individual lists in the Materials List Specification dialog. See Materials List Specification Dialog on page 1319.   

DETAILS DIALOG

For information about one or more selected line items in a Materials List, click the Details edit button. The Details 
dialog displays all Materials List columns for reference, which can be helpful when not all columns are in use in the 

Materials List. It also lists the Source Object of the selected line item or items.

This dialog will also open when multiple objects located on more than one floor are selected in a Materials List and you 
click the Find Object in Plan  edit button. See Find Object in Plan on page 703.           

When one or more line items located on the same floor are selected, click the Find button at the bottom of the dialog to 
view their location in a plan view window. 

 

Materials List Specification Dialog
             When a Materials List or the Master List is open, select Tools> Active View> Edit Active View to open the 
Materials List Specification dialog for the current list.

The Master List Specification dialog is similar to this dialog, but only the COLUMNS panel is available. See The Master List 
on page 1332.          

CATEGORIES PANEL

The Categories  listed here appear in the ID column of the Materials List in the order they are presented here. 

 l Check the box beside the name of each category that you want to display in the currently active Materials List. 
 l Click the Select All button to display all categories in the active Materials List.          
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 l Click the Clear All button to suppress the display of all categories in the active Materials List.          
 l Multiple rows can also be selected together using Shift and Ctrl keys. See Shift and Ctrl Select on page 217. 

Note: The information in a suppressed category is still part of the 
Materials List. If the Materials List is exported, suppressed categories are 
exported, as well.

COLUMNS PANEL

 l Check the box beside each column you want to include in the Materials List. To suppress a column’s display, remove 
the check mark next to its name. Columns appear in the Materials List in the order that they display in this list.           

 l Move Up - Click on a column name, then click this button to move that item up one place in the list.           
 l Move Down - Click this button to move the selected column down in the list.          

OPTIONS PANEL

 l Select a Layer Set from the drop-down list to apply its settings to the currently active Materials List. 
 l Click the Define button to open the Layer Display Options dialog and view or modify the selected Layer Set. See 

Layer Display Options Dialog on page 183.
 l Select a saved Structural Member Reporting default from the drop-down list to specify how framing members are 

counted and reported. See Structural Member Reporting Dialog on page 1314.
 l Select a floor level from the Restrict to Floor drop-down list to limit the current Materials List to objects on that 

floor. When "All Floors" is selected, the Materials List includes objects from all floors.           
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 l If you plan to buy materials from multiple suppliers, you can create a Materials List for each. Select an option from 
the Restrict to Supplier drop-down list to only list items associated with the selected supplier; select "Show All 
Suppliers" to list all items, including those with no supplier; or select "Show Only No Supplier" to only list items that 
do not have a supplier. Suppliers can be added to this list in the specification dialog for various objects.  See Object 
Information Panel on page 1336.         
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Materials List Columns
The columns in the Materials List and the Master List are very similar, but not all columns appear in all places. 

The following table lists the capabilities of each column:          

Column Available In Editable In Description

ID Materials List, 
Master List,
Components 
Panel

Materials List, 
Components 
Panel 

Displays an automatically generated 
identifier for each line item. Select the 
cell in this column to change an item’s 
category.

Use Master List Master List A check box beside for line item 
indicates if it is included in the Materials 
List. 

Sub 
Category

Materials List, 
Components 
Panel

Materials List, 
Components 
Panel

Select a cell in this column to change a 
line item’s subcategory. 

Floor Materials List N/A States the floor that the line item is 
located on. See Multiple Floors on page 
743. 

Label Materials List, 
Master List,
Components 
Panel

Materials List  Lists the label that displays in plan view 
for most items that have labels associated 
with them. See Label Panel on page 712. 

Supplier Materials List, 
Master List,
Components 
Panel

Materials List, 
Master List,
Components 
Panel

Specify a supplier for the item. A 
Supplier in the Master List is not used if 
one has been entered in the object’s 
specification dialog.

Manufacturer Materials List, 
Master List,
Components 
Panel

Materials List, 
Master List,
Components 
Panel

Specify a manufacturer for the item. A 
Manufacturer in the Master List is not 
used if one has been entered in the 
object’s specification dialog.

Code Materials List, 
Master List,
Components 
Panel

Materials List, 
Master List,
Components 
Panel

Specify a Code, such as an SKU, for the 
item. A Code in the Master List is not 
used if one has been entered in the 
object’s specification dialog.  

Size Materials List, 
Master List,
Components 
Panel

Materials List, 
Components 
Panel

Click in a cell to edit the size description 
of the line item. To restore the original 
size, delete the text you typed in. For a 
blank cell, type a single blank space.

Description Materials List, 
Master List,
Components 
Panel

Materials List, 
Components 
Panel

Click in a cell to edit the description of 
the line item in the same way that the 
Size can be edited. 
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Column Available In Editable In Description

Quantity Master List Master List Specify how many of an item must be 
found before information from the 
Master List is applied to it in a Materials 
List. If at least this many items are 
found, price, supplier, and other 
information is used. 

Count Materials List, 
Components 
Panel

Components 
Panel

This is the actual number of an item, 
either associated with the selected object 
or in the Materials List. Count can be 
increased for accessories added to a 
selected object.

Extra Materials List, 
Components 
Panel

Materials List, 
Components 
Panel

Specify an additional amount of the line 
item. Changes made in the object’s 
specification are reflected in the Count 
column in the Materials List.

Price Materials List, 
Master List,
Components 
Panel

Materials List, 
Master List,
Components 
Panel

This is the per-unit price of an item. A 
Price in the Master List is not used if one 
has been entered in the object’s 
specification dialog.

% Markup Materials List, 
Master List,
Components 
Panel

Materials List, 
Master List,
Components 
Panel

Specify a markup percentage for the 
item. A markup in the Master List is not 
used if one has been entered in the 
object’s specification dialog.

Labor Materials List, 
Master List,
Components 
Panel

Materials List, 
Master List,
Components 
Panel

Specify a labor cost for the item. A 
Labor value in the Master List is not 
used if one has been entered in the 
object’s specification dialog.

Equipment Materials List, 
Master List,
Components 
Panel

Materials List, 
Master List,
Components 
Panel

Specify an equipment cost related to the 
item. An Equipment value in the Master 
List is not used if one has been entered in 
the object’s specification dialog.

Total Cost Materials List, 
Components 
Panel

Materials List, 
Components 
Panel

This is the total cost based on Count, 
Price, % Markup, Labor and Equip 
values.

Default Master List Master List Click in this column to specify the line 
item as the default when more than one 
item is available.

Comment Materials List, 
Master List,
Components 
Panel

Materials List, 
Master List,
Components 
Panel

Additional information related to the 
item can be entered here. A Comment in 
the Master List is not used if one has 
been entered in the object’s specification 
dialog.

Accounting 
Code

Materials List, 
Master List,
Components 
Panel

Materials List, 
Master List,
Components 
Panel

The Accounting Code information is 
used when a materials list is exported for 
use in BuilderTREND software. 
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Editing Materials Lists
Materials lists can be edited in a variety of ways. You can adjust the width of a column by clicking and dragging the bar on 
the right side of the column name. 

EXPAND AND COLLAPSE ROWS

If a line item has an arrow to the left of its name in the ID column, it represents multiple individual objects. 
Click the Expand edit button to display these individual objects as separate line items; click the Collapse edit 

button to hide them. You can also click the arrow to the left of the name to expand or collapse the line items.         

FIND OBJECT IN PLAN

To find out where a line item in the Materials List is located in the model, select its row or any cell in its row and 
click the Find Object in Plan edit button. See Find Object in Plan on page 703.         

ADDING INFORMATION

You can enter information in the Price, Supplier, Code, Comment and Manufacturer columns for each line item. 

Adding price or other information for any item is straightforward. Simply click in the cell and type the desired information. 
When the information is correct, you can add it to the Master List. See Adding to the Master List on page 1333. 

You can switch between several existing suppliers or manufacturers for a given item by double-clicking on the right side of 
the cell in an appropriate column. A drop-down arrow displays to the left of the cell. Click it to view a list of suppliers or 
manufacturers for that item and select one.          

When a Materials List is calculated, you can have the program search the Master List for Price, Supplier, and Code 
information for each item by selecting Tools> Update From Master List . The information used is marked as “Default” 

in the Master List.               See Materials List Columns on page 1322.

CHANGING INFORMATION

Although the information in some columns cannot be saved to the Master List, you can change the information in any 
column in an individual Materials List. As with added information, click in a cell to select the existing text, then type in the 
desired text. 

To move an item in a Materials List to a new category, select the cell in the ID column and choose a new category from the 
drop-down list that becomes available. You can also select a subcategory by clicking in the cell in the Sub Category 
column. See Categories on page 1318.

CHANGING COUNT UNITS

The material for a given object component will be counted either by piece; linear feet or meters; square feet or meters; or 
cubic yards or meters. The same method and unit used in the Count column will be used in the Extra column. 

When the Count is linear, area, or volume, you can choose a different unit of measurement: 

 l Double-click in a cell in the Count column to select and edit it, then choose a unit of measurement from the drop-down 
list to the right of the selected cell.
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 l You can also click the Number Formatting  button when a Count cell is selected to specify the units and accuracy 

of the value in the selected field. The specified unit is also used in the Extra field for that row. See Number Formatting 
Dialog on page 1326.

MATERIALS LIST FORMULAS

Calculations in the Materials List are based on the properties of the objects in the model and the materials assigned to those 
objects. If the default calculations do not meet your needs, you can replace them with custom formulas. You can also add 
formulas to cells that do not have automatic calculations. See Materials List Formulas on page 1325.           

COUNT AND FORMULA TOOL TIPS

Whenever you mouse over a cell in the Materials List that is either in the Count column or contains a formula of any kind, a 
Tool Tip will display, providing information about the cell’s contents. When the Count is a total length, area, or volume, it 
may be rounded. The Tool Tip will show the value with greater accuracy.

TOTAL COST

By default, the Total Cost for a line item is calculated using the Count, Price, % Markup, Labor and Equipment columns to 
calculate the cost. The formula used is: 

(Count + Extra) * Price * (1 + (%    Markup/100)) + ((Count + Extra) * Labor) + ((Count + Extra) * Equipment)

If a column does not appear, 0 is used for the value of that column with the exception of Count and Price, which are always 
used in the calculation even if they are not shown.

COPYING INFORMATION

Portions of a Materials List can be copied and then pasted into a Text  object or into a word processing program or 

spreadsheet program using the standard Windows Copy (Ctrl + C), Cut (Ctrl + X), and Paste (Ctrl + V) commands. See 
Copying and Pasting Text on page 523.

CHANGING THE FONT

The font used for Materials Lists and the Master List can be specified in the Preferences dialog. See Font Panel on page 
103.          

The size of this font can also be specified in the Preferences dialog. See Report Style Panel on page 127.          

 

Materials List Formulas
Calculations in the Materials List are based on the properties of the objects in the model and the materials assigned to those 
objects. See Define Material Dialog on page 1066.           

If the default calculations do not meet your needs, you can replace them with custom formulas. Materials List formulas use 
Ruby syntax, which allows you to use basic arithmetic as well as construct more complex macros. See Creating User 
Defined Macros on page 1392.           
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To insert a custom Materials List formula
 1.  Double-click in any editable cell in the Materials List or on the COMPONENTS panel of an object’s specification 

dialog to select and edit it. See Components Panel on page 1335.          

 l The cells in some columns allow you to choose an item from a drop-down list.          

 l Most cells are editable text fields that have a contextual toolbar of editing tools above them when selected.          

 l When the cell is in the Count column, click the Number Formatting  button to specify the units and accuracy 

of the value in the selected field. You can also select a Count unit from a drop-down list to the right of the cell. 
The specified unit is also used in the Extra field for that row.          

 2.  In the inline text field, you can:          

 l Type the desired custom text that you need. The resulting text does not perform calculations and is static.           

 l Press the = key, then type or insert the desired custom formula. The = character at the beginning tells the formula 
to treat the text that follows as a formula instead of regular text.           

 3.  If the cell has been previously edited, you can click the Revert to Default  button to restore the original, 

automatically generated content.          

 4.  When multiple identical items are listed as a single line item:           

 l Select Apply Formula to Line Item  to apply the specified formula to the current row. When this option is 

selected, values in the other cells in the same row can be accessed, but not the properties of the object(s) 
themselves.           

 l Select Apply Formula to Source Object  to apply the specified formula to each individual object and display 

the total in the current cell. When this option is selected, the object(s)’ properties can be used.           

Note: When Apply Formula to Source Object is used, the reported 
value will only update when the formula is edited.

 5.  Click the Insert Macro  button to insert one or more User Defined text macros and/or Materials List column 

macros into the inline text field.          

Fields with custom macros report values with accuracy of up to two decimal points, even in columns that report whole 
numbers when calculated automatically.         

NUMBER FORMATTING DIALOG

Right-click in a cell in the Count or Extra column of the Materials List and select Number Formatting from the 
contextual menu. This edit button is also available when a cell in either of these columns is selected. See The Edit 

Toolbar on page 135. 

In the Number Formatting dialog, you can specify the units, formatting, and accuracy of the value in that cell. The settings 
in this dialog are also found in the Displayed Line Length Format dialog. See Displayed Line Length Dialog on page 297. 

CUSTOM FORMULA MACROS

You can create custom macros in the Edit Text Macro dialog and then insert them into the inline text field. See Edit Text 
Macro Dialog on page 1402.          
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 l Macros created for use in Materials List formulas need to have Evaluate checked in the Edit Text Macro dialog.           
 l Formulas that reference the object’s properties need to have “Owner Object” selected as the Context.          
 l Formulas that reference information in other cells in the current row need to have “Materials List Line Item” selected 

as the Context.          

Note: Custom formulas in legacy plan files may use deprecated behavior 
for measurement values. See Migrating Legacy Ruby Code on page 1406.

 

Materials List Polylines
A Materials List Polyline lets you create a Materials List that only includes objects within its area. The materials list 
Categories and floor levels included in the Materials List can be set in advance in the Materials List Polyline./Area 

Defaults dialog. 

To create a Materials List Polyline
 1.  In plan view, select Tools> Materials List> Materials List Polyline and draw a rectangular polyline. 

 2.  Select the Materials List Polyline and click the Open Object  edit button.

 3.  On the MATERIALS LIST panel of the Materials List Polyline Specification dialog, specify which categories and floor 
levels you want to include in the materials calculation, along with how you want objects within the polyline to be 
selected. See Materials List Polyline Specification Dialog on page 1327.

 4.  Edit the polyline’s position and shape as needed. See Editing Closed Polyline-Based Objects on page 230.

 5.  With the Materials List Polyline still selected, click the Calculate Materials List  edit button. A Materials List is 

created for objects within the polyline. 

To prevent an area from the middle of a Materials List Polyline 
from being included in a Materials List, use a polyline hole. See 

Polyline Holes on page 234. 

If a Materials List Polyline is configured in such a way that it includes a room, a Materials List created from it will include 
the floor and ceiling finish materials and substrate materials like sheathing and insulation for the entire room: not just within 
the polyline.

You can also convert a closed CAD polyline into a Materials List Polyline using the Convert Polyline  edit tool. See 

Convert Polyline on page 265.

 

Materials List Polyline Specification Dialog
To open the Materials List Polyline Specification dialog, select one or more Materials List Polylines and click the 
Open Object edit button.

The settings in this dialog are also found in the Materials List Polyline/Area Defaults dialog. 

MATERIALS LIST PANEL

The settings on the Materials List panel of the Materials List Polyline/Area Defaults dialog affect both Materials List 
Polylines and Materials List Area temporary marquees. See Calculate From Area on page 1310.

1327



Chief Architect Premier X14 Reference Manual - Materials List Polyline Specification Dialog

 
Included Floors/Categories

Specify the Included Floors/Categories in a Materials List generated from the selected Materials List Polyline. The table 
lists all Materials List categories in its rows and all floor levels in the current plan in its columns.    

 l A check mark in a field indicates that the category of object on a particular floor will be included in the Materials 
List. Click to add or remove the check mark. 

 l Click on the name of a Category to select that row, or click on a floor level name to select that column. Multiple 
categories or floor levels can also be selected, as can multiple fields. See Shift and Ctrl Select on page 217.    

 l Uncheck Include All Floors to show only the floor level that the selected Materials List Polyline is located on in the 
table.    

 l Click the Toggle Selected button to add or remove a check mark from the selected field(s), row(s), or column(s).    

 l Click the Toggle Category(s) button to add or remove check marks from the selected row(s).    

 l Click the Toggle Floor(s) button to add or remove check marks from the selected column(s).    

 l Click the Toggle All button to add or remove check marks from the selected column(s).    

 l Click the Revert All Changes button to restore the selections that were present when the dialog was first opened. 
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Included Objects

The Included Objects options control which objects are included in the Materials List based on their position relative to the 
selected Materials List Polyline.    

 l Choose Include Intersected Objects to include any objects whose bounding boxes are intersected by or located 
within the polyline.    

 l Choose Include Contained Objects to include only objects located entirely within the polyline.    

 l Choose Include Objects by Center to include only objects whose center points are located within the polyline.    

 l If multiple polylines with different settings are selected, No Change may be an additional option. Select this to 
retain the polylines’ original settings.

POLYLINE PANEL

The POLYLINE panel states information about the polyline’s shape, including the total length of its Perimeter, its enclosed 
Area, and the Number of Lines that make up its perimeter. See Line Specification Dialog on page 309.

SELECTED LINE/ARC PANEL

The SELECTED LINE panel is available when the selected cloud edge is a line as opposed to an arc. See Line Specification 
Dialog on page 309.

The SELECTED ARC panel is available when the selected segment of the cloud edge is an arc as opposed to a line. See Arc 
Panel on page 318.

See, too, Selected Edge on page 214 and Change Line/Arc on page 259. 

LINE STYLE PANEL

For information about the settings on this panel, see Line Style Panel on page 310.

FILL STYLE PANEL

The FILL STYLE panel is found in various dialogs throughout the program. See Fill Styles on page 197.

LABEL PANEL

Materials List Polyline labels display when the “Polylines, Labels” layer is turned on and use the Text Style assigned to that 
layer. See Text Styles on page 547. 

For more information about the settings on this panel, see Label Panel on page 712. 

 

Saving and Managing Materials Lists
Select Tools> Active View for tools that allow you to manage the current Materials List. See View Windows on page 149.          

To save an open Materials List, select Tools >  Active View > Save Active View. If the Materials List has not been 
previously saved, the Save Materials List dialog will open, allowing you to type a short, descriptive name for the list. 

You will also be prompted to save a Materials List when you close its window.          

You can also use Tools> Active View> Save Active View As to create an exact copy of the currently active materials list. 
Regardless of whether the current materials list is saved or not, you will be prompted to give the new view a name.          
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Saved Materials Lists can be accessed, renamed, duplicated, and deleted in the Project Browser. See Project Browser 
on page 58.         

Once a Materials List has been saved, it is               also listed in the Materials List Management dialog.

MATERIALS LIST MANAGEMENT DIALOG

Select Tools> Materials List>  Materials List Management to open the Materials List Management dialog.         

Click on the name of a saved Materials List in the list on the left to select it.          

 l Edit - Open the selected Materials List. You can also double-click an item in the list.          
 l Copy - Create a copy of the selected Materials List. Type a new name for it in the Save  Materials List dialog.         
 l Rename - Open the Rename Materials List dialog and type a new name for the list.         
 l Delete - Remove the selected Materials List from the current plan.         

 

Printing and Exporting the Materials List
There are several options for printing and exporting the information in a Materials List.

To print a Materials List, select File> Print while the Materials List window is active. See Print View Dialog on 
page 1385.

A Materials List can also be exported into a one of several different file formats that can be opened by various 
programs. In a Materials List window, or in the Master List, select File> Export Materials List to open the Export 

Materials List dialog.
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EXPORT MATERIALS LIST DIALOG

 
File Type

Specify the File Type that you would like to export to.         

 l Select Tab Delimited (TXT) to create a text file with a tab between each field entry in the Materials List, and a 
carriage return between each row.         

 l Select Comma Delimited (CSV) to create a text file with a comma between each field entry in the Materials List 
and a carriage return between each row.         

 l Select Spreadsheet (XML) to create a file that can be opened by Microsoft Excel.         

 l Select Web Page (HTML) to create an html file that you can view with a web browser.         

 
Options

Additional export options are available here.         

 l Uncheck Include Column Headers to prevent column headings from appearing in the first row of the exported file. 
Column headers are always included in HTML files.         

 l Uncheck Include Hidden Columns to only export columns currently displayed in the active Materials List. When 
this is checked, all columns are exported, regardless of whether they are currently displayed.         

 l Check Open in Default Spreadsheet Editor to open the exported file with the program specified on your computer 
when you finish exporting.         

 l When XML or HTML is selected above and Export with Colors is checked, the Color Theme or Custom Colors 
used in the Materials List are exported. When unchecked, the default system colors are exported. See Report Style 
Panel on page 127.         
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Units

Specify how Units of measurement are exported. Currency information is always exported, regardless of the option chosen 
here.         

 l Select Include Units with Amounts to include units in the same column as the associated value.         

 l Select Include Units in a New Column to report units as text in a new column.         

 l Select Do Not Include Units to not export units at all.         

  Third Party Formats

 l Select No Formatting to export the materials list data using the formatting used in the Chief Architect Premier 
Materials List.         

 l Select BuilderTREND to export the materials list data for use in BuilderTREND software. When this is selected, 
the only File Type available above is Comma Delimited (CSV).         

When you click OK, the Write Materials Export File dialog will open. This is a typical File Save dialog. See Exporting 
Files on page 41. 

ESTIMATING SOFTWARE

You can export a Materials List to a word processor or spreadsheet program to arrange it in your estimating format. You can 
also export the Materials List to a number of commercial estimating programs in whose databases you can keep your current 
pricing, labor costs, and  markups and generate reports based on this data. 

Before purchasing an estimating software program, be sure that the program supports the direct import of Chief Architect 
Materials Lists. 

Any questions regarding estimating software packages and how they interact with Chief Architect should be directed toward 
the company providing the estimating software. Chief Architect Software is unable to provide any technical support for third 
party programs.

 

The Master List
The Master List saves price, supplier, manufacturer, and other information about items in your Materials Lists and 
allows you to apply that information to items in future Materials Lists. Select Tools> Materials List> Master List to 

open the Master List.         

Chief Architect allows you to have more than one Master List. Only one can be active, however, and only the active list is 
updated with new information. You can specify which Master List is active in the Preferences dialog. See Report Style 
Panel on page 127.           
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Category

The Category drop-down list at the top left corner of the window lets you select one particular category for display, or all 
categories.         

 
Columns

As with individual Materials Lists, you can specify which columns display in the list. See Materials List Specification 
Dialog on page 1319.         

 
Find

Use the Find field near the bottom of the window to search for text in the Master List.         

The search starts from the currently selected cell and moves to the right, then moves down to the next row starting at the left 
column, and so on, until it finds an instance of the text you entered.           

ADDING TO THE MASTER LIST

You can edit line items in a Materials List and then add them to the Master List for future use.          

To use Update to Master List
 1.  Create a Materials List and change or add information in any editable column of a line item.          

 2.  Select the line item by clicking on its line number on the left side of the list. When selected, then entire line becomes 
highlighted.           

 3.  Select multiple adjacent rows by holding down the Shift key while clicking.           

 4.  Select Tools> Update to Master List . The information in the selected line is saved in the Master List.

 l If an item in the Master List has the same ID, Size, Description, and Label information as the selected line item, it 
will be updated.

 l If no item in the Master List matches the selection, a new line item in the Master List will be created.

Once Master List information exists for a particular item, you do not need to enter it again until you want to update it.           
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UPDATE FROM MASTER LIST

Similarly, items in a Materials List can be updated to include information in the Master List.          

To use Update from Master List
 1.  When a Materials List is active, click on a row number to select the row.           

 2.  Select Tools> Update from Master List  to have the program search the Master List for a record for the selected 

line item. If an identical record is available, its information is included in the Materials List.           

 l Multiple rows can be selected by clicking on one row number, then holding down the Shift key and clicking on 
additional row numbers.          

 l Select all rows by clicking the cell at the top left corner of the Materials List, above the row numbers.          

If the Master List contains more than one record for an item, the program references the last one entered. You can override 
this by defining one specific entry as the default. This is achieved by clicking on the check box in the Def column.           

The Master List is almost identical to a Materials List, but has a few additional controls to help with viewing.           

EDITING THE MASTER LIST

In the Master List, existing line items can be modified or deleted.               For information about the editability of columns in the 
Master List, see Materials List Columns on page 1322.

Often, the Master List will include items that you may not want to include in all Materials Lists.          

 l Check boxes in the Use column indicate whether each item is included in the Materials List. If Use is unchecked, the 
item is not included. This is useful in cases where several line items will be purchased as a single unit.          

 l This Quantity column is used to specify how many of an item must be found before information from the Master List 
is applied to it in a Materials List. If at least this many of the item are found, price, supplier, and other information is 
used. Quantity is useful for applying a quantity discount.          

 l When more than one line item is available for a specific component or accessory, the Default column indicates which 
item is to be used. Click this column to specify this item as the default. This is useful when a line item has been 
updated to the Master List more than once with different price, supplier or other information.          

To delete a row from the Master List, click on the row number at the far left. The entire row highlights. Select Edit> 
Delete, click the Delete  button, or press the Delete key on your keyboard.          

You should regularly back up your Master List (mmaster.mat) or 
lists. See Backing Up Your Files on page 42. 

 

Object Components
Many architectural objects in the program, from walls to cabinets to images, have components associated with them that are 
calculated in the Materials List and can be listed in schedules. For example, base cabinets have cabinet box and countertop 
components.

In addition to their components, some objects also have subcomponents. Cabinet boxes, for example, have doors, drawers 
and hardware.           

Components and subcomponents are specified on the COMPONENTS panel of many object specification dialogs.          
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You can also add and edit information for objects and their accessories in the Materials and Master Lists. See Editing 
Materials Lists on page 1324.          

COMPONENTS PANEL

Select one or more objects of the same type and click the Open Object edit button to open their specification dialog.         

The information on the COMPONENTS panel can also be edited for objects in the User Catalog of the Library Browser. See 
Editing Library Objects on page 986.           

The information on the COMPONENTS panel is the same as the Materials List line item(s) for the selected object.           

The selected object’s components and their attributes are listed in two tables.           

 
Components

The selected object’s components and subcomponents are listed here.         

 l Subcomponent names are indented to help distinguish them from main components.           

 l Click on a line item to select it and display its Materials List information to the right.          

The buttons above the table allow you to manage this list.           

 l When a component is selected, click the Add Line Item  button to add a new component to the list. When a 

subcomponent is selected, a new subcomponent is created instead.           

 l Click the Remove Line Item  button to remove the selected line item from the list.          

 l Click the Restore  button to return to the list any previously removed components or subcomponents. Only 

available when line items have been removed. User-created line items that have been removed are not affected by 
this option.

 l Click the Revert  button to reset any Formulas customized below. In the Cabinet Specification dialogs, they are 

reset to the values set in the corresponding Cabinet Defaults dialog; in the Cabinet Defaults dialogs, they are reset to 
the system defaults.     

   Materials List Data
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 l The left column is a list of column headings found in the Materials List. See Materials List Columns on page 1319.
         

 l The middle column displays the Formula used to calculate each row. See Materials List Formulas on page 1325.         

 l The Value resulting from each formula is shown for reference              in the right column.         

Additional information about how values are calculated may display below the table for some objects: notably, rooms and 
terrain features.

Note: The Label can be edited on the Label panel of the object’s 
specification dialog. See Label Panel on page 712.

 

Object Information Panel
The OBJECT INFORMATION panel is found in the specification and defaults dialogs for a variety of different objects. 
The settings on this panel let you specify information that can then be included in the Materials List and Schedules. 

See Materials List Columns on page 1322 and Columns to Include on page 701.    

 
Code

Specify a Code, such as an SKU, for the selected object. 

 
Comment

Specify a Comment for the selected object.

 
Description

Specify a Description for the selected object.
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Manufacturer

Specify the selected object’s Manufacturer. 

 
Supplier

Specify the selected object’s Supplier.

 
Custom Object Fields

The Custom Object Fields settings allow you to specify custom field values for use in schedules. See Custom Object Fields 
on page 702.             

 l A list of Custom Fields available in the current plan displays on the left. Click on a name to select it.

 l A Field Value for the selected Custom Field can be created or edited in the text field on the right. Individual objects 
can have different Field Values for the same Custom Field.

Click the Insert Macro button to the right of any of these text fields to insert a macro. See Text Macros on page 549.
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Chapter 41
 

Layout

The Chief Architect layout facility provides a set of easy to use tools for creating printed construction documents. You can 
create your own title block and border, then arrange multiple views of a plan, details, notes, and more on a page for printing.

Each layout file can contain many pages, each of which can contain multiple views, details, images, CAD objects, text, or 
contents and revision tables.

For detailed information about printing in Chief Architect, see Printing and Plotting on page 1368. 

TOPICS

Layout Preferences and Defaults 1339
The Layout Tools 1340
Creating a Layout File 1341
CAD and Text in Layout 1342
Pictures, Metafiles, and PDFs in Layout 1343
Sending Views to Layout 1343
Keeping Layout Views Current 1346
Displaying Layout Views 1348
Editing Layout Views 1350
Editing Layout Lines 1352
Layout Box Specification Dialog 1354
Opening Layout Views 1358
Managing Layout Links 1358
Layout Page Management 1360
Layout Page Information 1363
Layout Page and Revision Tables 1366
Printing Layout Files 1366
Exporting Layout Files 1367
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Layout Preferences and Defaults
There are a number of defaults and preference settings that affect layout files.

You can specify the background color of the drawing area in layout files on the COLORS panel of the Preferences 
dialog. See Colors Panel on page 102. 

To access the layout defaults for the current layout file, select Edit> Default Settings. The options in the Default 
Settings dialog are similar to those found in this same dialog in a plan file, although there are fewer choices in the list 

because only CAD objects, dimensions, and text can be drawn on layout pages. See Default Settings on page 76. 

GENERAL LAYOUT DEFAULTS

The settings in the General Layout Defaults dialog control basic features of the Chief Architect environment in the current 
layout file. As with other default settings, they are file specific, which means that they can be set differently in individual 
layout files. To open this dialog, select Edit> Default Settings , select "Layout", and click the Edit button. The settings 

in this dialog are also found in the General Plan Defaults dialog. See General Plan Defaults Dialog on page 96.

DRAWING SHEET SETUP

The settings in the Drawing Sheet Setup dialog are file-specific and are particularly important considerations in layout files. 
See Drawing Sheet Setup Dialog on page 1372.

LAYOUT PAGE DISPLAY OPTIONS

Select Tools> Layer Settings> Display Options to open the Layout Page Display Options dialog. 

This dialog is  similar to the Layers Display Options dialog, but controls only the display of objects drawn on the layout 
page, such as CAD objects, text, dimensions, and imported objects. The display of layout view boxes is also controlled by 
the Layout Page Display Options - but not the objects within those views. 

For information about how to use this dialog, see Layer Display Options Dialog on page 183.

For information about controlling the display of objects in views sent to layout, see Displaying Layout Views on page 1348. 

LAYOUT BOX DEFAULTS

The default line style, fill style, and label format for layout boxes can be set in the Layout Box Defaults dialog. See Layout 
Box Specification Dialog on page 1354.

PAGE TEMPLATES

In addition to the default settings available in layout files, you can create one or more Page Templates. Page Templates let 
you create features like a title block and border and then apply those features to any of the pages of your layout that you 
wish. See Layout Page Templates on page 1363.          

LAYOUT FILE TEMPLATES

You can customize layout default settings and Page Templates for future layouts and create a template. See Template Files 
on page 87.          
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The Layout Tools
There are a variety of tools available to send views to layout and edit them, as well as manage layout pages and links. 

Many of the tools available in layout are described in the Printing chapter. See The Printing Tools on page 1371. 

SENDING VIEWS TO LAYOUT

Select File> Send to Layout to open the Send to Layout dialog and send the current view to the specified layout 
page. See Sending Views to Layout on page 1343. 

In plan view, select a saved cross section/elevation view symbol and click the Send Camera’s View to Layout edit 
button. See Saving and Printing 3D Views on page 1114.

Select Tools> Layout> Referenced Plan Files to see a list of the files that are referenced by the layout. See 
Referenced Plan Files Dialog on page 52.         

EDITING LAYOUT VIEWS

A selected layout view can be edited much like other box-based objects. See Editing Box-Based Objects on page 234. In 
addition, a variety of edit tools allow you to control the appearance of each view:          

  Select a layout view and click the Open View edit button to open the view that was originally sent to layout. 
This tool is only available for dynamic views. See Editing Dynamic Views on page 1351. 

  Select a layout view and click the Rescale Layout edit button to open the Change Scale dialog and apply a 
different scale. See Rescaling Views on page 1351.         

  Select a layout view and click the Relink File edit button to open the Choose Layout File Reference dialog and 
relink the selected layout view. See Relinking Layout Views on page 1359.         

  Select a layout view and click the Layout Box Layers edit button to open the Layer Display Options dialog for 
the selected view. See Displaying Layout Views on page 1348.          

Note: You can also modify the layers of the layout file itself. See Layout 
Page Display Options on page 1339.

Select Tools> Layout> Edit Layout to allow the lines of a Vector View sent to layout to be edited individually. See 
Editing Layout Lines on page 1352.         

MANAGING LAYOUT PAGES

Layout pages can be managed via the Tools menu as well as using the contextual menu in the Project Browser. See Layout 
Page Management on page 1360.           

Select Tools> Layout> Edit Page Information to open the Layout Page Information dialog. See Layout Page 
Information on page 1363.          

Select Tools> Layout> Insert Page Before to add a new layout page, moving the current page and all following 
pages up one page, as long as there is nothing on page 1000. See Adding and Deleting Pages on page 1361.         

Select Tools> Layout> Insert Page After to add a new layout page, leaving the current page where it is but moving 
all following pages up one page, as long as there is nothing on page 1000.          

Select Tools> Layout> Duplicate Page to create an identical copy of the current page immediately after the original and 
with the same content and Page Information as the original.           
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Select Tools> Layout> Delete Page to delete the current layout page, moving all following pages down one page, as 
long as nothing is on the current page.          

Select Tools> Layout> Exchange With Next Page to switch the current layout page with the following page. Not 
available on Layout Page 1000.          

Select Tools> Layout> Exchange With Previous Page to switch the current layout page with the page preceding it. 
Not available on Layout Page 0.         

You can also specify the page that an object or group of objects 
displays on in its specification dialog. See Line Style Panel on 

page 310.    

Select Tools> Layout> Layout Page Table to place a Layout Page Table. See Layout Page Tables on page 1366.          

Select Tools> Layout> Layout Revision Table to place a Revision Table. See Revision Tables on page 1366.          

Select Edit> Delete Objects to delete categories of objects as well as Page Information from a specified scope of 
pages in the current layout file. See Delete Objects Dialog on page 289.

VIEWING LAYOUT FILES

Use Tools> Layout> Page Up, Page Down, and Change Layout Page to navigate the layout 
document. See The Current Page on page 1361.         

Select Window> Swap Views to switch between the current view and the view that was current before it. See 
Working in Multiple Views on page 154.

Select Tools> Layout> Update Layout Views to access tools that let you update semi-dynamic layout views. See 
Keeping Layout Views Current on page 1346.          

 

Creating a Layout File
To open an existing layout file, select File> Open Layout. Browse to a directory and select the layout file to open. 
See Opening and Importing Files on page 44.    

As with plan view windows, when a layout file is open, it is listed at the bottom of the Window menu as an open view. 
Layout files are also listed in the Project Browser. See Project Browser on page 58.

In order to create a layout file, you must open a new file and then save it.

Choose File> New Layout to create a blank layout file. A layout file is created with the name Untitled.layout. New 
layout files open to the first regular, non-Template page and use the default and layer settings associated with your 

layout template. See Template Files on page 87. 

Select File> Save to save the layout file. It is important that you save the layout in the same directory as the plan file 
from which views will be or have been sent to the layout pages. See Organizing Your Files on page 36.

Although it is possible to use multiple plan files with a layout, it is generally best to associate only one plan file with a 
layout and to use the same file name for both. If more than one plan file is used, all should be saved in the same directory as 
the layout file. 

When you save your layout, take a moment to also save the plan file associated with it. 
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When a view is sent to layout, the plan and layout files become 
linked. If you rename or move either file, this link will be 

broken and the view will not display. See Managing Layout Links on 
page 1358.

 

CAD and Text in Layout
CAD objects, text objects, as well as dimensions can be incorporated into your layout by both including them in your 
views sent to layout and by drawing them on the layout page. 

ON THE LAYOUT PAGE

CAD and text can be drawn directly on any layout page, allowing you to create a title block, border, as well as notes and 
other annotations. A variety of Layout Info text macros  with information about page number, revisions, and more can be 
inserted into text objects on layout pages. See Text Macros on page 549. 

Layout boxes have labels that can be customized to report a variety of information about each view. See Layout Box 
Borders and Labels on page 1349.

You can draw dimension lines on the layout page to help position CAD and text objects, as well. Dimensions that locate 
objects in a view sent to layout, however, should be drawn in the original view. See Dimensions on page 454.

CAD, text, and dimensions created in layout can be selected, edited, and deleted just as they can in other views. See Editing 
Text on page 518 and CAD Objects on page 294.

Pictures and PDFs can also be imported into layout. See Pictures, Images, and Walkthroughs on page 1180.

To move a text or CAD object to another page, change the Page number in its specification dialog. See Line Style Panel on 
page 1357.           

Any text or CAD objects that you would like to display on multiple pages of your layout file - for example, a title block and 
border - should be drawn on a page specified as a Page Template. See Layout Page Templates on page 1363.           

IN VIEWS SENT TO LAYOUT

CAD, text, and dimensions in views sent to layout are scaled just like other objects in the view. If you want text in a layout 
view to print at a particular size, specify its size based on the scaling you will use when you send the view to layout. See 
Character Size on page 504.

If you rotate a view on the layout page, any text in that view will rotate as well, provided that its Text Style is using the 
Rotate with Plan setting. See Text Styles on page 547. 

If you wish to use Global Text Macros that provide information about a view, such as its drawing scale or the plan’s file 
name, make sure that the text object is in the view sent to layout - not on the layout page.           

A number of macros with information about the layout view can also be added to a layout view’s label as Object Specific 
Macros. See Layout Box Borders and Labels on page 1349.           

CALLOUTS IN PLAN VIEWS

In plan views, callout shapes are used to refer the reader to a different location for more information about a particular 
feature shown in the view. There are four types of callout, each created in a different way:          
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 l A standard Callout  refers to a detail drawing. Callout text can be linked to a particular view or layout page by the 

user. See Linked Callouts on page 533.
 l A Note  callout is linked to a specific line item in a Note Schedule with written notes on particular topic. See 

Notes, Note Types, and Note Schedules on page 542.
 l An object label callout is linked to a Schedule  for that particular object type in the plan file. See The Schedule 

Tools on page 695.
 l A Cross Section/Elevation  callout represents the location of a saved cross section or elevation view in the plan 

file. By default, these callouts include dynamic information about the location of the view in layout. See Callout 
Labels on page 1092.

 

Pictures, Metafiles, and PDFs in Layout
Picture files, metafiles, and PDF files can be included in views sent to layout or imported directly onto a layout page. See 
Displaying Pictures, Metafiles, and PDF Boxes on page 1197.

Like CAD and text objects, imported pictures, metafiles, and PDFs can be included on Page Templates. See Layout Page 
Templates on page 1363.           

Views can also be sent to layout as pictures embedded in the layout file. See Static Views on page 1348. 

A picture, metafile, or PDF file imported onto the layout page can be selected and edited using its edit handles, edit tools 
and specification dialog. See Editing Pictures, Metafiles, and PDF Boxes on page 1198. 

Embedded pictures and pdf files increase layout file size. Limit 
the number of large and/or multiple pictures.

 

Sending Views to Layout
Layout files can contain many different views and details sent from one or more plan files. Views cannot, however, 
be sent from one layout file to another. To send the active view from a plan file to layout, select File> Send to 

Layout.

You can also send one or more saved, closed cross section/elevation views to layout by selecting the camera symbol 
and clicking the Send Camera’s View to Layout edit button. This edit tool is only available when the selected view 

has been saved, has not previously been sent to layout, and is not open. See Saving and Printing 3D Views on page 1114.

To send a view to layout
 1.  Prepare the view so that the desired layer, default, and other settings are in use. See Dynamic Views on page 1346 

for more details.

If there are layer settings that you use often, you can create 
custom layer sets. See Layer Sets on page 186.

 2.  Select File> Send to Layout . In the Send to Layout dialog, the available options vary depending on the type of 

view being sent to layout.

 3.  Click OK to send the view to the specified layout page. Depending on the type of view and size of the model, you 
may see a progress indicator in the Status Bar. See The Status Bar on page 25. 
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SEND TO LAYOUT DIALOG

 
Choose Layout

From the drop-down list, select the layout file you would like to send the current view to. All open layout files are available, 
as is “New Layout”. If the program finds a layout file with the same name as the current plan file, it will be listed as well.

 
Send Position

These options are available for all types of views.      

 l Send to Layout Page # - Enter a page number to send the view to.    

 l Check Snap to Active CAD Point to snap the view you are sending to layout to the active CAD Point. See Point 
Tools on page 301.    

 l Check Show Layout Page to go to the selected layout page when you click OK. When this is unchecked, the current 
view remains active.
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Send Options

The options available here depend on the type of view being sent to layout. The last settings used for cross section/elevation 
views are retained during the current program session, as are the last settings used for camera views and overviews, and 
those used for plan and CAD Detail views.    

 l Select Entire Plan/View to send to layout the extent of the plan that is visible when you click Fill Window . 

This option is not available for Perspective 3D views. See Types of 3D Views on page 1081.    

 l Select Current Screen to send only what is shown on screen to layout. This option is available for all view types.    

 l Select Current Screen As Image to send only what is shown on screen to layout as an embedded image. See 
Picture File Box Specification Dialog on page 1189. This option is available for all views, and is the only option 
available for rendered and CPU Ray Trace views.    

 l When Link Saved Plan View is checked, the view being sent to layout is dynamically linked to the Saved Plan 
View currently in use. The name of that view is stated in parentheses for reference. Uncheck this box to use the 
current floor, layer set, Reference Floor settings, and the currently active Default Set, but not the Saved Plan View. 
Not available if the view being sent to layout is not a Saved Plan View. The Saved Plan View can also be specified 
in the view’s Layout Box Specification dialog. See Layout Box Specification Dialog on page 1354.          

 
Camera View Options

These options are available for cross section/elevation, camera views, and overviews sent to layout - provided that Current 
Screen as Image is not selected, above. The last settings used for cross section/elevation views are retained during the 
current program session, as are the last settings used for camera views and overviews.    

 l Select Live View to make the view dynamically linked to the plan file.     

 l Select Update on Demand to update the view only when prompted. See Keeping Layout Views Current on page 1346.     

 l Select Always Update to update the view any time a change is made to the model. This option ensures that the view is 
always current but may cause program slowness.     

 l Select Plot Lines to send a Vector View to layout that uses automatically generated Plot Lines to represent surface 
edges and material pattern lines in the model. See Plot Line Views on page 1348.     

 l Check Color Fill to include colors that correspond to the materials used in the model.     

 l Check Use Edge Line Defaults to use the line weight and color set in the view’s Layout Box Specification dialog for all 
object edge lines. See Linked View Panel on page 1354.
When unchecked, the view uses layer- and/or object-specific settings, per the Surface Edge Lines settings in the 3D 
View Defaults dialog. See 3D View Defaults Dialog on page 1084.     

 l Check Use Pattern Line Defaults to use the line weight and color set in the view’s Layout Box Specification dialog 
for all material pattern lines. See Linked View Panel on page 1354.
When unchecked, the pattern line weight and color settings set in the Define Material dialog are used. See Pattern 
Panel on page 1067.

The Edge and Pattern Line Defaults settings are included for 
legacy files and are not the recommended method of 

specifying this information. See Edge and Pattern Lines on page 182.      
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Scaling

Select a radio button to specify how the view sent to layout is subjected to scaling.    

 l Select Fit to Sheet (No Scale) to send the view to layout at approximately half the size of the layout drawing sheet. 
Once on the layout page, the view can be resized. 

 l Specify the exact scale for the view in layout. The view can be rescaled later from layout if necessary. Both U.S. 
and metric units of measurement are available and can be selected independently. 

 l When views are sent to layout at different scales, line weights and line styles are subject to the same scaling. In most 
cases this is not desirable. When Use Layout Line Scaling is checked, the lines in views sent to layout appear the 
same as lines drawn directly on layout. This option is not available for rendered views. See Line Weights and Scaling 
on page 1380.

 

Keeping Layout Views Current
It is not uncommon for changes to be made to a plan after views have been sent to layout. In order to make sure that your 
layout file is up-to-date, it is important to recognize that there are four types of layout views: 

 l Dynamic Views on page 1346, which update automatically every time changes are made to the original view in the 
plan.

 l Semi-Dynamic Views on page 1347, which fully update when printed or prompted by you.
 l Static Views on page 1348, which do not reference the plan and cannot be updated: only replaced.
 l Plot Line Views on page 1348 have elements that are Dynamic or Semi-Dynamic and others that are Static. 

Semi-Dynamic and Plot Line Views can be updated using the Update Layout View tools. Select Tools> Layout> 
Update Layout Views. In addition, a selected view can be updated using the Update View  edit tool. 

DYNAMIC VIEWS

Dynamic views reference the original view in the plan and update automatically whenever changes are made to that view, 
including:

 l Changes to the model.
 l Changes to annotations in the view.
 l Changes to the layer set used by the layout view. See Layout View Layer Sets on page 1349.
 l Changes to the settings of any of the Active Defaults  in use in the view.          

 l Changes to any of the Saved Plan Default Specification settings.          

In order for a view to be Dynamic, it must be sent to layout using either the Entire Plan/View or Current View Send 
Option. In addition, camera views must have Update Always specified. See Send To Layout Dialog on page 1344.

While convenient, Dynamic views require use of your computer’s resources and may slow program performance. This is 
particularly the case with Physically Based Ray Trace views. Consider sending cameras, overviews, and cross 
section/elevations to layout as Semi-Dynamic views.

SAVED AND UNSAVED PLAN VIEWS

For the most part, plan views sent to layout are Dynamic; however, a number of elements are Static unless they are modified 
in the Saved Plan View they are associated with, and that view is then saved. See Plan Views on page 150. 
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These elements are also Static if the layout view links to an unsaved plan view. When this is the case, however, most of 
them can be specified in the Layout Box Specification dialog. See Layout Box Specification Dialog on page 1354.

 l The default Display in Plan View and Display of Openings in Non-Displayed Parts of Walls settings for pony walls 
are saved with each Saved Plan View and are a permanent part of the layout view unless the Saved Plan View is saved 
after the settings are modified. See Pony Wall Defaults on page 349.

 l The floor level shown in a view sent to layout does not change if you move to a different floor in the plan. See 
Multiple Floors on page 743.

 l The Reference Display  setting in a view sent to layout is unaffected if the Reference Display is turned on or off in 

the plan. See The Reference Display on page 69.
 l The Color  setting in a view sent to layout is unaffected if Color is toggled on or off in the original view. See 

Color On/Off on page 196. 
 l The Active Defaults  that are in use when a plan view is sent to layout are not affected when you switch to 

different defaults in the plan. See Using Active Defaults on page 84.           
 l The layer set used by a layout view does not change if you switch layer sets in the plan. See Layer Sets on page 186.           
 l In all cases, the Rotate Plan View  angle is a permanent part of the layout view. In order to modify this angle in a 

view sent to layout, you must delete the view from the layout page and resend it. See Rotate Plan View on page 151. 

There are several ways to specify whether a plan view sent to layout links to a Saved Plan View or not:          

 l Make active the Saved Plan View or an unsaved view prior to sending it to layout.          
 l Specify the desired Saved Plan View or choose “None” in the  Layout Box Specification dialog.           
 l Select a layout view or views and click the Create Saved Plan View  edit button. If a Saved Plan View with the 

same attributes as the selected view already exists, you will be given a choice to link to it or to create a duplicate in the 
plan file. If one does not exist, you can create a new one and specify its name.           

 l Select a layout view or views and click the Unlink Saved Plan View  edit button.           

For information about controlling the display of dynamic views in layout, see Displaying Layout Views on page 1348.   

SEMI-DYNAMIC VIEWS

Camera views, overviews, and cross section/elevation views can all be sent to layout as Semi-Dynamic views. Semi-
Dynamic views reference the original view in the plan but no information about the model or the view’s layer settings 
update unless you prompt the layout view to update. 

When a cross section/elevation view has been sent to layout, CAD objects, text, and dimensions in that view are fully 
Dynamic - even if the view is set to Update on Demand. See Detailing Cross Section/Elevation Views on page 1092.

In order for a view to be Semi-Dynamic, it must be sent using either the Entire Plan/View or Current View Send Option 
and have Update on Demand specified. See Send To Layout Dialog on page 1344.

There are several ways to update a Semi-Dynamic view:

 l Select it and click the Update View  edit button;

 l Select Tools> Layout> Update Layout Views> Update All Views ; or

 l Select Tools> Layout> Update Layout Views> Update All Live Views .

 l Update on Demand views also update automatically when you print the layout page that they are on. 
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Views set to Update on Demand may experience a loss in quality as you zoom and pan on the layout page. To restore a 
view’s resolution, simply update it. 

STATIC VIEWS

Static views are like a snapshot of the model taken at a specific time: they do not update when the plan changes. If changes 
to the plan need to be shown in a Static view, that view must be deleted and resent to layout. 

All views sent to layout using the Current Screen as Image option are Static. They are treated as imported images 
embedded in the layout file. See Picture File Box Specification Dialog on page 1189.

Because CPU Ray Trace views are themselves static images of the model, Current Screen as Image is the only option 
available when sending one to layout. See CPU Ray Tracing on page 1163.           

PLOT LINE VIEWS

Camera views, overviews, and cross section/elevation views using the Vector View Rendering Technique can be sent to 
layout as Plot Lines. See Rendered and Vector Views on page 1081.

In Plot Line views, the lines in the layout view that represent the 3D model are automatically generated copies of those in 
the original view, allowing them to maintain the line weights that were specified in the plan. See Line Weights on page 
1379.

 l Plot Line views are Semi-Dynamic in that they are linked to the original view and can be updated.
 l Plot Line views are Static in that they will not update automatically when printed: they can only be updated manually 

by you.
 l The Plot Lines themselves are also Static: they can be edited using the Edit Layout Lines  tool, but if the view is 

updated, these lines are deleted and replaced. For this reason, you should only use the Edit Layout Lines  tool 

after the model has been finalized. See Editing Layout Lines on page 1352.          
 l Any CAD objects, text, or dimensions drawn in a cross section/elevation view sent to layout will not be copied and 

represented by Plot Lines. These objects are fully Dynamic and will update immediately in the layout view if changes 
are made to them. See Detailing Cross Section/Elevation Views on page 1092.

 l The Color  setting in a Plot Line view is unaffected if Color is toggled on or off in the original view in the plan. 

See Color On/Off on page 196.
 l Image objects are not included in Plot Line views. See Images on page 1181.

Plot Line views do not automatically update when printed, nor can they be set to update automatically. In order to update a 
Plot Line view, you must do one of the following:

 l Select it and click the Update View  edit button;

 l Select Tools> Layout> Update Layout Views> Update All Views ; or

 l Select Tools> Layout> Update Layout Views> Update All Plot Line Views .

 

Displaying Layout Views
Just as some elements in a view window do not print, they are not included when a view is sent to layout: for example, the 
Reference Grid and camera symbols in plan view. See Print Preview on page 1376.         
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Although camera symbols are not included in views sent to 
layout, camera callouts are when the “Cameras” layer is turned 

on in the view. See Camera Labels and Callouts on page 1098. 

LAYOUT VIEW LAYER SETS

When a view is sent to layout, the active layer set is used. See Sending Views to Layout on page 1343.

Whether or not the layer settings in a view can be edited after it has been sent to layout depends on the view’s type.  See 
Keeping Layout Views Current on page 1346.          

 l The layer set used by a Dynamic or Semi-Dynamic view can be modified using the Layout Box Layers  edit tool.          

 l A different layer set can also be selected for Dynamic and Semi-Dynamic views using the Layout Box Layers  

edit tool.          
 l In addition, Dynamic and Semi-Dynamic views’ layer settings can be modified by opening the original view. See 

Opening Layout Views on page 1358.           
 l Static views cannot be changed. Similarly, even in Dynamic views, some features are static and cannot be altered.           

The layer set referenced by a Dynamic layout view is saved with the plan rather than the layout file.          

Do not delete layer sets that are used in layouts.
 

To use the Layout Box Layers tool
 1.  Select a layout view.           

 2.  Click the Layout Box Layers  edit button to open the Layer Display Options dialog for the selected view. See 

Layer Display Options Dialog on page 183.          

 l If this edit button is not available, the view is not dynamic.           

 l The layer set for the layout view displays at the top of the dialog.          

 l The settings for the currently selected layer display below.          

 3.  You can make changes to settings of the current layer set.

Changes made to this layer set affect all other views that use it, not necessarily the selected layout view alone.          

 4.  Alternatively, you can select a different layer set for the layout view from the Layer Set drop-down list.          

 5.  Be sure to Save  your changes in the plan file before closing the layout.          

LAYOUT BOX BORDERS AND LABELS

A border will display around each layout box when the “Layout Box Borders” layer is set to display in the Layout Page 
Display Options dialog. See Layout Page Display Options on page 1339. 

Layout boxes can also display labels when the “Layout Box Labels” layer is set to display. See Label Panel on page 712.   

Automatic layout box labels display basic information about the original view in the plan. For example, plan view sent to 
layout from Floor 1 will have an automatic label that says, “1st Floor”. A camera view sent to layout will have a label that 
states the camera’s name. Layout box labels have their own edit handles and can be customized to include text as well as 
Object Specific Text Macros. See Text Macros on page 549.
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Layout box labels can also be set to use callouts and markers. A callout or marker label can report its current page and the 
name of the view, and can be linked to a different view or layout page and report information about it, as well. See Linked 
Callouts on page 533.

MISSING LAYOUT VIEWS

If a view on the layout page can be selected but cannot be seen, its link to the plan from which it was sent may have been 
broken. See Managing Layout Links on page 1358. 

 

Editing Layout Views
To edit a layout view, first select its layout box using the Select Objects  tool. Once selected, the view box can be edited 

using its edit handles, edit toolbar or specification dialog.

USING THE EDIT HANDLES

Layout view boxes can be edited using their edit handles like closed polyline-based objects. See Editing Closed Polyline-
Based Objects on page 230. 

IN THE SPECIFICATION DIALOG

Layout view boxes can be customized in their specification dialog. See Layout Box Specification Dialog on page 1354.

USING THE EDIT TOOLS

A selected layout view or views can be edited in a variety of ways using the buttons on the Edit Toolbar. See The Edit 
Toolbar on page 135.

A few edit tools are unique to layout boxes:          

  Rescale Layout View allows you to specify the selected view’s scale. See Rescaling Views on page 1351.          

  Relink File lets you change the plan file that a dynamic view is linked to. See Relinking Layout Views on page 
1359.          

  Create Saved Plan View allows you to associate a selected layout view or views to a Saved Plan View in the 
plan that it is linked to. If a Saved Plan View with attributes identical to the selected view(s) exists, you will be 

asked to choose to link to it or create a new Saved Plan View. See Plan Views on page 150.           
  Unlink Saved Plan View disassociates the selected layout view(s) from a Saved Plan View and instead lets you 
specify the floor level and Default Set that the view shows. See Layout Box Specification Dialog on page 1354.          

  Layout Box Layers specifies which layer set and layer settings the selected view uses. See Layout Page Display 
Options on page 1339.          

  Pan/Scale Layout Box allows you to click and drag to pan within the selected view as well as specify its scale 
using inline text fields. See Panning the Display on page 158.

  Recenter Layout Box Contents centers the contents of the view in the layout box without changing the view's 
scale.

  Scale Layout Box Contents to Fit rescales the view so that all contents can be seen within the layout box's 
current extents.
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USING DIMENSIONS

Like other CAD based objects, layout views can be moved and resized using dimensions. See Moving Objects Using 
Dimensions on page 491.

MOVING VIEWS TO A DIFFERENT PAGE

To move a view from one layout page to another, select the view, click the Open Object  edit button, and change the 

Page on the LINE STYLE panel of the Layout Box Specification dialog. See Layout Box Specification Dialog on page 1354.          

COPYING VIEWS

Just like many objects, views sent to layout can be copied and pasted onto different layout pages or even into different 
layout files. 

As a general rule, though, if multiple copies of a view are needed, it is best to send the view to layout as many times as 
necessary because each view can then be controlled independently.

Bear in mind, too, that if a layout has views copied from a different layout file and is later moved to a different location on 
your computer, the link to the original plan file may be broken. See Keeping Layout Views Current on page 1346. 

EDITING DYNAMIC VIEWS

Select a Dynamic or Semi-Dynamic view and click the Open View  edit button to open the original view that was sent 

to layout. You can also double-click a view of either type in layout to open the original view. See Opening Layout Views on 
page 1358.

RESIZING SCALED VIEW BOXES

Scaled views retain their scale regardless of how you resize the border. If the border is increased in size, blank spaces may 
be created; if the border is made smaller, the view may become cropped. 

RESIZING NON-SCALED VIEW BOXES

If the view was sent to layout using the Fit to Sheet setting, or if a view is set to No Scale in the Change Scale dialog, 
resizing may have one of two results:

 l Drag a corner edit handle using the Alternate  Edit Behavior to resize both the border and the image 

proportionally. See Alternate on page 209.
 l If you use any other Edit Behavior or if you drag a side edit handle, the perimeter of the layout box changes but the 

view inside it stays the same size. If you make the border smaller, the view may become cropped. 

RESCALING VIEWS

There are a couple of ways to rescale a floor plan, CAD Detail, or cross section/elevation view sent to layout:

The Pan/Scale Layout Box edit tool allows you to change the scale of a selected layout view box by typing the 
desired scale in a pair of inline text fields.   

Scale Layout Box Contents to Fit rescales the view so that all contents can be seen within the layout box's current 
extents. The program chooses a scale that best achieves this task, regardless of whether it is a commonly used scale 

or not.
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The Rescale Layout View edit tool opens the Change Scale dialog.         

 l Choose No Scale to remove any specific scale factor associated with the selected view.           
 l Select the second option to specify a scale for the view. When its scale is changed, the layout view will resize. In most 

cases, you should specify a scale for plan views, CAD Details, and cross sections/elevation views. Typical scales are ¼ 
in = 1ft and 1 m = 50 m.          

 l When a view is sent to layout at a scale other than that of the original view, line weights and line styles are affected. In 
many cases, this is not desirable. Check Use Layout Line Scaling to make lines in the selected view appear the same 
as lines of the same weight drawn on the layout page. See Line Weights and Scaling on page 1380.          

 

Editing Layout Lines
Individual object edge and material pattern lines in a Vector View sent to layout using the Plot Lines option can be 
selected, edited, and drawn using the Edit Layout Lines tool. Changes made using this tool have no effect on the 3D 

model. See Rendered and Vector Views on page 1081.

Bear in mind that automatically generated Plot Lines are not dynamically linked to the model: if the layout view is updated, 
these lines are deleted and replaced. For this reason, you should only use the Edit Layout Lines tool after the model has 
been finalized. See Keeping Layout Views Current on page 1346.

The full set of CAD editing tools is not available when using 
Edit Layout Lines. It is often more efficient to edit lines in a 

Vector View by sending it to a CAD Detail for editing first. See CAD 
Detail from View on page 341.

CAD lines drawn in cross section/elevation views sent to layout cannot be edited using the Edit Layout Lines tool. Only 
Plot Lines generated by the program can be edited using this tool. See CAD and Text in Layout on page 1342.

SELECTING LAYOUT LINES

To select a line in a layout view, click the Edit Layout Lines button and click on the line. You can select additional lines in 
the same layout view using the marquee select or group select methods.  See Selecting Objects on page 212. 

ADDING NEW LAYOUT LINES

Add a line to a layout Vector View by clicking the Edit Layout Lines button, selecting a layout view, and drawing a new 
line within the layout box. Once drawn, this line can be edited like any other layout line and maintains its position in 
relation to the layout view it was drawn in.

EDITING LAYOUT LINES

When a layout line is selected, you can use the edit handles to change its size, angle, and position, as with standard CAD 
lines. A selected layout line can also be deleted like a standard CAD line; however, many of the edit tools that are available 
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for standard CAD objects are not available for layout lines.

Angle Snaps , Object Snaps , and Grid Snaps are all available in layout. See Snap Settings on page 162.

Layout line properties can be changed in the Layout Line Specification dialog. 

LAYOUT LINE SPECIFICATION DIALOG

Use the Edit Layout Lines tool to select one or more lines in a Vector View sent to layout, then click the Open 
Object edit button to open the Layout Line Specification dialog. 

The dialog lets you change the properties of the selected line(s) without changing the properties of all lines in the view.

  Line Type

 l Select Edge Line to specify the selected line(s) as defining the edges of the surface of 3D objects.

 l Select Pattern Line to specify the selected line(s) as patterns lines for materials such as brick, siding, and shingles.

 l When multiple lines are selected, No Change may be available. 

 
Line Weight

See Line Weights on page 1379. 

 l Type the desired Weight, or thickness, of the selected line(s) in the text field. 

 l Check Use Default Weight to use the default value set in the view’s Layout Box Specification dialog. See Linked 
View Panel on page 1354. 

 
Line Style

See  Line Styles on page 200. 

 l Select a line style from the drop-down list or click the Library button and choose one from the Library. 

 l Check Use Default Style to use the default style set in the Layout Box Specification dialog.
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  Line Color

 l Click the Color bar to select a line color. See Color Chooser/Select Color Dialog on page 204.

 l Check Use Default Color to use the default color set in the Layout Box Specification dialog.

 

Layout Box Specification Dialog
Select a layout view and click the Open Object edit button to open the Layout Box Specification dialog.

The settings on the LINE STYLE, FILL STYLE, and LABEL panels of this dialog are similar to those in the LAYOUT BOX 
DEFAULTS dialog. See Layout Preferences and Defaults on page 1339.

LINKED VIEW PANEL

The settings on the LINKED VIEW panel vary depending on the type of view selected. See Dynamic Views on page 1346. 
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Linked View

Information about the view that the selected layout box is linked to is reported here. If the selected layout box is not linked 
to a view, these lines will be blank.

 l File Name reports the linked file's full pathname.

 l View Name reports the name of a saved view; the floor level is reported for unsaved plan views. See View Windows 
on page 149.

 l View Type reports the view's Type. A plan view is referred to as "Floor level" if unsaved. See Saved Views on page 
149.

 l Click the Relink button to open the Link View dialog. See Link View Dialog on page 51.

 
Dimensions

The Number Height setting is only available in legacy layout files when the selected view is using a non-default Number 
Height value. This legacy setting affects the size of dimension numbers in the selected layout view but not in the original 
plan file. See Dimension Defaults Dialog on page 457.     
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Options

These settings vary, depending on the type of view selected.     

The Saved Plan View Options are only available when the Linked View is a saved plan view. See Plan Views on page 150.

 l The Current Floor is reported here for reference only.

 l Click the Edit View button to open the view's specification dialog. See Plan View Specification Dialog on page 153.

The Floor Level Options are only available when the Linked View is a plan view that is not saved. See Plan Views on page 
150.

 l Specify the Current Floor level shown in the view. See Displaying Floor Levels on page 747.

 l Select the Current Default Set used in the view from the drop-down list. See Default Sets on page 83.

 l Uncheck Show Color to turn color off in the selected view. See Color On/Off on page 196.

The Camera View Options are only available when the Linked View is a cross section/elevation view, camera view, or 
overview. See 3D View Tools on page 1085.

 l Select Live View to make the view dynamically linked to the plan file.      

 o Select Update on Demand to update the view only when prompted. See Keeping Layout Views Current on page 
1346.       

 o Select Always Update to update the view any time a change is made to the model. This option ensures that the view 
is always current but may cause program slowness.      

 l Select Plot Lines to make the view a semi-dynamic Vector View with automatically generated plot lines that 
represent surface edges and material pattern lines. See Plot Line Views on page 1348.      

 o Check Color Fill to include colors that correspond to the materials used in the model.       

 l Specify the Line Weight and Line Color defaults for edge lines and pattern lines in the current Plot Lines view. See 
 Line Styles on page 200.

The Edge Line Defaults and Pattern Line Defaults settings are only available when Plot Lines is selected above, and 
only have an effect on the entire view if Use Edge Line Defaults and/or Use Pattern Line Defaults were checked when 
the view was originally sent to layout. These settings are also the defaults for lines modified using the Edit Layout 
Lines  tool. See Send To Layout Dialog on page 1344 and Editing Layout Lines on page 1352.

 
Reference Display

These settings are only available when the Linked View is an unsaved plan view, and control the display and appearance of 
the Reference Floor in that view. These settings are only active when the Linked Saved Plan View is “None”, above, and 
are also found in the Change Floor/Reference dialog. See The Reference Display on page 69.         

BOX SCALE PANEL

The settings on the BOX SCALE panel control how the contents of the selected layout box are scaled. See Printing to Scale 
on page 1377.
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   l Choose No Scale to remove any specific scale factor associated with the selected view

 l Select the second option to specify a scale for the view. When its scale is changed, the layout view will resize. In 
most cases, you should specify a scale for plan views, CAD Details, and cross sections/elevation views. Typical 
scales are ¼ in = 1ft and 1 m = 50 m.

 l When a view is sent to layout at a scale other than that of the original view, line weights and line styles are affected. 
In many cases, this is not desirable. Check Use Layout Line Scaling to make lines in the selected view appear the 
same as lines of the same weight drawn on the layout page. See Line Weights and Scaling on page 1380.

 l When Scale Layout Box Contents Only is checked and you change the scale of the selected view, the layout box 
will resize to match. When unchecked, the layout box will remain the same size.

LAYER SET PANEL

The LAYER SET panel has one setting: select the view's Active Layer Set from the drop-down list. This option is only 
available when the selected layout box is linked to a view that is not saved. See Layer Sets on page 186.

POLYLINE PANEL

The POLYLINE panel states the length of the countertop’s Perimeter, its Area, and its Volume. See Polyline Panel on page 
323. 

SELECTED LINE/ARC PANEL

The SELECTED LINE panel is available when the selected edge is a line as opposed to an arc. For more information, see  Line 
Panel on page 309.

The SELECTED ARC panel is available when the selected edge has been converted to an arc. For more information, see Arc 
Panel on page 318.

See, too, Selected Edge on page 214 and Change Line/Arc on page 259. 

LINE STYLE PANEL

The settings on the LINE STYLE panel let you set the properties of the selected layout box’s border and to specify what 
layout page it is located on. 

For more information, see Line Style Panel on page 310. 
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FILL STYLE PANEL

For information about the FILL STYLE panel, see Fill Styles on page 197.

LABEL PANEL

Layout box labels display in layout when the “Layout Box Labels” layer is turned on and use the Text Style assigned to that 
layer. See Layout Box Borders and Labels on page 1349. 

For more information about the settings on this panel, see Label Panel on page 712.

 

Opening Layout Views
Dynamic and Semi-Dynamic views sent to layout refer to an original view in a plan. From the layout page, you can 
access that original view by selecting a layout box, then clicking the Open View edit button. The original view can 

also be opened by double-clicking the layout view using the Select Objects  tool.

Changes made in this view update in the original layout view. Be aware that depending on the changes you make, other 
views may also be affected. 

LAYER SETS

Notice the name of the current layer set that at the top of the Active Layer Display Options side window. Changes made to 
this layer set affect not only the current view, but also the associated layout view and any other views that use this layer set. 
See Layer Sets on page 186.           

It is important to remember that when a plan view is accessed by 
opening a dynamic layout view, that view uses the same layer set 

as the layout view.

DEFAULT SETS

Plan views, cross section/elevation views, and CAD Details sent to layout each have a set of Active Defaults associated with 
it. When you send one of these view types to layout, these defaults become associated with the layout view; and when you 
open the original view of one of these types of layout views, its defaults will become active automatically. See Multiple 
Saved Defaults on page 79.           

You can specify which defaults are associated with a plan view sent to layout by specifying the view’s Current Default Set 
in the Layout Box Specification dialog  See Layout Box Specification Dialog on page 1354.           

Note that the Current Default Set associated with a layout view always uses the layer set assigned to the layout view, 
regardless of how the Default Set itself may be defined.           

 

Managing Layout Links
Chief Architect allows you to review the plan files linked to a current layout, change existing links from one plan file to 
another, and reestablish links to plan files that have been moved or renamed. 
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PROTECTING LAYOUT LINKS

Careful file management is needed to avoid missing files and disrupted layout links. See Organizing Your Files on page 36.

The following guidelines can help prevent layout links from being broken:

 l Save plan files in the same folder as the layout, or in a sub-folder in that folder.
 l Custom graphics included in a plan or layout should be embedded in the file or saved in the same folder as the layout.
 l Plan files used to save CAD details or other information should be copied and saved in the same folder as the layout.         
 l Plan files should never be renamed. If a new name is desired, make a copy of the file and rename the copy. Changes 

made in the copy do not affect views sent to layout from the original plan.
 l Avoid sending cross section/elevations to layout more than once. Changes made to the view can affect layout views in 

unintended ways.
 l Layout files should never be moved. If a layout file must be moved, the entire folder it is saved in should be moved or 

copied and then moved.
 l Use File> Backup Entire Layout  to create an independent copy of the original layout. Avoid use of “Save As.”  

See Backup Entire Plan or Layout on page 55.
 l Do not delete any layer sets that are used by a view that was sent to layout. See Layer Sets on page 186.
 l If you relink a layout view to a new plan, be sure to save the plan file so the layer sets are updated.

When a layout box is selected, the name of the plan file and 
basic information about view it is linked to are reported in the 

Status Bar. See The Status Bar on page 25.

FINDING MISSING FILES

When a layout file is opened, the program performs a breadth-first search for dynamically linked views. This means that it:

 l Looks first in the same folder as the layout. 
 l Looks next in the folders located closest to the layout’s folder. 
 l If a missing file is not found, it expands its search further from the location of the layout file until the files with the 

linked views are located.
 l If a missing file is not found, a second breadth-first search will be performed, searching all zipped files found in the 

first search. 

If a file remains missing after the program performs a search of your system, a Warning message will indicate that the 
program could not successfully open all of the layout’s associated plan files. When you click OK, the Referenced Plan Files 
dialog will open, allowing you to relink the layout to its missing associated files.

You can also open this dialog at any time by selecting Tools> Layout> Referenced Plan Files  while a layout file is 

open.         

RELINKING LAYOUT VIEWS

There are a couple of ways to relink a dynamic layout view to a different view. One way is to select it and click the 
Relink Layout Box edit button to open the Link View dialog. See Link View Dialog on page 51

You can also relink a layout box to a view in the Layout Box Specification dialog. See Linked View Panel on page 1354.
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If you want to relink all references to a particular plan file so they refer to equivalent views in a different plan, use the 
Referenced Plan Files dialog. See Referenced Plan Files Dialog on page 52.         

MISSING LAYER SETS

The layer set associated with each view in a layout is saved with the plan file from which the view was sent. Just as it is 
important to not move, rename, or delete the plan file, it is important that you not rename or delete a layer set used by a 
layout view.         

If a layer set used by a layout view cannot be found when the layout is opened, the Missing Layer Set dialog will display.         

 
Layout Box Information

The Layout Box Information describes the layout view that is missing a layer set, indicating:         

 l The Layout Page where the view in question is located;          

 l View Information, which describes the contents of the view in question,          

 l The Plan Filename of the plan file that the layer set is missing from.         

 
Layer Sets

The Layer Sets options allow you to replace the missing layer set.         

 l The name of the Missing Layer Set displays for reference.           

 l Select a replacement layer set from the Available Layer Sets drop-down list.          

 l Click the Define button to open the Layout Page Display Options dialog, where you can make changes to the 
selected layer set.         

 

Layout Page Management
Layout files are organized into separate pages numbered 0 through 1000. There are a variety of tools that let you navigate 
and organize the pages of a layout file.

IN THE PROJECT BROWSER

All pages in a layout file that are in use are listed in the Project Browser, including Page Templates and all pages with 
content and/or Page Information. See Project Browser on page 58.
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Typically, blank layout pages are not listed in the Project Browser; however, if a new page is inserted using the contextual 
menu in the Project Browser, that new, blank page will be listed.

The three types of pages can be distinguished by the icon to the left of their names: 

Page Template

Page with Content

Blank Page

The contextual menu for a layout page in the Project Browser allows you to view it, edit its Layout Page information, move 
it relative to other pages, or delete it. See Contextual Menus on page 19. 

Pages are listed in order of their page number. You can change a page’s number, and thus its location in the layout file, by 
clicking and dragging it in the Project Browser. See Project Browser on page 58. 

THE CURRENT PAGE

The current layout page is indicated at the center of the Layout Page Up/Down buttons. When a layout 
file is first created, the current page is page one.

The current layout page is the default target of any view sent to layout. If sent to the wrong page, a view may be moved 
from one page to another. To do this, select the view you want to move, then click the Open Object  edit button to open 

the Layout Box Specification dialog. You can change the page number on the LINE STYLE panel. See Layout Box 
Specification Dialog on page 1354.

To navigate between layout pages
 1.  Click the arrow buttons on either side of the Layout Page button.

 2.  Click the Current Page number between the arrows to open the Go To Layout Page dialog. Enter a page number 
and click OK.

 3.  Select Page Up or Page Down from the Tools> Layout> menu.

 4.  Press Shift + N (up one page) or Shift + M (down one page) on the keyboard.

 5.  Double-click on a page in the Project Browser. 

Note: Layout pages do not print if they are blank, even if a border and 
title block are present.

ADDING AND DELETING PAGES

To begin work on a new page, simply send a view to that page, or navigate to it and begin drawing.

To insert a layout page in front of or behind the current page, select Tools> Layout> Insert Page Before or 
Insert Page After. Any pages that follow the new page move up one, provided that nothing is located on page 

1000.
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You can also right-click on a page in the Project Browser and select either Insert Page Before or Insert Page After from 
the contextual menu. 

To create an identical copy of the current page with the same content and Page Information as the original, select Tools> 
Layout> Duplicate Page. A duplicate is added immediately after the original and is active. You can also right-click on a 
page in the Project Browser and select Duplicate from the contextual menu.  

To remove the current page from the layout file, select Tools> Layout> Delete Page. The current page and all 
information on it - including any views - will be completely removed. You can also right-click on a layout page in 

the Project Browser and select Delete Page. 

Page Templates assigned to other pages cannot be deleted, and neither can page zero. See Layout Page Zero on page 1363.

EXCHANGING PAGES

Select Tools> Layout> Exchange With Next Page to switch the current layout page with the following page. Not 
available on Layout Page 1000. 

Select Tools> Layout> Exchange With Previous Page to switch the current layout page with the page preceding it. 
Not available on Layout Page 0.

LAYOUT PAGE INFORMATION

The Edit Page Information tool lets you specify any layout page as a Page Template or add information about it 
which can then be included in layout and revision tables. See Layout Page Information on page 1363.

LAYOUT PAGE NUMBERING

Each layout page has a number from 0 through 1000 which is used to identify its position in the layout document.           

While this basic numbering convention cannot be changed, you can create your own page numbering convention using the 
Label setting in the Layout Page Information dialog. See Layout Page Information on page 1363.           

To do this, begin by typing a prefix of your choice followed by a pound (#) sign in the Label field - for example, “A-#”. 
The program will replace the # with a numeral 1 on the first page with that particular prefix in its Label, and will increase 
the number by one on every page that follows if it too has the identical prefix in its Label.           

Although you can specify a Label for your page Templates, regular pages do not inherit this information from their specified 
Template: it must be added to each page individually.           

Custom page numbering using the Layout Page Label can be added to any page - including Page Templates - by inserting 
the %layout.label% macro into a text object. See Text Macros on page 549.          

There is also a selection of additional text macros that can be used to insert dynamic page numbering information:           

Macro Result

%page%                         Layout Page Number - States the 
absolute page number of the 
current layout page.

%page.print% Printed Page Number - States the 
printed page number of the current 
page. Blank pages are not included 
in this count.
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Macro Result

%numpages% Number of Printed Pages - States 
the total number of printed pages 
in the layout. 

%lastpage% Last Used Layout Page - States the 
absolute page number of the last 
printed page.

LAYOUT PAGE TEMPLATES

Layout Page Templates allow you to create a title block and border in one place and then assign them for use on any other 
layout pages that you wish. Multiple Page Templates can be created in the same layout file. Note that if a layout page is 
specified as a Page Template, it will not print as part of a print range. Page Templates can be printed as the Current Sheet, 
however. See Print View Dialog on page 1385.           

Add anything to a Page Template that you want on some or all of your printed layout pages, such as:          

 l Title Block. See Text, Callouts, and Markers on page 501.             
 l Borders. See CAD Objects on page 294.             
 l Text Macros. See Text Macros on page 549.          
 l Imported images. See Images on page 1181.          

Note: The printable area varies from printer to printer. For best results, 
inset layout borders 1/2" to 3/4" from the paper edge. 

You can assign a Page Template to any layout page, or specify any page as a Page Template, in the Layout Page 
Information dialog. See Layout Page Information on page 1363.

LAYOUT PAGE ZERO

In Chief Architect X5 and prior, Layout Page Zero was the only available Page Template. In Version X14, it functions in 
much the same way by default: it is specified as a Page Template with the title “Default Page Template”, and it is assigned 
to all pages.           

Because of its special purpose, Layout Page Zero cannot be deleted.           

 

Layout Page Information
The Edit Page Information tool opens the Layout Page Information dialog, which you can use to add title, revision, 
and other information to the current layout page. This information can then be used to create layout and revision 

tables, as well as used in text macros. 

You can also use this tool to specify the current page as a Template, or to assign a Template to the current page. See Layout 
Page Templates on page 1363. 

The Layout Page Information dialog can be opened in several ways:          

 l Select Tools> Layout> Edit Page Information.          
 l Click the Edit Page Information toolbar button.          
 l Right-click on a layout page in the Project Browser and select Edit Page Information from the contextual menu.           
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LAYOUT PAGE INFORMATION DIALOG

 
Page Information

The Page Information options let you add information to layout pages that can be shown in a Layout Page Table or added 
to text using a macro. The Label and Title will also display in the Project Browser.         

 l Choose the Selected Page, which is the page selected for editing in this dialog, from the drop-down list. Not 
available when the dialog is opened via the Project Browser contextual menu.          

 l Specify the selected page’s Label. If a cross section/elevation view is sent to this layout page, this Label can display 
in the camera’s callout label in plan view. See Camera Labels and Callouts on page 1098.           

If you type a pound sign # in the Label field, it will be replaced 
by the current layout page number on the layout sheet. See 

Layout Page Numbering on page 1362.

 l Specify the selected page’s Title.          

 l Specify the selected page’s Description.          

 l Specify the selected page’s Comments.          

 l Check Include in Layout Table to include the above information about the selected page in a Layout Table. If Use 
as Page Template is checked, this box will be unchecked automatically.          
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Page Template Options

The Page Template Options let you associate the selected layout page with a template, or specify it as a template. See 
Layout Page Templates on page 1363.         

 l Check Use as Page Template to specify the selected page as a template that can be assigned to other pages, but not 
printed. This box cannot be unchecked if the current page is the Page Template assigned to other pages.           

 l Assign a Page Template to the selected page by choosing one from the drop-down list. Not available when Use as 
Page Template is checked.          

 
Page Revisions

The Page Revisions settings let you manage the revisions associated with the selected page. Revisions can be shown in a 
Revision Table or added to text using a macro. See Revision Tables on page 1366.         

 l A table listing any revisions associated with the selected page displays for reference. Click on a line item in the table 
to select it.           

 l Click the New button to open the Layout Revision Specification dialog and add a new revision to the selected page.           

 l Click the Edit button to open the Layout Revision Specification dialog and edit the selected revision.          

 l Click the Delete button to remove the selected revision from the table.          

 l Click the Move Up or Move Down button to adjust the position of the selected revision in the table accordingly.          

REVISION SPECIFICATION DIALOG

Select Tools> Layout> Add Layout Revision to open the Revision Specification dialog. You can also click the New 
or Edit button in the Layout Page Information dialog to open this dialog.         

 
Revised Pages

Specify which pages the selected revision applies to. Only available when a new revision is being created.         

1365



Chief Architect Premier X14 Reference Manual - Layout Page and Revision Tables

  Revision Information

 l Specify the revision’s Label.          

 l Specify the Date that the revision was made. The program populates this field with the current date automatically.          

 l Specify who the revision was Revised By. The program populates this field with your Designer Information by 
default. See Designer Information on page 60.           

 l Specify a Description of the revision.          

 l Check Include in Revision Table to include this revision in a Layout Table for the selected page.          

 

Layout Page and Revision Tables
Title, revision, and other information can be added to each layout page and used to create tables of contents and revision 
schedules. 

Layout Tables are similar to schedules and can be edited much the same way that schedules can. See Editing Schedules on 
page 698. 

LAYOUT PAGE TABLES

Select Tools> Layout> Layout Page Table, then click on a layout page to place a Layout Page Table that that 
location. Layout Page Tables list all pages in the current file that have Layout Page Information specified, are set to 

be included in Layout Page Tables, and have data on them. See Layout Page Information on page 1363.

If you place a Layout Page Table on a Page Template, it will display on every page in the current layout that uses that 
template and will list all pages that have data and are set to be included in Layout Page Tables.

REVISION TABLES

Select Tools> Layout> Layout Revision Table, then click on a layout page to place a Layout Revision Table at that 
location. Layout Revision Tables list all revisions associated with the current page.

Unlike Layout Page Tables, Layout Revision Tables are page-specific. If you place a Layout Revision Table on a Page 
Template, it will display on every page that uses that template, but it will only list revisions associated with the current 
page. See Layout Page Templates on page 1363.

 

Printing Layout Files
Printing layout files is similar to printing a view in a plan file. Select File> Print> Print to open the Print dialog. See 
Print View Dialog on page 1385. 

As in plan views, printing options for layouts are set in the Drawing Sheet Setup dialog. These options apply to all pages of 
the layout file. See Drawing Sheet Setup Dialog on page 1372.

If a page does not have any data on it, it will not print. Only pages with one or more views sent to them or Text, CAD, or 
Dimensions drawn on them are printed.           

Pages specified as Page Templates do not print unless the template is the current page and you specifically choose the 
Current Page Print Range option. See Print View Dialog on page 1385. 
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Physically-Based Ray Trace renderings sent as live views to layout are printed after 20 samples at 96 dpi. If a layout file has 
one or more live Physically Based Ray Trace views sent to it, additional time to print may be required. See Physically Based 
(Ray Trace) on page 1148.         

PRINTING TO SCALE

A layout file’s drawing scale is specified in the Drawing Sheet Setup dialog. While you can specify any drawing scale that 
you wish, in nearly all circumstances, you will want the scale to be 1 in = 1 in or 1 mm = 1 mm for all layout files. 

The views sent to your layout pages have already been assigned a scale, and if you select a scale other than one-to-one for 
the layout, these views will be scaled a second time when printed. 

Layout views will print at their specified scales only when the 
drawing scale for the layout file is 1 in = 1 in or 1 mm = 1 mm.

To see or change the current scale of a layout view, select the view and click the Rescale Layout View  edit button. See 

Rescaling Views on page 1351.          

When a view is sent to layout at a scale other than that used by the original view, line weights may be affected. See Line 
Weights and Scaling on page 1380.

PRINTING SERVICES

If you plan to use a printing service, you may want to install a PDF writer. See Printing to a PDF File on page 1379. 

You can also print to file using the driver for the printer that the service will use. See Printing to File on page 1370.

Find out what paper size the print service uses and select it in the Drawing Sheet Setup dialog. See Drawing Sheet Setup 
Dialog on page 1372.

CHECK PLOTS

When a large drawing sheet size has been specified, you can print a check plot at a reduced scale so that it can be printed on 
a smaller printer. This allows you to make final checks before printing to the larger size. See Check Plots on page 1378.

 

Exporting Layout Files
Layout pages can be exported to .dxf/.dwg files much like any other vector-based view. 

The main difference is in the scale of the output, which is in scaled paper units rather than model units. If a 50” line in a 
plan would be scaled to 1” inch when printed, it is exported as a 1” line instead of its length before prior to scaling. See 
Exporting 2D DXF/DWG Files on page 1234.
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Chapter 42
 

Printing and Plotting

Chief Architect provides a variety of options for printing scaled plan views, cross section/elevation views, and 3D 
perspectives.

To create working drawings, you can use the program’s Layout facility. Multiple views of the model can be arranged on 
pages along with a border and title block. For more information, see Layout on page 1338.          

Chief Architect also allows you to save your drawings in .pdf file format that can then be sent to a printing service.

Note: Screen captures are provided for illustrative purposes only and are 
not an endorsement of any products.

TOPICS

Introduction to Printing 1369
Printers and Plotters 1369
Printing Defaults 1370
The Printing Tools 1371
Drawing Sheet Setup Dialog 1372
Print Preview 1376
Printing to Scale 1377
Printing Across Multiple Pages 1379
Printing to a PDF File 1379
Line Weights 1379
Watermarks 1382
Print View Dialog 1385
Print Image Dialog 1388
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Introduction to Printing
Chief Architect Premier offers printing options to suit a variety of needs. It is helpful to be familiar with these options and 
choose the one that makes the most sense for the project at hand.         

Note: Student, Academic, and Presentation versions of the software 
produce a non-editable watermark on all printed documents.

OUTPUT OPTIONS

Printing From Layout - For professional quality documents with a title block, border, and multiple views of the model, 
printing from layout provides the best results. For more information, see Layout on page 1338.         

Printing Directly From a View - You may prefer to print individual drawings directly from a view. See Print Tools on 
page 1372.          

Printing to PDF - Plans can be printed to a .pdf file and printed remotely. See Printing to a PDF File on page 1379.         

Export to STL - Exports an .stl file that can be printed on a stereolithography machine, or 3D printer. See STL Format on 
page 1244.         

TERMINOLOGY

Drawing Sheet Size - The dimensions of the final printed output. This may or may not be the same as the printer paper size. 
If the sheet and paper sizes are the same, only one page is required per sheet. See Drawing Sheet Setup Dialog on page 
1372.         

Paper Size - The dimensions of the paper to be printed on. Specifying a paper size that is smaller than the              Sheet Size allows 
large drawings to be printed across multiple pages.         

Check Plot - A test printing, typically at a smaller scale, made before final output to large paper format. For more 
information, see Check Plots on page 1378.         

Line Weight - The thickness of a line. A thicker line weight is easier to see, but may not show as much detail. See Line 
Weights on page 1379.          

Drawing Scale - You can specify this scale in the Drawing Sheet Setup dialog. See Drawing Sheet Setup Dialog on page 
1372.          

When a particular scale is not important, drawings can also be sized to fill a particular area. See Printing to Scale on page 
1377.         

Always familiarize yourself with your printer or plotter before a 
deadline is near, and bear in mind that it can take a little time to 

configure a new printer.

 

Printers and Plotters
There are many different types of printers and plotters. In general, a printer is smaller, normally outputting 8½ x 11" (Letter 
or ANSI A size), 8½ x 14" (Legal Size) or sometimes as large as 11 x 17" (Tabloid or ANSI B size).

Plotters are typically used to output larger sheets of paper such as 17 x 22" (ANSI C), or 18” x 24” (ARCH C).
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PRINTER DRIVERS

A printer driver is a program that allows a printer to communicate with the rest of the computer system. Drivers are usually 
created by the printer manufacturer, are typically updated regularly, and can usually be downloaded free of charge from the 
manufacturer’s website.          

In addition to interpreting between the printer and the rest of the system, printer drivers save default page size, orientation, 
margin size, and other information that Chief Architect refers to unless you specify otherwise. See Print View Settings on 
page 1371.         

If you experience printing problems, consider installing updated drivers for your printer. Visit your printer manufacturer’s 
website for more information.         

Options available with one driver may not be available with 
another. Printers and plotters supported in one operating system 

may not be supported by the manufacturer in another.

PRINTING TO FILE

If your print service requires you to print to a file that can be read by their plotter, you can install that printer’s drivers on 
your system and then use the Windows System Print dialog to Print to File. See Print View Dialog on page 1385.           

Printing to a file is not an option in the Mac System Print dialog.           

CLEARING PRINTER INFORMATION

Some information specific to individual printers, such as available paper sizes, is saved with each plan file. You can select 
File> Print> Clear Printer Info to clear the printer-specific information stored with the plan file.

 

Printing Defaults
You can print to any printer or plotter that is supported on your operating system and can specify the current printer at any 
time in either the Drawing Sheet Setup or Print View dialog.            

DRAWING SHEET SETUP

When any orthographic view is active, you can specify its Drawing Sheet size, margins, orientation, printed Drawing 
Scale, and more in the Drawing Sheet Setup dialog. Select File> Print> Drawing Sheet Setup to open this dialog. 

See Drawing Sheet Setup Dialog on page 1372.         

The settings in the Drawing Sheet Setup dialog are view-specific. This means that in a plan file, they can be set up one way 
for plan views and a different way for each cross section/elevation view and CAD Detail. When a new view is created, its 
initial settings are derived from the current plan view settings.

The Drawing Scale set in the Drawing Sheet Setup dialog acts as the default scale for the active view’s Print, Printed Size 
Input, and Send to Layout dialogs. See Send To Layout Dialog on page 1344.           

The settings in the Drawing Sheet Setup dialog can be customized and saved in your template plans and layout files. See 
Template Files on page 87.           
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PRINT VIEW SETTINGS

When you are ready to print an orthographic view, select File> Print> Print. The initial settings in the Print View 
dialog are drawn from the Drawing Sheet Setup for the view. The system’s default printer is selected and if possible, 

the paper size and orientation are set to match those of the Drawing Sheet.          

Once a view has been printed, most of the settings in the Print View dialog are saved and will be applied to all views of the 
same type, in all Chief Architect Premier files. View types with separate Print View settings are:           

 l Plan view          
 l Cross Section/Elevation views          
 l Layout          
 l Materials Lists          
 l CAD Details          
 l Time Tracker Logs          

If you prefer that the Print View settings not be retained in this manner, uncheck Remember Print Settings after Printing 
in the Drawing Sheet Setup dialog.          

DISPLAYING OBJECTS

You can control the display of objects when printing directly from a view in the Layer Display Options dialog. See 
Layer Display Options Dialog on page 183.

Objects must be visible in order for them to print; however, not all items that are visible will print. See Print Preview on 
page 1376.         

To control the display of objects in an orthogonal view sent to layout, select the view, click the Layout Box Layers  edit 

button, and make any needed changes in the Layer Display Options dialog. See Layout View Layer Sets on page 1349.          

To control the display of objects in a camera view sent to layout, turn layers on/off  in the view before it is sent to layout. 
You may find it helpful to create a custom layer set for printing directly from a view. See Layer Sets on page 186.

PRINT PREVIEW

To get a sense of whether your current settings will meet your needs when printed, you can use the Print Preview 
toggle to view the printed output on screen before any paper is used. See Print Preview on page 1376.         

 

The Printing Tools
Select File> Print to view the Print Tools submenu. These tools fall into four categories. 

PRINT SETUP TOOLS

Drawing Sheet Setup - Opens the Drawing Sheet Setup dialog. See Drawing Sheet Setup Dialog on page 1372.

Scale to Fit - Automatically selects a scale that fits your plan to the drawing sheet. See Printing to Scale on page 
1377.

Center Sheet - Automatically centers the drawing sheet on your drawing. See Center Sheet on page 1377.
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Print Preview - Shows on screen how the current view will appear printed, based on the current scale and other 
settings. See Print Preview on page 1376.

PRINT TOOLS

Print - Prints the current plan view, Vector View, CAD Detail, or layout sheet to a specified scale. See Print View 
Dialog on page 1385.

Print Image - Prints the current view including images, textures, and backdrop. Views printed with Print Image are 
not scaled. See Print Image Dialog on page 1388.

You can also select File> Export> Export PDF to open the Export PDF dialog. See Print View Dialog on page 
1385.

DISPLAY TOGGLES

A number of toggles allow you to turn various aspects of the display on or off. See Interface Toggles on page 14.           

Color  - Turn the on-screen display of color on or off in all views except perspective views. See Color on page 1376.         

Line Weights - When this is on, line weights appear on screen as they will print. See Line Weights on page 1376.         

Drawing Sheet - Turn this on for a preview of your plan relative to the current Drawing Sheet. See Drawing Sheet 
on page 1377.         

Reference Grid - The Reference Grid does not print, so you can turn this off to get a better sense of what the view 
will look like printed. See Reference Grid on page 1376.         

ADDITIONAL PRINT TOOLS

Customize Sheet Sizes - Allows you to create custom sheet sizes. See Customize Sheet Sizes Dialog on page 1375.          

Clear Printer Info - Some information specific to individual printers, such as available paper sizes, is saved with each file. 
This clears the printer-specific information associated with the current page setup. 

 

Drawing Sheet Setup Dialog
The settings in the Drawing Sheet Setup dialog control the sheet size and scaling for the current view. Select File> 
Print> Drawing Sheet Setup to open this dialog.         

The Drawing Sheet Setup dialog is only available when a plan view, cross section/elevation view,               CAD Detail, or layout is 
active. When a perspective view is active, Drawing Sheet Setup is not available.

The settings in this dialog are specific to the current view and are saved with the .plan              or .layout file.              See Printing Defaults 
on page 1370.
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Drawing Sheet

Specify the Orientation and Size of the Drawing Sheet, which is the final printed output.         

 l Click the Customize button to open the Customize Sheet Sizes dialog. See Customize Sheet Sizes Dialog on page 
1375.          

Paper can often be inserted into plotters in either of two 
orientations. Refer to your plotter’s documentation to find out 

which way to insert the paper for correct results.

 l Check Show Drawing Sheet in View to turn on the display of the Drawing Sheet in orthographic views. See 
Drawing Sheet on page 1377.

 
Drawing Scale

Specify the Drawing Scale for the active view. This scale is applied only when the view is printed.         
The scale is specified in two parts, which by default are              1 ft = 1 ft or 1 m = 1 m for layout views, and ¼ inch = 1 ft or 1 
m = 50 m for all other views. Both U.S. and metric units of measurement are available and can be selected independently.
The units of measurement available here can be controlled in the Preferences dialog. See Unit Conversions Panel on page 
113.          
The Drawing Scale acts as the default scale for the active view’s Print, Print Size Calculator, and Send to Layout dialogs.           
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Printer for View

                 Specify the Printer for View which is the printer for the active view in the current file. These settings are global, affecting 
all plan and layout files.                 

 l Uncheck Remember Print Settings after Printing to enable the Choose button, below. When this is checked, the 
printer is selected in the Print View dialog. See Printing Defaults on page 1370.         

 l Click the Choose button to select a printer and edit its paper settings in the Default Printer for View dialog.         

The name of a Printer displays to the left of the Choose button for reference.

 l If the Remember box is checked, the last printer used in the current view type is shown; if no printer has been used 
in the current view, “None” will display.         

 l If the Remember box is unchecked, the system’s default printer will be shown.         

If you have questions about your printer’s settings, consult its documentation.

 
Drawing Margins

Specify the Drawing Margins which define the extents of the printable area of the active view’s Drawing Sheet.         

 l Click the Populate from Printer button to set the margins based on the selected printer’s default settings. See 
Printers and Plotters on page 1369.          

 l Specify the width of the Top, Bottom, Left, and Right margins.         

 
Advanced Line Weights

The Advanced Line Weight Options allow you to specify the active view’s line weight scale. A layout file’s line weight 
scale should always be the same as that of any plan views associated with it. See Line Weights and Scaling on page 1380.         

 l Check Use 1 for all line weights (Home Designer compatibility) to have the program maintain a consistent line 
thickness and dash size when the drawing scale is changed. When checked, the Line Weight Scale is based on a 1/4 
inch = 1 foot drawing scale and 1= 1/300 inch line weight scale.               Plans originally created in any of the Home 
Designer programs have this checked by default; however, this option is not available for layouts and is not normally 
recommended. See Line Weights on page 1379. 

 l Select the Line Weight Scale. See Line Weights and Scaling on page 1380. This setting should always be the same 
for both a given layout file and any plan views associated with it.          

 
Preview of Line Weight

A line weight Preview illustrates how changes to the line weight scale affect the printed size of various line weights at the 
current Drawing Scale.         

DEFAULT PRINTER FOR VIEW DIALOG

To open the Default Printer for View dialog, click the Choose button in the Drawing Sheet Setup dialog.          
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 l Select a Printer from the drop-down list.          
 l Choose the Orientation of the paper used by the selected printer.          
 l Select a Paper Size from the drop-down list. The options available will depend on the selected printer.          
 l Select a Paper Source from the drop-down list. The options available will depend on the selected printer.          

CUSTOMIZE SHEET SIZES DIALOG

To open the Customize Sheet Sizes dialog, select File> Print> Customize Sheet Sizes, or click the Customize button in the 
Drawing Sheet Setup dialog.           

Several options are available:          

 l Click New to create a new sheet size.          
 l Select a sheet size and click Copy to create a duplicate sheet size.          
 l Click Delete to remove the selected sheet size.          
 l Select a sheet size and click Edit to open the Edit Paper Size dialog and change its description, dimensions, and units 

of measurement.         

 l Click OK to close the dialog. Any new sheet sizes created are now available in the Drawing Sheet Setup dialog.          
 l The data for this dialog is stored in the “sheetSizes.sheet” file in the program’s Data folder.           
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CLEARING PRINTER INFORMATION

Select File> Print> Clear Printer Info to clear the printer-specific information stored in the Drawing Sheet Setup dialog. 
See Printers and Plotters on page 1369.

This is useful for creating plan and layout templates without an associated printer. See Template Files on page 87.          

 

Print Preview
Print Preview and its related display toggles allow you to get a sense of what the current view will look like when it is 
printed.

PRINT PREVIEW

Select File> Print> Print Preview for an on-screen representation of how the current view will appear when printed. 
Print Preview is only available in views that can be scaled. See Printing to Scale on page 1377.

When Print Preview is on, the Drawing Sheet and line weights are displayed, and the Drawing Sheet  and Line 

Weights  toggles are overridden.         

Objects such as camera symbols, CAD points, text and dimension objects appear on-screen as they will on the printed page.

When Print Preview  is enabled, color will display depending on whether Print in Color is selected in the Print View 

dialog. See Print View Dialog on page 1385. 

The Reference Display does print if it is visible. See The Reference Display on page 69.         

COLOR

The Color toggle turns the on-screen display of color on or off in all views. When Color is toggled off, views print in 
either black and white or grayscale depending on your Preferences setting. See Colors Panel on page 102.

REFERENCE GRID

The Reference Grid is an on-screen grid composed of regular squares that can be used to convey a sense of scale 
while drawing.  It does not print, and its size can be specified in the General Plan Defaults dialog. See General Plan 

Defaults Dialog on page 96.         

LINE WEIGHTS

Select View> Line Weights for an on-screen representation of line weights and line styles.  Turning Line Weights on 
or off does not affect the final printed output.         

 l When Line Weights is turned on, you can Zoom In  to see the location of lines and dashed lines as they will 

appear on the printed page.           
 l When Line Weights is off, dashed lines look the same, regardless of the zoom factor.           

Line Weights can also be turned on or off in the Preferences dialog. See Appearance Panel on page 99.          
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DRAWING SHEET

The Drawing Sheet is a representation of the size and orientation of the final printed output. It is different from the 
printed page size, which means that you can print a large Sheet to multiple smaller pages. Select View> Drawing 

Sheet to show the Drawing Sheet on screen.

The Drawing Sheet size and orientation are specified in the Drawing Sheet Setup dialog. See Drawing Sheet Setup Dialog 
on page 1372.         

When the Drawing Sheet is set to display, a blue border representing the margins of the printable area will also display for 
reference. If the margins have been set to populate from the selected printer, this border may not display on all edges of the 
drawing sheet. See Printer Drivers on page 1370.

When Drawing Sheet  is on, the drawing sheet behaves as an object.           

 l When selected at its border the sheet has edit handles, allowing it to be moved. See Editing Objects on page 207.          
 l You can also resize the sheet using its edit handles; however, for best results, it is recommended that you instead select 

an available sheet size in the Drawing Sheet Setup dialog. See Drawing Sheet Setup Dialog on page 1372.          
 l Dimension lines can locate the edges of the sheet and can be used to position other objects relative to it. See Moving 

Objects Using Dimensions on page 491.          

Note: Specifying a sheet size in the Drawing Sheet Setup dialog 
is preferable to editing the sheet size on-screen.

The drawing sheet cannot be rotated or copied.           

CENTER SHEET

Select File> Print> Center Sheet to center the drawing sheet on the drawing. This moves the              sheet relative to the 
drawing but does not affect the coordinates of objects in the drawing. The location of the drawing sheet is 

independent for each floor of the model.         

 

Printing to Scale
Several different print scaling options are available. The type of view that you are printing determines which options you 
may choose from.

ORTHOGONAL VIEWS

Plan views, Orthographic 3D  views, CAD Details, and layout pages are orthogonal views, which means:         

 l Your line of sight is at a right angle to all objects in the view.             
 l Objects do not appear to decrease in size as their distances from the viewer increase.             

Orthogonal views can be printed to scale; however, Orthographic 3D views can only be printed to scale when the Vector 
View Rendering Technique is used.         

The scale set in the Page Setup dialog is inherited by the Print and Send to Layout dialogs. This scale can be overridden on 
an individual basis in either of these dialogs. See Print View Dialog on page 1385 and Sending Views to Layout on page 
1343.         

Select File> Print> Scale to Fit  in an orthogonal view to select a suitable scale and re-center the drawing sheet so that 

everything fits on the sheet.         

1377



Chief Architect Premier X14 Reference Manual - Printing to Scale

U.S. Unit drawing scales are typically noted in inches per foot. Larger scales, such as 1 inch = 50 feet or 1:200m, are often 
used for property layouts.         

Once a view has been sent to layout, there are a variety of additional scaling options. See Rescaling Views on page 1351.          

PERSPECTIVE VIEWS

Camera views and Perspective overviews display the model much the way the eye would see it and cannot be scaled.         

 l Objects in the view may be at any angle relative to your line of sight.              
 l Objects seem to decrease in size as their distances from the viewer increase.             

Perspective views can only be printed using the Print Image  tool. See Print Image Dialog on page 1388.         

While perspective views cannot be scaled, you can control the printed size of the view. If Fit to Paper is selected in the 
Print View dialog, a percent value can be set that defines how much of the printed page to fill. See Print View Dialog on 
page 1385. 50% causes the print to be 50% of both the height and width of the paper, including the non-printable border.           

For example, if printing to an 8½ x 11 page with a 1" non-printable border in each direction:           

 l 100% would print an area 8½ x 11. This is not recommended, as part of the output could fall outside the printable 
area.          

 l 50% would print an area 4¼ x 5½.           
 l Each printer may vary slightly.          

CHECK PLOTS

A check plot is a test print that allows you to print at a reduced scale on smaller, less expensive paper so you can check that 
the drawing will print as expected. The drawing scale is temporarily adjusted to a specified fraction of its true value. Both 
drawing scale and line weights are subject to this scale adjustment.           

For example, if a layout has a border designed to fit on a Drawing Sheet of 24” x 36”, a check plot at 1/2 scale would allow 
it to fit on a 12” x 18’ page. A view sent to that layout at a Drawing Scale of 1/4” = 1’ would be scaled at 1/8” = 1’ when 
printed at 1/2 scale.           

To create a check plot
 1.  Select File> Print> Print View . In the Print View dialog:           

 l Click the Check Plot at radio button, then choose the desired scale fraction from the drop-down list.           

 l The Paper Size will automatically adjust to fit the selected Check Plot Scale.           

 l Confirm that the Paper Size is the size you wish to use, then click Print.          

 2.  The next time you print a view, remember to choose To Scale or Fit to Paper again in the Print View dialog.           

PRINTING TEXT, DIMENSIONS, AND LINE STYLES

As with other objects your drawings, text and dimension numbers are subject to scaling when views are sent to layout or 
printed. See Scaling Text on page 521.          

Printed text size is also influenced by the selected font and the method used to specify its size. See Character Size on page 
504.          

Text may not print exactly as it appears on-screen. To get a better idea of how text and dimension characters will print, you 
may find it helpful to Zoom In  on them.           
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For best printed results, using true-type or open-type fonts is recommended.           

Text may not appear accurately on screen when the font used by 
the printer is different from the font used on screen. Consult 

your printer documentation for more information on font substitution.

The line styles assigned to CAD and a variety of other objects are subject to scaling when printed as well. They are only 
subject to scaling when sent to layout, however, under specific circumstances. See Line Weights and Scaling on page 1380.           

 

Printing Across Multiple Pages
When printing directly from a plan view, cross section/elevation view, or layout it is possible to print at a scale that does not 
fit the drawing on one page.

When printing to a paper size that is smaller than the sheet size, a 2% overlap is used. Crop marks print where the paper 
needs to be cut between pages. A solid line is drawn at the drawing sheet boundary on the sides that need to be cut.          

To see on-screen what the drawing will look like when printed, select View> Drawing Sheet   and then Window> Fill 

Window . Grey lines across the drawing sheet  indicate where the page breaks will occur. See Drawing Sheet on page 

1377.

 

Printing to a PDF File
Portable Document Format, or .pdf files, are  one of the most universally compatible and efficient file formats and can be 
viewed and printed on most computer platforms. 

You can save any view as a 2D .pdf file by selecting “Chief Architect Save as PDF” or any other PDF writer installed on 
your system as the Destination printer Name in either the Print View or Print Image dialog. See Print View Dialog on page 
1385 and Print Image Dialog on page 1388. 

You can also print to .pdf from any view by selecting File> Export> Export PDF . See PDF Files on page 1194.

When you print to .pdf, you will be asked to create a file name and choose a destination to save it in the Save as PDF File 
dialog. See Exporting Files on page 41.

You can also import .pdf file into Chief Architect. See Importing PDF Files on page 1194.         

 

Line Weights
The weight of a line refers to its thickness on the printed page and is described in absolute terms as a fraction of a unit, 
often 1/100th of a millimeter or 1/1000 of an inch. In Chief Architect, line weights are assigned to objects, patterns, and 
layers using whole numbers that correspond to the numerator of this fraction.          

You can specify the Line Weight Scale by defining the denominator and the unit used in this fraction in the Drawing Sheet 
Setup dialog. See Drawing Sheet Setup Dialog on page 1372.           

It is extremely important that every view sent to layout and the 
layout file share the same Line Weight Scale. When they do not, 

unwanted printed output will result.
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Your preferred line weights and line weight scale can be saved in your template plan and layout files. See Template Files on 
page 87.           

The method for specifying an object’s line weight depends on the object and the type of view.          

 l Most objects’ line weights can be set by layer. See Layer Display Options Dialog on page 183.          
 l Some objects’ line weights can be set in their specification dialogs. See Line Style Panel on page 310.          
 l The line weights for walls in plan view are defined by wall type in the Wall Type Definitions dialog. See Wall Type 

Definitions Dialog on page 390.          
 l The line weights of material pattern lines, which are visible in Vector Views, can be set in the Define Material dialog. 

See Define Material Dialog on page 1066.           
 l The line weight for fill patterns is set for individual objects in their specification dialogs. See Fill Styles on page 197.          
 l The line weight applied to surface edges in Vector Views can be set in the Print dialog. See Print View Dialog on page 

1385.         
 l The end cap length of dashed lines in plan view is set in the Preferences dialog.  See CAD Panel on page 117.          
 l An assigned line weight of 0 draws a line weight of 1 pixel, the thinnest line weight a printer allows. How thick this is 

varies from printer to printer. See Printers and Plotters on page 1369.           

LINE WEIGHTS AND SCALING

Line weights and line styles are subject to scaling when printed. You can see an on-screen approximation of what lines will 
look like when a view is printed by toggling on either Line Weights  or Print Preview . See Print Preview on page 

1376.          

When a view is sent to layout, line weights and styles may be further affected by the drawing scale selected for the layout 
view. This occurs when the layout view’s scale is different from the Drawing Scale of the original view.           

For example, assume that you have an object in a view with a line weight of 20, and that the view’s Drawing Scale is 1 mm 
= 50 mm.           

 l If you send the view to layout at 1 mm = 25 mm scale, twice the original scale, the resulting printed line weight for 
this object will increase to 40 instead of 20.           

 l If you send the view to layout at 1 mm = 100 mm scale, half the original scale, the resulting printed line weight for 
this object will decrease to 10 instead of 20.           

Line weight scaling affects both line weights and line styles and can be particularly noticeable with dashed line styles.               See 
Line Style Specification Dialog on page 202.

For example, assume that you have an object in a view with a dashed line style that has 10 mm dashes and 10 mm spaces, 
and that the view’s Drawing Scale is 1 mm = 50 mm.           

 l If you send the view to layout at 1 mm = 25 mm scale, twice the original scale, the resulting dashes and spaces will 
increase to 20 mm instead of 10 mm.          

 l If you send the view to layout at 1 mm = 100 mm scale, half the original scale, the resulting dashes and spaces will 
decrease to 5 mm instead of 10 mm.          

You can specify the drawing scale for any orthogonal view by opening the Drawing Sheet Setup dialog while in that view. 
See Printing to Scale on page 1377.           

For any layout view, you can specify whether the original line weight is maintained or not in the Send to Layout  and 
Change Scale dialogs. See Send To Layout Dialog on page 1344 and Rescaling Views on page 1351.         

Note that in order to produce exact line weights, a Vector View must be sent to layout using the Plot Lines option. See Plot 
Line Views on page 1348.          
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Note: Under most circumstances, you should select Use Layout Line 
Scaling when sending views to layout.

In the following image, the same plan view has been sent to layout twice, at two different scales. The view on the left was 
sent at the same scale as the original view, 
1/8” = 1’.  The view on the right was sent at 1” = 1’, or magnified eight times, to show an area of the plan in greater detail.           

Because the view on the right was sent to layout at a scale other than that of the original, it is subject to layout line scaling.           

The solid lines representing walls, cabinets and doors are rescaled to be eight times thicker than in the original view.          

Similarly, the dashed lines representing the door jambs are rescaled so that the dashes and the spaces between them are eight 
times larger than in the original view.           

If Use Layout Line Scaling is enabled, line weights are no longer scaled and the dashed lines display at the same size as in 
the original view.           
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Because the view in this example is scaled eight times larger in this case, the dashes and line weights look relatively small 
and fine when Use Layout Line Scaling is enabled. Were the view rescaled to be smaller instead, the line weights would 
look relatively large and thick.          

PRINTERS AND LINE WEIGHT

Line weight and print scaling are subject to the limitations of the printer being used. For example, you will not be able to 
see the difference between a line that is 1/150th of an inch wide and one that is 1/300th of an inch wide when they are 
printed using a printer that prints 150 dots per inch (DPI).           

That is, a CAD line with a line weight of 1 will look the same as a CAD line with a line weight of 4 when the Line Weight 
Scale is set at 1 = 1/600th of an inch and you print to a printer capable of 150 DPI.           

Setting an object’s or group of objects’ line weight to zero causes the lines to print as thinly as possible.          

The default Line Weight Scale of 1 = 1/100 mm makes it easy to 
meet many professional drawing standards and in most cases 

should not be changed.

 

Watermarks
A customizable watermark containing text or the image of your choice can be added to any plan view or layout. To 
toggle the watermark on or off in the current view, select View> Watermark.         

In layout files, the watermark will display on all pages when it is toggled on. In plan files, on the other hand, the Watermark 
toggle can be set on a view by view basis and can be saved in the Plan View Specification dialog, CAD Detail 
Specification, Camera Specification and Cross Section/Elevation Specification dialogs. See View Specification Dialogs on 
page 150.

Watermarks also are file specific, so you can have a different watermark in each plan and layout file if you wish.               If you 
want to use a particular watermark in all files, you can add it to your plan and layout templates. See Template Files on page 
87.

The method for printing a view with a watermark varies depending on the view type:          

 l For most types of views, check Show Watermark in the Print View dialog. See Print View Dialog on page 1385.           
 l For perspective cameras and overviews, toggle the watermark on before printing. See Saving and Printing 3D Views 

on page 1114.           
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Note: Student, Academic, and Presentation versions of the software 
produce a non-editable watermark on all printed documents. A second 
one can be added if you wish. 

WATERMARK DEFAULTS DIALOG

A watermark can be customized in the Watermark Defaults dialog. To open this dialog, select Edit> Default Settings and 
in the Default Settings dialog, click on “Watermark” and click the Edit button.          

You can also open this dialog by clicking the Define button in the Print View dialog. See Print View Dialog on page 1385.          

When the Watermark Defaults dialog is open, the watermark will display in the view window behind the dialog and will 
update as changes are made to its settings.          

 
Watermark Type

Select a Watermark Type from the drop-down list.          
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Text

The Text settings are available when “Text” is the Watermark Type selected above.         

 l Type the desired watermark Text in the text field.          

 l Click the Color bar to select a color for the watermark text. See Color Chooser/Select Color Dialog on page 204.          

 l Specify the Print Size of the watermark text, as measured from the baseline to top of the capital letter A in the 
selected Font.           

 l Select a Font from the drop-down list.          

 
Image

The Image settings are available when “Image” is the Watermark Type selected above.         

 l When an image File has been specified, its pathname displays here. You can type a different pathname if you wish.          

 l Click the Browse button to open the Watermark Image File dialog, which is a typical Open dialog. See Importing 
Files on page 45.           

 l Specify the Ratio to Sheet, which is how far the image extends across the sheet. Not available when “Fit to Sheet” 
Layout is selected, below.          

  General

 l Specify the Layout of the watermark from the drop-down list.          

 l Specify the watermark’s Angle, measured relative to a horizontal line pointing towards the right-hand side of the 
screen.           

 l Use the Transparency slider bar or text field to control how transparent the watermark is.           

 l The Marks Per settings are only available when “Tile” or “Border” is selected as the Layout, above.          

 l Specify the Marks Per Row, which is the number of instances of the watermark across the width of the Drawing 
Sheet.          

 l Specify the Marks Per Column, which is the number of instances of the watermark from top to bottom of the 
Drawing Sheet.          

 
Margins

Specify the watermark Margins, measured in from the edges of the Drawing Sheet.         

 l Check Use Drawing Sheet Margin to use the same margins for the watermark that are specified for the Drawing 
Sheet or uncheck this box to enable the settings that follow. See Drawing Sheet Setup Dialog on page 1372.           

 l Specify the width of the Top, Bottom, Left, and Right watermark margins.          

 l Check Update Automatically to have the watermark update in the current view as changes are made in the dialog.           

 l Click the Update button to update the watermark in the view behind the dialog. Not available if Update 
Automatically is checked above. 
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  Preview

 l Check Update Automatically to have the watermark update in the current view as changes are made in the dialog.

 l Click the Update button to update the watermark in the view behind the dialog. Not available if Update 
Automatically is checked above.             

 

Print View Dialog
To print from plan views, 3D Vector Views, layout, CAD Details, Time Tracker Logs, or the Materials  List, select 
File> Print> Print. The Print View, Print Layout, Print Time Tracker Log, or Print Materials List dialog opens. The 

settings that are available will vary depending on which version of the dialog is open. 

Select File> Export> Export PDF to open the similar Export PDF dialog.

Note: 3D views that are not Vector Views can be printed using Print 
Image. See Print Image Dialog on page 1388.

If Remember Print Settings after Printing is checked in the Drawing Sheet Setup dialog, most settings in this dialog will 
be saved and applied globally to all views of the same type in all Chief Architect files. There are three exceptions: Sheets 
and Copies are always reset, and the Print Source is determined by whether or not the Drawing Sheet  is toggled on 

See Print View Settings on page 1371.           
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  Destination

 l Select the Name of the printer you would like to use from the drop-down list. To print to .pdf, select “Chief 
Architect Save as PDF” from the list, or choose a .pdf writer installed on your system. See Printing to a PDF File 
on page 1379.

 l Select the DPI, or Dots Per Inch to use when printing, from the drop-down list. The available options may vary 
depending on the selected printer.

 
Paper

Select the Paper Orientation, Size, and Source. The available Size and Source options are controlled by the selected 
printer’s driver. See Printer Drivers on page 1370.

 l When possible, the program will automatically set the Size and Orientation to match those of the Drawing Sheet. See 
Drawing Sheet Setup Dialog on page 1372.

 l The Paper Size may be automatically adjusted if the Drawing Scale option is changed, below.
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Print Range

In layout files only, specify the range of pages to print. Only pages that have views or objects drawn directly on them                  and 
are not specified as Page Templates will print. Page Templates and empty pages do not print. See Layout Page Templates on 
page 1363.

 l Select All to print the entire drawing.                     

 l Select Current Sheet to print only the currently active layout page.                     

 l Select Sheets to specify which layout pages to print, then type the page numbers you wish to print, separated by 
commas or by a dash. Not available in plan files.           

Note: To produce collated multiple copies, specify the sheets in the 
desired order, separated by commas.

 
Print Source

Not available in the Print Materials List dialog.

 l Select Drawing Sheet to print the entire sheet even though you may be zoomed in on a portion of the view. This is 
selected by default when the Drawing Sheet is set to display in the current view.

 l Select Current View to print only that portion of the active view that is currently visible on screen. If you are 
zoomed out, any blank space outside the printable objects in the view is ignored. This is selected by default when the 
Drawing Sheet is not displaying in the current view.

 
Drawing Scale

 Changes to these options may cause the Paper Size to change, above. Not available in the Print Materials List dialog or in 
camera views or overviews. See Printing to Scale on page 1377.

 l Fit to Paper prints the view on one page. The program uses whatever scale is necessary to fit the plan on one page. 

 l When Fit to Paper is selected, specify the percentage of the paper to be used. The default value is 95%.

Note: The Fit to Paper percentage value is global - affecting all views 
in all files, and is retained between sessions.     

 l Select To Scale to print at the scale specified in the Drawing Sheet Setup dialog. See Drawing Sheet Setup Dialog 
on page 1372.     

 l To print a check plot, select Check Plot at and choose a scale adjustment from the drop-down list. See Check Plots 
on page 1378.          
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  Options

 l Specify the number of Copies you would like to print. 

 l Check Include Watermark to include a watermark in the printed output. Click the Define button to open the 
Watermark Defaults dialog. See Watermark Defaults Dialog on page 1383.          

 l Check Print in Color to print in color or clear the check box to print in either grayscale or black and white. In the 
Print Materials List and Print Time Tracker Log dialogs, system default colors are used when this box is unchecked.

 l To print in grayscale, check Obey Color On/Off Setting in the Preferences dialog before printing, then uncheck 
Print in Color. See Appearance Panel on page 99.          

 l To print in black and white, uncheck Obey Color On/Off Setting in the Preferences dialog before printing, then 
uncheck Print in Color. Lines and fill colors print as either black or white, depending on which is closer to the line 
or fill’s actual color.           

 l Most black and white printers print a grayscale approximation of the colors if Print in Color is selected.           

 
Advanced Options

Click the Open System Print Dialog button to close the Print View dialog and print using your operating system’s Print 
dialog instead. Not available when No Printer is selected.             

 
Preview

Control the appearance of the print job preview on the right side of the dialog.    

 l Specify the Page that displays in the Preview area.

 l Click the buttons to Zoom In, Zoom Out, or Fit the selected Page to the extents of the Preview area. 

 l Uncheck Update Automatically to turn off the print job Preview and prevent it from updating as changes are made 
to the settings in this dialog. 

 l Click the Update button to update the print job Preview to reflect the current settings in this dialog. If Update 
Automatically is unchecked, clicking Update may force the Preview to be blank.

  Preview Pane

 l When Update Automatically is checked, a preview of the current print job displays here. The drawing sheet 
displays as a white rectangle, and if multiple sheets are required, you can scroll through them. If the print job is 
large, a progress dialog may display briefly as the preview draws or updates.

 
 Information

To help prevent unwanted printed output, information messages regarding page size, resolution, and scale may display 
below the preview pane, depending on the settings in this dialog. 

 

Print Image Dialog
Any view can be printed by selecting File> Print Image. This is the only way to print a Ray Trace or most 3D 
views. See 3D Rendering on page 1129.

The Print Image dialog is similar to the Print View dialog; however, the printing process is different. Print Image prints 
individual pixels as opposed to vectors (lines).
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Destination

Select the Name of the Printer you wish to use from the drop-down list. To print to .pdf, select “Chief Architect Save as 
PDF” from the list, or choose a .pdf writer installed on your system. See Printing to a PDF File on page 1379.

 l Select the DPI, or Dots Per Inch to use when printing, from the drop-down list. The available options may vary 
depending on the selected printer.          

 
Paper

Select the Paper Orientation, Size, and Source. The available Size and Source options are controlled by the selected 
printer’s driver. See Printer Drivers on page 1370.

 
Options

Specify the number of Copies you would like to print. 

 
Advanced Options

Click the Open System Print Dialog button to close the Print View dialog and print using your operating system’s Print 
dialog instead. Not available when No Printer is selected.

 
Preview

Control the appearance of the print job Preview on the right side of the dialog.

 l Specify which Page displays in the Preview area.

 l Click the buttons to Zoom In, Zoom Out, or Fit the selected Page to the extents of the Preview. 

 l Uncheck Update Automatically to turn off the print job Preview and prevent it from updating as changes are made 
to the settings in this dialog. 

 l Click the Update button to update the print job Preview to reflect the current settings in this dialog. If Update 
Automatically is unchecked, clicking Update may force the Preview to be blank.
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Preview Pane

When Update Automatically is checked, a preview of the current print job is displayed to the right. If the print job is large, 
a progress dialog may display briefly as the preview draws or updates.

 
Information

To help prevent unwanted printed output, information messages regarding page size and resolution may display here, 
depending on the settings in this dialog. 
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Chapter 43
 

Ruby in Chief Architect

Ruby is a popular, open-source programming language that can be used for a wide variety of purposes.

In Chief Architect Premier, you can use Ruby 2.4.0 to create custom macros which can be used to produce object labels for 
specific needs and customized Materials List calculations. You can also type Ruby macro code bookended by percent signs 
into text objects and object labels.

Ruby is considered to be easy to use by its many users - not all of whom are software developers. If you’d like to learn 
more, visit:  www.ruby-lang.org.

TOPICS

Creating User Defined Macros 1392
Working with NVPublishers 1392
Working with Name-Value Pairs 1394
Macros and Context 1395
Measurement and NumberFormatter Classes 1398
Text Macro Management Dialog 1401
The Ruby Console 1405
Viewing the Interactive Tutorial 1406
Migrating Legacy Ruby Code 1406
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Creating User Defined Macros
You can create your own custom macros for a variety of purposes in Chief Architect Premier, including: 

 l Shortcuts for strings of text that are used repeatedly throughout a project. For examples, see Project Information on 
page 60.

 l Custom object labels. See Label Panel on page 712.
 l Custom labels inserted into text objects, callouts, and markers in plan view. See Referenced Object Context on page 

1396. 
 l Object Information that can be included in schedules and the Materials List. See Object Information Panel on page 

1336.
 l Materials List formulas. See Materials List Formulas on page 1325.

There are two broad categories of macro:

 l Text macros are essentially shortcuts that replace long strings of text with an inserted macro. Text macros can include 
Global macros with general information about the current view or file, but they cannot perform calculations. 

 l Ruby macros, on other hand, can include Name-Value Pairs, perform calculations, and even reference scripts written 
in Ruby. They do not, however, use regular text. In order to function, the information in each Ruby macro must have a 
defined Context: Owner Object, Referenced Object, or Materials List Line Item. 

Macros will update whenever the display is redrawn. You can 
prompt the screen to redraw by zooming, panning, or selecting 

View> Refresh Display. See Window and View Tools on page 148.

NAME-VALUE PAIRS AND PUBLISHERS

At the heart of most Ruby macros are Name-Value Pairs, or NVPs, and Name-Value Publishers, or publishers. A publisher 
is simply an object that has attributes that can be reported by a Ruby macro, and an NVP is the name of such an attribute 
and its value. For example: 

 l A cabinet is an example of a publisher.
 l The name of one of its attributes is height.
 l 36” is the value reported by height in a basic macro in a plan using US units.

Most objects in Chief Architect Premier have a selection of NVPs which can be used to report information about them in 
Ruby macros. See To view a publisher’s Name-Value Pairs on page 1393.

A Name-Value Pair can be used as a simple macro by bookending it with percent signs. For example, %height% will report 
the height of a wide variety of objects. See To insert a macro on page 550.         

CREATING AND EVALUATING CUSTOM MACROS

Custom Ruby macros are created in the Edit Text Macro dialog. See Edit Text Macro Dialog on page 1402.         

Custom macros can be evaluated in the Ruby Console. See The Ruby Console on page 1405.         

 

Working with NVPublishers
NVPublishers, or publishers, are objects in Premier that have attributes that can be reported by a Ruby macro.           
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In plan view, a publisher can either be an Owner Object or a Referenced Object.           

 l An Owner Object reports its own attributes directly in a label or using Object Information in a schedule or materials 
list.           

 l A Referenced Object’s attributes are reported by a macro inserted into a text object that is connected to the publisher 
by a line with arrow. See Referenced Object Context on page 1396.          

To view a publisher’s Name-Value Pairs
 1.  Select Tools> Ruby Console .          

 2.  Select an object in your plan - for example a base cabinet. This is an Owner Object.          

 3.  Type owner.names in the Input text field of the Ruby Console and press the Enter key.           

 4.  An array of NVPs will display in the Output field. These values are all attributes of the selected object.          

 5.  To view the array as a list, type puts owner.names and press Enter.           

You can request the NVPs for a Referenced Object just as you can for an Owner Object: select the Referenced Object and 
open the Ruby Console. Then, instead of typing owner.names, type referenced.names (or puts referenced.names).           

Note: The name-value pairs for rooms cannot be used to create 
Referenced Object macros. They only work as Owner Object macros. A 
number of macros that describe rooms are available as Global Macros, 
which do work when placed in a Text object located inside a room. 

RELATED OBJECTS

A given publisher may have NVPs that report information about objects associated with the publisher rather than about the 
publisher itself. For example, a base cabinet often has:           

 l An automatic countertop, which is a feature of the cabinet parametric object but is a publisher in its own right and has 
its own set of NVPs.          

 l Door and drawer panels, which are library symbols that are inserted into the cabinet. See Inserted Objects on page 
981.          

 l Moldings, which are library items assigned to the cabinet.          
 l A room that the cabinet is located in.           

These related objects are all publishers themselves and have their own NVPs.           

To view an object’s related publishers
 1.  Use the Leader Line  tool to create a Text Line with Arrow snapped to the object on the arrow end. See Leader 

Line on page 528.          

 2.  In the Rich Text Specification dialog, type or insert the %object_properties% User Defined macro. See To insert a 
macro on page 550.          

 3.  When you click OK, the text will report all NVPs, NVPublishers, and Collections associated with the object that the 
arrow is snapped to.          

Note: The %object_properties% macro cannot be used with a Leader 
Line to view the related publishers of a room. Instead, place the Text 
object inside the room. 

To include a related object’s NVPs in a macro, use this format: related_publisher_name.nvp_name.           
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Related objects may also be nested more than one layer deep: related_publisher_name.related_publisher_name.nvp_name.          

COLLECTIONS

Some objects can have more than one of a particular type of related object. For example, a cabinet may have multiple door 
or drawer panels. Each panel is an NVPublisher listed in a Collection. The layers of structural assemblies like walls are also 
listed in Collections.         

There are two main ways to use Collections in a Ruby macro:          

 l Access elements at a specific index, like an Array: 

collection_name[index].nvp_name             
 l Use a different Enumerable method with a Ruby block. Use this format, in which “parameter_name” can be replaced 

with any name/identifier: 

collection_name.enumerable_method                       
{ |parameter_name| parameter                     
_name.nvp_name }             

For more information, see: https://ruby-doc.org/core-2.4.0/Enumerable.html.         

ROOMS

Like other objects, rooms are publishers with related objects and collections associated with them. They are unusual, 
however, in that  if an otherwise independently placed object is positioned inside a room, that object will have NVPs that 
report information about the room.         

This means that a text object placed inside a room can serve as a custom label, using a macro to report dynamic information 
about the room. 

 l To add an NVP to a text object that reports information about the room the text is located in, use this format: 
room.nvp_name. See Working with NVPublishers on page 1392.

 l To create a custom macro to insert in a text object that reports information about the room the text is located in, use 
the Owner Object context and make sure "room" is defined as the publisher for all variables. See Owner Object 
Context on page 1396.

It also means that architectural objects can report information about the room they are in in their labels, in schedules, and in 
the Materials List. Objects that are not located entirely inside one room - including doors, windows, and any other object 
that extends beyond the extents of a single room - do not have this ability.          

 

Working with Name-Value Pairs
Ruby macros can access and report information about a variety of different objects in Premier. This information is presented 
in the form of Name-Value Pairs, or NVPs. 

NVP Names use all lower case characters and separate words using an underscore _ instead of a space.

Each NVP Value in Premier is reported in one of eleven ways:

 l Integer values are whole numbers.
 l Float values are numbers with decimal points.
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 l Measurement values are a custom class that have numbers with decimal points and a unit of measurement. See 
Measurement Class on page 1398. 

 l TrueClass reports that the publisher object has a particular attribute.
 l FalseClass reports that the publisher can have a particular attribute but does not.
 l NilClass reports that the publisher has a particular attribute, but that it doesn’t apply in the current instance.
 l String values are composed of text.
 l Symbol values are similar to text.
 l NVPublishers identify related objects.
 l Collections identify collections of related objects.
 l Hash identifies a collection of user-specified Custom Object Fields and is only returned by the custom_fields NVP.

There are two ways to view the NVPs associated with an object:

 l The Ruby Console can report all NVPs associated with a selected object.
 l The %object_information% macro can report all NVPs, NVPublishers, and Collections associated with an object.

HASHES

Ruby Hashes are collections of key-value pairs. In Premier, they can be used to access the information in Custom Object 
Fields. See Custom Object Fields on page 702. 

To include a Hash in a macro, use this format:

custom_fields[“custom field name”]. 

NAME VALUE PAIRS AND DEFAULTS

A number of NVPs for various objects end in ‘_is_default’. These NVPs will return either ‘true’ or ‘false’, depending on 
whether the object in question is set to use the dynamic default for that attribute. See Dynamic Defaults on page 79.

 

Macros and Context
Ruby macros can be used in different contexts, but in order for the Name-Value Pairs in a macro to report the correct 
information, the macro needs to identify the context it is designed to be used in.           

NON-EVALUATED TEXT MACROS

Non-evaluated text macros primarily act as shortcuts for strings of text that you use often in your work. They are dynamic, 
so if you need to modify a string, you can simply edit the associated macro instead of locating and changing every instance 
of the text in the plan or layout file.           

Non-evaluated text macros cannot display dynamic information about a particular object or perform calculations, however.          

To create a non-evaluated text macros
 1.  Open the Text Macro Management dialog and click the New button.           

 2.  In the Edit Text Macro dialog:          
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 l Type the desired text.          

 l Insert any Global text macros that you need. Non-evaluated User Defined macros can also be included.           

 l Inserted macros should use the format: %macro_name%.          

 l Leave the Evaluate check box unchecked.          

 3.  Confirm that the macro is valid by checking its Expanded Macro Value in the Text Macro Management dialog.          

The resulting macro can be inserted into a text object. Although it cannot not display dynamic information about a particular 
object or perform calculations, it can also be inserted into an object’s label or added to its Object Information.           

OWNER OBJECT CONTEXT

The Owner Object context allows a macro to perform calculations and dynamically report information about an object in its 
label and Object Information.           

To create an Owner Object macro
 1.  Select an object for which you would like to create a custom macro.           

 2.  With the object selected, open the Text Macro Management dialog and click the New button.           

 3.  In the Edit Text Macro dialog:          

 l You can use any NVPs associated with the selected object in the macro. See Working with Name-Value Pairs on 
page 1394.          

 l NVPs do not require special formatting, but macros inserted using the %macro_name% format cannot be used.          

 l To include a Ruby macro within another Ruby macro, use this format: macros.macro_name. 

 l When the intended owner is a text object reporting information about a room, use this format: room.nvp_name. See 
Working with NVPublishers on page 1392.

 l Check Evaluate and select “Owner Object” from the Context drop-down list.          

 4.  Confirm that the macro is valid by checking its Expanded Macro Value in the Text Macro Management dialog.          

The resulting macro can be inserted into the label for any object for which it is Valid.           

REFERENCED OBJECT CONTEXT

When a Ruby macro is assigned the Referenced Object context, it can be inserted into text with an arrow pointing to the 
object it refers to and then perform calculations or report information about that object.           

To create a Referenced Object macro
 1.  Select a text object with an arrow that is snapped to an object for which you would like to create a custom macro.           

 2.  Open the Text Macro Management dialog and click the New button.          

 3.  In the Edit Text Macro dialog:          

 l You can use any NVPs associated with the object that the text arrow is pointed to.           

 l NVPs do not require special formatting, but macros inserted using the %macro_name% format cannot be used.          
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 l To include a Ruby macro within another Ruby macro, use this format: macros.macro_name.          

 l Check Evaluate and select “Referenced Object” from the Context drop-down list.          

 4.  Confirm that the macro is valid by checking its Expanded Macro Value in the Text Macro Management dialog.          

To use a Referenced Object macro
 1.  Insert the custom macros into a Text, Rich Text, Callout, or Marker object.          

 2.  Draw a Text Line with Arrow between the text object and the object that your Referenced Object macro describes.           

Note: Referenced Object macros cannot be used with a Leader Line to 
report information about a room. Instead, use the Owner Object context, 
place the Text object inside the room, and use a macro in which "room" 
is defined as the publisher for all variables. See Owner Object Context on 
page 1396, above.

MATERIALS LIST LINE ITEM CONTEXT

A Materials List Line Item macro can be inserted into a cell in a materials list.          

To create a Materials List Line Item macro
 1.  Open the Text Macro Management dialog and click the New button.          

 2.  In the Edit Text Macro dialog:          

 l You can use any Name-Value Pairs associated with the object that the macro is meant to describe.          

 l Name-Value Pairs do not require special formatting, but macros inserted using the %macro_name% format cannot 
be used.          

 l To include a Ruby macro within another Ruby macro, use this format: 
macros.macro_name.          

 l Check Evaluate and select “Materials List Line Item” from the Context drop-down list.          

 3.  Unlike other types of macros, its validity cannot be confirmed in the Text Macro Management dialog.          

To use a Materials List Line Item macro
 1.  Select an object and click the Open Object edit button.          

 2.  On the COMPONENTS panel of the specification dialog, select a component or subcomponent associated with the 
object.         

 3.  Click in a Formula cell to select it, then click a second time to edit the cell.           

 4.  Select Apply Formula to Source Object .          

 5.  Click the Insert Macro  button and insert a macro.          

Macros can also be inserted in the Materials List in a similar manner. See To insert a custom Materials List formula on page 
1326.          

CONTEXTLESS MACROS

Select “None” as the Context for a Ruby macro if you would prefer to define the Context within the macro’s Value.           

To do this, type the Context before each NVP in the macro using this format:          
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 l owner.name_value          
 l referenced.name_value          
 l line_item.name_value          

 

Measurement and NumberFormatter Classes
Chief Architect Premier uses two custom Ruby classes that clarify and allow control of the units and formatting used by 
measurements: Measurement and NumberFormatter. 

MEASUREMENT CLASS

All Name-Value Pairs that return length, area, or volume values do so by reporting a Measurement. A Measurement 
includes both a numeric value and a unit. The program has a set of hard-coded default units that can be used, and Custom 
Unit Conversions are supported as well. See Add Unit Conversion Dialog on page 115. 

The default unit used by a Measurement depends on its category as well as whether the file uses U.S. (“Imperial”) or metric 
units: 

Category Default Units

Linear Inches or millimeters

Area Square feet or square meters

Volume Cubic feet or cubic meters

Unitless None

Anything else Items without precedent are 
represented in a power of inches or 
cm.

Although Measurements have a unit, it is not reported unless you create a custom format. See NumberFormatter Class on 
page 1399, below.

MEASUREMENT-SPECIFIC METHODS

The Measurement class is not derived from the Numeric class but has many of the same methods. It also has a small set of 
custom methods:

Measurement-Specific Method Return Comments

compatible_with?(other: Measurement) True  | False Returns True if other is compatible.

to_s(unit: Symbol | String = "") String Converts into a formatted representation of a 
Measurement. If a unit is provided, it must be 
compatible with the Measurement's type 
(linear, area, volume). 

to_f(unit: Symbol | String = "") Float Converts into a float with optional unit 
argument. If a unit is not provided, the result 
is converted to the appropriate default unit.
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Measurement-Specific Method Return Comments

convert_to(unit: Symbol | String) Float Converts into the specified unit. Raises an 
exception if the unit is incompatible. 

new([value: Float] = 0.0, [unit: Symbol | 
String] = "")

Measurement Creates a new Measurement. If unit is not an 
empty String, it must be a defined unit. 

type() String The "category" of measurement: "Linear", 
"Area", "Volume", "Unitless", or "Derived".  

unitless?() True | False Returns True if the Measurement is unitless.

CONVERSION METHODS

The following units in Chief Architect Premier have hard-coded methods to convert a Numeric to a Measurement and vice 
versa: 

 l Linear: inch, in, foot, ft, yard, yd, mm, cm, dm, m 
 l Area: Prefix “sq_” to any of the above
 l Volume: Prefix “cu_” to any of the above

Conversion Method Return Comments

to_measurement([unit: Symbol | String] 
= "")

 SHORTCUT:  .(unit)

Measurement Returns a Measurement equivalent to "self.to_
f unit". Omitting unit will produce a unitless 
Measurement.
+, -, *, and / operators will coerce the 
Numeric into a unitless Measurement.

convert_to(unit: Symbol | String)

 SHORTCUT:  .to_(unit)

Float Converts into the specified unit. 

NUMBERFORMATTER CLASS

Chief Architect Premier’s default format for Measurements uses up to 6 decimal places, a leading zero, and no trailing 
zeroes. It does not include a unit. The NumberFormatter class allows you to create formatting for Measurements to meet 
your needs. 

NUMBERFORMATTER METHODS

NumberFormatter Method Return Comments

apply(value: Numeric | Measurement) String Formats the given value. If it is a Measurement 
of type Linear, Area, or Volume, it must have a 
compatible unit. 

inspect() String Lists the current settings of the formatter.

unit() String The unit the formatter is currently using.

unit=(unit: Symbol | String)   Sets the unit the formatter will use. Mixed units 
("ft-in") and undefined units are supported.
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NumberFormatter Method Return Comments

show_unit() True | False Reports whether the formatter will include the 
unit in the output.

show_unit=(True | False)   Sets whether the formatter will include the unit 
in the output. 

show_leading_zero() True | False Reports whether the formatter will include a 
leading zero. 

show_leading_zero=(True | False)   Sets whether the formatter will include trailing 
zeros.

show_trailing_zeros() True | False Reports whether the formatter will include 
trailing zeros. 

show_trailing_zeros=(True | False)   Sets whether the formatter will include trailing 
zeros. 

use_fractions() True | False Reports whether the formatter will display 
fractions (True) or decimals (False).

use_fractions=(True | False)   Sets whether the formatter will display 
fractions (True) or decimals (False).

decimal_places() Fixnum Reports the maximum number of decimal 
places the formatter will use when not 
displaying fractions.

decimal_places=(Fixnum)   Sets the maximum number of decimal places 
the formatter will use when not displaying 
fractions. Must be >= 0. 

denominator() Fixnum Reports the denominator the formatter will use 
when displaying fractions.

denominator=(Fixnum)   Sets the denominator the formatter will use 
when displaying fractions. Must be >= 1.

thousands_separator() String The thousands separator displayed for numbers 
greater than 999. An empty String represents 
no thousands separator. 

thousands_separator=(separator: 
String) 

  Sets the thousands separator displayed for 
numbers greater than 999. An empty String 
represents no thousands separator. 

show_denominator() True | False Reports whether the denominator will be shown 
when displaying fractions.

show_denominator=(True | False)   Sets whether the denominator will be shown 
when displaying fractions. When the 
denominator is hidden, fractions are never 
reduced. 

reduce_fractions() String | 
False

Reports the method used to reduce fractions, if 
any. Returns False if fractions aren't reduced.
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NumberFormatter Method Return Comments

reduce_fractions=(method: :gcd | 
:closest | :none | "" | False) 

  Sets the method used to reduce fractions. :gcd 
or "gcd" will use the greatest common divisor 
of the passed in value and the denominator. 
:closest or "closest" will ignore the set 
denominator and try to pick the closest 
equivalent fraction. :none, an empty String, or 
False will prevent fractions from being reduced 
and always use the set denominator. 

 

Text Macro Management Dialog
A list of all user-defined text macros present in the current plan or layout file can be accessed by selecting CAD> 
Text> Text Macro Management.

 l If you wish to create a user defined macro for an object, or find out whether an existing macro is valid for an object, 
open this dialog while the object is selected. 

 l To create a user-defined macro to be inserted into a text object that describes another object, or to find out whether 
such a macro is valid, select a text object with an arrow pointing to the object in question and then open this dialog. 
See Macros and Context on page 1395. 

An object-specific version of this dialog is also available for objects saved in an unlocked library. Right-click on a single 
object of a type able to display labels and select Text Macro Management from the contextual menu. See Using the 
Contextual Menus on page 965. 

 l Any Owner Object macros assigned to the object’s label when it is added to the library are listed here. Note that 
objects in some manufacturer catalogs may include macros. See Manufacturer Catalogs on page 970. 

 l Custom macros can be imported to and exported from a library object, and additional macros can be added to the 
object, but you cannot specify them as part of a label while it is in the library. 

 l When the object is added to a plan, any macros associated with it are added to the plan, as well. 
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User Defined Macros

An alphabetical list of all User-Defined Macros present in the current file displays here.    

 l Click on the Name of a macro to select it.     

 l If a macro is Valid in the current context, a check mark will display to the right of its Name. See Macros and 
Context on page 1395.     

 l In legacy files, macros using deprecated behaviors may be present. When this is the case, an additional Info column 
will be present. See Migrating Legacy Ruby Code on page 1406.     

 l Information about a selected macro displays in the Macro Value and Expanded Macro Value fields to the right of the 
list. The Macro Value field shows the defined Value of the selected macro. The Expanded Macro Value shows the 
output of the macro in the current context.

 
Buttons

Edit or delete the selected text macro, create a new one, or import or export macros to and from other files. See Importing 
and Exporting Macros on page 1404, below.    

 l Click the Edit button to make changes to the selected macro in the Edit Text Macro dialog. Only available when an 
existing macro is selected.     

 l Click the New button to open the Edit Text Macro dialog and create a new macro.     

 l Click the Copy button to create a copy of the currently selected macro and open the Edit Text Macro dialog. Only 
available when an existing macro is selected.     

 l Click the Delete button to remove the selected macro from the list. Only available when an existing macro is 
selected.     

 l Click the Import button to open the Import Text Macros dialog and import macros exported from another file into 
the current file. See Importing Files on page 45.     

 l Click the Export button to open the Export Text Macros dialog and make the user-defined macros in this file 
available to be imported into another file. See Exporting Files on page 41.     

 l Click the Migrate button to migrate a legacy macro to the latest version. Only available when a legacy macro is 
selected. See Migrating Legacy Ruby Code on page 1406.

 
Macro Value

The Macro Value field displays the content, or text used to define the selected macro. 

 
Expanded Macro Value

The Expanded Macro Value field displays the information that the macro reports. If the selected macro is not Valid in the 
current context,  “#Evaluation Error#” will display here, 

 
Show Evaluation Error

If the selected macro is not Valid, click the Show Evaluation Error button to open an Information box with a description 
of the problem. See Macros and Context on page 1395.

EDIT TEXT MACRO DIALOG

The Edit Text Macro dialog can be accessed by clicking the Edit, New, or Copy button in the Text Macro Management 
dialog. 
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Name

Type a short, descriptive Name for the macro. Macro names must be unique within a given file, or library object.    

To avoid unexpected results, a macro should not have the same name as an NVP Name, NVPublisher, or Collection.    

 
Value

Type a macro using the Ruby 2.4.0 programming language in the Value field. NVPs existing macros, and references to 
Ruby .rb files can be included. 

 l You can also copy an NVP out of the Ruby Console or a definition from an .rb file and paste it here. See To Copy, 
Cut and Paste text on page 523.    

 l Click the Insert button above the Value field to insert an already existing macro into the selected macro. See To 
insert a macro on page 550.

Note: Chief Architect Premier uses Ruby 2.4.0. 
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Context

To create a Ruby macro with a context, check the Evaluate box, then select a Context from the drop-down list. When 
unchecked, a text macro will be created. See Non-Evaluated Text Macros on page 1395.

 l Choose None if the macro performs a function but doesn’t refer to an object or if the macro’s context - or contexts - 
are stated in its Value.

 l Choose Owner Object to create a macro for use in an object label.    

 l Choose Referenced Object to create a macro for use in a Text object with an arrow that points at an object that the 
macro describes.     

 l Choose Materials List Line Item to create a macro for use in the Materials List.     

If the selected macro is a legacy macro using deprecated behavior, additional options will be available. See Migrating 
Legacy Ruby Code on page 1406.     

 l Click the Migrate Formula button to open the Migrate Ruby dialog. 

 l After migrating the macro but before clicking OK in this dialog, you can click the Revert to Legacy button. This 
button is only available until you exit out of the dialog.

 
Results

For comparison purposes, the Original Result and New Result fields report Data Type and Value information when the 
selected macro is valid, or Evaluation Error information when it is not.     

 l The Original Result field reports information about the macro as it was when the dialog was first opened. This field 
will be blank for a newly created macro.     

 l The New Result field reports information based on changes made since the dialog was opened.

  Click OK to return to the Text Macro Management dialog. 

IMPORTING AND EXPORTING MACROS

User-defined text macros can be exported out of one plan file, layout file, or library object and imported into another file or 
object using the Text Macro Management dialog.

If the program encounters macros with duplicate names when importing into a plan or layout file, the Text Macro Name 
Conflict dialog will display, allowing you to choose how to handle the name conflict.

 l Select Rename the imported macro to keep both the existing macro and the one being imported. Then, type a short, 
descriptive, unique New Macro Name. By default, the new name is simply the original name appended by a number. 
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 l Select Discard the imported macro to use the existing macro already present in the destination file or library object 
rather than import the new one.

 l Select Replace the existing macro with the imported macro to delete the existing macro and replace it with the one 
being imported.

 l Check Do this for all remaining macro conflicts to apply the same choice for any other macros with conflicting 
names in the current import operation.

If the program encounters a macro name conflict when importing into a library object or when placing a library object in a 
plan, a Question message box will ask if you wish to  replace the existing macros. Click Yes to replace any existing macros 
with imported macros of the same name or click No to keep the existing macros and not import those of the same name.

 

The Ruby Console
The Ruby Console can be used to access information about a variety of objects in Chief Architect Premier: 
information which can then be used to create custom Ruby macros. It can also be used to evaluate custom Ruby 

macros to confirm that they are valid. See Creating User Defined Macros on page 1392.

Select Tools> Ruby Console to open the Ruby Console window. The Ruby Console can be open while you work using 
other tools in the program. 

The Ruby Console interface is simple: at the bottom of the window is an Input field where you can type commands, and the 
results of your commands display in the Output field above.

 
Command Input

Type expressions, or commands, in the Input field at the bottom of the window.

 l Press Enter on your keyboard to enter your expressions and see the results.    

Note: Chief Architect Premier uses Ruby 2.4.0.     

 
Results

The results of your expressions display in the larger Output field, above.  

 l > at the beginning of a line indicates that what follows is your expression.    

 l => at the beginning of a line indicates that what follows is a result.

 l As you type multiple expressions, they and the new results are added below the previous ones.    

 l Use the scrollbar on the right to scroll up and down the results field.
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Tutorial

Click the Tutorial button to view an interactive written tutorial presented in the Ruby Console. See Viewing the Interactive 
Tutorial on page 1406.

 
Resize

Click the size grip and drag to resize the Ruby Console window as needed.

USEFUL EXPRESSIONS

The following are a few commonly used expressions that you can use to obtain the attributes of one or more selected 
objects.

Macro Description

owner Returns the selected publisher

selected Returns an array of multiple selected publishers

referenced Returns the publishers

.names Preceded by owner, selected, or referenced, this 
returns an array of NVPs for the selected publisher
(s).

.<variable_name> Preceded by owner, selected, or referenced, this 
returns the value of the NVPs bounded by the 
brackets for the selected publishers(s).

puts Returns a list instead of an array.

$ Indicates a global variable rather than a local 
variable.

 

Viewing the Interactive Tutorial
An introductory tutorial is included with Chief Architect Premier and can be run in the Ruby Console. To run it, select 
Tools> Ruby Console , then click the Tutorial button at the bottom of the dialog or simply type show in the Input field. 

If you have previously run the tutorial during the current program session, the tutorial will open to the last topic shown. If 
you have not run the tutorial this session, its Table of Contents will open.

To view the tutorial’s Table of Contents at any time, type toc in the Input field.

 

Migrating Legacy Ruby Code
In Chief Architect Premier X11 and prior, Name-Value Pairs returned length, area, and volume measurements as Floats (or 
Integers, if rounded) instead of Measurements. When legacy Ruby macros or materials list formulas are evaluated in 
Version X14, the program will automatically check their version and provide an opportunity to migrate any instances of 
legacy Ruby code that it finds. 
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MATERIALS LIST FORMULAS

A cell with a legacy formula is identified by an Information   icon. When the cell is moused over, its tool tip indicates the 
presence of a legacy formula, as well. See Materials List Formulas on page 1325.

 l Select the cell and click the Migrate Formula button to migrate the formula to use updated formatting. 
 l After migrating the formula but before deselecting the cell, you can also click the Revert to Legacy button to restore 

the original legacy formula. This button is only available until you click out of the cell. 

TEXT MACROS

Legacy Ruby macros are also identified by an Information   icon in the Text Macro Management dialog. When the icon 
is moused over, its tool tip indicates the presence of a legacy macro, as well. Select the macro and click the Edit button for 
further options. See Text Macro Management Dialog on page 1401.

 l In the Edit Text Macro dialog for a legacy macro, click the Migrate Formula button to migrate the macro to use 
updated formatting. 

 l After migrating the macro but before clicking OK in the Edit Text Macro dialog, you can click the Revert to Legacy 
button. This button is only available until you exit out of the dialog.

Backwards migration for formulas and macros is not supported. 

RUBY MIGRATION DIALOG

The Migrate Formula button is available in the Materials List when a cell with a legacy formula is selected. In the Edit 
Text Macro and Text Macro Management dialogs, it is available when a legacy macro is selected. Click this button to open 
the Ruby Migration dialog.
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 Macro

The legacy macro's name displays here for reference.       

 l The macro can be edited in the text field using the Ruby 2.4.0 programming language. NVP’s, existing macros, and 
references to Ruby .rb files can be included.          

 l Click the Insert button above the text field to insert an already existing macro into the selected macro. See To insert 
a macro on page 550.         

   Issue

 l The Issue that needs to be addressed by migration is described here for reference.

 l If you make changes to the macro above and do not like the New Result below, click the Revert Changes button to 
restore the original value.

 
 Results

These fields report Data Type and Value information when the selected macro is valid, or Evaluation Error information 
when it is not, for comparison purposes.          

 l The Original Result field reports information about the macro as it was when the dialog was first opened.          

 l The New Result field reports information based on changes made since the dialog was opened.         

Click OK to return to the Text Macro Management dialog.         
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Chapter 44
 

Resources and Support

Chief Architect technical support, training, and other resources to help you be successful using our software. 

TOPICS

Learning and Inspiration 1410
Training Services 1411
Contacting Technical Support 1411
Error Messages 1412
Program Paths Dialog 1413
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Learning and Inspiration
Chief Architect offers a variety of resources that help you learn how to use the software, discover new drawing techniques, 
and connect with other Chief Architect users.

CHIEF ARCHITECT WEBSITE

The Chief Architect website has an array of resources, including downloadable library content, program updates, 
news and events, and more. Select Help> Visit Chief Architect Web Site from the program menu to launch your 

default internet browser to chiefarchitect.com.

REFERENCE MANUAL

The Chief Architect Premier X14 Reference Manual is a comprehensive source of information about the entire 
program interface. This manual is available online in .pdf format by selecting Help> View Reference Manual.

TUTORIAL GUIDE

Written for new Chief Architect users, but a helpful reference for users of all experience levels as well, the Tutorial Guide 
walks you through the process of creating a complete model, from the first wall to the interior design and landscaping.   

This guide is available online by selecting Help> View Tutorial Guide.

The Reference Manual and Tutorial Guide are available in 
printed form for optional purchase. For more information, visit 

chiefarchitect.com.             

ONLINE HELP VIDEOS

Another resource that illustrates Chief Architect’s tools is the collection of tutorial videos available on our website. To view 
the online videos, select Help> View Online Help Videos from the program menu or visit  www.chiefarchitect.com/videos.

ONLINE KNOWLEDGE BASE

The Chief Architect Knowledge Base is a collection of online articles that address common technical issues as well as a 
range of how-to questions with illustrations and step-by-step instructions. To access these resources, visit  
chiefarchitect.com.

CHIEFTALK ONLINE FORUM

The ChiefTalk Professional User Forum hosts ongoing discussion on a variety of topics related to the use of Chief Architect. 
It is rich with useful tips and available free of charge to all registered Chief Architect users. 

 l Discussions are initiated and carried out by users in a professional and friendly tone.
 l Experienced users share knowledge with each other and beginners.
 l Chief Architect Software team members post announcements, advice and technical information.

To visit ChiefTalk, select Help> ChiefTalk or go to  chieftalk.chiefarchitect.com.
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ONLINE SAMPLES GALLERY

A collection of plan sets, detail drawings, and renderings is available for viewing and download on our website. 
Select File> Download Sample Plans to launch your internet browser to chiefarchitect.com.

 

Training Services
Chief Architect offers a variety of online and in-person training opportunities. For details, schedules of upcoming events, 
and more, visit chiefarchitect.com.          

ONLINE WEBINARS

Chief Architect regularly conducts live, online training seminars designed for different skill levels, and on a variety of 
topics. Learn the basics of using Chief Architect the right way by joining an Introductory series, then progress through 
topics of interest, such as Kitchens and Baths, Construction Documents, and Terrain.           

ON-SITE SEMINARS

Throughout the year, Chief Architect also conducts training seminars in various locations around the United States.           

PERSONAL ONLINE TRAINING

Conducted via telephone and high-speed internet, Personal Online Training lets you focus on your specific design 
challenges. With a Personal Trainer, it's fast and easy to meet your personal training needs from the comfort of your own 
computer.           

 

Contacting Technical Support
Chief Architect’s world class technical support services can be accessed both online and by telephone. Select Help> 
Technical Support from the program menu to visit  chiefarchitect.com.

Before contacting Technical Support, take a moment to see if the answer to your question is found in the program’s Help, 
Training Videos, or other online resources. When you contact us, you will be referred to these resources if the answer can 
be found there.

There are a number of things you can do to ensure a speedy answer to your question when you contact Technical Support.

 l Select Help> About Chief Architect (PC) or Chief Architect> About Chief Architect (Mac) and make a note of the 
first characters of your Product Key and the program’s Build number.

 l We periodically release updates to the current program version. Before contacting Technical Support, select Help> 
Download Program Updates and make sure you are running the most current update for your program version. 

 l When you encounter an error message, click the Send Report button if possible and copy the message’s exact 
wording. See Error Messages on page 1412.

 l When calling Technical Support, have Chief Architect running on the computer where the problem occurs. This is 
necessary in order to troubleshoot the issue and verify that a solution is found. 

 l Be prepared to reproduce and describe the problem in detail. If we cannot reproduce the problem, there is a reduced 
chance that we will be able to resolve it.
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TELEPHONE SUPPORT

Our Technical Support team is committed to answering your questions as quickly as possible and in the order received. We 
can resolve most issues in just a few minutes and are happy to help you find the best resource to answer your questions. So 
that we can quickly answer all calls, though, we may ask that you limit your inquiry to one question. 

Chief Architect X14 users who participate in the Support and Software Assurance program should use the Priority 
Support telephone number provided in their SSA documentation.         

ONLINE SUPPORT

If a Support technician needs to see a copy of a plan, layout, or other file, they will ask you submit it to us using the Chief 
Architect Online Support Center. 

Questions can also be submitted directly to the Technical Support department using the Online Support Center as well. Be 
sure to provide a detailed description of the problem you are encountering in your ticket.

 

Error Messages
Most common error messages have a known cause and simple resolution. When you encounter an error or warning message 
in Chief Architect, you can click the Check Knowledge Base button in the message box to launch your default internet 
browser to the Chief Architect Knowledge Base on our website,  chiefarchitect.com.

If the message is discussed in an article it will display, providing information about the message and how best to avoid it. 

It is important that abnormal errors be reported to Chief Architect Technical Support so that we can identify and resolve any 
problems. 

The content of an error message is useful in diagnosing its cause. If you encounter an error message, make a note of the 
error number and the full text of the message. You can also click the Details button and copy the text into a text document 
or Online Support on page 1412 Center ticket.

If you encounter the error more than once, make a note of your steps prior to receiving the message.

Finally, check to see if there are program updates available. Program updates contain enhancements and other changes that 
allow the software to perform at an optimum level. Select Help> Download Program Updates from the Chief Architect 
menu and follow the instructions on our website, chiefarchitect.com.

ERROR REPORTING

When an error occurs, you may have the option in the message box to send the report to Chief Architect by clicking the 
Send Report button in the error message box. A report containing technical details about the error, but no personal 
information, is sent to our Testing team for evaluation. 

When you click the Send Report button, the Automatically Send Error Reports option will be enabled so that a report will 
be sent automatically should you encounter additional errors in the future. When Automatically Send Error Reports is 
enabled, error message boxes will not have a Send Report button. You can enable or disable Automatically Send Error 
Reports in the Preferences dialog. See General Panel on page 107.  

After clicking the Send Report button, please contact  Technical Support with any additional information that you may 
have about the circumstances of the error: for example, the type of view that was open and the tool that was active.
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Program Paths Dialog
Some technical issues can be caused by problems with support files used by Chief Architect Premier. In the event of such an 
issue, Chief Architect Technical Support may direct you to the Program Paths dialog. This dialog displays a list of files 
utilized by the software along with the pathname of each.  

To avoid unintended problems that could prevent you from using the software, it is strongly recommended that you make no 
changes to any of the files in this list except with the direct assistance of Technical Support.
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Chapter 45
 

What’s New in Chief Architect X14

Welcome to Chief Architect X14. This topic has been written to help our upgrading customers make a smooth transition 
from earlier versions of Chief Architect to Chief Architect X14. 

TOPICS

Getting Started Checklist 1415
Migrating Legacy Content 1416
Migrating Legacy Settings 1416
Migrating Legacy Templates 1417
Considerations for Legacy Files 1417
New and Improved Features by Chapter 1425
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Getting Started Checklist
There are many new features in Chief Architect X14, and many existing features have changed. The following list suggests 
steps you should take before migrating your files to Chief Architect X14. More information about each of these steps can be 
found after the list.

 1. □   Review the List of New and Improved Features by Chapter

There are a number of important reasons why you should familiarize yourself with the new and improved features in 
Chief Architect X14:

 l New and improved features allow you to produce drawings more efficiently, so it is to your advantage to use 
them. 

 l Some changes to existing functionality may affect your accustomed drawing style and thus your productivity 
if you are not aware of them. 

 l New features may affect your choice of settings in your template files, as well as your preferred Preferences 
settings. 

See  New and Improved Features by Chapter on page 1425. 

 2. □   Review Migrating Legacy Content

Legacy users of Chief Architect often have library catalogs and other custom content that they want to continue using. 
See Migrating Legacy Content on page 1416.

 3. □   Review Migrating Legacy Settings

Before migrating Preferences, Toolbars, or Hotkeys, bear in mind that legacy settings may not be best suited for using 
the new program version. See Migrating Legacy Settings on page 1416.

 4. □   Review Migrating Legacy Templates

Before migrating Templates, bear in mind that they may not be set up to take advantage of new tools in the new 
program version. See Migrating Legacy Templates on page 1417.

 5. □   Review the Considerations for Legacy Files

Before opening a plan or layout file created in a previous version of Chief Architect, be aware of potential changes to 
the file that could occur in the new program version. See Considerations for Legacy Files on page 1417.     

 6. □   Launch Chief Architect X14

Once you have learned about the new features in Version X14 and decided whether to migrate any custom settings from a 
legacy program version, launch Chief Architect X14. The first time you launch, the Migrate Settings dialog will give you 
the opportunity to bring legacy settings and content forward into Version X14.
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Migrating Legacy Content
Legacy users of Chief Architect Premier often have a wealth of library catalogs and other custom content that they have 
built over time and want to continue using. 

LEGACY LIBRARY CONTENT

There are several ways that legacy library catalogs can be brought into Chief Architect X14. 

If you have Chief Architect version X5 through X13 installed on your computer, the Migrate Settings dialog will display 
after you activate the license, allowing you to migrate library content as well as a selection of other settings for use in Chief 
Architect X14. If multiple legacy versions are present on the system, only the data associated with the most recent will be 
migrated.

You can import library files from Versions               X1 through X5 at any time by selecting Library> Import Library (.calib, 
.calibz) from the program menu.

In addition, library files from Versions               10 and prior can be imported by selecting Library> Convert Legacy (.alb) Library 
Files from the program menu. Bear in mind, though, that older content may not be of the same quality as currently offered 
catalogs and that legacy Manufacturer catalogs may be out of date. 

CUSTOM GRAPHICS FILES

Chief Architect can use graphics files regardless of where they are stored on your system; however, it is a good idea to keep 
your data organized in one location. If you have custom graphics files, including textures, images or backdrops that you 
used in a previous program version, you can copy them manually using your operating system for use in Chief Architect 
X14.  

 l Copy custom texture files to the Chief Architect X14 Textures folder located in the Chief Architect X14 Data folder. 
 l Copy custom image files to your Chief Architect X14 Images folder located in the Chief Architect X14 Data folder. 
 l Copy custom backdrop files to your Chief Architect X14 Backdrops folder located in the Chief Architect X14 Data 

folder. 

In Chief Architect X1 through X13, custom graphics were saved in the Chief Architect Data folder, as they are in version 
X14. In version 10, they were located in the program’s installation directory, in folders that began with “My”. Custom 
backdrops, for example, were saved in “My Backdrops”. 

Texture and image files are not listed in the Library Browser. These files can be assigned to material and image objects, 
however, which are stored in the library so it is important to retain them. There are several tools available for adding 
materials and images to the library. 

 

Migrating Legacy Settings
The Migrate Settings dialog lets you migrate settings from the most recent legacy installation of your Chief Architect title 
into Version X14. If you have extensively customized your Preferences, Toolbars, or Hotkeys, you may want to continue 
using those settings. Before doing so, though, it is important to consider that you may make it harder to take advantage of 
new tools and functionality in Version X14.
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PREFERENCES SETTINGS

Although you can migrate your Preferences settings from Versions X5 through X13 into Version X14, the settings that are 
available in Version X14 may differ from previous program versions. You should review all the settings in the Preferences 
dialog to make sure that they are set to suit your drawing needs. 

CUSTOM TOOLBAR CONFIGURATIONS

It is possible to migrate toolbar configuration files from previous program versions into Version X14; however, it is also 
possible that your migrated toolbars will be missing new tools available in Version X14. 

Additionally, obsolete toolbar buttons are occasionally removed from the program and will also be removed from migrated 
legacy toolbars. See  New and Improved Features by Chapter on page 1425 for information about new features as well as 
removed or deprecated tools.

CUSTOM HOTKEYS

Like toolbar configurations, legacy hotkeys can be migrated into Chief Architect Premier X14. Bear in mind, though, that 
occasionally the default hotkeys are modified to accommodate new features or changes in default system hotkeys.           

 

Migrating Legacy Templates
Chief Architect X14 installs a selection of template plan and layout files that have been set up to take advantage of the 
program’s updated tools and features.  Although you can migrate your template files for use in Version X14, for best results 
it is recommended that you either:

 l Use the installed templates when creating new plans and layout files in Chief Architect X14
 l Use the installed templates as the basis for creating new custom templates.          

If you choose to continue using template files that you used in a previous program version, it is very important that you take 
the time to review all the default settings in the file, making sure that they will continue to suit your needs in Version X14. 
See  New and Improved Features by Chapter on page 1425.

Next, make sure that you are aware of changes in Version X14 that may affect legacy files: including templates. See 
Considerations for Legacy Files on page 1417.

When you are ready to proceed, make copies of your custom templates in the Chief Architect X14 Templates directory. The 
Templates directory is located in the Chief Architect X14 Data folder. Next, open each template as you would a regular plan 
or layout file, by selecting File> Open, and then save any changes you make by selecting File> Save.          

If you do choose to continue using a legacy template plan, it is best to also use a legacy layout template from the same 
program version, as well. As with a template plan, take the time to go through the layout template’s defaults and make sure 
they are suited for use in Version X14 and that their line weight scales do not conflict with those in your template plans.  

 

Considerations for Legacy Files
As in all software, every new program version introduces changes to its functionality as well as to the user interface. If you 
choose to bring a project forward, be sure to take a few moments to look it over in the new version and confirm that the new 
functionality does not require you to make any modifications. Particularly if you have an approaching deadline, you may 
find it best to finish the current project in the version of the software in which you began it.
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Be sure to read this section before opening any plans created in 
earlier versions of Chief Architect.

Chief Architect X14 can open the .plan and .layout files from prior versions. Files with the older .pl and .la file extensions 
are no longer supported, however, and cannot be opened by Chief Architect X14. Before opening any files created in earlier 
versions of Chief Architect, it is important to be aware of changes made in the newest version and the effect they may have 
on your legacy plan and layout files. 

Please note that files saved in the latest program version cannot be read by older versions of the software. When a legacy 
file is saved in the version X14, an unaltered copy of the original file is created in the Chief Architect X14 Data folder, 
under Archives, which can still be opened in the original version. 

FOR FILES CREATED IN VERSION X13 AND PRIOR

In addition to the above recommendations, if you wish to open files created in Chief Architect Version      X13 or prior, bear in 
mind the following:   

 1.  Stair Walk Lines
In Chief Architect X13 and prior, Walk Lines were drawn on the "Dimensions" layer. In Version X14, they are drawn 
on the same layer as the staircase. When a legacy file is opened in Version X14, any Walk Lines displaying in the file 
may have different line color, weight, and style attributes. 

 2.  Door Rough Openings
In Chief Architect X13 and prior, if a door's Floor to Bottom height was not sufficient to accommodate its Bottom 
Rough Opening, the door's Top Rough Opening space would be increased in the model but not in the Door Specification 
dialog. In Version X14, this no longer occurs: if the Floor to Bottom height is less than the Bottom Rough Opening, the 
full Bottom Rough Opening is simply not modeled when framing is generated. When a legacy file is opened in Version 
X14, its rough opening is modeled exactly as it was in the previous program version but its Top and Bottom Rough 
Opening values now reflect how the rough opening is modeled. 

 3.  NKBA Auto Dimensions
In Chief Architect X13 and prior, the NKBA Auto Dimension and NKBA Auto Elevation Dimension tools had restricted 
default settings that met drawing standards set by the National Kitchen and Bath Association. In order to allow greater 
flexibility in Version X14, these tools have been merged into the other Auto Dimension tools. In plan files created using 
a template installed with Version X14, NKBA compliant dimensions can be created using the "Kitchen and Bath 
Dimension Defaults". In legacy plans opened in Version X14, use the "Legacy NKBA Dimension Defaults". 

FOR FILES CREATED IN VERSION X12 AND PRIOR

In addition to the above recommendations, if you wish to open files created in Chief Architect Version      X12 or prior, bear in 
mind the following: 

 1.  Default 110V Ceiling Outlet
In Chief Architect X12 and prior, the 110V Outlet tool did not have the ability to place outlets in ceilings. In Version 
X13, this ability was added, as was the new GFCI Outlet tool. When a legacy file is opened in Version X14, the new 
Electrical Defaults settings for these items will automatically refer to objects in the Version X14 Core Catalogs. You 
should confirm that these defaults meet your needs. If these default objects are not present in your library, a warning 
message will inform you of the issue. 

 2.  Sliding Door Hinge Side
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In Chief Architect X12 and prior, the fixed or 'hinge' side of sliding doors was described as viewed from the exterior 
side of the door. In Version X13, the hinge side is described using the more common method: as viewed from the 
interior side. When a legacy file is opened in Version X14, all instances of the %hinge_side% Name-Value Pair in 
labels, schedules, and the Materials List will use the new method. You should confirm that the Hinge Side information 
in labels, schedules, and Materials Lists meets your needs. 

 3.  Automatic and Manual Dimension Layers
In Chief Architect X12 and prior, the system default layer for automatically generated dimension lines was "Dimensions, 
Automatic", and the system default for manually drawn dimensions was "Dimensions, Manual". In Version X14, the 
system default layer for all dimensions is simply "Dimensions". When a legacy file is opened in Version X14, automatic 
dimensions that were on the "Dimensions, Automatic" layer in the earlier version will be placed on the "Dimensions, 
Legacy" layer while any dimensions that were on the "Dimensions, Manual" layer in the previous version will be placed 
on the "Dimensions" layer. 

 4.  Gable Lines
In Chief Architect X12 and prior, Gable Lines with a Pitch value of 90° were allowed but did not affect automatic roof 
generation. In Version X14, they are not supported. When a legacy file is opened in Version X14, any Gable Lines with 
a Pitch of 90° will be removed automatically. This will not affect the current roof or automatic roof generation. 

FOR FILES CREATED IN VERSION X11 AND PRIOR

In addition to the above recommendations, if you wish to open files created in Chief Architect Version               X11 or prior, bear in 
mind the following: 

 1.  Perspective Crop Mode
In Chief Architect X8 through X11, Perspective Crop Mode allowed older functionality governing zooming in cameras 
from Version X7 and prior to be preserved in saved cameras in legacy plans migrated forward. This deprecated tool has 
been removed from the program’s menu and toolbars in Version X12, although it can be migrated with legacy toolbars 
and hotkeys. Saved cameras in legacy plans with this behavior enabled may become distorted if you pan or zoom in the 
view. To permanently disable this behavior in a camera view and resolve the resulting distortion, select Window> Fill 
Window or press the F6 key. 

 2.  Layout Layer Sets          
In Chief Architect X11 and prior, the Send to Layout dialog had a sticky Make Copy of Active Layer Set option that 
created a new layer set for the layout view to help preserve layer settings in that view. This option was removed in 
Version X12 to encourage use of the multiple saved plan views. Saved plan views did not exist in Version X9 and prior, 
however, so if you open a plan originally created in Version X9 or prior, extra care must be taken to make sure layout 
views do not use the same layer set. 

 3.  Materials List Formulas and Ruby Macros          
Name-Value Pairs returned length, area, and volume measurements as Floats. In Version X12, these values are reported 
using the Measurement class that includes both a numeric value and a unit. Older Ruby code may change behavior when 
migrated into Version X12. When a legacy Ruby macro or materials list formula is evaluated, the program will 
automatically check its version and prompt you to migrate it to the newest version.                

 4.  Units of Measurement
In Chief Architect X11 and prior, units of measurement used by the program, including user-defined units,  were stored 
in a file called Units.dat located in the Chief Architect Data folder. Beginning in version X12, this information is saved 
with other Preferences settings. 
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FOR FILES CREATED IN VERSION              X10 AND PRIOR

In addition to the above recommendations, if you wish to open files created in Chief Architect Version               X10 or prior, bear in 
mind the following:

 1.  Marker and Elevation Point Heights          
In Chief Architect X10 and prior, the # sign could be added to the label of a Marker or Elevation Point and the label 
would report the height of the Marker or the Elevation Point’s elevation. In Version X14, text macros are used to report 
this information instead. In legacy plans, any # signs in Marker or Elevation Point labels will be replaced by the 
%heightf% or %elevationf% macro.  

 2.  Glass Shower Walls          
In Chief Architect X10 and prior, the “Glass Shower” wall type was included in installed template files and like other 
wall types, built to the structural layer of floors and ceilings and to the Main Layer of adjacent walls. In Version X14, 
this wall type has the new Partition Wall attribute and instead builds to floor, ceiling, and wall surfaces. When a legacy 
file is opened in Version X14, this wall type will be modified to have Partition Wall checked automatically and existing 
walls will be affected by this change.  

 3.  Fixture Schedules          
In Chief Architect X10 and prior, 3D Elevations and Perspectives in Fixture Schedules showed cabinet fixtures inserted 
into a cabinet. In Version X14, fixtures are shown on their own, even when they are inserted into an object in the plan. 
When a legacy file is opened in Version X14, any fixture schedules showing 3D views of objects may be affected by 
this change. 

FOR FILES CREATED IN VERSION X9 AND PRIOR

In addition to the above recommendations, if you wish to open files created in Chief Architect Version               X9 or prior, bear in 
mind the following:

 1.  Parallel Lights          
In Chief Architect X9 and prior, Parallel Light sources could be specified for electrical light fixtures and Added Lights. 
In Version X14, Parallel Lights are no longer supported. In legacy plans opened in Version X14, any Parallel Light 
sources will be converted to Spot Lights.  

 2.  Brick Ledges          
In Chief Architect X9 and prior, brick ledges were not represented in plan view. In Version X14, brick ledges are drawn 
in plan view on the “Slabs” layer in stem wall and grade beam foundations, and on the “Walls, Foundation” layer in 
monolithic slab foundations. When a legacy file is opened in Version X14, brick ledges, if present, will be drawn.                

 3.  Window Types          
In Chief Architect X9 and prior, the %type% text macro for windows reported some Window Types using abbreviations. 
In Version X14, the abbreviations were replaced with full words. When a legacy file is opened in Version X14, the 
width of Window Schedules may be affected, as may the width of columns in saved Materials Lists. 

 4.  Joist Direction Lines          
In Chief Architect X9 and prior, Joist Direction Lines described all platform framing as “joists” and used nominal 
lumber sizes in whole inches in US Unit plans. In Version X14, the platform’s framing Structure Type is reported and in 
US Unit plans, the size is described in fractional inches. When a legacy file is opened in Version X14, Joist Direction 
Lines will use the new, more accurate labeling.  

 5.  Custom Schedule Columns          
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In Chief Architect X9 and prior, custom schedule columns could be created by adding a Sub Category to a type of object 
on the Categories panel of the Preferences dialog. In Version X14, Sub Categories can no longer be created in this 
manner. When a legacy file is opened in Version X14, any Sub Categories shown as custom schedule columns will be 
converted to Custom Fields. 

 6.  Registered User Text Macros          
In Chief Architect X9 and prior, a selection of Registered User Text Macros could be inserted into Texts, Callouts, and 
Markers. These macros no longer displayed any data and in Version X14, they are no longer recognized. When a legacy 
file is opened in Version X14, any Registered User macros inserted into text objects are treated as regular text. 

FOR FILES CREATED IN VERSION X8 AND PRIOR

In addition to the above recommendations, if you wish to open files created in Chief Architect Version X8 or prior, bear in 
mind the following:           

 1.  Layer Names          

In Chief Architect X8 and prior, turning off the Modify Name in all Layer Sets option made it possible to assign different 
names to the same layer in different layer sets. In Version X9, this option was no longer supported. When a legacy file is 
opened in X14, the layer names used in the currently active layer set will be retained and any other layer names in other 
layer sets will be discarded. 

FOR FILES CREATED IN VERSION X7 AND PRIOR

In addition to the above recommendations, if you wish to open files created in Chief Architect Version               X7 or prior, bear in 
mind the following:

 1.  Boxed Eaves          
In Chief Architect X8, improvements to the generation of Boxed Eaves ensure that they extend into exterior rooms with 
“Use Soffit Surface for Ceiling” specified when located between the roof baseline and an interior room. In some legacy 
plans opened in Version X14, the Length value for Boxed Eaves may need to be modified in the Roof Plane 
Specification dialog.  

 2.  Uppercase Text          
The Uppercase option was added to Text Styles in Version               X8, whereas in Version X7 and prior, it was an option for 
Room Labels and Schedules only. In legacy plans opened in Version X8, any Schedules present in the drawing will be 
assigned a Custom Text Style, as will their associated Schedule Defaults. If any Schedule Default is set to Use Layer for 
Text Style and no objects are present on that layer, a new Schedule Text Style will be created and assigned to that layer. 
Room Labels are treated similarly: if any are present, they and their defaults will use a Custom Text Style. If a given 
Room Label or Schedule has been sent to layout more than once and was set to use different Text Styles in each layout 
view, it is possible that its appearance may be affected in some views.  

FOR FILES CREATED IN VERSION               X6 AND PRIOR

In addition to the above recommendations, if you wish to open files created in Chief Architect Version               X6 or prior, bear in 
mind the following:

 1.  Built-in Appliances          
In Chief Architect X6 and prior, some appliance symbols designed to be inserted into base cabinets had incorrect sizing 
data. In legacy plans opened in Version X14, these appliances will not fit into the cabinet correctly and will need to be 
replaced. Built-in dishwashers are particularly affected. 

 2.  Formatting of Bulleted and Numbered Lists          
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In Version X7, various improvements were made to the way lines of Rich Text are spaced. In legacy plans opened in 
Version X7, Rich Text objects with bulleted and numbered lists may require adjustments. 

 3.  Chief Blueprint Font
The Chief Blueprint font was improved for Version X6, with decreased top and bottom spacing. The change in spacing 
may increase the overall height of text objects using this font in X6 files opened in Version X14. X5 and prior legacy 
files will not be affected by this change. 

FOR FILES CREATED IN VERSION X5 AND PRIOR

In addition to the above recommendations, if you wish to open files created in Chief Architect Version X5 or prior, bear in 
mind the following:          

 1.  Name-Value Pairs for Doors and Windows          

In Version X6, the NVPs door_style_name, door_type_name, and window_type_name were shortened to style_name and 
type_name. Any object labels or text macros using these NVPs in legacy plans opened in Version X14 will need to be 
replaced.                

FOR FILES CREATED IN VERSION X4 AND PRIOR

In addition to the above recommendations, if you wish to open files created in Chief Architect Version X4 or prior, bear in 
mind the following:

 1.  Roof Overhangs and Framing          
In Chief Architect X4 and prior, roof overhangs were measured to the outside of the subfascia, whereas in Version X5 
and later, they are measured to the outside of the fascia or shadow boards, if present. In legacy plans opened in Version 
X14, this will not affect the appearance of roof planes in floor plan view because in X4 and prior, roof plane polylines 
represented the projected framing area whereas in Version X14 they represent the total projected area. But, the position 
of the fascia and subfascia will shift, as will the length of the rafters. 

 2.  Door Swing Direction and Materials          
In Chief Architect X4 and prior, exterior doors that swing outward displayed the interior material on the exterior side of 
the door. This was corrected in Version X14. Doors modified to work around the old behavior could be affected in 
legacy plans opened in Version X14. 

 3.  Door Swing Direction and Louvers          
Improvements to door louver direction may affect louvers in all doors with the exception of bifold doors. 

 4.  Wrapped Door/Window Lintels and Window Sills         
In Chief Architect X4 and prior, wrapped lintels and sills extended out further than those that were not wrapped. In 
legacy plans opened in Version X14, the extents of wrapped lintels and sills will be adjusted so that they equal their 
Extend setting. 

 5.  Cabinet Feet          
The offsets for cabinet foot millwork symbols in Version X4 and prior were set per millwork symbol to insert into 
cabinets effectively. In Version X14, the offset is set in the Cabinet Specification dialogs. When legacy plans are opened 
in Version X14, cabinet foot offsets are set to 0 and transferred to their containing cabinet, if one exists. Any customized 
or independently placed cabinet feet will be affected.                

 6.  Object Labels in Cross Section/Elevation Views          
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If a “Label” layer is turned on in a cross section/elevation view and objects of that type are visible in the view, then 
those objects’ labels will display in that view when the plan is opened in Version X14. 

 7.  Transparent Materials          
In Chief Architect X4, materials assigned to the Transparent Material Class for ray tracing were visible in rendered 
views even when their Index of Refraction was set to 1.0. When legacy plans are opened in Version X14, Transparent 
materials with an Index of Refraction of 1.0 are transferred to the General Material class and assigned a Transparency 
value of 100%. This will not affect these materials’ appearance in ray trace views, but will make them completely 
invisible in rendered views. 

 8.  Registered User Text Macros          
In Chief Architect X4 and prior, a selection of Registered User Text Macros could be inserted into Texts, Callouts, and 
Markers. These macros reported information that was provided when the program was installed and registered on the 
computer. In Version X5 and later, the program no longer collects registered user information. When a legacy file is 
opened in Version X14, any Registered User macros inserted into text objects are treated as regular text. 

 9.  Invisible Beams          
The legacy Invisible Beam check box was removed from the Wall Specification dialog. When legacy plans are opened 
in Version X14, any Invisible Beam walls will be converted to Invisible Walls. 

FOR FILES CREATED IN VERSION X3 AND PRIOR

In addition to the above recommendations, if you wish to open files created in Chief Architect Version               X3 or prior, bear in 
mind the following:

 1.  Text Styles          
The appearance of a number of objects that include text - including object labels, the North Pointer, Sun Angles, Joist 
Direction Lines, the Up/Down arrows for stairs and ramps - can now be controlled using Text Style. Their appearance 
may be altered somewhat in legacy plans opened in Chief Architect X14. 

 2.  Light Sources          
The illumination created by light fixtures and Added Lights was improved in Chief Architect X14. Lighting in legacy 
plans may appear noticeably brighter when viewed in version X14. 

FOR FILES CREATED IN VERSION X2 AND PRIOR

If you wish to open files created in Chief Architect Version               X2 or prior, bear in mind the following file management 
changes and structural enhancements:

 1.  Legacy file formats          
Chief Architect9.5 and prior              files were saved in  .pl and .la the file formats. These file formats files are no longer 
supported and cannot be opened in version X14. 

 2.  Material textures, images, and backdrops          
Chief ArchitectX2              and prior installed with a catalog of library content, including a selection of material textures, images, 
and backdrops. This library catalog is no longer installed with the program because it is now available for download on-
demand, so it will be possible to open a legacy plan in version X14 and encounter numerous missing file warnings. To 
avoid this, we recommend using the Export Entire Plan feature in the original program version to create a folder that 
includes the plan and all associated textures, images, and backdrops before opening this file in X14. This tool is renamed 
Backup Entire Plan in version X14. 

 3.  Floor and ceiling finish thicknesses          
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In Chief Architect X2 and prior, floor and ceiling finish layers were not modeled in 3D, and objects such as railings, 
stairs, landings, cabinets, fixtures, and furnishings measured their Floor to Bottom height from the subfloor. These 
objects now measure their Floor to Bottom height from the floor finish surface by default, so it is possible that you may 
notice height changes for these objects - particularly in saved, annotated cross section/elevation views. 

 4.  Riser heights and landing thicknesses          
The default Best Fit Riser Height for stairs that do not reach the next level has been updated from 9” (225 mm) in 
version               X2 and prior to 6 3/4” (169 mm) in Chief Architect X14. This may affect the riser heights of stairs, as well as 
the thicknesses of landings attached to those stairs. 

 5.  Auto Adjust Height          
The Follow Terrain option in some specification dialogs was replaced by the Auto Adjust Height check box. If a cabinet, 
fireplace, fixture, furniture, or other library symbol had Follow Terrain unchecked in version               X2 or prior and was 
located in a room with a floor height other than the default for the current floor, then the object’s Floor to Bottom 
Height will change to equal that room’s floor height. The object’s position in the model will not change, however. 

 6.  Adjustable Thickness Walls          
In Chief Architect X2 and prior, generic, single-layer wall types were available for use. When a legacy plan file is 
opened in version X14 and these wall types are detected, they are replaced by an updated, non-generic wall type. 
Framed walls and Railings will also acquire 1/2” (13 mm) thick layers of sheetrock on each side. Railings that define a 
Deck room with Advanced Deck Framing Built will not acquire sheetrock layers. 

 7.  Stairwells defined by railings          
Interior railings that used a generic, single-layer wall type drawn in older program versions will acquire layers of 
sheetrock when the plan is opened in version X14. This can affect the appearance of staircases where they join to a floor 
platform. To address this issue, select the railing and move it 1/2” (13 mm) away from the top edge of the staircase. 

 8.  Deck rooms          
In legacy plans opened in Chief Architect X14, Deck rooms with Advanced Deck Framing built retain the framing but 
have Automatic Deck Framing turned off by default. Decks with no Advanced Deck Framing built are converted to 
Balcony rooms. 

 9.  Material definitions and light sources
Settings in the Define Material dialog that affect materials’ appearance of brightness have been modified. The Ambient 
setting was removed, and the Diffuse setting for materials in legacy plans will be set to 100% when opened in version 
X14.           
The Quality setting for light sources set to use Soft Shadows in ray tracing was also modified. Lights using Soft 
Shadows in legacy plans will be set to use Medium quality. The Light Diameter of light sources in legacy plans is 
capped at 4” (100 mm).               

 10.  Structural Member Reporting          
When a plan created in Chief Architect X2 or prior is opened in Chief Architect X14, Materials Lists are set to calculate 
Total Linear Length. For a combination of linear length and piece count, select Mixed Reporting in the Structural 
Member Reporting dialog. 

 11.  Fill New Framing Members          
In Chief Architect X2 and prior, Fill New Framing Members was view-specific; in Chief Architect X14 it applies to the 
entire plan. As a result, it is turned off by default in legacy plans opened in version X14. 
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 New and Improved Features by Chapter
The following is a list of new and improved features in Premier Version X14. Where possible, cross-references to additional 
information has been provided. 

PROGRAM OVERVIEW

 l The Startup Options dialog has been replaced by the new Dashboard window.

FILE MANAGEMENT

 l The new Linked View dialog allows you to link the Reference Display and linked callouts to views in currently open 
files.

PROJECT PLANNING

 l The Set as Default edit tool is now available for Construction Lines.
 l Referenced plans in camera views can now use the Technical Illustration and Vector View Rendering Techniques.
 l The Reference Floor can now be set to display the Current Floor.

PREFERENCES AND DEFAULT SETTINGS

 l New Dashboard options in the Preferences dialog.
 l New Enable Retina Render Targets option can be unchecked on systems that do not have Retina displays to avoid 

performance issues.
 l New Reset Templates option in the Preferences dialog restores the installed template plan and layout files.
 l New Unlink External References options and improved organization in the Save as Template dialogs.
 l The Size of Start and End Indicators can now be specified.
 l New Roof Gable Lines (Delete) option in the Reset to Defaults dialog.

TOOLBARS AND HOTKEYS

 l Redesigned Gamepad Settings dialog to be more compact.

WINDOW AND VIEW TOOLS

 l The Save Active View As tool is now available for cross section/elevation views.

CREATING OBJECTS

 l The Orthogonal Move and Concentric Resize edit handles are now available for a variety of CAD-based objects when 
the Copy/Paste edit tool is used 

DISPLAYING OBJECTS

 l New Merge option in the Layer Display Options dialog and Active Layer Display Options side window.
 l CAD Block windows, including those associated with CAD blocks saved in the Library, now use the current file's 

CAD Block Detail Layer Set.
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 l The Opacity of the Selection and Edit Handle Colors set in the Preferences dialog can now be specified. See Color 
Chooser/Select Color Dialog on page 204.

EDITING OBJECTS

 l Predictive editing feedback has been added for a variety of different editing tools.
 l The Trim Object(s) and Extend Object(s) edit tools are now available for 3D Solid objects.
 l New Relative Angle to Itself and Absolute Angle options for moving objects using the Transform/Replicate Object 

edit tool.
 l The Retain Original Objects message box now contains a Cancel button.

CAD OBJECTS

 l CAD polylines can now be included in schedules.
 l The CAD Block Management dialog can now be accessed when a 3D camera view or overview is active.
 l The buttons in the CAD Block Management dialog now have tool tips.
 l New Fraction Style and Fraction Text Size settings and a Format Preview in the Displayed Line Length Format 

dialog.
 l New lateral arrowhead styles for use with Lines with Arrow and Dimension Lines.
 l New Circumference setting in the Circle Specification dialog.

WALLS, RAILINGS, AND FENCING

 l New Use Framing Reference option for individual walls.
 l New Reverse Stud Rollout Direction and Offset settings for individual walls.
 l The Top and Bottom Plate Count and vertical Plate Thickness can now be specified for each wall type.
 l The redundant Show Wall Length When Editing option was removed from the General Wall Defaults dialog.
 l New Treat as Part of Bay/Box/Bow Window Roof options for walls.
 l New Include Frieze option for walls allows you to suppress frieze moldings.
 l A custom Fill Style for wall footings can now be specified.
 l Wall footings can now be placed on a custom layer.
 l New Maximum Sill Plate Length setting.
 l Brick ledge lines in plan view are now drawn on the "Brick Ledge Lines" layer.

ROOMS

 l New Maximum Plank Length setting for Deck rooms.

DIMENSIONS

 l Dimension line specification and defaults dialogs now have a preview pane.
 l New Fraction Style and Fraction Text Size options for dimension lines.
 l Improved interface of Wall Options on the LOCATE panels of the Dimension Defaults dialog.
 l Redesigned EXTENSIONS and SEGMENTS panels in the Dimension Line Specification dialog.
 l New Same Angle as Dimension and Offset settings for Centerline marks.
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 l The Dimension Text Position and Orientation settings moved to the DIMENSION panel of the Dimension Line 
Specification dialog, and the GENERAL panel of the Dimension Defaults dialog.

 l The Auto Interior Dimension tool has been renamed Auto Room Dimension.
 l Auto Room and Auto Elevation Dimensions now have an Outer Dimension option.
 l New Same Angle as Dimension and Offset from Extension default settings for Centerline symbols.

TEXT, CALLOUTS, AND MARKERS

 l Callouts can now be linked to and report information about views and layout pages.
 l New Shape Angle and Text Angle settings in the Callout Specification dialog.
 l New Generate Angle from Schedule, Shape Angle and Text Angle settings in the Note Specification dialog.
 l Callout Cross Section Lines can now have arrows.
 l New Add Text Line with Arrow edit handle for text and callout objects.
 l Notes that are not associated with a schedule now have a Caution symbol and contextual menu.
 l The Add an Arrow setting in the Rich Text and Text Specification dialogs now matches the text's Align setting.
 l New Auto Adjust Text Direction option in the Callout and Marker Specification dialogs.
 l The Replace from Library edit tool is now available for Text objects.
 l Macros that are not valid in the current context now display as inactive in the menu that displays when the Insert 

Macro button in various dialogs is clicked. These macros are still available and can be inserted.

DOORS AND WINDOWS

 l The new Explode Bay/Bow Window  edit tool explodes Bay, Box, and Bow Windows into their component parts.

 l Bay, Box, and Bow Windows can now be copied and pasted.
 l The Reflect About Object edit tool is now available for Bow Windows.
 l New ROUGH OPENING panel in the specification dialogs for doors and windows. 
 l King Stud Count can now be specified for doors and windows.
 l Setting the default Window Level to 1 or higher no longer results in the Window tool placing transom windows.
 l Shutters can now be specified for Bay/Box/Bow component windows.
 l Shutters are now drawn in plan view, and the new "Shutters" layer controls the display of window and door shutters in 

plan and 3D views.
 l Shutters can now be set to Draw Closed and have a setting for Louver Size.
 l When wall framing is generated, a door's Bottom Rough Opening is no longer added to the Top Rough Opening when 

the Floor to Bottom value cannot accommodate it.
 l The rough opening for a pocket door's "pocket" side is now reduced by the Jamb Side Width value when framing is 

generated.

CABINETS

 l The Backsplash to Base Below check box has been deprecated and is only available in legacy plan files if it was 
checked in a wall cabinet's specification dialog in the original program version.

 l Cabinet door Swing Angle can now be opened from 0° to 180°.
 l The names of cabinet doors, drawers, and appliances are now stated on the FRONT/SIDES/BACK panel of the Cabinet 

Specification dialog. 
 l The size and orientation of cabinet hardware can now be customized.
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 l Automatic and Custom Countertops, Custom Backsplashes, and holes in both object types can now be included in 
schedules.

 l New Include Countertop in Schedule and Include Backsplash in Schedule options in the Base Cabinet 
Specification dialog.

SCHEDULES AND OBJECT LABELS

 l Schedules now support different Text Styles for their title, column headers, and body.
 l New Swap Rows/Columns option in the Schedule Specification dialog.
 l Objects listed in a schedule can now display their regular object label instead of or in addition to their schedule callout 

label.
 l Schedule callout labels can now be placed on custom layers.
 l New Shape Angle and Text Angle settings in the Schedule Specification dialog allow both callout labels and their 

text to be rotated together or independently.
 l New Top and Bottom Margin settings for the text in schedule cells.
 l New Auto Adjust Text Direction option for object labels.
 l New Reference setting for layout box, cabinet, symbol object, and architectural block labels.

FOUNDATIONS

 l The Pier/Pad Specification dialog now has the OBJECT INFORMATION and LABEL panels.
 l Round Piers and Square Pads can now be added to schedules.
 l Slabs can now be added to schedules.

STAIRS, RAMPS, AND LANDINGS

 l The Handrail Options for staircases are now located on the RAILING panel of the Staircase Specification dialog.
 l The Walk Line for a staircase is now drawn on the same layer as the staircase.

ROOFS

 l The Pitch in Degrees setting has been added to the Build Roof dialog.
 l The Dormer Specification dialog now has a Define button for wall types.

FRAMING AND TRUSSES

 l New Export to EasyFrame  tools export wall framing to the .ezf format for marking and cutting using the 

EasyFrame saw.
 l New Include Structural Purlins option produces pocket purlins between rafters.
 l New Build All Framing  tool.

 l Framing can now be located by dimension lines as they are drawn in elevation views.
 l The Maximum Length can now be specified for rim joists, wall plates, and girts. 
 l Each floor level can now have its own Framing Reference Marker.
 l The Energy Heel option for roof trusses is now available in the Framing Defaults dialog.
 l New Roof Overframing options and Shoe Plate size settings for roof framing.
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THE LIBRARY

 l New Replace from Library Scoping Modes when replacing inserted objects in a plan with an object from the Library 
Browser.

OTHER OBJECTS

 l Floor Material Regions, Wall Material Regions, and Custom Backsplashes can now be included in schedules.
 l Polyline Solids and 3D Boxes have been replaced with a single 3D Solid  tool.

 l Shape objects are now referred to as 3D Solids.
 l The 3D Solid Specification dialog now has the POLYLINE, SELECTED LINE/ARC, and LABEL panels.
 l 3D Solids can now be drawn against walls in camera views.
 l Angular Dimensions can now be used to reshape 3D Solid objects.
 l The Retain Aspect Ratio setting is now retained in the 3D Solid Specification dialog, but not other dialogs.
 l The LABEL panel was added to the specification dialogs for Primitive objects.
 l Primitive objects now have CAD Stops Move and Wall Stops Move settings in their specification dialogs.
 l New Fillet Edges , Fillet all Edges , Chamfer Edges , and Chamfer All Edges  edit tools for 3D 

Solids.

MATERIALS

 l The Pattern From Texture dialog now lets you choose a material map or other image file as the source for a custom 
material pattern.

 l The obsolete "Framing" Material Type has been removed.

3D VIEWS

 l Improved rendering on Retina displays in the Mac version of the software.
 l Sunlight can now be toggled off in the Camera and Cross Section/Elevation Specification dialogs.
 l Cross Section/Elevation camera symbols can now be offset from the center of their clip plane.
 l Technical Illustration renderings can now display Surface Edge Line colors using layer or object settings.

3D RENDERING AND RAY TRACING

 l Sun Angles can now be copied and pasted.
 l The Opaque Window Glass setting now affects windows and interior doors only.

PICTURES, IMAGES, AND WALKTHROUGHS

 l The Record Walkthrough Options dialog for Walkthrough Paths now has a Save to Chief Architect Cloud option.
 l The Walkthrough Path Specification dialog now has Use Sunlight and Adjust Sunlight options.
 l Enhanced Spherical Panoramic Backdrop settings for camera views.
 l Images, Backdrops, and Materials created using the Screen Capture tool now reference image files with date and time 

stamps.
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IMPORTING AND EXPORTING

 l Chief Architect Account Login is now retained between program sessions.
 l Added support for AutoCAD® 2022 and 2023 file import and export.
 l The Export 360 Panorama File dialog now has Create New and Replace Existing option when saving to the Chief 

Architect Cloud.

TERRAIN

 l Terrain objects can now be included in schedules.

MATERIALS LIST

 l The full program menu is now accessible in Materials List windows, with a variety of additional tools available for 
use.

 l The Board Sizes table in the Structural Member Reporting dialog is now sortable by column.

LAYOUT

 l New Layout Box Defaults dialog.
 l Layout box labels can now use callouts or markers that link to other pages or views.
 l New LINKED VIEW, BOX SCALE and LAYER SET panels in the Layout Box Specification dialog.
 l New Layout Box Defaults dialog lets you set up the default line, fill, and label style for layout boxes..
 l Camera views and cross section/elevation views sent to layout can now be rotated on the layout page.
 l New Scale Layout Box Contents Only setting controls whether the layout box resizes when its view is rescaled.
 l New Pan/Scale Layout Box , Recenter Layout Box Contents , and Scale Layout Box Contents to Fit  

edit tools for selected layout boxes.
 l The deprecated Dimension Number Height setting for plan views sent to layout has been removed from the program 

except in some legacy layout files.
 l There is no longer a prompt to update the view on the layout page when a camera view is closed.

RUBY IN CHIEF ARCHITECT

 l New Name-Value Pairs for  CAD Circles, walls, cabinets, Callouts, and layout box labels.
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Update to  1333
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3D Molding Polyline  952
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Render Panel  129
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Curbs  1296
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Wall Intersections  165

Snap Properties
Preferences  122

Soffit
Defaults  1033
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