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Chapter 1:

Program Overview

The Chief Architect Viewer can be used to 
view and add commentary to Chief Architect 
drawings in either plan or layout file format, 
facilitating  the communication process 
between design professionals and their 
clients. The Chief Architect Viewer offers 
many useful features:
• Open and explore plan and layout files 

created by Chief Architect software.
• Modify the display of the plan to see 

more or less detail.
• Create 3D views of the full model.
• Add notes to the drawing for review by 

your design professional.
• Print from any view.
• Export views as either picture files or 

Windows metafiles for use in other pro-
grams.

• Search for plans in a plan database.

If you would like to learn more about Chief 
Architect, select Help> Visit Chief 
Architect Web Site  from the program 
menu.

Chapter Contents
•      Startup Options
•      The Chief Architect Viewer Environment
•      Using the Mouse
•      View Windows
•      Toolbars and Hotkeys
•      Menus
•      Dialogs
•      The Status Bar
•      Message Boxes
•      Viewing a Plan
•      Color Chooser Dialog
•      Getting Help
•      About Chief Architect
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Startup Options
When the Chief Architect Viewer 
opens, the Startup Options dialog 

displays, allowing you to choose how you 
want to begin working in the program or 
access useful resources. 

The Startup Options dialog can be opened at 
any time by selecting File> Startup 
Options .

 or New Layout Choose Open Plan 

 or Open Layout  to view a plan 
or layout file. See “Opening a Plan or Layout 
File” on page 22. 

Recent Files lists the full pathnames of 
the most recently opened files. Click on 

a name to open the file. 

Click Getting Started to launch your 
default internet browser to the Getting 

Started page on our web site. There, you will 
find links to a variety of online resources 
with information about Chief Architect Pre-
mier X10.

1

2

Move your mouse pointer over a name
to see the file’s full pathname. 

3
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When an internet connection is 
available, the Announcements section 

displays updated messages and news from 
Chief Architect. 

Click My Account to launch your 
default internet browser to the Log In 

page on our web site. 

Your software version’s Build number 
displays here for reference.

The Chief Architect Viewer Environment
You can access Chief Architect Viewer’s 
features in various ways using the mouse and 
keyboard. 
• The program’s tools are accessed using 

the menus and toolbar buttons.

• Keyboard shortcuts are available for most 
tools.

• Contextual menus display with a right-
click of the mouse.

• The Status Bar at the bottom of the screen 
provides tool descriptions and other 
information about the current task. 

4 5

6
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Using the Mouse
Most of the program is controlled using the 
mouse. Objects and most views are created 
by either clicking the left mouse button or by 
dragging the cursor in the direction of a 
desired view. The Status Bar at the bottom 
of the Chief Architect Viewer’s main 
window indicates which tool is active.

The left button is the primary 
button used in the Chief Architect 
Viewer. Unless specified otherwise, 
Chief Architect Viewer 

documentation refers to the left mouse 
button.

The Right button has several uses. 

Right-click to select any object.If, for 

example, the Full Camera  tool is active, 
the left mouse button only allows you to 
click and drag to create camera views. You 
can select other object types such as text with 
the right mouse button.

You can also use the right mouse button to 
open a context sensitive menu with 
additional editing commands. See 
“Contextual Menus” on page 13.

The Middle button can be used to 
pan in most view types. To close a 
tabbed view window, click on its tab 
using the middle mouse button. You 

can also program it to work as a double-
click.

If your mouse does not have a middle mouse 
button, in the Mac version of Chief Architect 
Viewer you can use the left button and the 
Command key to achieve the same results.

The Mouse Wheel can be used to 
zoom in and out in most view types. 
See “Zoom Tools” on page 37.

3D Mice
3Dconnexion®'s 3D mice can be used to nav-
igate in Chief Architect Viewer. For informa-
tion about navigating in camera views and 
overviews, see “3Dconnexion® 3D Mice” on 
page 56.

Using a Trackpad
In addition to the standard trackpad gestures 
on your system, in Chief Architect Viewer 
you can pinch to zoom. 

In macOS™, you can Command + click to 
pan. Panning is not supported in the 
Windows version of the software, however.

Touch Screens
Standard one-finger touch screen gestures 
are supported in both the Windows and Mac 
versions of the software. In the Windows 
version, touching with a second finger to 
cancel an action is also supported, as are 
two-finger pan and two-finger pinch to 
zoom. 

Note: If you are left-handed and have re-pro-
grammed your mouse, reverse the instruc-
tions for left and right buttons in this manual. 
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Edit Handles
When you select an object, its edit handles 
display. 

When you pass the mouse over an edit 
handle, information about what the handle 
does displays in the Status Bar and the 
pointer changes to show how you can use 
that handle. 
• A two-headed arrow indicates that the 

object, corner or edge can be moved in 
the direction of the arrows. 

• A four-headed arrow indicates that the 
selected object or edge may be moved in 
multiple directions. 

• A circular arrow indicates that the 
selected object can be rotated.

Resize handles display along the edges of the 
object are used to change the size. 

The Move handle at the object’s center lets 
you move the object. Depending on the type 
of object(s) selected and how far you are 

zoomed in or out, the position of the Move 
handle may shift so that it remains on-screen. 

The triangular Rotate handle lets you rotate 
the object. 

You can cancel any edit handle operation 
before it is completed by pressing the Esc 
key on your keyboard or by pressing any two 
mouse buttons at the same time. 

The edit handles that display depend on the 
type of object selected, the current view, and 
how far you are zoomed out. 

Edit handles do not resize as you zoom in or 
out. If you are zoomed out far enough, some 
edit handles may be hidden so that they do 
not stack over one another. As you zoom in, 
these handles become visible again.

View Windows
View windows are sometimes referred to as 
“the drawing area” because most of them are 
windows in which you can draw or place 
architectural and/or CAD objects. There are 
a number of different types of view windows 
in the Chief Architect Viewer:

• Plan views
• Camera views and overviews
• Cross section/e

View windows can be navigated by panning 
and zooming. You can also enable scroll bars 
on their right side and bottom. Select View> 
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Scrollbars  to toggle their display. See 
“View Tools” on page 37. 

Although only one view window can be 
active at any given time, there is no limit to 
the number of view windows that can be 
open. View windows can be tiled or tabbed, 
and you can navigate between them in a 

number of different ways. See “Window and 
View Tools” on page 33.

You can also tear a view window out of the 
main program window. This creates a 
second, separate program window complete 
with toolbars and menus.  Individual view 
windows can be torn out and transferred 
between program windows. 

Toolbars and Hotkeys
The Chief Architect Viewer installs with a 
set of toolbars docked to the top, right side 
and bottom of the program window. Using 
the toolbar buttons is the fastest, easiest way 
to access many program features. If a tool is 
active, a small checkmark will display at the 
lower left of its button icon. When you pass 
the pointer over a toolbar button, a “tool tip” 
displays the name of the tool and a more 
detailed description displays in the Status 
Bar at the bottom of the program window. 
When you see one of these tool tips, press the 
F1 key to get more information about that 
item. See “Getting Help” on page 18. 

Click on the arrow to the right of a button to 
display a drop-down list of related tools. For 
example, click the arrow to the right of the 

Full Camera  button to display a drop-
down list of the other 3D View Tools.

You can, if you wish, move any toolbar to a 
different location.  Toolbars can be docked to 
any side of the program window, or they can 
be undocked and left floating.  Undocked 
toolbars can also be moved outside of the 
program window. 

Toolbar locations are saved between program 
sessions. 

The Edit Toolbar
When you select an object, the edit toolbar 
appears. By default, it is located at the 
bottom of the program window, just above 
the Status Bar. The buttons on the edit 
toolbar can be used to edit the selected 
object(s). Which buttons display depends on 
the type of object selected, the current view, 
and how you selected the object.

The edit toolbar buttons are the same as the 
options in the contextual menu when you 
right-click on an object. See “Contextual 
Menus” on page 13.
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Hotkeys
Many commands can be invoked from the 
keyboard.  Press Alt on your keyboard and 
press the underlined letter in a menu name to 
access that menu, as well as items in the 
menus and submenus. 

Other keys or key combinations will invoke a 
variety of program commands. If a Chief 
Architect Viewer menu item has a keyboard 
shortcut, or hotkey, associated with it, that 
hotkey will display to the right of its name in 
the menu.

Menus
The Chief Architect Viewer uses a standard 
Windows menu format. The menus are 
located below the title bar in the program 
window and can be used to access nearly all 
tools in the program. Click on a menu name 
to expand it, then click on a menu item to 
either activate that tool or access the item’s 
submenu. Items with a submenu have an 
arrow to the right of the name.

Menu items with an icon to their left have a 
toolbar button associated with them.

The menus can be accessed using the 
keyboard. Press the Alt key once to enable 
this functionality - one letter in each menu 
will become underlined. Press the key 
associated with one of these underlined 
letters to expand its menu - one letter in each 
menu item’s name will be underlined. Press 
the key associated with one of these letters to 
activate that tool or access the item’s 
submenu. Press the Esc key to undo your last 
selection, or click with the mouse to exit out 
of this functionality. 

Many tools in the Chief Architect Viewer 
also have hotkeys associated with them. If a 
menu item has a hotkey, it will display to the 
right of the item’s name. 

In the Chief Architect Viewer 
documentation, menu paths are written in 
this format: Tools> Layout Page> Up 

Page .  

Contextual Menus
Contextual menus are context-sensitive 
menus that display tools relevant to a 
selected object or view. To open a contextual 
menu, right-click on an object, in an empty 
space in a view window, or in a text field in a 
dialog box.

The options in an object’s contextual menu 
are usually the same as those on an object’s 
Edit toolbar. See “The Edit Toolbar” on page 
12.

Edit menu items with button icons 
to the left and hotkeys to the right
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Dialogs
Many functions in the Chief Architect 
Viewer are accessed through dialog boxes. 

Dialog panels and settings can be accessed 
using the mouse. You can also navigate the 
settings on a given dialog panel using the 
keyboard. For example:
• Line items in tree lists can be browsed 

using the arrow keys. Up and Down navi-
gate the list, while Left and Right expand 
and contract categories.

• Press the Tab key to shift focus from the 
tree list to the first setting on the selected 
panel. 

• Press the Tab key to shift focus from one 
setting to the next, or Shift + Tab to go in 
the reverse direction. 

• A check box can be checked or cleared 
by pressing the Spacebar or the + or - 
keys, respectively, while it is in focus. 

• Columns of radio buttons can be navi-
gated using the Up and Down arrow 
keys; rows can be navigated using the 
Left and Right arrows. Select a radio but-
ton by pressing the Spacebar while it is in 
focus.

• Settings in list boxes can be navigated 
using the Up and Down arrow keys. 
When a checkbox is in focus, it can be 
checked or cleared by pressing the Space-
bar. 

• Drop-down lists can be browsed using 
the Up and Down arrow keys. When the 
mouse pointer is directly over the drop-
down, the mouse scroll wheel can also be 
used; on a Mac, the list must also be 
expanded. In Windows only, you can 

press Tab to select the highlighted item in 
the list and proceed to the next setting. 

• Settings with spin control arrows  can 
be adjusted by typing in the text field or 
using the Up and Down arrow keys. 
When the mouse pointer is directly over 
the setting, the mouse scroll wheel can 
also be used.

• Slider bars  can be adjusted by typ-
ing in the text field or using the Left and 
Right arrow keys. When the mouse 
pointer is directly over the slider bar, the 
mouse scroll wheel can also be used.

• Line items in tables can be group selected 
using the Ctrl or Shift keys, or by press-
ing Ctrl+A.

• Press Enter on your keyboard to close 
most dialogs and apply your changes.

In the Mac version of the software, Dictation 
is supported in dialogs. Select Edit> Start 
Dictation, then open a dialog. Say the word 
“Numeral” before a number to enter it as a 
numeric value or immediately follow a 
number with a unit such as “foot” to enter it 
as a measurement. 

Specification Dialogs
Each object that you can draw in the 
Chief Architect Viewer has a unique 

specification dialog where you can enter 
size, style and other information specific to 

Note: Keyboard navigation in dialogs may
vary somewhat depending on your computer
platform. 
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the selected object. To access it, select the 
object and click the Open Object edit 
button. 

You can also double-click on an object with 

the Select Objects  tool active to open its 
specification dialog. 

The Status Bar
The Status Bar at the bottom of the main 
program window displays information about 
the current state of the program. 

This information depends on a variety of 
conditions such as the type of object 
selected, and the current position of the 
pointer. The information may include the 
following:
• The type of object currently selected or 

the total number of group-selected 
objects. 

• A description of the edit handle that the 
pointer is over.

• A brief description of the toolbar button 
or menu item highlighted by the mouse.

• The name of the active tool and its hot-
key, if it has one.

• The length and/or angle of an object as it 
is being drawn.

• Basic information about a selected library 
object, folder, or catalog.

• The current floor.
• The layer that the selected object is on.
• The size of the active window in pixels.

Message Boxes
As you work in the Chief Architect Viewer, 
the program will occasionally prompt you to 
examine your settings, alert you if you 
command it to do something that could 
potentially cause a problem, or notify you if 
it encounters a problem that needs your 
attention.

Situations where such message boxes may 
display include: 
• Closing a file or view without saving;
• A file referenced outside the program, 

such as an image or texture, is missing.

As with dialog boxes, you can access the 
options in a message box using the mouse or 
navigate them using the keyboard.

A few messages have a Send Report button. 
Click this button to send details regarding the 
issue that prompted the message to Chief 
Architect via the internet. 

Some message boxes include a “Remember 
my choice” or a “Do not show this again” 
checkbox. Check this box to prevent 
messages of this specific type from 
displaying in the future. When this box is 
checked, some options in the message box 
may become inactive.
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Viewing a Plan
You can see a model in a variety of different 
2D and 3D views. You can display more than 
one view at a time; and in any view, you can 
pan or zoom in or out. See “Window and 
View Tools” on page 33. 
Floor plan view is a 2D view of the model. 
Each floor displays separately; however, you  
can control which objects display at any given 
time, can easily switch between floors, and 
can also display items on a second floor for 
reference. See “Multiple Floors” on page 29.

You can create interior and exterior 3D views 
of a model from any perspective. As in floor 
plan view, you can control which objects are 
visible. See “3D Views” on page 47. 

All views can be exported as a graphic 
image. See “To export a picture” on page 86.

Layout Files
Layout files are used to produce printed 
construction documents by displaying 
multiple views of the model in combination 
with a variety of written information on 
multiple sheets. Only one layout file can be 

open at a time. See “Working in Multiple 
Views” on page 34. 

To open a layout file, select File> Open 
Layout . Browse to a directory and select 
the layout file to open. See “Opening a Plan 
or Layout File” on page 22.

The current page is indicated at the center of 

the Layout Page  buttons. 

To navigate between layout pages
• Click the arrow buttons on either side of 

the Layout Page  button. 
• Click the Current Page number between 

the arrows to open the Go To Layout 
Page dialog. Enter a page number and 
click OK.

• Select Page Up or Page Down from the 
Tools> Layout> menu.

• Press Shift + N (up one page) or Shift + 
M (down one page) on the keyboard.

Tape Measure
Use the Tape Measure tool to draw a 
temporary dimension line between 

any two points in the drawing area. The tool 
will place temporary markers at the start and 
end points of the dimension line. These 
points and the line both disappear when you 
release the mouse button. If an object is 
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located by the temporary line, you can snap 
to it.

Color Chooser Dialog
The Color Chooser dialog is opened 
by clicking the Color button in the 

Text Specification dialog or on the Color bar 

on the LINE STYLE and ARROW panels of the 
Line Specification dialog. See “Text” on 
page 71. 

The currently selected color displays in 
the rectangle at the lower center of the 

dialog. There are a number of ways to select 
a color in this dialog. 

Click in any one of the Basic colors 
boxes to select it.

Click anywhere in the color spectrum 
area to select a color. 

• The location of a selected color is identi-
fied by a black cross hairs and its Hue, 
Saturation, and RGB values will display 
below and update as you click.

• Click anywhere in the vertical bar or drag 
the arrow to adjust the selected color’s 
Luminosity and RGB values.

Define the selected color by specifying 
its Hue, Saturation, and Luminosity 

(HSL) or its Red, Green, and Blue (RGB) 
values.

Click in one of the Custom colors 
boxes to either select it as the new color 

or to specify it as the box for a new custom 
color to be defined. 

Click the Color Chooser Eyedropper, 
then click anywhere on your monitor to 

select the color displaying at that location. 

1

2

3

4

5

6
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Click OK to apply the current selected color 
to the Text or Line with Arrow’s line or fill 
style.

Getting Help
There are many forms of help available in the 
Chief Architect Viewer including: Tool Tips, 
the Status Bar, and the online Help menu. 

All these forms of help assume you have a 
basic working knowledge of your operating 
system, including how to use a mouse, open, 
close and save files, copy, paste, and right-
click to access contextual menus. Help also 
assumes you are familiar with basic 
computer terminology.

More information is available in the product 
documentation in electronic format and on 
Chief Architect’s official web site,  chiefar-
chitect.com. 

Tool Tips
When you move the pointer over a toolbar 
button or menu item, a Tool Tip displays, 
offering a brief description of the tool. More 
information displays in the Status Bar at the 
bottom of the window.

Contextual Help
Online Help is a searchable menu that 
provides information about all of the 

tools in the Chief Architect Viewer. Select 
Help> Launch Help to open the program’s 
Help and explore the table of contents, 
browse the Index, or Search for keywords.

The Help can also be used to provide instant 
information about toolbar buttons, menu 
items, and objects in your plan.

• When you move the cursor over a toolbar 
button or menu item, a brief summary of 
that tool displays in the Status Bar. Press 
the F1 key to open online Help to a page 
with more information about the tool.

• When an object is selected, edit handles 
display. Place the cursor over an edit han-
dle and press F1 to open online Help to a 
page with information about that handle. 

• Press the Help button in any dialog box 
to open online Help to a page describing 
the options in that dialog. 

Warning and Information 
Messages

As you work, the program may occasionally 
present Warning or Information messages 
regarding the operations you are performing. 
These messages are intended to help you use 
the program as designed and avoid potential 
problems.  See “Message Boxes” on page 15.

View Reference Manual

Select Help> View Reference Manual  
to view the contents of the Help Contents and 
Index in on online .pdf file.

Chief Architect strives to make our docu-
mentation as helpful as possible for all of our
customers. Please send any suggestions to 
documentation@chiefarchitect.com.

http://www.chiefarchitect.com/
http://www.chiefarchitect.com/
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About Chief Architect
Select Help> About Chief Architect 
Viewer in Windows® or Chief Architect> 
About Chief Architect in macOS™ to view 
the program’s version number and its release 
date.

Contact information for Chief Architect, Inc. 
is available on the MORE INFORMATION 
panel.
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Chapter 2:

File Management

The Chief Architect Viewer reads and edits 
two main document types: .plan files and 
.layout files. The complete 3D model of a 
structure, surrounding terrain and any CAD 
data associated with it are stored in the plan 
file. Data used to create working drawings 
and the links to various views or details are 
stored in the layout file.

All commands related to opening, saving and 
closing plans are located in the File menu. 
You can also open plans from the Startup 
Options dialog. See “Startup Options” on 
page 8.

Chapter Contents
•      Compatibility with Other Programs
•      Chief Architect Viewer Data
•      Opening a Plan or Layout File
•      Saving and Exporting Files
•      Auto Archive
•      Undo Files
•      Exiting The Chief Architect Viewer
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Compatibility with Other Programs
Plans and layout files produced in the 
following programs can all be read by the 
Chief Architect Viewer X10. 

• Chief Architect® 10.0 through X9
• All Better Homes and Gardens Home 

Designer® products, Interior Designer, 
and Landscaping and Deck Designer, 
Versions 7 and 8. 

• All Chief Architect Home Designer® 
products, Interior Designer, and Land-
scaping and Deck Designer, Versions 9 
through 2018. 

Files that have been opened and saved in the 
Chief Architect Viewer X10 can be read 
again in Version X10 Chief Architect 
programs and Version 2016 Home Designer 
programs, allowing you to share your 
thoughts and ideas with your design 
professional.

Files that have been opened and saved in 
Chief Architect Viewer X10 cannot be read 
by any of the program versions listed above. 

Plans and layout files produced in the 
Windows® version of the Chief Architect 
Viewer X10 can be read in the Mac® version, 
and vice versa. 

Chief Architect Viewer Data
When the Chief Architect Viewer X10 is 
installed, the program automatically creates a 
folder in the user Documents directory called 
Chief Architect Viewer X10 Data. This 
folder contains important information and 
should not be moved, renamed or deleted. 

Because the Chief Architect Viewer X10 
Data contains custom user data, it is not 
deleted when the program is uninstalled.

Opening a Plan or Layout File
The Chief Architect Viewer 
allows you to open, view and add 

comments to plan and layout files created for 

you by your design professional. Before 
opening one of these files, you must copy it 
onto your computer’s hard drive. 

If the Chief Architect Viewer X10 Data
folder is renamed, moved or deleted,

the program will automatically replace it
using default information from the Chief
Architect Viewer installation folder. When
this occurs, customized user settings and
custom user library content will not be avail-
able.
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It is recommended that you not save these 
files in the program’s installation folder. A 
good location for these files is your 
Documents directory, which is specifically 
intended for your own files.

Plan and layout files often refer to external 
support files such as images that your design 
professional may have also given to you. It is 
best to keep all files associated with your 
drawings in the same folder. 

For example, you can create a folder called 
“Chief Architect Viewer Plans” or another 
name you prefer and then copy all the files 
given to you there. See your operating 
system’s Help to learn how to create folders.

When the file you wish to open and any 
support files are saved on your computer, 

select File> Open Plan  to open a .plan 
file or File> Open Layout  to open a 
.layout file located on your computer. The 
Chief Architect Viewer automatically 
browses to the directory you last used to 
open a file.

In the Look in drop-down, browse to the 
location on your computer where the file you 
wish to open is saved. 

Any folders and either .plan or .layout files 
in the current location display in the field 
below.

Click on the file you wish to open. Its name 
will display in the File name text field. 

To open files of a different type, select one 
from the Files of type list. The only file 
types available are .plan and .layout. 

When the desired file is selected, click Open. 

The Open Plan File and Open Layout File 
dialogs can be resized by clicking and 
dragging the lower right corner. 

Recently Opened Files
The names of the plan and layout files you 
most recently opened or saved display at the 
bottom of the File menu. You can click on a 
recent file to open that file without using the 
Open File dialog. 

The names of recently open files also display 
in the Startup Options dialog. Click on the 
name of a file to open it. See “Startup 
Options” on page 8.

Saving and Exporting Files
There are two options for saving 
plan and layout files: File> Save 

and File> Save As.

When you first open a file in the Chief 
Architect Viewer, it is recommended that 

you use Save As  to modify the name of 
the file so that it can be distinguished from 
the original file that you received from your 
design professional.

Never open a file located on a server or
other computer on a network, or on a

removable storage device. Copy such files to
your local machine’s hard drive first, and then
open the copy.
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To save a plan or layout file

1. Select File> Save As  to open the 
Save File dialog.

2. Particularly if you were sent both plan 
and layout files, it is best to use the same 
location as the original files. See “Open-
ing a Plan or Layout File” on page 22.

3. In the File name text field, type a name 
for the file. 

4. Chief Architect Viewer automatically 
assigns the File of type and file exten-
sion .plan to plan files and .layout to 
layout files.

5. When both the Save in location and File 
name are correct, click Save. 

Both Save  and Save As  can be used 
to save your plan and layout files; however, 
they accomplish this in two different ways.

• File> Save  saves the current state of 
your plan or layout file without changing 
its name and should normally be used for 
saving your work.

• File> Save As  opens the Save File 
dialog, allowing you to save the plan file 
using a different name or location on 
your computer. 

Initially, all Open  and Save As  
operations go to the “My Documents” folder 
of your computer. After that, the location last 
visited is remembered and subsequent 

Open  or Save As  commands default 
to the directory last used for that operation. 
This path is saved when the program exits. 
The next time Chief Architect Viewer is 
launched, these defaults are used.

Save File Dialog
The Save File dialog uses the operating 
system’s file save dialog format, and is also 
used when exporting files. The dialog name 

may vary, depending on the type of file being 
saved or exported.

A similar Select Folder dialog allows you to 
select a folder to which files can be exported. 

Rather than type a new name, you can
click before the file name to place your

cursor at that location, then type “Edited_” to
distinguish this file from the original.
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Choose a location on your local 
computer for the file you are saving.

Any existing folders and/or files in the 
current location display here.

In the File Name field, type a name for 
the file. If you select an existing file 

from the space above, its name will display 
here automatically.

When saving a file, the program will 
choose the appropriate file type from 

the Save as type drop-down list. When 
exporting, you may need to choose a specific 
file type.

Exporting Files
The Chief Architect Viewer has options for 
exporting information out of and your 
drawings. See “Pictures, Metafiles, and 
Walkthroughs” on page 85. 

File export dialogs are simply versions of the 
Save File dialog. 

Backing Up Your Files
It is always a good idea to create backup 
copies of all your important files on your 
computer. 

It is strongly recommended, however, that 
you never save directly:
• Across a network, such as onto a server;
• Onto removable media such as a USB 

thumb drive, CD, or DVD;
• Across the Internet.

Instead, copy your files to such locations 
only after you have saved them on your 
computer’s hard drive and exited the 
program.

1

2

3

4
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Archive folders are used by Chief Architect 
Viewer to manage prior versions of your 
files. You should not view these files as a 
substitute for your own backup routine, and 
should never save a file in an archive folder.

When backing up your Chief Architect 
Viewer files, consider backing up not only 

your .plan files, but your custom user data, 
as well - including library content, toolbar 
configurations, and textures. This custom 
data is all located in the Chief Architect 
Viewer Data folder, so it can be easily 
backed up. See “Chief Architect Viewer 
Data” on page 22.

Auto Archive
The first time a plan or layout is saved, the 
Chief Architect Viewer creates an Archive 
folder in the Chief Architect Viewer Data 
folder. The Archive folder contains Auto 
Save and Archive files. 

The program does not create Auto Save and 
Archive files for untitled plans and layouts. 
In order for these to be created, a file must 
have been previously saved and given a 
name and save location on your computer. 
Further, Archive files are only updated when 
you save your work.

Auto Save and Archive files should not be 
viewed as a substitute for regularly saving 

your work by selecting File> Save  or 
pressing Ctrl + S on the keyboard, nor should 
they be considered an alternative to your own 
file backup routine.

Archive Files
Every time a drawing is saved, Archive files 
that keep a historical archive of your plan are 
automatically created or updated. 

Archive files are meant to be for emergency 
use only. If you must access an archive file, 
open it as you would any other file. See 
“Opening a Plan or Layout File” on page 22. 

As soon as the file is open, use Save As  
to save this file to another location.

Auto Save Files
As you work, the Chief Architect Viewer 
automatically creates Auto Save files at 
regular intervals when changes are made to a 
file but not saved by selecting File> 
Save . 

These Auto Save files are appended 
_auto_save.plan or _auto_save.layout and 
are saved in the Archive folder. 

When you close a file normally, its Auto 
Save file is retained until the next time the 
file is opened - at which time the Auto Save 
file is overwritten.

Auto save files created as a result of an 
improper program shutdown are appended 
_auto_save_bak.plan or 
_auto_save_bak.layout.

If you do not save your work regularly,
your archive files will not be updated.

Auto Save file after normal shut-down
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If your computer shuts down accidentally, 
you can recover some of your work by 
opening the _auto_save_bak file.

When you reopen a file after a computer shut 
down or system crash, the program will 
notify you if an Auto Save file newer than 
the original file is found and give you the 
option to one that file. 

Even with Auto Save, you should save your 
work manually on a regular basis using any 
of the following methods: 

• Click the Save  button.

• Select File> Save .
• Press Ctrl + S on the keyboard.

Undo Files
The Chief Architect Viewer stores a set 
number of copies of all open plan file 
changes, known as undo files. Undo files are 
referenced whenever you select Edit> 
Undo  or Edit> Redo . 

Undo files are stored in your operating 
system’s Temp directory. When the Chief 
Architect Viewer is closed normally, any 
current Undo files are deleted.

Exiting The Chief Architect Viewer
Select File> Exit to exit the program. If you 
have not saved any open files, you will be 
reminded to do so. It is better to save your 
work before exiting than to save on exit. See 
“Closing Views and Files” on page 39.

When you exit from the program using File> 
Exit, all Autosave files and Undo files are 
automatically deleted. 

On a Mac, if you click the program window’s 
red Close button, the window will close but 
the program itself will continue to run. To 
close it down completely, right-click on its 
icon on the Dock and select Quit from the 
contextual menu.

A file is auto saved only if you have
saved it previously. Auto Save does not

work for unnamed files. 

Auto Save file after abnormal shut-down
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Chapter 3:

Multiple Floors

Chief Architect plan files can have up to 30 
floors, plus a foundation and attic. The Chief 
Architect Viewer allows you to view all of 
them in a variety of ways.

Chapter Contents
•      Displaying Floors
•      Exchanging Floors
•      The Current Floor
•      The Reference Floor

Displaying Floors
The Chief Architect Viewer allows you to 
view the floors in your plan in a variety of 
ways.

In Floor Plan View
In floor plan view, only one floor can be 
active for editing at a time. This is referred to 
as the Current Floor. See “The Current 
Floor” on page 30. 

In addition to the Current Floor, one other 
floor can be displayed for reference 
purposes: the Reference Floor. Objects on 
the Current Floor can snap to those on the 
Reference Floor, helping you align objects. 
See “The Reference Floor” on page 30.

In 3D Views
In most 3D views, all floors in a plan are 
visible, from the foundation up to the attic. 
There are two exceptions: 

• Floor Camera  views, which show 
the Current Floor only.

•  Floor Overviews , which show the 
Current Floor, not including its ceiling, 
plus any floors beneath it. 

See “3D View Tools” on page 49. 
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Exchanging Floors
Select Build> Floor> Exchange With Floor 
Above or  Exchange With Floor Below to 
swap the current floor with the floor above or 
below. 

The floor that was moved becomes the 
current floor at its new location. You can 
easily move a floor up or down several floors 
by using either one of these buttons 
repeatedly.

The Current Floor
Only one floor can be active at any given 
time. The active floor is referred to as the 
Current Floor.

Floor Up / Floor Down
If you are working with 
more than one floor, you 

can select Tools> Reference Floors> Up 
One Floor or Down One Floor to switch 
from one floor to another. 

You can change the current floor in floor plan 
and 3D views. The current floor displays on 

the Change Floor/Reference  button, 

which can be found between the Down One 
Floor and the Up One Floor buttons. 

Floors become available once they have been 
built. The Attic and foundation levels are 
also accessible using these tools. 

Change Floor / Reference
If there are multiple floors, select 
Tools> Reference Floors> Change 

Floor/Reference to open the Change Floor/
Reference dialog, where you can select both 
the current floor and which floor is used in 
the Reference Floor, as well as control the 
appearance of the Reference Floor. 

The Reference Floor
When there is more than one floor in a 
model, it is often helpful to see how they 
relate to each other. Any floor can be shown 
as the Reference Floor along with the 
current floor. 

Reference Floor Display
To turn on the Reference Floor, select 
Tools> Reference Floors> Reference 

Floor Display or press F9 on your keyboard.

Note: If objects on the current floor and the
Reference Floor have edges that line up, the
Reference Floor may be difficult to see on
screen. When lines of two different colors are
superimposed upon each other, discoloration
may result.
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Reference Floor Display 
Options

The display of objects in the 
Reference Floor is controlled by 

selecting Tools> Reference Floors> 
Reference Floor Display Options. See 
“Layer Display Options Dialog” on page 42.

Change Floor / Reference Dialog
By default, the floor below the 
Current Floor is the Reference Floor, 

but any floor can be referenced using the 
Change Floor/Reference dialog. To open 

the dialog, select Tools> Reference Floors> 
Change Floor/Reference button. 

When this dialog is accessed from a camera 
view, only the Current Floor settings will be 
active.

The Current Floor is highlighted here. 
You can select another floor to make it 

the current floor. 

The Reference Floor currently used for 
reference is highlighted here. You can 

select another floor to display it instead. 

Swap Floor/Reference
If one floor is defined as the current 
floor and another floor is defined as 

the reference floor, select Tools> Reference 
Floors> Swap Floor/Reference to switch 
the status of the two floors.

1

2
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Chapter 4:

Window and View
Tools

The View and Window Tools let you control 
how views of your drawing are shown on 
screen, as well as toggle useful drawing aides 
on and off.

One layout file can be open at a time, but 
there is no limit to the number of plan files 
that can be open. The name of the file and the 
type of view displays at the top of each view 
window in its title bar. If the view is saved, 
its name also displays. 

Chapter Contents
•      View Windows
•      Working in Multiple Views
•      View Tools
•      Zoom Tools
•      Undo Zoom
•      Fill Window
•      Panning the Display
•      Closing Views and Files

View Windows
In Chief Architect Viewer, there are several 
different types of views:
• Plan, Camera, and Cross Section/Eleva-

tion Views are found in plan files only. 
Plan Views

• 3D Views

Each view displays in a view window. While 
multiple views can be open and display on 

screen, only one view window can be active 
at any given time. See “Working in Multiple 
Views” on page 34.
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 Working in Multiple Views
Although only one layout file can be open at 
a time, there is no limit to the number of plan 
files that can be open, nor is there a limit to 
the number of plan view windows that can be 
open. The name of the file and the type of 
view is stated at the top of each view window 
in its title bar as well as in its tab. If the view 
is saved, its name displays instead of the 
view type. 

By default, Chief Architect Viewer uses a 
tabbed document interface, which means that 
when more than one view window is open in 
the program window, each open window will 
have a tab that displays in a row above the 
currently active view.
• Each tab states the name of file and either 

the name of the view or the view type. 
• Each tab features an icon indicating its 

type of view. 

• Click on a tab to make it the active view.
• If there is not enough room in the pro-

gram window to display all tabs, left and 
right arrow buttons allow you to scroll 
through the tabs.

• Tabs can be reordered by clicking and 
dragging.

There is no limit to the number of 3D view 
windows that you can have open at a given 
time; bear in mind, though, that each window 
demands use of your computer’s resources 
and that you may see poor performance if too 
many views are open. See “3D Views” on 
page 47.

There are several ways to close a view 
window. See “Closing Views and Files” on 
page 39.

Tiling Views
As an alternative to tabbed views, 
windows can instead be tiled. 

Tiling allows you to display multiple views 
in a single Chief Architect Viewer window 

so you can see the results of changes in floor 
plan view in 3D or vice versa. It can also be 
useful for copying objects from one plan to 
another. 
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There are several ways to create tiled views:
• Click and drag a view window’s title bar 

or tab into the part of the drawing area 
that you would like it to be. When a high-
lighted space is created, release the 
mouse button. 

• Select Window> Tile Horizontally  
to display views in a horizontal orienta-
tion, one above the other. 

• Select Window> Tile Vertically  or 
press Shift + F6 on the keyboard to dis-
play views in a vertical, side by side, ori-
entation. 

Views are tiled left to right or top to bottom 
in the order in which they were last active: 
the most recent view is on the left or at the 
top, while least recent is on the right or on 
the bottom. 
• To activate a view, click on its title bar or 

anywhere in the view window. Note that 
any changes you make in the active win-
dow are reflected in other views as well.

• To end window tiling, select Window> 
Tab Windows. You can also end tiling by 
double-clicking on the title bar of the pro-
gram window.

Multiple Program Windows
To create a second program window, click 
and drag the title bar or tab of a view window 
completely out of the current program 
window: for example, onto a second monitor.  
A second Chief Architect Viewer program 
window will be created with its own menu 
and toolbars. 

Swapping Views
There are a number of ways to switch 
between open view windows:
• Click on a view window’s tab.

• Select Window> Select Next Tab  or 

Window> Select Previous Tab  to 
cycle through all open views in the order 
you prefer. 

Floor plan view and a camera view Tiled Vertically
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• In Windows, press the Ctrl + Tab (Next 
Window) or Ctrl + Shift + Tab (Previous 
Window) keys to cycle through all open 
views. 

• On a Mac, press the Ctrl + } (Next Win-
dow) or Ctrl + Shift + { (Previous Win-
dow) keys to cycle through all open 
views. 

• A list of all the views currently open is 
located at the bottom of the Window 
menu. Each view is identified by its name 

and what type of view it is. A checkmark 
is beside the view that is currently active. 
Select one to go directly to that view. 

If more than eight view windows are open, 
More Windows will be the last item in the 
Window menu. Select this option to open the 
Select Window dialog:

Select the name of a view in the list and click 
OK to make it the active view.
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View Tools
The View Tools allow you to open and close 
the program’s side windows, as well as 
toggle a variety of references and drawing 
aides. Select the View menu to access these 
tools. 

Refresh Display redraws the current 
window to clean up extra lines, show 
missing items, and correct random 

on-screen effects caused by changes to the 
model. 

Tool Palette opens and closes the 
Tool Palette, which will display 
related tools. 

Scrollbars displays and suppresses 
scrollbars on view windows. 

Color toggles the display of color in 
the current view. 

Crosshairs toggles the use of the 
blue crosshairs centered on the mouse 
pointer in most views. 

Zoom Tools
Zoom is used to magnify any given 
area on the plan or 3D view. Select 

Window> Zoom, then click and drag a 
marquee around an area on screen. When 
you release the mouse, the selected area 
expands to fill the screen. 

Note that in 3D views, using Zoom  does not 
reposition the camera. This can lead to 
inconsistencies between a camera’s position 
and what is actually shown in the view if 
other methods of zooming are used later. See 
“Repositioning Cameras” on page 55.

When the zoom is complete, whatever tool 
was active prior to selecting the  Zoom  tool 
automatically becomes active again. If 
another zoom is needed, click the  Zoom  
tool again.

Zoom In - Click to zoom in towards 
the screen center by a factor of two.

Zoom Out - Click to zoom out from 
the screen center by a factor of two.

Undo Zoom - Reverse the last zoom 
operation.

Fill Window - Fits all visible items on 
screen.

Fill Window Building Only - Fits all 
walls and railings on the current floor 

on screen. 

Zooming With the Mouse Wheel
Use the mouse wheel to zoom in and 
out in all view windows. Scrolling 
the mouse wheel one click up or 

down zooms in or out, centering on the 
location of your pointer and changing the 
zoom by about 10%.

By default, zooming in 3D views changes the 
camera’s position. See “Mouse Scroll Wheel 
and Trackpad” on page 55.
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Undo Zoom
Select Window> Undo Zoom to 
reverse the last zoom operation. 

Zoom  and Undo Zoom  are also 
available through the contextual menu. See 
“Contextual Menus” on page 13. 

Fill Window
In floor plan view or a cross section/
elevation view, select Window> Fill 

Window or press the F6 key to view nearly 
everything on screen that is visible, including 
the Reference Display. CAD Points are the 
only objects that are not included when Fill 
Window is used. 

If you are zoomed in so that only a portion of 
the drawing displays on screen, selecting Fill 
Window  zooms out so that the entire 
view fits on the screen. If you are zoomed 
out so that the entire drawing is smaller than 

the screen, selecting  Fill Window  
zooms in until the drawing fills the screen.

When the drawing sheet is shown, Fill 
Window  zooms to the sheet borders.

Fill Window Building Only
Window> Fill Window Building 
Only is similar to Fill Window, but 

zooms in or out to so that all walls and 
railings in the view fill the current window. 
Other objects are ignored.

In 3D Views

In 3D views, Fill Window  and Fill 
Window Building Only  adjust the 
camera’s Field of View is adjusted so that all 
surfaces in the 3D view are included.  

Panning the Display
There are four ways to pan the display 
without changing the zoom factor.

Note: Depending on the configuration of your
mouse, it may be necessary to hold down the
Ctrl key while turning the mouse wheel. If
zooming in and out are not working correctly,
contact the manufacturer of your mouse and
mouse driver for their assistance. 

Note: Undo and Redo do not affect zoom.
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Using the Scroll Bars
One method is to use the scroll bars on the 
right and bottom edges of the window.

• Drag the square button in the bar itself in 
order to pan a larger distance. 

• Click the end arrow keys on the scroll 
bars to shift the display in 12" incre-
ments. 

Using the Arrow Keys
In floor plan view, the arrow keys on the 
keyboard work exactly like clicking the 
arrow buttons on the scroll bar. 

Using the Mouse
If you have a wheel mouse, you can pan the 
display by pressing the middle mouse button, 
or wheel, and moving the mouse in the 
direction you would like to pan. When the 

middle mouse button is held down, the 

pointer changes to a hand  icon. 

In the Mac version of Chief Architect 
Viewer, you can pan using the left mouse 
button and Command key.

Mouse drivers sometimes have other 
functions assigned to the wheel and buttons. 
These override the Chief Architect Viewer 
setting.

Using a Mac Trackpad
In the Mac version of Chief Architect 
Viewer, you can two finger drag to pan the 
display. See “Using a Trackpad” on page 10. 

Using the Pan Window Tool
The Pan Window tool works much 
like the mouse wheel method.

Select Window> Pan Window . The 

pointer changes to a hand  icon. Click and 
drag to pan the window. The program reverts 
to the previously active tool when you 
release the mouse button.

Closing Views and Files
If a view is still needed, you can swap to a 
different view without closing it. If, however, 
a view is no longer needed, it can be closed. 
There are several ways to close a view 
window:
• Select File> Close to close the active win-

dow. 

• Press Ctrl + W or Ctrl + F4 on the 
keyboard to close the active window.

• Click the Close button in the active 
view’s title bar or in any view’s tab.

• A tabbed view can be closed by clicking 
on its tab using the middle mouse button.

Scroll Bars



40

Chief Architect Viewer X10 Reference Manual

• Select File> Close All 3D Views  to 
close all currently open camera view win-
dows instead of just the active window. 

• Select File> Close All Views to close all 
currently open view windows instead of 
just the active window. 

If a plan has only one view window open and 
you try to close it, the program will prompt 
you to save before closing if there are any 

unsaved changes. See “Saving and Exporting 
Files” on page 23.

Even if all view windows are closed, the 
program can still be open. See “Exiting The 
Chief Architect Viewer” on page 27. 

Although the program warns you if you
try to exit without saving, you should get

in the habit of saving plan files before exiting. 
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Chapter 5:

Displaying
Objects

Layers allow you control which objects 
display in floor plan and camera views. 

Chapter Contents
•      Layers
•      Layer Sets
•      Layer Display Options Dialog
•      Display Toggles
•      Select Color Dialog

Layers
Layers are used to organize and manage the 
display of all objects in all views. A layer can 
be thought of as a transparency sheet with 
objects placed on it for viewing. Nearly all 
views use multiple layers, like a stack of 
transparencies put together to show different 
types of objects. 

You can find out which layer an object is on 
by selecting the object and looking at the 
Status Bar. And, you can specify whether 
each layer displays in a particular view in the 
Layer Display Options dialog. 

Multiple layers are organized into Layer 
Sets, which allow you to control which 
objects display in different views.
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Layer Sets
Layer Sets are used to control the layer 
settings for different views in a plan or layout 
file. 

A layer set consists of a complete list of the 
layers in the current plan or layout along with 
the display settings for each layer as set for a 
particular type of view. These display 
settings can be modified, and can be different 
for each type of view. See “Layer Display 
Options Dialog” on page 42.

Layer sets are file specific, which means that 
changes made in one plan or layout file have 
no effect on the settings in other files. 

The Chief Architect Viewer uses a different 
layer set for the each type of view of your 
plan:
• Floor plan view.

• Camera views and Overviews. See “3D 
View Tools” on page 49.

• Elevation views. See “3D View Tools” on 
page 49.

• Framing Overviews. See “Framing Over-
view” on page 52.

• Reference Floor. See “The Reference 
Floor” on page 30.

While any view is active, select Tools> 
Display Options  to make changes to the 
layer set used for that view type. 

Any changes made to settings in the Layer 
Display Options dialog for one particular 
view will affect all views using that same 
layer set. For example, if you make changes 
for a camera view, all camera views and 
overviews in the current plan will be 
affected.  

Layer Display Options Dialog
The Layer Display Options dialog 
controls the display of layers in the 

active layer set. It consists of a table that lists 
all available layers and the attributes for 
each.

From any view, select Tools> Display 
Options  to open the Layer Display 
Options dialog. 

There are a number of dialogs similar to 
Layer Display Options in the program: 

• Select Tools> Reference Floors> Refer-
ence Floor Display Options  to open 
the Layer Display Options dialog with 
the Reference Display Set active. See 
“The Reference Floor” on page 30.

• Select Tools> Display Options  in a 
layout to open the Layout Page Display 
Options dialog.
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The layers in the Layer Display Options 
dialog can be sorted by either of its columns. 
• Click in the Disp column to remove or 

add a checkmark. A checkmark indicates 
that the layer is set to display in the 
current view. 

• Click OK to close the dialog and apply 
your changes.

• Click Cancel to close the dialog, ignor-
ing any edits.

Display Toggles
There are a number of toggles and tools that 
can be used to affect the appearance of the 
on-screen display. 

Print Preview
Print Preview and its related display 
toggles allow you to get a sense of 

what the current view will look like when it 
is printed. See “Print Preview” on page 90.

Refresh Display
Refresh Display redraws the current 
window to clean up extra lines, show missing 
items, and correct random on-screen effects 
caused by changes to a model. Select View> 
Refresh Display or press the F5 key to 
refresh the on-screen display. 

Color On/Off
The display of color on-screen can be 
toggled on and off in any view by selecting 
View> Color. 
• If Color  is toggled off in any 3D view 

other than a Vector View, the view will 
be displayed in grayscale. 

• If Color  is toggled off in any line 
based view, including floor plan view, 
Vector Views,  and layout, the view will 
be displayed in black and white

You can also print in color or gray scale. See 
“Print View Dialog” on page 92.

Delete Surface
In any 3D view, select 3D> Delete 
Surface, then click a surface in the 

view to temporarily remove the surface from 

Note: Not all objects display in all views. For
instance, invisible walls do not appear in
camera views.
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the current view. See “Delete 3D Surface” on 
page 54.

Select Color Dialog
The Select Color dialog can be opened by 
clicking on the color bar that can be found in 
many dialogs throughout the Windows 

version of the program. In the Mac version, 
the standard Colors dialog, or Color Picker, 
is used. 

The currently selected color displays in 
the rectangle at the lower center of the 

dialog. There are a number of ways to select 
a color in this dialog:

Click in any one of the Basic colors 
boxes to select it.

Click anywhere in the color spectrum 
area to select a color. 

• The location of the selected color is iden-
tified by a crosshairs.

• Click anywhere in the vertical bar or drag 
the arrow to adjust the selected color’s 
Luminosity and RGB values.

Define the color by specifying its Hue, 
Saturation, and Luminosity (HSL) or 

its Red, Green, and Blue (RGB) values.

Click in one of the Custom colors 
boxes to either select it or to specify it 

as the box for a new custom color to be 
defined.
• Click the Add to Custom Colors button 

to add the selected color to the Custom 
Colors group.

Click the Color Chooser Eyedropper, 
then click anywhere on your monitor to 

select the color displaying at that location.

1

2

3

4

5

6
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lick OK to apply the currently selected color 
to the object’s line or fill style, or to the 
material’s pattern color. 

You can select a color from any program
window. Before opening the Color

Chooser dialog, make sure the desired color
can be seen on screen. 
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Chapter 6:

3D Views

Little preparation is needed to create a 3D 
view of a model: simply click a button to 
create an overview or click and drag to create 
a camera or cross section/elevation view. 

Chapter Contents
•      OpenGL and Hardware
•      Camera Defaults Dialogs
•      3D View Tools
•      Creating Camera Views
•      Creating Overviews
•      Cross Section/Elevation Views
•      Displaying 3D Views
•      Repositioning Cameras
•      Editing 3D Views
•      Cross Section Slider
•      Saving and Printing 3D Views
•      Camera Specification Dialog
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OpenGL and Hardware
Chief Architect Viewer features an easy to 
use rendering engine that makes use of 
OpenGL rendering technology, which has 
good hardware support on most video cards. 

To take full advantage of thes rendering 
capabilities of Chief Architect Viewer, a 
graphics card or chipset that supports 
OpenGL 3.3 on Windows or 4.1 on Mac is 
required. 

Vector Views are non-photorealistic views in 
which objects are drawn using surface edge 
lines, or vectors. Limited lighting and 
shadows can be calculated and materials are 
represented using pattern lines and solid 
colors. See “Vector View” on page 69.

Once a 3D view is created, you can specify 
whether it uses the Standard or Vector View 
rendering technique. See “Rendering 
Techniques” on page 68.

Camera Defaults Dialogs
There are several defaults dialogs for 
cameras, which can be accessed by selecting 
3D> Edit Camera Defaults. Select an item 
in the submenu to open the defaults dialog 
associated with your selection: 

The settings in the Camera Defaults dialogs 
control the initial use of effects that improve 

the appearance of 3D views. Select 3D> Edit 
Camera Defaults to open this dialog.  

The settings in these dialogs are also found in 
the Camera Specification dialog. See 
“Camera Specification Dialog” on page 64.

Once a camera is created, its attributes can be 
customized. See “Editing 3D Views” on page 
60.

Full Camera Defaults
Specify the initial attributes of cameras 

created using the Full Camera  tool. See 
“Camera Views” on page 49.

The settings in this dialog are the same as 
those in the Full Camera Specification 
dialog. See “Camera Specification Dialog” 
on page 64.

Floor Camera Defaults
Specify the initial attributes of cameras 

created using the Floor Camera  tool. 

The settings in this dialog are the same as 
those in the Floor Camera Specification 
dialog. 
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Perspective Full Overview Defaults
Specify the initial attributes of cameras 
created using the Perspective Floor 
Overview  tool. See “Full Overview” on 
page 51.

The settings in this dialog are the same as 
those in the Perspective Full and Framing 
Overview Specification dialogs. 

Perspective Floor Overview Defaults
Specify the initial attributes of cameras 
created using the Perspective Floor 
Overview  tool. See “Full Overview” on 
page 51.

The panels in this dialog are the same as their 
respective panels in the Perspective Floor 
Overview Specification dialogs. 

Cross Section/ Elevation Defaults
Specify the initial attributes of cameras 
created using the Cross Section/
Elevation  tool. See “Cross Section/
Elevation Views” on page 50.

• Check Show Shadows to turn on shad-
ows in the selected camera view. When 
unchecked, shadows are not generated. 
See “Shadows” on page 68.

• Check Ray Casted Sun Shadows for 
higher quality shadows cast by sun light. 
Ray Casted Sun Shadows take longer to 
generate than regular shadows and only 
refresh when the camera is not moving. 

• Check Edge Smoothing When Idle to 
apply high quality edge smoothing to 
edge and pattern lines when the selected 
camera is not in motion. See “Edge 
Smoothing” on page 68. 

3D View Tools
Select 3D> Create Camera View to display 
the Camera View Tools. 

Camera Views
The Full Camera tool creates multi-
floor views of the 3D model. It can be 

used to create interior and exterior 

perspectives, and is good for displaying 
cathedral ceilings, roofs, lofts, stairwell 
openings, and other variation in floor and 
ceiling levels.

The Floor Camera tool creates 
perspective views of the current floor 

only. Nothing above the ceiling surface is 
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generated, and neither is anything below the 
floor. 

Overviews
The Full Overview tool creates views 
of the entire model including all floors, 
ceilings, and the roof. 

The Floor Overview tool creates 
views of the current floor with the 
ceiling removed and all floors beneath 

it visible. 

The Framing Overview tool creates 
views of the framing in the model. 

Framing must be present in the plan in order 

for it to display in a framing overview. See 
“Framing Overview” on page 52. 

Cross Section/Elevation Views
Cross Section/Elevation views are similar 
to the traditional, scaled orthographic views 
often used in drafting. They are scaled and 
can be fully annotated. See “Cross Section/
Elevation Views” on page 52.

A Cross Section/Elevation view 
displays all floors of the model. If the 

view is created outside the structure looking 
toward it, the result is an exterior elevation. 
If the view is created inside the structure, or 
passes through any of the structure, a cross 
section is created. 

Creating Camera Views
All Camera views are created using the same 
method.

To create a camera view

1. In floor plan view, select the desired 
camera tool. The mouse pointer displays 

the camera  icon. 
2. Click and drag a line to define the view 

direction. 
•  Where your line begins is the camera’s 

position. 
•  The line that you drag defines the 

direction the camera is pointed. 
•  The end of the line is the focal point of 

the view, the point the camera rotates 
around.

•  The field of view is 45°, which is 
similar to what the human eye sees or a 
50mm camera lens. 

3. When you release the mouse button, a 
view generates in a new window.

4. Return to the floor plan view. A camera 
symbol now displays in floor plan view. 

Camera 
(click)

Focal Point 
(release)

Line of Sight 
(drag)

1.

2.

3.
Field of View 
Indicator
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See “Working in Multiple Views” on 
page 34.

Camera Height
By default, Cameras are created at a height 
of 60” (1500 mm). Where this height is 
measured from depends on the location of 
the camera:

• If the camera is inside of a room, it is 
measured from that room’s subfloor.

• , it is measured from the default height of 
the subfloor for the current floor. 

Once created, a camera’s height can be 
modified in its Camera Specification dialog 

Creating Overviews
In the Chief Architect Viewer, there are three 
different overview types: Full, Floor and 
Framing Overviews. 

Overviews generate as soon as you select the 
tool and are always created at the same 
angle. The focal point is always located at 
the center of the model; however, the 
position of the camera will vary depending 
on the size of the 3D model. The larger or 
more spread out the model, the further away 
the camera will be from the focal point so 
that the entire model can be seen in the view. 

Once generated, an overview window’s title 
bar indicates  view type and a camera symbol 
representing the overview displays in floor 
plan view, The overview ‘camera’ can be 
edited much like regular camera views can. 
See “Editing 3D Views” on page 60.

Full Overview
Select  3D> Create Camera View> 
Perspective Full Overview to 

generate an exterior view of the entire model.

Floor Overview
Select 3D> Create Camera View>  
Floor Overview to create a view of 

the current floor with the ceiling removed 
and all floors beneath it visible.

Floor Overviews are an effective tool for 
illustrating traffic flow and the relationships 
between spaces.  

To see a different floor, select Tools> 
Reference Floors> Up One Floor  or Down 
One Floor . You can also return to floor plan 
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view and make another floor current before 
generating the Floor Overview

Framing Overview
Select 3D> Create Camera View> 
Framing Overview to create a view 

of the entire model, displaying only framing 
and the foundation. 

Select  3D> Create Camera View> 
Framing Overview to create a view of the 

entire model, displaying only framing and 
the foundation. 

Framing overviews include all floor, wall, 
and roof framing as well as foundations.  

Cross Section/Elevation Views
The Elevation tool produces views in 
which all lines and dimensions are 

their true lengths, regardless of their distance 
from the camera. 

Cross section/elevation views are the only 
3D views that can be annotated with the Text 
tools. 

Cross Section/Elevation 
Camera Tools

A Cross Section/Elevation view 
displays all floors of the model. The 

cross section begins at the point where the 
camera arrow is drawn and continues 
through the entire model. 

To create a Cross Section/Elevation view

1. Select the Cross Section/Elevation  
tool. The pointer changes to a  with 
crosshairs marking the position of the 
pointer.

2. Click and drag a line in floor plan view. 

•  A Camera symbol displays where you 
click, along with a Cross Section Line 
indicating the plane of the camera’s 
cross section cut line.

3. Drag in the direction of the Line of Sight 
to draw a camera arrow.

•  Always drag the camera arrow perpen-
dicular to the wall to be viewed. 

4. When you release the mouse button, the 
view generates in a new window.

•  If the view is a Backclipped Cross Sec-
tion, a second Cross Section Line at the 

Camera 
(click)

Focal Point 
(release)

Line of Sight 
(drag)

1.
2. 3.

Clip Plane Indicators
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end of the Line of Sight indicates the 
furthest extent of the backclip.

If the Line of Sight does not cut through a 3D 
object and the object is within the back 
clipped distance, such as a window shown in 
elevation, the object retains its 3D definition 
and can be selected, moved, stretched, or 
otherwise modified in the view. The 3D 
model is updated in all views.

Detailing Cross Section/
Elevation Views

Text objects can be created in cross section/
elevation views.If Text objects have been 
added to a cross section/elevation view, the 
program will prompt you to save the view 
before closing the window. This information 
is then stored in the view. See “Text” on page 
71.

Displaying 3D Views
A variety of tools and settings allow you to 
control the appearance of your 3D views. 
There are also numerous ways to adjust the 
position, focal point and field of view of a 
3D view. See “Editing 3D Views” on page 
60.

The name of the current plan file and the type 
of view displays at the top of each view 
window in its title bar. If a 3D view is saved, 
its name also displays. 

There is no limit to the number of 3D view 
windows that you can have open at a given 
time; bear in mind, though, that each window 
demands use of your computer’s resources 
and that you may see poor performance if too 
many views are open. See “Working in 
Multiple Views” on page 34. 

Layer Display Options
Which objects display in a 3D view is 
controlled in the Layer Display 

Options dialog. See “Layer Display Options 
Dialog” on page 42. 

Different view types use different layer sets 
when they are created. See “Layer Sets” on 
page 42.

In Floor Plan View
Cameras are represented in floor plan view 
by symbols that indicate the camera’s posi-
tion, field of view and focal point. 

You can also display camera symbols for 
saved cameras when the “Cameras” layer is 
turned on. See “Layers” on page 41.

The symbols for Elevation views and Full 
Overviews display on all floors, while those 
for Full and Floor Cameras and Doll House 
Views display only on the floor where the 
view was created. See “Creating Camera 
Views” on page 50.
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You can move a camera to a different floor 

by clicking the Up One Floor  or Down 
One Floor  button while the camera view 
is active. Note that this may affect what is 
seen in the view as well as its display in floor 
plan view. See “Floor Up / Floor Down” on 
page 30. 

Both saved and unsaved active cameras can 
have labels indicating the camera number or 
its name. Camera labels are located on the 
“Cameras, Labels” layer.

Camera labels are numbered sequentially in 
each plan in the order they were created. 

Camera symbols are an on-screen reference: 
they do not print unless Print Image is used.

In Rendered Views
There are a number of factors that contribute 
to the appearance of rendered 3D views:
• Select 3D> Camera View Options> 

Toggle Textures  in a 3D view to turn 
off the display of material textures. Not 
available in Glass House or Vector 
Views. 

• Select View> Color  to toggle 
between color and grayscale in 3D views. 
See “Color On/Off” on page 43. 

In Vector Views
There are also a number of factors that affect 
the appearance of 3D Vector Views:

• Select 3D> Toggle Patterns  in a 
Technical Illustration or Vector View to 
turn on or off the display of the “Patterns, 

3D Views” layer, which controls the dis-
play of material pattern lines. See “Lay-
ers” on page 41.

• Select View> Color  to toggle 
between color and black and white to 
control the display line and fill colors. 

Delete 3D Surface
The individual surfaces that make up 
objects can be temporarily removed 

from any 3D view by selecting 3D> Delete 
Surface and then clicking on a surface. 
When the pointer is over a surface, that 
surface will become highlighted.

Surfaces removed in one view are removed 
in all 3D views, but are not permanently 
removed from the model. Continue clicking 
surfaces to remove them, then select another 
tool when you are finished.

Surfaces in 3D views are composed of 
multiple triangles. Hold the Alt key while 
clicking to delete one triangular face at a 
time rather than all triangles forming a  
surface. 

To restore the most recently deleted surface, 

select 3D> Delete Surface  or click the 
toolbar button. 

There are several ways to restore all deleted 
surfaces:
• Select Build> Floor> Rebuild Walls/

Floors/Ceilings , 
• Exit the 3D view and reopen it.
• Generate a new 3D view. 
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Rebuild 3D
Select 3D> Rebuild 3D to regenerate 
all 3D data associated with the current 

plan. All open views will remain open.

Repositioning Cameras
Once a 3D view is created, there are many 
ways to manipulate the camera location and 
the direction of its line of site using the 
mouse, the keyboard, and the menus. 

When the keyboard, toolbar buttons, or menu 
commands are used to move or rotate a 
camera, the adjustments occur in regular 
increments. The size of these increments is 
specified in the Camera Specification 
dialog: 
• The Incremental Move Distance con-

trols Panning movement and forward and 
backward Dolly movement. 

• The Incremental Rotate Angle controls 
Orbit movement, Tilt movement, and side 
to side Dolly movement.

Each time you move the camera, the view is 
updated. If you are using either the toolbar or 

keyboard to move the camera,  you can hold 
down the Shift key, suppressing the redraw 
of the view until the Shift key is released and 
allowing you to move multiple increments 
more quickly. 

You can also move a camera to a different 

floor by clicking the Up One Floor  or 

Down One Floor  button while the 
camera view is active. Note that this may 
affect what is seen in the view as well as its 
display in floor plan view. See “Floor Up / 
Floor Down” on page 30. 

Mouse Scroll Wheel and Trackpad
3D views can be panned and zoomed when 
any tool is active using the mouse scroll 
wheel or trackpad gestures. See “Using a 
Trackpad” on page 10.

The program adjusts the speed of these 
actions depending on characteristics of the 
camera: 
• Zoom speed depends on how close the 

camera is to the object located behind the 
mouse pointer. When the target object is 

far from the camera, zooming is faster; as 
the camera gets closer to the target, 
zooming slows. 

• Panning speed depends on the length of 
the camera’s Line of Sight. In general, it 
is likely to be faster in an exterior view of 
a large model, slower in an interior view 
of a small room. See “Creating Camera 
Views” on page 50.

Press Ctrl + Alt + S while in a camera
view or overview to spin the view.

Press Esc to stop the spinning.
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By default, panning and zooming adjusts the 
position and direction of the camera. It does 
not, however, adjust the distances at which 
surfaces are clipped. This means that if you 
zoom in closely on an object, some of its 

surfaces may be removed from the view. One 
way to avoid this is to lower the camera’s 
Clip Surfaces Within value in the Camera 
Specification dialog. See . 

3Dconnexion® 3D Mice
3Dconnexion®'s 3D mice can be used to 
navigate in all views - including camera 
views and overviews.

In the Windows version of Chief Architect, 
pre-programmed view direction hotkeys are 
supported on devices with buttons for that 
purpose. MacOS™ does not provide mapping 
support to the view direction commands; 
however, you can create custom hotkeys for 
the commands in Chief Architect and then 

program your 3D mouse to use those 
hotkeys. See Hotkeys.

You can specify whether navigation is 
centered about the camera or its focal point 
in the Preferences dialog. See “Render 
Panel” on page 61.

Note that rolling is not supported in Chief 
Architect and that 3D mice cannot be used to 
move the mouse pointer. For details about 
using your 3D Connexion® mouse, refer to 
its documentation.

Move Camera with Mouse
An active camera’s position can be 
edited using the mouse. Select 3D> 

Move Camera With Mouse to access the 

Move Camera with Mouse modes. These 
tools are not available in Cross Section/
Elevation views.

Hotkey Description

Alt + O Mouse-Orbit Camera lets you move the mouse to rotate the camera 
around its focal point. The camera’s position and direction both change.

To continuously rotate the camera around its focal point, click in the 3D 
view, drag the mouse, and release the mouse button to “throw” the 
view. Click again in the view to stop it from rotating. 

Alt + 
middle 
mouse 
button

To temporarily activate Mouse-Orbit Camera, hold down the Alt key 
and then click and drag using the middle mouse button. When the Alt 
key and middle mouse button are released, whatever tool was 
previously in use will still be active. 
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Move Camera with Keyboard
An active camera’s position can be changed 
using the Arrow keys on your keyboard. 
Select 3D> Move Camera with Keyboard 
to access the Move Camera with Keyboard 
modes.These modes are not available in 
Cross Section/Elevation views.

These modes use the Incremental Move 
Distance and Incremental Rotate Angle set 
in the active 3D view’s Camera 
Specification dialog. 
• Keyboard-Orbit Camera lets you use 

the keyboard to rotate the camera around 
the focal point. The camera’s position 
and direction both change.

• Keyboard-Pan Camera lets you move 
the camera up, down, right, and left using 
the keyboard. The camera’s position 
changes, but its direction does not.

• Keyboard-Dolly Camera lets you move 
the camera forward and back using the 
Up and Down Arrow keys, and rotate 
side to side using the Left and Right keys. 

• Keyboard-Tilt Camera lets you use the 
Arrow keys to tilt the camera up, down, 
or side to side to change the focal point. 
The camera’s direction changes, but its 
position does not. 

Alt + P Mouse-Pan Camera lets you move the camera up, down, left and right 
using the mouse. The camera’s position changes, but its direction does 
not.

Alt + D Mouse-Dolly Camera lets you move  the camera forward and 
backward by moving mouse up and down. Move the mouse left or right 
to rotate the camera side to side. 

Alt + T Mouse-Tilt Camera lets you move the mouse to tilt the camera in any 
direction while staying in the same location. 

3D Center Camera on Point lets you focus the camera at a particular 
point in the scene. This changes the camera’s direction and focal point, 
but not its position. To use the 3D Center tool, activate the tool and 
then click on any object in the scene.

Z 3D Focus on Object lets you focus the camera on a specific object. 
This changes the camera’s position, direction, focal point, and the 
length of its line of sight. To use the 3D Center tool, activate the tool 
and then click on any object in the scene.

Hotkey Description
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Move Camera Tools
Select 3D> Move Camera in a 3D view to 
access these tools. These tools change the 
active camera’s position, but not its direction 
and are not available in Cross Section/
Elevation views. 

These tools use the Incremental Move 
Distance set in the active 3D view’s Camera 
Specification dialog. 

Orbit Camera Tools
Select 3D> Orbit Camera in a 3D 
view to access these tools. Orbiting 

the camera rotates it about the focal point 
using the Incremental Rotate Angle set in 

the active view’s Camera Specification 
dialog. 

These tools are not available in Cross 
Section/Elevation views.

Hotkey Description

F Move Camera Forward moves the camera and its focal point forward. 

B Move Camera Back moves the camera and the focal point back. 

L Move Camera Left moves the camera and the focal point to the left in 
a line perpendicular to the line of sight. 

R Move Camera Right moves the camera and the focal point to the right 
in a line perpendicular to the line of sight. 

U Move Camera Up moves the camera and the focal point up. 

D Move Camera Down moves the camera and the focal point down. 

Hotkey Description

I Move Camera In moves the camera closer to the focal point along the 
line of sight. The camera cannot move past the focal point using this 
tool.

O Move Camera Out moves the camera away from the focal point along 
the line of sight. 
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Tilt Camera Tools
Select 3D> Tilt Camera to access 
these tools. Tilting keeps the camera 

in one place and pivots the camera about its 
vertical or horizontal axis. This movement 
uses the Incremental Rotate Angle set in 
the active view’s Camera Specification 

dialog and is similar to tilting your head up 
and down or turning it side-to-side. 

These tools are not available in Cross 
Section/Elevation views. 

Orbit Camera Upward rotates the camera up about the focal point. 
The camera cannot rotate past a vertical line looking straight down on 
the focal point.

Orbit Camera Downward rotates the camera down about the focal 
point. The camera cannot rotate past a vertical line looking straight up 
at the focal point.

Orbit Camera Left rotates the camera to the left about the focal point.

Orbit Camera Right rotates the camera to the right about the focal 
point. 

Hotkey Description

Hotkey Description

Tilt Camera Upward tilts the camera up while keeping it in the same 
location. The camera cannot tilt beyond the vertical position.

Tilt Camera Downward tilts the camera down while keeping it in the 
same location. The camera cannot tilt beyond the vertical position.

Turn Camera Left turns the camera to the left while staying in the 
same location.

Turn Camera Right turns the camera to the right while staying in the 
same location.
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View Direction Tools
The View Direction Tools allow you 
to view the model from a specific 

direction in a camera view, overview, or 
cross section/elevation view. While one of 
these views is active, select 3D> View 
Direction to access these tools. 

Editing 3D Views
In addition to its position and direction, there 
are other ways to modify a 3D view.

In the Specification Dialog
You can  make adjustments to a 
camera in the Camera Specification 

dialog. This dialog is particularly helpful for 
making fine adjustments to the camera’s 
position, appearance, and other attributes. 
See “Camera Specification Dialog” on page 
64.

Using the Edit Tools
A camera symbol or symbols selected in 
floor plan view can be edited in a variety of 
ways using the buttons on the edit toolbar. 
See “The Edit Toolbar” on page 12.

The Copy/Paste  and Copy and Paste in 
Place  edit tools will be available for a 
selected camera or overview. They are not, 
however, available for levation views. See 
“Copying and Pasting Objects” on page 75.

Using the Edit Handles
Return to floor plan view without closing the 
3D view. See “Working in Multiple Views” 
on page 34. 

Description

Front View creates a front view 
of the model.

Back View creates a back view 
of the model.

Top View creates a top view of 
the model.

Bottom View creates a bottom 
view of the model.

Left Side View create a left side 
view of the model.

Right Side View create a right 
side view of the model.

Restore Original View restores 
the original view position.

Description

Tile a 3D view and the floor plan view
and use the camera movement tools to

see how they affect the camera. See “Tiling
Views” on page 34.
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Using the Select Objects  tool, select the 
camera object. When a camera symbol is 
selected it displays four edit handles. 

• Drag the Line of Sight handle to change 
the camera angle without moving the 
focal point.

• Drag the Move handle to relocate the 
camera while maintaining its relative 
angle.

• Drag the Focal Point handle to reposition 
the focal point and change the line of 
sight without moving the camera.

• Drag the Rotate handle to rotate the cam-
era’s line of sight about its center.

The 3D view corresponding to the camera 
symbol reflects changes made to the symbol 
in floor plan view. 

Multiple camera symbols can be selected; 
however, their editing options are limited to 
being moved, rotated, and deleted. 

Using the Contextual Menu
In a 3D view, right-click in an empty space in 
which the backdrop or background color 
displays to access the contextual menu. See 
“Contextual Menus” on page 13. 

• In Vector Views, the options are a selec-
tion of commonly used commands from 
the File, Edit, Tools and Window menus. 

• In the other Rendering Techniques, the 
options are a selection of tools and tog-
gles specific to the current view.

Up One Floor/Down One Floor
You can move a camera to a different floor. 
While the camera view is active, select 
Tools> Reference Floors> Up One 
Floor  or Down One Floor . Note that 
this may affect what is seen in the view as 
well as its display in floor plan view. See “In 
Floor Plan View” on page 53. 

The position and movement of a camera is 
affected by its location within the model. 
When the camera is outside a building, its 
height is relative to the terrain and follows 
the terrain as it is moved. When inside a 
building, the camera height is relative to the 
floor of the room it is drawn in.

If the camera is on an upper floor and you 
move the camera outside of the building, the 
camera remains at the same height relative to 
the floor it was created on.

Zooming
The Zoom Tools are available in all 
3D views. See “Zoom Tools” on page 

37. 

Selecting Window> Zoom In , Zoom 
Out  or Fill Window  does not change 

Rotate

Focal Point

Move

Line of Sight

Move
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the camera’s location or field of view. 
Instead, the extents of the view are expanded 
or cropped. 

Field of View
The Field of View refers to a camera’s field 
of vision. A wider field of view makes the 
focal point appear further away, as more of 
the image is included in the same view 
window. 

In floor plan view, the angled lines of a 
camera symbol indicate its field of view. 

A camera’s field of view can be adjusted in 
the Camera Specification dialog. See .

Cross Section Slider
Select 3D> Camera View Options> 
Cross Section Slider when a camera 

view or overview is active to open the Cross 
Section Slider dialog. 

FOV Indicators

Note: The Cross Section Slider is not avail-
able when the Vector View Rendering Tech-
nique is used. See “Rendering Techniques”
on page 68. 
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To use the Cross Section Slider

1. Check the box beside a cross section 
cutting plane to select it and make its 
Position slider and text box active.

2. Move the Position slider to adjust the 
position of the cutting plane. 

•  The cutting plane Position is measured 
from the edge of the model that is cut 
first by the selected cutting plane.

•  Position the Cutting Plane with accu-
racy using the text field to the right of 
the slider. 

3. Repeat steps 1-3 to use additional cut-
ting planes if you wish. 

4. Click OK to close the dialog.  

Saving and Printing 3D Views
3D camera views, overviews and cross 
section/elevation views can be saved with the 
plan in which they are created, exported and 
saved as image files, as well as printed. 

Saving 3D Views
Select 3D> Save Active Camera to 
save the current camera in the plan. 

You can also save a camera view by checking 
the Saved box in the Camera Specification 
dialog. See “Camera Specification Dialog” 
on page 64. 

In addition, if Text objects are drawn in a 
cross section/elevation view, you will be 
prompted to save the view when you close it. 
Any Text objects added to a cross section/
elevation view are saved with the view as 
part of the plan file. 

Activating Saved Views
There are three ways to open a saved 3D 
view: 
• Select the camera symbol in floor plan 

view and click the Open View  edit 
button.

• Double-click the camera symbol using 

the Select Objects  tool.
• Right-click on it and select Open View 

from the contextual menu.

Unsaved cameras that are open in another 
view window can also be activated using the 

Open View  edit button.

If you open a saved camera view and then 
modify its location or direction using any of 
the tools available in that view, the program 
will confirm whether you want to re-save the 
camera using these new settings when you 
close it. See “Repositioning Cameras” on 
page 55.

Exporting 3D Views
All 3D views can be exported and 
saved as .bmp, .jpg, .png, or .tif files. 

Select File> Export> Picture to save the 
current screen image as an image file. See 
“To export a picture” on page 86.

In addition, Vector Views can be exported 
and saved as .emf files. See “Metafiles” on 
page 86. 
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Once saved, a picture can be opened and 
converted into many other formats using a 
graphics program.

Printing 3D Views
Since all 3D views other than Vector 
Views are created using pixels instead 

of lines, File> Print> Print Image must be 
used when printing. Print Image is a special 

Chief Architect Viewer function that prints 
the screen in picture format.  

Closing 3D Views
Although you can have any number of 3D 
views open at a time, to conserve resources 
on your computer it is a good idea to close 
views when you no longer need them. There 
are a number of different ways to do this. See 
“Closing Views and Files” on page 39. 

Camera Specification Dialog
The Camera Specification dialog can 
be accessed in floor plan view by 

selecting camera symbol and clicking the 
Open Object edit button. See “In Floor Plan 
View” on page 53.

This dialog can also be accessed while a 
camera view or overview is active by 

selecting 3D> Edit Active Camera . 

The selected view’s specific type is indicated 
in the dialog’s title bar: the specification 

dialog for a Full Camera , for example, 
is named Full Camera Specification. 
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Camera Panel

General - 

• Specify the Name that displays in the 
camera label in floor plan view.

• Check Show Shadows to turn on shad-
ows in the selected camera view. When 
unchecked, shadows are not generated.

• Check Ray Casted Sun Shadows for 
higher quality shadows cast by sun light. 
Ray Casted Sun Shadows take longer to 
generate than regular shadows and only 
refresh when the camera is not moving. 

• Check Edge Smoothing When Idle to 
apply high quality edge smoothing to 
edge lines when the selected camera is 
not in motion. See “Edge Smoothing” on 
page 68. 

• Select the amount of Ambient Occlusion 
to use using the slider bar or text field. 
Ambient Occlusion allows variation in 

the strength of the ambient light. It is 
more realistic than uniform ambient light, 
but takes longer to render. Only affects 
Standard renderings. 

The Lighing settings control how many 
and which light sources are used in the 

current view. 

The Positioning settings determine the 
position and orientation of the camera. 

See “Repositioning Cameras” on page 55. 
• The Height Above Floor defines the 

height that the camera is above the floor 
level for the current floor. See “Camera 
Height” on page 51.

• The Tilt Angle determines the vertical 
angle that the camera is tilted. The cam-
era maintains its focal point and position 
in floor plan view, but if the camera is 
tilted, the focal point is above or below 
the current camera height. 

1

2

3
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To change a setting below, first uncheck 
Default. 
• The Incremental Move Distance con-

trols how far the camera moves each time 
you Pan in any direction or Dolly for-
wards or backward using the keyboard, 
toolbar buttons, or menu. For interior 
views a small number is good, but for 
exterior you may want a larger increment.

• The Incremental Rotate Angle defines 
how many degrees the camera rotates 
each time you Tilt, Orbit, or Dolly side to 
side using the keyboard, toolbar buttons, 
or menu. A setting of 90° would make 
one full rotation in four moves.

• The Field of View defines the camera’s 
field of vision in angular degrees. See 
“Field of View” on page 62.

Options - 

• Clip Surfaces Within - Objects located 
within this distance from the camera do 
not display in the view. Decrease this 
value to display objects located very 
close to the camera; increase it to 
improve the appearance of some surfaces 
in Overview cameras with very large 
extents. 

TODO

You can increase a camera’s Field of
View when the view is active by press-

ing the W key, or decrease the Field of View
by pressing the N key. 

4
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Chapter 7:

3D Rendering

There are a variety of tools available to 
create 3D views of a model: simply click a 
button to create an overview, or click and 
drag to create a camera or cross section/
elevation view. See “3D Views” on page 47.

To improve the quality of the rendering and 
create a custom look, you can  choose from 
several rendering techniques . 

Chapter Contents
•      Rendering Effects
•      Rendering Techniques
•      Speeding up 3D View Generation



68

Chief Architect Viewer X10 Reference Manual

Rendering Effects
There are a variety of factors which affect the 
appearance and quality of rendered 3D 
views. These options may also affect 
program performance. 

Shadows
Shadows have an important effect on 
image quality.Shadows are enabled in 

Full and Floorcamera views by default. You 
can, however, check or uncheck Show 
Shadows in the defaults dialog for any 
camera tool or in the. In addition, you can 
select 3D> Camera View Options> Toggle 
Shadows  in any camera view. See 
“Camera Panel” on page 65.

Edge Smoothing
Angled surface edges will sometimes display 
on screen as jagged or stair-stepped. Edge 

Smoothing softens this effect, producing 
cleaner lines.

High quality Edge Smoothing can be 
produced by checking Edge Smoothing 
When Idle in the Camera Specification 
dialog. This setting does not affect a camera 
while its position or orientation are being 
changed, but applies additional smoothing to 
edge lines when the camera is not in motion. 
See “Camera Specification Dialog” on page 
64. 

This high quality Edge Smoothing option is 
view-specific and can also be toggled on or 
off by selecting 3D> Camera View 
Options> Toggle Edge Smoothing When 
Idle . 

Rendering Techniques
Any camera view, cross section/
elevation view, or overview can be 

generated using one of several Rendering 
Techniques to produce views for a range of 
different purposes. When a 3D view is 
active, select 3D> Rendering Techniques to 
access these tools. 

Standard Rendering
Standard rendering is a photo-
realistic technique that represents 

materials using textures, models lighting, and 
can also display shadows. Surface edge lines 

are not drawn and no special colors or effects 
are applied. 

In floor plan view, the camera 
symbol for a view using the 
Standard technique displays an S 
in its center. See “Displaying 3D 
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Views” on page 53.

Vector View
In Vector Views, surface edge lines 
are drawn and pattern lines and colors 

are used to represent materials while textures 
are not. Shadows are supported, and when in 
use a single light source is used to produce 
them. Shading Contrast can be applied to 
surfaces, but other special colors or effects 
are not.

In floor plan view, the camera 
symbol for a view using the 
Vector View technique displays a 
V in its center. 

Glass House
Glass House rendering uses different 
shades of a single color to display the 

model with surface edge lines and semi-
transparent surfaces. Lighting and shadows 
are not modeled, and materials are not 
represented, so neither pattern lines nor 
textures are used. 

In floor plan view, the camera 
symbol for a view using the Glass 
House technique displays a G in 
its center. 

Physically Based
Physically Based rendering is similar 
to the photo-realistic Standard 

technique: it represents materials using 
textures, does not draw surface edge lines, 
models lighting, and can display shadows.

Physically Based rendering models material 
properties and light propagation more 
accurately than other rendering techniques 
and is best used when a focus on lighting and 
finish materials is the goal.

In floor plan view, the camera 
symbol for a view using the 
Physically Based technique 
displays a Ph in its center. 

Glass House Options
You can modify the appearance of 
Glass House Views by selecting 3D> 

Rendering Techniques> Glass House 
Options. 
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• Click the Color bar to select a color for 
the semi-transparent surfaces and lines in 

a Glass House view. See “Color Chooser 
Dialog” on page 17. 

• Click Reset to Defaults to restore the 
default settings used when the Glass 
House view was first created. 

Speeding up 3D View Generation
When you have a large, complex model with 
a lot of detail, it may take some time to 
generate a 3D view of everything in the 
model. During this process, progress 
information may display in the Status Bar 
and in a message window. 

There are several ways to speed up the 
generation time of views.

Turn Off Layers
The display of objects in 3D views can be 
turned on or off in the Display Options 
dialog. Turning off unneeded layers in 3D 
views can speed up 3D view generation time. 
See “Layer Display Options Dialog” on page 
42. 

Rendering Preferences
In the Preferences dialog, there are a 
number of settings that you can use to 
balance rendering quality and generation 
time. See “Render Panel” on page 61.

Halt Generation with Esc Key
In a large, complex model, repositioning the 
camera can be time-consuming. You can 
speed up this process using the Esc key. 
When you press the Esc key, the modeling 
process is interrupted and the view is 
displayed “as is”. Then, press the  F5 key to 
refresh the display. 
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Chapter 8:

Text

Text is an simple and effective way to 
communicate your thoughts and suggestions 
regarding a drawing. Text can be added in 
floor plan and cross section/elevation views, 
and to layout pages.

Text lines with arrow can be attached to text 
objects, allowing you to direct attention to 
specific plan details.

Chapter Contents
•      Creating Text
•      Displaying Text
•      Rich Text Specification Dialog
•      Text Specification Dialog
•      Editing Text
•      Copying and Pasting Text
•      Text Arrows
•      Line/Polyline Specification Dialog

Missing Fonts
If you open a plan or layout file that uses a 
font that is not installed on the current 
computer, the program will give you an 
opportunity to replace it in the Replace 
Fonts dialog. 
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The table lists all missing fonts and how they 
will be replaced. 
• Click on a font name in the list to select 

it. Use the Shift or Ctrl key to select mul-
tiple fonts. See “Shift and Ctrl Select” on 
page 83. 

• Select a replacement font from the 
Replace With drop-down list, or leave 
“No Change” as the selection to maintain 

the file’s association with the missing 
fonts. 

• A preview of the selected font displays 
below the Replace Width list.

If you do not plan to return the file to the 
computer where it was created, you may 
want to replace missing fonts with the fonts 
you normally use. On the other hand, if you 
do intend to return the file, you may prefer to 
not replace any missing fonts.

Creating Text
Text can be created in floor plan view, in 
cross section/elevation views, and on layout 
pages. 

Once created, text can be selected and edited 
in a variety of ways. See “Editing Text” on 
page 77. 

To create Text

1. Select Tools> Text . 
2. Click in the drawing area, and the Rich 

Text Specification dialog will open. See 
“Rich Text Specification Dialog” on 
page 73.

3. Type or paste the desired text into the 
Text Field.

4. Use the options in the dialog to change 
the font, style and size of any portion of 
the text. 

5. When you are finished, click OK. The 
Text  tool remains active, so you can 
create additional text objects if you 
wish. 

You can also create lines with arrows 
connecting the text that you create to items in 
the drawing. See “Text Arrows” on page 80. 

Displaying Text
As with other types of objects, the display of 
Text objects is controlled in the Layer 
Display Options dialog.   See “Layer 
Display Options Dialog” on page 42. 

Text objects can only be displayed in views 
where text can be created. 

The display attributes of each individual text 
object can be controlled independent of the 
layer it is placed on. See “Rich Text Specifi-
cation Dialog” on page 73. 

The display attributes of individual text 
objects, such as color and size, can be set in 
their specification dialogs. See “Rich Text 
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Specification Dialog” on page 73 and “Line/
Polyline Specification Dialog” on page 81.

Rich Text Specification Dialog
The Rich Text Specification dialog 

opens if you select the Text  tool 
and then click once in the drawing area. 

You can also open this dialog by selecting a 
Text  object, then clicking the Open 
Object edit button. 

Arrow Lines   have their own 
specification dialog. See “Line/Polyline 
Specification Dialog” on page 81.

Text Panel
The settings on the TEXT panel allow you to 
type the selected Text object’s content and 
control many aspects of its appearance, 
including its font, size, color and style.

You can specify the appearance of the text 
before typing, and can also select and change 
the attributes of all or portions of the text 
content after it is typed. To change text that 
already exists, simply highlight it using the 

mouse and/or the Shift + arrow keys and then 
make any needed changes to its attributes. 

Note: If you do not type anything in the text
field on this panel when creating a new
object, no object will be created when you
click OK. On the other hand, if you remove
the text from an existing object and click OK,
an empty text box will result.
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Use the options on the Edit Bar, which 
displays above the Text Entry field, to 

change the font, size, and style of the text.

Select the desired options before typing to 
affect the text as it is typed, or select some or 
all of the text and then specify which options 
to apply to it.
• Select a Font from the drop-down list.
• Specify the Text Size in drawing units. 

• Click the Color  button to specify the 
color of the selected or subsequently 
typed text. See “Select Color Dialog” on 
page 44. 

• Click the Bold  button to specify the 
selected text as bold.

• Click the Italic  button to specify the 
selected text as italic.

• Click the Underline  button to specify 
the selected text as underlined.

• Click the Strikethrough  button to 
specify the selected text as stricken-
through.

• Click the Uppercase  button to dis-
play the selected text in all capital letters.

• Click the Align Left , Align 
Center , or Align Right  button to 
specify the how text is aligned.

• Click the Paragraph Options  button 
to specify the selected paragraph’s align-
ment, spacing and bullets or numbering 
in the Paragraph Options dialog. 

• Specify the Zoom factor of the selected 
text by typing a percentage value in the 
text field or clicking the up/down arrows. 
This setting only affects the text as it 
appears in this dialog.

Type or paste text in the Text Entry 
field. See “Copy, Cut and Paste” on 

page 79.
• Right-click in the Text Entry field to 

access a contextual menu from which you 
can select Undo, Redo, Cut, Copy, Paste 
and Select All. See “Contextual Menus” 
on page 13. 

• To edit text in the entry field, click and 
drag to highlight any portion of it and 
then use the tools on the Edit Bar as 
needed.

1

Note: Some fonts cannot be drawn at certain
zoom factors. When this is the case, the
appearance of the text will not change.

2
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Paragraph Options Dialog

Specify the Alignment of the selected 
paragraph(s). 

Specify the Line Spacing of the 
selected paragraph(s). 

• Click the radio button beside Single, 1.5 
Lines, Double or User Specified.

• If you select User Specified Line 
Height, type the desired height for each 
line of text in the selected paragraph(s). 
For best results, this value should be at 
least as much as the largest character size 
used in the selected paragraph(s). 

Specify the appearance of the side 
Margins of the selected paragraph(s), 

as measured in from edges of the text box. 
Only positive Margin values can be used. 
• Specify the Indent, which is measured 

from the left side margin. A negative 
value can be used if a left Margin has 
been specified.

Specify the appearance of Bullets and 
numbering in the selected paragraph(s). 

• Select the desired bullet, numbered, or 
lettered Type from the drop-down list.

• Specify the Number Prefix, which are 
any characters that you would like to dis-
play before the selected paragraph’s num-
ber or letter. Does not affect paragraphs 
using circle or square bullets.

• Specify the Number Suffix, which are 
any characters that you would like to dis-
play after the selected paragraph’s num-
ber or letter and before its actual text. 
Does not affect paragraphs using circle or 
square bullets.

Text Specification Dialog
The Text Specification dialog opens 
if you select a simple Text object and 

click the Open Object edit button. 

1

2

3
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Text Panel
The settings on the TEXT panel allow you to 
type the selected Text object’s content.

Enter text in the Text Entry field.  

Select an Alignment option from the 
drop-down list to apply to the text.

A preview of the selected text object 
displays on the right.

Text Style Panel

1

2

3
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Uncheck Use Default Text Style to 
enable the settings that follow. When it 

is checked, information about the Text Style 
that is assigned to the selected object 
displays for reference.

Specify the attributes of the selected 
Text Style’s Font. 

• Select a font from the drop-down list.
• The text styles Bold, Underline, Italic, 

Strikeout, and Uppercase are available. 
Check any of the boxes to apply that 
style.

Specify the Size of text using the 
selected Text Style. 

• Enter the Character Height in drawing 
units. This height is subject to the current 
drawing scale. When imperial Inches or 

Feet and Inches are used, accuracy to 
1/128” is possible. 

Specify the selected Text Style’s Text 
Color. When Use Custom Text Style is 

not selected above, a Text Color does not 
display here for reference. 
• When By Layer is checked, text uses the 

line color assigned to the layer it is 
located on. See “Layers” on page 41. 

• Uncheck By Layer, then click the Color 
bar to select a different color. See “Select 
Color Dialog” on page 44.

A preview of the Text Style currently 
assigned to the selected object displays 

here.

A preview of the selected text object  
displays here.

Editing Text 
Once created, Text  objects and Arrow 
Lines  can be selected and edited using 
the edit handles the edit toolbar buttons, and 
their specification dialogs. See “Rich Text 
Specification Dialog” on page 73.

To select a Text  object or Arrow 
Line , click on it using either the tool 

used to create it or the Select Objects  
tool.

Sometimes, multiple Text  objects or 

Arrow Lines  are located close to one 
another, making it difficult to select a 
particular object. Click as close as you can to 
the desired object, then click the Select Next 

Object  edit button or press the Tab key 
until the object is selected. 

Editing Text Attributes
Most text attributes, including the font, size, 
style, and the content itself, are edited in the 
Rich Text Specification dialog.

In order to edit the attributes of an existing 
Text  object, you must select some or all 
of the text before making changes. See “Text 
Panel” on page 73. 

To edit Text attributes

1. Select a Text  object and click the 

Open Object  edit button.

1

2

3

4

5

6
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2. On the TEXT panel of the Rich Text 
Specification dialog, click and drag to 
select some or all of the text typed into 
the Text field. 

3. With some or all of the text selected, 
change any of the attributes available 
along the top of the panel, including the 
font, size, color, and style.

4. As changes are made, the selected text 
updates. Only the selected text is modi-
fied.

Using the Mouse

When a Text  object or Arrow Line  
is selected, it displays edit handles. Use the 
edit handles to resize, extend/contract, move, 
and rotate the selected object. 

As a text box’s width is made narrower or 
wider using an edit handle, its height may 
increase or decrease so that none of the text 
becomes hidden. The opposite is not true, 
however: a text box’s height cannot be 
resized smaller than the height of the rows of 
text it currently contains.

Arrow Lines  can also be connected to 
form polylines that can be reshaped using the 
edit handles. 

Using the Edit Tools

A selected Text  object or Arrow 
Line  can be copied or deleted using the 
edit toolbar buttons.

To copy and paste an object

1. Click on the text or arrow line to select 
it.

2. Click the Copy/Paste  edit button.
3. Click anywhere in the drawing area to 

paste the copy at that location.

Resize

Extend/
Contract

Rotate

Move

Change Angle/ 
Resize

Rotate

Move
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To make multiple copies, click the Sticky 
Mode  edit button before clicking in the 
drawing area. With Sticky Mode enabled, 
you can continue to click to paste as many 
copies of the object as needed. 

When you are finished, click the Main Edit 
Mode  edit button or select another tool.

You can also Cut , Copy , and 

Paste  a selected object by selecting these 
options from the Edit menu. These are the 
same as the standard Windows commands. 

To delete an object, select it and click the 

Delete  edit button or press the Delete key 
on your keyboard.

Resizing Text

The character height of Text  objects can 
be specified in their specification dialogs. 

Aligning Text
The text content of a text object can be 
aligned to the left, right, center or justified in 
the Rich Text Specification dialog. See 
“Text Panel” on page 73.

Copy, Cut and Paste
Copy, Cut and Paste of text into and out of 
the Rich Text Specification dialog can be 
accomplished using keyboard hotkeys:
• Press Ctrl + X to Cut the selected text and 

save it to the system clipboard.
• Press Ctrl + C to Copy the selected text 

and copy it to the system clipboard.
• Press Ctrl + V to paste your last cut or 

copied selection in a new text object.

Copy, Cut and Paste use the system 
clipboard, making it possible to to transfer 
text between text objects, between Chief 
Architect Viewer files, from a plan or layout 
into another application, or vice versa. 

Copying and Pasting Text
The Copy, Cut and Paste commands use the 
system clipboard, making it possible to 
transfer text between text objects, between 
Chief Architect Viewer files, from a plan or 
layout into another application such as a text 
editor or spreadsheet program, or vice versa. 

Cut, Copy, and Paste can also be accessed 
from the Edit menu of many applications, 
including Chief Architect Viewer. These 
menu commands are not available when the 
text specification dialogs are open, but you 
can use the associated hotkeys. 

To Copy, Cut and Paste text

1. On the TEXT panel of either text specifi-
cation dialog or in another program alto-
gether, highlight the text you wish to cut, 
copy or paste.

2. Press Ctrl + X to Cut the selected text 
out of its original location and save it to 
the system clipboard.

3. Press Ctrl + C to Copy the selected text 
to the system clipboard without remov-
ing it from its original location.
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4. Open the text object or a file in another 
application and click to place your cur-
sor in the Text field, writing area, or 
spreadsheet cell.

5. Press Ctrl + V to Paste the copied text at 
the location of your cursor.

Bear in mind that when text is copied and 
pasted, its formatting is not always retained. 
The results depend on the program or type of 
text object in which the content was created 
as well as the type of text object into which it 
is pasted. 

Pasting into Rich Text
Text pasted into a Rich Text object 
from another source will retain most - 

but not necessarily all - of its custom 

formatting. If a line of text is sufficiently 
long, however, it may be wrapped 
automatically when pasted into Rich Text. 

Text pasted into a RichText  object from 
a spreadsheet program retains basic column 
and row information. Column width cannot 
be adjusted; however, as you add or remove 
text from a cell, row height will increase or 
decrease to accommodate your changes.

Pasting into a View
Text can also be pasted directly into a plan 
viewelevation view. When you use the Paste 
command, a new Rich Text object is created, 
the text is pasted into that object, and it is 
selected. In order to see the new object, you 
may need to Fill Window. 

Text Arrows
Text arrows can be used to connect text 
objects to details of interest in your drawing.  

Text arrows can be snapped together to form 
open or closed polylines. If two lines with 
arrows meet within the bounding box of a 
text object, however, they will not join. This 
allows you to attach multiple, separate text 
arrows to a single text object.

Lines with arrows can be independent or 
attached to other objects. If an attached 
object is moved, the end of the Arrow Line 
will move, as well. Arrows attach to closed 
polyline-based objects along their edges, but 
can attach to Text or an architectural object 
anywhere within its bounding box in floor 
plan view. 

If an arrow is attached to text or another 
object, deleting either the text or the object 
will also delete the arrow. 

Arrow Line
Arrow Lines can be attached to text 
and architectural objects by selecting 

Tools> Arrow Line and then clicking and 
dragging to draw a line. There is no limit to 
the number of text lines with arrows that can 
be attached to an object.

The endpoints of Arrow Lines  can be 
joined to form polylines with corners that can 
be adjusted using the edit handles.  
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Auto Position Arrows
The following image illustrates the behavior 
of Auto Positioning. When the head of the 
arrow line is moved, the tail of the arrow 
snaps to different Auto Position locations on 
the text object, maintaining its connection.

Line/Polyline Specification Dialog
Select an Arrow Line and click the 
Open Object edit button to open the 

Line Specification dialog or the Polyline 

Specification dialog (if the object is 
composed of multiple line segments). 

Line Style Panel
The LINE STYLE panel allows you to control 
the line color and style of the selected line or 
polyline. 

• Click the Color bar to select the Color of 
the selected object’s line(s). See “Select 
Color Dialog” on page 44.

• Click the Style drop-down lis t to select a 
line style used to display the selected 
object.

An additional Display Options setting is 
available In the Picture File and Metafile 
Box Specification dialogs. See “Pictures, 
Metafiles, and Walkthroughs” on page 85.
• Check Show Outline to display the 

selected object’s border polyline. 
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Arrow Panel
The ARROW panel is available for lines and 
open polylines, but not for closed polylines.

• Select an arrowhead Style from the drop-
down list. Check Default to reset the 
arrow type.

• Select the Fill Color used to fill the 
arrowheads. Check Default to reset the 
fill color. See “Select Color Dialog” on 
page 44.

• Define a Size for the arrow(s). Check 
Default to reset the size.

• Check Arrow on Both Ends to place an 
arrow on both ends of the selected line or 
polyline.

Fill Style Panel
The FILL STYLE panel is available for closed 
polylines, but not for open polylines.

• Choose a Fill Pattern from the drop-
down list. The options that follow are dis-
abled if “None” is selected.

• Define the Spacing for the selected fill 
pattern. 

• Check Transparent Pattern Back-
ground to make the fill pattern transpar-
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ent. When you check this option, any 
objects behind the fill pattern are visible 
through it. 

• Fill Pattern Color - Select a line color or 
fill color if a solid fill is specified. This 
overrides the layer color. See “Select 
Color Dialog” on page 44.

• Use the Transparency slider bar or text 
field to control how transparent the fill 
pattern lines are. This setting also affects 
Solid fill colors. 

A preview of the selected pattern displays on 
the right. As changes are made to the settings 
on this panel, the preview will update.
• Choose a Preview Width from the drop-

down list. This value controls how large 
an area the preview represents. The 
selected value indicates the length of 
each side of the preview in actual plan 
inches (mm). 



84

Chief Architect Viewer X10 Reference Manual



 85

Chapter 9:

Pictures, Metafiles,
and Walkthroughs

You can save any view using a variety of 
picture file formats. In addition, Chief 
Architect Viewer allows you to create virtual 
tours that can be saved as .avi files, shared 
with others, and played back later.

You can save any 2D or 3D view using a 
variety of picture file formats that can be 
opened in other applications. 

In addition, if your design professional 
provided you with one, you can view a 3D 
walkthrough, which is a video tour of a 
model. 

Chapter Contents
•      Pictures
•      Metafiles

Pictures
There are several ways to save a picture of a 
view in Chief Architect Viewer:

Using the Export Picture tool is 
similar to creating a screen capture of 

everything  in the current view window. 
Pictures can be saved in various file formats 
and used in other applications. 

Export Picture  is best suited for 
rendered views. When exporting a line-based 

view, best results can be achieved by saving 
it as a Metafile. See “To export a metafile” 
on page 86.

Use the Print Image tool to either print or 
save the current view as a PDF file. See 
“Print Image Dialog” on page 95.
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To export a picture

1. Open the view that you would like to 
export as a picture file. 

2. Zoom, pan or otherwise adjust the view 
so that what you see on screen suits your 
needs. See “Displaying 3D Views” on 
page 53.

3. Select File> Export> Export Picture 
(BMP, JPG, PNG)  to open the 
Export Picture File dialog and give the 
file to be exported a name, file type, and 
location. See “Exporting Files” on page 
25.

Metafiles
A metafile (.emf, .wmf) is a special picture 
file format made up of vectors (lines) that 
allow the image to be rescaled without loss 
of quality. High resolution pictures of line-
based views can be exported as a metafile.

Exporting Metafiles
An enhanced metafile (.emf) can be exported 
from any line-based view: that is, from floor 
plan view and 3D Vector Views. 

Only objects that display on screen are 
included in an exported metafile. 

To export a metafile

1. Accurately position the view on screen.
2. Select File> Export> Export Metafile 

(EMF) . 

3. Drag a marquee  from corner to cor-
ner, defining the area that will included 
in the metafile.

4. Release the mouse button to open the 
Export Metafile dialog, which is a typi-
cal Save As dialog. See “Saving and 
Exporting Files” on page 23. 

5. When you click the Save button, the 
Metafile Size dialog opens.

6. Specify the desired Width or Height of 
the metafile. When one value is edited, 
the other changes to maintain its aspect 
ratio. 

Specify, too, the desired Dots Per Inch 
(DPI) for the metafile. A larger value 
results in a higher quality metafile, but 
also a larger file size.

7. When a metafile is exported from a 3D 
Vector View, you can also specify the 
printed thickness of lines in the view. To 
increase the printing line weight, type a 

Note: Metafiles are not supported in Mac
operating systems and cannot be exported in
Mac versions of the software. 
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larger number in the Use Line Weight 
field. See “Vector View” on page 69. 

Metafiles exported from floor plan view 

use the line weights defined in the Layer 
Display Options dialog. See “Layer 
Display Options Dialog” on page 42. 

Walkthroughs
A 3D Walkthrough is a series of pictures 
saved as an .avi file that can be played like a 
video. If your design professional gave you a 
walkthrough of a model, you can view it 
using a media player such as Windows 
Media Player.

To play a walkthrough .avi, begin by copying 
the file to your computer’s hard drive. Then, 
either:
• Double-click on the .avi file to launch 

your default media player and view the 
walkthrough video.

• Launch the media player of your choice 
and use it to play the walkthrough video.

http://www.chiefarchitect.com/
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Chapter 10:

Printing

The Chief Architect Viewer provides a 
variety of printing options, allowing you to 
print up to 11” x 17” in size.

The Chief Architect Viewer also allows you 
to save your drawings in .pdf file format that 
can then be sent to a printing service.

Chapter Contents
•      Clearing Printer Information
•      The Printing Tools
•      Print Preview
•      Printing Across Multiple Pages
•      Printing to a PDF File
•      Print View Dialog
•      Print Image Dialog

Note: Screen captures are provided for
illustrative purposes only and are not an
endorsement of any products.
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Clearing Printer Information
Some information specific to individual 
printers, such as available paper sizes, is 
saved with each plan file. You can select 

File> Print> Clear Printer Info to clear the 
printer-specific information stored with the 
plan file.

The Printing Tools
Select File> Print to view the Print 
Tools submenu.  

Print Preview - Shows on screen how 
the current view will appear printed, 

based on the current scale and other settings. 
See “Print Preview” on page 90.

Print - Prints the current floor plan 
view, Vector View, or layout sheet to a 

specified scale. See “Print View Dialog” on 
page 92.

Print Image - Prints the current view 
including images, textures, and 

backdrop. Views printed with Print Image 
are not scaled. See “Print Image Dialog” on 
page 95.

Clear Printer Info - Clears the printer 
information associated with the current page 
setup.  

Print Preview
Print Preview and its related display 
toggles allow you to get a sense of 

what the current view will look like when it 
is printed. 

Print Preview
Select File> Print> Print Preview for 
an on-screen representation of how 

the current view will appear when printed. 
Print Preview is only available in views that 
can be scaled.

Objects such as camera symbols that do not 

print do not display in Print Preview . 
Text and dimension objects appear on-screen 
as they will on the printed page.

When Print Preview  is enabled, color 
will display depending on whether Print in 
Color is selected in the Print View dialog. 
See “Print View Dialog” on page 92. 

Color
The Color toggle turns the on-screen 
display of color on or off in all views. 
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Printing Across Multiple Pages
When printing directly from a floor plan 
view, cross section/elevation view, or layout 
it is possible to print at a scale that does not 
fit the drawing on one page.

To see on-screen what the drawing will look 
like when printed, select File> Print> Print 
Preview  and then Window> Fill 
Window . Grey lines across the drawing 
sheet  indicate where the page breaks will 
occur. See “Print Preview” on page 90.

To print across multiple pages

1. Select File> Print> Print Preview  
to display the white rectangle represent-
ing the printer paper. See “Print Pre-
view” on page 90.

2. Click the Select Objects  button, 
then click near an edge of the printer 
paper rectangle to select it. 

When selected, the printer paper is 
highlighted in pale grey and a square 
Move edit handle displays at its center.

3. Click and drag the Move edit handle to 
position the printer paper so that the por-
tion of your drawing that you would like 
to print on your first page is located 
within the printable area of the page. 

4. Select File> Print> Print . In the 
Print dialog, make sure To Scale is 
selected, then click OK. See “Print View 
Dialog” on page 92.

5. Select the printer paper rectangle and 
move it so that the desired contents of 
your second printed page are within the 
printable area and print To Scale.

6. Continue moving the printer paper and 
printing as needed.

When printing multiple pages, it is generally 
a good idea to leave some overlap on the 
edges of each page to make sure that 
information near those edges is not left off 
the printed pages by mistake. 

Printing to a PDF File
Portable Document Format, or .pdf files, are  
one of the most universally compatible and 
efficient file formats and can be viewed and 
printed on most computer platforms. 

You can save any view as a .pdf file by 
selecting “Chief Architect Save as PDF” as 
the Destination printer Name in either the 
Print View or Print Image dialog. See “Print 

View Dialog” on page 92 and “Print Image 
Dialog” on page 95. 

If you have a .pdf writer installed on your 
system, you can use it to create a .pdf file 
instead. To print to .pdf, simply select it as 
the Destination printer Name in the Print 
View or Print Image dialog. 
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When you print to .pdf, you will be asked to 
create a file name and choose a destination to 
save it in the Save as PDF File dialog. 

Print View Dialog
To print from floor plan view, 3D 
Vector Views, or layout, select File> 

Print> Print. The Print View, or Print 
Layout, dialog opens. The settings that are 

available will vary depending on which 
version of the dialog is open. 

Note: 3D views that are not Vector Views can
be printed using Print Image.



Print View Dialog

 93

Select the Name of the Printer that you 
would like to use from the drop-down 

list. To print to .pdf, select “Chief Architect 
Save as PDF” from the list, or choose a .pdf 
writer installed on your system. See 
“Printing to a PDF File” on page 91. 
• Select the DPI, or Dots Per Inch to use 

when printing, from the drop-down list. 
The available options may vary depend-
ing on the selected printer.

Select the Paper Orientation, Size, 
and Source. The available Size and 

Source options are controlled by the selected 
printer’s driver.
• When possible, the program will auto-

matically set the Size and Orientation to 
match those of the Drawing Sheet. 

• The Paper Size may be automatically 
adjusted if the Drawing Scale option is 
changed, below.

1 2
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In layout files only, specify the Print 
Range. Only pages that have views or 

objects drawn directly on them will print. 
• Select All to print the entire drawing. 
• Select Current Sheet to print only the 

currently active layout page. 

Specify the Print Source. 

• Select Drawing Sheet to print the entire 
sheet even though you may be zoomed in 
on a portion of the view. 

• Select Current View to print only that 
portion of the active view that is currently 
visible on screen. If you are zoomed out, 
any blank space outside of the printable 
objects in the view is ignored. 

Specify the Drawing Scale of the 
printed output. Changes to these 

options may cause the Paper Size to change, 
above. Not available in camera views or 
overviews. 
• Fit to Paper prints the view on one page. 

The program uses whatever scale is nec-
essary to fit the plan on one page. 

• When Fit to Paper is selected, specify 
the percentage of the paper to be used. 
The default value is 95%.

• Select To Scale to print at the scale speci-
fied in the program in which the file was 
originally created.

• Select To Scale to print at the scale speci-
fied in the Drawing Sheet Setup dialog. 

Options - Specify the number of Cop-
ies you would like to print. 

Advanced Options - Click the Open 
System Print Dialog button to close 

the Print View dialog and print using your 
operating system’s Print dialog instead. Not 
available when No Printer is selected.

Control the appearance of the print job 
Preview on the right side of the dialog.

• Specify the Page that displays in the Pre-
view area.

• Click the buttons to Zoom In, Zoom 
Out, or Fit the selected Page to the 
extents of the Preview area. 

• Uncheck Update Automatically to turn 
off the print job Preview and prevent it 
from updating as changes are made to the 
settings in this dialog. 

• Click the Update button to update the 
print job Preview to reflect the current 
settings in this dialog. If Update Auto-
matically is unchecked, clicking Update 
may force the Preview to be blank.

When Update Automatically is 
checked, a preview of the current print 

job displays here. The drawing sheet displays 
as a white rectangle, and if multiple sheets 
are required, you can scroll through them. If 
the print job is large, a progress dialog may 
display briefly as the preview draws or 
updates.

To help prevent unwanted printed 
output, information messages regarding 

page size, resolution, and scale may display 
here, depending on the settings in this dialog. 

Note: The Fit to Paper percentage value is
global - affecting all views in all files, and is
retained between sessions.

3
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Print Image Dialog
Any view can be printed by selecting File> 
Print Image. This is the only way to print 
most 3D views. See “3D Rendering” on page 
67.

The Print Image dialog is similar to the Print 
View dialog; however, the printing process is 
different. Print Image prints individual 
pixels as opposed to vectors (lines).

Select the Name of the Printer you 
wish to use from the drop-down list. To 

print to .pdf, select “Chief Architect Save as 
PDF” from the list, or choose a .pdf writer 
installed on your system. See “Printing to a 
PDF File” on page 91.

Select the Paper Orientation, Size, 
and Source.

Specify the number of Copies you 
would like to print. 

Advanced Options - Click the Open 
System Print Dialog button to close 

the Print View dialog and print using your 

operating system’s Print dialog instead. Not 
available when No Printer is selected.

Control the appearance of the print job 
Preview on the right side of the dialog.

• Specify the Page that displays in the Pre-
view area.

• Click the buttons to Zoom In, Zoom 
Out, or Fit the selected Page to the 
extents of the Preview area. 

• Uncheck Update Automatically to turn 
off the print job Preview and prevent it 
from updating as changes are made to the 
settings in this dialog. 

1

2

3

4

5
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• Click the Update button to update the 
print job Preview to reflect the current 
settings in this dialog. If Update Auto-
matically is unchecked, clicking Update 
may force the Preview to be blank.

When Update Automatically is 
checked, a preview of the current print 

job displays here. If the print job is large, a 

progress dialog may display briefly as the 
preview draws or updates.

To help prevent unwanted printed 
output, information messages regarding 

page size and resolution may display here, 
depending on the settings in this dialog. 6

7
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