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Chapter 5:

Kitchen and Bath
Design Tutorial

This tutorial continues where the Materials Tutorial left off. You should save this tutorial using 
a new name to archive your previous work. 

The tools and techniques used to design kitchens and bathrooms are very similar. This tutorial 
focuses on kitchen design. When you’re finished you can use what you’ve learned to finish up 
the bathrooms as well. In this tutorial you will learn about: 

•      Adding Cabinets
•      Placing Appliances
•      Editing Cabinets and Appliances
•      Creating a Custom Countertop

•      Creating Architectural Blocks
•      Editing Cabinets and Appliances
•      Working in Cross Section/Elevation Views

Adding Cabinets

First, let’s select File> Save As , and choose to name our plan BeachHouse - Kitchen Bath 
Tutorial.

We’ll begin by placing a cabinet in the kitchen and editing its dimensions, orientation, and 
placement. For more information about cabinets, see “Cabinets” on page 649 of the Reference 
Manual.
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To place a base cabinet

1. Zoom  in on the Kitchen area in floor plan view.

2. Select Build> Cabinet> Base Cabinet .
3. Click to place a base cabinet anywhere in the kitchen.

Once a cabinet is placed, it can be edited like other objects.

To select and edit a cabinet
1. Cabinets can be selected using one of the following methods.

• Click on the cabinet while the Select Objects  tool is active.

• Click on the cabinet while any of the Cabinet Tools  are active. This allows only 
cabinets to be selected.

• Right-click on the cabinet when another tool is active.
2. When the cabinet is selected, edit handles, a front indicator, and a temporary dimension 

display. As with other objects, the arrow that displays when the pointer is held over an edit 
handle indicates what edit function that edit handle will perform. See “Editing Box-Based 
Objects” on page 198 of the Reference Manual.

• Move a cabinet using the move edit handle. By default, you can move a cabinet along 
either the X axis or the Y axis. To allow unrestricted movement, hold down the Ctrl 
key (or click using the right mouse button) then drag the cabinet. 

• Resize two sides of a cabinet using a resize edit handle, located in each corner. 
• Extend a cabinet’s edge on one side using an extend edit handle. One of the extend edit 

handles also displays an arrow that indicates the cabinet’s front. 
• Rotate a cabinet using the rotate edit handle.
• A temporary dimension updates as the cabinet is moved or resized.

Resize edit 
handles

Rotate edit 
handle

Move edit 
handle

Front 
indicator
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3. When the cabinet is selected, you can also click the Open Object  edit button to open 
its specification dialog and make a wide variety of changes to the cabinet. For more 
information, see “Cabinet Specification Dialog” on page 668 of the Reference Manual.

To lay out base cabinets for this tutorial
1. Place and position several initial base cabinets in your plan and edit their width and 

orientation as shown in the following image. 
• Notice that two of the cabinets are 36", two are 24" wide, one is 33" and one is 27" 

wide.
• A cabinet snaps to another if they are in alignment, facing the same direction, and of 

the same type.

To create corner cabinets 
1. Select the three foot base cabinet at upper right.

Note: The display of cabinet module lines has been turned on in the following
images. See “Displaying Cabinets” on page 658 of the Reference Manual for
more information. 
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2. Click the Open Object  edit button to open the Base Cabinet Specification dialog. On 
the General tab:

• Specify a Width greater than the Depth. The selected cabinet’s width should already 
have been changed to 36", which works well with a 24" depth. If it isn’t, change it to 
36" now.

• Click the Special drop-down list and select Corner. 
• On the Front tab, uncheck the box beside Diagonal Door. 
• Click OK to change the cabinet into a corner cabinet.

3. Repeat this process with the upper left Base Cabinet and open it for specification:
• On the General tab, change it to a corner cabinet (as we did in the previous step). 
• On the General tab, change the Left Side Width to 36 inches (36").
• On the Front tab, uncheck the box beside Diagonal Door if it is checked.

4. Click OK to close the Base Cabinet Specification dialog, then select this cabinet, use its 
rotate edit handle, then move it into the corner, until it bumps into the walls.

To place wall cabinets

1. Select Build> Cabinet> Wall Cabinet .

Note: To move a group of cabinets, select one cabinet, place the pointer over the
move handle, the click and drag the mouse cursor and you can push the entire
group of cabinets.



Adding Cabinets

 5

2. Click very above the left corner base cabinet to place a wall cabinet as shown.

3. Click the Open Object  edit button to open the Wall Cabinet Specification dialog:
• On the General tab, specify a Width of 33.
• On the Door/Drawer tab, change the Door Style to Framed Doors, and check Glass 

Doors if it is not already selected.
• On the Moldings tab, choose Add New to add a new molding profile to the cabinet.

For the purposes of this example, we will use a crown molding profile set with a 
Height of 2 1/2", a Width of 2 1/2", and a Vertical Offset of - 2 1/2".

• Click OK to apply these changes to the wall cabinet.
4. Once you have finished modifying the original wall cabinet, select it and click on the Copy 

edit tool, then click near the opposite wall to place a second wall cabinet identical to the 
first, and rotate it so that it faces out in to the door, instead of in to the wall.

To place soffits

Select Build> Cabinet> Soffit  then click above the wall cabinets to place soffits. 
Adjust their width and orientation to match the wall cabinets below.

Note: The display of cabinet face indicator lines has been turned on in the follow-
ing images. See “Displaying Cabinets” on page 658 of the Reference Manual for
more information. 
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Placing Appliances
Appliances come in two basic varieties, freestanding and built-in. Most plans use both types, 
including this one. For more information about library objects such as appliances, see “The 
Library” on page 789 of the Reference Manual.

To place a freestanding appliance

1. Select Library> Library Browser  to open the Library Browser.
2. Go to Architectural> Appliances> Refrigerators, locate a refrigerator, and select it for 

placement.
3. On the left of the kitchen, click in the empty space to the bottom of the base corner cabinet 

to place the refrigerator.

When objects are very close to one another or occupy the same vertical
space in floor plan view, it may be difficult to select the intended object. You

can select an objects, then click the Select Next Object  edit button or press
the Tab key to select a neighboring object. The Status Bar indicates which object
is currently selected.
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4. In the Appliances library, find the electric range and select it for placement.
5. Place the range in the empty space on the right of the kitchen. 

To place a built in appliance
1. Open the Fixtures category to the Sinks library, find the double self-rimming 32 inch sink  

and select it for placement. For the purposes of this tutorial, we used the Offset 32" sink.
2. Click on the base cabinet near the top of the screen that is 33" wide to place the sink.
3. In the Appliances library, find a basic dishwasher, select it for placement, and click on the 

cabinet to the right of the sink.

Editing Cabinets and Appliances
We’ve already learned how to edit the dimensions of cabinets and appliances in floor plan view. 
Like other objects, cabinets and appliances can also be edited in their own specification 
dialogs. This method allows a higher degree of customization.
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To edit cabinets in the Cabinet Specification dialog

1. Select the cabinet to the left of the sink and click the Open Object  edit button to open 
the Base Cabinet Specification dialog.

2. Select the drawer in the preview. Notice that clicking anywhere on the preview takes you 
to the Front tab.

3. Click the Add New button to open the New Cabinet Face Item dialog.
4. Click the Item Type drop-down list and select Cutting Board, assign an Item Height of 1 

inch, and click OK to return to the Cabinet Specification dialog.
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5. A new Cutting Board face item, as well as a new Separation, will be added below the 
drawer that you selected.

6. Click on the cutting board in the preview, then click the Move Up button three times to 
move the cutting board above the drawer and the empty spaces above and below it. 

7. Select the Separation and click the Move Up button three times, as well.

8. Click OK to close the Base Cabinet Specification dialog.
9. Follow this same procedure to make any additional changes to the other cabinets in your 

kitchen area, such as creating a bank of drawers, or changing the handle for drawers to be 
knobs.

10. Finally, we will add in several smaller base cabinets to fill in the gaps between appliances

To edit appliances in their specification dialogs

1. Select the refrigerator and click the Open Object  edit button to open the Fixture 
Specification dialog.

2. On the General tab, change the Depth to 28 and click OK.
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Creating a Custom Countertop
Now we’ll create a kitchen cabinet island, and add a custom countertop with an overhang. For 
more information, see “Editing Custom Countertops” on page 657 of the Reference Manual.

To create a cabinet island

1. Select Build> Cabinet> Base Cabinet .
2. Click to place a base cabinet in the kitchen area, and select it.

3. Click the Open Object  edit button to open the Base Cabinet Specification dialog.
• On the General tab, specify a Height of 33", a Width of 33" and a Depth of 27";
• On the Front tab, create 3 Double Drawers each having an Item Height of 7 1/2":



Creating a Custom Countertop

 11

• On the Door/Drawer tab, set the Drawer Handle to Knob;
• Click OK.

4. With the Base Cabinet still selected, click on the Copy/Paste  edit tool, and paste a 
copy of this modified cabinet next to the first, as in the image below.

5. For the next portion of this tutorial, we will turn off the display of cabinet labels by 

selecting Tools> Display Settings> Display Options , scroll down to the Cabinets, 
Labels layer, remove the checkmark the Disp column, and click OK.

To create a custom countertop

1. Turn on Object Snaps .

2. Select Build> Cabinet> Custom Countertop .
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3. Click and drag to draw a rectangular polyline that will become our custom countertop.

4. Select the custom countertop and use the edit tools to edit its shape as shown in the 
following images, where we have applied an Angle Hatch Fill Style to the Custom 
Countertop for easy viewing.

• Use the Break Line  and Change Line/Arc edit buttons to add edit handles and 
change the polyline’s shape. For more information, see “Break Line” on page 222 of 
the Reference Manual.

• You can also draw End to End  dimensions from the Base Cabinet to the edge of 
the Custom Countertop, and use those dimensions to type in a precise value for the 
distance. For more information see “Moving Objects Using Dimensions” on page 971 
of the Reference Manual.
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5. Let’s create a Full Camera  view and take a look.

6. Finally, let’s return to the Floor Plan view, add one more Wall Cabinet and Soffit above it 
on the right side of the kitchen, and resize them so that they are slightly wider than the 
Range below them.

Creating Architectural Blocks
Groups of items can be blocked together and saved to the library for use in other plans. 

To create an architectural block
1. While in Floor Plan view, group select all objects you would like to include in the 

architectural block.
2. One way to group select the objects is to hold down the Shift key and select additional 

objects to add them to the selection set. There are many other ways to select and group 
select objects. For more information, see “Selecting Objects” on page 176 of the Reference 
Manual.
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3. Click the Make Architectural Block  edit button.

To add objects to the library
1. If it is not still selected, select the architectural block.

2. Click the Add to Library  edit button to add the cabinet to the User Catalog folder in 
the Library Browser.

3. Right click on the Base cabinet name in the Library Browser and select Rename to change 
this cabinets name to Kitchen Bar.

4. Now click and drag the newly named Kitchen Bar cabinet into the appropriate User 
Catalog folder that you have created for it, such as Base Cabinets.

To explode an architectural block
1. Select an architectural block.

2. Click the Explode Architectural Block  edit button.

Working in Cross Section/Elevation Views
Like other objects, cabinets can be edited in cross section/elevation views. This method of 
editing is very powerful and allows objects to be edited easily in vertical space. Next we’ll edit 
wall cabinets and add a range hood. For more information about working in 3D views, see 
“Working in 3D” on page 883 of the Reference Manual.



Working in Cross Section/Elevation Views

 15

To create a cross section/elevation view

1. In floor plan view, select 3D> Create Orthographic View> Cross Section/Elevation . 
Click and drag a line of sight that intersects the group of cabinets that includes the range.

2. Zoom  in on the kitchen.

To edit the cabinets in a cross section/elevation view

1. Click the Select Objects  button, then click on the wall cabinet above the range, which 
should have double doors and be slightly wider than the base cabinet below it.

2. Click on the cabinet’s bottom edit handle and drag it upwards.
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3. When the temporary dimension indicates that the cabinet height is 18 inches, release the 
mouse button.

To place a range hood
1. Find a range hood from the Fixtures Library (Architectural> Appliances> Hoods> Large) 

and select it for placement.
2. Click above the range to place the hood.
3. If necessary, adjust its height and size using its edit handles.

Finishing Touches

You may want to add a few finishing touches.

• While we’re at it, let’s add some additional interior design elements from the Library 
Browser, including stools to our new bar in the kitchen (Interiors> Furniture> Seating> 
Stools).

• Add furniture to the dining nook and change the flooring to match the kitchen.

• Add a table and some chairs to the dining area.

• Continue placing objects from the Library Browser to customize the remainder of the house 
design.

Note: If you do not see Temporary Dimensions Displayed, select CAD> Dimen-

sion> Display Temporary Dimensions  to toggle this feature back on.
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To view our kitchen using the Cross Section Slider and Final View

1. In floor plan view, click Fill Window .

2. Create a Full Camera  view that starts from the exterior and release the mouse button 
in the kitchen. See “To create a camera view” on page 20.

3. Use the Mouse-Orbit Camera  tool to adjust the camera’s perspective. If you want, 
you can turn off the display of the backdrop in the 3D View Defaults dialog. For more 
information, see “3D View Defaults Dialog” on page 859 of the Reference Manual. 

4. Select 3D> Camera View Options> Cross Section Slider  to open the Cross Section 
Slider dialog.

5. Select the flat cut line and use the position slider to specify the location of the cutting 
plane. See “Cross Section Slider” on page 882 of the Reference Manual.

6. Select 3D> Camera View Options> Final View  to create a higher quality final view.
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7. In a future tutorial, we will be returning to this plan file, so be sure to Save  your work. 

If you would like, you can continue working on this plan in the Landscaping Tutorial. To learn 
how to arrange views of your model on a page for printing, see the Layout Tutorial.


