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Chapter 4:

Interior Design
Tutorial

In the Interior Design Tutorial, we’ll pick up where we left off in the House Design Tutorial. 
The shell and basic structure of our plan is complete, but a lot of interior finishing remains. Our 
plan still needs lights, outlets, and fixtures to be a functional home. In addition, the interior 
could use some creature comforts such as furniture, wall coverings and moldings. You may 
want to save this tutorial using a new name to archive your previous work. In this tutorial, you 
will learn about:
•      Controlling the Display of Objects
•      Working with Library Objects
•      Applying Room Moldings

•      Applying Wall Coverings
•      Creating a Tray Ceiling

Controlling the Display of Objects
We have a roof on our plan, but in this tutorial we’ll be working on the plan’s interior, so we do 
not need the roof planes to show in floor plan view. As we learned in the previous tutorial when 
we turned off the display of attic walls, the display of objects is controlled in the Layer Display 
Options dialog. For more information about layers and using the Layer Display Options 
dialog, see “Layers” on page 127 of the Reference Manual. 
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To control the display of objects

1. First, let’s make sure to select File> Save As  and give this version of our plan a new 
name, such as "BeachHouse - Interior Tutorial"

2. Select Tools> Display Settings> Display Options  (or press the ~ key) to open the 
Layer Display Options dialog. 

3. Press the letter R, find the layer "Roof Planes" and remove the check from the Display 
column. While we’re at it, let’s also turn off the display of "Windows, Labels" and "Doors, 
Labels." Click OK.

Working with Library Objects
Chief Architect comes with a library that contains thousands of library objects that can be used 
in a plan. For more information about the library and library objects, see “The Library” on page 
753 of the Reference Manual.

To use the Library Search feature to locate a symbol and place it in the plan

1. Move up to Floor 2 using the Floor Up  tool.

Floor 1 with the display of door and window labels and roof planes turned off
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2. Select Library> Library Browser  (or press Ctrl + L on your keyboard) to open the 
Library Browser. 

3. Click the Turn on search filtering options  button, then check Match entire word. 
4. In the text field, type "bed" and notice that search results will display below as you type.
5. Click on a bed in the search results list to select it for placement.

6. Click in the master bedroom to place the bed.

Library objects can be selected and edited using the mouse. They can also be opened for 
specification, a method that offers the most complete editing capabilities. See “Symbol Object 
Specification Dialogs” on page 779 of the Reference Manual.

When a library object is selected for placement the mouse pointer
icon indicates the type of library object selected, a preview outline of

the object displays in floor plan view, and basic information displays in the
Status Bar at the bottom of the program window.
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To use library search to place a furniture symbol

1. Click the Select Objects  button (or press the Spacebar) and click on the bed to select 
it. When selected, the bed displays edit handles. For more information, see “Editing Box-
Based Objects” on page 188 of the Reference Manual. 

2. Use the Rotate edit handle to rotate the bed.
3. Use the Move edit handle to move the bed up against the right wall.

4. You can modify the materials for the bed by using the Select Objects  button tool to 

select the bed, and click on the Open Object  edit button to open the Furniture 
Specification dialog.

Rotate edit 
handle

Resize edit 
handles

Move edit 
handle

Extend edit 
handles
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5.  Next, select the Materials tab, and select the element of the object you want to apply a new 
material to, such as the Bedspread.

6. Click on the Library Material button to display the Select Library Object dialog, which 
allows you to browse materials available in the Library to apply as the bedspread. For the 
purposes of our example, we will choose a light brown fabric.

7. Repeat this process for any of the other materials on the bed you may want to adjust, then 
click OK to apply the changes which will be visible when you create a camera view.

Now we’ll place some fixtures. If you cannot find what you’re looking for, the Library Search 
feature can help.

To use library search to place a fixture symbol

1. Select Library> Library Browser  to open the Library Browser. 
2. Type “toilet” into the search field at the top of the browser window. As you type, search 

results display in the Directory pane.
3. Select the Standard toilet from the search results.
4. Click in the master bathroom to place the toilet.

If there are multiple library objects in a plan that are similar, they can be replaced at the same 

time using the Replace From Library  edit button.

To replace a library object

1. While the Select Objects  tool is active, click on the toilet in floor plan view to select it.

2. Click the Replace From Library  edit button to open the Replace From Library 
dialog. 
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3. Click the Library button to select an item from the library to replace the standard toilet.
4. Select the Elongated toilet and click OK to return to the Replace From Library dialog.
5. Select Replace Selected Object and click OK.

Using the tools and techniques learned so far, place fixtures and furniture in both bathrooms on 
Floor 2 and Floor 1.

Floor 1



Applying Room Moldings

 7

Applying Room Moldings
In Chief Architect, you can specify base, crown and chair rail moldings for any room. The 
library contains hundreds of molding profiles; and in addition, you can create your own profiles 
and save them for future use. Moldings can be used in a variety of creative applications. We’ll 
start by applying a crown molding in the master bedroom, and then we’ll add a chair rail to the 
dining room. Finally, we’ll create our own molding profile and use it to create a tray ceiling in 
the dining room. For more information about moldings, see “Trim & Molding” on page 595 of 
the Reference Manual. 

To add crown molding

Now let’s take a look at our master bedroom in a 3D view. See “To create a camera view” on 

page 46 for information about using the Full Camera  tool.

1. With the camera view of the bedroom still active, click the Select Objects  button or 
press the Spacebar, then click in a blank space on the floor of the room to select it. 

2. Click the Open Object  edit button to open the Room Specification dialog for the 
master bedroom.

3. On the Moldings tab:

If existing walls and/or other objects do not allow enough room for a library
object to be placed, place the library object where there is enough room

and move the object into place while holding down the Ctrl key on the keyboard. 

Floor 2
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• Uncheck Default, and then click the Add New button. 
• In the Select Library Object dialog, you can either search or browse to find a crown 

molding that suits your needs. When you find one, select it and click OK. For more 
information, see “Select Library Object Dialog” on page 773 of the Reference 
Manual.

• If you wish, you can specify the Height and Width of the selected molding. In this 
tutorial, a Height of 4 inches is specified. 

• Select "Crown Molding" from the Type drop-down list and notice that the From Floor 
value is equal to the room’s Finished Ceiling Height on the Structure tab. 

• Click OK to close the Room Specification dialog. 
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Chair rail moldings can be applied to a room in the same manner. Base moldings are already 
applied in most room types by default, but can be edited, removed or added here, as well.

To add chair rail

1. With the camera view of the bedroom still active, click the Select Objects  button or 
press the Spacebar, then click in a blank space on the floor of the room to select it. 

2. Click the Open Object  edit button to open the Room Specification dialog for the 
master bedroom.

3. On the Moldings tab of the Room Specification dialog:
• Click the Add New button, and select a chair rail profile. 
• Specify a Height of 2" and set the From Floor value to 32" inches. 
• Click OK.
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Applying Wall Coverings
Now we’ll apply a wall covering to the master bedroom. Wall coverings can be used in addition 
to a wall’s surface material to create accents like wallpaper borders or wainscoting. For more 
information about wall coverings, see “Wall Materials” on page 258 of the Reference Manual.

To apply a wall covering

1. Select the master bedroom and click the Open Object  edit button.
2. On the Wall Covering tab of the Room Specification dialog, click the Add New button to 

open the Select Library Object dialog.
3. Browse to an appropriate material for your wall covering, and click OK. For the purposes 

of our example, a Natural Beadboard material is used.
4. Change the Height to 28 inches, and change the Floor to Bottom value to 3 1/2 inches to 

allow for the distance between the base and chair rail moldings. 

5. Click OK to close the Room Specification dialog.
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6. When you have finished, you may want to Save  your work.

Creating a Tray Ceiling
A tray ceiling is a special kind of stepped ceiling. There are a few different ways to create a tray 
ceiling in Chief Architect. Each method has advantages and disadvantages. Polyline solids can 
be used, primitive objects can be used, even soffits can be used to create tray ceilings. Using a 
room with a crown molding is a method that works particularly well because it can easily 
follow the outline of a room, regardless of its shape. First we’ll create a room, then apply and 
adjust a crown molding.

To create the room
1. First, let’s select File> Close to close the currently active camera view, returning us to the 

floor plan.

2. Next, select Library> Library Browser  to open the Library Browser. 
• Type “fan” into the search field at the top of the browser window. As you type, search 

results display in the Directory pane.
• Select the Lantern ceiling fan from the search results.

3. Click in the near the middle of the master bedroom to place the ceiling fan.

Additional wall covering materials can be found in the Manufac-
turer libraries. 
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4. To create our room, we will select Build> Wall> Polygon Shaped Room  which will 
display the New Polygon Shaped Room dialog.

5. Specify the Number of Sides as 8, and the Side Length to 48".

6. Click OK, and then click near the center of the ceiling fan to create the polygon shaped 
room.



Creating a Tray Ceiling

 13

To modify the room to create the tray ceiling

1. Select Build> Wall> Straight Exterior Wall , and with the wall tool active, hold down 
the Shift key on your keyboard to drag a marquee around the octagonal room to group 
select the walls that make up this area.

Note that the program automatically creates an invisible wall to 
ensure that an island room condition doesn’t result by adding this 

room within a room. For more information, see “Room Definition” on 
page 301 of the Reference Manual.
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2. Next, click on the Open Object  edit tool to display the Wall Specification dialog for 
all of these walls.

3. On the General tab, mark the walls as Railing and Invisible, then press OK.

4. Now use the Select Objects  button, or press the Spacebar, then click in the main 
Master Bedroom area to select it.

5. Click the Open Object  edit button to open the Room Specification dialog for the 
master bedroom, then on the Structure tab, set the Finished Ceiling Height to 98" and click 
OK.

6. Now, open the Room Specification dialog for the small octagonal room.
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7. On the General tab, uncheck the box beside Show Room Label.
8. On the Structure tab, verify that this room’s Finished Ceiling Height is still set to the 

default of 107 5/8.
9. While still on the Structure tab, click on the Ceiling Finish button, and change its material.

10. Go to the Moldings tab:
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• Uncheck Default, then click the Select button to display the Select Library Object 
dialog, where you can choose to apply a different molding, then click OK.

• Set its Height to 10" and its Type as "Crown Molding" and click OK. 
11. Click OK to close the Room Specification dialog.

Now let’s take a look at our master bedroom in a 3D view. See “To create a camera view” on 

page 46 for information about using the Full Camera  tool.
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If you would like, you can continue adding interior elements from the Library Browser before 
continuing to work on this plan in the Kitchen and Bath tutorial.
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