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Chapter 1:

Installation

This chapter will help you get started with the program. In this chapter you will learn:

•      What’s Included with the Software
•      System Requirements
•      Downloading Chief Architect
•      Installing Chief Architect
•      Installing Your Optional Hardware Lock

•      Starting Chief Architect
•      Program Updates
•      Deactivating Chief Architect Licenses
•      Uninstalling Chief Architect

What’s Included with the Software
Your Chief Architect purchase includes the following:

• Chief Architect Program DVD (optional purchase if program was downloaded)
• Password Key or Hardware Lock (optional)
• Chief Architect Getting Started Guide
• Your Product Key, or software license activation code
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System Requirements
In order to install and run Chief Architect, your computer system must meet the following minimum 
requirements:

• Windows® 7/Vista/XP
• 2.4 GHz processor
• 5 GB of disk space
• 2 GB of memory
• 256 MB of dedicated video memory, OpenGL 2.0 or higher
• High speed Internet for registration, video access, content downloads
• DVD drive (if software purchased on DVD)

For more information about system recommendations, visit our Web site at www.chiefarchitect.com.

Downloading Chief Architect
To download and install Chief Architect X3, you will first download the Chief Architect download 
Manager, and then use it to download the Chief Architect X3 installer.

1. Log in to your online Chief Architect account and browse to the Digital Locker page.
2. Click the  button.

3. In the File Download - Security Warning dialog that opens, click Run.
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4. If you prefer, you can instead click Save. In the Save As dialog, select an easy to find Save in 
location on  your computer, such as My Documents or your Windows Desktop, then click Save.

5. The Download Complete dialog will display when the file is finished downloading. Click the 
Run button.
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6. An Internet Explorer - Security Warning message may display next. If it does, click the Run 
button to continue.

7. The Save To - Chief Architect Downloader dialog will open next. 
• Click the File button if you would like to select a different location on your computer to save 

the Chief Architect installer. 
• Click OK to begin the download. 
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8. The Chief Architect Downloader progress dialog will open next. The installer is over 350 MB, 
so may take some time to download, depending on your Internet connection.

• The Saving To section of the dialog box states the location on your computer where the 
installer is being saved and its name. 

• The Progress section indicates how much of the installer has been downloaded thus far, how 
fast it is being downloaded and estimates how much more time will be needed.

9. If you wish, click the Options button and choose whether to: 
• Run This Program When Done downloading. This option is selected by default. Click to 

uncheck it if you prefer to run the installer at a later time.
• Finish Downloading Later. Select this option to stop the download. You can later resume 

where you left off by double-clicking on either the Download Manager acquired in steps 2 
and 3 above or the Finish Downloading Chief Architect X3 shortcut created on your 
Windows Desktop. This shortcut is created only when this option is chosen and is deleted 
when the download is completed. 

• Use Proxy Server Settings. Choose this option only if you use a proxy server. 
10. You can click the Pause button to temporarily halt the download. You can then click the Resume 

button to continue it.
11. You can also click the Cancel button to cancel the download entirely. The downloader will ask 

you if you would like to finish later: click Yes to Finish Download Later, as described above; 
click No to cancel the download and start again later.

Installing Chief Architect
When the file is completely downloaded, the Setup Wizard will launch automatically. 

If you have an Chief Architect Program DVD, insert it into your DVD drive. The Chief Architect 
installer will launch.

Note: If the Chief Architect installation window does not open, you can
open it manually. Click the Start button, then click the Run…option. Type
D:\Setup (assuming your DVD drive is drive D) and press Enter or click
OK.
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Setup Wizard Welcome

1. Depending on whether or not you have installed the program on this computer before, the text in 
this window may vary. Click Next to continue.

Setup Maintenance

2. If you have installed the program before, this window will display, allowing you to reinstall or 
uninstall the program. If you are installing the program for the first time, this window will not 
display.
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License Agreement

3. Read the License Agreement carefully. You must check the box beside I accept the terms and 
conditions of this license agreement before installing. See “End User License Agreement” on 
page 231 of the User’s Guide.

• Click the Advanced button if you’d like to specify a non-default installation location or 
exclude supplementary content from being installed. 

• Click Install to begin installing the software. The Setup Wizard will begin copying files to 
your hard disk. This may take a few minutes.

chief-architect-x3-users-guide.book  Page 13  Monday, August 9, 2010  2:08 PM



14

Chief Architect X3 User’s Guide

Choose Destination Location

4. This window appears only if you click the Advanced button, and then the Change button, in the 
previous windows. Choose the destination folder for the program. By default, the program 
installs in the C:\Program Files\Chief Architect directory, in a folder with the same name as your 
program version. 

• If you prefer a different location, click drop-down arrow to the right of the Look in: location 
and navigate to the desired location on your hard drive. 

• You can also type the full pathname of the installation directory in the Folder name: field.
• Click OK to proceed to the next window.
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Choose Items to Install

5. You can use this window to specify what features you wish to install. 
• Click on a line item to select it. Information about its contents and hard drive space 

requirements displays beneath the list of features.
• Click the drop-down arrow beside a line item to specify how it is installed. By default, 

Entire feature will be installed is selected for all line items.
• Select Entire feature will be unavailable to prevent the selected feature from being 

installed. When this option is selected, a red X will display beside the line item’s drop-down 
arrow. 

• Click Install to install the program and supplemental content as specified.
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Install

6. The Setup Wizard will begin copying files to your hard disk after a few moments and a green 
progress bar in this window will show the status of this process. This may take a few minutes.

Setup Wizard Complete

7. When all files have been copied, this dialog will display. Click Finish to launch Chief Architect.
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Installing Your Optional Hardware Lock
If you do not have hardware lock security for your Chief Architect license, skip this section and 
proceed to the Starting Chief Architect section of the instructions. 

Your Hardware Lock
If you have hardware lock security, the hardware lock is your key for operating Chief Architect. You 
will not be able to operate Chief Architect unless this lock is attached to the computer you wish to 
launch the program on, so please take care of it.

Before Installing Your Lock

Installing Your Lock
1. Attach your lock to any available USB port.
2. Your computer should detect the lock and install it automatically.
3. Launch Chief Architect.

Starting Chief Architect
If you have plan and layout files created in previous versions of Chief Architect, be sure to read 
“Before You Begin” on page 1143 before you open any of these files in Chief Architect X3. 

You can use the Start menu or the shortcut on your desktop to start Chief Architect. When you launch 
the program for the first time, the Registration Wizard will open. 

Take a moment to complete the Registration Wizard, which authenticates your right to use this 
product and gathers information which may be used to notify you of free updates and other important 
information. Please be assured that Chief Architect Inc never sells or shares this information with 
other parties.

Do not plug the hardware lock into your computer until you 
have completed the preceding Chief Architect installation 

instructions. 

HASP

USB Hardware Locks

Super Pro
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Registration Wizard

1. In the Welcome window, click Next to continue.

Enter Product Key
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2. Enter your Product Key, which is located in the account information from your download or on a 
sticker inside your DVD case.

Hardware Lock

3. If your program license uses hardware lock security, and either your hardware lock is not 
plugged in or a driver for the lock is not detected, this window will appear. 

• Make sure that your hardware lock is plugged into the computer and is lit up and click Next.
• If this window remains open, click the Install Hardware Lock Drivers button to install the 

most current driver for your lock. Then click Next.
• If, with the new driver installed, this window is still present, click the Run Hardware Lock 

Troubleshooter for more information.
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User Information

4. Enter your contact information. When you click Next, you will be asked to confirm your e-mail 
address. 

Mailing Address
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5. Enter your mailing address and click Next to continue.

Online Registration

6. Click the Next button to register online.

Completing the Registration Wizard
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7. To complete the Registration Wizard:
• Write down your Emergency Transfer Password and store it in a safe location. This 

information does not display if you have hardware lock security. 
• Click Print Registration Information to print a copy of the registration for your own 

records. 
• Click Finish to close the Registration Wizard and launch Chief Architect.

Legacy Library Conversion

8. If you have custom libraries on your computer that you created using Chief Architect X2, this 
dialog will display. To convert these custom libraries for use in version X3, click Yes. For more 
information about converting legacy libraries, see “Legacy Library Conversion” on page 726. 

Program Updates
From time to time, Chief Architect releases Chief Architect program updates that are available for 
download free of charge from the Chief Architect Web site,  www.chiefarchitect.com.

When a program update is available, this dialog will display when the program is opened:

• Click Yes to open your default Internet browser to the Program Updates section of the Chief 
Architect Web site.

• Click No to launch Chief Architect.

At any time, you can select Help> Download Program Updates from the Chief Architect menu to 
launch your default Web browser to the Program Updates section of the Chief Architect Web site.
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If you prefer that the program not check for program updates every time it launches, you can disable 
this feature in the Preferences dialog. See “General Panel” on page 83. 

Deactivating Chief Architect Licenses
A license of Chief Architect can only be active on one computer at any given time. If you have been 
running the software on one computer and wish to run it on a different computer, you must deactivate 
your license on.the first computer.

To deactivate a Chief Architect license

1. Launch Chief Architect on the computer where the license is active.
2. Select Help> Deactivate License from the menu.
3. A message will confirm that you wish to deactivate the license. Click Yes.
4. After a pause, a second message will inform you that the license has been deactivated.

If you are using hardware lock security, you do not need to deactivate your license. Instead, attach the 
lock to the computer you wish to use before launching Chief Architect. See “Your Hardware Lock” 
on page 17.

Uninstalling Chief Architect
There are two ways that Chief Architect can be removed from your computer: from the Control Panel 
and using the Setup Wizard on the program disk. Please note that if you do not have an active Internet 
connection, your license will not become deactivated.

To remove the program using the Control Panel

1. Double-click the Computer icon on your desktop (in Windows XP, “My Computer”).
2. Open the Control Panel.
3. Double-click Programs (in Windows XP, “Add or Remove Programs”).
4. Find Chief Architect and click Remove. 

To remove the program using the Setup Wizard

1. Place the disc in the DVD drive and select Install Chief Architect from the Chief Architect 
startup window.

2. On the Setup Maintenance page, select Uninstall and click Next. A message will display, asking 
if you would like to remove the selected application and its components.

An active Internet connection is required to deactivate 
a Chief Architect license. 
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3. Click Yes to remove Chief Architect.
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Chapter 2:

House Design
Tutorial

This House Design Tutorial shows you how to get started on a design project. The tutorials that 
follow continue with the same plan. When we are finished, we will have created a sample plan 
named “Oceanside” that can be downloaded from our web site at www.chiefarchitect.com.

 In this tutorial you will learn about:
•      Before You Begin
•      Getting Started
•      Setting Floor Defaults
•      Drawing Walls
•      Creating Dimension Lines
•      Adjusting Wall Positions

•      Creating Rooms
•      Creating a 3D View
•      Adding Floors
•      Adding Stairs
•      Adding a Roof
•      Improving Structural Support
•      Placing Doors and Windows
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Before You Begin
Chief Architect may look differently on your screen than it does in the following tutorials. 

• Screen captures are taken from a smaller window to optimize image quality, so the size and 
proportion of your interface may be different.

• Some features such as the Reference Grid have been turned off to optimize image quality. 
For more information, see “General Plan Defaults Dialog” on page 70 of the Reference 
Manual.

• Because toolbars can be customized, their default layout and location may differ. For more 
information, see “Toolbar Customization Dialog” on page 114 of the Reference Manual.

• As the program is updated, features may be added or removed. If you are using the latest 
version of Chief Architect, you may see buttons and/or menu items that have been added or 
removed since this tutorial was written. For more information, see “Program Updates” on 
page 22.

• Depending on your operating system and Windows system settings, dialogs and toolbars 
may appear differently than they do in the tutorials.

Getting Started
We’ll start with a new, blank plan. 

To start Chief Architect
1. Click the Windows Start button.
2. Select Programs> Chief Architect>, select the name of the Chief Architect program 

version you have, and click to start the program.
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3. When the program launches, the Startup Options window displays. 

• Click New Plan  to open a new, blank plan.
• If you have disabled the Startup Options at startup or already have the program open, 

you can select File> New Plan  to open a new, blank plan. 
• For more information, see “Startup Options” on page 28 of the Reference Manual.

4. It is wise to save your work, and save it often, as you proceed. 

• Select File> Save  from the menu to open the Save Plan File dialog
• Specify the location on your computer where you would like to save the plan.
• Enter a name for your plan.
• Click Save. 

To create and resize a terrain perimeter 

1. Select Terrain> Create Terrain Perimeter  from the menu or click the corresponding 
toolbar button. See “Toolbar Arrangement” on page 114 of the Reference Manual.
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• If this menu option is not available in a given plan file, a terrain perimeter already 
exists.

2. Select Window> Fill Window  to fill the screen with the terrain perimeter.

3. Select CAD> Dimension> Display Temporary Dimensions  and make sure 
temporary dimensions are turned on for display. A check is displayed next to the item in 
the submenu instead of the toolbar button icon when it is enabled.

4. Select the terrain perimeter by clicking on either of the vertical edges. Notice that a 
temporary dimension displays, indicating that the selected edge of the terrain perimeter is 
50 feet from the opposite edge.

5. Press the Enter key on your keyboard and repeat this step for the adjacent edge of the 
terrain perimeter, creating a square that is 150 feet by 150 feet.

Floor plan view window with terrain perimeter

Terrain 
Perimeter
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6. Click Window> Fill Window  to fill the screen with the terrain perimeter.

Setting Floor Defaults
Default settings determine the initial characteristics of objects when they are first drawn. 
Before we draw walls and create rooms, we should set the floor defaults. For more information, 
see “Floor Defaults Dialog” on page 374 of the Reference Manual.

To set the Floor Defaults

1. Select Edit> Default Settings  to open the Default Settings dialog. 

The Reference Grid, or Virtual Graph Paper, is a visual aid that
helps create a sense of scale when drawing. Grid squares are

12 inches per side. The Reference Grid is turned off for these tutorials
but can be turned on or off in the Plan Defaults dialog. See “General
Plan Defaults Dialog” on page 70 of the Reference Manual. 
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2. Select Floor in the tree view and click the Edit button to open the Floor 1 Defaults dialog. 

3. On the Structure tab, note the Ceiling Height. The initial value is 9 feet (9’) or 108 inches. 
We will leave this value unchanged for this tutorial. 

4. Click OK to close the Floor 1 Defaults dialog.
5. Click Done to close the Default Settings dialog.

Drawing Walls
We’ll start by drawing some exterior walls. When drawing walls, do not try to size or position 
them precisely - they can be more easily positioned after they are created. For more 
information, see “Walls, Railings, & Fencing” on page 231 of the Reference Manual.

To draw exterior walls

1. Select Build> Wall> Straight Exterior Wall  from the menu or click the 
corresponding toolbar button. 

2. Click and drag from left to right to draw a wall. Walls can be drawn in two ways:
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• If you first click using the left mouse button, each wall section will end when the 
mouse button is released. Place the pointer over an existing wall end and click and 
drag to create a new connected wall section. 

• If you initially click using the right mouse button, you will draw continuously 
connected walls until you click both mouse buttons simultaneously (or press the Esc 
key). See “Continuous Wall Drawing” on page 246 of the Reference Manual.

3. There are a couple things to notice as you draw a wall.
• The wall’s length displays in two places: above the wall and in the Status Bar at the 

bottom of the screen. 

• Wall angles are restricted to increments of 15° when Angle Snaps  are on. Select 

Edit> Snap Settings> Angle Snaps  and make sure they are turned on for this 
tutorial. See “Snap Behaviors” on page 141 of the Reference Manual for more 
information.

4. Continue drawing walls, creating a rough outline of the building’s exterior, as shown in the 
following image. 

Wall length is indicated in the Status Bar as the wall is drawn
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• Exact dimensions are not important yet, but it is helpful to keep the final size of the 
structure in mind as you draw. The overall length of this building’s sides is 44’, both 
horizontally and vertically. 

• It is important that exterior walls (and any other wall types with an interior side and an 
exterior side) are drawn clockwise to ensure the proper orientation of wall surfaces. 

• When the walls enclose an area completely, a Living Area label is created. See “Living 
Area” on page 291 of the Reference Manual.

• Keep the building within the terrain perimeter. It doesn’t have to be perfectly centered 
because both the terrain perimeter and the entire building can be moved later.

Interior walls are drawn the same way that exterior walls are.

To draw interior walls

1. Select Build> Wall> Straight Interior Wall  from the menu or click the corresponding 
toolbar button. 
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2. Draw an interior wall as shown in the following image.

If you use the wrong wall tool to draw a wall, you don’t need to delete it.  Instead, you can 
easily change its wall type.

To change a wall’s type

1. Select a wall with the incorrect wall type and click the Open Object  edit button to 
open the Wall Specification dialog. See “Wall Specification Dialog” on page 269 of the 
Reference Manual. 

2. On the Wall Types tab, click the Wall Type drop-down list and select the correct wall type 
3. Click OK to close the dialog and change the selected wall to the correct wall type. 

To delete a wall

1. While the Select Objects  tool is active, click on a wall with the pointer to select it.

2. Press the Delete key or click the Delete  edit button.

Creating Dimension Lines
Dimension lines locate walls, openings in walls, and other objects. In Chief Architect, you can 
generate automatic exterior dimension lines and draw a variety of manual dimensions such as 
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interior dimensions, point to point dimensions, baseline dimensions, and angular dimensions. 
For more information, see “Dimensions” on page 859 of the Reference Manual.

To create automatic exterior dimension lines

1. Select CAD> Dimension> Auto Exterior Dimensions .

2. For a closer view of a certain area, click the Zoom  tool, click and drag a box around 
the area you want to see in detail, and release the mouse button. That area fills the screen. 
For more information, see “Zoom & View Tools” on page 769 of the Reference Manual.

3. To return to the previous zoom factor, select Window> Undo Zoom .
4. If you can’t see all the exterior dimension lines at once, select Window> Fill Window 

Building Only  to center your plan on screen.

To draw an interior dimension line

1. Select CAD> Dimension Lines>  Interior Dimension .
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2. Click and drag a line that intersects the interior wall and other walls you want to locate. 

3. Release the mouse button to display the interior dimension. 

Note: The Automatic Exterior Dimensions tool does not affect inte-
rior dimension lines.

Note: Interior Dimensions locate the main layers of walls by
default rather than wall surfaces. See “Wall Type Definitions Dia-
log” on page 265 of the Reference Manual. This and other dimen-
sion defaults can be specified in the Dimension Defaults dialog.
See “Manual Dimension Defaults Dialog” on page 861 of the Ref-
erence Manual. 

Because interior dimensions and exterior dimensions can locate different wall surfaces, 
sometimes two dimension lines may appear to offer different measurements of the same distance. 
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To delete all dimensions at once

1. Select Edit> Delete Objects  to open the Delete Objects dialog. See “Delete Objects 
Dialog” on page 218 of the Reference Manual.

2. Select the All Rooms On This Floor radio button, check Dimensions, and click OK.

Adjusting Wall Positions
Now we’ll adjust the spacing of walls with more precision. For more information about using 
dimensions to relocate objects with accuracy, see “Moving Objects Using Dimensions” on 
page 883 of the Reference Manual.

To adjust the spacing of the exterior walls 

1. Let’s begin by selecting Window> Fill Window Building Only  so we can see the 
entire building.

2. Click the Select Objects  tool then click on an exterior wall to select it. 
3. Click and drag the Move edit handle that displays at the position along the wall where you 

clicked. Walls can be moved perpendicular to the direction that they are drawn.
4. As you move the wall, the dimension lines that indicate how far it is from other walls will 

update. Use these dimensions to position the wall accurately.

If you have difficulty positioning a wall at the desired location because it jumps over that 
location as you move it, try zooming in on it by scrolling with your mouse wheel or by using 

either the Zoom  or Zoom In  tool.  You can also use the Accurate Move  edit tool to 
slow your mouse movement.
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To use the Accurate Move edit tool 
1. Click on the wall that you wish to move more slowly and with greater accuracy.

2. Click the Accurate Move  edit button.
3. Click and drag the Move edit handle to the desired position.  

Your mouse will move more slowly for this edit only. The next time you want to move or resize 

the wall slowly, you will need to click the Accurate Move  edit button again.

When you are finished, the dimensions of your model should match those in the following 
image. 
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Another way to position walls and other objects with accuracy is by clicking on dimensions.

To use the Move Object Using Dimension tool

1. Click the Select Objects  button, then click on a wall that you want to move.
2. Click on a dimension line that indicates how far the selected wall is from another wall. 

There are a couple ways to determine which dimensions can be used for this purpose.
• Move the selected wall and see which dimensions update.
• Move your pointer over a dimension. If it is an associated dimension, the icon will 

change to a pointing hand ( ).

3. Click on the associated dimension and enter a new value. Remember, numbers entered 
with an apostrophe denote feet and numbers entered with quotes denote inches. If neither 
apostrophes or quotes are included, the entered value defaults to inches.

4. Use the Enter key on your keyboard to close the dialog and apply the change so that the 
wall will move the specified distance.

Selected Wall

Associated 
Dimension
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5. Repeat this process for the adjacent exterior wall, continuing in a clockwise direction. It 
may help to refresh Auto Exterior Dimensions  (Shift + A) between commands. 

For more information about using dimensions to finalize the layout of exterior walls, see 
“Resizing a House Using Exterior Dimensions” on page 884 of the Reference Manual.

When your exterior walls are positioned properly, you may find it helpful to delete the exterior 
dimensions using the Delete Objects dialog, as described previously. 

Creating Rooms
Now that the exterior of the house has been finalized we can begin laying out rooms on the 
interior. Rooms are defined by the walls that enclose them. They are then assigned a Room 
Type that assigns common room attributes. For more information about rooms, see “Room 
Types” on page 288 of the Reference Manual. 

To define rooms using interior walls

1. Select Build> Wall> Straight Interior Wall , then click and drag to draw interior 
walls. As with exterior walls, you don’t need to worry about exact placement as you draw.

If you use the Move Object Using Dimensions tool to reposition walls,
you should always work in the same direction, adjusting one wall sec-

tion after another.
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2. Select Build> Wall> Break Wall  and click to place two breaks at the locations shown 
in the following image.

3. Click the Select Objects  button, then select the middle wall section created by the 
breaks and delete it.

4. Adjust the wall spacing of the interior walls to match the following image using Interior 

Dimensions , just as you did with exterior walls. The original interior wall (hatched in 
the following image for illustrative purposes) should not be moved. 
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5. Using the Straight Interior Wall  tool, draw two more interior walls, creating a room 
that will become the dining room on the right side of the plan. 

6. Draw a vertical Interior Dimension  inside this new room, then use it to move the 
horizontal interior wall 9 feet from the opposing exterior wall.

Using Invisible Walls
In reality, rooms are not always be divided by a physical wall. The separation of two rooms 
may be marked by a change in the flooring (carpet to tile, for example), or by a change in the 
interior wall covering. In Chief Architect, an invisible wall can be used to define rooms without 
creating an actual wall. We’ll use invisible walls to define more of the first floor layout. For 
more information, see “Invisible Walls” on page 243 of the Reference Manual.
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To create an invisible wall 

1. Select Build> Wall> Invisible Wall  and draw invisible walls as shown in the 
following image.

Room Types
Rooms in Chief Architect are given special attributes by assigning a Room Type. For example, 
porches use a concrete floor material and have a ceiling and roof, while decks use floor 
planking and have no ceiling or roof. For more information, see “Rooms” on page 283 of the 
Reference Manual.

To designate a Room Type for a room

1. Click the Select Objects  button, then click in the small room at the bottom of the plan.
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2. Click the Open Object  edit button to open the Room Specification dialog.

3. Click the Room Type drop-down list and select Entry.
4. Click OK close the dialog and apply your change. 

Double-clicking a room when the Select Objects  tool is active will also open the Room 
Specification dialog. For more information, see “Room Specification Dialog” on page 301 of 
the Reference Manual.
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5. Open each of the rooms and assign room types as shown in the following image.

Decks and Porches
Decks and porches are exterior rooms that are defined by the deck railings and exterior walls 
that enclose them. When an exterior room is drawn using the Deck Railing  tool, the room is 
automatically assigned the exterior room type Deck. 

Railings and Deck Railings are drawn just like walls. To illustrate this, we’ll add a deck off the 
main floor between the master bedroom and the nook.

To draw a deck

1. Select Build> Deck> Straight Deck Railing .
2. Draw three deck railings as shown in the following image. The angled railing is drawn at a 

45 degree angle to the others. Note that when the mouse is released, the room is assigned 
the Room Type of Deck and given a room label.

3. Turn on Display Temporary Dimensions  and select the outer railing to position the 
railing as shown.

chief-architect-x3-users-guide.book  Page 44  Monday, August 9, 2010  2:08 PM



Creating a 3D View

 45

• For information about angular dimensions, see “Angular Dimensions” on page 875 of 
the Reference Manual. Note that you must uncheck No Locate on the General tab of 
the Deck Railing Specification dialog to allow angular dimensions to be created.

Creating a 3D View
Let’s take a look at our plan in 3D and see how it looks so far. For more information, see “3D 
Views” on page 779 of the Reference Manual. 

To create a camera view

1. In floor plan view, click the Fill Window  button to zoom out as needed to fill the view 
window with the entire drawing. 

2. Select 3D> Create Perspective View> Full Camera  (or press Shift + J).
3. Click at the bottom of the floor plan view window and drag a line that stops at the door. 

The point where you click (A) defines the point of perspective and the line (B) defines the 
direction of perspective.

chief-architect-x3-users-guide.book  Page 45  Monday, August 9, 2010  2:08 PM



46

Chief Architect X3 User’s Guide

4. Release the mouse button to create the 3D camera view. Where the mouse is released (C) is 
the camera’s focal point.

5. If necessary, you can use the Mouse-Orbit Camera  tool to change the camera’s 
perspective. The camera will revolve around its focal point (C). See “Move Camera with 
Mouse” on page 799 of the Reference Manual for more information.

6. To return to floor plan view, select File> Close from the menu.

A
B
C
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To create a floor overview 

1. In floor plan view, select 3D> Create Perspective View> Floor Overview . A floor 
overview displays a single floor without a ceiling or roof.

2. Select 3D> Move Camera With Mouse> Mouse-Orbit Camera  (should be selected 
by default) and click and drag the mouse on screen to change the camera perspective. You 
can press the I (in) and the O (out) keys on the keyboard to zoom in and out of the plan.

Adding Floors
Creating new floors in a plan is easy, but it is best to do so only after the first floor plan has 
been finalized. Now that we have done so in our plan, we’ll add a basement and second story. 
For more information about working with multiple floors, see “Multiple Floors” on page 373 of 
the Reference Manual. 

To create a foundation or basement
1. Press Ctrl + Tab on your keyboard to return to floor plan view. 

2. Select Build> Floor> Build Foundation . In the Build Foundation dialog: 
• Select 8" Concrete Stem Wall from the Wall Type drop-down list. 
• Change the Min. Wall Height to 100 inches.
• Click OK to close the dialog and create a foundation level for your plan. 
• For more information, see “Foundation Defaults” on page 387 of the Reference 

Manual.
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3. Select Derive New Foundation Plan From the First Floor Plan and click OK to close 
the New Floor dialog. See “Adding Floors” on page 376 of the Reference Manual. 

4. You can select Window> Fill Window Building Only  from the menu to center the 
plan on screen.

To add a second floor

1. Click the Up One Floor  button to return to the first floor.

2. Select Build> Floor> Build New Floor . The New Floor dialog displays.
3. Select Derive new 2nd floor plan from the 1st floor plan and click OK to close the New 

Floor dialog. A floor plan for the second floor is created based on the exterior walls of the 
first floor plan. We will need to edit the walls of our second floor manually. It will be 
difficult to know where the second story walls should be without knowing where the first 
floor walls are located.
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4. Select Tools> Reference Floors> Reference Display  (or press F9). The first floor 
walls are displayed for reference. 

We will now edit the second story walls.

To merge two parallel walls into one
1. Select a wall, then click and drag its center edit handle to move it.
2. When the wall becomes aligned with another wall and can merge with it, it will stop at a 

"sticky point." 
3. If you keep dragging the mouse, the wall will break free of the sticky point and you can 

continue moving it. In this case, we will release the mouse button. Note that the edit 
handles now extend the full length of the wall.

Note: Before merging walls, make sure Object Snaps are turned on. For
more information, see “Object Snaps” on page 142 of the Reference
Manual.

First floor 
walls displayed 
for reference

1. Select a wall and place the cursor 
over the center edit handle.
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2. Click and drag the pointer over the 
edge of another parallel wall. Look 
for the On Object snap indicator. 
For more information, see “Object 
Snaps” on page 142 of the 
Reference Manual.

On Object snap
indicator

3. Release the mouse button when 
the On Object snap indicator 
appears to merge the wall 
sections. Note that the edit 
handles now extend the full 
length of the wall.
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4. When finished, we will have four exterior walls that are aligned as shown in the following 
image. To achieve this, we could also have created a blank second floor plan and then 
drawn our second story walls manually. 

5. Select 3D> Create Perspective View> Full Overview  from the menu to create a 3D 
overview of our entire plan so far. 
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To add a second story deck

Now that we have a second floor, we’ll use the tools and techniques we learned earlier to add a 
second story deck that is aligned with the first story deck below. See “Decks” on page 292 of 
the Reference Manual for more information. 

1. Press Ctrl + Tab on your keyboard to switch back to floor plan view. 

2. If they are not already displayed, click Reference Display  to display the first floor 
walls.

3. Select the Straight Deck Railing  tool.

4. Draw a deck as shown in the following image. If you have Object Snaps  on, the 
second story deck railing will likely be drawn in alignment with the first floor on your first 
attempt. If not, you can align the deck railing with the first floor deck below in the 
following steps. 

5. Select a section of deck railing that has a deck railing below it on the first floor and click 

the Align with Wall Below  edit button. 

• Note: If Align with Wall Below  is not available, the selected railing either needs 
to be moved closer to the wall below, or the railing is already aligned with the one 
below. See “Aligning Walls” on page 254 of the Reference Manual. 
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6. Repeat this step for each section of railing that has a railing directly below it on the first 
floor. When you are finished, your second floor should look like this:

Adding Stairs
Now that we’ve got three floors we’ll need to get from one floor to another. For more 
information about stairs, see “Stairs, Ramps & Landings” on page 455 of the Reference 
Manual.

To draw stairs with a landing

1. Click Down One Floor  to go to the first floor. You may want to select Tools> 

Reference Floors> Reference Display  to turn off the display of the reference floor.

2. Select Build> Stairs> Straight Stairs  (or press Shift + Y).

chief-architect-x3-users-guide.book  Page 53  Monday, August 9, 2010  2:08 PM



54

Chief Architect X3 User’s Guide

3. Click and drag to draw a short stair section as shown in the following image.

4. Draw another stair section 90° to the right of the first stair section, along the interior wall.
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5. While the Straight Stairs  tool is still active, click in the corner between the two stair 
sections to create a landing. 

6. Click on the landing with either the Straight Stairs  or Select Objects  tool active, 
and resize it using its edit handles to fit against the wall. This may make a nice bench seat.

To create a stairwell
1. Select either of the two stair sections.

2. Click the Auto Stairwell  edit button to create a stairwell.
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3. Click the Up One Floor  button to go to the second floor. Notice that the second floor 
now displays a stairwell defined by railings.

A stairwell is an interior room that is automatically assigned the Room Type “Open Below” in 
the Room Specification dialog. See “Room Specification Dialog” on page 301 of the 
Reference Manual. 

It makes sense to draw the basement stairs directly below the stairs to Floor 2. We could use the 

Auto Stairwell  edit tool to create another stairwell; however, in this situation, it will be 
better to define the stairwell with walls placed under the stairs to Floor 2 rather than by the 
railings that the Auto Stairwell tool generates.

To manually create a stairwell

1. Click the Down One Floor  button to go down to Floor 1.
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2. Select Build> Wall> Straight Interior Wall , then click and drag to draw interior 
walls around the staircase drawn on this floor.

3. When the walls enclose a room around the stairs, click the Select Objects  button, then 
click on one of the walls to select it. Drag it so that it is positioned inside the stairs, either 
aligned with the stair edges or just inside the stair edges.

4. Repeat this process with the other walls. When you reposition the wall nearest the first step 
of the stairs, make sure it is positioned under the second step rather than the first. 

5. Next, click on a stair section inside of the stairwell room and click the Select Next 

Object  edit button as many times as needed until the room is selected. 
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In the following image, the room (highlighted in grey) is selected and the stair sections and 
landing have been assigned a transparent fill style so the walls drawn beneath them can be 
seen.

6. With the room selected, click the Open Object  edit button and in the Room 
Specification dialog, select Open Below from the Room Type drop-down list and click 
OK.

7. Go Down One Floor  and turn on the Reference Display . 

8. Select Build> Stairs> Straight Stairs  and draw two stair sections directly below the 
stairs you drew on Floor 1. Do not draw the landing just yet, though.

9. Select each stair section and adjust its width and position using its edit handles so that it 
fits within the walls forming the stairwell drawn on Floor 1.

10. When the stair sections are positioned properly, click with the Straight Stairs  tool to 
create a landing as you did on Floor 1. 
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11. Select 3D> Create Perspective View> Full Overview . 

12. When the view has generated, select 3D> Rendering Techniques> Glass House  to 
view our entire model, inside and out. 

13. Select 3D> Move Camera With Mouse> Mouse-Orbit Camera  and click and drag 
the mouse on screen to change the camera perspective. You can press the I (in) and the O 
(out) keys on the keyboard to zoom in and out of the plan.

Adding a Roof
It looks like our house could use a roof now. Chief Architect’s roof tools are covered in greater 
detail in the Roof Tutorial. For more information, see “Roof Tutorial” on page 201 and “Roofs” 
on page 403 of the Reference Manual. 

To turn on automatic roof generation

1. Select Build> Roof> Build Roof  from the menu to open the Build Roof dialog.
2. On the Build tab, check Auto Rebuild Roofs. See “Build Roof Dialog” on page 407 of the 

Reference Manual for more information. Click OK to generate a roof. 
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3. Select 3D> Create Perspective View> Full Overview  to create a exterior view of 
your plan.

To edit the default roof
1. Close any other views you may still have open. For the following steps, only the floor plan 

view and the previously created 3D view should be open. 
2. Make the floor plan view active by press Ctrl + Tab or by selecting the view that ends with 

“:Floor Plan” from the bottom of the Window menu. 

3. Click Up One Floor  to go to the first floor.

4. So that we can see the results of our changes, select Window> Tile Vertically  from 
the menu to tile the 3D view and floor plan view windows. 

5. Open the following first floor walls’ specification dialogs and assign the settings shown in 
the following image on the Roof tab of the Wall Specification dialog. See “Roof Tab” on 
page 273 of the Reference Manual. 

Individual walls can be selected and edited in both 2D and 3D views. See “Editing Walls” 
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on page 249 of the Reference Manual.; however it may be a quicker operation in floor plan 
view since you can hold down the Shift key and group-select walls.

Full Gable Wall

Full Gable 
Wall

Full Gable Wall

Full Gable 
Wall

Full 
Gable 
Wall

4/12 lower pitch 4/12 lower pitch

Full Gable 
Wall
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6. Click Up One Floor  to go to the second floor.
7. Assign the following settings on the Roof tab of the Wall Specification dialog to the 

second story walls. The additional walls you see are attic walls. You can ignore them for 
now. We’ll talk about them in the next section.

Open a wall for specification and assign a (lower) pitch of 4 in 12

Full Gable Wall
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8. Notice that as you make these changes in floor plan view the 3D model updates. 

Attic Walls
When a roof is generated, attic walls are also generated. An attic wall fills the space between 
the first floor walls and angled roof planes above. To see this in floor plan view, take a look at 
the second floor.

If you do not want to see attic walls in floor plan view, you turn off their display.

Attic walls generated below gable roof planes
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To turn off the display of attic walls

1. In floor plan view, select Tools> Display Settings> Display Options  (or press the ~ 
key) to open the Layer Display Options dialog. 

2. Find Walls, Attic in the Name column, remove the check from the Disp column for this 
item, and click OK. For more information, see “Layer Display Options Dialog” on page 
130 of the Reference Manual.

Improving Structural Support
The second floor is not supported well by the first floor. Before sending this plan in for 

approval, this must be addressed. Click the Down One Floor  and Up One Floor  

buttons while the Reference Display  is on to see how the walls on each floor line up.

• The southern wall of floor two should have the dining room wall directly below it, 
which can serve as a bearing wall. We could also add an interior wall to the staircase 
to serve as a bearing wall. The span between the two will require a floor beam.

• The entire western wall of the second floor is supported by an exterior wall below.
• The northern wall of the second floor needs help. We can move the closet wall directly 

below it, but we’ll also need to add a couple floor beams to help carry the load.
• The eastern wall of the second floor needs a floor beam to span between the exterior 

walls. Also, the first floor wall is not in alignment with the second story wall above.

First floor with the second floor 
displayed for reference

Second floor with the first floor 
displayed for reference
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To create bearing walls

1. Draw a Straight Interior Wall  beside the stairwell on floor one, making sure to align 
it with the second story wall above. If the Dining Room wall is not in alignment with the 

second story wall above, select it and click the Align with Wall Above  edit button.
2. Select the closet wall in the master bedroom and align it with the second story wall above. 
3. Select the wall that divides the Nook from the Deck and lick the Align with Wall Above 

 edit button.

To add floor beams

1. Select Edit> Default Settings , then click on "Framing" and click the Edit button.
2. On the Posts/Beams tab of the Build Framing dialog, specify the desired Initial Beam 

Values. For the purposes of this tutorial, we will not make any changes here - just note that 
the Depth is 12" and that beams are to be built Under Joists.

3. Select Build> Framing> Floor/Ceiling Beam .
4. In the master bedroom, click and drag to draw a floor beam that overlaps the exterior wall 

and the interior closet wall.
5. Once drawn, the floor beam can be selected and moved. See “Editing Box-Based Objects” 

on page 184 of the Reference Manual.

6. You may need to Zoom  in to make sure the floor beam is centered below the second 
story wall above. If the snapping behaviors prevent accurate positioning, you can hold 
down the Ctrl key to bypass them.

7. Draw three more floor beams to provide support for our second story; one over the deck, 
one between the kitchen and the nook, and another in the living room.

chief-architect-x3-users-guide.book  Page 65  Monday, August 9, 2010  2:08 PM



66

Chief Architect X3 User’s Guide

The floor beams we’ve added can remain exposed, or they could be drywalled and finished. In 
the Master Bedroom, we’ll lower the ceiling to cover the beam. See “Lowered Ceilings” on 
page 295 of the Reference Manual. 

To create a lowered ceiling

1. Select the master bedroom and click the Open Object  edit button. 
2. On the Structure tab of the Room Specification dialog, note the Finished Ceiling (F) 

value, 107 5/8", then click the Ceiling Finish button. 
3. In the Ceiling Finish Definition dialog: 

• Click in the Thickness field for Layer 1 to select it. 
• Click the Insert button to add a new layer above the selected layer. 
• This new layer’s Thickness should equal the depth of the desired lowered ceiling 

framing. In this example, we will use 5 1/2" joists. 
• With the new layer selected, click the Library button and choose "Fir Framing" as the 

material for this layer. 
• Click the Insert button to add one more layer above the framed layer. It’s Thickness 

should be 6 1/2", which is the difference between the beams’ Depth (12") and the 
lowered ceiling framing Thickness (5 1/2") and its material should remain "Air Gap".
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• Click OK to close the Ceiling Finish Definition dialog, apply your changes, and return 
to the Room Specification dialog. 

4. Note that now the Finished Ceiling (F) value is now 95 5/8" - 12" less than before. Click 
OK to close the Room Specification dialog, as well.

Placing Doors and Windows
We’re making progress on our house, but we can’t get into it, and neither can light. Now is a 
good time to add some doors and windows. For more information about doors and windows, 
see “Doors” on page 309 of the Reference Manual and “Windows” on page 333 of the 
Reference Manual.

To add a door
1. If your views are still tiled, close the 3D view and maximize the floor plan view.

2. Select Build> Door> Hinged Door .
3. Move the pointer to the entry and click on the front wall, left of its center, to place a door.

To add a window

1. Select Build> Window> Window .
2. Move the pointer to the entry and click on the wall, right of center, to place a window. 

To edit a door
1. So that we can better see the results when we edit our door, let’s create a camera view of 

the entry. Click and drag a camera arrow outside the structure, pointed at the entry.
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2. Click the Select Objects  tool, then click on the door to select it in the 3D view.

3. Click the Open Object  edit button to open the Door Specification dialog. For more 
information, see “Door Specification Dialog” on page 320 of the Reference Manual.

4. On the General tab, set the Door Style to Glass.
5. On the Frame & Lites tab, set the Frame Bottom to 8 inches. Press the Tab key to update 

the preview image on the right side of the dialog so that it reflects your change.
6. On the Lites tab, set the Lites across to 3 and Lites vertical to 4.
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7. Click OK to return to the 3D view.

To edit a window
1. Next, click on the window to select it.

2. Click the Open Object  edit button to open the Window Specification dialog. For 
more information, see “Window Specification Dialog” on page 350 of the Reference 
Manual.

3. On the General tab, select “Left-Sliding” from the Window Type drop-down list and set 
the Width to 36.
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4. On the Lites tab, change the Lites across to 2 and Lites vertical to 3.
5. Click OK to close the Window Specification dialog.

To change the door swing
1. Return to floor plan view and select the door.

2. Click the Change Opening/Hinge Side  edit button.

To copy a window or door
1. Return to the 3D view and select the window.

If you would like all of your doors and/or windows to be customized, make
your changes in the Door Defaults and Window Defaults dialogs before

placing these objects. For more information, see “Default Settings” on page 62
of the Reference Manual.
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2. Click the Copy/Paste  edit button. For more information about copying objects, see 
“Copying and Pasting Objects” on page 149 of the Reference Manual.

3. Click on the wall to the left of the entrance to paste the window.

Doors and windows can be placed, selected, deleted, copied, pasted, and edited in 2D and 3D 
views. If there is a window design that you will be using throughout a plan, you can create it 
once, then just copy and paste it. An even better approach is to set your door and window 
defaults to the desired settings before placing these objects. For more information, see “Default 
Settings” on page 62 of the Reference Manual. 

To create a doorway

1. Return to floor plan view and Zoom  in on the dining room.

2. Select Build> Door> Doorway  and click on the dining room wall nearest the entrance 
to place a doorway.
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3. Select 3D> Create Perspective View> Full Camera  and create an interior camera 
view of the doorway.

To customize the doorway

1. Select the doorway by clicking on it’s frame and click the Open Object  edit button to 
open the Door Specification dialog.

2. On the General tab, change the Width to 80 inches.
3. On the Casing tab, change the Casing Width to 10 inches. Be sure to delete the (D) from 

the text field. It stands for "default" and will continue to apply the default casing width if it 
is not removed, regardless of the value you specify.

4. On the Arch tab, click the Type drop-down and specify a broken arch from the list. Set the 
Height of the broken arch to 12 inches.

5. On the Casing tab, click the Library button below casing and select a molding profile 
from the Door & Window Casings library.

6. Click OK to close the Door Specification dialog.
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To center the doorway
1. Return to floor plan view and select the doorway.

2. Click the Center Object  edit button, then click inside the dining room, near the 
interior wall containing the doorway. See “Using Center Object” on page 205 of the 
Reference Manual. 

3. Return to the camera view to see the results.

Use the tools and techniques you’ve learned to add window and doors to the rest of the plan, as 
shown in the following images. Doors placed in interior walls become interior doors and have 
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different specifications than exterior doors. If you feel inspired, customize the doors and 
windows as you see fit.

First floor

Second floor
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When you have finished, Save  your work. 

We’ve added quite a lot to our model. Let’s see how it all looks. 

To take a final look

1. Using the Full Camera  tool, create an interior camera view that will allow an  
unobstructed 360° view of the first floor of the  model. Remember that where you click 
determines the camera’s perspective and where you release determines the point about 
which the camera will rotate. Therefore a short drag distance is ideal, however, the 
distance must be greater than one foot.
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2. Release the mouse button to create the 3D camera view then use the Mouse-Orbit 

Camera  tool to take a look around and see our progress so far.

3. You can also take a Floor Overview  on any floor.

4. When you have finished, Save  your work.

If you would like, you can continue working on this plan in the Interior Design Tutorial or 
Kitchen and Bath Design Tutorial. You can also learn about materials in the Materials Tutorial 
or find out more about roofs in the Roof Tutorial.To learn how to arrange views of your model 
on a page for printing, see the Layout Tutorial. 
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Interior Design
Tutorial

In the Interior Design Tutorial, we’ll pick up where we left off in the House Design Tutorial. 
The shell and basic structure of our plan is complete, but a lot of interior finishing remains. Our 
plan still needs lights, outlets, and fixtures to be a functional home. In addition, the interior 
could use some creature comforts such as furniture, wall coverings and moldings. You may 
want to save this tutorial using a new name to archive your previous work. In this tutorial, you 
will learn about:
•      Controlling the Display of Objects
•      Working with Library Objects
•      Adding Electrical Objects

•      Applying Room Moldings
•      Applying Wall Coverings

Controlling the Display of Objects
We have a roof on our plan, but in this tutorial we’ll be working on the plan’s interior, so we do 
not need the roof planes to show in floor plan view. As we learned in the previous tutorial when 
we turned off the display of attic walls, the display of objects is controlled in the Layer Display 
Options dialog. For more information about layers and using the Layer Display Options 
dialog, see “Layers” on page 125 of the Reference Manual. 
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To control the display of objects

1. Select Tools> Display Settings> Display Options   (or press the ~ key) to open the 
Layer Display Options dialog. 

2. Press the letter R, find the layer "Roof Planes" and remove the check from the Display 
column. While we’re at it, let’s also turn off the display of "Windows, Labels" and "Doors, 
Labels". Click OK.

Working with Library Objects
Chief Architect comes with a library that contains thousands of library objects that can be used 
in a plan. For more information about the library and library objects, see “The Library” on page 
713 of the Reference Manual.

First floor with the display of roof planes, window labels, and door labels turned off
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To place a bed

1. Select Library> Library Browser  (or press Ctrl + L on your keyboard) to open the 
Library Browser. 

2. Click the Turn on search filtering options  button, then check Match entire word. 
3. In the text field, type bed. Search results will display below as you type.
4. Click on a bed in the search results list to select it for placement. When a library object is 

selected for placement the mouse pointer icon indicates the type of library object selected, 
a preview outline of the object displays in floor plan view, and basic information displays 
in the Status Bar at the bottom of the program window.
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5. Click in the master bedroom to place the bed.

Library objects can be selected and edited using the mouse. They can also be opened for 
specification, a method that offers the most complete editing capabilities. See “Symbol Object 
Specification Dialogs” on page 741 of the Reference Manual.  

To edit a library object in floor plan view using the mouse

1. Click the Select Objects  button (or press the Spacebar) and click on the bed to select 
it. When selected, the bed displays edit handles. For more information, see “Editing Box-
Based Objects” on page 184 of the Reference Manual. 

chief-architect-x3-users-guide.book  Page 80  Monday, August 9, 2010  2:08 PM



Working with Library Objects

 81

2. Use the Rotate edit handle to rotate the bed.
3. Use the Move edit handle to move the bed up against the left wall.

Now we’ll place some fixtures. If you cannot find what you’re looking for, the Library Search 
feature can help.

To use library search

1. Select Library> Library Browser  to open the Library Browser. 

Rotate edit 
handle

Resize edit 
handles

Move edit 
handle

Extend edit 
handles
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2. Type “toilet” into the search field at the top of the browser window. As you type, search 
results display in the Directory pane.

3. Select the Lowboy from the search results.
4. Click in the bathroom to place the toilet. Click again in the master bathroom to place 

another toilet.

If there are multiple library objects in a plan that are similar, they can be replaced at the same 

time using the Replace From Library  edit button.

To replace a library object

1. While the Select Objects  tool is active, click on either one of the lowboy toilets in 
floor plan view to select it.

2. Click the Replace From Library  edit button to open the Replace From Library 
dialog. 

3. Click the Library button to select an item from the library to replace the lowboy toilets.
4. Select the standard toilet and click OK to return to the Replace From Library dialog.
5. Select Replace Identical Objects on Floor and click OK.
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Using the tools and techniques learned so far, place fixtures and furniture in both bathrooms. 

Adding Electrical Objects
The electrical tools that come with Chief Architect allow you to detail the location of outlets 
and lights, as well as the layout of switches and circuits. For more information about working 
with electrical objects, see “Electrical” on page 549 of the Reference Manual.

If existing walls and/or other objects do not allow enough room for a library
object to be placed, place the library object where there is enough room

and move the object into place while holding down the Ctrl key on the keyboard. 
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To place an outlet

1. Select Build> Electrical> 110V Outlet .
2. Click next to the sink in the bathroom to place an outlet. Notice that the outlet is a GFCI 

outlet, because the room is assigned the Room Type "bath".
3. Click next to the bed in the master bedroom. A standard 110V outlet is placed.

To place outlets in a room automatically

1. Select Build> Electrical> Auto Place Outlets .
2. Click once in the master bedroom and once in each bathroom to automatically place 

outlets. Auto Place Outlets  will place outlets a predetermined distance from one 
another and place lights above sinks in rooms with the room type “bath.”
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To place lights

1. Select Build> Electrical> Light .
2. Click on a wall to place a wall light.
3. Click in a room to place a ceiling light.

To place a switch

1. Select Build> Electrical> Switch .
2. Click on a wall to place a switch.
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Electrical objects can be connected in floor plan view to detail circuitry.

To draw circuits

1. Select Build> Electrical> Connect Electrical .
2. Click on an electrical object, drag a line to another electrical object, and release the mouse 

button.
3. Select the electrical connection to show an edit handle. Click and drag the edit handle to 

adjust the arc.

The library contains electrical objects such as fans, jacks, and smoke detectors.

Switch

Light

Outlet

Floor plan view showing switches, lights, and outlets

Floor plan view showing two electrical circuits
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To place an electrical object from the library

1. If it is not still open, select Library> Library Browser  to open the Library Browser.
2. Browse to the Architectural> Electrical category.
3. Find the ceiling mounted smoke detector, select it for placement, and click in the master 

bedroom to place it.

Now let’s take a look at our master bedroom in a 3D view. See “To create a camera view” on 

page 45 for information about using the Full Camera  tool.

To place electrical objects in a 3D view

1. Select Build> Electrical> Light . The cursor indicates that the light tool is active.

2. Click on the wall to place a light.
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3. Select Build> Electrical> Switch .
4. Click below the light to place a switch.

Applying Room Moldings
In Chief Architect, you can specify base, crown and chair rail moldings for any room. The 
library contains hundreds of molding profiles; and in addition, you can create your own profiles 
and save them for future use. Moldings can be used in a variety of creative applications. We’ll 
start by applying a crown molding in the master bedroom, and then we’ll add a chair rail to the 
dining room. Finally, we’ll create our own molding profile and use it to create a tray ceiling in 
the dining room. For more information about moldings, see “Trim & Molding” on page 561 of 
the Reference Manual. 

To add crown molding

1. With the camera view of the bedroom still active, click the Select Objects  button or 
press the Spacebar, then click in a blank space on the floor of the room to select it.  

2. Click the Open Object  edit button to open the Room Specification dialog for the 
master bedroom.

3. On the Moldings tab: 
• Uncheck Default, and then click the Add New button. 
• In the Select Library Object dialog, you can either browse to a crown molding in the 

tree list, or type "crown molding" in the text field. When you find a molding that suits 
your needs, click OK. For more information, see “Select Library Object Dialog” on 
page 735 of the Reference Manual.

Electrical objects can be placed in 3D views as well
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• If you wish, you can specify the Height of the selected molding. In this tutorial, a 
height of 4 inches is used. 

• Select "Crown Molding" from the Type drop-down list and notice that the From Floor 
value is equal to the room’s Finished Ceiling Height on the General tab. 

• Click OK to close the Room Specification dialog. 

Chair rail moldings can be applied to a room in the same manner. Base moldings are already 
applied in most room types by default, but can be edited, removed or added here, as well.

To add chair rail
1. Select File> Close to return to floor plan view, then select the dining room and click the 

Open Object  edit button.
2. Go to the Moldings tab of the Room Specification dialog. 
3. Click the Add New button, and select a chair rail profile. Specify a Height of 2" and set 

the From Floor value to 32" inches. Click OK.
4. Create a 3D camera view of the dining room to see the results. 
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Creating a Tray Ceiling
A tray ceiling is a special kind of stepped ceiling. There are a few different ways to create a tray 
ceiling in Chief Architect. Each method has advantages and disadvantages. Polyline solids can 
be used, primitive objects can be used, even soffits can be used to create tray ceilings. Using a 
molding is a method that works particularly well because it can easily follow the outline of a 
room, regardless of its shape. First we’ll create a profile, then apply that profile to a crown 
molding. For more information, see “Creating a Molding Profile” on page 568 of the Reference 
Manual.

To create a molding profile

1. Select CAD> CAD Detail Management  to open the CAD Detail Management dialog. 
Click the New button and name the new CAD Detail window "Tray Ceiling Profile". See 
“CAD Details” on page 974 of the Reference Manual for more about CAD Detail 
windows.

2. Select CAD> Lines> Draw Line  (or press W).
3. Draw a molding profile that will become a tray ceiling. A few things to keep in mind:

• The upper left hand corner of the profile will be placed in the corner of the ceiling.
• This molding profile must be a closed polyline. See “Editing Closed-Polyline Based 

Objects” on page 179 of the Reference Manual.

• Keep Grid Snaps  on. See “Grid Snaps” on page 146 of the Reference Manual.
• The distance of each line segment displays in the Status Bar as it is drawn.
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4. Select the closed polyline and click the Add to Library  edit button to add the Molding 
to the My Library catalog in the Library Browser.

5. In the Library Browser, right click on the Molding and select Rename to name this profile 
"Tray Ceiling Profile". 

6. If you want, you can create library folders to organize your custom content by right 
clicking on My Library and selecting New> Folder. See “Organizing the Library” on page 
729 of the Reference Manual. 

7. Once has been saved to the library, you can delete the original polyline if you wish.

8. Return to floor plan view, select the dining room and click the Open Object  edit 
button. 

9. On the Moldings tab of the Room Specification dialog, click the Add New button, find 
and select your new molding profile, set its Height to 10" and its Type as "Crown 
Molding" and click OK. 

10. Click OK to close the Room Specification dialog.
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Applying Wall Coverings
Now we’ll apply a wall covering to the master bedroom. Wall coverings can be used in addition 
to a wall’s surface material to create accents like wallpaper borders or wainscoting. For more 
information about wall coverings, see “Wall Materials” on page 299 of the Reference Manual.

To apply a wall covering

1. Select the master bedroom and click the Open Object  edit button.
2. On the Wall Covering tab of the Room Specification dialog, click the Add New button to 

open the Select Library Object dialog.
3. Browse to Chief Architect Libraries> Materials> Fabric & Wall Coverings> Patterns & 

Prints, select a pattern, and click OK.
4. Change the Width to 11 inches, and change the Top To Ceiling value to 12 inches to allow 

for the distance between the Ceiling and Lowered Ceiling. 
5. Click OK to close the Room Specification dialog.
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6. When you have finished, you may want to Save  your work.

If you would like, you can continue working on this plan in the Materials Tutorial. To learn 
how to arrange views of your model on a page for printing, see the Layout Tutorial.

Additional wall covering materials can be found in the Manufac-
turer libraries. 
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Materials
Tutorial

Materials display on the surfaces of objects in 3D views and can make a 3D view appear highly 
realistic.  When applied to most objects, material quantities will also be calculated in the 
Materials List. 

This tutorial continues from where the Interior Design Tutorial ended. You may want to save 
this tutorial using a new name to archive your previous work. In this tutorial you will learn 
about:

•      Setting Materials Defaults
•      Using the Materials Tab
•      Using the Material Painter
•      Using the Material Eyedropper
•      Using the Color Chooser

•      Blending Colors with Materials
•      Using the Material Eyedropper
•      Custom Materials, Images, and Backdrops
•      Generating a Materials List

Setting Materials Defaults
Material default settings determine the materials used by different objects when they are 
initially created. Setting the correct material defaults before beginning a project may help you 
save time. For more information, see “Preferences & Default Settings” on page 61 of the 
Reference Manual.
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To set material defaults

1. Select Edit> Default Settings  to open the Default Settings dialog. 

2. There are a couple options. You can do either or both: 
• Select an item in the tree list and click the Edit button to open the defaults dialog for 

that type of object. The default dialogs for architectural objects such as doors and 
windows have a Materials tab that allows you to set the material defaults for object 
components. See “Using the Materials Tab” on page 97.
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• Select Materials and click the Edit button to open the Material Defaults dialog. Here 
you can set the material defaults for many different objects, including some that do not 
have default dialogs. See “Material Defaults” on page 766 of the Reference Manual. 

3. When you are finished, click OK to close the defaults dialog, then click Done to close the 
Default Settings dialog.

Once an object has been placed in a plan, the materials applied to it can be changed in a number 
of ways. 

Using the Materials Tab
Most objects’ materials can be assigned in their specification dialog in both 2D and 3D views. 
The materials used by a door, for example, can be edited on the Materials tab of the Door 
Specification dialog. For more information, see “Materials Tab” on page 747 of the Reference 
Manual. 

To change material on an object using the Materials tab

1. Click the Select Objects  button, then click on the door leading from the master 
bedroom to the deck on Floor 1 to select it. 

2. Click the Open Object  edit button to open the Door Specification dialog.
3. On the Materials tab, notice that you can display the preview of either the interior or 

exterior of the door on the right side.
• Click the radio button beside Interior in the lower right corner of the dialog box.
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• Select one of the door’s components from the list on the left.

• Click the Library Material button to open the Select Library Object dialog.
4. Find and select a material and click OK.
5. You can continue to specify component materials. The preview in the dialog updates as 

changes are made. When finished, click OK to close the specification dialog.
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6. Create a Full Camera  view of the door.

The materials used in individual rooms can also be specified. Rooms can be selected in both 
floor plan and 3D views. 

• In floor plan view, click in an empty space within a room. When selected, the whole room is 
highlighted. If you accidentally select an object other than the room, you can press the Tab 
key on the keyboard until the room is selected.

• In camera views and overviews, click on the floor of the room to select it.

To edit a room using the Materials tab 

1. Select the master bedroom and click the Open Object  to open the Room 
Specification dialog.

2. On the Materials tab, select Moldings and click the Library Material button to open the 
Select Library Object dialog.
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3. Find and select a material and click OK to close the dialog.

4. Click OK to close the Room Specification dialog.

5. The results can be seen in a Full Camera  view.
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Using the Material Painter
The Material  Painter  tool allows you to select a material and then apply it to an object in 
a 3D view. 

There are five Material Painter Modes which specify how broadly or narrowly the selected 
material will be applied to surfaces in your plan. In this tutorial, the Component Mode is used. 
For more information, see “The Material Painter” on page 744 of the Reference Manual.

To apply a material using the Material Painter

1. While still in the 3D view of the door, select 3D> Materials> Material Painter  and 

confirm that there is a checkmark next to Material Painter Component Mode . 

2. Click the Material Painter  button to open the Select Library Object dialog. Browse 
to Flooring> Carpeting, select a carpet material, and click OK.

3. Move your cursor into the 3D view and notice that it displays a spray can icon . 
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4. Click on the floor of the master bedroom to apply the selected material to that surface, 
which is a component of the room. 

With the Material Painter  tool you can apply a material to nearly any surface, including 
many that can’t be individually selected like the base molding on a wall or the frame of a 

window. When either the Component  or Object  Modes is active, you can continue to 
apply the selected material to objects until a different tool is selected. 

To add artwork to a frame
1. Place a wall or desk frame in your plan and create a camera view in which it can be seen. A 

variety of frames can be found in the Interiors library category. 
2. Select 3D> Materials> Material Painter and confirm that there is a checkmark next to 

Material Painter Component Mode . 

3. Click the Material Painter  button to open the Select Library Object dialog and select 
a painting, photo or print from the Artwork library.

As an alternative to wall-to-wall carpeting, you can place an
area rug from the library in a room and assign to it whatever

material you wish. See “Placing Library Objects” on page 733.
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4. Move your cursor over the middle area of the frame and click to apply the selected 
artwork.

The artwork displayed in a frame can also be specified in the frame’s specification dialog. See 
“Symbol Object Specification Dialogs” on page 741 of the Reference Manual.

Blending Colors with Materials
Instead of using the Material Painter  to replace a material with a new one, we can use it 

with the Blend Colors With Materials  feature to blend a color with a textured material 
such as the carpet we selected for the master bedroom and create a new material. For more 
information, see “Blend Colors With Materials” on page 745 of the Reference Manual.

To blend a color with a texture

1. In a 3D view, select 3D> Materials> Material Painter> Material Painter . 
2. In the Select Library Object dialog, select a solid color for the carpet from the Generic 

Colors library, then click OK.

3. When you move your cursor into the view, it displays a paint roller icon .

• When Blend Colors with Materials  is active and a solid color is loaded in the 

Material Painter, your cursor displays the paint roller icon . 

• If you see the spray can icon  instead, select 3D> Materials> Material Painter> 

Blend Colors With Materials  or click the Blend Colors With Materials edit 
button to turn this feature on. 
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4. Click on the carpet to blend the selected color with the carpet texture.  The result is a new 
material with the textured appearance of the carpet as well as the color you selected. 

Using the Material Eyedropper
The Material Eyedropper  tool allows you to load a material that can be seen on a surface 

in a 3D view into the Material Painter  tool and then apply it to another surface. In our 
master bedroom, the type of wood we have assigned to the interior trim of the exterior door is 
different than the material used on the trim of the interior doors.We can easily change this using 

the Material Eyedropper . 

To change materials using the Material Eyedropper
1. Activate the camera view (or any 3D view).

Before using Blend Color With Material After using Blend Color With Material

The trim on the door at left is different from the other three doors
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2. Select 3D> Materials> Material Painter  from the menu. If there is a check beside 

Blend Color With Material , select this menu item to disable it; if not, simply click 
outside of the menu to close it again.

3. Select 3D> Materials> Material Eyedropper  and notice that the pointer displays an 

eyedropper icon .

4. Now just click to load that material. Notice that the pointer changes to a spray can , 
indicating that the loaded material is ready to apply to another object and replace the 
existing material.

5. Click on the doors and their frames to apply the loaded material.
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Specifying Landscaping Materials
You can use the Materials tab, Material Painter tools and Material Eyedropper to customize the 
appearance of your landscaping. The Terrain Perimeter, terrain features, terrain walls and 
curbs, and roads and sidewalks all have materials assigned to them that can be changed to suit 
your needs. For more information, see “Editing Terrain Objects” on page 631 of the Reference 
Manual. 

In addition, the materials assigned to Terrain Features, including garden beds, stepping stones 
and driveways,  are calculated in the Materials List. For more information, see “Materials 
Lists” on page 1119 of the Reference Manual.

Using the Color Chooser
With the Color Chooser  you can load any color that is displayed on your monitor and save 
it to the library for use in your plans. 

To create a new material using the Color Chooser

1. Select Tools> Color Chooser  to open the Color Chooser dialog.
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2. Place your mouse pointer over the eyedropper at the right of the dialog, then click and drag 
the eyedropper to an open image on your screen.

3. Release the mouse button to load the color, then click the Create Material button in the 
Color Chooser dialog. Click OK to close the Color Chooser dialog.

4. The new "Custom Color" is now saved in the My Library catalog with its R, G, B colors 
specified in its name. It can be renamed and moved, and is available for use in any plan.
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Custom Materials, Images, and Backdrops
Chief Architect allows you to customize your 3D views by importing your own materials, 
image objects, and backdrops that display in 3D views. For more information about images, see 
“Pictures, Images, & Walkthroughs” on page 989 of the Reference Manual. 

Creating Materials
Materials are special digital images that can be applied to the surfaces of objects. You can 
create your own custom materials and save them in the library. Bear in mind that materials 
typically cover a surface by tiling an image repeatedly and are specially edited so that they tile 
seamlessly: as a result, not all images will necessarily serve as effective materials.

Once a material is saved in the library, it can be applied to objects in any plan, either using the 
objects’ specification dialogs or the Material Painter tool. 

To add a new material to the library

1. Select Library> Library Browser  (or press Ctrl + L) to open the Library Browser.
2. Right-click on the User Libraries category and select New> Material from the contextual 

menu.
3. On the Texture tab of the Define Material dialog, give the new material a short, descriptive 

name.

Note: The following steps make use of image files that are not
included with the program. You can use image files that are already
on your computer or you can create new ones. You can even use
the same image file to create a material, an image, and a backdrop.
Learning the tools and techniques described is more important than
the appearance of the final product.
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4. Click the Browse button to open the Select Texture File dialog and browse to an image on 
your computer.

5. Select an image and click the Open button to return to the Define Material dialog.
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6. Specify the Scale of the texture, which controls how large the image will appear on the 
surfaces it is applied to.

7. On the Properties tab, specify the Material Class and attributes of the material. A Matte 
material will most closely resemble cloth, which is what this material will be used for.  

8. Click OK to add the new material to the My Library catalog.

For more information, see “Define Material Dialog” on page 756 of the Reference Manual. 

Creating Images
In Chief Architect, image objects are more than just 2D pictures. Images have size and height 
attributes and can contain transparency information. In floor plan view, they display only as 2D 
symbols; but in 3D views, the visual information that images contain can be seen.  

Images can be placed in a plan just as plants, furnishings and fixtures are: by selecting the 
image and clicking any floor plan view, camera view or overview. 

To create an image and save it to the library

1. Right-click on the My Images category of the Images library and select New> Image  
from the contextual menu to open the Image Specification dialog. For more information, 
see “Image Specification Dialog” on page 993 of the Reference Manual.

2. On the Image tab, click the Browse button and browse to any image on your computer. In 
this tutorial we will use an image of a dog that has transparency data associated with it; 
however, you can use any image. 

3. Click Open to return to the Image Specification dialog.
4. On the Image tab, enter the Height or Width, adjusting one will adjust the other, 

maintaining the correct proportion. Enter a Height Above Ground value to specify the 
elevation at which the image displays. A value of 24 inches works well in this case.
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5. Specify the transparency settings on the Transparency tab. 
6. Click OK to close the Image Specification dialog and add the new image to the My 

Images category in the Images library.

Importing Backdrops
Backdrops are images that display behind 3D views. In Chief Architect, you can take a photo 
of a site, save it to the library as a backdrop, and display it behind 3D views to create a realistic 
rendering of your model and its surrounding view.

To import a backdrop and save it to the library

1. Select File> Import> Backdrop  and browse to an image on your computer.

2. Select the image and click Open to add it to My Library.

To apply a backdrop to 3D views

1. Select 3D> 3D Settings   to open the 3D Settings dialog. 
2. On the Backdrop tab, click the Select Backdrop button to open the Select Library Object 

dialog.
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3. Find and select your backdrop from My Library and click OK.

4. Click OK to close the 3D Settings dialog. 
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You can see your custom material, image and backdrop by creating a Full Camera  view.

Generating a Materials List
To conclude this tutorial, we’ll generate a materials list for the house. You can generate a 
materials list for a single room, an area of the plan on one floor, or the whole plan. For more 
information, see “Materials Lists” on page 1119 of the Reference Manual.

To generate a materials list for the whole plan

1. Select Tools> Materials List> Calculate From All Floors . A materials list is 
generated for all floors of the house.

2. Locate the  under the Fixtures category. 
3. Click in the “Price” column for the barbeque and type in $75.00. Notice that the subtotal 

and Total both update to reflect the pricing change. You can specify prices for every 
material in your plan, allowing you to generate a cost estimate.

Note: The Materials List is only a rough cost estimate and should be
double checked before being relied on.
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4. If you wish, you can select File> Export Materials List  and save the list as a Tab-
delimited  .txt file, which can be opened in a spreadsheet application. 

5. Close the materials list by selecting File> Close Window from the menu. A dialog 
displays, asking if you want to save the materials list before closing.

6. Save or click No to close without saving. A new materials list can always be created later.

7. When you have finished, you may want to Save  your work.

You can generate a materials list to estimate the cost of an entire plan or just a portion of a plan. 
For more information, see “Materials Lists” on page 1119 of the Reference Manual.

8. Click in the “Price” column for the barbeque and type in $75.00. Notice that the subtotal 
and Total both update to reflect the pricing change. You can specify prices for every 
material in your plan, allowing you to generate a cost estimate.

9. If you would like, you can export the materials list as a Tab-delimited .txt file that can be 

opened in a spreadsheet program. Select File> Export Materials List  and save the 
materials list using the Write Materials Export File dialog. See “Editing Materials Lists” 
on page 1127 of the Reference Manual. 

Note: The Materials List is only a rough cost estimate and should
always be double checked before being relied on.
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10. Close the materials list window by selecting File> Close from the menu, by pressing F4, or 
by clicking the  in the upper right hand corner (for the current window, not the program). 
The Keep Materials List dialog displays, asking if you wold like to save this materials list 
before closing. 

11. Click No to close the materials list and return to the previous view.

To calculate a materials list for an individual room

1. Click the Select Objects  button, then click in a room to select it.

2. With the room selected, click the Calculate from Room  edit button or select Tools> 

Materials List> Calculate from Room . The program calculates a list of the objects 
and materials contained in the selected room. 

To calculate a materials list for just the deck

1. In floor plan view, select Tools> Materials List> Calculate from Area .
2. Click and drag a rectangle surrounding the first floor deck to display a materials list for the 

area within the rectangle. The resulting materials list only includes objects and materials 
located within the rectangle.

If you would like, you can continue working on this plan in the Kitchen and Bath Design 
Tutorial. 
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Chapter 5:

Kitchen and Bath
Design Tutorial

This tutorial continues where the Materials Tutorial left off. You should save this tutorial using 
a new name to archive your previous work. 

The tools and techniques used to design kitchens and bathrooms are very similar. This tutorial 
focuses on kitchen design. When you’re finished you can use what you’ve learned to finish up 
the bathrooms as well. In this tutorial you will learn about: 

•      Adding Cabinets
•      Placing Appliances
•      Editing Cabinets and Appliances
•      Creating a Custom Countertop

•      Creating Architectural Blocks
•      Editing Cabinets and Appliances
•      Working in Cross Section/Elevation Views

Adding Cabinets
We’ll begin by placing a cabinet in the kitchen and editing its dimensions, orientation, and 
placement. For more information about cabinets, see “Cabinets” on page 581 of the Reference 
Manual.

To place a base cabinet

1. Zoom  in on the Kitchen/Nook area in floor plan view.

2. Select Build> Cabinet> Base Cabinet .
3. Click to place a base cabinet anywhere in the kitchen.
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Once a cabinet is placed, it can be edited like other objects.

To select and edit a cabinet
1. Cabinets can be selected using one of the following methods.

• Click on the cabinet while the Select Objects  tool is active.

• Click on the cabinet while any of the Cabinet Tools  are active. This allows only 
cabinets to be selected.

• Right-click on the cabinet when another tool is active.
2. When the cabinet is selected, edit handles, a front indicator, and a temporary dimension 

display. As with other objects, the arrow that displays when the pointer is held over an edit 
handle indicates what edit function that edit handle will perform. See “Editing Box-Based 
Objects” on page 184 of the Reference Manual.

• Move a cabinet using the move edit handle. By default, you can move a cabinet at 90° 
angles. To allow unrestricted movement, hold down the Ctrl key (or click using the 
right mouse button) then drag the cabinet. 

• Resize two sides of a cabinet using a resize edit handle, located in each corner. 
• Extend a cabinet’s edge on one side using an extend edit handle. One of the extend edit 

handles also displays an arrow that indicates the cabinet’s front. 
• Rotate a cabinet using the rotate edit handle.
• A temporary dimension updates as the cabinet is moved or resized.

3. When the cabinet is selected, you can also click the Open Object  edit button to open 
its specification dialog and make a wide variety of changes to the cabinet. For more 
information, see “Cabinet Specification Dialog” on page 598 of the Reference Manual.

To lay out base cabinets for this tutorial
1. Place and position base cabinets in your plan and edit their width and orientation as shown 

in the following image. 

Resize edit 
handles

Rotate edit 
handle

Move edit 
handle

Front 
indicator
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• Notice that three of the cabinets are 36" wide, and one is 30" wide.
• A cabinet snaps to another if they are in alignment, facing the same direction, and of 

the same type.

To create corner cabinets 
1. Select the three foot base cabinet at bottom left.

Note: The display of cabinet module lines has been turned on in the following
image. See “Displaying Cabinets” on page 589 of the Reference Manual for more
information. 
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2. Click the Open Object  edit button to open the Base Cabinet Specification dialog. On 
the General tab:

• Specify a Width greater than the Depth. The selected cabinet’s width should already 
have been changed to 36", which works well with a 24" depth. If it isn’t, change it to 
36" now.

• Click the Special drop-down list and select Corner. 
• On the Front tab, check the box beside Diagonal Door. 
• Click OK to change the cabinet into a corner cabinet with an angled door front.

3. Select the three foot cabinet at bottom right and open it for specification:
• On the General tab, change it to a corner cabinet (as we did in the previous step). 
• On the General tab, change the Left Side Width to 45 inches (45").

chief-architect-x3-users-guide.book  Page 120  Monday, August 9, 2010  2:08 PM



Adding Cabinets

 121

• On the Front tab, uncheck the box beside Diagonal Door if it is checked.
4. Click OK to close the Base Cabinet Specification dialog, then select this cabinet and 

move it into the corner, until it bumps into the walls.
5. Select the corner cabinet on the left, and push it (along with the others) into the corner 

cabinet on the right.

6. Place two more base cabinets next to it that face to the right. Once placed, the cabinets may 
need to be rotated.

To place wall cabinets

1. Select Build> Cabinet> Wall Cabinet .
2. Click very near a corner to place a corner wall cabinet as shown. You can also place a 

standard wall cabinet, then open it for specification and change it to a corner cabinet, as 
described above.
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3. Continue placing wall cabinets, adjusting their widths to match the base cabinets below.

To place soffits

Select Build> Cabinet> Soffit  then click above the wall cabinets to place soffits. 
Adjust their width and orientation to match the wall cabinets below.

When objects are very close to one another or occupy the same vertical
space in floor plan view, it may be difficult to select the intended object. You

can select an objects, then click the Select Next Object edit button or press the
Tab key to select a neighboring object. The Status Bar indicates which object is
currently selected.
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Placing Appliances
Appliances come in two basic varieties, freestanding and built-in. Most plans use both types, 
including this one. For more information about library objects such as appliances, see “The 
Library” on page 713 of the Reference Manual.

To place a freestanding appliance

1. Select Library> Library Browser  to open the Library Browser.
2. Open the Architectural category to the Appliances library, find a standard refrigerator, and 

select it for placement.
3. Click to the right of the base cabinets near the top of the screen to place the refrigerator. 

You may need to move the cabinets so that the side of the refrigerator can be aligned with 
the wall of the nook.

The Status Bar indicates which object is currently selected
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To place a built in appliance
1. Open the Fixtures category to the Sinks library, find the double self-rimming 32 inch sink 

(Architectural>  Fixtures> Sinks> Kitchen Sinks> With Fixtures> Self-Rimming) and 
select it for placement. 

2. Click on the base cabinet near the top of the screen that is 3 feet wide to place the sink.
3. In the Appliances library, find a basic dishwasher, select it for placement, and click on the 

cabinet to the right of the sink.
4. In the Appliances library, find the electric drop-in range (Ranges> Slide-In) and select it 

for placement.
5. Place the range in the 30 inch cabinet near the bottom of the screen. 
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To move a group of cabinets
1. Select the far left cabinet near the top of the screen.
2. Place the pointer over the move handle and push the entire group of cabinets against the 

refrigerator.

Editing Cabinets and Appliances
We’ve already learned how to edit the dimensions of cabinets and appliances in floor plan view. 
Like other objects, cabinets and appliances can also be edited in their own specification 
dialogs. This method allows a higher degree of customization.

To edit cabinets in the Cabinet Specification dialog

1. Select the cabinet to the left of the sink and click the Open Object  edit button to open 
the Base Cabinet Specification dialog.

2. Select the drawer in the preview. Notice that clicking anywhere on the preview takes you 
to the Front tab.
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3. Click the Add New button to open the New Cabinet Face Item dialog.
4. Click the Item Type drop-down list and select Cutting Board, assign an Item Height of 1 

inch, and click OK to return to the Cabinet Specification dialog.

5. A new Cutting Board face item, as well as a new Separation, will be added below the 
drawer that you selected.  
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6. Click on the cutting board in the preview, then click the Move Up button three times to 
move the cutting board above the drawer and the empty spaces above and below it. 

7. Select the Separation and click the Move Up button three times, as well. 

8. Click OK to close the Base Cabinet Specification dialog.

To edit appliances in their specification dialogs

1. Select the refrigerator and click the Open Object  edit button to open the Fixture 
Specification dialog.

2. On the General tab, change the Depth to 28 and click OK.

Creating a Custom Countertop
Now we’ll add a custom countertop with an overhang. For more information, see “Editing 
Custom Countertops” on page 595 of the Reference Manual.

To create a custom countertop

1. Turn on Object Snaps .

2. Select Build> Cabinet> Custom Countertop .
3. Click and drag to draw a rectangular polyline that will become our custom countertop.

Note: Your cabinet may have a side backsplash to the left in the preview. This is 
because of the invisible wall to the left. Moving the invisible wall away from the cab-
inet removes this backsplash. If the cabinet displays a partial rear backsplash, it 
may be because of the window behind the cabinet.
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4. Select the custom countertop and use the edit tools to edit its shape as shown in the 
following image.

• Use the Break Line  and Change Line/Arc edit buttons to add edit handles and 
change the polyline’s shape. For more information, see “Break Line” on page 208 of 
the Reference Manual.

5. While we’re at it, let’s add some stools to our new bar (Interiors> Furniture> Seating> 
Stools).

6. Let’s create a Full Camera  view and take a look.

Custom countertop hatched for illustrative 
purposes only
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Creating Architectural Blocks
Groups of items can be blocked together and saved to the library for use in other plans. 

To create an architectural block
1. Return to floor plan view.
2. Group select all objects you would like to include in the architectural block. Select one 

object, then hold down the Shift key and select additional objects to add them to the 
selection set. There are many other ways to select and group select objects. For more 
information, see “Selecting Objects” on page 162 of the Reference Manual.

3. Click the Make Architectural Block  edit button.

Group selected 
cabinets, custom 
countertop, and 
stools
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To add objects to the library
1. If it is not still selected, select the architectural block.

2. Click the Add to Library  edit button to add the cabinet to the Import folder in the 
Library Browser.

3. Right click on the Base cabinet name in the import category and select Rename to change 
this cabinets name to Kitchen Bar.

4. Now click and drag the newly named Kitchen Bar cabinet into the appropriate Users 
Libraries folder that you have created for it, such as Base Cabinets.

To explode an architectural block
1. Select an architectural block.

2. Click the Explode Architectural Block  edit button.

Working in Cross Section/Elevation Views
Like other objects, cabinets can be edited in cross section/elevation views. This method of 
editing is very powerful and allows objects to be edited easily in vertical space. Next we’ll edit 
wall cabinets and add a range hood. For more information about cross section/elevation views, 
see “Working in 3D” on page 805 of the Reference Manual.

To create a cross section/elevation view

1. In floor plan view, select 3D> Create Orthographic View> Cross Section/Elevation . 
Click and drag a line of sight that that intersectsgroup of cabinets that includes the electric 
range.

2. Zoom  in on the kitchen.

chief-architect-x3-users-guide.book  Page 130  Monday, August 9, 2010  2:08 PM



Working in Cross Section/Elevation Views

 131

To edit the cabinets in a cross section/elevation view

1. Click the Select Objects  button, then click on the wall cabinet above the range, which 
should have double doors and be 36" wide like the base cabinet below it.

2. Click on the cabinet’s bottom edit handle and drag it upwards.

3. When the temporary dimension indicates that the cabinet height is 18 inches, release the 
mouse button.

To place a range hood
1. Find a range hood from the Fixtures Library (Architectural> Appliances> Hoods> 

Standard) and select it for placement.
2. Click above the range to place the hood.
3. If necessary, adjust its height and size using its edit handles.
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Finishing Touches
You may want to add a few finishing touches.

• Remove the window behind the refrigerator.
• Raise the bottom of the window behind the sink.
• Widen the window behind the sink, and center it on the sink.
• Add furniture and cabinets to the nook and change the flooring to match the kitchen.
• Add a table and some chairs to the dining room.

To view our kitchen using the Cross Section Slider and Final View

1. In floor plan view, click Fill Window .

2. Create a Full Camera  view that starts from the exterior and release the mouse button 
in the kitchen. See “To create a camera view” on page 45.
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3. Use the Mouse-Orbit Camera  tool to adjust the camera’s perspective. If you want, 
you can turn off the display of the backdrop in the 3D Settings dialog. For more 
information, see “3D Settings Dialog” on page 784 of the Reference Manual. 

4. Select 3D> Camera View Options> Cross Section Slider  to open the Cross Section 
Slider dialog. 

5. Select the flat cut line and use the position slider to specify the location of the cutting 
plane. See “Cross Section Slider” on page 804 of the Reference Manual.

6. Select 3D> Camera View Options> Final View  to create a higher quality final view.
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7. In a future tutorial, we will be returning to this plan file, so be sure to Save  your work. 

If you would like, you can continue working on this plan in the Landscaping Tutorial. To learn 
how to arrange views of your model on a page for printing, see the Layout Tutorial.
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Landscaping
Tutorial

This tutorial was written to help you learn how to use Chief Architect’s Terrain tools. In this 
tutorial, you will learn how to add elevation information to your terrain, how to create terrain 
features, and how to add plants and other objects from the library. 

It is a good idea to become familiar with the terrain tools before beginning your own terrain 
project. 

In this tutorial, you will learn about:
•      Editing the Terrain Perimeter
•      Creating a Plot Plan
•      Adding Elevation Information
•      Creating a Retaining Wall

•      Adding Terrain Features
•      Adding Library Objects to Your Plan
•      Creating Final Views

This tutorial continues from where the House Design Tutorial left off, so you may want to save 
this plan using a new name to archive your previous work.
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Editing the Terrain Perimeter
Your house may already be centered on the terrain perimeter. If it is not, you can move it.

To move the terrain perimeter

1. Select Window> Fill Window  then select Window> Zoom Out  to give us some 
working space.

2. Select the terrain perimeter and place your pointer over the move edit handle.

3. Move the terrain perimeter so that the house is centered.
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Displaying Lot Line Information
When plans are submitted for approval, bearing information for the lot perimeter is often 
required.

To display bearing information

1. Select the terrain perimeter and click the Open Object  edit button.
2. On the Line Style tab of the Terrain Specification dialog, check Show Length and Show 

Angle, then click OK. See “Terrain Specification Dialog” on page 632 of the Reference 
Manual. 

3. Select Edit> Default Settings  to open the Default Settings dialog, then open the CAD 
Defaults dialog. See “To display line length, bearing and radius” on page 140. 

4. Click the radio button to Display Line Angle as Bearing and click OK.
5. Click Done to close the Default Settings dialog.

Creating a Plot Plan
A plot plan is essentially a map of a property’s legal description. Plot plans usually have a 
North Pointer and can also include other features such as the location of buildings and setback 
lines.

When a property’s shape is more complicated than a basic rectangle, you may find it easiest to 
draw the plot lines yourself, rather than try to edit the terrain perimeter to meet your needs.

A plot plan can be drawn in floor plan view or, if you prefer, in a CAD Detail. 
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To create a plot plan polyline
1. Open a new Chief Architect plan.
2. If you want to draw your plot plan in a CAD Detail, select CAD> CAD Detail 

Management  and click New.
3. Type a short, descriptive name for your detail, such as "Plot Plan" and click OK.

4. Select CAD> Points> Input Point  to open the New CAD Point dialog. See “Input 
Point” on page 936 of the Reference Manual. 

5. Select Absolute Location and define the point’s position at (0,0) and click OK. This is the 
current point that serves as the Start Point for the first line of the plot plan. See “Point 
Tools” on page 936 of the Reference Manual.

6. Select CAD> North Pointer , then click and drag to create a North Pointer. See “North 
Pointer” on page 942 of the Reference Manual.

7. Select CAD> Lines> Input Line  to open the New CAD Line dialog. Notice that the 
Start Point is at (0,0): the location of the current point. See “Input Line” on page 940 of the 
Reference Manual.

8. Click Num Style and in the Number Style/Angle Style dialog, select Decimal Feet for the 
Number Style and Bearing for the Angle Style. See “Number Style/Angle Style Dialog” 
on page 110 of the Reference Manual.

9. Click OK to return to the New CAD Line dialog 
10. Select Relative to Start Point and check Polar (CCW to horz.). 
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11. Enter the length of the first side of your property boundary’s legal description in the 
Distance field, and the angle of that line in the Angle field.

12. Click Next and enter the Distance and Angle of the next property line. 
13. Continue until all property lines are entered, then click OK to close the New CAD Line 

dialog. The property line created should be closed, with the end point of the last line the 
same as the start point of the first.

To correct an error
1. If a line is entered incorrectly, click OK to close the New CAD Line dialog. 

2. Select Edit> Edit Behaviors> Edit Object Parts  to edit individual line segments 
within a polyline.

3. Click on the incorrect line to select it, then click Delete .

4. Click the Edit Object Parts  toggle button again to turn it off.

5. Place a CAD point at the end of the last correct line using the Place Point  tool to create 
a new current point.

6. Select CAD> Lines> Input Line  and continue entering data in the New CAD Line 
dialog.

To create a curved property line 

1. Click a property line to select it, then click the Change Line/Arc  edit button to turn 
this line into an arc.

2. If necessary, use the triangular Reshape edit handle to make the arc concave or convex.

3. Click the Open Object  edit button to open the Arc Specification dialog.
4. On the Arc tab, click the Lock Chord radio button, then specify the length of the Radius 

and click OK. 
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To display line length, bearing and radius

1. Select Edit> Default Settings .
2. In the Default Settings dialog, select CAD and click the Edit button.
3. In the CAD Defaults dialog, check Display Line Angle as Bearing.
4. Click OK, then click Done to close the Default Settings dialog, as well. 

5. Click the plot plan polyline to select it, then click the Open Object  edit button. 
6. On the Line Style tab of the Polyline Specification dialog, check Show Length, Show 

Angle, and All Angles. 

To convert to a terrain perimeter

1. Select the plot plan polyline and click the Convert Polyline  edit button. See “Convert 
Polyline” on page 215 of the Reference Manual.

2. In the Convert Polyline dialog, select Convert To: Terrain Perimeter, then click OK.
3. Make any needed changes in the Terrain Specification dialog and click OK. See “Terrain 

Specification Dialog” on page 632 of the Reference Manual.

A curved property line can also be created by entering data in the
New Arc dialog. See “Input Arc” on page 950 of the Reference

Manual.
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To create setback lines

1. Select Edit> Preferences , and on the Behaviors panel of the Preferences dialog, 
select the Concentric Edit Mode. See “Behaviors Panel” on page 97 of the Reference 
Manual.

2. In the Jump field, type in the setback distance required by your local planning department, 
such as 10’, and click OK.

3. Click the plot plan polyline to select it, then click the Copy/Paste  edit button. 
4. Place your cursor over a corner edit handle, then click and drag towards the center of the 

polyline. When a second, inner polyline appears, release the mouse.

5. Select the inner polyline and click the Open Object  edit button to open the Polyline 
Specification dialog.

6. On the Line Style tab, select a dashed line style from the drop-down list, uncheck Show 
Length and Show Angle, then click OK.

7. When you have finished creating your concentric copy, select Edit> Edit Behaviors> 

Default  to restore the default edit behavior.

To accurately position a building

1. Place a CAD Point  at a reference point along the perimeter of the property, such as at 
a corner. Or use the starting point for your plot plan polyline, (0,0), as a reference. 

2. Select CAD> Points> Input Point  to open the New CAD Point dialog.
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3. If you are using (0,0) as your reference point, select Absolute Location and specify the 
distance that the building should be from this point in the X Position and Y Position 
fields.

4. If you have placed a CAD Point at a different location, select Relative to Current Point 
and specify the desired distance from that point. Unless you want to specify the location in 
distance and bearing, Polar (CCW from horz) should remain unchecked.

5. When you click OK, a point is created at the specified location. Use this point as a 
reference to accurately position a wall or corner of the building.

To create a new layer

1. Select Tools> Display Settings> Display Options  to open the Layer Display Options 
dialog.

2. Click the New button to open the New Layer Name dialog.
3. Enter a name for the new layer.

4. Click OK to close the New Layer Name dialog then click OK again to close the Layer 
Display Options dialog.

To move the setback line to the new layer

1. In floor plan view, select the setback line and click the Open Object  edit button.
2. On the Line Style tab of the Polyline Specification dialog click the Layer drop-down list 

and select the new layer we just created. This moves the setback line to the new layer, 
however that layer is still currently displaying. Click OK.
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Adding Elevation Information
Our terrain is currently flat because there is no elevation data in the plan. For more information 
about elevation information, see “Elevation Data Tools” on page 618 of the Reference Manual.

To add elevation information to your plan

1. Select Window> Fill Window  to fill the window with the terrain perimeter.

2. Select Terrain> Elevation Data> Elevation Line  and draw elevation lines as shown 
in the following image. An elevation line drawn near the end of another will merge.

3. To enter elevation information, click the Select Objects  button, select an elevation 

line, and click the Open Object  edit button to open the Elevation Line Specification 
dialog. Values entered are in inches unless the foot ( ' ) mark is added. Negative values 
should be preceded with a hyphen (-).

You can display all of the tools in the Terrain menu on your tool-
bars by using the Terrain Configuration. See “Toolbar Configura-

tions” on page 119. 

200”

180”

96”
72”

48”

-72”

-120”
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4. Select 3D> Create Perspective View> Full Overview  to create a full overview. 
Pressing the “I” key or the “O” key moves the camera in or out. 

Creating a Retaining Wall
Adding a retaining wall helps create a flat building pad for the house. For more information 
about retaining walls, see “Retaining Walls” on page 628 of the Reference Manual.

To draw a retaining wall
1. Return to floor plan view. Note the generated contours.
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2. To make it easier to draw, you can turn off the display of primary contour lines in 2D. 
Select Tools> Display Settings> Display Options  to open the Layer Display Options 
dialog. Remove the check from the Disp column for the layer “Terrain, Primary Contours”. 
See “Layer Display Options Dialog” on page 130 of the Reference Manual for more 
information.

3. Select Terrain> Wall and Curb> Straight Retaining Wall . Draw two straight wall 
sections as shown in the following image.

4. Select Terrain> Wall and Curb> Curved Retaining Wall  and draw a curved 
retaining wall that connects at both ends to the two straight sections. Don’t worry about the 
angle just yet, we’ll adjust the curve in the next step.

5. Select the curved section then click the Make Arc Tangent  edit button to open the 
Radius of Tangent Curved Wall dialog. This dialog gives you a few alignment options. 
For more information, see “Make Arc Tangent” on page 254 of the Reference Manual. 
Click OK to make the curved wall section tangent to both straight sections. 

Open 3D views are redrawn whenever changes are made to the
plan, even if the 3D views are not active. Closing 3D views when

they are not needed will help maximize your computer’s performance.
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6. Now add two more Elevation Lines  just inside the retaining wall. This helps designate 
the height of this area when terrain is generated. This elevation line can stay at its default 
height of 0' 0”.

7. Take a look in a Full Overview . Your plan should look like this.

0”

chief-architect-x3-users-guide.book  Page 146  Monday, August 9, 2010  2:08 PM



Adding Terrain Features

 147

Adding Terrain Features
Now we’ll add a skirt around the house, a beach, a water line, and a pathway to our plan. For 
more information about terrain features, see “Terrain Feature Tools” on page 624 of the 
Reference Manual.

To add a skirt to the house
1. Close the overview to return to floor plan view.

2. Select Terrain> Feature> Rectangular Feature .
3. Click and drag to draw a feature polyline that surrounds the house.

4. With the Select Objects  button active, click the skirt to select it, click the Break 

Line  edit button, then click on the garden bed to add a break. 
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• A break adds an edit handle, allowing greater control of the shape of the terrain 
feature. 

• Continue adding breaks and using the edit handles to adjust the shape of the garden 
bed to match the footprint of the house. 

• For more information, see “Break Line” on page 208 of the Reference Manual.

5. If you want to, you can make an edge of the terrain feature curved by selecting that edge, 
then clicking the Change Line/Arc edit button.

6. While the terrain feature is still selected, click the Open Object  edit button to open the 
Terrain Feature Specification dialog.

7. On the Materials tab, select the terrain feature and click the Library Material button to 
open the Select Library Object dialog. Select a material for the terrain skirt and click OK. 

It may be easier to shape the terrain feature if all snapping
behavior has been turned off. For more information, see “Snap

Behaviors” on page 141 of the Reference Manual.
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8. Create a Perspective Full Overview  to see the results. 

To create a beach
1. Close the overview and return to floor plan view. 

2. Select Window> Fill Window  then select Window> Zoom Out  to give us some 
working space outside the terrain perimeter.

3. Select Terrain> Feature> Spline Feature  and draw a round terrain feature that 
extends beyond the boundaries of the terrain perimeter.
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4. Select the terrain feature and the Open Object  edit button to open the Terrain Feature 
Specification dialog.

• On the General tab, the Height should be at 0 inches. 
• On the Materials tab, select the terrain feature and click the Library Material button 

to open the Select Library Object dialog and assign a sand material from the 
landscaping library.

• Click OK to close the Select Library Object dialog then click OK to close the Terrain 
Feature Specification dialog and return to floor plan view.

5. Take a look at our new beach in a Perspective Full Overview . Notice that only the 
portion of the terrain feature that is included within the terrain perimeter is modeled.

To create a body of water

1. Return to floor plan view, select Terrain> Water Feature> Round Pond  and draw 
another spline feature, within the existing spline feature (the beach).
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2. Select the pond and click the Open Object  edit button. On the General tab of the 
Terrain Feature Specification dialog, raise the Height to 1 inch. This will display the 
water material above the beach.

3. Click OK and take a look in a Perspective Full Overview .

To create a stepping stone pathway 
1. Return to floor plan view. 

2. Select Terrain> Stepping Stone> Polyline Stepping Stone  and draw a stepping stone 

just above the beach line, leading to the entrance. It may help to Zoom  in.
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3. Select the stepping stone and open it for specification. 
• On the General tab, note that the Height is 1 inch. 
• On the Materials tab, select the Terrain Feature component, click the Library 

Material button, and specify a different material if you like. Brick Pavers in the 
Landscaping library make nice stepping stones.

4. Click OK to close the Select Library Object dialog then click OK to close the Terrain 
Feature Specification dialog and return to floor plan view.

5. Let’s look at our stepping stone in a Full Camera  view.

6. In floor plan view, click the Select Objects  button, select the stepping stone, click the 

Copy/Paste  edit button, then click the Sticky Mode  secondary edit button.
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7. Click in floor plan view to paste copies of the group selected objects. Continue pasting 
copies until you have created a pathway that leads to the house.

Adding Library Objects to Your Plan
The library contains many objects that can be added to a plan such as plant images and 
landscaping blocks. There are two ways to find objects in the library: by browsing and by 
searching. For more information about library objects, see “The Library” on page 713 of the 
Reference Manual. 

To browse the Plants library category

1. If the Library Browser is not open, select Library> Library Browser  to open it.
2. Click the + beside Plants to expand this category  and see its contents.
3. Click the + beside Trees to expand this folder  and view its contents, as well.
4. Expand the Deciduous folder and note the many tree species to choose from. Many of 

these folders contain still more subfolders with different varieties of that species. 

If you know exactly what tree you would like to place in your plan, browsing to it is an efficient 
way to find and select it; however, with so many options available it is often helpful to perform 
a search. 
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To search using the Plant Chooser

1. With the Library Browser still open, click the Plant Chooser  button at the bottom of 
the Library Browser to open the Plant Chooser dialog. This dialog can also be opened by 

selecting Terrain> Plant> Plant Chooser .

2. At the bottom of the Library Browser, click the Plant Chooser  button to open the 
Plant Chooser dialog. This dialog can also be opened by selecting Terrain> Plant> Plant 

Chooser .
3. On the Plant Information tab, enter “birch” in the Common Names field, and click the 

Search button to find birch trees in the Library Browser.

4. Select Betula papyrifera (young) from the search results and click the Close button. This 
locates and selects this plant in the Library Browser for placement.

5. Click in floor plan view or a 3D view to place the selected plant at that location. You can 
continue placing the selected plant image until another tool or library object is selected. 
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To add Landscaping Objects

1. In the Library Browser , browse to the Chief Architect Libraries category. 
2. The Exteriors library contains a selection of landscaping, deck and patio accessories, 

outdoor furniture, and other objects that you can place in your plan.
3. Outdoor furniture such as a garden bench are located in the Outdoor Living library folder. 

Library objects may need to be rotated, and can be accented with additional plants.

4. Create a Perspective Full Camera  view.
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Creating Final Views
A final view can be created from any full overview or camera view. A final view smooths out 
edges in a plan and creates a more realistic rendering of the model. For more information about 
final views, see “Preview vs Final View” on page 815 of the Reference Manual.

To take a Final View

1. Select 3D> Create Perspective View> Full Overview . Adjust the overview as you 
see fit.

2. Select 3D> Camera View Options> Final View With Shadows  to create a final view 
from the full overview.

3. When you have finished, you may want to Save  your work.

If you would like, you can continue working on this plan in the Deck Tutorial.  To learn how to 
arrange views of your model on a page for printing, see the Layout Tutorial.
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Deck Tutorial

In the House Design Tutorial, we added a deck to the backside of the house on both the first 
and second floor. Now we’ll continue where the  Landscaping Tutorial left off and create two 
more decks off the front of the house, connecting them with an exterior staircase. You may 
want to save this tutorial using a new name  to archive your previous work.

In this tutorial you will learn about: 
•      Drawing Decks
•      Drawing Stairs

•      Changing Planking Orientation
•      Adding Exterior Furniture

Drawing Decks
Since this home is on a beach, we might as well add a couple of decks off the front. For more 
information, see “The Deck Tools” on page 238 of the Reference Manual.

You can move the stepping stones that we added in the previous tutorial, delete them, or simply 
ignore them for now. 

To add a first floor deck to the plan
1. In floor plan view, go to the first floor (you may be there already).

2. Make sure Angle Snaps   and Object Snaps  are turned on. 
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3. Zoom  in on the front portion of the house.

4. Select Build> Deck> Straight Deck Railing  and draw a deck off of the first floor as 
shown in the following image. As you may recall from the first tutorial, when the deck 
railings and the exterior front walls of the house enclose an area, room definition is created 
and a "Deck" room label displays. 

5. Now take a look at our first floor deck in a Full Camera  view. You can see that the 
program automatically generated planking, posts, and beams.

To create a second floor deck beside a roof 

1. Return to floor plan view and select Build> Wall> Break Wall . Click on the exterior 
wall on the right side of the dining room, at the point where it is intersected by the wall 
separating the dining room from the kitchen.
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2. Click the Select Objects  button, then click on the exterior wall on the right side of the 
dining room to select it.

3. Click the Open Object  edit button, and on the Roof tab of the Wall Specification 
dialog, uncheck Full Gable Wall and click OK. 

4. Click the Up One Floor  button to go to the second floor, select the attic wall directly 

above the exterior wall you just edited and Delete  it.

5. Select Tools> Reference Floors> Reference Display  (or press F9) to turn on the first 
floor for reference. 

6. Select Build> Deck> Straight Deck Railing  and draw a deck on the second floor, 
above the dining room. 

7. Click and drag the railings at the front and right sides so that their exterior surfaces are 

aligned with the exteriors of the walls below. Make sure Object Snaps  are still turned 
on, then select the deck railing. Object snap indicators will display when the railing and 
wall below are in alignment.

8. The railing on the left side, however, should be just to the right of the wall below.

9. Select Build> Wall> Straight Exterior Wall  and draw an exterior wall directly over 
the wall on the left side of the dining room.

10. Select this wall and click the Open Object  edit button. On the General tab of the Wall 
Specification dialog, select Siding-4 from the Wall Type drop-down list, and click OK.

11. Select Tools> Reference Floors> Reference Display  (or press F9) to turn off the 
Reference Display again. 
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12. We now need to create access to the deck. Delete  the two windows, select Build> 

Door> Sliding Door , then click on the wall to place a sliding door. 

Object Snaps indicating alignment
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13. Now take a look at our second floor deck in a Full Camera  view.

The platform edge of the second story deck can be made to match the exterior wall using the 

Material Eyedropper  tool. See “Using the Material Eyedropper” on page 104.
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Drawing Stairs
Now we’ll draw stairs between the upper and lower decks, and from the lower deck to the 
terrain below. For more information, see “Stairs, Ramps & Landings” on page 455 of the 
Reference Manual

To connect the upper and lower decks with stairs
1. In floor plan view, go to the first floor. 
2. The deck planking is making it difficult to see the area where we’ll be working. In the 

Layer Display Options dialog, turn off the display of the layer "Framing, Deck Planking". 
If you cannot remember how to do this, see “Controlling the Display of Objects” on page 
77.

3. Make sure Angle Snaps  and Object Snaps  are turned on.

4. Select Build> Stairs> Straight Stairs . 
5. Click and drag to draw a stairway from the lower deck to the outside edge of the upper 

deck railing as shown in the following image. 
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6. To help the stairs locate the deck on Floor 2, select them and move the entire staircase 
back, away from the front railing. Then move the stairs forward again until they bump into 
the front wall of the dining room.

7. In many cases, an opening will be added automatically to the deck railing at the top of a 
staircase. You can see this opening, which is actually a doorway placed in the railing, 
either by going up one floor or by creating a 3D view of the second floor deck.

8. If an opening is not created, select Build> Door> Doorway  in either floor plan or a 3D 
view, then click on the deck railing to create an opening in front of the staircase.

To draw a down staircase to the ground

1. In floor plan view select Build> Stairs> Click Stairs 
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2. Click just to the outside of the deck platform, as shown in the following image.

3. Draw new stepping stones that lead to the staircase from the beach. To learn how to do 
this, see “To create a stepping stone pathway” on page 151.

4. Now take a look at our deck in a Full Camera  view.

Changing Planking Orientation
The angle of the deck planking can be controlled in the Room Specification dialog. 

To angle deck planking
1. Return to floor plan view and turn on the display of the layer "Framing, Deck Planking" so 

we can see the angle of the planking in floor plan view.
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2. Select the Deck room. You will likely select an individual plank. Click the Select Next 

Object  edit button or press the Tab key until the room is selected.

3. With the Deck room selected, click the Open Object  edit button and go to the Deck 
tab of the Room Specification dialog.

4. Uncheck the Automatic checkbox next to Plank Direction, and then change the Plank 
Direction to 45°. See “Deck Tab” on page 305 of the Reference Manual. 
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5. Click OK to close the Room Specification dialog and return to floor plan view.

Adding Exterior Furniture
Now let’s add some furniture to our deck. 

To add furniture to the deck
1. Open the Library Browser to Chief Architect Libraries> Exteriors> Outdoor Living> 

Outdoor Furniture> Furniture Sets> Adirondack> Adirondack Chair and select it for 
placement. When a library item is selected, a preview image displays.

2. In floor plan view or a 3D view, click on the deck to place a chair at that location. You can 
continue clicking to place more chairs.

3. Find Exteriors> Outdoor Living> Outdoor Cooking> Grills & Ranges> Gas> BBQ (shelf), 
select it for placement, and place the barbecue on the deck.
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If you would like, you can learn how to create a walkout basement in sloping terrain in the 
Walkout Basement Tutorial. To learn how to arrange views of your model on a page for 
printing, see the Layout Tutorial.
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Chapter 8:

Walkout
Basement

Tutorial

In this tutorial, we’ll use the same house plan that we’ve used in previous tutorials. However, 
the terrain will be entirely different. The terrain data, terrain objects, retaining wall, and the 
large front deck must be removed to allow for a walkout basement. We could delete all of these 
elements manually, but since we saved the plan as we began each new tutorial, we can instead 
open the plan that we saved at the end of  the House Design Tutorial (before we created 
landscaping), rename it, and start from there. 

In this tutorial you will learn about:
•      Editing the Terrain Perimeter
•      Adding Elevation Data
•      Adding Flat Regions
•      Adding Doors and Windows
•      Creating a Patio
•      Adding a Driveway
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Editing the Terrain Perimeter
1. Select the terrain perimeter, then click the Open Object  edit button to open the Terrain 

Specification dialog. 
2. On the General tab, make sure Flatten Pad and Auto Calculate Elevation are unchecked, 

and change the Elevation to 12 inches.

• Flatten Pad flattens the building pad around the house. By unchecking this, the terrain 
will be allowed to slope where it intersects the house.

• Auto Calculate Elevation places the house at average terrain height. By unchecking 
this, we can control the building’s height relative to the terrain.

• The Elevation is the distance between the default floor height of Floor 1 and a terrain 
elevation of 0". We will specify the Elevation as 12 inches to lower the terrain 12 
inches below the first floor.

3. Click OK to close the Terrain Specification dialog. 
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Adding Elevation Data
Now we’ll add elevation lines to give the site appropriate relief for a walkout basement.

Adding Elevation Lines
1. Select Terrain> Elevation Data> Elevation Line.
2. Draw an elevation line on the side of the house opposite the gable entrance. This part of 

the terrain will become lower in elevation.

3. Select the elevation line and click the Open Object  edit button to open the Elevation 
Line Specification dialog. You can also double-click the elevation line with the Select 

Objects  tool active to open it for specification.
4. Set the elevation at negative 96 inches (-96).

5. Click OK to close the Elevation Line Specification dialog.
6. Draw another elevation line on the other side of the house. We’ll let this elevation line stay 

at the default elevation of 0. 
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7. Let’s take look at our progress so far. Select 3D> Create Perspective View> Full 
Overview.

8. We can see that the lot is beginning to slope, but it could use a little more work. Close the 
current 3D view by selecting File> Close from the menu, pressing F4, or clicking the  in 
the top right corner of the window. If you have other active 3D views open, you may want 
to close them too. When multiple 3D views are open, your computer’s performance may 
not be optimal.

Adding Flat Regions
A typical walkout basement has an upper flat region where you enter the house on the first 
floor, and a lower flat region where you walk out to ground level from the basement.

To create flat regions

1. In floor plan view, Zoom  in on the house to see it in more detail.
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2. Make sure Object Snaps  are on.

3. Select Terrain> Elevation Data> Elevation Region  and draw a flat region directly 
below the deck.

4. Select the Elevation Region and click the Open Object  edit button, and on the 
Elevation tab of the Elevation Region Specification dialog, specify an Elevation of -92". 

5. Select Fill Window  to include the terrain perimeter on screen.
6. Draw another flat region that borders the main entrance, as shown in the following image.

7. Specify the elevation of this flat region as negative 12 (-12) inches.
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8. Just as we did in the previous tutorial, select the deck on the first floor and click the Build 

Advanced Deck Framing  edit button. Go to the second floor and repeat this step for 
the second floor deck.

9. Now create a Camera view of the deck. Create this camera view so that the focal point 
is the walkout basement. If you cannot remember how to do this, see “To create a camera 
view” on page 45.

The second floor deck was not given structural supports because there was a deck beneath it. 
We can take care of that manually.

To add support for the second story deck
1. Return to floor plan view.
2. On the first floor, group-select the deck railings and open them for specification.
3. On the Railing tab of the Deck Railing Specification dialog, check Post to Overhead 

Beam and click OK. See “Railing Tab” on page 277 of the Reference Manual.
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4. Take a look in a 3D view.

5. A section of our first floor deck railing should not have the Post to Overhead Beam 
attribute checked. Return to floor plan view and select Tools> Reference Floors> 
Reference Display  or press the F9 key to turn on the Reference Display.

6. Select Build> Wall> Break Wall  and place a break in the deck railing where the second 
floor deck above recedes.

7. Select the section of deck railing on the left that is not located under the second floor deck 
and uncheck Post to Overhead Beam on the Railing tab of its specification dialog. 

8. Press the F9 key to turn off the Reference Display again.
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9. Take a look in a 3D view.

Adding Doors and Windows
Now we’ll add a sliding door and some windows on the basement level.

To place a sliding door
1. Select Build> Door> Sliding Door, then click to place a sliding door in the foundation 

wall.

2. Select the door and click the Open Object  edit button, and specify this door as a glass 
door, 84 inches wide. If you do not remember how to do this, see “To edit a door” on page 
67.
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To place windows
Select Build> Window> Window, then click on the foundation walls to place windows. If 
you cannot remember how to do this, see “Placing Doors and Windows” on page 67

Creating a Patio
Our walkout basement could use a patio. As you may recall from previous tutorials, a terrain 
feature creates an object that sits on top of the terrain’s surface. This will work well for a patio.

To draw a patio
1. Press Ctrl + Tab to return to the basement level in floor plan view. 
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2. Select Terrain> Feature> Rectangular Feature  and draw a rectangular feature that 

sits on top of the flat region. This is much easier when Object Snaps  are on.

3. Open the rectangular feature for specification and on the General tab, set the Height to 4 
inches (placing it 4 inches above the elevation region) and set the Thickness to 6 inches 
(making it 6 inches thick, 2 inches subgrade). Click OK to close the Terrain Feature 
Specification dialog.

4. Press Ctrl + Tab to return to the 3D camera view. 
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Adding a Driveway
Now we’ll add a driveway to our plan.

To add a driveway to the plan
1. Select File> Close to return to floor plan view. You should still be on Floor 1.
2. Click the Fill Window  button to fill your screen with the terrain perimeter. 
3. Turn off the display of the layer, "Terrain, Primary Contours". If you cannot remember 

how to do this, see “Creating a Retaining Wall” on page 144.

4. Select Terrain> Driveway> Spline Driveway  then click and drag to draw driveway 
section. 

5. Click and drag the driveways edit handles to customize its shape as desired. See “Editing 
Spline Based Objects” on page 187.

6. Take a look at your plan in a Full Overview . Select 3D> Camera View Options> 

Final View  to smooth surface edges and improve the quality of the view. 
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If you would like, you can learn about creating retaining walls, planting beds and other 
landscaping features in the Landscaping Tutorial. To learn how to arrange views of your model 
on a page for printing, see the Layout Tutorial.
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Chapter 9:

Layout
Tutorial

In this tutorial we will create a layout template, send a few views to a layout page, then save 
this document in PDF format. 

In this tutorial you will learn about:

•      Creating a Layout Template
•      Creating a Border and Title Block
•      Sending Floor Plan Views to Layout
•      Sending Elevation Views to Layout

•      Sending Details to Layout
•      Sending Perspective Views to Layout
•      Printing to PDF

Getting Started
Chief Architect uses two file types: plans and layouts. In a plan file (.plan), we design a 3D 
model of a structure, and in a layout file (.layout) we arrange views of that model as well as 
text, callouts and other annotation to produce professional quality construction documents. For 
complete information about layouts, see “Layout” on page 1071 of the Reference Manual. 

In previous tutorials we explored aspects of creating a 3D model in a plan file. Now, we’ll 
create a layout file and arrange views of the model that we recently completed on the layout 
pages. Since we won’t be altering the model itself, it doesn’t matter which plan file you use. 
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Creating a Layout Template
Before creating a layout file, it is very helpful to create a layout template. Templates save 
default, layer and page setup settings and then apply them to new, blank files - saving you the 
time and work of specifying them every time you begin a new project. For more information 
about plan and layout templates, see “Template Files” on page 72 of the Reference Manual.

To create a layout template

1. Select File> New Layout  to open a new, blank layout file. 

2. Select Edit> Default Settings  from the menu to open the Default Settings dialog.  
Make any changes that you wish to the Text, CAD and Layout Defaults. This tutorial will 
simply use the default settings, but you can customize the defaults to suit your own tastes. 
See “Preferences & Default Settings” on page 61 of the Reference Manual. Click Done 
when you are finished to close the Default Settings dialog.

3. Select Tools> Display Settings> Display Options  to open the Layout Page Display 
Options dialog. Here you can set up line weights, styles, and colors for the layers in your 
layout template. See “Layout Page Display Options” on page 1083 of the Reference 
Manual. These settings do not affect objects within layout views - they only affect CAD, 
Text, Dimensions and layout box borders placed on the layout pages. Click OK when you 
are finished.
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4. Select File> Print> Page Setup  to open the Page Setup dialog. 

5. First we’ll click the Printer button and specify the printer. 
• If you have a local printer/plotter you will be using, select it from the list. 
• If you do not have a local printer, you can select a PDF driver as your printer. See 

“Printing to PDF” on page 200.
6. Specify the Size and Orientation for the Printer Paper and Drawing Sheet. The sizes 

available will be limited by the current printer. In most cases, the printer paper and the 
drawing sheet should be the same size. If you would like to print a test page or if you 
would like to tape smaller pieces of paper together to create a larger sheet, the printer paper 
and the drawing sheet can be different dimensions. 

7. The Drawing Scale for layout files should always be 1 in = 1 in (1 mm = 1 mm for metric 
plans). For more information, see “Page Setup Dialog” on page 1061 of the Reference 
Manual. Click OK when you are finished.

8. Select Tools> Layout> Page Down  to go to Layout Page 0. Any information that you 
place on Layout Page 0 will display and print on all pages of the document, so this is a 
good location for your border and title block. See “Layout Page Zero” on page 1078 of the 
Reference Manual. 
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9. Select Tools> Layout> Page Down  to go to Layout Page 0. Any information that you 
place on Layout Page 0 will display and print on all pages of the document, so this is a 
good location for your border and title block. See “Layout Page Zero” on page 1078 of the 
Reference Manual. 

10. Select File> Templates> Save Plan as Template . The Save Plan File dialog opens to 
the Templates directory specified in the Preferences dialog. For more information, see 
“Folders Panel” on page 85 of the Reference Manual.

11. Save your new layout template with a short, descriptive name such as "My 24 x 36 
Template.layout". 

12. When prompted, click Yes, specifying that you would like to use your new template as the 
default. 
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13. Your template layout file will close and (provided you have no other plans open) a new 
untitled layout file will open with your border, title block, default and layer settings ready 
to go.

Creating a Border and Title Block
Once the page setup of the layout sheet is established, you can use CAD tools to create a border 
and title block for your layout pages on Layout Page Zero. For information about the printable 
area of the drawing sheet, see “Show Sheet” on page 1053 of the Reference Manual.

Drawing borders may be simplified by making a few changes in the Preferences dialog and 
your plan defaults. When you have finished creating borders you may want to reverse these 
changes.

To create a layout border

1. Make sure that Object Snaps  are enabled, particular Endpoint  snaps.

2. Select Window> Fill Window  or zoom out so that you can see the entire drawing 
sheet.

3. Select CAD> Boxes & Framing> Rectangular Polyline , then click and drag a 
rectangle beginning at one corner of the drawing sheet and ending at the opposite corner.

• Watch for the red snap indicators that will display at each corner when Endpoint snaps 
are enabled. 

4. Select Edit> Preferences , then go to the Behaviors panel of the Preferences dialog. 
5. Select Concentric Edit Type, and specify the Jump value as the distance you would like 

your border to be drawn from the edge of the drawing sheet. In our example, 1/2" is used. 
For more information, see “Behaviors Panel” on page 97 of the Reference Manual.

6. Select the rectangular polyline, then click and slowly drag a corner edit handle towards the 
center of the polyline. When you reach the your specified Concentric Jump distance, the 
polyline will resize so that it’s edges are that distance from the drawing sheet edges. 
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• Make sure that your border is entirely within the printable area. 

7. You can easily create a double border in the same manner. Click the Copy/Paste  edit 
button, then click and slowly drag one of the corner edit handles towards the polyline 
center. A concentric copy of the polyline is made when you reach your Concentric Jump 
distance.

8. When you are finished concentrically resizing and copying your border objects, it is a good 
idea to return to the Behaviors panel of the Preferences dialog and return to the Default 
Edit Type.  

9. You can adjust the line weight, style and color for any CAD object in its specification 
dialog. See “Line Style Tab” on page 944 of the Reference Manual.  

10. To see the final product, you may find it helpful to turn off the display of the Snap and 
Reference Grids. See “Layout Defaults” on page 1072.

To create filleted corners

1. Select one of your rectangular polylines and double-click the Fillet Two Lines  edit 
button 

2. In the Chamfer/Fillet dialog, specify a Fillet Radius value. A value of 1" fillets one inch 
of each intersecting edge.

3. Select one side of the rectangle, click the Fillet Two Lines  edit button and then select 
an adjacent side. The two lines fillet where they meet.

4. Repeat step 3 until all corners are filleted.

Title Block
Create the title block using CAD objects and Text on Layout Page Zero. Include only those 
items that should appear on every layout page. You can create areas for page-specific 
information, which can be filled in later on each page.

A company logo can be added to a layout by importing it as a bitmap into a CAD detail, then 
sending the CAD Detail to the layout.  You can also embed the image in the layout file. For 
more information, see “Importing Pictures” on page 997 of the Reference Manual.

Text Macros
Page numbers can be entered on page zero using text macros that are available with the Text 
tool. The correct page number displays on all pages. A variety of other macros are also 
available including date/time, file name, drawing scale, and others. See “Text Macros” on page 
921. 
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Sending Floor Plan Views to Layout
In order to send any view to layout, first open both the destination layout file and the plan file. 
It is recommended that these two files have the same name and be saved in the same folder in 
your computer. See “Organizing Your Files” on page 44 of the Reference Manual and 
“Managing Layout Links” on page 1087 of the Reference Manual. 

To send a floor plan view to layout

1. Select File> Open Plan  and open a plan such as the Walkout Basement Tutorial plan.

2. Select File> Save As  and save the file using a new name.

3.  Select Window> Fill Window . 

4. Select Tools> Display Settings> Display Options  and turn on or off any layers as 
needed so that only the objects that you want to see in the layout view display.  

5. Click the Active Layer Set Control drop-down arrow and select Plot Plan Set from the 
list. Selecting this layer set turns off the display of layers that aren’t necessary for a site 
plan, such as cabinets, millwork and door and window labels. 

6.  Select File> Print> Page Setup  and make sure that your Drawing Scale is correct in 
the Page Setup dialog. This will be the scale of the view once it is sent to layout. For a 
plot plan, a scale such as 1/8 inch = 1 ft works well.
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7. Select File> Send to Layout  to open the Send to Layout dialog.
• Confirm that the view is being sent to layout using the same Scale as in the Page 

Setup dialog.
• Select Entire Plan/View under Send Options.
• Uncheck Make Copy of Active Layer Set. This means that once sent to layout, the 

view will use the Plot Plan Set and changes made to this layer set will affect the view.
• Under Send Position, we will Send to Layout Page # 2 and leave Show Layout Page 

checked so that when we click OK, the layout window will become active.

The information in the Page Setup dialog is view-specific. When you
open the dialog in floor plan view, its settings only apply to floor plan

views of the current plan.  When you open it in a cross section view or CAD
detail window, its settings apply only  to the current view or detail window.
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8. Click OK to send the view to layout.

9. Once sent to layout, the view can be selected and moved using its edit handles or edit 
buttons, and its edges can be edited like a CAD box. See “Editing Box-Based Objects” on 
page 184 of the Reference Manual. 

10. Select Window> Previous Window  (or press Ctrl + Tab) to return to floor plan view. 
11. Click the Active Layer Set Control drop-down arrow and select Default Set from the list 

of available layer sets. See “Active Layer Set Control” on page 130 of the Reference 
Manual.

Sending Elevation Views to Layout
Cross Section/Elevation , Backclipped Cross Section  and Wall Elevation  views 
can also be sent to layout.

It is important that we switch from the Plot Plan Set so that we don’t
make unwanted changes to our site plan view on the layout page.
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To send an elevation view to layout

1. Select 3D> Create Orthographic View> Cross Section/Elevation , then click and 
drag to create a front elevation view. See “Cross Section/Elevation Views” on page 791 of 
the Reference Manual.

2. In the elevation view, click the CAD Configuration  button to access the CAD toolbar 
(see “Toolbar Configurations” on page 119 of the Reference Manual) and add any 
annotations such as roof heights, pitches, material specifications or other notes. 
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3. You may want to Zoom  in on the house.

4. Select 3D> Save Active Camera  so that the camera and your annotations are retained 
and listed in the Project Browser. See “Saving & Printing 3D Views” on page 807 of the 
Reference Manual.

5. Select 3D> Edit Active Camera , and in the Cross Section/Elevation Camera 
Specification dialog, give the Cross Section view a short descriptive name, such as "Front 
Elevation".
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6. Select File> Print> Page Setup  and specify a Drawing Scale for the elevation view in 
the Page Setup dialog. 1/4 in = 1 ft should work well. Click OK to close the Page Setup 
dialog.

7. Select File> Send to Layout  to open the Send to Layout dialog.
• Confirm that the view is being sent to layout using the same Scaling as in the Page 

Setup dialog.
• Select Current Screen under Send Options.
• In this case, we will leave Make Copy of Active Layer Set unchecked. Once sent to 

layout, the view will use the Section View Set and changes made to this layer set will 
affect the view.

• Under Send Position, we will Send to Layout Page # 3 and leave Show Layout 
Page.

• When Orthogonal Views (including cross section/elevation views) are sent to layout, 
you can specify line weights for surface edge lines and pattern lines. You can also 
leave these boxes unchecked to use the line weight settings assigned to the individual 
objects and patterns in the view. See “Send To Layout Dialog” on page 1076 of the 
Reference Manual.
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8. Click OK.

9. Return to the elevation view, then select File> Close to close the view. The Closing 
Elevation dialog will appear, click OK. If you had made edits to the elevation view, 
clicking OK would update those edits to the layout view. In this case, no changes were 
made, so it doesn’t matter.

10. Return to floor plan view.  A camera symbol now displays, indicating the position of your 
saved elevation camera.

11. Repeat this process for a rear elevation view. The elevation views will need to be selected 
and repositioned on the layout page.
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If you would like to make changes to the lines in the elevation view, select CAD> CAD Detail 

From View  to make a copy of the view in a CAD detail window that is composed of 
editable lines and polylines. Changes made to the model do not affect views sent to CAD. See 
“CAD Details” on page 974 of the Reference Manual.
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Sending Details to Layout
Foundation, roof, cross section and other details are an important feature of professional 
construction documents. The steps used to send details to layout can also be used to place 
schedules, legends, keys and other items on the layout page.  

To send details to layout
1. Return to floor plan view.

2. Select CAD> CAD Detail Management  to open the CAD Detail Management dialog. 
Click the New button, type a short descriptive name for your detail and click OK.

Any Orthographic view can be converted to a CAD Detail. All patterns become lines 
and colors no longer display. Individual lines can be added and edited.
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3. A new CAD Detail window opens. You can create a CAD detail from scratch using the 
CAD tools, or you can place a CAD block from the library.

4. In this example, we will place a blocked drawing from the CAD Blocks library category. 
This block can be exploded and edited as needed. See “CAD Blocks” on page 968 of the 
Reference Manual.

5. Select File> Print> Page Setup  and specify a Drawing Scale for the CAD detail in 
the Page Setup dialog. 2 inches = 1 foot works well in this case.

6. Select File> Send to Layout  to open the Send to Layout dialog.
• Confirm that the view is being sent to layout using the same Scaling as in the Page 

Setup dialog.
• Select Entire Plan/View under Send Options.
• In this case, we will leave Make Copy of Active Layer Set checked and type a short, 

descriptive name for the layer set that the layout view will use, such as "Page 3 Detail 
Set". Once sent to layout, the view will use this layer set, so any changes made to the 
Default Set will not affect it.
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• Under Send Position, we will Send to Layout Page # 3 and leave Show Layout Page 
checked so that when we click OK, the layout window will become active.

7. Some useful notes are available in the Notes & Legends library in the CAD Blocks 
category. Text can also be copied and pasted from other applications. Place your notes in a 
CAD detail and send them to layout, as previously described. 
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Sending Perspective Views to Layout
Perspective views add visual appeal and clarity to your documentation. They are converted to 
bitmap images when sent to layout, which means that they increase your file size considerably. 
As a result, you should send perspective views to layout sparingly.

To send a perspective view to layout
1. Return to floor plan view.

2. Select 3D> Create Perspective View> Full Camera  and create a 3D view.
3. In the camera view, use the Move, Orbit and Tilt Camera tools available in the 3D menu to 

adjust the view to your liking. See “Editing 3D Views” on page 798 of the Reference 
Manual.

4. Click the Restore button at the top right corner of the view window, between the Minimize 
and Close buttons, then adjust the shape of the window so that it includes the information 
that you want and has a height to width ratio similar to the space you want it to fill on the 
layout page.

5. Select 3D> Camera View Options> Final View  to redraw the view at a higher quality 
according to your settings in the Preferences dialog. See “Preview vs Final View” on 
page 815 of the Reference Manual. 
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6. Select File> Send to Layout  to open the Send to Layout dialog. When perspective 
views are sent to layout our options are limited because they cannot be scaled. This is why 
we do not need to access the Page Setup dialog before sending the view to layout. 

7. Send to Layout Page # 1 and leave Show Layout Page checked. 
8. Select and resize the image as needed.
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Printing to PDF
A PDF, or Portable Document Format, file saves all of the printable information associated 
with a document such as a layout and makes it available for both viewing and printing without 
using the software originally used to create it. PDFs are easy to create and provide you with an 
efficient way to share your work with others or send documents to a print service.

In order to create a PDF, you must first have a PDF printer driver installed on your computer. 
Many options are available, including PDF995, which is available for download.  Select Help> 
Download PDF Printer Driver from the program menu or visit www.pdf995.com. 

Creating a PDF is a printing function, and the PDF driver installed on your computer should be 
treated like any other printer. Set up page size and orientation information in its Properties 
dialog and select your PDF writer as your printer in the Page Setup and Print dialogs. For 
more information, see “Printing to a PDF File” on page 1056 of the Reference Manual. 
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Chapter 10:

Roof Tutorial

This tutorial can be completed independent of the previous tutorials. We’ll go over some 
common roof styles that can be created using settings in the Wall Specification dialog. We’ll 
also learn how to add gables over doors and windows, how to create dormers automatically and 
manually, and how to create skylights. For additional information about using the Roof Tools, 
see “Roofs” on page 403 of the Reference Manual. 

In this tutorial you’ll learn about:
•      Auto Rebuild Roofs
•      Getting Started
•      Deleting Roofs
•      Hip Roofs
•      Gable Roofs
•      Shed Roofs
•      Saltbox Roofs
•      Gambrel Roofs
•      Gull Wing Roofs
•      Half Hip Roofs
•      Mansard Roofs
•      Finding the Start of an Upper Pitch
•      Roof Type Quick Reference
•      Roof Returns
•      Adding Gables over Doors and Windows

•      Automatic Dormers
•      Manually Drawn Dormers
•      Skylights
•      Using the Break Wall Tool with Roofs
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Auto Rebuild Roofs 
Auto Rebuild Roofs is a convenient feature in Chief Architect that automatically rebuilds the 
roof in a plan whenever the exterior walls or floor/ceiling heights are changed. Auto Rebuild 
Roofs is turned off by default, and this tutorial is presented with this feature disabled; however 
the information presented here also applies when it is enabled.

To turn on/off Auto Rebuild Roofs

1. Select Build> Roof> Build Roof  from the menu.
2. In the Build Roof dialog, check/uncheck Auto Rebuild Roofs and click OK.

Getting Started
We’ll begin this tutorial with a new plan.

To begin a new plan
1. If any plans are open, select File> Close All from the menu.

2. Select File> New Plan  to open a new plan.

3. Select Build> Wall> Straight Exterior Wall  and draw a rectangular floor plan, 
measuring about 34 feet by 24 feet (approximately 10.4 m by 7.3 m), in a clockwise 
direction. We’ll use this outline to build a number of different roof styles. See “Drawing 
Walls” on page 245.
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Deleting Roofs
Whether a roof was drawn manually or automatically generated, deleting roof planes is easy.

To delete a roof

1. Select Build> Roof> Delete Roof Planes .

• Select Edit> Delete Objects  and in the Delete Objects dialog, select All Rooms On 
This Floor; place a check beside Roof Planes; and click OK.

If a warning message states that roofs cannot be deleted while Auto Rebuild Roof is on, click 
the Yes button to turn off Auto Rebuild Roof and delete the roof. 

Hip Roofs
When roofs are automatically generated, the default roof type is a hip roof, which means that a 
roof plane is built over every exterior wall in the plan that does not have another wall drawn 
above it. 

To create a hip roof

1. Select Build> Roof> Build Roof  from the menu to open the Build Roof dialog. The 
Pitch is set at 6 in 12 inches.
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2. Check Build Roof Planes and click OK to generate a hip roof.

3. Select 3D> Create Perspective View > Full Overview  to create a 3D overview of the 

house. If you wish, you can select 3D> Toggle Textures  from the menu to turn off the 
display of textures.

4. Select Window> Tile Vertically  to see both views at the same time.
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Gable Roofs
If you would like a gable over a particular wall rather than a roof plane bearing on it, you can 
specify it as a Full Gable Wall in the Wall Specification dialog.

To create a gable over a wall, specify it as a Full Gable Wall. To create basic gable roof, two 
walls must be specified as such.

To create a gable roof
1. Click on the floor plan view window to make it the active view.

2. Select Build> Roof> Delete Roof Planes .

3. Click the Select Objects  tool, select the vertical wall on the left, hold down the Shift 
key, and select the vertical wall on the right. The two walls should be group-selected. 

4. Click the Open Object  edit button and on the Roof tab of the Wall Specification 
dialog, check Full Gable Wall and click OK.
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• Alternatively, you can click the Change to Gable Wall(s)  edit button.
• To remove the Full Gable Wall attribute from a wall, you can select it and click the 

Change to Hip Wall(s)  edit button.

5. Select Build> Roof> Build Roof  to open the Build Roof dialog, check Build Roof 
Planes, and click OK.

Shed Roofs
To create a single, sloping roof plane, or shed roof, two walls must be specified as Full Gable 
Walls, and one must be a High Shed/Gable Wall.

To create a shed roof
1. Click on the floor plan view window to make it the active view.

2. Select Build> Roof> Delete Roof Planes .

chief-architect-x3-users-guide.book  Page 206  Monday, August 9, 2010  2:08 PM



Saltbox Roofs

 207

3. With the Select Objects  tool, double-click the lower horizontal wall and in the Roof 
tab of the Wall Specification dialog, check High Shed/Gable Wall and click OK.

4. As in the Gable Roof example, specify the left and right vertical walls as Full Gable 
Walls.

5. Select Build> Roof> Build Roof  to open the Build Roof dialog, check Build Roof 
Planes, and click OK.

Saltbox Roofs
A saltbox is a type of gable roof with different pitches on each of the two roof planes and an 
offset ridge. Assign a different pitch to the two roof planes in the Wall Specification dialog for 
the wall supporting each one.

To create a saltbox roof
1. Click on the floor plan view window to make it the active view.

2. Select Build> Roof> Delete Roof Planes .

3. With the Select Objects  tool, double-click the lower horizontal wall. On the Roof tab 
of the Wall Specification dialog, remove the check from High Shed/Gable Wall and 
change the pitch to 12 in 12. Click OK to close the Wall Specification dialog.

4. Leave the Full Gable Wall box checked for the two vertical walls.

5. Select Build> Roof> Build Roof  to open the Build Roof dialog, check Build Roof 
Planes, specify the pitch as 3 in 12, and click OK.
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Gambrel Roofs
A gambrel or barn style roof has two pitches on each side of the ridge. The first (lower) pitch 
on either side is steeper than the pitch near the ridge.

To create a gambrel roof
1. Click on the floor plan view window to make it the active view.

2. Select Build> Roof> Delete Roof Planes .
3. Group select the horizontal walls and open them for specification. On the Roof tab:

• Specify the lower Pitch as 12 in 12.  
• Place a check in the box beside Upper Pitch.
• Keep the Upper Pitch as 6 in 12 and change the Start Height to 156. The second 

pitch will begin 60 inches above the top plate (top plate = 96 inches, so 96 + 60 =156).
• To learn more, see “Finding the Start of an Upper Pitch” on page 213.

4. Click OK to close the Wall Specification dialog. 
5. The two vertical walls should remain Full Gable Walls.
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6. Open the Build Roof dialog, check Build Roof Planes, specify the Pitch as 6 in 12 once 
again, and click OK.

Experiment with alternate pitches and overhangs. Also, try varying the height at which the 
second pitch begins so that you can see the effect it has on your gambrel roof design.

Gull Wing Roofs
A gull wing roof has two pitches on either side of the ridge, as a gambrel does; but the first 
pitch of a gull wing is shallower than the second.

To create a gull wing roof
1. Click on the floor plan view window to make it the active view.

2. Select Build> Roof> Delete Roof Planes .
3. Change the following settings for each of the horizontal walls on the Roof tab of the Wall 

Specification dialog:

• Specify the lower Pitch as 3 in 12.  
• Place a check in the box beside Upper Pitch.
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• Keep the Upper Pitch as 12 in 12 and change the Start Height to 114". The second 
pitch will begin 18 inches above the top plate (top plate = 96 inches, so 96 +180 
=114).

• To learn more, see “Finding the Start of an Upper Pitch” on page 213.
4. The two vertical walls remain Full Gable Walls.

5. Click the Build Roof  tool, check Build Roof Planes, and click OK in the Build Roof 
dialog.

Experiment with the height at which the second pitch begins so that you can see the effect it has 
on your gull wing roof design.

Half Hip Roofs
A half hip roof has two gable ends. At the top of each gable is a small hip that extends to the 
ridge.

To create a half hip roof
1. Click on the floor plan view window to make it the active view.

2. Select Build> Roof> Delete Roof Planes .

3. With the Select Objects  tool, double-click each wall and make these changes on the 
Roof tab of the Wall Specification dialog:
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For the two Horizontal walls:

• Specify the lower Pitch as 6 in 12. 
• Uncheck the box beside Upper Pitch. 

For the two Vertical walls:

• Leave the Full Gable Wall box checked.
• Check the box beside Upper Pitch.
• Specify the Upper Pitch as 3 in 12 and set the Start Height at 144". 

4. Click the Build Roof  tool, check Build Roof Planes, and click OK in the Build Roof 
dialog.
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Mansard Roofs
A mansard roof is a hip roof with two slopes on the roof sections above each of the four walls. 
The second slope begins at the same height above each wall. The upper slope is usually quite 
gentle and the lower slope, much steeper.

To create a mansard roof
1. Click on the floor plan view window to make it the active view.

2. Select Build> Roof> Delete Roof Planes .
3. Group select all four walls, open them for specification, and on the Roof tab of the Wall 

Specification dialog specify the following settings:

• Clear the Full Gable Wall checkbox.
• Specify the lower Pitch as 24 in 12.  
• Place a check in the box beside Upper Pitch.
• Keep the Upper Pitch as 1.5 in 12 and change the Start Height to 132". 
• To learn more, see “Finding the Start of an Upper Pitch” on page 213.

4. Click the Build Roof  tool, check Build Roof Planes, and click OK in the Build Roof 
dialog.
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Finding the Start of an Upper Pitch 
When creating a roof style with lower and upper pitches, you can determine the exact Starts at 
or In From Baseline values that you need in an elevation view.

To find the start of an upper pitch 
1. Generate the roof using only the first, lower pitch. Be sure to define all the roof 

information for each wall (gable, hip, first pitch, etc.).
2. Create a cross section view that includes the roof plane that will have the second pitch. See 

“Cross Section/Elevation Views” on page 791

3. Select CAD> Points> Place Point , click to place a temporary point near the location 
where you want the second pitch to start, and then either: 

• Using the End-to-End Dimension  tool, drag a dimension line from the floor on 
Floor 1 (which has a height of 0 by default) to the temporary point. 

• Using the End-to-End Dimension  tool, drag a dimension line from the baseline to 
the vertical plane of the temporary point.
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4. Enter either of these values in the Wall Specification dialog. You can press the Tab key to 
update the other value. Click OK to close the dialog. 

5. Open the Build Roof dialog, check Build Roof Planes and click OK to rebuild the roof.
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Roof Type Quick Reference
The following chart provides a quick reference for building the roof styles described in this 
tutorial. The chart shows which walls to change and what to change on the Roof tab of the Wall 
Specification dialog for each wall. These parameters are based on a 34x24-foot model. For 
different size plans, adjust these numbers.

Roof 
Type Wall to Change

Set as 
Full 

Gable

Set as 
High 
Shed 
Gable

Lower 
Pitch

Upper 
Pitch

Start 
Height

Gable
Roof

Vertical Wall 1
Vertical Wall 2
Horizontal Wall 1 X
Horizontal Wall 2 X

Shed
Roof

Vertical Wall 1 X
Vertical Wall 2 X
Horizontal Wall 1 X
Horizontal Wall 2

Saltbox
Roof

Vertical Wall 1 X
Vertical Wall 2 X
Horizontal Wall 1 12 in 12
Horizontal Wall 2 3 in 12

Gambrel
Roof

Vertical Wall 1 X
Vertical Wall 2 X
Horizontal Wall 1 12 in 12 6 in 12 156
Horizontal Wall 2 12 in 12 6 in 12 156

Gull Wing
Roof

Vertical Wall 1 X
Vertical Wall 2 X
Horizontal Wall 1 3 in 12 12 in 12 114
Horizontal Wall 2 3 in 12 12 in 12 114

Half Hip
Roof

Vertical Wall 1 X 3 in 12 144
Vertical Wall 2 X 3 in 12 144
Horizontal Wall 1 6 in 12
Horizontal Wall 2 6 in 12

Mansard
Roof

Vertical Wall 1 12 in 12 1.5 in 12 144
Vertical Wall 2 12 in 12 1.5 in 12 144
Horizontal Wall 1 12 in 12 1.5 in 12 144
Horizontal Wall 2 12 in 12 1.5 in 12 144
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Roof Returns
A roof return is a small decorative roof plane that connects to the low side of a gable roof 
overhang and extends below the upper triangular portion of the gable wall. The following 
pictures show the three styles of roof returns that can be produced in Chief Architect.

The first two are called Gable and Hip returns, since the returns themselves end in either a 
gable or a hip. The third is called a Full return because it extends under the entire gable, 
connecting both sides.

The Roof tab of the Wall Specification dialog contains the settings that generate roof returns. 
Roof returns can be specified for any wall, but only exterior Full Gable Walls can display 
them. 

Specify the horizontal Length of the returns in inches; the distance to Extend the returns past 
the main roof overhang; the style of roof return; and whether the returns are sloping or flat. As 
long as your model has a roof, the specified roof returns will be generated when you click OK. 
For more information, see “Roof Returns” on page 450 of the Reference Manual.

Gable Return Hip Return Full Return
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Adding Gables over Doors and Windows
You can add a gable roof over a door or window.

To create a gable roof over a door or window

1. Select a door or window, then click the Gable Over Door/Window  edit button.

2. Click the Build Roof  tool, check Build Roof Planes, and click OK in the Build Roof 
dialog.

3. A gable is created with an overhang of one foot on each side of the door or window.

To remove a gable roof over a door or window

1. Select the door or window and click the Delete Gable Over Opening  edit button.

2. Click the Build Roof  tool, check Build Roof Planes, and click OK in the Build Roof 
dialog.

3. When you rebuild the roof, the gable will be removed.

To create a gable over several doors and/or windows
1. Select a door, window, or mulled unit.
1. Hold down the Shift key and click on additional doors and/or windows to add them to your 

selection set.

2. Click the Gable Over Door/Window  edit button.

3. Click the Build Roof  tool, check Build Roof Planes, and click OK in the Build Roof 
dialog to create a gable over the selected wall openings.

chief-architect-x3-users-guide.book  Page 217  Monday, August 9, 2010  2:08 PM



218

Chief Architect X3 User’s Guide

Automatic Dormers
The Auto Dormer  and the Auto Floating Dormer  tools offer a quick and convenient 
alternative to drawing dormers manually. With just a few clicks an entire dormer is placed, 
complete with roof, roof hole, walls, and window. 

There is a limit to how low the roof pitch can be set when creating dormers. Generally, 9 in 12 
is the lowest pitch that will provide enough elevation to contain a dormer. 

Auto Floating Dormer

An Auto Floating Dormer  can be placed anywhere within a roof plane, as long as there is 
enough space to contain it. A floating dormer is what some people refer to as a “decorative” 
dormer. It does not require support walls and does not tie in with the structure of the building.

Select Build> Roof> Build Roof> Auto Floating Dormer  and click within an existing 
roof plane to place a floating dormer at that location. Once a dormer is created, it can be 
moved, resized and opened for specification. For more information, see “Editing Auto 
Dormers” on page 446 of the Reference Manual.

Auto Dormer

The Auto Dormer  tool places a standard dormer, which has the same space and structural 
requirements as a manually drawn dormer. If you have not drawn dormers manually, you may 
benefit from learning how. For information, see “Manually Drawn Dormers” on page 219. 

• Dormers can only be placed in roofs that are large and steep enough to contain them. You 
may need to change the pitch and/or size of a roof plane before an automatic dormer can be 
placed. If a warning message stating that some walls are outside the roof plane appears 
when you try to place an automatic dormer, try decreasing the Height value in the Dormer 
Defaults dialog. 

• A knee wall must be present for the dormer to connect to. A knee wall will create attic 
space and offer structural support. A wall must be present, but it does not necessarily have 
to be designated as a Knee Wall in the Wall Specification dialog.

• Dormers cannot be in conflict with the ceiling on the same floor. If you need to create an 
open, attic condition, check Ignore Top Floor in the Build Roof dialog and generate roof 
planes based on the floor below the dormer. If necessary, you can then use Raise Off Plate 

An Auto Floating Dormer cannot initially be placed so that its walls
align with an exterior wall. Once it is created, its front wall can often

be aligned with an exterior wall below; however, its side walls must remain
inside the exterior walls.
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in the Build Roof dialog to move roof planes up. See “Build Roof Dialog” on page 407 of 
the Reference Manual.

Once placed in your model, an automatic dormer can be repositioned and its width adjusted 
using its edit handles. Double-click on an automatic dormer to open the Dormer Specification 
dialog, which looks just like the Dormer Defaults dialog but only affects the selected dormer. 
You can also select the dormer window separately; resize it with its edit handles; and open it for 
specification. For more information about dormers, see “Dormers” on page 444 of the 
Reference Manual.

Manually Drawn Dormers
To create dormers in an upper floor, create a new floor for your plan and modify this floor with 
knee walls and windows to form gables. We’ll start with a new 40 x 30 foot plan to learn this 
technique.

As with automatic dormers, roof pitches of 9 in 12 or greater generally work better than 
shallow pitches when creating dormers because they provide enough vertical space to build the 
dormer within.  

To create a new plan
1. Select File> Close All from the menu to close any open plans.

2. Select File> New Plan  to open a new plan. In the Create New Plan dialog, select the 
Default Style template. 

3. Select Build> Wall> Straight Exterior Wall  and draw a rectangular floor plan, 40 
feet by 30 feet, in a clockwise direction.

4. Click the Fill Window Building Only  button to zoom in on the house.

5. Select File> Save  from the menu and give the plan a name.
6. Group select the right and left vertical walls, open them for specification, and on the Roof 

tab of the Wall Specification dialog, click the Full Gable Wall check box and click OK.

7. Select Build> Floor> Build New Floor .
8. Check the Derive new 2nd floor plan from 1st floor plan option in the New Floor dialog 

and click OK.
9. Group select the right and left vertical walls on the second floor, open them for 

specification, and on the Roof tab of the Wall Specification dialog, click the Full Gable 
Wall check box and click OK.
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10. Select Build> Roof> Build Roof , check Build Roof Planes, change the pitch to 12 in 
12, and click OK in the Build Roof dialog.

To create two knee walls

A knee wall is a short wall on an upper floor that is cut off by a roof plane.

1. Select Build> Wall> Straight Interior Wall  and draw a horizontal interior wall (from 
left to right). Position this knee wall so that it is 5 feet from the top exterior wall.

2. Draw another interior wall (from right to left) and position it 5 feet from the bottom 
exterior wall. You can reposition the knee walls using dimensions. For more information, 
see “Moving Objects Using Dimensions” on page 883 of the Reference Manual.

You can also create a custom wall type for the knee walls, such as a
wall with only a framing layer and one sheetrock layer. See “Wall

Type Definitions Dialog” on page 265 of the Reference Manual.
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3. Group select both interior walls and open them for specification. Check Knee Wall on the 
Roof tab of the Wall Specification dialog and click OK.

4. Select CAD> Dimensions> Automatic Exterior Dimensions  to create exterior 
dimension lines for your plan, which should now look like this:
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To build the dormer walls

1. Select Build> Wall> Straight Exterior Wall  and draw two rectangular boxes on the 
outside of the lower interior wall, as shown in the following image.

2. Position the lower walls of each dormer box 2 feet from the bottom wall. The lower 
dormer walls are those parallel to the bottom wall.
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3. Edit each dormer box so that it is 6 feet from each vertical side wall and 8 feet wide.

4. Select Build> Wall> Break Wall  and click along the lower interior wall to place wall 
breaks as shown in the following image.

5. Delete the upper, horizontal portion of each window box.

Corners after Break Wall is used
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To add a window to each dormer

1. Select Build> Window> Window  and click on each dormer front wall to place a 
window. The program may warn you that you are adding windows to an interior wall; click 
OK to continue.

2. Select the window; click the Center Object  edit button; and click near the wall 
containing the window to center it on the wall. See “Using Center Object” on page 205 of 
the Reference Manual.

3. Do the same for the other window.

To build the roof
1. Group select the two dormer front walls that contain a window, open them for 

specification, and on the Roof tab of the Wall Specification dialog, check Full Gable 
Wall and click OK.

2. Group select the dormer side walls, open them for specification, and on the Roof tab of the 
Wall Specification dialog, specify the Pitch for the dormer roof plane above the wall, and 
click OK. Earlier we specified a pitch of 12 in 12 in the Build Roof dialog, that pitch 
should have prefilled here. A steep pitch of 12 in 12 will work well for these dormers.

3. Double-click the narrow room above the top knee wall to open the Room Specification 
dialog, designate its Room Type as “Attic” and click OK.

4. Do the same for the lower attic room.

5. Select Build> Roof> Build Roof  from the menu. 
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6. In the Build Roof dialog, check Build Roof Planes, and click OK.
7. Create a 3D view to see the results.

8. Notice there are small gaps in the dormer side walls. This gap is caused by the difference 
between the position of the knee walls and the point at which the ceiling intersects the roof 
plane. This location is marked by the dotted line in floor plan view.

9. Select each of the knee walls and move them back so that they are in alignment with the 

ceiling plane. When Object Snaps  are enabled, the walls will snap into position when 
they are close to the ceiling lines.
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10. Take a look in a 3D view.

You can move the interior walls closer to or further from the outside walls to change the 
dormers’ elevation, or change the pitch for the roof to make the dormers longer. You can create 
dormers in more complex plans the same way, but you may want to experiment with wall 
placement and pitch to achieve the desired effect. 

Skylights
Skylights can easily be added using the Skylight  tool. In floor plan view, select Build> 

Roof> Skylight  then click and drag a rectangular shape within an existing roof plane. 
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When you release the mouse button, a skylight is created and can be repositioned and resized 
using its edit handles. For more information, see “Skylights” on page 441 of the Reference 
Manual.

Using the Break Wall Tool with Roofs
Many homes have more than one roof type built above a single exterior wall. One common 
example is a reverse gable roof, created when a house has gable walls that are perpendicular to 
one another, as in an L-shaped home. 

We can create a reverse gable roof on an L-shaped home using the Break Wall  tool.

To create an L-shaped home
1. Select File> Close All from the menu.

2. Select File> New Plan  to open a new plan.
3. Draw an L-shaped house with the following dimensions:

• Left wall - 30 feet long
• Upper wall - 45 feet long.
• Right wall 18 feet long.
• Lower wall extending left from the right wall - 25 feet long.
• Vertical wall connecting two lower walls - 12 feet long.
• Lower wall extending right from the left wall - 20 feet long.
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To create a reverse gable in this plan, we need to create three gable walls: two running 
vertically and one horizontally. 

To add a gable roof to the plan
1. Check Full Gable Wall on the Roof tab of the Wall Specification dialog for these three 

walls:
• The far left vertical wall
• The far right vertical wall
• The bottom left horizontal wall

2. Click the Build Roof  tool to open the Build Roof dialog, check Build Roof Planes, 
and click OK to build the roof. Your plan should look like this:
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Built this way, the gable wall on the left produces roof planes that extend too high and interfere 

with the roof over the lower part of the house. To correct this, use the Break Wall  tool to 
break the left wall into two different sections. We can then specify the upper section as Full 
Gable without affecting the lower section. 

To use the Break Wall tool

1. Select Build> Wall> Break Wall  and click the far left wall at a point even with the 
lower right wall. Extension snaps should help you place the break at the right place. See 
“Extension Snaps” on page 143 of the Reference Manual.

2. Open the lower portion of the wall for specification and on the Roof tab of the Wall 
Specification dialog, clear the Full Gable Wall checkbox and click OK. 
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3. Click the Build Roof  tool, check Build Roof Planes, and click OK to build a roof 
based on the new wall specifications.

You now have two full gable roof sections meeting to form your L-shaped roof. Your plan 
should look like the following image:

Notice the step in the ridge line. This can be corrected by resizing the lower gable wall. Select 
the vertical wall to the right of the bottom gable wall and move it to the left 2 feet, reducing the 
length of the gable wall from 20 to 18 feet. When you are finished, rebuild the roof. 

This completes the Roof Tutorial. You can use any combination of the techniques described 
here to create a wide variety of roof planes.
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Appendix A

End User License
Agreement

Chief Architect, Inc.

End User Software License Agreement for 
Chief Architect® Software

NOTICE TO USER:

PLEASE READ CAREFULLY: THIS IS A CONTRACT. BY INSTALLING, COPYING OR 
USING THIS SOFTWARE, YOU AGREE TO BE BOUND BY ALL THE TERMS AND 
CONDITIONS OF THIS LICENSE AGREEMENT, ON YOUR OWN BEHALF AND ON 
THE BEHALF OF THE ENTITY BY WHOM YOU ARE EMPLOYED OR REPRESENT. IF 
YOU DO NOT AGREE WITH THE TERMS OF THIS AGREEMENT, DO NOT INSTALL, 
USE OR COPY THE SOFTWARE. INSTEAD, RETURN THE SOFTWARE WITHIN THE 
SPECIFIED GUARANTEE PERIOD TO THE PLACE OF PURCHASE FOR A REFUND 
OF YOUR PURCHASE PRICE.

This Chief Architect, Inc. End User License Agreement ("License Agreement", or "EULA") is 
a legal agreement between you (an individual or entity) and Chief Architect, Inc., and sets forth 
the terms and conditions under which you are licensed to use the Software. "Software" means 
(A) all of the contents of the CD-ROM(s), DVD(s), electronic download, online media, or any 
other media which is accompanied by this Agreement, including, but not limited to (i) Chief 
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Architect or third party software, (ii) printed, "online" or electronic explanatory materials 
("Documentation"), (iii) digital images, sample plans, textures, images, symbols, photographs, 
videos or other artistic works ("Graphical Files"), (B) hardware or software security key, if any, 
and (C) modified versions, updates, upgrades, downloadable content, additions and copies of 
the software, if any, licensed to you by Chief Architect, Inc. (collectively, "Updates").

1. GRANT OF LICENSE TO USE SOFTWARE: Chief Architect, Inc. grants you a non-
exclusive, non-transferable (except as provided below) license ("License") to use the Software 
in object code only (and specifically not in source code) subject to the following terms and 
conditions: 

(a)Software: Unless otherwise agreed to in writing,  Chief Architect, Inc. grants you the right to 
use one copy of the  Software on only one computer at one location at any one time;

(b)Storage/Network Use: You may store or install the Software on a network server or other 
storage device only to install and run the Software on an internal network. You must, however, 
purchase and dedicate a separate license of the Software for each computer and each concurrent 
user of the Software installed or accessed from a network server or other storage device.  A 
single license for the Software may not be shared or used concurrently on different computers;

(c)Backup: You may make a backup copy of the Software for archival purposes.  If printed 
Documentation accompanies the Software, it may not be copied.  If the Software is 
accompanied by Documentation in electronic form, you may print out one (1) copy for your 
use which, in turn, may not be copied. A copy of the Software must include all copyright 
notices and this License Agreement;

(d)If you receive one copy of the Software electronically and a second copy on media, the 
second copy may be used for archival purposes only and may not be transferred to or used by 
any other person. This license does not grant you any right to any enhancement or update 
unless otherwise agreed to in writing by Chief Architect, Inc.;

(e)The Student Edition of the Software must be used only by a student for qualified educational 
purposes and only while actively studying at a qualified educational institution. The Student 
Edition of the Software shall not be used for commercial purposes;

(f)The NKBA Exam Version of the Software must be used only by a registered NKBA Exam 
applicant and only for the purpose of preparing for and taking the NKBA Exam. The NKBA 
Exam Version of the Software shall not be used for commercial purposes; 

(g)Educational Licenses are licensed for use by educational institutions for educational 
purposes only. If the Software is licensed as an Educational License and you are not a qualified 
educational institution using the Software for qualified educational purposes, then your 
license(s) of the Software are invalid.

2. OTHER RIGHTS AND RESTRICTIONS: 

(a)Reverse Engineering: You may not modify, translate, reverse engineer, decompile, 
disassemble, or modify the Software in any way or use any other method to convert the 

chief-architect-x3-users-guide.book  Page 232  Monday, August 9, 2010  2:08 PM



 233

Software or any component of the Software into human-readable code, create derivative works 
based upon the Software, Documentation, or Graphical Files or allow anyone else to do so; 

(b)Renting: You may not rent, lease, sub-license, lend, duplicate or distribute the Software, 
Documentation, or Graphical Files without the prior written consent of Chief Architect, Inc., 
which, if given, is subject to the transferee's consent to the terms and conditions of this License 
Agreement; 

(c)Copying: You may not copy or reproduce the Software, Documentation, or Graphical Files 
(except for personal back-up purposes); 

(d)Upgrades: If the Software is being licensed to you as an upgrade, renewal, or update to 
software previously licensed to you, you must cease using the software previously licensed to 
you, including any copies installed on your computer hard-disk drives, once you have 
successfully installed and commenced use of the upgrade, renewal, or update software.  You 
may not transfer or sell the software version previously licensed to you. Any unauthorized 
attempt to transfer or sell the software previously licensed to you will result in automatic 
termination of your current software license. You may, however, maintain a copy of the 
software previously licensed to you for archival purposes only;

(e)The Student Edition has a limited timeout period and cannot be upgraded. However, a 
portion of the purchase price of the Student Edition may be applied toward converting the 
Student Edition into a Professional Edition of the Software;

(f)Proprietary Notices: You may not remove any proprietary notices or labels from the 
Software, Documentation, or Graphical Files; 

(g)Protection: You may not utilize any computer hardware or software designed to defeat any 
hardware or software copy-protection device, should the Software be equipped with such 
protection. You may not disable any licensing or control features of the Software;

(h)Public Access: You may not copy the Software, Graphical Files, or any component of the 
Software onto any public network. You may not, in any manner, make it accessible to others, 
including via internet Web site, telecommunication transmittal, electronic bulletin board, or any 
other form of electronic distribution system;

(i)Distribution: This Software and all components of the Software are licensed for your use 
only. You may not share or distribute the Software to any other party or entity. You may share 
only images, textures, and symbols used by your design with other licensed users of the 
software; however, you may not share or distribute these files or exported versions of these 
files to any other party or entity for use as library content with other software programs. Use of 
Chief Architect Graphical Files as library content within other software programs is a violation 
of this License Agreement.

3. TRANSFERRING YOUR SOFTWARE: You may permanently transfer your license to 
another person or entity only upon written approval by Chief Architect, Inc., and according to 
the following terms and conditions:
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(a)You must fill out and return to Chief Architect, Inc. the Certificate of Transfer of Ownership 
prior to any transfer of the Software. This is available through the Chief Architect, Inc.’s 
Customer Service Department. Call Chief Architect, Inc.'s Customer Service Department prior 
to any transfer in order to receive this document;

(b)The transferor or transferee must pay to Chief Architect, Inc. a license transfer fee for each 
license transferred to complete the process of transfer of ownership;

(c)You may permanently transfer a current, valid and eligible license for the Software, for 
which full price was paid. If you received a discount or rebate on the Software, you must pay to 
Chief Architect, Inc. the difference in price between your discounted price and the full price of 
the Software for each license transferred. You must deliver the Software to the transferee in its 
entirety and must not retain any copy of the Software on any computer or storage media, 
including backup or archival copies;

(d)You may transfer an Additional License and still retain other licenses of the Software only 
by paying to Chief Architect, Inc. the difference in price between the full retail price of the 
Software and the net price paid (including discounts and rebates) for each Additional License 
transferred;

(e)If you own multiple licenses and you wish to transfer a license, the license to be transferred 
shall be the license for which you received the largest discount or rebate;

(f)Your License will automatically terminate upon any transfer of the Software;

(g)If the Software being transferred is an Upgrade, you must cease using all prior versions of 
the Software, Documentation, and Graphical Files as well. You must uninstall all versions of 
the software and you may not use or retain any copy of any prior version of the Software;

(h)You may not transfer any earlier versions of Software which have been upgraded;

(i)You may not transfer a license of the Software that was purchased under the Chief Architect 
National Accounts program;

(j)You may not transfer a Not For Resale (NFR) license of the Software. You also may not 
transfer a Student or Educational license of the Software;

(k)You may not transfer any NKBA Exam Version license of the Software;

(l)The recipient of the transfer shall agree to all the terms of this License Agreement as a 
condition of the transfer.

4. TITLE: Title, ownership, rights, and intellectual property rights in and to the Software, 
Documentation, Graphical Files, and any other accompanying materials shall remain with 
Chief Architect, Inc. or the respective third party.  Title, ownership, rights, and intellectual 
property rights in and to each of the Sample Drawings and any accompanying materials shall 
remain with each Licensor from whom Chief Architect, Inc. licensed each Sample Drawing 
and any accompanying materials.  Unauthorized copying of the Software, Documentation, 
Graphical Files, or Sample Drawings, or failure to comply with the foregoing restrictions, will 
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result in the automatic termination of this License Agreement.  Unauthorized duplication of the 
Software, Documentation, Graphical Files, or Sample Drawings constitutes copyright 
infringement and in the United States is punishable in a federal criminal action by a fine of up 
to $250,000 and imprisonment of up to five (5) years.  In addition, federal civil penalties allow 
the recovery of actual damages based on the number of unauthorized copies produced or 
statutory damages of up to $100,000 for willful copyright infringement. 

5. THIRD PARTY CONTENT: All trademarks and logos belong to their respective owners. All 
Graphical Files and Content, including symbols, images, textures, backdrops, text, and videos 
are the copyright subject matter of Chief Architect, Inc. or third parties. The Graphical Files 
and Content included with the Software are provided for use with the Software only. You shall 
not use the Graphical Files or Content included with the Software for any other purpose outside 
of the Software plan files. You shall not sell or distribute the Graphical Files or Content for any 
purpose whatsoever. You shall not use the Graphical Files or Content with other software.  
Chief Architect, Inc. and third party content, symbols, text, or textures shall not be copied, 
redistributed, or sold separately from the Software. Chief Architect, Inc. and third party product 
content is provided for representational purposes only. Chief Architect, Inc. and third parties 
assume no responsibility for any discrepancies between actual product appearance and that 
represented in the Software, or between actual pricing, characteristics, and specifications, and 
that mentioned anywhere in the Software or Documentation.

6. MONEY-BACK GUARANTEE PERIOD: The Software has a money-back guarantee for 
satisfaction. During the money-back guarantee period (the "Guarantee Period") following your 
first purchase of the Software, you may request to return the Software, Documentation, 
Security Device (if any), and packaging, along with the original purchase receipt, for a refund 
of the purchase price, less any applicable shipping fees, taxes, duties, discounts, and rebates 
paid. This money-back guarantee does not apply to license transfers. You agree to contact 
Chief Architect, Inc. in order to obtain and perform proper return material authorization 
("RMA") steps prior to returning the Software. You also agree to uninstall and deactivate the 
Software and all of its related files and content from your computer prior to returning the 
product.

If, after returning the Software, Documentation, Security Device (if any), and packaging for a 
refund, you repurchase any version of the Software again, you are, by the act of repurchasing 
the Software, acknowledging satisfaction with the Software, and by doing so agree to purchase 
and keep the Software permanently without the option to return it for a refund.

7. GRANT OF LICENSE TO USE SAMPLE DRAWINGS:  Chief Architect, Inc. has licensed 
from third parties (the "Licensors") sample drawings that may be included in the Software.  
These Sample Drawings are provided to you by Chief Architect, Inc. solely for demonstrative 
and illustrative purposes to help you more quickly learn and better understand the functional 
capabilities of the Software, and are licensed to you solely for these limited purposes.  You may 
not reproduce, distribute or use these Sample Drawings for any other purpose without the prior 
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written consent of Chief Architect, Inc. and the Licensor(s) from whom these Sample Drawings 
were licensed by Chief Architect, Inc.. 

8. LIMITED SOFTWARE WARRANTY:  Chief Architect, Inc. warrants that for a period of 
sixty (60) days from the date of your purchase of the Software as evidenced by an original copy 
of your receipt, the media upon which the Software is furnished will be free from defects in 
materials and workmanship under normal use.  EXCEPT FOR THE ABOVE EXPRESS 
LIMITED WARRANTIES, CHIEF ARCHITECT, INC. MAKES NO WARRANTIES AS TO 
THE SOFTWARE, EXPRESS, IMPLIED, STATUTORY, OR IN ANY COMMUNICATION 
WITH YOU.  CHIEF ARCHITECT, INC. SPECIFICALLY DISCLAIMS ANY OTHER 
WARRANTY INCLUDING THE IMPLIED WARRANTY OF MERCHANTABILITY OR 
FITNESS FOR A PARTICULAR PURPOSE WITH REGARD TO THE SOFTWARE, AND 
THE ACCOMPANYING WRITTEN MATERIALS.  CHIEF ARCHITECT, INC. DOES NOT 
WARRANT THAT YOUR USE OF THE SOFTWARE WILL BE UNINTERRUPTED OR 
THAT THE OPERATION OF THE SOFTWARE WILL BE ERROR-FREE.   If this Software 
was purchased in the United States, the above exclusions may not apply to you as some states 
do not allow the exclusion of implied warranties.   In addition to the above warranty rights, you 
may also have other rights, which vary from state to state.

9. CUSTOMER REMEDIES:  The entire liability of Chief Architect, Inc. and your exclusive 
remedy under the warranty provided as to Software set forth above will be, at Chief Architect, 
Inc.'s sole discretion: (i) to replace the media; (ii) to attempt to correct or work around software 
media errors, if any; or (iii) if the above remedies are impracticable to refund the license fee 
you paid, if any, for the Software.  The latter remedy is subject to pre-authorized return of the 
Software, Documentation, Security Device (if any) and packaging to Chief Architect, Inc. or to 
the Authorized Chief Architect, Inc. Dealer or Reseller from whom the Product was obtained 
together with an original copy of your receipt.

Repaired, corrected or replaced software media and documentation shall be covered by this 
limited warranty for the period remaining under the warranty that covered the original Software 
or, if longer, for thirty (30) days after the date Chief Architect, Inc. shipped the repaired or 
replaced software media or documentation to you. Only if you inform Chief Architect, Inc. of 
the problem with the software media or documentation during the applicable warranty period 
and provide evidence of the date you acquired the Software will Chief Architect, Inc. honor this 
warranty. 

10. NO WARRANTY AS TO THE SAMPLE DRAWINGS, SAMPLE PLANS, OR VIDEOS:  
CHIEF ARCHITECT, INC. MAKES NO WARRANTY WHATSOEVER AS TO THE 
SAMPLE DRAWINGS, SAMPLE PLANS, OR TRAINING VIDEOS WHICH ARE 
PROVIDED TO YOU SOLELY FOR DEMONSTRATIVE AND ILLUSTRATIVE 
PURPOSES.  CHIEF ARCHITECT, INC. MAKES NO WARRANTY THAT THE 
DIMENSIONS IN THE SAMPLE DRAWINGS, SAMPLE PLANS, OR VIDEOS ARE 
ACCURATE AND FREE OF DISCREPANCIES.  CHIEF ARCHITECT, INC. MAKES NO 
WARRANTY THAT THE SAMPLE DRAWINGS OR SAMPLE PLANS COMPLY WITH 
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ANY BUILDING CODES.  THE SAMPLE DRAWINGS AND SAMPLE PLANS ARE 
PROVIDED TO YOU "AS IS," AND CHIEF ARCHITECT, INC. AND THE LICENSORS 
OF THE SAMPLE DRAWINGS AND SAMPLE PLANS DISCLAIM ANY AND ALL 
WARRANTIES WITH RESPECT TO THE SAMPLE DRAWINGS AND SAMPLE PLANS, 
WHETHER EXPRESS OR IMPLIED OR ARISING BY CUSTOM OR TRADE USAGE, 
AND, SPECIFICALLY, MAKE NO WARRANTY OF MERCHANTABILITY OR FITNESS 
FOR ANY PARTICULAR PURPOSE.    

11. DISCLAIMER AND LIMITATION OF LIABILITY:  COMPUTER-AIDED DESIGN 
SOFTWARE AND OTHER TECHNICAL SOFTWARE ARE TOOLS INTENDED TO BE 
USED BY TRAINED AND EXPERIENCED INDIVIDUALS ONLY.  THEY ARE NOT 
SUBSTITUTES FOR YOUR TRAINED, EXPERIENCED AND PRACTICAL JUDGMENT.  
COMPUTER-AIDED DESIGN SOFTWARE AND OTHER TECHNICAL SOFTWARE ARE 
INTENDED TO ASSIST WITH ARCHITECTURAL, PREMISES OR PRODUCT DESIGN 
AND ARE NOT SUBSTITUTES FOR INDEPENDENT TESTING OF STRUCTURAL 
INTEGRITY, ENGINEERING, SOUNDNESS, SAFETY, AND UTILITY.  DUE TO THE 
LARGE VARIETY OF POTENTIAL APPLICATIONS FOR THE SOFTWARE, THE 
SOFTWARE HAS NOT BEEN TESTED IN ALL SITUATIONS UNDER WHICH IT MAY 
BE USED.  CHIEF ARCHITECT, INC. SHALL NOT BE LIABLE IN ANY MANNER 
WHATSOEVER FOR THE RESULTS OBTAINED THROUGH THE USE OF THE 
SOFTWARE.  PERSONS USING THE SOFTWARE ARE RESPONSIBLE FOR THE 
SUPERVISION, MANAGEMENT AND CONTROL OF THE SOFTWARE AND THEIR 
EMPLOYEES OR CONTRACTORS WHO USE THE SOFTWARE.  THIS 
RESPONSIBILITY INCLUDES, BUT IS NOT LIMITED TO, THE DETERMINATION OF 
APPROPRIATE USES FOR THE SOFTWARE AND THE SELECTION OF THE 
SOFTWARE AND OTHER PROGRAMS TO ACHIEVE INTENDED RESULTS.  PERSONS 
USING THE SOFTWARE ARE ALSO RESPONSIBLE FOR ESTABLISHING THE 
ADEQUACY OF INDEPENDENT PROCEDURES FOR TESTING THE RELIABILITY 
AND ACCURACY OF ANY PROGRAM OUTPUT, INCLUDING ALL ITEMS DESIGNED 
OR MEASURED BY USING THE SOFTWARE.

UNDER NO CIRCUMSTANCES WILL CHIEF ARCHITECT, INC., ITS DEALERS, 
RESELLERS, DISTRIBUTORS OR THE LICENSORS OF THE SAMPLE DRAWINGS 
AND SAMPLE PLANS BE LIABLE FOR ANY DAMAGES, WHETHER ARISING FROM 
TORT OR CONTRACT, INCLUDING LOSS OF DATA, LOST PROFITS, COST OF 
COVER, OR OTHER SPECIAL, INCIDENTAL, CONSEQUENTIAL OR INDIRECT 
DAMAGES ARISING OUT OF THE USE OR INABILITY TO USE THE SOFTWARE, 
DOCUMENTATION, GRAPHICAL FILES, OR THE SAMPLE DRAWINGS AND SAMPLE 
PLANS. CHIEF ARCHITECT, INC., ITS DEALERS, RESELLERS, DISTRIBUTORS AND 
THE LICENSORS OF THE SAMPLE DRAWINGS AND SAMPLE PLANS ASSUME NO 
LIABILITY OR RESPONSIBILITY FOR, AMONG OTHER THINGS, INADVERTENT 
DISCREPANCIES, CONSTRUCTION INTERPRETATIONS OR CONSTRUCTED 
RESULTS.  THESE LIMITATIONS WILL APPLY EVEN IF CHIEF ARCHITECT, INC., ITS 
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DEALERS, RESELLERS, DISTRIBUTORS OR THE LICENSORS OF THE SAMPLE 
DRAWINGS AND SAMPLE PLANS HAVE BEEN ADVISED OF THE POSSIBILITY OF 
SUCH DAMAGE.  YOU ACKNOWLEDGE THAT THE LICENSE FEE REFLECTS THIS 
ALLOCATION OF RISK.  FURTHER, IN NO EVENT SHALL THE LIABILITY OF CHIEF 
ARCHITECT, INC., ITS DEALERS, RESELLERS, DISTRIBUTORS AND THE 
LICENSORS OF THE SAMPLE DRAWINGS AND SAMPLE PLANS UNDER ANY 
PROVISION OF THIS AGREEMENT EXCEED THE LICENSE FEE PAID TO CHIEF 
ARCHITECT, INC. FOR THE SOFTWARE, DOCUMENTATION, GRAPHICAL FILES, 
AND THE SAMPLE DRAWINGS AND SAMPLE PLANS.  BECAUSE SOME STATES DO 
NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR 
CONSEQUENTIAL OR INCIDENTAL DAMAGES, THE ABOVE LIMITATION MAY 
NOT APPLY TO YOU. 

12. TERMINATION: This license shall terminate automatically if you fail to comply with the 
terms, conditions, and limitations described in this license. No notice shall be required from 
Chief Architect, Inc. to effectuate such termination. Upon termination, you must immediately 
uninstall and deactivate the Software. You must also return or destroy all copies of the Software 
and Documentation.

13. U.S. GOVERNMENT RESTRICTED RIGHTS:  The Software and Documentation are 
provided with RESTRICTED RIGHTS for U.S. Government customers.  Use, duplication or 
disclosure by the Government is subject to restrictions as set forth in subparagraph (c)(1 )(ii) of 
The Rights in Technical Data and Computer Software clause at DFARS 252.227-7013 or 
subparagraphs (c)(i) and (2) of the Commercial Computer Software-Restricted Rights at 48 
CFR 52.227-19 as applicable. The manufacturer is Chief Architect, Inc., 6500 N. Mineral Dr., 
Coeur d'Alene, Idaho  83815. 

14. GOVERNING LAW: This License Agreement shall be governed by the laws of the State of 
Idaho without regard to conflicts of law principles.  This License Agreement shall not be 
governed by the United Nations Convention of Contracts for the International Sale of Goods, 
the application of which is hereby expressly excluded. If either you or Chief Architect, Inc. 
employs attorneys to enforce any right arising out of this Agreement, the prevailing party shall 
be entitled to recover reasonable attorney's fees and costs.

15. ENTIRE AGREEMENT: This agreement constitutes the complete and exclusive agreement 
between you and Chief Architect, Inc. with respect to the subject matter hereof and supersedes 
all prior oral or written understandings, communications or agreements not specifically 
incorporated herein.  This agreement may not be modified except in a writing duly signed by an 
authorized representative of Chief Architect, Inc. and you.  THE ACCEPTANCE OF ANY 
PURCHASE ORDER PLACED BY YOU IS EXPRESSLY MADE CONDITIONAL ON 
YOUR CONSENT TO THE TERMS SET FORTH HEREIN.
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