
Chief Architect X3
Data Management Guide

Thank you for choosing Chief Architect X3 as an instructional tool for your school. Chief Architect is a 
complete residential drafting and 3D modeling program, and can generate a considerable amount of user-
specific and project-specific data. Much of this data is related to library content, which is an important 
aspect of the software’s functionality and contributes significantly to users’ drawings. 

Before installing Chief Architect X3, please take a moment to review this guide so that you can choose the 
deployment options that best suit your network environment. 
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Planning Library Content Deployment

Before installing Chief Architect X3 on workstations, it is a good idea to be familiar with how library catalog 
subscriptions work and to decide where library content will be obtained from. 

Library Subscriptions
Library catalog subscriptions allow users to obtain library content that is easily updatable. They are advantageous 
in an educational setting because if the content of a given catalog needs to be updated, no uninstalling, 
reinstalling, or importing is required. Users simply need access to the location of the published content, and they 
can update their local library database themselves.

Adding a library catalog subscription to the library database involves two steps:

•      First, a catalog must be subscribed to. This process creates an index of the catalog’s contents, adds preview 
images and search information to the database, and records where the content is published. 

•      Next, the actual library content is downloaded from the published location. Once downloaded, library content 
can be used in Chief Architect drawings.

Users with access to the location of the published libraries can actually subscribe to and download them 
themselves; however, bear in mind that this requires sufficient internet or network bandwidth and that depending 
on your download speeds and the amount of data being obtained, it can be time-consuming. Generally, it’s a 
good idea to download at least some content as part of the installation process.

Choosing a Published Location
The first step to planning library content deployment is deciding whether to subscribe to online library catalogs 
available at www.chiefarchitect.com/useraccess/content.html, to publish custom content at an accessible location 
on your organization’s network, or to subscribe to content both online and on the network. 

Subscribing to catalogs online is the most direct method for obtaining Chief Architect X3 library content. 

•      If student user accounts have permission to download from chiefarchitect.com, they can subscribe to content 
themselves, as needed. 

•      To save classroom time and use less internet bandwidth, it is recommended that you subscribe to the SSA 
Content for the specific program version you are installing. SSA Content and instructions are available at 
http://www.chiefarchitect.com/useraccess/bonuscontent.html.

•      Consider subscribing to at least some of the Manufacturer Catalogs, as well.  If possible, consult with the 
instructor to find out which catalogs are needed. 

Publishing catalogs at an accessible network location is very helpful if the instructor would like to create custom 
library catalogs to go with their lessons or if workstations do not have internet access. 

•      A network location must be made available for the published library content. Depending on how much con-
tent the instructor needs to publish, several GB of space should be allocated. 

•      Students should have read access to this location so that they can obtain content as it is made available.
•      Content cannot be simply copied to the network location - it must be published following the steps outlined in 

the Chief Architect X3 Reference Manual. In order to subscribe to content on the network as part of the work-
station installation process, this content must be published first. 
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Downloading Library Content
Once you have decided where library content will be obtained from, you should consider how much content to 
subscribe to, and how much to actually download. There are two issues to consider:

•      The library database and associated files can require a lot of disk space: several GB or more when all 
available content is downloaded. Depending on how you plan to deploy these files, you may want to limit 
how much content is available by restricting student account permissions. See Installing the Library Data-
base File on page 4.

•      Like library subscriptions, downloading library content requires time and internet and/or network band-
width. Consider downloading at least some content as part of the software installation process.

Installing Content from the DVD
An alternative to using updatable library catalog subscriptions is installing the Chief Architect Basic Content 
included on the Chief Architect X3 installation DVD. No internet access is required to obtain this catalog, but it 
is worth noting that compared with the content available online, its selection is quite limited.

If you choose to install the Chief Architect Basic Content from the DVD, note that you can save time by 
copying the library content to the local hard drive first.  Next, launch Chief Architect and select Edit> 
Preferences from the menu. On the Library Browser panel of the Preferences dialog, check “Prompt To 
Download Locally” and click OK. Next, right click on the Chief Architect Basic Content catalog in the Library 
Browser tree list, select Download, and browse to the location where you copied the library content. When you 
are finished, delete the files that you copied from the DVD and return to the Preferences dialog and uncheck 
“Prompt To Download Locally”. 
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Installing the Library Database File

With the information regarding library subscriptions in mind, the next step is to select a location for the library 
database and associated texture, image, and backdrop files. 

About Library Database Files
By default, each individual user has their own library database file, User_Library.calib. This file is located in the 
Chief Architect X3 Data folder, which is created in the Documents directory (My Documents in Windows XP). 
Textures, Images, and Backdrops associated with items in the library are saved in the Data folder, as well. 

Depending on how much library content instructors choose to make available to students, the library database 
and associated files can require a considerable amount of space: several GB or more. In a lab or classroom 
environment where workstations are shared by multiple students, library databases can quickly take up a lot of 
space on a given computer. 

Deployment Options
There are several ways that the library database and associated files can be deployed to address these files’ 
space requirements. Choose the strategy that best suits your network setup.

Map Library Content to a Shared Location
Multiple-seat network licenses allow you the option of locating the library database, as well as all associated 
texture, image, and backdrop files, to a shared location on each workstation. This option allows all users on a 
given computer to use the same library database, and is the recommended method of library deployment 
because it saves both disk space and class time.

Instructors should note that any custom library content that students may create will also be saved in the shared 
database. Students should be encouraged to export and back up their custom content as it could be deleted or 
modified by other users.

To create a shared library database

1. Identify a location on the workstation hard drive where you would like the shared library database file to be 
saved. Create a folder at that location with a short, descriptive name like “Chief Architect Library Data”, and 
make sure all users are granted both read and write access to that folder. 

2. Follow the instructions in the Network License Installation Guide through step 4 of “Installing on 
Workstations” on page 2.

3. When the registration is finished and the program launches, select Edit> Preferences from the program 
menu. 

4. On the Folders panel of the Preferences dialog, click the Browse button next to the My Data Folder field and 
browse to the folder that you created for the shared library database in step 1, then click OK.

5. Subscribe to, download, and/or import all library content that the instructor wants to make available to 
students. See Planning Library Content Deployment on page 2. 

6. Select File> Exit to close the program. 

7. Browse to the Documents folder (My Documents in Windows XP), locate the Chief Architect X3 Data folder, 
and delete it.
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8. Open the Windows Registry Editor and:
• Browse to HKEY_CURRENT_USER\Software\Chief Architect Inc\Chief Architect Premier\13.
• Delete all of the keys in this folder except for the one called “User Settings Folder”.
• Close the Windows Registry Editor.

9. Use your standard deployment process to deploy the Administrator’s user settings to the Default user.

10. Use this state to image the system to the workstations.

Create a New Library Database for Each Session
If a shared location is not an option on your workstations, you can delete each user’s Chief Architect X3 Data 
folder at the end of each session to conserve disk space. When a new session is started, a new Data folder 
including any library content you wish to include can then be created.

Instructors need to be aware that depending on the amount of library content made available, the time 
required to copy it can be considerable: several minutes or more if multiple catalogs have been downloaded, 
during which time Chief Architect cannot be used. Students should be encouraged to export and back up their 
custom content as it will not be retained. 

To create a new user library database for each session

1. Follow the instructions in the Network License Installation Guide through step 4 of “Installing on 
Workstations” on page 2.

2. When the registration is completed and the program launches, subscribe to and download all library 
content that the instructor wants to make available to students. See Planning Library Content Deployment 
on page 2.

3. Select File> Exit to close the program. 

4. Browse to the Documents folder, locate the Chief Architect X3 Data folder and copy the Database 
Libraries, Textures, Images or Backdrops folders.

5. Browse to the Chief Architect X3 installation directory and paste the folders in that directory. Windows will 
ask if you want to replace the existing folders: click Yes To All.

Map User Data to a Network Location
Many organizations map users’ Documents folder to a network location. This can present a number of 
significant problems when running Chief Architect, including slow program performance and the need for large 
amounts of storage space to accomodate the library data for each user. In addition, if the Documents folder is 
not accessible for any reason, users will not be able to launch the software. 

While not recommended, if you choose this option instructors should be aware that users will encounter 
program slowness while drawing, saving their work, and searching and placing library content. To help save 
some time, library content should be downloaded rather than just subscribed to. Students do not need to back 
up their data, however. 

To install the user library database to the Documents folder

1. Map users’ Documents folders to an accessible network location using your standard procedure.

2. Follow the instructions in the Network License Installation Guide through step 5 of “Installing on 
Workstations” on page 2.

3. When the registration is completed and the program launches, subscribe to and download all library 
content that the instructor wants to make available to students. See Planning Library Content Deployment 
on page 2.

4. Select File> Exit to close the program. 
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Backing Up User Data

As with all important data, it is strongly recommended that users back up their work, custom library content, and 
custom program settings. A final consideration when installing Chief Architect X3 is how this can best be 
accomplished. 

Backing Up Users’ Work
Regardless of whether your organization automatically backs up users’ files or whether they are responsible for 
backing up their own work, the best way to ensure that all of the data associated with a .plan or .layout file is 
retained is for them to use the File> Backup Entire Plan command. The resulting folder can then be copied to a 
backup location or removable storage device. 

Backing Up Library Content
Unless your organization has unlimited backup storage space, it will most likely be impractical to back up the 
entire library database for each user. A more feasible approach is to back up each user’s custom library content 
only. To do this, users should use the Export Library command. The resulting .calibz file can then be copied to a 
backup location or removable storage device. 

In the event that users delete data or make other unwanted changes to a library database, they can restore the 
database to its original condition as installed by the Administrator. To make this option available, copy the library 
database and associated files that you subscribe to and download into the program’s installation folder.

To create a backup of the library database

1. Install the software using the deployment option of your choice.

2. In Windows Explorer, copy the Database Libraries, Textures, Images and Backdrops folder in the shared 
folder that you created.

• If you did not choose to create a shared library database, then you will want to copy these same folders 
from the Chief Architect X3 Data folder, located in the Documents directory.

3. Paste them into the program’s installation folder. In a typical installation, this is located at: C:\Program 
Files\Chief Architect in a folder with the same name as the program version.

To restore a database to its original condition, a user should delete the existing database file while the program is 
not running and then launch the program. The backed up files will be copied to the location where they can use it.

Backing Up Custom Program Settings
Custom program settings such as customized toolbar configurations, hotkeys, and template files are saved in the 
Chief Architect X3 Data folder. Users can back up this information by simply copying this folder to a backup 
location or removable storage device. Please note that the Data folder is the default location for the library 
database. If you chose the second deployment option, creating a new library database for each session, users 
should be directed to delete the Database Libraries folder before their Data folder is backed up.


